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Bay Networks, Inc. Software License Agreement
NOTICE: Please carefully read this license agreement before copying or using the accompanying software or 
installing the hardware unit with pre-enabled software (each of which is referred to as “Software” in this Agreement). 
BY COPYING OR USING THE SOFTWARE, YOU ACCEPT ALL OF THE TERMS AND CONDITIONS OF THIS 
LICENSE AGREEMENT. THE TERMS EXPRESSED IN THIS AGREEMENT ARE THE ONLY TERMS UNDER 
WHICH BAY NETWORKS WILL PERMIT YOU TO USE THE SOFTWARE. If you do not accept these terms and 
conditions, return the product, unused and in the original shipping container, within 30 days of purchase to obtain a 
credit for the full purchase price

1. License Grant. Bay Networks, Inc. (“Bay Networks”) grants the end user of the Software (“Licensee”) a personal, 
nonexclusive, nontransferable license: a) to use the Software either on a single computer or, if applicable, on a single 
authorized device identified by host ID, for which it was originally acquired; b) to copy the Software solely for backup 
purposes in support of authorized use of the Software; and c) to use and copy the associated user manual solely in 
support of authorized use of the Software by Licensee. This license applies to the Software only and does not extend 
to Bay Networks Agent software or other Bay Networks software products. Bay Networks Agent software or other 
Bay Networks software products are licensed for use under the terms of the applicable Bay Networks, Inc. Software 
License Agreement that accompanies such software and upon payment by the end user of the applicable license fees 
for such software. 

2. Restrictions on use; reservation of rights. The Software and user manuals are protected under copyright laws. 
Bay Networks and/or its licensors retain all title and ownership in both the Software and user manuals, including any 
revisions made by Bay Networks or its licensors. The copyright notice must be reproduced and included with any 
copy of any portion of the Software or user manuals. Licensee may not modify, translate, decompile, disassemble, use 
for any competitive analysis, reverse engineer, distribute, or create derivative works from the Software or user 
manuals or any copy, in whole or in part. Except as expressly provided in this Agreement, Licensee may not copy or 
transfer the Software or user manuals, in whole or in part. The Software and user manuals embody Bay Networks’ and 
its licensors’ confidential and proprietary intellectual property. Licensee shall not sublicense, assign, or otherwise 
disclose to any third party the Software, or any information about the operation, design, performance, or 
implementation of the Software and user manuals that is confidential to Bay Networks and its licensors; however, 
Licensee may grant permission to its consultants, subcontractors, and agents to use the Software at Licensee’s facility, 
provided they have agreed to use the Software only in accordance with the terms of this license.

3. Limited warranty. Bay Networks warrants each item of Software, as delivered by Bay Networks and properly 
installed and operated on Bay Networks hardware or other equipment it is originally licensed for, to function 
substantially as described in its accompanying user manual during its warranty period, which begins on the date 
Software is first shipped to Licensee. If any item of Software fails to so function during its warranty period, as the sole 
remedy Bay Networks will at its discretion provide a suitable fix, patch, or workaround for the problem that may be 
included in a future Software release. Bay Networks further warrants to Licensee that the media on which the 
Software is provided will be free from defects in materials and workmanship under normal use for a period of 90 days 
from the date Software is first shipped to Licensee. Bay Networks will replace defective media at no charge if it is 
returned to Bay Networks during the warranty period along with proof of the date of shipment. This warranty does not 
apply if the media has been damaged as a result of accident, misuse, or abuse. The Licensee assumes all responsibility 
for selection of the Software to achieve Licensee’s intended results and for the installation, use, and results obtained 
from the Software. Bay Networks does not warrant a) that the functions contained in the software will meet the 
Licensee’s requirements, b) that the Software will operate in the hardware or software combinations that the Licensee 
may select, c) that the operation of the Software will be uninterrupted or error free, or d) that all defects in the 
operation of the Software will be corrected. Bay Networks is not obligated to remedy any Software defect that cannot 
be reproduced with the latest Software release. These warranties do not apply to the Software if it has been (i) altered, 
except by Bay Networks or in accordance with its instructions; (ii) used in conjunction with another vendor’s product, 
resulting in the defect; or (iii) damaged by improper environment, abuse, misuse, accident, or negligence. THE 
FOREGOING WARRANTIES AND LIMITATIONS ARE EXCLUSIVE REMEDIES AND ARE IN LIEU OF ALL 
OTHER WARRANTIES EXPRESS OR IMPLIED, INCLUDING WITHOUT LIMITATION ANY WARRANTY OF 
MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Licensee is responsible for the security of 
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its own data and information and for maintaining adequate procedures apart from the Software to reconstruct lost or 
altered files, data, or programs.

4. Limitation of liability. IN NO EVENT WILL BAY NETWORKS OR ITS LICENSORS BE LIABLE FOR ANY 
COST OF SUBSTITUTE PROCUREMENT; SPECIAL, INDIRECT, INCIDENTAL, OR CONSEQUENTIAL 
DAMAGES; OR ANY DAMAGES RESULTING FROM INACCURATE OR LOST DATA OR LOSS OF USE OR 
PROFITS ARISING OUT OF OR IN CONNECTION WITH THE PERFORMANCE OF THE SOFTWARE, EVEN 
IF BAY NETWORKS HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. IN NO EVENT 
SHALL THE LIABILITY OF BAY NETWORKS RELATING TO THE SOFTWARE OR THIS AGREEMENT 
EXCEED THE PRICE PAID TO BAY NETWORKS FOR THE SOFTWARE LICENSE.

5. Government Licensees. This provision applies to all Software and documentation acquired directly or indirectly 
by or on behalf of the United States Government. The Software and documentation are commercial products, licensed 
on the open market at market prices, and were developed entirely at private expense and without the use of any U.S. 
Government funds. The license to the U.S. Government is granted only with restricted rights, and use, duplication, or 
disclosure by the U.S. Government is subject to the restrictions set forth in subparagraph (c)(1) of the Commercial 
Computer Software––Restricted Rights clause of FAR 52.227-19 and the limitations set out in this license for civilian 
agencies, and subparagraph (c)(1)(ii) of the Rights in Technical Data and Computer Software clause of DFARS 
252.227-7013, for agencies of the Department of Defense or their successors, whichever is applicable.

6. Use of Software in the European Community. This provision applies to all Software acquired for use within the 
European Community. If Licensee uses the Software within a country in the European Community, the Software 
Directive enacted by the Council of European Communities Directive dated 14 May, 1991, will apply to the 
examination of the Software to facilitate interoperability. Licensee agrees to notify Bay Networks of any such 
intended examination of the Software and may procure support and assistance from Bay Networks.

7. Term and termination. This license is effective until terminated; however, all of the restrictions with respect to 
Bay Networks’ copyright in the Software and user manuals will cease being effective at the date of expiration of the 
Bay Networks copyright; those restrictions relating to use and disclosure of Bay Networks’ confidential information 
shall continue in effect. Licensee may terminate this license at any time. The license will automatically terminate if 
Licensee fails to comply with any of the terms and conditions of the license. Upon termination for any reason, 
Licensee will immediately destroy or return to Bay Networks the Software, user manuals, and all copies. Bay 
Networks is not liable to Licensee for damages in any form solely by reason of the termination of this license.

8. Export and Re-export. Licensee agrees not to export, directly or indirectly, the Software or related technical data 
or information without first obtaining any required export licenses or other governmental approvals. Without limiting 
the foregoing, Licensee, on behalf of itself and its subsidiaries and affiliates, agrees that it will not, without first 
obtaining all export licenses and approvals required by the U.S. Government: (i) export, re-export, transfer, or divert 
any such Software or technical data, or any direct product thereof, to any country to which such exports or re-exports 
are restricted or embargoed under United States export control laws and regulations, or to any national or resident of 
such restricted or embargoed countries; or (ii) provide the Software or related technical data or information to any 
military end user or for any military end use, including the design, development, or production of any chemical, 
nuclear, or biological weapons.

9. General. If any provision of this Agreement is held to be invalid or unenforceable by a court of competent 
jurisdiction, the remainder of the provisions of this Agreement shall remain in full force and effect. This Agreement 
will be governed by the laws of the state of California.

Should you have any questions concerning this Agreement, contact Bay Networks, Inc., 4401 Great America Parkway, 
P.O. Box 58185, Santa Clara, California 95054-8185.

LICENSEE ACKNOWLEDGES THAT LICENSEE HAS READ THIS AGREEMENT, UNDERSTANDS IT, AND 
AGREES TO BE BOUND BY ITS TERMS AND CONDITIONS. LICENSEE FURTHER AGREES THAT THIS 
AGREEMENT IS THE ENTIRE AND EXCLUSIVE AGREEMENT BETWEEN BAY NETWORKS AND 
LICENSEE, WHICH SUPERSEDES ALL PRIOR ORAL AND WRITTEN AGREEMENTS AND 
COMMUNICATIONS BETWEEN THE PARTIES PERTAINING TO THE SUBJECT MATTER OF THIS 
AGREEMENT. NO DIFFERENT OR ADDITIONAL TERMS WILL BE ENFORCEABLE AGAINST BAY 
NETWORKS UNLESS BAY NETWORKS GIVES ITS EXPRESS WRITTEN CONSENT, INCLUDING AN 
EXPRESS WAIVER OF THE TERMS OF THIS AGREEMENT.
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About This Guide

If you are responsible for upgrading Bay Networks router software from BayRS 
Version 7-11.xx to Version 12.00, you need to read this guide. 

If you want Go to 

An overview of the router upgrade process and a checklist of router 
upgrade tasks 

page 1-1

Router upgrade prerequisites and initial upgrade preparations page 2-1

Instructions for upgrading Site Manager Version 6.00 and BayRS 
Version 12.00 software

page 3-1

Instructions for transferring customized software image files to the 
router

page 4-1

Instructions for upgrading Boot and Diagnostic PROMs and 
configuration files 

page 4-1

Instructions for booting the router with the customized image and 
upgrading the configuration

page 5-1

Instructions for determining the PROM version on the router page A-1

To review configuration-specific issues affecting router upgrades page B-1

Instructions for upgrading the DCM software image in BayStack 
routers 

page C-1

Instructions for upgrading router software using Quick2Config page D-1

Instructions for upgrading 7-9.xx routers to BayRS Version 12.00 and 
Site Manager Version 6.00

page E-1
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Upgrading Routers from Version 7-11.xx to Version 12.00

                               
Before You Begin

Before using this guide, you must complete the following procedures for a new 
router:

• Ensure that your router is currently running a version of Router Software 
Version 7-11.xx router software. Also, be sure that you are running Bay 
Networks Site Manager Version 1.xx or later.

• Connect the router to the network and create a pilot configuration file (refer to 
Quick-Starting Routers, Configuring BayStack Remote Access, or Connecting 
ASN Routers to a Network).

• Ensure that the router you want to upgrade meets BayRS Version 12.00 
hardware and flash free-space prerequisites. If you need help meeting 
prerequisites, contact the Bay Networks Technical Solutions Center in your 
area.

• Install the router hardware.

For instructions, refer to one of the following guides:

-- Installing and Maintaining BN Routers

-- Installing and Maintaining ASN Routers 

-- Installing and Starting BayStack AN Routers

-- Installing and Starting 8-Port BayStack ANH Systems

-- Installing and Maintaining FN, LN, CN, AFN, and ALN Routers

Conventions

angle brackets (< >) Indicate that you choose the text to enter based on the 
description inside the brackets. Do not type the 
brackets when entering the command. 
Example: if command syntax is ping <ip_address>, 
you enter ping 192.32.10.12

bold text Indicates text that you need to enter, command names, 
and buttons in menu paths.
Example: Enter wfsm &

Example: Use the dinfo command. 
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Example: ATM DXI > Interfaces > PVCs identifies the 
PVCs button in the window that appears when you 
select the Interfaces option from the ATM DXI menu.

brackets ([ ]) Indicate optional elements. You can choose none, one, 
or all of the options.

ellipsis points Horizontal (. . .) and vertical ellipsis points indicate 
omitted information. 

italic text Indicates variable values in command syntax 
descriptions, new terms, file and directory names, and 
book titles.

quotation marks (“ ”) Indicate the title of a chapter or section within a book.

screen text Indicates data that appears on the screen. 
Example: Set Bay Networks Trap Monitor Filters

separator ( > ) Separates menu and option names in instructions and 
internal pin-to-pin wire connections. 
Example: Protocols > AppleTalk identifies the 
AppleTalk option in the Protocols menu. 

Example: Pin 7 > 19 > 20

vertical line (|) Indicates that you enter only one of the parts of the 
command. The vertical line separates choices. Do not 
type the vertical line when entering the command.
Example: If the command syntax is 

show at routes | nets, you enter either 
show at routes or show at nets, but not both.

Acronyms

AFN Access Feeder Node

ALN Access Link Node

BootP Bootstrap Protocol

CPU Central Processing Unit

DCE Data Circuit-terminating Equipment

DCM Data Collection Module

DTE Data Terminal Equipment

...( )
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FTP File Transfer Protocol 

GUI Graphic User Interface

HDLC high-level data link control

HSSI high-speed serial interface

IP Internet Protocol

IPX Internet Packet Exchange

LAN local area network

MAC media access control 

MIB Management Information Base

OSPF Open Shortest Path First

PPP Point-to-Point Protocol

PPX Parallel Packet Express

PROM Programmable Read-Only Memory

RAM random-access memory

RMON Remote Monitor

RIP Routing Information Protocol

SIMM Single In-line Memory Module

SPEX-HS Stack Packet Exchange-Hot-Swaps

TFTP Trivial File Transfer Protocol

Ordering Bay Networks Publications

To purchase additional copies of this document or other Bay Networks 
publications, order by part number from Bay Networks Press™ at the following 
numbers: 

• Phone--U.S./Canada: 888-422-9773

• Phone--International: 510-490-4752

• FAX--U.S./Canada and International: 510-498-2609

The Bay Networks Press catalog is available on the World Wide Web at 
support.baynetworks.com/Library/GenMisc. Bay Networks publications are 
available on the World Wide Web at support.baynetworks.com/Library/tpubs.
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Bay Networks Customer Service

You can purchase a support contract from your Bay Networks distributor or 
authorized reseller, or directly from Bay Networks Services. For information 
about, or to purchase a Bay Networks service contract, either call your local Bay 
Networks field sales office or one of the following numbers:

Information about customer service is also available on the World Wide Web at 
support.baynetworks.com.

How to Get Help

If you purchased a service contract for your Bay Networks product from a 
distributor or authorized reseller, contact the technical support staff for that 
distributor or reseller for assistance.

If you purchased a Bay Networks service program, call one of the following Bay 
Networks Technical Solutions Centers:

Region Telephone number Fax number

United States and 
Canada 

800-2LANWAN; then enter Express 
Routing Code (ERC) 290, when prompted, 
to purchase or renew a service contract

978-916-8880 (direct)

978-916-3514

Europe 33-4-92-96-69-66 33-4-92-96-69-96

Asia/Pacific 61-2-9927-8888 61-2-9927-8899

Latin America 561-988-7661 561-988-7550

Technical Solutions Center Telephone number Fax number

Billerica, MA 800-2LANWAN 978-916-3514

Santa Clara, CA 800-2LANWAN 408-495-1188

Valbonne, France 33-4-92-96-69-68 33-4-92-96-69-98

Sydney, Australia 61-2-9927-8800 61-2-9927-8811

Tokyo, Japan 81-3-5402-0180 81-3-5402-0173
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Chapter 1
Router Upgrade Overview

This chapter describes the router upgrade process and provides a checklist that 
you should carefully review before you begin the router upgrade process. Refer to 
the following topics:

Router Upgrade Process

The process for upgrading routers from Router Software Version 7-11.xx to 
BayRS Version 12.00 consists of four major phases and three optional tasks, 
depending on your router configuration requirements:

1. Preparing to upgrade (see Chapter 2)

2. Starting the upgrade: upgrading to Site Manager Version 6.00 and BayRS 
Version 12.00 (see Chapter 3)

3. Continuing the upgrade: transferring the customized image files and 
associated router files to the router and upgrading PROMs (see Chapter 4)

4. Completing the upgrade: booting the router with the customized image and 
upgrading the configuration (see Chapter 5)

Topic Page

Router Upgrade Process 1-1

Router Upgrade Checklist 1-3
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The optional tasks include:

• Upgrading the DCM software image in BayStack routers (Appendix C)

• Upgrading BayRS routers using Quick2Config (Appendix D)

The router upgrade process applies to the following Bay Networks routers:

• Access Feeder Node (AFN®) (with flash)

• Access Link Node (LN®)

• Access Node (AN®)

• BayStack™ routers (AN, ANH™, and ARN™) 

• Access Node Hub (ANH)

• BayStack Access Node Hub

• BayStack Access Remote Node

• Access Stack Node (ASN™)

• Backbone Concentrator Node (BCN®)

• Backbone Link Node (BLN®)

• Concentrator Node (CN®)

• Feeder Node (FN®)

Note: If you are upgrading an AN, ANH, ASN, or ARN router, you must read 
Configuring BayStack Remote Access or Connecting ASN Routers to a 
Network before you begin the upgrade process. These guides explain the 
special considerations for configuring and booting ANs, ANHs, ARNs, and 
ASNs.
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Router Upgrade Checklist 

Review the following items in this checklist before you begin the router upgrade 
process:

1. Check your hardware requirements, the amount of contiguous free space 
on your flash volume, and the version of your Boot PROM.

See “Router Upgrade Prerequisites” on page 2-5.

2. Identify the version of router software you are currently running. You 
should be running Router Software Version 7-11.xx.

If you plan to run RMON on a BayStack router (AN, ANH, or ARN), you 
must first upgrade the DCM software image version to 1.4.2. For instructions 
on upgrading the DCM software image, see Appendix C.

3. Identify the hardware configuration of the router you want to upgrade 
(router model, link modules, and slot assignments for link modules).

4. Gather the manuals you will need to refer to during the router upgrade 
process (Table 1-1). These manuals provide detailed information about 
many of the concepts and procedures outlined in this manual.

Table 1-1. Reference Books for Upgrading Routers 

To Do This Refer to This Book

Upgrade Site Manager on a PC or UNIX 
workstation.

Quick-Starting Routers

Upgrade router software on a PC or UNIX 
workstation.

Configuring and Managing Routers with Site 
Manager

Customize the router software image. Configuring and Managing Routers with Site 
Manager

Back up the router software image and 
configuration files

Configuring and Managing Routers with Site 
Manager

Transfer your customized image and 
router files to the router.

Configuring and Managing Routers with Site 
Manager

Upgrade Boot or Diagnostic PROMs in a 
router.

Using Technician Interface Software

Boot the router with a customized image. Configuring and Managing Routers with Site 
Manager

Upgrade configuration files on the router. Configuring and Managing Routers with Site 
Manager
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5. Review the configuration-specific issues that affect router upgrades to 
determine whether they apply to your situation.

Appendix B describes configuration-specific issues affecting router upgrades. 
If you are upgrading routers in an environment that includes any of the 
situations shown in Table 1-2, follow the instructions on the pages indicated.

Table 1-2. Configuration-Specific Situations Affecting Router Upgrades

Configuration-Specific Situation Page

Routers passing X.25 certification B-2

Standard point-to-point connections over synchronous lines B-3

Switched Services enhancements and compatibility B-4

PPP multiline migration B-6
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Chapter 2
Preparing to Upgrade

This chapter describes Site Manager and router prerequisites that you must meet 
before starting the router upgrade process. See the following topics:

Site Manager Upgrade Prerequisites

Before you upgrade to Site Manager Version 6.00, be sure to review Site Manager 
system requirements; update TCP/IP, network adapters, and drivers on the PC; 
and test the TCP/IP network connection.

Reviewing Site Manager System Requirements

Site Manager is a graphical user interface for router configuration and 
management over an IP network. To run Site Manager Version 6.00, your PC, 
IBM workstation, SPARCstation, or HP 9000 must meet the hardware and 
software requirements listed in Table 2-1.

Topic Page

Site Manager Upgrade Prerequisites 2-1

Upgrading Version 7-9.xx Routers 2-5

Router Upgrade Prerequisites 2-5
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Table 2-1. Site Manager System Requirements 

Platform Hardware and Software Requirements

PC • 486 PC (Pentium recommended)
• Microsoft Windows 95
• 16 MB of RAM (minimum)
• 60 MB of free disk space 
• Microsoft Windows TCP/IP protocol and compatible network 

adapters and drivers
• CD-ROM drive 
• VGA monitor (SuperVGA monitor recommended)

IBM workstation • Supported workstations:
-- RS/6000 340, 370
-- PowerPC

• Supported operating system is IBM AIX Version 4.2
• Window environment:

-- CDE 1.0.1
-- AIX Motif 1.2

• 32 MB of RAM (64 MB recommended)
• 80 MB of disk space
• 32 MB of swap space (64 MB recommended -- use 96 MB of 

swap space with the NetView for AIX application)
• Network adapter appropriate for your network
• CD-ROM drive

(continued)
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Updating TCP/IP, Network Adapters, and Drivers

Site Manager Version 6.00 for Windows 95 requires the Microsoft TCP/IP 
protocol stack provided with Windows 95 and a compatible network adapter and 
driver. 

If you purchased a machine with Windows 95 and a network adapter installed, 
most likely you have the correct TCP/IP protocol stack, network adapter, and 
driver.

If you need to upgrade from Windows 3.1 to Windows 95, first uninstall any 
existing 16-bit TCP/IP stack, such as Distinct TCP/IP Run Time. Otherwise, 
Windows 95 will install that stack instead of the Microsoft TCP/IP protocol stack.

SPARCstation • Supported workstations
-- SPARCstation 10, 20
-- UltraSPARCstation

• Supported operating systems:
-- SunOS 4.1.4
-- Solaris 2.5 and 2.5.1

• Window environment for Solaris: 
-- CDE 1.0.1
-- OpenWindows 3.5

• 32 MB of RAM (64 MB recommended) 
• 32 MB of swap space
• 85 MB of disk space
• Network adapter appropriate for your network
• CD-ROM drive

HP 9000 • Supported workstations include HP 9000 Series 700 or 800
• Supported operating system is the HP-UX 10.20, including 

the complete network services directory
• Window environment includes CDE 1.0.1
• 32 MB of RAM 
• 95 MB of free disk space 
• 32 MB of swap space (64 MB recommended)
• Network adapter appropriate for your network
• CD-ROM drive

Table 2-1. Site Manager System Requirements (continued)

Platform Hardware and Software Requirements
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If you already upgraded from Windows 3.1 to Windows 95 and the upgrade kept 
an existing 16-bit TCP/IP stack, such as Distinct TCP/IP Run Time, you must 
uninstall the 16-bit TCP/IP stack before adding the Microsoft TCP/IP protocol 
stack. 

To uninstall a 16-bit TCP/IP stack, refer to the TCP/IP provider’s documentation 
and support for help in removing the stack’s path statements, services file, and 
WINSOCK.DLL files dated prior to 7/11/95 (the date of the WINSOCK.DLL file 
installed by Windows 95).

To add or update a protocol, network adapter, or driver, refer to the appropriate 
documentation and support from Microsoft and the adapter manufacturer. 
Protocols and driver updates are added from the Network option of the Control 
Panel. New network adapters and their drivers are added from the Add New 
Hardware option of the Control Panel.

Windows 95 attempts to match a driver to the network adapter installed on your 
PC. If Windows 95 cannot match a compatible driver, you need to update the 
drivers. Contact the adapter manufacturer for the latest drivers. Microsoft and 
other Windows 95 Web sites may also have updated drivers. 

See the Microsoft Windows 95 Resource Kit for additional technical information 
about these issues. A hard copy is available from Microsoft Press.

Testing TCP/IP 

From your Site Manager workstation, send a ping request to the router before 
installing Site Manager to make sure your computer’s TCP/IP function is running:

1. From the Start menu, choose Programs > MS-DOS Prompt.

2. Enter the following command to ping your router:

ping <ip_address>

<ip_address> is the IP address of your router.

Messages appear at the prompt indicating whether replies were received. 
Replies verify that your Microsoft TCP/IP protocol stack is functional. 
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Upgrading Version 7-9.xx Routers

If you have a Version 7-9.xx router and you want to upgrade to BayRS Version 
12.00 and Site Manager Version 6.00, you must complete the upgrade procedure 
twice. First, you must upgrade to Router Software Version 10.0 and Site Manager 
software Version 4.0. Then you must upgrade from Router Software Version 10.0 
and Site Manager Version 4.0 to BayRS Version 12.00 and Site Manager 6.00.

For detailed instructions about upgrading Version 7-9.xx routers, see Appendix E.

Router Upgrade Prerequisites

Do not begin the router upgrade process until you verify that the router you want 
to upgrade meets the prerequisites described in this chapter.

Verifying Minimum Hardware and Configuration Requirements

Before you upgrade to BayRS Version 12.00, perform the following steps to 
ensure that your router meets all minimum hardware configuration and revision 
level requirements:

1. Check the flash memory requirements for the router you are upgrading.

Ensure that you have adequate flash memory to accommodate the Version 
12.00 router software. For instructions on how to check flash memory, refer to 
“Verifying Contiguous Free Space on a Flash Volume.”

2. Complete any planned (optional) upgrade from 2 MB flash to 
4 MB or 8 MB flash support on your router. 

This procedure may include a Boot PROM upgrade for the processor module 
in which your flash card resides. For example, if you have a VME-based 
router, you upgrade your flash card on a System Controller 2 (SYSCON-II) 
card. If you have a BN router, you upgrade your flash card in each of your 
FRE® or FRE-2 processor modules.

Note: If you need help meeting the hardware prerequisites of the Version 
12.00 router software upgrade procedure, contact the Bay Networks Technical 
Solutions Center in your area.
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BayRS Version 12.00 supports 8 MB flash capacity on BN and ASN routers. 
Before you upgrade your 8 MB flash card to Version 12.00, make sure that 
you upgrade your Boot PROM to Version 8.00 or later. 

3. Determine whether any other new router hardware depends on software 
or PROM upgrades to work properly. 

4. Complete any planned physical installations of the following router 
hardware:

• Spare FRE/FRE-2 controllers in your Version 7-11.xx BLN, BLN-2, or 
BCN router

• Additional/spare ASNs on your Version 8.xx, 9.xx, 10.0, or 11.xx ASN 
router

• New link modules in the router

Verifying Contiguous Free Space on a Flash Volume

You must determine the amount of contiguous free space required on a flash card 
to accommodate your customized Version 12.00 router software image and 
configuration files. The amount of contiguous free space available on the target 
flash volume must be greater than the combined size of your customized Version 
12.00 image and associated files (such as config, ti.cfg, install.bat, and, if 
appropriate, a Version 12.00 PROM image).

To obtain the amount of contiguous free space available on a selected volume, see 
the fields at the bottom of the Router Files Manager window in Site Manager 
(Table 2-2).

Table 2-2. Determining Contiguous Free Space on a Flash Card

Field Meaning

Total SIze Total number of bytes (used and unused) on the volume.

Available Free Space Number of unused bytes on the volume. 

Contiguous Free Space Number of unused bytes in the largest block available on the 
volume. This space is actual usable memory.
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Satisfying Initial Startup Requirements

Before you begin the router upgrade procedure:

• Identify the router software version you are currently running. You should be 
running Router Software Version 7-11.xx.

Also, if you plan to run RMON on a Version 12.00 BayStack router, you must 
first upgrade the DCM software image to Version 1.4.1; earlier versions do not 
work with BayRS Version 12.00. 

• Identify the hardware configuration of the router you want to upgrade (router 
model, link modules, and slot assignments for link modules).

• Consider your memory requirements carefully. Depending on the number of 
protocols installed on your router, you may require additional memory to run 
these protocols.

If you have questions regarding memory requirements, contact the Bay 
Networks Technical Solutions Center in your area.

• Obtain a working knowledge of both the operating system and the windowing 
software on the UNIX workstation or PC you will use to run Site Manager 
software.

• Obtain a 4 MB or 8 MB flash card (depending on your router type) on which 
to store the Version 12.00 router software image and associated files. A 2 MB 
flash card will not accommodate the BayRS Version 12.00 files. 

• Consider minimum hardware revisions (for example, a link module with 
hot-swap capability may require a hardware revision for
Version 12.00). 

• Read these Bay Networks publications:

-- Release Notes for BayRS Version 12.00

-- Release Notes for Site Manager Software Version 6.00

-- Known Anomalies: Router Software 12.00 and Site Manager 6.00
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Inspecting the Upgrade Kit

Check your upgrade kit to ensure that it contains the BayRS Version 12.00 and 
Site Manager Version 6.00 upgrade components listed in Table 2-3. 

The upgrade kit also includes a CD that contains both the BayRS Version 12.00 
on-line documentation library and the printed versions of the following BayRS 
Version 12.00 manuals:

• Router upgrade document (Version 7-11.xx to Version 12.00)

• Site Manager Release Notes

• Router Software Release Notes

• Known Anomalies 

Table 2-3. BayRS and Site Manager Software Upgrade Components 

Component
Software Storage Media and 
Printed Media

Management 
Platform

BayRS Version 12.00 includes:

• Platform-specific Router Software image files 
• Platform-specific Boot and Diagnostic image 

files
• config file
• debug.al file
• install.bat file
• bcc_help file (AN or BN routers only)
• ti.cfg file
• ti_asn.cfg file (for ASN router only)
• ti_arn file (for ARN router only)
• inst_arn.bat (ARN router install procedure)

Site Manager Version 6.00 includes
Technician Interface Scripts.

CD-ROM in High Sierra file 
format

UNIX workstation or
Windows/DOS PC
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Reviewing Configuration-Specific Issues Affecting Router Software 
Upgrades

Depending on the current configuration of your Version 7-11.xx router, you may 
need to consider certain issues before you begin the upgrade process. If you are 
upgrading routers in an environment that includes any of the following 
configuration-specific situations, see Appendix B for detailed information:

• X.25 certification requirements

• Bay Networks Standard Point-to-Point (PPP) connection guidelines

• Switched Services enhancements and compatibility issues 

• PPP multiline migration issues 

If none of these situations applies to the router you are upgrading, go to Chapter 3 
to begin the router upgrade process.

Using the BCC Help File

The BCC includes a new file called bcc.help in the router upgrade media for 
BayRS Version 12.00. The file ships on the same flash card as the router boot 
image, as well as in the rel directory of the upgrade CD. The file is included in all 
AN and BN router software suites.

To use BCC online Help, you must transfer the bcc.help file onto the router’s flash 
card. For instructions about transferring files to the router’s flash card, see
“Task 2: Transferring a Customized Image and Router Files to the Router” on 
page 4-5.

The file is called bcc.help by default. You can specify a new path name for this 
Help file, and then save this change to your existing configuration file as follows:

$ bcc
bcc> config

    box# help-file-name <slot_number>:<file_name.help>]
box# save config <config_filename>

<slot_number> is the slot number on which you want to store the Help file.

<file_name.help> is the Help file name (for example, bcc.help).

<config_filename> is the router configuration file name.
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Backing Up Your Files

Store backup copies of the configuration files on the Site Manager workstation. To 
prevent confusion, use a log to record the location, name, and purpose of each 
configuration file you back up. Organizing and naming the backup files on the Site 
Manager workstation will also help you prevent mix-ups.

Modifying Configuration Files

A configuration file contains the user-defined configuration for a router and its 
interfaces. After you have a working configuration file, you can use that file to 
boot the router. 

Bay Networks recommends that you always have a config file that you know 
works and that you test any new or modified configuration file under a unique 
name, for example, test.cfg. In this way, if the router has a problem starting, you 
can reset it and it will restart with the default file, config (see Configuring and 
Managing Routers with Site Manager for instructions about resetting the router).

Before you modify a configuration file, make sure that the router’s destination 
volume has enough space available for the file. If there is not enough space, you 
will have to copy the original files to another system and delete them from the 
router (See Configuring and Managing Routers with Site Manager for 
instructions). 

Compacting a Flash Memory Card

You should compact a flash memory card to free up space taken by deleted files. 
This ensures that the flash card has enough contiguous free space to accommodate 
the new Version 12.00 software image.

Caution: Always back up a file before deleting it. This includes configuration 
and log files. And always back up the current log file on the Site Manager 
workstation before clearing it; you may want to refer to it later to troubleshoot 
a problem.
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Compact your flash card during “off-peak” hours if possible, because of the heavy 
resources required (FRE memory and CPU cycles). Do not remove a flash card, 
hot-swap a slot, or reset a slot during flash card compaction, as the card will 
become corrupted, causing loss of data.

Compacting a Flash Memory Card Using Site Manager

Use the Router Files Manager Compact option to copy the active files from the 
flash memory card to the router’s memory, erase the flash memory card, and copy 
the files back to the memory card.

To compact the flash memory: 

1. In the main Site Manager window, choose Tools > Router Files Manager.

The Router Files Manager window opens. 

2. Select the volume that contains the flash memory media you want to 
compact.

3. Choose Commands > Compact.

A confirmation window appears.

4. Click on OK to begin compacting.

Compacting a Flash Memory Card Using the Technician Interface

To compact a flash memory card from the Technician Interface, enter the 
compact <volume>: command. For example, to compact the files in volume 2, 
enter:

compact 2: 

The file system copies all of the files to memory except for the deleted ones, 
erases the memory card, and copies the files back to the memory card.

Note: A flash compaction operation may take up to 12 minutes on an AN 
router. Do not turn the AN router on and off during compaction or you will 
corrupt the flash card and the AN router will not boot.
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Viewing the Status of the Flash Memory Card

To view the status of a memory card, display its directory. The directory displays 
the amount of “available free space” or “free space,” and the amount of 
“contiguous free space.”

The “available free space” or “free space” is the total number of bytes of unused 
space plus bytes of space used by files that are deleted.

In order for the memory card to accommodate a file, the file’s size must be less 
than or equal to the “contiguous free space.” The “contiguous free space” is the 
number of bytes of contiguous unused space.

If the file you want to store is less than the “available free space,” but more than 
the “contiguous free space,” compact the existing files first. When you finish 
compacting files on a memory card, the “contiguous free space” matches the 
“available free space.” 

Verifying Router Software Image Names on the Router

Make sure that the software image on the router is compatible with the type of 
router you are using. A router software image is a group of executable files that 
contains the operating system and protocols on your network for a Bay Networks 
router. The type of software image a router uses depends on the type of router. 

Table 2-4 lists router software images by router type. 

Table 2-4. Router Software Image Types 

Router
Software Image File 
Name 

Device That Image 
Runs On

AN an.exe Flash single inline 
memory modules 
(SIMMs)

BayStack AN, ANH, ARN an.exe, arn.exe Flash single inline 
memory module 
(SIMM)

AFN (flash) afn.exe Flash card

ANH an.exe Flash card

ARE bn.exe Flash card

(continued)
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The image contains all executable files for the current router software. Most 
executable files have an extension of .exe. The exceptions are protocol files on the 
CN, FN, and LN routers, which use the extension .out, and the ATM Routing 
Engine (ARE) slots, which use the extension .ppc. The .ppc files are equivalent to 
.exe files. For example, instead of using ip.exe on an ARE slot, the router uses 
ip.ppc.

ASN asn.exe Flash card

BCN bn.exe Flash card

BLN bn.exe Flash card

CN, FN, LN (VME) ace.out Flash card

IN in.exe Flash card

5380, 5580, 5780 s5000.exe Flash card

5780 ARE s5000.exe Flash card

Table 2-4. Router Software Image Types (continued)

Router
Software Image File 
Name 

Device That Image 
Runs On
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Verifying the Current PROM Version

You can use Site Manager or the Technician Interface to determine the current 
version of Boot and Diagnostic PROM images currently running in your router. 

Table 2-5 lists the Version 12.00 Boot and Diagnostic PROM file names and 
associated revision numbers for the various router platforms. 

See Appendix A for instructions on how to verify the current PROM version on 
your router. See “Task 3: Upgrading and Verifying PROMs on the Router” on 
page 4-10 for instructions on how to upgrade boot and diagnostic PROMs.

Table 2-5. Version 12.00 Boot and Diagnostic PROM Revisions

Router
Platform

Diagnostic PROM
File name 

Diagnostic PROM
Revision
Number

Boot PROM
File name

Boot PROM 
Revision
Number

AN andiag.exe v7.28 anboot.exe rel/9.00

AN200 andiag.exe v1.00 an200boot.exe rel/11.01

ARE arediag.ppc v1.12 areboot.ppc rel/11.02

BN frediag.exe v4.12 freboot.exe rel/8.10

ASN asndiag.exe v2.24 asnboot.exe rel/10.00 

ARN arndiag.exe
arn_pdbrom.rom

v1.30 
v1.06

arnboot.exe
Not applicable

v1.17
Not applicable

LN/CN No Diagnostic PROM shipped vmeboot.exe rel/8.11

AFN v3.04 combination boot and diagnostic 
PROM

Not applicable Not applicable

S5000 s5000diag.exe v0.04 s5000boot.exe 11.00
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Chapter 3
Upgrading Site Manager and Router Software

This chapter describes how to upgrade to Site Manager Version 6.00 and BayRS 
Version 12.00. It also describes how to customize the router software image and 
back up a router software image and configuration files. See the following topics:

Topic Page

Task 1: Upgrading to Site Manager Version 6.00 3-2

Task 2: Upgrading to BayRS Version 12.00 3-6

Task 3: Customizing the Router Software Image 3-10

Task 4: Backing Up the Router Software Image and Configuration Files 3-14
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Task 1: Upgrading to Site Manager Version 6.00

This section describes how to upgrade Site Manager Version 6.00 on your PC or 
UNIX workstation. 

Upgrading Site Manager on a PC

To upgrade Site Manager on your PC:

1. Check Site Manager system requirements and prerequisites.

Ensure that your PC complies with the Site Manager Version 6.00 system 
requirements and prerequisites listed in Table 2-1 on page 2.

2. Delete the existing Site Manager state files.

Site Manager creates state files for all Site Manager tools you use. State files 
describe the state of the application when you last exited it. You must delete 
these files before you install the new version of Site Manager on your PC or 
Site Manager may not function properly when you restart it.

To delete the existing Site Manager state files, enter the following command: 

del   c:\wf\*.sts

c is the name of the hard drive.

3. Load the Site Manager software.

Site Manager software is distributed on CDs. Refer to the appropriate section 
in Quick-Starting Routers for instructions about loading Site Manager Version 
6.00 from a CD onto a PC.

4. Start Site Manager Using Windows 95®.

To start Site Manager using Windows 95:

a. From the Windows 95 desktop, click on the Start button.

Note: You can use Quick2Config instead of Site Manager 6.00 to configure 
AN, ANH, and ASN routers to support BayRS Version 12.00. For instructions 
on how to upgrade an AN, ANH, or ASN to BayRS Version 12.00 using 
Quick2Config, see Appendix D.
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b. From the Start menu, choose Programs > Site Manager > 
PC_Site Manager.

The main Site Manager window opens (Figure 3-1), then the Router 
Connection Options window opens, allowing you to connect to the router. For 
instructions on how to connect to the router, see Configuring and Managing 
Routers with Site Manager.

Figure 3-1. Site Manager Window

After you finish upgrading Site Manager software on your PC, go to
“Task 2: Upgrading to BayRS Version 12.00” on page 3-6.

If you are having problems upgrading Site Manager, see Troubleshooting 
Routers.
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Upgrading Site Manager on a UNIX Workstation

To upgrade the Site Manager software on a Sun SPARCstation (running SunOS or 
Solaris OS), an IBM workstation, or an HP 9000 UNIX workstation:

1. Check system requirements and prerequisites.

Ensure that your UNIX workstation complies with the Site Manager 
Version 6.00 system requirements and prerequisites listed in Table 2-1 on 
page 2-2.

2. Get superuser privileges.

Enter the following command at the UNIX prompt:

su

3. Delete the existing Site Manager state files.

Site Manager creates state files for all Site Manager tools you use. State files 
describe the state of the application when you last exited it. You must delete 
these files before you install the new version of Site Manager on your UNIX 
workstation or Site Manager may not function properly when you restart it.

To delete the Site Manager state files, enter the following command from the 
home directory of every user account:

rm <home_directory>/.wf*

4. Install the Site Manager software.

Refer to the appropriate section in Quick-Starting Routers to install the 
Version 6.00 Site Manager software on a UNIX workstation.

Note: Exit from the current version of Site Manager before you delete any Site 
Manager files. Otherwise, the new version of Site Manager will not overwrite 
all of the current version files.

If You Are Using See This Section in Quick-Starting Routers

Sun SPARCstation running SunOS or 
Solaris

Installing Site Manager on a SPARCstation

IBM RS/6000 or PowerPC Installing Site Manager on an IBM Workstation

HP 9000 Installing Site Manager on an HP 9000
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5. Start Site Manager on a UNIX workstation.

Start Site Manager from a directory where you have read/write permission, 
because this directory becomes the working directory for Site Manager 
operations. Do not start Site Manager from the /usr/wf directory.

To start Site Manager on a UNIX workstation:

a. With a user account that has been set up for Site Manager, log on to a 
UNIX workstation. 

Be sure that the user account has the correct environment variables set 
and that the workstation meets the system requirements for Site Manager 
(see Quick-Starting Routers for more information).

b. Start the window environment.

Refer to the documentation for your UNIX workstation for instructions.

c. Go to the directory where you want to store router configuration files.

d. Enter the following command:

wfsm &

Site Manager starts and the Router Connection Options window opens, 
allowing you to connect to the router. For instructions on how to connect 
to the router, see Configuring and Managing Routers with Site Manager.

You can also start Site Manager from the UNIX command line, but this 
method is only recommended for users experienced with Site Manager. 
For instructions, see Configuring and Managing Routers with Site 
Manager.

After you finish upgrading Site Manager on your UNIX workstation, go to
“Task 2: Upgrading to BayRS Version 12.00” on page 3-6.
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Task 2: Upgrading to BayRS Version 12.00

This section describes how to upgrade to BayRS Version 12.00 on a PC or UNIX 
workstation.

Bay Networks router software is available on CD only. Table 3-1 shows the files 
that make up the Version 12.00 router software.

The steps that you follow to load the router software from CD depend on whether 
you use a PC or a UNIX workstation. The following sections describe how to load 
the router software from CD onto your PC or UNIX workstation.

Table 3-1. Router Software Files

File Name Description

config Default configuration file. 

The router references this binary file for 
configuration data when booting. The file must be 
named config for the router to boot with it 
automatically. We recommend that you back up the 
config file under a unique name before overwriting 
it.

bcc.help Help file for the Bay Command Console (BCC™)

debug.al ASCII file containing aliases 

install.bat Quick-Start installation script file

ti.cfg Initial configuration file

ti_asn.config Configuration file for ASN routers only

ti_arn.cfg Configuration file for ARN routers only

Platform-specific router 
software image files

Bootable router software image files 
(an.exe,afn.exe, arn.exe, asn.exe, bn.exe, 
s5000.exe)

Platform-specific boot and 
diagnostic image files

Diagnostic image files (frediag.exe, andiag.exe, 
an200diag.exe, arediag.ppc, asndiag.exe, 
arediag.exe, bndiag.exe, arndiag.exe, 
s5000diag.exe) 

Boot image files (anboot.exe, arnboot.exe, 
areboot.ppc. an200boot.exe, asnboot.exe, 
freboot.exe, s5000boot.exe, vmeboot.exe)
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Loading the Router Software onto a PC

To load the router software from CD onto a PC:

1. Insert the CD into the CD-ROM drive.

2. Bring up Windows.

3. Choose Start > Programs > Windows Explorer. 

The Explorer window opens.

4. In the Explorer window, click on the CD-ROM drive icon (for example, 
drive D).

5. Click on the rtr_xxx directory, where xxx is the router software version.

For example, for Version 12.00, you would click on the rtr_1200 directory.

You will see a list of directories specific to the version of the router software 
you are using, such as an, asn, bn, and so forth.

6. Click on the directory for your router platform.

7. Copy the router files in the rtr_1200 directory to a destination folder on 
your PC. 

For example, one method you can use to copy the router files to a destination 
folder is as follows:

a. Hold down the shift key and click on each file you want to copy. The 
files are highlighted.

b. Choose Edit > Copy.

c. Click on the folder to which you want to copy the router files.

d. Choose Edit > Paste.

The system copies the router files you selected to the destination folder on 
your PC. Load the router software for any of the other router platforms by 
repeating steps 6 and 7.
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Loading the Router Software onto a UNIX Workstation

To load the router software from CD onto a UNIX workstation:

1. Insert the CD into your CD-ROM drive.

2. If you have not already created a CD-ROM mountpoint, log in as root 
and create a root-level directory.

For example, to create a directory named cdrom, enter:

mkdir /cdrom

3. Mount the CD-ROM drive on one the following platforms:

4. Change directories by entering: 

cd /cdrom

5. Run the script to load the router software using one of the following 
commands:

On a SPARCstation, enter:

./copy.sh

SunOS on a SPARCstation Solaris on a SPARCstation

Enter this command:

mount -r -t hsfs /dev/sr0/ cdrom

Enter this command:

mount -F hsfs -o ro /dev/dsk/c0t6d0s0/ cdrom

IBM workstation HP 9000

Enter this command:

mount -v ‘cdrfs’ -r” /dev/cd0 / cdrom

Enter this command:

/etc/ mount /dev/dsk/c0t2d0/ cdrom

Note: If you use Solaris and you are running the vold daemon, the CD 
automatically mounts as /cdrom/release/_xxx_yyy (where xxx is the router 
software version and yyy is the Site Manager version), rather than /cdrom. For 
example, for BayRS Version 12.00 and Site Manager Version 6.00, the CD 
mounts as /cdrom/release_1200_600.
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On an IBM workstation, enter:

./copy.sh

On an HP 9000, enter:

./COPY.SH\;1

During the load procedure, you must specify the following:

• The directory where you want to load the router software

For example, /usr/wf/rtr_1200

• The router platform

The system then loads the software for the platform you selected.

A sample router upgrade script is as follows:

Please choose a Router Upgrade platform to load:

1) afnflash                  Access Feeder Node 
     2) an                        Access Node

3) asn                       Access Stackable Node
4) bn                        Backbone Node
5) bn/vnr                    Backbone Node VNR
6) in                        Integrated Node
7) vme                       VME Platform

8) ATM/VNR System 5000 Hub   Model 5380 Ethernet Router or Model
5580 Token Ring Router installed on
System 5000 hubs 

9) 5780                      Model 5780 ATM VNR Router
installed on 5000AH system

    10) dcm                       Data Collection Module
11) arn                       Advanced Remote Node
12) an200                     Access Node 200
q) Quit

You can now load the router software image from your PC or UNIX workstation 
into the Image Builder, as described in the next section.
117404-A Rev. A 3-9



Upgrading Routers from Version 7-11.xx to Version 12.00
Task 3: Customizing the Router Software Image

A router software image is a group of executable files that contain a version of the 
router software for a particular type of router. You can customize the router’s 
software image to fit your router configuration requirements using a Site Manager 
tool called the Image Builder. For a complete list of the router software images by 
router type, see “Verifying Router Software Image Names on the Router” on 
page 2-12. 

Loading the Router Software Image into the Image Builder

You load the router software image from your PC or UNIX workstation into the 
Image Builder. When you open the image file using the Image Builder, Site 
Manager copies the image to an Image Builder directory. On a PC, the directory is 
\wf \builder.dir. On a UNIX workstation, the directory is defined by the 
environment variable BUILDER_DIR. You should have already defined this 
variable during the Quick-Start procedure (refer to Quick-Starting Routers for 
instructions).

To load the router software into the Image Builder:

1. In the Site Manager main window, choose Tools > Image Builder.

The Image Builder window opens.

2. Choose File > Open. 

The Open window appears (Figure 3-2), listing directories and files.
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Figure 3-2. Open Window

3. Go to the directory where the router software image files reside.

For example, in Version 12.00, go to directory /usr/wf/rtr_1200.

4. Double-click on the directory that contains the router software image you 
want to load. 

For example, if you want to load an AN software image, double-click on the 
directory /usr/wf/rtr_1200/an. 

5. Choose the file name of the router software image that you want to open. 

For example, if you want to upgrade the AN image, click on the file an.exe.

6. Click on OK.

After you choose the directory and file name of the image, the Image Builder 
window lists the current components of the current router software image 
(Figure 3-3). The components listed vary depending on the version of router 
software you are using.
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Figure 3-3. Image Builder Window with Current Components

7. Go to “Modifying the Router Software Image” on page 3-12.

Modifying the Router Software Image

You modify the software image to:

• Remove any nonessential files (protocols) that you will not use.

You might want to remove specific protocols from the router software image 
to make more space available on the target flash card (NVFS) volume. 

The Image Builder will not allow you to remove essential files. This protects 
the most important files that make up your router software image. For 
example, you cannot remove the Operating System Kernel files from the 
baseline router software component. 

• Add components (protocols) that you removed inadvertently. 

If you removed files from an existing router software image, or you changed 
the router’s hardware modules to add functionality, you might want to add 
components to the router software image. 
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See Configuring and Managing Routers with Site Manager for detailed 
instructions about removing and adding software components to a router 
software image.

After you have modified the router software image, you must save the image 
on your workstation or PC. Go on to “Saving the Router Software Image.”

Saving the Router Software Image

Bay Networks recommends that you save modified software images in a different 
directory, and that you use different image names for each router on your network.

The Image Builder automatically stores a temporary copy of the software image in 
the Image Builder directory, which is created when you install Site Manager. (See 
Quick-Starting Routers for information about installing Site Manager.) The Image 
Builder saves only individual components in this directory, which are listed in the 
Available Components list.

To save the router software image:

1. In the Image Builder window, choose File > Save. 

This saves the router software image to your current directory. There is no 
confirmation window after the image is saved successfully.

2. Choose File > Exit.

You return to the main Site Manager window.

If you exit the Image Builder without saving your changes, a message asks if 
you want to discard changes before you exit.

After you finish modifying the image for the router you want to upgrade, back up 
the router software image and config files for that router as described in Task 4.
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Task 4: Backing Up the Router Software Image and 
Configuration Files

Bay Networks recommends that you back up onto your PC or workstation the 
router software image and config files currently stored on the router. It is 
important to maintain backup copies of these files to ensure that you can restore 
router operation in case you encounter malfunctions during the upgrade process.

For instructions on how to back up the router software image and config files onto 
the hard disk of your Site Manager PC or UNIX workstation, See Configuring and 
Managing Routers with Site Manager.
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Chapter 4
Transferring Customized Files to

the Router and Upgrading PROMs

This chapter describes how to prepare the router to receive a new software image, 
how to transfer the customized image and associated router files to the router, and 
how to upgrade and verify PROMs on the router. See the following topics:

Task 1: Preparing the Router to Receive a
New Software Image

Before you can transfer a customized image to the router you want to upgrade, 
you must first prepare the router’s flash card or flash SIMM to receive a 
customized image and a configuration file. See the following table for further 
instructions.

Topic Page

Task 1: Preparing the Router to Receive a New Software Image 4-1

Task 2: Transferring a Customized Image and Router Files to the Router 4-5

Task 3: Upgrading and Verifying PROMs on the Router 4-10
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Preparing Routers with One Flash Card

To prepare a router equipped with one flash card to accept a customized software 
image:

1. Verify that you have backed up the router’s Version 7-11.xx boot image to 
your Site Manager workstation.

You saved a copy of the Version 7-11.xx boot image when you backed up the 
router software image and configuration files in “Task 4: Backing Up the 
Router Software Image and Configuration Files” on page 3-14.

2. Load all the .str files from the router’s flash card into the router’s 
memory.

From the Technician Interface, enter the following command:

string load

It is important that you load the .str files into the router’s memory before 
deleting the previous router software image (step 3). If you fail to load the .str 
files and then delete the previous router software image from the router’s flash 
card, the software image running in memory may need to pull some .str files 
from the image that was previously stored on the flash. However, that image 
no longer exists or has been partially updated to a new software image. 

3. Delete the current router software image (for example, an.exe, asn.exe, or 
bn.exe) from the router’s flash card.

If the Number of Flash Memory 
Cards in the Router Is Refer to This Section

1 Preparing Routers with One Flash Cards or
Preparing Routers Configured for Netboot

Greater than 1 Preparing a Router with Multiple Flash Cards

Greater than 1 (and the cards 
contain files for an earlier release 
of the router software)

Using Flash Cards from Previous Releases (see 
Appendix E)

Note: AFN routers support only one flash card. AN routers support only one 
SIMM.
4-2 117404-A Rev. A



Transferring Customized Files to the Router and Upgrading PROMs
 

In the File Manager window, choose Commands > Delete.

Perform this step if the router is an AN and your network is not configured to 
perform a Netboot operation on an AN router.

4. Compact the router’s flash card.

In the Router Files Manager window, choose Commands > Compact.

A message appears asking whether you want to proceed with the file 
compaction.

Compacting the flash card ensures that it has enough contiguous free space to 
accommodate the Version 12.00 software image.

5. Click on Yes in the message window.

An hourglass appears for the duration of the file compaction. After several 
minutes, a window displays the following message, where x is the volume you 
are compacting:

Last file system command, “compact x:” finished successfully.

Go to “Task 2: Transferring a Customized Image and Router Files to the Router” 
on page 4-5.

Preparing Routers Configured for Netboot

If you have an AN or ASN router with one flash card and you have configured 
your router to boot off the network (using Netboot or Directed Netboot), consider 
the following:

• Do not delete the Version 7-11.xx boot image from the router’s flash card.

You may need a backup boot image in case the new boot image is corrupted. 

• Do not compact the contents of the card.

• Perform a Netboot operation on the AN router using a customized Version 
12.00 router software image residing on a BootP server in your network. 

Note: The AN may require approximately 12 minutes to finish compacting its 
flash file space.
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With this approach, the Version 12.00 image runs in active memory on the 
router, but the Version 7-11.xx image remains available on the router’s flash 
card as a backup.

After you verify that the Netboot operation ran successfully, you can install the 
Version 12.00 image on either the AN flash SIMM, ASN (flash), or BayStack flash 
card. You do this to ensure that the router software version stored in the router’s 
memory is compatible with the one stored on the AN flash SIMM, ASN flash, or 
BayStack flash card. By installing the Version 12.00 router software image onto 
the flash SIMM or flash card, you will have a backup version of the 12.00 image 
in case the Netboot operation fails.

Before you install the Version 12.00 image on flash SIMM or flash card:

1. Delete the Version 7-11.xx image from the AN flash SIMM.

2. Compact the contents of the flash SIMM.

3. Use TFTP to transfer your customized Version 12.00 image, an.exe, from 
your Site Manager workstation to the flash SIMM volume on the router.

See Cofiguring BayStack Remote Access or Connecting ASN Routers to a Network 
for detailed information on how to perform a Netboot operation on a router. 

Preparing a Router with Multiple Flash Cards

Bay Networks recommends that you use two flash cards in a router that supports 
multiple flash cards. This allows you to keep the active (Version 7-11.xx) software 
image on one flash card while you use the TFTP command in Site Manager to 
transfer the new (Version 12.00) image to another flash card designated for the 
upgrade. Once you successfully install and verify the new router software image, 
you can delete the earlier image version.

To prepare a router equipped with multiple flash cards to receive a customized 
software image:

1. Insert a flash card into your router.

This is the backup flash card onto which you will store the Version 12.00 
router software image and associated router files.

2. Back up the contents of your flash card to your Site Manager 
workstation.

You do this as a safeguard in case your flash card malfunctions.
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3. Reformat the flash card, making sure that the volume or slot number in 
which the flash card resides is correct. 

In the Router Files Manager window, choose Commands > Format.

This operation deletes all files from the flash card and compacts its contents.

Now your backup flash card is blank and is ready to accept the Version 12.00 
image and associated files.

4. Copy the Version 12.00 router image files from your Site Manager 
workstation to the flash card you just formatted.

Go on to “Task 2: Transferring a Customized Image and Router Files to the 
Router,” to copy the router software image to the router.

Task 2: Transferring a Customized Image and
Router Files to the Router

You can use the Router Files Manager to transfer a customized software image 
and associated router files to the router you want to upgrade using the Trivial File 
Transfer Protocol (TFTP) command. For a list of the files you need to transfer to 
the router, refer to “Task 2: Upgrading to BayRS Version 12.00” on page 3-6.

Before attempting to transfer a customized image to the router, consider the 
following conditions and guidelines:

• If the router you want to upgrade has only one flash card and you have not 
updated the router’s Boot PROM for Version 8.10 or 9.xx, you must rename 
your customized Version 12.00 image to boot.exe before attempting to 
transfer that image to the router.

• If the router you want to upgrade has multiple flash cards and you have not 
updated the router’s Boot PROM for Version 8.10 or 9.xx, you must:

a. Transfer the customized image (for example, asn.exe or bn.exe) to an 
alternate flash volume on the router. 

b. Boot the Version 12.00 image on the router by performing a “named 
boot” from the Technician Interface prompt, as follows:

<slot>:bn.exe <slot>:config
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<slot> is the slot containing the image name bn.exe and the original
configuration file, config.

• If space is available, you should retain the old software image on the router 
you want to upgrade until you succeed in booting it with the new software 
image. If adequate space is not available, delete the old image and then 
transfer the new one. 

To transfer a customized image file to the router you want to upgrade, complete 
the following steps:

1. Copy the router files from the directory in which you loaded the router 
software (/usr/wf/rtr_1200/an).

2. In the main Site Manager window, choose the router to which you want 
to transfer the software image by clicking on its IP address in the 
Well-Known Connections list.

3. Choose Tools > Router Files Manager.

The Router Files Manager window opens (Figure 4-1.)

Note: We recommend that you ping the router before you transfer the 
customized image file to it. For instructions on how to ping a router, see 
Configuring and Managing Routers with Site Manager. 
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Figure 4-1. Router Files Manager Window

4. Verify space on the destination volume.

Make sure that the router destination volume has enough space available for 
the file you want to transfer. The Router Files Manager window shows the 
available free space and contiguous free space on the router. 

For a DOS file system, refer to the number of bytes displayed for available 
free space. 

For an NVFS file system, refer to the number of bytes displayed for 
contiguous free space.
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If the file system on the router is an NVFS, compact the memory card to 
optimize the available free space, as follows:

a. In the Router Files Manager window, choose Commands > Compact.

b. Click on OK in the Confirmation window.

5. Choose File > TFTP > Put File(s).

The TFTP Put File Selection window opens (Figure 4-2), invoking the Trivial 
File Transfer Protocol (TFTP) software to execute file transfers.

Figure 4-2. The TFTP Put File Selection Window 

6. In the Path field, enter the path to the directory on the Site Manager 
workstation that contains the image file you want to transfer.

The file names in that directory appear in the Files list. You may transfer more 
than one file at a time, if applicable.

7. In the Files list, click on the image file and the associated router files that 
you want to transfer to the router. 
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8. Click on Add.

The selected files appear in the Files To Put list.

If you inadvertently add a file that you do not want to transfer to the router, 
choose that file in the Files To Put window and click on Remove.

9. If you want to send the image file and associated router files to only one 
router, click on No in the Multiple Routers field. Click on Yes to send 
these files to multiple routers.

Refer to Configuring and Managing Routers with Site Manager for more 
information about transferring files to multiple routers.

10. Click on OK.

The Router Files Manager transfers the file to the router. If a file of the same 
name already exists in that directory, the transferred file overwrites it. 

If the file transfer fails, check your setup for the TFTP operation. Then try to 
transfer the file again. 

If you need assistance, call the Bay Networks Technical Solutions Center.

Next, you must update the PROMs on the router and boot the router to load 
the new Version 12.00 software image. Go on to “Task 3: Upgrading and 
Verifying PROMs on the Router.”

Note: If you cannot transfer the customized image to the router successfully, 
do not reboot the router. On single flash card systems, the router fails to boot 
because there is no image available from which it can boot. 
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Task 3: Upgrading and Verifying PROMs on the Router

The router’s programmable read-only memory (PROM) contains software images 
for its bootstrap and diagnostic code. Bootstrap and diagnostic PROM code is 
included on the BayRS Version 12.00 release media. 

Bay Networks strongly recommends that you upgrade PROMs in a router to 
implement the latest software or hardware features before upgrading to a new 
version of the router software.

Why You Upgrade Boot and Diagnostic PROMs

You upgrade Boot PROMs in a router for the following reasons:

• You want to implement a Version 8.10 or later software or hardware feature 
that depends on the availability of the Version 8.10 or later Boot PROM 
image. For example, if you want to implement flash partitioning for your AN 
router, you must upgrade the Boot PROM image, anboot.exe, in that router to 
Version 8.10 or later. 

See Table A-1 on page A-5 for the list of features that require a Version 8.10 
or later Boot PROM image.

• You want to implement the new router software image-naming convention, 
which uses the router-specific image names introduced in Router Software 
Version 8.10 (Table 4-1).

Table 4-1. Router-Specific Image Names

Router Image Name Description

AN, ANH, AN200 an.exe Bootable image for the AN, ANH, and AN200

AFN (flash) afn.exe Bootable image for the AFN

ASN asn.exe Bootable image for the ASN

ARN arn.exe Bootable image for the ARN 

BCN, BLN, and 
BLN-2

bn.exe Bootable image for the BCN, BLN, and BLN-2

System 5000 net 
modules

s5000.exe Bootable image for the System 5000 net 
modules
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To implement the new naming convention, upgrade the Boot PROMs on all 
routers, except the FN, ALN, LN, and CN. The Boot PROM is located on PROM 
or flash PROM on each processor board. After upgrading, Version 8.10 and later 
Boot PROMs look only for the new router software image name at boot time.

In addition, Version 8.10 and later Boot PROMs for AN and AFN routers are 
backward-compatible. That is, the Boot PROM looks first for a Version 8.10 or 
later router software image name (an.exe or afn.exe, depending on the router) at 
boot time. If the Version 8.10 or later AN or AFN Boot PROM cannot find the 
router-specific image name, it searches next for the Version 7-8.xx image name, 
boot.exe.

You upgrade Diagnostic PROMs in routers when the diagnostic image version 
number for the new release of the router software is higher than the diagnostic 
image version number for the router software currently installed on your router. 

To determine the current version of the Boot or Diagnostic PROM in your router, 
see Appendix A. 

Methods for Upgrading PROMs

Depending on which router you are upgrading, you upgrade PROMs in that router 
in the following ways:

• By reprogramming the PROM components using the Technician Interface. 
This process of erasing the contents of PROM and transferring new bootstrap 
and diagnostic images is sometimes called “burning” the PROM.

• By physically replacing the existing PROM with the PROM version shipped 
with Router Software Version 8.10 or later.

Note: CN, FN, LN, and ALN (VME) routers continue to use the router 
software image name ace.out.
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Table 4-2 summarizes the methods for upgrading PROMs in various routers. 

Depending on your AN or ANH model, you transfer new boot and diagnostic code 
to PROM using either

• A PCMCIA flash card (BayStack AN and BayStack ANH)

• SIMM-based flash memory (AN and ANH models without a PCMCIA slot)

To upgrade the PROMs in a SIMM-based AN router with a motherboard revision 
lower than 14, you must order a PROM Upgrade Kit (Order No. 109435) to 
physically replace the PROM components.  

Go on to “Upgrading and Verifying PROMs.”

Table 4-2. Methods for Upgrading Boot PROMs in Various Routers

If Router Model Is
PROM Replacement 
Method Is 

Refer to

AFN (flash) Physical replacement Installing a Flash Memory 
Upgrade in an Access Feeder 
Node 

AN or ANH (with motherboard 
revision level earlier than 14)

Physical replacement Installing Boot and Diagnostic 
PROMs in an AN Router

AN, ANH, or BayStack routers 
(with motherboard Revision 14 
or later)

Technician Interface 
prom command

Installing Boot and Diagnostic 
PROMs in an AN Router

ASN or BN (BLN, BLN-2, BCN, 
ARE)

Technician Interface 
prom command

“Upgrading and Verifying 
PROMs” in this chapter

FN, LN, ALN, CN Technician Interface 
prom command

No Boot PROM upgrade 
required

Caution: Systems with one-time programmable (OTP) PROMs require 
component replacements to upgrade the PROM version. These systems 
include AFNs and ANs with motherboards earlier than Revision 14. AN 
motherboards Revision 14 and later provide flash-in-place capability; you 
upgrade these PROMs by downloading new code from the flash file system.
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Upgrading and Verifying PROMs 

You use the prom command from the Technician Interface to upgrade and verify 
the software on the Diagnostic or Boot PROM. This command is restricted to the 
Manager access level.

When you upgrade PROMs, the system erases the existing PROM and copies the 
contents of the newer PROM image file to the PROM. To verify the PROM, the 
system compares the contents of the new image file to the actual contents of the 
PROM.

To upgrade and verify PROMs on a router, begin at the Technician Interface 
prompt and complete the following steps:

1. Establish a Technician Interface session with the router.

Enter the following command at the Technician Interface prompt: 

Manager

Refer to Using Technician Interface Software for more information on how to 
open a Technician Interface session with the router.

2. Insert a flash card with contiguous free space sufficient to accommodate 
the PROM images you want to upgrade on the router. 

To determine the amount of contiguous free space, display the directory of the 
flash volume by entering the following command from the Technician 
Interface prompt:

dir <volume_no.>:

<volume_no.> is the slot in which the flash card resides.

If you need more contiguous free space for the PROM image:

a. Delete unnecessary or obsolete files.

b. Compact the contents of the flash card by entering:

compact <volume_no.>:

The following message appears:

Note: Before upgrading any router software, make sure that you save a copy 
of the original configuration file and boot image as a safeguard in case you 
encounter problems after upgrading.
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Compacting file system on volume <vol>:... 
This may take several minutes...Please wait...

100% Complete

Compaction completed

The space is compacted when the Technician Interface prompt reappears.

c. Verify that the amount of contiguous free space and available free 
space on the volume are the same by entering:

dir 

3. Transfer the PROM image files (for example, freboot.exe and frediag.exe) 
to the router’s flash card by using the tftp command.

For more information about the tftp command, see Using Technician 
Interface Software.

4. Update the boot PROM by entering:

prom -w <volume_no.> : <Boot_PROM_source_file>  <slot_ID >

<volume_no.> is the slot number of the Boot PROM source file located on a 
volume.

<Boot_PROM_source file> is the name of the Boot PROM source file (for 
example, freboot.exe).

<slot_ID> is the slot location of the Boot PROM that you want to update. 

For AN, ANH, and ARN routers, the <slot_ID> is always 1. 

For example:

prom -w   2:freboot.exe 3
or
prom -w   1:arnboot.exe 1

This command erases the Boot PROM on slot 3 and copies the contents of the 
freboot.exe file on volume 2 to the PROM on slot 3.

Note: Once you enter the prom command, it must run to completion. The 
control-c (abort) command is disabled for the duration of the prom command 
execution to allow it to run to completion. Updating takes from 2 to 10 minutes 
per PROM. Verifying takes up to 2 minutes per PROM. 
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5. Update the Diagnostic PROM by entering:

prom -w <volume_no.> <Diag_PROM_source_file>  <slot_ID>

<volume_no> is the slot number of the Diagnostic PROM source file located 
on a volume.

<Diag_PROM_source file> is the name of the diagnostic PROM source file 
(for example, frediag.exe).

<slot_ID> is the slot location of the diagnostic PROM file you want to update.

For AN, ANH, and ARN routers, the <slot_ID> is always 1. 

For example:

prom -w  2:frediag.exe 3
or 
prom -w  1:arndiag.exe 1

This command erases the Diagnostics PROM on slot 3 and copies the 
contents of the frediag.exe file on volume 2 to the PROM on slot 3.

6. Upgrade PROMs on multiple slots on your router.

If you need to update PROMs on multiple slots, use a dash to indicate a range 
of slots (2-5), or use commas or spaces to separate multiple slot locations
(2, 3, 4, or 2 3 4).

For example:

prom -w 2:frediag.exe 2, 3, 4, 5

This command erases the diagnostic PROMs on slots 2, 3, 4, and 5 and copies 
the contents of the frediag.exe file on volume 2 to the PROMs on slots 2, 3, 4, 
and 5.

For more information about updating PROMs on multiple slots, see Using 
Technician Interface Software.

Note: Boot PROM incompatibilities can exist if you have different Boot 
PROM revisions on different slots on your router. For example, the Boot 
PROM image in a slot running Boot PROM Version 8.00 will look for 
boot.exe. A Boot PROM image running Version 8.10 or later on a BN router 
will look for the image name bn.exe.
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7. Verify the PROM upgrade by entering the following command:

prom   -v <volume_no.> <Diag_PROM_source_file>  <slot_ID>

For example, for a boot PROM, enter:

prom -v <volume_no.>: [freboot.exe | asnboot.exe | anboot.exe |
arnboot.exe] <slot_ID>

For a diagnostics PROM, enter:

prom -v <volume_no.>: [frediag.exe | asndiag.exe | andiag.exe |
arndiag.exe]<slot_ID>

The system verifies that the PROM image on a designated flash volume (that 
is, the image file used as a source for upgrading the PROM) matches the 
image actually stored in the boot or diagnostics PROM, on a designated slot.

When you use the -v option, the console displays one of the following 
messages after the verification terminates:

prom: slot <slot ID> completed successfully

prom: PROM data does not match file data on slot <slot ID>

If the operation succeeds, the new images stored in the Boot and Diagnostic 
PROMs run when you reboot the router.

If the operation fails, the console displays a message describing the cause of 
the failure.

For additional examples of using the prom command to update and verify 
PROMs, see Using Technician Interface Software.

Upgrading PROMs in a Router from a Remote Site

This section summarizes the procedure for upgrading PROMs in a router that is 
located in a remote site. Be sure to read the special considerations in this section 
before upgrading router PROMs remotely.

Caution: If the PROM upgrade process is interrupted, the router could be 
disabled. 
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When upgrading PROMs in a router from a remote site, follow these guidelines to 
ensure that the PROM upgrade is successful:

• Store the PROM executable files (for example, frediag.exe and freboot.exe) on 
a flash card that resides on the slot in the system that you use the least.

• Perform the upgrade during nonpeak hours to ensure a minimum traffic load 
across all rails of the backplane (PPX).

The operations involved in updating PROMs are both data-transfer and CPU 
intensive, as are the regular functions of routing and forwarding normal data 
traffic. Because periods of high traffic (peak periods) may cause timeouts or 
other failures of the PROM upgrade process, it is important to perform PROM 
upgrades during off-peak periods. A failure during a PROM upgrade makes it 
necessary to repeat the procedure.

• On multislot systems, upgrade the PROM for each slot separately. Attempting 
to upgrade multiple slots at the same time increases the load on the router 
backplane.

After you upgrade PROMs on the router, boot the router with the customized 
image and upgrade your existing configuration file to support the new Version 
12.00 features. Go to Chapter 5.

Caution: Never reset or reboot a router while upgrading PROMs. Should a 
failure occur, restart the procedure immediately.
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Chapter 5
Booting the Router with

the Customized Image and
Upgrading the Configuration

This chapter describes how to boot the router with the customized image and 
upgrade the existing configuration file to support new BayRS Version 12.00 
features. It also describes how to upgrade frame relay circuits and transfer script 
files to the router. See the following topics:

Task 1: Booting the Router with the Customized Image

After you successfully transfer the customized image to the router and upgrade 
the PROMs, you can boot the router with the customized image. The first time you 
successfully boot an ASN router from a Version 12.00 image, the boot time may 
be longer. After that, you can shorten the boot interval by changing the default 
Netboot settings. 

Topic Page

Task 1: Booting the Router with the Customized Image 5-1

Task 2: Upgrading the Existing Configuration File 5-4

Task 3: Upgrading Frame Relay Circuits 5-7

Task 4: Transferring Script Files to the Router 5-7
117404-A Rev. A 5-1



Upgrading Routers from Version 7-11.xx to Version 12.00
Begin by entering the following commands at the Technician Interface prompt:

bconfig image local
bconfig config local

The ASN boots exclusively from the local image and a local configuration file. 

To boot the router with the customized image:

1. In the Site Manager window, select Administration > Boot Router.

The Boot Router window opens (Figure 5-1), showing the default router 
volume for the router boot image file (ace.out) and the default configuration 
file name (config). The file name and volume vary depending on the router.

For routers that use flash memory cards or single inline memory modules 
(SIMMs), the default volume is the first available card or module, which is 
designated by its slot number. For routers that use diskettes, the volume is the 
letter A.

Figure 5-1. Boot Router Window

2. Choose the correct router volume.

a. Click on one of the small buttons next to Boot Image volume number 
(an “A” in Figure 5-1) or the Configuration slot number (also “A”).

A pop-up window displays the available router volumes containing the 
router software image and the available slots containing the configuration 
file.

Note: If the router you want to upgrade has only one flash card, do not change 
the volume displayed.
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b. Click on the number of the slot you want your router to boot or 
configure from.

The pop-up window closes and the new slot number appears. 

3. Verify the name of the new router software boot image.

The default router-specific image name appears in the Boot Image box.

4. Verify the configuration file from which you want to boot the router.

The default configuration file name config appears in the Configuration box.

5. Click on Boot.

A confirmation window appears.

6. Click on OK.

The router boots using the router software image and the configuration file 
you specified.

Wait a few minutes to give the router time to boot. The boot time may be 
longer if you are booting an ASN router for the first time from a Version 12.00 
image. 

7. Verify that the router booted successfully with the customized image and 
configuration file.

In the main Site Manager window, choose View > Refresh Display.

If the router booted successfully, Site Manager establishes a connection to the 
router and displays system information (such as the system name, contact, 
location, description, and MIB version). 

If Site Manager does not display system information, the router did not boot 
successfully. Consider the following:

• If you have a router with one flash card, use a local console to reboot the 
router from the Technician Interface. If this operation fails, call the Bay 
Networks Technical Solutions Center in your area.

Note: If you are upgrading a router that is running Version 8.10, 9.xx, 10.0, or 
11.0 Boot PROMs to Version 12.00 and that router contains multiple flash 
cards, remove the Version 8.10, 9.xx, 10.0, or 11.0 backup flash card from the 
router. Otherwise, when you reset or cold-start the router, it will run different 
software versions on different slots.
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• If your router has multiple flash cards, boot the router off the original 
flash card (pre-Version 12.00). Follow the instructions in “Preparing a 
Router with Multiple Flash Cards” on page 4-4.

Task 2: Upgrading the Existing Configuration File

This section describes how to upgrade your existing configuration files to support 
the new Version 12.00 features. Optionally, you can create a new Version 12.00 
configuration file to replace your existing configuration file for the router.

Booting the Existing Configuration File

To upgrade an existing configuration file to Version 12.00, boot it on a router 
running a Version 12.00 router software image. This router software loads the 
existing configuration file into the router’s memory and updates the configuration 
file’s version stamp to match the Version 12.00 router software. It does not, 
however, automatically save that version to the file on the flash card until you save 
the configuration file in dynamic mode.

Saving the Configuration File in Dynamic Mode

After you boot the router with the existing configuration file, save the 
configuration file in dynamic mode. When you save the configuration file in 
dynamic mode, the file is saved directly to the router. 

To save the existing configuration file in dynamic mode:

1. In the Site Manager window, choose Tools > Configuration Manager > 
Dynamic.

The Configuration Manager window appears (Figure 5-2), displaying the
real-time router hardware and software configuration.
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Figure 5-2. Configuration Manager Window

2. Choose File > Save As.

The Save Configuration File window appears (Figure 5-3.)

Figure 5-3. Save Configuration File Window

3. Enter the configuration file name config.

4. Choose the correct volume by clicking in the volume field.
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If the file system on the router is an NVFS, and the volume (slot location of 
the memory card on the router) is not the volume to which you want to save 
this file, choose an alternate volume. Otherwise, go to the next step.

5. Click on Save.

The File Saved window opens (Figure 5-4), asking you to confirm your 
decision to save the file.

Figure 5-4. File Saved Window

6. Click on OK.

This rewrites the configuration file, config, out of the router’s memory and 
saves it to the router’s flash card with the Version 12.00 version stamp. 
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Task 3: Upgrading Frame Relay Circuits

If you are running router software earlier than Version 7.60 and the configuration 
file you upgraded in Task 3 had frame relay circuits, complete this task. 
Otherwise, go to “Task 4: Transferring Script Files to the Router.”

The upgrade procedure does not convert all frame relay circuit records, and Site 
Manager does not display them. You must delete all interfaces on which frame 
relay was configured and reconfigure the interfaces, as follows:

1. Open your current configuration file, using the Configuration Manager.

2. Choose Delete Circuits from the Circuits menu.

The Circuit List window displays the circuits.

3. Choose each circuit on which frame relay was configured in the 
configuration file you just upgraded.

4. Click on Delete.

The system removes the selected circuit.

5. Click on Done.

6. In the Circuits menu, click on Add Circuit.

7. Configure a new frame relay circuit for each circuit you deleted.

Task 4: Transferring Script Files to the Router

Transfer to the router from your Site Manager PC or UNIX workstation to the 
router any Version 12.00 Technician Interface scripts useful for your router 
configuration. These scripts let you manage the router using information stored in 
the Management Information Base (MIB). You can use the scripts to display 
information about protocols and network services and to enable and disable 
protocols, circuits, lines, and services.
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Technician Interface Script Descriptions

The Technician Interface scripts are .bat and .mnu files; you must transfer these 
files to a memory card in each router you want to upgrade to Version 12.00.

• The .bat files enable you to generate information about a protocol or service 
that the router supports.

• The .mnu files enable you to display this information from menus.

Each script contains subcommands to support the options that it provides. For a 
complete list of script files and definitions, refer to Using Technician Interface 
Scripts.

For each router you want to upgrade to Version 12.00, you must transfer a 
minimum set of scripts, regardless of which protocol-specific scripts you want to 
run on your router. Table 5-1 lists these scripts.

In addition to the required script files listed in Table 5-1, you can transfer to your 
router any protocol-specific scripts to support the protocols on the router you are 
upgrading to Version 12.00. For example, if you want to run only IP and frame 
relay on a router, transfer to that router the following script files: ip.mnu, fr.bat, 
and fr.mnu. 

Table 5-1. Minimum Set of Scripts to Transfer to a Router 

 Script Filename Description

show.bat Helps you isolate problems such as circuits that are not 
working, packets that are not being forwarded, and so 
forth.

setpath.bat Sets the search path and aliases for the script commands.

menu.bat Provides a menu from which you can select the script you 
want to run.

main.mnu Displays a top-level menu from which you can select other 
.bat files currently on the system.

monitor.bat Displays the same information as the show command, but 
refreshes the display periodically so you can examine 
trends and changes.
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Appendix A
Determining the PROM Version on the Router

This appendix describes how to determine the current version of Boot and 
Diagnostic PROM images currently running in your router using Site Manager 
and the Technician Interface. It also describes Boot PROM upgrades for new 
feature support.

On the back panel of some routers, a label displays the installed version of Boot 
and Diagnostic PROMs. For example, an AN router with a SIMM-based flash file 
system has a label that indicates the current PROM version number. See the guide 
contained in the PROM upgrade kit (Installing Boot and Diagnostic PROMs in an 
AN Router) for more information.

Using Site Manager to Determine the PROM Version

To obtain PROM version information from any router currently connected to your 
Site Manager PC or UNIX workstation:

1. In the main Site Manager window (see Figure 3-1 on page 3-3), choose 
Tools > Statistics Manager.

The Statistics Manager window opens.

The Statistics Manager displays the current router’s configuration. That is, it 
displays the circuit type and location of the router’s network interfaces and the 
bridging and routing protocols that are enabled on each interface.

2. Choose Tools > Quick Get.

The Quick Get Facility window opens, showing the objects in the 
Management Information Base (MIB). Use the browser window to scroll 
through and select objects from the MIB. Then use Quick Get to get all 
instances of the object you select and to display that information in columns 
in the Quick Get Facility window.
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3. Scroll through the MIB Browser window and choose the top-level object 
group, wfHardwareConfig.

The MIB displays subordinate object groups pertaining to router hardware 
configuration.

4. Click on the object group wfHwTable. 

5. Continue choosing object groups and descending through the tree until 
the MIB Browser displays the object wfHwBootPromRev or wfHwDiagPromRev 
(depending on which PROM version you want to verify).

6. Select the object wfHwBootPromRev or wfHwDiagPromRev. 

The Object Information field at the top right of the Quick Get window 
displays information about the object.

7. In the Quick Get window, click on Retrieve Request.

All router slots (indicated by the Instance ID field in the Quick Get data 
retrieval window) and the Boot PROM version associated with each slot 
appear.

The format for the Boot PROM revision that appears in the output window is 
eight hexadecimal numerals in a 32-bit display. The first four characters are 
major revisions; the last four are minor revisions. 

Convert the hexadecimal numerals to decimal to determine the PROM 
revision level. For example, the PROM image version number returned for the 
Version 9.xx router software is 0x00090000. 

8. Click on Done to exit the Quick Get Facility window.

For more information about using Quick Get, refer to Configuring and 
Managing Routers with Site Manager.

Note: Slots that have a System Resource Module (SRM) do not show a 
corresponding Boot PROM revision number.
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Using the Technician Interface to Determine the
PROM Version

To determine the version number of PROM images residing in a router while 
working from a local console, a Telnet session, or a modem, enter the following 
commands at the Technician Interface prompt:

1. To obtain the version number of Boot PROM images residing in a router, 
enter:

get wfHwEntry.19.*

With a BLN router, for example, information similar to the following appears, 
with one wfHwEntry.wfHwBootPromSource line for each slot:

wfHwEntry.wfHwBootPromSource.1 = (nil)
wfHwEntry.wfHwBootPromSource.2 = "rel/12.00/freboot.exe"
wfHwEntry.wfHwBootPromSource.3 = "rel/12.00/freboot.exe"
wfHwEntry.wfHwBootPromSource.4 = "rel/12.00/freboot.exe"
wfHwEntry.wfHwBootPromSource.5 = "rel/12.00/freboot.exe"

Each line of response to the command specifies:

• A slot number (for example, “wfHwEntry.wfHwBootPromSource.2” identifies 
slot 2).

• A path name that contains the version number of the image stored in the Boot 
PROM (for example, “rel/12.00/freboot.exe” identifies the Version 12.00 
Boot PROM image freboot.exe in slot 2).

2. To obtain the version number of Diagnostic PROM images residing in a 
router, enter:

get wfHwEntry.16.*

Note: The command does not return a Boot PROM version number for slot 1 
because slot 1 contains a System Resource Module (SRM). This applies to all 
routers except AN and ASN routers.
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With a BLN router, for example, information similar to the following appears, 
with one wfHwEntry.wfHwDiagPromSource line for each slot:

wfHwEntry.wfHwDiagPromSource.2 = 
"/harpdiag.rel/v6.00/wf.pj/harpoon.ss/image.p/frediag.exe"
wfHwEntry.wfHwDiagPromSource.3 = 
"/harpdiag.rel/v6.00/wf.pj/harpoon.ss/image.p/frediag.exe"
wfHwEntry.wfHwDiagPromSource.4 =
"/harpdiag.rel/v6.00/wf.pj/harpoon.ss/image.p/frediag.exe"
wfHwEntry.wfHwDiagPromSource.5 =
"/harpdiag.rel/v6.00/wf.pj/harpoon.ss/image.p/frediag.exe"

Each line of response to the command specifies:

• A slot number (for example, “wfHwEntry.wfHwDiagPromSource.2” identifies 
slot 2).

• A pathname that contains the version number of the image stored in a 
diagnostics PROM (for example, 
"/harpdiag.rel/v6.00/wf.pj/harpoon.ss/image.p/frediag.exe" identifies 
the “v6.00” (Version 6.00) diagnostics PROM image frediag.exe in slot 2).

Refer to Using Technician Interface Software for more information.

See Table 2-5 on page 2-14 for Version 12.00 Boot and Diagnostic PROM file 
names and associated revision numbers for the various router platforms. 

If you determine that you need to upgrade PROMs in your router, refer to 
“Upgrading and Verifying PROMs” on page 4-13.

Features Associated with PROM Upgrades

Table A-1 describes router features implemented between Versions 7.70 and 12.00 
that require a new version of Boot PROM. Upgrade the Boot PROM if the features 
you need depend on a Boot PROM version more recent than the version now in 
your router.

Note: The Boot PROM version that appears in the AFN MIB corresponds to 
the version of the AFN Diagnostics PROM code. (The AFN has a combined 
Boot/Diagnostic PROM device.) 
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Table A-1. Boot PROM Upgrades for New Feature Support 

Router
Model

Boot 
PROM
Version

PROM
File Name

PROM Features
If PROM Version Is
at This Version

Reason for
Upgrading PROM

AN/ANH 8.00 anboot.exe 4 MB flash 
capability.

Upgrade to PROM 
Version 9.00.

2 MB flash might be too 
small to accommodate 
Version 10.0 image.

8.10 anboot.exe New 
router-specific 
Boot image name 
(an.exe).

No action required. No new features beyond 
Version 8.10.

9.00 anboot.exe None. No action required. No new features beyond 
Version 8.10.

9.00b anboot.exe None. No action required. No action required.

AN200 11.01 an200boot.exe Support Router 
Software Version 
11.01.

No action required. No action required.

ARN V1.17 arnboot.exe None. No action required. No action required.

ASN 8.00 asnboot.exe 4 MB flash
capability.

Upgrade to PROM 
Version 10.0.

2 MB flash might be too 
small to accommodate 
Version 10.0 image.

8.10 asnboot.exe New 
router-specific 
Boot image name 
(asn.exe).

Support for
Hot-Swap SPX 
network module.

No action needed. No new features beyond 
Version 8.10.

9.00 asnboot.exe None. No action. No new features beyond 
Version 8.10.

10.00 asnboot.exe None. No action. --- 

(continued)
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BN 7.70/7.7
1

freboot.exe Support for
FRE-2 controller.

Upgrade to PROM 
Version 9.00.

4 MB flash capability;
changed to 
router-specific boot 
image name.

8.00 freboot.exe 4 MB flash
capability.

Upgrade to PROM 
Version 8.10.

2 MB flash might be too 
small to accommodate 
Version 10.0 image.

8.10 freboot.exe New 
router-specific 
Boot image name 
(bn.exe).

No action required. No new features beyond
Version 8.10.

9.01 areboot.ppc ARE/ATM-specific
feature.

No action required. Not applicable.

VME 8.00 vmeboot.exe 4 MB flash 
capability.

Upgrade to PROM 
Version 8.10.

2 MB flash might be too 
small to accommodate 
Version 10.0 image.

8.11 vmeboot.exe None. No action needed. Support for Quad Token 
Board.

AFN
(Flash)

3.03 No file  name Support for 4 MB 
flash capability.

Upgrade to PROM 
Version 8.10.

2 MB flash might be too 
small to accommodate 
Version 10.0 image.

3.04 No file  name New 
router-specific 
image name 
change.

No action required. No new features beyond 
Version 3.04.

ARE
s5000

A0000 areboot.ppc Support for 5780. No action required. No action required.

11.02 areboot.ppc Support for router 
software version 
11.02

No action required. No action required.

11.00 s5000boot.exe Support for router 
software version 
11.00.

No action required. No action required.

Table A-1. Boot PROM Upgrades for New Feature Support (continued)

Router
Model

Boot 
PROM
Version

PROM
File Name

PROM Features
If PROM Version Is
at This Version

Reason for
Upgrading PROM
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Appendix B
Configuration-Specific Issues

Affecting Router Upgrades

This appendix describes the Version 7-10.xx to 12.00 upgrade 
configuration-specific issues that may concern you, depending on the current 
configuration of your Version 7-10.xx router. Read this appendix if you are 
upgrading routers in an environment that includes any of the following situations:

• X.25 Configurations

• Standard Point-to-Point Connections

• Switched Services 

• PPP Multiline Circuits

Verifying X.25 Certification Requirements

Due to possible differences between older and newer link modules supporting 
connections to your X.25 network, you must verify that the router you need to 
upgrade to BayRS Version 12.00 can pass X.25 certification requirements.

Note: If the router you want to upgrade is a model AN or ASN, or if the router 
does not support any X.25 configurations, go to the next section that applies to 
your environment or to Chapter 3 to begin the upgrade process.
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Configuring FN, AFN, ALN, CN, or BN Routers to Run X.25

If you are configuring an FN, AFN, ALN, CN, or BN router to support any X.25 
configurations, follow the instructions in Table B-1.

Ensuring that Link Modules Pass X.25 Certification

Follow these guidelines to ensure that you are using a link module that can pass 
X.25 certification:

• Do not upgrade AFN hardware.

• Do not replace link modules delivered after June 1992.

• Upgrade link modules directly attached to the X.25 network that were 
delivered before October 1991.

• Inspect only the link modules directly attached to the X.25 network that were 
delivered between October 1991 and June 1992. Determine which modules to 
replace by removing the link module from the router and reading the revision 
level of any MK5025 chip on that module. If the revision level is C03 or later, 
do not replace.

Table B-1. Configuring FN, AFN, ALN, CN, or BN Routers to Run X.25

Router Software 
Version Action

Version 7.60 or 
earlier

The behavior of the serial controller chips on link modules differs 
slightly from the X.25 standard, making them noncertifiable in 
X.25 networks.

Version 7.60 or later The MK Thompson 5025 serial controller chip in the link modules 
now performs the LAPB function of X.25. This change significantly 
improves performance. However, you may still need to replace 
some link modules that have earlier versions of the MK5025 chip 
set to ensure that the router passes X.25 certification.

Note: If you need hardware to upgrade your router for X.25 support, contact 
your Bay Networks representative to order it. Specify that the router needs this 
hardware to satisfy X.25 certification requirements.
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Reviewing Standard Point-to-Point Connection Guidelines

If the router you want to upgrade has no synchronous, point-to-point connection 
requirements, go to the next section that applies to your environment or to Chapter 
3 to begin the upgrade process. Otherwise, read this section.

Configuring Point-to-Point Connections over Synchronous Lines

If you need to configure any point-to-point connections over synchronous lines, 
you must designate at both ends of the line an HDLC local address and a remote 
address. The router at each end receives packets at the designated local address 
and sends packets to the remote (destination) address. 

For each of these parameters, the Configuration Manager allows you to do one of 
the following:

• Set an implicit address value of DCE (which the router recognizes as a value 
of 0x01) or DTE (which is 0x03).

• Set an explicit address value of 0x02, 0x04, 0x05, 0x06, or 0x07.

Whatever local-remote address pair you assign at one end of a point-to-point 
synchronous line, you reverse at the opposite end of the line. For example, the 
synchronous circuit on Router A in Figure B-1 has an explicit local address (LA) 
value of 0x04 and a remote (destination) address (RA) of 0x05. In this case, you 
configure the synchronous circuit on Router B at the opposite end of the same line 
with a local address value of 0x05 and a remote address value of 0x04.

Figure B-1. Address Assignments on a Point-to-Point Synchronous Line
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Setting Explicit Local and Remote Address Values
with the Technician Interface

If the Configuration Manager constraints prove impractical due to the 
requirements of your existing network configuration, you can set explicit local 
and remote address values by entering the following commands at the Technician 
Interface prompt of the Version 12.00 router:

s wfSyncEntry.wfSyncLocalAddress.<slot>.<connector> <integer value>; 
commit

s wfSyncEntry.wfSyncRemoteAddress.<slot>.<connector> <integer value>; 
commit

save config <config filename>

<slot>.<connector> is the slot and connector (that is, the synchronous circuit) you 
want to configure.

<integer value> is the explicit address value in the range 0x00 to 0x99, excluding 
0x01 (the DCE setting) and 0x03 (the DTE setting).

Reviewing Switched Services Enhancements and 
Compatibility Issues Affecting Router Upgrades

This section describes how Version 12.00 Switched Services enhancements and 
compatibility issues affect the Version 7-10.xx to 12.00 upgrade process.

Upgrading Dial Services to Use PAP and CHAP for Caller Resolution

Bay Networks has completed its migration of dial services, which began in 
Version 8.10, from address-based caller resolution –- whoami (who-am-I) –- to 
authentication-based caller resolution.

Thus, when you use dial services (Dial-on-Demand, Dial Backup, 
Bandwidth-on-Demand) over any public switched network, such as an Integrated 
Services Digital Network (ISDN), you no longer can use an address-based method 
(IP or IPX addresses) to identify a peer router. Instead, you must configure your 
router to use one of the PPP authentication protocols: Challenge Handshake 
Authentication Protocol (CHAP) or Password Authentication Protocol (PAP). 
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PPP uses CHAP names and PAP IDs to identify the caller and to determine which 
circuit to bring up. You enter CHAP names or PAP IDs in a caller resolution table 
and associate each name or ID with a demand, primary, or bandwidth-on-demand 
circuit.

PAP requires the peer router to send a PAP packet that contains a plain-text user 
identifier and password to the originating router before the interface can advance 
to the network-layer protocol phase. For more information about PAP and CHAP, 
refer to Configuring PPP Services.

Table B-2 lists the methods used to identify a peer router, beginning with Router 
Software Version 7.60.

Upgrading Dial-on-Demand or Dial Backup Circuits

If you have a Version 7.xx-8.00 router that uses Dial-on-Demand or Dial Backup 
circuits and that initiates calls, and you want to upgrade that router to BayRS 
Version 12.00, the receiving router must be running Router Software Version 8.10 
or later. Otherwise, there is no mechanism by which the receiving router can 
identify the caller.

If you have multiple routers running Router Software Version 8.10 that use 
Dial-on-Demand or Dial Backup circuits, and you want to upgrade a router to 
BayRS Version 12.00, then you can upgrade the router on either end of the circuit. 
However, to ensure that caller resolution completes on the receiving end of the 
call, you must configure CHAP authentication and caller resolution information 
for both the caller and the receiver. 

Table B-2. Caller Resolution Methods 

Router Version Caller Resolution Mechanism 

Version 7.60-8.00 Router used PPP NCP address information to identify a peer 
router.

Version 8.10 Router used either PPP NCP address information or CHAP 
name to identify a peer router.

Versions 9.00, 10.0, 
11.0, and 12.00

Router uses CHAP name or PAP ID information to identify a 
peer router.
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PPP Multiline Migration Issues Affecting Router Upgrades

This section describes PPP multiline migration issues and how they affect router 
upgrades.

Running LCP on All Lines in a Multiline Circuit

Beginning with Router Software Version 9.00, PPP multiline circuits can 
negotiate and run the Link Control Protocol (LCP) on all lines in a multiline 
circuit, as opposed to only one line. By negotiating and running LCP on all lines 
in a multiline circuit, you can:

• Detect an initial looped-back condition on any line during LCP negotiation.

• Run an Echo Request on any or all lines independently.

• Run periodic CHAP authentication on any or all lines independently.

• Run Link Quality Reporting (LQR) on any and all lines independently.

Ensuring Backward-Compatibility for PPP Multiline Circuits

PPP multiline circuits did not run LCP on all lines of a circuit before Router 
Software Version 9.00. Therefore, Version 9.00 and later PPP multiline circuits 
and pre-Version 9.00 multiline circuits are incompatible. 
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Appendix C
Upgrading the DCM Software

Image in BayStack Routers

This appendix describes how to upgrade the DCM software image in BayStack 
routers (AN, ANH, or ARN) using either Site Manager or the Technician 
Interface. 

Instructions include:

• Verifying Hardware and Software Compatibility for DCM

• Verifying Minimum DCM Requirements

• Upgrading the DCM Software Image

Verifying Hardware and Software Compatibility for DCM

Before installing a Ethernet data collection module (DCM) in a BayStack router, 
you must ensure hardware and software compatibility. 

For RMON operation in BayStack routers, Bay Networks recommends running 
DCM Agent Software Version 1.4.2 and BayRS Version 12.00 software. However, 
earlier versions of software are supported. 
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The minimum requirements for RMON operation differ for BayStack
AN/ANH and BayStack ARN routers. See the following table for AN/ANH and 
ARN requirements:

Verifying Minimum DCM Requirements

To verify the minimum DCM hardware and software requirements:

1. Establish a Technician Interface session on the router by logging in via 
Telnet or a dialup modem.

2. Display the current version of DCM agent software. 

Your version of router software determines which commands you enter:

• On a router running Router Software Version 11.0 or later, enter the 
following command to display the DCM agent software version:

[1:1]$ get wfDCMEntry.wfDCMagentImageVersion.*

The Technician Interface displays a message similar to the following:

wfDCMmw.wfDCMagentImageVersion.1 = ”V1.4.2“

(There are two entries if there are two DCMs installed in an ARN.)

BayStack AN and ANH Minimum Requirements BayStack ARN Minimum Requirements

BayRS Version 9.0 (an.exe v9.00) or later BayRS Version 11.02 (arn.exe v11.02) or later

DCM Agent Software Version 1.4 (in11_140.obj) DCM Agent Software Version 1.4.1 (in11_141.obj) or 
1.4.2 (in11_142.obj) 

ARN Boot PROM Version 1.17 (arnboot.exe v1.17) or 
later

ARN Diagnostic PROM Version 1.30 (arndiag.exe 
v1.30) or later

DCM Hardware Revision D or later

Caution: Enabling an ARN DCM with DCM Agent Software Version 1.4 or earlier could 
disable the ARN.
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• On an AN or ANH router running Router Software Versions 9.0 to 10.0x, 
you access different MIB objects. Enter the following command:

[1:TN]$ get wfDCMmw.wfDCMAgentImageVersion.0

The Technician Interface displays information similar to the following:

wfDCMmw.wfDCMAgentImageVersion.0 = ”V1.4.0“

If the Agent Image Version line does not indicate “V1.4.1” or “V1.4.2,” see 
the next section to upgrade the DCM agent software.

3. To verify the correct ARN hardware revision, enter the following 
command:

[1:TN]$ get wfDCMEntry.wfDCMhwRev.*

The Technician Interface displays a message similar to the following:

wfDCMEntry.wfDCMhwRev.1 = "D"
wfDCMEntry.wfDCMhwRev.2 = "D"

If the Hardware Revision line indicates “C” or earlier, you must upgrade to 
DCM hardware Revision D or later.

Upgrading the DCM Software Image

Upgrading the DCM software image in BayStack routers using Site Manager or 
the Technician Interface involves:

• Transferring the DCM software image from CD-ROM to your PC or UNIX 
workstation.

• Transferring the DCM software image from your PC or UNIX workstation to 
the router’s flash card.

• Transferring the DCM software image from the router’s flash memory to the 
DCM’s flash memory.
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Using Site Manager

To upgrade the DCM software image in a BayStack router using Site Manager:

1. Transfer the DCM software image (for example, in11_142.obj) to a PC or 
UNIX workstation from:

• The latest BayRS CD-ROM release media

• The World Wide Web URL:

http://support.baynetworks.com/software/Router/

See “Task 2: Upgrading to BayRS Version 12.00” on page 3-6 for 
instructions. 

2. Transfer the DCM software image from your PC or workstation to the 
router’s flash memory. 

Refer to “Task 2: Transferring a Customized Image and Router Files to the 
Router” on page 4-5 for instructions.

3. Transfer the DCM software image from the router’s flash memory to the 
DCM flash memory, as follows:

In the Configuration Manager window (Figure C-1), choose Platform > DCM 
11.0 and later > Global... > Base Module DCM. 

Figure C-1. Choosing DCMMW Global Configuration Parameters
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The Edit Base Module DCM Parameters window opens (Figure C-2).

Figure C-2. Edit Base Module DCM Parameters Window

4. Change the Enable/Disable option to Disable.

5. Change the Boot Option from Local to Download.

This specifies that you want the Ethernet DCM to boot the downloaded DCM 
image from the Ethernet DCM’s flash memory and not from the router’s 
shared memory.

6. In the Image Name field, specify the target volume and the file name of 
the new DCM software image (in11_142.obj).

For example: 1: in11_142.obj.

7. Choose the Save option in the Image Save Mode field and click on OK.

The Edit Base Module DCM Parameters window closes.
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If you choose the No Save option, the Ethernet DCM boots with the new 
software image, but does not save the image to the Ethernet DCM’s flash 
memory.

Next, you need to complete steps 8 through 10 to boot the Ethernet DCM with 
the new DCM software image. You complete these steps at the Configuration 
Manager window. 

8. In the Configuration Manager window (Figure C-1), choose
Platform > DCM > Global.

The Edit Base Module DCM Parameters window opens (Figure C-2).

9. Choose Enable in the Enable/Disable option and click on OK.

This boots the Ethernet DCM board with the new DCM software image that 
you specified in the Image Name field and saves the new DCM software 
image in flash memory, if specified.

10. Choose Local in the Boot Option box.

You choose the Local option after you have saved the DCM software image to 
the Ethernet DCM’s flash and you want to boot the Ethernet DCM from its 
flash.

11. Choose OK to exit the Edit Base Module DCM Parameters window.

Using the Technician Interface

1. Use UNIX or PC file transfer commands to transfer the DCM software 
image (for example, n11_142.obj) to a PC or UNIX workstation from:

• The latest BayRS CD-ROM release media

• The World Wide Web URL:

http://support.baynetworks.com/software/Router

Contact the Bay Networks Technical Solutions Center if you do not have 
access to these sources.

2. Use FTP or TFTP to transfer the DCM image file and the dcmload.bat 
Technician Interface script from the workstation to the flash memory 
card on the router.
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3. Enter the following Technician Interface command to download the new 
software image from the router flash memory card to the DCM flash 
memory:

 [1:1]$ dcmload

The Technician Interface displays information about the dcmload script, and 
then prompts:

Do you want to download an image to the Base Module DCM
or the Expansion Module DCM (b/e) [b]

4. If the DCM is installed on an AN, ANH, or ARN base module, accept the 
default response, b. If the DCM is installed on an ARN expansion module, 
enter e. 

The Technician Interface displays the following prompt:

Specify DCM image name (volume:filename): 

5. Enter the image name in the form <volume:filename>, where <volume> is 1 
and <filename> is the name you gave the DCM image during the file 
transfer. 

For example, enter 1: in11_142.obj or 1:dcm142image.

The Technician Interface displays the following prompt:

Do you want DCM to save this image on its FLASH? (y/n)[y]

6. Answer yes (y).

Answering no (n) uses the downloaded image only once, reverting to the 
previous image at the next boot. The Technician Interface displays the 
following prompt:

Do you want to start the download process? (y/n)[y]

7. Answer yes (y) to begin downloading the new image, overwriting the 
existing DCM software image.

The downloading process takes less than a minute.

8. Verify that the DCM software image is now Version 1.4.1 or 1.4.2.

See step 2 in the previous section, “Verifying Minimum DCM Requirements” 
on page C-2.
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Sample Display – dcmload.bat

Use this script to download a DCM image from the router’s
Flash to a DCM board. 

When prompted for the image file name, use the form
<volume:filename>. 

When prompted whether to save the image on the DCM Flash,
answer yes (y) to overwrite the existing image on the DCM
Flash with the new image. Answer no (n) to use the downloaded
image once, but lose it at the next boot.

Specify DCM image name (volume:filename): 1:in11_142.obj

Do you want DCM to save this image on its FLASH? (y/n) [y]: y

Image Name is 1:dcmboot.exe
Image will be saved by DCM in its FLASH

Do you want to start the download process? (y/n) [y]: y
Downloading of DCM image has started. It will take few seconds to complete
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Appendix D
Upgrading Router Software

Using Quick2Config

This appendix provides guidelines for upgrading your existing AN, ASN, or ANH 
router to BayRS Version 12.00 using Quick2Config. We assume that you have 
knowledge of basic Quick2Config operations. 

For detailed information about installing and using Quick2Config, refer to 
Installing the Quick2Config Tool and Configuring Your Router Using the 
Quick2Config Tool. 

To upgrade an AN, ASN, or AHH router to BayRS Version 12.00 using 
Quick2Config:

1. Copy the router software image file (asn.exe or an.exe) from the CD to 
your PC (refer to “Task 2: Upgrading to BayRS Version 12.00” on 
page 3-6.)

2. Start the Quick2Config application.

To learn how to start Quick2Config from Windows 95, refer to Configuring 
Your Router Using the Quick2Config Tool.

3. From the Starting Quick2Config Session Dialog Box, choose the Connect 
to a router on the network option (the default).

4. Click on OK.

If the IP address for the router appears in the connection list, choose it. 
Otherwise, enter the router’s IP address in the IP address box.
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5. Transfer the existing an.exe or asn.exe image from the router to the PC. 

a. Choose File > Router File Manager. 

The Router File Manager window opens.

b. Choose the an.exe or asn.exe image file name and the volume on 
which the image file resides.

If there are multiple volumes on the router, choose the correct volume. 

c. In the Router File Manager window, choose File > Get from Router > 
TFTP.

This step ensures that you have a backup of the existing image if you need 
it.

6. Remove the existing router software image from your router.

With the an.exe or asn.exe image file still selected (highlighted), choose
File > Delete from the Router File Manager window.

The Delete File Dialog Box opens. 

7. Click on OK to delete the file.

8. Compact the contents of the flash card.

In the Router File Manager window, choose File > Compact.

Make sure that you choose the same volume from which you just deleted the 
an.exe or asn.exe image file.

Compacting the flash card ensures that it contains enough contiguous free 
space to accommodate the new Version 12.00 software image.

9. Transfer the Version 12.00 an.exe or asn.exe image file from the PC to the 
router’s flash card.

In the Router File Manager window, choose File > Send to Router > TFTP. 

Be sure to transfer the new Version 12.00 software image to the same volume 
from which you removed the previous one.

10. Close the Router File Manager.

Choose File > Exit to exit the Router File Manager.
D-2 117404-A Rev. A



Upgrading Router Software Using Quick2Config
 

11. Boot the router with the new Version 12.00 image (an.exe or asn.exe).

Quick2Config boots the router using the specified router software image and 
configuration file.

Refer to Configuring Your Router Using the Quick2Config Tool for detailed 
instructions on booting a router using Quick2Config.
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Appendix E
Upgrading Version 7-9.xx Routers

This appendix summarizes how to upgrade Version 7-9.xx routers to BayRS 
Version 12.00 and Site Manager Version 6.00. It also describes the flash card 
format compatibility between routers running previous versions of the router 
software and describes how to convert the contents of a flash card to formats 
compatible with the current version of the router software.

To upgrade Version 7-9.xx routers to BayRS Version 12.00 and Site Manager 
Version 6.00, you must complete two upgrade procedures:

• Upgrade to Router Software Version 10.0 and Site Manager Version 4.0.

• Upgrade from Router Software Version 10.0 and Site Manager 4.0 to BayRS 
Version 12.00 and Site Manager 6.00.

Upgrading Routers from Router Software Version 7-9.xx to 
Version 10.00

To upgrade routers from Version 7-9.xx to Router Software Version 10.0 using Site 
Manager, complete the tasks in Table E-1.

Table E-1. Upgrading Routers from Version 7-9.xx to Version 10.0

To Do This Refer to Chapter

1. Back up your existing (Version 7.xx, 8.xx, 
or 9.xx) configuration file and router files 
on the router’s flash card.

“Backing Up Your Files” on page 2-10.

2. Upgrade to Site Manager 4.0. “Task 1: Upgrading to Site Manager 
Version 6.00” on page 3-2.

(continued)
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After you upgrade to Router Software Version 10.0 and Site Manager 4.0, you 
must now upgrade Version 10.0/4.0 to BayRS Version 12.00 and Site Manager 
Version 6.00. Go on to “Upgrading Routers from Router Software Version 10.0 to 
BayRS Version 12.00.”

3. Upgrade to Router Software Version 10.0 “Task 2: Upgrading to BayRS Version 
12.00” on page 3-6.

4. Customize the Router Software Version 
10.0 software image using the Image 
Builder.

“Task 3: Customizing the Router Software 
Image” on page 3-10.

5. Transfer the router software image 
(Version 7.x, 8.x, or 9.x) and Boot and 
Diagnostic PROM files to your 
workstation or PC. 

“Task 2: Transferring a Customized Image 
and Router Files to the Router” on 
page 4-5.

6. Using the Technician Interface, upgrade 
the Boot and Diagnostic PROMs on the 
router.

“Task 3: Upgrading and Verifying PROMs 
on the Router” on page 4-10.

7. Boot the router using the Version 10.0 
customized image and the existing 
configuration file.

“Task 1: Booting the Router with the 
Customized Image” on page 5-1.

8. Save the Version 10.0 configuration file to 
the router’s flash card.

This writes the configuration file in the 
router’s memory and saves it to the 
router’s flash card with a Version 10.0 
MIB stamp.

You now have a Version 10.0 software 
image and configuration file on the 
router’s flash card.

“Task 2: Upgrading the Existing 
Configuration File” on page 5-4.

Table E-1. Upgrading Routers from Version 7-9.xx to Version 10.0

To Do This Refer to Chapter
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Upgrading Routers from Router Software Version 10.0 to 
BayRS Version 12.00

To upgrade from Version 10.0/4.0 to BayRS Version 12.00 and Site Manager 
Version 6.00 using Site Manager:

1. Upgrade your PC or UNIX workstation to Site Manager Version 6.00.

See Task 1: Upgrading to Site Manager Version 6.00 on page 3-2.

2. Transfer the Version 12.00 software image and router files (including 
PROMs) to your Site Manager workstation or PC.

See “Task 1: Upgrading to Site Manager Version 6.00” on page 3-2.

3. Customize the Version 12.00 software image using Image Builder.

See “Task 3: Customizing the Router Software Image” on page 3-10.

4. Transfer the Version 12.00 image and PROM files to the router’s flash 
card.

See “Task 2: Transferring a Customized Image and Router Files to the 
Router” on page 4-5.

5. Using the Technician Interface, upgrade the PROM files, if necessary.

See “Task 3: Upgrading and Verifying PROMs on the Router” on page 4-10.

6. Exit from the router and install any required hardware.

7. Start the router and boot it using the 12.00 software image and the 
Version 10.0 configuration file.

See “Task 1: Booting the Router with the Customized Image” on page 5-1.

8. Save the configuration file using its old file name.

See “Task 2: Upgrading the Existing Configuration File” on page 5-4.

This saves the configuration file in the router’s memory and saves it to the 
router’s flash card with a Version 12.00 MIB stamp.

You now have a Version 12.00 software image and configuration file on the 
router’s flash card.
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Using Flash Cards from Previous Releases

All Bay Networks routers running Router Software Version 7.60 to 8.10, and 
AFNs running Router Software Version 7.5x, write to flash cards using a 68-space 
file format. Bay Networks BNs (BLN, BLN-2, and BCN) running Router 
Software Version 7.5x write to flash cards using a 61-space file format. 

Table E-2 shows which Bay Networks routers can read, write, and boot from the 
different file format types.

When a BN running Router Software Version 8.10 or 9.00 reads a flash card that 
contains files written by a BN running Router Software Version 7.5x, and you 
enter the dinfo command at the Technician Interface prompt, the display indicates 
that the volume is corrupted. If you request a directory of the volume’s contents 
(using the dir command), the display indicates that the contiguous free space is 0 
(zero). You can, however, read and boot from the files.

Table E-2. Flash Volume File Compatibility Between Routers Running Different 
Versions of Router Software

Files Written to 
Flash Memory 
by:

Router Capabilities to Read, Write, or Boot from Files

FNs, LNs, CNs, 
and BNs 
Running 
Versions 7.60, 
7.7x, 7.80, 8.0x, 
8.10, or 9.00

AFNs Running 
Versions 7.60, 
7.7x, 7.80, 8.0x, 
8.10, 9.00

BNs Running 
Version 7.5x

AFNs Running 
Versions 7.5x, 
7.60, 7.7x, 7.80, 
8.0x, 8.10, 9.00, 
10.00

Any router running 
Versions 7.60, 
7.7x, 7.80, 8.0x, 
8.10, 9.00 Read, Write, Boot Read, Write, Boot Read, Boot Read, Write, Boot

AFN running 7.5x Read, Write, Boot Read, Write, Boot Read, Boot Read, Write, Boot

BN running 7.5x Read, Write, Boot None Read, Write, Boot None
E-4 117404-A Rev. A



Upgrading Version 7-9.xx Routers
 

You must convert the contents of a flash card to a format compatible with the 
router software currently running on a BN router. You do this by copying the files 
to the router’s memory, reformatting the flash card, and copying the files in 
memory back to the flash card. Follow these steps:

1. Insert the flash card into the BN router.

2. Display the flash card’s directory.

In the Router Files Manager window, choose Command > Directory.

If the available free space and contiguous free space are equal, you cannot 
compact the flash card at this time; go to step 3. Otherwise, go to step 5.

3. Fragment the flash card volume so you can compact it.

Copy the smallest file on the flash card to the same volume, giving it a new 
file name. Choose Command > Copy from the Router Files Manager.

4. Delete the original file you created in step 3.

This fragments the volume, dividing the contiguous space on the flash card. 
This allows you to compact the contents of the flash card.

5. Compact the contents of the flash card.

In the Router Files Manage window, choose Commands > Compact.

The router copies and rewrites all of the files in the correct format for the 
software that is currently running.
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