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Bay Networks Software License

This Software License shall govern the licensing of all software provided to licensee by Bay Networks (“Software”). 
Bay Networks will provide licensee with Software in machine-readable form and related documentation 
(“Documentation”). The Software provided under this license is proprietary to Bay Networks and to third parties from 
whom Bay Networks has acquired license rights. Bay Networks will not grant any Software license whatsoever, either 
explicitly or implicitly, except by acceptance of an order for either Software or for a Bay Networks product 
(“Equipment”) that is packaged with Software. Each such license is subject to the following restrictions:

1. Upon delivery of the Software, Bay Networks grants to licensee a personal, nontransferable, nonexclusive license 
to use the Software with the Equipment with which or for which it was originally acquired, including use at any 
of licensee’s facilities to which the Equipment may be transferred, for the useful life of the Equipment unless 
earlier terminated by default or cancellation. Use of the Software shall be limited to such Equipment and to such 
facility. Software which is licensed for use on hardware not offered by Bay Networks is not subject to restricted 
use on any Equipment, however, unless otherwise specified on the Documentation, each licensed copy of such 
Software may only be installed on one hardware item at any time.

2. Licensee may use the Software with backup Equipment only if the Equipment with which or for which it was 
acquired is inoperative.

3. Licensee may make a single copy of the Software (but not firmware) for safekeeping (archives) or backup 
purposes.

4. Licensee may modify Software (but not firmware), or combine it with other software, subject to the provision 
that those portions of the resulting software which incorporate Software are subject to the restrictions of this 
license. Licensee shall not make the resulting software available for use by any third party.

5. Neither title nor ownership to Software passes to licensee.

6. Licensee shall not provide, or otherwise make available, any Software, in whole or in part, in any form, to any 
third party. Third parties do not include consultants, subcontractors, or agents of licensee who have licensee’s 
permission to use the Software at licensee’s facility, and who have agreed in writing to use the Software only in 
accordance with the restrictions of this license.

7. Third-party owners from whom Bay Networks has acquired license rights to software that is incorporated into 
Bay Networks products shall have the right to enforce the provisions of this license against licensee.

8. Licensee shall not remove or obscure any copyright, patent, trademark, trade secret, or similar intellectual 
property or restricted rights notice within or affixed to any Software and shall reproduce and affix such notice on 
any backup copy of Software or copies of software resulting from modification or combination performed by 
licensee as permitted by this license.

Note:  This is Bay Networks basic license document. In the absence of a 
software license agreement specifying varying terms, this license -- or the 
license included with the particular product -- shall govern licensee’s use of 
Bay Networks software.
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Bay Networks Software License (continued)

9. Licensee shall not reverse assemble, reverse compile, or in any way reverse engineer the Software. [Note: For 
licensees in the European Community, the Software Directive dated 14 May 1991 (as may be amended from time 
to time) shall apply for interoperability purposes. Licensee must notify Bay Networks in writing of any such 
intended examination of the Software and Bay Networks may provide review and assistance.]

10. Notwithstanding any foregoing terms to the contrary, if licensee licenses the Bay Networks product “Site 
Manager,” licensee may duplicate and install the Site Manager product as specified in the Documentation. This 
right is granted solely as necessary for use of Site Manager on hardware installed with licensee’s network. 

11. This license will automatically terminate upon improper handling of Software, such as by disclosure, or Bay 
Networks may terminate this license by written notice to licensee if licensee fails to comply with any of the 
material provisions of this license and fails to cure such failure within thirty (30) days after the receipt of written 
notice from Bay Networks. Upon termination of this license, licensee shall discontinue all use of the Software 
and return the Software and Documentation, including all copies, to Bay Networks.

12. Licensee’s obligations under this license shall survive expiration or termination of this license.
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About This Guide

If you are responsible for upgrading Bay Networks™ router software from 
Version 7-10.xx to Version 11.0, you need to read this guide. Refer to this guide 
for

• An overview of the router upgrade process and a summary of router upgrade 
tasks (Chapter 1)

• Router upgrade prerequisites and initial upgrade preparations (Chapter 2)

• Instructions for installing Site Manager 5.0 and Router Software Version 11.0 
files (Chapter 3)

• Instructions for transferring customized image files to the router (Chapter 4)

• Instructions for upgrading Boot and Diagnostic PROMs and configuration 
files (Chapter 5) 

• Examples that show you how to upgrade various Version 7-10.xx routers to 
Version 11.0 (Appendix A)

• Configuration-specific issues affecting router upgrades (Appendix B)

• Instructions for upgrading the DCM software image in AN and ANH routers 
(Appendix C)

• Instructions for upgrading router software using Quick2Config (Appendix D)

Audience

Written for system and network managers, this guide assumes that

• You have a working knowledge of Bay Networks router software, Site 
Manager, and the Technician Interface.

• You have experience managing and configuring Bay Networks routers.
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Before You Begin

Before using this guide, you must complete the following procedures:

• Ensure that your router is currently running a version of Bay Networks 
7-10.xx router software. Also, be sure that you are running Bay Networks Site 
Manager Version 1.xx or later.

• Ensure that the router you want to upgrade meets Version 11.0 hardware and 
Flash free-space prerequisites. If you need help meeting prerequisites, contact 
the Bay Networks Technical Response Center in your area.

• Install the router hardware.

For instructions, refer to one of the following guides:

-- Installing and Maintaining BN Routers

-- Installing and Maintaining ASN Routers and BNX Platforms

-- Installing and Starting BayStack AN Routers

-- Installing and Starting 8-Port BayStack ANH Systems

-- Installing and Maintaining FN, LN, CN, AFN, and ALN Routers

Conventions

angle brackets (< >) Indicate that you choose the text to enter based on the 
description inside the brackets. Do not type the 
brackets when entering the command. 
Example: if command syntax is ping <ip_address>, 
you enter ping 192.32.10.12

bold text Indicates text that you need to enter, command names, 
and buttons in menu paths.
Example: Enter wfsm &

Example: Use the dinfo command. 

Example: ATM DXI > Interfaces > PVCs identifies the 
PVCs button in the window that appears when you 
select the Interfaces option from the ATM DXI menu.

brackets ([ ]) Indicate optional elements. You can choose none, one, 
or all of the options.
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ellipsis points Horizontal (. . .) and vertical ellipsis points indicate 
omitted information. 

italic text Indicates variable values in command syntax 
descriptions, new terms, file and directory names, and 
book titles.

quotation marks (“ ”) Indicate the title of a chapter or section within a book.

screen text Indicates data that appears on the screen. 
Example: Set Bay Networks Trap Monitor Filters

separator ( > ) Separates menu and option names in instructions and 
internal pin-to-pin wire connections. 
Example: Protocols > AppleTalk identifies the 
AppleTalk option in the Protocols menu. 

Example: Pin 7 > 19 > 20

vertical line (|) Indicates that you enter only one of the parts of the 
command. The vertical line separates choices. Do not 
type the vertical line when entering the command.
Example: If the command syntax is 

show at routes | nets, you enter either 
show at routes or show at nets, but not both.

Acronyms

AFN Access Feeder Node

ALN Access Link Node

BOOTP Bootstrap Protocol

CPU Central Processing Unit

DCE Data Circuit-terminating Equipment

DTE Data Terminal Equipment

FTP File Transfer Protocol 

HDLC high-level data link control

HSSI high-speed serial interface

IP Internet Protocol

IPX Internet Packet Exchange

LAN local area network

...( )
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MAC media access control 

MIB Management Information Base

OSPF Open Shortest Path First

PPP Point-to-Point Protocol

PPX Parallel Packet Express

PROM Programmable Read-Only Memory

RAM random-access memory

RIP Routing Information Protocol

SIMM Single In-line Memory Module

SPEX-HS Stack Packet Exchange-Hot-Swaps

TFTP Trivial File Transfer Protocol

Ordering Bay Networks Publications

To purchase additional copies of this document or other Bay Networks 
publications, order by part number from the Bay Networks Press™ at the following 
telephone or fax numbers:

• Telephone - U.S./Canada 1-888-4BAYPRESS
• Telephone - International 1-510-490-4752
• Fax 1-510-498-2609

You can also use these numbers to request a free catalog of Bay Networks Press 
product publications. 
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Technical Support and Online Services

To ensure comprehensive network support to our customers and partners 
worldwide, Bay Networks Customer Service has Technical Response Centers 
in key locations around the globe:

• Billerica, Massachusetts

• Santa Clara, California

• Sydney, Australia

• Tokyo, Japan

• Valbonne, France

The Technical Response Centers are connected via a redundant Frame Relay 
Network to a Common Problem Resolution system, enabling them to transmit and 
share information, and to provide live, around-the-clock support 365 days a year.

Bay Networks Information Services complement the Bay Networks Service 
program portfolio by giving customers and partners access to the most current 
technical and support information through a choice of access/retrieval means. 
These include the World Wide Web, CompuServe, Support Source CD, Customer 
Support FTP, and InfoFACTS document fax service.
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Bay Networks Customer Service 

If you purchased your Bay Networks product from a distributor or authorized 
reseller, contact that distributor’s or reseller’s technical support staff for assistance 
with installation, configuration, troubleshooting, or integration issues.

Customers can also purchase direct support from Bay Networks through a variety 
of service programs. As part of our PhonePlus™ program, Bay Networks Service 
sets the industry standard, with 24-hour, 7-days-a-week telephone support 
available worldwide at no extra cost. Our complete range of contract and 
noncontract services also includes equipment staging and integration, installation 
support, on-site services, and replacement parts delivery -- within approximately 
4 hours.

To purchase any of the Bay Networks support programs, or if you have questions 
on program features, use the following numbers:

In addition, you can receive information on support programs from your local 
Bay Networks field sales office, or purchase Bay Networks support directly 
from your authorized partner.

Region Telephone Number Fax Number

United States and 
Canada 

1-800-2LANWAN; enter Express Routing 
Code (ERC) 290 when prompted 

(508) 436-8880 (direct)

(508) 670-8766

Europe (33) 92-968-300 (33) 92-968-301

Asia/Pacific Region (612) 9927-8800 (612) 9927-8811 

Latin America (407) 997-1713 (407) 997-1714
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Bay Networks Information Services

Bay Networks Information Services provide up-to-date support information as a 
first-line resource for network administration, expansion, and maintenance. This 
information is available from a variety of sources.

World Wide Web

The Bay Networks Customer Support Web Server offers a diverse library of 
technical documents, software agents, and other important technical information 
to Bay Networks customers and partners.

A special benefit for contracted customers and resellers is the ability to access the 
Web Server to perform Case Management. This feature enables your support staff 
to interact directly with the network experts in our worldwide Technical Response 
Centers. A registered contact with a valid Site ID can

• View a listing of support cases and determine the current status of any open 
case. Case history data includes severity designation, and telephone, e-mail, 
or other logs associated with the case.

• Customize the listing of cases according to a variety of criteria, including 
date, severity, status, and case ID. 

• Log notes to existing open cases. 

• Create new cases for rapid, efficient handling of noncritical network 
situations.   

• Communicate directly via e-mail with the specific technical resources 
assigned to your case.

The Bay Networks URL is http://www.baynetworks.com. Customer Service is a 
menu item on that home page.

Customer Service FTP

Accessible via URL ftp://support.baynetworks.com (134.177.3.26), this site 
combines and organizes support files and documentation from across the 
Bay Networks product suite, including switching products from our Centillion™ 
and Xylogics® business units. Central management and sponsorship of this FTP 
site lets you quickly locate information on any of your Bay Networks products.
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Support Source CD

This CD-ROM -- sent quarterly to all contracted customers -- is a complete Bay 
Networks Service troubleshooting knowledge database with an intelligent text 
search engine.

The Support Source CD contains extracts from our problem-tracking database; 
information from the Bay Networks Forum on CompuServe; comprehensive 
technical documentation, such as Customer Support Bulletins, Release Notes, 
software patches and fixes; and complete information on all Bay Networks 
Service programs. 

You can run a single version on Macintosh Windows 3.1, Windows 95, 
Windows NT, DOS, or UNIX computing platforms. A Web links feature enables 
you to go directly from the CD to various Bay Networks Web pages.

CompuServe

For assistance with noncritical network support issues, Bay Networks Information 
Services maintain an active forum on CompuServe, a global bulletin-board 
system. This forum provides file services, technology conferences, and a message 
section to get assistance from other users.

The message section is monitored by Bay Networks engineers, who provide 
assistance wherever possible. Customers and resellers holding Bay Networks 
service contracts also have access to special libraries for advanced levels of 
support documentation and software. To take advantage of CompuServe’s recently 
enhanced menu options, the Bay Networks Forum has been re-engineered to allow 
links to our Web sites and FTP sites.

We recommend the use of CompuServe Information Manager software to access 
these Bay Networks Information Services resources. To open an account and 
receive a local dial-up number in the United States, call CompuServe at 
1-800-524-3388. Outside the United States, call 1-614-529-1349, or your nearest 
CompuServe office. Ask for Representative No. 591. When you are on line with 
your CompuServe account, you can reach us with the command GO BAYNET. 
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InfoFACTS

InfoFACTS is the Bay Networks free 24-hour fax-on-demand service. This 
automated system has libraries of technical and product documents designed to 
help you manage and troubleshoot your Bay Networks products. The system 
responds to a fax from the caller or to a third party within minutes of being 
accessed.

To use InfoFACTS in the United States or Canada, call toll-free 1-800-786-3228. 
Outside North America, toll calls can be made to 1-408-764-1002. In Europe, 
toll-free numbers are also available for contacting both InfoFACTS and 
CompuServe. Please check our Web page for the listing in your country.

How to Get Help

Use the following numbers to reach your Bay Networks Technical Response 
Center:

Technical Response Center Telephone Number Fax Number

Billerica, MA 1-800-2LANWAN (508) 670-8765

Santa Clara, CA 1-800-2LANWAN (408) 764-1188

Valbonne, France (33) 92-968-968 (33) 92-966-998

Sydney, Australia (612) 9927-8800 (612) 9927-8811

Tokyo, Japan (81) 3-5402-0180 (81) 3-5402-0173
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Chapter 1
Router Upgrade Overview

This chapter describes the router upgrade process, summarizes the tasks that make 
up the router upgrade process, and provides a checklist of important guidelines 
and tips for upgrading routers. 

Router Upgrade Process

The process for upgrading routers from Version 7-10.xx to Version 11.0 consists of 
four separate phases as depicted in Figure 1-1. Each phase includes a series of 
tasks that you must perform. Complete each task by following its subordinate 
procedures and numbered steps.

The router upgrade process applies to the following Bay Networks routers:

• Access Feeder Node (AFN®) (with Flash)

• Access Link Node (LN®)

• Access Node (AN®)

• BayStack™ Access Node 

• Access Node Hub (ANH™)

• BayStack Acess Node Hub

• Access Stack Node (ASN™)

• Backbone Concentrator Node (BCN®)

• Backbone Link Node (BLN®)

• Concentrator Node (CN®)

• Feeder Node (FN®)



Upgrading Routers from Version 7-10.xx to Version 11.0
Figure 1-1. Router Upgrade Process

Phase 1:
Preparing to Upgrade 

Phase 2:
Starting the Upgrade

Phase 3:
Continuing the Upgrade 

Phase 4:
Completing the Upgrade 

• Verify upgrade prerequisites

• Satisfy startup requirements

• Inspect your upgrade kit

• Review configuration-specific issues

• Prepare the router 
                       to accept router software image

                     • Transfer a customized software
  		image to the router  

• Upgrade PROMs

         • Boot the router with the
                 customized software image

												   • Upgrade configuration files 

											                         • Upgrade Frame Relay circuits (optional)

                       • Transfer script files to the router

 

• Install Site Manager Version 5.0

• Install Router Software Version 11.0

• Customize router software image
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Router Upgrade Task Summary

Table 1-1 summarizes the tasks that make up the router upgrade process. Refer to 
this table when you need to find information about a specific upgrade topic 
quickly.

Table 1-1. Router Upgrade Task Summary  

To Do This
Refer to 
Chapter

Satisfy startup requirements 2, Task 1

Inspect your upgrade kit to ensure that it contains the requisite router and Site Manager 
upgrade components. (Refer to Table 2-4.)

2, Task 2

Review configuration-specific issues affecting router software upgrades 3, Task 3

Upgrade the Distinct TCP/IP stack (or WinSock-compatible TCP/IP stack) and Site 
Manager on a PC
Upgrade Site Manager on a UNIX workstation. 

3, Task 1

Install the router software on your PC or UNIX workstation:

1. Load the router software from CD-ROM onto your PC or UNIX workstation. 
2. Load the router software into the Image Builder.

3, Task 2

Customize the Version 11.0 router software image by removing nonessential files. 3, Task 3

Back up Version 7-10.xx software image and config files to ensure that you can restore 
router operation in case the router malfunctions during the upgrade process.

3, Task 4

Preparing the router to receive a new software image:

• Prepare a router with one Flash card
• Prepare a router configured for Netboot
• Prepare a router with multiple Flash cards

4, Task 1

Transfer a customized image to the router 4, Task 2

Upgrade Boot and Diagnostic PROMs in the router:

1. Determine whether you need to upgrade Boot and Diagnostic PROMs in your router.
2. Determine the current PROM version.
3. Methods for upgrading PROMs
4. Upgrade and verify PROMs.
5. Upgrade PROMs in a router from a remote site.

5, Task 1

(continued)
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Router Upgrade Checklist 

Review the following items in this checklist before you begin the router upgrade 
process:

1. Check your hardware requirements, the amount of contiguous free space 
on your Flash volume, and the version of your Boot PROM.

Refer to “Router Upgrade Prerequisites” in Chapter 2.

2. Identify the version of router software you are currently running. You 
should be running Router Software Version 7-10.xx.

If you plan to run RMON on a version 11.0 AN or ANH router, you must first 
upgrade the DCM software image version to 1.4. For instructions on 
upgrading the DCM software image, refer to Appendix C.

3. Identify the hardware configuration of the router you want to upgrade 
(router model, link modules, and slot assignments for link modules).

4. Gather the manuals you will need to refer to during the router upgrade 
process (refer to Table 1-2.) This manual provides only general guidelines 
for completing the router upgrade tasks.

Boot the router with your customized software image:

1. Prepare the router to receive a customized software image.
2. Transfer a new software image to the router.
3. Boot the router with the customized software image.

5, Task 2

Upgrade your existing Version 7.xx, 8.xx or 9.0x configuration files to Version 11.0:

• Booting the 7-10.xx configuration file
• Saving the configuration file in dynamic mode
• Rebooting the router with a new configuration file

5, Task 3

Delete and reconfigure interfaces on which Frame Relay was configured. 5, Task 4

Transfer selected Version 11.0 Technician Interface script files from your Site Manager PC 
or workstation to a router.

5, Task 5

Table 1-1. Router Upgrade Task Summary  (continued)

To Do This
Refer to 
Chapter
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5. Review the configuration-specific issues that affect router upgrades to 
determine whether they apply to your current situation.

Appendix B describes configuration-specific issues affecting router upgrades. 
If you are upgrading routers in an environment that includes any of the 
situations shown in refer to Table 1-3., follow the instructions on the pages 
indicated.

*. If you use a Windows Socket-supported TCP/IP stack other than Distinct TCP/IP Version 3.31 to 
support Site Manager, refer to the user documentation supplied by the manufacturer of the TCP/IP 
stack for installation instructions.

Table 1-2. Reference Books for Upgrading Routers 

To Do This Refer to These Books

Upgrade the Distinct TCP/IP Stack and 
Site Manager on a PC*

Quick-Starting Routers and BNX Platforms;
Distinct TCP/IP for Microsoft Windows Run 
Time Installation and Configuration Guide

Upgrade Site Manager on a UNIX 
workstation

Quick-Starting Routers and BNX Platforms

Install router software on a PC or UNIX 
workstation

Modifying Software Images for Routers

Customize the router software image Modifying Software Images for Routers;
Managing Routers and BNX Platforms

Transfer your customized image to the 
router

Managing Routers and BNX Platforms

Boot the router with a customized image Modifying Software Images for Routers

Upgrade Boot or Diagnostic PROMs in a 
router

Using Technician Interface Software

Upgrade configuration files on the router Configuring Routers

Table 1-3. Configuration-specific Situations Affecting Router Upgrades

Configuration-specific Situation Refer to Page

Routers passing X.25 certification B-1

Standard Point-to-Point connections over synchronous lines B-3

Switched Services enhancements and compatibility B-4

PPP multiline migration B-6
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Chapter 2
Preparing to Upgrade

This chapter describes prerequisites for upgrading routers from Version 7-10.xx to 
Version 11.0. It also provides helpful tips for upgrading routers and describes 
initial router upgrade preparations.

Router Upgrade Prerequisites

Do not begin the router upgrade process until you verify that the router you want 
to upgrade meets the prerequisites described in this chapter for

• Minimal hardware and configuration requirements

• Contiguous free space on a Flash volume

Minimum Hardware and Configuration Requirements

Before you upgrade to Router Software Version 11.0, perform the following steps 
to ensure that your router meets all minimum hardware configuration and revision 
level requirements.

1. Check the Flash memory requirements for the router you are upgrading.

Ensure that you have adequate Flash memory to accommodate the Version 
11.0 router software. 

2. Complete any planned (optional) upgrade from 2-MB Flash to 
4-MB or 8-MB Flash support on your router. 

Note: If you need help meeting the hardware prerequisites of the Version 11.0 
router software upgrade procedure, contact the Bay Networks Technical 
Response Center in your area.
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This procedure includes a Boot PROM upgrade for the processor module in 
which your Flash card resides. For example, if you have a VME-based router, 
you upgrade your Flash card on a System Controller 2 (SYSCON-II) card. If 
you have a BN router, you upgrade your Flash card in each of your FRE or 
FRE-2 processor modules.

Router Software Version 11.0 supports 8-MB Flash capability on BN and 
ASN routers. Before you upgrade your 8-MB Flash card with Router 
Software Version 11.0, make sure that you upgrade your Boot PROM to 
Version 8.00 or later. 

Support for 4-MB Flash capability began with Version 8.00 of the router 
software.

3. Determine whether any other new router hardware depends on software 
or PROM upgrades to work properly. 

For example, an ASN SPEX™-HS requires a Diagnostic PROM upgrade to 
Version 2.16 before you install the new backplane module. Without the 
Diagnostic PROM upgrade, the ASN router will fail to pass diagnostics and 
will fail to boot. 

4. Complete any planned physical installations of the following router 
hardware:

• Spare FRE®/FRE-2 controllers in your Version 7-10.xx BLN, BLN-2, or 
BCN router

• Additional/spare ASNs on your Version 8.xx, 9.xx, or 10.0 ASN router

• New link modules in the router

Caution: The version of the Boot PROM you use to support 4-MB Flash cards 
in the router also has significant implications for router software image 
management within your network. (The router software image names for 
Version 8.10 and later have changed.) More detailed information on Boot 
PROMs and the new image-naming conventions follow later in this chapter.
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Contiguous Free Space on a Flash Volume

You must determine the amount of contiguous free space required on a Flash card 
to accommodate your customized Version 11.0 router software image and 
configuration files. The amount of contiguous free space available on the target 
Flash volume must be greater than the combined size of your customized Version 
11.0 image and associated files (such as config, ti.cfg, install.bat, and, if 
appropriate, a Version 11.0 PROM image).

To obtain the amount of contiguous free space available on a selected volume, see 
the fields at the bottom of the Router Files Manager window in Site Manager 
(Table 2-1).

Router Upgrade Hints and Tips

The following sections offer helpful hints and tips for upgrading router software 
from Version 7-10.xx to Version 11.0. Review these sections before beginning the 
upgrade process.

• “Backing Up Your Files”

• “Compacting a Flash Memory Card”

• “Verifying Router Software Image Names”

• “Verifying Current PROM Version”

• “Maintaining Consistent Files in Multiple Memory Cards”

• “Responding to a Failed prom Command”

Table 2-1. Determining Contiguous Free Space on Flash Card from 
Router Files Manager Window

Field Meaning

Total SIze Total number of bytes (used and unused) on the volume.

Available Free Space Number of unused bytes on the volume. 

Contiguous Free Space Number of unused bytes in the largest block available on 
the volume. This space is actual usable memory.
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Backing Up Your Files

Store backup copies of the configuration files on the Site Manager workstation. To 
prevent confusion, use a log to record the location, name, and purpose of each 
configuration file you back up. Organizing and naming the backup files on the Site 
Manager workstation will also help you prevent mix-ups.

Compacting a Flash Memory Card

You compact a Flash memory card to free up space taken by deleted files. This 
ensures that the Flash card has enough contiguous free space to accommodate the 
new Version 11.0 software image.

You should compact your Flash card during “off-peak” hours if possible, due to 
resource requirements to perform the compaction (FRE memory and CPU cycles). 
Do not remove a Flash card, hot-swap a slot, or reset a slot during a Flash card 
compaction as the Flash card will become corrupted, causing loss of data.

Compacting a Flash Memory Card from Site Manager

To compact a Flash memory card from Site Manager, the Compact option in the 
File Manager Commands menu.

Compacting a Flash Memory Card from the Technician Interface

To compact a Flash memory card from the Technician Interface, enter the 
compact <volume>: command. For example, enter compact 2: to compact the 
files in Volume 2. The file system copies all of the files to memory except for the 
deleted ones, erases the memory card, and copies the files back to the memory 
card.

Caution: Always back up a file before deleting it. This includes configuration 
and log files. And always back up the current log file on the Site Manager 
workstation before clearing it; you may want to refer to it later to troubleshoot 
a problem.

Note: A Flash compaction operation may take up to 12 minutes on an AN 
router. Do not power cycle the AN router during compaction. If you attempt to 
power cycle the AN router, the Flash card will be corrupted and will not boot.
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Viewing the Status of the Flash Memory Card

To view the status of a memory card, display its directory. The directory display 
shows the amount of “available free space” or “free space,” and the amount of 
“contiguous free space.”

The “available free space” or “free space” is the total number of bytes of unused 
space and bytes of space used by files that are deleted.

In order for the memory card to accommodate a file, the file’s size must be less 
than or equal to the “contiguous free space.” The “contiguous free space” is the 
number of bytes of unused space.

If the file you want to store is less than the “available free space,” but more than 
the “contiguous free space,” compact the existing files first. When you finish 
compacting files on a memory card, the “contiguous free space” matches the 
“available free space.” 

Verifying Router Software Image Names on the Router

Make sure that the router software image on the router is compatible with the type 
of router you are using. A router software image is a group of executable files that 
contains the operating system and protocols on your network with a Bay 
Networks router. The type of software image a router uses depends on the 
particular Bay Networks router you are trying to boot. 

Starting with Version 8.10 of the router software, Bay Networks implemented a 
new naming convention for router software image files in all routers except the 
FN, ALN, LN, and CN. The new naming convention provides the following 
benefits:

• Simplifies how you manage router software image files on your Site Manager 
workstation

• Reduces the complexity of performing future upgrades in a network 
containing different routers
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Table 2-2 lists the Version 11.0 router software images for each router platform 
and the device (Flash card or SIMMs) on which the image runs. If you are using a 
lower version of Bay Networks router software, refer to the appropriate version of 
this guide for details on router software images. 

Refer to Modifying Software Images for Routers for detailed information about 
software images.

Verifying Current PROM Version

You can use Site Manager or the Technician Interface to determine the current 
version of Boot and Diagnostic PROM images currently running in your router. 

Table 2-2. Router Software Image Types 

Router
Router Software 
Image

Device That Image 
Runs On

ARE bn.exe Flash card

5780 ARE s5000.exe Flash card

AFN (Flash) afn.exe Flash card

IN in.exe Flash card

ASN asn.exe Flash card

BLN bn.exe Flash card

BCN bn.exe Flash card

AN an.exe Flash Single Inline 
Memory Modules 
(SIMMs)

BayStack AN an.exe Flash card

CN, FN, LN (VME) ace.out Flash card
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Table 2-3 lists the Version 11.0 Boot and Diagnostic PROM filenames and 
associated revision numbers for the various router platforms. 

See Chapter 5 “Upgrading PROMs and Configuration Files” for instructions on 
how to verify the current PROM version on your router.

Maintaining Consistent Files in Multiple Memory Cards

If the router uses multiple memory cards, make sure that each file is consistent in 
each memory card designated for storing files of that type. For example, if you 
make a change to a router software image or configuration file, save the file to 
each memory card that contains the same files.

To make sure that the files of the same name are consistent on multiple memory 
cards, display the directory of each card and compare the sizes of each file.

Refer to Troubleshooting Routers for more information.

Table 2-3. Version 11.0 Boot and Diagnostic PROM Revisions

Router
Platform

Diagnostic PROM
Filename 

Diagnostic PROM
Revision
Number

Boot PROM
Filename

Boot PROM 
Revision
Number

AN andiag.exe v7.22 anboot.exe rel/9.00

ARE arediag.ppc v1.12 areboot.ppc rel/9.01

BN frediag.exe v4.10 freboot.exe rel/8.10

ASN asndiag.exe v2.18 asnboot.exe rel/10.00 

LN/CN No Diagnostic PROM shipped vmeboot.exe rel/8.11

AFN v3.04 combination boot and diagnostic 
PROM

Not applicable Not applicable
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Responding to a Failed prom Command

If you reboot after the prom command fails, a Bay Networks representative must 
reinsert new PROMs (programmable, read-only memory chips) on the board and 
rewrite the PROM software to them before the router can recover.

Initial Upgrade Preparations

Initial preparation for upgrading router software from Version 7-10.xx to Version 
11.0 consists of the following tasks, each of which is described in greater detail in 
this chapter.

• Task 1: Satisfying Startup Requirements

• Task 2: Inspecting your Upgrade Kit

• Task 3: Reviewing Configuration-specific Issues Affecting Router Software 
Upgrades 

Task 1: Satisfying Startup Requirements

Before you begin the router upgrade procedure, ensure that

• You identify the version of router software you are currently running. You 
should be running Router Software Version 7-10.xx.

Also, if you plan to run RMON on a Version 11.0 AN or ANH router, you 
must first upgrade the DCM software image to Version 1.4; DCM software 
images earlier than Version 1.4 cannot be used with Router Software Version 
11.0. 

• You identify the hardware configuration of the router you want to upgrade 
(router model, link modules, and slot assignments for link modules).

• You have considered your memory requirements carefully. Based on the 
number of protocols installed on your router, you may require additional 
memory to run these protocols.

Caution: If the Technician Interface prom command fails, do not reboot. 
Instead, call the Bay Networks Technical Response Center.
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If you have questions regarding memory requirements, contact the Bay 
Networks Technical Response Center in your area.

• You have a working knowledge of the operating system and the windowing 
software on the UNIX workstation or PC you will use to run Site Manager 
software.

• You have a 4-MB or 8-MB Flash card (depending on your router type) on 
which to store the Version 11.0 router software image and associated files. A 
2-MB Flash card will no longer accommodate the Version 11.0 router 
software image and associated files. 

• You have considered minimum hardware revisions (for example, a link 
module with hot-swap capability may require a hardware revision for
Version 11.0). 

• You have read these Bay Networks publications:

-- Read Me First: Router Software 11.0 and Site Manager 5.0

-- Release Notes for Router Software Version 11.0

-- Release Notes for Site Manager Software Version 5.0

-- Known Anomalies: Router Software 11.0 and Site Manager 5.0
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Task 2: Inspecting Your Upgrade Kit

Check your upgrade kit to ensure that it contains the Router Software Version 11.0 
and Site Manager Version 5.0 upgrade components listed in Table 2-4. 

*. Distinct TCP/IP Version 3.31 is a Windows Sockets (WinSock) compatible TCP/IP application program that ships with 
Site Manager 5.0. Site Manager uses Distinct TCP/IP software to communicate with Bay Networks routers.

Table 2-4. Router Software and Site Manager Software Upgrade Components 

Component
Software Storage Media 
and Printed Media

Management Platform

Router Software Version 11.0 includes

• Platform-specific Router Software image files 
• Platform-specific Boot and Diagnostic image 

files
• config file
• debug.al file
• install.bat file
• ti.cfg file
• ti_asn.cfg file (for ASN router only)

Site Manager Software Version 5.0 includes

• Technician Interface Scripts
• Distinct TCP/IP Version 3.31 for Site 

Manager*

CD-ROM on High Sierra file 
format

UNIX workstation or
Windows/DOS PC

Version 11.0 online documentation library CD-ROM on High Sierra file 
format

UNIX workstation or
Windows/DOS PC

Version 11.0 upgrade documentation:

• Router upgrade document
(Version 7-10.xx to Version 11.0)

• Site Manager Release Notes
• Router Software Release Notes
• Read Me First (if available)
• Known Anomalies 

Printed media UNIX workstation or
Windows/DOS PC

Distinct TCP/IP for Microsoft Windows Run 
TIme Installation and Configuration Guide

Printed media UNIX workstation or
Windows/DOS PC
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Task 3: Reviewing Configuration-specific Issues Affecting Router 
Software Upgrades

Depending on the current configuration of your Version 7-10.xx router, there may 
be configuration-specific issues that you need to consider before you begin the 
upgrade process. If you are upgrading routers in an environment that includes any 
of the following configuration-specific situations, see Appendix B for detailed 
information:

• X.25 Certification requirements

• Standard Point-to-Point (PPP) connection guidelines

• Switched Services enhancements and compatibility issues 

• PPP multiline migration issues 

If none of these situations applies to the router you are upgrading, go to Chapter 3 
to begin the router upgrade process.
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Chapter 3
Starting the Upgrade:

Upgrading Site Manager and Router Software

This chapter describes how to

• Upgrade Site Manager Version 5.0 and Router Software Version 11.0 files on 
your PC or UNIX workstation.

• Install the Router Software on a PC or UNIX workstation

• Customize the router software image

• Backup the existing router software image and configuration files
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Task 1: Upgrading to Site Manager Version 5.0

This section provides general guidelines for upgrading Site Manager 5.0 software 
and Distinct TCP/IP for Microsoft Windows on your PC. It also provides general 
guidelines for upgrading Site Manager on your UNIX workstation. Go to the 
section you need, as shown in Table 3-1.

For detailed information about the Distinct product, refer to Distinct TCP/IP for 
Microsoft Windows Run Time Installation and Configuration Guide, the Distinct 
Corporation documentation supplied with Site Manager. Also, check the Bay 
Networks Read Me First documentation for changes to the installation 
instructions. For detailed information about installing Site Manager on your PC or 
workstation, refer to Quick-Starting Routers and BNX Platforms.

Upgrading the Distinct TCP/IP Stack and Site Manager on a PC

Site Manager on the PC uses a Windows Socket-compatible TCP/IP stack to 
communicate across the IP network. Before you can upgrade to Site Manager 5.0 
on your PC, you must first upgrade the TCP/IP stack and configure it properly.

Site Manager ships with the Distinct TCP/IP for Microsoft Windows software, 
Version 3.31, a Distinct Corporation application. Distinct TCP/IP provides an 
interface between Site Manager and the TCP/IP network. Earlier versions of 
Distinct TCP/IP will not work with Site Manager 5.0 for the PC. 

Note: You can use Quick2Config instead of Site Manager 5.0 to configure AN, 
ANH, and ASN routers to support Router Software Version 11.0. For 
instructions on how to upgrade an AN, ANH, or ASN to Router Software 
Version 11.0 using Quick2Config, see Appendix D.

Table 3-1. Upgrading Site Manager on a PC or UNIX Workstation

If you are Go to section On page

Using a personal computer (PC) Upgrading the Distinct TCP/IP Stack 
and Site Manager on a PC

page 3-2

Using a Sun SPARCstation,
IBM RS/6000, or HP 9000

Upgrading Site Manager on a UNIX 
Workstation

page 3-6
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If you use another Windows Socket-supported TCP/IP stack to support Site 
Manager, refer to the user documentation supplied by the manufacturer of the 
TCP/IP stack for installation instructions. You do not have to install Distinct and 
can go to Step 4 of this procedure. For a complete list of Windows 
Socket-supported TCP/IP stacks supported by Site Manager 5.0, refer to 
Quick-Starting Routers and BNX Platforms.

Upgrading the Distinct TCP/IP Stack 

To upgrade Distinct TCP/IP for Microsoft Windows on your PC:

1. Prepare information for Distinct installation.

The Distinct installation prompts you to provide:

• Serial number and key code information

• Network interface card and driver information

• Network configuration information

For detailed instructions on preparing for the Distinct installation, refer to 
Quick-Starting Routers and BNX Platforms.

2. Delete all existing Distinct files.

Enter the following command at the DOS prompt:

del c:\windows\distinct\*.*

c is the name of the hard drive.

3. Remove the Distinct directory.

Enter the following command at the DOS prompt:

rmdir c:\windows\distinct

When you start the Site Manager installation program, the system 
automatically creates a new directory (\distinct) into which it installs the 
Distinct TCP/IP software.

Note: If the Distinct files and directory are stored in a path other than that 
indicated in Steps 2 and 3, enter the del and rmdir commands with the 
appropriate path.
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4. Install the Distinct TCP/IP software.

You can install the Distinct TCP/IP software from the Site Manager CD or 
from a disk. Refer to Quick-Starting Routers and BNX Platforms for 
instructions on installing the Distinct TCP/IP software.

5. Test the Distinct TCP/IP configuration.

Use the Distinct Ping function to send an echo request to the router after 
installing and configuring Distinct TCP/IP. This procedure tests your network 
and your Distinct configuration.

Upgrading Site Manager

To upgrade Site Manager on your PC:

1. Check the system requirements.

Ensure that your PC complies with the Site Manager Version 5.0 system 
requirements listed in Quick-Starting Routers and BNX Platforms.

2. Delete the Site Manager state files.

Enter the following command:

del   c:\wf\*.sts

c is the name of the hard drive.

State files describe the state of the application when you last exited it. Site 
Manager creates state files for all Site Manager tools you use.

3. Install the Site Manager software.

Note: Make sure that you have successfully loaded Distinct before installing 
Site Manager. If the Distinct installation is unsuccessful, review Appendix C 
“Trouble Shooting,” in the Distinct TCP/IP for Microsoft Windows Run Time 
Installation and Configuration Guide.

Note: If you do not delete the state files before you install the new version of 
Site Manager on your PC, Site Manager may not function properly when you 
restart it.
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Site Manager software is distributed on CDs and disks. Refer to the 
appropriate section in Quick-Starting Routers and BNX Platforms for 
instructions on installing both types of media on your PC.

4. Start up the Site Manager application from Windows.

a. Select the Site Manager program group.

b. Double-click on the PC/Site Manager icon.

The Site Manager window appears (Figure 3-1).

Figure 3-1. Site Manager Window

Note: Do not update the config.sys file or copy the driver file to the c:\etc 
directory; you did this when you initially installed Site Manager. 
If a window prompts you to choose options that involve adding new icons 
while you are installing Distinct, select “Do not create any new icon” and click 
on OK.
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After you finish upgrading Site Manager software on your PC, go to
Task 2: “Installing the Router Software on a PC or UNIX Workstation.”

If you are having problems upgrading Site Manager, refer to Troubleshooting 
Routers.

Upgrading Site Manager on a UNIX Workstation

To upgrade the Site Manager software on a Sun SPARCstation (running SunOS or 
Solaris OS), IBM RS/6000, or HP 9000 UNIX workstation:

1. Check system requirements.

Ensure that your UNIX workstation complies with the Site Manager 
Version 5.0 system requirements listed in Quick-Starting Routers and BNX 
Platforms.

2. Get superuser privileges.

Enter the following command at the UNIX prompt:

su

3. Delete the Site Manager state files.

Enter the following command from the home directory of every user account:

r m  <home_directory>/.wf*

Site Manager creates state files for all Site Manager tools you use. State files 
describe the state of the application when you last exited it.

Note: Exit from the current version of Site Manager before you delete any Site 
Manager files. Otherwise, the new version of Site Manager will not overwrite 
all of the current version files.

Note: If you do not delete the state files before you install the new version of 
Site Manager on your workstation, Site Manager may not function properly 
when you restart it.
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4. Refer to the appropriate section in Quick-Starting Routers and BNX 
Platforms to install the Version 5.0 Site Manager software.

After you finish upgrading Site Manager on your UNIX workstation, go to
Task 2: “Installing the Router Software on a PC or UNIX Workstation.”

Task 2: Installing the Router Software on a PC or UNIX 
Workstation

This section describes how to install Router Software Version 11.0 on your Site 
Manager Software Version 5.0 PC or UNIX workstation. For more detailed 
information about installing the router software, refer to Modifying Software 
Images for Routers.

Loading Router Software onto a PC or UNIX Workstation 

Bay Networks router software is available on CD-ROM only. The steps that you 
follow to load the router software from CD-ROM depend on whether you use a 
PC or a UNIX workstation. Table 3-2 outlines the steps that you must perform to 
load the router software from CD-ROM to your PC or UNIX workstation.

If you are using
See the following section in Quick-Starting 
Routers and BNX Platforms

Sun SPARCstation running SunOS or 
Solaris

Installing Site Manager on a SPARCstation

IBM RS/6000 Installing Site Manager on an IBM RS/6000

HP 9000 Installing Site Manager on an HP 9000
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Table 3-2. Loading the Router Software from CD-ROM to a PC or Workstation 

Step On a PC On a UNIX Workstation

1 Insert the CD-ROM into CD-ROM 
drive.

Insert the CD-ROM into your CD-ROM drive.

2 Bring up Windows. If you have not already created a CD-ROM mountpoint, log in 
as root and create a root-level directory.

For example, enter

mkdir /cdrom

3 Double-click on the File Manager 
icon.

Mount the CD-ROM drive.

SunOS on a SPARCstation Solaris on a SPARCstation

Enter this command:

mount -r -t hsfs 
/dev/<device> /cdrom

Enter this command:

mount -F hsfs -o ro 
/dev/<device> /cdrom

IBM RS/6000 HP 9000

Enter this command:

mount -o ro -v cdrfs
/dev/<device> /cdrom

Enter this command:

mount -r /dev/<device>
/cdrom

4 Click on the CD-ROM drive icon in 
the File Manager window.

Change directories by entering 

cd /cdrom

(continued)
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You can now load the router software into the Image Builder, as described in the 
next section.

5 Click on the rtr_xxx directory, 
where xxx is the router software 
version.

For example, for Version 11.0, you 
would click on the rtr_1100 
directory.

Run the script to load the router software using one of the 
following commands:

On a SPARCstation, enter

./COPY.SH

On an IBM RS/6000, enter

./copy.sh

On an HP 9000, enter

./COPY.SH\;1

6 Click on the directory for your 
router platform.

During the load procedure, you must specify the following:

• The directory where you want to load the router software
• The router platform: AFN (Flash), AN, ASN, BN, or VME

The system then loads the software for the platform you 
selected.

7 Select File > Copy.

8 Specify the destination directory:

\wf\xxx

xxx is the version of the router 
software.

9 Click on OK.

The system loads the router 
software for the platform you 
selected. When the process is 
complete, you can load the router 
software for any of the other 
platforms by repeating Steps 6-9.

Table 3-2. Loading the Router Software from CD-ROM to a PC or Workstation (continued)

Step On a PC On a UNIX Workstation
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Loading Router Software into the Image Builder

After you have loaded the router software from CD-ROM onto the local hard 
drive of your UNIX workstation or PC, you must load the router software into the 
Image Builder. You use the Image Builder to customize the router software image 
to fit your router configuration requirements.

To load the router software into the Image Builder:

1. Start Image Builder.

Select Tool > Image Builder from the main Site Manager window. 

The Image Builder window opens.

2. Select File > Open from the Image Builder window. 

The Open window appears (Figure 3-2).

Figure 3-2. Open Window

3. Select the directory and filename of the router software image that you 
want to open. Then click on OK.
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The directory and filename that you specify depend on the following:

• The computer platform (UNIX workstation or PC)

• The router platform

If you loaded the router software from CD-ROM onto a UNIX workstation, the 
system stored the software image in the directory for the appropriate router 
platform. For example, you would find the image ace.out for the VME platform in 
the vme directory.

If you loaded the router software onto a PC, the system stored the software image 
in the directory you created for the router software (\wf\xxx).

After you enter the pathname of the image, the Image Builder window lists the 
current components of the Version 11.0 router software image in the Image 
Builder window (Figure 3-3).

Figure 3-3. Image Builder Window with Current Components
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Chapter 4
Continuing the Upgrade:

Transferring Customized Files to the Router

This chapter describes how to

• Prepare the router to receive a new software image

• Transfer your customized image to the router

Task 1: Preparing the Router to Receive a New Software 
Image

Before you can transfer a customized image to the router you want to upgrade, 
you must first prepare the router’s Flash card or Flash SIMM to receive a 
customized image and a configuration file. Refer to the following table for further 
instructions.

If the number of Flash memory 
cards in the router is Refer to This Section

1 Preparing Routers with One Flash Card or
Preparing Routers Configured for Netboot

Greater than 1 Preparing a Router with Multiple Flash 
Cards

Greater than 1 (and the cards contain 
files for an earlier release of the router 
software)

Using Flash Cards from Previous Releases
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Preparing Routers with One Flash Card

To prepare a router equipped with one Flash card to accept a customized software 
image:

1. Verify that you have backed up the router’s Version 7-10.xx boot image to 
your Site Manager workstation.

You saved a copy of the Version 7-10.xx boot image when you backed up the 
router software image and configuration files in Chapter 3.

2. Load all the .str files from the router’s Flash card into the router’s 
memory by entering the following command from the Technician 
Interface:

string load

It is important that you load the .str files into the router’s memory before 
deleting the previous router software image (Step 3). If you fail to load the .str 
files and then delete the previous router software image from the router’s 
Flash card, the software image running in memory may need to pull some .str 
files from the image that was previously stored on the Flash. However, that 
image no longer exits or has been partially updated to a new software image. 

3. Delete the current router software image (for example, an.exe, asn.exe, or 
bn.exe) from the router’s Flash card by selecting Commands > Delete in 
the File Manager window.

Perform this step if the router is an AN and your network is not configured to 
perform a Netboot operation on an AN router.

4. Compact the router’s Flash card.

Select Commands > Compact from the Router Files Manager window.

A message appears asking whether you want to proceed with the file 
compaction.

Note: AFN routers support only one Flash card. AN routers support only one 
SIMM.
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You compact the Flash card to ensure that it has enough contiguous free space 
to accommodate the Version 11.0 software image.

5. Click on Yes in the message window.

An hourglass appears for the duration of the file compaction. After several 
minutes, a window displays the following message, where x is the volume you 
are compacting:

Last file system command, “compact x:” finished successfully.

Go to “Transferring a Customized Image to the Router.”

Preparing Routers Configured for Netboot

If you have an AN or ASN router with one Flash card and you have configured 
your router to boot off the network (using Netboot or Directed Netboot), consider 
the following:

• Do not delete the Version 7-10.xx boot image from the router’s Flash card.

You may need a backup boot image in case the new boot image is corrupted. 

• Do not compact the contents of the card.

• Netboot the AN router from a customized Version 11.0 router software image 
residing on a BOOTP server in your network. 

With this approach, the Version 11.0 image runs in active memory on the 
router, but the Version 7-10.xx image remains available on the router’s Flash 
card as a backup.

After you verify that the Netboot operation ran successfully, you might decide to 
install the Version 11.0 image on the AN Flash SIMM, ASN (Flash), or 
BayStack™ Flash card. You do this to ensure that the router software version 
stored in the router’s memory is compatible with the one stored on the AN Flash 
SIMM, ASN Flash, or BayStack Flash card. By installing the Version 11.0 router 
software image onto the SIMM Flash or a Flash card, you will have a backup 
version of the 11.0 image in case the Netboot operation fails.

Note: The AN may require approximately 12 minutes to finish compacting its 
Flash file space.
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Before you install the Version 11.0 image on Flash SIMM or Flash card, follow 
these steps:

1. Delete the Version 7-10.xx image from the AN Flash SIMM.

2. Compact the contents of the Flash SIMM.

3. Use TFTP to transfer your customized Version 11.0 image, an.exe, from 
your Site Manager workstation to the Flash SIMM volume on the router.

Refer to Connecting BayStack AN and ANH Systems to a Network or Connecting 
ASN Routers and BNX Platforms to a Network for detailed information on how to 
perform a Netboot operation on a router. 

Preparing a Router with Multiple Flash Cards

Bay Networks recommends that you use at least two Flash cards in any router 
designed to accommodate multiple Flash cards.

When you use two Flash cards in a router, you can keep the active
(Version 7-10.xx) software image on one Flash card while you use the TFTP 
command in Site Manager to transfer the new (Version 11.0) image to a backup 
Flash card designated for the upgrade. Once you successfully install and verify the 
new router software image, you can replace the earlier version image.

To prepare a router equipped with multiple Flash cards to receive a customized 
software image:

1. Insert a Flash card into your router.

This is the backup Flash card onto which you will store the Version 11.0 
router software image and associated files.

2. Back up the contents of your Flash card to your Site Manager 
workstation.

You do this as a safeguard in case your Flash card malfunctions.

3. Reformat the Flash card, making sure that the volume or slot number in 
which the Flash card resides is correct. 

Select Commands > Format from the Router Files Manager window.

This operation deletes all files from the Flash card and compacts its contents.

4. Copy the Version 11.0 router image files from your Site Manager 
workstation to the Flash card you just formatted.
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Now your backup Flash card is blank and is ready to accept the Version 11.0 
image and associated files.

Go to “Transferring a Customized Image to the Router” to copy the image to the 
router.

Using Flash Cards from Previous Releases

All Bay Networks routers running Software Versions 7.60 to 8.10, and AFNs 
running Version 7.5x, write to Flash cards using a 68-space file format. Bay 
Networks BNs (BLN, BLN-2, and BCN) running Version 7.5x write to Flash 
cards using a 61-space file format. 

Table 4-1 shows which Bay Networks routers can read, write, and boot from the 
different file format types.

When a BN running Router Software Version 8.10 or 9.00 reads a Flash card that 
contains files written by a BN running Router Software Version 7.5x, and you 
enter the dinfo command at the Technician Interface prompt, the display indicates 
that the volume is corrupted. If you request a directory of the volume’s contents 
(using the dir command), the display indicates that the contiguous free space is 0 
(zero). You can, however, read and boot from the files.

Table 4-1. Flash Volume File Compatibility between Routers Running Different 
Versions of Router Software

Files Written to 
Flash Memory 
by:

Router Capabilities to Read, Write, or Boot from Files

FNs, LNs, CNs, 
and BNs 
Running 7.60, 
7.7x, 7.80, 8.0x, 
8.10, or 9.00

AFNs Running 
7.60, 7.7x, 7.80, 
8.0x, 8.10, 9.00

BNs Running 
7.5x

AFNs Running 
7.5x, 7.60, 7.7x, 
7.80, 8.0x, 8.10, 
9.00, 10.0

Any router running 
7.60, 7.7x, 7.80, 
8.0x, 8.10, 9.00 Read, Write, Boot Read, Write, Boot Read, Boot Read, Write, Boot

AFN running 7.5x Read, Write, Boot Read, Write, Boot Read, Boot Read, Write, Boot

BN running 7.5x Read, Write, Boot None Read, Write, Boot None
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You must convert the contents of a Flash card to a format compatible with the 
router software currently running on a BN router. You do this by copying the files 
to the router’s memory, reformatting the Flash card, and copying the files in 
memory back to the Flash card. Follow these steps:

1. Insert the Flash card into the BN router.

2. Display the Flash card’s directory.

Select Commands > Directory from the Router Files Manager window.

If the available free space and contiguous free space are equal, you cannot 
compact the Flash card at this time; go to Step 3. Otherwise, go to Step 5.

3. Fragment the Flash card volume so you can compact it.

Copy the smallest file on the Flash card to the same volume, giving it a new 
filename. Select Command > Copy from the Router Files Manager.

4. Delete the original file you created in Step 3.

This fragments the volume, dividing the contiguous space on the Flash card. 
This allows you to compact the contents of the Flash card.

5. Compact the contents of the Flash card

Select Commands > Compact from the Router Files Manager. 

The router copies and rewrites all of the files in the correct format for the 
software that is currently running.
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Task 2: Transferring a Customized Image to the Router

The Router Files Manager allows you to transfer a customized image file between 
your Site Manager workstation and the router you want to upgrade using the 
TFTP command. 

Before attempting to transfer a customized image to the router, consider the 
following conditions:

• If the router you want to upgrade has only one Flash card and you have not 
updated the router’s Boot PROM for Version 8.10 or 9.xx, you must rename 
your customized Version 11.0 image to boot.exe before attempting to transfer 
that image to the router.

• If the router you want to upgrade has multiple Flash cards and you have not 
updated the router’s Boot PROM for Version 8.10 or 9.xx, you must

a. Transfer the customized image (for example, asn.exe or bn.exe) to an 
alternate Flash volume on the router. 

b. Boot the Version 11.0 image on the router by performing a “named 
boot” from the Technician Interface prompt, as follows:

<slot>:bn.exe <slot>:config

<slot> is the slot containing the image name bn.exe and the original
configuration file, config.

To transfer a customized image file to the router you want to upgrade:

1. Choose the router to which you want to transfer the image file.

a. Select Options > Router Connection in the Router Files Manager 
window (Figure 4-1).

Note: We recommend that you ping the router before you transfer the 
customized image file to it. For instructions on how to ping a router, refer to 
Managing Routers.
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Figure 4-1. Router Files Manager Window

The Router Connection Options window appears (Figure 4-2).

b. In the Node Name/IP Address field, enter the IP address of the router. 
Then click on OK.
4-8 114047 Rev. A



Continuing the Upgrade: Transferring Customized Files to the Router
 

Figure 4-2. Router Connection Options Window

2. Verify space on the destination volume.

Make sure that the router destination volume has enough space available for 
the file you want to transfer. The Router Files Manager window shows the 
available free space and contiguous free space on the router. 

For a DOS file system, refer to the number of bytes displayed for available 
free space. 

For an NVFS file system, refer to the number of bytes displayed for 
contiguous free space.

If the file system on the router is NVFS, compact the memory card to 
optimize the available free space by selecting Commands > Compact in the 
Router Files Manager window and clicking on OK in the Confirmation 
window.
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3. Select File > TFTP > Put File(s) in the Router Files Manager window. 

The TFTP Put File Selection window opens (Figure 4-3), invoking the Trivial 
File Transfer Protocol (TFTP) software to execute file transfers.

Figure 4-3. The TFTP Put File Selection Window 

4. In the Path box, enter the pathname of the directory on the Site Manager 
workstation that contains the image file you want to transfer.

The filenames in that directory appear in the Files window. You may transfer 
more than one file at a time, if applicable.

5. In the Files window, click on the image file you want to transfer to the 
router. Then click on Add.

The selected files appear in the Files To Put window.

If you inadvertently add a file that you do not want to transfer to the router, 
select that file in the Files To Put window and click on Remove.
4-10 114047 Rev. A



Continuing the Upgrade: Transferring Customized Files to the Router
 

6. If you want to send the image file to only one router, click on No in the 
Multiple Routers field. 

The Router Files Manager transfers the selected image file to the router to 
which you are currently connected.

Refer to Managing Routers and BNX Platforms for more information on 
transferring files to multiple routers.

7. Click on OK. 

During the file transfer operation, the Router Files Manager displays a 
message indicating the name of the image file currently being transferred, and 
the address of the router that is receiving the image file. When the file transfer 
completes successfully, the TFTP Put File Selection window closes and you 
return to the Router Files Manager window.

If the file transfer fails, check your setup for the TFTP operation. Then try to 
transfer the file again. 

If you need assistance, call the Bay Networks Technical Response Center.

Note: If you cannot transfer the customized image to the router successfully, 
do not reboot the router. On single Flash card systems, the router fails to boot 
because there is no image available from which it can boot. 
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Chapter 5
Completing the Upgrade:

Upgrading PROMs and Configuration Files

This chapter describes how to

• Upgrade PROMs in a router

• Boot the router with the customized image

• Upgrade configuration files

• Upgrade Frame Relay circuits (optional)

• Transfer script files to the router

Task 1: Upgrading PROMs in a Router

The router’s programmable read-only memory (PROM) contains software images 
for its bootstrap and diagnostic code. Bootstrap and diagnostic PROM code is 
included on the Router Software Version 11.0 release media. 

This section explains

• Whether you need to upgrade Boot and Diagnostic PROMs 
(“Determining Whether to Upgrade PROMs in a Router”)

• The methods for upgrading PROMs in various routers (“Methods for 
Upgrading PROMs”)

• How to upgrade and verify PROMs (“Upgrading and Verifying PROMs”) 

• How to upgrade PROMs remotely (“Upgrading PROMs in a Router from a 
Remote Site”)
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Determining Whether to Upgrade PROMs in a Router

This section describes when and why you should upgrade Boot and Diagnostic 
PROMs in routers.

Why You Upgrade Boot PROMs

You upgrade Boot PROMs in a router for the following reasons:

• You want to implement a Version 8.10 or later software or hardware feature 
that depends on the availability of the Version 8.10 or later Boot PROM 
image. For example, if you want to implement Flash partitioning for your AN 
router, you must upgrade the Boot PROM image, anboot.exe, in that router to 
Version 8.10 or later. 

Refer to Appendix A for the list of features that require a Version 8.10 or later 
Boot PROM image.

• You want to implement the new router software image-naming convention, 
which uses the following router-specific image names introduced in Router 
Software Version 8.10 (Table 5-1).

To implement the new naming convention, upgrade the Boot PROMs on all 
routers, except the FN, ALN, LN, and CN. The Boot PROM is located on PROM 
or Flash PROM on each processor board. Once upgraded, Version 8.10 and later 
Boot PROMs look only for the new router software image name at boot time.

Table 5-1. Router-specific Image Names

Router Image Name Description

AN an.exe Bootable image for the AN

AFN (Flash) afn.exe Bootable image for the AFN

ASN asn.exe Bootable image for the ASN

BCN, BLN, BLN-2, 
BNX

bn.exe Bootable image for the BCN, BLN, BLN-2, 
and BNX

Note: CN, FN, LN, and ALN (VME) routers continue to use the router 
software image name ace.out.
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In addition, Version 8.10 and later Boot PROMs for AN and AFN routers are 
backward-compatible. That is, the Boot PROM looks first for a Version 8.10 or 
later router software image name (an.exe or afn.exe, depending on the router) at 
boot time. If the Version 8.10 or later AN or AFN Boot PROM cannot find the 
router-specific image name, it searches next for the Version 7-8.xx image name, 
boot.exe.

Why You Upgrade Diagnostic PROMs

You upgrade Diagnostic PROMs in routers when the diagnostic image version 
number for the new release of the router software is higher than the diagnostic 
image version number for the router software currently installed on your router. 

To determine the current version of the Diagnostic or Boot PROM in your router, 
go to “Determining the Current PROM Version.”

Determining the Current PROM Version

You can use Site Manager or the Technician Interface to determine the current 
version of Boot and Diagnostic PROM images currently running in your router.

Note:  A label affixed to the back panel of some routers indicates the installed 
version of Boot and Diagnostic PROMs. For example, an AN router with a 
SIMM-based Flash file system has a label that indicates the current PROM 
version number. See the guide contained in the PROM upgrade kit (Installing 
Boot and Diagnostic PROMs in an AN Router) for more information.
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Using Site Manager

To obtain PROM version information from any router currently connected to your 
Site Manager PC or UNIX workstation:

1. In the main Site Manager window (refer to Figure 3-1), select Tools > 
Statistics Manager.

The Statistics Manager window opens.

The Statistics Manager displays the current router’s configuration. That is, it 
displays the circuit type and location of the router’s network interfaces and the 
bridging and routing protocols that are enabled on each interface.

2. Select Tools > Quick Get.

The Quick Get Facility window opens, showing the objects in the 
Management Information Base (MIB). Use the browser window to scroll 
through and select objects from the MIB. Then use Quick Get to get all 
instances of the object you select and to display that information in columns 
in the Quick Get Facility window.

3. Scroll through the MIB Browser window and select the top-level object 
group, wfHardwareConfig.

The MIB displays subordinate object groups pertaining to router hardware 
configuration.

4. Click on the object group wfHwTable. 

5. Continue selecting object groups and descending through the tree until 
the MIB Browser displays the object wfHwBootPromRev or 
wfHwDiagPromRev (depending on which PROM version you want to 
verify).

6. Select the object wfHwBootPromRev or wfHwDiagPromRev. 

The Object Information field at the top right of the Quick Get window 
displays information about the object.

7. Click on Retrieve Request in the Quick Get window.

All router slots (indicated by the Instance ID field in the Quick Get data 
retrieval window) and the Boot PROM version associated with each slot 
appear.
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The format for the Boot PROM revision that appears in the output window is 
eight hexadecimal numerals in a 32-bit display. The first four characters are 
major revisions; the last four are minor revisions. 

Convert the hexadecimal numerals to decimal to determine the PROM 
revision level. For example, the PROM image version number returned for the 
Version 9.xx router software is 0x00090000. 

8. Exit the Quick Get Facility window when you are done by clicking on 
Done.

For more information about using the Quick Get, refer to Managing Routers 
and BNX Platforms.

Using the Technician Interface

To determine the version number of PROM images residing in a router while 
working from a local console, a Telnet session, or a modem, enter the following 
commands at the Technician Interface prompt:

1. To obtain the version number of Boot PROM images residing in a router, 
enter

get wfHwEntry.19.*

With a BLN router, for example, information similar to the following appears, 
with one wfHwEntry.wfHwBootPromSource line for each slot.

wfHwEntry.wfHwBootPromSource.1 = (nil)
wfHwEntry.wfHwBootPromSource.2 = "rel/8.10/freboot.exe"
wfHwEntry.wfHwBootPromSource.3 = "rel/8.10/freboot.exe"
wfHwEntry.wfHwBootPromSource.4 = "rel/8.10/freboot.exe"
wfHwEntry.wfHwBootPromSource.5 = "rel/8.10/freboot.exe"

Note: Slots that have a System Resource Module (SRM) do not show a 
corresponding Boot PROM revision number.
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Each line of response to the command specifies

• A slot number (for example, “wfHwEntry.wfHwBootPromSource.2” identifies 
Slot 2).

• A pathname that contains the version number of the image stored in the Boot 
PROM (for example, “rel/8.10/freboot.exe” identifies the version 8.10 
Boot PROM image freboot.exe in Slot 2).

2. To obtain the version number of Diagnostic PROM images residing in a 
router, enter

get wfHwEntry.16.*

With a BLN router, for example, information similar to the following appears, 
with one wfHwEntry.wfHwDiagPromSource line for each slot:

wfHwEntry.wfHwDiagPromSource.2 = 
"/harpdiag.rel/v5.00/wf.pj/harpoon.ss/image.p/frediag.exe"
wfHwEntry.wfHwDiagPromSource.3 = 
"/harpdiag.rel/v5.00/wf.pj/harpoon.ss/image.p/frediag.exe"
wfHwEntry.wfHwDiagPromSource.4 =
"/harpdiag.rel/v5.00/wf.pj/harpoon.ss/image.p/frediag.exe"
wfHwEntry.wfHwDiagPromSource.5 =
"/harpdiag.rel/v5.00/wf.pj/harpoon.ss/image.p/frediag.exe"

Each line of response to the command specifies

• A slot number (for example, “wfHwEntry.wfHwDiagPromSource.2” identifies 
Slot 2).

• A pathname that contains the version number of the image stored in a 
diagnostics PROM (for example, 
"/harpdiag.rel/v5.00/wf.pj/harpoon.ss/image.p/frediag.exe" identifies 
the “v5.00” (Version 5.00) diagnostics PROM image frediag.exe in Slot 2).

Refer to Using Technician Interface Software for more information.

See Table 2-3 for Version 11.0 Boot and Diagnostic PROM filenames and 
associated revision numbers for the various router platforms. 

Note: The command does not return a Boot PROM version number for Slot 1 
because Slot 1 contains a System Resource Module (SRM). This applies to all 
routers except AN and ASN routers.
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If you determine that you need to upgrade PROMs in your router, continue with 
the next section, “Methods for Upgrading PROMs.”

Methods for Upgrading PROMs

Depending on which router you are upgrading, you upgrade PROMs in that router 
in the following ways:

• By reprogramming the PROM components using the Technician Interface. 
This process of erasing the contents of PROM and transferring new bootstrap 
and diagnostic images is sometimes called “burning” the PROM.

• By physically replacing the existing PROM with the PROM version shipped 
with Router Software Version 8.10 or later.

Table 5-2 summarizes the methods for upgrading PROMs in various routers. 

Table 5-2. Methods for Upgrading Boot PROMs in Various Routers

If Router Model Is
PROM Replacement 
Method Is 

Refer to

AFN (Flash) Physical replacement Installing a Flash Memory 
Upgrade in an Access Feeder 
Node 

AN or ANH (with motherboard 
revision level earlier than 14)

Physical replacement Installing Boot and 
Diagnostic PROMs in an AN 
Router

AN, ANH, or BayStack AN or 
ANH (with motherboard 
Revision 14 or later)

Technician Interface 
prom command

Installing Boot and 
Diagnostic PROMs in an AN 
Router

ASN or BN (BLN, BLN-2, BCN, 
ARE)

Technician Interface 
prom command

“Upgrading and Verifying 
PROMs,” in Chapter 5 of this 
manual

FN, LN, ALN, CN Technician Interface 
prom command

No Boot PROM upgrade 
required
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Depending on your AN or ANH model, you transfer new boot and diagnostic code 
to PROM using either

• A PCMCIA Flash card (BayStack AN and BayStack ANH)

• SIMM-based Flash memory (AN and ANH models without a PCMCIA slot)

To upgrade the PROMs in a SIMM-based AN router with a motherboard revision 
lower than 14, you must order a PROM Upgrade Kit (Order No. 109435) to 
physically replace the PROM components.  

Go to “Upgrading and Verifying PROMs.”

Upgrading and Verifying PROMs

Bay Networks strongly recommends that you upgrade PROMs in a router to 
implement the latest software or hardware features before upgrading to a new 
version of the router software.

You use the prom command from the Technician Interface to upgrade and verify 
the software on the Diagnostic or Boot PROM. This command is restricted to the 
Manager access level.

When you upgrade PROMs, the system erases the existing PROM and copies the 
contents of the newer PROM image file to the PROM. When you verify the 
PROM, the system compares the contents of the new image file to the actual 
contents of the PROM.

Caution: Systems with one-time programmable (OTP) PROMs require 
component replacements to upgrade the PROM version. These systems 
include AFNs and ANs with motherboards earlier than Revision 14. AN 
motherboards Revision 14 and later provide flash-in-place capability; you 
upgrade these PROMs by downloading new code from the Flash file system.
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To upgrade and verify PROMs:

1. Verify the contiguous free space available on the Flash card.

Ensure that the Flash card contains sufficient contiguous free space to 
accommodate the PROM images you are updating and the latest router image 
file.

To determine the amount of contiguous free space, display the directory of the 
Flash card by entering the following command from the Technician Interface 
prompt:

dir <volume_no.>:

<volume_no.> is the slot number in which the Flash card resides.

If you need more contiguous free space for the PROM image:

a. Delete unnecessary or obsolete files.

b. Compact the contents of the Flash card.

From the Router Files Manager, select Commands > Compact.

While the compact operation is in progress, a display of the percentage of the 
operation that has been completed appears next to the Volume field in the 
Router Files Manager window. The router is unavailable for any other file 
system requests until it completes the compact procedure.

When the compact operation is completed, the Router Files Manager 
automatically displays the list of files stored in the Flash card. 

2. Transfer the PROM image files (for example, freboot.exe and frediag.exe) 
to the Flash card.

The files are located in the Site Manager workstation directory that contains 
the router software.

From Site Manager, select Router Files Manager TFTP > Put File. Refer to 
Managing Routers and BNX Platforms for information on using the TFTP Put 
File option. 

Note: Before upgrading any router software, however, make sure that you save 
a copy of the original configuration file and boot image as a safeguard in case 
you encounter problems after upgrading.
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From the Technician Interface, use the tftp command. Refer to Using 
Technician Interface Software for more information. 

3. Establish a Technician Interface session with the router.

Enter the following command at the Technician Interface prompt: 

Manager

Refer to Using Technician Interface Software if you need more information 
on how to open a Technician Interface session with the router.

4. Update the Boot PROM by entering:

prom   -w <volume_no.> : <Boot_PROM_source_file>  <slot_ID >

<volume_no.> is the slot number of the Boot PROM source file located on a 
volume; <Boot_PROM_source file> is the name of the Boot PROM source 
file (for example, freboot.exe); and <slot_ID> is the slot location of the Boot 
PROM that you want to update.

For example:

prom   -w   2:freboot.exe 3

This command erases the Boot PROM on Slot 3 and copies the contents of the 
freboot.exe file on Volume 2 to the PROM on Slot 3.

The BN router now has the new Boot PROM file, which invokes only the 
router software image name bn.exe.

5. Update the Diagnostic PROM by entering:

prom -w <volume_no.> <Diag_PROM_source_file>  <slot_ID>

<volume_no> is the slot number of the Diagnostic PROM source file located 
on a volume; <Diag_PROM_source file> is the name of the diagnostic 
PROM source file (for example, frediag.exe); and <slot_ID> is the slot 
location of the diagnostic PROM file you want to update.

Note: Once you enter the prom command, it must run to completion. The 
control-c (abort) command is disabled for the duration of the prom command 
execution to allow it to run to completion. Updating takes from 2 to 10 minutes 
per PROM. Verifying takes up to 2 minutes per PROM. 
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For example:

prom   -w  2:frediag.exe 3

This command erases the Diagnostics PROM on Slot 3 and copies the 
contents of the freboot.exe file on Volume 2 to the PROM on Slot 3.

6. Upgrade PROMs on multiple slots on your router.

If you need to update PROMs on multiple slots, use a dash to indicate a range 
of slots (2-5), or use commas or spaces to separate multiple slot locations
(2, 3, 4, or 2 3 4).

For example:

prom   -w 2:frediag.exe 2, 3, 4, 5

This command erases the diagnostic PROMs on Slots 2, 3, 4, and 5 and copies 
the contents of the frediag.exe file on Volume 2 to the PROMs on Slots 2, 3, 4, 
and 5.

For more information about updating PROMs on multiple slots, refer to Using 
Technician Interface Software.

7. Verify the PROM upgrade by entering the following command:

prom   -v <volume_no.> <Diag_PROM_source_file>  <slot_ID>

For example, for a boot PROM, enter

prom -v <volume_no.>: [freboot.exe | asnboot.exe | anboot.exe] <slot_ID>

For a diagnostics PROM, enter

prom -v <volume_no.>: [frediag.exe | asndiag.exe | andiag.exe]  <slot_ID>

The system verifies that the PROM image on a designated flash volume (that 
is, the image file used as a source for upgrading the PROM) matches the 
image actually stored in the boot or diagnostics PROM, on a designated slot.

Note: Boot PROM incompatibilities can exist if you have different Boot 
PROM revisions on different slots on your router. For example, the Boot 
PROM image in a slot running Boot PROM Version 8.00 will look for 
boot.exe. A Boot PROM image running Version 8.10 on a BN router will look 
for the image name bn.exe.
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When you use the -v option, the console displays one of the following 
messages after the verification terminates:

prom: slot <slot ID> completed successfully

prom: PROM data does not match file data on slot <slot ID>

If the operation succeeds, the new images stored in the Boot and Diagnostic 
PROMs run when you reboot the router.

If the operation fails, the console displays a message describing the cause of 
the failure.

For additional examples of using the prom command to update and verify 
PROMs, refer to Using the Technician Interface Software.

Upgrading PROMs in a Router from a Remote Site

This section summarizes the procedure for upgrading PROMs in a router that is 
located in a remote site. Be sure to read the special considerations in this section 
before upgrading router PROMs remotely.

When upgrading PROMs in a router from a remote site, follow these guidelines to 
ensure that the PROM upgrade is successful:

• Store the PROM executable files (for example, frediag.exe and freboot.exe) on 
a Flash card that resides on the slot in the system that you use the least.

• Perform the upgrade during non-peak hours to ensure a minimum traffic load 
across all rails of the backplane (PPX).

The operations involved in updating PROMs are both data transfer and CPU 
intensive, as are the regular functions of routing and forwarding normal data 
traffic. Because periods of high traffic (peak periods) may cause time-outs or 
other failures of the PROM upgrade process, it is important to perform PROM 
upgrades during off-peak periods. A failure during a PROM upgrade makes it 
necessary to repeat the procedure.

• On multislot systems, upgrade the PROM for each slot separately. Attempting 
to upgrade multiple slots at the same time increases the load on the router 
backplane.

Caution: If the PROM upgrade process is interrupted, the router could be 
disabled. 
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Task 2: Booting the Router with the Customized Image

After you transfer the customized image to the router successfully and upgrade 
PROMs, you can boot the router with the customized image. This activates the 
customized image on your router.

If you are booting an ASN router for the first time from a Version 11.0 image, the 
boot time may be longer. After the ASN boots successfully from its Version 11.0 
image, you can shorten the boot interval by changing the default Netboot settings. 
Enter the following commands at the Technician Interface prompt:

bconfig image local
bconfig config local

This results in the ASN booting exclusively from the local image and a local 
configuration file. 

To boot the router with the customized image:

1. In the Site Manager window, select Administration > Boot Router.

The Boot Router window opens (Figure 5-1). It shows a default router volume 
for the Boot image file (ace.out) and the default configuration filename 
(config). 

Figure 5-1. Boot Router Window

Caution: Never reset or reboot a router while upgrading PROMs. Should a 
failure occur, restart the procedure immediately.
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2. Select the correct router volume.

a. Click on the rectangle next to the Boot Image volume number and the 
Configuration slot number.

A pop-up window displays the available router volumes containing the 
router software image and the available slots containing the configuration 
file.

b. Click on the number of the slot you want your router to boot or 
configure from.

The pop-up window closes and the new slot number appears. 

3. Verify the name of the new router software boot image.

By default, the router-specific image name appears in the Boot Image box.

4. Verify the configuration file from which you want to boot the router.

By default, the configuration filename config appears in the Configuration 
box.

5. Click on Boot.

A boot confirmation window appears.

6. Click on OK.

The router boots using the router software image and the configuration file 
you specified.

Wait a few minutes to give the router time to boot. The boot time may be 
longer if you are booting an ASN router for the first time from a Version 11.0 
image. 

Note: If the router you want to upgrade has only one Flash card, do not change 
the volumes displayed.

Note: If you are upgrading a router that is running Version 8.10, 9.xx, or 10.0 
Boot PROMs to Version 11.0 and that router contains multiple Flash cards, 
remove the Version 8.10, 9.xx, or 10.0 backup Flash card from the router. 
Otherwise, when you reset or cold-boot the router, the router will run different 
versions of the router software on different slots.
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7. Verify that the router booted successfully with the customized image.

Select View > Refresh Display from the main Site Manager window.

If the router booted successfully, Site Manager establishes a connection to the 
router and displays system information (such as the system name, contact, 
location, description, and MIB version). This confirms that the router can boot 
with the customized image.

If the router did not boot successfully, consider the following:

• If you have a router with one Flash card, use a local console to reboot the 
router from the Technician Interface. If this operation fails, call the Bay 
Networks Technical Response Center in your area.

• If your router has multiple Flash cards, boot off the original Flash card 
(pre-Version 11.0). Follow the instructions in “Preparing a Router with 
Multiple Flash Cards.”

Task 3: Upgrading Configuration Files

This section describes how to upgrade your existing Version 7-10.xx configuration 
files to support the new Version 11.0 features. Optionally, you can create new 
Version 11.0 configuration files to replace your existing configuration files for the 
router.

You upgrade your existing Version 7-10.xx configuration files using the 
Configuration Manager by booting the router with the Version 7-10.xx 
configuration file, saving the configuration file with a new filename in dynamic 
mode, and rebooting the router with the new configuration file. 

Booting the 7-10.xx Configuration File

To upgrade a Version 7-10.xx configuration file to Version 11.0, boot it on a router 
running a Version 11.0 router software image. This router software loads the 
configuration file currently in the router’s memory and updates the configuration 
file’s MIB stamp to match the Version 11.0 router software. It does not, however, 
automatically save that version to the file on the Flash card.
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Saving the Configuration File in Dynamic Mode

After you boot the router with the Version 7-10.xx configuration file, save the 
configuration file with a new filename as follows:

1. Select Tools > Configuration Manager > Dynamic in the Site Manager 
window.

The Configuration Manager window appears (Figure 5-2), displaying the
realtime router hardware and software configuration.

Figure 5-2. Configuration Manager Window

2. Select File > Save As in the Configuration Manager window.

The Save Configuration File window appears (Figure 5-3.)
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Figure 5-3. Save Configuration File Window

3. Enter a new filename to save the configuration file on the router, using the 
following format:

filename.cfg

where filename is the name you are assigning this file, and .cfg specifies the 
file type. For example, enter the filename, config1100. Do not use the filename 
config.

4. If the file system on the router is an NVFS, and the volume (slot location 
of the memory card on the router) that appears in the Volume box is not 
the volume to which you want to save this file, click on the Volume box 
and select an alternate volume. Otherwise, go to the next step.

5. Click on Save.

The File Saved pop-up window appears, prompting you to confirm your 
decision to save the file.

6. Click on OK in the File Saved pop-up window.

This rewrites the configuration file, config1100, in the router’s memory and 
saves it to the Flash card with the Version 11.0 MIB stamp. 
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Rebooting a Router with a New Configuration File

After you save the new configuration file (config1100) to the router, you 
implement the configuration by rebooting the router with that file. 

1. Select Administration > Boot Router.

The Boot Router window opens (Figure 5-4), displaying default filenames for 
the router software image and the configuration file. The default volume is the 
first available memory access card (indicated by slot number) on a router with 
a non-volatile file system (NVFS), or Volume A on a router with DOS file 
system.

Figure 5-4. Boot Router Window

Replace the default configuration filename in the Configuration box with the 
Version 11.0 configuration file, config1100, you just saved. 

2. Click on Boot.

The router boots with the Version 11.0 configuration file, config1100.

3. Verify that your router is up and running.

4. Rename the original configuration file to config.bck.

This creates a backup of the original configuration file, which you may need 
in case the router does not boot successfully with the Version 11.0 
configuration file (config1100).

5. Rename the Version 11.0 configuration, config1100, to the default 
configuration filename, config.

This ensures that the router will boot off the correct configuration file, in case 
the router experiences a power failure.
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After you successfully boot the router with a configuration file, it routes and 
bridges traffic.

Repeat Steps 1 through 5 if you want to upgrade another configuration file. Make 
sure you give the other configuration file a name other than config (for example, 
config1100_new.)

Task 4: Upgrading Frame Relay Circuits

If you are running a version of router software earlier than 7.60 and the 
configuration file you upgraded in Task 3 had Frame Relay circuits, complete this 
task. Otherwise, go to Task 5: “Transferring Script Files to the Router.”

The upgrade procedure does not convert all Frame Relay circuit records, and Site 
Manager does not display them. You must delete all interfaces on which Frame 
Relay was configured and reconfigure the interfaces, as follows:

1. Open your most up-to-date configuration file, using the Configuration 
Manager.

2. Choose Delete Circuits from the Circuits menu.

The Circuit List window displays the circuits.

3. Select each circuit on which Frame Relay was configured in the 
configuration file you just upgraded.

4. Select Delete.

The system removes the selected circuit.

5. Select Done.

6. Choose Add Circuit from the Circuits menu and configure a new Frame 
Relay circuit for each circuit you deleted.

Task 5: Transferring Script Files to the Router

Transfer from your Site Manager PC or UNIX workstation to the router any 
Version 11.0 Technician Interface scripts useful for your router configuration. 
These scripts let you manage the router using information stored in the 
Management Information Base (MIB). You can use the scripts to display 
information about protocols and network services and to enable and disable 
protocols, circuits, lines, and services.
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Technician Interface Script Descriptions

The Technician Interface scripts are .bat and .mnu files; you must transfer these 
files to a memory card in each router you want to upgrade to Version 11.0.

• .bat files enable you to generate information about a protocol or service that 
the router supports.

• .mnu files enable you to display this information from menus.

Each script contains subcommands to support the options that it provides. For a 
complete list of script files and definitions, refer to Using Technician Interface 
Scripts.

For each router you want to upgrade to Version 11.0, you must transfer a 
minimum set of scripts, regardless of which protocol-specific scripts you want to 
run on your router. Table 5-3 lists these scripts.

In addition to the required script files listed in Table 5-3, you can transfer to your 
router any protocol-specific scripts to support the protocols on the router you are 
upgrading to Version 11.0. For example, if you want to run only IP and Frame 
Relay on a router, transfer to that router the following script files: ip.mnu, fr.bat, 
and fr.mnu. 

Table 5-3. Minimum Set of Scripts to Transfer to a Router 

 Script Filename Description

show.bat Helps you isolate problems such as circuits that are not 
working, packets that are not being forwarded, and so 
forth.

setpath.bat Sets the search path and aliases for the script commands.

menu.bat Provides a menu from which you can select the script you 
want to run.

main.mnu Displays a top-level menu from which you can select other 
.bat files currently on the system.

monitor.bat Displays the same information as the show command, but 
refreshes the display periodically so you can examine 
trends and changes.
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Transferring Script Files

Before you transfer script files, do the following:

1. Compact the Flash card on your router.

Select Command > Compact from the Router Files Manager window in Site 
Manager. This give you more free space on a Flash card.

2. Check the size of the scripts you want to transfer to your router. 

Verify that the amount of contiguous free space you have on a Flash card in 
your router exceeds the size of the scripts to be transferred.

We recommend that you use the Bay Networks implementation of the File 
Transfer Protocol (FTP) to load scripts on a router from your workstation, because 
FTP enables you to load more than one file at a time. For information on how to 
load scripts, refer to Using Technician Interface Scripts.
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Appendix A
Router Integration Examples

Read this appendix for examples on how to upgrade routers from Version 7-10.xx 
to Version 11.0. Look for an example that applies to the router integration problem 
you want to solve.

Upgrading Routers from Version 7-10.xx to Version 11.0

This section contains examples that show you how to

• Upgrade a Version 8.xx-10.0 AN or ANH router to Version 11.0.

• Netboot a Version 7-9.xx AN router to Version 11.0

Example 1: Upgrading an AN, ANH, or BayStack AN or ANH Router 
from Version 8.xx-10.0 to Version 11.0

To upgrade a Version 8.xx-10.0 AN/ANH or BayStack AN/ANH router to Version 
11.0 of the router software:

1. Verify the version of the Boot PROM currently in the router.

Refer to “Determining the Current PROM Version” in Chapter 5 of this 
manual.

2. From the Technician Interface, delete the existing an.exe image from the 
Flash SIMM (for either the AN or ANH router). 

For example, if the existing an.exe image you want to delete resides on Slot 1 
in your router, enter the following command:

delete 1:an.exe
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3. Compact the Flash SIMM (or Flash card for a BayStack AN or ANH) 
that contained the earlier router software image (an.exe) that you just 
deleted. (Compaction takes approximately 12 minutes.)

For example, if the image file you want to delete is on Volume 1, enter the 
following command:

compact 1

Make sure that you do not interrupt the compact process or the Flash card or 
Flash SIMM will be corrupted.

4. Copy your customized Version 11.0 router software image an.exe and 
related files to the AN or ANH router.

5. Boot the AN, ANH, or BayStack AN/ANH router from your Version 11.0 
software image and a configuration file.

Use this same procedure (Steps 1 through 5) to upgrade ASN and BN routers, 
with the following exceptions:

• You must specify the correct image name for ASN and BN routers (bn.exe for 
BN routers and asn.exe for ASN routers). 

• You compact a Flash card when upgrading BN and ASN routers, not a Flash 
SIMM.

Example 2: Using Netboot to Upgrade a Version 7-9.xx AN Router to 
Version 10.0 

This example explains how to Netboot a Version 10.0 AN router if you have 
Netboot configured.

Netbooting a Version 11.0 AN Router with Netboot Configured

Netbooting the software image allows you to manage your image and 
configuration files from a remote location by storing them on the BOOTP server. 
It also minimizes the need to maintain the router’s local file system.
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To Netboot a Version 7-9.xx AN router to Version 11.0:

1. Upgrade Site Manager to Version 4.0.

See Chapter 3 of this manual for instructions on upgrading to Site Manager 
Version 4.0.

2. Start Site Manager.

3. Copy the Version 10.0 router software image (an.exe) and related files to 
your PC or workstation.

4. From the Site Manager main window, select Tools > Image Builder to 
start Image Builder.

The Image Builder window opens.

5. Select File > Open from the Image Builder window.

6. Select the directory and name of the image file (an.exe) you want to open. 
This is the same file you copied in Step 3.

7. Click on OK.

The system automatically creates a directory called .builder_dir and two 
subdirectories: one whose name matches the version number of the current 
router software release, and one whose name matches your router’s software 
image name. For example:

wf/builder_dir/rel1100/an

The /an directory contains all the executable files, including the boot file 
krnl_an.exe.

8. Copy the file named krnl_an.exe and any other protocol executable files 
that you have configured for the AN to the BOOTP server.

Ensure that you have set up the bootptab file on your UNIX workstation 
correctly. For information on setting up the bootptab file, refer to Connecting 
BayStack AN and ANH Systems to a Network.

9. Boot the AN router. 

The AN will retrieve the new 11.0 router software image from the BOOTP 
server.
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Features Associated with PROM Upgrades

Table A-1 describes router features implemented between Versions 7.70 and 9.xx 
that require a new version of Boot PROM. Upgrade the Boot PROM if the features 
you need depend on a Boot PROM version more recent than the version now in 
your router.

Note: The Boot PROM version that appears in the AFN MIB corresponds to 
the version of the AFN Diagnostics PROM code. (The AFN has a combined 
Boot/Diagnostic PROM device.) 

Table A-1. Boot PROM Upgrades for New Feature Support 

Router
Model

Boot 
PROM
Version

PROM
Filename

PROM Features
If PROM Version Is
at This Version

Reason for
Upgrading PROM

AN/ANH 8.00 anboot.exe 4-MB Flash 
capability.

Upgrade to PROM 
Version 9.00.

2-MB Flash might be too 
small to accommodate 
Version 10.0 image.

8.10 anboot.exe New 
router-specific 
Boot image name 
(an.exe).

No action required. No new features beyond 
Version 8.10.

9.00 anboot.exe None. No action required. No new features beyond 
Version 8.10.

ASN 8.00 asnboot.exe 4-MB Flash
capability.

Upgrade to PROM 
Version 10.0

2-MB Flash might be too 
small to accommodate 
Version 10.0 image.

8.10 asnboot.exe New 
router-specific 
Boot image name 
(asn.exe).

Support for
Hot-Swap SPX 
network module.

No action needed. No new features beyond 
Version 8.10.

9.00 asnboot.exe None. No action. No new features beyond 
Version 8.10.

(continued)
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BN 7.70/7.7
1

freboot.exe Support for
FRE-2 controller.

Upgrade to PROM 
Version 9.00.

4-MB Flash capability;
changed to 
router-specific boot 
image name.

8.00 freboot.exe 4-MB Flash
capability.

Upgrade to PROM 
Version 8.10.

2-MB Flash might be too 
small to accommodate 
Version 10.0 image.

8.10 freboot.exe New 
router-specific 
Boot image name 
(bn.exe).

No action required. No new features beyond
Version 8.10.

9.01 areboot.ppc ARE/ATM-specific
feature.

No action required. Not applicable.

VME 8.00 vmeboot.exe 4-MB Flash 
capability.

Upgrade to PROM 
Version 8.10.

2-MB Flash might be too 
small to accommodate 
Version 10.0 image.

8.11 vmeboot.exe None. No action needed. Support for Quad Token 
Board.

AFN
(Flash)

3.03 No filename Support for 4-MB 
Flash capability.

Upgrade to PROM 
Version 8.10.

2-MB Flash might be too 
small to accommodate 
Version 10.0 image.

3.04 No filename New 
router-specific 
image name 
change.

No action required. No new features beyond 
Version 3.04.

ARE
s5000

A0000 are.boot.ppc Support for 5780 No action required. No action required.

Table A-1. Boot PROM Upgrades for New Feature Support (continued)

Router
Model

Boot 
PROM
Version

PROM
Filename

PROM Features
If PROM Version Is
at This Version

Reason for
Upgrading PROM
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Appendix B
Configuration-specific Issues

Affecting Router Upgrades

This appendix describes the Version 7–10.xx to 11.0 configuration-specific issues 
that may concern you, depending on the current configuration of your Version 
7-10.xx router. Read this appendix if you are upgrading routers in an environment 
that includes any of the following situations:

• X.25 Configurations

• Standard Point-to-Point Connections

• Switched Services 

• PPP Multiline Circuits

Verifying X.25 Certification Requirements

Due to possible differences between older and newer link modules supporting 
connections to your X.25 network, you must verify that the router you need to 
upgrade to Router Software Version 11.0 can pass X.25 certification requirements.

Note: If the router you want to upgrade is a model AN or ASN, or if the router 
does not support any X.25 configurations, go to the next section that applies to 
your environment or to Chapter 3 to begin the upgrade process.
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Configuring FN, AFN, ALN, CN, or BN Routers to Run X.25

If you are configuring an FN, AFN, ALN, CN, or BN router to support any X.25 
configurations, follow the instructions in Table B-1.

Ensuring that Link Modules Pass X.25 Certification

Follow these guidelines to ensure that you are using a link module that can pass 
X.25 certification:

• Do not upgrade AFN hardware.

• Do not replace link modules delivered after June 1992.

• Upgrade link modules directly attached to the X.25 network that were 
delivered before October 1991.

• Inspect only the link modules directly attached to the X.25 network that were 
delivered between October 1991 and June 1992. Determine which modules to 
replace by removing the link module from the router and reading the revision 
level of any MK5025 chip on that module. If the revision level is C03 or later, 
do not replace.

Table B-1. Configuring FN, AFN, ALN, CN, or BN Routers to Run X.25

Router Software 
Version Action

Version 7.60 or 
earlier

The behavior of the serial controller chips on link modules differs 
slightly from the X.25 standard, making them noncertifiable in 
X.25 networks.

Version 7.60 or later The MK Thompson 5025 serial controller chip in the link modules 
now performs the LAPB function of X.25. This change significantly 
improves performance. However, you may still need to replace 
some link modules that have earlier versions of the MK5025 chip 
set to ensure that the router passes X.25 certification.

Note: If you need hardware to upgrade your router for X.25 support, contact 
your Bay Networks representative to order it. Specify that the router needs this 
hardware to satisfy X.25 certification requirements.
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Reviewing Standard Point-to-Point Connection Guidelines

If the router you want to upgrade has no synchronous, point-to-point connection 
requirements, go to the next section that applies to your environment or to Chapter 
3 to begin the upgrade process. Otherwise, read this section.

Configuring Point-to-Point Connections over Synchronous Lines

If you need to configure any point-to-point connections over synchronous lines, 
you must designate at both ends of the line an HDLC local address and a remote 
address. The router at each end receives packets at the designated local address 
and sends packets to the remote (destination) address. 

For each of these parameters, the Configuration Manager allows you to do one of 
the following:

• Set an implicit address value of DCE (which the router recognizes as a value 
of 0x01) or DTE (which is 0x03).

• Set an explicit address value of 0x02, 0x04, 0x05, 0x06, or 0x07.

Whatever local-remote address pair you assign at one end of a point-to-point 
synchronous line, you reverse at the opposite end of the line. For example, the 
synchronous circuit on Router A in Figure B-1 has an explicit local address (LA) 
value of 0x04 and a remote (destination) address (RA) of 0x05. In this case, you 
configure the synchronous circuit on Router B at the opposite end of the same line 
with a local address value of 0x05 and a remote address value of 0x04.

Figure B-1. Address Assignments on a Point-to-Point Synchronous Line

LA   0x04

RA   0x5

0x05   RA

0x04   LA   

UP70002A

Sync Line

Packets
Router A Router B

Packets
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Setting Explicit Local and Remote Address Values with the Technician 
Interface

If the Configuration Manager constraints prove impractical due to the 
requirements of your existing network configuration, you can set explicit local 
and remote address values by entering the following commands at the Technician 
Interface prompt of the Version 11.0 router:

s wfSyncEntry.wfSyncLocalAddress.<slot>.<connector> <integer value>; 
commit

s wfSyncEntry.wfSyncRemoteAddress.<slot>.<connector> <integer value>; 
commit

save config <config filename>

<slot>.<connector> is the slot and connector (that is, the synchronous circuit) 
you want to configure.

<integer value> is the explicit address value in the range 0x00 to 0x99, excluding 
0x01 (the DCE setting) and 0x03 (the DTE setting).

Reviewing Switched Services Enhancements and 
Compatibility Issues Affecting Router Upgrades

This section describes how Version 11.0 Switched Services enhancements and 
compatibility issues affect the Version 7-10.xx to 11.0 upgrade process.

Upgrading Dial Services to Use PAP and CHAP for Caller Resolution

Bay Networks has completed its migration of dial services, which began in 
Version 8.10, from address-based caller resolution – whoami (who-am-I) – to 
authentication-based caller resolution.

Thus, when you use dial services (Dial-on-Demand, Dial Backup, 
Bandwidth-on-Demand) over any public switched network, such as an Integrated 
Services Digital Network (ISDN), you no longer can use an address-based method 
(IP or IPX addresses) to identify a peer router. Instead, you must configure your 
router to use one of the PPP authentication protocols: Challenge Handshake 
Authentication Protocol (CHAP) or Password Authentication Protocol (PAP). 
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PPP uses CHAP names and PAP IDs to identify the caller and to determine which 
circuit to bring up. You enter CHAP names or PAP IDs in a caller resolution table 
and associate each name or ID with a demand, primary, or bandwidth-on-demand 
circuit.

PAP requires the peer router to send a PAP packet that contains a plain-text user 
identifier and password to the originating router before the interface can advance 
to the network-layer protocol phase. For more information about PAP and CHAP, 
refer to Configuring PPP Services.

Table B-2 lists the methods used to identify a peer router, beginning with Router 
Software Version 7.60.

Upgrading Dial-on-Demand or Dial Backup Circuits

If you have a Version 7.xx-8.00 router that uses Dial-on-Demand or Dial Backup 
circuits and that initiates calls, and you want to upgrade that router to Router 
Software Version 11.0, the receiving router must be running Router Software 
Version 8.10 or later. Otherwise, there is no mechanism by which the receiving 
router can identify the caller.

If you have multiple routers running Router Software Version 8.10 that use 
Dial-on-Demand or Dial Backup circuits, and you want to upgrade a router to 
Router Software Version 11.0, then you can upgrade the router on either end of the 
circuit. However, to ensure that caller resolution completes on the receiving end of 
the call, you must configure CHAP authentication and caller resolution 
information for both the caller and the receiver. 

Table B-2. Caller Resolution Methods 

Router Version Caller Resolution Mechanism 

Version 7.60-8.00 Router used PPP NCP address information to identify a peer 
router.

Version 8.10 Router used either PPP NCP address information or CHAP 
name to identify a peer router.

Versions 9.00, 10.0, 
and 11.0

Router uses CHAP name or PAP ID information to identify a 
peer router.
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PPP Multiline Migration Issues Affecting Router Upgrades

This section describes PPP multiline migration issues and how they affect router 
upgrades.

Running LCP on All Lines in a Multiline Circuit

Beginning with Router Software Version 9.00, PPP multiline circuits can 
negotiate and run the Link Control Protocol (LCP) on all lines in a multiline 
circuit, as opposed to only one line. By negotiating and running LCP on all lines 
in a multiline circuit, you can

• Detect an initial looped-back condition on any line during LCP negotiation

• Run an Echo Request on any or all lines independently

• Run periodic CHAP authentication on any or all lines independently

• Run Link Quality Reporting (LQR) on any and all lines independently

Ensuring Backward-Compatibility for PPP Multiline Circuits

PPP multiline circuits did not run LCP on all lines of a circuit before Router 
Software Version 9.00. Therefore, Version 9.00 and later PPP multiline circuits 
and pre-Version 9.00 multiline circuits are incompatible. 
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Appendix C
Upgrading the DCM Software

Image in AN and ANH Routers

This appendix describes how to upgrade the DCM software image on an AN or 
ANH router using either Site Manager or the Technician Interface. It also 
discusses DCM software image and router software compatibility and tells you 
how to find out what version of DCM you are currently running.    

Upgrading the DCM software image on an AN or ANH router involves

• Transferring the DCM software image from CD-ROM to your PC or UNIX 
workstation by performing the steps outlined in Chapter 3.

• Transferring the DCM software image from your PC or UNIX workstation to 
the router’s Flash card using TFTP.

• Transferring the DCM software image from the router’s Flash memory to the 
DCM’s Flash memory using either Site Manager or the Technician Interface

DCM Software Image and Router Software Compatibility

The Version 1.4 DCM software image is backwards-compatible with Router 
Software Version 9.0x and 10.0x. However, if you plan to run RMON on a Version 
11.0 AN or ANH router, you must upgrade the DCM software image to Version 
1.4; DCM software image versions earlier than 1.4 cannot be used with Router 
Software Version 11.0. If you attempt to run RMON on an 11.0 router that has a 
DCM software image version earlier than Version 1.4, (for example, Version 1.3.0 
or 1.3.1), you will get an error message from the RMON Summary application 
telling you that the router does not support RMON.

Before you attempt to upgrade a router to Version 11.0, we recommend that you 
first check the DCM software version residing on the Ethernet DCM. 
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Enter the following command from the Technician Interface to determine the 
DCM software image version:

[1:1]$ get wfDCMmw.wfDCMAgentImageVersion.0

The Technician Interface generates a message similar to the following:

wfDCMmw.wfDCMAgentImageVersion.0 = "V1.4.0"

Transferring the DCM Software Image from CD-ROM to your 
PC or Workstation

Using UNIX/PC file transfer commands, you can transfer the DCM software 
image (in11_140.obj) from CD-ROM to your PC or UNIX workstation. Refer to 
Chapter 3 “Loading Router Software onto a PC or UNIX Workstation” for 
instructions. 

Transferring the DCM Software Image from your PC or 
Workstation to a Router

You use Site Manger to transfer the DCM software image from your PC or UNIX 
workstation to the router’s Flash memory. Refer to Chapter 4, “Task 2: 
Transferring a Customized Image to the Router” for instructions.

Transferring the DCM Image from the Router’s Flash to the 
DCM Flash 

You can transfer the DCM image from the router’s Flash memory to the Ethernet 
DCM’s Flash memory using Site Manager or the Technician Interface.
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Using Site Manager

To upgrade the DCM software image from the router’s Flash memory to the 
Ethernet DCM Flash memory, follow these steps:

1. Select Platform > DCM 11.0 and later > Global... > Base Module DCM 
(Figure C-1.)

Figure C-1. Selecting DCMMW Global Configuration Parameters

The Edit Base Module DCM Parameters window opens (Figure C-2.)
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Figure C-2. Edit Base Module DCM Parameters Window

2. Change the Enable/Disable option to Disable.

3. Change the Boot Option from Local to Download 

This specifies that you want the Ethernet DCM to boot the downloaded DCM 
image from the Ethernet DCM’s Flash memory and not from the router’s 
shared memory.

4. In the Image Name field, specify the target volume and the filename of 
the new DCM software image (in11_140.obj).

For example: 1: in11_140.obj.

5. Select the Save option in the Image Save Mode field and click on OK.

The Edit Base Module DCM Parameters window closes.

If you select the No Save option, the Ethernet DCM boots with the new 
software image, but does not save the image to the Ethernet DCM’s Flash 
memory.
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Next, you need to complete Steps 6 through 8 to boot the Ethernet DCM with 
the new DCM software image. You complete these steps at the Configuration 
Manager window. 

6. Select Platform > DCM > Global from the Configuration Manager 
window (Figure C-1.)

The Edit DCM Base Module Parameters window opens (Figure C-2.)

7. Select Enable in the Enable/Disable option and click on OK.

This boots the Ethernet DCM board with the new DCM software image that 
you specified in the Image Name field and saves the new DCM software 
image in Flash memory, if specified.

8. Select Local in the Boot Option box.

You select the Local option after you have saved the DCM software image to 
the Ethernet DCM’s Flash and you want to boot the Ethernet DCM from its 
Flash.

Using the Technician Interface

You can upgrade the DCM software image from the router’s Flash memory to the 
Ethernet DCM Flash memory by running the dcmload.bat script file from the 
Technician Interface.

Respond to prompts in the dcmload.bat script file as follows:

• When prompted for the image file name, use the form <volume:filename>. 

• When prompted whether to save the image on the DCM Flash, answer yes (y) 
to overwrite the existing image on the Ethernet DCM Flash with the new 
image. Answer no (n) to use the downloaded image once, but lose it at the 
next boot.

Caution: Running dcmload.bat script temporarily disables, then re-enables, 
the DCM board.
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Sample Display – dcmload.bat

       Use this script to download a DCM image from the router’s
Flash to a DCM board. 

When prompted for the image file name, use the form
<volume:filename>. 

When prompted whether to save the image on the DCM Flash,
answer yes (y) to overwrite the existing image on the DCM
Flash with the new image. Answer no (n) to use the downloaded
image once, but lose it at the next boot.

Specify DCM image name (volume:filename): 1:in11_140.obj

Do you want DCM to save this image on its FLASH? (y/n) [y]: y

Image Name is 1:dcmboot.exe
Image will be saved by DCM in its FLASH

Do you want to start the download process? (y/n) [y]: y
Downloading of DCM image has started. It will take few seconds to complete
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Appendix D
Upgrading Router Software

Using Quick2Config

This appendix provides guidelines for upgrading your existing AN, ASN, or ANH 
router to Router Software Version 11.0 using Quick2Config™. We assume that 
you have knowledge of basic Quick2Config operations. 

For detailed information about installing and using Quick2Config, refer to 
Installing the Quick2Config Tool and Configuring Your Router Using the 
Quick2Config Tool. 

Perform these steps:

1. Copy the router software image file (asn.exe or an.exe) from the CD to 
your PC.

2. Start the Quick2Config application.

To learn how to start Quick2Config from Windows 95 or from Windows 3.1x, 
refer to Configuring Your Router Using the Quick2Config Tool.

3. Select the Connect to a router on the network option (default) from the 
Starting Quick2Config Session Dialog Box.

4. Click on OK.

If the IP address for the router displays in the connection list, select it. 
Otherwise, enter the router’s IP address in the IP address box.
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5. Transfer the existing an.exe or asn.exe image from the router to the PC. 

a. Select File > Router File Manager. 

The Router File Manager window opens.

b. Select the an.exe or asn.exe image file name and the volume on which 
the image file resides.

If there are multiple volumes on the router, select the correct volume. 

c. Select File > Get from Router > TFTP from the Router Files Manager 
window.

This ensures that you have a backup of the existing image if you need it.

6. Remove the existing router software image from your router.

With the an.exe or asn.exe image file still selected (highlighted), select
File > Delete from the Router File Manager window.

The Delete File Dialog Box appears. Click on OK to delete the file.

7. Compact the contents of the Flash card.

Select File > Compact from the Router File Manager window.

Make sure that you select the same volume from which you just deleted the 
an.exe or asn.exe image file.

You compact the Flash card to ensure that the Flash card contains enough 
contiguous free space to accommodate the new Version 11.0 software image.

8. Transfer the Version 11.0 an.exe or asn.exe image file from the PC to the 
router’s Flash card.

Select File > Send to Router > TFTP from the Router File Manager window.

Be sure to transfer the new Version 11.0 software image to the same volume 
from which you removed the previous one.

9. Close the Router File Manager.

Select File > Exit.

10. Boot the router with the new Version 11.0 image (an.exe or asn.exe).

Quick2Config boots the router using the specified router software image and 
configuration file.

Refer to Configuring Your Router Using the Quick2Config Tool for detailed 
instructions on booting a router using Quick2Config.
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 Glossary

ace.out

afn.exe

an.exe

Router software image containing executable files used to boot FN, LN, ALN, 
AFN with diskette, and CN routers.

Router software image containing executable files used to boot an AFN router.

Router software image containing executable files used to boot an AN or ANH 
router.

asn.exe

bn.exe

booting 

Router software image containing executable files used to boot an ASN router.

Router software image containing executable files used to boot a BN router.

The process in which a device obtains information and begins to process it to 
attain a state of normal operation.

BOOTP Bootstrap Protocol, a TCP/IP network protocol that lets network nodes request 
startup and configuration information from a BOOTP server node. 

config Network configuration file containing proprietary protocol services code.

Directed Netboot Bay Networks procedure for getting router startup files from a TFTP server on 
the IP network.

DLCMI 

DOS

Data Link Control Management Interface. Specification for the use of Frame 
Relay products that defines a method of exchanging status information between 
devices.

The primary disk operating system used by IBM and compatible personal 
computers.

driver 

dynamic

 A hardware device or program that controls or regulates another device.

The ability of a display or view to change as a result of ongoing network activity.
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Ethernet Type of network cabling and signaling that operates at the data link layer of the 
OSI model. 

Flash Memory Removable Personal Computer Memory Card International Association 
(PCMCIA) standard memory card. The ASN uses a Flash memory card to 
provide storage for its nonvolatile file system (NVFS), called the local file 
system.

Frame Relay

freboot.exe

frediag.exe 

Standard, connection-oriented protocol for use between data terminal equipment 
and data communications equipment. Frame Relay complies with the ANSI 
Annex D and LMI Frame Relay management specifications, along with the 
CCITT (now ITU-T) Annex A specification.

Copy of the bootstrap image resident on the Boot PROM for the BCN and BLN 
router.

Copy of the diagnostic image resident on the Diagnostic PROM for the BCN and 
BLN.

HDLC High-Level Data Link Control, a protocol that provides error correction at the 
data link layer.

image 

IP

One or more executable files used to boot a router; for example, asn.exe.

The Internet Protocol defined in RFC 791.

Local Boot 

MB

Bay Networks procedure for getting router startup files from the file system 
stored in local Flash memory.

Megabytes.

MIB

modem 

MS-DOS

multicast packets

Management Information Base. A standard or proprietary database that contains 
network configuration parameters and statistics.

A modulator-demodulator, a device that converts digital signals used by 
computers to analog signals that can be transmitted over telephone lines, and 
vice versa.

Microsoft Disk Operating System. A version of DOS used by computers that are 
compatible with IBM personal computers.

Targeted broadcast packets sent to a defined group.

Netboot Bay Networks procedure for getting router startup files from a BOOTP server on 
the IP network.
Glossary-2 114047 Rev. A



 Glossary
node 

packet

On local area networks, a device that is connected to the network and is capable 
of communicating with other network devices.

A unit of data sent across a network.

Ping

PPP 

router 

A program that is useful for testing and debugging networks. Ping sends an echo 
packet to the specified host and waits for a response. It then reports success or 
failure and statistics about its operation.

Point-to-Point Protocol, a protocol that provides a way of running IP over serial 
lines. It uses a variation of HDLC.

A device that connects two or more networks and can direct traffic based on 
network resource availability.

Site Manager Bay Networks network management application. It is an SNMP-based graphical 
user interface used by network administrators to manage Bay Networks routers.

SNMP 

stack

Telnet

Simple Network Management Protocol, a network management protocol on 
TCP/IP networks.

A group of drivers that work together to span the layers in the network protocol 
hierarchy.

Internet standard protocol for remote terminal connection service. Telnet is 
described in RFC 854.

Technician 
Interface

A software command-line interface, operating in router memory, that 
administrators use to manage Bay Networks routers.

TFTP Trivial File Transfer Protocol. A protocol that enables file sharing over TCP/IP 
networks.

Windows

WinSock

Microsoft Windows, the graphical user interface on which the router software 
runs.

Windows Sockets. An application programming interface (API) support for IP 
environments.
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asn.exe image. See also image, software
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backing up files, 2-4
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boot interval
changing, 5-13

Boot option
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Boot PROM
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deciding whether to upgrade, 5-7
how to upgrade, 5-7
methods for replacing, 5-7
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upgrading and verifying, 5-8
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booting
router, 5-13
with a customized image, 5-13
verifying success of, 5-14
with a new configuration file, 5-14

BOOTP server, definition of, Glossary-1

C
commands

prom command failed, 2-8

compatibility, file, 4-5

CompuServe, Bay Networks forum on, xx

configuration file, definition of, Glossary-1

configuration files
upgrading, 5-15

contiguous free space, 2-5

contiguous free space on Flash volume, 
determining amount of, 2-3

Customer Service FTP, fix

customer support. See getting help

customized, 4-6, 5-1

customized image
booting the router with, 4-6
converting, 4-6
transferring, 4-6
verifying, 4-6

D
Data Collection Module (DCM)
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upgrading the DCM software image, C-1
DCM software image compatibility, C-1
transferring the DCM software image, C-2

from CD ROM to your PC or UNIX
workstation, C-2
from PC or UNIX workstation to the router, 

C-2
from the router’s Flash memory to the DCM 

Flash, C-2
Flash media, C-5

dcmload command, C-5 to C-6

Distinct TCP/IP, 3-3
upgrading, 3-3
installing, 3-4

driver
definition of, Glossary-1

E
Ethernet, Glossary-2

F
files

compatibility of, 4-5
upgrading configurations, 5-15
using 7.x configurations, 4-5

flash cards
preparing routers, 4-2, 4-4
with one flash card, 4-2
with multiple flash cards, 4-4
configured for netboot, 4-3
using files from prior releases, 4-5

Flash memory
defined, Glossary-2

Frame Relay
defined, Glossary-2

Frame Relay, definition of, Glossary-2

free space, 2-5

G
getting help

from a Bay Networks Technical Response 
Center, xx

from the Support Source CD, xx
through Composure, xx
through Customer Service FTP, fix
through Innovates service, xx
through World Wide Web, fix

H
hardware configuration requirements, 2-1

HDLC encapsulation, Glossary-2

I
image

transferring to a router, 4-7 to 4-11

Image Builder, accessing, 3-10

image, software
defined, Glossary-2

in.exe, 2-6

Innovates service, xx

L
loading from CD-ROM onto UNIX workstation, 

3-7

M
memory

DCM option, C-5
flash, Glossary-2

MIB
defined, Glossary-2

O
overview of process, 3-1, 4-1, 5-1
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P
PPP wide-area protocol, Glossary-3

PROM command, 5-8

prom command failure, 2-8

PROMs
transfer image to Flash using TFTP

Site Manager, 5-9
Technician Interface, 5-9

verifying, 5-8

R
requirements

for upgrading, xi

router software
installing, 3-7
loading from CD-ROM onto PC, 3-7
loading into Image Builder, 3-10

router software image
customizing, 3-11

router software image. See image, software

router software images
definition of, 2-5
types of, 2-5

S
script files, 5-20

Site Manager, Glossary-3
installing, 3-4
upgrading

on a PC, 3-2 to 3-5
UNIX, 3-6

starting, 3-4

Support Source CD, xx

T
Technician Interface, Glossary-3

Technician Interface script files
definition of, 5-20

Technician Interface script files, transferring to a 
router, 5-19

testing, 3-3

TFTP
defined, Glossary-3

U
Updating PROMs

from a remote site, 5-12

upgrade
requirements, xi

upgrade kit
router software components, 2-9
Site Manager components, 2-9
verifying contents, 2-9

upgrading, 3-3
configuration files, 5-15
PC, 3-2
Site Manager, 3-2

on a PC, 3-2 to 3-5
UNIX workstation, 3-2

upgrading PROMs
methods for, 5-7

upgrading routers
checklist, 1-3
summary, 1-3
summary of steps, 3-1, 4-1, 5-1

upgrading Site Manager
UNIX, 3-6

upstream router
defined, Glossary-3

W
World Wide Web, Bay Networks home page on, 

fix
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