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VMware Remote Console 13.0

Release Notes

Release notes include product enhancements and notices, bug fixes, and resolved issues.

VMware Remote Console 13.0 Release Notes

This document contains the following sections

¢ Introduction
¢ About VMware Remote Console

Introduction

* VMware Remote Console 13.0 | 17 June 2025 | Build 24645870 | Mac App Store Build 24645974
* For VMware Cloud Foundation (VCF) and vSphere | Last document update 14 May 2025
* Check back for additions and updates to these release notes, marked New.

About VMware Remote Console

VMware Remote Console (VMRC) is a personal computer application that connects over a network to virtual machines
running on vSphere. The accompanying manual describes how to install VMRC, use it to access VMware virtual
machines, and perform operations on them.

As of version 11, VMRC requires direct access to port 443 on ESXi hosts. For more information, see Broadcom KB
316564. Compatibility with vCloud Director and VCF Automation may be limited.

What's New
VMRC 13.0 offers a number of bug fixes, as detailed below.

VMRC 13 release does not have the Check for Updates option; users must download and install updates manually from
the Broadcom Support Portal.

System Compatibility

You can install VMRC on the following systems:

¢ Windows 11

*  Windows Server 2022 and 2025

e Linux machines running kernel version up to 6.11

* MacOS 14 and above, with VMRC from the Apple store.

VMRC and VMware Workstation cannot be installed on the same computer, because they share common components.
The same is true of VMRC and VMware Fusion.

Recently Resolved Issues

The VMRC 13 release resolves the following issues.

¢ After vMotion of a VM, VMRC sometimes caused a host crash.

In certain (no-queue) cases, VMRC called Acquire Ticket too frequently when attempting to reconnect with the VM in
its new location. This was fixed both on ESX hosts and in VMRC itself.
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* Too many resources used with multiple VMRC sessions.
A customer reported high memory use and too many HTTP connections when many instances of VMRC were
connected to the same host. This was a regression in VMRC 11, caused by calling Property Collector filters
unnecessarily. Such calls are now made only when needed.

¢ VMRC can crash immediately after connecting to a VM.
After an upgrade to vSphere 8.0 U3b, VMRC failed immediately after connecting to a VM. The cause was that vSphere
failed to report vim.TaskInfo.reason during connection. In this release, VMRC ignores the missing value and continues.

¢ The Japanese locale showed an English user interface.
When the locale was set to Japanese, the VMRC 12.0.5 user interface displayed in English. The workaround was to
delete duplicate entries in the vmware.vmsg message translations. This issue is fixed in this release.

* VMRC could fail when accepting a security certificate.
When a Linux X11 server was set to 32-bit color depth instead of 24-bit, VMRC would exit after asking the user to
accept a security certificate. The workaround was to run X11 in 24-bit mode, but 32-bit support is improved in this
release.

Known Issues and Workarounds

These issues were also found in the previous VMRC 12 release.

* Some device operations are not supported on MacOS.
When you access virtual machines using the VMRC MacOS client, you cannot perform certain device operations. For
example, you cannot add new devices or display sound card settings.

* VMRC for MacOS slow with passthrough on mass storage devices.
When a mass storage device is mounted and passes through a remote virtual machine, the MacOS VMRC client may
freeze for several seconds. The workaround is to manually unmount the mass storage device from the host operating
system before initiating passthrough in VMRC.

VMware Remote Console 13.0.1 Release Notes

This document contains the following sections

¢ Introduction
¢ About VMware Remote Console

Introduction

¢ VMware Remote Console 13.0.1 | 29 Sept 2025 | Build 24954779 | Mac App Store Build 24958001
* For VMware Cloud Foundation (VCF) and vSphere 9.0.1| Last document update 29 Sept 2025
* Check back for additions and updates to these release notes, marked New.

About VMware Remote Console

VMware Remote Console (VMRC) is a personal computer application that connects over a network to virtual machines
running on vSphere. The accompanying manual describes how to install VMRC, use it to access VMware virtual
machines, and perform operations on them.

As of version 11, VMRC requires direct access to port 443 on ESXi hosts. For more information, see Broadcom KB
316564. Compatibility with vCloud Director and VCF Automation may be limited.

What's New

VMRC 13.0.1 offers a number of bug fixes, as detailed below.
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System Compatibility

You can install VMRC on the following systems:

e Windows 11

*  Windows Server 2022 and 2025

* Linux machines running kernel version up to 6.14

¢ MacOS 15 and above, with VMRC from the Apple store.

VMRC and VMware Workstation cannot be installed on the same computer, because they share common components.
The same is true of VMRC and VMware Fusion.

Recently Resolved Issues

The VMRC 13.0.1 release resolves the following issues.

* Performed a security audit and upgraded some components.
In response to CVE reported security issues, the following open source components were upgraded: Freetype from
2.12 10 2.13.1, libxml2 from 2.13.3 to 2.14.3, sqlite from 3.47.0 to 3.50.2, openssl from 3.0.15 to 3.0.17, Python from
3.10.16 to 3.10.18, and libX11 from 1.7.1 to 1.8.10.

Known Issues and Workarounds

These issues were reported against the VMRC 13.0 release.

¢ Check for updates option.
The VMRC 13 release did not have the Check for Updates option, and neither does 13.0.1. Users must download and
install updates manually from the Broadcom Support Portal or Apple store.

* Power operations missing for VM launched using PowerCLlI.
When a remote virtual machine is launched from a PowerCLI URL, the power options are grayed out in the main
menu. There is no known workaround.

* VM name not displayed on the console if launched from VCF Automation.

When a remote virtual machine is launched from the VCF Automation portal, the VM name does not appear on the
heading bar of the VMRC application. There is no workaround at this time.

These issues were also found in the previous VMRC 12 release.

* Some device operations are not supported on MacOS.
When you access virtual machines using the MacOS client, you cannot add new devices or display sound card
settings.

* VMRC for MacOS with passthrough on mass storage devices.
When a mass storage device is mounted and passes through a remote virtual machine, the MacOS client may freeze
for several seconds. A workaround is to manually unmount the mass storage device on the host operating system
before initiating passthrough.
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VMware Remote Console for vSphere

This manual describes how to install VMware Remote Console and use it to access VMware virtual machines and perform
operations on them.

The virtual machine management and device configuration options described later in this guide might not be available for
all VMware platforms.

Intended Audience

This information is intended for administrators and users who need to access virtual machine consoles and connect client-
side devices.

Terminology
For explanations of unfamiliar terms in this product and others, search the web for "VMware Glossary" or VMware Topics.

VMware Remote Console for vSphere

This manual describes how to install VMware Remote Console and use it to access VMware virtual machines and perform
operations on them.

VMware Remote Console (VMRC) is a standalone personal computer application that can connect to vSphere assets and
open virtual machine consoles on remote hosts. VMRC provides access to virtual machines from remote clients and can
perform guest and device operations such as configuring operating system settings and monitoring virtual machine status.
On some platforms, VMRC can also modify virtual machine settings such as CPU cores, memory, and storage.

VMware Remote Console is a free product that does not require a license key to use.

Intended Audience

This information is intended for administrators and users who need to access virtual machine consoles and connect client-
side devices.

Terminology
For explanations of unfamiliar terms in this product and others, search the web for VMware Glossary or VMware Topics.

Installing VMware Remote Console
You can install VMware Remote Console on Windows, MacOS, and Linux operating systems.
For a list of client operating systems supported for install, see the release notes for your version of VMRC.

You install VMware Remote Console from a Zip file on Windows, a bundle file on Linux, or from the Apple store on
MacOS. Sections below describe where to find the bundle and Zip file on the Broadcom support site.

The virtual machine management and device configuration options described later in this guide might not available
for vSphere installations running VMware Cloud Director or (Aria) VCF Automation. In such cases, you should ignore
chapters about configuring and managing virtual machines and devices.

Install VMRC on Windows

Download the Windows installation package, extract, and run VMRC on your local machine.
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First verify that your local machine is running a supported version of Windows, as described in the release notes for the
version you downloaded.

This procedure describes how to use the installation wizard to install the VMRC application. If you want to perform a silent
installation, see Perform a Silent Installation of VMRC.

1. Navigate to the product download area for VMware Cloud Foundation on the Broadcom support site. Sign-in might be
required.

2. If this is your first download, you must visit one or both Terms and Conditions, then click the "l agree" checkbox to
activate the cloud download button.

Click View Group on the right to expand. Click the cloud icon to download.
Decompress the file to a temporary directory and run the installation wizard.
Click Next to begin installation.

Read and accept the terms of the license agreement and click Next.
Specify the installation directory and click Next.

Select whether to join the Customer Experience Improvement Program (CEIP). For more information about CEIP, see
Join or Leave Customer Experience Improvement Program.

9. Click Install.

© N Ok w

VMware Remote Console should be installed on your local machine and configured to open URLs that use the vmrc
scheme.

Perform a Silent Installation of VMRC

You can perform a silent installation of VMware Remote Console on Windows machines.

Silent installation, also known as unattended installation, allows system administrators to automate the installation
process. During a silent installation, the end user is not required to perform any actions.

Prerequisites:

» Verify that the target machine is running a supported version of Windows. For a list of supported operating systems,
see the release notes for your version of VMware Remote Console.

* Read the VMware Remote Console End-User License Agreement (EULA) and be sure you can accept its terms and
conditions. The EULA is not displayed during a silent installation. If you want to read the EULA, perform a standard
installation.

Follow these steps:

1. Follow the download steps above for VMRC on Windows.

2. Transfer the file to the target machine and decompress it to a temporary directory.
3. Run Command Prompt as an administrator.

4. Run the following command to perform a silent installation.

VMware-VMRC-version-build.exe /s /v "/gqn EULAS AGREED={0 | 1} INSTALLDIR="install-directory" DATACOLLECTION={0
[ 1} /1 "log-file"

Option Description

EULAS_ AGREED Enter 1 to indicate that you accept the terms and conditions of the
EULA. Entering 0 stops installation.

INSTALLDIR Enter the directory where you want to install VMRC. If the

directory does not exist, it will be created. If you do not include this
parameter, VMRC will be installed in folder:

C:\Program Files (x86)\VMware\VMware Remote Console.
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Option Description

AUTOSOFTWAREUPDATE This option has no effect since checking for updates was
discontinued.

DATACOLLECTION Enter 1 to join the Customer Experience Improvement Program
(CEIP) or 0 to decline.

/1 Enter the file path of the VMRC installation log file. If the file
does not exist, it will be created, but you must specify an existing
directory. If you do not include this parameter, installation log will
be written to the $TEMP%\vminst. log file.

VMware Remote Console should be installed on the target machines and configured to open URLs that use the vmrc
scheme.

Install VMRC on MacOS

You can install VMRC by searching for "VMware Remote Console" using the App Store application on your MacOS
machine.

Once downloaded from the Apple store, you can install VMRC in the same way as other App Store fitles.

Install VMRC on Linux

Download the Linux installation package, extract, and run VMRC on your local machine.

First verify that your local machine is running a supported version of Linux, as described in the release notes for the
version you downloaded.

The Linux installation package includes a GUI installer and command-line installer. To force the installer to use command-
line mode, add the —--console parameter when running the installation package.

Follow these steps:

1.

Navigate to the product download area for VMware Cloud Foundation on the Broadcom support site. Sign-in might be
required.

If this is your first download, you must visit one or both Terms and Conditions, then click the "l agree" checkbox to
activate the cloud download button.

Click View Group on the right to expand. Click the cloud icon to download.

Switch to the root user with the su or sudo command.

If necessary, grant execute permissions to the installation package.

chmod +x VMware-Remote-Console-version-build.x86 64.bundle

Run the installation package.

./VMware-Remote-Console-version-build.x86 64.bundle

To install in GUI mode, perform the following steps.

a.
b.
c.

Read and accept the terms of the license agreement. Click Next.
Select whether to join Customer Experience Improvement Program (CEIP) and click Next.
Click Install.

To install in command-line mode, perform the following steps.

a.
b. When you reach the end of the license agreement, type yes to accept the license agreement.
C.

d. Wait for the installation to complete.

Press Enter and read the license agreement. You can type g to move to the end of the license agreement.

If you want to join the Customer Experience Improvement Program (CEIP) type yes.

VMware by Broadcom
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Now VMware Remote Console should be installed on your local machine and configured to open URLs that use the vmrc
scheme.

Configuring and Managing VMRC
This section describes how to configure and manage the VMRC application on supported operating systems.

You can configure proxy settings, change display resolution, enable hardware acceleration, and join or leave the
Customer Experience Improvement Program (CEIP).

Configure Proxy Settings

You can configure a proxy server through which VMRC can connect to your virtual machines.
Note:

HTTP(S) is the only supported protocol for proxy connections.

In previous releases, the VMWARE HTTPSPROXY environment variable was used to set a proxy server. Proxy settings
configured in this procedure take precedence over the value VMWARE HTTPSPROXY . However, if you do not configure
proxy settings, VMWARE HTTPSPROXY continues to take effect.

To use a proxy server that requires authentication, you must configure proxy settings using this procedure rather than
accept the VMWARE HTTPSPROXY setting.

1. In a web browser, go to vmrc://settings and click Open Link. The Connection Proxy dialog appears. If VMRC was
already opened:
a. On Windows, select VMRC > Preferences.
b. On MacOS, select VMware Remote Console > Settings.
c. On Linux, select File > Remote Console Preferences.

2. In the Connection Proxy dialog, follow these steps:
a. Click Enable proxy for remote virtual machine. On Windows and Linux, also click Connection Proxy Settings.
b. Enter the IP address (or hostname) and port of your proxy server. You can enter either IPv4 or IPv6 address.

c. Enter the user name and password to authenticate with your proxy server. On MacOS, first click Using
Credentials.
d. Click OK or Save. On MacQOS, restart VMRC for the configured settings to take effect.

After you have configured proxy settings, VMRC will send all subsequent virtual machine connections through the
specified proxy server.

If VMRC displays connection-related errors, ensure that your proxy settings are correct. On MacOS, be sure you restarted
VMRC.

Set VMRC Console Display Resolution

You can configure display resolution preferences that determine how a virtual machine is displayed after resizing the
VMRC window.

Note:

You change display resolution by resizing the window. This action works only if VMware Tools is installed and up-to-date
in the target virtual machine.

1. In a web browser, go to vmrc://settings and click Open Link. A dialog window appears. If VMRC was already opened:
a. On Windows, select VMRC > Preferences.
b. On MacOS, select VMware Remote Console > Settings.
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c. On Linux, select File > Remote Console Preferences.
2. Click Display.
3. Choose your preferred VM Window Resize setting.

Option Name Preference Type Description

Resize the virtual machine and the window. | Autofit Guest The virtual machine display resolution will
resize to fit the window.

Stretch the virtual machine in the window. |[Stretch Mode The virtual machine display will stretch to fill
the window, but not change the resolution.

These display resolution preferences apply to both normal window and full screen mode.

Enable Retina Resolution

Full resolution for Retina Display option makes VMRC less stretchable, but the virtual machine console appears sharper
on a Retina display.

1. In a web browser, go to vmrc://settings and click Open Link. The Connection Proxy dialog appears. If VMRC was
already opened:
— On MacQS, select VMware Remote Console > Settings.

2. Click Display.

3. Check Use full resolution for Retina Display.

Join or Leave Customer Experience Improvement Program
This product participates in VMware's Customer Experience Improvement Program (CEIP).

The CEIP provides VMware with technical information used to improve the quality, reliability, and functionality of VMware
products and services. The information does not personally identify any individual. Details regarding the data collected
through CEIP and the purposes for which it is used by VMware are set forth in the Trust and Assurance Framework.

When you start VMRC for the first time, you are prompted to select whether you want to participate in the CEIP. You can
also choose to join or leave the CEIP at any time thereafter by performing the following procedure.

1. In a web browser, go to vmrc://settings and click Open Link. A dialog window appears. If VMRC was already opened:
a. On Windows, select VMRC > Preferences.
b. On MacOS, select VMware Remote Console > Settings.
c. On Linux, select File > Remote Console Preferences.

2. Click Feedback.

3. Select or deselect Join the VMware Customer Experience Improvement Program.

Configure Hardware Acceleration

Hardware acceleration can improve performance and reduce battery usage. This functionality is turned off by default to
avoid breaking VMRC when used with unstable graphic cards. You can enable it in the VMRC settings.

1. In a web browser, go to vmrc://settings and click Open Link. A dialog window appears. If VMRC was already opened:
a. On Windows, select VMRC > Preferences.
b. On Linux, select File > Remote Console Preferences.

2. On Windows or Linux, select Hardware Acceleration.

3. Click OK.
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Configuring and Managing Virtual Machines
You can perform certain virtual machine configuration tasks directly in VMRC.

When connected to a virtual machine, you can install VMware Tools, change virtual machine settings, control power
settings, and send key input to a virtual machine.

The procedures in topics below might not be supported for VMware Cloud Director or VCF Automation, formerly Aria
Automation.

Install VMware Tools

In Windows and Linux, you can use VMRC to install VMware Tools on virtual machines. This feature is not available in
MacOS.

1. Access the target virtual machine in VMRC.
2. Initiate VMware Tools installation on the virtual machine. The following menu selections mount the VMware Tools 1ISO
file to the first virtual CD/DVD drive on the virtual machine.

— On Windows, select VMRC > Manage > Install VMware Tools.
— On Linux, select Virtual Machine > Install VMware Tools.

If VMware Tools was already installed on the virtual machine, the menu item changes to Reinstall VMware Tools. If an
outdated version of VMware Tools is installed on the virtual machine, the menu item changes to Update VMware Tools.

3. In the guest operating system, install VMware Tools. For detailed instructions, see "Installing VMware Tools" in the
VMware Tools User Guide.

4. Open the virtual machine settings in VMware Remote Console.
— On Windows, select VMRC > Manage > Virtual Machine Settings.
— On Linux, select Virtual Machine > Virtual Machine Settings.
5. On the Options tab, select VMware Tools and specify the desired configuration.

You can select whether to synchronize the guest and host operating system time and whether to update VMware Tools
manually or automatically.

Change Virtual Machine Settings
You can change the display name and the operating system type of a virtual machine.

You may want to change the operating system type of a virtual machine after you upgrade the operating system on the
virtual machine, or if an incorrect operating system type was selected for the virtual machine. Changing the operating
system type does not automatically change the guest operating system. It changes only the configuration file for the
virtual machine. Changing the operating system type is not supported in Linux, because its VMRC client cannot perform
operations on powered-off virtual machines.

To change virtual machine settings including operating system type display name:

1. Access the target virtual machine in VMRC.
2. If you want to change the operating system type, power off the virtual machine.
3. Open virtual machine settings.
— On Windows, select VMRC > Manage > Virtual Machine Settings.
— On MacQS, select Virtual Machine > Settings.
— On Linux, select Virtual Machine > Virtual Machine Settings.
4. Open the general virtual machine settings.
— On Windows or Linux, open the Options tab and click General.
— On MacQS, click General.
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5. Enter the desired name and select a guest operating system type.

The virtual machine configuration file is updated to reflect your changes.

Control Power Settings
You can use VMRC to restart, suspend, power on, and power off your virtual machines.

If VMware Tools is installed on your virtual machine, VMRC provides soft shutdown options by default. VMRC sends a
hard shutdown if VMware Tools is not installed or if the virtual machine is unresponsive.

CAUTION:

A hard shutdown while the virtual machine is still processing could cause data loss. Use soft shutdown whenever
possible.

1. Access the target virtual machine in VMRC.

2. Open the power menu.
— On Windows, select VMRC > Power.
— On MacQOS, select Virtual Machine.
— On Linux, select Virtual Machine > Power.

3. Select the desired power option.

If the virtual machine is powered off or suspended, select Power On.

5. To power off a virtual machine, select Shut Down Guest (Windows), Shut Down (MacOS), or Power Off Guest
(Linux).
On MacQS, you can force a hard shutdown by pressing the Command key while performing this step. This feature is
not available on Windows or Linux.

6. To restart a virtual machine, select Restart Guest (Windows), Restart (MacOS), or Reset Guest (Linux).

7. To suspend a virtual machine, select Suspend.

»

Send Key Input to a Virtual Machine

If your local machine intercepts the Ctri+Alt+Del key sequence, you can use VMRC to send that input directly to the virtual
machine. On MacOS, you can also send other key input if necessary.

1. Access the target virtual machine in VMRC.
2. Send the desired key input to the virtual machine.
— On Windows, select VMRC > Send Ctri+Alt+Del.
— On Linux, select Virtual Machine > Send Ctrl+Alt+Del.

— On MacOS, select Virtual Machine > Send Ctrl+Alt+Del to send the Ctrl+Alt+Del sequence or Virtual Machine >
Send Key > Name to send other key input. MacOS can send the following keys to virtual machines:

* Help (Insert)

* Home

e End

* Forward Delete
* Caps Lock

e Clear (Num Lock)
* Scroll Lock

* Print Screen

* Pause

e Break

* Menu
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e F8 through F16

Configuring and Managing Devices

You can use VMRC to add devices to virtual machines, including hard disks, CD/DVD drives, and parallel or serial ports.
You can also change virtual memory and processor settings, modify settings for existing devices, and manage ports and I/
O devices.

Not all features are available on all VMRC client operating systems.

Change Virtual Processor Settings
You can use VMRC to modify the number of processors or cores that are allocated to a virtual machine.
This option is not available in Linux, because its VMRC client cannot perform operations on powered-off virtual machines.

1. Access the target virtual machine in VMRC.
2. Power off the virtual machine.
3. Open the virtual machine settings in VMRC.
— On Windows, select VMRC > Manage > Virtual Machine Settings.
— On MacQOS, select Virtual Machine > Settings.
4. Open the processor settings.
— On Windows, open the Hardware tab and click Processors.
— On MacQS, click Processors and Memory.
5. Select the desired number of processors and cores.
On MacOS, you can select only the total number of cores.
6. Configure additional virtualization settings.
— On Windows, you can select Virtualize Intel VT-x/EPT or AMD-V/RVI.
— On MacOS, expand Advanced Options. You can then select one or more of the following options:
* Enable hypervisor applications in this virtual machine
* Enable code profiling applications in this virtual machine
* Enable IOMMU in this virtual machine

The virtual machine gets updated to reflect your changes.

Change Virtual Memory Settings
You can use VMRC to adjust the amount of memory that is allocated to a virtual machine.
This option is not available in Linux, because its VMRC client cannot perform operations on powered-off virtual machines.

1. Access the target virtual machine in VMRC.
2. Power off the virtual machine.
3. Open the virtual machine settings in VMware Remote Console.
— On Windows, select VMRC > Manage > Virtual Machine Settings.
— On MacQOS, select Virtual Machine > Settings.
4. Open the memory settings.
— On Windows, open the Hardware tab and click Memory.
— On MacOS, click Processors and Memory.
5. Enter or select the desired amount of memory for the virtual machine.

The virtual machine gets updated to reflect your changes.
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Add a New Virtual Hard Disk

On Windows and Linux, you can use VMRC to add a new virtual hard disk to a virtual machine. This feature is not

available in MacOS.

1. Access the target virtual machine in VMRC.

2. If you want to add an IDE hard disk, power off the virtual machine.
Adding an IDE hard disk is not supported in Linux, because its VMRC client cannot perform operations on powered-off

virtual machines.
3. Open the virtual machine settings in VMRC.

— On Windows, select VMRC > Manage > Virtual Machine Settings.
— On Linux, select Virtual Machine > Virtual Machine Settings.
4. On the Hardware tab, click Add to start the Add Hardware Wizard.

o

Select Hard Disk and click Next.
6. Select the desired hard disk type and click Next.

Option Description

IDE Create an IDE device, with VM powered off.
SCSI Create a SCSI device.

SATA Create a SATA device.

NVMe Create an NVMe device.

7. Select Create a new virtual disk and click Next.

8. Set the capacity for the new virtual hard disk.
9. Specify additional hard disk options.

Option

Description

Allocate all disk space now

Allocating all disk space when you create a virtual hard disk can
enhance performance, but requires all physical disk space to be
available now.

Store virtual disk as a single file

Select this option to store the virtual disk as a single file. With this
option selected, virtual disk starts small and expands as data is
added.

Split virtual disk into multiple files

Splitting the disk makes it easier to move the virtual machine

to another computer but may reduce performance with large
disks. Might be a no-op, because creating split virtual disks is not
supported for remote virtual machines .

10. Enter a path and filename for the virtual disk file.
11. Click Finish.

The wizard creates the new virtual hard disk. The disk appears to the guest operating system as a new, blank hard disk.

Add an Existing Virtual Disk

On Windows and Linux, you can use VMRC to add a new virtual hard disk to a virtual machine. This feature is not

available in MacOS.

Prerequisite: Verify that the VMDK file for the existing hard disk is located on the target virtual machine.

1. Access the target virtual machine in VMRC.
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2. If you want to add an IDE hard disk, power off the virtual machine.

Adding an IDE hard disk is not supported in Linux, because its VMRC client cannot perform operations on powered-off
virtual machines.

3. Open the virtual machine settings in VMRC.
— On Windows, select VMRC > Manage > Virtual Machine Settings.
— On Linux, select Virtual Machine > Virtual Machine Settings.

4. On the Hardware tab, click Add to start the Add Hardware Wizard.

5. Select Hard Disk and click Next.

6. Select the desired hard disk type and click Next.

Option Description

IDE Create an IDE device, with VM powered off.
SCSI Create a SCSI device.

SATA Create a SATA device.

NVMe Create an NVMe device.

7. Select Use an existing virtual disk and click Next.
8. Select the VMDK file for the desired hard disk.
9. Click Finish.

Manage Virtual Disks

On Windows and MacOS, you can use VMRC to remove or expand virtual hard disks and perform other operations. This
feature is not available in Linux, because its VMRC client cannot operate on powered-off virtual machines.

1. Access the target virtual machine in VMRC.
2. Power off the virtual machine.
3. If you want to compact or defragment a virtual hard disk, ensure that the hard disk is not mapped or mounted and is
configured in either dependent mode or independent persistent mode.
4. Open the virtual machine settings in VMware Remote Console.
— On Windows, select VMRC > Manage > Virtual Machine Settings.
— On MacOS, select Virtual Machine > Settings.
5. Open the settings for the target hard disk.
— On Windows, open the Hardware tab and select the desired hard disk.
— On MacQOS, select the desired hard disk under Removable Devices.
6. Perform the desired operation.
On Windows, choose from the following options:
— To remove the disk, click Remove.
— To expand the disk, click Expand in the Disk utilities section. Enter the desired disk size and click Expand.
— To map the disk to a local volume, click Map in the Disk utilities section.
— To defragment the disk, click Defragment in the Disk utilities section.
— To compact the disk, click Compact in the Disk utilities section.

— To change the disk mode, click Advanced in the Disk utilities section and select or deselect Independent. If you
configure the disk to use independent mode, select Persistent or Nonpersistent.

On MacOS, choose from the following options:
— To remove the hard disk, click Remove hard disk.
— To expand the disk, drag the Disk size slider or enter the desired value.

The following operations are supported on Windows only:
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e Compacting a virtual hard disk. Compacting reclaims unused space on the virtual disk.

» Defragmenting a virtual disk. Defragmenting rearranges files and unused space on the virtual disk so that programs
run faster and files open more quickly.

* Mapping a virtual hard disk to a local volume.

e Changing between dependent and independent mode.

Manage CD and DVD Drives

On Windows and Linux, you can use VMRC to add and manage CD/DVD drives on a virtual machine. Adding a CD/DVD
drive is not supported on MacOS, because its VMRC client cannot add hardware to a virtual machine.

1. Access the target virtual machine in VMRC.
2. If you want to configure a new CD/DVD drive, add it to your virtual machine:
a. Open the virtual machine settings in VMRC.
¢ On Windows, select VMRC > Manage > Virtual Machine Settings.
* On Linux, select Virtual Machine > Virtual Machine Settings.
b. Open the Hardware tab and click Add.
c. Select CD/DVD Drive and click Finish.
3. Open the settings for the target CD/DVD drive.
— On Windows or Linux, open the Hardware tab and select the desired CD/DVD drive.
— On MacOS, select the desired CD/DVD drive under Removable Devices.
4. Specify connection settings for the drive.
— To connect the drive immediately, select Connected (Windows or Linux) or Connect CD/DVD Drive (MacOS).
— To connect the drive each time the virtual machine is powered on, select Connect at power on.
5. Select whether the drive connects to a drive or image on your local machine or on the remote server.
6. Select the desired disk drive or disk image.

If you no longer need a configured CD/DVD drive, you can remove it from the virtual machine.

* On Windows or Linux, select the target CD/DVD drive and click Remove
¢ On MacOS, power off the virtual machine. Select the target CD/DVD drive and click Remove CD/DVD Drive.

Manage Floppy Drives

You can use VMRC to connect floppy drives to a virtual machine. On Windows, you can add or remove floppy drives.
Floppy add and remove are not supported on Linux because its VMRC client cannot operate on powered-off virtual
machines. Floppy add is not supported on MacOS because its VMRC client cannot add hardware to a virtual machine.

1. Access the target virtual machine in VMRC.
2. Windows only: if you want to configure a new floppy drive, add it to your virtual machine:
a. Power off the virtual machine.
b. Select VMRC > Manage > Virtual Machine Settings.
c. Open the Hardware tab and click Add.
d. Select Floppy Drive and click Finish.
3. Open the settings for the target floppy drive.
— On Windows or Linux, open the Hardware tab and select the desired floppy drive.
— On MacOS, select the desired floppy drive under Removable Devices.
4. Specify connection settings for the drive.
— To connect the drive immediately, select Connected (Windows or Linux) or Connect Floppy Drive (MacOS).
— To connect the drive each time the virtual machine is powered on, select Connect at power on.
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5. Select whether the drive connects to a drive or image on your local machine, or on the remote host.
6. Select the desired disk drive or disk image.
7. On MacOS, you can specify whether the drive is read-only.

If you no longer need a configured floppy drive, you can remove it from the virtual machine.

* On Windows, power off the virtual machine. Select the target floppy drive and click Remove.
¢ On MacOS, power off the virtual machine. Select the target floppy drive and click Remove Floppy Drive.

Manage Virtual Network Adapters

You can use VMRC to add and manage network adapters on a virtual machine. Adding a network adapter is not
supported on MacOS because its VMRC client cannot add hardware to a virtual machine.

1. Access the target virtual machine in VMRC.
2. If you want to configure a new network adapter, add it to your virtual machine.
a. Open the virtual machine settings.
¢ On Windows, select VMRC > Manage > Virtual Machine Settings.
* On Linux, select Virtual Machine > Virtual Machine Settings.
b. Open the Hardware tab and click Add.
c. Select Network Adapter and click Finish.
3. Open the settings for the target adapter.
— On Windows or Linux, open the Hardware tab and select the desired network adapter.
— On MacOS, select the desired network adapter under Removable Devices.
4. Specify connection settings for the network adapter.

— To connect the network adapter immediately, select Connected (Windows or Linux) or Connect Network Adapter
(MacOS).

— To connect the network adapter each time the virtual machine is powered on, select Connect at power on.
5. From the Network Connection drop-down menu, select a virtual network to which the network adapter will connect.

If you no longer need a configured network adapter, you can remove it from the virtual machine.

* On Windows or Linux, select the target network adapter and click Remove.
* On MacOS, power off the virtual machine. Select the target network adapter and click Remove Network Adapter.

Manage USB Controllers
You can use VMRC to add and manage USB controllers on a virtual machine.

1. Access the target virtual machine in VMRC.
2. On MacOS, power off the virtual machine.
3. If you want to configure a new USB controller, add it to your virtual machine.
a. Open the virtual machine settings.
¢ On Windows, select VMRC > Manage > Virtual Machine Settings.
¢ On MacOS, select Virtual Machine > Settings.
* On Linux, select Virtual Machine > Virtual Machine Settings.
b. Add a USB controller.
¢ On Windows or Linux, open the hardware tab and click Add. Select USB Controller and click Finish.
* On MacOS, under Removable Devices click USB. Then click Add USB Controller.
4. Open settings for the USB controller.
— On Windows or Linux, open the Hardware tab and select the USB controller.
— On MacQOS, select USB under Removable Devices.
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5. Select the USB version from the drop-down menu.
You can choose USB 1.1, USB 2.0, or USB 3.0.

If you no longer need a USB controller, you can remove it from the virtual machine.

¢ On Windows or Linux, select the USB controller and click Remove.

* On MacQOS, power off the virtual machine. Select the USB controller and under Advanced USB Options click
Remove USB Controller.

Connect Removable Devices
You can use VMRC to connect local USB and Bluetooth devices to a remote virtual machine.
Prerequisite: Verify that the device is connected on your local machine.

1. Access the target virtual machine in VMRC.

2. View available removable devices.
— On Windows, open the VMRC > Removable Devices menu.
— On MacQOS, select Virtual Machine > USB & Bluetooth > USB & Bluetooth Settings.
— On Linux, open the Virtual Machine > Removable Devices menu.

3. Connect the removable device to the virtual machine.

— On Windows or Linux, Linux, select the desired device from the Removable Devices menu and click Connect
(Disconnect from Host).

— On MacQOS, select the desired device under Connect USB devices from your Mac.

When the device is connected to the virtual machine, a check mark appears next to the name of the device, and a device
icon appears on the virtual machine taskbar.

If the device is connected to the client through a USB hub, the virtual machine sees only the USB device, not the hub.
If you need to disconnect a removable device, perform the following steps:

* On Windows or Linux, select the desired device from the Removable Devices menu and click Disconnect (Connect
to Host).

¢ On MacOS, deselect the desired device under Connect USB devices from your Mac.

Manage Sound Cards

On Windows and Linux, you can use VMRC to add or remove sounds cards on a virtual machine. This feature is not
available in MacOS.

1. Access the target virtual machine in VMRC.

2. Open the virtual machine settings.
a. On Windows, select VMRC > Manage > Virtual Machine Settings.
b. On Linux, select Virtual Machine > Virtual Machine Settings.

3. Open the Hardware tab and click Add.

4. Select Sound Card and click Finish.

If you no longer need a sound card configured, you can select the sound card and click Remove.

Manage Parallel or Serial Ports

You can use VMRC to attach (connect) virtual parallel ports or virtual serial ports to a virtual machine.
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On Windows, you can add and remove parallel or serial virtual ports. Adding ports is not supported on MacOS because its
VMRC client cannot add hardware to a virtual machine. Adding and removing ports are not supported on Linux because
its VMRC client cannot operate on powered-off virtual machines.

1. Access the target virtual machine in VMRC.
2. If you want to configure a new parallel or serial port, add it to the virtual machine.
a. Power off the virtual machine.
b. Select VMRC > Manage > Virtual Machine Settings.
c. Open the Hardware tab and click Add.
d. Select Parallel Port or Serial Port and click Finish.
3. Open settings for the target parallel or serial port.
a. On Windows or Linux, open the Hardware tab and select the desired port.
b. On MacOS, select the desired port under Removable Devices.
4. Specify connection settings for the port.
a. To connect the port immediately, select Connected on Windows and Linux. On MacOS, select Connect Parallel
Port or Connect Serial Port.

b. To connect the port each time the virtual machine is powered on, select Connect at power on.

5. Select whether the port connects to a physical port, an output file, or a named pipe. Named pipes are not available on
MacOS.

If you no longer need a configured parallel or serial port, you can remove it from the virtual machine.

¢ On Windows, power off the virtual machine. Select the target port and click Remove.

* On MacOS, power off the virtual machine. Select the target port and click Remove Parallel Port or Remove Serial
Port.

Manage Generic SCSI Devices

On Windows and Linux you can use VMRC to add or remove generic SCSI devices that map to physical SCSI devices.
Adding a generic SCSI device is not supported on MacOS because its VMRC client cannot add hardware to a virtual
machine.

1. Access the target virtual machine in VMRC.
2. If you want to configure a new generic SCSI device, add it to the virtual machine.
a. Open the virtual machine settings.
* On Windows, select VMRC > Manage > Virtual Machine Settings.
* On Linux, select Virtual Machine > Virtual Machine Settings.
b. Open the Hardware tab and click Add.
c. Select Generic SCSI Device and click Finish.
3. Open settings for the target device.
a. On Windows or Linux, open the Hardware tab and select the desired generic SCSI device.
b. On MacOS, select the desired generic SCSI device under Removable Devices.
4. Specify connection settings for the network adapter.

— To connect the network adapter immediately, select Connected on Windows and Linux. On MacQOS, select
Connect Generic SCSI Device.

— To connect the port each time the virtual machine is powered on, select Connect at power on.
5. Select a physical SCSI device to which the generic SCSI device will connect.

If you no longer need a configured generic SCSI device, you can remove it from the virtual machine.

¢ On Windows or Linux, select the target generic SCSI device and click Remove.
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* On MacOS, power off the virtual machine. Select the target generic SCSI device and click Remove Generic SCSI
Device.
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Documentation Legal Notice

This Documentation, which includes embedded help systems and electronically distributed materials, (hereinafter referred
to as the “Documentation”) is for your informational purposes only and is subject to change or withdrawal by Broadcom

at any time. This Documentation is proprietary information of Broadcom and may not be copied, transferred, reproduced,
disclosed, modified or duplicated, in whole or in part, without the prior written consent of Broadcom.

If you are a licensed user of the software product(s) addressed in the Documentation, you may print or otherwise make
available a reasonable number of copies of the Documentation for internal use by you and your employees in connection
with that software, provided that all Broadcom copyright notices and legends are affixed to each reproduced copy.

The right to print or otherwise make available copies of the Documentation is limited to the period during which the
applicable license for such software remains in full force and effect. Should the license terminate for any reason, it is your
responsibility to certify in writing to Broadcom that all copies and partial copies of the Documentation have been returned
to Broadcom or destroyed.

TO THE EXTENT PERMITTED BY APPLICABLE LAW, BROADCOM PROVIDES THIS DOCUMENTATION “AS

IS” WITHOUT WARRANTY OF ANY KIND, INCLUDING WITHOUT LIMITATION, ANY IMPLIED WARRANTIES OF
MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NONINFRINGEMENT. IN NO EVENT WILL
BROADCOM BE LIABLE TO YOU OR ANY THIRD PARTY FOR ANY LOSS OR DAMAGE, DIRECT OR INDIRECT,
FROM THE USE OF THIS DOCUMENTATION, INCLUDING WITHOUT LIMITATION, LOST PROFITS, LOST
INVESTMENT, BUSINESS INTERRUPTION, GOODWILL, OR LOST DATA, EVEN IF BROADCOM IS EXPRESSLY
ADVISED IN ADVANCE OF THE POSSIBILITY OF SUCH LOSS OR DAMAGE.

The use of any software product referenced in the Documentation is governed by the applicable license agreement and
such license agreement is not modified in any way by the terms of this notice

The manufacturer of this Documentation is Broadcom Inc.

Provided with “Restricted Rights.” Use, duplication or disclosure by the United States Government is subject to the
restrictions set forth in FAR Sections 12.212, 52.227-14, and 52.227-19(c)(1) - (2) and DFARS Section 252.227-7014(b)
(3), as applicable, or their successors.

Copyright © 2005-2025 Broadcom. All Rights Reserved. The term “Broadcom” refers to Broadcom Inc. and/or its
subsidiaries. All trademarks, trade names, service marks, and logos referenced herein belong to their respective
companies.
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