Windows Registry Guide

Windows Registry Guide Windows Registry Guide
Get the latest from http://www.winguides.com/registry/
Tricks, tweaks & hacks for optimizing, enhancing and securing Windows systems.

The Windows Registry Guide provides an extensive range registry tips, tricks & tweaks for optimizing, enhancing and securing the Windows operating system. Get started by exploring the categorized tweaks below or visit us online at http://www.winguides.com/

Categories

Enhancements Enhancements
Operating System and Application Enhancements

Files Files
Tweaks & Settings Found Outside the Registry

Performance Performance
Optimize and Increase System Performance

Security Security
Security Restrictions and System Policies

Tips and Tricks Tips and Tricks
Tweaks, Shortcuts and Hidden Windows Features

Troubleshooting Troubleshooting
Tips and Tricks to Fix System Problems

Documents and Resources

Windows Registry FAQ Windows Registry FAQ
The Windows Registry FAQ provides an insight into the functionality and components that form the Windows registry, the central storage area for all common Windows configuration settings.

Windows Scripting Guide Windows Scripting Guide External Link
Say good-bye to batch files and hello to Windows scripting, the native method used to automate your Windows system using the VBScript or JScript languages. The Windows Scripting Guide is loaded with source code and information to help you on your way to creating powerful scripts and macros.

Windows Security Guide Windows Security Guide External Link
Is your system secure? Have you been visited by hacker? Learn how to make your Windows system secure and keep it protected with current security alerts, vulnerabilites and patches at the Windows Security Guide.

Windows Support Forums Windows Support Forums External Link
If you have a question or require help with a Windows technical support problem, drop by the Windows Support Forums and access the wealth of information provided by the WinGuides community.

Return to Index Copyright © 2001. All Rights Reserved. License


Registry Guide : Enhancements

Home : Enhancements

Hardware Hardware
Hardware Functionality Enhancements

Network Network
Network & Connectivity Enhancements

Software Software
Enhancements for Specific Windows Applications

Windows 95, 98 & ME Windows 95, 98 & ME
Windows 95, 98 & ME Specific Enhancements

Windows NT/2000 Windows NT/2000
Windows NT & 2000 Specfic Enhancements

Remove the Minimize, Maximize and Close Tooltips (All Versions)
When you move your mouse over the three control boxes on a standard Window frame it will show tooltip text for each item. This tweak controls that function.

Change the Start Button Text (All Versions) Popular
Would you like to change the Start button to say something else, perhaps your name, company or any other 5 or less letter word? This article explains the procedure to manually modify the text of the Windows Start button.

Control the Auto Complete Mode (All Versions) Popular
This setting controls whether the automatic text completion (AutoComplete) feature of Windows explorer appends the suggested text to the words as you are typing as well as showing a drop-down list of available values.

Enable Font Smoothing (All Versions) Popular
This setting controls whether fonts are anti-aliased to appear smoother when displayed within Windows.

Change the Link Color of Active Files and Folders (All Versions)
This setting controls the color of the active file or folder when using the web view (single-click) display method.

Active Window Tracking Using Your Mouse Cursor (All Versions) Popular
This tweak allows you to control the Window focus using the mouse cursor, by making an application active simply by moving your mouse cursor over it. This similar behavior to X-Windows on Unix.

Display a Background Bitmap on Explorer Toolbars (All Versions) Popular
This tweak allows you to choose a a bitmap image to display as the background for the explorer toolbars.

Control Application Focus Settings (All Versions)
When Windows applications require user input or focus, they will either pop-up over the existing window, or their icon will flash on the taskbar waiting for user action. This tweak controls that behavior.

Removing the 'Shortcut to...' Text on Shortcuts (All Versions) Popular
Don't like having 'Shortcut to...' appended to every Shortcut? You're not alone. With this tip you can stop Windows for adding this text when creating links.

Change the Alignment of Drop-Down Menus (All Versions)
By default, Windows drop-down menus are aligned to the left, with this tweak you can change the default behavior to align the menus to the right instead.

Adjust the Mouse Double-Click Sensitivity Area (All Versions)
This setting controls the amount of mouse movement allowed between clicks, for two consecutive clicks to be registered as a double-click.

Change the Position of the Desktop Wallpaper (All Versions) Popular
Unfortunately Windows only gives you the limited options of center or tile for the placement of the desktop wallpaper. With this setting you can move the image anyway on your desktop.

Add an Expanding Control Panel to Start Menu (All Versions) Popular
Want easy access to the Control Panel options? With this tip you can add an expanding Control Panel folder to the start menu. This trick will work with most special folders too.

Add Explore From Here to Every Folder (All Versions) Popular
When you right click on any folder this will give you an option to Explore From Here, which will open up an explorer window of that folder.

Add Command Prompt Here to Every Folder (All Versions) Popular
If you still use the DOS prompt regularly, then this tip is for you. It creates a new right-click option to open a command prompt window at the directory you are currently working from.

Change the Size of Desktop Icons (All Versions) Popular
Are your icons too small? Or too big? This setting will let you resize them to suit your desktop preference.

Creating Program Aliases in Windows (All Versions)
A hidden feature in the Windows registry allows you to create program aliases. Allowing you to create, for example, an alias called JBLOGGS.EXE that when executed actually runs another program, e.g. NOTEPAD.EXE

Easily Use Notepad to Open a File (All Versions)
Enabling this setting will allow you to use Notepad to open a file by simply right clicking on the icon. Also the Notepad will be used to open the files by default if no association already exists.

Displaying Hi-Color Icons without the Plus Pack (All Versions) Popular
If you like a bit more color and detail in your icons, then step up to hi-color mode. With this setting your Windows icons are shown in all their hi-resolution glory.

Remove the Favorites Folder from the Start Menu (All Versions) Popular
This tweak allows you to remove the Favorites folder from the Start Menu.


Registry Guide : Enhancements : Software

Home : Enhancements : Software

Dr Watson Dr Watson
Tweaks for Dr Watson

Internet Explorer Internet Explorer
Tweaks for Internet Explorer

Microsoft Office Microsoft Office
Enhancements for Word, Excel, Access & Powerpoint

Outlook Express Outlook Express
Tweaks for Outlook Express

pcAnywhere pcAnywhere
Tweaks for Symantec pcAnywhere

Disable Media Player Upgrade Message (All Versions)
This setting allows you to disable the automatic Media Player upgrade message that appears when a new version of the player has been released.

Remove Items from Media Player (All Versions)
This tweak allows you to remove the Radio Bar, Media Favorites and Finding New Station from Windows Media Player.

Change the MSN Messenger Background Image (All Versions)
This tweak allows you to change the background bitmap image in the MSN Messenger service.

Change the Title of Windows Media Player (All Versions)
This tweak allows you to customize the title bar text shown on Windows Media Player.

Disable the Norton AntiVirus Splash Screen (All Versions)
This setting will stop the Norton AntiVirus Scanner startup logo from being shown.

Configure Symantec Live Update to Use Passive FTP (All Versions)
Norton LiveUpdate 1.3 and higher defaults to using active FTP. This tweak allows you to configure it to use passive FTP instead.

Disable the Norton Utilities Splash Screen (All Versions)
This setting will disable the Norton Utilities splash screen from being shown whenever the applications are run.

Enable DVD Features in Media Player (All Versions) Popular
This setting allows you to use Microsoft Media Player to Play and Open DVDs.

Control Active Server Pages Browser Buffering
This setting controls whether Active Server Pages (ASP) buffers output to a browser. If this setting is enabled then all output is collected before any is sent to the browser. This fixes some problems with incomplete and random data being sent to a browser using Internet Information Server (IIS).

Enable the GSM Audio Codec in Netmeeting 2.1
By default Netmeeting does not include the GSM audio codec, this tweak enables the GSM codec to enhance interoperability with other GSM capable applications.

Use Smooth Scrolling in Telnet (All Versions)
This tweak enables the smooth scrolling function in Windows Telnet.

Change the Default Gatekeeper Discovery TTL (All Versions)
This setting controls the TTL (Time To Live) for the gatekeeper multicast packets in Netmeeting.

Change the ICQ Email Tagline (All Versions)
Newer versions of ICQ come with a handy email client. Unfortunately they add "Download ICQ at ..." to the end of every outgoing message. You can remove or change this in the registry to whatever you like.


Registry Guide : Enhancements : Software : Internet Explorer

Home : Enhancements : Software : Internet Explorer

Create a Desktop Shortcut to Hotmail (All Versions)
This tweak can be used to create a shortcut directly to your Hotmail e-mail account on your desktop.

Disable the Custom Search Page in Internet Explorer (All Versions)
This setting allows you to diable the use of the custom search page in Internet Explorer.

Disable the Go Button in Internet Explorer (All Versions)
This setting is used to remove the "Go" button from the Internet Explorer toolbar.

Disable Internet Explorer Download Notification (All Versions)
This setting is used to disable download notification in Internet Explorer 5.0.

Specify the Default Internet Explorer Download Directory (All Versions)
This setting is used to specify which directory should be used as the default location to save downloaded files retrieved using Internet Explorer.

Hide Links Folder on Favorites Menu (All Versions)
Internet Explorer persistently creates a Links folder on the Favorites menu, this tweak allows you to remove it.

Changing the Internet Explorer User Agent String (All Versions)
Whenever a web browser is used to connect to a remote web server it includes a User Agent string that contains details about browser and operating system. This tweak allows you to add or remove additional information from this string.

Internet Explorer Intercepts the FTP Command (All Versions)
When you enter a FTP command such as "FTP ftp.microsoft.com" IE may launch instead of the DOS based FTP program.

Check for Internet Explorer Updates (All Versions)
Internet Explorer 5 and higher has the ability to automatically check for software updates. This tweak controls that feature.

Use an Alternate Source Viewer with Internet Explorer (All Versions)
By default when you use the View Source feature of Internet Explorer it launches Windows notepad as the text editor. This tweak lets you choose which editor to use.

Control the Internet Explorer Script Debugger (All Versions)
When an Internet Explorer detects an error on a page it has the ability to launch a script debugger to diagnose the problem. This setting controls the use of the Internet Explorer script debugging functions.

Add a Background Bitmap to the Internet Explorer Toolbar (All Versions)
Want to have you own bitmap shown on the Internet Explorer toolbar? It's simple with this registry setting.

Change the Internet Explorer & Outlook Express Toolbar Logo (All Versions) Popular
When you browse the Internet using Internet Explorer or read messages using Outlook Express, a logo is displayed indicating whether activity is taking place. With this tweak you can modify which logo is shown, customize it or reset it to the default.

Internet Explorer FTP Mode (All Versions)
Internet Explorer has the ability to display FTP sites as if they were local folders. This tweak controls which mode IE uses for FTP.

Clear Internet Explorer Typed URL History (All Versions) Popular
Internet Explorer caches any URL's that are typed into the address bar. This could become a privacy issue on a shared computer, or it may become a nuisance if there is a particular URL you want to remove without clearing the whole history.

Disable Expanding Internet Explorer New Menu
Usually when you click on the New menu in Internet Explorer it is expanded to include options like New Window, Message, Post and Internet Call. Using this tweak will stop the menu expanding and therefore only display the "New Window" option.

Show Friendly HTTP Error Messages (IE5) (All Versions)
By default Internet Explorer 5 will show a friendly version of any HTTP errors it receives, for example Error 404 Page Moved. This tweak controls that functionality allowing it to be enabled or disabled.

Control Smart Favorites Menu (IE5) (All Versions)
Internet Explorer 5 uses Personalized Menus which remembers which sites you have visited recently and hides the sites you haven't. This tweak allows you to enable or disable this functionality.

Correct Internet Explorer Window Location (All Versions)
Sometimes Internet Explorer may have problems with it's explorer window location, possibly placing the window off the screen or only allowing you to minimize or maximize the window. This tweak should reset Internet Explorer to the default position.

Change the Internet Explorer Search Engine (All Versions)
Normally when you type 'go keyword' in the Internet Explorer address bar IE will search the web using a Microsoft selected search engine. By modifying this key you can select which search engine to use.

Proxy Server Configuration (All Versions)
If you need to configure a proxy server on multiple computers, or would just like to automate the procedure through the registry then this tip will explain how.

Modifying the Internet Explorer Partial Address Feature (All Versions)
The Internet Explorer partial address feature, scans common domains for a match to a keyword entered in the Address bar. The feature is limited by default to searching only .COM, .EDU and .ORG domains. This tip allows you to add new domains and modify their priorities.

Hide the Internet Explorer Icon (All Versions)
This option hides the Internet Explorer icon from the Windows desktop.

Change the Location of the Outlook Express Mail and News Files (All Versions)
If you have installed Windows on a separate partition and want to keep it free of any unnecessary files, you can change the location of the mail and news files stored by Outlook Express to another partition.

Changing the Internet Explorer Window Title (All Versions)
This setting allows you to customize Internet Explorer by using your own window title. For example you could rename IE to 'My Browser' or anything else you like!


Registry Guide : Enhancements : Software : Microsoft Office

Home : Enhancements : Software : Microsoft Office

Remove Items from Office Places Bar (All Versions)
This tweak is used to remove items from the Places Bar in the Office 2000/XP Open and Save As dialog boxes.

Add Custom Places to the Office Dialog Box (All Versions)
This tweak is used to add custom places to the Office 2000 and Office XP Open and Save As dialog boxes.

Prevent the Office Clipboard Toolbar from Appearing (All Versions)
When you copy multiple items in any of the Microsoft Office programs, the Office Clipboard appears, allowing you to collect and paste multiple items stored in the toolbar. This tweak allows you to prevent the toolbar from automatically appearing.

Disable Office 2000 Tune Up (All Versions)
This setting is used to disable the Office tune up feature.

Disable Document Editing Time Tracking (All Versions)
Whenever you open a Office document the time open is tracked and added to the total "Edit Time". This tweak disables that tracking.

Configure Office to Use the Standard System Font (All Versions)
This setting causes Microsoft office to use the standard system font for the user interface instead of the default Office font.

Change the Number of Undo Levels in Excel 2000 (All Versions)
This tweak lets you modify the amount of undo history information that Excel will track. Increasing this value allows you to undo more than the default number of changes.

Enable Live Scrolling in Microsoft Word (All Versions)
Normally when you move through a Word document using the scroll bar the page doesn't update until you release the mouse button. With this tweak the document location is updated as you move.

Control the Behavior of the Office Assistants (All Versions)
These settings control the behavior of the office assistants.

Enable Four Digit Year Display in Microsoft Excel (All Versions)
When Excel formats a date, it uses one of several default formats, the most common is the system short date (yy). Therefore when a user types a 4-digit year (yyyy) date in Excel, it may be displayed in a 2-digit year (yy) format. This tweak changes to default the 4-digit format.

Control Microsoft Office 2000 Personalized Menus (All Versions)
Microsoft Office 2000 introduced personalized menus (a.k.a. adaptive menus) that remembers which items you use regularly and hides items you don't. This tweak allows you to enable or disable this functionality.

Changing the Registered Company in Microsoft Office (All Versions)
With previous versions of Microsoft Office it was necessary to re-install Office to change the registered company as shown on the splash screen and in the About dialog box. With Office 2000 it can be changed in the registry.

Deleting the Office Assistants (All Versions)
Are you annoyed by those office assistants always popping-up when you least expect it? This tweak will let you remove them for good!


Registry Guide : Enhancements : Software : Outlook Express

Home : Enhancements : Software : Outlook Express

Change the Start Page for Outlook Express (All Versions)
This setting can be used to change the page that Outlook Express loads in the right-hand window when it first starts-up.

Control the Ability to Use HTTP Mail in Outlook Express (All Versions)
This tweak is used to specify whether HTTP mail servers, such as Hotmail, can be used or created in Outlook Express.

Outlook Express and IMAP Settings (All Versions)
This tweak allows you to correctly setup Outlook Express to use folders on the IMAP server for Drafts and Sent Mail instead of duplicating them with local folders.

Prevent Account Changes in Outlook Express (All Versions)
This setting disables the ability for users to create or modify any mail, news or directory accounts in Outlook Express.

Remove the Outlook Express Splash Screen (All Versions)
Sick of the Outlook Express splash screen every time you start? This tip will help you remove it.

Change the Outlook Express Window Title (All Versions)
This setting allows you to customize Outlook Express by using your own window title. For example you could rename Outlook Express to 'My Mail Reader' or anything else you like!

Colorful Message Backgrounds (All Versions)
This setting enables colorful backgrounds with Outlook Express.


Registry Guide : Enhancements : Software : pcAnywhere

Home : Enhancements : Software : pcAnywhere

Display Host in List (pcAnywhere) (All Versions)
The registry entry allows the host to respond to remote requests for names. Thus, by disabling the registry item, you can hide the host from users scanning the network.

Add an Additional Delay to Browse Packets (pcAnywhere) (All Versions)
Use this setting when remotes display an incomplete list of TCP/IP hosts in the host list over a WAN or LAN connection.

Connect to TCP/IP Hosts With Unknown Status (pcAnywhere) (All Versions)
This registry entry allows a remote to try to connect to a host if the host's status is unknown. The usual reason for not knowing the host's status is that direct packets have been filtered by a firewall between the host and the remote.

Configure the TCP/IP Data Port (pcAnywhere) (All Versions)
Use this setting to select which TCP data port pcANYWHERE32 uses.

Configure the TCP/IP Status Port (pcAnywhere) (All Versions)
Use this setting to select which TCP status port pcAnywhere uses.

Port Compatibility with Legacy Versions (pcAnywhere) (All Versions)
pcANYWHERE32 8.0 hosts and remotes can connect to earlier hosts and remotes without any registry changes. You may want to turn off compatibility to limit network traffic or allow third party applications that have registered the ports that earlier versions of pcANYWHERE32 7.x and pcAnywhere 2.0 were using.

TCP/IP Broadcast Mode (pcAnywhere) (All Versions)
Use this setting to turn off or modify pcANYWHERE32's broadcast options to limit network traffic when the remote browses for a host.

TCP/IP Query Interval (pcAnywhere) (All Versions)
Use this setting to limit network traffic. Sometimes the additional network queries to refresh the browse list will interfere with getting status lights or making connections.

Configure the Winsock Buffer Size (pcAnywhere) (All Versions) Popular
Use this registry item to set the size in bytes of TCP's Winsock buffer. Using a large value may increase the throughput of connections where the delay is large in relation to the bandwidth. This includes Internet, ISDN, RAS, dial-up networking, WAN and satellite connections.

Compatibility with the OnNet 2.1 TCP/IP Stack (pcAnywhere) (All Versions)
This registry item resolves an issue where pcAnywhere displayed the wrong host IP address when using FTP's OnNet 2.1 TCP/IP stack.

Prompt for TCP/IP Host (pcAnywhere) (All Versions)
This registry item allows a TCP/IP remote to specify an IP address or name when you leave the "Host To Connect To" field blank.

Adapter Binding Mode (pcAnywhere) (All Versions)
This registry item allows a waiting host to bind to a new adapter, such as a dial-up adapter, without reinitializing the host.

TCP/IP Host Binding Mode (pcAnywhere) (All Versions)
This registry item allows you to specify whether the host will wait on the first TCP/IP address given by the operating system, or whether it will wait on the TCP/IP index as indicated by TCPIPHostAddressIndex.

Specify Host Mode TCP/IP Address (pcAnywhere) (All Versions)
This registry item allows you to specify which TCP/IP address index the host will wait on.

Multicast Packet Delay (pcAnywhere) (All Versions)
This sets the delay in milliseconds between each send. This is useful if multicast error correction is disabled.

Configure the Multicast Data Port (pcAnywhere) (All Versions)
This setting selects the port that the multicast data is sent to.

Multicast Error Correction (pcAnywhere) (All Versions)
This sets the level of error correction used on the host. The host specifies which level of error correction the remotes will use.

Multicast Adapter Selection (pcAnywhere) (All Versions)
Use this registry item for a multihomed, multicast host that is not binding to the correct network card. This can be why none of the remotes receive the multicast packets.

Configure Multicast Send and Receive Buffers (pcAnywhere) (All Versions)
These registry items set the number of receive and send buffers when using an error correction multicast session. For slow remotes, a larger value may lead to less data loss.

Multicast Maximum Transmission Unit (pcAnywhere) (All Versions)
This registry item sets the Maximum Transmission Unit (MTU) in bytes. The MTU is the maximum bytes that may be sent as one IP multicast packet.

Multicast Winsock Receive Buffer (pcAnywhere) (All Versions)
This registry item sets the size in bytes of the Winsock receive buffer.

Ignore DSR on Serial Devices (pcAnywhere) (All Versions)
Use this item for modems or other serial devices that do not initialize correctly because their DSR is not initially set. It is also useful if the modem connection does not have a DSR line.

Change Serial 56K Connection Speed (pcAnywhere) (All Versions)
Use this item when a serial connection can be made at 38,400 bps and 115,000 bps, but not at 57,600 bps.

TAPI Modem Errors (pcAnywhere) (All Versions)
Each time you add a TAPI modem, it generates a unique TAPI Permanent Line ID which is stored in pcANYWHERE32's connection items. If you no longer have a modem with this unique ID, pcANYWHERE32 displays an error message. This registry key tells pcANYWHERE32 how to handle this situation.

Configure IPX Search Mode (pcAnywhere) (All Versions)
This registry item enables the SAP method of network search instead of using the bindery when making IPX connections.

Hide the Record Session Button (pcAnywhere) (All Versions)
Use this registry key to hide the Record Session icon from the remote session toolbar.

Remote Printer Inactivity Time-out (pcAnywhere) (All Versions)
Use this setting if a print job is being separated into multiple jobs during remote printing. This item sets the inactivity time-out for the remote printing facility.

Configure Legacy Remote Print Mode (pcAnywhere) (All Versions)
This setting specifies the default print destination when connecting to a pcAnywhere 2.0 or 5.0 host.

Show Full Screen Reminder Message (pcAnywhere) (All Versions)
This setting turns the Full Screen Reminder Message on or off.

Host Connection Time-Out (pcAnywhere) (All Versions)
If pcAnywhere host does not respond, hang up. This is useful for scripts that call systems where a modem will answer, but the pcAnywhere host may not be running.

Run Smart Setup (pcAnywhere) (All Versions)
This setting controls whether SmartSetup is run when pcAnywhere is loaded for the first time.

Run the pcAnywhere Service in Stealth Mode (pcAnywhere) (All Versions)
Use this setting to hide the Host Waiting icon and Waiting dialog.

Use Computer Name Instead of Caller Name (pcAnywhere) (All Versions)
When this key is set, if a host has the "Prompt to confirm connection" option checked, the host computer's prompt dialog will display the remote's computer name instead of the caller's name when a connection is made.

Wait for Call After Disconnect (pcAnywhere) (All Versions)
If enabled, the host will not wait for a call when the remote disconnects.

Configure Persistent Cache (pcAnywhere) (All Versions)
This setting turns pcAnywhere's persistent cache feature on or off.

Multi-Processor Options (pcAnywhere) (All Versions)
This registry item specifies which processors pcANYWHERE32 8.0 will run on.

Prompt If Logged Out (pcAnywhere) (All Versions)
This registry key allows you to specify how pcANYWHERE32 will handle a remote connection when the pcANYWHERE32 host is waiting at the Windows NT login screen and the "Prompt On Connection" and "Disconnect On Timeout" options have been checked.

Speed Send File Size Limits (pcAnywhere) (All Versions)
The minimum size a file must be for SpeedSend to work is 10K. You can change this value.

Confirm File Send (pcAnywhere) (All Versions)
When this setting is disabled, the remote does not display the confirm prompt when sending a file.

Confirm File Delete (pcAnywhere) (All Versions)
When this setting is disabled, the remote does not display the confirm prompt when deleting a file.


Registry Guide : Enhancements : Hardware

Home : Enhancements : Hardware

Mouse Mouse
Windows Mouse Enhancements
Printers Printers
Windows Printer Enhancements

Enabling UDMA66 Mode on Intel Chipsets (Windows 2000) Popular
If you have a computer with an Intel chipset that supports UDMA66, you will still find that UDMA66 mode is disabled by default on Windows 2000 computers. This tweak enables it.

Fix AMD Athlon AGP Paging Issue (Windows 2000)
Windows 2000 based computers may stop responding when you use an Accelerated Graphics Port (AGP) program with an AMD Athlon processor. This is due to the memory allocated by the video adapter driver becoming corrupted. This registry tweak will fix the problem.

Modify the Keyboard Buffer Size (All Versions)
Occasionally Windows may report an error relating to an overflow in the keyboard buffer. This tweak can be used to increase the size of the buffer, and avoid this problem.

PC Speaker Beeping on Errors (All Versions)
If you get annoyed by the beeps and noises coming from your PC speaker but can't find a way to turn it off, then use this tip to disable it.

Control the CD-ROM Autorun Function (All Versions) Popular
Normally when you insert a disc into your CD-ROM drive, the contents are automatically launched. This tweak allows you to disable this behavior.


Registry Guide : Enhancements : Hardware : Printers

Home : Enhancements : Hardware : Printers

Specify the Print Server Broadcast Timeout (Windows NT/2000)
This setting is used to specify the timeout period between broadcasts of a print servers resources.

Specify the Printer Browser Timeout (Windows NT/2000)
This setting is used to specify the time a network printer should remain in the browse list before it is removed.

Control Printing Notification Messages (Windows NT)
By default Windows NT notifies a user with a popup message that their print job has been completed on the printer. This setting controls that behavior.

Change a Users Default Printer (All Versions)
This setting will allow you the change the default printer of a user by modifying the registry.

Changing the Default Printer Spool Directory (Windows NT)
Windows uses the hard drive to store information before sending it to a printer. If the system is acting as a print server it is possible that the default location may cause insufficient disk space.

Beep on Printer Errors (Windows NT)
When this setting is enabled the machine will beep every few seconds when a remote job error occurs on a print server.

Disable the Printer Server Browse Thread (Windows NT/2000)
When this option is enabled, the print spooler does not send shared printer information to other print servers.

Define the Scheduler Priority (Windows NT)
This setting controls the overall priority of the printer scheduler.

Disable Print Job Notification in Event Viewer (Windows NT)
By default Windows NT server adds an entry in the event log for every print job occurring on the spooler. This can quickly fill up the event log with redundant information.


Registry Guide : Enhancements : Hardware : Mouse

Home : Enhancements : Hardware : Mouse

Control the Mouse "Snap To" Feature (All Versions)
When enabled, this setting causes the mouse pointer to snap-to the default button of the active application window.

Reverse the Mouse Buttons (All Versions)
By default the left mouse button is the primary mouse button and the right is the secondary. This tweak lets you swap those buttons around to make the right the primary, which may be useful for left handed users.

Modify the Mouse Buffer Size (All Versions)
Occasionally Windows may report an error relating to an overflow in the mouse buffer. This tweak can be used to increase the size of the buffer, and avoid this problem.

Adjust IntelliMouse Scroll Function (All Versions)
This entry determines the number of lines scrolled for each rotation of the mouse wheel on a Microsoft IntelliMouse when no modifier keys (such as [Ctrl] or [Shift]) are pressed.


Registry Guide : Enhancements : Network

Home : Enhancements : Network

Clients Clients
Network Workstation Enhancements

Protocols Protocols
Network Protocol Settings for TCP/IP, IPX/SPX and NetBEUI

Remote Access Remote Access
Dial-up and Remote Access Enhancements

Servers Servers
Network Server Enhancements

Remove the Hand Icon for Shared Resources (All Versions)
Normally when you share a local resource on the network a hand icon is placed under the item to show it is shared. With this tweak you can remove the icon.

Suppress the Domain Controller Cannot Be Reached Message (Windows NT/2000)
When Windows is unable to contact a domain controller during a users login a popup error message is displayed, this message can be removed by modifying this setting.

Removing or Adding Items to Your Persistent Connections List (Windows NT)
Windows stores the names of previously mapped drives in the registry, this can be a security threat if vulnerable hidden shares are listed. An advantage is that this key can also be used to set default items for list, if for example inexperienced users were required to map common drives, your could store them here.

Specifying a Preferred Netware Server (Windows 9x/Me)
This setting allows you to specify a default Netware.

Display Domain Logon Confirmation (All Versions)
When this option is enabled, a dialog box is shown when successful validation by a Windows domain occurs.

Automatically Detect Slow Network Connections (Windows NT)
By default, Windows NT will attempt to detect the time-out on network links to determine their speed (high or low). This functionality can be disabled if Windows is having problems determining the speed of your link.

Define the Slow Link Time-Out (Windows NT)
Windows uses this value to define what should be classified as low speed and what is a high speed connection. The default time-out is 2000 milliseconds, any connection slower is considered a low speed link.


Registry Guide : Enhancements : Network : Clients

Home : Enhancements : Network : Clients

Specify the WinSock Database Files Location (Windows NT/2000)
This parameter specifies the path to the standard internet database files (HOSTS, LMHOSTS, NETWORKS, PROTOCOLS) used by the Windows Sockets interface.

Binding Multiple IP Address to a Single Network Card (Windows 9x/Me)
The Windows 9x GUI does not accept having multiple IP addresses specified for a single network adapter. This tweak allows you to add additional IP addresses using the registry.

Control the DNS Port Used for Lookups (Windows 9x/Me)
This setting controls which port is used for DNS lookup requests. The default is port 53, but in some firewall situations the settings can be useful to specify an alternate port.

Control Keep Alive Parameters (Windows 9x/Me)
These settings control how Windows manages connection keep alive transmissions. Including the timeout before keepalives are sent, the interval between keepalive transmissions and how often to send session keepalive packets on active sessions.

Control the Timeout for LMHOST Name Resolution (Windows 9x/Me)
This setting controls the period of time the system will wait before timing out when seeking LMHOSTS for name resolution.

Specify the Number of Simultaneous Connections (Windows 9x/Me)
This setting specifies the maximum number of concurrent connections accepted.

Enable Random Adapter Responses (Windows 9x/Me)
For a computer with multiple network adapters, this setting specifies whether to respond with an IP address selected randomly from the range of addresses on the computer or whether to return the IP address of the adapter that the request came in upon.

Disable Automatic Netware Logon (Windows 9x/Me)
This setting disables the automatic logon to Netware servers.

Disable SAP advertising for Netware Networks (Windows 9x/Me)
By default Windows will send SAP packets to advertise available file and print shares when 'File and Print Sharing for Netware Networks' is enabled, this setting disables those packets.


Registry Guide : Enhancements : Network : Protocols

Home : Enhancements : Network : Protocols

TCP/IP TCP/IP
Internet Protocol Enhancements
Windows Internet Name Service Windows Internet Name Service
WINS Settings and Enhancements

Control the Use of Dynamic Domain Name System (Windows 2000)
Windows 2000 supports dynamic Domain Name System (DDNS) updates and is enabled by default for Windows 2000 DNS clients. This setting allows you to control whether network adapters should send updates.

Specify the Number of Broadcast Name Resolution Attempts (Windows 9x/Me)
This setting controls the number of attempts to resolve a NetBIOS name using a broadcast query.

Specify the Timeout Period for Broadcast Queries (Windows 9x/Me)
This setting allows you to specify the period of time the system will wait before timing out broadcast name queries.

Specify the NetBIOS Name Cache Timeout Period (Windows 9x/Me)
This setting specifies the period that NetBIOS names are cached before requiring an additional name query.

Specify the Number of NetBIOS Entries to Store (Windows 9x/Me)
These settings control the maximum number of NetBIOS entries to store in the name and session tables.

Specify the NetBIOS Name Resolution Mode (Windows 9x/Me)
There are several modes used in the resolution of NetBIOS, including WINS and LMHOSTS lookups and broadcast queries. This setting controls which mode is used.


Registry Guide : Enhancements : Network : Protocols : Windows Internet Name Service

Home : Enhancements : Network : Protocols : Windows Internet Name Service

Enable WINS Proxy Agent (Windows 9x/Me)
This setting controls whether the current computer should act as a WINS proxy agent and forward WINS name queries.

Control the WINS Refresh Period (Windows 9x/Me)
This setting control the initial WINS refresh timeout value.

Specify the WINS Port Number (Windows 9x/Me)
This setting allows you to specify an alternate port number to use with all WINS name queries and registration requests.

Control WINS Query Settings (Windows 9x/Me)
These settings control the WINS query parameters including the number of query attempts and query timeout.

Specify Response Mode for Multi-Adapter Computers (Windows 9x/Me)
For a computer with multiple network adapters, this setting specifies whether to send all IP addresses on a name query request from WINS.


Registry Guide : Enhancements : Network : Protocols : TCP/IP

Home : Enhancements : Network : Protocols : TCP/IP

Enable Source Routing on Token Ring Networks (Windows NT/2000)
Setting this parameter to 1 will force TCP/IP to transmit ARP queries with source routing enabled on Token Ring networks. By default, the stack transmits ARP queries without source routing first and retries with source routing enabled if no reply was received.

Control Selective Acknowledgement (SACK) Operation (Windows NT/2000)
This parameter controls whether or not Selective ACK (SACK - RFC 2018) support is enabled. With SACK enabled (default), a packet or series of packets can be dropped, and the receiver informs the sender which data has been received, and where there may be "holes" in the data.

Specify System-wide TCP Receive Window Size (Windows 98)
The TcpWindowSize parameter can be used to set the receive window on a per-interface basis. This parameter can be used to set a global limit for the TCP window size on a system-wide basis.

Modify the Number of Duplicate ACKs for Fast Retransmit (Windows 2000)
This parameter determines the number of duplicate ACKs that must be received for the same sequence number of sent data before "fast retransmit" is triggered to resend the segment that has been dropped in transit.

Optimize Windows TCP/IP Connection Retransmissions (Windows NT/2000)
This parameter determines the number of times TCP will retransmit a connect request (SYN) before aborting the attempt. The retransmission timeout is doubled with each successive retransmission in a given connect attempt.

Specify the Maximum Number of TCP/IP Connections (Windows NT/2000)
This parameter specifies the maximum number of connections that TCP may have open simultaneously.

Change the Maximum Transmission Unit (MTU) Size (Windows NT/2000) Popular
This parameter specifies the Maximum Transmission Unit (MTU) for a network interface. By optimizing the MTU setting you can gain substantial network performance increases, especially when using dial-up modem connections.

Decrease the TIME_WAIT Timeout to Increase Connections (Windows NT/2000)
This setting determines the length of time that a connection will stay in the TIME_WAIT state before being closed. The default is 240 seconds which on a busy server will limit the maximum connections to around 200/sec. Reducing this setting will increase the maximum connection limit.

Modify the Initial Retransmission Timeout (Windows NT/2000)
This parameter controls the initial retransmission timeout used by TCP on each new connection. It applies to the connection request (SYN) and to the first data segment(s) sent on each connection.

Change TCP/IP Broadcast Address (Windows NT/2000)
This setting allows Windows to be configured to use zeros-broadcasts (0.0.0.0) instead of ones-broadcasts (255.255.255.255). Most systems use ones-broadcasts, but some systems derived from BSD implementations use zeros-broadcasts.

Transmit Ethernet Packets Using 802.3 SNAP Encoding (Windows NT/2000)
Enabling this setting forces TCP/IP to transmit Ethernet packets using 802.3 SNAP encoding. By default, the stack transmits packets in DIX Ethernet format. It will always receive both formats.

Specify the Default TCP/IP Type of Service (TOS) (Windows NT)
This setting specifies the default type of service (TOS) for IP packets generated by the TCP/IP stack. This can be used to manage quality of service (QOS) throughout a network.

Specify the Default TCP/IP Time to Live (Windows NT/2000)
Specifies the default Time To Live (TTL) value set in the header of outgoing IP packets. The TTL determines the maximum amount of time an IP packet may live in the network without reaching its destination. It is effectively a limit on the number of routers an IP packet may pass through before being discarded.

Enable Dead Gateway Detection (Windows NT/2000)
This setting specifies whether Windows should automatically detect and use an alternate gateway in the event of transmiting a segment several times without receiving a response.

Detect Black Hole Routers During Path MTU Discovery (Windows NT/2000)
Specifies whether the stack will attempt to detect Maximum Transmission Unit (MTU) routers that do not send back ICMP fragmentation-needed messages.

Enable Path MTU Discovery (Windows NT/2000)
Enabling the setting causes TCP to attempt to discover the Maximum Transmission Unit (MTU or largest packet size) over the path to a remote host. By discovering the Path MTU and limiting TCP segments to this size, TCP can eliminate fragmentation at routers along the path that connect networks with different MTUs.

Specify the Router Buffer Size (Windows NT/2000)
This parameter determines how much memory IP allocates to store packet data in the router packet queue. When this buffer space is filled, the router begins discarding packets at random from its queue.

Specify the Conformance Level for IP Multicast (Windows NT/2000)
This parameter determines to what extent the system supports IP multicasting and participates in the Internet Group Management Protocol, RFC 1112.

Control Keep Alive Parameters (Windows NT/2000)
These settings control how Windows manages connection keep alive transmissions. Including the timeout before keepalives are sent and the interval between keepalive transmissions.

Specify the Router Packet Queue Size (Windows NT/2000)
This parameter determines the number of IP packet headers allocated for the router packet queue. When all headers are in use, the router will begin to discard packets at random from the queue.

Control Windows Treatment of Priority TCP/IP Data (Windows NT/2000)
This parameter determines whether TCP uses the RFC 1122 specification for urgent data or the mode used by BSD- derived systems. The two mechanisms interpret the urgent pointer in the TCP header and the length of the urgent data differently.

Controls RFC 1323 Time Stamp and Window Scaling Options (Windows NT/2000)
This setting controls RFC 1323 timestamps and window scaling options. Timestamps and Window scaling are enabled by default, but can be manipulated with flag bits.

Specify System-wide TCP Receive Window Size (Windows 2000)
The TcpWindowSize parameter can be used to set the receive window on a per-interface basis. This parameter can be used to set a global limit for the TCP window size on a system-wide basis.

Control Windows Treatment of Priority TCP/IP Data (Windows 9x/Me)
This value specifies how Windows should handle urgent data transfers, either in a same manner to some UNIX systems or as specified by RFC 1122.

Specify the TCP/IP Receive Window Size (Windows 9x/Me) Popular
This setting controls the size of the TCP/IP receive Window. In general, larger receive windows work better with high-delay, high-bandwidth data.

Enable Dead Gateway Detection (Windows 9x/Me)
This setting specifies whether Windows should automatically detect and use an alternate gateway in the event of a failed gateway.

Specify the Default TCP/IP Type of Service (TOS) (Windows 9x/Me)
This setting specifies the default type of service (TOS) for IP packets generated by the TCP/IP stack. This can be used to manage quality of service (QOS) throughout a network.

Specify the Default TCP/IP Time to Live (Windows 9x/Me)
This setting specifies the default time to live (TTL) value for IP packets generated by the Windows TCP/IP stack.

Specify the Conformance Level for IP Multicast (Windows 9x/Me)
This parameter determines to what extent the system supports IP multicasting and participates in the Internet Group Management Protocol, RFC 1112.

Control the Number of TCP/IP Connection Attempts (Windows 9x/Me)
This setting controls the number of TCP/IP connection attempts (SYN packets) to be transmitted before timing out.

Control the Number of TCP/IP Transmission Retries (Windows 9x/Me)
This setting defines the number of transmission retries will be transmitted before the connection is aborted.

Enable MTU Black Hole Detection (Windows 9x/Me)
Specifies whether the stack will attempt to detect Maximum Transmission Unit (MTU) routers that do not send back ICMP fragmentation-needed messages.

Enable MTU Discovery (Windows 9x/Me)
This setting specifies whether the TCP/IP stack will attempt to perform path MTU discovery as specified in RFC 1191.

Control TCP/IP Routing Parameters (Windows 9x/Me)
These settings control IP routing features including the total amount of buffer space to allocate for routing packets and the maximum number of packets that can be routed simultaneously.

Controls RFC 1323 Time Stamp and Window Scaling Options (Windows 9x/Me)
This setting controls RFC 1323 time stamps and window scaling options for TCP/IP packets.

Override the Default Broadcast Address (Windows 9x/Me)
This setting overrides the default broadcast address that is derived from the IP address and subnet mask. Primarily the broadcast address is used for NetBIOS name queries.

Optimize Windows TCP/IP Data Retransmissions (Windows NT/2000)
This parameter controls the number of times TCP will retransmit an individual data segment (not connection request segments) before aborting the connection.

Optimize the Windows TCP/IP Window Size (Windows NT/2000)
This parameter determines the maximum TCP receive window size offered by the system. The receive window specifies the number of bytes a sender may transmit without receiving an acknowledgment.


Registry Guide : Enhancements : Network : Remote Access

Home : Enhancements : Network : Remote Access

Dial-Up Networking Password Box Grayed Out (Windows 9x/Me)
If you are having problems trying to get DUN to remember your password and you find the option grayed out then there are a few things you can try.

Modify the Internet Auto-Dial Settings (All Versions)
Windows has the option to automatically dial your Internet Service Provider (ISP) to establish an Internet connection. This option can be controlled using this tweak.


Registry Guide : Enhancements : Network : Servers

Home : Enhancements : Network : Servers

Specify the Server Announcement Frequency (Windows NT/2000)
Specifies how often a nonhidden server announces itself to the network. More frequent announcements keep client server tables more up to date, but may increase network overhead and processing on client computers, because the clients must process every announcement.

Specify the Server Announcement Spacing (Windows NT/2000)
This parameter specifies the time by which the server announcement period can vary. This helps to prevent several servers from continuously announcing simultaneously, thereby reducing network load peaks.

Include a Comment in the Server Announcement (Windows NT/2000)
This setting allows you to specify a comment which is sent in server announcements and returned to NetServerGetInfo requests.

Specify the Idle Timeout for Server Connnections (Windows NT/2000)
Specifies the amount of idle time that a circuit is allowed before being disconnected. If this parameter is set to a low value, it saves server resources but reduces performance because of client overhead in reconnecting.

Control MS-DOS File Control Blocks (FCBs) Usage on Servers (Windows NT/2000)
Specifies whether MS-DOS File Control Blocks (FCBs) are folded together, so multiple remote opens are performed as a single open on the server to save resources.

Modifying LAN Based Auto-disconnect Time-Out (Windows NT)
Windows NT can be configured to automatically disconnect idle LAN sessions are a set number of minutes.

Support Long Filenames on Netware Servers (Windows 9x/Me)
This setting controls whether long filenames (LFN) are supported on Netware servers, and if supported which versions.


Registry Guide : Enhancements : Windows 95, 98 & ME

Home : Enhancements : Windows 95, 98 & ME

Automatic Logon without Name or Password (Windows 9x/Me) Popular
This setting allows Windows clients to logon without entering a user name or password, therefore bypassing the logon box.

Removing Suspend from the Start Menu (Windows 9x/Me) Popular
If the Suspend option doesn't work as it should, or you simply want to remove the option from the Start Menu, then use this tweak.

Use Windows Update Without Registering (Windows 98) Popular
Windows Update is a handy feature of Windows 98, having to register your personal details before being able to use it isn't as good! With this tip you can bypass the registration process.

Changing the Location of Windows 9x's Installation Files (Windows 9x/Me) Popular
Modifying the string will change the path that the Windows 95 setup program will look for the installation files.


Registry Guide : Enhancements : Windows NT/2000

Home : Enhancements : Windows NT/2000

Command Processor Command Processor
Enhancements for the NT/2000 Command Processor
Windows File Checker Windows File Checker
Enhancements and Tweaks for the File Checker

Open and Save Dialog Box Customization (Windows 2000)
These settings allow you to remove the places bar, most-recently-used (MRU) list and the back button from the common dialog boxes.

Use an Alternative User Interface (Windows NT/2000)
This setting allows you to specify an alternate shell to use as the Windows user interface instead of the default explorer shell.

Remove the Windows NT Security Menu Item (Windows Terminal Server)
This setting is used to hide the Windows NT Security menu item on the Start Menu of a terminal server session.

Remove the Disconnect Menu Item (Windows Terminal Server)
This setting is used to hide the Disconnect menu item on a terminal server Start menu.

Limit Bandwidth with the QoS Packet Scheduler Service (Windows 2000)
This setting allows you to specify combined percentage of Quality of Service traffic through a specific adapater.

Enable Manual Crash Feature (Windows 2000)
Microsoft Windows 2000 includes a feature that enables you to have the system stop responding and generate a Memory.dmp file (crash to blue-screen) by using a button combination on the keyboard.

Hide the Search Button on the Explorer Toolbar (Windows 2000)
This restriction allows you to remove the search button from the "Standard Buttons" toolbar in Windows explorer.

Auto Logon to a Windows NT Machine (Windows NT/2000) Popular
Windows NT includes a feature that allows you to automatically logon to the machine and network, bypassing the Winlogon dialog box.

Hard Disk Free Space Warning (Windows NT/2000)
By default Windows sends an administrative alert when the amount of free space remaining on a hard disk drive falls below 10 percent. This percentage can be configured using this setting.

Change the Number of Recent Documents to Display (Windows 2000)
This setting is used to specify the number of documents and files that are kept in the recent documents section of the Start menu.

Specify Users to Receive Administrative Alerts (Windows NT/2000)
This setting is used to specify a list of users and/or computers that should receive administrative alerts.

Specify the Schedule for Alerter Service (Windows NT/2000)
This setting is used to specify how often the server checks alert conditions and sends any required alert messages to administrative users.

Prevent Uploading Folders to a Users Server Profile (Windows NT/2000)
When profiles are used and a user logs off from a Windows NT domain certain folders are uploaded to the central user profile on the server. This setting allows you to stop any time consuming or non-essential folders (e.g. Temporary Internet Files) from being transferred.

Change the Display Color of Compressed Files and Folders (Windows NT/2000)
When a file is compressed in Windows NT, there is an option in Explorer to display it in a different color to easily distinguish them. This setting defines what color to use, the default is blue.

Control Network Browser Elections (Windows NT)
A browser election is a normal network occurrence and provides a means to guarantee there is never more than one master browser present in a domain or workgroup.

Configure the TCP/IP Settings of a Network Adapter (Windows NT/2000)
These values control the TCP/IP parameters of the network interface cards. Configurable parameters include IP Address, Subnet Mask and Default Gateway.

Improve Core System Performance in Windows NT (Windows NT/2000) Popular
On systems with large amount of RAM this tweak can be enabled to force the core Windows NT system to be kept in memory and not paged to disk.

Enable Start Menu Scrolling (Windows 2000)
When there are more items on the Start Menu than can fit on the screen, Windows can either create a second column of items or it can create a scrolling menu. This tweak controls that functionality.

Show Compressed Files in an Alternate Color (Windows NT/2000)
This setting controls whether compressed files and folders are shown in explorer using a different color to make them easily distinguishable.

Display the Attributes Column in Explorer (Windows 2000)
If you like to view your files using the detailed view option you may have noticed that the attributes column has disappeared. With the introduction of Windows 98 it was removed by default, this tweak adds it back.

Force the Use of Automatic Logon (Windows 2000)
Normally when a Windows machine is configured to automatically logon to a specified account users can bypass this and enter alternate account information. This tweak forces the machine to auto logon and to ignore any bypass attempts.

Changes the IRP Stack Size (Windows NT)
When you access shares on a computer running Windows NT Server from a Windows NT client and the IRPstackSize parameter is set too low on the server, you may receive the following error message: "Not enough server storage is available to process this command." This tweak should resolve the problem.

Create a Useful Name for My Computer (Windows NT/2000) Popular
This tweak will rename "My Computer" to "Username on Computername" making it simple to determine which computer you are logged on to and which username you are logged on as.

Windows NT Short File Extensions (Windows NT/2000)
Windows NT evaluates file extensions on the first three characters, therefore 'filename.html' is actually treated as 'filename.htm'. Therefore if you use a command such as 'del *.htm' to delete all the '.htm' files, you will also delete all '.html' files as well. This functionality can be disabled by modifying the registry.

Configuring the Registry Size Limit (Windows NT/2000)
The Registry Size Limit, or RSL, controls the total amount of space the may be consumed in paged pool memory and disk space by registry data. The RSL is a kind of "global quota" for registry space.

Automatically Reboot on the 'Blue Screen of Death' (Windows NT/2000)
Windows NT workstation will usually freeze when getting a dreaded 'Blue Screen of Death' (BSOD). Changing this setting will force Windows NT to automatically reboot when it crashes instead.

Show Cascading Control Panel Items (Windows 2000)
This tweak controls whether the Control Panel is shown as a cascading menu or as a simple folder link on the Start Menu.

Show Cascading Network Connections (Windows 2000)
This tweak makes the 'Network and Dial-up Connections' folder on the Start Menu into a cascading menu instead of a simple folder link.

Show Cascading My Documents Folder (Windows 2000)
This tweak makes the 'My Documents' folder on the Start Menu into a cascading folder, which then give you direct access to sub-folders without having to open the main 'My Documents' directory first.

Control Smart Menus (Windows 2000)
Windows 2000 included a new feature called 'Personalized Menus', which remembers which items you use regularly and hides items you don't. This tweak allows you to enable or disable this functionality.

Hide or Display Administrative Tools Menu (Windows 2000)
As with Windows NT, Windows 2000 has an 'Administrative Tools' folder on the Start Menu. This folder contains powerful administration utilities and therefore can be hidden to avoid accidental use.

Cascade the Printer Folder (Windows 2000)
This tweak controls when the 'Printers' sub-folder under 'Settings' on the Start Menu, is shown as a cascading folder.

Show Log Off [Username] on the Start Menu (Windows 2000)
This setting controls whether the 'Log Off [Username]' option is shown on the Start Menu.

Show Favorites on the Start Menu (Windows 2000)
This setting controls whether the Favorites folder is shown on the Start Menu.

Configure the DHCP Settings of a Network Adapter (Windows NT/2000)
This setting controls whether TCP/IP should use DHCP to automatically assign an IP address, or if it should use the statically defined address.

Change the Vertical Icon Spacing (Windows NT/2000)
This setting specifies the number of pixels that appear vertically between icons. Windows determines the default based on the icon title font and the display you are using.

Enable Plug-and-Play on Windows NT (Windows NT 4.0)
Windows NT4 doesn't support plug-and-play devices out of the box, but it can be configured to a least partially support some PnP features with a little help.

Power the Computer Off After Shutdown (Windows NT/2000) Popular
Enabling this setting will cause Windows to automatically power down your computer once it has finished the shutdown process.

Control the Default Virtual Machine Option (Windows NT/2000)
When starting a 16bit application you have the option of running each in a separate virtual machine (VDM). With this setting you can change the default value.

Automatically Close Non-Responding Applications (Windows NT/2000)
Occasionally when Windows NT shuts down, a task will return as 'Not Responding' and you are given the option to end the task. This tweak automatically closes any non-responding applications.

Run Logon Scripts Synchronously (Windows NT/2000)
This setting defines whether the system should wait for the logon scripts to complete before starting the user's shell or whether the scripts should run asynchronously.

Delete Cached Copies of Roaming Profiles (Windows NT/2000)
If this setting is enabled, when users with roaming profiles log off, the system will delete the cached copy of their roaming profile. This will help to save disk space where that are lots of roaming users.

Time-out for User Profile Dialog Boxes (Windows NT/2000)
When the user is presented with a dialog box requesting User Profile information, this specifies the amount of time in seconds before the dialog box is closed and the default is accepted. The default value is 30 seconds.

Allow extended characters in 8.3 filenames (Windows NT/2000)
This setting allows extended characters to be used in 8.3 filenames. Short file names with extended characters may not be viewable on computers that do not have the same character code page.


Registry Guide : Enhancements : Windows NT/2000 : Command Processor

Home : Enhancements : Windows NT/2000 : Command Processor

Enable Command Line Completion (Windows NT/2000) Popular
Command completion allows you to type a portion of a file name, and then have the system complete the rest by pressing the specified key. This is similar to the UNIX shell command completion feature.

Changing Default Colors for Command Prompt (Windows NT/2000)
The value DefaultColor controls the foreground and background colors used in command prompt windows. It has a default value of 0, for standard white text on a black background.

Enable Path Command Line Completion (Windows 2000)
Path completion is similiar to the concept of command completion. This setting allows you to specify a key, that when pressed completes the remainder of an incomplete directory name.

Run Startup Programs in a Command Prompt (Windows 2000)
This setting allows you to specify commands or programs to be automatically executed whenever a command processor is launched. For example, to set environment variables or parameters using a batch file.

Disable Command Processor Extensions (Windows 2000)
This setting controls whether command extensions are enabled or disabled. When command extensions are used they change the behaviour of various standard command processor functions such as CD, MD, DEL, PROMPT and SET.

Enable Delayed Environment Variable Expansion (Windows 2000)
This setting allows you to enable or disable delayed environment variable expansion in the command processor. If this feature is enabled then exclaimation characters can be used to substitute the value of an environment variable at execution time.


Registry Guide : Enhancements : Windows NT/2000 : Windows File Checker

Home : Enhancements : Windows NT/2000 : Windows File Checker

Manage Windows File Protection Scans (Windows 2000)
This setting controls whether the Windows File Checker (SFC) should scan and replace the protected files during boot up.

Specify the Directory to Store Cached SFC Files (Windows 2000)
This entry is used to specify which directory the Windows File Checker (SFC) should use to store the cached copies of protected files.

Display SFC Progress Meter (Windows 2000)
Specifies whether the Windows File Checker (SFC) progress meter should be displayed during file checking.

Disable Windows File Protection (Windows 2000) Popular
Windows 2000 introduced a new feature called Windows File Protection (WFP), part of the System File Checker, which is intended to avoid some of the common DLL consistency issues. This feature may also block valid attempts to change system files and it can therefore be disabled using this tweak.

Change the Size of the Windows File Protection Cache (Windows 2000)
The Windows File Protection feature of Windows stores copies of common DLL files and replaces them if the original becomes damaged or lost. This tweak lets you control the maximum amount of space available to be consumed by the backup DLL's.

Windows File Checker Command-line Options (Windows 2000)
The Windows File Checker is used to scans all the protected system files and replaces incorrect versions with a cached copy of the correct version. These are the command-line options to control the Windows file protection (WFP) utility.


Registry Guide : Files

Home : Files

AUTOEXEC.BAT
MS-DOS Startup Configuration File

BOOT.INI
Windows NT Configuration File

CONFIG.SYS
MS-DOS Startup Configuration File

MSDOS.SYS
Windows & DOS Configuration File

SYSTEM.INI
Windows Configuration File


Registry Guide : Files : AUTOEXEC.BAT

Home : Files : AUTOEXEC.BAT

Setting the Windows Temporary Directory (All Versions)
Depending on which version of Windows you run, temporary files are usually stored in C:\WINDOWS\TEMP. This tweak shows how to move the location of the temporary file directory.

Load Drivers and Programs into High Memory (Windows 3.1)
Programs and device drivers loaded from the AUTOEXEC.BAT file are normally loaded straight into low memory. This change allows them to be loaded high.

Remove Command Echoing (Windows 9x/Me)
Normally when commands are read and executed from the AUTOEXEC.BAT file, there are echoed back to the screen. This setting turns the echo off, which means only message text will be shown, and not the originating command.


Registry Guide : Files : BOOT.INI

Home : Files : BOOT.INI

Change the Default Operating System (Windows NT)
This setting in the BOOT.INI file controls which operating system the NT Boot Loader launches by default if none is selected.

Change Default OS Selection Timeout (Windows NT)
This setting controls the amount of time Windows NT will wait before loading the Default OS choice as define by the "default=" option.

Boot Windows NT with the Default VGA Video Driver (Windows NT)
This explains how to create an a safe VGA video mode start-up option, especially useful when your video adapter or driver is causing problems.

Boot Windows NT in Safe Mode (Windows NT)
Windows NT can be very temperamental sometimes are you add new software or install a new driver. The option allows you the create a Windows NT alternative to the Windows 9x Safe Mode. In this mode extra checks are performed and not all third party drivers are loaded.

Disable Detection of Devices on Serial Ports (Windows NT)
Windows NT attempts to probe the serial ports on boot-up to detect any serial mice. This can cause problems with other serial devices such as UPS's.

Enable the 4GT RAM Tuning Feature of NT Enterprise Edition (Windows NT)
With standard Windows NT Server, the per-process address limit is 2 gigabytes (GB) of random access memory (RAM). The 4GT feature of Windows NT Server/E increases this limit to 3 GB without introducing new APIs. 4GT does this by reducing the potential RAM allocated to the Windows NT kernel from 2 GB to 1 GB.


Registry Guide : Files : CONFIG.SYS

Home : Files : CONFIG.SYS

Load DOS Command Processor into High Memory (Windows 9x/Me) Popular
DOS is limited to 640kb low memory, as more device drivers are loaded that space is used up leaving less available memory for applications. This setting loads the DOS command processor into high memory, freeing some low memory for other applications.

Increase the Number Disk Buffers (Windows 3.1)
This setting can be used to increase the number of disk buffers available to DOS.

Load Device Drivers into Memory (Windows 3.1)
This setting is used to load specified device drivers into memory (or high memory).

Control the Number of File Control Blocks (FCBs) (Windows 3.1)
This setting specifies the number of file control blocks (FCBs) that the operating system can have open at the same time.

Controls the Number of Simultaneous Files (Windows 3.1)
This setting specifies the number of files that the operating system can access at one time.

Specify the Maximum Number of Drive Letters (Windows 3.1)
This setting control the maximum number of drivers accessible by a drive letter.

Control the Number of Data Stacks (Windows 3.1)
Support the dynamic use of data stacks to handle hardware interrupts.

Use Extended Memory (Windows 3.1)
Himem, an extended-memory manager, is a program that coordinates the use of your computer's extended memory, including the high memory area (HMA). It must be loaded before any application or device drivers can use extended memory.

Enable the Ability to Load Devices into Upper Memory (Windows 3.1)
Originally EMM386 was required to provide EMS memory, an alternate form of extended memory. Now with the sparse use of EMS, it's primary purpose is to provide support for loading real-mode device drivers in the upper memory area.


Registry Guide : Files : MSDOS.SYS

Home : Files : MSDOS.SYS

Running Scandisk on Boot Up (Windows 9x/Me)
If Windows 9x is shutdown incorrectly, or the turn power turned off without shutting down, the system will attempt to run Scandisk on the next boot. You can control whether Scandisk doesn't run, prompts whether to run, or runs automatically.

Control Windows Double Buffering Support (Windows 98)
Windows 98 includes double buffering support, some systems may have an incompatibility between the computer's BIOS and the Dblbuff.sys file.

Modifying the [Paths] Section of MSDOS.SYS (Windows 9x/Me)
The [Paths] section lists the locations for other Windows 95 files (such as the registry) and can be modified if files are moved.

Forces Your Computer to Boot in Safe Mode (Windows 9x/Me)
This setting when enabled forces your computer to always boot in Safe Mode.

Suppress Safe Mode Warning Message (Windows 9x/Me)
Enabling this setting suppresses the safe mode warning message when booting up, and bypasses the Startup menu.

Load Compression Driver into Low Memory (Windows 9x/Me)
This setting controls whether double space (or drive space) is loaded into high memory. If you are having compatibility problems with software that makes assumptions about the available memory try changing this setting.

Disable Function Keys During the Boot Sequence (Windows 9x/Me)
By default Windows 9x enables the function keys on boot, these allow you to control the boot process. For example pressing F5 while the "Starting Windows 95..." message is displayed will boot Windows in Safe Mode.

Change the Function Keys Timeout (Windows 9x/Me)
By default Windows 9x enables the function keys during the boot sequence for 2 seconds, these keys allow you to control the boot process. This value can be changed using this tweak.

Control Whether the Windows 9x GUI is Loaded Automatically (Windows 9x/Me)
By default Windows 9x automatically loads the GUI (or Windows Desktop) with this key you can control whether the GUI is loaded or if you just want the MS-DOS 7.0 prompt.

Display the Windows Splash Screen While Loading (Windows 9x/Me)
When Windows is loading normally you see the Windows clouds splash screen, this can be disabled to show the background DOS boot process.

Allow Booting to the Previous Operating System (Windows 9x/Me)
If you installed an upgrade version of Windows 9x, you can normally press F4 to boot your previous version of Windows. This option can be disabled.

Showing the Windows Boot Menu (Windows 9x/Me)
By default Windows 9x does not show the boot menu unless you press F8. The boot menu allows you to boot Windows in different modes, including Safe Mode and Command Prompt Mode. You can configure the boot menu to be shown automatically on every boot.


Registry Guide : Files : SYSTEM.INI

Home : Files : SYSTEM.INI

Use High Memory for DOS Drivers (Windows 9x/Me)
This setting causes Windows to load the local DOS devices into high memory and freeing up more low memory for DOS applications.

Improve Swap File Performance (Windows 98) Popular
On systems with large amounts of memory (i.e. > 128mb) the hard disk based swap file is not needed as much, this tweak optimizes the use of the swap file on such systems.

Control the Size of the Disk Cache (Windows 9x/Me) Popular
This tweak allows you control the minimum and maximum amount of memory being allocated as disk cache. It can be used to speed up your system and possibly avoid some memory problems.

Changing Spare Stack Pages (Windows 95)
Windows 95 sets aside a number of extra memory pages (spare stack pages) to be used temporarily to prevent a system "crash" due to a stack overflow condition. Sometimes all the spare pages can be used, and an error message is shown, this tweak allows you to increase the number available.


Registry Guide : Performance

Home : Performance

File System File System
File System Performance Settings
Network & Internet Network & Internet
Internet and Network Performance Settings

Manage Foreground and Background Task Priority (Windows NT)
This setting is used to manage the relative priority between foreground and background applications, this is normally accessed through Control Panel > System > Performance.

Control the Windows Animation Function (All Versions) Popular
Although the animation function can make animated Windows look good, it can also slow down your PC if you have a slower graphics card. This setting allows you to control whether the function is enabled or disabled.

Control Whether Windows Performs Smooth Scrolling (All Versions) Popular
This setting allow you to disable the Windows smooth scrolling function, which on an low-powered system can cause performance degradation.

Optimizing L2 Caches Over 256K (Windows NT) Popular
Windows NT by default is optimized for a 256K size L2 cache. With most computers now having L2 caches larger than 256K it pays to take the time to change the SecondLevelDataCache setting to correspond to the size of the L2 cache installed.


Registry Guide : Performance : File System

Home : Performance : File System

Configure the Contiguous File Allocation Size (All Versions) Popular
This setting optimizes the contiguous file allocation size for the file system. This is especially useful for disk intensive applications.

Increase File System Caching Memory (Windows NT) Popular
Windows NT will normally limit the amount of RAM that can be locked for I/O operations. Using this registry key will allow you to override the automatic setting.

Increase NTFS Performance by Disabling the Last Access Time Stamp (Windows NT)
When Windows NT accesses a directory on an NTFS volume, it updates the LastAccess time stamp on each directory it detects. Therefore, if there are a large number of directories, this can affect performance.

Disable 8.3 Name Creation (NTFS) (Windows NT)
This key stops the NTFS volume from generating MS-DOS compatible 8.3 file names. Disabling this feature can increase the performance on heavily used NTFS partitions that have large amount of files with long filenames.


Registry Guide : Performance : Network & Internet

Home : Performance : Network & Internet

Cable Modem and DSL Speed Tweak to Increase Performance (Windows 9x/Me) Popular
Use these settings with your Cable Modem or DSL broadband Internet connection, to boost network throughput performance with Windows 95, 98 and ME.

Cable Modem and DSL Speed Tweak to Increase Performance (Windows 2000) Popular
Use these settings with your Cable Modem or DSL broadband Internet connection, to boost network throughput performance with Windows 2000.

Cable Modem and DSL Speed Tweak to Increase Performance (Windows NT)
Use these settings with your Cable Modem or DSL broadband Internet connection, to boost network throughput performance with Windows NT.

Increase the Maximum Number of HTTP Sessions Allowed (All Versions) Popular
To abide by the HTTP specifications Windows limits the number of simultaneous connections that it will make to a single HTTP (web) server. This affects all Windows Internet applications that use the standard API, including Internet Explorer. The behavior can be seen when downloading multiple files from a web site only a certain number (2 or 4) will be active at any one time.

Optimizing the DefaultRcvWindow & DefaultTTL Settings (Windows 9x/Me) Popular
The optimization of RcvWindow and DefaultTTL along with other registry settings such as MaxMTU and MaxMSS can speed up TCP/IP modem networking connections (e.g. Internet connections).

Optimizing Dial-Up Modem Connection Speed (Windows 9x/Me) Popular
By optimizing the MaxMTU & MaxMSS settings along with the RWIN and TTL settings you can increase dialup modem connection reliability and performance by as much as 200%.

Increase Network Performance (Windows NT) Popular
If you increase the number of buffers that the redirector reserves for network performance, it may increase your network throughput. Each extra execution thread that you configure will take 1k of additional nonpaged pool memory, but only if your applications actually use them.


Registry Guide : Security

Home : Security

Control Panel Control Panel
Control Panel Security Restrictions

Network Network
Network and Workgroup Security Settings

Remote Access Remote Access
Remote Access Security Settings

Software Software
Security Settings for Windows Applications

System System
System Security Restrictions and Settings

Remove Folders from Settings on the Start Menu (All Versions)
Removes the Control Panel and Printers folders from the Settings menu. Note: Removing the Taskbar, Control Panel, and Printer folders causes the Settings menu to be removed completely.

Remove the Documents Folder from the Start Menu (All Versions) Popular
This setting can be used to remove the recent Documents folder from the Start Menu.

Don't Save Settings at Exit (All Versions)
Normally when Windows exits it saves the desktop configuration, including icon location, appearance etc. This setting disables these changes from being saved, this is useful in both a secure environment and when you don't want people to change the appearance of your desktop once you have it setup the way you like it.

Restrict Changes to Active Desktop Settings (All Versions)
This tweak allows you to have Active Desktop enabled, but to restrict any changes to the settings.

Don't Add Recent Files to Documents on the Start Menu (All Versions) Popular
Normally when you open or access a document or file it is added to the list of recent documents on the Start Menu. This tweak will stop files from being added to the list.

Clear Recent Documents When Windows Exits (All Versions) Popular
This tweak will clear the list of recent documents on the Start Menu when Windows exits.

Remove the Help Option from the Start Menu (Windows 2000)
This tweak hides the Help option on the Start Menu.

Remove My Documents from Documents on the Start Menu (Windows 2000)
This tweak hides 'My Documents' which is shown under the Documents folder on the Start Menu.

Disable Active Desktop (All Versions)
This tweak will disable the use of the Active Desktop feature.

Active Desktop Restrictions (All Versions)
Features of the Windows Active Desktop can be selectively controlled by modifying options in the Windows registry. Following the instructions in this tweak.

Remove Active Desktop Options from the Settings Menu (All Versions)
The tweak will remove the Active Desktop options from Settings on the Start Menu.

Disable the Ability to Modify the Start Menu (Windows 98)
Normally users are able to right-click on the Start Menu and modify it using the context menu. This option give you the ability to disable this function.

Disable the Shut Down Command (All Versions)
This option allows you to stop users from being able to shutdown the computer by disabling the shut down command.

Hide All Items on the Desktop (All Versions) Popular
Enabling this options hides all the items and programs on the Windows desktop.

Hide Drives in My Computer (All Versions) Popular
This setting controls which drives are visible in 'My Computer', it is possible to hide all drives or just selected ones.

Remove the Find Command From the Start Menu (All Versions)
When enabled this setting removes the 'Find' command from the Start Menu.

Hide the Network Neighborhood Icon (All Versions)
The Network Neighborhood icon is shown on the Windows desktop whenever Windows networking is installed, by enabling this setting the icon will be hidden.

Remove the Run Command from the Start Menu (All Versions)
Removes the user's ability to start applications or processes from the Start menu by removing the option completely.

Remove the Taskbar from Settings on the Start Menu (All Versions)
Enabling this option removes the Taskbar option from Settings on the Start Menu, therefore stopping users from changing the taskbar properties. Note: Removing the Taskbar, Control Panel, and Printer folders causes the Settings menu to be removed completely.

Remove File menu from Explorer (Windows NT)
Removes the File option from Explorer's toolbar. (This option was added in Service Pack 2.)

Remove common program groups from Start menu (All Versions)
Disables the display of common groups when the user selects Programs from the Start menu.

Restricting Applications Users Can Run (All Versions) Popular
Windows gives the ability to restrict the applications that can be run by users on a workstation.


Registry Guide : Security : Software

Home : Security : Software

DOS DOS
MS-DOS and Windows 3.x Application Restrictions
Internet Explorer Internet Explorer
Internet Explorer Security Restrictions

Manage Attachment Security in Outlook (All Versions) Popular
New security measures that improve the dialog box warnings for attachments were included in Microsoft Outlook beginning with Outlook 2000 (SR-1). The file extensions that trigger the more secure warnings can be managed through the registry.

Microsoft Netmeeting Policies (All Versions)
These restrictions and policies can be used to disable or restrict access to certain features of Microsoft Netmeeting 3.


Registry Guide : Security : Software : DOS

Home : Security : Software : DOS

Disable the MS-DOS Command Prompt (All Versions)
This setting allows you to disable the use of the MS-DOS command prompt in Windows.

Disable Single Mode MS-DOS Applications in Windows (All Versions)
This setting allows you to disable the use of real mode DOS applications from within the Windows shell.


Registry Guide : Security : Software : Internet Explorer

Home : Security : Software : Internet Explorer

Internet Explorer Control Panel Restrictions (Part 2) (All Versions) Popular
The features available within the Internet Explorer control panel (Tools -> Internet Options) can be individually managed and disabled using this tweak.

Restrict Help Menu Items in Internet Explorer (All Versions)
The menu items with the Internet Explorer "Help" menu can be individually removed or the menu disabled completely using this tweak.

Internet Explorer 5 Restrictions (All Versions) Popular
Microsoft Internet Explorer 5 has a range of features that can be selectively controlled by modifying the Windows registry.

Disable the Ability to Customize Toolbars (All Versions)
By right clicking on a toolbar you are usually given the option to Customize, which allows you to change which functions are available from the toolbar. This tweak allows you to disable that function.

Remove the Option to Change or Hide Toolbars (All Versions)
By default users are able to select which toolbars are displayed either be right clicking the toolbar itself, or by changing the options from the View menu. This tweak locks the toolbars, removing the ability to change which are displayed.

Internet Explorer Control Panel Restrictions (Part 1) (All Versions)
These tweaks allows you to control access to the Internet Explorer setup and control panel functions (found under Tools -> Internet Options).

Remove the Content Advisor and Ratings Password (All Versions)
If you've forgotten the Internet Explorer content advisor password and want to change the ratings settings then follow these instructions to change the settings back to their defaults.


Registry Guide : Security : Control Panel

Home : Security : Control Panel

Display Display
Display Properties Restrictions

Network Network
Network Properties Restrictions

Passwords Passwords
Password Properties Restrictions

Printers Printers
Printer Properties Restrictions

System System
System Properties Restrictions

Hide Control Panel on Start Menu (All Versions) Popular
This setting allows you to hide the Control Panel options from the Start Menu.

Hiding Control Panel Applets (All Versions)
This tweak allows you to show or hide any of the applets found in the Windows Control Panel.

Deny Access to the Display Settings (All Versions)
This option disables the display settings control panel icon, and stops users from accessing any display settings.

Disable Network Control Panel (Windows 9x/Me)
Enabling this option disables access to the Network Control Panel icon.

Disable Printers Control Panel Icon (Windows 9x/Me)
This option disables access to the Printers icon in control panel, therefore stopping users from changing Printer settings.

Restrict Access to the Passwords Control Panel (Windows 9x/Me)
This options disables access to the Passwords icon on the control panel, therefore stopping users from changing security related settings.


Registry Guide : Security : Control Panel : Display

Home : Security : Control Panel : Display

Hide the Display Appearance Page (All Versions)
When enabled this setting hides the display settings appearance page.

Hide the Display Background Page (All Versions)
This option hides the background page stopping users from changing any background display settings.

Hide the Screen Saver Settings Page (All Versions)
This option hides the screen saver page from the display settings control, which stops users having access to change screen saver settings.

Hide the Display Settings Page (All Versions)
This option hides the Settings page from the display properties control.


Registry Guide : Security : Control Panel : Network

Home : Security : Control Panel : Network

Hide the File and Printer Sharing Controls (Windows 9x/Me)
Enabling this options hides the file and printer sharing controls, stopping users from disabling or creating new file or printer shares.

Hide Network Identification Page (Windows 9x/Me)
The Network Identification page include options to set the Computer Name, Workgroup and Description, enabling this option disables access to the Network ID page.

Hide Network Access Control Page (Windows 9x/Me)
The Access Control Page, defines whether the computer support User-Level access or Share-Level access, enabling this option removes access to the Access Control Page.


Registry Guide : Security : Control Panel : Passwords

Home : Security : Control Panel : Passwords

Hide the Change Passwords Page (Windows 9x/Me)
When this setting is enabled, users are no longer able to access the Change Passwords page.

Hide the Remote Administration Page (Windows 9x/Me)
Enabling this function stops users from being able to change the remote administration settings for the computer.

Hide the User Profiles Page (Windows 9x/Me)
The user profile page controls whether all users share or have separate user profiles, access to this page can be disabled by enabling this setting.


Registry Guide : Security : Control Panel : Printers

Home : Security : Control Panel : Printers

Hide the General and Details Printer Pages (Windows 9x/Me)
This option hides the printer details and general printer information pages. Once enabled this option stops users from changing specific printer settings.

Disable the Deletion of Printers (Windows 9x/Me)
Printers can be deleted simply by any user pressing the delete key, enabling this setting stops users from being able to delete printers.

Disable the Addition of Printers (Windows 9x/Me)
Any user can add a new printer their system, this option once enabled disables the addition of new printers to the computer.


Registry Guide : Security : Control Panel : System

Home : Security : Control Panel : System

Hide the Device Manager Page (Windows 9x/Me)
This setting controls whether the Device Manager, under Control Panel / System is visible.

Hide the Hardware Profiles Page (Windows 9x/Me)
This setting when enabled hides the Hardware Profiles page from the System icon on the Control Panel.

Hide the File System Button (Windows 9x/Me)
This option hides the File System button from the System icon on the Control Panel.

Hide the Virtual Memory Button (Windows 9x/Me)
This option hides the Virtual Memory button from the System icon on the Control Panel.


Registry Guide : Security : Network

Home : Security : Network

Automatic Hidden Shares (Windows NT/2000)
When networking has been installed on a Windows NT machine, it will automatically create hidden shares to the local disk drives. The shares are normally accessed via \server\c$ and \server\d$ depending on the drive letter. It is possible to disable the sharing at run-time, but this tweak will stop the automatic sharing altogether.

Disable the Ability to Remotely Shutdown the Computer Browser Service (Windows NT/2000)
It is possible for a malicious user to shut down a computer browser, or all computer browsers, on the same subnet. If all of the computers on the same subnet are shut down, they can then declare their own computer the new master browser.

Hiding Servers from the Browser List (Windows NT/2000)
If you have a secure server or workstation you wish to hide from the general browser list, add this registry setting.

Require Validation by Network for Windows Access (Windows 9x/Me)
By default Windows 9x doesn't require a valid network username and password combination for a user to bypass the logon and gain access to the local machine. This functionality can be changed to require validation by the network before allowing access.

Fix DHCP Security Flaw (Windows 9x/Me)
The ICMP Router Discovery Protocol (IRDP) comes enabled by default on DHCP clients that are running Microsoft Windows 9x/2000 machines. By spoofing IRDP Router Advertisements, an attacker can remotely add default route entries on a remote system.

Hide Computers Near Me in Network Places (Windows 2000)
This setting allows you to show or hide the computers listed Near Me in My Network Places.

Hide Network and Dial-up Connections on Start Menu (Windows 2000)
This tweak allows you to hide the Network and Dial-up Connections option on the Start Menu.

Disable the Automatic Creation of a Default Network Route (Windows NT)
This tweak controls the default behavior of Windows to add a network route to 0.0.0.0 on multi-homed machines (e.g. proxy or firewall).

Disable TCP/IP Source Routing (Windows NT 4.0)
Normally, on a computer running Windows NT 4.0, you cannot disable the source routing feature for the TCP/IP protocol. By using this tweak it is possible to disable it.

Changing LAN Manager Authentication on Windows NT (Windows NT)
Windows NT supports two kinds of challenge/response authentication: LanManager (LM) and Windows NT (NTLM). LM authentication is not as strong as Windows NT authentication so some customers may want to disable its use, because an attacker sniffing the network traffic could possibly attack the weaker protocol.

Changing the Password Expiry Warning Period (Windows NT)
This entry specifies the number of days before a user's password expires that a warning message is displayed.

Hide Share Passwords with Asterisks (All Versions)
This setting controls whether the password typed when accessing a file share is shown in clear text or as asterisks.

Disable File and Printer Sharing (All Versions)
When file and printer sharing is installed it allows users to make services available to other users on a network, this functionality can be disabled by changing this setting.

Disable Caching of Domain Password (All Versions)
Enabling this setting disables the caching of the domain passwords, and therefore passwords are required to be re-entered to access any additional domain resources.

Remove the Map and Disconnect Network Drive Options (Windows NT)
Prevents users from making additional network connections by removing the Map Network Drive and Disconnect Network Drive buttons from the toolbar in Explorer and also removing the menu items from the Context menu of My Computer and the Tools menu of Explorer. (This option was added in Service Pack 2.)

Remove Entire Network from Network Neighborhood (All Versions)
Entire Network is an option under Network Neighborhood that allows users to see all the Workgroups and Domains on the network. Entire Network can be disabled, so users are confined to their own Workgroup or Domain.

Hide Workgroup Content from Network Neighborhood (All Versions)
Enabling this option hides all Workgroup contents from being displayed in Network Neighborhood.

Setting a Minimum Password Length (All Versions)
You can force Windows to reject passwords that do not meet a minimum password length. Useful to help stop people from using trivial passwords where security is an issue.

Restricting Information Available to Anonymous Logon Users (Windows NT)
Windows NT has a feature where anonymous logon users can list domain user names and enumerate share names. Customers who want enhanced security have requested the ability to optionally restrict this functionality.

Sending Unencrypted Passwords (Windows NT)
Connecting to SMB servers (such as Samba and LAN Manager for UNIX) with an unencrypted (plain text) password fails after upgrading to Windows NT 4.0 Service Pack 3. This is because the SMB redirector in Service Pack 3 handles unencrypted passwords differently than previous versions of Windows NT. Beginning with Service Pack 3, the SMB redirector will not send an unencrypted password unless you add a registry entry to enable unencrypted passwords.

Don't Display Last User Name (Windows NT)
Enabling this key will blank the username box on the logon screen. Preventing people that are logging on from knowing the last user on the system.

Remove 'Log Off Username' from the Start Menu (All Versions)
This tweak allows you to remove the 'Log Off Username' option from the Start menu.

Defining Local and Remote Drive Visibility Under WinNT (Windows NT)
Administrators may use the NODRIVES entry to disable access to floppy drives on a per-user basis. The NODRIVES entry uses a 32-bit word to define local and network drive visibility for each logical drive in the computer. The lower 26 bits of the 32-bit word correspond to drive letters A through Z. Drives are visible when set to 0 and hidden when set to 1.

Disabling Save Password option in Dial-Up Networking (Windows NT)
When you dial a phonebook entry in Dial-Up Networking (DUN), you can use the 'Save Password' option so that your DUN password is cached and you will not need to enter it on successive dial attempts. This key disables that option.


Registry Guide : Security : Remote Access

Home : Security : Remote Access

Disable the "Log on using dial-up connection" Check Box (Windows NT/2000)
During logon Windows allows users to optionally connect to a Windows domain using dial-up networking, this tweak can be used to disable that option.

Automatically Use Dial-Up Networking to Logon (Windows NT)
There is an option that is available on the logon dialog box and allows you to dial into your logon server for authentication of your user account, this can be enabled by default.

Disable Dial-In Access (All Versions)
It's possible for users to setup a modem on a Windows machine, and by using Dial-up Networking allow callers to connect to the internal network. Especially in a corporate environment this can cause a major security risk.

Maximum Number of Remote Access Authentication Attempts (Windows NT)
This setting controls the number of authentication retries before a remote access connection is terminated.

Maximum Time Limit for Authentication (Windows NT)
A time limit can be enforced on the period available to logon via remote access before the connection is terminated.

Automatically Disconnect Remote Access Callers (Windows NT)
Specifies the amount of idle time in minutes to wait before disconnecting the remote access client.

Specify the Callback Pause Period (Windows NT)
When callback is required or requested this setting defines how long to wait before initiating the callback connection.


Registry Guide : Security : System

Home : Security : System

Disable Run Commands Specified in the Registry (Windows 2000)
This restriction is used to disable the ability to run startup programs specified in the registry when Windows launches.

Implement a User Based Custom Shell (Windows 2000)
Windows 2000 allows you to selectively specify the system shell based on the logged in user. For example this allows one user to use the standard explorer interface and another to use the legacy progman shell.

Remove the Ability to Modify File Types (Windows 2000)
This setting allows you to remove the ability to change, add or delete file types using explorer the Folder Options interface.

Disable User Tracking (Windows 2000)
This setting stops Windows from recording user tracking information including which applications a user runs and which files and documents are being accessed.

Control the Automatic Restarting of the Shell (Windows NT/2000)
By default if the Windows user interface or one of its components fails, the interface is restarted automatically, the can be changed so that you must restart the interface by logging off and logging on again manually.

Control Whether Windows Reboots After a Crash (Windows NT/2000)
This tweak controls whether Windows should automatically reboot after a crash or system failure.

Disable context menus for the Taskbar (Windows NT/2000)
Removes the context menus (right click on the taskbar) for the tray, including the Start button, Tab control, and Clock.

Disable the Ability to Right Click on the Desktop (Windows NT/2000)
This tweak removes the context menu that would normally appear when the user right clicks on the desktop or in the Explorer right results pane.

Enable System File Protection Popup Notifications (Windows Me)
This tweak controls whether a popup notification message is shown when the System File Protection (SFP) service performs an action.

Change the Message Shown on the Logon Box (Windows NT)
You can personalize (or legalize) the message displayed on the logon box above the user name and password.

Disable Registry Editing Tools (All Versions) Popular
This setting disables the ability to run the registry editing tools Regedit.exe or Regedt32.exe interactively.

Disable User Profiles (Windows 9x/Me)
This setting can be used to disable the use of user profiles.

Force Users to Logon to Windows (Windows 9x/Me) Popular
Usually users can simply press 'Cancel' at the Windows logon box to bypass the login process and gain access to the local computer. This tweak will logout the user if the authentication fails or the user clicks Cancel.

Remove the Ability to Right Click on the Start Button (All Versions)
Usually when a user right clicks on the start button they are able to select Open, Explore or Find. Use this tweak to remove these options and secure your desktop.

Force the Use of Active Desktop (All Versions)
The user is normally given the option of disabling Active Desktop through the display properties. This tweak removes the ability to disable Active Desktop.

Display Hidden File Extensions (All Versions)
Even when you have configured Windows to display all file extensions, there are still some which remain hidden. This potentially allows dangerous files to be masked as safe files, fooling the user into executing them. This tweak helps expose those file extensions.

Disable Folder Options Menu
This tweak allows you to hide the Folder Options function from the folder Tools menu. Allowing you to restrict access to numerous advanced folder features.

Determines which drives the Autorun feature is enabled on (All Versions)
Determines whether the Autorun feature is enabled on each drive connected to the system. When Autorun is enabled, media is started automatically when it is inserted in the drive.

Disable Windows Hotkeys (All Versions)
This tweak disables the use of Windows hotkeys.

Restrict Access to the Windows Update Feature (All Versions)
Windows 98 and later Windows versions contain a feature known as Windows Update, which allows users to update Windows specific software. With this modification you can remove access to this feature from the settings sub-menu.

Restricting Access to the Event Logs (Windows NT/2000)
The Windows NT event log contains records documenting application, security and system events taking place on the machine. These logs can contain sensitive data, and by default, the Guest account has access to view them. This tweak allows you to restrict access to administrators and system accounts only.

Stopping the KnownDLLs Vulnerability (Windows NT)
In Windows NT the core operating system DLLs are kept in virtual memory and shared between the programs running on the system. This has exposed a vulnerability that could allow a user to gain administrative privileges on the computer the user is interactively logged onto.

Disable the Lock Workstation Button (Windows NT)
Add this setting to the registry to stop unauthorized users from locking machines from the Windows NT Security dialog box.

Disable the Change Password Button (Windows NT)
This setting disables the 'Change Password' button on the Windows NT Security dialog box. Enabling this setting stops casual users from being able to change the password.

Clear the Page File at System Shutdown (Windows NT)
Windows normally does not clear or recreate the page file. On a heavy used system this can be both a security threat and performance drop. Enabling this setting will cause Windows to clear the page file whenever the system is shutdown.

Secure Network Access to the Windows NT Registry (Windows NT)
Windows supports accessing a remote registry via the Registry Editor across a network. The default setting allows for users to connected and modify data within the remote registry.

Securing Network Access to CD-ROM Drives (Windows NT)
This setting determines whether data in the CD-ROM drive is accessible to other users. This value entry satisfies, in part, the C2 security requirement that you must be able to secure removable media.

Securing Network Access to Floppy Drives (Windows NT)
This setting determines whether data in the floppy disk drive is accessible to other users. This value entry satisfies, in part, the C2 security requirement that you must be able to secure removable media.

Specify executable files to be run by Winlogon (Windows NT)
This setting Specifies executable files to be run by Winlogon in the system context, and can be modified by simply editing the value.

Require Alphanumeric Windows Password (All Versions)
Windows by default will accept anything as a password, including nothing. This setting controls whether Windows will require a alphanumeric password, i.e. a password made from a combination of alpha (A, B, C...) and numeric (1, 2 ,3 ...) characters.

Disabled Password Caching (All Versions)
Normally Windows caches a copy of the users password on the local system to allow for additional automation, this leads to a possible security threat on some systems. Disabling caching means the users passwords are not cached locally. This setting also removes the second Windows password screen and also remove the possibility of networks passwords to get out of sync.

Enable Shutdown from Authentication Dialog Box (Windows NT)
When this setting is enabled a [Shutdown] button is displayed in authentication dialog box when the system first starts. This allows you to shutdown a system without logging in. The button is shown by default on a workstation and removed on a server installation.

Disable Task Manager (Windows NT)
Enables or disables the user's ability to start Task Manager to view processes, applications running, and make changes to the priority or state of the individual processes. (This option was added in Service Pack 2.)

Preventing the Logon Screen Saver from Launching (Windows NT)
Windows NT has a default screen saver called login.scr, which runs even if no screen saver has been selected. This can present a security risk, as it can allow a local user to replace login.scr with another program and have it launched with system privileges.

Legal Notice Dialog Box Before Logon (All Versions)
Use these fields to create a dialog box that will be presented to any user before logging onto the system. This is useful where you are required by law to warn people that it is illegal to attempt to logon without being an authorized user.


Registry Guide : Tips and Tricks

Home : Tips and Tricks

Windows 95, 98 & ME Windows 95, 98 & ME
Tips specifically for Windows 95, 98 & ME
Windows NT/2000 Windows NT/2000
Tips specifically for Windows NT & 2000

Specify the Program to Play Inserted Audio-CDs (All Versions)
This value is used to specify which program should be used to play an audio CD when it is inserted and the autostart feature is enabled.

Full Window Drag Option (All Versions) Popular
This setting enables the Full Windows Drag function, which allow you to view the contents of window while dragging it across the screen, instead of just the standard outline.

Re-Initialize Your Registry Without Rebooting (All Versions) Popular
Some registry changes require you to restart Windows before they are enabled. This tip lets you re-initialize your registry and refresh your desktop without having to leave Windows.

Remove the Start Banner on the Taskbar (All Versions) Popular
Hide the bouncing arrow and the "Click Here to Begin" caption that appear on the taskbar when you start Windows.

Remove or Change the Shortcut Arrow (All Versions) Popular
Would you prefer to display your shortcuts without the arrow in the bottom left hand corner? This tip will show you how to change the arrow icon or remove it completely.

Add Your Own Tips (All Versions) Popular
Are you sick of seeing the same tips again and again when you first logon to Windows? Now you can change them to whatever you want, whether it's quotes, jokes or a to-do list, anything is possible.

Control CoolSwitch Application Swapping (All Versions) Popular
CoolSwitch is a feature available within Windows to quickly switch between tasks and programs by using the Alt + TAB keys.

Show File and Folder Names Using the Correct Case (All Versions) Popular
Some versions of Windows will attempt to adjust the capitalization of files and folders that are in all uppercase to make them more visually pleasing. For example, if you create a folder named "C:\ALLINCAPS" Windows will actually display it as "C:\Allincaps". This feature can be disabled using this tweak.

Automatic Window Refresh (All Versions) Popular
Normally when the contents of a window change you may need to wait a few seconds, or press F5, to refresh the display to see the updated information. This tweak configures the system to perform faster automatic updates.

Changing the Menu Show Delay (All Versions) Popular
Windows normally delays menus before they are displayed. For regular users this delay can become annoying, with this setting you to change the delay time or remove it altogether.

Change the Logon Screen Background Color (All Versions) Popular
When you change the color scheme and appearance of your desktop it does not change the background color of the logon screen to match. This tweak allows you to change that color as well.

Change the Logon Screen Wallpaper (All Versions) Popular
When you setup a background wallpaper for your desktop, the initial logon screen wallpaper is not changed and stays as the default Windows appearance. This tweak allow you to change the default wallpaper.

Force Windows to Unload DLL's from Memory (All Versions) Popular
Windows Explorer will usually try and cache DLL's by keeping them in memory even after the application using them has been closed. This can cause performance problems on low memory systems, and can be annoying when developing on Windows and the DLL's remain in use.

Show Windows Version on Desktop (All Versions) Popular
Early versions of Windows showed their version number on the desktop, this feature was removed in the released version. If you're in an environment where it may be useful to quickly locate the version of Windows then this tweak re-enables that feature.

Add Custom Folder to My Computer or the Desktop (All Versions) Popular
Create your own custom system folder on the desktop or in My Computer, that can't be deleted or renamed.

Add the QuickView Option to All Files (All Versions)
If you ever wanted to add QuickView to the context menu of all file types, it may be a tedious task doing so using Windows Explorer's Options - File Type window. This tip shows how to do it in a couple of easy steps.

Rename or Delete Special Folders (All Versions)
This setting allows you to rename and delete special folders (such as the Recycle Bin) as if it was a normal folder by right-clicking the icon.

Change the Recycle Bin Icons (All Versions) Popular
Would you like to make you Recycle Bin into something a bit more exciting? Maybe a glowing toxic waste bin? With this tweak you can change the icon to be whatever you like.

Including Manufacturer and Support Details (All Versions) Popular
This tip lets you include a company logo and contact information in the System Properties dialog box. This is especially useful if you run a computer store and want your customers to be reminded where they bought their PC and where to get technical support.

Make the Columns Fit (All Versions)
Want to quickly see all the column in explorer without having to resize them individually? This tip does it for you.

Close Parent Windows Automatically (All Versions)
Have you ever had a screen full of explorer windows on your desktop after digging through heaps of directories? This tip lets you close the current window and all it's parent windows in one easy step.

Expand and Contract Folders With Ease (All Versions)
It can be a time-consuming process to expand a folder by clicking on the (+) for each and every sub-directory. This tip lets you expand and contract them all at once, with one keystroke.

Avoid Accidental Registry Imports (All Versions)
By default, if you double-click on a file with a '.REG' extension the file will be imported into the system registry. You can change the default so it opens the file for editing instead.

Change the Default Name and Company Information (All Versions)
When you install a new application, using MS Setup, a default Name and Company are shown, these values can be changed when the details have changed or are incorrect.

Change the Location of System and Special Folders (All Versions)
Windows keeps a number of special folders such as "My Documents", "Desktop", "Favorites" and the "Start Menu". These folders can be moved anywhere on you system and the new location updated in this key.

Launching Programs When Windows Starts (All Versions) Popular
You can automatically start programs whenever Windows launches. If you have programs automatically starting that you have not loaded then you can remove them using this tip as well.

Removing Item Types from the New Menu (All Versions)
When you right-click on your desktop or other selected applications there is a New sub-menu which contains a list a default templates. This list can be modified to include only the templates you want.

Remove Cached Command Lines from the Run Menu (All Versions)
Got a lot of items in the Start Menu's run command history? This tip will allow you to remove any extraneous commands.

Remove the Tildes in Short Filenames (All Versions)
When long filenames are shown in an application that only supports short filenames a tilde "~" is used to convert the long name into a compatible short name. This setting removes the use of tildes.

Creating a Shortcut to the System Folders (All Versions)
This function allow you to add a shortcut to various system folders on your Desktop or Start Menu.

Changing the Registered Owner and Organization (All Versions) Popular
If you entered the wrong registration information when you installed Windows you can change it and other miscellaneous settings such as ProductID and ProductName.

Automatically View Thumbnails of Bitmap Files (All Versions)
Makes Explorer show a thumbnail version of bitmaps files in the current folder rather than the generic icon ordinarily used. This is a great way to preview .BMP files without having to open them first.

Removing Icons from your Desktop (All Versions) Popular
This key contains a number of subkeys which hold information about the namespace extensions of icons on your desktop. Through this key you can control which icons are visible on the desktop, including the My Computer, Inbox, MSN and Internet icons.


Registry Guide : Tips and Tricks : Windows 95, 98 & ME

Home : Tips and Tricks : Windows 95, 98 & ME

Speed Up ISP Logon Time (Windows 9x/Me) Popular
On some systems it can take a long time to connect to the Internet, you can decrease the time required to connect to your ISP by trying these simple steps.

Faster Modem Dialing (Windows 9x/Me) Popular
Waiting to long for your modem to dial? This tip lets you reduce the time it takes your modem to dial, and increase your overall modem connection speed.

Items in Dialog Boxes Sorted Incorrectly (Windows 98)
When viewing files and folders from a Windows dialog box the items may be sorted incorrectly. For example, files may be listed before folders, items may be sorted in descending order, and so on. This tip should resolve this problem.

Start Windows Without Prompting for a Password (Windows 9x/Me) Popular
Does Windows prompt you for a password every time you boot up even though you're the only one using the PC? Follow these instructions to make Windows automatically start up without prompting you for a password.

Remove Task Scheduler (Windows 9x/Me)
Task Scheduler is automatically installed in some versions of Windows, and also when you install Internet Explorer. This tweak will remove it from your system.

Desktop Icon Redraw (All Versions)
If you desktop icons are redrawing too frequently, it could be because the icon cache is full. Try increasing the size by changing this setting.

Order the Menu (Windows 98)
It's easy to reorder the items on any Windows 98 cascading menu by holding down the mouse button and drag a highlighted file or folder up or down the list. With this tip it's even easier to force the entire list into permanent alphabetical order.

Restart Windows Quickly without Rebooting (Windows 9x/Me) Popular
Tired of waiting for Windows to restart? Sometimes it can take ages to completely shutdown, then your have to wait for the PC to reset as well. Try this tip to speed up your computer's shutdown procedure.

Change the Startup and Shutdown Screens (Windows 9x/Me) Popular
Microsoft has a knack for making the Windows startup and shutdown screens pretty boring. Luckily it's relatively easy to replace these images with pictures of your own.


Registry Guide : Tips and Tricks : Windows NT/2000

Home : Tips and Tricks : Windows NT/2000

Disable the Creation of Last Known Good (Windows NT/2000)
This setting allows you to disable the creation of the LastKnownGood configuration, which stores a copy of the configuration after each successful boot-up.

View the System BIOS Information (Windows NT/2000)
This registry key stores information about the system BIOS, including the release date, version number and video BIOS date.

Control the Display of Popup Error Messages (Windows NT/2000)
This tweak is used to control which error messages are displayed as popups, and also allows you disable the use of popup error dialog boxes entirely.

Reduce the Time the Startup List is Shown on Boot (Windows NT/2000)
30 Seconds is a long time when you're waiting for Windows NT to boot. With this tip you can decrease the time the system waits for a selection, or remove the time-out all together.

Launch Folder Windows in a Separate Process (Windows NT/2000)
This setting controls whether each folder window is launched as a separate explorer task. The benefit of this method is that if one window has an error and crashes the others should be not be affected. The disadvantage is that it takes more system resources for each folder.

Change System Environment Variables (Windows NT/2000)
This key contains the Windows NT system environment variables, the variables include Path, Temp, Windir and any other defined values.

Change Directories Without Typing the Whole Name (Windows NT/2000)
Changing directories at the command prompt can be a hit and miss process when long filenames are involved. This tip let you change directories with ease, not matter how long the directory name.

Launch the Task Manager Quickly (Windows NT/2000) Popular
Launching the Task Manager can sometimes be difficult depending on the situation. Some people didn't know that the Task Manager can actually be launched in at least three different ways to make it easier to use when you need it the most.

Configuring Unimodem Support (Windows NT)
Windows NT 4.0 and greater support Unimodem modems, if your device is not supported though Windows can be configured to use the MODEM.INF file instead.

Removing Windows NT Devices and Services (Windows NT/2000)
Sometimes it is possible to get orphaned services remaining in the registry. These services can be remove be modifying this key.

Changing the Startup Mode of a Service (Windows NT/2000)
All services have a setting controlling how they are started either manually, automatically or disabled. This setting can be changed through the registry.

Define Whether Windows Parses Autoexec.bat (Windows NT/2000)
When this value is 1, the environment variables declared in the Autoexec.bat file are included in the user's environment.

Stop Error Messages When Booting (Windows NT)
Stops the annoying Windows pop-up messages notifying you a device is not functioning when you boot-up Windows NT.

View Which Hot Fix Patches Have Been Installed (Windows NT)
Periodically Microsoft releases Hot Fix's to patch bugs in Windows NT and other products, this key contains information about which Hot fix's have been installed.

PS2 Mouse Port Rate Adjustment (Windows NT)
Ever noticed how your mouse cursor flickers sometimes or doesn't run as smoothly as you would like? That's because the refresh rate is set too low, modify this key to speed things up and make your mouse cursor move smoothly.

Disable Automatic Cache Updates in NT's DNS Server (Windows NT)
This value disables that automatic cache updated from the DNS root servers. Useful when there is a problem with the root servers, or if you wish to completely control DNS updates.


Registry Guide : Troubleshooting

Home : Troubleshooting

File System File System
Advanced File System Troubleshooting
Logging Logging
Logging and Reporting Functions

Send Administrative Alerts of System Crashes (Windows NT/2000)
This setting controls whether Windows should send an alert to the Administrator when a system crashes.

Control Whether Windows Logs a System Crash
This setting controls whether Windows logs a system crash to the event log, this will allow the exact time of the crash to be permanently recorded.

Create a System Crash Dump File (Windows NT/2000)
This setting controls whether Windows creates a dump file of the computer memory when a system crashes.

Specify the System Crash Dump File Location (Windows NT/2000)
This tweak is used to specify the location where the dump file should be written after a system crash.

Control the Dump Creation Method (Windows NT/2000)
This tweak controls whether the system should create a new dump file and overwrite the existing file or whether it should append data to the old dump file when a system crash occurs.

'Failure Writing to the System Registry...' Error Message (Windows 95) Popular
When you run a setup program that was created using the Application Setup Wizard, you may receive an error message indicating the registry may be corrupt or you do not have the required permissions to write to the registry.

Has Your Taskbar Disappeared? (All Versions) Popular
If your taskbar has disappeared from the desktop or becomes hidden when you move your cursor near, it may be due to a corrupt registry key.

MS-DOS Compatibility Mode Problems with PCI IDE Controllers (Windows 9x/Me)
If your computer contains a PCI IDE hard disk controller that employs serialization between the two IDE channels, this tip may help you resolve a MS-DOS compatibility mode problem in Device Manager.

Are You Missing Fonts from the Fonts Folder? (All Versions)
A font may seem to be installed correctly but does not appear in the Fonts folder because the Fonts key in the registry is missing or damaged.

Unable to Connect More Than 10 Clients (Windows NT)
If you have a retail version of Windows NT server, and you are still unable to connect more the 10 users concurrently, then have a look at this tip.

Addition of New LAN Interface in RRAS Causes Event Message (Windows NT)
When you install an additional network interface card (NIC) and the Routing and Remote Access Service (RRAS) is already installed, you receive an error 20101 in the System Log in Event Viewer.

Delay Occurs When Unlocking Workstation (Windows NT)
Sometimes a noticeable delay occurs when the logged on user or an administrator attempts to unlock a workstation. This because when you unlock the workstation Windows NT will update the domain list if the cached list's age exceeds two minutes (by default). This age limit can be modified.

Changing the Default State of the NUMLOCK Key (Windows NT)
The NUMLOCK key is usually only turned on before the user has logged into the computer, this can cause problem for people with portable computers that do not check the status of the NUMLOCK key before typing their password. The default behavior can be changed with this setting.

Removing Programs listed in the Add/Remove Programs Box (All Versions) Popular
All Windows 9x or NT compatible programs must include an Uninstall program, sometimes though the program may get removed but entry in Add/Remove programs doesn't, from this key you can remove those orphaned entries.

PCMCIA Network Adapter Problems (Windows 9x/Me)
When using a PCMCIA network adapter under Windows 98 you might not be able to connect the computer to the network, and under Control Panel > System there is a yellow exclamation mark "!" next to the card.

New Command Missing in Windows Explorer (All Versions)
After you install Internet Explorer with the Windows Desktop Update component you may notice that the New command is missing from the right-click context menu. This tip will help you fix the problem.

Change the Default Mailbox Sound Setting (All Versions)
When you receive a new message, a sound may not be played even though "Play sound when new messages arrive" is enabled.

Long File Names Need to be Enabled (Windows 98)
If you are receiving an error when installing Windows 98 that long file names need to enabled in order for Windows 98 to install successfully try this.

CD-ROM Does Not Run Automatically When Inserted (Windows 9x/Me) Popular
When you insert a CD-ROM into the CD-ROM drive, it may not be run automatically, changing this registry key should correct the problem.


Registry Guide : Troubleshooting : File System

Home : Troubleshooting : File System

Disable Tracking of Shell Shortcuts (Windows 2000)
This setting is used to control the use of the tracking-based method of resolving shell shortcuts on NTFS partitions.

Disable ScanDisk After Improper Shutdown (Windows Me)
Normally if a system is shutdown improperly scandisk will run on the next reboot to ensure the contents of the hard disk are valid. This setting stops scandisk from running automatically when restarting.

Configure 32-bit Protected Mode IO Drivers (Windows 9x/Me)
This setting controls whether fixed disk access is performed through Windows protected mode drivers or through real mode drivers and BIOS routines. If you are experiencing drive IO errors enabling this setting may be a possible solution.

Control Write Behind Caching (Windows 9x/Me)
For increased performance write behind caching is used to write data to the fixed disks, this means that in the event of a system failure there is a possibility that data would not be completely written to the disk. If you have a system critical application you can disable this functionality to be sure that data is written directly to the disk bypassing the cache.

Shortcuts Created Resolve to UNC Paths (Windows NT/2000)
A user may click a program's shortcut and be prompted to Enter Network Password, yet the properties of the shortcut indicate a relative path to the local computer.

Control Long Filename Support (All Versions)
Windows 9x and NT introduced the use of long filenames on existing FAT partitions. Some legacy software maybe incompatible with this new file system design, and may require the use of 8.3 filenames. By enabling this setting you can turn off long filename support.

Configure Protected-Mode Hard Disk Interrupt Handling (Windows 9x/Me)
This switch allows Windows to terminate interrupts from the hard disk controller, bypassing the ROM routine that handles these interrupts. Some hard drives might require that this setting be disabled in order for interrupts to be processed correctly. If this setting is disabled, the ROM routine handles the interrupts.

Configure New File Sharing and Locking Semantics (Windows 9x/Me)
This setting controls the file locking mechanisms of Windows 9x, disable this setting only if you are currently experiencing problems with specific applications.

Preserving Long Filenames for Legacy Applications (Windows 9x/Me)
Windows normally preserves the long filenames of files accessed by legacy applications. This functionality can be disabled if you are experiencing LFN errors with a legacy application.

Use Asynchronous or Synchronous Buffer Commits (Windows 9x/Me)
This setting changes function calls to the File-Commit API to return immediately back without checking the data has been correctly written to the disk drive. By default Windows uses synchronous buffer commits, this setting allows you to enable asynchronous as an alternative for applications that may need this functionality.


Registry Guide : Troubleshooting : Logging

Home : Troubleshooting : Logging

Create a Oakley Log for IPSec Troubleshooting (Windows 2000)
Enabling this setting causes Windows to create an Oakley.log file in the %SystemRoot%\debug folder for developers or network administrators with advanced IKE knowledge.

Change the Number of SQL Server Error Logs (Windows NT)
By default, Microsoft SQL Server 7.0 only stores seven error logs; Errorlog and Errorlog.1 through Errorlog.6. Since the log is re-created every time SQL Server is restarted you may want to keep more than seven logs archived.

Netmeeting Logging (All Versions)
This tweak enables some logging functions in Microsoft Netmeeting, the log file will written to /nmLog.txt.

Enable Internet Mail Logging in Outlook 2000 (All Versions)
To help diagnose POP3, SMTP & Internet mail problems, Microsoft included a logging option for Outlook 2000. This feature can be enabled through the registry.

Remote Access Service (RAS) Device Logging (Windows NT)
Creates a file called DEVICE.LOG in the %SYSTEMROOT%\SYSTEM32\RAS folder for information about commands that the modem is sending and errors that are reported. This file can be very useful in debugging RAS failures.

Remote Access Service (RAS) PPP Logging (Windows NT)
Creates a file called PPP.LOG in the %SYSTEMROOT%\SYSTEM32\RAS folder to help diagnose connectivity problems between a PPP server and a PPP client when one of the computers is a Windows NT Remote Access Service client.


Windows Registry FAQ

Windows Registry FAQ
by Simon Clausen

What is the Registry?
The Registry is a database used to store settings and options for the 32 bit versions of Microsoft Windows including Windows 95, 98, ME and NT/2000. It contains information and settings for all the hardware, software, users, and preferences of the PC. Whenever a user makes changes to a Control Panel settings, or File Associations, System Policies, or installed software, the changes are reflected and stored in the Registry.

The physical files that make up the registry are stored differently depending on your version of Windows; under Windows 95 & 98 it is contained in two hidden files in your Windows directory, called USER.DAT and SYSTEM.DAT, for Windows Me there is an additional CLASSES.DAT file, while under Windows NT/2000 the files are contained seperately in the %SystemRoot%\System32\Config directory. You can not edit these files directly, you must use a tool commonly known as a "Registry Editor" to make any changes (using registry editors will be discussed later in the article).

The Structure of the Registry

The Registry has a hierarchal structure, although it looks complicated the structure is similar to the directory structure on your hard disk, with Regedit being similar to Windows Explorer.

Registry Structure Each main branch (denoted by a folder icon in the Registry Editor, see left) is called a Hive, and Hives contains Keys. Each key can contain other keys (sometimes referred to as sub-keys), as well as Values. The values contain the actual information stored in the Registry. There are three types of values; String, Binary, and DWORD - the use of these depends upon the context.

There are six main branches, each containing a specific portion of the information stored in the Registry. They are as follows:

  • HKEY_CLASSES_ROOT - This branch contains all of your file association mappings to support the drag-and-drop feature, OLE information, Windows shortcuts, and core aspects of the Windows user interface.
  • HKEY_CURRENT_USER - This branch links to the section of HKEY_USERS appropriate for the user currently logged onto the PC and contains information such as logon names, desktop settings, and Start menu settings.
  • HKEY_LOCAL_MACHINE - This branch contains computer specific information about the type of hardware, software, and other preferences on a given PC, this information is used for all users who log onto this computer.
  • HKEY_USERS - This branch contains individual preferences for each user of the computer, each user is represented by a SID sub-key located under the main branch.
  • HKEY_CURRENT_CONFIG - This branch links to the section of HKEY_LOCAL_MACHINE appropriate for the current hardware configuration.
  • HKEY_DYN_DATA - This branch points to the part of HKEY_LOCAL_MACHINE, for use with the Plug-&-Play features of Windows, this section is dymanic and will change as devices are added and removed from the system.

Each registry value is stored as one of five main data types:

  • REG_BINARY - This type stores the value as raw binary data. Most hardware component information is stored as binary data, and can be displayed in an editor in hexadecimal format.
  • REG_DWORD - This type represents the data by a four byte number and is commonly used for boolean values, such as "0" is disabled and "1" is enabled. Additionally many parameters for device driver and services are this type, and can be displayed in REGEDT32 in binary, hexadecimal and decimal format, or in REGEDIT in hexadecimal and decimal format.
  • REG_EXPAND_SZ - This type is an expandable data string that is string containing a variable to be replaced when called by an application. For example, for the following value, the string "%SystemRoot%" will replaced by the actual location of the directory containing the Windows NT system files. (This type is only available using an advanced registry editor such as REGEDT32)
  • REG_MULTI_SZ - This type is a multiple string used to represent values that contain lists or multiple values, each entry is separated by a NULL character. (This type is only available using an advanced registry editor such as REGEDT32)
  • REG_SZ - This type is a standard string, used to represent human readable text values.

Editing the Registry

The Registry Editor (REGEDIT.EXE) is included with most version of Windows (although you won't find it on the Start Menu) it enables you to view, search and edit the data within of the Registry. There are several methods for starting the Registry Editor, the simplest is to click on the Start button, then select Run, and in the Open box type "regedit", and if the Registry Editor is installed it should now open and look like the image below.

Picture of regedit.exe

An alternative Registry Editor (REGEDT32.EXE) is available for use with Windows NT/2000, it includes some additional features not found in the standard version, including; the ability to view and modify security permissions, and being able to create and modify the extended string values REG_EXPAND_SZ & REG_MULTI_SZ.

Create a Shortcut to Regedit
This can be done by simply right-clicking on a blank area of your desktop, selecting New, then Shortcut, then in the Command line box enter "regedit.exe" and click Next, enter a friendly name (e.g. 'Registry Editor') then click Finish and now you can double click on the new icon to launch the Registry Editor.

Using Regedit to modify your Registry
Once you have started the Regedit you will notice that on the left side there is a tree with folders, and on the right the contents (values) of the currently selected folder.

Like Windows explorer, to expand a certain branch (see the structure of the registry section), click on the plus sign [+] to the left of any folder, or just double-click on the folder. To display the contents of a key (folder), just click the desired key, and look at the values listed on the right side. You can add a new key or value by selecting New from the Edit menu, or by right-clicking your mouse. And you can rename any value and almost any key with the same method used to rename files; right-click on an object and click rename, or click on it twice (slowly), or just press F2 on the keyboard. Lastly, you can delete a key or value by clicking on it, and pressing Delete on the keyboard, or by right-clicking on it, and choosing Delete.

Note: it is always a good idea to backup your registry before making any changes to it. It can be intimidating to a new user, and there is always the possibility of changing or deleting a critical setting causing you to have to reinstall the whole operating system. It's much better to be safe than sorry!

Importing and Exporting Registry Settings

A great feature of the Registry Editor is it's ability to import and export registry settings to a text file, this text file, identified by the .REG extension, can then be saved or shared with other people to easily modify local registry settings. You can see the layout of these text files by simply exporting a key to a file and opening it in Notepad, to do this using the Registry Editor select a key, then from the "Registry" menu choose "Export Registry File...", choose a filename and save. If you open this file in notepad you will see a file similar to the example below:

REGEDIT4

[HKEY_LOCAL_MACHINE\SYSTEM\Setup]
"SetupType"=dword:00000000
"CmdLine"="setup -newsetup"
"SystemPrefix"=hex:c5,0b,00,00,00,40,36,02

The layout is quite simple, REGEDIT4 indicated the file type and version, [HKEY_LOCAL_MACHINE\SYSTEM\Setup] indicated the key the values are from, "SetupType"=dword:00000000 are the values themselves the portion after the "=" will vary depending on the type of value they are; DWORD, String or Binary.

So by simply editing this file to make the changes you want, it can then be easily distributed and all that need to be done is to double-click, or choose "Import" from the Registry menu, for the settings to be added to the system Registry.

Deleting keys or values using a REG file
It is also possible to delete keys and values using REG files. To delete a key start by using the same format as the the REG file above, but place a "-" symbol in front of the key name you want to delete. For example to delete the [HKEY_LOCAL_MACHINE\SYSTEM\Setup] key the reg file would look like this:

REGEDIT4

[-HKEY_LOCAL_MACHINE\SYSTEM\Setup]

The format used to delete individual values is similar, but instead of a minus sign in front of the whole key, place it after the equal sign of the value. For example, to delete the value "SetupType" the file would look like:

REGEDIT4

[HKEY_LOCAL_MACHINE\SYSTEM\Setup]
"SetupType"=-

Use this feature with care, as deleting the wrong key or value could cause major problems within the registry, so remember to always make a backup first.

Regedit Command Line Options
Regedit has a number of command line options to help automate it's use in either batch files or from the command prompt. Listed below are some of the options, please note the some of the functions are operating system specific.

regedit.exe [options] [filename]

filename   Import .reg file into the registry
/s         Silent, i.e. hide confirmation box when importing files
/e         Export registry file
           e.g. regedit /e file.reg HKEY_USERS\.DEFAULT
/L:system  Specify the location of the system.dat to use
/R:user    Specify the location of the user.dat to use
/C         Compress [filename] (Windows 98)

Maintaining the Registry

How can you backup and restore the Registry?

Windows 95
Microsoft included a utility on the Windows 95 CD-ROM that lets you create backups of the Registry on your computer. The Microsoft Configuration Backup program, CFGBACK.EXE, can be found in the \Other\Misc\Cfgback directory on the Windows 95 CD-ROM. This utility lets you create up to nine different backup copies of the Registry, which it stores, with the extension RBK, in your \Windows directory. If your system is set up for multiple users, CFGBACK.EXE won't back up the USER.DAT file.

After you have backed up your Registry, you can copy the RBK file onto a floppy disk for safekeeping. However, to restore from a backup, the RBK file must reside in the \Windows directory. Windows 95 stores the backups in compressed form, which you can then restore only by using the CFGBACK.EXE utility.

Windows 98
Microsoft Windows 98 automatically creates a backup copy of the registry every time Windows starts, in addition to this you can manually create a backup using the Registry Checker utility by running SCANREGW.EXE from Start | Run menu.

What to do if you get a Corrupted Registry
Windows 95, 98 and NT all have a simple registry backup mechanism that is quite reliable, although you should never simply rely on it, remember to always make a backup first!

Windows 95
In the Windows directory there are several hidden files, four of these will be SYSTEM.DAT & USER.DAT, your current registry, and SYSTEM.DA0 & USER.DA0, a backup of your registry. Windows 9x has a nice reature in that every time it appears to start successfully it will copy the registry over these backup files, so just in case something goes wrong can can restore it to a known good state. To restore the registry follow these instruction:

1. Click the Start button, and then click Shut Down.

2. Click Restart The Computer In MS-DOS Mode, then click Yes.

3. Change to your Windows directory. For example, if your Windows directory is c:\windows, you would type the following:

cd c:\windows

4. Type the following commands, pressing ENTER after each one. (Note that SYSTEM.DA0 and USER.DA0 contain the number zero.)

attrib -h -r -s system.dat
attrib -h -r -s system.da0
copy system.da0 system.dat
attrib -h -r -s user.dat
attrib -h -r -s user.da0
copy user.da0 user.dat

5. Restart your computer.

Following this procedure will restore your registry to its state when you last successfully started your computer.

If all else fails, there is a file on your hard disk named SYSTEM.1ST that was created when Windows 95 was first successfully installed. If necessary you could also change the file attributes of this file from read-only and hidden to archive to copy the file to C:\WINDOWS\SYSTEM.DAT.

Windows NT
On Windows NT you can use either the "Last Known Good" option or RDISK to restore to registry to a stable working configuration.

How can I clean out old data from the Registry?
Although it's possible to manually go through the Registry and delete unwanted entries, Microsoft provides a tool to automate the process, the program is called RegClean. RegClean analyzes Windows Registry keys stored in a common location in the Windows Registry. It finds keys that contain erroneous values, it removes them from the Windows Registry after having recording those entries in the Undo.Reg file. You can download this free utility from our downloads page.


Registry Guide : Enhancements : Software : Dr Watson

Home : Enhancements : Software : Dr Watson

Specify an Alternate Debugging Utility (Windows NT/2000)
By default Windows uses Dr Watson as the debugger when a system crash occurs. This setting allows you to specify an alternate utility such as Visual Studio or Norton CrashGuard.

Set the Dr Watson Log Directory (Windows NT/2000)
This tweak is used to set the directory that stores the log files created by the Dr. Watson utility.

Control the Log File Creation Method of Dr Watson (Windows NT/2000)
This tweak controls whether the Dr. Watson utility creates a new log file or appends data to the old log file for each application error that occurs.

Control Whether Dr Watson Creates a Crash Dump (Windows NT/2000)
This tweak controls whether the Dr. Watson utility creates a crash dump file after an application crash has occured.

Specify the Location of the Dump File (Windows NT/2000)
This tweak allows you to specify the path and filename to use when creating a crash dump file.

Control Whether Dr Watson Alerts Using Sound (Windows NT/2000)
This tweak controls whether the Dr. Watson utility uses sound notification, i.e. a WAV file, to alert during an application error.

Control Whether Dr Watson Alerts Using Popups (Windows NT/2000)
This tweak controls whether the Dr. Watson utility display a message box when it encounters an application error.

Specify the Wave File for Sound Notification (Windows NT/2000)
This tweak is used to specify the path and filename of the wave file to be played during an application error if sound notification has been enabled.

Control Thread Dumping in Dr Watson (Windows NT/2000)
This tweak controls whether the Dr. Watson utility should dump the contents of all threads during an application error.

Control Symbol Dumping in Dr Watson (Windows NT/2000)
This tweak controls whether the Dr. Watson should dump the contents of the symbol tables during an application error.

Specify the Number of Instructions to Record (Windows NT/2000)
This tweak specifies the number of instructions for Dr. Watson to record during an application error.

Changing the Behavior of the Dr Watson Utility (Windows NT/2000)
By default whenever an application error occurs in Windows NT, Dr Watson is launched and the debugger started automatically. The extra resources needed for the debugger can sometimes push the system over the edge. It is possible to stop the debugger from launching by changing this setting.


Copyright Notice

Copyright Notice

All content and graphics within this software are protected by U.S. copyright and international treaties and may not be copied without the express permission of WinGuides.com, which reserves all rights. The materials herein are made available for informational and noncommercial uses offline only, provided the content and/or graphics are not modified in any way and all copyright and other notices on any copy are retained.

Permission to use content may be granted on a case-by-case basis. WinGuides.com welcomes such requests. Please direct any inquiries to info@winguides.com.

DO NOT copy or adapt the design or layout herein which is also covered by copyright. Elements of WinGuides.com websites and software are protected by trade dress, trademark, unfair competition, and other laws and may not be copied or imitated in whole or in part.

Any rights not expressly granted herein are reserved.

Microsoft, Windows, Windows NT and/or other Microsoft products referenced herein are either trademarks or registered trademarks of Microsoft. The names of actual companies and products mentioned herein may be the trademarks of their respective owners.


Don't Display Last User Name (Windows NT)

Don't Display Last User Name (Windows NT)
Enabling this key will blank the username box on the logon screen. Preventing people that are logging on from knowing the last user on the system.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'DontDisplayLastUserName' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DontDisplayLastUserName | REG_SZ | "1" | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: DontDisplayLastUserName
Type: REG_SZ (String Value)
Value: (1=enable, 0=disable)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 18, 1998


Disable 8.3 Name Creation (NTFS) (Windows NT)

Disable 8.3 Name Creation (NTFS) (Windows NT)
This key stops the NTFS volume from generating MS-DOS compatible 8.3 file names. Disabling this feature can increase the performance on heavily used NTFS partitions that have large amount of files with long filenames.

Warning: Some 16 bit installation programs may have problems with this option enabled, you can either re-enabled 8.3 creation during the install or use directory names in the non LFN format i.e. "c:\progra~1\applic~1"

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NtfsDisable8dot3NameCreation | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem]
Name: NtfsDisable8dot3NameCreation
Type: REG_DWORD (DWORD Value)
Value: (0=disable, 1=enable)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 18, 1998


Enable Command Line Completion (Windows NT/2000)

Enable Command Line Completion (Windows NT/2000)
Command completion allows you to type a portion of a file name, and then have the system complete the rest by pressing the specified key. This is similar to the UNIX shell command completion feature.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, called 'CompletionChar' and set it to equal the hex value of the required control character. For example to use the TAB key set the value to '9', to use Ctrl-D set the value to '4' and for Ctrl-F set the value to '6'.

Exit your registry, you may need to restart Windows for the change to take effect.

Now when you type the first part of a filename then press the specified key, Windows will complete the filename for you. Pressing the key multiple times will scroll through all the options.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | CompletionChar | REG_DWORD | 0x00000009 (9) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Command Processor |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Command Processor]
Name: CompletionChar
Type: REG_DWORD (DWORD Value)
Value: Hex Control Character

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 8, 2001


Automatic Hidden Shares (Windows NT/2000)

Automatic Hidden Shares (Windows NT/2000)
When networking has been installed on a Windows NT machine, it will automatically create hidden shares to the local disk drives. The shares are normally accessed via \server\c$ and \server\d$ depending on the drive letter. It is possible to disable the sharing at run-time, but this tweak will stop the automatic sharing altogether.

Open your registry and find the key below.

Create a new DWORD value of either 'AutoShareWks' for NT Workstation or 'AutoShareServer' for NT server. Then set the value to equal '0' to disable automatic sharing. If the values already exist then modify them to change the value.

Restart Windows and the automatic shares should not be created.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AutoShareWks | REG_DWORD | 0x00000000 (0) | |
| |  | AutoShareServer | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parame... |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\
Parameters]
Name: AutoShareServer, AutoShareWks
Type: REG_DWORD (DWORD Value)
Value: (0=disable, 1=enable)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 21, 2001


CD-ROM Does Not Run Automatically When Inserted (Windows 9x/Me)

CD-ROM Does Not Run Automatically When Inserted (Windows 9x/Me)
When you insert a CD-ROM into the CD-ROM drive, it may not be run automatically, changing this registry key should correct the problem.

Open your registry and find the key below.

Create a new Binary value, or modify the existing value called 'NoDriveTypeAutoRun' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoDriveTypeAutoRun | REG_BINARY | 0000 95 00 00 00 | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoDriveTypeAutoRun
Type: REG_BINARY (Binary Value)
Value: 0000 95 00 00 00

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 18, 1998


Control the CD-ROM Autorun Function (All Versions)

Control the CD-ROM Autorun Function (All Versions)
Normally when you insert a disc into your CD-ROM drive, the contents are automatically launched. This tweak allows you to disable this behavior.

Open your registry and find the key below.

Change to value of 'Autorun', or create a new DWORD value if it doesn't already exist, and set the data to equal '0' for Autorun disabled.

Restart your computer for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Autorun | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\CDRom |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\CDRom]
Name: Autorun
Type: REG_DWORD (DWORD Value)
Value: (0=disable, 1=enable)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 18, 1998


Removing Icons from your Desktop (All Versions)

Removing Icons from your Desktop (All Versions)
This key contains a number of subkeys which hold information about the namespace extensions of icons on your desktop. Through this key you can control which icons are visible on the desktop, including the My Computer, Inbox, MSN and Internet icons.

The name of each key is a globally unique identifier (GUID), and the default value of each key is a human-readable name for the namespace extension, although this is not the same name as the icon on the desktop.

To delete an icon from your desktop:

Step through the subkeys until you find the key representing the icon you want to remove from your desktop, delete the key and the icon should disappear.

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\
Desktop\NameSpace]

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 18, 1998


Remove the Documents Folder from the Start Menu (All Versions)

Remove the Documents Folder from the Start Menu (All Versions)
This setting can be used to remove the recent Documents folder from the Start Menu.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, called 'NoRecentDocsMenu' set the value to equal '1' to enable the restriction.

Exit your registry, you may need to restart for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoRecentDocsMenu | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoRecentDocsMenu
Type: REG_DWORD (DWORD Value)
Value: (0 = display, 1 = remove)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 16, 2000


Remove 'Log Off Username' from the Start Menu (All Versions)

Remove 'Log Off Username' from the Start Menu (All Versions)
This tweak allows you to remove the 'Log Off Username' option from the Start menu.

Open your registry and find the key below.

Create a new binary value, or modify the existing value, named 'NoLogOff'. Modify the value to equal '01 00 00 00' to disable the Log Off prompt, or '00 00 00 00' to enable it.

Logoff or restart Windows for the change to take effect.

Note: This setting relies in Internet Explorer 4.0 or greater being installed.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoLogOff | REG_BINARY | 01 00 00 00 | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoLogOff
Type: REG_BINARY (Binary Value)
Value: 01 00 00 00

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 18, 1998


Remove the Favorites Folder from the Start Menu (All Versions)

Remove the Favorites Folder from the Start Menu (All Versions)
This tweak allows you to remove the Favorites folder from the Start Menu.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, called 'NoFavoritesMenu' and set the value to '1' to disable the Favorites folder.

Exit you registry and restart for the change to take effect.

Note: Create the same value under the HKEY_LOCAL_MACHINE hive for the change to be system wide.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoFavoritesMenu | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoFavoritesMenu
Type: REG_DWORD (DWORD Value)
Value: (0 = show favorites, 1 = no favorites)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 18, 1998


Defining Local and Remote Drive Visibility Under WinNT (Windows NT)

Defining Local and Remote Drive Visibility Under WinNT (Windows NT)
Administrators may use the NODRIVES entry to disable access to floppy drives on a per-user basis. The NODRIVES entry uses a 32-bit word to define local and network drive visibility for each logical drive in the computer. The lower 26 bits of the 32-bit word correspond to drive letters A through Z. Drives are visible when set to 0 and hidden when set to 1.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NODRIVES' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NODRIVES | REG_DWORD | 0x3FFFFFF (67108863) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NODRIVES
Type: REG_DWORD (DWORD Value)
Value: A bit mask of 11111111111111111111111111 (0x3FFFFFFh) would hide all drive letters.

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 18, 1998


Changing Default Colors for Command Prompt (Windows NT/2000)

Changing Default Colors for Command Prompt (Windows NT/2000)
The value DefaultColor controls the foreground and background colors used in command prompt windows. It has a default value of 0, for standard white text on a black background.

You can replace this value with a two-digit hexadecimal number, in which the first digit selects a background color and the second a foreground color. A value of F0, for example, would give black text on a white background, and 1E would yield yellow text on a blue background.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | DefaultColor | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Command Processor |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Command Processor]
Name: DefaultColor
Type: REG_DWORD (DWORD Value)
Value: (0 = default)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 8, 2001


Auto Logon to a Windows NT Machine (Windows NT/2000)

Auto Logon to a Windows NT Machine (Windows NT/2000)
Windows NT includes a feature that allows you to automatically logon to the machine and network, bypassing the Winlogon dialog box.

To enable this function you need to add several new values to the [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon] key.

1. Add a new string value named 'DefaultUserName' and set it to the username you wish to automatically logon as.

2. Add a new string value named 'DefaultPassword' and set this to the password for the user entered above.

3. Add a new string value named 'DefaultDomainName' and set this to the domain of the user. Ignore this value if the NT box is not participating in NT Domain security.

4. Add a new string value named 'AutoAdminLogon' and set it to either '1' to enable auto logon or '0' to disable it.

5. For Windows 2000 the additional ForceAutoLogon setting must be enabled to stop the tweak from resetting on reboot.

Exit and restart, Windows should not ask for a password and automatically show the desktop of the user.

Note: The password is stored in registry, which means anyone who has access to the machine has access to the password.

Note: You can bypass this function by holding down the SHIFT key during the boot or logoff process.

It is also important to note that if the DontDisplayLastUserName value is enabled, the auto logon feature does not function.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AutoAdminLogon | REG_SZ | "1" | |
| |  | DefaultUserName | REG_SZ | "jbloggs" | |
| |  | DefaultPassword | REG_SZ | "blog123" | |
| |  | DefaultDomainName | REG_SZ | "BLOGLAND" | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: AutoAdminLogon
Type: REG_SZ (String Value)
Value: (0=disable, 1=enable)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 4, 2001


Remote Access Service (RAS) Device Logging (Windows NT)

Remote Access Service (RAS) Device Logging (Windows NT)
Creates a file called DEVICE.LOG in the %SYSTEMROOT%\SYSTEM32\RAS folder for information about commands that the modem is sending and errors that are reported. This file can be very useful in debugging RAS failures.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'Logging' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Logging | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RasMan\Parameters |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RasMan\Parameters]
Name: Logging
Type: REG_DWORD (DWORD Value)
Value: (0=disable, 1=enable)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 18, 1998


Remote Access Service (RAS) PPP Logging (Windows NT)

Remote Access Service (RAS) PPP Logging (Windows NT)
Creates a file called PPP.LOG in the %SYSTEMROOT%\SYSTEM32\RAS folder to help diagnose connectivity problems between a PPP server and a PPP client when one of the computers is a Windows NT Remote Access Service client.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'Logging' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Logging | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RasMan\PPP |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RasMan\PPP]
Name: Logging
Type: REG_DWORD (DWORD Value)
Value: (0=disable, 1=enable)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 18, 1998


Disabling Save Password option in Dial-Up Networking (Windows NT)

Disabling Save Password option in Dial-Up Networking (Windows NT)
When you dial a phonebook entry in Dial-Up Networking (DUN), you can use the 'Save Password' option so that your DUN password is cached and you will not need to enter it on successive dial attempts. This key disables that option.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'DisableSavePassword' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DisableSavePassword | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RasMan\Parameters |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RasMan\Parameters]
Name: DisableSavePassword
Type: REG_DWORD (DWORD Value)
Value: (0=disable, 1=enable)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 18, 1998


Changing the Menu Show Delay (All Versions)

Changing the Menu Show Delay (All Versions)
Windows normally delays menus before they are displayed. For regular users this delay can become annoying, with this setting you to change the delay time or remove it altogether.

Open your registry and find the key below.

Create a new string value, or modify the existing value, named 'MenuShowDelay' and set it to equal the delay you would like before the menus are shown as a time in milliseconds.

Log off or restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | MenuShowDelay | REG_SZ | "400" | |
-
| HKEY_CURRENT_USER\Control Panel\Desktop |
-

Settings:
Key: [HKEY_CURRENT_USER\Control Panel\Desktop]
Name: MenuShowDelay
Type: REG_SZ (String Value)
Value: 0-999 (milliseconds)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 10, 2000


Active Window Tracking Using Your Mouse Cursor (All Versions)

Active Window Tracking Using Your Mouse Cursor (All Versions)
This tweak allows you to control the Window focus using the mouse cursor, by making an application active simply by moving your mouse cursor over it. This similar behavior to X-Windows on Unix.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, named ActiveWindowTracking' and set it to equal '1' for enabled or '0' for disabled.

Restart Windows for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ActiveWindowTracking | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Control Panel\Mouse |
-

Settings:
Key: [HKEY_CURRENT_USER\Control Panel\Mouse]
Name: ActiveWindowTracking
Type: REG_DWORD (DWORD Value)
Value: (0=disable,1=enable)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 10, 2000


Control the Windows Animation Function (All Versions)

Control the Windows Animation Function (All Versions)
Although the animation function can make animated Windows look good, it can also slow down your PC if you have a slower graphics card. This setting allows you to control whether the function is enabled or disabled.

Open your registry and find the key below.

Create a new string value, or modify the existing value, named "MinAnimate" and set it to '0' to disable the animation or '1' to enable it.

Restart or log off Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | MinAnimate | REG_SZ | "0" | |
-
| HKEY_CURRENT_USER\Control Panel\Desktop\WindowMetrics |
-

Settings:
Key: [HKEY_CURRENT_USER\Control Panel\Desktop\WindowMetrics]
Name: MinAnimate
Type: REG_SZ (String Value)
Value: (0=disable, 1=enable)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 5, 2001


Change the Display Color of Compressed Files and Folders (Windows NT/2000)

Change the Display Color of Compressed Files and Folders (Windows NT/2000)
When a file is compressed in Windows NT, there is an option in Explorer to display it in a different color to easily distinguish them. This setting defines what color to use, the default is blue.

Open your registry and find the key below.

Create a new binary value, or modify the existing value, named "AltColor" and set it to equal the hexadecimal RGB color value for the files and folders.

Restart Windows for the change to take effect.

Note: The option to "Display compressed files and folders with alternate color" must be enabled in explorer.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AltColor | REG_BINARY | 00 00 ff 00 | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer]
Name: AltColor
Type: REG_BINARY (Binary Value)
Value: 00 00 ff 00 (default)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 20, 2001


Legal Notice Dialog Box Before Logon (All Versions)

Legal Notice Dialog Box Before Logon (All Versions)
Use these fields to create a dialog box that will be presented to any user before logging onto the system. This is useful where you are required by law to warn people that it is illegal to attempt to logon without being an authorized user.

Open your registry and find the appropriate key for your operating system.

Windows 9x:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Winlogon

Windows NT:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

Modify the value named 'LegalNoticeCaption' to represent the caption on the dialog box (e.g. 'WARNING!'). If this value doesn't already exist create it.

Modify the value named 'LegalNoticeText' to represent the body of the dialog box (e.g. 'Do Not Attempt to Logon to this system unless you are an authorized user!')

Exit your registry and restart Windows, and the next time you boot up you should be presented with the dialog box before logging on.

Note: This value is limited to 256 characters, you need to install the latest Windows NT service pack to allow up to 1024 characters.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | LegalNoticeCaption | REG_SZ | "Password Required" | |
| |  | LegalNoticeText | REG_SZ | "Do not attempt to logon to..." | |
-
| |
-

Settings:
Name: LegalNoticeCaption, LegalNoticeText
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 19, 1998


Automatically View Thumbnails of Bitmap Files (All Versions)

Automatically View Thumbnails of Bitmap Files (All Versions)
Makes Explorer show a thumbnail version of bitmaps files in the current folder rather than the generic icon ordinarily used. This is a great way to preview .BMP files without having to open them first.

Find the key below and modify the value of (Default) to equal '%1'.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | "%1" | |
-
| HKEY_CLASSES_ROOT\Paint.Picture\DefaultIcon |
-

Settings:
Key: [HKEY_CLASSES_ROOT\Paint.Picture\DefaultIcon]
Name: (Default)
Type: REG_SZ (String Value)
Value: %1

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 20, 1998


Optimizing Dial-Up Modem Connection Speed (Windows 9x/Me)

Optimizing Dial-Up Modem Connection Speed (Windows 9x/Me)
By optimizing the MaxMTU & MaxMSS settings along with the RWIN and TTL settings you can increase dialup modem connection reliability and performance by as much as 200%.

What is the MTU and MSS?

MTU stands for Maximum Transmission Unit and in basic terms, it defines the maximum size of a packet that can be transferred in one frame over a network.

MSS or Maximum Segment Size defines how much actual data can put in that packet, and it is therefore a marginally smaller value than MTU to allow for packet addressing and other information.

Why do the default values need to be changed?

By default Windows hard codes the value of MTU to equal 1500 bytes. This value is adequate for normal LAN networking, but when your connecting to the Internet with a modem this value is too high. This can show itself in different ways, the most noticeable affect is less than peak performance.

By adjusting this value to more closely match the requirements of a modem Internet connection huge performance gains can be achieved.

Below are the instructions on how to modify these values for yourself. Please remember though, modifying the Windows registry is not for the faint hearted. Always remember to back it up first!

1. To change the settings you first have to find the details of your Dial-Up Adapter.

2. Find the key HKEY_LOCAL_MACHINE\Enum\Root\Net and within there will be one or more sub-keys such as 0000, 0001 ...

3. Open each key and find the one that contains the value of 'DeviceDesc' equal to 'Dial-Up Adapter'.

4. Within that key there will also be another sub-key named 'Bindings'. Open the 'Bindings' sub-key and you will find a string name like 'MSTCP\0000'. Take note of the four digit number after 'MSTCP' (in this case 0000) and use it in the next step.

5. Now go to the key 'HKEY_LOCAL_MACHINE\Enum\Network\MSTCP' and expand the sub-key with the same four digit number as from the previous step.

6. In this key you will find a value called 'Driver' and it will be equal to something similar to 'NetTrans\0002'. Take note of this four digit number (in this case 0002) and use it in the next step.

7. Now open the key [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans] below there will be one or more sub-key's. Expand the key with the name equal to the four digit number from the previous step.

8. Within this key create a new string value named 'MaxMTU' and set it to '576', and also add a string value named 'MaxMSS' and set it to '536'.

9. Then exit the registry and restart your computer.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | MaxMTU | REG_SZ | "576" | |
| |  | MaxMSS | REG_SZ | "536" | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans]
Name: MaxMTU, MaxMSS
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 23, 1999


Optimizing the DefaultRcvWindow & DefaultTTL Settings (Windows 9x/Me)

Optimizing the DefaultRcvWindow & DefaultTTL Settings (Windows 9x/Me)
The optimization of RcvWindow and DefaultTTL along with other registry settings such as MaxMTU and MaxMSS can speed up TCP/IP modem networking connections (e.g. Internet connections).

RWIN (Receive WINdow) is the buffer your machine waits to fill with data before attending to whatever other TCP transactions are occurring on the other threads and sockets WinSock has open while a connection is in progress.

The value of TTL (Time To Live) defines how long a packet can stay active before being discarded. The default value is '32'.

1. Open your registry and find the key below.

2. Create a new string value named 'DefaultRcvWindow' and set it to '4288'. If 'DefaultRcvWindow' already exists, then simply modify the current value.

3. Also create another string value named 'DefaultTTL' under the same key and set that to '128'. Again if it already exist, simply modify the value.

4. Exit the registry and restart Windows for the change to take effect..

Registry Editor Example
| | Name |  | Type | Data | |
| |  | DefaultRcvWindow | REG_SZ | "4288" | |
| |  | DefaultTTL | REG_SZ | "128" | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: DefaultRcvWindow, DefaultTTL
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 8, 2000


Changing the Registered Owner and Organization (All Versions)

Changing the Registered Owner and Organization (All Versions)
If you entered the wrong registration information when you installed Windows you can change it and other miscellaneous settings such as ProductID and ProductName.

Open your registry and find the key below for your operating system.

Windows 9x:
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion]

Windows NT:
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion]

Modify the strings values of 'RegisteredOwner' and 'RegisteredOrganization' to equal the required owner and company names.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | RegisteredOwner | REG_SZ | "Joe Bloggs" | |
| |  | RegisteredOrganization | REG_SZ | "ACME, Inc." | |
-
| |
-

Settings:
Name: RegisteredOwner, RegisteredOrganization
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 22, 1998


Creating a Shortcut to the System Folders (All Versions)

Creating a Shortcut to the System Folders (All Versions)
This function allow you to add a shortcut to various system folders on your Desktop or Start Menu.

Create a new folder on your desktop and name it "Control Panel.{21EC2020-3AEA-1069-A2DD-08002B30309D}" It should look like the normal Control Panel icon (not a shortcut). You can now move the icon anywhere on your desktop or start menu.

The same can be achieved for others by substituting these values:

For Dial Up Networking
Dial-Up Networking.{992CFFA0-F557-101A-88EC-00DD010CCC48}

For Printers
Printers.{2227A280-3AEA-1069-A2DE-08002B30309D}

For Control Panel
Control Panel.{21EC2020-3AEA-1069-A2DD-08002B30309D}

My Computer
My Computer.{20D04FE0-3AEA-1069-A2D8-08002B30309D}

For Network Neighborhood
Network Neighborhood.{208D2C60-3AEA-1069-A2D7-08002B30309D}

For the Inbox
InBox.{00020D75-0000-0000-C000-000000000046}

For the Recycle Bin
Recycle Bin.{645FF040-5081-101B-9F08-00AA002F954E}

For more check out the HKEY_CLASSES_ROOT\CLSID key.

Settings:
Key: [HKEY_CLASSES_ROOT\CLSID]

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 16, 1998


Displaying Hi-Color Icons without the Plus Pack (All Versions)

Displaying Hi-Color Icons without the Plus Pack (All Versions)
If you like a bit more color and detail in your icons, then step up to hi-color mode. With this setting your Windows icons are shown in all their hi-resolution glory.

Create a new string value named "Shell Icon BPP" in the key below. Change the value to equal the color depth supported by your video card (e.g. '16' for 16-bit graphics cards or '24' for 24-bit graphics cards)

Note: You need a graphics card capable of displaying above 256 colors for this to be useful.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Shell Icon BPP | REG_SZ | "16" | |
-
| HKEY_CURRENT_USER\Control Panel\Desktop\WindowMetrics |
-

Settings:
Key: [HKEY_CURRENT_USER\Control Panel\Desktop\WindowMetrics]
Name: Shell Icon BPP
Type: REG_SZ (String Value)
Value: 16

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 16, 1998


Easily Use Notepad to Open a File (All Versions)

Easily Use Notepad to Open a File (All Versions)
Enabling this setting will allow you to use Notepad to open a file by simply right clicking on the icon. Also the Notepad will be used to open the files by default if no association already exists.

Open your registry and find the key "HKEY_CLASSES_ROOT\*\shell", if it doesn't already exist then create it.

Under shell create a new key called open, and edit the string "(Default)" to read "Open With Notepad".

Under open create a new key called command, and edit the string "(Default)" to read "notepad.exe %1".

Now when you right click on a file you should see "Open with Notepad" as one of the options.

Note: This tweak may affect the Office 97 toolbar feature and stop it from working correctly. This is because when you click an icon on the Office toolbar it activates the first context menu item, which in this case is the new "Open with Notepad" command, rather than looking for the default item.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | "notepad.exe %1" | |
-
| HKEY_CLASSES_ROOT\*\shell |
-

Settings:
Key: [HKEY_CLASSES_ROOT\*\shell]
Name: (Default)
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 17, 1998


Add Explore From Here to Every Folder (All Versions)

Add Explore From Here to Every Folder (All Versions)
When you right click on any folder this will give you an option to Explore From Here, which will open up an explorer window of that folder.

Open your registry and find the key below, if it doesn't already exist create it.

Change the value of '(Default)' to equal 'E&xplore From Here'.

Create a new key under the [Explore] key called command, and edit the '(Default)' value to equal 'explorer.exe /e,/root,/idlist,%i'.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | "explorer.exe /e,/root,/idlist,%i" | |
-
| HKEY_CLASSES_ROOT\Directory\shell\Explore |
-

Settings:
Key: [HKEY_CLASSES_ROOT\Directory\shell\Explore]
Name: (Default)
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 23, 1999


Changing the Location of Windows 9x's Installation Files (Windows 9x/Me)

Changing the Location of Windows 9x's Installation Files (Windows 9x/Me)
Modifying the string will change the path that the Windows 95 setup program will look for the installation files.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'SourcePath' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SourcePath | REG_SZ | "D:\WIN95" | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Setup |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Setup]
Name: SourcePath
Type: REG_SZ (String Value)
Value: D:\WIN95

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 17, 1998


Disable Print Job Notification in Event Viewer (Windows NT)

Disable Print Job Notification in Event Viewer (Windows NT)
By default Windows NT server adds an entry in the event log for every print job occurring on the spooler. This can quickly fill up the event log with redundant information.

To disable this function, change the DWORD value for EventLog to "0".

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | EventLog | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Providers |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Providers]
Name: EventLog
Type: REG_DWORD (DWORD Value)
Value: (0 = disable)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 22, 1998


Increase NTFS Performance by Disabling the Last Access Time Stamp (Windows NT)

Increase NTFS Performance by Disabling the Last Access Time Stamp (Windows NT)
When Windows NT accesses a directory on an NTFS volume, it updates the LastAccess time stamp on each directory it detects. Therefore, if there are a large number of directories, this can affect performance.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, named "NtfsDisableLastAccessUpdate" and set it to "1" to prevent the LastAccess time stamp from being updated.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NtfsDisableLastAccessUpdate | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem]
Name: NtfsDisableLastAccessUpdate
Type: REG_DWORD (DWORD Value)
Value: (0 = disable, 1 = enable)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 22, 1998


Hard Disk Free Space Warning (Windows NT/2000)

Hard Disk Free Space Warning (Windows NT/2000)
By default Windows sends an administrative alert when the amount of free space remaining on a hard disk drive falls below 10 percent. This percentage can be configured using this setting.

Open your registry and find the key below.

Create a new DWORD value called "DiskSpaceThreshold" and set it to the percentage of free disk space remaining before an alert is sent.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DiskSpaceThreshold | REG_DWORD | 0x00000005 (5) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parame... |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\
Parameters]
Name: DiskSpaceThreshold
Type: REG_DWORD (DWORD Value)
Value: 0 - 99 percent (Default is 10)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 4, 2001


Adjust IntelliMouse Scroll Function (All Versions)

Adjust IntelliMouse Scroll Function (All Versions)
This entry determines the number of lines scrolled for each rotation of the mouse wheel on a Microsoft IntelliMouse when no modifier keys (such as [Ctrl] or [Shift]) are pressed.

If the value of this entry is 0, the screen will not scroll when the mouse wheel is turned. If the value of this entry is greater than the number of lines visible in the window, the screen will scroll up or down by one page. To direct Windows NT to interpret all wheel rotations as page-up or page-down commands, set the value of this entry to 0xffffffff.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | WheelScrollLines | REG_SZ | "3" | |
-
| HKEY_CURRENT_USER\Control Panel\Desktop |
-

Settings:
Key: [HKEY_CURRENT_USER\Control Panel\Desktop]
Name: WheelScrollLines
Type: REG_SZ (String Value)
Value: 0 - 0xFFFFFFFF

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 22, 1998


Control Network Browser Elections (Windows NT)

Control Network Browser Elections (Windows NT)
A browser election is a normal network occurrence and provides a means to guarantee there is never more than one master browser present in a domain or workgroup.

Open your registry and find the key below.

To control which computer is the Domain Master Browser, create a new string value, or modify the existing value, named "IsDomainMaster" and set the value to equal either "Yes", "No" or "Auto".

To prevent an NT Workstation or Server (non-PDC) from acting as a browser, create a new string value, or modify the existing value, named "MaintainServerList" and set it "No", the other options are "Yes", "No" or "Auto".

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | IsDomainMaster | REG_SZ | "Yes" | |
| |  | MaintainServerList | REG_SZ | "Auto" | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Browser\Parameters |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Browser\Parameters]
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 20, 2001


Increase File System Caching Memory (Windows NT)

Increase File System Caching Memory (Windows NT)
Windows NT will normally limit the amount of RAM that can be locked for I/O operations. Using this registry key will allow you to override the automatic setting.

Open your registry and find the key below.

Create a new DWORD value named 'IoPageLockLimit' if it does not already exist. Set the value to equal the maximum number of Kbytes to be allocated to I/O operations as per the table below:

RAM       IoPageLockLimit
(MB)       Decimal    Hex
4           4096     1000
8           8192     2000
16         16384     4000
32         32768     8000
64         65536    10000

As with all performance related changes, get a baseline measurement using performance monitor and then make your changes in small increments and retest the performance after each change.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | IoPageLockLimit | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memo... |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\
Memory Management]
Name: IoPageLockLimit
Type: REG_DWORD (DWORD Value)
Value: 0 = default

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 21, 2000


Increase Network Performance (Windows NT)

Increase Network Performance (Windows NT)
If you increase the number of buffers that the redirector reserves for network performance, it may increase your network throughput. Each extra execution thread that you configure will take 1k of additional nonpaged pool memory, but only if your applications actually use them.

To configure additional buffers and threads, edit:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanWorkstation\Parameters

Create new DWORD values, or modify the existing values, called:

'MaxCmds' The range is 0 - 255 and the default is 15

'MaxThreads' Set it to the same value as MaxCmds

You may also want to increase the value of 'MaxCollectionCount'. This value represents the buffer for character-mode named pipes writes. The default is 16 and the range is 0 - 65535.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | MaxCmds | REG_DWORD | 0x0000001e (30) | |
| |  | MaxThreads | REG_DWORD | 0x0000001e (30) | |
| |  | MaxCollectionCount | REG_DWORD | 0x00000020 (30) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\P... |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\
Parameters]
Type: REG_DWORD (DWORD Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 22, 1998


Desktop Icon Redraw (All Versions)

Desktop Icon Redraw (All Versions)
If you desktop icons are redrawing too frequently, it could be because the icon cache is full. Try increasing the size by changing this setting.

Open your registry and find the key below.

Create a new string value, or modify the existing value, called "Max Cached Icons" and set it to "8192". This will increase the icon cache to 8MB (8192kb).

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Max Cached Icons | REG_SZ | "8192" | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer]
Name: Max Cached Icons
Type: REG_SZ (String Value)
Value: 8192

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 29, 2000


Hiding Servers from the Browser List (Windows NT/2000)

Hiding Servers from the Browser List (Windows NT/2000)
If you have a secure server or workstation you wish to hide from the general browser list, add this registry setting.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, named "Hidden" and set it to "1".

Reboot the server. It may take up to an hour for the server to disappear from the browse list.

Hint: The same result can be achieved by executing NET CONFIG SERVER /HIDDEN:YES on the workstation

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Hidden | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parame... |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\
Parameters]
Name: Hidden
Type: REG_DWORD (DWORD Value)
Value: (0 = visible, 1 = hidden)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: November 30, 2000


Windows NT Short File Extensions (Windows NT/2000)

Windows NT Short File Extensions (Windows NT/2000)
Windows NT evaluates file extensions on the first three characters, therefore 'filename.html' is actually treated as 'filename.htm'. Therefore if you use a command such as 'del *.htm' to delete all the '.htm' files, you will also delete all '.html' files as well. This functionality can be disabled by modifying the registry.

To turn this setting off, editing the key found below and set the value of 'Win95TruncatedExtensions' to '0', to turn the feature back on, set the value back to '1'.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Win95TruncatedExtensions | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem]
Name: Win95TruncatedExtensions
Type: REG_DWORD (DWORD Value)
Value: (0 = disable , 1 = enable)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 10, 2000


Remove the Content Advisor and Ratings Password (All Versions)

Remove the Content Advisor and Ratings Password (All Versions)
If you've forgotten the Internet Explorer content advisor password and want to change the ratings settings then follow these instructions to change the settings back to their defaults.

All the Content Advisor settings are stored in the key below. If you no longer have the password, then simply delete the key, and all the settings will be removed.

Open your registry, find the key below. Single click on the key to highlight it, press the DELETE key, or alternatively select Delete from the Edit menu.

Close Internet Explorer, re-open it, and the Content Advisor feature should be disabled.

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\
Ratings]

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 28, 1998


Rename or Delete Special Folders (All Versions)

Rename or Delete Special Folders (All Versions)
This setting allows you to rename and delete special folders (such as the Recycle Bin) as if it was a normal folder by right-clicking the icon.

Set the value of "Attributes" in the appropriate key below to "70 01 00 20", you will then be able to rename and/or delete any special folders by right-clicking them.

Recycle Bin
[HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}\ShellFolder]

Search the [HKEY_CLASSES_ROOT\CLSID] key for any other folders you want to modify.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Attributes | REG_BINARY | 70 01 00 20 | |
-
| |
-

Settings:
Name: Attributes
Type: REG_BINARY (Binary Value)
Value: (70 01 00 20=enable, 40 01 00 20=default)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 28, 1999


Changing the Internet Explorer Window Title (All Versions)

Changing the Internet Explorer Window Title (All Versions)
This setting allows you to customize Internet Explorer by using your own window title. For example you could rename IE to 'My Browser' or anything else you like!

Open your registry and find the key below.

Create a new string value, or modify the existing value, to equal the title you would like.

Note: Delete the value of 'WindowTitle' to change the title back to the default.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Window Title | REG_SZ | "My Browser" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
Name: Window Title
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 30, 1998


Remove the Tildes in Short Filenames (All Versions)

Remove the Tildes in Short Filenames (All Versions)
When long filenames are shown in an application that only supports short filenames a tilde "~" is used to convert the long name into a compatible short name. This setting removes the use of tildes.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NameNumericTail' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NameNumericTail | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem]
Name: NameNumericTail
Type: REG_DWORD (DWORD Value)
Value: (0=disable,1=enable)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 5, 1998


Full Window Drag Option (All Versions)

Full Window Drag Option (All Versions)
This setting enables the Full Windows Drag function, which allow you to view the contents of window while dragging it across the screen, instead of just the standard outline.

Open your registry and find the key below.

Create a new string value named 'DragFullWindows', or modify the existing value, to equal '1' for enabled, or '0' for disabled.

Close the registry and log off or restart Windows.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DragFullWindows | REG_SZ | "1" | |
-
| HKEY_CURRENT_USER\Control Panel\Desktop |
-

Settings:
Key: [HKEY_CURRENT_USER\Control Panel\Desktop]
Name: DragFullWindows
Type: REG_SZ (String Value)
Value: (0=disable, 1=enable)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 20, 2001


Add a Background Bitmap to the Internet Explorer Toolbar (All Versions)

Add a Background Bitmap to the Internet Explorer Toolbar (All Versions)
Want to have you own bitmap shown on the Internet Explorer toolbar? It's simple with this registry setting.

Open your registry and find the key below.

Add a new string value, or modify the existing value, named "BackBitmap" for IE4 or "BackBitmapIE5" for IE5, then set the value to the path and name of bitmap file you wish to use (e.g. "C:\WINDOWS\CLOUDS.BMP")

Exit your registry and restart Internet Explorer for the change to take effect.

Note: To remove an existing background image, simply delete these values and IE will use the default setting.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | BackBitmap | REG_SZ | "c:\windows\clouds.bmp" | |
| |  | BackBitmapIE5 | REG_SZ | "c:\windows\clouds.bmp" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Toolbar |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Toolbar]
Name: BackBitmap or BackBitmapIE5
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 11, 2000


Sending Unencrypted Passwords (Windows NT)

Sending Unencrypted Passwords (Windows NT)
Connecting to SMB servers (such as Samba and LAN Manager for UNIX) with an unencrypted (plain text) password fails after upgrading to Windows NT 4.0 Service Pack 3. This is because the SMB redirector in Service Pack 3 handles unencrypted passwords differently than previous versions of Windows NT. Beginning with Service Pack 3, the SMB redirector will not send an unencrypted password unless you add a registry entry to enable unencrypted passwords.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, named "EnablePlainTextPassword" and set it to equal "1" to enable plain text passwords.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | EnablePlainTextPassword | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Rdr\Parameters |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Rdr\Parameters]
Name: EnablePlainTextPassword
Type: REG_DWORD (DWORD Value)
Value: (0=disable, 1=enable)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 9, 1998


Internet Explorer Intercepts the FTP Command (All Versions)

Internet Explorer Intercepts the FTP Command (All Versions)
When you enter a FTP command such as "FTP ftp.microsoft.com" IE may launch instead of the DOS based FTP program.

To disable this behavior, open your registry and find the key below, then delete the value of "ftp".

To re-enable, create a new string value called "ftp" and set it to equal "ftp://".

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ftp | REG_SZ | "ftp://" | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\URL\Prefixes |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\URL\
Prefixes]
Name: ftp
Type: REG_SZ (String Value)
Value: ftp://

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: November 28, 2000


Change the Default Mailbox Sound Setting (All Versions)

Change the Default Mailbox Sound Setting (All Versions)
When you receive a new message, a sound may not be played even though "Play sound when new messages arrive" is enabled.

This registry key displays the path to the Windows 9x and NT default "new mail" sound. It is recommended to first check the sound control panel to make sure a sound is selected for New Mail notification.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | "c:\windows\beep.wav" | |
-
| HKEY_CURRENT_USER\AppEvents\Schemes\Apps\.Default\MailBeep\.current |
-

Settings:
Key: [HKEY_CURRENT_USER\AppEvents\Schemes\Apps\.Default\MailBeep\.current]
Name: (Default)
Type: REG_SZ (String Value)
Value: Filename

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 15, 1998


Change the Logon Screen Background Color (All Versions)

Change the Logon Screen Background Color (All Versions)
When you change the color scheme and appearance of your desktop it does not change the background color of the logon screen to match. This tweak allows you to change that color as well.

Open your registry and find the key below.

Modify the value named 'Background' according to the color you would like in RGB (Red/Green/Blue) format. For example, "0 0 0" for black or "255 255 255" for white, and every other color in between.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Background | REG_SZ | "0 0 0" | |
-
| HKEY_USERS\.DEFAULT\Control Panel\Colors |
-

Settings:
Key: [HKEY_USERS\.DEFAULT\Control Panel\Colors]
Name: Background
Type: REG_SZ (String Value)
Value: 0 0 0 - 255 255 255

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 10, 2000


Add Custom Folder to My Computer or the Desktop (All Versions)

Add Custom Folder to My Computer or the Desktop (All Versions)
Create your own custom system folder on the desktop or in My Computer, that can't be deleted or renamed.

Add the following series of keys and values to the registry at ([HKEY_CLASSES_ROOT\CLSID] or [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID]). The entry can be a random number. In this example 'FD4DF9E0-E3DE-11CE-BFCF-ABCD1DE12345'

[HKEY_CLASSES_ROOT\CLSID\{FD4DF9E0-E3DE-11CE-BFCF-ABCD1DE12345}]
@='My Menu'

[HKEY_CLASSES_ROOT\CLSID\{FD4DF9E0-E3DE-11CE-BFCF-ABCD1DE12345}\DefaultIcon]
@='c:\winnt\myicon.ico'

[HKEY_CLASSES_ROOT\CLSID\{FD4DF9E0-E3DE-11CE-BFCF-ABCD1DE12345}\InProcServer32]
@='shell32.dll'
'ThreadingModel'='Apartment'

[HKEY_CLASSES_ROOT\CLSID\{FD4DF9E0-E3DE-11CE-BFCF-ABCD1DE12345}\Shell\Open My Menu\Command]
@="c:\winnt\explorer /n /root,c:\MyFolder"

[HKEY_CLASSES_ROOT\CLSID\{FD4DF9E0-E3DE-11CE-BFCF-ABCD1DE12345}\ShellEx\PropertySheetHandlers\{FD4DF9E0-E3DE-11CE-BFCF-ABCD1DE12345}]

[HKEY_CLASSES_ROOT\CLSID\{FD4DF9E0-E3DE-11CE-BFCF-ABCD1DE12345}\ShellFolder]
"Attributes"=hex:00,00,00,00

To place the folder (which is now a system folder) on the desktop and in My Computer, add the following keys:

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Desktop\NameSpace\{FD4DF9E0-E3DE-11CE-BFCF-ABCD1DE12345}]

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\NameSpace\{FD4DF9E0-E3DE-11CE-BFCF-ABCD1DE12345}]

The folder cannot be deleted from the desktop or My Computer, nor can it be renamed other than removing the CLSID and the entries under NAMESPACE.

Settings:
Key: [HKEY_CLASSES_ROOT\CLSID]
Name: CLSID
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 21, 1999


Remove or Change the Shortcut Arrow (All Versions)

Remove or Change the Shortcut Arrow (All Versions)
Would you prefer to display your shortcuts without the arrow in the bottom left hand corner? This tip will show you how to change the arrow icon or remove it completely.

To Remove the Icon:
Open your registry and delete the value named 'IsShortCut' from the keys [HKEY_CLASSES_ROOT\lnkfile] and [HKEY_CLASSES_ROOT\piffile].

To Change the Icon:
Open the key [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\
Explorer\Shell Icons] and create a new string value, or modify the existing value, called '29'. Set it to equal the filename, including path, for the icon you want to use for the shortcut arrow. By setting this to a blank icon it has a similar effect to the removal method above, without the side effects.

Restart Windows for the changes to take effect.

Note: This tweak effectively changes the properties of shortcuts so they are no longer considered to be shortcuts by Windows, this may have some slight side effects, such as hot keys not working as before.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | 29 | REG_SZ | "c:\windows\system\shell32.dll,21" | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Sh... |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\
Shell Icons]
Name: 29
Type: REG_SZ (String Value)
Value: Icon Filename

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 5, 2000


Remove Cached Command Lines from the Run Menu (All Versions)

Remove Cached Command Lines from the Run Menu (All Versions)
Got a lot of items in the Start Menu's run command history? This tip will allow you to remove any extraneous commands.

Delete the value corresponding to the command you want to remove, or remove all the entries to clear the list completely.

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\
RunMRU]

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 27, 1998


Dial-Up Networking Password Box Grayed Out (Windows 9x/Me)

Dial-Up Networking Password Box Grayed Out (Windows 9x/Me)
If you are having problems trying to get DUN to remember your password and you find the option grayed out then there are a few things you can try.

1. Make sure you have Client for Microsoft Networks installed on your system. Control Panel / Networking / Add / Client / Microsoft / Microsoft Networking.

2. Your Windows startup is configured to ask for a password and you are hitting the esc key when the logon box is displayed.

3. You have a corrupted password file. Do a search for *.pwl in the Windows folder and rename all the files you find. Note - this will force you to rebuild your password files from scratch.

4. Check the Registry:

  • Run the Registry Editor (REGEDIT.EXE).
  • Find HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Network\Real Mode Net.
  • If you see autologon (on the right side) with a value of "00 00 00 00", double-click on it, and change the value to "01 00 00 00 00".
  • Exit RegEdit and restart the PC.

    Settings:
    Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Network\
    Real Mode Net]
    Type: REG_DWORD (DWORD Value)

    Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

    Last Modified: February 20, 2001

    • Return to Index Copyright © 2001. All Rights Reserved. License


Long File Names Need to be Enabled (Windows 98)

Long File Names Need to be Enabled (Windows 98)
If you are receiving an error when installing Windows 98 that long file names need to enabled in order for Windows 98 to install successfully try this.

Open your registry and find the key below.

Look for an entry in the right pane named "NameNumericTail" and delete it.

Exit and reboot then retry the installation.

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem]
Name: NameNumericTail
Type: REG_DWORD (DWORD Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 15, 1998


Disable Automatic Cache Updates in NT's DNS Server (Windows NT)

Disable Automatic Cache Updates in NT's DNS Server (Windows NT)
This value disables that automatic cache updated from the DNS root servers. Useful when there is a problem with the root servers, or if you wish to completely control DNS updates.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, named "AutoCacheUpdate" and set it to "0" to disable automatic updates.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AutoCacheUpdate | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\DNS\Parameters |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\DNS\Parameters]
Name: AutoCacheUpdate
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: November 16, 1998


PCMCIA Network Adapter Problems (Windows 9x/Me)

PCMCIA Network Adapter Problems (Windows 9x/Me)
When using a PCMCIA network adapter under Windows 98 you might not be able to connect the computer to the network, and under Control Panel > System there is a yellow exclamation mark "!" next to the card.

Open your registry and find the key below.

Modify the value named "EnablePowerManagement" and change it to '0' based on the following:

  • If the current value is '0000 01 00 00 00' change it to '0000 00 00 00 00' (Full Version).
  • If the current value is '0x00000001 (1)' change it to '0x00000000 (0)' (Upgrade Version)
Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | EnablePowerManagement | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\VCOMM |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\VCOMM]
Name: EnablePowerManagement
Value: (0 = disable, 1 = enable)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: November 20, 1998


PS2 Mouse Port Rate Adjustment (Windows NT)

PS2 Mouse Port Rate Adjustment (Windows NT)
Ever noticed how your mouse cursor flickers sometimes or doesn't run as smoothly as you would like? That's because the refresh rate is set too low, modify this key to speed things up and make your mouse cursor move smoothly.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, called "SampleRate" and set it to equal 60 - 200 (decimal), where a higher number means a smoother cursor.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SampleRate | REG_DWORD | 0x0000003c (60) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\i8042prt\Parameters |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\i8042prt\Parameters]
Name: SampleRate
Type: REG_DWORD (DWORD Value)
Value: 0 - 200 (default = 60)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: November 20, 1998


New Command Missing in Windows Explorer (All Versions)

New Command Missing in Windows Explorer (All Versions)
After you install Internet Explorer with the Windows Desktop Update component you may notice that the New command is missing from the right-click context menu. This tip will help you fix the problem.

To resolve this issue, open your registry and verify that the registry key listed below has the value listed, and if needed, edit the value to match the value listed.

Note: This registry entry only exists if the Windows Desktop Update component is installed. If the Windows Desktop Update component is not installed, add the registry entry and (Default) value.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | "{D969A300-E7FF-11d0-A93B-00A0C90F2719}" | |
-
| HKEY_CLASSES_ROOT\Directory\Background\shellex\ContextMenuHandlers\New |
-

Settings:
Key: [HKEY_CLASSES_ROOT\Directory\Background\shellex\ContextMenuHandlers\New]
Name: (Default)
Type: REG_SZ (String Value)
Value: {D969A300-E7FF-11d0-A93B-00A0C90F2719}

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: November 20, 1998


Change the Internet Explorer & Outlook Express Toolbar Logo (All Versions)

Change the Internet Explorer & Outlook Express Toolbar Logo (All Versions)
When you browse the Internet using Internet Explorer or read messages using Outlook Express, a logo is displayed indicating whether activity is taking place. With this tweak you can modify which logo is shown, customize it or reset it to the default.

Use Your Own Animated Logo
There are two bitmap files used to display the animated logo, both can be identical except for the size, one is 38 pixels wide and the other 22 pixels.

Using an image editor, such as MS Paint, create an image similar to a roll of film, where equal sized "frames" are a stacked vertically within the one larger image. For example, a large icon, with 10 frames, would be 38 pixels wide and 380 pixels high (38 pixels x 10 frames = 380 pixels high).

When active and the logo is animated, the top frame is shown first, then the next, an so on, until the last frame is reached and the image loops. Similarly, when the application is idle, the first frame is shown statically until further activity, that is unless an alternate non-animated logo has been defined using the technique below.

Once you have created the icons you need to register them by opening the key [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Toolbar] in your registry.

Then create two new string values, or modify the existing values, named 'SmBrandBitmap' and 'BrandBitmap' and set their values to equal the full filename of the small (22 pixel) image and large (38 pixel) image respectively.

Use Your Own Non-Animated Logo
These images are shown when the application is idle, as with the method above there are two images one small 22 x 22 pixel and a larger 38 x 38 pixel. To activate them open the key [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main] and create two string values named 'SmallBitmap' and 'BigBitmap' setting the values to equal the filenames of the images.

Reset to the Default Logos
To restore the default animated logo, delete the 'BrandBitmap' and 'SmBrandBitmap' string values found under the registry key [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Toolbar].

To restore the default idle logo, delete the 'SmallBitmap' and 'BigBitmap' string values found under the registry key [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main].

Note: You will need to restart Internet Explorer or Outlook Express for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | BrandBitmap | REG_SZ | "c:\windows\animation.bmp" | |
| |  | SmBrandBitmap | REG_SZ | "c:\windows\animation_small.bmp" | |
| |  | BigBitmap | REG_SZ | "c:\windows\logo.bmp" | |
| |  | SmallBitmap | REG_SZ | "c:\windows\logo_small.bmp" | |
-
| |
-

Last Modified: October 10, 2000


Change Default OS Selection Timeout (Windows NT)

Change Default OS Selection Timeout (Windows NT)
This setting controls the amount of time Windows NT will wait before loading the Default OS choice as define by the "default=" option.

Change the attributes for BOOT.INI so it is not 'Read Only', BOOT.INI is found in the root directory of the first partition. And open the file using Notepad or another text editor (not Microsoft Word or any word processor).

Change the default value of '30' to a number representing a timeout in seconds. i.e.. to have a timeout of 5 seconds change the value to 'timeout=5'.

The change will take affect on the next reboot.

Hint: To have an Windows NT wait indefinitely for a choice change this value to 'timeout=-1'.

Settings:
Name: timeout

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 2, 1998


Change the Default Operating System (Windows NT)

Change the Default Operating System (Windows NT)
This setting in the BOOT.INI file controls which operating system the NT Boot Loader launches by default if none is selected.

Change the attributes for BOOT.INI so it is not 'Read Only', BOOT.INI is found in the root directory of the first partition. Then open the file using Notepad or another text editor (not Microsoft Word or any word processor).

Under the [boot loader] section change the 'default=' option to one of the operating systems listed under the [operating systems] section that you wish to use as the default.

For example, to load Windows NT from the first partition on the first IDE hard drive in the /WINNT directory the option would look like:

default=multi(0)disk(0)rdisk(0)partition(1)\WINNT

Settings:
Name: default

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 10, 2000


Boot Windows NT with the Default VGA Video Driver (Windows NT)

Boot Windows NT with the Default VGA Video Driver (Windows NT)
This explains how to create an a safe VGA video mode start-up option, especially useful when your video adapter or driver is causing problems.

Change the attributes for BOOT.INI so it is not 'Read Only', BOOT.INI is found in the root directory of the first partition. And open the file using Notepad or another text editor (not Microsoft Word or any word processor).

Listed under the [operating systems] section are all the OS's the NT boot loader can launch. To create a new safe VGA entry copy one of the existing NT entries and paste it on a new line.

At the end of the new entry add '/basevideo' (without the quotation marks), change the description of the entry to reflect that it is VGA mode.

The new entry should look similar to:
multi(0)disk(0)rdisk(0)partition(1)\WINNT="Windows NT Workstation Version 4.00 [VGA mode]" /basevideo

Changes will take place on the next reboot.

Settings:
Name: [operating systems]

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 2, 1998


Boot Windows NT in Safe Mode (Windows NT)

Boot Windows NT in Safe Mode (Windows NT)
Windows NT can be very temperamental sometimes are you add new software or install a new driver. The option allows you the create a Windows NT alternative to the Windows 9x Safe Mode. In this mode extra checks are performed and not all third party drivers are loaded.

Change the attributes for BOOT.INI so it is not 'Read Only', BOOT.INI is found in the root directory of the first partition. And open the file using Notepad or another text editor (not Microsoft Word or any word processor).

Listed under the [operating systems] section are all the OS's the NT boot loader can launch. To create a new safe mode entry copy one of the existing NT entries and paste it on a new line.

At the end of the new entry add '/sos' (without the quotation marks), change the description of the entry to reflect that it is safe mode. Additional adding '/basevideo' will launch NT with the default VGA driver.

The new entry should look similar to:
multi(0)disk(0)rdisk(0)partition(1)\WINNT="Windows NT Workstation Version 4.00 [Safe Mode]" /sos /basevideo

Changes will take place on the next reboot.

Last Modified: December 2, 1998


Disable Detection of Devices on Serial Ports (Windows NT)

Disable Detection of Devices on Serial Ports (Windows NT)
Windows NT attempts to probe the serial ports on boot-up to detect any serial mice. This can cause problems with other serial devices such as UPS's.

Change the attributes for BOOT.INI so it is not 'Read Only', BOOT.INI is found in the root directory of the first partition. And open the file using Notepad or another text editor (not Microsoft Word or any word processor).

Listed under the [operating systems] section are all the OS's the NT boot loader can launch.

At the end of the each entry add '/NoSerialMice' (without the quotation marks).

The new entry should look similar to:
multi(0)disk(0)rdisk(0)partition(1)\WINNT="Windows NT Workstation Version 4.00" /NoSerialMice

Changes will take place on the next reboot.

Last Modified: December 2, 1998


Enable the 4GT RAM Tuning Feature of NT Enterprise Edition (Windows NT)

Enable the 4GT RAM Tuning Feature of NT Enterprise Edition (Windows NT)
With standard Windows NT Server, the per-process address limit is 2 gigabytes (GB) of random access memory (RAM). The 4GT feature of Windows NT Server/E increases this limit to 3 GB without introducing new APIs. 4GT does this by reducing the potential RAM allocated to the Windows NT kernel from 2 GB to 1 GB.

Change the attributes for BOOT.INI so it is not 'Read Only', BOOT.INI is found in the root directory of the first partition. And open the file using Notepad or another text editor (not Microsoft Word or any word processor).

Listed under the [operating systems] section are all the OS's the NT boot loader can launch.

At the end of the each entry add '/3GB' (without the quotation marks).

The new entry should look similar to:
multi(0)disk(0)rdisk(0)partition(1)\WINNT="Windows NT Server Version 4.00" /3GB

Changes will take place on the next reboot.

Note: This change is only effective if you are using Windows NT Server/E. On standard Windows NT, this flag will relocate the kernel, but applications will be unable to access more than 2 GB.

Last Modified: December 2, 1998


Disable Function Keys During the Boot Sequence (Windows 9x/Me)

Disable Function Keys During the Boot Sequence (Windows 9x/Me)
By default Windows 9x enables the function keys on boot, these allow you to control the boot process. For example pressing F5 while the "Starting Windows 95..." message is displayed will boot Windows in Safe Mode.

Change the attributes for MSDOS.SYS so it is not 'Read Only', MSDOS.SYS is found in the root directory of your C:\ drive. Open the file using Notepad or another text editor (not Microsoft Word or any word processor).

Change the value of 'BootKeys=' to 'BootKeys=1' for enabled or 'BootKeys=0' for disabled.

Changes will take place on the next reboot.

Settings:
Value: BootKeys=1 (default) or BootKeys=0 (disabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 2, 1998


Change the Function Keys Timeout (Windows 9x/Me)

Change the Function Keys Timeout (Windows 9x/Me)
By default Windows 9x enables the function keys during the boot sequence for 2 seconds, these keys allow you to control the boot process. This value can be changed using this tweak.

Change the attributes for MSDOS.SYS so it is not 'Read Only', MSDOS.SYS is found in the root directory of your C:\ drive. Open the file using Notepad or another text editor (not Microsoft Word or any word processor).

Change the value of 'BootDelay=' to a value representing the number of seconds to make the keys available. e.g. To enable the keys for 5 seconds change the value to 'BootDelay=5'

Changes will take place on the next reboot.

Settings:
Value: BootDelay=2 (default)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 2, 1998


Control Whether the Windows 9x GUI is Loaded Automatically (Windows 9x/Me)

Control Whether the Windows 9x GUI is Loaded Automatically (Windows 9x/Me)
By default Windows 9x automatically loads the GUI (or Windows Desktop) with this key you can control whether the GUI is loaded or if you just want the MS-DOS 7.0 prompt.

Change the attributes for MSDOS.SYS so it is not 'Read Only', MSDOS.SYS is found in the root directory of your C:\ drive. Open the file using Notepad or another text editor (not Microsoft Word or any word processor).

Change the value of 'BootGUI=' to 'BootGUI=1' for GUI enabled or 'BootGUI=0' GUI disabled.

Changes will take place on the next reboot.

Settings:
Value: BootGUI=1 (default)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 2, 1998


Display the Windows Splash Screen While Loading (Windows 9x/Me)

Display the Windows Splash Screen While Loading (Windows 9x/Me)
When Windows is loading normally you see the Windows clouds splash screen, this can be disabled to show the background DOS boot process.

Change the attributes for MSDOS.SYS so it is not 'Read Only', MSDOS.SYS is found in the root directory of your C:\ drive. Open the file using Notepad or another text editor (not Microsoft Word or any word processor).

Change the value of 'Logo=' to 'Logo=1' for splash screen enabled or 'Logo=0' for disabled.

Changes will take place on the next reboot.

Hint: Pressing [Esc] while the splash screen is showing will have the same effect for that session.

Settings:
Value: Logo=1 (default)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 2, 1998


Allow Booting to the Previous Operating System (Windows 9x/Me)

Allow Booting to the Previous Operating System (Windows 9x/Me)
If you installed an upgrade version of Windows 9x, you can normally press F4 to boot your previous version of Windows. This option can be disabled.

Change the attributes for MSDOS.SYS so it is not 'Read Only', MSDOS.SYS is found in the root directory of your C:\ drive. Open the file using Notepad or another text editor (not Microsoft Word or any word processor).

Change the value of 'BootMulti=' to 'BootMulti=1' for F4 enabled or 'BootMulti=0' for disabled.

Changes will take place on the next reboot.

Settings:
Value: BootMulti=1 (default)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 2, 1998


Running Scandisk on Boot Up (Windows 9x/Me)

Running Scandisk on Boot Up (Windows 9x/Me)
If Windows 9x is shutdown incorrectly, or the turn power turned off without shutting down, the system will attempt to run Scandisk on the next boot. You can control whether Scandisk doesn't run, prompts whether to run, or runs automatically.

Change the attributes for MSDOS.SYS so it is not 'Read Only', MSDOS.SYS is found in the root directory of your C:\ drive. Open the file using Notepad or another text editor (not Microsoft Word or any word processor).

Change the value of 'AutoScan=' to:

  • AutoScan=0 : Scandisk is Disabled
  • AutoScan=1 : Scandisk Prompts First
  • AutoScan=2 : Scandisk Runs Automatically
Changes will take place on the next reboot.

Note: It is advisable to run Scandisk after an incorrect shutdown to avoid file corruption.

Note: This feature is only available on Windows 95 OSR 2 and greater.

Settings:
Value: AutoScan=1 (default)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 28, 1999


Showing the Windows Boot Menu (Windows 9x/Me)

Showing the Windows Boot Menu (Windows 9x/Me)
By default Windows 9x does not show the boot menu unless you press F8. The boot menu allows you to boot Windows in different modes, including Safe Mode and Command Prompt Mode. You can configure the boot menu to be shown automatically on every boot.

Change the attributes for MSDOS.SYS so it is not 'Read Only', MSDOS.SYS is found in the root directory of your C:\ drive. Open the file using Notepad or another text editor (not Microsoft Word or any word processor).

Change the value of 'BootMenu=' to 'BootMenu=1' for enabled or 'BootMenu=0' for disabled.

If the boot menu is enabled you can control how long it waits before continuing to boot with the 'BootMenuDelay=' option. Set 'BootMenuDelay=' to the amount of time to wait in seconds. i.e. 'BootMenuDelay=5' would wait 5 seconds before continuing to load Windows.

Changes will take place on the next reboot.

Note: BootKeys must also be enabled for this option to function i.e. 'BootKeys=1'

Settings:
Value: BootMenu=0 (default)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 2, 1998


Restricting Information Available to Anonymous Logon Users (Windows NT)

Restricting Information Available to Anonymous Logon Users (Windows NT)
Windows NT has a feature where anonymous logon users can list domain user names and enumerate share names. Customers who want enhanced security have requested the ability to optionally restrict this functionality.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, named "RestrictAnonymous" and set it to "1" to restrict access.

Restart Windows for the change to take effect.

Note: It is only possible to control this operation after installing Windows NT 4.0 Service Pack 3 or the Windows NT 3.51 hot fix.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | RestrictAnonymous | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\LSA |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\LSA]
Name: RestrictAnonymous
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 3, 1998


Stop Error Messages When Booting (Windows NT)

Stop Error Messages When Booting (Windows NT)
Stops the annoying Windows pop-up messages notifying you a device is not functioning when you boot-up Windows NT.

Create a REG_DWORD value of 'NoPopupsOnBoot' in the key below (if it doesn't already exist). Set the value to '1' to disable pop-up messages from appearing.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoPopupsOnBoot | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Windows |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Windows]
Name: NoPopupsOnBoot
Type: REG_DWORD (DWORD Value)
Value: (1 = disable messages)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 14, 1998


Change the Location of the Outlook Express Mail and News Files (All Versions)

Change the Location of the Outlook Express Mail and News Files (All Versions)
If you have installed Windows on a separate partition and want to keep it free of any unnecessary files, you can change the location of the mail and news files stored by Outlook Express to another partition.

Change the value of 'Store Root' in the key below to equal the new path.

Don't forget to move the 'mail' and 'news' folder from the old location to the new.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Store Root | REG_SZ | "c:\mail" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Outlook Express |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Outlook Express]
Name: Store Root
Type: REG_SZ (String Value)
Value: Path to Files

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 14, 1998


Change the Logon Screen Wallpaper (All Versions)

Change the Logon Screen Wallpaper (All Versions)
When you setup a background wallpaper for your desktop, the initial logon screen wallpaper is not changed and stays as the default Windows appearance. This tweak allow you to change the default wallpaper.

Open your registry and find the key below.

Modify the value of 'Wallpaper' to equal the path and filename of the bitmap (BMP) file you want to use as the background (e.g. 'c:\windows\mylogo.bmp').

Restart Windows for the changes to take effect.

Note: In the same key, you should also be aware of, and possibly set these additional values "Pattern"="(None)" & "TileWallpaper"="0"

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Wallpaper | REG_SZ | "c:\windows\mylogo.bmp" | |
| |  | Pattern | REG_SZ | "(None)" | |
| |  | TileWallpaper | REG_SZ | "0" | |
-
| HKEY_USERS\.DEFAULT\Control Panel\Desktop |
-

Settings:
Key: [HKEY_USERS\.DEFAULT\Control Panel\Desktop]
Name: Wallpaper
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 10, 2000


View Which Hot Fix Patches Have Been Installed (Windows NT)

View Which Hot Fix Patches Have Been Installed (Windows NT)
Periodically Microsoft releases Hot Fix's to patch bugs in Windows NT and other products, this key contains information about which Hot fix's have been installed.

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Hotfix]

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 14, 1998


Removing Item Types from the New Menu (All Versions)

Removing Item Types from the New Menu (All Versions)
When you right-click on your desktop or other selected applications there is a New sub-menu which contains a list a default templates. This list can be modified to include only the templates you want.

Each template exists in the [HKEY_CLASSES_ROOT] hive associated with a file extension. Whether it is visible or not in the New menu is controlled by whether the related entry has a sub-key called 'ShellNew'.

For example on the New menu there is usually an entry for "Text Document". This is visible because of the key: [HKEY_CLASSES_ROOT\.txt\ShellNew] If you were to rename the key so it no longer had a sub-key called 'ShellNew' by changing it to [HKEY_CLASSES_ROOT\.txt\ShellNewOld] it would disappear from the New menu.

1. Open Regedit, and using the Find function (Ctrl+F) search for any values of 'ShellNew'.

2. Several should be found under the [HKEY_CLASSES_ROOT] hive, if you do not want them to be displayed rename 'ShellNew' to 'ShellNewOld'.

Note: Changes should take place immediately without needing to reboot.

Last Modified: December 14, 1998


Change the Location of System and Special Folders (All Versions)

Change the Location of System and Special Folders (All Versions)
Windows keeps a number of special folders such as "My Documents", "Desktop", "Favorites" and the "Start Menu". These folders can be moved anywhere on you system and the new location updated in this key.

Open your registry and find the key below, listed are all the Windows special folders.

Note the current location of the folder you want to move, and then using explorer move the folder to the new location.

Edit the value in the key below for the folder you moved to reflect the new directory location.

Note: Log off or restart Windows for the changes to take effect.

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\
User Shell Folders]

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 15, 1998


Setting a Minimum Password Length (All Versions)

Setting a Minimum Password Length (All Versions)
You can force Windows to reject passwords that do not meet a minimum password length. Useful to help stop people from using trivial passwords where security is an issue.

Open your registry and find the key below, if the Network sub-key does not already exist then create it.

Create a new REG_BINARY value named 'MinPwdLen', and set the data to the minimum number of characters required for a password to be accepted.

Note: This does not apply to existing passwords, only new or changed.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | MinPwdLen | REG_BINARY | 06 | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Ne... |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\
Network]
Name: MinPwdLen
Type: REG_BINARY (Binary Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 15, 1998


Launching Programs When Windows Starts (All Versions)

Launching Programs When Windows Starts (All Versions)
You can automatically start programs whenever Windows launches. If you have programs automatically starting that you have not loaded then you can remove them using this tip as well.

Add a new startup application
Open your registry and find the key [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run].

For each program you want to start automatically create a new string value using a descriptive name, and set the value of the string to the program executable.

For example, to automatically start Notepad, add a new entry of "Notepad"="c:\windows\notepad.exe".

Note: Remember to include the full path to the file, if the directory is not included in your default search path.

Remove a startup application
If you're trying to remove a program and can not find it in the StartUp folder (usually C:\WINDOWS\Start Menu\Programs\StartUp), then it may be launching from one of the registry keys below. To remove it, delete the value associated with the program you want to remove.

[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run]
[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\RunOnce]
[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\RunServices]
[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\RunServicesOnce]
[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Winlogon\Userinit]

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run]
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\RunOnce]
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\RunServices]
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\RunServicesOnce]
[HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Windows]

It may also be loaded from the [Load] or [Run] sections of your WIN.INI file, found in the Windows directory.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Notepad | REG_SZ | "c:\windows\notepad.exe" | |
-
| |
-

Last Modified: December 15, 1998


Removing Programs listed in the Add/Remove Programs Box (All Versions)

Removing Programs listed in the Add/Remove Programs Box (All Versions)
All Windows 9x or NT compatible programs must include an Uninstall program, sometimes though the program may get removed but entry in Add/Remove programs doesn't, from this key you can remove those orphaned entries.

Open your registry and find the key below. Under this key will be a number of sub-keys, each representing an installed application.

To see which application each sub-key represents, open it and there should be at least two values 'DisplayName' and 'UninstallString'. 'DisplayName' is the name used in the Add/Remove programs list, and 'UninstallString' is the program used to uninstall the application.

To remove a program from the list you can simple delete the sub-key representing that program.

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall]

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 15, 1998


Creating Program Aliases in Windows (All Versions)

Creating Program Aliases in Windows (All Versions)
A hidden feature in the Windows registry allows you to create program aliases. Allowing you to create, for example, an alias called JBLOGGS.EXE that when executed actually runs another program, e.g. NOTEPAD.EXE

Open your registry and find the key below, below it should be a number of sub-keys.

To create a new alias create a sub-key, and call it the name of the alias you wish to create (e.g. "JBLOGGS.EXE").

Modify the (default) value of the sub-key to equal the fully qualified path and filename of the application you want to be launched when you execute the alias (e.g. "c:\windows\notepad.exe").

Exit your registry and to test use the Start -> Run command type in the name of your alias (i.e. "JBLOGGS.EXE") and the aliased program should be launched, in this case Notepad.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | "c:\windows\notepad.exe" | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths]
Name: (Default)
Type: REG_SZ (String Value)
Value: Filename (e.g. c:\windows\notepad.exe)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 15, 1998


Preventing the Logon Screen Saver from Launching (Windows NT)

Preventing the Logon Screen Saver from Launching (Windows NT)
Windows NT has a default screen saver called login.scr, which runs even if no screen saver has been selected. This can present a security risk, as it can allow a local user to replace login.scr with another program and have it launched with system privileges.

Open your registry and find the key below.

Change the value of 'ScreenSaveActive' to '0' to disable the screen saver.

Restart Windows for the change to take effect.

Note: An alternative screen saver can be used, if disabling is not an option, simple change the value of 'SCRNSAVE.EXE' in the same to key, to equal the full path of the screen saver you wish to use.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ScreenSaveActive | REG_SZ | "0" | |
-
| HKEY_USERS\.DEFAULT\Control Panel\Desktop |
-

Settings:
Key: [HKEY_USERS\.DEFAULT\Control Panel\Desktop]
Name: ScreenSaveActive
Type: REG_SZ (String Value)
Value: (0 = disabled, 1 =enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 16, 1998


Restricting Applications Users Can Run (All Versions)

Restricting Applications Users Can Run (All Versions)
Windows gives the ability to restrict the applications that can be run by users on a workstation.

Open your registry and find the key [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]

Create a new DWORD value and name it 'RestrictRun' set the value to equal '1' for enabled or '0' for disabled.

Then define the applications the are allowed to be run at the key [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\RestrictRun].

Creating a new string value for each application, named as consecutive numbers.

Reboot the computer for the changes to take effect.

Caution: If you are the person who applies Group Policy, do not apply this policy to yourself. If applied too broadly, this policy can prevent administrators from running Group Policy or the registry editors. As a result, once applied, you cannot change this policy except by reinstalling Windows 2000.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | 1 | REG_SZ | "notepad.exe" | |
| |  | 2 | REG_SZ | "regedit.exe" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: RestrictRun

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 18, 1998


Add the QuickView Option to All Files (All Versions)

Add the QuickView Option to All Files (All Versions)
If you ever wanted to add QuickView to the context menu of all file types, it may be a tedious task doing so using Windows Explorer's Options - File Type window. This tip shows how to do it in a couple of easy steps.

Open your registry and create a sub-key called QuickView under [HKEY_CLASSES_ROOT\*].

Change the (Default) value of the new sub-key to equal '*'.

Close the registry and open an Explorer window. Right-click on any file and the QuickView command should now appear.

Note: You need to have QuickView installed on your PC. If not, Go to Control Panel, Add/Remove Programs and add it from the Accessories group in the Windows Setup tab.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | "*" | |
-
| HKEY_CLASSES_ROOT\*\QuickView |
-

Settings:
Key: [HKEY_CLASSES_ROOT\*\QuickView]
Name: (Default)
Type: REG_SZ (String Value)
Value: *

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 7, 1999


Optimizing L2 Caches Over 256K (Windows NT)

Optimizing L2 Caches Over 256K (Windows NT)
Windows NT by default is optimized for a 256K size L2 cache. With most computers now having L2 caches larger than 256K it pays to take the time to change the SecondLevelDataCache setting to correspond to the size of the L2 cache installed.

Open your registry and find the key below.

Create a new DWORD value, of modify the existing value, named "SecondLevelDataCache" and set it to equal your L2 cache size in Kb's (decimal).

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SecondLevelDataCache | REG_DWORD | 0x00000200 (512) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memo... |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\
Memory Management]
Name: SecondLevelDataCache
Type: REG_DWORD (DWORD Value)
Value: Cache (in Kb) using Decimal Notation

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 31, 1998


Disable the MS-DOS Command Prompt (All Versions)

Disable the MS-DOS Command Prompt (All Versions)
This setting allows you to disable the use of the MS-DOS command prompt in Windows.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, named "Disabled" and set it to "1" to disable the command prompt or to re-enable it again later change the value to "0".

Note: You need to reboot for this restriction to come into force.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Disabled | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Win... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
WinOldApp]
Name: Disabled
Type: REG_DWORD (DWORD Value)
Value: (0 = disable, 1 = enable)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 3, 1999


Disable Single Mode MS-DOS Applications in Windows (All Versions)

Disable Single Mode MS-DOS Applications in Windows (All Versions)
This setting allows you to disable the use of real mode DOS applications from within the Windows shell.

Open your registry and find the key below.

Create a new DWORD value, and name it 'NoRealMode' and set it to "1" to disable real mode DOS', to re-enable it again later change the value to "0".

Note: You need to reboot for this restriction to come into force.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoRealMode | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Win... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
WinOldApp]
Name: NoRealMode
Type: REG_DWORD (DWORD Value)
Value: (0 = disable, 1 = enable)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 3, 1999


PC Speaker Beeping on Errors (All Versions)

PC Speaker Beeping on Errors (All Versions)
If you get annoyed by the beeps and noises coming from your PC speaker but can't find a way to turn it off, then use this tip to disable it.

Open your registry and find the key below.

Create a new string value, or modify the existing value, named "Beep" and set it to either 'Yes' for beeping enabled or 'No' for beeping disabled.

You may need to log off or restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Beep | REG_SZ | "No" | |
-
| HKEY_CURRENT_USER\Control Panel\Sound |
-

Settings:
Key: [HKEY_CURRENT_USER\Control Panel\Sound]
Name: Beep
Type: REG_SZ (String Value)
Value: Yes or No

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 3, 1999


Control Whether Windows Performs Smooth Scrolling (All Versions)

Control Whether Windows Performs Smooth Scrolling (All Versions)
This setting allow you to disable the Windows smooth scrolling function, which on an low-powered system can cause performance degradation.

Open your registry and find the key below.

Modify the value, or create a new binary value, named "SmoothScroll" and set it to either '00 00 00 00' for disabled or '01 00 00 00' for enabled.

Log off or restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SmoothScroll | REG_BINARY | 00 00 00 00 | |
-
| HKEY_CURRENT_USER\Control Panel\Desktop |
-

Settings:
Key: [HKEY_CURRENT_USER\Control Panel\Desktop]
Name: SmoothScroll
Type: REG_BINARY (Binary Value)
Value: (00 00 00 00 = disabled, 01 00 00 00 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 3, 1999


Hide Share Passwords with Asterisks (All Versions)

Hide Share Passwords with Asterisks (All Versions)
This setting controls whether the password typed when accessing a file share is shown in clear text or as asterisks.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'HideSharePwds' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | HideSharePwds | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Ne... |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Network]
Name: HideSharePwds
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1=enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 4, 1999


Require Alphanumeric Windows Password (All Versions)

Require Alphanumeric Windows Password (All Versions)
Windows by default will accept anything as a password, including nothing. This setting controls whether Windows will require a alphanumeric password, i.e. a password made from a combination of alpha (A, B, C...) and numeric (1, 2 ,3 ...) characters.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'AlphanumPwds' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AlphanumPwds | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Ne... |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Network]
Name: AlphanumPwds
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1=enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 4, 1999


Disabled Password Caching (All Versions)

Disabled Password Caching (All Versions)
Normally Windows caches a copy of the users password on the local system to allow for additional automation, this leads to a possible security threat on some systems. Disabling caching means the users passwords are not cached locally. This setting also removes the second Windows password screen and also remove the possibility of networks passwords to get out of sync.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'DisablePwdCaching' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DisablePwdCaching | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Ne... |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Network]
Name: DisablePwdCaching
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1=enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 4, 1999


Automatic Logon without Name or Password (Windows 9x/Me)

Automatic Logon without Name or Password (Windows 9x/Me)
This setting allows Windows clients to logon without entering a user name or password, therefore bypassing the logon box.

Open your registry and find the key below.

Create a new string value called "Default Password" and set it to match the password of the default user.

Restart Windows and the system should automatically logon.

Hint: The username of the default user can be found at [HKEY_LOCAL_MACHINE\Network\Logon\Username]

Note: The password is stored in clear text, therefore anyone with access to the registry can see the default password.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | Default Password | REG_SZ | "blogs123" | |
-
| HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Winlogon |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Winlogon]
Name: Default Password
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 17, 2000


Support Long Filenames on Netware Servers (Windows 9x/Me)

Support Long Filenames on Netware Servers (Windows 9x/Me)
This setting controls whether long filenames (LFN) are supported on Netware servers, and if supported which versions.

Open your registry and find the key below, if it doesn't already exist then create it.

Create a new DWORD value, or modify the existing value, named "SupportLFN" and set it to either '0', '1' or '2' depending on the table below:

Value   Description
-----   -----------
  0     LFN Disabled
  1     LFN Enabled on Netware 3.12 and above
  2     LFN Enabled on all Netware servers that support LFN

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SupportLFN | REG_DWORD | 0x00000002 (2) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\NWREDIR |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\NWREDIR]
Name: SupportLFN
Type: REG_DWORD (DWORD Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 4, 1999


Specifying a Preferred Netware Server (Windows 9x/Me)

Specifying a Preferred Netware Server (Windows 9x/Me)
This setting allows you to specify a default Netware.

Open your registry and find the key below.

Create new string value named "AuthenticatingAgent" and set it to the name of your preferred Netware server.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AuthenticatingAgent | REG_SZ | "NETSERVER" | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NWNP32\NetworkProvider |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NWNP32\
NetworkProvider]
Name: AuthenticatingAgent
Type: REG_SZ (String Value)
Value: Server Name

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 4, 1999


Disable Automatic Netware Logon (Windows 9x/Me)

Disable Automatic Netware Logon (Windows 9x/Me)
This setting disables the automatic logon to Netware servers.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'DisableDefaultPasswords' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | DisableDefaultPasswords | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NWNP32\NetworkProvider |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NWNP32\
NetworkProvider]
Name: DisableDefaultPasswords
Type: REG_DWORD (DWORD Value)
Value: (0 = enabled, 1 = disabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 4, 1999


Disable SAP advertising for Netware Networks (Windows 9x/Me)

Disable SAP advertising for Netware Networks (Windows 9x/Me)
By default Windows will send SAP packets to advertise available file and print shares when 'File and Print Sharing for Netware Networks' is enabled, this setting disables those packets.

Open your registry and find the key below.

Create a new string value, or modify the existing value, named "Use_Sap" and set it to "0" to disable SAP packets.

In addition you may also be required to create another key named [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NcpServer\Parameters\Ndi\Params\Use_Sap] and set the (Default) value to equal "0".

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Use_Sap | REG_SZ | "0" | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NcpServer\Parameters |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NcpServer\
Parameters]
Name: Use_Sap
Type: REG_SZ (String Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 4, 1999


Require Validation by Network for Windows Access (Windows 9x/Me)

Require Validation by Network for Windows Access (Windows 9x/Me)
By default Windows 9x doesn't require a valid network username and password combination for a user to bypass the logon and gain access to the local machine. This functionality can be changed to require validation by the network before allowing access.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called "MustBeValidated" and set it to equal "1" to require successful authentication.

Restart Windows for the change to take effect.

Your machine must be part of a Windows domain for this tweak to work, as the user must be authenticated by the network.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | MustBeValidated | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\Network\Logon |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\Network\Logon]
Name: MustBeValidated
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 29, 2000


Disable Dial-In Access (All Versions)

Disable Dial-In Access (All Versions)
It's possible for users to setup a modem on a Windows machine, and by using Dial-up Networking allow callers to connect to the internal network. Especially in a corporate environment this can cause a major security risk.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoDialIn' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoDialIn | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Ne... |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Network]
Name: NoDialIn
Type: REG_DWORD (DWORD Value)
Value: (0 = dial-in enabled, 1 = dial-in disabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 4, 1999


Disable File and Printer Sharing (All Versions)

Disable File and Printer Sharing (All Versions)
When file and printer sharing is installed it allows users to make services available to other users on a network, this functionality can be disabled by changing this setting.

Open your registry and find the key below, if it doesn't already exist then create it.

Create two new DWORD values named "NoFileSharing" and "NoPrintSharing" and set the values to either '1' for sharing disabled or '0' for sharing enabled. Both settings do not have to be the same, it is possible to have one disabled and the other enabled.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoFileSharing | REG_DWORD | 0x00000001 (1) | |
| |  | NoPrintSharing | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Ne... |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Network]
Name: NoFileSharing, NoPrintSharing
Type: REG_DWORD (DWORD Value)
Value: (0 = file sharing, 1 = disabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 4, 1999


Display Domain Logon Confirmation (All Versions)

Display Domain Logon Confirmation (All Versions)
When this option is enabled, a dialog box is shown when successful validation by a Windows domain occurs.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'DomainLogonMessage' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DomainLogonMessage | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\Network\Logon |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\Network\Logon]
Name: DomainLogonMessage
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 4, 1999


Disable Caching of Domain Password (All Versions)

Disable Caching of Domain Password (All Versions)
Enabling this setting disables the caching of the domain passwords, and therefore passwords are required to be re-entered to access any additional domain resources.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoDomainPwdCaching' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoDomainPwdCaching | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\Network\Logon |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\Network\Logon]
Name: NoDomainPwdCaching
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 4, 1999


Enable Shutdown from Authentication Dialog Box (Windows NT)

Enable Shutdown from Authentication Dialog Box (Windows NT)
When this setting is enabled a [Shutdown] button is displayed in authentication dialog box when the system first starts. This allows you to shutdown a system without logging in. The button is shown by default on a workstation and removed on a server installation.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'ShutdownWithoutLogon' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ShutdownWithoutLogon | REG_SZ | "1" | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: ShutdownWithoutLogon
Type: REG_SZ (String Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 4, 1999


Beep on Printer Errors (Windows NT)

Beep on Printer Errors (Windows NT)
When this setting is enabled the machine will beep every few seconds when a remote job error occurs on a print server.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'BeepEnabled' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | BeepEnabled | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print]
Name: BeepEnabled
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 4, 1999


Maximum Number of Remote Access Authentication Attempts (Windows NT)

Maximum Number of Remote Access Authentication Attempts (Windows NT)
This setting controls the number of authentication retries before a remote access connection is terminated.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'AuthenticateRetries' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AuthenticateRetries | REG_DWORD | 0x00000003 (3) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RemoteAccess\Parame... |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RemoteAccess\
Parameters]
Name: AuthenticateRetries
Type: REG_DWORD (DWORD Value)
Value: 1 to 10

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 4, 1999


Maximum Time Limit for Authentication (Windows NT)

Maximum Time Limit for Authentication (Windows NT)
A time limit can be enforced on the period available to logon via remote access before the connection is terminated.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'AuthenticateTime' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AuthenticateTime | REG_DWORD | 0x0000003c (60) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RemoteAccess\Parame... |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RemoteAccess\
Parameters]
Name: AuthenticateTime
Type: REG_DWORD (DWORD Value)
Value: 20 to 600 (seconds)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 4, 1999


Automatically Disconnect Remote Access Callers (Windows NT)

Automatically Disconnect Remote Access Callers (Windows NT)
Specifies the amount of idle time in minutes to wait before disconnecting the remote access client.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'AutoDisconnect' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AutoDisconnect | REG_DWORD | 0x00000005 (5) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RemoteAccess\Parame... |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RemoteAccess\
Parameters]
Name: AutoDisconnect
Type: REG_DWORD (DWORD Value)
Value: Time in Minutes

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 4, 1999


Specify the Callback Pause Period (Windows NT)

Specify the Callback Pause Period (Windows NT)
When callback is required or requested this setting defines how long to wait before initiating the callback connection.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'CallbackTime' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | CallbackTime | REG_DWORD | 0x0000000c (12) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RemoteAccess\Parame... |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RemoteAccess\
Parameters]
Name: CallbackTime
Type: REG_DWORD (DWORD Value)
Value: 2 - 12 (seconds)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 4, 1999


Run Logon Scripts Synchronously (Windows NT/2000)

Run Logon Scripts Synchronously (Windows NT/2000)
This setting defines whether the system should wait for the logon scripts to complete before starting the user's shell or whether the scripts should run asynchronously.

This function can also be controlled on a per user basis by modifying the same value at [HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Winlogon]

Note: The value in [HKEY_CURRENT_USER] section take precedence over [HKEY_LOCAL_MACHINE].

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | RunLogonScriptSync | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: RunLogonScriptSync
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 4, 1999


Delete Cached Copies of Roaming Profiles (Windows NT/2000)

Delete Cached Copies of Roaming Profiles (Windows NT/2000)
If this setting is enabled, when users with roaming profiles log off, the system will delete the cached copy of their roaming profile. This will help to save disk space where that are lots of roaming users.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'DeleteRoamingCache' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DeleteRoamingCache | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: DeleteRoamingCache
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 4, 1999


Automatically Detect Slow Network Connections (Windows NT)

Automatically Detect Slow Network Connections (Windows NT)
By default, Windows NT will attempt to detect the time-out on network links to determine their speed (high or low). This functionality can be disabled if Windows is having problems determining the speed of your link.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'SlowLinkDetectEnabled' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SlowLinkDetectEnabled | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: SlowLinkDetectEnabled
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 4, 1999


Define the Slow Link Time-Out (Windows NT)

Define the Slow Link Time-Out (Windows NT)
Windows uses this value to define what should be classified as low speed and what is a high speed connection. The default time-out is 2000 milliseconds, any connection slower is considered a low speed link.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'SlowLinkTimeOut' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SlowLinkTimeOut | REG_DWORD | 0x000003e8 (1000) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: SlowLinkTimeOut
Type: REG_DWORD (DWORD Value)
Value: Time (milliseconds)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 4, 1999


Time-out for User Profile Dialog Boxes (Windows NT/2000)

Time-out for User Profile Dialog Boxes (Windows NT/2000)
When the user is presented with a dialog box requesting User Profile information, this specifies the amount of time in seconds before the dialog box is closed and the default is accepted. The default value is 30 seconds.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'ProfileDlgTimeOut' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ProfileDlgTimeOut | REG_DWORD | 0x0000003c (6) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: ProfileDlgTimeOut
Type: REG_DWORD (DWORD Value)
Value: 1 to 600 (seconds)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 4, 1999


Disable the Shut Down Command (All Versions)

Disable the Shut Down Command (All Versions)
This option allows you to stop users from being able to shutdown the computer by disabling the shut down command.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoClose' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoClose | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoClose
Type: REG_DWORD (DWORD Value)
Value: (0 = shutdown enabled, 1 = shutdown disabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 4, 1999


Hide All Items on the Desktop (All Versions)

Hide All Items on the Desktop (All Versions)
Enabling this options hides all the items and programs on the Windows desktop.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoDesktop' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoDesktop | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoDesktop
Type: REG_DWORD (DWORD Value)
Value: (0 = disable restriction, 1 = enabled restriction)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 4, 1999


Hide Drives in My Computer (All Versions)

Hide Drives in My Computer (All Versions)
This setting controls which drives are visible in 'My Computer', it is possible to hide all drives or just selected ones.

The value of 'NoDrives' defines which drives are visible. The low order (right most) bit is drive A: while the 26th bit is Drive Z: To hide a drive, turn on it's bit.

If your not happy working in Hex, add these decimal numbers to hide the drive(s):

A: 1, B: 2, C: 4, D: 8, E: 16, F: 32, G: 64, H: 128, I: 256, J: 512, K: 1024, L: 2048, M: 4096, N: 8192, O: 16384, P: 32768, Q: 65536, R: 131072, S: 262144, T: 524288, U: 1048576, V: 2097152, W: 4194304, X: 8388608, Y: 16777216, Z: 33554432, ALL: 67108863

Note: These drives will still appear in File Manager, to remove File Manager, delete winfile.exe.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoDrives | REG_DWORD | 0x03ffffff (67108863) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoDrives
Type: REG_DWORD (DWORD Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 4, 1999


Remove the Find Command From the Start Menu (All Versions)

Remove the Find Command From the Start Menu (All Versions)
When enabled this setting removes the 'Find' command from the Start Menu.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoFind' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoFind | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoFind
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 4, 1999


Hide the Network Neighborhood Icon (All Versions)

Hide the Network Neighborhood Icon (All Versions)
The Network Neighborhood icon is shown on the Windows desktop whenever Windows networking is installed, by enabling this setting the icon will be hidden.

In addition this disables UNC capability from within the Explorer interface, including the Start menu's Run command, UNC paths configured by the administrator in Policies for shared folders, desktop icons, the Start command, and so forth. This does not impair the functionality of the command line Net.exe command.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoNetHood | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoNetHood
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 4, 1999


Remove the Run Command from the Start Menu (All Versions)

Remove the Run Command from the Start Menu (All Versions)
Removes the user's ability to start applications or processes from the Start menu by removing the option completely.

Note: If the user still has access to the MS-DOS prompt icon or command prompt, the user can start unauthorized applications.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoRun | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoRun
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 4, 1999


Don't Save Settings at Exit (All Versions)

Don't Save Settings at Exit (All Versions)
Normally when Windows exits it saves the desktop configuration, including icon location, appearance etc. This setting disables these changes from being saved, this is useful in both a secure environment and when you don't want people to change the appearance of your desktop once you have it setup the way you like it.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoSaveSettings' set the value to equal '1' to enable the restriction.

Exit your registry, you may need to restart for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoSaveSettings | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoSaveSettings
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 16, 2000


Remove Folders from Settings on the Start Menu (All Versions)

Remove Folders from Settings on the Start Menu (All Versions)
Removes the Control Panel and Printers folders from the Settings menu. Note: Removing the Taskbar, Control Panel, and Printer folders causes the Settings menu to be removed completely.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, called 'NoSetFolders' and edit the value according to the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: This tweak may also disable the Windows Explorer hotkey shortcut (Windows + E).

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoSetFolders | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoSetFolders
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 27, 2001


Remove the Taskbar from Settings on the Start Menu (All Versions)

Remove the Taskbar from Settings on the Start Menu (All Versions)
Enabling this option removes the Taskbar option from Settings on the Start Menu, therefore stopping users from changing the taskbar properties. Note: Removing the Taskbar, Control Panel, and Printer folders causes the Settings menu to be removed completely.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoSetTaskbar' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoSetTaskbar | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoSetTaskbar
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 4, 1999


Remove the Start Banner on the Taskbar (All Versions)

Remove the Start Banner on the Taskbar (All Versions)
Hide the bouncing arrow and the "Click Here to Begin" caption that appear on the taskbar when you start Windows.

Open your registry and find the key below.

Create a new Binary value, or modify the existing value called 'NoStartBanner' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoStartBanner | REG_BINARY | 00 00 00 00 | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoStartBanner
Type: REG_BINARY (Binary Value)
Value: (00 00 00 00 = start banner, 01 00 00 00 = no start banner)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 7, 2000


Determines which drives the Autorun feature is enabled on (All Versions)

Determines which drives the Autorun feature is enabled on (All Versions)
Determines whether the Autorun feature is enabled on each drive connected to the system. When Autorun is enabled, media is started automatically when it is inserted in the drive.

This value is comprised of 32 bits. The lower 26 bits each represent a drive, with the lowest (right- most) bit representing drive A and the 26th bit from the right representing drive Z. If a bit is set to 0, the autorun feature is enabled on that drive. If a bit is set to 1, the autorun feature is disabled on that drive.

For example, if the value of this entry is 0x8 (1000 binary), autorun is disabled on drive D. Note that a value of 1 in the bit representing the CD-ROM drive takes precedence over the value of Autorun.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoDriveAutoRun | REG_DWORD | 0x03ffffff (67108863) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoDriveAutoRun
Type: REG_DWORD (DWORD Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 14, 2000


Remove File menu from Explorer (Windows NT)

Remove File menu from Explorer (Windows NT)
Removes the File option from Explorer's toolbar. (This option was added in Service Pack 2.)

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoFileMenu' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoFileMenu | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoFileMenu
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 4, 1999


Remove common program groups from Start menu (All Versions)

Remove common program groups from Start menu (All Versions)
Disables the display of common groups when the user selects Programs from the Start menu.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoCommonGroups' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoCommonGroups | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoCommonGroups
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 4, 1999


Disable context menus for the Taskbar (Windows NT/2000)

Disable context menus for the Taskbar (Windows NT/2000)
Removes the context menus (right click on the taskbar) for the tray, including the Start button, Tab control, and Clock.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoTrayContextMenu' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoTrayContextMenu | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoTrayContextMenu
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 27, 2001


Disable the Ability to Right Click on the Desktop (Windows NT/2000)

Disable the Ability to Right Click on the Desktop (Windows NT/2000)
This tweak removes the context menu that would normally appear when the user right clicks on the desktop or in the Explorer right results pane.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoViewContextMenu' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoViewContextMenu | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoViewContextMenu
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 27, 2001


Remove the Map and Disconnect Network Drive Options (Windows NT)

Remove the Map and Disconnect Network Drive Options (Windows NT)
Prevents users from making additional network connections by removing the Map Network Drive and Disconnect Network Drive buttons from the toolbar in Explorer and also removing the menu items from the Context menu of My Computer and the Tools menu of Explorer. (This option was added in Service Pack 2.)

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoNetConnectDisconnect' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoNetConnectDisconnect | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoNetConnectDisconnect
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 4, 1999


Define Whether Windows Parses Autoexec.bat (Windows NT/2000)

Define Whether Windows Parses Autoexec.bat (Windows NT/2000)
When this value is 1, the environment variables declared in the Autoexec.bat file are included in the user's environment.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'ParseAutoexec' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ParseAutoexec | REG_SZ | "0" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: ParseAutoexec
Type: REG_SZ (String Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 4, 1999


Disable Task Manager (Windows NT)

Disable Task Manager (Windows NT)
Enables or disables the user's ability to start Task Manager to view processes, applications running, and make changes to the priority or state of the individual processes. (This option was added in Service Pack 2.)

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'DisableTaskMgr' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DisableTaskMgr | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
System]
Name: DisableTaskMgr
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 4, 1999


Disable the Printer Server Browse Thread (Windows NT/2000)

Disable the Printer Server Browse Thread (Windows NT/2000)
When this option is enabled, the print spooler does not send shared printer information to other print servers.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'DisableServerThread' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DisableServerThread | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Print |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Print]
Name: DisableServerThread
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 4, 1999


Define the Scheduler Priority (Windows NT)

Define the Scheduler Priority (Windows NT)
This setting controls the overall priority of the printer scheduler.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'SchedulerThreadPriority' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SchedulerThreadPriority | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Print |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Print]
Name: SchedulerThreadPriority
Type: REG_DWORD (DWORD Value)
Value: Above normal = 1; Normal = 0, Less than normal = ffffffff

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 4, 1999


Allow extended characters in 8.3 filenames (Windows NT/2000)

Allow extended characters in 8.3 filenames (Windows NT/2000)
This setting allows extended characters to be used in 8.3 filenames. Short file names with extended characters may not be viewable on computers that do not have the same character code page.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NtfsAllowExtendedCharacterIn8dot3Name' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NtfsAllowExtendedCharacterIn8dot3Name | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem]
Name: NtfsAllowExtendedCharacterIn8dot3Name
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 4, 1999


Deny Access to the Display Settings (All Versions)

Deny Access to the Display Settings (All Versions)
This option disables the display settings control panel icon, and stops users from accessing any display settings.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoDispCPL' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoDispCPL | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
System]
Name: NoDispCPL
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 4, 1999


Hide the Display Appearance Page (All Versions)

Hide the Display Appearance Page (All Versions)
When enabled this setting hides the display settings appearance page.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoDispAppearancePage' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoDispAppearancePage | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
System]
Name: NoDispAppearancePage
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 4, 1999


Hide the Display Background Page (All Versions)

Hide the Display Background Page (All Versions)
This option hides the background page stopping users from changing any background display settings.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoDispBackgroundPage' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoDispBackgroundPage | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
System]
Name: NoDispBackgroundPage
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 4, 1999


Hide the Screen Saver Settings Page (All Versions)

Hide the Screen Saver Settings Page (All Versions)
This option hides the screen saver page from the display settings control, which stops users having access to change screen saver settings.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoDispScrSavPage' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoDispScrSavPage | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
System]
Name: NoDispScrSavPage
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 4, 1999


Hide the Display Settings Page (All Versions)

Hide the Display Settings Page (All Versions)
This option hides the Settings page from the display properties control.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoDispSettingsPage' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoDispSettingsPage | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
System]
Name: NoDispSettingsPage
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 4, 1999


Remove Entire Network from Network Neighborhood (All Versions)

Remove Entire Network from Network Neighborhood (All Versions)
Entire Network is an option under Network Neighborhood that allows users to see all the Workgroups and Domains on the network. Entire Network can be disabled, so users are confined to their own Workgroup or Domain.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoEntireNetwork' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoEntireNetwork | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Net... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Network]
Name: NoEntireNetwork
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 4, 1999


Hide Workgroup Content from Network Neighborhood (All Versions)

Hide Workgroup Content from Network Neighborhood (All Versions)
Enabling this option hides all Workgroup contents from being displayed in Network Neighborhood.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoWorkgroupContents' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoWorkgroupContents | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Net... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Network]
Name: NoWorkgroupContents
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 4, 1999


Disable Network Control Panel (Windows 9x/Me)

Disable Network Control Panel (Windows 9x/Me)
Enabling this option disables access to the Network Control Panel icon.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoNetSetup' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoNetSetup | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Net... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Network]
Name: NoNetSetup
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 4, 1999


Hide Network Identification Page (Windows 9x/Me)

Hide Network Identification Page (Windows 9x/Me)
The Network Identification page include options to set the Computer Name, Workgroup and Description, enabling this option disables access to the Network ID page.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoNetSetupIDPage' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoNetSetupIDPage | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Net... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Network]
Name: NoNetSetupIDPage
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 4, 1999


Hide Network Access Control Page (Windows 9x/Me)

Hide Network Access Control Page (Windows 9x/Me)
The Access Control Page, defines whether the computer support User-Level access or Share-Level access, enabling this option removes access to the Access Control Page.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoNetSetupSecurityPage' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoNetSetupSecurityPage | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Net... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Network]
Name: NoNetSetupSecurityPage
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 4, 1999


Disable Printers Control Panel Icon (Windows 9x/Me)

Disable Printers Control Panel Icon (Windows 9x/Me)
This option disables access to the Printers icon in control panel, therefore stopping users from changing Printer settings.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoPrinters' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoPrinters | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoPrinters
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 4, 1999


Hide the General and Details Printer Pages (Windows 9x/Me)

Hide the General and Details Printer Pages (Windows 9x/Me)
This option hides the printer details and general printer information pages. Once enabled this option stops users from changing specific printer settings.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoPrinterTabs' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoPrinterTabs | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoPrinterTabs
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 4, 1999


Disable the Deletion of Printers (Windows 9x/Me)

Disable the Deletion of Printers (Windows 9x/Me)
Printers can be deleted simply by any user pressing the delete key, enabling this setting stops users from being able to delete printers.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoDeletePrinter' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoDeletePrinter | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoDeletePrinter
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 4, 1999


Disable the Addition of Printers (Windows 9x/Me)

Disable the Addition of Printers (Windows 9x/Me)
Any user can add a new printer their system, this option once enabled disables the addition of new printers to the computer.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoAddPrinter' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoAddPrinter | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoAddPrinter
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 4, 1999


Restrict Access to the Passwords Control Panel (Windows 9x/Me)

Restrict Access to the Passwords Control Panel (Windows 9x/Me)
This options disables access to the Passwords icon on the control panel, therefore stopping users from changing security related settings.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoSecCPL' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoSecCPL | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
System]
Name: NoSecCPL
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 4, 1999


Hide the Change Passwords Page (Windows 9x/Me)

Hide the Change Passwords Page (Windows 9x/Me)
When this setting is enabled, users are no longer able to access the Change Passwords page.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoPwdPage' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoPwdPage | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
System]
Name: NoPwdPage
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 5, 1999


Hide the Remote Administration Page (Windows 9x/Me)

Hide the Remote Administration Page (Windows 9x/Me)
Enabling this function stops users from being able to change the remote administration settings for the computer.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoAdminPage' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoAdminPage | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
System]
Name: NoAdminPage
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 5, 1999


Hide the User Profiles Page (Windows 9x/Me)

Hide the User Profiles Page (Windows 9x/Me)
The user profile page controls whether all users share or have separate user profiles, access to this page can be disabled by enabling this setting.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoProfilePage' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoProfilePage | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
System]
Name: NoProfilePage
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 5, 1999


Hide the Device Manager Page (Windows 9x/Me)

Hide the Device Manager Page (Windows 9x/Me)
This setting controls whether the Device Manager, under Control Panel / System is visible.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoDevMgrPage' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoDevMgrPage | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
System]
Name: NoDevMgrPage
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 5, 1999


Hide the Hardware Profiles Page (Windows 9x/Me)

Hide the Hardware Profiles Page (Windows 9x/Me)
This setting when enabled hides the Hardware Profiles page from the System icon on the Control Panel.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoConfigPage' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoConfigPage | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
System]
Name: NoConfigPage
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 5, 1999


Hide the File System Button (Windows 9x/Me)

Hide the File System Button (Windows 9x/Me)
This option hides the File System button from the System icon on the Control Panel.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoFileSysPage' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoFileSysPage | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
System]
Name: NoFileSysPage
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 5, 1999


Hide the Virtual Memory Button (Windows 9x/Me)

Hide the Virtual Memory Button (Windows 9x/Me)
This option hides the Virtual Memory button from the System icon on the Control Panel.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoVirtMemPage' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoVirtMemPage | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
System]
Name: NoVirtMemPage
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 5, 1999


Hide the File and Printer Sharing Controls (Windows 9x/Me)

Hide the File and Printer Sharing Controls (Windows 9x/Me)
Enabling this options hides the file and printer sharing controls, stopping users from disabling or creating new file or printer shares.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoFileSharingControl' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoFileSharingControl | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Net... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Network]
Name: NoFileSharingControl
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 5, 1999


Disable Registry Editing Tools (All Versions)

Disable Registry Editing Tools (All Versions)
This setting disables the ability to run the registry editing tools Regedit.exe or Regedt32.exe interactively.

Warning: Be careful with this setting because once you enter this key into the registry you will not be able to use regedit to undo the command. So think wisely before using this modification so you don't lock yourself of the registry.

Open your registry and find the key below.

Create a new DWORD value named 'DisableRegistryTools' and set the value to equal '1' to disable registry editing functions.

If you have inadvertently locked yourself out of your registry you can use the following file to unlock it. Please don't abuse this by trying to circumvent system administrator policies.

Download: unlock.reg

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DisableRegistryTools | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
System]
Name: DisableRegistryTools
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: November 28, 2000


Hide the Internet Explorer Icon (All Versions)

Hide the Internet Explorer Icon (All Versions)
This option hides the Internet Explorer icon from the Windows desktop.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoInternetIcon' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoInternetIcon | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoInternetIcon
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 5, 1999


Change the Default Name and Company Information (All Versions)

Change the Default Name and Company Information (All Versions)
When you install a new application, using MS Setup, a default Name and Company are shown, these values can be changed when the details have changed or are incorrect.

Open your registry and find the key below.

Modify the two values named 'DefName' and 'DefCompany', and change the values to your current Name and Company respectively.

The next time you install a program these new values will be used as the defaults instead.

Note: This will not affect the registered names of existing applications, it only affects new installations.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DefName | REG_SZ | "Joan Bloggs" | |
| |  | DefCompany | REG_SZ | "ACME, Inc." | |
-
| HKEY_CURRENT_USER\Software\Microsoft\MS Setup (ACME)\User Info |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\MS Setup (ACME)\User Info]
Name: DefName, DefCompany
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 5, 1999


Changing the Default Printer Spool Directory (Windows NT)

Changing the Default Printer Spool Directory (Windows NT)
Windows uses the hard drive to store information before sending it to a printer. If the system is acting as a print server it is possible that the default location may cause insufficient disk space.

Create a new directory to act as the Printer spool directory.

Open your registry and find the key below..

Change the value of 'DefaultSpoolDirectory" to equal the full path of the newly created directory.

Restart Windows or stop and start the 'Spooler' service.

The default directory is: %SystemRoot%\system32\spool\PRINTERS

Note: To change the spool directory for a specific printer only, find the sub-key under the key below that corresponds to the printer in question. Modify the value of 'SpoolDirectory' to equal the directory you want to use.

Note: If the directory doesn't exist, Windows will use the default.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | DefaultSpoolDirectory | REG_SZ | "D:\SPOOLER" | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Printers |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Printers]
Name: DefaultSpoolDirectory
Type: REG_SZ (String Value)
Value: Full path to printer spool directory

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 6, 1999


Modifying LAN Based Auto-disconnect Time-Out (Windows NT)

Modifying LAN Based Auto-disconnect Time-Out (Windows NT)
Windows NT can be configured to automatically disconnect idle LAN sessions are a set number of minutes.

Open your registry and find the key below.

Modify the value of 'Autodisconnect' to equal the time in minutes before a session is disconnected. If this value doesn't already exist create a new string value.

Restart Windows for the change to take effect.

Note: To disable Autodisconnects set the value to '0xffffffff'.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Autodisconnect | REG_DWORD | 0xffffffff (4294967295) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parame... |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\
Parameters]
Name: Autodisconnect
Type: REG_DWORD (DWORD Value)
Value: 0 to 4,294,967,295 (0xffffffff) in minutes

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 6, 1999


Changing the Behavior of the Dr Watson Utility (Windows NT/2000)

Changing the Behavior of the Dr Watson Utility (Windows NT/2000)
By default whenever an application error occurs in Windows NT, Dr Watson is launched and the debugger started automatically. The extra resources needed for the debugger can sometimes push the system over the edge. It is possible to stop the debugger from launching by changing this setting.

Open your registry and find the key below.

Change the value of 'Auto' to equal '0' to disable the automatic debugger.

Note: To disable Dr. Watson completely simply delete the AeDebug subkey and then to re-enable simple execute the command 'drwtsn32 -i'.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Auto | REG_SZ | "0" | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AeDebug |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AeDebug]
Name: Auto
Type: REG_SZ (String Value)
Value: (0 = message, 1 = debugger & message)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 6, 1999


Changing the Default State of the NUMLOCK Key (Windows NT)

Changing the Default State of the NUMLOCK Key (Windows NT)
The NUMLOCK key is usually only turned on before the user has logged into the computer, this can cause problem for people with portable computers that do not check the status of the NUMLOCK key before typing their password. The default behavior can be changed with this setting.

Open your registry and find the key below.

Change the value of 'InitialKeyboardIndicators' to either '0' for off, or '2' for on.

Note: This change will affect all users but value can also be changed on a user-by-user basis by modifying [HKEY_CURRENT_USER\Control Panel\Keyboard] using the same values.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | InitialKeyboardIndicators | REG_SZ | "2" | |
-
| HKEY_USERS\.DEFAULT\Control Panel\Keyboard |
-

Settings:
Key: [HKEY_USERS\.DEFAULT\Control Panel\Keyboard]
Name: InitialKeyboardIndicators
Type: REG_SZ (String Value)
Value: 0 = NUMLOCK off, 2 = NUMLOCK on

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 6, 1999


Removing Windows NT Devices and Services (Windows NT/2000)

Removing Windows NT Devices and Services (Windows NT/2000)
Sometimes it is possible to get orphaned services remaining in the registry. These services can be remove be modifying this key.

Open your registry and find the key below.

Under this key are subkeys representing each device and service installed on the machine.

To remove, first stop the service through Control Panel / Services, then locate the subkey corresponding to device or service and delete it.

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services]

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 6, 1999


Changing the Startup Mode of a Service (Windows NT/2000)

Changing the Startup Mode of a Service (Windows NT/2000)
All services have a setting controlling how they are started either manually, automatically or disabled. This setting can be changed through the registry.

Open your registry and file the key below.

Listed under this key are subkeys representing the devices and services on the system.

Open the subkey corresponding to the service you wish to change, and modify the value of 'Start' to equal either "2" (for automatic), "3" (for manual) or "4" (for disabled)

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Start | REG_DWORD | 0x00000002 (2) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services]
Name: Start
Type: REG_DWORD (DWORD Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 6, 1999


Automatically Close Non-Responding Applications (Windows NT/2000)

Automatically Close Non-Responding Applications (Windows NT/2000)
Occasionally when Windows NT shuts down, a task will return as 'Not Responding' and you are given the option to end the task. This tweak automatically closes any non-responding applications.

Open your registry and find the key below.

Modify the value of 'AutoEndTasks' to equal '1' to automatically end tasks or '0' to prompt for action.

The default time-out before ending the task is defined by the value of 'WaitToKillAppTimeout' located in the same key, this value is in milliseconds (default = 20000 i.e. 20 seconds). You can therefore additionally change this value to speed the process up.

Note: This change will affect all users but value can also be changed on a user-by-user basis by modifying [HKEY_CURRENT_USER\Control Panel\Desktop] and the same values.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AutoEndTasks | REG_SZ | "1" | |
| |  | WaitToKillAppTimeout | REG_SZ | "10000" | |
-
| HKEY_USERS\.DEFAULT\Control Panel\Desktop |
-

Settings:
Key: [HKEY_USERS\.DEFAULT\Control Panel\Desktop]
Name: AutoEndTasks
Type: REG_SZ (String Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 6, 1999


Removing or Adding Items to Your Persistent Connections List (Windows NT)

Removing or Adding Items to Your Persistent Connections List (Windows NT)
Windows stores the names of previously mapped drives in the registry, this can be a security threat if vulnerable hidden shares are listed. An advantage is that this key can also be used to set default items for list, if for example inexperienced users were required to map common drives, your could store them here.

Open your registry and find the key below.

Listed under this key are all the shares Windows has stored for the current user, simply delete the entries you don't want to store or add new ones by adding a new string value, and name it by incrementing the alpha values already in the list. Set the data to equal the drive share you wish to add.

Note: This change affects only the current user, to change the defaults for all users modify [KEY_USERS\.DEFAULT] key instead.

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Network\
Persistent Connections]

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 6, 1999


Control the Default Virtual Machine Option (Windows NT/2000)

Control the Default Virtual Machine Option (Windows NT/2000)
When starting a 16bit application you have the option of running each in a separate virtual machine (VDM). With this setting you can change the default value.

Having a separate virtual machine, has the advantage that if the applications crashes only that one application is affected, on the down side it takes more system resources.

Open your registry and find the key and value below, if they don't already exist create them.

Change the value of 'DefaultSeparateVDM' to either 'Yes' or 'No'.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | DefaultSeparateVDM | REG_SZ | "Yes" | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\WOW |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\WOW]
Name: DefaultSeparateVDM
Type: REG_SZ (String Value)
Value: 'Yes' or 'No'

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 7, 1999


Configuring Unimodem Support (Windows NT)

Configuring Unimodem Support (Windows NT)
Windows NT 4.0 and greater support Unimodem modems, if your device is not supported though Windows can be configured to use the MODEM.INF file instead.

Open your registry and find the key below.

Create a new DWORD value named "EnableUnimodem" and set it to equal to '0' for disabled.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | EnableUnimodem | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\RAS\PROTOCOLS |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\RAS\PROTOCOLS]
Name: EnableUnimodem
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 7, 1999


Securing Network Access to CD-ROM Drives (Windows NT)

Securing Network Access to CD-ROM Drives (Windows NT)
This setting determines whether data in the CD-ROM drive is accessible to other users. This value entry satisfies, in part, the C2 security requirement that you must be able to secure removable media.

Because the CD-ROM drive is a volume, by default, it is shared as an administrative share on the network. If the value of this entry is 1, the CD-ROM drive is allocated to the user as part of the interactive logon process and, therefore, only the current user can access it. This prevents administrators and remote users (and even the same user at a different workstation) from accessing the drive while the current user is logged on to the computer. The drive is shared again when the current user logs off the computer.

Value Meanings:

  • '0' = Compact discs in the CD-ROM drive can be accessed by all administrators in the domain.

  • '1' = Only the user logged on locally can access data on the compact discs in the CD-ROM drive.
    •

    Registry Editor Example
    | | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AllocateCDRoms | REG_SZ | "1" | |
    -
    | HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
    -

    Settings:
    Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
    Name: AllocateCDRoms
    Type: REG_SZ (String Value)
    Value: (0 = enabled, 1 = disabled)

    Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

    Last Modified: January 7, 1999


Securing Network Access to Floppy Drives (Windows NT)

Securing Network Access to Floppy Drives (Windows NT)
This setting determines whether data in the floppy disk drive is accessible to other users. This value entry satisfies, in part, the C2 security requirement that you must be able to secure removable media.

Because the floppy disk drive is a volume, by default it is shared as an administrative share on the network. If the value of this entry is 1, the floppy disk drive is allocated to the user as part of the interactive logon process and, therefore, only the current user can access it. This prevents administrators and remote users (and even the same user at a different workstation) from accessing the drive while the current user is logged on. The drive is shared again when the current user logs off.

Value Meanings:

  • '0' = Floppy disks in the floppy disk drive can be accessed by all administrators in the domain.

  • '1' = Only the user logged on locally can access data on the floppy disks in the floppy disk drive.
    •

    Registry Editor Example
    | | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AllocateFloppies | REG_SZ | "1" | |
    -
    | HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
    -

    Settings:
    Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
    Name: AllocateFloppies
    Type: REG_SZ (String Value)
    Value: (0 = enabled, 1 = disabled)

    Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

    Last Modified: January 7, 1999


Control the Automatic Restarting of the Shell (Windows NT/2000)

Control the Automatic Restarting of the Shell (Windows NT/2000)
By default if the Windows user interface or one of its components fails, the interface is restarted automatically, the can be changed so that you must restart the interface by logging off and logging on again manually.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'AutoRestartShell' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AutoRestartShell | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: AutoRestartShell
Type: REG_DWORD (DWORD Value)
Value: (0 = disable, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 28, 2001


Delay Occurs When Unlocking Workstation (Windows NT)

Delay Occurs When Unlocking Workstation (Windows NT)
Sometimes a noticeable delay occurs when the logged on user or an administrator attempts to unlock a workstation. This because when you unlock the workstation Windows NT will update the domain list if the cached list's age exceeds two minutes (by default). This age limit can be modified.

Open your registry and find the key below..

Create a new DWORD value, or modify the existing value, named "DcacheMinInterval" and set it to equal the new cache time-out in seconds (decimal).

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DcacheMinInterval | REG_DWORD | 0x000000f0 (240) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: DcacheMinInterval
Type: REG_DWORD (DWORD Value)
Value: 120-86400 (decimal) (expressed in seconds)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 7, 1999


Automatically Use Dial-Up Networking to Logon (Windows NT)

Automatically Use Dial-Up Networking to Logon (Windows NT)
There is an option that is available on the logon dialog box and allows you to dial into your logon server for authentication of your user account, this can be enabled by default.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'RasForce' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | RasForce | REG_SZ | "1" | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: RasForce
Type: REG_SZ (String Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 7, 1999


Suppress the Domain Controller Cannot Be Reached Message (Windows NT/2000)

Suppress the Domain Controller Cannot Be Reached Message (Windows NT/2000)
When Windows is unable to contact a domain controller during a users login a popup error message is displayed, this message can be removed by modifying this setting.

To remove the following message:

A domain controller for your domain could not be contacted. You have been logged on using cached account information. Changes made to your profile since you last logged on may not be available.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, named 'ReportDC' and set it to equal '0' to suppress the message.

Restart Windows for the change to take effect.

Note: This can also be controlled on a system-wide basis by modifying the same value at [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon].

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ReportDC | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: ReportDC
Type: REG_DWORD (DWORD Value)
Value: (0 = message is suppressed, 1 = message is not suppressed)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 13, 2000


Changing the Password Expiry Warning Period (Windows NT)

Changing the Password Expiry Warning Period (Windows NT)
This entry specifies the number of days before a user's password expires that a warning message is displayed.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'PasswordExpiryWarning' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | PasswordExpiryWarning | REG_DWORD | 0x00000007 (7) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: PasswordExpiryWarning
Type: REG_DWORD (DWORD Value)
Value: Number of Days (Default = 14)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 7, 1999


Specify executable files to be run by Winlogon (Windows NT)

Specify executable files to be run by Winlogon (Windows NT)
This setting Specifies executable files to be run by Winlogon in the system context, and can be modified by simply editing the value.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'System' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | System | REG_SZ | "lsass.exe" | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: System
Type: REG_SZ (String Value)
Value: (default = lsass.exe)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 7, 1999


Control Windows Double Buffering Support (Windows 98)

Control Windows Double Buffering Support (Windows 98)
Windows 98 includes double buffering support, some systems may have an incompatibility between the computer's BIOS and the Dblbuff.sys file.

A setting of 1 is a conditional setting that enables double-buffering for controllers that need it (for example, SCSI controllers). A setting of 2 is an unconditional setting that enables double-buffering regardless of whether the controller needs it or not.

Note: that some computers, especially those that use a SCSI hard disk, may require double buffering to work properly.

Settings:
Name: DoubleBuffer
Value: (0 = disabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 7, 1999


Modifying the [Paths] Section of MSDOS.SYS (Windows 9x/Me)

Modifying the [Paths] Section of MSDOS.SYS (Windows 9x/Me)
The [Paths] section lists the locations for other Windows 95 files (such as the registry) and can be modified if files are moved.

The [Paths] section can contain the following settings:

HostWinBootDrv=<Root of Boot Drive>

Default: C
Purpose: Specifies the location for the root of the boot drive.

UninstallDir=<Root of Boot Drive>

Default: C
Purpose: Specifies the location of the W95undo.dat and W95undo.ini files. These files are necessary to uninstall Windows 95.
NOTE: This setting is present only if you back up your system files when you are prompted during Windows 95 Setup.

WinBootDir=<Windows Directory>

Default: Directory specified during Setup (for example, C:\WINDOWS)
Purpose: Lists the location of the necessary files for booting.

WinDir=<Windows Directory>

Default: Directory specified during Setup (for example, C:\WINDOWS)
Purpose: Lists the location of the Windows 95 directory specified during Setup.

Last Modified: January 7, 1999


Forces Your Computer to Boot in Safe Mode (Windows 9x/Me)

Forces Your Computer to Boot in Safe Mode (Windows 9x/Me)
This setting when enabled forces your computer to always boot in Safe Mode.

Add a new value of 'BootSafe=' to MSDOS.SYS.

Set the value to '1' to always boot in Safe mode or '0' to run normally.

Settings:
Name: BootSafe
Value: (1=enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 7, 1999


Suppress Safe Mode Warning Message (Windows 9x/Me)

Suppress Safe Mode Warning Message (Windows 9x/Me)
Enabling this setting suppresses the safe mode warning message when booting up, and bypasses the Startup menu.

Add a new value of 'BootWarn=' to MSDOS.SYS.

Set the value to '1' to ignore the Safe mode warning or '0' to run normally.

Settings:
Name: BootWarn
Value: (1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 7, 1999


Load Compression Driver into Low Memory (Windows 9x/Me)

Load Compression Driver into Low Memory (Windows 9x/Me)
This setting controls whether double space (or drive space) is loaded into high memory. If you are having compatibility problems with software that makes assumptions about the available memory try changing this setting.

A setting of 0 does not let Windows 95 load COMMAND.COM or DRVSPACE.BIN/DBLSPACE.BIN at the top of 640K.

Change the attributes for MSDOS.SYS so it is not 'Read Only', MSDOS.SYS is found in the root directory of your C:\ drive. Open the file using Notepad or another text editor (not Microsoft Word or any word processor).

Add a new line with the following text 'LoadTop=0' to load the compression driver into low memory.

Changes will take place on the next reboot.

Settings:
Name: LoadTop
Value: (0 = load in low memory)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 7, 1999


Control Long Filename Support (All Versions)

Control Long Filename Support (All Versions)
Windows 9x and NT introduced the use of long filenames on existing FAT partitions. Some legacy software maybe incompatible with this new file system design, and may require the use of 8.3 filenames. By enabling this setting you can turn off long filename support.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'Win31FileSystem' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Win31FileSystem | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem]
Name: Win31FileSystem
Type: REG_DWORD (DWORD Value)
Value: (0 = long file names, 1 = 8.3 filenames)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 12, 1999


Configure Protected-Mode Hard Disk Interrupt Handling (Windows 9x/Me)

Configure Protected-Mode Hard Disk Interrupt Handling (Windows 9x/Me)
This switch allows Windows to terminate interrupts from the hard disk controller, bypassing the ROM routine that handles these interrupts. Some hard drives might require that this setting be disabled in order for interrupts to be processed correctly. If this setting is disabled, the ROM routine handles the interrupts.

Open your registry and find the key below.

Create a new Binary value, or modify the existing value called 'VirtualHDIRQ' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | VirtualHDIRQ | REG_BINARY | 00 00 00 00 | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem]
Name: VirtualHDIRQ
Type: REG_BINARY (Binary Value)
Value: (00 00 00 00 = disabled, 01 00 00 00 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 12, 1999


Configure New File Sharing and Locking Semantics (Windows 9x/Me)

Configure New File Sharing and Locking Semantics (Windows 9x/Me)
This setting controls the file locking mechanisms of Windows 9x, disable this setting only if you are currently experiencing problems with specific applications.

Open your registry and find the key below.

Create a new Binary value, or modify the existing value called 'SoftCompatMode' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SoftCompatMode | REG_BINARY | 00 00 00 00 | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem]
Name: SoftCompatMode
Type: REG_BINARY (Binary Value)
Value: (00 00 00 00 = disabled, 01 00 00 00 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 12, 1999


Preserving Long Filenames for Legacy Applications (Windows 9x/Me)

Preserving Long Filenames for Legacy Applications (Windows 9x/Me)
Windows normally preserves the long filenames of files accessed by legacy applications. This functionality can be disabled if you are experiencing LFN errors with a legacy application.

Open your registry and find the key below.

Create a new Binary value, or modify the existing value called 'PreserveLongNames' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | PreserveLongNames | REG_BINARY | 00 00 00 00 | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem]
Name: PreserveLongNames
Type: REG_BINARY (Binary Value)
Value: (00 00 00 00 = disabled, ff ff ff ff = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 12, 1999


Configure 32-bit Protected Mode IO Drivers (Windows 9x/Me)

Configure 32-bit Protected Mode IO Drivers (Windows 9x/Me)
This setting controls whether fixed disk access is performed through Windows protected mode drivers or through real mode drivers and BIOS routines. If you are experiencing drive IO errors enabling this setting may be a possible solution.

Open your registry and find the key below.

Create a new Binary value, or modify the existing value called 'ForceRMIO' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ForceRMIO | REG_BINARY | 00 00 00 00 | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem]
Name: ForceRMIO
Type: REG_BINARY (Binary Value)
Value: (00 00 00 00 = protected mode, 01 00 00 00 = real mode)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 1, 2000


Control Write Behind Caching (Windows 9x/Me)

Control Write Behind Caching (Windows 9x/Me)
For increased performance write behind caching is used to write data to the fixed disks, this means that in the event of a system failure there is a possibility that data would not be completely written to the disk. If you have a system critical application you can disable this functionality to be sure that data is written directly to the disk bypassing the cache.

Open your registry and find the key below.

Create a new Binary value, or modify the existing value called 'DriveWriteBehind' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DriveWriteBehind | REG_BINARY | 00 00 00 00 | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem]
Name: DriveWriteBehind
Type: REG_BINARY (Binary Value)
Value: (00 00 00 00 = protected mode, 01 00 00 00 = real mode)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: November 28, 2000


Use Asynchronous or Synchronous Buffer Commits (Windows 9x/Me)

Use Asynchronous or Synchronous Buffer Commits (Windows 9x/Me)
This setting changes function calls to the File-Commit API to return immediately back without checking the data has been correctly written to the disk drive. By default Windows uses synchronous buffer commits, this setting allows you to enable asynchronous as an alternative for applications that may need this functionality.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'AsyncFileCommit' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AsyncFileCommit | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem]
Name: AsyncFileCommit
Type: REG_DWORD (DWORD Value)
Value: (0 = sync, 1 = async)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 12, 1999


Add Your Own Tips (All Versions)

Add Your Own Tips (All Versions)
Are you sick of seeing the same tips again and again when you first logon to Windows? Now you can change them to whatever you want, whether it's quotes, jokes or a to-do list, anything is possible.

Open your registry and find the key below.

Create a new string valued named by incrementing the existing value names and set it to the required tip text.

To remove, highlight and delete the value.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Z | REG_SZ | "Don't forget to visit ..." | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Tips |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\
Tips]
Type: REG_SZ (String Value)
Value: Tip Text

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: November 28, 2000


'Failure Writing to the System Registry...' Error Message (Windows 95)

'Failure Writing to the System Registry...' Error Message (Windows 95)
When you run a setup program that was created using the Application Setup Wizard, you may receive an error message indicating the registry may be corrupt or you do not have the required permissions to write to the registry.

As the error message indicates, the problem may be due to a corrupt registry or incorrect permissions to write to the registry. In addition, the problem occurs on computers running Windows 95 when the Setup program tries to add an entry to a registry key and the key will exceed 64K in size as a result. Registry keys are limited to 64K in Windows 95.

When the problem occurs on a Windows 95 computer, it usually happens when Setup tries to add entries to the key below.

Try running the RegClean utility provided by Microsoft, a link can be found at our downloads page. Alternatively have a look at the Microsoft Knowledge Base article referenced below.

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SharedDLLs]

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: November 28, 2000


Enable Live Scrolling in Microsoft Word (All Versions)

Enable Live Scrolling in Microsoft Word (All Versions)
Normally when you move through a Word document using the scroll bar the page doesn't update until you release the mouse button. With this tweak the document location is updated as you move.

Open your registry and find the key below.

Create a new string value, or modify the existing value, named 'LiveScrolling' and set it to equal '1' for live scrolling enabled or '0' for disabled.

Close the registry and restart Word.

Note: This also works in Word 2000 by selecting the Office\9.0 registry key.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | LiveScrolling | REG_SZ | "1" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Office\8.0\Word\Options |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Office\8.0\Word\Options]
Name: LiveScrolling
Type: REG_SZ (String Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 20, 2001


Automatically Reboot on the 'Blue Screen of Death' (Windows NT/2000)

Automatically Reboot on the 'Blue Screen of Death' (Windows NT/2000)
Windows NT workstation will usually freeze when getting a dreaded 'Blue Screen of Death' (BSOD). Changing this setting will force Windows NT to automatically reboot when it crashes instead.

Open your registry and find the key below.

Change the value of 'AutoReboot' to equal '1' for automatic reboot, or '0' for disabled.

Restart Windows for the change to take effect.

Note: This function can also be enabled from 'Control Panel -> System -> Startup/Shutdown -> Automatically Reboot'. This feature is enabled by default on NT server, and disabled on NT Workstation.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AutoReboot | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CrashControl |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CrashControl]
Name: AutoReboot
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 4, 2000


Shortcuts Created Resolve to UNC Paths (Windows NT/2000)

Shortcuts Created Resolve to UNC Paths (Windows NT/2000)
A user may click a program's shortcut and be prompted to Enter Network Password, yet the properties of the shortcut indicate a relative path to the local computer.

Shortcuts created on a computer automatically embed a UNC (Universal Naming Convention) path such as \\admin$ in the .lnk file. The default shortcut resolution method is to resolve the link to the original location of the file (the "absolute" path) before looking at another path of where that file may or may not exist (the secondary or "relative" path). In this case, the UNC path to the original file is always reachable, which prevents the link from being resolved by means of a local path. As a result, the user who is trying to run the shortcut is prompted for the administrator's password of the computer that created the link.

Open your registry and find the key below.

Create a new DWORD value called 'LinkResolveIgnoreLinkInfo' and set the value to '1' for enabled.

Exit the registry editor and reboot for the changes to take effect.

Note: To apply this change on a per computer basis modify the same key under the HKEY_LOCAL_MACHINE hive.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | LinkResolveIgnoreLinkInfo | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: LinkResolveIgnoreLinkInfo
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 20, 1999


Order the Menu (Windows 98)

Order the Menu (Windows 98)
It's easy to reorder the items on any Windows 98 cascading menu by holding down the mouse button and drag a highlighted file or folder up or down the list. With this tip it's even easier to force the entire list into permanent alphabetical order.

Open your registry and find the key below.

Highlight the Order entry in the Contents pane, then delete it. The list will be in alphabetical order the next time Windows opens.

You'll find a similar Menu subkey under each of the &Program subkeys Accessories, Games and so on). Follow the same procedure to alphabetize those lists, too.

With Windows 98 or 2000 it's even easier simply right-click on the menu you want to re-order and select 'Sort by Name'.

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\
MenuOrder\Start Menu\&Programs\Menu]

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: July 3, 2000


Restart Windows Quickly without Rebooting (Windows 9x/Me)

Restart Windows Quickly without Rebooting (Windows 9x/Me)
Tired of waiting for Windows to restart? Sometimes it can take ages to completely shutdown, then your have to wait for the PC to reset as well. Try this tip to speed up your computer's shutdown procedure.

You can reduce the time it takes for Windows to restart by holding down the SHIFT key while you select 'Shutdown'. This will restart Windows only, and not your whole computer.

Last Modified: February 2, 1999


Speed Up ISP Logon Time (Windows 9x/Me)

Speed Up ISP Logon Time (Windows 9x/Me)
On some systems it can take a long time to connect to the Internet, you can decrease the time required to connect to your ISP by trying these simple steps.

Open the Dial-Up Networking folder, right click on the icon for your ISP and select 'Properties'.

Chose the 'Server Types' tab, and then under Advanced Options uncheck the 'Log on to network' box, and make sure that 'Enabled Software Compression' is checked. From under Allowed Network Protocols uncheck 'NetBEUI' and 'IPX/SPX Compatible'.

Next time you connect to your ISP, the connection should be a little faster.

Last Modified: February 20, 2001


Faster Modem Dialing (Windows 9x/Me)

Faster Modem Dialing (Windows 9x/Me)
Waiting to long for your modem to dial? This tip lets you reduce the time it takes your modem to dial, and increase your overall modem connection speed.

Open Control Panel -> Modems, select your modem and click on Properties. Select the Connection tab, and click on 'Advanced'.

In the text box that is labeled 'Extra Settings' at the following text (without the quotation marks) 'S11=40'.

The number specified after S11= (in this case 40) is the time for each tone in milliseconds. Lower numbers equals faster dialing. If your having problems connecting try increasing the number until it works.

Note: This may not work as planned in some countries and with some modems.

Last Modified: February 20, 2001


Re-Initialize Your Registry Without Rebooting (All Versions)

Re-Initialize Your Registry Without Rebooting (All Versions)
Some registry changes require you to restart Windows before they are enabled. This tip lets you re-initialize your registry and refresh your desktop without having to leave Windows.

Save your work before attempting this tip!

Press CTRL + ALT + DELETE, to bring up the Windows task list. Highlight 'Explorer' and click on 'End Task', if the Shutdown screen is shown, click 'Cancel'. After a few seconds an error message will popup, click on 'End Task' and the Windows explorer will be reloaded along with any new registry settings.

For Windows NT or 2000, press Ctrl + Alt + Delete and select "Task Manager". Choose the "Processes" tab and locate the "explorer.exe" process, highlight it and click "End Process". Select 'File -> New Task', then enter 'explorer' and click OK.

Hint: For other ways to launch the task manager have a look at this article.

Last Modified: January 20, 2001


Make the Columns Fit (All Versions)

Make the Columns Fit (All Versions)
Want to quickly see all the column in explorer without having to resize them individually? This tip does it for you.

Simple press CTRL + + (press the plus button twice on the numeric keypad), this will adjust the column width so you can view the info in each column.

This tip may also work with programs based on the Windows explorer interface. Try it out!

Note: You may have to expand the window borders to see all the columns.

Last Modified: February 2, 1999


Close Parent Windows Automatically (All Versions)

Close Parent Windows Automatically (All Versions)
Have you ever had a screen full of explorer windows on your desktop after digging through heaps of directories? This tip lets you close the current window and all it's parent windows in one easy step.

To close a folder and all its open parent folders, simply press the SHIFT key while clicking on its Close box or alternatively press ALT + SHIFT + F4.

Last Modified: February 2, 1999


Expand and Contract Folders With Ease (All Versions)

Expand and Contract Folders With Ease (All Versions)
It can be a time-consuming process to expand a folder by clicking on the (+) for each and every sub-directory. This tip lets you expand and contract them all at once, with one keystroke.

While in any application that is based on the explorer interface (e.g. Windows Explorer) simple highlight the parent folder you wish to expand and press '*' (asterix on the keypad) and all the sub folders will expand out, press '-' (minus on the keypad) and they'll all contract back again.

Hint: This works in regedit.exe as well!

Last Modified: February 2, 1999


Reduce the Time the Startup List is Shown on Boot (Windows NT/2000)

Reduce the Time the Startup List is Shown on Boot (Windows NT/2000)
30 Seconds is a long time when you're waiting for Windows NT to boot. With this tip you can decrease the time the system waits for a selection, or remove the time-out all together.

The simple way to modify the time-out is to open Control Panel > System. Then click on the 'Startup/Shutdown' tab and change the value of 'Show list for'. Any value between 1-999 is valid, if you choose '0' the system will wait forever for you to make a selection.

If you would like to boot Windows without waiting for the time-out the process is slightly more difficult.

Using Windows explorer find the file called BOOT.INI on your system drive. Make the file not read-only, by right clicking on it and choosing Properties, and then under Attributes, uncheck 'Read-only' and click OK. Now double-click on BOOT.INI, and it should open in Notepad.

There is a line under the [boot loader] section labeled timeout=. The number after the '=' sign is the time in seconds Windows will wait for a selection. To make Windows boot instantly change this value to '-1' (i.e. timeout=-1). Save the file, and the next time you reboot Windows NT won't wait for a selection and just load the default OS choice.

Last Modified: November 28, 2000


Clear the Page File at System Shutdown (Windows NT)

Clear the Page File at System Shutdown (Windows NT)
Windows normally does not clear or recreate the page file. On a heavy used system this can be both a security threat and performance drop. Enabling this setting will cause Windows to clear the page file whenever the system is shutdown.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'ClearPageFileAtShutdown' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ClearPageFileAtShutdown | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memo... |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\
Memory Management]
Name: ClearPageFileAtShutdown
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 2, 1999


Change Directories Without Typing the Whole Name (Windows NT/2000)

Change Directories Without Typing the Whole Name (Windows NT/2000)
Changing directories at the command prompt can be a hit and miss process when long filenames are involved. This tip let you change directories with ease, not matter how long the directory name.

To change a directory quickly you can use wildcards, for example, to change to the 'C:\Program Files' directory simply type:

cd c:\prog*

Note: This will work in alphabetical order, therefore if you have two directories named 'c:\dir1' and 'c:\dir2' and you type cd dir*, you will be moved to the 'c:\dir1' directory.

Last Modified: February 2, 1999


Launch the Task Manager Quickly (Windows NT/2000)

Launch the Task Manager Quickly (Windows NT/2000)
Launching the Task Manager can sometimes be difficult depending on the situation. Some people didn't know that the Task Manager can actually be launched in at least three different ways to make it easier to use when you need it the most.

First Method:
Press CTRL + ALT + DELETE and click on the 'Task Manager...' button on the Windows NT Security dialog.

Second Method:
Right click on the Windows NT taskbar and chose 'Task Manager...'

Third Method:
Press CTRL + SHIFT + ESC and the Task Manager will be launched instantly.

Last Modified: February 2, 1999


Change the Message Shown on the Logon Box (Windows NT)

Change the Message Shown on the Logon Box (Windows NT)
You can personalize (or legalize) the message displayed on the logon box above the user name and password.

Simply create a new string value named 'LogonPrompt' in the key below, and enter the text you want to display. The default message is: 'Enter a user name and password that is valid for this system.'

This feature can be used in conjunction with the Legal Notice Dialog Box Before Logon tweak.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | LogonPrompt | REG_SZ | "Enter your name and..." | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: LogonPrompt
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 20, 2001


Enable Plug-and-Play on Windows NT (Windows NT 4.0)

Enable Plug-and-Play on Windows NT (Windows NT 4.0)
Windows NT4 doesn't support plug-and-play devices out of the box, but it can be configured to a least partially support some PnP features with a little help.

Find the directory on your Windows NT CD-ROM called \Drvlib\Pnpisa, then open the directory for your system type (standard PC's are x86 or i386). In this directory are two files. To install plug-and-play support, right-click on the file called 'Pnpisa.inf' and select install. You'll need to restart Windows for the changes to take effect.

Note: Windows NT should now detect PnP devices, but you may have to configure the settings manually.

Last Modified: February 2, 1999


Secure Network Access to the Windows NT Registry (Windows NT)

Secure Network Access to the Windows NT Registry (Windows NT)
Windows supports accessing a remote registry via the Registry Editor across a network. The default setting allows for users to connected and modify data within the remote registry.

By creating the new key listed below, or modifying the existing key if it already exits, it is possible to control access to the registry remotely.

Use REGEDT32 to modify the permissions on the key below to suit your security requirements, the permissions on this key represent the remote access permissions to the registry.

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurePipeServers\
winreg]

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 2, 1999


Unable to Connect More Than 10 Clients (Windows NT)

Unable to Connect More Than 10 Clients (Windows NT)
If you have a retail version of Windows NT server, and you are still unable to connect more the 10 users concurrently, then have a look at this tip.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'Users' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Users | REG_DWORD | 0xffffffff (4294967295) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parame... |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\
Parameters]
Name: Users
Type: REG_DWORD (DWORD Value)
Value: (0xffffffff = unlimited)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 2, 1999


Power the Computer Off After Shutdown (Windows NT/2000)

Power the Computer Off After Shutdown (Windows NT/2000)
Enabling this setting will cause Windows to automatically power down your computer once it has finished the shutdown process.

Note: This feature must be supported by the computer's BIOS.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | PowerdownAfterShutdown | REG_SZ | "1" | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: PowerdownAfterShutdown
Type: REG_SZ (String Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 2, 1999


Addition of New LAN Interface in RRAS Causes Event Message (Windows NT)

Addition of New LAN Interface in RRAS Causes Event Message (Windows NT)
When you install an additional network interface card (NIC) and the Routing and Remote Access Service (RRAS) is already installed, you receive an error 20101 in the System Log in Event Viewer.

This event will be logged every time RRAS starts yet does not prevent RRAS from starting properly, nor does it cause any loss of functionality within RRAS.

For each value of (x) in the key below, verify the value of 'Enabled' is equal to '1' or '0', the default is '1' Enabled.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Enabled | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Router\Interfaces\(x) |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Router\Interfaces\
(x)]
Name: Enabled
Type: REG_DWORD (DWORD Value)
Value: (0 = false, 1 = true)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 2, 1999


Avoid Accidental Registry Imports (All Versions)

Avoid Accidental Registry Imports (All Versions)
By default, if you double-click on a file with a '.REG' extension the file will be imported into the system registry. You can change the default so it opens the file for editing instead.

From either Explorer or My Computer click on View -> Options, then the 'File Types' tab. Scroll down the list of registered file type until you find 'Registration Entries', highlight it and click 'Edit'. Listed in the 'Actions' box should be three actions: Edit, Merge and Print. Highlight 'Edit' and click 'Set Default', Edit should become Bold.

Next time you double-click on a .REG file, notepad should open instead. You can still import a file by simply right-click on it and select 'Merge'.

Last Modified: February 2, 1999


Change the Startup and Shutdown Screens (Windows 9x/Me)

Change the Startup and Shutdown Screens (Windows 9x/Me)
Microsoft has a knack for making the Windows startup and shutdown screens pretty boring. Luckily it's relatively easy to replace these images with pictures of your own.

There are three files which makeup the startup and shutdown screens, they are:

  • LOGO.SYS - The startup screen, usually located in your C:\ directory.
  • LOGOW.SYS - The 'Please wait...' screen, usually located in your c:\windows directory.
  • LOGOS.SYS - The 'It's now safe to turn off your computer.' screen, usually located in your c:\windows directory.

    • These files are standard 256 color Windows bitmap files with dimensions of 320(w) x 400(h). You can use basically any image editing program to change them (as long as it supports BMP files).

    Warning: Before getting started make sure to take a backup copy of all three files (LOGO.SYS may or may not already exist).

    1. Copy LOGOW.SYS and LOGOS.SYS to a temporary folder, and rename their extensions to .BMP

    2. Using your favorite graphics editor, open the files and modify them to your liking.

    3. Once your finished, save the files, change their extensions back to .SYS, and copy them back over the original files in the Windows directory (which you've already backed-up) and you're done.

    Alternatively you can create three new BMP files for each screen, just make sure that the proportions of 320(w) x 400(h) are maintained. The file once finished should be 129,078 bytes.

    Last Modified: February 2, 1999


Changing LAN Manager Authentication on Windows NT (Windows NT)

Changing LAN Manager Authentication on Windows NT (Windows NT)
Windows NT supports two kinds of challenge/response authentication: LanManager (LM) and Windows NT (NTLM). LM authentication is not as strong as Windows NT authentication so some customers may want to disable its use, because an attacker sniffing the network traffic could possibly attack the weaker protocol.

The implementation of the NTLM Security Service Provider (SSP) in Server Pack 4 has been enhanced to allow clients to control which variants of NTLM are used, and to allow servers to control which variants they will accept.

To change the type of authentication to be used modify the key below with the following values:

Level 0 - Send LM response and NTLM response; never use NTLMv2 session security
Level 1 - Use NTLMv2 session security if negotiated
Level 2 - Send NTLM response only
Level 3 - Send NTLMv2 response only
Level 4 - DC refuses LM responses
Level 5 - DC refuses LM and NTLM responses (accepts only NTLMv2)

Note: Currently only Windows NT 4.0 (SP4 and greater) support NTLMv2, before making any changes to this key please read the Microsoft Knowledge base article below.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | LMCompatibilityLevel | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa]
Name: LMCompatibilityLevel
Type: REG_DWORD (DWORD Value)
Value: 0 (default) to 5 as defined above

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 2, 1999


Add Command Prompt Here to Every Folder (All Versions)

Add Command Prompt Here to Every Folder (All Versions)
If you still use the DOS prompt regularly, then this tip is for you. It creates a new right-click option to open a command prompt window at the directory you are currently working from.

Open your registry and find the key below.

Create a new sub key called 'CommandPrompt' as in [HKEY_CLASSES_ROOT\Directory\shell\CommandPrompt]. Change the value of '(Default)' within the key to equal the text you would like on the right-click menu, for example 'Command Prompt Here'.

Create another new sub-key under the key created above, name this subkey 'command' as in: [HKEY_CLASSES_ROOT\Directory\shell\CommandPrompt\command]. Change the value of '(default)' within this key depending on your operating system to equal either:

Windows 9x
command.com /k cd "%1"

or

Windows NT
cmd.exe /k cd "%1"

Now right-click on a folder and the new option of 'Command Prompt Here' should be available.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | "command.com /k cd "%1"" | |
-
| HKEY_CLASSES_ROOT\Directory\shell |
-

Settings:
Key: [HKEY_CLASSES_ROOT\Directory\shell]
Name: (Default)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 23, 1999


Modifying the Internet Explorer Partial Address Feature (All Versions)

Modifying the Internet Explorer Partial Address Feature (All Versions)
The Internet Explorer partial address feature, scans common domains for a match to a keyword entered in the Address bar. The feature is limited by default to searching only .COM, .EDU and .ORG domains. This tip allows you to add new domains and modify their priorities.

The values listed under the key below control which domains are auto searched for matches to the keyword entered in the Address bar.

To add a new domain simply create a new string value and name it a sequential number (e.g. '7'). Set the data of the new value to equal the domain you want to search, for example to also search .DE domains add a new value of 'www.%s.de' (%s represents the keyword).

To change their priorities, simply rename the values with sequential numbers where '1' is the site to be checked first.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | 1 | REG_SZ | "www.%s.de" | |
| |  | 2 | REG_SZ | "www.%s.com" | |
| |  | 3 | REG_SZ | "%s.de" | |
| |  | 4 | REG_SZ | "%s.com" | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\UrlTemplate |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\UrlTemplate]
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 7, 1999


Change the Size of Desktop Icons (All Versions)

Change the Size of Desktop Icons (All Versions)
Are your icons too small? Or too big? This setting will let you resize them to suit your desktop preference.

Open your registry and find the key below.

Create a new value named 'Shell Icon Size' and set the value, or modify the existing value, to equal the size of your icons in pixels. Smaller values = smaller icons!

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Shell Icon Size | REG_SZ | "16" | |
-
| HKEY_CURRENT_USER\Control Panel\Desktop\WindowMetrics |
-

Settings:
Key: [HKEY_CURRENT_USER\Control Panel\Desktop\WindowMetrics]
Name: Shell Icon Size
Type: REG_SZ (String Value)
Value: Size in Pixels (Default = 32)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 8, 1999


Disable the Lock Workstation Button (Windows NT)

Disable the Lock Workstation Button (Windows NT)
Add this setting to the registry to stop unauthorized users from locking machines from the Windows NT Security dialog box.

Note: This functionality requires Windows NT Service Pack 4 or higher.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DisableLockWorkstation | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
System]
Name: DisableLockWorkstation
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 9, 1999


Disable the Change Password Button (Windows NT)

Disable the Change Password Button (Windows NT)
This setting disables the 'Change Password' button on the Windows NT Security dialog box. Enabling this setting stops casual users from being able to change the password.

Note: This functionality requires Windows NT Service Pack 4 or higher.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DisableChangePassword | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
System]
Name: DisableChangePassword
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 9, 1999


Optimize Windows TCP/IP Connection Retransmissions (Windows NT/2000)

Optimize Windows TCP/IP Connection Retransmissions (Windows NT/2000)
This parameter determines the number of times TCP will retransmit a connect request (SYN) before aborting the attempt. The retransmission timeout is doubled with each successive retransmission in a given connect attempt.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'TcpMaxConnectRetransmissions' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | TcpMaxConnectRetrans... | REG_DWORD | 0x00000003 (3) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]
Name: TcpMaxConnectRetransmissions
Type: REG_DWORD (DWORD Value)
Value: 0 - 0xFFFFFFFF (Default = 3)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 20, 2001


Optimize Windows TCP/IP Data Retransmissions (Windows NT/2000)

Optimize Windows TCP/IP Data Retransmissions (Windows NT/2000)
This parameter controls the number of times TCP will retransmit an individual data segment (not connection request segments) before aborting the connection.

The retransmission timeout is doubled with each successive retransmission on a connection. It is reset when responses resume. The base timeout value is dynamically determined by the measured round-trip time on the connection.

Note: The Windows NT/2000 TCP/IP implementation is largely self tuning. Adjusting registry parameters may adversely affect system performance.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | TcpMaxDataRetransmissions | REG_DWORD | 0x00000006 (6) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]
Name: TcpMaxDataRetransmissions
Type: REG_DWORD (DWORD Value)
Value: 0 - 0xFFFFFFFF (default = 5)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 9, 1999


Optimize the Windows TCP/IP Window Size (Windows NT/2000)

Optimize the Windows TCP/IP Window Size (Windows NT/2000)
This parameter determines the maximum TCP receive window size offered by the system. The receive window specifies the number of bytes a sender may transmit without receiving an acknowledgment.

In general, larger receive windows will improve performance over high delay, high bandwidth networks. For greatest efficiency, the receive window should be an even multiple of the TCP Maximum Segment Size (MSS).

Reducing the TCP Window size effectively causes an acknowledgment to be sent to the sender for data received sooner. This will lower the possibility that the sender will time out while waiting for an acknowledgment. However it will also increase the amount of network traffic and cause slower throughput.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | TcpWindowSize | REG_DWORD | 0x00002238 (8760) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]
Name: TcpWindowSize
Type: REG_DWORD (DWORD Value)
Value: 0 - 0xFFFF (default = 8760 for Ethernet)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 9, 1999


Configure the TCP/IP Settings of a Network Adapter (Windows NT/2000)

Configure the TCP/IP Settings of a Network Adapter (Windows NT/2000)
These values control the TCP/IP parameters of the network interface cards. Configurable parameters include IP Address, Subnet Mask and Default Gateway.

Open your registry and find the key below, where {Adapter} equals the service name of the installed NIC. For example 3COM 905 NIC's service name is 'El90x'.

Modify the values names (listed below) in binary.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | DefaultGateway | REG_BINARY | 00 | |
| |  | IPAddress | REG_BINARY | 30 2e 30 2e 30 2e 30 00 00 | |
| |  | SubnetMask | REG_BINARY | 30 2e 30 2e 30 2e 30 00 00 | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\{Adapter}\Parameter... |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\{Adapter}\
Parameters\Tcpip]
Name: IPAddress; SubnetMask; DefaultGateway
Type: REG_BINARY (Binary Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 20, 2001


Configure the DHCP Settings of a Network Adapter (Windows NT/2000)

Configure the DHCP Settings of a Network Adapter (Windows NT/2000)
This setting controls whether TCP/IP should use DHCP to automatically assign an IP address, or if it should use the statically defined address.

Open your registry and find the key below, where {Adapter} equals the service name of the installed network card.

Change the value of 'EnableDHCP' to equal either '0' for disabled, or '1' for enabled.

Note: If you change this setting to disabled, make sure you have IP addressing information defined.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | EnableDHCP | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\{Adapter}\Parameter... |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\{Adapter}\
Parameters\Tcpip]
Name: EnableDHCP
Type: REG_DWORD (DWORD Value)
Value: (0 = DHCP Disabled, 1= DHCP Enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 9, 1999


Start Windows Without Prompting for a Password (Windows 9x/Me)

Start Windows Without Prompting for a Password (Windows 9x/Me)
Does Windows prompt you for a password every time you boot up even though you're the only one using the PC? Follow these instructions to make Windows automatically start up without prompting you for a password.

Windows 9x passwords are recorded in a Password List file, these files are stored in the Windows directory and named according to your username, they can be recognized by their .PWL extension.

For example, if your username was 'John' then your password file would probably be 'c:\windows\john.pwl'

To remove the password prompt start by finding the PWL file relating to your username and rename it to *.old (e.g. c:\windows\john.old).

If your running a network, you then need to open 'Control Panel -> Network' and check that the 'Primary Network Logon' is set to 'Windows Logon'.

Now restart Windows and you'll be prompted for a password, leave the Password box empty then click OK, you should now not be prompted for a password again.

Last Modified: September 29, 2000


Has Your Taskbar Disappeared? (All Versions)

Has Your Taskbar Disappeared? (All Versions)
If your taskbar has disappeared from the desktop or becomes hidden when you move your cursor near, it may be due to a corrupt registry key.

Close any open desktop and taskbar applications, then open your registry and find the key below.

Delete the entire "StuckRects" key, or "StuckRects2" for Windows 2000, and reboot.

When Windows restarts the taskbar should be set back to a default working state.

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\
StuckRects]

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 10, 2000


Are You Missing Fonts from the Fonts Folder? (All Versions)

Are You Missing Fonts from the Fonts Folder? (All Versions)
A font may seem to be installed correctly but does not appear in the Fonts folder because the Fonts key in the registry is missing or damaged.

Move the contents of the Fonts folder to an empty folder. By opening the Fonts folder, select all the fonts, copy them, and paste them to a new folder.

Open your registry and find the key below appropriate to your operating system. Highlight the key and press DELETE. Once the key has been deleted create a new key to replace it, by selecting Edit -> New -> Key and name the new key [Fonts].

Restart the computer, then re-install the fonts by opening the Control Panel, double-click on 'Fonts'. And from the File menu select 'Install New Fonts...' adding the fonts that were previously copied to the temporary directory.

Windows 95
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Fonts]

Windows NT
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts]

Last Modified: February 23, 1999


Change a Users Default Printer (All Versions)

Change a Users Default Printer (All Versions)
This setting will allow you the change the default printer of a user by modifying the registry.

Open your registry and find the key appropriate for your operating system, as shown below.

Add or edit the value of 'Device', to equal the printer you want to become default for the current user.

Windows 95
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Windows]

Windows NT
[HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Windows]

Note:The device is the name used to represent the printer in the registry, the name can also be found in the [HKEY_CURRENT_USER\Printers\Settings] key.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Device | REG_SZ | "HP Laserjet,winspool,LPT1:" | |
-
| |
-

Settings:
Name: Device
Type: REG_SZ (String Value)
Value:

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 23, 1999


Change the Maximum Transmission Unit (MTU) Size (Windows NT/2000)

Change the Maximum Transmission Unit (MTU) Size (Windows NT/2000)
This parameter specifies the Maximum Transmission Unit (MTU) for a network interface. By optimizing the MTU setting you can gain substantial network performance increases, especially when using dial-up modem connections.

MTU stands for Maximum Transmission Unit and in basic terms, it defines the maximum size of a packet that can be transferred in one frame over a network.

Open your registry and find the key below. Add a new value, or edit the existing value, to equal the new MTU size. For low bandwidth modem connections a MTU value of '576' (1398 in decimal) would be a good size.

Note: For Windows 2000 the key is HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\ Interfaces\[Adapter ID]

Note: IP datagrams may span multiple packets. Values larger than the default for the underlying network will result in the transport using the network default MTU. Values smaller than 68 will result in the tranport using an MTU of 68.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | MTU | REG_DWORD | 0x00000576 (1398) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters]
Name: MTU
Type: REG_DWORD (DWORD Value)
Value: Default = 0xFFFFFFFF

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 20, 2001


Stopping the KnownDLLs Vulnerability (Windows NT)

Stopping the KnownDLLs Vulnerability (Windows NT)
In Windows NT the core operating system DLLs are kept in virtual memory and shared between the programs running on the system. This has exposed a vulnerability that could allow a user to gain administrative privileges on the computer the user is interactively logged onto.

To enable stronger protection on system base objects such as the KnownDLLs list, change the value of 'ProtectionMode' to equal '1' in the registry key below.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ProtectionMode | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager]
Name: ProtectionMode
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 23, 1999


Change System Environment Variables (Windows NT/2000)

Change System Environment Variables (Windows NT/2000)
This key contains the Windows NT system environment variables, the variables include Path, Temp, Windir and any other defined values.

Open your registry and find the key below. Modify the value of any existing variables by double-clicking the value name. To create a new variable, select Edit -> New -> String Value.

Note: A reboot may be required for these changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Path | REG_SZ | "c:\winnt; c:\winnt\system32" | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Envi... |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\
Environment]
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 23, 1999


MS-DOS Compatibility Mode Problems with PCI IDE Controllers (Windows 9x/Me)

MS-DOS Compatibility Mode Problems with PCI IDE Controllers (Windows 9x/Me)
If your computer contains a PCI IDE hard disk controller that employs serialization between the two IDE channels, this tip may help you resolve a MS-DOS compatibility mode problem in Device Manager.

To cause Windows to attempt to reinitialize the protected-mode IDE driver, remove the 'NoIDE' entry from the registry key below.

After you update the registry, restart Windows. Windows will then attempt to initialize the protected-mode driver for the controller.

If no problems are encountered, the file system and virtual memory will operate in 32-bit mode, and Device Manager will not display an exclamation point in a yellow circle for the IDE channels.

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\IOS]
Name: NoIDE

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 25, 1999


Change the Internet Explorer Search Engine (All Versions)

Change the Internet Explorer Search Engine (All Versions)
Normally when you type 'go keyword' in the Internet Explorer address bar IE will search the web using a Microsoft selected search engine. By modifying this key you can select which search engine to use.

Open your registry and find the key below.

Modify the value of default to equal the URL for the search engine you want to use, substituting '%s' to represent the keywords.

For example, to use AltaVista the value would be:
http://www.altavista.com/cgi-bin/query?q=%s

And to use Yahoo! the value would be:
http://search.yahoo.com/bin/search?p=%s

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | "http://www.altavista.com/cgi-bin/query?q=%s" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\SearchUrl |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\SearchUrl]
Name: (Default)
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 28, 1999


Change the Position of the Desktop Wallpaper (All Versions)

Change the Position of the Desktop Wallpaper (All Versions)
Unfortunately Windows only gives you the limited options of center or tile for the placement of the desktop wallpaper. With this setting you can move the image anyway on your desktop.

Open your registry and find the key below.

Create two new string values of 'Wallpaperoriginx' and 'Wallpaperoriginy'. If the values already exist then you simply modify them.

Set the value of 'Wallpaperoriginx' to equal the horizontal offset, and set the value of 'Wallpaperoriginy' to equal the vertical offset. Then either restart Windows, or change your background image through the Control Panel.

Note: The image is offset from the center of your desktop, so you can use positive and negative values.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Wallpaperoriginx | REG_SZ | "100" | |
| |  | Wallpaperoriginy | REG_SZ | "300" | |
-
| HKEY_CURRENT_USER\Control Panel\Desktop |
-

Settings:
Key: [HKEY_CURRENT_USER\Control Panel\Desktop]
Name: Wallpaperoriginx, Wallpaperoriginy
Type: REG_SZ (String Value)
Value: Distance in Pixels

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 28, 1999


Change the Recycle Bin Icons (All Versions)

Change the Recycle Bin Icons (All Versions)
Would you like to make you Recycle Bin into something a bit more exciting? Maybe a glowing toxic waste bin? With this tweak you can change the icon to be whatever you like.

Open your registry and find the key below.

Within the key are three values: '(Default)', 'Empty' and 'Full'. Set the values to equal the icon you'd like to display for the various states of the Recycle Bin.

Note: These changes should take place immediately, you may need to refresh your desktop by clicking on a blank area and pressing F5.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | "c:\icons\toxic.ico" | |
| |  | Empty | REG_SZ | "c:\icons\toxic.ico" | |
| |  | Full | REG_SZ | "c:\icons\toxic_full.ico" | |
-
| HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}\DefaultIcon |
-

Settings:
Key: [HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}\
DefaultIcon]
Name: (Default), Empty, Full
Type: REG_SZ (String Value)
Value: Filename

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 28, 1999


Proxy Server Configuration (All Versions)

Proxy Server Configuration (All Versions)
If you need to configure a proxy server on multiple computers, or would just like to automate the procedure through the registry then this tip will explain how.

Open your registry and find the key below.

The values that configure the Internet proxy setup are located in this key. To change which proxy server is used, modify the value of 'ProxyServer' to equal the server and port combination. For example if your proxy server was called \PROXY and it was running on port 80 then the setting would equal 'PROXY:80'.

You may also need to set the value of 'ProxyEnable' to equal '1' for proxy enabled or '0' for disabled. Setting the value of 'ProxyOverride' to equal '<local>' will stop internal addresses from going through the proxy.

Note: Changes should take effect immediately.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ProxyEnable | REG_BINARY | 01 00 00 00 | |
| |  | ProxyOverride | REG_SZ | "" | |
| |  | ProxyServer | REG_SZ | "PROXY:80" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Set... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\
Internet Settings]
Name: ProxyServer
Type: REG_SZ (String Value)
Value: Server:Port

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 28, 1999


Including Manufacturer and Support Details (All Versions)

Including Manufacturer and Support Details (All Versions)
This tip lets you include a company logo and contact information in the System Properties dialog box. This is especially useful if you run a computer store and want your customers to be reminded where they bought their PC and where to get technical support.

To add the manufacturer and support information you need to create two new files in the Windows system directly, normally 'c:\windows\system' for Windows 9x and 'c:\winnt\system32' for Windows NT.

The first file is a text file called 'OEMINFO.INI'. To create the file open notepad and copy the template below, make any changes and save the file in the System directory.

OEMINFO.INI Template

[General]
Manufacturer=Enter the Company Name Here
Model=Enter the Computer Model Name Here

[Support Information]
Line1=first line of support information
Line2=second line
Line3=third line
Line4=fourth line

; Create as many lines as you need by incrementing the Line number

The other file you need to create is a logo file. This is a standard Windows bitmap file, but it must be saved as 'OEMLOGO.BMP' in the System directory.

Once you've created both these files, open System Properties from Control Panel, and your logo and company name will be listed. The details you entered in the [Support Information] section will show up when you click on the Support Information button.

Last Modified: February 28, 1999


Add an Expanding Control Panel to Start Menu (All Versions)

Add an Expanding Control Panel to Start Menu (All Versions)
Want easy access to the Control Panel options? With this tip you can add an expanding Control Panel folder to the start menu. This trick will work with most special folders too.

The first step is find the system ID of the folder you want to add, these ID's can be found under the [HKEY_CLASSES_ROOT\CLSID] key. The Control Panel's key is called [HKEY_CLASSES_ROOT\CLSID\{21EC2020-3AEA-1069-A2DD-08002B30309D}] and the ID is the last set of number after CLSID, in this case '{21EC2020-3AEA-1069-A2DD-08002B30309D}'.

Once you've found the ID the hard work is done, now all you need to do is right-click on the Start button and chose open.

Now create a new folder with the name of the folder followed by a dot and the folder ID. For Control Panel create a new folder called 'Control Panel.{21EC2020-3AEA-1069-A2DD-08002B30309D}'. The new folder should now change into the Control Panel logo. Close the explorer window and click on the Start button, and there should now be a new expanding folder for the Control Panel.

Last Modified: February 28, 1999


Display Host in List (pcAnywhere) (All Versions)

Display Host in List (pcAnywhere) (All Versions)
The registry entry allows the host to respond to remote requests for names. Thus, by disabling the registry item, you can hide the host from users scanning the network.

Use this setting so the host will not appear in a remote's list when the remote is scanning the network.

If the remote specifies the name of a host that has the DisplayHostInList option disabled, the host will appear in the remote's list, but the name displayed in the remote's list will not change from whatever the remote user entered.

Note: This item currently only refers to TCP/IP hosts.

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System]
Name: DisplayHostInList
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Add an Additional Delay to Browse Packets (pcAnywhere) (All Versions)

Add an Additional Delay to Browse Packets (pcAnywhere) (All Versions)
Use this setting when remotes display an incomplete list of TCP/IP hosts in the host list over a WAN or LAN connection.

The entry allows you to set the amount of delay used to create the remote's browse list. Technically, it adds 0.01 seconds between broadcast packets, and waits one additional second for the host's response for each unit of delay set.

For example, a setting of 2 means wait .02 additional seconds between each packet and an additional 2 seconds to receive the response from those broadcasts.

If you are having problems over a WAN connection, start with a setting of 1. If the setting does not work correctly, increase the number until the entire host list is displayed.

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System]
Name: TCPIPBrowseDelay
Type: REG_DWORD (DWORD Value)
Value: Delay in Milliseconds

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Connect to TCP/IP Hosts With Unknown Status (pcAnywhere) (All Versions)

Connect to TCP/IP Hosts With Unknown Status (pcAnywhere) (All Versions)
This registry entry allows a remote to try to connect to a host if the host's status is unknown. The usual reason for not knowing the host's status is that direct packets have been filtered by a firewall between the host and the remote.

An unfortunate side effect of enabling this key is that if the host's status is unknown to the remote, but the host is actually busy, the remote will receive a blank screen when it tries to connect. The remote can cancel from this screen and make another connection without difficulty. Sometimes, due to the length of time that the browse list updates take, updates will be turned off. By setting this item, you ensure that the list delays will not be turned off due to the length of time they take.

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System]
Name: TCPIPConnectIfUnknown
Type: REG_DWORD (DWORD Value)
Value: (0 = Use UDP directed packets, 1 = Do not use UDP directed packets)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Configure the TCP/IP Data Port (pcAnywhere) (All Versions)

Configure the TCP/IP Data Port (pcAnywhere) (All Versions)
Use this setting to select which TCP data port pcANYWHERE32 uses.

Note: Version 7.52's remote always uses the value in this registry entry. Version 8.0 remotes only use this entry if the TCPIPNetBroadcast entry equals 1.

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System]
Name: TCPIPDataPort
Type: REG_BINARY (Binary Value)
Value: 15FF (HEX) = Registered Port (Default)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Configure the TCP/IP Status Port (pcAnywhere) (All Versions)

Configure the TCP/IP Status Port (pcAnywhere) (All Versions)
Use this setting to select which TCP status port pcAnywhere uses.

The default is the port for pcAnywhere is 1600 (hex). For compatibility with previous versions, change the port number to 0016 (hex).

Note: Version 7.52's remote always uses the value in this registry entry. Version 8.0 remote only uses this entry if the TCPIPNetBroadcast entry equals 1.

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System]
Name: TCPIPStatusPort
Type: REG_BINARY (Binary Value)
Value: 1600 (HEX) (Default)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Port Compatibility with Legacy Versions (pcAnywhere) (All Versions)

Port Compatibility with Legacy Versions (pcAnywhere) (All Versions)
pcANYWHERE32 8.0 hosts and remotes can connect to earlier hosts and remotes without any registry changes. You may want to turn off compatibility to limit network traffic or allow third party applications that have registered the ports that earlier versions of pcANYWHERE32 7.x and pcAnywhere 2.0 were using.

If compatibility is set to OFF, then the pcANYWHERE32 8.0 host opens one TCP (TCPIPDataPort) and one UDP (TCPIPStatusPort) port. Remotes query and try to connect to one set of TCP and UDP ports.

If compatibility is set to ON, then the pcANYWHERE32 8.0 host opens the TCP port defined in TCPIPDataPort and port 65301, and the UDP port defined in TCPIPStatusPort and port 22. Remotes query and try to connect to the ports defined in the registry and ports 65301 and 22.

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System]
Name: TCPIPPortCompatibility
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


TCP/IP Broadcast Mode (pcAnywhere) (All Versions)

TCP/IP Broadcast Mode (pcAnywhere) (All Versions)
Use this setting to turn off or modify pcANYWHERE32's broadcast options to limit network traffic when the remote browses for a host.

If this is set to '0', only the hosts specified in Applications Options - TCP/IP host list will appear in a remote's TCP/IP browse list.

If this is set to '1' the default, pcANYWHERE32 sends 254 UDP packets per network. This setting is best when accessing pcAnywhere TCP/IP hosts through the Internet and on wide area networks. However, this option does send the most TCP/IP packets on the network.

If this is set to '2', pcANYWHERE32 sends one UDP broadcast packet per network. However, if the router filters broadcast packets, you will not see pcANYWHERE32 hosts across the router.

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System]
Name: TCPIPNetBroadcast
Type: REG_DWORD (DWORD Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


TCP/IP Query Interval (pcAnywhere) (All Versions)

TCP/IP Query Interval (pcAnywhere) (All Versions)
Use this setting to limit network traffic. Sometimes the additional network queries to refresh the browse list will interfere with getting status lights or making connections.

Set this registry item to a high value if you get a message that a known ready host is busy when you try to connect to the host, and direct packets are not filtered. It is especially important to increase this value if the TCPIPBrowseDelay value has been increased, because it is difficult to connect if the network query is going on at the same time.

The default is 50 seconds. The minimum setting is 30 seconds. A setting of zero turns off all list updates.

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System]
Name: TCPIPQueryInterval
Type: REG_DWORD (DWORD Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Configure the Winsock Buffer Size (pcAnywhere) (All Versions)

Configure the Winsock Buffer Size (pcAnywhere) (All Versions)
Use this registry item to set the size in bytes of TCP's Winsock buffer. Using a large value may increase the throughput of connections where the delay is large in relation to the bandwidth. This includes Internet, ISDN, RAS, dial-up networking, WAN and satellite connections.

For example, if the delay between two end points is 500 msec (.5 sec), the default throughput will be limited to 8K / .5 sec = 16K/sec. By increasing the value to its maximum setting, the theoretical throughput will be 65535 / .5 sec = 128K/sec.

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System]
Name: TCPIPWSDataBuf
Type: REG_DWORD (DWORD Value)
Value: 1 - 65535 (Default = 8000)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Compatibility with the OnNet 2.1 TCP/IP Stack (pcAnywhere) (All Versions)

Compatibility with the OnNet 2.1 TCP/IP Stack (pcAnywhere) (All Versions)
This registry item resolves an issue where pcAnywhere displayed the wrong host IP address when using FTP's OnNet 2.1 TCP/IP stack.

When this is set to 1, pcANYWHERE32 8.0 uses the default IP address as defined by the FTP software.

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\Host]
Name: OnNet
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Prompt for TCP/IP Host (pcAnywhere) (All Versions)

Prompt for TCP/IP Host (pcAnywhere) (All Versions)
This registry item allows a TCP/IP remote to specify an IP address or name when you leave the "Host To Connect To" field blank.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'PromptForTCPIPHost' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\
Remote Control]
Name: PromptForTCPIPHost
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Adapter Binding Mode (pcAnywhere) (All Versions)

Adapter Binding Mode (pcAnywhere) (All Versions)
This registry item allows a waiting host to bind to a new adapter, such as a dial-up adapter, without reinitializing the host.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'TCPIPHostAdapterMode' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System]
Name: TCPIPHostAdapterMode
Type: REG_DWORD (DWORD Value)
Value: (0 = bind to the default network adapter, 1 = bind to all network adapters)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


TCP/IP Host Binding Mode (pcAnywhere) (All Versions)

TCP/IP Host Binding Mode (pcAnywhere) (All Versions)
This registry item allows you to specify whether the host will wait on the first TCP/IP address given by the operating system, or whether it will wait on the TCP/IP index as indicated by TCPIPHostAddressIndex.

Note: Requires version 8.02 or higher.

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System]
Name: TCPIPHostBindMode
Type: REG_DWORD (DWORD Value)
Value: (0 = Use first or default TCP/IP address, 2 = Use TCP/IP address index as indicated by TCPIPHostAddressIndex)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Specify Host Mode TCP/IP Address (pcAnywhere) (All Versions)

Specify Host Mode TCP/IP Address (pcAnywhere) (All Versions)
This registry item allows you to specify which TCP/IP address index the host will wait on.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'TCPIPHostAddressIndex' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System]
Name: TCPIPHostAddressIndex
Type: REG_DWORD (DWORD Value)
Value: TCP/IP address index to wait on

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Multicast Packet Delay (pcAnywhere) (All Versions)

Multicast Packet Delay (pcAnywhere) (All Versions)
This sets the delay in milliseconds between each send. This is useful if multicast error correction is disabled.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'TCPIPMcastDataDelay' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System]
Name: TCPIPMcastDataDelay
Type: REG_DWORD (DWORD Value)
Value: Delay in Milliseconds (0 = disabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Configure the Multicast Data Port (pcAnywhere) (All Versions)

Configure the Multicast Data Port (pcAnywhere) (All Versions)
This setting selects the port that the multicast data is sent to.

Open your registry and find the key below.

Create a new Binary value, or modify the existing value called 'TCPIPMcastDataPort' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System]
Name: TCPIPMcastDataPort
Type: REG_BINARY (Binary Value)
Value: (0x15ff = Default)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Multicast Error Correction (pcAnywhere) (All Versions)

Multicast Error Correction (pcAnywhere) (All Versions)
This sets the level of error correction used on the host. The host specifies which level of error correction the remotes will use.

If you set this to '0' (disabled), you should use TCPIPMcastDataDelay to slow the sends from the host to minimize the loss on slow remotes.

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System]
Name: TCPIPMcastErrorCorrect
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 2 = Full error correction)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Multicast Adapter Selection (pcAnywhere) (All Versions)

Multicast Adapter Selection (pcAnywhere) (All Versions)
Use this registry item for a multihomed, multicast host that is not binding to the correct network card. This can be why none of the remotes receive the multicast packets.

To specify a particular network card, specify its number. For example, to force the multicast packet to be sent from the second network card, set this registry item to 2. Although the network card order is fairly stable, the order may change according to current DHCP and RAS status. To display the current network card order, run WINIPCFG.EXE for Windows 95, or IPCONFIG.EXE for Windows NT.

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System]
Name: TCPIPMcastInterface
Type: REG_DWORD (DWORD Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Configure Multicast Send and Receive Buffers (pcAnywhere) (All Versions)

Configure Multicast Send and Receive Buffers (pcAnywhere) (All Versions)
These registry items set the number of receive and send buffers when using an error correction multicast session. For slow remotes, a larger value may lead to less data loss.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'TCPIPMcastHostNumRecvBuf, TCPIPMcastHostNumSendBuf, TCPIPMcastRemNumRecvBuf, TCPIPMcastRemNumSendBuf' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System]
Name: TCPIPMcastHostNumRecvBuf, TCPIPMcastHostNumSendBuf, TCPIPMcastRemNumRecvBuf, TCPIPMcastRemNumSendBuf
Type: REG_DWORD (DWORD Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Multicast Maximum Transmission Unit (pcAnywhere) (All Versions)

Multicast Maximum Transmission Unit (pcAnywhere) (All Versions)
This registry item sets the Maximum Transmission Unit (MTU) in bytes. The MTU is the maximum bytes that may be sent as one IP multicast packet.

The largest supported value is 10,239. Do not set this value below its default of 1400 bytes.

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System]
Name: TCPIPMcastMTU
Type: REG_DWORD (DWORD Value)
Value: 1400 - 10,239 bytes

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Multicast Winsock Receive Buffer (pcAnywhere) (All Versions)

Multicast Winsock Receive Buffer (pcAnywhere) (All Versions)
This registry item sets the size in bytes of the Winsock receive buffer.

If error correction is off, set this value to 16384 bytes to minimize loss of data on the view-only remotes.

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System]
Name: TCPIPMcastWSRecvBuf
Type: REG_DWORD (DWORD Value)
Value: Size in Bytes (Default = 8000)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Ignore DSR on Serial Devices (pcAnywhere) (All Versions)

Ignore DSR on Serial Devices (pcAnywhere) (All Versions)
Use this item for modems or other serial devices that do not initialize correctly because their DSR is not initially set. It is also useful if the modem connection does not have a DSR line.

This registry item forces the computer to ignore the DSR setting of the attached modem or serial device. Thus, you can get around the requirement of setting a modem's DSR high.

The default is to ignore the DSR. To respect the DSR, add the registry item as a DWORD and set it to a value of zero.

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System]
Name: SerialIgnoreDSR
Type: REG_DWORD (DWORD Value)
Value: (0 = Respect DSR, 1= Ignore DSR)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Change Serial 56K Connection Speed (pcAnywhere) (All Versions)

Change Serial 56K Connection Speed (pcAnywhere) (All Versions)
Use this item when a serial connection can be made at 38,400 bps and 115,000 bps, but not at 57,600 bps.

This setting changes the default serial speed from 57,600 bps to 56,000 bps when you select 57,600 bps. It does not affect TAPI serial speeds.

The default is not to change the serial speed. To use 56,000 bps instead of 57,600 bps, add the registry item as a DWORD and set it to a value other than zero.

Note: Use only for Digiboards under Windows NT.

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System]
Name: SerialUse56000
Type: REG_DWORD (DWORD Value)
Value: (0 = Do not change, 1 = Change)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


TAPI Modem Errors (pcAnywhere) (All Versions)

TAPI Modem Errors (pcAnywhere) (All Versions)
Each time you add a TAPI modem, it generates a unique TAPI Permanent Line ID which is stored in pcANYWHERE32's connection items. If you no longer have a modem with this unique ID, pcANYWHERE32 displays an error message. This registry key tells pcANYWHERE32 how to handle this situation.

The options are:

  • 0 = Always error if TAPI ID does not match.
  • 1 = Error if TAPI ID does not match and more than one TAPI modem is present. If only one TAPI modem is installed, then use it if the TAPI IDs do not match.
  • 2 = Always use the first TAPI modem if the TAPI ID does not match
    •

    Settings:
    Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System]
    Name: UseFirstTapiModem
    Type: REG_DWORD (DWORD Value)

    Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

    Last Modified: March 1, 1999


Configure IPX Search Mode (pcAnywhere) (All Versions)

Configure IPX Search Mode (pcAnywhere) (All Versions)
This registry item enables the SAP method of network search instead of using the bindery when making IPX connections.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'IPXUseNBSapMethod' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System]
Name: IPXUseNBSapMethod
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Hide the Record Session Button (pcAnywhere) (All Versions)

Hide the Record Session Button (pcAnywhere) (All Versions)
Use this registry key to hide the Record Session icon from the remote session toolbar.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'HideRecordingButton' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\
Remote Control]
Name: HideRecordingButton
Type: REG_DWORD (DWORD Value)
Value: (0 = Visible, 1 = Hidden)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Remote Printer Inactivity Time-out (pcAnywhere) (All Versions)

Remote Printer Inactivity Time-out (pcAnywhere) (All Versions)
Use this setting if a print job is being separated into multiple jobs during remote printing. This item sets the inactivity time-out for the remote printing facility.

If there is no activity on the port being captured for remote printing, pcANYWHERE32 assumes the printing job is done and stop spooling. This may cause a print job to be separated into multiple jobs if there is a long delay during the printing. This DWORD registry item allows you to adjust the length in seconds of the inactivity on the captured port before pcAnywhere assumes a print job has stopped spooling.

The default is 30 seconds. To adjust the inactivity time-out, add the registry item as a DWORD set to the number of seconds you want.

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\
Remote Control]
Name: PrinterFlushTimeout
Type: REG_DWORD (DWORD Value)
Value: Seconds before assuming print job has completed

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Configure Legacy Remote Print Mode (pcAnywhere) (All Versions)

Configure Legacy Remote Print Mode (pcAnywhere) (All Versions)
This setting specifies the default print destination when connecting to a pcAnywhere 2.0 or 5.0 host.

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\
Remote Control]
Name: Print
Value: (0 = Discard, 1 = Host, 2 = Remote, 3 = Host and Remote)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Show Full Screen Reminder Message (pcAnywhere) (All Versions)

Show Full Screen Reminder Message (pcAnywhere) (All Versions)
This setting turns the Full Screen Reminder Message on or off.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'ShowAltEnterMsg' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\
Remote Control]
Name: ShowAltEnterMsg
Type: REG_DWORD (DWORD Value)
Value: (0 =disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Host Connection Time-Out (pcAnywhere) (All Versions)

Host Connection Time-Out (pcAnywhere) (All Versions)
If pcAnywhere host does not respond, hang up. This is useful for scripts that call systems where a modem will answer, but the pcAnywhere host may not be running.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NonPCAHostTimeout' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\
Remote Control]
Name: NonPCAHostTimeout
Type: REG_DWORD (DWORD Value)
Value: Time in Seconds (0 = Forever)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Run Smart Setup (pcAnywhere) (All Versions)

Run Smart Setup (pcAnywhere) (All Versions)
This setting controls whether SmartSetup is run when pcAnywhere is loaded for the first time.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'SmartSetup' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System]
Name: SmartSetup
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Run the pcAnywhere Service in Stealth Mode (pcAnywhere) (All Versions)

Run the pcAnywhere Service in Stealth Mode (pcAnywhere) (All Versions)
Use this setting to hide the Host Waiting icon and Waiting dialog.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'ServiceStealthMode' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\Host]
Name: ServiceStealthMode
Type: REG_DWORD (DWORD Value)
Value: (0 = Show Icon, 1 = Hide Icon)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Use Computer Name Instead of Caller Name (pcAnywhere) (All Versions)

Use Computer Name Instead of Caller Name (pcAnywhere) (All Versions)
When this key is set, if a host has the "Prompt to confirm connection" option checked, the host computer's prompt dialog will display the remote's computer name instead of the caller's name when a connection is made.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'ConfirmComputerName' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\Host]
Name: ConfirmComputerName
Type: REG_DWORD (DWORD Value)
Value: (0 = Use Caller name, 1 = Use remote's Computer name)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Wait for Call After Disconnect (pcAnywhere) (All Versions)

Wait for Call After Disconnect (pcAnywhere) (All Versions)
If enabled, the host will not wait for a call when the remote disconnects.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'OnlyOneGoodConnection' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\Host]
Name: OnlyOneGoodConnection
Type: REG_DWORD (DWORD Value)
Value: (0 = Host waits for a call after each connection, 1 = Do not wait for a call)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Configure Persistent Cache (pcAnywhere) (All Versions)

Configure Persistent Cache (pcAnywhere) (All Versions)
This setting turns pcAnywhere's persistent cache feature on or off.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'PersistentCache' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\Host]
Name: PersistentCache
Type: REG_DWORD (DWORD Value)
Value: (0 = Off, 1 = On)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Multi-Processor Options (pcAnywhere) (All Versions)

Multi-Processor Options (pcAnywhere) (All Versions)
This registry item specifies which processors pcANYWHERE32 8.0 will run on.

To have pcANYWHERE32 8.0 run on a specific processor, set this value according to the table below. If you want pcANYWHERE32 8.0 to run on several specific processors, then set this value to the sum of the values below.

   Value     Processor
   -----     ---------
   0         All
   1         1
   2         2
   4         3
   8         4
   16        5
   32        6
   64        7
   128       8

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\Host]
Name: ProcessorMask
Type: REG_DWORD (DWORD Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Prompt If Logged Out (pcAnywhere) (All Versions)

Prompt If Logged Out (pcAnywhere) (All Versions)
This registry key allows you to specify how pcANYWHERE32 will handle a remote connection when the pcANYWHERE32 host is waiting at the Windows NT login screen and the "Prompt On Connection" and "Disconnect On Timeout" options have been checked.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'PromptIfLoggedOut' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\Host]
Name: PromptIfLoggedOut
Type: REG_DWORD (DWORD Value)
Value: (0 = User Will Connect, 1 = User Won't Connect)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Speed Send File Size Limits (pcAnywhere) (All Versions)

Speed Send File Size Limits (pcAnywhere) (All Versions)
The minimum size a file must be for SpeedSend to work is 10K. You can change this value.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'SpeedSend Minimum Size' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\
File Transfer]
Name: SpeedSend Minimum Size
Type: REG_DWORD (DWORD Value)
Value: Size in KB (Default = 10)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Confirm File Send (pcAnywhere) (All Versions)

Confirm File Send (pcAnywhere) (All Versions)
When this setting is disabled, the remote does not display the confirm prompt when sending a file.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'ConfirmSend' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\
File Transfer]
Name: ConfirmSend
Type: REG_DWORD (DWORD Value)
Value: (0 = Disabled, 1 = Enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Confirm File Delete (pcAnywhere) (All Versions)

Confirm File Delete (pcAnywhere) (All Versions)
When this setting is disabled, the remote does not display the confirm prompt when deleting a file.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'ConfirmDelete' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\
File Transfer]
Name: ConfirmDelete
Type: REG_DWORD (DWORD Value)
Value: (0 = Disabled, 1 = Enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Use Windows Update Without Registering (Windows 98)

Use Windows Update Without Registering (Windows 98)
Windows Update is a handy feature of Windows 98, having to register your personal details before being able to use it isn't as good! With this tip you can bypass the registration process.

Open your registry and find the key below.

Create a new string value called 'RegDone', or modify the existing value, to equal '1'.

Check that the key [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Welcome\RegWiz] exists, if it doesn't then create a new key.

Next time you run Windows Update it shouldn't ask you to complete the registration process.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | RegDone | REG_SZ | "1" | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion]
Name: RegDone
Type: REG_SZ (String Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 7, 1999


Removing the 'Shortcut to...' Text on Shortcuts (All Versions)

Removing the 'Shortcut to...' Text on Shortcuts (All Versions)
Don't like having 'Shortcut to...' appended to every Shortcut? You're not alone. With this tip you can stop Windows for adding this text when creating links.

Open your registry and find the key below.

Create a new BINARY value name 'link', of modify the existing value, to equal '00 00 00 00' to have the Shortcut text disabled.

This tweak can also be applied to the [HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Explorer] key, to change all users.

Note: Restart your computer before creating any new shortcuts.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | link | REG_BINARY | 00 00 00 00 | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer]
Name: link
Type: REG_BINARY (Binary Value)
Value: (00 00 00 00 = No Shortcut Text)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 7, 1999


Change the Alignment of Drop-Down Menus (All Versions)

Change the Alignment of Drop-Down Menus (All Versions)
By default, Windows drop-down menus are aligned to the left, with this tweak you can change the default behavior to align the menus to the right instead.

Open your registry and find the key below.

Create a new string value, or modify the existing value, named 'MenuDropAlignment' and set it to equal '1' for right alignment or '0' for left alignment.

Restart or logoff Windows for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | MenuDropAlignment | REG_SZ | "1" | |
-
| HKEY_CURRENT_USER\Control Panel\Desktop |
-

Settings:
Key: [HKEY_CURRENT_USER\Control Panel\Desktop]
Name: MenuDropAlignment
Type: REG_SZ (String Value)
Value: (0 = left, 1 = right)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 7, 1999


Adjust the Mouse Double-Click Sensitivity Area (All Versions)

Adjust the Mouse Double-Click Sensitivity Area (All Versions)
This setting controls the amount of mouse movement allowed between clicks, for two consecutive clicks to be registered as a double-click.

Open your registry and find the key below.

Create two new string values named 'DoubleClickHeight' and 'DoubleClickWidth'. Set the these values to equal the size in pixels of the double-click area.

Logoff, or restart Windows for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DoubleClickHeight | REG_SZ | "30" | |
| |  | DoubleClickWidth | REG_SZ | "30" | |
-
| HKEY_CURRENT_USER\Control Panel\Desktop |
-

Settings:
Key: [HKEY_CURRENT_USER\Control Panel\Desktop]
Name: DoubleClickHeight, DoubleClickWidth
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 7, 1999


Change the Outlook Express Window Title (All Versions)

Change the Outlook Express Window Title (All Versions)
This setting allows you to customize Outlook Express by using your own window title. For example you could rename Outlook Express to 'My Mail Reader' or anything else you like!

Open your registry and find the key below.

Create a new string value, or modify the existing value, to equal the title you would like.

Note: Delete the value of 'WindowTitle' to change the title back to the default.

For Outlook Express 5.0 the location of the key has changed to: [HKEY_CURRENT_USER\Identities\{** Identity ID **}\Software\Microsoft\Outlook Express\5.0]

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | WindowTitle | REG_SZ | "My Mail Reader" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Outlook Express |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Outlook Express]
Name: WindowTitle
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 11, 2000


Colorful Message Backgrounds (All Versions)

Colorful Message Backgrounds (All Versions)
This setting enables colorful backgrounds with Outlook Express.

Open your registry and find the key below.

Change the value of 'ColorCycle' to equal '1' for enabled.

Close the registry and open Outlook Express. Open a new message and hold down CTRL + SHIFT, then press the 'Z' key to cycle through the colored backgrounds.

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Internet Mail and News]
Name: ColorCycle
Type: REG_SZ (String Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 7, 1999


Configure the Contiguous File Allocation Size (All Versions)

Configure the Contiguous File Allocation Size (All Versions)
This setting optimizes the contiguous file allocation size for the file system. This is especially useful for disk intensive applications.

Open your registry and find the key below.

Create a new DWORD value named 'ContigFileAllocSize', set the value to equal '200' (in hex).

Close the registry and restart the computer for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ContigFileAllocSize | REG_DWORD | 0x00000200 (512) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem]
Name: ContigFileAllocSize
Type: REG_DWORD (DWORD Value)
Value: 200 (hex) or 512 (decimal)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 10, 2000


Remove the Outlook Express Splash Screen (All Versions)

Remove the Outlook Express Splash Screen (All Versions)
Sick of the Outlook Express splash screen every time you start? This tip will help you remove it.

Open your registry and create a new value called 'NoSplash' in the key below.

Change the value to equal '1' to disable the splash screen.

Exit the registry and restart Outlook Express.

Keys:

Outlook 4.0 and below
[HKEY_CURRENT_USER\Software\Microsoft\Outlook Express]

Outlook 5.0
[HKEY_CURRENT_USER\Identities\{** Identity ID **}\Software\Microsoft\Outlook Express\5.0]

Where {** Identity ID **} is your system identity ID.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoSplash | REG_DWORD | 0x00000001 (1) | |
-
| |
-

Settings:
Name: NoSplash
Type: REG_DWORD (DWORD Value)
Value: 1 = no splash screen, 0 = splash screen

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 16, 2000


Deleting the Office Assistants (All Versions)

Deleting the Office Assistants (All Versions)
Are you annoyed by those office assistants always popping-up when you least expect it? This tweak will let you remove them for good!

Open your registry and find the key below. Then delete all the values under the key.

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\8.0\Common\Assistant]

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 17, 1999


Restricting Access to the Event Logs (Windows NT/2000)

Restricting Access to the Event Logs (Windows NT/2000)
The Windows NT event log contains records documenting application, security and system events taking place on the machine. These logs can contain sensitive data, and by default, the Guest account has access to view them. This tweak allows you to restrict access to administrators and system accounts only.

Open your registry and find the key below.

Under this key are three sub-keys: Application, Security and System. These subkeys represent each section of the event log. To restrict access to each section create a new DWORD value of 'RestrictGuestAccess' under each sub-key and set it to equal '1'. To restrict access to only certain sections, then only add the value to that specific key.

Restart Windows for change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | RestrictGuestAccess | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\EventLog |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\EventLog]
Name: RestrictGuestAccess
Type: REG_DWORD (DWORD Value)
Value: (0 = guest access, 1 = restricted access)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 25, 1999


Change the ICQ Email Tagline (All Versions)

Change the ICQ Email Tagline (All Versions)
Newer versions of ICQ come with a handy email client. Unfortunately they add "Download ICQ at ..." to the end of every outgoing message. You can remove or change this in the registry to whatever you like.

Open your registry and find the key below.

Change the value of the setting name to whatever you like. You may also want to hold on to the "double bars" as they represent carriage returns.

Settings:
Key: [HKEY_CURRENT_USER\Software\Mirabilis\ICQ\DefaultPrefs]
Name: Email Message
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 17, 1999


Disable TCP/IP Source Routing (Windows NT 4.0)

Disable TCP/IP Source Routing (Windows NT 4.0)
Normally, on a computer running Windows NT 4.0, you cannot disable the source routing feature for the TCP/IP protocol. By using this tweak it is possible to disable it.

Open your registry and find the key below.

Create a new DWORD value named 'DisableIPSourceRouting' and set the value to either '1' to disable source routing, or '0' to enable source routing.

Exit the registry and reboot.

Note: You must have Windows NT Service Pack 5 or greater installed for this setting to work.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DisableIPSourceRouting | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]
Name: DisableIPSourceRouting
Type: REG_DWORD (DWORD Value)
Value: '0' or '1'

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 17, 1999


Create a Useful Name for My Computer (Windows NT/2000)

Create a Useful Name for My Computer (Windows NT/2000)
This tweak will rename "My Computer" to "Username on Computername" making it simple to determine which computer you are logged on to and which username you are logged on as.

For Windows NT
Using REGEDT32.EXE (this is necessary for REG_EXPAND_SZ) open your registry and find the key below.

Delete the existing value called "No Name" and add a new REG_EXPAND_SZ value with an empty value name and set the string to equal "%USERNAME% on %COMPUTERNAME%".

For Windows 2000
Rename the value named "LocalizedString" to "LocalizedString.old". Create a new REG_EXPAND_SZ value named "LocalizedString", and copy the contents of the original value to the new value except change the words "My Computer" to equal "%USERNAME% on %COMPUTERNAME%". For example, the new "LocalizedString" value may equal "@C:\WINNT\system32\shell32.dll,-9216@1033,%USERNAME% on %COMPUTERNAME%".

Exit the registry editor, click on your desktop and press F5 (for refresh). The "My Computer" icon should now be rename to "Username on Computername".

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | LocalizedString | REG_EXPAND_SZ | "@C:\WINNT\system32\shell32.dll,-9216@1033,%USERNAME% on %COMPUTERNAME%". | |
-
| HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D} |
-

Settings:
Key: [HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}]
Type: REG_EXPAND_SZ (Expanded String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 22, 2000


Improve Core System Performance in Windows NT (Windows NT/2000)

Improve Core System Performance in Windows NT (Windows NT/2000)
On systems with large amount of RAM this tweak can be enabled to force the core Windows NT system to be kept in memory and not paged to disk.

Open your registry and find the value in the key below.

Change the value to '1' enable the tweak and stop the core process from being paged, or set it to '0' for the default.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DisablePagingExecutive | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memo... |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\
Memory Management]
Name: DisablePagingExecutive
Type: REG_DWORD (DWORD Value)
Value: (0 or 1)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 20, 2001


Removing Suspend from the Start Menu (Windows 9x/Me)

Removing Suspend from the Start Menu (Windows 9x/Me)
If the Suspend option doesn't work as it should, or you simply want to remove the option from the Start Menu, then use this tweak.

Open your registry and find the key and value below.

Change the value of 'APMMenuSuspend' to equal '00', restart the machine and the suspend option should have disappeared.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | APMMenuSuspend | REG_BINARY | 00 | |
-
| HKEY_LOCAL_MACHINE\Enum\Root\*PNP0C05\0000 |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\Enum\Root\*PNP0C05\0000]
Name: APMMenuSuspend
Type: REG_BINARY (Binary Value)
Value: (00 = not visible, 01 = visible)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 5, 1999


Restrict Access to the Windows Update Feature (All Versions)

Restrict Access to the Windows Update Feature (All Versions)
Windows 98 and later Windows versions contain a feature known as Windows Update, which allows users to update Windows specific software. With this modification you can remove access to this feature from the settings sub-menu.

Open your registry and find the key below.

Create a new binary value named "NoWindowsUpdate" and set the new value to equal "01 00 00 00".

Refresh your desktop, or restart your Windows session for the modification to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoWindowsUpdate | REG_BINARY | 01 00 00 00 | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoWindowsUpdate
Type: REG_BINARY (Binary Value)
Value: 01 00 00 00 (to disable access)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 19, 1999


Internet Explorer 5 Restrictions (All Versions)

Internet Explorer 5 Restrictions (All Versions)
Microsoft Internet Explorer 5 has a range of features that can be selectively controlled by modifying the Windows registry.

Open your registry and find the key below.

Create a new DWORD value based on the options below, and set the new value to equal "1" to enable the restriction or "0" to disable the restriction.

Note: These restrictions can be used either on a user by user basis by adding them to HKEY_CURRENT_USER or on a computer wide basis by adding them to HKEY_LOCAL_MACHINE.

  • NoBrowserClose - Disable the option of closing Internet Explorer.
  • NoBrowserContextMenu - Disable right-click context menu.
  • NoBrowserOptions - Disable the Tools / Internet Options menu.
  • NoBrowserSaveAs - Disable the ability to Save As.
  • NoFavorites - Disable the Favorites.
  • NoFileNew - Disable the File / New command.
  • NoFileOpen - Disable the File / Open command.
  • NoFindFiles - Disable the Find Files command.
  • NoSelectDownloadDir - Disable the option of selecting a download directory.
  • NoTheaterMode - Disable the Full Screen view option.
  • NoAddressBar - Disable the address bar.
  • NoToolBar - Disable the tool bar.
  • NoLinksBar - Disable the links bar.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoBrowserClose | REG_DWORD | 0x00000001(1) | |
| |  | NoBrowserContextMenu | REG_DWORD | 0x00000001 (1) | |
| |  | NoBrowserOptions | REG_DWORD | 0x00000001 (1) | |
| |  | NoBrowserSaveAs | REG_DWORD | 0x00000001 (1) | |
| |  | NoFavorites | REG_DWORD | 0x00000001 (1) | |
| |  | NoFileNew | REG_DWORD | 0x00000001 (1) | |
| |  | NoFileOpen | REG_DWORD | 0x00000001 (1) | |
| |  | NoFindFiles | REG_DWORD | 0x00000001 (1) | |
| |  | NoSelectDownloadDir | REG_DWORD | 0x00000001 (1) | |
| |  | NoTheaterMode | REG_DWORD | 0x00000001 (1) | |
| |  | NoAddressBar | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Restrict... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\
Restrictions]
Type: REG_DWORD (DWORD Value)
Value: (0 = disable restriction, 1 = enable restriction)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 25, 2000


Active Desktop Restrictions (All Versions)

Active Desktop Restrictions (All Versions)
Features of the Windows Active Desktop can be selectively controlled by modifying options in the Windows registry. Following the instructions in this tweak.

Open your registry and find the key below.

Create a new DWORD value based on the options below, and set the new value to equal "1" to enable the restriction or "0" to disable the restriction.

Note: These restrictions can be used either on a user by user basis by adding them to HKEY_CURRENT_USER or on a computer wide basis by adding them to HKEY_LOCAL_MACHINE.

  • NoChangingWallpaper - Disable the ability to change wallpapers.
  • NoComponents - Disable components.
  • NoAddingComponents - Disable the ability to add components.
  • NoDeletingComponents - Disable the ability to delete components.
  • NoEditingComponents - Disable the ability to edit components.
  • NoCloseDragDropBands
  • NoMovingBands

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoChangingWallpaper | REG_DWORD | 0x00000001 (1) | |
| |  | NoComponents | REG_DWORD | 0x00000001 (1) | |
| |  | NoAddingComponents | REG_DWORD | 0x00000001 (1) | |
| |  | NoDeletingComponents | REG_DWORD | 0x00000001 (1) | |
| |  | NoEditingComponents | REG_DWORD | 0x00000001 (1) | |
| |  | NoCloseDragDropBands | REG_DWORD | 0x00000001 (1) | |
| |  | NoMovingBands | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Act... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
ActiveDesktop]
Type: REG_DWORD (DWORD Value)
Value: (0 = disable restriction, 1 = enable restriction)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 19, 1999


Remove Active Desktop Options from the Settings Menu (All Versions)

Remove Active Desktop Options from the Settings Menu (All Versions)
The tweak will remove the Active Desktop options from Settings on the Start Menu.

Open your registry and find the key below.

Create a new DWORD value named "NoSetActiveDesktop", and set the new value to equal "1" to enable the restriction or "0" to disable the restriction.

Note: This restriction can be used either on a user by user basis by adding it to HKEY_CURRENT_USER or on a computer wide basis by adding it to HKEY_LOCAL_MACHINE.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoSetActiveDesktop | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoSetActiveDesktop
Type: REG_DWORD (DWORD Value)
Value: (0 = disable restriction, 1 = enable restriction)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 19, 1999


Disable the Ability to Modify the Start Menu (Windows 98)

Disable the Ability to Modify the Start Menu (Windows 98)
Normally users are able to right-click on the Start Menu and modify it using the context menu. This option give you the ability to disable this function.

Open your registry and find the key below.

Create a new DWORD value named "NoChangeStartMenu", and set the new value to equal "1" to enable the restriction or "0" to disable the restriction.

Note: This restriction can be used either on a user by user basis by adding it to HKEY_CURRENT_USER or on a computer wide basis by adding it to HKEY_LOCAL_MACHINE.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoChangeStartMenu | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoChangeStartMenu
Type: REG_DWORD (DWORD Value)
Value: (0 = disable restriction, 1 = enable restriction)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 19, 1999


Modify the Internet Auto-Dial Settings (All Versions)

Modify the Internet Auto-Dial Settings (All Versions)
Windows has the option to automatically dial your Internet Service Provider (ISP) to establish an Internet connection. This option can be controlled using this tweak.

Open your registry and find the key below.

Create a new binary value named "EnableAutodial", and set the new value to equal "01 00 00 00" to enable autodial or "00 00 00 00" to disable it.

Note: This restriction can be used either on a user by user basis by adding it to HKEY_CURRENT_USER or on a computer wide basis by adding it to HKEY_LOCAL_MACHINE.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | EnableAutodial | REG_BINARY | 00 00 00 00 | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Set... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\
Internet Settings]
Name: EnableAutodial
Type: REG_BINARY (Binary Value)
Value: (00 00 00 00 = disabled, 01 00 00 00 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 19, 1999


Enable Internet Mail Logging in Outlook 2000 (All Versions)

Enable Internet Mail Logging in Outlook 2000 (All Versions)
To help diagnose POP3, SMTP & Internet mail problems, Microsoft included a logging option for Outlook 2000. This feature can be enabled through the registry.

Open your registry and find the key below.

Create a new DWORD value and name it 'Logging' set the value to '1' to enable logging, or '0' to disable it.

Three log files will be created in the 'C:\Windows\Temp\Outlook Logging' directory the next time an Internet Mail session takes place. The files are 'InetXP.txt', 'Pop3log.txt' and 'Smtplog.txt'.

See the Microsoft Knowledge Base article below for more details on how to interpret the logs.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Logging | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Outlook\Options\Mail |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Outlook\Options\Mail]
Name: Logging
Type: REG_DWORD (DWORD Value)
Value: 1 = logging enabled, 0 = logging disabled

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 5, 2000


Changing the Registered Company in Microsoft Office (All Versions)

Changing the Registered Company in Microsoft Office (All Versions)
With previous versions of Microsoft Office it was necessary to re-install Office to change the registered company as shown on the splash screen and in the About dialog box. With Office 2000 it can be changed in the registry.

Open your registry and find the key:

[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\{00000409-78E1-11D2-B60F-006097C998E7}]

Change the value of 'RegCompany' to the new name for the registered company name.

Then find the following registry key:

[HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Common\UserInfo]

And rename the key to be OldUserInfo as in [HKEY_CURR ... Common\OldUserinfo]

Exit your registry editor, close any Office programs and restart one. The registered company should now be changed on both the splash screen and in the About dialog box.

Last Modified: January 5, 2000


Setting the Windows Temporary Directory (All Versions)

Setting the Windows Temporary Directory (All Versions)
Depending on which version of Windows you run, temporary files are usually stored in C:\WINDOWS\TEMP. This tweak shows how to move the location of the temporary file directory.

Open up AUTOEXEC.BAT with a text editor, it is normally found at C:\AUTOEXEC.BAT. If you're run Windows 9x it maybe possible to right-click the file in explorer and choose 'Edit'.

Add two new lines, or modify the existing lines if they are already there, as follows:

SET TEMP=[directory]
SET TMP=[directory]

e.g. SET TEMP=C:\GARBAGE

Save AUTOEXEC.BAT, create the directory entered above and reboot.

Settings:
Name: SET TEMP and SET TMP

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 17, 2000


Disable the Automatic Creation of a Default Network Route (Windows NT)

Disable the Automatic Creation of a Default Network Route (Windows NT)
This tweak controls the default behavior of Windows to add a network route to 0.0.0.0 on multi-homed machines (e.g. proxy or firewall).

Open your registry.

Create a new DWORD value named 'DontAddDefaultRoute' in the key below.

Set the value to '1' to enable the restriction.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | DontAddDefaultRoute | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\{Adapter}\Parameters |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\{Adapter}\
Parameters]
Name: DontAddDefaultRoute
Type: REG_DWORD (DWORD Value)
Value: (0 = disable restriction, 1 = enable restriction)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 11, 2000


Correct Internet Explorer Window Location (All Versions)

Correct Internet Explorer Window Location (All Versions)
Sometimes Internet Explorer may have problems with it's explorer window location, possibly placing the window off the screen or only allowing you to minimize or maximize the window. This tweak should reset Internet Explorer to the default position.

Exit Internet explorer, then open your registry and find the key below.

Find the value named 'Window_Placement' and delete it, make sure you have highlighted the correct value as there is no Undo function.

Restart Internet Explorer and it should now be located in the default position.

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
Name: Window_Placement
Type: REG_BINARY (Binary Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 11, 2000


Outlook Express and IMAP Settings (All Versions)

Outlook Express and IMAP Settings (All Versions)
This tweak allows you to correctly setup Outlook Express to use folders on the IMAP server for Drafts and Sent Mail instead of duplicating them with local folders.

Open your registry and find the key below. Where {Account ID} is the number relating to the IMAP account (e.g. 00000001). You may have to open a few sub-folders to find the correct one.

From your network administrator find out the name of the root IMAP folder (e.g. INBOX), the Drafts folder (e.g. Drafts) and the Sent Items folder (e.g. SentMail).

Create new string values (or modify existing value) named 'IMAP Root Folder', 'IMAP Drafts Folder' and 'IMAP Sent Items Folder'. Set the values to equal the details obtained in the previous step.

Exit the registry and restart Outlook Express.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | IMAP Root Folder | REG_SZ | "INBOX" | |
| |  | IMAP Drafts Folder | REG_SZ | "Drafts" | |
| |  | IMAP Sent Items Folder | REG_SZ | "Sent Items" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Internet Account Manager\Accounts\{... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Internet Account Manager\Accounts\
{Account ID}]
Name: IMAP Root Folder, IMAP Drafts Folder, IMAP Sent Items Folder
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 7, 2001


Disable Active Desktop (All Versions)

Disable Active Desktop (All Versions)
This tweak will disable the use of the Active Desktop feature.

Open your registry and find the key below.

Create a new DWORD value named "NoActiveDesktop", and set the new value to equal "1" to enable the restriction or "0" to disable the restriction.

Note: This restriction can be used either on a user by user basis by adding it to HKEY_CURRENT_USER or on a computer wide basis by adding it to HKEY_LOCAL_MACHINE.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoActiveDesktop | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoActiveDesktop
Type: REG_DWORD (DWORD Value)
Value: (0 = disable restriction, 1 = enable restriction)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 16, 2000


Show Cascading Control Panel Items (Windows 2000)

Show Cascading Control Panel Items (Windows 2000)
This tweak controls whether the Control Panel is shown as a cascading menu or as a simple folder link on the Start Menu.

Open your registry and find the key mentioned below.

Create a new string value, or modify the existing value, named 'CascadeControlPanel'. Modify the value to equal 'YES' to enable cascading or 'NO' to disable it.

Exit your registry and log off for the changes to take effect.

Note: By using the same key except under the [HKEY_LOCAL_MACHINE] tree the tweak can be enforced system wide, instead of only user based.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | CascadeControlPanel | REG_SZ | "Yes" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Adv... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\
Advanced]
Name: CascadeControlPanel
Type: REG_SZ (String Value)
Value: Yes or No

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 18, 2000


Show Cascading Network Connections (Windows 2000)

Show Cascading Network Connections (Windows 2000)
This tweak makes the 'Network and Dial-up Connections' folder on the Start Menu into a cascading menu instead of a simple folder link.

Open your registry and find the key mentioned below.

Create a new string value, or modify the existing value, named 'CascadeNetworkConnections'. Modify the value to equal 'YES' to enable cascading or 'NO' to disable it.

Exit your registry and log off for the changes to take effect.

Note: By using the same key except under the [HKEY_LOCAL_MACHINE] tree the tweak can be enforced system wide, instead of only user based.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | CascadeNetworkConnections | REG_SZ | "Yes" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Adv... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\
Advanced]
Name: CascadeNetworkConnections
Type: REG_SZ (String Value)
Value: Yes or No

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 18, 2000


Show Cascading My Documents Folder (Windows 2000)

Show Cascading My Documents Folder (Windows 2000)
This tweak makes the 'My Documents' folder on the Start Menu into a cascading folder, which then give you direct access to sub-folders without having to open the main 'My Documents' directory first.

Open your registry and find the key mentioned below.

Create a new string value, or modify the existing value, named 'CascadeMyDocuments'. Modify the value to equal 'YES' to enable cascading or 'NO' to disable it.

Exit your registry and log off for the changes to take effect.

Note: By using the same key except under the [HKEY_LOCAL_MACHINE] tree the tweak can be enforced system wide, instead of only user based.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | CascadeMyDocuments | REG_SZ | "Yes" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Adv... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\
Advanced]
Name: CascadeMyDocuments
Type: REG_SZ (String Value)
Value: Yes or No

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 18, 2000


Control Smart Menus (Windows 2000)

Control Smart Menus (Windows 2000)
Windows 2000 included a new feature called 'Personalized Menus', which remembers which items you use regularly and hides items you don't. This tweak allows you to enable or disable this functionality.

Open your registry and find the key mentioned below.

Create a new string value, or modify the existing value, named 'IntelliMenus'. Modify the value to equal 'YES' to enable smart menus or 'NO' to disable them.

Exit your registry and log off for the changes to take effect.

Note: By using the same key except under the [HKEY_LOCAL_MACHINE] tree the tweak can be enforced system wide, instead of only user based.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | IntelliMenus | REG_SZ | "No" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Adv... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\
Advanced]
Name: IntelliMenus
Type: REG_SZ (String Value)
Value: Yes or No

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 18, 2000


Hide or Display Administrative Tools Menu (Windows 2000)

Hide or Display Administrative Tools Menu (Windows 2000)
As with Windows NT, Windows 2000 has an 'Administrative Tools' folder on the Start Menu. This folder contains powerful administration utilities and therefore can be hidden to avoid accidental use.

Open your registry and find the key mentioned below.

Create a new string value, or modify the existing value, named 'StartMenuAdminTools'. Modify the value to equal 'YES' to show the administrative tools folder or 'NO' to hide it.

Exit your registry and log off for the changes to take effect.

Note: By using the same key except under the [HKEY_LOCAL_MACHINE] tree the tweak can be enforced system wide, instead of only user based.

Note: Hiding the folder does not stop the use of the tools, it only make it more difficult to locate them.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | StartMenuAdminTools | REG_SZ | "Yes" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Adv... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\
Advanced]
Name: StartMenuAdminTools
Type: REG_SZ (String Value)
Value: Yes or No

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 18, 2000


Enable Start Menu Scrolling (Windows 2000)

Enable Start Menu Scrolling (Windows 2000)
When there are more items on the Start Menu than can fit on the screen, Windows can either create a second column of items or it can create a scrolling menu. This tweak controls that functionality.

Open your registry and find the key mentioned below.

Create a new string value, or modify the existing value, named 'StartMenuScrollPrograms'. Modify the value to equal 'YES' to enable scrolling of the items or 'NO' to disable it.

Exit your registry and log off for the changes to take effect.

Note: By using the same key except under the [HKEY_LOCAL_MACHINE] tree the tweak can be enforced system wide, instead of only user based.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | StartMenuScrollPrograms | REG_SZ | "Yes" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Adv... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\
Advanced]
Name: StartMenuScrollPrograms
Type: REG_SZ (String Value)
Value: Yes or No

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 20, 2001


Cascade the Printer Folder (Windows 2000)

Cascade the Printer Folder (Windows 2000)
This tweak controls when the 'Printers' sub-folder under 'Settings' on the Start Menu, is shown as a cascading folder.

Open your registry and find the key mentioned below.

Create a new string value, or modify the existing value, named 'CascadePrinters'. Modify the value to equal 'YES' to enable cascading or 'NO' to disable it.

Exit your registry and log off for the changes to take effect.

Note: By using the same key except under the [HKEY_LOCAL_MACHINE] tree the tweak can be enforced system wide, instead of only user based.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | CascadePrinters | REG_SZ | "Yes" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Adv... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\
Advanced]
Name: CascadePrinters
Type: REG_SZ (String Value)
Value: Yes or No

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 18, 2000


Show Log Off [Username] on the Start Menu (Windows 2000)

Show Log Off [Username] on the Start Menu (Windows 2000)
This setting controls whether the 'Log Off [Username]' option is shown on the Start Menu.

Open your registry and find the key mentioned below.

Create a new DWORD value, or modify the existing value, named 'StartMenuLogoff'. Modify the value to equal '1' to enable the Log Off option or '0' to disable it.

Exit your registry and log off for the changes to take effect.

Note: By using the same key except under the [HKEY_LOCAL_MACHINE] tree the tweak can be enforced system wide, instead of only user based.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | StartMenuLogoff | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Adv... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\
Advanced]
Name: StartMenuLogoff
Type: REG_SZ (String Value)
Value: 0 = disable, 1 = enabled

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 18, 2000


Show Favorites on the Start Menu (Windows 2000)

Show Favorites on the Start Menu (Windows 2000)
This setting controls whether the Favorites folder is shown on the Start Menu.

Open your registry and find the key mentioned below.

Create a new DWORD value, or modify the existing value, named 'StartMenuFavorites'. Modify the value to equal '1' to enable Favorites or '0' to disable them.

Exit your registry and log off for the changes to take effect.

Note: By using the same key except under the [HKEY_LOCAL_MACHINE] tree the tweak can be enforced system wide, instead of only user based.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | StartMenuFavorites | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Adv... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\
Advanced]
Name: StartMenuFavorites
Type: REG_DWORD (DWORD Value)
Value: 0 = disable, 1 = enabled

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 18, 2000


Show Friendly HTTP Error Messages (IE5) (All Versions)

Show Friendly HTTP Error Messages (IE5) (All Versions)
By default Internet Explorer 5 will show a friendly version of any HTTP errors it receives, for example Error 404 Page Moved. This tweak controls that functionality allowing it to be enabled or disabled.

Open your registry and find the key mentioned below.

Create a new string value, or modify the existing value, named 'Friendly http errors'. Modify the value to equal 'YES' to enable friendly errors or 'NO' to disable them.

Exit your registry and restart IE for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Friendly http errors | REG_SZ | "Yes" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
Name: Friendly http errors
Type: REG_SZ (String Value)
Value: Yes or No

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 18, 2000


Control Smart Favorites Menu (IE5) (All Versions)

Control Smart Favorites Menu (IE5) (All Versions)
Internet Explorer 5 uses Personalized Menus which remembers which sites you have visited recently and hides the sites you haven't. This tweak allows you to enable or disable this functionality.

Open your registry and find the key mentioned below.

Create a new string value, or modify the existing value, named 'FavIntelliMenus'. Modify the value to equal 'YES' to enable smart menus or 'NO' to disable them.

Exit your registry and log off for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | FavIntelliMenus | REG_SZ | "No" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
Name: FavIntelliMenus
Type: REG_SZ (String Value)
Value: Yes or No

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 18, 2000


Hiding Control Panel Applets (All Versions)

Hiding Control Panel Applets (All Versions)
This tweak allows you to show or hide any of the applets found in the Windows Control Panel.

Open your registry and find the key below.

For each applet you want to hide create a new string value and call it the filename of the applet to be hidden (for example 'fax.cpl'). Set the value to equal 'No' to hide the applet or 'Yes' to display it.

Exit the registry and either logout or restart Windows.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | fax.cpl | REG_SZ | "No" | |
| |  | powercfg.cpl | REG_SZ | "No" | |
-
| HKEY_CURRENT_USER\Control Panel\don't load |
-

Settings:
Key: [HKEY_CURRENT_USER\Control Panel\don't load]
Type: REG_SZ (String Value)
Value: Yes or No

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 2, 2000


Control Microsoft Office 2000 Personalized Menus (All Versions)

Control Microsoft Office 2000 Personalized Menus (All Versions)
Microsoft Office 2000 introduced personalized menus (a.k.a. adaptive menus) that remembers which items you use regularly and hides items you don't. This tweak allows you to enable or disable this functionality.

Exit all open Office 2000 applications, including Word, Excel, Access and Outlook.

Then open your registry and find the key below, if it does not exist create it.

Create a new DWORD value named 'AdaptiveMenus' and set the value to '0' for disabled and '1' for enabled.

Exit the registry and restart the Office applications for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AdaptiveMenus | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Common\Toolbars |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Common\Toolbars]
Name: AdaptiveMenus
Type: REG_DWORD (DWORD Value)
Value: 0 = disabled, 1 = enabled

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 4, 2000


Increase the Maximum Number of HTTP Sessions Allowed (All Versions)

Increase the Maximum Number of HTTP Sessions Allowed (All Versions)
To abide by the HTTP specifications Windows limits the number of simultaneous connections that it will make to a single HTTP (web) server. This affects all Windows Internet applications that use the standard API, including Internet Explorer. The behavior can be seen when downloading multiple files from a web site only a certain number (2 or 4) will be active at any one time.

Windows will limit connections to a single HTTP 1.0 server to four simultaneous connections. Connections to a single HTTP 1.1 server will be limited to two simultaneous connections. The HTTP 1.1 specification (RFC2068) mandates the two connection limit while the four connection limit for HTTP 1.0 is a self-imposed restriction which coincides with the standard used by a number of popular Web browsers.

Open your registry and find the key below.

Create two new values, or modify the existing values, called 'MaxConnectionsPerServer' and 'MaxConnectionsPer1_0Server'. Change the values to equal the number of simultaneous requests allowed to a single HTTP server, the default values are 2 and 4 respectively.

Exit your registry and restart Windows.

NOTE: By changing these settings you are causing Windows to break the HTTP protocol specification for any Internet applications running on your machine.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | MaxConnectionsPerServer | REG_DWORD | 0x00000005 (5) | |
| |  | MaxConnectionsPer1_0Server | REG_DWORD | 0x00000005 (5) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Set... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\
Internet Settings]
Type: REG_DWORD (DWORD Value)
Value: Number of Simultaneous Connections

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 13, 2000


Internet Explorer Control Panel Restrictions (Part 1) (All Versions)

Internet Explorer Control Panel Restrictions (Part 1) (All Versions)
These tweaks allows you to control access to the Internet Explorer setup and control panel functions (found under Tools -> Internet Options).

Open your registry and find the key below.

Create a new DWORD value based on the options below, and set the new value to equal "1" to enable the restriction or "0" to disable the restriction.

  • Advanced
  • Autoconfig
  • Cache
  • CalendarContact
  • Certificates
  • Check_If_Default
  • Colors
  • Connection Settings
  • Connection Wizard
  • Fonts
  • History
  • HomePage
  • Languages
  • Links
  • Messaging
  • Profiles
  • Proxy
  • Ratings
  • Wallet

Note: These restrictions can be used either on a user by user basis by adding them to HKEY_CURRENT_USER or on a computer wide basis by adding them to HKEY_LOCAL_MACHINE.

Settings:
Key: [HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\
Control Panel]
Type: REG_DWORD (DWORD Value)
Value: (0 = disable restriction, 1 = enable restriction)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 13, 2000


Show Windows Version on Desktop (All Versions)

Show Windows Version on Desktop (All Versions)
Early versions of Windows showed their version number on the desktop, this feature was removed in the released version. If you're in an environment where it may be useful to quickly locate the version of Windows then this tweak re-enables that feature.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'PaintDesktopVersion' set the value to equal '1' to display the version.

Exit the registry, you may need to restart for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | PaintDesktopVersion | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Control Panel\Desktop |
-

Settings:
Key: [HKEY_CURRENT_USER\Control Panel\Desktop]
Name: PaintDesktopVersion
Type: REG_DWORD (DWORD Value)
Value: (0 = disable, 1 = enable)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 15, 2000


Control Application Focus Settings (All Versions)

Control Application Focus Settings (All Versions)
When Windows applications require user input or focus, they will either pop-up over the existing window, or their icon will flash on the taskbar waiting for user action. This tweak controls that behavior.

This tweak requires the modification of two values, depending on the way you would like applications to take the focus. The first setting controls whether applications simply steal the focus, that is pop-up over the existing in focus window, or if instead they wait in the background and flash the taskbar icon. The second setting controls the flashing of the icon.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value named 'ForegroundLockTimeout', change the value to either the timeout required, or to '0' which causes the application to take the focus instantly. The default value is '200000' (0x00030d40 hex).

The other settings affects the number of times the icon flashes if above value was not set to zero.

Create a new DWORD value, or modify the existing value called 'ForegroundFlashCount' set the value (in decimal) to the number times to flash the taskbar icon, setting the value to '0' cases the icon to flash infinitely. The default value is '3'.

Exit your registry, you may need to restart for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ForegroundFlashCount | REG_DWORD | 0x00000003 (3) | |
| |  | ForegroundLockTimeout | REG_DWORD | 0x00030d40 (200000) | |
-
| HKEY_CURRENT_USER\Control Panel\Desktop |
-

Settings:
Key: [HKEY_CURRENT_USER\Control Panel\Desktop]
Type: REG_DWORD (DWORD Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 16, 2000


Restrict Changes to Active Desktop Settings (All Versions)

Restrict Changes to Active Desktop Settings (All Versions)
This tweak allows you to have Active Desktop enabled, but to restrict any changes to the settings.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoActiveDesktopChanges' set the value to equal '1' to enable the restriction.

Exit your registry, you may need to restart for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoActiveDesktopChanges | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoActiveDesktopChanges
Type: REG_DWORD (DWORD Value)
Value: (0 = disable restriction, 1 = enable restriction)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 16, 2000


Hide Computers Near Me in Network Places (Windows 2000)

Hide Computers Near Me in Network Places (Windows 2000)
This setting allows you to show or hide the computers listed Near Me in My Network Places.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoComputersNearMe' set the value to equal '1' to enable the restriction.

Exit your registry, you may need to restart for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoComputersNearMe | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoComputersNearMe
Type: REG_DWORD (DWORD Value)
Value: (0 = disable restriction, 1 = enable restriction)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 16, 2000


Hide Control Panel on Start Menu (All Versions)

Hide Control Panel on Start Menu (All Versions)
This setting allows you to hide the Control Panel options from the Start Menu.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoControlPanel' set the value to equal '1' to enable the restriction.

Exit your registry, you may need to restart for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoControlPanel | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoControlPanel
Type: REG_DWORD (DWORD Value)
Value: (0 = disable restriction, 1 = enable restriction)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 16, 2000


Hide Network and Dial-up Connections on Start Menu (Windows 2000)

Hide Network and Dial-up Connections on Start Menu (Windows 2000)
This tweak allows you to hide the Network and Dial-up Connections option on the Start Menu.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoNetworkConnections' set the value to equal '1' to enable the restriction.

Exit your registry, you may need to restart for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoNetworkConnections | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoNetworkConnections
Type: REG_DWORD (DWORD Value)
Value: (0 = disable restriction, 1 = enable restriction)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 16, 2000


Don't Add Recent Files to Documents on the Start Menu (All Versions)

Don't Add Recent Files to Documents on the Start Menu (All Versions)
Normally when you open or access a document or file it is added to the list of recent documents on the Start Menu. This tweak will stop files from being added to the list.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoRecentDocsHistory' set the value to equal '1' to enable the restriction.

Exit your registry, you may need to restart for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoRecentDocsHistory | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoRecentDocsHistory
Type: REG_DWORD (DWORD Value)
Value: (0 = disable restriction, 1 = enable restriction)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 16, 2000


Clear Recent Documents When Windows Exits (All Versions)

Clear Recent Documents When Windows Exits (All Versions)
This tweak will clear the list of recent documents on the Start Menu when Windows exits.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'ClearRecentDocsOnExit' set the value to equal '1' to enable the tweak.

Exit your registry, you may need to restart for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ClearRecentDocsOnExit | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: ClearRecentDocsOnExit
Type: REG_DWORD (DWORD Value)
Value: (0 = disable, 1 = enable)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 16, 2000


Remove the Help Option from the Start Menu (Windows 2000)

Remove the Help Option from the Start Menu (Windows 2000)
This tweak hides the Help option on the Start Menu.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoSMHelp' set the value to equal '1' to enable the restriction.

Exit your registry, you may need to restart for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoSMHelp | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoSMHelp
Type: REG_DWORD (DWORD Value)
Value: (0 = disable restriction, 1 = enable restriction)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 16, 2000


Remove My Documents from Documents on the Start Menu (Windows 2000)

Remove My Documents from Documents on the Start Menu (Windows 2000)
This tweak hides 'My Documents' which is shown under the Documents folder on the Start Menu.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoSMMyDocs' set the value to equal '1' to enable the restriction.

Exit your registry, you may need to restart for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoSMMyDocs | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoSMMyDocs
Type: REG_DWORD (DWORD Value)
Value: (0 = disable restriction, 1 = enable restriction)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 16, 2000


Disable Windows Hotkeys (All Versions)

Disable Windows Hotkeys (All Versions)
This tweak disables the use of Windows hotkeys.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoWinKeys' set the value to equal '1' to enable the restriction.

Exit your registry, you may need to restart for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoWinKeys | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoWinKeys
Type: REG_DWORD (DWORD Value)
Value: (0 = disable restriction, 1 = enable restriction)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 16, 2000


Hide Links Folder on Favorites Menu (All Versions)

Hide Links Folder on Favorites Menu (All Versions)
Internet Explorer persistently creates a Links folder on the Favorites menu, this tweak allows you to remove it.

There are two methods that can be used to hide the Links folder, one using the registry and the other using file attributes. Both methods are detailed below:

Using the Registry
Open your registry and find the key below.

Set the value of "LinksFolderName" to equal a blank string. Open IE and delete the Links folder from the Favorites menu.

The next time you start Internet Explorer the Links folder will not be recreated.

Using File Attributes
Using Explorer find the location of your Favorites folder (e.g. C:\Documents and Settings\Joe Bloggs\Favorites) within that folder will be a sub-folder named Links.

Select the Links folder and right-click (or secondary click) and select Properties, check the Hidden checkbox and click OK.

From now on the Links folder should be hidden from the Favorites list.

Note: This works for any other folder or link on the favorites menu as well.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | LinksFolderName | REG_SZ | "" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Toolbar |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Toolbar]
Name: LinksFolderName
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 14, 2001


Changing Spare Stack Pages (Windows 95)

Changing Spare Stack Pages (Windows 95)
Windows 95 sets aside a number of extra memory pages (spare stack pages) to be used temporarily to prevent a system "crash" due to a stack overflow condition. Sometimes all the spare pages can be used, and an error message is shown, this tweak allows you to increase the number available.

If you receive the following error message, it means Windows has detected that it has run out of spare stack pages. Windows should continue to operate normally unless a device driver encounters a stack overflow condition when there are no free spare stack pages.

Error: There are no spare stack pages. It may be necessary to increase the setting named 'MinSPs' in System.ini to prevent possible stack faults. There are currently [xxx] SPs allocated.

To increase the number of available spare pages follow these instructions:

Open the file SYSTEM.INI located in your Windows directory (usually C:\WINDOWS\SYSTEM.INI) using a text editor (e.g. Notepad).

Add the following line to the [386Enh] section of the file and then restart your computer:

MinSPs=4

If the problem persists, increase the number of spare stack pages in increments of 4 (for example, 8, 12, 16). Note: Each spare stack page requires 4 kilobytes of memory.

Settings:
Name: MinSPs

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 20, 2000


Display the Attributes Column in Explorer (Windows 2000)

Display the Attributes Column in Explorer (Windows 2000)
If you like to view your files using the detailed view option you may have noticed that the attributes column has disappeared. With the introduction of Windows 98 it was removed by default, this tweak adds it back.

Open your registry and find the key below.

Create a new DWORD value called 'ShowAttribCol' and set the value to '1' to enable the attributes column.

Restart Windows.

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\
Advanced]
Name: ShowAttribCol
Type: REG_DWORD (DWORD Value)
Value: (0 = disable, 1 = enable)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 17, 2000


Fix DHCP Security Flaw (Windows 9x/Me)

Fix DHCP Security Flaw (Windows 9x/Me)
The ICMP Router Discovery Protocol (IRDP) comes enabled by default on DHCP clients that are running Microsoft Windows 9x/2000 machines. By spoofing IRDP Router Advertisements, an attacker can remotely add default route entries on a remote system.

For full details of this vulnerability see the L0pht advisory.

Open your registry and find the key below. Where #### is the binding for TCP/IP. More than one TCP/IP binding may exist.

For each number (e.g. 0001) open the key and create a new DWORD value called 'PerformRouterDiscovery' and set the value to equal '0'.

Exit Windows and Restart.

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Class\NetTrans\####]
Name: PerformRouterDiscovery
Type: REG_DWORD (DWORD Value)
Value: (0 = disable, 1 = enable)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: July 10, 2000


Disable Expanding Internet Explorer New Menu

Disable Expanding Internet Explorer New Menu
Usually when you click on the New menu in Internet Explorer it is expanded to include options like New Window, Message, Post and Internet Call. Using this tweak will stop the menu expanding and therefore only display the "New Window" option.

Open your registry and find the key below.

Create a new DWORD value called 'NoExpandedNewMenu' and set the value to '1' to stop the expanded menu from displaying.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoExpandedNewMenu | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoExpandedNewMenu
Type: REG_DWORD (DWORD Value)
Value: (0 = expanded, 1 = not expanded)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 14, 2000


Disable Folder Options Menu

Disable Folder Options Menu
This tweak allows you to hide the Folder Options function from the folder Tools menu. Allowing you to restrict access to numerous advanced folder features.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value named "NoFolderOptions" and set it to equal "1" to hide the options or "0" to show the options.

Log-off or restart Windows for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoFolderOptions | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoFolderOptions
Type: REG_DWORD (DWORD Value)
Value: (0 = show options, 1 = hide options)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 18, 2000


Improve Swap File Performance (Windows 98)

Improve Swap File Performance (Windows 98)
On systems with large amounts of memory (i.e. > 128mb) the hard disk based swap file is not needed as much, this tweak optimizes the use of the swap file on such systems.

Using notepad open the file SYSTEM.INI in your Windows directory.

Find the [386Enh] section and add a new line reading "ConservativeSwapfileUsage=1". Save the file and restart Windows for the change to take effect.

Settings:
Name: ConservativeSwapfileUsage
Value: 1

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 20, 2001


Display Hidden File Extensions (All Versions)

Display Hidden File Extensions (All Versions)
Even when you have configured Windows to display all file extensions, there are still some which remain hidden. This potentially allows dangerous files to be masked as safe files, fooling the user into executing them. This tweak helps expose those file extensions.

It is possible for a malicious user to name a file so that it looks safe to open, when in fact it may be executable containing dangerous content.

For example, a file could be displayed as "readme.txt" in explorer, when it fact it is really name "readme.txt.shs" but since the ".shs" portion of the filename is hidden it is impossible to tell it apart from a simple text file. Then once a user double-clicks to open this file, instead of seeing a text page as expected, the file will be executed by Windows as a scrap object and potentially harm the system.

To remove the potential to hide files, search through the registry for any values named "NeverShowExt", a common one is located at [HKEY_CLASSES_ROOT\ShellScrap]. To force the file extension to be shown highlight the value "NeverShowExt" and press delete. Now the full file extension should be shown and not masked.

You may need to restart or logoff Windows for the change to take effect.

Settings:
Key: [HKEY_CLASSES_ROOT]
Name: NeverShowExt

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 26, 2000


Automatic Window Refresh (All Versions)

Automatic Window Refresh (All Versions)
Normally when the contents of a window change you may need to wait a few seconds, or press F5, to refresh the display to see the updated information. This tweak configures the system to perform faster automatic updates.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, named "UpdateMode" and set it to equal "0" for faster updates.

Restart Windows for the change to take effect.

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Update]
Name: UpdateMode
Type: REG_DWORD (DWORD Value)
Value: default = 1

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 28, 2000


Force Users to Logon to Windows (Windows 9x/Me)

Force Users to Logon to Windows (Windows 9x/Me)
Usually users can simply press 'Cancel' at the Windows logon box to bypass the login process and gain access to the local computer. This tweak will logout the user if the authentication fails or the user clicks Cancel.

Like all registry tweaks, this is for advanced users, please do not attempt to try this if you are not confident with the Windows registry and recovering from any subsequent problems.

Firstly, setup your computer for multiple users by using the 'Users' wizard in the Control Panel. Create a new user in addition to any existing users, then restart Windows and login as the new user (this will become your new default account).

While you are logged in open your registry and expand the [HKEY_USERS] key, there should be several sub-folders including ".DEFAULT", "Software" and a folder corresponding to the new username you created above.

Open the key listed below (if the 'Run' key does not already exist then create it), and create a new string value named "NoLogon", and set the value to equal "RUNDLL32 shell32,SHExitWindowsEx 0".

Log-off and now when you login using the new username you should gain access to the desktop, but when you press Cancel or enter the wrong password the desktop should partially load, and then the computer should return to the login screen.

Note: If you have problems with this tweak, press F8 while the "Starting Windows 98..." boot-up message is showing, and select Safe Mode. Then open your registry and delete the "NoLogon" key created above.

Note: Once this tweak has been implemented any subsequent users accounts that are created will inherit the 'NoLogon' value and therefore reboot when they login. To avoid this; when you first create a new user, open the key below for the newly created account name (e.g. [HKEY_USERS\jdoe]) and remove the 'NoLogon' value.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoLogon | REG_SZ | "RUNDLL32 shell32,SHExitWindowsEx 0" | |
-
| HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Run |
-

Settings:
Key: [HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Run]
Name: NoLogon
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 11, 2000


Clear Internet Explorer Typed URL History (All Versions)

Clear Internet Explorer Typed URL History (All Versions)
Internet Explorer caches any URL's that are typed into the address bar. This could become a privacy issue on a shared computer, or it may become a nuisance if there is a particular URL you want to remove without clearing the whole history.

Open your registry and find the key below and delete any value you want to remove.

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\TypedURLs]

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 3, 2000


Microsoft Netmeeting Policies (All Versions)

Microsoft Netmeeting Policies (All Versions)
These restrictions and policies can be used to disable or restrict access to certain features of Microsoft Netmeeting 3.

Open your registry and find the key below.

Create a new DWORD value and name it according to the list of values below. Set the value to equal "1" to enable the setting.

  • CallSecurity
  • IntranetWebDirURL
  • MaximumBandwidth
  • NoAddingDirectoryServers
  • NoAdvancedCalling
  • NoAllowControl
  • NoAppSharing
  • NoAudio
  • NoAudioPage
  • NoChangeDirectSound
  • NoChat
  • NoDirectoryServices
  • NoFullDuplex
  • NoGeneralPage
  • NoNewWhiteBoard
  • NoOldWhiteBoard
  • NoReceivingVideo
  • NoSecurityPage
  • NoSendingFiles
  • NoSendingVideo
  • NoSharing
  • NoSharingDesktop
  • NoSharingDosWindows
  • NoSharingExplorer
  • NoTrueColorSharing
  • NoVideoPage
  • NoWebDirectory
  • Use AutoConfig

Restart Netmeeting for the changes to take effect.

Settings:
Key: [HKEY_CURRENT_USER\SOFTWARE\Policies\Microsoft\Conferencing]
Type: REG_DWORD (DWORD Value)
Value: (0 = disable policy, 1 = enable policy)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 3, 2000


Netmeeting Logging (All Versions)

Netmeeting Logging (All Versions)
This tweak enables some logging functions in Microsoft Netmeeting, the log file will written to /nmLog.txt.

Open your registry and find the key below.

Create a new DWORD value named "RetailLog" and set the value to "1" to enable logging.

Restart Netmeeting for the change to take effect.

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Conferencing\Debug]
Name: RetailLog
Type: REG_DWORD (DWORD Value)
Value: (1 = enable logging)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 3, 2000


Change the Default Gatekeeper Discovery TTL (All Versions)

Change the Default Gatekeeper Discovery TTL (All Versions)
This setting controls the TTL (Time To Live) for the gatekeeper multicast packets in Netmeeting.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'GKMCastTTL' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Conferencing\GatekeeperDLL]
Name: GKMCastTTL
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 3, 2000


Disable the Ability to Customize Toolbars (All Versions)

Disable the Ability to Customize Toolbars (All Versions)
By right clicking on a toolbar you are usually given the option to Customize, which allows you to change which functions are available from the toolbar. This tweak allows you to disable that function.

Open your registry and find the key below.

Create a new DWORD value named "NoToolbarCustomize" and set the value to "1" to disable the ability to customize the toolbars.

You may need to log-off for the change to take effect.

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoToolbarCustomize
Type: REG_DWORD (DWORD Value)
Value: (1 = enable restriction)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 3, 2000


Remove the Option to Change or Hide Toolbars (All Versions)

Remove the Option to Change or Hide Toolbars (All Versions)
By default users are able to select which toolbars are displayed either be right clicking the toolbar itself, or by changing the options from the View menu. This tweak locks the toolbars, removing the ability to change which are displayed.

Open your registry and find the key below.

Create a new value named "NoBandCustomize" and set it to equal "1" to enable the restriction.

You may need to log-off for the change to take effect.

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoBandCustomize
Type: REG_DWORD (DWORD Value)
Value: (1 = enable logging)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 3, 2000


Disable User Tracking (Windows 2000)

Disable User Tracking (Windows 2000)
This setting stops Windows from recording user tracking information including which applications a user runs and which files and documents are being accessed.

Open your registry and find the key below.

Create a new DWORD value named "NoInstrumentation" and set the value equal to "1" to enable the restriction.

You may need to log-off for the change to take effect.

Note: If this restriction is enabled customized menus and other features that require user tracking information are disabled.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoInstrumentation | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoInstrumentation
Type: REG_DWORD (DWORD Value)
Value: (1 = enable restriction)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 11, 2001


Force the Use of Active Desktop (All Versions)

Force the Use of Active Desktop (All Versions)
The user is normally given the option of disabling Active Desktop through the display properties. This tweak removes the ability to disable Active Desktop.

Open your registry and find the key below.

Create a new DWORD value named "ForceActiveDesktopOn" and set the value to "1" to force the use of Active Desktop.

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: ForceActiveDesktopOn
Type: REG_DWORD (DWORD Value)
Value: (1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 3, 2000


Control the Size of the Disk Cache (Windows 9x/Me)

Control the Size of the Disk Cache (Windows 9x/Me)
This tweak allows you control the minimum and maximum amount of memory being allocated as disk cache. It can be used to speed up your system and possibly avoid some memory problems.

Using notepad or another text editor, open your SYSTEM.INI file from your Windows directory.

Find the section starting with [vcache], and add the following two lines, or modify them if they already exist.

MinFileCache=0
MaxFileCache=4096

These values set the amount of memory in kilobytes to be used for disk caching, if you have more the 16Mb of RAM you may want to increase the MaxFileCache size, to about 25% of your total RAM (i.e. if you have 128Mb use "MaxFileCache=32768")

Restart Windows for the change to take effect.

Note: If you are receiving an error like "Error: An I/O subsystem driver failed to load" try increasing the maximum size to 6144.

Settings:
Name: MinFileCache, MaxFileCache

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 20, 2001


Internet Explorer FTP Mode (All Versions)

Internet Explorer FTP Mode (All Versions)
Internet Explorer has the ability to display FTP sites as if they were local folders. This tweak controls which mode IE uses for FTP.

Open your registry and find the key below.

Set the value named "Use Web Based FTP" to equal "no" for the folder view or "yes" for the traditional view.

Restart IE for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Use Web Based FTP | REG_SZ | "No" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Ftp |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Ftp]
Name: Use Web Based FTP
Type: REG_SZ (String Value)
Value: Yes or No

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 5, 2000


Cable Modem and DSL Speed Tweak to Increase Performance (Windows 2000)

Cable Modem and DSL Speed Tweak to Increase Performance (Windows 2000)
Use these settings with your Cable Modem or DSL broadband Internet connection, to boost network throughput performance with Windows 2000.

Open your registry and find the key below.

Create the following DWORD values, as most of these values will not already exist you will need to create them by clicking on 'Edit -> New -> DWORD Value' and then set the value as shown below.

DefaultTTL = "80" hex (or 128 decimal)
Specifies the default time to live (TTL) for TCP/IP packets. The default is 32.

EnablePMTUBHDetect = "0"
Specifies whether the stack will attempt to detect Maximum Transmission Unit (MTU) routers that do not send back ICMP fragmentation-needed messages. The default is 0.

EnablePMTUDiscovery = "1"
Specifies whether the TCP/IP stack will attempt to perform path MTU discovery as specified in RFC 1191. The default is 1.

SackOpts = "1"
Enables support for selective acknowledgements as documented by Request for Comment (RFC) 2018. Default is 0.

Tcp1323Opts = "3"
Controls RFC 1323 time stamps and window scaling options. Possible values are: "0" = disable RFC 1323 options, "1" = window scale enabled only, "2" = time stamps enabled only and "3" = both options enabled.

TcpWindowSize = "7FFF" hex (or 32767 decimal)
Specifies the receive window size advertised by the TCP/IP stack. If you have a latent network you can try increasing the value to 93440, 186880, or 372300.

GlobalMaxTcpWindowSize = "7FFF" hex (or 32767 decimal)
Specifies the system maximum receive window size advertised by the TCP/IP stack.

Exit your registry and restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DefaultTTL | REG_DWORD | 0x00000080 (128) | |
| |  | EnablePMTUBHDetect | REG_DWORD | 0x00000000 (0) | |
| |  | EnablePMTUDiscovery | REG_DWORD | 0x00000001 (1) | |
| |  | GlobalMaxTcpWindowSize | REG_DWORD | 0x00007fff (32767) | |
| |  | SackOpts | REG_DWORD | 0x00000001 (1) | |
| |  | Tcp1323Opts | REG_DWORD | 0x00000003 (3) | |
| |  | TcpWindowSize | REG_DWORD | 0x00007fff (32767) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]
Type: REG_DWORD (DWORD Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 18, 2000


Cable Modem and DSL Speed Tweak to Increase Performance (Windows 9x/Me)

Cable Modem and DSL Speed Tweak to Increase Performance (Windows 9x/Me)
Use these settings with your Cable Modem or DSL broadband Internet connection, to boost network throughput performance with Windows 95, 98 and ME.

If you are using Windows 95, first download and install the Winsock Update from Microsoft before proceeding to the steps below.

Open your registry and find the key below.

Create the following values, as most of these values will not already exist you will need to create them by clicking on Edit -> New -> DWORD or String Value and then set the value as shown below.

DefaultTTL = "128" (String Value)
Specifies the default time to live (TTL) for TCP/IP packets. The default is 32.

DefaultRcvWindow = "32767" (String Value)
Specifies the default receive window advertised by the TCP/IP stack. The default is 8192. If you're using Windows 98, Me or 2000 and have a latent network, you can try increasing the value to 93440, 186880, or 372300.

PMTUBlackHoleDetect = "0" (String Value)
Specifies whether the stack will attempt to detect Maximum Transmission Unit (MTU) routers that do not send back ICMP fragmentation-needed messages. The default is 0.

PMTUDiscovery = "1" (String Value)
Specifies whether the TCP/IP stack will attempt to perform path MTU discovery as specified in RFC 1191. The default is 1.

SackOpts = "1" (String Value)
Enables support for selective acknowledgements as documented by Request for Comment (RFC) 2018. Default is 0.

Tcp1323Opts = "3" (DWORD Value)
Controls RFC 1323 time stamps and window scaling options. Possible values are: "0" = disable RFC 1323 options, "1" = window scale enabled only, "2" = time stamps enabled only and "3" = both options enabled.

To increase performance even further follow the instructions here and increase the MaxMTU to 1500 (or 1492 if your provider uses PPPoE).

Exit your registry and restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DefaultTTL | REG_SZ | "128" | |
| |  | DefaultRcvWindow | REG_SZ | "32767" | |
| |  | PMTUBlackHoleDetect | REG_SZ | "0" | |
| |  | PMTUDiscovery | REG_SZ | "1" | |
| |  | SackOpts | REG_SZ | "1" | |
| |  | Tcp1323Opts | REG_DWORD | 0x00000003 (3) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 20, 2001


Change the Number of SQL Server Error Logs (Windows NT)

Change the Number of SQL Server Error Logs (Windows NT)
By default, Microsoft SQL Server 7.0 only stores seven error logs; Errorlog and Errorlog.1 through Errorlog.6. Since the log is re-created every time SQL Server is restarted you may want to keep more than seven logs archived.

Open your registry and find the key below.

Create a new DWORD value called 'NumErrorLogs' and set it to equal the number of archived logs you want to keep.

You may need to restart SQL for the change to become effective.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NumErrorLogs | REG_DWORD | 0x00000014 (20) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer\MSSQLServer |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer\MSSQLServer]
Name: NumErrorLogs
Type: REG_DWORD (DWORD Value)
Value: default = 7

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 5, 2000


Modify the Keyboard Buffer Size (All Versions)

Modify the Keyboard Buffer Size (All Versions)
Occasionally Windows may report an error relating to an overflow in the keyboard buffer. This tweak can be used to increase the size of the buffer, and avoid this problem.

Open your registry and find the key below.

Modify the value of 'KeyboardDataQueueSize' to equal the size of the queue buffer to use, for example 64 hex (100 decimal).

Exit your registry and restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | KeyboardDataQueueSize | REG_DWORD | 0x00000064 (100) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Kbdclass\Parameters |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Kbdclass\Parameters]
Name: KeyboardDataQueueSize
Type: REG_DWORD (DWORD Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 5, 2000


Modify the Mouse Buffer Size (All Versions)

Modify the Mouse Buffer Size (All Versions)
Occasionally Windows may report an error relating to an overflow in the mouse buffer. This tweak can be used to increase the size of the buffer, and avoid this problem.

Open your registry and find the key below.

Modify the value of 'MouseDataQueueSize' to equal the size of the queue buffer to use, for example 64 hex (100 decimal).

Exit your registry and restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | MouseDataQueueSize | REG_DWORD | 0x00000064 (100) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Mouclass\Parameters |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Mouclass\Parameters]
Name: MouseDataQueueSize
Type: REG_DWORD (DWORD Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 5, 2000


Remove the Ability to Right Click on the Start Button (All Versions)

Remove the Ability to Right Click on the Start Button (All Versions)
Usually when a user right clicks on the start button they are able to select Open, Explore or Find. Use this tweak to remove these options and secure your desktop.

Open your registry and find the key [HKEY_CLASSES_ROOT\Directory\shell] then rename it from 'shell' to 'shell.old'.

Do the same with the key [HKEY_CLASSES_ROOT\Folder\shell] and rename it to [...\shell.old].

Once complete the two original keys should now be called [HKEY_CLASSES_ROOT\Directory\shell.old] and [HKEY_CLASSES_ROOT\Folder\shell.old] respectively.

Now when you right click on the start button, you should no longer be given the option to Open, Explore or Find.

Last Modified: September 5, 2000


Use Smooth Scrolling in Telnet (All Versions)

Use Smooth Scrolling in Telnet (All Versions)
This tweak enables the smooth scrolling function in Windows Telnet.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, named 'SmoothScroll' and set the value to '1' to enable or '0' to disable.

Restart Telnet for the change to take effect.

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Telnet]
Name: SmoothScroll
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 5, 2000


Enable the GSM Audio Codec in Netmeeting 2.1

Enable the GSM Audio Codec in Netmeeting 2.1
By default Netmeeting does not include the GSM audio codec, this tweak enables the GSM codec to enhance interoperability with other GSM capable applications.

Download the netmeeting-gsm.reg registry file to a temporary directory.

Right click on the downloaded file, and choose 'Merge'. Restart Netmeeting for the change to take effect.

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Audio\ACMH323Encodings]
Name: GSM 6.10, 8 000 Hz; Mono_8000_0_13000
Type: REG_DWORD (DWORD Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 17, 2000


Display a Background Bitmap on Explorer Toolbars (All Versions)

Display a Background Bitmap on Explorer Toolbars (All Versions)
This tweak allows you to choose a a bitmap image to display as the background for the explorer toolbars.

Open your registry and find the key below.

Create a new string value, or modify the existing value, named 'BackBitmapShell' and set the value to the location & filename of the bitmap file you want to use.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | BackBitmapShell | REG_SZ | "c:\windows\soapbu~1.bmp" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Toolbar |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Toolbar]
Name: BackBitmapShell
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 17, 2000


Force Windows to Unload DLL's from Memory (All Versions)

Force Windows to Unload DLL's from Memory (All Versions)
Windows Explorer will usually try and cache DLL's by keeping them in memory even after the application using them has been closed. This can cause performance problems on low memory systems, and can be annoying when developing on Windows and the DLL's remain in use.

Open your registry and find the key [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer].

Create a new sub-key named 'AlwaysUnloadDll' and set the default value to equal '1' to disable Windows holding the DLL in memory.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | "1" | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Al... |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\
AlwaysUnloadDLL]
Name: Default
Type: REG_SZ (String Value)
Value: (1 = enable)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 26, 2000


Remove Task Scheduler (Windows 9x/Me)

Remove Task Scheduler (Windows 9x/Me)
Task Scheduler is automatically installed in some versions of Windows, and also when you install Internet Explorer. This tweak will remove it from your system.

Open your registry and find the key below.

There should be a value named 'SchedulingAgent' which is set to equal 'mstask.exe', this is the entry that loads the Task Scheduler. Delete this value to stop the task manager loading again.

Note: Remember to backup your registry before deleting any values!

Settings:
Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\RunServices]
Name: SchedulingAgent
Type: REG_SZ (String Value)
Value: mstask.exe

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 17, 2000


Control Active Server Pages Browser Buffering

Control Active Server Pages Browser Buffering
This setting controls whether Active Server Pages (ASP) buffers output to a browser. If this setting is enabled then all output is collected before any is sent to the browser. This fixes some problems with incomplete and random data being sent to a browser using Internet Information Server (IIS).

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, named 'BufferingOn' and set the value to '1' to enable buffering.

Exit your registry editor, you should not need to restart any services for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | BufferingOn | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W3SVC\ASP\Parameters |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W3SVC\ASP\
Parameters]
Name: BufferingOn
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = buffering enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 26, 2000


Change the Vertical Icon Spacing (Windows NT/2000)

Change the Vertical Icon Spacing (Windows NT/2000)
This setting specifies the number of pixels that appear vertically between icons. Windows determines the default based on the icon title font and the display you are using.

Open your registry and find the key below.

Create a new string value, or modify the existing value, named 'IconVerticalSpacing' and set the value to equal the number of pixel to appears vertically between icons, for example '62'.

You may need to restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | IconVerticalSpacing | REG_SZ | "62" | |
-
| HKEY_CURRENT_USER\Control Panel\Desktop |
-

Settings:
Key: [HKEY_CURRENT_USER\Control Panel\Desktop]
Name: IconVerticalSpacing
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 9, 1999


Configuring the Registry Size Limit (Windows NT/2000)

Configuring the Registry Size Limit (Windows NT/2000)
The Registry Size Limit, or RSL, controls the total amount of space the may be consumed in paged pool memory and disk space by registry data. The RSL is a kind of "global quota" for registry space.

Open your registry and find the key below.

Create new DWORD value, or modify the existing value, named 'RegistrySizeLimit' and set the value to equal the desired RSL in bytes.

Note: RegistrySizeLimit must have a type of REG_DWORD, and a data length of 4 bytes, or it is ignored. If you set the value RegistrySizeLimit to less than 4 megabytes (MB), it is forced up to 4 MB. If you set it to greater than about 80 percent of the size of paged pool, it is set down to 80 percent of the size of paged pool (it is assumed that paged pool is always more than 5 MB). If you set it to 0xffffffff the maximum size allowable (or 80 percent of paged pool, up to 102 MB) is set.

Shutdown and restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | RegistrySizeLimit | REG_DWORD | 0xffffffff (4294967295) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control]
Name: RegistrySizeLimit
Type: REG_DWORD (DWORD Value)
Value: (0xffffffff = maximum)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 27, 2000


Load DOS Command Processor into High Memory (Windows 9x/Me)

Load DOS Command Processor into High Memory (Windows 9x/Me)
DOS is limited to 640kb low memory, as more device drivers are loaded that space is used up leaving less available memory for applications. This setting loads the DOS command processor into high memory, freeing some low memory for other applications.

Open the CONFIG.SYS file found in the root directory of your C: drive using Notepad or another text editor (not Microsoft Word or any word processor).

Add a new line with the text "DOS=HIGH,UMB", or modify the exiting line beginning with "DOS=" and change it to "DOS=HIGH,UMB" to load the DOS processor into high memory.

These changes will take place on the next reboot.

Note: Make sure the following lines also exist at the top of the file, without them DOS can not be loaded into upper memory.

DEVICE=C:\WINDOWS\HIMEM.SYS
DEVICE=C:\WINDOWS\EMM386.EXE NOEMS

Settings:
Value: DOS=HIGH,UMB

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 17, 2000


Increase the Number Disk Buffers (Windows 3.1)

Increase the Number Disk Buffers (Windows 3.1)
This setting can be used to increase the number of disk buffers available to DOS.

Open the CONFIG.SYS file found in the root directory of your C: drive using Notepad or another text editor (not Microsoft Word or any word processor).

Add a new line with the text "buffers=40", or modify the exiting line beginning with "buffers=" and change it to "buffers=40" where '40' is the number of disk buffers. Alternatively use "buffershigh=40" to cause the reserved memory to be taken out of the upper memory area instead.

These changes will take place on the next reboot.

Settings:
Name: buffers or buffershigh

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 17, 2000


Load Device Drivers into Memory (Windows 3.1)

Load Device Drivers into Memory (Windows 3.1)
This setting is used to load specified device drivers into memory (or high memory).

Open the CONFIG.SYS file found in the root directory of your C: drive using Notepad or another text editor (not Microsoft Word or any word processor).

Add a new line with the text "device=xxxxxxx.sys" where 'xxxxxxx.sys' is the device to be loaded. Alternatively use "devicehigh=xxxxxxx.sys" command to cause the device to be loaded into the upper memory area instead.

These changes will take place on the next reboot.

Settings:
Name: device or devicehigh

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 17, 2000


Control the Number of File Control Blocks (FCBs) (Windows 3.1)

Control the Number of File Control Blocks (FCBs) (Windows 3.1)
This setting specifies the number of file control blocks (FCBs) that the operating system can have open at the same time.

Open the CONFIG.SYS file found in the root directory of your C: drive using Notepad or another text editor (not Microsoft Word or any word processor).

Add a new line with the text "fcbs=xx" where 'xx' is the number of fcbs to have open simultaneously. Alternatively use "fcbshigh=xx" command to cause the reserved memory to be taken out of the upper memory area instead.

These changes will take place on the next reboot.

Settings:
Name: fcbs or fcbshigh

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 17, 2000


Controls the Number of Simultaneous Files (Windows 3.1)

Controls the Number of Simultaneous Files (Windows 3.1)
This setting specifies the number of files that the operating system can access at one time.

Open the CONFIG.SYS file found in the root directory of your C: drive using Notepad or another text editor (not Microsoft Word or any word processor).

Add a new line with the text "files=xx" where 'xx' is the maximum number of files to have open simultaneously (for example files=60). Alternatively use "fileshigh=xx" command to cause the reserved memory to be taken out of the upper memory area instead.

These changes will take place on the next reboot.

Settings:
Name: files or fileshigh

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 17, 2000


Specify the Maximum Number of Drive Letters (Windows 3.1)

Specify the Maximum Number of Drive Letters (Windows 3.1)
This setting control the maximum number of drivers accessible by a drive letter.

Open the CONFIG.SYS file found in the root directory of your C: drive using Notepad or another text editor (not Microsoft Word or any word processor).

Add a new line with the text "lastdrive=?" where '?' is the last accessible driver letter (for example lastdrive=Z). Alternatively use "lastdrivehigh=?" command to cause the reserved memory to be taken out of the upper memory area instead.

These changes will take place on the next reboot.

Settings:
Name: lastdrive or lastdrivehigh

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 17, 2000


Control the Number of Data Stacks (Windows 3.1)

Control the Number of Data Stacks (Windows 3.1)
Support the dynamic use of data stacks to handle hardware interrupts.

Open the CONFIG.SYS file found in the root directory of your C: drive using Notepad or another text editor (not Microsoft Word or any word processor).

Add a new line with the text "stacks=xx" where 'xx' is the number of data stacks (for example stacks=9,256). Alternatively use "stackshigh=" command to cause the reserved memory to be taken out of the upper memory area instead.

These changes will take place on the next reboot.

Settings:
Name: stacks or stackshigh

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 17, 2000


Use Extended Memory (Windows 3.1)

Use Extended Memory (Windows 3.1)
Himem, an extended-memory manager, is a program that coordinates the use of your computer's extended memory, including the high memory area (HMA). It must be loaded before any application or device drivers can use extended memory.

Open the CONFIG.SYS file found in the root directory of your C: drive using Notepad or another text editor (not Microsoft Word or any word processor).

At the top of the file add a line with the text "device=c:\windows\himem.sys" where 'c:\windows' is the path to the himem.sys file.

These changes will take place on the next reboot.

Settings:
Value: device=himem.sys

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 17, 2000


Enable the Ability to Load Devices into Upper Memory (Windows 3.1)

Enable the Ability to Load Devices into Upper Memory (Windows 3.1)
Originally EMM386 was required to provide EMS memory, an alternate form of extended memory. Now with the sparse use of EMS, it's primary purpose is to provide support for loading real-mode device drivers in the upper memory area.

Open the CONFIG.SYS file found in the root directory of your C: drive using Notepad or another text editor (not Microsoft Word or any word processor).

At the top of the file, after the HIMEM device, add a line with the text "device=c:\windows\emm386.exe NOEMS" where 'c:\windows' is the path to the himem.sys file.

These changes will take place on the next reboot.

Last Modified: October 17, 2000


Load Drivers and Programs into High Memory (Windows 3.1)

Load Drivers and Programs into High Memory (Windows 3.1)
Programs and device drivers loaded from the AUTOEXEC.BAT file are normally loaded straight into low memory. This change allows them to be loaded high.

Open the AUTOEXEC.BAT file found in the root directory of your C: drive using Notepad or another text editor (not Microsoft Word or any word processor).

In front of any lines loaded applications or drivers, for example MSCDEX.EXE, appended "LH" (for Load High), for example:

LH C:\WINDOWS\COMMAND\MSCDEX /D:MSCD001

These changes will take place on the next reboot.

Settings:
Name: lh

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 17, 2000


Remove Command Echoing (Windows 9x/Me)

Remove Command Echoing (Windows 9x/Me)
Normally when commands are read and executed from the AUTOEXEC.BAT file, there are echoed back to the screen. This setting turns the echo off, which means only message text will be shown, and not the originating command.

Open the AUTOEXEC.BAT file found in the root directory of your C: drive using Notepad or another text editor (not Microsoft Word or any word processor).

At the top of the file add a new line equal to "@echo off", this will remove the command echo.

These changes will take place on the next reboot.

Settings:
Name: @echo off

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 17, 2000


Cable Modem and DSL Speed Tweak to Increase Performance (Windows NT)

Cable Modem and DSL Speed Tweak to Increase Performance (Windows NT)
Use these settings with your Cable Modem or DSL broadband Internet connection, to boost network throughput performance with Windows NT.

Open your registry and find the key below.

Create the following DWORD values, as most of these values will not already exist you will need to create them by clicking on 'Edit -> New -> DWORD Value' and then set the value as shown below.

DefaultTTL = "80" hex (or 128 decimal)
Specifies the default time to live (TTL) for TCP/IP packets. The default is 32.

EnablePMTUBHDetect = "0"
Specifies whether the stack will attempt to detect Maximum Transmission Unit (MTU) routers that do not send back ICMP fragmentation-needed messages. The default is 0.

EnablePMTUDiscovery = "1"
Specifies whether the TCP/IP stack will attempt to perform path MTU discovery as specified in RFC 1191. The default is 1.

TcpWindowSize = "faf0" hex (or 64240 decimal)
Specifies the receive window size advertised by the TCP/IP stack.

Exit your registry and restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DefaultTTL | REG_DWORD | 0x00000080 (128) | |
| |  | EnablePMTUBHDetect | REG_DWORD | 0x00000000 (0) | |
| |  | EnablePMTUDiscovery | REG_DWORD | 0x00000001 (1) | |
| |  | TcpWindowSize | REG_DWORD | 0x0000faf0 (64240) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]
Type: REG_DWORD (DWORD Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 18, 2000


Enable DVD Features in Media Player (All Versions)

Enable DVD Features in Media Player (All Versions)
This setting allows you to use Microsoft Media Player to Play and Open DVDs.

Open your registry and find the key below.

Create a new string value called "EnableDVDUI" and set it to "yes" to enable DVD functionality.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | EnableDVDUI | REG_SZ | "Yes" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\MediaPlayer\Player\Settings |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\MediaPlayer\Player\Settings]
Name: EnableDVDUI
Type: REG_SZ (String Value)
Value: yes or no

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 18, 2000


Override the Default Broadcast Address (Windows 9x/Me)

Override the Default Broadcast Address (Windows 9x/Me)
This setting overrides the default broadcast address that is derived from the IP address and subnet mask. Primarily the broadcast address is used for NetBIOS name queries.

Open your registry and find the key below.

Create a new DWORD value (or string for Windows 98), named "BroadcastAddress" and set it to the broadcast address in hexadecimal form.

Restart Windows for the change to take effect.

Note: For Windows 98, the Data Type is a String value.

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: BroadcastAddress
Type: REG_DWORD (DWORD Value)
Value: broadcast address in hexadecimal

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 18, 2000


Specify the Number of Broadcast Name Resolution Attempts (Windows 9x/Me)

Specify the Number of Broadcast Name Resolution Attempts (Windows 9x/Me)
This setting controls the number of attempts to resolve a NetBIOS name using a broadcast query.

Open your registry and find the key below.

Create a new DWORD value (or string for Windows 98), called "BcastNameQueryCount" and set it to equal the number of attempts.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | BcastNameQueryCount | REG_DWORD | 0x00000005 (5) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: BcastNameQueryCount
Type: REG_DWORD (DWORD Value)
Value: Number of Attempts (Default = 3)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 19, 2000


Specify the Timeout Period for Broadcast Queries (Windows 9x/Me)

Specify the Timeout Period for Broadcast Queries (Windows 9x/Me)
This setting allows you to specify the period of time the system will wait before timing out broadcast name queries.

Open your registry and find the key below.

Create a new DWORD value (or string for Windows 98) called "BcastQueryTimeout", and set it to equal the period of time in milliseconds (minimum 100).

Restart Windows for the change to take effect.

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: BcastQueryTimeout
Type: REG_DWORD (DWORD Value)
Value: Time in milliseconds (Default =750)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 19, 2000


Control Windows Treatment of Priority TCP/IP Data (Windows 9x/Me)

Control Windows Treatment of Priority TCP/IP Data (Windows 9x/Me)
This value specifies how Windows should handle urgent data transfers, either in a same manner to some UNIX systems or as specified by RFC 1122.

Open your registry and find the key below.

Create a new DWORD value (or string for Windows 98) called "BSDUrgent" and set it to equal "0" to use the RFC 1122 method or "1" to use the default UNIX method.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | BSDUrgent | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: BSDUrgent
Type: REG_DWORD (DWORD Value)
Value: (0 = use RFC1122 method, 1 = default)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 20, 2001


Specify the NetBIOS Name Cache Timeout Period (Windows 9x/Me)

Specify the NetBIOS Name Cache Timeout Period (Windows 9x/Me)
This setting specifies the period that NetBIOS names are cached before requiring an additional name query.

Open your registry and find the key below.

Create a new DWORD value (or string for Windows 98) called "CacheTimeout" and set it to equal the number of milliseconds to cache NetBIOS names (minimum 60,000 - 1 minute).

Restart Windows for the change to take effect.

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: CacheTimeout
Type: REG_DWORD (DWORD Value)
Value: Time in milliseconds (Default =360,000)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 19, 2000


Enable Dead Gateway Detection (Windows 9x/Me)

Enable Dead Gateway Detection (Windows 9x/Me)
This setting specifies whether Windows should automatically detect and use an alternate gateway in the event of a failed gateway.

Open your registry and find the key below.

Create a new DWORD value (or string for Windows 98) called "DeadGWDetect" and set it to equal "0" to disable dead gateway detection or "1" to enable it.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DeadGWDetect | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: DeadGWDetect
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 19, 2000


Specify the TCP/IP Receive Window Size (Windows 9x/Me)

Specify the TCP/IP Receive Window Size (Windows 9x/Me)
This setting controls the size of the TCP/IP receive Window. In general, larger receive windows work better with high-delay, high-bandwidth data.

For added efficiency, the receive window should also be an even multiple of the TCP Maximum Segment Size (MSS).

Open your registry and find the key below.

Create a new DWORD value (or string for Windows 98) called "DefaultRcvWindow" and set it to equal the required window size in bytes.

Restart Windows for the change to take effect.

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: DefaultRcvWindow
Type: REG_DWORD (DWORD Value)
Value: size in bytes (Default = 8192)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 20, 2001


Specify the Default TCP/IP Type of Service (TOS) (Windows 9x/Me)

Specify the Default TCP/IP Type of Service (TOS) (Windows 9x/Me)
This setting specifies the default type of service (TOS) for IP packets generated by the TCP/IP stack. This can be used to manage quality of service (QOS) throughout a network.

Open your registry and find the key below.

Create a new DWORD value called "DefaultTOS" and set it to the 8 bit number represent the default TOS for IP packets.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | DefaultTOS | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: DefaultTOS
Type: REG_DWORD (DWORD Value)
Value: 8-bit number (Default = 0)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 19, 2000


Specify the Default TCP/IP Time to Live (Windows 9x/Me)

Specify the Default TCP/IP Time to Live (Windows 9x/Me)
This setting specifies the default time to live (TTL) value for IP packets generated by the Windows TCP/IP stack.

Open your registry and find the key below.

Create new string value named "DefaultTTL" and set it to equal the required TTL.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | DefaultTTL | REG_SZ | "32" | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: DefaultTTL
Type: REG_SZ (String Value)
Value: (Default = 32)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 19, 2000


Control the DNS Port Used for Lookups (Windows 9x/Me)

Control the DNS Port Used for Lookups (Windows 9x/Me)
This setting controls which port is used for DNS lookup requests. The default is port 53, but in some firewall situations the settings can be useful to specify an alternate port.

Open your registry and find the key below.

Create a new DWORD value (or string value for Windows 98) called "DnsServerPort" and set it to equal the required port address.

Restart Windows for the change to take effect.

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: DnsServerPort
Type: REG_DWORD (DWORD Value)
Value: Port Number (Default = 53)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 19, 2000


Enable WINS Proxy Agent (Windows 9x/Me)

Enable WINS Proxy Agent (Windows 9x/Me)
This setting controls whether the current computer should act as a WINS proxy agent and forward WINS name queries.

Open your registry and find the key below.

Create a new DWORD value (or string value for Windows 98) called "EnableProxy" and set it to "1" to enable the proxy service.

Restart Windows for the change to take effect.

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: EnableProxy
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 19, 2000


Specify the Conformance Level for IP Multicast (Windows 9x/Me)

Specify the Conformance Level for IP Multicast (Windows 9x/Me)
This parameter determines to what extent the system supports IP multicasting and participates in the Internet Group Management Protocol, RFC 1112.

There are three levels or conformance:

  • Level 0: no support for IP multicasting
  • Level 1: support for sending but not receiving multicast IP datagrams
  • Level 2: full support for IP multicasting

Open your registry and find the key below.

Create a new DWORD value (or string value for Windows 98) called "IGMPLevel" and set it to either 0, 1 or 2 accord to the level required above.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | IGMPLevel | REG_DWORD | 0x00000002 (2) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: IGMPLevel
Type: REG_DWORD (DWORD Value)
Value: 0, 1 or 2 (Default = 2)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 19, 2000


Control the WINS Refresh Period (Windows 9x/Me)

Control the WINS Refresh Period (Windows 9x/Me)
This setting control the initial WINS refresh timeout value.

Open your registry and find the key below.

Create a new DWORD value (or string value for Windows 98) called "InitialRefreshT.O." and set it to equal the timeout in milliseconds. The minimum and default timeout is 960,000 milliseconds (approx 16 minutes) and the maximum is 4,294,967,295 milliseconds (approx 50 days).

Restart Windows for the change to take effect.

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: InitialRefreshT.O.
Type: REG_DWORD (DWORD Value)
Value: Time in milliseconds (Default =960,000)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 19, 2000


Control Keep Alive Parameters (Windows 9x/Me)

Control Keep Alive Parameters (Windows 9x/Me)
These settings control how Windows manages connection keep alive transmissions. Including the timeout before keepalives are sent, the interval between keepalive transmissions and how often to send session keepalive packets on active sessions.

Open your registry and find the key below.

Create new DWORD value named "KeepAliveTime" and set it to equal the number of milliseconds to wait before sending keep alive packets (the default is 2 hours - 7,200,000 milliseconds).

Also create a new DWORD value (or string value for Windows 98) called "KeepAliveInterval" and set it to equal the time in milliseconds between retransmissions of keepalives, once the KeepAliveTime has expired (the default is 1 second - 1000 milliseconds).

Also create a new DWORD value (or string value for Windows 98) called "SessionKeepAlive" and set it to equal the time in seconds between keepalive packets on active sessions (the default is 3600 second - 1 hour).

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | KeepAliveTime | REG_DWORD | 0x006DDD00 (7200000) | |
| |  | KeepAliveInterval | REG_DWORD | 0x000003e8 (1000) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: KeepAliveTime, KeepAliveInterval, SessionKeepAlive
Type: REG_DWORD (DWORD Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 19, 2000


Control the Timeout for LMHOST Name Resolution (Windows 9x/Me)

Control the Timeout for LMHOST Name Resolution (Windows 9x/Me)
This setting controls the period of time the system will wait before timing out when seeking LMHOSTS for name resolution.

Open your registry and find the key below.

Create a new DWORD value (or string value for Windows 98) called "LmhostsTimeout" and set it to equal the timeout period in milliseconds, the minimum value is 1000 (1 second).

Restart Windows for the change to take effect.

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: LmhostsTimeout
Type: REG_DWORD (DWORD Value)
Value: Time in milliseconds (Default = 10,000)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 19, 2000


Specify the Number of Simultaneous Connections (Windows 9x/Me)

Specify the Number of Simultaneous Connections (Windows 9x/Me)
This setting specifies the maximum number of concurrent connections accepted.

Open your registry and find the key below.

Create a new string value named "MaxConnections" and set it to equal the number of connections, the default is 100.

Restart Windows for the change to take effect.

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: MaxConnections
Type: REG_SZ (String Value)
Value: 32-bit Number

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 19, 2000


Control the Number of TCP/IP Connection Attempts (Windows 9x/Me)

Control the Number of TCP/IP Connection Attempts (Windows 9x/Me)
This setting controls the number of TCP/IP connection attempts (SYN packets) to be transmitted before timing out.

Open your registry and find the key below.

Create a new string value named "MaxConnectRetries" and set it to the number or retires, the default is 3.

Restart Windows for the change to take effect.

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: MaxConnectRetries
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 19, 2000


Control the Number of TCP/IP Transmission Retries (Windows 9x/Me)

Control the Number of TCP/IP Transmission Retries (Windows 9x/Me)
This setting defines the number of transmission retries will be transmitted before the connection is aborted.

Open your registry and find the key below.

Create a new string value named "MaxDataRetries" and set it to equal the number of retries, the default is 5.

Restart Windows for the change to take effect.

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: MaxDataRetries
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 19, 2000


Specify the WINS Port Number (Windows 9x/Me)

Specify the WINS Port Number (Windows 9x/Me)
This setting allows you to specify an alternate port number to use with all WINS name queries and registration requests.

Open your registry and find the key below.

Create a new DWORD value (or string value for Windows 98) called "NameServerPort" and set it to equal the required port number, the default is 137.

Restart Windows for the change to take effect.

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: NameServerPort
Type: REG_DWORD (DWORD Value)
Value: (Default = 137)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 19, 2000


Control WINS Query Settings (Windows 9x/Me)

Control WINS Query Settings (Windows 9x/Me)
These settings control the WINS query parameters including the number of query attempts and query timeout.

Open your registry and find the key below.

Create a new string value called "NameSrvQueryCount" and set it to the number of query retries, the default is 3.

Create a DWORD value (or string value for Windows 98) called "NameSrvQueryTimeout" and set it to the number of milliseconds to wait before timing out a name server query, the default is 750.

Restart Windows for the changes to take effect.

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: NameSrvQueryCount, NameSrvQueryTimeout

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 19, 2000


Specify the Number of NetBIOS Entries to Store (Windows 9x/Me)

Specify the Number of NetBIOS Entries to Store (Windows 9x/Me)
These settings control the maximum number of NetBIOS entries to store in the name and session tables.

Open your registry and find the key below.

Create a new DWORD value (or string value for Windows 98) called "NameTableSize" and set it to equal the number of entries in the name table to a maximum of 255, the default is 17.

Create a new DWORD value (or string value for Windows 98) called "SessionTableSize" and set it to equal the number of entries in the session table to a maximum of 255, the default is 255.

Restart Windows for the change to take effect.

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: NameTableSize, SessionTableSize
Type: REG_DWORD (DWORD Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 19, 2000


Specify the NetBIOS Name Resolution Mode (Windows 9x/Me)

Specify the NetBIOS Name Resolution Mode (Windows 9x/Me)
There are several modes used in the resolution of NetBIOS, including WINS and LMHOSTS lookups and broadcast queries. This setting controls which mode is used.

Open your registry and find the key below.

Create a new string value called "NodeType" and set it to equal either 1, 2, 4, or 8 where 1 = b-node, 2 = p-node, 4 = m-node, and 8 = h-node. This value can also be specified using DHCP.

Restart Windows for the change to take effect.

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: NodeType
Type: REG_SZ (String Value)
Value: 1, 2, 4, or 8

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 19, 2000


Enable MTU Black Hole Detection (Windows 9x/Me)

Enable MTU Black Hole Detection (Windows 9x/Me)
Specifies whether the stack will attempt to detect Maximum Transmission Unit (MTU) routers that do not send back ICMP fragmentation-needed messages.

Open your registry and find the key below.

Create a new DWORD value (or string value for Windows 98) named "PMTUBlackHoleDetect" and set it to either "1" to enable detection or "0" to disable it.

Restart Windows for the change to take effect.

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: PMTUBlackHoleDetect
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 19, 2000


Enable MTU Discovery (Windows 9x/Me)

Enable MTU Discovery (Windows 9x/Me)
This setting specifies whether the TCP/IP stack will attempt to perform path MTU discovery as specified in RFC 1191.

Open your registry and find the key below.

Create a new DWORD value (or string value for Windows 98) named "PMTUDiscovery" and set it to equal "1" to enable discovery or "0" to disable it.

Restart Windows for the change to take effect.

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: PMTUDiscovery
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 19, 2000


Enable Random Adapter Responses (Windows 9x/Me)

Enable Random Adapter Responses (Windows 9x/Me)
For a computer with multiple network adapters, this setting specifies whether to respond with an IP address selected randomly from the range of addresses on the computer or whether to return the IP address of the adapter that the request came in upon.

Open your registry and find the key below.

Create a new DWORD value (or string value for Windows 98) named "RandomAdapter" and set it to "1" to enable random adapter addresses or "0" to disable them (the default).

Restart Windows for the change to take effect.

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: RandomAdapter
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 19, 2000


Control TCP/IP Routing Parameters (Windows 9x/Me)

Control TCP/IP Routing Parameters (Windows 9x/Me)
These settings control IP routing features including the total amount of buffer space to allocate for routing packets and the maximum number of packets that can be routed simultaneously.

Open your registry and find the key below.

Create a DWORD value (or string value for Windows 98) called "RoutingBufSize" and set it equal the amount of buffer space to allocate for routing packets, the default is 73,216.

Create another DWORD value (or string value for Windows 98) called "RoutingPackets" and set it to equal the number of packets that can be routed simultaneously, the default is 50.

Restart Windows for the changes to take effect.

Note: These settings are ignored if EnableRouting = 0.

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: RoutingBufSize, RoutingPackets
Type: REG_DWORD (DWORD Value)
Value: 32-bit number

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 19, 2000


Specify Response Mode for Multi-Adapter Computers (Windows 9x/Me)

Specify Response Mode for Multi-Adapter Computers (Windows 9x/Me)
For a computer with multiple network adapters, this setting specifies whether to send all IP addresses on a name query request from WINS.

Open your registry and find the key below.

Create a new DWORD value (or string value for Windows 98) called "SingleResponse" and set it to equal "1" to send only one address is a name response or "0" to send all addresses.

Restart Windows for the change to take effect.

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: SingleResponse
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 19, 2000


Controls RFC 1323 Time Stamp and Window Scaling Options (Windows 9x/Me)

Controls RFC 1323 Time Stamp and Window Scaling Options (Windows 9x/Me)
This setting controls RFC 1323 time stamps and window scaling options for TCP/IP packets.

This feature has four modes of operation:

  • 0 = disable RFC 1323 options
  • 1 = window scale enabled only
  • 2 = time stamps enabled only
  • 3 = both options enabled
Open your registry and find the key below.

Create a new DWORD value named "Tcp1323Opts" and set it to equal 0, 1, 2 or 3 depending on the required mode listed above.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Tcp1323Opts | REG_DWORD | 0x00000003 (3) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: Tcp1323Opts
Type: REG_DWORD (DWORD Value)
Value: 0, 1, 2 or 3

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 19, 2000


Control the Internet Explorer Script Debugger (All Versions)

Control the Internet Explorer Script Debugger (All Versions)
When an Internet Explorer detects an error on a page it has the ability to launch a script debugger to diagnose the problem. This setting controls the use of the Internet Explorer script debugging functions.

Open your registry and find the key below.

Create a new string value, or modify the existing value, named "Disable Script Debugger" and set it to either "yes" to disable the debugger or "no" to enable it.

Restart Internet Explorer for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Disable Script Debugger | REG_SZ | "yes" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
Name: Disable Script Debugger
Type: REG_SZ (String Value)
Value: yes or no

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 26, 2000


Disable the Norton AntiVirus Splash Screen (All Versions)

Disable the Norton AntiVirus Splash Screen (All Versions)
This setting will stop the Norton AntiVirus Scanner startup logo from being shown.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, named "DisableSplashScreen" and set it to equal "1" to disable the splash screen.

The next time Norton AV is run the splash screen should not be display.

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\Norton AntiVirus\Clinic]
Name: DisableSplashScreen
Type: REG_DWORD (DWORD Value)
Value: (0 = enable splash, 1 = disabled splash)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 26, 2000


Changes the IRP Stack Size (Windows NT)

Changes the IRP Stack Size (Windows NT)
When you access shares on a computer running Windows NT Server from a Windows NT client and the IRPstackSize parameter is set too low on the server, you may receive the following error message: "Not enough server storage is available to process this command." This tweak should resolve the problem.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, named "IRPstackSize" and set it to equal the required stack size between 1 and 12, the default is 4.

Restart Windows for the change to take effect.

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\
Parameters]
Name: IRPstackSize
Type: REG_DWORD (DWORD Value)
Value: 1 - 12 (default = 4)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 26, 2000


Configure Symantec Live Update to Use Passive FTP (All Versions)

Configure Symantec Live Update to Use Passive FTP (All Versions)
Norton LiveUpdate 1.3 and higher defaults to using active FTP. This tweak allows you to configure it to use passive FTP instead.

Open your registry and find the key below.

Create a new DWORD value named "UsePassiveFtpMode" and set it to equal "1" to enable passive FTP mode.

Restart Live Update for the change to take effect.

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\LiveUpdate\Preferences]
Name: UsePassiveFtpMode
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 26, 2000


Disable User Profiles (Windows 9x/Me)

Disable User Profiles (Windows 9x/Me)
This setting can be used to disable the use of user profiles.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, named "UserProfiles" and set it to equal "0" to disable user profiles.

Restart Windows for the change to take effect.

Settings:
Key: [HKEY_LOCAL_MACHINE\Network\Logon]
Name: UserProfiles
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 26, 2000


Disable the Norton Utilities Splash Screen (All Versions)

Disable the Norton Utilities Splash Screen (All Versions)
This setting will disable the Norton Utilities splash screen from being shown whenever the applications are run.

Open your registry and find the key below.

Create new string value called "DisableSplashScreen" and set it to "1" to disable the splash screen.

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\Norton Utilities]
Name: DisableSplashScreen
Type: REG_SZ (String Value)
Value: (0 = enable splash, 1 = disabled splash)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 26, 2000


Control the Behavior of the Office Assistants (All Versions)

Control the Behavior of the Office Assistants (All Versions)
These settings control the behavior of the office assistants.

Office 2000
Open your registry and find the key below.

Office 97
Open your registry and find the key [HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Common\Assistant].

Create new DWORD values, or modify the existing values, according to the list below.

Restart any office applications for the changes to take effect.

  • AsstAssistWithWizards - Should the assistants help with Office wizards.
  • AsstAssistWithHelp - Should the assistants assist with help.
  • AsstAssistWithAlerts - Should the assistants be opened for Office alerts.
  • AsstGuessHelp - Should the assistants guess which help topics are shown.
  • AsstKeyboardShortcutTips - Specifies if tips about keyboard shortcuts should be shown.
  • AsstFeatureTips - Specifies if tips about using features more effectively should be shown.
  • AsstMouseTips - Specifies if tips about using the mouse more effectively should be shown.
  • AsstMoveWhenInTheWay - Should the assistants move when in the way.
  • AsstOnlyHighPriorityTips - Specifies if only high priority tips should be shown.
  • AsstSearchInProgram - Specifies if the assistants can search for product help while in programming mode.
  • AsstShowTipOfDay - Shows the tip of the day at startup.
  • AsstSounds - Specifies whether the assistants can makes sounds.
  • AsstTipTimeout - Specifies the number of seconds before tip bulb is brought down.
  • AsstTop - Specifies top position of the window.
  • AsstLeft - Specifies left position of the window.

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Common\Assistant]
Type: REG_DWORD (DWORD Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 26, 2000


Enable Four Digit Year Display in Microsoft Excel (All Versions)

Enable Four Digit Year Display in Microsoft Excel (All Versions)
When Excel formats a date, it uses one of several default formats, the most common is the system short date (yy). Therefore when a user types a 4-digit year (yyyy) date in Excel, it may be displayed in a 2-digit year (yy) format. This tweak changes to default the 4-digit format.

Open your registry and find the key below.

Create a new DWORD value named "EnableFourDigitYearDisplay" and set it to equal "1" to enable 4-digit dates.

Restart Excel for the change to take effect.

Settings:
Key: [HKEY_CURRENT_USER\Software\ Microsoft\Office\9.0\Excel\Options]
Name: EnableFourDigitYearDisplay
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 26, 2000


Show File and Folder Names Using the Correct Case (All Versions)

Show File and Folder Names Using the Correct Case (All Versions)
Some versions of Windows will attempt to adjust the capitalization of files and folders that are in all uppercase to make them more visually pleasing. For example, if you create a folder named "C:\ALLINCAPS" Windows will actually display it as "C:\Allincaps". This feature can be disabled using this tweak.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, called "DontPrettyPath" and set it to equal "1" to display the file using their original capitalization or "0" to adjust the caps.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DontPrettyPath | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Adv... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\
Advanced]
Name: DontPrettyPath
Type: REG_DWORD (DWORD Value)
Value: (0 = adjust caps, 1 = show caps)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 29, 2000


Launch Folder Windows in a Separate Process (Windows NT/2000)

Launch Folder Windows in a Separate Process (Windows NT/2000)
This setting controls whether each folder window is launched as a separate explorer task. The benefit of this method is that if one window has an error and crashes the others should be not be affected. The disadvantage is that it takes more system resources for each folder.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, named "SeparateProcess" and set it to "0" to disable separate processes or "1" to enable them.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SeparateProcess | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Adv... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\
Advanced]
Name: SeparateProcess
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 29, 2000


Show Compressed Files in an Alternate Color (Windows NT/2000)

Show Compressed Files in an Alternate Color (Windows NT/2000)
This setting controls whether compressed files and folders are shown in explorer using a different color to make them easily distinguishable.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, named "ShowCompColor" and set it to equal "1" to enable the use of alternate colors or "0" to use the default colors.

Restart Windows for the change to take effect.

Note: The color used to display the files and folders can be set using this tweak.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ShowCompColor | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Adv... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\
Advanced]
Name: ShowCompColor
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 20, 2001


Change the Link Color of Active Files and Folders (All Versions)

Change the Link Color of Active Files and Folders (All Versions)
This setting controls the color of the active file or folder when using the web view (single-click) display method.

Open your registry and find the key below.

Create a new string value, or modify the existing value, named "HotTrackingColor" and set it to equal an RGB color value. For example red is "255 0 0" and the default blue is "0 0 255".

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | HotTrackingColor | REG_SZ | "0 0 255" | |
-
| HKEY_CURRENT_USER\Control Panel\Colors |
-

Settings:
Key: [HKEY_CURRENT_USER\Control Panel\Colors]
Name: HotTrackingColor
Type: REG_SZ (String Value)
Value: Color in RGB

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 29, 2000


Control the Auto Complete Mode (All Versions)

Control the Auto Complete Mode (All Versions)
This setting controls whether the automatic text completion (AutoComplete) feature of Windows explorer appends the suggested text to the words as you are typing as well as showing a drop-down list of available values.

Open your registry and find the key below.

Create a new string value, or modify the existing value, named "Append Completion" and set it to "yes" to append the suggested text as you are typing or "no" to only show a drop-down list.

Restart Windows for the change to take effect.

Note: This setting also changes the auto complete functionality of Internet Explorer.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Append Completion | REG_SZ | "Yes" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Aut... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\
AutoComplete]
Name: Append Completion
Type: REG_SZ (String Value)
Value: yes or no

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 21, 2001


Use an Alternate Source Viewer with Internet Explorer (All Versions)

Use an Alternate Source Viewer with Internet Explorer (All Versions)
By default when you use the View Source feature of Internet Explorer it launches Windows notepad as the text editor. This tweak lets you choose which editor to use.

Open your registry and create the key below if it does not already exist.

Set the (Default) value to equal the full path and filename of the required text editor.

Restart Internet Explorer for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | "c:\windows\notepad.exe" | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\View Source Edit... |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\
View Source Editor\Editor Name]
Name: (Default)
Type: REG_SZ (String Value)
Value: Path and Filename of Editor

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 29, 2000


Control Printing Notification Messages (Windows NT)

Control Printing Notification Messages (Windows NT)
By default Windows NT notifies a user with a popup message that their print job has been completed on the printer. This setting controls that behavior.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, named "NetPopup" and set it to equal "0" to disable notification or "1" to enable it.

Restart the printer spooler service or restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NetPopup | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Providers |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Providers]
Name: NetPopup
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: November 1, 2000


Force the Use of Automatic Logon (Windows 2000)

Force the Use of Automatic Logon (Windows 2000)
Normally when a Windows machine is configured to automatically logon to a specified account users can bypass this and enter alternate account information. This tweak forces the machine to auto logon and to ignore any bypass attempts.

Open your registry and find the key below.

Create a new string value called "ForceAutoLogon" and set it to equal "1" to force automatic logons or "0" to allow alternate users.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ForceAutoLogon | REG_SZ | "1" | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\Winlogon |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\Winlogon]
Name: ForceAutoLogon
Type: REG_SZ (String Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: November 1, 2000


Enabling UDMA66 Mode on Intel Chipsets (Windows 2000)

Enabling UDMA66 Mode on Intel Chipsets (Windows 2000)
If you have a computer with an Intel chipset that supports UDMA66, you will still find that UDMA66 mode is disabled by default on Windows 2000 computers. This tweak enables it.

Open your registry and find the key below.

Create a new DWORD value called "EnableUDMA66" and set it to "1" to enable UDMA66 or "0" to disable it.

Restart Windows for the change to take effect.

Note: Before you enable UDMA66 mode make sure that the device supports UDMA66 mode and use an 80-pin IDE cable with the proper pin cut.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | EnableUDMA66 | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Class\{4D36E96A-E325... |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Class\
{4D36E96A-E325-11CE-BFC1-08002BE10318}\0000]
Name: EnableUDMA66
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 20, 2001


Enable Font Smoothing (All Versions)

Enable Font Smoothing (All Versions)
This setting controls whether fonts are anti-aliased to appear smoother when displayed within Windows.

Open your registry and find the key below.

Create a new string value, or modify the existing value, called "FontSmoothing" and set it to "2" to enable font smoothing or "0" to disable it.

Logoff or restart Windows for the change to take effect.

Note: Font smoothing is only effective when using high color video modes.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | FontSmoothing | REG_SZ | "2" | |
-
| HKEY_CURRENT_USER\Control Panel\Desktop |
-

Settings:
Key: [HKEY_CURRENT_USER\Control Panel\Desktop]
Name: FontSmoothing
Type: REG_SZ (String Value)
Value: (0 = disabled, 2 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: November 1, 2000


Control CoolSwitch Application Swapping (All Versions)

Control CoolSwitch Application Swapping (All Versions)
CoolSwitch is a feature available within Windows to quickly switch between tasks and programs by using the Alt + TAB keys.

Open your registry and find the key below.

Modify the value named "CoolSwitch" and set it to "0" to disable task switching or "1" to enable it.

To change the size of the CoolSwitch popup modify the values named "CoolSwitchColumns" and "CoolSwitchRows".

Logoff or restart Windows for the changes to take effect.

Hint: If you don't want to switch applications you can cancel a CoolSwitch at any time by pressing Escape.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | CoolSwitch | REG_SZ | "1" | |
-
| HKEY_CURRENT_USER\Control Panel\Desktop |
-

Settings:
Key: [HKEY_CURRENT_USER\Control Panel\Desktop]
Name: CoolSwitch
Type: REG_SZ (String Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: November 1, 2000


Check for Internet Explorer Updates (All Versions)

Check for Internet Explorer Updates (All Versions)
Internet Explorer 5 and higher has the ability to automatically check for software updates. This tweak controls that feature.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, called "NoUpdateCheck" and set it to "1" to disable the update check or "0" to enable it.

Restart Internet Explorer for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoUpdateCheck | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
Name: NoUpdateCheck
Type: REG_DWORD (DWORD Value)
Value: (0 = enable checks, 1 = disable checks)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: November 1, 2000


Prevent Account Changes in Outlook Express (All Versions)

Prevent Account Changes in Outlook Express (All Versions)
This setting disables the ability for users to create or modify any mail, news or directory accounts in Outlook Express.

Open your registry and find the key below.

Create new DWORD value called "No Modify Accts" and set it to "1" to enable the restriction or "0" to allow users to modify accounts.

Restart Outlook Express for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | No Modify Accts | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Outlook Express |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Outlook Express]
Name: No Modify Accts
Type: REG_DWORD (DWORD Value)
Value: (1 = enable restriction)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: November 1, 2000


Items in Dialog Boxes Sorted Incorrectly (Windows 98)

Items in Dialog Boxes Sorted Incorrectly (Windows 98)
When viewing files and folders from a Windows dialog box the items may be sorted incorrectly. For example, files may be listed before folders, items may be sorted in descending order, and so on. This tip should resolve this problem.

This behavior can occur if the sort order in Windows Explorer is changed from the default order.

To resolve this behavior, and reset the default sort order:

  1. Right-click Start, click Explore, and then click drive C.
  2. On the View menu, click Details.
  3. Click the Name column to sort items by name, press and hold down the CTRL key, and then quit Windows Explorer by clicking Close in the upper-right corner of the screen.
  4. Release the CTRL key.
  5. Restart your computer.
Note: You must perform these steps exactly as they are listed. For example, do not quit Windows Explorer by clicking Exit on the File menu.

Last Modified: November 1, 2000


Reverse the Mouse Buttons (All Versions)

Reverse the Mouse Buttons (All Versions)
By default the left mouse button is the primary mouse button and the right is the secondary. This tweak lets you swap those buttons around to make the right the primary, which may be useful for left handed users.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'SwapMouseButtons' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SwapMouseButtons | REG_SZ | "1" | |
-
| HKEY_CURRENT_USER\Control Panel\Mouse |
-

Settings:
Key: [HKEY_CURRENT_USER\Control Panel\Mouse]
Name: SwapMouseButtons
Type: REG_SZ (String Value)
Value: (0 for normal, 1 = swap buttons)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 1, 2000


Disable the Ability to Remotely Shutdown the Computer Browser Service (Windows NT/2000)

Disable the Ability to Remotely Shutdown the Computer Browser Service (Windows NT/2000)
It is possible for a malicious user to shut down a computer browser, or all computer browsers, on the same subnet. If all of the computers on the same subnet are shut down, they can then declare their own computer the new master browser.

Firstly download and install the patch below for your operating system:

  • Windows 2000
  • Windows NT 4.0 (Intel)
  • Windows NT 4.0 (Alpha)

Open you registry and find the key below.

Create a new DWORD value called "RefuseReset" and set it to "1" to ignore the ResetBrowser frames request.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | RefuseReset | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MrxSmb\Parameters |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MrxSmb\Parameters]
Name: RefuseReset
Type: REG_DWORD (DWORD Value)
Value: (0 = normal, 1 = refuse reset)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 5, 2000


Disable Windows File Protection (Windows 2000)

Disable Windows File Protection (Windows 2000)
Windows 2000 introduced a new feature called Windows File Protection (WFP), part of the System File Checker, which is intended to avoid some of the common DLL consistency issues. This feature may also block valid attempts to change system files and it can therefore be disabled using this tweak.

Open your registry and find the key below.

Change the value of "SFCDisable" to equal "0xffffff9d" to disable WFS or "0" to enable it. The other valid values are:

"1" for disabled, prompt at boot to re-enable
"2" for disabled at next boot only, no prompt to re-enable
"4" for enabled, with popups disabled

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SFCDisable | REG_DWORD | 0xffffff9d (4294967197) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: SFCDisable
Type: REG_DWORD (DWORD Value)
Value: (0 = enabled (default), 0xffffff9d = disabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 27, 2001


Change the Start Button Text (All Versions)

Change the Start Button Text (All Versions)
Would you like to change the Start button to say something else, perhaps your name, company or any other 5 or less letter word? This article explains the procedure to manually modify the text of the Windows Start button.

Manually changing the Start button requires the use of a binary file editor (Hex editor) to alter a critical Windows system file, it is therefore not recommended for inexperienced users. This method has been successfully tested on Windows 95, 98, ME and 2000 and therefore should be quite safe, although we do not accept any responsibility for system problems or data loss.

As mentioned before you will need to have a hex editor installed, there are many different products available and if you don't have one already a quick search of a shareware site should provide many choices, for this tweak we only require basic features.

  1. The file that needs to be changed is Windows Explorer, and it is essential to make a backup before you modify anything. "Explorer.exe" can be found in the Windows directory, usually C:\WINDOWS for Windows 95, 98 & ME and C:\WINNT for Windows NT/2000. Make a copy of "Explorer.exe" and place it into another directory, C:\BACKUP might be a good choice.

  2. Open the original "Explorer.exe" found in the Windows directory in your hex editor.

  3. You now need to find the word "Start", although there are many entries for "Start" in the file only one is used for to label the Start button. Use the search function in the hex editor to find all the strings equal to "S t a r t" which is represented as "53 00 74 00 61 00 72 00 74" in hex values. As there are many different "Start" strings keep searching until you find one located just before this text "There was an internal error and one of the windows you were using has been closed.". Below is a list of offsets to help you locate the correct text.

    • Windows 98
      Offset: 0x00028D6E - 0x00028D76
    • Windows NT4
      Offset: 0x00028BEE - 0x00028BF6
    • Windows ME
      Offset: 0x00033DDE - 0x00033DE6
    • Windows 2000
      Offset: 0x0003860E - 0x00038616

    The result should look similar to the image below, depending on the display from your hex editor.

    Hex editor display of Start text

  4. Once you have located the string, you can then replace the letters in "Start" with five other characters. You must use exactly five characters, if the word you want to use is less, replace the remaining characters with the space key. In this example we have replaced "Start" with "Guide", alternatively a three-letter word would look like "A B C" (note the spaces). Once you have changed the letters the result should look similar to the image below.

    Hex editor display of replacement text

  5. Now save the file in the Windows directory with a different file name, for example "explorer.new". You can't save it as "Explorer.exe" as that file is currently in use and can't be overwritten. Confirm that you have the two Explorer files in the Windows directory, they both should be the same file size but have different modified dates.

  6. The next step is different depending on your operating system. Only do the step required for your version.

    • Windows 95, 98 & ME
      Exit to DOS (or use a boot disk for Windows ME) and at the command prompt change to the Windows directory and rename "explorer.exe" to "explorer.old". Then copy the newly modified Explorer "explorer.new" to "explorer.exe". Do a directory listing and confirm that "explorer.exe" has the most recent modified date and time. Restart the computer and Windows should reload along with the new Start button text.

    • Windows NT/2000
      Windows 2000 users may need to firstly disable Windows file protection to stop Windows from replacing the modified file with the original. First close any open applications and open a new Command Prompt window, then switch back to the GUI and open the Task Manager. Find the "explorer.exe" process and end it, you should now be left with only the command prompt and task manager. Switch back to the command prompt and change to the Windows directory, rename "explorer.exe" to "explorer.old", and copy the newly modified Explorer "explorer.new" to "explorer.exe". Do a directory listing and confirm that "explorer.exe" has the most recent modified date and time. Switch back to Task Manager and launch a "New Task" called "explorer.exe" this should reload the shell along with your modified "Start" button.

  7. If everything has gone successfully you will now have a new Start button, and also hopefully learnt something about the Explorer file structure. If you do have problems replace the faulty Explorer with the backup made during the first step.

    Windows start menu

Last Modified: January 31, 2001


Restrict Help Menu Items in Internet Explorer (All Versions)

Restrict Help Menu Items in Internet Explorer (All Versions)
The menu items with the Internet Explorer "Help" menu can be individually removed or the menu disabled completely using this tweak.

Open your registry and find the key below.

Create new DWORD values, or modify the existing values, from the list below setting them to equal "1" to enable the restriction or "0" to disable the restriction.

  • NoHelpMenu - Disables the entire help menu
  • NoHelpItemNetscapeHelp - Removes the "For Netscape Users" menu item
  • NoHelpItemSendFeedback - Removes the "Send Feedback" menu item
  • NoHelpItemTipOfTheDay - Removes the "Tip of the Day" menu item
  • NoHelpItemTutorial - Removes the "Tour" (Tutorial) menu item

These restictions can be enforced system-wide by placing these values within the same subkey under the [HKEY_LOCAL_MACHINE] hive.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoHelpMenu | REG_DWORD | 0x00000001 (1) | |
| |  | NoHelpItemNetscapeHelp | REG_DWORD | 0x00000001 (1) | |
| |  | NoHelpItemSendFeedback | REG_DWORD | 0x00000001 (1) | |
| |  | NoHelpItemTipOfTheDay | REG_DWORD | 0x00000001 (1) | |
| |  | NoHelpItemTutorial | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Restrict... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\
Restrictions]
Type: REG_DWORD (DWORD Value)
Value: (0 = restriction disabled, 1 = restriction enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 4, 2001


Manage Attachment Security in Outlook (All Versions)

Manage Attachment Security in Outlook (All Versions)
New security measures that improve the dialog box warnings for attachments were included in Microsoft Outlook beginning with Outlook 2000 (SR-1). The file extensions that trigger the more secure warnings can be managed through the registry.

Open your registry and find the key below, if the 'Security' sub-key does not already exist then create it.

Create two new string values, or modify the existing values, called "AddWarningFileTypes" and "RemoveWarningFileTypes".

To include additional file extensions to receive the warning, add the extensions, seperated by a semicolon, to the "AddWarningFileTypes" value (not including the leading period (.)). For example, to add Word and Excel documents to this list you would set the value to equal "DOC;XLS".

Removing warnings is the same but in reverse, for example, to remove the warning for registry files and VBScript files your would set the "RemoveWarningFileTypes" value to equal "REG;VBS".

Restart Outlook for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AddWarningFileTypes | REG_SZ | "DOC;XLS" | |
| |  | RemoveWarningFileTypes | REG_SZ | "REG;VBS" | |
-
| HKEY_LOCAL_MACHINE\Software\Microsoft\Office\9.0\Outlook\Security |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Office\9.0\Outlook\Security]
Name: AddWarningFileTypes, RemoveWarningFileTypes
Type: REG_SZ (String Value)
Value: File Extensions (Seperated a Semicolon)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 17, 2001


Disable the "Log on using dial-up connection" Check Box (Windows NT/2000)

Disable the "Log on using dial-up connection" Check Box (Windows NT/2000)
During logon Windows allows users to optionally connect to a Windows domain using dial-up networking, this tweak can be used to disable that option.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'RasDisable' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: RasDisable
Type: REG_SZ (String Value)
Value: (0 = restriction disabled, 1 = restriction enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 26, 2001


Change the Size of the Windows File Protection Cache (Windows 2000)

Change the Size of the Windows File Protection Cache (Windows 2000)
The Windows File Protection feature of Windows stores copies of common DLL files and replaces them if the original becomes damaged or lost. This tweak lets you control the maximum amount of space available to be consumed by the backup DLL's.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, called "SfcQuota" and set it to the allowable disk space in megabytes (decimal mode). For example, 50Mb would be 0x00000032 (50) and 200Mb would be 0x000000c8 (200). The default value is 0 (zero) which allows unlimited space.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SfcQuota | REG_DWORD | 0x000000c8 (200) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: SfcQuota
Type: REG_DWORD (DWORD Value)
Value: Size in Megabytes (0 = unlimited (default))

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 27, 2001


Binding Multiple IP Address to a Single Network Card (Windows 9x/Me)

Binding Multiple IP Address to a Single Network Card (Windows 9x/Me)
The Windows 9x GUI does not accept having multiple IP addresses specified for a single network adapter. This tweak allows you to add additional IP addresses using the registry.

Open your registry and find the key below where the final four digits represents the network adapter. If you only have one adapter the digits will be 0000.

Within this key will be two values called "IPAddress" and "IPMask". To add additional IP addresses add the comma-separated IP and subnet mask values to both these keys respectively without using spaces.

Exit your registry and reboot for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | IPAddress | REG_SZ | "192.168.0.5,10.0.0.30" | |
| |  | IPMask | REG_SZ | "255.255.255.0,255.0.0.0" | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans\0000 |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans\0000]
Name: IPAddress, IPMask
Type: REG_SZ (String Value)
Value: Comma-separated IP and Subnet Masks

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 19, 2001


Internet Explorer Control Panel Restrictions (Part 2) (All Versions)

Internet Explorer Control Panel Restrictions (Part 2) (All Versions)
The features available within the Internet Explorer control panel (Tools -> Internet Options) can be individually managed and disabled using this tweak.

Open you registry and find the key below.

Create a new DWORD value for each restriction from the list below, set the value to equal "1" to enable the restriction or "0" to disable it.

  • "Accessibility" - disables all options under Accessibility
  • "GeneralTab" - removes General tab
  • "SecurityTab" - removes Security tab
  • "ContentTab" - removes Content tab
  • "ConnectionsTab" - removes Connections tab
  • "ProgramsTab" - removes Programs tab
  • "AdvancedTab" - removes Advanced tab
  • "CertifPers" - prevents changing Certificate options
  • "CertifSite" - removes the Personal tab from Certificate manager
  • "SecChangeSettings" - prevents changing Security Levels for the Internet Zone
  • "SecAddSites" - prevents adding Sites to ANY zone
  • "FormSuggest" - disables AutoComplete for forms
  • "FormSuggest Passwords" - prevents Prompt me to save password from being displayed
  • "Connwiz Admin Lock" - disables the Internet Connection Wizard
  • "Settings" - prevents any changes to Temporary Internet Files
  • "ResetWebSettings" - disables the Reset web Setting button

You may need to restart Windows for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Accessibility | REG_DWORD | 0x00000001 (1) | |
| |  | GeneralTab | REG_DWORD | 0x00000001 (1) | |
| |  | SecurityTab | REG_DWORD | 0x00000001 (1) | |
| |  | ContentTab | REG_DWORD | 0x00000001 (1) | |
| |  | ConnectionsTab | REG_DWORD | 0x00000001 (1) | |
| |  | ProgramsTab | REG_DWORD | 0x00000001 (1) | |
| |  | AdvancedTab | REG_DWORD | 0x00000001 (1) | |
| |  | CertifPers | REG_DWORD | 0x00000001 (1) | |
| |  | CertifSite | REG_DWORD | 0x00000001 (1) | |
| |  | SecChangeSettings | REG_DWORD | 0x00000001 (1) | |
| |  | SecAddSites | REG_DWORD | 0x00000001 (1) | |
| |  | FormSuggest | REG_DWORD | 0x00000001 (1) | |
| |  | FormSuggest Passwords | REG_DWORD | 0x00000001 (1) | |
| |  | Connwiz Admin Lock | REG_DWORD | 0x00000001 (1) | |
| |  | Settings | REG_DWORD | 0x00000001 (1) | |
| |  | ResetWebSettings | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control ... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\
Control Panel]
Type: REG_DWORD (DWORD Value)
Value: (0 = disable restriction, 1 = enable restriction)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 7, 2001


Fix AMD Athlon AGP Paging Issue (Windows 2000)

Fix AMD Athlon AGP Paging Issue (Windows 2000)
Windows 2000 based computers may stop responding when you use an Accelerated Graphics Port (AGP) program with an AMD Athlon processor. This is due to the memory allocated by the video adapter driver becoming corrupted. This registry tweak will fix the problem.

Open your registry and find the key below.

Create a new DWORD value called "LargePageMinimum" and set it to equal "0xffffffff".

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | LargePageMinimum | REG_DWORD | 0xffffffff (4294967295) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memo... |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\
Memory Management]
Name: LargePageMinimum
Type: REG_DWORD (DWORD Value)
Value: 0xffffffff (4294967295 decimal)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 20, 2001


Changing the Internet Explorer User Agent String (All Versions)

Changing the Internet Explorer User Agent String (All Versions)
Whenever a web browser is used to connect to a remote web server it includes a User Agent string that contains details about browser and operating system. This tweak allows you to add or remove additional information from this string.

A standard user agent string would look similar to:

Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Which means Internet Explorer 5.5 running on Windows 2000.

When a customized user agent string is used it may contain additional information set by the company the created the branded version of the browser. For example a branded version from an ISP may look like:

Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0; Your_ISP_Name)

Since this information is sent to the remote web server it may be stored in the web server log files and therefore possibly used to track branded versions of a web browser.

To Change This Information

Open your registry and find the key below.

Each value name listed in this key will be sent to the remote web server as an additional entry in the user agent string. To remove any additional information delete all the entries within the [Post Platform] key. To add additional entries create a string value and name it the string you want to be sent.

Restart Internet Explorer for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Your_ISP_Name | REG_SZ | "" | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Se... |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\
Internet Settings\User Agent\Post Platform]
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 6, 2001


Change the Title of Windows Media Player (All Versions)

Change the Title of Windows Media Player (All Versions)
This tweak allows you to customize the title bar text shown on Windows Media Player.

Open your registry and find the key below.

Create a new string value called "TitleBar" and set it to the text you would like display in the title.

Restart Media Player for the change the take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | TitleBar | REG_SZ | "My Media Player" | |
-
| HKEY_CURRENT_USER\Software\Policies\Microsoft\WindowsMediaPlayer |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Policies\Microsoft\WindowsMediaPlayer]
Name: TitleBar
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 27, 2001


Remove the Minimize, Maximize and Close Tooltips (All Versions)

Remove the Minimize, Maximize and Close Tooltips (All Versions)
When you move your mouse over the three control boxes on a standard Window frame it will show tooltip text for each item. This tweak controls that function.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'MinMaxClose' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Settings:
Key: [HKEY_CURRENT_USER\Control Panel\Desktop]
Name: MinMaxClose
Type: REG_SZ (String Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 28, 2001


Remove the Hand Icon for Shared Resources (All Versions)

Remove the Hand Icon for Shared Resources (All Versions)
Normally when you share a local resource on the network a hand icon is placed under the item to show it is shared. With this tweak you can remove the icon.

Open your registry and find the [SharingHandler] key below.

To remove the icon clear the current data from the "(Default)" value. To restore the icon to the default enter one of the filenames listed below for your OS.

Restart Windows for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | "" | |
-
| HKEY_CLASSES_ROOT\Network\SharingHandler |
-

Settings:
Key: [HKEY_CLASSES_ROOT\Network\SharingHandler]
Name: (Default)
Type: REG_SZ (String Value)
Value: (blank = No Icon, "msshrui.dll" for Windows 9x, "ntshrui.dll" for Windows NT)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 27, 2001


Change the Number of Undo Levels in Excel 2000 (All Versions)

Change the Number of Undo Levels in Excel 2000 (All Versions)
This tweak lets you modify the amount of undo history information that Excel will track. Increasing this value allows you to undo more than the default number of changes.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'UndoHistory' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | UndoHistory | REG_DWORD | 0x00000064 (100) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Excel\Options |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Excel\Options]
Name: UndoHistory
Type: REG_DWORD (DWORD Value)
Value: Number of Undo Levels

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 27, 2001


Enable System File Protection Popup Notifications (Windows Me)

Enable System File Protection Popup Notifications (Windows Me)
This tweak controls whether a popup notification message is shown when the System File Protection (SFP) service performs an action.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'ShowPopups' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ShowPopups | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\ SystemFile... |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\
SystemFileProtection]
Name: ShowPopups
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 27, 2001


Windows File Checker Command-line Options (Windows 2000)

Windows File Checker Command-line Options (Windows 2000)
The Windows File Checker is used to scans all the protected system files and replaces incorrect versions with a cached copy of the correct version. These are the command-line options to control the Windows file protection (WFP) utility.

The System File Checker is initiated with using the "SFC" command. Below are the command-line option which can be used with this utility.

/SCANNOW     Scans all protected system files immediately.
/SCANONCE    Scans all protected system files once at the next boot.
/SCANBOOT    Scans all protected system files at every boot.
/CANCEL      Cancels all pending scans of protected system files.
/QUIET       Replaces all incorrect file versions without prompting
             the user.
/ENABLE      Enables Windows File Protection for normal operation
/PURGECACHE  Purges the file cache and scans all protected system
             files immediately.
/CACHESIZE=x Sets the file cache size

Last Modified: February 27, 2001


Set the Dr Watson Log Directory (Windows NT/2000)

Set the Dr Watson Log Directory (Windows NT/2000)
This tweak is used to set the directory that stores the log files created by the Dr. Watson utility.

Open your registry and find the key below.

Create a new Expanded String value, or modify the existing value called 'LogFilePath' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | LogFilePath | REG_SZ | "C:\WINNT\LOGS" | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DrWatson |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DrWatson]
Name: LogFilePath
Type: REG_EXPAND_SZ (Expanded String Value)
Value: Directory Path

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 28, 2001


Control the Log File Creation Method of Dr Watson (Windows NT/2000)

Control the Log File Creation Method of Dr Watson (Windows NT/2000)
This tweak controls whether the Dr. Watson utility creates a new log file or appends data to the old log file for each application error that occurs.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'AppendToLogFile' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AppendToLogFile | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DrWatson |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DrWatson]
Name: AppendToLogFile
Type: REG_DWORD (DWORD Value)
Value: (0 = new, 1 = append)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 28, 2001


Control Whether Dr Watson Creates a Crash Dump (Windows NT/2000)

Control Whether Dr Watson Creates a Crash Dump (Windows NT/2000)
This tweak controls whether the Dr. Watson utility creates a crash dump file after an application crash has occured.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'CreateCrashDump' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DrWatson]
Name: CreateCrashDump
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 28, 2001


Specify the Location of the Dump File (Windows NT/2000)

Specify the Location of the Dump File (Windows NT/2000)
This tweak allows you to specify the path and filename to use when creating a crash dump file.

Open your registry and find the key below.

Create a new Expanded String value, or modify the existing value called 'CrashDumpFile' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | CrashDumpFile | REG_SZ | "C:\WINNT\DUMP\APP.DMP" | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DrWatson |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DrWatson]
Name: CrashDumpFile
Type: REG_EXPAND_SZ (Expanded String Value)
Value: File Location

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 28, 2001


Control Whether Dr Watson Alerts Using Sound (Windows NT/2000)

Control Whether Dr Watson Alerts Using Sound (Windows NT/2000)
This tweak controls whether the Dr. Watson utility uses sound notification, i.e. a WAV file, to alert during an application error.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'SoundNotification' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SoundNotification | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DrWatson |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DrWatson]
Name: SoundNotification
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 28, 2001


Control Whether Dr Watson Alerts Using Popups (Windows NT/2000)

Control Whether Dr Watson Alerts Using Popups (Windows NT/2000)
This tweak controls whether the Dr. Watson utility display a message box when it encounters an application error.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'VisualNotification' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | VisualNotification | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DrWatson |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DrWatson]
Name: VisualNotification
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 28, 2001


Specify the Wave File for Sound Notification (Windows NT/2000)

Specify the Wave File for Sound Notification (Windows NT/2000)
This tweak is used to specify the path and filename of the wave file to be played during an application error if sound notification has been enabled.

Open your registry and find the key below.

Create a new Expanded String value, or modify the existing value called 'WaveFile' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | WaveFile | REG_SZ | "C:\MEDIA\ALERT.WAV" | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DrWatson |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DrWatson]
Name: WaveFile
Type: REG_EXPAND_SZ (Expanded String Value)
Value: File Location

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 28, 2001


Control Thread Dumping in Dr Watson (Windows NT/2000)

Control Thread Dumping in Dr Watson (Windows NT/2000)
This tweak controls whether the Dr. Watson utility should dump the contents of all threads during an application error.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'DumpAllThreads' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DumpAllThreads | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DrWatson |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DrWatson]
Name: DumpAllThreads
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 28, 2001


Control Symbol Dumping in Dr Watson (Windows NT/2000)

Control Symbol Dumping in Dr Watson (Windows NT/2000)
This tweak controls whether the Dr. Watson should dump the contents of the symbol tables during an application error.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'DumpSymbols' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DumpSymbols | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DrWatson |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DrWatson]
Name: DumpSymbols
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 28, 2001


Specify the Number of Instructions to Record (Windows NT/2000)

Specify the Number of Instructions to Record (Windows NT/2000)
This tweak specifies the number of instructions for Dr. Watson to record during an application error.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'Instructions' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Instructions | REG_DWORD | 0x0000000a (10) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DrWatson |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DrWatson]
Name: Instructions
Type: REG_DWORD (DWORD Value)
Value: Number

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 28, 2001


Control the Display of Popup Error Messages (Windows NT/2000)

Control the Display of Popup Error Messages (Windows NT/2000)
This tweak is used to control which error messages are displayed as popups, and also allows you disable the use of popup error dialog boxes entirely.

Open your registry and find the key below.

Modify the value of "ErrorMode" according to the options below.

Value  Description
-----  -----------
  0    All errors appear in popups (Default)
  1    System errors disabled, application errors still
       using popups
  2    Neither system or application errors use popups

Note: This setting does not affect error logging, any errors will still be logged as normal.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ErrorMode | REG_DWORD | 0x00000002 (2) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Windows |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Windows]
Name: ErrorMode
Type: REG_DWORD (DWORD Value)
Value: (0 = all errors, 1 = application errors, 2 = no popups)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 28, 2001


Control Whether Windows Reboots After a Crash (Windows NT/2000)

Control Whether Windows Reboots After a Crash (Windows NT/2000)
This tweak controls whether Windows should automatically reboot after a crash or system failure.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'CrashControl' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | CrashControl | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control]
Name: CrashControl
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = auto reboot)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 28, 2001


Send Administrative Alerts of System Crashes (Windows NT/2000)

Send Administrative Alerts of System Crashes (Windows NT/2000)
This setting controls whether Windows should send an alert to the Administrator when a system crashes.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'SendAlert' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SendAlert | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CrashControl |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CrashControl]
Name: SendAlert
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 28, 2001


Control Whether Windows Logs a System Crash

Control Whether Windows Logs a System Crash
This setting controls whether Windows logs a system crash to the event log, this will allow the exact time of the crash to be permanently recorded.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'LogEvent' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | LogEvent | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CrashControl |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CrashControl]
Name: LogEvent
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 28, 2001


Create a System Crash Dump File (Windows NT/2000)

Create a System Crash Dump File (Windows NT/2000)
This setting controls whether Windows creates a dump file of the computer memory when a system crashes.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'CrashDumpEnabled' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | CrashDumpEnabled | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CrashControl |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CrashControl]
Name: CrashDumpEnabled
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 28, 2001


Specify the System Crash Dump File Location (Windows NT/2000)

Specify the System Crash Dump File Location (Windows NT/2000)
This tweak is used to specify the location where the dump file should be written after a system crash.

Open your registry and find the key below.

Create a new Expanded String value, or modify the existing value called 'DumpFile' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DumpFile | REG_SZ | "C:\WINNT\MEMORY.DMP" | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CrashControl |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CrashControl]
Name: DumpFile
Type: REG_EXPAND_SZ (Expanded String Value)
Value: File Location

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 28, 2001


Control the Dump Creation Method (Windows NT/2000)

Control the Dump Creation Method (Windows NT/2000)
This tweak controls whether the system should create a new dump file and overwrite the existing file or whether it should append data to the old dump file when a system crash occurs.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'Overwrite' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Overwrite | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CrashControl |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CrashControl]
Name: Overwrite
Type: REG_DWORD (DWORD Value)
Value: (0 = append, 1 = overwrite)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 28, 2001


Run Startup Programs in a Command Prompt (Windows 2000)

Run Startup Programs in a Command Prompt (Windows 2000)
This setting allows you to specify commands or programs to be automatically executed whenever a command processor is launched. For example, to set environment variables or parameters using a batch file.

Open your registry and find the key below.

Create a new string value called "AutoRun" and set the value to equal the commands to be automatically executed. Multiple commands should be seperated by double ampersands e.g. "command1 && command2".

The changes will take effect the next time the command processor is used.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AutoRun | REG_SZ | "c:\batch\environ.bat" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Command Processor |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Command Processor]
Name: AutoRun
Type: REG_SZ (String Value)
Value: Command to Execute

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 8, 2001


Disable Command Processor Extensions (Windows 2000)

Disable Command Processor Extensions (Windows 2000)
This setting controls whether command extensions are enabled or disabled. When command extensions are used they change the behaviour of various standard command processor functions such as CD, MD, DEL, PROMPT and SET.

Open your registry and find the key below.

Create a new DWORD value called "EnableExtensions" and set it "1" to enable extensions or "0" to disable them (default is enabled).

The command extensions involve changes and/or additions to the following commands:

DEL or ERASE
COLOR
CD or CHDIR
MD or MKDIR
PROMPT
PUSHD
POPD
SET
SETLOCAL
ENDLOCAL
IF
FOR
CALL
SHIFT
GOTO
START
ASSOC
FTYPE

To get specific details, type commandname /? to view the help.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | EnableExtensions | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Command Processor |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Command Processor]
Name: EnableExtensions
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 8, 2001


Enable Delayed Environment Variable Expansion (Windows 2000)

Enable Delayed Environment Variable Expansion (Windows 2000)
This setting allows you to enable or disable delayed environment variable expansion in the command processor. If this feature is enabled then exclaimation characters can be used to substitute the value of an environment variable at execution time.

Open your registry and find the key below.

Create a new DWORD value called "DelayedExpansion" and set it to equal "1" to enabled variable expansion or "0" to disable it.

Delayed expansion will be available the next time the command processor is used. To access variables surround the variable name with exclaimation characters i.e. "!varname!". For example to echo the PATH variable you could use the following command:

echo !path!

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DelayedExpansion | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Command Processor |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Command Processor]
Name: DelayedExpansion
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 8, 2001


Enable Path Command Line Completion (Windows 2000)

Enable Path Command Line Completion (Windows 2000)
Path completion is similiar to the concept of command completion. This setting allows you to specify a key, that when pressed completes the remainder of an incomplete directory name.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, called 'PathCompletionChar' and set it to equal the hex value of the required control character. For example to use the TAB key set the value to '9', to use Ctrl-D set the value to '4' and for Ctrl-F set the value to '6'.

Now when you are using a command prompt and type the first part of a directory name then press the specified key, Windows will complete the remainder for you. Pressing the key multiple times will scroll through the available options.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | PathCompletionChar | REG_DWORD | 0x00000009 (9) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Command Processor |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Command Processor]
Name: PathCompletionChar
Type: REG_DWORD (DWORD Value)
Value: Hex Control Character

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 8, 2001


Prevent Uploading Folders to a Users Server Profile (Windows NT/2000)

Prevent Uploading Folders to a Users Server Profile (Windows NT/2000)
When profiles are used and a user logs off from a Windows NT domain certain folders are uploaded to the central user profile on the server. This setting allows you to stop any time consuming or non-essential folders (e.g. Temporary Internet Files) from being transferred.

Open your registry and find the key below.

Create a new string value called "ExcludeProfileDirs" and set it to equal the directory names to be excluded from the upload. The directory names should be entered relative to the root of the profile, and must be separated by semicolons.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ExcludeProfileDirs | REG_SZ | Temporary Internet Files;Personal | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: ExcludeProfileDirs
Type: REG_SZ (String Value)
Value: Directories to Exclude

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 26, 2001


Change the Number of Recent Documents to Display (Windows 2000)

Change the Number of Recent Documents to Display (Windows 2000)
This setting is used to specify the number of documents and files that are kept in the recent documents section of the Start menu.

Open your registry and find the key below.

Create a new DWORD value called "MaxRecentDocs" and set it to equal the number of documents to display in the recent documents list, the default is 15.

Restart Windows for the change to take efftec.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | MaxRecentDocs | REG_DWORD | 0x0000001e (30) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: MaxRecentDocs
Type: REG_DWORD (DWORD Value)
Value: Number of Documents (32-bit)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 4, 2001


Control the Mouse "Snap To" Feature (All Versions)

Control the Mouse "Snap To" Feature (All Versions)
When enabled, this setting causes the mouse pointer to snap-to the default button of the active application window.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'SnapToDefaultButton' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | SnapToDefaultButton | REG_SZ | "1" | |
-
| HKEY_CURRENT_USER\Control Panel\Mouse |
-

Settings:
Key: [HKEY_CURRENT_USER\Control Panel\Mouse]
Name: SnapToDefaultButton
Type: REG_SZ (String Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 4, 2001


View the System BIOS Information (Windows NT/2000)

View the System BIOS Information (Windows NT/2000)
This registry key stores information about the system BIOS, including the release date, version number and video BIOS date.

Open your registry and find the key below for information on the system BIOS.

These values are read-only and can not be changed.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SystemBiosDate | REG_SZ | "12/30/99" REG_SZ | |
-
| HKEY_LOCAL_MACHINE\HARDWARE\DESCRIPTION\System |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\HARDWARE\DESCRIPTION\System]
Name: SystemBiosDate, SystemBiosVersion, VideoBiosDate
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 4, 2001


Specify Users to Receive Administrative Alerts (Windows NT/2000)

Specify Users to Receive Administrative Alerts (Windows NT/2000)
This setting is used to specify a list of users and/or computers that should receive administrative alerts.

Open your registry using REGEDT32 and find the key below.

Modify the REG_MULTI_SZ value called "AlertNames" and on a seperate line enter each user or computer to receive the alerts.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AlertNames | REG_MULTI_SZ | "jsmith jdoe" | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Alerter\Parameters |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Alerter\Parameters]
Name: AlertNames
Type: REG_MULTI_SZ (Multi-String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 4, 2001


Specify the Schedule for Alerter Service (Windows NT/2000)

Specify the Schedule for Alerter Service (Windows NT/2000)
This setting is used to specify how often the server checks alert conditions and sends any required alert messages to administrative users.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'AlertSched' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AlertSched | REG_DWORD | 0x00000005 (5) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parame... |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\
Parameters]
Name: AlertSched
Type: REG_DWORD (DWORD Value)
Value: 1 to 65535 minutes

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 4, 2001


Specify the Server Announcement Frequency (Windows NT/2000)

Specify the Server Announcement Frequency (Windows NT/2000)
Specifies how often a nonhidden server announces itself to the network. More frequent announcements keep client server tables more up to date, but may increase network overhead and processing on client computers, because the clients must process every announcement.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'Announce' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Announce | REG_DWORD | 0x000000f0 (240) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parame... |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\
Parameters]
Name: Announce
Type: REG_DWORD (DWORD Value)
Value: 1 to 65535 seconds (Default is 240)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 4, 2001


Specify the Server Announcement Spacing (Windows NT/2000)

Specify the Server Announcement Spacing (Windows NT/2000)
This parameter specifies the time by which the server announcement period can vary. This helps to prevent several servers from continuously announcing simultaneously, thereby reducing network load peaks.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'AnnDelta' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AnnDelta | REG_DWORD | 0x00000bb8 (3000) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parame... |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\
Parameters]
Name: AnnDelta
Type: REG_DWORD (DWORD Value)
Value: 0 to 65535 milliseconds (Default is 3000)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 4, 2001


Include a Comment in the Server Announcement (Windows NT/2000)

Include a Comment in the Server Announcement (Windows NT/2000)
This setting allows you to specify a comment which is sent in server announcements and returned to NetServerGetInfo requests.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'Comment' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Comment | REG_SZ | "Primary Mail Server" | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parame... |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\
Parameters]
Name: Comment
Type: REG_SZ (String Value)
Value: Text String

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 4, 2001


Specify the Idle Timeout for Server Connnections (Windows NT/2000)

Specify the Idle Timeout for Server Connnections (Windows NT/2000)
Specifies the amount of idle time that a circuit is allowed before being disconnected. If this parameter is set to a low value, it saves server resources but reduces performance because of client overhead in reconnecting.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'Disc' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Disc | REG_DWORD | 0x0000000F (15) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parame... |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\
Parameters]
Name: Disc
Type: REG_DWORD (DWORD Value)
Value: 0 to infinite minutes (Default is 15)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 4, 2001


Control MS-DOS File Control Blocks (FCBs) Usage on Servers (Windows NT/2000)

Control MS-DOS File Control Blocks (FCBs) Usage on Servers (Windows NT/2000)
Specifies whether MS-DOS File Control Blocks (FCBs) are folded together, so multiple remote opens are performed as a single open on the server to save resources.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'EnableFCBopens' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | EnableFCBopens | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parame... |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\
Parameters]
Name: EnableFCBopens
Type: REG_DWORD (DWORD Value)
Value: 0 = disabled, 1 = enabled (Default is 1)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 4, 2001


Control the Ability to Use HTTP Mail in Outlook Express (All Versions)

Control the Ability to Use HTTP Mail in Outlook Express (All Versions)
This tweak is used to specify whether HTTP mail servers, such as Hotmail, can be used or created in Outlook Express.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'HTTP Mail Enabled' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | HTTP Mail Enabled | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Outlook Express |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Outlook Express]
Name: HTTP Mail Enabled
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 4, 2001


Manage Windows File Protection Scans (Windows 2000)

Manage Windows File Protection Scans (Windows 2000)
This setting controls whether the Windows File Checker (SFC) should scan and replace the protected files during boot up.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'SFCScan' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SFCScan | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: SFCScan
Type: REG_DWORD (DWORD Value)
Value: 0 = disabled, 1 = scan every boot, 2 = scan once

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 4, 2001


Specify the Directory to Store Cached SFC Files (Windows 2000)

Specify the Directory to Store Cached SFC Files (Windows 2000)
This entry is used to specify which directory the Windows File Checker (SFC) should use to store the cached copies of protected files.

Open your registry and find the key below.

Create a new Expanded String value, or modify the existing value called 'SFCDllCacheDir' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SFCDllCacheDir | REG_SZ | "C:\WINNT\SFC" | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: SFCDllCacheDir
Type: REG_EXPAND_SZ (Expanded String Value)
Value: Qualified Directory

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 4, 2001


Display SFC Progress Meter (Windows 2000)

Display SFC Progress Meter (Windows 2000)
Specifies whether the Windows File Checker (SFC) progress meter should be displayed during file checking.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'SFCShowProgress' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SFCShowProgress | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: SFCShowProgress
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 4, 2001


Specify the Default Internet Explorer Download Directory (All Versions)

Specify the Default Internet Explorer Download Directory (All Versions)
This setting is used to specify which directory should be used as the default location to save downloaded files retrieved using Internet Explorer.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'Download Directory' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Download Directory | REG_SZ | "C:\My Files" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer]
Name: Download Directory
Type: REG_SZ (String Value)
Value: Qualified Directory

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 20, 2001


Specify the Print Server Broadcast Timeout (Windows NT/2000)

Specify the Print Server Broadcast Timeout (Windows NT/2000)
This setting is used to specify the timeout period between broadcasts of a print servers resources.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, named "ServerThreadTimeout" and set it to equal the time in milliseconds between broadcasts, the default is 600,000 (10 minutes).

Restart Windows or the service for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ServerThreadTimeout | REG_DWORD | 0x000927C0 (600000) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print]
Name: ServerThreadTimeout
Type: REG_DWORD (DWORD Value)
Value: Timeout in milliseconds

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 20, 2001


Specify the Printer Browser Timeout (Windows NT/2000)

Specify the Printer Browser Timeout (Windows NT/2000)
This setting is used to specify the time a network printer should remain in the browse list before it is removed.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NetPrinterDecayPeriod' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NetPrinterDecayPeriod | REG_DWORD | 0x00036EE80 (3600000) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print]
Name: NetPrinterDecayPeriod
Type: REG_DWORD (DWORD Value)
Value: 0 to 4294967295 milliseconds (Default is 3,600,000)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 20, 2001


Hide the Search Button on the Explorer Toolbar (Windows 2000)

Hide the Search Button on the Explorer Toolbar (Windows 2000)
This restriction allows you to remove the search button from the "Standard Buttons" toolbar in Windows explorer.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoShellSearchButton' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoShellSearchButton | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoShellSearchButton
Type: REG_DWORD (DWORD Value)
Value: (0 = display, 1 = remove)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 20, 2001


Disable ScanDisk After Improper Shutdown (Windows Me)

Disable ScanDisk After Improper Shutdown (Windows Me)
Normally if a system is shutdown improperly scandisk will run on the next reboot to ensure the contents of the hard disk are valid. This setting stops scandisk from running automatically when restarting.

Open your registry and find the key below.

Create a new Binary value, or modify the existing value called 'DisableScandiskOnBoot' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DisableScandiskOnBoot | REG_BINARY | 00 00 00 01 | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem]
Name: DisableScandiskOnBoot
Type: REG_BINARY (Binary Value)
Value: 01

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 1, 2001


Disable Tracking of Shell Shortcuts (Windows 2000)

Disable Tracking of Shell Shortcuts (Windows 2000)
This setting is used to control the use of the tracking-based method of resolving shell shortcuts on NTFS partitions.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoResolveTrack' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoResolveTrack | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoResolveTrack
Type: REG_DWORD (DWORD Value)
Value: (0 = resolve, 1 = do not resolve)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 2, 2001


Control the Use of Dynamic Domain Name System (Windows 2000)

Control the Use of Dynamic Domain Name System (Windows 2000)
Windows 2000 supports dynamic Domain Name System (DDNS) updates and is enabled by default for Windows 2000 DNS clients. This setting allows you to control whether network adapters should send updates.

Open your registry and find the key below.

Modify the value named "DisableDynamicUpdate" and set it to equal "1" to disable the use of dynamic updates.

Restart Windows for the changes to take effect.

Note: This can also be controlled on a per adapter basis by modifying the same value at HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\ Parameters\Interfaces\[Adapter ID].

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DisableDynamicUpdate | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]
Name: DisableDynamicUpdate
Type: REG_DWORD (DWORD Value)
Value: (0 = enable updates, 1 = disable updates)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 2, 2001


Implement a User Based Custom Shell (Windows 2000)

Implement a User Based Custom Shell (Windows 2000)
Windows 2000 allows you to selectively specify the system shell based on the logged in user. For example this allows one user to use the standard explorer interface and another to use the legacy progman shell.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'Shell' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Shell | REG_SZ | progman.exe | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
System]
Name: Shell
Type: REG_SZ (String Value)
Value: Filename of Replacement Shell

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 20, 2001


Use an Alternative User Interface (Windows NT/2000)

Use an Alternative User Interface (Windows NT/2000)
This setting allows you to specify an alternate shell to use as the Windows user interface instead of the default explorer shell.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'Shell' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Shell | REG_SZ | explorer.exe | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: Shell
Type: REG_SZ (String Value)
Value: Filename of Replacement Shell

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 20, 2001


Disable the Creation of Last Known Good (Windows NT/2000)

Disable the Creation of Last Known Good (Windows NT/2000)
This setting allows you to disable the creation of the LastKnownGood configuration, which stores a copy of the configuration after each successful boot-up.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'ReportBootOk' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ReportBootOk | REG_SZ | "0" | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: ReportBootOk
Type: REG_SZ (String Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 20, 2001


Remove the Ability to Modify File Types (Windows 2000)

Remove the Ability to Modify File Types (Windows 2000)
This setting allows you to remove the ability to change, add or delete file types using explorer the Folder Options interface.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoFileAssociate' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoFileAssociate | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Ex... |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoFileAssociate
Type: REG_DWORD (DWORD Value)
Value: (0 = buttons enabled, 1 = buttons disabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 20, 2001


Remove the Windows NT Security Menu Item (Windows Terminal Server)

Remove the Windows NT Security Menu Item (Windows Terminal Server)
This setting is used to hide the Windows NT Security menu item on the Start Menu of a terminal server session.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoNtSecurity' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoNtSecurity | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoNtSecurity
Type: REG_DWORD (DWORD Value)
Value: (0 = display, 1 = remove)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 20, 2001


Remove the Disconnect Menu Item (Windows Terminal Server)

Remove the Disconnect Menu Item (Windows Terminal Server)
This setting is used to hide the Disconnect menu item on a terminal server Start menu.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoDisconnect' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoDisconnect | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoDisconnect
Type: REG_DWORD (DWORD Value)
Value: (0 = display, 1 = remove)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 20, 2001


Limit Bandwidth with the QoS Packet Scheduler Service (Windows 2000)

Limit Bandwidth with the QoS Packet Scheduler Service (Windows 2000)
This setting allows you to specify combined percentage of Quality of Service traffic through a specific adapater.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NonBestEffortLimit' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NonBestEffortLimit | REG_DWORD | 0x00000032 (50) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Psched\Parameters\A... |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Psched\Parameters\
Adapters\[Adpater-ID]]
Name: NonBestEffortLimit
Type: REG_DWORD (DWORD Value)
Value: Decimal Percentage

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 20, 2001


Enable Manual Crash Feature (Windows 2000)

Enable Manual Crash Feature (Windows 2000)
Microsoft Windows 2000 includes a feature that enables you to have the system stop responding and generate a Memory.dmp file (crash to blue-screen) by using a button combination on the keyboard.

This feature is disabled by default. To enable this feature, open your registry and find the key below.

Create a new DWORD value called "CrashOnCtrlScroll" and set it to "1" to enable keyboard initiated crashes.

After restarting the computer, you can generate a system to stop responding by holding down the right CTRL key and pressing the SCROLL LOCK key twice.

Note: Pressing left CTRL key does not generate the system to stop responding.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | CrashOnCtrlScroll | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\i8042prt\Parameters |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\i8042prt\Parameters]
Name: CrashOnCtrlScroll
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 20, 2001


Create a Oakley Log for IPSec Troubleshooting (Windows 2000)

Create a Oakley Log for IPSec Troubleshooting (Windows 2000)
Enabling this setting causes Windows to create an Oakley.log file in the %SystemRoot%\debug folder for developers or network administrators with advanced IKE knowledge.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'EnableLogging' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | EnableLogging | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\PolicyAgent\Oakley |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\PolicyAgent\Oakley]
Name: EnableLogging
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 20, 2001


Specify an Alternate Debugging Utility (Windows NT/2000)

Specify an Alternate Debugging Utility (Windows NT/2000)
By default Windows uses Dr Watson as the debugger when a system crash occurs. This setting allows you to specify an alternate utility such as Visual Studio or Norton CrashGuard.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'Debugger' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Debugger | REG_SZ | "drwtsn32 -p %ld -e %ld -g" | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AeDebug |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AeDebug]
Name: Debugger
Type: REG_SZ (String Value)
Value: Filename

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 20, 2001


Specify the Program to Play Inserted Audio-CDs (All Versions)

Specify the Program to Play Inserted Audio-CDs (All Versions)
This value is used to specify which program should be used to play an audio CD when it is inserted and the autostart feature is enabled.

Open your registry and find the key below.

Create a new String value, or modify the existing value called '(Default)' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | "cdplayer.exe /play %1" | |
-
| HKEY_CLASSES_ROOT\AudioCD\Shell\Play\Command |
-

Settings:
Key: [HKEY_CLASSES_ROOT\AudioCD\Shell\Play\Command]
Name: (Default)
Type: REG_SZ (String Value)
Value: Command-line to Execute

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 20, 2001


Use High Memory for DOS Drivers (Windows 9x/Me)

Use High Memory for DOS Drivers (Windows 9x/Me)
This setting causes Windows to load the local DOS devices into high memory and freeing up more low memory for DOS applications.

Open your SYSTEM.INI and add the line:

LocalLoadHigh=1
Under the [386Enh] section.

Settings:
Key: [[386Enh]]
Name: LocalLoadHigh
Value: 1

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 20, 2001


Open and Save Dialog Box Customization (Windows 2000)

Open and Save Dialog Box Customization (Windows 2000)
These settings allow you to remove the places bar, most-recently-used (MRU) list and the back button from the common dialog boxes.

Open your registry and find the key below.

Create a new DWORD value named according to the table below and set it to "1" to hide the button.

  • NoBackButton - Hides the back button
  • NoFileMRU - Hides the most-recently-used (MRU) list
  • NoPlacesBar - Hides the places bar
    •

    Registry Editor Example
    | | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoBackButton | REG_DWORD | 0x00000001 (1) | |
| |  | NoFileMRU | REG_DWORD | 0x00000001 (1) | |
| |  | NoPlacesBar | REG_DWORD | 0x00000001 (1) | |
    -
    | HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Com... |
    -

    Settings:
    Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
    Comdlg32]
    Name: NoFileMRU, NoBackButton, NoPlacesBar
    Type: REG_DWORD (DWORD Value)
    Value: (0 = display, 1 = remove)

    Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

    Last Modified: May 21, 2001


Remove Items from Office Places Bar (All Versions)

Remove Items from Office Places Bar (All Versions)
This tweak is used to remove items from the Places Bar in the Office 2000/XP Open and Save As dialog boxes.

Open your registry and find the key below. For Office XP replace "9.0" with "10.0" in the registry key, as Office XP is internally known as Office 10.

Below this key is a series of sub-key representing the items on the Places Bar. Open each item you want to hide and add a new DWORD value named "Show" and set it to "0" to hide that item.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Show | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Common\Open Find\Places\... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Common\Open Find\Places\
StandardPlaces]
Name: Show
Type: REG_DWORD (DWORD Value)
Value: (0 = hide, 1 = show)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 21, 2001


Add Custom Places to the Office Dialog Box (All Versions)

Add Custom Places to the Office Dialog Box (All Versions)
This tweak is used to add custom places to the Office 2000 and Office XP Open and Save As dialog boxes.

Open your registry and find the key below. For Office XP replace "9.0" with "10.0" in the registry key, as Office XP is internally known as Office 10.

For each custom place create a new sub-key called "PlaceX" where X is a unique number starting at 1 (i.e. Place1, Place2 ...). Open the new sub-key and create two new string values called "Name" and "Path" and set them to equal the display name and folder path respectively.

Restart Office for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Name | REG_SZ | "My Music Folder" | |
| |  | Path | REG_SZ | "c:\music" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Common\Open Find\Places\... |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Common\Open Find\Places\
UserDefinedPlaces]
Name: Name, Path
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 21, 2001


Prevent the Office Clipboard Toolbar from Appearing (All Versions)

Prevent the Office Clipboard Toolbar from Appearing (All Versions)
When you copy multiple items in any of the Microsoft Office programs, the Office Clipboard appears, allowing you to collect and paste multiple items stored in the toolbar. This tweak allows you to prevent the toolbar from automatically appearing.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'AcbControl' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AcbControl | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Common\General |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Common\General]
Name: AcbControl
Type: REG_DWORD (DWORD Value)
Value: (0 = appears, 1 = disabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 21, 2001


Disable Office 2000 Tune Up (All Versions)

Disable Office 2000 Tune Up (All Versions)
This setting is used to disable the Office tune up feature.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'Disabled' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Disabled | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\Software\Microsoft\Office\9.0\Common\TuneUp |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Office\9.0\Common\TuneUp]
Name: Disabled
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = disabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 21, 2001


Disable Media Player Upgrade Message (All Versions)

Disable Media Player Upgrade Message (All Versions)
This setting allows you to disable the automatic Media Player upgrade message that appears when a new version of the player has been released.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'AskMeAgain' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AskMeAgain | REG_SZ | "no" | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MediaPlayer\PlayerUpgrade |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MediaPlayer\PlayerUpgrade]
Name: AskMeAgain
Type: REG_SZ (String Value)
Value: "yes" or "no"

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 21, 2001


Remove Items from Media Player (All Versions)

Remove Items from Media Player (All Versions)
This tweak allows you to remove the Radio Bar, Media Favorites and Finding New Station from Windows Media Player.

Open your registry and find the key below.

For each item you want to remove create a new DWORD value according to the values below and set it to equal "1" for disabled.

Restart Media Player for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoRadioBar | REG_DWORD | 0x00000001 (1) | |
| |  | NoMediaFavorites | REG_DWORD | 0x00000001 (1) | |
| |  | NoFindNewStations | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\WindowsMediaPlayer |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\WindowsMediaPlayer]
Name: NoRadioBar, NoMediaFavorites, NoFindNewStations
Type: REG_DWORD (DWORD Value)
Value: (0 = appears, 1 = disabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 21, 2001


Disable the Custom Search Page in Internet Explorer (All Versions)

Disable the Custom Search Page in Internet Explorer (All Versions)
This setting allows you to diable the use of the custom search page in Internet Explorer.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'Use Custom Search URL' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Use Custom Search URL | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
Name: Use Custom Search URL
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 21, 2001


Disable the Go Button in Internet Explorer (All Versions)

Disable the Go Button in Internet Explorer (All Versions)
This setting is used to remove the "Go" button from the Internet Explorer toolbar.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'ShowGoButton' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ShowGoButton | REG_SZ | "no" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
Name: ShowGoButton
Type: REG_SZ (String Value)
Value: "yes" or "no"

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 21, 2001


Disable Internet Explorer Download Notification (All Versions)

Disable Internet Explorer Download Notification (All Versions)
This setting is used to disable download notification in Internet Explorer 5.0.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'NotifyDownloadComplete' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NotifyDownloadComplete | REG_SZ | "no" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
Name: NotifyDownloadComplete
Type: REG_SZ (String Value)
Value: "yes" or "no"

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 21, 2001


Disable Document Editing Time Tracking (All Versions)

Disable Document Editing Time Tracking (All Versions)
Whenever you open a Office document the time open is tracked and added to the total "Edit Time". This tweak disables that tracking.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoTrack' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoTrack | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Common\General |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Common\General]
Name: NoTrack
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = disable tracking)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 21, 2001


Configure Office to Use the Standard System Font (All Versions)

Configure Office to Use the Standard System Font (All Versions)
This setting causes Microsoft office to use the standard system font for the user interface instead of the default Office font.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'UseOfficeUIFont' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | UseOfficeUIFont | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Common\General |
-

Settings:
Key: [HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Common\General]
Name: UseOfficeUIFont
Type: REG_DWORD (DWORD Value)
Value: (0 = system, 1 = default)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 21, 2001


Change the MSN Messenger Background Image (All Versions)

Change the MSN Messenger Background Image (All Versions)
This tweak allows you to change the background bitmap image in the MSN Messenger service.

Locate the installation directory for MSN Messenger on your system (e.g. "C:\Program Files\Messenger"). This location can also be found in the registry in the "InstallationDirectory" value at [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MessengerService].

Rename the "lvback.gif" file in the installation directory to "lvback.old". Then copy and rename the new background GIF file to the same directory as "lvback.gif".

Restart MSN Messenger for the change to take effect.

Last Modified: May 21, 2001


Change the Start Page for Outlook Express (All Versions)

Change the Start Page for Outlook Express (All Versions)
This setting can be used to change the page that Outlook Express loads in the right-hand window when it first starts-up.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'FrontPagePath' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | FrontPagePath | REG_SZ | "http://www.winguides.com/" | |
-
| HKEY_CURRENT_USER\Identities\[Identity]\Software\Microsoft\Outlook Expre... |
-

Settings:
Key: [HKEY_CURRENT_USER\Identities\[Identity]\Software\Microsoft\
Outlook Express\5.0]
Name: FrontPagePath
Type: REG_SZ (String Value)
Value: URL or Filename

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 21, 2001


Create a Desktop Shortcut to Hotmail (All Versions)

Create a Desktop Shortcut to Hotmail (All Versions)
This tweak can be used to create a shortcut directly to your Hotmail e-mail account on your desktop.

Right-click on your desktop and create a new shortcut. For Windows NT/2000 set the target to:

%windir%\System32\rundll32.exe
"%ProgramFiles%\Internet Explorer\hmmapi.dll",OpenInboxHandler

for Windows 9x/Me set it to:

rundll32 "C:\Program
Files\Internet Explorer\hmmapi.dll",OpenInboxHandler

Click "Finish" and click the icon to launch Hotmail.

Last Modified: May 31, 2001


Disable Run Commands Specified in the Registry (Windows 2000)

Disable Run Commands Specified in the Registry (Windows 2000)
This restriction is used to disable the ability to run startup programs specified in the registry when Windows launches.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'DisableLocalMachineRun' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DisableLocalMachineRun | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Ex... |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: DisableLocalMachineRun
Type: REG_DWORD (DWORD Value)
Value: (0 = enable run, 1 = disable run)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 20, 2001


Manage Foreground and Background Task Priority (Windows NT)

Manage Foreground and Background Task Priority (Windows NT)
This setting is used to manage the relative priority between foreground and background applications, this is normally accessed through Control Panel > System > Performance.

Open your registry and find the key below.

Modify the existing value, or create a new value, called "Win32PrioritySeparation" and set it to a valid DWORD value from the information below.

Windows NT Workstation

  • 0 - foreground and background threads get the same amount of processor time
  • 1 - foreground processes get more processor time than background processes
  • 2 - Foreground processes get much more processor time than background processes

Windows NT Server

The processor time that threads receive is fixed and the value instead determines the priority boost given to foreground processes, with 2 being the highest boost.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Win32PrioritySeparation | REG_DWORD | 0x00000002 (2) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\PriorityControl |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\PriorityControl]
Name: Win32PrioritySeparation
Type: REG_DWORD (DWORD Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 20, 2001


Decrease the TIME_WAIT Timeout to Increase Connections (Windows NT/2000)

Decrease the TIME_WAIT Timeout to Increase Connections (Windows NT/2000)
This setting determines the length of time that a connection will stay in the TIME_WAIT state before being closed. The default is 240 seconds which on a busy server will limit the maximum connections to around 200/sec. Reducing this setting will increase the maximum connection limit.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'TcpTimedWaitDelay' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | TcpTimedWaitDelay | REG_DWORD | 0x0000001e (30) | |
-
| HKEY_LOCAL_MACHINE\System\CurrectControlSet\Services\Tcpip\Parameters |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrectControlSet\Services\Tcpip\Parameters]
Name: TcpTimedWaitDelay
Type: REG_DWORD (DWORD Value)
Value: 30-300 seconds (decimal)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 20, 2001


Modify the Initial Retransmission Timeout (Windows NT/2000)

Modify the Initial Retransmission Timeout (Windows NT/2000)
This parameter controls the initial retransmission timeout used by TCP on each new connection. It applies to the connection request (SYN) and to the first data segment(s) sent on each connection.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'InitialRtt' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | InitialRtt | REG_DWORD | 0x00000bb8 (3000) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters]
Name: InitialRtt
Type: REG_DWORD (DWORD Value)
Value: 0-65535 milliseconds (decimal)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 20, 2001


Specify the WinSock Database Files Location (Windows NT/2000)

Specify the WinSock Database Files Location (Windows NT/2000)
This parameter specifies the path to the standard internet database files (HOSTS, LMHOSTS, NETWORKS, PROTOCOLS) used by the Windows Sockets interface.

Open your registry and find the key below.

Create a new Expanded String value, or modify the existing value called 'DatabasePath' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DatabasePath | REG_EXPAND_SZ | %SystemRoot%\system32\drivers\etc | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters]
Name: DatabasePath
Type: REG_EXPAND_SZ (Expanded String Value)
Value: Filename

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 20, 2001


Change TCP/IP Broadcast Address (Windows NT/2000)

Change TCP/IP Broadcast Address (Windows NT/2000)
This setting allows Windows to be configured to use zeros-broadcasts (0.0.0.0) instead of ones-broadcasts (255.255.255.255). Most systems use ones-broadcasts, but some systems derived from BSD implementations use zeros-broadcasts.

Open your registry and find the key below. For Windows 2000 instead use the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ Tcpip\Parameters\Interfaces\[Adapter ID] key.

Create a new DWORD value called "UseZeroBroadcast" and set it to "1" to enable 0.0.0.0 broadcasts.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | UseZeroBroadcast | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\[Adapter Name]\Para... |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\[Adapter Name]\
Parameters\Tcpip]
Name: UseZeroBroadcast
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = use 0.0.0.0 broadcast)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 20, 2001


Enable Source Routing on Token Ring Networks (Windows NT/2000)

Enable Source Routing on Token Ring Networks (Windows NT/2000)
Setting this parameter to 1 will force TCP/IP to transmit ARP queries with source routing enabled on Token Ring networks. By default, the stack transmits ARP queries without source routing first and retries with source routing enabled if no reply was received.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'ArpAlwaysSourceRoute' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ArpAlwaysSourceRoute | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters]
Name: ArpAlwaysSourceRoute
Type: REG_DWORD (DWORD Value)
Value: (0 = false, 1 = true)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 21, 2001


Transmit Ethernet Packets Using 802.3 SNAP Encoding (Windows NT/2000)

Transmit Ethernet Packets Using 802.3 SNAP Encoding (Windows NT/2000)
Enabling this setting forces TCP/IP to transmit Ethernet packets using 802.3 SNAP encoding. By default, the stack transmits packets in DIX Ethernet format. It will always receive both formats.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'ArpUseEtherSNAP' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ArpUseEtherSNAP | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters]
Name: ArpUseEtherSNAP
Type: REG_DWORD (DWORD Value)
Value: (0 = false, 1 = true)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 20, 2001


Specify the Default TCP/IP Type of Service (TOS) (Windows NT)

Specify the Default TCP/IP Type of Service (TOS) (Windows NT)
This setting specifies the default type of service (TOS) for IP packets generated by the TCP/IP stack. This can be used to manage quality of service (QOS) throughout a network.

Open your registry and find the key below.

Create a new DWORD value called "DefaultTOS" and set it to the 8 bit number represent the default TOS for IP packets.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | DefaultTOS | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters]
Name: DefaultTOS
Type: REG_DWORD (DWORD Value)
Value: 0 - 255 (See RFC 791 for a definition of the values)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 20, 2001


Specify the Default TCP/IP Time to Live (Windows NT/2000)

Specify the Default TCP/IP Time to Live (Windows NT/2000)
Specifies the default Time To Live (TTL) value set in the header of outgoing IP packets. The TTL determines the maximum amount of time an IP packet may live in the network without reaching its destination. It is effectively a limit on the number of routers an IP packet may pass through before being discarded.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'DefaultTTL' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | DefaultTTL | REG_DWORD | 0x00000080 (128) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters]
Name: DefaultTTL
Type: REG_DWORD (DWORD Value)
Value: 1-255 hops

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 20, 2001


Enable Dead Gateway Detection (Windows NT/2000)

Enable Dead Gateway Detection (Windows NT/2000)
This setting specifies whether Windows should automatically detect and use an alternate gateway in the event of transmiting a segment several times without receiving a response.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'EnableDeadGWDetect' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | EnableDeadGWDetect | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters]
Name: EnableDeadGWDetect
Type: REG_DWORD (DWORD Value)
Value: (0 = false, 1 = true)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 20, 2001


Detect Black Hole Routers During Path MTU Discovery (Windows NT/2000)

Detect Black Hole Routers During Path MTU Discovery (Windows NT/2000)
Specifies whether the stack will attempt to detect Maximum Transmission Unit (MTU) routers that do not send back ICMP fragmentation-needed messages.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'EnablePMTUBHDetect' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | EnablePMTUBHDetect | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters]
Name: EnablePMTUBHDetect
Type: REG_DWORD (DWORD Value)
Value: (0 = false, 1 = true)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 20, 2001


Enable Path MTU Discovery (Windows NT/2000)

Enable Path MTU Discovery (Windows NT/2000)
Enabling the setting causes TCP to attempt to discover the Maximum Transmission Unit (MTU or largest packet size) over the path to a remote host. By discovering the Path MTU and limiting TCP segments to this size, TCP can eliminate fragmentation at routers along the path that connect networks with different MTUs.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'EnablePMTUDiscovery' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | EnablePMTUDiscovery | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters]
Name: EnablePMTUDiscovery
Type: REG_DWORD (DWORD Value)
Value: (0 = false, 1 = true)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 20, 2001


Specify the Router Buffer Size (Windows NT/2000)

Specify the Router Buffer Size (Windows NT/2000)
This parameter determines how much memory IP allocates to store packet data in the router packet queue. When this buffer space is filled, the router begins discarding packets at random from its queue.

Note: Packet queue data buffers are 256 bytes in length, so the value of this parameter should be a multiple of 256. Multiple buffers are chained together for larger packets. The IP header for a packet is stored separately. This parameter is ignored and no buffers are allocated if the IP router is not enabled.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ForwardBufferMemory | REG_DWORD | 0x00012200 (74240) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters]
Name: ForwardBufferMemory
Type: REG_DWORD (DWORD Value)
Value: 0 - 0xFFFFFFFF Buffer Size in Bytes

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 20, 2001


Specify the Conformance Level for IP Multicast (Windows NT/2000)

Specify the Conformance Level for IP Multicast (Windows NT/2000)
This parameter determines to what extent the system supports IP multicasting and participates in the Internet Group Management Protocol, RFC 1112.

There are three levels or conformance:

  • Level 0: no support for IP multicasting
  • Level 1: support for sending but not receiving multicast IP datagrams
  • Level 2: full support for IP multicasting

Open your registry and find the key below.

Create a new DWORD value called "IGMPLevel" and set it to either 0, 1 or 2 accord to the level required above.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | IGMPLevel | REG_DWORD | 0x00000002 (2) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters]
Name: IGMPLevel
Type: REG_DWORD (DWORD Value)
Value: 0, 1 or 2 (Default = 2)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 20, 2001


Control Keep Alive Parameters (Windows NT/2000)

Control Keep Alive Parameters (Windows NT/2000)
These settings control how Windows manages connection keep alive transmissions. Including the timeout before keepalives are sent and the interval between keepalive transmissions.

Open your registry and find the key below.

Create new DWORD value named "KeepAliveTime" and set it to equal the number of milliseconds to wait before sending keep alive packets (the default is 2 hours - 7,200,000 milliseconds).

Also create a new DWORD value (or string value for Windows 98) called "KeepAliveInterval" and set it to equal the time in milliseconds between retransmissions of keepalives, once the KeepAliveTime has expired (the default is 1 second - 1000 milliseconds).

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | KeepAliveTime | REG_DWORD | 0x006DDD00 (7200000) | |
| |  | KeepAliveInterval | REG_DWORD | 0x000003e8 (1000) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters]
Name: KeepAliveTime, KeepAliveInterval
Type: REG_DWORD (DWORD Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 20, 2001


Specify the Router Packet Queue Size (Windows NT/2000)

Specify the Router Packet Queue Size (Windows NT/2000)
This parameter determines the number of IP packet headers allocated for the router packet queue. When all headers are in use, the router will begin to discard packets at random from the queue.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NumForwardPackets' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NumForwardPackets | REG_DWORD | 0x00000032 (50) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters]
Name: NumForwardPackets
Type: REG_DWORD (DWORD Value)
Value: 1 - 0xFFFFFFFF

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 20, 2001


Specify the Maximum Number of TCP/IP Connections (Windows NT/2000)

Specify the Maximum Number of TCP/IP Connections (Windows NT/2000)
This parameter specifies the maximum number of connections that TCP may have open simultaneously.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'TcpNumConnections' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | TcpNumConnections | REG_DWORD | 0x00fffffe (16777214) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters]
Name: TcpNumConnections
Type: REG_DWORD (DWORD Value)
Value: 0 - 0xfffffe

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 20, 2001


Control Windows Treatment of Priority TCP/IP Data (Windows NT/2000)

Control Windows Treatment of Priority TCP/IP Data (Windows NT/2000)
This parameter determines whether TCP uses the RFC 1122 specification for urgent data or the mode used by BSD- derived systems. The two mechanisms interpret the urgent pointer in the TCP header and the length of the urgent data differently.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'TcpUseRFC1122UrgentPointer' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | TcpUseRFC1122UrgentPointer | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters]
Name: TcpUseRFC1122UrgentPointer
Type: REG_DWORD (DWORD Value)
Value: (0 = false, 1 = use RFC1122 method)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 20, 2001


Control Selective Acknowledgement (SACK) Operation (Windows NT/2000)

Control Selective Acknowledgement (SACK) Operation (Windows NT/2000)
This parameter controls whether or not Selective ACK (SACK - RFC 2018) support is enabled. With SACK enabled (default), a packet or series of packets can be dropped, and the receiver informs the sender which data has been received, and where there may be "holes" in the data.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'SackOpts' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SackOpts | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters]
Name: SackOpts
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 21, 2001


Controls RFC 1323 Time Stamp and Window Scaling Options (Windows NT/2000)

Controls RFC 1323 Time Stamp and Window Scaling Options (Windows NT/2000)
This setting controls RFC 1323 timestamps and window scaling options. Timestamps and Window scaling are enabled by default, but can be manipulated with flag bits.

This feature has four modes of operation:

  • 0 = disable RFC 1323 options
  • 1 = window scale enabled only
  • 2 = time stamps enabled only
  • 3 = both options enabled
Open your registry and find the key below.

Create a new DWORD value named "Tcp1323Opts" and set it to equal 0, 1, 2 or 3 depending on the required mode listed above.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Tcp1323Opts | REG_DWORD | 0x00000003 (3) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters]
Name: Tcp1323Opts
Type: REG_DWORD (DWORD Value)
Value: 0,1,2 or 3

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 20, 2001


Specify System-wide TCP Receive Window Size (Windows 2000)

Specify System-wide TCP Receive Window Size (Windows 2000)
The TcpWindowSize parameter can be used to set the receive window on a per-interface basis. This parameter can be used to set a global limit for the TCP window size on a system-wide basis.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'GlobalMaxTcpWindowSize' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | GlobalMaxTcpWindowSize | REG_DWORD | 0x00007fff (32767) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters]
Name: GlobalMaxTcpWindowSize
Type: REG_DWORD (DWORD Value)
Value: 0–0x3FFFFFFF

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 20, 2001


Specify System-wide TCP Receive Window Size (Windows 98)

Specify System-wide TCP Receive Window Size (Windows 98)
The TcpWindowSize parameter can be used to set the receive window on a per-interface basis. This parameter can be used to set a global limit for the TCP window size on a system-wide basis.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, called 'GlobalMaxTcpWindoSize' and edit the value according to the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: This is not a spelling mistake, Windows 98 contains a TCP stack bug which looks for the wrong value name (see KB article Q239731) instead of "GlobalMaxTcpWindowSize".

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | GlobalMaxTcpWindoSize | REG_DWORD | 0x00007fff (32767) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\VxD\MSTCP\Parameters |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\VxD\MSTCP\
Parameters]
Name: GlobalMaxTcpWindoSize
Type: REG_DWORD (DWORD Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 21, 2001


Modify the Number of Duplicate ACKs for Fast Retransmit (Windows 2000)

Modify the Number of Duplicate ACKs for Fast Retransmit (Windows 2000)
This parameter determines the number of duplicate ACKs that must be received for the same sequence number of sent data before "fast retransmit" is triggered to resend the segment that has been dropped in transit.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'TcpMaxDupAcks' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | TcpMaxDupAcks | REG_DWORD | 0x00000002 (2) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters]
Name: TcpMaxDupAcks
Type: REG_DWORD (DWORD Value)
Value: 1-3 (default =2)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 21, 2001


License Agreement

License Agreement

LICENSE: WinGuides.com grants you a nonexclusive license to use the accompanying copyrighted software program(s) (the "SOFTWARE"), which includes any associated software components, and any online or electronic documentation, subject to the terms and restrictions set forth in this License Agreement. By installing, copying, or otherwise using the SOFTWARE, you agree to be bound by the terms of this License Agreement. You are not permitted to lease, rent, distribute or sublicense the Software or to use the Software in a time-sharing arrangement or in any other unauthorized manner. Further, no license is granted to you in the human readable code of the Software (source code). Except as provided below, this License Agreement does not grant you any rights to patents, copyrights, trade secrets, trademarks, or any other rights in respect to the Software.

RESTRICTIONS: Modification, reverse engineering, reverse compiling, or disassembly of the SOFTWARE is expressly prohibited, except and only to the extent that such activity is expressly permitted by applicable law.

NO WARRANTY: THE SOFTWARE AND DOCUMENTATION ARE PROVIDED ON AN "AS IS" BASIS AND ALL RISK IS WITH YOU. BECAUSE THE SOFTWARE AND DOCUMENTATION ARE PROVIDED TO YOU FREE OF CHARGE, WINGUIDES.COM MAKES NO WARRANTIES, EXPRESS, IMPLIED OR STATUTORY, AS TO ANY MATTER WHATSOEVER. IN PARTICULAR, ANY AND ALL WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE OR NON-INFRINGEMENT OF THIRD PARTIES RIGHTS ARE EXPRESSLY EXCLUDED. FURTHER, WINGUIDES.COM MAKES NO REPRESENTATIONS OR WARRANTIES THAT THE SOFTWARE AND DOCUMENTATION PROVIDED ARE FREE OF ERRORS OR VIRUSES OR THAT THE SOFTWARE AND DOCUMENTATION ARE SUITABLE FOR YOUR INTENDED USE.

LIMITATION OF LIABILITY: IN NO EVENT SHALL WINGUIDES.COM OR ITS SUPPLIERS BE LIABLE TO YOU OR ANY OTHER PARTY FOR ANY INCIDENTAL, SPECIAL OR CONSEQUENTIAL DAMAGES, LOSS OF DATA OR DATA BEING RENDERED INACCURATE, LOSS OF PROFITS OR REVENUE, OR INTERRUPTION OF BUSINESS IN ANY WAY ARISING OUT OF OR RELATED TO THE USE OR INABILITY TO USE THE SOFTWARE AND/OR DOCUMENTATION, REGARDLESS OF THE FORM OF ACTION, WHETHER IN CONTRACT, TORT (INCLUDING NEGLIGENCE), STRICT PRODUCT LIABILITY OR OTHERWISE, EVEN IF ANY REPRESENTATIVE OF WINGUIDES.COM OR ITS SUPPLIERS HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. THIS DISCLAIMER OF LIABILITY FOR DAMAGES WILL NOT BE AFFECTED BY ANY FAILURE OF THE SOLE AND EXCLUSIVE REMEDIES HEREUNDER.

Should you have any questions concerning this License Agreement, or if you desire to contact WinGuides.com for any reason, please contact WinGuides.com by electronic mail at: info@winguides.com.