Windows 2000 Resource Kit Performance Counters Start Page

to search for a performance counter

our Web site for updates

related resources

give comments at our Web site

Performance Counters Reference

The Windows 2000 Performance Counters Reference describes all performance objects and counters provided for use with tools in the Performance snap-in of Windows 2000. Use this reference to learn how monitoring counter values can assist you in diagnosing problems or detecting bottlenecks in your system.

© Copyright 1985-2000
Microsoft Corporation. All rights reserved.


Windows 2000 Performance Counters Reference

This Help file provides a reference to the performance counters used by System Monitor and Performance Logs and Alerts, programs hosted by the Performance console in Windows 2000. These counters collect and present information about system performance when you configure a graph, log, or alert to be monitored.

This Help file contains the following topics:

  • Overview of Performance Data Collection. Defines performance objects, counters, and instances.
  • Windows 2000 System Performance Counters. Describes the standard performance counters installed when you install Windows 2000.
  • Counters by Feature. Describes the performance counters that are associated with optional services or features.
  • Counters by Object. Describes performance counters, grouped by object.
  • Bottleneck Detection Counters. Describes performance counters used to identify bottlenecks in your system.

© 1985-2000 Microsoft Corporation. All rights reserved.


Overview of Performance Data Collection

Windows 2000 defines the performance data it collects in terms of objects, counters, and instances. A performance object is any resource, application, or service that can be measured. Using System Monitor and Performance Logs and Alerts, you can select performance objects, counters, and instances to collect and present data about the performance of system components or installed software.

Each object has performance counters that are used to measure various aspects of performance, such as transfer rates for disks or, for processors, the amount of processor time consumed. The object may also have an instance, which is a unique copy of a particular object type; not all object types support multiple instances.

This Help file describes objects, counters, and instances using the following syntax:

\\Computer_name\Object(ParentInstance/ObjectInstance#InstanceIndex)\Counter
  • The \\Computer component is optional; it specifies the name of the computer. The local computer is the default.
  • The \Object component specifies the performance object that contains the performance counter. If this object has a variable list of instances, then an instance string is included.
  • The (ParentInstance/ObjectInstance#InstanceIndex) component is only required if the object supports multiple instances. The format of the string depends on the object type. If the object has single instances, the format is the instance name enclosed in parentheses. For example:
    (Explorer)
  • For objects with multiple instances, the parent instance name comes before the object instance, and is separated by a forward slash ( / ) character. For example:
    (Explorer/0)
  • If the object has multiple instances that have the same name string, they can be indexed sequentially by specifying the instance index (a number starting with "1") preceded by a pound sign. Instance indexes are zero-based, so all instances have an implicit zero index. For example:
    (Explorer/0#1)
  • The \Counter component is required; it specifies the performance counter.

An instance called _Total instance is available on most objects and represents the sum of the values for all instances of the object for a specific counter.

In addition to the counter descriptions provided in this Help file, you can click the Explain button in the Add Counters dialog box in System Monitor or Performance Logs and Alerts to display counter descriptions.


Counter Types

Each counter is assigned a counter type. The counter type determines how the counter data is calculated, averaged, and displayed. The Performance console supports more than 30 counter types, although many of the available counter types are not implemented in the counters installed with Windows 2000.

This section describes all supported counter types, including the following information.

Counter type name The name of the counter type. The System Monitor counter descriptions in this Help file include the name of the counter type. You can click the counter name in the description to see a definition of the counter.

Description A brief description of the counter type, including a description of the formula by which counters of that type are calculated and displayed.

Generic type The general category that represents the display format counter. Generic types include:

  • Average. These counters measure a value over time and display the average of the last two measurements.
  • Difference. These counters subtract the last measurement from the previous one and display the difference, if it is positive; if negative, they display a zero.
  • Instantaneous. These counters display the most recent measurement.
  • Percentage. These counters display calculated values as a percentage.
  • Rate. Similar to an average counter, these counters sample an increasing count of events over time and divide the cache in count values by the change in time to display a rate of activity.

Formula Describes how to convert the raw data and other components, such as performance frequency, to arrive at the formatted counter value for display in the Performance console. The variables N and D appear in the formula to describe the two distinct data components, such as raw data and performance frequency, used to calculate the displayed counter values.

For each counter type, the notation of the formula can include the following variables:

Variable | Description
B | A base-value variable. Some counter types require the use of a counter base that supplies a stored value for calculating their formatted value. That base value is the denominator in the formula for the counter type. When describing counter types with multiple samplings, B is shown with numbered subscripts, such as B0 for the oldest sampling, B1 for the next more recent sampling, and Bn for the latest sampling.
N | The numerator, typically the first variable. For the purposes of the calculation formulas in this section, N is used to describe the raw counter data.
D | The denominator, typically the second variable, as needed.

The following table describes the types of counter bases and the counter types that they support.

Base Type | Description | Corresponding Counter Types
PERF_AVERAGE_BASE | Stores the denominator for calculating a counter to present "time per operation" or "count per operation." | PERF_AVERAGE_BULK PERF_AVERAGE_TIMER
PERF_COUNTER_MULTI_BASE | Indicates the number of items sampled. It is used as the denominator in the calculations to get an average among the items sampled when taking timings of multiple, but similar items. | PERF_100NSEC_MULTI_TIMER PERF_100NSEC_MULTI_TIMER_INV PERF_COUNTER_MULTI_TIMER PERF_COUNTER_MULTI_TIMER_INV
PERF_RAW_BASE | Stores the denominator of a counter that presents a general arithmetic fraction. | PERF_RAW_FRACTION
PERF_SAMPLE_BASE | Stores the number of sampling interrupts taken and is used as a denominator in the sampling fraction. The sampling fraction is the number of samples that were 1 (or TRUE) for a sample interrupt. | PERF_SAMPLE_FRACTION

Average The mathematical formula used to calculate averages of the formatted counter data.

Example An example of the specified counter type. Click the counter name in the example to see a description of that counter.

Additional information pertaining to how System Monitor formats raw data, such as data size and display suffix, appears in the Platform SDK.


PERF_100NSEC_MULTI_TIMER

Description | This counter type shows the active time of one or more components as a percentage of the total time of the sample interval. It measures time in 100ns units. This counter type is a multitimer. Multitimers are designed to monitor more than one instance of a component, such as a processor or disk.
Generic type | Percentage
Formula | ((N1 - N0) / (D1 - D0)) x 100 / B, where the denominator (D) represents the total elapsed time of the sample interval, the numerator (N) represents the portions of the sample interval during which the monitored components were active, and the variable B denotes the base count for the monitored components.
Average | ((Nx - N0) / (Dx - D0) ) x 100 / B
Example | There are no counters of this type installed with Windows 2000.

Note Image Note

The Network Segment\ % Network Utilization counter installed by Network Monitor defines the variable B as the available bandwidth, rather than monitored components.


PERF_100NSEC_MULTI_TIMER_INV

Description | This counter type shows the active time of one or more components as a percentage of the total time of the sample interval. Counters of this type measure time in 100 nanosecond (ns) units. They derive the active time by measuring the time that the components were not active and subtracting the result from multiplying 100 percent by the number of objects monitored. This counter type is an inverse multitimer. Multitimers are designed to monitor more than one instance of a component, such as a processor or disk. Inverse counters measure the time that a component is not active and derive its active time from the measurement of inactive time.
Generic type | Percentage
Formula | (B - ((N1 - N0) / (D1 - D0))) x 100, where the denominator (D) represents the total elapsed time of the sample interval, the numerator (N) represents the time during the interval when monitored components were inactive, and B represents the number of components being monitored.
Average | (B - ((Nx - N0) / (Dx - D0))) x 100
Example | There are no counters of this type installed with Windows 2000.

See also

  • PERF_100NSEC_MULTI_TIMER


PERF_100NSEC_TIMER

Description | This counter type shows the active time of a component as a percentage of the total elapsed time of the sample interval. It measures time in units of 100ns. Counters of this type are designed to measure the activity of one component at a time.
Generic type | Percentage
Formula | (N1 - N0) / (D1 - D0) x 100 where the denominator (D) represents the total elapsed time of the sample interval and the numerator (N) represents the portions of the sample interval during which the monitored components were active.
Average | (Nx - N0) / (Dx - D0) x 100
Example | Processor\ % User Time


PERF_100NSEC_TIMER_INV

Description | This counter type shows the average percentage of active time observed during the sample interval. This is an inverse counter. Counters of this type calculate active time by measuring the time that the service was inactive and then subtracting the percentage of active time from 100 percent.
Generic type | Percentage
Formula | (1- ((N1 - N0) / (D1 - D0))) x 100, where the denominator (D) represents the total elapsed time of the sample interval and the numerator (N) represents the time during the interval when the monitored components were inactive.
Average | (1- ((Nx - N0) / (Dx - D0))) x 100
Example | Processor\ % Processor Time


PERF_AVERAGE_BULK

Description | This counter type shows how many items are processed, on average, during an operation. Counters of this type display a ratio of the items processed (such as bytes sent) to the number of operations completed. The ratio is calculated by comparing the number of items processed during the last interval to the number of operations completed during the last interval.
Generic type | Average
Formula | (N1 - N0) / (D1 - D0), where the numerator (N) represents the number of items processed during the last sample interval and the denominator (D) represents the number of operations completed during the last two sample intervals.
Average | (Nx - N0) / (Dx - D0)
Example | PhysicalDisk\ Avg. Disk Bytes/Transfer


PERF_AVERAGE_TIMER

Description | This counter type measures the time it takes, on average, to complete a process or operation. Counters of this type display a ratio of the total elapsed time of the sample interval to the number of processes or operations completed during that time. This counter type measures time in ticks of the system clock. The F variable represents the number of ticks per second. The value of F is factored into the equation so that the result can be displayed in seconds.
Generic type | Average
Formula | ((N1 - N0) / F) / (D1 - D0), where the numerator (N) represents the number of ticks counted during the last sample interval, F represents the frequency of the ticks, and the denominator (D) represents the number of operations completed during the last sample interval.
Average | ((Nx - N0) / F) / (Dx - D0)
Example | PhysicalDisk\ Avg. Disk sec/Transfer


PERF_COUNTER_BULK_COUNT

Description | This counter type shows the average number of operations completed during each second of the sample interval. Counters of this type measure time in ticks of the system clock. The F variable represents the number of ticks per second. The value of F is factored into the equation so that the result can be displayed in seconds. This counter type is the same as the PERF_COUNTER_COUNTER type, but it uses larger fields to accommodate larger values.
Generic type | Difference
Formula | (N1 - N0) / ( (D1 - D0) / F, where the numerator (N) represents the number of operations performed during the last sample interval, the denominator (D) represent the number of ticks elapsed during the last sample interval, and F is the frequency of the ticks.
Average | (Nx - N0) / ((Dx - D0)/ F)
Example | System\ File Read Bytes/sec


PERF_COUNTER_COUNTER

Description | This counter type shows the average number of operations completed during each second of the sample interval. Counters of this type measure time in ticks of the system clock. The F variable represents the number of ticks per second. The value of F is factored into the equation so that the result can be displayed in seconds.
Generic type | Difference
Formula | (N1- N0) / ( (D1-D0) / F), where the numerator (N) represents the number of operations performed during the last sample interval, the denominator (D) represents the number of ticks elapsed during the last sample interval, and F is the frequency of the ticks.
Average | (Nx - N0) / ((Dx - D0) / F)
Example | System\ File Read Operations/sec


PERF_COUNTER_DELTA

Description | This counter type shows the change in the measured attribute between the two most recent sample intervals.
Generic type | Difference
Formula | N1 - N0
Average | (Nx - N0) / x
Example | There are no counters of this type installed with Windows 2000.


PERF_COUNTER_LARGE_DELTA

Description | This counter type shows the change in the measured attribute between the two most recent sample intervals. It is the same as the PERF_COUNTER_DELTA counter type except that it uses larger fields to accommodate larger values.
Generic type | Difference
Formula | N1 - N0
Average | (Nx - N0) / x
Example | There are no counters of this type installed with Windows 2000.


PERF_COUNTER_LARGE_QUEUELEN_TYPE

Description | This counter type monitors the average length of a queue to a resource over time. Counters of this type display the difference between the queue lengths observed during the last two sample intervals, divided by the duration of the interval. This counter type is the same as PERF_COUNTER_QUEUELEN_TYPE except that it uses larger fields to accommodate larger values.
Generic type | Average
Formula | (N1 - N0) / (D1 - D0), where the numerator (N) represents the number of items in a queue and the denominator (D) represents the time elapsed during the sample interval.
Average | (Nx - N0) / (Dx - D0)
Example | PhysicalDisk\ Avg. Disk Queue Length


PERF_COUNTER_LARGE_RAWCOUNT

Description | This counter type shows the last observed value only, not an average. It is the same as PERF_COUNTER_RAWCOUNT except that it uses larger fields to accommodate larger values.
Generic type | Instantaneous
Formula | None. Shows raw data as collected.
Average | SUM (N) / x
Example | There are no counters of this type installed with Windows 2000.


PERF_COUNTER_LARGE_RAWCOUNT_HEX

Description | This counter type shows the last observed value in hexadecimal format. It is the same as PERF_COUNTER_RAWCOUNT_HEX except that it uses larger fields to accommodate larger values.
Generic type | Instantaneous
Formula | None. Shows raw data as collected.
Average | SUM (N) / x
Example | There are no counters of this type installed with Windows 2000.


PERF_COUNTER_MULTI_TIMER

Description | This counter type is a multitimer. Multitimers collect data from more than one instance of a component, such as a processor or disk. Counters of this type display the active time of one or more components as a percentage of the total time of the sample interval. Because the numerator records the active time of components operating simultaneously, the resulting percentage can exceed 100 percent. This counter type differs from PERF_100NSEC_MULTI_TIMER in that it measures time in units of ticks of the system performance timer, rather than in 100ns units.
Generic type | Percentage
Formula | ((N1 - N0) / (D1 - D0)) x 100, where the denominator (D) represents the total elapsed time of the sample interval and the numerator (N) represents the portions of the sample interval during which the monitored components were active. They are multiplied by 100 to display the value as a percentage.
Average | (Nx - N0) / (Dx - D0) x 100
Example | There are no counters of this type installed with Windows 2000.


PERF_COUNTER_MULTI_TIMER_INV

Description This counter type shows the active time of one or more components as a percentage of the total time of the sample interval. It derives the active time by measuring the time that the components were not active and subtracting the result from 100 percent by the number of objects monitored.

This counter type is an inverse multitimer. Multitimers monitor more than one instance of a component, such as a processor or disk. Inverse counters measure the time that a component is not active and derive its active time from that measurement.

This counter differs from PERF_100NSEC_MULTI_TIMER_INV in that it measures time in units of ticks of the system performance timer, rather than in 100ns units.
Generic type | Percentage
Formula | (B- ((N1 - N0) / (D1 - D0))) x 100, where the denominator (D) represents the total elapsed time of the sample interval, the numerator (N) represents the time during the interval when monitored components were inactive, and B represents the number of components being monitored.
Average | (B- ((Nx - N0) / (Dx - D0))) x 100
Example | There are no counters of this type installed with Windows 2000.


PERF_COUNTER_QUEUELEN_TYPE

Description | This counter type is designed to monitor the average length of a queue to a resource over time. It shows the difference between the queue lengths observed during the last two sample intervals divided by the duration of the interval.
Generic type | Average
Formula | (N1 - N0) / (D1 - D0), where the numerator (N) represents the number of items in the queue and the denominator (D) represents the time elapsed during the last sample interval.
Average | (Nx - N0) / (Dx - D0)
Example | There are no counters of this type installed with Windows 2000.


PERF_COUNTER_RAWCOUNT

Description | This counter type shows the last observed value only. It does not display an average.
Generic type | Instantaneous
Formula | None. Shows raw data as collected.
Average | SUM (N) / x
Example | Memory\Available Bytes


PERF_COUNTER_RAWCOUNT_HEX

Description | This counter type shows the most recently observed value in hexadecimal format. It does not display an average.
Generic type | Instantaneous
Formula | None. Shows raw data as collected.
Average | SUM (N) / x
Example | There are no counters of this type installed with Windows 2000.


PERF_COUNTER_TEXT

Description | This counter type shows a variable-length text string. It does not display calculated values.
Generic type | Text
Formula | N/A
Average | N/A
Example | There are no counters of this type installed with Windows 2000.


PERF_COUNTER_TIMER

Description | This counter type shows the average time that a component is active as a percentage of the total sample time.
Generic type | Percentage
Formula | (N1 - N0) / (D1 - D0), where the denominator (D) represents the total elapsed time of the sample interval and the numerator (N) represents the portions of the sample interval during which the monitored components were active.
Average | (Nx - N0) / (Dx - D0)
Example | There are no counters of this type installed with Windows 2000.


PERF_COUNTER_TIMER_INV

Description | This is an inverse counter type. Inverse counters measure the time that a component is not active and derive the active time from that measurement. Counters of this type display the average percentage of active time observed during sample interval. The value of these counters is calculated by monitoring the percentage of time that the service was inactive and then subtracting that value from 100 percent. This counter type is the same as PERF_100NSEC_TIMER_INV except that it measures time in units of ticks of the system performance timer rather than in 100ns units.
Generic type | Percentage
Formula | (1- ((N1 - N0) / (D1 - D0))) x 100, where the denominator (D) represents the total elapsed time of the sample interval and the numerator (N) represents the time during the interval when the monitored components were inactive.
Average | (1- ((Nx - N0) / (Dx - D0))) x 100
Example | There are no counters of this type installed with Windows 2000.


PERF_ELAPSED_TIME

Description | This counter type shows the total time between when the component or process started and the time when this value is calculated. The F variable represents the number of time units that elapse in one second. The value of F is factored into the equation so that the result can be displayed in seconds.
Generic type | Difference
Formula | (D0 - N0) / F, where D represents the current time, N represents the time the object was started, and F represents the number of time units that elapse in one second.
Average | (Dx - N0) / F
Example | System\ System Up Time


PERF_PRECISION_100NS_TIMER

Description | This counter type shows a value that consists of two counter values: the count of the elapsed time of the event being monitored, and the "clock" time from a private timer in the same units. It measures time in 100 ns units. This counter type differs from other counter timers in that the clock tick value accompanies the counter value eliminating any possible difference due to latency from the function call. Precision counter types are used when standard system timers are not precise enough for accurate readings.
Generic type | Percentage
Formula | NX – N0 / D1 – D0 where the numerator (N) represents the counter value and the denominator (D) is the value of the private timer. The private timer has the same frequency as the 100 ns timer.
Average | NX – N0 / D1 – D0
Example | PhysicalDisk\% Disk Time


PERF_PRECISION_TIMER

Description | This counter type shows a value that consists of two counter values: the count of the elapsed time of the event being monitored, and the frequency from the system performance timer. This counter type differs from other counter timers in that the clock tick value accompanies the counter value eliminating any possible difference due to latency from the function call. Precision counter types are used when standard system timers are not precise enough for accurate readings.
Generic type | Percentage
Formula | NX – N0 / D1 – D0 where the numerator (N) represents the counter value and the denominator (D) is the value of the system performance timer.
Average | NX – N0 / D1 – D0
Example | There are no counters of this type installed with Windows 2000.


PERF_PRECISION_OBJECT_TIMER

Description | This counter type shows a value that consists of two counter values: the count of the elapsed time of the event being monitored, and the frequency specified in the PerfFreq field of the object header. This counter type differs from other counter timers in that the clock tick value accompanies the counter value so as to eliminate any possible difference due to latency from the function call. Precision counter types are used when standard system timers are not precise enough for accurate readings.
Generic type | Percentage
Formula | NX – N0 / D1 – D0 where the numerator (N) represents the counter value and the denominator (D) is the value of the private timer.
Average | NX – N0 / D1 – D0
Example | There are no counters of this type installed with Windows 2000.


PERF_RAW_FRACTION

Description | This counter type shows the ratio of a subset to its set as a percentage. For example, it compares the number of bytes in use on a disk to the total number of bytes on the disk. Counters of this type display the current percentage only, not an average over time.
Generic type | Instantaneous, Percentage
Formula | (N0 / D0), where D represents a measured attribute and N represents one component of that attribute.
Average | SUM (N / D) /x
Example | Paging File\% Usage Peak


PERF_SAMPLE_COUNTER

Description | This counter type shows the average number of operations completed in one second. It measures time in units of ticks of the system performance timer. The F variable represents the number of ticks that occur in one second. It is factored into the equation so that the result can be displayed in seconds.
Generic type | Average
Formula | (N1 - N0) / ((D1 - D0) / F), where the numerator (N) represents the number of operations completed, the denominator (D) represents elapsed time in units of ticks of the system performance timer, and F represents the number of ticks that elapse in one second.
Average | (Nx - N0) / ((Dx - D0) / F)
Example | There are no counters of this type installed with Windows 2000.


PERF_SAMPLE_FRACTION

Description | This counter type shows the average ratio of hits to all operations during the last two sample intervals.
Generic type | Percentage; Hits %
Formula | (N1 - N0) / (D1 - D0), where the numerator (N) represents the number of successful operations during the last sample interval, and the denominator (D) represents the change in the number of all operations (of the type measured) completed during the sample interval.
Average | (Nx - N0) / (Dx - D0) (See Note below)
Example | Cache\Pin Read Hits %

Note Image Note

The Hit% counters are best displayed in System Monitor in chart view. Hits often appear in short bursts that are not visible in reports. Also, the average displayed for Hit% on the status bar in chart view might not match the average displayed in report view because they are calculated differently. In chart view, the Hit% is an average of all changes in the counter during the test interval; in report view, it is the average of the difference between the first and last counts during the test interval.


Bottleneck-Detection Counters

Some counters are useful for identifying performance problems, or bottlenecks, that affect the operating system or installed applications. A bottleneck exists when a single component is adversely affecting the performance of the whole system. This section lists counters to watch when trying to diagnose or prevent performance problems.

  • Finding Memory Bottlenecks
  • Finding Processor Bottlenecks
  • Finding Disk Bottlenecks
  • Finding Cache Bottlenecks
  • Finding Bottlenecks on Multiprocessor Computers
  • Finding Network Bottlenecks


Finding Memory Bottlenecks

Use the following counters to monitor the performance of physical and virtual memory on a computer that is running Windows 2000.

  • Memory\ Page Faults/sec
  • Memory\ Page Reads/sec
  • Memory\ Page Writes/sec
  • Memory\ Pages Input/sec
  • Memory\ Pages Output/sec
  • Memory\ Available Bytes
  • Memory\ Pool Nonpaged Bytes
  • Process\ Page Faults/sec
  • Process\ Working Set
  • Process\ Private Bytes
  • Process\ Page File Bytes

For more information about using these counters to test and tune memory, see "Evaluating Memory and Cache Usage" in the Microsoft® Windows® 2000 Server Resource Kit Server Operations Guide.


Finding Processor Bottlenecks

Use the following counters to monitor the performance of one or more processors on a computer that is running Windows 2000 Professional.

  • Processor\ % Processor Time
  • System\ % Total Processor Time
  • System\ Processor Queue Length
    • Process\ % Privileged Time
    • Process\ % Processor Time
    • Process\ % User Time
    • Process\ Priority Base
    • Thread\ % Privileged Time
    • Thread\ % Processor Time
    • Thread\ % User Time
    • Thread\ Context Switches/sec
    • Thread\ Priority Base
    • Thread\ Priority Current
    • Thread\ Thread State

For more information about using these counters to test and tune processor performance, see "Analyzing Processor Activity" in the Server Operations Guide.

For details about performance monitoring for multiprocessor computers, see "Finding Bottlenecks on Multiprocessor Computers" and "Measuring Multiprocessor System Performance" in the Server Operations Guide.


Finding Disk Bottlenecks

Use the following counters to monitor the performance of physical disks and logical partitions of physical disks on a computer that is running Windows 2000 Professional.

  • PhysicalDisk\ % Disk Time
  • PhysicalDisk\ Avg. Disk Queue Length
  • PhysicalDisk\ Current Disk Queue Length
  • PhysicalDisk\ Avg. Disk Sec/Read
  • PhysicalDisk\ Avg. Disk Sec/Write
  • PhysicalDisk\ Disk Read Bytes/sec
  • PhysicalDisk\ Disk Write Bytes/sec
  • PhysicalDisk\ Avg. Disk Bytes/Read
  • PhysicalDisk\ Avg. Disk Bytes/Write
  • PhysicalDisk\ Disk Reads/sec
  • PhysicalDisk\ Disk Writes/sec

For more information about using these counters to test and tune disk performance, see "Examining and Tuning Disk Performance" in the Server Operations Guide.


Finding Cache Bottlenecks

Use the following counters to monitor the performance of the file system cache on a computer that is running Windows 2000 Professional.

  • Memory\ Cache Bytes
  • Memory\ Cache Faults/sec
  • Memory\ Page Faults/sec
  • Memory\ Pages Input/sec
  • Memory\ Pages Output/sec
  • Cache\ Copy Reads/sec
  • Cache\ Data Flushes/sec
  • Cache\ Copy Read Hits %
  • Cache\ Lazy Write Pages/sec
  • Cache\ Lazy Write Flushes/sec
  • Cache\ Read Aheads/sec
  • PhysicalDisk\ Disk Reads/sec
  • PhysicalDisk\ Disk Writes/sec

For more information about using these counters to test and tune cache performance, see "Evaluating Memory and Cache Usage" in the Server Operations Guide.


Finding Bottlenecks on Multiprocessor Computers

Use the following counters to monitor the performance of multiprocessor computers that are running Windows 2000 Professional.

  • System\ % Total Processor Time
  • System\ Processor Queue Length
  • Processor\ % Processor Time
  • Process\ % Processor Time
  • Thread\ % Processor Time


Finding Network Bottlenecks

Use the following counters to identify bottlenecked network resources:

  • Network Interface\ Bytes Total/sec
  • Network Interface\ Bytes Sent/sec
  • Network Interface\ Bytes Received/sec
  • Protocol_layer_object\ Segments Received/sec
  • Protocol_layer_object\ Segments Sent/sec
  • Protocol_layer_object\ Frames Sent/sec
  • Protocol_layer_object\ Frames Received/sec

    For NWLink performance objects, frame-related counters report only zeroes. Use datagram-based counters for these objects.

  • Server\ Bytes Total/sec
  • Server\ Bytes Received/sec
  • Server\ Bytes Sent/sec
  • Network Segment\ % Network Utilization


Counters by Feature

Some Windows 2000 features or services install one or more performance objects to measure the activity of the feature or service. The following is a list of features or services and their corresponding performance objects:

  • Internet Information Service
    • Active Server Pages
    • FTP Service
    • Web Service
    • Internet Information Services Global
  • Indexing Service
    • Indexing Service
    • Indexing Service Filter
    • HTTP Indexing Service
  • Message Queuing
    • MSMQ Session
    • MSMQ IS
    • MSMQ Queue
    • MSMQ Service
  • Quality of Service (QoS) Admission Control
    • ACS/RSVP Service
    • ACS/RSVP Interfaces
    • ACS/RSVP Policy
  • Routing and Remote Access (RRAS)
    • RAS Port
    • RAS Total
  • File Replication Service
    • FileReplicaConn
    • FileReplicaSet
  • Terminal Service
    • Terminal Services Session
  • Active Directory™
    • NTDS


Counters by Object

This section includes all of the performance objects installed by Windows 2000, grouped alphabetically. The Performance tool user interfaces show performance objects listed alphabetically. Objects appear in the tool interfaces if they are installed on your computer, which is typically done by installing the associated service or feature.


ACS Policy Object

The ACS Policy object provides data about service rejections for policy reasons. Network administrators should monitor the counters provided by this object when the Admission Control (RSVP) Service is enabled. The ACS Policy object is available only if the Admission Control (RSVP) Service has won the designated subnet bandwidth manager (DSBM) election and is running the Policy Admission Control. The subnet bandwidth manager is a QoS signaling technique supported in Windows 2000 that is used to manage bandwidth on old and new LAN topologies.

There is one object for each subnet to which this system is connected.

Counter Name | Description | Counter Type
Bad user Identity Policy Elements | Shows the number of user Identity Policy Elements that could not be identified by Microsoft Identity Local Policy Module. | PERF_COUNTER_RAWCOUNT
DS cache size | Shows the number of entries in the directory service cache. | PERF_COUNTER_RAWCOUNT
Flow count PATH rejections | Shows the number of PATH messages rejected due to flow count. | PERF_COUNTER_RAWCOUNT
Flow count RESV rejections | Shows the number of RESV messages rejected due to flow count. | PERF_COUNTER_RAWCOUNT
Flow duration PATH rejections | Shows the number of PATH messages rejected due to flow duration. | PERF_COUNTER_RAWCOUNT
Flow duration RESV rejections | Shows the number of RESV messages rejected due to flow duration. | PERF_COUNTER_RAWCOUNT
Flow rate PATH rejections | Shows the number of PATH messages rejected due to flow rate. | PERF_COUNTER_RAWCOUNT
Flow rate RESV rejections | Shows the number of RESV messages rejected due to flow rate. | PERF_COUNTER_RAWCOUNT
Other policy PATH rejections | Shows the number of PATH messages rejected due to other policies. | PERF_COUNTER_RAWCOUNT
Other policy RESV rejections | Shows the number of RESV messages rejected due to other policies. | PERF_COUNTER_RAWCOUNT
PATH message changes admitted | Shows the number of changes to PATH messages admitted. | PERF_COUNTER_RAWCOUNT
PATH messages admitted | Shows the number of PATH messages admitted. | PERF_COUNTER_RAWCOUNT
Peak rate PATH rejections | Shows the number of PATH messages rejected due to the service reaching its peak rate. | PERF_COUNTER_RAWCOUNT
Peak rate RESV rejections | Shows the number of RESV messages rejected due to the service reaching its peak rate. | PERF_COUNTER_RAWCOUNT
RESV message changes admitted | Shows the number of changes to RESV messages admitted. | PERF_COUNTER_RAWCOUNT
RESV messages admitted | Shows the number of RESV messages admitted. | PERF_COUNTER_RAWCOUNT
Total flow rate PATH rejections | Shows the number of PATH messages rejected due to the service reaching its total flow rate. | PERF_COUNTER_RAWCOUNT
Total flow rate RESV rejections | Shows the number of RESV messages rejected due to the service reaching its total flow rate. | PERF_COUNTER_RAWCOUNT
Total peak rate PATH rejections | Shows the number of PATH messages rejected due to the service reaching its total peak rate. | PERF_COUNTER_RAWCOUNT
Total peak rate RESV rejections | Shows the number of RESV messages rejected due to the service reaching its total peak rate. | PERF_COUNTER_RAWCOUNT
User ID change PATH rejections | Shows the number of PATH messages rejected because the user ID changed. | PERF_COUNTER_RAWCOUNT
User ID change RESV rejections | Shows the number of RESV messages rejected because the user ID changed. | PERF_COUNTER_RAWCOUNT

See also

  • QoS Admission Control


ACS/RSVP Interfaces Object

ACS/RSVP Interfaces performance object counters report statistics about RSVP activity, flow, bandwidth, RSVP messages sent, and so on. The ACS/RSVP Interfaces object is available if ACS is running and there is an object for each IP address on the system.

Counter Name | Description | Counter Type
Admitted Bandwidth | Shows the total admitted bandwidth, in bits per second, in use by the interface. | PERF_COUNTER_RAWCOUNT
Blocked RESVs | Shows the number of blockaded reservations that failed due to failed reservations that have not been removed from this node. For more information about blockade states, see RFC 2205. | PERF_COUNTER_RAWCOUNT
General Failures | Shows the total number of non-admission control errors that have occurred on this interface. For more information about the other traffic control failures, see RFC 2205. | PERF_COUNTER_RAWCOUNT
Maximum Admitted Bandwidth | Shows the highest amount of allocated bandwidth admitted on the interface during the period in which the ACS has been running. | PERF_COUNTER_RAWCOUNT
Number of Active Flows | Shows the number of reserved flows that are currently installed and maintained by RSVP on this interface. | PERF_COUNTER_RAWCOUNT
PATH ERR Messages Received | Shows the total number of PATH error messages received on this interface. This number indicates the number of times that a PATH has been rejected by a remote host. | PERF_COUNTER_RAWCOUNT
PATH ERR Messages Sent | Shows the total number of PATH ERR messages that were sent by the ACS/RSVP service rejecting incoming PATH messages. | PERF_COUNTER_RAWCOUNT
PATH Messages Received | Shows the total number of PATH messages that have been received on this interface. | PERF_COUNTER_RAWCOUNT
PATH Messages Sent | Shows the total number of PATH messages that were sent by the ACS/RSVP service on this the interface. | PERF_COUNTER_RAWCOUNT
PATH State Timeouts | Shows the total number of times that the RSVP PATH state timed out. This happens when no PATH messages are received within the designated timeout period. This error message can be caused by a route change. | PERF_COUNTER_RAWCOUNT
PATH TEAR Messages Received | Shows the total number of PATH TEAR messages that have been received on the interface. A PATH-TEAR message removes the PATH state along the route. | PERF_COUNTER_RAWCOUNT
PATH TEAR Messages Sent | Shows the total number of PATH TEAR messages that were sent on the interface to tear down an RSVP PATH state in the network. A PATH-ERR messages indicates an error in response to the PATH message. | PERF_COUNTER_RAWCOUNT
Policy Control Failures | Shows the total number of RSVP requests that are not admitted on this interface due to a conflict with policy settings. | PERF_COUNTER_RAWCOUNT
Receive Messages Errors - Big Messages | Shows the total number of incoming RSVP messages that were dropped because they were bigger than the maximum configured RSVP message size. | PERF_COUNTER_RAWCOUNT
Receive Messages Errors - No Memory | Shows the total number of incoming RSVP messages that were dropped due to insufficient memory. | PERF_COUNTER_RAWCOUNT
Resource Control Failures | Shows the number of reservations that failed due to the lack of resources. | PERF_COUNTER_RAWCOUNT
RESV CONFIRM Messages Received | Shows the total number of RESV CONFIRM messages that have been received by the interface. | PERF_COUNTER_RAWCOUNT
RESV CONFIRM Messages Sent | Shows the total number of RESV CONFIRM messages that were sent on this interface in response to RESV messages sent from remote hosts. | PERF_COUNTER_RAWCOUNT
RESV ERR Messages Received | Shows the total number of RESV ERR messages that were sent on this interface by the ACS/RSVP service. rejecting incoming RESV messages. A RESV-ERR message indicates an error in response to the RESV. | PERF_COUNTER_RAWCOUNT
RESV ERR Messages Sent | Shows the total number of RESV errors that were sent on this interface. This number indicates how many reservations have been rejected by the network. | PERF_COUNTER_RAWCOUNT
RESV Messages Received | Shows the total number of RESV messages that have been received on this interface. | PERF_COUNTER_RAWCOUNT
RESV Messages Sent | Shows the total number of RESV messages that were sent by the ACS/RSVP service sent on this the interface | PERF_COUNTER_RAWCOUNT
RESV State Timeouts | Shows the total number of times that the RSVP RESV state timed out. This happens when no RESV messages are received within the designated timeout period. This error message can be caused by a route change. | PERF_COUNTER_RAWCOUNT
RESV TEAR Messages Received | Shows the total number of RESV TEAR messages that have been received on the interface. A RESV-TEAR message removes the reservation along the route. | PERF_COUNTER_RAWCOUNT
RESV TEAR Messages Sent | Shows the total number of RESV TEAR messages that were sent on the interface to tear down a RESV state in the network. | PERF_COUNTER_RAWCOUNT
Send Messages Errors - Big Messages | Shows the total number of outgoing RSVP messages that were dropped because they were bigger than the maximum configured RSVP message size. | PERF_COUNTER_RAWCOUNT
Send Messages Errors - No Memory | Shows the total number of outgoing RSVP messages that were dropped due to insufficient memory. | PERF_COUNTER_RAWCOUNT
Signaling Bytes Received | Shows the total RSVP signaling traffic, in bytes, that have been received by the ACS/RSVP service on this interface. | PERF_COUNTER_RAWCOUNT
Signaling Bytes Sent | Shows the total RSVP signaling traffic, in bytes, that were sent by the ACS/RSVP service on this interface. | PERF_COUNTER_RAWCOUNT

See also

  • QoS Admission Control


ACS/RSVP Service Object

The ACS/RSVP Service performance object counters report statistics about Resource Reservation Protocol (RSVP) and Quality of Service (QoS) Admission Control (ACS) activity, flow, bandwidth, RSVP messages sent, and so on. The ACS/RSVP Service object is available if QoS Admission Control is installed, even if the service is not running.

Counter Name | Description | Counter Type
Bytes in QoS Notifications | Shows a running total of the number of bytes that were delivered in QoS Notifications to QoS-enabled applications. | PERF_COUNTER_RAWCOUNT
Failed QoS Requests | Shows the number of QoS requests generated by QoS-enabled applications that have been rejected by the ACS/RSVP service. Failed QoS requests can be caused by invalid QoS requests. | PERF_COUNTER_RAWCOUNT
Failed QoS Sends | Shows the number of QoS notifications the ACS/RSVP service that could not be sent to the QoS applications. Failed QoS sends can be caused by terminated applications. | PERF_COUNTER_RAWCOUNT
Network Interfaces | Shows the number of local network interfaces that are visible to, and used by the RSVP service. | PERF_COUNTER_RAWCOUNT
Network Sockets | Shows the total number of raw sockets that were opened for the purpose of RSVP signaling. | PERF_COUNTER_RAWCOUNT
QoS notifications | Shows the number of QoS notifications that were delivered to QoS-enabled applications by the QoS RSVP service. | PERF_COUNTER_RAWCOUNT
QoS Sockets | Shows the number of sockets that are currently QoS enabled. | PERF_COUNTER_RAWCOUNT
QoS-Enabled Receivers | Shows the number of RESV messages sent for QoS-enabled receivers. This number increments each time a RESV is refreshed. | PERF_COUNTER_RAWCOUNT
QoS-Enabled Senders | Shows the number of PATH messages sent for QoS-enabled senders. This number increments each time a PATH is refreshed. | PERF_COUNTER_RAWCOUNT
RSVP Message Buffers in Use | Shows the number of active packet buffers that are currently being used by the ACS/RSVP service. This number increases and decreases depending on the number of buffers being used. | PERF_COUNTER_RAWCOUNT
RSVP Sessions | Shows the current number of active RSVP sessions on the ACS/RSVP service. | PERF_COUNTER_RAWCOUNT
Timers | Shows the number of timer events that are scheduled to take place. This counter shows the activity level of the ACS/RSVP service. | PERF_COUNTER_RAWCOUNT

See also

  • Default System Performance Counters
  • QoS Admission Control


Active Server Pages Object

The Active Server Pages performance object monitors errors, requests, sessions, or other data generated from Active Server Pages (ASP) applications.

Counter Name | Description | Counter Type
Debugging Requests | Shows the number of ASP pages sent to the script debugger. | PERF_COUNTER_RAWCOUNT
Errors During Script Runtime | Shows the number of requests that failed due to run-time errors. | PERF_COUNTER_RAWCOUNT
Errors From ASP Preprocessor | Shows the number of requests that failed due to preprocessor errors. | PERF_COUNTER_RAWCOUNT
Errors From Script Compilers | Shows the total number of requests that failed due to script compilation errors. | PERF_COUNTER_RAWCOUNT
Errors/sec | Shows the number of errors that occur per second. | PERF_COUNTER_COUNTER
Request Bytes In Total | Shows the total size, in bytes, of all requests. | PERF_COUNTER_RAWCOUNT
Request Bytes Out Total | Shows the total size, in bytes, of all responses sent to clients. This does not include the standard Hypertext Transfer Protocol (HTTP) response headers. | PERF_COUNTER_RAWCOUNT
Request Execution Time | Shows the time, in milliseconds, that it took to execute the most recent request. | PERF_COUNTER_RAWCOUNT
Request Wait Time | Shows the time, in milliseconds, that the most recent request was waiting in the queue. | PERF_COUNTER_RAWCOUNT
Requests Disconnected | Shows the number of requests that were disconnected due to a communications failure. | PERF_COUNTER_RAWCOUNT
Requests Executing | Shows the number of requests that are currently executing. | PERF_COUNTER_RAWCOUNT
Requests Failed Total | Shows the total number of requests that failed due to errors, authorization failure, or rejections. | PERF_COUNTER_RAWCOUNT
Requests Not Authorized | Shows the number of requests that failed due to insufficient access rights. | PERF_COUNTER_RAWCOUNT
Requests Not Found | Shows the number of requests for files that were not found. | PERF_COUNTER_RAWCOUNT
Requests Queued | shows the number of requests waiting for service from the queue. | PERF_COUNTER_RAWCOUNT
Requests Rejected | Shows the total number of requests that were not executed due to insufficient resources for processing the requests. This may be due to configuration problems or a memory limitation. | PERF_COUNTER_RAWCOUNT
Requests Succeeded | Shows the number of requests that were successfully executed. | PERF_COUNTER_RAWCOUNT
Requests Timed Out | Shows the number of requests that timed out. | PERF_COUNTER_RAWCOUNT
Requests Total | Shows the total number of requests since the service was started. | PERF_COUNTER_RAWCOUNT
Requests/sec | shows the number of requests that were executed per second. This value is important for monitoring server performance. | PERF_COUNTER_COUNTER
Script Engines Cached | Shows the number of script engines that are in the cache. | PERF_COUNTER_RAWCOUNT
Session Duration | Shows the time, in milliseconds, that the most recent session lasted. | PERF_COUNTER_RAWCOUNT
Sessions Current | shows the number of sessions that are being serviced. | PERF_COUNTER_RAWCOUNT
Sessions Timed Out | Shows the number of sessions that have timed out. | PERF_COUNTER_RAWCOUNT
Sessions Total | Shows the total number of sessions that have been opened since the service was started. | PERF_COUNTER_RAWCOUNT
Templates Cached | Shows the number of templates that are currently in the ASP file cache. | PERF_COUNTER_RAWCOUNT
Template Cache Hit Rate | Shows the percentage of requests found in the template cacheover the sample interval. | PERF_COUNTER_RAWCOUNT
Template Notifications | Shows the number of templates invalidated in the cache due to change notification. | PERF_COUNTER_RAWCOUNT
Transactions Aborted | Shows the number of transactions that were aborted (rolled back). | PERF_COUNTER_RAWCOUNT
Transactions Committed | Shows the number of transactions that were committed. | PERF_COUNTER_RAWCOUNT
Transactions Pending | Shows the number of transactions that have not yet been committed. | PERF_COUNTER_RAWCOUNT
Transactions Total | Shows the total number of transactions since the service was started. This counter reports the sum of the values of Transactions Aborted, Transactions Committed, and Transactions Pending. | PERF_COUNTER_RAWCOUNT
Transactions/sec | Shows the number of transactions started per second. | PERF_COUNTER_COUNTER

See also

  • Internet Information Service


AppleTalk Object

The AppleTalk performance object consists of counters that monitor traffic on the AppleTalk network.

Counter Name | Description | Counter Type
AARP Packets/sec | Shows the number of AppleTalk Address Resolution Protocol (AARP) packets per second received by AppleTalk on this port. | PERF_COUNTER_COUNTER
ATP ALO Response/sec | Shows the number of AppleTalk Transaction Protocol (ATP) at-least-once transaction responses per second on this port. | PERF_COUNTER_COUNTER
ATP Packets/sec | Shows the number of ATP packets per second received by AppleTalk on this port. | PERF_COUNTER_COUNTER
ATP Recvd Release/sec | Shows the number of ATP transaction release packets per second received on this port. | PERF_COUNTER_COUNTER
ATP Response Timeouts | Shows the number of ATP release timers that have expired on this port. | PERF_COUNTER_RAWCOUNT
ATP Retries Local | Shows the number of ATP requests retransmitted on this port. | PERF_COUNTER_RAWCOUNT
ATP Retries Remote | Shows the number of ATP requests retransmitted to this port. | PERF_COUNTER_RAWCOUNT
ATP XO Response/sec | Shows the number of ATP exactly-once transaction responses per second on this port. | PERF_COUNTER_COUNTER
Average Time/AARP Packet | Shows the average time, in milliseconds, needed to process an AARP packet on this port. | PERF_AVERAGE_BULK
Average Time/ATP Packet | Shows the average time, in milliseconds, needed to process an ATP packet on this port. | PERF_AVERAGE_BULK
Average Time/DDP Packet | Shows the average time, in milliseconds, needed to process a Data Delivery Protocol (DDP) packet on this port. | PERF_AVERAGE_BULK
Average Time/NBP Packet | Shows the average time, in milliseconds, needed to process a Name Binding Protocol (NBP) packet on this port. | PERF_AVERAGE_BULK
Average Time/RTMP Packet | Shows the average time, in milliseconds, needed to process a Routing Table Maintenance Protocol (RTMP) packet on this port. | PERF_AVERAGE_BULK
Average Time/ZIP Packet | Shows the average time, in milliseconds, needed to process a Zone Information Protocol (ZIP) packet on this port. | PERF_AVERAGE_BULK
Bytes In/sec | Shows the number of bytes received per second by AppleTalk on this port. | PERF_COUNTER_BULK_COUNT
Bytes Out/sec | Shows the number of bytes sent per second by AppleTalk on this port. | PERF_COUNTER_BULK_COUNT
Current NonPaged Pool | Shows the current amount of nonpaged memory resources used by AppleTalk. | PERF_COUNTER_RAWCOUNT
DDP Packets/sec | Shows the number of DDP packets per second received by AppleTalk on this port. | PERF_COUNTER_COUNTER
NBP Packets/sec | Shows the number of NBP packets per second received by AppleTalk on this port. | PERF_COUNTER_COUNTER
Packets dropped | Shows the number of packets dropped due to resource limitations on this port. | PERF_COUNTER_RAWCOUNT
Packets In/sec | Shows the number of packets received per second by AppleTalk on this port. | PERF_COUNTER_COUNTER
Packets Out/sec | Shows the number of packets sent per second by AppleTalk on this port. | PERF_COUNTER_COUNTER
Packets Routed In/sec | Shows the number of packets routed in per second on this port. | PERF_COUNTER_COUNTER
Packets Routed Out/sec | Shows the number of packets routed out per second on this port. | PERF_COUNTER_COUNTER
RTMP Packets/sec | Shows the number of RTMP packets per second received by AppleTalk on this port. | PERF_COUNTER_COUNTER
ZIP Packets/sec | Shows the number of ZIP packets per second received by AppleTalk on this port. | PERF_COUNTER_COUNTER


Browser Object

The Browser performance object consists of counters that measure the rates of announcements, enumerations, and other browser transmissions.

Counter Name | Description | Counter Type
Announcements Domain/sec | Shows the rate at which a domain has announced itself to the network. | PERF_COUNTER_BULK_COUNT
Announcements Server/sec | Shows the rate at which the servers in this domain have announced themselves to the server. | PERF_COUNTER_BULK_COUNT
Announcements Total/sec | Shows the sum of the values of Announcements Domain /sec and Announcements Server /sec. | PERF_COUNTER_BULK_COUNT
Duplicate Master Announcements | Shows the number of times that the master browser has detected another master browser on the same domain. | PERF_COUNTER_RAWCOUNT
Election Packets/sec | Shows the rate at which browser election packets have been received by the workstation. | PERF_COUNTER_COUNTER
Enumerations Domain/sec | Shows the rate at which domain browse requests have been processed by this workstation. | PERF_COUNTER_COUNTER
Enumerations Other/sec | Shows the rate of browse requests processed by this workstation that are not domain or server browse requests. | PERF_COUNTER_COUNTER
Enumerations Server/sec | Shows the rate at which server browse requests have been processed by this workstation. | PERF_COUNTER_COUNTER
Enumerations Total/sec | Shows the rate at which browse requests have been processed by this workstation. This value is the sum of the values of, Enumerations Domain/sec, Enumerations Other/sec and Enumerations Server/sec. | PERF_COUNTER_COUNTER
Illegal Datagrams/sec | Shows the rate at which incorrectly formatted datagrams have been received by the workstation. | PERF_COUNTER_BULK_COUNT
Mailslot Allocations Failed | Shows the number of times that the datagram receiver has failed to allocate a buffer to hold a user mailslot write. | PERF_COUNTER_RAWCOUNT
Mailslot Opens Failed/sec | Shows the rate at which mailslot messages to be delivered to mailslots that are not present are received by this workstation. | PERF_COUNTER_COUNTER
Mailslot Receives Failed | Shows the number of mailslot messages that could not be received due to transport failures. | PERF_COUNTER_RAWCOUNT
Mailslot Writes Failed | Shows the total number of mailslot messages that have been successfully received, but that could not be written to the mailslot. | PERF_COUNTER_RAWCOUNT
Mailslot Writes/sec | Shows the rate at which mailslot messages have been successfully received. | PERF_COUNTER_COUNTER
Missed Mailslot Datagrams | Shows the number of Mailslot Datagrams that have been discarded due to configuration or allocation limits. | PERF_COUNTER_RAWCOUNT
Missed Server Announcements | Shows the number of server announcements that have been missed due to configuration or allocation limits. | PERF_COUNTER_RAWCOUNT
Missed Server List Requests | Shows the number of requests to retrieve a list of browser servers that were received by this workstation, but could not be processed. | PERF_COUNTER_RAWCOUNT
Server Announce Allocations Failed/sec | Shows the rate at which server (or domain) announcements have failed due to lack of memory. | PERF_COUNTER_COUNTER
Server List Requests/sec | Shows the rate at which requests to retrieve a list of browser servers have been processed by this workstation. | PERF_COUNTER_COUNTER


Cache Object

The Cache performance object consists of counters that monitor the file system cache, an area of physical memory that stores recently used data as long as possible to permit access to the data without having to read from the disk. Because applications typically use the cache, the cache is monitored as an indicator of application input/output (I/O) operations. When memory is plentiful, the cache can grow, but when memory is scarce, the cache can become too small to be effective.

Counter Name | Description | Counter Type
Async Copy Reads/sec | Shows the rate at which read operations from pages of the file system cache involve a memory copy of the data from the cache to the application's buffer. The application regains control immediately even if the disk must be accessed to retrieve the page. | PERF_COUNTER_COUNTER
Async Data Maps/sec | Shows the rate at which an application using a file system, such as NTFS, to map a page of a file into the file system cache, does not wait for the page to be retrieved if it is not in main memory. | PERF_COUNTER_COUNTER
Async Fast Reads/sec | Shows the rate at which read operations from the file system cache bypass the installed file system and retrieve the data directly from the cache. Normally, file I/O requests invoke the file system to retrieve data from a file, but this path permits data to be retrieved from the cache directly (without file system involvement) if the data is in the cache. Even if the data is not in the cache, one invocation of the file system is avoided. If the data is not in the cache, the request does not wait until the data has been retrieved from the disk, but gets control immediately. | PERF_COUNTER_COUNTER
Async MDL Reads/sec | Shows the rate at which read operations from the file system cache use a Memory Descriptor List (MDL) to access the pages. The MDL contains the physical address of each page in the transfer, thus permitting Direct Memory Access (DMA) of the pages. If the accessed page(s) are not in main memory, the calling application program does not wait for the pages to be retrieved from disk through a page fault. | PERF_COUNTER_COUNTER
Async Pin Reads/sec | Shows the rate at which data is read into the file system cache before writing the data back to disk. Pages read in this fashion are pinned in memory at the completion of the read. Pinned pages are those that are read into the file system cache before the system writes data back to the disk at the completion of the read. The file system regains control immediately even if the disk must be accessed to retrieve the page. While pinned, a page's physical address is not altered. | PERF_COUNTER_COUNTER
Copy Read Hits % | Shows the percentage of cache copy read requests that did not require a disk read to access the page in the cache. A copy read is a file read operation that is satisfied by a memory copy from a page in the cache to the application's buffer. The LAN redirector uses this method for retrieving information from the cache, as does the LAN server for small transfers. This method is also used by the disk file systems. | PERF_SAMPLE_FRACTION
Copy Reads/sec | Shows the rate at which read operations from pages of the file system cache involve a copy read. | PERF_COUNTER_COUNTER
Data Flush Pages/sec | Shows the rate at which the file system cache has flushed to disk in response to a request to flush or to satisfy a write-through file write request. More than one page can be transferred on each flush operation. | PERF_COUNTER_COUNTER
Data Flushes/sec | Shows the rate at which the file system cache has flushed its contents to disk in response to a request to flush or to satisfy a write-through file write request. | PERF_COUNTER_COUNTER
Data Map Hits % | Shows the percentage of data maps in the file system cache that could be resolved without having to retrieve a page from the disk, because the page was already in physical memory. | PERF_SAMPLE_FRACTION
Data Map Pins/sec | Shows the rate at which data maps in the file system cache resulted in pinning a page in main memory. | PERF_SAMPLE_FRACTION
Data Maps/sec | Shows the rate at which a file system, such as NTFS, maps a page of a file into the file system cache to read the page. | PERF_COUNTER_COUNTER
Fast Read Not Possibles/sec | Shows the rate at which an application program interface (API) function call attempts to bypass the file system to get to data in the file system cache that required invoking the file system. | PERF_COUNTER_COUNTER
Fast Read Resource Misses/sec | Shows the rate at which cache misses occur because of insufficient resources to satisfy the request. | PERF_COUNTER_COUNTER
Fast Reads/sec | Shows the rate at which read operations from the file system cache bypass the installed file system and retrieve the data directly from the cache. | PERF_COUNTER_COUNTER
Lazy Write Flushes/sec | Shows the rate at which the Lazy Writer thread writes to disk. | PERF_COUNTER_COUNTER
Lazy Write Pages/sec | Shows the rate at which the Lazy Writer thread has written to disk. | PERF_COUNTER_COUNTER
MDL Read Hits % | Shows the percentage of MDL read requests to the file system cache that did not require disk accesses to provide memory access to the page or pages in the cache. | PERF_SAMPLE_FRACTION
MDL Reads/sec | Shows the rate at which read operations from the file system cache use an MDL to access the data. The LAN server uses this method for large transfers out of the server. | PERF_COUNTER_COUNTER
Pin Read Hits % | Shows the percentage of pin read requests that did not require a disk read to provide access to the page in the file system cache. | PERF_SAMPLE_FRACTION
Pin Reads/sec | Shows the rate at which data is read into the file system cache before writing the data back to disk. Pages read in this fashion are pinned in memory at the completion of the read. | PERF_COUNTER_COUNTER
Read Aheads/sec | Shows the rate at which read operations from the file system cache detect sequential access to a file. The read aheads permit the data to be transferred in larger blocks than those being requested by the application, reducing the overhead per access. | PERF_COUNTER_COUNTER
Sync Copy Reads/sec | Shows the rate at which read operations from pages of the file system cache involve a memory copy of the data from the cache to the application's buffer. The file system does not regain control until the copy operation is complete, even if the disk must be accessed to retrieve the page. | PERF_COUNTER_COUNTER
Sync Data Maps/sec | Shows the rate at which a file system, such as NTFS, maps a page of a file into the file system cache to read the page, and, if it is not in main memory, waits for the page to be retrieved. | PERF_COUNTER_COUNTER
Sync Fast Reads/sec | Shows the rate which read operations from the file system cache bypass the installed file system and retrieve the data directly from the cache. | PERF_COUNTER_COUNTER
Sync MDL Reads/sec | Shows the rate at which read operations from the file system cache use an MDL to access the pages. | PERF_COUNTER_COUNTER
Sync Pin Reads/sec | Shows the rate at which data is read into the file system cache before it is written back to disk. Pages read in this fashion are pinned in memory at the completion of the read. | PERF_COUNTER_COUNTER

See also

  • Finding Cache Bottlenecks
  • Finding Memory Bottlenecks
  • Default System Performance Counters


Client Service For NetWare Object

The Client Service For NetWare performance object consists of counters that measure packet transmission rates, logon attempts, and connections.

Counter Name | Description | Counter Type
Bytes Received/sec | Shows the rate at which bytes are coming in to the Redirector from the network. It includes all application data in addition to network protocol information (such as packet headers). | PERF_COUNTER_BULK_COUNT
Bytes Total/sec | Shows the rate at which the redirector is processing data bytes. This includes all application and file data in addition to protocol information (such as packet headers). | PERF_COUNTER_BULK_COUNT
Bytes Transmitted/sec | Shows the rate at which bytes are leaving the redirector to the network. It includes all application data in addition to network protocol information (such as packet headers). | PERF_COUNTER_BULK_COUNT
Connect NetWare 2.x | Shows connections to NetWare 2.x servers. | PERF_COUNTER_RAWCOUNT
Connect NetWare 3.x | Shows connections to NetWare 3.x servers. | PERF_COUNTER_RAWCOUNT
Connect NetWare 4.x | Shows connections to NetWare 4.x servers. | PERF_COUNTER_RAWCOUNT
File Data Operations/sec | Shows the rate at which the redirector is processing data operations. In general, one operation includes many bytes, although this may not always be the case because of operation overhead. You can determine the efficiency of this path by dividing the value of Bytes/sec by the value of File Data Operations/sec to determine the average number of bytes transferred per operation. | PERF_COUNTER_COUNTER
File Read Operations/sec | Shows the rate at which applications are asking the redirector for data. Each call to a file system or similar API call counts as one operation. | PERF_COUNTER_COUNTER
File Write Operations/sec | Shows the rate at which applications are sending data to the redirector. Each call to a file system or similar API call counts as one operation. | PERF_COUNTER_COUNTER
Packet Burst IO/sec | Shows the sum of the values of Packet Burst Read NCPs/sec and Packet Burst Write NCPs/sec. | PERF_COUNTER_COUNTER
Packet Burst Read NCP Count/sec | Shows the rate at which NetWare Core Protocol requests Packet Burst Read. The Packet Burst Protocol is built on top of Internetwork Packet Exchange (IPX) and can speed the transfer of multiple packet NetWare Core Protocol (NCP) file reads and writes. | PERF_COUNTER_COUNTER
Packet Burst Read Timeouts/sec | Shows the rate at which the Client Service for NetWare was required to retransmit a burst read request because the NetWare server took too long to respond. | PERF_COUNTER_COUNTER
Packet Burst Write NCP Count/sec | Shows the rate at which NetWare Core Protocol requests packet burst write. Packet burst is a windowing protocol that improves performance. | PERF_COUNTER_COUNTER
Packet Burst Write Timeouts/sec | Shows the rate at which the Client Service for NetWare was required to retransmit a burst write request because the NetWare server took too long to respond. | PERF_COUNTER_COUNTER
Packets Received/sec | Shows the rate at which the redirector receives packets, also called Server Message Blocks (SMBs). Network transmissions are divided into packets. The average number of bytes received in a packet can be obtained by dividing the value of Bytes Received/sec by the value of Packets Received/sec. Some packets received might not contain incoming data (for example, an acknowledgment to a write operation made by the redirector would count as an incoming packet). | PERF_COUNTER_BULK_COUNT
Packets Transmitted/sec | Shows the rate at which the redirector sends packets. The average number of bytes transmitted in a packet can be obtained by dividing the value of Bytes Transmitted/sec by the value of Packets Transmitted/sec. | PERF_COUNTER_BULK_COUNT
Packets/sec | Shows the rate at which the redirector processes data packets. Typically one packet includes many bytes, although this may not be the case because each packet has protocol overhead. The average number of bytes transferred in a packet can be obtained by dividing the value of Bytes/sec by the value of Packets/sec. You can also divide this counter by the value of Operations/sec to determine the average number of packets per operation, another measure of efficiency. | PERF_COUNTER_BULK_COUNT
Read Operations Random/sec | Shows the rate at which, on a file-by-file basis, nonsequential read operations are made. If a read is made using a particular file handle, and then is followed by another read that is not the next contiguous byte, this counter is incremented by one. | PERF_COUNTER_COUNTER
Read Packets/sec | Shows the rate at which read packets are being placed on the network. Each time a single packet is sent with a request to read data remotely, this counter is incremented by one. | PERF_COUNTER_COUNTER
Server Disconnects | Shows the number of times that a server has disconnected the redirector. | PERF_COUNTER_RAWCOUNT
Server Reconnects | Shows the number of times that the redirector reconnected to a server to complete a new active request. The redirector may be disconnected by the server if it remains inactive for too long. Even if all of your remote files are closed, the redirector keeps your connections intact on your local computer for about ten minutes. Such inactive connections are called dormant connections. Reconnecting may take a substantial period of time. | PERF_COUNTER_RAWCOUNT
Server Sessions | Shows the total number of security objects managed by the redirector. Logging on to a server followed by a network access to the same server establishes one connection, but two sessions. | PERF_COUNTER_RAWCOUNT
Write Operations Random/sec | Shows the rate at which, on a file-by-file basis, nonsequential write operations are made. If a write is made using a particular file handle, and then is followed by another write that is not the next contiguous byte, this counter is incremented by one. | PERF_COUNTER_COUNTER
Write Packets/sec | Shows the rate at which write operations are sent to the network. Each time a single packet is sent with a request to write remote data, this counter is incremented by one. | PERF_COUNTER_COUNTER


Database Object

These counters describe the activity of the Extensible Storage Engine (ESE), a transacted database system that stores all Microsoft® Active Directory® objects, can access a performance object (the Database object) that provides counters to measure the activity of the ESE. This object is not installed by default and needs to be installed using Lodctr.exe in the Platform SDK. Values are only reported for processes that use the ESE.

The Database object provides performance statistics for each process using the ESE high performance embedded database management system. This section does not describe counters that are for developer use only.

Counter Name | Description | Counter Type
Cache % Hit | Shows the percentage of database file page requests that were fulfilled by the database cache without causing a file operation. If this percentage is too low, the database cache size may be too small. | PERF_SAMPLE_FRACTION
Cache Page Fault Stalls/sec | Shows the number of page faults per second that cannot be serviced because there are no pages available for allocation from the database cache. If this counter is nonzero most of the time, the clean threshold may be too low. | PERF_COUNTER_COUNTER
Cache Page Faults/sec | Shows the number of database file page requests that require the database cache manager to allocate a new page from the database cache. If this rate is too high, the database cache size may be too small. | PERF_COUNTER_COUNTER
Cache Size | Shows the amount of system memory used by the database cache manager to hold commonly used information from the database file(s) to prevent file operations. If the database cache size seems to be too small for optimal performance and there is very little available memory on the system (see Memory\Available Bytes), adding more memory to the system may increase performance. If there is a lot of available memory on the system and the database cache size is not growing beyond a certain point, the database cache size may be capped at an artificially low limit. Increasing this limit may increase performance. | PERF_COUNTER_RAWCOUNT
File Bytes Read/sec | Shows the rate at which bytes are read from the database file(s) into the database cache per second. If this rate is too high, the database cache size may be too small. | PERF_COUNTER_COUNTER
File Bytes Written/sec | Shows the rate at which bytes are written to the database file(s) from the database cache per second. If this rate is too high, the database cache size may be too small. | PERF_COUNTER_COUNTER
File Operations Pending | Shows the number of reads and writes issued by the database cache manager to the database file(s) that are currently being processed by the operating system. A large number of pending file operations can increase system throughput but will increase response time for individual operations. Typically, a larger number means that file operations to the database file(s) may be a bottleneck. | PERF_COUNTER_RAWCOUNT
File Operations/sec | Shows the number of reads and writes issued by the database cache manager to the database file(s) per second. If this rate is too high, the database cache size may be too small. | PERF_COUNTER_COUNTER
Log Record Stalls/sec | Shows the number of log records that cannot be added to the log buffers per second because they are full. If this counter is nonzero most of the time, the log buffer size may be a bottleneck. | PERF_COUNTER_COUNTER
Log Threads Waiting | Shows the number of threads waiting for their data to be written to the log to complete an update of the database. If this number is too high, the log may be a bottleneck. | PERF_COUNTER_RAWCOUNT
Log Writes/sec | Shows the number of times that the log buffers are written to the log file(s) per second. If this number approaches the maximum write rate for the media holding the log file(s), the log may be a bottleneck. | PERF_COUNTER_COUNTER
Table Open Cache % Hit | Shows the percentage of database tables opened using cached schema information. If this percentage is too low, the table cache size may be too small. | PERF_SAMPLE_FRACTION
Table Open Cache Hits/sec | Shows the number of database tables opened using cached schema information per second. If this rate is too low, the table cache size may be too small. | PERF_COUNTER_COUNTER
Table Open Cache Misses/sec | Shows the number of database tables opened without using cached schema information per second. If this rate is too high, the table cache size may be too small. | PERF_COUNTER_COUNTER
Table Opens/sec | Shows the number of database tables opened per second. | PERF_COUNTER_COUNTER


DHCP Server Object

The DHCP Server performance object provides counters for monitoring DHCP service activity. The DHCP service enables the server to perform as a DHCP server and configure DHCP-enabled client computers on your network as described in the DHCP standard. This object is available when the service is running. The following table describes the counters provided by the DHCP Server object and how to interpret the values when monitoring DHCP service performance.

Counter Name | Description | Counter Type
Acks/sec | Shows the rate at which DHCP Acknowledgements have been sent by the DHCP server. A sudden or abnormal increase in this number indicates that a large number of clients are being renewed by the DHCP server. This may indicate that scope lease times are too short. | PERF_COUNTER_COUNTER
Active Queue Length | Shows the number of packets in the processing queue of the DHCP server. This number equals the number of unprocessed messages received by the server. A large number may indicate heavy server traffic. | PERF_COUNTER_RAWCOUNT
Conflict Check Queue Length | Shows the number of packets waiting in the DHCP server queue due to conflict detection. This queue holds messages not responded to while the DHCP server performs address conflict detection. A large value may indicate that Conflict detection attempts has been set too high in DHCP server properties or that there is heavy lease traffic at the server. | PERF_COUNTER_RAWCOUNT
Declines/sec | Shows the rate at which DHCP Declines have been received by the DHCP server. A high value indicates that several clients have found their address to be in conflict, possibly indicating network trouble. It may help to enable conflict detection on the DHCP server. Conflict detection should only be used temporarily on the server. | PERF_COUNTER_COUNTER
Discovers/sec | Shows the rate at which DHCP Discovers have been received by the DHCP server. A sudden or abnormal increase indicates that a large number of clients are probably attempting to initialize and obtain an IP address lease from the server, such as when a number of client computers are started at one time. | PERF_COUNTER_COUNTER
Duplicates Dropped/sec | Shows the rate at which the DHCP server received duplicate packets. A large number indicates that clients are probably timing out too fast or that the server is not responding very fast. | PERF_COUNTER_COUNTER
Informs/sec | Shows the rate at which DHCP Informs have been received by the DHCP server. DHCP inform messages are used when the DHCP server queries for the directory service for the enterprise root and when dynamic update updates are being done on behalf of clients by the server. | PERF_COUNTER_COUNTER
Milliseconds per Packet (Avg). | Shows the average time per packet taken by the DHCP server to send a response. This number can vary depending on the server hardware and its I/O subsystem. A sudden or unreasonable increase may indicate a problem, either with the I/O subsystem slowing or because of intrinsic processing overhead on the server computer. | PERF_COUNTER_RAWCOUNT
Nacks/sec | Shows the rate at which DHCP negative acknowledgments (Nacks) have been sent by the DHCP server. A very high value may indicate potential network problems, such as misconfiguration of clients or the server. One possible cause of server problems is a deactivated scope. For clients, a very high value could be caused by computers moving between subnets, such as laptop portables or other mobile devices. | PERF_COUNTER_COUNTER
Offers/sec | Shows that rate at which DHCP Offers have been sent out by the DHCP server. A sudden or abnormal increase in this number indicates heavy traffic on the server. | PERF_COUNTER_COUNTER
Packets Expired/sec | Shows the rate at which packets expire in the DHCP server message queue. Packets expire because they are in the server's internal message queue for too long. A large number indicates that the server is either taking too long to process some packets while other packets are queued and becoming stale, or traffic on the network is too high for the DHCP server to handle. This could suggest a disk or memory bottleneck. | PERF_COUNTER_COUNTER
Packets Received/sec | Shows the rate at which packets are received by the DHCP server. A large number indicates heavy DHCP-related message traffic to the server. | PERF_COUNTER_COUNTER
Releases/sec | Shows the rate at which DHCP Releases have been received by the DHCP server. This number is only incremented when clients manually release their address, such as when the ipconfig /release command is used at the client computer. Because clients rarely release their address, this counter should not be high for most networks and configurations. | PERF_COUNTER_COUNTER
Requests/sec | Shows the rate at which DHCP Requests have been received by the DHCP server. A sudden or abnormal increase in this number indicates a large number of clients are probably trying to renew their leases with the DHCP server. This may indicate scope lease times are too short. | PERF_COUNTER_COUNTER

See also

  • DHCP Service


Distribution Transaction Coordinator Object

The Distributed Transaction Coordinator performance object provides statistics about Distributed Transaction Coordinator (MS DTC), part of Component Services (formerly known as Transaction Server) that coordinates external, or two-phase transactions. Among other things, MS DTC is used to coordinate two-phase transactions by Message Queuing.

Counter Name | Description | Counter Type
Aborted Transactions | Shows the number of aborted transactions. | PERF_COUNTER_RAWCOUNT
Aborted Transactions/sec | Shows the rate at which transactions are aborted. | PERF_COUNTER_RAWCOUNT
Active Transactions | Shows the number of currently active transactions. | PERF_COUNTER_RAWCOUNT
Active Transactions Maximum | Shows the maximum number of transactions that were ever concurrently active. | PERF_COUNTER_RAWCOUNT
Committed Transactions | Shows the number of committed transactions. | PERF_COUNTER_RAWCOUNT
Committed Transactions/sec | Shows the number of transactions committed per second. | PERF_COUNTER_RAWCOUNT
Force Aborted Transactions | Shows the number of transactions aborted by the system administrator. | PERF_COUNTER_RAWCOUNT
Force Committed Transactions | Shows the number of transactions committed by the system administrator. | PERF_COUNTER_RAWCOUNT
In Doubt Transactions | Shows the number of transactions in doubt; that is, neither committed nor aborted . | PERF_COUNTER_RAWCOUNT
Response Time – Average | Shows the average time between when transactions begin and commit. | PERF_COUNTER_RAWCOUNT
Response Time – Maximum | Shows the maximum time between when transactions begin and commit. | PERF_COUNTER_RAWCOUNT
Response Time – Minimum | Shows the minimum time between when transactions begin and commit. | PERF_COUNTER_RAWCOUNT
Transactions/sec | Shows the rate at which transactions are performed. | PERF_COUNTER_RAWCOUNT


DNS Object

The Domain Name System (DNS) is an Internet and TCP/IP standard name service.

The DNS performance object provides counters for monitoring various areas of performance of the DNS service that enables client computers on your network to register and resolve DNS domain names. These names are used to find and access resources offered by other computers on your network or other networks, such as the Internet. The data reported by the DNS object includes the number of overall queries and responses processed by a DNS server, the number of DNS queries and responses processed using either the User Datagram Protocol (UDP) or the Transmission Control Protocol (TCP), the number of queries and responses that used recursion to look up and fully resolve DNS names on behalf of requesting clients, and the number of queries and responses made to servers using the WINS lookup integration features of the DNS service.

Counter Name | Description | Counter Type
AXFR Request Received | Shows the total number of full zone transfer requests received by the master DNS server. | PERF_COUNTER_RAWCOUNT
AXFR Request Sent | Shows the total number of full zone transfer requests sent by the secondary DNS server. | PERF_COUNTER_RAWCOUNT
AXFR Response Received | Shows the total number of full zone transfer responses received by the secondary DNS server. | PERF_COUNTER_RAWCOUNT
AXFR Success Received | Shows the total number of successful full zone transfers received by the secondary DNS server. | PERF_COUNTER_RAWCOUNT
AXFR Success Sent | Shows the total number of successful full zone transfers of the master DNS server. | PERF_COUNTER_RAWCOUNT
Caching Memory | Shows the total amount of caching memory used by the DNS server. | PERF_COUNTER_RAWCOUNT
Database Node Memory | Shows the total database node memory used by the DNS server. | PERF_COUNTER_RAWCOUNT
Dynamic Update NoOperation | Shows the total number of No-operation/empty dynamic update requests received by the DNS server. | PERF_COUNTER_RAWCOUNT
Dynamic Update NoOperation/sec | Shows the rate at which No-operation/empty dynamic update requests are received by the DNS server. | PERF_COUNTER_COUNTER
Dynamic Update Queued | Shows the total number of dynamic updates that are queued by the DNS server. | PERF_COUNTER_RAWCOUNT
Dynamic Update Received | Shows the total number of dynamic update requests that are received by the DNS server. | PERF_COUNTER_RAWCOUNT
Dynamic Update Received/sec | Shows the rate at which dynamic update requests are received by the DNS server. | PERF_COUNTER_COUNTER
Dynamic Update Rejected | Shows the total number of dynamic updates rejected by the DNS server. | PERF_COUNTER_RAWCOUNT
Dynamic Update TimeOuts | Shows the total number of dynamic update timeouts of the DNS server. | PERF_COUNTER_RAWCOUNT
Dynamic Update Written to Database | Shows the total number of dynamic updates written to the database by the DNS server. | PERF_COUNTER_RAWCOUNT
Dynamic Update Written to Database/sec | Shows the rate at which dynamic updates are written to the database by the DNS server. | PERF_COUNTER_COUNTER
IXFR Request Received | Shows the total number of incremental zone transfer requests received by the master DNS server. | PERF_COUNTER_RAWCOUNT
IXFR Request Sent | Shows the total number of incremental zone transfer requests sent by the secondary DNS server. | PERF_COUNTER_RAWCOUNT
IXFR Response Received | Shows the total number of incremental zone transfer responses received by the secondary DNS server. | PERF_COUNTER_RAWCOUNT
IXFR Success Received | Shows the total number of successful incremental zone transfers received by the secondary DNS server. | PERF_COUNTER_RAWCOUNT
IXFR Success Sent | Shows the total number of successful incremental zone transfers of the master DNS server. | PERF_COUNTER_RAWCOUNT
IXFR TCP Success Received | Shows the total number of successful TCP incremental zone transfers received by the secondary DNS server. | PERF_COUNTER_RAWCOUNT
IXFR UDP Success Received | Shows the total number of successful UDP incremental zone transfers received by the secondary DNS server. | PERF_COUNTER_RAWCOUNT
Nbstat Memory | Shows the total Nbstat memory used by the DNS server. | PERF_COUNTER_RAWCOUNT
Notify Received | Shows the total number of notifies received by the secondary DNS server. | PERF_COUNTER_RAWCOUNT
Notify Sent | Shows the total number of notifies sent by the master DNS server. | PERF_COUNTER_RAWCOUNT
Record Flow Memory | Shows the total record flow memory used by the DNS server. | PERF_COUNTER_RAWCOUNT
Recursive Queries | Shows the total number of recursive queries received by the DNS server. | PERF_COUNTER_RAWCOUNT
Recursive Queries/sec | Shows the rate at which recursive queries are received by the DNS server. | PERF_COUNTER_COUNTER
Recursive Query Failure | Shows the total number of recursive query failures. | PERF_COUNTER_RAWCOUNT
Recursive Query Failure/sec | Shows the rate of recursive query failures. | PERF_COUNTER_COUNTER
Recursive Send TimeOuts | Shows the total number of recursive query sending timeouts. | PERF_COUNTER_RAWCOUNT
Recursive TimeOut/sec | Shows the rate of recursive query sending timeouts. | PERF_COUNTER_COUNTER
Secure Update Failure | Shows the total number of secure update failures of the DNS server. | PERF_COUNTER_RAWCOUNT
Secure Update Received | Shows the total number of secure update requests received by the DNS server. | PERF_COUNTER_RAWCOUNT
Secure Update Received/sec | Shows the rate at which secure update requests are received by the DNS server. | PERF_COUNTER_COUNTER
TCP Message Memory | Shows the total amount of TCP message memory used by the DNS server. | PERF_COUNTER_RAWCOUNT
TCP Query Received | Shows the total number of TCP queries received by the DNS server. | PERF_COUNTER_RAWCOUNT
TCP Query Received/sec | Shows the rate at which TCP queries are received by the DNS server. | PERF_COUNTER_COUNTER
TCP Response Sent | Shows the total number of TCP responses sent by the DNS server. | PERF_COUNTER_RAWCOUNT
TCP Response Sent/sec | Shows the rate at which TCP responses are sent by the DNS server. | PERF_COUNTER_COUNTER
Total Query Received | Shows the total number of queries received by the DNS server. | PERF_COUNTER_RAWCOUNT
Total Query Received/sec | Shows the rate at which queries are received by the DNS server. | PERF_COUNTER_COUNTER
Total Response Sent | Shows the total number of responses sent by the DNS server. | PERF_COUNTER_RAWCOUNT
Total Response Sent/sec | Shows the rate at which responses are sent by the DNS server. | PERF_COUNTER_COUNTER
UDP Message Memory | Shows the total UDP message memory used by the DNS server. | PERF_COUNTER_RAWCOUNT
UDP Query Received | Shows the total number of UDP queries received by the DNS server. | PERF_COUNTER_RAWCOUNT
UDP Query Received/sec | Shows the rate at which UDP queries are received by the DNS server. | PERF_COUNTER_COUNTER
UDP Response Sent | Shows the total number of UDP responses sent by the DNS server. | PERF_COUNTER_RAWCOUNT
UDP Response Sent/sec | Shows the rate at which UDP responses are sent by the DNS server. | PERF_COUNTER_COUNTER
WINS Lookup Received | Shows the total number of WINS lookup requests received by the DNS server. | PERF_COUNTER_RAWCOUNT
WINS Lookup Received/sec | Shows the rate at which WINS lookup requests are received by the DNS server. | PERF_COUNTER_COUNTER
WINS Response Sent | Shows the total number of WINS lookup responses sent by the DNS server. | PERF_COUNTER_RAWCOUNT
WINS Response Sent/sec | Shows the rate at which WINS lookup responses are sent by the server. | PERF_COUNTER_COUNTER
WINS Reverse Lookup Received | Shows the total number of WINS reverse lookup requests received by the DNS server. | PERF_COUNTER_RAWCOUNT
WINS Reverse Lookup Received/sec | Shows the rate at which WINS reverse lookup requests are received by the DNS server. | PERF_COUNTER_RAWCOUNT
WINS Reverse Response Sent | Shows the total number of WINS Reverse lookup responses sent by the DNS server. | PERF_COUNTER_RAWCOUNT
WINS Reverse Response Sent/sec | Shows the rate at which WINS Reverse lookup responses are sent by the server. | PERF_COUNTER_COUNTER
Zone Transfer Failure | Shows the total number of failed zone transfers of the master DNS server. | PERF_COUNTER_RAWCOUNT
Zone Transfer Request Received | Shows the total number of zone transfer requests received by the master DNS server. | PERF_COUNTER_RAWCOUNT
Zone Transfer SOA Request Sent | Shows the total number of zone transfer start of authority (SOA) requests sent by the secondary DNS server. | PERF_COUNTER_RAWCOUNT
Zone Transfer Success | Shows the total number of successful zone transfers of the master DNS server. | PERF_COUNTER_RAWCOUNT

See also

  • DNS Service


Fax Service Object

The Fax Service performance object tracks fax activity while the Fax service is running. It is recommended that you use the counters in conjunction with event log data about fax events to assess service performance. The following counters can indicate system problems, such as installation of the wrong modem driver, which prevents the fax from being sent or received.

Counter Name | Description | Counter Type
Inbound bytes | Shows the number of inbound bytes received by the Fax service. | PERF_COUNTER_RAWCOUNT
Inbound failed receptions | Shows the number of faxes that were not received, such as a call that was answered without a fax being received. | PERF_COUNTER_RAWCOUNT
Inbound faxes | Shows the number of inbound faxes received by the Fax service. | PERF_COUNTER_RAWCOUNT
Inbound minutes receiving | Shows the time, in minutes, spent receiving inbound messages. | PERF_COUNTER_RAWCOUNT
Inbound pages | Shows the number of inbound pages received by the Fax service. | PERF_COUNTER_RAWCOUNT
Outbound bytes | Shows the number of outbound bytes sent by the Fax service. | PERF_COUNTER_RAWCOUNT
Outbound failed connections | Shows the number of faxes that were not sent, for example, because there was no dial tone, no answer, busy, or another unknown error. | PERF_COUNTER_RAWCOUNT
Outbound failed transmissions | Shows the number of faxes that could not be sent. | PERF_COUNTER_RAWCOUNT
Outbound faxes | Shows the number of outbound faxes sent by the Fax service. | PERF_COUNTER_RAWCOUNT
Outbound minutes sending | Shows the time, in minutes, spent sending outbound messages. | PERF_COUNTER_RAWCOUNT
Outbound pages | Shows the number of outbound pages sent by the Fax service. | PERF_COUNTER_RAWCOUNT
Total bytes | Shows the total number of bytes sent and received by the Fax service. | PERF_COUNTER_RAWCOUNT
Total faxes | Shows the total number of faxes sent and received by the Fax service. | PERF_COUNTER_RAWCOUNT
Total minutes sending/receiving | Shows the total time, in minutes, spent sending and receiving. | PERF_COUNTER_RAWCOUNT
Total pages | Shows the total number of pages sent and received by the Fax service. | PERF_COUNTER_RAWCOUNT

See also

  • Fax Service


FileReplicaConn Object

The FileReplicaConn performance object displays performance statistics of the REPLICACONN object that defines replica connections to distributed file system (Dfs) roots.

Counter Name | Description | Counter Type
Authentications | Shows the number of authentications performed. | PERF_COUNTER_COUNTER
Authentications in Error | Shows the number of authentications performed in error. | PERF_COUNTER_COUNTER
Bindings | Shows the number of bindings completed. | PERF_COUNTER_COUNTER
Bindings in Error | Shows the number of bindings completed in error. | PERF_COUNTER_COUNTER
Communication Timeouts | Shows the number of communication timeouts. | PERF_COUNTER_COUNTER
Fetch Blocks Received | Shows the number of fetch blocks received. | PERF_COUNTER_COUNTER
Fetch Blocks Received in Bytes | Shows the number of fetch blocks received in bytes. | PERF_COUNTER_BULK_COUNT
Fetch Blocks Sent | Shows the number of fetch blocks sent. | PERF_COUNTER_COUNTER
Fetch Blocks Sent in Bytes | Shows the number of fetch blocks sent in bytes. | PERF_COUNTER_BULK_COUNT
Fetch Requests Received | Shows the number of fetch requests received. | PERF_COUNTER_COUNTER
Fetch Requests Sent | Shows the number of fetch requests sent. | PERF_COUNTER_COUNTER
Inbound Change Orders Dampened | Shows the number of inbound change orders dampened. | PERF_COUNTER_COUNTER
Join Notifications Received | Shows the number of join notifications received. | PERF_COUNTER_COUNTER
Join Notifications Sent | Shows the number of join notifications sent. | PERF_COUNTER_COUNTER
Joins | Shows the number of joins. | PERF_COUNTER_COUNTER
Local Change Orders Sent | Shows the number of local change orders sent. | PERF_COUNTER_COUNTER
Local Change Orders Sent At Join | Shows the number of local change orders sent at join. | PERF_COUNTER_COUNTER
Outbound Change Orders Dampened | Shows the number of outbound change orders dampened. | PERF_COUNTER_COUNTER
Packets Sent | Shows the number of packets sent. | PERF_COUNTER_COUNTER
Packets Sent in Bytes | Shows the number of packets sent, in bytes. | PERF_COUNTER_BULK_COUNT
Packets Sent in Error | Shows the number of packets sent in error. | PERF_COUNTER_COUNTER
Remote Change Orders Received | Shows the number of remote change orders received. | PERF_COUNTER_COUNTER
Remote Change Orders Sent | Shows the number of remote change orders sent. | PERF_COUNTER_COUNTER
Unjoins | Shows the number of unjoins. | PERF_COUNTER_COUNTER

See also

  • File Replication Service


FileReplicaSet Object

The FileReplicaSet performance object displays performance statistics of the REPLICASET object that defines a replica set (one or more replicas, shared volumes or directories that store duplicates of the contents of an original share). The object reports statistics for the computer that constitutes the original share. For example, in a bidirectional ring topology of three computers A, B, and C, where computer A and computer C both replicate from computer B, the FileReplicaSet counters would provide data for computer B.

Counter Name | Description | Counter Type
Authentications | Shows the number of authentications performed. | PERF_COUNTER_COUNTER
Authentications in Error | Shows the number of authentications performed in error. | PERF_COUNTER_COUNTER
Bindings | Shows the number of bindings completed. | PERF_COUNTER_COUNTER
Bindings in Error | Shows the number of bindings completed in error. | PERF_COUNTER_COUNTER
Bytes of Files Installed | Shows the number of bytes of files installed. | PERF_COUNTER_BULK_COUNT
Bytes of Staging Fetched | Shows the number of bytes of staging fetched. Staging is the temporary storage of files prior to replication. | PERF_COUNTER_BULK_COUNT
Bytes of Staging Generated | Shows the number of bytes of staging generated. | PERF_COUNTER_BULK_COUNT
Bytes of Staging Regenerated | Shows the number of bytes of staging regenerated. | PERF_COUNTER_BULK_COUNT
Change Orders Aborted | Shows the number of change orders aborted. | PERF_COUNTER_COUNTER
Change Orders Evaporated | Shows the number of change orders evaporated. | PERF_COUNTER_COUNTER
Change Orders Issued | Shows the number of change orders issued. | PERF_COUNTER_COUNTER
Change Orders Morphed | Shows the number of change orders morphed. | PERF_COUNTER_COUNTER
Change Orders Propagated | Shows the number of change orders propagated. | PERF_COUNTER_COUNTER
Change Orders Received | Shows the number of change orders received. This is an important counter to monitor. In an idle state this counter should be zero. | PERF_COUNTER_COUNTER
Change Orders Retired | Shows the number of change orders retired. | PERF_COUNTER_COUNTER
Change Orders Retried | Shows the number of change orders retried. | PERF_COUNTER_COUNTER
Change Orders Retried at Fetch | Shows the number of change orders retried at fetch. | PERF_COUNTER_COUNTER
Change Orders Retried at Generate | Shows the number of change orders retried at generate. | PERF_COUNTER_COUNTER
Change Orders Retried at Install | Shows the number of change orders retried at install. | PERF_COUNTER_COUNTER
Change Orders Retried at Rename | Shows the number of change orders retried at rename. | PERF_COUNTER_COUNTER
Change Orders Sent | Shows the number of change orders sent. This is an important counter to monitor. In an idle state this counter should be zero. | PERF_COUNTER_COUNTER
Communication Timeouts | Shows the number of communication timeouts. | PERF_COUNTER_COUNTER
DS Bindings | Shows the number of directory bindings. | PERF_COUNTER_COUNTER
DS Bindings in Error | Shows the number of directory bindings in error. | PERF_COUNTER_COUNTER
DS Objects | Shows the number of directory service objects. | PERF_COUNTER_COUNTER
DS Objects in Error | Shows the number of directory service objects in error. | PERF_COUNTER_COUNTER
DS Polls | Shows the number of directory service polls. | PERF_COUNTER_COUNTER
DS Polls with Changes | Shows the number of directory service polls with changes. | PERF_COUNTER_COUNTER
DS Polls without Changes | Shows the number of directory service polls without changes. | PERF_COUNTER_COUNTER
DS Searches | Shows the number of directory serive searches. | PERF_COUNTER_COUNTER
DS Searches in Error | Shows the number of directory service searches in error. | PERF_COUNTER_COUNTER
Fetch Blocks Received | Shows the number of fetch blocks received. | PERF_COUNTER_COUNTER
Fetch Blocks Received in Bytes | Shows the number of fetch blocks received in bytes. | PERF_COUNTER_BULK_COUNT
Fetch Blocks Sent | Shows the number of fetch blocks sent. | PERF_COUNTER_COUNTER
Fetch Blocks Sent in Bytes | Shows the number of fetch blocks sent in bytes. | PERF_COUNTER_BULK_COUNT
Fetch Requests Received | Shows the number of fetch requests received. | PERF_COUNTER_COUNTER
Fetch Requests Sent | Shows the number of fetch requests sent. | PERF_COUNTER_COUNTER
Files Installed | Shows the number of files installed. This is an important counter to monitor. In an idle state this counter should be zero. | PERF_COUNTER_COUNTER
Files Installed with Error | Shows the number of files installed with error. | PERF_COUNTER_COUNTER
Inbound Change Orders Dampened | Shows the number of inbound change orders dampened. | PERF_COUNTER_COUNTER
Join Notifications Received | Shows the number of join notifications received. | PERF_COUNTER_COUNTER
Join Notifications Sent | Shows the number of join notifications sent. | PERF_COUNTER_COUNTER
Joins | Shows the number of joins. | PERF_COUNTER_COUNTER
KB of Staging Space Free | Shows the number of kilobytes of staging space free. This is an important counter to monitor. In an idle state, this counter should be 660 MB. | PERF_COUNTER_LARGE_RAWCOUNT
KB of Staging Space In Use | Shows the number of kilobytes of staging space in use. This is an important counter to monitor. If all available staging space is in use, then replication stops. | PERF_COUNTER_LARGE_RAWCOUNT
Local Change Orders Aborted | Shows the number of local change orders aborted. | PERF_COUNTER_COUNTER
Local Change Orders Issued | Shows the number of local change orders issued. | PERF_COUNTER_COUNTER
Local Change Orders Morphed | Shows the number of local change orders morphed. | PERF_COUNTER_COUNTER
Local Change Orders Propagated | Shows the number of local change orders propagated. | PERF_COUNTER_COUNTER
Local Change Orders Retired | Shows the number of local change orders retired. | PERF_COUNTER_COUNTER
Local Change Orders Retried | Shows the number of local change orders retried. | PERF_COUNTER_COUNTER
Local Change Orders Retried at Fetch | Shows the number of local change orders retried at fetch. | PERF_COUNTER_COUNTER
Local Change Orders Retried at Generate | Shows the number of local change orders retried at generate. | PERF_COUNTER_COUNTER
Local Change Orders Retried at Install | Shows the number of local change orders retried at install. | PERF_COUNTER_COUNTER
Local Change Orders Retried at Rename | Shows the number of local change orders retried at rename. | PERF_COUNTER_COUNTER
Local Change Orders Sent | Shows the number of local change orders sent. | PERF_COUNTER_COUNTER
Local Change Orders Sent At Join | Shows the number of local change orders sent at join. | PERF_COUNTER_COUNTER
Outbound Change Orders Dampened | Shows the number of outbound change orders dampened. | PERF_COUNTER_COUNTER
Packets Received | Shows the number of packets (change notifications, file data, or other command packets) received. This is an important counter to monitor. In an idle state, there should be no packets received unless a computer is having trouble joining with other computers in the replica set. | PERF_COUNTER_COUNTER
Packets Received in Bytes | Shows the number of packets received in bytes. | PERF_COUNTER_BULK_COUNT
Packets Received in Error | Shows the number of packets received in error. | PERF_COUNTER_COUNTER
Packets Sent | Shows the number of packets sent. This is an important counter to monitor. | PERF_COUNTER_COUNTER
Packets Sent in Bytes | Shows the number of packets sent in bytes. | PERF_COUNTER_BULK_COUNT
Packets Sent in Error | Shows the number of packets sent in error. | PERF_COUNTER_COUNTER
Remote Change Orders Aborted | Shows the number of remote change orders aborted. | PERF_COUNTER_COUNTER
Remote Change Orders Issued | Shows the number of remote change orders issued. | PERF_COUNTER_COUNTER
Remote Change Orders Morphed | Shows the number of remote change orders morphed. | PERF_COUNTER_COUNTER
Remote Change Orders Propagated | Shows the number of remote change orders propagated. | PERF_COUNTER_COUNTER
Remote Change Orders Received | Shows the number of remote change orders received. | PERF_COUNTER_COUNTER
Remote Change Orders Retired | Shows the number of remote change orders retired. | PERF_COUNTER_COUNTER
Remote Change Orders Retried | Shows the number of remote change orders retried. | PERF_COUNTER_COUNTER
Remote Change Orders Retried at Fetch | Shows the number of remote change orders retried at fetch. | PERF_COUNTER_COUNTER
Remote Change Orders Retried at Generate | Shows the number of remote change orders retried at generate. | PERF_COUNTER_COUNTER
Remote Change Orders Retried at Install | Shows the number of remote change orders retried at install. | PERF_COUNTER_COUNTER
Remote Change Orders Retried at Rename | Shows the number of remote change orders retried at rename. | PERF_COUNTER_COUNTER
Remote Change Orders Sent | Shows the number of remote change orders sent. | PERF_COUNTER_COUNTER
Replica Sets Created | Shows the number of replica sets created. | PERF_COUNTER_COUNTER
Replica Sets Deleted | Shows the number of replica sets deleted. | PERF_COUNTER_COUNTER
Replica Sets Removed | Shows the number of replica sets removed. | PERF_COUNTER_COUNTER
Replica Sets Started | Shows the number of replica sets started. | PERF_COUNTER_COUNTER
Staging Files Fetched | Shows the number of staging files fetched. | PERF_COUNTER_COUNTER
Staging Files Generated | Shows the number of staging files generated. | PERF_COUNTER_COUNTER
Staging Files Generated with Error | Shows the number of staging files generated with error. | PERF_COUNTER_COUNTER
Staging Files Regenerated | Shows the number of staging files regenerated. | PERF_COUNTER_COUNTER
Threads exited | Shows the number of threads exited. | PERF_COUNTER_COUNTER
Threads started | Shows the number of threads started. | PERF_COUNTER_COUNTER
Unjoins | Shows the number of unjoins. | PERF_COUNTER_COUNTER
Usn Reads | Shows the number of update sequence number (USN) reads. | PERF_COUNTER_COUNTER
Usn Records Accepted | Shows the number of USN records accepted. This is an important counter to monitor. Replication is triggered by entries to the NTFS USN journal. A high value on this counter, such as one every five seconds, indicates heavy replication traffic and may result in replication latency. | PERF_COUNTER_COUNTER
Usn Records Examined | Shows the number of USN records examined. | PERF_COUNTER_COUNTER
Usn Records Rejected | Shows the number of USN records rejected. | PERF_COUNTER_COUNTER

See also

  • File Replication Service


FTP Service Object

The FTP Service performance object consists of counters that show data about the Internet Information Services FTP service.

Counter Name | Description | Counter Type
Bytes Received/sec | Shows the rate at which data bytes are received by the FTP service at the application layer. This value does not include protocol headers or control bytes associated with the data received. Bytes Received/sec is a subset of FTP Service\Bytes Total/sec. | PERF_COUNTER_BULK_COUNT
Bytes Sent/sec | Shows the rate at which data bytes are sent by the FTP service at the application layer. This value does not include protocol headers or control bytes associated with the data sent. Bytes Sent/sec is a subset of FTP Service\Bytes Total/sec. | PERF_COUNTER_BULK_COUNT
Bytes Total/sec | Shows the rate at which data bytes are sent and received by the FTP service at the application layer. This value does not include protocol headers or control bytes associated with the data transmitted. Bytes Total/sec is the sum of the values of FTP Service\Bytes Sent/sec and FTP Service\Bytes Received/sec. | PERF_COUNTER_BULK_COUNT
Current Anonymous Users | Shows the number of anonymous connections to the FTP service noted during the most recent observation. Anonymous connections are connections whose requests either did not contain a user name and password or whose user name and password were ignored because authentication is not permitted on the server. If anonymous connections are not permitted on the server, the value of Current Anonymous Users is zero. Current Anonymous Users shows successful connections only. If a client request for an anonymous connection is rejected and the client responds with valid authenticating data, the connection is counted as nonanonymous. The value of this counter might not reflect the exact number of connections: when System Monitor observed the counter value, new connections might not yet have been entered, and closed connections might not yet have been deleted. | PERF_COUNTER_RAWCOUNT
Current Connections | Shows the number of connections to the FTP service noted during the most recent observation. The value of this counter might not reflect the exact number of connections: when System Monitor observed the counter value, new connections might not yet have been entered, and closed connections might not yet have been deleted. | PERF_COUNTER_RAWCOUNT
Current NonAnonymous Users | Shows the number of nonanonymous connections to the FTP service noted during the most recent observation. Nonanonymous connections are connections whose requests contain a valid user name and password, or other authentication that is required by a custom authentication scheme. If authentication is not enabled on the server, and none of the applications that run on the server request or require authentication, the value of Current NonAnonymous Users is zero. Current NonAnonymous Users shows successful connections only. If a client request for an anonymous connection is rejected and the client responds with valid authenticating data, the connection is counted as nonanonymous. The value of this counter might not reflect the exact number of connections: when System Monitor observed the counter value, new connections might not yet have been entered, and closed connections might not yet have been deleted. | PERF_COUNTER_RAWCOUNT
Maximum Anonymous Users | Shows the largest number of anonymous connections to the FTP service maintained simultaneously since the FTP service was started. The value of this counter might not reflect the exact number of connections: when System Monitor observed the counter value, new connections might not yet have been entered, and closed connections might not yet have been deleted. | PERF_COUNTER_RAWCOUNT
Maximum Connections | Shows the largest number of connections to the FTP service simultaneously maintained since the FTP service started. The value of this counter might not reflect the exact number of connections: when System Monitor observed the counter value, new connections might not yet have been entered, and closed connections might not yet have been deleted. | PERF_COUNTER_RAWCOUNT
Maximum NonAnonymous Users | Shows the largest number of nonanonymous connections to the FTP service maintained simultaneously since the FTP service was started. Maximum NonAnonymous Users shows successful connections only. If a client request for an anonymous connection is rejected and the client responds with valid authenticating data, the connection is counted as nonanonymous. The value of this counter might not reflect the exact number of connections: when System Monitor observed the counter value, new connections might not yet have been entered, and closed connections might not yet have been deleted. | PERF_COUNTER_RAWCOUNT
Total Anonymous Users | Shows the number of anonymous connections to the FTP service that have been established since the FTP service was started. Total Anonymous Users shows successful connections only. If a client request for an anonymous connection is rejected and the client responds with valid authenticating data, the connection is counted as nonanonymous. The value of this counter might not reflect the exact number of connections: when System Monitor observed the counter value, new connections might not yet have been entered, and closed connections might not yet have been deleted. | PERF_COUNTER_RAWCOUNT
Total Connection Attempts | Shows the total number of connections to the FTP service that have been established since the service was started. The value of this counter either remains the same or increases over time. This value does not include failed attempts to connect to the FTP server. To monitor all connection attempts, use the Connection counters on the TCP performance object. To monitor the number of connections to the FTP server that are currently active, use the FTP Service\ Current Connections counter. | PERF_COUNTER_RAWCOUNT
Total Files Received | Shows the total number of files received by the FTP service since the service was started. Total Files Received is a subset of FTP Service\Total Files Transferred. | PERF_COUNTER_RAWCOUNT
Total Files Sent | Shows the total number of files sent by the FTP service since the service was started. Total Files Sent is a subset of the FTP Service\Total Files Transferred counter. | PERF_COUNTER_RAWCOUNT
Total Files Transferred | Shows the total number of files transmitted by the FTP service since the service was started. Files Total is the sum of the values of FTP Service\Total Files Sent and FTP Service\Total Files Received. | PERF_COUNTER_RAWCOUNT
Total Logon Attempts | Shows the total number of times a user logged on successfully to the FTP service since the service was started. This counter is incremented when a connection satisfies the criteria for logging on to FTP, such as providing user authentication requirements. The FTP service supports clear-text logon authentication. The value of Total Logon Attempts does not include failed attempts to log on to the FTP service. However, the value of FTP Service\Total Logon Attempts is a subset of the value of FTP Service\Total Connection Attempts. Failed logon attempts (situations where clients were able to connect but not to log on) can be calculated by subtracting the value of Total Logon Attempts from the value of Total Connection Attempts. | PERF_COUNTER_RAWCOUNT
Total NonAnonymous Users | Shows the number of nonanonymous connections to the FTP service that have been established since the FTP service was started. Total NonAnonymous Users shows successful connections only. If a client request for an anonymous connection is rejected and the client responds with valid authenticating data, the connection is counted as nonanonymous. The value of this counter might not reflect the exact number of connections: when System Monitor observed the counter value, new connections might not yet have been entered, and closed connections might not yet have been deleted. | PERF_COUNTER_RAWCOUNT

See also

  • Internet Information Service


Gateway for NetWare Service Object

The Gateway for NetWare Service performance object consists of counters that measure packet transmission rates and activity of the Gateway for NetWare service.

Counter Name | Description | Counter Type
Bytes Received/sec | Shows the rate of bytes coming in to the Redirector from the network. It includes all application data in addition to network protocol information (such as packet headers.) | PERF_COUNTER_BULK_COUNT
Bytes Total/sec | Shows the rate the Redirector is processing data bytes. It includes all application and file data in addition to protocol information. | PERF_COUNTER_BULK_COUNT
Bytes Transmitted/sec | Shows the rate at which bytes are leaving the Redirector to the network. It includes all application in addition to network protocol information. | PERF_COUNTER_BULK_COUNT
Connect NetWare 2.x | Shows the number of connections to NetWare 2.x servers. | PERF_COUNTER_RAWCOUNT
Connect NetWare 3.x | Shows the number of connections to NetWare 3.x servers. | PERF_COUNTER_RAWCOUNT
Connect NetWare 4.x | Shows the number of connections to NetWare 4.x servers. | PERF_COUNTER_RAWCOUNT
File Data Operations/sec | Shows the rate at which the Redirector is processing data operations. One operation includes many bytes but can be reduced because each packet has protocol overhead. You can determine the efficiency of this path by dividing the value of Bytes/sec by this counter to determine the average number of bytes transferred per operation. | PERF_COUNTER_COUNTER
File Read Operations/sec | Shows the rate at which applications are asking the Redirector for data. Each call to a file system or similar API call counts as one operation. | PERF_COUNTER_COUNTER
File Write Operations/sec | Shows the rate at which applications are sending data to the Redirector. Each call to a file system or similar API call counts as one operation. | PERF_COUNTER_COUNTER
Packet Burst IO/sec | Shows the sum of the values of Packet Burst Read NCPs/sec and Packet Burst Write NCPs/sec. | PERF_COUNTER_COUNTER
Packet Burst Read NCP Count/sec | Shows the rate of NetWare Core Protocol requests for Packet Burst Read. Packet Burst is a windowing protocol that improves performance. | PERF_COUNTER_COUNTER
Packet Burst Read Timeouts/sec | Shows the rate the NetWare Service needs to retransmit a Burst Read Request because the NetWare server took too long to respond. | PERF_COUNTER_COUNTER
Packet Burst Write NCP Count/sec | Shows the rate of NetWare Core Protocol requests for Packet Burst Write. | PERF_COUNTER_COUNTER
Packet Burst Write Timeouts/sec | Shows the rate at which the NetWare Service needs to retransmit a Burst Write Request because the NetWare server took too long to respond. | PERF_COUNTER_COUNTER
Packets Received/sec | Shows the rate at which the Redirector is receiving packets (SMBs). Network transmissions are divided into packets. The average number of bytes received in a packet can be obtained by dividing the value of Bytes Received/sec by this counter. Some packets received might not contain incoming data, for example an acknowledgment to a write made by the Redirector would count as an incoming packet. | PERF_COUNTER_BULK_COUNT
Packets Transmitted/sec | Shows the rate at which the Redirector is sending packets. Network transmissions are divided into packets. The average number of bytes transmitted in a packet can be obtained by dividing the value of Bytes Transmitted/sec by this counter. | PERF_COUNTER_BULK_COUNT
Packets/sec | Shows the rate the Redirector is processing data packets. One packet typically includes many bytes but can be reduced because each packet has protocol overhead. You can determine the efficiency of this path by dividing the value of Bytes/sec by this counter to determine the average number of bytes transferred/packet. You can also divide this counter by the value of Operations/sec to determine the average number of packets per operation. | PERF_COUNTER_BULK_COUNT
Read Operations Random/sec | Shows the rate at which, on a file-by-file basis, nonsequential reads are made. If a read is made using a particular file handle, and then is followed by another read that is not the contiguous next byte, this counter is incremented by one. | PERF_COUNTER_COUNTER
Read Packets/sec | Shows the rate at which read packets are being placed on the network. Each time a single packet is sent with a request to read data remotely, this counter is incremented by one. | PERF_COUNTER_COUNTER
Server Disconnects | Shows the number of times that a server has disconnected your Redirector. See also Server Reconnects. | PERF_COUNTER_RAWCOUNT
Server Reconnects | Shows the number of times the Redirector has had to reconnect to a server to complete a new active request. You can be disconnected by the Server if you remain inactive for too long. Locally even if all your remote files are closed, the Redirector will keep your connections intact for ten minutes. Such inactive connections are called Dormant Connections. Reconnecting is expensive in time. | PERF_COUNTER_RAWCOUNT
Server Sessions | Shows the total number of security objects that the Redirector has managed. For example, a logon to a server followed by a network access to the same server will establish one connection, but two sessions. | PERF_COUNTER_RAWCOUNT
Write Operations Random/sec | Shows the rate at which, on a file-by-file basis, nonsequential writes are made. | PERF_COUNTER_COUNTER
Write Packets/sec | Shows the rate at which writes are being sent to the network. Each time a single packet is sent with a request to write remote data, this counter is incremented by one. | PERF_COUNTER_COUNTER

See also

  • Internet Information Service


Http Indexing Service Object

The Http Indexing Service object counters report statistics regarding queries run by Indexing Service through Internet Information Service. Unlike other Indexing Service counters, which can report values even if Indexing Service is not being used in conjunction with a Web server, these counters only report values when Indexing Services queries are executed through the Web server.

Counter Name | Description | Counter Type
% Cache Hits | Shows the percentage of queries that were found in the cache, out of the total number of times the cache was queried. | PERF_RAW_FRACTION
% Cache Misses | Shows the percentage of times queries that were not found in the cache, out of the total number of times the cache was queried. | PERF_RAW_FRACTION
Active Queries | Shows the current number of running queries. | PERF_COUNTER_RAWCOUNT
Cache Items | Shows the number of completed queries that are stored in the cache since the Web service was started and the first query was posted. | PERF_COUNTER_RAWCOUNT
Current Requests Queued | Shows the current number of query requests that are pending. | PERF_COUNTER_RAWCOUNT
Queries per Minute | Shows the number of queries executed per minute by the server. This counter can be used to determine server usage. | PERF_COUNTER_RAWCOUNT
Total Queries | Shows the total number of queries run since the service was started. | PERF_COUNTER_RAWCOUNT
Total Requests Rejected | Shows the total number of query requests that were rejected because the server was too busy. If this value begins to increase steadily, a bottleneck is developing. To alleviate this condition, reconfigure the server by adding more random-access memory (RAM) or use less resource-intensive queries. See the Indexing Service documentation for more information. | PERF_COUNTER_RAWCOUNT

See also

  • Indexing Service


IAS Accounting Clients Object

The IAS Accounting Clients performance object is installed by the Internet Authentication Service (IAS). IAS uses the Remote Authentication Dial-In User Service (RADIUS) protocol to perform remote authentication. IAS performance objects report activity for servers or clients, including user authentication, authorization, and accounting (usage).

When selecting counters for this object, note that each client is a separate instance.

Counter Name | Description | Counter Type
Accounting-Requests | Shows the number of packets received from this client on the accounting port. | PERF_COUNTER_RAWCOUNT
Accounting-Requests/sec | Shows the rate, in seconds, at which packets were received from this client on the accounting port. | PERF_COUNTER_COUNTER
Accounting-Responses | Shows the number of RADIUS Accounting-Response packets sent to this client. | PERF_COUNTER_RAWCOUNT
Accounting-Responses/sec | Shows the rate in seconds at which duplicate RADIUS Accounting-Request packets were received from this client. | PERF_COUNTER_COUNTER
Bad Authenticators | Shows the number of packets that contained invalid Signature attributes. | PERF_COUNTER_RAWCOUNT
Bad Authenticators/sec | Shows the rate, in seconds, at which packets that contained invalid Signature attributes were received. | PERF_COUNTER_COUNTER
Dropped Packets | Shows the number of incoming packets silently discarded for a reason other than being malformed, bad authenticators, or unknown types. | PERF_COUNTER_RAWCOUNT
Dropped Packets/sec | Shows the rate in seconds at which incoming packets were silently discarded for a reason other than being malformed, bad authenticators, or unknown types. | PERF_COUNTER_COUNTER
Duplicate Accounting-Requests | Shows the number of duplicate RADIUS Accounting-Request packets received from this client. | PERF_COUNTER_RAWCOUNT
Duplicate Accounting-Requests/sec | Shows the rate, in seconds, at which duplicate RADIUS Accounting-Request packets were received from this client. | PERF_COUNTER_COUNTER
Malformed Packets | Shows the number of malformed packets received. Bad authenticators or unknown types are not included. | PERF_COUNTER_RAWCOUNT
Malformed Packets/sec | Shows the rate, in seconds, at which malformed packets were received. | PERF_COUNTER_COUNTER
No Record | Shows the number of RADIUS Accounting-Request packets that were received and responded to but not recorded. | PERF_COUNTER_RAWCOUNT
No Record/sec | Shows the rate, in seconds, at which RADIUS Accounting-Request packets were received and responded to but not recorded. | PERF_COUNTER_COUNTER
Packets Received | Shows the number of packets received. | PERF_COUNTER_RAWCOUNT
Packets Received/sec | Shows the rate, in seconds, at which packets were received. | PERF_COUNTER_COUNTER
Packets Sent | Shows the number of packets sent. | PERF_COUNTER_RAWCOUNT
Packets Sent/sec | Shows the rate, in seconds, at which packets were sent. | PERF_COUNTER_COUNTER
Unknown Type | Shows the number of packets of unknown type that were received. An unknown type is a RADIUS packet that contains an unrecognized entry in the Code field, used to identify the packet type. Consequently IAS does not support packets of unknown type. | PERF_COUNTER_RAWCOUNT
Unknown Type/sec | Shows the rate, in seconds, at which packets of unknown type were received. | PERF_COUNTER_COUNTER

See also

  • Internet Authentication Service


IAS Accounting Server Object

The IAS Accounting Server performance object is installed by the IAS. IAS uses the RADIUS protocol to perform remote authentication. IAS performance objects report activity for servers or clients, including user authentication, authorization, and accounting (usage).

When selecting counters for this object, note that each client is a separate instance.

Counter Name | Description | Counter Type
Accounting-Requests | Shows the number of packets received from this client on the accounting port. | PERF_COUNTER_RAWCOUNT
Accounting-Requests/sec | Shows the rate, in seconds, at which packets were received from this client on the accounting port. | PERF_COUNTER_COUNTER
Accounting-Responses | Shows the number of RADIUS Accounting-Response packets sent to this client. | PERF_COUNTER_RAWCOUNT
Accounting-Responses/sec | Shows the rate, in seconds, at which RADIUS Accounting-Response packets were sent to this client. | PERF_COUNTER_COUNTER
Bad Authenticators | Shows the number of packets that contained invalid Signature attributes. | PERF_COUNTER_RAWCOUNT
Bad Authenticators/sec | Shows the rate, in seconds, at which packets that contained invalid Signature attributes were received. | PERF_COUNTER_COUNTER
Dropped Packets | Shows the number of incoming packets that were silently discarded for a reason other than being malformed, bad authenticators, or unknown types. | PERF_COUNTER_RAWCOUNT
Dropped Packets/sec | Shows the rate, in seconds, at which incoming packets were silently discarded for a reason other than being malformed, bad authenticators, or unknown types. | PERF_COUNTER_COUNTER
Duplicate Accounting-Requests | Shows the number of duplicate RADIUS Accounting-Request packets that were received from this client. | PERF_COUNTER_RAWCOUNT
Duplicate Accounting-Requests/sec | Shows the rate, in seconds, at which duplicate RADIUS Accounting-Request packets were received from this client. | PERF_COUNTER_COUNTER
Invalid Requests | Shows the number of packets received from unknown addresses. | PERF_COUNTER_RAWCOUNT
Invalid Requests/sec | Shows the rate, in seconds, at which packets were received from unknown addresses. | PERF_COUNTER_COUNTER
Malformed Packets | Shows the number of malformed packets received. Bad authenticators or unknown types are not included. | PERF_COUNTER_RAWCOUNT
Malformed Packets/sec | Shows the rate, in seconds, at which malformed packets were received. Bad authenticators or unknown types are not included. | PERF_COUNTER_COUNTER
No Record | Shows the number of RADIUS Accounting-Request packets that were received and responded to but not recorded. | PERF_COUNTER_RAWCOUNT
No Record/sec | Shows the rate in seconds at which RADIUS Accounting-Request packets were received and responded to but not recorded. | PERF_COUNTER_COUNTER
Packets Received | Shows the number of packets received. | PERF_COUNTER_RAWCOUNT
Packets Received/sec | Shows the rate, in seconds, at which packets were received. | PERF_COUNTER_COUNTER
Packets Sent | Shows the number of packets sent. | PERF_COUNTER_RAWCOUNT
Packets Sent/sec | Shows the rate, in seconds, at which packets were sent. | PERF_COUNTER_COUNTER
Server Reset Time | Shows the time elapsed, in hundredths of a second, since the server configuration was reset. | PERF_COUNTER_RAWCOUNT
Server Up Time | Shows the time elapsed, in hundredths of a second, since the server process was started. | PERF_COUNTER_RAWCOUNT
Unknown Type | Shows the number of packets of unknown type that were received. | PERF_COUNTER_RAWCOUNT
Unknown Type/sec | Shows the rate, in seconds, at which packets of unknown type were received. | PERF_COUNTER_COUNTER

See also

  • Internet Authentication Service


IAS Authentication Clients Object

The IAS Authentication Clients performance object is installed by IAS. IAS uses the RADIUS protocol to perform remote authentication. IAS performance objects report activity for servers or clients, including user authentication, authorization, and accounting (usage).

When selecting counters for this object, note that each client is a separate instance.

Counter Name | Description | Counter Type
Access-Accepts | Access-Accepts/sec | PERF_COUNTER_RAWCOUNT
Access-Accepts/sec | Access-Rejects | PERF_COUNTER_COUNTER
Access-Challenges | Access-Challenges/sec | PERF_COUNTER_RAWCOUNT
Access-Challenges/sec | Accounting-Requests | PERF_COUNTER_COUNTER
Access-Rejects | Access-Rejects/sec | PERF_COUNTER_RAWCOUNT
Access-Rejects/sec | Access-Challenges | PERF_COUNTER_COUNTER
Access-Requests | Access-Requests/sec | PERF_COUNTER_RAWCOUNT
Access-Requests/sec | Duplicate Access-Requests | PERF_COUNTER_COUNTER
Bad Authenticators | Bad Authenticators/sec | PERF_COUNTER_RAWCOUNT
Bad Authenticators/sec | Dropped Packets | PERF_COUNTER_COUNTER
Dropped Packets | Dropped Packets/sec | PERF_COUNTER_RAWCOUNT
Dropped Packets/sec | Unknown Type | PERF_COUNTER_COUNTER
Duplicate Access-Requests | Duplicate Access-Requests/sec | PERF_COUNTER_RAWCOUNT
Duplicate Access-Requests/sec | Access-Accepts | PERF_COUNTER_COUNTER
Malformed Packets | Malformed Packets/sec | PERF_COUNTER_RAWCOUNT
Malformed Packets/sec | Bad Authenticators | PERF_COUNTER_COUNTER
Packets Received | Packets Received/sec | PERF_COUNTER_RAWCOUNT
Packets Received/sec | Malformed Packets | PERF_COUNTER_COUNTER
Packets Sent | Packets Sent/sec | PERF_COUNTER_RAWCOUNT
Packets Sent/sec | Packets Received | PERF_COUNTER_COUNTER
Unknown Type | Unknown Type/sec | PERF_COUNTER_RAWCOUNT
Unknown Type/sec | Access-Requests | PERF_COUNTER_COUNTER

See also

  • Internet Authentication Service


IAS Authentication Server Object

The IAS Authentication Server performance object is installed by IAS. IAS uses the RADIUS protocol to perform remote authentication. IAS performance objects report activity for servers or clients, including user authentication, authorization, and accounting (usage).

When selecting counters for this object, note that each client is a separate instance.

Counter Name | Description | Counter Type
Access-Accepts | Shows the number of RADIUS Access-Accept packets sent to this client. | PERF_COUNTER_RAWCOUNT
Access-Accepts/sec | Shows the rate, in seconds, at which RADIUS Access-Accept packets were sent to this client.. | PERF_COUNTER_COUNTER
Access-Challenges | Shows the number of Access-Challenge packets sent to this client. | PERF_COUNTER_RAWCOUNT
Access-Challenges/sec | Shows the rate at which Access-Challenge messages are being processed. | PERF_COUNTER_COUNTER
Access-Rejects | Shows the number of RADIUS Access-Reject packets sent to this client. | PERF_COUNTER_RAWCOUNT
Access-Rejects/sec | Shows the rate at which Access-Reject messages are being processed. | PERF_COUNTER_COUNTER
Access-Requests | Shows the number of packets that were received on the authentication port from this client. | PERF_COUNTER_RAWCOUNT
Access-Requests/sec. | Shows the rate, in seconds, at which packets were received on an authentication port from this client. | PERF_COUNTER_COUNTER
Bad Authenticators | Shows the total number of packets that contained invalid signature attributes. | PERF_COUNTER_RAWCOUNT
Bad Authenticators/sec | Shows the rate in seconds at which packets that contained invalid signature attributes were received. | PERF_COUNTER_COUNTER
Dropped Packets | Shows the number of incoming packets dropped for reasons other than being malformed, bad authenticators, or unknown types. | PERF_COUNTER_RAWCOUNT
Dropped Packets/sec | Shows the rate, in seconds, at which packets were dropped for reasons other than being malformed, bad authenticators, or of an unknown type. | PERF_COUNTER_COUNTER
Duplicate Access-Requests | Shows the number of duplicate RADIUS Access-Request packets received from this client. | PERF_COUNTER_RAWCOUNT
Duplicate Access-Requests/sec | Shows the rate, in seconds, at which duplicate RADIUS Access-Request packets were received from this client. | PERF_COUNTER_COUNTER
Invalid Requests | Shows the number of packets received from unknown addresses. | PERF_COUNTER_RAWCOUNT
Invalid Requests/sec | Shows the rate, in seconds, at which packets were received from unknown addresses. | PERF_COUNTER_COUNTER
Malformed Packets | Shows the number of malformed packets received. Bad authenticators or unknown types are not included. | PERF_COUNTER_RAWCOUNT
Malformed Packets/sec | Shows the rate, in seconds, at which malformed packets were received. Bad authenticators or unknown types are not included. | PERF_COUNTER_COUNTER
Packets Received | Shows the number of packets received. | PERF_COUNTER_RAWCOUNT
Packets Received/sec | Shows the rate, in seconds, at which packets were received. | PERF_COUNTER_COUNTER
Packets Sent | Shows the number of packets sent. | PERF_COUNTER_RAWCOUNT
Packets Sent/sec | Shows the rate, in seconds, at which packets were sent. | PERF_COUNTER_COUNTER
Server Reset Time | Shows the time elapsed, in hundredths of a second, since the server configuration was reset. | PERF_COUNTER_RAWCOUNT
Server Up Time | Shows the time elapsed, in hundredths of a second, since the server process was started. | PERF_COUNTER_RAWCOUNT
Unknown Type | Shows the number of packets received that were of an unknown type. | PERF_COUNTER_RAWCOUNT
Unknown Type/sec | Shows the rate, in seconds, at which packets of an unknown type were received. | PERF_COUNTER_COUNTER

See also

  • Internet Authentication Service


ICMP Object

The ICMP performance object consists of counters that measure the rates at which Internet Control Message Protocol (ICMP) messages are sent and received by using the ICMP protocol. It also includes counters that monitor ICMP protocol errors.

Counter Name | Description | Counter Type
Messages Outbound Errors | Shows the number of ICMP messages that were not sent due to problems within ICMP such as lack of buffers. This value does not include errors discovered outside the ICMP layer, such as those recording the failure of IP to route the resultant datagram. In some implementations, none of the error types are included in the value of this counter. | PERF_COUNTER_RAWCOUNT
Messages Received Errors | Shows the number of ICMP messages that were received but had errors, such as bad ICMP checksums, bad length, and so on. | PERF_COUNTER_RAWCOUNT
Messages Received/sec | Shows the rate at which ICMP messages are received. The rate includes messages received in error. | PERF_COUNTER_COUNTER
Messages Sent/sec | Shows the rate at which the server attempts to send messages. The rate includes messages sent in error. | PERF_COUNTER_COUNTER
Messages/sec | Shows the total rate at which ICMP messages are sent and received by the entity. The rate includes messages received or sent in error. | PERF_COUNTER_COUNTER
Received Address Mask | Shows the number of ICMP Address Mask Request messages received. | PERF_COUNTER_RAWCOUNT
Received Address Mask Reply | Shows the number of ICMP Address Mask Reply messages received. | PERF_COUNTER_RAWCOUNT
Received Dest. Unreachable | Shows the number of ICMP Destination Unreachable messages received. | PERF_COUNTER_RAWCOUNT
Received Echo Reply/sec | Shows the rate at which ICMP Echo Reply messages are received. | PERF_COUNTER_COUNTER
Received Echo/sec | Shows the rate at which ICMP Echo messages are received. | PERF_COUNTER_COUNTER
Received Parameter Problem | Shows the number of ICMP Parameter Problem messages received. | PERF_COUNTER_RAWCOUNT
Received Redirect/sec | Shows the rate at which ICMP Redirect messages are received. | PERF_COUNTER_COUNTER
Received Source Quench | Shows the number of ICMP Source Quench messages received. | PERF_COUNTER_RAWCOUNT
Received Time Exceeded | Shows the number of ICMP Time Exceeded messages received. | PERF_COUNTER_RAWCOUNT
Received Timestamp Reply/sec | Shows the rate at which ICMP Timestamp Reply messages are received. | PERF_COUNTER_COUNTER
Received Timestamp/sec | Shows the rate at which ICMP Timestamp (request) messages are received. | PERF_COUNTER_COUNTER
Sent Address Mask | Shows the number of ICMP Address Mask Request messages sent. | PERF_COUNTER_RAWCOUNT
Sent Address Mask Reply | Shows the number of ICMP Address Mask Reply messages sent. | PERF_COUNTER_RAWCOUNT
Sent Destination Unreachable | Shows the number of ICMP Destination Unreachable messages sent. | PERF_COUNTER_RAWCOUNT
Sent Echo Reply/sec | Shows the rate at which ICMP Echo Reply messages are sent. | PERF_COUNTER_COUNTER
Sent Echo/sec | Shows the rate at which ICMP Echo messages are sent. | PERF_COUNTER_COUNTER
Sent Parameter Problem | Shows the number of ICMP Parameter Problem messages sent. | PERF_COUNTER_RAWCOUNT
Sent Redirect/sec | Shows the rate at which ICMP Redirect messages are sent. | PERF_COUNTER_COUNTER
Sent Source Quench | Shows the number of ICMP Source Quench messages sent. | PERF_COUNTER_RAWCOUNT
Sent Time Exceeded | Shows the number of ICMP Time Exceeded messages sent. | PERF_COUNTER_RAWCOUNT
Sent Timestamp Reply/sec | Shows the rate at which ICMP Timestamp Reply messages are sent. | PERF_COUNTER_COUNTER
Sent Timestamp/sec | Shows the rate at which ICMP Timestamp (request) messages are sent. | PERF_COUNTER_COUNTER


Image Object

The Image performance object consists of counters that monitor virtual address usage of images executed by processes on the computer. This object contains "costly" counters for which data collection is typically either processor-intensive or memory-intensive. Costly counters cannot be selected with System Monitor but can be accessed using Showperf.exe and other tools included on the Windows 2000 Resource Kit companion CD.

Counter Name | Description | Counter Type
Exec Read Only | Shows memory that can be executed as well as read. Image Space is the virtual address space used by the selected image with this protection. | PERF_COUNTER_RAWCOUNT
Exec Read/Write | Shows memory that can be executed by programs as well as being read and written. | PERF_COUNTER_RAWCOUNT
Exec Write Copy | Shows memory that can be executed by programs as well as being read and written. This type of protection is used when memory needs to be shared between processes. If the sharing processes only read the memory, then they all use the same memory. If a sharing process desires write access, then a copy of this memory is made for that process. | PERF_COUNTER_RAWCOUNT
Executable | Shows memory that can be executed by programs, but cannot be read or written. This type of protection is not supported by all processor types. | PERF_COUNTER_RAWCOUNT
No Access | Prevents a process from writing or reading these pages, and generates an access violation if either is attempted. | PERF_COUNTER_RAWCOUNT
Read Only | Prevents the contents of these pages from being modified. Any attempt to write or modify these pages generates an access violation | PERF_COUNTER_RAWCOUNT
Read/Write | Allows a process to read, modify and write to these pages. | PERF_COUNTER_RAWCOUNT
Write Copy | Used when memory is shared for reading but not for writing. When processes are reading this memory, they can share the same memory; however, when a sharing process wants read/write access to this shared memory, a copy is made for writing to. | PERF_COUNTER_RAWCOUNT

See also

  • Process Address Space object
  • Job object
  • Job object details
  • Thread details


Indexing Service Object

The Indexing Service performance object counters report statistics pertaining to the creation of indexes and the merging and querying of indexes by Indexing Service.

Counter Name | Description | Counter Type
# documents indexed | Shows the number of documents indexed since the current indexing session started. This does not include the documents indexed in prior sessions of Indexing Service. | PERF_COUNTER_RAWCOUNT
Deferred for indexing | Shows the number of documents that need to be indexed but can't be because they are in use. | PERF_COUNTER_RAWCOUNT
Files to be indexed | Shows the least number of documents known to need indexing. | PERF_COUNTER_RAWCOUNT
Index size (MB) | Shows the size, in megabytes, of the content index. | PERF_COUNTER_RAWCOUNT
Merge progress | Shows the percentage of the current merge that was completed. | PERF_COUNTER_RAWCOUNT
Running queries | Shows the number of queries that are currently running. | PERF_COUNTER_RAWCOUNT
Saved indexes | Shows the number of indexes that have been saved. | PERF_COUNTER_RAWCOUNT
Total # documents | Shows the total number of documents known to the index. | PERF_COUNTER_RAWCOUNT
Total # of queries | Shows the total number of queries made since the index was mounted | PERF_COUNTER_RAWCOUNT
Unique keys | Shows the number of unique words in the index. | PERF_COUNTER_RAWCOUNT
Word lists | Shows the number of word lists in the index. | PERF_COUNTER_RAWCOUNT

See also

  • Index Service


Indexing Service Filter Object

The Index Service Filter object monitors the filtering activity of Indexing Service.

Counter Name | Description | Counter Type
Binding time (msec) | Shows the average time, in milliseconds, to bind to a filter file. | PERF_COUNTER_RAWCOUNT
Indexing speed (MB/hr) | Shows the speed, in megabytes per hour, at which documents are indexed. This does not include generating abstracts. | PERF_COUNTER_RAWCOUNT
Total indexing speed (MB/hr) | Shows the speed, in megabytes per hour, at which documents are indexed. This includes generating abstracts. | PERF_COUNTER_RAWCOUNT

See also

  • Index Service


Internet Information Services Global Object

The Internet Information Services Global performance object consists of counters that apply jointly to the Hypertext Transport Protocol (HTTP) service and File Transfer Protocol (FTP) service.

Counter Name | Description | Counter Type
Active Flushed Entries | Shows the number of cached file handles that will be closed when all current transfers complete. | PERF_COUNTER_RAWCOUNT
BLOB Cache Flushes | Shows the number of flushes of the binary large object (BLOB) cache since the service was started. | PERF_COUNTER_RAWCOUNT
BLOB Cache Hits | Shows the total number of successful lookups in the BLOB cache. | PERF_COUNTER_RAWCOUNT
BLOB Cache Hits % | Shows the ratio of BLOB cache hits to total cache requests. | PERF_RAW_FRACTION
BLOB Cache Misses | Shows the total number of unsuccessful lookups in the BLOB cache. | PERF_COUNTER_RAWCOUNT
Current BLOBs Cached | Shows the number of BLOB information blocks currently in the cache for HTTP and FTP services. | PERF_COUNTER_RAWCOUNT
Current Blocked Async I/O Requests | Shows the number of current requests temporarily blocked due to bandwidth throttling settings. Blocked requests are held in a buffer and then unblocked if more bandwidth becomes available, unless a timeout limit is reached. | PERF_COUNTER_RAWCOUNT
Current File Handles Cached | Shows the number of open file handles currently in the cache for HTTP and FTP services. | PERF_COUNTER_RAWCOUNT
Current URIs Cached | Shows uniform resource identifier (URI) information blocks currently in the cache for HTTP and FTP services. | PERF_COUNTER_RAWCOUNT
File Handle Cache Flushes | Shows the number of file handle cache flushes since the service was started. | PERF_COUNTER_RAWCOUNT
File Handle Cache Hits | Shows the total number of successful lookups in the file handle cache. | PERF_COUNTER_RAWCOUNT
File Handle Cache Hits % | Shows the ratio of file handle cache hits to total cache requests. | PERF_RAW_FRACTION
File Handle Cache Misses | Shows the total number of unsuccessful lookups in the file handle cache. | PERF_COUNTER_RAWCOUNT
Measured Async I/O Bandwidth Usage | Shows the amount of measured bandwidth of asynchronous I/O averaged over a minute. This is a measure of the total amount of user traffic on your server. | PERF_COUNTER_RAWCOUNT
Total Allowed Async I/O Requests | Shows the total number of requests allowed by bandwidth throttling settings since the service was started. When you throttle bandwidth, the number of allowed user requests will be restricted. | PERF_COUNTER_RAWCOUNT
Total BLOBs Cached | Shows the total number of BLOB information blocks added to the cache for HTTP and FTP services | PERF_COUNTER_RAWCOUNT
Total Blocked Async I/O Requests | Shows the total number of requests temporarily blocked due to bandwidth throttling settings since the service was started. Blocked requests are held in a buffer and then unblocked if more bandwidth becomes available, unless a timeout limit is reached. | PERF_COUNTER_RAWCOUNT
Total File Handles Cached | Shows the total number of file handles added to the cache for HTTP and FTP services | PERF_COUNTER_RAWCOUNT
Total Flushed BLOBs | Shows the number of BLOB information blocks that have been removed from the cache since the service was started. | PERF_COUNTER_RAWCOUNT
Total Flushed Files | Shows the number of file handles that have been removed from the cache since the service was started. | PERF_COUNTER_RAWCOUNT
Total Flushed URIs | Shows the number of URI information blocks that have been removed from the cache since the service was started. | PERF_COUNTER_RAWCOUNT
Total Rejected Async I/O Requests | Shows the total requests rejected due to bandwidth throttling settings since the service was started. When a request is rejected, it is not held in a buffer, unlike a blocked request. | PERF_COUNTER_RAWCOUNT
Total URIs Cached | Shows the total number of URI information blocks added to the cache for HTTP and FTP services. | PERF_COUNTER_RAWCOUNT
URI Cache Flushes | Shows the total number of URI cache flushes since the service was started. | PERF_COUNTER_RAWCOUNT
URI Cache Hits | Shows the total number of successful lookups in the URI cache. | PERF_COUNTER_RAWCOUNT
URI Cache Hits % | Shows the ratio of URI cache hits to total cache requests. | PERF_RAW_FRACTION
URI Cache Misses | Shows the total number of unsuccessful lookups in the URI cache. | PERF_COUNTER_RAWCOUNT

See also

  • Internet Information Services


IP Object

The Internet Protocol (IP) performance object includes counters that describe the rates at which IP datagrams are transmitted by a computer using the IP protocol. It also describes various error counts for the IP protocol.

Counter Name | Description | Counter Type
Datagrams Forwarded/sec | Shows the rate at which attempts were made to find routes to forward input datagrams to their final destination because the local server was not their final IP destination. In servers that do not act as IP gateways, this rate includes only packets that were source-routed via this entity, and the source-route option processing was successful. | PERF_COUNTER_COUNTER
Datagrams Outbound No Route | Shows the number of IP datagrams discarded because no route could be found to transmit them to their destination. This counter includes any packets counted in Datagrams Forwarded/sec that meet this "no route" criterion. | PERF_COUNTER_RAWCOUNT
Datagrams Outbound Discarded | Shows the number of output IP datagrams that were discarded even though no problems were encountered to prevent their transmission to their destination (for example, for lack of buffer space). This counter includes datagrams counted in Datagrams Forwarded that meet this criterion. | PERF_COUNTER_RAWCOUNT
Datagrams Received Address Errors | Shows the number of input IP datagrams that were discarded because the IP address in their IP header destination field was not valid for the computer. This count includes invalid addresses (for example, 0.0. 0.0) and addresses of unsupported Classes (for example, Class E). For entities that are not IP gateways and do not forward datagrams, this counter includes datagrams discarded because the destination was not a local address. | PERF_COUNTER_RAWCOUNT
Datagrams Received Delivered/sec | Shows the rate at which input IP datagrams are successfully delivered to IP user-protocols, including ICMP. | PERF_COUNTER_COUNTER
Datagrams Received Discarded | Shows the number of input IP datagrams that were discarded even though problems prevented their continued processing (for example, for lack of buffer space). This counter does not include any datagrams discarded while awaiting re-assembly. | PERF_COUNTER_RAWCOUNT
Datagrams Received Header Errors | Shows the number of input IP datagrams that were discarded due to errors in the IP headers, including bad checksums, version number mismatch, other format errors, time-to-live exceeded, errors discovered while processing their IP options, and so on. | PERF_COUNTER_RAWCOUNT
Datagrams Received Unknown Protocol | Shows the number of locally-addressed datagrams successfully received but discarded because of an unknown or unsupported protocol. | PERF_COUNTER_RAWCOUNT
Datagrams Received/sec | Shows the rate at which IP datagrams are received from the interfaces, including those in error. Datagrams Received/sec is a subset of IP\ Datagrams/sec. | PERF_COUNTER_COUNTER
Datagrams Sent/sec | Shows the rate at which IP datagrams are supplied for transmission by local IP user-protocols (including ICMP). This counter does not include datagrams counted in IP\ Datagrams Forwarded/sec. Datagrams Sent/sec is a subset of IP\ Datagrams/sec. | PERF_COUNTER_COUNTER
Datagrams/sec | Shows the rate at which IP datagrams are received from or sent to the interfaces, including those in error. Forwarded datagrams are not included in this rate. | PERF_COUNTER_COUNTER
Fragment Re-assembly Failures | Shows the number of failures detected by the IP re-assembly algorithm, such as time outs, errors, and so on. This is not necessarily a count of discarded IP fragments since some algorithms (notably RFC 815) lose track of the number of fragments by combining them as they are received. | PERF_COUNTER_RAWCOUNT
Fragmentation Failures | Shows the number of IP datagrams that were discarded because they needed to be fragmented but could not be (for example, because the "Don't Fragment" flag was set). | PERF_COUNTER_RAWCOUNT
Fragmented Datagrams/sec | Shows the rate at which datagrams are successfully fragmented. | PERF_COUNTER_COUNTER
Fragments Created/sec | Shows the rate at which IP datagram fragments have been generated as a result of fragmentation. | PERF_COUNTER_COUNTER
Fragments Re-assembled/sec | Shows the rate at which IP fragments are successfully re-assembled. | PERF_COUNTER_COUNTER
Fragments Received/sec | Shows the rate at which IP fragments that need to be re-assembled at this entity are received. | PERF_COUNTER_COUNTER


Job Object Object

The Job performance object reports the accounting and processor usage data collected by each active job object. A job object provides a means of managing groups of processes with respect to their processor usage and other factors. For more information about creating and managing job objects, see the Platform SDK link on the Web Resources page at http://windows.microsoft.com/windows2000/reskit/webresources.

Counter Name | Description | Counter Type
Current % Kernel Mode Time | Shows the percentage of the sample interval that the processes in the Job object spent executing code in kernel or privileged mode. | PERF_100NSEC_TIMER
Current % Processor Time | Shows the percentage of the sample interval that the processes in the Job object spent executing code. | PERF_100NSEC_TIMER
Current % User Mode Time | Shows the percentage of the sample interval that the processes in the Job object spent executing code in user mode. | PERF_100NSEC_TIMER
Pages/sec | Shows the page fault rate of all the processes in the Job object. | PERF_COUNTER_COUNTER
Process Count - Active | Shows the number of processes that are currently associated with the Job object. | PERF_COUNTER_RAWCOUNT
Process Count - Terminated | Shows the number of processes that have been terminated because of a limit violation. | PERF_COUNTER_RAWCOUNT
Process Count - Total | Shows the number of processes, both active and terminated, that are or have been associated with the Job object. | PERF_COUNTER_RAWCOUNT
This Period mSec - Kernel Mode | Shows the time, in milliseconds, of user mode processor time used by all the processes in the Job object, including those that have terminated or that are no longer associated with the Job object, since a time limit on the Job was established. | PERF_COUNTER_LARGE_RAWCOUNT
This Period mSec - Processor | Shows the time, in milliseconds, of processor time used by all the processes in the Job object, including those that have terminated or that are no longer associated with the Job object, since a time limit on the Job was established. | PERF_COUNTER_LARGE_RAWCOUNT
This Period mSec - User Mode | Shows the time, in milliseconds, of user mode processor time used by all the processes in the Job object, including those that have terminated or that are no longer associated with the Job object, since a time limit on the Job was established. | PERF_COUNTER_LARGE_RAWCOUNT
Total mSec - Kernel Mode | Shows the time, in milliseconds, of kernel mode processor time used by all the processes in the Job object, including those that have terminated or that are no longer associated with the Job object, since the Job object was created. | PERF_COUNTER_LARGE_RAWCOUNT
Total mSec - Processor | Shows the time, in milliseconds, of processor time used by all the processes in the Job object, including those that have terminated or that are no longer associated with the Job object, since the Job object was created. | PERF_COUNTER_LARGE_RAWCOUNT
Total mSec - User Mode | Shows the time, in milliseconds, of user mode processor time used by all the processes in the Job object, including those that have terminated or that are no longer associated with the Job object, since the Job object was created. | PERF_COUNTER_LARGE_RAWCOUNT

See also

  • Job Object Details Object


Job Object Details

The Job Object Details performance object counters show detailed performance information about the active processes that make up a job object.

Counter Name | Description | Counter Type
% Privileged Time | Shows the percentage of elapsed time that the process threads have spent executing code in privileged mode. When a Windows 2000 system service is called, the service will often run in privileged mode to gain access to system-private data. Such data is protected from access by threads executing in user mode. Calls to the system can be explicit or implicit, such as page faults or interrupts. Unlike some early operating systems, Windows 2000 uses process boundaries for subsystem protection in addition to the traditional protection of user and privileged modes. Some work done by Windows 2000 on behalf of your application might appear in other subsystem processes in addition to the privileged time in your process. | PERF_100NSEC_TIMER
% Processor Time | Shows the percentage of elapsed time that all of the process threads used the processor to execute instructions. An instruction is the basic unit of execution in a computer, a thread is the object that executes instructions, and a process is the object created when a program is run. Code executed to handle some hardware interrupts and trap conditions are included in this count. | PERF_100NSEC_TIMER
% User Time | Shows the percentage of elapsed time that the process threads spent executing code in user mode. Applications, environment subsystems, and integral subsystems execute in user mode. Code executing in user mode cannot damage the integrity of the Windows 2000 executive, kernel, and device drivers. Unlike some early operating systems, Windows 2000 uses process boundaries for subsystem protection in addition to the traditional protection of user and privileged modes. Some work done by Windows 2000 on behalf of your application might appear in other subsystem processes in addition to the privileged time in your process. | PERF_100NSEC_TIMER
Creating Process ID | Shows the Process ID of the process that created the process. The creating process may have terminated, so this value may no longer identify a running process. | PERF_COUNTER_LARGE_RAWCOUNT
Elapsed Time | Shows the time, in seconds, that this process has been running. | PERF_ELAPSED_TIME
Handle Count | Shows the total number of handles currently open by this process. This is the sum of the handles currently open by each thread in this process. | PERF_COUNTER_RAWCOUNT
ID Process | Shows the unique identifier of this process. ID Process numbers are reused, so they only identify a process for the lifetime of that process. | PERF_COUNTER_LARGE_RAWCOUNT
IO Data Bytes/sec | Shows the rate that the process is reading and writing bytes in I/O operations. It counts all I/O activity generated by the process to include file, network, and device I/Os. | PERF_COUNTER_BULK_COUNT
IO Data Operations/sec | Shows the rate at which the process is issuing read and write I/O operations. This counter counts all I/O activity generated by the process to include file, network, and device I/Os. | PERF_COUNTER_BULK_COUNT
IO Other Bytes/sec | Shows the rate at which the process is issuing bytes to I/O operations that don't involve data such as control operations. It counts all I/O activity generated by the process to include file, network, and device I/Os. | PERF_COUNTER_BULK_COUNT
IO Other Operations/sec | Shows the rate at which the process is issuing I/O operations that are neither read nor write operations (for example, a control function). It counts all I/O activity generated by the process to include file, network, and device I/Os. | PERF_COUNTER_BULK_COUNT
IO Read Bytes/sec | Shows the rate at which the process is reading bytes from I/O operations. It counts all I/O activity generated by the process to include file, network, and device I/Os. | PERF_COUNTER_BULK_COUNT
IO Read Operations/sec | Shows the rate at which the process is issuing read I/O operations. It counts all I/O activity generated by the process to include file, network, and device I/Os. | PERF_COUNTER_BULK_COUNT
IO Write Bytes/sec | Shows the rate at which the process is writing bytes to I/O operations. It counts all I/O activity generated by the process to include file, network, and device I/Os. | PERF_COUNTER_BULK_COUNT
IO Write Operations/sec | Shows the rate at which the process is issuing write I/O operations. It counts all I/O activity generated by the process to include file, network, and device I/Os. | PERF_COUNTER_BULK_COUNT
Page Faults/sec | Shows the rate of page faults by the threads executing in this process. A page fault occurs when a thread refers to a virtual memory page that is not in its working set in main memory. This will not cause the page to be fetched from disk if it is on the standby list and already in main memory, or if it is in use by another process that is sharing the page. | PERF_COUNTER_COUNTER
Page File Bytes | Shows the current number of bytes this process has used in the paging file(s). Paging files are used to store pages of memory used by the process that are not contained in other files. Paging files are shared by all processes; lack of space in paging files can prevent other processes from allocating memory. | PERF_COUNTER_LARGE_RAWCOUNT
Page File Bytes Peak | Shows the maximum number of bytes this process has used in the paging file(s). | PERF_COUNTER_LARGE_RAWCOUNT
Pool Nonpaged Bytes | Shows the size, in bytes, in the nonpaged pool, an area of system memory (physical memory used by the operating system) for objects that cannot be written to disk, but must remain in physical memory as long as they are allocated. Memory\ Pool Nonpaged Bytes is calculated differently than Process\ Pool Nonpaged Bytes, and might not equal Process(_Total)\ Pool Nonpaged Bytes This counter displays the last observed value only; it is not an average. | PERF_COUNTER_RAWCOUNT
Pool Paged Bytes | Shows the size, in bytes, in the paged pool. Memory\ Pool Paged Bytes is calculated differently than Process\ Pool Paged Bytes, so it might not equal Process(_Total)\ Pool Paged Bytes. This counter displays the last observed value only; it is not an average. | PERF_COUNTER_RAWCOUNT
Priority Base | Shows the current base priority of this process. Threads within a process can raise and lower their own base priority relative to the base priority of the priority. | PERF_COUNTER_RAWCOUNT
Private Bytes | Shows the current size, in bytes, that this process has allocated that cannot be shared with other processes. | PERF_COUNTER_LARGE_RAWCOUNT
Thread Count | Shows the number of threads currently active in this process. An instruction is the basic unit of execution in a processor, and a thread is the object that executes instructions. Every running process has at least one thread. | PERF_COUNTER_RAWCOUNT
Virtual Bytes | Shows the current size, in bytes, of the virtual address space the process is using. Use of virtual address space does not necessarily imply corresponding use of either disk or main memory pages. Virtual space is finite, and by using too much, the process can limit its ability to load libraries. | PERF_COUNTER_LARGE_RAWCOUNT
Virtual Bytes Peak | Shows the maximum number of bytes of virtual address space the process has used at any one time. | PERF_COUNTER_LARGE_RAWCOUNT
Working Set | Shows the current size, in bytes, in the Working Set of this process. The Working Set is the set of memory pages touched recently by the threads in the process. If free memory in the computer is above a threshold, pages are left in the Working Set of a process even if they are not in use. When free memory falls below a threshold, pages are trimmed from Working Sets. If they are needed, they will be soft-faulted back into the Working Set before leaving main memory. | PERF_COUNTER_RAWCOUNT
Working Set Peak | Shows the maximum size, in bytes, in the Working Set of this process at any point in time. | PERF_COUNTER_RAWCOUNT

See also

  • Job Object


LogicalDisk Object

The Logical Disk performance object consists of counters that monitor logical partitions of hard or fixed disk drives. System Monitor identifies logical disks by their drive letter, such as "C." To monitor Logical Disk object counters, you must activate them by typing the following at the command prompt:

diskperf -yv

Counter Name | Description | Counter Type
% Disk Time | Shows the percentage of time that the selected disk drive is busy servicing read or write requests. | PERF_PRECISION_100NS_TIMER
% Disk Read Time | Shows the percentage of time that the selected disk drive is busy servicing read requests. | PERF_PRECISION_100NS_TIMER
% Disk Write Time | Shows the percentage of time that the selected disk drive is busy servicing write requests. | PERF_PRECISION_100NS_TIMER
% Free Space | Shows the percentage of the total usable space on the selected logical disk drive that is free. | PERF_RAW_FRACTION
Avg. Disk Bytes/Read | Shows the average number of bytes transferred from the disk during read operations. | PERF_AVERAGE_BULK
Avg. Disk Bytes/Transfer | Shows the average number of bytes transferred to or from the disk during write or read operations. | PERF_AVERAGE_BULK
Avg. Disk Bytes/Write | Shows the average number of bytes transferred to the disk during write operations. | PERF_AVERAGE_BULK
Avg. Disk Queue Length | Shows the average number of both read and write requests that were queued for the selected disk during the sample interval. | PERF_COUNTER_LARGE_QUEUELEN_TYPE
Avg. Disk Read Queue Length | Shows the average number of read requests that were queued for the selected disk during the sample interval. | PERF_COUNTER_LARGE_QUEUELEN_TYPE
Avg. Disk sec/Read | Shows the average time, in seconds, of a read operation from the disk. | PERF_AVERAGE_TIMER
Avg. Disk sec/Transfer | Shows the time, in seconds, of the average disk transfer. | PERF_AVERAGE_TIMER
Avg. Disk sec/Write | Shows the average time, in seconds, of a write operation to the disk. | PERF_AVERAGE_TIMER
Avg. Disk Write Queue Length | Shows the average number of write requests that were queued for the selected disk during the sample interval. | PERF_COUNTER_LARGE_QUEUELEN_TYPE
Current Disk Queue Length | Shows the number of requests outstanding on the disk at the time that the performance data is collected. It also includes requests in service at the time of the collection. This is a snapshot, not an average over a time interval. Multispindle disk devices can have multiple requests active at one time, but other concurrent requests are awaiting service. This counter might reflect a transitory high or low queue length, but if there is a sustained load on the disk drive, it is likely that this will be consistently high. Requests experience delays proportional to the length of this queue minus the number of spindles on the disks. This difference should average less than two for good performance. | PERF_COUNTER_RAWCOUNT
Disk Bytes/sec | Shows the rate at which bytes are transferred to or from the disk during write or read operations. | PERF_COUNTER_BULK_COUNT
Disk Read Bytes/sec | Shows the rate at which bytes are transferred from the disk during read operations. | PERF_COUNTER_BULK_COUNT
Disk Reads/sec | Shows the rate at which read operations are performed on the disk. | PERF_COUNTER_COUNTER
Disk Transfers/sec | Shows the rate at which read and write operations are performed on the disk. | PERF_COUNTER_COUNTER
Disk Write Bytes/sec | Shows the rate at which bytes are transferred to the disk during write operations. | PERF_COUNTER_BULK_COUNT
Disk Writes/sec | Shows the rate at which write operations are performed on the disk. | PERF_COUNTER_COUNTER
Free Megabytes | Shows the unallocated space, in megabytes, on the disk drive. One megabyte is equal to 1,048,576 bytes. | PERF_COUNTER_RAWCOUNT

See also

  • Finding Cache Bottlenecks
  • Finding Disk Bottlenecks


MacFile Server Object

The MacFile Server performance object provides information about a system running File Server for Macintosh.

Counter Name | Description | Counter Type
Current Files Open | Shows the number of internal files currently open in the MacFile server. This count does not include files opened on behalf of Macintosh clients. | PERF_COUNTER_RAWCOUNT
Current Paged Memory | Shows the current amount of paged memory resources used by the MacFile server. | PERF_COUNTER_RAWCOUNT
Current NonPaged Memory | Shows the current amount of nonpaged memory resources used by the MacFile Server. |
Current Sessions | Shows the number of sessions currently connected to the MacFile Server. The counter reports current server activity. | PERF_COUNTER_RAWCOUNT
Failed Logons | Shows the number of failed attempts to log on to the MacFile server. These values can indicate that password-guessing programs are being used to undermine the security on the server. | PERF_COUNTER_RAWCOUNT
Max NonPaged Memory | Shows the maximum amount of nonpaged memory resources use by the MacFile Server. | PERF_COUNTER_RAWCOUNT
Max Paged Memory | Shows the maximum amount of paged memory resources used by the MacFile Server. | PERF_COUNTER_RAWCOUNT
Maximum Files Open | Shows the maximum number of internal files open at one time in the MacFile Server. This count does not include files opened on behalf of Macintosh clients. | PERF_COUNTER_RAWCOUNT
Maximum Sessions | Shows the maximum number of sessions connected at one time to the MacFile Server. This counter indicates the level of usage of the server. | PERF_COUNTER_RAWCOUNT
Data Read/sec | Shows the number of bytes read from the disk per second. | PERF_COUNTER_BULK_COUNT
Data Written/sec | Shows the number of bytes written to the disk per second. | PERF_COUNTER_BULK_COUNT
Data Received/sec | Shows the number of bytes received from the network per second. This counter indicates how busy the server is. | PERF_COUNTER_BULK_COUNT
Data Transmitted/sec | Shows the number of bytes sent on the network per second. This counter indicates how busy the server is. | PERF_COUNTER_BULK_COUNT
Current Queue Length | Shows the number of outstanding work items waiting to be processed. | PERF_COUNTER_RAWCOUNT
Maximum Queue Length | Shows the maximum number of outstanding work items waiting at one time. | PERF_COUNTER_RAWCOUNT
Current Threads | Shows the current number of threads used by the MacFile Server. This counter indicates how busy the server is. | PERF_COUNTER_RAWCOUNT
Maximum Threads | Shows the maximum number of threads used by the MacFile Server. This counter indicates the peak usage level of the server. | PERF_COUNTER_RAWCOUNT


Memory Object

The Memory performance object consists of counters that describe the behavior of physical and virtual memory on the computer. Physical memory is the amount of random-access memory (RAM) on the computer. Virtual memory consists of space in physical memory and on disk. Many of the memory counters monitor paging, which is the movement of pages of code and data between disk and physical memory. Excessive paging, a symptom of a memory shortage, can cause delays which interfere with all system processes.

Counter Name | Description | Counter Type
% Committed Bytes In Use | shows the ratio of Memory\ Committed Bytes to the Memory\ Commit Limit. Committed memory is physical memory in use for which space has been reserved in the paging file so that it can be written to disk. The commit limit is determined by the size of the paging file. If the paging file is enlarged, the commit limit increases, and the ratio is reduced. | PERF_RAW_FRACTION
Available Bytes | Shows the amount of physical memory, in bytes, available to processes running on the computer. It is calculated by summing adding the amount of space on the zeroed, free, and standby memory lists. Free memory is ready for use; zeroed memory consists of pages of memory filled with zeros to prevent later processes from seeing data used by a previous process; standby memory is memory that has been removed from a process's working set (its physical memory) en route to disk but is still available to be recalled. | PERF_COUNTER_RAWCOUNT
Available KBytes | Shows the amount of memory available to processes running on the computer, in kilobytes rather than bytes, as reported by Memory\Available Bytes. | PERF_COUNTER_RAWCOUNT
Available MBytes | Shows the amount of memory available to processes running on the computer, in megabytes rather than bytes, as reported by Memory\Available Bytes. | PERF_COUNTER_RAWCOUNT
Cache Bytes | Shows the sum of the values of System Cache Resident Bytes, System Driver Resident Bytes, System Code Resident Bytes, and Pool Paged Resident Bytes. | PERF_COUNTER_RAWCOUNT
Cache Bytes Peak | Shows the maximum number of bytes used by the file system cache since the system was last restarted. This might be larger than the current size of the cache. | PERF_COUNTER_RAWCOUNT
Cache Faults/sec | hows the rate at which faults occur when a page sought in the file system cache is not found and must be retrieved from elsewhere in memory (a soft fault) or from disk (a hard fault). This counter shows the number of faults, without regard for the number of pages faulted in each operation. | PERF_COUNTER_COUNTER
Commit Limit | Shows the amount of virtual memory, in bytes, that can be committed without having to extend the paging file(s). Committed memory is physical memory which has space reserved on the disk paging files. There can be one or more paging files on each physical drive. If the paging file(s) are expanded, this limit increases accordingly. | PERF_COUNTER_RAWCOUNT
Committed Bytes | Shows the amount of committed virtual memory, in bytes. | PERF_COUNTER_RAWCOUNT
Demand Zero Faults/sec | Shows the rate at which a zeroed page is required to satisfy the fault. Zeroed pages, pages emptied of previously stored data and filled with zeros, are security features in Windows 2000 that prevent processes from seeing data stored by earlier processes that used the memory space. Windows 2000 maintains a list of zeroed pages to accelerate this process. This counter shows numbers of faults, without regard to the numbers of pages retrieved to satisfy the fault. | PERF_COUNTER_COUNTER
Free System Page Table Entries | Shows the number of page table entries not currently in use by the system. | PERF_COUNTER_RAWCOUNT
Page Faults/sec | Shows the average number of pages faulted per second. It is measured in numbers of pages faulted; because only one page is faulted in each fault operation, this is also equal to the number of page fault operations. This counter includes both hard faults (those that require disk access) and soft faults (where the faulted page is found elsewhere in physical memory). Most processors can handle large numbers of soft faults without significant consequence. However, hard faults, which require disk access, can cause delays. | PERF_COUNTER_COUNTER
Page Reads/sec | Shows the rate at which the disk is read to resolve hard page faults. It shows numbers of read operations, without regard to the number of pages retrieved in each operation. Hard page faults occur when a process references a page in virtual memory that is not in its working set or elsewhere in physical memory, and must be retrieved from disk. This counter is a primary indicator of the kinds of faults that cause system-wide delays. It includes read operations to satisfy faults in the file system cache (usually requested by applications) and in noncached mapped memory files. Compare the value of Page Reads/sec to the value of Pages Input/sec to find an average of how many pages were read during each read operation. | PERF_COUNTER_COUNTER
Page Writes/sec | Shows the rate at which pages are written to disk to free up space in physical memory. Pages are written to disk only if they are changed while in physical memory, so they are likely to hold data, not code. This counter shows write operations, without regard to the number of pages written in each operation. | PERF_COUNTER_COUNTER
Pages Input/sec | Shows the rate at which pages are read from disk to resolve hard page faults. Hard page faults occur when a process refers to a page in virtual memory that is not in its working set or elsewhere in physical memory, and must be retrieved from disk. When a page is faulted, the system tries to read multiple contiguous pages into memory to maximize the benefit of the read operation. Compare Pages Input/sec to Page Reads/sec to find the average number of pages read into memory during each read operation | PERF_COUNTER_COUNTER
Pages Output/sec | Shows the rate at which pages are written to disk to free up space in physical memory. A high rate of pages output might indicate a memory shortage. Windows 2000 writes more pages back to disk to free up space when physical memory is in short supply. This counter shows numbers of pages, and can be compared to other counts of pages without conversion. | PERF_COUNTER_COUNTER
Pages/sec | Shows the rate at which pages are read from or written to disk to resolve hard page faults. This counter is a primary indicator of the kinds of faults that cause system-wide delays. It is the sum of Memory\ Pages Input/sec and Memory\ Pages Output/sec. It is counted in numbers of pages, so it can be compared to other counts of pages, such as Memory\ Page Faults/sec, without conversion. It includes pages retrieved to satisfy faults in the file system cache (usually requested by applications) and noncached mapped memory files. | PERF_COUNTER_COUNTER
Pool Nonpaged Allocs | Shows the number of calls to allocate space in the nonpaged pool. It is measured in numbers of calls to allocate space, regardless of the amount of space allocated in each call. | PERF_COUNTER_RAWCOUNT
Pool Nonpaged Bytes | Shows the size, in bytes, of the nonpaged pool. Memory\ Pool Nonpaged Bytes is calculated differently than Process\ Pool Nonpaged Bytes, so it might not equal Process(_Total )\ Pool Nonpaged Bytes. | PERF_COUNTER_RAWCOUNT
Pool Paged Allocs | Shows the number of calls to allocate space in the paged pool. It is measured in numbers of calls to allocate space, regardless of the amount of space allocated in each call. | PERF_COUNTER_RAWCOUNT
Pool Paged Bytes | Shows the size, in bytes, of the paged pool. Memory\ Pool Paged Bytes is calculated differently than Process\ Pool Paged Bytes, so it might not equal Process(_Total )\ Pool Paged Bytes. | PERF_COUNTER_RAWCOUNT
Pool Paged Resident Bytes | Shows the current size, in bytes, of the paged pool. Space used by the paged and nonpaged pools is taken from physical memory, so a pool that is too large denies memory space to processes. | PERF_COUNTER_RAWCOUNT
System Cache Resident Bytes | Shows the size, in bytes, of pageable operating system code in the file system cache. This value includes only current physical pages and does not include any virtual memory pages not currently resident. It does not equal the System Cache value shown in Task Manager. As a result, this value may be smaller than the actual amount of virtual memory in use by the file system cache. This value is a component of Memory\ System Code Resident Bytes which represents all pageable operating system code that is currently in physical memory. | PERF_COUNTER_RAWCOUNT
System Code Resident Bytes | Shows the size, in bytes, of operating system code currently in physical memory that can be written to disk when not in use. This value is a component of Memory\ System Code Total Bytes, which also includes operating system code on disk. Memory\ System Code Resident Bytes (and Memory\ System Code Total Bytes) does not include code that must remain in physical memory and cannot be written to disk. | PERF_COUNTER_RAWCOUNT
System Code Total Bytes | Shows the size, in bytes, of pageable operating system code currently in virtual memory. It is a measure of the amount of physical memory being used by the operating system that can be written to disk when not in use. This value is calculated by adding the bytes in Ntoskrnl.exe, Hal.dll, the boot drivers, and file systems loaded by Ntldr/osloader. This counter does not include code that must remain in physical memory and cannot be written to disk. | PERF_COUNTER_RAWCOUNT
System Driver Resident Bytes | Shows the size, in bytes, of pageable physical memory being used by device drivers. It is the working set (physical memory area) of the drivers. This value is a component of Memory\ System Driver Total Bytes, which also includes driver memory that has been written to disk. Neither Memory\ System Driver Resident Bytes nor Memory\ System Driver Total Bytes includes memory that cannot be written to disk. | PERF_COUNTER_RAWCOUNT
System Driver Total Bytes | Shows the size, in bytes, of pageable virtual memory currently being used by device drivers. Pageable memory can be written to disk when it is not being used. It includes physical memory (Memory\ System Driver Resident Bytes) and code and data written to disk. It is a component of Memory\ System Code Total Bytes. | PERF_COUNTER_RAWCOUNT
Transition Faults/sec | Shows the rate at which page faults are resolved by recovering pages that were being used by another process sharing the page, or were on the modified page list or the standby list, or were being written to disk at the time of the page fault. The pages were recovered without additional disk activity. Transition faults are counted in numbers of faults; because only one page is faulted in each operation, it is also equal to the number of pages faulted. | PERF_COUNTER_COUNTER
Write Copies/sec | Shows the rate at which page faults are caused by attempts to write that have been satisfied by copying the page from elsewhere in physical memory. This is an economical way of sharing data since pages are only copied when they are written to; otherwise, the page is shared. This counter shows the number of copies, without regard to the number of pages copied in each operation. | PERF_COUNTER_COUNTER

See also

  • Finding Memory Bottlenecks
  • Finding Cache Bottlenecks


MSMQ Queue Object

The MSMQ Queue performance object monitors message statistics for a selected queue. There are instances for each queue on the computer. In addition, if an Message Queuing–based application has a private queue open on another computer, an instance for that queue is also available. The computer queues instance represents the computer's source journal and dead letter queues.

Counter Name | Description | Counter Type
Bytes in Journal Queue | Shows the total number of bytes that currently reside in the journal queue. For the computer queue instance, this represents the computer journal queue. | PERF_COUNTER_RAWCOUNT
Bytes in Queue | Shows the total number of bytes that currently reside in the queue. For the computer queue instance, this represents the dead letter queue. | PERF_COUNTER_RAWCOUNT
Messages in Journal Queue | Shows the total number of messages that currently reside in the journal queue. For the computer queue instance, this represents the computer journal queue. | PERF_COUNTER_RAWCOUNT
Messages in Queue | Shows the total number of messages that currently reside in the queue. For the computer queue instance, this represents the dead letter queue. For queues residing on the local computer, this counter shows how many messages are waiting to be read. For queues residing on a different computer, this counter shows the number of messages waiting to be sent. This counter is useful in determining if message handling is stalled. | PERF_COUNTER_RAWCOUNT

See also

  • MSMQ Service


MSMQ Service Object

The MSMQ Service performance object monitors session and message statistics for a selected computer that is running Message Queuing.

Counter Name | Description | Counter Type
Incoming Messages/sec | Shows the rate of incoming Message Queuing messages handled by the Message Queuing service. This counter is useful for determining if the local Message Queuing service is currently receiving messages. | PERF_COUNTER_COUNTER
IP Sessions | Shows the number of open IP sessions. | PERF_COUNTER_RAWCOUNT
IPX Sessions | shows the number of open IPX sessions. | PERF_COUNTER_RAWCOUNT
MSMQ Incoming Messages | Shows the total number of incoming messages handled by the Message Queuing service. | PERF_COUNTER_RAWCOUNT
MSMQ Outgoing Messages | Shows the total number of outgoing messages handled by the Message Queuing service. | PERF_COUNTER_RAWCOUNT
Outgoing Messages/sec | Shows the rate of outgoing Message Queuing messages handled by the Message Queuing service. This counter is useful for determining if the local Message Queuing service is currently sending messages. | PERF_COUNTER_COUNTER
Sessions | Shows the total number of open network sessions. A session is opened whenever a message is to be sent or received and closed automatically after two to five minutes of inactivity. Windows 2000 Server closes a session after two minutes; Windows 2000 Professional or Windows 95 closes a session after five minutes. This counter indicates if messaging activity has occurred recently. | PERF_COUNTER_RAWCOUNT
Total Bytes in All Queues | Shows the total number of bytes in all active queues under the Message Queuing service. | PERF_COUNTER_RAWCOUNT
Total Messages in All Queues | Shows the total number of messages in all active queues under the Message Queuing service. This counter shows the total number of messages that are waiting to be received by local applications or sent to another destination. | PERF_COUNTER_RAWCOUNT

See also

  • MSMQ Service


MSMQ Session Object

The MSMQ Session performance object monitors statistics about active sessions between computers running Message Queuing. There can be an instance for each session.

Counter Name | Description | Counter Type
Incoming Bytes | Shows the total number of bytes that were received through the selected session. | PERF_COUNTER_RAWCOUNT
Incoming Bytes/sec | Shows the rate at which Message Queuing messages are entering through the selected session. | PERF_COUNTER_RAWCOUNT
Incoming Messages | Shows the total number of messages that were received through the selected session. | PERF_COUNTER_RAWCOUNT
Incoming Messages/sec | Shows the rate at which Message Queuing messages are entering through the selected session. | PERF_COUNTER_RAWCOUNT
Outgoing Bytes | shows the total number of bytes that were sent through the selected session. | PERF_COUNTER_RAWCOUNT
Outgoing Bytes/sec | Shows the rate at which Message Queuing messages are leaving through the selected session. | PERF_COUNTER_RAWCOUNT
Outgoing Messages | Shows the total number of messages that were sent through the selected session. | PERF_COUNTER_RAWCOUNT
Outgoing Messages/sec | Shows the rate at which Message Queuing messages are leaving through the selected session. | PERF_COUNTER_RAWCOUNT

See also

  • Counters by Feature: Message Queuing


NBT Connection Object

The NBT Connection performance object consists of counters that measure the rates at which bytes are sent and received over the NetBIOS over TCP/IP (NetBT or NBT) protocol provides NetBIOS support for the TCP/IP protocol. NBT connection between the local computer and a remote computer. The connection is identified by the name of the remote computer.

Counter Name | Description | Counter Type
Bytes Received/sec | Shows the rate at which bytes are received by the local computer over an NBT connection to a remote computer. All bytes received by the local computer over the particular NBT connection are counted. | PERF_COUNTER_BULK_COUNT
Bytes Sent/sec | shows the rate at which bytes are sent by the local computer over an NBT connection to a remote computer. All bytes sent by the local computer over the particular NBT connection are counted. | PERF_COUNTER_BULK_COUNT
Bytes Total/sec | Shows the rate at which bytes are transmitted by the local computer over an NBT connection to a remote computer. All bytes transmitted by the local computer over the particular NBT connection are counted. | PERF_COUNTER_BULK_COUNT


NetBEUI Object

The NetBEUI performance object consists of counters that measure data transmission for network activity which conforms to the NetBIOS End User Interface (NetBEUI) standard.

Counter Name | Description | Counter Type
Bytes Total/sec | Shows the total rate of bytes sent to or received from the network by the protocol, but only counts the bytes in frames (packets) which carry data. This is the sum of the values of Frame Bytes/sec and Datagram Bytes/sec. | PERF_COUNTER_BULK_COUNT
Connection Session Timeouts | Shows the number of connections that were dropped due to a session time out. This counter is an accumulator and shows a running total. | PERF_COUNTER_RAWCOUNT
 | Shows the number of connections that were canceled. This counter is an accumulator and shows a running total. | PERF_COUNTER_RAWCOUNT
Connections No Retries | Shows the total count of connections that were successfully made on the first try. This counter is an accumulator and shows a running total. | PERF_COUNTER_RAWCOUNT
Connections Open | Shows the number of connections currently open for this protocol. This counter shows the current count only and does not accumulate over time. | PERF_COUNTER_RAWCOUNT
Connections With Retries | Shows the total count of connections that were made after retrying the attempt. A retry occurs when the first connection attempt failed. This counter is an accumulator and shows a running total. | PERF_COUNTER_RAWCOUNT
Datagram Bytes Received/sec | Shows the rate at which datagram bytes are received by the computer. A datagram is a connectionless packet whose delivery to a remote computer is not guaranteed. | PERF_COUNTER_BULK_COUNT
Datagram Bytes Sent/sec | Shows the rate at which datagram bytes are sent from the computer. | PERF_COUNTER_BULK_COUNT
Datagram Bytes/sec | Shows the rate at which datagram bytes are processed by the computer. This counter measures datagram bytes that are both received and sent. | PERF_COUNTER_BULK_COUNT
Datagrams Received/sec | Shows the rate at which datagrams are received by the computer. | PERF_COUNTER_COUNTER
Datagrams Sent/sec | Shows the rate at which datagrams are sent from the computer. | PERF_COUNTER_COUNTER
Datagrams/sec | Shows the rate at which datagrams are processed by the computer. This counter measures datagrams that are both received and sent. | PERF_COUNTER_COUNTER
Disconnects Local | Shows the number of session disconnections that were initiated by the local computer. This counter is an accumulator and shows a running total. | PERF_COUNTER_RAWCOUNT
Disconnects Remote | Shows the number of session disconnections that were initiated by the remote computer. This counter is an accumulator and shows a running total. | PERF_COUNTER_RAWCOUNT
Expirations Ack | Shows the count of T2 timer expirations. | PERF_COUNTER_RAWCOUNT
Expirations Response | Shows the count of T1 timer expirations. | PERF_COUNTER_RAWCOUNT
Failures Adapter | Shows the number of connections that were dropped due to an adapter failure. This counter is an accumulator and shows a running total. | PERF_COUNTER_RAWCOUNT
Failures Link | Shows the number of connections that were dropped due to a link failure. This counter is an accumulator and shows a running total. | PERF_COUNTER_RAWCOUNT
Failures No Listen | Shows the number of connections that were rejected because the remote computer was not listening for connection requests. | PERF_COUNTER_RAWCOUNT
Failures Not Found | Shows the number of connection attempts that failed because the remote computer could not be found. This counter is an accumulator and shows a running total. | PERF_COUNTER_RAWCOUNT
Failures Resource Local | Shows the number of connections that failed because of resource problems or shortages on the local computer. This counter is an accumulator and shows a running total. | PERF_COUNTER_RAWCOUNT
Failures Resource Remote | Shows the number of connections that failed because of resource problems or shortages on the remote computer. This counter is an accumulator and shows a running total. | PERF_COUNTER_RAWCOUNT
Frame Bytes Received/sec | Shows the rate at which data bytes are received by the computer. This counter only shows the frames that carry data. | PERF_COUNTER_BULK_COUNT
Frame Bytes Rejected/sec | Shows the rate at which data bytes are rejected. This counter only shows the bytes in data frames that carry data. | PERF_COUNTER_BULK_COUNT
Frame Bytes Re-Sent/sec | Shows the rate at which data bytes are re-sent by the computer. This counter only shows the bytes in frames that carry data. | PERF_COUNTER_BULK_COUNT
Frame Bytes Sent/sec | Shows the rate at which data bytes are sent by the computer. This counter only shows the bytes in frames that carry data. | PERF_COUNTER_BULK_COUNT
Frame Bytes/sec | Shows the rate at which data bytes are processed by the computer. This counter is the sum of the values of Frame Bytes Received/sec and Frame Bytes Sent/sec. This counter only shows the bytes in frames that carry data. | PERF_COUNTER_BULK_COUNT
Frames Received/sec | Shows the rate at which data frames are received by the computer. This counter only shows the frames that carry data. | PERF_COUNTER_COUNTER
Frames Rejected/sec | Shows the rate at which data frames are rejected. This counter only shows the frames that carry data. | PERF_COUNTER_COUNTER
Frames Re-Sent/sec | Shows the rate at which data frames are re-sent by the computer. This counter only shows the frames that carry data. | PERF_COUNTER_COUNTER
Frames Sent/sec | Shows the rate at which data frames are sent by the computer. This counter only shows the frames that carry data. | PERF_COUNTER_COUNTER
Frames/sec | Shows the rate at which data frames are processed by the computer. This counter is the sum of the values of Frames Received/sec and Frames Sent/sec and only shows the frames that carry data. | PERF_COUNTER_COUNTER
Packets Received/sec | Shows the rate at which packets are received by the computer. This counter shows all packets processed (control as well as data packets). | PERF_COUNTER_COUNTER
Packets Sent/sec | Shows the rate at which packets are sent by the computer. This counter shows all packets sent by the computer (control as well as data packets). | PERF_COUNTER_COUNTER
Packets/sec | Shows the rate at which packets are processed by the computer. This count is the sum of the values of Packets Sent/sec and Packets Received/sec and includes all packets processed (control as well as data packets). | PERF_COUNTER_COUNTER
Piggyback Ack Queued/sec | Shows the rate at which piggyback acknowledgments are queued. Piggyback acknowledgments are acknowledgments of received packets that are to be included in the next outgoing packet to the remote computer. | PERF_COUNTER_COUNTER
Piggyback Ack Timeouts | Shows the number of times that a piggyback acknowledgment could not be sent because there was no outgoing packet to the remote computer on which to piggyback. If no outgoing packet is sent within the time-out period, then an acknowledgment packet is sent and this counter is incremented. | PERF_COUNTER_RAWCOUNT
Window Send Average | Shows the average number of data bytes that were sent before waiting for an acknowledgment from the remote computer. | PERF_COUNTER_RAWCOUNT
Window Send Maximum | Shows the maximum number of data bytes that are sent before waiting for an acknowledgment from the remote computer. | PERF_COUNTER_RAWCOUNT


NetBEUI Resource Object

The NetBEUI Resource performance object consists of counters that track the use of buffers by the NetBEUI protocol.

Counter Name | Description | Counter Type
Times Exhausted | Shows the number of times that all resources (buffers) were in use. The number in parentheses following the resource name is used to identify the resource in Event Log messages. | PERF_COUNTER_RAWCOUNT
Used Average | Shows the current number of resources (buffers) in use. The number in parentheses following the resource name is used to identify the resource in Event Log messages. | PERF_COUNTER_RAWCOUNT
Used Maximum | Shows the maximum number of NetBEUI resources (buffers) in use at any point in time. This value is useful in sizing the maximum resources provided. The number in parentheses following the resource name is used to identify the resource in Event Log messages. | PERF_COUNTER_RAWCOUNT


Network Interface Object

The Network Interface performance object consists of counters that measure the rates at which bytes and packets are sent and received over a TCP/IP connection. It includes counters that monitor connection errors.

The Network Interface counters display data about the network adapters on the server computer. The first instance of the Network Interface object (Instance 1) that you see in System Monitor represents the loopback. The loopback is a local path through the protocol driver and the network adapter. All other instances represent installed network adapters.

Counter Name | Description | Counter Type
Bytes Received/sec | Shows the rate at which bytes are received over each network adapter. The counted bytes include framing characters. Bytes Received/sec is a subset of Network Interface\Bytes Total/sec. | PERF_COUNTER_COUNTER
Bytes Sent/sec | Shows the rate at which bytes are sent over each network adapter. The counted bytes include framing characters. Bytes Sent/sec is a subset of Network Interface\Bytes Total/sec. | PERF_COUNTER_COUNTER
Bytes Total/sec | Shows the rate at which bytes are sent and received on the network interface, including framing characters. Bytes Total/sec is the sum of the values of Network Interface\Bytes Received/sec and Network Interface\ Bytes Sent/sec. | PERF_COUNTER_COUNTER
Current Bandwidth | Shows an estimate of the current bandwidth of the network interface in bits per second (BPS). For interfaces that do not vary in bandwidth or for those where no accurate estimation can be made, this value is the nominal bandwidth. | PERF_COUNTER_RAWCOUNT
Output Queue Length | Shows the length of the output packet queue, in packets. If this is longer than two, there are delays and the bottleneck should be found and eliminated, if possible. Since the requests are queued by Network Driver Interface Specification (NDIS) in this implementation, this value is always 0. | PERF_COUNTER_RAWCOUNT
Packets Outbound Discarded | Shows the number of outbound packets to be discarded even though no errors had been detected to prevent transmission. One possible reason for discarding the a packet could be to free up buffer space. | PERF_COUNTER_RAWCOUNT
Packets Outbound Errors | Shows the number of outbound packets that could not be transmitted because of errors. | PERF_COUNTER_RAWCOUNT
Packets Received Discarded | Shows the number of inbound packets that were chosen to be discarded even though no errors had been detected to prevent their being deliverable to a higher-layer protocol. One possible reason for discarding such a packet could be to free up buffer space. | PERF_COUNTER_RAWCOUNT
Packets Received Errors | Shows the number of inbound packets that contained errors preventing them from being deliverable to a higher-layer protocol. | PERF_COUNTER_RAWCOUNT
Packets Received Non-Unicast/sec | Shows the rate at which non-unicast (subnet broadcast or subnet multicast) packets are delivered to a higher-layer protocol. | PERF_COUNTER_COUNTER
Packets Received Unicast/sec | Shows the rate at which subnet-unicast packets are delivered to a higher-layer protocol. | PERF_COUNTER_COUNTER
Packets Received Unknown | Shows the number of packets received through the interface that were discarded because of an unknown or unsupported protocol. | PERF_COUNTER_RAWCOUNT
Packets Received/sec | Shows the rate at which packets are received on the network interface. | PERF_COUNTER_COUNTER
Packets Sent/sec | Shows the rate at which packets are sent on the network interface. | PERF_COUNTER_COUNTER
Packets Sent Non-Unicast/sec | Shows the rate at which packets are requested to be transmitted to nonunicast (subnet broadcast or subnet multicast) addresses by higher-level protocols. The rate includes packets that were discarded or not sent. | PERF_COUNTER_COUNTER
Packets Sent Unicast/sec | Shows the rate at which packets are requested to be transmitted to subnet-unicast addresses by higher-level protocols. The rate includes the packets that were discarded or not sent. | PERF_COUNTER_COUNTER


Network Segment Object

The Network Segment performance object provides network statistics for the local network segment; it is installed by the Network Monitor driver protocol on Windows 2000 Professional and by Network Monitor Tools on Windows 2000 Server.

Counter Name | Description | Counter Type
% Broadcast Frames | Shows the percentage of network bandwidth that is made up of broadcast traffic on this network segment. | PERF_AVERAGE_BULK
% Multicast Frames | Shows the percentage of network bandwidth that is made up of multicast traffic on this network segment. | PERF_AVERAGE_BULK
% Network Utilization | %Shows the percentage of network bandwidth in use on this network segment. | PERF_COUNTER_MULTI_TIMER
Broadcast Frames Received/sec | Shows the number of broadcast frames received per second on this network segment. | PERF_COUNTER_COUNTER
Multicast Frames Received/sec | Shows the number of multicast frames received per second on this network segment. | PERF_COUNTER_COUNTER
Total Bytes Received/sec | Shows the number of bytes received per second on this network segment. | PERF_COUNTER_COUNTER
Total Frames Received/sec | Shows the total number of frames received per second on this network segment. | PERF_COUNTER_COUNTER

See also

  • Network Monitor


NNTP Commands Object

The NNTP Commands performance object includes counters for all NNTP commands processed by the Network News Transport Protocol (NNTP) service, which is installed as an optional component of Internet Information Services.

NNTP counters are started for each virtual server instance and are reset to zero when the virtual server is started. A single NNTP service can have many virtual servers (also called sites).

Counter Name | Description | Counter Type
Article Commands | Shows the number of ARTICLE commands received by the NNTP Server since it was started. | PERF_COUNTER_RAWCOUNT
Article Commands/sec | Shows the number of ARTICLE commands per second that were received by the NNTP Server since it was started. | PERF_COUNTER_COUNTER
Check Commands | Shows the number of CHECK commands received by the NNTP Server since it was started. | PERF_COUNTER_RAWCOUNT
Check Commands/sec | Shows the number of CHECK commands per second that were received by the NNTP Server since it was started. | PERF_COUNTER_COUNTER
Group Commands | Shows the number of GROUP commands received by the NNTP Server since it was started. | PERF_COUNTER_RAWCOUNT
Group Commands/sec | Shows the number of GROUP commands per second that were received by the NNTP Server since it was started. | PERF_COUNTER_COUNTER
Help Commands | Shows the number of HELP commands that were received by the NNTP Server since it was started. | PERF_COUNTER_RAWCOUNT
Help Commands/sec | Shows the number of HELP commands per second that were received by the NNTP Server since it was started. | PERF_COUNTER_COUNTER
IHave Commands | Shows the number of IHAVE commands received by the NNTP Server since it was started. | PERF_COUNTER_RAWCOUNT
IHave Commands/sec | Shows the number of IHAVE commands per second that were received by the NNTP Server since it was started. | PERF_COUNTER_COUNTER
Last Commands | Shows the number of LAST commands received by the NNTP Server since it was started. | PERF_COUNTER_RAWCOUNT
Last Commands/sec | Shows the number of LAST commands per second that were received by the NNTP Server since it was started. | PERF_COUNTER_COUNTER
List Commands | Shows the number of LIST commands received by the NNTP Server since it was started. | PERF_COUNTER_RAWCOUNT
List Commands/sec | Shows the number of LIST commands per second that were received by the NNTP Server since it was started. | PERF_COUNTER_COUNTER
Logon Attempts | Shows the number of logon attempts that have been made to the NNTP Server. | PERF_COUNTER_RAWCOUNT
Logon Attempts/sec | Shows the number of logon attempts per second that have been made to the NNTP Server. | PERF_COUNTER_COUNTER
Logon Failures | Shows the number of logons that had failed. | PERF_COUNTER_RAWCOUNT
Logon Failures/sec | Shows the number of logons per second that had failed. | PERF_COUNTER_COUNTER
Mode Commands | Shows the number of MODE commands received by the NNTP Server since it was started. | PERF_COUNTER_RAWCOUNT
Mode Commands/sec | Shows the number of MODE commands per second that were received by the NNTP Server since it was started. | PERF_COUNTER_COUNTER
Newgroups Commands | Shows the number of NEWGROUPS commands that were received by the NNTP Server since it was started. | PERF_COUNTER_RAWCOUNT
Newgroups Commands/sec | Shows the number of NEWGROUPS commands per second that were received by the NNTP Server since it was started. | PERF_COUNTER_COUNTER
Newnews Commands | Shows the number of NEWNEWS commands received by the NNTP Server since it was started. | PERF_COUNTER_RAWCOUNT
Newnews Commands/Sec | Shows the number of NEWNEWS commands per second that were received by the NNTP Server since it was started. | PERF_COUNTER_COUNTER
Next Commands | Shows the number of NEXT commands received by the NNTP Server since it was started. | PERF_COUNTER_RAWCOUNT
Next Commands/sec | Shows the number of NEXT commands per second that were received by the NNTP Server since it was started. | PERF_COUNTER_COUNTER
Post Commands | Shows the number of POST commands received by the NNTP Server since it was started. | PERF_COUNTER_RAWCOUNT
Post Commands/sec | Shows the number of POST commands per second that were received by the NNTP Server since it was started. | PERF_COUNTER_COUNTER
Quit Commands | Shows the number of QUIT commands that were received by the NNTP Server since it was started. | PERF_COUNTER_RAWCOUNT
Quit Commands/sec | Shows the number of QUIT commands per second that were received by the NNTP Server since it was started. | PERF_COUNTER_COUNTER
Search Commands | Shows the number of SEARCH commands received by the NNTP Server since it was started. | PERF_COUNTER_RAWCOUNT
Search Commands/sec | Shows the number of SEARCH commands per second that were received by the NNTP Server since it was started. | PERF_COUNTER_COUNTER
Stat Commands | Shows the number of STAT commands received by the NNTP Server since it was started. | PERF_COUNTER_RAWCOUNT
Stat Commands/sec | Shows the number of STAT commands per second that were received by the NNTP Server since it was started. | PERF_COUNTER_COUNTER
Takethis Commands | Shows the number of TAKETHIS commands received by the NNTP Server since it was started. | PERF_COUNTER_RAWCOUNT
Takethis Commands/sec | Shows the number of TAKETHIS commands per second that were received by the NNTP Server since it was started. | PERF_COUNTER_COUNTER
XHdr Commands | Shows the number of XHDR commands received by the NNTP Server since it was started. | PERF_COUNTER_RAWCOUNT
XHdr Commands/Sec | Shows the number of XHDR commands per second that were received by the NNTP Server since it was started. | PERF_COUNTER_COUNTER
XOver Commands | Shows the number of XOVER commands received by the NNTP Server since it was started. | PERF_COUNTER_RAWCOUNT
XOver Commands/sec | Shows the number of XOVER commands per second that were received by the NNTP Server since it was started. | PERF_COUNTER_COUNTER
XPat Commands | Shows the number of XPAT commands received by the NNTP Server since it was started. | PERF_COUNTER_RAWCOUNT
XPat Commands/sec | Shows the number of XPAT commands per second that were received by the NNTP Server since it was started. | PERF_COUNTER_COUNTER
XReplic Commands | Shows the number of XREPLIC commands received by the NNTP Server since it was started. | PERF_COUNTER_RAWCOUNT
XReplic Commands/sec | Shows the number of XREPLIC commands per second that were received by the NNTP Server since it was started. | PERF_COUNTER_COUNTER


NNTP Server Object

The NNTP Server performance object monitors posting, authentication, and connection activity on an NNTP server. The Network News Transport Protocol (NNTP) service is an optional component of Internet Information Services.

NNTP counters are started for each virtual server instance and are reset to zero when the virtual server is started. A single NNTP service can have many virtual servers (also called sites).

In addition to monitoring these counters, it is recommended that you also monitor the system counters PhysicalDisk\Disk Reads/sec, PhysicalDisk\Disk Writes/sec, PhysicalDisk\Disk Transfers/sec and Processor(_Total)\% Processor Time.

Counter Name | Description | Counter Type
Article Map Entries | Shows the entries inserted into the article mapping table of the NNTP server. | PERF_COUNTER_RAWCOUNT
Article Map Entries/sec | Shows the entries inserted per second into the article mapping table of the NNTP server. | PERF_COUNTER_COUNTER
Articles Deleted | Shows the number of articles deleted on the NNTP server since it was started. | PERF_COUNTER_RAWCOUNT
Articles Deleted/sec | Shows the number of articles deleted per second on the NNTP server since it was started. | PERF_COUNTER_COUNTER
Articles Posted | Shows the number of articles posted (committed) to the NNTP server. This can be used to determine if the server is accepting posts. If this value is smaller than that of Articles Received, this indicates that the server is rejecting articles and you need to investigate the cause. | PERF_COUNTER_RAWCOUNT
Articles Posted/sec | Shows the number of articles posted per second to the NNTP server. | PERF_COUNTER_COUNTER
Articles Received | Shows the total number of files received by the NNTP server and can include rejected articles. If this value is greater than that of Articles Posted, this indicates that the server is rejecting articles and you need to investigate the cause. | PERF_COUNTER_RAWCOUNT
Articles Received/sec | Shows the total number of files per second received by the NNTP server. | PERF_COUNTER_COUNTER
Articles Sent | Shows the total number of files sent by the NNTP server to other servers and can include rejected articles. | PERF_COUNTER_RAWCOUNT
Articles Sent/sec | Shows the total number of files sent per second by the NNTP server. | PERF_COUNTER_COUNTER
Articles Total | Shows the sum of Articles Sent and Articles Received. This is the total number of files transferred by the NNTP server. | PERF_COUNTER_RAWCOUNT
Bytes Received/sec | Shows the rate that data bytes are received by the NNTP server. | PERF_COUNTER_BULK_COUNT
Bytes Sent/sec | Shows the rate that data bytes are sent by the NNTP server. | PERF_COUNTER_BULK_COUNT
Bytes Total/sec | Shows the sum of Bytes Sent/sec and Bytes Received/sec. This is the total rate of bytes transferred by the NNTP server. | PERF_COUNTER_BULK_COUNT
Control Messages Failed | Shows the total number of control messages failed or not applied by the NNTP server. | PERF_COUNTER_RAWCOUNT
Control Messages Received | Shows the total number of control messages received by the NNTP server. | PERF_COUNTER_RAWCOUNT
Current Anonymous Users | Shows the number of anonymous users currently connected to the NNTP server. | PERF_COUNTER_RAWCOUNT
Current Connections | Shows the current number of connections to the NNTP server. | PERF_COUNTER_RAWCOUNT
Current NonAnonymous Users | Shows the number of nonanonymous users currently connected to the NNTP server. | PERF_COUNTER_RAWCOUNT
Current Outbound Connections | Shows the number of current outbound connections being made by the NNTP server. | PERF_COUNTER_RAWCOUNT
Failed Outbound Logons | Shows the number of failed outbound logons made by the NNTP server. | PERF_COUNTER_RAWCOUNT
History Map Entries | Shows the entries inserted into the history mapping table of the NNTP server. | PERF_COUNTER_RAWCOUNT
History Map Entries/Sec | Shows the entries inserted per second into the history mapping table of the NNTP server. | PERF_COUNTER_COUNTER
Maximum Anonymous Users | Shows the maximum number of anonymous users that are simultaneously connected to the NNTP server. | PERF_COUNTER_RAWCOUNT
Maximum Connections | Shows the maximum number of simultaneous connections to the NNTP server. | PERF_COUNTER_RAWCOUNT
Maximum NonAnonymous Users | Shows the maximum number of nonanonymous users simultaneously connected to the NNTP server. | PERF_COUNTER_RAWCOUNT
Moderated Postings Failed | Shows the total number of moderated postings the NNTP server fails to send to an SMTP Server. | PERF_COUNTER_RAWCOUNT
Moderated Postings Sent | Shows the total number of moderated postings the NNTP server attempts to send to an SMTP Server. | PERF_COUNTER_RAWCOUNT
Sessions Flow Controlled | Shows the number of client sessions that are currently in a flow controlled state in the NNTP server. | PERF_COUNTER_RAWCOUNT
Total Anonymous Users | Shows the total number of anonymous users that have ever connected to the NNTP server. | PERF_COUNTER_RAWCOUNT
Total Connections | Shows the number of connections that have been made to the NNTP server. | PERF_COUNTER_RAWCOUNT
Total NonAnonymous Users | Shows the total number of nonanonymous users that have ever connected to the NNTP server. | PERF_COUNTER_RAWCOUNT
Total Outbound Connections | Shows the number of outbound connections that have been made by the NNTP server. | PERF_COUNTER_RAWCOUNT
Total Outbound Connections Failed | Shows the number of unsuccessful outbound connections that have been made by the NNTP server. | PERF_COUNTER_RAWCOUNT
Total Passive Feeds | Shows the number of passive feeds accepted by the NNTP server. | PERF_COUNTER_RAWCOUNT
Total Pull Feeds | Shows the number of pull feeds made by the NNTP server. | PERF_COUNTER_RAWCOUNT
Total Push Feeds | Shows the number of push feeds made by the NNTP server. | PERF_COUNTER_RAWCOUNT
Total SSL Connections | Shows the number of Secure Sockets Layer (SSL) connections that have been made to the NNTP server. | PERF_COUNTER_RAWCOUNT
Xover Entries | Shows the number of xover entries in the xover table of the NNTP server. | PERF_COUNTER_RAWCOUNT
Xover Entries/sec | Shows the number of xover entries inserted per second in the xover table of the NNTP server. | PERF_COUNTER_COUNTER


NTDS Object

The NTDS object provides statistics about the activity of Active Directory. The object provides information about the following:

  • The Name Service Provider Interface (NSPI), used to facilitate communication between the Active Directory and Exchange Directory Service (XDS).
  • The Local Security Authority (LSA), a protected subsystem that maintains the security for the local computer.
  • The Security Accounts Manager (SAM) interface, that provides compatibility between Windows 2000 and Windows NT 4.0 domains. The Lightweight Directory Access Protocol (LDAP) interface that provides the API for LDAP clients and exposes the Active Directory Services Interface (ADSI) so additional applications may be written that can talk to the Active Directory.
  • The Directory System Agent (DSA), the Active Directory process that runs on each domain controller and manages all the directory service functions.
  • The Knowledge Consistency Checker (KCC), an Active Directory component that is responsible for the generating the replication topology between domain controllers.
Counter Name | Description | Counter Type
AB ANR/sec | Shows the rate at which Address Book clients perform Ambiguous Name Resolutions (ANR) operations. | PERF_COUNTER_COUNTER
AB Browses/sec | Shows the rate at which Address Book clients perform browse operations. | PERF_COUNTER_COUNTER
AB Client Sessions | Shows the number of connected Address Book client sessions. | PERF_COUNTER_RAWCOUNT
AB Matches/sec | Shows the rate at which Address Book clients perform find operations. | PERF_COUNTER_COUNTER
AB Property Reads/sec | Shows the rate at which Address Book clients perform property read operations. | PERF_COUNTER_COUNTER
AB Proxy Lookups/sec | Shows the rate at which proxy clients query perform search operations. | PERF_COUNTER_COUNTER
AB Searches/sec | Shows the rate at which Address Book clients perform key search operations | PERF_COUNTER_COUNTER
DRA Highest USN Committed (High part) | Shows the high-order 32 bits of the highest USN Committed on the DSA. | PERF_COUNTER_RAWCOUNT
DRA Highest USN Committed (Low part) | Shows the low-order 32 bits of the highest USN Committed on the DSA. | PERF_COUNTER_RAWCOUNT
DRA Highest USN Issued (High part) | Shows the high-order 32 bits of the highest USN Issued on the DSA. | PERF_COUNTER_RAWCOUNT
DRA Highest USN Issued (Low part) | Shows the low-order 32 bits of the highest USN Issued on the DSA. | PERF_COUNTER_RAWCOUNT
DRA Inbound Bytes Compressed (Between Sites, After Compression)/sec | Shows the compressed size, in bytes, of inbound compressed replication data (size after compression, from DSAs in other sites). | PERF_COUNTER_COUNTER
DRA Inbound Bytes Compressed (Between Sites, Before Compression)/sec | Shows the original size, in bytes, of inbound compressed replication data (size before compression, from DSAs in other sites). | PERF_COUNTER_COUNTER
DRA Inbound Bytes Not Compressed (Within Site)/sec | Shows the number of incoming bytes replicated that were not compressed at the source (that is, from DSAs in the same site). | PERF_COUNTER_COUNTER
DRA Inbound Bytes Total/sec | Shows the total number of bytes replicated in. It is the sum of the number of uncompressed bytes (never compressed) and the number of compressed bytes (after compression). | PERF_COUNTER_COUNTER
DRA Inbound Full Sync Objects Remaining | Shows the number of objects remaining until the full sync completes (when set). | PERF_COUNTER_RAWCOUNT
DRA Inbound Object Updates Remaining in Packet | Shows the number of object updates received in the current directory replication update packet that have not yet been applied to the local server. | PERF_COUNTER_RAWCOUNT
DRA Inbound Objects Applied/sec | Shows the rate at which replication updates received from replication partners are applied by the local directory service. This count excludes changes that are received but not applied (for example, when the change is already present). This indicates how much replication update activity is occurring on the server as a result of changes generated on other servers. | PERF_COUNTER_COUNTER
DRA Inbound Objects Filtered/sec | Shows the number of objects received from inbound replication partners that contained no updates that needed to be applied. | PERF_COUNTER_COUNTER
DRA Inbound Objects/sec | Shows the number of objects received from neighbors through inbound replication. A neighbor is a domain controller from which the local domain controller replicates locally. | PERF_COUNTER_COUNTER
DRA Inbound Properties Applied/sec | Shows the number of properties that are updated due to incoming property winning the reconciliation logic that determines the final value to be replicated. | PERF_COUNTER_COUNTER
DRA Inbound Properties Filtered/sec | Shows the number of property changes that are received during the replication that we have already seen. | PERF_COUNTER_COUNTER
DRA Inbound Properties Total/sec | Shows the total number of object properties received from inbound replication partners. | PERF_COUNTER_COUNTER
DRA Inbound Values (DNs only)/sec | Shows the number of object property values received from inbound replication partners that are Distinguished Names (DNs) which reference other objects. distinguished-name values, such as group or distribution list memberships, are generally more expensive to apply than other kinds of values. | PERF_COUNTER_COUNTER
DRA Inbound Values Total/sec | shows the total number of object property values received from inbound replication partners. Each inbound object has one or more properties, and each property has zero or more values. Zero values indicates property removal. | PERF_COUNTER_COUNTER
DRA Outbound Bytes Compressed (Between Sites, After Compression)/sec | Shows the compressed size, in bytes, of outbound compressed replication data (size after compression, from DSAs in other sites). | PERF_COUNTER_COUNTER
DRA Outbound Bytes Compressed (Between Sites, Before Compression)/sec | Shows the original size, in bytes, of outbound compressed replication data (size before compression, from DSAs in other sites). | PERF_COUNTER_COUNTER
DRA Outbound Bytes Not Compressed (Within Site)/sec | Shows the number of bytes replicated out that were not compressed (that is., from DSAs in the same site). | PERF_COUNTER_COUNTER
DRA Outbound Bytes Total/sec | Shows the total number of bytes replicated out. It is the sum of the number of uncompressed bytes (never compressed) and the number of compressed bytes (after compression). | PERF_COUNTER_COUNTER
DRA Outbound Objects Filtered/sec | Shows the number of objects that were determined by outbound replication to have no updates that the outbound partner did not already have. | PERF_COUNTER_COUNTER
DRA Outbound Objects/sec | Shows the number of objects replicated out. | PERF_COUNTER_COUNTER
DRA Outbound Properties/sec | Shows the number of properties replicated out. | PERF_COUNTER_COUNTER
DRA Outbound Values (DNs only)/sec | Shows the number of object property values containing Distinguished Names sent to outbound replication partners. DN-values, such as group or distribution list memberships, are generally more expensive to read than other kinds of values. | PERF_COUNTER_COUNTER
DRA Outbound Values Total/sec | Shows the number of object property values sent to outbound replication partners. | PERF_COUNTER_COUNTER
DRA Pending Replication Synchronizations | Shows the number of directory synchronizations that are queued for this server but not yet processed. | PERF_COUNTER_RAWCOUNT
DRA Reads | Shows the percentage of directory reads coming from DRA. | PERF_RAW_FRACTION
DRA Searches | Shows the percentage of directory searches coming from DRA. | PERF_RAW_FRACTION
DRA Sync Failures on Schema Mismatch | Shows the number of sync requests made to neighbors that failed because their schema are not synchronized. | PERF_COUNTER_RAWCOUNT
DRA Sync Requests Made | Shows the number of sync requests made to neighbors. | PERF_COUNTER_RAWCOUNT
DRA Sync Requests Successful | Shows the number of sync requests made to the neighbors that successfully returned. | PERF_COUNTER_RAWCOUNT
DRA Writes | Shows the percentage of directory writes coming from DRA. | PERF_RAW_FRACTION
DS Client Binds/sec | Showa the number of Ntdsapi.dll binds per second serviced by this DC. | PERF_COUNTER_COUNTER
DS Client Name Translations/sec | Shows the number of Ntdsapi.dll name translations per second serviced by this DC. | PERF_COUNTER_COUNTER
DS Directory Reads/sec | Shows the number of directory reads per second. | PERF_COUNTER_COUNTER
DS Directory Searches/sec | Shows the number of directory searches per second. | PERF_COUNTER_COUNTER
DS Directory Writes/sec | Shows the number of directory writes per second. | PERF_COUNTER_COUNTER
DS Monitor List Size | Shows the number of requests to be notified when objects are updated that are currently registered with this DSA. | PERF_COUNTER_RAWCOUNT
DS Name Cache hit rate | Shows the percentage of directory object name component lookups that are satisfied out of the DSA's name cache. | PERF_RAW_FRACTION
DS Notify Queue Size | Shows the number of pending update notifications that have been queued, but not yet transmitted to clients. | PERF_COUNTER_RAWCOUNT
DS Other Reads | Shows the percentage of directory reads not coming from SAM, DRA, LDAP, LSA, XDS, KCC, or NSPI. | PERF_RAW_FRACTION
DS Other Searches | Shows the percentage of directory searches not coming from SAM, DRA, LDAP, LSA, XDS, KCC, or NSPI. | PERF_RAW_FRACTION
DS Other Writes | Shows the percentage of directory writes not coming from SAM, DRA, LDAP, LSA, XDS, KCC, or NSPI. | PERF_RAW_FRACTION
DS Search sub-operations/sec | Shows the number of search suboperations per second. One search operation is made up of many suboperations. A sub operation roughly corresponds to an object that the search causes the directory service to consider. | PERF_COUNTER_COUNTER
DS Security Descriptor Propagations Events | Shows the number of Security Descriptor Propagation Events that are queued but not yet processed. | PERF_COUNTER_RAWCOUNT
DS Security Descriptor Propagator Average Exclusion Time | Shows the average length of time that the Security Descriptor propagator spends waiting for exclusive access to database elements during a Security Descriptor Propagation sub-operation. | PERF_COUNTER_RAWCOUNT
DS Security Descriptor Propagator Runtime Queue | Shows the number of objects remaining to examine while processing the current directory service security descriptor propagator event. | PERF_COUNTER_RAWCOUNT
DS Security Descriptor sub-operations/sec | Shows the number of Security Descriptor Propagation suboperations per second. One Security Descriptor Propagation operation is made up of many sub operations. | PERF_COUNTER_COUNTER
DS Server Binds/sec | Shows the number of DC-to-DC binds per second that are serviced by this DC. | PERF_COUNTER_COUNTER
DS Server Name Translations/sec | Shows the number of DC-to-DC name translations per second serviced by this DC. | PERF_COUNTER_COUNTER
DS Threads in Use | Shows the current number of threads in use by the directory service (which is different than the number of threads in the directory service process). This is the number of threads currently servicing client API calls and can be used to indicate whether additional processors should be used. | PERF_COUNTER_RAWCOUNT
KCC Reads | Shows the percentage of directory reads coming from KCC. | PERF_RAW_FRACTION
KCC Searches | Shows the percentage of directory searches coming from KCC. | PERF_RAW_FRACTION
KCC Writes | Shows the percentage of directory writes coming from KCC. | PERF_RAW_FRACTION
KDC AS Requests | Shows the number of Authentication Server (AS) requests serviced by the Kerberos Key Distribution Center (KDC) per second. AS requests are used by client to obtain a ticket-granting ticket. | PERF_COUNTER_COUNTER
KDC TGS Requests | Shows the number of Ticket Granting Server (TGS) requests serviced by the KDC per second. TGS requests are used by the client to obtain a ticket to a resource. | PERF_COUNTER_COUNTER
Kerberos Authentications | Shows the number of times per second that clients use a ticket to this DC to authenticate to this DC. | PERF_COUNTER_COUNTER
LDAP Active Threads | Shows the current number of threads in use by the LDAP subsystem of the local directory service. | PERF_COUNTER_RAWCOUNT
LDAP Bind Time | Shows the time, in milliseconds, taken for the last successful LDAP bind. | PERF_COUNTER_RAWCOUNT
LDAP Client Sessions | Shows the number of currently connected LDAP client sessions. | PERF_COUNTER_RAWCOUNT
LDAP Searches | Shows the percentage of directory searches coming from LDAP. | PERF_RAW_FRACTION
LDAP Searches/sec | Shows the rate at which LDAP clients perform search operations. | PERF_COUNTER_COUNTER
LDAP Successful Binds | Shows the percentage of LDAP bind attempts that are successful. | PERF_RAW_FRACTION
LDAP Successful Binds/sec | Shows the number of LDAP binds per second. | PERF_COUNTER_COUNTER
LDAP UDP operations/sec | Shows the number of UDP operations that the LDAP server is processing per second. | PERF_COUNTER_COUNTER
LDAP Writes | Shows the percentage of directory writes coming from LDAP. | PERF_RAW_FRACTION
LDAP Writes/sec | Shows the rate at which LDAP clients perform write operations. | PERF_COUNTER_COUNTER
LSA Reads | Shows the percentage of directory reads coming from LSA. | PERF_RAW_FRACTION
LSA Searches | Shows the percentage of directory searches coming from LSA. | PERF_RAW_FRACTION
LSA Writes | Shows the percentage of directory writes coming from LSA. | PERF_RAW_FRACTION
NSPI Reads | Shows the percentage of directory reads coming from NSPI. | PERF_RAW_FRACTION
NSPI Searches | Shows the percentage of directory searches coming from NSPI. | PERF_RAW_FRACTION
NSPI Writes | Shows the percentage of directory writes coming from NSPI. | PERF_RAW_FRACTION
NTLM Authentications | Shows the number of NTLM authentications per second serviced by this DC. | PERF_COUNTER_COUNTER
SAM Account Group Membership Evaluations/sec | Shows the number of SAM Account Group Membership Evaluations per second. | PERF_COUNTER_COUNTER
SAM Create Machine Attempts/sec | Shows the number of SAM create machine attempts per second. | PERF_COUNTER_COUNTER
SAM Create User Attempts/sec | Shows the number of SAM create user attempts per second. | PERF_COUNTER_COUNTER
SAM Enumerations/sec | Shows the number of SAM Enumerations per second. | PERF_COUNTER_COUNTER
SAM GC Evaluations/sec | Shows the number of SAM Global Catalog Evaluations per second. | PERF_COUNTER_COUNTER
SAM Membership Changes/sec | Shows the number of SAM membership changes. | PERF_COUNTER_COUNTER
SAM Non-Transitive Membership Evaluations/sec | Shows the number of SAM Non-Transitive Membership Evaluations per second. | PERF_COUNTER_COUNTER
SAM Password Changes/sec | Shows the number of SAM password changes per second. | PERF_COUNTER_COUNTER
SAM Query Displays/sec | Shows the number of SAM query displays per second. | PERF_COUNTER_COUNTER
SAM Reads | Shows the percentage of directory reads coming from SAM. | PERF_RAW_FRACTION
SAM Resource Group Membership Evaluations/sec | Shows the number of SAM Resource Group Membership Evaluations per second. | PERF_COUNTER_COUNTER
SAM Searches | Shows the percentage of directory searches coming from SAM. | PERF_RAW_FRACTION
SAM Successful Create Machines/sec | Shows the number of successful create machines per second. | PERF_COUNTER_COUNTER
SAM Successful Create Users/sec | Shows the number of successful create users per second. | PERF_COUNTER_COUNTER
SAM Transitive Membership Evaluations/sec | Shows the number of SAM Transitive Membership Evaluations per second. | PERF_COUNTER_COUNTER
SAM Universal Group Membership Evaluations/sec | Shows the number of SAM Universal Group Membership Evaluations per second. | PERF_COUNTER_COUNTER
SAM Writes | Shows the percentage of directory writes coming from SAM. | PERF_RAW_FRACTION
XDS Client Sessions | Shows the number of connected Extended Directory Service client sessions. This indicates the number of connections from other Windows 2000 services and the Exchange Administrator program. | PERF_COUNTER_RAWCOUNT
XDS Reads | Shows the percentage of directory reads coming from XDS. | PERF_RAW_FRACTION
XDS Searches | Shows the percentage of directory searches coming from XDS. | PERF_RAW_FRACTION
XDS Writes | Shows the percentage of directory writes coming from XDS. | PERF_RAW_FRACTION


NWLink IPX Object

The NWLink IPX performance object consists of counters that measure datagram transmission to and from computers using the IPX protocol.

Note Image Note

This object only reports valid data for counters that monitor datagrams and packets; for frame-related counters, the object tends to report zero values. In addition, connection-related data is not likely to be useful because IPX is a connectionless protocol.

Counter Name | Description | Counter Type
Bytes Total/sec | Shows the total rate at which bytes are sent to or received from the network by the protocol, but only counts the bytes in frames which carry data. This is the sum of the values of Frame Bytes/sec and Datagram Bytes/sec. | PERF_COUNTER_BULK_COUNT
Connection Session Timeouts | Shows the number of connections that were dropped due to a session time out. This number is cumulative and shows a running total. | PERF_COUNTER_RAWCOUNT
Connections Canceled | Shows the number of connections that were canceled. This number is cumulative and shows a running total. | PERF_COUNTER_RAWCOUNT
Connections No Retries | Shows the total number of connections that were successfully made on the first try. This number is cumulative and shows a running total. | PERF_COUNTER_RAWCOUNT
Connections Open | Shows the number of connections currently open for this protocol. This counter shows the current count only and does not accumulate over time. | PERF_COUNTER_RAWCOUNT
Connections With Retries | Shows the total count of connections that were made after retrying the attempt. A retry occurs when the first connection attempt failed. This number is cumulative and shows a running total. | PERF_COUNTER_RAWCOUNT
Datagram Bytes Received/sec | Shows the rate at which datagram bytes are received by the computer. | PERF_COUNTER_BULK_COUNT
Datagram Bytes Sent/sec | Shows the rate at which datagram bytes are sent from the computer. | PERF_COUNTER_BULK_COUNT
Datagram Bytes/sec | Shows the rate at which datagram bytes are processed by the computer. This counter is the sum of the values of Datagram Bytes Received/sec and Datagram Bytes Sent/sec. | PERF_COUNTER_BULK_COUNT
Datagrams Received/sec | Shows the rate at which datagrams are received by the computer. | PERF_COUNTER_COUNTER
Datagrams Sent/sec | Shows the rate at which datagrams are sent from the computer. | PERF_COUNTER_COUNTER
Datagrams/sec | Shows the rate at which datagrams are processed by the computer. This counter shows the sum of the values of Datagrams Received/sec and Datagrams Sent/sec. | PERF_COUNTER_COUNTER
Disconnects Local | Shows the number of session disconnections that were initiated by the local computer. This number is cumulative and shows a running total. | PERF_COUNTER_RAWCOUNT
Disconnects Remote | Shows the number of session disconnections that were initiated by the remote computer. This number is cumulative and shows a running total. | PERF_COUNTER_RAWCOUNT
Expirations Ack | Shows the count of T2 timer expirations. | PERF_COUNTER_RAWCOUNT
Expirations Response | Shows the count of T1 timer expirations. | PERF_COUNTER_RAWCOUNT
Failures Adapter | Shows the number of connections that were dropped due to an adapter failure. This number is cumulative and shows a running total. | PERF_COUNTER_RAWCOUNT
Failures Link | Shows the number of connections that were dropped due to a link failure. This number is cumulative and shows a running total. | PERF_COUNTER_RAWCOUNT
Failures No Listen | Shows the number of connections that were rejected because the remote computer was not listening for connection requests. | PERF_COUNTER_RAWCOUNT
Failures Not Found | Shows the number of connection attempts that failed because the remote computer could not be found. This number is cumulative and shows a running total. | PERF_COUNTER_RAWCOUNT
Failures Resource Local | Shows the number of connections that failed because of resource problems or shortages on the local computer. This number is cumulative and shows a running total. | PERF_COUNTER_RAWCOUNT
Failures Resource Remote | Shows the number of connections that failed because of resource problems or shortages on the remote computer. This number is cumulative and shows a running total. | PERF_COUNTER_RAWCOUNT
Frame Bytes Received/sec | Shows the rate at which data bytes are received by the computer. This counter only shows the frames that carry data. | PERF_COUNTER_BULK_COUNT
Frame Bytes Rejected/sec | Shows the rate at which data bytes are rejected. This counter only shows the bytes in frames that carry data. | PERF_COUNTER_BULK_COUNT
Frame Bytes Re-Sent/sec | Shows the rate at which data bytes are re-sent by the computer. This counter only shows the bytes in frames that carry data. | PERF_COUNTER_BULK_COUNT
Frame Bytes Sent/sec | shows the rate at which data bytes are sent by the computer. This counter only shows the bytes in frames that carry data. | PERF_COUNTER_BULK_COUNT
Frame Bytes/sec | Shows the rate at which data bytes are processed by the computer. This counter is the sum of Frame Bytes Sent/sec and Frame Bytes Received/sec. This counter only shows the bytes in frames that carry data. | PERF_COUNTER_BULK_COUNT
Frames Received/sec | Shows the rate at which data frames are received by the computer. This counter only shows the frames that carry data. | PERF_COUNTER_COUNTER
Frames Rejected/sec | Shows the rate at which data frames are rejected. This counter only shows the frames that carry data. | PERF_COUNTER_COUNTER
Frames Re-Sent/sec | Shows the rate at which data frames are re-sent by the computer. This counter only shows the frames that carry data. | PERF_COUNTER_COUNTER
Frames Sent/sec | Shows the rate at which data frames are sent by the computer. This counter only shows the frames that carry data. | PERF_COUNTER_COUNTER
Frames/sec | Shows the rate at which data frames are processed by the computer. This counter is the sum of the values of Frames Received/sec and Frames Sent/sec. This counter only shows the frames that carry data. | PERF_COUNTER_COUNTER
Packets Received/sec | Shows the rate at which packets are received by the computer. This counter shows all packets processed (control as well as data packets). | PERF_COUNTER_COUNTER
Packets Sent/sec | shows the rate at which packets are sent by the computer. This counter shows all packets sent by the computer (control as well as data packets). | PERF_COUNTER_COUNTER
Packets/sec | Shows the rate at which packets are processed by the computer. This count is the sum of the values of Packets Sent/sec and Packets Received/sec. This counter includes all packets processed (control as well as data packets). | PERF_COUNTER_COUNTER
Piggyback Ack Queued/sec | Shows the rate at which piggyback acknowledgments are queued. | PERF_COUNTER_COUNTER
Piggyback Ack Timeouts | Shows the number of times that a piggyback acknowledgment could not be sent because there was no outgoing packet to the remote computer on which to piggyback. If no outgoing packet is sent within the time-out period, then an acknowledgment packet is sent and this counter is incremented. | PERF_COUNTER_RAWCOUNT
Window Send Average | Shows the average number of data bytes that were sent before waiting for an acknowledgment from the remote computer. | PERF_COUNTER_RAWCOUNT
Window Send Maximum | Shows the maximum number of data bytes that are sent before waiting for an acknowledgment from the remote computer. | PERF_COUNTER_RAWCOUNT

See also

  • NWLink NetBIOS Object
  • NWLink SPX Object


NWLink NetBIOS Object

The NWLink NetBIOS performance object consists of counters that monitor IPX transport rates and connections.

Note Image Note

This object only reports valid data for counters that monitor datagrams and packets; for frame-related counters, the object tends to report zero values.

Counter Name | Description | Counter Type
Bytes Total/sec | Shows the total rate of bytes sent to or received from the network by the protocol, but only counts the bytes in frames which carry data. This is the sum of the values of Frame Bytes/sec and Datagram Bytes/sec. | PERF_COUNTER_BULK_COUNT
Connection Session Timeouts | Shows the number of connections that were dropped due to a session time out. This number is cumulative and shows a running total. | PERF_COUNTER_RAWCOUNT
Connections Canceled | Shows the number of connections that were canceled. This number is cumulative and shows a running total. | PERF_COUNTER_RAWCOUNT
Connections No Retries | shows the total count of connections that were successfully made on the first try. This number is cumulative and shows a running total. | PERF_COUNTER_RAWCOUNT
Connections Open | Shows the number of connections currently open for this protocol. This counter shows the current count only and does not accumulate over time. | PERF_COUNTER_RAWCOUNT
Connections With Retries | Shows the total count of connections that were made after retrying the attempt. A retry occurs when the first connection attempt failed. This number is cumulative and shows a running total. | PERF_COUNTER_RAWCOUNT
Datagram Bytes Received/sec | Shows the rate at which datagram bytes are received by the computer. | PERF_COUNTER_BULK_COUNT
Datagram Bytes Sent/sec | Shows the rate at which datagram bytes are sent from the computer. | PERF_COUNTER_BULK_COUNT
Datagram Bytes/sec | shows the rate at which datagram bytes are processed by the computer. This counter is the sum of the values of Datagram Bytes Received/sec and Datagram Bytes Sent/sec. | PERF_COUNTER_BULK_COUNT
Datagrams Received/sec | Shows the rate at which datagrams are received by the computer. | PERF_COUNTER_COUNTER
Datagrams Sent/sec | Shows the rate at which datagrams are sent from the computer. | PERF_COUNTER_COUNTER
Datagrams/sec | Shows the rate at which datagrams are processed by the computer. This counter shows the sum of the values of Datagrams Received/sec and Datagrams Sent/sec. | PERF_COUNTER_COUNTER
Disconnects Local | Shows the number of session disconnections that were initiated by the local computer. This number is cumulative and shows a running total. | PERF_COUNTER_RAWCOUNT
Disconnects Remote | Shows the number of session disconnections that were initiated by the remote computer. This number is cumulative and shows a running total. | PERF_COUNTER_RAWCOUNT
Expirations Ack | Shows the count of T2 timer expirations. | PERF_COUNTER_RAWCOUNT
Expirations Response | Shows the count of T1 timer expirations. | PERF_COUNTER_RAWCOUNT
Failures Adapter | Shows the number of connections that were dropped due to an adapter failure. This number is cumulative and shows a running total. | PERF_COUNTER_RAWCOUNT
Failures Link | Shows the number of connections that were dropped due to a link failure. This number is cumulative and shows a running total. | PERF_COUNTER_RAWCOUNT
Failures No Listen | Shows the number of connections that were rejected because the remote computer was not listening for connection requests. | PERF_COUNTER
Failures Not Found | shows the number of connection attempts that failed because the remote computer could not be found. This number is cumulative and shows a running total. | PERF_COUNTER_RAWCOUNT
Failures Resource Local | Shows the number of connections that failed because of resource problems or shortages on the local computer. This number is cumulative and shows a running total. | PERF_COUNTER_RAWCOUNT
Failures Resource Remote | Shows the number of connections that failed because of resource problems or shortages on the remote computer. This number is cumulative and shows a running total. | PERF_COUNTER_RAWCOUNT
Frame Bytes Received/sec | Shows the rate at which data bytes are received by the computer. This counter only shows the frames that carry data. | PERF_COUNTER_BULK_COUNT
Frame Bytes Rejected/sec | Shows the rate at which data bytes are rejected. This counter only shows the bytes in data frames that carry data. | PERF_COUNTER_BULK_COUNT
Frame Bytes Re-Sent/sec | Shows the rate at which data bytes are re-sent by the computer. This counter only shows the bytes in frames that carry data. | PERF_COUNTER_BULK_COUNT
Frame Bytes Sent/sec | Shows the rate at which data bytes are sent by the computer. This counter only shows the bytes in frames that carry data. | PERF_COUNTER_BULK_COUNT
Frame Bytes/sec | Shows the rate at which data bytes are processed by the computer. This counter is the sum of the values of Frame Bytes Received/sec and Frame Bytes Sent/sec. This counter only shows the bytes in frames that carry data. | PERF_COUNTER_BULK_COUNT
Frames Received/sec | Shows the rate at which data frames are received by the computer. This counter only shows the frames that carry data. | PERF_COUNTER_COUNTER
Frames Rejected/sec | Shows the rate at which data frames are rejected. This counter only shows the frames that carry data. | PERF_COUNTER_COUNTER
Frames Re-Sent/sec | Shows the rate at which data frames are re-sent by the computer. This counter only shows the frames that carry data. | PERF_COUNTER_COUNTER
Frames Sent/sec | Shows the rate at which data frames are sent by the computer. This counter only shows the frames that carry data. | PERF_COUNTER_COUNTER
Frames/sec | Shows the rate at which data frames are processed by the computer. This counter is the sum of the values of Frames Received/sec and Frames Sent/sec. This counter only shows the frames that carry data. | PERF_COUNTER_COUNTER
Packets Received/sec | Shows the rate at which packets are received by the computer. This counter shows all packets processed (control as well as data packets). | PERF_COUNTER_COUNTER
Packets Sent/sec | Shows the rate at which packets are sent by the computer. This counter shows all packets sent by the computer (control as well as data packets). | PERF_COUNTER_COUNTER
Packets/sec | Shows the rate at which packets are processed by the computer. This count is the sum of the values of Packets Received/sec and Packets Sent/sec. This counter includes all packets processed (control as well as data packets). | PERF_COUNTER_COUNTER
Piggyback Ack Queued/sec | Shows the rate at which piggyback acknowledgments are queued. | PERF_COUNTER_COUNTER
Piggyback Ack Timeouts | shows the number of times that a piggyback acknowledgment could not be sent because there was no outgoing packet to the remote computer on which to piggyback. If no outgoing packet is sent within the time-out period, then an acknowledgment packet is sent and this counter is incremented. | PERF_COUNTER_RAWCOUNT
Window Send Average | Shows the average number of data bytes that were sent before waiting for an acknowledgment from the remote computer. | PERF_COUNTER_RAWCOUNT
Window Send Maximum | Shows the maximum number of data bytes that are sent before waiting for an acknowledgment from the remote computer. | PERF_COUNTER_RAWCOUNT

See also

  • NWLink IPX Object
  • NWLink SPX Object


NWLink SPX Object

The NWLink SPX performance object consists of counters that measure data transmission and session connections for computers using the SPX protocol.

Note Image Note

This object only reports valid data for counters that monitor datagrams and packets; for frame-related counters, the object tends to report zero values.

Counter Name | Description | Counter Type
Bytes Total/sec | Shows the total rate of bytes sent to or received from the network by the protocol, but only shows the bytes in frames that carry data. This is the sum of the values of Frame Bytes/sec and Datagram Bytes/sec. | PERF_COUNTER_BULK_COUNT
Connection Session Timeouts | Shows the number of connections that were dropped due to a session time out. This number is cumulative and shows a running total. | PERF_COUNTER_RAWCOUNT
Connections Canceled | Shows the number of connections that were canceled. This number is cumulative and shows a running total. | PERF_COUNTER_RAWCOUNT
Connections No Retries | Shows the total count of connections that were successfully made on the first try. This number is cumulative and shows a running total. | PERF_COUNTER_RAWCOUNT
Connections Open | Shows the number of connections currently open for this protocol. This counter shows the current count only and does not accumulate over time. | PERF_COUNTER_RAWCOUNT
Connections With Retries | Shows the total count of connections that were made after retrying the attempt. A retry occurs when the first connection attempt failed. This number is cumulative and shows a running total. | PERF_COUNTER_RAWCOUNT
Datagram Bytes Received/sec | Shows the rate at which datagram bytes are received by the computer. | PERF_COUNTER_BULK_COUNT
Datagram Bytes Sent/sec | Shows the rate at which datagram bytes are sent from the computer. | PERF_COUNTER_BULK_COUNT
Datagram Bytes/sec | Shows the rate at which datagram bytes are processed by the computer. This counter is the sum of the values of Datagram Bytes Received/sec and Datagram Bytes Sent/sec. | PERF_COUNTER_BULK_COUNT
Datagrams Received/sec | Shows the rate at which datagrams are received by the computer. | PERF_COUNTER_COUNTER
Datagrams Sent/sec | Shows the rate at which datagrams are sent from the computer. | PERF_COUNTER_COUNTER
Datagrams/sec | Shows the rate at which datagrams are processed by the computer. This counter is the sum of the values of Datagrams Received/sec and Datagrams Sent/sec. | PERF_COUNTER_COUNTER
Disconnects Local | Shows the number of session disconnections that were initiated by the local computer. This number is cumulative and shows a running total. | PERF_COUNTER_RAWCOUNT
Disconnects Remote | Shows the number of session disconnections that were initiated by the remote computer. This number is cumulative and shows a running total. | PERF_COUNTER_RAWCOUNT
Expirations Ack | Shows the count of T2 timer expirations | PERF_COUNTER_RAWCOUNT
Expirations Response | Shows the count of T1 timer expirations. | PERF_COUNTER_RAWCOUNT
Failures Adapter | Shows the number of connections that were dropped due to an adapter failure. This number is cumulative and shows a running total. | PERF_COUNTER_RAWCOUNT
Failures Link | Shows the number of connections that were dropped due to a link failure. This number is cumulative and shows a running total. | PERF_COUNTER_RAWCOUNT
Failures No Listen | Shows the number of connections that were rejected because the remote computer was not listening for connection requests. | PERF_COUNTER_RAWCOUNT
Failures Not Found | Shows the number of connection attempts that failed because the remote computer could not be found. This number is cumulative and shows a running total. | PERF_COUNTER_RAWCOUNT
Failures Resource Local | Shows the number of connections that failed because of resource problems or shortages on the local computer. This number is cumulative and shows a running total. | PERF_COUNTER_RAWCOUNT
Failures Resource Remote | Shows the number of connections that failed because of resource problems or shortages on the remote computer. This number is cumulative and shows a running total. | PERF_COUNTER_RAWCOUNT
Frame Bytes Received/sec | Shows the rate at which data bytes are received by the computer. This counter only shows the frames that carry data. | PERF_COUNTER_BULK_COUNT
Frame Bytes Rejected/sec | Shows the rate at which data bytes are rejected. This counter only shows the bytes in data frames that carry data. | PERF_COUNTER_BULK_COUNT
Frame Bytes Re-Sent/sec | Shows the rate at which data bytes are re-sent by the computer. This counter only shows the bytes in frames that carry data. | PERF_COUNTER_BULK_COUNT
Frame Bytes Sent/sec | Shows the rate at which data bytes are sent by the computer. This counter only shows the bytes in frames that carry data. | PERF_COUNTER_BULK_COUNT
Frame Bytes/sec | Shows the rate at which data bytes are processed by the computer. This counter is the sum of the values of Frame Bytes Received/sec and Frame Bytes Sent/sec. This counter only shows the bytes in frames that carry data. | PERF_COUNTER_BULK_COUNT
Frames Received/sec | Shows the rate at which data frames are received by the computer. This counter only shows the frames that carry data. | PERF_COUNTER_COUNTER
Frames Rejected/sec | Shows the rate at which data frames are rejected. This counter only shows the frames that carry data. | PERF_COUNTER_COUNTER
Frames Re-Sent/sec | Shows the rate at which data frames are re-sent by the computer. This counter only shows the frames that carry data. | PERF_COUNTER_COUNTER
Frames Sent/sec | Shows the rate at which data frames are sent by the computer. This counter only shows the frames that carry data. | PERF_COUNTER_COUNTER
Frames/sec | Shows the rate at which data frames are processed by the computer. This counter is the sum of the values of Frames Received/sec and Frames Sent/sec. This counter only shows the frames that carry data. | PERF_COUNTER_COUNTER
Packets Received/sec | Shows the rate at which packets are received by the computer. This counter shows all packets processed (control as well as data packets). | PERF_COUNTER_COUNTER
Packets Sent/sec | Shows the rate at which packets are sent by the computer. This counter shows all packets sent by the computer (control as well as data packets). | PERF_COUNTER_COUNTER
Packets/sec | Shows the rate at which packets are processed by the computer. This count is the sum of the values of Packets Sent and Packets Received per second. This counter includes all packets processed (control as well as data packets). Packets/sec is visible in IPX and NetBIOS. | PERF_COUNTER_COUNTER
Piggyback Ack Queued/sec | Shows the rate at which piggyback acknowledgments are queued. | PERF_COUNTER_COUNTER
Piggyback Ack Timeouts | Shows the number of times that a piggyback acknowledgment could not be sent because there was no outgoing packet to the remote computer on which to piggyback. If no outgoing packet is sent within the time-out period, then an acknowledgment packet is sent and this counter is incremented. | PERF_COUNTER_RAWCOUNT
Window Send Average | Shows the running average number of data bytes that were sent before waiting for an acknowledgment from the remote computer. | PERF_COUNTER_RAWCOUNT
Window Send Maximum | Shows the maximum number of data bytes that are sent before waiting for an acknowledgment from the remote computer. | PERF_COUNTER_RAWCOUNT

See also

  • NWLink NetBIOS Object
  • NWLink IPX Object


Objects Object

The Objects performance object consists of counters that monitor logical objects in the system, such as processes, threads, mutexes, and semaphores. This information can be used to detect the unnecessary consumption of computer resources. Each object requires memory to store basic information about the object.

Counter Name | Description | Counter Type
Events | Shows the number of events in the computer at the time of data collection. This is an instantaneous count, not an average over the time interval. An event is used when two or more threads try to synchronize execution. | PERF_COUNTER_RAWCOUNT
Mutexes | Shows the number of mutexes in the computer at the time of data collection. This is an instantaneous count, not an average over the time interval. Mutexes are used by threads to assure that only one thread is executing a particular section of code. | PERF_COUNTER_RAWCOUNT
Processes | Shows the number of processes in the computer at the time of data collection. This is an instantaneous count, not an average over the time interval. Each process represents the running of a program. | PERF_COUNTER_RAWCOUNT
Sections | Shows the number of sections in the computer at the time of data collection. This is an instantaneous count, not an average over the time interval. A section is a portion of virtual memory created by a process for storing data. A process might share sections with other processes. | PERF_COUNTER_RAWCOUNT
Semaphores | Shows the number of semaphores in the computer at the time of data collection. This is an instantaneous count, not an average over the time interval. Threads use semaphores to obtain exclusive access to data structures that they share with other threads. | PERF_COUNTER_RAWCOUNT
Threads | Shows the number of threads in the computer at the time of data collection. This is an instantaneous count, not an average over the time interval. A thread is the basic executable entity that can execute instructions in a processor. | PERF_COUNTER_RAWCOUNT

See also

  • Thread Object
  • Process Object
  • Image Object
  • Process Address Space Object


Paging File Object

The Paging File performance object consists of counters that monitor the paging file(s) on the computer. The paging file is a reserved space on disk that backs up committed physical memory on the computer.

Counter Name | Description | Counter Type
% Usage Peak | Shows the greatest percentage of the paging file that was in use during the sample interval. | PERF_RAW_FRACTION

See also

  • Process\Page File Bytes Peak


PBServer Monitor Object

Phone Book service, a comprehensive phone book management system, is a component of Connection Point Services. Phone Book service provides a central location for adding, removing, and distributing access numbers for both public and private networks. The PBServer Monitor performance object monitors activity on the phone book server. (PBServer is an abbreviation of Phone Book Server.) A few of the counters, such as Error Hits, can be used to detect errors.

These counter objects do not show up in System Monitor until the service has been started. The service starts when a phone book is requested.

Counter Name | Description | Counter Type
Delta Upgrade Hits | Shows the total number of updated (delta) phone book files that have been successfully downloaded to the Connection Manager client. | PERF_COUNTER_RAWCOUNT
Delta Upgrade Hits/sec | Shows the number of updated (delta) phone book files that are successfully downloaded per second. to the Connection Manager client. | PERF_COUNTER_COUNTER
Error Hits | Shows the total number of requests that could not be satisfied by the phone book service. This could be due to a problem with the client or due to corruption in the service database. For example, the client is looking for the wrong phone book or a database corruption caused a phone book to be missing from the database. To investigate the cause, review the Web Service log for Windows NT verbose logging. Connection Manager requests appear in the log as Get requests to the Pbserver.dll. Also check for the PB= value in the log; this will be name of phone book. Research this name; try to find the name in the database (Pbserver.mdb). It may be necessary to repost the phone book using administrative tools. | PERF_COUNTER_RAWCOUNT
Error Hits/sec | Shows the number of requests per second that could not be satisfied by the phone book service. | PERF_COUNTER_COUNTER
Full Upgrade Hits | Shows the total number of full phone book files that have been successfully downloaded. | PERF_COUNTER_RAWCOUNT
Full Upgrade Hits/sec | Shows the number of full phone book files that are successfully downloaded per second. | PERF_COUNTER_COUNTER
No Upgrade Hits | Shows the total number of requests for phone book files that did not require an update to the phone book file on the user's computer. | PERF_COUNTER_RAWCOUNT
No Upgrade Hits/sec | Shows the number of requests for phone book files per second that do not require an update to the phone book file on the user's computer. | PERF_COUNTER_COUNTER
Total Hits | Shows the total number of requests for phone book files since Web services were last started. If this value seems low in comparison with the amount of user traffic you would expect, this could indicate a problem. | PERF_COUNTER_RAWCOUNT
Total Hits/sec | Shows the number of requests per second for phone book files. This counter is useful for determining the load on the Phone Book service. | PERF_COUNTER_COUNTER


PhysicalDisk Object

The PhysicalDisk performance object consists of counters that monitor hard or fixed disk drives on a computer. Disks are used to store file, program, and paging data, are read to retrieve these items, and are written to record changes to them. The values of physical disk counters are sums of the values of the logical disks (or partitions) into which they are divided.

Counter Name | Description | Counter Type
% Disk Read Time | Shows the percentage of time that the selected disk drive is busy servicing read requests. | PERF_PRECISION_100NS_TIMER
% Disk Time | Shows the percentage of elapsed time that the selected disk drive is busy servicing read or write requests. | PERF_PRECISION_100NS_TIMER
% Disk Write Time | Shows the percentage of elapsed time that the selected disk drive is busy servicing write requests. | PERF_PRECISION_100NS_TIMER
Avg. Disk Bytes/Read | Shows the average number of bytes transferred from the disk during read operations. | PERF_AVERAGE_BULK
Avg. Disk Bytes/Transfer | Shows the average number of bytes transferred to or from the disk during write or read operations. | PERF_AVERAGE_BULK
Avg. Disk Bytes/Write | Shows the average number of bytes transferred to the disk during write operations. | PERF_AVERAGE_BULK
Avg. Disk Queue Length | Shows the average number of both read and write requests that were queued for the selected disk during the sample interval. | PERF_COUNTER_LARGE_QUEUELEN_TYPE
Avg. Disk Read Queue Length | Shows the average number of read requests that were queued for the selected disk during the sample interval. | PERF_COUNTER_LARGE_QUEUELEN_TYPE
Avg. Disk sec/Read | Shows the average time, in seconds, of a read of data from the disk. | PERF_PRECISION_100NS_TIMER
Avg. Disk sec/Transfer | Shows the average time, in seconds, of a disk transfer. | PERF_PRECISION_100NS_TIMER
Avg. Disk sec/Write | Shows the average time, in seconds, of a write of data to the disk. | PERF_PRECISION_100NS_TIMER
Avg. Disk Write Queue Length | Shows the average number of write requests that were queued for the selected disk during the sample interval. | PERF_COUNTER_LARGE_QUEUELEN_TYPE
Current Disk Queue Length | Shows the number of requests that are outstanding on the disk at the time that the performance data is collected. It includes requests in service at the time of the collection. This is a snapshot, not an average over the time interval. It includes requests in service at the time of the collection. Multispindle disk devices can have multiple requests active at one time, but other concurrent requests are awaiting service. This counter might reflect a transitory high or low queue length, but if there is a sustained load on the disk drive, it is likely that this is consistently high. Requests experience delays proportional to the length of this queue minus the number of spindles on the disks. This difference should average less than two. | PERF_COUNTER_RAWCOUNT
Disk Bytes/sec | Shows the rate at which bytes are transferred to or from the disk during write or read operations. | PERF_COUNTER_BULK_COUNT
Disk Read Bytes/sec | Shows the rate at which bytes are transferred from the disk during read operations. | PERF_COUNTER_BULK_COUNT
Disk Reads/sec | Shows the rate of read operations on the disk. | PERF_COUNTER_COUNTER
Disk Transfers/sec | Shows the rate of read and write operations on the disk. | PERF_COUNTER_COUNTER
Disk Write Bytes/sec | Shows the rate at which bytes are transferred to the disk during write operations. | PERF_COUNTER_BULK_COUNT
Disk Writes/sec | Shows the rate of write operations on the disk. | PERF_COUNTER_COUNTER
% Idle Time | Shows the percentage of time that the disk was idle during the sample interval. | PERF_PRECISION_100NS_TIMER
Split IO/Sec | Shows the rate at which that I/O requests to the disk were split into multiple requests. A split I/O may result from requesting data in a size that is too large to fit into a single I/O or that the disk is fragmented on single-disk systems. | PERF_COUNTER_COUNTER

See also

  • Finding Disk Bottlenecks


Print Queue Object

Windows 2000 printing features provide the Print Queue Object performance object for tracking activity in the server print queue. Its counters are reset when either the print server or the spooler service is restarted.

Counter Name | Description | Counter Type
Add Network Printer Calls | Shows the total number of calls from other print servers to add shared network printers to this server since last restart. | PERF_COUNTER_RAWCOUNT
Bytes Printed/sec | Shows the number of bytes per second printed in a print queue. This is a rough indication of how busy a printer is. This counter can be used for bottleneck detection. | PERF_COUNTER_BULK_COUNT
Enumerate Network Printer Calls | Shows the total number of calls from browse clients to this print server to request network browse lists since last restart. | PERF_COUNTER_RAWCOUNT
Job Errors | Shows the total number of job errors in a print queue since last restart. Job errors can occur if the connection to the printer has errors due to network problems. | PERF_COUNTER_RAWCOUNT
Jobs | Shows the current number of jobs in a print queue. Use this counter to identify excessive use. | PERF_COUNTER_RAWCOUNT
Jobs Spooling | Shows the current number of spooling jobs in a print queue. | PERF_COUNTER_RAWCOUNT
Max Jobs Spooling | Shows the maximum number of spooling jobs in a print queue since last restart. | PERF_COUNTER_RAWCOUNT
Max References | Shows the peak number of references (open handles) to this printer. | PERF_COUNTER_RAWCOUNT
Not Ready Errors | Shows the total number of printer not ready errors in a print queue since the last restart. | PERF_COUNTER_RAWCOUNT
Out of Paper Errors | Shows the total number of out of paper errors in a print queue since the last restart. | PERF_COUNTER_RAWCOUNT
References | Shows the current number of references to a print queue. A reference can be a user or a program that is connecting to a printer and opening a print queue. | PERF_COUNTER_RAWCOUNT
Total Jobs Printed | Shows the total number of jobs printed on a print queue since the last restart. | PERF_COUNTER_RAWCOUNT
Total Pages Printed | Shows the total number of pages printed through GDI on a print queue since the last restart. | PERF_COUNTER_RAWCOUNT


Process Object

The Process performance object consists of counters that monitor running application program and system processes. All the threads in a process share the same address space and have access to the same data.

Counter Name | Description | Counter Type
% Privileged Time | Shows the percentage of elapsed time that the threads of the process have spent executing code in privileged mode. When a Windows 2000 system service is called, the service often runs in Privileged Mode to gain access to system-private data. Such data is protected from access by threads executing in user mode. Calls to the system can be explicit or implicit, such as page faults or interrupts. Unlike some early operating systems, Windows 2000 uses process boundaries for subsystem protection in addition to the traditional protection of user and privileged modes. These subsystem processes provide additional protection. Therefore, some work done by Windows 2000 on behalf of your application might appear in other subsystem processes in addition to the privileged time in your process. | PERF_100NSEC_TIMER
% Processor Time | Shows the percentage of elapsed time that all of the threads of this process used the processor to execute instructions. An instruction is the basic unit of execution in a computer; a thread is the object that executes instructions; and a process is the object created when a program is run. Code executed to handle some hardware interrupts and trap conditions are included in this count. | PERF_100NSEC_TIMER
% User Time | Shows the percentage of elapsed time that this process's threads have spent executing code in user mode. Applications, environment subsystems, and integral subsystems execute in user mode. Code executing in user mode cannot damage the integrity of the Windows NT Executive, kernel, or and device drivers. Unlike some early operating systems, Windows 2000 uses process boundaries for subsystem protection in addition to the traditional protection of user and privileged modes. These subsystem processes provide additional protection. Therefore, some work done by Windows 2000 on behalf of your application might appear in other subsystem processes in addition to the privileged time in your process. | PERF_100NSEC_TIMER
Page Faults/sec | Shows the rate at which page faults by the threads executing in this process are occurring. A page fault occurs when a thread refers to a virtual memory page that is not in its working set in main memory. This does not cause the page to be fetched from disk if it is on the standby list and hence already in main memory, or if it is in use by another process with whom the page is shared. | PERF_COUNTER_COUNTER
Page File Bytes | Shows the current number of bytes that this process has used in the paging file(s). Paging files are used to store pages of memory used by the process that are not contained in other files. Paging files are shared by all processes, and lack of space in paging files can prevent other processes from allocating memory. | PERF_COUNTER_RAWCOUNT
Page File Bytes Peak | Shows the maximum number of bytes that this process has used in the paging file(s). Paging files are used to store pages of memory used by the process that are not contained in other files. Paging files are shared by all processes, and lack of space in paging files can prevent other processes from allocating memory. | PERF_COUNTER_RAWCOUNT
Priority Base | Shows the current base priority of this process. Threads within a process can raise and lower their own base priority relative to the process's base priority. | PERF_COUNTER_RAWCOUNT
Private Bytes | Shows the current number of bytes that this process has allocated that cannot be shared with other processes. | PERF_COUNTER_RAWCOUNT
Working Set | Shows the current number of bytes in the working set of this process. The working set is the set of memory pages touched recently by the threads in the process. If free memory in the computer is above a certain threshold, pages are left in the working set of a process even if they are not in use. When free memory falls below a certain threshold, pages are trimmed from working sets. If they are needed, they are then soft-faulted back into the working set before they leave main memory. | PERF_COUNTER_RAWCOUNT
Creating Process ID | Shows the identifier of the process that created the current process. Note that the creating process may have terminated since this process was created and so this value may no longer identify a running process. | PERF_COUNTER_RAWCOUNT
Elapsed Time | Shows the total elapsed time, in seconds, that this process has been running. | PERF_ELAPSED_TIME
Handle Count | Shows the total number of handles currently open by this process. This number is the equal to the sum of the handles currently open by each thread in this process. | PERF_COUNTER_RAWCOUNT
ID Process | Shows the unique identifier of this process. ID Process numbers are reused, so they only identify a process for the lifetime of that process. | PERF_COUNTER_RAWCOUNT
IO Data Bytes/sec | Shows the rate at which the process is reading and writing bytes in I/O operations. This counter counts all I/O activity generated by the process to include file, network and device I/O's. | PERF_COUNTER_BULK_COUNT
IO Data Operations/sec | Shows the rate at which the process is issuing read and write I/O operations. This counter counts all I/O activity generated by the process to include file, network and device I/O's. | PERF_COUNTER_BULK_COUNT
IO Other Bytes/sec | Shows the rate at which the process is issuing bytes to I/O operations that don't involve data such as control operations. This counter counts all I/O activity generated by the process to include file, network and device I/O's. | PERF_COUNTER_BULK_COUNT
IO Other Operations/sec | Shows the rate at which the process is issuing I/O operations that are neither a read or a write operation. An example of this type of operation would be a control function. This counter counts all I/O activity generated by the process to include file, network and device I/O's. | PERF_COUNTER_BULK_COUNT
IO Read Bytes/sec | Shows the rate at which the process is reading bytes from I/O operations. This counter counts all I/O activity generated by the process to include file, network and device I/O's. | PERF_COUNTER_BULK_COUNT
IO Read Operations/sec | Shows the rate at which the process is issuing read I/O operations. This counter counts all I/O activity generated by the process to include file, network and device I/O's. | PERF_COUNTER_BULK_COUNT
IO Write Bytes/sec | Shows the rate the process is writing bytes to I/O operations. This counter counts all I/O activity generated by the process to include file, network and device I/O's. | PERF_COUNTER_BULK_COUNT
IO Write Operations/sec | Shows the rate at which the process is issuing write I/O operations. This counter counts all I/O activity generated by the process to include file, network and device I/O's. | PERF_COUNTER_BULK_COUNT
Pool Nonpaged Bytes | Shows the number of bytes in the nonpaged pool, a system memory area where space is acquired by operating system components as they accomplish their appointed tasks. Nonpaged pool pages cannot be paged out to the paging file, but instead remain in main memory as long as they are allocated. | PERF_COUNTER_RAWCOUNT
Pool Paged Bytes | Shows the number of bytes in the Paged Pool, a system memory area where space is acquired by operating system components as they accomplish their appointed tasks. Paged Pool pages can be paged out to the paging file when not accessed by the system for sustained periods of time. | PERF_COUNTER_RAWCOUNT
Thread Count | Shows the number of threads currently active in this process. An instruction is the basic unit of execution in a processor, and a thread is the object that executes instructions. Every running process has at least one thread. | PERF_COUNTER_RAWCOUNT
Virtual Bytes | Shows the current size, in bytes, of the virtual address space that the process is using. Use of virtual address space does not necessarily imply corresponding use of either disk or main memory pages. Virtual space is finite, and by using too much, the process can limit its ability to load libraries. | PERF_COUNTER_RAWCOUNT
Virtual Bytes Peak | Shows the maximum size, in bytes, of virtual address space the process has used at any one time. Use of virtual address space does not necessarily imply corresponding use of either disk or main memory pages. However, virtual space is finite, and the process might limit its ability to load libraries by using too much. | PERF_COUNTER_RAWCOUNT
Working Set Peak | Shows the maximum size, in bytes, in the working set of this process at any point in time. The working set is the set of memory pages touched recently by the threads in the process. If free memory in the computer is above a certain threshold, pages are left in the working set of a process even if they are not in use. When free memory falls below a certain threshold, pages are trimmed from working sets. If they are needed, they are then soft-faulted back into the working set before they leave main memory. | PERF_COUNTER_RAWCOUNT

See also

  • Finding Processor Bottlenecks
  • Finding Memory Bottlenecks
  • Finding Bottlenecks on Multiprocessor Computers


Process Address Space Object

The Process Address Space performance object consists of counters that monitor memory allocation and use for a selected process.

This object contains "costly" counters for which data collection is typically either processor-intensive or memory-intensive. Costly counters cannot be selected with System Monitor but can be accessed using Showperf.exe and other tools in the Windows 2000 Resource Kit.

Counter Name | Description | Counter Type
Bytes Free | Shows the total unused virtual address space of this process. | PERF_COUNTER_RAWCOUNT
Bytes Image Free | Shows the amount of virtual address space that is not in use or reserved by images within this process. | PERF_COUNTER_RAWCOUNT
Bytes Image Reserved | Shows the sum of all virtual memory reserved by images run within this process. | PERF_COUNTER_RAWCOUNT
Bytes Reserved | Shows the total amount of virtual memory reserved for future use by this process. | PERF_COUNTER_RAWCOUNT
ID Process | Shows the unique identifier of this process. ID Process numbers are reused, so they only identify a process for the lifetime of that process. | PERF_COUNTER_RAWCOUNT
Image Space Exec Read Only | Shows the virtual address space in use by the images being executed by the process. This is the sum of all the address space with this protection allocated by images run by the selected process. Execute read-only memory is memory that can be executed as well as read. | PERF_COUNTER_RAWCOUNT
Image Space Exec Read/Write | Shows the virtual address space in use by the images being executed by the process. This is the sum of all the address space with this protection allocated by images run by the selected process. Execute read/write memory is memory that can be executed by programs as well as read and written and modified. | PERF_COUNTER_RAWCOUNT
Image Space Exec Write Copy | Shows the virtual address space in use by the images being executed by the process. This is the sum of all the address space with this protection allocated by images run by the selected process. Execute write copy memory is memory that can be executed by programs as well as read and written. This type of protection is used when memory needs to be shared between processes. If the sharing processes only read the memory, they all use the same memory. If a sharing process desires write access, then a copy of this memory is made for that process. | PERF_COUNTER_RAWCOUNT
Image Space Executable | Shows the virtual address space in use by the images being executed by the process. This is the sum of all the address space with this protection allocated by images run by the selected process. Executable memory is memory that can be executed by programs, but cannot be read or written. This type of protection is not supported by all processor types. | PERF_COUNTER_RAWCOUNT
Image Space No Access | Shows the virtual address space in use by the images being executed by the process. This is the sum of all the address space with this protection allocated by images run by the selected process. No access protection prevents a process from writing to or reading from these pages, and an access violation is generated if either is attempted. | PERF_COUNTER_RAWCOUNT
Image Space Read Only | Shows the virtual address space in use by the images being executed by the process. This is the sum of all the address space with this protection allocated by images run by the selected process. Read-only protection prevents the contents of these pages from being modified. Any attempt to write or modify these pages generates an access violation. | PERF_COUNTER_RAWCOUNT
Image Space Read/Write | Shows the virtual address space in use by the images being executed by the process. This is the sum of all the address space with this protection allocated by images run by the selected process. Read/write protection allows a process to read, modify, and write to these pages. | PERF_COUNTER_RAWCOUNT
Image Space Write Copy | Shows the virtual address space in use by the images being executed by the process. This is the sum of all the address space with this protection allocated by images run by the selected process. Write copy protection is used when memory is shared for reading but not for writing. When processes are reading this memory, they can share the same memory: however, when a sharing process wants to have read/write access to this shared memory, a copy of that memory is made for writing to. | PERF_COUNTER_RAWCOUNT
Mapped Space Exec Read Only | Shows virtual memory that has been mapped to a specific virtual address (or range of virtual addresses) in the process's virtual address space. | PERF_COUNTER_RAWCOUNT
Mapped Space Exec Read/Write | Shows virtual memory that has been mapped to a specific virtual address (or range of virtual addresses) in the process's virtual address space. | PERF_COUNTER_RAWCOUNT
Mapped Space Exec Write Copy | Shows virtual memory that has been mapped to a specific virtual address (or range of virtual addresses) in the process's virtual address space. | PERF_COUNTER_RAWCOUNT
Mapped Space Executable | Shows virtual memory that has been mapped to a specific virtual address (or range of virtual addresses) in the process's virtual address space. | PERF_COUNTER_RAWCOUNT
Mapped Space No Access | Shows virtual memory that has been mapped to a specific virtual address (or range of virtual addresses) in the process's virtual address space. | PERF_COUNTER_RAWCOUNT
Mapped Space Read Only | Shows virtual memory that has been mapped to a specific virtual address (or range of virtual addresses) in the process's virtual address space. | PERF_COUNTER_RAWCOUNT
Mapped Space Read/Write | Shows virtual memory that has been mapped to a specific virtual address (or range of virtual addresses) in the process's virtual address space. | PERF_COUNTER_RAWCOUNT
Mapped Space Write Copy | Shows virtual memory that has been mapped to a specific virtual address (or range of virtual addresses) in the process's virtual address space. | PERF_COUNTER_RAWCOUNT
Reserved Space Exec Read Only | Shows virtual memory that has been reserved for future use by a process, but has not been mapped or committed. | PERF_COUNTER_RAWCOUNT
Reserved Space Exec Read/Write | Shows virtual memory that has been reserved for future use by a process, but has not been mapped or committed. | PERF_COUNTER_RAWCOUNT
Reserved Space Exec Write Copy | Shows virtual memory that has been reserved for future use by a process, but has not been mapped or committed. | PERF_COUNTER_RAWCOUNT
Reserved Space Executable | Shows virtual memory that has been reserved for future use by a process, but has not been mapped or committed. | PERF_COUNTER_RAWCOUNT
Reserved Space No Access | Shows virtual memory that has been reserved for future use by a process, but has not been mapped or committed. | PERF_COUNTER_RAWCOUNT
Reserved Space Read Only | Shows virtual memory that has been reserved for future use by a process, but has not been mapped or committed. | PERF_COUNTER_RAWCOUNT
Reserved Space Read/Write | Shows virtual memory that has been reserved for future use by a process, but has not been mapped or committed. | PERF_COUNTER_RAWCOUNT
Reserved Space Write Copy | Shows virtual memory that has been reserved for future use by a process, but has not been mapped or committed. | PERF_COUNTER_RAWCOUNT
Unassigned Space Exec Read Only | Shows mapped and committed virtual memory in use by the process that is not attributable to any particular image being executed by that process. | PERF_COUNTER_RAWCOUNT
Unassigned Space Exec Read/Write | Shows mapped and committed virtual memory in use by the process that is not attributable to any particular image being executed by that process. | PERF_COUNTER_RAWCOUNT
Unassigned Space Exec Write Copy | Shows mapped and committed virtual memory in use by the process that is not attributable to any particular image being executed by that process. | PERF_COUNTER_RAWCOUNT
Unassigned Space Executable | Shows mapped and committed virtual memory in use by the process that is not attributable to any particular image being executed by that process.. | PERF_COUNTER_RAWCOUNT
Unassigned Space No Access | Shows mapped and committed virtual memory in use by the process that is not attributable to any particular image being executed by that process. | PERF_COUNTER_RAWCOUNT
Unassigned Space Read Only | Shows mapped and committed virtual memory in use by the process that is not attributable to any particular image being executed by that process. | PERF_COUNTER_RAWCOUNT
Unassigned Space Read/Write | Shows mapped and committed virtual memory in use by the process that is not attributable to any particular image being executed by that process. | PERF_COUNTER_RAWCOUNT
Unassigned Space Write Copy | Shows mapped and committed virtual memory in use by the process that is not attributable to any particular image being executed by that process. | PERF_COUNTER_RAWCOUNT

See also

  • Image Object
  • Thread Object
  • Thread Details Object
  • Process Object


Processor Object

The Processor performance object consists of counters that measure aspects of processor activity. The processor is the part of the computer that performs arithmetic and logical computations, initiates operations on peripherals, and runs the threads of processes. A computer can have multiple processors. The processor object represents each processor as an instance of the object.

Counter Name | Description | Counter Type
% DPC Time | Shows the percentage of time that the processor spent receiving and servicing deferred procedure calls (DPCs) during the sample interval. DPCs are interrupts that run at a lower priority than standard interrupts. % DPC Time is a component of % Privileged Time because DPCs are executed in privileged mode. They are counted separately and are not a component of the interrupt counters. | PERF_100NSEC_TIMER
% Interrupt Time | Shows the percentage of time that the processor spent receiving and servicing hardware interrupts during the sample interval. This value is an indirect indicator of the activity of devices that generate interrupts, such as the system clock, the mouse, disk drivers, data communication lines, network interface cards, and other peripheral devices. These devices normally interrupt the processor when they have completed a task or require attention. Normal thread execution is suspended during interrupts. Most system clocks interrupt the processor every 10 milliseconds, creating a background of interrupt activity. | PERF_100NSEC_TIMER
% Privileged Time | Shows the percentage of non-idle processor time spent in privileged mode. Privileged mode is a processing mode designed for operating system components and hardware-manipulating drivers. It allows direct access to hardware and all memory. The alternative, user mode, is a restricted processing mode designed for applications, environment subsystems, and integral subsystems. The operating system switches application threads to privileged mode to obtain operating system services. % Privileged Time includes time spent servicing interrupts and DPCs. A high rate of privileged time might be attributable to a large number of interrupts generated by a failing device. | PERF_100NSEC_TIMER
% Processor Time | Shows the percentage of time that the processor is executing application or operating system processes other than Idle. This counter is a primary indicator of processor activity. It is calculated by measuring the time that the processor spends executing the thread of the Idle process in each sample interval, and subtracting that value from 100%. Each processor has an Idle thread which consumes cycles when no other threads are ready to run. | PERF_100NSEC_TIMER_INV
% User Time | Shows the percentage of non-idle processor time that is spent in user mode. User mode is a restricted processing mode designed for applications, environment subsystems, and integral subsystems. The alternative, privileged mode, is designed for operating system components and allows direct access to hardware and all memory. The operating system switches application threads to privileged mode to obtain operating system services. | PERF_100NSEC_TIMER
APC Bypasses/sec | Shows the rate at which kernel asynchronous procedure call (APC) interrupts were avoided. | PERF_COUNTER_COUNTER
DPC Bypasses/sec | Shows the rate at which deferred procedure calls (DPCs) on all processors were avoided. DPCs are interrupts that run at a lower priority than standard interrupts. | PERF_COUNTER_COUNTER
DPC Rate | Shows the rate at which deferred procedure calls (DPCs) are added to the processor's DPC queue between the timer ticks of the processor clock. DPC objects are queued to this processor's DPC queue per clock tick. DPCs are interrupts that run at a lower priority than standard interrupts. Each processor has its own DPC queue. This counter measures the rates at which DPCs are added to the queue, not the number of DPCs in the queue. | PERF_COUNTER_RAWCOUNT
DPCs Queued/sec | Shows the overall rate at which deferred procedure calls (DPCs) are added to the processor's DPC queue. DPCs are interrupts that run at a lower priority than standard interrupts. Each processor has its own DPC queue. This counter measures the rate at which DPCs are added to the queue, not the number of DPCs in the queue. | PERF_COUNTER_COUNTER
Interrupts/sec | Shows the average number of hardware interrupts that the processor is receiving and servicing per second. It does not include DPCs, which are counted separately. This value is an indirect indicator of the activity of devices that generate interrupts, such as the system clock, the mouse, disk drivers, data communication lines, network interface cards and other peripheral devices. These devices normally interrupt the processor when they have completed a task or require attention. Normal thread execution is suspended during interrupts. Most system clocks interrupt the processor every 10 milliseconds, creating a background of interrupt activity. | PERF_COUNTER_COUNTER

See also

  • Finding Bottlenecks on Multiprocessor Computers
  • Finding Processor Bottlenecks


PSched Flow Object

The PSched Flow Object shows statistics from the packet scheduler, a feature of QoS Admission Control.

Counter Name | Description | Counter Type
Packets dropped | Shows the number of packets dropped by the packet scheduler. | PERF_COUNTER_RAWCOUNT
Packets scheduled | Shows the number of packets that were scheduled in some way (rather than just being directly sent to the underlying miniport). | PERF_COUNTER_RAWCOUNT
Packets transmitted | Shows the number of packets from this flow that have been sent. | PERF_COUNTER_RAWCOUNT
Average packets in shaper | Shows the average number of packets in the scheduler over the last sampling period. | PERF_COUNTER_RAWCOUNT
Max packets in shaper | Shows the maximum number of packets that have ever simultaneously been in the scheduler. | PERF_COUNTER_RAWCOUNT
Average packets in sequencer | Shows the average number of packets in the sequencer over the last sampling period. | PERF_COUNTER_RAWCOUNT
Max packets in sequencer | Shows the maximum number of packets that have ever simultaneously been in the sequencer. | PERF_COUNTER_RAWCOUNT
Bytes scheduled | Shows the number of bytes that were scheduled in some way (rather than just being directly sent to the underlying miniport). | PERF_COUNTER_RAWCOUNT
Bytes transmitted | Shows the number of bytes from this flow that have been sent. | PERF_COUNTER_RAWCOUNT
Bytes transmitted/sec | Shows the number of bytes per second from this flow that have been sent. | PERF_COUNTER_COUNTER
Bytes scheduled/sec | Shows the number of bytes per second from this flow that have been scheduled. | PERF_COUNTER_COUNTER
Packets transmitted/sec | Shows the number of packets per second from this flow that have been sent. | PERF_COUNTER_COUNTER
Packets scheduled/sec | Shows the number of packets per second from this flow that have been scheduled. | PERF_COUNTER_COUNTER
Packets dropped/sec | Shows the number of packets that were dropped by the packet scheduler from this flow per second. | PERF_COUNTER_COUNTER
Nonconforming packets scheduled | Shows the number of packets that have entered the packet scheduler at a rate which exceeded the flow parameters. | PERF_COUNTER_RAWCOUNT
Nonconforming packets scheduled/sec | Shows the rate at which nonconforming packets have entered the packet scheduler. | PERF_COUNTER_COUNTER
Nonconforming packets transmitted | Shows the number of packets that have been sent by the packet scheduler at a rate which exceeded the flow parameters. | PERF_COUNTER_RAWCOUNT
Nonconforming packets transmitted/sec | Shows the rate at which nonconforming packets have been sent by the packet scheduler. | PERF_COUNTER_COUNTER
Maximum Packets in netcard | Shows the maximum number of packets that have been queued in the network adapter by this flow. | PERF_COUNTER_RAWCOUNT
Average Packets in netcard | Shows the average number of packets that have been queued in the network adapter by this flow. | PERF_COUNTER_RAWCOUNT

See also PSched Pipe Object

© 1985-2000 Microsoft Corporation. All rights reserved.


PSched Pipe Object

The PSched Pipe Object performance object reports statistics from the packet scheduler, a feature of QoS Admission Control.

Counter Name | Description | Counter Type
Average packets in netcard | Shows the average number of packets in the network card over the last sampling period. | PERF_COUNTER_RAWCOUNT
Average packets in sequencer | Shows the average number of packets in the sequencer over the last sampling period. | PERF_COUNTER_RAWCOUNT
Average packets in shaper | Shows the average number of packets in the scheduler shaper over the last sampling period. | PERF_COUNTER_RAWCOUNT
Flow mods rejected | Shows the number of times a flow modification has been rejected. | PERF_COUNTER_RAWCOUNT
Flows closed | Shows the number of flows that have been closed. | PERF_COUNTER_RAWCOUNT
Flows modified | Shows the number of times that a flow has been modified. | PERF_COUNTER_RAWCOUNT
Flows opened | Shows the number of flows that were opened on this pipe (some of which may now be closed). | PERF_COUNTER_RAWCOUNT
Flows rejected | Shows the number of flow creations that were rejected. | PERF_COUNTER_RAWCOUNT
Max packets in netcard | Shows the maximum number of packets ever simultaneously in the network card. | PERF_COUNTER_RAWCOUNT
Max packets in sequencer | Shows the maximum number of packets that have ever simultaneously been in the sequencer. | PERF_COUNTER_RAWCOUNT
Max packets in shaper | Shows the maximum number of packets that have ever simultaneously been in the scheduler. | PERF_COUNTER_RAWCOUNT
Max simultaneous flows | Shows the maximum number of flows that have been simultaneously open on this pipe. | PERF_COUNTER_RAWCOUNT
Nonconforming packets scheduled | Shows the number of packets that have entered the packet scheduler at a rate which exceeded that packet's flow parameters. | PERF_COUNTER_RAWCOUNT
Nonconforming packets scheduled/sec | Shows the rate at which nonconforming packets have entered the packet scheduler. | PERF_COUNTER_COUNTER
Nonconforming packets transmitted | Shows the number of packets that have been sent by the packet scheduler at a rate which exceeded that packet's flow parameters. | PERF_COUNTER_RAWCOUNT
Nonconforming packets transmitted/sec | Shows the rate at which nonconforming packets have been sent by the packet scheduler. | PERF_COUNTER_COUNTER
Out of packets | Shows the number of times Packet Scheduler has been unable to allocate a packet. | PERF_COUNTER_RAWCOUNT

See also

Psched Flow object


RAS Port Object

The RAS Port performance object consists of counters that monitor individual Remote Access Service (RAS) ports of the RAS device on the system.

Counter Name | Description | Counter Type
Alignment Errors | Shows the total number of Alignment errors for this connection. Alignment errors occur when a received byte is different from the expected byte. | PERF_COUNTER_RAWCOUNT
Buffer Overrun Errors | Shows the total number of Buffer Overrun errors for this connection. Buffer Overrun errors occur when the software cannot handle the rate at which data is received. | PERF_COUNTER_RAWCOUNT
Bytes Received | Shows the total number of bytes received for this connection. | PERF_COUNTER_RAWCOUNT
Bytes Received/sec | Shows the number of bytes received per second. | PERF_COUNTER_COUNTER
Bytes Transmitted | Shows the total number of bytes transmitted for this connection. | PERF_COUNTER_RAWCOUNT
Bytes Transmitted/sec | Shows the number of bytes transmitted per second. | PERF_COUNTER_COUNTER
CRC Errors | Shows the total number of CRC errors for this connection. CRC errors occur when the frame received contains erroneous data. | PERF_COUNTER_RAWCOUNT
Frames Received | Shows the total number of data frames received for this connection. | PERF_COUNTER_RAWCOUNT
Frames Received/sec | Shows the number of frames received per second. | PERF_COUNTER_COUNTER
Frames Transmitted | Shows the total number of data frames transmitted for this connection. | PERF_COUNTER_RAWCOUNT
Frames Transmitted/sec | Shows the number of frames transmitted per second. | PERF_COUNTER_COUNTER
Percent Compression In | Shows the compression ratio for bytes being received. | PERF_COUNTER_RAWCOUNT
Percent Compression Out | Shows the compression ratio for bytes being transmitted. | PERF_COUNTER_RAWCOUNT
Serial Overrun Errors | Shows the total number of Serial Overrun errors for this connection. Serial Overrun errors occur when the hardware cannot handle the rate at which data is received. | PERF_COUNTER_RAWCOUNT
Timeout Errors | Shows the total number of Timeout errors for this connection. Timeout Errors occur when an expected packet is not received in time. | PERF_COUNTER_RAWCOUNT
Total Errors | Shows the total number of CRC, Timeout, Serial Overrun, Alignment, and Buffer Overrun errors for this connection. | PERF_COUNTER_RAWCOUNT
Total Errors/sec | Shows the total number of CRC, Timeout, Serial Overrun, Alignment, and Buffer Overrun errors per second. | PERF_COUNTER_COUNTER


RAS Total Object

The RAS Total performance object consists of counters that combine values for all ports of the Remote Access Service (RAS) device on the computer.

Counter Name | Description | Counter Type
Alignment Errors | Shows the total number of Alignment errors for this connection. Alignment Errors occur when a received byte is different from the expected byte. | PERF_COUNTER_RAWCOUNT
Buffer Overrun Errors | Shows the total number of Buffer Overrun errors for this connection. Buffer Overrun errors when the software cannot handle the rate at which data is received. | PERF_COUNTER_RAWCOUNT
Bytes Received | Shows the total number of bytes received for this connection. | PERF_COUNTER_RAWCOUNT
Bytes Received/sec | Shows the number of bytes received per second. | PERF_COUNTER_COUNTER
Bytes Transmitted | Shows the total number of bytes transmitted for this connection. | PERF_COUNTER_RAWCOUNT
Bytes Transmitted/sec | Shows the number of bytes transmitted per second. | PERF_COUNTER_COUNTER
CRC Errors | Shows the total number of CRC errors for this connection. CRC errors occur when the frame received contains erroneous data. | PERF_COUNTER_RAWCOUNT
Frames Received | Shows the total number of data frames received for this connection. | PERF_COUNTER_RAWCOUNT
Frames Received/sec | Shows the number of frames received per second. | PERF_COUNTER_COUNTER
Frames Transmitted | Shows the total number of data frames transmitted for this connection. | PERF_COUNTER_RAWCOUNT
Frames Transmitted/sec | Shows the number of frames transmitted per second. | PERF_COUNTER_COUNTER
Percent Compression In | Shows the compression ratio for bytes being received. | PERF_COUNTER_RAWCOUNT
Percent Compression Out | Shows the compression ratio for bytes being transmitted. | PERF_COUNTER_RAWCOUNT
Serial Overrun Errors | Shows the total number of Serial Overrun errors for this connection. Serial Overrun errors occur when the hardware cannot handle the rate at which data is received. | PERF_COUNTER_RAWCOUNT
Timeout Errors | Shows the total number of Timeout errors for this connection. Timeout errors occur when an expected packet is not received in time. | PERF_COUNTER_RAWCOUNT
Total Connections | Shows the total number of Remote Access connections. | PERF_COUNTER_RAWCOUNT
Total Errors | Shows the total number of CRC, Timeout, Serial Overrun, Alignment, and Buffer Overrun errors for this connection. | PERF_COUNTER_RAWCOUNT
Total Errors/sec | Shows the total number of CRC, Timeout, Serial Overrun, Alignment, and Buffer Overrun errors per second. | PERF_COUNTER_COUNTER


Redirector Object

The Redirector performance object consists of counters that monitor network connections originating at the local computer.

Counter Name | Description | Counter Type
Bytes Received/sec | Shows the rate of bytes coming in to the Redirector from the network. It includes all application data and network protocol information, such as packet headers. | PERF_COUNTER_BULK_COUNT
Bytes Total/sec | Shows the rate at which the Redirector is processing data bytes. This includes all application and file data in addition to protocol information, such as packet headers. | PERF_COUNTER_BULK_COUNT
Bytes Transmitted/sec | Shows the rate at which bytes are leaving the Redirector to the network. It includes all application data and network protocol information, such as packet headers and the like. | PERF_COUNTER_BULK_COUNT
Connects Core | Shows the number of connections that you have to servers running the original MS-Net SMB protocol, including MS-Net itself and Xenix and VAXs. | PERF_COUNTER_RAWCOUNT
Connects LAN Manager 2.0 | Shows the number of connections to LAN Manager 2.0 servers, including LMX servers. | PERF_COUNTER_RAWCOUNT
Connects LAN Manager 2.1 | Connects LAN Manager 2.1 shows the number of connections to LAN Manager 2.1 servers, including LMX servers. | PERF_COUNTER_RAWCOUNT
Connects Windows NT | Shows the number of connections to computers running Windows NT 4.0 or earlier or Windows 2000. | PERF_COUNTER_RAWCOUNT
Current Commands | Shows the number of requests to the Redirector that are currently queued for service. If this number is much larger than the number of network adapter cards installed in the computer, the network(s) and/or the server(s) being accessed are seriously bottlenecked. | PERF_COUNTER_RAWCOUNT
File Data Operations/sec | Shows the rate at which the Redirector is processing data operations. One operation should include many bytes, though each operation has overhead. You can determine the efficiency of this path by dividing the value of Bytes/sec by the value of this counter to determine the average number of bytes transferred per operation. | PERF_COUNTER_COUNTER
File Read Operations/sec | Shows the rate at which applications are asking the Redirector for data. Each call to a file system or similar application program interface (API) call counts as one operation. | PERF_COUNTER_COUNTER
File Write Operations/sec | Shows the rate at which applications are sending data to the Redirector. Each call to a file system or similar application program interface (API) call counts as one operation. | PERF_COUNTER_COUNTER
Network Errors/sec | Shows the rate at which serious unexpected errors are occurring. Such errors generally indicate that the Redirector and one or more servers are having serious communication difficulties. For example, a Server Manager Block (SMB) protocol error generates a network error. An entry is written in the system event log, and can provide details. | PERF_COUNTER_COUNTER
Packets Received/sec | Shows the rate at which the Redirector is receiving packets (also called Server Message Blocks or SMBs). Network transmissions are divided into packets. The average number of bytes received in a packet can be obtained by dividing the value of Bytes Received/sec by the value of this counter. Some packets received might not contain incoming data (for example, an acknowledgment of a write operation made by the Redirector would count as an incoming packet). | PERF_COUNTER_BULK_COUNT
Packets Transmitted/sec | Shows the rate at which the Redirector is sending packets (also called Server Message Blocks or SMBs). Network transmissions are divided into packets. The average number of bytes transmitted in a packet can be obtained by dividing the value of Bytes Transmitted/sec by the value of this counter. | PERF_COUNTER_BULK_COUNT
Packets/sec | Shows the rate at which the Redirector is processing data packets. One packet should includes many bytes, though each packet has protocol overhead. You can determine the efficiency of this path by dividing the value of Bytes/sec by the value of this counter to determine the average number of bytes transferred per packet. You can also divide the value of this counter by the value of Operations/sec to determine the average number of packets transferred per operation, another measure of efficiency. | PERF_COUNTER_BULK_COUNT
Read Bytes Cache/sec | Shows the rate at which applications are using the Redirector to access the file system. Some of these data requests are satisfied by retrieving the data from the cache. Requests that miss the cache cause a page fault. | PERF_COUNTER_BULK_COUNT
Read Bytes Network/sec | Shows the rate at which applications are reading data across the network. This occurs when data sought in the file system cache is not found there and must be retrieved from the network. Dividing this value by the value of Bytes Received/sec indicates the proportion of application data that is traveling across the network. | PERF_COUNTER_BULK_COUNT
Read Bytes Non-Paging/sec | Shows the number of bytes read by the Redirector in response to normal file requests by an application when they are redirected to come from another computer. In addition to file requests, this counter includes other methods of reading across the network, such as Named Pipes and Transactions. This counter counts only application data, not network protocol information. | PERF_COUNTER_BULK_COUNT
Read Bytes Paging/sec | Shows the rate at which the Redirector is attempting to read bytes in response to page faults. Page faults are caused by loading modules (such as programs and libraries), by a miss in the file system cache or by files directly mapped into the address space of applications. | PERF_COUNTER_BULK_COUNT
Read Operations Random/sec | Shows the rate at which, on a file-by-file basis, non-sequential read operations are made. If a read operation is made using a particular file handle, and then is followed by another read operation that is not the next contiguous byte, this counter is incremented by one. | PERF_COUNTER_COUNTER
Read Packets Small/sec | Shows the rate at which read operations of less than one-fourth of the server's negotiated buffer size are made by applications. If you have a high rate of small packet reads, it is possible that buffers are being used inefficiently. This counter is incremented once for each read. It does not count packets. | PERF_COUNTER_COUNTER
Read Packets/sec | Shows the rate at which read packets are being placed on the network. Each time a single packet is sent with a request to read data remotely, this counter is incremented by one. | PERF_COUNTER_COUNTER
Reads Denied/sec | Shows the rate at which the server is unable to accommodate requests for raw reads operations. When a read operation is much larger than the server's negotiated buffer size, the Redirector requests a Raw Read which, if granted, permits the transfer of the data without much protocol overhead on each packet. To accomplish this, the server must lock out other requests: if the server is too busy, the request is denied. | PERF_COUNTER_COUNTER
Reads Large/sec | Shows the rate at which read operations that are over two times the server's negotiated buffer size are made by applications. Too many read operations could place a strain on server resources. This counter is incremented once for each read. It does not count packets. | PERF_COUNTER_COUNTER
Server Disconnects | Shows the number of times that a server has disconnected your Redirector. | PERF_COUNTER_RAWCOUNT
Server Reconnects | Shows the number of times that your Redirector has had to reconnect to a server to complete a new active request. You can be disconnected by the server if you remain inactive for too long. Even if all remote files are closed, the Redirector keeps your connections intact locally for about ten minutes. Such inactive connections are called dormant connections. Reconnecting is expensive in time. | PERF_COUNTER_RAWCOUNT
Server Sessions | Shows the total number of security objects that are managed by the Redirector. For example, logging on to a server followed by a network access to the same server establishes one connection, but two sessions. | PERF_COUNTER_RAWCOUNT
Server Sessions Hung | Shows the number of active sessions that are timed out and unable to proceed due to a lack of response from the remote server. | PERF_COUNTER_RAWCOUNT
Write Bytes Cache/sec | Shows the rate at which applications on your computer are using the Redirector to write to the file system cache. The data might not leave your computer immediately; it can be retained in the cache for further modification before being written to the network, reducing network traffic. Each write of a byte to the cache is counted here. | PERF_COUNTER_BULK_COUNT
Write Bytes Network/sec | Shows the rate at which applications are writing data across the network. This occurs when the file system cache is bypassed, such as for named pipes or transactions, or else the cache writes the bytes to disk to make room for other data. Dividing the value of this counter by the value of Bytes Transmitted/sec indicates what proportion of application data is being written to the network. | PERF_COUNTER_BULK_COUNT
Write Bytes Non-Paging/sec | Shows the rate at which bytes are written by the Redirector in response to normal file outputs by an application when they are redirected to another computer. In addition to file requests, this counter includes other methods of writing across the network such as Named Pipes and Transactions. This counter only counts application data, and oes not network protocol information. | PERF_COUNTER_BULK_COUNT
Write Bytes Paging/sec | Shows the rate at which the Redirector is attempting to write bytes changed in the pages being used by applications. The program data changed by modules (such as programs and libraries) that were loaded over the network are 'paged out' when no longer needed. Other output pages come from the cache. | PERF_COUNTER_BULK_COUNT
Write Operations Random/sec | Shows the rate at which, on a file-by-file basis, non-sequential write operations are made. If a write operation is made using a particular file handle and then is followed by another write operation that is not the next contiguous byte, this counter is incremented by one. | PERF_COUNTER_COUNTER
Write Packets Small/sec | Shows the rate at which write operations are made by applications that are less than one-fourth of the server's negotiated buffer size. Too many write operations can indicate a waste of buffers on the server. This counter shows write operations, not packets, and is incremented once for each write operation. | PERF_COUNTER_COUNTER
Write Packets/sec | Shows the rate at which write operations are being sent to the network. Each time a single packet is sent with a request to write remote data, this counter is incremented by one. | PERF_COUNTER_COUNTER
Writes Denied/sec | Shows the rate at which the server is unable to accommodate requests for Raw Writes. When a write is much larger than the server's negotiated buffer size, the Redirector requests a Raw Write, which would permit the transfer of the data without a lot of protocol overhead on each packet. To accomplish this the server must lock out other requests: the request is denied if the server is really busy. | PERF_COUNTER_COUNTER
Writes Large/sec | Shows the rate at which write operations are made by applications that are over two times greater than the server's negotiated buffer size. Too many of these write operations could place a strain on server resources. This counter shows write operations, not packets, and is incremented once for each write operation. | PERF_COUNTER_COUNTER

See also

  • Server Object
  • Server Work Queues Object


Server Object

The Server performance object consists of counters that measure communication between the local computer and the network.

Counter Name | Description | Counter Type
Blocking Requests Rejected | Shows the number of times that the server has rejected blocking server message block requests (SMBs) due to insufficient count of free work items. This counter indicates whether the MaxWorkItem or MinFreeWorkItems server registry parameters might need tuning. | PERF_COUNTER_COUNTER
Bytes Received/sec | Shows the rate at which the server is receiving bytes from the network. This counter indicates how busy the server is. | PERF_COUNTER_BULK_COUNT
Bytes Total/sec | Shows the rate at which the server is transmitting bytes through the network. This value provides an overall indication of how busy the server is. | PERF_COUNTER_BULK_COUNT
Bytes Transmitted/sec | Shows the rate at which the server is sending bytes on the network. This counter indicates how busy the server is. | PERF_COUNTER_BULK_COUNT
Context Blocks Queued/sec | Shows the rate at which work context blocks had to be placed on the server's FSP queue to await server action. | PERF_COUNTER_COUNTER
Errors Access Permissions | Shows the number of times attempts to open files on behalf of clients have failed with the message STATUS_ACCESS_DENIED. This counter can indicate is someone is attempting to access random files to improperly access a file that was not properly protected. | PERF_COUNTER_RAWCOUNT
Errors Granted Access | Shows the number of times that attempts to access files successfully opened were denied. This counter can indicate attempts to access files without proper access authorization. | PERF_COUNTER_RAWCOUNT
Errors Logon | Shows the number of failed logon attempts to the server. This counter can indicate whether password guessing programs are being used to crack the security on the server. | PERF_COUNTER_RAWCOUNT
Errors System | Shows the number of times that an internal server error was detected. Errors can reflect problems with logon, security, memory allocation, disk operations, transport driver interface operations, communication (such as receipt of unimplemented or unrecognized SMBs), or I/O Request Packet stack size for the server. Many of these errors are also written to the System log and Security log in Event Viewer. The server can recover from most the errors displayed by this counter, but they are unexpected and should be reported to Microsoft Product Support Services. | PERF_COUNTER_RAWCOUNT
File Directory Searches | Shows the number of searches for files currently active in the server. This counter indicates current server activity. | PERF_COUNTER_RAWCOUNT
Files Open | Shows the number of files currently opened on the server. This counter indicates current server activity. | PERF_COUNTER_RAWCOUNT
Files Opened Total | Shows the number of successful attempts to open a file performed by the server of behalf of clients. This counter is useful in determining the amounts of file I/O and overhead for path-based operations, and for determining the effectiveness of open locks. | PERF_COUNTER_RAWCOUNT
Logon Total | Shows all interactive logon attempts, network logon attempts, service logon attempts, successful logon attempts, and failed logon attempts since the computer was last rebooted. | PERF_COUNTER_RAWCOUNT
Logon/sec | Shows the rate of all interactive logon attempts, network logon attempts, service logon attempts, successful logon attempts, and failed logon attempts. | PERF_COUNTER_COUNTER
Pool Nonpaged Bytes | Shows the size, in bytes, of nonpageable computer memory that the server is currently using. This value is useful for determining the values of the MaxNonpagedMemoryUsage entry in the Windows 2000 Registry. For more information, see the Technical Reference to the Windows 2000 Registry on the Windows 2000 Resource Kit companion CD. | PERF_COUNTER_RAWCOUNT
Pool Nonpaged Failures | Shows how many times allocations from the nonpaged pool have failed. This counter indicates that the computer's physical memory is too small. | PERF_COUNTER_COUNTER
Pool Nonpaged Peak | Shows the maximum size, in bytes, of the nonpaged pool the server has had in use at any one point. This counter indicates how much physical memory the computer should have. | PERF_COUNTER_RAWCOUNT
Pool Paged Bytes | Shows the size, in bytes, of pageable computer memory that the server is currently using. This counter can help in determining good values for the MaxPagedMemoryUsage registry entry. | PERF_COUNTER_RAWCOUNT
Pool Paged Failures | Shows how many times allocations from the paged pool have failed. This counter indicates that the computer's physical memory or page file are too small. | PERF_COUNTER_RAWCOUNT
Pool Paged Peak | Shows the maximum size, in bytes, of the paged pool that the server has allocated. This counter indicates the proper sizes of the page file(s) and physical memory. | PERF_COUNTER_RAWCOUNT
Server Sessions | Shows the number of sessions currently active in the server. This counter indicates current server activity. | PERF_COUNTER_RAWCOUNT
Sessions Errored Out | Shows the number of sessions that have been closed due to unexpected error conditions. This counter indicates how frequently network problems are causing dropped sessions on the server. The Sessions Errored Out counter reports auto-disconnects along with errored-out sessions. For a more accurate value for errored-out sessions, obtain the value for Sessions Timed Out and reduce the Sessions Errored Out value by that amount. | PERF_COUNTER_RAWCOUNT
Sessions Forced Off | Shows the number of sessions that have been forced to log off. This counter can indicate how many sessions were forced to log off due to logon time constraints. | PERF_COUNTER_RAWCOUNT
Sessions Logged Off | Shows the number of sessions that have terminated normally. This counter is useful in interpreting the statistics from Sessions Timed Out and Sessions Errored Out. | PERF_COUNTER_RAWCOUNT
Sessions Timed Out | Shows the number of sessions that have been closed because idle time exceeded the AutoDisconnect parameter for the server. This counter shows whether the AutoDisconnect setting is helping to conserve resources. | PERF_COUNTER_RAWCOUNT
Work Item Shortages | Shows the number of times STATUS_DATA_NOT_ACCEPTED was returned at receive indication time. This occurs when no work item is available or can be allocated to service the incoming request. This counter indicates whether the InitWorkItems or MaxWorkItems registry entries might need to be adjusted. | PERF_COUNTER_COUNTER


Server Work Queues Object

The Server Work Queues performance object consists of counters that monitor the length of queues and objects in the queues.

Counter Name | Description | Counter Type
Active Threads | Shows the number of threads currently working on a request from the server client for this CPU. The system keeps this number as low as possible to minimize unnecessary context switching. This is an instantaneous count for the CPU, not an average over time. | PERF_COUNTER_RAWCOUNT
Available Threads | Shows the number of server threads on this processor that are not currently working on requests from a client. The server dynamically adjusts the number of threads to maximize server performance. | PERF_COUNTER_RAWCOUNT
Available Work Items | Shows the instantaneous number of available work items for this CPU. A work item is typically a request from a client to the server; the server maintains a pool of available work items per CPU to speed processing. A sustained near-zero value indicates the need to increase the MinFreeWorkItems registry value for the server service. This value is always 0 in the Blocking Queue instance. | PERF_COUNTER_RAWCOUNT
Borrowed Work Items | Shows the number of free work items borrowed from another CPU because a CPU ran out of available work items in its pool. An increasing value of this running counter might indicate the need to increase the MaxWorkItems or MinFreeWorkItems registry values for the server service. This value is always 0 in the Blocking Queue instance. | PERF_COUNTER_RAWCOUNT
Bytes Received/sec | Shows the rate at which the server is receiving bytes from the network clients on this CPU. This value is a measure of how busy the server is. | PERF_COUNTER_BULK_COUNT
Bytes Sent/sec | Shows the rate at which the server is sending bytes to the network clients on this CPU. This value is a measure of how busy the server is. | PERF_COUNTER_BULK_COUNT
Bytes Transferred/sec | Shows the rate at which the server is exchanging bytes with the network clients on this CPU. This value is a measure of how busy the server is. | PERF_COUNTER_BULK_COUNT
Context Blocks Queued/sec | Shows the rate at which work context blocks have to be placed on the server's FSP queue to await server action. | PERF_COUNTER_COUNTER
Current Clients | Shows the current count of the clients being processed by this CPU. The server actively balances the client load across all of the CPU's in the system. This value is always 0 in the Blocking Queue instance. | PERF_COUNTER_RAWCOUNT
Queue Length | Shows the current length of the server work queue for this CPU. A sustained queue length greater than four might indicate processor congestion. This is an instantaneous count, not an average over time. | PERF_COUNTER_RAWCOUNT
Read Bytes/sec | Shows the rate at which the server is reading data from files for the clients on this CPU. This value is a measure of how busy the server is. | PERF_COUNTER_BULK_COUNT
Read Operations/sec | Shows the rate at which the server is performing file read operations for the clients on this CPU. This value is a measure of how busy the server is. This value is always 0 in the Blocking Queue instance. | PERF_COUNTER_BULK_COUNT
Total Bytes/sec | Shows the rate at which the server is reading and writing data to and from the files for the clients on this CPU. This value is a measure of how busy the server is. | PERF_COUNTER_BULK_COUNT
Total Operations/sec | Shows the rate at which the server is performing file read and write operations for the clients on this CPU. This value is a measure of how busy the server is. This value is always 0 in the Blocking Queue instance. | PERF_COUNTER_BULK_COUNT
Work Item Shortages | Shows the number of times that no work item was available or could be allocated to service the incoming request. A work item is the location where the server stores an SMB. The amount available fluctuate between a minimum and maximum value configured based on how the server is configured and the amount of memory on the computer. If work item shortages are occurring, it may be caused by an overloaded server. If the Work Item Shortages counter value is increasing, consider changing the registry value. HKEY_LOCAL_MACHINE\ SYSTEM\CurrentControlSet\ Services\LanmanServer\Parameters \Maxworkitems. Allowing this value to be achieved consistently initiates flow control, which hurts performance. This value is always 0 in the Blocking Queue instance. | PERF_COUNTER_RAWCOUNT
Write Bytes/sec | Shows the rate at which the server is writing data to files for the clients on this CPU. This value is a measure of how busy the server is. | PERF_COUNTER_BULK_COUNT
Write Operations/sec | Shows the rate at which the server is performing file write operations for the clients on this CPU. This value is a measure of how busy the server is. This value is always 0 in the Blocking Queue instance. | PERF_COUNTER_BULK_COUNT


Site Server ILS Service

The Site Server ILS Service performance object reports statistics about activity of Site Server Internet Locator Service (ILS). Site Server ILS service provides directory services on a server for IP multicast conferencing and H.323 telephony. Because the Site Server ILS service exposes an LDAP interface, the Site Server ILS Service object reports some LDAP data.

Counter Name | Description | Counter Type
ACL Failure | Shows the number of operations that failed because the client did not have sufficient privileges. | PERF_COUNTER_RAWCOUNT
Active Repl Server | Shows the number of active replication servers with dynamic databases replicating to each other. | PERF_COUNTER_RAWCOUNT
Authentication Failure | Shows the number of client authentication that have failed. | PERF_COUNTER_RAWCOUNT
Basic Binds | Shows the total number of binds that used clear-text authentication. | PERF_COUNTER_RAWCOUNT
Basic Binds per sec | Shows the rate at which clear-text authentications occurred in seconds. | PERF_COUNTER_COUNTER
Bytes Received | Shows the total number of bytes received. | PERF_COUNTER_RAWCOUNT
Bytes Received/sec | Shows the rate at which bytes have been received. | PERF_COUNTER_COUNTER
Bytes Sent | Shows the total number of bytes sent. | PERF_COUNTER_RAWCOUNT
Bytes Sent/sec | Shows the rate at which bytes are being sent. | PERF_COUNTER_COUNTER
Connection Attempted | Shows the total number of client connections attempted. | PERF_COUNTER_RAWCOUNT
Connection Current | Shows the number of users currently connected. | PERF_COUNTER_RAWCOUNT
Connection Max | Shows the maximum number of connections handled concurrently since the server was started. | PERF_COUNTER_RAWCOUNT
Connection Total | Shows the total number of client connections that were successfully connected. | PERF_COUNTER_RAWCOUNT
Current Dynamic Attrib | Shows the number of dynamic attributes allocated. | PERF_COUNTER_RAWCOUNT
Current Dynamic Object | Shows the number of dynamic objects allocated. | PERF_COUNTER_RAWCOUNT
DPA/NTLM Binds | Shows the total number of distributed password authentication (DPA) or NTLM style bindings. | PERF_COUNTER_RAWCOUNT
DPA/NTLM Binds per sec | Shows the rate at which DPA or NTLM style bindings occurred in seconds. | PERF_COUNTER_COUNTER
Dynamic Add | Shows the total number of LDAP add operations against the dynamic store. | PERF_COUNTER_RAWCOUNT
Dynamic Add per sec | Shows the rate at which LDAP add operations occurred against dynamic store of the database in seconds. | PERF_COUNTER_COUNTER
Dynamic Compare | Shows the total number of LDAP compare operations against the dynamic store of the database. | PERF_COUNTER_RAWCOUNT
Dynamic Compare per sec | Shows the rate at which LDAP compare operations occurred against the dynamic store of the database in seconds. | PERF_COUNTER_COUNTER
Dynamic Delete | Shows the total number of LDAP delete operations against the dynamic store of the database. | PERF_COUNTER_RAWCOUNT
Dynamic Delete per sec | Shows the rate at which LDAP delete operations occurred against the dynamic store of the database in seconds. | PERF_COUNTER_COUNTER
Dynamic Extended per sec | Shows the rate at which LDAP extended requests occurred against the dynamic store of the database in seconds. | PERF_COUNTER_COUNTER
Dynamic Extended Request | Shows the total number of LDAP extended requests against the dynamic store of the database. | PERF_COUNTER_RAWCOUNT
Dynamic Modify | Shows the total number of LDAP modify operations against the dynamic store of the database. | PERF_COUNTER_RAWCOUNT
Dynamic Modify DN | Shows the total number of LDAP modify distinguished name operations against the dynamic store of the database. | PERF_COUNTER_RAWCOUNT
Dynamic Modify DN per sec | Shows the rate at which LDAP modify distinguished name operations were performed against the dynamic store of the database in seconds. | PERF_COUNTER_COUNTER
Dynamic Modify per sec | Shows the rate at which LDAP modify operations occurred against the dynamic store of the database in seconds. | PERF_COUNTER_COUNTER
Dynamic Object Timeout | Shows the number of dynamic objects that have expired because the client did not refresh its time-to-live (TTL) value. | PERF_COUNTER_RAWCOUNT
Dynamic Search | Shows the total number of search operations against the dynamic store of the database. | PERF_COUNTER_RAWCOUNT
Dynamic Search per sec | Shows the rate at which search operations occurred against the dynamic store of the database in seconds. | PERF_COUNTER_COUNTER
Last LDAP Request Latency | Shows the amount of latency for the last LDAP operation. | PERF_COUNTER_RAWCOUNT
Out of Memory Warnings | Shows the number of out-of-memory errors that have occurred. | PERF_COUNTER_RAWCOUNT
Pending ldap request | Shows the outstanding LDAP request waiting to be performed. | PERF_COUNTER_RAWCOUNT
Repl Server | Shows the total number of configured servers with dynamic databases replicating to each other. | PERF_COUNTER_RAWCOUNT
Replication Add In | Shows the number of add operations replicated to the Active Directory database. | PERF_COUNTER_RAWCOUNT
Replication Add In per sec | Shows the rate at which add operations were replicated to the Active Directory database in seconds. | PERF_COUNTER_COUNTER
Replication Add Out | Shows the number of add operations replicated to other databases. | PERF_COUNTER_RAWCOUNT
Replication Add Out per sec | Shows the rate at which add operations were replicated to other databases in seconds. | PERF_COUNTER_COUNTER
Replication Commit | Shows the total number of replication messages received that were committed to the dynamic database. | PERF_COUNTER_RAWCOUNT
Replication Conflict | Shows the total number of replication messages received which required conflict resolution. | PERF_COUNTER_RAWCOUNT
Replication Del In | Shows the total number of delete operations replicated to the dynamic database. | PERF_COUNTER_RAWCOUNT
Replication Del In per sec | Shows the rate at which delete operations were replicated to other databases in seconds. | PERF_COUNTER_COUNTER
Replication Del Out | Shows the number of delete operations that were replicated to other databases. | PERF_COUNTER_RAWCOUNT
Replication Del Out per sec | Shows the rate at which delete operations were replicated to other databases in seconds. | PERF_COUNTER_COUNTER
Replication Error | Shows the total number of replication messages that were lost due to replication, network, or local server errors. | PERF_COUNTER_RAWCOUNT
Replication Modify DN In | Shows the number of modify distinguished name operations replicated to the dynamic database. | PERF_COUNTER_RAWCOUNT
Replication Modify DN In per sec | Shows the rate at which modify distinguished name operations were replicated to the dynamic database in seconds. | PERF_COUNTER_COUNTER
Replication Modify DN Out | Shows the number of modify distinguished name operations replicated to other databases. | PERF_COUNTER_RAWCOUNT
Replication Modify DN Out per sec | Shows the rate at which modify distinguished name operations were replicated to other databases in seconds. | PERF_COUNTER_COUNTER
Replication Modify In | Shows the number of modify operations replicated to the dynamic database. | PERF_COUNTER_RAWCOUNT
Replication Modify In per sec | Shows the rate at which modify operations were replicated to the dynamic database in seconds. | PERF_COUNTER_COUNTER
Replication Modify Out | Shows the number of modify operations replicated to other databases. | PERF_COUNTER_RAWCOUNT
Replication Modify Out per sec | Shows the rate at which modify operations were replicated to other databases in seconds. | PERF_COUNTER_COUNTER
Replication Queue Size | Shows the current total of replication queue sizes. | PERF_COUNTER_RAWCOUNT
Replication Reject | Shows the total number of replication messages received that were rejected by the dynamic database due to conflict errors or constraints. | PERF_COUNTER_RAWCOUNT
Replication Total In Op | Shows the total number of operations replicated to the dynamic database. | PERF_COUNTER_RAWCOUNT
Replication Total In Op per sec | Shows the rate at which the total number of operations were replicated to the dynamic database in seconds. | PERF_COUNTER_COUNTER
Replication Total Out Op | Shows the total number of operations replicated to other databases. | PERF_COUNTER_RAWCOUNT
Replication Total Out Op per sec | Shows the rate at which the total number of operations were replicated to other databases in seconds. | PERF_COUNTER_COUNTER
Request handled per sec | Shows the rate at which of LDAP requests were handled in seconds. | PERF_COUNTER_COUNTER
Static Add | Shows the total number of LDAP add operations performed against the static store of the database. | PERF_COUNTER_RAWCOUNT
Static Add per sec | Shows the rate at which LDAP add operations were performed against the static store of the database in seconds. | PERF_COUNTER_COUNTER
Static Compare | Shows the total number of LDAP compare operations against the static store of the database. | PERF_COUNTER_RAWCOUNT
Static Compare per sec | Shows the rate at which LDAP compare operations were performed against the static store of the database in seconds. | PERF_COUNTER_COUNTER
Static Delete | Shows the total number of LDAP delete operations performed against the static store of the database. | PERF_COUNTER_RAWCOUNT
Static Delete per sec | Shows the rate at which LDAP delete operations were performed against the static store of the database in seconds. | PERF_COUNTER_COUNTER
Static Extended per sec | Shows the rate at which LDAP extended requests were performed against the static store of the database in seconds. | PERF_COUNTER_COUNTER
Static Extended Request | Shows the total number of LDAP extended requests against the static store of the database. | PERF_COUNTER_RAWCOUNT
Static Modify | Shows the total number of LDAP modify operations performed against the static store of the database. | PERF_COUNTER_RAWCOUNT
Static Modify DN | Shows the total number of LDAP modify distinguished name operations against the static store of the database. | PERF_COUNTER_RAWCOUNT
Static Modify DN per sec | Shows the rate at which LDAP modify distinguished name operations were performed against the static store of the database in seconds. | PERF_COUNTER_COUNTER
Static Modify per sec | Shows the rate at which LDAP modify operations were performed against the static store of the database in seconds. | PERF_COUNTER_COUNTER
Static Search | Shows the total number of LDAP searches against the static store of the database. | PERF_COUNTER_RAWCOUNT
Static Search per sec | Shows the rate at which LDAP searches were performed against the static store of the database in seconds. | PERF_COUNTER_COUNTER
Total Request handled | Shows the total number of LDAP requests handled | PERF_COUNTER_RAWCOUNT
TTL Thread State | Shows a value indicating the state of the time-to-live thread, if this value is 1, the service is in the process of cleaning up expired objects. | PERF_COUNTER_RAWCOUNT
ULP Add App | Shows the total number of User Locator Protocol (ULP) applications added. | PERF_COUNTER_RAWCOUNT
ULP Add User | Shows the total number of ULP users added. | PERF_COUNTER_RAWCOUNT
ULP Del App | Shows the total number of ULP applications deleted. | PERF_COUNTER_RAWCOUNT
ULP Del User | Shows the total number of ULP users deleted. | PERF_COUNTER_RAWCOUNT
ULP Directory | Shows the total number of ULP directory operations performed. | PERF_COUNTER_RAWCOUNT
ULP directory per sec | Shows the rate at which ULP directory operations occurred in seconds. | PERF_COUNTER_COUNTER
ULP Resolve | Shows the total number of ULP resolves performed. | PERF_COUNTER_RAWCOUNT
ULP Resolve per sec | Shows the rate at which ULP resolves were performed in seconds. | PERF_COUNTER_COUNTER


SMTP Server Object

The SMTP Server performance object monitors message activity generated by the Simple Mail Transport Protocol (SMTP) service, that can be installed as part of Windows 2000 Server.

Counter Name | Description | Counter Type
% Recipients Local | Shows the percentage of recipients that will be delivered locally. | PERF_RAW_FRACTION
% Recipients Remote | Shows the percentage of recipients that will be delivered remotely. | PERF_RAW_FRACTION
Avg Recipients/msg Received | Shows the average number of recipients per inbound message received. | PERF_RAW_FRACTION
Avg Recipients/msg Sent | Shows the average number of recipients per outbound messages sent. | PERF_RAW_FRACTION
Avg Retries/msg Delivered | Shows the average number of retries per local delivery. | PERF_RAW_FRACTION
Avg Retries/msg Sent | Shows the average number of retries per outbound message sent. | PERF_RAW_FRACTION
Badmailed Messages (Bad Pickup File) | Shows the number of malformed pickup messages sent to the badmail directory (a default directory used for forwarding undeliverable messages). | PERF_COUNTER_RAWCOUNT
Badmailed Messages (General Failure) | Shows the number of messages sent to badmail for reasons not associated with a specific counter. | PERF_COUNTER_RAWCOUNT
Badmailed Messages (Hop Count Exceeded) | Shows the number of messages sent to badmail because they had exceeded the maximum hop count. | PERF_COUNTER_RAWCOUNT
Badmailed Messages (NDR of DSN) | Shows the number of Delivery Status Notifications sent to badmail becuase they could not be delivered. If a message is undeliverable, it is returned to the sender with a nondelivery report (NDR). | PERF_COUNTER_RAWCOUNT
Badmailed Messages (No Recipients) | Shows the number of messages sent to badmail because they had no recipients. | PERF_COUNTER_RAWCOUNT
Badmailed Messages (Triggered via Event) | Shows the number of messages sent to badmail at the request of a server event sink. An event sink is mechanism for notifying clients when events occur. | PERF_COUNTER_RAWCOUNT
Bytes Received Total | Shows the total number of bytes received by the server. | PERF_COUNTER_LARGE_RAWCOUNT
Bytes Received/sec | Shows the rate at which bytes are received by the server. | PERF_COUNTER_BULK_COUNT
Bytes Sent Total | Shows the total number of bytes sent by the server. | PERF_COUNTER_LARGE_RAWCOUNT
Bytes Sent/sec | Shows the rate that bytes are sent by the server. | PERF_COUNTER_BULK_COUNT
Bytes Total | Shows the total number of bytes sent and received by the server. | PERF_COUNTER_LARGE_RAWCOUNT
Bytes Total/sec | Shows the rate at which bytes are sent and received by the server. | PERF_COUNTER_BULK_COUNT
Cat: Address lookup completions | Shows the number of address lookup completions processed by the server. | PERF_COUNTER_RAWCOUNT
Cat: Address lookup completions/sec | Shows the rate of address lookup completions processed per second by the server. | PERF_COUNTER_COUNTER
Cat: Address lookups | Shows the number of Active Directory lookups for individual addresses by the server. | PERF_COUNTER_RAWCOUNT
Cat: Address lookups not found | Shows the number of address lookups that did not find any Active Directory object. | PERF_COUNTER_RAWCOUNT
Cat: Address lookups/sec | Shows the rate in seconds at which address lookups were dispatched to the Active Directory. | PERF_COUNTER_COUNTER
Cat: Categorizations completed | Shows the total number of messages to the categorizer that have completed categorization. Categorizing means looking up sender and recipient properties in the directory service, including doing distribution list expansion. | PERF_COUNTER_RAWCOUNT
Cat: Categorizations completed successfully | Shows the number of categorizations that were completed without any errors. | PERF_COUNTER_RAWCOUNT
Cat: Categorizations completed/sec | Shows the total number of messages submitted to categorizer that have finished categorization. | PERF_COUNTER_COUNTER
Cat: Categorizations failed (DS connection failure) | Shows the number of categorizations that failed due to a Active Directory connection failure. | PERF_COUNTER_RAWCOUNT
Cat: Categorizations failed (DS logon failure) | Shows the number of categorizations that failed due to a Active Directory logon failure. | PERF_COUNTER_RAWCOUNT
Cat: Categorizations failed (non-retryable error) | Shows the number of categorizations that failed with a hard error (one which doesn't allow attempts to retry the operation). | PERF_COUNTER_RAWCOUNT
Cat: Categorizations failed (Out Of Memory) | Shows the number of categorizations that failed due to lack of available memory. | PERF_COUNTER_RAWCOUNT
Cat: Categorizations failed (retryable error) | Shows the number of categorizations that failed with a error which allowed an attempt to retry the operation. | PERF_COUNTER_RAWCOUNT
Cat: Categorizations failed (sink retryable error) | Shows the number of categorizations that failed with a generic error which allowed an attempt to retry the operation. | PERF_COUNTER_RAWCOUNT
Cat: Categorizations in progress | Shows the number of categorizations in progress. | PERF_COUNTER_RAWCOUNT
Cat: LDAP bind failures | Shows the total number of LDAP bind failures. | PERF_COUNTER_RAWCOUNT
Cat: LDAP binds | Shows the total number of successfull LDAP binds performed. | PERF_COUNTER_RAWCOUNT
Cat: LDAP connection failures | Shows the total number of connection failures encountered for LDAP servers. | PERF_COUNTER_RAWCOUNT
Cat: LDAP connections | Shows the total number of LDAP connections opened. | PERF_COUNTER_RAWCOUNT
Cat: LDAP connections currently open | Shows the number of LDAP connections currently open. | PERF_COUNTER_RAWCOUNT
Cat: LDAP general completion failures | Shows the number of LDAP completions with a generic failure. | PERF_COUNTER_RAWCOUNT
Cat: LDAP paged search completion failures | Shows the number of LDAP paged searches that completed with a failure. | PERF_COUNTER_RAWCOUNT
Cat: LDAP paged search failures | Shows the number of failures to dispatch an asynchronous paged LDAP search. | PERF_COUNTER_RAWCOUNT
Cat: LDAP paged searches | Shows the number of LDAP paged searches successfully dispatched. | PERF_COUNTER_RAWCOUNT
Cat: LDAP paged searches completed | Shows the number of paged LDAP completions processed. | PERF_COUNTER_RAWCOUNT
Cat: LDAP search completion failures | Shows the number of LDAP searches that completed with a failure. | PERF_COUNTER_RAWCOUNT
Cat: LDAP search failures | Shows the number of failures to dispatch an asynchronous LDAP search. | PERF_COUNTER_RAWCOUNT
Cat: LDAP searches | Shows the number of LDAP searches successfully dispatched. | PERF_COUNTER_RAWCOUNT
Cat: LDAP searches abandoned | Shows the umber of LDAP searches abandoned. | PERF_COUNTER_RAWCOUNT
Cat: LDAP searches completed | Shows the number of LDAP search completions processed. | PERF_COUNTER_RAWCOUNT
Cat: LDAP searches completed/sec | Shows the number of LDAP search completions processed per second. | PERF_COUNTER_COUNTER
Cat: LDAP searches pending completion | Shows the number of LDAP searches pending asynchronous completion. | PERF_COUNTER_RAWCOUNT
Cat: LDAP searches/sec | Shows the number of LDAP searches successfully dispatched/sec. | PERF_COUNTER_COUNTER
Cat: mailmsg duplicate collisions | Shows the number of times a duplicate recipient address was detected by mail message or the categorizer.. | PERF_COUNTER_RAWCOUNT
Cat: Messages aborted | Shows the number of messages marked to be aborted by the categorizer. | PERF_COUNTER_RAWCOUNT
Cat: Messages bifurcated | Shows the number of new messages created by the categorizer (bifurcation). | PERF_COUNTER_RAWCOUNT
Cat: Messages Categorized | Shows the number of messages categorizer has submitted to queuing. | PERF_COUNTER_RAWCOUNT
Cat: Messages submitted | Shows the total number of messages submitted to the categorizer. | PERF_COUNTER_RAWCOUNT
Cat: Messages submitted/sec | Shows the rate at which messages are being submitted to the categorizer. | PERF_COUNTER_COUNTER
Cat: Recipients after categorization | Shows the number of mail message recipients submitted from the categorizer to queuing. | PERF_COUNTER_RAWCOUNT
Cat: Recipients before categorization | Shows the number of mail message recipients submitted to the categorizer. | PERF_COUNTER_RAWCOUNT
Cat: Recipients in categorization | Shows the number of recipients the categorizer is currently processing. | PERF_COUNTER_RAWCOUNT
Cat: Recipients NDRd (ambiguous address) | Shows the number of recipients with addresses that match multiple Active Directory objects. | PERF_COUNTER_RAWCOUNT
Cat: Recipients NDRd (forwarding loop) | Shows the number of recipients NDRd by the categorizer due to a forwarding loop detection. | PERF_COUNTER_RAWCOUNT
Cat: Recipients NDRd (illegal address) | Shows the number of recipients with illegal addresses detected by the categorizer. | PERF_COUNTER_RAWCOUNT
Cat: Recipients NDRd (sink recip errors) | Shows the number of recipients NDRd by the categorizer due to a generic recipient failure. | PERF_COUNTER_RAWCOUNT
Cat: Recipients NDRd (unresolved) | Shows the number of unresolved recipients (local addresses not found). | PERF_COUNTER_RAWCOUNT
Cat: Recipients NDRd by categorizer | Shows the number of recipients set to be NDRd by the categorizer. | PERF_COUNTER_RAWCOUNT
Cat: Senders unresolved | Shows the number of senders not found in the Active Directory. | PERF_COUNTER_RAWCOUNT
Cat: Senders with ambiguous addresses | Shows the number of senders with addresses that match multiple Active Directory objects. | PERF_COUNTER_RAWCOUNT
Categorizer Queue Length | Shows the number of messages in the categorizer queue. | PERF_COUNTER_RAWCOUNT
Connection Errors/sec | Shows the number of connection errors occurring per second. | PERF_COUNTER_COUNTER
Current Messages in Local Delivery | Shows the number of messages that are currently being processed by a server event sink for local delivery. | PERF_COUNTER_RAWCOUNT
Directory Drops Total | Shows the total number of messages placed in a drop directory. | PERF_COUNTER_RAWCOUNT
Directory Drops/sec | Shows the number of messages placed in a drop directory per second. | PERF_COUNTER_COUNTER
DNS Queries Total | Shows the total number of DNS lookups. | PERF_COUNTER_RAWCOUNT
DNS Queries/sec | Shows the rate of DNS lookups. | PERF_COUNTER_COUNTER
ETRN Messages Total | Shows the total number of extended turn (ETRN) messages received by the server. | PERF_COUNTER_RAWCOUNT
ETRN Messages/sec | Shows the number of ETRN messages per second. | PERF_COUNTER_COUNTER
Inbound Connections Current | Shows the total number of connections currently inbound. | PERF_COUNTER_RAWCOUNT
Inbound Connections Total | Shows the total number of inbound connections received. | PERF_COUNTER_RAWCOUNT
Local Queue Length | Shows the number of messages in the local queue. | PERF_COUNTER_RAWCOUNT
Local Retry Queue Length | Shows the number of messages in the local retry queue. | PERF_COUNTER_RAWCOUNT
Message Bytes Received Total | Shows the total number of bytes received in messages. | PERF_COUNTER_LARGE_RAWCOUNT
Message Bytes Received/sec | Shows the rate that bytes are received in messages. | PERF_COUNTER_BULK_COUNT
Message Bytes Sent Total | Shows the total number of bytes sent in messages. | PERF_COUNTER_LARGE_RAWCOUNT
Message Bytes Sent/sec | Shows the rate that bytes are sent in messages. | PERF_COUNTER_BULK_COUNT
Message Bytes Total | Shows the total number of bytes sent and received in messages. | PERF_COUNTER_LARGE_RAWCOUNT
Message Bytes Total/sec | Shows the rate that bytes are sent and received in messages. | PERF_COUNTER_BULK_COUNT
Message Delivery Retries | Shows the total number of local deliveries that were retried. | PERF_COUNTER_RAWCOUNT
Message Received/sec | Shows the rate that inbound messages are being received. | PERF_COUNTER_COUNTER
Message Send Retries | Shows the total number of outbound message sends that were retried. | PERF_COUNTER_RAWCOUNT
Messages Currently Undeliverable | Shows the number of messages that have been reported as currently undeliverable by routing. | PERF_COUNTER_RAWCOUNT
Messages Delivered Total | Shows the total number of messages delivered to local mailboxes. | PERF_COUNTER_RAWCOUNT
Messages Delivered/sec | Shows the rate that messages are delivered to local mailboxes. | PERF_COUNTER_COUNTER
Messages Pending Routing | Shows the number of messages that have been categorized but not routed. | PERF_COUNTER_RAWCOUNT
Messages Received Total | Shows the total number of inbound messages accepted. | PERF_COUNTER_RAWCOUNT
Messages Refused for Address Objects | Shows the total number of messages refused due to no address objects. | PERF_COUNTER_RAWCOUNT
Messages Refused for Mail Objects | Shows the total number of messages refused due to no mail objects. | PERF_COUNTER_RAWCOUNT
Messages Refused for Size | Shows the total number of messages rejected because they were too big. | PERF_COUNTER_RAWCOUNT
Messages Sent Total | Shows the total number of outbound messages sent. | PERF_COUNTER_RAWCOUNT
Messages Sent/sec | Shows the rate that outbound messages are being sent. | PERF_COUNTER_COUNTER
NDRs Generated | Shows the number of non-delivery reports that have been generated. | PERF_COUNTER_RAWCOUNT
Number of MailFiles Open | Shows the number of handles to open mail files. | PERF_COUNTER_RAWCOUNT
Number of QueueFiles Open | Shows the number of handles to open queue files. | PERF_COUNTER_RAWCOUNT
Outbound Connections Current | Shows the number of connections currently outbound. | PERF_COUNTER_RAWCOUNT
Outbound Connections Refused | Shows the number of outbound connection attempts refused by remote sites. | PERF_COUNTER_RAWCOUNT
Outbound Connections Total | Shows the total number of outbound connections attempted. | PERF_COUNTER_RAWCOUNT
Pickup Directory Messages Retrieved Total | Shows the total number of messages retrieved from the mail pick-up directory. | PERF_COUNTER_RAWCOUNT
Pickup Directory Messages Retrieved/sec | Shows the rate that messages are being retrieved from the mail pick-up directory. | PERF_COUNTER_COUNTER
Remote Queue Length | Shows the number of messages in the remote queue. | PERF_COUNTER_RAWCOUNT
Remote Retry Queue Length | Shows the number of messages in the retry queue for remote delivery. | PERF_COUNTER_RAWCOUNT
Routing Table Lookups Total | Shows the total number of routing table lookups. | PERF_COUNTER_RAWCOUNT
Routing Table Lookups/sec | Shows the number of routing table lookups per second. | PERF_COUNTER_COUNTER
Total Connection Errors | Shows the total number of connection errors. | PERF_COUNTER_RAWCOUNT
Total DSN Failures | Shows the total number of failed DSN generation attempts. | PERF_COUNTER_RAWCOUNT
Total messages submitted | Shows the total messages submitted to queuing for delivery. | PERF_COUNTER_RAWCOUNT


SMTP NTFS Store Driver Object

The SMTP NTFS Store Driver performance object counters describe activity of the Exchange NTFS store driver, which is responsible for message transport to and from the message store.

Counter Name | Description | Counter Type
Messages allocated | Shows the total number of messages allocated. | PERF_COUNTER_RAWCOUNT
Messages deleted | Shows the total number of messages deleted. | PERF_COUNTER_RAWCOUNT
Messages enumerated | Shows the total number of messages enumerated during startup. | PERF_COUNTER_RAWCOUNT
Messages in the queue directory | Shows the current number of messages in the queue directory. | PERF_COUNTER_RAWCOUNT
Open message bodies | Shows the current number of open message bodies. | PERF_COUNTER_RAWCOUNT
Open message streams | Shows the current number of open message streams. | PERF_COUNTER_RAWCOUNT


System Object

The System performance object consists of counters that apply to more than one component of the computer. Percentage counters by default do not show values above 100 percent. See "Overview of Performance Monitoring" in the Windows 2000 Server Resource Kit Server Operations Guide for instructions about changing this default in the registry.

Counter Name | Description | Counter Type
%Registry Quota In Use | Shows the percentage of the Total Registry Quota Allowed that is currently being used by the system. | PERF_RAW_FRACTION
Alignment Fixups/sec | Shows the rate of alignment faults fixed by the system. | PERF_COUNTER_COUNTER
Context Switches/sec | Shows the combined rate at which all processors on the computer are switched from one thread to another. Context switches occur when a running thread voluntarily relinquishes the processor, is preempted by a higher priority, ready thread, or switches between user-mode and privileged (kernel) mode to use an Executive or subsystem service. It is the sum of the values of Thread\Thread: Context Switches/sec for each thread running on all processors on the computer and is measured in numbers of switches. There are context switch counters on the System and Thread objects. | PERF_COUNTER_COUNTER
Exception Dispatches/sec | Shows the rate at which exceptions are dispatched by the system. | PERF_COUNTER_COUNTER
File Control Bytes/sec | File Control Bytes/sec shows the overall rate at which bytes are transferred for all file system operations that are neither read nor write operations, including file system control requests and requests for information about device characteristics or status. It is measured in numbers of bytes per second. | PERF_COUNTER_BULK_COUNT
File Control Operations/sec | Shows the combined rate of file system operations that are neither read nor write operations, such as file system control requests and requests for information about device characteristics or status. This is the inverse of System\System: File Data Operations/sec and is measured in numbers of operations. | PERF_COUNTER_COUNTER
File Data Operations/sec | Shows the combined rate of read and write operations on all logical disks on the computer. This is the inverse of System\System: File Control Operations/sec. | PERF_COUNTER_COUNTER
File Read Bytes/sec | Shows the overall rate at which bytes are read to satisfy file system read requests to all devices on the computer, including read operations from the file system cache. It is measured in numbers of bytes per second. | PERF_COUNTER_BULK_COUNT
File Read Operations/sec | Shows the combined rate of file system read requests to all devices on the computer, including requests to read from the file system cache. It is measured in numbers of read operations per second. | PERF_COUNTER_COUNTER
File Write Bytes/sec | Shows the overall rate at which bytes are written to satisfy file system write requests to all devices on the computer, including write operations to the file system cache. It is measured in numbers of bytes per second. | PERF_COUNTER_BULK_COUNT
File Write Operations/sec | Shows the combined rate of file system write requests to all devices on the computer, including requests to write to data in the file system cache. It is measured in numbers of write operations per second. | PERF_COUNTER_COUNTER
Floating Emulations/sec | Shows the rate of floating emulations performed by the system. | PERF_COUNTER_COUNTER
Processor Queue Length | Shows the number of threads in the processor queue. There is a single queue for processor time even on computers with multiple processors. Therefore, you may need to divide this value by the number of processors servicing the workload. Unlike the disk counters, this counter shows ready threads only, not threads that are running. A sustained processor queue of greater than two threads generally indicates processor congestion. | PERF_COUNTER_RAWCOUNT
System Calls/sec | Shows the combined rate of calls to Windows 2000 system service routines by all processes running on the computer. These routines perform all of the basic scheduling and synchronization of activities on the computer, and provide access to nongraphic devices, memory management, and name space management. | PERF_COUNTER_COUNTER
System Up Time | Shows the total time, in seconds, that the computer has been operational since it was last started. | PERF_ELAPSED_TIME
Total APC Bypasses/sec | Shows the combined rate at which kernel asynchronous procedure call (APC) interrupts on all processors were avoided. This value is the sum of the values of Processor\Processor: APC Bypasses/sec for each processor, divided by the number of processors. | PERF_COUNTER_COUNTER
Total DPC Bypasses/sec | Shows the combined rate at which deferred procedure calls (DPCs) on all processors were avoided. DPCs are interrupts that run at a lower priority than standard interrupts. This value is the sum of the values of Processor\Processor: DPC Bypasses/sec for each processor, divided by the number of processors. | PERF_COUNTER_COUNTER
Total DPC Rate | Shows the combined rate at which DPCs are added to the DPC queues of all processors between timer ticks of each processor's system clock. Each processor has its own DPC queue clock on the processor. This counter measures the rate at which DPCs are added to the queue, not the number of DPCs in the queue. This value is the sum of the values of Processor\Processor: DPC Rate for each processor on the computer, divided by the number of processors. | PERF_COUNTER_RAWCOUNT
Total DPCs Queued/sec | Shows the combined rate at which DPC are added to the DPC queue of all processors on the computer. This counter measures the rates at which DPCs are added to the queue, not the number of DPCs in the queue. This value is the sum of the values of Processor\Processor: DPCs Queued/sec for each processor on the computer, divided by the number of processors. | PERF_COUNTER_COUNTER
Total Interrupts/sec | Shows the combined rate of hardware interrupts received and processed by all processors on the computer. This value is the sum of the values of Processor\Processor: Interrupts/sec for each processor, divided by the number of processors. It does not include DPCs, which are counted separately. This value is an indirect indicator of the activity of devices that generate interrupts, such as the system timer, the mouse, disk drivers, data communication lines, network interface cards and other peripheral devices. These devices normally interrupt the processor when they have completed a task or require attention. Normal thread execution is suspended during interrupts. Most system clocks interrupt the processor every 10 milliseconds, creating a background of interrupt activity. | PERF_COUNTER_COUNTER


Telephony Object

The Telephony performance object provides counters for monitoring telephone-communication activity on a computer running Windows 2000.

Counter Name | Description | Counter Type
Active Lines | Shows the number of telephone or integrated services digital network (ISDN) lines serviced by the computer that are currently in use by applications. | PERF_COUNTER_RAWCOUNT
Active Telephones | Shows the number of telephone devices (telephones or speaker phones) that are currently in use by applications. | PERF_COUNTER_RAWCOUNT
Client Apps | Shows the number of applications that are currently using telephony services. | PERF_COUNTER_RAWCOUNT
Current Incoming Calls | Shows the number of incoming calls that are currently being serviced by the computer. | PERF_COUNTER_RAWCOUNT
Current Outgoing Calls | Shows the number of outgoing calls that are currently being serviced by the computer. | PERF_COUNTER_RAWCOUNT
Incoming Calls/sec | Shows the rate at which incoming calls are answered by this computer. | PERF_COUNTER_COUNTER
Lines | Shows the number of telephone lines serviced by the computer. | PERF_COUNTER_RAWCOUNT
Outgoing Calls/sec | Shows the rate at which outgoing calls are made by this computer. | PERF_COUNTER_COUNTER
Telephone Devices | Shows the number of telephone devices (telephones or speaker phones) serviced by the computer. | PERF_COUNTER_RAWCOUNT


TCP Object

The TCP performance object consists of counters that measure the rates at which TCP segments are sent and received using the Transmission Control Protocol (TCP). It includes counters that monitor the number of TCP connections in each TCP connection state.

Counter Name | Description | Counter Type
Connection Failures | Shows the number of times that TCP connections have made a direct transition to the CLOSED state from the SYN-SENT or SYN-RCVD state, plus the number of times TCP connections have made a direct transition to the LISTEN state from the SYN-RCVD state. | PERF_COUNTER_RAWCOUNT
Connections Active | Shows the number of times TCP connections have made a direct transition to the SYN-SENT state from the CLOSED state. | PERF_COUNTER_RAWCOUNT
Connections Established | Shows the number of TCP connections for which the current state is either ESTABLISHED or CLOSE-WAIT. | PERF_COUNTER_RAWCOUNT
Connections Passive | Shows the number of times that TCP connections have made a direct transition to the SYN-RCVD state from the LISTEN state. | PERF_COUNTER_RAWCOUNT
Connections Reset | Shows the number of times that TCP connections have made a direct transition to the CLOSED state from either the ESTABLISHED or CLOSE-WAIT state. | PERF_COUNTER_RAWCOUNT
Segments/sec | Shows the rate at which TCP segments are sent or received using the TCP protocol. Segments/sec is the sum of the values of TCP\ Segments Received/sec and TCP\Segments Sent/sec. | PERF_COUNTER_COUNTER
Segments Received/sec | Shows the rate at which segments are received, including those received in error. This count includes segments received on currently established connections. Segments Received/sec is a subset of TCP: Segments/sec. | PERF_COUNTER_COUNTER
Segments Retransmitted/sec | Shows the rate at which segments containing one or more previously transmitted bytes are retransmitted. | PERF_COUNTER_COUNTER
Segments Sent/sec | Shows the rate at which segments are sent. This value includes those on current connections, but excludes those containing only retransmitted bytes. Segments Sent/sec is a subset of TCP\ Segments/sec. | PERF_COUNTER_COUNTER


Terminal Services Session Object

The Terminal Services Session object provides per-session resource statistics such as packet and frame transmission data, errors, and cache activity for Terminal Services.

In addition, the Terminal Services Session object reports session-specific activity using the following Process object counters:

  • % Privileged Time
  • % Processor Time
  • % User Time
  • Handle Count
  • Page Faults/sec
  • Page File Bytes
  • Page File Bytes Peak
  • Pool Nonpaged Bytes
  • Pool Paged Bytes
  • Private Bytes
  • Thread Count
  • Virtual Bytes
  • Virtual Bytes Peak
  • Working Set
  • Working Set Peak
Counter Name | Description | Counter Type
Input Async Frame Error | Shows the number of input async framing errors. These can be caused by a noisy transmission line. Using a smaller packet size may help in some cases. | PERF_COUNTER_RAWCOUNT
Input Async Overflow | Shows the number of input async overflow errors. These can be caused by a lack of buffer space available on the host. | PERF_COUNTER_RAWCOUNT
Input Async Overrun | Shows the number of input async overrun errors. These can be caused by the baud rate being faster than the computer can handle, or if a serial line that does not use a 16550 universal asynchronous receiver-transmitter (UART) is used. Overruns can also occur if too many high speed serial lines are active at one time for the processor's power. | PERF_COUNTER_RAWCOUNT
Input Async Parity Error | Shows the number of input async parity errors. These can be caused by a noisy transmission line | PERF_COUNTER_RAWCOUNT
Input Bytes | Shows the number of bytes input on this session that includes all protocol overhead. | PERF_COUNTER_COUNTER
Input Compress Flushes | Shows the number of input compression dictionary flushes. When the data can not be compressed, the compression dictionary is flushed so that newer data has a better chance of being compressed. Some causes of data not compressing include transferring compressed files over Client Drive Mapping. | PERF_COUNTER_RAWCOUNT
Input Compressed Bytes | Shows the number of bytes input after compression. This number compared with the Total Bytes input is the compression ratio. | PERF_COUNTER_COUNTER
Input Compression Ratio | Shows the compression ratio of the server input data stream. | PERF_COUNTER_RAWCOUNT
Input Errors | Shows the number of input errors of all types. Some example input errors are lost acknowledgments (ACKs), badly formed packets, and so forth. | PERF_COUNTER_RAWCOUNT
Input Frames | Shows the number of frames input on this Session. | PERF_COUNTER_COUNTER
Input Timeouts | Shows the total number of timeouts on the communication line as seen from the client side of the connection. These are typically the result of a noisy line. On some high latency networks, this could be the result of the protocol timeout being too short. Increasing the protocol timeout on these types of lines will improve performance by reducing needless retransmissions. | PERF_COUNTER_RAWCOUNT
Input Transport Errors | Input Transport Errors shows the number of Terminal Services transport-level errors on input. | PERF_COUNTER_RAWCOUNT
Input WaitForOutBuf | Shows the number of times that a wait for an available send buffer was done by the protocols on the client side of the connection. | PERF_COUNTER_RAWCOUNT
Input WdBytes | Shows the number of bytes input on this session after all protocol overhead has been removed. | PERF_COUNTER_COUNTER
Input WdFrames | Shows the number of frames input after any additional protocol added frames have been removed. | PERF_COUNTER_COUNTER
Output Async Frame Error | Shows the number of output async framing errors. This could be caused by a hardware or line problem. | PERF_COUNTER_RAWCOUNT
Output Async Overflow | Shows the number of output async overflow errors. | PERF_COUNTER_RAWCOUNT
Output Async Overrun | Shows the number of output async overrun errors. | PERF_COUNTER_RAWCOUNT
Output Async Parity Error | Shows the number of output async parity errors. These can be caused by a hardware or line problem. | PERF_COUNTER_RAWCOUNT
Output Bytes | Shows the number of bytes output on this Session that includes all protocol overhead. | PERF_COUNTER_COUNTER
Output Compress Flushes | Shows the number of output compression dictionary flushes. When the data can not be compressed, the compression dictionary is flushed so that newer data has a better chance of being compressed. Some causes of data not compressing includes transferring compressed files over Client Drive Mapping. | PERF_COUNTER_RAWCOUNT
Output Compressed Bytes | Shows the number of bytes output after compression. This number compared with the Total Bytes output is the compression ratio. | PERF_COUNTER_COUNTER
Output Compression Ratio | Shows the compression ratio of the server output data stream. | PERF_COUNTER_RAWCOUNT
Output Errors | Shows the number of output errors of all types. Some example output errors are lost ACKs, badly formed packets, and so on. | PERF_COUNTER_RAWCOUNT
Output Frames | Shows the number of framesoutput on this session. | PERF_COUNTER_COUNTER
Output Timeouts | Shows the total number of timeouts on the communication line from the host side of the connection. These are typically the result of a noisy line. | PERF_COUNTER_RAWCOUNT
Output Transport Errors | Shows the number of Terminal Services transport-level errors on output. | PERF_COUNTER_RAWCOUNT
Output WaitForOutBuf | Shows the number of times that a wait for an available send buffer was done by the protocol on the server side of the connection. | PERF_COUNTER_COUNTER
Output WdBytes | Shows the number of bytes output on this session after all protocol overhead has been removed. | PERF_COUNTER_COUNTER
Output WdFrames | Shows the number of frames output before any additional protocol frames have been added. | PERF_COUNTER_COUNTER
Protocol Bitmap Cache Hit Ratio | Shows the hit ratio in the protocol bitmap cache. A higher hit ratio means better performance since data transmissions are reduced. Low hit ratios are due to the screen updating with new information that is either not re-used, or is flushed out of the client cache. | PERF_COUNTER_RAWCOUNT
Protocol Bitmap Cache Hits | Shows the number of hits in the protocol bitmap cache. | PERF_COUNTER_RAWCOUNT
Protocol Bitmap Cache Reads | Shows the number of references to the protocol bitmap cache. | PERF_COUNTER_RAWCOUNT
Protocol Brush Cache Hit Ratio | Shows the hit ratio in the protocol brush cache. | PERF_COUNTER_RAWCOUNT
Protocol Brush Cache Hits | Shows the number of hits in the protocol brush cache. | PERF_COUNTER_RAWCOUNT
Protocol Brush Cache Reads | Shows the number of references to the protocol brush cache. | PERF_COUNTER_RAWCOUNT
Protocol Glyph Cache Hit Ratio | Shows the hit ratio in the protocol glyph cache. | PERF_COUNTER_RAWCOUNT
Protocol Glyph Cache Hits | Shows the number of hits in the protocol glyph cache. | PERF_COUNTER_RAWCOUNT
Protocol Glyph Cache Reads | Shows the number of references to the protocol glyph cache. | PERF_COUNTER_RAWCOUNT
Protocol Save Screen Bitmap Cache Hit Ratio | Shows the hit ratio in the protocol save screen bitmap cache. | PERF_COUNTER_RAWCOUNT
Protocol Save Screen Bitmap Cache Hits | Shows the number of hits in the protocol save screen bitmap cache. | PERF_COUNTER_RAWCOUNT
Protocol Save Screen Bitmap Cache Reads | Shows the number of references to the protocol save screen bitmap cache. | PERF_COUNTER_RAWCOUNT
Total Async Frame Error | Shows the total number of async framing errors. | PERF_COUNTER_RAWCOUNT
Total Async Overflow | Shows the total number of async overflow errors. | PERF_COUNTER_RAWCOUNT
Total Async Overrun | Shows the total number of async overrun errors. | PERF_COUNTER_RAWCOUNT
Total Async Parity Error | Shows the total number of async parity errors. | PERF_COUNTER_RAWCOUNT
Total Bytes | Shows the total number of bytes on this Session that includes all protocol overhead. | PERF_COUNTER_COUNTER
Total Compress Flushes | Shows the total number of compression dictionary flushes. | PERF_COUNTER_RAWCOUNT
Total Compressed Bytes | Shows the total number of bytes after compression. This number compared with the total bytes is the compression ratio. | PERF_COUNTER_COUNTER
Total Compression Ratio | Shows the total compression ratio of the server data stream. | PERF_COUNTER_RAWCOUNT
Total Errors | Total Errors shows the total number of errors of all types. | PERF_COUNTER_RAWCOUNT
Total Frames | Shows the total number of frames on this Session. | PERF_COUNTER_COUNTER
Total Protocol Cache Hit Ratio | Shows the overall hit ratio for all protocol caches. | PERF_COUNTER_RAWCOUNT
Total Protocol Cache Hits | Shows the total hits in all protocol caches. The protocol caches Windows objects that are likely to be re-used to avoid having to resend them on the transmission line. Example objects are Windows icons and brushes. Hits in the cache represent objects that did not need to be resent. | PERF_COUNTER_RAWCOUNT
Total Protocol Cache Reads | Shows the total references to all protocol caches. | PERF_COUNTER_RAWCOUNT
Total Timeouts | Shows the total number of timeouts on the communication line from both the host and client sides of the connection. | PERF_COUNTER_RAWCOUNT
Total Transport Errors | Shows the total number of Terminal Services transport-level errors. | PERF_COUNTER_RAWCOUNT
Total WaitForOutBuf | Shows the number of times that a wait for an available send buffer was done by the protocols on both the server and client sides of the connection. | PERF_COUNTER_COUNTER
Total WdBytes | Shows the total number of bytes on this Session after all protocol overhead has been removed. | PERF_COUNTER_COUNTER
Total WdFrames | Shows the total number of frames input and output before any additional protocol frames have been added. | PERF_COUNTER_COUNTER


Thread Object

The Thread performance object consists of counters that measure aspects of thread behavior. A thread is the basic object that executes instructions on a processor. All running processes have at least one thread.

Counter Name | Description | Counter Type
% Privileged Time | Shows the percentage of elapsed time that this thread has spent executing code in privileged mode. When a Windows 2000 system service is called, the service often runs in privileged mode to gain access to system-private data. Such data is protected from access by threads executing in user mode. Calls to the system can be explicit or implicit, such as page faults or interrupts. Unlike some early operating systems, Windows 2000 uses process boundaries for subsystem protection in addition to the traditional protection of user and privileged modes. These subsystem processes provide additional protection. Therefore, some work done by Windows 2000 on behalf of your application might appear in other subsystem processes in addition to the privileged time in your process. | PERF_100NSEC_TIMER
% Processor Time | Shows the percentage of elapsed time that this thread used the processor to execute instructions. An instruction is the basic unit of execution in a processor, and a thread is the object that executes instructions. Code executed to handle certain hardware interrupts and trap conditions are included in this count. | PERF_100NSEC_TIMER
% User Time | Shows the percentage of elapsed time that this thread has spent executing code in user mode. Applications, environment subsystems, and integral subsystems execute in user mode. Code executing in user mode cannot damage the integrity of the Windows 2000 Executive, Kernel, and device drivers. Unlike some early operating systems, Windows 2000 uses process boundaries for subsystem protection in addition to the traditional protection of user and privileged modes. These subsystem processes provide additional protection. Therefore, some work done by Windows 2000 on behalf of your application might appear in other subsystem processes in addition to the privileged time in your process. | PERF_100NSEC_TIMER
Context Switches/sec | Shows the rate at which switches from one thread to another occur. Thread switches can occur either inside of a single process or across processes. A thread switch can be caused either by one thread asking another for information, or by a thread being preempted by another, higher priority thread becoming ready to run. Unlike some early operating systems, Windows 2000 uses process boundaries for subsystem protection in addition to the traditional protection of user and privileged modes. These subsystem processes provide additional protection. Therefore, some work done by Windows 2000 on behalf of an application might appear in other subsystem processes in addition to the privileged time in the application. Switching to the subsystem process causes one context switch in the application thread. Switching back causes another context switch in the subsystem thread. | PERF_COUNTER_COUNTER
Elapsed Time | Shows the total elapsed time, in seconds, that this thread has been running. | PERF_ELAPSED_TIME
ID Process | Shows the unique identifier of this process. ID Process numbers are reused, so they only identify a process for the lifetime of that process. | PERF_COUNTER_RAWCOUNT
ID Thread | Shows the unique identifier of this thread. ID Thread numbers are reused, so they only identify a thread for the lifetime of that thread. | PERF_COUNTER_RAWCOUNT
Priority Base | Shows the current base priority of this thread. The system can raise the thread's dynamic priority above the base priority if the thread is handling user input, or lower it toward the base priority if the thread becomes compute bound. | PERF_COUNTER_RAWCOUNT
Priority Current | Shows the current dynamic priority of this thread. The system can raise the thread's dynamic priority above the base priority if the thread is handling user input, or lower it toward the base priority if the thread becomes compute bound. | PERF_COUNTER_RAWCOUNT
Start Address | Shows the starting virtual address for this thread. | PERF_COUNTER_RAWCOUNT
Thread State | Shows the current state of the thread. Valid values are: 0Initialized 1Ready 2Running 3Standby 4 Terminated 5 Waiting 6 Transition 7 Unknown | PERF_COUNTER_RAWCOUNT
Thread Wait Reason | Shows the reason that a thread was in the Wait state and is only applicable when the thread is in the Wait state as reflected by Thread\Thread State (value is 5). Values are as follows: 0Waiting for a component of the Windows NT Executive 1Waiting for a page to be freed 2Waiting for a page to be mapped or copied 3Waiting for space to be allocated in the paged or nonpaged pool 4Waiting for an Execution Delay to be resolved 5Suspended 6Waiting for a user request 7Waiting for a component of the Windows NT Executive 8Waiting for a page to be freed 9Waiting for a page to be mapped or copied 10Waiting for space to be allocated in the paged or nonpaged pool 11Waiting for an Execution Delay to be resolved 12Suspended 13Waiting for a user request 14Waiting for an event pair high 15Waiting for an event pair low 16Waiting for an LPC Receive notice 17Waiting for an LPC Reply notice 18Waiting for virtual memory to be allocated 19Waiting for a page to be written to disk 20+(Reserved for future use) | PERF_COUNTER_RAWCOUNT

See also

  • Finding Bottlenecks on Multiprocessor Computers
  • Finding Processor Bottlenecks


Thread Details Object

The Thread Details performance object consists of counters that measure aspects of thread behavior that are difficult or time-consuming to collect. These counters are distinguished from those in the Thread performance object by their high overhead.

This object contains costly counters, counters for which data collection is typically either processor-intensive or memory-intensive. Costly counters cannot be selected with System Monitor but can be accessed using Showperf.exe and other tools in the Windows 2000 Resource Kit.

Counter Name | Description | Counter Type
User PC | Shows the current user program counter for this thread. This is also known as an instruction pointer in CPU registers. | PERF_COUNTER_RAWCOUNT

See also

  • Thread Object
  • Process Address Space Object
  • Image Object


UDP Object

The UDP performance object consists of counters that measure the rates at which User Data Protocol (UDP) datagrams are sent and received using the UDP. It includes counters that monitor UDP errors.

Counter Name | Description | Counter Type
Datagrams No Port/sec | Shows the rate at which UDP datagrams are received which there was no application at the destination port. | PERF_COUNTER_COUNTER
Datagrams Received Errors | Shows the number of received UDP datagrams that could not be delivered for reasons other than the lack of an application at the destination port. | PERF_COUNTER_RAWCOUNT
Datagrams Received/sec | Shows the rate at which UDP datagrams are delivered to UDP users. | PERF_COUNTER_COUNTER
Datagrams Sent/sec | Shows the rate at which UDP datagrams are sent from the computer. | PERF_COUNTER_COUNTER
Datagrams/sec | Shows the rate at which UDP datagrams are transferred by the computer. | PERF_COUNTER_COUNTER


Web Service Object

The Web Service object counters installed with Internet Information Service monitor file transfer rates, bandwidth usage, and connection rates.

You can view performance data for all instances of this object (using the _Total instance) or for specific instances, such as the Default Web Site or Administration Web Site instances.

In addition to these counters, counters supplied by the Internet Information Services Global performance object combine data for the Web service with the performance data they report for IIS as a whole. For more information, see the Internet Information Services Global object.

Counter Name | Description | Counter Type
Anonymous Users/sec | Shows the rate at which users are making anonymous connections using the Web service. | PERF_COUNTER_COUNTER
Bytes Received/sec | Showsthe rate that data bytes are received by the Web service. | PERF_COUNTER_BULK_COUNT
Bytes Sent/sec | Shows the rate that data bytes are sent by the Web service. | PERF_COUNTER_BULK_COUNT
Bytes Total/sec | Shows the sum of Bytes Sent/sec and Bytes Received/sec. This is the total rate of bytes transferred by the Web service. | PERF_COUNTER_BULK_COUNT
CGI Requests/sec | Shows the rate at which Common Gateway Interface (CGI) requests are simultaneously being processed by the Web service. | PERF_COUNTER_COUNTER
Connection Attempts/sec | Shows the rate at which connections using the Web service are being attempted. | PERF_COUNTER_COUNTER
Copy Requests/sec | Shows the rate at which HTTP requests using the COPY method are made. Copy requests are used for copying files and directories | PERF_COUNTER_COUNTER
Current Anonymous Users | Shows the number of users who currently have an anonymous connection using the Web service. | PERF_COUNTER_RAWCOUNT
Current Blocked Async I/O Requests | Shows current requests that are temporarily blocked due to bandwidth throttling settings. | PERF_COUNTER_RAWCOUNT
Current CAL count for authenticated users | Shows the current count of licenses used simultaneously by the Web service for authenticated connections. | PERF_COUNTER_RAWCOUNT
Current CAL count for SSL connections | Shows the current count of licenses used simultaneously by the Web service for SSL connections. | PERF_COUNTER_RAWCOUNT
Current CGI Requests | Shows the current number of CGI requests that are simultaneously being processed by the Web service. | PERF_COUNTER_RAWCOUNT
Current Connections | Shows the current number of connections established with the Web service. | PERF_COUNTER_RAWCOUNT
Current ISAPI Extension Requests | Shows the current number of Extension requests that are simultaneously being processed by the Web service. | PERF_COUNTER_RAWCOUNT
Current NonAnonymous Users | Shows the number of users who currently have a non-anonymous connection using the Web service. | PERF_COUNTER_RAWCOUNT
Delete Requests/sec | Shows the rate at which HTTP requests using the DELETE method are made. Delete requests are generally used for file removals. | PERF_COUNTER_COUNTER
Files Received/sec | Shows the rate at which files are received by the Web service. | PERF_COUNTER_COUNTER
Files Sent/sec | Shows the rate at which files are sent by the Web service. | PERF_COUNTER_COUNTER
Files/sec | Shows the rate at which files are transferred, that is, sent and received by the Web service. | PERF_COUNTER_COUNTER
Get Requests/sec | Shows the rate at which HTTP requests using the GET method are made. Get requests are generally used for basic file retrievals or image maps, though they can be used with forms. | PERF_COUNTER_COUNTER
Head Requests/sec | Shows the rate at which HTTP requests using the HEAD method are made. Head requests generally indicate a client is querying the state of a document they already have to see if it needs to be refreshed. | PERF_COUNTER_COUNTER
ISAPI Extension Requests/sec | Shows the rate at which ISAPI Extension requests are simultaneously being processed by the Web service. | PERF_COUNTER_COUNTER
Lock Requests/sec | Shows the rate at which HTTP requests using the LOCK method are made. Lock requests are used to lock a file for one user so that only that user can modify the file. | PERF_COUNTER_COUNTER
Locked Errors/sec | Shows the rate of errors due to requests that couldn't be satisfied by the server because the requested document was locked. These are generally reported as an HTTP 423 error code to the client. | PERF_COUNTER_COUNTER
Logon Attempts/sec | Shows the rate at which logons using the Web service are being attempted. | PERF_COUNTER_COUNTER
Maximum Anonymous Users | Shows the maximum number of users who established concurrent anonymous connections using the Web service (counted since service startup). | PERF_COUNTER_RAWCOUNT
Maximum CAL count for authenticated users | Shows the maximum count of licenses used simultaneously by the Web service for authenticated connections. | PERF_COUNTER_RAWCOUNT
Maximum CAL count for SSL connections | Shows the maximum count of licenses used simultaneously by the Web service for SSL connections. | PERF_COUNTER_RAWCOUNT
Maximum CGI Requests | Shows the maximum number of CGI requests simultaneously processed by the Web service. | PERF_COUNTER_RAWCOUNT
Maximum Connections | Shows the maximum number of simultaneous connections established with the Web service. | PERF_COUNTER_RAWCOUNT
Maximum ISAPI Extension Requests | Shows the maximum number of Extension requests simultaneously processed by the Web service. | PERF_COUNTER_RAWCOUNT
Maximum NonAnonymous Users | Shows the maximum number of users who established concurrent non-anonymous connections using the Web service (counted since service startup). | PERF_COUNTER_RAWCOUNT
Measured Async I/O Bandwidth Usage | Shows the measured bandwidth of asynchronous I/O averaged over a minute. | PERF_COUNTER_RAWCOUNT
Mkcol Requests/sec | Shows the rate at which HTTP requests using the MKCOL method are made. MKCOL requests are used to create directories on the server. | PERF_COUNTER_COUNTER
Move Requests/sec | Shows the rate at which HTTP requests using the MOVE method are made. MOVE requests are used for moving files and directories. | PERF_COUNTER_COUNTER
NonAnonymous Users/sec | Shows the rate at which users are making nonanonymous connections using the Web service. | PERF_COUNTER_COUNTER
Not Found Errors/sec | Shows the rate of errors due to requests that couldn't be satisfied by the server because the requested document could not be found. These are generally reported as an HTTP 404 error code to the client. | PERF_COUNTER_COUNTER
Options Requests/sec | Shows the rate at which HTTP requests using the OPTIONS method are made. | PERF_COUNTER_COUNTER
Other Request Methods/sec | Shows the rate at which HTTP requests are made that do not use the OPTIONS, GET, HEAD, POST, PUT, DELETE, TRACE, MOVE, COPY, MKCOL, PROPFIND, PROPPATCH, MS-SEARCH, LOCK or UNLOCK methods. These may include LINK or other methods supported by gateway applications. | PERF_COUNTER_COUNTER
Post Requests/sec | Shows the rate at which HTTP requests using the POST method are made. POST requests are generally used for forms or gateway requests. | PERF_COUNTER_COUNTER
Propfind Requests/sec | Shows the rate at which HTTP requests using the PROPFIND method are made. PROPFIND requests retrieve property values on files and directories. | PERF_COUNTER_COUNTER
Proppatch Requests/sec | Shows the rate at which HTTP requests using the PROPPATCH method are made. PROPPATCH requests set property values on files and directories. | PERF_COUNTER_COUNTER
Put Requests/sec | Shows the rate at which HTTP requests using the PUT method are made. The PUT method requests that the document sent to the server be stored under the supplied Internet address. | PERF_COUNTER_COUNTER
Search Requests/sec | Shows the rate at which HTTP requests using the MS-SEARCH method are made. Search requests are used to query the server to find resources that match a set of conditions provided by the client. | PERF_COUNTER_COUNTER
Total Allowed Async I/O Requests | Shows the total number of requests allowed by bandwidth throttling settings (counted since service startup). When bandwidth throttling is defined, the number of allowed user requests is restricted. | PERF_COUNTER_RAWCOUNT
Total Anonymous Users | Shows the total number of users who established an anonymous connection with the Web service (counted since service startup). | PERF_COUNTER_RAWCOUNT
Total Blocked Async I/O Requests | Shows the number of total requests temporarily blocked due to bandwidth throttling settings (counted since service startup). | PERF_COUNTER_RAWCOUNT
Total CGI Requests | Shows the total number of CGI requests. CGI requests are custom gateway executables (.exe) the administrator can install to add forms processing or other dynamic data sources. CGI requests initiate a process on the server which can be a large drain on server resources. The count is the total since service startup. | PERF_COUNTER_RAWCOUNT
Total Connection Attempts (all instances) | Shows the number of connections that have been attempted using the Web service (counted since service startup). This counter is for all instances listed. | PERF_COUNTER_RAWCOUNT
Total Copy Requests | Shows the number of HTTP requests using the COPY method (counted since service startup). COPY requests are used for copying files and directories | PERF_COUNTER_RAWCOUNT
Total count of failed CAL requests for authenticated users | Shows the number of HTTP requests that failed due to a license being unavailable for an authenticated user. The count is the total since service startup. | PERF_COUNTER_RAWCOUNT
Total count of failed CAL requests for SSL connections | Shows the total count of HTTP requests that failed due to a license being unavailable for SSL connections. | PERF_COUNTER_RAWCOUNT
Total Delete Requests | Shows the number of HTTP requests using the DELETE method (counted since service startup). Delete requests are generally used for file removals. | PERF_COUNTER_RAWCOUNT
Total Files Received | Shows the total number of files received by the Web service (counted since service startup). | PERF_COUNTER_RAWCOUNT
Total Files Sent | Shows the total number of files sent by the Web service (counted since service startup). | PERF_COUNTER_RAWCOUNT
Total Files Transferred | Shows the sum of Files Sent and Files Received. This is the total number of files transferred by the Web service (counted since service startup). | PERF_COUNTER_RAWCOUNT
Total Get Requests | Shows the number of HTTP requests using the GET method (counted since service startup). GET requests are generally used for basic file retrievals or image maps, though they can be used with forms. | PERF_COUNTER_RAWCOUNT
Total Head Requests | Shows the number of HTTP requests using the HEAD method (counted since service startup). Head requests generally indicate a client is querying the state of a document they already have to see if it needs to be refreshed. | PERF_COUNTER_RAWCOUNT
Total ISAPI Extension Requests | Shows the total number of ISAPI Extension Requests. ISAPI Extension Requests are custom gateway Dynamic Link Libraries (.dll) the administrator can install to add forms processing or other dynamic data sources. Unlike CGI requests, ISAPI requests are simple calls to a DLL library routine, thus they are better suited to high performance gateway applications. The count is the total since service startup. | PERF_COUNTER_RAWCOUNT
Total Lock Requests | Shows the number of HTTP requests using the LOCK method (counted since service startup). LOCK requests are used to lock a file for one user so that only that user can modify the file. | PERF_COUNTER_RAWCOUNT
Total Locked Errors | Shows the number of requests that couldn't be satisfied by the server because the requested was locked. These are generally reported as an HTTP 423 error code to the client. The count is the total since service startup. | PERF_COUNTER_RAWCOUNT
Total Logon Attempts | Shows the number of logons that have been attempted using the Web service (counted since service startup). | PERF_COUNTER_RAWCOUNT
Total Method Requests | Shows the number of all HTTP requests (counted since service startup). | PERF_COUNTER_RAWCOUNT
Total Method Requests/sec | Shows the rate at which all HTTP requests are made. | PERF_COUNTER_COUNTER
Total Mkcol Requests | Shows the number of HTTP requests using the MKCOL method (counted since service startup). MKCOL requests are used to create directories on the server. | PERF_COUNTER_RAWCOUNT
Total Move Requests | Shows the number of HTTP requests using the MOVE method (counted since service startup). MOVE requests are used for moving files and directories. | PERF_COUNTER_RAWCOUNT
Total NonAnonymous Users | Shows the total number of users who established a non-anonymous connection with the Web service (counted since service startup). | PERF_COUNTER_RAWCOUNT
Total Not Found Errors | Shows the number of requests that couldn't be satisfied by the server because the requested document could not be found. These are generally reported as an HTTP 404 error code to the client. The count is the total since service startup. | PERF_COUNTER_RAWCOUNT
Total Options Requests | Shows the number of HTTP requests using the OPTIONS method (counted since service startup). | PERF_COUNTER_RAWCOUNT
Total Other Request Methods | Shows the number of HTTP requests that are not OPTIONS, GET, HEAD, POST, PUT, DELETE, TRACE, MOVE, COPY, MKCOL, PROPFIND, PROPPATCH, MS-SEARCH, LOCK or UNLOCK methods (counted since service startup). These may include LINK or other methods supported by gateway applications. | PERF_COUNTER_RAWCOUNT
Total Post Requests | Shows the number of HTTP requests using the POST method (counted since service startup). POST requests are generally used for forms or gateway requests. | PERF_COUNTER_RAWCOUNT
Total Propfind Requests | Shows the number of HTTP requests using the PROPFIND method (counted since service startup). PROPFIND requests retrieve property values on files and directories. | PERF_COUNTER_RAWCOUNT
Total Proppatch Requests | Shows the number of HTTP requests using the PROPPATCH method (counted since service startup). PROPPATCH requests set property values on files and directories. | PERF_COUNTER_RAWCOUNT
Total Put Requests | Shows the number of HTTP requests using the PUT method (counted since service startup). | PERF_COUNTER_RAWCOUNT
Total Rejected Async I/O Requests | Shows the total number of requests rejected due to bandwidth throttling settings (counted since service startup). | PERF_COUNTER_RAWCOUNT
Total Search Requests | Shows the number of HTTP requests using the MS-SEARCH method (counted since service startup). Search requests are used to query the server to find resources that match a set of conditions provided by the client. | PERF_COUNTER_RAWCOUNT
Total Trace Requests | Shows the number of HTTP requests using the TRACE method (counted since service startup). TRACE requests allow the client to see what is being received at the end of the request chain and use the information for diagnostic purposes. | PERF_COUNTER_RAWCOUNT
Total Unlock Requests | Shows the number of HTTP requests using the UNLOCK method (counted since service startup). UNLOCK requests are used to remove locks from files. | PERF_COUNTER_RAWCOUNT
Trace Requests/sec | Shows the rate at which HTTP requests using the TRACE method are made. TRACE requests allow the client to see what is being received at the end of the request chain and use the information for diagnostic purposes. | PERF_COUNTER_COUNTER
Unlock Requests/sec | Shows the rate at which HTTP requests using the UNLOCK method are made. UNLOCK requests are used to remove locks from files. | PERF_COUNTER_COUNTER


Windows Media Station Service Object

The Windows Media Station Service performance object provides statistics about the Windows Media Station service that provides multicasting, distribution and storage functions for ASF streams.

Performance counter | Description | Counter Type
Stations | Shows the number of station objects that currently exist in the server. | PERF_COUNTER_RAWCOUNT
Controllers | Shows the number of controllers that are currently connected to the server. | PERF_COUNTER_RAWCOUNT
Streams | Shows the number of stream objects that currently exist in the server. | PERF_COUNTER_RAWCOUNT


Windows Media Unicast Service Object

The Windows Media Unicast Service performance object provides statistics about the Windows Media service Unicast service that provides unicasting functions for Advanced Streaming Format (ASF) streams.

Counter Name | Description | Counter Type
Active Live Unicast Streams | Shows the number of live unicast streams that are being streamed. | PERF_COUNTER_RAWCOUNT
Active Streams | Shows the number of active files, or streams, currently being sent to the Microsoft® Media Players. Provides an overall indicator of system activity. A client is still connected even if it has stopped playing a file; because the Windows Media Unicast service maintains the bandwidth allocation to that client for 60 seconds after the client stops playing (this is called the Client Inactivity Time-out period). After the Client Inactivity Time-out period has elapsed, the server actively checks the client's status by periodically sending a message to each client. The server keeps a client connection open as long as the client responds to a message within three minutes (this is called the Client Terminal Time-out). | PERF_COUNTER_RAWCOUNT
Active TCP Streams | Shows the number of active Transmission Control Protocol (TCP) streams that are currently being sent to the Media Players. | PERF_COUNTER_RAWCOUNT
Active UDP Streams | Shows the number of active UDP streams currently being sent to the Media Players. | PERF_COUNTER_RAWCOUNT
Aggregate Read Rate | Shows the sum, in bytes per second, of the read rates for all files being sent to the Media Players. This counter indicates the speed at which the server is reading data from the disk. The graph usually appears jagged because the block read time is shorter than the block sends. | PERF_COUNTER_BULK_COUNT
Aggregate Send Rate | Shows the sum, in bytes per second, of the send rates for all files being sent to the Media Players. This counter indicates the speed at which the server is sending data to the players. The graph must appear relatively smooth; a jagged graph can indicate that streams are battling for bandwidth. | PERF_COUNTER_BULK_COUNT
Allocated Bandwidth | Shows the amount of bandwidth that the server allocates, based on the number of currently connected Media Players. Generally, clients connected to Windows Media Services that are not receiving streams still are allocated bandwidth. If a Windows Media Services player has allocated bandwidth but does not send a command during the Client Inactivity Time-out period, its bandwidth is de-allocated. The Client Inactivity Time-out period is 60 seconds. | PERF_COUNTER_RAWCOUNT
Authentication Requests | Shows the number of times an authentication plug-in is called to authenticate a client. Depending on the protocol in use, either HTTP or Microsoft Media Server (MMS), a single client may be authenticated once or several times when accessing each piece of unicast content. This is a general indicator of how often authentication plug-ins are used. | PERF_COUNTER_COUNTER
Authentications Denied | Shows the number of times that clients are denied access to unicast content by authentication plug-ins. Clients are denied access by an authentication plug-in when their IDs cannot be verified, no user accounts exist, or the authentication plug-in is not working. | PERF_COUNTER_COUNTER
Authorization Requests | Shows the number of times that an authorization plug-in is called to authorize a client. Each client action, such as opening or playing unicast content, is separately authorized so the total number of authorization requests is greater than the number of connected clients. This is a general indicator of how often authorization plug-ins are used. | PERF_COUNTER_COUNTER
Authorizations Refused | Shows the number of times that clients are denied access to unicast content by authorization plug-ins. Plug-ins deny access to clients based on their function (for example, a billing plug-in may deny client access to unicast content if the user account contains insufficient funds.) | PERF_COUNTER_COUNTER
Connected Clients | Shows the number of client programs that are currently connected. This indicates all Media Players connected to the system. This includes clients streaming, clients in paused and connected states, and clients that the server has not yet detected as being disconnected. The latter can occur if a client has lost power, or has been disconnected from the network and has not been able to notify the server of termination. | PERF_COUNTER_RAWCOUNT
Connection Rate | Shows the rate at which clients are connecting to the server. This is used to determine the number of instantaneous connections being serviced by the server. The default is 10 connections per second. This counter is useful for correlating client connections with utilization of system resource. | PERF_COUNTER_COUNTER
HTTP Streams | Shows the number of active HTTP streams that are currently being sent to Media players. | PERF_COUNTER_RAWCOUNT
HTTP Streams Reading Body | Shows the number of connected clients that have read the file header and are actively streaming unicast content via HTTP. The values of HTTP Streams Reading Body and HTTP Streams Reading Header equal the value of HTTP Streams. | PERF_COUNTER_RAWCOUNT
HTTP Streams Reading Header | Shows the number of clients that are connected to the server via HTTP and are reading a file header, but are not yet streaming the unicast content. The values of HTTP Streams Reading Header and HTTP Streams Reading Body equals the value of HTTP Streams. | PERF_COUNTER_RAWCOUNT
Late Reads | Shows the number of late read completions per second. A late read is a disk read operation that takes significantly longer than expected to complete. Typically, this counter is nonzero only when the server is under a very heavy load. If this counter is often nonzero, this can indicate that the system is not properly configured (for example, you need additional hard disk drives, or a lower setting for the maximum number of clients), or that other applications are competing with Windows Media Services for use of the disk. | PERF_COUNTER_COUNTER
Pending Connections | Shows the number of clients that are attempting to connect to the server but are not yet connected. This number may be high if the server is running near maximum capacity and cannot process a large number of connection requests in a timely manner. | PERF_COUNTER_RAWCOUNT
Plugin Errors | Shows the number of times that the plug-ins failed to perform their function (for example, a plug-in could not reach its user database, the plug-in crashed, and so on). | PERF_COUNTER_COUNTER
Plugin Events | Shows the number of events reported to plug-ins. This is an indicator of how much the server is using external plug-ins. | PERF_COUNTER_COUNTER
Scheduling Rate | Shows the rate, in seconds, at which requests are being made for tasks to be scheduled. Scheduled tasks include reading data from the disk and writing data to the network. The scheduling rate is roughly proportional to the rate at which packets are being sent by the server. This rate does not represent a one-to-one correspondence. | PERF_COUNTER_COUNTER
Stream Errors | Shows the number of errors that are occurring per second. Stream errors represent the number of stream data packets that are discarded by the server. They are introduced by the server when it cannot meet the demand for data and must throw packets away to avoid running behind schedule indefinitely. Stream errors show up most often after late reads occur. They indicate that the system is not configured properly or that other applications are competing for system resources. Heavy network traffic can also contribute to stream errors. | PERF_COUNTER_COUNTER
Stream Terminations | Shows the rate at which streams are terminated due to errors. Stream terminations indicate that the system is not configured properly, or that the file being streamed is corrupted. The server unilaterally terminates a stream under certain circumstances — most commonly, when the server is running significantly behind schedule. If the server must throw away several packets in a row from a given stream to remain on schedule, it terminates the stream. Streams can also be terminated if invalid data is encountered during file streaming. | PERF_COUNTER_COUNTER
UDP Resend Requests | Shows the number of times clients ask the Windows Media Services server to resend data packets that were not received. This value may be high when the server cannot reliably send packets via UDP. This is a good indicator of server or network overload. | PERF_COUNTER_COUNTER
UDP Resends Sent | Shows the number of UDP Resend Requests that are processed by the Windows Media Services server. Not all UDP Resend Requests are processed if the server is under a heavy load. | PERF_COUNTER_COUNTER


WINS Server Object

The WINS Server performance object reports activity of a computer running WINS. This object's counters are cleared each time you start and stop the service. Windows Internet Name Service (WINS) provides a dynamic database service that can register and resolve NetBIOS names to IP addresses used on your network. Windows 2000 Server provides WINS, which enables the server computer to act as a NetBIOS name server and register and resolve names for WINS-enabled client computers on your network as described in the NetBIOS over TCP/IP standards.

Counter Name | Description | Counter Type
Unique Registrations/sec | Shows the rate at which unique registration are received by the server. | PERF_COUNTER_COUNTER
Group Registrations/sec | Shows the rate at which group registration are received by the server. | PERF_COUNTER_COUNTER
Total Number of Registrations/sec | Shows is the sum of the Unique and Group registrations per sec. This is the total rate at which registration are received by the server. | PERF_COUNTER_COUNTER
Unique Renewals/sec | Shows the rate at which unique renewals are received by the server. | PERF_COUNTER_COUNTER
Group Renewals/sec | Shows the rate at which group renewals are received by the server. | PERF_COUNTER_COUNTER
Total Number of Renewals/sec | Shows the sum of the Unique and Group renewals per sec. This is the total rate at which renewals are received by the server. | PERF_COUNTER_COUNTER
Releases/sec | Shows the rate at which releases are received by the server. | PERF_COUNTER_COUNTER
Queries/sec | Shows the rate at which queries are received by the server. | PERF_COUNTER_COUNTER
Unique Conflicts/sec | Shows the rate at which unique registrations/renewals received by the server resulted in conflicts with records in the database. | PERF_COUNTER_COUNTER
Group Conflicts/sec | Shows the rate at which group registration received by the server resulted in conflicts with records in the database. | PERF_COUNTER_COUNTER
Total Number of Conflicts/sec | Shows the sum of the Unique and Group conflicts per sec. This is the total rate at which conflicts were seen by the server. | PERF_COUNTER_COUNTER
Successful Releases/sec | Shows the total number of successful releases per second. | PERF_COUNTER_COUNTER
Failed Releases/sec | Shows the total number of failed releases per second. | PERF_COUNTER_COUNTER
Successful Queries/sec | Shows the total number of successful queries per second. | PERF_COUNTER_COUNTER
Failed Queries/sec | Shows the total number of failed queries per second. | PERF_COUNTER_COUNTER


Windows 2000 System Performance Counters

The following counters are standard in the Windows 2000 operating system, are installed by Setup by default. Note that some may only be visible if you install or start the associated service.

  • ACS/RSVP Service. Default counter: Interfaces.
  • Browser. Default counter: Announcements Server/sec.
  • Cache. Default counter: Data Map Hits %.
  • Distributed Transaction Coordinator. Default counter: Active Transactions.
  • HTTP Indexing Service. Default counter: % Cache hits.
  • IAS Accounting Clients. Default counter: Malformed Packets.
  • IAS Accounting Server. Default counter: Server Up Time.
  • IAS Authentication Clients. Default counter: Malformed Packets.
  • IAS Authentication Server. Default counter: Server Up Time.
  • ICMP . Default counter: Messages/sec.
  • Indexing Service. Default counter: Word lists.
  • Indexing Service Filter. Default counter: Total indexing speed (MB/hr).
  • IP. Default counter: Datagrams/sec.
  • Job Object. Default counter: Current % Processor Time.
  • Job Object Details. Default counter: % Processor Time.
  • LogicalDisk. Default counter: % Disk Time.
  • Memory. Default counter: Pages/sec.
  • NBT Connection. Default counter: Bytes Total/sec.
  • Network Interface. Default counter: Bytes Total/sec.
  • Objects. Default counter: Processes.
  • Paging File. Default counter: % Usage.
  • PhysicalDisk. Default counter: % Disk Time.
  • Print Queue. Default counter: Jobs.
  • Process. Default counter: % Processor Time.
  • Processor. Default counter: % Processor Time.
  • Redirector. Default counter: Bytes Total/sec.
  • Server. Default counter: Bytes Total/sec.
  • Server Work Queues. Queue Length.
  • System. Default counter: File Data Operations/sec.
  • TCP. Default counter: Segments\sec.
  • Telephony. Default counter: Lines.
  • Thread. Default counter: % Processor Time.
  • UDP. Default counter: Datagrams/sec.

In addition, some counters are considered "costly," meaning that it takes a long time to collect data from them. These counters do not appear in System Monitor and can only be viewed using Showperf.exe or other performance-related tools in the Windows 2000 Resource Kit. The following are examples of costly counters:

Image

Process Address Space

Thread Details

For information about bottlenecks in some of these subsystem components, see the following topics:

Finding Memory Bottlenecks

Finding Processor Bottlenecks

Finding Cache Bottlenecks

Finding Disk Bottlenecks

When monitoring multiprocessor systems, see the following topic:

Finding Bottlenecks in Multiprocessor Computers


Copyright

Information in this document, including URL and other Internet Web site references, is subject to change without notice. Unless otherwise noted, the example companies, organizations, products, people, and events depicted herein are fictitious and no association with any real company, organization, product, person, or event is intended or should be inferred. Complying with all applicable copyright laws is the responsibility of the user. Without limiting the rights under copyright, no part of this document may be reproduced, stored in or introduced into a retrieval system, or transmitted in any form or by any means (electronic, mechanical, photocopying, recording, or otherwise), or for any purpose, without the express written permission of Microsoft Corporation.

Microsoft may have patents, patent applications, trademarks, copyrights, or other intellectual property rights covering subject matter in this document. Except as expressly provided in any written license agreement from Microsoft, the furnishing of this document does not give you any license to these patents, trademarks, copyrights, or other intellectual property.

© 2000 Microsoft Corporation. All rights reserved.

Microsoft, MS-DOS, Windows, Windows NT, and other names of Microsoft products and/or services referenced herein are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries/regions.

The names of actual companies and products mentioned herein may be the trademarks of their respective owners. NT is a trademark of Northern Telecom Limited.

Any RFC excerpts are subject to the following statement:

Copyright © The Internet Society (1999). All Rights Reserved. This document and translations of it may be copied and furnished to others, and derivative works that comment on or otherwise explain it or assist in its implementation may be prepared, copied, published and distributed, in whole or in part, without restriction of any kind, provided that the above copyright notice and this paragraph are included on all such copies and derivative works. However, this document itself may not be modified in any way, such as by removing the copyright notice or references to the Internet Society or other Internet organizations, except as needed for the purpose of developing Internet standards in which case the procedures for copyrights defined in the Internet Standards process must be followed, or as required to translate it into languages other than English. The limited permissions granted above are perpetual and will not be revoked by the Internet Society or its successors or assigns. This document and the information contained herein is provided on an "AS IS" basis and THE INTERNET SOCIETY AND THE INTERNET ENGINEERING TASK FORCE DISCLAIMS ALL WARRANTIES, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO ANY WARRANTY THAT THE USE OF THE INFORMATION HEREIN WILL NOT INFRINGE ANY RIGHTS OR ANY IMPLIED WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE.


Windows 2000 Resource Kit: Core Networking Guide Online Book

Resource Kit Component Not Installed

The Windows 2000 Resource Kit component you attempted to reach is not installed on your computer.

Click the Back button to return to the previous topic.

© Copyright 1985-2000 Microsoft Corporation. All rights reserved.


Windows 2000 Resource Kit Performance Counters Search Tips Page

Performance Counters Reference

How to find a Performance Counter

The Windows 2000 Performance Counters Reference provides information about performance objects and counters available in Windows 2000. This reference groups objects by name, as well as by the features or services that install them.

Search Tab

If you don't know the object to which a counter belongs or the application that installs it, use the Search tab located in the left pane.

© Copyright 1985-2000 Microsoft Corporation. All rights reserved.


Performance Counters Reference: Related Resources

Performance Counters Reference

Related Resources

For information about performance counters, see the following resources:

The Windows 2000 Server Resource Kit Server Operations Guide contains information about performance counters.

Search the Microsoft Knowledge Base for information about performance counters.

© Copyright 1985-2000 Microsoft Corporation. All rights reserved.