Technical Reference to the Windows 2000 Registry Start Page

to search for a registry element

our Web site for updates

related resources

an important notice regarding the registry

give comments at our Web site

Technical Reference to the Registry

This file provides detailed descriptions of Windows 2000 registry content, such as the subtrees, keys, subkeys, and entries that advanced users want to know about, including many entries that cannot be changed by using Windows 2000 tools or programming interfaces.

© Copyright 1985-2000
Microsoft Corporation. All rights reserved.


Technical Reference to the Registry: Alphabetical List

This page requires a browser capable of displaying frames.


Glossary of Registry Terms

- A -

Active Window Tracking

Asynchronous Transfer Mode (ATM)

Authentication package

- B -

Black hole router (TCP/IP)

Browse list

- C -

Code page

Context-sensitive

Control set

Critical Section

Cryptographic key cache

Current control set

- D -

Deadlock

- E -

Encrypting file system

Enumerator

Event identifier

- F -

Fast Forwarding Path for Offload (FFP)

Foreground process / background process

Filename completion

File system cache

Fully Qualified Domain Name (FQDN)

- G -

Global catalog

GUID

- H -

Hardware profile

Hot keys

Hot tracking

- I -

ICMP destination unreachable message

ILMI

Input method editor

Interface (TCP/IP)

Iteration

- J -

No entries

- K -

Keyboard layout

- L -

Language ID

LastKnownGood control set

Locale

Locale ID

Location tracking

LSA

- M -

No entries

- N -

NDIS

Nonpaged pool

- O -

No entries

- P -

Paged pool

Paging files

Pipe

Pod (UNIX)

Policy-processing policies

Pool leaks

Protected files

Published printer

Published programs

- Q -

No entries

- R -

Raster fonts

Recursive resolution

Referenced entry (TCP/IP ARP cache table)

Remote Access ServerFlags Values

- S -

Scan code

Security Descriptor

Service group

Shutdown scripts

SID

Site

SNMP

Sorting ID

Startup scripts

SYN flooding

SYN flooding attack protection

- T -

Task Manager

Transform file

Trusted performance counter DLL

Twips

- U -

UNC provider

UNI

Universal Naming Convention (UNC)

- V -

Virtual machine

- W -

No entries

- X -

No entries

- Y -

No entries

- Z -

No entries


About the Technical Reference to the Windows 2000 Registry

About the Technical Reference to the Windows 2000 Registry©

Description of the Technical Reference

The Technical Reference to the Windows 2000 Registry is an aid to understanding the contents of the Windows 2000 Registry. It includes descriptions of the some of the most useful subtrees, keys, subkeys, and entries in the registry.

The following figure shows the registry of a typical computer, as seen by Regedit.exe. The figure shows the names used in this file to refer to different parts of the registry.

View of the registry in Regedit with callouts naming registry elements

Contents of the Technical Reference

The Technical Reference to the Windows 2000 Registry includes:

  • Selected content of the registry of Windows 2000 Professional and Windows 2000 Server.
  • Subkeys and entries that are added by the system.
  • Subkeys and entries that do not appear in the registry unless you add them.
  • Subkeys and entries for many optional services packaged with Windows 2000, such as hardware and software drivers, and network services. However, it does not include subkeys or entries for other programs used on a computer running Windows, such as Microsoft Word.
  • Change methods, which are the recommended procedures for changing the values in the registry without editing the registry directly. These include administrative tools, elements of the Windows user interface, and application programming interfaces.

Scope of the Technical Reference

The Technical Reference describes the content of the registry. It does not describe the registry component of the operating system or explain its proper maintenance. For this information, see "The Windows 2000 Registry" in Help for Windows 2000. For a more detailed discussion, see Chapter <insert reference here> of the Windows 2000 Workstation Resource Kit.

The Technical Reference describes the registry content that is most useful to administrators and support personnel. It is not a complete listing of all registry contents. It primarily documents entries that adminstrators might need to change and can be changed only by editing the registry.

The vast majority of registry content consists of options that are set and maintained by system code for internal use. Changing the values of these entries can produce unexpected, contradictory, or uninterpretable instructions in operating system and application programs. They can also degrade the performance of your system, obscure the location of essential files, and invalidate your Windows licensing agreement. Do not experiment with the registry or change any entries that you do not completely understand.

The Technical Reference and your registry

Some of the entries described in this file do not appear in the registry of every computer running Windows 2000. Your registry varies depending upon the version of Windows you are running, the hardware and software installed, and the services you have configured for your system. Many subkeys and entries are available in Windows 2000, but operate only when you have added them to the registry directly, either by using a registry editor, or a program that edits the registry.

Updates to the Technical Reference

The Technical Reference to the Windows 2000 Registry is periodically updated and included in releases and supplements of the Windows 2000 Professional Resource Kit and the Windows 2000 Server Resource Kit.

Corrections and additions to the Technical Reference to the Registry appear in the Windows 2000 Resource Kits Web site.


Components of an entry description

This page displays the components common to the descriptions of registry entries in this file. The text on this page describes the components.

Entry name

Registry path: HKLM\SYSTEM\CurrentControlSet\...

The registry path shows the location of the entry in the registry. You can use the path to navigate to the entry.

Data type | Range | Default
Defines the length and type of data that can be stored in the entry. See Data Types in the Windows 2000 Registry | Demonstrates the syntax or format of the data in the entry and the range of valid values. For example, 0 | 4 means that "0" and "4" are the only values permitted. Words that describe a range, but are not part of the range, appear in italics. For example, IP address. Italics are also used to show the data units. For example, 1 - 60 seconds. | The default is the value the system adds to the registry when it has not been changed or configured. If the entry does not appear in the registry, the default is the value the systems assumes or the value that describes the way the system behaves. For example, the default value of an entry is 0 if the system behaves as though the value was set to 0 when the entry is not in the registry.

Note Image Note

The data type, range, and default table is only included in descriptions of registry entries. Folders, such as subtrees, keys, and subkeys, do not have these attributes.

Description

For registry folders (subtrees, keys, and subkeys) the Description explains what kinds of data are stored in the folder and programs or services that create or use the data in the container.

For entries, the Description explains how the program or service interprets the data stored in the value of the entry.

When the entry has a range of values, the Description includes a table describing the effect of each value on the program or service.

In a description, the names of registry entries appear in bold; the names of other registry elements appear in plain text.

The table in a descriptions lists the meaning of each valid value or range of values.

Value | Meaning
0 | Effect of 0
1 | Effect of 1

Change method

The change method describes the method you should use to change the value of the entry. Use these alternatives whenever they are available. Entries that do not have a change method can be changed only by editing the registry or using a program that edits the registry.

Activation method

The activation method describes additional steps you must take to make changes to the entry effective. Typically, these involve restarting a service, restarting Windows 2000, or logging off and logging on again.

Note Image Note

Notes provide additional information about the entry. Typically, notes tell when the system adds the entry to the registry, qualifies the use of the entry, and describes the order of precedence of related entries.

Tip Image Tip

Tips provide suggestions for using or learning more about the entry.

Caution Image Caution

Cautions describe the harm that might result if you add, change, or delete a registry element. Please take the cautions seriously. They are intended to protect your system.

Related Entries

Related entries are active links to entries that configure the same component or configure the same features on a different component. Related entries help you find the entry that meets your needs precisely.


Description of the Windows 2000 Registry

The Windows 2000 registry is a hierarchical database that contains the value of variables in Windows 2000 and in the applications and services that run on Windows 2000. The operating system and other programs also store data about users, and about the current configuration of the system and its components in the registry. Because the registry is available whenever the system is running, programs that start and stop can keep persistent data in the registry.

caution-icon Caution

Do not use a registry editor to edit the registry directly unless you have no alternative. The registry editors bypass the standard safeguards provided by administrative tools. These safeguards prevent you from entering conflicting settings or settings that are likely to degrade performance or damage your system. Editing the registry directly can have serious, unexpected consequences that can prevent the system from starting and require that you reinstall Windows 2000. To configure or customize Windows 2000, use the programs in Microsoft Management Console or Control Panel whenever possible.

Structure of the Registry

Much of the registry consists of nested containers known as subtrees, keys, and subkeys. These are like folders. The data actually is stored in the registry entries, the lowest level element in the registry. The entries are like files. The series of nested containers comprise a path to each entry. Because entry names are unique only within a path, entries are referenced by their full registry path and name.

An entry consists of a name, a data type, which defines the length and format of data that the entry can store, and a a field known as the value of a registry entry. Data is stored in value.

Variability of the Registry

No two registries are exactly alike. Because the registry stores data about the hardware and software installed on and available to your computer, much of the registry is very specific to the computer and its current configuration.

Also, some of the registry content is constant, but other content is created anew each time you start the operating system or log on as a user. As a result, many changes to the registry are deleted or replaced when you restart or log off and log on again.

Finally, the location of registry entries can change. Programmers sometimes move entries when they update programs and features, and programs have been known to move entire sections of the registry to a new location when a service or feature is enabled.

As a result, it is not prudent to include a direct reference to a registry entry path and name in any program or script. If you do, the program or script might not operate correctly with future versions of the operating system. To retrieve, add, delete, or change a registry entries, use the standard Win32 APIs. The APIs are updated with each version of the system to find the data you need.

How Registry Data is Used

Programs store all types of data in registry entries. Typically, programs use standard Win32 application programning interfaces (APIs) to retrieve data from the registry. The program specifies an entry by its path and name and the API returns the value of the entry. Programs also use standard APIs to add and delete registry content and to change the values of registry entries.

After they retrieve and read the data in the value of an entry, each program interprets the data and implements its result independently, depending on how the program is written.

For example, a value of 1 might indicate to a program that an optional feature is enabled or disabled, or it might force the program to wait for one millisecond or one day before taking action.

A file location stored in a registry entry might tell the program where to find a file or it might instruct the program to move the file to the specified location.

Because programs are so infinitely variable, it is very difficult to predict how they interpret the registry data. It is important to remember that the registry belongs to programs, not to users. And, unless you are very familiar with the program or the registry entry, it is wise to stay out of the registry.

Users and the Registry

Most users never need to view or edit the registry. The administrative tools and Windows interface enable users to change set preferences and change the services and features of the operating system safely.

However, there are rare instances when an operating system variable cannot be changed by any means other than editing the registry.

If this occurs, consult this file and other resources to make certain that you must edit the registry. Then, back up the registry using standard procedures. Make your changes and test them before returning your computer to its place in your enterprise.


Viewing and editing the Registry

Most users never need to view or edit the registry. You can configure most system services by using the programs provided with Windows 2000, such as Computer Management, Control Panel and Group Policy, or the administrative tools installed with optional services, such as WINS Manager and Internet Service Manager.

If you wish to view the registry or need to change a value that can only be set directly in the registry, use a registry editor, such as Regedit.exe or Regedt32.exe, the registry editors installed with Windows 2000.

To start a registry editor, click Start, click Run, and then type the name of the editor in the Run box.

caution-icon Caution

Do not use a registry editor to edit the registry directly unless you have no alternative. The registry editors bypass the standard safeguards provided by administrative tools. These safeguards prevent you from entering conflicting settings or settings that are likely to degrade performance or damage your system. Editing the registry directly can have serious, unexpected consequences that can prevent the system from starting and require that you reinstall Windows 2000. To configure or customize Windows 2000, use the programs in Microsoft Management Console or Control Panel whenever possible.

Tip-icon Tip

To avoid making inadvertent changes when viewing the registry, use Regedt32. From the Options menu, select Read Only Mode.

For information about the registry editors, see Help for Regedit.exe and Regedt32.exe.


Data Types in the Windows 2000 Registry

Data types define what kind of data an entry can store. The following data types are used by entries in the Windows 2000 registry:

REG_BINARY

Raw binary data. Most hardware component information is stored as binary data. It can be displayed in an easy-to-read format by using Windows 2000 Diagnostics. REG_BINARY data can be displayed and entered in binary or hexadecimal format in a registry editor. For example, see PagingFiles.

REG_DWORD

Data represented by a number that is 4 bytes (32 bits) long. Boolean (0 or 1) values and many entries for device drivers and services take this data type. REG_DWORD data can be displayed in binary, hexadecimal, or decimal format in a registry editor. For example, see ActivityLogFlag.

REG_DWORD_LITTLE_ENDIAN

Same as REG_DWORD. A 32-bit number in which the most significant byte is displayed as the leftmost or high-order byte. This is the most common format for storing numbers in computers running Windows 2000 and Windows 98.

REG_DWORD_BIG_ENDIAN

A 32-bit number in which the most significant byte is displayed as the rightmost or low-order byte. This is opposite of the order in which bytes are stored in the REG_DWORD and REG_DWORD_LITTLE_ENDIAN data types.

REG_EXPAND_SZ

A variable-length text string. REG_EXPAND_SZ data can include variables that are resolved when an application or service uses the data. For example, the value of File includes the variable Systemroot. When the Event Log service references the File entry, this variable is replaced by the name of the directory containing the Windows 2000 system files.

REG_LINK

Indicates a symbolic link between system or application data and a registry value. You can use Unicode characters in a REG_LINK entry.

REG_MULTI_SZ

Multiple text strings formatted as an array of null-terminated strings, and terminated by two null characters. Values that contain lists or multiple values in a form that people can read usually take this data type. The values in a REG_MULTI_SZ entry can be separated by spaces, commas or other marks. For example, the value of Machine is a list of paths accessible by all remote users of Windows 2000.

REG_SZ

A fixed-length text string. Boolean ("True" or "False") values and other short text values usually have this data type. For example, see Wallpaper.

REG_FULL_RESOURCE_DESCRIPTOR

A series of nested arrays designed to store a resource list for a hardware component or driver. For example, in Regedt32, double-click ConfigurationData (in HKEY_LOCAL_MACHINE\Hardware\Description\System \MultifunctionAdapter\0\ControllerName\0).


Windows 2000 Registry: Making Registry changes effective

Making Registry changes effective

When you use an administrative tool to change the configuration of a system feature or service, the change usually takes effect immediately or soon thereafter.

However, if you make the same change by editing the registry, you might need to log off and log on again, restart the service, or restart Windows 2000.

In general, if you change the value of any entry in the CurrentControlSet subkey, you must restart the computer for the changes to take effect. Also, if you use a registry editor to change values for most entries in HKEY_CURRENT_USER, you must log off and log on again for the changes to take effect.

When a change to the value of an entry is not immediate, the description of the entry contains an Activation Method field which describes what you need to do to make the change effective.


HKEY_CURRENT_CONFIG

HKCC

Description

The HKEY_CURRENT_CONFIG subtree (HKCC) stores configuration data for the current hardware profile.

The HKEY_CURRENT_CONFIG subtree does not contain any data. It just stores a pointer to the content of the Current subkey of HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Hardware Profiles. As such, the contents of the Current subkey appear in HKEY_CURRENT_CONFIG and can be viewed and changed in either location. This subtree provides easier access to this data.

Note Image Note

For information about the content of HKEY_CURRENT_CONFIG, see the description of the Hardware Profiles subkey and its Current subkey.

Related Entries

Current

Hardware Profiles subkey


HKEY_CLASSES_ROOT

HKCR

Description

The HKEY_CLASSES_ROOT subtree contains two types of data:

  • Data that associates file types with programs. The file type subkeys in HKEY_CLASSES_ROOT have the same name as the file name extension for the file type, such as .exe. File type associations are stored in the registry, but you should use Windows Explorer to change them. In Windows Explorer, from the Tools menu, click Folder Options, and then click the File Types tab.
  • Configuration data for COM objects.

The content of HKEY_CLASSES_ROOT comes from two sources, HKEY_LOCAL_MACHINE\SOFTWARE\Classes and HKEY_CURRENT_USER\SOFTWARE\Classes. If a subkey or entry appears in either location, it also appears HKEY_CLASSES_ROOT. If the values of entries in the two Classes subkeys conflict, only the value in HKEY_CURRENT_USER\SOFTWARE\Classes appears in HKEY_CLASSES_ROOT.

In Windows NT 4.0 and earlier, HKEY_CLASSES_ROOT displayed the data in HKEY_LOCAL_MACHINE\SOFTWARE\Classes only. The current merged configuration lets the system register program classes independently for each user. This feature is known as per-user class registration.

Per-user registration has several benefits:

  • Multiple users can customize a single computer. For example, User A can install an application which uses a particular file type, and User B can install a different application which uses the same file type without affecting User A.
  • Roaming class registration. Because class registrations are stored in the user profile, the class registrations are loaded on each computer through the application management extension after the profile is loaded. When the user logs in to a different computer, the registration will travel with the user through the directory and be written to a local portion of the user profile during logon.

    • Note: Roaming class registration is only available when using Intellimirror Software Management. For more information about Intellimirror, see Windows 2000 Help.

  • Increased registry security. Previously, users could change or delete registry keys under HKLM\SOFTWARE\Classes, thus breaking an application or changing its behavior. However, with class information now written to the user profile, a system administrator can limit access to HKLM\SOFTWARE\Classes.

Note Image Note

This is a change in functionality from Windows NT 4.0, where HKEY_CLASSES_ROOT was an alias of HKEY_LOCAL_MACHINE\SOFTWARE\Classes. For more information about HKEY_CLASSES_ROOT, see the COM Programmer's Reference and the Automation Programmer's Reference in the Platform Software Development Kit at http://msdn.microsoft.com.

If an entry exists in both HKEY_LOCAL_MACHINE\SOFTWARE\Classes and HKEY_CURRENT_USER\SOFTWARE\Classes, the value of the entry in HKEY_CURRENT_USER\SOFTWARE\Classes will take precedence.

If you create a new key or subkey in HKEY_CLASSES_ROOT, it will also be created in HKEY_LOCAL_MACHINE\SOFTWARE\Classes. If you create a new entry in this same key or subkey, that entry will also appear in that key or subkey in HKEY_LOCAL_MACHINE\SOFTWARE\Classes.

If you create a new entry in an existing subkey, where that entry will appear depends on whether the subkey already exists in HKEY_LOCAL_MACHINE\SOFTWARE\Classes or HKEY_CURRENT_USER\SOFTWARE\Classes:

  • If the subkey exists in both HKEY_CURRENT_USER\SOFTWARE\Classes and HKEY_LOCAL_MACHINE\SOFTWARE\Classes, the entry will appear in that subkey in HKEY_CURRENT_USER\SOFTWARE\Classes only.
  • If the subkey already exists in HKEY_CURRENT_USER\SOFTWARE\Classes only, then the entry will appear in that subkey in HKEY_CURRENT_USER\SOFTWARE\Classes.
  • If the subkey already exists in HKEY_LOCAL_MACHINE\SOFTWARE\Classes only, then the entry will appear in that subkey in HKEY_LOCAL_MACHINE\SOFTWARE\Classes.


HKEY_CURRENT_USER

HKCU

Description

The HKEY_CURRENT_USER subtree contains the user profile for the user who is currently logged on to the computer. The user profile includes environment variables, personal program groups, desktop settings, network connections, printers, and application preferences. The data in the user profile is similar to the data stored in the Win.ini file in Windows 3.x.

The HKEY_CURRENT USER subtree does not contain any data. It just stores a pointer to the content of HKEY_USERS\<Security ID (SID) of current user>. As such, the data stored in this subkey of HKEY_USERS appears in HKEY_CURRENT_USER. The data can be viewed and changed directly and programmatically in either location.

A new HKEY_CURRENT_USER subtree is created each time a user logs on. The data for HKEY_CURRENT_USER comes from the profile of the current user. If no profile is available, HKEY_CURRENT_USER is built from the user profile settings established for a default user, stored on the System drive\Documents and Settings\Default User (WINNT)\Ntuser.dat.


Console

HKCU\

Description

The Console key stores data for the console subsystem, which hosts all character-mode applications, such as Command Processor. In addition, the Console key can contain subkeys for custom command windows.

Change method

To change the console window settings, click the system menu icon in the title bar, and then select either Defaults to change the settings for all instances of that window, or Properties to change the current window only.

Activation method

Changes made in the Properties dialog box are effective immediately. Changes made in the Defaults dialog box or in the registry are effective the next time you open a console window.

Note Image Note

The values in the registry reflect the default window settings.

The entries in this key, or the ability to change them, might be affected by a policy. For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD. For general information about Group Policy, see Group Policy in Windows 2000 Help.


<console-window-name>

HKCU\Console\

Description

Represents a particular console window.

When you save the configuration of a character-based window, such as when you create a shortcut to a screen, the system adds a subkey under the Console key in which it saves the configuration of the window. These subkeys are named for the command windows. When you open the window, the system uses the values stored in this subkey rather than the values in the root of the Console key.

The entries in the <console-window-name> subkey are the same as entries in the Console key.

Change method

To change the console window settings, click the system menu icon in the title bar, and then select either Defaults to change the settings for all instances of that window, or Properties to change the current window only.

Activation method

Changes made in the Properties dialog box are effective immediately. Changes made in the Defaults dialog box or in the registry are effective the next time you open a console window.

Note Image Note

The <console-window-name> subkey does not appear unless the current user has changed the properties of the command window.

The <console-window-name> subkey is a variable representing the subkeys under the Console key. It does not actually appear in the registry. This variable subkey displays information which is common to the subkeys in the Console key.


<element-name>

HKCU\Console\<console-window-name>

Description

The <element-name> entry is a variable representing the entries under the <console-window-name> subkey. It does not actually appear in the registry. This variable entry displays information which is common to the entries in the <console-window-name> subkey.

The entries in the <console-window-name> subkey are used instead of those in the Console key for that console window. The meanings of these entries are the same as those of the entries in the Console key.

Note Image Note

The <element-name> entry does not appear unless the current user has changed the properties of the command window.

The <element-name> entry is a variable representing the entries under the <console-window-name> subkey. It does not actually appear in the registry. This variable entry displays information which is common to the entries in the <console-window-name> subkey.

The entries in the <console-window-name> subkey are used instead of those in the Console key for that console window. The meanings of these entries are the same as those of the entries in the Console key.


ColorTable<#>

HKCU\Console

Data type | Range | Default value
REG_DWORD | RGB value | (Depends on color.)

Description

Defines the colors in the color well on the Colors tab of the console Properties or Defaults dialog box. Each of the 16 ColorTablex entries corresponds with one of the registry entries ColorTable00 - ColorTable15.

Change method

To change the available colors, click the system menu icon in the title bar, and then select either Defaults to change the settings for all instances of that window, or Properties to change the current window only. Click the Colors tab, and then select a color well. Use the RGB boxes in the Selected Color Values group box to change that color.

Activation method

Changes made in the Properties dialog box are effective immediately. Changes made in the Defaults dialog box or in the registry are effective the next time you open a console window.

Note Image Note

The values in the registry reflect the default window settings.

The ColorTable<#> entry is a variable representing the entries ColorTable00 - ColorTable15 under the HKCU\Console key. It does not actually appear in the registry. This variable entry displays information that is common to the entries in the Console key.


CursorSize

HKCU\Console

Data type | Range | Default value
REG_DWORD | Percentage | 0x19 (25%)

Description

Specifies the percentage of a character cell that is occupied by the cursor. This setting affects the default window.

Value | Meaning
0x19 | Small (25%)
0x32 | Medium (50%)
0x64 | Large (100%)

Change method

To change the size of the cursor, click the system menu icon in the title bar, and then select either Defaults to change the settings for all instances of that window, or Properties to change the current window only. Click the Options tab, and then use the Cursor Size group box to change the cursor size.

Activation method

Changes made in the Properties dialog box are effective immediately. Changes made in the Defaults dialog box or in the registry are effective the next time you open a console window.

Note Image Note

The values in the registry reflect the default window settings.


FaceName

HKCU\Console

Data type | Range | Default value
REG_SZ | Font name | (Blank value)

Description

Specifies the name of an alternate command window font. If there is no font name in the value of this entry, the system uses raster fonts.

Change method

To change the alternate font, click the system menu icon in the title bar, and then select either Defaults to change the settings for all instances of that window, or Properties to change the current window only. Click the Font tab, and then select a font from the Fonts list box.

Activation method

Changes made in the Properties dialog box are effective immediately. Changes made in the Defaults dialog box or in the registry are effective the next time you open a console window.

Note Image Note

The values in the registry reflect the default window settings.


FontFamily

HKCU\Console

Data type | Range | Default value
REG_DWORD | Number | 0

Description

Specifies the font family of the font used in the command window.

Value | Meaning
0 | Raster fonts
48 | TrueType fonts

Change method

To change the font type, click the system menu icon in the title bar, and then select either Defaults to change the settings for all instances of that window, or Properties to change the current window only. Click the Font tab, and then select a font from the Fonts single selection list box.

Activation method

Changes made in the Properties dialog box are effective immediately. Changes made in the Defaults dialog box or in the registry are effective the next time you open a console window.

Note Image Note

The values in the registry reflect the default window settings.


FontSize

HKCU\Console

Data type | Range | Default value
REG_DWORD | HeightWidth (in pixels) | 0x000000000

Description

Specifies the size of the font used in the command window.

The value of this entry is an 8-byte hexadecimal value. The first four bytes (high word) specify the height of characters in pixels. The last four bytes (low word) specify the width of characters in pixels.

For example, if the value of this entry is 0x000000005, characters in the command window are 12 (0xC) pixels high and 5 pixels wide. A value of 0x00000000 indicates the default character size which is 8 pixels high and 12 pixels wide.

Change method

To change the font size, click the system menu icon in the title bar, and then select either Defaults to change the settings for all instances of that window, or Properties to change the current window only. Click the Font tab, and then select a size from the Size single selection list box.

Activation method

Changes made in the Properties dialog box are effective immediately. Changes made in the Defaults dialog box or in the registry are effective the next time you open a console window.

Note Image Note

The values in the registry reflect the default window settings.


FontWeight

HKCU\Console

Data type | Range | Default value
REG_DWORD | Number | 0

Description

Specifies the weight or thickness of the command window font.

Value | Meaning
0 | Normal weight.
1 | Bold text.

Change method

To change the font weight, click the system menu icon in the title bar, and then select either Defaults to change the settings for all instances of that window, or Properties to change the current window only. Click the Font tab and either select or clear the Bold fonts checkbox.

Activation method

Changes made in the Properties dialog box are effective immediately. Changes made in the Defaults dialog box or in the registry are effective the next time you open a console window.

Note Image Note

The values in the registry reflect the default window settings.


FullScreen

HKCU\Console

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether or not the command window is set to open in full-screen mode.

Value | Meaning
0 | Window mode.
1 | Full-screen mode.

Change method

To change the screen mode, click the system menu icon in the title bar, and then select either Defaults to change the settings for all instances of that window, or Properties to change the current window only. Click the Options tab, and then select either Window or Full Screen in the Display Options group box.

Activation method

Changes made in the Properties dialog box are effective immediately. Changes made in the Defaults dialog box or in the registry are effective the next time you open a console window.

Note Image Note

The values in the registry reflect the default window settings.

This entry is supported only by computers with Intel processors.


HistoryBufferSize

HKCU\Console

Data type | Range | Default value
REG_DWORD | Number of commands | 50

Description

Specifies the number of commands that can be stored in each command history buffer.

Change method

To change the size of the history buffer, click the system menu icon in the title bar, and then select either Defaults to change the settings for all instances of that window, or Properties to change the current window only. Click the Options tab, and then change the Buffer Size in the Command History group box.

Activation method

Changes made in the Properties dialog box are effective immediately. Changes made in the Defaults dialog box or in the registry are effective the next time you open a console window.

Note Image Note

The values in the registry reflect the default window settings.

Related Entries

NumberOfHistoryBuffers


InsertMode

HKCU\Console

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines how the system behaves when the user types over existing characters.

Value | Meaning
0 | Overtype mode. Characters typed replace highlighted characters.
1 | Insert mode. Characters typed are inserted before the highlighted characters.

Change method

To change the typing mode, click the system menu icon in the title bar, and then select either Defaults to change the settings for all instances of that window, or Properties to change the current window only. Click the Options tab, and then select Insert Mode in the Edit Options group box.

Activation method

Changes made in the Properties dialog box are effective immediately. Changes made in the Defaults dialog box or in the registry are effective the next time you open a console window.

Note Image Note

The values in the registry reflect the default window settings.


LoadConIme

HKCU\Console

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether or not the IME proxy process for the Windows 2000 console (Conime.exe) is loaded automatically when you log on to Windows 2000.

Value | Meaning
0 | Do not load Conime.exe automatically.
1 | Load Conime.exe automatically when Windows 2000 starts.

Activation method

To make changes to this entry effective, you must log off of Windows 2000, and then log on again.

Note Image Note

This entry is used only when the locale of the computer is set to 932 (Japanese), 936 (Chinese), 949 (Korean Unified Hangul), or 950 (Chinese Big5 Extended) .


NumberOfHistoryBuffers

HKCU\Console

Data type | Range | Default value
REG_DWORD | Number of buffers | 4

Description

Specifies the number of history buffers allocated to store commands.

Change method

To change the number of history buffers, click the system menu icon in the title bar, and then select either Defaults to change the settings for all instances of that window, or Properties to change the current window only. Click the Options tab, and then change the Number of Buffers in the Command History group box.

Activation method

Changes made in the Properties dialog box are effective immediately. Changes made in the Defaults dialog box or in the registry are effective the next time you open a console window.

Note Image Note

The values in the registry reflect the default window settings.

Related Entries

HistoryBufferSize


PopupColors

HKCU\Console

Data type | Range | Default value
REG_DWORD | Foreground color number Background color number | 0x000000F5

Description

Specifies the colors used in popup windows, by color number.

The value of this entry is an 8-byte hexadecimal value. The first four bytes (high word) represent the background color. The last four bytes (low word) represent the text color.

Hexadecimal value | Color
0 | Black
1 | Blue
2 | Green
3 | Aqua
4 | Red
5 | Purple
6 | Yellow
7 | White
8 | Gray
9 | Light Blue
A | Light Green
B | Light Aqua
C | Light Red
D | Light Purple
E | Light Yellow
F | Bright White

Change method

To change the colors of the popup windows, click the system menu icon in the title bar, and then select either Defaults to change the settings for all instances of that window, or Properties to change the current window only. Click the Colors tab, and then use the color well control options to change the values.

Activation method

Changes made in the Properties dialog box are effective immediately. Changes made in the Defaults dialog box or in the registry are effective the next time you open a console window.

Note Image Note

The values in the registry reflect the default window settings.


QuickEdit

HKCU\Console

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether QuickEdit mode is enabled. In QuickEdit mode, users can cut and paste text by using the mouse.

Value | Meaning
0 | QuickEdit mode is disabled. Users must use commands on the Edit menu to cut and paste.
1 | QuickEdit mode is enabled. Users can use either the mouse or commands on the Edit menu to cut and paste.

Change method

To change the editing options, click the system menu icon in the title bar, and then select either Defaults to change the settings for all instances of that window, or Properties to change the current window only. Click the Options tab, and then select Quick Edit Mode in the Edit Options group box.

Activation method

Changes made in the Properties dialog box are effective immediately. Changes made in the Defaults dialog box or in the registry are effective the next time you open a console window.

Note Image Note

The values in the registry reflect the default window settings.


ScreenBufferSize

HKCU\Console

Data type | Range | Default value
REG_DWORD | Buffer size | 0x00190050

Description

Determines the size of the screen buffer (the screen that is retained in memory). If the size of the screen displayed on the monitor is smaller than the screen buffer, you can scroll to see the entire screen. You cannot display a console screen that is larger than the screen buffer.

The value of this entry is an 8-byte hexadecimal value. The first four bytes (high word) represent the number of characters that appear on each line of the screen. The last four bytes (low word) represent the number of lines of text on the screen.

For example, the default value, 0x00190050, indicates that the screen buffer is 25 (0x19) lines high and 80 (0x50) characters wide.

Change method

To change the screen buffer size, click the system menu icon in the title bar, and then select either Defaults to change the settings for all instances of that window, or Properties to change the current window only. Click the Layout tab, and then use the Screen Buffer Size group box to set the width and height.

Activation method

Changes made in the Properties dialog box are effective immediately. Changes made in the Defaults dialog box or in the registry are effective the next time you open a console window.

Note Image Note

The values in the registry reflect the default window settings.

Related Entries

WindowSize


ScreenColors

HKCU\Console

Data type | Range | Default value
REG_DWORD | Color number | 0x000000007

Description

Specifies the colors of console windows.

The value of this entry is an 8-byte hexadecimal value. The first four bytes (high word) represent the background color. The last four bytes (low word) represent the text color.

Hexadecimal value | Color
0 | Black
1 | Blue
2 | Green
3 | Aqua
4 | Red
5 | Purple
6 | Yellow
7 | White
8 | Gray
9 | Light Blue
A | Light Green
B | Light Aqua
C | Light Red
D | Light Purple
E | Light Yellow
F | Bright White

Change method

To change the screen colors, click the system menu icon in the title bar, and then select either Defaults to change the settings for all instances of that window, or Properties to change the current window only. Click the Colors tab, and then use the color well options to change the values.

Activation method

Changes made in the Properties dialog box are effective immediately. Changes made in the Defaults dialog box or in the registry are effective the next time you open a console window.

Note Image Note

The values in the registry reflect the default window settings.

For Command Processor windows, the value of DefaultColor takes precedence over the value of ScreenColors.


WindowPosition

HKCU\Console

Data type | Range | Default value
REG_DWORD | Position | There is no default value for this entry.

Description

Specifies the position of the command window on the user's screen.

The value of this entry is an 8-byte hexadecimal value. The first four bytes (high word) represent the position of the window on the Y (vertical) axis. The last four bytes (low word) represent the position of the window on the X (horizontal) axis.

Change method

To change the window position, click the system menu icon in the title bar, and then select either Defaults to change the settings for all instances of that window, or Properties to change the current window only. Click the Layout tab, and then use the Window Position group box.

Activation method

Changes made in the Properties dialog box are effective immediately. Changes made in the Defaults dialog box or in the registry are effective the next time you open a console window.

Note Image Note

The values in the registry reflect the default window settings.

If this entry does not appear in the registry, the system selects a position for the window. This is equivalent to the Let system position window option on the Layout tab in the Console Properties box.


WindowSize

HKCU\Console

Data type | Range | Default value
REG_DWORD | Size (number of characters) | 0x00190050

Description

Specifies the size of the command window.

The value of this entry is an 8-byte hexadecimal value. The first four bytes (high word) represent the number of characters that appear on each line of the screen. The last four bytes (low word) represent the number of lines of text on the screen.

For example, the default value, 0x00190050, indicates that the screen buffer is 25 (0x19) lines high and 80 (0x50) characters wide.

If the screen buffer (the size of the screen retained in memory) is larger than the window size, you can scroll to see the entire screen. You cannot make the window size larger than the screen buffer size.

Change method

To change the window size, click the system menu icon in the title bar, and then select either Defaults to change the settings for all instances of that window, or Properties to change the current window only. Click the Layout tab, and then use the Window Size box to set the width and height of the window.

Activation method

Changes made in the Properties dialog box are effective immediately. Changes made in the Defaults dialog box or in the registry are effective the next time you open a console window.

Note Image Note

The values in the registry reflect the default window settings.

Related Entries

ScreenBufferSize


Control Panel

HKCU\

Description

The Control Panel key and its subkeys contain entries which determine the accessibility, regional, and desktop appearance settings.

Change method

To change the values of these entries, use Control Panel.

Note Image Note

The entries in this subkey can be overriden by entries of the same name in the HKCU\Software\Policies\Microsoft\Control Panel and HKCU\Software\Policies\Microsoft\Windows\Control Panel subkeys

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


Accessibility

HKCU\Control Panel\

Description

The Accessibility subkey contains subkeys and entries which determine the accessibility settings.

Change method

To change the values of these entries double-click Accessibility Options in Control Panel or use Accesibility hotkeys.


<Accessibility-option>

HKCU\Control Panel\Accessibility\

Description

Represents an accessibility option.

The Accessibility subkey contains subkeys and entries which determine the accessibility settings.

Change method

To change the values of these entries, double-click Accessibility Options in Control Panel or use the Accessibility hotkeys.

Note Image Note

The <Accessibility_option> entry is a variable representing the entries under the HKCU\Control Panel\Accessibility\ subkey. It does not actually appear in the registry. This variable entry displays information which is common to the entries in the Accessibility subkey.


Appearance

HKCU\Control Panel\

Description

The Appearance subkey stores information about the appearance of the Windows elements.

Note Image Note

The entries in this subkey can be superceded by Group Policy setting included in Windows 2000.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.


Current

HKCU\Control Panel\Appearance

Data type | Range | Default value
REG_SZ | Scheme name | Windows Standard

Description

Stores the name of the color scheme currently in use on the computer.

Change method

To change the color scheme, double-click Display in Control Panel. Click the Appearance tab, and then select a scheme from the drop-down box.

Note Image Note

This entry appears in the registry only when the current scheme is not "Windows Standard."


CustomColors

HKCU\Control Panel\Appearance

Data type | Range | Default value
REG_BINARY | RGB value | 0xFFFFFF

Description

Stores information about the custom colors created by the user.

Change method

To change the color scheme, double-click Display in Control Panel. Click the Appearance tab, click the Color drop-down box, and then click Other. Select a color, and then click Add to Custom Colors.


Schemes

HKCU\Control Panel\Appearance\

Description

The Schemes subkey stores information about the schemes used on the computer.


<Scheme-name>

HKCU\Control Panel\Appearance\Schemes

Data type | Range | Default value
REG_BINARY | RGB values | (There is no defaul value for this entry.)

Description

Determines the appearance of each element of the window scheme.

Change method

To change the scheme, double-click Display in Control Panel. Click the Appearance tab, and then select a scheme from the Scheme drop-down list. To change any of the individual elements of the scheme, select the element from the Item drop-down list.

Note Image Note

The <Scheme-name> subkey is a variable representing the appearance schemes subkeys in the HKCU\Control Panel\Appearance\Schemes\<Scheme-name> subkey. It does not actually appear in the registry. This subkey entry displays information which is common to screen savers and is stored in the Schemes subkey.


Colors

HKCU\Control Panel\

Description

The Colors subkey contains entries that determine the color of each element of the Windows 2000 desktop. The values are shown as a series of three numbers, which refer to the RGB (red-green-blue) value of the color.

Change method

To change the colors of the elements of the Windows 2000 desktop, double-click Display in Control Panel, and then click the Appearance tab in the Display Properties dialog box.

Activation method

Changes made using the Display Properties dialog box are effective immediately; changes made using the registry are not effective until the computer has been restarted.


<element-name>

HKCU\Control Panel\Colors

Data type | Range | Default value
REG_SZ | RGB values | RGB value

Description

Represents a color and stores entries that apply only to that color.

Change method

To change the colors of the elements of the Windows 2000 desktop, double-click Display in Control Panel, and then click the Appearance tab in the Display Properties dialog box.

Activation method

Changes made by using the Properties box are effective immediately; changes made by using the registry are not effective until the computer has been restarted.

Note Image Note

The <element-name> entry is a variable representing the entries under the HKCU\Control Panel\Colors subkey. It does not actually appear in the registry. This variable entry displays information that is common to the entries in the Colors subkey.

The entries in the Colors subkey contain values that determine the color of each element of the Windows 2000 desktop. The values are shown as a series of three numbers, which refer to the RGB (red-green-blue) value of the color.


Current

HKCU\Control Panel\

Description

The Current subkey appears in the registry, but is not used by Windows 2000.


Color Schemes

HKCU\Control Panel\Current

Data type | Range | Default value
REG_SZ | Color scheme | Windows Standard

Description

This subkey appears in the registry, but is not used by Windows 2000.

Change method

To change the color scheme on your computer, use Display in Control Panel.


Custom Colors

HKCU\Control Panel\

Description

The Custom Colors subkey defines the custom colors in the color palette. The entries in the Custom Colors subkey are named ColorA through ColorP, and all have a default value of 0xFFFFFF.

Change method

To change the custom colors, double-click Display in Control Panel, and then click the Appearance tab in the Display Properties dialog box. Click the Colors drop-down list box, and then click Other.


<Color>

HKCU\Control Panel\Custom Colors

Data type | Range | Default value
REG_SZ | RGB value | 0x00FFFFFF

Description

Represents a custom color.

The entries in this subkey define the custom colors in the color palette. The entries in the Custom Colors subkey are named ColorA through ColorP, and all have a default value of 0xFFFFFF.

Change method

To change the custom colors, double-click Display in Control Panel, and then click the Appearance tab in the Display Properties dialog box. Click the Colors drop-down list box, and then click Other.

Note Image Note

The <Color> entry is a variable representing the entries under the HKCU\Control Panel\Custom Colors subkey. It does not actually appear in the registry. This variable entry displays information that is common to the entries in the Custom Colors subkey.


Desktop

HKCU\Control Panel\

Description

The Desktop subkey contains entries that control the appearance of the screen background and the position of windows and icons on the screen.


ActiveWndTrkTimeout

HKCU\Control Panel\Desktop

Data type | Range | Default value
REG_DWORD | milliseconds | 0

Description

Determines time (in milliseconds) that the mouse needs to remain over a window before the window is activated.


AutoEndTasks

HKCU\Control Panel\Desktop

Data type | Range | Default value
REG_SZ | 0 | 1 | 0

Description

Determines whether user processes are ended automatically when the user logs off or shuts down Windows 2000.

Value | Meaning
0 | Processes are not ended automatically. The system waits until the process ends and, if the time it takes to end the process exceeds the value of HungAppTimeout, the End Task dialog box appears, stating that the application cannot respond to the End Task request.
1 | Processes are ended automatically.

Related Entries

HungAppTimeout

WaitToKillServiceTimeout


CaretWidth

HKCU\Control Panel\Desktop

Data type | Range | Default value
REG_DWORD | number of pixels | 1

Description

Specifies the width of the blinking caret.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


CoolSwitch

HKCU\Control Panel\Desktop

Data type | Range | Default value
REG_SZ | 0 | 1 | 1

Description

This entry is not used by and has no effect on Windows 2000.


CoolSwitchColumns

HKCU\Control Panel\Desktop

Data type | Range | Default value
REG_SZ | Number of columns in decimal | 7

Description

Determines how many columns of icons can appear in the Task Switcher (ALT+TAB) box.


CoolSwitchRows

HKCU\Control Panel\Desktop

Data type | Range | Default value
REG_SZ | Number of rows in decimal | 3

Description

Determines how many rows of icons can appear in the Task Switcher (ALT+TAB) box.


CursorBlinkRate

HKCU\Control Panel\Desktop

Data type | Range | Default value
REG_SZ | Number of milliseconds in decimal | 500

Description

Determines how much time elapses between each blink of the selection cursor.

Change method

To change the value of this entry, double-click Keyboard in Control Panel, click the Speed tab, and then use the slider in the Cursor blink rate box.


DragFullWindows

HKCU\Control Panel\Desktop

Data type | Range | Default value
REG_SZ | 0 | 1 | 1

Description

Determines what appears on the screen while a user drags a window.

Value | Meaning
0 | Only the outline of the window rectangle moves as the window is dragged.
1 | The entire window and its contents move as the window is dragged.

Change method

To change the value of this entry, double-click Display in Control Panel, click the Effects tab, and then select or clear the Show window contents while dragging check box in the Visual effects group box.


DragHeight

HKCU\Control Panel\Desktop

Data type | Range | Default value
REG_SZ | Number of pixels in decimal | 4

Description

Determines the height of the rectangle used to detect the start of a drag operation.


DragWidth

HKCU\Control Panel\Desktop

Data type | Range | Default value
REG_SZ | Number of pixels in decimal | 4

Description

Determines the width of the rectangle used to detect the start of a drag operation.


FontSmoothing

HKCU\Control Panel\Desktop

Data type | Range | Default value
REG_SZ | 0 | 2 | 0

Description

Determines whether the edges of large fonts are painted in different shades of gray to make the font look smoother.

Value | Meaning
0 | Font smoothing is disabled (edges are not painted different shades of gray).
2 | Font smoothing is enabled (edges are painted different shades of gray).

Change method

To change the value of this entry, double-click Display in Control Panel, click the Effects tab, and then select or clear the Smooth edges of screen fonts check box in the Visual effectsgroup box.


ForegroundFlashCount

HKCU\Control Panel\Desktop

Data type | Range | Default value
REG_DWORD | Number of flashes in decimal | 3

Description

Determines the number of times the taskbar button will flash to notify the user that a background window has been activated by the system. If the time elapsed since the last user input exceeds the value of ForegroundLockTimeout, the window will automatically be brought to the foreground.

Related Entries

ForegroundLockTimeout


ForegroundLockTimeout

HKCU\Control Panel\Desktop

Data type | Range | Default value
REG_DWORD | Time in milliseconds | 200000

Description

Specifies the time, following user input, during which the system will not allow applications to force themselves into the foreground.

Related Entries

ForegroundFlashCount


GridGranularity

HKCU\Control Panel\Desktop

Data type | Range | Default value
REG_SZ | 0-49 (8-pixel units) | 0

Description

This entry is not used by and has no effect on Windows 2000.


HungAppTimeout

HKCU\Control Panel\Desktop

Data type | Range | Default value
REG_SZ | Number of milliseconds in decimal | 5000

Description

Determines how long the system waits for user processes to end in response to the End Task button command in Task Manager. If this threshold is exceeded, the End Task dialog box appears, stating that the process did not respond.

Related Entries

AutoEndTasks

WaitToKillAppTimeout


LowPowerActive

HKCU\Control Panel\Desktop

Data type | Range | Default value
REG_SZ | 0 | 1 | 0

Description

Determines if the low power alarm is set.

Value | Meaning
0 | Disabled. An alarm will not activate when battery power is low.
1 | Enabled. An alarm will activate when battery power is low.

Change method

To change the value of this entry, double-click Display in Control Panel. Click the Screen Saver tab, click the Power button, and then click the Alarms tab.

Note Image Note

This option is only availble on a battery-powered computer that has Advanced Power Management (APM) enabled. For more information about APM, see Windows 2000 Help.


LowPowerTimeOut

HKCU\Control Panel\Desktop

Data type | Range | Default value
REG_SZ | 0 | 1 | 0

Description

Determines if the low power timeout is set.

Value | Meaning
0 | Disabled. The low power timeout is not set.
1 | Enabled. The low power timeout is not set.

Change method

To change the value of this entry, double-click Display in Control Panel. Click the Screen Saver tab, click the Power button, and then click the Alarms tab.

Note Image Note

This option is only availble on a battery-powered computer that has Advanced Power Management (APM) enabled. For more information about APM, see Windows 2000 Help.


MenuShowDelay

HKCU\Control Panel\Desktop

Data type | Range | Default value
REG_SZ | Number of milliseconds in decimal | 400

Description

Determines the interval from the time the cursor is pointed at a menu until the menu items are displayed.


PaintDesktopVersion

HKCU\Control Panel\Desktop

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether or not the version and build number of Windows is visible on the desktop. If desktop version painting is enabled, the following text will appear in the lower right-hand corner:

Windows 2000 <version>
Build <build-number>

Value | Meaning
0 | Disabled. The version and build number of Windows is not visible on the desktop.
1 | Enabled. The version and build number of Windows is visible on the desktop.


Pattern

HKCU\Control Panel\Desktop

Data type | Range | Default value
REG_SZ | (None) | b1 b2 b3 b4 b5 b6 b7 b8 (in decimal) | (None)

Description

Specifies a pattern for the screen background.

The values (b1 - b8) define a two-color pattern bitmap that is 8 pixels wide and 8 pixels high. Each b-number value specifies the pattern for one row of the bitmap. The b-number values are 8-bit binary values which are entered in decimal. The bits in each b-number value represent a row of 8 pixels. If a bit is set to 0, the pixel it defines is set to the background color. If a bit is set to 1, the pixel it defines is set to the foreground color.

For example, if you set the b1 value to the decimal value 128, the top row of pixels in the bitmap appears as the binary equivalent, 10000000. The system interprets this to mean that the first pixel has the foreground color and the seven remaining pixels have the background color.

The background color is determined by the value of Background, and the foreground color is determined by the value of WindowText, both of which appear in the Colors subkey.

Change method

To change the value of this entry, double-click Display in Control Panel. Click the Background tab, click the Pattern button, and then select a pattern from the list.

Related Entries

Colors subkey


ScreenSaveActive

HKCU\Control Panel\Desktop

Data type | Range | Default value
REG_SZ | 0 | 1 | 1

Description

Determines whether or not a screen saver is selected.

Value | Meaning
0 | No screen saver is selected.
1 | A screen saver is selected.

Change method

To select a screen saver, double-click Display in Control Panel and then click the Screen Saver tab. You can then either select a screen saver from the drop-down list box or select (None).

Note Image Note

This entry can be superceded by a policy included in Windows 2000. While the No screen saver Group Policy is enabled, the system ignores this entry. The setting of the No screen saver policy is stored in the value of ScreenSaveActive (Policies subkey).

Related Entries

SCRNSAVEEXE


ScreenSaverIsSecure

HKCU\Control Panel\Desktop

Data type | Range | Default value
REG_SZ | 0 | 1 | 0

Description

Records whether or not the screen saver is password-protected. When a screen saver is password-protected, the user must enter the correct password to end the screen saver.

This entry stores the setting of the Password protected check box on the Screen saver tab in Display in Control Panel.

Value | Meaning
0 | The check box is cleared. The screen saver is not password-protected.
1 | The check box is selected. The screen saver is password-protected.

Change method

To change the value of this entry, double-click Display in Control Panel. Click the Screen Saver tab, and then either select or clear the Password protected check box.

Note Image Note

This entry can be superceded by a policy included in Windows 2000. While the Password protect the screen saver Group Policy is enabled, the system disables the Password protected check box and ignores this entry. The setting of the Password protect the screen saver policy is stored in the value of ScreenSaverIsSecure (Policies subkey).


ScreenSaveTimeOut

HKCU\Control Panel\Desktop

Data type | Range | Default value
REG_SZ | Number of seconds in decimal | 900 (15 minutes)

Description

Specifies the how long the system must remain idle before the screen saver starts.

Change method

To change the value of this entry, double-click Display in Control Panel, click the Screen Saver tab, and then change the value in the Wait text box.


SCRNSAVE.EXE

HKCU\Control Panel\Desktop

Data type | Range | Default value
REG_SZ | File name | There is no default value for this entry.

Description

Specifies the name of the screen saver executable file.

Change method

To change the value of this entry, double-click Display in Control Panel. Click the Screen Saver tab, and then select a screen saver from the Screen saver drop-down list.

Note Image Note

Windows 2000 adds this entry to the registry when you use Display in Control Panel to select a screen saver. If you disable all screen savers by choosing (None) from the Screen Saver drop-down list box, Windows 2000 deletes this entry from the registry.

This entry can be superceded by a policy included in Windows 2000. While the Screen saver executable name Group Policy is enabled, the system ignores this entry. The setting of the Screen saver executable name policy is stored in the value of SCRNSAVE.EXE (Policies subkey).


TileWallpaper

HKCU\Control Panel\Desktop

Data type | Range | Default value
REG_SZ | 0 | 1 | 0

Description

Determines how the desktop wallpaper is positioned on the screen.

Value | Meaning
0 | Wallpaper is centered on the screen.
1 | Wallpaper is tiled across the screen.

Change method

To change the value of this entry, double-click Display in Control Panel. Click the Background tab, and then select Center or Tile from the Picture Display box.


UserPreferencesMask

HKCU\Control Panel\Desktop

Data type | Range | Default value
REG_BINARY | 0x0 - 0xFFFFFFFF (bitmask) | 0x80003E9E

Description

This entry represents a mask of bits that correspond to various UI settings.

Bit | UI Setting | Default Value | Meaning
0 | Active window tracking | 0 | Active window tracking disabled.
1 | Menu animation | 1 | Menu animation enabled; menu effect depends on value of bit 9.
2 | Combo box animation | 1 | Slide-open effect for combo boxes enabled.
3 | List box smooth scrolling | 1 | Smooth-scrolling effect for list boxes enabled.
4 | Gradient captions | 1 | Gradient effect for window title bars enabled.
5 | Keyboard cues | 0 | Menu access key letters underlined only when the menu is activated from the keyboard.
6 | Active window tracking Z order | 0 | Windows activated through active window tracking are not brought to the top.
7 | Hot tracking | 1 | Hot tracking enabled.
8 | Reserved | 0 | This bit reserved for future use.
9 | Menu fade | 1 | Menu fade animation enabled. If menu fade animation is disabled, menus use slide animation. This bit is ignored if menu animation (bit 1) is disabled.
10 | Selection fade | 1 | Selection fade enabled; the selected menu will remain on the screen briefly and then fade out after the user makes a selection.
11 | Tool tip animation | 1 | Tool tip animation enabled; effect depends on value of bit 12.
12 | Tool tip fade | 1 | Tool tip fade animation enabled. If tool tip fade animation is disabled, tool tips use slide animation. This bit is ignored if tool tip animation (bit 11) is disabled.
13 | Cursor shadow | 1 | Cursor shadow is enabled. This effect only appears if the system has a color depth of more than 256 colors.
14-30 | Reserved | 0 | These bits reserved for future use.
31 | UI effects | 1 | All UI effects (Combo box animation, Cursor shadow, gradient captions, hot tracking, list box smooth scrolling, menu animation, menu underlines, selection fade, tool tip animation) are enabled.


WaitToKillAppTimeout

HKCU\Control Panel\Desktop

Data type | Range | Default value
REG_SZ | Number of milliseconds in decimal | 20000 (20 seconds)

Description

Determines how long the system waits for user processes to end after the user attempts to log off or to shut down Windows 2000. If this threshold is exceeded, the End Task dialog box appears, stating that the process did not respond or, if AutoEndTasks is enabled, the system ends the process automatically.

Related Entries

AutoEndTasks

HungAppTimeOut

WaitToKillServiceTimeout


Wallpaper

HKCU\Control Panel\Desktop

Data type | Range | Default value
REG_SZ | [Path]File name | (Blank value) | (Blank value.)

Description

Specifies the name of the file in which the bitmap for the screen background is stored. If the file is not located in the Systemroot or Systemroot\System32 directory, you must include the path.

Value | Meaning
(Blank value) | No wallpaper is selected.
[Path]File name | Specifies the location of the file in which the wallpaper bitmap is stored.

Change method

To change the value of this entry, double-click Display in Control Panel. Click the Background tab. Select an image from the Select a background picture or HTML document as Wallpaper group box, or click the Browse button to locate an alternate image.

Activation method

Changes made by using the Display Properties dialog box are effective immediately.

Note Image Note

This entry can be superceded by a policy included in Windows 2000. While the Active Desktop Wallpaper Group Policy is enabled, the system ignores this entry. The setting of the Active Desktop Wallpaper policy is stored in the value of Wallpaper (Policies subkey).


WallpaperStyle

HKCU\Control Panel\Desktop

Data type | Range | Default value
REG_SZ | 0 | 2 | 0

Description

Determines how the desktop bitmap is displayed on the desktop if it is not tiled.

Value | Meaning
0 | Center the bitmap on the desktop.
2 | Stretch the bitmap vertically and horizontally to fit the desktop.

Change method

To change the value of this entry, use the Background tab in the Display Properties box.

Activation method

Changes made by using the Display Properties dialog box are effective immediately.

Related Entries

TileWallpaper


WheelScrollLines

HKCU\Control Panel\Desktop

Data type | Range | Default value
REG_SZ | 0 | 1 - 4294967295 (decimal only) | 3

Description

Specifies the number of lines scrolled for each one-notch rotation of the mouse wheel on a Microsoft IntelliMouse when no modifier keys (such as CTRL or SHIFT) are pressed.

Value | Meaning
0 | The screen does not scroll when the mouse wheel is rotated.
1 - 4294967295 | Specifies the number of lines scrolled each time the mouse wheel is rotated by one notch. If the value of this entry is greater than the number of lines visible in the window, the screen scrolls up or down by one page.

Change method

Applications should use the SPI_SETWHEELSCROLLLINES or SPI_GETWHEELSCROLLLINES APIs to change the value of this entry. For more information, see "SystemParametersInfo" the Platform Software Development Kit (SDK) documentation in the MSDN Library at http://msdn.microsoft.com.

Activation method

You must log off of Windows 2000 and then log on again before a change to this entry takes effect.


WindowMetrics

HKCU\Control Panel\Desktop\

Description

The WindowMetics subkey contains the current dimensions of window display elements. The units of some of the entries are in pixels, others are in X-Y coordinates, and some are in twips.


BorderWidth

HKCU\Control Panel\Desktop\WindowMetrics

Data type | Range | Default value
REG_SZ | 0 to -750 (twips) | -15 (15 twips)

Description

Determines the current setting for the width of the borders around all the windows with borders that can be sized.

Change method

To change the value of this entry, double-click Display in Control Panel. Click the Appearance tab, and then select Active Window Border from the Item drop-down list box, and then set the value of Size. The numbers in the Size box correspond to pixels, where one pixel equals fifteen twips.

Activation method

Changes made in Control Panel are effective immediately. Changes made in the registry are not effective until you log off and then log back on again.

Note Image Note

Values entered in twips (minus values) are rounded to the nearest pixel value. For instance, -17 will be converted to 1 pixel, while -28 is converted to 2 pixels.

The registry also accepts values in pixels (0 to 50); however, any values entered in Control Panel will be converted into twips in the registry.


CaptionFont

HKCU\Control Panel\Desktop\WindowMetrics

Data type | Range | Default value
REG_BINARY | Font name (in binary) | MS Sans Serif

Description

Stores data about the caption font.

Change method

To change the value of this entry, double-click Display in Control Panel and then click the Appearance tab. Select Active Title Bar from the Item drop-down list box and then make selections from the Font and Size drop-down list boxes.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


CaptionHeight

HKCU\Control Panel\Desktop\WindowMetrics

Data type | Range | Default value
REG_SZ | Number of twips | -270 (270 twips)

Description

Specifies the height of caption buttons.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


CaptionWidth

HKCU\Control Panel\Desktop\WindowMetrics

Data type | Range | Default value
REG_SZ | Number of twips | -270 (270 twips)

Description

Specifies the width of caption buttons.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


IconFont

HKCU\Control Panel\Desktop\WindowMetrics

Data type | Range | Default value
REG_BINARY | Font name (in binary) | MS Sans Serif

Description

Specifies the font used for text associated with icons.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


IconSpacing

HKCU\Control Panel\Desktop\WindowMetrics

Data type | Range | Default value
REG_SZ | Number of twips | -75 (75 twips)

Description

Specifies the width of the grid cell used for the large view of an icon.


IconTitleWrap

HKCU\Control Panel\Desktop\WindowMetrics

Data type | Range | Default value
REG_SZ | 0 | 1 | 1

Description

Determines whether the title text for an icon wraps or truncates if it is too long to fit on one line.

Value | Meaning
0 | Title text is truncated.
1 | Title text wraps to the next line.


IconVerticalSpacing

HKCU\Control Panel\Desktop\WindowMetrics

Data type | Range | Default value
REG_SZ | Number of twips | Depends on display.

Description

Specifies the width of the vertical space between icons. Windows 2000 determines the default based on the icon title font and the display device you are using.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


MenuFont

HKCU\Control Panel\Desktop\WindowMetrics

Data type | Range | Default value
REG_BINARY | Font name | MS Shell Dlg

Description

Specifies the font used in menu bars.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


MenuHeight

HKCU\Control Panel\Desktop\WindowMetrics

Data type | Range | Default value
REG_SZ | Number of twips | -270 (270 twips)

Description

Specifies the height of menu bars.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


MenuWidth

HKCU\Control Panel\Desktop\WindowMetrics

Data type | Range | Default value
REG_SZ | Number of twips | -270 (270 twips)

Description

Specifies the width of menu bar buttons.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


MessageFont

HKCU\Control Panel\Desktop\WindowMetrics

Data type | Range | Default value
REG_BINARY | Font name (in binary) | MS Shell Dlg

Description

Stores the name of the font used in message boxes.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


MinAnimate

HKCU\Control Panel\Desktop\WindowMetrics

Data type | Range | Default value
REG_SZ | 0 | 1 | 1

Description

Determines whether a window animates when being resized.

Value | Meaning
0 | Disabled. Window does not animate when being resized.
1 | Enabled. Window animates when being resized.

Change method

To change the value of this entry, double-click Display in Control Panel. Click the Effects tab, and then check Show transition effects for windows, menus and lists in the Visual effects group box.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


MinArrange

HKCU\Control Panel\Desktop\WindowMetrics

Data type | Range | Default value
REG_SZ | 0 - 11 | 0

Description

Determines the arrangement of minimized windows on the desktop. The value of this entry determines the starting point and the direction in which the windows are arranged from that point.

Value | Meaning
0 | Bottom left, moving right.
1 | Bottom right, moving left.
2 | Top left, moving right.
3 | Top right, moving left.
4 | Bottom left, moving up.
5 | Bottom right, moving up.
6 | Top left, moving down.
7 | Top right, moving down.
8 | Bottom left, hidden.
9 | Bottom right, hidden.
10 | Top left, hidden.
11 | Top right, hidden.

Note Image Note

Minimized windows are visible only when Windows Explorer is inactive.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


MinHorzGap

HKCU\Control Panel\Desktop\WindowMetrics

Data type | Range | Default value
REG_SZ | Number of twips | 0

Description

Specifies the horizontal gap between two minimized windows.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


MinVertGap

HKCU\Control Panel\Desktop\WindowMetrics

Data type | Range | Default value
REG_SZ | Number of twips | 0

Description

Specifies the vertical gap between two minimized windows.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


MinWidth

HKCU\Control Panel\Desktop\WindowMetrics

Data type | Range | Default value
REG_SZ | Number of twips | -154 (154 twips)

Description

Specifies the width of a minimized window.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


ScrollHeight

HKCU\Control Panel\Desktop\WindowMetrics

Data type | Range | Default value
REG_SZ | Number of twips | -240 (240 twips)

Description

Specifies the height of a standard horizontal scroll bar.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


ScrollWidth

HKCU\Control Panel\Desktop\WindowMetrics

Data type | Range | Default value
REG_SZ | Number of twips | -240 (240 twips)

Description

Specifies the width of a standard vertical scroll bar.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


Shell Icon BPP

HKCU\Control Panel\Desktop\WindowMetrics

Data type | Range | Default value
REG_SZ | 4 | 8 | 16 | 24 | 32 | 4

Description

Determines the color resolution of the icons on the Windows 2000 desktop.

The value of this entry specifies the number of bits used to describe each pixel.

Value (number of bits) | Meaning
4 | 16 colors.
8 | 256 colors.
16 | 65,536 colors.
24 | 16,777,216 colors.
32 | 16,777,216 colors.

Change method

To change the value of this entry, double-click Display in Control Panel. Click the Effects tab, and then click the Show icons using all possible colors check box to use the maximum number of colors as determined by your display mode.


ShellIconSize

HKCU\Control Panel\Desktop\WindowMetrics

Data type | Range | Default value
REG_SZ | 16 - 48 pixels (in decimal) | 32 pixels

Description

Specifies the size of icons used by the Windows Explorer interface.


Size

HKCU\Control Panel\Desktop\WindowMetrics

Data type | Range | Default value
REG_SZ | Number of pixels | Depends on video driver.

Description

Specifies the size of the shell large icon used by the Windows Explorer interface.

Caution Image Caution

This value is determined by the video driver on the computer. Do not change the value of this entry.


SmCaptionFont

HKCU\Control Panel\Desktop\WindowMetrics

Data type | Range | Default value
REG_BINARY | Font name (in binary) | MS Shell Dlg

Description

Determines the font used for small captions.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


SmCaptionHeight

HKCU\Control Panel\Desktop\WindowMetrics

Data type | Range | Default value
REG_SZ | Number of twips | -225 (225 twips)

Description

Specifies the height of small captions.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


SmCaptionWidth

HKCU\Control Panel\Desktop\WindowMetrics

Data type | Range | Default value
REG_SZ | Number of twips | -225 (225 twips)

Description

Specifies the width of small caption buttons.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


StatusFont

HKCU\Control Panel\Desktop\WindowMetrics

Data type | Range | Default value
REG_BINARY | Font name (in binary) | MS Shell Dlg

Description

Stores information about the font used in status bars.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


International

HKCU\Control Panel\

Description

The International subkey stores options that are selected in Regional Options in Control Panel. These entries determine how the system and programs display dates, times, and currency. The data for each user is stored separately.

Change method

To change the value of entries in this subkey, double-click Regional Options in Control Panel.


iCalendarType

HKCU\Control Panel\International

Data type | Range | Default value
REG_SZ | 0 - 12 Calendar-ID | For U.S. English: 1

Description

Specifies the type of calendar currently being used on the system, as represented by its calendar ID.


iCountry

HKCU\Control Panel\International

Data type | Range | Default value
REG_SZ | Country/region code | For U.S. English: 1

Description

Stores the country/region code. This number is the same as the country or region's international telephone code, except for Canada, which is 2.


iCurrDigits

HKCU\Control Panel\International

Data type | Range | Default value
REG_SZ | 0 - 9 in decimal | For U.S. English: 2

Description

Specifies the number of digits displayed after the decimal separator in currency.

Change method

To change the value of this entry, double-click Regional Options in Control Panel. Click the Currency tab, and then make a selection from the No. of digits after decimal drop-down list box.

Related Entries

iDigits


iCurrency

HKCU\Control Panel\International

Data type | Range | Default value
REG_SZ | 0 | 1 | 2 | 3 | 0

Description

Specifies the format for displaying currency.

Value | Meaning
0 | $2
1 | 2$
2 | $ 2
3 | 2 $

Change method

To change the value of this entry, double-click Regional Options in Control Panel. Click the Currency tab, and then make a selection from the Positive currency format drop-down list box.

Related Entries

sCurrency


iDate

HKCU\Control Panel\International

Data type | Range | Default value
REG_SZ | 0 | 1 | 2 | For U.S. English: 0

Description

Specifies the default format for displaying short dates.

Value | Meaning
0 | mm/dd/yy
1 | dd/mm/yy
2 | yy/mm/dd

For example, if the value of this entry is 0, February 8, 1999, will appear as 02/08/99.

Related Entries

iDate

sLongDate

sDate


iDigits

HKCU\Control Panel\International

Data type | Range | Default value
REG_SZ | 0 - 9 in decimal | For U.S. English: 2

Description

Specifies the number of digits displayed after the decimal separator in numbers.

Change method

To change the value of this entry, double-click Regional Options in Control Panel. Click the Numbers tab, and then make a selection from the No. of digits after decimal drop-down list box.

Related Entries

iCurrentDigits


iFirstDayOfWeek

HKCU\Control Panel\International

Data type | Range | Default value
REG_SZ | 0 - 6 | For U.S. English: 6

Description

Specifies which day is considered first in a week.

Value | Meaning
0 | Monday
1 | Tuesday
2 | Wednesday
3 | Thursday
4 | Friday
5 | Saturday
6 | Sunday


iFirstWeekOfYear

HKCU\Control Panel\International

Data type | Range | Default value
REG_SZ | 0 | 1 | 2 | For U.S. English: 0

Description

Specifies which week of the year is considered first.

Value | Meaning
0 | Week containing January 1 is the first week of the year.
1 | First full week following January 1 is the first week of the year.
2 | First week containing at least 4 days is the first week of the year.


iLZero

HKCU\Control Panel\International

Data type | Range | Default value
REG_SZ | 0 | 1 | For U.S. English: 1

Description

Determines whether a leading zero is used in decimal numbers.

Value | Meaning | Example
0 | No leading zeros. | .1
1 | Use a leading zero. | 0.1

Change method

To change the value of this entry, double-click Regional Options in Control Panel. Click the Numbers tab, and then make a selection from the Display leading zeroes drop-down list box.

Related Entries

sDecimal


iMeasure

HKCU\Control Panel\International

Data type | Range | Default value
REG_SZ | 0 | 1 | For U.S. English: 1

Description

Determines which measurement system is used.

Value | Meaning
0 | Metric
1 | U.S.

Change method

To change the value of this entry, double-click Regional Options in Control Panel. Click the Numbers tab, and then make a selection from the Measurement system drop-down list box.


iNegCurr

HKCU\Control Panel\International

Data type | Range | Default value
REG_SZ | 0 - 15 in decimal | For U.S. English: 0

Description

Specifies the format for displaying negative currency.

Value | Meaning | Example
0 | ($1.1) | ($100.00)
1 | -$1.1 | -$100.00
2 | $-1.1 | $-100.00
3 | $1.1- | $100.00-
4 | (1.1$) | (100.00$)
5 | -1.1$ | -100.00$
6 | 1.1-$ | 100.00-$
7 | 1.1$- | 100.00$-
8 | -1.1 $ | -100.00 $ (space before $)
9 | -$ 1.1 | -$ 100.00 (space after $)
10 | 1.1 $- | 100.00 $- (space before $)
11 | $ 1.1- | $ 100.00- (space after $)
12 | $ -1.1 | $ -100.00 (space after $)
13 | 1.1- $ | 100.00- $ (space before $)
14 | ($ 1.1) | ($ 100.00) (space after $)
15 | (1.1 $) | (100.00 $) (space before $)

Change method

To change the value of this entry, double-click Regional Options in Control Panel. Click the Currency tab, and then make a selection from the Negative currency format drop-down list box.


iNegNumber

HKCU\Control Panel\International

Data type | Range | Default value
REG_SZ | 0 | 1 | 2 | 3 | 4 | For U.S. English: 1

Description

Specifies the format of negative numbers.

Value | Meaning
0 | (1.1)
1 | -1.1
2 | - 1.1
3 | 1.1-
4 | 1.1 -

Change method

To change the value of this entry, double-click Regional Options in Control Panel. Click the Numbers tab, and then select a format from the Negative number format drop-down box.


iTime

HKCU\Control Panel\International

Data type | Range | Default value
REG_SZ | 0 | 1 | For U.S. English: 1

Description

Determines whether time is displayed with a 12-hour or 24-hour clock format.

Value | Meaning
0 | 12-hour clock.
1 | 24-hour clock.

Change method

To change the value of this entry, double-click Regional Options in Control Panel. Click the Time tab, and then make a selection from the Time format drop-down list box.


iTimePrefix

HKCU\Control Panel\International

Data type | Range | Default value
REG_SZ | 0 | 1 | 0

Description

Specifies whether a time marker (AM or PM) appears before or after the time.

Value | Meaning | Example
0 | Suffix | 9:15 AM
1 | Prefix | AM 9:15


iTLZero

HKCU\Control Panel\International

Data type | Range | Default value
REG_SZ | 0 | 1 | For U.S. English: 0

Description

Determines whether leading zeros are inserted before single-digit hours when time is displayed.

Value | Meaning | Example
0 | No leading zeros before single-digit hours. | 6:04 PM
1 | A leading zero is inserted before a single-digit hour. | 06:04 PM

Change method

To change the value of this entry, double-click Regional Options in Control Panel. Click the Time tab, and then make a selection from the Time format drop-down list box.


Locale

HKCU\Control Panel\International

Data type | Range | Default value
REG_SZ | locale ID | For U.S. English: 00000409

Description

Specifies the locale selected by the current user. The locale ID identifies the geographic variation of the spoken language chosen by the user. The chosen locale determines the default values for all other regional preferences, such as how dates and times are formatted and the symbols that are used in currency.

Change method

To change the value of this entry, double-click Regional Options in Control Panel. Click the General tab, and then make a selection from the Your locale (location) drop-down list box.


NumShape

HKCU\Control Panel\International

Data type | Range | Default value
REG_SZ | 0 | 1 | 2 | 1

Description

Determines the shape of digits in Unicode languages. By default, the digits 0-9 are displayed with the appropriate digit shape for the default locale (presuming that the appropriate font is available). The value of the NumShape entry determines whether the digits 0-9 are forced to display as European digits.

Value | Meaning
0 The shape of the digits is dependent on context. European digits follow Latin text, Arabic-Indic digits follow Arabic text, and Thai digits follow Thai text. When there is no preceeding text, Windows 2000 takes both the locale and the displayed reading order into consideration:
Locale | Reading order | Digits
Arabic | Right to Left | Arabic Indic
Thai | Left to Right | Thai
All others | Any | Locale default
1 | Digits are diplayed according to the default locale.
2 | Digit shapes are determined by sNativeDigits.

Related Entries

sNativeDigits


s1159

HKCU\Control Panel\International

Data type | Range | Default value
REG_SZ | String | For U.S. English: AM

Description

Specifies the text or symbols used to indicate that the time displayed is before noon in 12-hour time format.

Change method

To change the value of this entry, double-click Regional Options in Control Panel. Click the Time tab and then click the AM symbol drop-down list box.


s2359

HKCU\Control Panel\International

Data type | Range | Default value
REG_SZ | String | For U.S. English: PM

Description

Specifies the text or symbols used to indicate that the time displayed is at or after noon in 12-hour time format.

Change method

To change the value of this entry, double-click Regional Options in Control Panel. Click the Time tab and then click the PM symbol drop-down list box.


sCountry

HKCU\Control Panel\International

Data type | Range | Default value
REG_SZ | Name of country or region | For U.S. English: United States

Description

Specifies the fully localized name of the country or region. This name is based on the localized version of the product.

Note Image Note

This entry is used only by programs that are configured to read Win.ini files. Programs that use the standard Win32 APIs do not use this entry.

Caution Image Caution

Do not change the value of this entry. These values must comply with ISO standards and correspond to ISO values for functionality and language selection.


sCurrency

HKCU\Control Panel\International

Data type | Range | Default value
REG_SZ | Symbol or character | For U.S. English: $

Description

Specifies the currency symbol used to display monetary values.

Change method

To change the value of this entry, double-click Regional Options in Control Panel. Click the Currency tab, and then make a selection from the Currency symbol drop-down list box.

Note Image Note

Regional Options in Control Panel restricts this entry such that it will not accept the numeric digits 0–9. Editing the registry directly to set the value of this entry to a numeric digit could have one of two effects:

  • If an application calls the GetCurrencyFormat API, the system will use the default symbol for the locale.
  • If an application does not use the GetCurrencyFormat API and the application does not check the format itself, the numeric value will be used. This could cause errors if the value is used in calculations.

Related Entries

iCurrency


sDate

HKCU\Control Panel\International

Data type | Range | Default value
REG_SZ | Symbol or character | For U.S. English: /

Description

Specifies the symbol separating numbers when the date is displayed in short date (numeric) format, such as 6/5/69.

Change method

To change the value of this entry, double-click Regional Options in Control Panel. Click the Date tab, and then make a selection from the Date separator drop-down list box.

Note Image Note

Regional Options in Control Panel links the sDate and sShortDate values. This ensures the date separator and the date format are synchronized. For example,

sDate | sShortDate | Meaning
/ | M/d/yy | 6/5/69

Setting sTime and sTimeFormat independently in the registry can result in conflicting values. To repair these settings, use Regional Options in Control Panel.

Setting only one value in the registry might not change the date as it appears in applications since an application can read either sDate or sShortDate.

Related Entries

sShortDate

iDate

sLongDate


sDecimal

HKCU\Control Panel\International

Data type | Range | Default value
REG_SZ | Symbol or character | For U.S. English: . (a period)

Description

Specifies the punctuation used to separate the fractional part of a decimal number from the whole number part.

Change method

To change the value of this entry, double-click Regional Options in Control Panel. Click the Currency tab, and then click the Decimal symbol drop-down list box.

Note Image Note

Regional Options in Control Panel restricts this entry such that it will not accept the numeric digits 0–9. Editing the registry directly to set this value to a numeric digit could have one of two effects:

  • If an application calls the GetNumberFormat API, the system will use the default symbol for the locale.
  • If an application does not use the GetNumberFormat API and the application does not check the format itself, the numeric value will be used. This could cause errors if the value is used in calculations.

Related Entries

iLZero


sGrouping

HKCU\Control Panel\International

Data type | Range | Default value
REG_SZ | number of digits[;number of digits...] | For U.S. English: 3;0

Description

Describes how digits are grouped to the left of the decimal.

Each numeric value in this entry determines how many digits will be grouped together. The first number in this value determines the number of digits immediatly preceeding the decimal point, and each subsequent value determines the number of digits between thousands separators. If the last value is 0, the preceding value is repeated.

Value | Example
3;2;0 | 12,34,56,789
3;0 | 123,456,789
0;0 | 123456789

The symbol used to separate the groups is determined by the value of sThousand.

Change method

To change the value of this entry, double-click Regional Options in Control Panel. Click the Numbers tab, and then select a grouping from the Digit grouping drop-down list.

Note Image Note

Regional Options in Control Panel limits this value to the three options in the table, but you can enter up to five groups of digits, such as 1;2;3;4;5, in the value of this entry.

Related Entries

sThousand


sLanguage

HKCU\Control Panel\International

Data type | Range | Default value
REG_SZ | Language abbreviation | For U.S. English: ENU

Description

Specifies the primary spoken language displayed by Windows 2000. The value of this entry consists of a three-letter code representing the language. The first two letters are based on the ISO 2 letter language codes for the primary language. The third letter indicates the sub-language for the locale.

Change method

To change the value of this entry, double-click Regional Options in Control Panel. Click the General tab, and then select a location from the Your locale (location): drop-down list.

Note Image Note

This entry is used only by programs that are configured to read Win.ini files. Programs that use the standard Win32 APIs do not use this entry.

Caution Image Caution

Do not change the value of this entry. These values must comply with ISO standards and correspond to ISO values for functionality and language selection.


sList

HKCU\Control Panel\International

Data type | Range | Default value
REG_SZ | Symbol or character | For U.S. English: , (a comma)

Description

Specifies the symbol used to separate items in a list.

Change method

To change the value of this entry, double-click Regional Options in Control Panel. Click the Numbers tab, and then click the List separator drop-down list box.


sLongDate

HKCU\Control Panel\International

Data type | Range | Default value
REG_SZ | Date format | For U.S. English: dddd, MMMM dd, yyyy

Description

Specifies the format, including the abbreviations and separators, used to display dates in long date (text) format.

Value | Example
dddd, MMMM dd, yyyy | Saturday, October 12, 1986
MMMM dd, yyyy | October 12, 1986
dddd, dd MMMM, yyyy | Saturday, 12 October, 1986
dd MMMM, yyyy | 12 October, 1986

Change method

To change the value of this entry, double-click Regional Options in Control Panel. Click the Date tab, and then make a selection from the Long date format drop-down list box.

Activation method

Changes made in the registry are effective immediately.

Related Entries

iDate

sDate

sShortDate


sMonDecimalSep

HKCU\Control Panel\International

Data type | Range | Default value
REG_SZ | Symbol | For U.S. English: "." (period)

Description

Specifies the symbol used to separate the decimal values in currency.

For example, in the value, $1.20, a period separates the decimal values.

Change method

To change the value of this entry, double-click Regional Options in Control Panel. Click the Currency tab, and then Select a symbol from the Decimal symbol drop-down box.

Note Image Note

Regional Options in Control Panel restricts this entry such that it will not accept the numeric digits 0–9. Editing the registry directly to set this entry to a numeric digit could have one of two effects:

  • If a programs calls the GetCurrencyFormat API, the system will use the default symbol for the locale.
  • If an application does not use the GetCurrencyFormat API and the application does not check the format itself, the numeric value will be used. This could cause errors if the value is used in calculations.


sMonGrouping

HKCU\Control Panel\International

Data type | Range | Default value
REG_SZ | number of digits[;number of digits...] | For U.S. English: 3;0

Description

Specifies how digits are grouped to the left of the decimal in currency.

Each numeric value in this entry determines how many digits will be grouped together. The first number in this value determines the number of digits immediatly preceeding the decimal point, and each subsequent value determines the number of digits between thousands separators. If the last value is 0, the preceding value is repeated.

Regional Options in Control Panel limits this value to the three options displayed in the table below. However, you can enter up to five groups of digits in this value in the registry. For example, you can enter 1;2;3;4;5.

Value | Example
3;2;0 | 12,34,56,789
3;0 | 123,456,789
0;0 | 123456789

Change method

To change the value of this entry, double-click Regional Options in Control Panel. Click the Currency tab, and then select a grouping from the Digit grouping drop-down list.

Related Entries

sMonThousandSep


sMonThousandSep

HKCU\Control Panel\International

Data type | Range | Default value
REG_SZ | Symbol | For U.S. English: "," (comma)

Description

Specifies the symbol used to separate the thousands in currency.

For example, in the value, $1,000, a comma separates the values.

Change method

To change the value of this entry, double-click Regional Options in Control Panel. Click the Currency tab, and then Select a symbol from the Digit grouping symbol drop-down box.

Note Image Note

Regional Options in Control Panel restricts this entry such that it will not accept the numeric digits 0-9. Editing the registry directly to set this value to a numeric digit could have one of two effects:

  • If an application calls the GetCurrencyFormat API, the system will use the default symbol for the locale.
  • If an application does not use the GetCurrencyFormat API and the application does not check the format itself, the numeric value will be used. This could cause errors if the value is used in calculations.


sNativeDigits

HKCU\Control Panel\International

Data type | Range | Default value
REG_SZ | Number set | For U.S.English: 0123456789

Description

Describes the ten characters that are the native equivalent to the ASCII "0"-"9" as determined by the locale.


sNegativeSign

HKCU\Control Panel\International

Data type | Range | Default value
REG_SZ | Symbol | U.S. English: "-" (minus)

Description

Specifies the symbol used to display negative numbers.

Change method

To change the value of this entry, double-click Regional Options in Control Panel. Click the Numbers tab, and then select a symbol from the Negative sign symbol drop-down list.

Note Image Note

Regional Options in Control Panel restricts this entry such that it will not accept the numeric digits 0-9. Editing the registry directly to set this value to a numeric digit could have one of two effects:

  • If an application calls the GetNumberFormat or GetCurrencyFormat API, the system will use the default symbol for the locale.
  • If an application does not use the GetNumberFormat or GetCurrencyFormat API and the application does not check the format itself, the numeric value will be used. This could cause errors if the value is used in calculations.


sPositiveSign

HKCU\Control Panel\International

Data type | Range | Default value
REG_SZ | Symbol | (Blank)

Description

Specifies the symbol used to display positive numbers.

Note Image Note

Regional Options in Control Panel restricts this entry such that it will not accept the numeric digits 0-9. Editing the registry directly to set this value to a numeric digit could have one of two effects:

  • If an application calls the GetNumberFormat or GetCurrencyFormat API, the system will use the default symbol for the locale.
  • If an application does not use the GetNumberFormat or GetCurrencyFormat API and the application does not check the format itself, the numeric value will be used. This could cause errors if the value is used in calculations.


sShortDate

HKCU\Control Panel\International

Data type | Range | Default value
REG_SZ | Date format | For U.S. English: M/d/yy

Description

Specifies the format used to display dates in short date (numeric) format, such as 6/5/69.

Change method

To change the value of this entry, double-click Regional Options in Control Panel. Click the Date tab, and then make a selection from the Short date format drop-down list box.

Note Image Note

Regional Options in Control Panel links the sDate and sShortDate entries. This ensures the date separator and the date format are synchronized. For example,

sDate | sShortDate | Meaning
/ | M/d/yy | 6/5/69

Setting sTime and sTimeFormat independently in the registry can result in conflicting values. To repair these settings, use Regional Options in Control Panel.

Setting only one value in the registry might not change the date as it appears in applications, because an application can read either sDate or sShortDate.

Related Entries

iDate

sDate

sLongDate


sThousand

HKCU\Control Panel\International

Data type | Range | Default value
REG_SZ | Symbol or character | For U.S. English: , (a comma)

Description

Specifies the symbol used to separate digits to the left of the decimal.

For example, if the value of this entry is a comma, and the value of sGrouping is 3;0, the system displays the number 3000 as 3,000.

Change method

To change the value of this entry, double-click Regional Options in Control Panel. Click the Numbers tab, and then select a symbol from the Digit grouping symbol drop-down box.

Note Image Note

Regional Options in Control Panel restricts this entry such that it will not accept the numeric digits 0-9. Editing the registry directly to set this value to a numeric digit could have one of two effects:

  • If an application calls the GetNumberFormat API, the system will use the default symbol for the locale.
  • If an application does not use the GetNumberFormat API and the application does not check the format itself, the numeric value will be used. This could cause errors if the value is used in calculations.

Related Entries

sGrouping


sTime

HKCU\Control Panel\International

Data type | Range | Default value
REG_SZ | Symbol or character | For U.S. English: : (a colon)

Description

Specifies the character used to separate the hours, minutes, and seconds when displaying time. For example, if the value is a colon, noon appears as 12:00:00.

Change method

To change the value of this entry, double-click Regional Options in Control Panel. Click the Time tab, and then make a selection from the Time separator drop-down list box.

Note Image Note

Regional Options in Control Panel links the sTime and sTimeFormat entries. This ensures that the time separator and the time format are synchronized. For example,

sTime | sTimeFormat | Meaning
: | h:mm:ss tt | 8:20:00 AM

Setting sTime and sTimeFormat independently in the registry can result in conflicting values. To repair these settings, use Regional Options in Control Panel.

Setting only one value in the registry might not change the time as it appears in applications, because an application can read either sTime or sTimeFormat.

Related Entries

sTimeFormat


sTimeFormat

HKCU\Control Panel\International

Data type | Range | Default value
REG_SZ | Time format | For U.S. English: h:mm:ss tt

Description

Descibes the format in which time is displayed.

Change method

To change the time format, double-click Regional Options in Control Panel. Click the Time tab, and then select a format from the Time format drop-down list.

Note Image Note

Regional Options in Control Panel links the sTime and sTimeFormat entries. This ensures that the time separator and the time format are synchronized. For example,

sTime | sTimeFormat | Meaning
: | h:mm:ss tt | 8:20:00 AM

Setting sTime and sTimeFormat independently in the registry can result in conflicting values. To repair these settings, use Regional Options in Control Panel.

Setting only one value in the registry might not change the time as it appears in applications, because an application can read either sTime or sTimeFormat.

Related Entries

sTime


Keyboard

HKCU\Control Panel\

Description

The Keyboard subkey stores the options selected in Keyboard in Control Panel. The entries in this subkey are stored separately for each user. Keyboard configuration data for all users is stored in the KeyboardLayout and KeyboardLayouts subkeys in HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control.


InitialKeyboardIndicators

HKCU\Control Panel\Keyboard

Data type | Range | Default value
REG_SZ | 0 | 2 | 0

Description

Determines whether the NUMLOCK key is on or off when the computer starts. The system stores the state of the NUMLOCK key in this entry during logoff and shutdown, and then uses this value to restore the state when the user logs on.

Value | Meaning
0 | NUMLOCK is off.
2 | NUMLOCK is on.

Change method

To change the value of this entry, press the NUMLOCK key on your keyboard.


KeyboardDelay

HKCU\Control Panel\Keyboard

Data type | Range | Default value
REG_SZ | 0-3 | 1

Description

Determines how long after a key is pressed and held down that the key begins to repeat the character. The values 0 (shortest delay; approximately 250 milliseconds) and 3 (longest delay; approximately 1 second) correspond to the four increments on the Repeat delay scale in Keyboard in Control Panel.

Change method

To change the value of this entry, use the Keyboard Properties box. Repeat delay is in the Character repeat box on the Speed tab.


KeyboardSpeed

HKCU\Control Panel\Keyboard

Data type | Range | Default value
REG_SZ | 0-31 | 31

Description

Determines the rate at which a character repeats when you hold down a keyboard key. The values 0 (slowest repeat rate; approximately 2 characters per second) through 31 (fastest repeat rate; approximately 30 characters per second) correspond to the 31 increments on the Repeat rate scale in Keyboard in Control Panel.

Change method

To change the value of this entry, use the Keyboard Properties box. Repeat rate is in the Character repeat box on the Speed tab.


Mouse

HKCU\Control Panel\

Description

The Mouse subkey stores the options selected by configuring Mouse in Control Panel.


DoubleClickHeight

HKCU\Control Panel\Mouse

Data type | Range | Default value
REG_SZ | Pixels in decimal | 4

Description

Establishes the height of the rectangle that Windows 2000 uses to detect double-clicks. If sequential clicks are positioned within the rectangle defined by the values of DoubleClickHeight and DoubleClickWidth, and occur within the time specified by the value of DoubleClickSpeed, they are interpreted as double-clicks. Otherwise, they are interpreted as sequential single clicks.

Change method

To view and change the value of this entry, applications must use the SystemParametersInfo API.

Related Entries

DoubleClickSpeed

DoubleClickWidth


DoubleClickSpeed

HKCU\Control Panel\Mouse

Data type | Range | Default value
REG_SZ | 100 - 900 (milliseconds in decimal) | 500

Description

Specifies the maximum time that can elapse between mouse clicks that is interpreted as a double-click. If the time between clicks exceeds the value of this entry, the clicks are interpreted as single clicks.

Change method

To change the value of this entry, double-click Mouse in Control Panel. Click the Buttons tab and use the Double-click speed slider.


DoubleClickWidth

HKCU\Control Panel\Mouse

Data type | Range | Default value
REG_SZ | Pixels in decimal | 4

Description

Establishes the width of the rectangle that Windows 2000 uses to detect double-clicks. If sequential clicks are positioned within the rectangle defined by DoubleClickHeight and DoubleClickWidth, and occur within the time specified by DoubleClickSpeed, they are interpreted as double-clicks. Otherwise, they are interpreted as sequential single clicks.

Change method

To view and change the value of this entry, applications should use the SystemParametersInfo API.

Related Entries

DoubleClickHeight

DoubleClickSpeed


MouseSpeed

HKCU\Control Panel\Mouse

Data type | Range | Default value
REG_SZ | 0 | 1 | 2 | 1

Description

Determines how fast the cursor moves in response to movements of the mouse.

MouseSpeed, MouseThreshold1, and MouseThreshold2 determine when and by how much cursor speed is accelerated when you move the mouse rapidly.

When you move the mouse slowly, the system moves the cursor at a constant rate that is directly proportional to the rate at which you move the mouse. However, if you move the mouse fast enough to exceed the value of MouseThreshold1 or MouseThreshold2, the system can respond by accelerating the movement of the cursor, so that the cursor moves twice as fast or four times as fast as you move the mouse.

Value | Meaning
0 | No acceleration.
1 | Double at MouseThreshold1. When the mouse speed reaches or exceeds the value of MouseThreshold1, the cursor moves at twice the normal speed; that is, the cursor moves two pixels for every one pixel movement of the mouse.
2 | Double at MouseThreshold1; quadruple at MouseThreshold2. When the mouse speed reaches or exceeds the value of MouseThreshold1, the cursor moves at twice the normal speed; that is, the cursor moves two pixels for every one pixel movement of the mouse. When the mouse speed reaches or exceeds the value of MouseThreshold2, the cursor moves at four times the normal speed; that is, the cursor moves four pixels for every one pixel movement of the mouse.

Change method

To change the value of this entry, double-click Mouse in Control Panel. Click the Motion tab and use the Acceleration radio buttons. The Acceleration setting determines the following registry values:

 | None | Low | Medium | High
MouseSpeed | 0 | 1 | 2 | 2
MouseThreshold1 | 0 | 7 | 4 | 4
MouseThreshold2 | 0 | 0 | 12 | 6


MouseThreshold1

HKCU\Control Panel\Mouse

Data type | Range | Default value
REG_SZ | Pixels in decimal | 6

Description

Specifies a mouse speed that triggers accelerated cursor movement. If, within the interval between mouse interrupts, the mouse moves by more than the number of pixels specified in the value of this entry, the system can accelerate the cursor. When accelerated, the cursor moves more than one pixel for each one pixel movement of the mouse.

The amount of acceleration depends on the value of MouseSpeed. If the value of MouseSpeed is 1 or 2, cursor speed is doubled when the mouse speed reaches MouseThreshold1. If the value of MouseSpeed is 2, cursor speed is quadrupled when the mouse speed reaches MouseThreshold2.

Change method

To change the value of this entry, double-click Mouse in Control Panel. Click the Motion tab and use the Acceleration option buttons. The Acceleration setting determines the following registry values:

 | None | Low | Medium | High
MouseSpeed | 0 | 1 | 2 | 2
MouseThreshold1 | 0 | 7 | 4 | 4
MouseThreshold2 | 0 | 0 | 12 | 6

Related Entries

MouseSpeed

MouseThreshold2


MouseThreshold2

HKCU\Control Panel\Mouse

Data type | Range | Default value
REG_SZ | Pixels in decimal | 10

Description

Specifies a mouse speed that triggers accelerated cursor movement. If, within the interval between mouse interrupts, the mouse moves by more than the number of pixels specified in the value of this entry, the system can accelerate the cursor. When accelerated, the cursor moves more than one pixel for each one pixel movement of the mouse.

The amount of acceleration depends on the value of MouseSpeed. If the value of MouseSpeed is 1 or 2, cursor speed is doubled when the mouse speed reaches MouseThreshold1. If the value of MouseSpeed is 2, cursor speed is quadrupled when the mouse speed reaches MouseThreshold2.

Change method

To change the value of this entry, double-click Mouse in Control Panel. Click the Motion tab, and then use the Acceleration option buttons. The Acceleration setting determines the following registry values:

 | None | Low | Medium | High
MouseSpeed | 0 | 1 | 2 | 2
MouseThreshold1 | 0 | 7 | 4 | 4
MouseThreshold2 | 0 | 0 | 12 | 6

Related Entries

MouseSpeed

MouseThreshold1


SnapToDefaultButton

HKCU\Control Panel\Mouse

Data type | Range | Default value
REG_SZ | 0 | 1 | 0

Description

Determines whether the snap-to-default feature is enabled. If the value of the entry is 1, the cursor is always positioned over the default button when you open a dialog box, .

Value | Meaning
0 | Disables snap-to-default feature.
1 | Enables snap-to-default feature.

Change method

To change the value of this entry, use the Mouse Properties box in Control Panel; the Snap to default box is on the Motion tab.


SwapMouseButtons

HKCU\Control Panel\Mouse

Data type | Range | Default value
REG_SZ | 0 | 1 | 0

Description

Determines whether the standard functions of the right and left mouse buttons are reversed. If they are reversed, the right button performs normal select and drag functions and the left button opens context menus and performs special drag operations.

Value | Meaning
0 | Not reversed.
1 | Reversed.

Change method

To change the value of this entry, use the Mouse Properties box in Control Panel; the Button configuration box is on the Buttons tab.


Patterns

HKCU\Control Panel\

Description

The Patterns subkey contains entries that specify the colors of desktop patterns.

Change method

To change the values of the entries in this subkey, double-click Display in Control Panel. Click the Background tab, click the Pattern button, and then select a pattern from the list. You can edit the pattern by clicking the Edit Pattern button.


<Pattern>

HKCU\Control Panel\Patterns

Data type | Range | Default value
REG_SZ | (None) | b1 b2 b3 b4 b5 b6 b7 b8 (in decimal) | 170 85 170 85 170 85 170 85

Description

Represents a pattern.

Change method

To change the values of the entries in this subkey, double-click Display in Control Panel. Click the Background tab, click the Pattern button, and then select a pattern from the list. You can edit the pattern by clicking the Edit Pattern button.

Note Image Note

The <Pattern> entry is a variable representing the entries under the HKCU\Control Panel\Patterns subkey. It does not actually appear in the registry. This variable entry is used to display information that is common to the entries in the Patterns subkey.

The values (b1 – b8) define a two-color pattern bitmap that is 8 pixels wide and 8 pixels high. Each b# value specifies the pattern for one row of the bitmap. The b# values are 8-bit binary values that are entered in decimal. The bits in each b# value represent a row of 8 pixels. If a bit is set to 0, the pixel it defines is set to the background color. If a bit is set to 1, the pixel it defines is set to the foreground color.

For example, if you set the b1 value to the decimal value 128, the top row of pixels in the bitmap appears as the binary equivalent, 10000000. The system interprets this to mean that the first pixel has the foreground color and the seven remaining pixels have the background color.

The background color is determined by the value of Background and the foreground color is determined by the value of WindowText, both of which appear in the Colors subkey.

Each entry in the Patterns subkey is named for and describes a pattern and each has the REG_SZ data type.

Related Entries

Colors subkey


PowerCfg

HKCU\Control Panel\

Description

The PowerCfg subkey stores information about the power management policies currently in use on the computer.

Change method

To change these entries, double-click Display in Control Panel. Click the Screen Saver tab, click the Power button, and then use the drop-down lists in the Power schemes and Settings for Always On power scheme boxes.


Screen Saver.<Screensaver-name>

HKCU\Control Panel\

Description

Represents a screen saver and stores entries that apply only to that screen saver.

The Control Panel subkey can contain subkeys representing each screen saver installed on Windows 2000. The Screen Saver.<Screensaver-name> subkey is a variable representing these subkeys. Each Screen Saver.<Screensaver-name> subkey stores data that is specific to a screen saver.

Change method

To change the screen saver, double-click Display in Control Panel. Click the Screen Saver tab, and then select a screen saver from the drop-down list box.

Note Image Note

The Screen Saver.<Screensaver-name> subkey is a variable representing the screen saver subkeys in HKCU\Control Panel subkey. It does not actually appear in the registry. This subkey entry displays information which is common to screen savers and is stored in the Control Panel subkey.


<element-name>

HKCU\Control Panel\Screen Saver.<Screensaver-name>

Description

Each <element-name> entry represents an element of the screen saver that can be altered by the user.

Change method

To change the screen saver elements, double-click Display in Control Panel. Click the Screen Saver tab, and then click the Settings button.

Note Image Note

The <element-name> entry is a variable representing the entries under the HKCU\Control Panel\Screen Saver.<Screensaver-name> subkey. It does not actually appear in the registry. This variable entry displays information that is common to the entries in the Screen Saver.<Screensaver-name> subkey.


Environment

HKCU\

Description

The Environment key stores the values of environment variables that can be set by users. Each entry in this key associates an environment variable with the path that is substituted for the variable. The default values for these entries are defined in the user's profile.

Change method

To change the values of entries in this key, use System in Control Panel. Click the Advanced tab, and then click Environment Variables. These entries appear in the User variables for user-name section.

Activation method

To make changes to the entries in this key effective, you must log off and then log on again. Changes to these variables take effect when a non-Windows-based application is run or when the command prompt is used.

Tip Image Tip

To change the values of entries in this key, use System in Control Panel. Click the Advanced tab, and then click Environment Variables. These entries appear in the User variables for user-name section.

Caution Image Caution

The data type of entries in this key must be REG_EXPAND_SZ. If a user or application changes the data type, the system will not replace the variable with its intended value.


TEMP

HKCU\Environment

Data type | Range | Default value
REG_EXPAND_SZ | Path | %USERPROFILE%\Temp

Description

Specifies the path represented by the TEMP variable.

Change method

To change the value of this entry, use System in Control Panel. Click the Advanced tab and then click Environment Variables. TEMP appear in the User variables for user-name section.

Activation method

To make changes to the entries in this subkey effective, you must log off and then log on again. Changes to these variables take effect when a non-Windows-based application is run or when the command prompt is used.

Caution Image Caution

The data type of entries in this subkey must be REG_EXPAND_SZ. If a user or application changes the data type, the system will not replace the variable with its intended value.


TMP

HKCU\Environment

Data type | Range | Default value
REG_EXPAND_SZ | Path | %USERPROFILE%\Temp

Description

Specifies the path represented by the TMP variable.

Change method

To change the value of this entry, use System in Control Panel. Click the Advanced tab and then click Environment Variables. TMP appear in the User variables for user-name section.

Activation method

To make changes to the entries in this subkey effective, you must log off and then log on again. Changes to these variables take effect when a non-Windows-based application is run or when the command prompt is used.

Caution Image Caution

The data type of entries in this subkey must be REG_EXPAND_SZ. If a user or application changes the data type, the system will not replace the variable with its intended value.


Keyboard Layout

HKCU\

Description

The Keyboard Layout key stores information about the installed keyboard layouts.


Attributes

HKCU\Keyboard Layout

Data type | Range | Default value
REG_DWORD | 0 | 0x10000 (in hexadecimal) | 0

Description

Specifies which key is used to turn off the Caps Lock.

Value | Meaning
0 | CAPS LOCK key is used.
0x10000 | SHIFT key is used.

Change method

To change the value of this entry, double-click Keyboard in Control Panel. Click the Input Locales tab, and then select a radio button from the To turn off Caps Lock box.


Preload

HKCU\Keyboard Layout\

Description

The Preload subkey stores the codes for each keyboard layout chosen by the user. Windows 2000 uses this information to restore the keyboard layout when the user logs back on.

Each entry in the Preload subkey represents a keyboard layout selected by the user where the name of the entry is a decimal number beginning with 1. The 1 entry identifies the user's default layout.

Change method

To change the keyboard layout, double-click Keyboard in Control Panel. Click the Input Locales tab, and then click the Add button in the Installed input locales box.


<layout-number>

HKCU\Keyboard Layout\Preload

Data type | Range | Default value
REG_SZ | Keyboard layout code in decimal | US English: 00000409

Description

Represents a keyboard layout.

Each entry in the Preload subkey represents a keyboard layout selected by the user. The entries have the following format:
Number REG_SZ Keyboard layout code in decimal
where the name of the entry is a decimal number beginning with 1. The 1 entry identifies the user's default layout.

For example,
1 REG_SZ 00000409
2 REG_SZ 0000040A
indicates that the user has selected keyboard layout 00000409 (U.S. English) and keyboard layout 0000040A (Spanish). These layouts will be loaded when the user logs on.

The keyboard layout code consists of the locale ID, which identifies the geographic variation of the spoken language chosen by the user, and a 4-digit code which indicates whether the keyboard layout is the default layout for the locale.

Change method

To change the keyboard layout, double-click Keyboard in Control Panel. Click the Input Locales tab, and then click the Add button in the Installed input locales box.

Note Image Note

The <layout-number> entry is a variable representing the entries in the Substitutes subkey under the HKCU\Keyboard Layout\Preload subkey. It does not actually appear in the registry. This variable entry displays information which is common to the entries in the Preload subkey.


Substitutes

HKCU\Keyboard Layout\

Description

The Substitutes subkey stores the codes of alternative keyboard layouts preferred by the user. The system checks the user's Substitutes subkey when loading the keyboard layout, and if a substitute is specified, the corresponding layout is substituted for the default layout. The Substitutes key has no entries unless the user has selected a substitute keyboard layout.

Change method

To change the keyboard layout, double-click Keyboard in Control Panel. Click the Input Locales tab, and then click the Add button in the Installed input locales box.


<Keyboard layout code>

HKCU\Keyboard Layout\Substitutes

Data type | Range | Default value
REG_SZ | Keyboard layout code | Keyboard layout code

Description

Represents a keyboard layout.

These entries associate a standard layout with a preferred alternative. They have the following format:
Keyboard layout code (standard) REG_SZ Keyboard layout code (preferred alternative)

For example,
00000409 REG_SZ 00010409
indicates that each time the 00000409 (U.S. English) keyboard layout is called, the system should substitute the preferred alternative, the 00010409 (Dvorak U.S. English) keyboard layout.

Change method

To change the keyboard layout, double-click Keyboard in Control Panel. Click the Input Locales tab, and then click the Add button in the Installed input locales box.

Note Image Note

The <Keyboard layout code> entry is a variable representing the entries in the Substitutes subkey under the HKCU\Keyboard Layout key. It does not actually appear in the registry. This variable entry displays information which is common to the entries in the Substitutes subkey.


Toggle

HKCU\Keyboard Layout\

Description

The Toggle subkey determines which key sequences can be used to toggle between input locales.


Hotkey

HKCU\Keyboard Layout\Toggle

Data type | Range | Default value
REG_SZ | 1 | 2 | 3 | 4 | 1

Description

Determines whether a key sequence can be used to shift between input locales.

Value | Meaning
1 | Key Sequence enabled; use Left-ALT+SHIFT to switch between locales.
2 | Key Sequence enabled; use CTRL+SHIFT to switch between locales.
3 | Key Sequences disabled.
4 | If the default locale is Thai, the accent grave key toggles input locales; otherwise key sequences are disabled.

Change method

To change the value of this entry, double-click Keyboard in Control Panel. Click the Input Locales tab, click Change Key Sequence, and select an option from the Change Key Sequence dialog box.


Network

HKCU\

Description

The Network key stores information about mapped network drives. Each subkey in Network represents a drive that is connected to the computer and will be reconnected when the user logs on again. The subkeys are named for the drive letter to which the drive is mapped. The system adds a Drive letter subkey to the registry when you map a drive and select the Reconnect at Logon option. The entries in the Drive letter subkeys store data that is used to reconnect the drive.

Change method

To map to a network drive, from the Tools menu select Map Network Drive. In the Folder box, type the path to the drive, and then click Finish.


<Drive letter>

HKCU\Network\

Description

Represents a disk drive recognized by the system

Change method

To map to a network drive, from the Tools menu select Map Network Drive. In the Folder box, type the path to the drive, and then click Finish.

Note Image Note

The <Drive letter> subkey is a variable representing the subkeys under the HKCU\Network key. It does not actually appear in the registry. This variable entry displays information which is common to the subkeys under this key.

The subkeys are named for the drive letter to which the drive is mapped. The system adds a <Drive letter> subkey to the registry when you map a drive and select the Reconnect at Logon option. The entries in the <Drive letter> subkeys store data that is used to reconnect the drive.


ConnectionType

HKCU\Network\<Drive letter>

Data type | Range | Default value
REG_DWORD | 1 | 2 | 1

Description

Specifies how the drive is connected to the local computer.

Value | Meaning
1 | Drive redirection.
2 | Print redirection.


ProviderName

HKCU\Network\<Drive letter>

Data type | Range | Default value
REG_SZ | Network name | Microsoft Windows Network

Description

Specifies the network provider used to make the connection.


ProviderType

HKCU\Network\<Drive letter>

Data type | Range | Default value
REG_DWORD | <provider-number> | <provider-number>

Description

Specifies a constant that identifies the provider used to make the connection. The value for the Microsoft LanMan provider is 0x20000. Other values are assigned by Microsoft to third-party providers.


RemotePath

HKCU\Network\<Drive letter>

Data type | Range | Default value
REG_SZ | UNC sharename | Path

Description

Specifies the UNC (universal naming convention) name for the directory to which the drive is mpped. For example, \\Computer1\Drive1.


UserName

HKCU\Network\<Drive letter>

Data type | Range | Default value
REG_SZ | Username (including domain name) | (The user name of the current user.)

Description

Identifies the user who established the connection to the shared directory. This entry stores the name entered in the Connect As box in the Map Network Drive dialog box.


Printers

HKCU\

Description

The Printers subkey in HKEY_CURRENT_USER stores user preferences for printers.

Related Entries

Printers subkey for local printers in SOFTWARE

Printers subkey for local printers in SYSTEM

Printers subkey for LanMan Print Services network printers


Software

HKCU\

Description

The Software subkey stores program variables that are specific to the current user. The system stores some of its variables in the subkeys in Software. In addition, the Software subkey contains subkeys representing the vendors that produced the software running on the system, including Microsoft.

Related Entries

Software subkey (HKLM)


CheyenneDMG

HKCU\Software\

Description

The CheyenneDMG subkey stores configuration data for programs produced by Cheyenne Directory Management Group. For Windows 2000, this includes the Directory Service Migration Tool, a snap-in that facilitates migration from NetWare to Active Directory.


pg2MaxObjPerView

HKCU\Software\CheyenneDMG

Data type | Range | Default value
REG_DWORD | 0x64 (100) - 0xFFFFFFFF objects | 0x2710 (10,000 objects)

Description

Determines the maximum number of objects that the Directory Migration Service Tool can discover in a NetWare Directory Services database before it alerts the user that the scope is too large for efficient discovery.

If the number of objects discovered exceeds the value of this entry, then the system displays a message explaining that the database is unusually large and is not practical to retrieve in a single discovery operation. The message recommends that the user stop the current discovery operation and divide the discovery operation into smaller units. The user can choose to proceed with the discovery operation, which might take a protracted period of time to complete, or to stop the operation.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


Microsoft

HKCU\Software\

Description

The Microsoft subkey stores configuration data for Microsoft programs running on the computer. The subkeys in the Microsoft subkey represent each of the programs. The entries in the program subkeys are specific to the current user.

The Microsoft subkey in HKEY_CURRENT_USER stores entries that apply only to the current user of the computer. There is also a Software\Microsoft subkey in HKEY_LOCAL_MACHINE which stores entries that apply to all users of the computer.

Related Entries

Microsoft subkey (HKLM)


Command Processor

HKCU\Software\Microsoft\

Description

The Command Processor subkey stores user preferences for the command processor (Cmd.exe). Entries in the Command Processor subkey can also appear in HKEY_LOCAL_MACHINE. If both appear, the values in HKEY_CURRENT_USER take precedence over the values in HKEY_LOCAL_MACHINE. Command-line settings entered in Cmd.exe take prescedence over registry settings.

Change method

To change the values of the entries in this subkey, use Command Processor (Cmd.exe).

Note Image Note

For more information about Command Processor, see Windows 2000 Help.

Related Entries

Command Processor in HKLM

Console


AutoRun

HKCU\Software\Microsoft\Command Processor

Data type | Range | Default value
REG_SZ | list of commands | There is no default value for this entry.

Description

Contains commands which are executed each time you start Cmd.exe.

Change method

To change the value of this entry, use Command Processor (Cmd.exe).

Note Image Note

AutoRun can appear in HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If both appear in the registry, the value of the entry in HKEY_CURRENT_USER takes precedence over the value in HKEY_LOCAL_MACHINE.

The command line switches take precedence over the registry settings.

Tip Image Tip

To disable AutoRun for one use of the command processor, at the command prompt, type CMD /D.

For more information about the AutoRun feature, at the command prompt, type CMD /?.

Related Entries

AutoRun in HKLM


CompletionChar

HKCU\Software\Microsoft\Command Processor

Data type | Range | Default value
REG_DWORD | 0x0 | 0x1 - 0x1F | 0x20 | 0x40

Description

Specifies a character that activates the filename completion feature in the command processor (Cmd.exe).

To specify a character, enter the hexadecimal value of an ASCII control character other than 0x20 (space). For example, 0x4 represents Ctrl-D and 0x6 represents Ctrl-F. To disable the file name completion feature, set the value of this entry to 0x0.

Change method

To change the value of this entry, use Command Processor (Cmd.exe).

Note Image Note

CompletionChar and PathCompletionChar can appear in HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If both appear in the registry, the value of the entry in HKEY_CURRENT_USER takes precedence over the value in HKEY_LOCAL_MACHINE.

Tip Image Tip

To enable or disable file name completion and directory name completion for one use of the command processor, at the command prompt, type CMD /F:ON (enable) or CMD /F:OFF (disable). This command sets the completion character to CTRL+F (0x6).

For more information about the file name completion feature, at a command prompt, type CMD /?

Related Entries

PathCompletionChar

CompletionChar in HKLM


DefaultColor

HKCU\Software\Microsoft\Command Processor

Data type | Range | Default value
REG_DWORD | 0x00000000 | 0x00000001 - 0x000000FE | 0

Description

Specifies a default background color and text color for the command processor window. The value consists of two hexadecimal digits. The first digit specifies the background color; the second digit specifies the text color. The hexadecimal values correspond to colors in the following table.

Hexadecimal value | Color
0 | Black
1 | Blue
2 | Green
3 | Aqua
4 | Red
5 | Purple
6 | Yellow
7 | White
8 | Gray
9 | Light Blue
A | Light Green
B | Light Aqua
C | Light Red
D | Light Purple
E | Light Yellow
F | Bright White

This entry is used only when its value is valid and not 0x0, and the user has not specified the window color by using the COLOR or /T commands. Values are not valid if the background color and the text color are identical, such as 0x55. If the value of this entry is not valid or 0x0, and the user has not entered a command to change the color, the command processor uses the colors specified for the console window in which the command processor runs.

Change method

To change the colors of a command window, click the system menu icon in the title bar, and then select either Defaults to change the settings for all instances of that window, or Properties to change the current window only. Click the Colors tab and use the color well options to change the values. This will change the colors for all console windows. To only change the colors for the command windows, you must edit the registry.

Related Entries

DefaultColor in HKLM

ScreenColors


DelayedExpansion

HKCU\Software\Microsoft\Command Processor

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether the command processor supports delayed expansion of environment variables. If the value of this entry is 1, the command processor interprets an exclamation mark, !, as an environment variable that is expanded only when used.

By default, the command processor expands variables when it reads a line of text. However, you can direct the command processor to expand a variable only when it is used. This permits you to include variables in compound conditional statements, and prevent them from being set before they are tested.

Value | Meaning
0 | Delayed expansion is not supported. The command processor expands environment variables when it reads them. It does not support exclamation marks as delayed variables.
1 | Delayed expansion is supported. The system expands environment variables surrounded by exclamation marks, such as !VAR!, only when they are used.

Change method

To change the value of this entry, start the Command Processor (Cmd.exe) and type cmd /v:on.

Note Image Note

DelayedExpansion can appear in HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If both appear in the registry, the value of the entry in HKEY_CURRENT_USER takes precedence over the value in HKEY_LOCAL_MACHINE.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry. Even when this entry appears in the registry, the setting of the command line switch, /V, takes precedence over this value.

Tip Image Tip

For more details, start the Command Processor (Cmd.exe) and type help set or type cmd /? and read the entry on the /V command.

Related Entries

DelayedExpansion (in HKLM)


EnableExtensions

HKCU\Software\Microsoft\Command Processor

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether the extensions to the command processor (Cmd.exe), such as chdir and setlocal, are enabled. Because the extensions might be incompatible with a command-script language, Windows 2000 lets you disable the extensions. This entry affects all extensions. You cannot use it to enable or disable extensions selectively. You can, however, disable extensions for a particular invocation of Cmd.exe by using the /E:OFF switch.

Value | Meaning
0 | Disabled
1 | Enabled

Change method

To change the value of this entry, use Command Processor (Cmd.exe).

Related Entries

EnableExtensions in HKLM


PathCompletionChar

HKCU\Software\Microsoft\Command Processor

Data type | Range | Default value
REG_DWORD | 0x0 | 0x1 - 0x1F | 0x20 | 0x40

Description

Specifies a character that activates the directory name completion feature in the command processor (Cmd.exe).

To specify a character, enter the hexadecimal value of an ASCII control character other than 0x20 (space). For example, 0x4 represents Ctrl-D, and 0x6 represents Ctrl-F. To disable the directory name completion feature, set the value of this entry to 0x0.

Change method

Use Command Processor (Cmd.exe) to change the value of this entry.

Note Image Note

CompletionChar and PathCompletionChar can appear in HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If both appear in the registry, the value of the entry in HKEY_CURRENT_USER takes precedence over the value in HKEY_LOCAL_MACHINE.

The command line switches take precedence over the registry settings.

Tip Image Tip

To enable or disable directory name completion for one use of the command processor, at the command prompt, type CMD /F:ON (enable) or CMD /F:OFF (disable). This command sets the completion character to CTRL+D (0x4).

For more information about the path completion feature, at a command prompt, type CMD /?

Related Entries

CompletionChar

PathCompletionChar in HKLM


Driver Signing

HKCU\Software\Microsoft\

Description

The Driver Signing subkey in HKCU stores entries for the code signing feature for Windows 2000. The entries in this subkey apply only to the current user of the computer.

Microsoft digitally signs driver files to affirm that the driver software has been tested with Windows and has not been altered since it was tested by Microsoft.

Note Image Note

The entries in this subkey apply only to the current user of the computer. The entries in the Driver Signing subkey in HKLM apply to all users of the computer.

The system adds this subkey to the registry when you change the default value of one of its entries.

Tip Image Tip

For more information about driver signing and code signing, see Code signing for Windows 2000 in Windows 2000 Help.

Related Entries

Driver Signing (HKLM)


Policy

HKCU\Software\Microsoft\Driver Signing

Data type | Range | Default value
REG_DWORD | 0 | 1 | 2 | 1

Description

Determines how the system responds when a user tries to install device driver files that are not digitally signed.

Value | Meaning
0 | Ignore. The system proceeds with the installation even if it includes unsigned files.
1 | Warn. The system notifies the user that files are not digitally signed and lets the user decide whether to stop or to proceed with the installation and permit unsigned files to be installed.
2 | Block. The system will not install unsigned files. As a result, the installation stops, and none of the files in the driver package are installed.

This entry applies only to the current user of the computer. However, if a stricter setting is configured for all users of the computer (in Policy in HKLM) or a user Group Policy establishes a stricter setting (in BehaviorOnFailedVerify), then this value is ignored for the current user.

This entry stores the option selected in the File signature verification section of the Driver Signing Options dialog box when the Apply setting as system default box is not selected. If the box is selected, then the selection applies to all users of the computer and it is stored in the value of Policy in HKLM.

Change method

To change the value of this entry, use System in Control Panel. Click the Hardware tab, click Driver Signing, and then select an option in the File signature verification section. (Do not select the Apply setting as a system default box.)

Note Image Note

The system adds this entry to the registry when you use System in Control Panel to change the default value.

This entry applies to all users of the computer. The Policy entry also can appear in the HKCU\SOFTWARE\Microsoft\Driver Signing for a particular user. Also, you can use the Code signing for device drivers Group Policy to add the BehaviorOnFailedVerify entry to the registry.

Related Entries

Policy (HKLM)

BehaviorOnFailedVerify (Group Policy)


File Manager

HKCU\Software\Microsoft\

Description

The File Manager subkey is not used by and has no effect on Windows 2000.


Ntbackup

HKCU\Software\Microsoft\

Description

The Ntbackup subkey contains entries that store configuration data for Windows Backup (Ntbackup.exe). Windows Backup enables you to back up files to tape and restore files from tape. You can use Windows Backup to back up the files in which the registry is stored.

When you configure Windows Backup, it adds its default subkeys and entries to the registry. Many of these entries are no longer used by Windows Backup. Other entries are maintained by the system and should never be changed by editing the registry.

Note Image Note

When you upgrade from a previous version of Windows on which you used Windows Backup, delete the subkeys and entries in the Ntbackup subkey before running the upgraded version of Windows Backup. This assures that registry entries are appropriate to the most recent version of Windows Backup.

To run Backup, click Start, point to Programs, point to Accessories, point to System Tools, and then click Backup.


Backup Engine

HKCU\Software\Microsoft\Ntbackup\

Description

The Backup Engine subkey stores user preference information for the Backup utility.

Caution Image Caution

Do not change the values of the entries in this subkey. These entries are maintained by the system, and modifying them might cause Backup to improperly save or restore data, resulting in data loss.


Backup files inuse

HKCU\Software\Microsoft\Ntbackup\Backup Engine

Data type | Range | Default value
REG_SZ | 0 | 1 | 0

Description

Determines whether Backup backs up open files.

Value | Meaning
0 | Backup skips open files.
1 | Backup backs up open files.

Caution Image Caution

Backup can lock files temporarily while backing them up or restoring them. Locks on open files can interfere with the operation of applications and services, such as WINS and DHCP.


Use fast file restore

HKCU\Software\Microsoft\Ntbackup\Backup Engine

Data type | Range | Default value
REG_SZ | 0 | 1 | 1

Description

Determines whether the fast file restore feature is enabled.

Value | Meaning
0 | Disables fast file restore.
1 | Enables fast file restore.

Tip Image Tip

Fast file restore is desirable for most tasks. However, you should disable fast file restore if you encounter problems restoring a file that resides entirely on the last tape of a multiple tape restore operation. Change the value of this entry to 0, rerun Backup, and then change the value of this entry back to 1.


Translators

HKCU\Software\Microsoft\Ntbackup\

Description

The Translators subkey stores translator information used by Backup.


Sytos Plus ECC Flag

HKCU\Software\Microsoft\Ntbackup\Translators

Data type | Range | Default value
REG_SZ | 0 | 1 | 2 | 2

Description

Overrides an incorrect setting for the backup error correction code (ECC). This entry is designed to resolve translation errors encountered when restoring or cataloging a Sytos Plus tape under Windows.

Value | Meaning
0 | Off - Backup assumes that there is no software ECC on the tape. This value is recommended for 4 mm DAT, 8 mm DAT, and ¼ in. 525 tapes.
1 | On - Backup assumes that there is software ECC on the tape. This value is recommended for ¼ in. 150 tapes.
2 | Auto - Backup determines whether a Sytos Plus tape was written with software ECC by checking the data on the tape.


User Interface

HKCU\Software\Microsoft\Ntbackup\

Description

The User Interface subkey stores user preference information for Backup.

Caution Image Caution

Do not change the values of the entries in this subkey. These entries are maintained by the system, and modifying them might cause Backup to improperly save or restore data, resulting in data loss.


Wait time

HKCU\Software\Microsoft\Ntbackup\User Interface

Data type | Range | Default value
REG_SZ | 0 - 32767 seconds (in decimal) | 30

Description

Determines how long Backup waits for a file to be released when it is being used by another process. When the time specified by the value of this entry expires, Backup stops trying to back up the file and proceeds to other files.


Perfmon

HKCU\Software\Microsoft

Description

The Perfmon subkey stores user-specific configuration data for Performance Monitor 4 (Perfmon4.exe), a performance monitoring tool designed for Windows NT 4.0 and earlier. In Windows 2000, Performance Monitor 4 has been replaced by System Monitor, but Performance Monitor 4 is included on the Windows 2000 Resource Kit CD-ROM for compatibility with earlier systems.

Note Image Note

The Perfmon subkey appears in the registry the first time you use Performance Monitor 4. You might need to run Performance Monitor 4 more than once for all of the default entries to appear in the Perfmon subkey.

The entries in the Perfmon subkey only apply to Performance Monitor 4, a tool provided only on the Windows 2000 Resource Kit CD. They do not affect System Monitor. To configure System Monitor, use the System Monitor Properties dialog box.


CapPercentsAt100

HKCU\Software\Microsoft\Perfmon

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether Performance Monitor 4 (Perfmon4.exe) displays percentage values greater than 100%. By default, Performance Monitor 4 displays 100% whenever it reads a value greater than 100 for a percentage counter. Changing the default value enables Performance Monitor 4 to display more accurate data for counters that combine data from more than one component into a single value.

Value | Meaning
0 | Display percentages greater than 100%. The percentage values are limited to 100% times the number of components represented by the counter value.
1 | Limit percentage values to 100%.

The default value prevents Performance Monitor 4 from displaying erroneous values. However, some counters display values that consist of data from more than one component. The total value for each component cannot be greater than 100%, but the total for all components can be as high as 100% times the number of components.

For example, the "Physical Disk: % Disk Time: Total" performance counter sums the percentage of active time of each physical disk. The resulting percentage is a simple sum of active time; it is not divided by the number of physical disks on the computer. As a result, the value reported to Performance Monitor 4 can be as great as 100% times the number of physical disks but, by default, Performance Monitor 4 cannot report a value greater than 100%. If the value of this entry is 1, Performance Monitor 4 will display values up to 100% times the number of physical disks on the computer.

Activation method

Changes to this value take effect the next time you start Performance Monitor 4.

Note Image Note

This entry is only applies to Performance Monitor 4 (Perfmon4.exe), a tool provided only on the Windows 2000 Resource Kit CD. It does not affect System Monitor. To configure System Monitor, use the System Monitor Properties dialog box.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

This entry changes the Performance Monitor 4 display for all performance objects and counters, not just those that display data for multiple components in a single value. Therefore, if the value of this entry is 0 and a single-component counter returns an erroneous value greater than 100%, Performance Monitor 4 will display it.

When Performance Monitor 4 calculates values for the Processor performance object, it divides the values it collects by the number of processors in the computer. Because the number of components is factored into the percentage calculation, the resulting percentage represents the percentage of total processor capacity. This value cannot be greater than 100% regardless of the value of this entry.


DataTimeOut

HKCU\Software\Microsoft\Perfmon

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF milliseconds | 0x4E20 (20 seconds)

Description

Determines how long Performance Monitor 4 (Perfmon4.exe) waits for data from its data-collection thread. If the thread does not return data within the time specified by the value of this entry, Performance Monitor 4 ignores the data and displays a value of 0 for the counter.

Consider increasing the value of this entry when you monitor remote computers over a slow connection, such as a dial-up connection using a modem. Because the program implements any value you enter, be sure to increase in small increments and test your changes.

Activation method

Changes to this value take effect the next time you start Performance Monitor 4.

Note Image Note

This entry is only applies to Performance Monitor 4 (Perfmon4.exe), a tool provided only on the Windows 2000 Resource Kit CD. It does not affect System Monitor. To configure System Monitor, use the System Monitor Properties dialog box.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


MonitorDuplicateInstances

HKCU\Software\Microsoft\Perfmon

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether Performance Monitor 4 (Perfmon4.exe) recognizes and displays more than one instance of an object with a given name.

For example, this entry determines whether Performance Monitor 4 displays two instances of the Microsoft Word process, both named Winword.exe.

Value | Meaning
0 | Performance Monitor 4 displays only one instance of the named object. All data collected for that name is associated with the same instance.
1 | Performance Monitor 4 can display data for multiple instances with the same name.

Activation method

Changes to this value take effect the next time you start Performance Monitor 4.

Note Image Note

This entry is only applies to Performance Monitor 4 (Perfmon4.exe), a tool provided only on the Windows 2000 Resource Kit CD. It does not affect System Monitor. To configure System Monitor, use the System Monitor Properties dialog box.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


ReportEventsToEventLog

HKCU\Software\Microsoft\Perfmon

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether Performance Monitor 4 (Perfmon4.exe) records error and warning events when it fails to retrieve data or retrieves unreadable or uninterpretable data (such as negative time). These events appear in the Application Log in Event Viewer.

When Performance Monitor 4 receives uninterpretable data; it displays 0 or 100 for the data point, depending on the counter type.

Value | Meaning
0 | Performance Monitor 4 does not log data errors or notify the user that it has received uninterpretable data.
1 | Performance Monitor 4 writes an error to the Application Log when it receives uninterpretable data.

Activation method

Changes to this value take effect the next time you start Performance Monitor 4.

Note Image Note

This entry is only applies to Performance Monitor 4 (Perfmon4.exe), a tool provided only on the Windows 2000 Resource Kit CD. It does not affect System Monitor. To configure System Monitor, use the System Monitor Properties dialog box.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

EventLogLevel


Windows

HKCU\Software\Microsoft\

Description

The Windows subkey stores configuration data for the programs running on the Win32 subsystem. The subkeys of the Windows subkey represent versions of the Win32 subsystem, such as CurrentVersion. Each version subkey contains subkeys representing programs that run on that version of the subsystem.

The Windows subkey in HKEY_CURRENT_USER stores entries that apply only to the current user of the computer. There is also a SOFTWARE\Microsoft\Windows subkey in HKEY_LOCAL_MACHINE that stores entries that apply to all users of the computer.

Related Entries

Windows subkey (HKLM)


CurrentVersion

HKCU\Software\Microsoft\Windows\

Description

The CurrentVersion subkey stores configuration data for programs running on the Win32 subsystem. The subkeys of CurrentVersion represent programs that run on the current version of Win32 subsystem and store user-specific configuration data for those programs.


Explorer

HKCU\Software\Microsoft\Windows\CurrentVersion\

Description

The Explorer subkey stores configuration data for Windows Explorer and the Windows interface, including the Start menu, the desktop, common folders, and Control Panel.


Advanced

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\

Description

The Advanced subkey stores the settings of options on the Taskbar and Start Menu Properties dialog box.

Change method

To change the value of entries in this subkey, use the Taskbar and Start Menu Properties dialog box. Do not edit the registry.


IntelliMenus

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

Data type | Range | Default value
REG_SZ | YES | No | YES

Description

Enables and disables personalized menus.

This entry stores the setting of the Use Personalized Menus check box on the Taskbar and Start Menu Properties dialog box.

Windows 2000 personalizes long menus by moving recently used items to the top of the menu and by hiding items that have not been used recently. Users can display the hidden items by clicking an arrow to extend the menu.

Value | Meaning
YES | Enables personalized menus.
No | Disables personalized menus.

Change method

To change the value of this entry, click Start, click Settings, click Taskbar & Start Menu. This entry corresponds to the Use Personalized Menus check box on the General tab of the Taskbar and Start Menu Properties dialog box. Do not edit the registry.

Note Image Note

This entry can be superceded by a policy included in Windows 2000. While the Disable Personalized Menus policy is in effect, the system removes the Use Personalized Menus check box from the Start Menu and ignores this entry. The setting of the Disable Personalized Menus policy is stored in the value of Intellimenus in the Policies subkey. If users cannot find the Use Personalized Menus option, check the setting of the Disable personalized menus policy.

Personalized menus require user tracking. If the Disable user tracking policy is in effect, Group Policy sets the value of NoInstrumentation to 1. As a result, the system disables user tracking and personalized menus and ignores the value of Intellimenus.

Tip Image Tip

For detailed information about particular Group Policies, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

Related Entries

Intellimenus (Policies subkey)

NoInstrumentation


DesktopProcess

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether the components of Windows 2000 Explorer run in a single process or in two separate processes.

Value | Meaning
0 | All of the components of Windows Explorer (Explorer, Desktop, and Taskbar) run as separate threads in a single, multithreaded process called Explorer.exe.
1 | All instances of Windows Explorer run in one process and the Desktop and Taskbar run in a separate process. Both processes are called Explorer.exe.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Tip Image Tip

To verify that DesktopProcess is enabled, use the Processes tab in Task Manager. If the value of DesktopProcess is 1, at least two instances of the Explorer.exe process should appear in the list of processes (one for the Desktop and Taskbar and one for Windows Explorer). For each additional instance of Windows Explorer, a new instance of Explorer.exe should appear in the list of processes.

Caution Image Caution

Enabling DesktopProcess can interfere with the functions of Windows Explorer if the computer is not equipped to run all processes efficiently. Do not set the value of DesktopProcess to 1 unless the computer has a Pentium processor (or equivalent) and at least 16 MB of physical random access memory.


Shell Folders

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\

Description

The entries in the Shell Folders subkey are not used by and have no effect on Windows 2000. Paths to the Windows Explorer folders are stored in the User Shell Folders subkey. For more information on shell folders, search the Platform Software Development Kit (SDK) documentation in the MSDN Library at http://msdn.microsoft.com.


Shutdown Setting

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer

Data type | Range | Default value
REG_DWORD | 1 | 2 | 4 | 8 | 10 | 20 | 40 | 80 | 2

Description

Specifies the shutdown setting.

Value | Meaning
0x1 | Log off. Ends your session, leaving the computer running on full power.
0x2 | Shut down. Ends your session and shuts down Windows 2000 so that you can safely turn off power.
0x4 | Restart. Ends your session, shuts down Windows 2000, and starts Windows 2000 again.
0x8 | Restart in MS-DOS mode. Ends your session, shuts down Windows 2000, and starts MS-DOS mode. (Restart in MS-DOS mode is not available in Windows 2000)
0x10 | Stand by. Maintains your session, keeping the computer running on low power with data still in memory. (This setting requires power management hardware support.)
0x20 | Stand by (with wakeup events disabled). Maintains your session, keeping the computer running on low power with data still in memory. (This setting requires power management hardware support.)
0x40 | Hibernate. Saves your session to disk so that you can safely turn off power. Your session is restored the next time you start Windows 2000.
0x80 | Disconnect. Disconnects your session. You can reconnect to this session when you log on again. (Disconnect is available only in Terminal Server sessions.)

This value is maintained as the "last selection" for a given user. Windows 2000 writes this value whenever an option is selected from the shut down dialog.


Tips

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\

Description

The Tips subkey stores information about the display of the Welcome to Windows splash screen in Windows 2000 Professional.


Show

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Tips

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether the Welcome to Windows splash screen, Welcome.exe, is shown the next time the user logs on.

Value | Meaning
0 | The Welcome to Windows splash screen will not be shown the next time the user logs on.
1 | The Welcome to Windows splash screen will be shown the next time the user logs on.

Change method

To change the value of this entry for the current user, use the Show this screen at startup check box on the splash screen.

Note Image Note

This entry can be overridden by a Group Policy. When the Don't display welcome screen at logon policy in the User Configuration or Computer Configuration folders is enabled, this entry is ignored. Users can display the welcome screen manually, but the system does not display it at logon, regardless of the setting of the Show this screen at startup check box. The Don't display welcome screen at logon policy setting is stored in NoWelcomeScreen (HKLM) and NoWelcomeScreen (HKCU).

This entry affects Windows 2000nbsp;Professional only.

Tip Image Tip

If a user's Welcome screen does not appear as expected, check the setting of the Don't display welcome screen at logon policy. This policy takes preference over the user setting and the value of this entry.

Related Entries

NoWelcomeScreen (HKLM)

NoWelcomeScreen (HKCU)


User Shell Folders

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\

Description

The User Shell Folders subkey of HKEY_LOCAL_MACHINE stores the paths to Windows Explorer folders for the current user of the computer.

Note Image Note

The entries in this subkey can appear in both the Shell Folders subkey and the User Shell Folders and in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. The entries which appear in user User Shell Folders take precedence over those in Shell Folders. The entries which appear in HKEY_CURRENT_USER take precedence over those in HKEY_LOCAL_MACHINE.

Related Entries

Shell Folders in HKEY_CURRENT_USER

Shell Folders in HKLM

User Shell Folders in HKLM


AppData

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

Data type | Range | Default value
REG_EXPAND_SZ | Path | %USERPROFILE%\Application Data

Description

Stores the path to a folder containing user-specific files installed by applications.

For example, Microsoft Word can install a custom dictionary in the location specified by the value of this entry. You can enter any valid UNC name or mapped drive in the value of this entry.

Note Image Note

The %USERPROFILE% variable represents the path to the user's profile folder. The default is Systemroot\Documents and Settings\<username>.


Desktop

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

Data type | Range | Default value
REG_EXPAND_SZ | Path | %USERPROFILE%\Desktop

Description

Stores the path to the folder containing the shortcuts and Internet addresses that appear on the user's desktop.

You can enter any valid UNC name or mapped drive in the value of this entry.

Note Image Note

The %USERPROFILE% variable represents the path to the user's profile folder. The default is Systemroot\Documents and Settings\<username>.

Related Entries

Common Desktop in HKLM\User Shell Folders


Favorites

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

Data type | Range | Default value
REG_EXPAND_SZ | Path | %USERPROFILE%\Favorites

Description

Stores the path to the folder containing the Internet addresses that appear in the Favorites menu of the user's Internet browser.

You can enter any valid UNC name or mapped drive in the value of this entry.

Note Image Note

The %USERPROFILE% variable represents the path to the user's profile folder. The default is Systemroot\Documents and Settings\<username>.

Related Entries

Common Favorites in HKLM\User Shell Folders


NetHood

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

Data type | Range | Default value
REG_EXPAND_SZ | Path | %USERPROFILE%\NetHood

Description

Stores the path to the folder containing shortcuts to servers that the user has added to My Network Places.

You can enter any valid UNC name or mapped drive in the value of this entry.

Note Image Note

The %USERPROFILE% variable represents the path to the user's profile folder. The default is Systemroot\Documents and Settings\<username>.


Personal

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

Data type | Range | Default value
REG_EXPAND_SZ | Path | %USERPROFILE%\My Documents

Description

Stores the path to the user's Personal folder.

The Personal folder is the default location for saving application files. You can enter any valid UNC name or mapped drive in the value of this entry.

Note Image Note

The %USERPROFILE% variable represents the path to the user's Profiles folder. The default is Systemroot\Documents and Settings\username.

Related Entries

Personal in HKLM\User Shell Folders


PrintHood

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

Data type | Range | Default value
REG_EXPAND_SZ | Path | %USERPROFILE%\PrintHood

Description

Stores the path to the folder containing shortcuts to printers that the user has added to the computer.

You can enter any valid UNC name or mapped drive in the value of this entry.

Note Image Note

The %USERPROFILE% variable represents the path to the user's Profiles folder. The default is Systemroot\Documents and Settings\username.


Programs

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

Data type | Range | Default value
REG_EXPAND_SZ | Path | %USERPROFILE%\Start Menu\Programs

Description

Stores the path to the folder that contains the items which appear in the Programs menu on the Start menu.

You can enter any valid UNC name or mapped drive in the value of this entry.

Note Image Note

The %USERPROFILE% variable represents the path to the user's Profiles folder. The default is Systemroot\Documents and Settings\username.

Related Entries

Common Programs in HKLM\User Shell Folders


Recent

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

Data type | Range | Default value
REG_EXPAND_SZ | Path | %USERPROFILE%\Recent

Description

Stores the path to the folder containing the names of the documents most recently opened by the user.

These items appear in the Documents menu on the user's Start menu. You can enter any valid UNC name or mapped drive in the value of this entry.

Note Image Note

The %USERPROFILE% variable represents the path to the user's Profiles folder. The default is Systemroot\Documents and Settings\username.


SendTo

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

Data type | Range | Default value
REG_EXPAND_SZ | Path | %USERPROFILE%\SendTo

Description

Stores the path to the folder containing links to drives, communication programs, and applications.

You can enter any valid UNC name or mapped drive in the value of this entry.

Note Image Note

The %USERPROFILE% variable represents the path to the user's Profiles folder. The default is Systemroot\Documents and Settings\username.


Start Menu

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

Data type | Range | Default value
REG_EXPAND_SZ | Path | %USERPROFILE%\Start Menu

Description

Stores the path to the folder containing the items that appear in the Start menu.

You can enter any valid UNC name or mapped drive in the value of this entry.

Note Image Note

The %USERPROFILE% variable represents the path to the user's Profiles folder. The default is Systemroot\Documents and Settings\username.

Related Entries

Common Start Menu in HKLM\User Shell Folders


Startup

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

Data type | Range | Default value
REG_EXPAND_SZ | Path | %USERPROFILE%\Start Menu\Programs\Startup

Description

Stores the path to the folder containing shortcuts to items that appear in the Startup menu on the user's Start menu.

Windows 2000 automatically starts these items when the user logs on. You can enter any valid UNC name or mapped drive in the value of this entry.

Note Image Note

The %USERPROFILE% variable represents the path to the user's Profiles folder. The default is Systemroot\Documents and Settings\username.

Related Entries

Common Startup in HKLM\User Shell Folders


Policies

HKCU\Software\Microsoft\Windows\CurrentVersion\

Description

The Policies subkey contains entries that store Group Policy settings.

Group Policy adds, deletes, and changes the values of entries in this subkey when you use the Group Policy snap-in to configure a policy, that is, to enable or disable the policy. When the policies affecting you or your computer change, such as when you move to a new user group, Group Policy deletes the entries applied to the old group and then adds the entries applied to the new group.

Group Policy manages registry entries in four Policies subkeys:

  • HKLM\SOFTWARE\Policies
  • HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies
  • HKCU\SOFTWARE\Policies
  • HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies

The Policies subkeys in HKCU store policy-related entries that are configured separately for each user. The system adds these entries when you enable (and, for some policies, when you disable) a policy in the User Configuration folder in Group Policy.

The Policies subkeys in HKLM store policy-related entries that apply to all users of the computer. The system adds these entries when you enable (and, for some policies, when you disable) a policy in the Computer Configuration folder in Group Policy.

Many policy-related entries can appear in both HKCU and HKLM. Typically, the entries in HKLM take precedence over the entries in HKCU when both are configured.

The SOFTWARE\Microsoft\Windows\CurrentVersion\Policies subkey stores policy-related entries for Windows 2000 and for Windows NT 4.0 and earlier. The SOFTWARE\Policies subkey is new in Windows 2000. Please note that the different versions of Windows support different policies.

Change method

To add, remove, or change the value of entries in this subkey, use Group Policy.

Note Image Note

Many of the entries in the Policies subkeys have counterparts in other registry subkeys. These counterparts, known as preferences have the same effect on user or computer features as entries in the Policies subkey. However, when an entry appears in the Policies subkey, the preference is almost always ignored. For details, see the entry descriptions.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Caution Image Caution

Do not use a registry editor to change the values in this subkey. If you do, they will be overwritten the next time your policies are refreshed.


ActiveDesktop

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\

Description

The Active Desktop subkey stores the entries created when you configure a Group Policy for Active in Windows 2000. These entries are created and maintained by Group Policy, and are read and interpreted by Active Desktop.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


AdminComponent

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop\

Description

The AdminComponent subkey stores entries added by Group Policy settings for Active Desktop. These entries specify items that an administrator has added to or deleted from Active Desktop by setting a policy.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


Add

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop\AdminComponent

Data type | Range | Default value
REG_SZ | URL[ URL] | There is no default value for this entry.

Description

Adds specified Web content items to the desktop, and prevents users from permanently deleting these items.

Users can close or delete the items (if policies allow), but the items are added again each time the policy is refreshed.

This entry stores the item you type in the Add box of the Add/Delete items Group Policy. Group Policy adds this entry to the registry when you enable the Add/Delete items policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Add/Delete items policy (User Configuration\AdministrativeTemplates\Desktop\Active Desktop).

Note Image Note

Items removed from the value of this entry are not deleted from the desktop. They are just not added again if a user deletes them.

To make changes to this entry effective, you must log off of Windows 2000 and then log on again.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


Delete

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop\AdminComponent

Data type | Range | Default value
REG_SZ | URL[ URL] | There is no default value for this entry.

Description

Deletes specified Web content items from the desktop.

Users can add the items again (if policies allow), but the items are deleted each time the policy is refreshed.

This entry stores the item you type in the Delete box of the Add/Delete items Group Policy. Group Policy adds this entry to the registry when you enable the Add/Delete items policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Add/Delete items policy (User Configuration\AdministrativeTemplates\Desktop\Active Desktop). You can also use this policy to delete particular Web-based items from users' desktops. Users can add the item again (if policies allow), but the item is deleted each time the policy is refreshed.

Note Image Note

To make changes to this entry effective, you must log off of Windows 2000 and then log on again.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


NoAddingComponents

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Prevents users from adding Web content to their Active Desktop.

A value of 1 removes the New button from Web tab in Display in Control Panel and removes the New Desktop Item command from the Active Desktop menu. As a result, users cannot add Web pages or pictures from the Internet or an intranet to the desktop.

This entry stores the setting of the Prohibit adding items Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. Users cann add Web content to their Active desktop.
1 | The policy is enabled. Users cannot add Web content to their Active Desktop.

This entry does not remove existing Web content from the Active Desktop, or prevent users from removing existing Web content.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Prohibit adding items policy (User Configuration\AdministrativeTemplates\Desktop\Active Desktop).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoComponents


NoChangingWallPaper

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Disables all options on the Background tab of Display in Control Panel. As a result, users cannot add or change the background design of the desktop.

This entry stores the setting of the Disable changing wallpaper Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. Options on the Background tab are enabled.
1 | The policy is enabled. The Background tab still appears, but all options on the tab are disabled.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable changing wallpaper policy (User Configuration\Administrative Templates\Control Panel\Display).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoDispBackgroundPage

Wallpaper

NoHTMLWallPaper


NoClosingComponents

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines if users are prevented from removing Web content from their Active Desktop.

Prevents users from closing Web content from their Active Desktop.

A value of 1 removes the list of the Active Desktop items from the Active Desktop menu. (To see this list, right-click the desktop and point to Active Desktop. The list appears at the bottom of the menu.) Also, it removes the check boxes from items on the Web tab in Display in Control Panel.

This entry stores the setting of the Prohibit closing items Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. Users can close Web content from their Active Desktop.
1 | The policy is enabled. Users cannot close Web content from their Active Desktop.

In Active Desktop, you can add items to the desktop, but close them so they are not displayed. If you set the value of this entry to 1, items added to the desktop cannot be closed; they always appear on the desktop.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Prohibit closing items policy (User Configuration\AdministrativeTemplates\Desktop\Active Desktop).

Note Image Note

This entry does not prevent users from deleting items from their Active Desktop.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoDeletingComponents


NoComponents

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Removes Active Desktop content and prevents users from adding Active Desktop content.

This entry stores the setting of the Disable all items Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. Users can add and remove Active Desktop content.
1 | The policy is enabled. Active Desktop is removed and users cannot restore it.

Setting the value of this entry to 1 removes all Active Desktop items from the desktop. It also removes the Web tab from Display in Control Panel and removes the New Desktop Item command from the Active Desktop menu. As a result, users cannot add Web pages or pictures from the Internet or an intranet to the desktop.

This entry does not disable Active Desktop. Users can still use image formats, such as JPEG and GIF, for their desktop wallpaper.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable all items policy (User Configuration\AdministrativeTemplates\Desktop\Active Desktop).

Note Image Note

To make changes to this entry effective, you must log off of Windows 2000 and then log on again.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoAddingComponents

NoDeletingComponents


NoDeletingComponents

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Prevents users from deleting Web content from their Active Desktop.

A value of 1 removes the Delete button from the Web tab in Display in Control Panel. As a result, users can temporarily remove, but not delete, Web content from their Active Desktop.

This entry stores the setting of the Prohibit deleting items Group Policy. Group Policy adds this entry to the registry when you configure the Prohibit deleting items policy.

Value | Meaning
0 | Users are able to delete Web content from their Active desktop.
1 | Users are prevented from deleting Web content from their Active Desktop.

This entry does not prevent users from adding Web content to their Active Desktop.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Prohibit deleting items policy (User Configuration\AdministrativeTemplates\Desktop\Active Desktop).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoClosingComponents

NoComponents


NoEditingComponents

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Prevents users from changing the properties of Web content items on their Active Desktop.

Setting the value of this entry to 1 disables the Properties button on the Web tab in Display in Control Panel. Also, it removes the Properties item from the menu for each item on the Active Desktop. As a result, users can change the properties of an item, such as its synchronization schedule, password, or display characteristics.

This entry stores the setting of the Prohibit editing items Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. Users can change the properties of Web content on their Active Desktop.
1 | The policy is enabled. Users cannot change the properties of Web content on their Active Desktop.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Prohibit editing items policy (User Configuration\AdministrativeTemplates\Desktop\Active Desktop).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


NoHTMLWallPaper

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Permits only bitmap images for wallpaper.

This entry stores the setting of the Allow only bitmapped wallpaper Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Allow only bitmapped wallpaper policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 | The policy is disabled or not configured. Any image format can be used for wallpaper.
1 | The policy is enabled. The desktop background ("wallpaper") is limited to bitmap (.bmp) files. If users select files with other image formats, such as JPEG, GIF, PNG, or HTML, the wallpaper does not load.

This policy is designed to avoid the Active Desktop prompt. When users select a wallpaper with an alternate image format, the system prompts them to enable Active Desktop. By limiting users to bitmapped files, the prompt is avoided.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Allow only bitmapped wallpaper policy (User Configuration\AdministrativeTemplates\Desktop\Active Desktop).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoChangingWallPaper

NoDispBackgroundPage

Wallpaper


Comdlg32

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\

Description

The Comdlg32 subkey contains entries that store Group Policy settings for the common Open dialog box. The entries in this subkey are written and maintained by Group Policy and read and interpreted by the Open dialog box program.

The entries in the Comdlg32 subkey only affect programs that use the standard Open dialog box provided to developers of Windows programs.

Tip Image Tip

To see an example of the standard Open dialog box, run Notepad and, from the File menu, click Open.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


NoBackButton

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Comdlg32

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Removes the Back button from the Open dialog box.

This entry stores the setting of the Hide the common dialog back button Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. The Back button appears on the Open dialog box.
1 | The policy is enabled. The Back button is removed from the Open dialog box.

This entry, and related entries in this subkey, lets you remove new features added in Windows 2000, so that the Open dialog box looks like it did in Windows NT 4.0 and earlier. These entries only affect programs that use the standard Open dialog box provided to developers of Windows programs.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Hide the common dialog back button policy (User Configuration\Administrative Templates\Windows Components\Windows Explorer\Common Open File Dialog).

Tip Image Tip

To see an example of the standard Open dialog box, run Notepad and, from the File menu, click Open.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoPlacesBar

NoFileMru


NoFileMru

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Comdlg32

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Removes the list of most recently used files from the standard Open dialog box.

This entry stores the setting of the Hide the dropdown list of recent files Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Hide the dropdown list of recent files policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 | The policy is disabled or not configured. The File name field includes a dropdown list of recently used files.
1 | The policy is enabled. The File name field is a simple text box. Users must browse directories to find a file or type a file name in the text box.

This entry, and related entries in this subkey, lets you remove new features added in Windows 2000, so that the Open dialog box looks like it did in Windows NT 4.0 and earlier. These entries only affect programs that use the standard Open dialog box provided to developers of Windows programs.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Hide the dropdown list of recent files policy (User Configuration\Administrative Templates\Windows Components\Windows Explorer\Common Open File Dialog).

Tip Image Tip

To see an example of the standard Open dialog box, run Notepad and, from the File menu, click Open.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoBackButton

NoPlacesBar


NoPlacesBar

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Comdlg32

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Removes the shortcut bar from the Open dialog box.

This entry stores the setting of the Hide the common dialog places bar Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
The policy is disabled or not configured. | The shortcut bar appears in the Open dialog box.
1 | The policy is enabled. The shortcut bar is removed from the Open dialog box.

This entry, and related entries in this subkey, lets you remove new features added in Windows 2000, so that the Open dialog box looks like it did in Windows NT 4.0 and earlier. These entries only affect programs that use the standard Open dialog box provided to developers of Windows programs.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Hide the common dialog places bar policy (User Configuration\Administrative Templates\Windows Components\Windows Explorer\Common Open File Dialog).

Tip Image Tip

To see an example of the standard Open dialog box, run Notepad and, from the File menu, click Open.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoBackButton

NoFileMru


Explorer

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\

Description

The Policies\Explorer subkey contains entries that store Group Policy settings for Windows Explorer and the Windows interface. These include policies for the Start menu, taskbar, desktop, and Control Panel. The entries in this subkey are written and maintained by Group Policy and read and interpreted by the Windows Explorer program.

This subkey in HKEY_CURRENT_USER stores policy-related entries that are configured separately for each user. There is also a Software\Microsoft\Windows\CurrentVersion\Policies\Explorer subkey in HKEY_LOCAL_MACHINE that stores policy-related entries that apply to all users of this computer.

Note Image Note

Many of the entries in the Policies subkeys have counterparts in other registry subkeys. These counterparts, known as preferences have the same effect on user or computer features as entries in the Policies subkey. However, when an entry appears in the Policies subkey, the preference is almost always ignored. For details, see the entry descriptions.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

Explorer subkey (HKLM)


ClassicShell

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Disables Active Desktop, Web view, and thumbnail views. Also, users cannot configure their system to open items by single-clicking (such as in Mouse in Control Panel). As a result, the user interface looks and operates like the interface for Windows NT 4.0 and users cannot restore the new features.

This entry stores the setting of the Enable Classic Shell Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. The system displays the new user interface features designed for Windows 2000.
1 | The policy is enabled. The user interface behaves like the interface for Windows NT 4.0 and users cannot restore the new features.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Enable Classic Shell policy (User Configuration\Administrative Templates\Windows Components\Windows Explorer).

Note Image Note

This entry takes precedence over the value of the ForceActiveDesktopOn entry. When the value of ClassicShell is 1, Active Desktop is disabled, and ForceActiveDesktopOn is ignored.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

ForceActiveDesktopOn

NoActiveDesktop

NoFolderOptions


ClearRecentDocsOnExit

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0 0

Description

Deletes the contents of the Documents menu when the user logs off.

The Documents menu contains shortcuts to the non-program files the user opened most recently.

This entry stores the setting of the Clear history of recently opened documents on exit Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. Shortcuts in the Documents menu are saved when the user logs off and available again when the user logs on.
1 | The policy is enabled. The Documents menu is emptied when the user logs off.

You can use the Clear history of recently opened documents on exit policy, in coordination with the Remove Documents menu from Start Menu policy (NoRecentDocsMenu) and the Do not keep history of recently opened documents policy (NoRecentDocsHistory) to manage access to recently opened files. The system uses this entry only when neither of these related entries is set to 1.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Clear history of recently opened documents on exit policy (User Configuration\AdministrativeTemplates\Start Menu & Taskbar).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoRecentDocsHistory

NoRecentDocsMenu


DisableLocalMachineRun

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Directs the system to ignore the customized run list for Windows NT 4.0 and earlier.

This entry stores the setting of the Disable legacy run list Group Policy. Group Policy adds this entry to the registry with a value of 1 when you configure the Disable legacy run list policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 | The policy is disabled or not configured. Windows 2000 adds any customized run list configured for Windows NT 4.0 and earlier to its run list.
1 | The policy is enabled. The system ignores the run list for Windows NT 4.0 and earlier.

A run list is customized list of additional programs and documents that the system starts automatically when it starts. These programs are added to the standard run list of programs and services that the system starts.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable legacy run list policy (User Configuration\Administrative Templates\System\Logon/Logoff).

Note Image Note

This entry can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If this entry appears in both subtrees, the value in HKEY_LOCAL_MACHINE takes precedence over the value in HKEY_CURRENT_USER.

Tip Image Tip

The customized run lists for Windows NT 4.0 and earlier are stored in the registry in HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run and HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Windows\Run. They can be configured by using the Run policy in System Policy Editor for Windows NT 4.0 and earlier.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

DisableLocalMachineRun (HKLM)

DisableLocalMachineRunOnce (HKCU)

Run subkey (HKLM)


DisableLocalMachineRunOnce

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Directs the system to ignore customized run-once lists.

This entry stores the setting of the Disable the run once list Group Policy. Group Policy adds this entry to the registry with a value of 1 when you configure the Disable the run once list policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 | The policy is disabled or not configured. The system runs the programs in the run-once list.
1 | The policy is enabled. The system ignores the run-once list.

A run-once list is customized list of additional programs and documents that are started automatically the next time the system starts (but not thereafter). These programs are added to the standard list of programs and services that the system starts.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable the run once list policy (Computer Configuration\Administrative Templates\System).

Note Image Note

This entry can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If this entry appears in both subtrees, the value in HKEY_LOCAL_MACHINE takes precedence over the value in HKEY_CURRENT_USER.

Tip Image Tip

Customized run-once lists are stored in the registry in HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\RunOnce.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

DisableLocalMachineRunOnce (HKLM)

DisableLocalMachineRun (HKCU)

Run subkey (HKCU)


DisablePersonalDirChange

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Prevents users from moving the My Documents folder.

This entry stores the setting of the Prohibit user from changing My Documents path Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. Users can move the My Documents folder.
1 | The policy is enabled. Users cannot move the My Documents folder.

By default, a user can move the My Documents folder by typing a new path in the Target box of the My Documents Properties dialog box. If the value of this entry is 1, then when users type a new path in the Target box, a message appears explaining that a policy prevents the action.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Prohibit user from changing My Documents path policy (User Configuration\AdministrativeTemplates\Desktop).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


DisallowCpl

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Removes the icons representing selected Control Panel items from the Start menu and the Control Panel window.

This entry stores the setting of the Hide specified control panel applets Group Policy. Group Policy adds this entry the registry with value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes this entry from the registry.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. The system displays the icons of all Control Panel items.
1 | The policy is enabled. The system hides the icons of Control Panel items specified by entries in the DisallowCpl subkey. It does not prevent any Control Panel programs from running.

Change method

To change the value of the entries in this subkey, use Group Policy. These entries correspond to the Hide specified control panel applets policy (User Configuration\Administrative Templates\Control Panel).

Note Image Note

There is also a DisallowCpl subkey which stores the names of hidden Control Panel items. If the subkey does not appear in the registry or does not contain any entries, this entry has no effect.

The Hide specified control panel applets policy takes precedence over the Show only specified control panel applets policy. If the same Control Panel item appears in both the DisallowCpl subkey and the RestrictCpl subkey, the item is hidden, and the entry in the RestrictCpl subkey is ignored.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


DisallowRun

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Prevents Windows from running the programs represented by entries in the DisallowRun subkey.

This entry stores the setting of the Don't run specified Windows applications Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | Users can run all installed Windows programs.
1 | Users cannot run programs represented by entries in the RestrictRun subkey.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Don't run specified Windows applications policy (User Configuration\Administrative Templates\System).

Note Image Note

There is also a DisallowRun subkey which stores the names of programs that users cannot run. If the subkey does not appear in the registry or does not contain any entries, then this entry has no effect.

This entry only prevents users from running programs that are started by the Windows Explorer process. It does not prevent users from running programs such as Task Manager, which are started by the system process or by other processes. Also, if users have access to the command prompt, Cmd.exe, this policy does not prevent them from starting programs in the command window that they are not permitted to start by using Windows Explorer.

The Run only allowed Windows applications policy takes precedence over the Don't run specified Windows applications policy. If both policies are applied to the same user, the Run only allowed Windows applications policy is implemented and the Don't run specified Windows applications policy is ignored.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

DisallowRun subkey


EnforceShellExtensionSecurity

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Directs Windows to start only the user interface extensions that the system security or the user have approved.

When the system detects that the user is downloading an external program that runs as part of the Windows user interface, the system searches for a digital certificate or requests that the user approve the action.

This entry stores the setting of the Only allow approved Shell extensions Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. Windows starts all interface extensions.
1 | The policy is enabled. Windows only starts approved interface extensions.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Only allow approved Shell extensions policy (User Configuration\Administrative Templates\Windows Components\Windows Explorer).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


ForceActiveDesktopOn

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Enables Active Desktop and prevents users from disabling it.

This entry stores the setting of the Enable Active Desktop Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. Active Desktop is disabled by default, but users can enable it.
1 | The policy is enabled. Active Desktop is enabled and users cannot disable it.

When the value of this entry is 1 the system disables the following items to prevent users from trying to change the setting while a policy is in effect.

  • The Show Web Content item on the context menu that appears when you right-click the desktop;
  • The Show Web content on my Active Desktop item on the Web tab in Display in Control Panel;
  • The Use Windows classic desktop item on the General tab of the Folder Options dialog box.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Enable Active Desktop policy (User Configuration\AdministrativeTemplates\Desktop\Active Desktop).

Note Image Note

If both the ForceActiveDesktopOn entry and the NoActiveDesktop entry are set to 1, the NoActiveDesktop entry is ignored. If the ClassicShell entry is set to 1, then Active Desktop is disabled and both of these entries are ignored.

To make changes to this entry effective, you must log off of Windows 2000 and then log on again.

Tip Image Tip

To enable Active Desktop without setting a policy, right-click the desktop, point to Active Desktop, and then click Show Web Content.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

ClassicShell

NoActiveDesktop

NoFolderOptions


ForceStartMenuLogOff

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Adds the Log Off username item to the Start menu and prevents users from removing it.

Also, the system ignores the setting in the Display Logoff box on the Taskbar and Start Menu Properties dialog box. As a result, users cannot remove the Log Off user-name item while this policy is in effect.

This entry stores the setting of the Add Logoff to the Start Menu Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Add Logoff to the Start Menu policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. Users can use the Display Logoff item to add and remove the Log Off username item.
1 | The Log Off username item appears in the Start menu and users cannot remove it.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Add Logoff to the Start Menu policy (User Configuration\AdministrativeTemplates\Start Menu & Taskbar).

Note Image Note

The Disable Logoff on the Start Menu policy takes precedence over the Add Logoff to the Start Menu policy. That is, when the value of StartMenuLogoff is 1, the system removes the Logoff username item from the Start menu and ignores the ForceStartMenuLogoff entry.

Tip Image Tip

To add or remove the Log Off username item on a computer, click Start, click Settings, click Taskbar & Start Menu, click the Advanced tab and, in the Start Menu Settings box, click Display Logoff.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoLogoff

StartMenuLogOff


GreyMSIAds

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines if Start menu shortcuts to partially installed programs are displayed in gray text.

Displays Start menu shortcuts to partially installed programs in gray text.

This entry stores the setting of the Gray unavailable Windows Installer programs Start Menu shortcuts Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. All Start menu shortcuts appear in black text.
1 | The policy is enabled. Shortcuts to partially-installed programs appear in gray text.

This entry makes it easier for users to distinguish between programs that are fully installed and those that are only partially installed.

Partially installed programs include those that a system administrator assigns using Windows Installer and those that users have configured for full installation upon first use.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Gray unavailable Windows Installer programs Start Menu shortcuts policy (User Configuration\AdministrativeTemplates\Start Menu & Taskbar).

Note Image Note

Setting the value of this entry to 1 can make the Start menu slow to open.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


Intellimenus

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 2 | 0

Description

Enables and disables personalized menus, and determines whether users can change the setting.

This entry stores the setting of the Disable personalized menus Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Disable personalized menus policy. When you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Windows 2000 personalizes long menus by moving recently used items to the top of the menu and by hiding items that have not been used recently. Users can display the hidden items by clicking an arrow to extend the menu.

Value | Meaning
0 | Enables personalized menus by default, but lets users change the setting.
1 | Disables personalized menus and removes the Use Personalized Menus option so users cannot change the setting.
2 | Enables personalized menus and removes the Use Personalized Menus option so users cannot change the setting. (You cannot use Group Policy to select this value.)

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable personalized menus policy (User Configuration\AdministrativeTemplates\Start Menu & Taskbar).

Note Image Note

This entry takes precedence over a user setting. When this entry appears in the registry with a value of 1, a policy is in effect and the system ignores the value of Intellimenus (in the Explorer\Advanced subkey) and removes the Use Personalized Menus option from the Start Menu. If users cannot find the Use Personalized Menus option, check the setting of the Disable personalized menus policy.

Personalized menus require user tracking. If you enable the Disable user tracking policy, Group Policy sets the value of NoInstrumentation to 1. As a result, the system disables user tracking and personalized menus, and ignores the value of Intellimenus.

Tip Image Tip

To enable or disable personalized menus without setting a policy, click Start, click Settings, and then click Taskbar & Start Menu. The Use Personalized Menus check box appears on the General tab of the Taskbar and Start Menu Properties dialog box.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

Intellimenus (Explorer\Advanced subkey)

NoInstrumentation


LinkResolveIgnoreLinkInfo

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether Windows 2000 traces shortcuts back to their sources when it cannot find the target on the user's system.

This entry stores the setting of the Do not track Shell shortcuts during roaming Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. Windows traces shortcuts back to their sources when it cannot find the target on the user's system.
1 | The policy is enabled. Windows only searches the current target path. It does not search for the original path even when it cannot find the target file in the current target path.

Shortcut files typically include an absolute path to the original target file as well as the relative path to the current target file. When the system cannot find the file in the current target path, then, by default, it searches for the target in the original path. If the shortcut has been copied to a different computer, the original path might lead to a network computer, including external resources, such as an Internet server.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Do not track Shell shortcuts during roaming policy (User Configuration\Administrative Templates\Windows Components\Windows Explorer).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoResolveSearch

NoResolveTrack


MaxRecentDocs

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF shortcuts | 0xF (15 shortcuts)

Description

Determines how many shortcuts the system can display in the Documents menu on the Start menu.

This entry stores the setting of the Maximum number of recent documents Group Policy. Group Policy adds this entry to the registry when you enable the Maximum number of recent documents policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 15.

The Documents menu contains shortcuts to the non-program files the user has most recently opened.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Maximum number of recent documents policy (User Configuration\Administrative Templates\Windows Components\Windows Explorer).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoRecentDocsHistory

NoRecentDocsMenu


MemCheckBoxInRunDlg

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Adds the Run in Separate Memory Space check box to Run dialog box. This check box lets users run a 16-bit program in a dedicated (not shared) Virtual DOS Machine (VDM) process. The additional check box is enabled only when a user types the name of a 16-bit program in the Run dialog box.

This entry stores the setting of the Add "Run in Separate Memory Space" check box to Run dialog box Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. TheRun in Separate Memory Space check box does not appear.
1 | The policy is enabled. The Run in Separate Memory Space check box appears on the Run dialog box.

All DOS and 16-bit programs run on Windows 2000 in the Windows Virtual DOS Machine program. VDM simulates a 16-bit environment, complete with the DLLs required by 16-bit programs. By default, all 16-bit programs run as threads in a single, shared VDM process. As such, they share the memory space allocated to the VDM process and cannot run simultaneously.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Add "Run in Separate Memory Space" check box to Run dialog box policy (User Configuration\AdministrativeTemplates\Start Menu & Taskbar).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


NoActiveDesktop

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Disables Active Desktop and prevents users from enabling it.

This entry stores the setting of the Disable Active Desktop Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. Active Desktop is disabled by default, but users can enable it.
1 | The policy is enabled. Active Desktop is disabled and users cannot enable it.

When the value of this entry is 1 the system restricts access to the following items to prevent users from trying to change the setting while a policy is in effect.

  • Removes the Active Desktop item from the context menu that appears when you right-click the desktop;
  • Removes the Web tab from Display in Control Panel;
  • Disables the Enable Web content on my desktop item on the General tab of the Folder Options dialog box.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable Active Desktop policy (User Configuration\AdministrativeTemplates\Desktop\Active Desktop).

Note Image Note

If both the ForceActiveDesktopOn entry and the NoActiveDesktop entry are set to 1, the NoActiveDesktop entry is ignored. If the ClassicShell entry is set to 1, then Active Desktop is disabled and both of these entries are ignored.

To make changes to this entry effective, you must log off of Windows 2000 and then log on again.

Tip Image Tip

To disable Active Desktop without setting a policy, right-click the desktop, point to Active Desktop, and then turn off Show Web Content.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

ClassicShell

ForceActiveDesktopOn

NoActiveDesktopChanges

NoFolderOptions


NoActiveDesktopChanges

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Prevents the user from enabling or disabling Active Desktop or changing the Active Desktop configuration.

A value of 1 removes the Web tab from Display in Control Panel and removes the Active Desktop item from menu that appears when you right-click the desktop. As as result, users cannot enable or disable Active Desktop. If Active Desktop is already enabled, users cannot add, remove, or edit Web content or disable, lock, or synchronize Active Desktop components.

This entry stores the setting of the Prohibit changes Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. Users can enable, disable and configure Active desktop configuration.
1 | The policy is enabled. Users cannot enable or disable Active Desktop or reconfigure it. This value locks down the configuration you establish by using other entries in this subkey.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Prohibit changes policy (User Configuration\AdministrativeTemplates\Desktop\Active Desktop).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoActiveDesktop


NoAddPrinter

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Removes the Add Printer option from the Start menu and from the Printers folder. Also, users cannot add printers by dragging a printer icon into the Printers folder.

This entry stores the setting of the Disable addition of printers Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. The Add Printer option appears.
1 | The policy is enabled. The Add Printer option is removed.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable addition of printers policy (User Configuration\Administrative Templates\Control Panel\Printers).

Note Image Note

This entry does not prevent users from using other methods to add printers, such as the Add Hardware wizard.

To change printer permissions without setting a policy, in the Printers folder, right-click a printer, click Properties, and then click the Security tab.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Caution Image Caution

If users have not added any printers to their system before this policy is applied, then they cannot print.

Related Entries

NoSetFolders


NoChangeAnimation

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Disables the Use transition effects for menus and tooltips option in Display in Control Panel. As a result, user cannot animate the movement of windows, menus, and lists.

This entry stores the setting of the Disable UI to change menu animation setting Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. The Use transition effects for menus and tooltips option is enabled.
1 | The policy is enabled. The Use transition effects for menus and tooltips option is disabled.

Effects such as animation are designed to enhance the user's experience but might be confusing or distracting to some users.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable UI to change menu animation setting policy (User Configuration\Administrative Templates\Windows Components\Windows Explorer).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


NoChangeKeyboardNavigationIndicators

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Disables the Hide keyboard navigation indicators until I use the ALT key option in Display in Control Panel.

When Hide keyboard navigation indicators until I use the ALT key option is selected, the underlining that indicates a keyboard shortcut character (hot key) does not appear on menus until you press ALT.

This entry stores the setting of the Disable UI to change keyboard navigation indicator setting Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. The Hide keyboard navigation indicators until I use the ALT key option is enabled.
1 | The policy is enabled. The Hide keyboard navigation indicators until I use the ALT key option is disabled.

Effects, such as transitory underlines, are designed to enhance the user's experience but might be confusing or distracting to some users.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable UI to change keyboard navigation indicator setting policy (User Configuration\Administrative Templates\Windows Components\Windows Explorer).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


NoChangeStartMenu

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Prevents users from using the drag-and-drop method to reorder or remove items on the Start menu. Also, it removes context menus from the Start menu.

This entry stores the setting of the Disable drag-and-drop context menus on the Start Menu Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Disable drag-and-drop context menus on the Start Menu policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. Users can drag and drop Start menu items and can display context menus.
1 | The policy is enabled. Users cannot drag and drop Start menu items or display context menus.

This entry does not prevent users from using other methods of customizing the Start menu or performing the tasks available from the context menus.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable drag-and-drop context menus on the Start Menu policy (User Configuration\AdministrativeTemplates\Start Menu & Taskbar).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoSetTaskbar

NoTrayContextMenu


NoClose

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Removes the Shut Down item from the Start menu and disables the Shut Down button on the Windows Security dialog box.

As a result, users cannot use the Windows user interface to shut down the system. However, this entry does not prevent users from running programs that shut down Windows.

This entry stores the setting of the Disable and remove the Shut Down command Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 | The policy is disabled or not configured. The Shut Down items appear.
1 | The policy is enabled. The Shut Down items do not appear.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable and remove the Shut Down command policy (User Configuration\AdministrativeTemplates\Start Menu & Taskbar).

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Tip Image Tip

The Windows Security dialog box appears when you press Ctrl+Alt+Delete while logged on to the system.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

ShutdownWithoutLogon

PowerdownAfterShutdown


NoCloseDragDropBands

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Prevents users from manipulating destop toolbars.

When the value of this entry is 1, users cannot add or remove toolbars from the desktop. Also, users cannot drag toolbars onto or off of docked toolbars.

This entry stores the setting of the Disable adding, dragging, dropping and closing the Taskbar's toolbars Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. Users can manipulate desktop toolbars.
1 | The policy is enabled. Users cannot manipulate desktop toolbars.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable adding, dragging, dropping and closing the Taskbar's toolbars policy (User Configuration\AdministrativeTemplates\Desktop).

Note Image Note

If users have added or removed toolbars, setting the value of this entry to 1 prevents them from restoring the default configuration.

Tip Image Tip

To view the toolbars that can be added to the desktop, right-click a docked toolbar (such as the taskbar beside the Start button), and point to Toolbars.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoMovingBands


NoCommonGroups

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Removes items in the All Users profile from the Programs menu on the Start menu. Only items in the current user's user profile appear.

This entry stores the setting of the Remove common program groups from Start Menu Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. The Programs menu contains items from the All Users profile and items from the current user's user profile.
1 | The policy is enabled. Only items in the current user's user profile appear in the Programs menu.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Remove common program groups from Start Menu policy (User Configuration\AdministrativeTemplates\Start Menu & Taskbar).

Tip Image Tip

To see the Programs menu items in the All Users profile, on the system drive, go to Documents and Settings\All Users (WINNT)\Start Menu\Programs.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


NoComputersNearMe

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Removes the Computers Near Me icon, and the icons representing computers in the workgroup, from My Network Places and from the Map Network Drive browser window.

This entry stores the setting of the No "Computers Near Me" in My Network Places Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. The Computers Near Me icon appears when the computer is a member of a workgroup.
1 | The policy is enabled.The Computers Near Me icon never appears.

The Computers Near Me icon appears only on computers in a workgroup. This entry does not affect computers that are members of a domain.

This entry does not prevent users from connecting to computers in their workgroup by other commonly used methods, such as typing the share name in the Run dialog box or the Map Network Drive dialog box.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the No "Computers Near Me" in My Network Places policy (User Configuration\Administrative Templates\Windows Components\Windows Explorer).

Note Image Note

The Computers Near Me icon is designed for computers in a workgroup. This icon might appear on a computer in a domain if the system was upgraded from a pre-release version of Windows 2000.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoEntireNetwork

NoNetHood


NoControlPanel

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Prevents Control.exe, the Control Panel executable file, from starting. As a result, users cannot start Control Panel or run any Control Panel programs.

A value of 1 also removes Control Panel from the Start menu, and removes the Control Panel folder from Windows Explorer. If users try to start a Control Panel program by using another method, a message appears explaining that a policy prevents the action.

This entry stores the setting of the Disable Control Panel Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. Enables Control Panel and Control Panel programs.
1 | The policy is enabled. Disables Control Panel and Control Panel programs.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable Control Panel policy (User Configuration\AdministrativeTemplates\Start Menu & Taskbar).

Note Image Note

This entry does not disable the programs that appears as folders in Control Panel, such as Network and Dial-up Connections, Scheduled Tasks, or Fonts. To disable these programs, use the Disable programs on Settings menu policy (NoSetFolders.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoDispCPL

NoNetworkConnections

NoSetFolders


NoDeletePrinter

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Prevents users from using the Printers folder to delete local and network printers.

This entry stores the setting of the Disable deletion of printers Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. Users can delete printers from the Printers folder.
1 | The policy is enabled. Users cannot delete printers from the Printers folder.

If a user tries to delete a printer while this policy is enabled, a message appears explaining that a policy prevents the action.

This entry does not prevent users from using other programs to delete a printer.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable deletion of printers policy (User Configuration\Administrative Templates\Control Panel\Printers).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoSetFolders


NoDesktop

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines if icons, shortcuts, and other default and user-defined items are removed from the desktop, including Briefcase, Recycle Bin, My Computer, and My Network Places.

Removes icons, shortcuts, and other default and user-defined items from the desktop, including Briefcase, Recycle Bin, My Computer, and My Network Places.

This entry stores the setting of the Hide all icons on Desktop Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. Desktop items appear.
1 | The policy is enabled.Desktop items are removed.

Removing icons and shortcuts does not prevent the user from using another method to start the programs or opening the items they represent.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Hide all icons on Desktop policy (User Configuration\AdministrativeTemplates\Desktop).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


NoDFSTab

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Removes the Dfs tab from Windows Explorer and from other programs that use the Windows Explorer browser, such as My Computer. As a result, users cannot use this tab to view or change the properties of the Distributed file system (Dfs) shares available from their computer.

This entry stores the setting of the Disable DFS tab Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured.The Dfs tab appears.
1 | The policy is enabled. The Dfs tab is removed from Windows Explorer.

This entry does not prevent users from using other methods to configure Dfs.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable DFS tab policy (User Configuration\Administrative Templates\Windows Components\Windows Explorer).

Tip Image Tip

To see the DFS tab, right-click the name of a Dfs drive, and then click Properties.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


NoDriveAutoRun

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0x0 - 0x3FFFFFF (bitmapped value) | 0x0

Description

Determines whether the Autoplay feature is enabled on each drive connected to the system. When Autoplay is enabled, media is started automatically when it is inserted in the drive.

The value of this entry is comprised of 32 bits. The lower 26 bits each represent a drive, with the lowest (right-most) bit representing drive A, and the 26th bit from the right representing drive Z. If a bit is set to 0, the Autoplay feature is enabled on that drive. If a bit is set to 1, the Autoplay feature is disabled on that drive.

For example, if the value of this entry is 0x8 (1000 binary), Autoplay is disabled on drive D.

Note Image Note

Autoplay is triggered by a Media Change Notification (MCN) message from the CD-ROM driver. If the Windows 2000 interface does not receive this message, Autoplay does not operate, regardless of the value of this entry. Entries that suppress the MCN message, such as Autorun and AutoRunAlwaysDisable, also disable Autoplay.

Autoplay is also disabled on any drive if it is disabled by the value of NoDriveAutoRun (in HKLM or HKCU) or NoDriveTypeAutoRun (in HKLM or HKCU). However, if NoDriveAutoRun or NoDriveTypeAutoRun appear in HKEY_LOCAL_MACHINE, their corresponding entries in HKEY_CURRENT_USER are ignored.

Although this entry is located in the Policies\Explorer subkey, it is not associated with a Group Policy setting in Windows 2000.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

Related Entries

Autorun

AutoRunAlwaysDisable

NoDriveAutoRun (in HKLM)

NoDriveTypeAutoRun (in HKLM)

NoDriveTypeAutoRun (in HKCU)


NoDrives

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0x0 - 0x3FFFFFF | 0x0

Description

Removes the icons representing selected drives from My Computer and Windows Explorer. Also, the drive letters representing the selected drives do not appear in the standard Open dialog box.

This entry stores the setting of the Hide these specified drives in My Computer Group Policy. Group Policy adds this entry to the registry when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

The value of this entry is a 32-bit bitmask. The lower 26 bits in this value correspond to the 26 letters used to identify drives on the local computer and its network. The rightmost bit represents drive A; the 26th bit from the right represents drive Z. To hide a drive, set the bit that corresponds to its drive letter to 1. To display a drive, set the bit that corresponds to its drive letter to 0. To hide all 26 drives, set all bits to 1. This corresponds to a value of 67108863 (decimal) or 0x3FFFFFF (hexadecimal).

Group Policy sets the value of this entry to one of the following values.

Value | Meaning
0x03FFFFFFFF | Restrict all drives.
0x3 | Restrict A and B drives only.
0x4 | Restrict C drive only.
0x8 | Restrict D drive only.
0x7 | Restrict A, B, and C drives only.
0xF | Restrict A, B, C, and D drives only.
0x0 | Do not restrict drives. All drives appear.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Hide these specified drives in My Computer policy (User Configuration\Administrative Templates\Windows Components\Windows Explorer). Select a drive or combination of drives from the drop-down list.

Note Image Note

This entry removes the drive icons. Users can still gain access to drive contents by using other methods, such as by typing the path to a directory on the drive in the Map Network Drive dialog box, in the Run dialog box, or in a command window.

This entry does not prevent users from using programs to access these drives or their contents. And, it does not prevent users from using the Disk Management snap-in to view and change drive characteristics.

By default, the system does not hide drives. Therefore, disabling the Hide these specified drives in My Computer policy, not configuring the policy, and enabling the policy and setting it to Do not restrict drives do not have any effect on the system.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoNetConnectDisconnect

NoViewOnDrive


NoDriveTypeAutoRun

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_SZ | 0x0 - 0xFF | 0x95

Description

Disables the Autoplay feature on all drives of the type specified.

Autoplay begins reading from a drive as soon as you insert media in the drive. As a result, the setup file of programs and the music on audio media starts immediately.

This entry stores the setting of the Disable Autoplay Group Policy. Group Policy adds this entry to the registry when you enable the Hide these specified drives in My Computer policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0x95.

This entry is a bitmapped value. To disable Autoplay on a particular type of drive, set the bit representing that drive type to 1. To disable more than one type of drive, set the bits representing each type to 1, or sum the hexadecimal values of the representative bits.

Value | Meaning
0x1 | Disables Autoplay on drives of unknown type.
0x4 | Disables Autoplay on removable drives.
0x8 | Disables Autoplay on fixed drives.
0x10 | Disables Autoplay on network drives.
0x20 | Disables Autoplay on CD-ROM drives.
0x40 | Disables Autoplay on RAM disks.
0x80 | Disables Autoplay on drives of unknown type.
0xFF | Disables Autoplay on all types of drives.

By default, Autoplay is disabled on removable drives, such as the floppy disk drive (but not the CD-ROM drive), and on network drives. The default value 0x95 (149) is the sum of 0x1, 0x81 (unknown types), 0x4 (floppy drives), and 0x10 (network drives).

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable Autoplay policy (User Configuration\Administrative Templates\System).

Note Image Note

Autoplay is triggered by a Media Change Notification (MCN) message from the CD-ROM driver. If the Windows 2000 interface does not receive this message, Autoplay does not operate, regardless of the value of this entry. Entries that suppress the MCN message, such as Autorun and AutorunAlwaysDisable also disable Autoplay.

Autoplay is disabled on any drive if it is disabled by the value of NoDriveAutoRun (in HKLM or HKCU) or NoDriveTypeAutoRun (in HKLM or HKCU).

However, if NoDriveAutoRun or NoDriveTypeAutoRun appear in HKEY_LOCAL_MACHINE, their corresponding entries in HKEY_CURRENT_USER are ignored.

You can use the Disable Autoplay Group Policy to add CD-ROM drives to the list of drive types already disabled (removable drives, network drives, and unknown drives) or to disable Autoplay on all drives. You must edit the registry to set any other value.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

Autorun

AutoRunAlwaysDisable

NoDriveAutoRun (in HKLM)

NoDriveAutoRun (in HKCU)

NoDriveTypeAutoRun (in HKLM)


NoFavoritesMenu

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Removes the Display Favorites item from the Start Menu Settings box. As a result, users cannot add the Favorites menu to the Start menu.

This entry stores the setting of the Remove Favorites menu from Start Menu Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Remove Favorites menu from Start Menu policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. The Display Favorites item appears.
1 | The policy is enabled. The Display Favorites item does not appear.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Remove Favorites menu from Start Menu policy (User Configuration\AdministrativeTemplates\Start Menu & Taskbar).

Note Image Note

This entry only affects the Start menu. The Favorites item still appears in Windows Explorer and in Internet Explorer.

Tip Image Tip

To display the Favorites menu, click Start, point to Settings, click Taskbar & Start Menu, click the Advance tab, and then, under Start Menu Settings, select Display Favorites.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


NoFileAssociate

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | Terminal Services systems: 1 All other Windows 2000 systems 0

Description

Disables the buttons on the File Types tab. As a result, users can view file type associations, but they cannot add, delete, or change them.

The File Types tab shows which programs open when you double-click a type of file. The file types are represented by their file name extension.

Value | Meaning
0 | The user can add, delete, and change file type associations.
1 | The user cannot add, delete, or change file type associations.

By disabling this tab, you can prevent malicious users from creating an association that starts a risky or destructive program. Also, users cannot create less-productive associations, such as associating the .doc file type with Microsoft Wordpad instead of Microsoft Word.

Note Image Note

Although this entry is located in the Policies\Explorer subkey, it is not associated with a Group Policy included in Windows 2000. You can create a policy by adding this entry to an Administrative Templates file. For information, see Creating custom .adm files in Windows 2000 Help.

This entry only applies to the current user. To set this entry for all users of the computer, use NoFileAssociate in the HKLM subtree. If the settings of these entries conflict, the setting in HKCU overrides the setting in HKLM.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Tip Image Tip

To see the File Types tab, in My Computer, from the Tools menu, click Folder Options, and then click the File Types tab.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

Related Entries

NoFileAssociate (HKLM)


NoFileMenu

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Removes the File menu from My Computer and Windows Explorer and disables the File menu in Internet Explorer.

This entry stores the setting of the Remove File menu from Windows Explorer Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. The File menus are active.
1 | The policy is enabled. The File menus are removed or disabled.

This entry does not prevent users from using other methods to perform tasks available on the File menu.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Remove File menu from Windows Explorer policy (User Configuration\Administrative Templates\Windows Components\Windows Explorer).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


NoFind

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Removes or disables selected search features.

This entry stores the setting of the Remove Search menu from Start Menu Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Remove Search menu from Start Menu policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

When the value of this entry is 1, the following features are removed or disabled. When the value is 0, these features operate normally.

  • The Search item is removed from the Start menu and from the context menu that appears when you right-click the Start menu.
  • The system does not respond when users press F3 or the Application key (the key with the Windows logo) + F.
  • In Windows Explorer, the Search item still appears on the Standard buttons toolbar, but the system does not respond when the user presses Ctrl + F.
  • In Windows Explorer, the Search item does not appear in the context menu when you right-click an icon representing a drive or a folder.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Remove Search menu from Start Menu policy (User Configuration\AdministrativeTemplates\Start Menu & Taskbar).

Note Image Note

This entry affects the specified user interface elements only. It does not affect Internet Explorer and does not prevent the user from using other methods to search.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoShellSearchButton


NoFolderOptions

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Removes the Folder Options item from all Windows Explorer menus and removes the Folder Options item from Control Panel. As a result, users cannot use the Folder Options dialog box.

This entry stores the setting of the Remove the Folder Options menu item from the Tools menu Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. The Folder Options item appears.
1 | The policy is enabled. The Folder Options item is removed.

The Folder Options dialog box lets users set many properties of Windows Explorer, such as Active Desktop, Web view, Offline Files, hidden system files, and file types.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Remove the Folder Options menu item from the Tools menu policy (User Configuration\Administrative Templates\Windows Components\Windows Explorer).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoActiveDesktop

ForceActiveDesktopOn

NoConfigCache (HKCU)


NoHardwareTab

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Removes the Hardware tab.

A value of 1 removes the Hardware tab from Mouse, Keyboard, and Sounds and Multimedia in Control Panel. It also removes the Hardware tab from the Properties dialog box for all local drives, including hard drives, floppy disk drives, and CD-ROM drives. As a result, users cannot use the Hardware tab to view or change the device list or device properties, or use the Troubleshoot button to resolve problems with the device.

This entry stores the setting of the Hide Hardware tab Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. The Hardware tab appears.
1 | The policy is enabled.The Hardware tab is removed.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Hide Hardware tab policy (User Configuration\Administrative Templates\Windows Components\Windows Explorer).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


NoInstrumentation

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Disables user tracking.

A value of 1 prevents the system from tracking the programs users run, the paths they navigate, and the documents they open. The system uses this information to customize Windows features. As a result, the system disables customized menus and other features that require user tracking information.

This entry stores the setting of the Disable user tracking Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Disable user tracking policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. Enables user tracking.
1 | Disables user tracking and features that require tracking data, such as personalized menus.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable user tracking policy (User Configuration\AdministrativeTemplates\Start Menu & Taskbar).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoIntellimenus


NoInternetIcon

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Removes the Internet Explorer icon from the desktop and from the Quick Launch bar on the taskbar.

This entry stores the setting of the Hide Internet Explorer icon on desktop Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. The Internet Explorer icon appears on the desktop.
1 | The policy is enabled.The Internet Explorer icon is hidden.

This entry does not prevent the user from starting Internet Explorer by using other methods.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Hide Internet Explorer icon on desktop policy (User Configuration\AdministrativeTemplates\Desktop).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


NoLogoff

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Prevents the user from logging off of Windows 2000.

When the value of this entry is 1, users cannot log off of the system by using any method, including programs run from the command line, such as scripts. It also disables or removes all menu items and buttons that log the user off of the system.

This entry stores the setting of the Disable Logoff Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. The user can log off.
1 | The policy is enabled. The user cannot log off.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable Logoff policy (User Configuration\Administrative Templates\System\Logon/Logoff).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

ForceStartMenuLogOff

StartMenuLogOff


NoManageMyComputerVerb

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Removes the Manage item from the Windows Explorer context menu. The context menu appears when you right-click Windows Explorer or My Computer.

This entry stores the setting of the Hides the Manage item on the Windows Explorer context menu Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. The Manage item appears in the Windows Explorer context menu.
1 | The policy is enabled. The Manage item is removed from the Windows Explorer context menu.

The Manage item opens Computer Management (Compmgmt.msc), a console tool which includes many of the primary Windows 2000 administrative tools, such as Event Viewer, Device Manager, and Disk Management. You must be an administrator to use many of the features of these tools.

This entry does not remove the Computer Management item from the Start menu (Start, Programs, Administrative Tools, Computer Management), nor does it prevent users from using other methods to start Computer Management.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Hides the Manage item on the Windows Explorer context menu policy (User Configuration\Administrative Templates\Windows Components\Windows Explorer).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoViewContextMenu


NoMovingBands

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Prevents users from adjusting the length of desktop toolbars, reordering items on toolbars, or repositioning docked toolbars.

This entry stores the setting of the Disable adjusting desktop toolbars Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. Users can adjust toolbars.
1 | The policy is enabled. Users cannot adjust toolbars.

This entry does not prevent users from adding or removing toolbars on the desktop.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable adjusting desktop toolbars policy (User Configuration\AdministrativeTemplates\Desktop).

Note Image Note

If users have adjusted their toolbars, this entry prevents them from restoring the default configuration.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoCloseDragDropBands


NoNetConnectDisconnect

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Prevents users from using Windows Explorer or My Network Places to map or disconnect network drives.

This entry stores the setting of the Remove "Map Network Drive" and "Disconnect Network Drive" Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

The policy is enabled. Users cannot map or disconnect newtork drives.
Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. Users can map and disconnect network drives.
1 |

A value of 1 removes the Map Network Drive and Disconnect Network Drive commands from the toolbar and Tools menus in Windows Explorer and My Network Places and from menus that appear when you right-click the Windows Explorer or My Network Places icons. It also removes the Add Network Place option from My Network Places.

nThis policy does not prevent users from connecting to another computer, such as by typing the name of a shared folder in the Run dialog box

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Remove "Map Network Drive" and "Disconnect Network Drive" policy (User Configuration\Administrative Templates\Windows Components\Windows Explorer).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoDrives


NoNetHood

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Removes the My Network Places icon from the desktop.

This entry stores the setting of the Hide My Network Places icon on desktop Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. The My Network Places icon appears on the desktop.
1 | The policy is enabled. The My Network Places icon is hidden.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Hide My Network Places icon on desktop policy (User Configuration\AdministrativeTemplates\Desktop).

Note Image Note

This entry only affects the desktop icon. It does not prevent users from connecting to the network or browsing for shared computers on the network.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoEntireNetwork

NoComputersNearMe


NoNetworkConnections

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Prevents users from running Network and Dial-up Connections.

This entry stores the setting of the Remove Network and Dial-up Connections from Start Menu Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable theRemove Network and Dial-up Connections from Start Menu policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | Network and Dial-up Connections runs.
1 | Network and Dial-up Connections does not run.

A value of 1 prevents the Network and Dial-up Connections folder from opening and removes Network and Dial-up Connections from the Settings menu on the Start menu. Network and Dial-up Connections still appears in Control Panel and in Windows Explorer, but if a user tries to start it, a message appears explaining that a policy prevents the action.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Remove Network and Dial-up Connections from Start Menu policy (User Configuration\AdministrativeTemplates\Start Menu & Taskbar).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoSetFolders

NoControlPanel


NoRecentDocsHistory

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Prevents the system from saving shortcuts to documents the user has recently opened.

By default, the system saves a shortcut to each of the non-program files the user most recently opened and displays the shortcuts on the Start menu under Documents. The shortcuts let users easily review and restart recently used documents.

This entry stores the setting of the Do not keep history of recently opened documents Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable theDo not keep history of recently opened documents policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. Document shortcuts are saved.
1 | The policy is enabled. Document shortcuts are not saved.

You can use this policy, in coordination with the Remove Documents menu from Start Menu policy (NoRecentDocsMenu) and the Clear history of recently opened documents on exit policy (ClearRecentDocsOnExit) to manage access to recently opened files.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Do not keep history of recently opened documents policy (User Configuration\AdministrativeTemplates\Start Menu & Taskbar).

Note Image Note

If you set the value of this entry to 1 and do not set the value of NoRecentDocsMenu to 1, the Documents menu appears on the Start menu, but it is empty.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

ClearRecentDocsOnExit

MaxRecentDocs

NoRecentDocsMenu


NoRecentDocsMenu

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Removes the Documents menu from the Start menu.

The Documents menu contains links to the non-program files that users have most recently opened. It appears so that users can easily reopen the documents.

This entry stores the setting of the Remove Documents menu from Start Menu Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Remove Documents menu from Start Menu policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. The Documents menu appears on the Start menu.
1 | The policy is enabled. The Documents menu is removed from the Start menu.

You can use the Remove Documents menu from Start Menu policy, in coordination with the Do not keep history of recently opened documents policy (NoRecentDocsHistory) and Clear history of recently opened documents policy (ClearRecentDocsOnExit) to customize access to recently opened files.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Remove Documents menu from Start Menu policy (User Configuration\AdministrativeTemplates\Start Menu & Taskbar).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

ClearRecentDocsOnExit

MaxRecentDocs

NoRecentDocsHistory


NoRecentDocsNetHood

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Remote shared folders are not added to My Network Places when you open a document in the shared folder.

This entry stores the setting of the Do not add shares from recently opened documents to the My Network Places folder Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. When you open a document in a remote shared folder, the system adds a connection to the shared folder to My Network Places.
1 | The policy is enabled. Shared folders are not added to My Network Places automatically when you open a document in the shared folder.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Do not add shares from recently opened documents to the My Network Places folder policy (User Configuration\AdministrativeTemplates\Desktop).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


NoResolveSearch

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Prevents the system from conducting a comprehensive search of the target drive to resolve a shortcut.

By default, when the system cannot find the target file for a shortcut (.lnk), it searches all paths associated with the shortcut. If the target file is located on an NTFS partition, the system then uses the target's file ID to find a path. If the resulting path is not correct, it conducts a comprehensive search of the target drive in an attempt to find the file.

When the value of this entry is 1, the system does not conduct the final drive search. It just displays a message explaining that the file is not found.

This entry stores the setting of the Do not use the search-based method when resolving shell shortcuts Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. The system conducts a comprehensive search of the target drive.
1 | The policy is enabled. The system does not conduct the final drive search. It just displays a message explaining that the file is not found.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Do not use the search-based method when resolving shell shortcuts policy (User Configuration\AdministrativeTemplates\Start Menu & Taskbar).

Note Image Note

This entry only applies to target files on NTFS partitions. FAT partitions do not have this ID tracking and search capability.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

LinkResolveIgnoreLinkInfo

NoResolveTrack


NoResolveTrack

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines if the system is prevented from using NTFS tracking features to resolve a shortcut.

By default, when the system cannot find the target file for a shortcut (.lnk), it searches all paths associated with the shortcut. If the target file is located on an NTFS partition, the system then uses the target's file ID to find a path. If the resulting path is not correct, it conducts a comprehensive search of the target drive in an attempt to find the file.

Prevents the system from using NTFS tracking features to resolve a shortcut.

By default, when the system cannot find the target file for a shortcut (.lnk), it searches all paths associated with the shortcut. If the target file is located on an NTFS partition, the system then uses the target's file ID to find a path. If the resulting path is not correct, it conducts a comprehensive search of the target drive in an attempt to find the file.

If the value of this entry is 1, the system does not try to locate the file by using its file ID. It skips this step and begins a comprehensive search of the drive specified in the target path.

This entry stores the setting of the Do not use the tracking-based method when resolving shell shortcuts Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. The system uses NTFS tracking features.
1 | The system does not use NTFS tracking features.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Do not use the tracking-based method when resolving shell shortcuts policy (User Configuration\AdministrativeTemplates\Start Menu & Taskbar).

Note Image Note

This entry only applies to target files on NTFS partitions. FAT partitions do not have this ID tracking and search capability.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

LinkResolveIgnoreLinkInfo

NoResolveSearch


NoRun

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Removes the Run command from the Start menu and removes the New Task (Run) command from Task Manager. Also, users with extended keyboards can no longer display the Run dialog box by pressing the Application key (the key with the Windows logo) + R.

Removes the Run command from the Start menu and removes the New Task (Run) command from Task Manager. Also, users with extended keyboards can no longer display the Run dialog box by pressing Application key (the key with the Windows logo) + R.

This entry stores the setting of the Remove Run menu from Start Menu Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Remove Run menu from Start Menu policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. The Run command appears.
1 | The policy is enabled. The Run command is removed.

This entry affects the specified interfaces only. It does not prevents users from using other methods to run programs.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Remove Run menu from Start Menu policy (User Configuration\AdministrativeTemplates\Start Menu & Taskbar).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


NoRunasInstallPrompt

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Removes the Install Program As Other User dialog box for local and network installations. As a result, users cannot submit alternate logon credentials to install a program.

This entry stores the setting of the Do not request alternate credentials Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. Users can submit alternate logon credentials to install a program.
1 | The policy is enabled. Users cannot submit alternate logon credentials to install a program.

Install Program As Other User dialog box prompts the current user for the user name and password of an administrator. It appears when users who are not administrators try to install programs from local media.

Many programs can be installed only by an administrator. A value of 0 allows administrators who have logged on as regular users to install programs without logging off and logging on again using their administrator credentials

When the value of this entry is 1, and a user does not have sufficient permissions to install a program, the installation continues with the current user's logon credentials. As a result, the installation might fail, or it might complete but not include all features. Or, the installationt might appear to complete successfully, but the installed program might not operate correctly.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Do not request alternate credentials policy (User Configuration\Administrative Templates\Windows Components\Windows Explorer).

Note Image Note

By default, users are not prompted for alternate logon credentials when installing programs from a network share. If the value of this entry is 1, users are not prompted for administrator credentials on any installation and the PromptRunasInstallNetPath entry is ignored.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

PromptRunasInstallNetPath


NoSaveSettings

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Prevents users from saving certain changes to the desktop. Users can change the desktop, but some changes, such as the positions of open windows and the size and position of the taskbar, are not saved when users log off. Shortcuts placed on the desktop are always saved.

This entry stores the setting of the Don't save settings at exit Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. Changes to the desktop are saved.
1 | The policy is enabled. Some changes to the desktop are not saved.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Don't save settings at exit policy (User Configuration\AdministrativeTemplates\Desktop).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


NoSetFolders

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Prevents Control Panel, Printers, and Network and Dial-up Connections from running, and removes the corresponding menu items.

This entry stores the setting of the Disable programs on Settings menu Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Disable programs on Settings menu policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. Control Panel, Printers, and Network and Dial-up Connections can run.
1 | The policy is enabled. Control Panel, Printers, and Network and Dial-up Connections do not run.

A value of 1 removes the Control Panel, Printers, and Network and Dial-up Connections folders from the Settings menu on the Start menu, and from My Computer and Windows Explorer. It also prevents the programs represented by these folders (such as Control.exe) from running. However, users can still start Control Panel items by using other methods, such as right-clicking the desktop to start Display or right-clicking My Computer to start System.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable programs on Settings menu policy (User Configuration\AdministrativeTemplates\Start Menu & Taskbar).

Note Image Note

A value of 1 also disables other items that appear as folders in Control Panel, such as Fonts and Scheduled Tasks.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoAddPrinter

NoControlPanel

NoDeletePrinter

NoDispCPL

NoNetworkConnections


NoSetTaskbar

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Prevents the user from opening the Taskbar and Start Menu Properties dialog box.

A value of 1 removes the Taskbar & Start Menu item from the Settings menu on the Start menu. Also, if a user right-clicks the taskbar and then clicks Properties, a message appears explaining that a policy prevents the action.

This entry stores the setting of the Disable changes to Taskbar and Start Menu Settings Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Disable changes to Taskbar and Start Menu Settings policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. Users can use the Taskbar and Start Menu Properties dialog box.
1 | The policy is enabled. Users cannot open or use the Taskbar and Start Menu Properties dialog box.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable changes to Taskbar and Start Menu Settings policy (User Configuration\AdministrativeTemplates\Start Menu & Taskbar).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoChangeStartMenu


NoShellSearchButton

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Removes the Search button from the Standard Buttons toolbar that appears in Windows Explorer and other programs that use the Windows Explorer window, such as My Computer and My Network Places.

This entry stores the setting of the Remove Search button from Windows Explorer Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. The Search button appears on the Windows Explorer toolbar.
1 | The policy is enabled. The Search button is removed from the Windows Explorer toolbar.

This entry does not remove the Search button or affect any search features of Internet browser windows, such as the Internet Explorer window. Also, it does not affect the Search items on the Windows Explorer context menu or on the Start menu.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Remove Search button from Windows Explorer policy (User Configuration\Administrative Templates\Windows Components\Windows Explorer).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoFind

NoViewContextMenu


NoSMHelp

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Removes the Help command from the Start menu.

This entry stores the setting of the Remove Help menu from Start Menu Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Remove Help menu from Start Menu policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. The Help command appears on the Start menu.
1 | The policy is enabled. The Help command is removed from the Start menu.

This entry only affects the Start menu. It does not remove the Help menu from Windows Explorer and does not prevent users from running Windows 2000 Help.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Remove Help menu from Start Menu policy (User Configuration\AdministrativeTemplates\Start Menu & Taskbar).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


NoSMMyDocs

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Removes the My Documents icon from the Start Menu and its submenus.

This entry stores the setting of the Remove My Documents icon from Start Menu Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. The My Documents icon appears on the Start menu.
1 | The policy is enabled. The My Documents icon is removed from the Start menu.

A value of 1 only removes the icon. It does not prevent the user from using other methods to gain access to the contents of the My Documents folder.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Remove My Documents icon from Start Menu policy (User Configuration\AdministrativeTemplates\Start Menu & Taskbar).

Note Image Note

To make changes to this entry effective, you must log off of and log back on to Windows 2000.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

{450D8FBA-AD25-11D0-98A8-0800361B1103} (Removes the My Documents icon from the desktop)


NoStartMenuSubFolders

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Hides all folders on the user-specific (top) section of the Start menu. Other items appear, but folders are hidden.

This entry stores the setting of the Remove user's folders from the Start Menu Group Policy. Group Policy adds this entry to the registry when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. Windows 2000 displays folders on both sections of the Start menu.
1 | The policy is enabled. No folders appear on the top section of the Start menu. If users add folders to the Start Menu directory in their user profiles, the folders appear in the directory but not on the Start menu.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Remove user's folders from the Start Menu policy (User Configuration\AdministrativeTemplates\Start Menu & Taskbar).

Note Image Note

This entry hides all user-specific folders, not just those associated with redirected folders.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


NoTrayContextMenu

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Hides the menus that appear when you right-click the taskbar or right-click items on the taskbar.

This entry stores the setting of the Disable context menu for taskbar Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Disable context menu for taskbar policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. Context-sensitive menus appear when you right-click the taskbar or items on the taskbar.
1 | The policy is enabled. Context-sensitive menus are hidden.

This entry does not prevent users from using other methods to issue the commands that appear on these menus.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable context menu for taskbar policy (User Configuration\AdministrativeTemplates\Start Menu & Taskbar).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoChangeStartMenu


NoViewContextMenu

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Removes shortcut menus from the desktop and Windows Explorer. Shortcut menus appear when you right-click an item.

This entry stores the setting of the Disable Windows Explorer's default context menu Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. Shortcut menus appear.
1 | The policy is enabled. Shortcut menus are hidden.

When the value of this entry is 1, menus do not appear when you right-click the desktop or when you right-click the items in Windows Explorer. This value does not prevent users from using other methods to issue commands available on the shortcut menus.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable Windows Explorer's default context menu policy (User Configuration\Administrative Templates\Windows Components\Windows Explorer).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoManageMyComputerVerb

NoShellSearchButton


NoViewOnDrive

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0x0 - 0x3FFFFFF | 0x0

Description

Prevents users from using My Computer to gain access to the content of selected drives.

When a drive is represented in the value of this entry, users cannot view the contents of the selected drives in My Computer or Windows Explorer. Also, they cannot use the Run dialog box, the Map Network Drive dialog box, or the Dir command to view the directories on these drives.

This entry stores the setting of the Prevent access to drives from My Computer Group Policy. Group Policy adds this entry to the registry when you enable the Prevent access to drives from My Computer policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0x0.

The value of this entry is a 32-bit bitmask. The lower 26 bits in this value correspond to the 26 letters used to identify drives on the local computer and its network. The rightmost bit represents drive A; the 26th bit from the right represents drive Z. To restrict access to a drive, set the bit that corresponds to its drive letter to 1. To permit access to a drive, set the bit that corresponds to its drive letter to 0. To restrict access to all 26 drives, set all bits to 1. This corresponds to a value of 67108863 (decimal) or 0x3FFFFFF (hexadecimal).

Group Policy sets the value of this entry to one of the following values.

Value | Meaning
0x03FFFFFFFF | Restrict all drives.
0x3 | Restrict A and B drives only.
0x4 | Restrict C drive only.
0x8 | Restrict D drive only.
0x7 | Restrict A, B, and C drives only.
0xF | Restrict A, B, C, and D drives only.
0x0 | Do not restrict drives. All drives appear.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Prevent access to drives from My Computer policy (User Configuration\Administrative Templates\Windows Components\Windows Explorer). Select a drive or combination of drives from the drop-down list.

Note Image Note

The icons representing the specified drives still appear in My Computer, but if users double-click the icons, a message appears explaining that a policy prevents the action.

This entry does not prevent users from using programs to access local and network drives. Also, it does not prevent users from using the Disk Management snap-in to view and change drive characteristics.

By default, the system permits access to all drives. Therefore, disabling the Prevent access to drives from My Computer policy, not configuring the policy, and enabling the policy and setting it to Do not restrict drives do not have any effect on the system.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoDrives


NoWelcomeScreen

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Suppresses the Getting Started with Windows 2000 welcome screen. By default, this screen appears in Windows 2000 Professional each time a user logs on.

This entry stores the setting of the Don't display welcome screen at logon Group Policy in the User Configuration folder. Group Policy adds this entry to the registry with a value of 1 when you enable the Don't display welcome screen at logon policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. Getting Started with Windows 2000 appear in Windows 2000 Professional each time a user logs on.
1 | The policy is enabled. Getting Started with Windows 2000 is not displayed automatically, although users can display it on demand.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Don't display welcome screen at logon policy (User Configuration\Administrative Templates\System).

Note Image Note

This entry takes precedence over a user setting. While the Don't display welcome screen at logon policy is enabled (the value of this entry is 1), the system ignores the setting of the Show this screen at startup check box on the welcome screen and the value of Show, which stores the setting.

This entry applies only to Windows 2000 Professional. It does not affect the Configure Your Server on a Windows 2000 Server welcome screen on Windows 2000 Server.

This entry can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If the entry appears in both places, the value of the entry in HKEY_LOCAL_MACHINE takes precedence over the value in HKEY_CURRENT_USER.

Tip Image Tip

To display the welcome screen, click Start, point to Programs, point to Accessories, point to System Tools, and then click Getting Started. To suppress the welcome screen without setting a policy, clear the Show this screen at startup check box on the welcome screen.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoWelcomeScreen (HKLM)

Show


NoWindowsUpdate

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Prevents users from connecting to the Windows Update Web site.

A value of 1 prevents users from connecting to the Windows Update Web site at http://windowsupdate.microsoft.com from Windows 2000. Also, this policy removes the Windows Update hyperlink from the Start Menu and from the Tools menu in Internet Explorer.

This entry stores the setting of the Disable and remove links to Windows Update Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Disable and remove links to Windows Update policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. Users can connect to the Windows Update Web site.
1 | The policy is enabled. Users cannot connect to the Windows Update Web site.

Windows Update, the online extension of Windows, offers software updates to keep a user's system up-to-date. The Windows Update Product Catalog determines which system files, security fixes, and Microsoft updates users need and shows the newest versions available for downloading.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable and remove links to Windows Update policy (User Configuration\AdministrativeTemplates\Start Menu & Taskbar).

Note Image Note

While this policy is enabled, users who try to connect to the Windows Update Web site are redirected to an alternate page. To see this page, enable the policy, and then go to the Windows Update Web site at http://windowsupdate.microsoft.com.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoAddFromInternet


PromptRunasInstallNetPath

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Prompts users for alternate logon credentials during network-based installations.

By default, users are only prompted for administrator credentials when installing programs from local media. A value of 1 extends this privilege even when users are installing programs from a network share.

This entry stores the setting of the Request credentials for network installations Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. The Install Program As Other User dialog box appears only when users are installing programs from local media.
1 | The policy is enabled. The Install Program As Other User dialog box appears even when a program is being installed from files on a network computer across a local area network connection.

The Install Program as Other User dialog box prompts the current user for the user name and password of an administrator. Setting the value of this entry to 1 allows administrators who have logged on as regular users to install programs without logging off and logging on again using their administrator credentials.

If the Install Program as Other User dialog box doesn't appear, the installation proceeds with the current user's permissions. If these permissions are not sufficient, the installation might fail, or it might complete but not include all features. Or it might appear to complete successfully, but the installed program might not operate correctly.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Request credentials for network installations policy (User Configuration\Administrative Templates\Windows Components\Windows Explorer).

Note Image Note

If the value of the NoRunAsInstallPrompt entry is 1, it takes precedence over the setting for this entry. Users are not prompted for alternate logon credentials on any installation and the PromptRunAsInstallNetPath entry is igored.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoRunAsInstallPrompt


RestrictCpl

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Hides the icons representing all Control Panel items and folders, except those specified by entries in the RestrictCpl subkey. When hidden, the icons representing Control Panel programs and folders do not appear on the Start menu or in the Control Panel window.

This entry stores the setting of the Show only specified control panel applets Group Policy. Group Policy adds this entry the registry with value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes this entry from the registry.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. The system displays the icons of all Control Panel items.
1 | The policy is enabled. The system hides the icons of all Control Panel items, except those specified by entries in the RestrictCpl subkey. It does not prevent any Control Panel programs from running.

Change method

To change the value of the entries in this subkey, use Group Policy. These entries correspond to the Show only specified control panel applets policy (User Configuration\Administrative Templates\Control Panel).

Note Image Note

There is also a RestrictCpl subkey, which stores the names of Control Panel items that are displayed while this policy is in effect. If the subkey does not appear in the registry or does not contain any entries, the Control Panel window is empty.

The Hide specified control panel applets policy takes precedence over the Show only specified control panel applets policy. If the same Control Panel item appears in both the DisallowCpl subkey and the RestrictCpl subkey, the item is hidden, and the entry in the RestrictCpl subkey is ignored.

Tip Image Tip

To find the file name of a Control Panel item, search for files with the .cpl file name extension in the Systemroot\System32 directory.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

DisallowCpl (subkey)

NoDispCPL

RestrictCpl (subkey)


RestrictRun

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\

Description

The RestrictRun subkey contains a list of programs that restricted users can still run. This list is used only when the value of the RestrictRun entry is 1.

This subkey stores the contents of the Show Contents box in the Run only allowed Windows applications Group Policy. Group Policy adds this subkey and its entries to the registry when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes this subkey and its entries from the registry.

The entries in this subkey comprise a complete list of the Windows programs which affected users can run. If a program is not represented by an entry in this subkey, users cannot run the program. If no entries appear in this subkey, users cannot run any programs started by Windows Explorer.

Each entry in this subkey represents a Windows program, such as Notepad, and contains the name of the executable file for the program, such as Notepad.exe. The number that names this entry only represents the order in which the programs are entered. It does not affect the feature.

These entries have the following format. All entries must include the file name extension of the file.

Item-number REG_SZ Name of executable file

For example, the following entry permits restricted users to use Microsoft Word (Winword.exe).

1 REG_SZ Winword.exe

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Run only allowed Windows applications policy (User Configuration\Administrative Templates\System).

Note Image Note

There is also a RestrictRun entry which enables the Run only allowed Windows applications policy. If the RestrictRun entry is not in the registry, or if its value is 0, the policy is not enabled, and the system ignores the RestrictRun subkey and its entries.

This entry only prevents users from running programs that are started by the Windows Explorer process. It does not prevent users from running programs such as Task Manager, which are started by the system process or by other processes. Also, if users have access to the command prompt, Cmd.exe, this policy does not prevent them from starting programs in the command window that they are not permitted to start by using Windows Explorer.

The Run only allowed Windows applications policy takes precedence over the Don't run specified Windows applications policy. If both policies are applied to the same user, the Run only allowed Windows applications policy is implemented and the Don't run specified Windows applications policy is ignored.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Caution Image Caution

If you are the person who applies Group Policy, do not apply this policy to yourself. If applied too broadly, this policy can prevent administrators from running Group Policy or the registry editors. As a result, once applied, you cannot change this policy except by reinstalling Windows 2000.

Related Entries

DisallowRun (subkey)

RestrictRun (subkey)


Run

HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer\

Description

The Run subkey stores the names of executable files and document files that Windows 2000 runs automatically when this user logs on to the system.

There are several Run subkeys in the registry. Group Policy adds this subkey and its entries to the registry when you enable the Run these programs at user logon policy in the User Configuration folder. If you disable the policy or set it to Not configured, Group Policy deletes the Run subkey (and all of its entries) from the registry.

Each entry in the Run subkey represents a program or document. The entry name is an ordinal number, and its value is the name of (and, optionally, the path to) an executable file or document. You provide the file name when you configure the policy.

Each entry in the run subkey has the following format:

Number REG_SZ [Path]File name

For example, the entry

1 REG_SZ Calc.exe

indicates that the Windows calculator will be started automatically when a user logs on.

2 REG_SZ E:\NewFile\Readme.doc

indicates that the ReadMe document will be started automatically when a user logs on.

Note Image Note

The Policies\Explorer\Run subkey can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If this entry appears in both subtrees, the system starts the programs specified in HKEY_LOCAL_MACHINE just before it starts the programs specified in HKEY_CURRENT_USER.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


StartMenuLogOff

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Removes the Log Off user-name item from the Start menu and prevents users from restoring it.

Also, the system removes the Display Logoff item from Start Menu Options to prevent users from restoring the Log Off user-name item while the policy is in effect.

This entry stores the setting of the Disable Logoff on the Start Menu Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Disable Logoff on the Start Menu policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. Users can use the Display Logoff item to add and remove the Log Off <username> item.
1 | The policy is enabled. The Log Off <username> item is removed the Start menu and users cannot restore it.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable Logoff on the Start Menu policy (User Configuration\AdministrativeTemplates\Start Menu & Taskbar).

Note Image Note

This entry affects the Start menu only. It does not affect the Log Off item on the Windows Security dialog box that appears when you press Ctrl+Alt+Del, and it does not prevent users from using other methods to log off.

This entry takes precedence over a user setting. When this entry appears in the registry, a policy is in effect, and the system ignores the value of StartMenuLogoff in HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced. If the Logoff item does not operate as expected, check to see if this entry is in the registry.

The Disable Logoff on the Start Menu policy takes precedence over the Add Logoff to the Start Menu policy. That is, when the value of StartMenuLogoff is 1, the system removes the Logoff username item from the Start menu and ignores the ForceStartMenuLogOff entry.

Tip Image Tip

To add or remove the Log Off <username> item without setting a policy, click Start, click Settings, click Taskbar & Start Menu, click the Advanced tab and, in the Start Menu Settings box, click Display Logoff.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoLogoff

ForceStartMenuLogOff


Network

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\

Description

The Policies\Network subkey contains entries that store Group Policy settings for network services, such as Offline Files and Network and Dial-up Connections. The entries in this subkey are written and maintained by Group Policy and read and interpreted by the network services programs.

Entries appear in this subkey when you configure a policy; that is, when you enable or disable the policy.

Note Image Note

Many of the entries in this subkey have counterparts elsewhere in the registry. These counterparts, known as preferences, have the same effect on user or computer features as entries in the Policies subkey. However, the entries in the Policies subkey always take precedence over the entries located elsewhere in the registry. When an entry appears in the Policies subkey, the preference is ignored.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


NoEntireNetwork

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Network

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Removes the Entire Network option and the icons representing networked computers from My Network Places and from the Map Network Drive browser. As a result, users cannot view computers outside of their workgroup or local domain in lists of network resources in Windows Explorer and My Network Places.

This entry stores the setting of the No "Entire Network" in My Network Places Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. The Entire Network option appears.
1 | The policy is enabled. The Entire Network option is removed.

This entry does not prevent users from viewing or connecting to computers in their workgroup or domain. It also does not prevent users from connecting to remote computers by other commonly used methods, such as typing the share name in the Run dialog box or the Map Network Drive dialog box.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the No "Entire Network" in My Network Places policy (User Configuration\Administrative Templates\Windows Components\Windows Explorer).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoNetHood

NoComputersNearMe


NonEnum

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\

Description

The NonEnum subkey of the Policies subkey contains entries that tell the system not to enumerate (display) components of the Windows interface. These entries are written and maintained by Group Policy and read and interpreted by the interface programs.

The Non-Enum policy subkey in HKEY_CURRENT_USER stores entries that are configured separately for each user. There is also a Software\Microsoft\Windows\CurrentVersion\Policies\NonEnum subkey in HKEY_LOCAL_MACHINE that stores policy-related entries that apply to all users of this computer.

The entries in this subkey have the following format:

Class-ID or GUID of the component REG-DWORD 0 | 1

Group Policy stores the values of policy settings in this subkey. It adds, deletes, or changes the values of entries in this subkey when you configure related Group Policies.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NonEnum subkey (HKLM)


{450D8FBA-AD25-11D0-98A8-0800361B1103}

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\NonEnum

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Removes the My Documents icon.

This entry stores the setting of the Remove My Documents icon from desktop Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 | The My Documents icon appears.
1 | The My Documents icon is removed from the desktop, from Windows Explorer, from programs that use the Windows Explorer windows, and from the standard Open dialog box.

This entry does not prevent the user from using other methods to gain access to the contents of the My Documents folder.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Remove My Documents icon from desktop policy (User Configuration\AdministrativeTemplates\Desktop).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoSMMyDocs


System

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\

Description

The System subkey stores the entries created when you configure a Group Policy that affects a basic component of Windows 2000. The entries in this subkey are written and maintained by Group Policy and read and interpreted by the component program.

The System subkey in HKEY_CURRENT_USER stores policy-related entries that are configured separately for each user. There is also a Software\Microsoft\Windows\CurrentVersion\Policies\System subkey in HKEY_LOCAL_MACHINE that stores entries that apply to all users of this computer.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

HKCU\Software\Policies\Microsoft\Windows\System

HKLM\SOFTWARE\Policies\Microsoft\System

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

HKLM\SOFTWARE\Policies\Microsoft\Windows\System


ConnectHomeDirToRoot

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Restores the definitions of the %HOMESHARE% and %HOMEPATH% environment variables to those used in Windows NT 4.0 and earlier. This entry lets you use scripts designed for Windows NT on Windows 2000.

This entry stores the setting of the Connect home directory to root of the share Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy, Group Policy sets the value to 0. If you set the policy to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. The system uses the Windows 2000 definitions of %HOMESHARE% and %HOMEPATH%.
1 | The policy is enabled. The system uses the Windows NT 4.0 definitions of %HOMESHARE% and %HOMEPATH%.

Along with %HOMEDRIVE%, %HOMESHARE% and %HOMEPATH% define the home directory of a user profile. The home directory is a persistent mapping of a drive letter on the local computer to a local or remote directory.

On Windows 2000, %HOMESHARE% stores the fully qualified path to the home directory (such as \\server\share\dir1\dir2\homedir). Users can access the home directory and any of its subdirectories from the home drive letter, but they cannot see or access its parent directories. %HOMEPATH% stores a final backslash and is included for compatibility with earlier systems.

On Windows NT 4.0 and earlier, %HOMESHARE% stores only the network share (such as \\server\share). %HOMEPATH% stores the remainder of the fully qualified path to the home directory (such as \dir1\dir2\homedir). As a result, users can access any directory on the home share by using the home directory drive letter.

See an example.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Connect home directory to root of the share policy (User Configuration\Administrative Templates\System\Logon/Logoff).

Tip Image Tip

To specify a home directory in Windows 2000, in Active Directory Users and Computers or Local Users and Groups, right-click the name of a user account, click Properties, click the Profile tab, and in the Home folder section, select the Connect option and select a drive letter and home directory.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


DisableChangePassword

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Disables the Change Password button on the Windows Security dialog box (which appears when you press Ctrl+Alt+Del). As a result, users cannot change their Windows password on demand.

This entry stores the setting of the Disable Change Password Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. The Change Password button is enabled.
1 | The policy is enabled. The Change Password button is disabled.

This entry does not prevent users from changing their password when prompted by the system. The system prompts users for a new password when an administrator requires a new password or their password expires.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable Change Password policy (User Configuration\Administrative Templates\System\Logon/Logoff).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


DisableLockWorkstation

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Prevents users from locking the system.

This entry stores the setting of the Disable Lock Computer Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. Users can lock the computer.
1 | The policy is enabled. Users cannot lock the computer.

While locked, the desktop is hidden and the system cannot be used. Only the user who locked the system or the system administrator can unlock it.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable Lock Computer policy (User Configuration\Administrative Templates\System\Logon/Logoff).

Tip Image Tip

To lock a computer without configuring a policy, press Ctrl+Alt+Delete, and then click Lock Computer.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


DisableRegistryTools

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Disables the Windows registry editors, Regedt32.exe and Regedit.exe.

This entry stores the setting of the Disable registry editing tools Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. The registry editors do not run.
1 | The policy is enabled. The registry editors run.

If a user tries to start a registry editor while the value of this entry is 1, a message appears explaining that a policy prevents the action.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable registry editing tools policy (User Configuration\Administrative Templates\System).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

RestrictRun subkey


DisableTaskMgr

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Prevents users from starting Task Manager (Taskmgr.exe).

This entry stores the setting of the Disable Task Manager Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. Users can run Task Manager.
1 | Users cannot run Task Manager. If a user tries to start Task Manager, a message appears explaining that a policy prevents the action.

Task Manager lets users start and stop programs; monitor the performance of their computers; view and monitor all programs running on their computers, including system services; find the executable names of programs; and change the priority of the process in which programs run.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable Task Manager policy (User Configuration\Administrative Templates\System\Logon/Logoff).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


EnableProfileQuota

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Enables and disables the policy that limits the size of roaming user profiles.

This entry stores the setting of the Limit profile size Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. The system does not limit the size of roaming user profiles.
1 | The policy is enabled. The system limits the size of roaming user profiles. Users cannot log off of the system if their profile exceeds the maximum permitted size.

When a roaming user profile reaches the threshold established by the value of MaxProfileSize, the system does not let the user log off until they reduce their profile to a permissible size. To aid the user, the system displays the files that comprise the user profile, and asks the user to delete files from the list.

The values of related entries let you customize this feature by warning the user that their profile is too large before they try to log off.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Limit profile size policy (User Configuration\Administrative Templates\System\Logon/Logoff).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

ProfileQuotaMessage

MaxProfileSize

IncludeRegInProQuota

WarnUser

WarnUserTimeout


GroupPolicyRefreshTime

HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

Data type | Range | Default value
REG_DWORD | 0 - 64800 minutes | 90

Description

Determines how often Group Policy is applied to computers.

This entry specifies how often Group Policy for computers is updated (in the background) while the computer is in use. This entry specifies a background update rate only for Group Policies in the User Configuration folder.

This entry stores the setting of the Group Policy refresh interval for computers Group Policy. Group Policy adds this entry to the registry when you configure the Group Policy refresh interval for computers policy.

Value | Meaning
(Entry does not appear.) | Group Policy is applied every 90 minutes.
0 | The computer tries to update Group Policy every 7 seconds.
number of minutes | Group Policy is applied each time the specified interval expires.

Because updates might interfere with users' work and increase network traffic, very short update intervals are not appropriate for most installations.

To prevent clients with the same update interval from requesting updates simultaneously, you can also specify how much the actual update interval varies by using the GroupPolicyRefreshTimeOffset entry.

In addition to background updates, Group Policy for the computer is always updated when the system starts.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Group Policy refresh interval for computers policy (User Configuration\Administrative Templates\System\Group Policy).

Note Image Note

If the DisableBkGndGroupPolicy entry is set to 1, this entry is ignored.

This entry establishes the update rate for computer Group Policy. To set an update rate for user policies, use the GroupPolicyRefreshTime (HKLM) entry.

This entry can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If this entry appears in both subtrees, the value in HKEY_LOCAL_MACHINE takes precedence over the value in HKEY_CURRENT_USER.

Tip Image Tip

Consider notifying users that their policy is updated periodically so that they recognize the signs of a policy update. When Group Policy is updated, the Windows desktop is refreshed; it flickers briefly and closes open menus. Also, restrictions imposed by Group Policies, such as those that limit the programs users can run, might interfere with tasks in progress.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

DisableBkGndGroupPolicy

GroupPolicyRefreshTimeDC

GroupPolicyRefreshTime (HKLM)

GroupPolicyRefreshTimeOffset


GroupPolicyRefreshTimeOffset

HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

Data type | Range | Default value
REG_DWORD | 0 - 1440 minutes | 0x1E (30 minutes)

Description

Determines how often Group Policy is applied to computers.

This entry stores the setting of the Group Policy refresh interval for computers Group Policy. Group Policy adds this entry to the registry when you configure the Group Policy refresh interval for computers policy.

This entry specifies a the upper limit to a random offset for how often Group Policy for computers is updated (in the background) while the computer is in use. This entry specifies a background update rate only for Group Policies in the User Configuration folder.

To prevent clients with the same update interval from requesting updates simultaneously, the system varies the update interval for each client by a random number of minutes. The value of this entry sets the upper limit for the range of variance. For example, if the value of this entry is 30 minutes, the system selects a variance of 0 to 30 minutes. A large number establishes a broad range and makes it less likely that client requests overlap. However, updates might be delayed significantly.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Group Policy refresh interval for computers policy (User Configuration\Administrative Templates\System\Group Policy).

Note Image Note

If the DisableBkGndGroupPolicy entry is set to 1, this entry is ignored.

This entry establishes the update rate for User Group Policy. To set an update rate for user policies, use the GroupPolicyRefreshTimeOffset entry in HKLM.

Tip Image Tip

Consider notifying users that their policy is updated periodically so that they recognize the signs of a policy update. When Group Policy is updated, the Windows desktop is refreshed; it flickers briefly and closes open menus. Also, restrictions imposed by Group Policies, such as those that limit the programs users can run, might interfere with tasks in progress.

To specify that Group Policy should never be updated while the computer is in use, enable the Disable background refresh of Group Policy policy.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

DisableBkGndGroupPolicy

GroupPolicyRefreshTimeOffset

GroupPolicyRefreshTimeOffsetDC


HideLegacyLogonScripts

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether logon scripts written for Windows NT 4.0 are displayed as they run.

Logon scripts are batch files of instructions that run when the user logs on. By default, Windows 2000 displays the instructions in logon scripts written for Windows NT 4.0 and earlier in a command window as they run. The system does not display logon scripts written for Windows 2000 as they run.

This entry stores the setting of the Run legacy logon scripts hidden Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy, Group Policy sets the value to 0. If you set the policy to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. Logon scripts written for Windows NT 4.0 and earlier are displayed as they run.
1 | The policy is enabled. Logon scripts written for Windows NT 4.0 and earlier are not displayed as they run.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Run legacy logon scripts hidden policy (User Configuration\Administrative Templates\System\Logon/Logoff).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

HideLogonScripts


HideLogoffScripts

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Displays the instructions in logoff scripts as they run.

Logoff scripts are batch files of instructions that run when the user logs off. By default, the system does not display the instructions in the logoff script.

This entry stores the setting of the Run logoff scripts visible Group Policy. Group Policy adds this entry to the registry with a value of 0 when you enable the policy. If you disable the policy, Group Policy sets the value to 1. If you set the policy to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 1.

Value | Meaning
0 | The policy is enabled. The system displays each instruction in the logoff script as it runs. The instructions appear in a command window. This setting is designed for advanced users.
1 (or not in registry) | The policy is disabled or not configured. The instructions are suppressed.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Run logoff scripts visible policy (User Configuration\Administrative Templates\System\Logon/Logoff).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

HideLogonScripts

HideShutdownScripts

HideStartupScripts


HideLogonScripts

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Displays the instructions in logon scripts as the scripts run.

This entry stores the setting of the Run logon scripts visible Group Policy. Group Policy adds this entry to the registry with a value of 0 when you enable the policy. If you disable the policy, Group Policy sets the value to 1. If you set the policy to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 1.

Value | Meaning
0 | The policy is enabled. The system displays each instruction in the logon script as it runs. The instructions appear in a command window. This setting is designed for advanced users.
1 (or not in registry) | The policy is disabled or not configured. Logon script instructions are suppressed.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Run logon scripts visible policy (User Configuration\Administrative Templates\System\Logon/Logoff).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

HideLegacyLogonScripts

HideLogoffScripts

HideShutdownScripts

HideStartupScripts


IncludeRegInProQuota

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether registry files appear in the list of files that users can delete from their roaming user profile.

When a user's roaming user profile grows too large, the system displays a list of the files that comprise the user profile, and asks the user to delete files from the list.

By default, the NTuser.dat and NTuser.dat.log files, which store and record changes to the HKEY_CURRENT_USER subtree, are excluded from the list, because these files should never be deleted.

This entry stores the setting of the Include registry in file list check box in the Limit profile size Group Policy. Group Policy adds this entry to the registry when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes this entry from the registry and the system does not regulate the size of roaming user profiles.

Value | Meaning
0 | The checkbox is cleared. Registry files do not appear in the profile file list.
1 | The checkbox is selected. Registry files are included in profile file list.

When the value of EnableProfileQuota is 1, and a roaming user profile exceeds the threshold established by the value of MaxProfileSize, system does not let the user log off until they delete enough files to reduce their profile to a permissible size.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Limit profile size policy (User Configuration\Administrative Templates\System\Logon/Logoff). Select or clear the Include registry in files list check box.

Note Image Note

This entry is used only when the Limit profile size policy is enabled, that is, when the value of EnableProfileQuota is 1.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

EnableProfileQuota

MaxProfileSize

ProfileQuotaMessage

WarnUser

WarnUserTimeout


MaxProfileSize

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System

Data type | Range | Default value
REG_DWORD | 0x12C - 0xFFFFFFFF kilobytes | 0x7530 (30000 KB = 30 MB)

Description

Specifies the maximum allowed size of each roaming user profile.

This entry stores the value you type in the Max Profile Size box in the Limit profile size Group Policy. Group Policy adds this entry to the registry when you enable the Limit profile size policy. If you disable the policy or set it to Not configured, Group Policy deletes this entry from the registry and the system does not limit the size of roaming user profiles.

When a roaming user profile reaches the threshold specified in this entry, the system does not let the user log off until they reduce their profile to a a size smaller than or equal to the value of this entry. To aid the user, the system displays the files that comprise the user profile, and asks the user to delete files from the list.

The related entries in this subkey let you warn the user that their profile is too large before they try to log off.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Max Profile Size box in the Limit profile size policy (User Configuration\Administrative Templates\System\Logon/Logoff).

Note Image Note

This entry is used only when the Limit profile size policy is enabled, that is, when the value of EnableProfileQuota is 1.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

EnableProfileQuota

IncludeRegInProQuota

ProfileQuotaMessage

WarnUser

WarnUserTimeout


NoDispAppearancePage

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Removes the Appearance tab from Display in Control Panel. As a result, users cannot use the Display program to change the colors or color scheme of the desktop and windows.

This entry stores the setting of the Hide Appearance tab Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. The Appearance tab appears.
1 | The policy is enabled.The Appearance tab is removed.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Hide Appearance tab policy (User Configuration\Administrative Templates\Control Panel\Display).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


NoDispBackgroundPage

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Removes the Background tab from Display in Control Panel. As a result, users cannot use the Display program to change the pattern or wallpaper on the desktop.

This entry stores the setting of the Hide Background tab Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. The Background tab appears.
1 | The policy is enabled. The Background tab is removed.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Hide Background tab policy (User Configuration\Administrative Templates\Control Panel\Display).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

Wallpaper

NoHTMLWallPaper

NoChangingWallPaper


NoDispCpl

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Prevents Display in Control Panel from running.

This entry stores the setting of the Disable Display in Control Panel Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. Display can run.
1 | Display does not run. When users try to start Display, a message appears explaining that a policy prevents the action.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable Display in Control Panel policy (User Configuration\Administrative Templates\Control Panel\Display).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

DisallowCpl (entry)

NoControlPanel

NoSetFolders

RestrictCpl (entry)


NoDispScrSavPage

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Removes the Screen Saver tab from Display in Control Panel. As a result, users cannot use the Display program to add, configure, or change the screen saver on the computer.

This entry stores the setting of the Hide Screen Saver tab Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. The Screen Saver tab appears.
1 | The policy is enabled. The Screen Saver tab is removed.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Hide Screen Saver tab policy (User Configuration\Administrative Templates\Control Panel\Display).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

ScreenSaveActive

SCRNSAVE.EXE

ScreenSaverIsSecure


NoDispSettingsPage

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Removes the Settings tab from Display in Control Panel. As a result, users cannot use the Display program to add, configure, or change the display settings on the computer.

This entry stores the setting of the Hide Settings tab Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. The Settings tab appears.
1 | The policy is enabled. The Settings tab is removed.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Hide Settings tab policy (User Configuration\Administrative Templates\Control Panel\Display).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


ProfileQuotaMessage

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System

Data type | Range | Default value
REG_SZ | String | You have exceeded your profile storage space. Before you can log off, you need to move some items from your profile to network or local storage.

Description

Specifies the message the system displays to notify user that their roaming user profile is too large .This message is displayed as soon as the system detects that the profile has grown too large.

This entry stores the string you type in the Custom Message box in Limit profile size Group Policy. Group Policy adds this entry to the registry when you enable the Limit profile size policy. If you disable the policy or set it to Not configured, Group Policy deletes this entry from the registry.

The system displays this message only when the value of the WarnUser entry is 1. If the value of WarnUser is 1.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Custom Message box in the Limit profile size policy (User Configuration\Administrative Templates\System\Logon/Logoff).

Note Image Note

This entry is used only when the Limit profile size policy is enabled, that is, when the value of EnableProfileQuota is 1, and when the policy is configured to warn users as soon as their profile exceeds the maximum size, that is, when the value of WarnUser is 1.

To suppress this notification message, clear the Notify user when profile storage space is exceeded check box to set the value of WarnUser to 0. If you delete the ProfileQuotaMessage entry from the registry, the system displays the default message. If you delete the default text from the Custom Message box, or delete the value of ProfileQuotaMessage, the system displays an empty message box.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

EnableProfileQuota

MaxProfileSize

IncludeRegInProQuota

WarnUser

WarnUserTimeout


RunLogonScriptSync

HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Directs the system to wait for the logon scripts to finish running before it starts the Windows Explorer interface program and creates the desktop.

This entry stores the setting of the Run logon scripts synchronously Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Run logon scripts synchronously policy. If you disable the policy, Group Policy sets the value to 0. If you set the policy to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 | The policy is disabled or not configured. Logon scripts and Windows Explorer are not synchronized and can run simultaneously.
1 | The policy is enabled. Windows Explorer does not start until the logon scripts have finished running. This setting assures that logon script processing is complete before the user starts working, but it can delay the appearance of the desktop.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Run logon scripts synchronously policy (User Configuration\Administrative Templates\System\Logon).

Note Image Note

This entry appears in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. The value in HKEY_LOCAL_MACHINE takes precedence over the policy set in HKEY_CURRENT_USER.

This entry takes precedence over a user setting. When this entry appears in the registry, a policy is in effect and the system ignores the value of RunLogonScriptSync (HKLM) and RunLogonScriptSync (HKCU).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

RunLogonScriptSync (HKLM)

RunLogonScriptSync (Winlogon in HKCU)

RunLogonScriptSync (Winlogon in HKLM)


Shell

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System

Data type | Range | Default value
REG_SZ | Path and file name | There is no default value for this entry.

Description

Specifies an alternate user interface for Windows 2000.

This entry stores the setting of the Custom user interface Group Policy. Group Policy adds this entry to the registry when you enable the Custom user interface policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry.

The Explorer program (Explorer.exe) creates the familiar Windows interface, but you can use this entry to specify an alternate interface. When this entry appears in the registry, the system starts the interface you specify instead of Explorer.exe.

Value | Meaning
(Entry does not appear.) | Explorer.exe is used as the interface.
executable name | The specified program is used as the interface.

The value of this entry must include the file name of the interface program, including the .exe file name extension. If the interface program file is not located in a folder specified in the Path environment variable for your system, the entry must include the fully qualified path to the file.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Custom user interface policy (User Configuration\Administrative Templates\System).

Tip Image Tip

To find the folders indicated by the Path environment variable, double-click System Properties in Control Panel, click the Advanced tab, click the Environment Variables button, and then, in the System variables box, click Path.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


Wallpaper

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System

Data type | Range | Default value
REG_SZ | Path and filename | There is no default value for this entry.

Description

Specifies the desktop background (wallpaper) displayed on all users' desktops and prevents users from changing the image or its presentation.

This entry stores the setting of the Wallpaper Name box in the Active Desktop Wallpaper Group Policy. Group Policy adds this entry to the registry when you enable the Active Desktop Wallpaper policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and users can select their own wallpaper.

The value of this entry consists of the path and file name of the file that contains the image. The path can be specified as a local path, such as C:\Winnt\Logo.bmp, or a UNC path, such as \\Server\Share\Logo.bmp. The wallpaper you specify can be stored in a bitmap (*.bmp), JPEG (*.jpg), or HTML (*.htm, *.html) file.

If the value of this entry is blank or incorrect, or if specified file is not available when the user logs on, no wallpaper is displayed. Users cannot specify alternate wallpaper.

If this entry does not appear in the registry, no wallpaper is displayed by default, but users can select the wallpaper of their choice.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Active Desktop Wallpaper policy (User Configuration\AdministrativeTemplates\Desktop\Active Desktop). Type the fully-qualified path and name of the file that stores the wallpaper image. You can type a local path, such as C:\Winnt\Logo.bmp or a UNC path, such as \\Server\Share\Logo.bmp.

Note Image Note

The Active Desktop Wallpaper policy also lets you determine whether the image is tiled, centered, or stretched. This specification is stored in the value of WallpaperStyle.

This entry requires that Active Desktop be enabled. By default, Active Desktop is disabled. To enable Active Desktop by using a policy, use the ForceActiveDesktopOn entry.

This entry takes precedence over a user setting. When this entry appears in the registry, a policy is in effect and the system ignores the value of Wallpaper in the Control Panel\Desktop subkey.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

WallpaperStyle

NoHTMLWallPaper

NoChangingWallPaper


WallpaperStyle

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System\

Data type | Range | Default value
REG_SZ | 0 | 1 | 2 | 0

Description

Determines whether the appearance of the wallpaper specified in the value of Wallpaper is centered, tiled, or stretched, and prevents users from changing this specification.

This entry stores the setting of the Wallpaper Style box in the Active Desktop Wallpaper Group Policy. Group Policy adds this entry to the registry when you enable the Active Desktop Wallpaper policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and users can select their own wallpaper and specify its presentation.

Value | Meaning
(Not in registry) | The policy is not configured. Wallpaper is centered, but users can change the presentation.
0 | Centered.
1 | Tiled.
2 | Stretched.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Active Desktop Wallpaper policy (User Configuration\AdministrativeTemplates\Desktop\Active Desktop).

Note Image Note

This entry only appears when the Active Desktop Wallpaper policy is enabled.

This entry requires that Active Desktop be enabled. By default, Active Desktop is disabled. To enable Active Desktop by using a policy, use the ForceActiveDesktopOn entry.

This entry takes precedence over a user setting. When this entry appears in the registry, a policy is in effect and the system ignores the value of WallpaperStyle in the Control Panel\Desktop subkey.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

Wallpaper

NoHTMLWallPaper

NoChangingWallPaper


WarnUser

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines when the system notifies users that their roaming user profile is too large.

This entry stores the setting of the Notify user when profile storage space is exceeded check box in the Limit profile size Group Policy. Group Policy adds this entry to the registry when you enable the Limit profile size policy. If you disable the policy or set it to Not configured, Group Policy deletes this entry from the registry and the system does not regulate the size of roaming user profiles.

Value | Meaning
0 | The check box is cleared. The system notifies users when they try to log off.
1 | The check box is selected. The system notifies users as soon as it detects that their profile exceeds the permitted maximum size. If the user does not resolve the problem, the system notifies the user when they try to log off.

When the value of EnableProfileQuota is 1, and a roaming user profile exceeds the threshold established by the value of MaxProfileSize, system does not let the user log off until they reduce their profile to a permissible size.

The WarnUser entry lets you notify users in advance that their profile is too large. When the value of this entry is 1, the system displays the message specified by the value of ProfileQuotaMessage. The message is repeated at a rate determined by the value of WarnUserTimeout.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Limit profile size policy (User Configuration\Administrative Templates\System\Logon/Logoff). Select or clear the Notify user when profile storage space is exceeded check box.

Note Image Note

This entry is used only when the Limit profile size policy is enabled, that is, when the value of EnableProfileQuota is 1.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

EnableProfileQuota

IncludeRegInProQuota

MaxProfileSize

ProfileQuotaMessage

WarnUserTimeout


WarnUserTimeout

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF minutes | 0xF (15 minutes)

Description

Determines how often the message specified by the value of ProfileQuotaMessage is displayed. This message is displayed repeatedly at the specified rate when the user's roaming user profile is too large.

This entry stores the value you type in the Remind user every X minutes box in the Limit profile size Group Policy. Group Policy adds this entry to the registry when you enable the Limit profile size policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system does not regulate the size of roaming user profiles.

If the value of this entry is 0, the message is displayed only once.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Limit profile size policy (User Configuration\Administrative Templates\System\Logon/Logoff). Use the Remind user every X minutes spin box to select a time.

Note Image Note

This entry is used only when the Limit profile size policy is enabled, that is, when the value of EnableProfileQuota is 1, and when the policy is configured to warn users as soon as their profile exceeds the maximum size, that is, when the value of WarnUser is 1.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

EnableProfileQuota

IncludeRegInProQuota

MaxProfileSize

ProfileQuotaMessage

WarnUser


Uninstall

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\

Description

The Uninstall subkey contains entries that store Group Policy settings for Add/Remove Programs in Control Panel. The entries in this subkey are written and maintained by Group Policy and read and interpreted by Add/Remove Programs.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


DefaultCategory

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall

Data type | Range | Default value
REG_SZ | Category name | There is no default value for this entry.

Description

Specifies the category of programs that appears when users open the Add New Programs page.

This entry stores the setting of the Specify default category for Add New Programs Group Policy. Group Policy adds this entry to the registry when you enable the Specify default category for Add New Programs policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry.

Value | Meaning
(Not in registry.) | The policy is disabled or not configured. All programs (Category: All Categories) are displayed when the Add New Programs page opens.
Category name | The policy is enabled. Only the programs in the category you specify are displayed when the Add New Programs page opens.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Specify default category for Add New Programs policy (User Configuration\Administrative Templates\Control Panel\Add/Remove Programs). Type the name of a category in the Category text box for this policy. You must enter a category that is already defined in Add/Remove Programs. To define a category, use Software Installation.

Note Image Note

This entry specifies the default category only. It does not prevent users from using the Category box to select another category of programs.

This entry is ignored if the value of NoAddPage is set to 1.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


NoAddFromCDorFloppy

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Removes the Add a program from CD-ROM or floppy disk section from the Add New Programs page. As a result, users cannot use Add/Remove Programs to install programs from removable media.

This entry stores the setting of the Hide the "Add a program from CD-ROM or floppy disk" option Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. The Add a program from CD-ROM or floppy disk option is available to all users.
1 | The policy is enabled. The Add a program from CD-ROM or floppy disk section is removed from the Add New Programs page.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Hide the "Add a program from CD-ROM or floppy disk" option policy (User Configuration\Administrative Templates\Control Panel\Add/Remove Programs).

Note Image Note

This entry does not prevent users from using other tools and methods to add or remove program components.

If the value of the NoAddPage entry is set to 1, this entry is ignored. Also, if the value of the DisableMedia entry is set to 1, users cannot add programs from removable media, regardless of the setting of this entry.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

DisableMedia

NoAddPage


NoAddFromInternet

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Removes the Add programs from Microsoft section of the Add New Programs page. This section includes a button that connects users to the Windows Update Web site. As a result, users cannot connect to Windows Update from Add/Remove Programs.

This entry stores the setting of the Hide the "Add programs from Microsoft" option Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 | The policy is disabled or not configured. The Add programs from Microsoft section is displayed.
1 | The policy is enabled. The Add programs from Microsoft section is removed.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Hide the "Add programs from Microsoft" option policy (User Configuration\Administrative Templates\Control Panel\Add/Remove Programs).

Note Image Note

If the NoAddPage entry is set to 1, then this entry is ignored.

This entry does not prevent users from using other tools and methods to connect to Windows Update.

The Disable and remove links to Windows Update policy (NoWindowsUpdate) prevents users from connecting to Windows Update from Windows 2000. If the value of NoWindowsUpdate is 1, and users click the Windows Update button in Add/Remove Programs, the system displays a message explaining that the action is prevented by a policy.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoAddPage

NoWindowsUpdate


NoAddFromNetwork

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Removes the Add programs from your network section of the Add New Programs page. The Add programs from your network section lists published programs and provides an easy way to install them.

This entry stores the setting of the Hide the "Add programs from your network" option Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. The Add programs from your network section appears. Users can view and install published programs.
1 | The policy is enabled. The Add programs from your network section is removed. Users cannot use this method to view and install published programs.

If the value of this entry is 1, users cannot tell which programs have been published by the system administrator, and they cannot use Add/Remove Programs to install published programs. However, they can still install programs by using other methods, and they can view and install assigned (partially installed) programs that are offered on the desktop or on the Start menu.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Hide the "Add programs from your network" option policy (User Configuration\Administrative Templates\Control Panel\Add/Remove Programs).

Note Image Note

If the value of NoAddPage is set to 1, this entry is ignored.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoAddPage


NoAddPage

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Removes the Add New Programs button from the Add/Remove Programs bar. As a result, users cannot view or change the attached page.

This entry stores the setting of the Hide Add New Programs page Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. The Add New Programs page is available to all users.
1 | The policy is enabled. The Add New Programs button is removed from the Add/Remove Programs bar.

The Add New Programs page lets users install programs published or assigned by a system administrator.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Hide Add New Programs page policy (User Configuration\Administrative Templates\Control Panel\Add/Remove Programs).

Note Image Note

This entry does not prevent users from using other tools and methods to install programs.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoAddFromCDorFloppy

NoAddFromInternet

NoAddFromNetwork


NoAddRemovePrograms

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines if users are prevented from using Add/Remove Programs.

Removes Add/Remove Programs from Control Panel and removes the Add/Remove Programs item from menus. As a result, users cannot run Add/Remove Programs.

This entry stores the setting of the Disable Add/Remove Programs Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. Add/Remove Programs is hidden.
1 | The policy is enabled. Add/Remove Programs is visible and available to users.

Add/Remove Programs lets users install, uninstall, repair, add, and remove features and components of Windows 2000 and a wide variety of Windows programs. Programs published or assigned to the user appear in Add/Remove Programs.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable Add/Remove Programs policy (User Configuration\Administrative Templates\Control Panel\Add/Remove Programs).

Note Image Note

When the value of this entry is set to 1, it takes precedence over the other entries in this subkey.

This entry does not prevent users from using other tools and methods to install or uninstall programs.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


NoRemovePage

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Removes the Change or Remove Programs button from the Add/Remove Programs bar. As a result, users cannot view or change the attached page.

Removes the Change or Remove Programs button from the Add/Remove Programs bar. As a result, users cannot view or change the attached page.

This entry stores the setting of the Hide Change or Remove Programs page Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. The Change or Remove Programs page is available to all users.
1 | The policy is enabled. The Change or Remove Programs button is removed from the Add/Remove Programs bar. As a result, users cannot view or change the attached page.

The Change or Remove Programs button lets users uninstall, repair, add, or remove features of installed programs.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Hide Change or Remove Programs page policy (User Configuration\Administrative Templates\Control Panel\Add/Remove Programs).

Note Image Note

This entry does not prevent users from using other tools and methods to delete or uninstall programs.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


NoServices

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Removes the Set up services section of the Add/Remove Windows Components page. As a result, users cannot use Add/Remove Programs to configure installed services.

This entry stores the setting of the Go directly to Components wizard Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. The Set up services section appears when there are unconfigured system services.
1 | The policy is enabled. The Set up services never appears.

The Set up services section lists system services that have not been configured and offers users easy access to the configuration tools. The Set up services appears only when there are unconfigured system services.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Go directly to Components wizard policy (User Configuration\Administrative Templates\Control Panel\Add/Remove Programs).

Note Image Note

This entry does not prevent users from using other methods to configure services.

Clicking the Add/Remove Windows Components button usually displays a page that consists of Set up services and a button to start the Windows Component wizard. However, when Set up services does not appear, clicking the Add/Remove Windows Components button starts the Windows Component wizard immediately.

If the value of NoWindowsSetupPage is set to 1, this entry is ignored.

Tip Image Tip

To remove Set up services and prevent the Windows Component wizard from starting, set the value of NoWindowsSetupPage to 1.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoWindowsSetupPage


NoSupportInfo

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Removes links to the Support Info dialog box.

This entry stores the setting of the Disable Support Information Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. The Support Info hyperlink appears.
1 | The policy is enabled. The Support Info hyperlink is removed.

Programs listed on the Change or Remove Programs page can include a Click here for support information hyperlink. When clicked, the hyperlink opens a dialog box that displays troubleshooting information, including a link to the installation files, and data that users need to obtain product support, such as the Product ID and version number of the program. The dialog box also includes a hyperlink to support information on the Internet, such as the Microsoft Product Support Services Web page.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable Support Information policy (User Configuration\Administrative Templates\Control Panel\Add/Remove Programs).

Note Image Note

Not all programs provide a support information hyperlink.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


NoWindowsSetupPage

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Removes the Add/Remove Windows Components button from the Add/Remove Programs bar. As a result, users cannot view or change the associated page.

This entry stores the setting of the Hide Add/Remove Windows Components page Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. The Add/Remove Windows Components page is available to all users.
1 | The policy is enabled. The Add/Remove Windows Components button is removed from the Add/Remove Programs bar. As a result, users cannot view or change the associated page.

The Add/Remove Windows Components page lets users configure installed services and use the Windows Component wizard to add, remove, and configure components of Windows 2000 from the installation files.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Hide Add/Remove Windows Components page policy (User Configuration\Administrative Templates\Control Panel\Add/Remove Programs).

Note Image Note

This entry does not prevent users from using other tools and methods to configure services or add or remove program components. However, this entry blocks user access to the Windows Components wizard.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoServices


Windows Help

HKCU\Software\Microsoft\

Description

The values in this subkey are not used by and have no effect on Windows 2000.


Windows NT

HKCU\Software\Microsoft\

Description

The Windows NT subkey stores configuration data for components of Windows 2000. The subkeys of the Windows NT subkey represent versions of the operating system, such as CurrentVersion, which refers to the version currently running on the computer. Each version subkey contains subkeys representing components that run on that version of the system.

The Windows NT subkey in HKEY_CURRENT_USER stores entries that apply only to the current user of the computer. There is also a SOFTWARE\Microsoft\Windows NT subkey in HKEY_LOCAL_MACHINE that stores entries that apply to all users of the computer.

Related Entries

Windows NT subkey (HKLM)


CurrentVersion

HKCU\Software\Microsoft\Windows NT\

Description

The CurrentVersion subkey stores configuration data for programs designed to run on the most current version Windows 2000 installed on the computer. The subkeys of CurrentVersion represent programs that run on the current version of Windows 2000 and store user-specific configuration data for those programs.


Devices

HKCU\Software\Microsoft\Windows NT\CurrentVersion\

Description

The Devices subkey in HKEY_CURRENT_USER lists the printers to which the client computer has a connection.

Each of the entries in this subkey has the following format:

printer-name REG_SZ Driver-name,Port:

printer-name will either be local printer or \\server\printername.

driver-name for Windows clients will be winspool.

port will either be LPT1 or Nexx where xx is a numerical value, starting with 00.


Event Viewer

HKCU\Software\Microsoft\Windows NT\CurrentVersion\

Description

The Event Viewer subkey stores configuration data for the Event Viewer snap-in.

Event Viewer displays information, warning, and error events that Windows 2000, and applications and services that run on Windows 2000 write to event logs.

Note Image Note

This subkey does not appear in the registry by default. Event Viewer adds this subkey to the registry when you change the default value of one of its entries.

Related Entries

EventLog subkey


ConfirmUrl

HKCU\Software\Microsoft\Windows NT\CurrentVersion\Event Viewer

Description

Suppresses the Internet confirmation dialog box in Event Viewer. This dialog box reminds you that Event Viewer is sending event information over the Internet and requests your permission to proceed.

The Internet Confirmation dialog box appears in Event Viewer when you click an Internet link on the Properties dialog box for an event. It is designed to remind the user that potentially confidential information is being sent outside of their network.

Value | Meaning
0 | Suppress the Internet confirmation dialog box. Thereafter, Event Viewer sends the information over the Internet without consulting the user.
1 | Displays confirmation dialog box.

Tip Image Tip

This entry corresponds to the "Don't ask me again (always send information)" check box. If you have inadvertently selected the check box, you can restore the confirmation dialog box by setting the value of this entry to 1 in the registry.


Extensions

HKCU\Software\Microsoft\Windows NT\CurrentVersion\

Description

The Extensions subkey stores entries which associate file name extensions with command line executions. These entries are used only when a file name extension is not already associated with a program.

Each of the entries in this subkey has the following format:

file name extension REG_SZ command line to execute

For example, the entry

txt REG_SZ notepad.exe^.txt

indicates that the default action for all files with the extension .txt is to open the file with notepad, whereas

txt REG_SZ notepad.exe^.txt -openandprint

indicates that the default action for all files with the extension .txt is to open the file with notepad and print it to the default printer.

The caret symbol (^) is replaced with the name of the selected file in the command line at run time.

Change method

To associate a file type with a program, use Windows Explorer. From the Tools menu, click Folder Options, and then click the File Types tab.

Tip Image Tip

For more information about creating a file association, search the Platform Software Development Kit (SDK) documentation in the MSDN Library at http://msdn.microsoft.com.


Network

HKCU\Software\Microsoft\Windows NT\CurrentVersion\

Description

The Network subkey in the Software key stores configuration data for programs used to view, manage and maintain the network. Each program stores its data in a separate subkey in the Network subkey.


Event Viewer

HKCU\Software\Microsoft\Windows NT\CurrentVersion\Network\

Description

The Event Viewer subkey and its entries are not used by and have no effect on Windows 2000.

Note Image Note

Entries for the Event Viewer snap-in are stored in the Event Viewer subkey in CurrentVersion.

Related Entries

Event Viewer


SaveSettings

HKCU\Software\Microsoft\Windows NT\CurrentVersion\Network\Event Viewer

Description

This entry is not used by and has no effect on Windows 2000.


Persistent Connections

HKCU\Software\Microsoft\Windows NT\CurrentVersion\Network\

Description

The Persistent Connections subkey stores data about connections to network drives.


SaveConnections

HKCU\Software\Microsoft\Windows NT\CurrentVersion\Network\Persistent Connections

Data type | Range | Default value
REG_SZ | yes | no | no

Description

Stores the current setting of the Reconnect at logon check box in the Map Network Drive dialog box in Explorer. If Reconnect at logon is selected when you map a drive, the system connects the drive to the computer when you log on again.

Value | Meaning
yes | Reconnect at logon is selected. A check will appear in this box the next time you open the Map Network Drive dialog box.
no | Reconnect at logon is cleared. The check box will be cleared the next time you open the Map Network Drive dialog box.

Change method

To change the value of this entry, use either Explorer or Command Prompt. In Explorer, from the Tools menu, select Map Network Drive, and then select or clear the Reconnect at logon check box. At the command prompt, type either net use/persist:yes or net use/persist:no.


Server Manager

HKCU\Software\Microsoft\Windows NT\CurrentVersion\Network\

Description

The Server Manager subkey stores configuration data for Server Manager in Windows NT 4.0. This subkey is not used by and has no effect on Windows 2000.

Note Image Note

In Windows 2000, use Active Directory. For more information, see New Ways to Do Familiar Tasks in the online Help.


User Manager

HKCU\Software\Microsoft\Windows NT\CurrentVersion\Network\

Description

The User Manager subkey stores configuration data for User Manager in Windows NT 4.0. This subkey is not used by and has no effect on Windows 2000; it remains in the registry to support User Manager in Windows NT 4.0.

Note Image Note

In Windows 2000, use the users and Groups snapin. For more information, see New Ways to Do Familiar Tasks in the online Help.


User Manager for Domains

HKCU\Software\Microsoft\Windows NT\CurrentVersion\Network\

Description

The User Manager for Domains subkey stores configuration data for User Manager in Windows NT 4.0. This subkey is not used by and has no effect on Windows 2000.

Note Image Note

In Windows 2000, use Active Directory Users and Computers. For more information, see New Ways to Do Familiar Tasks in the online Help.


PrinterPorts

HKCU\Software\Microsoft\Windows NT\CurrentVersion\

Description

The PrinterPorts subkey lists the printers to which the client computer has a connection.

Each of the entries in this subkey has the following format:

printer-name REG_SZ Driver-name,Port:,Timeout

printer-name will either be local printer or \\server\printername.

driver-name for Windows clients will be winspool.

port will either be LPT1 or Nexx where xx is a numerical value starting with 00.

timeout is in the form of DeviceNotSelectedTimeout,TransmissionRetryTimeout.


Program Manager

HKCU\Software\Microsoft\Windows NT\CurrentVersion\

Description

Program Manager is the primary desktop interface for Windows NT 3.51 and earlier. In Windows 2000, the default interface is Windows Explorer, but you can still use Program Manager (Progman.exe).


Restrictions

HKCU\Software\Microsoft\Windows NT\CurrentVersion\Program Manager\

Description

The Restrictions subkey stores restrictions on the user's ability to change Program Manager. This information applies mainly to Windows NT 3.51 and earlier, but it also applies to later versions of Windows if you are running Program Manager as the desktop interface.

Note Image Note

These entries apply to Program Manager only; they do not affect Windows Explorer.


EditLevel

HKCU\Software\Microsoft\Windows NT\CurrentVersion\Program Manager\Restrictions

Data type | Range | Default value
REG_DWORD | 0 | 1 | 2 | 3 | 4 | 0

Description

Restricts the user's ability to modify Program Manager. Please note that these values represent increasing levels of restrictions, each of which includes the restrictions of the previous levels.

Value | Meaning
0 | No restrictions. The user can change any configurable feature of Program Manager.
1 | The user cannot create, delete, or rename program groups. The New, Move, Copy, and Delete commands on the File menu are disabled when a program group is selected.
3 | The user cannot create, delete, or rename program groups (as in the value of 1). In addition, the user cannot create or delete program items. The New, Move, Copy, and Delete commands on the File menu are always disabled.
4 | The user cannot create, delete, or rename program groups or items (as in the value of 2). In addition, the user cannot change command lines for program items. The text in the Command Line box in the Properties dialog box cannot be changed.
5 | The user cannot create, delete, or rename program groups or items, or change command lines for program items (as in the value of 3). In addition, the user cannot change any program item information. The fields in the Properties dialog box are disabled, so the user can view, but not change, the entries in the fields.

Note Image Note

This entry applies to Program Manager only; it does not affect Windows Explorer.


NoClose

HKCU\Software\Microsoft\Windows NT\CurrentVersion\Program Manager\Restrictions

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Prevents the user from quitting Program Manager.

Value | Meaning
0 | The user can use Exit Windows, Close, or ALT+F4 to quit Program Manager.
1 | The Exit Windows and Close commands are disabled, and the ALT+F4 key combination does not operate.

Note Image Note

This entry applies to Program Manager only; it does not affect Windows Explorer.


NoFileMenu

HKCU\Software\Microsoft\Windows NT\CurrentVersion\Program Manager\Restrictions

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Removes the File menu from Program Manager.

Users can start the applications in groups by selecting them and pressing ENTER, or by double-clicking their icons. If the value of NoClose is 0, users can still quit Windows 2000 by using the Exit Windows command or by pressing ALT+F4.

Value | Meaning
0 | The File menu appears in Program Manager.
1 | The File menu does not appear in Program Manager.

Note Image Note

This entry applies to Program Manager only; it does not affect Windows Explorer.


NoRun

HKCU\Software\Microsoft\Windows NT\CurrentVersion\Program Manager\Restrictions

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Disables the Run command on the File menu. The user cannot run applications from Program Manager unless the applications are represented by icons in a group.

Value | Meaning
0 | Enables the Run command.
1 | Disables the Run command.

Note Image Note

This entry applies to Program Manager only; it does not affect Windows Explorer.


NoSaveSettings

HKCU\Software\Microsoft\Windows NT\CurrentVersion\Program Manager\Restrictions

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Disables the Save Settings on Exit command in the Options menu in Program Manager. Changes that the user makes to the arrangement of windows and icons are not restored when Windows 2000 is restarted.

Value | Meaning
0 | Enables Save Settings on Exit.
1 | Disables Save Settings on Exit.

Note Image Note

The value of this entry takes precedence over the value of SaveSettings.

This entry applies to Program Manager only; it does not affect Windows Explorer.


Restrictions

HKCU\Software\Microsoft\Windows NT\CurrentVersion\Program Manager\Restrictions

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether the restrictions set in this subkey are enabled. This entry takes precedence over all other entries in this subkey. This entry allows you to set or remove all restrictions by editing a single value.

Value | Meaning
0 | Enables restrictions.
1 | Disables restrictions.

Note Image Note

This entry applies to Program Manager only; it does not affect Windows Explorer.


ShowCommonGroups

HKCU\Software\Microsoft\Windows NT\CurrentVersion\Program Manager\Restrictions

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether common program groups are displayed in Program Manager.

Value | Meaning
0 | Program groups are not displayed.
1 | Program groups are displayed.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

This entry applies to Program Manager only; it does not affect Windows Explorer.


Settings

HKCU\Software\Microsoft\Windows NT\CurrentVersion\Program Manager\

Description

The Program Manager\Settings subkey stores the values of options set in Program Manager. This information applies mainly to Windows NT 3.51 and earlier, but it also applies to later versions of Windows if you are running Program Manager as the desktop interface.


AutoArrange

HKCU\Software\Microsoft\Windows NT\CurrentVersion\Program Manager\Settings

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Stores the value of the AutoArrange command on the Options menu in Program Manager. If the value of this entry is 1, the icons in each program group are arranged automatically when you run Program Manager.

Value | Meaning
0 | Disables AutoArrange. (The AutoArrange command is not selected.)
1 | Enables AutoArrange. (The AutoArrange command is selected.)

Note Image Note

This entry applies to Program Manager only; it does not affect Windows Explorer.


display.drv

HKCU\Software\Microsoft\Windows NT\CurrentVersion\Program Manager\Settings

Data type | Range | Default value
REG_SZ | File name | vga.drv

Description

Specifies the video display driver used on the system.

Note Image Note

This entry applies to Program Manager only; it does not affect Windows Explorer.


MinOnRun

HKCU\Software\Microsoft\Windows NT\CurrentVersion\Program Manager\Settings

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Stores the value of the Minimize On Use command on the Options menu in Program Manager. If the value of this entry is 1, Program Manager is minimized when you run an application.

Value | Meaning
0 | Program Manager is not minimized when you run another application. (The Minimize On Use command is not selected.)
1 | Program Manager is minimized when you run another application. (The Minimize On Use command is selected.)

Note Image Note

This entry applies to Program Manager only; it does not affect Windows Explorer.


SaveSettings

HKCU\Software\Microsoft\Windows NT\CurrentVersion\Program Manager\Settings

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Stores the value of the Save Settings On Exit command on the Options menu in Program Manager. If the value of this entry is 1, changes that the user makes to the arrangement of windows and icons are saved when Windows 2000 is restarted.

Value | Meaning
0 | Enables Save Settings on Exit.
1 | Disables Save Settings on Exit.

Note Image Note

This entry applies to Program Manager only; it does not affect Windows Explorer.

If the value of NoSaveSettings is 1, the value of SaveSettings is ignored.


UNICODE Groups

HKCU\Software\Microsoft\Windows NT\CurrentVersion\Program Manager\

Description

The Unicode Groups subkey specifies group numbers for the program groups defined in Program Manager. This information applies mainly to Windows NT 3.51 and earlier, but it applies also to later versions of Windows if you are running Program Manager as the desktop interface.

The entries in the UNICODE Groups subkey associate a group number with the name of a program group. The entries have the following format:

Group# REG_SZ Group name


TaskManager

HKCU\Software\Microsoft\Windows NT\CurrentVersion\

Description

The TaskManager subkey stores preferences for Task Manager.


Preferences

HKCU\Software\Microsoft\Windows NT\CurrentVersion\TaskManager

Data type | Range | Default value
REG_BINARY | Binary value | (Binary value)

Description

Stores user preferences for Task Manager.

Change method

To change the value of this entry, use Task Manager. Use the options in the View menu to set the preferences for each of the tabs.

Note Image Note

For more information on Task Manger, click the Help menu in Windows Task Manager.


TrueType

HKCU\Software\Microsoft\Windows NT\CurrentVersion\

Description

The TrueType subkey stores data that determines the use and display of TrueType fonts in Windows-based applications.


TTEnable

HKCU\Software\Microsoft\Windows NT\CurrentVersion\TrueType

Data type | Range | Default value
REG_SZ | 1 | 1

Description

Determines whether TrueType fonts can be used in Windows–based applications.

Value | Meaning
1 | TrueType fonts can be used.

Note Image Note

Changing the value of this entry to 0 will not disable TrueType fonts. TrueType fonts are always enabled.


TTonly

HKCU\Software\Microsoft\Windows NT\CurrentVersion\TrueType

Data type | Range | Default value
REG_SZ | 0 | 1 | 0

Description

Determines whether fonts other than TrueType fonts can be used in Windows-based programs.

Value | Meaning
0 | All installed fonts can be used.
1 | Only TrueType fonts can be used.

Change method

To change the value of this entry, double-click Fonts in Control Panel. On the Tools menu, click folder Options, and then click the TrueType Fonts tab. Select the Show only TrueType Fonts in the programs on my computer check box.

Activation method

You must restart the computer before these changes take effect.

Note Image Note

For more information on Fonts, click the Help menu in the Fonts folder.

Setting this value to 1 will not affect existing non-TrueType fonts in existing documents, nor will it prevent you from installing a non-TrueType font. It will prevent all non-TrueType fonts from appearing in the fonts list in applications.


Windows

HKCU\Software\Microsoft\Windows NT\CurrentVersion\

Description

The Windows subkey contains entries that store user preferences.

Related Entries

Windows control subkey (HKLM\System\CurrentControlSet\Control\Windows)

Windows subkey (HKLM\Software)


Device

HKCU\Software\Microsoft\Windows NT\CurrentVersion\Windows

Data type | Range | Default value
REG_SZ | Output-device-name,Device-driver,Port-connection | Output-device-name,winspool,Port-connection

Description

Specifies the default printer. An explicit port and driver must be assigned to the printer device. The device-driver is the file name (without the extension) of the device driver file.

Change method

To change the default printer, click Start, point to Settings and click Printers. Right-click the printer, and then click Set as Default Printer.


Documents

HKCU\Software\Microsoft\Windows NT\CurrentVersion\Windows

Data type | Range | Default value
REG_SZ | File name extensions | (Blank value)

Description

Defines files to be considered documents by Windows 2000. Enter the file name extensions without the preceding periods, and separate the extensions from each other with a space.

Use this entry only to define document file name extensions that are not associated with any application and are not listed in the Extensions subkey.

Related Entries

Programs


DosPrint

HKCU\Software\Microsoft\Windows NT\CurrentVersion\Windows

Data type | Range | Default value
REG_SZ | yes | no | no

Description

Determines whether MS-DOS interrupts are used when printing.

Value | Meaning
yes | MS-DOS interrupts are used.
no | Printing output is sent directly to the port to which the printer is assigned.


fPrintError

HKCU\Software\Microsoft\Windows NT\CurrentVersion\Windows

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether error messages generated during debugging are printed. Error messages usually indicate serious problems in the Window Manager code.

Value | Meaning
0 | Disabled. Error messages do not print.
1 | Enabled. Error messages print.

Note Image Note

This entry appears only when running a debug build of Windows 2000.


fPrintFileLine

HKCU\Software\Microsoft\Windows NT\CurrentVersion\Windows

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether the file and line number that generated an error message during debugging are printed.

Value | Meaning
0 | Disabled. File and line number do not print.
1 | Enabled. File and line number do print.

Note Image Note

This entry appears only when running a debug build of Windows 2000.


fPrintVerbose

HKCU\Software\Microsoft\Windows NT\CurrentVersion\Windows

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines the level of detail printed when warnings and error messages are generated during debugging. Verbose data is intended only for Microsoft internal development purposes.

Value | Meaning
0 | Standard debugging data is displayed.
1 | All data is displayed.

Note Image Note

This entry appears only when running a debug build of Windows 2000.


fPrintWarning

HKCU\Software\Microsoft\Windows NT\CurrentVersion\Windows

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether warnings generated during debugging are printed. Warnings usually indicate errors in an application's interaction with the Window Manager.

Value | Meaning
0 | Disabled. Warnings do not print.
1 | Enabled. Warnings print.

Note Image Note

This entry appears only when running a debug build of Windows 2000.


fPromptOnError

HKCU\Software\Microsoft\Windows NT\CurrentVersion\Windows

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether the user is prompted by the debugger when error messages are generated during debugging. Errors usually indicate serious problems in Window Manager code.

Value | Meaning
0 | Do not prompt.
1 | Prompt.

Note Image Note

This entry appears only when running a debug build of Windows 2000.


fPromptOnVerbose

HKCU\Software\Microsoft\Windows NT\CurrentVersion\Windows

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines the level of detail of user prompts when warnings and errors are generated during debugging. Verbose data is intended for Microsoft internal development only.

Value | Meaning
0 | Standard data is displayed.
1 | All data is displayed.

Note Image Note

This entry appears only when running a debug build of Windows 2000.


fPromptOnWarning

HKCU\Software\Microsoft\Windows NT\CurrentVersion\Windows

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether users are notified by the debugger when warnings are generated during debugging. Warnings usually indicate errors in an application's interaction with the Window Manager.

Value | Meaning
0 | Do not prompt.
1 | Prompt.

Note Image Note

This entry appears only when running a debug build of Windows 2000.


load

HKCU\Software\Microsoft\Windows NT\CurrentVersion\Windows

Data type | Range | Default value
REG_SZ | [Path]File name(s) | (Blank value)

Description

Specifies the programs run when Windows 2000 starts. The program is minimized (appears as a taskbar icon) while it is running.

This entry stores a list of file names of programs or files associated with an application. Each file name must be separated from the others by a space. If the file is not located in the Systemroot directory, you must specify the path to the file.

Change method

To load a program at startup, add the application to Systemroot\Documents and Settings\All Users\Start Menu\Programs\Startup. Right-click the icon, click Properties, click the Shortcut tab, and select Minimized from the Run drop-down menu. This will not actually change the value of the load entry, but will emulate the behavior.

Related Entries

Run


NetMessage

HKCU\Software\Microsoft\Windows NT\CurrentVersion\Windows

Data type | Range | Default value
REG_SZ | yes | no | no

Description

This entry is not used by and has no effect on Windows 2000.


NullPort

HKCU\Software\Microsoft\Windows NT\CurrentVersion\Windows

Data type | Range | Default value
REG_SZ | String | None | None

Description

This entry is not used by and has no effect on Windows 2000.


Programs

HKCU\Software\Microsoft\Windows NT\CurrentVersion\Windows

Data type | Range | Default value
REG_SZ | File name extensions (no periods) | com exe bat pif cmd

Description

Specifes the file types that Windows 2000 considers to be applications. Separate each file name extension from the others with a space.

Related Entries

Documents


run

HKCU\Software\Microsoft\Windows NT\CurrentVersion\Windows

Data type | Range | Default value
REG_SZ | [Path]File name(s) | (Blank value)

Description

Specifies the applications the user directs Windows 2000 to run at startup.

This entry stores a list of file names of applications or documents associated with an application. Each file name must be separated from the others by a space. If the file is not located in the Systemroot directory, you must specify the path to the file.


Winlogon

HKCU\Software\Microsoft\Windows NT\CurrentVersion\

Description

The Winlogon subkey stores configuration data for the Winlogon component of Windows 2000. Winlogon authenticates and interactive user and enables them to log on. Winlogon supports desktops, the Ctrl+Alt+Del secure attention sequence, screen saver control, network provider support, authentication and password updates.


ReportDC

HKCU\Software\Microsoft\Windows NT\CurrentVersion\Winlogon

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Stores the user setting for the domain controller message. (The computer setting is stored in the value of ReportControllerMissing.)

This entry determines, in part, whether the system displays the following message when it cannot contact the domain controller that stores a user's roaming user profile.

A domain controller for your domain could not be contacted. You have been logged on using cached account information. Changes made to your profile since you last logged on might not be available.

This entry stores the setting of the Do not display this message again check box on the domain controller message dialog box. When you select the checkbox, the system sets the value of this entry to 0.

Value | Meaning
0 | Do not display the domain controller message. (The check box is selected.)
1 (or not in registry) | Display the domain controller message. (The check box is cleared.)

Display of the domain controller message is managed by two registry entries, ReportDC and ReportControllerMissing. The message is displayed only when both entries are set to their display setting, that is, when ReportDC is set to 1 or it does not appear in the registry, and ReportDomainController appears in the registry with a value of TRUE. By default, the message is not displayed.

Note Image Note

While the domain controller message is displayed, other elements of the user interface are disabled, but all processes continue to run normally. If the OK button accompanying this message is not clicked after two minutes, the message box disappears.

Related Entries

NoPopUpsOnBoot

ReportControllerMissing


RunLogonScriptSync

HKCU\Software\Microsoft\Windows NT\CurrentVersion\Winlogon

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether the system waits for the logon script to finish running before it starts Windows Explorer and creates the desktop.

Value | Meaning
0 | The logon script and Windows Explorer can run simultaneously.
1 | Windows Explorer does not start until the logon script has finished running.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Run logon scripts synchronously policy (User Configuration\Administrative Templates\System\Logon/Logoff).

Note Image Note

This entry also appears in the Winlogon subkey in HKEY_LOCAL_MACHINE (see RunLogonScriptSync (HKLM)). The HKEY_LOCAL_MACHINE value applies to all users. The HKEY_CURRENT_USER value is configured separately for each user.

This entry can be superceded by Group Policy settings included in Windows 2000. While the Run logon scripts synchronously Group Policy is enabled (in the Computer Configuratio or User Configuration policy folders), the system ignores this entry. The Run logon scripts synchronously setting is stored in the values of RunLogonScriptSync (HKLM) and RunLogonScriptSync (HKCU).

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

Related Entries

RunLogonScriptSync (HKLM)


Policies

HKCU\Software\

Description

The Policies subkey contains entries that store Group Policy settings.

Group Policy adds, deletes, and changes the values of entries in this subkey when you use the Group Policy snap-in to configure a policy, that is, to enable or disable the policy. When the policies affecting you or your computer change, such as when you move to a new user group, Group Policy deletes the entries applied to the old group and adds the entries applied to the new group.

Group Policy manages registry entries in four Policies subkeys:

  • HKLM\Software\Policies
  • HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies
  • HKCU\SOFTWARE\Policies
  • HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies

The Policies subkeys in HKCU store policy-related entries that are configured separately for each user. The system adds these entries when you enable (and, for some policies, when you disable) a policy in the User Configuration folder in Group Policy.

The Policies subkeys in HKLM store policy-related entries that apply to all users of the computer. The system adds these entries when you enable (and, for some policies, when you disable) a policy in the Computer Configuration folder in Group Policy.

Many policy-related entries can appear in both HKCU and HKLM. Typically, the entries in HKLM take precedence over the entries in HKCU when both are configured.

The SOFTWARE\Microsoft\Windows\CurrentVersion\Policies subkey stores policy-related entries for Windows 2000 and for Windows NT 4.0 and earlier. The SOFTWARE\Policies subkey is new in Windows 2000. Please note that the different versions of Windows support different policies.

Change method

To add, remove, or change the entries in this subkey, use Group Policy.

Note Image Note

Many of the entries in the Policies subkeys have counterparts in other registry subkeys. These counterparts, known as preferences have the same effect on user or computer features as entries in the Policies subkey. However, when an entry appears in the Policies subkey, the preference is almost always ignored. For details, see the entry descriptions.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Caution Image Caution

Do not use a registry editor to change the values in this subkey. If you do, they will be overwritten the next time your policies are refreshed.


Microsoft

HKCU\Software\Policies\

Description

The Policies\Microsoft subkey contains entries that store Group Policy settings for Microsoft products. The entries in this subkey are created and maintained by Group Policy.

The Policies\Microsoft subkey in HKEY_CURRENT_USER stores entries that are configured separately for each user. The system adds these entries when you enable (and, for some policies, when you disable) a policy in the User Configuration folder in Group Policy.

There is also a Policies\Microsoft subkey in HKEY_LOCAL_MACHINE which stores entries for policies that apply to all users of the computer. The system adds these entries when you enable (and, for some policies, when you disable) a policy in the Computer Configuration folder in Group Policy.

Change method

To add, remove, or change the entries in this subkey, use Group Policy.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

Microsoft subkey (HKLM\Software\Policies)


Control Panel

HKCU\Software\Policies\Microsoft\

Description

The Control Panel subkey contains entries that store Group Policy settings for Control Panel programs. The entries in this subkey are written and maintained by Group Policy, and are read and interpreted by the Control Panel program.

Change method

To add, remove, or change the entries in this subkey, use Group Policy.

Note Image Note

The entries in this subkey take precedence over entries of the same name in the HKCU\Control Panel and HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Control Panel subkeys.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

Control Panel subkey in HKCU\Software\Policies\Microsoft\Windows


Desktop

HKCU\Software\Policies\Microsoft\Control Panel\

Description

The Desktop subkey contains entries that store Group Policy settings for Display and Regional Options in Control Panel. The entries in this subkey are written and maintained by Group Policy, and are read and interpreted by the Control Panel programs.

Change method

To add, remove, or change the entries in this subkey, use Group Policy.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


MultiUILanguageID

HKCU\Software\Policies\Microsoft\Control Panel\Desktop

Data type | Range | Default value
REG_SZ | Language identifier | 0x409 (For U.S. English)

Description

Specifies the language used in menus and dialog boxes in Windows 2000, and prevents users from changing it.

This entry stores the setting of the Restrict selection of Windows 2000 menus and dialogs language Group Policy. Group Policy adds this entry to the registry when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry.

Value | Meaning
(Not in registry) | The policy is disabled or not configured. Users can use Regional Options in Control Panel to select a language for Windows 2000.
Language identifier | The policy is enabled. Uses the language specified in the value of this entry.

When this entry appears in the registry, the system disables the menus and dialog boxes in the Regional Options in Control Panel so users cannot change the language while a policy is in effect.

If the language specified in this entry is not installed on the system to which this policy applies, Windows 2000 uses English (United States), that is locale 0x409.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Restrict selection of Windows 2000 menus and dialogs language policy (User Configuration\Administrative Templates\Control Panel\Regional Options). Use the drop-down list box to select a language.

Note Image Note

Not all of the locales available on Windows 2000 can be used as the value this entry. Use only the Language identifier that are valid for this entry.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


International

HKCU\Software\Policies\Microsoft\Control Panel\

Description

The International subkey in the Policies subkey contains entries that store Group Policy settings for calendar options in Regional Options in Control Panel. The entries in this subkey are created and maintained by Group Policy and read and interpreted by Regional Options.

There is also a Regional Options setting for the desktop in Group Policy in HKCU\Software\Policies\Microsoft\Control Panel\Desktop.

Note Image Note

The policy-related entries in the International subkey take precedence over non-policy related entries in the International subkey in HKCU\Control Panel\International.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

International subkey (HKCU\Control Panel)


Calendars

HKCU\Software\Policies\Microsoft\Control Panel\International\

Description

The Calendars subkey in the Policies subkey contains entries that store Group Policy settings for calendar options in Regional Options in Control Panel. The entries in this subkey are created and maintained by Group Policy and read and interpreted by Regional Options.

There is also a Regional Options setting for the desktop in Group Policy in HKCU\Software\Policies\Microsoft\Control Panel\Desktop.

Note Image Note

The policy-related entries in the Calendars subkey take precedence over non-policy related entries in HKCU\Control Panel\International\Calendars.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


TwoDigitYearMax

HKCU\Software\Policies\Microsoft\Control Panel\International\Calendars\

Description

The TwoDigitYearMax subkey in the Policies subkey contains entries that store Group Policy settings for calendar options in Regional Options in Control Panel. The entries in this subkey are created and maintained by Group Policy and read and interpreted by Regional Options.

This subkey can contain an entry representing each of the different calendars available on Windows 2000. Each entry represents a type of calendar and is named by the calendar-ID of that type of calendar .

The System.adm file included in Windows 2000, adds an entry named 1 (see the <Calendar-ID> entry) to the TwoDigitYearMax subkey when you enable the Century interpretation for Year 2000 Group Policy. However, you can edit the System.adm file or create a custom .adm file to add an entry for any Windows 2000 calendar type. TwoDigitYearMax is relevant to all calendar types except for the Era: Year of the Emperor (Japan) calendar (Type 3) and the Era: Year of Taiwan calendar (Type 4).

Note Image Note

Regional Options in Control Panel coordinates all Gregorian calendars, such that changes to any type of Gregorian calendar are applied to all other types of Gregorian calendars. However, Group Policy changes the value only of the localized Gregorian calendar. To maintain coordinated Gregorian calendars, you must edit System.adm or create a customize .adm file.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


<Calendar-ID>

HKCU\Software\Policies\Microsoft\Control Panel\International\Calendars\TwoDigitYearMax

Data type | Range | Default value
REG_SZ | 99 - 9999 | 2029 (for Gregorian calendars)

Description

Determines how programs interpret two-digit years, and prevents users from changing the setting.

This entry specifies the last year in a 100-year range. The system interprets any two-digit year as being in the range ending with the year specified by this entry.

For example, if the value of this entry is 2550, the system assumes that all two-digit years it encounters fall within the years 2451 to 2550. If the system encounters a two-digit date of 30, it interprets the date as being 2530. If the two-digit date is 60, the system interprets the date as 2460.

When this entry appears in the registry, the system disables the When a two-digit year is entered, interpret it as a year between spin box in the Calendar section of the Date tab in Regional Options in Control Panel. As a result, users cannot change the interpretation of two-digit years while this policy is in effect.

Group Policy uses this entry for the Century interpretation for Year 2000 Group Policy setting. Group Policy adds an entry named 1 (for calendar-ID 1) to the TwoDigitYearMax subkey when you enable the Century interpretation for Year 2000 policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 2029.

The Century interpretation for Year 2000 policy only applies to localized Gregorian calendars (Calendar-ID 1). Also, because it is designed for the 21st century, it limits the values you can enter to a range of 2001 - 2099. However, you can edit the System.adm file or create a custom .adm file to add an entry for any Windows 2000 calendar type. Two-digit year interpretation is relevant to all calendar types except for the Era: Year of the Emperor (Japan) calendar (Type 3) and the Era: Year of Taiwan calendar (Type 4).

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Century interpretation for Year 2000 policy (User Configuration\Administrative Templates\System).

Note Image Note

This entry applies only to calendars whose calendar-ID matches the name of this entry.

Regional Options in Control Panel coordinates all Gregorian calendars, such that changes to any type of Gregorian calendar are applied to all other types of Gregorian calendars. However, Group Policy changes the value only of the localized Gregorian calendar. To maintain coordinated Gregorian calendars, you must edit System.adm or create a customized .adm file.

This entry only affects the programs that use the Windows feature to interpret two-digit years. If a program does not interpret two-digit years correctly, consult the documentation or manufacturer of the program.

This entry overrides a user setting. When this entry appears in the registry, the system disables the When a two-digit year is entered, interpret it as a year between spin box in the Calendar section of the Date tab and ignores the entry for this calendar type in HKCU\Control Panel\International\Calendars\TwoDigitYearMax, which stores the option setting.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


MMC

HKCU\Software\Policies\Microsoft\

Description

The MMC subkey contains entries that store Group Policy settings for the Microsoft Management Console (MMC). The entries in this subkey are written and maintained by Group Policy and read and interpreted by the MMC program.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


<Class-ID>

HKCU\Software\Policies\Microsoft\MMC\

Description

The <Class-ID> subkey contains entries that store Group Policy settings for Microsoft Management Console (MMC) snap-ins. These entries are created and maintained by Group Policy and read and interpreted by the snap-in programs. This subkey is named by the class identifier (class ID) of the snap-in to which it applies.

Each <Class-ID> subkey represents a snap-ins in the Microsoft Management Console (MMC). The entries which appear in these subkeys apply only to that snap-in

Note Image Note

The <Class-ID> subkey is a variable representing the subkeys under the MMC subkey. It does not actually appear in the registry. We use this variable subkey to display information which is common to the subkeys in the MMC subkey.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

<Class-ID> subkey in the Group Policy subkey


Restrict_Run

HKCU\Software\Policies\Microsoft\MMC\<Class-ID>

Data type | Range | Default value
REG_DWORD | 0 | 1 | (Not in registry) 0

Description

Permits or prohibits use of this snap-in.

This entry stores the setting of a policy in the Restricted/Permitted snap-ins folders in Group Policy. Each policy in the folder represents a snap-in, a snap-in extension, or a Group Policy component. When you enable a policy in the folder, Group Policy adds the Restrict_Run entry to the <Class-ID> subkey for the named snap-in or component and sets its value to 1. If you disable the policy, Group Policy adds the Restrict_Run entry and sets its value to 0. If you set the policy to Not configured, Group Policy deletes the entry from the registry.

Value | Meaning
0 | Prohibits use of the snap-in.
1 | Permits use of the snap-in.
(Not in registry) | When the value of RestrictToPermittedSnapins is 1, this snap-in is prohibited. Otherwise, the snap-in is permitted.

By default, users can use all of the snap-ins. However, you can prohibit access to a particular snap-in by disabling its policy in the Restricted/Permitted snap-ins Group Policy folder. When you disable the policy, Group Policy sets the value of Restrict_Run to 0. As a result, the system does not run that snap-in.

However, if you enable the Restrict users to the explicitly permitted list of snap-ins policy, users cannot run any snap-ins unless the value of Restrict_Run is 1. All other snap-ins are prohibited. To add Restrict_Run to the registry with a value of 1, enable the policy for that snap-in in the Restricted\Permitted snap-ins folder.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the <Snap-in-name> policy (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins or its subfolders).

Tip Image Tip

See a list of the Class ID subkeys and the snap-ins they represent.

.

To prohibit users from gaining access to any snap-ins, enable the Restrict users to the explicitly permitted list of snap-ins policy (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console), and do not configure any of the policies in the Restricted\Permitted snap-ins folder. You do not have to disable the policies.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

RestrictToPermittedSnapins


RestrictAuthorMode

HKCU\Software\Policies\Microsoft\MMC

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Prevents users from opening the Microsoft Management Console (MMC) in author mode, from explicitly opening console files in author mode, and from opening any console files that open in author mode by default.

This entry stores the setting of the Restrict the user from entering author mode Group Policy. Group Policy adds this entry to the registry when you with a value of 1 when you enable the policy. If you disable the policy, Group Policy sets the value to 0. If you set the policy to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. Users can open the MMC in author mode.
1 | The policy is enabled. Users can open the MMC in author mode.

When the value of this entry is 1, users cannot open a blank MMC console window from the Start menu or from a command prompt and users cannot create console files or add or remove snap-ins. Also, because they cannot open author-mode console files, they cannot use the tools that the files contain.

However, while this value is 1, users can open MMC user-mode console files, such as those on the Administrative Tools menu in Windows 2000 Server.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Restrict the user from entering author mode policy (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


RestrictToPermittedSnapins

HKCU\Software\Policies\Microsoft\MMC

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Selectively permits or prohibits the use of Microsoft Management Console (MMC) snap-ins.

This entry stores the setting of the Restrict users to the explicitly permitted list of snap-ins Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy, Group Policy sets the value to 0. If you set the policy to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. All snap-ins are permitted, except those explicitly prohibited. Snap-ins are explicitly prohibited when the when the value of Restrict_Run in the <Class-ID> subkey for that snap-in is 0. (If the Restrict_Run entry for that snap-in is not in the registry or if its value is 1, the snap-in is permitted.)
1 | The policy is enabled. All snap-ins are prohibited, except those explicitly permitted. Snap-ins are explicitly permitted when the when the value of Restrict_Run in the <Class-ID> subkey for that snap-in is set to 1. (If the Restrict_Run entry for that snap-in is not in the registry or if its value is 0, the snap-in is prohibited.)

A value of 1 prohibits users from running any snap-ins except those you explicitly permit them to use. Use this value if you plan to prohibit use of all or most snap-ins.

A value of 0 (the default value) lets users run all snap-ins except those that you explicitly prohibit. Use this value if you plan to permit use of all or most snap-ins.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Restrict users to the explicitly permitted list of snap-ins policy (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console).

Note Image Note

To explicitly permit or prohibit a snap-in, use the policies in the Restricted/Permitted snap-ins folder in Group Policy.

To prohibit use of all snap-ins, enable the Restrict users to the explicitly permitted list of snap-ins policy (which sets the value of RestrictToPermittedSnapins to 1, and do not configure any of the policies in the Restricted/Permitted snap-ins folder.

Tip Image Tip

See a list of the Class ID subkeys and the snap-ins they represent.

.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Caution Image Caution

If the value of this entry is 1, and none of the policies in the Restrict/Permitted snap-ins Group Policy folder are enabled, users cannot use any MMC snap-ins.

Related Entries

Restrict_Run


Windows

HKCU\Software\Policies\Microsoft\

Description

The Windows subkey contains entries that store Group Policy settings for components of Windows 2000. The subkeys and entries in the Windows subkey are written and maintained by Group Policy, and are read and interpreted by the component that implements them.

The Windows subkey in HKEY_CURRENT_USER stores entries that are configured separately for each user. There is also a Software\Policies\Microsoft\Windows subkey in HKEY_LOCAL_MACHINE which stores entries that apply to all users of the computer.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

HKLM\SOFTWARE\Policies\Microsoft\Windows


App Management

HKCU\Software\Policies\Microsoft\Windows\

Description

The App Management subkey contains entries that store the Group Policy settings which determine how programs run. The subkeys and entries in the Windows subkey are written and maintained by Group Policy, and are read and interpreted by the component that implements them.

Note Image Note

Policy entries in the App Management subkey override default settings in the SOFTWARE\Microsoft\Windows\CurrentVersion\App Management subkeys..

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

App Management subkey in (HKLM)


COMClassStore

HKCU\Software\Policies\Microsoft\Windows\App Management

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Directs the system to search Active Directory for missing Component Object Model (COM) components that a program requires.

This entry stores the setting of the Download missing COM components Group Policy. Group Policy adds this entry to the registry with a value of 1 when you configure the Download missing COM components policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry.

Value | Meaning
0 or not in registry) | The policy is disabled or not configured. When a required COM component registration is missing, the program continues without it. As a result, the program might not perform all of its functions, or it might stop.
1 | The policy is enabled. The system searches Active Directory for a missing COM component registration and if it is found, downloads it. The resulting searches might make some programs start or run slowly.

Many Windows programs, such as the Microsoft Management Console snap-ins, use the interfaces provided by the COM. These programs cannot perform all of their functions unless Windows 2000 has internally registered the required components.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Download missing COM components policy (Computer Configuration\Administrative Templates\System).

Note Image Note

This entry can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If this entry appears in both subtrees, the value in HKEY_LOCAL_MACHINE takes precedence over the value in HKEY_CURRENT_USER.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

COMClassStore (HKLM)


Control Panel

HKCU\Software\Policies\Microsoft\Windows\

Description

The Control Panel subkey contains entries that store Group Policy settings for Control Panel programs. The entries in this subkey are written and maintained by Group Policy, and are read and interpreted by the Control Panel program.

Note Image Note

The entries in this subkey take precedence over entries of the same name in the HKCU\Control Panel and HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Control Panel subkeys.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

Control Panel subkey in HKCU\Software\Policies\Microsoft


Desktop

HKCU\Software\Policies\Microsoft\Windows\Control Panel\

Description

The Desktop subkey contains entries that store Group Policy settings for Display and Regional Options in Control Panel. The entries in this subkey are written and maintained by Group Policy, and are read and interpreted by the Control Panel programs.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


ScreenSaveActive

HKCU\Software\Policies\Microsoft\Windows\Control Panel\Desktop

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Prevents screen savers from running on this system.

This entry stores the setting of the No screen saver Group Policy. Group Policy adds this entry to the registry with a value of 0 when you enable the policy. If you disable the policy, Group Policy sets the value to 1. If you set the policy to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 1.

Value | Meaning
0 | The policy is enabled. Screen savers do not run. Also, the Screen Saver section of the Screen Saver tab is disabled, so that users do not try to change the screen saver options while a policy is in effect.
(Not in registry) | 1 | The policy is disabled or not configured. Screen savers run.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the No screen saver policy (User Configuration\Administrative Templates\Control Panel\Display).

Note Image Note

The No screen saver policy takes precedence over the Screen saver executable name policy (SCRNSAVE.EXE). If both are enabled, the Screen saver executable name policy is ignored and no screen savers run.

This entry takes precedence over a user setting. When this entry appears in the registry, a policy is in effect and the system ignores the value of ScreenSaveActive in the Control Panel\Desktop subkey.

Tip Image Tip

To specify a screen saver on a computer without setting a policy, use Control Panel. Double-click Display, and then click the Screen Saver tab.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoDispScrSavPage

SCRNSAVE.EXE

ScreenSaverIsSecure


ScreenSaverIsSecure

HKCU\Software\Policies\Microsoft\Windows\Control Panel\Desktop

Data type | Range | Default value
REG_DWORD | (Not in registry) | 0 | 1 | (Not in registry.)

Description

Determines whether screen savers used on the computer are password protected, and prevents users from changing the setting.

This entry stores the setting of the Password protect the screen saver Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy, Group Policy sets the value to 0. If you set the policy to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
(Not in registry.) | Users can turn password protection on and off.
0 | Screen savers are not password protected.
1 | All screen savers are password protected.

When this entry appears in the registry, the system disables the Password protected check box on the Screen Saver tab in Display in Control Panel so users cannot change this setting while a policy is in effect.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Password protect the screen saver policy (User Configuration\Administrative Templates\Control Panel\Display).

To specify a screen saver on a computer, in Control Panel, double-click Display, and then click the Screen Saver tab.

To specify a screen saver in a policy, use the Desktop screen saver executable name policy.

Note Image Note

This entry takes precedence over a user setting. When this entry appears in the registry, the system disables the Password protected check box ignores the value of ScreenSaverIsSecure in the Control Panel\Desktop subkey which stores the check box setting.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoDispScrSavPage

ScreenSaveActive

SCRNSAVE.EXE

ScreenSaverGracePeriod


SCRNSAVE.EXE

HKCU\Software\Policies\Microsoft\Windows\Control Panel\Desktop

Data type | Range | Default value
REG_SZ | Path and file name | There is no default value for this entry.

Description

Specifies the screen saver used on the computer, and prevents users from changing the screen saver.

This entry stores the setting of the Screen saver executable name Group Policy. Group Policy adds this entry to the registry when you enable the Screen saver executable name policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry.

When this entry appears in the registry, the system uses the screen saver specified in the value of this entry. Also, the system disables the drop-down list of screen savers on the Screen Saver tab in Display in Control Panel, so users cannot change the screen saver while a policy is in effect.

The value of this entry must include the executable name of a valid Windows screen saver file, including the .scr file name extension. If the screen saver file is not in the Systemroot\System32 directory, the value must include the fully qualified path to the file. If the specified screen saver is not installed on the computer, no screen saver runs.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Screen saver executable name policy (User Configuration\Administrative Templates\Control Panel\Display).

Note Image Note

The Screen saver executable name policy can be superceded by the No screen saver policy (ScreenSaveActive). If the value of ScreenSaveActive is 0, then screen savers do not run on the computer, and the SCRNSAVE.EXE entry is ignored.

This entry takes precedence over a user setting. When this entry appears in the registry, a policy is in effect and the system ignores the value of SCRNSAVE.EXE in the Control Panel\Desktop subkey.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoDispScrSavPage

ScreenSaveActive

ScreenSaverIsSecure


Directory UI

HKCU\Software\Policies\Microsoft\Windows\

Description

The Directory UI subkey stores the entries created when you configure a Group Policy for the Active Directory in Windows 2000. These entries are created and maintained by Group Policy, and are read and interpreted by Active Directory.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

Installer subkey (HKLM)


EnableFilter

HKCU\Software\Policies\Microsoft\Windows\Directory UI

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Displays the filter bar above the results of an Active Directory search. The filter bar consists of buttons for applying additional filters to search results.

This entry stores the setting of the Enable filter in Find dialog box Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. The filter bar does not appear by default, but users can display it by selecting Filter from the View menu.
1 | The policy is enabled. The filter bar appears when the Active Directory Find dialog box opens, but users can hide it.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Enable filter in Find dialog box policy (User Configuration\AdministrativeTemplates\Desktop\Active Directory).

Tip Image Tip

To see the filter bar, open My Network Places, click Entire Network, and then click Directory. Right-click the name of a Windows 2000 domain, and then click Find. Type the name of an object in the directory, such as Administrator. If the filter bar does not appear above the resulting display, then, from the View menu, click Filter.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


HideDirectoryFolder

HKCU\Software\Policies\Microsoft\Windows\Directory UI

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Hides the Active Directory folder in My Network Places. The Active Directory folder displays Active Directory objects in a browse window.

This entry stores the setting of the Hide Active Diretory folder Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. The Active Directory folder appears in the My Network Places folder.
1 | The policy is enabled. the Active Directory folder does not appear in the My Network Places folder.

This policy is designed to let users search Active Directory, but not tempt them to casually browse Active Directory.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Hide Active Diretory folder policy (User Configuration\AdministrativeTemplates\Desktop\Active Directory).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


QueryLimit

HKCU\Software\Policies\Microsoft\Windows\Directory UI

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF objects | 0x2710 (10,000 objects)

Description

Specifies the maximum number of objects the system displays in response to a command to browse or search Active Directory.

This entry stores the setting of the Maximum size of Active Directory searches Group Policy. Group Policy adds this entry to the registry when you enable the Screen saver executable name policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0x2710 (10000 objects). Typically, 10,000 objects consumes approximately 2 MB of memory or disk space.

This policy is designed to protect the network and the domain controller from the effect of expansive searches. It limits returns in all browse displays associated with Active Directory, such as those in Local Users and Groups, Active Directory Users & Computers, and dialog boxes used to set permissions for user or group objects in Active Directory.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Maximum size of Active Directory searches policy (User Configuration\AdministrativeTemplates\Desktop\Active Directory).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


Group Policy Editor

HKCU\Software\Policies\Microsoft\Windows\

Description

The Group Policy Editor subkey contains entries that store the Group Policy settings which determine how Group Policy is applied to this system. The entries in this subkey are written and maintained by Group Policy.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

Group Policy


DCOption

HKCU\Software\Policies\Microsoft\Windows\Group Policy Editor

Data type | Range | Default value
REG_DWORD | 1 | 2 | 3 | 1

Description

Determines which domain controller the Group Policy snap-in uses.

This entry stores the setting of the Group Policy domain controller selection Group Policy. Group Policy adds this entry to the registry when you enable the Group Policy domain controller selection policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 1.

Value | Meaning
1 (or not in registry) | Use the Primary Domain Controller. The Group Policy snap-in reads and writes changes to the domain controller designated as the PDC Operations Master for the domain.
2 | Inherit from the Active Directory Snap-ins. The Group Policy snap-in reads and writes changes to the domain controller that Active Directory Users and Computers or Active Directory Sites and Services snap-ins use.
3 | Use any available domain controller. The Group Policy snap-in can read and write changes to any available domain controller.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Group Policy domain controller selection policy (User Configuration\Administrative Templates\System\Group Policy).

Tip Image Tip

To change the PDC Operations Master for a domain, in Active Directory Users and Computers, right-click a domain, and then click Operations Masters.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


DisableAutoADMUpdate

HKCU\Software\Policies\Microsoft\Windows\Group Policy Editor

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines if the system is prevented from updating the Administrative Templates source files automatically when you open Group Policy.

Prevents the system from updating the Administrative Templates source files automatically when you open Group Policy.

This entry stores the setting of the Disable automatic update of ADM files Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

By default, when you start Group Policy, the system loads the most recently revised copies of each Administrative Templates source file (.adm) that it finds in the %Systemroot%\inf directory. The .adm files create the list of policies that appear in the Administrative Templates folder in Group Policy.

When the value of this entry is 1, the system loads the .adm files you used the last time you ran Group Policy. Thereafter, you must update the .adm files manually.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. The system loads the most current version of each .adm file.
1 | The policy is enabled. The system loads the .adm files you used the last time you ran Group Policy.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable automatic update of ADM files policy (User Configuration\Administrative Templates\System\Group Policy).

Note Image Note

Upgrading your .adm files does not overwrite your policy configuration settings. The settings are stored in Active Directory, not in the .adm files.

Tip Image Tip

To upgrade your .adm files manually, in Group Policy, right-click the Administrative Templates folder (either instance), and then click Add/Remove Templates.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


NewGPOLinksDisabled

HKCU\Software\Policies\Microsoft\Windows\Group Policy Editor

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Creates new Group Policy object links in the disabled state.

This entry stores the setting of the Create new Group Policy object links disabled by default Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. Newly created Group Policy object links are immediately enabled. If you don't want them to be effective until they are configured and tested, you must disable the object link.
1 | The policy is enabled. Newly created Group Policy object links are disabled. After you configure and test the new object links, either by using Active Directory Users and Computers or Active Directory Sites and Services, you can enable the object links for use on the system.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Create new Group Policy object links disabled by default policy (User Configuration\Administrative Templates\System\Group Policy).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


ShowPoliciesOnly

HKCU\Software\Policies\Microsoft\Windows\Group Policy Editor

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Turns on the Show Policies Only command in Group Policy, and prevents administrators from turning it off.

When the Show Policies Only command is turned on, only true policies are displayed in the Group Policy snap-in; other items, known as preferences, are hidden.

This entry stores the setting of the Enforce Show Policies Only Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

A Group Policy administration (.adm) file can contain both true policies and preferences. True policies, which are fully supported by Group Policy, must use registry entries in the Software\Policies or Software\Microsoft\Windows\CurrentVersion\Policies registry subkeys. Preferences, which are not fully supported, use registry entries in other subkeys.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. The Show Policies Only command is turned on by default, but administrators can view preferences by turning off the Show Policies Only command.
1 | The policy is enabled. The Show Policies Only command is turned on, and administrators cannot turn it off. As a result, Group Policy displays only true policies; preferences do not appear.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Enforce Show Policies Only policy (User Configuration\Administrative Templates\System\Group Policy).

Tip Image Tip

To find the Show Policies Only command, in Group Policy, click the Administrative Templates folder (either instance), then right-click the same folder, and then point to View.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


Installer

HKCU\Software\Policies\Microsoft\Windows\

Description

The Installer subkey stores the entries created when you configure a Group Policy setting for Windows Installer. These entries are created and maintained by Group Policy, and are read and interpreted by Windows Installer.

The Installer subkey in the Policies subkey in HKEY_CURRENT_USER stores policy-related entries that are configured separately for each user. The system adds these entries when you enable (and, for some policies, when you disable) a policy in the User Configuration folder in Group Policy.

There is also an Installer subkey in the Policies subkey in HKEY_LOCAL_MACHINE, which stores entries for policies that apply to all users of the computer. The system adds these entries when you enable (and, for some policies, when you disable) a policy in the Computer Configuration folder in Group Policy.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

Installer subkey (HKLM)


AlwaysInstallElevated

HKCU\Software\Policies\Microsoft\Windows\Installer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Directs Windows Installer to use system permissions when it installs a program. By default, Windows Installer uses the user's permissions to install programs.

This entry stores the setting of the Always install with elevated privileges Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Always install with elevated privileges policy. If you disable the policy, Group Policy sets the value to 0. If you set the policy to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. Use the current user's permissions, except when installing published or assigned programs.
1 | The policy is enabled. Uses system permissions.

This entry extends elevated privileges to all programs. These privileges are usually reserved for programs that have been assigned to the user (offered on the desktop), assigned to the computer (installed automatically), or made available in Add/Remove Programs in Control Panel. This entry lets users install programs that require access to directories that the user might not have permission to view or change, including directories on highly restricted computers.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Always install with elevated privileges policy (User Configuration\Administrative Templates\Windows Components\Windows Installer).

Note Image Note

This entry can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If this entry appears in both subtrees, the value in HKEY_LOCAL_MACHINE takes precedence over the value in HKEY_CURRENT_USER.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Caution Image Caution

Skilled users can take advantage of the permissions this entry grants to change their privileges and gain permanent access to restricted files and folders. Note that the version of this entry in HKEY_CURRENT_USER is not guaranteed to be secure.

Related Entries

AlwaysInstallElevated (HKLM)


DisableMedia

HKCU\Software\Policies\Microsoft\Windows\Installer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Prevents users, including administrators, from installing programs from removable media.

This entry stores the setting of the Disable media source for any install Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy, Group Policy sets the value to 0. If you set the policy to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. Users can install programs from removable media when the installation is running in their own security context, but only system administrators can install programs from removable media when an installation is running with elevated system privileges.
1 | The policy is enabled. Neither regular users nor system administrator can install programs from removable media, regardless of the security context. If a user tries to install a program from removable media, such as CD-ROMs, floppy disks, and DVDs, a message appears, stating that the feature cannot be found.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable media source for any install policy (User Configuration\Administrative Templates\Windows Components\Windows Installer).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

AllowLockdownMedia

NoAddFromCDorFloppy


DisableRollback

HKCU\Software\Policies\Microsoft\Windows\Installer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Prohibits Windows Installer from generating and saving the files it needs to reverse an interrupted or unsuccessful installation.

This entry prevents Windows Installer from recording the original state of the system and the sequence of changes it makes during an installation. It also prevents Windows Installer from retaining files it intends to delete later. As a result, Windows installer cannot restore the computer to its original state if an installation does not complete successfully.

This entry stores the setting of the Disable rollback Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Disable rollback policy. If you disable the policy, Group Policy sets the value to 0. If you set the policy to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. Windows Installer can generate and save the files it needs to reverse an interrupted or unsuccessful installation.
1 | The policy is enabled. Windows Installer cannot generate or save the files it needs to reverse an interrupted or unsuccessful installation.

This entry is designed to reduce the amount of temporary disk space required to install programs. Also, it prevents malicious users from interrupting an installation to gather data about the internal state of the computer or to search secure system files. However, because an incomplete installation can render the system or a program inoperable, do not change the default behavior unless it becomes essential.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable rollback policy (User Configuration\Administrative Templates\Windows Components\Windows Installer).

Note Image Note

This entry can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If this entry appears in both subtrees, the value in HKEY_LOCAL_MACHINE takes precedence over the value in HKEY_CURRENT_USER.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

DisableRollback (HKLM)


SearchOrder

HKCU\Software\Policies\Microsoft\Windows\Installer

Data type | Range | Default value
REG_SZ | String | nmu

Description

Specifies the order in which Windows Installer searches for installation files.

This entry stores the setting of the Search order Group Policy. Group Policy adds this entry to the registry when you enable the Search order policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is nmu.

This entry consists of a string of up to three letters, where each letter represents a installation file source. The following table shows the meaning of each letter.

Value | Meaning
n | Network.
m | Removable media (such as a floppy disk, CD-ROM, or DVD).
u | URL, or the Internet.

To specify the order in which installation files are searched, type the letters representing each file source in the order that you want Windows Installer to search them. To exclude a file source, omit or delete the letter representing that source type

For example, the default value, nmu, directs Windows Installer to search the network first (n), then removable media (m), and finally, the Internet (u).

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Search order policy (User Configuration\Administrative Templates\Windows Components\Windows Installer). Type the letters representing each file source in the order that you want Windows Installer to search. To exclude a file source, omit or delete the letter representing that source type.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


NetCache

HKCU\Software\Policies\Microsoft\Windows\

Description

The NetCache subkey contains entries that store Group Policy settings for the Offline Files feature. In Group Policy, these policies appear in the Computer Configuration\Administrative Templates\Network\Offline Files folder.

This subkey in HKEY_LOCAL_MACHINE stores entries related to policies that apply to all users of this computer. There is also a Microsoft\Windows\NetCache subkey in HKEY_CURRENT_USER, which stores policy-related entries that are configured separately for each user.

Also, many the policy-related entries in this subkey take precedence over user settings while the policy is in effect. The affected user settings are stored in HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\NetCache.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


AssignedOfflineFolders

HKCU\SOFTWARE\Policies\Microsoft\Windows\NetCache\

Description

The AssignedOfflineFolders subkey contains entries that store Group Policy settings for the Offline Folders feature. These entries are created and maintained by Group Policy, and are read and interpreted by the Offline Folders program.

This subkey stores a list of shared files and folders that are always made available offline.

This subkey and its entries store the setting of the Administratively assigned offline files Group Policy. Group Policy adds this subkey and entries to the registry when you configure the Administratively assigned offline files policy. If you disable the policy or set it to Not configured, Group Policy deletes the subkey and its entries from the registry.

Each of the entries in this subkey has the following format:

Path and file name or Path and folder name REG_SZ (Blank)

Files in this list behave as though they are manually cached, just as if a user had selected the Make available offline option for each file. When you enable the policy, the system copies these files to the offline file cache of each computer's local hard drive. These copies are always complete, and they are never automatically deleted as long as the policy is enabled.

If you disable the policy or set it to Not configured, these files are deleted from each system's offline file cache. They remain in the cache only if users have manually cached the files independent of this policy.

Change method

To add, delete or change the value of entries in this subkey, use Group Policy. This subkey corresponds to the Administratively assigned offline files policy (Computer Configuration\Administrative Templates\Network\Offline Files).

Note Image Note

This subkey can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If this entry appears in both subtrees, the list in HKEY_LOCAL_MACHINE is used and the list in HKEY_CURRENT_USER is ignored.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


CustomGoOfflineActions

HKCU\Software\Policies\Microsoft\Windows\NetCache\

Description

The CustomGoOfflineActions subkey contains entries that determine whether users can work offline if they are suddenly disconnected from particular offline file servers. This feature lets you specify exceptions to the general offline action rules for servers that require a specialized response, such as those that host databases.

The CustomGoOfflineActions subkey and its entries stores the setting of the Non-default server disconnect actions Group Policy. Group Policy adds this subkey and entries to the registry when you configure the Non-default server disconnect actions policy. If you disable the policy or set it to Not configured, Group Policy deletes the subkey and its entries from the registry.

Each of the entries in this subkey represents a particular server, and specifies whether users can use the server's files offline when disconnected from the server.

These entries override the default offline action rules, the Exception list on the Offline Files tab, and the general offline action policy specified by the Action on server disconnect policy (stored in GoOfflineAction).

When this subkey contains valid entries, the system disables the Exception list section on the Offline Files tab to prevent administrators from specifying customized server responses while a policy is in effect. If an administrator has already created an exception list, their list is ignored while the policy is in effect.

Each of the entries in this subkey has the following format:

Computer-name REG_SZ 0 or 1

The value of the entry indicates the custom response.

Value | Meaning
0 | Users can work offline if they are disconnected from this server.
1 | Users cannot work offline if they are disconnected from this server.
Reskit REG_SZ 1

indicates that users are not permitted to work offline when they are disconnected from the Reskit server.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Non-default server disconnect actions policy (User Configuration\Administrative Templates\Network\Offline Files). Click Show, and then click Add. In the Type the name of the item to be added box, type the server's computer name. Then, in the Type the value of the item to be added box, type 0 if users can work offline when they are disconnected from this server, or type 1 if they cannot.

To configure this setting without setting a policy, use Windows Explorer. On the Tools menu, click Folder Options, click the Offline Files tab, and then click Advanced. This policy corresponds to the settings in the Exception list section.

Note Image Note

This entry takes precedence over a user setting. When this entry appears in the registry, the system disables the Exception list section of the Offline Files tab and ignores the value of entries in the CustomGoOfflineActions subkey in HKCU\Software\Microsoft\Windows\CurrentVersion\NetCache, which stores its data. If the Exception list does not operate as expected, check to see if this entry is in the registry.

This entry can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If this entry appears in both subtrees, the value in HKEY_LOCAL_MACHINE takes precedence over the value in HKEY_CURRENT_USER.

Tip Image Tip

To specify customized offline action rules without establishing a policy, in Windows Explorer, on the Tools menu, click Folder Options, click the Offline Files tab, and then click Advanced. This policy corresponds to the settings in the Exception list section.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

CustomGoOfflineActions subkey (HKLM)


EventLoggingLevel

HKCU\Software\Policies\Microsoft\Windows\NetCache

Data type | Range | Default value
REG_DWORD | 0 - 3 | 0

Description

Determines which events the Offline Files feature records in the Application Log in Event Viewer.

This entry stores the setting in the Enter {0 – 3} box of the Event logging level Group Policy. Group Policy adds this entry to the registry when you configure the Event logging level policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

The values in the following table are cumulative; that is, each level includes the events in all preceding levels.

Value | Meaning
0 | Records an error when the Offline Files cache is corrupted.
1 | Also records an event when the server hosting the offline file is disconnected from the network.
2 | Also records events when the local computer is connected and disconnected from the network.
3 | Also records an event when the server hosting the offline file is reconnected to the network.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Event logging level policy (Computer Configuration\Administrative Templates\Network\Offline Files). From the Enter box, select the number corresponding to the events you want the system to log.

Note Image Note

This entry can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If this entry appears in both subtrees, the value in HKEY_LOCAL_MACHINE takes precedence over the value in HKEY_CURRENT_USER.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

EventLoggingLevel(HKLM)


GoOfflineAction

HKCU\Software\Policies\Microsoft\Windows\NetCache

Data type | Range | Default value
REG_DWORD | (Not in registry) | 0 | 1 | (Not in registry)

Description

Determines whether network files remain available if the computer is suddenly disconnected from the server hosting the files. Also, it prevents users, including administrators, from changing this option.

This entry stores the setting of the Action on server disconnect Group Policy. Group Policy adds this entry to the registry when you configure the Action on server disconnect policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry.

Value | Meaning
(Not in registry) | The policy is disabled or not configured. Users can work offline by default, but administrators can change this option.
0 | The policy is enabled and set to Work offline. Users can use local copies of network files while the server is inaccessible.
1 | The policy is enabled and set to Never go offline. Network files are not available while the server is inaccessible.

When this entry appears in the registry, the system disables the When a network connection is lost option on the Offline Files tab in Folder Options in Windows Explorer. This prevents administrators from changing the option while a policy is in effect.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Action on server disconnect policy (User Configuration\Administrative Templates\Network\Offline Files).

To configure the offline actions without setting a policy, use Windows Explorer. On the Tools menu, click Folder Options, click the Offline Files tab, click Advanced, and then select an option in the When a network connection is lost section.

Note Image Note

This entry takes precedence over a user setting. When this entry appears in the registry, the system disables the When a network connection is lost option on the Offline Files tab and ignores the value of GoOfflineAction in HKCU\Software\Microsoft\Windows\CurrentVersion\NetCache, which stores the option setting. If the Offline Files tab does not operate as expected, check to see if this entry is in the registry.

This entry can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If this entry appears in both subtrees, the value in HKEY_LOCAL_MACHINE takes precedence over the value in HKEY_CURRENT_USER.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

GoOfflineAction (HKLM)

CustomGoOfflineActions subkey (HKCU)


InitialBalloonTimeoutSeconds

HKCU\Software\Policies\Microsoft\Windows\NetCache

Data type | Range | Default value
REG_DWORD | 10 - 60 seconds | 30

Description

Determines how long the first reminder balloon for a network status change is displayed.

This entry stores the setting of the Initial reminder balloon lifetime Group Policy. Group Policy adds this entry to the registry when you configure the Initial reminder balloon lifetime policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system uses the default value of 30 seconds.

Reminder balloons appear when the user's connection to a network file is lost or reconnected and are updated periodically. By default, the first reminder for an event is displayed for 30 seconds. Then, updates appear every 60 minutes and are displayed for 15 seconds. You can use this entry to change the duration of the first reminder.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Initial reminder balloon lifetime policy (User Configuration\Administrative Templates\Network\Offline Files).

Note Image Note

This entry can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If this entry appears in both subtrees, the value in HKEY_LOCAL_MACHINE takes precedence over the value in HKEY_CURRENT_USER.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

InitialBalloonTimeoutSeconds (HKLM)


NoCacheViewer

HKCU\SOFTWARE\Policies\Microsoft\Windows\NetCache

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Removes the Offline Files folder.

The Offline Files folder lists network files stored on the local computer for offline use. Users can use the Offline Files folder to view or open copies of network files, and view characteristics of offline files, such as their server status, type, and location.

This entry stores the setting of the Prevent use of Offline Files folder Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Prevent use of Offline Files folder policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 | Displays the Offline Files folder.
1 | Removes the Offline Files folder.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Prevent use of Offline Files folder policy (User Configuration\Administrative Templates\Network\Offline Files).

To view the Offline Files Folder without setting a policy, use Windows Explorer. On the Tools menu, click Folder Options, click the Offline Files tab, and then click View Files.

Note Image Note

This entry affects the Offline Files folder only. It does not prevent users from working offline or from saving local copies of files available offline. Also, it does not prevent them from using other programs, such as Windows Explorer, to view their offline files.

This entry can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If this entry appears in both subtrees, the value in HKEY_LOCAL_MACHINE takes precedence over the value in HKEY_CURRENT_USER.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoCacheViewer (HKLM)


NoConfigCache

HKCU\Software\Policies\Microsoft\Windows\NetCache

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Prevents users from enabling, disabling, or changing the configuration of Offline Files.

This entry stores the setting of the Disable user configuration of Offline Files Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Disable user configuration of Offline Files policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 | The policy is disabled or not configured. Users can configure Offline Files.
1 | The policy is enabled. Users cannot configure Offline Files.

When the value of this entry is 1, the system removes the Offline Files tab from the Folder Options dialog box. It also removes the Settings item from the Offline Files context menu and disables the Settings button on the Offline Files Status dialog box. As a result, users cannot view or change the options on the Offline Files tab or the Offline Files dialog box.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable user configuration of Offline Files policy (User Configuration\Administrative Templates\Network\Offline Files ).

Note Image Note

This entry takes precedence over a user setting. When this entry appears in the registry, a policy is in effect and the system ignores the entries in the HKLM\Software\Microsoft\Windows\CurrentVersion\NetCache and HKCU\Software\Microsoft\Windows\CurrentVersion\NetCache subkeys which store the option settings. If the Offline Files tab does not operate as expected, check to see if this entry is in the registry.

This entry can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If this entry appears in both subtrees, the value in HKEY_LOCAL_MACHINE takes precedence over the value in HKEY_CURRENT_USER.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoConfigCache (HKLM)


NoMakeAvailableOffline

HKCU\SOFTWARE\Policies\Microsoft\Windows\NetCache

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Prevents users from making network files and folders available offline.

This entry stores the setting of the Disable "Make Available Offline" Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Disable "Make Available Offline" policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 | Users can make network files and folders available offline.
1 | Users cannot make network files and folders available offline.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable "Make Available Offline" policy (User Configuration\Administrative Templates\Network\Offline Files).

Note Image Note

This entry disables manual caching only. It does not prevent the system from saving local copies of files on shares designated for automatic caching.

This entry can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If this entry appears in both subtrees, the value in HKEY_LOCAL_MACHINE takes precedence over the value in HKEY_CURRENT_USER.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoMakeAvailableOffline (HKLM)


NoReminders

HKCU\SOFTWARE\Policies\Microsoft\Windows\NetCache

Data type | Range | Default value
REG_DWORD | (Not in registry) | 0 | 1 | (Not in registry)

Description

Determines whether reminder balloons are displayed, and prevents users from changing the setting.

This entry stores the setting of the Disable reminder balloons Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Disable reminder balloons policy. If you disable the policy, Group Policy sets the value to 0. If you set the policy to Not configured, Group Policy deletes the entry from the registry.

Value | Meaning
(Not in registry) | The policy is not configured. Reminder balloons are displayed, but users can hide them.
0 | The policy is disabled. Reminder balloons are displayed, and users cannot hide them.
1 | The policy is enabled. Reminder balloons are hidden, and users cannot display them.

When this value appears in the registry, the system disables the Enable reminders option on the Offline Files tab to prevent users from changing the setting while a policy is in effect.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable reminder balloons policy (User Configuration\Administrative Templates\Network\Offline Files).

To disable reminder balloons without setting policy, use Windows Explorer. On the Tools menu, click Folder Options, click the Offline Files tab, and then deselect the Enable reminders check box.

Note Image Note

This entry takes precedence over a user setting. When this entry appears in the registry, the system disables the Enable reminders option on the Offline Files tab and ignores the value of NoReminders in HKCU\Software\Microsoft\Windows\CurrentVersion\NetCache, which stores the option setting. If the Offline Files tab does not operate as expected, check to see if this entry is in the registry.

This entry can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If this entry appears in both subtrees, the value in HKEY_LOCAL_MACHINE takes precedence over the value in HKEY_CURRENT_USER.

Tip Image Tip

To disable reminder balloons without setting a policy, use Windows Explorer. On the Tools menu, click Folder Options, click the Offline Files tab, and then clear the Enable reminders check box.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoReminders (HKLM)


ReminderBalloonTimeoutSeconds

HKCU\SOFTWARE\Policies\Microsoft\Windows\NetCache

Data type | Range | Default value
REG_DWORD | 10 - 60 seconds | 15

Description

Determines how long updated reminder balloons are displayed.

This entry stores the setting of the Reminder balloon lifetime Group Policy. Group Policy adds this entry to the registry when you configure the Reminder balloon lifetime policy.

Reminder balloons appear when the user's connection to a network file is lost or reconnected and are updated periodically. By default, the first reminder for an event is displayed for 30 seconds. Then, updates appear every 60 minutes and are displayed for 15 seconds. You can use this entry to change the duration of the update reminder.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Reminder balloon lifetime policy (Computer Configuration\Administrative Templates\Network\Offline Files).

Note Image Note

This entry can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If this entry appears in both subtrees, the value in HKEY_LOCAL_MACHINE takes precedence over the value in HKEY_CURRENT_USER.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

ReminderBalloonTimeoutSeconds (HKLM)


ReminderFreqMinutes

HKCU\SOFTWARE\Policies\Microsoft\Windows\NetCache

Data type | Range | Default value
REG_DWORD | 0 - 1440 minutes | 60

Description

Determines how often reminder balloon updates appear, and prevents users from changing the setting.

This entry stores the setting of the Minutes box in the Reminder balloon frequency Group Policy. Group Policy adds this entry to the registry when you configure the Reminder balloon frequency policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system uses the default value of 60 minutes.

When this entry appears in the registry, the system removes the Display reminder balloon every … minutes option on the Offline Files tab. This prevents users from changing the setting while a policy is in effect.

Reminder balloons appear when the user's connection to a network file is lost or reconnected and are updated periodically. By default, the first reminder for an event is displayed for 30 seconds. Then, updates appear every 60 minutes and are displayed for 15 seconds. You can use this entry to change the update interval.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Reminder balloon frequency policy (Computer Configuration\Administrative Templates\Network\Offline Files).

To set reminder balloon frequency without setting a policy, use Windows Explorer. On the Tools menu, click Folder Options, and then click the Offline Files tab. This entry corresponds to the Display reminder balloon every … minutes option.

Note Image Note

This entry takes precedence over a user setting. When this entry appears in the registry, the system disables the Display reminder balloon every … minutes option on the Offline Files tab and ignores the value of ReminderFreqMinutes in HKCU\Software\Microsoft\Windows\CurrentVersion\NetCache, which stores the option setting. If the Offline Files tab does not operate as expected, check to see if this entry is in the registry.

This entry can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If this entry appears in both subtrees, the value in HKEY_LOCAL_MACHINE takes precedence over the value in HKEY_CURRENT_USER.

Tip Image Tip

To set reminder balloon frequency without setting a policy, use Windows Explorer. On the Tools menu, click Folder Options, and then click the Offline Files tab. This entry corresponds to the Display reminder balloon every … minutes option.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

ReminderFreqMinutes (HKLM)


SyncAtLogoff

HKCU\Software\Policies\Microsoft\Windows\NetCache

Data type | Range | Default value
REG_DWORD | (Not in registry) | 0 | 1 | (Not in registry)

Description

Determines whether the system performs a full or quick synchronization of offline files when users log off, and prevents users, including administrators, from changing the setting.

Quick synchronization ensures that files are complete, but does not ensure that they are current. Full synchronization ensures that offline files are complete and current.

This entry stores the setting of the Synchronize all offline files before logging off Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Synchronize all offline files before logging off policy. If you disable the policy, Group Policy sets the value to 0. If you set the policy to Not configured, Group Policy deletes the entry from the registry.

Value | Meaning
(Not in registry) | The policy is not configured. The system performs a quick synchronization by default, but administrators can change the setting.
0 | The policy is disabled. The system performs a quick synchronization, and administrators cannot change this setting.
1 | The policy is enabled. The system performs a full synchronization, and administrators cannot change this setting.

When this entry appears in the registry, the system disables the Synchronize all offline files before logging off option on the Offline Files tab. This prevent administrators from changing the synchronization option while a policy is in effect.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Synchronize all offline files before logging off policy (Computer Configuration\Administrative Templates\Network\Offline Files).

To change the synchronization method without setting a policy, use Windows Explorer. On the Tools menu, click Folder Options, click the Offline Files tab, and then select the Synchronize all offline files before logging off option.

Note Image Note

This entry takes precedence over a user setting. When this entry appears in the registry, a policy is in effect and the system disables the Synchronize all offline files before logging off option on the Offline Files tab and ignores the value of SyncAtLogoff in HKCU\Software\Microsoft\Windows\CurrentVersion\NetCache which stores the option setting. If the Offline Files tab does not operate as expected, check to see if this entry is in the registry.

This entry can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If this entry appears in both subtrees, the value in HKEY_LOCAL_MACHINE takes precedence over the value in HKEY_CURRENT_USER.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

SyncAtLogoff (HKLM)


Network Connections

HKCU\Software\Policies\Microsoft\Windows\

Description

The Network Connections subkey contains entries that store Group Policy settings for Network and Dial-up Connections. The entries in this subkey are written and maintained by Group Policy, and are read and interpreted by the Network and Dial-up Connections program.

This subkey in HKEY_CURRENT_USER stores policy-related entries that are configured separately for each user. There is also a Software\Policies\Microsoft\Windows\Network Connections subkey in HKEY_LOCAL_MACHINE that stores entries related to policies which apply to all users of this computer.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


NC_AddRemoveComponents

HKCU\Software\Policies\Microsoft\Windows\Network Connections

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether users can add and remove network components.

This entry stores the setting of the Enable adding or removing components of a RAS or LAN connection Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy, Group Policy sets the value to 0. If you set the policy to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 1.

A value of 0 disables the Install and Uninstall buttons for components of connections and prevents users from using the Windows Components wizard to add or remove components. These buttons are on the General tab for LAN connections and on the Networking tab for dial-up connections.

Value | Meaning
0 | The policy is disabled. Users cannot add or remove network components.
1 (or not in registry) | The policy is enabled or not configured. Users can add and remove network components.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Enable adding or removing components of a RAS or LAN connection policy (User Configuration\Administrative Templates\Network\Network and Dial-up Connections).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


NC_AdvancedSettings

HKCU\Software\Policies\Microsoft\Windows\Network Connections

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether the Advanced Settings item on the Advanced menu in Network and Dial-up Connections is enabled. The Advanced Settings item lets users view and change bindings and view and change the order in which the computer accesses connections, network providers, and print providers.

This entry stores the setting of the Enable the Advanced Settings item on the Advanced menu Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy, Group Policy sets the value to 0. If you set the policy to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 1.

Value | Meaning
0 | The policy is disabled. The Advanced Settings item is disabled.
1 (or not in registry) | The policy is enabled or not configured.The Advanced Settings item is enabled.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Enable the Advanced Settings item on the Advanced menu policy (User Configuration\Administrative Templates\Network\Network and Dial-up Connections).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


NC_AllowAdvancedTCPIPConfig

HKCU\Software\Policies\Microsoft\Windows\Network Connections

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether users can use Network and Dial-up Connections to configure TCP/IP, DNS, and WINS settings.

This entry stores the setting of the Allow TCP/IP advanced configuration Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy, Group Policy sets the value to 0. If you set the policy to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 1.

Value | Meaning
0 | The policy is disabled. The Advanced button is disabled and the users cannot open the Advanced TCP/IP Setting dialog box.
1 (or not in registry) | The policy is enabled or not configured. The Advanced button on the Internet Protocol (TCP/IP) Properties dialog box is enabled. As a result, users can open the Advanced TCP/IP Settings Properties page and modify IP settings, such as DNS and WINS server information.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Allow TCP/IP advanced configuration policy (User Configuration\Administrative Templates\Network\Network and Dial-up Connections).

Note Image Note

If the NC_LanProperties entry or the NC_LanChangeProperties entry is set to 0, users cannot gain access to the Advanced button. As a result, this entry is ignored.

Tip Image Tip

To open the Advanced TCP/IP Setting dialog box, in Network and Dial-up Connections, right-click a local area connection, and click Properties. In the Components checked are used by this connection box, click Internet Protocol (TCP/IP), click the Properties button, and then click the Advanced button.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NC_LanChangeProperties

NC_LanProperties


NC_ChangeBindState

HKCU\Software\Policies\Microsoft\Windows\Network Connections

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether users can enable and disable the components used by dial-up and local area connections.

This entry stores the setting of the Allow connection components to be enabled or disabled Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy, Group Policy sets the value to 0. If you set the policy to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 1.

A value of 1 disables the check boxes that appear beside the name of the component in the Properties dialog box for a connection. When they are active, users can use these check boxes to enable and disable components of a connection. Selecting the check box enables the component, and clearing the check box disables the component. These check boxes are on the General tab for LAN connections and on the Networking tab for dial-up connections.

Value | Meaning
0 | The policy is disabled. The check boxes for enabling and disabling components are active. Users can use the check boxes to enable or disable the components that a connection uses.
1 (or not in registry) | The policy is enabled or not configured. The check boxes for enabling and disabling components are disbled. Users cannot enable or disable the components that a connection uses.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Allow connection components to be enabled or disabled policy (User Configuration\Administrative Templates\Network\Network and Dial-up Connections).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


NC_DeleteAllUserConnection

HKCU\Software\Policies\Microsoft\Windows\Network Connections

Data type | Range | Default value
REG_DWORD | (Not in registry) | 0 | 1 | (Not in registry)

Description

Specifies which users can delete shared dial-up connections. Shared connections are available to all users of the computer. By default, only Administrators can delete shared dial-up connections.

This entry stores the setting of the Enable deletion of RAS connections available to all users Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy, Group Policy sets the value to 0. If you set the policy to Not configured, Group Policy deletes the entry from the registry.

Value | Meaning
(Not in registry) | The policy is not configured. Only Administrators can delete shared dial-up connections.
0 | The policy is disabled. No users (including administrators) can delete shared dial-up connections.
1 | The policy is enabled. All users can delete shared dial-up connections.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Enable deletion of RAS connections available to all users policy (User Configuration\Administrative Templates\Network\Network and Dial-up Connections).

Note Image Note

When the value of NC_DeleteConnection is 0, it takes precedence over NC_DeleteAllUserConnection. Users cannot delete any RAS connections and the NC_DeleteAllUserConnection entry is ignored.

This entry does not affect LAN connections. LAN connections are created and deleted automatically by the system when a LAN adapter is installed or removed. You cannot use Network and Dial-up Connections to create or delete a local area connection.

Tip Image Tip

To create a shared RAS connection, on the Connection Availability page in the Network Connections wizard, click For all users.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NC_DeleteConnection


NC_DeleteConnection

HKCU\Software\Policies\Microsoft\Windows\Network Connections

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether users can delete their private dial-up (RAS) connections. Private connections are those that are available only to one user.

This entry stores the setting of the Enable deletion of RAS connections Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy, Group Policy sets the value to 0. If you set the policy to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 1.

Value | Meaning
0 | The policy is disabled. Users cannot delete any RAS connections. This value also disables the Delete option on the context menu for a RAS connection and on the File menu in Network and Dial-up Connections.
1 (or not in registry) | The policy is enabled or not configured. Users can delete their private RAS connections and administrators can delete connections available to all users.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Enable deletion of RAS connections policy (User Configuration\Administrative Templates\Network\Network and Dial-up Connections).

Note Image Note

When the value of this entry is 0, it takes precedence over the Enable deletion of RAS connections available to all users policy (NC_DeleteAllUserConnection. Users cannot delete any RAS connections and the NC_DeleteAllUserConnection entry is ignored.

This entry does not affect LAN connections. LAN connections are created and deleted automatically when a LAN adapter is installed or removed.

Tip Image Tip

To create a private connection, on the Connection Availability page in the Network Connections wizard, click the Only for myself option.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NC_DeleteAllUserConnection


NC_DialupPrefs

HKCU\Software\Policies\Microsoft\Windows\Network Connections

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether the Dial-up Preferences item on the Advanced menu in Network and Dial-up Connections is enabled. The Dial-up Preferences item lets users create and change connections before logon and configure AutoDialing and callback features.

This entry stores the setting of the Enable the Dial-up Preferences item on the Advanced menu Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy, Group Policy sets the value to 0. If you set the policy to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 1.

Value | Meaning
0 | The policy is disabled. The Dial-up Preferences item is disabled.
1 (or not in registry) | The policy is enabled or not configured. The Dial-up Preferences item is enabled.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Enable the Dial-up Preferences item on the Advanced menu policy (User Configuration\Administrative Templates\Network\Network and Dial-up Connections).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


NC_LanChangeProperties

HKCU\Software\Policies\Microsoft\Windows\Network Connections

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether users can change the properties of components used by a local area connection.

This entry stores the setting of the Enable access to properties of components of a LAN connection Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy, Group Policy sets the value to 0. If you set the policy to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 1.

Value | Meaning
0 | The policy is disabled.The Properties button is disabled.
1 (or not in registry) | The policy is enabled or not configured. The Properties button is enabled.

The Properties button opens the Local Area Connection Properties dialog box, which includes a list of the network components that the connection uses. To view or change the properties of a component, click the name of the component, and then click the Properties button beneath the component list.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Enable access to properties of components of a LAN connection policy (User Configuration\Administrative Templates\Network\Network and Dial-up Connections).

Note Image Note

Not all network components have configurable properties. For components that are not configurable, the Properties button is always disabled.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NC_AllowAdvancedTCPIPConfig


NC_LanConnect

HKCU\Software\Policies\Microsoft\Windows\Network Connections

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether users can connect and disconnect LAN connections.

A value of 0 disables the Connect and Disconnect buttons. Also, double-clicking the icon representing the connection has no effect.

This entry stores the setting of the Enable connecting and disconnecting a LAN connection Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy, Group Policy sets the value to 0. If you disable the policy, Group Policy sets the value to 0. If you set the policy to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 1.

Value | Meaning
0 | The policy is disabled. Users cannot connect or disconnect LAN connections.
1 (or not in registry) | The policy is enabled or not configured. Users can connect and disconnect LAN connections.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Enable connecting and disconnecting a LAN connection policy (User Configuration\Administrative Templates\Network\Network and Dial-up Connections).

Note Image Note

Even when the value of this entry is 0, users can still connect and disconnect from the Status page for a connection. To prevent users from displaying the Status page, disable the Enable status statistics for an active connection policy (NC_Statistics).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


NC_LanProperties

HKCU\Software\Policies\Microsoft\Windows\Network Connections

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether users can view and change the properties of a local area connection.

A value of 0 disables the Properties menu for a local area connection. As a result, users cannot use the Local Area Connection Properties dialog box to view or change the properties of a local area connection.

By default, the Properties menu item appears when users right-click the icon representing a local area connection. Also, when users select the connection, Properties is enabled on the File menu.

This entry stores the setting of the Enable access to properties of a LAN connection Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy, Group Policy sets the value to 0. If you set the policy to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 1.

Value | Meaning
0 | The policy is disabled. The Properties menu is disabled.
1 | The policy is enabled or not configured. The Properties menu is enabled.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Enable access to properties of a LAN connection policy (User Configuration\Administrative Templates\Network\Network and Dial-up Connections).

Note Image Note

This entry supersedes policy-related entries that remove or disable parts of the Local Area Connection Properties dialog box, such as those that hide tabs, remove the check boxes for enabling or disabling components, or disable Properties button for components that a connection uses. When the value of this entry is 0, those entries are ignored.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NC_AllowAdvancedTCPIPConfig


NC_NewConnectionWizard

HKCU\Software\Policies\Microsoft\Windows\Network Connections

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether users can use the Network Connection wizard, which creates new network connections.

This entry stores the setting of the Display and enable the Network Connection wizard Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy, Group Policy sets the value to 0. If you set the policy to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 1.

Value | Meaning
0 | The policy is disabled. The Make New Connection icon does not appear. As a result, users cannot start the Network Connection wizard.
1 (or not in registry) | The policy is enabled or not configured. The Make New Connection icon appears in Network and Dial-up Connections. Clicking Make New Connection starts the Network Connection wizard.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Display and enable the Network Connection wizard policy (User Configuration\Administrative Templates\Network\Network and Dial-up Connections).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


NC_RasAllUserProperties

HKCU\Software\Policies\Microsoft\Windows\Network Connections

Data type | Range | Default value
REG_DWORD | (Not in registry) | 0 | 1 | (Not in registry)

Description

Specifies which users can view and change the properties of shared dial-up connections. Shared connections are available to all users of the computer. By default, only Administrators can view change the properties of shared dial-up connections.

This entry determines whether a Properties menu item appears when a user right-clicks the icon representing a dial-up connection and whether the Properties item appears on the File menu when a user selects a shared dial-up connection. The Properties items open the Dial-up Connection Properties dialog box, which lets users view and change the properties of a dial-up connection.

This entry stores the setting of the Enable access to properties of RAS connections available to all users Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy, Group Policy sets the value to 0. If you set the policy to Not configured, Group Policy deletes the entry from the registry.

Value | Meaning
(Not in registry) | The policy is not configured. Only Administrators can view or change the properties of shared dial-up connections.
0 | The policy is disabled. No users (including administrators) can view or change the properties of shared dial-up connections.
1 | The policy is enabled. All users can view and change the properties of shared dial-up connections.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Enable access to properties of RAS connections available to all users policy (User Configuration\Administrative Templates\Network\Network and Dial-up Connections).

Note Image Note

This entry supersedes policy-related entries that remove or disable parts of the Dial-up Connection Properties dialog box, such as those that hide tabs, remove the check boxes for enabling or disabling components, or disable Properties button for components that a connection uses. When the value of this entry is 0, those entries are ignored.

Tip Image Tip

To create a dial-up connection that is available to all users, on the Connection Availability page in the Network Connections wizard, click the For all users option. To find connections available to all users, see the Connections folder on your system drive (Documents and Settings\All Users\Application Data\Microsoft\Network\Connections).

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


NC_RasChangeProperties

HKCU\Software\Policies\Microsoft\Windows\Network Connections

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether users can view and change the properties of components used by a dial-up connection.

This entry stores the setting of the Enable access to properties of components of a RAS connection Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy, Group Policy sets the value to 0. If you set the policy to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 1.

Value | Meaning
0 | The policy is disabled. The Properties button is disabled.
1 (or not in registry) | The policy is enabled or not configured. The Properties button is enabled.

The Properties button opens the Dial-up Connection Properties dialog box, which includes a list of the network components that the connection uses. To view or change the properties of a component, click the name of the component, and then click the Properties button beneath the component list.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Enable access to properties of components of a RAS connection policy (User Configuration\Administrative Templates\Network\Network and Dial-up Connections).

Note Image Note

Not all network components have configurable properties. For components that are not configurable, the Properties button is always disabled.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


NC_RasConnect

HKCU\Software\Policies\Microsoft\Windows\Network Connections

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether users can connect and disconnect dial-up connections.

This entry stores the setting of the Enable connecting and disconnecting a RAS connection Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy, Group Policy sets the value to 0. If you disable the policy, Group Policy sets the value to 0. If you set the policy to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 1.

Value | Meaning
0 | The policy is disabled. Users cannot connect or disconnect dial-up connections.
1 (or not in registry) | The policy is enabled or not configured. Users can connect and disconnect dial-up connections.

When the value of this entry is 0, the Connect and Disconnect menu items are disabled and double-clicking the icon representing the connection has no effect.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Enable connecting and disconnecting a RAS connection policy (User Configuration\Administrative Templates\Network\Network and Dial-up Connections).

Note Image Note

Even when the value of this entry is 0, users can still connect and disconnect from the Status page for a connection. To prevent users from displaying the Status page, disable the Enable status statistics for an active connection policy (NC_Statistics).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


NC_RasMyProperties

HKCU\Software\Policies\Microsoft\Windows\Network Connections

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether users can view and change the properties of their private dial-up connections. Private connections are available only to one user.

A value of 0 disables the Properties menu for a local area connection. As a result, users cannot use the Dial-up Connection Properties dialog box to view or change the properties of their private dial-up connections.

By default, the Properties menu item appears when users right-click the icon representing a dial-up connection. Also, when users select the connection, Properties appears on the File menu.

This entry stores the setting of the Allow access to current user's RAS connection properties Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy, Group Policy sets the value to 0. If you set the policy to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 1.

Value | Meaning
0 | The policy is disabled. Users cannot view or change the properties of their private dial-up connections.
1 (or not in registry) | The policy is enabled or not configured. Users can view and change the properties of their private dial-up connections.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Allow access to current user's RAS connection properties policy (User Configuration\Administrative Templates\Network\Network and Dial-up Connections).

Note Image Note

This entry supersedes policy-related entries that remove or disable parts of the Dial-up Connection Properties dialog box, such as those that hide tabs, remove the check boxes for enabling or disabling components, or disable Properties button for components that a connection uses. When the value of this entry is 0, those entries are ignored.

Tip Image Tip

To create a private connection, on the Connection Availability page in the Network Connections wizard, click the Only for myself option.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


NC_RenameConnection

HKCU\Software\Policies\Microsoft\Windows\Network Connections

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether users can rename dial-up and local area connections.

This entry stores the setting of the Enable renaming of connections, if supported Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy, Group Policy sets the value to 0. If you set the policy to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 1.

Value | Meaning
0 | The policy is disabled. Users cannot rename connections.
1 (or not in registry) | The policy is enabled or not configured. Users can rename connections.

By default, users can rename connections by clicking the icon representing a connection or by using the File menu. When the value of this entry is 0, the Rename options are disabled.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Enable renaming of connections, if supported policy (User Configuration\Administrative Templates\Network\Network and Dial-up Connections).

Note Image Note

When the value of this entry is 0 and the value of NC_RenameMyRasConnection is 1, then users can rename only their private connections. However, when the value of this entry is 1, users can rename all connections, regarless of the value of NC_RenameMyRasConnection.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


NC_RenameMyRasConnection

HKCU\Software\Policies\Microsoft\Windows\Network Connections

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether users can rename their private dial-up connections. Private connections are available only to one user.

This entry stores the setting of the Enable renaming of RAS connections belonging to the current user Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy, Group Policy sets the value to 0. If you set the policy to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 1.

Value | Meaning
0 | The policy is disabled. The Rename option is disabled, even on the user's private connections.
1 (or not in registry) | The policy is enabled or not configured. The Rename option is enabled on users' private dial-up connections. Users can rename their private connection by right-clicking an icon representing the connection or by using the File menu.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Enable renaming of RAS connections belonging to the current user policy (User Configuration\Administrative Templates\Network\Network and Dial-up Connections).

Note Image Note

When the value of NC_RenameConnection is 1, users can rename any connections, and NC_RenameMyRASConnection is ignored. However, if the value of NC_RenameConnection is 0, and the value of NC_RenameMyRASConnection is 1, users can only rename their private connections.

Tip Image Tip

To create a private connection, on the Connection Availability page in the Network Connections wizard, click the Only for myself option.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


NC_ShowSharedAccessUI

HKCU\Software\Policies\Microsoft\Windows\Network Connections

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether the Sharing tab and Internet Connection Sharing wizard page are displayed. These dialog boxes let administrators enable, disable, and configure the Internet Connection Sharing feature of a dial-up connection.

When displayed, the Sharing tab appears in the Properties dialog box for a dial-up connection on all Windows 2000 systems. The Internet Connection Sharing page appears in the Network Connection wizard only on Windows 2000 Server.

This entry stores the setting of the Allow configuration of connection sharing Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Allow configuration of connection sharing policy. If you disable the policy, Group Policy sets the value to 0. If you set the policy to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 1.

Value | Meaning
0 | The policy is disabled. The system removes the Sharing tab and Internet Connection Sharing wizard page.
1 | The policy is enabled or not configured. The system displays the Sharing tab and Internet Connection Sharing wizard page.

Internet Connection Sharing lets users configure their system as an Internet gateway for a small network. It provides network services, such as name resolution, to the network.

By default, Internet Connection Sharing is disabled when you create a dial-up connection, but administrators can use the Sharing tab and Internet Connection Sharing wizard page to enable it.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Allow configuration of connection sharing policy (User Configuration\Administrative Templates\Network\Network and Dial-up Connections).

Note Image Note

This entry applies only to users in the Administrators group.

This entry can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If the entry appears in both places, the value of the entry in HKEY_LOCAL_MACHINE takes precedence over the value in HKEY_CURRENT_USER.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NC_ShowSharedAccessUI (HKLM)


NC_Statistics

HKCU\Software\Policies\Microsoft\Windows\Network Connections

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether users can view the Status page for an active connection.

The Status page displays information about the connection and its activity. It also provides buttons to disconnect and to configure the properties of the connection.

This entry stores the setting of the Enable status statistics for an active connection Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy, Group Policy sets the value to 0. If you set the policy to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 1.

Value | Meaning
0 | The policy is disabled. The Status option is disabled, and the Status page does not appear.
1 (or not in registry) | The policy is enabled or not configured. The Status page appears when users double-click an active connection. Also, an option to display the Status page appears on a menu when users right-click the icon for an active connection, and the option appears on the File menu when users select an active connection.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Enable status statistics for an active connection policy (User Configuration\Administrative Templates\Network\Network and Dial-up Connections).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


System

HKCU\Software\Policies\Microsoft\Windows\

Description

The System subkey stores entries related to policies of the operating system, such as the logon environment, task scheduler, and permissions to set and update group policies. These entries are created and maintained by Group Policy, and are read and interpreted by system component programs.

The System subkey in HKEY_CURRENT_USER stores entries that are configured separately for each user. There is also a Software\Policies\Microsoft\Windows\System subkey in HKEY_LOCAL_MACHINE, which stores entries that apply to all users of the computer.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System

HKLM\SOFTWARE\Policies\Microsoft\System

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

HKLM\SOFTWARE\Policies\Microsoft\Windows\System


DisableCMD

HKCU\Software\Policies\Microsoft\Windows\System

Data type | Range | Default value
REG_DWORD | (Not in registry) | 1 | 2 | (Not in registry)

Description

Determines whether users can run the interactive command prompt, Cmd.exe, and determines whether batch files (.cmd and .bat) can run on the system while this user is logged on.

This entry stores the setting of the Disable the command prompt Group Policy. Group Policy adds this entry to the registry when you enable the Disable the command prompt policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry.

Value | Meaning
(Not in registry.) | The policy is not configured. Users can run Cmd.exe and batch files can run on the system.
1 | The policy is enabled and set to Yes. Users cannot run Cmd.exe, but the system can run batch files.
2 | The policy is enabled and set to No. Users cannot running Cmd.exe, and batch files cannot run on the system.

When this entry appears in the registry, users cannot run Cmd.exe. If a user tries to open a command window, the system displays a message explaining that a policy prevents the action.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable the command prompt policy (User Configuration\Administrative Templates\System).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Caution Image Caution

Do not prevent the computer from running batch files if the computer uses logon, logoff, startup, or shutdown batch file scripts, or for users that use Terminal Services.


ExcludeProfileDirs

HKCU\Software\Policies\Microsoft\Windows\System

Data type | Range | Default value
REG_SZ | Folder-name[;Folder-name...] | There is no default value for this entry.

Description

Excludes additional folders from the user's roaming profile.

By default, the History, Local Settings, Temp, and Temporary Internet Files folders are excluded from the user's roaming profile. The folders specified in the value of this entry are excluded in addition to the default excluded folders.

This entry stores the setting of the Exclude directories in roaming profile Group Policy. Group Policy adds this entry to the registry when you enable the Exclude directories in roaming profile policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry

This entry lets you exclude folders that are normally included in the user's profile. As a result, these folders need not be stored by the network server on which the profile resides, and do not follow users to other computers.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Exclude directories in roaming profile policy (User Configuration\Administrative Templates\System\Logon/Logoff).

Note Image Note

You cannot use this entry to include the folders that are excluded by default.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


GroupPolicyMinTransferRate

HKCU\Software\Policies\Microsoft\Windows\System

Data type | Range | Default value
REG_DWORD | 0x0 | 0x1 - 0xFFFFFFF kilobits per second | 0x1F4 (500 kilobits per second)

Description

Defines a slow connection for purposes of applying and updating Group Policy.

If a policy update travels from the domain controller to the computer at a rate slower than is specified value of this entry, the system considers the connection to be slow.

This entry stores the setting of the Connection speed (Kbps) box in the Group Policy slow link detection Group Policy. Group Policy adds this entry to the registry when you enable the Group Policy slow link detection policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 500 kilobits.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Group Policy slow link detection policy (User Configuration\Administrative Templates\System\Group Policy). In the Connection speed box, type a decimal number between 0 and 4,294,967,200 (0xFFFFFFA0), indicating a transfer rate in kilobits per second. Any connection slower than this rate is considered to be slow. If you type 0, all connections are considered to be fast.

Note Image Note

The system's response to a slow policy connection is determined by the program implementing the policy. Also, the policy processing entries in the HKLM\Software\Policies\Microsoft\Windows\Group Policy\<Class-ID> subkeys let you override the programs' specified responses to slow connections.

This entry appears in both HKEY_CURRENT_USER and HKEY_LOCAL_MACHINE. The value of this entry in HKEY_LOCAL_MACHINE defines a slow link for policies in the Computer Configuration folder. The value of this entry in HKEY_CURRENT_USER defines a slow link for policies in the User Configuration folder.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

GroupPolicyMinTransferRate (HKLM)

SlowLinkDetectEnabled


Task Scheduler5.0

HKCU\Software\Policies\Microsoft\Windows\

Description

The Task Scheduler5.0 subkey stores the entries created when you configure a Group Policy for the Scheduled Tasks feature of Windows 2000. These entries are created and maintained by Group Policy, and are read and interpreted by Scheduled Tasks.

The Task Scheduler5.0 subkey in the Policies subkey in HKEY_CURRENT_USER stores entries that are configured separately for each user. The system adds these entries when you enable (and, for some policies, when you disable) a policy in the User Configuration folder in Group Policy.

There is also a Task Scheduler5.0 subkey in the Policies subkey in HKEY_LOCAL_MACHINE, which stores entries for policies that apply to all users of the computer. The system adds these entries when you enable (and, for some policies, when you disable) a policy in the Computer Configuration folder in Group Policy.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


Allow Browse

HKCU\Software\Policies\Microsoft\Windows\Task Scheduler5.0

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Limits newly scheduled items to programs on the user's Start menu and prevents the user from changing the scheduled program for existing tasks.

A value of 1 removes the Browse button from the Scheduled Task wizard and from the Task tab of the properties dialog box for a task. Also, users cannot edit the Run box or the Start in box that determine the program and path for a task. As a result, when users create a task, they must select a program from the list in the Scheduled Task wizard, which displays only the tasks that appear on the Start menu and its submenus. Once a task is created, users cannot change the program a task runs.

This entry stores the setting of the Prohibit Browse Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Prohibit Browse policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 | The policy is disabled or not configured. Users can schedule any program and can change the programs that existing tasks run
1 | The policy is enabled. Users can only schedule tasks that run programs on their Start menu. They cannot change the programs that existing tasks run.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Prohibit Browse policy (User Configuration\Administrative Templates\Windows Components\Task Scheduler).

Note Image Note

This does not prevent users from creating a new task by pasting or dragging any program into the Scheduled Tasks folder. To prevent this action, use DragAndDrop.

This entry can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If this entry appears in both subtrees, the value in HKEY_LOCAL_MACHINE takes precedence over the value in HKEY_CURRENT_USER.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

Allow Browse (HKLM)

DragAndDrop (HKCU)


Disable Advanced

HKCU\Software\Policies\Microsoft\Windows\Task Scheduler5.0

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Removes the Open advanced properties for this task when I click Finish item from last page of the Scheduled Task wizard. As a result, users cannot view or change the properties of newly created tasks.

This entry stores the setting of the Disable Advanced Menu Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Disable Advanced Menu policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 | The policy is disabled or not configured. Users can view and change the properties of newly created tasks.
1 | The policy is enabled. Users cannot view or change the properties of newly created tasks.

This policy is designed to simplify task creation for beginning users. However, a value of 1 does not prevent users from using the Properties page to view and change the properties of a task.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable Advanced Menu policy (User Configuration\Administrative Templates\Windows Components\Task Scheduler).

Note Image Note

This entry can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If this entry appears in both subtrees, the value in HKEY_LOCAL_MACHINE takes precedence over the value in HKEY_CURRENT_USER.

Tip Image Tip

This entry affects newly created tasks only. To prevent users from changing the properties of existing tasks, use the Property Pages entry.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

Disable Advanced (HKLM)

Property Pages (HKCU)


DragAndDrop

HKCU\Software\Policies\Microsoft\Windows\Task Scheduler5.0

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Disables the Cut, Copy, and Paste shortcut items on the context menu and on the Edit menu in Scheduled Tasks. It also disables the drag-and-drop features of the Scheduled Tasks folder. As a results, users cannot add new scheduled tasks by dragging, moving, or copying a document or program into the Scheduled tasks folder.

This entry stores the setting of the Disable Drag-and-Drop Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Disable Drag-and-Drop policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 | The policy is disabled or not configured. The cut, paste, move, and drag and drop features of the Scheduled Tasks folder are enabled.
1 | The policy is enabled. The cut, paste, move, and drag and drop features of the Scheduled Tasks folder are disabled.

This entry does not prevent users from using other methods to create new tasks and it does not prevent users from deleting tasks.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable Drag-and-Drop policy (User Configuration\Administrative Templates\Windows Components\Task Scheduler).

Note Image Note

This entry can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If this entry appears in both subtrees, the value in HKEY_LOCAL_MACHINE takes precedence over the value in HKEY_CURRENT_USER.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

DragAndDrop (HKLM)


Execution

HKCU\Software\Policies\Microsoft\Windows\Task Scheduler5.0

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Removes the Run and End Task items from the context menu that appears when you right-click a task in Scheduled Tasks. As a result, users cannot start tasks manually or force tasks to end.

This entry stores the setting of the Prevent Task Run or End Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Prevent Task Run or End policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 | The policy is disabled or not configured. Users can start and stop tasks manually.
1 | The policy is enabled. Users cannot start and stop tasks manually.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Prevent Task Run or End policy (Computer Configuration\Administrative Templates\Windows Components\Task Scheduler).

Note Image Note

This entry can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If this entry appears in both subtrees, the value in HKEY_LOCAL_MACHINE takes precedence over the value in HKEY_CURRENT_USER.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

Execution (HKLM)


Property Pages

HKCU\SOFTWARE\Policies\Microsoft\Windows\Task Scheduler5.0

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Removes the Properties item from the File menu in Scheduled Tasks and from the context menu that appears when you right-click a task.

As a result, users cannot viewing or change the properties of an existing task, such as the program the task runs, its schedule details, idle time and power management settings, and its security context. They can only see the properties that appear in Detail view and in the task preview.

This entry stores the setting of the Hide Property Pages Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Hide Property Pages policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 | The policy is disabled or not configured. Users can view and change the properties of a task.
1 | The policy is enabled. Users cannot view or change the properties of a task.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Hide Property Pages policy (Computer Configuration\Administrative Templates\Windows Components\Task Scheduler).

Note Image Note

This entry can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If this entry appears in both subtrees, the value in HKEY_LOCAL_MACHINE takes precedence over the value in HKEY_CURRENT_USER.

Tip Image Tip

This entry affects existing tasks only. To prevent users from changing the properties of newly created tasks, use the Disable Advanced (HKCU) entry.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

Disable Advanced (HKCU)

Property Pages (HKLM)


Task Creation

HKCU\SOFTWARE\Policies\Microsoft\Windows\Task Scheduler5.0

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Prevents users from creating new tasks in Scheduled Tasks.

A value of 1 removes the Add Scheduled Task item that starts the New Task wizard. Also, the system does not respond when users try to move, paste, or drag programs or documents into the Scheduled Tasks folder.

This entry stores the setting of the Disable New Task Creation Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Disable New Task Creation policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 | The policy is disabled or not configured. The user can create new tasks.
1 | The policy is enabled. The user cannot create new tasks.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable New Task Creation policy (User Configuration\Administrative Templates\Windows Components\Task Scheduler).

Note Image Note

This entry does not prevent administrators of a computer from using At.exe to create new tasks or prevent administrators from submitting tasks from remote computers.

This entry can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If this entry appears in both subtrees, the value in HKEY_LOCAL_MACHINE takes precedence over the value in HKEY_CURRENT_USER.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

Task Creation (HKLM)

Task Deletion (HKCU)


Task Deletion

HKCU\SOFTWARE\Policies\Microsoft\Windows\Task Scheduler5.0

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Prevents users from deleting new tasks in Scheduled Tasks.

A value of 1 removes the Delete item from the Edit menu in the Scheduled Tasks folder and from the menu that appears when you right-click a task. Also, the system does not respond when users try to cut or drag a task from the Scheduled Tasks folder.

This entry stores the setting of the Disable Task Deletion Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Disable Task Deletion policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 | The policy is disabled or not configured. The user can delete tasks.
1 | The policy is enabled. The user cannot delete tasks.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable Task Deletion policy (User Configuration\Administrative Templates\Windows Components\Task Scheduler).

Note Image Note

This entry does not prevent administrators of a computer from using At.exe to delete tasks.

This entry can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If this entry appears in both subtrees, the value in HKEY_LOCAL_MACHINE takes precedence over the value in HKEY_CURRENT_USER.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

Task Deletion (HKLM)

Task Creation (HKCU)


Windows NT

HKCU\Software\Policies\Microsoft\

Description

The Policies\Microsoft\Windows NT subkey stores the entries created when you configure a Group Policy related to Windows 2000. These entries are created and maintained by Group Policy.

The Policies\Microsoft\Windows NT subkey in HKEY_CURRENT_USER stores entries that are configured separately for each user. The system adds these entries when you enable (and, for some policies, when you disable) a policy in the User Configuration folder in Group Policy.

There is also a Policies\Microsoft\Windows NT subkey in HKEY_LOCAL_MACHINE, which stores entries for policies that apply to all users of the computer. The system adds these entries when you enable (and, for some policies, when you disable) a policy in the Computer Configuration folder in Group Policy.

Change method

To add, delete, or change an entry in this subkey, use Group Policy.

Note Image Note

The system adds this subkey to the registry when you change the default value of one of its entries.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

Windows NT (Policy subkey in HKLM)


Driver Signing

HKCU\Software\Policies\Microsoft\Windows NT\

Description

The Driver Signing subkey contains entries that store Group Policy settings for the Code Signing feature of Windows 2000. The entries in this subkey are written and maintained by Group Policy, and are read and interpreted by the Code Signing program.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


BehaviorOnFailedVerify

HKCU\Software\Policies\Microsoft\Windows NT\Driver Signing

Data type | Range | Default value
REG_DWORD | (Not in registry) | 0 | 1 | 2 | 1

Description

Determines how the system responds when a user tries to install device driver files that are not digitally signed.

This entry stores the setting of the Code signing for device drivers Group Policy. Group Policy adds this entry to the registry when you enable the Code signing for device drivers policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry.

This entry establishes the least secure response permitted on the systems of users in the group. Users can use System in Control Panel to select a more secure setting, but when this policy is enabled, the system does not implement any setting less secure than the one the policy established.

Value | Meaning
0 | Ignore. The system proceeds with the installation even if it includes unsigned files.
1 | Warn. The system notifies the user that files are not digitally signed and lets the user decide whether to stop or to proceed with the installation and whether to permit unsigned files to be installed.
2 | Block. The system to refuses to install unsigned files. As a result, the installation stops, and none of the files in the driver package is installed.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Code signing for device drivers policy (User Configuration\Administrative Templates\System). Use the drop-down box to specify the desired response.

To change driver file security without setting a policy, use System in Control Panel. Right-click My Computer, click Properties, click the Hardware tab, and then click the Driver Signing button.

Note Image Note

The system's response to unsigned driver files is determined by comparing the value of this entry to the values of the Policy entry in HKCU and the Policy entry in HKLM. The entry with the highest (most secure) value is used.

Tip Image Tip

To change driver file security without setting a policy, use System in Control Panel. Right-click My Computer, click Properties, click the Hardware tab, and then click the Driver Signing button.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

Policy (HKLM)

Policy (HKCU)


Printers

HKCU\Software\Policies\Microsoft\Windows NT\

Description

The Policies\Microsoft\Windows NT\Printers subkey stores the entries created when you configure a Group Policy for printers. These entries are created and maintained by Group Policy, and are read and interpreted by the printing functions in Windows 2000.

The Policies\Microsoft\Windows NT\Printers subkey in HKEY_CURRENT_USER stores entries that are configured separately for each user. The system adds these entries when you enable (and, for some policies, when you disable) a policy in the User Configuration folder in Group Policy.

There is also a Policies\Microsoft\Windows NT\Printers subkey in HKEY_LOCAL_MACHINE, which stores entries for policies that apply to all users of the computer. The system adds these entries when you enable (and, for some policies, when you disable) a policy in the Configuration folder in Group Policy.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


Wizard

HKCU\Software\Policies\Microsoft\Windows NT\Printers\

Description

The Printers\Wizard subkey stores the entries created when you configure a Group Policy that affects the Add Printer wizard. These entries are created and maintained by Group Policy, and are read and interpreted by the printing functions in Windows 2000.

The Printers\Wizard subkey in HKEY_CURRENT_USER stores entries that are configured separately for each user. The system adds these entries when you enable (and, for some policies, when you disable) a policy in the User Configuration folder in Group Policy.

There is also a Printers\Wizard subkey in HKEY_LOCAL_MACHINE, which stores entries for policies that apply to all users of the computer. The system adds these entries when you enable (and, for some policies, when you disable) a policy in the Configuration folder in Group Policy.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


Default Search Scope

HKCU\Software\Policies\Microsoft\Windows NT\Printers\Wizard

Data type | Range | Default value
REG_SZ | LDAP distinguished name | (There is no default value for this entry.)

Description

Specifies the Active Directory location where searches for printers begin.

This entry stores the setting of the Default Active Directory path when searching for printers Group Policy. Group Policy adds this entry to the registry when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and all searches begin at the root of Active Directory.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Default Active Directory path when searching for printers policy (User Configuration\Administrative Templates\Control Panel\Printers).

Note Image Note

This entry only provides a starting point for Active Directory searches for printers. It does not restrict user searches through the Active Directory.

Tip Image Tip

For more information about the format of an LDAP distinguished name, see "Object Naming" in the "Active Directory Logical Structure" chapter in the Windows 2000 Resource Kit Distributed Systems Guide.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


Downlevel Browse

HKCU\Software\Policies\Microsoft\Windows NT\Printers\Wizard

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Enables and disables the browse feature of the Add Printer wizard. The browse feature lets users search the network for shared printers.

This entry stores the setting of the Browse the network to find printers Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy, Group Policy sets the value to 0. If you set the policy to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 1.

Value | Meaning
0 | The policy is disabled. The browse feature is disabled. Users cannot browse the network to find a shared printer; they must type a printer name.
1 (or not in registry) | The policy is enabled or not configured. The browse feature is enabled. When users click Add a network printer, but do not type the name of a particular printer, the Add Printer wizard displays a list of all shared printers on the network and invites users to choose a printer from among them.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Browse the network to find printers policy (User Configuration\Administrative Templates\Control Panel\Printers).

Note Image Note

This entry affects the Add Printer wizard only. It does not prevent users from using other programs to browse for shared printers or to connect to network printers.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


Printers Page URL

HKCU\Software\Policies\Microsoft\Windows NT\Printers\Wizard

Data type | Range | Default value
REG_SZ | URL (Up to 255 characters) | There is no default value for this entry.

Description

Adds a link to an Internet or intranet Web page to the Add Printer wizard.

This entry stores the setting of the Browse a common web site to find printers Group Policy. Group Policy adds this entry to the registry when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry.

When this entry appears in the registry, the system adds a Browse button beside the Connect to a printer on the Internet or your intranet option on the Locate Your Printer page in the Add Printer wizard. When users click Browse, the system opens an Internet browser and navigates to the URL address that appears in the value of this entry.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Browse a common web site to find printers policy (User Configuration\Administrative Templates\Control Panel\Printers).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

DisableWebPrinting

SupportLinkName

SupportLink


UNICODE Program Groups

HKCU\

Description

The UNICODE Program Groups key contains subkeys that define the contents of all personal program groups in Program Manager. This information applies mainly to Windows 3.51 and earlier, but it applies also to Windows 2000 if you are running Program Manager as the desktop interface.

Change method

Data in this subkey is stored in binary format, so you cannot edit it using a registry editor. To change the content of program groups, use Program Manager.


HKEY_LOCAL_MACHINE

HKLM

Description

The HKEY_LOCAL_MACHINE subtree contains information about the local computer system, including hardware and operating system data such as bus type, system memory, device drivers, and startup control parameters.


HARDWARE

HKLM\

Description

The Hardware key stores data that describes the computer hardware detected by the system. This key is recreated each time the system starts. It includes information about devices and about the software drivers and other resources associated with devices.


DESCRIPTION

HKLM\HARDWARE\

Description

The Description subkey is a repository for data collected by the Windows 2000 hardware recognizer. It includes information about the BIOS, processors, and bus architecture. The Description subkey is recreated each time the system starts.


System

HKLM\HARDWARE\DESCRIPTION\

Description

The System subkey stores data collected by the Windows 2000 hardware recognizer. It includes information about the BIOS, processors, and bus architecture. The System subkey is recreated each time the system starts.


DEVICEMAP

HKLM\HARDWARE\

Description

The Devicemap subkey contains a set of subkeys representing the base classes of all devices on the computer. Drivers that control a device store the base class name in an entry in their HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services subkey.


SERIALCOMM

HKLM\HARDWARE\DEVICEMAP\

Description

The Serialcomm subkey stores data about serial ports on the computer. This subkey is part of the Hardware key and is recreated each time the system starts.


\Device\Serial#

HKLM\HARDWARE\DEVICEMAP\SERIALCOMM

Data type | Range | Default value
REG_SZ | COM port | There is no default value for this entry.

Description

Associates the Windows 2000 serial device identified by the number # with the communications port named by the value of the entry, such as COM1. The system uses this entry to identify the serial ports currently available on the computer.


SOFTWARE

HKLM\

Description

The SOFTWARE subkey stores program variables that are apply to all users of the computer. The system stores some of its variables in the subkeys in SOFTWARE. In addition, the SOFTWARE subkey contains subkeys representing the vendors that produced the software running on the system, including Microsoft.

Related Entries

HKCU\SOFTWARE subkey


Microsoft

HKLM\SOFTWARE\

Description

The Microsoft subkey stores configuration data for Microsoft programs running on the computer. The subkeys in the Microsoft subkey represent each of the programs and store settings that only affect the program.

The Microsoft subkey in HKEY_LOCAL_MACHINE stores entries that apply to all users of the computer. There is also a Software\Microsoft subkey in HKEY_CURRENT_USER that stores entries that apply only to the current user of the computer.

Related Entries

Microsoft subkey (HKCU)


Command Processor

HKLM\SOFTWARE\Microsoft\

Description

The Command Processor subkey stores user preferences for the command processor (Cmd.exe). Command Processor entries can also appear in HKEY_CURRENT_USER. If both appear, the values in HKEY_CURRENT_USER take precedence over the values in HKEY_LOCAL_MACHINE. Command-line settings entered in Cmd.exe take prescedence over registry settings.

Change method

To change the values of the entries in this subkey, use Command Processor (Cmd.exe).

Note Image Note

For more information about Command Processor, see Windows 2000 Help.

Related Entries

Command Processor in HKEY_CURRENT_USER


AutoRun

HKLM\SOFTWARE\Microsoft\Command Processor

Data type | Range | Default value
REG_SZ | list of commands | There is no default value for this entry.

Description

Contains commands which are executed each time you start Cmd.exe.

Change method

To change the value of this entry, use Command Processor (Cmd.exe).

Note Image Note

AutoRun can appear in HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If both appear in the registry, the value of the entry in HKEY_CURRENT_USER takes precedence over the value in HKEY_LOCAL_MACHINE.

The command line switches take precedence over the registry settings.

Tip Image Tip

To disable AutoRun for one use of the command processor, at the command prompt, type CMD /D.

For more information about the AutoRun feature, at the command prompt, type CMD /?.

Related Entries

AutoRun in HKEY_CURRENT_USER


CompletionChar

HKLM\SOFTWARE\Microsoft\Command Processor

Data type | Range | Default value
REG_DWORD | 0x0 | 0x1 - 0x1F | 0x20 | 0x40

Description

Specifies a character that activates the file-name completion feature in the command processor (Cmd.exe).

To specify a character, enter the hexadecimal value of an ASCII control character other than 0x20 (space). For example, 0x4 represents Ctrl-D and 0x6 represents Ctrl-F. To disable the file-name completion feature, set the value of this entry to 0x0.

Change method

To change the value of this entry, use Command Processor (Cmd.exe).

Note Image Note

CompletionChar and PathCompletionChar can appear in HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If both appear in the registry, the value of the entry in HKEY_CURRENT_USER takes precedence over the value in HKEY_LOCAL_MACHINE.

The command line switches take precedence over the registry settings.

Tip Image Tip

To enable or disable file name completion and directory name completion for one use of the command processor, at the command prompt, type CMD /F:ON (enable) or CMD /F:OFF (disable). This command sets the completion character to CTRL+F (0x6).

For more information about the file-name completion feature, at a command prompt, type CMD /?

Related Entries

PathCompletionChar

CompletionChar in HKEY_CURRENT_USER


DefaultColor

HKLM\SOFTWARE\Microsoft\Command Processor

Data type | Range | Default value
REG_DWORD | 0x00000000 | 0x00000001 - 0x000000FE | 0

Description

Specifies a default background color and text color for the command processor window. The value consists of two hexadecimal digits. The first digit specifies the background color; the second digit specifies the text color. The hexadecimal values correspond to colors in the following table.

Hexadecimal value | Color
0 | Black
1 | Blue
2 | Green
3 | Aqua
4 | Red
5 | Purple
6 | Yellow
7 | White
8 | Gray
9 | Light Blue
A | Light Green
B | Light Aqua
C | Light Red
D | Light Purple
E | Light Yellow
F | Bright White

This entry is used only when its value is valid and not 0x0, and when the user has not specified the window color by using the COLOR or /T commands. Values are not valid if the background color and the text color are identical, such as 0x55. If the value of this entry is not valid or 0x0, and the user has not entered a command to change the color, the command processor uses the colors specified for the console window in which the command processor runs.

Change method

To change the colors of a command window, click the system menu icon in the title bar, and then select either Defaults to change the settings for all instances of that window, or Properties to change the current window only. Click the Colors tab, and then use the color well options to change the values. This will change the colors for all console windows. To only change the colors for the command windows, you must edit the registry.

Related Entries

DefaultColor in HKEY_CURRENT_USER

ScreenColors


DelayedExpansion

HKLM\SOFTWARE\Microsoft\Command Processor

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether the command processor supports delayed expansion of environment variables. If the value of this entry is 1, the command processor interprets an exclamation mark, !, as an environment variable that is expanded only when used.

By default, the command processor expands variables when it reads a line of text. However, you can direct the command processor to expand a variable only when it is used. This permits you to include variables in compound conditional statements, and prevent them from being set before they are tested.

Value | Meaning
0 | Delayed expansion is not supported. The command processor expands environment variables when it reads them. It does not support exclamation marks as delayed variables.
1 | Delayed expansion is supported. The system expands environment variables surrounded by exclamation marks, such as !VAR!, only when they are used.

Change method

To change the value of this entry, start the Command Processor (Cmd.exe) and type cmd /v:on.

Note Image Note

DelayedExpansion can appear in HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If both appear in the registry, the value of the entry in HKEY_CURRENT_USER takes precedence over the value in HKEY_LOCAL_MACHINE.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry. Even when this entry appears in the registry, the setting of the command line switch, /V, takes precedence over this value.

Tip Image Tip

For more details, start the Command Processor (Cmd.exe) and type help set or type cmd /? and read the entry on the /V command.

Related Entries

DelayedExpansion (HKCU)


EnableExtensions

HKLM\SOFTWARE\Microsoft\Command Processor

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether the extensions to the command processor (Cmd.exe), such as chdir and setlocal, are enabled. Because the extensions might be incompatible with a command-script language, Windows 2000 lets you disable the extensions. This entry affects all extensions. You cannot use it to enable or disable extensions selectively. You can, however, disable extensions for a particular invocation of Cmd.exe by using the /E:OFF switch.

Value | Meaning
0 | Disabled
1 | Enabled

Change method

To change the value of this entry, use Command Processor (Cmd.exe).

Related Entries

EnableExtensions in HKEY_CURRENT_USER


PathCompletionChar

HKLM\SOFTWARE\Microsoft\Command Processor

Data type | Range | Default value
REG_DWORD | 0x0 | 0x1 - 0x1F | 0x20 | 0x40

Description

Specifies a character that activates the directory name completion in the command processor (Cmd.exe).

To specify a character, enter the hexadecimal value of an ASCII control character other than 0x20 (space). For example, 0x4 represents Ctrl-D and 0x6 represents Ctrl-F. To disable the directory name completion feature, set the value of this entry to 0x0.

Change method

Use Command Processor (Cmd.exe) to change the value of this entry.

Note Image Note

CompletionChar and PathCompletionChar can appear in HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If both appear in the registry, the value of the entry in HKEY_CURRENT_USER takes precedence over the value in HKEY_LOCAL_MACHINE.

The command line switches take precedence over the registry settings.

Tip Image Tip

To enable or disable directory name completion for one use of the command processor, at the command prompt, type CMD /F:ON (enable) or CMD /F:OFF (disable). This command sets the completion character to CTRL+D (0x4).

For more information about the path completion feature, at a command prompt, type CMD /?

Related Entries

CompletionChar

PathCompletionChar in HKEY_CURRENT_USER


DFSHost

HKLM\SOFTWARE\Microsoft\

Description

The DFSHost subkey stores configuration data for a Distributed file system (Dfs) root.

Tip Image Tip

To repair a damaged Dfs root, use the Dfs snap-in. If the Dfs snap-in does not fix the root configuration and you cannot stop hosting a Dfs namespace, you can delete the Dfs root configuration. Delete the DFSHost subkey, and then delete the subkeys in the LocalVolumes subkey (in HKLM\SYSTEM\CurrentControlSet\Services\DFSDriver). Do not delete the LocalVolumes subkey.

Related Entries

Dfs service subkey

DFSDriver subkey

LocalVolumes subkey

NtFrs subkey


Driver Signing

HKLM\SOFTWARE\Microsoft\

Description

The Driver Signing subkey in HKLM stores entries for the code signing feature of Windows 2000. The entries in this subkey apply to all users of the computer.

Microsoft digitally signs driver files to affirm that the driver software has been tested with Windows and has not been altered since it was tested by Microsoft.

Note Image Note

The entries in this subkey apply to all users of the computer. The entries in the Driver Signing subkey in HKCU apply only to the current user.

Tip Image Tip

For more information about driver signing and code signing, see Code signing for Windows 2000 in Windows 2000 Help.

Related Entries

Driver Signing (HKCU)


Policy

HKLM\SOFTWARE\Microsoft\Driver Signing

Data type | Range | Default value
REG_BINARY | 00 | 01 | 02 | 01

Description

Determines how the system responds when a user tries to install device driver files that are not digitally signed.

Value | Meaning
00 | Ignore. The system proceeds with the installation even if it includes unsigned files.
01 | Warn. The system notifies the user that files are not digitally signed and lets the user decide whether to stop or to proceed with the installation and permit unsigned files to be installed.
02 | Block. The system will not install unsigned files. As a result, the installation stops, and none of the files in the driver package are installed.

This entry applies to all users of the computer. However, if a stricter setting is configured for the current user (in Policy in HKCU) or a user Group Policy establishes a stricter setting (in BehaviorOnFailedVerify), then this value is ignored for the current user.

This entry stores the option selected in the File signature verification section of the Driver Signing Options dialog box when the Apply setting as system default box is selected. If the box is not selected, the selection applies only to the current user, and it is stored in the value of Policy in HKCU.

Change method

To change the value of this entry, use System in Control Panel. Click the Hardware tab, click Driver Signing, select an option in the File signature verification section, and then click the Apply setting as a system default box.

Note Image Note

The system adds this entry to the registry when you use System in Control Panel to change the default value.

This entry applies to all users of the computer. The Policy entry also can appear in the HKCU\SOFTWARE\Microsoft\Driver Signing for a particular user.

Tip Image Tip

For more information about driver signing and code signing, see Code signing for Windows 2000 in Windows 2000 Help.

Related Entries

Policy (HKCU)

BehaviorOnFailedVerify (Group Policy)


DrWatson

HKLM\SOFTWARE\Microsoft\

Description

The entries in the DrWatson subkey store configuration settings for Dr. Watson for Windows 2000 (drwtsn32.exe), the application error debugger for Windows 2000. These entries specify how the Dr. Watson for Windows 2000 notifies the user of an application error, and how its log file and crash dump file are configured.

Dr. Watson for Windows 2000 is installed with Windows 2000. The entries described in this section appear in your registry the first time Dr. Watson for Windows 2000 is started on your system.

Change method

To change the values of entries in this subkey, use Dr. Watson for Windows 2000. To start Dr. Watson for Windows 2000, click Start, click Run, and then type drwtsn32.

Activation method

These entries appear in the registry when you run Dr. Watson for Windows 2000 or when it runs automatically.


AppendToLogFile

HKLM\SOFTWARE\Microsoft\DrWatson

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether Dr. Watson for Windows 2000 overwrites the existing log file with new data or appends new data to the end of the existing log file. By default, the log file is named Drwtsn32.log and resides in the root of the system directory.

Value | Meaning
0 | Do not append. Dr. Watson for Windows 2000 overwrites the existing log file each time it records data about an application error.
1 | Append Dr. Watson for Windows 2000 appends new data to the end of the existing log file.

Change method

To change the value of this entry, use the Append to Existing Log File option in Dr. Watson for Windows 2000. To start Dr. Watson for Windows 2000, click Start, click Run, and then type drwtsn32.

Activation method

These entries appear in the registry when you run Dr. Watson for Windows 2000 or when it runs automatically.

Tip Image Tip

For a detailed description of the Dr. Watson for Windows 2000 log file, start Drwtsn32.exe, click Help, and then double-click Log File Description.


CrashDumpFile

HKLM\SOFTWARE\Microsoft\DrWatson

Data type | Range | Default value
REG_SZ | File name | %windir%\user.dmp

Description

Specifies the location of the crash dump file for Dr. Watson for Windows 2000. The crash dump file is a binary file created when a program running on Windows 2000 stops abnormally. The crash dump file can be interpreted by the Windows Debugger.

All users must have permission to read and write to the crash dump file. By default, the crash dump file is named user.dmp and resides in the root of the system directory.

This entry is used only when the value of CreateCrashDump is 1.

Change method

To change the value of this entry, enter a file name in the Crash Dump text box in Dr. Watson for Windows 2000. To start Dr. Watson for Windows 2000, click Start, click Run, and then type drwtsn32.

Activation method

These entries appear in the registry when you run Dr. Watson for Windows 2000 or when it runs automatically.

Related Entries

CreateCrashDump


CreateCrashDump

HKLM\SOFTWARE\Microsoft\DrWatson

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether Dr. Watson for Windows 2000creates a binary crash dump file when a program stops abnormally. The crash dump file can then be interpreted by the Windows Debugger.

If the value of this entry is 1, then the location of the crash dump file must appear in the value of CrashDumpFile. By default, the crash dump file is named user.dmp and resides in the root of the system directory.

Change method

To change the value of this entry, use the Create Crash Dump File option in Dr. Watson for Windows 2000. To start Dr. Watson for Windows 2000, click Start, click Run, and then type drwtsn32.

Activation method

These entries appear in the registry when you run Dr. Watson for Windows 2000 or when it runs automatically.

Related Entries

CrashDumpFile


DumpAllThreads

HKLM\SOFTWARE\Microsoft\DrWatson

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines which application threads are included in the log file created by Dr. Watson for Windows 2000 when an application error occurs. By default, the log file is named Drwtsn32.log and resides in the root of the system directory.

Value | Meaning
0 | Error thread only. The log file includes state information only for the thread that caused the application error.
1 | All threads. The log file includes state information for all threads that run in the process in which application error occurred.

Change method

To change the value of this entry, use the Dump All Thread Contexts option in Dr. Watson for Windows 2000. To start Dr. Watson for Windows 2000, click Start, click Run, and then type drwtsn32.

Activation method

These entries appear in the registry when you run Dr. Watson for Windows 2000 or when it runs automatically.

Tip Image Tip

For a detailed description of the Dr. Watson for Windows 2000 log file, start Drwtsn32.exe, click Help, and then double-click Log File Description.


DumpSymbols

HKLM\SOFTWARE\Microsoft\DrWatson

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether Dr. Watson for Windows 2000 includes a dump of the symbol table for each application module in its log file. The symbol table consists of the name and memory address of each symbol. By default, because it can be very large, the symbol table is not included in the log file.

Value | Meaning
0 | Omit symbol table.
1 | Include symbol table.

Change method

To change the value of this entry, use the Dump Symbol Table option in Dr. Watson for Windows 2000. To start Dr. Watson for Windows 2000, click Start, click Run, and then type drwtsn32.

Activation method

These entries appear in the registry when you run Dr. Watson for Windows 2000 or when it runs automatically.

Tip Image Tip

For a detailed description of the Dr. Watson for Windows 2000 log file, start Drwtsn32.exe, click Help, and then double-click Log File Description.


Instructions

HKLM\SOFTWARE\Microsoft\DrWatson

Data type | Range | Default value
REG_DWORD | 0x0 - 0x1F4 (0 - 500) | 0xA (10)

Description

Determines how many instructions preceding and following the faulty instruction are included in the instruction disassembly portion of Drwtsn32.log, the log file for Dr. Watson for Windows 2000.

The instruction disassembly includes the function that was being executed when the error occurred; the memory address, raw machine instruction, and decoded machine instruction for each adjacent instruction; and a complete analysis of the faulty instruction.

Change method

To change the value of this entry, enter a number in the Number of Instructions text box in Dr. Watson for Windows 2000. To start Dr. Watson for Windows 2000, click Start, click Run, and then type drwtsn32.

Activation method

These entries appear in the registry when you run Dr. Watson for Windows 2000 or when it runs automatically.

Tip Image Tip

To see an example of the instruction disassembly portion of the Dr. Watson for Windows 2000 log file, start Drwtsn32.exe, click Help, double-click Log File Description, and then scroll down through the file.

For a detailed description of the Dr. Watson for Windows 2000 log file, start Drwtsn32.exe, click Help, and then double-click Log File Description.


LogFilePath

HKLM\SOFTWARE\Microsoft\DrWatson

Data type | Range | Default value
REG_SZ | Path name | %windir% (%windir% indicates the root of the system directory.)

Description

Specifies the location of Drwtsn32.log, the log file for Dr. Watson for Windows 2000.

The log file contains diagnostic information about application errors that occurred on Windows 2000. All users must have permission to read and write to the log file.

Change method

To change the value of this entry, enter a path in the Log File Path text box in Dr. Watson for Windows 2000. To start Dr. Watson for Windows 2000, click Start, click Run, and then type drwtsn32.

Activation method

These entries appear in the registry when you run Dr. Watson for Windows 2000 or when it runs automatically.

Tip Image Tip

For a detailed description of the Dr. Watson for Windows 2000 log file, start Drwtsn32.exe, click Help, and then double-click Log File Description.


MaximumCrashes

HKLM\SOFTWARE\Microsoft\DrWatson

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF | 10

Description

Determines how many errors Dr. Watson for Windows 2000 maintains in its application error viewer and in the Event Viewer application log at any given time. When the number of recorded errors reaches the value of this entry, Dr. Watson operates normally and adds new errors to its log and crash dump file, but it does not add any new errors to its application log viewer or to the Event Viewer application log until it is reset.

The user is not notified that the number of crashes has reached the maximum.

To reset Dr. Watson for Windows 2000, run Drwtsn32.exe. You can either click Clear or increase the value in the Number of Errors to Save text box. When you click Clear, you delete all errors from the application error viewer in Dr. Watson for Windows 2000and you delete all events from the Event Viewer application log, even those not generated by Dr. Watson for Windows 2000. However, records of the application errors remain in the Drwtsn32.log and in the crash dump file, user.dmp, if one has been selected.

Change method

To change the value of this entry, enter a number in the Number of Errors to Save text box in Dr. Watson for Windows 2000. To start Dr. Watson for Windows 2000, click Start, click Run, and then type drwtsn32.

Activation method

These entries appear in the registry when you run Dr. Watson for Windows 2000 or when it runs automatically.

Tip Image Tip

To determine how many application errors Dr. Watson for Windows 2000 has analyzed since it was last reset, see the value of NumberOfCrashes.


NumberOfCrashes

HKLM\SOFTWARE\Microsoft\DrWatson

Data type | Range | Default value
REG_DWORD | 0x0 - value of MaximumCrashes | There is no default value for this entry.

Description

Counts the number of application errors Dr. Watson for Windows 2000 is maintaining in its application error viewer and in the Event Viewer application log. When this value reaches the value of MaximumCrashes, Dr. Watson for Windows 2000 operates normally and adds new errors to its log and crash dump file, but it does not add any new errors to its application log viewer or to the Event Viewer application log until it is reset.

The user is not notified that the number of crashes has reached the maximum.

To reset Dr. Watson for Windows 2000, run Drwtsn32.exe. You can either click Clear or increase the value in the Number of Errors to Save text box. When you click Clear, you delete all errors from the application error viewer in Dr. Watson for Windows 2000and you delete all events from the Event Viewer application log, even those not generated by Dr. Watson for Windows 2000. However, records of the application errors remain in the Drwtsn32.log and in the crash dump file, user.dmp, if one has been selected.

Activation method

These entries appear in the registry when you run Dr. Watson for Windows 2000 or when it runs automatically.

Caution Image Caution

Do not change the value of this entry. Dr. Watson for Windows 2000 uses this entry to maintain an accurate count of application errors.


SoundNotification

HKLM\SOFTWARE\Microsoft\DrWatson

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether Dr. Watson for Windows 2000 generates a sound when it detects an application error. If the value of this entry is 1, you can enter the name of a wave file (.wav) in the value of WaveFile. Otherwise, Dr. Watson generates two standard beeps.

This entry is used only when the computer is equipped with a sound card.

Value | Meaning
0 | No sound.
1 | Beeps or plays a specified wave file when it detects an application error.

Change method

To change the value of this entry, use the Sound Notification option in Dr. Watson for Windows 2000. To start Dr. Watson for Windows 2000, click Start, click Run, and then type drwtsn32.

Activation method

These entries appear in the registry when you run Dr. Watson for Windows 2000 or when it runs automatically.


VisualNotification

HKLM\SOFTWARE\Microsoft\DrWatson

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether Dr. Watson for Windows 2000 displays a message box when it detects an application error.

You might consider changing the default value of this entry on unattended computers or on the computers of task-based workers. However, it does not interfere with normal processing. While the message box is displayed, no new messages or windows can be displayed, but background processes are not affected. If the buttons on the message box are not clicked within five minutes, the message box is removed.

Change method

To change the value of this entry, use the Visual Notification option in Dr. Watson for Windows 2000. To start Dr. Watson for Windows 2000, click Start, click Run, and then type drwtsn32.

Activation method

These entries appear in the registry when you run Dr. Watson for Windows 2000 or when it runs automatically.


WaveFile

HKLM\SOFTWARE\Microsoft\DrWatson

Data type | Range | Default value
REG_SZ | File name | (Blank)

Description

Locates the file containing the sound that Dr. Watson for Windows 2000 plays when it detects an application error.

This entry is used only when the computer has a sound card and the value of SoundNotification is 1.

Change method

To change the value of this entry, use the Wave File option in Dr. Watson for Windows 2000. (If the computer does not have a sound card, the Wave File option is disabled.) To start Dr. Watson for Windows 2000, click Start, click Run, and then type drwtsn32.

Activation method

These entries appear in the registry when you run Dr. Watson for Windows 2000 or when it runs automatically.


MSMQ

HKLM\SOFTWARE\Microsoft\

Description

The MSMQ subkey stores configuration data for Message Queuing. This subkey and its contents appear only if you have installed the Message Queuing service.

Message Queuing is a store-and-forward service that enables applications to communicate across heterogeneous networks and operating systems, even when the networks and applications are running at different times. Message Queuing stores messages in queues and forwards them when the destination networks and applications come online. The entries in this subkey apply to all users of the computer.


Parameters

HKLM\SOFTWARE\Microsoft\MSMQ\

Description

The Parameters subkey stores configuration options for Message Queuing.


AckTimeout

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF milliseconds | Message Queuing calculates a value for this entry dynamically.

Description

Determines how long Message Queuing waits for internal message acknowledgement of a network session before deciding that the session should be closed.

By default, Message Queuing calculates an optimal acknowledgment timeout based on the quality of the communication line. However, you can add this entry to the registry and set it to a different value to override the result of the calculation.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Caution Image Caution

Adding this entry to the registry prevents the system from using an optimal value calculated for each line. If you set the value of this entry too low, sessions can be disconnected before any messages are delivered.


BscAckFrequency

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF seconds | A8C0 (43200 seconds = 12 hours)

Description

Determines how often a backup site controller (BSC) notifies its primary site controller (PSC) that it has purged deleted objects. If this counter expires 14 times and the PSC still has not received a purge message from the BSC, it issues an event warning and purges its deleted objects.

Note Image Note

This entry is used only when it appears in the registry of a Message Queuing MQIS server.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


CertificationAuthorities

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters\

Description

The CertificationAuthorities subkey contains X509-V3 certificates from external certification authorities (CAs). These subkeys are created by the Microsoft Crypto API 2.0. Message Queuing uses the certificates to generate digital signatures that uniquely identify the message sender. The certificate and the digital signature are sent with each authenticated message.

Change method

To enable or disable certificates, in Control Panel, double-click MS Message Queue, click the Security tab, and then click the Certification Authorities button.

Note Image Note

The entries in the subkeys under CertificationAuthorities store actual certification authority (CA) certificates, not just pointers to entries in another location.

Caution Image Caution

Do not change the value of entries in this subkey by editing the registry. Changing these values can disable the security features of Message Queuing.


CertInfoCacheSize

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF certificates | 0x35 (53 entries)

Description

Determines the maximum number of certificates stored in the certificate cache, which stores information about certificates found in incoming messages. This cache helps Message Queuing authenticate incoming messages more quickly.

If the cache is full (that is, the number of certificates is equal to the value of the CertInfoCacheSize entry) when the next certificate arrives, Message Queuing deletes half of the certificates in the cache. The oldest certificates are deleted first.

Note Image Note

Entries in the certificate cache are not subject to an expiration time. Certificates are deleted from the cache only when the cache is full.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


CleanupInterval

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF milliseconds | Message Queuing Client: 0x493E0 (300,000 milliseconds = 5 minutes) Message Queuing Server: 1D4C0 (120,000 millseconds = 2 minutes)

Description

Determines how long Message Queuing keeps an inactive network session open. If the network remains inactive for longer than the interval specified by this value, Message Queuing ends the session.


ClusteredQMs

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Description

The ClusteredQMs subkey stores entire registry sections of Message Queuing services running as cluster resources.

For every clustered Message Queuing resource, there is a subkey under the ClusteredQMs subkey which holds all the entries of this Message Queuing resource.

Note Image Note

Editing the entries in this subkey should only be done on the node currently hosting the resource, and only when the resource is online.


ClusterName

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_SZ | String | There is no default value for this entry.

Description

Stores the name of the cluster in which Message Queuing is installed.

This entry is used when Message Queuing is installed in a cluster-server configuration.


CryptKeyExpirationTime

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF milliseconds | 0x927C0 (600000 milliseconds = 10 minutes)

Description

Determines how long outgoing symmetric keys remain in the cryptographic key cache. When the time specified by this value expires, the key is deleted from the cache of the source server and symmetric keys used for encrypting messages are renewed.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

CryptSendKeyCacheSize


CryptReceiveKeyCacheSize

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF keys | 0x7F (127)

Description

Determines the maximum number of symmetric encryption keys found in incoming messages that can be stored in the cryptographic key cache on the receiving server.

If the cache is full (that is, the number of incoming keys is equal to the value of the CryptReceiveKeyCacheSize entry) when the next certificate arrives, Message Queuing deletes half of the certificates in the cache. The oldest certificates are deleted first.

Note Image Note

Incoming keys in the cryptographic key cache are not subject to an expiration time. Incoming keys are deleted from the cache only when the cache is full.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

CryptSendKeyCacheSize


CryptSendKeyCacheSize

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF keys | 0x35 (53)

Description

Determines the maximum number of outgoing symmetric encryption keys that can be stored in the cryptographic key cache on the sending server.

If the cache is full (that is, the number of outgoing keys is equal to the value of the CryptReceiveKeyCacheSize entry) when the next key arrives, Message Queuing deletes half of the keys in the cache. The oldest keys are deleted first.

Note Image Note

Incoming keys in the cryptographic key cache are not subject to expiration. Incoming keys are deleted from the cache only when the cache is full.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

CryptReceiveKeyCacheSize


DcCacheExpirationTime

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF milliseconds | 0xA4CB80 (10,800,000 milliseconds = 3hours)

Description

Determines how long an entry can remain in the domain controller cache. When the time interval specified in this entry expires, the domain controller name is deleted from the cache. The domain controller cache stores the name of the primary or backup domain controller in each domain that responds to queries fastest. Message Queuing uses the domain controller listed in the cache to search for information about users whose security identifiers (SIDs) appear in incoming messages.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

DcCacheSize


DcCacheSize

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF domains | 0x11 (17)

Description

Determines the maximum number of entries in the domain controller cache. If the cache is full (that is, the number of entries is equal to the value of the DcCacheSize entry) when the next entry arrives, Message Queuing deletes half of the entries in the cache. The oldest entries are deleted first.

The domain controller cache stores the name of the primary or backup domain controller in each domain that responds fastest to queries. There is one entry for each domain. Message Queuing uses the domain controller listed in the cache to search for information about users whose security identifiers (SIDs) appear in incoming messages.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

DcCacheExpirationTime


DeferredInit

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Prevents Message Queuing from contacting the MQIS server automatically at startup.

Value | Meaning
0 | Automatic. Message Queuing contacts the MQIS server automatically when the service starts.
1 | Deferred. Message Queuing does not contact the MQIS server automatically when the service starts. Instead, it contacts the MQIS when the first Message Queuing program requires access to the MQIS.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Caution Image Caution

The deferred setting can cause a brief delay while Message Queuing connects to the MQIS server. This delay might cause the first program that requires the MQIS server to appear momentarily unresponsive.


DSAdsRefreshIPSitesIntervalSecs

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF seconds | 0xE10 (3600 seconds = 1 hour)

Description

Specifies the minimum interval between successive updates of the IP subnets data for the site. Message Queuing servers use information from these updates to find the IP addresses of computer sites.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


DSAdsRefreshNT4SitesIntervalSecs

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF seconds | 0x5460 (21,600 seconds = 6 hours)

Description

Specifies the minimum interval between successive updates of the list of primary site controllers running Windows NT 4.0. Message Queuing uses information from these updates to determine whether it needs to support clients using previous versions of the operating system.

Note Image Note

This entry is used only when Windows 2000 MSIQ servers are supporting Windows NT 4.0 clients.


DSCliSearchAdsForServersIntervalSecs

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF seconds | 0x708 (1800 seconds = 30 minutes)

Description

Specifies the minimum interval between successive searches through Active Directory for Message Queuing servers. Message Queuing searches the Active Directory when it cannot connect to known Message Queuing servers.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Caution Image Caution

Do not change the value of this entry. Changing it can prevent Message Queuing from locating known servers in the Active Directory.


DSListRefresh

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF milliseconds | 0x2932E00 (43,200,000 milliseconds = 12 hours)

Description

Determines how often a Message Queuing client computer receives updated enterprise information from the Message Queuing directory service. The Message Queuing updates the ServersCache subkey on the local computer with data about the enterprise configuration, such as new sites and new servers.

Related Entries

MQISServer

ServersCache subkey


DSSecurityCache

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_BINARY | Security descriptor | There is no default value for this entry. The security descriptor of the computer is copied from the MQIS.

Description

Stores the security descriptor of the local Message Queuing computer. The security descriptor of the computer determines, among other things, which users or groups of users have permission to create queues on this computer. The value of this registry entry is used if an offline user attempts to create a private queue when a queue request is processed.

The security descriptor is saved in the registry to allow private queues to be created while the computer is not connected to the network.

Caution Image Caution

Do not change the value of this entry. If you do, the online operation of Message Queuing might be inconsistent with its offline operation.


ForceNoTransactionModeSwitch

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_SZ | String

Description

Directs Message Queuing to use the default-abort model after upgrading to Windows 2000 from Windows NT 4.0 and earlier.

If you add this entry to the registry of a computer running MSMQ 1.0, an upgrade to Windows 2000 preserves the default-abort model and will not transfer to the default-commit.


IdleAckDelay

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF milliseconds | 500

Description

Sets the maximum idle delay time between receiving a message and sending an acknowledgment back to the source.

Idle time is the time during which no messages are sent on the session. This time value ensures that computers creating a session for a limited time only will get all acknowledgments possible during the session. This prevents unnecessary resending due to lost acknowledgments.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


LastPrivateQueueId

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_BINARY | 0x0 - 0xFFFFFFFF | 0xA (10)

Description

Records the serial number of the last private queue created.

Caution Image Caution

Do not change the value of this entry. If you change it, Message Queuing might generate the same identifier for a private queue and damage the queue and the message service.


LogDataCreated

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines if log files are missing.

When Message Queuing runs for the first time, it creates local log files and sets the value of this entry to 1. This entry is used later by Message Queuing to determine whether log files are missing. If log files are missing, Message Queuing will not start, and an appropriate event will be generated.

Value | Meaning
0 | Local log files are not created on the computer.
1 | Local log files are created on the computer.


LogMgrBuffers

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF buffers | 0x190 (400)

Description

Determines how many buffers the Log Manager allocates for each new log file.

This entry is used to optimize Log Manager performance.

Note Image Note

This entry does not appear in the registry unless you add it or use a program to change its default value.

Caution Image Caution

Do not change the value of this entry. An inappropriate value can interfere with logging, transactions, and the exactly-once delivery mechanism.


LogMgrChkptInterval

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF milliseconds | x2710 (10 seconds)

Description

Determines how often the Log Manager performs an internal checkpoint on the log. This entry is used to optimize Log Manager performance.

Note Image Note

This entry does not appear in the registry unless you add it or use a program to change its default value.

Caution Image Caution

Do not change the value of this entry. An inappropriate value can interfere with logging, transactions, and the exactly-once delivery mechanism.


LogMgrFileSize

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF bytes | 0x600000 (6 MB)

Description

Determines the size of the Log Manager file. The size of this file affects its maintenance and Message Queuing's performance. Message Queuing performs checkpoints (saves the current log entries) when the log file occupies more than half of the space allocated for it. If the value of this entry is too small, Message Queuing takes checkpoints too frequently, diminishing overall performance. If the file is too large, it consumes unnecessary disk space.

Note Image Note

This entry does not appear in the registry unless you add it or use a program to change its default value.

Caution Image Caution

Do not change the value of this entry. An inappropriate value can interfere with logging and with the operation of Message Queuing.


LogMgrFlushInterval

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF milliseconds | 0x32 (50)

Description

Determines how often the Log Manager flushes the log file.

Note Image Note

This entry does not appear in the registry unless you add it or use a program to change its default value.

Caution Image Caution

Do not change the value of this entry. An inappropriate value can interfere with logging, transactions, and the exactly-once delivery mechanism.


LogMgrProbeInterval

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF milliseconds | 0x64 (100)

Description

Determines how often the Log Manager considers writing an empty record to the log file buffer. Empty records are written to fill the log file buffers so that the buffer contents are written to disk.

Note Image Note

This entry does not appear in the registry unless you add it or use a program to change its default value.

Caution Image Caution

Do not change the value of this entry. An inappropriate value can interfere with logging, transactions, and the exactly-once delivery mechanism.


LogMgrTimerInterval

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF milliseconds | 0xA (10)

Description

Determines how often the Log Manager considers performing a flush or internal checkpoint ("pulse interval").

Note Image Note

This entry does not appear in the registry unless you add it or use a program to change its default value.

Caution Image Caution

Do not change the value of this entry. An inappropriate value can interfere with logging, transactions, and the exactly-once delivery mechanism.


MachineCache

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters\

Description

The MachineCache subkey of the MSMQ\Parameters subkey stores configuration data that associates the local MQIS client computer with other computers in the enterprise managed by Message Queuing.


Address

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters\MachineCache

Data type | Range | Default value
REG_BINARY | Network addresses | There is no default value for this entry.

Description

Stores a list of the local computer's network addresses. These addresses are detected when the system starts. IP addresses are preceded by the bytes "04 00 01 00.", and IPX addresses are preceded by the bytes "0A 00 03 00".

Note Image Note

This list is updated each time the system starts. Do not edit the value of this entry.


CNs

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters\MachineCache

Data type | Range | Default value
REG_BINARY | GUIDs | There is no default value for this entry.

Description

Stores a list of the GUIDs of connected networks to which this computer is attached. The GUIDs for each network appear in the same order as the network addresses in the value of the Address entry.

Note Image Note

This list is updated each time the system starts. Do not edit the value of this entry.


CurrentMQISServer

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters\MachineCache

Data type | Range | Default value
REG_SZ | Computer name | Computer name

Description

Stores the computer name of the MQIS server currently selected by Message Queuing on this computer. The MQIS client uses the server specified for MQIS queries.

Note Image Note

This entry is used only when it appears in the registry of a Message Queuing MQIS client.

Related Entries

StaticMQISServer


EnterpriseId

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters\MachineCache

Data type | Range | Default value
REG_BINARY | Identifier | There is no default value for this entry.

Description

Stores a GUID which uniquely identifies the enterprise in which this computer is installed. The value of this entry must be the same in all Message Queuing computers in the enterprise.

Caution Image Caution

Do not change the value of this entry. If you change it, Message Queuing assumes that you have removed the computer from the enterprise, and the computer will not be able to access any MQIS server, or establish any network connections.


ForcedDSServer

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters\MachineCache

Data type | Range | Default value
REG_SZ | Computer Names | There is no default value for this entry.

Description

Used by Message Queuing in cases where querying the Directory Service for MQIS servers list fails or returns no results.

If this occurs, the value of this entry (the MQIS server name) is used by Message Queuing.


LkgMQISServer

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters\MachineCache

Data type | Range | Default value
REG_SZ | Computer Names | (There is no default value for this entry.)

Description

Stores a backup list of the MQIS servers in the current site (that is, the last known good copy of the values in the MQISServer entry).

This backup list is copied into MQISServer when the Message Queuing service discovers that the list in the MQISServer entry is overwritten by a list of MQIS servers from an incorrect Message Queuing enterprise. This can happen when a Message Queuing service belongs to MSMQ 1.0 enterprise and none of the MQIS servers in the MQISServer list are online at the computer restart. Message Queuing then queries the Windows 2000 Directory Service for a list of MQIS servers. If Windows 2000 Message Queing is deployed in this domain, the query returns a list of MQIS servers belonging to this deployment and not the correct MQIS servers from the MSMQ 1.0 Enterprise.


LongLiveTime

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters\MachineCache

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF seconds | 0x76A700 (7,776,000 seconds = 90 days)

Description

Determines how long a message remains in the system before it is deleted.

Change method

To change the value of this entry, use Message Queuing Explorer.


MachineJournalQuota

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters\MachineCache

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFE bytes | 0xFFFFFFFF | 0xFFFFFFFF

Description

Limits the amount of data that is stored in the journal file on the computer.

Value | Meaning
0x0 - 0xFFFFFFFE bytes | Journal file size limit.
0xFFFFFFFF | No limit on the size of the journal file.

Change method

To change the value of this entry, use Message Queuing Explorer.


MachineQuota

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters\MachineCache

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFE kilobytes | 0xFFFFFFFF | 0xFFFFFFFF

Description

Limits the total amount of data that is stored in message files on the computer. The sum of bytes in all message files on the computer cannot exceed the value of this entry.

Value | Meaning
0x0 - 0xFFFFFFFE kilobytes | Total message file size limit
0xFFFFFFFF | There is no limit on the message file size.

Change method

To change the value of this entry, use Message Queuing Explorer.


MasterId

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters\MachineCache

Data type | Range | Default value
REG_DWORD | GUID | There is no default value for his entry.)

Description

Stores a GUID which uniquely identifies the computer to other MQIS servers in the enterprise.

Note Image Note

This entry is used only when it appears in the registry of a Message Queuing MQIS server.

Caution Image Caution

Do not change the value of this entry. If you change it, other MQIS servers will not recognize the computer.


MQISServer

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters\MachineCache

Data type | Range | Default value
REG_SZ | Computer names | There is no default value for this entry.

Description

Stores a list of the MQIS servers in the current site.

For computers with Message Queuing belonging to a Windows 2000 site, this list contains all Windows 2000 domain controllers running Message Queuing as well as Windows 2000 servers running Message Queuing with Routing. For computers with Message Queuing belonging to Windows NT 4.0 MSMQ Enterprise, this list contains the primary site controller (PSC) and all backup site controllers (BSCs) at the local site. The list is compiled by Message Queuing at intervals specified by the value of the DSListRefresh entry and stored in the value of this entry. The Message Queuing client selects a server from this list.

Note Image Note

This entry is used only when it appears in the registry of a Message Queuing MQIS client.

Related Entries

StaticMQISServer


MQS

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters\MachineCache

Data type | Range | Default value
REG_DWORD | 0 | 1 | 2 | 4 | 8 | 16 | There is no default value for this entry.

Description

Specifies the type of messaging service provided by this computer.

Value | Meaning
0 | Independent client
1 | Routing server
2 | Backup site controller (BSC)
4 | Primary site controller (PSC)
8 | Primary enterprise controller (PEC)
16 | Routing and Remote Access connectivity

Caution Image Caution

Do not change the value of this entry. The computer's Message Queuing type is recorded in the MQIS database. Changing the value of this entry makes the database value inconsistent with the registry value, causing errors that might disable Message Queuing.


QMId

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters\MachineCache

Data type | Range | Default value
REG_BINARY | GUID | There is no default value for this entry.

Description

Stores the GUID that uniquely identifies this computer in the enterprise. The GUID is generated when Message Queuing is installed.

Caution Image Caution

Do not change the value of this entry. Message Queuing stores this GUID when Message Queuing is set up. Changing the value of this entry might cause Message Queuing to misidentify the computer.


SiteId

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters\MachineCache

Data type | Range | Default value
REG_BINARY | GUID | There is no default value for this entry.

Description

Stores the GUID that uniquely identifies the site in which the computer is currently located.

Change method

To change the site in which the computer resides, in Control Panel, double-click MS Message Queue, click the Mobile tab, and then change the value of the Site field.


SiteName

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters\MachineCache

Data type | Range | Default value
REG_SZ | String | There is no default value for this entry.

Description

Stores the name of the site in which the computer is currently located.

Change method

To change the site in which the computer resides, in Control Panel, double-click MS Message Queue, click the Mobile tab, and then change the value of the Site field.


StaticMQISServer

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters\MachineCache

Data type | Range | Default value
REG_SZ | Computer name | Does not appear in the registry.

Description

Specifies the server that Message Queuing uses for this client.

By default, this entry does not appear in the registry, and Message Queuing selects a current server randomly from the list of available BSC and PSC servers at the site. By adding this entry to the registry, you direct Message Queuing to use only the server specified by this value. The value of this entry replaces the values of the MQISServer and CurrentMQISServer entries, so that this server is the only one known to the client.

A static server is recommended when one server is clearly preferable to others, such as specifying a local server when other servers are connected by slow network links from a remote location.

Note Image Note

This entry is used only when it appears in the registry of a Message Queuing MQIS client.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


MaxMessageSize

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF bytes | 0x400000 (4 MB)

Description

Determines the maximum size of the message file. Because messages must fit in the file, the value of this entry also limits the size of messages sent and received by Message Queuing.

When Message Queuing starts, it restores all persistent messages in message files. If Message Queuing finds a message file larger than the value of this entry, it might not operate correctly. Also, when Message Queuing encounters messages larger than this value, it blocks all further transports from the sending computer. To restore communication, you must set the value of this entry greater than or equal to the size of the message that exceeded this value, and then restart Message Queuing.

If you increase this value, you might be able to transmit larger messages between applications on the same computer. However, because this entry affects both incoming and outgoing messages, in order to send a larger message to other computers running Message Queuing, you must increase this value on all participating systems. If any system has a lower value, it might block all further transports from computers sending larger messages.

Activation method

Message Queuing checks this entry only at startup. If you change the value of this entry, you must restart Message Queuing to make the change effective.

Note Image Note

This entry affects Message Queuing only. It does not change characteristics of the network or network programs that might limit the size of messages.

Caution Image Caution

Do not change the value of this entry. Increasing this value might prevent you from sending messages larger than 4 MB. Decreasing this value might block all further transports between Message Queuing computers.


MaxRRThreads

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF | Message Queuing Client: 0x10 (16) Message Queuing Server: 0x40 (64)

Description

Determines the maximum number of threads created by the local queue manager (QM) to serve the remote read requests.

Note Image Note

This entry does not appear in the registry unless you add it or use a program to change its default value.

Related Entries

QMThreadNo


MaxSysQueue

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF queues | 0x4

Description

Determines the maximum number of private queues that can be allocated for Message Queuing internal use.

Caution Image Caution

Do not change the value of this entry. Changing this value can prevent Message Queuing from operating.


MaxUnackedPacket

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFFMessages | 0x40 (64 Messages)

Description

Determines the maximum size of the message queue to each network session. The value of this entry limits the number and size of messages that can be stored between internal acknowledgments from the receiving server. If the queue fills before an acknowledgment is received, additional messages are discarded.

If the queue is too small, messages might be lost. Alternatively, because messages in the queue are released again when a session fails, a large queue can flood the system with duplicate messages.

Note Image Note

This entry does not appear in the registry unless you add it or use a program to change its default value.


MessageID

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF | 0x40 (64)

Description

Stores the message identifier of the last message sent. This number is stored when Message Queuing stops and is used to restore the system when it restarts.

Caution Image Caution

Do not change the value of this entry. If you change it, you might cause Message Queuing to send duplicate messages.


Migration

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters\

Description

The Migration subkey stores entries that determine how Message Queuing data is propagated to clients running previous versions of the operating system. Entries in the Migration subkey are used only when there are MSMQ 1.0 MQIS servers running Windows NT 4.0 and earlier. They are not used when all servers are running Windows 2000.

Note Image Note

Message Queuing does not add this entry to the registry. You can add it by editing the registry or by using programs that edit the registry.


HelloInterval

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters\Migration

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF seconds | 0x4B0 (1200 seconds = 20 minutes)

Description

Determines how often a Message Queuing server sends "hello" messages to each client.

Note Image Note

Entries in the Migration subkey are used only when there are MSMQ 1.0 MQIS servers running Windows NT 4.0 and earlier. They are not used when all servers are running Windows 2000.

Message Queuing does not add this entry to the registry. You can add it by editing the registry or by using programs that edit the registry.

Tip Image Tip

The length of the replication interval is a multiple of the length of the hello-message interval. The multiplier that determines the length of the replication interval is stored in the value of TimesHelloForReplicationInterval.

Related Entries

TimesHelloForReplicationInterval


PSCAckFrequencySN

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters\Migration

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF | 0x100 (256)

Description

Determines how often MQIS on the primary site controller (PSC) sends ACK (acknowledgment) messages. ACK messages are sent repeatedly until the intended recipient acknowledges its receipt.

The interval between acknowledgment messages is based on the number of changes to the Active Directory on the master domain. The value of this entry specifies the number of changes that must occur between ACK messages.

Note Image Note

Entries in the Migration subkey are used only when there are MSMQ 1.0 MQIS servers running Windows NT 4.0 and earlier. They are not used when all servers are running Windows 2000.

Message Queuing does not add this entry to the registry. You can add it by editing the registry or by using programs that edit the registry.


PurgeBuffer

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters\Migration

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF | 0x400 (1024)

Description

Specifies the number of recently deleted objects that cannot yet be permanently erased.

When objects are deleted, they remain in the Active Directory until they are erased permanently. Message Queuing creates a buffer zone of recently deleted objects that cannot be erased. If an object is deleted accidentally, you can retrieve it if it is still in the buffer zone. The value of this entry determines the number of recently deleted objects in the buffer zone.

Note Image Note

Entries in the Migration subkey are used only when there are MSMQ 1.0 MQIS servers running Windows NT 4.0 and earlier. They are not used when all servers are running Windows 2000.

Message Queuing does not add this entry to the registry. You can add it by editing the registry or by using programs that edit the registry.


ReplMsgTimeout

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters\Migration

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF seconds | 0x4B0 (1200 seconds = 20 minutes)

Description

Determines how long replication messages can remain in the Active Directory before they are deleted.

Note Image Note

Entries in the Migration subkey are used only when there are MSMQ 1.0 MQIS servers running Windows NT 4.0 and earlier. They are not used when all servers are running Windows 2000.

Message Queuing does not add this entry to the registry. You can add it by editing the registry or by using programs that edit the registry.


ReplThreads

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters\Migration

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF | 0x4

Description

Specifies the number of threads Message Queuing allocates for answering replication and sync messages from servers running Windows NT 4.0.

Note Image Note

Entries in the Migration subkey are used only when there are MSMQ 1.0 MQIS servers running Windows NT 4.0 and earlier. They are not used when all servers are running Windows 2000.

Message Queuing does not add this entry to the registry. You can add it by editing the registry or by using programs that edit the registry.


TimesHelloForReplicationInterval

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters\Migration

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF | 0xFFFFFFFF

Description

Determines how often Message Queuing sends replication messages.

The interval between replication messages is based on the length of the interval between "hello" messages, as determined by the value of HelloInterval. The replication interval is expressed as the number of hello-message intervals. The value of this entry specifies the number of hello-message intervals that must elapse between replication messages.

For example, if the value of HelloInterval is 60 seconds, and the value of TimesHelloForReplicationInterval is 60, then the interval between replication messages is one hour (60 * 60 seconds).

Note Image Note

Entries in the Migration subkey are used only when there are MSMQ 1.0 MQIS servers running Windows NT 4.0 and earlier. They are not used when all servers are running Windows 2000.

Message Queuing does not add this entry to the registry. You can add it by editing the registry or by using programs that edit the registry.

Related Entries

HelloInterval


MinRRThreads

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF | Windows 2000 Workstation: 4 Windows 2000 Server: 16

Description

Determines the minimum number of threads the local queue manager (QM) keeps alive, even when the thread's idle time is greater than the value of the RRThreadIdleTTL entry.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

RRThreadIdleTTL


mqisConnectionNumber

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF | 1

Description

Determines the maximum number of connections to the local SQL database that Message Queuing permits.

Increasing the value of this entry can improve database access significantly. However, you must limit user connections to the number specified in your SQL client license.

Change method

To change the value of this entry, double-click MS Message Queue in Control Panel, and then click the Server tab.


mqisdb

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_SZ | Connection name | mqis

Description

Specifies the name of the open database connectivity (ODBC) connection to the local SQL database.

Note Image Note

This entry is used only when it appears in the registry of a Message Queuing MQIS server.

This entry does not appear in the registry unless you add it or use a program to change its default value.


MsmqIpPingPort

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF (port number) | 0xDC7 (3527)

Description

Determines the UDP port that Message Queuing uses to "ping" servers. Message Queuing uses an internal "ping" algorithm to quickly determine the availability and configuration of a server.

Note Image Note

This entry does not appear in the registry unless you add it or use a program to change its default value.

This entry is used only when the value of UsePing is 1.

Caution Image Caution

This value must be the same on all computers in the enterprise. Using different UPD ports can significantly increase the time it takes for Message Queuing to establish network connections.

Related Entries

MsmqIpxPingPort


MsmqIpPort

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF (port number) | 0x709 (1801)

Description

Determines the TCP port that Message Queuing uses to connect queue managers.

Note Image Note

This entry does not appear in the registry unless you add it or use a program to change its default value.

Caution Image Caution

Do not change the value of this entry. Changing this value can prevent Message Queuing computers from exchanging messages.


MsmqIpxPingPort

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF )port number) | 0xDC7 (3527)

Description

Determines the IPX port that Message Queuing uses to "ping" servers. Message Queuing uses an internal "ping" algorithm to quickly determine the availability and configuration of a server.

Note Image Note

This entry is used only when the value of UsePing is 1.

This entry does not appear in the registry unless you add it or use a program to change its default value.

Caution Image Caution

This value must be the same on all computers in the enterprise. Using different IPX ports can significantly increase the time it takes for Message Queuing to establish network connections.

Related Entries

MsmqIpPingPort


MsmqIpxPort

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF (port number) | 0x36C (876)

Description

Determines the SPX port that Message Queuing uses to connect queue managers which are running IPX.

Note Image Note

This entry does not appear in the registry unless you add it or use a program to change its default value.


OCMsetup

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters\

Description

The OCMsetupSubkey subkey of the MSMQ\Parameters subkey stores information about the installation and configuration of Message Queuing when it is set up by using the Optional Components Manager setup.

Caution Image Caution

These values are stored by Message Queuing for internal use. Do not add or change any entries or values in this subkey.


Directory

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters\OCMsetup

Data type | Range | Default value
REG_SZ | Path and directory name | There is no default value for this entry.

Description

Stores the location of the directory where Message Queuing is installed/

Caution Image Caution

Do not change the value of this entry. Changing the value can prevent the Setup program from successfully installing, upgrading, or uninstalling Message Queuing.


InstalledComponents

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters\OCMsetup

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF | There is no default value for this entry.

Description

Records the Message Queuing components that were installed on this computer.

Caution Image Caution

Do not change the value of this entry. Changing the value can prevent the Setup program from successfully installing, upgrading, or uninstalling Message Queuing.


NonServiceInstalled

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters\OCMsetup

Data type | Range | Default value
REG_DWORD | 0 | 1 | There is no default value for this entry.

Description

Indicates whether the hypertext markup language (HTML) version of the Message Queuing documentation is installed.

Value | Meaning
0 | The HTML version of the Message Queuing documentation is not installed.
1 | The HTML version of the Message Queuing documentation is installed.

Caution Image Caution

Do not change the value of this entry. Changing the value can prevent the Setup program from successfully installing, upgrading, or uninstalling Message Queuing.


ShortcutCount

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters\OCMsetup

Description

Records the number of shortcuts installed by OCM Setup.

Caution Image Caution

Do not change the value of this entry. Changing the value can prevent the Setup program from successfully installing, upgrading, or uninstalling Message Queuing.


ShortcutDirectory

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters\OCMsetup

Description

Records the location of the directory where Message Queuing shortcuts are installed

Caution Image Caution

Do not change the value of this entry. Changing the value can prevent the Setup program from successfully installing, upgrading, or uninstalling Message Queuing.


PerThreadDSServer

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Enables applications to work with a different directory service server for each thread.

The default value for the PerThreadDSServer entry allows all threads to work with the same directory service server, and if one thread changes the directory service, it affects the others. In Windows 2000, some operations might require access to a specific directory service server. Enabling this mode guarantees that the directory service activity of the other threads will not change the server. This is relevant only in Message Queuing mixed mode, when some of the servers in the site are running MSMQ 1.0 and some are running Message Queuing.

Value | Meaning
0 | All threads access the same directory service server.
1 | All threads can access a different directory service server.


QmPbKeyCacheSize

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF keys | 0x35 (53 keys)

Description

Determines the maximum number of keys that can be stored in the queue manager (QM) public encryption key cache. This cache stores public encryption keys recently used in replication and notification messages.

If the cache is full (that is, the number of keys is equal to the value of QmPbKeyCacheSize), when the next key arrives, Message Queuing deletes half of the keys in the cache. The oldest keys are deleted first.

All replication and notification messages are digitally signed by the MQIS that generated the message. The Message Queuing computers that receive the message validate its signature by using the public key of the sending MQIS. Storing recently used keys in a cache reduces the time it takes to verify the signature.

Note Image Note

Entries in the public encryption key cache are not subject to an expiration time. These entries are deleted only when the cache is full.

This entry does not appear in the registry unless you add it or use a program to change its default value.


QMThreadNo

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0x1 - 0x10 threads | Windows 2000 Server:Number of processors *5+3 Windows 2000 Professional:Number of processors*3

Description

Determines the number of threads created in the Message Queuing process (Mqsvc.exe) to handle messages.

Increasing the value of this entry can improve the performance of Message Queuing, but too many threads can overload the processor.

Note Image Note

This entry does not appear in the registry unless you add it or use a program to change its default value.

Related Entries

MaxRRThreads


RemoteQMMachine

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_SZ | Computer name | Computer name

Description

Specifies the name of the supporting server computer for the local Message Queuing dependent client. The supporting server routes messages to the client, transmits queries and responses, and updates the client’s view of the enterprise.

Change method

To change the value of this entry, in Control Panel, double-click MS Message Queue, and then click the MSMQ Client tab.

Note Image Note

This entry is used only when it appears in the registry of a Message Queuing client that is dependent on a parent server.


RemoveDuplicateCleanup

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF milliseconds | 0x1B7740 (30 minutes)

Description

Implements a simple removal mechanism for duplicate, non-transactional messages.

If a duplicate message is received within the time interval specified by the value of the RemoveDuplicateCleanup entry, the duplicate message is removed. Message Queuing keeps a record of a limited number of messages received (defined by the value of the RemoveDuplicateSize entry). Thus, if more RemoveDuplicateSize messages are received between the original message and the duplicate, the duplicate message will be accepted by the queue manager (QM).

When Message Queuing is stopped and then restarted, the time elapsed since the message was received is set to zero for all recoverable messages, while the records of non-recoverable messages are lost.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


RMFlushInterval

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF milliseconds | 0x1B7740 (1,800,000 millseconds = 30 minutes)

Description

Determines how often Message Queuing takes a checkpoint of Resource Manager transactions. The checkpoint saves the current transactions and exactly-once-delivery state of Message Queuing.

The value of this entry is used when no checkpoints have been taken in the Resource Manager as a result of other events, such as when its log file is more than half full. It guarantees that a checkpoint is performed no less frequently than the time specified.

If this value is too large, it might prolong the time it takes to recover files to their last checkpoint. If the value is too small, frequent checkpoints can degrade Message Queuing performance.

Note Image Note

This entry does not appear in the registry unless you add it or use a program to change its default value.

Caution Image Caution

Do not change the value of this entry. An inappropriate value can interfere with logging, transactions, and the exactly-once delivery mechanism.


RpcCancelTimeout

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF minutes | 0x5

Description

Determines how long a Message Queuing client waits after submitting a request before it notifies the user that the MQIS server has not responded. This entry appears only in the registries of Message Queuing client computers.

Note Image Note

This entry does not appear in the registry unless you add it or use a program to change its default value.

This entry is used only when it appears in the registry of a Message Queuing client computer.


RRThreadIdleTTL

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF milliseconds | Windows 2000 Professional: 2 minutes Windows 2000 Server: 5 minutes

Description

Indicates the maximum time that a thread, created to serve remote-read requests, can be idle before the thread is closed by the local queue manager (QM).

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


Security

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters\

Description

The Security subkey contains subkeys that contain information about the computer account and about whether server authentication is used (secured communication between client and server).

Note Image Note

The entries in the subkeys under the HKLM\SOFTWARE\Microsoft\MSMQ\Parameters\CertificationAuthorities subkeys store actual certification authority (CA) certificates, not just pointers to entries in another location.

Caution Image Caution

Do not change the values of entries in this subkey by editing the registry. Changing these values can disable the security features of Message Queuing.


RcvOnlyEnhMsgAuthn

HKLM\Software\Microsoft\MSMQ\Parameters\Security

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether the receiver will accept both MSMQ 1.0 and Message Queuing signatures, or only Message Queuing.

Message Queuing can use two different signatures to authenticate messages: MSMQ 1.0 signatures and Message Queuing signatures. By default, the receiving computer will accept either type of signature.

Value | Meaning
0 | Use MSMQ 1.0 and Message Queuing signatures
1 | Use only Message Queuing signatures


SendMsgAuthn

HKLM\Software\Microsoft\MSMQ\Parameters\Security

Data type | Range | Default value
REG_DWORD | 1 | 2 | 4 | 2

Description

Determines the authentication to be used to sign the authenticate message.

Message Queuing can use two different signatures when sending authenticate messages: MSMQ 1.0 signatures and Message Queuing signatures. By default, Message Queuing will only use MSMQ 1.0 signatures. When the PROPID_M_AUTH_LEVEL property of a message is set to MQMSG_AUTH_LEVEL_ALWAYS, the value of this registry entry determines what authentication will be used to sign the authenticate message.

Value | Meaning
1 | MSMQ 1.0 and Message Queuing signatures
2 | MSMQ 1.0 signatures only
4 | Message Queuing signatures only


ServerCertDigest

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters\Security

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF | There is no default value for this entry.

Description

Determines which server certificate is used if the certificate store contains several certificates. Message Queuing will use only the certificate whose hash (digest) matches this value.

The value of this entry is set when the user registers a server certificate through Control Panel. The ServerCertDigest entry is used only on a Message Queuing server that runs on a Windows 2000 domain controller.


ServerCertStore

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters\Security

Data type | Range | Default value
REG_SZ | string | There is no default value for this entry.

Description

Specifies the name of the machine certificate store where the server certificate for the local server is stored.

This entry is used only on a Message Queuing server that runs on a Windows 2000 domain controller. The server certificate is used for the Secured Communication feature, where Message Queuing clients can verify that they query an authentic Message Queuing server.

The value of this entry is set when the user registers a server certificate through Control Panel. The value is read by Message Queuing the first time a client wants to authenticate the server.


SeqIDAtLastRestore

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF | There is no default value for this entry.

Description

Records the value of the last assigned sequence ID at the time of the last restore in the registry.

This entry is used to distinguish between restored messages and those messages sent after the restore. This entry is necessary to guarantee the exactly once delivery of transactional messages when the backup/restore utility is used. Do not edit this value.


SeqMaxAckDelay

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFE seconds | 0xA (10 seconds)

Description

Defines the length of delay in sending acknowledgements for transacted messages.

Message Queuing sends an order acknowledgment for the delivered, transacted messages. The value of this entry defines the delay in sending these messages; the receiving computer never sends an order acknowledgment more frequently than once per this number of seconds.

The SeqMaxAckDelay entry provides for batching of messages, which saves unnecessary traffic. Too large a value might cause resending of the messages because the sending computer might think the packets did not arrive. Too small a value might cause more order-acknowledgment packets to be sent.


SeqResend10Time

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF seconds | 0x5460 (21,600 seconds = 6 hours)

Description

Determines how often outgoing, transacted messages are resent because they are unacknowledged.

The value of this entry specifies the interval between resends for the tenth and subsequent resend attempts. If the sender still does not receive an acknowledgement from the intended recipient, the message is resent at the rate specified by this value until it times out.

The interval between earlier resends is determined by the values of the following entries: SeqResend13Time, SeqResend46Time, SeqResend79Time.

Note Image Note

This entry does not appear in the registry unless you add it or use a program to change its default value.

Caution Image Caution

Do not change the value of this entry. An inappropriate value can interfere with message delivery.


SeqResend13Time

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF seconds | 0x1E (30)

Description

Determines how often outgoing, transacted messages are resent because they are unacknowledged.

The value of this entry specifies the interval between resends for the first three times the message is resent. If, after the third resend, the sender still does not receive an acknowledgement from the intended recipient, the message is resent at intervals determined by the values of the following entries: SeqResend46Time, SeqResend79Time, SeqResend10Time

Note Image Note

This entry does not appear in the registry unless you add it or use a program to change its default value.

Caution Image Caution

Do not change the value of this entry. An inappropriate value can interfere with message delivery.


SeqResend46Time

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF seconds | 0x12C (300 seconds = 5 minutes)

Description

Determines how often outgoing, transacted messages are resent because they are unacknowledged.

The value of this entry specifies the interval between resends for the fourth, fifth, and sixth times the message is resent. If, after the sixth resend, the sender still does not receive an acknowledgment from the intended recipient, the interval between acknowledgments is determined by the values of the following entries: SeqResend79Time, SeqResend10Time. The interval between the first three resends is determined by the value of SeqResend13Time.

Note Image Note

This entry does not appear in the registry unless you add it or use a program to change its default value.

Caution Image Caution

Do not change the value of this entry. An inappropriate value can interfere with message delivery.


SeqResend79Time

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF seconds | 0x708 (1800 seconds = 30 minutes)

Description

Determines how often outgoing, transacted messages are resent because they are unacknowledged.

The value of this entry specifies the interval between resends for the seventh, eighth, and ninth times the message is resent. If, after the ninth resend, the sender still does not receive an acknowledgment from the intended recipient, the interval between acknowledgments is determined by the value of SeqResend10Time.

The interval between earlier resends is determined by the values of the following entries: SeqResend13Time, SeqResend46Time.

Note Image Note

This entry does not appear in the registry unless you add it or use a program to change its default value.

Caution Image Caution

Do not change the value of this entry. An inappropriate value can interfere with message delivery.


ServersCache

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters\

Description

The ServersCache subkey of the MSMQ\Parameters subkey stores information pertaining to Message Queuing about each site in the enterprise. ServersCache contains a separate entry for each site in the enterprise. The entry is the name of the site, and its value consists of a list of all the MQIS servers in the site. These values are updated at an interval specified by the value of the DSListRefresh entry.

Each of the entries in the ServersCache subkey represents a site and stores the computer names and supported protocols of all Message Queuing servers at the site. These entries have the following format:
Site name REG_SZ 01 | 10 | 11 NumberComputer name[,NumberComputer name,NumberComputer name]

Each computer name is preceded by a number (01, 10, or 11), which indicates the communication protocols supported by each server. If the site includes multiple servers, the entries must be separated by commas.

  • A value of 1 in the lowest (right) digit indicates that the server supports the IPX protocol.
  • A value of 1 in the second (left) digit indicates that the server supports the IP protocol.

For example,
Central REG_SZ 11ServerOne,10ServerTwo,01ServerThree
indicates that at the Central site, there are three computers running Message Queuing: \\ServerOne supports both IP and IPX, \\ServerTwo supports only IP, and \\ServerThree supports only IPX.


Setup

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters\

Description

The Setup subkey stores entries that contain information about the operating system installed, the name of the computer, name of the local domain, and the name of the local organizational unit (OU).

Note Image Note

The entries in the subkeys under CertificationAuthorities store actual certification authority (CA) certificates, not just pointers to entries in another location.


AlwaysWithoutDS

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters\Setup

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Directs Message Queuing to remain in workgroup mode.

Value | Meaning
0 | Message Queuing will try to join Message Queuing Enterprise on the domain when the computer is moved from workgroup to domain.
1 | Message Queuing must remain in the workgroup mode, even if the computer later joins a domain.


JoinStatus

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters\Setup

Data type | Range | Default value
REG_DWORD | 0x1 - 0x4 | There is no default value for this entry.

Description

Implements transactional semantics for the join process, so that if a computer stops abnormally, the join process continues after Windows 2000 restarts.

Message Queuing adds this entry to the registry when Message Queuing detects that a computer joined a domain.

Value | Meaning
1 | MSMQ_JOIN_STATUS_START_JOINING.
2 | MSMQ_JOIN_STATUS_JOINED_SUCCESSFULLY.
3 | MSMQ_JOIN_STATUS_FAIL_TO_JOIN.
4 | MSMQ_JOIN_STATUS_UNKNOWN.


MachineDN

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters\Setup

Data type | Range | Default value
REG_SZ | String | There is no default value for this entry.

Description

Describes the local computer in the Active Directory.

The value of the MachineDN entry is the distinguished name of the computer object and is used when the computer moves between domains to check if the Message Queuing configuration object is still in its old place. This entry is updated on every restart.


MachineDomain

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters\Setup

Data type | Range | Default value
REG_SZ | String | There is no default value for this entry.

Description

Enables the user to check if the computer has moved between domains.

The MachineDomain entry is the NetBIOS name of the domain that owns the computer object. This entry is not erased when you move your computer from a domain to a workgroup.


MQISServersForJoin

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters\Setup

Data type | Range | Default value
REG_SZ | Computer Names | There is no default value for this entry.

Description

Stores the list of MQIS servers when a computer leaves the Windows 2000 domain and joins a workgroup.

When a computer running Message Queuing leaves the Windows 2000 domain and joins a workgroup, the list of MQIS servers is copied from MQISServer and then stored in this entry. When the computer rejoins the Windows 2000 domain, the list is copied back to MQISServer.


StoreAckTimeout

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF milliseconds | This entry does not appear in the registry.

Description

Determines how long Message Queuing waits for internal message acknowledgement of persistent messages on a network session before deciding that the session should be closed.

By default, Message Queuing calculates an optimal acknowledgment timeout based on the quality of the communication line. However, you can add this entry to the registry and then set it to a different value to override the result of the calculation.

Caution Image Caution

Adding this entry to the registry prevents the system from using an optimal value calculated for each line. If you set the value of this entry too low, sessions can be disconnected before any messages are delivered.


StoreInSeqLogPath

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_SZ | Path and directory name | Installation path\MSMQ\Storage

Description

Specifies the directory where Message Queuing stores exactly-once-delivery checkpoint files.

Change method

To view or change the value of this entry, in Control Panel, double-click Message Queuing. The directory where the transaction log and all checkpoint files are stored appears in the Transaction Logger Folder box.

Note Image Note

Message Queuing stores all checkpoint files in the same directory as transaction log file (QM Log). If you use Message Queuing in Control Panel to change the value in the Transaction Logger Folder box, Message Queuing moves all checkpoint files and the transaction log to the new location.

This entry does not appear in the registry unless you add it or use a program to change its default value.

Related Entries

StoreMqLogPath

StoreXactLogPath


StoreJournalPath

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_SZ | Path and directory name | Installation path\MSMQ\Storage

Description

Specifies the directory in which Message Queuing stores journal message files. Journal messages are copies of incoming or outgoing messages processed by a server.

Change method

To change the value of this entry, in Control Panel, double-click Message Queuing, and then click the Messages tab.


StoreLogPath

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_SZ | Path and directory name | Installation path\MSMQ\Storage

Description

Specifies the directory in which Message Queuing stores the log files associated with persistent message files.

Change method

To change the value of this entry, in Control Panel, double-click Message Queuing, and then click the Messages tab.


StoreMqLogPath

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_SZ | Path and directory name | Installation path\MSMQ\Storage

Description

Specifies the directory where Message Queuing stores the transaction log file, also known as the QM log. Message Queuing stores the current state of active transactions and incoming transacted messages in the transaction log file.

Change method

To view or change the value of this entry, in Control Panel, double-click Message Queuing. The directory where the transaction log and all checkpoint files are stored appears in the Transaction Logger Folder box.

Note Image Note

Message Queuing stores all checkpoint files in the same directory as transaction log file (QM Log). If you use Message Queuing in Control Panel to change the value in the Transaction Logger Folder box, Message Queuing moves all checkpoint files and the transaction log to the new location.

Related Entries

StoreInSeqLogPath

StoreXactLogPath


StorePersistentPath

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_SZ | Path and directory name | Installation path\MSMQ\Storage

Description

Specifies the directory in which Message Queuing stores persistent message files.

Change method

To change the value of this entry, in Control Panel, double-click Message Queuing, and then click the Messages tab.


StoreReliablePath

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_SZ | Path and directory name | Installation path\MSMQ\Storage

Description

Specifies the directory in which Message Queuing stores express message files.

Change method

To change the value of this entry, in Control Panel, double-click Message Queuing, and then click the Messages tab.


StoreXactLogPath

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_SZ | Path and directory name | Installation path\MSMQ\Storage

Description

Specifies the directory where Message Queuing stores transaction checkpoint files.

Change method

To view or change the value of this entry, in Control Panel, double-click Message Queuing. The directory where the transaction log and all checkpoint files are stored appears in the Transaction Logger Folder box.

Note Image Note

Message Queuing stores all checkpoint files in the same directory as transaction log file (QM Log). If you use Message Queuing in Control Panel to change the value in the Transaction Logger Folder box, Message Queuing moves all checkpoint files and the transaction log to the new location.

Related Entries

StoreInSeqLogPath

StoreMqLogPath


SysQueuePriority

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF | 0x7FFF (32,767)

Description

Specifies the base priority of messages destined for system queues.

Note Image Note

This entry does not appear in the registry unless you add it or use a program to change its default value.

Caution Image Caution

Do not reduce the value of this entry. Permitting lower-priority messages to be sent to queues might delay messages with higher priority, including system messages.


TCPNoDelay

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Disables nagling. Nagling is a TCP feature that combines several small packets into a single, larger packet for more efficient transmission.

By default, Message Queuing enables nagling on the TCP sockets it uses. This improves overall performance, but it might briefly delay transmission of smaller packets. You can add this entry to the registry to disable nagling if the delay is undesirable or unacceptable.

Value | Meaning
0 | Nagling is enabled.
1 | Nagling is disabled.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


TransactionMode

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_SZ | DefaultCommit | (blank) | DefaultCommit

Description

Uses the default-abort mode to process transactions.

For performance reasons, the mode has been changed to default-commit in Message Queuing. When the value of this entry is blank, the service uses the previous default-abort mode. When the value of this entry contains DefaultCommit, the service uses the new default-commit mode. The normal upgrade from Windows NT 4.0 sets the value of this entry to DefaultCommit.


UsePing

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Directs Message Queuing to use an internal "ping" algorithm to determine the availability and configuration of a server. Using a "ping", the service can find this information quickly.

Value | Meaning
0 | Message Queuing will not use the ping algorithm.
1 | Message Queuing will use the ping algorithm.

Note Image Note

This entry does not appear in the registry unless you add it or use a program to change its default value.

Related Entries

MsmqIpxPingPort

MsmqIpPingPort


UserCacheExpirationTime

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF milliseconds | Message Queuing clients: 0x1B7740 (1,800,000 milliseconds = 30 minutes) Message Queuing servers: 0x5265C0 (5,400,000 milliseconds = 90 minutes)

Description

Determines how long user account information is stored in the user cache before being deleted.

Note Image Note

This entry does not appear in the registry unless you add it or use a program to change its default value.

Related Entries

UserCacheSize


UserCacheSize

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF entries | 0xFD (253 entries)

Description

Determines the maximum number of entries that can be stored in the user account information cache. This cache stores information about users who recently sent messages to the computer.

When Message Queuing receives a message, it uses user account information to verify that the sending user has permission to send messages to the particular queue. Storing user account information in the cache reduces the time it takes to verify user permissions.

I the cache is full (that is, the number of entries is equal to the value of UserCacheSize) when the next entry arrives, Message Queuing deletes half of the entries in the cache. The oldest entries are deleted first.

Note Image Note

This entry does not appear in the registry unless you add it or use a program to change its default value.

Related Entries

UserCacheExpirationTime


WaitTime

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Description

Determines how often a Queue Manager attempts to access the Message Queuing directory service and/or perform name resolution in order to deliver an outgoing message. This entry specifies the elapsed time between successive attempts. The queue manager continues its attempts until it is successful.

By default, a Queue Manager waits 60 seconds between the first and second attempts. Thereafter, the time between attempts increases in 30–second intervals until it reaches five minutes (300 seconds). Subsequent attempts occur at five–minute intervals. However, if you change the value of this entry, the value you enter determines the elapsed time between all attempts and does not vary.

Consider adding this entry to the registry and increasing its value if computer names and addresses change frequently. You might also want to increase its value if messages are submitted offline using a format name which requires access to the Message Queuing directory service (PUBLIC or PRIVATE formats) or name resolution (DIRECT format with UNC or DNS machine name).

High values (less frequent attempts) reduce the number of trials and minimize the time Message Queuing takes to send the message after the destination computer reconnects to the network. Low values (more frequent attempts) can occupy the Queue Manager with repeated, futile attempts to find the destination computer.

Note Image Note

This entry does not appear in the registry unless you add it or use a program to change its default value.


Workgroup

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Indicates that Message Queuing does not have access to Active Directory.

Message Queuing is is designed to store and retrieve information from Active Directory. Message Queuing adds this entry to the registry with a value of 1 when the system does not have access to Active Directory. Programs can use this entry to optimize their functions by avoiding procedures that require Active Directory.

Value | Meaning
0 | Message Queuing has access to Active Directory.
1 | Message Queuing does not have access to Active Directory.

The system sets this value to 1 when Message Queuing is installed in one of the following configurations:

  • Message Queuing is installed on a computer that belongs to a workgroup.
  • Message Queuing is installed on a computer that belongs to a domain, but it does not have access to Active Directory. (The No access to DS option is specified in the setup instructions.)
  • Message Queuing is first installed on a computer in a workgroup, and then later, when the computer joins a Windows 2000 domain, but the Message Queuing service does not join the Message Queuing deployment in the domain.

Note Image Note

This entry appears in the registry only when Message Queuing does not have access to Active Directory (a value of 1) or, it has access now, but it did not have access in the past (a value of 0).

If Message Queuing gains access to Active Directory (such as when the computer joins a domain), Message Queuing detects the change and changes the value of this entry to 0. No manual changes are required.

Caution Image Caution

Do not change the value of this entry. This entry merely records the current condition. You cannot use this entry to deny or provide access to a domain or to Active Directory. If you change the value of this entry, Message Queuing will not operate properly.


WriteMsgTimeout

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF seconds | 10

Description

Determines how long write-request messages are active. When the value of this entry expires, the write-request message is deleted.

Note Image Note

This entry is used only when it appears in the registry of a Message Queuing MQIS server.

This entry does not appear in the registry unless you add it or use a program to change its default value.


XactDeadLetterAlways

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Places timed-out or undeliverable messages in the XactDeadLetter queue.

In MSMQ 1.0, timed-out or undeliverable transactional messages were placed in the XactDeadLetter queue by default. In Windows 2000, the messages are placed in the XactDeadLetter queue only if the MSMQ_DEADLETTER property is selected.

Setting the value of this entry to 1 forces the local Message Queuing service to revert to MSMQ 1.0 behavior. Use this entry when the change in default behavior might break the existing application.

Value | Meaning
0 | Messages are placed in the XactDead Letter queue only if the message property (MSMQ_DEADLETTER) was set on the message.
1 | Messages are placed in the XactDeadLetter queue.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


XactDelayReceiveNack

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFE seconds | There is no default value for this entry.

Description

Specifies an additional delay for timing out non-received transactional messages sent from this computer.

Message Queuing will wait an additional amount of time, equal to the value of the XactDelayReceiveNack entry, after the Time-To-Be-Received has expired and before placing the message in the XactDeadLetterQueue. The purpose of this delay is to allow positive receive acknowledgments (sent shortly before the TTBR expires) to reach the sender. If this value is not explicitly set in the registry, the value of XactDelayReciveNack will be automatically set to the smallest of the Time-To-Be-Received and Time-To-Reach-Queue properties of the message.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


OS/2 Subsystem for NT

HKLM\SOFTWARE\Microsoft\

Description

The OS/2 Subsystem for NT subkey stores basic software information for the Microsoft OS/2 version 1.x subsystem. The OS/2 Subsystem for NT subkey contains several subkeys but, by default, only the config.sys subkey contains an entry. When an OS/2 program has been run on the system, the config.sys subkey contains configuration information for OS/2. Until then, this subkey contains a single entry that serves as a placeholder.


1.0

HKLM\SOFTWARE\Microsoft\OS/2 Subsystem for NT\

Description

The 1.0 subkey stores basic software information for the Microsoft OS/2 version 1.x subsystem. This subkey contains several subkeys but, by default, only the config.sys subkey contains an entry.


config.sys

HKLM\SOFTWARE\Microsoft\OS/2 Subsystem for NT\1.0\

Data type | Range | Default value
REG_MULTI_SZ | Configuration data | Configuration data

Description

This entry appears in the config.sys subkey until an OS/2 program is run on Windows 2000.

Related Entries

Os2LibPath


PswdSync

HKLM\SOFTWARE\Microsoft\

Description

The PswdSync subkey stores configuration data for the Password Synchronization Service. The Password Synchronization Service lets users use a single password for computers running Windows 2000 computers and UNIX. It assures that any password changes made on Windows 2000 are communicated to the UNIX pod, either in clear or encrypted text. It also assures that all passwords conform to the security standards implemented on the system by notification packages, such as Passfilt.dll.

The PswdSync subkey contains two subkeys, Domains and NotifyChange. The Domains subkey contains <pod-name> subkeys, each of which represents a UNIX pod and stores data that applies to only to the pod. The NotifyChange subkey is used internally by the Password Synchronization Service to detect and implement configuration changes while the service is running. Do not delete or change it.

The PswdSync subkey also can contain entries. The entries in PswdSync apply to all UNIX pods. These entries can also appear in the PswdSync\Domains\<pod-name> subkeys where they apply only to the specified pod. If the same entry appears in the PswdSync subkey and in a <pod-name> subkey, the value in the <pod-name> subkey takes precedence over the value in PswdSync when configuring that pod.

Change method

To change the value of entries in this subkey, use the Password Synchronization Administrator. Do not edit the registry.

Note Image Note

The Pswdsync subkey appears in the registry when you configure the Password Synchronization Service (by using the Password Synchronization Administrator) and then restart Windows 2000.


Domains

HKLM\SOFTWARE\Microsoft\PswdSync\

Description

The Domains subkey stores configuration data for the UNIX pods associated with the Windows 2000 Password Synchronization Service. The Password Synchronization Service lets users use a single password for computers running Windows 2000 and UNIX.

The Domains subkey contains <pod-name> subkeys, each of which represents a UNIX pod and stores data that applies only to the pod.

Change method

To change the value of entries in this subkey, use the Password Synchronization Administrator. Do not edit the registry.

Note Image Note

This subkey appears in the registry when you use the Password Synchronization Administrator to configure a UNIX pod.


<pod-name>

HKLM\SOFTWARE\Microsoft\PswdSync\Domains\

Description

The Domains subkey contains a subkey for each of the UNIX pods associated with this Windows 2000 server. The subkeys in Domains are named for the pod and store entries that apply only to the pod.

The entries listed under <pod-name> can appear in any <pod-name> subkey. Some of the entries can also appear in the PswdSync subkey. However, when they appear in PswdSync, their values apply to all pods. When the same entry appears in PswdSync and in a <pod-name> subkey, the value in the <pod-name> subkey takes precedence over the value in the PswdSync subkey when configuring the named pod.

Change method

To change the value of entries in this subkey, use the Password Synchronization Administrator. Do not edit the registry.

Note Image Note

This subkey appears in the registry when you use the Password Synchronization Administrator to configure a UNIX pod.

The <Pod-name> subkey is a variable representing the subkeys in the Domains subkeys. It doesn't actually appear in the registry. This variable subkey displays the entries that can appear in any of the Domains subkeys. The entries that actually appear in your registry depend upon the configuration of the pod.


Hosts

HKLM\SOFTWARE\Microsoft\PswdSync\Domains\<pod-name>

Data type | Range | Default value
REG_MULTI_SZ | List of IP addresses or DNS host names (one per line) | (Determined when pod is created.)

Description

An ordered list of UNIX hosts that comprise the UNIX pod for this server. This entry determines the composition of the pod. When you create a pod, the Password Synchronization Administrator requires that you add at least one host to the pod.

The order of hosts in this entry also determines the order in which this Windows 2000 server contacts the hosts when it updates a password. If the first host contacted receives the password update successfully, that host propagates the update to other hosts in the pod. Other hosts are contacted (in the order specified) only if the first host does not receive the update.

Change method

To change the value of this entry, use the Password Synchronization Administrator. Do not edit the registry.

Note Image Note

This subkey appears in the registry when you use the Password Synchronization Administrator to configure a UNIX pod.


Logging

HKLM\SOFTWARE\Microsoft\PswdSync\Domains\<pod-name>

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines which audit events are written to the System Log in Event Viewer.

This entry does not affect the recording of error events for the Password Synchronization Service. These events are recorded in the System Log regardless of the value of this entry.

Value | Meaning
0 | Record failure audit events only.
1 | Record success and failure audit events.

Change method

To change the value of this entry, use the Password Synchronization Administrator. Do not edit the registry.

Note Image Note

This entry can appear in the PswdSync subkey and in any <pod-name> subkey. When it appears in PswdSync, its value applies to all pods. When it appears in a <pod-name> subkey, its value applies only to that pod. When the entry appears in both subkeys, the value in the <pod-name> subkey takes precedence over the same value in the PswdSync subkey when configuring the named pod.

This entry appears in the registry when you use the Password Synchronization Administrator to configure a UNIX pod.

Related Entries

Logging (PswdSync subkey)


LoginAccount

HKLM\SOFTWARE\Microsoft\PswdSync\Domains\<pod-name>

Data type | Range | Default value
REG_SZ | Account-name | root

Description

Stores the account name used when using Rlogin to log on to a remote UNIX computer for the purpose of synchronizing passwords. Rlogin sends passwords in clear text.

This entry appears in the registry only when the Unsecure using Rlogin password propagation method is selected, that is, the value of PropagateMethod is 0.

Change method

To change the value of this entry, use the Password Synchronization Administrator. Do not edit the registry.

Note Image Note

This entry does not appear in the registry unless you use the Password Synchronization Administrator to change the default value.


LoginPrompt

HKLM\SOFTWARE\Microsoft\PswdSync\Domains\<pod-name>

Data type | Range | Default value
REG_SZ | String | # (a pound sign followed by a space)

Description

Stores the UNIX shell prompt that signals this Windows 2000 server to issue the password command.

This entry appears in the registry only when the Unsecure using Rlogin password propagation method is selected, that is, the value of PropagateMethod is 0.

Change method

To change the value of this entry, use the Password Synchronization Administrator. Do not edit the registry.

Note Image Note

This entry does not appear in the registry unless you use the Password Synchronization Administrator to change the default value.


Max Retries

HKLM\SOFTWARE\Microsoft\PswdSync\Domains\<pod-name>

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF | (The current value of Max Retries in the Pswdsync subkey, by default, 3.)

Description

Determines the maximum number of times the Password Synchronization Service repeats an attempt to update a password.

When an update attempt fails, the Password Synchronization Service repeats the update attempt (at a rate determined by the value of Update Retry Interval) until an attempt is successful or the number of attempts reaches the value of this entry.

When the number of unsuccessful attempts reaches this value, the Password Synchronization Service stops attempting to update the password data and records the following error (#2004) in the System Log in Event Viewer. Password Propagation failed for user <user-name> on Domain <pod-name>.

Change method

To change the value of this entry, use the Password Synchronization Administrator. Do not edit the registry.

Note Image Note

This entry can appear in the PswdSync subkey and in any <pod-name> subkey. When it appears in PswdSync, its value applies to all pods. When it appears in a <pod-name> subkey, its value applies only to that pod. When the entry appears in both subkeys, the value in the <pod-name> subkey takes precedence over the same value in the PswdSync subkey when configuring the named pod.

This entry appears in the registry when you use the Password Synchronization Administrator to configure a UNIX pod.

Related Entries

Update Retry Interval

Max Retries (PswdSync subkey)


PasswordCmd

HKLM\SOFTWARE\Microsoft\PswdSync\Domains\<pod-name>

Data type | Range | Default value
REG_SZ | String | passwd

Description

Stores the command used by Rlogin to change the password on a UNIX computer. The Password Synchronization Service uses Rlogin to update passwords when they are sent in clear text.

This entry appears in the registry only when passwords are sent in clear text, that is, when the Unsecure using Rlogin password propagation method is selected .

Change method

To change the value of this entry, use the Password Synchronization Administrator. Do not edit the registry.

Note Image Note

This entry does not appear in the registry unless you use the Password Synchronization Administrator to change the default value.


Port Number

HKLM\SOFTWARE\Microsoft\PswdSync\Domains\<pod-name>

Data type | Range | Default value
REG_DWORD | 0 - 65535 (decimal) | 6677

Description

Stores the number of the port used to connect this Windows 2000 computer to a UNIX host.

This entry appears in the registry only when the Secure using Encryption password propagation method is selected, that is, the value of PropagateMethod is 1.

Change method

To change the value of this entry, use the Password Synchronization Administrator. Do not edit the registry.

Note Image Note

This entry does not appear in the registry unless you use the Password Synchronization Administrator to change the default value.


Propagate Method

HKLM\SOFTWARE\Microsoft\PswdSync\Domains\<pod-name>

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines which password propagation method this Windows 2000 computer uses when it synchronizes passwords with a UNIX computer.

Value | Meaning
0 | The Unsecure using Rlogin method is used. Passwords are sent in clear text.
1 | The Secure using Encryption method is used. Passwords are encrypted before being sent.

Change method

To change the value of this entry, use the Password Synchronization Administrator. Do not edit the registry.

Note Image Note

This entry does not appear in the registry unless you use the Password Synchronization Administrator to change the default value.


PropAllowGroup

HKLM\SOFTWARE\Microsoft\PswdSync\Domains\<pod-name>

Data type | Range | Default value
REG_SZ | Windows NT user group | PasswordPropAllow

Description

Limits password synchronization to users in a specified user group.

When the name of a Windows 2000 user group defined in your system appears in the value of this entry, the service synchronizes passwords only for users in that group. This entry lets you limit password synchronization only to users who log on to UNIX computers regularly.

If the value of this entry does not contain the name of a existing user group and the default group, PasswordPropAllow, does not exist in your system, all of the system's users are considered to be clients and the service synchronizes all of their passwords. (If the system is running on a stand-alone computer, the service synchronizes the passwords of all local users. If the system is running on a domain controller, the service synchronizes the passwords of all users in the domain.)

Note Image Note

This entry does not appear in the registry unless you use the Password Synchronization Administrator to change the default value.

Tip Image Tip

If only a small subset of domain users need to have synchronized passwords, use PropAllowGroup, to identify that group of users. If all but a few users need to have synchronized passwords, use PropDenyGroup to identify the group of excluded users.

To create a Windows user group, use Active Directory Users and Computers.

Related Entries

PropDenyGroup


PropDenyGroup

HKLM\SOFTWARE\Microsoft\PswdSync\Domains\<pod-name>

Data type | Range | Default value
REG_SZ | Windows NT user group | PasswordPropDeny

Description

Excludes from password synchronization users in the group listed in this entry.

When the name of a valid Windows 2000 user group appears in this list, the service synchronizes passwords for all users except the members of that group. This entry lets you exclude from the service users who do not or should not log on to UNIX computers.

If the value of this entry does not contain the name of a existing user group and the default group, PasswordPropDeny, does not exist in your system, all of the system's users are considered to be clients and the service synchronizes all of their passwords. (If the system is running on a stand-alone computer, the service synchronizes the passwords of all local users. If the system is running on a domain controller, the service synchronizes the passwords of all users in the domain.)

Note Image Note

This entry does not appear in the registry unless you use the Password Synchronization Administrator to change the default value.

Tip Image Tip

If only a small subset of domain users need to have synchronized passwords, use PropAllowGroup, to identify that group of users. If all but a few users need to have synchronized passwords, use PropDenyGroup to identify the group of excluded users.

To create a Windows user group, use Active Directory Users and Computers.

Related Entries

PropAllowGroup


Update Retry Interval

HKLM\SOFTWARE\Microsoft\PswdSync\Domains\<pod-name>

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF seconds | (The current value of UpdateRetryInterval in the Pswdsync subkey, by default, 120)

Description

Determines how often the Password Synchronization Services resends update a password update. Password updates are resent only when an update attempt fails.

Change method

To change the value of this entry, use the Password Synchronization Administrator. Do not edit the registry.

Note Image Note

This entry can appear in the PswdSync subkey and in any <pod-name> subkey. When it appears in PswdSync, its value applies to all pods. When it appears in a <pod-name> subkey, its value applies only to that pod. When the entry appears in both subkeys, the value in the <pod-name> subkey takes precedence over the same value in the PswdSync subkey when configuring the named pod.

This entry appears in the registry when you use the Password Synchronization Administrator to configure a UNIX pod.

Related Entries

Max Retries

Update Retry Interval (PswdSync subkey)


Logging

HKLM\SOFTWARE\Microsoft\PswdSync

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines which audit events are written to the System Log in Event Viewer.

This entry does not affect the recording of error events for the Password Synchronization Service. These events are recorded in the System Log regardless of the value of this entry.

Value | Meaning
0 | Record failure audit events only.
1 | Record success and failure audit events.

Change method

To change the value of this entry, use the Password Synchronization Administrator. Do not edit the registry.

Note Image Note

This entry can appear in the PswdSync subkey and in any <pod-name> subkey. When it appears in PswdSync, its value applies to all pods. When it appears in a <pod-name> subkey, its value applies only to that pod. When the entry appears in both subkeys, the value in the <pod-name> subkey takes precedence over the same value in the PswdSync subkey when configuring the named pod.

This entry appears in the registry when you use the Password Synchronization Administrator to configure a UNIX pod.

Related Entries

Logging (<pod-name> subkey)


Max Retries

HKLM\SOFTWARE\Microsoft\PswdSync

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF | 3

Description

Determines the maximum number of times the Password Synchronization Service repeats an attempt to update a password.

When an update attempt fails, the Password Synchronization Service repeats the update attempt (at a rate determined by the value of Update Retry Interval) until an attempt is successful or the number of attempts reaches the value of this entry.

When the number of unsuccessful attempts reaches this value, the Password Synchronization Service stops attempting to update the password data and records the following error (#2004) in the System Log in Event Viewer. Password Propagation failed for user <user-name> on Domain <domain-name>.

Change method

To change the value of this entry, use the Password Synchronization Administrator. Do not edit the registry.

Note Image Note

This entry can appear in the PswdSync subkey and in any <pod-name> subkey. When it appears in PswdSync, its value applies to all pods. When it appears in a <pod-name> subkey, its value applies only to that pod. When the entry appears in both subkeys, the value in the <pod-name> subkey takes precedence over the same value in the PswdSync subkey when configuring the named pod.

This entry appears in the registry when you use the Password Synchronization Administrator to configure a UNIX pod.

Related Entries

Update Retry Interval

Max Retries (<pod-name> subkey)


NotifyChange

HKLM\SOFTWARE\Microsoft\PswdSync\

Description

This subkey is used internally by the Password Synchronization Service to detect and implement configuration changes while the service is running. Do not delete or change the contents of this subkey.

Note Image Note

This subkey appears in the registry when you configure the Password Synchronization Service (by using the Password Synchronization Administrator) and then restart Windows 2000.

Caution Image Caution

Do not delete this subkey or change its contents. If you do, you might lose all customized configuration of the Password Synchronization Service and disrupt its normal operation.


Update Retry Interval

HKLM\SOFTWARE\Microsoft\PswdSync

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF seconds | 120

Description

Determines how often the Password Synchronization Services resends update a password update. Password updates are resent only when an update attempt fails.

Change method

To change the value of this entry, use the Password Synchronization Administrator. Do not edit the registry.

Note Image Note

This entry can appear in the PswdSync subkey and in any <pod-name> subkey. When it appears in PswdSync, its value applies to all pods. When it appears in a <pod-name> subkey, its value applies only to that pod. When the entry appears in both subkeys, the value in the <pod-name> subkey takes precedence over the same value in the PswdSync subkey when configuring the named pod.

This entry appears in the registry when you use the Password Synchronization Administrator to configure a UNIX pod.

Related Entries

Max Retries

Update Retry Interval (<pod-name> subkey)


Windows

HKLM\SOFTWARE\Microsoft\

Description

The Windows subkey stores configuration data for the programs running on the Win32 subsystem. The subkeys of the Windows subkey represent versions of the Win32 subsystem, such as CurrentVersion. Each version subkey contains subkeys representing programs that run on that version of the subsystem.

The Windows subkey in HKEY_LOCAL_MACHINE stores entries that apply to all users of the computer. There is also a SOFTWARE\Microsoft\Windows subkey in HKEY_CURRENT_USER that stores entries that apply only to the current user of the computer.

Related Entries

Windows subkey (HKCU)


CurrentVersion

HKLM\SOFTWARE\Microsoft\Windows\

Description

The CurrentVersion subkey stores configuration data for programs running on the Win32 subsystem. The subkeys of CurrentVersion represent programs that run on the current version of Win32 subsystem and store configuration data for those programs that apply to all users of the computer.


Explorer

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\

Description

The Explorer subkey stores configuration data for Windows Explorer and for the Windows interface.


Shell Folders

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\

Description

The entries in the Shell Folders subkey are not used by and have no effect on Windows 2000. Paths to the Windows Explorer folders are stored in the User Shell Folders subkey. For more information on shell folders, search the Platform Software Development Kit (SDK) documentation in the MSDN Library at http://msdn.microsoft.com.

Related Entries

User Shell Folders


User Shell Folders

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\

Description

The User Shell Folders subkey of HKEY_LOCAL_MACHINE stores the paths to Windows Explorer folders for the current user of the computer.

Note Image Note

The entries in this subkey can appear in both the Shell Folders subkey and the User Shell Folders and in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. The entries which appear in user User Shell Folders take precedence over those in Shell Folders. The entries which appear in HKEY_CURRENT_USER take precedence over those in HKEY_LOCAL_MACHINE.

Related Entries

User Shell Folders in HKEY_CURRENT_USER


Common Desktop

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

Data type | Range | Default value
REG_EXPAND_SZ | Path | %ALLUSERPROFILE%\Desktop

Description

Stores the path to the folder containing the shortcuts and Internet addresses that appear on the desktop.

You can enter any valid UNC name or mapped drive in the value of this entry.

Note Image Note

The %ALLUSERPROFILE% variable represents the path to the user's Profiles folder. The default is Systemroot\Documents and Settings\All Users.

Related Entries

Desktop in HKCU\User Shell Folders


Common Documents

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

Data type | Range | Default value
REG_EXPAND_SZ | Path | %ALLUSERPROFILE%\Documents

Description

Stores the path to the folder containing the shortcuts and Internet addresses that appear on the user's desktop.

You can enter any valid UNC name or mapped drive in the value of this entry.

Note Image Note

The %ALLUSERPROFILE% variable represents the path to the user's Profiles folder. The default is Systemroot\Documents and Settings\All Users.

Related Entries

Common Documents in HKLM\User Shell Folders


Common Favorites

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

Data type | Range | Default value
REG_EXPAND_SZ | Path | %ALLUSERPROFILE%\Favorites

Description

Stores the path to the folder containing the Internet addresses that appear in the Favorites menu of the user's Internet browser.

You can enter any valid UNC name or mapped drive in the value of this entry.

Note Image Note

The %ALLUSERPROFILE% variable represents the path to the user's Profiles folder. The default is Systemroot\Documents and Settings\All Users.


Common Programs

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

Data type | Range | Default value
REG_EXPAND_SZ | Path | %ALLUSERPROFILE%\Start Menu\Programs

Description

Stores the path to the folder that contains the items which appear in the Programs menu on the Start menu.

You can enter any valid UNC name or mapped drive in the value of this entry.

Note Image Note

The %ALLUSERPROFILE% variable represents the path to the user's Profiles folder. The default is Systemroot\Documents and Settings\All Users.

Related Entries

Programs in HKCU\User Shell Folders


Common Start Menu

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

Data type | Range | Default value
REG_EXPAND_SZ | Path | %ALLUSERPROFILE%\Start Menu

Description

Stores the path to the folder containing the items that appear in the Start menu.

You can enter any valid UNC name or mapped drive in the value of this entry.

Note Image Note

The %ALLUSERPROFILE% variable represents the path to the user's Profiles folder. The default is Systemroot\Documents and Settings\All Users.


Common Startup

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

Data type | Range | Default value
REG_EXPAND_SZ | Path | %ALLUSERPROFILE%\Start Menu\Programs\Startup

Description

Stores the path to the folder containing shortcuts to items that appear in the Startup menu on the Start menu.

Note Image Note

The %ALLUSERPROFILE% variable represents the path to the user's Profiles folder. The default is Systemroot\Documents and Settings\All Users.

Related Entries

Startup in HKCU\User Shell Folders


Personal

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

Data type | Range | Default value
REG_SZ | Path | Systemroot\My Documents

Description

Stores the path to a particular user's Personal folder.

The Personal folder is the default location for saving application files. You can enter any valid UNC name or mapped drive in the value of this entry.

Related Entries

Personal in HKCU\User Shell Folders


Policies

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\

Description

The Policies subkey stores registry entries that are managed by Group Policy.

Group Policy adds, deletes, and changes the values of entries in this subkey when you use the Group Policy snap-in to configure a policy, that is, to enable or disable the policy. When the policies affecting you or your computer change, such as when you move to a new user group, Group Policy deletes the entries applied to the old group and adds the entries applied to the new group.

Group Policy manages registry entries in four Policies subkeys:

  • HKLM\SOFTWARE\Policies
  • HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies
  • HKCU\SOFTWARE\Policies
  • HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies

The Policies subkeys in HKCU store policy-related entries that are configured separately for each user. Group Policy adds these entries when you enable (and, for some policies, when you disable) a policy in the User Configuration folder in Group Policy.

The Policies subkeys in HKLM store policy-related entries that apply to all users of the computer. The system adds these entries when you enable (and, for some policies, when you disable) a policy in the Computer Configuration folder in Group Policy.

Many policy-related entries can appear in both HKCU and HKLM. Typically, the entries in HKLM take precedence over the entries in HKCU when both are configured.

The SOFTWARE\Microsoft\Windows\CurrentVersion\Policies subkey stores policy-related entries for Windows 2000 and for Windows NT 4.0 and earlier. The SOFTWARE\Policies subkey is new in Windows 2000. Please note that the different versions of Windows support different policies.

Change method

To add, remove, or change the value of entries in this subkey, use Group Policy.

Note Image Note

Many of the entries in the Policies subkeys have counterparts in other registry subkeys. These counterparts, known as preferences, have the same effect on user or computer features as entries in the Policies subkey. However, when an entry appears in the Policies subkey, the preference is almost always ignored. For details, see the entry descriptions.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Caution Image Caution

Do not use a registry editor to change the values in this subkey. If you do, they will be overwritten the next time your policies are refreshed.


Explorer

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\

Description

The Policies\Explorer subkey contains entries that store Group Policy settings for Windows Explorer and the Windows interface. These include policies for the Start menu, taskbar, desktop, and Control Panel. The entries in this subkey are written and maintained by Group Policy, and are read and interpreted by the Windows Explorer program.

This subkey in HKEY_LOCAL_MACHINE stores entries that apply to all users of this computer. There is also a Software\Microsoft\Windows\CurrentVersion\Policies\Explorer subkey in HKEY_CURRENT_USER, which stores policy-related entries that are configured separately for each user.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

Explorer subkey (HKCU)


DisableLocalMachineRun

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Directs the system to ignore the customized run list for Windows NT 4.0 and earlier.

This entry stores the setting of the Disable legacy run list Group Policy. Group Policy adds this entry to the registry with a value of 1 when you configure the Disable legacy run list policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 | The policy is disabled or not configured. Windows 2000 adds any customized run list configured for Windows NT 4.0 and earlier to its run list.
1 | The policy is enabled. The system ignores the run list for Windows NT 4.0 and earlier.

A run list is customized list of additional programs and documents that the system starts automatically when it starts. These programs are added to the standard run list of programs and services that the system starts.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable legacy run list policy (Computer Configuration\Administrative Templates\System).

Note Image Note

This entry can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If this entry appears in both subtrees, the value in HKEY_LOCAL_MACHINE takes precedence over the value in HKEY_CURRENT_USER.

Tip Image Tip

The customized run lists for Windows NT 4.0 and earlier are stored in the registry in HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run and HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Windows\Run. They can be configured by using the Run policy in System Policy Editor for Windows NT 4.0 and earlier.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

DisableLocalMachineRun (HKCU)

DisableLocalMachineRunOnce (HKLM)


DisableLocalMachineRunOnce

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Directs the system to ignore customized run-once lists.

This entry stores the setting of the Disable the run once list Group Policy. Group Policy adds this entry to the registry with a value of 1 when you configure the Disable the run once list policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 | The policy is disabled or not configured. The system runs the programs in the run-once list.
1 | The policy is enabled. The system ignores the run-once list.

A run-once list is customized list of additional programs and documents that are started automatically the next time the system starts (but not thereafter). These programs are added to the standard list of programs and services that the system starts.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable the run once list policy (Computer Configuration\Administrative Templates\System).

Note Image Note

This entry can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If this entry appears in both subtrees, the value in HKEY_LOCAL_MACHINE takes precedence over the value in HKEY_CURRENT_USER.

Tip Image Tip

Customized run-once lists are stored in the registry in HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\RunOnce.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

DisableLocalMachineRunOnce (HKCU)

DisableLocalMachineRun (HKLM)

Run subkey (HKLM)

Run subkey (HKCU)


NoDisconnect

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Removes the Disconnect item from the Shut Down Windows dialog box on Terminal Services clients.

This entry stores the setting of the Remove Disconnect item from Start menu (Terminal Services only) Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Remove Disconnect item from Start menu (Terminal Services only) policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 | The policy is disabled or not configured. The Disconnect item appears in the drop-down list of options in the Shut Down Windows dialog box.
1 | The policy is enabled. The Disconnect item does not appear in the drop-down list of options in the Shut Down Windows dialog box. Terminal Services users cannot use this familiar method to disconnect their client from a Terminal Services server.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Remove Disconnect item from Start menu (Terminal Services only) policy (Computer Configuration\Administrative Templates\System).

Note Image Note

This entry affects the Shut Down Windows dialog box only. It does not prevent users from using other methods of disconnecting from a Terminal Services server.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

EnableAdminTSRemote

NoNTSecurity


NoDriveAutoRun

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0x0 - 0x3FFFFFF (bitmapped value) | 0x0

Description

Determines whether the Autoplay feature is enabled on each drive connected to the system. When Autoplay is enabled, media is started automatically when it is inserted in the drive.

The value of this entry is comprised of 32 bits. The lower 26 bits each represent a drive, with the lowest (right-most) bit representing drive A, and the 26th bit from the right representing drive Z. If a bit is set to 0, the Autoplay feature is enabled on that drive. If a bit is set to 1, the Autoplay feature is disabled on that drive.

For example, if the value of this entry is 0x8 (1000 binary), Autoplay is disabled on drive D.

Note Image Note

Autoplay is triggered by a Media Change Notification (MCN) message from the CD-ROM driver. If the Windows interface does not receive this message, Autoplay does not operate, regardless of the value of this entry. Entries that suppress the MCN message, such as Autorun and AutorunAlwaysDisable, also disable Autoplay.

Autoplay is also disabled on any drive if it is disabled by the value of NoDriveAutoRun (in HKLM or HKCU) or NoDriveTypeAutoRun (in HKLM or HKCU).

However, if NoDriveAutoRun or NoDriveTypeAutoRun appear in HKEY_LOCAL_MACHINE, their corresponding entries in HKEY_CURRENT_USER are ignored.

Although this entry is located in the Policies\Explorer subkey, it is not associated with a Group Policy included in Windows 2000.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

Related Entries

Autorun

AutoRunAlwaysDisable

NoDriveAutoRun (in HKCU)

NoDriveTypeAutoRun (in HKLM)

NoDriveTypeAutoRun (in HKCU)


NoDriveTypeAutoRun

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_SZ | 0x0 - 0xFF | 0x95

Description

Disables the Autoplay feature on all drives of the type specified.

Autoplay begins reading from a drive as soon as you insert media in the drive. As a result, the setup file of programs and the music on audio media starts immediately.

This entry stores the setting of the Disable Autoplay Group Policy. Group Policy adds this entry to the registry when you enable the Hide these specified drives in My Computer policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0x95.

This entry is a bitmapped value. To disable Autoplay on a particular type of drive, set the bit representing that drive type to 1. To disable more than one type of drive, set the bits representing each type to 1, or sum the hexadecimal values of the representative bits.

Value | Meaning
0x1 | Disables Autoplay on drives of unknown type.
0x4 | Disables Autoplay on removable drives.
0x8 | Disables Autoplay on fixed drives.
0x10 | Disables Autoplay on network drives.
0x20 | Disables Autoplay on CD-ROM drives.
0x40 | Disables Autoplay on RAM disks.
0x80 | Disables Autoplay on drives of unknown type.
0xFF | Disables Autoplay on all types of drives.

By default, Autoplay is disabled on removable drives, such as the floppy disk drive (but not the CD-ROM drive), and on network drives. The default value 0x95 (149) is the sum of 0x1, 0x81 (unknown types), 0x4 (floppy drives), and 0x10 (network drives).

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable Autoplay policy (Computer Configuration\Administrative Templates\System).

Note Image Note

Autoplay is triggered by a Media Change Notification (MCN) message from the CD-ROM driver. If the Windows interface does not receive this message, Autoplay does not operate, regardless of the value of this entry. Entries that suppress the MCN message, such as Autorun and AutoRunAlwaysDisable also disable Autoplay.

Autoplay is also disabled on any drive if it is disabled by the value of NoDriveAutoRun (in HKLM or HKCU) or NoDriveTypeAutoRun (in HKLM or HKCU).

However, if NoDriveAutoRun or NoDriveTypeAutoRun appear in HKEY_LOCAL_MACHINE, their corresponding entries in HKEY_CURRENT_USER are ignored.

You can use the Disable Autoplay Group Policy to add CD-ROM drives to the list of drive types already disabled (removable drives, network drives, and unknown drives) or to disable Autoplay on all drives. You must edit the registry to set any other value.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

Autorun

AutoRunAlwaysDisable

NoDriveAutoRun (in HKLM)

NoDriveAutoRun (in HKCU)

NoDriveTypeAutoRun (in HKCU)


NoEncryptOnMove

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Prevents Windows Explorer from encrypting files when they are moved to an encrypted folder.

This entry stores the setting of the Do not automatically encrypt files moved to encrypted folders Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enabled the Do not automatically encrypt files moved to encrypted folders policy. When you disable the policy, or set it to Not configured, Group Policy deletes this entry from the registry.

Value | Meaning
0 | The policy is disabled or not configured. Windows Explorer automatically encrypts files when they are moved to an encrypted folder.
1 | The policy is enabled. Windows Explorer does not encrypt files that are moved to an encrypted folder.

This entry applies only to files moved within a volume. When files are moved to other volumes, or if you create a new file in an encrypted folder, Windows Explorer automatically encrypts those files.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Do not automatically encrypt files moved to encrypted folders policy (Computer Configuration\Administrative Templates\System).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


NoFileAssociate

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | Terminal Services systems: 1 All other Windows 2000 systems 0

Description

Disables the buttons on the File Types tab. As a result, users can view file type associations, but they cannot add, delete, or change them.

The File Types tab shows which programs open when you double-click a type of file. The file types are represented by their file name extension.

Value | Meaning
0 | Users can add, delete, and change file type associations.
1 | Users cannot add, delete, or change file type associations.

By disabling this tab, you can prevent malicious users from creating an association that starts a risky or destructive program. Also, users cannot create less productive associations, such as associating the .doc file type with Wordpad instead of Microsoft Word. This is a particular risk on multi-user systems, such as Terminal Services clients.

Note Image Note

Although this entry is located in the Policies\Explorer subkey, it is not associated with a Group Policy included in Windows 2000. You can create a policy by adding this entry to an Administrative Templates file. For information, see Creating custom .adm files in Windows 2000 Help.

This entry applies to all users of the computer. To set this entry for particular users, use NoFileAssociate in the HKCU subtree. If the settings of these entries conflict, the setting in HKCU overrides the setting in HKLM.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Tip Image Tip

To see the File Types tab, in My Computer, from the Tools menu, click Folder Options, and then click the File Types tab.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

Related Entries

NoFileAssociate (HKCU)


NoNTSecurity

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Removes the Windows Security item from the Settings menu on a Terminal Services client.

This entry stores the setting of the Remove security option from Start menu (Terminal Services only) Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Remove security option from Start menu (Terminal Services only) policy. If you disable the policy or do not configure it, Group Policy deletes the entry from the registry.

Value | Meaning
0 (not in registry) | The policy is disabled or not configured. The Windows Security item appears in Settings menu on the Start menu.
1 | The policy is enabled. The Windows Security item does not appear in Settings menu on the Start menu. As a result, users must type a security attention sequence, such as Ctrl+Alt+End, to open the Windows Security dialog box on a Terminal Services client.

This policy is designed to prevent inexperienced users from logging on to Terminal Services inadvertently.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Remove security option from Start menu (Terminal Services only) policy (Computer Configuration\Administrative Templates\System).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoDisconnect

EnableAdminTSRemote


NoWelcomeScreen

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Prevents the Getting Started with Windows 2000 welcome screen in Windows 2000 Professional from being displayed each time a user logs on. Users can still display the welcome screen by selecting it from the Start menu or by typing Welcome in the Run dialog box.

This entry stores the setting of the Don't display welcome screen at logon Group Policy. Group Policy adds this entry to the registry with a value of 1 when you configure the Don't display welcome screen at logon policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 | The policy is disabled or not configured. Getting Started with Windows 2000 appear in Windows 2000 Professional each time a user logs on.
1 | The policy is enabled. Getting Started with Windows 2000 is not displayed automatically, although users can display it on demand.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Don't display welcome screen at logon policy (Computer Configuration\Administrative Templates\System).

Note Image Note

This entry takes precedence over a user setting. While the Don't display welcome screen at logon policy is enabled (the value of this entry is 1), the system ignores the setting of the Show this screen at startup check box on the welcome screen and the value of Show, which stores the setting.

This policy applies only to Windows 2000 Professional. It does not affect the Configure Your Server on a Windows 2000 Server screen on Windows 2000 Server.

This policy appears in the Computer Configuration and User Configuration folders. If both policies are configured, the setting in Computer Configuration takes precedence over the setting in User Configuration.

Tip Image Tip

To display the Welcome screen in Windows 2000 Professional, click Start, point to Programs, point to Accessories, point to System Tools, and then click Getting Started. To suppress the welcome screen without setting a policy, clear the Show this screen at startup check box on the welcome screen.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoWelcomeScreen (HKCU)

Show


Run

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer\

Description

The Run subkey stores the names of executable files and document files that Windows 2000 runs automatically when any user logs on to the system.

There are several Run subkeys in the registry. Group Policy adds this subkey and its entries to the registry when you enable the Run these programs at user logon policy in the Computer Configuration folder. If you disable the policy or set it to Not configured, Group Policy deletes the Run subkey (and all of its entries) from the registry.

Each entry in the Run subkey represents a program or document. The entry name is an ordinal number, and its value is the name of (and, optionally, the path to) an executable file or document. You provide the file name when you configure the policy.

Each entry in the run subkey has the following format:

Number REG_SZ [Path]File name

For example, the entry

1 REG_SZ Calc.exe

indicates that the Windows calculator will be started automatically when a user logs on.

2 REG_SZ E:\NewFile\Readme.doc

indicates that the ReadMe document will be started automatically when a user logs on.

Note Image Note

The Policies\Explorer\Run subkey can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If this entry appears in both subtrees, the system starts the programs specified in HKEY_LOCAL_MACHINE just before it starts the programs specified in HKEY_CURRENT_USER.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


NonEnum

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\

Description

The NonEnum subkey of the Policies subkey contains entries that tell the system not to enumerate (display) components of the Windows interface. These entries are written and maintained by Group Policy, and are read and interpreted by the interface programs.

The Non-Enum policy subkey in HKEY_LOCAL_MACHINE stores entries that apply to all users of this computer. There is also a Software\Microsoft\Windows\CurrentVersion\Policies\NonEnum subkey in HKEY_CURRENT_USER, which stores policy-related entries that are configured separately for each user.

The entries in this subkey have the following format:

Class-ID or GUID of the component REG-DWORD 0 | 1

Group Policy stores the value of policy settings in this subkey. It adds, deletes, or changes the values of entries in this subkey when you configure related Group Policies.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NonEnum subkey (HKCU)


{BDEADF00-C265-11D0-BCED-00A0C90AB50F}

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\NonEnum

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

This entry is maintained by the Windows interface for its internal use. Although it appears in the Policies subkey, it is not associated with a Windows 2000 policy.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

Caution Image Caution

Do not delete this entry or change its value.


System

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\

Description

The System subkey stores the entries created when you configure a Group Policy that affects a basic component of Windows 2000. The entries in this subkey are written and maintained by Group Policy, and are read and interpreted by the component program.

The System subkey in HKEY_LOCAL_MACHINE stores entries that apply to all users of this computer. There is also a Software\Microsoft\Windows\CurrentVersion\Policies\System subkey in HKEY_CURRENT_USER, which stores policy-related entries that are configured separately for each user.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

HKCU\Software\Policies\Microsoft\Windows\System

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System

HKLM\SOFTWARE\Policies\Microsoft\System

HKLM\SOFTWARE\Policies\Microsoft\Windows\System


DisableBkGndGroupPolicy

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Prevents Group Policy from being updated while the computer is in use. This policy applies to Group Policies for computers, users, and domain controllers.

This entry stores the setting of the Disable background refresh of Group Policy Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Disable background refresh of Group Policy policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 | The policy is disabled or not configured. The system can update Group Policy settings while users are working.
1 | The policy is enabled. The system waits until the current user logs off the system before updating Group Policy settings.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable background refresh of Group Policy policy (Computer Configuration\Administrative Templates\System\Group Policy).

Note Image Note

This entry takes precedence over a user setting. When this entry appears in the registry, a policy is in effect, and the system ignores the value of DisableBkGndGroupPolicy in HKLM\SOFTWARE\Microsoft\CurrentVersion\Winlogon.

Tip Image Tip

The frequency of updates is determined by the values of the GroupPolicyRefreshTime (HKLM) and GroupPolicyRefreshTimeOffset (HKLM), or GroupPolicyRefreshTime (HKCU) and GroupPolicyRefreshTimeOffset (HKCU) entries.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

GroupPolicyRefreshTime (HKCU)

GroupPolicyRefreshTime (HKLM)

GroupPolicyRefreshTimeOffset (HKCU)

GroupPolicyRefreshTimeOffset (HKLM)


DisableStatusMessages

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Suppresses system status messages. These messages remind users to wait while their system starts or shuts down, or while users log on or off.

This entry stores the setting of the Disable Boot / Shutdown / Logon / Logoff status messages Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Disable Boot / Shutdown / Logon / Logoff status messages policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. The system displays status messages.
1 | The policy is enabled. The system does not display a message reminding users to wait while their system starts or shuts down, or while users log on or off.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable Boot / Shutdown / Logon / Logoff status messages policy (Computer Configuration\Administrative Templates\System).

Note Image Note

The Disable Boot / Shutdown / Logon / Logoff status messages policy takes precedence over the Verbose vs normal status messages policy. When the value of DisableStatusMessages is 1, the system does not display status messages and the VerboseStatus entry is ignored.

This entry takes precedence over a user setting. When this entry appears in the registry, the system ignores the value of DisableStatusMessages in HKLM\SOFTWARE\Microsoft\CurrentVersion\Winlogon.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


GroupPolicyRefreshTime

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

Data type | Range | Default value
REG_DWORD | 0 - 64800 minutes | 90

Description

Determines how often Group Policy is applied to computers.

This entry specifies how often Group Policy for computers is updated (in the background) while the computer is in use. In addition to background updates, Group Policy for the computer is always updated when the system starts. This entry specifies a background update rate only for Group Policies in the Computer Configuration folder.

This entry stores the setting you enter in the update time Minutes box of the Group Policy refresh interval for computers Group Policy. Group Policy adds this entry to the registry when you enable the Group Policy refresh interval for computers policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 90 minutes.

If the value of this entry is 0, the system updates Group Policy approximately every 7 seconds. Because updates might interfere with users' work and increase network traffic, very short update intervals are not appropriate for most installations.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Group Policy refresh interval for computers policy (Computer Configuration\Administrative Templates\System\Group Policy).

Note Image Note

The Group Policy refresh interval for computers policy also includes an time offset to prevent clients with the same update interval from requesting updates simultaneously. The offset is stored in the value of GroupPolicyRefreshTimeOffset.

If background updates are disabled (that is, the value of DisableBkGndGroupPolicy entry is 1, this entry is ignored.

This entry can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If this entry appears in both subtrees, the value in HKEY_LOCAL_MACHINE takes precedence over the value in HKEY_CURRENT_USER.

Tip Image Tip

Consider notifying users that their policy is updated periodically so that they recognize the signs of a policy update. When Group Policy is updated, the Windows desktop is refreshed; it flickers briefly and closes open menus. Also, restrictions imposed by Group Policies, such as those that limit the programs users can run, might interfere with tasks in progress.

To specify that Group Policy should never be updated while the computer is in use, enable the Disable background refresh of Group Policy policy (see DisableBkGndGroupPolicy).

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

GroupPolicyRefreshTime (HKCU)

GroupPolicyRefreshTimeOffset (HKLM)

GroupPolicyRefreshTimeDC (HKLM)

DisableBkGndGroupPolicy


GroupPolicyRefreshTimeOffset

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

Data type | Range | Default value
REG_DWORD | 0 - 1440 minutes | 0

Description

Determines the maximum time offset used when updating Group Policy settings for computers.

This entry specifies the maximum length of random offset time interval. The system calculates the actual offset at run time and adds it to the Group Policy update interval for that computer. The offset prevents clients with the same update interval from requesting updates simultaneously.

This entry stores the setting of the random time Minutes box on the Group Policy refresh interval for computers Group Policy. Group Policy adds this entry to the registry when you enable the Group Policy refresh interval for computers policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 30 minutes.

A large value establishes a broad range and makes it less likely that client update requests overlap. However, updates might be delayed significantly.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Group Policy refresh interval for computers policy (Computer Configuration\Administrative Templates\System\Group Policy).

Note Image Note

The Group Policy refresh interval for computers policy also lets you set the update interval. This interval is stored in the value of GroupPolicyRefreshTime (HKLM).

This entry applies only to Group Policy settings in the Computer Configuration folder.

If background updates are disabled (that is, the value of DisableBkGndGroupPolicy entry is 1, this entry is ignored.

This entry can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If this entry appears in both subtrees, the value in HKEY_LOCAL_MACHINE takes precedence over the value in HKEY_CURRENT_USER.

Tip Image Tip

Consider notifying users that their policy is updated periodically so that they recognize the signs of a policy update. When Group Policy is updated, the Windows desktop is refreshed; it flickers briefly and closes open menus. Also, restrictions imposed by Group Policies, such as those that limit the programs users can run, might interfere with tasks in progress.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

GroupPolicyRefreshTime (HKLM)

GroupPolicyRefreshTimeOffset (HKCU)

GroupPolicyRefreshTimeOffsetDC (HKLM)

DisableBkGndGroupPolicy


HideShutdownScripts

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether the instructions in shutdown script are displayed as the script runs.

This entry stores the setting of the Run shutdown scripts visible Group Policy. Group Policy adds this entry to the registry with a value of 0 when you enable the Run shutdown scripts visible policy. If you disable the policy, Group Policy sets the value to 1. If you set the policy to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 1.

Value | Meaning
0 | The policy is enabled. The system displays each instruction in the shutdown script as it runs. The instructions appear in a command window. This setting is designed for advanced users.
1 | The policy is disabled or not configured. The instructions in a shutdown script are suppressed.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Run shutdown scripts visible policy (Computer Configuration\Administrative Templates\System\Logon).

Note Image Note

This entry takes precedence over a user setting. When this entry appears in the registry, a policy is in effect, and the system ignores the value of HideShutdownScripts in HKLM\SOFTWARE\Microsoft\CurrentVersion\Winlogon.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

HideLegacyLogonScripts

HideLogoffScripts

HideShutdownScripts

HideStartupScripts


HideStartupScripts

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether the instructions in a startup script are displayed as the script runs.

This entry stores the setting of the Run startup scripts visible Group Policy. Group Policy adds this entry to the registry with a value of 0 when you enable the Run startup scripts visible policy. If you disable the policy, Group Policy sets the value to 1. If you set the policy to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 1.

Value | Meaning
0 | The policy is enabled. The system displays each instruction in the startup script as it runs. The instructions appear in a command window. This setting is designed for advanced users.
1 | The policy is disabled or not configured. The instructions in a startup script are suppressed.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Run startup scripts visible policy (Computer Configuration\Administrative Templates\System\Logon).

Note Image Note

This entry takes precedence over a user setting. When this entry appears in the registry, a policy is in effect, and the system ignores the value of HideStartupScripts in HKLM\SOFTWARE\Microsoft\CurrentVersion\Winlogon.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

HideLogoffScripts

HideLogonScripts

HideShutdownScripts


MaxGPOScriptWait

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

Data type | Range | Default value
REG_DWORD | 0 | 1 -32000 seconds | 600 (10 minutes)

Description

Determines how long the system waits for scripts applied by Group Policy to run.

The value of this entry limits the combined time allowed for all logon, startup, and shutdown scripts applied by Group Policy to finish running.

This entry stores the setting of the Maximum wait time for Group Policy scripts Group Policy. Group Policy adds this entry to the registry with the value you enter when you configure the Maximum wait time for Group Policy scripts policy. If you disable the policy or do not configure it, Group Policy deletes the entry from the registry and the system behaves as though the value of the entry is 600 seconds (10 minutes).

Value | Meaning
0x0 | The system waits until all scripts have finish running, no matter how long they take.
0x1 - 0x8000 | Specifies how long the system waits for scripts to finish. If the scripts have not finished running when the specified time expires, the system stops script processing and records an error event.

This interval is particularly important when other system tasks must wait while the scripts complete. By default, each startup script must complete before the next one runs. Also, you can set the RunLogonScriptSync entry to direct the system to wait for the logon scripts to complete before loading the desktop.

An excessively long interval can delay the system and inconvenience users. However, if the interval is too short, prerequisite tasks might not be done, and the system can appear to be ready prematurely.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Maximum wait time for Group Policy scripts policy (Computer Configuration\Administrative Templates\System\Logon). In the Seconds box, type a number from 1 to 32,000 for the number of seconds you want the system to wait for the set of scripts to finish. To direct the system to wait until the scripts have finished, no matter how long they take, type 0.

Note Image Note

This entry takes precedence over a user setting. When this entry appears in the registry, a policy is in effect and the system ignores the value of MaxGPOScriptWait in the Winlogon subkey.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

RunLogonScriptSync (HKLM)


RunLogonScriptSync

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Directs the system to wait for the logon scripts to finish running before it starts the Windows Explorer interface program and creates the desktop.

This entry stores the setting of the Run logon scripts synchronously Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Run logon scripts synchronously policy. If you disable the policy, Group Policy sets the value to 0. If you set the policy to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 | The policy is disabled or not configured. Logon scripts and Windows Explorer are not synchronized and can run simultaneously.
1 | The policy is enabled. Windows Explorer does not start until the logon scripts have finished running. This setting assures that logon script processing is complete before the user starts working, but it can delay the appearance of the desktop.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Run logon scripts synchronously policy (Computer Configuration\Administrative Templates\System\Logon).

Note Image Note

This entry appears in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If the values conflict, the value in HKEY_LOCAL_MACHINE takes precedence over the value in HKEY_CURRENT_USER.

This entry takes precedence over a user setting. When this entry appears in the registry, a policy is in effect and the system ignores the value of RunLogonScriptSync (HKLM) and RunLogonScriptSync (HKCU).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

RunLogonScriptSync (HKCU)

RunLogonScriptSync (Winlogon in HKCU)

RunLogonScriptSync (Winlogon in HKLM)


RunStartupScriptSync

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether the system coordinates ("synchronizes") the running of startup scripts. When they are synchronized, the system waits for each script to complete before it starts the next script.

This entry stores the setting of the Run startup scripts asynchronously Group Policy. Group Policy adds this entry to the registry with a value of 0 when you enable the policy. If you disable this policy, Group Policy sets the value of this entry to 1. If you set the policy to Not configured, Group Policy deletes the entry from the registry, and the system behaves as though the value is 1. (Please note that this is a reversal of the usual behavior.)

Value | Meaning
0 | The policy is enabled. Startup scripts cannot run until the previous script is finished running.
1 | The policy is disabled or not configured. The system does not synchronize the running of startup scripts. As a result, startup scripts can run simultaneously.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Run startup scripts asynchronously policy (Computer Configuration\Administrative Templates\System\Logon).

Note Image Note

This entry takes precedence over a user setting. When this entry appears in the registry, a policy is in effect, and the system ignores the value of RunStartupScriptSync in HKLM\SOFTWARE\Microsoft\CurrentVersion\Winlogon.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


SynchronousMachineGroupPolicy

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Lets the system display the logon prompt before it finishes updating Group Policy settings for the computer.

This entry stores the setting of the Apply Group Policy for computers asynchronously during startup Group Policy. Group Policy adds this entry to the registry with a value of 0 when you enable the Apply Group Policy for computers asynchronously during startup policy. If you disable the policy, Group Policy sets the value to 1. If you set the policy to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 1.

Value | Meaning
0 | The policy is enabled. The system does not wait for updates to computer Group Policy settings to complete before inviting the user to log on. As a result, the Windows interface might appear to be ready before computer Group Policy is applied.
1 | The policy is disabled or not configured. Users cannot log on until computer Group Policy is updated.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Apply Group Policy for computers asynchronously during startup policy (Computer Configuration\Administrative Templates\System\Group Policy).

Note Image Note

This entry takes precedence over a user setting. When this entry appears in the registry, a policy is in effect, and the system ignores the value of SynchronousMachineGroupPolicy in HKLM\SOFTWARE\Microsoft\CurrentVersion\Winlogon.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

SynchronousUserGroupPolicy


SynchronousUserGroupPolicy

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Lets the system display the logon prompt before it finishes updating Group Policy settings for the user.

This entry stores the setting of the Apply Group Policy for users asynchronously during logon Group Policy. Group Policy adds this entry to the registry with a value of 0 when you enable the policy. If you disable the policy, Group Policy sets the value to 1. If you set the policy to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 1.

Value | Meaning
0 | The policy is enabled. The system does not coordinate the tasks of loading desktop and updating user Group Policy. As a result, Windows might appear ready for use before user Group Policy is updated.
1 | The policy is disabled or not configured. The system does not make the desktop available to users until updates to Group Policy user setting are complete.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Apply Group Policy for users asynchronously during logon policy (Computer Configuration\Administrative Templates\System\Group Policy).

Note Image Note

This entry takes precedence over a user setting. When this entry appears in the registry, a policy is in effect, and the system ignores the value of SynchronousUserGroupPolicy in HKLM\SOFTWARE\Microsoft\CurrentVersion\Winlogon.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

SynchronousMachineGroupPolicy


VerboseStatus

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Directs the system to display highly detailed status messages.

This entry stores the setting of the Verbose vs normal status messages Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. The system displays standard status message designed for most users.
1 | The policy is enabled. The system displays status message that reflect each step in the process of starting, shutting down, logging on or logging off the system. This value is designed for sophisticated users.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Verbose vs normal status messages policy (Computer Configuration\Administrative Templates\System).

Note Image Note

The Disable Boot / Shutdown / Logon / Logoff status messages policy takes precedence over the Verbose vs normal status messages policy. When the value of DisableStatusMessages is 1, the system does not display status messages and the VerboseStatus entry is ignored.

This entry takes precedence over a user setting. When this entry appears in the registry, the system ignores the value of VerboseStatus in HKLM\SOFTWARE\Microsoft\CurrentVersion\Winlogon.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

DisableStatusMessages


Run

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\

Description

The Run subkey of HKEY_LOCAL_MACHINE\Software stores the names of programs that Windows 2000 runs at startup, for all users of the computer, each time the system starts.

Each entry in the subkey represents a program. The value of the entry is the name of the executable file for the program. These entries have the following format:

Program Name REG_SZ File name


RunOnce

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\

Description

The RunOnce subkey of HKEY_LOCAL_MACHINE\SOFTWARE stores the names of programs that Windows 2000 runs at startup, for all users of the computer, the next time the system starts. When these programs are run, their names are deleted from the RunOnce subkey so that they are not run again automatically.

Each entry in the subkey represents a program. The value of the entry is the name of the executable file for the program. These entries have the following format:

Program Name REG_SZ File name


Windows NT

HKLM\SOFTWARE\Microsoft\

Description

The Windows NT subkey stores configuration data for components of Windows 2000. The subkeys of the Windows NT subkey represent versions of the operating system, such as CurrentVersion, which refers to the version currently running on the computer. Each version subkey contains subkeys representing components that run on that version of the system.

The Windows NT subkey in HKEY_CURRENT_USER stores entries that apply only to the current user of the computer. There is also a SOFTWARE\Microsoft\Windows NT subkey in HKEY_LOCAL_MACHINE that stores entries that apply to all users of the computer.

Related Entries

Windows NT subkey (HKCU)


CurrentVersion

HKLM\SOFTWARE\Microsoft\Windows NT\

Description

The CurrentVersion subkey stores configuration data for programs designed to run on the most current version Windows 2000 installed on the computer. The subkeys of CurrentVersion represent programs that run on the current version of Windows 2000 and store configuration data for those programs that apply to all users of the computer.


AeDebug

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\

Description

The AeDebug subkey stores user preferences for Dr. Watson and other debugging tools that run on Windows 2000.

Change method

Use the Dr. Watson for Windows 2000 dialog box to change Dr. Watson values. (Run drwtsn32 from the command prompt or use the Run command on the Start menu.) To disable Dr. Watson, delete the AeDebug subkey. To reenable Dr. Watson, type drwtsn -i at the command prompt or from the Run command on the Start menu.


Auto

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AeDebug

Data type | Range | Default value
REG_SZ | 0 | 1 | 1

Description

Determines whether or not the debugger specified in the value of the Debugger entry is started automatically when an application error occurs.

Value | Meaning
0 | The system displays a message box notifying the user when an application error occurs.
1 | The debugger is started automatically.

If the Debugger entry contains the name of a valid debugger (such as Drwtsn32, WinDbg, or NTSD), the user can choose to terminate the application by clicking OK or to run the debugger by clicking Cancel. (If no debugger is specified, there is no Cancel button in the message box.)


Debugger

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AeDebug

Data type | Range | Default value
REG_SZ | Name of debugger and switch settings. | drwtsn32 -p %ld -e %ld -g

Description

Specifies the debugger that is activated when an application error occurs. If the value of the Auto entry is 1, this debugger is started automatically. If the value of Auto is 0, the user must start the debugger.

Dr. Watson (drwtsn32) is the default debugger, but another debugger (such as WinDbg or NTSD) can be installed as the automatic debugger. The values following the debugger name are specific to the debugger. The default switches for Dr. Watson are set as follows:

Value | Meaning
-p | Stores the Process ID for the running process at the location specified by %ld.
-e | Stores the Event ID for the running process at the location specified by %Id.
-g | Tells the debugger to go (start).

Note Image Note

For more information on Dr. Watson, see the Online Help for Dr. Watson.


UserDebuggerHotKey

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AeDebug

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFF | 0x0

Description

Specifies the key that, when pressed, establishes a breakpoint in code being debugged.

The debugger interrupts code processing at the breakpoint so the programmer can examine a suspected problem.

The key specified in this value only sets a breakpoint. It does not invoke the debugger (the debugger must be running before the key is pressed) and it does not switch the debugger to single-step mode.

The value of this entry is a keyboard scan code. The default value, 0x0, represents the F12 key on a 101-key keyboard or the - (hyphen, VK_SUBTRACT) key on an 82-key keyboard.

The following table lists the scan codes and virtual key codes for a standard keyboard.

Scan code | Virtual key code
0x00 | VK_SUBTRACT (F12)
0x01 | VK_LBUTTON
0x02 | VK_RBUTTON
0x03 | VK_CANCEL
0x04 | VK_MBUTTON
0x08 | VK_BACK
0x09 | VK_TAB
0x0C | VK_CLEAR
0x0D | VK_RETURN
0x10 | VK_SHIFT
0x11 | VK_CONTROL
0x12 | VK_MENU
0x13 | VK_PAUSE
0x14 | VK_CAPITAL
0x15 | VK_KANA, VK_HANGEUL, VK_HANGUL
0x17 | VK_JUNJA
0x18 | VK_FINAL
0x19 | VK_HANJA, VK_KANJI
0x1B | VK_ESCAPE
0x1C | VK_CONVERT
0x1D | VK_NONCONVERT
0x1E | VK_ACCEPT
0x1F | VK_MODECHANGE
0x20 | VK_SPACE
0x21 | VK_PRIOR
0x22 | VK_NEXT
0x23 | VK_END
0x24 | VK_HOME
0x25 | VK_LEFT
0x26 | VK_UP
0x27 | VK_RIGHT
0x28 | VK_DOWN
0x29 | VK_SELECT
0x2A | VK_PRINT
0x2B | VK_EXECUTE
0x2C | VK_SNAPSHOT
0x2D | VK_INSERT
0x2E | VK_DELETE
0x2F | VK_HELP
0x30 - 0x39 | VK_0 - VK_9 (ASCII 0 - 9)
0x41 - 0x5A | VK_A - VK_Z (ASCII A - Z)


Font Drivers

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\

Description

The Font Drivers subkey stores configuration data for external font drivers.


<driver-name>

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Font Drivers

Data type | Range | Default value
REG_SZ | file name | file name

Description

The <driver-name> entry is a variable representing the entries under the Font Drivers subkey. It does not actually appear in the registry. This variable entry displays information which is common to the entries in the Font Drivers subkey.

Stores a list of external font drivers installed on the system.

There is an entry in the Font Drivers subkey for each font driver installed in Windows 2000. Each of these entries has the following format:

Driver name REG_SZ File name

For example,

Adobe Type Manager REG_SZ atmfd.dll

indicates that the driver for Adobe Type Manager is in the file atmfd.dll. The driver files are stored in Systemroot\WINNT\system32.

Change method

To change the value of this entry, use the program supplied by your font vendor for adding and removing drivers.

Note Image Note

The bitmap, vector, and TrueType drivers are built in to Windows 2000 and do not appear in the value of this entry. The Adobe Type Manager driver for PostScript fonts which ships with Windows 2000 does appear in this entry.


FontDPI

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\

Description

The FontDPI subkey stores information about the size of the system fonts.


LogPixels

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontDPI

Data type | Range | Default value
REG_DWORD | 0x13 - 0x1E0 pixels per inch | 0x96

Description

Determines the size of fonts on the desktop and in menus. This entry also determines the bitmap resolution of icons and toolbar buttons.

Change method

To change the value of this entry, double-click Display in Control Panel. Click the Settings tab, click the Advanced button, and on the General tab, select a font size from the drop-down list box.

Activation method

You must restart the computer before any changes to this entry take effect.

Note Image Note

The actual range of this entry depends on the installed monitor.


Fonts

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\

Description

The Fonts subkey stores the names of the files that support each font installed on Windows 2000. This information is used by applications running on Windows 2000.


<font-name>

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts

Data type | Range | Default value
REG_SZ | Font Name | Font file name

Description

Associates a font with the name of the file in which the font is stored.

There is an entry in the Fonts subkey for each font installed in Windows. These entries have the following format:

Font Name REG_SZ Font file name

For example,

Arial (TrueType) REG_SZ ARIAL.TTF

indicates that the Arial (TrueType) font is located in the Arial.ttf file. The font files are located in Systemroot\WINNT\Fonts.

Note Image Note

The <font-name> entry is a variable representing the entries under the Fonts subkey. It does not actually appear in the registry. This variable entry displays information which is common to the entries in the Fonts subkey.


FontSubstitutes

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\

Description

The FontSubstitues subkey stores the names of alternative fonts that can be used when a requested font or a font that appears in a document is not available or is unsupported.


<Font-name>

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontSubstitutes

Data type | Range | Default value
REG_SZ | font name | substitute font

Description

Associates an alternative font with the actual font requested by a program or used in a document.

The substitute font can be used either as the screen font or as the printer font or both. These entries have the following form:

Font name REG_SZ substitute font

For example,

Helvetica REG_SZ Arial

indicates that Arial can be substituted for Helvetica if Helvetica is not available.

Note Image Note

The <Font-name> subkey is a variable representing the subkeys in the FontSubstitutes subkey. It does not actually appear in the registry. This variable entry displays information which is common to the entries in


GRE_Initialize

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\

Description

The GRE_Initialize subkey holds screen raster fonts which are used by command windows.

The fonts are stored in the Systemroot\WINNT\system32\dllcache folder and are hidden to prevent them from being accidentally deleted. All the entries in this subkey have the following format:

font name REG_SZ file name

Change method

These fonts are used by the system. Do not change the values of these entries.

Note Image Note

For more information on fonts in Windows 2000, see the Windows 2000 Professional Resource Kit.


Network

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\

Description

The subkeys stored in the Network subkey are not used by and have no effect on Windows 2000. They remain in the registry to support applications which administer earlier versions of Windows.


Shared Parameters

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Network\

Description

This subkey is not used by and has no effect on Windows 2000. It remains in the registry to support applications which administer earlier versions of Windows.


SMAddOns

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Network\

Description

This subkey is not used by and has no effect on Windows 2000. It remains in the registry to support applications which administer earlier versions of Windows.


UMAddOns

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Network\

Description

This subkey is not used by and has no effect on Windows 2000. It remains in the registry to support applications which administer earlier versions of Windows.


World Full Access Shared Parameters

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Network\

Description

This subkey is not used by and has no effect on Windows 2000. It remains in the registry to support applications which administer earlier versions of Windows.


PDH

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\

Description

The PDH subkey stores configuration data for the Performance Data Helper dynamic link library (Pdh.dll). PDH is a library of performance data collection and processing functions used by performance monitoring programs, such as System Monitor.

Note Image Note

Windows 2000 does not add this subkey to the registry. You can add it by editing the registry or by using a program that edits the registry.


DefaultNullDataSource

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\PDH

Data type | Range | Default value
REG_DWORD | 1 | 4 | 1

Description

Determines the source from which the PDH functions retrieve performance data.

In Windows NT 4.0 and earlier, the PDH functions used information stored in the registry to retrieve data collected by internal counters. In Windows 2000, PDH functions can also retrieve data stored by using the Windows Management Instrumentation (WMI) interface.

Value | Meaning
1 | Registry. PDH functions retrieve performance data through registry interfaces.
4 | WMI. PDH functions use WMI interfaces to retrieve counter data.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


Perflib

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\

Description

The Perflib subkey stores configuration data for the Windows Performance Library, which collects and organizes data for performance tools, such as System Monitor.

In addition to entries, the Perflib subkey contains a <Language-code> subkey for each spoken language you configure for Windows 2000. The <Language-code> subkey stores performance counter names and their descriptions in the specified language. The <Language-code> subkey is named for the language code for the language. For example, the counters and descriptions for the English language are stored in a subkey named 009, the language code for English (United States).

Activation method

To make changes to entries in this subkey effective, restart the Remote Registry Service, or restart Windows 2000.

Tip Image Tip

If you cannot display particular performance counters, check the Application Log in Event Viewer for events recorded by Perflib. When Perflib finds a disabling error in a performance counter DLL, it records an event and then sets the value of Disable Performance Counters to 1 to disable the counters.


<Language-code>

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Perflib\

Description

The Perflib subkey contains a <Language-code> subkey for each spoken language you configure for Windows 2000. The <Language-code> subkey stores performance counter names and their descriptions in the specified language. The <Language-code> subkey is named for the language code associated with the language. For example, the counters and definitions for the English language are stored in a subkey named 009, the language code for English (United States).

The <Language-code> subkey is a variable representing the subkeys under the HKCU\Software\Microsoft\Perflib subkey. It doesn't actually appear in the registry. This variable subkey displays the entries that can appear in any of the language code subkeys in the Perflib subkey. The actual <language-code> subkeys in your registry depend upon the spoken language you have chosen for your system.

Activation method

To make changes to entries in this subkey effective, restart the Remote Registry Service or restart Windows 2000.

Tip Image Tip

If particular performance counters do not appear in your performance monitoring tool, check the Application Log in Event Viewer for events recorded by Perflib. When Perflib detects disabling errors in a counter DLL, it records an event in the log and sets the value of DisablePerformanceCounters to 1 to disable the counters.

Caution Image Caution

Do not change the values of entries in this subkey. This subkey is maintained by the Performance Library. If you change it, the performance tools on your system will not operate properly.


Counter

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Perflib\<Language-code>

Data type | Range | Default value
REG_MULTI_SZ | Counter names and indices | There is no default value for this entry.

Description

Stores the name and index and each performance counter installed in Windows 2000. The data stored in this value comes from the .ini files for the counter.

Activation method

To make changes to this entry effective, restart the Remote Registry Service or restart Windows 2000.

Tip Image Tip

If particular performance counters do not appear in your performance monitoring tool, check the Application Log in Event Viewer for events recorded by Perflib. When Perflib detects disabling errors in a counter DLL, it records an event in the log and sets the value of DisablePerformanceCounters to 1 to disable the counters.

Caution Image Caution

Do not change the value of this entry. This value is maintained by the Performance Library. If you change it, the performance tools on your system will not operate properly.


Help

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Perflib\<Language-code>

Data type | Range | Default value
REG_MULTI_SZ | Descriptions of counters | There is no default value for this entry.

Description

Stores text describing the counters performance counters installed in Windows 2000. This text is designed for performance tools, such System Monitor.

Activation method

To make changes to this entry effective, restart the Remote Registry Service or restart Windows 2000.

Note Image Note

This entry does not appear in Regedit. To view this entry, use Regedt32.

Tip Image Tip

To view the descriptive text in System Monitor, in the Add to Chart dialog box, click Explain.

For information on how to add descriptive text to the counters you develop for Windows 2000, see the Platform Software Development Kit (SDK).

Caution Image Caution

Do not change this value. This value is maintained by the Performance Library. If you change it, the performance tools on your system will not operate properly.


CollectUnicodeProcessNames

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Perflib

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines the source of process names displayed in performance tools, such as System Monitor.

This entry is designed to ensure that process names written in Unicode-based (2-byte-per-character) languages are displayed correctly in System Monitor.

Process names are displayed in System Monitor when a process is an instance of a performance object, such as when you select the Process performance object in the System Monitor Add to Chart dialog box.

By default, the Performance Library, which gathers data for System Monitor, reads process names from the process header. In the process header, data is stored in 1-byte-per-character ANSI fields and the characters in Unicode process names are truncated. When you set the value of CollectUnicodeProcessNames to 1, you direct the Performance Library to read full-character process names from the executable program files where they are stored in 2-byte-per-character Unicode format.

Value | Meaning
0 | Collect process names from the process header (1-byte-per-character ANSI format).
1 | Collect process names from the executable program file (2-byte-per-character Unicode format).

Activation method

To make changes to this entry effective, restart the Remote Registry Service or restart Windows 2000.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Collecting process names from executable files increases System Monitor overhead slightly. However, it is recommended whenever System Monitor is used on a computer configured to display a Unicode character set.


Configuration Flags

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Perflib

Data type | Range | Default value
REG_DWORD | 0x0 - 0x1F | 0x10

Description

Regulates the performance counter DLL run–time test feature. The Performance Library (Perflib) tests performance counter DLLs whenever you select a performance counter in System Monitor or a similar performance tool.

Perflib can perform tests to detect the following errors:

  • Slow procedure calls (non-trusted counter DLLs only).
  • Data buffer alignment errors.
  • Buffer integrity errors.
  • Function errors.
  • Program exceptions (critical).

The value of this entry determines which tests Perflib runs on trusted and non-trusted performance counter DLLs.

This value also determines how Perflib responds when a counter DLL fails a test. Perflib always records an error in the Application Log in Event Viewer (Source = Perflib). However, it can also disable the counter DLL, so that the counters are not displayed in any performance tool until you manually re-enable the DLL.

By default, Perflib uses the following test guidelines.

  • Time the procedure calls of non-trusted counter DLLs. When a procedure call is slow, record a message in the Application Log.
  • Test trusted and non-trusted counter DLLs for data buffer alignment errors. If a counter DLL fails the test, record a message in the Application Log.
  • Thoroughly test the integrity of buffers returned by non-trusted counter DLLs. If a counter fails the test, disable the counter.
  • Do not test the integrity of buffers returned by trusted counter DLLs, unless specified otherwise by the value of ExtCounterTestLevel. If a counter DLL fails a test required by the value of ExtCounterTestLevel, disable the counter.
  • Detect errors in the function calls of trusted and non-trusted counter DLLs. If an error is detected, record a message in the Application Log.
  • Detect program exceptions in the function calls of trusted and non-trusted counter DLLs. If a DLL generates an exception, disable the counters.

The value of this entry is a bitmask that you can use to change the default behavior. By default, only bit 0x10 (10000) is set. To select a behavior, set the bit representing the behavior to 1, or sum the values of all desired bits. For example, to prevent Perflib from testing for data buffer alignment (1 binary) and prevent Perflib from disabling counters (10 binary), set the value of this entry to 0x3 (11 binary).

Bit value | Test setting
0x0 | Use default test behavior.
0x1 (1 binary) | Do not test for data buffer alignment errors. (These are common errors that are not usually critical.) Perform all other tests.
0x2 (10 binary) | Do not disable counters. Perform all tests, but if a counter generates a function error or program exception, record a message in the Application Log.
0x4 (100 binary) | Do not time procedure calls or perform buffer integrity tests. (When set, the ExtCounterTestLevel entry and the entries that define a slow procedure call (see Notes below) are ignored.
0x8 (1000 binary) | Disable counters if their procedure calls are slow. (Non-trusted counter DLLs only.)
0x10 (10000 binary) | Collect debugging data.

Perflib performs reliability tests to identify and eliminate defective counter DLLs. One defective counter DLL can harm your Windows 2000 performance tools, preventing them from displaying any performance data and, in some cases, causing errors that shut down the system and start Dr. Watson for Windows 2000.

Activation method

To make changes to this entry effective, restart the Remote Registry Service or restart Windows 2000.

Note Image Note

Bit 0x2 (10) takes precedence over bit 0x8 (1000). If bit 0x2 is set, Perflib does not disable performance counters.

Perflib disables counters by setting the value of Disable Performance Counters for that service to 1. After you have repaired or replaced the counter DLL, you must re-enable them manually by changing the value of Disable Performance Counters to 1.

Perflib does not time the procedure calls of trusted counters. To determine whether the procedure call of a non-trusted counter is abnormally slow, Perflib uses the standards established by values of OpenProcedureWaitTime, Open Timeout, and Collect Timeout.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Tip Image Tip

If particular performance counters do not appear in your performance counter display tool, check the Application Log in Event Viewer for events recorded by Perflib.

Caution Image Caution

Run–time tests can perceptibly delay the appearance of performance data, but they protect the system's monitoring capability.

Related Entries

EventLogLevel

DisablePerformanceCounters

ExtCounterTestLevel


Disable Performance Counters

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Perflib

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Enables and disables the registry-based performance counters on this system.

If the value of this entry is 1, Perflib does not retrieve performance counter data from the registry. As a result, System Monitor and other tools that use the data cannot display it. Instead, when a program requests performance data from the registry, the system returns an error to the program explaining that the Performance Library (Perflib) service is disabled.

Value | Meaning
0 | Enables performance counters. Programs can retrieve performance data from the registry.
1 | Disables performance counters. Programs cannot retrieve performance data from the registry.

Activation method

To make changes to this entry effective, restart the Remote Registry Service or restart Windows 2000.

Note Image Note

This entry affects all performance counters on the system. To enable or disable the performance counters for a particular service, use Exctrlst.exe to add Disable Performance Counters to the Performance subkey for the service. Exctrlst is a tool on the Windows 2000 Resource Kit CD.

Tip Image Tip

If particular performance counters do not appear in your performance monitoring tool, check the Application Log in Event Viewer for events recorded by Perflib. When Perflib detects disabling errors in a counter DLL, it records an event in the log and sets the value of DisablePerformanceCounters (in the Services subkey) to 1 to disable the counters.

Caution Image Caution

If you change the value of this entry to 1, the Performance object and Performance counter lists in System Monitor will be empty. You will not be able to use System Monitor, or any tool that uses Performance Library data, to monitor your system.

Related Entries

DisablePerformanceCounters (Services subkey)


EventLogLevel

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Perflib

Data type | Range | Default value
REG_DWORD | 0 | 1 | 2 | 3 | 1

Description

Determines which events the Performance Library records in the Application Log in Event Viewer.

Value | Meaning
0 | No logging.
1 | Errors only.
2 | Errors and warnings.
3 | Errors, warnings, information, and success/failure conditions.

Consider increasing the value of this entry if you are encountering problems starting or running a performance tool. If you find Perflib errors in the Application Log, increase this value again to log more detail on future errors.

Activation method

To make changes to this entry effective, restart the Remote Registry Service or restart Windows 2000.

Note Image Note

This entry has a different effect on Windows 2000 than it has on Windows NT 4.0 and earlier. In Windows NT 4.0 and earlier, it determines the logging level for extensible counters only. For more information, see Regentry.hlp in the Windows NT Resource Kits 4.0.

If a remote computer is using System Monitor to monitor the local computer, you must restart Windows 2000 on the local computer and stop and restart System Monitor on the remote computer before changes to this entry take effect.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Tip Image Tip

If particular performance counters do not appear in your performance monitoring tool, check the Application Log in Event Viewer for events recorded by Perflib. When Perflib detects disabling errors in a counter DLL, it records an event in the log and sets the value of DisablePerformanceCounters to 1 to disable the counters.

Related Entries

ExtCounterTestLevel

ReportEventsToEventLog

(Performance Monitor 4)


ExtCounterTestLevel

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Perflib

Data type | Range | Default value
REG_DWORD | 1 | 2 | 3 | 4 | 4

Description

Determines the extent to which Perflib tests the data buffers of trusted performance counter DLLs.

If a counter DLL fails the buffer integrity test specified by the value of this entry, then, by default, Perflib records an error in the Application Log (Source = Perflib) and disables the counters. Perflib does not load the counters again until you have manually reenabled them.

Value | Meaning
1 | High. The Performance Library tests the pointers and buffers of returned by trusted counter DLLs thoroughly. To protect the user's buffer from damage, Perflib sends the function a copy of the buffer, instead of the actual buffer.
2 | Medium. The Performance Library checks pointers and buffer length, but does not test pointer references or buffer contents. It sends the DLL function a copy of the user's buffer so the actual buffer is not damaged.
3 | Low. The Performance Library does not test pointers or buffers. However, it does send the trusted counter function a copy of the user's buffer so the actual buffer is not damaged.
4 | None. The Performance Library does not test pointers or buffers, and it sends the user's buffer; not a copy. This value minimizes System Monitor overhead, especially when monitoring applications that require large performance data buffers.

Perflib tests the integrity of data buffers to identify and eliminate defective counter DLLs. One defective counter DLL can harm your Windows 2000 performance tools, preventing them from displaying any performance data and, in some cases, causing errors that shut down the system and start Dr. Watson for Windows 2000.

Activation method

To make changes to this entry effective, restart the Remote Registry Service or restart Windows 2000.

Note Image Note

The data buffer integrity test is one of several Perflib run-time reliability tests. To configure the Perflib test feature, use the Configuration Flags entry.

If the 0x4 bit (100) is set in the value of Configuration Flags, Perflib does not perform data buffer integrity tests on any counters, including trusted counters.

To prevent Perflib from disabling counters when they fail a test, set the 0x2 (10) bit in the value of Configuration Flags. This bit prevents Perflib from disabling any counters that fail any tests. It is not specific to trusted counters or data buffer integrity tests.

Perflib disables counter by setting the value of Disable Performance Counters for that service to 1. After you have repaired or replaced the counter DLL, you must re-enable them manually by changing the value of Disable Performance Counters to 1.

This entry has a different effect on Windows 2000 than it has on Windows NT 4.0 and earlier. In Windows NT 4.0 and earlier, it determines the testing level for extensible counters. For more information, see Regentry.hlp in the Windows NT Resource Kit 4.0.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Tip Image Tip

If a performance counter does not appear in your performance monitoring tool, check the Application Log in Event Viewer for events recorded by Perflib.

Related Entries

Configuration Flags

EventLogLevel

Library Validation Code

DisablePerformanceCounters


OpenProcedureWaitTime

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Perflib

Data type | Range | Default value
REG_DWORD | 0x0 - 0xEE6B2800 milliseconds | 0x2710 (10 seconds)

Description

Defines a slow Open procedure call for the performance counters DLLs on this system.

When an Open procedure call takes longer to complete than the time specified in this entry then, by default, Perflib records an error in the Application Log. However, if the value of Configuration flags is0x0, Perflib disables the counter DLL and does not load the counters again until you have manually reenabled them.

Perflib times the procedure calls of non-trusted counters to identify counters that can delay or lock performance tools during initialization. While the Open procedure call proceeds, you cannot use the performance tools, and remote users cannot log on to the local computer.

Activation method

To make changes to this entry effective, restart the Remote Registry Service or restart Windows 2000.

Note Image Note

Perflib disables counter by setting the value of Disable Performance Counters for that service to 1. After you have repaired or replaced the counters, you must re-enable them manually by changing the value of Disable Performance Counters to 1.

Perflib does not time the procedure calls of trusted performance counter DLLs This entry applies only to non-trusted DLLs.

This entry applies to all counter DLLs on this system. To adjust the Open procedure time for the counters of a particular service, use the Open Timeout entry.

The value of this entry is also the default value of the Collect Timeout entry.

This entry has a different effect on Windows 2000 than it has on Windows NT 4.0 and earlier. In Windows NT 4.0 and earlier, it determines the Open procedure wait time only for extensible counters. For more information, see Regentry.hlp in the Windows NT Resource Kit 4.0.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Tip Image Tip

If you suspect problems with procedure calls, check the Application Log in Event Viewer. Perflib records an error in the log whenever a procedure call exceeds its limit.

Related Entries

Open Timeout

Configuration flags

Collect timeout


TotalInstanceName

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Perflib

Data type | Range | Default value
REG_SZ | String | _Total

Description

Specifies an alternate name for the _Total instance in performance tools, such as System Monitor.

The _Total instance represents the sum of values for all other instances of a performance object. For example, the _Total instance of Logical Disk: % Disk Time represents the sum of active time for all logical partitions on the computer. You can use this entry to change the name of the _Total instance as it appears in your performance tools.

Activation method

To make changes to this entry effective, restart the Remote Registry Service or restart Windows 2000.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Tip Image Tip

If particular performance counters do not appear in your performance monitoring tool, check the Application Log in Event Viewer for events recorded by Perflib. When Perflib detects disabling errors in a counter DLL, it records an event in the log and sets the value of DisablePerformanceCounters to 1 to disable the counters.


Print

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\

Description

The Print subkey stores hardware information for printers that applies to all users of the computer.

Note Image Note

For more information on printing with Windows 2000, see the Windows 2000 Professional Resource Kit.

Related Entries

Print subkey in HKEY_LOCAL_MACHINE\SYSTEM


Printers

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\

Description

The Printers subkey contains information about the local priters.

Note Image Note

The printers listed in this subkey can be shared, or they can only be accessible to the host computer.

The entries in this subkey are linked to the Print\Printers entries that appear in the SYSTEM key. Changes made in this subkey will be reflected in the SYSTEM key.

Related Entries

Printers subkey in HKEY_CURRENT_USER

Printers subkey for local printers in SYSTEM

Printers subkey for LanMan Print Services network printers


<printer-name>

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Printers\

Description

The <printer-name> subkey is a variable representing the subkeys under the Printers subkey. It does not actually appear in the registry. This variable subkey displays information which is common to the subkeys in the Printers subkey.

This subkey stores information about printers connected to the print server.

The subkeys and entries which appear in this subkey are backed up in the Printers subkey in HKEY_LOCAL_MACHINE\SYSTEM. Any changes made in the SOFTWARE\Printers subkey will be reflected in the SYSTEM\Printers subkey.

Note Image Note

This subkey appears only on servers which host local printers. It does not appear on computers which only connect to network printers.

Related Entries

<printer-name> subkey for local printers

<printer-name> subkey for LanMan Print Services Printers

Printers subkey in HKEY_LOCAL_MACHINE\SYSTEM


PrinterDriverData

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Printers\<printer-name>\

Description

The PrinterDriverData subkey contains information about the drivers for the printer.

Related Entries

PrinterDriverData subkey for LanMan Print Services network printers


Transparency

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Printers\<printer-name>\PrinterDriverData

Data type | Range | Default value
REG_DWORD | (blank) | 1 | There is no default value for this entry.

Description

Specifies the background mode when Winprint_TextNoCRTranslation is set to 1. If the background mode is set to transparent, the driver will not print the background of the document, regardless of color.

Value | Meaning
(blank) | Background is opaque.
1 | Background is transparent.

Related Entries

Winprint_TextNoCRTranslation


Winprint_TextNoCRTranslation

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Printers\<printer-name>\PrinterDriverData

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Enables or disables carriage return translation.

By default, Windows 2000 will translate a carriage return to a carriage return plus a line feed.

Value | Meaning
0 | Carriage returns will be translated to a carriage return plus a line feed.
1 | Carriage return translation disabled.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


Winprint_TextNoTranslation

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Printers\<printer-name>\PrinterDriverData

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Enables or disables carriage return and line feed translation.

By default, Windows 2000 will translate a carriage return or a line feed to a carriage return plus a line feed.

Value | Meaning
0 | Carriage returns and line feeds will be translated to a carriage return plus a line feed.
1 | Carriage return and line feed translation disabled.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


SpoolDirectory

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Printers\<printer-name>

Data type | Range | Default value
REG_SZ | path | There is no default value for this entry.

Description

Specifies the folder which holds spooled files for the specified local printer.

Note Image Note

This entry appears only on servers which are print servers. It does not appear on computers which host local printers.


DefaultSpoolDirectory

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Printers

Data type | Range | Default value
REG_SZ | path | Systemroot\System32\spool\PRINTERS

Description

Specifies the folder which holds spooled files that are being printed by this system on a local printer.

This entry is backed up in the Printers SYSTEM subkey. Any changes made to this entry in the SOFTWARE key will be reflected in the SYSTEM key.

Related Entries

DefaultSpoolDirectory in the SYSTEM subkey

DefaultSpoolDirectory for network printers

Printers in teh SYSTEM key


Providers

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\

Description

The Providers subkey contains information about the network printers. The printers listed in this subkey are not hosted locally, but are printers to which the local computer is connected.

Related Entries

Providers subkey in the SYSTEM key

Providers subkey in the <server-name> subkey


LanMan Print Services

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Providers\

Description

The LanMan Print Services subkey stores configuration data for the LanMan Print Services, the default print provider for Windows 2000.

Note Image Note

In Windows NT 4.0 and earlier, this subkey was in the Providers subkey in SYSTEM.


Servers

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Providers\LanMan Print Services\

Description

The Servers subkey contains subkeys and entries that store configuration data for LanMan Print Services, the default print provider for Windows 2000.

Related Entries

Servers subkey in the SYSTEM key


<server-name>

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Providers\LanMan Print Services\Servers\

Description

The <server-name> subkeys stores information about printers connected to the specified print server.

Note Image Note

The <server-name> subkey is a variable representing the subkeys under the Servers subkey. It does not actually appear in the registry. This variable subkey displays information which is common to the subkeys in the Servers subkey.


BeepEnabled

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Providers\LanMan Print Services\Servers\<server-name>

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether the computer beeps when a remote print job is in error.

Value | Meaning
0 | The computer does not beep each time a print job is retried.
1 | The computer beeps each time the job is retried.

By default, a print job is resubmitted every 10 seconds. The beep will occur on the same computer that displays popups, which is determined by the value of NetPopupToComputer.

Note Image Note

The value of this entry in the <server-name> subkey applies only to print jobs sent to the specified network server. The value of BeepEnabled in the Print subkey applies to local print jobs.

Related Entries

BeepEnabled for local printers


Forms

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Providers\LanMan Print Services\Servers\<server-name>\

Description

The Forms subkey in the <server-name> subkey stores information about the different printing forms available to the printer.

These forms include envelopes and paper sizes. Each of the forms has the REG_BINARY data type.


Printers

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Providers\LanMan Print Services\Servers\<server-name>\

Description

The Printers subkey in the Providers subkey contains information about the individual network printers to which the local computer is connected.

Related Entries

Printers subkey in HKEY_CURRENT_USER

Printers subkey for local printers in SOFTWARE

Printers subkey for local printers in SYSTEM


<printer-name>

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Providers\LanMan Print Services\Servers\<server-name>\Printers\

Description

The <printer-name> subkeys in the <server-name>\Printers subkeys stores information about the individual network printers to which the local computer is connected.

Note Image Note

You must have Manage Printers permissions on the printer in order to change the settings in this subkey.

The <printer-name> subkey is a variable representing the subkeys under the Printers subkey. It does not actually appear in the registry. This variable subkey displays information which is common to the subkeys in the Printers subkey.

Related Entries

<printer-name> subkey for local printers

<printer-name> subkey in SOFTWARE


Datatype

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Providers\LanMan Print Services\Servers\<server-name>\Printers\<printer-name>

Data type | Range | Default value
REG_SZ | dataype | RAW

Description

Lists the default datatype associated with this printer.

The default datatype is used if the application does not specify a datatype. Most Windows 2000 applications use the EMF datatype by default.

Change method

To change the value of this entry, click Start, point to Settings, and then select Printers. Right-click the printer name, and then select Properties. Click the Advanced tab, click the Print Processor button, and then select a data type from the Default datatype list box.

Note Image Note

Most MS-DOS clients, Windows for Workgroups clients, and Windows 95/98 clients will fail when they attempt to use the printer if you specify a datatype other than RAW.

You must have Manage Printers permissions on the printer to be able to change this setting.


Default Priority

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Providers\LanMan Print Services\Servers\<server-name>\Printers\<printer-name>

Data type | Range | Default value
REG_DWORD | -1 | 0 | 1 | 0

Description

Describes the printing priority for network printers.

Value | Meaning
-1 | Low
0 | Normal
1 | High

Note Image Note

You must be an Administrator on the print server to be able to change this setting.

Related Entries

DefaultPriority in the Printers subkey (local printers)


Description

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Providers\LanMan Print Services\Servers\<server-name>\Printers\<printer-name>

Data type | Range | Default value
REG_SZ | String | There is no default value for this entry.

Description

Stores the information which appears in the Comment box of the Printers properties box for network printers.

Change method

To change the value of this entry, click Start, point to Settings, and then select Printers. Right-click the printer name, and then select Properties. Click the General tab, and then enter any text in the Comment text box.

Note Image Note

You must have Manage Printers permissions to be able to change this setting.

Related Entries

Description for local printers


DsDriver

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Providers\LanMan Print Services\Servers\<server-name>\Printers\<printer-name>\

Description

The DsDriver subkey contains entries which contain information about the printer and the driver.


DsSpooler

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Providers\LanMan Print Services\Servers\<server-name>\Printers\<printer-name>\

Description

The DsSpooler subkey contains entries which describe the published attributes of the spooler.


Location

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Providers\LanMan Print Services\Servers\<server-name>\Printers\<printer-name>

Data type | Range | Default value
REG_SZ | String | There is no default value for this entry.

Description

Describes the physical location of a network printer. This corresponds with the Location box in the Printers properties box.

Change method

To change the value of this entry, click Start, point to Settings, and then select Printers. Right-click the printer name, and then select Properties. Click the General tab, and then enter any text in the Location text box.

Note Image Note

You must have Manage Printers permissions on the printer to be able to change this setting.

Related Entries

Location for local printers


Name

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Providers\LanMan Print Services\Servers\<server-name>\Printers\<printer-name>

Data type | Range | Default value
REG_SZ | string | (There is no default value for this printer.)

Description

Contains the name of the specified network printer.

Change method

To change the value of this entry, click Start, point to Settings, and then select Printers. Right-click the printer name, and then select Properties. Click the General tab, and then enter the printer name in the text box next to the printer icon.

Note Image Note

You must have Manage Printers permissions on this printer to be able to change this setting.


PnPData

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Providers\LanMan Print Services\Servers\<server-name>\Printers\<printer-name>\

Description

The PnPData subkey contains entries which contain information about the installed printers.


Manufacturer

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Providers\LanMan Print Services\Servers\<server-name>\Printers\<printer-name>\PnPData

Data type | Range | Default value
REG_SZ | manufacturer name | (Depends on printer.)

Description

Contains the name of the manufacturer of the specified printer.


OEM URL

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Providers\LanMan Print Services\Servers\<server-name>\Printers\<printer-name>\PnPData

Data type | Range | Default value
REG_SZ | URL | (Depends on printer.)

Description

Contains the URL to the printer manufacturer.

This URL providers a link to the OEM web site on printer driver information. This appears as a link in the left pane of the printers folder when you click on a printer from that manufacturer. If a URL is not specified, a link to Microsoft support is included instead.


Print Processor

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Providers\LanMan Print Services\Servers\<server-name>\Printers\<printer-name>

Data type | Range | Default value
REG_SZ | processor name | winprint

Description

Contains the name of the print processor for the specified network printer.

Change method

To change the value of this entry, click Start, point to Settings, and then select Printers. Right-click the printer name, and then select Properties. Click the Advanced tab, click the Print Processor button, and then select a print processor from the list.

Note Image Note

You must have Manage Printers permissions on the printer to be able to change this setting.

Related Entries

PrintProcessor for local printers


Printer Driver

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Providers\LanMan Print Services\Servers\<server-name>\Printers\<printer-name>

Data type | Range | Default value
REG_SZ | driver name | (Depends on printer.)

Description

Contains the name of the printer driver for the specified network printer.

Change method

To change the value of this entry, click Start, point to Settings, and then select Printers. Right-click the printer name, and then select Properties. Click the Advanced tab, and either select a driver from the Driver drop-down list or click the New Driver button to install a new driver using the Add Printer Driver Wizard.

Note Image Note

You must have Manage Printers access on the printer to be able to change this setting.

Related Entries

Printer Driver for local printers


PrinterDriverData

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Providers\LanMan Print Services\Servers\<server-name>\Printers\<printer-name>\

Description

The PrinterDriverData subkey in the Providers subkey contains information about the drivers for the network printers to which the specified server is connected. The entries that appear in this subkey are determined by the installed driver.

Related Entries

PrinterDriverData subkey for local printers


DependentFiles

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Providers\LanMan Print Services\Servers\<server-name>\Printers\<printer-name>\PrinterDriverData

Data type | Range | Default value
REG_MULTI_SZ | filenames | (Depends on printer driver.)

Description

Lists the names of additional files required by the system for printing.

These files are stored in Systemroot\WINNT\system32\spool\drivers\<environment-name>\<version-number>.

Related Entries

DependentFiles in the <printer-name> subkey in the Environments subkey


Priority

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Providers\LanMan Print Services\Servers\<server-name>\Printers\<printer-name>

Data type | Range | Default value
REG_DWORD | 1 - 99 | 1

Description

Indicates priority of the specified network printer.

A higher value indicates higher priority. If two print queues are sending jobs to the same port, the queue with the higher priority will print first.

Change method

To change the value of this entry, click Start, point to Settings, and then select Printers. Right-click the printer name, and then select Properties. Click the Advanced tab, and then select a value from the Priority box.

Note Image Note

You must have Manage Printers access on the printer to be able to change this setting.

To set the print priority for a specific document, click Start, point to Settings, and then select Printers. Double-click the printer name, and then select the document whose priority you want to change. From the Document menu, select Properties, and then click the General tab. Use the Priority slider to set the priority.

Related Entries

Priority for local printers


Security

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Providers\LanMan Print Services\Servers\<server-name>\Printers\<printer-name>

Data type | Range | Default value
REG_BINARY | Binary value | (Binary value.)

Description

Stores security settings for the specified network printer.

Change method

To change the security settings, click Start, point to Settings, and then select Printers. Double-click the printer name, and then click the Security tab.

Note Image Note

You must have Manage Printer permissions on the printer to be able to change this setting.


Separator File

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Providers\LanMan Print Services\Servers\<server-name>\Printers\<printer-name>

Data type | Range | Default value
REG_SZ | path and filename | There is no default value for this entry.

Description

Contains that path and file name for the separator page for the specified network printer.

Change method

To change the value of this entry, click Start, point to Settings, and then select Printers. Right-click the printer name, and then select Properties. Click the Advanced tab, click the Separator Page button, and then enter a path and file name or select the file from the browse list.

Note Image Note

You must have Manage Printer permissions on the print server to be able to change this setting.

Related Entries

Separator File for local printers


Share Name

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Providers\LanMan Print Services\Servers\<server-name>\Printers\<printer-name>

Data type | Range | Default value
REG_SZ | share name | share name

Description

Contains the name of the specified network printer on the printer server.

Change method

To change the value of this entry, click Start, point to Settings, and then select Printers. Right-click the printer name, and then select Properties. Click the Sharing tab, click the Shared as radio button, and then enter the share name in the text box.

Note Image Note

You must have Manage Printers permissions on the printer to be able to change this setting.

Related Entries

Share Name for local printers


SpoolDirectory

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Providers\LanMan Print Services\Servers\<server-name>\Printers\<printer-name>

Data type | Range | Default value
REG_SZ | path | There is no default value for this entry.

Description

This entry is not used by and has no effect on Windows 2000.


StartTime

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Providers\LanMan Print Services\Servers\<server-name>\Printers\<printer-name>

Data type | Range | Default value
REG_DWORD | 0x0 - 0x59F (almost 24 hours) minutes since 4:00 P.M. | 0x0

Description

Stores the availability start time of the specified network printer.

Change method

To change the value of this entry, click Start, point to Settings, and then select Printers. Right-click the printer name, and then select Properties. Click the Advanced tab, click the Available from radio button, and then select a time from the spin box.

Note Image Note

You must have Manage Printers permission on the printer to be able to change this setting.

Related Entries

StartTime for local printers


UntilTime

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Providers\LanMan Print Services\Servers\<server-name>\Printers\<printer-name>

Data type | Range | Default value
REG_DWORD | 0x0 - 0x59F (almost 24 hours) minutes since 4:00 P.M. | 0x0

Description

Stores the availability end time of the specified network printer.

Change method

To change the value of this entry, click Start, point to Settings, and then select Printers. Right-click the printer name, and then select Properties. Click the Advanced tab, click the Available from radio button, and then select a time from the Tospin box.

Note Image Note

You must have Manage Printers permissions on the printer to be able to change this setting.

Related Entries

UntilTime for local printers


DefaultSpoolDirectory

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Providers\LanMan Print Services\Servers\<server-name>\Printers

Data type | Range | Default value
REG_SZ | path | Systemroot\System32\spool\PRINTERS

Description

This entry is not used by and has no effect on Windows 2000.

Related Entries

DefaultSpoolDirectory for local printers

DefaultSpoolDirectory in the SOFTWARE subkey


Providers

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Providers\LanMan Print Services\Servers\<server-name>\

Description

The Providers subkey in the <server-name> subkey stores configuration data used by the specified server.

Related Entries

Providers subkey in the SYSTEM key

Providers subkey in the SOFTWARE key


EventLog

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Providers\LanMan Print Services\Servers\<server-name>\Providers

Data type | Range | Default value
REG_DWORD | 0x0 - 0x1F (bitmask) | Windows 2000 Professional: 0x1B (11011) Windows 2000 Server: 0x1F (11111)

Description

Specifies the level of detail of events logged by the print spooler for the specified server.

The value of this entry is a bitmask. To direct the print spooler to log entries of the type specified, set the bit representing that type to 1, or sum the hexadecimal values of all desired types. For example, the default value for Windows 2000 Server, 11111, indicates that the print spooler logs all events. The default value for Windows 2000 Professional, 11011 indicates that the print spooler logs all events except information.

Value | Event type
0x0 (0 binary) | Success
0x1 (1 binary) | Error
0x2 (10 binary) | Warning
0x4 (100 binary) | Information
0x8 (1000 binary) | Audit success
0x10 (10000 binary) | Audit failure

Change method

To change the value of this entry, click Start, click Settings, and then click Printers. From the File menu, click Server Properties, click the Advanced tab, and then select or clear the check boxes representing each event type.

Related Entries

EventLog for local printers


NetPopup

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Providers\LanMan Print Services\Servers\<server-name>\Providers

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether or not users are notified when print jobs on remote printers are complete.

The value of this entry in the <server-name> subkey affects all and only the printers on that server.

Value | Meaning
0 | Users are not notified.
1 | A message appears on the user's display when remote print jobs that they have submitted are complete.

Change method

To change the value of this entry, click Start, point to Settings, and then click Printers. From the File menu, click Server Properties, and then click the Advanced tab. This entry corresponds to the Notify when remote documents are printed option.

Note Image Note

You must be an administrator on the print server to be able to change this setting.

Related Entries

NetPopup for local printers


NetPopupToComputer

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Providers\LanMan Print Services\Servers\<server-name>\Providers

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Specifies if print notifications for network print jobs should be sent to the printer that printed the document or to the user.

Value | Meaning
0 | Popups are sent to the printer that printed the document.
1 | Popups are sent to the printer on the network that the user who printed the document first logged on to.

Change method

To change the value of this entry for a local printer, click Start, point to Settings, and then click Printers. From the File menu, click Server Properties, and then click the Advanced tab. This entry corresponds to the Notify computer, not user when remote documents are printed option.

To change the value of this entry for a network printer, connect to the printer server and double-click the printer. From the File menu, click Server Properties, and then click the Advanced tab. This entry corresponds to the Notify computer, not user when remote documents are printed option.

Related Entries

NetPopupToComputer for local printers


RestartJobOnPoolEnabled

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Providers\LanMan Print Services\Servers\<server-name>\Providers

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether a print job on the specified network printer can be restarted after an error.

If the value of this entry is set to 1, a "Cancel/Retry" dialog box will appear on the user's system for the value of RestartJobOnPoolError.

Value | Meaning
0 | The job cannot be restarted on error.
1 | Print jobs can be restarted on error.

Note Image Note

This entry applies only to pooled printers.

Related Entries

RestartJobOnPoolEnabled for local printers

RestartJobOnPoolError


RestartJobOnPoolError

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Providers\LanMan Print Services\Servers\<server-name>\Providers

Data type | Range | Default value
REG_DWORD | number of seconds | 0x00000258 (600 seconds = 10 minutes)

Description

Determines how long the print monitor for the specified network printer waits before starting a print job on another port in the print pool if an error occurs.

Note Image Note

This entry applies only to pooled printers.

Both the print monitor and the printer must support SNMP.

Related Entries

RestartJobOnPoolError for local printers


RetryPopup

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Providers\LanMan Print Services\Servers\<server-name>\Providers

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether Retry/Cancel popups appear when an error occurs on jobs printed to a network printer.

Value | Meaning
0 | Popups do not appear.
1 | Popups appear on the print server.

Related Entries

RetryPopup for local printers


LoadTrustedDrivers

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Providers\LanMan Print Services\Servers

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines the source of drivers for the print service provider.

Value | Meaning
0 | Drivers can be installed from any remote print server.
1 | Drivers can be installed only from the trusted print server shares specified by the value of TrustedDriverPath.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

TrustedDriverPath


SyncOpenPrinter

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Providers\LanMan Print Services\Servers

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether requests sent to the spooler are synchronous or asynchronous.

If requests are synchronous, print jobs are printed in the order in which they begin spooling. This might cause jobs that have finished spooling to wait for jobs that began spooling first, but are not yet complete.

Value | Meaning
0 | Print requests are processed asynchronously. Print jobs begin printing as soon as data is spooled.
1 | Print requests are processed synchronously. Print jobs are printed in the order in which their first bytes are spooled.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


TrustedDriverPath

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Providers\LanMan Print Services\Servers

Data type | Range | Default value
REG_DWORD | Path | There is no default value for this entry.

Description

Contains the path to trusted print server shares from which you can install printer drivers. If the value of LoadTrustedDrivers is 1, you can only install drivers from the server shares located in the path specified in the value of this entry.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

LoadTrustedDrivers


Type 1 Installer

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\

Description

The Type 1 Installer subkey contains subkeys which store information about the Type 1 fonts installed on the system.


Type 1 Fonts

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Type 1 Installer\

Description

The Type 1 Fonts subkey contains the names of the Type 1 fonts which are installed on the system.

The fonts are stored in the Systemroot\WINNT\Fonts folder, and the corresponding entries have the following format:

font name REG_SZ file name


Windows

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\

Description

The Windows subkey stores configuration data used by 16-bit Windows 3.x applications running on Windows 2000 and earlier.

Related Entries

Windows subkey (HKCU\Software)

Windows subkey (HKLM\System\CurrentControlSet\Control\Windows)


AppInit_DLLs

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Windows

Data type | Range | Default value
REG_SZ | DLL file names | (Blank value)

Description

Specifies which dynamic-link libraries (DLLs) installed on the computer are loaded by Windows 3.x–based applications.


DeviceNotSelectedTimeout

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Windows

Data type | Range | Default value
REG_SZ | Number of seconds (in decimal) | 15

Description

This entry is not used by and has no effect on Windows 2000. It remains in the registry to support applications which were written for Windows 3.51 and earlier.


swapdisk

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Windows

Data type | Range | Default value
REG_SZ | Drive:Directory | The directory indicated by the the value of TEMP (or, if there is no TEMP environment variable, the boot directory of the first hard drive, which is usually C:).

Description

This entry is not used by and has no effect on Windows 2000. It remains in the registry to support applications which were written for Windows 4.0 and earlier.


TransmissionRetryTimeout

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Windows

Data type | Range | Default value
REG_SZ | Number of seconds (in decimal) | Windows NT 3.1: 45 Windows NT 3.51 and later: 90

Description

This entry is not used by and has no effect on Windows 2000. It remains in the registry to support applications which were written for Windows 3.51 and earlier.


Winlogon

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\

Description

The Winlogon subkey stores configuration data for the Winlogon service. Winlogon provides support for interactive logon to Windows 2000.

The Winlogon subkey of HKEY_LOCAL_MACHINE\Software stores data that applies to all users of the computer. There is also a Winlogon subkey in HKEY_CURRENT_USER that stores user-specific settings for Winlogon.

Related Entries

Winlogon subkey ( HKCU)


allocatecdroms

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

Data type | Range | Default value
REG_SZ | 0 | 1 | 0

Description

Restricts access to data in the CD-ROM drive.

Value | Meaning
0 | Administrators in the domain can gain access to compact discs in the CD-ROM drive.
1 | Only the user logged on locally can gain access to data on the compact discs in the CD-ROM drive.

Because the CD-ROM drive is a volume, by default, it is shared as an administrative share on the network. If the value of this entry is 1, the CD-ROM drive is allocated to the user as part of the interactive logon process and, therefore, only the current user can access it. This prevents administrators and remote users (and even the same user at a different computer) from accessing the drive while the current user is logged on. The drive is shared again when the current user logs off.


allocatedasd

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

Data type | Range | Default value
REG_SZ | 0 | 1 | 2 | 0

Description

Determines which users can format and eject removable hard disks.

Value | Meaning
0 | Only administrators of the computer.
1 | Only administrators and power users.
2 | Only administrators and the local current user.


allocatefloppies

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

Data type | Range | Default value
REG_SZ | 0 | 1 | 0

Description

Restricts access to data in the floppy disk drive.

Value | Meaning
0 | Administrators in the domain can gain access to compact discs in the floppy disk drive.
1 | Only the user logged on locally can gain access to data on the floppy disks in the floppy disk drive.

Because the floppy disk drive is a volume, by default it is shared as an administrative share on the network. If the value of this entry is 1, the floppy disk drive is allocated to the user as part of the interactive logon process and, therefore, only the current user can access it. This prevents administrators and remote users (and even the same user at a different computer) from accessing the drive while the current user is logged on. The drive is shared again when the current user logs off.


AutoAdminLogon

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

Data type | Range | Default value
REG_SZ | 0 | 1 | 0

Description

Determines whether the automatic logon feature is enabled. Automatic logon uses the domain, user name, and password stored in the registry to log you on to the computer when the system starts. The Log On to Windows dialog box is not displayed.

Value | Meaning
0 | Disables automatic logon.
1 | Enables automatic logon.

Activation method

You must log off of Windows 2000, shut down the computer, and start it again before changes to this entry take effect.

Note Image Note

Automatic logon requires that DefaultDomainName and DefaultUserName appear in the registry with valid values.

Caution Image Caution

Automatic logon allows other users to start your computer and log on using your account.

Because automatic logon proceeds in a different order than an authenticated logon, it can cause timing conflicts. If you are loading several network transport protocols, automatic logon might cause Windows 2000 to attempt to connect to network resources before the protocols network transports are completely loaded.

If you disable automatic logon by setting the value of AutoAdminLogon to 0, remember to delete the value of DefaultPassword, which is stored and displayed in your registry editor in plain, unencrypted text.

Related Entries

DefaultDomainName

DefaultUserName


AutoRestartShell

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

Data type | Range | Default value
REG_DWORD | 1

Description

Determines whether the Windows 2000 user interface (typically, Explorer.exe) is restarted automatically if it stops unexpectedly.

Value | Meaning
0 | If the Windows 2000 user interface or one of its components fails, you must restart the interface by logging off and logging on again.
1 | If the Windows 2000 user interface or one of its components fails, the interface is restarted automatically.


CachedLogonsCount

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

Data type | Range | Default value
REG_SZ | 0 - 50 entries (decimal) | 10

Description

Determines how many user account entries are saved in the logon cache on the local computer. Windows 2000 saves user account information used to log on to the computer so it can be used in the event that the user's domain controller is unavailable.

If the value of this entry is 0, Windows 2000 does not save any user account information in the logon cache. In this case, if the user's domain controller is not available and the user tries to log on a computer that does not have their account information, Windows 2000 displays the following message:

"The system cannot log you on now because the domain <Domain-name> is not available."

Activation method

You must restart Windows 2000 to make changes to this entry effective.


CachePrimaryDomain

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

Data type | Range | Default value
REG_SZ | SYS-WINNT

Description

This entry is not used by Windows 2000. It is ignored by the system, so you do not need to delete it.


DCacheMinInterval

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

Data type | Range | Default value
REG_SZ | 120 - 86,400 seconds | 120 (2 minutes)

Description

Determines how often the list of domains in the Unlock Workstation dialog box is updated. The list of domains is updated before it is displayed to the user if its age exceeds the value of DcacheMinInterval.

The domain list saved in a memory cache on the local computer. When the user unlocks a workstation (or server), if the list is more than two minutes old (the default), the system retrieves domain data and updates the list. The short update interval ensures that the domain list is current. However, refreshing the list can cause a noticeable delay.

You can use this entry to increase the time between domain list updates and eliminate some of the delay. However, if the domain list changes between updates, users might not see the most current list of domains.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


DCacheUpdate

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

Data type | Range | Default value
REG_BINARY | Domain names in binary form | There is no default value for this entry.

Description

Stores domain names in binary form for use by internal Winlogon programming code.

Caution Image Caution

This entry is stored by Winlogon for its own use. Do not delete this entry or change its value. If you do, Windows 2000 might not operate properly.


DebugServerCommand

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

Data type | Range | Default value
REG_SZ | no

Description

This entry is not used by Winlogon in Windows 2000.


DefaultDomainName

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

Data type | Range | Default value
REG_SZ | Domain-name | NEWDOMAIN

Description

Stores the name of the domain onto which the user last logged on successfully. The value of this entry appears in the Log On to Windows dialog box the next time it is displayed.

Related Entries

AutoAdminLogon

DefaultUserName


DefaultUserName

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

Data type | Range | Default value
REG_SZ | User-name | Administrator

Description

Stores the last user name entered in the Log On to Windows dialog box.

The value of this entry appears in the Log On to Windows dialog box the next time it is displayed. It is also used in automated logons and unattended setup.

Note Image Note

This entry is required if you have configured Windows 2000 to log on automatically by setting the value of AutoAdminLogon to 1.

Tip Image Tip

If you delete the value of this entry, the system restores it the next time a user logs on to Windows 2000. To specify that the user name field in the Log On to Windows dialog box be blank, set the value of DontDisplayLastUserName to 1.

Related Entries

AutoAdminLogon

DefaultDomainName

DontDisplayLastUserName


DeleteRoamingCache

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether a copy of a user's roaming profile is saved on this computer when the user logs off.

Roaming profiles reside on a network server. But, by default, when users with roaming profiles log off, the system also saves a copy of their roaming profile on the hard drive of the computer they are using in case the server that stores the roaming profile is unavailable when the user logs on again.

Value | Meaning
0 | A copy of the user's roaming profile is saved on the hard drive of this computer when they log off.
1 | Any copies of the user's roaming profile on this computer are deleted when the user logs off. The roaming profile still remains on the server that stores it. This setting is designed to conserve disk space on this computer.

Note Image Note

This entry can be superceded by a policy included in Windows 2000. While the Delete cached copies of roaming profiles Group Policy is enabled, the system ignores this entry. The Delete cached copies of roaming profiles setting is stored in the value of DeleteRoamingCache.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.


disablecad

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

Data type | Range | Default value
REG_DWORD | 0 | 1 | Windows 2000 Server: 0 Windows 2000 Professional: 1 (See notes)

Description

Determines whether users must press the Ctrl+Alt+Del security attention sequence to log on to Windows 2000.

If the value of this entry is 0, the Log On to Windows dialog box is displayed as soon as the system starts. The Windows 2000 splash screen bearing the Press Ctrl-Alt-Delete to begin message is suppressed.

Value | Meaning
0 | Users must press Ctrl+Alt+Del to log on to the system.
1 | Users need not press Ctrl+Alt+Del to log on to the system.

Setting the value of this entry to 1 can compromise system security. Because only Windows responds to the Ctrl+Alt+Del security sequence, you can be assured that any passwords you enter following that sequence are sent only to Windows. If you eliminate the sequence requirement, malicious programs can request and receive your Windows password.

Change method

To set a policy related to this entry, use Security Settings in Group Policy.

Disable CTRL+ALT+DEL requirement for logon Computer Configuration\Windows Settings\Security Settings\Local Policies\Security Options

Activation method

To make changes to this entry effective, you must restart Windows 2000.

Note Image Note

This value can be overridden by a security policy. If your system does not respond as expected, see you system administrator.

The default value of disablecad is 0 on Windows 2000 Server and 1 on Windows 2000 Professional. However, when a computer running Windows 2000 Professional joins a domain, the system sets disablecad to 0. Also, if your computer includes a component that requires a domain account, such as a smart card reader, you must set this value to 0.

Setting this value to 1 suppresses the Computer Locked dialog box. When you press Ctrl+Alt+Del and then click Lock Computer, the Unlock Computer dialog box appears immediately.

A setting of 1 suppresses a custom logon banner (see LegalNoticeCaption or LegalNoticeText).


DontDisplayLastUserName

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

Data type | Range | Default value
REG_SZ or REG_DWORD | 0 | 1 (decimal only) | 0

Description

Determines whether a user name appears in the Log On to Windows dialog box.

By default, Windows 2000 displays the user name of the last user who logged on successfully (as stored in the value of DefaultUserName) in the Log On to Windows dialog box. If the value of this entry is 1, the User name box in the Log On to Windows dialog box is blank.

Value | Meaning
0 | The name of the last user who logged on successfully is displayed in the Log On to Windows dialog box. This setting is designed to make logging on faster and easier.
1 | The User name field in the Log On to Windows dialog box is blank. This setting is designed to enhance the security of the system by not displaying a valid user name.

Note Image Note

This entry can be overriden by a Group Policy setting in Windows 2000. When the Do not display last user name in logon screen policy (Computer Configuration\Windows Settings\Security Settings\Local Policies\Security Options) is defined, this entry is ignored.

Tip Image Tip

For detailed information about particular Group Policies, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

Related Entries

DefaultUserName


KeepRasConnection

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

Data type | Range | Default value
REG_SZ | 0 | 1 | 0

Description

Determines whether Windows 2000 closes all open dial-up (Routing and Remote Access) connections when users log off.

Value | Meaning
0 | RAS connections are closed.
1 | RAS connections remain open.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


LegalNoticeCaption

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

Data type | Range | Default value
REG_SZ | String | (Blank)

Description

Specifies the caption (title bar text) for the message box that appears after a user presses Ctrl+Alt+Del to log on.

If the value of this entry is not blank, a message box bearing this caption and the message specified in the value of LegalNoticeText, appears before the Log On to Windows dialog box is displayed. The user must click OK in the message box to proceed with logon.

For example, in the figure below, the value of LegalNoticeCaption is "Legal Notice."

Note Image Note

The message is not displayed when the value of disablecad is 1.

Related Entries

LegalNoticeText


LegalNoticeText

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

Data type | Range | Default value
REG_SZ | String | (Blank)

Description

Specifies the text for the message box that appears after a user presses Ctrl+Alt+Del to log on.

If the value of this entry is not blank, a message box displaying the value of this entry appears before the Log on to Windows dialog box is displayed. The user must click OK in the message box to proceed with logon.

For example, in the figure below, the value of LegalNoticeText is "You must be an employee of XYZ to use this computer." The text displayed in the title bar of the logon banner is specified by the value of LegalNoticeCaption.

Note Image Note

The logon banner is not displayed when the value of DisableCAD is 1.

Related Entries

LegalNoticeCaption


LogonPrompt

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

Data type | Range | Default value
REG_SZ | String | (Blank)

Description

Specifies a text message for the Log On to Windows dialog box.

By default, there is no logon prompt message, but you can add this entry to the registry to add a message.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


MaxGPOScriptWait

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

Data type | Range | Default value
REG_DWORD | 0 | 1 -32000 seconds | 600 (10 minutes)

Description

Determines how long the system waits for scripts applied by Group Policy to run.

The value of this entry limits the combined time allowed for all logon, startup, and shutdown scripts applied by Group Policy to finish running.

Value | Meaning
0x0 | The system waits until all scripts have finish running, no matter how long they take.
0x1 - 0x8000 | Specifies how long the system waits for scripts to finish. If the scripts have not finished running when the specified time expires, the system stops script processing and records an error event.

This interval is particularly important when other system tasks must wait while the scripts complete. By default, each startup script must complete before the next one runs.

An excessively long interval can delay the system and inconvenience users. However, if the interval is too short, prerequisite tasks might not be done, and the system can appear to be ready prematurely.

Note Image Note

This entry can be superceded by a policy included in Windows 2000. When the Maximum wait time for Group Policy scripts policy is enabled, the system ignores this entry. The policy setting is stored in the value of MaxGPOScriptWait in the Policies subkey. If this feature does not operate as expected, check to see if a policy is in effect.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


PasswordExpiryWarning

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF days | 0xE (14 days)

Description

Specifies how long before a user's password expires it is that the system displays a message prompting them to change it.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


PowerdownAfterShutdown

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

Data type | Range | Default value
REG_SZ | 0 | 1 | Windows 2000 Server: 0 Windows 2000 Professional: 1

Description

This entry appears in the registry, but is ignored by Windows 2000.

In Windows NT 4.0 and earlier, this value controlled the Shutdown and Power off option. This option is not available in Windows 2000. Instead, when you shut down Windows 2000, it automatically turns power off on all computers that support this feature.

Note Image Note

The power off feature is not supported on all computers.

Related Entries

ShutdownWithoutLogon

NoClose


ProfileDlgTimeOut

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF seconds | 0x1E (30 seconds)

Description

Defines the starting time for the User Environment Countdown Timer. This timer determines how long the system waits for a user response before it uses a default value. The value of this entry is used when any of the following events occur:

  • The system detects a slow link between the client and the server that stores the client's profile.
  • The system cannot access or update a server-based profile at logon or logoff.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

The value of this entry can be overridden by a policy. If your system does not respond as expected, the Timeout for dialog boxes Group Policy might be in effect. See ProfileDlgTimeout (Policies subkey).

If you change this value by editing the registry, enter the value in decimal numbers.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

SlowLinkDetectEnabled

SlowLinkTimeOut


RasForce

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

Data type | Range | Default value
REG_SZ | 0 | 1 | 0

Description

Determines whether the Log on using dial-up connection check box is selected by default when the system starts. This check box appears on the Log On to Windows dialog box that is displayed when you log on to Windows 2000.

The system uses this value only when you have created a dial-up connection by using Network and Dial-up Connections and the computer is a member of a domain.

Value | Meaning
0 | Cleared. The Log on using dial-up connection check box is cleared when displayed. Users can click to select it.
1 | Selected. The Log on using dial-up connection check box is selected when displayed. Users can click to clear it.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


ReportBootOk

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

Data type | Range | Default value
REG_SZ | 0 | 1 | 1

Description

Determines whether Winlogon declares startup to be successful. If you change the value of this entry to 0, you must use another program, such as Bootok.exe or Bootvrfy.exe, to declare the startup successful.

Value | Meaning
0 | Winlogon does not declare startup to be successful.
1 | Winlogon declares startup to be successful after at least one user has logged on successfully.

Caution Image Caution

If this entry is deleted from the registry, Winlogon does not declare the startup to be successful.

Related Entries

BootVerificationProgram subkey

BootVerification service subkey


ReportControllerMissing

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

Data type | Range | Default value
REG_SZ | TRUE | FALSE | FALSE

Description

Stores the computer setting for the domain controller message. (The user setting is stored in the value of ReportDC.)

This entry determines, in part, whether the system displays the following message when it cannot contact the domain controller that stores a user's roaming user profile:

A domain controller for your domain could not be contacted. You have been logged on using cached account information. Changes made to your profile since you last logged on might not be available.

Value | Meaning
FALSE (or not in registry) | Does not display the domain controller message.
TRUE | Displays the domain controller message.

Display of the domain controller message is managed by two registry entries, ReportDC and ReportControllerMissing. The message is displayed only when both entries are set to their display setting, that is, when ReportDC is set to 1 or it does not appear in the registry, and ReportDomainController appears in the registry with a value of TRUE. By default, the message is not displayed.

Note Image Note

While the domain controller message is displayed, other elements of the user interface are disabled, but all processes continue to run normally. If the OK button accompanying this message is not clicked after two minutes, the message box disappears.

The value of this entry must appear in all capital letters. Otherwise, the system ignores the value and behaves as though the value is FALSE.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

ReportDC

NoPopUpsOnBoot


RunLogonScriptSync

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether the system waits for the logon script to finish running before it starts Windows Explorer and creates the desktop.

Value | Meaning
0 | The logon script and Windows Explorer can run simultaneously.
1 | Windows Explorer does not start until the logon script has finished running.

Change method

To establish a policy related to this entry, use Group Policy. The value of this entry can be overridden by using the Run logon scripts synchronously policy (User or Computer Configuration\Administrative Templates\System\Logon).

Note Image Note

This entry also appears in the Winlogon subkey in HKEY_CURRENT_USER (see RunLogonScriptSync). The HKEY_LOCAL_MACHINE value applies to all users. The HKEY_CURRENT_USER value is configured separately for each user.

This entry can be superceded by Group Policy settings included in Windows 2000. While the Run logon scripts synchronously Group Policy is enabled (in the Computer Configuratio or User Configuration policy folders), the system ignores this entry. The Run logon scripts synchronously setting is stored in the values of RunLogonScriptSync (HKLM) and RunLogonScriptSync (HKCU).

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

Related Entries

RunLogonScriptSync (HKCU)


ScreenSaverGracePeriod

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

Data type | Range | Default value
REG_DWORD | 0x0 - 0x20C49B (2,147,483) seconds (~ 24 days) | 0x5

Description

Determines when password protection of a screen saver becomes effective. This entry determines the delay between the appearance of a password protected screen saver and the enforcement of the password requirement.

Password protection of a screen saver is not effective immediately. By default, there is a brief period within which you can use the mouse or keyboard to stop the screen saver without entering the password. This delay is designed to minimize the disruption that results when the screen saver starts while you are working.

You can add this entry to the registry to adjust the length of the delay. To make password protection effective immediately, set the value of this entry to 0x0.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


SFCDllCacheDir

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

Data type | Range | Default value
REG_EXPAND_SZ | Fully qualified path | Systemroot\System32\Dllcache

Description

Specifies an alternate location for the Windows File Protection cache.

Note Image Note

This entry can be superceded by a policy included in Windows 2000. While the Specify Windows File Protection cache location policy is enabled and SFCDllCacheDir appears in the Policies subkey, the system ignores this entry. If the Windows File Protection cache does not appear in the expected location, check to see whether a policy is in effect.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

Related Entries

SFCDllCacheDir (Policies subkey)


SfcQuota

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFE MB | 0xFFFFFFFF | Windows 2000 Professional: 0x32 (50 MB) Windows 2000 Server: 0xFFFFFFFF (unlimited)

Description

Specifies the maximum amount of disk space that can be used for the Windows File Protection file cache.

Windows File Protection adds protected files to the cache until the cache content reaches the quota. If the quota is greater than 50 MB, WFP adds other important Windows 2000 files to the cache until the cache size reaches the quota.

Value | Meaning
(Not in registry) | The default value is set to 50 MB on Windows 2000 Professional and is unlimited on Windows 2000 Server.
1 - 0xFFFFFFFE | Specifies the size of the Windows File Protection cache on the local hard drive.
0xFFFFFFFF | The cache size is not limited. Save all cache all protected system files on the local hard drive.

Note Image Note

This entry can be superceded by a policy included in Windows 2000. While the Limit Windows File Protection cache size policy is enabled and SfcQuota appears in the Policies subkey, the system ignores this entry. If Windows File Protection does not operate as expected, check to see whether a policy is in effect.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

Related Entries

SfcQuota(Policies subkey)


SfcScan

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

Data type | Range | Default value
REG_DWORD | 0 | 1 | 2 | 0

Description

Determines when Windows File Protection scans protected files for changes. By default, protected files are scanned only during setup.

Value | Meaning
0 | Windows File Protection scans files only during setup.
1 | Windows File Protection scans files at setup and each time you start Windows 2000. This setting delays each startup.
2 | Windows File Protection scans files the next time you start the system.

Change method

To change the value of this entry, use System File Checker (SFC.exe), a tool included in Windows 2000 Server.

Note Image Note

This entry affects file scanning only. It does not affect the standard background file change detection that Windows File Protection provides.

This entry can be superceded by a policy included in Windows 2000. While the Set Windows File Protection scanning is enabled, the system ignores this entry. The setting of the Set Windows File Protection scanning policy is stored in the value of Sfcscan in the Policies subkey. If Windows File Protection or System File Checker does not operate as expected, check to see whether a policy is in effect.

Windows File Protection only scans when the current user is an administrator of the computer.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

Related Entries

SfcScan(Policies subkey)


SfcShowProgress

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Hides the file scan progress window. This window provides status information to sophisticated users, but might confuse novices.

Value | Meaning
0 | The file scan progress window does not appear during file scanning.
1 | The file scan progress window appears.

Note Image Note

This entry can be superceded by a policy included in Windows 2000. While the Hide the file scan progress window is enabled, and the value of SfcShowProgress in the Policies subkey is 0, the system ignores this entry. If the scan progress window does not appear, check to see whether a policy is in effect.

Windows File Protection only scans when the current user is an administrator of the computer.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

Related Entries

SfcShowProgress (Policies subkey)


Shell

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

Data type | Range | Default value
REG_SZ | Name of executable file | Explorer.exe

Description

Specifies the programs that provide the user interface to the operating system.

By default, Winlogon starts the programs specified in the value of Userinit, including Userinit.exe. Userinit.exe starts the user interface program. However, if Winlogon cannot start the programs specified in the value of Userinit, Winlogon directly executes the programs specified in the value of Shell.

Related Entries

Userinit

System


ShowLogonOptions

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether logon options are displayed in the Log on to Windows dialog box when the dialog box opens.

The Log on to Windows dialog box has an Options toggle button that alternately hides and displays the Domain box and the Log on using dial-up connection options.

Value | Meaning
0 | The options are hidden when the dialog box opens, but users can click the Options button to display them.
1 | The options are displayed when the dialog box opens, but users can click the Options button to hide them.


ShutdownWithoutLogon

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

Data type | Range | Default value
REG_SZ | 0 | 1 | Windows 2000 Server: 0 Windows 2000 Professional: 1

Description

Determines whether the Shutdown button in the Log On to Windows dialog box is enabled. The Log On to Windows dialog box is displayed when you are logging on to Windows 2000. The Shutdown button lets users stop the operating system without logging on or turning off power to the computer.

Value | Meaning
0 | The Shutdown button is disabled. It still appears in the Log On to Windows dialog box, but it is dimmed and does not operate.
1 | The Shutdown button is enabled.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Enable shutdown from Authentication dialog box policy (Computer Settings\Software Policies\Windows NT System\Logon).

Related Entries

PowerdownAfterShutdown

NoClose


SlowLinkDetectEnabled

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether the system detects slow connections between this computer and remote servers that store roaming user profiles.

Value | Meaning
0 | The system does not measure the time it takes for a server bearing a user's profile to respond. Users must wait for their server-based profile to become available.
1 | The system times the server's response to a request for a user's profile. If the server does not respond before the value of SlowLinkTimeOut expires, the system offers users the option of using a version of their user profile saved on this computer or waiting for the server-based profile.

This entry, and related entries in this subkey, together describe a strategy for managing user profiles residing on remote servers. In particular, they tell the system how to respond when a remote profile is slow to load.

Consider setting this value to 0 if server-based profiles are desired, even if downloading the profile over WAN or dialup networking links causes logon delays.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Automatically detect slow network connections policy (Computer Settings\Software Policies\Windows NT User Profiles).

Note Image Note

This entry can be superceded by a policy included in Windows 2000. While the Do not detect slow network connections Group Policy is enabled, the system ignores this entry. The Do not detect slow network connections setting is stored in the value of SlowLinkDetectEnabled.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

Related Entries

ProfileDlgTimeOut

SlowLinkTimeOut


SlowLinkProfileDefault

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Directs the system to wait for the remote copy of the roaming user profile to load, even when loading is slow. Also, the system waits for the remote copy when the user is notified about a slow connection, but does not respond in the time allowed.

Value | Meaning
0 | Use the local copy. When a remote profile is slow to load, the system loads the local copy of the roaming user profile. The local copy is also used when the user is consulted (as set in the SlowLinkUIEnabled entry), but does not respond in the time allowed (as set in ProfileDlgTimeOut).
1 | The policy is enabled. The system waits for the remote copy of the user profile to load.

Waiting for the remote profile is appropriate when users move between computers frequently and the local copy of their profile is not always current. Using the local copy is desirable when quick logging on is a priority.

Note Image Note

This entry can be superceded by a policy included in Windows 2000. When the Wait for remote user profile is enabled, the system ignores this entry. The setting of the Wait for remote user profile policy is stored in the value of SlowLinkProfileDefault in the Policies subkey. If the slow link feature does not operate as expected, check to see if a policy is in effect.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


SlowLinkTimeOut

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

Data type | Range | Default value
REG_DWORD | 0 - 120,000 milliseconds | 2000 (2 seconds)

Description

Defines a slow link for Winlogon. If the server storing a user's profile does not respond before the time specified in the value of this entry expires, Winlogon considers the link to the server to be slow and offers users the option of using a profile cached on their local computer instead of waiting for the server.

This entry is used only when the value of SlowLinkDetectEnabled is 1.

You can increase the value of SlowLinkTimeOut to favor the server-based profile. This is particularly useful for clients using DHCP-assigned addresses, or for computers accessing server-based profiles over slow WAN links, such as dial-up connections.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Slow network connection timeout policy (Computer Settings\Software Policies\Windows NT User Profiles).

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

ProfileDlgTimeOut

SlowLinkDetectEnabled


System

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

Data type | Range | Default value
REG_SZ | Names of executable files | lsass.exe

Description

This entry appears in the registry, but it is not used by Windows 2000.


TaskMan

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

Data type | Range | Default value
REG_SZ | Names of executable files | Taskmgr.exe

Description

Specifies the task manager used by the system. You can add this entry to the registry to specify an alternate task manager.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


Userinit

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

Data type | Range | Default value
REG_SZ | Names of executable files (filename extension not required) | userinit

Description

Specifies the programs that Winlogon runs when a user logs on. By default, Winlogon runs Userinit.exe, a program which runs logon scripts, reestablishes network connections, and then starts Explorer.exe, the Windows user interface.

You can change the value of this entry to add or remove programs. For example, to have your program run before the Windows Explorer user interface is started, substitute the name of your program for Userinit.exe in the value of this entry, then include instructions in your program to start Userinit.exe. You might also want to substitute Explorer.exe for Userinit.exe if you are working offline and are not using logon scripts.

Related Entries

Shell

System


VmApplet

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

Data type | Range | Default value
REG_SZ | Names of executable files (filename extension not required) | rundll32 shell32,Control_RunDLL "sysdm.cp"

Description

Specifies programs that Winlogon runs for the user so that the user can adjust the configuration of virtual memory when there is no paging file on the system volume.

These programs are run only when the system volume does not include a paging file.

Caution Image Caution

Do not change the value of this entry. If you do, you can damage the virtual memory configuration of Windows 2000.

Related Entries

Shell

System

Userinit


Welcome

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

Data type | Range | Default value
REG_SZ | String | (Blank)

Description

Specifies the text that appears in the caption bar beside the title of the Log On to Windows, Windows Security, Computer Locked, and Unlock Computer dialog boxes.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Tip Image Tip

The system adds only one space between the dialog box title and your message. To further separate the title from your message, begin your message with leading spaces.

Related Entries

LegalNoticeCaption


WOW

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\

Description

The WOW subkey contains subkeys and entries that control startup parameters that affect MS-DOS–based applications and applications created for 16-bit Windows 3.x.

Related Entries

WOW subkey in the SYSTEM key


boot

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\WOW\

Description

The boot subkey contains information about drivers and fonts which are loaded each time the computer is started.


Policies

HKLM\SOFTWARE\

Description

The Policies subkey contains entries that store Group Policy settings.

Group Policy adds, deletes, and changes the values of entries in this subkey when you use the Group Policy snap-in to configure a policy; that is, to enable or disable the policy. When the policies affecting you or your computer change, such as when you move to a new user group, Group Policy deletes the entries applied to the old group and adds the entries applied to the new group.

Group Policy manages registry entries in four Policies subkeys:

  • HKLM\SOFTWARE\Policies
  • HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies
  • HKCU\SOFTWARE\Policies
  • HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies

The Policies subkeys in HKCU store policy-related entries that are configured separately for each user. Group Policy adds these entries when you enable (and, for some policies, when you disable) a policy in the User Configuration folder in Group Policy.

The Policies subkeys in HKLM store policy-related entries that apply to all users of the computer. The system adds these entries when you enable (and, for some policies, when you disable) a policy in the Computer Configuration folder in Group Policy.

Many policy-related entries can appear in both HKCU and HKLM. Typically, the entries in HKLM take precedence over the entries in HKCU when both are configured.

The SOFTWARE\Microsoft\Windows\CurrentVersion\Policies subkey stores policy-related entries for Windows 2000 and for Windows NT 4.0 and earlier. The SOFTWARE\Policies subkey is new in Windows 2000. Please note that the different versions of Windows support different policies.

Change method

To add, remove, or change the entries in this subkey, use Group Policy.

Note Image Note

Many of the entries in the Policies subkeys have counterparts in other registry subkeys. These counterparts, known as preferences have the same effect on user or computer features as entries in the Policies subkey. However, when an entry appears in the Policies subkey, the preference is almost always ignored. For details, see the entry descriptions.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Caution Image Caution

Do not use a registry editor to change the values of entries in this subkey. If you do, they will be overwritten the next time your policies are refreshed.


Microsoft

HKLM\SOFTWARE\Policies\

Description

The Policies\Microsoft subkey stores the entries created when you configure a Group Policy related to a Microsoft product. These entries are created and maintained by Group Policy, and are read and interpreted by the product program.

The Policies\Microsoft subkey in HKEY_LOCAL_MACHINE stores entries that apply to all users of the computer. The system adds these entries when you enable (and, for some policies, when you disable) a policy in the Computer Configuration folder in Group Policy.

There is also a Policies\Microsoft subkey in HKEY_CURRENT_USER, which stores policy-related entries that are configured separately for each user. The system adds these entries when you enable (and, for some policies, when you disable) a policy in the User Configuration folder in Group Policy.

Change method

To add, delete, or change the entries in this subkey, use Group Policy.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

Microsoft subkey (HKCU\Software\Policies)


System

HKLM\SOFTWARE\Policies\Microsoft\

Description

The System subkey stores the entries created when you configure a Group Policy that affects a basic component of Windows 2000. The entries in this subkey are created and maintained by Group Policy, and are read and interpreted by the component programs.

The Policies\Microsoft\Windows\System subkey in HKEY_LOCAL_MACHINE stores entries related to policies that apply to all users of this computer.There is also a Policies\Microsoft\Windows\System subkey in HKEY_CURRENT_USER, which stores policy-related entries that are configured separately for each user.

Change method

To add, delete, or change the entries in this subkey, use Group Policy.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

HKCU\Software\Policies\Microsoft\Windows\System

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

HKLM\SOFTWARE\Policies\Microsoft\Windows\System


DNSclient

HKLM\SOFTWARE\Policies\Microsoft\System\

Description

The DNSClient subkey stores entries created when you configure a Group Policy for the Domain Name System (DNS) client. The entries in this subkey are created and maintained by Group Policy and read and interpreted by the DNS service.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


NV PrimaryDnsSuffix

HKLM\SOFTWARE\Policies\Microsoft\System\DNSclient

Data type | Range | Default value
REG_SZ | DNS suffix | There is no default value for this entry.

Description

Stores the most recent setting of the Primary DNS Suffix Group Policy. When you restart Windows 2000, the system copies this value into the value of PrimaryDnsSuffix.

The primary DNS suffix is used in DNS name registration and DNS name resolution.

Group Policy adds this entry to the registry when you enable the Primary DNS Suffix policy. If you disable the policy or do not configure it, Group Policy deletes this entry from the registry.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Primary DNS Suffix policy (Computer Configuration\Administrative Templates\System\DNS Client). In the text box provided, type the entire primary DNS suffix you want to assign, for example, reskit.com.

Note Image Note

The Primary DNS Suffix policy does not disable the Primary DNS suffix of this computer box that administrators use to change the primary DNS suffix of a computer. If an administrator enters a suffix in the box and restarts Windows 2000, that suffix is stored in the value of Domain, but it is ignored while the policy is in effect.

Tip Image Tip

To change the primary DNS suffix of a computer without setting a policy, click System in Control Panel, click the Network Identification tab, click Properties, click More, and then enter a suffix in the Primary DNS suffix of this computer box.

For more information about DNS, see Domain Name System (DNS) in Windows 2000 Help. Also, see Windows 2000 DNS in the Windows 2000 Resource Kit Core Networking Guide.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

PrimaryDnsSuffix

Domain

NV Domain


PrimaryDnsSuffix

HKLM\SOFTWARE\Policies\Microsoft\System\DNSclient

Data type | Range | Default value
REG_SZ | DNS suffix | (The local primary DNS suffix)

Description

Specifies the primary Domain Name System (DNS) suffix assigned to this computer by a Group Policy. The primary DNS suffix is used in DNS name registration and DNS name resolution.

This entry stores the setting of the Primary DNS Suffix Group Policy. When you enable the Primary DNS Suffix policy, Group Policy stores the value specified in the policy in NV PrimaryDnsSuffix. Then, when you restart Windows 2000, the policy setting is copied to the value of PrimaryDnsSuffix. If you disable the policy or do not configure it, Group Policy deletes the NV Primary DNS Suffix entry from the registry. Then, when you restart Windows 2000, this entry is deleted, too.

If this entry does not appear in the registry, the system uses the value of Domain as the primary DNS suffix. Domain stores the value displayed in the Primary DNS suffix of this computer box on the DNS Suffix and NetBIOS Computer Name dialog box in System in Control Panel.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Primary DNS Suffix policy (Computer Configuration\Administrative Templates\System\DNS Client). In the text box provided, type the entire primary DNS suffix you want to assign, for example, reskit.com. The policy setting is temporarily stored in the value of NV PrimaryDnsSuffix and it is copied to PrimaryDnsSuffix when you restart Windows 2000.

Note Image Note

This entry has no effect on domain controllers.

This entry takes precedence over a user setting. When this entry appears in the registry, a policy is in effect and the system ignores the value of Domain and the Primary DNS suffix of this computer box on the DNS Suffix and NetBIOS Computer Name dialog box in System in Control Panel. If the computer uses a primary DNS suffix different from the one specified in the Primary DNS suffix of this computer box, check to see if this entry is in the registry.

The policy does not disable the Primary DNS suffix of this computer box that administrators use to change the primary DNS suffix of a computer. If administrators enters a suffix in the box, that suffix is stored in the value of Domain, but it is ignored while the policy is in effect.

Tip Image Tip

To change the primary DNS suffix of a computer without setting a policy, click System in Control Panel, click the Network Identification tab, click Properties, click More, and then enter a suffix in the Primary DNS suffix of this computer box.

For more information about DNS, see Domain Name System (DNS) in Windows 2000 Help. Also, see Windows 2000 DNS in the Windows 2000 Resource Kit Core Networking Guide.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NV PrimaryDnsSuffix

Domain

NV Domain


Windows

HKLM\SOFTWARE\Policies\Microsoft\

Description

The Windows subkey contains entries that store Group Policy settings for components of Windows 2000. The subkeys and entries in the Windows subkey are written and maintained by Group Policy, and are read and interpreted by the component that implements them.

The SOFTWARE\Policies\Microsoft\Windows subkey in HKEY_LOCAL_MACHINE stores entries related to policies that apply to all users of this computer. There is also a Software\Policies\Microsoft\Windows subkey in HKEY_CURRENT_USER that stores policy-related entries that are configured separately for each user.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

HKCU\Software\Policies\Microsoft\Windows


App Management

HKLM\SOFTWARE\Policies\Microsoft\Windows\

Description

The App Management subkey contains entries that store the Group Policy settings which determine how programs are run. The subkeys and entries in the Windows subkey are written and maintained by Group Policy, and are read and interpreted by the component that implements them.

Note Image Note

Policy entries in the App Management subkey override default settings in the SOFTWARE\Microsoft\Windows\CurrentVersion\App Management subkeys.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

App Management subkey in (HKCU)


COMClassStore

HKLM\SOFTWARE\Policies\Microsoft\Windows\App Management

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Directs the system to search Active Directory for missing Component Object Model (COM) components that a program requires.

This entry stores the setting of the Download missing COM components Group Policy. Group Policy adds this entry to the registry with a value of 1 when you configure the Download missing COM components policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry.

Value | Meaning
0 (Not in registry) | The policy is disabled or not configured. When a required COM component registration is missing, the program continues without it. As a result, the program might not perform all of its functions, or it might stop.
1 | The policy is enabled. The system searches Active Directory for a missing COM component registration and if it is found, downloads it. The resulting searches might make some programs start or run slowly.

Many Windows programs, such as the Microsoft Management Console snap-ins, use the interfaces provided by the COM. These programs cannot perform all of their functions unless Windows 2000 has internally registered the required components.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Download missing COM components policy (Computer Configuration\Administrative Templates\System).

Note Image Note

This entry can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If this entry appears in both subtrees, the value in HKEY_LOCAL_MACHINE takes precedence over the value in HKEY_CURRENT_USER.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

COMClassStore (HKCU)


Group Policy

HKLM\SOFTWARE\Policies\Microsoft\Windows\

Description

The Group Policy subkey stores the data for Group Policy settings that configure the Group Policy components of Windows 2000.

The Group Policy subkey contains a subkey representing each of the client-side extensions designed for Group Policy. These <Class-ID> subkeys are named for the class-ID of the extension, and store entries that apply only to Group Policy settings which use that client-side extension.

In Windows 2000, the <Class-ID> subkeys stores entries added when you select options in the policy–processing policies for client-side extensions.

Note Image Note

Group Policy adds this subkey to the registry when you configure a related policy, such as the client-side extension policies in Computer Configuration\Administrative Templates\System\Group Policy in Group Policy.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

Group Policy Editor


<Class-ID>

HKLM\SOFTWARE\Policies\Microsoft\Windows\Group Policy\

Description

The Group Policy subkey contains a subkey representing each of the client-side extensions used to create settings in Group Policy. These <Class-ID> subkeys are named for the class-ID of the extension, and store entries that apply only to Group Policies which use that client-side extension.

These subkeys store the settings of the policy-processing policies in the Computer Configuration\Administrative Templates\System\Group Policy folder in Group Policy.

The following table shows the <Class-ID> subkeys and the corresponding client-side extension:

Class ID | Policy component
{25537BA6-77A8-11D2-9B6C-0000F8080861} | Folder Redirection policy
{35378EAC-683F-11D2-A89A-00C04FBBCFA2} | Registry policy
{3610EDA5-77EF-11D2-8DC5-00C04FA31A66} | Disk Quota policy
{42B5FAAE-6536-11D2-AE5A-0000F87571E3} | Scripts policy
{827D319E-6EAC-11D2-A4EA-00C04F79F83A} | Security policy
{A2E30F80-D7DE-11d2-BBDE-00C04F86AE3B} | Internet Explorer maintenance policy
{B1BE8D72-6EAC-11D2-A4EA-00C04F79F83A} | EFS recovery policy
{C6DC5466-785A-11D2-84D0-00C04FB169f7} | Software installation policy
{E437BC1C-AA7D-11D2-A382-00C04F991E27} | IP security policy

Note Image Note

The <Class-ID> subkey is a variable representing the subkeys under the Group Policy subkey. It does not actually appear in the registry. This variable subkey is used to display information which is common to the subkeys in the Group Policy subkey.

Some policies do not support the features that can be configured by entries in a <Class-ID> subkey. For a list of client-side extensions that support each entry, see the entry description.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

<Class-ID> subkey in the MMC subkey


NoBackgroundPolicy

HKLM\SOFTWARE\Policies\Microsoft\Windows\Group Policy\<Class-ID>

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Prevents the system from updating Group Policy settings while a user is logged on.

This entry stores the setting of the Do not apply during periodic background processing option in the policy–processing policies in Group Policy.

  • If you enable a policy–processing policy and select this option, Group Policy adds this entry to the appropriate <Class-ID subkey> with a value of 1.
  • If you clear the option or disable the policy, Group Policy sets the value of this entry to 0.
  • If you set the policy to not configured, Group Policy deletes this entry from the registry and the system behaves as though the value is 0.
Value | Meaning
0 | Permit background updates.
1 | Prohibit background updates.

Background updates can disrupt the user, cause a program to stop or operate abnormally, and, in very rare cases, damage data.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Do not apply during periodic background processing option in the policy–processing policies in Group Policy.

Note Image Note

This entry only affects background updates, which occur periodically while a user is logged on. It does not affect the updates that are always performed when you restart the system or when a user logs on.

This entry overrides customized settings specified in the installation script for a policy.

This entry is not supported by the Software Installation or Folder Redirection client-side extensions. Therefore, this entry is ignored if it appears in the {25537BA6-77A8-11D2-9B6C-0000F8080861} (Folder Redirection) or {C6DC5466-785A-11D2-84D0-00C04FB169f7} (Software installation) subkeys.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoGPOListChanges

NoSlowLink


NoGPOListChanges

HKLM\SOFTWARE\Policies\Microsoft\Windows\Group Policy\<Class-ID>

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Updates Group Policy settings as scheduled, even when the Group Policy objects have not changed.

This entry stores the setting of the Process even if the Group Policy objects have not changed option in the policy–processing policies in Group Policy.

  • If you enable a policy–processing policy and select this option, Group Policy adds this entry to the appropriate <Class-ID subkey> with a value of 0.
  • If you clear the option or disable the policy, Group Policy sets the value of this entry to 1.
  • If you set the policy to not configured, Group Policy deletes this entry from the registry and the system behaves as though the value is 1.
Value | Meaning
0 | Always update policy settings as scheduled.
1 | Update policy settings only when the Group Policy Object changes.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Process even if the Group Policy objects have not changed option in the policy–processing policies in Group Policy.

Note Image Note

This entry overrides customized settings specified in the installation script for a policy.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoBackgroundPolicy

NoSlowLink


NoSlowLink

HKLM\SOFTWARE\Policies\Microsoft\Windows\Group Policy\<Class-ID>

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Updates policy settings even when the update is transmitted across a slow network connection, such as a telephone line.

Because updates across slow connections can cause significant delays, by default, the system does not update policy settings when it detects a slow connection.

This entry stores the setting of the Allow processing across a slow network connection option in the policy–processing policies in Group Policy.

  • If you enable a policy–processing policy and select this option, Group Policy adds this entry to the appropriate <Class-ID subkey> with a value of 0.
  • If you clear the option or disable the policy, Group Policy sets the value of this entry to 1.
  • If you set the policy to not configured, Group Policy deletes this entry from the registry and the system behaves as though the value is 1.
Value | Meaning
0 | Policies are updated even when the update is being transmitted across a slow network connection, such as a telephone line.
1 | Policies are not updated over a slow connection.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Allow processing across a slow network connection option in the policy–processing policies in Group Policy.

Note Image Note

This entry overrides customized settings specified in the installation script for a policy.

This entry is not supported by the Registry policy or Security policy client-side extensions. Therefore, this entry is ignored if it appears in the {35378EAC-683F-11D2-A89A-00C04FBBCFA2} (Registry policy) or {827D319E-6EAC-11D2-A4EA-00C04F79F83A} (Security policy) subkeys.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoBackgroundPolicy

NoGPOListChanges

GroupPolicyMinTransferRate


Installer

HKLM\SOFTWARE\Policies\Microsoft\Windows\

Description

The Installer subkey stores the entries created when you configure a Group Policy for Windows Installer in Windows 2000. These entries are created and maintained by Group Policy, and are read and interpreted by Windows Installer.

The Installer subkey in the Policies subkey in HKEY_LOCAL_MACHINE stores entries that apply to all users of the computer. The system adds these entries when you enable (and, for some policies, when you disable) a policy in the Computer Configuration folder in Group Policy.

There is also an Installer subkey in the Policies subkey in HKEY_CURRENT_USER, which stores entries that are configured separately for each user. The system adds these entries when you enable (and, for some policies, when you disable) a policy in the User Configuration folder in Group Policy.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

Installer subkey (HKCU)


AllowLockdownBrowse

HKLM\SOFTWARE\Policies\Microsoft\Windows\Installer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Enables the Browse button on the Use feature from dialog box, even when an installation is running with system permissions.

The Browse button lets users search for installation files. When an installation is running with system permissions, the browse feature can provide access to directories that the user's own permissions would not allow. Thus, by default, only system administrators can browse during installations with elevated system privileges, such as installations offered on the desktop or displayed in Add/Remove Programs.

This entry stores the setting of the Enable user to browse for source while elevated Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy, Group Policy sets the value to 0. If you set the policy to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 of (Not in registry) | The policy is disabled or not configured. The user cannot search for installation files during privileged installations.
1 | The policy is enabled. The user can search for installation files during privileged installations.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Enable user to browse for source while elevated policy (Computer Configuration\Administrative Templates\Windows Components\Windows Installer).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

DisableBrowse


AllowLockdownMedia

HKLM\SOFTWARE\Policies\Microsoft\Windows\Installer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Allows users to install programs from removable media, such as floppy disks and CD-ROMs, during installations running with system permissions. Installations offered on the desktop or displayed in Add/Remove Programs run with system permissions.

By default, only administrators can install programs from removable media when the installation is running with system permissions.

This entry stores the setting of the Enable user to use media source while elevated Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy, Group Policy sets the value to 0. If you set the policy to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. Users cannot install programs from removable media when the installation is running with system permissions.
1 | The policy is enabled. All users (including administrators) can install programs from removable media on all installations.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Enable user to use media source while elevated policy (Computer Configuration\Administrative Templates\Windows Components\Windows Installer).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

DisableMedia


AllowLockdownPatch

HKLM\SOFTWARE\Policies\Microsoft\Windows\Installer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0 0

Description

Permits all users to install patches, even when an installation program is running with elevated system permissions.

Patches are updates or upgrades that replace only those program files that have changed. Because patches can be easy vehicles for malicious programs, some installations prohibit their use. By default, only system administrators can apply patches during installations running with system permissions, such as installations offered on the desktop or displayed in Add/Remove Programs.

This entry stores the setting of the Enable user to patch elevated products Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy, Group Policy sets the value to 0. If you set the policy to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. Users cannot install patches when installing with system permissions.
1 | The policy is enabled. Users can install patches when installing with system permissions.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Enable user to patch elevated products policy (Computer Configuration\Administrative Templates\Windows Components\Windows Installer).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

DisablePatch


AlwaysInstallElevated

HKLM\SOFTWARE\Policies\Microsoft\Windows\Installer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Directs Windows Installer to use system permissions when it installs a program. By default, Windows Installer uses the user's permissions to install programs.

This entry stores the setting of the Always install with elevated privileges Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Always install with elevated privileges policy. If you disable the policy, Group Policy sets the value to 0. If you set the policy to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. Use the current user's permissions, except when installing published or assigned programs.
1 | The policy is enabled. Uses system permissions.

This entry extends elevated privileges to all programs. These privileges are usually reserved for programs that have been assigned to the user (offered on the desktop), assigned to the computer (installed automatically), or made available in Add/Remove Programs in Control Panel. This entry lets users install programs that require access to directories that the user might not have permission to view or change, including directories on highly restricted computers.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Always install with elevated privileges policy (Computer Configuration\Administrative Templates\Windows Components\Windows Installer).

Note Image Note

This entry can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If this entry appears in both subtrees, the value in HKEY_LOCAL_MACHINE takes precedence over the value in HKEY_CURRENT_USER.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Caution Image Caution

Skilled users can take advantage of the permissions this entry grants to change their privileges and gain permanent access to restricted files and folders. Note that the User Configuration version of this entry is not guaranteed to be secure.

Related Entries

AlwaysInstallElevated (HKCU)


DisableBrowse

HKLM\SOFTWARE\Policies\Microsoft\Windows\Installer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Disables the Browse button beside the Use feature from list in the Windows Installer dialog box. By default, the Browse button is disabled only when users who are not administrators are using system permissions to install a program.

Without the Browse button, users cannot search for installation files when they add features or components to an installed program. Instead, the user must select an installation file source from the Use features from list that the system administrator configures.

This entry stores the setting of the Disable browse dialog box for new source Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Disable browse dialog box for new source policy. If you disable the policy, Group Policy sets the value to 0. If you set the policy to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. Users can search for installation files. The Browse button is disabled only when non-Administrators are using system permission to install programs by using system permission.
1 | The policy is enabled. Users cannot search for installation files. The Browse button is always disabled.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable browse dialog box for new source policy (Computer Configuration\Administrative Templates\Windows Components\Windows Installer).

Note Image Note

This entry affects Windows Installer only. It does not prevent users from selecting other browsers, such Windows Explorer or My Network Places, to search for installation files.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


DisableMSI

HKLM\SOFTWARE\Policies\Microsoft\Windows\Installer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 2 | 0

Description

Disables or restricts the use of Windows Installer. This entry can prevent users from installing software on their systems or permit users to install only those programs offered by a system administrator.

This entry stores the setting of the Disable Windows Installer Group Policy. Group Policy adds this entry to the registry when you enable the Disable Windows Installer policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 | The policy is enabled and set to Never. Windows Installer is fully enabled. Users can install and upgrade software. Windows Installer is enabled by default on Windows 2000. This value has the same effect as disabling or not configuring the policy.
1 | The policy is enabled and set to For non-managed apps only. Users are permitted to install only those programs that a system administrator assigns (offers on the desktop) or publishes (adds to Add/Remove Programs).
2 | The policy is enabled and set to Always. Windows Installer is disabled.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable Windows Installer policy (Computer Configuration\Administrative Templates\Windows Components\Windows Installer). Use the options in the Disable Windows Installer box to establish an installation policy.

Note Image Note

This entry affects Windows Installer only. It does not prevent users from using other methods to install and upgrade programs.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


DisablePatch

HKLM\SOFTWARE\Policies\Microsoft\Windows\Installer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Prevents users from using Windows Installer to install patches.

Patches are updates or upgrades that replace only those program files that have changed. Because patches can be easy vehicles for malicious programs, some installations prohibit their use.

This entry stores the setting of the Disable patching Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Disable patching policy. If you disable the policy, Group Policy sets the value to 0. If you set the policy to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. Users can use Windows Installer to install patches.
1 | The policy is enabled. Users cannot use Windows Installer to install patches.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable patching policy (Computer Configuration\Administrative Templates\Windows Components\Windows Installer).

Note Image Note

This entry applies only to installations that run in the user's security context. By default, users who are not system administrators cannot apply patches to installations that run with elevated system privileges, such as those offered on the desktop or in Add/Remove Programs.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

AllowLockdownPatch


DisableRollback

HKLM\SOFTWARE\Policies\Microsoft\Windows\Installer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Prohibits Windows Installer from generating and saving the files it needs to reverse an interrupted or unsuccessful installation.

This entry prevents Windows Installer from recording the original state of the system and the sequence of changes it makes during an installation. It also prevents Windows Installer from retaining files it intends to delete later. As a result, Windows installer cannot restore the computer to its original state if an installation does not complete successfully.

This entry stores the setting of the Disable rollback Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Disable rollback policy. If you disable the policy, Group Policy sets the value to 0. If you set the policy to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. Windows Installer can generate and save the files it needs to reverse an interrupted or unsuccessful installation.
1 | The policy is enabled. Windows Installer cannot generate or save the files it needs to reverse an interrupted or unsuccessful installation.

This entry is designed to reduce the amount of temporary disk space required to install programs. Also, it prevents malicious users from interrupting an installation to gather data about the internal state of the computer or to search secure system files. However, because an incomplete installation can render the system or a program inoperable, do not change the default behavior unless it becomes essential.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable rollback policy (Computer Configuration\Administrative Templates\Windows Components\Windows Installer).

Note Image Note

This entry can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If this entry appears in both subtrees, the value in HKEY_LOCAL_MACHINE takes precedence over the value in HKEY_CURRENT_USER.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

DisableRollback (HKCU)


EnableAdminTSRemote

HKLM\SOFTWARE\Policies\Microsoft\Windows\Installer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Allows Terminal Services administrators to install and configure programs remotely.

By default, system administrators can install programs only when system administrators are logged on to the computer on which the program is being installed. This policy creates a special exception for computers running Terminal Services.

This entry stores the setting of the Allow admin to install from Terminal Services session Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy, Group Policy sets the value to 0. If you set the policy to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. Users, including Terminal Services administrators, cannot install and configure programs remotely.
1 | Terminal Services administrators can install and configure programs remotely.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Allow admin to install from Terminal Services session policy (Computer Configuration\Administrative Templates\Windows Components\Windows Installer).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoNTSecurity

NoDisconnect


EnableUserControl

HKLM\SOFTWARE\Policies\Microsoft\Windows\Installer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Permits users to change installation options that typically are available only to system administrators.

This entry stores the setting of the Enable user control over installs Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy, Group Policy sets the value to 0. If you set the policy to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. Users cannot change installation options that are usually available only to system administrators.
1 | Users can change installation options that are usually available only to system administrators.

The security features of Windows Installer prevent users from changing installation options typically reserved for system administrators, such as specifying the directory to which files are installed. If Windows Installer detects that an installation package has permitted the user to change a protected option, it stops the installation and displays a message. These security features operate only when the installation program is running in a privileged security context in which it has access to directories denied to the user.

This policy is designed for less restrictive environments. It can be used to circumvent errors in an installation program that prevent software from being installed.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Enable user control over installs policy (Computer Configuration\Administrative Templates\Windows Components\Windows Installer).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Caution Image Caution

This entry bypasses some of the security features of Windows Installer. It permits installations to complete that otherwise would be halted due to a security violation.


Logging

HKLM\SOFTWARE\Policies\Microsoft\Windows\Installer

Data type | Range | Default value
REG_SZ | Letter(s) representing a type of event (no punctuation or spaces between letters) | iweap

Description

Specifies the types of events that Windows Installer records in its transaction log. The log, Msi.log, appears in the Temp directory of the system volume.

This entry stores the setting of the Logging Group Policy. Group Policy adds this entry to the registry when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is iweap.

The value of this entry consists of one or more letters, each of which represents a type of event. To direct Windows Installer to record events of this type, add the letter representing the event type to the value of this entry. You can enter the letters in any order. T

If this entry does not appear in the registry, Windows Installer logs the default event types, as represented by the letters iweap. If this entry appears in the registry, but its value is blank, the system does not log any events.

Value | Meaning
i | Status messages.
w | Nonfatal warnings.
e | All error messages.
a | Start up of actions.
r | Action-specific records.
u | User requests.
c | Initial UI parameters.
m | Out of memory.
p | Terminal properties.
v | Verbose output.
o | Out of disk space messages.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Logging policy (Computer Configuration\Administrative Templates\Windows Components\Windows Installer).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


SafeForScripting

HKLM\SOFTWARE\Policies\Microsoft\Windows\Installer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Allows Web-based programs to install software on the computer without notifying the user.

By default, when a script hosted by an Internet browser tries to install a program on the system, the system warns users and allows them to select or refuse the installation. This entry suppresses the warning and allows the installation to proceed.

This entry stores the setting of the Disable IE security prompt for Windows Installer scripts Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy, Group Policy sets the value to 0. If you set the policy to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. The system warns users when a script hosted by an Internet browser tries to install a program on the system.
1 | The warning is suppressed and the installation is allowed to proceed.

This entry is designed for enterprises that use Web-based tools to distribute programs to their employees. However, because this can pose a security risk, it should be applied cautiously.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable IE security prompt for Windows Installer scripts policy (Computer Configuration\Administrative Templates\Windows Components\Windows Installer).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


TransformsSecure

HKLM\SOFTWARE\Policies\Microsoft\Windows\Installer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Saves copies of transform files in a secure location on the local computer, instead of in the user's profile.

This entry stores the setting of the Cache transforms in secure location on workstation Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy, Group Policy sets the value to 0. If you set the policy to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | The policy is disabled or not configured. Transform files are stored in the user's profile.
1 | The policy is enabled. Transform files are stored in a secure location on the local computer.

By default, Windows Installer stores transform files in the Application Data directory in the user's profile. When a user reinstalls, removes, or repairs an installation, the transform file is available, even if the user is on a different computer or isn't connected to the network.

When the value of this entry is 1, transform files are stored in a secure location on the user's computer, instead of in the user profile. Because Windows Installer requires the transform file in order to repeat an installation in which the transform file was used, the user must be using the same computer or be connected to the original or identical media to reinstall, remove, or repair the installation.

This policy is designed for enterprises that must take special precautions to prevent unauthorized or malicious editing of transform files.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Cache transforms in secure location on workstation policy (Computer Configuration\Administrative Templates\Windows Components\Windows Installer).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


NetCache

HKLM\SOFTWARE\Policies\Microsoft\Windows\

Description

The NetCache subkey contains entries that store Group Policy settings for the Offline Files feature. These entries are created and maintained by Group Policy, and are read and interpreted by the Offline Files program. In Group Policy, these policies appear in the Computer Configuration\Administrative Templates\Network\Offline Files folder.

This subkey in HKEY_LOCAL_MACHINE stores entries related to policies that apply to all users of this computer. There is also a Microsoft\Windows\NetCache subkey in HKEY_CURRENT_USER, which stores policy-related entries that are configured separately for each user.

Also, many the policy-related entries in this subkey take precedence over user settings while the policy is in effect. The affected user settings are stored in HKLM\Software\Microsoft\Windows\CurrentVersion\NetCache.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


AlwaysPinSubFolders

HKLM\SOFTWARE\Policies\Microsoft\Windows\NetCache

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Makes subfolders available offline whenever their parent folder is made available offline.

This entry stores the setting of the Subfolders always available offline Group Policy. Group Policy adds this entry to the registry when you enable theSubfolders always available offline policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

This policy automatically extends the Make available offline setting to all new and existing subfolders of a folder. Users do not have the option of excluding subfolders.

Value | Meaning
0 | The policy is disabled or not configured. Subfolders are not automatically included. The system asks users whether they want subfolders to be made available offline whenever they make a parent folder available offline.
1 | The policy is enabled. Existing subfolders are automatically included. New subfolders are made available offline the next time the parent folder is synchronized.

Activation method

To make changes to the Subfolders always available offlinepolicy or this entry effective, you must restart Windows 2000.

Note Image Note

This entry applies only when folders are manually cached by using the Make available offline command. It does not apply to automatically cached folders.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


AssignedOfflineFolders

HKLM\SOFTWARE\Policies\Microsoft\Windows\NetCache\

Description

The AssignedOfflineFolders subkey stores a list of shared files and folders that are always made available offline.

This subkey and its entries store the setting of the Administratively assigned offline files Group Policy. Group Policy adds this subkey and entries to the registry when you configure the Administratively assigned offline files policy. If you disable the policy or set it to Not configured, Group Policy deletes the subkey and its entries from the registry.

Each of the entries in this subkey has the following format:

Path and file name or Path and folder name REG_SZ (Blank)

Files in this list behave as though they are manually cached, just as if a user had selected the Make available offline option for each file. When you enable the policy, the system copies these files to the offline file cache of each computer's local hard drive. These copies are always complete, and are never automatically deleted as long as the policy is enabled.

If you disable the policy or set it to Not configured, these files are deleted from each system's offline file cache. They remain in the cache only if users have manually cached the files independent of this policy.

Change method

To add, delete or change the value of entries in this subkey, use Group Policy. This subkey corresponds to the Administratively assigned offline files policy (Computer Configuration\Administrative Templates\Network\Offline Files).

Note Image Note

This subkey can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If this entry appears in both subtrees, the list in HKEY_LOCAL_MACHINE is used and the list in HKEY_CURRENT_USER is ignored.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


CustomGoOfflineActions

HKLM\SOFTWARE\Policies\Microsoft\Windows\NetCache\

Description

The CustomGoOfflineActions subkey contains entries that determine whether users can work offline if they are suddenly disconnected from particular offline file servers. This feature lets you specify exceptions to the general offline action rules for servers that require a specialized response, such as those that host databases.

The CustomGoOfflineActions subkey and its entries store the setting of the Non-default server disconnect actions Group Policy. Group Policy adds this subkey and entries to the registry when you configure the Non-default server disconnect actions policy. If you disable the policy or set it to Not configured, Group Policy deletes the subkey and its entries from the registry.

Each of the entries in this subkey represents a particular server, and specifies whether users can use the server's files offline when disconnected from the server.

These entries override the default offline action rules, the Exception list on the Offline Files tab, and the general offline action policy specified by the Action on server disconnect policy (stored in GoOfflineAction).

When this subkey contains valid entries, the system disables the Exception list section on the Offline Files tab to prevent administrators from specifying customized server responses while a policy is in effect. If an administrator has already created an exception list, their list is ignored while the policy is in effect.

Each of the entries in this subkey has the following format:

Computer-name REG_SZ 0 or 1

The value of the entry indicates the custom response.

Value | Meaning
0 | Users can work offline if they are disconnected from this server.
1 | Users cannot work offline if they are disconnected from this server.
Reskit REG_SZ 1

indicates that users are not permitted to work offline when they are disconnected from the Reskit server.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Non-default server disconnect actions policy (Computer Configuration\Administrative Templates\Network\Offline Files). Click Show, and then click Add. In the Type the name of the item to be added box, type the server's computer name. Then, in the Type the value of the item to be added box, type 0 if users can work offline when they are disconnected from this server, or type 1 if they cannot.

To configure this setting without setting a policy, in Windows Explorer, on the Tools menu, click Folder Options, click the Offline Files tab, and then click Advanced. This policy corresponds to the settings in the Exception list section.

Note Image Note

This entry takes precedence over a user setting. When this entry appears in the registry, the system disables the Exception list section of the Offline Files tab and ignores the value of entries in the CustomGoOfflineActions subkey in HKCU\Software\Microsoft\Windows\CurrentVersion\NetCache, which stores its data. If the Exception list does not operate as expected, check to see if this entry is in the registry.

This subkey and its entries can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If this entry appears in both subtrees, the value in HKEY_LOCAL_MACHINE takes precedence over the value in HKEY_CURRENT_USER.

Tip Image Tip

To specify customized offline action rules without establishing a policy, in Windows Explorer, on the Tools menu, click Folder Options, click the Offline Files tab, and then click Advanced. This policy corresponds to the settings in the Exception list section.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

CustomGoOfflineActions subkey (HKCU)


DefCacheSize

HKLM\SOFTWARE\Policies\Microsoft\Windows\NetCache

Data type | Range | Default value
REG_DWORD | (Not in registry) | 0 - 10000 percentage of disk space (* 100) | 1000 (10.00 percent)

Description

Limits the percentage of the computer's disk space that can be used to store automatically-cached offline files, and prevents users, including administrators, from changing it.

This entry stores the setting of the Default cache size Group Policy. Group Policy adds this entry to the registry when you enable theDefault cache size policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry.

The value of this entry is a percentage of disk space, specified to the hundredth of a percent (a ten-thousandth), but without a decimal point. To enter a value, multiply the decimal value of the percentage by 10000, or multiply the percent value by 100.

For example, to specify 76.25%, multiply .7625 by 10,000 or multiply 76.25 by 100. Group Policy enters the resulting value, 7625, in the value of this entry.

Value | Meaning
(Not in registry) | The policy is disabled or not configured. The system limits disk space for automatically-cached files to 10 percent of the system drive by default, but users can change it.
0 - 10000 | Specifies the automatic-cache disk space limit, and prevents users from changing it.

When this entry appears in the registry, the system disables the Amount of disk space to use for temporary offline files option on the Offline Files tab in Folder Options of Windows Explorer. This prevents users from changing the option while a policy is in effect.

Automatic caching can be set on any network share. When a user opens a file on the share, the system automatically stores a copy of the file on the user's computer.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Default cache size policy (Computer Configuration\Administrative Templates\Network\Offline Files).

To change the amount of disk space used for automatic caching without setting a policy, use Windows Explorer. On the Tools menu, click Folder Options, click the Offline Files tab, and then use the slider bar associated with the Amount of disk space to use for temporary offline files option.

Note Image Note

This entry takes precedence over a user setting. When this entry appears in the registry, a policy is in effect and the system disables the Amount of disk space to use for temporary offline files option on the Offline Files tab and ignores the value of DefCacheSize in HKLM\Software\Microsoft\Windows\CurrentVersion\NetCache which stores the option setting. If the Offline Files tab does not operate as expected, check to see if this entry is in the registry.

This entry does not limit the disk space available for files that user's make available offline manually.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


Enabled

HKLM\SOFTWARE\Policies\Microsoft\Windows\NetCache

Data type | Range | Default value
REG_DWORD | (Not in registry) | 0 | 1 | Windows 2000 Professional: 1 Windows 2000 Server: 0

Description

Enables and disables the Offline Files feature, and prevents users from changing the setting.

This entry stores the setting of the Enabled Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Enabled policy. If you disable the policy, Group Policy sets this value to 0. If you set the policy to Not configured, Group Policy deletes the entry from the registry.

Value | Meaning
(Not in registry) | Offline Files is enabled in Windows 2000 Professional and disabled in Windows 2000 Server, but users can change the setting.
0 | Offline Files is disabled, and users cannot enable it.
1 | Offline Files is enabled, and users cannot disable it.

To prevent users from changing the setting while a policy is in effect, the system disables the Enable Offline Files option on the Offline Files tab.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Enabled policy (Computer Configuration\Administrative Templates\Network\Offline Files) in Group Policy).

To enable offline files without setting a policy, use Windows Explorer. On the Tools menu, click Folder Options, click the Offline Files tab, and then click Enable Offline Files.

Activation method

To make changes to this entry effective, you must restart Windows 2000.

Note Image Note

This entry takes precedence over a user setting. When this entry appears in the registry, a policy is in effect and the system disables the Enable Offline Files option on the Offline Files tab and ignores the value of Enabled in HKLM\Software\Microsoft\Windows\CurrentVersion\NetCache which stores the option setting. If the Offline Files tab does not operate as expected, check to see if this entry is in the registry.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


EventLoggingLevel

HKLM\SOFTWARE\Policies\Microsoft\Windows\NetCache

Data type | Range | Default value
REG_DWORD | 0 - 3 | 0

Description

Determines which events the Offline Files feature records in the Application Log in Event Viewer.

This entry stores the setting in the Enter {0 – 3} box of the Event logging level Group Policy. Group Policy adds this entry to the registry when you configure the Event logging level policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

The values in the following table are cumulative; that is, each level includes the events in all preceding levels.

Value | Meaning
0 | Records an error when the Offline Files cache is corrupted.
1 | Also records an event when the server hosting the offline file is disconnected from the network.
2 | Also records events when the local computer is connected and disconnected from the network.
3 | Also records an event when the server hosting the offline file is reconnected to the network.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Event logging level policy (Computer Configuration\Administrative Templates\Network\Offline Files).

Note Image Note

This entry can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If this entry appears in both subtrees, the value in HKEY_LOCAL_MACHINE takes precedence over the value in HKEY_CURRENT_USER.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

EventLoggingLevel (HKCU)


ExcludeExtensions

HKLM\SOFTWARE\Policies\Microsoft\Windows\NetCache

Data type | Range | Default value
REG_SZ | *.File-name-extension[;*. file-name-extension] | (Blank)

Description

Lists types of files that cannot be used offline. The list stored in this entry overrides the system's default list of file types that are never cached for offline use.

This entry stores the setting of the Files not cached Group Policy. Group Policy adds this entry to the registry when you enable the Event logging level policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system uses the default list of non-cached file types.

By default, the system never caches files of the following types, as identified by their file name extension:

File type | Filename extension
.SLM | Microsoft Source Library Management file
.MDB | Microsoft Access database file
.LDB | Microsoft Access security file
.MDW | Microsoft Access Workgroup file
.MDE | Microsoft Access compiled module file
.PST | Microsoft Outlook personal folder file
.DB? | Generic database file

The list you create in this entry replaces the system's default list of non-cached files. Thus, to add a file to the default list, type a list that includes the default files and the type you are adding. To remove a file type from this list, type a list that includes all file types in the default list, except for the type you are removing.

The system maintains a list of non-cached files to protect files that cannot be separated, such as database components. Non-cached files are excluded from automatic and manual caching for offline use. The system does not cache files of the type specified even when they reside on a network share configured for automatic caching. Also, if users try to make a file of this type available offline, the operation will fail and the system displays the following message in the Synchronization Manager Progress dialog box:

Files of this type cannot be made available offline

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Files not cached policy (Computer Configuration\Administrative Templates\Network\Offline Files).

Activation method

To make changes to this entry effective, you must log off and log on again.

Note Image Note

This policy was documented incorrectly on the Explain tab in Group Policy for Windows 2000.

To make changes to this policy effective, you must log off and log on again.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


GoOfflineAction

HKLM\SOFTWARE\Policies\Microsoft\Windows\NetCache

Data type | Range | Default value
REG_DWORD | (Not in registry) | 0 | 1 | (Not in registry)

Description

Determines whether network files remain available if the computer is suddenly disconnected from the server hosting the files. Also, it prevents users, including administrators, from changing this option.

This entry stores the setting of the Action on server disconnect Group Policy. Group Policy adds this entry to the registry when you configure the Action on server disconnect policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry.

Value | Meaning
(Not in registry) | The policy is disabled or not configured. Users can work offline by default, but administrators can change this option.
0 | The policy is enabled and set to Work offline. Users can use local copies of network files while the server is inaccessible.
1 | The policy is enabled and set to Never go offline. Network files are not available while the server is inaccessible.

When this entry appears in the registry, the system disables the When a network connection is lost option on the Offline Files tab in Folder Options in Windows Explorer. This prevents administrators from changing the option while a policy is in effect.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Action on server disconnect policy (Computer Configuration\Administrative Templates\Network\Offline Files). Use the Action drop-down box to specify how computers in the group respond.

To configure offline actions without setting a policy, use Windows Explorer. On the Tools menu, click Folder Options, click the Offline Files tab, click Advanced, and then select an option in the When a network connection is lost section.

Note Image Note

This entry takes precedence over a user setting. When this entry appears in the registry, the system disables the When a network connection is lost option on the Offline Files tab and ignores the value of GoOfflineAction in HKCU\Software\Microsoft\Windows\CurrentVersion\NetCache, which stores the option setting. If the Offline Files tab does not operate as expected, check to see if this entry is in the registry.

This entry can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If this entry appears in both subtrees, the value in HKEY_LOCAL_MACHINE takes precedence over the value in HKEY_CURRENT_USER.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

GoOfflineAction (HKCU)

CustomGoOfflineActions subkey (HKLM)


InitialBalloonTimeoutSeconds

HKLM\SOFTWARE\Policies\Microsoft\Windows\NetCache

Data type | Range | Default value
REG_DWORD | 10 - 60 seconds | 30

Description

Determines how long the first reminder balloon for a network status change is displayed.

This entry stores the setting of the Initial reminder balloon lifetime Group Policy. Group Policy adds this entry to the registry when you configure the Initial reminder balloon lifetime policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system uses the default value of 30 seconds.

Reminder balloons appear when the user's connection to a network file is lost or reconnected and are updated periodically. By default, the first reminder for an event is displayed for 30 seconds. Then, updates appear every 60 minutes and are displayed for 15 seconds. You can use this entry to change the duration of the first reminder.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Initial reminder balloon lifetime policy (Computer Configuration\Administrative Templates\Network\Offline Files).

Note Image Note

This entry can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If this entry appears in both subtrees, the value in HKEY_LOCAL_MACHINE takes precedence over the value in HKEY_CURRENT_USER.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

InitialBalloonTimeoutSeconds (HKCU)


NoCacheViewer

HKLM\SOFTWARE\Policies\Microsoft\Windows\NetCache

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Removes the Offline Files folder.

The Offline Files folder lists network files stored on the local computer for offline use. Users can use the Offline Files folder to view or open copies of network files, and view characteristics of offline files, such as their server status, type, and location.

This entry stores the setting of the Prevent use of Offline Files folder Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Prevent use of Offline Files folder policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 | Displays the Offline Files folder.
1 | Removes the Offline Files folder.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Prevent use of Offline Files folder policy (Computer Configuration\Administrative Templates\Network\Offline Files).

Note Image Note

This entry affects the Offline Files folder only. It does not prevent users from working offline or from saving local copies of files available offline. Also, it does not prevent them from using other programs, such as Windows Explorer, to view their offline files.

This entry can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If this entry appears in both subtrees, the value in HKEY_LOCAL_MACHINE takes precedence over the value in HKEY_CURRENT_USER.

Tip Image Tip

To view the Offline Files folder, use Windows Explorer. Click the Tools menu, click Folder Options, click the Offline Files tab, and then click View Files.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoCacheViewer (HKCU)


NoConfigCache

HKLM\SOFTWARE\Policies\Microsoft\Windows\NetCache

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Prevents users from enabling, disabling, or changing the configuration of Offline Files.

This entry stores the setting of the Disable user configuration of Offline Files Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Disable user configuration of Offline Files policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 | The policy is disabled or not configured. Users can configure Offline Files.
1 | The policy is enabled. Users cannot configure Offline Files.

When the value of this entry is 1, the system removes the Offline Files tab from the Folder Options dialog box. It also removes the Settings item from the Offline Files context menu and disables the Settings button on the Offline Files Status dialog box. As a result, users cannot view or change the options on the Offline Files tab or the Offline Files dialog box.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable user configuration of Offline Files policy (Computer Configuration\Administrative Templates\Network\Offline Files).

Note Image Note

This entry takes precedence over a user setting. When this entry appears in the registry, a policy is in effect and the system ignores the entries in the HKLM\Software\Microsoft\Windows\CurrentVersion\NetCache and HKCU\Software\Microsoft\Windows\CurrentVersion\NetCache subkeys which store the option settings. If the Offline Files tab does not operate as expected, check to see if this entry is in the registry.

This entry can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If this entry appears in both subtrees, the value in HKEY_LOCAL_MACHINE takes precedence over the value in HKEY_CURRENT_USER.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoConfigCache (HKCU)

NoFolderOptions


NoMakeAvailableOffline

HKLM\SOFTWARE\Policies\Microsoft\Windows\NetCache

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Prevents users from making network files and folders available offline.

This entry stores the setting of the Disable "Make Available Offline" Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Disable "Make Available Offline" policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 | Users can make network files and folders available offline.
1 | Users cannot make network files and folders available offline.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable "Make Available Offline" policy (Computer Configuration\Administrative Templates\Network\Offline Files).

Note Image Note

This entry disables manual caching only. It does not prevent the system from saving local copies of files on shares designated for automatic caching.

This entry can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If this entry appears in both subtrees, the value in HKEY_LOCAL_MACHINE takes precedence over the value in HKEY_CURRENT_USER.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoMakeAvailableOffline (HKCU)


NoReminders

HKLM\SOFTWARE\Policies\Microsoft\Windows\NetCache

Data type | Range | Default value
REG_DWORD | (Not in registry) | 0 | 1 | (Not in registry)

Description

Determines whether reminder balloons are displayed, and prevents users from changing the setting.

This entry stores the setting of the Disable reminder balloons Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Disable reminder balloons policy. If you disable the policy, Group Policy sets the value to 0. If you set the policy to Not configured, Group Policy deletes the entry from the registry.

Value | Meaning
(Not in registry) | The policy is not configured. Reminder balloons are displayed, but users can hide them.
0 | The policy is disabled. Reminder balloons are displayed, and users cannot hide them.
1 | The policy is enabled. Reminder balloons are hidden, and users cannot display them.

When this value appears in the registry, the system disables the Enable reminders option on the Offline Files tab to prevent users from changing the setting while a policy is in effect.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable reminder balloons policy (User Configuration\Administrative Templates\Network\Offline Files).

Note Image Note

This entry takes precedence over a user setting. When this entry appears in the registry, the system disables the Enable reminders option on the Offline Files tab and ignores the value of NoReminders in HKCU\Software\Microsoft\Windows\CurrentVersion\NetCache, which stores the option setting. If the Offline Files tab does not operate as expected, check to see if this entry is in the registry.

This entry can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If this entry appears in both subtrees, the value in HKEY_LOCAL_MACHINE takes precedence over the value in HKEY_CURRENT_USER.

Tip Image Tip

To disable reminder balloons without setting a policy, use Windows Explorer. On the Tools menu, click Folder Options, click the Offline Files tab, and then clear the Enable reminders check box.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoReminders (HKCU)


PurgeAtLogoff

HKLM\SOFTWARE\Policies\Microsoft\Windows\NetCache

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Deletes the contents of the Offline Files cache when the user logs off. The Offline Files cache stores local copies of automatically-cached and manually-cached offline files.

This entry stores the setting of the At logoff, delete local copy of user’s offline files Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the At logoff, delete local copy of user’s offline files policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 | The policy is disabled or not configured. Local copies of offline files are retained in the Offline Files cache.
1 | The policy is enabled. Local copies of offline files are retained only while the user is logged on the computer. When the user logs off, the system empties the Offline File cache.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the At logoff, delete local copy of user’s offline files policy (Computer Configuration\Administrative Templates\Network\Offline Files).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Caution Image Caution

The system does not update network copies of files (synchronize) before deleting the local files. Changes to local files since the last synchronization are lost.


ReminderBalloonTimeoutSeconds

HKLM\SOFTWARE\Policies\Microsoft\Windows\NetCache

Data type | Range | Default value
REG_DWORD | 10 - 60 seconds | 15

Description

Determines how long updated reminder balloons are displayed.

This entry stores the setting of the Reminder balloon lifetime Group Policy. Group Policy adds this entry to the registry when you configure the Reminder balloon lifetime policy.

Reminder balloons appear when the user's connection to a network file is lost or reconnected and are updated periodically. By default, the first reminder for an event is displayed for 30 seconds. Then, updates appear every 60 minutes and are displayed for 15 seconds. You can use this entry to change the duration of the update reminder.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Reminder balloon lifetime policy (Computer Configuration\Administrative Templates\Network\Offline Files).

Note Image Note

This entry can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If this entry appears in both subtrees, the value in HKEY_LOCAL_MACHINE takes precedence over the value in HKEY_CURRENT_USER.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

ReminderBalloonTimeoutSeconds (HKCU)


ReminderFreqMinutes

HKLM\SOFTWARE\Policies\Microsoft\Windows\NetCache

Data type | Range | Default value
REG_DWORD | 0 - 1440 minutes | 60

Description

Determines how often reminder balloon updates appear, and prevents users from changing the setting.

This entry stores the setting of the Minutes box in the Reminder balloon frequency Group Policy. Group Policy adds this entry to the registry when you configure the Reminder balloon frequency policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system uses the default value of 60 minutes.

When this entry appears in the registry, the system removes the Display reminder balloon every … minutes option on the Offline Files tab. This prevents users from changing the setting while a policy is in effect.

Reminder balloons appear when the user's connection to a network file is lost or reconnected and are updated periodically. By default, the first reminder for an event is displayed for 30 seconds. Then, updates appear every 60 minutes and are displayed for 15 seconds. You can use this entry to change the update interval.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Reminder balloon frequency policy (Computer Configuration\Administrative Templates\Network\Offline Files).

Note Image Note

This entry takes precedence over a user setting. When this entry appears in the registry, the system disables the Display reminder balloon every … minutes option on the Offline Files tab and ignores the value of ReminderFreqMinutes in HKCU\Software\Microsoft\Windows\CurrentVersion\NetCache, which stores the option setting. If the Offline Files tab does not operate as expected, check to see if this entry is in the registry.

This entry can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If this entry appears in both subtrees, the value in HKEY_LOCAL_MACHINE takes precedence over the value in HKEY_CURRENT_USER.

Tip Image Tip

To set reminder balloon frequency without setting a policy, use Windows Explorer. On the Tools menu, click Folder Options, and then click the Offline Files tab. This entry corresponds to the Display reminder balloon every … minutes option.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

ReminderFreqMinutes (HKCU)


SyncAtLogoff

HKLM\SOFTWARE\Policies\Microsoft\Windows\NetCache

Data type | Range | Default value
REG_DWORD | (Not in registry) | 0 | 1 | (Not in registry)

Description

Determines whether the system performs a full or quick synchronization of offline files when users log off, and prevents users, including administrators, from changing the setting.

Quick synchronization ensures that files are complete, but does not ensure that they are current. Full synchronization ensures that offline files are complete and current.

This entry stores the setting of the Synchronize all offline files before logging off Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Synchronize all offline files before logging off policy. If you disable the policy, Group Policy sets the value to 0. If you set the policy to Not configured, Group Policy deletes the entry from the registry.

Value | Meaning
(Not in registry) | The policy is not configured. The system performs a quick synchronization by default, but administrators can change the setting.
0 | The policy is disabled. The system performs a quick synchronization, and administrators cannot change this setting.
1 | The policy is enabled. The system performs a full synchronization, and administrators cannot change this setting.

When this entry appears in the registry, the system disables the Synchronize all offline files before logging off option on the Offline Files tab. This prevent administrators from changing the synchronization option while a policy is in effect.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Synchronize all offline files before logging off policy (Computer Configuration\Administrative Templates\Network\Offline Files).

To change the synchronization method without setting a policy, use Windows Explorer. On the Tools menu, click Folder Options, click the Offline Files tab, and then select the Synchronize all offline files before logging off option.

Note Image Note

This entry takes precedence over a user setting. When this entry appears in the registry, a policy is in effect and the system disables the Synchronize all offline files before logging off option on the Offline Files tab and ignores the value of SyncAtLogoff in HKCU\Software\Microsoft\Windows\CurrentVersion\NetCache which stores the option setting. If the Offline Files tab does not operate as expected, check to see if this entry is in the registry.

This entry can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If this entry appears in both subtrees, the value in HKEY_LOCAL_MACHINE takes precedence over the value in HKEY_CURRENT_USER.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

SyncAtLogoff (HKCU)


Network Connections

HKLM\SOFTWARE\Policies\Microsoft\Windows\

Description

The Network Connections subkey contains entries that store Group Policy settings for Network and Dial-up Connections. The entries in this subkey are written and maintained by Group Policy, and are read and interpreted by the Network and Dial-up Connections program.

This subkey in HKEY_LOCAL_MACHINE stores entries related to policies that apply to all users of this computer. There is also a Software\Policies\Microsoft\Windows\Network Connections subkey in HKEY_CURRENT_USER, which stores policy-related entries that are configured separately for each user.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


NC_ShowSharedAccessUI

HKLM\SOFTWARE\Policies\Microsoft\Windows\Network Connections

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether the Sharing tab and Internet Connection Sharing wizard page are displayed. These dialog boxes let administrators enable, disable, and configure the Internet Connection Sharing feature of a dial-up connection.

When displayed, the Sharing tab appears in the Properties dialog box for a dial-up connection on all Windows 2000 systems. The Internet Connection Sharing page appears in the Network Connection wizard only on Windows 2000 Server.

This entry stores the setting of the Allow configuration of connection sharing Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Allow configuration of connection sharing policy. If you disable the policy, Group Policy sets the value to 0. If you set the policy to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 1.

Value | Meaning
0 | The policy is disabled. The system removes the Sharing tab and Internet Connection Sharing wizard page.
1 | The policy is enabled or not configured. The system displays the Sharing tab and Internet Connection Sharing wizard page.

Internet Connection Sharing lets users configure their system as an Internet gateway for a small network. It provides network services, such as name resolution, to the network.

By default, Internet Connection Sharing is disabled when you create a dial-up connection, but administrators can use the Sharing tab and Internet Connection Sharing wizard page to enable it.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Allow configuration of connection sharing policy (Computer Configuration\Administrative Templates\Network\Network and Dial-up Connections).

Note Image Note

This entry applies only to users in the Administrators group.

This entry can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If the entry appears in both places, the value of the entry in HKEY_LOCAL_MACHINE takes precedence over the value in HKEY_CURRENT_USER.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NC_ShowSharedAccessUI (HKCU)


Psched

HKLM\SOFTWARE\Policies\Microsoft\Windows\

Description

The Psched subkey stores entries created when you configure a Group Policy for the Quality of Service (QoS) Packet Scheduler.

Each entry in this subkey stores a policy setting used to configure the Packet Scheduler. These entries are read and interpreted by the Packet Scheduler when it implements the policy.

Note Image Note

The policy-related entries in this subkey are not included in the Administrative Template (.adm) files provided with Windows 2000. To use these entries, you must write a policy and then add it to a new or existing .adm file. For instructions, see Advanced topic: Creating custom .adm files in Windows 2000 Server Help.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


DiffServByteMappingConforming

HKLM\SOFTWARE\Policies\Microsoft\Windows\Psched

Description

The DiffServByteMappingConforming subkey stores entries that specify an alternate Differentiated Services Code Point (DSCP) value for service types specified in the per-flow flowspec. The Packet Scheduler inserts the corresponding DSCP value in the IP header of the packets. These entries apply only to packets that conform to the flow specification.

This subkey can also contain an entry assigning a default DSCP value to packets carrying TCP traffic that are not otherwise classified to a flow.

This subkey stores the entries created when you enable the policies in the DSCP value of conforming packets folder in Group Policy (Computer Configuration\Administrative Templates\Network\QoS Packet Scheduler). You can use these policies to override the default DSCP value used for packets of any recognized service type.

  • If you enable the policies in the DSCP value of conforming packets folder, the system adds entries to this subkey with values you specify in the policy.
  • If you disable the policies in the DSCP value of conforming packets folder or do not configure them, Group Policy deletes these entries from the registry, and the Packet Scheduler uses the default values.

This subkey can also contain a ServiceTypeTcpTraffic entry that stores the value you enter in the DSCP value field of the Specify default marking for TCP traffic Group Policy. Despite the name of the entry, this policy is not limited to a particular service type. It applies to all TCP traffic that is not otherwise classified to a flow.

  • If you enable the Specify default marking for TCP traffic Group Policy, the system adds the ServiceTypeTcpTraffic entry to the registry and inserts the value you enter in the IP header of the packets.
  • If you disable the Specify default marking for TCP traffic Group Policy or do not configure it, Group Policy deletes the ServiceTypeTcpTraffic entry from the registry, and the Packet Scheduler uses the default value of 0.

All entries in this subkey have the following format:

Entry name | Data type | Value
<Service-type> | REG_DWORD | 0x0 - 0x3F

For example, the entry that overrides the default DCSP value for the Guaranteed service type appears as follows:

Entry name | Data type | Value
ServiceTypeGuaranteed | REG_DWORD | 0x20

The following table shows the DSCP value used when no entries appear in this subkey. ServiceTypeTcpTraffic applies to all conforming packets carrying TCP traffic, regardless of their service type.

Service type | Default DSCP value
ServiceTypeBestEffort | 0x00
ServiceTypeControlledLoad | 0x18
ServiceTypeGuaranteed | 0x28
ServiceTypeNetworkControl | 0x30
ServiceTypeQualitative | 0x00
ServiceTypeTcpTraffic | 0x00

Change method

To change the value of entries in this subkey, use Group Policy.

Note Image Note

The policy-related entries in this subkey are not included in the Administrative Template (.adm) files provided with Windows 2000. To use these entries, you must write a policy and then add it to a new or existing .adm file. For instructions, see Advanced topic: Creating custom .adm files in Windows 2000 Server Help.

The entries in this subkey apply to all network adapters on the computer. You can also change the DSCP values for packets on any particular network adapter by adding entries to the DiffServByteMappingConforming subkey in HKLM\SYSTEM\CurrentControlSet\Services\Psched\Parameters\Adapters\<Adapter-GUID>. If entries appear in the both locations in the registry, the adapter-specific entry takes precedence over the policy when configuring that particular adapter.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

DiffServByteMappingNonConforming (Policies subkey)

DiffServByteMappingConforming (<Adapter-GUID> subkey)

DiffServByteNonMappingConforming (<Adapter-GUID> subkey)


DiffServByteMappingNonConforming

HKLM\SOFTWARE\Policies\Microsoft\Windows\Psched

Description

The DiffServByteMappingNonConforming subkey stores entries that specify an alternate Differentiated Services Code Point (DSCP) value for service types specified in the per-flow flowspec. The Packet Scheduler inserts the corresponding DSCP value in the IP header of the packets. These entries apply only to packets that do not conform to the flow specification.

This subkey stores the entries created when you enable the policies in the DSCP value of non-conforming packets folder in Group Policy (Computer Configuration\Administrative Templates\Network\QoS Packet Scheduler). You can use these policies to override the default DSCP value used for packets of any recognized service type.

By default, the service type of all non-conforming packets have a DSCP value of 0x00, but these policies add entries to this subkey that override the default DSCP value used for packets of all recognized service types.

  • If you enable the policies in the DSCP value of non-conforming packets folder, the system adds entries to this subkey with values you specify in the policy.
  • If you disable the policies in the DSCP value of non-conforming packets folder or do not configure them, Group Policy deletes these entries from the registry, and the Packet Scheduler uses the default values.

All entries in this subkey have the following format:

Entry name | Data type | Value
<Service-type> | REG_DWORD | 0x0 - 0x3F

For example, the entry that changes the DSCP value associated with the Guaranteed service type appears as follows.

Entry name | Data type | Value
ServiceTypeGuaranteed | REG_DWORD | 0x20

The valid service types are as follows. ServiceTypeTcpTraffic applies to all conforming packets carrying TCP traffic, regardless of their service type.

  • ServiceTypeBestEffort
  • ServiceTypeControlledLoad
  • ServiceTypeGuaranteed
  • ServiceTypeNetworkControl
  • ServiceTypeQualitative

Change method

To change the value of entries in this subkey, use Group Policy.

Note Image Note

The policy-related entries in this subkey are not included in the Administrative Template (.adm) files provided with Windows 2000. To use these entries, you must write a policy and then add it to a new or existing .adm file. For instructions, see Advanced topic: Creating custom .adm files in Windows 2000 Server Help.

The entries in this subkey apply to all network adapters on the computer. You can also change the DSCP values of packets on any particular network adapter by adding entries to the DiffServByteMappingNonConforming subkey in HKLM\SYSTEM\CurrentControlSet\Services\Psched\Parameters\Adapters\<Adapter-GUID>. If entries appear in the both locations in the registry, the adapter-specific entry takes precedence over the policy when configuring that particular adapter.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

DiffServByteNonMappingConforming (<Adapter-GUID> subkey)

DiffServByteMappingConforming (Policies subkey)

DiffServByteMappingConforming (<Adapter-GUID> subkey)


MaxOutstandingSends

HKLM\SOFTWARE\Policies\Microsoft\Windows\Psched

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF | 0xFFFF

Description

Determines the maximum number of outstanding packets permitted on the system. When the number of outstanding packets reaches this limit, the Packet Scheduler postpones submissions to all network adapters until the number falls below this limit.

Outstanding packets are packets that the Packet Scheduler has submitted to the network adapter for transmission, but which the network adapter has not yet sent.

This entry stores the setting of the Limit outstanding packets policy (Computer Configuration\Administrative Templates\Network\QoS Packet Scheduler). Group Policy adds this entry to the registry when you enable the Limit outstanding packets policy.

  • If you enable this policy, the system sets the value of this entry to 1.
  • If you disable this policy or do not configure it, Group Policy deletes this entry from the registry.

If the value of this entry is too low, packets can accumulate in the Packet Scheduler when network traffic is heavy. The packet scheduler services packet flows in order of priority or weight.

If the value of this entry is too high, packets can accumulate in the network adapter, rather than the Packet Scheduler. In this case, the queue servicing routines implemented by the Packet Scheduler sequencer have no effect on the order in which packets from different flows are transmitted. However, the system benefits from the optimized performance of pipelining on the adapter.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Limit outstanding packets Group Policy (Computer Configuration\Administrative Templates\Network\QoS Packet Scheduler).

Note Image Note

This entry is not included in an Administrative Template (.adm) files provided with Windows 2000. To use this entry, you must write a policy and add it to a new or existing .adm file. For instructions, see Advanced topic: Creating custom .adm files in Windows 2000 Server Help.

This entry applies to all network adapters on the computer. You can also set an outstanding packet limit for any particular network adapter by using the MaxOutstandingSends entry in an HKLM\SYSTEM\CurrentControlSet\Services\Psched\Parameters\Adapters\<Adapter-GUID> subkey. If both entries appear in the registry, the adapter-specific entry takes precedence over the policy when configuring that particular adapter.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

Related Entries

MaxOutstandingSends


NonBestEffortLimit

HKLM\SOFTWARE\Policies\Microsoft\Windows\Psched

Data type | Range | Default value
REG_DWORD | 0 - 100 percentage of connection bandwidth | 20

Description

Determines the percentage of connection bandwidth that the system can reserve. This value limits the combined bandwidth reservations all programs running on the system.

This entry stores the setting of the Limit reserved bandwidth Group Policy (Computer Configuration\Administrative Templates\Network\QoS Packet Scheduler). Group Policy adds this entry to the registry when you enable the Limit reserved bandwidth policy.

  • If you enable the policy, the system sets the value of this entry to the value you specify in the policy.
  • If you disable this policy or do not configure it, Group Policy deletes this entry from the registry and the Packet Scheduler uses the default value of 20%.

Change method

To change the value of this entry, use Group Policy.

Note Image Note

This entry is not included in an Administrative Template (.adm) files provided with Windows 2000. To use this entry, you must write a policy and add it to a new or existing .adm file. For instructions, see Advanced topic: Creating custom .adm files in Windows 2000 Server Help.

This entry applies to all network adapters on the computer. You can also set a connection bandwidth limit for any particular network adapter by using the NonBestEffortLimit entry in an HKLM\SYSTEM\CurrentControlSet\Services\Psched\Parameters\Adapters\<Adapter-GUID> subkey. If both entries appear in the registry, the adapter-specific entry takes precedence over the policy when configuring that particular adapter.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

Related Entries

NonBestEffortLimit (<Adapter-GUID> subkey)


TimerResolution

HKLM\SOFTWARE\Policies\Microsoft\Windows\Psched

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF microseconds | (System default, typically 10 microseconds)

Description

Determines the smallest unit of time that the Packet Scheduler uses when scheduling packets for transmission. The Packet Scheduler cannot schedule packets for transmission more frequently than permitted by the value of this entry.

This entry stores the setting of the Set timer resolution policy (Computer Configuration\Administrative Templates\Network\QoS Packet Scheduler). Group Policy adds this entry to the registry when you enable the Set timer resolution policy.

  • If you enable this policy, Group Policy stores the value you specify in the policy in the value of this entry.
  • If you disable this policy or do not configure it, Group Policy deletes this entry from the registry and uses the default timer resolution set for the system.

If you enter a value that is too small for the Hardware Abstraction Layer on your system to support, the system uses the smallest supported interval.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Set timer resolution Group Policy (Computer Configuration\Administrative Templates\Network\QoS Packet Scheduler).

Note Image Note

This entry is not included in an Administrative Template (.adm) files provided with Windows 2000. To use this entry, you must write a policy and add it to a new or existing .adm file. For instructions, see Advanced topic: Creating custom .adm files in Windows 2000 Server Help.

This entry takes precedence over a user setting. When this entry appears in the registry, a policy is in effect and the system ignores the value of TimerResolution in the Psched\Parameters subkey.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

Related Entries

TimerResolution (Psched\Parameters subkey)


UserPriorityMapping

HKLM\SOFTWARE\Policies\Microsoft\Windows\Psched

Description

The UserPriorityMapping subkey stores entries that specify an alternate link layer (Layer-2) priority value for service types specified in the per-flow flowspec. The Packet Scheduler inserts the link layer priority value in the Layer-2 priority header of packets. These entries apply only to packets that conform to the flow specification.

This subkey can also contain an entry assigning a default priority value to packets carrying TCP traffic. This entry applies only to TCP packets that are not otherwise classified to a flow.

This subkey stores the entries created when you enable the policies in the Layer-2 priority value folder in Group Policy (Computer Configuration\Administrative Templates\Network\QoS Packet Scheduler). You can use these policy to override the default Layer-2 priority value used for packets of any recognized service type.

  • If you enable the policies in the Layer-2 priority value folder, the system adds entries to this subkey with values you specify in the policy.
  • If you disable the policies in the Layer-2 priority value folder or do not configure them, Group Policy deletes these entries from the registry and the Packet Scheduler uses the default values.

This subkey also can contain a ServiceTypeTcpTraffic entry that stores the value you enter in the Priority value field of the Specify default marking for TCP traffic Group Policy (Computer Configuration\Administrative Templates\Network\QoS Packet Scheduler). Despite the name of the entry, this policy is not limited to a particular service type. It applies to all TCP traffic that is not otherwise classified to a flow.

  • If you enable the Specify default marking for TCP traffic Group Policy, the system adds the ServiceTypeTcpTraffic entry to the registry, and then inserts its value in the Layer-2 header of affected packets.
  • If you disable the Specify default marking for TCP traffic Group Policy or do not configure it, Group Policy deletes the ServiceTypeTcpTraffic entry from the registry, and the Packet Scheduler uses the default value of 0.

All entries in this subkey have the following format:

Entry name | Data type | Value
<Service-type> | REG_DWORD | 0 - 7

For example, the entry that changes the priority value associated with the Guaranteed service type appears as follows.

Entry name | Data type | Value
ServiceTypeGuaranteed | REG_DWORD | 6

The following table shows the priority values assigned when no entries appear in this subkey. ServiceTypeNonConforming applies to all packets that do not conform to the flow specification. ServiceTypeTcpTraffic applies to packets carrying TCP traffic that is not otherwise classified to a flow.

Value | Meaning
ServiceTypeNonConforming | 1
ServiceTypeBestEffort | 0
ServiceTypeControlledLoad | 4
ServiceTypeGuaranteed | 5
ServiceTypeNetworkControl | 7
ServiceTypeQualitative | 0
ServiceTypeTcpTraffic | 0

Change method

To change the value of entries in this subkey, use Group Policy.

Note Image Note

The policy-related entries in this subkey are not included in the Administrative Template (.adm) files provided with Windows 2000. To use these entries, you must write a policy and then add it to a new or existing .adm file. For instructions, see Advanced topic: Creating custom .adm files in Windows 2000 Server Help.

The entries in this subkey apply to all network adapters on the computer. You can also change the priority values of packets on any particular network adapter by adding entries to the UserPriorityMapping subkey in HKLM\SYSTEM\CurrentControlSet\Services\Psched\Parameters\Adapters\<Adapter-GUID>. If entries appear in the both locations in the registry, the adapter-specific entry takes precedence over the policy when configuring that particular adapter.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

UserPriorityMapping (<Adapter-GUID> subkey)


System

HKLM\SOFTWARE\Policies\Microsoft\Windows\

Description

The System subkey contains entries that store Group Policy settings for the operating system, such as the logon environment, task scheduler, and permissions to set and update group policies. These entries are created and maintained by Group Policy, and are read and interpreted by system component programs.

The Policies\Microsoft\Windows\System subkey in HKEY_LOCAL_MACHINE stores entries related to policies that apply to all users of this computer. There is also a Policies\Microsoft\Windows\System subkey in HKEY_CURRENT_USER, which stores policy-related entries that are configured separately for each user.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

HKCU\Software\Policies\Microsoft\Windows\System

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System

HKLM\SOFTWARE\Policies\Microsoft\System

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System


DeleteRoamingCache

HKLM\SOFTWARE\Policies\Microsoft\Windows\System

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether the system saves a copy of a user's roaming profile on the local computer's hard drive when the user logs off.

Roaming profiles reside on a network server. By default, when users with roaming profiles log off, the system also saves a copy of their roaming profile on the hard drive of the computer they are using in case the server that stores the roaming profile is unavailable when the user logs on again. The local copy is also used when the remote copy of the roaming user profile is slow to load.

This entry stores the setting of the Delete cached copies of roaming profiles Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Delete cached copies of roaming profiles policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 | The policy is disabled or not configured. The system saves a local copy of the user's roaming profile.
1 | The policy is enabled. The system deletes all local copies of the user's roaming profile when the user logs off. The roaming profile still remains on the network server.

This entry, and the related entries listed below, together describe a strategy for managing user profiles residing on remote servers. In particular, they tell the system how to respond when a remote profile is slow to load.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Delete cached copies of roaming profiles policy (Computer Configuration\Administrative Templates\System\Logon).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Caution Image Caution

Do not set the value of this entry to 1 if you are using the slow link detection feature of Windows 2000. To respond to a slow link, the system requires a local copy of the user's roaming profile.

Related Entries

ProfileErrorAction

SlowLinkDefault

SlowLinkDetectEnabled

SlowLinkTimeOut (Policies subkey)

SlowLinkTimeOut (Winlogon subkey)

SlowLinkUIEnabled

UserProfileMinTransferRate


GroupPolicyMinTransferRate

HKLM\SOFTWARE\Policies\Microsoft\Windows\System

Data type | Range | Default value
REG_DWORD | 0x0 | 0x1 - 0xFFFFFFF kilobits per second | 0x1F4 (500 kilobits per second)

Description

Defines a slow connection for purposes of applying and updating Group Policy.

If a policy update travels from the domain controller to the computer at a rate slower than is specified value of this entry, the system considers the connection to be slow.

This entry stores the setting of the Connection speed (Kbps) box in the Group Policy slow link detection Group Policy. Group Policy adds this entry to the registry when you enable the Group Policy slow link detection policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 500 kilobits.

If the value of this entry is 0x0, all connections are considered to be fast.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Group Policy slow link detection policy (Computer Configuration\Administrative Templates\System\Group Policy). In the Connection speed box, type a decimal number between 0 and 4,294,967,200 (0xFFFFFFA0), indicating a transfer rate in kilobits per second. Any connection slower than this rate is considered to be slow. If you type 0, all connections are considered to be fast.

Note Image Note

The system's response to a slow policy connection is determined by the program implementing the policy. Also, the policy processing entries in the HKLM\Software\Policies\Microsoft\Windows\Group Policy\<Class-ID> subkeys let you override the programs' specified responses to slow connections.

This entry appears in both HKEY_CURRENT_USER and HKEY_LOCAL_MACHINE. The value of this entry in HKEY_LOCAL_MACHINE defines a slow link for policies in the Computer Configuration folder. The value of this entry in HKEY_CURRENT_USER defines a slow link for policies in the User Configuration folder.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

GroupPolicyMinTransferRate (HKCU)

SlowLinkDetectEnabled


GroupPolicyRefreshTimeDC

HKLM\SOFTWARE\Policies\Microsoft\Windows\System

Data type | Range | Default value
REG_DWORD | 0 - 64800 minutes | 5

Description

Determines how often Group Policy for computers is updated on domain controllers while they are running (in the background).

This entry specifies a background update rate only for Group Policies in the Computer Configuration folder. The updates specified by this entry occur in addition to updates performed when the system starts.

This entry stores the setting you enter in the update time Minutes box of the Group Policy refresh interval for domain controllers Group Policy. Group Policy adds this entry to the registry when you enable the Group Policy refresh interval for domain controllers policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 5 minutes.

If the value of this entry is 0, the domain controller tries to update Group Policy every 7 seconds. However, because updates might interfere with users' work and increase network traffic, very short update intervals are not appropriate for most installations.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Group Policy refresh interval for domain controllers policy (Computer Configuration\Administrative Templates\System\Group Policy).

Note Image Note

This entry is used only when you are establishing policy for a domain, site, organizational unit (OU), or customized group. If you are establishing policy for a local computer only, the system ignores the value of this entry.

The Group Policy refresh interval for domain controllers policy also includes an time offset to prevent computers with the same update interval from requesting updates simultaneously. The offset is stored in the value of GroupPolicyRefreshTimeOffsetDC.

If background updates are disabled (that is, the value of DisableBkGndGroupPolicy entry is 1, this entry is ignored.

This entry can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If this entry appears in both subtrees, the value in HKEY_LOCAL_MACHINE takes precedence over the value in HKEY_CURRENT_USER.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

GroupPolicyRefreshTime (HKCU)

GroupPolicyRefreshTime (HKLM)

GroupPolicyRefreshTimeOffset (HKCU)

GroupPolicyRefreshTimeOffset (HKLM)

GroupPolicyRefreshTimeOffsetDC


GroupPolicyRefreshTimeOffsetDC

HKLM\SOFTWARE\Policies\Microsoft\Windows\System

Data type | Range | Default value
REG_DWORD | 0 - 1440 minutes | 0

Description

Determines the maximum time offset used when updating computer Group Policy settings on domain controllers.

This entry specifies the maximum length of random offset time interval. The system calculates the actual offset at run time and adds it to the Group Policy update interval for that computer. The offset prevents clients with the same update interval from requesting updates simultaneously.

This entry stores the setting of the random time Minutes box on the Group Policy refresh interval for domain controllers Group Policy. Group Policy adds this entry to the registry when you enable the Group Policy refresh interval for domain controllers policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0 minutes.

A large value establishes a broad range and makes it less likely that client update requests overlap. However, updates might be delayed significantly.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Group Policy refresh interval for domain controllers policy (Computer Configuration\Administrative Templates\System\Group Policy).

Note Image Note

This entry is used only when you are establishing policy for a domain, site, organizational unit (OU), or customized group. If you have established a policy for a local computer only, the system ignores the value of this entry.

The Group Policy refresh interval for domain controllers policy also lets you set the update interval. This interval is stored in the value of GroupPolicyRefreshTimeDC (HKLM).

This entry applies only to Group Policy settings in the Computer Configuration folder.

If background updates are disabled (that is, the value of DisableBkGndGroupPolicy entry is 1, this entry is ignored.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

GroupPolicyRefreshTimeDC (HKLM)

GroupPolicyRefreshTimeOffset (HKLM)

DisableBkGndGroupPolicy


ProfileDlgTimeOut

HKLM\SOFTWARE\Policies\Microsoft\Windows\System

Data type | Range | Default value
REG_DWORD | 0 - 600 seconds | 0x1E (30 seconds)

Description

Determines how long the system waits for a user response before it uses a default value.

The default value is applied when the user does not respond to messages explaining that any of the following events has occurred:

  • The system detects a slow connection between users' computers and the server that stores the users' roaming user profiles.
  • The system cannot access users' server-based profiles when users log on or off.
  • Users' local profiles are newer than their server-based profiles.

This entry stores the setting of the Timeout for dialog boxes Group Policy. Group Policy adds this entry to the registry with the value you entry when you enable the Timeout for dialog boxes policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 30 seconds.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Timeout for dialog boxes policy (Computer Configuration\Administrative Templates\System\Logon). Type a decimal number between 0 and 600 for the length of the interval

Note Image Note

This entry takes precedence over a user setting. When this entry appears in the registry, a policy is in effect and the system ignores the value of ProfileDlgTimeOut.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

EnableProfileQuota

IncludeRegInProQuota

MaxProfileSize

ProfileQuotaMessage

SlowLinkDefault

SlowLinkTimeOut

UserProfileMinTransferRate


ProfileErrorAction

HKLM\SOFTWARE\Policies\Microsoft\Windows\System

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Logs a user off automatically when the system cannot load the user's roaming user profile. This entry is used when the system cannot find the roaming user profile or the profile contains errors which prevent it from loading correctly.

This entry stores the setting of the Log users off when roaming profile fails Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Log users off when roaming profile fails policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 | Disabled. When the roaming profile fails to load, the system loads a local copy of the roaming user profile. If a local copy is not available, the system loads the default user profile (stored in Systemroot\Documents and Settings\Default User).
1 | Enabled. When the roaming profile fails to load, the system logs the user off.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Log users off when roaming profile fails policy (Computer Configuration\Administrative Templates\System\Logon).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

DeleteRoamingCache


ProfileUnloadTimeout

HKLM\SOFTWARE\Policies\Microsoft\Windows\System

Data type | Range | Default value
REG_DWORD | 0x0 | 0x1- 0xFFFFFFF retries | 0x3C (60)

Description

Determines how many times the system tries to unload and update the registry portion of a user profile. When the number of trials specified in the value of this entry is exhausted, the system stops trying. As a result, the user profile might not be current, and local and roaming user profiles might not match.

This entry stores the setting of the Maximum retries to unload and update user profile Group Policy. Group Policy adds this entry to the registry when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 60.

When a user logs off of the computer, the system unloads the user-specific section of the registry (HKEY_CURRENT_USER) into a file (NTUSER.DAT) and updates it. However, if another program or service is reading or editing the registry, the system cannot unload it. The system tries repeatedly (at a rate of once per second) to unload and update the registry settings. By default, the system repeats its periodic attempts 60 times (over the course of one minute). You can use the policy to adjust the maximum number of retries. (You cannot adjust the retry rate.)

Value | Meaning
(Not in registry) | The policy is disabled or not configured. The system repeats its attempt 60 times.
0x0 | The policy is enabled and set to 0. The system tries just once to unload and update the user's registry settings. It does not try again.
0x1 - 0xFFFFFFFF | Specifies the number of times the system tries to unload and update the user's registry settings.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Maximum retries to unload and update user profile policy (Computer Configuration\Administrative Templates\System\Logon).

Note Image Note

This policy is particularly important to servers running Terminal Services. Because Terminal Services edits the user's registry settings when they log off, the system's first few attempts to unload the user settings are more likely to fail.

This policy does not affect the system's attempts to update the files in the user profile.

Tip Image Tip

Consider increasing the number of retries specified in this policy if there are many user profiles stored in the computer's memory. This indicates that the system has not been able to unload the profile.

Check the Application Log in Event Viewer for events generated by Userenv. The system records an event whenever it tries to unload the registry portion of the user profile. The system also records an event when it fails to update the files in a user profile.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


SlowLinkDetectEnabled

HKLM\SOFTWARE\Policies\Microsoft\Windows\System

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Enables and disables the system's slow link detection feature.

Slow link detection measures the speed of the connection between a user's computer and the remote server that stores the roaming user profile. When the system detects a slow link, the related entries listed below tell the system how to respond.

This entry stores the setting of the Do not detect slow network connections Group Policy. Group Policy adds this entry to the registry with a value of 0 when you enable the Do not detect slow network connections policy. If you disable the policy, Group Policy sets the value to 1. If you set the policy to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 1.

Value | Meaning
0 | The policy is enabled. Slow link detection is disabled. The system does not detect slow connections or recognize any connections as being slow. As a result, the system does not respond to slow connections to user profiles and it ignores the policies that tell the system how to respond to a slow connection.
1 | The policy is disabled or not configured. Slow link detection is enabled. The system measures the speed of the connection between the user's computer and profile server. If the connection is slow (as defined by the SlowLinkTimeOut and UserProfileMinTransferRate entries), the system uses the related entries to determine how to proceed. By default, when the connection is slow, the system loads a local copy of the user profile.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Do not detect slow network connections policy (Computer Configuration\Administrative Templates\System\Logon).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

DeleteRoamingCache

ProfileErrorAction

SlowLinkTimeOut

SlowLinkDefault

SlowLinkUIEnabled

UserProfileMinTransferRate


SlowLinkProfileDefault

HKLM\SOFTWARE\Policies\Microsoft\Windows\System

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Directs the system to wait for the remote copy of the roaming user profile to load, even when loading is slow. Also, the system waits for the remote copy when the user is notified about a slow connection, but does not respond in the time allowed.

This entry stores the setting of the Wait for remote user profile Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Wait for remote user profile policy. If you disable the policy or set it to Not Configured, Group Policy deletes this entry from the registry and the system behaves as though it were set to 0.

Value | Meaning
0 | The policy is disabled or not configured. When a remote profile is slow to load, the system loads the local copy of the roaming user profile. The local copy is also used when the user is consulted (as set in the SlowLinkUIEnabled entry), but does not respond in the time allowed (as set in ProfileDlgTimeOut).
1 | The policy is enabled. The system waits for the remote copy of the user profile to load.

This entry and the related entries listed below together define the system's response when roaming user profiles are slow to load.

Waiting for the remote profile is appropriate when users move between computers frequently and the local copy of their profile is not always current. Using the local copy is desirable when quick logging on is a priority.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Wait for remote user profile policy (Computer Configuration\Administrative Templates\System\Logon).

Note Image Note

This entry takes precedence over a user setting. When this entry appears in the registry, a policy is in effect and the system ignores the value of SlowLinkProfileDefault in HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon. If remote user profiles do not operate as expected, check to see if this entry is in the registry.

If the value of SlowLinkDetectEnabled is 1, this entry is ignored. Also, if the value of DeleteRoamingCache is 1, there is no local copy of the roaming profile to load when the system detects a slow connection.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

DeleteRoamingCache

ProfileErrorAction

SlowLinkDetectEnabled

SlowLinkTimeOut

SlowLinkUIEnabled

UserProfileMinTransferRate


SlowLinkTimeOut

HKLM\SOFTWARE\Policies\Microsoft\Windows\System

Data type | Range | Default value
REG_DWORD | 0 - 20000 milliseconds | 120

Description

Defines a slow connection for roaming user profiles for non-IP computers.

This entry stores the setting of the Time (milliseconds) box in the Slow network connection timeout for user profiles Group Policy. Group Policy adds this entry to the registry when you enable the Slow network connection timeout for user profiles policy. If you disable the policy or set it to Not Configured, Group Policy deletes this entry from the registry and the system behaves as though it were set to 120 milliseconds.

If the server on which the user's roaming user profile resides takes longer to respond than the threshold set by this entry, then the system considers the connection to the profile to be slow.

This entry and the related entries together define the system's response when roaming user profiles are slow to load.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Time (milliseconds) spin box in the Slow network connection timeout for user profiles policy (Computer Configuration\Administrative Templates\System\Logon).

Note Image Note

For IP computers, use the UserProfileMinTransferRate entry.

If the value of the SlowLinkDetectEnabled entry is set to 1, this entry is ignored. Also, if the value of the DeleteRoamingCache entry is set to 1, there is no local copy of the roaming profile to load when the system detects a slow connection.

Tip Image Tip

Consider increasing this value for clients using DHCP Service-assigned addresses or for computers accessing profiles across dial-up connections.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

DeleteRoamingCache

ProfileErrorAction

SlowLinkDetectEnabled

SlowLinkDefault

SlowLinkUIEnabled


SlowLinkUIEnabled

HKLM\SOFTWARE\Policies\Microsoft\Windows\System

Data type | Range | Default value
REG_DWORD | 0 (Not in registry) | 1 | 0

Description

Notifies users when their roaming profile is slow to load. The notice lets users decide whether to use a local copy or to wait for the roaming user profile.

This entry stores the setting of the Prompt user when slow link is detected Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Prompt user when slow link is detected policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 | (Entry does not appear.) | Users are not notified when their roaming profile is slow to load. By default, the system loads the local copy of the profile. However, if the value of SlowLinkDefault is 1, then the system loads the remote copy of the user profile.
1 | Users are notified when their roaming profile is slow to load and are asked how to proceed.

This entry and the related entries in this subkey together define the system's response when roaming user profiles are slow to load.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Prompt user when slow link is detected policy (Computer Configuration\Administrative Templates\System\Logon).

Note Image Note

If the value of SlowLinkDetectEnabled is 1, this entry is ignored. Also, if the value of DeleteRoamingCache is 1, there is no local copy of the roaming profile to load when the system detects a slow connection.

Tip Image Tip

To adjust the time within which the user must respond to this notice, use ProfileDlgTimeOut.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

DeleteRoamingCache

ProfileErrorAction

SlowLinkDefault

SlowLinkDetectEnabled

SlowLinkTimeOut

UserProfileMinTransferRate


UserPolicyMode

HKLM\SOFTWARE\Policies\Microsoft\Windows\System

Data type | Range | Default value
REG_DWORD | (Not in registry) | 1 | 2 | (Not in registry)

Description

Applies the user Group Policy settings established for this computer to its users.

By default, user Group Policy settings are applied to particular users, regardless of which computer they are using. However, this entry directs the system to apply the user Group Policy settings established for this computer to its users. The computer's user Group Policy settings affect users only while they are using this computer.

This feature designed for special-use computers, such as those in public places, laboratories, and classrooms, where you might need extra security.

This entry stores the setting of the User Group Policy loopback processing mode Group Policy. Group Policy adds this entry to the registry when you enable the User Group Policy loopback processing mode policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry.

Value | Meaning
(Not in registry) | The policy is disabled or not configured. The user's Group Policy settings are applied to the user.
1 | The policy is enabled and set to Merge. The system applies the computer's user Group Policy settings and the user's user Group Policy settings. When the policy settings conflict, the computer's user Group Policy settings are applied.
2 | The policy is enabled and set to Replace. Only the computer's user Group Policy settings are applied.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the User Group Policy loopback processing mode policy (Computer Configuration\Administrative Templates\System\Group Policy).

Select one of the following policy modes from the Mode box.

  • Replace indicates that the user policies defined in the computer's Group Policy objects replace the user policies normally applied to the user.
  • Merge indicates that the user policies defined in the computer's Group Policy objects and the user policies normally applied to the user are combined. If the policy settings conflict, the user policies in the computer's Group Policy objects take precedence over the user's normal policies.

Note Image Note

This policy is effective only when both the computer account and the user account are in Windows 2000 domains.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


UserProfileMinTransferRate

HKLM\SOFTWARE\Policies\Microsoft\Windows\System

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF kilobits per second | 0x1F4 (500 kilobits per second)

Description

Defines a slow connection for roaming user profiles for computers connected to IP networks.

This entry stores the setting of the Connection speed spin box in the Slow network connection timeout for user profiles Group Policy. Group Policy adds this entry to the registry when you enable the Slow network connection timeout for user profiles policy. If you disable the policy or set it to Not Configured, Group Policy deletes this entry from the registry and the system behaves as though the value is 500 kilobits per second.

If the server on which the user's roaming user profile resides takes longer to respond than the threshold set by this entry, then the system considers the connection to the profile to be slow.

This entry and the related entries together define the system's response when roaming user profiles are slow to load.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Connection speed spin box in the Slow network connection timeout for user profiles policy (Computer Configuration\Administrative Templates\System\Logon).

Note Image Note

For non-IP computers, use the SlowLinkTimeOut entry.

If the value of SlowLinkDetectEnabled is 1, this entry is ignored. Also, if the value of DeleteRoamingCache entry is 1, there is no local copy of the roaming profile to load when the system detects a slow connection.

Tip Image Tip

Consider increasing this value for clients using DHCP Service-assigned addresses or for computers accessing profiles across dial-up connections.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

DeleteRoamingCache

ProfileErrorAction

SlowLinkDetectEnabled

SlowLinkDefault

SlowLinkUIEnabled


Task Scheduler5.0

HKLM\SOFTWARE\Policies\Microsoft\Windows\

Description

The Task Scheduler5.0 subkey stores the entries created when you configure a Group Policy for the Scheduled Tasks feature of Windows 2000. These entries are created and maintained by Group Policy, and are read and interpreted by Scheduled Tasks.

The Task Scheduler5.0 subkey in the Policies subkey in HKEY_LOCAL_MACHINE stores entries that apply to all users of the computer. The system adds these entries when you enable (and, for some policies, when you disable) a policy in the Computer Configuration folder in Group Policy.

There is also a Task Scheduler5.0 subkey in the Policies subkey in HKEY_CURRENT_USER, which stores entries that are configured separately for each user. The system adds these entries when you enable (and, for some policies, when you disable) a policy in the User Configuration folder in Group Policy.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


Allow Browse

HKLM\SOFTWARE\Policies\Microsoft\Windows\Task Scheduler5.0

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Limits newly scheduled items to programs on the user's Start menu and prevents the user from changing the scheduled program for existing tasks.

A value of 1 removes the Browse button from the Scheduled Task wizard and from the Task tab of the properties dialog box for a task. Also, users cannot edit the Run box or the Start in box that determine the program and path for a task. As a result, when users create a task, they must select a program from the list in the Scheduled Task wizard, which displays only the tasks that appear on the Start menu and its submenus. Once a task is created, users cannot change the program a task runs.

This entry stores the setting of the Prohibit Browse Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Prohibit Browse policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 | The policy is disabled or not configured. Users can schedule any program and can change the programs that existing tasks run
1 | The policy is enabled. Users can only schedule tasks that run programs on their Start menu. They cannot change the programs that existing tasks run.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Prohibit Browse policy (Computer Configuration\Administrative Templates\Windows Components\Task Scheduler).

Note Image Note

This does not prevent users from creating a new task by pasting or dragging any program into the Scheduled Tasks folder. To prevent this action, use DragAndDrop.

This entry can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If this entry appears in both subtrees, the value in HKEY_LOCAL_MACHINE takes precedence over the value in HKEY_CURRENT_USER.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

Allow Browse (HKCU)

DragAndDrop (HKLM)


Disable Advanced

HKLM\SOFTWARE\Policies\Microsoft\Windows\Task Scheduler5.0

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Removes the Open advanced properties for this task when I click Finish item from last page of the Scheduled Task wizard. As a result, users cannot view or change the properties of newly created tasks. This setting is designed to simplify task creation for beginning users.

This entry stores the setting of the Disable Advanced Menu Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Disable Advanced Menu policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 | The policy is disabled or not configured. Users can view and change the properties of newly created tasks.
1 | The policy is enabled. Users cannot view or change the properties of newly created tasks.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable Advanced Menu policy (Computer Configuration\Administrative Templates\Windows Components\Task Scheduler).

Note Image Note

This entry can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If this entry appears in both subtrees, the value in HKEY_LOCAL_MACHINE takes precedence over the value in HKEY_CURRENT_USER.

Tip Image Tip

This entry affects newly created tasks only. To prevent users from changing the properties of existing tasks, use Property Pages.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

Disable Advanced (HKCU)

Property Pages (HKLM)


DragAndDrop

HKLM\SOFTWARE\Policies\Microsoft\Windows\Task Scheduler5.0

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Disables the Cut, Copy, and Paste shortcut items on the context menu and on the Edit menu in Scheduled Tasks. It also disables the drag-and-drop features of the Scheduled Tasks folder. As a results, users cannot add new scheduled tasks by dragging, moving, or copying a document or program into the Scheduled tasks folder.

This entry stores the setting of the Disable Drag-and-Drop Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Disable Drag-and-Drop policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 | The policy is disabled or not configured. The cut, paste, move, and drag and drop features of the Scheduled Tasks folder are enabled.
1 | The policy is enabled. The cut, paste, move, and drag and drop features of the Scheduled Tasks folder are disabled.

This entry does not prevent users from using other methods to create new tasks and it does not prevent users from deleting tasks.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable Drag-and-Drop policy (Computer Configuration\Administrative Templates\Windows Components\Task Scheduler).

Note Image Note

This entry can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If this entry appears in both subtrees, the value in HKEY_LOCAL_MACHINE takes precedence over the value in HKEY_CURRENT_USER.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

DragAndDrop (HKCU)


Execution

HKLM\SOFTWARE\Policies\Microsoft\Windows\Task Scheduler5.0

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Removes the Run and End Task items from the context menu that appears when you right-click a task in Scheduled Tasks. As a result, users cannot start tasks manually or force tasks to end.

This entry stores the setting of the Prevent Task Run or End Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Prevent Task Run or End policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 | The policy is disabled or not configured. Users can start and stop tasks manually.
1 | The policy is enabled. Users cannot start and stop tasks manually.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Prevent Task Run or End policy (Computer Configuration\Administrative Templates\Windows Components\Task Scheduler).

Note Image Note

This entry can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If this entry appears in both subtrees, the value in HKEY_LOCAL_MACHINE takes precedence over the value in HKEY_CURRENT_USER.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

Execution (HKCU)


Property Pages

HKLM\SOFTWARE\Policies\Microsoft\Windows\Task Scheduler5.0

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Removes the Properties item from the File menu in Scheduled Tasks and from the context menu that appears when you right-click a task.

As a result, users cannot viewing or change the properties of an existing task, such as the program the task runs, its schedule details, idle time and power management settings, and its security context. They can only see the properties that appear in Detail view and in the task preview.

This entry stores the setting of the Hide Property Pages Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Hide Property Pages policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 | The policy is disabled or not configured. Users can view and change the properties of a task.
1 | The policy is enabled. Users cannot view or change the properties of a task.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Hide Property Pages policy (Computer Configuration\Administrative Templates\Windows Components\Task Scheduler).

Note Image Note

This entry affects existing tasks only. To prevent users from changing the properties of newly created tasks, use Disable Advanced.

This entry can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If this entry appears in both subtrees, the value in HKEY_LOCAL_MACHINE takes precedence over the value in HKEY_CURRENT_USER.

Tip Image Tip

This entry affects existing tasks only. To prevent users from changing the properties of newly created tasks, use the Disable Advanced (HKCU) entry.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

Disable Advanced (HKLM)

Property Pages (HKCU)


Task Creation

HKLM\SOFTWARE\Policies\Microsoft\Windows\Task Scheduler5.0

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Prevents users from creating new tasks in Scheduled Tasks.

A value of 1 removes the Add Scheduled Task item that starts the New Task wizard. Also, the system does not respond when users try to move, paste, or drag programs or documents into the Scheduled Tasks folder.

This entry stores the setting of the Disable New Task Creation Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Disable New Task Creation policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 | The policy is disabled or not configured. The user can create new tasks.
1 | The policy is enabled. The user cannot create new tasks.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable New Task Creation policy (Computer Configuration\Administrative Templates\Windows Components\Task Scheduler).

Note Image Note

This entry does not prevent administrators of a computer from using At.exe to create new tasks or prevent administrators from submitting tasks from remote computers.

This entry can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If this entry appears in both subtrees, the value in HKEY_LOCAL_MACHINE takes precedence over the value in HKEY_CURRENT_USER.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

Task Creation (HKCU)

Task Deletion (HKLM)


Task Deletion

HKLM\SOFTWARE\Policies\Microsoft\Windows\Task Scheduler5.0

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Prevents users from deleting new tasks in Scheduled Tasks.

A value of 1 removes the Delete item from the Edit menu in the Scheduled Tasks folder and from the menu that appears when you right-click a task. Also, the system does not respond when users try to cut or drag a task from the Scheduled Tasks folder.

This entry stores the setting of the Disable Task Deletion Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Disable Task Deletion policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 | The policy is disabled or not configured. The user can delete tasks.
1 | The policy is enabled. The user cannot delete tasks.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Disable Task Deletion policy (Computer Configuration\Administrative Templates\Windows Components\Task Scheduler).

Note Image Note

This entry does not prevent administrators of a computer from using At.exe to delete tasks.

This entry can appear in both HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER. If this entry appears in both subtrees, the value in HKEY_LOCAL_MACHINE takes precedence over the value in HKEY_CURRENT_USER.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

Task Deletion (HKCU)

Task Creation (HKLM)


Windows NT

HKLM\SOFTWARE\Policies\Microsoft\

Description

The Policies\Microsoft\Windows NT subkey contains entries that store Group Policy settings for Windows 2000. These entries are created and maintained by Group Policy, and are read and interpreted by the system components.

The Policies\Microsoft subkey in HKEY_LOCAL_MACHINE stores entries that apply to all users of the computer. The system adds these entries when you enable (and, for some policies, when you disable) a policy in the Computer Configuration folder in Group Policy.

There is also a Policies\Microsoft\Windows NT subkey in HKEY_CURRENT_USER, which stores policy-related entries that are configured separately for each user. The system adds these entries when you enable (and, for some policies, when you disable) a policy in the User Configuration folder in Group Policy.

Change method

To add, delete, or change an entry in this subkey, use Group Policy.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

Windows NT (Policy subkey in HKCU)


DiskQuota

HKLM\SOFTWARE\Policies\Microsoft\Windows NT\

Description

The DiskQuota subkey contains entries that store Group Policy settings for disk quotas on NTFS volumes. These entries are created and maintained by Group Policy, and are read and interpreted by the Disk Quota program.

The Disk Quota policies included in Windows 2000 limit the amount of disk space users can consume, and they determine how the system responds when users exceed a warning level or quota limit.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


ApplyToRemovableMedia

HKLM\SOFTWARE\Policies\Microsoft\Windows NT\DiskQuota

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Extends the disk quota policies in this folder to NTFS file system volumes on removable media.

This entry stores the setting of the Apply policy to removable media Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Apply policy to removable media policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 | The policy is disabled. Disk quota Group Policy settings apply only to fixed media.
1 | The policy is disabled. Disk quota Group Policy settings apply to fixed and removable media.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Apply policy to removable media policy (Computer Configuration\Administrative Templates\System\Disk Quotas).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

DiskQuota subkey


Enable

HKLM\SOFTWARE\Policies\Microsoft\Windows NT\DiskQuota

Data type | Range | Default value
REG_DWORD | (Not in registry) | 0 | 1 | (Not in registry)

Description

Enables and disables disk quota management on all NTFS volumes of the computer, and prevents users from changing the setting.

This entry stores the setting of the Enable disk quotas Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Enable disk quotas policy. If you disable the policy, Group Policy sets the value of this entry to 0. If you set the policy to Not configured, Group Policy deletes the entry from the registry.

Value | Meaning
(Not in registry) | The policy is not configured. Disk quota management is disabled, but administrators can enable it.
0 | The policy is disabled. Disk quota management is disabled, and administrators cannot enable it.
1 | The policy is enabled. Disk quota management is enabled and administrators cannot disable it.

To prevent users from changing the setting while a policy is in effect, the system disables the Enable quota management option on the Quota tab of NTFS volumes.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Enable disk quotas policy (Computer Configuration\Administrative Templates\System\Disk Quotas).

Note Image Note

This entry takes precedence over a user setting stored on the NTFS volume. When this entry appears in the registry, a policy is in effect and the system disables the Enable quota management option on the Quota tab. If the Quota tab does not operate as expected, check to see if this entry is in the registry.

This entry enables disk quota management but does not establish or enforce a particular disk quota limit. To specify a disk quota limit, use the Default quota limit and warning level policy (stored in Limit, LimitUnits, Threshold, and ThresholdUnits). Otherwise, the system uses the physical space on the volume as the quota limit.

Tip Image Tip

To enable or disable disk quota management without setting a policy, in My Computer, right-click the name of an NTFS volume, click Properties, click the Quota tab, and then click the Enable quota management option.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

Enforce

Limit

LimitUnits

Threshold

ThresholdUnits


Enforce

HKLM\SOFTWARE\Policies\Microsoft\Windows NT\DiskQuota

Data type | Range | Default value
REG_DWORD | (Not in registry) | 0 | 1 | (Not in registry)

Description

Determines whether disk quota limits are enforced and prevents users from changing the setting.

This entry stores the setting of the Enforce disk quota limit Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Enforce disk quota limit policy. If you disable the policy, Group Policy sets the value of this entry to 0. If you set the policy to Not configured, Group Policy deletes this entry from the registry.

Value | Meaning
(Not in registry) | The policy is not configured. The disk quota limit is not enforced by default, but administrators can change the setting to enforce it.
0 | The policy is disabled. The disk quota limit is not enforced and administrators cannot change the setting to enforce it.
1 | The policy is enabled. The disk quota limit is enforced and administrators cannot change the setting to turn enforcement off.

To prevent administrators from changing the enforcement setting while a policy is in effect, the system disables the Deny disk space to users exceeding quota limit option on the Quota tab.

When users reach an enforced limit, the system responds as though the physical space on the volume were exhausted. When users reach an unenforced limit, their status in the Quota Entries window changes, but they can continue to write to the volume as long as physical space is available.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Enforce disk quota limit policy (Computer Configuration\Administrative Templates\System\Disk Quotas).

Note Image Note

This entry takes precedence over a user setting stored on the NTFS volume. When this entry appears in the registry, a policy is in effect and the system disables the Deny disk space to users exceeding quota limit option on the Quota tab. If the Quota tab does not operate as expected, check to see if this entry is in the registry.

This entry enforces disk quota limits, but does not establish or enforce a particular disk quota limit. To specify a disk quota limit, use the Default quota limit and warning level policy (stored in Limit, LimitUnits, Threshold, and ThresholdUnits). Otherwise, the system uses the physical space on the volume as the quota limit.

Tip Image Tip

To enforce disk quotas without setting a policy, in My Computer, right-click the name of an NTFS volume, click Properties, click the Quota tab, and then click the Deny disk space to users exceeding quota limit option.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

Enable

Limit

LimitUnits

Threshold

ThresholdUnits


Limit

HKLM\SOFTWARE\Policies\Microsoft\Windows NT\DiskQuota

Data type | Range | Default value
REG_DWORD | (Not in registry) | 0 - 1000 | (Not in registry)

Description

Specifies the number of units in the default disk quota limit for new users of an NTFS volume.

This entry is used in configuring the disk quota management feature of NTFS file system volumes. Along with the value of LimitUnits, which specifies the unit of the disk quota limit, this entry restricts the disk space that new users of an NTFS volume can consume.

This entry stores the number you enter in the Value box of the Default quota limit and warning level Group Policy. Group Policy adds Limit to the registry when you enable the Default quota limit and warning level policy. If you disable the policy or set it to Not configured, Group Policy deletes this entry from the registry. If you do so, the system uses the amount of physical space on the volume as the disk quota limit.

Value | Meaning
(Not in registry) | There is no specified disk quota limit. Users are limited to the physical space on each NTFS volume.
1 - 1000 | The number of units in the disk quota limit for new users.

The quota limit established by the policy overrides the user settings for quota limits. Also, when you set a quota limit, the system disables the corresponding options in the Select the default quota limit for new users of this volume section on the Quota tab so administrators cannot change the limits while a policy is in effect.

This entry applies to all new users as soon as they write to the volume. It does not affect disk quota limits for current users or affect customized limits and warning levels set for particular users (on the Quota tab in Volume Properties).

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Default quota limit and warning level policy (Computer Configuration\Administrative Templates\System\Disk Quotas).

Note Image Note

This entry is effective only when disk quota management is enabled on the volume (see Enable. Also, if disk quotas are not enforced (see Enforce), users can exceed the quota limit you set. When users reach the quota limit, their status in the Quota Entries window changes, but users can continue to write to the volume.

Tip Image Tip

When you select a limit, remember that the same limit applies to all users on all volumes, regardless of actual volume size. Be sure to set the limit so that it is reasonable for the range of volumes in the group.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

Enforce

LimitUnits

Threshold

ThresholdUnits


LimitUnits

HKLM\SOFTWARE\Policies\Microsoft\Windows NT\DiskQuota

Data type | Range | Default value
REG_DWORD | (Not in registry) | 1-6 | (Not in registry)

Description

Specifies the units used in the default disk quota limit for new users of an NTFS volume.

This entry is used in configuring the disk quota management feature of NTFS file system volumes. Along with the value of Limit, which specifies the number of unit in the disk quota limit, this entry restricts the disk space that new users of an NTFS volume can consume.

This entry stores the value you enter in the Default quota limit Units box of the Default quota limit and warning level Group Policy. Group Policy adds LimitUnits to the registry when you enable the Default quota limit and warning level policy. If you disable the policy or set it to Not configured, Group Policy deletes this entry from the registry. Then, the system uses the amount of physical space on the volume as the disk quota limit.

Value | Meaning
(Entry does not appear.) | The disk space available to users is not limited. The disk quota management feature uses the physical space on each volume as its quota limit.
1 | KB (kilobytes)
2 | MB (megabytes)
3 | GB (gigabytes)
4 | TB (terabytes)
5 | PB (picabytes)
6 | EB (exabytes)

The quota limit established by the policy overrides the user settings for quota limits. Also, when you set a quota limit, the system disables the corresponding options in the Select the default quota limit for new users of this volume section on the Quota tab so administrators cannot change the limits while a policy is in effect.

This entry applies to all new users as soon as they write to the volume. It does not affect disk quota limits for current users or affect customized limits and warning levels set for particular users (on the Quota tab in Volume Properties).

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Default quota limit and warning level policy (Computer Configuration\Administrative Templates\System\Disk Quotas).

Note Image Note

This entry is effective only when disk quota management is enabled on the volume (see Enable . Also, if disk quotas are not enforced (see Enforce), users can exceed the quota limit you set. When users reach the quota limit, their status in the Quota Entries window changes, but users can continue to write to the volume.

Tip Image Tip

When you select a limit, remember that the same limit applies to all users on all volumes, regardless of actual volume size. Be sure to set the limit so that it is reasonable for the range of volumes in the group.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

Enforce

Limit

Threshold

ThresholdUnits


LogEventOverLimit

HKLM\SOFTWARE\Policies\Microsoft\Windows NT\DiskQuota

Data type | Range | Default value
REG_DWORD | (Not in registry) | 0 | 1 | (Not in registry)

Description

Determines whether the system records an event in the local Application Log when users reach their disk quota limit on a volume, and prevents users from changing the logging setting.

This entry stores the setting of the Log event when quota limit exceeded Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Log event when quota limit exceeded policy. If you disable the policy, Group Policy sets the value of this entry to 0. If you set the policy to Not configured, Group Policy deletes the entry from the registry.

Value | Meaning
(Not in registry) | No events are recorded, but administrators can use the Quota tab option to change the setting.
0 | The policy is disabled. No events are recorded, and administrators cannot change the logging setting.
1 | The policy is enabled. The system records an event when the user reaches their disk quota limit, and administrators cannot change the logging setting.

When this entry appears in the registry, the system disables the Log event when a user exceeds their quota limit option on the Quota tab so administrators cannot change the setting while a policy is in effect.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Log event when quota limit exceeded policy (Computer Configuration\Administrative Templates\System\Disk Quotas).

Note Image Note

This entry takes precedence over a user setting stored on the NTFS volume. When this entry appears in the registry, a policy is in effect and the system disables the Log event when quota limit exceeded option on the Quota tab. If the Quota tab does not operate as expected, check to see if this entry is in the registry.

This policy is independent of the enforcement policies for disk quotas. As a result, you can direct the system to log an event regardless of whether or not you choose to enforce the disk quota limit.

This policy does not affect the Quota Entries window on the Quota tab. Even without the logged event, users can detect that they have reached their limit because their status in the Quota Entries window changes.

Tip Image Tip

To turn on logging without setting a policy, in My Computer, right-click the name of an NTFS volume, click Properties, click the Quota tab, and then click the Log event when a user exceeds their quota limit option.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

LogEventOverThreshold


LogEventOverThreshold

HKLM\SOFTWARE\Policies\Microsoft\Windows NT\DiskQuota

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether the system records an event in the local Application Log when users reach their disk quota warning level, and prevents users from changing the logging setting.

This entry stores the setting of the Log event when quota warning level exceeded Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Log event when quota warning level exceeded policy. If you disable the policy, Group Policy sets the value of this entry to 0. If you set the policy to Not configured, Group Policy deletes the entry from the registry.

Value | Meaning
(Not in registry) | No events are recorded, but administrators can use the Quota tab option to change the setting.
0 | The policy is disabled. No events are recorded, and administrators cannot change the logging setting.
1 | The policy is enabled. The system records an event when the user reaches their disk quota warning level, and administrators cannot change the logging setting.

When this entry appears in the registry, the system disables the Log event when a user exceeds their warning level option on the Quota tab so administrators cannot change the setting while a policy is in effect.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Log event when quota warning level exceeded policy (Computer Configuration\Administrative Templates\System\Disk Quotas).

Note Image Note

This entry takes precedence over a user setting stored on the NTFS volume. When this entry appears in the registry, a policy is in effect and the system disables the Log event when a user exceeds their warning level option on the Quota tab. If the Quota tab does not operate as expected, check to see if this entry is in the registry.

This policy does not affect the Quota Entries window on the Quota tab. Even without the logged event, users can detect that they have reached their warning level because their status in the Quota Entries window changes.

Tip Image Tip

To turn on logging without setting a policy, in My Computer, right-click the name of an NTFS volume, click Properties, click the Quota tab, and then click the Log event when a user exceeds their warning level option.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

LogEventOverLimit


Threshold

HKLM\SOFTWARE\Policies\Microsoft\Windows NT\DiskQuota

Data type | Range | Default value
REG_DWORD | (Not in registry) | 1 - 1000 | (Not in registry.)

Description

Specifies the number of units in the default disk quota warning level for new users of an NTFS volume.

This entry is used in configuring the disk quota management feature of NTFS file system volumes. Along with the value of ThresholdUnits, this entry specifies the warning level, that is, the point at which the user's status in the Quota Entries window changes to indicate that the user is approaching the disk quota limit.

This entry stores the number you enter in the Default warning level Value box of the Default quota limit and warning level Group Policy. Group Policy adds Threshold to the registry when you enable the Default quota limit and warning level policy. If you disable the policy or set it to Not configured, Group Policy deletes this entry from the registry. Then, the system uses the amount of physical space on the volume as the disk quota warning level.

Value | Meaning
(Not in registry) | There is no specified disk quota warning level. The system uses the physical space on each NTFS volume as the warning level.
1 - 1000 | The number of units in the disk quota warning level for new users.

The warning level established by the policy overrides the user settings for quota limits. Also, when you set a quota limit and warning level, the system disables the corresponding options in the Select the default quota limit for new users of this volume section on the Quota tab so administrators cannot change the values while a policy is in effect.

This entry applies to all new users as soon as they write to the volume. It does not affect disk quota warning levels for current users or affect customized limits and warning levels set for particular users (on the Quota tab in Volume Properties).

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Default quota limit and warning level policy (Computer Configuration\Administrative Templates\System\Disk Quotas).

Note Image Note

This entry is used only when disk quota management is enabled on the volume, either by a user setting or by a policy (see Enable).

Tip Image Tip

When you select a warning level, remember that the same warning level applies to all users on all volumes, regardless of actual volume size. Be sure to set the warning level so that it is reasonable for the range of volumes in the group.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

Limit

LimitUnits

ThresholdUnits


ThresholdUnits

HKLM\SOFTWARE\Policies\Microsoft\Windows NT\DiskQuota

Data type | Range | Default value
REG_DWORD | (Not in registry) | 1 - 6 | (Not in registry)

Description

Specifies the units for the default disk quota warning level for new users of an NTFS volume.

This entry is used in configuring the disk quota management feature of NTFS file system volumes. Along with the value of Threshold, this entry specifies the warning level, that is, the point at which the user's status in the Quota Entries window changes to indicate that the user is approaching the disk quota limit.

This entry stores the value you enter in the Default warning level Units box of the Default quota limit and warning level Group Policy. Group Policy adds ThresholdUnits to the registry when you enable the Default quota limit and warning level policy. If you disable the policy or set it to Not configured, Group Policy deletes this entry from the registry. Then, the system uses the amount of physical space on the volume as the disk quota warning level.

Value | Meaning
(Not in registry.) | There is no specified disk quota warning level. The system uses the physical space on each NTFS volume as the warning level.
1 | KB (kilobytes)
2 | MB (megabytes)
3 | GB (gigabytes)
4 | TB (terabytes)
5 | PB (picabytes)
6 | EB (exabytes)

The warning level established by the policy overrides the user settings for quota limits. Also, when you set a quota limit and warning level, the system disables the corresponding options in the Select the default quota limit for new users of this volume section on the Quota tab so administrators cannot change the values while a policy is in effect.

This entry applies to all new users as soon as they write to the volume. It does not affect disk quota warning levels for current users or affect customized limits and warning levels set for particular users (on the Quota tab in Volume Properties).

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Default quota limit and warning level policy (Computer Configuration\Administrative Templates\System\Disk Quotas).

Note Image Note

This entry is used only when disk quota management is enabled on the volume, either by a user setting or by a policy (see Enable).

Tip Image Tip

When you select a limit, remember that the same limit applies to all users on all volumes, regardless of actual volume size. Be sure to set the limit and warning level so that it is reasonable for the range of volumes in the group.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

Limit

LimitUnits

Threshold


Printers

HKLM\SOFTWARE\Policies\Microsoft\Windows NT\

Description

The Policies\Microsoft\Windows NT\Printers subkey contains entries that store Group Policy settings for printers. These entries are created and maintained by Group Policy, and are read and interpreted by the printing functions in Windows 2000.

The Policies\Microsoft\Windows NT\Printers subkey in HKEY_LOCAL_MACHINE stores entries that apply to all users of the computer. The system adds these entries when you enable (and, for some policies, when you disable) a policy in the Computer Configuration folder in Group Policy.

There is also a Policies\Microsoft\Windows NT\Printers subkey in HKEY_CURRENT_USER, which stores policy-related entries that are configured separately for each user. The system adds these entries when you enable (and, for some policies, when you disable) a policy in the User Configuration folder in Group Policy.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


DisableWebPrinting

HKLM\SOFTWARE\Policies\Microsoft\Windows NT\Printers

Data type | Range | Default value
REG_DWORD | (Not in registry) | 0 | 1 | 0

Description

Enables and disables server-side support for internet printing.

Internet printing lets you display printers on Web pages so the printers can be viewed, managed, and used across the Internet or an intranet.

This entry stores the setting of the Web-based printing Group Policy. Group Policy adds this entry to the registry with a value of 0 when you enable the Web-based printing policy. If you disable the policy, Group Policy sets the value to 1. If you set the policy to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
(Not in registry) | The policy is not configured. Internet printing is supported.
0 | The policy is enabled. Internet printing is supported.
1 | The policy is disabled. Internet printing is not supported.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Web-based printing policy (Computer Configuration\Administrative Templates\Printers).

Note Image Note

This entry affects the server side of Internet printing only. It does not prevent the print client on the computer from printing across the Internet.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

Printers Page URL

SupportLink

SupportLinkName


Immortal

HKLM\SOFTWARE\Policies\Microsoft\Windows NT\Printers

Data type | Range | Default value
REG_DWORD | (Not in registry) | 0 | 1 | 0

Description

Allows the domain controller to prune (delete from Active Directory) the printers published by this computer.

By default, the pruning service on the domain controller prunes printer objects from Active Directory if the computer that published them does not respond to contact requests. When the computer that published the printers restarts, it republishes any deleted printer objects.

This entry stores the setting of the Allow pruning of published printers Group Policy. Group Policy adds this entry to the registry with a value of 0 when you enable theAllow pruning of published printers policy. If you disable the policy, Group Policy sets the value to 1. If you set the policy to Not configured, Group Policy deletes the entry from the registry and the system behaves as the value is 0.

Value | Meaning
(Not in registry) | The policy is not configured. Pruning is permitted. The domain controller prunes this computer's printers when the computer does not respond to contact requests.
0 | The policy is enabled. Pruning is permitted. The domain controller prunes this computer's printers when the computer does not respond to contact requests.
1 | The policy is disabled. Pruning is prohibited. The domain controller does not prune this computer's printers. This setting is designed to prevent printers from being pruned while the computer is temporarily disconnected from the network.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Allow pruning of published printers policy (Computer Configuration\Administrative Templates\Printers).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


PhysicalLocation

HKLM\SOFTWARE\Policies\Microsoft\Windows NT\Printers

Data type | Range | Default value
REG_SZ | Location (up to 259 characters) | (There is no default value for this entry)

Description

Specifies the string that appears in the Location field when users open the Find Printer dialog box (Start, Search, For printers).

Typically, this field displays the location of the user's computer, such as such as Building A/Floor 2. The system uses the location as one of its criteria when searching for nearby printers in Active Directory.

This entry stores the setting of the Computer location Group Policy. Group Policy adds this entry to the registry when you configure the Computer location policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry.

If this entry does not appear in the registry, the Location field is blank. The user can type their location, or when Location Tracking is on, they can browse Active Directory to find their location. If no location is specified, the system uses the IP address and subnet mask of the computer to estimate its location.

When you provide a default location string, the user does not have to understand or remember the language or format of your printer location scheme. You can also use this entry to direct users to the closest printer or to direct them to a particular printer or group of printers that you want them to use.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Computer location policy (Computer Configuration\Administrative Templates\Printers).

Note Image Note

This entry is effective only when Location tracking is enabled (that is, the value of PhysicalLocationSupport is 1). Otherwise, this entry is ignored.

To turn Location Tracking on, enable the Pre-populate printer search location text policy, which sets the value of PhysicalLocationSupport to 1.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

PhysicalLocationSupport


PhysicalLocationSupport

HKLM\SOFTWARE\Policies\Microsoft\Windows NT\Printers

Data type | Range | Default value
REG_DWORD | (Not in registry) | 0 | 1 | 0

Description

Enables and disables the Location Tracking feature of Windows 2000 printers.

This entry stores the setting of the Pre-populate printer search location text Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Pre-populate printer search location text policy. If you disable the policy, Group Policy sets the value to 0. If you set the policy to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
(Not in registry) | The policy is not configured. Location Tracking is disabled.
0 | The policy is disabled. Location Tracking is disabled.
1 | The policy is enabled. Location tracking is enabled.

When location tracking is enabled, a Browse button appears beside the Location field in the Find Printers dialog box. The Browse button also appears on the General tab of the Properties dialog box for a printer. It lets users browse for printers by location without their having to know the precise location (or location naming scheme).

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Pre-populate printer search location text policy (Computer Configuration\Administrative Templates\Printers).

Tip Image Tip

To open the Find Printers dialog box, click Start, click Search, and then click For printers.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

PhysicalLocation


PruneDownlevel

HKLM\SOFTWARE\Policies\Microsoft\Windows NT\Printers

Data type | Range | Default value
REG_DWORD | 0 | 1 | 2 | 0

Description

Determines whether the system prunes (deletes from Active Directory) printers that are not automatically republished. This policy applies to printers running operating systems other than Windows 2000 and to Windows 2000 printers published outside of their domain

This entry stores the setting of the Prune printers that are not automatically republished Group Policy. Group Policy adds this entry to the registry when you enable the Prune printers that are not automatically republished policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

The Windows 2000 pruning service prunes printer objects from Active Directory when the computer that published them does not respond to contact requests. Computers running Windows 2000 detect and republish deleted printer objects when they rejoin the network. However, because non–Windows 2000 computers and computers in other domains cannot republish printers in Active Directory automatically, then, by default, the system never prunes their printer objects.

Value | Meaning
0 | The policy disabled or not configured, or it is enabled and set to Never. Printer objects that are not automatically republished are never pruned.
1 | The policy is enabled and set to Only if Print Server is found. The system prunes printer objects that are not automatically republished only if the print server responds, but the printer is unavailable.
2 | The policy is enabled and set to Whenever printer is not found. The system prunes printer objects that are not automatically republished whenever the host computer does not respond, just as it does with Windows 2000 printers.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Prune printers that are not automatically republished policy (Computer Configuration\Administrative Templates\Printers).

Note Image Note

This entry applies to printers published by using Active Directory Users and Computers or Pubprn.vbs. It does not apply to printers published by using Printers in Control Panel.

Tip Image Tip

If you disable automatic pruning, remember to delete printer objects manually whenever you remove a printer or print server.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


PruningInterval

HKLM\SOFTWARE\Policies\Microsoft\Windows NT\Printers

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF minutes | 0x1E0 (480 minutes = 8 hours)

Description

Specifies how often the pruning service on a domain controller contacts computers to verify that their printers are operational.

This entry stores the setting of the Directory pruning interval Group Policy. Group Policy adds this entry to the registry when you enable the Directory pruning interval policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 480.

The pruning service periodically contacts computers that have published printers. If a computer does not respond to the contact message (optionally, after repeated attempts), the pruning service prunes (deletes from Active Directory) printer objects the computer has published.

By default, the pruning service contacts computers every eight hours and allows two repeated contact attempts before deleting printers from Active Directory. You can use this entry to change the interval between contact attempts. To change the number of attempts, use the Directory pruning retry policy (PruningRetries).

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Directory pruning interval policy (Computer Configuration\Administrative Templates\Printers).

Note Image Note

This entry is used only on domain controllers.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

PruningRetries


PruningPriority

HKLM\SOFTWARE\Policies\Microsoft\Windows NT\Printers

Data type | Range | Default value
REG_DWORD | 0x0 | 0x1 | 0x2 | 0xFFFFFFFE | 0xFFFFFFFF | 0x0

Description

Sets the priority of the pruning thread.

This entry stores the setting of the Directory pruning priority Group Policy. Group Policy adds this entry to the registry when you configure the Directory pruning priority policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0x0.

Value | Meaning
0x0 | Normal (0)
0x1 | Above Normal (1)
0x2 | Highest (2)
0xFFFFFFFE | Lowest (-2)
0xFFFFFFFF | Below Normal (-1)

The pruning thread, which runs only on domain controllers, deletes printer objects from Active Directory if the printer that published the object does not respond to contact attempts. This process keeps printer information in Active Directory current.

The thread priority influences the order in which the thread receives processor time and determines how likely it is to be preempted by higher priority threads. By default, the pruning thread runs at normal priority. However, you can adjust the priority to improve the performance of this service.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Directory pruning priority policy (Computer Configuration\Administrative Templates\Printers).

Note Image Note

This entry affects only on domain controllers.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

PruningInterval


PruningRetries

HKLM\SOFTWARE\Policies\Microsoft\Windows NT\Printers

Data type | Range | Default value
REG_DWORD | 0 - 6 | 2

Description

Specifies how many times the pruning service on a domain controller repeats its attempt to contact a computer before pruning the computer's printers.

This entry stores the setting of the Directory pruning retry Group Policy. Group Policy adds this entry to the registry when you enable the Directory pruning retry policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 2.

The pruning service periodically contacts computers that have published printers to verify that the printers are still available for use. If a computer does not respond to the contact message, the message is repeated for the specified number of times. If the computer still fails to respond, then the pruning service prunes (deletes from Active Directory) printer objects the computer has published.

By default, the pruning service contacts computers every eight hours and allows two retries before deleting printers from Active Directory. You can use this policy to change the number of retries. To change the interval between attempts, use the Directory pruning interval policy (PruningInterval).

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Directory pruning retry policy (Computer Configuration\Administrative Templates\Printers).

Note Image Note

This entry affects domain controllers only.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


PublishPrinters

HKLM\SOFTWARE\Policies\Microsoft\Windows NT\Printers

Data type | Range | Default value
REG_DWORD | (Not in registry) | 0 | 1 | 1

Description

Determines whether the computer's shared printers can be published in Active Directory.

If the value of this entry is 0, the system disables the List in directory option in the Printers folder. Also, the Add Printer wizard does not publish shared printers in Active Directory.

This entry stores the setting of the Allow printers to be published Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Allow printers to be published policy. If you disable the policy, Group Policy sets the value to 0. If you set the policy to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 1.

Value | Meaning
(Not in registry) | The policy is not configured. Users can use the Add Printer wizard or the List in directory option in the Printers folder to publish shared printers in Active Directory.
0 | The policy is disabled. This computer's shared printers cannot be published in Active Directory.
1 | The policy is enabled. Users can use the Add Printer wizard or the List in directory option in the Printers folder to publish shared printers in Active Directory.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Allow printers to be published policy (Computer Configuration\Administrative Templates\Printers).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

Auto Publishing


ServerThread

HKLM\SOFTWARE\Policies\Microsoft\Windows NT\Printers

Data type | Range | Default value
REG_DWORD | (Not in registry) | 0 | 1 | (Not in registry)

Description

Announces the presence of shared printers to print browse master servers for the domain.

On Windows 2000 domains with Active Directory, shared printer resources are available in Active Directory and are not announced by default.

This entry stores the setting of the Printer browsing Group Policy. Group Policy adds this entry to the registry when you configure the Printer browsing policy.

This entry stores the setting of the Printer browsing Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable thePrinter browsing policy. If you disable the policy, Group Policy sets the value to 0. If you set the policy to Not configured, Group Policy deletes the entry from the registry.

Value | Meaning
(Not in registry) | Shared printers are announced to browse master servers only when Active Directory is not available.
0 | Shared printers are not announced to print browse master servers, even when Active Directory is not available.
1 | The print spooler announces shared printers to the print browse master servers. As a result, shared printers appear in the domain list in the Browse for Printer dialog box of the Add Printer wizard.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Printer browsing policy (Computer Configuration\Administrative Templates\Printers).

Note Image Note

A client license is used each time a client computer announces a printer to a print browse master on the domain.

Changes to this policy are not evident until the system receives an updated printer list from the browse master server. Extended delays are common. (The Explain tab in Group Policy fails to mention this delay.)

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


SupportLink

HKLM\SOFTWARE\Policies\Microsoft\Windows NT\Printers

Data type | Range | Default value
REG_SZ | URL (up to 255 characters) | (There is no default value for this entry)

Description

Specifies the internet address of the Web page link displayed in the Printers folder. The words that appear in the link are stored in the value of SupportLinkName.

This entry stores the setting of the URL box in the Custom support URL in the Printers folder's left pane Group Policy. Group Policy adds this entry to the registry when you configure the Custom support URL in the Printers folder's left pane policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry.

This policy lets you replace the default support links displayed in the Printers folder with a link to the printer support Web page for your enterprise. By default, the Printers folder includes a link to the Windows 2000 Support Web page. It can also include a link to a Web page supplied by the vendor of the currently selected printer. However, when this entry and SupportLinkName appear in the registry with valid values, the system displays the link they define in place of the default links.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Custom support URL in the Printers folder's left pane policy (Computer Configuration\Administrative Templates\Printers).

Note Image Note

Web pages links appear in the Printers folder only when Web view is enabled. If Web view is disabled, this entry has no effect. (To enable Web view, open the Printers folder, select the Tools menu, click Folder Options, click the General tab, and then click Enable Web content in folders.)

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

DisableWebPrinting

Printers Page URL

SupportLinkName


SupportLinkName

HKLM\SOFTWARE\Policies\Microsoft\Windows NT\Printers

Data type | Range | Default value
REG_SZ | String (up to 255 characters) | (There is no default value for this entry)

Description

Specifies the words that appear in the Web page link in the Printers folder. The URL for the link is stored in the value of SupportLink.

This entry stores the setting of the URL Title box in the Custom support URL in the Printers folder's left pane Group Policy. Group Policy adds this entry to the registry when you configure the Custom support URL in the Printers folder's left pane policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry.

This policy lets you replace the default support information in the Printers folder with a link to a printer support Web page for your enterprise. By default, the Printers folder includes a link to the Windows 2000 Support Web page. It can also include a link to a Web page supplied by the vendor of the currently selected printer. However, when this entry and SupportLink appear in the registry with valid values, the system displays the link they define in place of these default links.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Custom support URL in the Printers folder's left pane policy (Computer Configuration\Administrative Templates\Printers).

Note Image Note

Web pages links appear in the Printers folder only when Web view is enabled. If Web view is disabled, this entry has no effect. (To enable Web view, open the Printers folder, select the Tools menu, click Folder Options, click the General tab, and then click Enable Web content in folders.)

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

DisableWebPrinting

Printers Page URL

SupportLink


VerifyPublishedState

HKLM\SOFTWARE\Policies\Microsoft\Windows NT\Printers

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFE minutes | 0xFFFFFFFF | 0xFFFFFFFF

Description

Directs the system to verify its published printers in the background while the system is running, and specifies how often this background verification is performed.

Whenever the system starts, it verifies that the printers it published in Active Directory have not been deleted. This entry provides for additional, periodic verifications while the system is running.

This entry stores the setting of the Check published state Group Policy. Group Policy adds this entry to the registry when you configure the Check published state policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0xFFFFFFFF.

Value | Meaning
0x0 - 0xFFFFFFFE minutes | Specifies the interval between background verifications of published printers.
0xFFFFFFFF | No background verifications. The system verifies its printers only when it starts.

Typically, printers are deleted from Active Directory by the printer pruning service, which deletes unavailable printers to keep Active Directory accurate and up to date. If an active printer that this system published has been pruned, the system recognizes the error during its verification, and republishes the printer in Active Directory.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Check published state policy (Computer Configuration\Administrative Templates\Printers).

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


Wizard

HKLM\SOFTWARE\Policies\Microsoft\Windows NT\Printers\

Description

The Printers\Wizard subkey stores the entries created when you configure a Group Policy that affects the Add Printer wizard. These entries are created and maintained by Group Policy, and are read and interpreted by the printing functions in Windows 2000.

The Printers\Wizard subkey in HKEY_LOCAL_MACHINE stores entries that apply to all users of the computer. The system adds these entries when you enable (and, for some policies, when you disable) a policy in the Computer Configuration folder in Group Policy.

There is also a Printers\Wizard subkey in HKEY_CURRENT_USER that stores policy-related entries that are configured separately for each user. The system adds these entries when you enable (and, for some policies, when you disable) a policy in the User Configuration folder in Group Policy.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


Auto Publishing

HKLM\SOFTWARE\Policies\Microsoft\Windows NT\Printers\Wizard

Data type | Range | Default value
REG_DWORD | (Not in registry) | 0 | 1 | 1

Description

Determines whether the Add Printer wizard automatically publishes the computer's shared printers in Active Directory.

This entry stores the setting of the Automatically publish new printers in Active Directory Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the Automatically publish new printers in Active Directory policy. If you disable the policy, Group Policy sets the value to 0. If you set the policy to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 1.

Value | Meaning
(Not in registry) | The policy is not configured. The Add Printer wizard automatically publishes all shared printers.
0 | The policy is disabled. The Add Printer wizard does not automatically publish printers. However, you can publish shared printers manually.
1 | The policy is enabled. The Add Printer wizard automatically publishes all shared printers.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Automatically publish new printers in Active Directory policy (Computer Configuration\Administrative Templates\Printers).

Note Image Note

The value of this entry is ignored when the value of PublishPrinters is 0.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

PublishPrinters


Windows File Protection

HKLM\SOFTWARE\Policies\Microsoft\Windows NT\

Description

The Windows File Protection subkey contains entries that store Group Policy settings for the Windows File Protection feature of Windows 2000. The entries in this subkey are written and maintained by Group Policy, and are read and interpreted by the Windows File Protection program.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.


SFCDllCacheDir

HKLM\SOFTWARE\Policies\Microsoft\Windows NT\Windows File Protection

Data type | Range | Default value
REG_SZ | Fully qualified path | Systemroot\System32\Dllcache

Description

Specifies an alternate location for the Windows File Protection cache.

This entry stores the setting of the Cache file path text box in the Specify Windows File Protection cache location Group Policy. Group Policy adds this entry to the registry when you enable the Specify Windows File Protection cache location policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system uses the default value.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Specify Windows File Protection cache location policy (Computer Configuration\Administrative Templates\System\Windows File Protection).

Note Image Note

This entry takes precedence over a user setting. While the Specify Windows File Protection cache location policy is enabled (and this entry appears in the registry), the system ignores the value of SFCDllCacheDir in the Winlogon subkey.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Caution Image Caution

Do not put the cache on a network shared directory.

Related Entries

SFCDllCacheDir (Winlogon subkey)


SfcQuota

HKLM\SOFTWARE\Policies\Microsoft\Windows NT\Windows File Protection

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFE MB | 0xFFFFFFFF | Windows 2000 Professional: 0x32 (50 MB) Windows 2000 Server: 0xFFFFFFFF (unlimited)

Description

Specifies the maximum amount of disk space that can be used for the Windows File Protection file cache.

Windows File Protection saves verified versions of files in its cache on the local hard drive for later use. It adds protected files to the cache until the cache content reaches the quota. If the quota is greater than 50 MB, WFP adds other important Windows 2000 files to the cache until the cache size reaches the quota.

This entry stores the setting of the Limit Windows File Protection cache size Group Policy. Group Policy adds this entry to the registry when you enable the Limit Windows File Protection cache size policy. If you disable this policy or set it to not configured, Group Policy deletes the entry from the registry and the system uses the default values.

Value | Meaning
(Not in registry) | The policy is disabled or not configured. The default value is set to 50 MB on Windows 2000 Professional and is unlimited on Windows 2000 Server.
1 - 0xFFFFFFFE | The policy is enabled and set to a value less than 4294967295. Specifies the size of the Windows File Protection cache on the local hard drive.
0xFFFFFFFF | The policy is enabled and set to 4294967295. The cache size is not limited. Save all cache all protected system files on the local drive.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Limit Windows File Protection cache size policy (Computer Configuration\Administrative Templates\System\Windows File Protection).

Note Image Note

This entry takes precedence over a user setting. While the Limit Windows File Protection cache size policy is enabled (and this entry appears in the registry), the system ignores the value of SfcQuota in the Winlogon subkey.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

SfcQuota (Winlogon subkey)


SfcScan

HKLM\SOFTWARE\Policies\Microsoft\Windows NT\Windows File Protection

Data type | Range | Default value
REG_DWORD | 0 | 1 | 2 | 0

Description

Determines when Windows File Protection scans protected files for changes. By default, protected files are scanned only during setup.

This entry stores the setting of the Scanning frequency box in the Set Windows File Protection scanning Group Policy. Group Policy adds this entry to the registry when you configure the Set Windows File Protection scanning policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 0.

Value | Meaning
0 | The policy is disabled or not configured, or the policy is enabled and set to Do not scan during startup. Windows File Protection scans files only during setup.
1 | The policy is enabled and set to Scan during startup. Windows File Protection scans files at setup and each time you start Windows 2000. This setting delays each startup.
2 | The policy is enabled and set to Scan once. Windows File Protection scans files the next time you start the system.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Set Windows File Protection scanning policy (Computer Configuration\Administrative Templates\System\Windows File Protection). Enable the policy and select a rate from the Scanning Frequency box.

Note Image Note

This entry affects file scanning only. It does not affect the standard background file change detection that Windows File Protection provides.

This entry takes precedence over a user setting. While the Set Windows File Protection scanning policy is enabled (and this entry appears in the registry), the system ignores the value of SfcScan in the Winlogon subkey. Also, this entry overrides System File Checker (SFC.EXE) commands, /SCANONCE and /SCANBOOT, which change the value of SFCScan in the Winlogon subkey.

Windows File Protection only scans when the current user is an administrator of the computer.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

SfcScan(Winlogon subkey)


SfcShowProgress

HKLM\SOFTWARE\Policies\Microsoft\Windows NT\Windows File Protection

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Hides the file scan progress window. This window provides status information to sophisticated users, but might confuse novices.

This entry stores the setting of the Hide the file scan progress window Group Policy. Group Policy adds this entry to the registry with a value of 0 when you enable the Hide the file scan progress window policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry and the system behaves as though the value is 1.

Value | Meaning
0 | The policy is enabled. The file scan progress window does not appear during file scanning.
1 | The policy is disabled or not configured. The file scan progress window appears.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Hide the file scan progress window policy (Computer Configuration\Administrative Templates\System\Windows File Protection).

Note Image Note

This entry takes precedence over a user setting. While the Hide the file scan progress window policy is enabled (and the value of this entry is 0), the system ignores the value of SfcShowProgress in the Winlogon subkey.

Windows File Protection only scans when the current user is an administrator of the computer.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

SfcShowProgress (Winlogon subkey)


Program Groups

HKLM\SOFTWARE\

Description

In Windows NT 4.0 and earlier, the Program Groups subkey stored the contents of program groups the user defined in Program Manager. In Windows 2000, these Program Groups appear as shortcuts in subfolders of the Start menu.


ConvertedToLinks

HKLM\SOFTWARE\Program Groups

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Records whether program groups created in a previous version of Windows have been converted to links in Windows 2000.

Value | Meaning
0 | Not converted.
1 | Converted.

If you upgraded from Windows NT 4.0 and earlier, or an earlier version of Windows, your old program groups appear as folders on the Programs menu. Windows 2000 Setup also adds several programs and folders to the Start menu.

For more information about adding shortcuts to the Start menu, see Windows 2000 Help.

Note Image Note

The conversion is done by grpconv.exe during the upgrade process. This program is located in Systemroot\WINNT\system32.


SYSTEM

HKLM\

Description

The subkeys in HKEY_LOCAL_MACHINE\SYSTEM store values for the current control set and for other control sets that can be used, or have been used, to run Windows 2000. Windows 2000 maintains at least two control sets to ensure that the system always starts.


<ControlSet00n>

HKLM\SYSTEM\

Description

The <ControlSet00n> subkeys represent a control set for the system.

The numbered ControlSet00n subkeys, such as ControlSet001 and ControlSet002, contain control sets that can be used to start and run Windows 2000. Most systems have two numbered control sets, an original and a backup copy of a control set that has been used to start the system successfully, but the system can maintain as many as four control sets. Windows 2000 maintains backup copies so that you can undo configuration changes that might otherwise prevent you from starting the system.

Windows 2000 identifies the control set that was last used successfully, the current control set, and the default control set. These designations are stored in the Select subkey.

Windows 2000 automatically maintains the control sets and selects one of them when the system starts based on settings in the Select subkey and the success or failure of system startup. When the system starts, users can also select the LastKnownGood control set during the boot loader procedure.

All the numbered control set subkeys, including the one that appears in the CurrentControlSet subkey, can have the same subkeys and entries. In this reference, these subkeys are entries are listed under the CurrentControlSet subkey.

Note Image Note

The <ControlSet00n> subkey is a variable representing the numbered control sets under the HKLM\SYSTEM subkey. It doesn't actually appear in the registry.

Related Entries

Select subkey

CurrentControlSet subkey


CurrentControlSet

HKLM\SYSTEM\

Description

The CurrentControlSet subkey does not actually contain a control set. The subkeys and entries that appear in the CurrentControlSet subkey are the contents of one of the numbered control sets, such as ControlSet001. The control set that appears in CurrentControlSet is selected by the system at startup and identified by the value of Current in the Select subkey.

For example, if the value of Current is 1, the contents of ControlSet001 appear in CurrentControlSet.

Related Entries

Current


Control

HKLM\SYSTEM\CurrentControlSet\

Description

The CurrentControlSet\Control subkey and its subkeys contain entries that control system startup, such as the subsystems to load and the size and location of paging files.

Activation method

You must restart the system before any changes in the Control subkey take effect.


BackupRestore

HKLM\SYSTEM\CurrentControlSet\Control\

Description

The BackupRestore subkey contains subkeys that determine which files and registry keys the system will not back up or restore.

Caution Image Caution

Do not change the values of these entries. Altering these values can prevent Windows Backup from successfully backing up and/or restoring data.


FilesNotToBackup

HKLM\SYSTEM\CurrentControlSet\Control\BackupRestore\

Description

The FilesNotToBackup subkey includes entries that specify the files that Backup does not back up.

Each of the entries in this subkey has the following format:
<component> REG_MULTI_SZ path and file name [path and file name]

Unless otherwise indicated, the paths are relative to Systemroot and can have any of several forms:

  • A path ending with "\" indicates the subkey and its entries only.
  • A path ending with "\*" indicates the folder and all of its subfolders and files.
  • A path ending with "\*.*" indicates the folder and all of its subfolders and files.
  • A path ending with "\* file name extension" indicates only files with the specified extension.
  • A path ending with /s indicates the directory and all of its subdirectories.
  • A path ending with a file name indicates only that file.
Entry | Default Value
Client Side Cache | %SystemRoot%\csc\* /s
ComPlus | %SystemRoot%\registration]*.\clb \*.crmlog /s
Internet Explorer | %UserProfile%\index.dat /s
Memory Page File | \Pagefile.sys
MS Distributed Transaction Coordinator | Systemroot\WINNT\System32\DTCLog\MSDTC.LOG
Power Options | \hiberfil.sys
Single Instance Storage | \SIS Common Store\*.* /s
Temporary Files | %TEMP%\* /s

Change method

To change the value of these entries, use Backup. From the Tools menu, click Options. Click the Exclude Files tab. Use the Add new, Edit, and Remove buttons to select those files not to be backed up.


KeysNotToRestore

HKLM\SYSTEM\CurrentControlSet\Control\BackupRestore\

Description

The KeysNotToRestore subkey specifies the names of those registry keys that will not be restored by Backup.

Each of the entries has the following format:
<component> REG_MULTI_SZ registry path [registry path]

The paths are relative from HKEY_LOCAL_MACHINE\SYSTEM and can take one of three forms:

  • A path ending with "\" indicates that the subkey and all of its subkeys and entries will be preserved from the existing registry. These values will not be overwritten by the information in Backup during the restore process.
  • A path ending with "\*" indicates that the subkey and all of its subkeys and entries will be merged with the existing registry. New entries will be added but existing entries will not be altered.
  • A path ending with an entry name indicates only that entry.
Entry | Default Value
Active Directory Restore | CurrentControlSet\Services\NTDS\Restore In Progress\ CurrentControlSet\Services\NTDS\Parameters\New Database GUID
Fault Tolerance | Disk\
Installed Services | CurrentControlSet\Services*
LDM Boot Information | CurrentControlSet\Control\Services\dmio\boot info\
Mount Manager | MountedDevices\
Pending Rename Operations | CurrentControlset\Control\Session Manager\PendingFileRenameOperations
Plug & Play | CurrentControlSet\Session Manager\PendingFileRenameOperations
Session Manager | CurrentControlSet\Control\SessionManager\AllowProtectedRename
Windows Setup | Setup\SystemPartition

Caution Image Caution

Do not change the values of the entries in this subkey. Altering these values can prevent Backup from successfully backing up and/or restoring data.


BootVerificationProgram

HKLM\SYSTEM\CurrentControlSet\Control\

Description

The BootVerificationProgram subkey stores data about custom startup verification programs. Startup verification programs specify the criteria for a successful startup and notify the system that the startup is successful, two functions otherwise performed by Winlogon. You can write a custom startup verification program and use this subkey to direct the Windows 2000 service controller to run it.

Some custom startup verification programs notify the system that startup was not successful, causing the system to restart using the LastKnownGood control set. Others determine whether their criteria were satisfied and, if they were, run Bootok.exe, a program that notifies the system that startup was successful. Bootok.exe is included in Windows 2000.

Note Image Note

To run a custom startup verification program, you must disable the standard startup verification functions in Winlogon by setting the value of the ReportBootOk entry to 0.

You cannot run a custom startup verification program if you are also running the Bootvrfy startup verification program.

Caution Image Caution

Do not add or change the value of the entries in the BootVerificationProgram subkey unless you need to run a custom verification program.

Related Entries

LastKnownGood entry in the Select subkey

ReportBootOk


ImagePath

HKLM\SYSTEM\CurrentControlSet\Control\BootVerificationProgram

Data type | Range | Default value
REG_SZ | REG_EXPAND_SZ | Filename | There is no default value for this entry.

Description

Specifies the full path and file name of a custom startup verification program. The Windows 2000 service controller runs the program listed here at startup.

Note Image Note

To run a custom startup verification program, you must disable the standard startup verification functions in Winlogon by setting ReportBootOk to 0.

Windows 2000 does not add the ImagePath entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

ReportBootOk


Class

HKLM\SYSTEM\CurrentControlSet\Control\

Description

The Class subkey stores configuration data for classes of hardware devices.

Each subkey under Class represents a device class and is named by the GUID for the class. It appears as a 16-digit alphanumeric string within curly braces. These class-GUID subkeys store configuration data that applies to the entire class of devices, such as the class of all modems.

Within the class-GUID subkeys are four-digit numbered subkeys which represent particular devices that are instances of the class. These subkeys store data that applies only to that device.

Because the Class subkey is hardware specific, its contents vary widely. The Class subkey on your computer might look quite different from the attributes described in this reference.

Tip Image Tip

To determine the type of hardware device represented by a class-GUID subkey, use a registry editor. Click the name of the class-GUID subkey (it appears as a 16-byte alphanumeric string within brackets). The device type appears in the value of the first, unnamed entry in the subkey.

To display hidden devices, non–Plug and Play devices, and devices not attached to the computer (commonly known as ghosted or phantom devices), type set DEVMGR_SHOW_NONPRESENT_DEVICES=1 at the command line. Then, use Device Manager to remove or reconfigure these devices. Do not edit the registry. For more information, see Viewing Hidden Devices in the Windows 2000 Professional Resource Kit.

Many digits in the GUID are unique to your system. However, the three digits preceding the first hyphen are specific to the device class and are the same on all systems. For example, the three digits preceding the first hyphen in the DVD/CD-ROM drives class are always 965.

Caution Image Caution

Do not change any entries in the Class subkey or any subkey within it. These subkeys are configured by the system to be compliant with Plug and Play standards. Changing any data can prevent your computer devices from starting or operating properly.


<{Class-GUID}>

HKLM\SYSTEM\CurrentControlSet\Control\Class\

Description

A <{Class-GUID}> subkey represents the component associated with the class-GUID.

Each <{Class-GUID}> subkey under Class represents a device class and is named by the GUID for the class. It appears as a 16-digit alphanumeric string within curly braces. These class-GUID subkeys store configuration data that applies to the entire class of devices, such as the class of all modems.

Within the class-GUID subkeys are four-digit numbered subkeys which represent particular devices that are instances of the class. These subkeys store data that applies only to that device.

Because the Class subkey is hardware specific, its contents vary widely. The Class subkey on your computer might look quite different from the attributes described in this reference.

Note Image Note

The <{Class-GUID}> subkey is a variable representing the subkeys under the HKLM\SYSTEM\CurrentControlSet\Control\Class subkey. It doesn't actually appear in the registry. This variable subkey displays the entries and subkeys that are common to many of the subkeys under the Class subkey. The actual Class subkeys in your registry depend upon the hardware installed on the computer or available to the system.

Tip Image Tip

To determine the type of hardware device represented by a class-GUID subkey, use a registry editor. Click the name of the class-GUID subkey (it appears as a 16-byte alphanumeric string within brackets). The device type appears in the value of the first, unnamed entry in the subkey.

Many digits in the GUID are unique to your system. However, the three digits preceding the first hyphen are specific to the device class and are the same on all systems. For example, the three digits preceding the first hyphen in the DVD/CD-ROM drives class are always 965.

Caution Image Caution

Do not change any entries in the Class subkey or any subkey within it. These subkeys are configured by the system to be compliant with Plug and Play standards. Changing any data can prevent your computer devices from starting or operating properly.


<Device-number (000n)>

HKLM\SYSTEM\CurrentControlSet\Control\Class\<{Class-GUID}>

Description

A <Device-number (000n)> subkey represents a particular device.

The <Device-number (000n)> subkeys in your registry are named by ascending, four-digit numeric codes beginning with 0000. Each subkey represents a particular device that is an instances of the class. These subkeys store data that applies only to that device.

The numeric order of the subkeys is determined by the order in which the devices were enumerated to your system. They are not intrinsic to the device.

Because the <Device-number (000n)> subkeys are hardware specific, its contents vary widely. The <Device-number (000n)> subkeys on your computer might look quite different from the attributes described in this reference.

Note Image Note

The <Device-number (000n)> subkey is a variable representing the subkeys under the HKLM\SYSTEM\CurrentControlSet\Control\Class\<{Class-GUID}> subkeys. It doesn't actually appear in the registry. This variable subkey displays the entries and subkeys that are common to many of the subkeys in the class-GUID subkeys under the Class subkey. The actual <Device-number> subkeys in your registry depend upon the hardware installed on the computer or available to the system.

Tip Image Tip

To determine the type of hardware device represented by a class-GUID subkey, use a registry editor. Click the name of the class-GUID subkey (it appears as a 16-byte alphanumeric string within brackets). The device type appears in the value of the first, unnamed entry in the subkey.

Many digits in the GUID are unique to your system. However, the three digits preceding the first hyphen are specific to the device class and are the same on all systems. For example, the three digits preceding the first hyphen in the DVD/CD-ROM drives class are always 965.

Caution Image Caution

Do not change any entries in the Class subkey or any subkey within it. These subkeys are configured by the system to be compliant with Plug and Play standards. Changing any data can prevent your computer devices from starting or operating properly.


Linkage

HKLM\SYSTEM\CurrentControlSet\Control\Class\<{Class-GUID}>\<Device-number (000n)>\

Description

The <Device-number (000n)> subkeys for network devices can contain a Linkage subkey. This Linkage subkey stores configuration data for binding network components. The bindings associate devices and services with the transport protocols they use.

Network services, such as DHCP, and transport protocols, such as TCP/IP, also have Linkage subkeys. These Linkage subkeys store data about bindings from the perspective of the service. They associate network services and protocols with the devices that support them.

A binding consists of three entries, Bind, Export, and Route. Each of these entries can include more than one component. The components are listed in the entries in a precise order, so that the first component in one entry corresponds with the first component in the other entries, and each subsequent component corresponds with subsequent components in the other entries.

In Windows NT 4.0 and earlier, all Linkage subkeys were stored in subkeys of the Services subkey (HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\<Service-name>). In Windows 2000, the Linkage subkeys for services are still in the services key, but Linkage subkeys for devices are stored in HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Class\<{Class-GUID}> in the numeric subkey representing the particular device.

Change method

This information is provided only for reference. Use only published application programming interfaces. Do not include the Linkage subkey in Windows programs. This subkey might not be included in future versions of Windows.

Note Image Note

A valid binding requires a value for three entries: Bind, Export, and Route.

Tip Image Tip

To determine the type of hardware device represented by a class-GUID subkey, use a registry editor. Click the name of the class-GUID subkey (it appears as a 16-byte alphanumeric string within brackets). The device type appears in the value of the first, unnamed entry in the subkey.

Many digits in the GUID are unique to your system. However, the three digits preceding the first hyphen are specific to the device class and are the same on all systems. For example, the three digits preceding the first hyphen in the DVD/CD-ROM drives class are always 965.

Caution Image Caution

Do not change any entries in the Class subkey or any subkey within it. These subkeys are configured by the system to be compliant with Plug and Play standards. Changing any data can prevent your computer devices from starting or operating properly.

Related Entries

Linkage subkeys for services


Bind

HKLM\SYSTEM\CurrentControlSet\Control\Class\<{Class-GUID}>\<Device-number (000n)>\Linkage

Data type | Range | Default value
REG_MULTI_SZ | ObjectName ObjectName ... | There is no default value for this entry.

Description

Specifies the services, protocols, and devices to which this device is associated in a binding. The system builds the bind from the values in this entry and in the Bind entries of the associated protocols and services.

More than one component of the same type can be listed in this value. For example, if the computer has two network adapters, the value of Bind for a network adapter type would consist of two object names.

Note Image Note

A valid binding requires a value for three entries: Bind, Export, and Route.

Tip Image Tip

To determine the type of hardware device represented by a class-GUID subkey, use a registry editor. Click the name of the class-GUID subkey (it appears as a 16-byte alphanumeric string within brackets). The device type appears in the value of the first, unnamed entry in the subkey.

Many digits in the GUID are unique to your system. However, the three digits preceding the first hyphen are specific to the device class and are the same on all systems. For example, the three digits preceding the first hyphen in the DVD/CD-ROM drives class are always 965.

Caution Image Caution

Do not change any entries in the Class subkey or any subkey within it. These subkeys are configured by the system to be compliant with Plug and Play standards. Changing any data can prevent your computer devices from starting or operating properly.

Related Entries

Linkage subkeys for services

Bind (for services)


Export

HKLM\SYSTEM\CurrentControlSet\Control\Class\<{Class-GUID}>\<Device-number (000n)>\Linkage

Data type | Range | Default value
REG_MULTI_SZ | ObjectName ObjectName ... | There is no default value for this entry.

Description

Specifies objects that the service must be able to access for the binding to be successful. Objects named in the value of Export must be installed on the system and available to the service or device.

Note Image Note

A valid binding requires a value for three entries: Bind, Export, and Route.

Tip Image Tip

To determine the type of hardware device represented by a class-GUID subkey, use a registry editor. Click the name of the class-GUID subkey (it appears as a 16-byte alphanumeric string within brackets). The device type appears in the value of the first, unnamed entry in the subkey.

Many digits in the GUID are unique to your system. However, the three digits preceding the first hyphen are specific to the device class and are the same on all systems. For example, the three digits preceding the first hyphen in the DVD/CD-ROM drives class are always 965.

Caution Image Caution

Do not change any entries in the Class subkey or any subkey within it. These subkeys are configured by the system to be compliant with Plug and Play standards. Changing any data can prevent your computer devices from starting or operating properly.

Related Entries

Linkage subkeys for services

Export (for services)


OtherDependencies

HKLM\SYSTEM\CurrentControlSet\Control\Class\<{Class-GUID}>\<Device-number (000n)>\Linkage

Data type | Range | Default value
REG_MULTI_SZ | ServiceName ServiceName ... | There is no default value for this entry.

Description

Specifies services required by the network component in addition to those specified in the binding. This entry and its value are retained when bindings are reconfigured, even when the other entries in the Linkage subkey are deleted and recreated.

For example, in the NetBT\Linkage subkey, the value of OtherDependencies is Tcpip. This value indicates that NetBT requires TCP/IP, regardless of its current binding configuration.

Note Image Note

A valid binding requires a value for three entries: Bind, Export, and Route.

Services upon which the network component depends due to its current binding are stored in its DependOnService entry.

Windows 2000 adds this entry to the subkey only when it is required by the network component. It does not appear in all Linkage subkeys.

Tip Image Tip

To determine the hardware device represented by a <Device-number> subkey, use a registry editor. Click the <Device-number> subkey (it appears as a four-digit number, such as 0000). The value of DriverDesc, which describes the driver, typically identifies the device.

Many digits in the GUID are unique to your system. However, the three digits preceding the first hyphen are specific to the device class and are the same on all systems. For example, the three digits preceding the first hyphen in the DVD/CD-ROM drives class are always 965.

Caution Image Caution

Do not change any entries in the Class subkey or any subkey within it. These subkeys are configured by the system to be compliant with Plug and Play standards. Changing any data can prevent your computer devices from starting or operating properly.


Route

HKLM\SYSTEM\CurrentControlSet\Control\Class\<{Class-GUID}>\<Device-number (000n)>\Linkage

Data type | Range | Default value
REG_MULTI_SZ | SubkeyName SubkeyName ... | There is no default value for this entry.

Description

Specifies the Linkage subkeys from which data was collected to create the binding. Each name in the value of this entry indicates a path through the binding protocol.

The Linkage subkeys that appear in the value of this entry can represent services or devices.

  • Linkage subkeys for services bear the name of the service, such as Tcpip, and appear in HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services.
  • Linkage subkeys for device are named by the GUID of the device class and appear in HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Class.

Note Image Note

A valid binding requires a value for three entries: Bind, Export, and Route.

Tip Image Tip

To determine the type of hardware device represented by a class-GUID subkey, use a registry editor. Click the name of the class-GUID subkey (it appears as a 16-byte alphanumeric string within brackets). The device type appears in the value of the first, unnamed entry in the subkey.

Many digits in the GUID are unique to your system. However, the three digits preceding the first hyphen are specific to the device class and are the same on all systems. For example, the three digits preceding the first hyphen in the DVD/CD-ROM drives class are always 965.

Caution Image Caution

Do not change any entries in the Class subkey or any subkey within it. These subkeys are configured by the system to be compliant with Plug and Play standards. Changing any data can prevent your computer devices from starting or operating properly.

Related Entries

Linkage subkeys for services

Route (for services)


Ndi

HKLM\SYSTEM\CurrentControlSet\Control\Class\<{Class-GUID}>\<Device-number (000n)>\

Description

The Ndi subkeys store data for network driver installers (NDI). NDIs install and configure network drivers and components that have complex or highly customized and specific requirements that cannot be specified by using standard INF scripts for network class installers.

The entries in the Ndi subkeys vary with the requirements of the component. The entries described in this subkey are common to many components.

Note Image Note

Windows 2000 does not include NetRules subkeys. In Windows NT 4.0 and earlier, the NetRules subkeys contained entries that specified bind rules for network software components. Some bind specifications are stored in the Ndi subkeys that contain configuration data for network driver installers. However, these are primary upper bind and lower bind settings only.

Related Entries

Linkage subkeys for devices


Interfaces

HKLM\SYSTEM\CurrentControlSet\Control\Class\<{Class-GUID}>\<Device-number (000n)>\Ndi\

Description

The Interfaces subkey stores entries that specify the upper and lower bounds of driver interfaces, that is, the relationship between layers of drivers in the network. The lower interface, optionally specified by the value of LowerRange, indicates the hardware or lower-level drivers with which this driver can communicate, such as Ethernet. The upper interfaces, optionally specified by the value of UpperRange, indicates the software interface provided by the driver.

Note Image Note

Windows 2000 does not include NetRules subkeys. In Windows NT 4.0 and earlier, the NetRules subkeys contained entries that specified bind rules for network software components. Some bind specifications are stored in the Ndi subkeys that contain configuration data for network driver installers. However, these are primary upper bind and lower bind settings only.


LowerRange

HKLM\SYSTEM\CurrentControlSet\Control\Class\<{Class-GUID}>\<Device-number (000n)>\Ndi\Interfaces

Data type | Range | Default value
REG_SZ | List of interfaces | There is no default value for this entry.

Description

Specifies the hardware and lower-level drivers that can serve as lower interfaces for this driver. A lower interface is a lower-level (closer to hardware) component with which the driver can communicate.

Note Image Note

Windows 2000 does not include NetRules subkeys. In Windows NT 4.0 and earlier, the NetRules subkeys contained entries that specified bind rules for network software components. Some bind specifications are stored in the Ndi subkeys that contain configuration data for network driver installers. However, these are primary upper bind and lower bind settings only.

Caution Image Caution

This value is maintained by the Network Driver Interface. Do not specify this value in an INF file.

Related Entries

Linkage subkeys for devices


UpperRange

HKLM\SYSTEM\CurrentControlSet\Control\Class\<{Class-GUID}>\<Device-number (000n)>\Ndi\Interfaces

Data type | Range | Default value
REG_SZ | List of interfaces | There is no default value for this entry.

Description

Specifies the software program provided by this driver that serve as its upper interfaces. An upper interface is a higher-level (farther from hardware) component with which the driver communicates.

Note Image Note

Windows 2000 does not include NetRules subkeys. In Windows NT 4.0 and earlier, the NetRules subkeys contained entries that specified bind rules for network software components. Some bind specifications are stored in the Ndi subkeys that contain configuration data for network driver installers. However, these are primary upper bind and lower bind settings only.

Caution Image Caution

This value is maintained by the Network Driver Interface. Do not specify this value in an INF file.

Related Entries

Linkage subkeys for devices


params

HKLM\SYSTEM\CurrentControlSet\Control\Class\<{Class-GUID}>\<Device-number (000n)>\Ndi\

Description

The params subkey stores configuration data specific to the driver represented by the <Device-number> subkey and maintained by the Network Driver Interface (NDI).

Note Image Note

Windows 2000 does not include NetRules subkeys. In Windows NT 4.0 and earlier, the NetRules subkeys contained entries that specified bind rules for network software components. Some bind specifications are stored in the Ndi subkeys that contain configuration data for network driver installers. However, these are primary upper bind and lower bind settings only.


Service

HKLM\SYSTEM\CurrentControlSet\Control\Class\<{Class-GUID}>\<Device-number (000n)>\Ndi

Data type | Range | Default value
REG_SZ | Service-name | There is no default value for this entry.

Description

Stores the name of the driver or service that is installed by the network driver installer.

Caution Image Caution

Do not change the value of this entry. If you do, the system might not be able to locate or operate the driver.


(Network adapters) {4D36E972-E325-11CE-BFC1-08002BE10318}

HKLM\SYSTEM\CurrentControlSet\Control\Class\

Description

The {4D36E972-E325-11CE-BFC1-08002BE10318} subkey represents the class of network adapter devices supported by the system.

This subkey contains several 4-digit numbered subkeys which represent particular network adapters. These subkeys store data that applies only to that device.

Caution Image Caution

Do not change any entries in the Class subkey or any subkey within it. These subkeys are configured by the system to be compliant with Plug and Play standards. Changing any data can prevent your computer devices from starting or operating properly.


WAN Miniport (L2TP) <Device-number (000n)>

HKLM\SYSTEM\CurrentControlSet\Control\Class\(Network adapters) {4D36E972-E325-11CE-BFC1-08002BE10318}\

Description

One of the four-digit numbered subkeys in the {4D36E972-E325-11CE-BFC1-08002BE10318} subkey stores configuration data for WAN Miniport devices using the Layer 2 Tunneling Protocol (L2TP) driver. The particular subkey differs among computers.

To determine which of the numbered subkeys stores L2TP driver data on your computer, look for the value, Wan Miniport (L2TP), in the DriverDesc entry in each numbered subkey.

L2TP is an industry standard tunneling protocol. Unlike Point-to-point tunneling protocol (PPTP), which is based on TCP, L2TP is based on UDP.

Caution Image Caution

Do not change any entries in the Class subkey or any subkey within it. These subkeys are configured by the system to be compliant with Plug and Play standards. Changing any data can prevent your computer devices from starting or operating properly.

Related Entries

Rasl2tp subkey


ControlReceiveWindow

HKLM\SYSTEM\CurrentControlSet\Control\Class\(Network adapters) {4D36E972-E325-11CE-BFC1-08002BE10318}\WAN Miniport (L2TP) <Device-number (000n)>

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF messages | 0x8

Description

Specifies the suggested value for the maximum number of control messages that can be held in the local receive window.

The value of this entry is sent to a peer in a Receive Window Attribute-Value Pair (AVP) message during tunnel negotiation. It is intended to suggest to the peer that they should increase the size of the receive window from its typical value of 4 control messages. This value is only a guideline; the driver does not enforce the value.

If the value of this entry is 0x0, the L2TP driver does not send a Receive Window AVP message during tunnel negotiation. As a result, the peer assumes a receive window size of 4 messages.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


EnableForRas

HKLM\SYSTEM\CurrentControlSet\Control\Class\(Network adapters) {4D36E972-E325-11CE-BFC1-08002BE10318}\WAN Miniport (L2TP) <Device-number (000n)>

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether the port is configured for dial-up connections using Remote Access Service (RAS). This entry applies to ports managed by an L2TP driver.

Value | Meaning
0 | Not configured for dial-up connections. This value is designed for routers.
1 | Configured for dial-up connections.

Change method

To change the value of this entry, use Routing and Remote Access. Do not edit the registry.

Related Entries

EnableForRouting

ProhibitIpSec


EnableForRouting

HKLM\SYSTEM\CurrentControlSet\Control\Class\(Network adapters) {4D36E972-E325-11CE-BFC1-08002BE10318}\WAN Miniport (L2TP) <Device-number (000n)>

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether the port is configured for as a router. This entry applies to ports managed by an L2TP driver.

Value | Meaning
0 | Not configured as a router. This value is designed for ports handling dial-up connections.
1 | Configured as a router.

Change method

To change the value of this entry, use Routing and Remote Access. Do not edit the registry.

Related Entries

EnableForRas


Exclusive Tunnels

HKLM\SYSTEM\CurrentControlSet\Control\Class\(Network adapters) {4D36E972-E325-11CE-BFC1-08002BE10318}\WAN Miniport (L2TP) <Device-number (000n)>

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether outgoing calls to the same peer use the same tunnel.

Value | Meaning
0 | Shared: If a tunnel to a peer is already established, new outgoing calls can be added to the existing tunnel.
1 | Exclusive: The L2TP driver creates a new tunnel for each outgoing call.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


HelloMs

HKLM\SYSTEM\CurrentControlSet\Control\Class\(Network adapters) {4D36E972-E325-11CE-BFC1-08002BE10318}\WAN Miniport (L2TP) <Device-number (000n)>

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF | 0xEA60 (60,000 milliseconds = 1 minute)

Description

Determines how often the L2TP driver sends Hello messages. One hello message is sent each time the connection is idle for the time specified in this entry. This time is known as the hello interval.

Hello messages are L2TP control messages send at regular intervals to prevent an active, but quiet, connection from being mistaken for an idle line. They are also known as "keep-alive" messages.

If the value of this entry is 0x0, the system does not send hello messages. As a result, an active connection might be terminated prematurely.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


HostName

HKLM\SYSTEM\CurrentControlSet\Control\Class\(Network adapters) {4D36E972-E325-11CE-BFC1-08002BE10318}\WAN Miniport (L2TP) <Device-number (000n)>

Data type | Range | Default value
REG_SZ | String | Computer name of this computer

Description

Specifies the host name passed to a peer during tunnel negotiation.

By default, the name of the local computer is sent to the peer, but you can add this value to the registry to specify a different host name. Enter any valid host name in ASCII characters, such as an IP address or DNS name.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


IgnoreFramingMismatch

HKLM\SYSTEM\CurrentControlSet\Control\Class\(Network adapters) {4D36E972-E325-11CE-BFC1-08002BE10318}\WAN Miniport (L2TP) <Device-number (000n)>

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines how the L2TP driver responds when a peer requests a framing type that is not offered by the system.

Value | Meaning
0 | The tunnel is terminated.
1 | The error is ignored.

By default, the L2TP driver ignores frame errors. This is appropriate because the definition of the framing field is still being revised.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


InitialSendTimeoutMs

HKLM\SYSTEM\CurrentControlSet\Control\Class\(Network adapters) {4D36E972-E325-11CE-BFC1-08002BE10318}\WAN Miniport (L2TP) <Device-number (000n)>

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF milliseconds | 0x3E8 (1000 milliseconds = 1 second)

Description

Determines how long the L2TP driver waits for a control message to be acknowledged before retransmitting the message. The value of this entry is used the first time each control messages is sent.

The L2TP driver adjusts this value dynamically depending on the network transmission rate. This entry establishes the maximum waiting time after the first transmission.

Consider increasing this value if the network is very slow and calls are terminated prematurely. However, if this value is too high, system resources can be spent on maintaining circuits for unresponsive peers.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

MaxRetransmits

MaxSendTimeoutMs


MaxAckDelayMs

HKLM\SYSTEM\CurrentControlSet\Control\Class\(Network adapters) {4D36E972-E325-11CE-BFC1-08002BE10318}\WAN Miniport (L2TP) <Device-number (000n)>

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF milliseconds | 0x1F4 (500 milliseconds)

Description

Determines how long the L2TP driver can wait before acknowledging receipt of a packet.

The L2TP driver tries to minimize packet traffic by "piggybacking" acknowledgments, that is, sending acknowledgments with another outgoing data packet. If there are no outgoing data packets, the system waits for a packet for a specified interval before sending the acknowledgement in a separate packet.

The L2TP driver adjusts the wait interval dynamically based on the network transmission rate. This entry establishes the maximum duration of this interval.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


MaxOutOfOrder

HKLM\SYSTEM\CurrentControlSet\Control\Class\(Network adapters) {4D36E972-E325-11CE-BFC1-08002BE10318}\WAN Miniport (L2TP) <Device-number (000n)>

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF packets | 0x64 (100 packets)

Description

Determines how much memory space is reserved for resorting packets received out of order. The space is based on the number of packets it can hold.

If the value of this entry is 0x0, the system does not resort packets received out of order. Packets received out of order are discarded.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


MaxRetransmits

HKLM\SYSTEM\CurrentControlSet\Control\Class\(Network adapters) {4D36E972-E325-11CE-BFC1-08002BE10318}\WAN Miniport (L2TP) <Device-number (000n)>

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF | 0x2

Description

Determines how many times the L2TP driver retransmits a control message. Control messages are transmitted repeatedly when they are not acknowledged.

Consider increasing this value if the network is very slow and calls are terminated prematurely. However, if this value is too high, system resources can be spent on maintaining circuits for unresponsive peers.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

InitialSendTimeoutMs

MaxSendTimeoutMs


MaxSendTimeoutMs

HKLM\SYSTEM\CurrentControlSet\Control\Class\(Network adapters) {4D36E972-E325-11CE-BFC1-08002BE10318}\WAN Miniport (L2TP) <Device-number (000n)>

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF milliseconds | 0x2710 (10,000 milliseconds = 10 seconds)

Description

Determines how long the L2TP driver waits for a control message to be acknowledged before retransmitting the message. The value of this entry is used when control messages are being repeated because they are not acknowledged.

The L2TP driver adjusts this value dynamically depending on the network transmission rate. This entry establishes the maximum waiting time between repeated transmissions.

Consider increasing this value if the network is very slow and calls are terminated prematurely. However, if this value is too high, system resources can be spent on maintaining circuits for unresponsive peers.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

InitialSendTimeoutMs

MaxRetransmits


MaxWanEndpoints

HKLM\SYSTEM\CurrentControlSet\Control\Class\(Network adapters) {4D36E972-E325-11CE-BFC1-08002BE10318}\WAN Miniport (L2TP) <Device-number (000n)>

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF | 0x3E8 (1000)

Description

Stores the maximum number of WAN endpoints permitted on the system for use by the L2TP driver.

The value of this entry is set at 1000 endpoints by default. However, the system does not let the value of WanEndpoints exceed the value of MaxWanEndpoints. If you use the Maximum ports box in Routing and Remote Access to raise the value of WanEndpoints above the value of MaxWanEndpoints, the system automatically increases the value of MaxWanEndpoints to equal it. The system will raise the value until it reaches the number of available devices.

Note Image Note

Each time you increase the value in the Maximum ports box so that it is greater than the value of this entry, you must restart Windows 2000 to make the change effective.

Tip Image Tip

The value in the Maximum ports box is stored in the value of WanEndpoints. To go to the Maximum ports box, use Routing and Remote Access. Right-click Ports, click Properties, click WAN Miniport (L2TP), and then click Configure.

Related Entries

MinWanEndpoints

WanEndpoints


MinWanEndpoints

HKLM\SYSTEM\CurrentControlSet\Control\Class\(Network adapters) {4D36E972-E325-11CE-BFC1-08002BE10318}\WAN Miniport (L2TP) <Device-number (000n)>

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF | 0x0

Description

Stores the minimum number of WAN endpoints permitted on the system for use by the L2TP driver.

Related Entries

MaxWanEndpoints

WanEndpoints


OutgoingRole

HKLM\SYSTEM\CurrentControlSet\Control\Class\(Network adapters) {4D36E972-E325-11CE-BFC1-08002BE10318}\WAN Miniport (L2TP) <Device-number (000n)>

Description

Determines the role assumed by the L2TP driver when the system places an outgoing call.

Value | Meaning
1 | LNS: The L2TP driver acts as a network server, responsible for the server side of the L2TP protocol. As such it sends an Outgoing-Call-Request (OCRQ) message.
2 | LAC: The L2TP driver merely acts as an access concentrator, capable of implementing L2TP protocol. As such it sends an Incoming-Call-Request (ICRQ) message.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


Password

HKLM\SYSTEM\CurrentControlSet\Control\Class\(Network adapters) {4D36E972-E325-11CE-BFC1-08002BE10318}\WAN Miniport (L2TP) <Device-number (000n)>

Data type | Range | Default value
REG_SZ | String | (Not in registry)

Description

Enables L2TP tunnel authentication.

When this entry appears in the registry, the L2TP driver uses tunnel authentication to filter connections to its host. To establish a connection, the peer requesting a connection must provide the string specified in the value of this entry.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

To provide security for applications, use Internet Protocol Security (IPSec) in Windows 2000.


PayloadReceiveWindow

HKLM\SYSTEM\CurrentControlSet\Control\Class\(Network adapters) {4D36E972-E325-11CE-BFC1-08002BE10318}\WAN Miniport (L2TP) <Device-number (000n)>

Description

Specifies the suggested value for the maximum number of payload messages that can be held in the local receive window. The number of messages held determines the size of the window.

The value of this entry is sent to a peer in a Receive Window Attribute-Value Pair (AVP) message during call negotiation. This value is only a guideline; the driver does not enforce the value.

If the value of this entry is 0x0, the system does not control the flow of payload messages.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


PayloadSendWindow

HKLM\SYSTEM\CurrentControlSet\Control\Class\(Network adapters) {4D36E972-E325-11CE-BFC1-08002BE10318}\WAN Miniport (L2TP) <Device-number (000n)>

Data type | Range | Default value
REG_DWORD | 0x1 - 0xFFFFFFFF messages | 0x10 (16 messages)

Description

Specifies the maximum number of payload messages that can be held in the local send window. The number of messages held determines the size of the window.

The value of this entry is sent to Ndiswan.sys, driver that acts an intermediary between L2TP and NdisWan drivers. Ndiswan.sys regulates outgoing payload message traffic. Peers can request a smaller window (fewer messages), but not a larger one.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


WanEndpoints

HKLM\SYSTEM\CurrentControlSet\Control\Class\(Network adapters) {4D36E972-E325-11CE-BFC1-08002BE10318}\WAN Miniport (L2TP) <Device-number (000n)>

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF | 0x5

Description

Stores the number of WAN endpoints currently configured for use.

This entry stores the value in the Maximum ports box in Routing and Remote Access.

Change method

To change the value of this entry, use Routing and Remote Access. Right-click Ports, click Properties, click WAN Miniport (L2TP), and then click Configure. This entry stores the value in the Maximum ports box.

Note Image Note

If you increase the value of Maximum ports so that it exceeds the value of MaxWanEndpoints, you must restart Windows 2000 to make your change effective.

.

Caution Image Caution

Do not change the value of this entry by editing the registry. If you do, the system cannot adjust corresponding values and L2TP might not support the number of endpoints you request.

Related Entries

MaxWanEndpoints

MinWanEndpoints


CrashControl

HKLM\SYSTEM\CurrentControlSet\Control\

Description

The Crash Control subkey stores entries that determine what happens when the system locks, fails, or terminates abnormally.

Change method

To change these values of entries in this subkey, use System in Control Panel. Right-click My Computer, click Properties, click the Advanced tab, and then click Startup and Recovery.


AutoReboot

HKLM\SYSTEM\CurrentControlSet\Control\CrashControl

Data type | Range | Default value
REG_DWORD | 0 | 1 | Windows 2000 Server: 1 Windows 2000 Professional: 0

Description

Specifies whether the system restarts automatically when it fails or locks.

This entry stores the value of the Automatically reboot check box in System in Control Panel.

Value | Meaning
0 | Do not restart automatically.
1 | Restart automatically.

Change method

To change the value of this entry, use the System in Control Panel. Click the Advanced tab, then click the Startup and Recovery button. This value is set to 1 when the Automatically reboot box is checked.

Activation method

To make changes to this value effective, you must restart Windows 2000.

Note Image Note

To change the value of this entry, you must be an administrator of the computer.


CrashDumpEnabled

HKLM\SYSTEM\CurrentControlSet\Control\CrashControl

Data type | Range | Default value
REG_DWORD | 0 | 1 | Windows 2000 Server: 1 Windows 2000 Professional: 0

Description

Specifies whether Windows 2000 writes the contents of system memory to a log file when the system stops unexpectedly. The contents of this log file can then be used to determine why the system stopped.

This entry stores the value of the Write debugging information to check box in System in Control Panel. The name and location of the file are specified in the value of DumpFile.

Value | Meaning
0 | No files are written when the system terminates abnormally.
1 | Debugging information is written to a file when the system terminates abnormally.

Change method

To change the value of this entry, use the System in Control Panel. Click the Advanced tab, then click the Startup and Recovery button. This value is set to 1 when the Write debugging information to box is checked.

Activation method

To make changes to this value effective, you must restart Windows 2000.

Note Image Note

To change the value of this entry, you must be an administrator of the computer.

Related Entries

DumpFile

Overwrite


DumpFile

HKLM\SYSTEM\CurrentControlSet\Control\CrashControl

Data type | Range | Default value
REG_EXPAND_SZ | Path | %SystemRoot%\MEMORY.DMP

Description

Specifies the location of the recovery log file. If the system stops abnormally, and the value CrashDumpEnabled is 1, Windows 2000 copies the contents of system memory to the recovery log file.

If you change the value of this entry, Windows 2000 does not move any existing recovery log files. Instead, the next time the system stops abnormally, it creates a recovery log file in the new location.

This entry stores the value in box below the Write debugging information to check box in System in Control Panel.

Change method

To change the value of this entry, use System in Control Panel. Click the Advanced tab, then click the Startup and Recovery button. Enter the location of the log file in the text box below the Write debugging information to check box.

Activation method

To make changes to this value effective, you must restart Windows 2000.

Note Image Note

To change the value of this entry, you must be an administrator of the computer.

Related Entries

CrashDumpEnabled

Overwrite


KernelDumpOnly

HKLM\SYSTEM\CurrentControlSet\Control\CrashControl

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Specifies that only the area of memory used by the operating system kernel is copied to the recovery log when the system stops abnormally.

The kernel of the system manages its most basic functions, such as allocating processor time and handling hardware interrupts.

The location of the recovery log is stored in the value of DumpFile. By default, it is Systemroot\MEMORY.DMP.

Value | Meaning
0 | The entire contents of system memory is copied to the recovery log. This setting provides the most data for your investigation of the abnormal stop.
1 | Only the kernel memory is copied to the recovery log. This setting provides less data, but it is quicker and produces smaller recovery log files.

Change method

To change the value of this entry, use System in Control Panel. Click the Advanced tab, and then click the Startup and Recovery button. This value is set to 1 when the Write kernel information only box is checked.

Activation method

To make changes to this value effective, you must restart Windows 2000.

Note Image Note

To change the value of this entry, you must be an administrator of the computer.

Windows 2000 adds this value to the registry when you use System in Control Panel to change the default value.

Related Entries

CrashDumpEnabled

DumpFile


LogEvent

HKLM\SYSTEM\CurrentControlSet\Control\CrashControl

Data type | Range | Default value
REG_DWORD | 0 | 1 | Windows 2000 Server: 1 Windows 2000 Professional: 0

Description

Determines whether the system writes an error to the System Log in Event Viewer when Windows 2000 terminates abnormally.

This entry stores the value of the Write an event to the system log check box in System in Control Panel.

Value | Meaning
0 | No events are logged when the system terminates abnormally.
1 | The system writes an error message to the System Log when Windows 2000 terminates abnormally.

Change method

To change the value of this entry, use System in Control Panel. Click the Advanced tab, then click the Startup and Recovery button. This value is set to 1 when the Write an event to the system log box is checked.

Activation method

To make changes to this value effective, you must restart Windows 2000.

Note Image Note

To change the value of this entry, you must be an administrator of the computer.


NMICrashDump

HKLM\SYSTEM\CurrentControlSet\Control\CrashControl

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether the system performs standard software error processing when a hardware error causes a non-maskable interrupt (NMI).

This entry is used only on computers with x86 architecture, such as Intel (™) processor platforms. Other systems always perform standard software error processing when hardware interrupts are detected.

By default, an NMI interrupt stops the system and displays a hardware malfunction message. If the value of this entry is 1, the system also performs standard software error processing. The software error processing displays a Stop ("blue screen") message containing information about the state of the operating system and other programs when the NMI interrupt occurred.

If the value of CrashDumpEnabled also is 1, the standard error processing routine writes the contents of system memory to a recovery log file.

Value | Meaning
0 | NMI interrupts do not trigger standard software error processing. Only a hardware malfunction message is displayed.
1 | NMI interrupts display a hardware malfunction message and trigger standard software error processing, including a Stop ("blue screen") message.

This entry is designed to suppress the Stop message when the system stops due to a hardware error. The text display associated with the Stop message can fill the screen and make it difficult to find the hardware malfunction message. Also, some processors cannot process the high volume of error messages associated with an NMI interrupt and a stop message without error. (See the Microsoft Knowledge Base, Article Q174830).

Activation method

To make changes to this value effective, you must restart Windows 2000.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that adds it.

To change the value of this entry, you must be an administrator of the computer.

Related Entries

CrashDumpEnabled


Overwrite

HKLM\SYSTEM\CurrentControlSet\Control\CrashControl

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether the system writes over the old recovery file or creates a new recovery file each time the system stops abnormally.

When the system stops abnormally and the value of CrashDumpEnabled is 1, Windows 2000 copies the contents of system memory to the recovery log file. The data in this file can help to determine the cause of the failure.

This entry stores the value of the Overwrite any existing file check box in System in Control Panel.

Value | Meaning
0 | The system creates a new recovery file for each failure. This setting preserves a record of previous failures to aid your investigation.
1 | The system overwrites the existing recovery file. This setting prevents the system from accumulating unused recovery files.

Change method

To change the value of this entry, use System in Control Panel. Click the Advanced tab, then click the Startup and Recovery button. This value is set to 1 when the Overwrite any existing file box is checked.

Activation method

To make changes to this value effective, you must restart Windows 2000.

Note Image Note

To change the value of this entry, you must be an administrator of the computer.

Related Entries

CrashDumpEnabled

DumpFile


SendAlert

HKLM\SYSTEM\CurrentControlSet\Control\CrashControl

Data type | Range | Default value
REG_DWORD | 0 | 1 | Windows 2000 Server: 1 Windows 2000 Professional: 0

Description

Determines whether the system sends an alert to administrators of the computer when the system stops unexpectedly.

This entry stores the value of the Send an administrative alert check box in System in Control Panel.

Value | Meaning
0 | The system does not alert administrators when this system stops.
1 | The system sends an alert to administrators when this system stops.

Change method

To change the value of this entry, use System in Control Panel. Click the Advanced tab, then click the Startup and Recovery button. This value is set to 1 when the Send an administrative alert box is checked.

Activation method

To make changes to this value effective, you must restart Windows 2000.

Note Image Note

To change the value of this entry, you must be an administrator of the computer.


CriticalDeviceDatabase

HKLM\SYSTEM\CurrentControlSet\Control\

Description

The CriticalDeviceDatabase subkey stores the critical device database. This database stores configuration data for new devices which must be installed and started before the Windows 2000 components that normally install devices are started.


CurrentUser

HKLM\SYSTEM\CurrentControlSet\Control

Data type | Range | Default value
REG_SZ | USERNAME | USERNAME

Description

This entry is not used by Windows 2000. It remains in the registry to support older programs that reference it.

Note Image Note

The value of this entry always is USERNAME; it is not a variable. The system does not expand this value or replace it with the name of the current user.


FileSystem

HKLM\SYSTEM\CurrentControlSet\Control\

Description

The FileSystem subkey stores entries for file systems supported by Windows 2000.


NtfsAllowExtendedCharacterIn8dot3Name

HKLM\SYSTEM\CurrentControlSet\Control\FileSystem

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether the characters from the extended character set, including diacritic characters, can be used in 8.3 short file names on NTFS volumes.

Value | Meaning
0 | 8.3-format file names on NTFS volumes are limited to the standard ASCII character set (minus any reserved values.)
1 | Extended characters are permitted in 8.3-format file names on NTFS volumes.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


NtfsDisable8dot3NameCreation

HKLM\SYSTEM\CurrentControlSet\Control\FileSystem

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether NTFS generates an 8.3-format short name for long file names, and for file names which contain characters from the extended character set. If the value of this entry is 0, files can have two names: the user-specified name and the NTFS-generated short name. If the name the user specifies conforms to 8.3, no short file name is generated.

Changing this value does not change the file, but it does change the way NTFS displays and manages the file.

Value | Meaning
0 | NTFS creates short file names. This setting enables applications that cannot process long file names and computers that use different code pages to find the files.
1 | NTFS does not create short file names. Although this setting increases file performance, applications that cannot process long file names and computers that use different code pages might not be able to find the files.

Activation method

You must restart the system before a change to this value takes effect.


NtfsDisableLastAccessUpdate

HKLM\SYSTEM\CurrentControlSet\Control\FileSystem

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether NTFS updates the last-access time stamp on each directory when it lists the directories on an NTFS volume.

This entry is designed to prevent the NTFS log buffer in physical memory from becoming filled with time stamp update records. If you have an NTFS volume with a very large number of directories (in excess of 70,000), and Windows 2000 does not respond quickly to dir commands, adding this entry to the registry might make directory listings faster.

Value | Meaning
0 | When listing directories, NTFS updates the last-access time stamp on each directory it detects and writes a record to the NTFS log noting each time change.
1 | When listing directories, NTFS does not update the last-access time stamp and does not write time stamp update records to the NTFS log.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program, such as Group Policy, that edits the registry.

Tip Image Tip

For more information on NTFS directories, see the Microsoft Knowledge Base link on the Web Resources page. Search the Knowledge Base for Article Q150355, or use the keywords NTFS directories.


NtfsEncryptionService

HKLM\SYSTEM\CurrentControlSet\Control\FileSystem

Data type | Range | Default value
REG_SZ | Efs | Efs

Description

Determines which encryption service NTFS uses. EFS (Encrypting File System) is the encryption service included in Windows 2000.

This entry specifies the encryption service for NTFS. It does not cause NTFS to encrypt any files. (Files and folders on NTFS partitions are encrypted selectively on Windows 2000.) Similarly, deleting this entry does not cause NTFS to decrypt files, although removing its encryption service prevents NTFS from encrypting or decrypting files or gaining access to encrypted files.

Tip Image Tip

To encrypt a file or folder on an NTFS partition, use Windows Explorer. Right-click the name of the file or folder, click Properties, click the Advanced button, and then click the Encrypt contents to secure data option.

To prevent users in a policy group from encrypting files, use Group Policy. Open the Encrypted Data Recovery Agents policy folder (Computer Configuration\Windows Settings\Security Settings\Public Key Policies) and delete all of the certificates it contains. For more information, see the Group Policy Reference, Gp.chm, on the Windows 2000 Resource Kits CD.

You can also encrypt a file or folder from the command line by using Cipher.exe, a program included in Windows 2000. For more information, at the command line, type Cipher /?.

Caution Image Caution

Do not delete this entry or change its value. If you do, encrypted files become inaccessible.


Win31FileSystem

HKLM\SYSTEM\CurrentControlSet\Control\FileSystem

Data type | Range | Default value
REG_DWORD | 0|1 | 0

Description

Determines whether or not the FAT file system uses long file names and extended timestamps. This entry is designed to make the files stored on FAT volumes use only those features of the FAT filesystem as used by Windows 3.1 and earlier. Changing this value does not change any files, but it does change how FAT displays and manages the files.

Value | Meaning
0 | Long file names and extended timestamps are used. Windows 3.1 and MS-DOS systems will be able to read the files, but will not be able to update the timestamp information or use the long file names (file names would be truncated to filena~1).
1 | Long file names and extended timestamps are not used. Only those features of the FAT file system which were available to Windows 3.1 and earlier will be used.

Activation method

You must restart the system before a change to this value takes effect.

Note Image Note

Any discrepancies caused by setting this entry to 0, using a file on a Windows 3.1 or earlier system, and then opening the file on a Windows 3.51 or later or Windows 95/98 system, can be resolved by running chkdsk.

Setting this value to 1 will maximize compatibility with Windows 3.1 and MS-DOS systems.


Win95TruncatedExtensions

HKLM\SYSTEM\CurrentControlSet\Control\FileSystem

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether NTFS and FAT generate 8.3-format file names for new files.

Setting Win95Truncated Extensions to 1 does not change any existing file name extensions, nor does it change the way these extensions are displayed or managed by Find, File Manager, or Windows Explorer. However, it causes NTFS and FAT to generate short names for new files, and to truncate the third character of file name extensions.

The following table provides shows how filename.html would be truncated.

Value | Short name generated
0 | filena~1.htm
1 | filena~1.ht~

The following table provides an example of how this entry changes the file system's response to commands entered in a command prompt window.

Value | Command: del *.htm | Command: del *.html
0 | Only files whose extension is .htm are deleted. | Only files whose extension is .html are deleted.
1 | Files whose extensions begin with .htm are deleted, including *.htm and *.html but not *.ht~. | Only files whose extension is .html are deleted.


GraphicsDrivers

HKLM\SYSTEM\CurrentControlSet\Control\

Description

The GraphicsDrivers subkey stores entries for DirectX and other graphics drivers in Windows 2000. In addition to the DCI subkey, which appears by default, PermanentSettingChanges and TemporarySettingChanges subkeys can be added to the registry to override the default configuration of graphics drivers. Note the correct path for each entry.


DCI

HKLM\SYSTEM\CurrentControlSet\Control\GraphicsDrivers\

Description

Stores configuration data for graphics drivers, including those implementing DirectDraw for Windows 2000.


Timeout

HKLM\SYSTEM\CurrentControlSet\Control\GraphicsDrivers\DCI

Data type | Range | Default value
REG_DWORD | Seconds | 7

Description

Specifies how long a DirectDraw application can keep a graphics device frame buffer locked when a dynamic mode change or security desktop change is pending.

When the time specified in this entry expires, the system forces the DirectDraw application to release the frame buffer. Forcing the release prevents the DirectDraw application from locking and thus not releasing its resources. However, forcing the release might cause an access violation error.

Value | Meaning
0 | DirectDraw acceleration is disabled and direct frame buffer access is not permitted. However, DirectDraw continues to run in emulation mode.
Seconds | The number of seconds the system waits before forcing a DirectDraw application to release a frame buffer.


PermanentSettingChanges

HKLM\SYSTEM\CurrentControlSet\Control\GraphicsDrivers\

Description

The DCI subkey stores configuration data for graphics drivers, including those implementing DirectDraw for Windows 2000.

Note Image Note

Windows 2000 does not add the PermanentSettingChanges subkey to the registry. You can add this subkey to override the default configuration of graphics drivers.


DisableAll

HKLM\SYSTEM\CurrentControlSet\Control\GraphicsDrivers\PermanentSettingChanges

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether users can save changes to the display settings of graphics devices. The display settings, usually changed by using Display in Control Panel, include characteristics such as resolution, color depth, and refresh rate. This entry is less restrictive than DisableAll in the TemporarySettingChanges subkey, which allows users to change display settings, but not save these changes.

Value | Meaning
0 | All users can save the changes they make to display settings.
1 | No users, including the Administrator, can save changes made to display settings.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add this entry to override the default configuration of graphics drivers by using a program which edits the registry.

Setting DisableAll to 1 is more restrictive than disabling Display in Control Panel (NoDispCPL). DisableAll prevents the use of the ChangeDisplaySettings API. Disabling Display in Control Panel does not prevent the user from using other programs that call the ChangeDisplaySettings API.

Related Entries

DisableAll in the TemporarySettingChanges subkey


TemporarySettingChanges

HKLM\SYSTEM\CurrentControlSet\Control\GraphicsDrivers\

Description

The DCI subkey stores configuration data for graphics drivers, including those implementing DirectDraw for Windows 2000.

Note Image Note

Windows 2000 does not add the TemporarySettingChanges subkey to the registry. You can add this subkey to override the default configuration of graphics drivers.


DisableAll

HKLM\SYSTEM\CurrentControlSet\Control\GraphicsDrivers\TemporarySettingChanges

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether users can save changes to the display settings of graphics devices. The display settings, usually changed by using Display in Control Panel, include characteristics such as resolution, color depth, and refresh rate. This entry is more restrictive than DisableAll in the PermanentSettingChanges subkey, which allows users to change display settings, but not save these changes.

Value | Meaning
0 | All users can save the changes they make to display settings.
1 | No users, including the Administrator, can change display settings.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add this entry to override the default configuration of graphics drivers by using a program which edits the registry.

Setting DisableAll to 1 is more restrictive than disabling Display in Control Panel (NoDispCPL). DisableAll prevents the use of the ChangeDisplaySettings API. Disabling Display in Control Panel does not prevent the user from using other programs that call the ChangeDisplaySettings API.

Related Entries

DisableAll in the PermanentSettingChanges subkey


GroupOrderList

HKLM\SYSTEM\CurrentControlSet\Control\

Description

The GroupOrderList subkey stores the order in which services in a service group are loaded when the system starts.

Services in a service group are assigned a tag, a numeric value that is unique within a service group. When the system loads a service group, it loads the services in the order in which their tags appear in the GroupOrderList entry for that service group.

Each entry in the GroupOrderList subkey represents a service group. The value of the entry is a series of tags in a specified order. All entries have the same format:

Service group name REG_BINARY Number of tags tag [tag …]

For example,

PointerPort REG_BINARY 030000000200000001000000030000000

The entry in this example determines the order in which the three services in the PointerPort service group are loaded. The first value, 3, indicates that there are three tags stored in the entry. The remaining values, 2, 1, and 3, indicate that the service assigned tag 2 will be loaded first in that group, followed by the service assigned tag 1, and then the service assigned tag 3.

Tip Image Tip

To find the services in any service group, use Regedit.exe to open HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services. On the Edit menu, click Find, type the name of the service group, and select only the Data check box. Press F3 to find other services in the service group.

To find the service group and tag number of any service, open the subkey representing the service in \CurrentControlSet\Services. Click Group to find its service group, and click Tag to find its tag number.


hivelist

HKLM\SYSTEM\CurrentControlSet\Control\

Description

The hivelist subkey contains the locations of files that store the permanent keys of the registry. Permanent keys are not recreated each time the system starts. By default, the files for all permanent keys except those in HKEY_CURRENT_USER are in Systemroot\System32\Config. The HKEY_CURRENT_USER files are stored in the subdirectories of System-drive\Documents and Settings.


\REGISTRY\MACHINE\HARDWARE

HKLM\SYSTEM\CurrentControlSet\Control\hivelist

Data type | Range | Default value
REG_SZ | Path | (blank)

Description

This entry has no value because the HKEY_LOCAL_MACHINE\Hardware key is recreated each time the system starts. The contents of this entry are not saved in a file.


\REGISTRY\MACHINE\SAM

HKLM\SYSTEM\CurrentControlSet\Control\hivelist

Data type | Range | Default value
REG_SZ | Path | \Device\Harddisk 0\Partition1\WINNT\System32\Config\SAM

Description

Specifies the location of files that store the HKEY_LOCAL_MACHINE\SAM key.


\REGISTRY\MACHINE\SECURITY

HKLM\SYSTEM\CurrentControlSet\Control\hivelist

Data type | Range | Default value
REG_SZ | Path | \Device\Harddisk 0\Partition1\WINNT\System32\Config\SECURITY

Description

Specifies the location of files that store the HKEY_LOCAL_MACHINE\Security key.


\REGISTRY\MACHINE\SOFTWARE

HKLM\SYSTEM\CurrentControlSet\Control\hivelist

Data type | Range | Default value
REG_SZ | Path | \Device\Harddisk 0\Partition1\WINNT\System32\Config\Software

Description

Specifies the location of files that store the HKEY_LOCAL_MACHINE\SOFTWARE key.


\REGISTRY\MACHINE\SYSTEM

HKLM\SYSTEM\CurrentControlSet\Control\hivelist

Data type | Range | Default value
REG_SZ | Path | \Device\Harddisk 0\Partition1\WINNT\System32\Config\System

Description

Specifies the location of files that store the HKEY_LOCAL_MACHINE\SYSTEM key.


\REGISTRY\USER\<Security ID number>

HKLM\SYSTEM\CurrentControlSet\Control\hivelist

Data type | Range | Default value
REG_SZ | Path | \Device\Harddisk #\Documents and Settings\Username\NTUSER.DAT

Description

Specifies the location of files that store the current user profile.

Note Image Note

The \REGISTRY\USER\<Security ID number> entry is a variable representing the entries in the hivelist subkey. It does not actually appear in the registry. This variable entry displays information which is common to the entries in the hivelist subkey.


\REGISTRY\USER\.DEFAULT

HKLM\SYSTEM\CurrentControlSet\Control\hivelist

Data type | Range | Default value
REG_SZ | Path | Device\Harddisk 0\Partition1\WINNT\System32\Config\Default

Description

Specifies the location of files that store the HKEY_USERS\.DEFAULT key.


IDConfigDB

HKLM\SYSTEM\CurrentControlSet\Control\

Description

The IDConfigDB subkey stores configuration data that identifies the current hardware configuration for the system.


CurrentConfig

HKLM\SYSTEM\CurrentControlSet\Control\IDConfigDB

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF | 1

Description

Identifies the hardware profile currently in use on the computer.

The value of this entry corresponds to the number of one of the <Profile-number> subkeys in the Hardware Profiles subkey of HKEY_LOCAL_MACHINE. (HKLM\System\CurrentControlSet\Hardware Profiles). It indicates the <Profile-number> subkey that stores the values comprising the current profile. The content of the indicated subkey also appears in the Current subkey in Hardware Profiles.

This value also corresponds to the number of one of the <Profile-number> subkeys in the Hardware Profiles subkey of IDConfigDB (HKLM\System\CurrentControlSet\Control\IDConfigDB\Hardware Profiles). This subkey stores information about the hardware profiles configured for use on the computer, including FriendlyName, which stores the name of the profile used in System in Control Panel.


Hardware Profiles

HKLM\SYSTEM\CurrentControlSet\Control\IDConfigDB\

Description

The Hardware Profiles subkey of IDConfigDB stores information about the hardware profiles configured on the system.

A hardware profile consists of specified changes to the original hardware profile configured in the SOFTWARE and SYSTEM keys of HKEY_LOCAL_MACHINE. These changes are stored in the Hardware Profiles subkey in HKEY_LOCAL_MACHINE.

The Hardware Profiles subkey in the IDConfigDB subkey stores information about the profile, but not the profile itself.

You can use System in Control Panel to create a hardware profile. Also, the system creates new hardware profiles automatically when it encounters configurations that require new profiles, such as when a portable computer is undocked or moved from one docking station to another.

Tip Image Tip

To create a hardware profile, double-click System in Control Panel, click the Hardware tab, and then click the Hardware Profiles button.


<Profile-number>

HKLM\SYSTEM\CurrentControlSet\Control\IDConfigDB\Hardware Profiles\

Description

A <Profile-number> subkey stores information about a particular hardware profile on the system.

The data stored in this subkey is specific to the hardware profile.

Note Image Note

The <Profile-number> subkey is a variable representing the numbered subkeys under the IDConfigDDB\Hardware Profiles subkey. It doesn't actually appear in the registry. We use this subkey to describe features common to all numbered Hardware Profiles subkeys in the registry.

This subkey stores information about the hardware profile, but it does not store the hardware profile. The changes that comprise the actual hardware profile are stored in a <Profile-number> subkey in HKLM\System\CurrentControlSet\Hardware Profiles.

Tip Image Tip

To determine which numbered subkey under Hardware Profiles represents the current hardware profile, see CurrentConfig. The value of CurrentConfig corresponds to the number of the subkey that contains the current hardware profile.

Related Entries

<Profile-number> subkey

CurrentConfig


FriendlyName

HKLM\SYSTEM\CurrentControlSet\Control\IDConfigDB\Hardware Profiles\<Profile-number>\

Description

Stores the commonly used name for the hardware profile. This name is used to identify the hardware profile in System in Control Panel and in Device Manager.

Tip Image Tip

To determine which numbered subkey under Hardware Profiles represents the current hardware profile, see CurrentConfig in HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\IDConfigDB. The value of CurrentConfig corresponds to the number of the subkey that contains the current hardware profile.


Keyboard Layout

HKLM\SYSTEM\CurrentControlSet\Control\

Description

The Keyboard Layout subkey stores data that associates Windows 2000 keyboard layout names with MS-DOS-style two-character keyboard layout names. This data is used by the kb16 command (equivalent to keyb in MS-DOS). The system uses this information when loading a keyboard layout for virtual DOS machine (VDM) windows.

Related Entries

Keyboard Layouts subkey


DosKeybCodes

HKLM\SYSTEM\CurrentControlSet\Control\Keyboard Layout\

Description

The DosKeybCodes subkey stores data used to associate Windows 2000 keyboard layouts with MS-DOS–style two-character keyboard layout names used by the kb16 command (equivalent to keyb in MS-DOS).

The entries in the DosKeybCodes subkey are named by 8-digit hexadecimal Windows 2000 keyboard layout codes. The first four digits of the codes indicate whether the keyboard layout or Input Method Editor is the default layout for the language (indicated by all zeros), or a variation of the default (other than zeros). The last four digits are the standard locale ID. For example, the 0001040A entry represents variation 0x0001 of language 0x040A (Spanish).

Entries in the DosKeybCodes subkey have the following format:

Layout code number REG_SZ Two-character MS-DOS keyboard layout name

For example,

0001040A REG_SZ sp

This entry associates Windows 2000 keyboard layout number 0x0001040A with MS-DOS keyboard layout name sp.


<DosKeybCode>

HKLM\SYSTEM\CurrentControlSet\Control\Keyboard Layout\DosKeybCodes

Description

Represents a keyboard layout.

These entries are named by 8-digit hexadecimal Windows 2000 keyboard layout codes. The first four digits of the codes indicate whether the keyboard layout or Input Method Editor is the default layout for the language (indicated by all zeros) or a variation of the default (other than zeros). The last four digits are the standard locale ID. For example, the 0001040A entry represents variation 0x0001 of language 0x040A (Spanish.)

All entries have the following format:

Layout code number REG_SZ Two-character MS-DOS keyboard layout name

For example,

0001040A REG_SZ sp

This entry associates Windows 2000 keyboard layout 0x0001040A with MS-DOS keyboard layout sp.

Note Image Note

The <DosKeybID> entry is a variable representing the entries under the HKLM\SYSTEM\CurrentControlSet\Control\DosKeybCodes subkey. It does not actually appear in the registry. This variable subkey displays the entries of the DosKeybCodes subkey.


DosKeybIDs

HKLM\SYSTEM\CurrentControlSet\Control\Keyboard Layout\

Description

The DosKeybIDs subkey contains entries that associate Windows 2000 keyboard layouts with special three-digit codes. These codes help to distinguish among layouts when there is more than one layout for a locale. The system uses this information when loading a keyboard layout for virtual DOS machine (VDM) windows.

The entries in the DosKeybIDs subkey are named by 8-digit hexadecimal Windows keyboard layout codes. The first four digits of the codes indicate whether the keyboard layout or Input Method Editor is the default layout for the language (as indicated by all zeros) or a variation of the default (other than zeros). The last four digits are the standard locale ID. For example, the 00010415 entry represents variation 0x0001 of language 0x0415 (Polish.)

Entries in the DosKeybIDs subkey have the following format:

Windows 2000 layout code number REG_SZ Three-digit MS-DOS keyboard layout ID

For example,

00010415 REG_SZ 214

associates Windows 2000 keyboard layout 0x00010415 with MS-DOS keyboard layout ID 214.


<DosKeybID>

HKLM\SYSTEM\CurrentControlSet\Control\Keyboard Layout\DosKeybIDs

Data type | Range | Default value
REG_SZ | Windows LayoutCodeNumber | (Depends on layout code.)

Description

Represents a keyboard layout.

The entries in the DosKeybIDs subkey are named by 8-digit hexadecimal Windows 2000 keyboard layout codes. The first four digits of the codes indicate whether the keyboard layout or Input Method Editor is the default layout for the language (as indicated by all zeros), or a variation of the default (other than zeros). The last four digits are the standard locale ID. For example, the 00010415 entry represents variation 0x0001 of language 0x0415 (Polish).

Entries in the DosKeybIDs subkey have the following format:

Windows 2000 layout code number REG_SZ Three-digit MS-DOS keyboard layout ID

For example,

00010415 REG_SZ 214

associates Windows 2000 keyboard layout 0x00010415 with MS-DOS keyboard layout ID 214.

Note Image Note

The <DosKeybID> entry is a variable representing the entries under the HKLM\SYSTEM\CurrentControlSet\Control\DosKeybIDs subkey. It does not actually appear in the registry. This variable entry displays the entries of the DosKeybIDs subkey.


Keyboard Layouts

HKLM\SYSTEM\CurrentControlSet\Control\

Description

The Keyboard Layouts subkey stores data used to associate the keyboard layout for each locale with the dynamic link library (DLL) for the keyboard layout or Input Method Editor (IME) that supports the language of the locale.

The subkeys of Keyboard Layouts are named by 8-digit hexadecimal Windows 2000 keyboard layout codes. The first four digits of the codes indicate whether the keyboard layout or IME is the default layout for the language (as indicated by all zeros), or a variation of the default (other than zeros). The last four digits are the standard locale ID.

For example, the 00010402 subkey represents the first variation of the keyboard layouts associated with locale 0x0402 (Bulgarian).

Related Entries

Keyboard Layout subkey


<Keyboard layout code>

HKLM\SYSTEM\CurrentControlSet\Control\Keyboard Layouts\

Description

The <Keyboard layout code> subkeys represent a particular keyboard layout.

The entries in the <Keyboard layout code> subkey store information about the installed keyboard layout or Input Method Editor (IME).

Note Image Note

The <Keyboard layout code> subkey is a variable representing the subkeys under the HKLM\SYSTEM\CurrentControlSet\Control\Keyboard Layouts subkey. It does not actually appear in the registry. This variable subkey displays the subkeys which are common to many of the Keyboard Layouts subkeys.


IME File

HKLM\SYSTEM\CurrentControlSet\Control\Keyboard Layouts\<Keyboard layout code>

Data type | Range | Default value
REG_SZ | DLL name | (Depends on keyboard layout.)

Description

Specifies the Input Method Editor (IME) for the installed keyboard layout.

Note Image Note

In Windows 2000, Unicode IMEs can be supported on any system locale when East Asian language support is installed.


Layout File

HKLM\SYSTEM\CurrentControlSet\Control\Keyboard Layouts\<Keyboard layout code>

Data type | Range | Default value
REG_SZ | DLL name | (Depends on keyboard layout or IME.)

Description

Specifies the DLL for the keyboard layout or Input Method Editor (IME).


Layout Id

HKLM\SYSTEM\CurrentControlSet\Control\Keyboard Layouts\<Keyboard layout code>

Data type | Range | Default value
REG_SZ | Layout ID number | (Depends on keyboard layout or IME.)

Description

Specifies the ID number of an alternate keyboard layout or Input Method Editor (IME). This entry appears only in subkeys in which the first four digits are greater than 0000, indicating that the keyboard layout or IME is a variation of the default keyboard layout for the locale.


Layout Text

HKLM\SYSTEM\CurrentControlSet\Control\Keyboard Layouts\<Keyboard layout code>

Data type | Range | Default value
REG_SZ | Keyboard layout name | (Depends on keyboard layout or IME.)

Description

Specifies the name used to represent the keyboard layout or Input Method Editor (IME) on the Input Locales tab of Regional Options in Control Panel.


Lsa

HKLM\SYSTEM\CurrentControlSet\Control\

Description

The Lsa subkey stores configuration data for the Local Security Authority (LSA).

Tip Image Tip

For more information about Windows 2000 security, see the Windows 2000 Distributed Systems Guide.


Authentication Packages

HKLM\SYSTEM\CurrentControlSet\Control\Lsa

Data type | Range | Default value
REG_BINARY | DLL filename | msv1_0

Description

Lists the user authentication package that is loaded and called when users attempt to log on to Windows 2000.

Caution Image Caution

Do not change the value of this entry. Windows 2000 cannot operate with authentication packages other than MSV 1_0. If you delete this value or delete the entry, no one will be able to log on to Windows 2000.


Bounds

HKLM\SYSTEM\CurrentControlSet\Control\Lsa

Data type | Range | Default value
REG_BINARY | 0x0 - 00 00 0A 00 00 00 0A 00 | 0x00 30 00 00 00 20 00 00 (Upper bound = 0x3000 (12,288); lower bound = 0x2000 (8,192))

Description

Establishes thresholds for managing the length of the kernel-mode Local Security Authority (LSA) audit queue. The audit queue stores kernel-mode events destined for the Security Log in Event Viewer.

The value of this entry is an 8-byte binary field. The first four bytes establish the maximum number of items that can be held in the audit queue (the upper bound). When the number of audits exceeds this value, LSA discards all new audits until the number of audits remaining in the queue reaches the lower bound, as established by the value of the last four bytes.

Tip Image Tip

The system does not notify you when the queue is nearing, has reached, or has exceeded its upper bound. To prevent the system from running when it cannot report all security events, set the value of CrashOnAuditFail to 1.

Related Entries

CrashOnAuditFail


CrashOnAuditFail

HKLM\SYSTEM\CurrentControlSet\Control\Lsa

Data type | Range | Default value
REG_DWORD | 0 | 1 | 2 | 0

Description

Determines whether the system halts when it cannot record new security events, either because the Security Log in Event Viewer is full, or because the internal queue to the log has reached the maximum established by the value of Bounds. This feature prevents unauthorized activities from occurring when they cannot be recorded in the Security Log.

Value | Meaning
0 | The system does not halt even when it cannot report all auditable security events.
1 | When the Security Log is full or the queue to the log has reached its maximum size, the system displays the message "c0000244 (STATUS_AUDIT_FAILED)" and halts. When the computer is restarted, and until the Security Log is cleared, only members of the Administrators group can log on.
2 | The system halted because it could not report auditable Security events. The system sets CrashOnAuditFail to 2 just before it halts. When the value of this entry is 2, the Local Security Authority (LSA) permits only members of the Administrators group to log on.

Change method

You must restart the computer before changes to this entry take effect.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Tip Image Tip

For more information on CrashOnAuditFail, see the Microsoft Knowledge Base link on the Web Resources page. Search the Knowledge Base for Article Q140058, or use the keywords CrashOnAuditFail or security log.

Related Entries

Bounds


Kerberos

HKLM\SYSTEM\CurrentControlSet\Control\Lsa\

Description

The Kerberos subkey stores configuration data for the Kerberos v5 authentication protocol in Windows 2000. Kerberos v5 is the primary security protocol for authentication within a domain. It verifies the identity of the user and the system, and transmits only encrypted passwords.


Domains

HKLM\SYSTEM\CurrentControlSet\Control\Lsa\Kerberos\

Description

The Domains subkey stores information about Kerberos realms for systems that elect to use non-Windows-based Kerberos authentication.


<Realm-name>

HKLM\SYSTEM\CurrentControlSet\Control\Lsa\Kerberos\Domains\

Description

The <Realm-name> subkey stores configuration data for a non-Windows-based Kerberos realm. Non-Windows Kerberos servers use realms instead of Windows domains.

Kerberos Setup (Ksetup.exe), a tool included with the Windows 2000 Support Tools, adds this subkey to the registry when you use Ksetup to create a Kerberos realm. The Kerberos Security Provider in Windows 2000 uses the data in the subkey to locate a non-Windows Kerberos Key Distribution Center and interoperate with the Kerberos realm.

This subkey bears the name you assign to the realm when you use the /SetRealm command in Kerberos Setup.

Change method

To add, delete, or change the configuration of a Kerberos realm, use Kerberos Setup (Ksetup.exe), a tool included in Windows 2000 Support Tools.

Note Image Note

The <Realm-name> subkey does not actually appear in the registry. It is a variable used to describe the elements common to realm-specific subkeys in the Domains subkey.

Tip Image Tip

For more information about KSetup.exe, see Tools Help in the Windows 2000 Support Tools. For more information about Kerberos interoperability features, see MIT Kerberos 5 (krb5 1.0) Interoperability on the Windows 2000 Server Security Services Web site.


KdcNames

HKLM\SYSTEM\CurrentControlSet\Control\Lsa\Kerberos\Domains\<Realm-name>

Data type | Range | Default value
REG_MULTI_SZ | Space-separated list of the DNS names of KDC servers | (There is no default value for this entry. You must specify at least one KDC server when you create a realm.)

Description

Stores the DNS names of computers running the Key Distribution Center (KDC) service for an Kerberos realm.

This entry stores the values you enter when you use the /AddKdc command in Kerberos Setup (Ksetup.exe), a tool included with the Windows 2000 Support Tools.

Computers running Windows 2000 can use a non-Windows Kerberos server to administer authentication, instead of using a Windows 2000 domain for Kerberos authentication. These systems participate in an Kerberos realm instead of a Windows domain, and the DNS names for the KDC servers are stored in this entry in the registry, instead of on a domain controller.

Change method

To change the value of this entry, use Kerberos Setup (Ksetup.exe), a tool included in Windows 2000 Support Tools. Do not edit the registry.

Note Image Note

This entry is required for a Kerberos realm. The realm will not operate properly unless this entry appears in the registry.

Tip Image Tip

For more information about KSetup.exe, see Tools Help in the Windows 2000 Support Tools. For more information about Kerberos interoperability features, see MIT Kerberos 5 (krb5 1.0) Interoperability on the Windows 2000 Server Security Services Web site.


KpasswdNames

HKLM\SYSTEM\CurrentControlSet\Control\Lsa\Kerberos\Domains\<Realm-name>

Data type | Range | Default value
REG_MULTI_SZ | Comma-separated list of computer names | (There is no default value for this entry. You must specify at least one password server when you create a realm.)

Description

Lists the computer names of Kerberos Change Password Protocol Servers for the Kerberos realm. These servers communicate on port 464.

This entry stores the values you enter when you use the /AddKpasswd command in Kerberos Setup (Ksetup.exe), a tool included with the Windows 2000 Support Tools.

Computers running Windows 2000 can use a non-Windows Kerberos server to administer authentication, instead of using a Windows 2000 domain for Kerberos authentication. These systems participate in a Kerberos realm instead of a Windows domain, and the names of the KDC password servers are stored in this entry in the registry, instead of on a domain controller.

Change method

To change the value of this entry, use Kerberos Setup (Ksetup.exe), a tool included in Windows 2000 Support Tools. Do not edit the registry.

Tip Image Tip

For more information about KSetup.exe, see Tools Help in the Windows 2000 Support Tools. For more information about Kerberos interoperability features, see MIT Kerberos 5 (krb5 1.0) Interoperability on the Windows 2000 Server Security Services Web site.

Caution Image Caution

This entry is required for a Kerberos realm. If it does not appear in the registry, users cannot change their Windows 2000 passwords.


RealmFlags

HKLM\SYSTEM\CurrentControlSet\Control\Lsa\Kerberos\Domains\<Realm-name>

Data type | Range | Default value
REG_DWORD | 0 - 7 | 0

Description

A bitmask specifying additional features of a non-Windows-based Kerberos realm.

Computers running Windows 2000 can use a non-Windows Kerberos server to administer authentication, instead of using a Windows 2000 domain for Kerberos authentication. These systems participate in an Kerberos realm instead of a Windows domain. This entry establishes the features of the realm.

To enable a feature, set the bit representing the feature to 1, or sum the decimal or hexadecimal values representing each feature. For example, to enable all features, set the value of this entry to 7 (1 + 2 + 4).

Value | Meaning
0 | No additional features enabled.
1 | Send address
2 | TCP supported
4 | Okay to delegate

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Tip Image Tip

For more information about KSetup.exe, see Tools Help in the Windows 2000 Support Tools. For more information about Kerberos interoperability features, see MIT Kerberos 5 (krb5 1.0) Interoperability on the Windows 2000 Server Security Services Web site.


Parameters

HKLM\SYSTEM\CurrentControlSet\Control\Lsa\Kerberos\

Description

The Kerberos\Parameters subkey stores configuration options for the Kerberos v5 authentication protocol in Windows 2000.

Note Image Note

Windows 2000 does not add this subkey to the registry. You can add it by editing the registry or by using a program that edits the registry.


LogLevel

HKLM\SYSTEM\CurrentControlSet\Control\Lsa\Kerberos\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Directs Kerberos to record an informational event in the System Log in Event Viewer whenever it receives a request for a service ticket.

Value | Meaning
0 | Ticket requests are not recorded in the event log.
1 | Ticket requests are recorded in the event log (Source = Kerberos).

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


UserList

HKLM\SYSTEM\CurrentControlSet\Control\Lsa\Kerberos\

Description

The UserList subkey stores entries that associate a Kerberos security principal to a local Windows 2000 user account.

Computers running Windows 2000 can use a non-Windows Kerberos server to administer authentication, instead of using a Windows 2000 domain for Kerberos authentication. For ease of use, the system lets you map a Kerberos security principal, such as the name of a principal or a realm, to a local Windows user account.

This subkey stores mappings you enter when you use the /MapUser command in Kerberos Setup (Ksetup.exe), a tool included with the Windows 2000 Support Tools. Ksetup adds the entries to the registry.

All entries in this subkey have the following format, where * indicates all users.

Kerberos-name or * REG_SZ Local-name or *

For example, if you enter the following mapping command in Ksetup:

ksetup /mapuser user@domain.reskit.com  Guest

then Ksetup adds the following entry to the UserList subkey:

user@domain.reskit.com REG_SZ Guest

Change method

To change the value of this entries in this subkey, use Kerberos Setup (Ksetup.exe), a tool included in Windows 2000 Support Tools. Do not edit the registry.

Tip Image Tip

For more information about KSetup.exe, see Tools Help in the Windows 2000 Support Tools. For more information about Kerberos interoperability features, see MIT Kerberos v5 (krb5 1.0) Interoperability on the Windows 2000 Server Security Services Web site.


lmcompatibilitylevel

HKLM\SYSTEM\CurrentControlSet\Control\Lsa

Data type | Range | Default value
REG_DWORD | 0-5 | 0

Description

Specifies the mode of authentication and session security to be used for network logons. This does not affect interactive logons.

Value | Meaning
0 | Send LM and NTLM response; never use NTLMv2 session security. Clients will use LM and NTLM authentication, and never use NTLMv2 session security. Domain controllers will accept LM, NTLM and NTLMv2 authentication.
1 | Use NTLMv2 session security if negotiated. Clients will use LM and NTLM authentication, and use NTLMv2 session security if the server supports it. Domain controllers accept LM, NTLM and NTLMv2 authentication.
2 | Send NTLM response only. Clients will only use NTLM authentication, and use NTLMv2 session security if the server supports it. Domain controller accepts LM, NTLM and NTLMv2 authentication.
3 | Send NTLMv2 response only. Clients will use NTLMv2 authentation, use NTLMv2 session security if the server supports it. Domain controllers accept LM, NTLM and NTLMv2 authentication.
4 | Domain controller refuses LM responses. Clients will use NTLMv2 authentation, and use NTLMv2 session security if the server supports it. Domain controller refuses LM authentication (instead, it accepts NTLM and NTLMv2).
5 | Domain controller refuses LM and NTLM responses (accepts only NTLMv2). Clients will use NTLMv2 authentation, use NTLMv2 session security if the server supports it. Domain controller refuses NTLM and LM authentication (accepts only NTLMv2).

Activation method

You must restart Windows to make changes to this entry effective.

Note Image Note

For more information about Windows 2000 security, see the Windows 2000 Distributed Systems Guide.

Tip Image Tip

For more information on LM authentication, see the Microsoft Knowledge Base link on the Web Resources page. Search the Knowledge Base for Article Q147706, or use the keywords LM authentication.


MSV1_0

HKLM\SYSTEM\CurrentControlSet\Control\Lsa\

Description

The MSV1_0 subkey stores information about the security settings for the computer.


NtlmMinClientSec

HKLM\SYSTEM\CurrentControlSet\Control\Lsa\MSV1_0

Data type | Range | Default value
REG_DWORD | 0 | 0x10 | 0x20 | 0x80000 | 0x20000000 | 0

Description

Specifies the minimum required security setting for client-side network connections by applications using the NTLMSSP security provider.

Value | Meaning
0 | None. No security is used for either authentication or session security.
0x10 | Message integrity. If either NtlmMinClientSec or NtlmMinServerSec is set to 0x10, the connection will fail if message integrity is not negotiated.
0x20 | Message confidentiality. If either NtlmMinClientSec or NtlmMinServerSec is set to 0x20, the connection will fail if message confidentiality is not negotiated.
0x80000 | NTLMv2 session security. If either NtlmMinClientSec or NtlmMinServerSec is set to 0x80000, the connection will fail if NTLMv2 session security is not negotiated.
0x20000000 | 128 bit encryption. If either NtlmMinClientSec or NtlmMinServerSec is set to 0x20000000, the connection will fail if message confidentiality is in use but 128-bit encryption is not negotiated.

Activation method

You must restart Windows to make changes to this entry effective.

Note Image Note

These settings will not guarantee that message integrity or confidentiality will actually be used by an application even when they are negotiated. For more information, see the Microsoft Knowledge Base link on the Web Resources page. Search the Knowledge Base for Article Q147706, or use the keywords LM authentication.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

For more information about Windows 2000 security, see the Windows 2000 Distributed Systems Guide.

Related Entries

NtlmMinServerSec


NtlmMinServerSec

HKLM\SYSTEM\CurrentControlSet\Control\Lsa\MSV1_0

Data type | Range | Default value
REG_DWORD | 0 | 0x10 | 0x20 | 0x80000 | 0x20000000 | 0

Description

Specifies the minimum required security setting for server-side network connections by applications using the NTLMSSP security provider.

Value | Meaning
0 | None. No security is used for either authentication or session security.
0x10 | Message integrity. If either NtlmMinClientSec or NtlmMinServerSec is set to 0x10, the connection will fail if message integrity is not negotiated.
0x20 | Message confidentiality. If either NtlmMinClientSec or NtlmMinServerSec is set to 0x20, the connection will fail if message confidentiality is not negotiated.
0x80000 | NTLMv2 session security. If either NtlmMinClientSec or NtlmMinServerSec is set to 0x80000, the connection will fail if NTLMv2 session security is not negotiated.
0x20000000 | 128 bit encryption. If either NtlmMinClientSec or NtlmMinServerSec is set to 0x20000000, the connection will fail if message confidentiality is in use but 128-bit encryption is not negotiated.

Activation method

You must restart Windows to make changes to this entry effective.

Note Image Note

These settings will not guarantee that message integrity or confidentiality will actually be used by an application even when they are negotiated. For more information, see the Microsoft Knowledge Base link on the Web Resources page. Search the Knowledge Base for Article Q147706, or use the keywords LM authentication.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

For more information about Windows 2000 security, see the Windows 2000 Distributed Systems Guide.

Related Entries

NtlmMinClientSec


Notification Packages

HKLM\SYSTEM\CurrentControlSet\Control\Lsa

Data type | Range | Default value
REG_MULTI_SZ | File name[ file name...] | FPNWCLNT RASSFM KDCSVC scecli

Description

Specifies the dynamic-link libraries (DLLs) that are loaded or called when passwords are set or changed. To specify more than one file, list the file names one above the other by pressing ENTER between each file name.

This entry is often used to load libraries for services such as File and Print Services for NetWare.

You can use this entry to implement custom DLLs which specify alternate criteria for valid passwords, such as complex password rules. Notification packages that implement password verification are recommended for all primary and backup domain controllers. You can also write a custom password filter to fulfill special security requirements.

Tip Image Tip

For more information on and sample code for creating password filters, see the Microsoft Knowledge Base link on the Web Resources page. Search the Knowledge Base for Article Q151082, or use the keywords Password Change Filtering .

To audit the loading of notification packages, click Start, point to Programs, point to Administrative Tools, and then select Local Security Policy. Expand Local Policies, and then double-click Audit Policy. Double-click Audit System Events, and then use the Success and Failure check boxes.


RestrictAnonymous

HKLM\SYSTEM\CurrentControlSet\Control\Lsa

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Restricts anonymous users from displaying lists of users or viewing security permissions.

Value | Meaning
0 | Disabled. Anonymous users are not restricted.
1 | Enabled. Users who logged on anonymously (also known as null session connections) cannot display lists of domain user names or share names. These users cannot use all of the features of Windows Explorer, Local Users and Groups, or other programs that enumerate users or shares or view Security permissions.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Tip Image Tip

For more information on RestrictAnonymous, see the Microsoft Knowledge Base link on the Web Resources page. Search the Knowledge Base for Article Q143474, or use the keywords restrict anonymous logon.


Network

HKLM\SYSTEM\CurrentControlSet\Control\

Description

The Network subkey stores configuration data for networking components and connections.


Connections

HKLM\SYSTEM\CurrentControlSet\Control\Network\

Description

The Connections subkey stores configuration data for Network and Dial-up Connections, the Windows 2000 program for adding, removing, configuring, and monitoring RAS and LAN connections.

Note Image Note

Most of the entries in the subkeys of Connections can be changed by using Network and Dial-up Connections. Whenever possible, use Network and Dial-up Connections and avoid editing the registry.

Tip Image Tip

To start Network and Dial-up Connections, right-click My Network Places and then click Properties, or in Control Panel, double-click Network and Dial-up Connections.


StatMon

HKLM\SYSTEM\CurrentControlSet\Control\Network\Connections\

Description

The StatMon subkey stores configuration data for the Connection Status Monitor and other tools that monitor the status and performance of network connections.

Note Image Note

The StatMon subkey does not appear in the registry until you install a tool that monitors network connections.


ShowLanErrors

HKLM\SYSTEM\CurrentControlSet\Control\Network\Connections\StatMon

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether LAN connection error counts are displayed on the Status page for a local area connection.

Because most users do not need this information and might find it confusing or misleading, error counts do not appear by default. However, you can add this entry to the registry and set it to 1 to add the error counts to the status page display.

Value | Meaning
0 | LAN connection error counts do not appear on the Status page for a local area connection.
1 | LAN connection error counts appear on the General tab of the Status page.

Note Image Note

This entry applies to the Status page displayed to all users of this computer. You cannot configure it separately for different users of the computer.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry. If the StatMon subkey has not been added by a monitoring tool, you must also add the subkey to the registry.

Tip Image Tip

To display the Status page for a local area connection, use Network and Dial-up Connections in Control Panel. Right-click My Network Places, click Properties, and then double-click the name of a local area connection, or right-click the name of a local area connection and then click Status.


NetworkProvider

HKLM\SYSTEM\CurrentControlSet\Control\

Description

The NetworkProvider subkey contains information about the available network providers.

Related Entries

networkprovider subkey in the Services key


Order

HKLM\SYSTEM\CurrentControlSet\Control\NetworkProvider\

Description

The NetworkProvider\Order subkey contains a list of the network providers that use the Microsoft network-independent APIs.

Related Entries

networkprovider subkey in the Services key


ProviderOrder

HKLM\SYSTEM\CurrentControlSet\Control\NetworkProvider\Order

Data type | Range | Default value
REG_SZ | Provider name[, Provider name, ...] | LanmanWorkstation (when a single network is installed)

Description

Contains a list of the available network providers in the order in which they are accessed.

To appear in this list, network providers must be represented by a subkey under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services. They must be a member of the NetworkProvider service group, and must have a networkprovider subkey in their Services subkey. The NetworkProvider subkey stores information for the Multiple Provider Router. The service group for each service is stored in the value of Group.

Change method

To change the value of this entry, double-click Network in Control Panel. From the Advanced menu, choose Advanced Settings and click the Provider Order tab. Click on a provider and use the up and down arrows to change the order.

Tip Image Tip

To find all the services in the NetworkProvider service group, use Regedit.exe to open HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services. On the Edit menu, click Find, type NetworkProvider, and then select only the Data check box.

Related Entries

Group

networkprovider subkey in the Services key


Nls

HKLM\SYSTEM\CurrentControlSet\Control\

Description

The Nls subkey stores data for the National Language Support (NLS) interface in Windows 2000. This subkey contains information about supported locales and code pages.

The CodePage subkey and Language subkey of the Nls subkey associate code page and locale identification codes with the translation files required to use them.

Related Entries

CodePage subkey

Language subkey


CodePage

HKLM\SYSTEM\CurrentControlSet\Control\Nls\

Description

The CodePage subkey contains data that associates code page IDs supported by Windows 2000 with code page translation files installed on the system.

Each entry in the CodePage subkey represents one supported code page. If the code page is installed on the system, the value of the entry is the name of the code page file. If the code page is supported but not installed, the value field of the entry is blank.

There are also some special code page entries installed with Windows 2000. These entries associate a system default with another code page entry.


<code-page>

HKLM\SYSTEM\CurrentControlSet\Control\Nls\CodePage

Data type | Range | Default value
REG_SZ | NLS filename | (Depends on locale.)

Description

Represents a code page.

Each entry in the CodePage subkey represents one supported code page. If the code page is installed on the system, the value of the entry is the name of the code page file. If the code page is supported but not installed, the value field of the entry is blank.

Entries in the CodePage subkey have the following format:

# CodePageID REG_SZ Filename | (blank)

For example,

10000 REG_SZ c_10000.nls

This entry indicates that code page 10000 is installed on the system and is associated with code page file C_10000.nls.

10006 REG_SZ

This entry indicates that code page 10006 is supported by Windows 2000, but is not installed on the system.

Note Image Note

The <code-page> entry is a variable representing the entries under the CodePage subkey. It does not actually appear in the registry. This variable entry displays information which is common to the entries in the CodePage subkey.


ACP

HKLM\SYSTEM\CurrentControlSet\Control\Nls\CodePage

Data type | Range | Default value
REG_SZ | code page | For U.S. English: 1252

Description

Indicates the default code page for ANSI characters. These code pages are supported for Windows 3.1 compatibility. For U.S. English, the value of this entry indicates that code page 1252 and its file, C_1252.nls, are used for ANSI characters.

Value | Character set
874 | Thai
932 | ShiftJIS - Japan
936 | GBK - Chinese (PRC, Singapore)
949 | Korean Unified Hangul
950 | Big5 Extended - Chinese (Taiwan, Hong Kong SAR)
1250 | Central European
1251 | Cyrillic
1252 | U.S. (ANSI)
1253 | Greek
1254 | Turkish
1255 | Hebrew
1256 | Arabic
1257 | Baltic
1258 | Vietnamese


MACCP

HKLM\SYSTEM\CurrentControlSet\Control\Nls\CodePage

Data type | Range | Default value
REG_SZ | code page | For U.S. English: 10000

Description

Indicates the default code page for Macintosh characters. For U.S. English, the value of this entry indicates that code page 10000 and its file, C_10000.nls, are used for Macintosh characters.

Value | Character set
10000 | Roman
10001 | Japanese
10002 | Chinese (Big5)
10003 | Korean
10004 | Arabic
10005 | Hebrew
10006 | Greek I
10007 | Cyrillic
10010 | Romania
10017 | Ukraine
10029 | Latin 2
10079 | Icelandic
10081 | Turkish
10082 | Croatian


OEMCP

HKLM\SYSTEM\CurrentControlSet\Control\Nls\CodePage

Data type | Range | Default value
REG_SZ | code page | For U.S. English: 437

Description

Indicates the default code page for OEM (original equipment manufacturers) characters. For U.S. English, the value of this entry indicates that code page 437 and its file, C_437.nls, are used for OEM characters.

Value | Character set
437 | United States
708 | Arabic (ASMO 708)
720 | Arabic (Transparent ASMO)
737 | Greek (formerly 437G)
775 | Baltic
850 | Multilingual (Latin I)
852 | Slavic (Latin II)
855 | Cyrillic
857 | Turkish
860 | Portuguese
861 | Icelandic
862 | Hebrew
863 | Canadian-French
864 | Arabic
865 | Nordic
866 | Russian
869 | Modern Greek
874 | Thai
932 | ShiftJIS - Japan
936 | GBK - Chinese (PRC, Singapore)
949 | Korean Unified Hangul
950 | Big5 Extended - Chinese (Taiwan, Hong Kong SAR)
1258 | Windows Vietnamese


OEMHAL

HKLM\SYSTEM\CurrentControlSet\Control\Nls\CodePage

Data type | Range | Default value
REG_SZ | font filename | vgaoem.fon

Description

Specifies the default font supplied by the OEM (original equipment manufacturer).

This font is stored in Systemroot\WINNT\Fonts.


Language

HKLM\SYSTEM\CurrentControlSet\Control\Nls\

Description

The Language subkey contains data that associates Windows 2000 locale IDs with internal supporting files installed on the system.

Each entry in the Language subkey represents one locale supported by Windows 2000. If the locale is installed on the system, the value of the entry is the name of its internal supporting file. If the locale is supported but not installed, there is no value for the entry.


<language-ID>

HKLM\SYSTEM\CurrentControlSet\Control\Nls\Language

Data type | Range | Default value
REG_SZ | NLS filename | (Depends on locale.)

Description

Represents a language for Windows 2000.

The <language-ID> entry is a variable representing the entries under the Language subkey. It does not actually appear in the registry. This variable entry displays information which is common to the entries in the Language subkey.

Each entry in the Language subkey represents one locale supported by Windows 2000. If the locale is installed on the system, the value of the entry is the name of its internal supporting file. If the locale is supported but not installed, there is no value for the entry.

Each entry has the following format:

# LanguageID REG_SZ Filename | (no value)

For example,

0402 REG_SZ l_intl.nls

This entry indicates that locale 0402 is installed on the system and is associated with file L_intl.nls.

0403 REG_SZ

This entry indicates that locale 0403 is supported by Windows 2000, but is not installed on the computer.

Note Image Note

The <language-ID> entry is a variable representing the entries under the Language subkey. It does not actually appear in the registry. This variable entry displays information which is common to the entries in the Language subkey.


Default

HKLM\SYSTEM\CurrentControlSet\Control\Nls\Language

Data type | Range | Default value
REG_SZ | locale | For U.S. English: 0409

Description

Indicates the system default locale. The value of this entry indicates that locale 0x0409 (US English) is used when no other language is specified.


InstallLanguage

HKLM\SYSTEM\CurrentControlSet\Control\Nls\Language

Data type | Range | Default value
REG_SZ | locale | For U.S. English: 0409

Description

Indicates the code page which corresponds to the localized version of the product.


Language Groups

HKLM\SYSTEM\CurrentControlSet\Control\Nls\

Description

The Language Groups subkey contains information about the supported and installed language groups.

Each of the entries in this subkey represents a language group which is supported by Windows 2000.

<group-number> | Language Group
1 | Western Europe
2 | Central Europe
3 | Baltic
4 | Greek
5 | Cyrillic
6 | Turkish
7 | Japanese
8 | Korean
9 | Traditional Chinese
a | Simplified Chinese
b | Thai
c | Hebrew
d | Arabic
e | Vietnamese
f | Indic
10 | Georgian
11 | Armenian


<group-number>

HKLM\SYSTEM\CurrentControlSet\Control\Nls\Language Groups

Data type | Range | Default value
REG_SZ | (Blank) | 1 | There is no default value for this entry.

Description

Indicates which language groups are installed.

Value | Meaning
(Blank) | The language group is supported but not installed.
1 | The language group is installed.

Note Image Note

The <group-number> entry is a variable representing the entries under the Language Groups subkey. It does not actually appear in the registry. This variable entry displays information which is common to the entries in the Language Groups subkey.


Locale

HKLM\SYSTEM\CurrentControlSet\Control\Nls\

Description

The entries in this subkey list the locales that are installed on the system.


<locale>

HKLM\SYSTEM\CurrentControlSet\Control\Nls\Locale

Data type | Range | Default value
REG_SZ | (Blank) | 0x1 - 0x11 | There is no default value for this entry.

Description

Represents a locale supported by the system.

The <locale> entries represent the locales supported by the system. Those entries which have a blank value are supported by the system but not installed. Those entries with a value are installed, and the value of the entry indicates the language group of the locale.

Value | Meaning
(Blank) | The locale is supported by the system but not installed.
0x1 | Western Europe
0x2 | Central Europe
0x3 | Baltic
0x4 | Greek
0x5 | Cyrillic
0x6 | Turkish
0x7 | Japanese
0x8 | Korean
0x9 | Traditional Chinese
0xA | Simplified Chinese
0xB | Thai
0xC | Hebrew
0xD | Arabic
0xE | Vietnamese
0xF | Indic
0x10 | Georgian
0x11 | Armenian

Note Image Note

The <locale> entry is a variable representing the entries under the Locale subkey. It does not actually appear in the registry. This variable entry displays information which is common to the entries in the Locale subkey.


Alternate Sorts

HKLM\SYSTEM\CurrentControlSet\Control\Nls\Locale\

Description

The Alternate Sorts subkey contains data about the alternate sorts available for the installed locale. These sorting codes determine which sorting order will be used for those locales which have more than one sorting order.


<sort-code>

HKLM\SYSTEM\CurrentControlSet\Control\Nls\Locale\Alternate Sorts

Data type | Range | Default value
REG_SZ | (Blank) | 1 | There is no default value for this entry.

Description

Represents a sort code.

The entries which appear in the Alternate Sorts subkey are determined by the installed locales. Each entry has the following format:

Sorting ID REG_SZ (Blank) | 1

For example,

00010407 REG_SZ 1

This entry indicates that an alternate sort will be used for locale 0407.

Note Image Note

The <sort-code> entry is a variable representing the entries under the Alternate Sorts subkey. It does not actually appear in the registry. This variable entry displays information which is common to the entries in the Alternate Sorts subkey.


Print

HKLM\SYSTEM\CurrentControlSet\Control\

Description

The Print subkey stores information and settings for printers that applies to all users of the computer.

Note Image Note

For more information on printing with Windows 2000, see the Windows 2000 Professional Resource Kit.

Related Entries

Print subkey in HKEY_LOCAL_MACHINE\SOFTWARE.


BeepEnabled

HKLM\SYSTEM\CurrentControlSet\Control\Print

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether the computer beeps when a local print job is in error.

Value | Meaning
0 | The computer does not beep each time a print job is retried.
1 | The computer beeps each time the job is retried.

By default, a print job is resubmitted every 10 seconds. The beep will occur on the same computer which displays popups, which is determined by the value of NetPopupToComputer.

Note Image Note

The value of this entry in the Print subkey applies only to local print jobs. The value of BeepEnabled in the <server-name> subkey applies to network print jobs sent to the specified server.

Related Entries

BeepEnabled for LanMan Print Services network printers


BrowsePrintWorkstations

HKLM\SYSTEM\CurrentControlSet\Control\Print

Data type | Range | Default value
REG_DWORD | 0x0 | 0xFFFFFFFF | 4 + number of machines sharing printers 32

Description

Specifies the number of workstations to be notified with the browse list.

Value | Meaning
0 | The printer will not appear in the browse list for any Windows 3.5 or earlier clients. It will appear in the browse list for Windows 3.51 and later clients.
(blank) | 0xFFFFFFFF | The printer will appear in the browse list of the default number of clients (see Default value above).

Note Image Note

This entry affects only Windows 3.5 and earlier clients.


DebugFlags

HKLM\SYSTEM\CurrentControlSet\Control\Print

Description

This entry is for internal use only. Do not change the value of this entry.


DisableServerThread

HKLM\SYSTEM\CurrentControlSet\Control\Print

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether the browse thread on the current print server is enabled. The browse thread is used to call other printer servers to notify them that the printer exists.

Value | Meaning
0 | Enables the browse thread.
1 | Disables the browse thread.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


EnableBroadcastSpoolerStatus

HKLM\SYSTEM\CurrentControlSet\Control\Print

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether the system sends spooler and job status messages when the job count changes.

Value | Meaning
0 | Status messages are not sent.
1 | Status messages are sent.

Note Image Note

In Windows NT 4.0 and earlier, the spooler sent messages by default, but this behavior is changed in Windows 2000 to improve performance.

Caution Image Caution

A value of 1 can degrade the performance of your system by requiring programs that don't use spooler information to read and discard it.


Environments

HKLM\SYSTEM\CurrentControlSet\Control\Print\

Description

The Environments subkey contains subkeys that store configuration data for printing on the different platforms on which Windows 2000 runs. Each subkey representing a platform has two subkeys, Drivers and Print Processors, which store configuration data for the print drivers and processors installed on Windows 2000.


Windows <environment-name>

HKLM\SYSTEM\CurrentControlSet\Control\Print\Environments\

Description

The Windows <environment-name> subkey represents a windows environment and stores entries that apply only to that environment.

Note Image Note

The Windows <environment-name> subkey is a variable representing the subkeys in the Environments subkey. It does not actually appear in the registry. This variable subkey displays information which is common to the subkeys in the Environments subkey.

The Windows <environment-name> subkeys contain subkeys that store configuration data for printing on different platforms on which different versions of Windows runs. Each subkey representing a platform has two subkeys, Drivers and Print Processors, which store configuration data for the print drivers and processors installed on Windows.


Directory

HKLM\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows <environment-name>

Data type | Range | Default value
REG_SZ | Directory name | (Depends on environment.)

Description

Specifies the directory which contains print drivers for that environment.

For example, the value W32X86 indicates that the drivers for the Windows x86 environment are stored in Systemroot\System32\spool\drivers\w32x86.

Windows environment | Default value
Windows 4.0 | WIN40
Windows NT Alpha_AXP | W32ALPHA
Windows NT PowerPC | W32PPC
Windows NT R4000 | W32MIPS
Windows NT x86 | W32X86


Drivers

HKLM\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows <environment-name>\

Description

The Drivers subkey contains subkeys which store configuration data for each of the drivers installed.


Version-<number>

HKLM\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows <environment-name>\Drivers\

Description

The Version-<number> subkey contains information about the drivers for a print environment. There is a different number for each version of the printer driver. Version-2 drivers are Windows NT 4.0 drivers; Version-3 drivers are Windows 2000 drivers.

Note Image Note

The Version-<number> subkey is a variable representing the subkeys under the Drivers subkey. It does not actually appear in the registry. This variable subkey displays information which is common to the subkeys in the Drivers subkey.


<driver-name>

HKLM\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows <environment-name>\Drivers\Version-<number>\

Description

The <driver-name> subkey in the Version-<number> subkey contains information about necessary files and settings for the specified printer driver.

Note Image Note

The <driver-name> subkey is a variable representing the entries under the Version-number subkey. It does not actually appear in the registry. This variable subkey displays information which is common to the subkeys in the Version-number subkey.


Configuration File

HKLM\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows <environment-name>\Drivers\Version-<number>\<driver-name>

Data type | Range | Default value
REG_SZ | File name | (Depends on driver.)

Description

Contains the name of the configuration dynamic-link library (DLL) for the print environment.

This file is stored in Systemroot\WINNT\system32\spool\drivers\<environment-name>\<version-number>.


Data File

HKLM\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows <environment-name>\Drivers\Version-<number>\<driver-name>

Data type | Range | Default value
REG_SZ | File name | (Depends on driver.)

Description

Contains the name of the print datafile for the print environment.

This file contains information about the default settings for the printer. It is stored in Systemroot\WINNT\system32\spool\drivers\<environment-name>\<version-number>.


Dependent Files

HKLM\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows <environment-name>\Drivers\Version-<number>\<driver-name>

Data type | Range | Default value
REG_MULTI_SZ | filenames | (Depends on printer driver.)

Description

Lists the names of additional files required by the system for printing.

These files are stored in Systemroot\WINNT\system32\spool\drivers\<environment-name>\<version-number>.

Related Entries

DependentFiles in the PrinterDriverData subkey in the Providers subkey


Driver

HKLM\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows <environment-name>\Drivers\Version-<number>\<driver-name>

Data type | Range | Default value
REG_SZ | File name | (Depends on driver.)

Description

Stores the name of the dynamic-link library (DLL) which contains the driver for the printer.

This file is stored in Systemroot\WINNT\system32\spool\drivers\<environment-name>\<version-#>

Related Entries

Driver in the <processor-name> subkey

Driver in the <Port Monitor> subkey

Driver in the LanMan Print Services Port subkey


Help File

HKLM\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows <environment-name>\Drivers\Version-<number>\<driver-name>

Data type | Range | Default value
REG_SZ | filename | filename

Description

Contains the name of the file which contains the context-sensitive help for the properties box of the specified printer driver.

This file is located in Systemroot\WINNT\System32\spool\drivers\<environment-name>\<version-number>.


Previous Names

HKLM\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows <environment-name>\Drivers\Version-<number>\<driver-name>

Data type | Range | Default value
REG_MULTI_SZ | path | There is no default value for this entry.

Description

Stores the previous names of the printer driver.

This entry is used when the name of the printer driver has changed between releases.


Version

HKLM\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows <environment-name>\Drivers\Version-<number>\<driver-name>

Data type | Range | Default value
REG_DWORD | Version number | (Depends on printer driver.)

Description

Contains the version number of the installed print driver.


Directory

HKLM\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows <environment-name>\Drivers\Version-<number>

Data type | Range | Default value
REG_SZ | number | (Depends on environment.)

Description

Specifies the version number. The value of this entry corresponds to the version number of the subkey.


Print Processors

HKLM\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows <environment-name>\

Description

The Print Processors subkey stores configuration data for print processors for that environment.

The Print Processors subkey contains a subkey representing each print processor installed in Windows for that platform. These entries store configuration data separately for each print processor.


<processor-name>

HKLM\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows <environment-name>\Print Processors\

Description

The <processor-name> entry is a variable representing the subkey under the Print Processors subkey. It does not actually appear in the registry. This variable subkey displays information which is common to the subkeys in the Print Processors subkey.

The <processor-name> subkey contains configuration data for the print processor.


Driver

HKLM\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows <environment-name>\Print Processors\<processor-name>

Data type | Range | Default value
REG_SZ | DLL filename | (Depends on processor.)

Description

Stores the name of the dynamic-link library (DLL) which contains the driver for the print processor.

The default DLLs which are included with Windows 2000 are listed below, though other DLLs might also appear. The location of the DLL will vary: localspl.dll is located in Systemroot\WINNT\system32; other DLLs might appear in Systemroot\WINNT\system32\spool\prtprocs\w32x86.

Processor | DLL filename
SFMPSPRT | sfmpsprt.dll
winprint | localspl.dll

Related Entries

Driver in the <printer-name> subkey

Driver in the <Port Monitor> subkey

Driver in the LanMan Print Services Port subkey


FastPrintSlowDownThreshold

HKLM\SYSTEM\CurrentControlSet\Control\Print

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF bytes | FastPrintWaitTimeout FastPrintThrottleTimeout (Default: 0x78 (120 bytes))

Description

Establishes the minimum size of a spooling job that can be scheduled for printing.

If the portion of a print job that has been spooled is smaller than the size specified by the value of this entry, the job continues to spool, but cannot be scheduled to print. The job is scheduled to print when the portion spooled reaches this value.

This entry also is used to determine whether the spooler regulates the rate at which the job is spooled. If the portion of a spooling job that remains to be sent to the printer is less than the size specified by this value, the spooler limits the rate at which the job is sent to one byte of data in every interval specified by the value of FastPrintThrottleTimeout. This strategy is designed to prevent printers from timing out because they have not received data frequently enough. (Most PostScript printers must receive data at least every 15 seconds.)

The default value of this entry is calculated by dividing the value of FastPrintWaitTimeout (default = 240 seconds) by the value of FastPrintThrottleTimeout (default = 2 seconds/byte). This entry is used only when the Spool print documents so program finishes printing faster option is selected and the Print spooled documents first option is cleared.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

FastPrintThrottleTimeout

FastPrintWaitTimeout


FastPrintThrottleTimeout

HKLM\SYSTEM\CurrentControlSet\Control\Print

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF milliseconds | 0x7D0 (2 seconds)

Description

Determines the rate at which the spooler sends data when the FastPrintSlowDownThreshold is reached. When this threshold is reached, the spooler sends one byte of data each time the interval specified by this entry expires. This prevents the printer from pausing because it hasn't received data for a specified period (typically 15 seconds for a PostScript printer). The spooler continues to send data at this rate until the value of FastPrintSlowDownTheshold is exceeded.

This entry is used when the Start printing immediately option is selected.

Change method

To change the value of this entry, right-click the printer in the Printers folder, and then select Properties. Click the Advanced tab, and then select or clear the Start printing immediately radio button.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

FastPrintSlowDownThreshold


FastPrintWaitTimeout

HKLM\SYSTEM\CurrentControlSet\Control\Print

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF milliseconds | 0x3A980 (240,000 msec = 4 minutes)

Description

Determines how long the port thread waits for an application to send more data before pausing the current print job, and then moving to the next print job. This entry is used when the Start printing immediately option is selected to synchronize the port thread with the spooling application.

Change method

To change the value of this entry, right-click the printer in the Printers folder, and then select Properties. Click the Advanced tab tab, and then select or clear the Start printing immediately radio button.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


MaxRpcSize

HKLM\SYSTEM\CurrentControlSet\Control\Print

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF (in bytes) | 1048576 (1 MB)

Description

Specifies the maximum size in bytes of incoming RPC data blocks.


Monitors

HKLM\SYSTEM\CurrentControlSet\Control\Print\

Description

The Monitors subkey stores entries for print monitors installed on Windows 2000. The Monitors subkey contains a subkey for each port monitor that stores configuration data for the port monitor installed on the system.

Related Entries

Monitors subkey for LanMan Print Services network printers


<Monitor>

HKLM\SYSTEM\CurrentControlSet\Control\Print\Monitors\

Description

The <Monitor> subkey contains information about the status and drivers of the monitors used by the computer.

Note Image Note

The <Monitor> subkey is a variable representing the subkeys under the Monitors subkey. It does not actually appear in the registry. This variable subkey displays information which is common to the subkeys in the Monitors subkey.


Driver

HKLM\SYSTEM\CurrentControlSet\Control\Print\Monitors\<Monitor>

Data type | Range | Default value
REG_SZ | DLL filename | (Depends on monitor.)

Description

Stores the name of the dynamic-link library (DLL) of the driver for the provider network port. These DLLs are stored in Systemroot\WINNT\system32.

Monitor | DLL file
AppleTalk Printing Devices | sfmmon.dll
BJ Language Monitor | cnbjmon.dll
Hewlett-Packard Network Port | hpmon.dll
Local Port | localspl.dll
LPR Port | lprmon.dll
PJL Language Monitor | pjlmon.dll
Standard TCP/IP Port | tcpmon.dll
USB Monitor | USBMON.dll

Related Entries

Driver in the <printer-name> subkey

Driver in the <processor-name> subkey

Driver in the LanMan Print Services Port subkey


EOJTimeout

HKLM\SYSTEM\CurrentControlSet\Control\Print\Monitors\<Monitor>

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF milliseconds | 60000 milliseconds

Description

This entry is added to the registry by the port or language monitor, and its value and meaning vary for different monitors. For most monitors, this entry determines how long a print job remains in the print queue after it has been spooled to the printer. For other monitors, this entry determines how long after a printer has stopped spooling data that the print monitor notifies the printer that the job is complete.


Ports

HKLM\SYSTEM\CurrentControlSet\Control\Print\Monitors\<Monitor>\

Description

The Ports subkey contains information about the current availability of the ports.


FailureTimeout

HKLM\SYSTEM\CurrentControlSet\Control\Print\Monitors\<Monitor>\Ports

Data type | Range | Default value
REG_DWORD | number of seconds | 15

Description

Specifies the length of time that the system will wait for a response from the printer. If the printer does not respond before this time elapses, the system will cancel the print job.


StatusUpdateEnabled

HKLM\SYSTEM\CurrentControlSet\Control\Print\Monitors\<Monitor>\Ports

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether the port monitor is able to update the spooler with the port status.

Value | Meaning
0 | Disabled. The monitor is able to update the spooler with the port status.
1 | Enabled. The monitor is not able to update the spooler with the port status.

Tip Image Tip

For pooled printers, set StatusUpdateEnabled to 1 and StatusUpdateInterval to a minumum value to allow the spooler to send print jobs to an alternate printer when one printer in the pool is offline.

Related Entries

RestartJobOnPoolEnabled

RestartJobOnPoolError

StatusUpdateInterval


StatusUpdateInterval

HKLM\SYSTEM\CurrentControlSet\Control\Print\Monitors\<Monitor>\Ports

Data type | Range | Default value
REG_DWORD | number of seconds | 0x0000000a (10 seconds)

Description

Specifies how often the port monitor updates the spooler with port status.

Tip Image Tip

For pooled printers, setting StatusUpdateEnabled to 1 and StatusUpdateInterval to a minumum value will allow the spooler to send print jobs to an alternate printer when one printer in the pool is offline.

Related Entries

RestartJobOnPoolEnabled

RestartJobOnPoolError

StatusUpdateEnabled


NetPrinterDecayPeriod

HKLM\SYSTEM\CurrentControlSet\Control\Print

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF milliseconds | 0x36EE80 (3,600,000 milliseconds = 1 hour)

Description

Determines how long a network printer remains in the browse list.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


PendingUpgrades

HKLM\SYSTEM\CurrentControlSet\Control\Print\

Description

This subkey is used by Windows 2000 during setup. Do not change the values in this subkey.


PortThreadPriority

HKLM\SYSTEM\CurrentControlSet\Control\Print

Data type | Range | Default value
REG_DWORD | -1 | 0 | 1 | | 0

Description

Establishes the priority at which port threads run on the processor. Port threads send output to the printers. The priority of a thread determines the order in which it is scheduled to run on the processor.

Value | Meaning
-1 or 0xFFFFFFFF | below normal
0 | normal
1 | above normal


Printers

HKLM\SYSTEM\CurrentControlSet\Control\Print\

Description

The Printers subkey in the Print subkey contains information about the local printers.

Note Image Note

The printers listed in this subkey can be shared, or they can only be accessible to the host computer.

The entries in this subkey are linked to the Print\Printers entries that appear in the SOFTWARE key. Changes made in the SOFTWARE key will be reflected in this subkey.

Related Entries

Printers subkey in HKEY_CURRENT_USER

Printers subkey for local printers in SOFTWARE

Printers subkey for LanMan Print Services network printers


<printer-name>

HKLM\SYSTEM\CurrentControlSet\Control\Print\Printers\

Description

The <printer-name> subkey is a variable representing the subkeys under the Printers subkey. It does not actually appear in the registry. This variable subkey displays information which is common to the subkeys in the Printers subkey.

The <printer-name> subkey in the Print\Printers subkey stores information about local printers.

The entries which appear in this subkey are backup copies, and they are linked to the entries in the Printers SOFTWARE subkey.

Note Image Note

This subkey appears only on servers which have local printers. It does not appear on computers that only connect to network printers.

Related Entries

<printer-name> subkey for LanMan Print Services Printers

<printer-name> subkey in the SOFTWARE key


Default Priority

HKLM\SYSTEM\CurrentControlSet\Control\Print\Printers\<printer-name>

Data type | Range | Default value
REG_DWORD | -1 | 0 | 1 | 0

Description

Describes the printing priority for local printers.

Value | Meaning
-1 | Low
0 | Normal
1 | High

Related Entries

DefaultPriority in the Providers subkey (network printers)


Description

HKLM\SYSTEM\CurrentControlSet\Control\Print\Printers\<printer-name>

Data type | Range | Default value
REG_SZ | String | There is no default value for this entry.

Description

Stores the information which appears in the Comment box of the Printers properties box for local printers.

Change method

To change the value of this entry, click Start, point to Settings, and then select Printers. Right-click the printer name, and then select Properties. Click the General tab, and then enter any text in the Comment text box.

Related Entries

Description for LanMan Print Services network printers


Location

HKLM\SYSTEM\CurrentControlSet\Control\Print\Printers\<printer-name>

Data type | Range | Default value
REG_SZ | String | There is no default value for this entry.

Description

Describes the physical location of a local printer. This corresponds with the Location box in the printers properties box.

Change method

To change the value of this entry, click Start, point to Settings, and then select Printers. Right-click the printer name, and then select Properties. Click the General tab, and then enter any text in the Location text box.

Related Entries

Location for LanMan Print Services network printers


Name

HKLM\SYSTEM\CurrentControlSet\Control\Print\Printers\<printer-name>

Data type | Range | Default value
REG_SZ | string | (There is no default value for this printer.)

Description

Contains the network name of the specified local printer.

Change method

To change the value of this entry, click Start, point to Settings, and then select Printers. Right-click the printer name, and then select Properties. Click the General tab, and then enter the printer name in the text box next to the printer icon.

Related Entries

Name for Internet Print Provider network printers

Name for LanMan Print Services netwrok printers

Name for NetWare or compatible network printers


Print Processor

HKLM\SYSTEM\CurrentControlSet\Control\Print\Printers\<printer-name>

Data type | Range | Default value
REG_SZ | processor name | (Depends on printer.)

Description

Contains the name of the print processor for the specified local printer.

Change method

To change the value of this entry, click Start, point to Settings, and select Printers. Right-click the printer name and select Properties. Click the Advanced tab, click the Print Processor button, and select a print processor from the list.

Related Entries

PrintProcessor for LanMan Print Services network printers


Printer Driver

HKLM\SYSTEM\CurrentControlSet\Control\Print\Printers\<printer-name>

Data type | Range | Default value
REG_SZ | driver name | (Depends on printer.)

Description

Contains the name of the printer driver for the specified local printer.

Change method

To change the value of this entry, click Start, point to Settings, and then select Printers. Right-click the printer name, and then select Properties. Click the Advanced tab, and then either select a driver from the Driver drop-down list or click the New Driver button to install a new driver using the Add Printer Driver Wizard.

Related Entries

Printer Driver for LanMan Print Services network printers


Priority

HKLM\SYSTEM\CurrentControlSet\Control\Print\Printers\<printer-name>

Data type | Range | Default value
REG_DWORD | 1 - 99 | 1

Description

Indicates priority of the specified local printer.

A higher value indicates higher priority. If two printers are sending jobs to the same port, the printer with the higher priority will print first.

Change method

To change the value of this entry, click Start, point to Settings, and then select Printers. Right-click the printer name, and then select Properties. Click the Advanced tab, and then select a value from the Priority spin box.

Note Image Note

To set the print priority for a specific document, click Start, point to Settings, and then select Printers. Double-click the printer name, and then select the document whose priority you want to change. From the Document menu, select Properties, and then click the General tab. Use the Priority slider to set the priority.

Related Entries

Priority for LanMan Print Services network printers


Separator File

HKLM\SYSTEM\CurrentControlSet\Control\Print\Printers\<printer-name>

Data type | Range | Default value
REG_SZ | path and filename | There is no default value for this entry.

Description

Contains that path and file name for the separator page for the specified local printer.

Change method

To change the value of this entry, click Start, point to Settings, and then select Printers. Right-click the printer name, and then select Properties. Click the Advanced tab, click the Separator Page button, and then enter a path and file name or select the file from the browse list.

Related Entries

Separator File for LanMan Print Services network printers


Share Name

HKLM\SYSTEM\CurrentControlSet\Control\Print\Printers\<printer-name>

Data type | Range | Default value
REG_SZ | share name | share name

Description

Contains the name of the specified local printer as it appears on the printer server.

Change method

To change the value of this entry, click Start, point to Settings, and then select Printers. Right-click the printer name, and then select Properties. Click the Sharing tab, click the Shared as radio button, and enter the share name in the text box.

Related Entries

Share Name for LanMan Print Services network printers


StartTime

HKLM\SYSTEM\CurrentControlSet\Control\Print\Printers\<printer-name>

Data type | Range | Default value
REG_DWORD | 0x0 - 0x59F (almost 24 hours) minutes since 4:00 P.M. | 0x0

Description

Stores the availability start time of the specified local printer.

Change method

To change the value of this entry, click Start, point to Settings, and then select Printers. Right-click the printer name and select Properties. Click the Advanced tab, click the Available from radio button, and then select a time from the spin box.

Related Entries

StartTime for LanMan Print Services network printers


UntilTime

HKLM\SYSTEM\CurrentControlSet\Control\Print\Printers\<printer-name>

Data type | Range | Default value
REG_DWORD | 0x0 - 0x59F (almost 24 hours) minutes since 4:00 P.M. | 0x0

Description

Stores the availability end time of the specified local printer.

Change method

To change the value of this entry, click Start, point to Settings, and then select Printers. Right-click the printer name, and then select Properties. Click the Advanced tab, click the Available from radio button, and then select a time from the Tospin box.

Related Entries

UntilTime for LanMan Print Services network printers


DefaultSpoolDirectory

HKLM\SYSTEM\CurrentControlSet\Control\Print\Printers

Data type | Range | Default value
REG_SZ | path | Systemroot\WINNT\System32\spool\PRINTERS

Description

Specifies the folder which holds spooled files that are being printed by this system on a local printer.

The system reads the value of DefaultSpoolDirectory in the SOFTWARE subkey. The value of DefaultSpoolDirectory in the SYSTEM subkey is a backup copy. Therefore, changes made to the value of this entry in the SYSTEM subkey will have no effect.

Change method

To change the value of this entry, click Start, point to Settings, and then select Printers. Right-click the printer name, and then select Properties. Click the Advanced tab, and then type a path in the Spool folder text box.

To change the value of this entry for a network printer, connect to the printer server and double-click the printer. From the File menu, select Server Properties. Click the Advanced tab and type a path in the Spool folder text box.

Related Entries

DefaultSpoolDirectory for LanMan Print Services network printers

DefaultSpoolDirectory in the SOFTWARE subkey


PriorityClass

HKLM\SYSTEM\CurrentControlSet\Control\Print

Description

This entry is not used by and has no effect on Windows 2000.


Providers

HKLM\SYSTEM\CurrentControlSet\Control\Print\

Description

The Providers subkey contains information about the network printers. The printers listed in this subkey are not hosted locally, but are printers to which the local computer is connected.

Note Image Note

Providers entries for LanMan Print Services are stored in the Providers subkey in the SOFTWARE key. This is a change from Windows NT 4.0 and earlier.

Related Entries

Providers subkey in the SOFTWARE key

Providers subkey in the <server-name> subkey


EventLog

HKLM\SYSTEM\CurrentControlSet\Control\Print\Providers

Data type | Range | Default value
REG_DWORD | 0x0 - 0x1F (bitmask) | Windows 2000 Professional: 0x1B (11011) Windows 2000 Server: 0x1F (11111)

Description

Specifies the level of detail of events logged by the print spooler for local print jobs.

The value of this entry is a bitmask. To direct the print spooler to log entries of the type specified, set the bit representing that type to 1 or sum the hexadecimal values of all desired types. For example, the default value for Windows 2000 Server, 11111, indicates that the print spooler logs all events. The default value for Windows 2000 Professional, 11011 indicates that the print spooler logs all events except information.

Value | Event type
0x0 (0 binary) | Success
0x1 (1 binary) | Error
0x2 (10 binary) | Warning
0x4 (100 binary) | Information
0x8 (1000 binary) | Audit success
0x10 (10000 binary) | Audit failure

Change method

To change the value of this entry, click Start, click Settings, and then click Printers. From the File menu, click Server Properties, click the Advanced tab, and then select or clear the check boxes representing each event type.

Related Entries

EventLog for LanMan Print Services network printers


Internet Print Provider

HKLM\SYSTEM\CurrentControlSet\Control\Print\Providers\

Description

The Internet Print Provider subkey stores information about the Internet Print Provider.


DisplayName

HKLM\SYSTEM\CurrentControlSet\Control\Print\Providers\Internet Print Provider

Data type | Range | Default value
REG_SZ | provider name | HTTP Print Services

Description

Specifies the localized name of the print service provider displayed in the Print Manager and Printers main window.

Related Entries

DisplayName in the LanMan Print Services subkey

DisplayName in the NetWare or Compatible Network subkey


Name

HKLM\SYSTEM\CurrentControlSet\Control\Print\Providers\Internet Print Provider

Data type | Range | Default value
REG_SZ | file name | inetpp.dll

Description

Specifies the dynamic-link library (DLL) for the Internet Print Provider.

This DLL is stored in Systemroot\WINNT\system32

Related Entries

Name for local printers

Name for LanMan Print Services netwrok printers

Name for NetWare or compatible network printers


LanMan Print Services

HKLM\SYSTEM\CurrentControlSet\Control\Print\Providers\

Description

The LanMan Print Services subkey stores configuration data for the LanMan Print Services, the default print provider for Windows 2000.


DisplayName

HKLM\SYSTEM\CurrentControlSet\Control\Print\Providers\LanMan Print Services

Data type | Range | Default value
REG_SZ | provider name | LanMan Print Services

Description

Specifies the localized name of the print service provider displayed in the Print Manager and Printers main window.

Related Entries

DisplayName in the Internet Print Providers subkey

DisplayName in the NetWare or Compatible Network subkey


Monitors

HKLM\SYSTEM\CurrentControlSet\Control\Print\Providers\LanMan Print Services\

Description

The Monitors subkey in the LanMan Print Services subkey stores information about the monitors used by the LanMan print service.

Related Entries

Monitors subkey for local printers


LanMan Print Services Port

HKLM\SYSTEM\CurrentControlSet\Control\Print\Providers\LanMan Print Services\Monitors\

Description

The LanMan Print Services Port subkey stores configuration data for the LanMan Print Services port monitor.


Driver

HKLM\SYSTEM\CurrentControlSet\Control\Print\Providers\LanMan Print Services\Monitors\LanMan Print Services Port

Data type | Range | Default value
REG_SZ | driver name | win32spl.dll

Description

Stores the name of the dynamic-link library (DLL) of the driver for the LanMan Print Services Port.

This file is stored in Systemroot\WINNT\system32.

Related Entries

Driver in the <printer-name> subkey

Driver in the <processor-name> subkey

Driver in the <Port Monitor> subkey


Name

HKLM\SYSTEM\CurrentControlSet\Control\Print\Providers\LanMan Print Services

Data type | Range | Default value
REG_SZ | file name | win32spl.dll

Description

Specifies the dynamic link library (DLL) for the LanMan Print Service provider.

This DLL is stored in Systemroot\WINNT\system32.

Related Entries

Name for local printers

Name for Internet Print Provider network printers

Name for NetWare or compatible network printers


Servers

HKLM\SYSTEM\CurrentControlSet\Control\Print\Providers\LanMan Print Services\

Description

The Servers subkey contains subkeys and entries that store configuration data for LanMan Print Services, the default provider for Windows 2000.

Related Entries

Servers subkey in the SOFTWARE key


AddPrinterDrivers

HKLM\SYSTEM\CurrentControlSet\Control\Print\Providers\LanMan Print Services\Servers

Data type | Range | Default value
REG_DWORD | 0 | 1 | Windows 2000 Professional: 0 Windows 2000 Server: 1

Description

Determines which users can add printer connections. Printer connections might require that a new driver be installed.

Value | Meaning
0 | All users are allowed to add printers drivers when they add connections.
1 | Only Administrators and Power Users are allowed to add connections which require new printer drivers.

Note Image Note

This entry does not affect whether or not a user can add a printer connection. It only restricts whether or not the user can install new drivers.


NetPopup

HKLM\SYSTEM\CurrentControlSet\Control\Print\Providers

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether users are notified when print jobs on remote printers are complete.

This entry applies to the computer and affects all and only those printers that are directly connected (local) to the computer. If you configure this entry on a computer with multiple printers, such as a print server, the value of this entry applies to all printers that reside on the server. It cannot be configured separately for any printer or any user.

Also, this entry applies only to remote printing. Users are not notified when local print jobs are complete.

Value | Meaning
0 | Users are not notified.
1 | A message appears on the user's display when remote print jobs that they have submitted are complete.

Change method

To change the value of this entry for a local printer, click Start, click Settings, and click Printers. From the File menu, click Server Properties, and then click the Advanced tab. This entry corresponds to the Notify when remote documents are printed option.

To change this value for a network printer, connect to the print server and click the Printers folder. From the File menu, click Server Properties, and then click the Advanced tab. This entry corresponds to the Notify when remote documents are printed option.

Note Image Note

This policy only affects printers connected directly to the computer. To set this policy for a network printer, you must be an administrator of the print server on which the printer resides.

Messages enabled by this entry are sent by using the Windows 2000 Messaging Service. If the Messaging Service is not running on the user's computer, users do not receive the message.

Tip Image Tip

To prevent a network printer from sending you a message, you can use Computer Management to stop the Windows 2000 Messaging Service. However, if you do, you do not receive any messages sent by using the Messaging Service.

Related Entries

NetPopup for LanMan Print Services network printers


NetPopupToComputer

HKLM\SYSTEM\CurrentControlSet\Control\Print\Providers

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Specifies if print notifications for local print jobs should be sent to the printer that printed the document or to the user.

Value | Meaning
0 | Popups are sent to the printer that printed the document.
1 | Popups are sent to the printer on the network that the user who printed the document first logged on to.

Change method

To change the value of this entry for a local printer, click Start, point to Settings, and then click Printers. From the File menu, click Server Properties, and then click the Advanced tab. This entry corresponds to the Notify computer, not user when remote documents are printed option.

To change the value of this entry for a network printer, connect to the printer server and double-click the printer. From the File menu, click Server Properties, and then click the Advanced tab. This entry corresponds to the Notify computer, not user when remote documents are printed option.

Related Entries

NetPopupToComputer for LanMan Print Services network printers


NetWare or Compatible Network

HKLM\SYSTEM\CurrentControlSet\Control\Print\Providers\

Description

Stores options for printing when using print resources on NetWare servers.

This subkey is used when you connect a Windows 2000 Professional system to a server running NetWare server software.

Note Image Note

This subkey is added to the registry when you install Client Service for NetWare or Gateway Services for NetWare.

Related Entries

PrintOption


DisplayName

HKLM\SYSTEM\CurrentControlSet\Control\Print\Providers\NetWare or Compatible Network

Data type | Range | Default value
REG_SZ | provider name | NetWare or Compatible Network

Description

Specifies the localized name of the print service provider displayed in the Print Manager and Printers main window.

Related Entries

DisplayName in the Internet Print Providers subkey

DisplayName in the LanMan Print Services subkey


Name

HKLM\SYSTEM\CurrentControlSet\Control\Print\Providers\NetWare or Compatible Network

Data type | Range | Default value
REG_SZ | file name | nwprovau.dll

Description

Specifies the dynamic-link library (DLL) for the \NetWare or Compatible Print Service provider.

This DLL is stored in Systemroot\WINNT\system32.

Related Entries

Name for local printers

Name for Internet Print Provider network printers

Name for LanMan Print Services netwrok printers


Timeout

HKLM\SYSTEM\CurrentControlSet\Control\Print\Providers\NetWare or Compatible Network

Data type | Range | Default value
REG_DWORD | 0x2710 - 0xFFFFFFFE milliseconds | 0xFFFFFFFF | 0xEA60 (1 minute)

Description

Determines how often Windows 2000 updates the print queue of a NetWare server. The value of this entry specifies the time interval between automatic refresh updates.

Value | Meaning
0x2710 - 0xFFFFFFFE milliseconds | Specifies the time between updates of the NetWare print queue.
0xFFFFFFFF | Disables automatic updates. Windows 2000 sends new print jobs to the NetWare server, but it does not update the queue list.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


Order

HKLM\SYSTEM\CurrentControlSet\Control\Print\Providers

Data type | Range | Default value
REG_MULTI_SZ | Print providers | LanMan Print Services Internet Print Provider

Description

Specifies the order in which print providers are used.

The local spooler is queried first, but if it is busy or not operating, remote print providers are queried in the order specified by the value of this entry.

Tip Image Tip

Consider changing this value if one print provider is known to be more reliable or available more frequently than others. Specifying a successful print provider can prevent print jobs from timing out.


RestartJobOnPoolEnabled

HKLM\SYSTEM\CurrentControlSet\Control\Print\Providers

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether a print job to a local printer can be restarted after an error.

If the value of this entry is set to 1, a Cancel/Retry dialog box will appear on the user's system for the value of RestartJobOnPoolError.

Value | Meaning
0 | Print jobs can not be restarted on error.
1 | Print jobs can be restarted on error.

Note Image Note

This entry applies only to pooled printers.

Related Entries

RestartJobOnPoolEnabled for LanMan Print Services network printers

RestartJobOnPoolError


RestartJobOnPoolError

HKLM\SYSTEM\CurrentControlSet\Control\Print\Providers

Data type | Range | Default value
REG_DWORD | number of seconds | 0x00000258 (600 seconds = 10 minutes)

Description

Determines how long the print monitor waits before starting a print job on another port in the print pool if an error occurs.

Note Image Note

This entry applies only to pooled printers.

Both the print monitor and the printer must support SNMP.

Related Entries

RestartJobOnPoolError for LanMan Print Services network printers

StatusUpdateEnabled

StatusUpdateInterval


RetryPopup

HKLM\SYSTEM\CurrentControlSet\Control\Print\Providers

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether Retry/Cancel popups appear on error on jobs printed to a local printer.

Value | Meaning
0 | Popups do not appear.
1 | Popups appear on the print server.

Related Entries

RetryPopup for LanMan Print Services network printers


RouterCacheSize

HKLM\SYSTEM\CurrentControlSet\Control\Print\Providers

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF | 16

Description

Specifies the maximum number of print provider names that can be stored in the printer name cache.

The spooler stores the names of print providers in the printer name cache and uses this cache to locate the appropriate print provider. This prevents the spooler from needing to search through all print providers installed on the system.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


RefreshTimesPerDecayPeriod

HKLM\SYSTEM\CurrentControlSet\Control\Print

Data type | Range | Default value
REG_DWORD | times per hour | 2

Description

Specifies the number of times per decay period that the browse masters and backup servers are notified of a server's presence on the network. The decay period is determined by the value of NetPrinterDecayPeriod.

If a value is specified for both RefreshTimesPerDecayPeriod and ServerThreadTimeout, the server will use whichever value is greater.

Note Image Note

When the value of this entry is 0, the system uses the default value.

Related Entries

NetPrinterDecayPeriod

ServerThreadTimeout


RouterCacheSize

HKLM\SYSTEM\CurrentControlSet\Control\Print

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF | 16

Description

Specifies the maximum number of print provider names that can be stored in the printer name cache.

The spooler stores the names of print providers in the printer name cache and uses this cache to locate the appropriate print provider. This prevents the spooler from needing to search through all print providers installed on the system.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


SchedulerThreadPriority

HKLM\SYSTEM\CurrentControlSet\Control\Print

Data type | Range | Default value
REG_DWORD | 0x0 | 0x1 | 0xFFFFFFFF | 0x0

Description

Determines the priority of the scheduler thread. The scheduler thread assigns jobs to ports. The priority of a thread determines the order in which it is scheduled to run on the processor.

Value | Meaning
0x0 | Normal
0x1 | Above normal
0xFFFFFFFF | Below normal


ServerThreadTimeout

HKLM\SYSTEM\CurrentControlSet\Control\Print

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF milliseconds | 0x927C0 (600,000 milliseconds = 10 minutes)

Description

Specifies the amount of time that the server thread is idle before it notifies other print servers of its printers.

This entry allows the name of the print server to appear in the Add Printer Wizard. If the value of this entry is greater than the value of NetPrinterDecayPeriod, the printer will not appear in the printer list.

Related Entries

NetPrinterDecayPeriod


SpoolerPriority

HKLM\SYSTEM\CurrentControlSet\Control\Print

Data type | Range | Default value
REG_DWORD | 0x20 | 0x40 | 0x80 | 0x20

Description

Determines the priority class of the print spooler process.

The priority of the print spooler process establishes a range of priority for print spooler threads.

Value | Meaning
0x20 | Normal priority.
0x40 | Idle.
0x80 | High priority.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


PriorityControl

HKLM\SYSTEM\CurrentControlSet\Control\

Description

The entries in the PriorityControl subkey determine the relative priority of foreground (active) applications to background (inactive) applications.


Win32PrioritySeparation

HKLM\SYSTEM\CurrentControlSet\Control\PriorityControl

Data type | Range | Default value
REG_DWORD | 0x0 - 0x3F (111111 binary) | 0x2 (000010 binary)

Description

Specifies the strategy used for optimizing processor time on this system. The value of this entry determines, in part, how much processor time the threads of a process receive each time they are scheduled, and how much the allotted time can vary. It also affects the relative priority of the threads of foreground and background processes.

The value of this entry is a 6-bit bitmask comprised of three sets of two bits (AABBCC). Each two-bit set determines a different characteristic of the optimizing strategy.

  • The highest two bits (AABBCC) determine whether each processor interval is relatively long or short.
  • The middle two bits (AABBCC) determine whether the length of the interval varies or is fixed.
  • The lowest two bits (AABBCC) determine whether the threads of foreground processes get more processor time than the threads of background processes each time they run.

The values of the bits are as follows:

The highest two bits (AABBCC) determine how long the threads of processes are permitted to run each time they are scheduled. This interval is specified as a range because threads can be preempted and processor time is not precisely determined.

Values of the highest two bits:

Value | Meaning
00 or 11 | Shorter intervals (Windows 2000 Professional), Longer intervals (Windows 2000 Server
01 | Longer intervals
10 | Shorter intervals

The middle two bits (AABBCC) determine whether the length of processor time is fixed (always the same length) or varies. It also determines whether the threads of foreground processes have longer processor intervals than those of background processes. If the processor interval is fixed, that interval applies equally to the threads of foreground and background processes. If the processor interval varies, the length of time each thread runs varies, but the ratio of processor time of foreground threads to background threads is fixed.

If a variable interval is specified, the ratio of foreground thread processor time to background thread processor time is determined by the value of the lowest set of bits.

Values of the middle two bits:

Value | Meaning
00 or 11 | Variable-length intervals (Windows 2000 Professional), Fixed-length intervals (Windows 2000 Server)
01 | Variable-length intervals
10 | Fixed-length intervals

The lowest two bits (AABBCC) determine the ratio of processor time of foreground to background threads. This value is used only when the middle two bits in this mask specify a variable-length interval. Otherwise, the processor interval for foreground and background threads is the same.

Values of the lowest two bits:

Value | Meaning
00 | Equal and fixed. The threads of foreground processes get the same amount of processor time as the threads of background processes and as the threads of processes with a priority class of Idle. Also, the processor interval is fixed. This value overrides the specification of a variable-length interval in the middle two bits.
01 | 2 : 1. The threads of foreground processes twice as much processor time than the threads of background processes each time they are scheduled for the processor.
10 or 11 | 3 : 1. The threads of foreground processes three times as much processor time than the threads of background processes each time they are scheduled for the processor.

Please note that the same value is interpreted differently on a computer running Windows 2000 Professional than on one running Windows 2000 Server.

For example, on a computer running Windows 2000 Professional, the default value, 2 (000010) specifies shorter, variable intervals, in which foreground threads get three times as much processor time as background threads.

On a computer running Windows 2000 Server, the default value, 2 (000010) specifies longer, fixed intervals, in which foreground and background threads get the same amount of processor time each time they run.

These strategies optimize foreground processes on a workstation and accommodate the needs of processor-intensive services on a server.

Change method

To change the value of this entry, in Control Panel, double-click System, click the Advanced tab, click Performance Options and then, in the Application response section, click Applications or Background services.

Clicking Applications sets the value of this entry to 100110, and provides for short, variable length processor intervals in which foreground processes get three times as much processor time as do background processes.

Clicking Background services sets the value of this entry to 011000, and provides for longer, fixed-length processor intervals in which foreground processes and background processes get equal processor priority.

Tip Image Tip

The meaning and use of this entry have changed for Windows NT 3.51, Windows NT 4.0, and Windows 2000. For information about this entry in Windows NT 4.0 and earlier, consult the Windows NT Resource Kit 4.0.


ProductOptions

HKLM\SYSTEM\CurrentControlSet\Control\

Description

Stores information about the variations of Windows 2000 running on the computer.

Caution Image Caution

Do not delete this subkey or change its contents. This subkey stores protected operating system data. Editing this data violates your Windows 2000 licensing agreement and disqualifies you from receiving Microsoft Product Support Services service. If programs try to change the data, the system stops abnormally and displays a blue screen.


ProductSuite

HKLM\SYSTEM\CurrentControlSet\Control\ProductOptions

Data type | Range | Default value
REG_MULTI_SZ | Platform suite or blank | There is no default value for this entry.

Description

Stores data that identifies a special operating system variation running on the computer. This entry lets programs identify and customize their features to the platform.

Tip Image Tip

To view this data, programs can use the GetVersionEx and VerifyVersionInfo application programming interfaces.

Caution Image Caution

Do not delete this entry or change its value. This entry stores protected operating system data. Editing this data violates your Windows 2000 licensing agreement and disqualifies you from receiving Microsoft Product Support Services service. If programs try to change the data, the system stops abnormally and displays a Stop error screen.


ProductType

HKLM\SYSTEM\CurrentControlSet\Control\ProductOptions

Data type | Range | Default value
REG_SZ | Platform identifier | Windows 2000 Professional: WinNT Windows 2000 Server: ServerNT or LanmanNT

Description

Stores data that identifies the operating system platform running on the computer. This data lets programs identify and customize their features to the platform.

In Windows 2000, the following entries identify the platform options.

Value | Meaning
WinNT | Windows 2000 Professional
ServerNT | Windows 2000 Server
LanmanNT | Windows 2000 Server

Tip Image Tip

To view this data, programs can use the GetVersionEx and VerifyVersionInfo application programming interfaces.

Caution Image Caution

Do not delete this entry or change its value. This entry stores protected operating system data. Editing this data violates your Windows 2000 licensing agreement and disqualifies you from receiving Microsoft Product Support Services service. If programs try to change the data, the system stops abnormally and displays a blue screen.


RegistrySizeLimit

HKLM\SYSTEM\CurrentControlSet\Control

Data type | Range | Default value
REG_DWORD | 0x0 | 0x1000000 (16 MB) - 80% paged pool (in bytes) | 0x0

Description

Establishes the maximum amount of memory and disk space that can be consumed by the registry.

Registry size is limited to prevent the registry from consuming space needed by processes. The value of RegistrySizeLimit applies to space in the paged pool, to disk space for the paging file and files where registry data is stored, and to space used by some of the registry's run-time structures. Other registry run-time structures are governed by their own size limits or by other means.

RegistrySizeLimit only establishes a maximum size for the registry. Unlike other limits, it does not allocate or reserve space for the registry.

By default, RegistrySizeLimit is based upon the size of the paged pool, as follows:

  • If the value of this entry is 0x0, or if this entry does not appear in the registry, the system adjusts the value of RegistrySizeLimit dynamically based upon the size of the paged pool.
  • If the values of both RegistrySizeLimit and PagedPoolSize are 0x0, the system calculates an optimal value for both entries. Typically, the system sets the value of PagedPoolSize approximately equal to the amount of physical memory on the computer, and sets the value of RegistrySizeLimit to approximately 33 percent of the value of PagedPoolSize.
  • If the value of this entry is greater than 16 MB (0x1000000) and less or equal to than 80 percent of the paged pool size, the value will be used as the registry size limit. The system will not calculate an optimal size limit or adjust the size limit when the amount of memory or the size of the paged pool changes.
  • If the value of this entry is greater than 80 percent of the size of the paged pool, the system sets the value of RegistrySizeLimit equal to 80 percent of the size of the paged pool.

Change method

To add or change the value of this entry, in Control Panel double-click System. Click the Advanced tab, click Performance Options, click the Change button, and then enter a value in the Maximum Registry Size box.

Activation method

You must restart the computer before a change to this value takes effect.

Note Image Note

To ensure that a user can always start the system and edit the registry, the size of the registry is not subject to the maximum set in RegistrySizeLimit until after the first successful loading of a user profile.

Windows 2000 does not add this entry to the registry unless you use System in Control Panel to change the default value.

Tip Image Tip

If the system notifies you that your registry is too small, use System in Control Panel to change this value. Typically, increasing the registry size limit by 1 MB is sufficient.

For more information on paged pools and nonpaged pools, see the Microsoft Knowledge Base link on the Web Resources page. Search the Knowledge Base for Article Q126402, or use the keywords PagedPoolSize and NonPagedPoolSize.

Related Entries

PagedPoolSize


SafeBoot

HKLM\SYSTEM\CurrentControlSet\Control\

Description

The entries in the SafeBoot subkey contain information about the safe mode settings of the computer. In safe mode, Windows 2000 uses default settings (VGA monitor, no network, Microsoft mouse driver, and the minimum device drivers required to start Windows).

For example, if your computer does not start after you install new software, you might be able to start it in safe mode with minimal services and then change your computer settings or remove the newly installed software that is causing the problem.

Change method

To start Windows 2000 in safe mode, restart the computer and press F8 when you see the message Please select the operating system to start.

Caution Image Caution

Changing the values of these entries can prevent Windows 2000 from starting.


AlternateShell

HKLM\SYSTEM\CurrentControlSet\Control\SafeBoot

Data type | Range | Default value
REG_SZ | Program name | cmd.exe

Description

Lists the name of the alternative environment used when the Safe mode with Command Prompt option is selected.

Change method

To start Windows 2000 in safe mode, restart the computer and then press F8 when you see the message Please select the operating system to start.

Note Image Note

See Help in Windows 2000 for information about starting your computer in safe mode.

Caution Image Caution

Changing the value of this entry can prevent Windows 2000 from starting.


Minimal

HKLM\SYSTEM\CurrentControlSet\Control\SafeBoot\

Description

The Minimal subkey stores the names of basic files and drivers (mouse, keyboard, Mass Storage, base video and default system services) used when Safe Mode is selected.

Change method

To start Windows 2000 in safe mode, restart the computer and then press F8 when you see the message Please select the operating system to start.

Note Image Note

See Help in Windows 2000 for information about starting your computer in safe mode.

Caution Image Caution

Changing the value of this entry can prevent Windows 2000 from starting.


<file-name or driver-name>

HKLM\SYSTEM\CurrentControlSet\Control\SafeBoot\Minimal\

Data type | Range | Default value
REG_SZ | File name or driver name | File name or driver name

Description

Store the names of basic files and drivers (mouse, keyboard, Mass Storage, base video and default system services) used when Safe Mode is selected.

Change method

To start Windows 2000 in safe mode, restart the computer and then press F8 when you see the message Please select the operating system to start.

Note Image Note

See Help in Windows 2000 for information about starting your computer in safe mode.

The <file_name or driver_name> subkey is a variable representing the subkeys under the HKLM\SYSTEM\CurrentControlSet\Control\SafeBoot\Minimal subkey. It does not actually appear in the registry. This variable entry displays information which is common to the entries in the Minimal subkey.

Caution Image Caution

Changing the value of this entry can prevent Windows 2000 from starting.


Network

HKLM\SYSTEM\CurrentControlSet\Control\SafeBoot\

Description

The Network subkey stores the names of basic files, drivers, and network connections (mouse, keyboard, Mass Storage, base video and default system services) used when Safe Mode with Networking is selected.

Change method

To start Windows 2000 in safe mode, restart the computer and then press F8 when you see the message Please select the operating system to start.

Note Image Note

See Help in Windows 2000 for information about starting your computer in safe mode.

Caution Image Caution

Changing the value of this entry can prevent Windows 2000 from starting.


<file-name or driver-name>

HKLM\SYSTEM\CurrentControlSet\Control\SafeBoot\Network\

Data type | Range | Default value
REG_SZ | File name or driver name | File name or driver name

Description

Store the names of basic files and drivers (mouse, keyboard, Mass Storage, base video and default system services) used when Safe Mode is selected.

Change method

To start Windows 2000 in safe mode, restart the computer and then press F8 when you see the message Please select the operating system to start.

Note Image Note

See Help in Windows 2000 for information about starting your computer in safe mode.

The <file_name or driver_name> subkey is a variable representing the subkeys under the HKLM\SYSTEM\CurrentControlSet\Control\SafeBoot\Network subkey. It does not actually appear in the registry. This variable entry displays information which is common to the entries in the Network subkey.

Caution Image Caution

Changing the value of this entry can prevent Windows 2000 from starting.


SecurePipeServers

HKLM\SYSTEM\CurrentControlSet\Control\

Description

The SecurePipeServers subkey contains the winreg subkey which controls remote access to the registry. If these subkeys do not appear in the registry, remote access to the registry is determined by the permissions set in each registry subkey.

Change method

To view the permissions set for the SecurePipeServers subkey, use Regedt32.exe. On the Security menu, click Permissions.

Note Image Note

Remote registry security and the functions of the Secure Pipe Servers and winreg registry subkeys are included in Windows 2000 Server and Windows 2000 Professional. However, it is enabled by default only on Windows 2000 Server. You can add these subkeys to the registry of a computer running Windows 2000 Professional and it will operate as described.


winreg

HKLM\SYSTEM\CurrentControlSet\Control\SecurePipeServers\

Description

The permissions set for the winreg subkey determine who can remotely connect to a registry. If this subkey does not exist, all users can remotely connect to the registry.

To remotely connect to a registry, a user must have at least Read Access to the winreg subkey on the target computer.

After the user is connected, the type of access that the user has to various registry keys and subkeys is determined by the permissions which have been granted to that specific user. Administrators have Full Control permission to winreg, and Backup Operators have read-only access to winreg.

Change method

To view the permissions set for the winreg subkey, use Regedt32.exe. On the Security menu, click Permissions.

Note Image Note

Regedit.exe allows user access to all subtrees except HKEY_CURRENT_CONFIG and HKEY_CURRENT_USER.

By default, the winreg subkey exists on both workstations and servers. However, it is enabled by default only on Windows 2000 Server. You can add these subkeys to the registry of a computer running Windows 2000 Professional and it will operate as described.


AllowedPaths

HKLM\SYSTEM\CurrentControlSet\Control\SecurePipeServers\winreg\

Description

The AllowedPaths subkey of winreg contains a list of the registry paths that all users can access remotely regardless of whether or not they have been given permissions to the winreg subkey. AllowedPaths permits users to perform some system functions that require remote access to very specific registry keys , such as checking the status of a printer, without having to grant those users access to the winreg subkey.

Change method

To view the permissions set for the AllowedPaths subkey, use Regedt32.exe. On the Security menu, click Permissions.

Note Image Note

The paths specified in the AllowedPaths subkey can be accessed anonymously.


Machine

HKLM\SYSTEM\CurrentControlSet\Control\SecurePipeServers\winreg\AllowedPaths

Data type | Range | Default value
REG_MULTI_SZ | Registry paths | SYSTEM\CurrentControlSet\Control\ProductOptions SYSTEM\CurrentControlSet\Control\Print\Printers SYSTEM\CurrentControlSet\Services\Eventlog SOFTWARE\Microsoft\Windows NT\CurrentVersion

Description

Lists registry paths in the HKEY_LOCAL_MACHINE subtree that all remote users can access. Remote users can access the paths listed in this subkey, and all subkeys of those paths, even if they do not otherwise have permission to gain access to the registry remotely.

Note Image Note

The paths specified can be accessed anonymously.


ServiceGroupOrder

HKLM\SYSTEM\CurrentControlSet\Control\

Description

The ServiceGroupOrder subkey contains a list of all service groups in the order in which the groups are loaded.

Tip Image Tip

To determine which service group a service belongs to, find the value of its Group entry.

To find all services in a service group, use Regedit.exe. On the Edit menu, click Find, type the name of the service group, and select only the Data check box.

Related Entries

Group

GroupOrderList subkey


List

HKLM\SYSTEM\CurrentControlSet\Control\ServiceGroupOrder

Data type | Range | Default value
REG_MULTI_SZ | Service groups | (List of service groups)

Description

Specifies the order in which service groups are loaded into memory at startup.

Note Image Note

The default value of this entry was documented incorrectly in the Windows NT Resource Kit 4.0. The default value shown here is correct.


ServiceProvider

HKLM\SYSTEM\CurrentControlSet\Control\

Description

The ServiceProvider subkey stores information about the installed service providers.


Order

HKLM\SYSTEM\CurrentControlSet\Control\ServiceProvider\

Description

The Order subkey contains values used by the Windows Sockets Service Resolution and Registration (RNR) APIs.


ExcludedProviders

HKLM\SYSTEM\CurrentControlSet\Control\ServiceProvider\Order

Data type | Range | Default value
REG_SZ | Name space provider number[ Name space provider number…] | (Blank value)

Description

Specifies name space providers that are not used when performing name resolution.

To exclude a name space provider, enter the number (in decimal) from the following table that represents the name space provider you want to exclude. You can enter more than one value in this entry. Use a single space to separate the values.

Number | Name space provider
1 | NS_SAP
2 | NS_NDS
10 | NS_TCPIP_LOCAL
11 | NS_TCPIP_HOSTS
12 | NS_DNS
13 | NS_NETBT
14 | NS_WINS
20 | NS_NBP
30 | NS_MS
31 | NS_STDA
32 | NS_CAIRO
40 | NS_X500
41 | NS_NIS

Note Image Note

The list of name space providers is updated frequently. This table might not be complete. For current information, seach the Microsoft support Web site.


ProviderOrder

HKLM\SYSTEM\CurrentControlSet\Control\ServiceProvider\Order

Data type | Range | Default value
REG_MULTI_SZ | registry subkey[ registry subkey…] | (Varies with installed protocols.)

Description

Lists the registry subkeys of name space providers, in the order in which they are used. These subkeys are in the Services subkey.

For example, if the value of this entry is Tcpip, data about the TCP/IP name space provider is located in HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip.

To be a valid provider, the subkey listed must contain a ServiceProvider subkey that includes the Class and ProviderPath entries.

Note Image Note

Do not change the value of this entry. Changing this value might prevent the system from finding required data.


Session Manager

HKLM\SYSTEM\CurrentControlSet\Control\

Description

The Session Manager subkey contains data used by many different components of the Session Manager.


BootExecute

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager

Data type | Range | Default value
REG_BINARY | Command or executable program | autocheck autochk *

Description

Specifies the applications, services, and commands executed during startup.

For example, if Convert.exe has been used to convert the file system on a hard disk drive, you can add the following command to BootExecute to convert the file system when Windows 2000 is restarted:

BootExecute = autocheck autoconv \DosDevices\x: /FS:NTFS

Note Image Note

Do not delete the default value, autocheck autochk *, from the value of BootExecute. To prevent Autochk.exe from running or from running on specific volumes, use Chkntfs.exe.

Tip Image Tip

For more information on Autochk, Chkntfs, and Convert, see the Microsoft Knowledge Base link on the Web Resources page. Search the Knowledge Base using the keywords Autochk, Chkntfs, and Convert.


CriticalSectionTimeout

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager

Data type | Range | Default value
REG_DWORD | Seconds | 2592000 (2,592,00 seconds = 30 days)

Description

Determines how long critical section objects can be held by a thread. When this time expires, the system forces the thread to release the critical section, thus preventing critical section deadlocks.


DOS Devices

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\

Description

The DOS Devices subkey maps the device names used by applications to device names used by Windows 2000.


AUX

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\DOS Devices

Data type | Range | Default value
REG_SZ | Device name | \DosDevices\COM1

Description

Associates the AUX device name used by applications with the system's internal name for the serial port.


MAILSLOT

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\DOS Devices

Data type | Range | Default value
REG_SZ | Device name | \Device\MailSlot

Description

Associates the MAILSLOT device name used by applications with the system's internal name for the mailslot file system driver used to pass messages between servers.


NUL

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\DOS Devices

Data type | Range | Default value
REG_SZ | Device name | \Device\Null

Description

Associates the NUL device name used by applications with the system's internal name for a null driver. Some applications use null drivers to direct output to a destination where the user cannot see it.


PIPE

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\DOS Devices

Data type | Range | Default value
REG_SZ | Device name | \Device\NamedPipe

Description

Associates the PIPE device name used by applications to the system's internal name for the named pipe file system.


PRN

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\DOS Devices

Data type | Range | Default value
REG_SZ | Device name | \DosDevices\LPT1

Description

Associates the PRN device name used by applications with the system's internal name for the printer port.


UNC

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\DOS Devices

Data type | Range | Default value
REG_SZ | Device name | \Device\Mup

Description

Maps the Universal Naming Convention (UNC) device name used by applications to the system's internal name for the multiple UNC provider.


Environment

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\

Description

Stores the values of environment variables that the system creates. These variables are used by Winlogon and Windows Explorer in Windows 2000 and Windows NT 4.0, and by Program Manager in Windows NT 3.51 and earlier.

Change method

To change the values of entries in this subkey, use System in Control Panel. Click the Advanced tab and then click Environment Variables. These entries appear in the System variables section.

Caution Image Caution

The data type of entries in this subkey must be REG_EXPAND_SZ. If a user or application changes the data type, the system will not replace the variable with its intended value.

Use extreme care when changing these entries. If the operating system cannot find the files specified for a subsystem, you will not be able to run applications designed for other environments.

Related Entries

Environment subkey (HKCU)


ComSpec

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Environment

Data type | Range | Default value
REG_EXPAND_SZ | Filename | %SystemRoot%\system32\cmd.exe

Description

Stores the path and file name of the Windows 2000 command interpreter, Cmd.exe. The command interpreter is analogous to MS-DOS Command.com.

Change method

To change the value of this entry, use System in Control Panel. Click the Advanced tab and then click Environment Variables. This entry appears in the System variables section.

Caution Image Caution

The data type of this entry must be REG_EXPAND_SZ. If a user or application changes the data type, the system will not replace the variable with its intended value.


Cpu

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Environment

Data type | Range | Default value
REG_EXPAND_SZ | i386 | There is no default value for this entry.

Description

Stores the type of processor installed on the computer.


NUMBER_OF_PROCESSORS

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Environment

Data type | Range | Default value
REG_SZ | 1 - 4 (in decimal) | number

Description

Stores the number of processors installed on the computer.


Os2LibPath

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Environment

Data type | Range | Default value
REG_EXPAND_SZ | Filename | %SystemRoot%\system32\os2\dll;

Description

Stores the path to the Microsoft OS/2 version 1.x library.

Change method

To change the value of this entry, double-click System in Control Panel. Click the Advanced tab, and then click Environment Variables. This entry appears in the System variables section.

Caution Image Caution

The data type of this entry must be REG_EXPAND_SZ. If a user or an application changes the data type, the system will not replace the variable with its intended value.


Path

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Environment

Data type | Range | Default value
REG_EXPAND_SZ | Filename | %SystemRoot%\system32; %SystemRoot%

Description

Stores the path to system files.

Change method

To change the value of this entry, double-click System in Control Panel. Click the Advanced tab, and then click Environment Variables. This entry appears in the System variables section.

Caution Image Caution

The data type of this entry must be REG_EXPAND_SZ. If a user or an application changes the data type, the system will not replace the variable with its intended value.


PROCESSOR_ARCHITECTURE

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Environment

Data type | Range | Default value
REG_SZ | Processor type | x86

Description

Stores the type of the processors installed on the system.

For Windows 2000, the system always sets the value of this entry to x86. However, this entry remains in the system to anticipate future needs and to maintain compatibility with earlier systems.


PROCESSOR_LEVEL

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Environment

Data type | Range | Default value
REG_SZ | Model number | There is no default value for this entry.

Description

Stores the model number of the processor installed on the computer. Programs can use this entry to adjust their configuration for different systems.


TEMP

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Environment

Data type | Range | Default value
REG_EXPAND_SZ | Path | %SystemRoot%\Temp

Description

Stores the path to the TEMP temporary directory for the system.

Change method

To change the value of this entry, use System in Control Panel. Click the Advanced tab and then click Environment Variables. This entry appears in the System variables section.

Caution Image Caution

The data type of this entry must be REG_EXPAND_SZ. If a user or application changes the data type, the system will not replace the variable with its intended value.


TMP

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Environment

Data type | Range | Default value
REG_EXPAND_SZ | Path | %SystemRoot%\Temp

Description

Stores the path to the TMP temporary directory for the system.

Change method

To change the value of this entry, use System in Control Panel. Click the Advanced tab and then click Environment Variables. This entry appears in the System variables section.

Caution Image Caution

The data type of this entry must be REG_EXPAND_SZ. If a user or application changes the data type, the system will not replace the variable with its intended value.


windir

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Environment

Data type | Range | Default value
REG_EXPAND_SZ | Pathname | %SystemRoot%

Description

Stores the path to the executable file for Win16 on Win32 (WOW).

Caution Image Caution

The data type of this entry must be REG_EXPAND_SZ. If a user or application changes the data type, the system will not replace the variable with its intended value.


ExcludeFromKnownDlls

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager

Data type | Range | Default value
REG_MULTI_SZ | DLL filenames | DLL filenames

Description

Lists those DLLs which will be excluded from the list of KnownDLLs.


FileRenameOperations

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\

Description

The FileRenameOperations subkey stores the names of files to be deleted when the system is restarted.

The system adds this entry to the registry when a user or program tries to delete a file that is in use. The file names are stored in the value of this entry until the computer is restarted and then they are deleted.

Note Image Note

The files identified by this entry are deleted before the system creates its paging files. This sequence allows the system to delete paging files from previous startups.


<file-name>

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\FileRenameOperations

Data type | Range | Default value
REG_MULTI_SZ | File names | There is no default value for this entry.

Description

The <file-name> entry is a variable representing the entries under the FileRenameOperations subkey. It does not actually appear in the registry. This variable entry displays information which is common to the entries in the FileRenameOperations subkey.

The system adds this entry to the registry when a user or program tries to delete a file that is in use. The file name is stored in the value of this entry until the computer is restarted and then the file is deleted.

Note Image Note

The files identified by this entry are deleted before the system creates its paging files. This sequence allows the system to delete paging files from previous startups.


GlobalFlag

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager

Data type | Range | Default value
REG_DWORD | Bit-mask | 0

Description

The value of this entry consists of 8 bits, which are used as switches to enable and disable advanced internal system diagnostics and troubleshooting tests.


KnownDLLs

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\

Description

The KnownDLLs subkey defines the set of dynamic-link libraries (DLLs) that are searched during system startup.

In general these are system DLLs that are loaded from disk into a section of memory and then checked for integrity. These DLLs consume some resources, even if no application loads them.


<DLL-name>

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\KnownDLLs

Data type | Range | Default value
REG_SZ | DLL filenames | DLL filenames

Description

Represent dynamic link libraries (DLLs) for drivers.

All <DLL-name> entries have the following format:

DriverName REG_SZ DLL filename

For example,

advapi32 REG_SZ advapi32.dll

This entry indicates that the Advapi32 driver is associated with the dynamic-link library in Advapi32.dll

Note Image Note

The <DLL-name> entry is a variable representing the entries in the KnownDLLs subkey. It does not actually appear in the registry. This variable entry displays information which is common to the entries in the KnownDLLs subkey.


Memory Management

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\

Description

The Memory Management subkey stores configuration data for paging files.

Change method

To create a new paging file or to change the size of a paging file, double-click System in Control Panel, click the Advanced tab, click the Performance Options button, and then click the Change button in the Virtual memory box.

Note Image Note

For more information on memory management and paging files, see Help for Windows 2000.

Tip Image Tip

To create a new paging file or to change the size of a paging file, double-click System in Control Panel, click the Advanced tab, click the Performance Options button, and then click the Change button in the Virtual memory box.

Caution Image Caution

Do not change the size of the paging file by editing the registry. To create a new paging file or to change the size of a paging file, use Control Panel.


ClearPageFileAtShutdown

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Specifies whether inactive pages in the paging file are filled with zeros when the system stops. This is a Windows 2000 security feature which prevents the pages from being read by another process. The system cannot fill active pages with zeros because some are being used by the system or other remaining active processes.

Value | Meaning
0 | Inactive pages are not filled with zeros.
1 | Inactive pages are filled with zeros.

Caution Image Caution

Changing this value can degrade the performance of your computer.


DisablePagingExecutive

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Specifies whether user-mode and kernel-mode drivers and kernel-mode system code can be paged to disk when not in use.

Value | Meaning
0 | Drivers and the kernel must remain in physical memory.
1 | Drivers and the kernel can be paged to disk as needed.

Tip Image Tip

Leaving this value set to 0 is useful when debugging drivers because all of the code and data is always memory resident.


IoPageLockLimit

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

Data type | Range | Default value
REG_DWORD | 0x0 | 0x1 - 0xFFFFFFFF bytes | 0

Description

Specifies the maximum number of bytes that can be locked for I/O operations.

Value | Meaning
0x0 | The system sets the lock limit to 512 KB.
0x1 - 0xFFFFFFFF bytes | The value entered overrides the system default and is used as the I/O lock limit.

Note Image Note

The maximum lock limit is determined by the amount of physical memory on the computer. Do not set the lock limit above the following values:

Amount of physical memory | Maximum lock limit
Less than 64 MB | Physical memory minus 7 MB
64 MB - 500 MB | Physical memory minus 16 MB
512 MB and greater | Physical memory minus 64 MB


LargeSystemCache

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

Data type | Range | Default value
REG_DWORD | 0 | 1 | Windows 2000 Professional: 0 Windows 2000 Server: 1

Description

Determines whether the system maintains a standard size or a large size file system cache, and influences how often the system writes changed pages to disk.

Increasing the size of the file system cache generally improves server performance, but it reduces the physical memory space available to applications and services. Similarly, writing system data less frequently minimizes use of the disk subsystem, but the changed pages occupy memory that might otherwise be used by applications.

Value | Meaning
0 | Establishes a standard size file system cache of approximately 8 MB. The system allows changed pages to remain in physical memory until the number of available pages drops to approximately 1000. This setting is recommended for servers running applications that do their own memory caching, such as Microsoft SQL Server, and for applications that perform best with ample memory, such as Internet Information Services.
1 | Establishes a large system cache working set that can expand to physical memory, minus 4 MB, if needed. The system allows changed pages to remain in physical memory until the number of available pages drops to approximately 250. This setting is recommended for most computers running Windows 2000 Server on large networks.

Caution Image Caution

Setting this value to 1 can have an impact on the performance of any services that run on the server. A value of 1 should be used only if the server is used exclusively as a file server.


NonPagedPoolQuota

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

Data type | Range | Default value
REG_DWORD | 0 | 1-128 (megabytes) | 0

Description

Establishes the maximum space in the nonpaged pool that can be allocated by any process. Any attempt by a process to allocate more space in the nonpaged pool will fail.

Value | Meaning
0 | The system calculates an optimal value for this entry based on the amount of physical memory on the computer, and adjusts this value if the amount of memory changes. This value is optimal for most systems.
1–128 | Overrides the value calculated by the system and prevents the system from adjusting this value dynamically. This setting can degrade performance.

Caution Image Caution

Do not change the value of this entry. The system adjusts this value dynamically. Changing the value prevents the system from using its algorithms to calculate an optimal value for the system.

Related Entries

NonPagedPoolSize

PagedPoolQuota


NonPagedPoolSize

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

Data type | Range | Default value
REG_DWORD | 0 | Number of bytes | 0

Description

Specifies the size of the nonpaged pool.

Value | Meaning
0 | The system calculates an optimal value for this entry based on the amount of physical memory on the computer, and then adjusts this value if the amount of memory changes. This value is optimal for most systems.
Number of bytes | Creates a nonpaged pool of the specified size. This overrides the value calculated by the system and prevents the system from adjusting this value dynamically. This setting can degrade performance.

Activation method

You must restart the computer before a change to this value takes effect.

Tip Image Tip

For more information on paged pools and nonpaged pools, see the Microsoft Knowledge Base link on the Web Resources page. Search the Knowledge Base for Article Q126402, or use the keywords PagedPoolSize and NonPagedPoolSize.

Caution Image Caution

Changing this value can degrade the performance of your computer.

Related Entries

NonPagedPoolQuota

PagedPoolSize


PagedPoolQuota

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

Data type | Range | Default value
REG_DWORD | 0 | 1-128 (megabytes) | 0

Description

Establishes the maximum space in the paged pool that can be allocated by any process. Any attempt by a process to allocate more space in the paged pool will fail.

Value | Meaning
0 | The system calculates an optimal value for this entry based on the amount of physical memory on the computer, and adjusts this value if the amount of memory changes. This value is optimal for most systems.
1–128 | Overrides the value calculated by the system and prevents the system from adjusting this value dynamically. This setting can degrade performance.

Activation method

You must restart the computer before a change to this value takes effect.

Tip Image Tip

For more information on paged pools and nonpaged pools, see the Microsoft Knowledge Base link on the Web Resources page. Search the Knowledge Base for Article Q126402, or use the keywords PagedPoolSize and NonPagedPoolSize.

Caution Image Caution

Do not change the value of this entry. The system adjusts this value dynamically based on internal algorithms. Changing this value prevents the system from calculating an optimal value. This is likely to degrade the performance of your system.

Related Entries

NonPagedPoolQuota

PagedPoolSize


PagedPoolSize

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

Data type | Range | Default value
REG_DWORD | 0x0 | 0x00000001 - 0x0C000000 (bytes in hexadecimal) bytes | 0x0

Description

Specifies the size of the paged pool.

Value | Meaning
0 | The system calculates an optimal value for this entry based on the amount of physical memory on the computer, and adjusts this value if the amount of memory changes. The system algorithm typically sets the size of the paged pool to slightly less than the amount of physical memory in the computer. This value is optimal for most systems.
Number of bytes | Creates a paged pool of the specified size. This overrides the value calculated by the system and prevents the system from adjusting this value dynamically. This setting can degrade performance.

Activation method

You must restart the computer before a change to this value takes effect.

Tip Image Tip

For more information on paged pools and nonpaged pools, see the Microsoft Knowledge Base link on the Web Resources page. Search the Knowledge Base for Article Q126402, or use the keywords PagedPoolSize and NonPagedPoolSize.

Caution Image Caution

Do not change the value of this entry. The system adjusts this value dynamically based on internal algorithms. Changing this value prevents the system from calculating an optimal value. This is likely to degrade the performance of your system.

Related Entries

NonPagedPoolQuota

PagedPoolSize

RegistrySizeLimit


PagingFiles

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

Data type | Range | Default value
REG_BINARY | Name Minimum(MB) Maximum(MB) | C:\Pagefile.sys 27 77

Description

Specifies the name of the paging file and the minimum and maximum size range (in megabytes) for the paging file.

Change method

To change the size range of the paging file or to create new paging files, double-click System in Control Panel, click the Advanced tab, click the Performance Options button, and then click the Change button in the Virtual Memory box.

Note Image Note

For more information on memory management and paging files, see Help for Windows 2000.


SecondLevelDataCache

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

Data type | Range | Default value
REG_DWORD | 0 | 1 - Cache size (in kilobytes) | 0 (256 KB)

Description

Specifies the size of the secondary processor cache, also known as the L2 cache. Data in this entry is used only when the Hardware Abstraction Layer (HAL) cannot detect the L2 cache.

Value | Meaning
0 | Sets the L2 cache size to 256 KB.
Number of kilobytes | Sets the L2 cache size to the value specified.


SystemPages

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

Data type | Range | Default value
REG_DWORD | 0 | Number of entries | 0

Description

Defines the number of system page table entries that are reserved for mapping I/O buffers and other information into the system address space. Each system page table entry maps one page.

Value | Meaning
0 | The system calculates an optimal number of page table entries based on the platform type and the amount of memory available to the system. The system adjusts this value if the amount of memory changes.
Number of entries | Specifies the number of reserved page table entries. This value overrides the system's calculated value and prevents the system from adjusting the value.

Caution Image Caution

Do not change the value of this entry. Changing it prevents the system from calculating an optimal value for your system and adjusting the value when your system changes.


ObjectDirectories

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager

Data type | Range | Default value
REG_BINARY | Object directory list | Windows 2000 Professional: \DosDevices\Windows\RPC Control Windows 2000 Server: \Windows \RPC Control

Description

Lists the object directories the system creates during startup.

Caution Image Caution

Do not change the value of this entry. This value is maintained by the system. Changing this value can prevent Windows 2000 from starting.


PendingFileRenameOperations

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager

Data type | Range | Default value
REG_MULTI_SZ | File name pairs | There is no default value for this entry.

Description

Stores the names of files to be renamed when the system is restarted.

This entry is comprised of pairs of file names. The file specified in the first item of the pair is renamed to match the second item of the pair. The system adds this entry to the registry when a user or program tries to rename a file that is in use. The file names are stored in the value of this entry until the system is restarted and then they are renamed.

Caution Image Caution

This entry is maintained by Windows 2000 for internal use only. Do not change the value of this entry.


ProcessorControl

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager

Data type | Range | Default value
REG_DWORD | 0 | 1 | 2 | 0

Description

Records whether the system has run a processor check routine.

The first time you start Windows 2000, the system runs a routine to determine whether your processor supports the advanced features of the Windows 2000 memory management system, such as write-back caching. If it does not, the system disables these features, and then it sets the value of this entry to 2 to indicate that the routine has been run and need not be run again.

Value | Meaning
0 (or not in registry) | The system has never been started. When it is started, the system sets this value to 1 and runs the processor check routine. If the routine is successful, the system sets this value to 2. If it is unsuccessful, the value remains set to 1.
1 | The system ran the processor check routine, and the routine caused the system to stop abnormally. The system did not adjust any features. It will not attempt to run the routine again.
2 | The processor check routine completed successfully. If necessary, the system adjusted its features. The system will not run the routine again.

Note Image Note

The value of this entry does not indicate whether the system has disabled any memory management functions. It indicates only whether the processor check routine has been run and whether it completed successfully.

Tip Image Tip

For more information on the STOP message, see the Microsoft Knowledge Base link on the Web Resources page. Search the Knowledge Base using the keywords STOP 0x0000009A (SYSTEM_LICENSE_VIOLATION).

Caution Image Caution

Do not change the value of this entry. If you do, you might disable optimizing features of Windows 2000, or enable features that cause the system to operate abnormally.


RegisteredProcessors

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager

Data type | Range | Default value
REG_DWORD | 2 | 4 | Windows 2000 Server: 4 Windows 2000 Professional: 2

Description

This entry is for internal use only. Do not delete or change it.


ResourceTimeoutCount

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF (four-second units) | 648000 (648,000 four-second units = 30 days)

Description

Determines how long the system waits for a locked kernel-mode resource to become available. When a resource is unavailable, the system waits for 500 milliseconds. If the resource is still unavailable, the system boosts the priority of the thread using the resource (to speed its completion) and waits for up to the number of four-second units specified by the value of this entry before terminating the request. If the resource becomes available before this time expires, the timing stops, the timer is reinitialized, and the resource is released to the waiting thread.

A resource that remains unavailable for more than 30 days typically indicates a problem that should be investigated and resolved before proceeding.


SubSystems

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\

Description

The SubSystems subkey contains entries for subsystems that run on Windows 2000.

Caution Image Caution

The entries in SubSystems are maintained by Windows 2000. Do not change the value of these entries unless you are directed to do so by a Microsoft Product Support Specialist.


SystemStartOptions

HKLM\SYSTEM\CurrentControlSet\Control

Data type | Range | Default value
REG_SZ | String | There is no default value for this entry.

Description

Stores special instructions for startup. Windows 2000 receives these instructions from the firmware (ROM) in RISC-based systems and from Boot.Ini in x86 computers.

For example, if you select the VGA option at startup, the value of SystemStartOptions is BASEVIDEO SOS. BASEVIDEO is the VGA mode for display drivers. SOS directs the system to display each driver as it loads during startup, rather than displaying a series of dots.

Note Image Note

If you change the value of this entry by using a registry editor, your changes will be overritten by the value specified in the Boot.ini file the next time the computer starts.


Update

HKLM\SYSTEM\CurrentControlSet\Control\

Description

The Update subkey stores configuration data for System Policy Editor in Windows NT 4.0. This entry is not used by Group Policy in Windows 2000.

Note Image Note

The values in this subkey are not used by Group Policy in Windows 2000. They remain in the registry to support System Policy Editor for Windows NT 4.0.


NetworkPath

HKLM\SYSTEM\CurrentControlSet\Control\Update

Data type | Range | Default value
REG_SZ | Path and filename | There is no default value for this entry.

Description

Specifies the location of the system policy file in Windows NT 4.0 and earlier. This entry is not used by Group Policy in Windows 2000. This entry is used only when the value of the UpdateMode entry is 2.

The value of this entry must consist of the full path and file name of a logical drive or a full path in Universal Naming Convention (UNC) format.

Change method

To change the value of this entry, use System Policy Editor.

Note Image Note

The values in this subkey are not used by Group Policy in Windows 2000. They remain in the registry to support System Policy Editor for Windows NT 4.0.

Related Entries

UpdateMode


UpdateMode

HKLM\SYSTEM\CurrentControlSet\Control\Update

Data type | Range | Default value
REG_DWORD | 0 | 1 | 2 | 1

Description

Specifies the source of data for system policies in Windows NT 4.0 and earlier. This entry is not used by Group Policy in Windows 2000.

Value | Meaning
0 | No policies. System policies are not applied because no source file is specified.
1 | Automatic. System policies are read from the Net Logon share of the authenticating server.
2 | Manual. The system policy file is specified in the value of NetworkPath.

Change method

To change the value of this entry, select or clear Remote Update (Computer\Network\System policies update) in System Policy Editor, and then use the Update mode list box to select the update mode.

Note Image Note

The values in this subkey are not used by Group Policy in Windows 2000. They remain in the registry to support System Policy Editor for Windows NT 4.0.

Related Entries

NetworkPath


VirtualDeviceDrivers

HKLM\SYSTEM\CurrentControlSet\Control\

Description

The VirtualDeviceDrivers subkey stores configuration data for virtual device drivers.


VDD

HKLM\SYSTEM\CurrentControlSet\Control\VirtualDeviceDrivers

Data type | Range | Default value
REG_MULTI_SZ | Filenames | There is no default value for this entry.

Description

Specifies the Win32 dynamic-link libraries (DLLs) for virtual device drivers. The system loads the VDDs in this list when a Windows 2000 virtual DOS machine is started. By default, this entry has no value because the Windows 2000 virtual device drivers are built into the system and need not be loaded separately.


WaitToKillServiceTimeout

HKLM\SYSTEM\CurrentControlSet\Control

Data type | Range | Default value
REG_SZ | Milliseconds in decimal | 20000 (20 seconds)

Description

Determines how long the system waits for services to stop after notifying the service that the system is shutting down. This entry is used only when the user issues a shut-down command by clicking the Shut Down button on the Windows 2000 Security dialog box, or by selecting Shut down from the Shut Down Windows dialog box.

When the value of this entry expires, the system notifies the user that the service has not stopped. The user can force the service task to stop or continue to wait. If the user waits, this value specifies the interval between repeated user notices that the service has not stopped.

If all services stop before this value expires, the system shuts down; it does not wait for this value to expire.

Note Image Note

Some services increase the value of this entry to provide more time for cleanup tasks.

Tip Image Tip

For more information WaitToKillServiceTimeout, see the Microsoft Knowledge Base link on the Web Resources page. Search the Knowledge Base for Article Q146092, or use the keyword WaitToKillServiceTimeout.

Related Entries

WaitToKillAppTimeout

HungAppTimeout


Windows

HKLM\SYSTEM\CurrentControlSet\Control\

Description

The Windows subkey contains configuration data for the Win32 subsystem in Windows 2000.

Related Entries

Windows subkey (HKCU\Software)

Windows subkey (HKLM\Software)


Directory

HKLM\SYSTEM\CurrentControlSet\Control\Windows

Data type | Range | Default value
REG_EXPAND_SZ | Directory name | %SystemRoot%

Description

Specifies the directory in which Windows 2000 files are stored.


ErrorMode

HKLM\SYSTEM\CurrentControlSet\Control\Windows

Data type | Range | Default value
REG_DWORD | 0 | 1 | 2 | 0

Description

Determines which errors appear as pop-up error messages that interrupt the user. ErrorMode is a system-level control of pop-up error messages from system processes and applications. Applications determine which of their errors can appear as pop-ups. ErrorMode can suppress only those pop-ups that applications can display.

Value | Meaning
0 | All errors appear in pop-ups.
1 | Errors from system processes do not appear in pop-ups. Application errors still appear in pop-ups.
2 | Neither application errors nor system process errors appear in pop-ups. This value is designed for unattended computers.

Note Image Note

This value does not affect error logging; all messages that appear as pop-ups are also written to the event log.


NoInteractiveServices

HKLM\SYSTEM\CurrentControlSet\Control\Windows

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Prevents background services from interacting with users. NoInteractiveServices was designed to improve performance of unattended computers.

NoInteractiveServices cannot be used to make a service interact with a user unless the service is written to be interactive. Also, it will not prevent a service from displaying error messages.

Value | Meaning
0 | Interactive background services (Type 0x110) can communicate with users.
1 | Background services cannot interact with users. This value overrides the Control Panel setting for interactive services (as described below) and the SERVICE_INTERACTIVE_PROCESS option in the CreateService API.

Note Image Note

To determine whether a service is run in interactive mode, click Start, point to Programs, point to Administrative Tools, and then double-click Computer Management. Double-click System Tools, double-click Services, right-click a service to see its properties, and then select the Log On tab. The Allow Service to Interact with Desktop check box is selected if the service is interactive, and cleared if it is not. Selecting the check box will not make a service interact with the user unless it is written to do so.


NoPopUpsOnBoot

HKLM\SYSTEM\CurrentControlSet\Control\Windows

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether pop-up error messages that appear when the system starts are suppressed. You can add NoPopUpsOnBoot to the registry to prevent Windows 2000 from displaying messages when no one is there to read them, such as computers that are configured to log on to Windows 2000 automatically.

Value | Meaning
0 | Pop-up error messages are displayed.
1 | Pop-up error messages are suppressed.

Note Image Note

NoPopUpsOnBoot does not suppress the message notifying the user that the domain controller cannot be contacted. To suppress this message, use ReportDC.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

ReportDC

ReportControllerMissing


SystemDirectory

HKLM\SYSTEM\CurrentControlSet\Control\Windows

Data type | Range | Default value
REG_EXPAND_SZ | Directory name | %SystemRoot%\system32

Description

Specifies the directory for the Windows 2000 system files.


WOW

HKLM\SYSTEM\CurrentControlSet\Control\

Description

The WOW subkey contains entries that control startup parameters that affect MS-DOS–based applications and applications created for 16-bit Windows 3.x.


cmdline

HKLM\SYSTEM\CurrentControlSet\Control\WOW

Data type | Range | Default value
REG_EXPAND_SZ | Path [option [option]] | %SystemRoot%\system32\ntvdm.exe

Description

Specifies the command run when an MS-DOS-based application starts. The command includes the name and location of the program that creates a Windows 2000 virtual DOS machine (NTVDM) for MS-DOS programs. Programs designed for MS-DOS run on Windows 2000 in a process that this program creates.

The following options can also be included:

Value | Meaning
-a | Specifies a command to pass to the NTVDM.
-f | Specifies the directory for Ntvdm.exe.
-m | Hides the NTVDM console window.
-w | Specifies the NTVDM for 16-bit Windows applications.

Activation method

Changes to this entry are effective immediately and remain in effect until the MS-DOS-based application is closed.

Tip Image Tip

You can create multiple copies of Ntvdm.exe with different names and run a different MS-DOS-based program in each copy. Because each MS-DOS–based program runs in a process with a different name, it is much easier to identify the program when monitoring its process. If you change the name of Ntvdm.exe, you must also change the value of this entry to identify the new NTVDM program.

Related Entries

wowcmdline


DefaultSeparateVDM

HKLM\SYSTEM\CurrentControlSet\Control\WOW

Data type | Range | Default value
REG_SZ | yes | no | no

Description

Determines the default mode for running 16-bit Windows applications. On Windows 2000, 16-bit applications can run as separate threads in a shared NTVDM process, or each can run in a separate NTVDM process.

Value | Meaning
yes | By default, 16-bit Windows applications run in a separate process.
no | By default, 16-bit Windows applications run as threads in the NTVDM process.

Typically, 16-bit applications are run in a separate process to improve their performance. When sharing a process, only one 16-bit application can run at a time; all other threads of the NTVDM process are blocked. Also, it is easier to monitor an application when it is running in a separate process.


KnownDLLs

HKLM\SYSTEM\CurrentControlSet\Control\WOW

Data type | Range | Default value
REG_SZ | DLL filenames | comm.drv commdlg.dll ctl3dv2.dll ddeml.dll keyboard.drv lanman.drv mapi.dll mmsystem.dll mouse.drv netapi.dll olecli.dll olesvr.dll pmspl.dll shell.dll sound.drv system.drv toolhelp.dll vga.drv wfwnet.drv win87em.dll winoldap.mod winsock.dll winspool.exe wowdeb.exe timer.drv rasapi16.dll compobj.dll storage.dll ole2.dll ole2disp.dll ole2nls.dll typelib.dll msvideo.dll avifile.dll msacm.dll mciavi.drv mciseq.drv mciwave.drv progman.exe avicap.dll

Description

Stores a list of dynamic-link libraries (DLLs) that can be used by both 16-bit Windows applications and by 32-bit Windows applications. When a 16-bit Windows application requests a DLL that appears on this list, the system loads the DLL from the System32 directory, rather than using the application's version of the DLL.

User.dll, Gdi.dll, and System.drv are not included in this list because they are required Windows 2000 system files and their location cannot be changed.

Tip Image Tip

To replace or upgrade a DLL, delete the DLL name from this list. This causes the system to search system directories for the new DLL.

Related Entries

KnownDLLs subkey


LPT_timeout

HKLM\SYSTEM\CurrentControlSet\Control\WOW

Data type | Range | Default value
REG_SZ | Number of seconds | 15

Description

Determines how long an MS-DOS–based application can keep an LPT port open after use. When the time open after use exceeds the value of this entry, the system closes the port and deletes its output. Limiting the time a port can remain open limits the effect of MS-DOS–based applications that use BIOS and do not close the port.


size

HKLM\SYSTEM\CurrentControlSet\Control\WOW

Data type | Range | Default value
REG_SZ | 0 | Number in megabytes | 0

Description

Determines the amount of virtual memory allocated to each Windows 2000 virtual DOS machine (NTVDM) running an MS-DOS-based application.

Value | Meaning
0 | The system calculates an optimal NTVDM size based on the amount of physical memory on the computer, and adjusts the size if the amount of memory changes.
Number (MB) | Overrides the value calculated by the system and prevents the system from adjusting this value dynamically.

Related Entries

wowsize


wowcmdline

HKLM\SYSTEM\CurrentControlSet\Control\WOW

Data type | Range | Default value
REG_EXPAND_SZ | Path [option [option]] | %SystemRoot%\system32\ntvdm.exe -a %SystemRoot%\system32\krnl386

Description

Specifies the command run when a 16-bit Windows application starts. The command includes the name and location of the program that creates a virtual DOS machine (NTVDM) for 16-bit Windows programs. All 16-bit Windows programs run on Windows 2000 in a process that this program creates.

The following options can also be included:

Option | Meaning
-a | Specifies a command to pass to the NTVDM.
-f | Specifies the directory for Ntvdm.exe.
-m | Hides the NTVDM console window.
-w | Specifies the NTVDM for 16-bit Windows applications.

Activation method

Changes to this value are effective immediately and remain in effect until the 16-bit Windows-based application is closed.

Related Entries

cmdline


wowsize

HKLM\SYSTEM\CurrentControlSet\Control\WOW

Data type Range Default value
REG_SZ Number in megabytes
Amount of Memory | Default Value
< 12 MB | 3 MB
12 - 16 MB | 6 MB
> 16 MB | 8 MB

Description

Determines the amount of virtual memory allocated to a Windows 2000 virtual DOS machine (NTVDM) to run 16-bit Windows applications. This entry is used only on RISC systems. On computers with Intel™ processors, the system calculates this value based on the amount of physical memory on the computer.

For each megabyte of memory specified in wowsize, the system allocates 1.25 MB to the NTVDM process. For example, if the value of wowsize is 4, the system allocates 5 MB of memory to the NTVDM process.

Caution Image Caution

Do not set wowsize to less than 3 MB. Most applications cannot run in an NTVDM with less memory.


Enum

HKLM\SYSTEM\CurrentControlSet\

Description

The Enum subkey contains a database representing all devices installed on the computer and recognized by the system. The database in Enum stores configuration data for hardware devices independent of the drivers they use. This subkey is critical to the configuration of Plug and Play devices in Windows 2000.

Change method

To change device settings, use Device Manager.

Note Image Note

Users, including administrators, are not permitted to view or change the contents of the Enum subkey. These restrictions protect the integrity of the operating system and the devices on your computer.

Tip Image Tip

To display hidden devices, non–Plug and Play devices, and devices not attached to the computer (commonly known as ghosted or phantom devices), type set DEVMGR_SHOW_NONPRESENT_DEVICES=1 at the command line. Then, use Device Manager to remove or reconfigure these devices. Do not edit the registry. For more information, see Viewing Hidden Devices in the Windows 2000 Professional Resource Kit.

Caution Image Caution

Do not attempt to change the permissions on the Enum subkey. If you do, you might damage the sequence of inherited permissions in the registry. If you change the content of the Enum subkey, you can damage the Plug and Play functions of Windows 2000 and prevent devices from operating. If you must gain access to the Enum subkey, contact Microsoft Product Support Services.

Related Entries

Enum subkey (for each service)


Hardware Profiles

HKLM\SYSTEM\CurrentControlSet\

Description

The Hardware Profiles subkey stores the hardware profiles on your system.

A hardware profile consists of specified changes to the original hardware profile configured in the SOFTWARE and SYSTEM keys of HKEY_LOCAL_MACHINE. To allow us to apply and remove hardware profiles easily, the original value in the SOFTWARE or SYSTEM subkey is not changed; instead that change is stored in a numbered subkey of the Hardware Profiles subkey.

You can use System in Control Panel to create a hardware profile. Also, the system creates new hardware profiles automatically when it encounters configurations that require one, such as when a portable computer is undocked or moved from one docking station to another.

Each hardware profile is stored in one <Profile-number> subkey of the Hardware Profiles subkey. The content of the numbered subkeys looks like a miniature version of the Software and System subkeys. It contains all and only those subkeys in the path to the entry changed by the hardware profile. When a hardware profile is applied, the values in the numbered subkeys override the corresponding values in Software and System.

The current hardware profile is stored in one of the numbered subkeys in the Hardware Profiles subkey, but it also appears in the Current subkey of Hardware Profiles and in the HKEY_CURRENT_CONFIG subtree of the registry. Because the Current subkey and HKEY_CURRENT_CONFIG merely store pointers to the content of the numbered Hardware Profiles subkey currently in use, you can view and edit the data in either of the three locations.

Note Image Note

For information about the entries in a subkey of Hardware Profiles, see the description of that entry in the Software or System key. For example, to find a description of the contents of Hardware Profiles\<Profile-number>\Software\Fonts, see the description of HKLM\Software\Fonts.

Tip Image Tip

To create hardware profiles, use System in Control Panel. Click the Hardware tab, and then click the Hardware Profiles button.

Related Entries

<Profile-number> subkey

Current subkey

HKEY_CURRENT_CONFIG


<Profile-number>

HKLM\SYSTEM\CurrentControlSet\Hardware Profiles\

Description

A <Profile-number> subkey stores the configuration data for a particular hardware profile that you create for your system.

A hardware profile consists of specified changes to the original hardware profile configured in the SOFTWARE and SYSTEM keys of HKEY_LOCAL_MACHINE. To allow hardware profiles to be easily applied and removed, the original value in the SOFTWARE or SYSTEM key is not changed; instead that change is stored in a <Profile-number> subkey of Hardware Profiles.

The content of each <Profile-number> subkey looks like a miniature version of the SOFTWARE and SYSTEM keys. It contains all and only those subkeys in the path to the entry changed by the hardware profile. When a hardware profile is selected, the values in the numbered subkeys override the corresponding values in SOFTWARE and SYSTEM.

Your system can store several hardware profiles, although not all are appropriate to every hardware configuration of your computer. (For example, a particular hardware profile might apply to a portable computer only when it is docked.) If the computer does not have any hardware profiles or any appropriate to the current hardware configuration, the system creates one for you. You can also use System in Control Panel to create hardware profiles.

Note Image Note

The <Profile-number> subkey is a variable representing the numbered subkeys under the Hardware Profiles subkey. It doesn't actually appear in the registry. This subkey is used to describe features common to all numbered hardware profile subkeys in the registry.

Tip Image Tip

To determine which numbered subkey under Hardware Profiles represents the current hardware profile, see CurrentConfig in HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\IDConfigDB. The value of CurrentConfig corresponds to the number of the subkey that contains the current hardware profile.

Related Entries

Current

Hardware Profiles subkey

<Profile-number> (IDConfigDB)


Current

HKLM\SYSTEM\CurrentControlSet\Hardware Profiles\

Description

The Current subkey in the Hardware Profiles subkey displays configuration data for the hardware profile currently in use on the system.

The Current subkey does not actually contain any data. Instead, it contains a pointer to the <Profile-number> subkey under Hardware Profiles, which contains the current hardware profile. As such, the contents of the selected subkey appear in Current.

Also, the contents of Current appear in the HKEY_CURRENT_CONFIG subtree of the registry. Because the Current subkey and HKEY_CURRENT_CONFIG merely store pointers to the content of the numbered Hardware Profiles subkey currently in use, you can view and edit the data in any of the three locations.

The content of the Current subkey (and all <Profile-number> subkeys) looks like a miniature version of the SOFTWARE and SYSTEM keys. It contains all and only those subkeys in the path to the entry changed by the hardware profile. When a hardware profile is selected, the values in the numbered subkeys override the corresponding values in SOFTWARE and SYSTEM.

The system always designates one profile as the current one.

  • If the system does not have any hardware profiles that are appropriate to the current hardware configuration, the system creates one automatically, and that profile becomes the current hardware profile.
  • If the system includes only one hardware profile that is appropriate to the current hardware configuration, that profile is automatically chosen to be the current hardware profile.
  • If the system includes more than one hardware profile that is appropriate to the current hardware configuration then, when the system starts, it prompts the user to select from among the appropriate hardware profiles. The chosen profile becomes the current profile.

The current hardware profile remains current until the system stops or the hardware configuration changes, such as when an ACPI-capable portable computer docks or undocks.

Tip Image Tip

To determine which numbered subkey under Hardware Profiles represents the current hardware profile, see CurrentConfig in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\IDConfigDB. The value of CurrentConfig corresponds to the number of the subkey that contains the current hardware profile.

Related Entries

Hardware Profiles subkey

<Profile-number> subkey

HKEY_CURRENT_CONFIG

CurrentConfig


Services

HKLM\SYSTEM\CurrentControlSet\

Description

The Services subkeys contain entries for standard and optional Windows 2000 services, such as device drivers, file system drivers, and Win32 service drivers. Although the values of the entries differ for each service, most Services subkeys have the same subkeys and entries.

Each Services subkey bears the name of the service that uses it. Often, this is also the name of the file from which the service is loaded.

Some of the services and devices represented by subkeys in the Services subkey are installed on the computer, but some of the subkeys represent services that are not installed or not enabled. To determine which services are installed on the computer, click Services in Computer Management. To determine which devices are installed on the computer, use Device Manager.

Note Image Note

Adding a subkey to the Services subkey does not install a service. Windows 2000 does not recognize a service unless it is properly installed by using the standard installation methods, such as the CreateService API, or the SC CREATE command.


<service-name>

HKLM\SYSTEM\CurrentControlSet\Services\

Description

Represents a service for Windows 2000.

Entries and subkeys common to Services subkeys appear in the <service-name> subkey. Entries and subkeys that are specific to a service are described in the subkey bearing the service name.

Note Image Note

The <service-name> subkey is a variable representing the subkeys under the HKLM\SYSTEM\CurrentControlSet\Services subkey. It doesn't actually appear in the registry. This variable subkey displays the entries and subkeys that are common to many of the Services subkeys. The actual Services subkeys in your registry depend upon the services installed on the computer or available to the system.


DependOnGroup

HKLM\SYSTEM\CurrentControlSet\Services\<service-name>

Data type | Range | Default value
REG_MULTI_SZ | Service group name [service group name] | There is no default value for this entry.

Description

Specifies the service group(s) that must be loaded before this service is loaded. This entry ensures that prerequisite services are loaded successfully.

Note Image Note

This information is presented for reference only. You cannot change the prerequisite services for a service by editing this entry. To change the value of DependOnService, use the ChangeServiceConfig API or Sc.exe, a tool included in the Windows 2000 Resource Kit.


DependOnService

HKLM\SYSTEM\CurrentControlSet\Services\<service-name>

Data type | Range | Default value
REG_MULTI_SZ | Service group name [service name] | There is no default value for this entry.

Description

Specifies the service(s) that must be loaded before this service is loaded. This entry ensures that prerequisite services are loaded successfully.

Note Image Note

This information is presented for reference only. You cannot change the prerequisite services for a service by editing this entry. To change the value of DependOnService, use the ChangeServiceConfig API or Sc.exe, a tool included in the Windows 2000 Resource Kit.


Enum

HKLM\SYSTEM\CurrentControlSet\Services\<service-name>\

Description

The Enum subkey appears in subkeys under the Services subkey that store values for drivers and other services that control or interact with devices.

The Enum subkey in each Services subkey stores information about the hardware associated with this service.

The values in the Enum subkey associate the service with the instance of the device it controls.

Note Image Note

Values of entries in the Services\service-name\Enum subkey are rewritten each time the system starts. Do not change the values of entries in this subkey.

Related Entries

Enum subkey (for all services)


ErrorControl

HKLM\SYSTEM\CurrentControlSet\Services\<service-name>

Data type | Range | Default value
REG_DWORD | 0 - 3 | Usually 0 or 1

Description

Specifies how to proceed if the driver for the service or device fails to load or to initialize properly. By default, the value of ErrorControl for all Windows 2000 services and drivers is 0 or 1.

Value | Meaning
0 | Ignore: If the driver fails to load or initialize, startup proceeds with no warning messages.
1 | Normal: If the driver fails to load or initialize, startup proceeds, but a warning message appears.
2 | Severe: If the driver fails to load or initialize, the system declares the startup to have failed and restarts by using the LastKnownGood control set. If startup is already using the LastKnownGood control set, it continues.
3 | Critical: If the driver fails to load or initialize, the system declares the startup to have failed and restarts by using the LastKnownGood control set. If startup is already using the LastKnownGood control set, the system stops the startup procedures and runs a debugging program.

Note Image Note

This information is presented for reference only. You cannot change the load configuration of a service by editing this entry. To change the value of ErrorControl, use the ChangeServiceConfig API or Sc.exe, a tool on the Windows 2000 Resource Kit.


Group

HKLM\SYSTEM\CurrentControlSet\Services\<service-name>

Data type | Range | Default value
REG_DWORD | Service group name | There is no default value for this entry.

Description

Specifies the name of the service group to which the service belongs. If this entry does not appear in the registry, the service does not belong to a service group. As a result, it will be loaded after all services in service groups are loaded.

Note Image Note

This information is presented for reference only. You cannot change the service group of a service by editing this entry. To change the value of Group, use the ChangeServiceConfig API or Sc.exe, a tool on the Windows 2000 Resource Kit.


ImagePath

HKLM\SYSTEM\CurrentControlSet\Services\<service-name>

Data type | Range | Default value
REG_EXPAND_SZ | Path and filename | Drivers: Systemroot\System32\Drivers\<Driver-name>.sys Services: Systemroot\System32\<Service-name>.exe

Description

Specifies the location of the executable file for the driver or device. This entry is not used for network adapters.

Note Image Note

This information is presented for reference only. You cannot change the prerequisite services for a service by editing this entry. To change the value of DependOnService, use the ChangeServiceConfig API or Sc.exe, a tool included in the Windows 2000 Resource Kit.


Linkage

HKLM\SYSTEM\CurrentControlSet\Services\<service-name>\

Description

The Services subkeys for network services and protocols contain a Linkage subkey. This Linkage subkey stores configuration data for binding network components. The bindings associate network services with protocols and devices that support them.

Hardware devices, such as network adapters, and network services, such as File and Print Services for Microsoft, also have Linkage subkeys. These Linkage subkeys store data about bindings from the perspective of the device. They associate devices and services with the transport protocols they use. In Windows 2000, the Linkage subkeys for devices are stored in HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Class\<{Class-GUID}> in the numeric subkey representing the particular device.

Windows 2000 creates the bindings from data stored in the Linkage subkeys in both locations.

A binding consists of three entries, Bind, Export, and Route. Each of these entries can include more than one component. The components are listed in the entries in a precise order, so that the first component in one entry corresponds with the first component in the other entries, and each subsequent component corresponds with subsequent components in the other entries.

Note Image Note

In Windows 2000, the registry no longer includes NetRules subkeys. In Windows NT 4.0 and earlier, the NetRules subkey stored binding parameters for network software components. In Windows 2000, binding is performed by the network class installers that install network drivers and other software components. Bind specification are stored in .inf files, not in the registry.

Some bind specifications are stored in the Ndi subkeys that contain configuration data for network driver installers. However, these are primary upper bind and lower bind settings only.

Caution Image Caution

Bindings are created by the system. Do not change the values of these entries.

Related Entries

Linkage subkeys for devices

Ndi subkeys


Bind

HKLM\SYSTEM\CurrentControlSet\Services\<service-name>\Linkage

Data type | Range | Default value
REG_MULTI_SZ | ObjectName ObjectName ... | There is no default value for this entry.

Description

Specifies the services, protocols, and devices to which this service is associated in a binding. The system builds the bind from the values in this entry and in the Bind entries of the associated protocols and devices.

More than one component of the same type can be listed in this value. For example, if the computer has two networks, the value of Bind for a network adapter type would consist of two object names.

Note Image Note

A valid binding requires a value for three entries: Bind, Export, and Route.

Caution Image Caution

Bindings are created by the system. Do not change the values of these entries.

Related Entries

Linkage subkeys for devices

Bind (for devices)


Export

HKLM\SYSTEM\CurrentControlSet\Services\<service-name>\Linkage

Data type | Range | Default value
REG_MULTI_SZ | ObjectName ObjectName ... | There is no default value for this entry.

Description

Specifies objects that the service must be able to access for the binding to be successful. Objects named in the value of Export must be installed on the system and available to the service or device.

Note Image Note

A valid binding requires a value for three entries: Bind, Export, and Route.

Caution Image Caution

Bindings are created by the system. Do not change the values of these entries.

Related Entries

Linkage subkeys for devices

Export (for devices)


OtherDependencies

HKLM\SYSTEM\CurrentControlSet\Services\<service-name>\Linkage

Data type | Range | Default value
REG_MULTI_SZ | ServiceName ServiceName ... | There is no default value for this entry.

Description

Specifies services required by the network component in addition to those specified in the binding. This entry and its value are retained when bindings are reconfigured, even when the other entries in the Linkage subkey are deleted and recreated.

For example, in the NetBT\Linkage subkey, the value of OtherDependencies is Tcpip. This value indicates that NetBT requires TCP/IP, regardless of its current binding configuration.

Note Image Note

A valid binding requires a value for three entries: Bind, Export, and Route.

Services upon which the network component depends due to its current binding are stored in its DependOnService entry.

Windows 2000 adds this entry to the subkey only when it is required by the network component. It does not appear in all Linkage subkeys.

Caution Image Caution

Bindings are created by the system. Do not change the values of these entries.

Related Entries

Linkage subkeys for devices

OtherDependencies (for devices)


Route

HKLM\SYSTEM\CurrentControlSet\Services\<service-name>\Linkage

Data type | Range | Default value
REG_MULTI_SZ | SubkeyName SubkeyName ... | There is no default value for this entry.

Description

Specifies the Linkage subkeys from which data was collected to create the binding. Each name in the value of this entry indicates a path through the binding protocol.

The Linkage subkeys that appear in the value of this entry can represent services or devices.

  • Linkage subkeys for services bear the name of the service, such as Tcpip, and appear in HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services.
  • Linkage subkeys for device are named by the GUID of the device class and appear in HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Class.

Note Image Note

A valid binding requires a value for three entries: Bind, Export, and Route.

Caution Image Caution

Bindings are created by the system. Do not change the values of these entries.

Related Entries

Linkage subkeys for devices

Route (for devices)


networkprovider

HKLM\SYSTEM\CurrentControlSet\Services\<service-name>\

Description

The networkprovider subkey, which stores the name of the device, the provider, and the provider order, can appear in the Services subkeys for a network service. When a network service has a networkprovider subkey, the value of Group in the <service-name> subkey must be NetworkProvider.

Related Entries

NetworkProvider Control subkey


ObjectName

HKLM\SYSTEM\CurrentControlSet\Services\<service-name>

Data type | Range | Default value
REG_SZ | Object name | Drivers: Systemroot\System32\Drivers\<Driver-name>.sys Services: Systemroot\System32\<Service-name>.exe

Description

If the service represented by the subkey is a kernel-mode driver or file system driver, this entry specifies the name of the Windows 2000 driver object that the I/O Manager uses to load the device driver.

If the service represented by the subkey is a Win32 service, this entry specifies the account name that the service uses to log on to Windows 2000.

Note Image Note

This information is presented for reference only. You cannot change the driver object or account name that Windows 2000 uses to start a service by editing this entry. To change the value of ObjectName, use the ChangeServiceConfig API or Sc.exe, a tool on the Windows 2000 Resource Kit.

Tip Image Tip

To determine what type of service is represented by the subkey, see Type.


Parameters

HKLM\SYSTEM\CurrentControlSet\Services\<service-name>\

Description

The Parameters subkeys contain entries specific to each service, such as a registry entry to enable an optional component of the service. Many entries in the Parameters subkeys are not added to the registry when you install the service. You must add them by editing the registry or by using a snap-in or administrative program that adds the entries to the registry.


Performance

HKLM\SYSTEM\CurrentControlSet\Services\<service-name>\

Description

The Performance subkey contains entries for the performance counter dynamic-link library (DLL) for the service. These values are used by the performance library to collect data for the performance counters that monitor the service. These entries are maintained by the system and should not be changed.

Activation method

To make changes to entries in this subkey effective, restart the Remote Registry Service or restart Windows 2000.

Tip Image Tip

If particular performance counters do not appear in your performance monitoring tool, check the Application Log in Event Viewer for events recorded by Perflib. When Perflib detects disabling errors in a counter DLL, it records an event in the log and sets the value of DisablePerformanceCounters to 1 to disable the counters.

Caution Image Caution

Do not change the values of entries in the Performance subkey. Changing these values can interfere with the operation of the service's performance counters.


Collect Timeout

HKLM\SYSTEM\CurrentControlSet\Services\<Service-name>\Performance

Data type | Range | Default value
REG_DWORD | 0x0 - 0xEE6B2800 milliseconds | (The value of OpenProcedureWaitTime.)

Description

Defines a slow Collect procedure call for these counters.

This entry tells Perflib how long the Collect procedure call for these counters is expected to run. If the time specified in this entry expires before the call completes, Perfib considers the call to be abnormally slow and records an error in the Application Log in Event Viewer. Also, if required by the value of Configuration Flags, Perflib disables the counters and does not display the counters again until you manually re-enable them.

Perflib times the procedure calls of non-trusted counters to identify counters that can delay or lock performance tools during initialization. While the Collect procedure call proceeds, you cannot use the performance tools, and remote users cannot log on to the local computer.

Activation method

To make changes to this entry effective, restart the Remote Registry Service or restart Windows 2000.

Note Image Note

Timing procedure calls is one of several tests Perflib performs to maintain the integrity of your counters. To configure the Perflib test feature, use the Configuration Flags entry.

Perflib does not time the procedure calls of trusted performance counter DLLs. This entry applies only to non-trusted DLLs.

Perflib disables counters due to slow procedure calls only when, in the value of Configuration Flags, the 0x8 (100) bit is set and the 0x2 (10) bit is not set.

Perflib does not time procedure calls when the 0x4 bit (100) is set in the value of Configuration Flags.

Perflib disables counter by setting the value of Disable Performance Counters for that service to 1. After you have repaired or replaced the counter DLL, you must re-enable them manually by changing the value of Disable Performance Counters to 0.

Some performance counters DLLs add the Collect Timeout entry to the registry. If it does not appear, you can add this entry to the registry to override the default value.

Tip Image Tip

If you suspect problems with procedure calls, check the Application Log in Event Viewer. Perflib records an error in the log whenever a procedure call exceeds its limit.

Related Entries

OpenProcedureWaitTime

Open Timeout


Disable Performance Counters

HKLM\System\CurrentControlSet\Services\<Service-name>\Performance

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Enables and disables registry-based performance counters for this service.

If the value of this entry is 1, Perflib does not retrieve performance data about these counters from the registry. As a result, System Monitor, and other tools that use the data, cannot display it. Instead, the tools display a value of 0 or 100%, depending on the counter.

The Performance Library (Perflib) uses this entry to disable counters that cause serious errors. This prevents the troublesome counters from jeopardizing the display of all performance counters on the system. You can use this entry to reenable the counters for a service after the counter DLL has been repaired or replaced.

Value | Meaning
0 | Enables performance counters for this service.
1 | Disables performance counters for this service.

Change method

To change the value of this entry, use Extensible Performance Counter List (Exctrlst.exe), a tool on the Windows 2000 Resource Kit CD.

Activation method

To make changes to this entry effective, restart the Remote Registry Service or restart Windows 2000.

Note Image Note

This entry only affects the performance counters for a particular service. To enable or disable all registry-based performance counters on the system, add the Disable Performance Counters entry to the Perflib subkey.

To prevent Perflib from disabling counters, set the 0x2 (10) bit in the value of Configuration Flags.

Tip Image Tip

If particular performance counters do not appear in your performance monitoring tool, check the Application Log in Event Viewer for events recorded by Perflib. When Perflib detects disabling errors in a counter DLL, it records an event in the log and sets the value of DisablePerformanceCounters to 1 to disable the counters.

Caution Image Caution

If you set the value of this entry to 1, the performance objects and counters for this service do not appear in any performance tool. You will not be able to use System Monitor, or any tool that uses Performance Library data, to monitor these counters.

Do not edit the registry or use Exctrlst to enable counters that Perflib has disabled, unless the counter DLL has been repaired or replaced. If you do, Perflib will detect the errors and disable the counters again. Or, the troublesome counters can prevent you from monitoring any performance counters on your system.

Related Entries

EventLogLevel

DisablePerformanceCounters

ExtCounterTestLevel

OpenProcedureWaitTime

Open Timeout

Collect Timeout


Library Validation Code

HKLM\System\CurrentControlSet\Services\<Service-name>\Performance

Data type | Range | Default value
REG_BINARY | Unique code signature | There is no default value for this entry.

Description

Identifies a trusted performance counter DLL.

This entry stores data identifying a particular version of a performance counter DLL as one that has been certified to be free of disabling errors. When the data for a DLL matches the value of this entry, the Performance Library (Perflib) considers the DLL to be trusted.

This entry is added to the registry by the script that installs the DLL in Windows 2000.

Activation method

To make changes to this entry effective, restart the Remote Registry Service or restart Windows 2000.

Note Image Note

By default, trusted counter DLLs are exempt from Perflib's extensive run–time testing, but you can use ExtCounterTestLevel to require some tests. ExtCounterTestLevel applies to all trusted counters on the system, not just those of any particular service.

Tip Image Tip

If particular performance counters do not appear in your performance monitoring tool, check the Application Log in Event Viewer for events recorded by Perflib. When Perflib detects disabling errors in a counter DLL, it records an event in the log and sets the value of DisablePerformanceCounters to 1 to disable the counters.

Caution Image Caution

Do not change the value of this entry by editing the registry. If you do, the performance counters for this service will not operate properly.

Related Entries

ExtCounterTestLevel

Configuration Flags

Disable Performance Counters (in the Perflib subkey)

Disable Performance Counters (in the Performance subkey for a service)


Open Timeout

HKLM\SYSTEM\CurrentControlSet\Services\<Service-name>\Performance

Data type | Range | Default value
REG_DWORD | 0x0 - 0xEE6B2800 milliseconds | The value of OpenProcedureWaitTime

Description

Defines a slow Open procedure call for these counters.

This entry tells Perflib how long the Open procedure call for these counters is expected to run. If the time specified in this entry expires before the call completes, Perfib considers the call to be abnormally slow and records an error in the Application Log in Event Viewer. Also, if required by the value of Configuration Flags, Perflib disables the counters and does not display the counters again until you manually re-enable them.

Perflib times the procedure calls of non-trusted counters to identify counters that can delay or lock performance tools during initialization. While the Collect procedure call proceeds, you cannot use the performance tools, and remote users cannot log on to the local computer.

Activation method

To make changes to this entry effective, restart the Remote Registry Service or restart Windows 2000.

Note Image Note

Timing procedure calls is one of several tests Perflib performs to maintain the integrity of your counters. To configure the Perflib test feature, use the Configuration Flags entry.

Perflib does not time the procedure calls of trusted performance counter DLLs. This entry applies only to non-trusted DLLs.

Perflib disables counters due to slow procedure calls only when, in the value of Configuration Flags, the 0x8 (100) bit is set and the 0x2 (10) bit is not set.

Perflib does not time procedure calls when the 0x4 bit (100) is set in the value of Configuration Flags.

Perflib disables counter by setting the value of Disable Performance Counters for that service to 1. After you have repaired or replaced the counter DLL, you must re-enable them manually by changing the value of Disable Performance Counters to 0.

Some performance counters DLLs add the Collect Timeout entry to the registry. If it does not appear, you can add this entry to the registry to override the default value.

Tip Image Tip

If you suspect problems with procedure calls, check the Application Log in Event Viewer. Perflib records an error in the log whenever a procedure call exceeds its limit.

Related Entries

OpenProcedureWaitTime

Collect Timeout

Configuration flags


Security

HKLM\SYSTEM\CurrentControlSet\Services\<service-name>\

Description

The Security subkey stores information about the permissions set for a driver or a Win32 service.


Security

HKLM\SYSTEM\CurrentControlSet\Services\<service-name>\Security

Data type | Range | Default value
REG_BINARY | Security descriptor | There is no default value for this entry.

Description

Stores the security descriptor for the service. A security descriptor specifies the security attributes of the service, including the security identifier (SID) and access control lists associated with the service.

Applications view and edit the Security entry by using the QueryServiceObjectSecurity() and SetServiceObjectSecurity() Win32 APIs.


Start

HKLM\SYSTEM\CurrentControlSet\Services\<service-name>

Data type | Range | Default value
REG_DWORD | 0 - 4 | There is no default value for this entry.

Description

Specifies how the service is loaded or started. If the service is a Win32 service, the value of Start must be 2, 3, or 4. This entry is not used for network adapters.

Value | Meaning
0 | Boot: Loaded by kernel loader. Components of the driver stack for the boot (startup) volume must be loaded by the kernel loader.
1 | System: Loaded by I/O subsystem. Specifies that the driver is loaded at kernel initialization.
2 | Automatic: Loaded by Service Control Manager. Specifies that the service is loaded or started automatically.
3 | Manual: Specifies that the service does not start until the user starts it manually, such as by using Device Manager.
4 | Disabled: Specifies that the service should not be started.

Note Image Note

This information is presented for reference only. You cannot change the starting rules for a service by editing this entry. To change the value of Start, use the ChangeServiceConfig API or Sc.exe, a tool on the Windows 2000 Resource Kit.

Tip Image Tip

To determine what type of service is represented by the subkey, see Type.


Tag

HKLM\SYSTEM\CurrentControlSet\Services\<service-name>

Data type | Range | Default value
REG_DWORD | Tag number | There is no default value for this entry.

Description

Specifies the tag number for the service.

Each service in a service group is assigned a tag, a numeric value that is unique within a service group. Services in the service group are loaded in the order that their tag appears in the GroupOrderList subkey for the service group.

For example, the Busmouse service is in the Pointer Port service group. The value of Tag for Busmouse is 3. The value of Pointer Port in the GroupOrderList subkey is 030000000200000001000000030000000 (binary), indicating that there are three services in the Pointer Port service group. The service with Tag 2 is loaded first, the service with Tag 1 is loaded second, and Busmouse, with Tag 3, is the last service in the Pointer Port group to be loaded.

Note Image Note

This information is presented for reference only.. You cannot change the load order of a service by editing this entry. To change the value of Tag, use the ChangeServiceConfig API or Sc.exe, a tool on the Windows 2000 Resource Kit.

Related Entries

Group

ServiceGroupOrder subkey

GroupOrderList subkey


Type

HKLM\SYSTEM\CurrentControlSet\Services\<service-name>

Data type | Range | Default value
REG_DWORD | 1 | 2 | 4 | 8 | 16 | 32 | 272 | 288 | There is no default value for this entry.

Description

Identifies the type of service represented by the subkey.

Value | Meaning
1 | A kernel-mode device driver.
2 | A file system driver.
4 | A set of arguments for an adapter.
8 | A file system driver service, such as a file system recognizer.
16 | A Win32 program that runs in a process by itself. This type of Win32 service can be started by the service controller.
32 | A Win32 program that shares a process. This type of Win32 service can be started by the service controller.
272 | A Win32 program that runs in a process by itself (like Type16) and can interact with users.
288 | A Win32 program that shares a process and can interact with users.

Note Image Note

This information is presented for reference only. You cannot change Windows 2000’s view of a service by editing this entry. To change the value of Type, use the ChangeServiceConfig API or Sc.exe, a tool on the Windows 2000 Resource Kit.

Related Entries

Group

ServiceGroupOrder subkey

GroupOrderList subkey


Alerter

HKLM\SYSTEM\CurrentControlSet\Services\

Description

The Alerter subkey stores configuration data for the Alerter service. This service sends messages to users warning them of impending resource, security or access problems on the server. Alerts appear in a message box on the user's display. Typically, the Alerter service alerts users when a printer is running out of paper or the disk on a file server is nearly full.

Change method

To specify users who receive alerts about this server, use the Send Administrative Alerts to preference (Computer Configuration\Windows Settings\Administrative Templates\Administrative Services) in Group Policy.


Parameters

HKLM\SYSTEM\CurrentControlSet\Services\Alerter\

Description

The Parameters subkey stores configuration data for the Alerter service. This service sends messages to users warning them of impending resource, security or access problems on the server. Alerts appear in a message box on the user's display. Typically, the Alerter service warns users when a printer is running out of paper or the disk on a file server is nearly full.

Change method

To specify users who receive alerts about this server, use the Send Administrative Alerts to preference (Computer Configuration\Windows Settings\Administrative Templates\Administrative Services) in Group Policy.


AlertNames

HKLM\SYSTEM\CurrentControlSet\Services\Alerter\Parameters

Data type | Range | Default value
REG_MULTI_SZ | Comma-separated list of user and/or computer names | (Blank)

Description

Specifies the computers and/or users notified of impending resource, security or access problems on the server. Alerts appear in a message box on the user's display. Typically, the Alerter service sends alerts when a printer is running out of paper or the disk on a file server is nearly full.

If you enter a computer name, the system notifies the current user of the computer. If the value of this entry is blank, no alerts are sent.

Change method

To change the value of this entry, use the Send Administrative Alerts to preference (Computer Configuration\Windows Settings\Administrative Templates\Administrative Services) in Group Policy.

Note Image Note

To specify a computer, enter the computer's DNS name or NetBIOS computer name. To specify a user, enter their internal (domain) user name. Do not enter an internet address.


AtmUni

HKLM\SYSTEM\CurrentControlSet\Services\

Description

The AtmUni subkey stores configuration data for the Asynchronous Transfer Mode (ATM) user-to-network interface (UNI) Call Manager. The ATM UNI Call Manager is a Windows 2000 component that creates switched and permanent virtual circuits for ATM signaling and communication.

The AtmUni\Parameters subkey stores entries that apply to all ATM network adapters. Entries that configure a particular adapter are stored in the subkey named by the GUID of the adapter in AtmUni\Parameters\Adapters.

The AtmUni subkey and its subkeys appear in the registry only after you install an ATM network adapter. The system detects the adapter and installs the Windows ATM Services and their registry elements.

By default, the AtmUni subkey contains only the standard entries associated with a Windows service. All other subkeys are empty. However, Windows ATM Services adds entries to these subkeys when you use Network and Dial-up Connections to change the default properties of an ATM connection, the ATM Call Manager, an ATM network adapter. You can also add the entries described in this file to configure your ATM adapters.


Parameters

HKLM\SYSTEM\CurrentControlSet\Services\AtmUni\

Description

The AtmUni subkey stores configuration data for the Asynchronous Transfer Mode (ATM) user-to-network interface (UNI) Call Manager. The ATM UNI Call Manager is a Windows 2000 service that creates switched and permanent virtual circuits for ATM signaling and communication.

The Parameters subkey of AtmUni stores entries that apply to all ATM network adapters.

In addition to these entries, the Parameters subkey contains an Adapters subkey which contains a subkey for each ATM network adapter installed on the system. The subkeys within AtmUni\Parameters\Adapters are named by the GUID of a particular network adapter and store entries that apply only to that adapter.


Adapters

HKLM\SYSTEM\CurrentControlSet\Services\AtmUni\Parameters\

Description

The Adapters subkey of AtmUni\Parameters stores ATM configuration data that applies only to a particular adapter. (Entries that apply to all adapters appear in the AtmUni\Parameters subkey.) This subkey enables you to configure individual adapters independently.

The Adapters subkey contains one or more subkeys, each of which represents a particular ATM network adapter and is named by the GUID of that adapter. Each of these <Adapter-GUID> subkeys stores entries that apply only to the adapter represented by the subkey.

Some entries can appear in the AtmUni\Parameters subkey and in an <Adapter-GUID> subkey. If the entry appears in both locations, the value in the <Adapter-GUID> subkey takes preference over the value in the AtmUni\Parameters subkey when configuring that particular adapter.


<Adapter-GUID>

HKLM\SYSTEM\CurrentControlSet\Services\AtmUni\Parameters\Adapters\

Description

Each <Adapter-GUID> subkey in Adapters represents a particular ATM network adapter and is named by the GUID of the adapter. The actual <Adapter-GUID> subkeys in your registry depend upon the ATM adapters installed on the computer or available to the system.

Some entries can appear in the AtmUni\Parameters subkey and in an <Adapter-GUID> subkey. If the entry appears in both locations, the value in the <Adapter-GUID> subkey takes preference over the value in the AtmUni\Parameters subkey when configuring that particular adapter.

Note Image Note

The <Adapter-GUID> subkey is a variable representing the subkeys under the HKLM\System\CurrentControlSet\Services\AtmUni\Parameters\Adapters subkey. It doesn't actually appear in the registry. This variable subkey displays the entries and subkeys that are common to many of the subkeys in Adapters.


Parameters

HKLM\SYSTEM\CurrentControlSet\Services\AtmUni\Parameters\Adapters\<Adapter-GUID>\

Description

The Parameters subkey under the <Adapter-GUID> subkey stores configuration data that applies only to the ATM network adapter represented by the subkey.

Some entries can appear in the AtmUni\Parameters subkey and in an <Adapter-GUID> subkey. If the entry appears in both locations, the value in the <Adapter-GUID> subkey takes preference over the value in the AtmUni\Parameters subkey when configuring that particular adapter.


IlmiRegisterAddresses

HKLM\SYSTEM\CurrentControlSet\Services\AtmUni\Parameters\Adapters\<Adapter-GUID>\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether ILMI is enabled on the adapter.

By default, ILMI address registration is enabled on all ATM network adapters. To disable ILMI on a particular adapter, set the value of this entry to 0 in the <Adapter-GUID> subkey representing the target adapter.

Value | Meaning
0 | ILMI is disabled.
1 | ILMI is enabled.


LogFileName

HKLM\SYSTEM\CurrentControlSet\Services\AtmUni\Parameters

Data type | Range | Default value
REG_SZ | Fully-qualified path to a text file (.txt) | There is no default value for this entry.

Description

Specifies the location of the ATMUNI event log file. If you do not add this entry to the registry, the AtmUni Call Manager does not create a log.

By adding this entry to the registry, you direct the AtmUni Call Manager to create an event log file at the specified location. To specify the types of events should be recorded in the log, use the LogFlags entry. By default, no events are recorded in the log.

The AtmUni Call Manager creates a new log file at the specified location each time the service starts and records events in that file until the service stops. There is no limit on the log file size. To prevent a particular log file from being overwritten when the service starts again, you must rename the file or change the value of this entry.

Note Image Note

The ATMUNI log file records events generated by activity all ATM network adapters. You cannot configure a log file for a particular ATM adapter.

Related Entries

LogFlags


LogFlags

HKLM\SYSTEM\CurrentControlSet\Services\AtmUni\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xF bitmask value | 0x0

Description

Determines which types of events are recorded in the ATMUNI log file. The ATMUNI log file is created only when the value of this entry is greater than 0x0 and you have added a LogFileName entry to this subkey.

The value of this entry is a bitmask. To add an event type to the log, set the bit representing that event type to 1. To indicate that a type of event should not appear in the log, set the bit representing that event type to 0. Or, sum the hexadecimal values of the event types that should appear in the log.

For example, to indicate the all event types should appear in the log, enter 0xF (1 + 2 + 4 + 8).

Value | Meaning
0x0 (0) | Do not write any events to the log. No log is created.
0x1 (01) | Failed calls
0x2 (10) | Successful calls
0x4 (100) | Abnormal call terminations
0x8 (1000) | Normal call terminations

Note Image Note

The ATMUNI log records events generated by activity all ATM network adapters. You cannot configure a log file for a particular ATM adapter.

Related Entries

LogFileName


AuthSrv

HKLM\SYSTEM\CurrentControlSet\Services\

Description

The AuthSrv subkey stores configuration data shared by the Internet Authentication Service (IAS) and Routing and Remote Access.


Parameters

HKLM\SYSTEM\CurrentControlSet\Services\AuthSrv\

Description

The AuthSrv\Parameters subkey stores configuration data shared by the Internet Authentication Service (IAS) and Routing and Remote Access.


AuthorizationDlls

HKLM\SYSTEM\CurrentControlSet\Services\AuthSrv\Parameters

Data type | Range | Default value
REG_MULTI_SZ | Names of plug-ins | Blank

Description

Lists plug-ins that are called after Remote Access policy evaluation, but before output is written to the log file. Plug-ins are identified by the fully-qualified path to the dynamic link library that implements the plug-in.

A plug-in is a software component that adds a specific feature or service. You can use plug-ins to add authentication, auditing, or accounting features to IAS and RAS. Plug-ins listed in the value of this entry must conform to requirements specified in the IAS SDK register.

Tip Image Tip

For more information about plug-ins for IAS, see the Internet Authentication Service Software Developer's Kit (IAS SDK).

Caution Image Caution

Do not change the value of this entry unless you are directed to do so by Microsoft Product Support Services. This value is maintained by the system for its internal use.


ExtensionDlls

HKLM\SYSTEM\CurrentControlSet\Services\AuthSrv\Parameters

Data type | Range | Default value
REG_MULTI_SZ | Names of plug-ins | Blank

Description

Lists the dynamic link libraries (DLLs) that are called as soon as the system receives a request (before the requesting user is authenticated). Extension DLLS are identified by the fully-qualified path to the DLL file.

Extension DLLs listed in the value of this entry must conform to requirements specified in the IAS SDK register.

Tip Image Tip

For more information about plug-ins for IAS, see the Internet Authentication Service Software Developer's Kit (IAS SDK).

Caution Image Caution

Do not change the value of this entry unless you are directed to do so by Microsoft Product Support Services. This value is maintained by the system for its internal use.


BootVerification

HKLM\SYSTEM\CurrentControlSet\Services\

Description

The BootVerification subkey stores entries for Bootvrfy.exe, a program included in Windows 2000 that notifies the system that startup was successful. Bootvrfy.exe can be run on a local or remote computer.

By default, Winlogon determines whether a startup is successful and notifies the system of its success or failure. However, you can use Bootvrfy to declare the logon successful instead. Typically, users place Bootvrfy.exe in a service group so that it runs after mission-critical applications have been loaded successfully. This ensures that startup is declared successful only after these applications have been loaded.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits it.

To run a custom startup verification program, you must disable the standard startup verification functions in Winlogon by setting the value of ReportBootOk to 0.

You cannot run Bootvrfy.exe if you are also running a custom startup verification program. Custom boot verification programs are listed in the value of ImagePath in the BootVerificationProgram subkey.

Tip Image Tip

To run Bootvrfy.exe, use a registry editor to add the BootVerification subkey to the registry. Then, add the following entries to the subkey with the values specified.

Entry name | Data type | Value
ErrorControl | REG_DWORD | 1
ImagePath | REG_EXPAND_SZ | Bootvrfy.exe
ObjectName | REG_SZ | LocalSystem
Start | REG_DWORD | 3
Type | REG_DWORD | 2

Related Entries

BootVerificationProgram subkey

ImagePath

ReportBootOk


Cdrom

HKLM\SYSTEM\CurrentControlSet\Services\

Description

The Cdrom subkey stores configuration data for CD-ROM drivers and devices.


Autorun

HKLM\SYSTEM\CurrentControlSet\Services\Cdrom

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether the system sends a Media Change Notification (MCN) message to the Windows interface when it detects that a CD-ROM is inserted in the drive. The MCN message triggers media-related features, such as Autoplay.

If the MCN message is disabled, the media features that use it do not operate.

Value | Meaning
0 | No MCN message.
1 | Sends an MCN message.

Change method

To change the value of this entry, use Device Manager.

Activation method

To make a change to this entry effective, you must restart Windows 2000.

Note Image Note

If the value of this entry is 0, Autoplay does not operate, regardless of the values of NoDriveAutoRun (in HKLM and HKCU) and NoDriveTypeAutoRun (in HKLM and HKCU).

Tip Image Tip

To disable Autoplay on particular drives, use NoDriveAutoRun (HKLM or HKCU) or NoDriveTypeAutoRun (HKLM or HKCU). Do not disable the Media Change Notification message unless you have no alternative.

Related Entries

AutoRunAlwaysDisable

NoDriveAutoRun (in HKLM)

NoDriveAutoRun (in HKCU)

NoDriveTypeAutoRun (in HKLM)

NoDriveTypeAutoRun (in HKCU)


AutoRunAlwaysDisable

HKLM\SYSTEM\CurrentControlSet\Services\Cdrom

Data type | Range | Default value
REG_MULTI_SZ | Vendor or product identfiers | (List of identified products and product groups.)

Description

Suppresses the Media Change Notification (MCN) message for particular CD-ROM devices.

By default, the system sends a Media Change Notification message when a CD-ROM is inserted in a CD-ROM device. The MCN message triggers media features, such as Autoplay. When the MCN message is suppressed, these media features do not operate.

This entry identifies devices that do not support media features. Typically, this list consists of CD-ROM changers that do not support Autoplay because they must load the media physically to verify that it is a compact disk before playing.

The entries in this list need not be complete device identifiers. The system suppresses the MCN message for all devices that begin with the characters of an entry in the list. This method makes it easier to disable media features for all products of a certain vendor or product line.

Note Image Note

If the value of this entry is not blank, it takes precedence over a value of 1 in AutoRun for the particular devices identified.

If a device is identified in this list, Autoplay does not operate on the device, regardless of the values of NoDriveAutoRun (in HKLM and HKCU) and NoDriveTypeAutoRun (in HKLM and HKCU).

The identifiers listed in this value are those reported to the system by the device. These identifiers might differ from those listed on the drive housing.

The default value for this entry consists of products and product groups that have been identified through testing as being unable to support Autoplay. This list might change as testing progresses and products are updated.

Tip Image Tip

To disable Autoplay on particular drives, use NoDriveAutoRun (HKLM or HKCU) or NoDriveTypeAutoRun (HKLM or HKCU). Do not disable the Media Change Notification message unless you have no alternative.

Caution Image Caution

Do not change the value of this entry. If you add or remove items from the list, your CD-ROM devices might not operate properly.

Related Entries

Autorun

NoDriveAutoRun (in HKLM)

NoDriveAutoRun (in HKCU)

NoDriveTypeAutoRun (in HKLM)

NoDriveTypeAutoRun (in HKCU)


Dfs

HKLM\SYSTEM\CurrentControlSet\Services\

Description

The Dfs subkey stores configuration data for Distributed file system (Dfs). Dfs helps you manage shared files that are distributed across multiple servers on a network.

Related Entries

DFSHost software subkey

DFSDriver subkey

LocalVolumes subkey

NtFrs subkey


Parameters

HKLM\SYSTEM\CurrentControlSet\Services\Dfs\

Description

The Dfs\Parameters subkey stores configuration data for Distributed file system (Dfs). Dfs helps you manage shared files that are distributed across multiple servers on a network.


DfsDriver

HKLM\SYSTEM\CurrentControlSet\Services\

Description

The DFSDriver subkey stores configuration data for the Distributed file system (Dfs) driver. Dfs helps you manage shared files that are distributed across multiple servers on a network.

Related Entries

Dfs service subkey

DFSHost software subkey

NtFrs subkey


LocalVolumes

HKLM\SYSTEM\CurrentControlSet\Services\DfsDriver\

Description

The LocalVolumes subkey stores configuration data that is specific to a local volume managed by Distributed file system (Dfs).

The LocalVolumes subkey contains a subkey for each Dfs-managed local volume on the system. The entries in each local volume subkey apply only to that volume.

Tip Image Tip

To repair a damaged Dfs root, use the Dfs snap-in. If the Dfs snap-in does not fix the root configuration and you cannot stop hosting a Dfs namespace, you can delete the Dfs root configuration. Delete the DFSHost subkey, and then delete the subkeys in the LocalVolumes subkey (in HKLM\SYSTEM\CurrentControlSet\Services\DFSDriver). Do not delete the LocalVolumes subkey.

Related Entries

Dfs service subkey

DFSHost software subkey


Dhcp

HKLM\SYSTEM\CurrentControlSet\Services\

Description

The DHCP subkey stores configuration data for the Dynamic Host Configuration Protocol (DHCP) service.

DHCP assigns IP addresses dynamically from an IP address database on a DHCP server.


Parameters

HKLM\SYSTEM\CurrentControlSet\Services\Dhcp\

Description

The DHCP\Parameters subkey stores configuration data for the Dynamic Host Configuration Protocol (DHCP) service. The entries in the Parameters subkey apply to all DHCP servers.

DHCP assigns IP addresses dynamically from an IP address database on a DHCP server.


Options

HKLM\SYSTEM\CurrentControlSet\Services\Dhcp\Parameters\

Description

The Options subkey in DHCP\Parameters stores configuration data for options that the client can request from the DHCP server by using DHCP Manager.

The Options subkey does not contain entries. Instead, it contains numbered subkeys, each of which represents a DHCP option. The entries in each <Option#> subkey apply only to the option represented by the subkey.


<Option#>

HKLM\SYSTEM\CurrentControlSet\Services\Dhcp\Parameters\Options\

Description

The DHCP\Parameters subkey contains <Option#> subkeys, which store configuration data for options that the client can request from the DHCP server by using DHCP Manager.

Most of the entries described in this file as being stored in the <Option#> subkey can appear in any of the subkeys in the Options subkey.

Note Image Note

The <Option#> subkey is a variable representing the subkeys in the DHCP\Parameters\Options subkey. It doesn't actually appear in the registry. The <Option#> subkey displays the entries and subkeys that are common to many of the subkeys in the Options subkey.


KeyType

HKLM\SYSTEM\CurrentControlSet\Services\Dhcp\Parameters\Options\<Option#>

Data type | Range | Default value
REG_DWORD | 1 - 7 | 7

Description

Specifies the data type of the registry entry that stores configuration data for the option. The data type defines the length and format of data that the entry can store.

Value | Meaning
1 | REG_SZ
2 | REG_EXPAND_SZ
3 | REG_BINARY
4 | REG_DWORD or REG_DWORD_LITTLE_ENDIAN
5 | REG_DWORD_BIG_ENDIAN
6 | REG_LINK
7 | REG_MULTI_SZ

Note Image Note

The name of the entry that stores configuration data appears in the value of RegLocation.

Tip Image Tip

Also, see Data Types in the Windows 2000 Registry.

Related Entries

RegLocation


RegLocation

HKLM\SYSTEM\CurrentControlSet\Services\Dhcp\Parameters\Options\<Option#>

Data type | Range | Default value
REG_SZ | Registry path | (Varies with the option.)

Description

Specifies the path to the registry entry that stores the data to configure the option. This data is obtained from the DHCP server.

The path to the entry can include a variable, ?, which represents the Services subkey for the network adapter. For example, if the value of RegLocation is System\CurrentControlSet\Services\?\Parameters\Tcpip\DhcpSubnetMaskOpt, it indicates that data for the option is stored in the value of DhcpSubnetMaskOpt in HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Services\AdapterName#\Parameters\Tcpip.

Tip Image Tip

The data type of the registry entry that stores configuration data appears in the value of KeyType.

Related Entries

KeyType


UseMHAsyncDns

HKLM\SYSTEM\CurrentControlSet\Services\Dhcp\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether a computer running Windows 2000 registers dynamically with the Domain Name System (DNS) servers listed in the TCP/IP Properties dialog box.

Value | Meaning
0 | Disables dynamic registration.
1 | Enables dynamic registration


DHCPServer

HKLM\SYSTEM\CurrentControlSet\Services\

Description

The DHCPServer subkey stores configuration data for the DHCP service. A Dynamic Host Configuration Protocol (DHCP) server is a Windows 2000 Server computer running Microsoft TCP/IP and the DHCP-compatible server software.

DHCP servers maintain a database of TCP/IP configuration information and provide that information to clients upon request.


Parameters

HKLM\SYSTEM\CurrentControlSet\Services\DHCPServer\

Description

The Parameters subkey stores configuration options for the DHCP Service database on this server. DHCP servers maintain a database of TCP/IP configuration information and provide that information to clients upon request.


ActivityLogFlag

HKLM\SYSTEM\CurrentControlSet\Services\DhcpServer\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether DHCP activity is audited and recorded in a log.

Value | Meaning
0 | No auditing or logging.
1 | DHCP activity is audited and logged.

Change method

To change the value of this entry, use the DHCP Manager snap-in. Right-click the name of the server, click Properties, and then click the General tab. This entry stores the value in the Enable Audit Log check box.

Note Image Note

Windows 2000 does not add this entry to the registry unless you use DHCP Manager to change the default value of this entry.


APIProtocolSupport

HKLM\SYSTEM\CurrentControlSet\Services\DhcpServer\Parameters

Data type | Range | Default value
REG_DWORD | 1 | 2 | 4 | 5 | 7 | 5

Description

A bitmask that specifies the supported protocols for the DHCP server. You can change this value to ensure that different computers running different protocols can access the DHCP server.

To enable support for a protocol, set the corresponding bit to 1, or add the hexadecimal value to the value of APIProtocolSupport. For example, to enable support for all protocols, set the value of this entry to 0x7 (111 binary).

Binary value | Hexadecimal value | Meaning
1 | 0x1 | Supports TCP/IP protocol.
10 | 0x2 | Supports named pipes protocols.
100 | 0x4 | Supports local procedure call (LPC) protocols.


BackupDatabasePath

HKLM\SYSTEM\CurrentControlSet\Services\DhcpServer\Parameters

Data type | Range | Default value
REG_EXPAND_SZ | Path | Systemroot\System32\dhcp\backup

Description

Specifies the directory where the backup copy of the DHCP client information database is stored. If you change the value of this entry, DHCP saves new backup copies to the new location, but it does not move existing backup copies of the database.

Tip Image Tip

Store the backup file on a hard drive other than the one on which the database resides. This lets you recover the database even when the system drive fails. However, because DHCP Manager cannot access a network drive for database backup and recovery, you cannot store the backup file on a network drive.

Related Entries

DatabasePath

BackupInterval


BackupInterval

HKLM\SYSTEM\CurrentControlSet\Services\DhcpServer\Parameters

Data type | Range | Default value
REG_DWORD | 1 - 71582 minutes | 60

Description

Determines how often the DHCP client information database is backed up.

Note Image Note

Because DHCP stores this value internally in milliseconds, this entry is limited to values less than 71583. When converted to milliseconds, greater values are too large to store in a DWORD field.

Related Entries

BackupDatabasePath


DatabaseCleanupInterval

HKLM\SYSTEM\CurrentControlSet\Services\DhcpServer\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF minutes | 0x5A0

Description

Determines how often the DHCP Service deletes expired ("doomed") records from the DHCP client information database. By default, records expire after four hours. Deleting expired records releases space for new IP addresses.


DatabaseName

HKLM\SYSTEM\CurrentControlSet\Services\DhcpServer\Parameters

Data type | Range | Default value
REG_SZ | Filename | dhcp.mdb

Description

Specifies the name of the file that contains the DHCP client information database.

Change method

To change the value of this entry, use DHCP Manager.

Related Entries

DatabasePath


DatabasePath

HKLM\SYSTEM\CurrentControlSet\Services\DhcpServer\Parameters

Data type | Range | Default value
REG_EXPAND_SZ | Path | Systemroot\System32\dhcp

Description

Specifies the directory where the DHCP client information database files and audit log files are stored. If you change the value of this entry, DHCP stores new database files in this location, but it does not move existing database files to the new location.

By default, database files and audit log files are stored in the same directory. The location of log files is determined by the value of DhcpLogFilePath.

Change method

To change the value of this entry, use the DHCP Manager snap-in. Right-click the name of the server, click Properties, click the Advanced tab, and enter a new path in the Database path field.

Related Entries

DatabaseName

DhcpLogFilePath


DbType

HKLM\SYSTEM\CurrentControlSet\Services\DhcpServer\Parameters

Data type | Range | Default value
REG_DWORD | 3 | 4 | 5 | 5

Description

Indicates the type of DHCP client information data in the installation. The DHCP service uses this entry to determine which version of DHCP's internal database management tools it uses.

Value | Meaning
3 | Windows NT 3.51-style database
4 | Windows NT 4.0-style database
5 | Windows 2000-style database

Note Image Note

Do not change the value of this entry unless you are directed to do so by Microsoft Product Support Services.

Windows 2000 does not add this entry to the registry unless you use DHCP Manager to change the default value of this entry.

Caution Image Caution

This value must indicate the correct database type. If the database management tools are not appropriate to the database, the DHCP service might not operate properly.


DebugFlag

HKLM\SYSTEM\CurrentControlSet\Services\DhcpServer\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF | 0

Description

This entry appears in the registry, but it is not used by Windows 2000.


DetectConflictRetries

HKLM\SYSTEM\CurrentControlSet\Services\DhcpServer\Parameters

Data type | Range | Default value
REG_DWORD | 0 - 5 retries | 0

Description

Determines how many times the DHCP service issues ICMP ping messages if the messages are not successful. When the number of unsuccessful ping messages reaches the value of this entry, the DHCP services offers a new IP address.

Change method

To change the value of this entry, use the DHCP Manager snap-in. Right-click the name of the server, click Properties, and then click the Advanced tab. This entry stores the value in the Conflict detection attempts box.

Note Image Note

The maximum valid value for this entry is 5. If you enter a value greater than 5, DHCP Service interprets it as a 5.

Windows 2000 does not add this entry to the registry unless you use DHCP Manager to change the default value of this entry.


DhcpLogDiskSpaceCheckInterval

HKLM\SYSTEM\CurrentControlSet\Services\DhcpServer\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF number of audit log entries | 0x32 (50)

Description

Determines how often DHCP verifies that disk space and file size are adequate for its audit log. The value of this entry represents the number of audit log records entered between each verification check.

Related Entries

DhcpLogMinSpaceOnDisk


DhcpLogFilePath

HKLM\SYSTEM\CurrentControlSet\Services\DhcpServer\Parameters

Data type | Range | Default value
REG_SZ | Path name | Same as DatabasePath

Description

Specifies the directory where DHCP audit logs are stored. If you change the value of this entry, DHCP moves the audit log files to the new location.

By default, the audit logs are stored in the same directory as the DHCP client information database. The location of the database is specified in the value of DatabasePath.

Change method

To change the value of this entry, use the DHCP Manager snap-in. Right-click the name of the server, click Properties, click the Advanced tab, and enter a new path in the Log file path field.

Related Entries

DatabasePath


DhcpLogFilesMaxSize

HKLM\SYSTEM\CurrentControlSet\Services\DhcpServer\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF MB | 0x7 (7 MB)

Description

Specifies the maximum combined size of one week's worth of DHCP audit logs. If the audit logs exceed the size specified by this value, DHCP stops writing to the audit log until sufficient space becomes available.


DhcpLogMinSpaceOnDisk

HKLM\SYSTEM\CurrentControlSet\Services\DhcpServer\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF MB | 0x14 (20 MB)

Description

Specifies the minimum amount of free disk space required for audit logging.

DHCP periodically verifies that it has sufficient disk space to proceed with audit logging (the interval is specified in the value of DhcpLogDiskSpaceCheckInterval. This entry specifies the minimum value it requires. If the amount of free disk space is less than the value of this entry, the DHCP service does not write to the audit log. Logging is suspended until sufficient disk space is available.

Related Entries

DhcpLogDiskSpaceCheckInterval


IgnoreBroadcastFlag

HKLM\SYSTEM\CurrentControlSet\Services\DhcpServer\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether the DHCP server complies with or ignores the value of the broadcast bit (broadcast flag) in a client DHCP Discover message.

By default, Windows 2000 DHCP servers ignore the broadcast bit on the client requests. Instead, they send all DHCP responses as IP broadcasts to the limited broadcast address (255.255.255.255). However, a DHCP server can be configured to unicast responses if the client request specifies that a broadcast response is not required.

On Microsoft DHCP clients, the broadcast bit is not set, that is, it is set to request initial Dhcpoffer and Dhcpack packets in unicast messages.

Value | Meaning
0 | Comply with broadcast flag in client request.
1 | Ignore the broadcast flag in client requests and broadcast all DHCP packets

Activation method

You must restart the system before a change to this value takes effect.

Caution Image Caution

Setting IgnoreBroadcastFlag to 0 reduces broadcast traffic. However, clients cannot receive unicast Dhcpoffer and Dhcpack packets unless the Microsoft DHCP server and DHCP client are on a homogeneous Ethernet network or the same subnet of a Token Ring network. Do not change the default broadcast behavior of a Microsoft DHCP server if the server and client are on different Token Ring subnets or are separated by a router or bridge that does MAC level address translation, for example, Ethernet to or from Token Ring.


MaxActiveThreads

HKLM\SYSTEM\CurrentControlSet\Services\DhcpServer\Parameters

Data type | Range | Default value
REG_DWORD | 0 - 20 | 1

Description

Used to calculate the maximum number of DHCP message processing threads that can be active at any given time. The DHCP service will activate no more threads than the value of this entry plus one thread for each processor on the server computer.

The value of this entry must be less than or equal to the value of the MaxProcessingThreads entry. If you enter a higher value, the system uses the value of MaxProcessingThreads.

Related Entries

MaxProcessingThreads


MaxProcessingThreads

HKLM\SYSTEM\CurrentControlSet\Services\DhcpServer\Parameters

Data type | Range | Default value
REG_DWORD | 1 - 20 | 1 1

Description

Used to calculate the maximum number of message processing threads the DHCP service can create. The DHCP service will create no more threads than the value of this entry plus one thread for each processor on the server computer.

This value must be greater than or equal to the value of MaxActiveThreads.

Related Entries

MaxActiveThreads


RestoreFlag

HKLM\SYSTEM\CurrentControlSet\Services\DhcpServer\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

This registry entry represents enables an optional feature that is not fully implemented or tested in Windows 2000. Do not change the value of this entry.


DNS

HKLM\SYSTEM\CurrentControlSet\Services\

Description

The DNS subkey stores configuration information for the Domain Name System (DNS) server.

DNS associates IP addresses and other data identifying a computer with the computer's display name, such as host.reskit.com.

Activation method

DNS reads its registry entries only when it starts. You can change entries while the DNS server is running by using the DNS console. If you change entries by editing the registry, the changes are not effective until you restart the DNS server.

Tip Image Tip

This subkey stores data for the DNS server. To configure DNS dynamic update on the DNS client, see the following entries in the Tcpip subkey:
DefaultRegistrationTTL
EnableAdapterDomainNameRegistration
DisableDynamicUpdate
DisableReplaceAddressesInConflicts
DisableReverseAddressRegistrations
UpdateSecurityLevel


Parameters

HKLM\SYSTEM\CurrentControlSet\Services\DNS\

Description

The DNS\Parameters subkey stores DNS configuration data that applies to all zones in the network. Settings that apply to a specific zone are stored in a subkey representing that zone in the DNS\Zones subkey.


AddressAnswerLimit

HKLM\SYSTEM\CurrentControlSet\Services\DNS\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 5 - 28 records | 0

Description

Specifies the maximum number of A (host IP address) records that the DNS server is permitted to insert in the answer section of a response to an A record query (a query for an IP address). The value of this entry also influences the setting of the truncation bit. If the value of this entry is between 5 and 28, the truncation bit is not set on the response, even when the packet space is exceeded.

The value of AddressAnswerLimit is imposed upon A record queries only; it does not affect other types of queries.

Value | Meaning
0 | There is no limit on the number of A records in a response. If the response, including all A records, does not fit in a UDP DNS packet, the truncation bit is set.
5 - 28 | The maximum permissible number of A records in a response. The truncation bit is not set, regardless of the size of the response.

Change method

To change the value of this entry, use Dnscmd.exe, a tool included with the Windows 2000 Support Tools. The change is effective immediately; you do not have to restart the DNS server.

Activation method

DNS reads its registry entries only when it starts. You can change entries while the DNS server is running by using the DNS console. If you change entries by editing the registry, the changes are not effective until you restart the DNS server.

Note Image Note

This entry was designed to resolve a problem in DNS for Windows 95 (without service packs) in which DNS fails when it receives more than 28 A records in a response to an A query. This occurs infrequently and only when numerous servers are supporting a Web site. However, because the truncation bit is not set, limiting A records has the added benefit of preventing remote DNS servers from using TCP to retry these queries. DNS servers often use TCP to retry queries when they receive a response with the truncation bit set.

DNS does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry, such as Dnscmd.exe.


AutoConfigFileZones

HKLM\SYSTEM\CurrentControlSet\Services\DNS\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 2 | 3 | 1

Description

Determines whether the DNS server updates the resource records of standard primary zones when the fully qualified domain name (that is, the name or the primary DNS suffix) of the local computer changes.

This entry establishes criteria for zone updates. If a zone meets the criteria, then, when the fully qualified domain name of the local computer changes, the DNS server updates the host name on resource records that include the local computer name, such as SOA, NS, and A records. Otherwise, the records are not updated when the computer name changes.

Value | Meaning
0 | No zones. The DNS server does not update resource records when the local computer name changes.
1 | Dynamic update zones. The DNS server only updates resource records of standard primary zones that permit dynamic updates.
2 | No dynamic update zones. The DNS server only updates resource records of standard primary zones that do not permit dynamic updates.
3 | All zones. The DNS server updates the resource records of all standard primary zones.

Activation method

DNS reads its registry entries only when it starts. You can change entries while the DNS server is running by using the DNS console. If you change entries by editing the registry, the changes are not effective until you restart the DNS server.

Tip Image Tip

To find other registry entries related to DNS dynamic update, type "dynamic update" on the Search tab in this file.

Related Entries

PreviousLocalHostname


BindSecondaries

HKLM\SYSTEM\CurrentControlSet\Services\DNS\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Enables the server running DNS to interoperate with non-Microsoft DNS servers that use an older, slower version of the DNS BIND service.

Value | Meaning
0 | The Microsoft DNS server places as many resource records as possible in each message to achieve maximum compression and speed of transfer. Microsoft DNS servers and non-Microsoft DNS servers that use BIND version 4.9.4 or higher can receive transfers in this format.
1 | The Microsoft DNS server sends zone transfers to non-Microsoft DNS secondaries with one resource record per message. Non-Microsoft DNS servers using BIND versions prior to 4.9.4 cannot receive the transfer unless it is in this single resource record per message format.

Change method

To change the value of this entry, use the DNS console. Right-click the server name, click Properties, click the Advanced tab. This entry corresponds to the Bind Secondaries option in the Advanced server options list.

Activation method

DNS reads its registry entries only when it starts. You can change entries while the DNS server is running by using the DNS console. If you change entries by editing the registry, the changes are not effective until you restart the DNS server.

Note Image Note

Transfers between Microsoft DNS servers always use the faster, high-compression method, regardless of the value of BindSecondaries.

The default value is appropriate for most DNS servers. Set this value to 0 only when you have NEW BIND servers (or non-BIND, non-Windows servers) which are secondaries to Microsoft DNS server and transfer performance is a high priority.


BootMethod

HKLM\SYSTEM\CurrentControlSet\Services\DNS\Parameters

Data type | Range | Default value
REG_DWORD | 0 - 3 | 3

Description

Determines the source of information DNS uses to start, such as settings to configure the DNS Service, a list of authoritative zones, and configuration settings for the zones.

Value | Meaning
0 | Undefined. This entry does not provide the source of startup information.
1 | Traditional BIND file. DNS searches for startup information in a standard, BIND-style file called Boot in the Systemroot\System32\DNS directory on the local hard drive. DNS uses the information defined in this file, but looks in the DNS subkeys in the registry for any startup information that does not appear in the file.
2 | Registry. DNS starts by using the server configuration and zone information stored in the registry in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\DNS.
3 | Active Directory and registry. DNS searches for startup information by using the Windows 2000 Active Directory and the registry. DNS uses the information defined in Active Directory, and looks in the DNS subkeys in the registry for server-specific and zone-specific information that does not appear in Active Directory. DNS compiles its list of authoritative zones from Active Directory and the registry.

Change method

To change the value of this entry, use the DNS console. Right-click the server name, click Properties, click the Advanced tab. This entry corresponds to the Boot method drop-down list.

Activation method

DNS reads its registry entries only when it starts. You can change entries while the DNS server is running by using the DNS console. If you change entries by editing the registry, the changes are not effective until you restart the DNS server.

Note Image Note

This entry is designed to replace EnableRegistryBoot which determined the source of startup DNS information in Windows NT 4.0 prior to Service Pack 4. If EnableRegistryBoot appears in the registry of a computer running Windows 2000, DNS sets BootMethod to the corresponding value and uses BootMethod thereafter.

The new BIND file style for configuring DNS servers is not supported by DNS for Windows 2000.

Related Entries

EnableRegistryBoot

Type


DatabaseDirectory

HKLM\SYSTEM\CurrentControlSet\Services\DNS\Parameters

Data type | Range | Default value
REG_SZ | Directory path | Systemroot\System32\Dns

Description

Specifies the directory that contains the DNS database.

By default, the DNS database is located in Systemroot\System32\Dns, but you can add this entry to the registry to change the default location. If you do, the DNS server loads from and writes new zone records to the new location. If you already have a DNS database in Systemroot\System32\Dns, you must move it to the new location manually. DNS will not move or maintain the original database.

Activation method

DNS reads its registry entries only when it starts. To make changes to this entry effective, restart DNS.

Note Image Note

BIND files must be located in the Systemroot\System32\Dns directory, regardless of the value of this entry.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

BootMethod

EnableRegistryBoot

DsIntegrated

DatabaseFile


DefaultAgingState

HKLM\SYSTEM\CurrentControlSet\Services\DNS\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether the DNS scavenging feature is enabled by default on newly created Active Directory–integrated zones.

When scavenging, the DNS server inspects the timestamps of resource records for this zone in the DNS database and deletes records that are out of date.

Value | Meaning
0 | Scavenging is disabled by default on new Active Directory–integratedzones. The DNS server does not delete old resource records.
1 | Enables scavenging by default on new Active Directory–integratedzones.

When you create a new Active Directory–integrated zone, the system copies the value of this entry into the value of Aging in the <Zone-name> subkey for the new zone and uses the value of Aging thereafter.

Change method

To change the value of this entry, use the DNS console. Right-click the name of a server, and then click Set Aging/Scavenging for all zones.

Activation method

DNS reads its registry entries only when it starts. You can change entries while the DNS server is running by using the DNS console. If you change entries by editing the registry, the changes are not effective until you restart the DNS server.

Note Image Note

By default, scavenging is disabled on the DNS server and on all zones. To enable scavenging for any zone, you must enable it on the DNS server (as specified in ScavengingInterval) and on the zone (as specified by the value of Aging). If scavenging is disabled on the DNS server, all entries that configure scavenging on any zone are ignored.

Tip Image Tip

You can apply this value to existing Active Directory–integrated zones by selecting the Apply these settings to the existing Active Directory–integrated zones option on the Server Aging/Scavenging Confirmation dialog box.

Caution Image Caution

DNS adds this entry to the registry when you use the DNS console to configure scavenging. Do not edit the registry to add, delete or change this value.

Related Entries

Aging

ScavengingInterval

RefreshInterval

DefaultRefreshInterval

NoRefreshInterval

DefaultNoRefreshInterval


DefaultNoRefreshInterval

HKLM\SYSTEM\CurrentControlSet\Services\DNS\Parameters

Data type | Range | Default value
REG_DWORD | 0x1 - 0xFFFFFFFF hours | 0xA8 (168 hours = 1 week)

Description

Specifies the duration of the no-refresh interval for newly created Active Directory–integrated zones.

The no-refresh interval is the period during which servers cannot update the timestamp of the resource record and the scavenging feature cannot delete the record. The no-refresh interval is designed to improve the performance of Active Directory-related services by concentrating write operations for a record.

When you create a new Active Directory–integrated zone, the system copies the value of this entry into the value of NoRefreshInterval in the <Zone-name> subkey for the new zone and uses the value of NoRefreshInterval thereafter.

Change method

To change the value of this entry, use the DNS console. Right-click the name of a server, and then click Set Aging/Scavenging for all zones.

Activation method

DNS reads its registry entries only when it starts. You can change entries while the DNS server is running by using the DNS console. If you change entries by editing the registry, the changes are not effective until you restart the DNS server.

Note Image Note

By default, scavenging is disabled on the DNS server and on all zones. To enable scavenging for any zone, you must enable it on the DNS server (as specified in ScavengingInterval) and on the zone (as specified by the value of Aging). If scavenging is disabled on the DNS server, all entries that configure scavenging on any zone are ignored.

Tip Image Tip

You can apply this value to existing Active Directory–integrated zones by selecting the Apply these settings to the existing Active Directory–integrated zones option on the Server Aging/Scavenging Confirmation dialog box.

Caution Image Caution

DNS adds this entry to the registry when you use the DNS console to configure scavenging. Do not edit the registry to add, delete or change this value.

Related Entries

Aging

ScavengingInterval

DefaultAgingState

RefreshInterval

DefaultRefreshInterval

NoRefreshInterval


DefaultRefreshInterval

HKLM\SYSTEM\CurrentControlSet\Services\DNS\Parameters

Data type | Range | Default value
REG_DWORD | 0x1 - 0xFF hours | 0xA8 (168 hours = 1 week)

Description

Specifies the duration of the refresh interval for newly created Active Directory–integrated zones.

The refresh interval is the time during which the server can update the timestamp of a resource record. During its refresh interval, a record is protected and cannot be deleted by the scavenging feature of the DNS server.

When you create a new Active Directory–integrated zone, the system copies the value of this entry into the value of RefreshInterval in the <Zone-name> subkey for the new zone and uses the value of RefreshInterval thereafter.

Change method

To change the value of this entry, use the DNS console. Right-click the name of a server, and then click Set Aging/Scavenging for all zones.

Activation method

DNS reads its registry entries only when it starts. You can change entries while the DNS server is running by using the DNS console. If you change entries by editing the registry, the changes are not effective until you restart the DNS server.

Note Image Note

By default, scavenging is disabled on the DNS server and on all zones. To enable scavenging for any zone, you must enable it on the DNS server (as specified in ScavengingInterval) and on the zone (as specified by the value of Aging). If scavenging is disabled on the DNS server, all entries that configure scavenging on any zone are ignored.

Tip Image Tip

You can apply this value to existing Active Directory–integrated zones by selecting the Apply these settings to the existing Active Directory–integrated zones option on the Server Aging/Scavenging Confirmation dialog box.

Caution Image Caution

DNS adds this entry to the registry when you use the DNS console to configure scavenging. Do not edit the registry to add, delete or change this value.

Related Entries

Aging

ScavengingInterval

DefaultAgingState

RefreshInterval

NoRefreshInterval

DefaultNoRefreshInterval


DisableAutoReverseZones

HKLM\SYSTEM\CurrentControlSet\Services\DNS\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Enables and disables automatic reverse zones, an optimizing feature of DNS. When automatic reverse zones is enabled, DNS automatically creates three reverse lookup zones.

Reverse lookup zones enable the DNS server to be authoritative, that is, to know the answer in advance and to respond immediately to the most common name queries, eliminating unnecessary recursive queries. In accordance with pertinent RFCs, by default, the DNS server is authoritative for three reverse lookup zones:

  • 0.in-addr.arpa (0.0.0.0)
  • 127.in-addr.arpa (127.0.0.1 - loopback)
  • 255.in-addr.arpa (255. 255. 255. 255 - broadcast)
Value | Meaning
0 | The automatic reverse zones feature is enabled. The DNS server automatically creates three reverse lookup zones.
1 | Disables automatic reverse zones. The DNS server does not create reverse lookup zones automatically.

Change method

To change the value of this entry, use Dnscmd.exe, a tool included with the Windows 2000 Support Tools, and then restart the DNS server. Please note that changing this entry is not recommended.

Activation method

Because the DNS server creates zones only when it starts, you must restart the DNS server to make changes to this entry effective, even when using Dnscmd to make the change.

Note Image Note

DNS does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry, such as Dnscmd.exe.

Caution Image Caution

Do not change the value of this entry unless instructed to by Microsoft Product Support. Using automatic reverse zones improves the performance of the DNS server. The default value is optimal for almost all DNS server configurations.


EnableRegistryBoot

HKLM\SYSTEM\CurrentControlSet\Services\DNS\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines the source of information DNS uses to start, such as settings to configure DNS, a list of authoritative zones, and configuration settings for the zones.

In Windows 2000, the EnableRegistryBoot entry has been replaced by BootMethod. If EnableRegistryBoot appears in the registry, DNS uses its value to set the value of BootMethod, and then uses BootMethod thereafter.

Value | Meaning
0 | File. DNS searches for startup information in a standard, BIND-style file called Boot in the Systemroot\System32\DNS directory on the local hard drive. DNS uses the information defined in this file, but looks in the DNS subkeys in the registry for any startup information that does not appear in the file.
1 | Registry. DNS starts only by using the server configuration and zone information stored in the registry in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\DNS. It does not use a boot file.

Activation method

DNS reads its registry entries only when it starts. You can change entries while the DNS server is running by using the DNS console. If you change entries by editing the registry, the changes are not effective until you restart the DNS server.

Note Image Note

This entry is included in the registry for compatibility with Windows NT 4.0 and earlier. For Windows 2000, use BootMethod.

The default startup behavior of the DNS server, as described above, applies only to Windows 2000 and Windows NT 4.0 with Service Pack 4. Prior to Service Pack 4, the DNS server started by using values from the boot file, but began storing values in the registry as soon as you used the DNS snap-in to change a value that affected the boot file. For more information, see the Windows NT 4.0 Resource Kit.

Tip Image Tip

To configure DNS dynamic update, see the following entries in the Tcpip subkey:
DefaultRegistrationTTL
EnableAdapterDomainNameRegistration
DisableDynamicUpdate
DisableReplaceAddressesInConflicts
DisableReverseAddressRegistrations
UpdateSecurityLevel

Related Entries

BootMethod


EventLogLevel

HKLM\SYSTEM\CurrentControlSet\Services\DNS\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 2 | 4 | 4

Description

Determines which events the DNS service records in the DNS Server log in Event Viewer.

Value | Meaning
0 | None. The DNS Service does not record events in any Event Viewer log.
1 | Errors only.
2 | Errors and warnings.
4 | All events -- errors, warnings, and informational events.

Change method

To change the value of this entry, use Dnscmd.exe, a tool included with the Windows 2000 Support Tools. The change is effective immediately; you do not have to restart the DNS server.

Activation method

DNS reads its registry entries only when it starts. You can change entries while the DNS server is running by using Dnscmd.exe. If you change entries by editing the registry, the changes are not effective until you restart the DNS server.

Note Image Note

DNS creates the DNS Server Log in Event Viewer when you install the DNS and restart the system. Until you restart, DNS writes its events to the System Log in Event Viewer.

Related Entries

EventLog subkey


ForwardDelegations

HKLM\SYSTEM\CurrentControlSet\Services\DNS\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether the DNS server forwards queries about delegated subzones to servers outside of its authoritative zone. This entry is used only when the delegated subzone is within the DNS server's authoritative zone, even though the primary server for the subzone is in another zone.

By default, when the DNS server receives a query for a name outside its authoritative zone, it forwards the query to a similarly-named server in another zone. However, when it receives a query for a delegated subzone, and the subzone is within the DNS server's zone (even when the primary server for the site is in another zone), it sends the query directly to the subzone, and does not forward it. When the value of this entry is 1, the DNS server forwards queries for delegated subzones to other servers, just as it does for names in other zones.

You might consider adding this entry and setting it to 1 if the delegation was at a remote site that was more easily reached by a remote server.

Value | Meaning
0 | The DNS server sends queries about delegated subzones that are within its authoritative zone directly to the subzone. It does not forward them.
1 | The DNS server forwards all name queries about delegated subzones to servers in other zones.

Change method

To change the value of this entry, use Dnscmd.exe, a tool included with the Windows 2000 Support Tools. The change is effective immediately; you do not have to restart the DNS server.

Activation method

DNS reads its registry entries only when it starts. You can change entries while the DNS server is running by using Dnscmd.exe. If you change entries by editing the registry, the changes are not effective until you restart the DNS server.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry, such as Dnscmd.exe.

This entry is used only when forwarding is enabled. If the value of Forwarders does not contain at least one valid IP address, this entry is ignored.

Related Entries

Forwarders

IsSlave

NoRecursion


Forwarders

HKLM\SYSTEM\CurrentControlSet\Services\DNS\Parameters

Data type | Range | Default value
REG_SZ | IP address[, IP address] ... (dotted decimal form) | (Blank)

Description

Specifies the servers (as identified by their IP addresses) to which the DNS server forwards queries for names outside of its authoritative zone. Queries to the servers in the forwarders list are performed recursively, not iteratively, on behalf of the querying client. By default, no forwarding servers are specified and the DNS server sends name queries to other servers iteratively.

You might consider specifying a list of forwarding servers in the DNS console if the DNS server is communicating across slow links, or if you are intentionally querying a specific server in order to accumulate a name cache on that server.

Change method

To change the value of this entry use the Forwarders tab in the DNS console or use Dnscmd.exe, a tool included with the Windows 2000 Support Tools. The change is effective immediately; you do not have to restart the DNS server.

Activation method

DNS reads its registry entries only when it starts. You can change entries while the DNS server is running by using the DNS console. If you change entries by editing the registry, the changes are not effective until you restart the DNS server.

Note Image Note

If you start DNS by using a standard BIND file, the value of Forwarders in the BIND file takes precedence over the value of this registry entry. The entry might be deleted or its value replaced by the value in the BIND file.

the DNS snap-in does not add this entry to the registry unless you use the Forwarders tab to change the default value.

Tip Image Tip

In general, a single forwarder is more efficient than multiple forwarders, because query results are concentrated in one forwarder's cache. To indicate that a forwarder should be queried more than once if an initial query is unsuccessful, list the IP address of the forwarder more than once on the Forwarders tab.

Related Entries

IsSlave


ForwardingTimeout

HKLM\SYSTEM\CurrentControlSet\Services\DNS\Parameters

Data type | Range | Default value
REG_DWORD | 0x1 - 0xFFFFFFFF seconds | 0x5

Description

Determines how long DNS waits for each server in the list in Forwarders to respond to a query. If a forwarder server does not respond before the time specified here expires, the DNS server forwards the query to the next forwarder server in the Forwarders list. If none of the forwarder servers respond in the time specified by ForwardingTimeout, the value of IsSlave determines how the DNS server responds to the original query.

Change method

To change the value of this entry, use the Forwarders tab in the DNS console, or use Dnscmd.exe, a tool included with the Windows 2000 Support Tools. Using either method, your change is effective immediately; you do not have to restart the DNS server.

Activation method

DNS reads its registry entries only when it starts. You can change entries while the DNS server is running by using the DNS console or Dnscmd.exe. If you change entries by editing the registry, the changes are not effective until you restart the DNS server.

Note Image Note

DNS adds this entry to the registry when you use the DNS Server Properties dialog box to enable forwarders.

This entry is used only when forwarding is enabled. If the value of Forwarders does not contain at least one valid IP address, this entry is ignored.

Zero (0x0) is not a valid value for this entry. If you enter 0x0, DNS uses the default value, 0x5.

This value is used only when it is less than the value of RecursionTimeout. If it is greater, the DNS server uses the value of RecursionTimeout.

Caution Image Caution

Do not change the value of this entry by editing the registry. If the Forwarders entry contains valid IP addresses and this entry is deleted, the DNS server might not start or might not operate properly.

Related Entries

Forwarders

IsSlave

RecursionRetry

RecursionTimeout


IsSlave

HKLM\SYSTEM\CurrentControlSet\Services\DNS\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines how the DNS server responds when it does not receive a response to a query it has forwarded.

Value | Meaning
0 | Not a slave. If the forwarder servers do not respond, the DNS server issues standard iterative queries to try to resolve the remote name.
1 | Is a slave. If the forwarder servers do not respond, the DNS server terminates the search and sends a SERVER_FAILURE response to the query.

Change method

To change the value of this entry, use the Do not use recursion check box on the Forwarders tab in the DNS console. You can also use Dnscmd.exe, a tool included with the Windows 2000 Support Tools. Your changes are effective immediately; you do not have to restart the DNS server.

Activation method

DNS reads its registry entries only when it starts. You can change entries while the DNS server is running by using the DNS console or Dnscmd.exe. If you change entries by editing the registry, the changes are not effective until you restart the DNS server.

Note Image Note

If you start DNS by using a standard BIND file, the value of Slave in the BIND file takes precedence over the value of this registry entry. The entry might be deleted or its value replaced by the value in the BIND file.

This entry is used only when forwarding is enabled, that is, when the value of Forwarders includes at least one valid IP address.

Tip Image Tip

In general, a single forwarder is more efficient than multiple forwarders, because query results are concentrated in one forwarder's cache. To indicate that a forwarder should be queried more than once if an initial query is unsuccessful, list the IP address of the forwarder more than once on the Forwarders tab.

Caution Image Caution

Do not change the value of this entry by editing the registry. If the Forwarders entry contains valid IP addresses and this entry is deleted, the DNS server might not start or might not operate properly.

Related Entries

Forwarders


ListenAddresses

HKLM\SYSTEM\CurrentControlSet\Services\DNS\Parameters

Data type | Range | Default value
REG_BINARY | IP address[, IP address] ... (dotted decimal form) | (Blank)

Description

Lists the IP addresses bound to the DNS server. If there are no addresses in the value of this entry or if this entry does not appear in the registry, the DNS server attempts to bind to all IP addresses on the computer.

The default value is optimal for most servers. However, you might need to exclude certain interfaces, especially if you are running Windows NT 4.0 SP1 or earlier, which cannot bind to more than 15 IP addresses. Also, on Windows NT 4.0 and earlier and Windows 2000, the DNS server does not detect and bind to more than 35 interfaces properly.

Change method

To change the value of this entry, use the Interfaces dialog in the DNS console or Dnscmd.exe, a tool included with the Windows 2000 Support Tools. Your changes are effective immediately; you do not have to restart the DNS server.

Activation method

DNS reads its registry entries only when it starts. You can change entries while the DNS server is running by using the DNS console. If you change entries by editing the registry, the changes are not effective until you restart the DNS server.

Note Image Note

This feature does not usually improve the performance of DNS servers running Windows 2000.


LocalNetPriority

HKLM\SYSTEM\CurrentControlSet\Services\DNS\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines the order in which the DNS server returns A records (requests for IP addresses) when it has multiple A records for the same name.

Value | Meaning
0 | The DNS server returns the A records in a the order in which they were added to the database. It does not sort them. If the value of RoundRobin is 1, the server rotates among the records it returns.
1 | The DNS server returns records in order of their similarity to the IP address of the querying client.

Change method

To change the value of this entry, use the DNS console. Right-click the server name, click Properties, click the Advanced tab. This entry corresponds to the Enable Netmask Ordering option. You can also use Dnscmd.exe, a tool included with the Windows 2000 Support Tools. With either method, your changes are effective immediately; you do not have to restart the DNS server.

Activation method

DNS reads its registry entries only when it starts. You can change entries while the DNS server is running by using the DNS console or Dnscmd.exe. If you change entries by editing the registry, the changes are not effective until you restart the DNS server.

Note Image Note

The order in which A records are returned depends on the value of LocalNetPriority and the value of RoundRobin, as follows:

  • When both are set to 1 (or neither entry appears in the registry), the DNS server rotates among the A records it returns in local net priority order, that is, in order of their similarity to the IP address of the querying client.
  • If the value of RoundRobin is 0 and the value of LocalNetPriority is 1, the DNS server returns the records in local net priority order. It does not rotate among available addresses.
  • If the value of RoundRobin is 1 and the value of LocalNetPriority is 0, the DNS server rotates among the available record in the order in which the records were added to the database.
  • If the values of RoundRobin and LocalNetPriority are 0, the DNS server returns the records in the order in which they were added to the database. It does not attempt to sort them or rotate its returns from among them.

Related Entries

RoundRobin


LogFileMaxSize

HKLM\SYSTEM\CurrentControlSet\Services\DNS\Parameters

Data type | Range | Default value
REG_DWORD | 0x10000 (64 KB) - 0xFFFFFFFF bytes | 0x400000 (4 MB)

Description

Specifies the maximum permissible size of the DNS transaction log, Dns.log. When the log reaches the specified maximum size, DNS writes over the oldest transactions.

Activation method

DNS reads its registry entries only when it starts. Changes are not effective until you restart the DNS server.

Note Image Note

If you enter a value less than 64 KB (0x10000), the system sets the maximum log size to 64 KB.

Related Entries

LogLevel

LogFilePath


LogFilePath

HKLM\SYSTEM\CurrentControlSet\Services\DNS\Parameters

Data type | Range | Default value
REG_DWORD | Path and name | %SystemRoot%\System32\dns\dns.log

Description

Specifies the file name and location of the DNS transaction log, known by default as Dns.log.

If you change the value of this entry, DNS creates new log files in the specified directory, but it does not move existing log files to the new location. Also, DNS does not delete or maintain log files in the original location.

Activation method

DNS reads its registry entries only when it starts. Changes are not effective until you restart the DNS server.

Caution Image Caution

You must enter a file name, as well as a path, in the value of this entry. If you omit the name, DNS interprets the name of the final directory as a file name. For example, if you enter C:\temp, then DNS creates a file called temp and stores it in the root of the C: drive.

Related Entries

LogLevel

LogFileMaxSize


LogLevel

HKLM\SYSTEM\CurrentControlSet\Services\DNS\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 | 0x1 | 0x10 | 0x20 | 0xFE| 0x100 | 0x200 | 0x1000 | 0x2000 | 0x4000 | 0x8000 | 0xFFFF | 0x10000 | 0x20000 | 0x1000000 | 0x80000000 | 0x0

Description

Determines which events the DNS server records in its transaction log, Dns.log.

LogLevel is a 32-bit binary value. To direct DNS to log a type of event, the DNS console sets the value of this entry to the value representing that event type, as listed below. To direct DNS to log more than one type of event, the DNS console sets the value of this entry to the sum of the values representing each event type you want to include in the log.

To get a complete log, set the value of this entry to 0x8100F331.

Value | Meaning
0x0 | None. The DNS Service does not create Dns.log.
0x1 | Queries
0x10 | Notifications
0x20 | Updates
0xFE | Non-query transactions
0x100 | Questions
0x200 | Answers
0x1000 | Send packets
0x2000 | Receive packets
0x4000 | UDP packets
0x8000 | TCP packets
0xFFFF | All packets
0x10000 | Active Directory write transaction
0x20000 | Active Directory update transaction
0x1000000 | Full packets
0x80000000 | Write-through transactions

Change method

To change the value of this entry, use the DNS console. Right-click the server name, click Properties, click the Logging tab. This bitmask corresponds to the check boxes in the Debug logging options section. Do not change this value by editing the registry.

Activation method

DNS reads its registry entries only when it starts. You can change entries while the DNS server is running by using the DNS console. If you change entries by editing the registry, the changes are not effective until you restart the DNS server.

Related Entries

EventLogLevel

LogFilePath

LogFileMaxSize


LooseWildcarding

HKLM\SYSTEM\CurrentControlSet\Services\DNS\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether the DNS server uses loose wildcarding, as it did in Windows NT 4.0 and earlier. This method does not strictly comply with standards for using the wildcard character in resource records, as specified by RFC 1034.

Value | Meaning
0 | Do not use loose wildcarding. Records must match the name and record type specified in a name query. Otherwise, the DNS server returns an "empty" response, meaning that no match was found. This setting complies with RFC 1034.
1 | Use loose wildcarding. If no resource record matches the name and type specified in the query, the DNS server searches for a related wildcard record of the type specified in the query. Then, the DNS server returns a resource record that matches the wildcard pattern.

Activation method

DNS reads its registry entries only when it starts. If you change the value of this entry by editing the registry, the changes are not effective until you restart the DNS server.

Note Image Note

The default method that the DNS server uses to resolve queries that contain wildcards is changed for Windows 2000. In Windows NT 4.0 and earlier, by default, the DNS server did not comply with RFC 1034. Instead, it searched until it found a record that matched the name and record type in the query.

Tip Image Tip

If your hosts can receive mail, the default value is optimal. However, if you advertise hosts that are not mail servers, you should add MX records for each host to the DNS. If you set the value of this entry to 1, just two MX records can satisfy all queries for the authoritative zone.


MaxCacheTtl

HKLM\SYSTEM\CurrentControlSet\Services\DNS\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 | 0x1 - 0xFFFFFFFF seconds | 0x15180 (86,400 seconds = 1 day)

Description

Determines how long a record of a recursive name query can be saved by the DNS server.

If the value of this entry is 0x0, the DNS server does not save any records.

The DNS server saves the records of recursive names queries in a memory cache so that it can respond quickly to new queries for the same name. Records are deleted from the cache periodically to keep the cache content current. The interval during which the record remain in the cache usually is determined by the value of the Time to Live (TTL) field in the record. MaxCacheTtl establishes the maximum time that records can remain in the cache. The DNS server deletes records from the cache when the value of this entry expires, even if the value of the TTL field in the record is greater.

Change method

To change the value of this entry, use Dnscmd.exe, a tool included with the Windows 2000 Support Tools. The change is effective immediately; you do not have to restart the DNS server.

Activation method

DNS reads its registry entries only when it starts. If you change the value of this entry by editing the registry, the changes are not effective until you restart the DNS server.

Note Image Note

This entry does not affect WINS data saved in the DNS memory cache. WINS data is saved until the Cache Timeout Value on the WINS record expires. To view or change the Cache Timeout Value on the WINS record, use the DNS snap-in. Right-click a zone name, click Properties, click the WINS tab, and click the Advanced button.


NameCheckFlag

HKLM\SYSTEM\CurrentControlSet\Services\DNS\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 2 | 3 | 2

Description

Specifies which character standard is applied to DNS names. The standard determines which characters are permitted in DNS names and which are prohibited.

Value | Meaning
0 | RFC-compliant ANSI characters
1 | Non-RFC-compliant ANSI characters
2 | Multibyte UTF8 characters
3 | Permit all characters.

Change method

To change the value of this entry, use the DNS console. Right-click a DNS server, click Properties, click the Advanced tab and then, in the Name checking list box, click the name of the desired standard. Or, use Dnscmd.exe, a tool included with the Windows 2000 Support Tools. Using either method, your changes are effective immediately; you do not have to restart the DNS server.

Activation method

DNS reads its registry entries only when it starts. You can change entries while the DNS server is running by using the DNS console or Dnscmd.exe. If you change entries by editing the registry, the changes are not effective until you restart the DNS server.


NoRecursion

HKLM\SYSTEM\CurrentControlSet\Services\DNS\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether the DNS server performs recursive resolution in accordance with the NoResolution bit in the DNS name query packet header.

Value | Meaning
0 | The DNS server acts in accordance with the NoRecursion bit set in the packet header.
1 | The DNS server does not perform recursive resolution regardless of the setting of the NoResolution bit in the packet header.

You might consider changing the NoRecursion value if clients are limited to the names on a server, such as within an intranet, or when the server is not capable of resolving external names.

Change method

To change the value of this entry, use the DNS console. Right-click the server name, click Properties, click the Advanced tab. This entry corresponds to the Disable Recursion option. Or, use Dnscmd.exe, a tool included with the Windows 2000 Support Tools. Using either method, your changes are effective immediately; you do not have to restart the DNS server.

Do not change this value by editing the registry.

Activation method

DNS reads its registry entries only when it starts. You can change entries while the DNS server is running by using the DNS console or Dnscmd.exe. If you change entries by editing the registry, the changes are not effective until you restart the DNS server.

Note Image Note

If you start DNS by using a standard BIND file, the value of NoRecursion in the BIND file takes precedence over the value of this registry entry. The entry might be deleted or its value replaced by the value in the BIND file.


PreviousLocalHostname

HKLM\SYSTEM\CurrentControlSet\Services\DNS\Parameters

Data type | Range | Default value
REG_SZ | Fully qualified domain name | (Fully qualified domain name of the local computer)

Description

Stores the fully qualified domain name of the local computer. When the computer name or the primary DNS suffix changes, the DNS server uses the previous name to update resource records on primary, Active Directory–integrated zones.

The DNS server copies the name of the local computer (stored in the value of Hostname in Tcpip\Parameters) and the primary DNS suffix (stored in the value of PrimaryDnsSuffix) to the value of PreviousLocalHostname. If the computer name or primary DNS suffix changes, the DNS server searches SOA, NS and A resource records for the value of PreviousLocalHostname and replaces each instance with the new computer name. Then, it copies the new value of Hostname and PrimaryDnsSuffix to PreviousLocalHostname to prepare for future changes.

Activation method

DNS reads its registry entries only when it starts. If you change the value of this entry by editing the registry, the changes are not effective until you restart the DNS server.

Note Image Note

The DNS server updates resource records in accordance with the standards set for the zone and stored in the value of AutoConfigFileZones

.

Related Entries

Hostname

AutoConfigFileZones


PublishAddresses

HKLM\SYSTEM\CurrentControlSet\Services\DNS\Parameters

Data type | Range | Default value
REG_SZ | IP address [IP address] | (Blank)

Description

Specifies the IP addresses you want to publish for the computer. The DNS server creates A records only for the address in this list.

If this entry does not appear in the registry, or if its value is blank, the DNS server creates an A record for each of the computer's IP addresses.

This entry is designed for computers with multiple IP addresses, where you prefer to publish only a subset of the available addresses. Typically, this is used to prevent the DNS server from returning a private network address in response to a query, when the computer has a corporate network address.

Activation method

DNS reads its registry entries only when it starts. You can change entries while the DNS server is running by using the DNS console. If you change entries by editing the registry, the changes are not effective until you restart the DNS server.

Note Image Note

The DNS server does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


PublishAutonet

HKLM\SYSTEM\CurrentControlSet\Services\DNS\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether the DNS server builds A records for temporary IP addresses produced by Automatic Private IP Addressing (APIPA). This entry applies only when the DNS server is building A records for the computer on which it is running.

APIPA is designed for computers on single-subnet networks that do not include a DHCP server. APIPA automatically assigns an IP address from its reserved range, 169.254.0.01 through 169-254.255.254. These IP addresses, commonly known as autonet addresses, are used only until the system finds a DHCP server. APIPA addresses cannot be used on the Internet.

Value | Meaning
0 | Exclude APIPA addresses.
1 | Include APIPA addresses.

Activation method

DNS reads its registry entries only when it starts. If you change entries by editing the registry, the changes are not effective until you restart the DNS server.

Note Image Note

The DNS server does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


RecursionRetry

HKLM\SYSTEM\CurrentControlSet\Services\DNS\Parameters

Data type | Range | Default value
REG_DWORD | 0x1 - 0xFFFFFFFF seconds | 0x3

Description

Determines how often DNS repeats recursive client queries when it does not receive a response from a remote server. If the DNS server does not receive a response before the time specified by this value expires, the DNS server repeats the query to the same server or to other DNS servers.

The default value is appropriate for most servers. However, if this value is less than the time it takes for a remote server to respond over a slow link, you should increase this value so that it is slightly longer than the observed response time.

Change method

To change the value of this entry, use Dnscmd.exe, a tool included with the Windows 2000 Support Tools. The change is effective immediately; you do not have to restart the DNS server.

Activation method

DNS reads its registry entries only when it starts. If you change the value of this entry by editing the registry, the changes are not effective until you restart the DNS server.

Related Entries

ForwardingTimeout

RecursionTimeout


RecursionTimeout

HKLM\SYSTEM\CurrentControlSet\Services\DNS\Parameters

Data type | Range | Default value
REG_DWORD | 0x1 - 0xFFFFFFFF seconds | 0xF (15 seconds)

Description

Determines how long DNS waits for remote servers to respond to a recursive client query before terminating the search. If the DNS server does not receive a response to a recursive query, the server repeats the query at intervals specified by the value of the RecursionRetry entry. If, despite repeated trials, the server does not receive a response before the value of RecursionTimeout expires, the DNS server terminates the search and sends a SERVER_FAILURE response to the query.

This value is appropriate for most DNS servers. However, if this value is less than the time it takes for a remote server to respond over a slow link, you should increase this value so that it is slightly longer than the observed response time. In measuring actual response times, be sure to distinguish responses from remote DNS servers from repeated query attempts by the client.

Change method

To change the value of this entry, use Dnscmd.exe, a tool included with the Windows 2000 Support Tools. The change is effective immediately; you do not have to restart the DNS server.

Activation method

DNS reads its registry entries only when it starts. If you change the value of this entry by editing the registry, the changes are not effective until you restart the DNS server.

Related Entries

ForwardingTimeout

ForwardingTimeout

RecursionRetry


RoundRobin

HKLM\SYSTEM\CurrentControlSet\Services\DNS\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines the order in which the DNS server returns A records (requests for IP addresses) when it has multiple A records for the same name.

Value | Meaning
0 | The DNS server returns the A records in a fixed, file load order.
1 | The DNS server rotates among the A records it returns for a given name. Rotating helps to balance the load placed on each connection to the named server.

Change method

To change the value of this entry, use the DNS console. Right-click the server name, click Properties, click the Advanced tab. This entry corresponds to the Enable Round Robin option. Or, use Dnscmd.exe, a tool included with the Windows 2000 Support Tools. Using either method, your changes are effective immediately; you do not have to restart the DNS server.

Activation method

DNS reads its registry entries only when it starts. If you change the value of this entry by editing the registry, the changes are not effective until you restart the DNS server.

Note Image Note

The order in which A records are returned depends on the value of LocalNetPriority and the value of RoundRobin, as follows:

  • When both are set to 1 (or RoundRobin does not appear in the registry), the DNS server rotates among the A records it returns in local net priority order, that is, in order of their similarity to the IP address of the querying client.
  • If the value of RoundRobin is 0 and the value of LocalNetPriority is 1, the DNS server returns the records in local net priority order. It does not rotate among available addresses.
  • If the value of RoundRobin is 1 and the value of LocalNetPriority is 0 (or neither appear in the registry), the DNS server rotates among the available record in the order in which the records were added to the database.
  • If the values of RoundRobin and LocalNetPriority are 0 (or LocalNetPriority does not appear in the registry), the DNS server returns the records in the order in which they were added to the database. It does not attempt to sort them or rotate its returns from among them.

Related Entries

LocalNetPriority

ForwardingTimeout

RecursionRetry


RpcProtocol

HKLM\SYSTEM\CurrentControlSet\Services\DNS\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0x7 | 0xFFFFFFFF | 0xFFFFFFFF

Description

Specifies the protocols over which administrative RPC runs. The DNS server establishes endpoints to allow connections over these protocols.

Value | Meaning
0x0 | No protocols. Disables RPC for DNS.
0x1 (001 binary) | TCP/IP
0x2 (010 binary) | Named pipes
0x3 (011 binary) | TCP/IP and named pipes
0x4 (100 binary) | LPC
0x5 (101 binary) | LPC and TCP/IP
0x6 (110 binary) | LPC and named pipes
0x7 (111 binary) | TCP/IP, LPC, and named pipes
0xFFFFFFFF | All protocols

Change method

To change the value of this entry, use the DNS console. Do not change this value by editing the registry.

Activation method

DNS reads its registry entries only when it starts. You can change entries while the DNS server is running by using the DNS console. If you change entries by editing the registry, the changes are not effective until you restart the DNS server.


ScavengingInterval

HKLM\SYSTEM\CurrentControlSet\Services\DNS\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 | 0x1 - 0xFFFFFFFF hours | 0x0

Description

Determines whether the scavenging feature of DNS is enabled and specifies how often the DNS server scavenges its database records.

When scavenging, the DNS server inspects the timestamps of resource records in the DNS database and deletes records that are out of date.

Value | Meaning
0x0 | Scavenging is disabled. The DNS server does not delete old resource records.
0x1 - 0xFFFFFFFF | Enables scavenging and specifies the number of hours between each scavenging pass.

This entry stores the value you enter in the Enable automatic scavenging of stale records section in the DNS console.

By default, when you use the DNS console to enable scavenging on the DNS server, it configures DNS to perform scavenging once each week (0xA8 = 168 hours).

Change method

To change the value of this entry, use the DNS console. Right-click a server name, click Properties, and then click the Advanced tab. Select the Enable automatic scavenging of stale records check box and use the text boxes to determine how often DNS performs scavenging.

Activation method

DNS reads its registry entries only when it starts. You can change entries while the DNS server is running by using the DNS console. If you change entries by editing the registry, the changes are not effective until you restart the DNS server.

Note Image Note

DNS adds this entry to the registry until when you use the DNS console or Dnscmd.exe to enable scavenging and set a scavenging interval. If you disable scavenging, the DNS console sets the value of this entry to 0x0.

By default, scavenging is disabled. To enable the DNS scavenging feature on any zone, scavenging must be enabled on the server (by this entry) and enabled for the zone (by the value of Aging in a <Zone-name> subkey. If this entry specifies that scavenging is disabled on the DNS server, all values that configure scavenging for any zone are ignored.

Tip Image Tip

You can also use the DNS Server Troubleshooting Tool (Dnscmd.exe) in the \Support\Tools folder of the Windows 2000 operating system CD to change this value. For more information, see Windows 2000 Tools Help.

Caution Image Caution

DNS adds this entry to the registry when you use the DNS console or the DNS Server Troubleshooting Tool (Dnscmd.exe) to configure scavenging. Do not edit the registry to add, delete or change this value.

Related Entries

Aging

DefaultAgingState

RefreshInterval

DefaultRefreshInterval

NoRefreshInterval

DefaultNoRefreshInterval


SecureResponses

HKLM\SYSTEM\CurrentControlSet\Services\DNS\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether the DNS server filters the records it saves in its memory cache in an attempt to eliminate illegitimate records.

The DNS server saves the records of recursive names queries in a memory cache so that it can respond quickly to new queries for the same name. By default, it saves all records. However, if the value of this entry is 1, DNS only saves query records for names that are in the same subtree as the server that provided them. For example, the DNS server would save an NS record for ns.reskit.com from the reskit.com server, but not save the NS record for ns.avionics.com from the reskit.com server. This filtering was designed to minimize the effect of malicious attacks on an Internet server, but it might generate additional network traffic.

Value | Meaning
0 | The DNS server saves all name query records in its memory cache. It does not attempt to filter out illegitimate records.
1 | The DNS server only saves records of names that are in the same subtree as the name in the original query.

Change method

To change the value of this entry, use the DNS console. Right-click the name of a DNS server, and then click the Advanced tab. This entry stores the setting of the Secure cache against pollution check box.

Activation method

DNS reads its registry entries only when it starts. You can change entries while the DNS server is running by using the DNS console. If you change entries by editing the registry, the changes are not effective until you restart the DNS server.


SendPort

HKLM\SYSTEM\CurrentControlSet\Services\DNS\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 - 4294967295 port number | 0

Description

Specifies a port through which the DNS server sends recursive UDP queries to other DNS servers.

By default, the DNS server sends recursive UDP queries through a randomly selected port, known as the DNS port. This entry directs the DNS server to use a particular port. Consider adding this entry to the registry if you want to use port 53 or another port.

If the value of this entry is 0 or if the entry does not appear in the registry, DNS selects a port randomly.

Activation method

DNS reads its registry entries only when it starts. You can change entries while the DNS server is running by using the DNS console. If you change entries by editing the registry, the changes are not effective until you restart the DNS server.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


StrictFileParsing

HKLM\SYSTEM\CurrentControlSet\Services\DNS\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines how the DNS server responds when it receives zone files whose records contain errors, as defined by RFCs. The RFC-violating records include records for names outside of the zone, CNAME records at names that contain other records, and other records at names that contain CNAME records.

Value | Meaning
0 | When the DNS encounters an erroneous record, it writes an error to the DNS log in Event Viewer, and then continues to load.
1 | When the DNS encounters erroneous records, it writes an error to the DNS log in Event Viewer, and then stops and does not load.

Change method

To change the value of this entry, use the DNS console. Right-click the server name, click Properties, click the Advanced tab. This entry corresponds to the Fail On Load If Bad Zone Data option. Or, use Dnscmd.exe, a tool included with the Windows 2000 Support Tools. Using either method, you changes are effective immediately; you do not have to restart the DNS server.

Activation method

DNS reads its registry entries only when it starts. You can change entries while the DNS server is running by using the DNS console or Dnscmd.exe. If you change the vaue of this entry by editing the registry, the changes are not effective until you restart the DNS server.

Note Image Note

The default behavior of DNS changed between Windows NT 4.0 with Service Pack 4, and Windows 2000. In Windows NT 4.0 (previous to Service Pack 4) and earlier, the DNS server does not start if it encounters incorrect zone records. Check the System Log in Event Viewer for errors.


UpdateOptions

HKLM\SYSTEM\CurrentControlSet\Services\DNS\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0x80000000 | 0x30F

Description

Prohibits DNS dynamic update of certain types of records.

This entry is a bitmask. To disable DNS dynamic update on a record type, set the bit for that record type to 1, or sum the hexadecimal values of the record types.

Value | Meaning
0x0 | No record types are restricted. DNS dynamic update is permitted on all record types.
0x1 | SOA records
0x2 | NS records
0x4 | Delegation NS records
0x8 | Server host records
0x100 | On secure dynamic update, exclude SOA records
0x200 | On secure dynamic update, exclude root NS records
0x30F | On standard dynamic update, exclude NS, SOA, and server host records. On secure dynamic update, exclude root NS and SOA records. Allow delegations and server host updates.
0x400 | On secure dynamic update, exclude delegation NS records
0x800 | On secure dynamic update, exclude server host records
0x1000000 | DS peer records
0x80000000 | Disable DNS dynamic update.

Activation method

DNS reads its registry entries only when it starts. You can change entries while the DNS server is running by using the DNS console. If you change entries by editing the registry, the changes are not effective until you restart the DNS server.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

A value of 0x80000000 disables DNS dynamic update on the DNS server.

Tip Image Tip

To find other registry entries related to DNS dynamic update, type "dynamic update" on the Search tab in this file.


WriteAuthorityNs

HKLM\SYSTEM\CurrentControlSet\Services\DNS\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines when the DNS server writes NS records in the Authority section of a response. This entry relieves the DNS server of the task of writing unnecessary NS records in the Authority section and ensures that the DNS server complies with relevant RFCs.

Value | Meaning
0 | The DNS server writes NS records in the Authority section of referrals only. This setting complies with RFC1034 and the DNSIND Clarify Draft.
1 | The DNS server writes NS records in the Authority section of all successful authoritative responses. These NS records are neither required nor useful.

Change method

To change the value of this entry, use Dnscmd.exe, a tool included with the Windows 2000 Support Tools. The change is effective immediately; you do not have to restart the DNS server.

Activation method

DNS reads its registry entries only when it starts. You can change entries while the DNS server is running by using Dnscmd.exe. If you change entries by editing the registry, the changes are not effective until you restart the DNS server.

Note Image Note

The default value is optimal for most DNS servers. Providing NS records in the Authority section consumes processor time and network bandwidth and is not recommended unless it is required by a network application or service.


XfrConnectTimeout

HKLM\SYSTEM\CurrentControlSet\Services\DNS\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF seconds | 1E (30 seconds)

Description

Determines how long the DNS server waits for the secondary server to connect to a primary server. If the connection is not established by the time this value expires, the DNS server drops the connection.

Activation method

DNS reads its registry entries only when it starts. You can change entries while the DNS server is running by using the DNS console. If you change entries by editing the registry, the changes are not effective until you restart the DNS server.

Note Image Note

The DNS server does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


Zones

HKLM\SYSTEM\CurrentControlSet\Services\DNS\

Description

The DNS\Zones subkey stores information about the authoritative zones of a DNS server. The Zones subkey contains subkeys that represent each of the authoritative zones on the server. (In this file, these subkeys are depicted as <Zone-name>.) The Zone-name subkeys store configuration data set separately for each authoritative zone.

In addition to the zone-name subkeys, if the DNS server is not root authoritative, the Zones subkey contains subkey named "." (period) which stores configuration data for the cache file, also known as the root hint file.


<Zone-name>

HKLM\SYSTEM\CurrentControlSet\Services\DNS\Zones\

Description

The DNS\Zones subkey contains a subkey for each of the authoritative zones on the server. These zone subkeys are named for the zone and store settings that apply only to the zone.

The entries listed under <Zone-name> can appear in any subkey under DNS\Zones.

Activation method

DNS reads its registry entries only when it starts. You can change entries while the DNS server is running by using the DNS console. If you change entries by editing the registry, the changes are not effective until you restart the DNS server.

Note Image Note

The <Zone-name> subkey is a variable representing the zone subkeys in the HKLM\SYSTEM\CurrentControlSet\Services\DNS\Zones subkey. It doesn't actually appear in the registry. This variable subkey displays the entries that can appear in any of the Zones subkeys. The entries that actually appear in your registry depend upon the configuration of the zone.


Aging

HKLM\SYSTEM\CurrentControlSet\Services\DNS\Zones\<Zone-name>

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether the DNS scavenging feature is enabled for this zone.

When scavenging, the DNS server inspects the timestamps of resource records for this zone in the DNS database and deletes records that are out of date.

Value | Meaning
0 | Scavenging is disabled. The DNS server does not delete old resource records.
1 | Enables scavenging for this zone.

You can enable scavenging on a zone by using three different methods. All of these methods change the value of Aging.

  • By selecting the Scavenge stale resource records check box on the Aging page for any zone.

    • Aging directly stores the value of the Scavenge stale resource records checkbox on the Aging page of the DNS console.

  • By configuring all new Active Directory–integrated zones so that scavenging is enabled by default.

    • The default configuration for a new zone is stored in the value of DefaultAgingState, and is copied to the value of Aging when a new Active Directory–integrated zone is created.

    DefaultAgingState stores the setting in the Server Aging/Scavenging Properties dialog box.

  • By applying the default configuration for a new zone to existing Active Directory–integrated zones.

    • When you select the Apply these settings to the existing Active Directory-integrated zones check box on the Server Aging/Scavenging Confirmation dialog box, the value of DefaultAgingState is copied to the value of Aging and replaces any existing value.

Change method

To change the value of this entry, use the DNS console. Right-click the name of a zone, click Properties, click the General tab, and then click the Aging button. This entry corresponds to the Scavenge stale resource records check box.

Activation method

DNS reads its registry entries only when it starts. You can change entries while the DNS server is running by using the DNS console. If you change entries by editing the registry, the changes are not effective until you restart the DNS server.

Note Image Note

By default, scavenging is disabled on the DNS server and on all zones. To enable scavenging for any zone, you must enable it on the DNS server (as specified in ScavengingInterval) and on the zone (as specified by this value). If scavenging is disabled on the DNS server, all entries that configure scavenging on any zone are ignored.

Caution Image Caution

DNS adds this entry to the registry when you use the DNS console to configure scavenging. Do not edit the registry to add, delete or change this value.

Related Entries

ScavengingInterval

DefaultAgingState

RefreshInterval

DefaultRefreshInterval

NoRefreshInterval

DefaultNoRefreshInterval


AllowUpdate

HKLM\SYSTEM\CurrentControlSet\Services\DNS\Zones\<zone-name>

Data type | Range | Default value
REG_DWORD | 0 | 1 | 2 | Standard primary zones: 0 Active Directory-integrated zones: 2

Description

Determines whether this primary zone accepts dynamic update requests. Once accepted by the zone, the update request still is subject to any security requirements established for updates.

Value | Meaning
0 | This zone does not accept dynamic update requests.
1 | This zone accepts dynamic update requests.
2 | This zone only accepts secure dynamic update requests. This option is available only on zones that are integrated with Active Directory.

Change method

To change the value of this entry, use the DNS console. Right-click the zone name, click Properties, click the General tab. This entry corresponds to the Dynamic update drop-down box. Do not change this value by editing the registry.

Activation method

DNS reads its registry entries only when it starts. You can change entries while the DNS server is running by using the DNS snap-in. If you change entries by editing the registry, the changes are not effective until you restart the DNS server.

Note Image Note

This entry is effective only in a primary DNS zone. Otherwise, the entry is ignored.

Tip Image Tip

To find other registry entries related to DNS dynamic update, type "dynamic update" on the Search tab in this file.


DatabaseFile

HKLM\SYSTEM\CurrentControlSet\Services\DNS\Zones\<zone-name>

Data type | Range | Default value
REG_SZ | DNS database file name ( *.dns) | There is no default value for this entry.

Description

Specifies the name of the file that stores the DNS database for the zone.

DNS reads the value of this entry when DNS is started by using entries from the registry (that is, the value of BootMethod is 2 or 3). If DNS is started by using values from a boot file, then the database file name specified in the boot file is stored in this entry, replacing any previous value.

This entry is required for standard primary zones (those not integrated with Active Directory). It is required for secondary zones only when they load from a zone file.

Change method

To change the value of this entry, use the DNS console. Right-click the zone name, click Properties, click the General tab. This entry corresponds to the Zone file name box. Do not change this value by editing the registry.

Activation method

DNS reads its registry entries only when it starts. You can change entries while the DNS server is running by using the DNS snap-in. If you change entries by editing the registry, the changes are not effective until you restart the DNS server.

Caution Image Caution

Do not change this value by editing the registry. If this entry is deleted or is set to an incorrect value, the DNS server will not load the zone.

Related Entries

BootMethod

EnableRegistryBoot

DsIntegrated

DatabaseDirectory


DsIntegrated

HKLM\SYSTEM\CurrentControlSet\Services\DNS\Zones\<zone-name>

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether zone data is stored in the Active Directory.

DNS adds this entry to the registry only when the zone is integrated with Active Directory.

Value | Meaning
0 (The entry does not appear in the registry.) | Zone information is stored in files.
1 | Zone information is stored in Active Directory. Updates are written to Active Directory and replicated from within it.

Change method

To add this entry to the registry, use the DNS console. Right-click the zone name, click Properties, click the General tab, click Change and select the Active Directory Integrated type. Do not change the value of this entry by editing the registry.

Activation method

DNS reads its registry entries only when it starts. You can change entries while the DNS server is running by using the DNS snap-in. If you change entries by editing the registry, the changes are not effective until you restart the DNS server.

Note Image Note

This entry applies only to Active Directory–integrated zones. Otherwise, the entry is ignored.

Caution Image Caution

Do not change this value by editing the registry. If this entry is deleted or is set to an incorrect value, the DNS server will not load the zone.

Related Entries

BootMethod

EnableRegistryBoot


MasterServers

HKLM\SYSTEM\CurrentControlSet\Services\DNS\Zones\<zone-name>

Data type | Range | Default value
REG_SZ | IP address[, IP address] ... (dotted decimal form) | There is no default value for this entry.

Description

Specifies the master servers from which the secondary server pulls zone transfers. This entry is required for secondary zones.

Change method

To change the value of this entry, use the DNS console. Right-click the name of a secondary zone, click Properties, and then click the General tab. This value corresponds to the Masters IP addresses fields. Do not change this value by editing the registry.

Activation method

DNS reads its registry entries only when it starts. You can change entries while the DNS server is running by using the DNS snap-in. If you change entries by editing the registry, the changes are not effective until you restart the DNS server.

Note Image Note

This entry is effective only the when it appears in the registry of a secondary DNS zone. Otherwise, it is ignored.

Related Entries

Type

BootMethod

EnableRegistryBoot


NoRefreshInterval

HKLM\SYSTEM\CurrentControlSet\Services\DNS\Zones\<Zone-name>

Data type | Range | Default value
REG_DWORD | 0x1 - 0xFFFFFFFF hours | 0xA8 (168 hours = 1 week)

Description

Specifies the duration of the no-refresh interval for a resource record.

The no-refresh interval is the period during which servers cannot update the timestamp of the resource record, and the scavenging feature cannot delete the record. The no-refresh interval is designed to improve the performance of Active Directory-related services by concentrating write operations.

This entry and related entries configure the scavenging feature of the DNS server. The no-refresh interval for a record begins when its timestamp is updated. When the time specified by this entry expires, the refresh interval begins, during which servers have a specified period to update the timestamps of the resource record. During its refresh interval and the no-refresh interval, a record is protected and cannot be deleted by the scavenging feature of the DNS server. However, when both intervals expire, the DNS server can scavenge (delete) resource records that are still out of date.

You can specify the duration of the no-refresh interval for a zone by using three different methods. All of these methods change the value of NoRefreshInterval.

  • By using the No refresh interval box on the Aging page for any zone.

    • NoRefreshInterval directly stores the value of the No refresh interval box on the Aging page of the DNS console.

  • By configuring all new Active Directory–integrated zones so that the duration of the no-refresh interval is set to a particular value by default.

    • The default duration of the no-refresh interval for a new zone is stored in the value of DefaultNoRefreshInterval, and is copied to the value of NoRefreshInterval when a new Active Directory–integrated zone is created.

    DefaultNoRefreshInterval stores the setting in the Server Aging/Scavenging Properties dialog box.

  • By applying the default configuration for a new zone to existing zones.

    • When you select the Apply these settings to the existing Active Directory-integrated zones check box on the Server Aging/Scavenging Confirmation dialog box, the value of DefaultNoRefreshInterval is copied to the value of NoRefreshInterval and replaces any existing value.

Change method

To change the value of this entry, use the DNS console. Right-click the name of a zone, click Properties, click the General tab, and then click the Aging button. This entry stores the value in the No refresh interval field.

Activation method

DNS reads its registry entries only when it starts. You can change entries while the DNS server is running by using the DNS console. If you change entries by editing the registry, the changes are not effective until you restart the DNS server.

Note Image Note

This entry is used only when scavenging is enabled on the server (as specified in ScavengingInterval) and on the zone (as specified by the value of Aging). By default, scavenging is disabled.

Caution Image Caution

DNS adds this entry to the registry when you use the DNS console to configure scavenging. Do not edit the registry to add, delete or change this value.

Related Entries

Aging

ScavengingInterval

DefaultAgingState

RefreshInterval

DefaultRefreshInterval

DefaultNoRefreshInterval


NotifyLevel

HKLM\SYSTEM\CurrentControlSet\Services\DNS\Zones\<zone-name>

Data type | Range | Default value
REG_DWORD | 0 | 1 | 2 | Standard primary zones: 1 Active Directory–integrated zones: 2

Description

Determines which secondary servers this DNS master server notifies when zone information changes.

This entry lets you configure the DNS server to send change notices only to specified servers. Limiting the distribution of zone information is intended for security, but it also conserves processor time and prevents denial-of-service attacks (also known as SYN flooding).

Value | Meaning
0 | No notices. DNS does not notify secondary servers when zone information changes.
1 | Notify only the name servers that are authoritative for the zone. Authoritative name servers are specified by NS records at the zone root.
2 | Notify only the servers you specify. To create a list of servers that receive notices, use the Zone Properties Notify dialog box in the DNS console. the DNS console stores your list in the value of NotifyServers. If NotifyServers does not appear in the registry or its value is blank, DNS does not send notices.

Change method

To change the value of this entry, use the DNS console. Right-click the name of a secondary zone, click Properties, click the Zone Transfer tab, click the Notify button, and then select an option. Do not change this value by editing the registry.

Activation method

DNS reads its registry entries only when it starts. You can change entries while the DNS server is running by using the DNS snap-in. If you change entries by editing the registry, the changes are not effective until you restart the DNS server.

Note Image Note

This entry is not replicated to other DNS servers authoritative for this zone.

This entry is effective only when it appears in the registry of a master DNS server. Otherwise, it is ignored.

Related Entries

NotifyServers

SecureSecondaries


NotifyServers

HKLM\SYSTEM\CurrentControlSet\Services\DNS\Zones\<zone-name>

Data type | Range | Default value
REG_SZ | IP address[, IP address] ... (dotted decimal form) | 0

Description

Stores a customized list of secondary servers that this master DNS server notifies when zone information changes. Servers are represented in this list by their IP addresses.

This entry corresponds to the list of servers on the Notify tab in the DNS console.

This list is used only when the value of NotifyLevel is 2.

Change method

To change the value of this entry, use the DNS console. Right-click the name of a secondary zone, click Properties, click the Zone Transfer tab, click the Notify button, and enter a list of IP addresses. Do not change this value by editing the registry.

Activation method

DNS reads its registry entries only when it starts. You can change entries while the DNS server is running by using the DNS console. If you change entries by editing the registry, the changes are not effective until you restart the DNS server.

Note Image Note

This entry is not replicated to other DNS servers authoritative for this zone.

This entry is effective only when it appears in the registry of a master DNS server. Otherwise, it is ignored.

Related Entries

NotifyLevel

SecureSecondaries

SecondaryServers


RefreshInterval

HKLM\SYSTEM\CurrentControlSet\Services\DNS\Zones\<Zone-name>

Data type | Range | Default value
REG_DWORD | 0x1 - 0xFF hours | 0xA8 (168 hours = 1 week)

Description

Specifies the duration of the refresh interval for a resource record. The refresh interval is the time during which the server can update the timestamp of a resource record. During its refresh interval, a record is protected and cannot be deleted by the scavenging feature of the DNS server.

This entry and related entries configure the scavenging feature of the DNS server. The period specified in this entry begins when the no-refresh interval (the period during which timestamps cannot be updated) for a record ends. When the time specified by this entry expires, the scavenging feature of the DNS server can delete the record if it is out of date.

You can specify the duration of the refresh interval for a zone by using three different methods. All of these methods change the value of RefreshInterval.

  • By using the Refresh interval box on the Aging page for any zone.

    • RefreshInterval directly stores the value of the Refresh interval box on the Aging page of the DNS console.

  • By configuring all new Active Directory–integrated zones so that the duration of the refresh interval is set to a particular value by default.

    • The default duration of the refresh interval for a new zone is stored in the value of DefaultRefreshInterval, and is copied to the value of RefreshInterval when a new Active Directory–integrated zone is created.

    DefaultRefreshInterval stores the setting in the Server Aging/Scavenging Properties dialog box.

  • By applying the default configuration for a new zone to existing zones.

    • When you select the Apply these settings to the existing Active Directory-integrated zones check box on the Server Aging/Scavenging Confirmation dialog box, the value of DefaultRefreshInterval is copied to the value of RefreshInterval and replaces any existing value.

Change method

To change the value of this entry, use the DNS console. Right-click the name of a zone, click Properties, click the General tab, and then click the Aging button. This entry stores the value in the Refresh interval field.

Activation method

DNS reads its registry entries only when it starts. You can change entries while the DNS server is running by using the DNS console. If you change entries by editing the registry, the changes are not effective until you restart the DNS server.

Note Image Note

This entry is used only when scavenging is enabled on the server (as specified in ScavengingInterval) and on the zone (as specified by the value of Aging). By default, scavenging is disabled.

Tip Image Tip

The refresh interval must be long enough to allow all servers that maintain resource records to update their timestamps. Because the DHCP server is usually the last server to update its records, you can monitor DHCP records to make sure you have scheduled enough time for updates. If records are being scavenged too soon, use the DNS console to set this value back to the default value of 1 week (168 hours).

Caution Image Caution

DNS adds this entry to the registry when you use the DNS console to configure scavenging. Do not edit the registry to add, delete or change this value.

Related Entries

Aging

ScavengingInterval

DefaultAgingState

DefaultRefreshInterval

NoRefreshInterval

DefaultNoRefreshInterval


ScavengeServers

HKLM\SYSTEM\CurrentControlSet\Services\DNS\Zones\<Zone-name>

Data type | Range | Default value
REG_EXPAND_SZ | Comma-separated IP addresses in dotted-decimal form | (Blank)

Description

Limits the DNS servers that can scavenge the resource records for this zone to the servers listed in this entry.

When scavenging, the DNS server inspects the timestamps of resource records for this zone in the DNS database and deletes records that are out of date.

By default, this entry does not appear in the registry and, therefore, all primary servers that are authoritative for this zone can scavenge its resource records. However, when this entry appears in the registry, only the servers specified in the value of the entry can scavenge the resource records for the zone.

Change method

To change the value of this entry use the DNS Server Troubleshooting Tool (Dnscmd.exe) on the Windows 2000 Resource Kit CD-ROM. For more information, see Windows 2000 Tools Help.

Activation method

DNS reads its registry entries only when it starts. You can change entries while the DNS server is running by using the DNS console. If you change entries by editing the registry, the changes are not effective until you restart the DNS server.

Note Image Note

By default, scavenging is disabled on the DNS server and on all zones. To enable scavenging for any zone, you must enable it on the DNS server (as specified in ScavengingInterval) and on the zone (as specified by this value). If scavenging is disabled on the DNS server, all entries that configure scavenging on any zone are ignored.

Caution Image Caution

If this entry appears in the registry, but its value is blank, no servers are authorized to scavenge its records. As a result, scavenging is effectively disabled on the zone.

DNS adds this entry to the registry when you use the use the DNS Server Troubleshooting Tool (Dnscmd.exe) in the \Support\Tools folder of the Windows 2000 operating system CD to configure scavenging. Do not edit the registry to add, delete or change this value.

Related Entries

ScavengingInterval

Aging


SecondaryServers

HKLM\SYSTEM\CurrentControlSet\Services\DNS\Zones\<zone-name>

Data type | Range | Default value
REG_SZ | IP address[, IP address] ... (dotted decimal form) | There is no default value for this entry.

Description

Stores a customized list of secondary servers to which DNS sends zone transfers. Servers are represented in this list by their IP addresses.

Secondary DNS servers can request zone transfers from master DNS servers. You can configure master DNS servers to send zone transfers only to the secondary servers that appear in this list. DNS rejects zone transfer requests from servers that do not appear in this list.

This entry stores the list of servers specified on the Zone Transfer tab in the DNS console. This list is used only when the value of SecureSecondariesis 2.

Change method

To change the value of this entry, use the DNS console. Right-click the name of a secondary zone, click Properties, and then click the Zone Transfer tab. Do not change this value by editing the registry.

Activation method

DNS reads its registry entries only when it starts. You can change entries while the DNS server is running by using the DNS console. If you change entries by editing the registry, the changes are not effective until you restart the DNS server.

Note Image Note

This entry is not replicated to other DNS servers authoritative for this zone.

This entry is effective only when it appears in the registry of a master DNS server.

Tip Image Tip

To clear the list of secondary servers, use the DNS snap-in. Right-click the name of a secondary zone, click Properties, and then click the Zone Transfer tab. To delete a server from the list, select the server name, and then click Remove.

Caution Image Caution

Do not delete this entry from the registry. To clear the list of secondary servers, use the Zone Transfer tab on the Zones Properties Notify dialog box.

Related Entries

SecureSecondaries


SecureSecondaries

HKLM\SYSTEM\CurrentControlSet\Services\DNS\Zones\<zone-name>

Data type | Range | Default value
REG_DWORD | 0 | 1 | 2 | 3 | Standard zones: 0 Active Directory–integrated zones: 3

Description

Determines which secondary servers can receive zone transfers for this zone from this master DNS server.

Secondary servers request zone transfers from master DNS servers. You can configure the DNS server to send zone transfers only to a group of servers you specify. If other servers request zone transfers, the DNS server rejects the requests.

Limiting the distribution of zone information is intended for security, but it also conserves processor time and prevents denial-of-service attacks (also known as SYN flooding).

Value | Meaning
0 | Disable secondary security. Send zone transfers to all secondary servers that request them.
1 | Send zone transfers only to name servers that are authoritative for the zone. Authoritative name servers are specified by NS records at the root of the zone.
2 | Send zone transfers only to servers you specify. To create a list of servers that receive zone transfer, use the Zone Properties Notify dialog box in the DNS console. the DNS console stores your list in the value of SecondaryServers. If SecondaryServers does not appear in the registry or its value is blank, this server does not send zone transfers.
3 | Do not send zone transfers.

Change method

To change the value of this entry, use the DNS console. Right-click the name of a secondary zone, click Properties, and then click the Zone Transfer tab. Do not change this value by editing the registry.

Activation method

DNS reads its registry entries only when it starts. You can change entries while the DNS server is running by using the DNS console. If you change entries by editing the registry, the changes are not effective until you restart the DNS server.

Note Image Note

This entry is effective only when it appears in the registry of a master DNS server. Otherwise, it is ignored.

Related Entries

SecondaryServers

NotifyLevel


Type

HKLM\SYSTEM\CurrentControlSet\Services\DNS\Zones\<zone-name>

Data type | Range | Default value
REG_DWORD | 1 | 2 | There is no default value for this entry.

Description

Specifies the type of zone represented by the subkey.

Value | Meaning
1 | Primary zone
2 | Secondary zone

Change method

To change the value of this entry, use the DNS console. Right-click the zone name, click Properties, click the General tab, and then click Change. The first two options, pertaining to primary zones, correspond to a value of 1. The final option, Standard secondary, corresponds to a value of 2.

Activation method

DNS reads its registry entries only when it starts. You can change entries while the DNS server is running by using the DNS console. If you change entries by editing the registry, the changes are not effective until you restart the DNS server.

Caution Image Caution

Do not change this value by editing the registry. If this entry is deleted or is set to an incorrect value, the DNS server will not load the zone.

Related Entries

BootMethod

EnableRegistryBoot


DnsCache

HKLM\SYSTEM\CurrentControlSet\Services\

Description

The DNSCache subkey stores configuration data for the DNS caching resolver service of the DNS client. This service saves the responses to DNS queries so that the DNS server is not repeatedly queried for the same information.

Tip Image Tip

To configure DNS dynamic update, see the following entries in the Tcpip subkey:
DefaultRegistrationTTL
EnableAdapterDomainNameRegistration
DisableDynamicUpdate
DisableReplaceAddressesInConflicts
DisableReverseAddressRegistrations
UpdateSecurityLevel


Parameters

HKLM\SYSTEM\CurrentControlSet\Services\DnsCache\

Description

The DNSCache\Parameters subkey stores configuration data for the DNS caching resolver service of the DNS client. This service saves the responses to DNS queries so that the DNS server is not repeatedly queried for the same information.

Tip Image Tip

To configure DNS dynamic update, see the following entries in the Tcpip subkey:
DefaultRegistrationTTL
EnableAdapterDomainNameRegistration
DisableDynamicUpdate
DisableReplaceAddressesInConflicts
DisableReverseAddressRegistrations
UpdateSecurityLevel


AdapterTimeoutCacheTime

HKLM\SYSTEM\CurrentControlSet\Services\Dnscache\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF seconds | 0x78 (120 seconds = 2 minutes)

Description

Determines how long the DNS client on Windows 2000 Professional avoids an unresponsive network adapter.

When the DNS servers accessible through a particular network adapter interface do not respond to repeated requests, the DNS client stops sending queries to that interface for the time specified in the value of this entry. During that time, the DNS client sends queries to servers accessible through other network adapters.

If the value of this entry is 0x0, this optimizing feature is disabled. DNS continues to send queries to unresponsive adapters.

Activation method

To make changes to this entry effective, restart the DNS client service or restart Windows 2000.

Note Image Note

This entry is used only on Windows 2000 Professional.

Related Entries

NetFailureCacheTime


MaxCacheEntryTtlLimit

HKLM\SYSTEM\CurrentControlSet\Services\DnsCache\Parameters

Data type | Range | Default value
REG_DWORD | 0x1 - 0xFFFFFFFF seconds | 0x15180 (86400 seconds = (1 day)

Description

Establishes the maximum time that a DNS record, other than an SOA record, can remain in the DNS cache.

This entry establishes a ceiling for time-to-live (TTL) values of non-SOA records. By default, the TTL value in the DNS answer record determines how long records are saved in the DNS cache. However, if a TTL value in a DNS answer record exceeds the value of this entry, it is ignored, and the DNS client sets the TTL to the value of this entry.

Activation method

To make changes to this entry effective, restart the DNS client service or restart Windows 2000.

Note Image Note

This entry does not apply to SOA records. The maximum TTL for SOA records is determined by the value of MaxSOACacheEntryTtlLimit.


MaxSOACacheEntryTtlLimit

HKLM\SYSTEM\CurrentControlSet\Services\DnsCache\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF seconds | 0x12C (300 seconds = 5 minutes)

Description

Establishes the maximum time that an SOA record can remain in the DNS cache.

This entry establishes a ceiling for time-to-live (TTL) values of SOA records. By default, the TTL value in the DNS answer determines how long records are saved in the DNS cache. However, if the TTL value in the DNS answer exceeds the value of this entry, it is ignored, and the DNS client sets the TTL to the value of this entry.

Activation method

To make changes to this entry effective, restart the DNS client service or restart Windows 2000.

Note Image Note

This entry establishes a customized maximum TTL for SOA records. The maximum TTL for all other DNS records is determined by the value of MaxCacheEntryTtlLimit.


NegativeCacheTime

HKLM\SYSTEM\CurrentControlSet\Services\DnsCache\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF seconds | 0x12C (300 seconds = 5 minutes)

Description

Determines how long an entry recording a negative answer to a query remains in the DNS cache. When the time specified in the value expires, the DNS client the deletes answer record from the cache.

Activation method

To make changes to this entry effective, restart the DNS client service or restart Windows 2000.

Note Image Note

This entry does not apply to queries for SOA records. The maximum cache time for negative SOA records is determined by the value of NegativeSOACacheTime.


NegativeSOACacheTime

HKLM\SYSTEM\CurrentControlSet\Services\DnsCache\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF seconds | 0x78 (120 seconds = 2 minutes)

Description

Determines how long an entry recording a negative answer to a query for an SOA record remains in the DNS cache. When the time specified in the value expires, the DNS client deletes the answer record from the cache.

Activation method

To make changes to this entry effective, restart the DNS client service or restart Windows 2000.

Note Image Note

This entry applies only to queries for SOA records. The maximum cache time for negative non-SOA records is determined by the value of NegativeCacheTime.


NetFailureCacheTime

HKLM\SYSTEM\CurrentControlSet\Services\DnsCache\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF seconds | 0x1E (30 seconds)

Description

Determines for how long the DNS client on Windows 2000 Professional stops sending queries when it suspects that the network is down.

When the DNS client does not receive responses to repeated queries sent to any network adapter, the DNS client stops sending queries for the time specified in the value of this entry. During that time, the DNS client returns a timeout response to all queries.

If the value of this entry is 0x0, this optimizing feature is disabled. DNS continues to send queries to an unresponsive network.

Activation method

To make changes to this entry effective, restart the DNS client service or restart Windows 2000.

Note Image Note

This entry is used only on Windows 2000 Professional.

Related Entries

AdapterTimeoutCacheTime


EventLog

HKLM\SYSTEM\CurrentControlSet\Services\

Description

The Eventlog subkey stores configuration data used by Event Viewer to manage the event logs.

The Eventlog subkey contains the standard entries that appear in all Services subkeys. In addition, the Eventlog subkey contains subkeys representing each of its logs. In this file, these log-specific subkeys are represented by the generic subkey, <Log-name>.

Windows 2000 creates subkeys for the three standard logs that appear in Event Viewer -- Application, Security, and System -- and Windows services, such as DNS, create subkeys for their own logs. Programmers can create additional log-specific subkeys for custom logs that they create.

Related Entries

Event Viewer subkey


<Log-name>

HKLM\SYSTEM\CurrentControlSet\Services\EventLog\

Description

The <Log-name> subkey is a variable representing the log-specific subkeys in the EventLog subkey. It doesn't actually appear in the registry. This variable subkey displays the entries and subkeys that are common to many of the log-specific subkeys in the EventLog subkey.

The log-specific subkeys in your registry represent event logs and bear the name of the event log. They stores configuration data that applies only to that log. This includes the logs created by Windows 2000 and its services, and logs that you create.


<Source-name>

HKLM\SYSTEM\CurrentControlSet\Services\EventLog\<Log-name>\

Description

The <Source-name> subkey is a variable representing the EventLog\<Log-name> subkeys that store entries for a log source. A log source is a program, service, or operating system component that writes to an event log.

This subkey doesn't actually appear in the registry. This variable subkey displays the entries and subkeys that are common to many of the source-specific subkeys in the EventLog subkey.

Each <Source-name> subkey represents a program or service that writes to the log represented by the <log-name> subkey. The <Source-name> subkey stores configuration data that tells the Event Log service where to find and how to display the events for that source.

For example, the Dr. Watson for Windows 2000 service records its events in the Application Log in Event Viewer. Therefore, the source, DrWatson, has a subkey in the EventLog\Application subkey.

Note Image Note

If a source program that is not represented by a <Source-name> subkey writes an event to an event log, the Event Viewer uses the entries in the subkey identified by the value of PrimaryModule to display the event in Event Viewer.

Caution Image Caution

Do not change the values of these entries by editing the registry. Source programs should use the standard Win32 APIs to register a source program and write events to the event log.


CategoryCount

HKLM\SYSTEM\CurrentControlSet\Services\EventLog\<Log-name>\<Source-name>

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF | There is no default value for this entry.

Description

Specifies the number of event categories defined by the source program.

This entry is required if the source uses categories and registers a category message file (as stored in the value of CategoryMessageFile).

Note Image Note

If CategoryMessageFile entry appears in the registry for a source, then a CategoryCount entry is required for that source .

Related Entries

CategoryMessageFile


CategoryMessageFile

HKLM\SYSTEM\CurrentControlSet\Services\EventLog\<Log-name>\<Source-name>

Data type | Range | Default value
REG_EXPAND_SZ | Path and file name [; Path and file name] | There is no default value for this entry.

Description

Stores the location of the file that contains categories for the events generated by the source program. Typically, event categories are included in the dynamic link library (DLL) or executable file for the source program.

The data in the category message file associates events with categories. The category classifies the event, usually by identifying the component or function that generated the event. Each source program can define its own categories and associate them with events. The category of an event is displayed in the Category column in Event Viewer.

Note Image Note

The same file can be used as the value of EventMessageFile, CategoryMessageFile, and ParameterMessageFile.

If CategoryMessageFile appears in the registry, then the CategoryCount entry is required.

Related Entries

CategoryCount

EventMessageFile

ParameterMessageFile


EventMessageFile

HKLM\SYSTEM\CurrentControlSet\Services\EventLog\<Log-name>\<Source-name>

Data type | Range | Default value
REG_EXPAND_SZ | Path and file name [; Path and file name] | There is no default value for this entry.

Description

Stores the location of the file that contains event identifiers for the events generated by the source program and text describing each event. Typically, event identifiers are included in the dynamic link library (DLL) or executable file for the source program.

A program can enter more than one file name in this value. Because Event Viewer opens the files in the order in which they are listed, you should list files in the order in which event identifiers are most likely to be found.

Also, when displaying the event log of a remote computer, Event Viewer first tries to locate the event identifiers in the first event message file listed for the source on the remote computer. If Event Viewer cannot open the event message file or cannot find the event identifier, it searches in the first event message file listed for the source on the local computer before searching other event message files on the remote and local computer.

Note Image Note

The same file can be used as the value of EventMessageFile, CategoryMessageFile, and ParameterMessageFile.

Related Entries

CategoryMessageFile

ParameterMessageFile


ParameterMessageFile

HKLM\SYSTEM\CurrentControlSet\Services\EventLog\<Log-name>\<Source-name>

Data type | Range | Default value
REG_EXPAND_SZ | Path and file name [; Path and file name] | (There is no default value for this entry.)

Description

Stores the location of the file that contains values for variables in the event description. This file is optional.

The descriptive text in the event message file can contain variables. Some variables (indicated by %n) are resolved by substituting data from the event record. Other variables (indicated by %%n) are resolved by substituting text from a parameter message file (ParameterMessageFile). The Event Log service locates the correct values, and then replaces the variables before displaying the text in the Description field in Event Viewer.

Note Image Note

The same file can be used as the value of EventMessageFile, CategoryMessageFile, and ParameterMessageFile.


TypesSupported

HKLM\SYSTEM\CurrentControlSet\Services\EventLog\<Log-name>\<Source-name>

Data type | Range | Default value
REG_DWORD | 0x0 - 0x1F bitmask | There is no default value for this entry.

Description

Indicates the types of events generated by the source program.

The value of this entry determines which of the Types check boxes in Event Viewer are enabled. (To see the Types check boxes, from the View menu in Event Viewer, click Filter.)

Each bit in the mask represents an event type. To indicate that the source program generates events of a certain type, set the bit for that type to 1. To indicate that the source program supports more than one type of event, set multiple bits or sum the hexadecimal values for each event type.

Bitmask value | Meaning
0 | Success
1 | Error
10 binary (2) | Warning
100 binary (4) | Information
1000 binary (8) | Success audit
10000 binary (16) | Failure audit

Caution Image Caution

Do not change the value of this entry by editing the registry. Changing this value does not change the types of events generated by a source program. Source programs that add events of a new type should use the standard Win32 APIs to change this value.


DisplayNameFile

HKLM\SYSTEM\CurrentControlSet\Services\EventLog\<Log-name>

Data type | Range | Default value
REG_EXPAND_SZ | File name | Systemroot\system32\els.dll

Description

Identifies the file that stores the localized name of the event log.

The name stored in the specified file appears as the log name in Event Viewer.

If this entry does not appear in the registry for an event log, Event Viewer displays the name of the <log-name> registry subkey as the log name.

Caution Image Caution

Do not change the value of this entry. If you do, Event Viewer might not be able to locate the file containing the log name.

Related Entries

DisplayNameID


DisplayNameID

HKLM\SYSTEM\CurrentControlSet\Services\EventLog\<Log-name>

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF | There is no default value for this entry.

Description

Stores the message identification number of the log name string.

This number indicates the message in which the localized display name appears. The message is stored in the file specified by the value of DisplayNameFile.

For example, if the value of this entry is 0x5, the localized display name for the log appears in Message ID 5.

If this entry does not appear in the registry for an event log, Event Viewer displays the name of the <log-name> registry subkey as the log name.

Caution Image Caution

Do not change the value of this entry. If you do, Event Viewer cannot locate the correct display name for an event log.

Related Entries

DisplayNameFile


File

HKLM\SYSTEM\CurrentControlSet\Services\EventLog\<Log-name>

Data type | Range | Default value
REG_EXPAND_SZ | Path and file name | %SystemRoot%\System32\Config\AppEvent.evt

Description

Specifies the fully qualified path to the file where each event log is stored. This entry enables Event Viewer and other log processing programs to find the log files.

The value of this entry is displayed in the Log name field of the Properties dialog box for a log in Event Viewer.

Change method

To view the value of this entry, use Event Viewer.

Note Image Note

If you must move the event log files, do not use variables other than %SystemRoot% in the file paths. Event Viewer cannot resolve variables other than %SystemRoot% on remote computers.


MaxSize

HKLM\SYSTEM\CurrentControlSet\Services\EventLog\<Log-name>

Data type | Range | Default value
REG_DWORD | 0x10000 - 0xFFFF0000 bytes (64 KB - 4 GB) in 64 KB increments | 0x80000 (512 KB)

Description

Specifies the maximum size of the log file.

This entry corresponds to the Maximum log size option on the Properties page for a log in Event Viewer.

You cannot resolve a full log by increasing the value of this entry. You must clear the log file manually by clicking Clear all Events on the Properties page for any log in Event Viewer.

Change method

To change the value of this entry, use Event Viewer.


PrimaryModule

HKLM\SYSTEM\CurrentControlSet\Services\EventLog\<Log-name>

Data type | Range | Default value
REG_SZ | Subkey name | There is no default value for this entry.

Description

Identifies the subkey in Services\Eventlog\<Log-name> that contains default values for the entries in the Services\Eventlog\<Log-name>\<Source-name> subkey.

These default values are used to display events in Event Viewer when the source program has not specified values in a <Source-name> subkey, or when files specified as the value of an entry cannot be opened or do not have the required data.

For example, in the Services\Eventlog\Security subkey, the default value of PrimaryModule is Security. This value indicates that the Services\Eventlog\Security\Security subkey contains default values for entries that appear in the Services\Eventlog\Security\<SourceName> subkey. These values are used to display events in the security log when the source program does not specify valid values for the entries.


Retention

HKLM\SYSTEM\CurrentControlSet\Services\EventLog\<Log-name>

Data type | Range | Default value
REG_DWORD | 0x0 | 0x1 - 0xFFFFFFFE seconds | 0xFFFFFFFF | 0x93A80 (604800 seconds = 7 days)

Description

Determines how long records of events are protected from being overwritten. When the age of an event reaches or exceeds the value of this entry, it can be overwritten.

Value | Meaning
0x0 | Event Viewer overwrites events only when the log reaches the maximum size, as defined by the value of MaxSize. This value corresponds to the Overwrite events as needed option on the Properties dialog box for a log in Event Viewer.
0x1 - 0xFFFFFFFE | Specifies how long records are protected.
0xFFFFFFFF | Records are never overwritten. When the log file reaches its maximum size, as defined by the value of MaxSize, ???. You must clear the log manually, by clicking Clear all Events. This value corresponds to the Do not overwrite events option in Event Viewer.

Change method

To change the value of this entry, use Event Viewer. This entry corresponds to the options in the Event log wrapping section of the Properties page for any log.

Note Image Note

Event Viewer requires that you enter retention values in days, not seconds, and enforces a range of 1 day (86,400 seconds) - 365 days (31,536,000 seconds). If you change the value of this entry by editing the registry, the value you enter is effective. However, if you change any values in the Event Log Settings Properties dialog box for any log in Event Viewer, Event Viewer converts the value of Retention to the nearest day and replaces the value in the registry.


Sources

HKLM\SYSTEM\CurrentControlSet\Services\EventLog\<Log-name>

Data type | Range | Default value
REG_MULTI_SZ | Names of programs | There is no default value for this entry.

Description

Specifies the applications, services, or groups of applications that write events to this log. Each program listed in the value of Sources is represented by a subkey in the LogName subkey.


i8042prt

HKLM\SYSTEM\CurrentControlSet\Services\

Description

The i8042prt subkey stores data for the i8042prt driver. The i8042prt driver controls the keyboard and PS/2-compatible mouse for the Intel 8042 controller.

Note Image Note

For Windows 2000, many of the entries in the Parameters subkey are used only when a device is installed. When the system recognizes a new device, it copies these entries from Parameters to a device-specific subkey in the Enum subkey. Thereafter, it uses only the entries in Enum. For more information, see the entries in the Parameters subkey.


Parameters

HKLM\SYSTEM\CurrentControlSet\Services\i8042prt\

Description

The Parameters subkey stores data for the i8042prt driver. The i8042prt driver controls the keyboard and PS/2-compatible mouse for the Intel 8042 controller.

For Windows 2000, many of the entries in the Parameters subkey are used only when a device is installed. When the system recognizes a new device, it copies these entries from Parameters to a device-specific subkey in the Enum subkey. Thereafter, it uses only the entries in Enum. For more information, see the entries in the Parameters subkey.

Caution Image Caution

Do not edit the Enum subkey. To change the value of entries in Enum, use Device Manager.


EnableWheelDetection

HKLM\SYSTEM\CurrentControlSet\Services\i8042prt\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 2 | 1

Description

(This entry has limited use in Windows 2000. See Notes below.)

Determines whether the driver attempts to detect and enable the wheel on the mouse device. Some devices are equipped with a mouse wheel to provide rapid scrolling and other control features when supported by an application.

Value | Meaning
0 | Disable mouse wheel detection. The driver does not attempt to determine whether the mouse has a wheel or to enable it. Even if the mouse has a wheel, the wheel does not function in programs.
1 | Detect and enable the mouse wheel. If the driver detects a wheel on the mouse, it enables the wheel.
2 | Enable without detecting. The driver attempts to enable a mouse wheel without determining whether the mouse has a wheel.

Note Image Note

This entry is used only when a device is installed. When the system recognizes a new device, it copies this entry to a device-specific subkey in the Enum subkey.Thereafter, it uses only the entries in Enum.

For mouse devices that do not fully support all Intellimouse and PS/2 functions, including dynamic enabling, set the value of this entry to 2.

Tip Image Tip

To view or change the value of this entry for a particular PS/2 mouse, use Device Manager. In the tree control, click Device and then, in the results pane, click Mouse, double-click the device name, and click the Advanced Settings tab. This value appears in the Wheel Detection box.

Caution Image Caution

In rare instances, when the system tries to detect and enable the mouse wheel, the system stops responding. To recover, restart Windows 2000. If the problem persists, restart by using the LastKnownGood control set.


KeyboardDataQueueSize

HKLM\SYSTEM\CurrentControlSet\Services\i8042prt\Parameters

Data type | Range | Default value
REG_DWORD | 0x1 - 0xFFFFFFFF | 0x64 (100)

Description

(This entry has limited use in Windows 2000. See Notes below.)

Specifies the number of keyboard events buffered by the keyboard driver. It is also used in calculating the size of the keyboard driver's internal buffer in nonpaged memory pool. To determine the number of bytes to allocate for the buffer, the system multiplies the size of the KEYBOARD_INPUT_DATA structure (defined in NTDDKBD.H) by the value of KeyboardDataQueueSize.

You might consider increasing this value if the driver does not initialize or operate correctly and the System Log in Event Viewer contains the following message from the source, i8042prt :

The ring buffer that stores incoming keyboard data has overflowed (buffer size is configurable via the registry).

Note Image Note

This entry is used only when a device is installed. When the system recognizes a new device, it copies this entry to a device-specific subkey in the Enum subkey. Thereafter, it uses only the entries in Enum.


KeyboardDeviceBaseName

HKLM\SYSTEM\CurrentControlSet\Services\i8042prt\Parameters

Data type | Range | Default value
REG_SZ | Base keyboard port device name | KeyboardPort

Description

This entry is added to the registry, but it is not used. In Windows NT 4.0 and earlier, the keyboard class driver used this entry to locate keyboard port device objects. In Windows 2000, the keyboard class driver locates non-Plug-and-Play keyboards by using entries in the Devicemap subkey (HKEY_LOCAL_MACHINE\Hardware\Devicemap\KeyboardClass).


MouseDataQueueSize

HKLM\SYSTEM\CurrentControlSet\Services\i8042prt\Parameters

Data type | Range | Default value
REG_DWORD | 0x1 - 0xFFFFFFFF | 0x64 (100)

Description

(This entry has limited use in Windows 2000. See Notes below.)

Specifies the number of mouse events buffered by the mouse driver. It is also used in calculating the size of the mouse driver's internal buffer in nonpaged memory pool. To determine the number of bytes to allocate for the buffer, the system multiplies the size of the MOUSE_INPUT_DATA structure (defined in NTDDMOU.H) by the value of MouseDataQueueSize.

You might consider increasing this value if the driver does not initialize or operate correctly and the System Log in Event Viewer contains the following message from the source, Inport :

The ring buffer that stores incoming mouse data has overflowed (buffer size is configurable via the Registry).

Note Image Note

This entry is used only when a device is installed. When the system recognizes a new device, it copies this entry to a device-specific subkey in the Enum subkey. Thereafter, it uses only the entries in Enum.

Tip Image Tip

To view or change the value of this entry for a particular PS/2 mouse, use Device Manager. In the tree control, click Device and then, in the results pane, click Mouse, double-click the device name, and click the Advanced Settings tab. This value appears in the Input Buffer Length box.


MouseResendStallTime

HKLM\SYSTEM\CurrentControlSet\Services\i8042prt\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF microseconds | 3E8 (1 second)

Description

Determines how long the mouse driver waits for an acknowledgement (ACK) of a reset if a RESEND message is returned without an ACK. This entry is used when the mouse driver interrupt service routine includes a reset.

Note Image Note

Windows 2000 does not add this entry to the registry. To override the default value, you must add this entry by editing the registry or by using a program that edits the registry.

Unlike some entries in this subkey, this entry remains in the Parameters subkey and is read from this location even after a keyboard is installed.


MouseResolution

HKLM\SYSTEM\CurrentControlSet\Services\i8042prt\Parameters

Data type | Range | Default value
REG_DWORD | Mouse resolution specifier | 0x3

Description

(This entry has limited use in Windows 2000. See Notes below.)

Specifies the resolution of the mouse port. The number of counts per millimeter of resolution is determined by raising 2 to the power of the value of MouseResolution.

For example, if the value of MouseResolution is 3, the mouse resolution is 2**3, or 8 counts per millimeter.

Note Image Note

This entry is used only when a device is installed. When the system recognizes a new device, it copies this entry to a device-specific subkey in the Enum subkey. Thereafter, it uses only the entries in Enum.


MouseSynchIn100ns

HKLM\SYSTEM\CurrentControlSet\Services\i8042prt\Parameters

Data type | Range | Default value
REG_DWORD | Time in 100-nanosecond units | 20000000 (2 seconds)

Description

(This entry has limited use in Windows 2000. See Notes below.)

Specifies the length of time after which the next mouse interrupt is assumed to indicate the start of a new mouse packet (partial packets are discarded). This enables the driver to synchronize its internal notion of the mouse packet state with the hardware state when a mouse interrupt is lost.

Consider modifying this value if the system appears to be generating extra mouse events, such as when objects are selected although the mouse button has not been pressed.

Note Image Note

This entry is used only when a device is installed. When the system recognizes a new device, it copies this entry to a device-specific subkey in the Enum subkey. Thereafter, it uses only the entries in Enum.


NumberOfButtons

HKLM\SYSTEM\CurrentControlSet\Services\i8042prt\Parameters

Data type | Range | Default value
REG_DWORD | 0x1 - 0xFFFFFFFF | 0x2

Description

(This entry has limited use in Windows 2000. See Notes below.)

Specifies the number of buttons on the mouse port mouse at startup. If the number of buttons detected at startup is incorrect, you can override it by changing the value of this entry.

Note Image Note

This entry is used only when a device is installed. When the system recognizes a new device, it copies this entry to a device-specific subkey in the Enum subkey. Thereafter, it uses only the entries in Enum.


OverrideKeyboardSubtype

HKLM\SYSTEM\CurrentControlSet\Services\i8042prt\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF | 0x0

Description

Specifies the OEM-dependent keyboard subtype. You can add this entry to the registry to correct an error in the keyboard subtype detected at startup.

Note Image Note

Unlike some entries in this subkey, this entry remains in the Parameters subkey and is read from this location even after a keyboard is installed.


OverrideKeyboardType

HKLM\SYSTEM\CurrentControlSet\Services\i8042prt\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF | There is no default value for this entry.

Description

Specifies the keyboard type. You can add this entry to the registry to correct an error in the keyboard type detected at startup.

The following table shows some commonly used values for this entry. This is not a complete list.

Value | Meaning
0x2 | Enhanced 101-key keyboard or compatible
0x4 | Enhanced 102-key keyboard or compatible

Note Image Note

Unlike some entries in this subkey, this entry remains in the Parameters subkey and is read from this location even after a keyboard is installed.


PointerDeviceBaseName

HKLM\SYSTEM\CurrentControlSet\Services\i8042prt\Parameters

Data type | Range | Default value
REG_SZ | Base mouse port device name | PointerPort

Description

This entry is added to the registry, but it is not used. In Windows NT 4.0 and earlier, the mouse port driver used this entry to locate pointer port device objects. In Windows 2000, the mouse port driver locates non-Plug-and-Play pointing devices by using entries in the Devicemap subkey (HKEY_LOCAL_MACHINE\Hardware\Devicemap\PointerClass).

Related Entries

Devicemap subkey


PollingIterations

HKLM\SYSTEM\CurrentControlSet\Services\i8042prt\Parameters

Data type | Range | Default value
REG_DWORD | 0x400 - 0xFFFFFFFF attempts | 0x2EE0 (12000 attempts)

Description

Specifies the maximum number of times Windows 2000 polls the hardware. If the number of trials specified in this entry is exceeded, Windows 2000 stops polling. This entry is used on keyboards other than old-style AT keyboards.

You might consider increasing this value if the driver does not initialize or operate correctly and the System Log in Event Viewer contains the following message from the source, i8042prt :

The operation on <driver name> timed out (time out is configurable via the Registry).

Note Image Note

Unlike some entries in this subkey, this entry remains in the Parameters subkey and is read from this location even after a keyboard is installed.

Related Entries

PollingInterationsMaximum


PollingIterationsMaximum

HKLM\SYSTEM\CurrentControlSet\Services\i8042prt\Parameters

Data type | Range | Default value
REG_DWORD | 0x400 - 0xFFFFFFFF attempts | 0x2EE0 (12000 attempts)

Description

Specifies the maximum number of times Windows 2000 polls the hardware on older-style AT keyboards. If the number of trials specified in this entry is exceeded, Windows 2000 stops polling.

You might consider increasing this value if the driver does not initialize or operate correctly and the System Log in Event Viewer contains the following message from the source, i8042prt :

The operation on <driver name> timed out (time out is configurable via the Registry).

Note Image Note

Unlike some entries in this subkey, this entry remains in the Parameters subkey and is read from this location even after a keyboard is installed.

Related Entries

PollingInterations


PollStatusIterations

HKLM\SYSTEM\CurrentControlSet\Services\i8042prt\Parameters

Data type | Range | Default value
REG_DWORD | 0x1 - 0xFFFFFFFF | 0x1

Description

(This entry has limited use in Windows 2000. See Notes below.)

Specifies the maximum number of times the system verifies interrupts on the i8042 controller status register. If the interrupt cannot be verified in the number of trials specified in PollStatusIterations, the interrupt is ignored.

This entry is designed to minimize the effect of interrupts raised before the Output Buffer Full bit is set in the i8042 status register. This condition occurs on some computers, such as the Olivetti MIPS computer.

If the system seems to ignore keyboard interrupts, increase the value of this entry. The system might mistakenly ignore an interrupt if the Output Buffer Full bit is not set when the interrupt is raised. However, if you increase the value of PollStatusIterations, the Interrupt Service Routine will take longer to execute because there is a one-microsecond delay following each check for Output Buffer Full.

Note Image Note

This entry is used only when a device is installed. When the system recognizes a new device, it copies this entry to a device-specific subkey in the Enum subkey. Thereafter, it uses only the entries in Enum.

Tip Image Tip

To determine whether the driver is processing keyboard interrupts correctly, press the NUM LOCK key. If the Num Lock light on the keyboard turns on or off, this indicates that the i8042prt driver handled the keyboard interrupt correctly.


ResendIterations

HKLM\SYSTEM\CurrentControlSet\Services\i8042prt\Parameters

Data type | Range | Default value
REG_DWORD | 0x1 - 0xFFFFFFFF | 0x3

Description

Specifies the maximum number of times a hardware operation is attempted. If the number of trials exceeds the value of this entry, Windows 2000 considers the operation to have failed.

You might consider increasing this value if the driver does not initialize or operate correctly and the System Log in Event Viewer contains the following message from the source, i8042prt :

Exceeded the allowable number of retries (configurable via the Registry) on device <device-name>.

Note Image Note

Unlike some entries in this subkey, this entry remains in the Parameters subkey and is read from this location even after a keyboard is installed.


SampleRate

HKLM\SYSTEM\CurrentControlSet\Services\i8042prt\Parameters

Data type | Range | Default value
REG_DWORD | Mouse sampling rate in Hz | 0x3C (60 Hz)

Description

(This entry has limited use in Windows 2000. See Notes below.)

Specifies how often the PS/2 driver measures the characteristics and activities of the PS/2 mouse. The driver uses the information gathered by sampling to optimize the operation of the mouse device.

Note Image Note

This entry is used only when a device is installed. When the system recognizes a new device, it copies this entry to a device-specific subkey in the Enum subkey. Thereafter, it uses only the entries in Enum.

Tip Image Tip

To view or change the value of this entry for a particular PS/2 mouse, use Device Manager. In the tree control, click Device and then, in the results pane, click Mouse, double-click the device name, and click the Advanced Settings tab. This value appears in the Sample Rate box.


IAS

HKLM\SYSTEM\CurrentControlSet\Services\

Description

The IAS subkey stores configuration data for the Internet Authentication Service (IAS) in Windows 2000 Server.

IAS performs centralized authentication, authorization, auditing, and accounting of user who connect to a network by using the virtual private network and dial-up functions.


Parameters

HKLM\SYSTEM\CurrentControlSet\Services\IAS\

Description

The IAS\Parameters subkey stores configuration data for the Internet Authentication Service (IAS) in Windows 2000 Server.

IAS performs centralized authentication, authorization, auditing, and accounting of user who connect to a network by using the virtual private network and dial-up functions.


Allow SNMP Set

HKLM\SYSTEM\CurrentControlSet\Services\IAS\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether Internet Authentication Service (IAS) accepts incoming Simple Network Management Protocol (SNMP) Set messages. This entry applies only when SNMP is being used to monitor the Internet Authentication Service (IAS).

Set messages change or update values in an SNMP management information database (MIB). IAS accepts these messages only when an agent has permission to write to the MIB.

Set messages are prohibited by default, but you can add this entry to the registry to permit the IAS to accept Set messages.

Value | Meaning
0 | IAS rejects Set messages.
1 | IAS accepts set messages.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


Ping User-Name

HKLM\SYSTEM\CurrentControlSet\Services\IAS\Parameters

Data type | Range | Default value
REG_SZ | User name | Blank

Description

Specifies a user name (or user name pattern with variables) that the Internet Authentication Service (IAS) recognizes as a fictitious name. As a result, IAS rejects authentication requests and responds to all accounting requests from this user. Also, IAS does not record transactions involving this user in any log files.

Proxy servers implementing the Remote Authentication Dial-In User Service (RADIUS) protocol and Network Access Servers periodically send authentication and accounting requests (known as "ping requests" to verify that the server is responsive. These ping requests include fictional user names.

This entry helps IAS recognize the fictitious name or naming scheme used in ping requests. This method is likely to improve IAS performance and make the event log easier to interpret.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Tip Image Tip

To indicate more than one user name, enter a name pattern, such as a DNS name including wildcard characters. For help with patterns, search for "pattern-matching" in Windows 2000 Help.


LanmanServer

HKLM\SYSTEM\CurrentControlSet\Services\

Description

The LanmanServer subkey stores configuration data for the LAN Manager 2.x server service.


Parameters

HKLM\SYSTEM\CurrentControlSet\Services\LanmanServer\

Description

The Parameters subkey stores configuration data that is specific to the LAN Manager Server service.


MaxFreeConnections

HKLM\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters

Data type | Range | Default value
REG_DWORD | 2 - 100 connection blocks | There is no default value for this entry.

Description

Specifies the maximum number of free connection blocks maintained for each endpoint.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


MaxGlobalOpenSearch

HKLM\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters

Data type | Range | Default value
REG_DWORD | 0x1 - 0xFFFFFFFF searches | 0x1000 (4096)

Description

Determines the maximum number of core searches that can be active simultaneously on the server.

This entry is designed to limit the resources used by active core searches. A high value allows more searches to be active, but can use up more server resources. A low value saves server resources, but can impair clients who run many simultaneous searches.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


MaxKeepSearch

HKLM\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters

Data type | Range | Default value
REG_DWORD | 10 - 10,000 seconds | 3600 (1 hour)

Description

Specifies the maximum time that the Server service will support an MS-DOS search. If the time specified by value of this entry expires, the search is terminated.

A longer search time provides better interoperability with MS-DOS utilities performing operations such as tree-copy and delete-node. However, long searches use more memory and can cause unusual behavior on the local computer, such as a failure of a local directory-delete operation.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

MaxGlobalOpenSearch


MaxLinkDelay

HKLM\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0x100000 seconds | 0x3C (60 seconds)

Description

Specifies the maximum time a connection can be delayed before the Server service disables raw I/O for the connection.

Raw I/O is an optimizing feature that permits the Server service to send unsegmented data across the network. Because raw I/O can cause delays, the service disables it in an attempt to resolve the delay.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


MaxMpxCt

HKLM\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters

Data type | Range | Default value
REG_DWORD | 1 - 125 requests | 50

Description

Specifies a suggested limit on the number of outstanding client requests that can be maintained for each client on this server. Because the limit on outstanding requests is negotiated between the client and server and enforced by the client, this value might not be the actual maximum used.

Increasing this value might improve server performance, but it requires more receive buffers (work items) on the server.

Note Image Note

For Windows NT 4.0 Service Pack 3 and later, the valid values for this entry range from 1 to 65535 requests, with a default value of 50 requests. For Windows 2000, the maximum value for this entry is limited to 125 requests to assure that Windows 95 and Windows 98 clients can connect to the server.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Tip Image Tip

If you are running Windows 2000 Terminal Server with many clients and are experiencing communication delays, you might improve server performance by increasing the value of this entry. For more information, see the Microsoft Knowledge Base link on the Web Resources page. Search the Knowledge Base for Article Q191370, or use the keywords MaxMpxCt.


MaxNonpagedMemoryUsage

HKLM\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters

Data type | Range | Default value
REG_DWORD | 0x100000 - 0xFFFFFFFF bytes | (Depends on the amount of physical memory in the computer.))

Description

Specifies the maximum amount of space that the Server service is permitted to allocate from the nonpaged memory pool at one time.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


MaxPagedMemoryUsage

HKLM\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters

Data type | Range | Default value
REG_DWORD | 0x100000 - 0xFFFFFFFF bytes | (Depends on the amount of physical memory in the computer.))

Description

Specifies the maximum amount of space that the Server service is permitted to allocate from the paged memory pool at one time.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


MaxRawWorkItems

HKLM\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters

Data type | Range | Default value
REG_DWORD | 1 - 512 buffers | (Depends upon configuration.)

Description

Determines the maximum number of raw work items (undivided receive buffers) that the Server service can allocate each time it runs. If this limit is reached, the Server service rejects further requests from the client for raw I/O operations.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


MaxThreadsPerQueue

HKLM\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters

Data type | Range | Default value
REG_DWORD | 1 - 65,535 threads | 10

Description

Determines the maximum number of threads the server creates to service its processor queue.

The Server service maintains a separate queue of client requests for each processor on the computer. The server dynamically adjusts the number of threads available to service client requests and always uses the smallest number of threads possible to achieve maximum server throughput.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


LanmanWorkstation

HKLM\SYSTEM\CurrentControlSet\Services\

Description

The LanmanWorkstation subkey stores configuration data for the Workstation service. The Workstation service provides network connections and communications on both computers running Windows 2000 Professional and Windows 2000 Server.


Parameters

HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\

Description

The LanmanWorkstation\Parameters subkey stores configuration data for the Workstation service. The Workstation service provides network connections and communications on both computers running Windows 2000 Professional and Windows 2000 Server.


BufFilesDenyWrite

HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether the redirector saves in a memory cache files that are opened with only FILE_SHARE_READ sharing access. Typically, files opened with FILE_SHARE_READ specified cannot be cached because other processes might be reading the file. This optimization prevents other processes from writing to the file. Set this value to 0 to preserve the strict semantics of the specified sharing modes.

Value | Meaning
0 | Shared files cannot be cached.
1 | Permits the Workstation service to cache shared files.


BufNamedPipes

HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether the redirector caches character-mode named pipes. If named pipes are not stored in the cache, they are flushed to the server immediately, and read-ahead is disabled on these named pipes.

Value | Meaning
0 | Character-mode named pipes are not cached.
1 | Permits the Workstation service to cache character-mode named pipes.


CacheFileTimeout

HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF seconds | 0xA (10 seconds)

Description

Determines how long a file can remain in the cache after it is closed. If the file is not reopened before the time indicated by the value of this entry expires, it is flushed from the cache.

Increase the value of this entry if you are performing operations on the server, such as performing a build over the network, that regularly reopens files more than 10 seconds after an application has closed them.

Related Entries

DormantFileLimit


CollectionTime

HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters

Data type | Range | Default value
REG_DWORD | 0 - 65,535,000 milliseconds | 250

Description

Specifies the maximum time that application data waiting to be written is permitted to remain in the character-mode buffer of a named pipe.

The redirector writes data from the character-mode buffer when the amount of buffered data reaches the size threshold established by the value of the MaxCollectionCount entry. However, if the application has written at least one byte of data to the buffer but not enough data to reach the size threshold, the contents of the buffer are written when the time specified by this value expires.

Increasing the value of this entry can improve the performance of a named pipe applications. However, it does not affect applications, such as SQL Server applications, which do their own buffering.

Related Entries

SizCharBuf


ConnectTimeout

HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF seconds | 0x12C (300 seconds or 5 minutes)

Description

Specifies the maximum amount of time the redirector waits for a connect or disconnect to complete.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


DormantFileLimit

HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF files | 45

Description

Determines how many files on each share can remain open in the redirector's cache after an application has closed them. If the number of open, cached files on a share exceeds the value of this entry, the system begins to close the cached files.

The Windows redirector keeps files open in the cache after an application has closed the file. This entry is designed to prevent cached files from occupying the limited number of places available for open files. By default, LAN Manager servers permit only 60 files from remote clients and 50 files from each client workstation to remain open.

Related Entries

CacheFileTimeout


IllegalDatagramResetTime

HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF seconds | 0xE10 (3600 seconds = 1 hour)

Description

Specifies the length of an interval during which the system counts illegal-datagram events.

The system limits the number of illegal-datagram events that can be counted during this interval to the value of the NumIllegalDatagramEvents entry. Events that are counted are recorded in the System Log in Event Viewer.

IllegalDatagramResetTime and NumIllegalDatagramEvents are designed to prevent the system log from becoming filled with illegal-datagram events.

Related Entries

NumIllegalDatagramEvents


KeepConn

HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters

Data type | Range | Default value
REG_DWORD | 1 - 65,535 seconds | 600 (10 minutes)

Description

Specifies the maximum amount of time that an idle connection can remain open. If the idle time for a connection reaches the value of this entry, the connection is closed.

Increase the value of this entry if your application closes and opens UNC files on a server less frequently than every 10 minutes. This decreases the number of reconnections to a server.


LockIncrement

HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF milliseconds | 0xA (10)

Description

Determines how long an OS/2–based application can wait when a request for a lock fails. If the lock request cannot be granted before the time specified in this entry expires, the redirector rejects the lock request. This entry is used when OS/2–based applications on servers other than those running LAN Manager version 2.0 and later request that a lock operation wait indefinitely, or if the lock cannot be granted immediately.

Note Image Note

Do not change this value unless you are running an OS/2–based application that requests lock operations which might fail. This entry does not affect Windows 32–bit applications.


LockMaximum

HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF milliseconds | 0x1F4 (500)

Description

Used to configure the lock backoff package. This entry exists to prevent an errant application from consuming server time by issuing nonblocking requests when there is no data available for the application.


LockQuota

HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF bytes | 0x1000 (4 KB)

Description

Specifies the maximum amount of data that can be read from a file when the value of the UseLockReadUnlock entry is 1.

Consider increasing the value of this entry if your application performs a significant number of lock-and-read operations. These are operations in which an application locks data and reads the data immediately thereafter.

Caution Image Caution

Increasing this value to more than 2 MB and using an application that locks megabtyes of data can cause the system to deplete its paged pool.


LogElectionPackets

HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether the browser generates an event when an election packet is received.

Value | Meaning
0 | The browser does not generate an event.
1 | The browser writes an event to the System Log in Event Viewer.


MailslotBuffers

HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF buffers | 3

Description

Determines the maximum number of buffers available to process mailslot messages. If your program uses many mailslot operations, you can increase this value to avoid losing mailslot messages.

Note Image Note

The default value of this entry changed on Windows 2000. On Windows NT 4.0 and earlier, the default value is 5 buffers.


MaxCmds

HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters

Data type | Range | Default value
REG_DWORD | 0 - 255 network control blocks | 15

Description

Specifies the maximum number of network control blocks that the redirector is permitted to reserve. The value of this entry coincides with the number of execution threads that can be outstanding simultaneously.

Increase this value to improve network throughput, especially if you are running applications that perform more than 15 simultaneous operations. However, because this entry also limits the number of outstanding execution threads, your network performance might not improve. Each additional execution thread uses a margin of 1 KB of nonpaged pool when the network is at capacity. However, these resources are not consumed until the user references data in the network control block.


MaxCollectionCount

HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFF bytes (0 - 65,535) | 0x10 (16)

Description

Specifies the amount of data that must be present in the character-mode buffer of a named pipe to trigger a write operation. If the amount of data in the buffer meets or exceeds this value, it is written immediately. Otherwise, it is retained in the buffer until more data is added or the value of the CollectionTime entry expires.

Increasing the value of this entry can improve the performance of named-pipe applications, but it does not affect applications, such as SQL Server applications, which do their own buffering.

Related Entries

SizCharBuf


NumIllegalDatagramEvents

HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF events | 0x5

Description

Specifies the maximum number of illegal-datagram events that can be counted within the interval defined by the value of the IllegalDatagramResetTime entry. Events that are counted are then recorded in the System Log in Event Viewer.

IllegalDatagramResetTime and NumIllegalDatagramEvents are designed to prevent the System Log from becoming filled with illegal-datagram events.

Related Entries

IllegalDatagramResetTime


OtherDomains

HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters

Data type | Range | Default value
REG_SZ | Domain name | (Blank value)

Description

Specifies additional Microsoft LAN Manager domains listed for browsing.


PipeIncrement

HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF milliseconds | 0xA (10)

Description

Controls the rate at which the redirector "backs off" on failing nonblocking named pipe read operations.

This entry is used to prevent an errant application from swamping a server with nonblocking requests when there is no data available for the application. You can use the backoff statistics to tune this entry to be more efficient for an application that uses nonblocking named pipes. However, this value does not affect applications, such as SQL Server applications, which do their own buffering.


PipeMaximum

HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF milliseconds | 0x1F4 (500)

Description

Controls the maximum time at which the redirector "backs off" on failing nonblocking named pipe read operations.

This entry exists to prevent an errant application from swamping a server with nonblocking requests when there is no data available for the application. You can use the backoff statistics to tune this entry to be more efficient for an application that uses nonblocking named pipes (except for SQL Server applications).


SessTimeout

HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters

Data type | Range | Default value
REG_DWORD | 10 - 65,535 seconds | 45

Description

Determines the duration of the secondary delay used in calculating a time-out value for outstanding operations. If the redirector does not receive a response to an outstanding operation before the resulting time-out expires, it considers the operation tdo have failed. The value of the SessTimeout entry can be thought of as a margin for error. If there is an unexpected delay, the redirector permits the operation this extra time to complete.

The redirector adds the value of this entry to the expected response time for a server message block (SMB). The resulting time-out is calculated dynamically, and is approximately equal to:

[(SMB size + Size of data sent or received) / bytes per second] + SessTimeout.

SessTimeout is used for all protocols, including TCP/IP. However, it does not apply to certain types of SMBs, such as transaction commands, that have their own time-out variable in the SMB.

Note Image Note

SessTimeout for Windows 2000 is different from SessTimeout for LAN Manager. In Windows 2000, SessTimeout is just one factor in the time-out equation. In LAN Manager, it is the actual time-out value.


SizCharBuf

HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters

Data type | Range | Default value
REG_DWORD | 64 - 4096 bytes | 512

Description

Specifies the size of the character buffers for a named pipe. The redirector maintains a read-ahead buffer and a write-behind buffer for each pipe. This entry establishes the size of both buffers.

The buffer size determines the amount of data the redirector reads and writes.

When reading, the redirector attempts to read enough data to fill the read buffer. If the data it is reading is smaller than the buffer, the redirector reads ahead until the buffer is full. If the data is larger than the buffer, the redirector bypasses the character-mode buffer and reads the data directly into the user buffer.

When writing, the redirector collects data in the character-mode buffer until it meets or exceeds the size specified by the value of the MaxCollectionCount entry, or until the time specified by the value of the CollectionTime entry expires.

Increasing the value of this entry can improve the performance of named-pipe applications, but it does not affect applications, such as SQL Server applications, that do their own buffering.


UseLockReadUnlock

HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether the lock-and-read and write-and-unlock performance enhancements are enabled. These features improve performance when an application locks data and then reads the data immediately thereafter, or writes data and then unlocks it immediately.

Value | Meaning
0 | Lock-and-read and write-and-unlock features are not enabled.
1 | Enables the lock-and-read and write-and-unlock features.

Caution Image Caution

Setting this value to 1 usually improves performance significantly. However, it degrades the performance of database applications that lock a range of data and do not allow data within that range to be read.

Related Entries

LockQuota


UseOpportunisticLocking

HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether the opportunistic-locking (oplock) performance enhancement is enabled. If enabled, the redirector requests an opportunistic lock on any file opened in "Deny None" mode. As a result, the server performs automatic read-ahead and write-behind caching on behalf of the redirector.

Value | Meaning
0 | Disables opportunistic locking.
1 | Enables opportunistic locking.

Note Image Note

Opportunistic locks improve performance significantly. Do not change the value of this entry unless you are testing the system.


UseUnlockBehind

HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether the unlock-behind optimization feature is enabled. If enabled, the redirector unlocks data immediately in response to an unlock request. It does not wait for confirmation from the server that the unlock operation is complete.

Value | Meaning
0 | Disables the unlock-behind optimization feature.
1 | Enables the unlock-behind optimization feature.

Note Image Note

Unlock-behind optimization improves performance significantly. Do not change the value of this entry unless you are testing the system.


Mouclass

HKLM\SYSTEM\CurrentControlSet\Services\

Description

The Mouclass subkey stores configuration data for the Mouseclass device driver. The Mouseclass device driver handles hardware-independent operations on a specific class of devices; in this case, the mouse and other pointing devices. The port drivers manage the hardware-specific operations.


Parameters

HKLM\SYSTEM\CurrentControlSet\Services\Mouclass\

Description

The Parameters subkey in the Mouclass subkey stores configuration data for the Mouseclass device driver. The Mouseclass device driver handles hardware-independent operations on a specific class of devices; in this case, the mouse and other pointing devices. The port drivers manage the hardware-specific operations.


ConnectMultiplePorts

HKLM\SYSTEM\CurrentControlSet\Services\Mouclass\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether there is one or more than one port device object for each class device object. This entry is used primarily by device drivers.

Value | Meaning
0 | 1:1. Indicates that the class device object created by the driver is connected to one port device object.
1 | 1:Many. Indicates that the class device object created by the driver is connected to multiple port device objects. As a result, the events generated by all pointing devices on the system are fed to the Windows subsystem in a single input stream.

Related Entries

MaximumPortsServiced


MaximumPortsServiced

HKLM\SYSTEM\CurrentControlSet\Services\Mouclass\Parameters

Data type | Range | Default value
REG_DWORD | 0x1 - 0xFFFFFFFF | 0x3

Description

Specifies the maximum number of port devices the mouse class device driver can connect to and service.

Note Image Note

This entry establishes a maximum. If the actual number of port devices is greater than one, the value of ConnectMultiplePorts must be 1.

Related Entries

ConnectMultiplePorts


MouseDataQueueSize

HKLM\SYSTEM\CurrentControlSet\Services\Mouclass\Parameters

Data type | Range | Default value
REG_DWORD | 0x1 - 0xFFFFFFFF | 0x64 (100)

Description

Specifies the number of mouse events buffered by the mouse driver. It also is used in calculating the size of the mouse driver's internal buffer in nonpaged memory pool.

To determine the number of bytes to allocate for the buffer, the system multiplies the size of the MOUSE_INPUT_DATA structure (defined in NTDDMOU.H) by the value of MouseDataQueueSize.

You might consider increasing this value if the driver does not initialize or operate correctly and the system event log contains the following message from the source, Mouclass:

"The ring buffer that stores incoming mouse data has overflowed (buffer size is configurable via the Registry)."


PointerDeviceBaseName

HKLM\SYSTEM\CurrentControlSet\Services\Mouclass\Parameters

Data type | Range | Default value
REG_SZ | Base port device name | PointerClass

Description

Specifies the base name for the device objects created by the mouse class device driver.

Note Image Note

The device driver stores information about the device in a subkey of DEVICEMAP (HKEY_LOCAL_MACHINE\HARDWARE\DEVICEMAP) that has the same name as the value of this entry. The pointer class driver uses the DEVICEMAP subkey to locate the pointer port device objects.


MRxSmb

HKLM\SYSTEM\CurrentControlSet\Services\

Description

The MRxSmb subkey stores configuration data for the Browser Server service. The Browser Service provides the list of participating browser servers on the network.


Parameters

HKLM\SYSTEM\CurrentControlSet\Services\MRxSmb\

Description

The MRxSmb\Parameters subkey stores configuration data for the Browser Server service. The Browser Service provides the list of participating browser servers on the network.


BackupBrowserRecoveryTime

HKLM\SYSTEM\CurrentControlSet\Services\MRxSmb\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF milliseconds | 0x1B7740 (1,800,000 millseconds = 30 minutes)

Description

Determines how long a backup server must wait after being stopped before it can accept another request to become a backup server.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


BrowserFindMasterTimeout

HKLM\SYSTEM\CurrentControlSet\Services\MRxSmb\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF seconds | 0xFFFFFFFF seconds

Description

Specifies the maximum duration of FindMaster requests. If a FindMaster request takes longer than the value of this entry, the request is cancelled.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry. In Windows NT 3.1 and earlier, add this entry to the DGRcvr\Parameters subkey.


BrowserMinimumConfiguredBrowsers

HKLM\SYSTEM\CurrentControlSet\Services\MRxSmb\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF | 0x1

Description

Specifies the minimum number of backup servers that the master browser attempts to promote.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


EnablePlainTextPassword

HKLM\SYSTEM\CurrentControlSet\Services\MRxSmb\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether the SMB redirector can send unencrypted passwords to servers that request them.

The SMB redirector always sends encrypted passwords unless a server specifically requests an unencrypted password. If the value of this entry is 0, the SMB redirector sends only encrypted passwords. If a server requests an unencrypted password, the request fails. However, you can set the value of this entry to 1 to force the redirector to send an unencrypted password when a server requests one. This permits you to connect to SMB servers that do not support password encryption, such as Samba, Hewlett-Packard (HP) LM/X, or LAN Manager for UNIX. Microsoft SMB servers never request unencrypted passwords.

Value | Meaning
0 | The SMB redirector sends encrypted passwords only. Requests for unencrypted passwords fail.
1 | The SMB redirector can send unencrypted passwords to servers that request them.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry. This entry is supported only by Windows NT 4.0 with Service Pack 3 and later.


GetBrowserListThreshold

HKLM\SYSTEM\CurrentControlSet\Services\MRxSmb\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFE | 0xFFFFFFFF | 0xFFFFFFFF

Description

Establishes the maximum number of browser redirector requests that can be missed in one hour without generating an event. If more requests are missed, the browser service writes an event to the System Log in Event Viewer.

Value | Meaning
0x0 - 0xFFFFFFFE | The number of requests that triggers an Event Log message.
0xFFFFFFFF | Events are not generated when requests are missed.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry. In Windows NT 3.1 and earlier, add this entry to the DGRcvr\Parameters subkey.


MailslotDatagramThreshold

HKLM\SYSTEM\CurrentControlSet\Services\MRxSmb\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFE | 0xFFFFFFFF | 0xFFFFFFFF

Description

Establishes the maximum number of mailslot requests that can be missed in one hour without generating an event. If more requests are missed, the browser service writes an event to the System Log in Event Viewer.

Value | Meaning
0x0 - 0xFFFFFFFE | The number of requests that triggers an Event Log message.
0xFFFFFFFF | No events are generated when requests are missed.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry. On Windows NT 3.1 and earlier, add this entry to the DGRcvr\Parameters subkey.


MaximumBrowseEntries

HKLM\SYSTEM\CurrentControlSet\Services\MRxSmb\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF table entries | 0x186A0 (100,000 entries)

Description

Specifies the maximum number of entries in the browser table.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


NDIS

HKLM\SYSTEM\CurrentControlSet\Services\

Description

The NDIS subkey stores configuration data for the NDIS interface in Windows 2000, Ndis,sys.

Ndis.sys supports communication between protocol drivers, network interface drivers and network adapters. Ndis.sys acts as an intermediary between protocol drivers and network adapters, so that they can remain independent, allowing a network adapter to support multiple network protocols, such as TCP/IP and IPX. It also allows multiple network interface drivers and multiple network adapters to co-exist within a system.


Parameters

HKLM\SYSTEM\CurrentControlSet\Services\NDIS\

Description

The NDIS\Parameters subkey stores configuration data for the NDIS 5.0 interface in Windows 2000, Ndis.sys.

Ndis.sys supports communication between protocol drivers, network interface drivers, and network adapters. Ndis.sys acts as an intermediary between protocol drivers and network adapters, so that they can remain independent and allow a network adapter to support multiple network protocols, such as TCP/IP and IPX. It also allows multiple network interface drivers and multiple network adapters to co-exist within a system.


ProcessorAffinityMask

HKLM\SYSTEM\CurrentControlSet\Services\NDIS\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 | 0x1 - 0xFFFFFFFE | 0xFFFFFFFF | 0xFFFFFFFF (-1)

Description

Specifies which processors can be associated with a network adapter and service the delayed procedure calls (DPCs) generated by that network adapter. This entry is designed for multiprocessor computers, specifically those with more than one network adapter.

Each of the 32 bits in the value of ProcessorAffinityMask represents one processor. The high bit represents processor 32, and the low bit represents processor 0.

If a bit is set to 1, the processor represented by the bit can be associated with a network adapter and service all of the DPCs it generates.

If a bit is set to 0, the processor represented by the bit cannot be associated with any particular network adapter. When a network adapter is not associated with a processor, its DPCs are serviced by the same processor that serviced the interrupt from which the DPC evolved.

Value | Meaning
0x0 | If the value of this entry is 0 (all bits are set to 0), none of the processors are associated with network adapters. DPCs are serviced by the same processor that serviced the interrupt. This setting is useful for platforms that distribute interrupts among all processors, such as the Windows 2000 and Windows NT 4.0 platforms for Intel Pentium and Pentium Pro (P6) processors.
0x1 - 0xFFFFFFFE | If some of the bits are set to 0 and others are set to 1, the system skips processors associated with bits set to 0 and assigns network adapters to processors whose bits are set to 1.
0xFFFFFFFF | If the value of this entry is 0xFFFFFFFF (all bits are set to 1), all processors on the computer can be associated with network adapters. If there are multiple processors and multiple network adapters, each adapter is associated with one processor and services all of its DPCs. The first adapter is associated with the processor with the highest number. Subsequent adapters are associated with the next processor in descending numeric order. If there are more adapters than there are processors, the system begins again at the highest numbered processor and assigns a network adapter to each remaining processor in descending numeric order.


NdisWan

HKLM\SYSTEM\CurrentControlSet\Services\

Description

The NdisWan subkey stores configuration data for NDISWAN drivers supporting Remote Access Service (RAS). The NdisWan subkey appears in the registry only when RAS is installed on the computer.

NDISWAN is an intermediate-level Network Device Interface Specification (NDIS) driver that lies between a 802.3 miniport to a WAN miniport, converting NDIS packets to WAN packets. NDISWAN supports PPP protocol/link framing, compression, and encryption.


Parameters

HKLM\SYSTEM\CurrentControlSet\Services\NdisWan\

Description

The NdisWan\Parameters subkey stores configuration data for NDISWAN drivers supporting Remote Access Service (RAS). The NdisWan subkey appears in the registry only when RAS is installed on the computer.

NDISWAN is an intermediate-level Network Device Interface Specification (NDIS) driver that lies between a 802.3 miniport to a WAN miniport, converting NDIS packets to WAN packets. NDISWAN supports PPP protocol/link framing, compression, and encryption.


IGMPIdle

HKLM\SYSTEM\CurrentControlSet\Services\NdisWan\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether NdisWan drivers consider Internet Group Management Protocol (IGMP) packets to be valid communications traffic.

Many servers send IGMP packets periodically to prevent a quiet, but active line from being mistaken for an idle line. These packets can be misinterpreted as communication. They can also prevent a truly idle line from being disconnected.

Value | Meaning
0 | IGMP packets are considered to be valid communications traffic that keeps a line active.
1 | IGMP packets are filtered out and not counted as valid communications traffic.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


Netlogon

HKLM\SYSTEM\CurrentControlSet\Services\

Description

The Netlogon subkey stores information for the Net Logon service.

The Net Logon service verifies logon requests and registers, authenticates, and locates domain controllers. Also, to maintain backward compatibility, Net Logon manages replication of the user account database to backup domain controllers running Windows NT 4.0 and earlier.

For Windows 2000, Net Logon manages replication only when it involves servers running Windows NT 4.0 and earlier. Net Logon for Windows 2000 does not manage replication between two servers running Windows 2000.


Parameters

HKLM\SYSTEM\CurrentControlSet\Services\Netlogon\

Description

The Parameters subkey stores configuration data specific to the Net Logon service.

The Net Logon service verifies logon requests, and registers, authenticates, and locates domain controllers. Also, to maintain backward compatibility, Net Logon manages replication of the user account database to backup domain controllers running Windows NT 4.0 and earlier.

Note Image Note

For Windows 2000, Net Logon manages replication only when it involves servers running Windows NT 4.0 and earlier. Net Logon for Windows 2000 does not manage replication between two servers running Windows 2000.


AllowRepInNonMixed

HKLM\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether backup domain controllers running Windows NT 4.0 and earlier can replicate from this primary domain controller even when the primary domain controller is not configured to be in mixed mode.

This entry is used only when it appears in the registry of a primary domain controller running Windows 2000.

Value | Meaning
0 | When the PDC is configured to be in non-mixed mode, only BDCs running Windows 2000 can replicate from it.
1 | BDCs running Windows NT 4.0 and earlier can replicate from this PDC, even when it is not configured to be in mixed mode.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


AutoSiteCoverage

HKLM\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether the system can add sites to the coverage area of this domain controller.

Domain controllers "cover," that is, provide services, to the site in which they reside and to other sites listed in the value of SiteCoverage. In addition, when the value of this entry is 1, the system can add sites that do not have domain controllers to this domain controller's coverage area.

Value | Meaning
0 | The system cannot add sites to the coverage area of this domain controller.
1 | The system can add sites to the coverage area of this domain controller.

The sites added to the domain controller's coverage are stored in memory and a new list is assembled each time the Net Logon service starts. While Net Logon runs, it updates this list at an interval specified by the value of DnsRefreshInterval
.

To determine this extended site coverage, the Net Logon service uses information from the Active Directory. It applies the criteria listed below to determine which domain controller can provide the best service to a non-covered site. By default, all domain controllers are candidates for a non-covered site. However, you use this entry to exclude domain controllers from the selection pool, the system might not be able to select the best domain controller for the site.

The criteria are applied in the order shown and each subsequent criterion is applied only if the candidate domain controllers were equal on all previous criteria.

  • Connection cost: The connection to the domain controller is less costly than connections to other domain controllers in the domain;
  • Most domain controllers: The site in which the domain controller resides has more domain controllers than other sites;
  • Alphabetical order (tie breaker): The name of the site in which the domain controller resides is earlier in the alphabet than the site names of other domain controllers.

Note Image Note

This entry is used only when it appears in the registry of a domain controller.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Tip Image Tip

The list of additional sites computed for each domain controller is recorded in Netlogon.log when the value of DBFlag
is at least 0x20. To direct Net Logon to record the process it uses to compute site coverage, set the value of DBFlag to 0x800FFFF.

Related Entries

SiteCoverage

GcSiteCoverage


AvoidPdcOnWan

HKLM\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Prevents the Backup Domain Controller (BDC) from sending new password information to a remote Primary Domain Controller (PDC). Also, if a client password fails to authenticate on the BDC, the BDC does not attempt to authenticate that password on the remote PDC. Instead of Net Logon, the PDC and BDC use Active Directory replication to update password information.

This entry does not affect password sharing between BDCs and PDCs residing on the same site. If the BDC and PDC are on the same site, the BDC sends password information regardless of the value of this entry.

Setting this value to 1 can reduce WAN traffic between domain controllers at remote locations, but PDCs might not always have the most current password data. As a result, legitimate users might not be authenticated.

Value | Meaning
0 | BDC sends password information to remote PDC.
1 | BDC sends password information to PDCs within the site.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


ChangeLogSize

HKLM\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters

Data type | Range | Default value
REG_DWORD | 0x10000 - 0x400000 bytes (64 KB - 4 MB) | 0x10000 (64 KB)

Description

Specifies the maximum size of the Net Logon transaction log, Netlogon.chg. This limit applies to space allocated for the transaction log in physical memory and on disk in Systemroot\Netlogon.chg. The typical size of an entry is 32 bytes, so a 64 KB log holds approximately 2,000 entries.

Note Image Note

The value of ChangeLogSize should be the same on all backup domain controllers. This consistency ensures that when a backup domain controller is promoted to a primary domain controller, it has the same ChangeLogSize value as the other backup domain controllers.

Increasing the value of this entry to 4 MB does not degrade system performance. The 4 MB setting ensures that the only those segments of the domain's database that changed are replicated.

For Windows 2000, the Net Logon transaction log records only those replication-related changes involving servers running Windows NT 4.0 and earlier. Net Logon for Windows 2000 does not manage replication between servers running Windows 2000.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits it.


CloseSiteTimeout

HKLM\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters

Data type | Range | Default value
REG_SZ | 0x3C - 0x418937 seconds (1 minute - 49.7 days) 49.7 days) | 0x384 (15 minutes)

Description

Determines how often the Net Logon service attempts to find a nearby domain controller. The value of this entry specifies the minimum time that must elapse between attempts. The value is used when Net Logon is using a domain controller in a site that is not nearby, but a client requires a domain controller in a site near it.

This value does not apply when Net Logon is finding a domain controller to authenticate an interactive logon that is using pass-through authentication on a secure channel. Such transactions are not subject to any minimum time between attempts.

This value is used to separate attempts to locate domain controllers when a secure channel is used for other communications, such as pass-through authentication of a network logon.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Caution Image Caution

Use caution when changing this value. If this value is too high, the requesting client might be delayed significantly. If this value is too low, repeated attempts to find the domain controller can create excessive network traffic.


DBFlag

HKLM\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters

Data type | Range | Default value
REG_SZ | 0x0 - 0xFFFFFFFF (0 - 4294967295) | 0

Description

A bitmask that determines the characteristics of the Net Logon debugging log, Netlogon.log.

For detailed debugging of the Net Logon service for Windows 2000, set the value of this entry to 0xFFFF. To debug replication problems between Windows 2000 and Windows NT 4.0 and earlier, set the value to 0x80FFFF. On computers running Windows NT 4.0 and earlier, set the value to 0x2080FFFF.

Change method

To change the value of DBFlag, use Nltest, a command-line tool for Net Logon administration in the \Support\Tools folder of the Windows 2000 operating system CD. At the command line, type:

Nltest /DBFLAG:<Hexadecimal value>.

Do not edit the registry.

Activation method

To make changes to this entry effective, you must restart the computer.

Note Image Note

You can enter values in decimal or hexadecimal format. All hexadecimal values must be preceded by the "0x" characters.

Netlogon.dll is fully supported in Windows 2000. In Windows NT 4.0 and earlier, the debugging log is supported only by the internal debugging versions of Netlogon.dll. To use this functionality on Windows NT 4.0 and earlier, obtain a debugging version of Netlogon.dll from Microsoft Product Support Services at http://support.microsoft.com.

Tip Image Tip

For a complete list of the bitmask values for DBFlag, see the Microsoft Knowledge Base link on the Web Resources page. Search the Knowledge Base using the keywords DBFlag.

To make data entry easier, change the data type of DBFlag programmatically to REG_DWORD.


DisablePasswordChange

HKLM\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Prevents the workstation from changing its computer account password automatically.

By default, Windows 2000 automatically changes the password on the local computer account at regular intervals. You can prevent automatic changes by setting the value of this entry to 1. A value of 1 does not prevent you from changing the computer account password manually or by using a program.

The time between automatic password changes is determined by the value of MaximumPasswordAge. The default value is 30 days.

Value | Meaning
0 | Windows 2000 automatically changes the computer account password at regular intervals.
1 | Windows 2000 never changes the computer account password.

Tip Image Tip

This entry prevents the local computer from sending a password change to the domain controller. To prevent the domain controller from accepting any changes, set the value of RefusePasswordChange to 1.

Caution Image Caution

Disabling automatic password changes can make the system more vulnerable to malicious access. Frequent password changes can be a significant safeguard for your system.

Related Entries

RefusePasswordChange


DnsRefreshInterval

HKLM\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 | 0x1 - 0x418937 seconds | 0xE10 (1 hour)

Description

Determines how often the Net Logon service re-registers DNS names. Repeat registration helps to ensure that DNS names are not lost. This is particularly important to DNS names that are registered dynamically.

The value of this entry also determines how often Net Logon updates the dynamic site coverage list for participating domain controllers. (See AutoSiteCoverage.

After a successful registration, Net Logon re-registers the DNS name after five minutes have passed. The interval between each subsequent registration is doubled until the interval reaches the value of DnsRefreshInterval. Thereafter, Net Logon re-registers DNS names when the value of DnsRefreshInterval expires.

Value | Meaning
0x0 | Net Logon does not re-register DNS names.
0x1 - 0x418937 seconds | Specifies the maximum time between repeated registration of DNS names.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

AutoSiteCoverage


DnsTtl

HKLM\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 | 0x1 - 0x7FFFFFFF seconds | 0x258 (10 minutes)

Description

Determines how long DNS records registered by the Net Logon service are saved in a memory cache in the client computer.

Value | Meaning
0x0 | DNS records registered by Net Logon are not cached.
0x1 - 0x7FFFFFFF seconds | Specifies the maximum time a record is saved in the cache.

This value applies to all records regardless of how frequently or how recently they might be referenced. It ensures that client records are always current.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Tip Image Tip

Increasing the value of this entry might improve performance. However, if this value is too large, the DNS record might not be updated often enough.


DuplicateEventlogTimeout

HKLM\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0x418937 seconds (Up to 49.7 days) | 0x1C20 (2 hours)

Description

Specifies the minimum time that must elapse between the recording of identical events in order for the Net Logon service to write both to the System Log in Event Viewer. If the time between recording is less than the value of this entry, Net Logon regards the second event as a continuation of the first event and does not write it to the System Log.

This entry is designed to minimize the number of repeated entries in the System Log. To direct Net Logon to record all events, set the value of this entry to 0.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


DynamicSiteName

HKLM\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters

Data type | Range | Default value
REG_SZ | String | There is no default value for this entry.

Description

Stores the dynamically-determined site name for the domain in which this member server or workstation is located. The value of this entry is determined by the Net Logon service; it is not specified by an administrator or user.

The value of SiteName always takes precedence over the value of this entry. If SiteName appears in the registry, this value is not used.

Net Logon gets this value from a standard Win32 API call, DsGetDcName, which locates a domain controller in a specified domain. Net Logon calls this function when the computer starts. Other programs can make this call to the Net Logon service.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits it.

This entry is used only when it appears in the registry of a member server or workstation.

Tip Image Tip

To change the site in which the computer resides, use SiteName.

Caution Image Caution

Do not change the value of this entry. This entry stores values determined dynamically by Net Logon.

Related Entries

SiteName

SiteNameTimeout


ExpectedDialupDelay

HKLM\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters

Data type | Range | Default value
REG_DWORD | 0 - 600 seconds | 0

Description

Specifies an amount of additional time that the Net Logon service waits for a response from a domain controller. If the domain controller does not respond before the total time allowed elapses, Net Logon assumes that the domain controller is not available and proceeds accordingly.

This entry is designed to allow extra time for a response when the domain controller is connected by a slow dialup link.

This entry is used to extend time limits for the following conditions:

  • When locating a domain controller in a trusted domain, such as when authenticating a user's logon credentials.

    • Net Logon allows fifteen seconds, plus the value of ExpectedDialupDelay for the domain controller to respond. The timer begins when the first of three datagrams is sent to the domain controller.

    Timeout = 15 seconds + ExpectedDialupDelay seconds
  • When an API call is issued over a secure channel to a domain controller that has already been located.

    • Net Logon allows 45 seconds, plus the value of ExpectedDialupDelay for the domain controller to respond.

    Timeout = 45 seconds + ExpectedDialupDelay seconds

To give remote domain controllers more time to respond, you can add this entry to the registry and increase its value.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


GcSiteCoverage

HKLM\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters

Data type | Range | Default value
REG_MULTI_SZ | Site names | (Blank. The list is empty.)

Description

A list of additional sites in which this domain controller registers itself as a global catalog resource. These sites are in addition to those that Net Logon assumes to be closely related to the site based on their physical proximity, network topology, or bandwidth. As such, this list does not include the site in which the domain controller resides.

You can add this entry to the registry to add sites to the list. This list lets you associate sites which might be logically connected, but physically disparate.

The domain controller considers itself to be closely related to the sites in this list. Therefore, it replicates to the site and, when pinged by a client in the site, indicates that it is close by turning on the "closest site" bit.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits it.

This entry is used only when it appears in the registry of a domain controller.

Related Entries

SiteName

DynamicSiteName

SiteName

SiteCoverage


KdcSrvPort

HKLM\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFF 0x0 - 0xFFFF | 0x58 (88)

Description

Specifies the TCP port number for the Key Distribution Center (KDC) service on the domain controller.

The KDC service is a network authentication service specified by the Kerberos protocol. Windows 2000 implements a KDC as the authentication service on each domain controller.

Note Image Note

This entry is only used when it appears in the registry of a domain controller.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Tip Image Tip

The Net Logon service records the value of this entry on LDAP SRV records it writes. You can view these records by using DNS dynamic update, or by viewing the netlogon.dns file (Systemroot\System32\config). Also, if the value of DBFlag is 0x2080FFFF, Netlogon records the LDAP SRV records in its debugging log, Netlogon.log (Systemroot\debug).

Related Entries

LdapSrvPort

LdapGcSrvPort


LdapGcSrvPort

HKLM\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFF 0x0 - 0xFFFF | 0xCC4 (3268)

Description

Specifies the TCP port number and the UDP port number on which the LDAP server listens for queries to the global catalog.

Note Image Note

This entry is only used when it appears in the registry of a domain controller.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits it.

Tip Image Tip

Net Logon records the value of this entry on LDAP SRV records it writes. You can view these records by using DNS dynamic update, or by viewing the netlogon.dns file (Systemroot\System32\config). Also, if the value of DBFlag is 0x2080FFFF, Net Logon records the LDAP SRV records in its debugging log, Netlogon.log (Systemroot\debug).

Related Entries

LdapSrvPort

KdcSrvPort


LdapSrvPort

HKLM\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFF 0x0 - 0xFFFF | 0x185 (389)

Description

Specifies the TCP port number and the UDP port number on which the LDAP server listens.

Note Image Note

This entry is only used when it appears in the registry of a domain controller.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits it.

Tip Image Tip

Net Logon records the value of this entry on LDAP SRV records it writes. You can view these records by using DNS dynamic update, or by viewing the netlogon.dns file (Systemroot\System32\config). Also, if the value of DBFlag is 0x2080FFFF, Net Logon records the LDAP SRV records in its debugging log, Netlogon.log (Systemroot\debug).

Related Entries

LdapGcSrvPort

KdcSrvPort


LdapSrvPriority

HKLM\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFF 0x0 - 0xFFFF | 0x0

Description

Specifies the priority of this domain controller. The priority determines the order in which clients contact a domain controller. 0x0 represents the highest priority; 0xFFFF represents the lowest priority. The highest priority domain controller should be contacted first. Lower priority domain controllers are used only when those with higher priority are not available.

When domain controllers have the same priority value, their priority weight, as specified in the value of LdapSrvWeight is used to determines the order in which they are contacted.

Note Image Note

This entry is only used when it appears in the registry of a domain controller.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Tip Image Tip

Net Logon records the value of this entry on LDAP SRV records it writes. You can view these records by using DNS dynamic update, or by viewing the netlogon.dns file (Systemroot\System32\config). Also, if the value of DBFlag is 0x2080FFFF, Net Logon records the LDAP SRV records in its debugging log, Netlogon.log (Systemroot\debug).

Related Entries

LdapSrvWeight


LdapSrvWeight

HKLM\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFF 0x0 - 0xFFFF | 0x64 (100)

Description

Specifies the weight (or weighted priority) of this domain controller. The weight determines the probability that a client would contact the domain controller when selecting from among domain controllers with the same priority. Domain controllers with the highest weight are most likely to be contacted.

Clients contact domain controllers in priority order, as specified by the value of LdapSrvPriority. The highest priority domain controller (the one with the lowest value of LdapSrvPriority) is contacted first.

However, when domain controllers have the same priority value, Net Logon selects from among them by using a statistical calculation based on the weight assigned to the domain controller. Domain controllers with the highest weight are most likely to be contacted. This method allocates contact traffic most efficiently.

To calculate the probability that a given domain controller would be contacted by a client, use the following formula:

LdapSrvWeight / Sum (LdapSrvWeight for DCs of that priority)

For example, if three domain controllers were all assigned the highest priority, 0x0, the probability that each would be contacted would be as follows:

Server | Weight | Probability
A | 3 | 1/2 (3/6)
B | 2 | 1/3 (2/6)
C | 1 | 1/6

Note Image Note

When interpreting priority and weight values, remember that priorities are inverse, but weights are positive. That is, for priority, the lowest number (0x0) represents the highest priority. For weights, the highest number represents the highest weight.

When all domain controllers have the same weight, then, by convention, the value of LdapSrvWeight is 0.

This entry is only used when it appears in the registry of a domain controller.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Tip Image Tip

Net Logon records the value of this entry on LDAP SRV records it writes. You can view these records by using DNS dynamic update, or by viewing the netlogon.dns file (Systemroot\System32\config). Also, if the value of DBFlag is 0x2080FFFF, Net Logon records the LDAP SRV records in its debugging log, Netlogon.log (Systemroot\debug).

Related Entries

LdapSrvPriority


MailslotDuplicateTimeout

HKLM\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1- 5 seconds | 2

Description

Specifies the minimum amount of time that must separate mailslot messages received by the Net Logon service. If Net Logon receives two mailslot messages within an interval that is less than or equal to the value of this entry, the system considers the messages to be duplicates and ignores the second message.

Value | Meaning
0 | Net Logon does not ignore mailslot messages, regardless of the interval between messages.
1 - 5 seconds | The time that must elapse between mailslot messages for both to be processed.

A value of 0 is appropriate when Net Logon must recognize and respond to messages that might appear to be duplicates. For example, when a domain controller is separated from a client computer by a bridge/router, the bridge/router filters outgoing NBF broadcasts but allows incoming broadcasts. Net Logon must respond to the NBF mailslot message which is filtered out by the bridge/router and to the actual, unfiltered mailslot message the system receives.

If the value of this entry is too high, Net Logon might ignore retry attempts from a client.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

MaximumMailslotMessages

MaximumMailslotTimeout


MailslotMessageTimeout

HKLM\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters

Data type | Range | Default value
REG_DWORD | 0x5 - 0xFFFFFFFF seconds | 0xA (10 seconds)

Description

Specifies the maximum acceptable age of an incoming mailslot message. If Net Logon receives a mailslot message that older than this value, it ignores the message.

This limitation allows Net Logon to process messages recent messages efficiently. It assumes that the sender of the old message timed out is no longer waiting for a response.

If this value is set too low, Net Logon might ignore important incoming mailslot messages. However, because Net Logon typically processes each mailslot message in a fraction of a second, the default value is usually optimal.

Note Image Note

This entry is significant only if the server is used to capacity.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits it.

Related Entries

MaximumMailslotMessages

MailslotDuplicateTimeout


MaxConcurrentApi

HKLM\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 - 10 API calls | 0

Description

Specifies the maximum number of simultaneous, logon-related application programming interface (API) calls that can be transmitted across a secure channel at any one time.

API calls can be transmitted concurrently only on secure channels that are digitally signed or encrypted.

The default value is optimal for most installations, however, you can add this entry to the registry to increase its value. Increasing this value can improve efficiency. However, larger values can exhaust the resources of the domain controller communicating on the secure channel.

Value | Meaning
0 | One call at a time on member workstations and domain controllers; 2 concurrent calls on member servers.
1 - 10 | Number of concurrent calls. This limit applies to workstations, domain controllers, and servers.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits it.

Related Entries

signsecurechannel

sealsecurechannel


MaximumLogFileSize

HKLM\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF | 0x1312D00 (20,000,000 bytes)

Description

Specifies the maximum size of the Net Logon debugging file, Netlogon.log. When the file reaches this size, any existing Netlogon.bak file is deleted, the current Netlogon.log file is renamed to Netlogon.bak, and a new Netlogon.log file is created. Logging is not interrupted.

The Netlogon.log file is created when the value of DBFlag is greater than 0.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


MaximumMailslotMessages

HKLM\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters

Data type | Range | Default value
REG_DWORD | 0x1 - 0xFFFFFFFF messages | 0x1F4 (500 messages)

Description

Specifies the maximum number of mailslot messages queued to the Net Logon service.

The Net Logon service is designed to process incoming mailslot messages immediately, but messages can accumulate when the server is processing many requests. Each mailslot message consumes about 1500 bytes in the nonpaged memory pool until it is processed.

Reducing the value of this entry limits the amount of the nonpaged memory pool that Net Logon consumes. However, If this value is set too low, Net Logon might reject important incoming mailslot messages.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

MailslotMessageTimeout

MailslotDuplicateTimeout


MaximumPasswordAge

HKLM\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters

Data type | Range | Default value
REG_DWORD | 1 - 1000000 days | 30

Description

Determines how often the system changes the computer account password of the local computer. This entry is used only when the system is configured to change the computer password automatically at regular intervals, that is, when value of DisablePasswordChange is 0.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

DisablePasswordChange


Pulse

HKLM\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters

Data type | Range | Default value
REG_DWORD | 60 - 172,800 seconds (Up to 48 hours) | 300 (5 minutes)

Description

Determines how often a primary domain controller notifies backup domain controllers that changes have been made to the SAM and LSA databases. When the time specified by the value of this entry expires, the PDC sends notices only to the BDCs whose databases are not current.

The value of this entry does not affect database changes that trigger immediate updates. These include:

  • Changing an account lockout policy.
  • Changing a domain password policy.
  • Changing a computer account password.
  • Locking out an account.
  • Changing the password for a trust account.

Note Image Note

For Windows 2000, Net Logon manages replication only when it involves servers running Windows NT 4.0 or earlier. Net Logon for Windows 2000 does not manage replication between two servers running Windows 2000.

Related Entries

PulseConcurrency

PulseMaximum

PulseTimeout1

PulseTimeout2

Randomize


PulseConcurrency

HKLM\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters

Data type | Range | Default value
REG_DWORD | 1 - 500 pulses | 10

Description

Defines the maximum number of simultaneous pulses the primary domain controller (PDC) sends to backup domain controllers (BDCs).

This entry is designed to limit the workload that sending and processing responses to pulses place on the PDC. The PDC must be powerful enough to support this many concurrent replication RPC calls.

Increasing the value of PulseConcurrency increases the load on the PDC. Decreasing the value of PulseConcurrency increases the time it takes for a domain with a large number of BDCs to replicate a SAM/LSA change to all of the BDCs.

Note Image Note

For Windows 2000, Net Logon manages replication only when it involves servers running Windows NT 4.0 or earlier. Net Logon for Windows 2000 does not manage replication between two servers running Windows 2000.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

Pulse

PulseMaximum

PulseTimeout1

PulseTimeout2

Randomize


PulseMaximum

HKLM\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters

Data type | Range | Default value
REG_DWORD | 60 - 172,800 seconds (Up to 48 hours) | 7200 (2 hours)

Description

Defines the maximum time interval between pulses. If the time specified in this value expires, the primary domain controller sends at least one pulse, even if all backup domain controller databases are current.

Note Image Note

For Windows 2000, Net Logon manages replication only when it involves servers running Windows NT 4.0 or earlier. Net Logon for Windows 2000 does not manage replication between two servers running Windows 2000.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

Pulse

PulseConcurrency

PulseTimeout1

PulseTimeout2

Randomize


PulseTimeout1

HKLM\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters

Data type | Range | Default value
REG_DWORD | 1 - 120 seconds | 10

Description

Defines how long the primary domain controller (PDC) waits for a response from a backup domain controller (BDC) before it considers the BDC to be unresponsive. An unresponsive BDC is not counted against the limit specified by PulseConcurrency, allowing the PDC to send a pulse to another BDC in the domain.

If this value is too high, a domain with a large number of unresponsive BDCs takes a long time to complete a partial replication. If this number is too low, a slow BDC might mistakenly be treated as unresponsive. When the BDC finally does respond, it will partially replicate from the PDC, increasing the load on the PDC.

Note Image Note

For Windows 2000, Net Logon manages replication only when it involves servers running Windows NT 4.0 or earlier. Net Logon for Windows 2000 does not manage replication between two servers running Windows 2000.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits it.

Related Entries

Pulse

PulseConcurrency

PulseMaximum

PulseTimeout2

Randomize


PulseTimeout2

HKLM\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters

Data type | Range | Default value
REG_DWORD | 60 - 3600 seconds | 300 (5 minutes)

Description

Defines how long a primary domain controller (PDC) waits for a backup domain controller (BDC) to complete each step in the replication process. If the value of this entry is exceeded, the PDC regards the BDC as unresponsive and can send a pulse to another BDC in the domain.

PulseTimeout2 applies only to PDCs and is only used when a BDC cannot retrieve all the changes to the SAM/LSA database in a single RPC call.

To be considered responsive, the BDC must respond to a pulse and must continue reporting its progress on the replication. If the interval between progress reports exceeds the value of PulseTimeout2, the BDC is considered to be unresponsive. An unresponsive BDC is not counted against the limit specified by PulseConcurrency, allowing the PDC to send a pulse to another BDC in the domain.

If the value of this entry is set too high, a slow BDC, or one whose replication rate is too slow, consumes one of the PulseConcurrency slots. If the value of this entry is too low, the PDC's workload increases because of the large number of BDCs doing a partial replication.

Note Image Note

For Windows 2000, Net Logon manages replication only when it involves servers running Windows NT 4.0 or earlier. Net Logon for Windows 2000 does not manage replication between two servers running Windows 2000.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

Pulse

PulseConcurrency

PulseMaximum

PulseTimeout1

Randomize


Randomize

HKLM\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters

Data type | Range | Default value
REG_DWORD | 0 - 120 seconds | 1

Description

Specifies how long a backup domain controller (BDC) waits after receiving a pulse before it responds to the primary domain controller (PDC).

The value of Randomize must be smaller than the value of PulseTimeout1; otherwise the PDC will consider the BDC to be unresponsive.

When calculating an optimal value for Randomize, remember that the time required to replicate a SAM/LSA change to all the BDCs in a domain will be greater than:

[(Randomize/2) * NumberOfBDCsInDomain] / PulseConcurrency

If this entry does not appear in the registry, Net Logon determines optimal values for the server depending upon the domain controller's workload.

Note Image Note

For Windows 2000, Net Logon manages replication only when it involves servers running Windows NT 4.0 or earlier. Net Logon for Windows 2000 does not manage replication between two servers running Windows 2000.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

Pulse

PulseConcurrency

PulseMaximum

PulseTimeout1

PulseTimeout2


RefusePasswordChange

HKLM\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Prevents domain controllers from accepting requests from workstations to change their computer account passwords.

By default, Windows 2000 Professional systems automatically request a change to their computer account passwords at regular intervals (as specified in the value of MaximumPasswordAge). By setting the value of this entry to 1, you direct the system to reject the change each time it arrives.

Value | Meaning
0 | Accept changes to workstation computer account passwords.
1 | Reject changes to workstation computer account passwords.

Note Image Note

For Windows 2000, Net Logon manages replication only when it involves servers running Windows NT 4.0 or earlier. Net Logon for Windows 2000 does not manage replication between two servers running Windows 2000.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits it.

Tip Image Tip

To prevent a workstation from sending a password change to the domain controller, set the value of DisablePasswordChange to 1.

Caution Image Caution

Disabling automatic password changes can make the system more vulnerable to malicious access. Frequent password changes can be a significant safeguard for your system.

Related Entries

DisablePasswordChange

MaximumPasswordAge


RegisterDnsARecords

HKLM\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether this domain controller registers DNS A (IP address) records for the domain. If this domain controller is a global catalog resource, then this entry also determines whether the domain controller registers DNS A records for the global catalog.

Value | Meaning
0 | Does not register DNS A records. LDAP implementations that do not support SRV records will not be able to locate the LDAP server on this domain controller.
1 | Registers DNS A records.

Note Image Note

This entry is used only when it appears in the registry of a domain controller.

You might consider setting this value to 0 if DNS fails to complete its dynamic updates because it cannot update A records. DNS stops updating when an update attempt fails.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


requiresignorseal

HKLM\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether the system requires that all secure traffic channel communications be either signed or sealed.

The security specifications for secure channel traffic are determined jointly by the value of this entry and the values of RequireStrongKey, signsecurechanneland sealsecurechannel.

Value | Meaning
0 | This system does not require that channel traffic be signed or sealed. Instead, the security of channel traffic is negotiated with the domain controller. System preferences in the negotiation for traffic security are determined by the values of signsecurechanneland sealsecurechannel.
1 | True. Outgoing traffic on a secure channel must be either signed or sealed. If the domain controller on the other side of the channel does not support signing or sealing, the system refuses to establish a channel. If the value of sealsecurechannel is 1, traffic must be encrypted; otherwise, it must be signed.

Note Image Note

This entry should be set to 1 only when all of the trusted domains support signed and sealed communications.

Windows 2000 adds this entry to the registry when you install the system for the first time, or when you change the default value. If you upgrade from of Windows 2000, the entry does not appear in the registry, but it is still in effect on your system.

Related Entries

signsecurechannel

sealsecurechannel


RequireStrongKey

HKLM\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether the system requires that all secure channel keys be computed by using a strong key. If it does, the trusted domain controller on the other side of the channel must be able to compute strong keys. For public, non-exportable keys, a strong key is one that is 128 bytes or longer.

All secure channels have keys. The keys are used for authentication, signing, or encryption, depending on the capability and requirements of the systems.

Value | Meaning
0 | False. This system does not require that the trusted domain controller be able to compute a strong key.
1 | True. The system requires that the trusted domain controller be able to compute a strong key. If the domain controller on the other side of the channel does not support strong key encryption, this system refuses to establish a channel.

Note Image Note

This entry should be set to 1 only when all of the trusted domains are able to compute strong keys.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

SignSecureChannel

SealSecureChannel


ScavengeInterval

HKLM\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters

Data type | Range | Default value
REG_DWORD | 60 - 172,800 seconds (1 minute - 2 days) | 900 (15 minutes)

Description

Determines how often the Net Logon service performs the following operations.

  • Checks for password expirations on secure channels.
  • Checks for idle secure channels.
  • Sends a mailslot message to an external trust in which a domain controller has not been discovered. (Domain controllers only.)
  • Attempts to add the domain's NetBIOS name, until successful. (Primary domain controllers only.)

The default value is optimal for most systems. However, in rare cases, such as when a trusted domain is connected by an expensive connection, you might add this entry to increase the time between operations.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

In Windows NT 4.0 and earlier, the interval between subsequent registration of DNS names (DnsRefreshInterval) was based on ScavengeInterval. This is not the case with Windows 2000.


Scripts

HKLM\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters

Data type | Range | Default value
REG_EXPAND_SZ | Path | Systemroot\Domain-name\Scripts

Description

Overrides the default location of the Net Logon shared directory on the domain controller. If you change the value of this entry, the system moves the Net Logon shared directory to the location you specify. Net Logon stores logon scripts in this directory.

If the logon scripts directory is located in a path other than the default, Systemroot\Domain-name\Scripts, it is not replicated by the File Replication service.

Caution Image Caution

Do not add this entry to the registry or change its value. If you do, the logon scripts directory is not replicated. If you choose to move this directory, consider reconfiguring the File Replication service to include the new location.


sealsecurechannel

HKLM\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether outgoing secure channel traffic should be encrypted (sealed).

Channel traffic security is determined jointly by the value of this entry and the values of RequireStrongKey, requiresignorseal and signsecurechannel.

When requiresignorseal is set to 1, this entry determines whether encryption (sealing) is required for a secure channel. When requiresignorseal is set to 0, this entry specifies this system's preferences when negotiating with the domain controller on the other side of the channel. Also, because encryption is more secure than signing, when the value of this entry is 1, it takes precedence over the value of signsecurechannel.

Value | Meaning
0 | False. Outgoing traffic on a secure channel need not be encrypted. However, if the value of signsecurechannel is 1, outgoing traffic should be signed.
1 | True. Outgoing traffic on a secure channel should be encrypted. This specification is enforced when the value of requiresignorseal is 1.

Note Image Note

Windows 2000 adds this entry to the registry when you install the system for the first time, or when you change the default value. If you upgrade from Windows NT 4.0 or earlier, the entry does not appear in the registry, but it is still in effect on your system.

Related Entries

requiresignorseal

signsecureshannel


signsecurechannel

HKLM\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether outgoing secure channel traffic should be signed. This entry is used when negotiating the conditions of a secure channel with a domain controller.

Channel traffic security is determined jointly by the value of this entry and the values of RequireStrongKey, requiresignorseal and sealsecurechannel.

This entry is used only when the value of requiresignorsealis 0. Otherwise, the system requires that traffic at least be signed and does not consult this entry. Also, because encryption is more secure than signing, this entry is superceded when the value of sealsecurechannel is 1.

Value | Meaning
0 | False. Outgoing traffic on a secure channel need not be signed.
1 | True. Outgoing traffic on a secure channel should be signed.

Note Image Note

Windows 2000 adds this entry to the registry when you install the system for the first time, or when you change the default value. If you upgrade from Windows NT 4.0 or earlier, the entry does not appear in the registry, but it is still in effect on your system.

Related Entries

requiresignorseal

sealsecurechannel

RequireStrongKey


SiteCoverage

HKLM\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters

Data type | Range | Default value
REG_MULTI_SZ | Site names | (The list is empty.)

Description

A list of additional sites in which this domain controller registers itself. These sites are in addition to the site in which the domain controller resides and the sites listed in the value of AutoSiteCoverage.

You can add this entry to the registry to add sites to the list. This list lets you associate sites which might be logically connected, but physically disparate. The additional sites specified might be related by their corporate function, physical proximity, or network topology.

The domain controller considers itself to be closely related to the sites in this list. Therefore, it replicates to the site and, when queried, indicates that it is the closest site.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

This entry is used only when it appears in the registry of a domain controller.

Related Entries

SiteName

DynamicSiteName

SiteName

GcSiteCoverage


SiteName

HKLM\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters

Data type | Range | Default value
REG_SZ | String | There is no default value for this entry.

Description

Determines the site in which a member server or workstation is located. If you change the value of this entry, the value you enter overrides the dynamically determined site (stored in the value of DynamicSiteName), and places the system in the site you specify.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

This entry is used only when it appears in the registry of a member server or workstation.

Related Entries

DynamicSiteName


SiteNameTimeout

HKLM\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 | 0x1 - 0x418937 seconds | Ox12C (300 seconds = 5 minutes)

Description

Determines how often Net Logon automatically updates its record of the site in which the computer is located. Net Logon saves the name of the site in the value of DynamicSiteName and uses the saved site name for its operations. When the value of this entry expires, Net Logon requests the current site from the domain controller in the computer's primary domain and updates DynamicSiteName.

Value | Meaning
0x0 | The site name is updated each time it is returned to the caller.
0x1 - 0x418937 (49 days) | Specifies the time between updates.

The default value is optimal for most installations, but you can add this entry to the registry to change it. Increasing this value (updating less frequently) reduces network traffic, but can result in outdated site names, especially if the site changes frequently.

Note Image Note

When an administrator enters a site name, it is stored in the value of SiteName and is used instead of the value determined automatically and stored in DynamicSiteName. When SiteName is populated, the site name is not updated automatically and SiteNameTimeout is not used.

This entry is used only on client computers and member servers. Net Logon does not update the site name of domain controllers.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

DynamicSiteName

SiteName


SysVol

HKLM\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters

Data type | Range | Default value
REG_SZ | Path | Systemroot\SYSVOL\SYSVOL

Description

Specifies the path to Sysvol, the system volume shared directory on the domain controller. If you change the value of this entry, Net Logon moves the system volume to the location you specify.

The Sysvol share is created automatically when the a Windows 2000 domain controller is installed. A multi-master replicated copy of the system volume resides on each domain controller.

If the system volume directory is located in a path other than the default, it not automatically replicated by the File Replication service.

Caution Image Caution

Do not add this entry to the registry or change its value. If you do, the logon scripts directory is not replicated. If you choose to move this directory, consider reconfiguring the File Replication service to include the new location.


SysVolReady

HKLM\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Indicates the replication status of the system volume on a domain controller.

This entry is set by DcPromo, Backup, and File Replication service (FRS) to indicate the replication state of the SYSVOL share. During replication, the system volume is not shared and the domain controller does not respond to DSGetDcName calls, which seek a domain controller in the domain.

Value | Meaning
0 | The system volume is being replicated or receiving replication updates and is not shared.
1 | The system volume is not being replicated. The volume is shared.

You can use this entry to notify the system that replication of the SYSVOL is complete. If a problem with the FRS prevents it from resetting this value automatically after replication, you can change the value of this entry to 1 by editing the registry.

Note Image Note

This entry appears only in the registry of a domain controller.


TrustedDomainList

HKLM\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters

Data type | Range | Default value
REG_MULTI_SZ | yes | no | no

Description

Lists the domains that are trusted by this computer's domain.

Caution Image Caution

Do not change the value of this entry. This value is set by Net Logon for its internal use. Changing this value might interfere with this computer's membership in the domain and participation in its trusts.


Update

HKLM\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters

Data type | Range | Default value
REG_SZ | yes | no | no

Description

This entry appears in the registry, but it is not used by Windows 2000.


UseDynamicDns

HKLM\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether the Net Logon service on this domain controller uses DNS dynamic updates. Net Logon can use DNS dynamic updates to register DNS names identifying the domain controller.

DNS dynamic updates provide automatic updates of zone data, such as DNS names, on the zone's primary server whenever an authorized zone server requests an update. It supplements the static, manual method of adding and changing zone records. The DNS dynamic update protocol is defined in RFC 2136.

Value | Meaning
0 | Net Logon does not use DNS dynamic updates. Records specified in the Netlogon.dns file (Systemroot\System32\config\netlogon.dns) must be registered manually in DNS.
1 | Net Logon uses DNS dynamic updates to register the names identifying this domain controller.

You might consider disabling Net Logon's use of DNS dynamic updates if your DNS servers do not support DNS dynamic updates or to eliminate the network traffic associated with periodic registration of Net Logon's DNS records.

Note Image Note

This entry is supported on domain controllers only.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Tip Image Tip

This entry does not enable or disable support for DNS dynamic updates on this server. It only affects use of DNS dynamic updates by the Net Logon service. To enable DNS dynamic updates on a server, use the DNS snap-in. Right-click the name of a zone, click Properties, click the General tab, and in the Dynamic update box, select Allow Updates.


NTDS

HKLM\SYSTEM\CurrentControlSet\Services\

Description

The NTDS subkey stores configuration data for Active Directory.

In particular, Active Directory stores in the NTDS subkey domain controller information that it uses to restart Active Directory independently and to configure the Active Directory database. Active Directory also saves log file locations in this subkey.


Parameters

HKLM\System\CurrentControlSet\Services\NTDS\

Description

The NTDS\Parameters subkey stores configuration data for Active Directory.

In particular, Active Directory stores in the NTDS subkey domain controller information that it uses to restart Active Directory independently and to configure the Active Directory database. Active Directory also saves log file locations in this subkey.


Repl topology update delay (secs)

HKLM\SYSTEM\CurrentControlSet\Services\NTDS\Parameters

Data type | Range | Default value
REG_DWORD | 0x14 - 0xFFFFFFFF seconds | 0x12C (300 seconds or 5 minutes)

Description

Enables you to modify the time interval that the Knowledge Consistency Checker will wait before running its first replication topology check.

By default, the Knowledge Consistency Checker runs its first replication topology check five minutes after the domain controller starts.


Repl topology update period (secs)

HKLM\SYSTEM\CurrentControlSet\Services\NTDS\Parameters

Data type | Range | Default value
REG_DWORD | 0x14 - 0xFFFFFFFFseconds | 0x384 (900 seconds = 15 minutes)

Description

Allows the administrator to modify the interval at which the Knowledge Consistency Checker performs a review of the topology.

By default, as long as services are running, the Knowledge Consistency Checker reviews the topology every 15 minutes and makes changes as necessary. The administrator can modify the interval at which the Knowledge Consistency Checker performs this review by changing the value of the Repl topology update period entry.


Schema Update Allowed

HKLM\SYSTEM\CurrentControlSet\Services\NTDS\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Allows you to modify the schema.

The value of the The Schema may be modified on this server check box is stored in the registry in the Schema Update Allowed entry. Active Directory adds this entry to the registry when you use the Active Directory Schema snap-in to change the default value.

Change method

To change the value of this entry, use the Active Directory Schema snap-in. Do not edit the registry.


TCP/IP Port

HKLM\System\CurrentControlSet\Services\NTDS\Parameters

Data type | Range | Default value
REG_DWORD | 1 - 65535 port number | (There is no default value for this entry.)

Description

Allows you to specify a fixed port for routed environments or when port filtering is employed.

Active Directory registers the endpoint when it starts, and uses either a dynamically assigned port or a specified port, whichever is configured. To specify a fixed port for routed environments or when port filtering is employed, you can edit the TCP/IP Port entry to configure Active Directory to register a specific port with the endpoint mapper. The default value is determined by port availability.


NtFrs

HKLM\SYSTEM\CurrentControlSet\Services\

Description

The NtFrs subkey stores configuration data for the File Replication service (FRS). FRS automatically updates and synchronizes the contents of replicated files.

Related Entries

Dfs subkey

DFSHost subkey

DfsDriver subkey


Parameters

HKLM\SYSTEM\CurrentControlSet\Services\NtFrs\

Description

The NtFrs subkey stores configuration data for the File Replication service (FRS). FRS automatically updates and synchronizes the contents of folders managed by Distributed file system (Dfs).


Debug Disable

HKLM\SYSTEM\CurrentControlSet\Services\Ntfrs\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether FRS records its actions in trace log files.

If enabled, FRS creates log files are named Ntfrs_000x in the Systemroot\debug directory

Value | Meaning
0 | Enables the trace log.
1 | Disables the trace log.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

Debug Log File

Debug Log Files

Debug Log Severity

Debug Maximum Log Messages


Debug Log File

HKLM\SYSTEM\CurrentControlSet\Services\Ntfrs\Parameters

Data type | Range | Default value
REG_SZ | PathI | Systemroot\debug

Description

Determines where the File Replication service (FRS) stores its trace log files.

If you change the value of this entry, FRS creates new trace log files in the directory specified, but it does not move existing trace log files to the new location. Also, FRS does delete or maintain log files in the original location.

Activation method

To make changes to this entry effective, you must stop and restart FRS.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Tip Image Tip

If you have more than one hard drive, you can improve disk performance by storing the FRS trace log files on a different hard drive than the one that stores the FRS database and replica tree.

Related Entries

Debug Disable

Debug Log Files

Debug Log Severity

Debug Maximum Log Messages


Debug Log Files

HKLM\SYSTEM\CurrentControlSet\Services\Ntfrs\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF | 5

Description

Determines how many File Replication service (FRS) trace log files can be active simultaneously.

FRS creates a set of sequential log files named Ntfrs_000x.log. The files are numbered, beginning with 0001, so that the log with the highest number contains the most recently logged entries. The log files are retained until the number of files reaches the value of this entry. Then FRS deletes Ntfrs_0001 and renumbers all remaining logs accordingly.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

Debug Log File

Debug Disable

Debug Log Severity

Debug Maximum Log Messages


Debug Log Severity

HKLM\SYSTEM\CurrentControlSet\Services\Ntfrs\Parameters

Data type | Range | Default value
REG_DWORD | 0 - 5 | 4

Description

Determines the level of detail of that FRS records in its trace log files (Ntfrs_000n.log).

The File Replication service (FRS) assigns severity levels to each FRS event. The value of this entry determines which severity levels are written to the log. The higher the value of this entry, the more detailed the log becomes.

If the value of this entry is 0, only the most severe events are recorded in the log. If the value of this entry is 5, almost all events are recorded in the log.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

Debug Log File

Debug Disable

Debug Log Files

Debug Maximum Log Messages


Debug Maximum Log Messages

HKLM\SYSTEM\CurrentControlSet\Services\Ntfrs\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF | 0x4E20 (20,000)

Description

Determines how many entries can be stored in each FRS trace log file (Ntfrs_000x.log).

When the number of event entries reaches the value of Debug Maximum Log Messages, the system closes the log file and starts a new log file. The log files are numbered sequentially, so that when the FRS closes Ntfrs_0001.log, it begins Ntfrs_0002.log.

The default value of 10,000 entries (0x2710) uses approximately 1 MB of disk space.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

Debug Log File

Debug Disable

Debug Log File

Debug Log Severity


Staging Space Limit in KB

HKLM\SYSTEM\CurrentControlSet\Services\Ntfrs\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF KB | 0xA1220 (660000 KB = 660 MB)

Description

Determines the maximum amount of disk space FRS can use to store staging files.

FRS uses staging files to encapsulate the data streams and attributes associated with each replicated file (or directory) object. The staging file is transferred among replica members where they use it to recreate the replicated object.

When the space consumed by staging files reaches the value of this entry, inbound replication is suspended. FRS tries to release space by replicating staging files to all outbound partners.

Typically, staging files reach this limit because FRS cannot offload files to an outbound partner that connects infrequently.

Activation method

You can add this entry or change its value while FRS is running. You do not need to restart FRS to make the change effective.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


NWCWorkstation

HKLM\SYSTEM\CurrentControlSet\Services\

Description

The NWCWorkstation subkey stores configuration data for Client Service for NetWare. This service enables your Windows 2000 Professional workstation to gain access to file and print services on Novell NetWare servers even if you are not running NetWare client software.

Note Image Note

This subkey appears in the registry when you install Client Service for NetWare.


Parameters

HKLM\SYSTEM\CurrentControlSet\Services\NWCWorkstation\

Description

The Parameters subkey stores configuration data for specific to Client Service for NetWare. This service enables your Windows 2000 Professional workstation to gain access to file and print services on Novell NetWare servers even if you are not running NetWare client software.

Note Image Note

This subkey appears in the registry when you install Client Service for NetWare.


CurrentUser

HKLM\SYSTEM\CurrentControlSet\Services\NWCWorkstation\Parameters

Data type | Range | Default value
REG_SZ | Security identifier (SID) | There is no default value for this entry.

Description

Stores the security identifier (SID) of the user currently logged on to the local computer.

Client Service for NetWare stores user-specific configuration data in subkeys named for the SID of the user. These subkeys appear in the Logon subkey and the Option subkeys of the NWCWorkstation services subkey.

Note Image Note

This subkey appears in the registry when you install Client Service for NetWare.


DefaultLocation

HKLM\SYSTEM\CurrentControlSet\Services\NWCWorkstation\Parameters

Data type | Range | Default value
REG_SZ | Server-name or Tree\Context | (There is no default value for this entry.)

Description

Specifies the Netware 3.x server or NDS tree/context for all new users. This entry applies to users the first time they log on.

Once they have logged on, administrators can use GSNW in Control Panel to change their preferred server or tree and context.

The DefaultLocation and DefaultScriptOptions entries let you set default values for the preferred server and logon script client options. When both of these entries appear in the registry with valid values, the system supresses the Select NetWare Logon dialog box that requests this information from the user. Otherwise, the dialog box appears each time a user logs on until they select a preferred server.

Note Image Note

This entry is used only when the DefaultScriptOptions entry appears in the registry with a valid value. Otherwise, the entry is ignored and the system requires a user to select a server from the Select NetWare Logon dialog box.


DefaultScriptOptions

HKLM\SYSTEM\CurrentControlSet\Services\NWCWorkstation\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0x3 | 0x800 | 0x3

Description

Determines whether logon scripts are enabled or disabled by default. This entry applies to users the first time they log on.

Once they have logged on, administrators can use GSNW in Control Panel to enable or disable logon scripts.

Value | Meaning
0x0 | Logon scripts are disabled.
0x1 | Logon scripts are enabled only on bindery servers.
0x2 | Logon scripts are enabled only on Novell Directory Services (NDS) directories.
0x3 | Logon scripts are enabled on both bindery servers and NDS directories.
0x800 | Logon scripts enabled and are in debugging mode.

This entry is a bitmask. Bit 1 enables logon scripts on bindery servers. Bit 2 (10 binary) enables logon scripts on NDS servers. To enable logon scripts on a type of server, set the bit for that server type to 1. To turn debugging mode on, set bit 12 (10000000000, or 0x800).

The DefaultLocation and DefaultScriptOptions entries let you set default values for the preferred server and logon script client options. When both of these entries appear in the registry with valid values, the system supresses the Select NetWare Logon dialog box that requests this information from the user. Otherwise, the dialog box appears each time a user logs on until they select a preferred server.

Note Image Note

This entry is used only when the DefaultScriptOptions entry appears in the registry with a valid value. Otherwise, the entry is ignored and the system requires a user to specify their logon script options on the Select NetWare Logon dialog box.


Logon

HKLM\SYSTEM\CurrentControlSet\Services\NWCWorkstation\Parameters\

Description

Stores data about the current user for use by the Client Service for NetWare. This data is used internally by the Client Service for NetWare.

The Logon subkey contains subkeys that represent users that have logged on to the system. These subkeys are named for the security identifier (SID) of the user. The data in each SID subkey apply only to the user represented by the SID.

Note Image Note

This subkey appears in the registry when you install Client Service for NetWare.

Caution Image Caution

Do not change the content of the Logon subkey. If you do, Client Service for NetWare might not operate properly and users might not be able to gain access to resources on NetWare servers.

Related Entries

<SID> subkey


<SID>

HKLM\SYSTEM\CurrentControlSet\Services\NWCWorkstation\Parameters\Logon\

Description

The <SID> subkeys represent particular users.

The <SID> subkey sare named for the security identifier (SID) of the user. These subkeys store data about the current user for use by the Client Service for NetWare. This data is used internally by the Client Service for NetWare. The data in each SID subkey apply onto to the user represented by the SID.

Note Image Note

The <SID> subkey is a variable representing the SID-named subkeys under the HKLM\SYSTEM\CurrentControlSet\Services\NWCWorkstation\Parameters\Logon subkey. It doesn't actually appear in the registry. This variable subkey displays the entries and subkeys that are common to many of the subkeys in Logon. The actual SID subkeys in your registry are specific to your system and its users.

This subkey appears in the registry when you install Client Service for NetWare.

Tip Image Tip

To determine which SID subkey in your registry stores options for the current user, find the value of CurrentUser in the NWCWorkstation\Parameters subkey.

Caution Image Caution

Do not change the content of the Logon subkey. If you do, Client Service for NetWare might not operate properly and users might not be able to gain access to resources on NetWare servers.


Option

HKLM\SYSTEM\CurrentControlSet\Services\NWCWorkstation\Parameters\

Description

Stores the value of optional settings for the current user for use by the Client Service for NetWare. This data is used internally by the Client Service for NetWare.

The Option subkey contains subkeys that represent users that have logged on to the system. These subkeys are named for the security identifier (SID) of the user. The data in each SID subkey apply only to the user represented by the SID.

Tip Image Tip

To determine which SID subkey in your registry stores options for the current user, find the value of CurrentUser in the NWCWorkstation\Parameters subkey.


<SID>

HKLM\SYSTEM\CurrentControlSet\Services\NWCWorkstation\Parameters\Option\

Description

The <SID> subkeys represent particular users.

The <SID> subkeys are named for the security identifier (SID) of the user. These subkeys store data about the current user for use by the Client Service for NetWare. This data is used internally by the Client Service for NetWare. The data in each SID subkey apply onto to the user represented by the SID.

Note Image Note

This subkey appears in the registry when you install Client Service for NetWare.

The <SID> subkey is a variable representing the SID-named subkeys under the HKLM\SYSTEM\CurrentControlSet\Services\NWCWorkstation\Parameters\Option subkey. It doesn't actually appear in the registry. This variable subkey displays the entries and subkeys that are common to many of the subkeys in Option. The actual SID subkeys in your registry are specific to your system and its users.

Tip Image Tip

To determine which SID subkey in your registry stores options for the current user, find the value of CurrentUser in the NWCWorkstation\Parameters subkey.


LogonScript

HKLM\SYSTEM\CurrentControlSet\Services\NWCWorkstation\Parameters\Option\<SID>

Data type | Range | Default value
REG_DWORD | 1 - 3 | (See below.)

Description

Determines whether a logon script is to be run when the user represented by the SID directly connects to a NetWare server. The logon script does not run if the user connects through a gateway.

This entry stores the value of the Run Login Script check box in GSNW in Control Panel and the Run Login Script check box on the Select NetWare Logon dialog box. The Select NetWare Logon dialog box appears the first time a user logs on after installing Client Service for NetWare.

Value | Meaning
0 | Do not run the Client Service for NetWare logon script.
1 | Run the Client Service for NetWare logon script.

Change method

To change the value of this entry, select or clear the Run Login Script check box in GSNW in Control Panel.

Note Image Note

This subkey appears in the registry when you install Client Service for NetWare.

The default logon script, Nwscript.exe, is located in Systemroot\System32, but you can run without a logon script or create your own logon script.


NDSPreferredServer

HKLM\SYSTEM\CurrentControlSet\Services\NWCWorkstation\Parameters\Option\<SID>

Data type | Range | Default value
REG_SZ | Server-name | (Blank)

Description

Specifies the Novell Directory Services (NDS) server that the system tries first when logging the user on to an NDS tree.

If this entry does is not in the registry or the specified server is not available, the system logs the user on the first server in the user's tree and context that responds to the logon request. (The tree and context are stored in the value of PreferredServer).

Specifying a particular server assures that when you log on through a Novell Directory Services (NDS) tree containing more than one NetWare server, that you are authenticated by the same NetWare server that you map to use NetWare resources. As a result, you use only one licensed connection.

Note Image Note

This entry is used only when the client is connected to a network that uses Novell Directory Services.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Tip Image Tip

For more information about this entry, see Article Q219345 in the Microsoft Knowledge Base at http://www.microsoft.com/support/kb.htm

Related Entries

PreferredServer


PreferredServer

HKLM\SYSTEM\CurrentControlSet\Services\NWCWorkstation\Parameters\Option\<SID>

Data type | Range | Default value
REG_SZ | *Tree\Context or Server-name | (Blank)

Description

Specifies the NetWare server or NDS tree and context to which this user logs on. If the specified server is not available, the system notifies the user and lets them select from among a list of other available servers. If the value of this entry is blank, the system does not log the user on to a NetWare server.

An asterisk (*) preceding the string indicates that the value is a Novell Directory Service (NDS) tree and context. Otherwise, the value indicates a NetWare 3.x server.

This entry stores the value of the Select Preferred Server, Tree, and Context text boxes in GSNW in Control Panel and on the Select NetWare Logon dialog box. The Select NetWare Logon dialog box appears the first time a user logs on after installing Client Service for NetWare.

Client Services for NetWare adds this entry to the registry with the value that the user enters in the dialog box options. If the user leaves the dialog box options blank, the value of this entry is blank. When this entry is not in the registry, Client Service for NetWare assumes that the user has logged on before.

Users can change the value of this entry by using GSNW or CSNW in Control Panel. If this value is blank when the user logs on again, the system displays a dialog box offering users a list of available servers. If the user selects a server, the name of that server is written to the value of this entry. If they do not, they are not logged on to a NetWare server.

Change method

To change the value of this entry on Windows 2000 Server, use GSNW in Control Panel. On Windows 2000 Professional, use CSNW in Control Panel. Do not edit the registry.

Note Image Note

When this entry stores an NDS tree and context, by default, the system logs the user on to the first server in that tree and context that responds to a logon request. To indicate a preferred server within the specified NDS tree/context, use the NDSPreferredServer entry.

Related Entries

NDSPreferredServer


PrintOption

HKLM\SYSTEM\CurrentControlSet\Services\NWCWorkstation\Parameters\Option\<SID>

Data type Range Default value
REG_DWORD

Description

A bitmask representing user-specific options for printing to NetWare resources. Each bit in the mask represents one option. To enable the option, set the bit to 1; to disable it, set the bit to 0.

Change method

To change the value of this entry, use GSNW in Control Panel.

Note Image Note

This subkey appears in the registry when you install Client Service for NetWare.

Related Entries

NetWare or Compatible Network print subkey


PerfDisk

HKLM\SYSTEM\CurrentControlSet\Services\

Description

The PerfDisk subkey stores configuration data for Perfdisk.dll, the Windows 2000 disk performance driver. Perfdisk collects performance-related data about logical and physical disk drives for display by System Monitor and other display tools.


Performance

HKLM\SYSTEM\CurrentControlSet\Services\PerfDisk\

Description

The PerfDisk\Performance subkey stores configuration data for Perfdisk.dll, the Windows 2000 disk performance driver. Perfdisk collects performance-related data about logical and physical disk drives for display by System Monitor and other display tools.

Activation method

To make changes to entries in this subkey effective, restart the Remote Registry Service or restart Windows 2000.

Tip Image Tip

If particular performance counters do not appear in your monitoring-monitoring tool, check the Application Log in Event Viewer for events recorded by Perflib. When Perflib detects disabling errors in a counter DLL, it records an event in the log and sets the value of DisablePerformanceCounters to 1 to disable the counters.


NT4 Instance Names

HKLM\SYSTEM\CurrentControlSet\Services\PerfDisk\Performance

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether instances of the PhysicalDisk performance object displayed in performance tools, such as System Monitor, include the names of logical drives residing on the physical drive.

Value | Meaning
0 | PhysicalDisk instance names display the drive number and logical drive letters. (New for Windows 2000)
1 | PhysicalDisk instance names display drive number only. (Same as Windows NT 4.0 and earlier)

For example, if a physical drive (Disk 0) includes three logical disks, C, D, and E then, if the value of this entry is 1, the physical disk instance is represented as 0: C, D, E. If the value of this entry is 0, the same instance is represented as 0.

Activation method

To make changes to this entry effective, restart the Remote Registry Service or restart Windows 2000.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Tip Image Tip

To test this entry on your computer, in System Monitor, click the + button and, in the Performance object box, click PhysicalDisk. Observe the names of instances in the Select instances from list box. Then, add this entry to your registry, set its value to 1, and observe the PhysicalDisk instance names again.


Psched

HKLM\SYSTEM\CurrentControlSet\Services\

Description

The Psched subkey stores configuration data for the Quality of Service (QoS) Packet Scheduler. The Packet Scheduler determines the delivery schedule of each queue of packets and resolves competition between queued packets .


Parameters

HKLM\SYSTEM\CurrentControlSet\Services\Psched\

Description

The Psched\Parameters subkey stores configuration data for the Quality of Service (QoS) Packet Scheduler. The Packet Scheduler controls network traffic. It determines the delivery schedule of each queue of packets and resolves competition between queued packets .

The Parameters subkey stores entries that applies to all network adapters on the computer. In addition to entries, the Parameters subkey also contains an Adapters subkey which stores entries that are configured separately for each network adapters that supports QoS Admission Control.

Related Entries

Adapters subkey


Adapters

HKLM\SYSTEM\CurrentControlSet\Services\Psched\Parameters\

Description

The Adapters subkey stores data that is configured separately for each network adapters that supports the Quality of Service (QoS).

The Adapters subkey contains one subkey for each QoS network adapter on the computer. The subkey is named by the GUID of the network adapter and stores entries that apply only to that network adapter.


<Adapter-GUID>

HKLM\SYSTEM\CurrentControlSet\Services\Psched\Parameters\Adapters\

Description

The <Adapter-GUID> subkey represents a particular network adapter that supports the Quality of Service (QoS) and stores entries that apply only to the named adapter.

The <Adapter-GUID> subkey is a variable representing the subkeys in the Psched\Parameters\Adapters subkey. It doesn't actually appear in the registry. We use this variable subkey to display the entries that are common to the subkeys in the Adapters subkey.

The <Adapter-GUID> subkeys in your registry represent network adapters or network adapter drivers and are named by for GUID for the adapter. Each subkey represents a particular adapter and stores configuration data that applies only to that adapter.


DiffServByteMappingConforming

HKLM\SYSTEM\CurrentControlSet\Services\Psched\Parameters\Adapters\<Adapter-GUID>\

Description

The DiffServByteMappingConforming subkey stores entries that specify an alternate Differentiated Services Code Point (DSCP) value for service types specified in the per-flow flowspec. The Packet Scheduler inserts the corresponding DSCP value in the IP header of the packets. These entries only to packets that conform to the flow specification.

This subkey can also contain an entry, ServiceTypeTcpTraffic, that assigns a default DSCP value to packets carrying TCP traffic. Despite its name, this entry does not pertain to packets of any particular service type. This entry applies only to TCP packets that have not otherwise been classified to a flow.

The DiffServByteMappingConforming subkey does not appear by default, but you can add it to the registry to override the default DSCP value for unclassified TCP traffic or for packets of any recognized service type.

All entries in this subkey must have the following format:

Entry name | Data type | Value
<Service-type> | REG_DWORD | 0x0 - 0x3F

For example, to change the DSCP value associated with the Guaranteed service type, add the DiffServByteMappingConforming subkey, then add the following entry to the DiffServByteMappingConforming subkey.

Entry name | Data type | Value
ServiceTypeGuaranteed | REG_DWORD | 0x20

The following table shows the DSCP value used when no entries appear in this subkey.

Service type | Default DSCP value
ServiceTypeBestEffort | 0x00
ServiceTypeControlledLoad | 0x18
ServiceTypeGuaranteed | 0x28
ServiceTypeNetworkControl | 0x30
ServiceTypeQualitative | 0x00
ServiceTypeTcpTraffic | 0x00

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

The entries in this subkey take precedence over Group Policies that apply to packets carried by all network adapters on this computer. For more information, see DiffServByteMappingConforming (Policies subkey).

Related Entries

DiffServByteNonMappingConforming (<Adapter-GUID> subkey)

DiffServByteMappingConforming (Policies subkey)

DiffServByteMappingNonConforming (Policies subkey)


DiffServByteMappingNonConforming

HKLM\SYSTEM\CurrentControlSet\Services\Psched\Parameters\Adapters\<Adapter-GUID>\

Description

The DiffServByteMappingNonConforming subkey stores entries that specify an alternate Differentiated Services Code Point (DSCP) value for service types specified in the per-flow flowspec. The Packet Scheduler inserts the DSCP value in the IP header of the packets. These entries apply only to packets that do not conform to the flow specification.

This subkey does not appear by default, but you can add it to the registry to override the default priority value for packets of any recognized service type. By default, a DCSP value of 0x00 is used for all non-conforming packets.

All entries in this subkey must have the following format:

Entry name | Data type | Value
<Service-type> | REG_DWORD | 0x0 - 0x3F

For example, to change the DSCP value associated with the Guaranteed service type, add the DiffServByteMappingNonConforming subkey, then add the following entry to the DiffServByteMappingNonConforming subkey.

Entry name | Data type | Value
ServiceTypeGuaranteed | REG_DWORD | 0x20

The valid service types are as follows

  • ServiceTypeBestEffort
  • ServiceTypeControlledLoad
  • ServiceTypeGuaranteed
  • ServiceTypeNetworkControl
  • ServiceTypeQualitative

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

The entries in this subkey take precedence over Group Policies that apply to packets carried by all network adapters on this computer. For more information, see DiffServByteMappingNonConforming (Policies subkey).

Related Entries

DiffServByteMappingConforming (<Adapter-GUID> subkey)

DiffServByteMappingNonConforming (Policies subkey)

DiffServByteMappingConforming (Policies subkey)


MaxOutstandingSends

HKLM\SYSTEM\CurrentControlSet\Services\Psched\Parameters\Adapters\<Adapter-GUID>

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF | 0xFFFF

Description

Determines the maximum number of outstanding packets permitted on the interface. When the number of outstanding packets reaches this limit, the Packet Scheduler postpones all submissions to this network adapter until the number falls below this limit.

Outstanding packets are packets that the Packet Scheduler has submitted to the network adapter for transmission, but which the network adapter has not yet sent.

If the value of this entry is too low, packets can accumulate in the Packet Scheduler when network traffic is heavy. The packet scheduler services packet flows in order of priority or weight.

If the value of this entry is too high, packets can accumulate in the network adapter, rather than the Packet Scheduler. In this case, the queue servicing routines implemented by the Packet Scheduler sequencer have no effect on the order in which packets from different flows are transmitted. However, the system benefits from the optimized performance of pipelining on the adapter.

Note Image Note

This entry takes precedence over a Group Policy that applies to packets carried by all network adapters on this computer. For more information, see MaxOutstandingSends (Policies subkey).

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


NonBestEffortLimit

HKLM\SYSTEM\CurrentControlSet\Services\Psched\Parameters\Adapters\<Adapter-GUID>

Data type | Range | Default value
REG_DWORD | 0 - 100 percentage of connection bandwidth | 20

Description

Determines the percentage of connection bandwidth that the system can reserve on the network adapter. This value limits the combined bandwidth reservations all programs running on the system.

Note Image Note

This entry takes precedence over a Group Policy that applies to packets carried by all network adapters on this computer. For more information, see NonBestEffortLimit (Policies subkey).

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

NonBestEffortLimit (<Adapter-GUID> subkey)


UserPriorityMapping

HKLM\SYSTEM\CurrentControlSet\Services\Psched\Parameters\Adapters\<Adapter-GUID>\

Description

The UserPriorityMapping subkey stores entries that specify an alternate link layer (Layer-2) priority value for service types specified in the per-flow flowspec. The Packet Scheduler inserts the link layer priority value in the Layer-2 priority header of packets. These entries apply only to packets that conform to the flow specification.

This subkey can also contain an entry, ServiceTypeTcpTraffic, that assigns a default Layer-2 priority value to packets carrying TCP traffic. Despite its name, this entry does not pertain to packets of any particular service type. This entry applies only to TCP packets that have not otherwise been classified to a flow.

This subkey does not appear by default, but you can add it to the registry to override the default priority value for unclassified TCP traffic or packets of any recognized service type.

All entries in this subkey must have the following format:

Entry name | Data type | Value
<Service-type> | REG_DWORD | 0 - 7

For example, to change the priority value associated with the Guaranteed service type, add the UserPriorityMapping subkey, then add the following entry to the UserPriorityMapping subkey.

Entry name | Data type | Value
ServiceTypeGuaranteed | REG_DWORD | 6

The following table shows the priority values assigned when no entries appear in this subkey. ServiceTypeNonConforming applies to all packets that do not conform to the flow specification. ServiceTypeTcpTraffic applies to packets carrying unclassified TCP traffic.

Value | Meaning
ServiceTypeNonConforming | 1
ServiceTypeBestEffort | 0
ServiceTypeControlledLoad | 4
ServiceTypeGuaranteed | 5
ServiceTypeNetworkControl | 7
ServiceTypeQualitative | 0
ServiceTypeTcpTraffic | 0

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

The entries in this subkey take precedence over a policy included in Windows 2000. For more information, see UserPriorityMapping (Policies subkey).

Related Entries

UserPriorityMapping (Policies subkey)


TimerResolution

HKLM\SYSTEM\CurrentControlSet\Services\Psched\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF microseconds | (System default, typically 10 microseconds)

Description

Determines the smallest unit of time that the Packet Scheduler uses when scheduling packets for transmission. The Packet Scheduler cannot schedule packets for transmission more frequently than permitted by the value of this entry.

If you enter a value that is too small for the Hardware Abstraction Layer on your system to support, the system uses the smallest supported interval.

Note Image Note

This entry can be superceded by a policy included in Windows 2000. While the Set timer resolution Group Policy is enabled, the system ignores this entry. The setting of the Set timer resolution policy is stored in the value of TimerResolution (Policies subkey).

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

TimerResolution (Policies subkey)


Qossp

HKLM\SYSTEM\CurrentControlSet\Services\

Description

The Qossp subkey stores configuration data for the Quality of Service (QoS) service provider.

QoSsp is the Winsock QoS service provider for Windows 2000. QoSsp is a layered service provider: it is positioned above the default Winsock service provider and intercepts all QoS-related requests. These QoS requests are then translated into the appropriate RSVP signaling to request resources from the network.


EnablePriorityBoost

HKLM\SYSTEM\CurrentControlSet\Services\Qossp

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether QoS priority boosting is enabled on this interface. QoS boosts traffic priority only when RSVP signaling is disabled.

Priority boosting increases the link-level priority of GQoS application traffic to the priority of the service level the program requests. Traffic priority determines the order in which packets are submitted to the network when it is congested.

You can use this entry to priority of traffic without signaling.

Value | Meaning
0 | The link-level traffic priority of GQoS application traffic is not elevated, regardless of its service type. The traffic maintains the same priority level as other best-effort traffic.
1 | The link-level traffic priority of GQoS application traffic is elevated to the priority of the service level the program requests.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

To determine this setting a particular QoS interface, add the EnablePriorityBoost entry to an interface-specific <Interface-name>\Qos subkey in Tcpip\Parameters. If this entry appears in both the Qossp subkey and an <Interface-name>\Qos subkey, the value in the <Interface-name>\Qos subkey takes precedence over the value in the Qossp subkey when configuring that interface.

Caution Image Caution

Consider the effect of priority boosting carefully before enabling it. Priority boosting is not subject to policy or admission control.

Related Entries

EnablePriorityBoost (<Inteface-name>\Qos)


EnableRSVP

HKLM\SYSTEM\CurrentControlSet\Services\Qossp

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether Resource ReSerVation Protocol (RSVP) is enabled.

RSVP is a signaling protocol that creates a reserved communications channel and guarantees a specific level of quality for traffic on that channel.

Value | Meaning
0 | Disabled. RSVP signaling is not available to QoS connections terminating on the interface.
1 | Enabled. RSVP signaling is used for all QoS connections terminating on the interface.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

This entry can appear in the Qossp subkey or in an interface-specific <Interface-name>\Qos subkey in Tcpip\Parameters. The value in the Qossp subkey affects all interfaces, but the value in the <Interface-name>\Qos subkey only affects the named interface. If this entry appears in both subkeys, the value in the <Interface-name>\Qos subkey takes precedence over the value in the Qossp subkey when configuring that interface.

Related Entries

EnableRSVP (<Inteface-name>\Qos)


LowDelayBound

HKLM\SYSTEM\CurrentControlSet\Services\Qossp

Data type | Range | Default value
REG_DWORD | 0x1 - 0xFFFFFFFF microseconds | 0x2710 (10,000 microseconds = 10 milliseconds)

Description

Specifies the value that QoS inserts in the Latency field of a flowspec (the service parameters for a combined sequence of packets) when the traffic is highly sensitive to delays. The Latency field defines the maximum acceptable delay between transmission of a bit by the sender and its receipt by one or more intended receivers.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

To determine this setting for all QoS interfaces, add the LowDelayBound entry to the Qossp services subkey. If this entry appears in both the Qossp subkey and an <Interface-name> subkey, the value in the <Interface-name> subkey takes precedence over the value in the Qossp subkey when configuring that interface.

Related Entries

LowDelayBound (<Inteface-name>\Qos)

MediumDelayBound (Qossp)

MediumDelayBound (<Inteface-name>\Qos)


MapGeneralInfo

HKLM\SYSTEM\CurrentControlSet\Services\Qossp

Data type | Range | Default value
REG_DWORD | 0 - 7 | 3

Description

Determines whether the general information service type (SERVICETYPE_GENERALINFO) is mapped to the controlled load or guaranteed service level. The system uses this mapping when an interface does not support RSVP signaling or when RSVP signaling is disabled on an interface.

QoS senders usually specify SERVICETYPE_GENERALINFO to indicate that they can support both controlled load and guaranteed service capability to the receiver.

Controlled load approximates the behavior of best-effort service in unloaded (not heavily loaded or congested) conditions. Guaranteed service guarantees the maximum limit on delay.

Value | Meaning
0 - 3 | Map SERVICETYPE_GENERALINFO traffic to the controlled load service level.
4 - 7 | Map SERVICETYPE_GENERALINFO traffic to the guaranteed service level.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

To determine this setting a particular QoS interface, add the MapGeneralInfo entry to an interface-specific <Interface-name>\Qos subkey in Tcpip\Parameters. If this entry appears in both the Qossp subkey and an <Interface-name>\Qos subkey, the value in the <Interface-name>\Qos subkey takes precedence over the value in the Qossp subkey when configuring that interface.

Tip Image Tip

For more information about service levels, see Quality of Service in the Windows 2000 Server Resource Kit.

Related Entries

MapGeneralInfo (<Inteface-name>\Qos)


MediumDelayBound

HKLM\SYSTEM\CurrentControlSet\Services\Qossp

Data type | Range | Default value
REG_DWORD | 0x1 - 0xFFFFFFFF microseconds | 0x186A0 (100,000 microseconds = 100 milliseconds)

Description

Specifies the value that QoS inserts in the Latency field of a flowspec (the service parameters for a combined sequence of packets) when the traffic on this interface is moderately sensitive to delays. The Latency field defines the maximum acceptable delay between transmission of a bit by the sender and its receipt by one or more intended receivers.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

To determine this setting a particular QoS interface, add the MediumDelayBound entry to an interface-specific <Interface-name>\Qos subkey in Tcpip\Parameters. If this entry appears in both the Qossp subkey and an <Interface-name>\Qos subkey, the value in the <Interface-name>\Qos subkey takes precedence over the value in the Qossp subkey when configuring that interface.

Related Entries

MediumDelayBound (<Inteface-name>\Qos)

LowDelayBound (Qossp)

LowDelayBound (<Inteface-name>\Qos)


Rasl2tp

HKLM\SYSTEM\CurrentControlSet\Services\

Description

The Rasl2tp subkey stores configuration data for the Layer 2 Tunneling Protocol (L2TP) support in Routing and Remote Access.

L2TP is an industry standard tunneling protocol. Unlike Point-to-point tunneling protocol (PPTP), which is based on TCP, L2TP is based on UDP.

Related Entries

WAN Miniport (L2TP) <Device-number (000n)> subkey

ProhibitIpSec


RasMan

HKLM\SYSTEM\CurrentControlSet\Services\

Description

The RasMan subkey stores configuration data for Routing and Remote Access. The subkeys in the RasMan subkey depend upon the services installed.


Parameters

HKLM\SYSTEM\CurrentControlSet\Services\RasMan\

Description

The RasMan\Parameters subkey stores configuration data for Routing and Remote Access.


DisableSavePassword

HKLM\SYSTEM\CurrentControlSet\Services\RasMan\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether the passwords associated with Network Connections phone book entries are saved. If you have many phone book entries, accumulated saved passwords can cause a slight delay after you type your credentials in the Connecting To dialog box.


IpOutHighWatermark

HKLM\SYSTEM\CurrentControlSet\Services\RasMan\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF | 0x5

Description

Specifies the maximum number of unused IP dial-out adapters that Routing and Remote Access can maintain. If the number of unused IP dial-out adapters exceeds the value specified in this entry, Routing and Remote Access deletes the excess adapters.

Routing and Remote Access creates IP dial-out adapters dynamically as needed, and deletes them when they are no longer needed. Routing and Remote Access creates reserve adapters in advance to prevent call delays. However, because adapters consume system resources, you should have only as many reserve adapters as you will use.

If the value of this entry is too high, resources are wasted on maintaining excess adapters. If the value of this entry is too low, users will experience perceptible delays while adapters are being created.

Related Entries

IpOutLowWatermark


IpOutLowWatermark

HKLM\SYSTEM\CurrentControlSet\Services\RasMan\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF | 0x1

Description

Specifies the minimum number of unused IP dial-out adapters that Routing and Remote Access can maintain. If the number of unused IP dial-out adapters falls below the value specified in this entry, RRAS creates more adapters.

RRAS creates IP dial-out adapters dynamically as needed, and deletes them when they are no longer needed. RRAS creates reserve adapters in advance to prevent call delays. However, because adapters consume system resources, you should have only as many reserve adapters as you will use.

If the value of this entry is too high, resources are wasted on maintaining excess adapters. If the value of this entry is too low, users will experience perceptible delays while adapters are being created.

Related Entries

IpOutHighWatermark


Logging

HKLM\SYSTEM\CurrentControlSet\Services\RasMan\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

This entry still appears in the registry, but it is ignored by Windows 2000.


ProhibitIpSec

HKLM\SYSTEM\CurrentControlSet\Services\RasMan\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Prevents Routing and Remote Access from conducting IP security (IPSec) negotiation on calls using Layer 2 Tunneling Protocol (L2TP).

By default, Routing and Remote Access combines L2TP and IPSec to provide secure remote communication. If you set the value of this entry to 1, L2TP calls are not secure.

Value | Meaning
0 | RRAS conducts IPSec negotiation on L2TP calls.
1 | RRAS does not conduct IPSec negotiation on L2TP calls.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


PPP

HKLM\SYSTEM\CurrentControlSet\Services\RasMan\

Description

The RasMan\PPP subkey contains entries for the Point-to-Point Protocol (PPP) service for Routing and Remote Access.

Note Image Note

For Windows 2000, the PPP subkey has a ControlProtocols subkey. Entries for control protocols, such as CBCP, IPCP, and IPXCP, which were located in the PPP subkeys for Windows NT 4.0 and earlier, now appear in the RasMan\PPP\ControlProtocols\BuiltIn subkey.


BapListenTimeout

HKLM\SYSTEM\CurrentControlSet\Services\RasMan\PPP

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF seconds | 0x2D (45 seconds)

Description

Determines how long the client waits for a response to a BAP callback-request. While waiting, the port on which the client listens is not available for any other use. When the value of this entry expires, the port is released.

This entry is used only when client computers are configured to use Bandwidth Allocation Protocol (BAP). BAP adds and drops links dynamically as they are needed to support your network traffic. Clients send callback-requests to ask the server to connect an additional link.

Note Image Note

The default value is optimal for most installations. However, you might consider increasing this value if the client is not answering the server's callback. This can indicate that the client stops listening before the server calls. Increase this value by approximately 15 seconds and test the callback again.

The RAS client implements any value you enter in this entry, even if the value is impractical. Be certain to test the effect of changing these values before you go online.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


ControlProtocols

HKLM\SYSTEM\CurrentControlSet\Services\RasMan\PPP\

Description

The ControlProtocols subkey stores configuration data for PPP control protocols and authentication protocols, such as IPCP, IPXCP, PAP, and EAP.

Note Image Note

For Windows 2000, the PPP subkey has a ControlProtocols subkey. Entries for control protocols, such as CBCP, IPCP, and IPXCP, that were located in the PPP subkeys for Windows NT 4.0 and earlier now appear in the RasMan\PPP\ControlProtocols\BuiltIn subkey.


BuiltIn

HKLM\SYSTEM\CurrentControlSet\Services\RasMan\PPP\ControlProtocols\

Description

The BuiltIn subkey stores configuration data for PPP control protocols and authentication protocols that are included in Windows 2000.

Note Image Note

For Windows 2000, the PPP subkey has a ControlProtocols subkey. Entries for control protocols, such as CBCP, IPCP, and IPXCP, that were located in the PPP subkeys for Windows NT 4.0 and earlier now appear in the RasMan\PPP\ControlProtocols\BuiltIn subkey.


AcceptVJCompression

HKLM\SYSTEM\CurrentControlSet\Services\RasMan\PPP\ControlProtocols\BuiltIn

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether IPCP accepts IPCP standard option 0x02, Van Jacobson (VJ) header compression.

Value | Meaning
0 | IPCP does not accept VJ compression.
1 | IPCP accepts VJ compression.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


DefaultDomain

HKLM\SYSTEM\CurrentControlSet\Services\RasMan\PPP\ControlProtocols\BuiltIn

Data type | Range | Default value
REG_SZ | Domain name | Name of local computer or domain controller

Description

Specifies the domain used to validate a logon when no domain is specified. This entry applies to networked computers running Windows 2000 Server only.

By default, the system uses the name of the primary domain of the local computer. However, you can add this entry to the registry to override the default value and force the system to use the specified domain.

Note Image Note

This entry does not apply to computers running Windows 2000 Workstation or to stand-alone computers. For these, the default domain is always the name of the local computer.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


Path

HKLM\SYSTEM\CurrentControlSet\Services\RasMan\PPP\ControlProtocols\BuiltIn

Data type | Range | Default value
REG_EXPAND_SZ | Path and file name | %SystemRoot%\System32\rasppp.dll

Description

Stores the path to the dynamic link libraries for the Routing and Remote Access control protocols.

Note Image Note

In Windows NT 4.0 and earlier, each control protocol was supported by a separate DLL. In Windows 2000, a single DLL supports all control protocols.


RegisterRoutersWithNameServers

HKLM\SYSTEM\CurrentControlSet\Services\RasMan\PPP\ControlProtocols\BuiltIn

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Directs Routing and Remote Access to register all dial-out routers with the DNS and WINS servers of the server router.

Value | Meaning
0 | Routers dialing out of the network do not register with the server router's DNS and WINS servers
1 | Routers dialing out of the network register with the server router's DNS and WINS servers.

Activation method

Changes to this entry take effect the next time a router dials out of the network.

Note Image Note

This entry affects routers only when they dial out of the network. It does not affect registration of routers under any other conditions.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


RequestNameServerAddresses

HKLM\SYSTEM\CurrentControlSet\Services\RasMan\PPP\ControlProtocols\BuiltIn

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether IPCP on RAS clients request Microsoft extension options 0x81, 0x82, 0x83, and 0x84 for WINS and DNS server address negotiation.

Value | Meaning
0 | Prevents IPCP from requesting the Microsoft extension options for WINS and DNS server address negotiation.
1 | IPCP on RAS clients request the Microsoft extension options for WINS and DNS server address negotiation.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

In Windows NT 4.0 and earlier, this entry appeared in the HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Rasman\PPP\IPCP subkey.


RequestVJCompression

HKLM\SYSTEM\CurrentControlSet\Services\RasMan\PPP\ControlProtocols\BuiltIn

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether IPCP on RAS clients request IPCP standard option 0x02, Van Jacobson header (VJ) compression.

Value | Meaning
0 | Prevents RAS clients from requesting VJ compression.
1 | RAS clients request VJ compression.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

In Windows NT 4.0 and earlier, this entry appeared in the HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Rasman\PPP\IPCP subkey.


DefaultCallbackDelay

HKLM\SYSTEM\CurrentControlSet\Services\RasMan\PPP

Data type | Range | Default value
REG_DWORD | 0 - 255 seconds | 12

Description

Determines how long the RAS server's modem waits before calling back. You can add this entry to the registry of the RAS client to change the default value calculated by the RAS server.


DefaultIdleTimeout

HKLM\SYSTEM\CurrentControlSet\Services\RasMan\PPP

Data type | Range | Default value
REG_DWORD | 0x0 | 0x1 - 0xFFFFFFFF seconds | 0x0

Description

Determines how long an idle port remains active after its last transmission before it is closed.

Value | Meaning
0x0 | Idle ports do not time out. An idle port can remain active indefinitely.
0x1 - 0xFFFFFFFF seconds | The number of seconds an idle port can remain active.

Note Image Note

The "Disconnect if Idle for" Routing and Remote Access policy takes precedence over the value of this entry.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


DefaultPortLimit

HKLM\SYSTEM\CurrentControlSet\Services\RasMan\PPP

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFE ports | 0xFFFFFFFF | 0xFFFFFFFF

Description

Specifies the maximum number of ports that can be grouped into a multi-link bundle.

Value | Meaning
0x0 - 0xFFFFFFFF | The maximum number of ports in a bundle.
0xFFFFFFFF | There is no limit on the number of ports in a bundle.

Note Image Note

The "Limit Maximum ports" RRAS policy on the Multilink tab takes precedence over the value of this entry.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


DefaultSessionTimeout

HKLM\SYSTEM\CurrentControlSet\Services\RasMan\PPP

Data type | Range | Default value
REG_DWORD | 0x0 | 0x1 - 0xFFFFFFFF seconds | 0x0

Description

Determines how long a port can remain active before it is closed.

Value | Meaning
0x0 | Ports do not time out. A port can remain active indefinitely.
0x1 - 0xFFFFFFFF seconds | The number of seconds the port remains active.

Note Image Note

The "Restrict maximum session to" RRAS policy on the takes precedence over the value of this entry.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


DontNegotiateMultilinkOnSingleLinks

HKLM\SYSTEM\CurrentControlSet\Services\RasMan\PPP

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether the remote access client negotiates Multilink for connections with one device.

Multilink combines the bandwidth of two or more physical connections into a single logical connection. When a client establishes two or more physical connections to the same server, Multilink combines them into a single logical connection.

The remote access client always negotiates Multilink for connections with multiple devices. This entry applies only to connections with just one device, such as a modem or ISDN.

Value | Meaning
0 | Multilink is negotiated for all connections.
1 | Multilink is not negotiated for connections with just one device.


EAP

HKLM\SYSTEM\CurrentControlSet\Services\RasMan\PPP\

Description

The EAP subkey stores configuration data for the Extensible Authentication Protocol (EAP) service of PPP. EAP provides high-level security for virtual private network connections.


13

HKLM\SYSTEM\CurrentControlSet\Services\RasMan\PPP\EAP\

Description

The 13 subkey stores configuration data for the Extensible Authentication Protocol - Transport Level Security (EAP-TLS). EAP-TLS provides highly secure authentication for smart cards.


IgnoreNoRevocationCheck

HKLM\SYSTEM\CurrentControlSet\Services\RasMan\PPP\EAP\13

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Lets EAP-TLS clients connect even when the server does not perform or cannot complete a revocation check of the client's certificate chain (excluding the root certificate). Typically, revocation checks fail because the certificate doesn't include revocation information.

By default, an EAP-TLS client cannot connect unless the server completes a revocation check of the client's certificate chain (including the root certificate) and verifies that none of the certificates has been revoked. However, you can use this entry to override the default behavior.

This entry does not interfere with the revocation check. Also, it does not permit clients to connect if the revocation check reveals that a certificate in the chain has been revoked.

Value | Meaning
0 | Clients cannot connect unless a revocation check completes successfully.
1 | Permits clients to connect even when the revocation check cannot be completed.

You can use this entry to authenticate clients whose certificate does not include certificate revocation list distribution points (CRPs), such as those from third parties, and from the Microsoft Certificate Authority prior to Windows 2000.

Note Image Note

This entry is effective only when it appears in the registry of a RRAS server.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

IgnoreRevocationOffline

NoRootRevocationCheck

NoRevocationCheck


IgnoreRevocationOffline

HKLM\SYSTEM\CurrentControlSet\Services\RasMan\PPP\EAP\13

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Lets EAP-TLS clients connect even when a server that stores a relevant revocation list is not available on the network.

By default, EAP-TLS does not permit clients to connect unless it can complete a revocation check of their certificate chain and verify that none of the certificates has been revoked. When it cannot connect to a server that stores a revocation list, EAP-TLS considers the certificate to have failed the revocation check. However, you can add this entry to the registry to direct EAP-TLS to ignore errors related to unavailable servers.

This entry prevents a client from being denied permission to connect because poor network conditions prevented their revocation check from completing successfully.

Value | Meaning
0 | The server considers a certificate to have failed the revocation check when it cannot connect to a server that stores a revocation list.
1 | When the server connect to a server that stores a revocation list, it ignores the error and permits the client to connect.

Note Image Note

This entry is effective only when it appears in the registry of a RRAS server.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

NoRootRevocationCheck

IgnoreNoRevocationCheck

NoRootRevocationCheck

NoRevocationCheck


MaxTLSMessageLength

HKLM\SYSTEM\CurrentControlSet\Services\RasMan\PPP\EAP\13

Data type | Range | Default value
REG_DWORD | 0x5DC - 0xFFFFFFFF bytes | 0x4000 (16,384 bytes)

Description

Specifies the maximum permissible length of a Transport Layer Security (TLS) message or a set of fragmented TLS messages. If the client or server encounters a longer message, it ignores the message.

This entry is designed to prevent malicious users from harming the service by sending excessively long TLS messages.


NoRevocationCheck

HKLM\SYSTEM\CurrentControlSet\Services\RasMan\PPP\EAP\13

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Prevents EAP-TLS from performing a revocation check of the EAP-TLS client's public key certificate.

The revocation check verifies that the public key certificate (and the certificates in its certificate chain) have not been revoked.

Value | Meaning
0 | Enables revocation check.
1 | Disables the revocation check.

Note Image Note

This entry is effective only when it appears in the registry of a RRAS server.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Tip Image Tip

This entry disables the revocation check of the client's complete certificate chain. To disable the revocation check of the client's root certificate only, use the NoRootRevocationCheck entry.

Related Entries

NoRootRevocationCheck

IgnoreRevocationOffline

IgnoreNoRevocationCheck


NoRootRevocationCheck

HKLM\SYSTEM\CurrentControlSet\Services\RasMan\PPP\EAP\13

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Prevents EAP-TLS from performing a revocation check of the EAP client's root public key certificate.

The revocation check verifies that the public key certificate (and the certificates in its certificate chain) have not been revoked.

This entry only eliminates the revocation check of the client's root certificate. A revocation check is still performed on the remainder of the client's certificate chain.

Value | Meaning
0 | EAP-TLS performs a revocation check on the client's entire certificate chain, including the root certificate.
1 | EAP-TLS does not perform a revocation check on the root certificate.

You can use this entry to authenticate clients whose certificate does not include certificate revocation list distribution points (CDPs), such as those from third parties, and from the Microsoft Certificate Authority prior to Windows 2000. Also, this entry can prevent certification-related delays that occur when a certificate revocation list is offline or is expired.

Note Image Note

This entry is effective only when it appears in the registry of a RRAS server.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Tip Image Tip

This entry only disables the revocation check of the client's root certificate. To disable the revocation check of the entire certificate chain, use the NoRevocationCheck entry.

Related Entries

IgnoreRevocationOffline

IgnoreNoRevocationCheck


LowerBandwidthThreshold

HKLM\SYSTEM\CurrentControlSet\Services\RasMan\PPP

Data type | Range | Default value
REG_DWORD | 0 | 1 - 100 percent | 50

Description

Specifies the minimum bandwidth utilization when Bandwidth Allocation Protocol is used. If the percentage of bandwidth used falls below this minimum for more than the value specified in TimeBelowThreshold, Routing and Remote Access closes the connection.

A value of 0 indicates that no minimum bandwidth utilization is enforced.

Note Image Note

This setting can be overridden by a remote access policy. If you have set the Capacity option on the Multilink tab in Routing and Remote Access to a value other than 50%, that setting overrides the value of this registry entry.

This entry is used only when Bandwidth Allocation Protocol (BAP) is enabled on the computer.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

TimeBelowThreshold


MaxConfigure

HKLM\SYSTEM\CurrentControlSet\Services\RasMan\PPP

Data type | Range | Default value
REG_DWORD | 0 - 255 packets | 10

Description

Indicates how many Configure-Request packets Routing and Remote Access is permitted to send without receiving a valid Configure-ACK, Configure-NAK or Configure-Reject response. If Routing and Remote Access does not receive a valid response after sending the number of packets indicated by the value of this entry, Routing and Remote Access assumes that the peer cannot respond.


MaxFailure

HKLM\SYSTEM\CurrentControlSet\Services\RasMan\PPP

Data type | Range | Default value
REG_DWORD | 0 - 255 packets | 5

Description

Specifies how many Config-Nak packets Routing and Remote Access is permitted to send while negotiating a PPP connection. If the negotiation is not successful after the specified number of Config-Nak packets are sent, Routing and Remote Access terminates the PPP negotiation and considers it to have failed.


MaxReject

HKLM\SYSTEM\CurrentControlSet\Services\RasMan\PPP

Data type | Range | Default value
REG_DWORD | 0 - 255 packets | 5

Description

Indicates how many Config-Reject packets Routing and Remote Access is permitted to send while negotiating a PPP connection. If the negotiation is not successful after the specific number of rejections are sent, Routing and Remote Access terminates the PPP negotiation and considers it to have failed.


MaxTerminate

HKLM\SYSTEM\CurrentControlSet\Services\RasMan\PPP

Data type | Range | Default value
REG_DWORD | 0 - 255 packets | 2

Description

Indicates how many Terminate-Request packets Routing and Remote Access is permitted to send. If Routing and Remote Access does not receive a Terminate-ACK response after sending the number of packets indicated by the value of this entry, Routing and Remote Access assumes that the peer cannot respond.


NegotiateTime

HKLM\SYSTEM\CurrentControlSet\Services\RasMan\PPP

Data type | Range | Default value
REG_DWORD | 0x0 | 0x1 - 0xFFFFFFFF seconds | 0x96 (150 seconds)

Description

Determines how long PPP negotiation is permitted to proceed. If the PPP negotiation has not resulted in a successful convergence in the time indicated by the value of this entry, the server disconnects the line.

Value | Meaning
0x0 | There is no time limit for PPP negotiation. The line will not be disconnected for exceeding a negotiation time limit.
0x1 - 0xFFFFFFFF seconds | The time limit for PPP negotiation.


RestartTimer

HKLM\SYSTEM\CurrentControlSet\Services\RasMan\PPP

Data type | Range | Default value
REG_DWORD | 0x0 | 0x1 - 0xFFFFFFFF seconds | 0x3

Description

Determines how long Routing and Remote Access waits for a response from a peer to the transmission of Configure-Request and Terminate-Request packets before retransmitting the packets.


TimeBelowThreshold

HKLM\SYSTEM\CurrentControlSet\Services\RasMan\PPP

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF seconds | 0x78 (2 minutes)

Description

Determines how long a connection using Bandwidth Allocation Protocol can remain below the minimum bandwidth use (as specified by the value of LowerBandwidthThreshold) before it is disconnected.

Note Image Note

This setting can be overridden by a remote access policy. If you have set the Capacity...for a period of option on the Multilink tab in Routing and Remote Access to a value other than 120 seconds, that setting overrides the value of this registry entry.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


Rdr

HKLM\SYSTEM\CurrentControlSet\Services\

Description

The Rdr subkey contains configuration data for the Windows 2000 redirector (Rdr) service.

This subkey and its entries do not appear in the registry by default, but you can add them to the registry to customize the redirector service.


Parameters

HKLM\SYSTEM\CurrentControlSet\Services\Rdr\

Description

The Rdr\Parameters subkey contains configuration data for the Windows 2000 redirector (Rdr) service.

This subkey and its entries do not appear in the registry by default, but you can add them to the registry to customize the redirector service.


RemoteAccess

HKLM\SYSTEM\CurrentControlSet\Services\

Description

The RemoteAccess subkey stores configuration data for Routing and Remote Access.

Several other subkeys, such as RasMan, RasAuto, and RasAcd, also store entries for secondary services that support dial-in connections. The RemoteAccess subkey stores data that applies to the entire service.

Change method

Some entries in this subkey can be changed by using the Routing and Remote Access Manager. For details, see the description of each entry.


Accounting

HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess\

Description

The Accounting subkey stores configuration data for Routing and Remote Access accounting providers, such as Windows and RADIUS. Accounting providers record connection information in log files.

The Accounting subkey does not contain any entries. It contains a Providers subkey which contains entries that apply to all dial-up accounting providers and subkeys representing each provider, which store provider-specific entries.


Providers

HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess\Accounting\

Description

The Accounting\Providers subkey stores configuration data for Routing and Remote Access authentication providers, such as Windows and RADIUS.

The Providers subkey contains entries that apply to all dial-up accounting providers. It also contains subkeys representing each provider, which are named by the GUID of the provider and store entries that apply only to that provider.

The following accounting providers are included in Windows 2000

  • {1AA7F840-C7F5-11D0-A376-00C04FC9DA04} represents the RADIUS accounting provider.
  • {1AA7F846-C7F5-11D0-A376-00C04FC9DA04} represents the Windows accounting provider.


{1AA7F840-C7F5-11D0-A376-00C04FC9DA04}

HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess\Accounting\Providers\

Description

The {1AA7F840-C7F5-11D0-A376-00C04FC9DA04} subkey stores configuration data for the RADIUS accounting provider.

This subkey can also contain a Servers subkey which, in turn, contains subkeys representing each RADIUS server used for RADIUS accounting. The server-specific subkeys store entries that apply only to the named server.

Tip Image Tip

To configure a RRAS server to use RADIUS accounting, use Accounting Provider box on the Security tab in the Routing and Remote Access snap in.

Related Entries

{1AA7F846-C7F5-11D0-A376-00C04FC9DA04}

(Windows accounting provider subkey)


Servers

HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess\Accounting\Providers\{1AA7F840-C7F5-11D0-A376-00C04FC9DA04}\

Description

The {1AA7F840-C7F5-11D0-A376-00C04FC9DA04}\Servers subkey stores server-specific configuration data for a RADIUS accounting provider .

This subkey does not contain any entries. It contains subkeys representing each RADIUS used for RADIUS accounting. The server-specific subkeys store entries that are configured separately for each server and apply only to the named server.

Note Image Note

RRAS add the Servers subkey to the registry when you add a server to the list in the RADIUS Accounting dialog box in Routing and Remote Access.

Tip Image Tip

To configure a RRAS server to use RADIUS accounting, use Accounting Provider box on the Security tab in the Routing and Remote Access snap in.


<Server-name>

HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess\Accounting\Providers\{1AA7F840-C7F5-11D0-A376-00C04FC9DA04}\Servers\

Description

The <Server-name> subkey stores server-specific configuration data for a RADIUS accounting provider.

The <Server-name> subkey is a variable representing the subkeys in the RemoteAccess\Accounting\{1AA7F840-C7F5-11D0-A376-00C04FC9DA04}\Servers subkey. It doesn't actually appear in the registry. We use this variable subkey to display the entries and subkeys that are common to the subkeys in the Servers subkey.

The <Server-name> subkeys in your registry represent RADIUS servers used for RADIUS accounting. Each subkey represents a particular server and stores configuration data that applies only to that server.

Note Image Note

RRAS add a <Server-name> subkey to the registry when you add a server to the list in the RADIUS Accounting dialog box in Routing and Remote Access.

Tip Image Tip

To configure a RRAS server to use RADIUS accounting, use Accounting Provider box on the Security tab in the Routing and Remote Access snap in.


NASIpAddress

HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess\Accounting\Providers\{1AA7F840-C7F5-11D0-A376-00C04FC9DA04}\Servers\<Server-name>

Data type | Range | Default value
REG_SZ | IP address | There is no default value for this entry.

Description

Identifies the network access server (NAS) to use with RADIUS accounting. The server is identified by this IP address.

The Routing and Remote Access server binds to this address. Also, it uses this address as the value of the NAS_IP_Address RADIUS attribute (Attribute 4).

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Tip Image Tip

To configure a RRAS server to use RADIUS accounting, use Accounting Provider box on the Security tab in the Routing and Remote Access snap in.

Related Entries

NASIpAddress

(RADIUS accounting providers)


Retries

HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess\Accounting\Providers\{1AA7F840-C7F5-11D0-A376-00C04FC9DA04}\Servers\<Server-name>

Data type | Range | Default value
REG_DWORD | 0x1 - 0xFFFFFFFF | 0x2

Description

Determines how many times the RRAS server sends an Accounting-Request message to the RADIUS servers. RRAS repeats the message if none of the RADIUS servers respond.

If a RADIUS server does not responded before the number of retries is exhausted, RAS terminates the connection and records an error in the System Log in Event Viewer. If the client tries to connect again, RRAS treats it like a new connection attempt.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Tip Image Tip

To configure a RRAS server to use RADIUS accounting, use Accounting Provider box on the Security tab in the Routing and Remote Access snap in.

Related Entries

Retries (Authentication\Providers subkey)


{1AA7F846-C7F5-11D0-A376-00C04FC9DA04}

HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess\Accounting\Providers\

Description

The {1AA7F846-C7F5-11D0-A376-00C04FC9DA04} subkey stores configuration data for the Windows accounting provider.

Tip Image Tip

To configure a RRAS server to use Windows accounting, use Accounting Provider box on the Security tab in the Routing and Remote Access snap in.

Related Entries

{1AA7F840-C7F5-11D0-A376-00C04FC9DA04}

(RADIUS accounting provider subkey)


ActiveProvider

HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess\Accounting\Providers

Data type | Range | Default value
REG_SZ |

Description

Specifies the accounting provider used to record dial-up connection data in a log file. This entry stores the GUID of the accounting provider you select by using the Routing and Remote Access snap-in.

Windows is the default accounting provider, but you can use the Routing and Remote Access snap-in to select an alternate accounting provider.

The following accounting providers are included in Windows 2000

  • {1AA7F840-C7F5-11D0-A376-00C04FC9DA04} represents the RADIUS accounting provider.
  • {1AA7F846-C7F5-11D0-A376-00C04FC9DA04} represents the Windows accounting provider.

Entries specific to these providers are stored in the following subkeys in RemoteAccess\Accounting\Providers:

  • {1AA7F840-C7F5-11D0-A376-00C04FC9DA04} (RADIUS accounting provider subkey)
  • {1AA7F846-C7F5-11D0-A376-00C04FC9DA04} (Windows accounting provider subkey)

Change method

To change the value of this entry, use Routing and Remote Access. Right-click the name of the server, click Properties, click the Security tab and select a provider from the Accounting provider drop-down box.

Caution Image Caution

To change the value of this entry, use Routing and Remote Access. Do not edit the registry.


Authentication

HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess\

Description

The Authentication subkey stores configuration data for Routing and Remote Access authentication providers, such as Windows and RADIUS.

The Authentication subkey does not contain any entries. It contains a Providers subkey which contains entries that apply to all dial-up authentication providers and subkeys representing each provider, which store provider-specific entries.


Providers

HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess\Authentication\

Description

The Authentication\Providers subkey stores configuration data for Routing and Remote Access authentication providers, such as Windows and RADIUS.

The Providers subkey contains entries that apply to all dial-up authentication providers. It also contains subkeys representing each provider, which are named by the GUID of the provider and store entries that apply only to that provider.

The following authentication providers are included in Windows 2000

  • {1AA7F83F-C7F5-11D0-A376-00C04FC9DA04} represents the RADIUS authentication provider.
  • {1AA7F841-C7F5-11D0-A376-00C04FC9DA04} represents the Windows authentication provider.

Related Entries

{1AA7F83F-C7F5-11D0-A376-00C04FC9DA04} (RADIUS authentication provider subkey)

{1AA7F841-C7F5-11D0-A376-00C04FC9DA04} (Windows authentication provider subkey)

{1AA7F840-C7F5-11D0-A376-00C04FC9DA04} (RADIUS accounting provider subkey)


{1AA7F83F-C7F5-11D0-A376-00C04FC9DA04}

HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess\Authentication\Providers\

Description

The {1AA7F83F-C7F5-11D0-A376-00C04FC9DA04} subkey stores configuration data for the RADIUS authentication provider.

This subkey also can contain a Servers subkey which, in turn, contains subkeys representing each RADIUS server used for RADIUS authentication. The server-specific subkeys store entries that apply only to the named server.

Tip Image Tip

To configure a RRAS server to use RADIUS authentication, use Authentication Provider box on the Security tab in the Routing and Remote Access snap in.

Related Entries

{1AA7F841-C7F5-11D0-A376-00C04FC9DA04}

(Windows authentication provider subkey)

{1AA7F840-C7F5-11D0-A376-00C04FC9DA04}

(RADIUS accounting provider subkey)


Servers

HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess\Authentication\Providers\{1AA7F83F-C7F5-11D0-A376-00C04FC9DA04}\

Description

The {1AA7F83F-C7F5-11D0-A376-00C04FC9DA04}\Servers subkey stores server-specific configuration data for a RADIUS authentication provider .

This subkey does not contain any entries. It contains subkeys representing each RADIUS server used for RADIUS authentication. The server-specific subkeys store entries that are configured separately for each server and apply only to the named server.

Note Image Note

RRAS adds the Servers subkey to the registry when you add a server to the list in the RADIUS Authentication dialog box in Routing and Remote Access.

Tip Image Tip

To configure a RRAS server to use RADIUS authentication, use Authentication Provider box on the Security tab in the Routing and Remote Access snap in.


<Server-name>

HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess\Authentication\Providers\{1AA7F83F-C7F5-11D0-A376-00C04FC9DA04}\Servers\

Description

The <Server-name> subkey stores server-specific configuration data for a RADIUS authentication provider.

The <Server-name> subkey is a variable representing the subkeys in the RemoteAccess\Authentication\{1AA7F83F-C7F5-11D0-A376-00C04FC9DA04}\Servers subkey. It doesn't actually appear in the registry. We use this variable subkey to display the entries and subkeys that are common to the subkeys in the Servers subkey.

The <Server-name> subkeys in your registry represent RADIUS servers that are used for RADIUS authentication. Each subkey represents a particular server and stores configuration data that applies only to that server.

Note Image Note

RRAS adds the Servers subkey to the registry when you add a server to the list in the RADIUS Authentication dialog box in Routing and Remote Access.

Tip Image Tip

To configure a RRAS server to use RADIUS authentication, use Authentication Provider box on the Security tab in the Routing and Remote Access snap in.


NASIpAddress

HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess\Authentication\Providers\{1AA7F83F-C7F5-11D0-A376-00C04FC9DA04}\Servers\<Server-name>

Data type | Range | Default value
REG_SZ | IP address | There is no default value for this entry.

Description

Identifies the network access server (NAS) to use with RADIUS authentication. The server is identified by this IP address.

The Routing and Remote Access server binds to this address. Also, it uses this address as the value of the NAS_IP_Address RADIUS attribute (Attribute 4).

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Tip Image Tip

To configure a RRAS server to use RADIUS authentication, use Authentication Provider box on the Security tab in the Routing and Remote Access snap in.

Related Entries

NASIpAddress

(RADIUS accounting providers)


Retries

HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess\Authentication\Providers\{1AA7F83F-C7F5-11D0-A376-00C04FC9DA04}\Servers\<Server-name>

Data type | Range | Default value
REG_DWORD | 0x1 - 0xFFFFFFFF | 0x2

Description

Determines how many times the RRAS server sends an Access-Request message to the RADIUS servers. RRAS repeats the message if none of the RADIUS servers respond.

If a RADIUS server does not responded before the number of retries is exhausted, RAS terminates the connection and records an error in the System Log in Event Viewer. If the client tries to connect again, RRAS treats it like a new connection attempt.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Tip Image Tip

To configure a RRAS server to use RADIUS authentication, use Authentication Provider box on the Security tab in the Routing and Remote Access snap in.

Related Entries

Retries (Accounting\Providers subkey)


SendSignature

HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess\Authentication\Providers\{1AA7F83F-C7F5-11D0-A376-00C04FC9DA04}\Servers\<Server-name>

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Directs RRAS to include a digital signature in all Access–Requests messages to this RADIUS server.

Value | Meaning
0 | RRAS includes a digital signature only in Extensible Authentication Protocol (EAP) Access–Requests messages.
1 | RRAS includes a digital signature in all Access–Requests messages.

Change method

To change the value of this entry, use the Routing and Remote Access snap-in. Right-click the name of the server, click Properties, and then click the Security tab. From the Authentication Provider drop-down list, select RADIUS Authentication, click Configure, click Edit and select the Always use digital signatures check box.

Tip Image Tip

To configure a RRAS server to use RADIUS authentication, use Authentication Provider box on the Security tab in the Routing and Remote Access snap in.


{1AA7F841-C7F5-11D0-A376-00C04FC9DA04}

HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess\Authentication\Providers\

Description

The {1AA7F841-C7F5-11D0-A376-00C04FC9DA04} subkey stores configuration data for the Windows authentication provider.

Tip Image Tip

To configure a RRAS server to use Windows authentication, use Authentication Provider box on the Security tab in the Routing and Remote Access snap in.


ActiveProvider

HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess\Authentication\Providers

Data type | Range | Default value
REG_SZ | {1AA7F841-C7F5-11D0-A376-00C04FC9DA04}

Description

Specifies the authentication provider used to authenticate users who dial-up to the computer. This entry stores the GUID of the authentication provider you select by using the Routing and Remote Access snap-in.

Windows is the default authentication provider, but you can use the Routing and Remote Access snap-in to select an alternate authentication provider.

The following authentication providers are included in Windows 2000

  • {1AA7F83F-C7F5-11D0-A376-00C04FC9DA04} represents the RADIUS authentication provider.
  • {1AA7F841-C7F5-11D0-A376-00C04FC9DA04} represents the Windows authentication provider.

Entries specific to these providers are stored in the following subkeys in RemoteAccess\Authentication\Providers:

  • {1AA7F83F-C7F5-11D0-A376-00C04FC9DA04} (RADIUS authentication provider subkey)
  • {1AA7F841-C7F5-11D0-A376-00C04FC9DA04} (Windows authentication provider subkey)

Change method

To change the value of this entry, use the Routing and Remote Access snap-in. Right-click the name of the server, click Properties, click the Security tab and select a provider from the Authentication provider drop-down box.

Caution Image Caution

To change the value of this entry, use the Routing and Remote Access snap-in. Do not edit the registry.


Parameters

HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess\

Description

The RemoteAccess\Parameters subkey stores configuration data for Routing Remote Access. The data in this subkey specifies the value of variables that apply to the entire service.

Activation method

You must stop and restart the Remote Access service before changes to the values in this subkey take effect.


AccountLockout

HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess\Parameters\

Description

The AccountLockout subkey stores the database for the account lockout feature of Routing and Remote Access.

Account lockout prohibits dial-in access to a server after repeated failed authentication attempts. By default, the account lockout feature is disabled.

This subkey stores entries that specify the operating criteria for the Account Lockout feature. It also includes subkeys representing user accounts affected by the feature. These <domain>:<user-name> subkeys each represent one user and track the number of failed attempts to authenticate the user.

Note Image Note

Account lockout prevents all dial-in access to a locked user account, not just access from the computer that submitted the failed authentication.

Tip Image Tip

To disable Account Lockout or reset all user denial counts to 0 while the server is running, set the value of MaxDenials to 0. If you delete the AccountLockout subkey or the <domain>:<user-name> subkey for a user, the service does not detect the change until the system is restarted.


<domain>:<user-name>

HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess\Parameters\AccountLockout\

Description

The <domain>:<user-name> subkey in AccountLockout subkey stores the account lockout record for a user.

The system adds this subkey to the registry when a dial-in authentication attempt for the user account fails, that is, when the value of Denials for a user account is 1. The system deletes this subkey when the value of ResetTime (mins) expires, setting the value of Denials for all users back to 0.

The <domain>:<user-name> subkey is a variable representing the subkeys in the AccountLockout subkey. It doesn't actually appear in the registry. We use this variable subkey to display the entries that can appear in any AccountLockout user subkey.

Note Image Note

Account lockout prevents all dial-in access to a locked user account, not just access from the computer that submitted the failed authentication.

Tip Image Tip

To disable Account Lockout or reset all user denial counts to 0 while the server is running, set the value of MaxDenials to 0. If you delete the AccountLockout subkey or the <domain>:<user-name> subkey for a user, the service does not detect the change until the system is restarted.


Denials

HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess\Parameters\AccountLockout\<domain>:<user-name>

Data type | Range | Default value
REG_DWORD | 0x1 - 0xFFFFFFFF | There is no default value for this entry.

Description

Stores the current number of failed attempts to authenticate this user account for dial-up access.

This entry stores a counter that is incremented each time an attempt to authenticate the account (submit a valid user name and correct password) fails. This entry (and the user subkey that stores it) is created the first time an authentication attempt fails during the interval specified by the value of ResetTime (mins). The entry (and its subkey) is deleted when the value of ResetTime (mins) expires or someone successfully authenticates the user account.

If, at any time during the interval defined by ResetTime (mins), the value of Denials for this user reaches denial threshold for the server (stored in the value of MaxDenials) the user account is locked. The system does not process any subsequent dial-in authentication attempts for this account until the value of ResetTime (mins) expires, or an administrator deletes the user's <domain>:<user-name> subkey or sets the value of Denials for that account to 0 (or less than the value of MaxDenials).

Note Image Note

Account lockout prevents all dial-in access to a locked user account, not just access from the computer that submitted the failed authentication.


MaxDenials

HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess\Parameters\AccountLockout

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines how many attempts to authenticate a user account can fail before the user is denied dial-in access to the server. Authentication fails when a user enters an incorrect password for a valid user name.

This entry also enables and disables the Account Lockout feature of Routing and Remote Access service. If the value of this entry is greater than 0, the Account Lockout feature is enabled on this computer. Otherwise, it is disabled.

When the number of denials (failed attempts) for an account exceeds the value of MaxDenials within the time specified by the value of ResetTime (mins), the user account is locked. The system does not process any subsequent dial-in authentication attempts until the value of ResetTime (mins) expires, or an administrator deletes the user's <domain>:<user-name> subkey or sets the value of Denials for that account to 0 (or less than the value of MaxDenials).

Consider increasing the value of this entry if your server is the target of malicious attempts to gain access to your system. However, because Account Lockout can prevent legitimate users from gaining access to their accounts, it should not be used unless it is needed.

Note Image Note

Account lockout prevents all dial-in access to a locked user account, not just access from the computer that submitted the failed authentication.

Tip Image Tip

To disable Account Lockout or reset all user denial counts to 0 while the server is running, set the value of MaxDenials to 0. If you delete the AccountLockout subkey or the <domain>:<user-name> subkey for a user, the service does not detect the change until the system is restarted.

Related Entries

ResetTime (mins)


ResetTime (mins)

HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess\Parameters\AccountLockout

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF | 2880 (48 hours)

Description

Determines the time interval for the Account Lockout feature.

User's accounts are locked when the number of denials (failed authentication attempts) for the account exceeds the configured threshold during this interval. When this interval expires, the denial counter for each user is deleted and the interval begins again.

If this value is too large, legitimate users who occasionally mistype or forget their password might be denied access unnecessarily. If the value is too small, malicious users can program a wait time into their programs and continue their attempts to infiltrate the account.

Note Image Note

Account lockout prevents all dial-in access to a locked user account, not just access from the computer that submitted the failed authentication.

Tip Image Tip

The denial counter for each user is stored in the value of Denials. The denial threshold for this computer is stored in the value of MaxDenials.

Related Entries

Denials

MaxDenials


AuthenticateRetries

HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess\Parameters

Data type | Range | Default value
REG_DWORD | 0 - 10 | 2

Description

Specifies the maximum number of times the Remote Access service attempts to authenticate a client.

This entry differs from CallbackRetries which specifies the maximum number of times the remote access service tries to call the client back for the purpose of authentication.

Change method

To change the value of this entry, use the Max number of unsuccessful authentication retries policy in Group Policy. (Computer Settings\Software Policies\Windows NT Remote Access)

Activation method

You must stop and restart Routing and Remote Access before changes to these values take effect.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

AuthenticateTime

CallbackRetries


AuthenticateTime

HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess\Parameters

Data type | Range | Default value
REG_DWORD | 20 - 600 seconds | 120

Description

Specifies the maximum time within which a user must be successfully authenticated. If the client does not complete the authentication process within this time, the user is disconnected.

Change method

To change the value of this entry, use the Max time limit for authentication policy in Group Policy. (Computer Settings\Software Policies\Windows NT Remote Access)

Activation method

You must stop and restart the Remote Access service before changes to these values take effect.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

AuthenticateRetries


AutoDisconnect

HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 | 0x1 - 0xFFFFFFFF seconds | 0x0

Description

Determines how long an inactive connection can remain open. If a connection remains inactive longer than the value of this entry permits, the connection is closed. Connections are considered to be inactive when they are not transferring NetBIOS session data, such as copying files, accessing network resources, or sending and receiving electronic mail.

Value | Meaning
0x0 | Inactive connections are never disconnected automatically. This setting might be appropriate when clients are running NetBIOS datagram applications.
0x1 - 0xFFFFFFFF seconds | The maximum time the system permits an inactive connection to remain open.

Change method

To change the value of this entry, use the Auto Disconnect policy in Group Policy. (Computer Settings\Software Policies\Windows NT Remote Access)

Activation method

You must stop and restart the Remote Access service before changes to these values take effect.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


CallbackRetries

HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF | 0x0

Description

Determines how many times the server attempts to call the client back if the initial callback fails. This entry is used only when the callback security feature is enabled.

If the value of this entry is 0x0 (the default value) and the initial callback fails, the system does not attempt any further callbacks.

This entry is designed for environments where telephone systems are not always reliable and multiple calls are often required to establish a connection.

This entry differs from AuthenticateRetries which specifies the maximum number of times the Remote Access service attempts to authenticate the client, not just to contact the client by calling back.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

DefaultCallbackDelay

AuthenticateRetries

CallbackTime


CallbackTime

HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess\Parameters

Data type | Range | Default value
REG_DWORD | 2 - 12 seconds | 2

Description

Specifies how long the server waits before calling the client back for authentication. The value of this entry is a default which is used only when the client does not specify an interval between callbacks. It is used only when the callback feature is enabled.

This entry differs from AuthenticateTime which specifies the minimum interval between attempts to authenticate the client, not just, not just to contact the client by calling back.

Change method

To change the value of this entry, use the Wait interval for callback policy in Group Policy. (Computer Settings\Software Policies\Windows NT Remote Access)

Activation method

You must stop and restart Routing and Remote Access before changes to these values take effect.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

AuthenticateTime

CallbackRetries

SecurityHostTime


Ip

HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess\Parameters\

Description

The RAS IP subkey stores entries for the Remote Access Service (RAS) by using the Internet Protocol (IP).


AllowClientIpAddresses

HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess\Parameters\Ip

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Lets dial-up clients request a connection to a particular Routing and Remote Access server by specifying its IP address.

Value | Meaning
0 | Clients cannot request a particular server.
1 | Clients can request a particular server.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

In Windows NT 4.0 and earlier, this entry appeared in the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Rasman\PPP\IPCP subkey.

The "Client may request an IP address" Routing and Remote Access policy takes precedence over the value of this entry.


DNSNameServers

HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess\Parameters\Ip

Data type | Range | Default value
REG_MULTI_SZ | IP address [IP address] | ( IP address of DNS server)

Description

Determines which DNS servers the Routing and Remote Access client uses.

You can add this entry to the registry of a Routing and Remote Access server to override the automatic assignment of the RAS server's DNS servers to the RAS client.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

WINSNameServer

WINSNameServerBackup


InitialAddressPoolSize

HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess\Parameters\Ip

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF addresses | 0xA (10 addresses)

Description

Limits the number of addresses the Routing and Remote Access server gets from the DHCP server at one time.

The number of addresses in each batch cannot exceed the value of InitialAddressPoolSize. By default, the number of addresses in each batch is equal to the number of available Routing and Remote Access ports + 1. However, if InitialAddressPoolSize is less than ports + 1, Routing and Remote Access sets the batch size to the value of InitialAddressPoolSize.

The Routing and Remote Access server gets a batch of addresses when the service starts and it gets the same number of addresses each time it uses up the previous batch.


StaticAddressPool

HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess\Parameters\Ip\

Description

The StaticAddressPool subkey stores a range of static IP address for use on a Routing and Remote Access server.

The StaticAddressPool subkey contains numbered subkeys, each of which represents a particular static IP address pool. The entries in the numbered subkeys define the range of IP addresses in the pool.

Change method

To create a static IP address pool, use Routing and Remote Access. Right-click a server name, click Properties, click the IP tab, select the Static address pool option, and then click Add.

Note Image Note

RRAS adds the StaticAddressPool subkey to the registry when you use Routing and Remote Access to add and configure a static address pool.

Caution Image Caution

To create a static IP address pool, use the IP tab in Routing and Remote Access. Do not edit the registry.


<Pool-number>

HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess\Parameters\Ip\StaticAddressPool\

Description

The <Pool-number> subkey represents a particular pool of static IP addresses for Routing and Remote Access servers. These subkeys are numbered, beginning with 0, in the order that the pool was created. The entries in the <Pool-number> subkeys define the range of IP addresses in the pool.

The <Pool-number> subkey is a variable representing the subkeys in the RemoteAccess\Parameters\Ip\StaticAddressPool subkey. It doesn't actually appear in the registry. We use this variable subkey to display the entries and subkeys that are common to the subkeys in the StaticAddressPool subkey.

Note Image Note

RRAS add a <Pool-number> subkey to the registry when you add a static IP address pool by defining a range in the New Address Range dialog box in Routing and Remote Access.

Tip Image Tip

For more information about static address pools, see TCP/IP and remote access in Windows 2000 Help.

Caution Image Caution

To create a static IP address pool, use the IP tab in Routing and Remote Access. Do not edit the registry.


From

HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess\Parameters\Ip\StaticAddressPool\<Pool-number>

Data type | Range | Default value
REG_DWORD | IP address (as integers, not dotted decimal format) | There is no default value for this entry.

Description

Specifies the first IP address in the pool range.

This entry stores the value in the Start IP address box on the New Address Range dialog box in Routing and Remote Access.

The IP address is stored in this entry as four contiguous hexadecimal values. For example, the IP address 1.2.3.4 would appear in this entry as 0x1020304 and 255.255.255.255 would appear as 0xFFFFFFFF (255 = 0xFF).

Change method

To create a static IP address pool, use Routing and Remote Access. Right-click a server name, click Properties, click the IP tab, select the Static address pool option, and then click Add.

Note Image Note

RRAS add the From entry to the registry when you add a static IP address pool by defining a range in the New Address Range dialog box in Routing and Remote Access.

Tip Image Tip

For more information about static address pools, see TCP/IP and remote access in Windows 2000 Help.

Caution Image Caution

To create a static IP address pool, use the IP tab in Routing and Remote Access. Do not edit the registry.


To

HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess\Parameters\Ip\StaticAddressPool\<Pool-number>

Data type | Range | Default value
REG_DWORD | IP address (as integers, not dotted decimal format) | There is no default value for this entry.

Description

Specifies the last IP address in the pool range.

This entry stores the value in the End IP address box on the New Address Range dialog box in Routing and Remote Access.

The IP address is stored in this entry as four contiguous hexadecimal values. For example, the IP address 1.2.3.4 would appear in this entry as 0x1020304 and 255.255.255.255 would appear as 0xFFFFFFFF (255 = 0xFF).

Change method

To create a static IP address pool, use Routing and Remote Access. Right-click a server name, click Properties, click the IP tab, select the Static address pool option, and then click Add.

Note Image Note

RRAS add the From entry to the registry when you add a static IP address pool by defining a range in the New Address Range dialog box in Routing and Remote Access.

Tip Image Tip

For more information about static address pools, see TCP/IP and remote access in Windows 2000 Help.

Caution Image Caution

To create a static IP address pool, use the IP tab in Routing and Remote Access. Do not edit the registry.

Related Entries

From


WINSNameServer

HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess\Parameters\Ip

Data type | Range | Default value
REG_SZ | IP address | ( IP address of WINS server)

Description

Determines which WINS name server the RAS client uses.

You can add this entry to the registry of a RAS server to override the automatic assignment of the RAS server's WINS server to the RAS client.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

DNSNameServers

WINSNameServerBackup


WINSNameServerBackup

HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess\Parameters\Ip

Data type | Range | Default value
REG_SZ | IP address | (IP address of WINS server)

Description

Determines which backup WINS name server the RAS client uses.

You can add this entry to the registry of a RAS server to override the automatic assignment of the RAS server's backup WINS server to the RAS client.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

DNSNameServers

WINSNameServer


Ipx

HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess\Parameters\

Description

Stores entries for the Remote Access Service (RAS) when it is implemented by using Internetwork Packet Exchange (IPX).


FirstWanNode

HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess\Parameters\Ipx

Data type | Range | Default value
REG_SZ | 12-digit hexadecimal value representing the node | There is no default value for this entry.

Description

Identifies the base node number assigned to callers.

If the callers are using the same network number, the system assigns the base node number to all callers. However, if all callers are using different network number, the system assigns the base node number to the first caller, and then increments the node number by 1 for each subsequent caller.

Note Image Note

You must enter the node number into the registry editor in hexadecimal format. The registry editors do not convert text values to a different radix.


LanOnlyMode

HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess\Parameters

Data type | Range | Default value
REG_DWORD | 0

Description

This entry appears in the registry if you upgrade from Windows NT 4.0 and earlier, but it is not used by Windows 2000.


LoggingFlags

HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess\Parameters

Data type | Range | Default value
REG_DWORD | 0 - 3 | 3

Description

Determines which events Routing and Remote Access records in the System Log in Event Viewer. This entry affects logging by Routing and Remote Access only; it does not affect logging by routing components or by transports, such as IP and IPX.

Value | Meaning
0 | No log. Routing and Remote Access does not record any events in the System Log.
1 | Errors only
2 | Errors and warnings only.
3 | All events (errors, warnings, and information).

Change method

To change the value of this entry, use Routing and Remote Access Manager. Right-click the server name, click Properties, and then click the RAS Event Logging tab. Do not edit the registry.

Activation method

You must stop and restart the Remote Access service before changes to these values take effect.


RouterType

HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess\Parameters

Data type | Range | Default value
REG_DWORD | 0 - 7 | 1

Description

Specifies the functions of the remote access router. To enable more than one function, sum the value for each function.

For example, to enable a router for RAS clients (value = 1) and for inter-LAN communication (value = 2), set the value of RouterType to 3.

Value | Meaning
1 | A remote access server for RAS clients.
2 | A LAN-to-LAN router.
4 | A LAN-to-WAN-to-LAN or Demand Dial router.

Change method

To change the value of this entry, use Routing and Remote Access Manager. Right-click the name of the RAS server, click Properties, and click the General tab. Do not edit the registry.

Activation method

You must stop and restart the Remote Access service before changes to these values take effect.

Note Image Note

This value appears in the registry when you use the Routing and Remote Access Manager snap-in to configure the router.


SecurityHostTime

HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess\Parameters

Data type | Range | Default value
REG_DWORD | 20 - 600 seconds | 120

Description

Specifies how long Routing and Remote Access waits for clients to complete third party authentication. If authentication is not complete before this value expires, Routing and Remote Access considers it to have failed.

The time limit specified in this entry applies only to the third party authentication that occurs before Routing and Remote Access authentication. The time limit for Routing and Remote Access authentication is specified in the value of AuthenticateTime.

Activation method

You must stop and restart the Remote Access service before changes to these values take effect.

Related Entries

AuthenticateTime


ServerFlags

HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF | 0x402702

Description

A bitmask that determines whether important features of the Remote Access service are enabled.

To enable a feature, set the bit associated with the feature to 1 or add the hexadecimal value associated with the feature to the value of ServerFlags. To enable a feature, set the bit associated with the feature to 0 or subtract the hexadecimal value associated with the feature from the value of ServerFlags.

To view the valid values for ServerFlags, see Values for Remote Access ServerFlags.

The default value, 0x402702, enables the following features for dial-in clients and routers:

  • Software compression (0x2)
  • CHAP protocol (0x100)
  • LCP extensions (0x200)
  • Multilink protocol (0x400)
  • BAP protocol (0x2000)
  • Authentication not required for clients connecting over direct connect ports.

Change method

To change the value of this entry, use Routing and Remote Access Manager.

Activation method

You must stop and restart the Remote Access service before changes to these values take effect.


ServiceDll

HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess\Parameters

Data type | Range | Default value
REG_EXPAND_SZ | Path | %SystemRoot%\System32\mprdim.dll

Description

Specifies the location of the dynamic link library for the Remote Access service.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Caution Image Caution

Do not change the value of this entry. If you change this value or move the dynamic link library file, you can prevent the RRAS service from starting.


Stamp

HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 0

Description

This entry is used internally by Routing and Remote Access. It ensures that the time stamp in the Parameters subkey is accurate even when the registry entries are copied to and changed within an internal memory cache.

Activation method

You must stop and restart the Remote Access service before changes to these values take effect.

Caution Image Caution

Do not change the value of this entry. The entry is used internally by the RRAS service.


Policy

HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess\

Description

The Policy subkey of Remote Access stores policy settings shared by the Internet Authentication Service (IAS) Routing and Remote Access service (RRAS). Remote Access policies determine permissions and connection settings.

The entries in the policy subkey also determine which attributes are used to authenticate users and how they are evaluated.


Allow LM Authentication

HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess\Policy

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether Internet Authentication Service (IAS) and Routing and Remote Access Service (RRAS) can use LanManager (LM) Challenge/Response authentication.

By default, IAS and RRAS use Windows Challenge/Response authentication, version 2 (known as NTLMv2) because it provides more robust password protection. However, LanManager authentication support is available to maintain compatibility with servers running older operating systems that do not support NTLM authentication.

Value | Meaning
0 | LanManager authentication is not supported. As a result, servers are subject to the secure password authentication provided by NTLMv2. However, the system cannot connect to servers that do not support Window 2000 Challenge/Response authentication, such as Windows 95, Windows 98, or Windows for Workgroups servers.
1 | LanManager authentication is supported. The system can connect to servers that do not support NTLMv2. However, the system is vulnerable to malicious attacks that take advantage of the weaker protocol.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


Default User Identity

HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess\Policy

Data type | Range | Default value
REG_SZ | User account name | User-Name

Description

Specifies the name used for guest access to the network.

By default, if a request for guest access does not include the name of a user account, then the system uses the guest account for the local computer or for the domain. However, you can add this entry to the registry to specify an alternate guest account.

The account specified in this entry is used for guest accounts instead of the default when:

  • The value of Override User-Name is 0;
  • User Identity Attribute does not appear in the registry;
  • The RADIUS attribute specified in the value of User Identity Attribute does not appear in the request.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Tip Image Tip

RADIUS attributes are defined in RFC 2138. To find a list of RADIUS attributes, see RFC 2138, or see Remote access RADIUS Attributes.

Related Entries

User Identity Attribute

Override User-Name


Override User-Name

HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess\Policy

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Directs IAS and Routing and Remote Access to use the RADIUS attribute specified in the value of User Identity Attribute to identify an account for purposes of authentication and accounting. The specified attribute is used instead of the user account name even when a valid user account name appears in the request.

Value | Meaning
0 | Use User-Name. IAS uses the value of the RADIUS User-Name attribute for authentication and accounting.
1 | Use the attribute specified in the value of User Identity Attribute.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Tip Image Tip

RADIUS attributes are defined in RFC 2138. To find a list of RADIUS attributes, see RFC 2138, or see Remote access RADIUS Attributes.

Caution Image Caution

If the value of this entry is 1, and User Identity Attribute does not appear in the registry with a valid value, IAS does not authenticate any users.

Related Entries

User Identity Attribute

Default User Identity


User Identity Attribute

HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess\Policy

Data type | Range | Default value
REG_DWORD | RADIUS attribute number | By default, this entry does not appear in the registry.

Description

Specifies an alternate RADIUS attribute used to identify a user account in Active Directory for authentication and authorization.

By default, the value of the alternate attribute specified here is used only when the an access request does not include a user name, that is, when the request does not include a valid RADIUS User-Name attribute.

However, if the value of Override User-Name is 1, IAS must use the attribute specified in the value of this entry to identify the account, even when the request includes a valid User-Name attribute.

To specify an attribute, enter the Remote Access Dial-in User Service (RADIUS) attribute number for the attribute in decimal integers. For example, to identify users by their Caller ID or Automatic Number Identification (ANI), add this entry to the registry and set its value to 31, the RADIUS attribute number for Calling-Station-Id.

Note Image Note

If the attribute specified in this entry is not included in the request, IAS uses the value of the RADIUS User-Name attribute. If it is not present or valid, IAS uses the account specified in the value of Default User Identity, if any. Otherwise, the system uses the guest account for the local computer or the domain.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Tip Image Tip

RADIUS attributes are defined in RFC 2138. To find a list of RADIUS attributes, see RFC 2138, or see Remote access RADIUS Attributes.

Related Entries

Override User-Name

Default User Identity


RSVP

HKLM\SYSTEM\CurrentControlSet\Services\

Description

The RSVP subkey stores configuration information for the Windows 2000 implementation of the Resource Reservation Protocol, commonly known as RSVP.

RSVP is a signaling protocol that establishes a reserved data transmission route with a specified quality of service.


Parameters

HKLM\SYSTEM\CurrentControlSet\Services\RSVP\

Description

The RSVP\Parameters subkey stores configuration information for the Windows 2000 implementation of the Resource Reservation Protocol, commonly known as RSVP.

RSVP is a signaling protocol that establishes a reserved data transmission route with a specified quality of service.


DisableFastStart

HKLM\SYSTEM\CurrentControlSet\Services\RSVP\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Enables and disables the Fast Start feature of RSVP.

Fast Start is designed to minimize the effect of a lost signaling message. Fast Start sends the first few RSVP reservation messages for a session at a faster than normal rate. Typically, path reservation messages are sent every 30 seconds, but Fast Start sends several identical messages before the first refresh interval expires. As a result, if one message is lost, another identical message arrives quickly.

Value | Meaning
0 | Enables Fast Start.
1 | Disables Fast Start.


EnableTracing

HKLM\SYSTEM\CurrentControlSet\Services\RSVP\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Generates a log of messages and API calls.

This entry starts the Rsvptrace tool, which records RSVP messages that are sent and received by the RSVP service provider on a host computer. The log also includes records of API calls between applications and the RSVP service provider. You can use these records to verify that applications are making the required calls to the API, that the RSVP service provider is generating RSVP messages, and that messages are arriving from the network. Rsvptrace is included in Windows 2000.

The Rsvptrace log files are stored in %windir%\System32\Logfiles and are named RsvpTrace<NN>.txt, where <NN> is a number from 00 to 09. Rsvptrace starts a new log when each log is full and, after all ten have been created, it writes over the oldest log file.

Value | Meaning
0 | Disable the Rsvptrace tool.
1 | Enable the Rsvptrace tool.

Activation method

To make changes to this entry effective, use Computer Management to stop and restart the RSVP service.

Note Image Note

You can enables Rsvptrace on an Admission Control Service server to inspect received and transmitted RSVP messages. However, because ACS servers do not run multimedia applications, no API call records appear in the trace.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


Serial

HKLM\SYSTEM\CurrentControlSet\Services\

Description

The Serial subkey stores default settings for all serial ports on the computer. These settings can be overridden for a specific serial ports by settings in the Enum subkey (HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum) for that device.

Note Image Note

In Windows NT 4.0 and earlier, the Serial\Parameters subkey contained Serial# subkeys that stored settings for individual serial ports. In Windows 2000, settings for individual ports are stored in device-specific subkeys of the Enum subkey (HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum). If you have upgraded from Windows NT 4.0 and earlier, Serial# subkeys might still appear in your registry, but they are not fully supported. For more information see Serial# subkeys.

Tip Image Tip

To override the values set in the Serial subkey for any specific device, use Device Manager.

Related Entries

Serial# subkeys


Enum

HKLM\SYSTEM\CurrentControlSet\Services\Serial\

Description

This subkey is added to the registry, but it is not used by Windows 2000.

In Windows NT 4.0 and earlier, this subkey contained subkeys representing specific serial ports on the computer. In Windows 2000, settings for individual ports are stored in device-specific subkeys of Enum subkey (HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum).


ForceFifoEnable

HKLM\SYSTEM\CurrentControlSet\Services\Serial

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether FIFO (first in, first out) buffering is enabled. This entry is effective only when the system includes hardware that supports a FIFO buffer, such as the National Semiconductor 16550AFN.

Value | Meaning
0 | Disables FIFO.
1 | Enables FIFO.

Note Image Note

The value of this entry is used as the default value for all serial ports on the computer. Settings for specific serial ports are stored in the device-specific subkey for that port in the Enum subkey (HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum).

Tip Image Tip

To change this value, you must edit the registry. To change the ForceFifoEnable setting for a specific serial port, use Device Manager.

Caution Image Caution

Not all FIFO buffers are reliable. If the application or the user notices that data is lost or not transmitted, set this value to 0.


LogFifo

HKLM\SYSTEM\CurrentControlSet\Services\Serial

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether the system records an event at startup notifying users that FIFO is enabled on their system. If enabled, the event appears in the System Log in Event Viewer. By default, LogFifo is set to 1 when the system is installed. After the event appears once, the system sets LogFifo to 0 to suppress the event thereafter.

Note Image Note

The value of this entry is used as the default value for all serial ports on the computer. Settings for specific serial ports are stored in the device-specific subkey for that port in the Enum subkey (HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum).

Tip Image Tip

To change this value, you must edit the registry. To change the LogFifo setting for a specific serial port, use Device Manager.


Parameters

HKLM\SYSTEM\CurrentControlSet\Services\Serial\

Description

The Parameters subkey appears in the registry to provide compatibility with Windows NT 4.0 and earlier.

In Windows NT 4.0 and earlier, the Serial\Parameters subkey contained Serial# subkeys that stored settings for individual serial ports. For Windows 2000, settings for individual ports are stored in device-specific subkeys of the Enum subkey (HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum). If you have upgraded from Windows NT 4.0 or earlier, Serial# subkeys might still appear in your registry, but they are not fully supported. For more information, see Serial# subkeys.

Caution Image Caution

Do not edit the Serial# subkeys in Parameters. To configure individual serial ports in Windows 2000, use Device Manager. Device Manager can associate each port with the correct device-specific subkey in Enum and changes its settings accurately.


Serial#

HKLM\SYSTEM\CurrentControlSet\Services\Serial\Parameters\

Description

The Serial# subkeys appears in the registry to provide compatibility with Windows NT 4.0 and earlier.

In Windows 2000, each Serial# subkey stored settings an individual serial ports. The settings in the Serial# subkeys took precedence over default settings for all serial ports in the Serial subkey. For Windows 2000, settings for individual ports are stored in device-specific subkeys of the Enum subkey (HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum).

If you have upgraded from Windows NT 4.0 and earlier, Serial# subkeys might still appear in your registry, but they are not fully supported. When the system starts, it reads the entries in the Serial# subkey, copies them to the device-specific Enum subkey for the port, and then adds the LegacyDiscovered entry to indicate that the entries have been transferred. Thereafter, it ignores the entries in the Serial# subkey.

Caution Image Caution

Do not edit the Serial# subkeys in Parameters. To configure individual serial ports in Windows 2000, use Device Manager. Device Manager can associate each port with the correct device-specific subkey in Enum and changes its settings accurately.

Related Entries

LegacyDiscovered


LegacyDiscovered

HKLM\SYSTEM\CurrentControlSet\Services\Serial\Parameters\Serial#

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

A value of 1 indicates that the system has copied the entries in this Serial# subkey to the port's device-specific subkey in the Enum subkey (HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum). (The system does not set the value of this entry to 0.) After using this entry to mark that it has transferred the data, the system no longer reads this subkey.

Note Image Note

In Windows NT 4.0 and earlier, each Serial# subkey stored settings an individual serial ports. The settings in the Serial# subkeys took precedence over default settings for all serial ports in the Serial subkey. In Windows 2000, settings for individual ports are stored in device-specific subkeys of HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum.

If you have upgraded from Windows NT 4.0 and earlier, Serial# subkeys might still appear in your registry, but after the values they contain are copied to Enum, these subkeys are no longer used.

Related Entries

Serial# subkey


PermitShare

HKLM\SYSTEM\CurrentControlSet\Services\Serial

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether serial ports can be set to the same interrupt request level (IRQ). Some ports do not work properly if two ports have the same IRQ.

Value | Meaning
0 | Each serial port on the computer must have a different IRQ.
1 | Serial ports on the computer can have the same IRQ.

Note Image Note

The value of this entry is used as the default value for all serial ports on the computer. Settings for specific serial ports are stored in the device-specific subkey for that port in the Enum subkey (HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum).

Tip Image Tip

To change this value, you must edit the registry. To change the PermitShare setting for a specific serial port, use Device Manager.


RxFIFO

HKLM\SYSTEM\CurrentControlSet\Services\Serial

Data type | Range | Default value
REG_DWORD | 1 | 4 | 8 | 14 | 8

Description

Determines the number of characters that can accumulated in the receive FIFO buffer of a National Semiconductor 16550-compatible device before it generates an interrupt. The device generates an interrupt when this threshold is reached or when an internal hardware timer expires. The hardware timer prevents characters from being left in the buffer when activity is low.

Increasing the value of this entry can improve the performance of the port. However, if the value is too high, the rate at which characters arrive in the buffer can exceed the rate at which they leave the buffer, resulting in overrun errors.

Note Image Note

The value of this entry is used as the default value for all serial ports on the computer. Settings for specific serial ports are stored in the device-specific subkey for that port in the Enum subkey (HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum).

Tip Image Tip

To change this value, you must edit the registry. To change the RxFIFO setting for a specific serial port, use Device Manager.

Related Entries

TxFIFO


TxFIFO

HKLM\SYSTEM\CurrentControlSet\Services\Serial

Data type | Range | Default value
REG_DWORD | 1 - 16 | 14

Description

Determines how many characters are sent at a time to the transmit FIFO buffer of a National Semiconductor 16550-compatible device.

Note Image Note

The value of this entry is used as the default value for all serial ports on the computer. Settings for specific serial ports are stored in the device-specific subkey for that port in the Enum subkey (HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum).

Tip Image Tip

To change this value, you must edit the registry. To change the TxFIFO setting for a specific serial port, use Device Manager.

Related Entries

RxFIFO


Sermouse

HKLM\SYSTEM\CurrentControlSet\Services\

Description

In Windows NT 4.0 and earlier, the Sermouse subkey contained configuration data for the Microsoft serial mouse driver. In Windows 2000, this data is moved to the device-specific subkeys of the Enum subkey, such as HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\Serenum\...\<Device-name>\Parameters. (The actual path to the subkey varies with the device.)

However, when you upgrade from Windows NT 4.0 and earlier, some of the values in the Sermouse subkey are copied to the device-specific keys. For details, see the descriptions of the Sermouse subkeys and entries.


Parameters

HKLM\SYSTEM\CurrentControlSet\Services\Sermouse\

Description

In Windows NT 4.0 and earlier, the Parameters subkey in the Sermouse subkey contained configuration data for the Microsoft serial mouse driver. In Windows 2000, this data is moved to the device-specific subkeys of the Enum subkey, such as HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\Serenum\...\<Device-name>\Parameters. (The actual path to the subkey varies with the device.)

However, when you upgrade from Windows NT 4.0 and earlier, some of the values in the Sermouse\Parameters subkey are copied to the device-specific keys. For details, see the descriptions of the entries.


MouseDataQueueSize

HKLM\SYSTEM\CurrentControlSet\Services\Sermouse\Parameters

Data type | Range | Default value
REG_DWORD | 0x1 - 0xFFFFFFFF | 0x64 (100)

Description

This entry appears in the registry, but it is not used by the Windows 2000 serial mouse driver. In Windows 2000, the queue size is equal to one packet and is not configurable.


NumberOfButtons

HKLM\SYSTEM\CurrentControlSet\Services\Sermouse\Parameters

Data type | Range | Default value
REG_DWORD | 0x1 - 0xFFFFFFFF | 0x2

Description

In Windows NT 4.0 and earlier, this entry stored the number of buttons on the serial mouse that were detected at startup. In Windows 2000, the number of mouse buttons is stored in the device-specific subkeys of the Enum subkey (HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum) subkey. However, the system still uses the value of this entry as source data.

If you have a serial mouse, and have upgraded from Windows NT 4.0 and earlier, the system copies the value of this entry to the device-specific Enum subkeys of all serial mouse devices and uses the value in those subkeys.

Caution Image Caution

The value of this entry is copied to the device-specific Enum subkeys of all serial mouse devices recognized by the system. If you change the value of this entry, the new value is used for all new serial mouse devices the system recognizes.


PointerDeviceBaseName

HKLM\SYSTEM\CurrentControlSet\Services\Sermouse\Parameters

Data type | Range | Default value
REG_SZ | Base port device name | PointerPort

Description

This entry appears in the registry, but it is not used by the Windows 2000 serial mouse driver.


SampleRate

HKLM\SYSTEM\CurrentControlSet\Services\Sermouse\Parameters

Data type | Range | Default value
REG_DWORD | Mouse sampling rate in Hz | 0x28 (40 Hz)

Description

The system adds this entry to the registry, but it does not use it. The Microsoft Serial Mouse driver does not sample mouse activity.


SNMP

HKLM\SYSTEM\CurrentControlSet\Services\

Description

The SNMP subkey stores configuration data for the SNMP service.

The SNMP service implements Simple Network Management Protocol standards for TCP/IP and IPX networks. This service enables you to manage and monitor servers, workstations, routers, and hubs remotely from a centrally-located computer.


Parameters

HKLM\SYSTEM\CurrentControlSet\Services\SNMP\

Description

The SNMP subkey stores configuration data for the SNMP service.

The SNMP service implements Simple Network Management Protocol standards for TCP/IP and IPX networks. This service enables you to manage and monitor servers, workstations, routers, and hubs remotely from a centrally-located computer.

The SNMP\Parameters subkey contains subkeys that function like traditional registry entries. These subkeys store lists of items identified to the SNMP service. Each item in the list is represented by a numbered entry. The name of the item is the value of the entry.


EnableAuthenticationTraps

HKLM\SYSTEM\CurrentControlSet\Services\SNMP\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Enables and disables authentication traps.

When authentication traps are enabled, SNMP sends a trap when it receives a request that does not match a community name or host filter in its lists.

Value | Meaning
0 | The SNMP service does not send authentication traps.
1 | The SNMP service sends an authentication trap when it receives a request that does not match any community name or host filter in its lists.

Change method

To change the value of this entry, use Computer Management. In the console tree, click Services and Applications, click Services, and then click SNMP Service. From the Action menu, click Properties, click the Security tab, and select or clear the Send authentication trap check box.

Note Image Note

In Windows NT 4.0, this data was stored in the Switch entry in the EnableAuthenticationTraps subkey.


ExtensionAgents

HKLM\SYSTEM\CurrentControlSet\Services\SNMP\Parameters\

Description

The ExtensionAgents subkey contains entries that indicate where in the registry the configuration data for SNMP extension agents is stored.

The names of the entries consist of decimal integers beginning with 0. The value of the entry is the registry path to the data that is loaded by the DLL for the extension agent. All entries in this subkey have the REG_SZ data type.

For example,

0 REG_SZ Software\Microsoft\W3SVC\CurrentVersion

In this example, the configuration data for the WWW service is located in HKEY_LOCAL_MACHINE\Software\Microsoft\W3SVC\CurrentVersion.


PermittedManagers

HKLM\SYSTEM\CurrentControlSet\Services\SNMP\Parameters\

Description

The PermittedManagers subkey stores the names of hosts that are permitted to send requests to an SNMP agent.

The computer names of hosts are stored as entries in this subkey. Each entry represents a host that is a permitted manager. The name of the entry is an ordinal number that reflects the order in which you entered the host when you configured SNMP. The value of the entry is the host name. All entries have the REG_SZ data type.

For example, 1 REG_SZ Host01
In this example, the host, Host01, can send requests to an agent.

Change method

To change the value of this entry use the Services snap-in. Right-click SNMP Service, then click Properties.


TrapConfiguration

HKLM\SYSTEM\CurrentControlSet\Services\SNMP\Parameters\

Description

The TrapConfiguration subkey stores the name of the hosts that receives trap messages for the community. Trap messages are alerts initiated by SNMP agents.

The TrapConfiguration subkey contains a series of subkeys, each of which represents one community. The entries in the community subkey identify the hosts to which the SNMP agent sends traps for that community.

The host names are stored as entries in the community subkey. The names of the host entries are ordinal numbers beginning with 0. The value of the entry can be a host name, an IP address, or an IPX address. All entries in this subkey have the REG_SZ data type.

For example, the SNMP\Parameters\TrapConfiguration subkey contains a Community01 subkey, which represents a valid community. The Community01 subkey contains one or more entries of the following type: 2 REG_SZ 138.10.12.86 In this example, the SNMP agent will send traps for Community01 to the host at the specified IP address.

Change method

To view, add, or delete hosts from a community subkey, use Services in Computer Management.


Public

HKLM\SYSTEM\CurrentControlSet\Services\SNMP\Parameters\TrapConfiguration\

Description

The Public subkey in the TrapConfiguration subkey represents the Public community, the default community for SNMP services. This subkey stores the names of hosts designated to receive trap messages on behalf of all hosts in the Public community. Trap messages are alerts initiated by SNMP agents.

The host names for the Public community are stored as entries in the Public subkey. The names of the host entries are ordinal numbers beginning with 0. The value of the entry can be a host name, an IP address, or an IPX address. All entries in this subkey have the REG_SZ data type.

For example, the SNMP\Parameters\TrapConfiguration\Public subkey contains a contains one or more entries of the following type: 2 REG_SZ 138.10.12.86 In this example, the SNMP agent will send traps for the Public to the host at the specified IP address.

Change method

To view, add, or delete hosts from a community subkey, use Services in Computer Management.


ValidCommunities

HKLM\SYSTEM\CurrentControlSet\Services\SNMP\Parameters\

Description

The ValidCommunities subkey stores a list of the communities defined to the SNMP service.

To SNMP, a community is a group of hosts (servers, workstations, hubs, and routers) that are administered together by SNMP. An SNMP agent accepts requests only from management systems within the communities it recognizes and and only when the requested operation is allowed by the permissions established for the community.

A community name is a network password shared by the hosts in the community.

Each entry in the ValidCommunities subkey represents one community that you identified to SNMP. The entry name is the same as the community name and the value of the entry is bitmask specifying the permissions of the community. All entries have the REG_DWORD data type.

For example,

ROCommunity | REG_DWORD | 0x4
RWCommunity | REG_DWORD | 0x8

constitutes a list of communities as stored in the ValidCommunities subkey.

Change method

To change the value of this entry use the Services snap-in. Right-click SNMP Service, then click Properties.


Tcpip

HKLM\SYSTEM\CurrentControlSet\Services\

Description

The Tcpip subkey stores configuration data for the Microsoft implementation of TCP/IP. TCP/IP is a set of networking protocols that enable communication over diverse interconnected networks.

The Tcpip subkey stores some of the configuration data for TCP/IP (Transmission Control Protocol/Internet Protocol), primarily the settings for the TCP/IP service. Other registry subkeys, such as those for network components and services related to TCP/IP (such as DHCP, NetBT, and Winsock), also store entries that affect the operation of TCP/IP internet protocol implementation on your computer.

Change method

To change the values of many of the entries in the TCPIP subkey and its subkeys, use Network and Dial-up Connections. Right-click Local Area Connection, click Properties, click Internet Protocol (TCP/IP), and then click the Properties button.


Parameters

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\

Description

The Parameters subkey stores configuration data that applies to the TCP/IP service as a whole. This data can be overridden by settings specific to a network component that uses TCP/IP, such as a network adapter driver, or by settings specific to a service that uses TCP/IP, such as DHCP or Winsock. These component-specific entries reside in subkeys representing the component.


Adapters

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\

Description

The Adapters subkey stores TCP/IP configuration data that can be configured differently for each network adapter on the computer.

The Adapters subkey contains one or more subkeys, each of which represents one network adapter and is named by its network identifier. (In this file, these subkeys are represented by a generic variable, <adapter-name>.) The entries in the <adapter-name> subkeys under Adapters apply only to the network adapter represented by the subkey and they override any conflicting settings in the TCPIP\Parameters subkey.


<Adapter-name>

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Adapters\

Description

The <adapter-name> subkeys in your registry represent network adapters or network adapter drivers and bear the network name the adapter. Each subkey represents a particular adapter and stores configuration data that applies only to that adapter.

Most of the entries described in this file as being stored in the <adapter-name> subkey can appear in any of the subkeys in the Adapters subkey.

Some entries can appear in the Tcpip\Parameters subkey and in the <adapter-name> subkeys. If the entry appears in the Parameters subkey, then its value applies to all adapters by default. If the entry appears in an <adapter-name> subkey, then its value applies only to the adapter represented by the subkey and takes precedence over the value in the Parameters subkey when configuring this particular adapter.

Note Image Note

The <adapter-name> subkey is a variable representing the subkeys in the HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Adapters subkey. It does not actually appear in the registry. This subkey entry displays information which is common to the entries in the Adapters subkey.


AllowUnqualifiedQuery

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether the Domain Name Server (DNS) service permits unqualified queries.

Unqualified queries do not include the domain name. They have the form <hostname>. (host name followed by a dot) and are satisfied by any matching host name.

If unqualified queries are not permitted, and a query is submitted that does not include a domain name, then the Domain Name Server (DNS) service automatically appends the name of the local domain.

The following table shows the meaning of each value and the result of submitting the unqualified query: host1. from the reskit.com domain:

Value | Meaning | Sample query result
0 | Do not permit unqualified queries. | host1.reskit.com
1 | Permit unqualified queries. | host1.


AllowUserRawAccess

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Lets users who are not administrators use raw sockets. By default, only users in the Administrators group can use raw sockets.

Value | Meaning
0 | Only administrators can use raw sockets.
1 | All users can use raw sockets.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Tip Image Tip

For information on raw sockets, see the Windows Sockets Specification at ftp://ftp.microsoft.com/bussys/winsock/winsock2.


ArpAlwaysSourceRoute

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | (Not in registry) | 0 | 1 | (Not in registry)

Description

Enables or disables source routing for IP broadcasts.

Some environments require source routing data, but some transparent bridges discard frames with source routing information when passing them to different media types, such as Ethernet. This entry lets you customize the setting of the source routing bit to suit your environment.

Value | Meaning
(Not in registry) | TCP/IP transmits ARP queries without source routing on the first attempt. If it does not receive a reply, it retransmits the query with source routing.
0 | ARP queries (and other IP broadcasts) are never sent with source routing.
1 | ARP queries always are sent with source routing.

Note Image Note

The implementation of this entry changed for Windows NT 4.0 with Service Pack 2. This description pertains only to Windows 2000 and Windows NT 4.0 with Service Pack 2 and later. To interpret the values of this entry for Windows NT 4.0 (previous to Service Pack 2) and earlier, see the Windows NT Resource Kit 4.0.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


ArpCacheLife

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF seconds | 0x78 (120 seconds = 2 minutes)

Description

Determines how long an unreferenced entry can remain in the Address Resolution Protocol (ARP) cache table. Entries cannot remain in the table longer than specified by the value of this entry. However, entries can be removed sooner if the table space they occupy is needed to store a new entry.

By default, ArpCacheLife applies to unreferenced entries. The duration of referenced entries is determined by the value of ArpCacheMinReferencedLife, which is 10 minutes, by default. However, referenced entries must remain in the table at least as long as unreferenced entries. Therefore, if the value of ArpCacheLife is greater than or equal to the value of ArpCacheMinReferencedLife (10 minutes), then the value of ArpCacheLife is used for both referenced and unreferenced entries.

Note Image Note

This value does not affect ARP cache table entries that are added manually. TCP/IP does not remove manual entries.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

ArpCacheMinReferencedLife


ArpCacheMinReferencedLife

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFE seconds | 0xFFFFFFFF | 0x258 (600 seconds = 10 minutes)

Description

Determines how long referenced entries must remain in the Address Resolution Protocol (ARP) cache table before they can be deleted.

By default, the value of ArpCacheLife determines the duration of unreferenced entries (2 minutes by default) and ArpCacheMinReferencedLife determines the duration of referenced entries. However, referenced entries must remain at least as long as unreferenced entries. Therefore, if the value of ArpCacheLife is greater than or equal to the value of ArpCacheMinReferencedLife, then ArpCacheMinReferencedLife is ignored and ArpCacheLife determines how long both referenced and unreferenced entries remain in the table.

Value | Meaning
0x0 - 0xFFFFFFFE seconds | The minimum lifetime of unreferenced ARP cache entries.
0xFFFFFFFF | No minimum lifetime is enforced.

Note Image Note

This value does not affect ARP cache table entries that are added manually. TCP/IP does not remove manual entries.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

ArpCacheLife


ArpRetryCount

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 1 - 3 | 3

Description

Determines how many times TCP sends an Address Request Packet for its own address when the service is installed. (This is known as a gratuitous ARP.) TCP sends a gratuitous ARP to determine whether the IP address it is assigned is already in use on the network.

If another computer replies to the ARP, the local computer's IP address is disabled, an error is written to the System Log in Event Viewer, and an error message is displayed to the current user. Windows 2000 starts, but it cannot operate if it is connected to the network with an address that is not unique. When the computer broadcasts to any address, it will be detected by the computer that originally held the address.

If the computer that had the IP address first is also running Windows 2000, an error message is written to its System Log and an error message is displayed to its current user.


ArpTRSingleRoute

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Sends source-routed (token ring) ARP broadcasts as single-routed broadcasts.

By default, source-routed ARP broadcasts are sent as all-routes broadcasts.

Value | Meaning
0 | Source-routed (token ring) ARP broadcasts are sent as all-routes broadcasts.
1 | Source-routed (token ring) ARP broadcasts are sent as single-route broadcasts.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


ArpUseEtherSNAP

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether TCP/IP transmits Ethernet packets by using DIX Ethernet format or 802.3 SNAP encoding. It can receive packets in either format.

Value | Meaning
0 | TCP/IP transmits packets in DIX Ethernet format.
1 | TCP/IP transmits Ethernet packets by using 802.3 SNAP encoding.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


DatabasePath

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_EXPAND_SZ | %SystemRoot%\System32\drivers\etc

Description

Specifies the path to the standard Internet database files, such as Hosts.sam, Lmhosts.sam, Services.sam, Networks, Protocol, and Quotes. This entry is used by the Windows Sockets interface.


DefaultRegistrationTTL

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF seconds | Default: 0x4B0 (1200 seconds = 20 minutes)

Description

Specifies the default Time To Live (TTL) value set in the header of outgoing DNS dynamic update registrations. The TTL determines how long a packet that has not reached its destination can remain on the network before it is discarded.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Tip Image Tip

To find other registry entries related to DNS dynamic update, type "dynamic update" on the Search tab in this file.

Related Entries

EnableAdapterDomainNameRegistration

DisableDynamicUpdate

DisableReplaceAddressesInConflicts

DisableReverseAddressRegistrations

UpdateSecurityLevel


DefaultTTL

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 1 - 255 seconds | 128

Description

Specifies the default Time To Live (TTL) value set in the header of outgoing IP packets. The TTL determines how long an IP packet that has not reached its destination can remain on the network before it is discarded.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


DhcpDomain

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_SZ | Domain name | (None. Provided by DHCP)

Description

This entry appears in the registry, but it is not used by Windows 2000.


DhcpNameServer

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_SZ | IPAddress[ IPAddress...] (A-space delimited list of dotted decimal IP addresses.) | (There is no default value for this entry. It is configured by the DHCP client.)

Description

This entry appears in the registry, but it is not used by Windows 2000.

Caution Image Caution

This entry is used internally by the by the DHCP client service when the service is enabled. Do not delete this entry or change its value. It is described for reference only.


DisableDHCPMediaSense

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Directs the DHCP client to ignore Media Sense events from the interface.

Media Sense provides a mechanism for network adapters to notify the protocol stack of when network media is connected and disconnected. The protocol stack can then update its network configuration parameters. Media Sense is especially useful on portable computers which are commonly disconnected from one network and connected to a different network.

Media sense events direct the DHCP client to take an action, such as attempting to obtain a lease when a media is connected, or invalidating the interface and routes when media is disconnected.

Value | Meaning
0 | Enables media sense on the DHCP client.
1 | Disables media sense on the DHCP client.

Note Image Note

Because 10b2 or coaxial (RG-58) Ethernet cable is not a connection-based media, media sense does not detect connection and disconnection events on this type of network cable.

NetBEUI and IPX do not recognize media sense events.

Related Entries

DisableMediaSenseEventLog


DisableDynamicUpdate

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Disables DNS dynamic update registration for all interfaces on this system.

With dynamic update, DNS client computers automatically register and update their resource records whenever address changes occur.

Value | Meaning
0 | Enables dynamic update registration.
1 | Disables dynamic update registration.

Note Image Note

For dynamic update to operate on any interface, it must be enabled at the system level and at the interface level. Thus, to disable DNS dynamic update for a particular interface, add DisableDynamicUpdate to an <Interface-name> subkey and set its value to 1. To disable dynamic update on all interfaces of a system, add DisableDynamicUpdate to the Tcpip\Parameters subkey and set its value to 1.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Tip Image Tip

To find other registry entries related to DNS dynamic update, type "dynamic update" on the Search tab in this file.

Related Entries

DisableDynamicUpdate (<Interface-name> subkey)


DisableIPSourceRouting

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Disables IP source routing.

IP source routing lets the sender designate the IP route that a datagram takes through the network.

Value | Meaning
0 | Enables IP source routing.
1 | Disables IP source routing.


DisableMediaSenseEventLog

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Disables logging of DHCP Media Sense events.

By default, DHCP records an event in the System Log in Event Viewer when network media is connected or disconnected. The log provides a record that can be used when troubleshooting network problems.

Media Sense provides a mechanism for network adapters to notify the protocol stack of when network media is connected and disconnected. The protocol stack can then update its network configuration parameters. Media Sense is especially useful on portable computers which are commonly disconnected from one network and connected to a different network.

Value | Meaning
0 | Enables logging of media sense events.
1 | Disables logging of media sense events.

Note Image Note

Because 10b2 or coaxial (RG-58) Ethernet cable is not a connection-based media, media sense does not detect connection and disconnection events on this type of network cable.

NetBEUI and IPX do not recognize media sense events.

Related Entries

DisableDHCPMediaSense


DisableReplaceAddressesInConflicts

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Prevents the DNS client from overwriting an existing resource record when it discovers an address conflict during dynamic update.

An address conflict occurs when the DNS client discovers that an existing A record associates its DNS name with the IP address of a different computer.

By default, the DNS client tries to replace the original registration with a record associating the DNS name to its own IP address. However, you can use this entry to direct DNS back out of the registration process and to record an error in the Event Viewer log instead.

This entry is designed for zones that do not use secure dynamic update. It prevents unauthorized users from changing the IP address registration of a client computer.

Value | Meaning
0 | The DNS client overwrites the existing A record with an A record for its own IP address.
1 | The DNS client backs out of the registration process and writes an error to the Event Viewer log.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Tip Image Tip

To find other registry entries related to DNS dynamic update, type "dynamic update" on the Search tab in this file.

Related Entries

DefaultRegistrationTTL

EnableAdapterDomainNameRegistration

DisableDynamicUpdate

DisableReverseAddressRegistrations

UpdateSecurityLevel


DisableTaskOffload

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Disables offloading of processor tasks to the network adapter. Offloading is designed to optimize performance of Windows 2000.

NDIS 5.0 lets TCP take full advantage of intelligence in network adapters by letting the adapter do some of the tasks normally performed by the processor. Letting the processor offload these tasks to the network adapter leaves the processor free for tasks that only it can perform.

TCP in Windows 2000 supports offloading of IPSec encryption to network adapters with encryption hardware, and offloading of TCP checksum calculations on headers and data to capable network adapters.

Value | Meaning
0 | Enables offloading.
1 | Disables offloading.

Caution Image Caution

Task offloading significantly improves system performance. Do not disable offloading unless you must do so for testing or troubleshooting.


Domain

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_SZ | DNS suffix | (The local primary DNS suffix)

Description

Specifies the primary Domain Name System (DNS) suffix for the computers. The primary DNS suffix is used in DNS name registration and DNS name resolution.

This entry stores the value typed in the Primary DNS suffix of this computer box on the DNS Suffix and NetBIOS Computer Name dialog box in System in Control Panel after you restart the system. Before the system is restarted, the value in the Primary DNS suffix of this computer box is stored in the value of the NV Domain entry.

By default, the value of this entry is set to the DNS name of Active Directory domain to which the computer is joined.

Change method

To change the value of this entry, click System in Control Panel, click the Network Identification tab, click Properties, click More, and then enter a suffix in the Primary DNS suffix of this computer box. The user setting is stored in the value of NV Domain and it is copied to Domain when you restart Windows 2000.

Note Image Note

This entry can be superceded by a policy included in Windows 2000. While the Primary DNS Suffix Group Policy is enabled, the system ignores this entry. The Primary DNS Suffix policy setting is stored in the value of NV PrimaryDnsSuffix and PrimaryDnsSuffix.

The Primary DNS Suffix Group Policy does not disable or change the appearance of the Primary DNS suffix of this computer dialog box, but the system does not read the value entered in that box and stored in this entry. The system reads this entry when the Primary DNS Suffix Group Policy is disabled or not configured, that is, when the PrimaryDnsSuffix entry does not appear in the registry.

Tip Image Tip

For information about Group Policies, see the Group Policy Reference, Gp.chm, on the Windows 2000 Resource Kit CD.

Related Entries

NV Domain

PrimaryDnsSuffix

NV PrimaryDnsSuffix


EnableAddrMaskReply

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether this computer responds to ICMP address mask requests by sending ICMP address mask replies.

Internet Control Message Protocol (ICMP) is an error reporting and diagnostic utility in IP. Routers, intermediary devices, and hosts use ICMP messages to communicate with each other.

An address mask request (ICMP Type 17) is an ICMP message that a networked computer issues to determine the subnet mask on the local network. RFC 1122 restricts the computers that can reply to address mask request to authoritative agents (hosts or gateways) that are explicitly configured to respond to address masks.

If your computer responds to address mask requests, it might enable malicious users to discover sections of your network topology.

Value | Meaning
0 | Disabled. This system does not reply to address mask requests.
1 | Enabled. This system responds to address mask requests by sending address mask replies (ICMP Type 18).

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


EnableBcastArpReply

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Directs TCP to respond to an Address Resolution Protocol (ARP) request even when the source Ethernet address in the ARP request is not unicast. Otherwise, it responds only when the Ethernet address is unicast.

Value | Meaning
0 | Respond even when the Ethernet address in an ARP request is not unicast.
1 | Respond only the Ethernet address in an ARP request is unicast.

Caution Image Caution

Do not set the value of this entry to 0 if you are using Network Load Balancing. Network Load Balancing does not operate properly when non-unicast addresses are permitted.


EnableDeadGWDetect

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether TCP performs dead gateway detection. Dead gateway detection is a TCP feature that identifies gateways that are not operating properly and switches the computer to a new default gateway.

When enabled, any given connections defines a gateway as non-operational ("dead") when a packet sent to the gateway must be retransmitted more than half of the number of times specified in the value of TcpMaxDataRetransmissions. The connection switches to the next gateway in the list in DefaultGateway or DhcpDefaultGateway. The system defines a gateway as dead when more than 25% of its connections have switched to the next default gateway in the list.

Value | Meaning
0 | Disables dead gateway detection.
1 | Enables dead gateway detection.

Change method

To define backup gateways, use Network and Dial-up Connections. Right-click Local Area Connection, click Properties, click Internet Protocol (TCP/IP), and then click the Properties button. In the bottom, right corner of the General tab, click the Advanced button, click the IP Settings tab, and then, in the Default gateways, in order of use section, click Add.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


EnableFastRouteLookup

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether the fast route lookup feature is enabled. Fast route lookups make route searches faster, but use a significant amount ofnon-pageable memory.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

This entry is used only on Windows 2000 Server computers which have at least 64 MB of physical memory.

This entry is used only when Routing and Remote Access Service (RRAS) is enabled on this system.


EnableMulticastForwarding

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether this computer forwards IP multicasts.

Multicasting enables hosts to send a datagram to multiple recipients in a single operation. To receive multicasts, the recipients join a host group which has a single IP destination address.

IP multicasts are forwarded across networks by multicast routers that reside with, or are separate from, Internet gateways. The originating host transmits the IP multicast datagram as a local network multicast to all immediately-neighboring members of the destination host group. Then, multicast routers on the local network forward the datagram to all other networks.

Value | Meaning
0 | Disabled. This computer does not forward IP multicasts.
1 | Enabled. This computer forwards IP multicasts.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

This entry is used only when Routing and Remote Access Service (RRAS) is enabled on this system.


EnablePMTUBHDetect

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether the TCP tries to detect black hole routers during the Path MTU (maximum transmission unit) discovery process. Enabling black hole detection increases the maximum number of times TCP retransmits a given segment.

If the value of this entry is 1, TCP recognizes when it has transmitted the same segment several times without receiving an acknowledgement. TCP reduces the maximum segment size (MSS) to 536 bytes and sets the Don't-Fragment bit. If, as a result, receipt of the segment is acknowledged, TCP continues the practice in all subsequent transmissions on the connection.

Value | Meaning
0 | Disables black hole detection.
1 | Enables black hole detection.

Note Image Note

This entry is used only when the Path MTU discovery process is performed, that is, when the value of EnablePMTUDiscovery is 1.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

EnablePMTUDiscovery


EnablePMTUDiscovery

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether TCP uses a fixed, default maximum transmission unit (MTU) or attempts to detect the actual MTU.

By discovering the Path MTU and limiting TCP segments to this size, TCP can eliminate fragmentation at routers along the path that connects networks with different MTUs. Fragmentation reduces TCP throughput and increases network congestion.

By default, this value applies to all interfaces. However, the MTU can be reduced for any particular interface by changing the default value of MTU in the subkey for that interface.

Value | Meaning
0 | TCP uses an MTU of 576 bytes for all connections to computers outside the local subnet.
1 | TCP attempts to discover the MTU of the path to a remote host.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

EnablePMTUBHDetect

MTU


EnableSecurityFilters

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether TCP/IP filters datagrams and TCP sync characters (SYNs).

If the value of this entry is 1, TCP/IP filters all incoming UDP datagrams, raw IP datagrams, and TCP SYNs. You can customize the filtering for each interface by using the UdpAllowedPorts, TcpAllowedPorts, and RawIpAllowedProtocols entries.

This entry does not affect packets that are not filtered by IP, such as packets routed through IP to other computers, and incoming packets that are filtered in the transports before being delivered to the local computer.

Change method

To change the value of this entry, use Network and Dial-up Connections. Right-click Local Area Connection, click Properties, click Internet Protocol (TCP/IP), and click the Properties button. In the bottom, right corner of the Internet Protocol (TCP/IP) Properties page, click the Advanced button, click the Options tab, click TCP/IP filtering, and then click Properties. This entry is associated with the Enable TCP/IP Filtering (All adapters) check box..

Related Entries

UdpAllowedPorts

TcpAllowedPorts

RawIpAllowedProtocols


FFPControlFlags

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Enables and disables Fast Forwarding Path for Offload (FFP) on this system.

Value | Meaning
0 | FFP is disabled. TCP/IP instructs FFP-capable adapters not to fast forward datagrams.
1 | FFP is enabled. TCP/IP provides for fast forwarding (FFP) on this system.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

This entry is used only when Routing and Remote Access Service (RRAS) is enabled on this system.

Related Entries

FFPFastForwardingCacheSize


FFPFastForwardingCacheSize

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF bytes | 0x19000 (102,400)

Description

Specifies the maximum amount of system memory that a device driver is permitted to allocate to its fast forwarding cache. The fast forwarding cache is a section of reserved memory used to support TCP/IP fast forwarding.

This entry is used only when fast forwarding is enabled (that is, the value of FFPControlFlags is 1) and the driver uses system memory for its cache. This value does not apply when the driver uses memory on the device for its cache.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

FFPControlFlags


ForwardBroadcasts

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 0

Description

Windows 2000 does not forward broadcasts. This entry appears in the registry, but it is not used by Windows 2000.


ForwardBufferMemory

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF bytes (must be a multiple of 256) | 0x12200 (74,240 bytes; enough for fifty 1480-byte packets, rounded to a multiple of 256)

Description

Determines the size of the buffer IP allocates to store packet data in the router packet queue. Because packet queue data buffers are 256 bytes long, the value of this entry must be a multiple of 256.

When this buffer space is filled, the router begins discarding packets at random from its queue. If packets are too large for the buffer, multiple buffers are chained together. If no buffers are allocated or if the IP router is not enabled, this entry is ignored.

Because packet headers are stored separately, buffer size is not affected by the IP header for a packet.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

MaxForwardBufferMemory

NumForwardPackets


GlobalMaxTcpWindowSize

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0x3FFFFFFF bytes | (See description.)

Description

Determines the largest TCP receive window offered by the system. The receive window is the number of bytes a sender can transmit without receiving an acknowledgment. This entry override's TCP's negotiated maximum receive window size and replaces it with the value of this entry.

TCP uses a receive window that is four times the size of the maximum TCP segment size (MSS) negotiated during connection setup, up to a maximum size of 64 KB. TCP for Windows 2000 also supports windows scaling, as detailed in RFC 1323. Scaling enables TCP to provide a receive window of up to 1 GB.

For Ethernet networks, the default value of this entry is 0x4470 (17,520 or twelve 1460-byte segments.). For other networks, the default value is 0xFFFF (65535), unless 0xFFFF is larger than:

  • Four times the maximum TCP data size on the network;

    • and

  • 0x2000 (8192) rounded up to an even multiple of the network TCP data size.

Note Image Note

This entry determines the default maximum receive window size for all interfaces. When configuring any particular interface, the value of TcpWindowSize for the interface takes precedence over the value of this entry.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

TcpWindowSize


Hostname

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_SZ | DNS host name | (Name of the local computer.)

Description

Specifies the host name portion of the DNS name of the computer. The host name is the first label in the computer's DNS name.

Change method

To change the value of this entry, right-click My Computer, click Properties. click the Network Identification tab, and then click the Properties button. The host name appears in the Computer name field of the Identification Changes dialog box.


IGMPLevel

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 2 | 2

Description

Determines the extent to which the system supports IP multicasting and participates in the Internet Group Management Protocol.

Value | Meaning
0 | No multicast support.
1 | Send IP multicast packets only.
2 | Send and receive IP multicast packets (participate in IGMP).

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


Interfaces

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\

Description

The Interfaces subkey stores configuration data specific to a TCP/IP communications interface.

The Interfaces subkey stores TCP/IP configuration data that can be configured differently for each interface used by the system. The Interfaces subkey contains one or more subkeys, each of which represents one interface. In this file, the subkey representing interfaces are represented by a generic variable subkey, <interface-name>. The entries in the <interface-name> subkeys under Interfaces apply only to the interface represented by the subkey and they override any conflicting settings in the TCPIP\Parameters subkey.


<interface-name>

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\

Description

The <interface-name> subkeys in your registry represent TCP\IP communication interfaces and are named by the network name for the interface. Each subkey represents a particular interface and stores configuration data that applies only to that interface.

Most of the entries described in this file as being stored in the <interface-name> subkey can appear in any of the subkeys in the Interfaces subkey.

Some entries can appear in the Tcpip\Parameters subkey and/or in one or more <interface-name> subkeys. If the entry appears in the Parameters subkey, then it applies to all interfaces by default. If the entry appears in an <interfaces-name> subkey, then it applies only to the interfaces represented by the subkey and takes precedence of the value in the Parameters subkey when configuring this particular interface.

Note Image Note

The <interface-name> subkey is a variable representing the subkeys in the Tcpip\Parameters\Interfaces subkey. It doesn't actually appear in the registry. This variable subkey displays the entries and subkeys that are common to many of the subkeys in the Interfaces subkey.


DefaultGateway

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<interface-name>

Data type | Range | Default value
REG_MULTI_SZ | IPAddress[ IPAddress...] (A-space delimited list of dotted decimal IP addresses.) | (Blank value.)

Description

An ordered list of gateways that can be used as the default gateway for this system. Packets are sent to the default gateway when they are destined for a subnet to which this computer is not connected, or for there is no specific route.

At any time, only one gateway is the default gateway. The other gateways are used, in the order specified, when the system detects that the current default gateway is not operational (See EnableDeadGWDetect and TcpMaxDataRetransmissions).

If this entry contains a valid value, it overrides the value of DhcpDefaultGateway, which is configured by DHCP.

Change method

To change the value of this entry, use Network and Dial-up Connections. Right-click Local Area Connection, click Properties, click Internet Protocol (TCP/IP), and click the Properties button. In the lower right corner, click the Advanced button, click the IP Settings tab, and use the Default gateways, in order of use section to change this value.

Related Entries

EnableDeadGWDetect

TcpMaxDataRetransmissions

DhcpDefaultGateway


DhcpDefaultGateway

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<interface-name>

Data type | Range | Default value
REG_MULTI_SZ | IPAddress[ IPAddress...] (A-space delimited list of dotted decimal IP addresses.) | (There is no default value for this entry. The value is configured by DHCP.)

Description

An ordered list of gateways that can be used as the default gateway for this system. This list is configured by DHCP. Packets are sent to the default gateway when they are destined for a subnet to which this computer is not connected, or for which there is no specific.

At any time, only one gateway is the default gateway. The other gateways are used, in the order specified, when the system detects that the current default gateway is not operational (See EnableDeadGWDetect and TcpMaxDataRetransmissions).

This DHCP-configured entry is overridden by DefaultGateway, which is configured by the user, when that entry contains a valid value. (It is blank by default.)

Tip Image Tip

This entry is associated with a DHCP option. Configuration data for DHCP options is stored in each HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Dhcp\Parameters\Options\ <Option#> subkey. The path to this entry is stored in the value of RegLocation in the associated <Option#> subkey.

To find the DHCP option associated with this entry, use Regedit.exe. From the Edit menu, click Find, and enter the following text: SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\?\DhcpDefaultGateway and select only the Data checkbox.

Caution Image Caution

The DHCP client service adds this entry to the registry when the service is enabled. It is maintained for internal use by the DHCP client service. Do not delete this entry or change its value.


DhcpDomain

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<interface-name>

Data type | Range | Default value
REG_SZ | Domain name | (There is no default value for this entry. The value is configured by DHCP.)

Description

Specifies the Domain Name System (DNS) domain name of the interface, as provided by DHCP.

The DNS domain name is determined by three entries, DhcpDomain, which is configured by DHCP, and by Domain, which you can configure.

If these entries contain valid values, the user-configured value, Domain, takes precedence over the value of DhcpDomain.

Note Image Note

The DHCP client service adds this entry to the registry when the service is enabled. Do not change the value of this entry.

Tip Image Tip

This entry is associated with a DHCP option. Configuration data for DHCP options is stored in each HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Dhcp\Parameters\Options\ <Option#> subkey. The path to this entry is stored in the value of RegLocation in the associated <Option#> subkey.

To find the DHCP option associated with this entry, use Regedit.exe. From the Edit menu, click Find, and enter the following text: SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\?\DhcpDomain and select only the Data checkbox.

Related Entries

Domain


DhcpIPAddress

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<interface-name>

Data type | Range | Default value
REG_SZ | IPAddress[ IPAddress...] (A-space delimited list of dotted decimal IP addresses.) | (There is no default value for this entry. The value is configured by DHCP.)

Description

Specifies the IP addresses of the interface, as configured by DHCP.

The IP address of the interface is managed by two entries, DhcpIPAddress, which is configured by DHCP, and IPAddress, which you can configure. If the value of IPAddress contains one or more valid values (to replace 0.0.0.0), it overrides the value of DhcpIPAddress.

Caution Image Caution

The DHCP client service adds this entry to the registry when the service is enabled. It is maintained for internal use by the DHCP client service. Do not delete this entry or change its value.

Related Entries

IPAddress


DhcpNameServer

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<interface-name>

Data type | Range | Default value
REG_SZ | IPAddress[ IPAddress...] (A-space delimited list of dotted decimal IP addresses.) | (There is no default value for this entry. The value is configured by DHCP.)

Description

Stores a list of DNS servers to which Windows Sockets sends queries when it resolves names for the interface. The value of this entry is configured for the interface by DHCP, but can overridden by a different valid value configured by the user.

The interface-specific DNS name server for the system is determined by the values of DhcpNameServer, which is configured by DHCP, and by NameServer, which you can configure.

If all entries contain valid values, the user-configured values take precedence over the DHCP-configured values configuring the affected interface.

Note Image Note

The DHCP client service adds this entry to the registry when the service is enabled. Do not change the value of this entry.

Tip Image Tip

This entry is associated with a DHCP option. Configuration data for DHCP options is stored in each HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Dhcp\Parameters\Options\ <Option#> subkey. The path to this entry is stored in the value of RegLocation in the associated <Option#> subkey.

To find the DHCP option associated with this entry, use Regedit.exe. From the Edit menu, click Find, and enter the following text: SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\?\DhcpNameServer and select only the Data checkbox.

Caution Image Caution

The DHCP client service adds this entry to the registry when the service is enabled. It is maintained for internal use by the DHCP client service. Do not delete this entry or change its value.

Related Entries

NameServer (Interfaces subkeys)


DhcpServer

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<interface-name>

Data type | Range | Default value
REG_SZ | IPAddress[ IPAddress...] (A-space delimited list of dotted decimal IP addresses.) | (There is no default value for this entry. The value is configured by DHCP.)

Description

Stores the IP address of the DHCP server that granted the lease to the IP address stored in the value of DhcpIPAddress.

Note Image Note

The DHCP client service adds this entry to the registry when the service is enabled. Do not change the value of this entry.

Caution Image Caution

The DHCP client service adds this entry to the registry when the service is enabled. It is maintained for internal use by the DHCP client service. Do not delete this entry or change its value.


DhcpSubnetMask

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<interface-name>

Data type | Range | Default value
REG_SZ | (A space-delimited list of dotted decimal subnet masks.) | (There is no default value for this entry. The value is configured by DHCP.)

Description

Specifies the subnet mask for the IP address specified in the value of IPAddress or DhcpIPAddress. This entry, which can be changed by the user, overrides the DHCP-configured values for the subnet mask.

The subnet mask is determined by two entries, DhcpSubnetMask, which is configured by DHCP, and SubnetMask, which you can configure. If the value of SubnetMask is not 0.0.0.0, then it overrides the value of DhcpSubnetMask.

Caution Image Caution

The DHCP client service adds this entry to the registry when the service is enabled. It is maintained for internal use by the DHCP client service. Do not delete this entry or change its value.

Related Entries

DhcpIPAddress

IPAddress

SubnetMask


DhcpSubnetMaskOpt

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<interface-name>

Data type | Range | Default value
REG_MULTI_SZ | (A space-delimited list of dotted decimal subnet masks.) | (There is no default value for this entry. The value is configured by DHCP.)

Description

Specifies the subnet mask associated with a DHCP option.

The subnet mask stored in the value of this entry is not used for routing. DHCP just uses this entry to test and build the actual subnet mask which is stored in the value of DhcpSubnetMask.

Tip Image Tip

This entry is associated with a DHCP option. Configuration data for DHCP options is stored in each HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Dhcp\Parameters\Options\ <Option#> subkey. The path to this entry is stored in the value of RegLocation in the associated <Option#> subkey.

To find the DHCP option associated with this entry, use Regedit.exe. From the Edit menu, click Find, and enter the following text: SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\?\DhcpSubnetMaskOpt and select only the Data checkbox.

Caution Image Caution

The DHCP client service adds this entry to the registry when the service is enabled. It is maintained for internal use by the DHCP client service. Do not delete this entry or change its value.

Related Entries

DhcpSubnetMask


DisableDynamicUpdate

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<interface-name>

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Disables DNS dynamic update registration on this interface.

With dynamic update, DNS client computers automatically register and update their resource records whenever address changes occur.

Value | Meaning
0 | Enables dynamic update registration.
1 | Disables dynamic update registration.

Note Image Note

For dynamic update to operate on any interface, it must be enabled at the system level and at the interface level. Thus, to disable DNS dynamic update for a particular interface, add DisableDynamicUpdate to an <Interface-name> subkey and set its value to 1. To disable dynamic update on all interfaces of a system, add DisableDynamicUpdate to the Tcpip\Parameters subkey and set its value to 1.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Tip Image Tip

To find other registry entries related to DNS dynamic update, type "dynamic update" on the Search tab in this file.

Related Entries

DisableDynamicUpdate (Tcpip\Parameters subkey)

DefaultRegistrationTTL

EnableAdapterDomainNameRegistration

DisableReplaceAddressesInConflicts

DisableReverseAddressRegistrations

UpdateSecurityLevel


DisableReverseAddressRegistrations

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<interface-name>

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Disables DNS dynamic update registration of PTR records by this DNS client. PTR ("pointer") records associate an IP address with a computer name.

This entry is designed for enterprises in which the primary DNS server that is authoritative for the reverse lookup zone cannot or is configured not to perform dynamic updates. It reduces unnecessary network traffic and eliminates event log errors that record failed attempts to register PTR records.

Value | Meaning
0 | Register PTR records.
1 | Do not register PTR records.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Tip Image Tip

To find other registry entries related to DNS dynamic update, type "dynamic update" on the Search tab in this file.

Related Entries

DefaultRegistrationTTL

EnableAdapterDomainNameRegistration

DisableDynamicUpdate

DisableReplaceAddressesInConflicts

UpdateSecurityLevel


Domain

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<interface-name>

Data type | Range | Default value
REG_SZ | (Any valid DNS domain name) | (Blank value. You must enter a valid value when you use Network in Control Panel to configure the interface.)

Description

Specifies the Domain Name System (DNS) domain name of the interface, as provided by DHCP.

The interface-specific DNS domain name is determined by the value of DhcpDomain, which is configured by DHCP, and Domain, which you can configure.

If these entries contain valid values, the user-configured value, Domain, takes precedence over the value of DhcpDomain.

Change method

To change the value of this entry, use Network and Dial-up Connections. Right-click Local Area Connection, click Properties, click Internet Protocol (TCP/IP), and then click Properties. At the bottom right corner of the page, click the Advanced button, click the DNS tab, and then type the value in the DNS domain name text box.

Related Entries

DhcpDomain


DontAddDefaultGateway

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<interface-name>

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Disables the default LAN adapter route that is installed when you install PPTP. If you disable the default route, you might need to configure static routes for hosts that are reached using a router other than the default gateway.

Value | Meaning
0 | The system installs default routes for each LAN adapter.
1 | Default routes are not installed.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits it. PPTP users must add this entry for each interface that is not connected to the Internet.


EnableAdapterDomainNameRegistration

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<interface-name>

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Enables DNS dynamic update registration of the domain name of the network adapter for this interface. By default, this registration is not updated dynamically.

This entry is designed for systems where you must register the network adapter IP address(es) under the network adapter's domain name.

If the value of this entry is 1, but dynamic update is disabled on this interface (that is, the value of DisableDynamicUpdate for this interface is 1), this adapter's address(es) are registered under the adapter's domain name and under the system's primary domain name.

Value | Meaning
0 | Disables dynamic update of this network adapter's domain name.
1 | Disables dynamic update of this network adapter's domain name.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Tip Image Tip

To find other registry entries related to DNS dynamic update, type "dynamic update" on the Search tab in this file.

Related Entries

DisableDynamicUpdate

DefaultRegistrationTTL

DisableDynamicUpdate

DisableReplaceAddressesInConflicts

DisableReverseAddressRegistrations

UpdateSecurityLevel


EnableDHCP

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<interface-name>

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether the Dynamic Host Configuration Protocol service (DHCP) is enabled. If the value of this entry is 1, the DHCP client service is used to configure this interfaces.

Value | Meaning
0 | Disables DHCP for this interface.
1 | Enables DHCP for this interface.

Change method

To change the value of this entry, use Network and Dial-up Connections. Right-click Local Area Connection, click Properties, and click Internet Protocol (TCP/IP). This entry is associated with the Obtain an IP address automatically option.

Note Image Note

This entry is added to the registry when you use Network Connections in Control Panel to configure TCP/IP.

When DHCP is enabled, the phrase DHCP Enabled appears in the IP addresses box in place of a static IP address. To view this setting, double-click Network Connections in Control Panel, right-click Local Area Connection, click Properties, click Internet Protocol (TCP/IP), click the Advanced button, and then click the IP Settings tab.


IPAddress

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<interface-name>

Data type | Range | Default value
REG_SZ | IPAddress[ IPAddress...] (A-space delimited list of dotted decimal IP addresses.) | 0.0.0.0

Description

Specifies the IP addresses of the interface. You can enter a value in this entry to override the DHCP-configured IP address.

The IP address of the interface is managed by two entries, DhcpIPAddress, which is configured by DHCP, and IPAddress, which you can configure. If the value of IPAddress contains one or more valid values (to replace 0.0.0.0), it overrides the value of DhcpIPAddress.

Change method

To change the value of this entry, use Network and Dial-up Connections. Right-click Local Area Connection, click Properties, click Internet Protocol (TCP/IP), click the Use the following IP address option and then enter the IP address and supporting data in the associated text boxes.

Note Image Note

For each IP address listed in the value of this entry, there must be a valid subnet mask in the value of SubnetMask for the interface.

This entry is added to the registry when you use Network Connections in Control Panel to configure TCP/IP.

Related Entries

DhcpIPAddress


IPAutoconfigurationAddress

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<interface-name>

Data type | Range | Default value
REG_SZ | IP address, in dotted decimal format | 0.0.0.0

Description

Stores the IP address assigned to this interface by the IP autoconfiguration feature.

Autoconfiguration allows TCP/IP to configure an interface even when it cannot locate a DHCP server. If an attempt to locate a DCHP server fails, TCP/IP configures the interface by using IP addresses from the Microsoft reserved Class B network (169.254.0.0), subnet mask 255.255.0.0. During autoconfiguration, TCP/IP continues its attempts to locate a DHCP server and abandons the autoconfiguration process if one is located.

Note Image Note

This entry is used only when IP autoconfiguration is enabled, that is, the value of IPAutoconfigurationEnabled is 1.

Caution Image Caution

Do not change the value of this entry. If you do, the IP address assigned to the interface might not be reliable.


IPAutoconfigurationEnabled

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<interface-name>

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether the IP autoconfiguration feature is enabled for this interface.

Autoconfiguration allows TCP/IP to configure an interface even when it cannot locate a DHCP server. If an attempt to locate a DCHP server fails, TCP/IP configures the interface by using IP addresses from the Microsoft reserved Class B network (169.254.0.0), subnet mask 255.255.0.0. During autoconfiguration, TCP/IP continues its attempts to locate a DHCP server and abandons the autoconfiguration process if one is located.

IPAutoconfigurationEnabled also appears in the Tcpip\Parameters subkey and its value applies, by default, to all interfaces. However, if this entry appears in any Interfaces subkey, its value overrides the value in the Tcpip\Parameters subkey when configuring the interface.

Caution Image Caution

Do not change the value of this entry. If you do, the IP address assigned to the interface might not be reliable.


IPAutoconfigurationMask

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<interface-name>

Data type | Range | Default value
REG_SZ | Subnet mask (dotted decimal format) | 255.0.0.0

Description

Stores the subnet mask assigned to the client by the IP autoconfiguration feature.

Autoconfiguration allows TCP/IP to configure an interface even when it cannot locate a DHCP server. If an attempt to locate a DCHP server fails, TCP/IP configures the interface by using an IP address from the Microsoft reserved Class B network (169.254.0.0), subnet mask 255.255.0.0. During autoconfiguration, TCP/IP continues its attempts to locate a DHCP server and abandons the autoconfiguration process if one is located.

IPAutoconfigurationMask also appears in the Tcpip\Parameters subkeys. The value of the entry in the Tcpip\Parameters subkey applies, by default, to all interfaces. However, if this entry appears in any Interfaces\<interface-name> subkey, its value overrides the value in the Tcpip\Parameters subkey when configuring that interface.

Note Image Note

This entry is used only when IP autoconfiguration is enabled, that is, the value of IPAutoconfigurationEnabled is 1.

Caution Image Caution

Do not change the value of this entry. If you do, the IP address assigned to the interface might not be reliable.

Related Entries

IPAutoconfigurationMask

IPAutoconfigurationEnabled


IPAutoconfigurationSeed

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<interface-name>

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFF | 0

Description

The DHCP client manages this entry for its internal use. Do not change the value of this entry.

Caution Image Caution

Do not change the value of this entry under any circumstances. If you do, your computer will not operate properly.


IPAutoconfigurationSubnet

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<interface-name>

Data type | Range | Default value
REG_DWORD | Subnet address, in dotted decimal format | 169.254.0.0

Description

Determines the subnet address used by the IP autoconfiguration feature to assign an IP address to an interface.

Autoconfiguration allows TCP/IP to configure an interface even when it cannot locate a DHCP server. If an attempt to locate a DCHP server fails, TCP/IP configures the interface by using an IP address from the Microsoft reserved Class B network (169.254.0.0), subnet mask 255.255.0.0. During autoconfiguration, TCP/IP continues its attempts to locate a DHCP server and abandons the autoconfiguration process if one is located.

IPAutoconfigurationSubnet also appears in the Tcpip\Parameters subkey. The value of the entry in the Tcpip\Parameters subkey applies, by default, to all interfaces. However, if this entry appears in any Interfaces\<interface-name> subkey, its value overrides the value in the Tcpip\Parameters subkey when configuring that interface.

Note Image Note

This entry is used only when IP autoconfiguration is enabled, that is, the value of IPAutoconfigurationEnabled is 1.

Caution Image Caution

Do not change the value of this entry. If you do, the IP address assigned to the interface might not be reliable.


Lease

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<interface-name>

Data type | Range | Default value
REG_DWORD | 0x1 - 0xFFFFFFFF seconds | (There is no default value for this entry. This value is calculated by the system based on the conditions of the lease.)

Description

Specifies how long the lease on the IP address for this interface is valid.

The value of this entry is equal to the difference between LeaseTerminatesTime and LeaseObtainedTime.

The client attempts to renew its lease when the value of T1 expires and, if necessary, attempts again when the value of T2 expires. By default, T1 is equal to half of the value of Lease and T2 is equal to 7/8 (87.5%) of the value of Lease.

Note Image Note

This entry is created and maintained by the DHCP client service when the service is enabled.

Caution Image Caution

This entry is maintained by DHCP for its internal use. Do not delete this entry from the registry or change its value. If you do, you might void the interface's lease on its IP address and prevent the computer from operating on the network.

Related Entries

LeaseObtainedTime

LeaseTerminatesTime

T1

T2


LeaseObtainedTime

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<interface-name>

Data type | Range | Default value
REG_DWORD | Time, in seconds, since 12:00 A.M. on January 1, 1970 | (There is no default value for this entry. This value is calculated by the system based on the conditions of the lease.)

Description

Stores the time that the interface acquired the lease on its IP address.

The client attempts to renew its lease when the value of T1 expires and, if necessary, attempts again when the value of T2 expires. By default, T1 is equal to half of the value of Lease and T2 is equal to 7/8 (87.5%) of the value of Lease.

Note Image Note

This entry is created and maintained by the DHCP client service when the service is enabled.

Caution Image Caution

This entry is maintained by DHCP for its internal use. Do not delete this entry from the registry or change its value. If you do, you might void the interface's lease on its IP address and prevent the computer from operating on the network.

Related Entries

Lease

LeaseTerminatesTime


LeaseTerminatesTime

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<interface-name>

Data type | Range | Default value
REG_DWORD | Time, in seconds, since 12:00 A.M. on January 1, 1970 | (There is no default value for this entry. This value is calculated by the system based on the conditions of the lease.)

Description

Stores the time when the lease on the interfaces' IP address expires.

The client attempts to renew its lease when the value of T1 expires and, if necessary, attempts again when the value of T2 expires. By default, T1 is equal to half of the value of Lease and T2 is equal to 7/8 (87.5%) of the value of Lease.

Note Image Note

This entry is created and maintained by the DHCP client service when the service is enabled.

Caution Image Caution

This entry is maintained by DHCP for its internal use. Do not delete this entry from the registry or change its value. If you do, you might void the interface's lease on its IP address and prevent the computer from operating on the network.

Related Entries

Lease

LeaseObtainedTime


MaxForwardPending

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<interface-name>

Data type | Range | Default value
REG_DWORD | 0x1 - 0xFFFFFFFF packets | 0x1388 (5000 packets)

Description

Establishes the maximum number of packets that the IP forwarding engine is permitted to submit simultaneously for transmission to a particular network interface. If the number of packets exceeds the value of this entry, IP places the excess packets in a queue until outstanding transmissions on the interface are complete and then submits them for transmission.

The optimal value for this entry depends on the number and characteristics of outgoing lines. The default value for this entry is usually sufficient, especially for network adapters that transmit packets very quickly. However, increasing this value might improve the performance of a single RAS interface that multiplexes many slow serial lines.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

The default value of this entry is increased in Windows 2000. The default value for Windows NT 3.51 with Service Pack 2 and later is 0x14 (20).


MTU

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<interface-name>

Data type | Range | Default value
REG_DWORD | 0x44 - Dynamically determined MTU (in bytes) | 0xFFFFFFFF | 0xFFFFFFFF

Description

Reduces the size of the maximum transmission unit (MTU) TCP/IP uses for the network interface. The value of this entry overrides the MTU detected dynamically by the network adapter.

The MTU is the size of the largest packet that can be transmitted over the underlying network, including the size of the transport header. The MTU is configured separately for each interface.

To prevent fragmentation, the MTU should be large enough to hold any IP datagram in a single frame. IP datagrams larger than the MTU are divided into fragments whose size is a multiple of eight octets. The fragments travel separately to the destination computer, where they are reassembled before the datagram is processed.

MTU detection is determined for all interfaces by the value of EnablePMTUDiscovery. By default, the network adapter for each interface detects the largest MTU that can be transmitted by the interface and uses that for its transmissions. However, if MTU detection is disabled (that is, the value of EnablePMTUDiscovery is 0), the system uses a fixed MTU of 576 bytes. If you change the default value of MTU, you override either setting as it pertains to the interface represented by this subkey.

Value | Meaning
0x44 (68 bytes) - dynamically determined MTU | Specifies the MTU used for the network interface. This value overrides the MTU determined dynamically by the network adapter.
0xFFFFFFFF (or any value greater than the dynamically-determined MTU) | Use the dynamically-determined MTU.

Note Image Note

If you enter a value greater than the dynamically-determined MTU, the system uses the value of the dynamically-determined MTU instead. You can use this entry to reduce, but not to increase, the size of the MTU.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Tip Image Tip

For more information, search the Microsoft Knowledge Base for articles that include the term MTU or PMTU.

Caution Image Caution

In general, replacing a dynamically determined value with a fixed value degrades the performance of the operating system. Do not change the value of this entry unless the detected MTU is not compatible with the network media.

Related Entries

EnablePMTUDiscovery


NameServer

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<interface-name>

Data type | Range | Default value
REG_SZ | IPAddress[ IPAddress...] (A-space delimited list of dotted decimal IP addresses.) | (Blank value)

Description

Stores a list of DNS servers to which Windows Sockets sends queries when it resolves names for this interface. This entry, which can be changed by the user, overrides the DHCP-configured values for the DNS name servers.

The interface-specific DNS name server for the system is determined by the values of DhcpNameServer, which is configured by DHCP, and by NameServer, which you can configure.

If these entries contain valid values, the user-configured values take precedence over the DHCP-configured values when configuring the affected interface.

Change method

To change the value of this entry. use Network and Dial-up Connections. Right-click a connection and click Properties. If it is a dial-up connection, click the Networking tab. In the Components checked are used by this connection box, click Internet Protocol (TCP/IP), click Properties, click the Advanced button, and click the DNS tab. The servers in this list appear in the DNS addresses, in order of use box. To add a DNS server to the list, click Add.

Related Entries

DhcpNameServer


NTEContextList

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<interface-name>

Data type | Range | Default value
REG_MULTI_SZ | 0x0 - 0xFFFF | There is no default value for this entry.

Description

Stores the context number(s) of the IP address of this interface. Each IP address has a unique list of context numbers.

Caution Image Caution

Do not change the value of this entry. TCP/IP uses this value to identify an IP address. If you delete this entry or change its contents, you might prevent this computer from operating on the network.


PerformRouterDiscovery

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<interface-name>

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether Windows 2000 performs router discovery on this interface.

Router discovery solicits router information form the network. The system adds the information retrieved to the route table.

Value | Meaning
0 | Disables router discovery
1 | Enables router discovery

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Tip Image Tip

The router discovery method is specified in RFG 1256.

Related Entries

SolicitationAddressBcast

PerformRouterDiscoveryBackup


PerformRouterDiscoveryBackup

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<interface-name>

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Stores the a backup copy of the value of PerformRouterDiscovery.

This entry is used only when IP routing is enabled and the value of PerformRouterDiscovery is 0.

Caution Image Caution

Do not change the delete this entry or change its value. If you do, Windows might not operate properly.

Related Entries

PerformRouterDiscovery


Qos

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<interface-name>\

Description

The QoS subkey stores configuration data for Quality of Service (QoS) that are specific to a TCP/IP interface. The entries in this subkey are configured separately for each interface and apply only to the specified interface.


EnablePriorityBoost

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<interface-name>\Qos

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether QoS priority boosting is enabled on this interface. QoS boosts traffic priority only when RSVP signaling is disabled.

Priority boosting increases the link-level priority of GQoS application traffic to the priority of the service level the program requests. Traffic priority determines the order in which packets are submitted to the network when it is congested.

You can use this entry to priority of traffic without signaling.

Value | Meaning
0 | The link-level traffic priority of GQoS application traffic is not elevated, regardless of its service type. The traffic maintains the same priority level as other best-effort traffic.
1 | The link-level traffic priority of GQoS application traffic is elevated to the priority of the service level the program requests.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

To determine this setting for all QoS interfaces, add the EnablePriorityBoost entry to the Qossp services subkey. If this entry appears in both the Qossp subkey and an <Interface-name>\Qos subkey, the value in the <Interface-name>\Qos subkey takes precedence over the value in the Qossp subkey when configuring that interface.

Caution Image Caution

Consider the effect of priority boosting carefully before enabling it. Priority boosting is not subject to policy or admission control.

Related Entries

EnablePriorityBoost (Qossp)


EnableRSVP

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<interface-name>\Qos

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether Resource ReSerVation Protocol (RSVP) is enabled on this interface.

RSVP is a signaling protocol that creates a reserved communications channel and guarantees a specific level of quality for traffic on that channel.

Value | Meaning
0 | Disabled. RSVP signaling is not available to QoS connections terminating on the interface.
1 | Enabled. RSVP signaling is used for all QoS connections terminating on the interface.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

To determine this setting a particular QoS interface, add the EnableRSVP entry to an interface-specific <Interface-name>\Qos subkey in Tcpip\Parameters. If this entry appears in both the Qossp subkey and an <Interface-name>\Qos subkey, the value in the <Interface-name>\Qos subkey takes precedence over the value in the Qossp subkey when configuring that interface.

Related Entries

EnableRSVP (Qossp)


LowDelayBound

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<interface-name>\Qos

Data type | Range | Default value
REG_DWORD | 0x1 - 0xFFFFFFFF microseconds | 0x2710 (10,000 microseconds = 10 milliseconds)

Description

Specifies the value that QoS inserts in the Latency field of a flowspec (the service parameters for a combined sequence of packets) when the traffic is highly sensitive to delays. The Latency field defines the maximum acceptable delay between transmission of a bit by the sender and its receipt by one or more intended receivers.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

To determine this setting a particular QoS interface, add the LowDelayBound entry to an interface-specific <Interface-name>\Qos subkey in Tcpip\Parameters. If this entry appears in both the Qossp subkey and an <Interface-name>\Qos subkey, the value in the <Interface-name>\Qos subkey takes precedence over the value in the Qossp subkey when configuring that interface.

Related Entries

LowDelayBound (Qossp)

MediumDelayBound (<Inteface-name>\Qos)

MediumDelayBound (Qossp)


MapGeneralInfo

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<interface-name>\Qos

Data type | Range | Default value
REG_DWORD | 0 - 7 | 3

Description

Determines whether the general information service type (SERVICETYPE_GENERALINFO) is mapped to the controlled load or guaranteed service level. The system uses this mapping when an interface does not support RSVP signaling or when RSVP signaling is disabled on an interface.

QoS senders usually specify SERVICETYPE_GENERALINFO to indicate that they can support both controlled load and guaranteed service capability to the receiver.

Controlled load approximates the behavior of best-effort service in unloaded (not heavily loaded or congested) conditions. Guaranteed service guarantees the maximum limit on delay.

Value | Meaning
0 - 3 | Map SERVICETYPE_GENERALINFO traffic to the controlled load service level.
4 - 7 | Map SERVICETYPE_GENERALINFO traffic to the guaranteed service level.

Note Image Note

To determine this setting for all QoS interfaces, add the MapGeneralInfo entry to the Qossp services subkey. If this entry appears in both the Qossp subkey and an <Interface-name>\Qos subkey, the value in the <Interface-name>\Qos subkey takes precedence over the value in the Qossp subkey when configuring that interface.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Tip Image Tip

For more information about service levels, see Quality of Service in the Windows 2000 Server Resource Kit.

Related Entries

MapGeneralInfo (Qossp)


MediumDelayBound

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<interface-name>\Qos

Data type | Range | Default value
REG_DWORD | 0x1 - 0xFFFFFFFF microseconds | 0x186A0 (100,000 microseconds = 100 milliseconds)

Description

Specifies the value that QoS inserts in the Latency field of a flowspec (the service parameters for a combined sequence of packets) when the traffic on this interface is moderately sensitive to delays. The Latency field defines the maximum acceptable delay between transmission of a bit by the sender and its receipt by one or more intended receivers.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

To determine this setting for all QoS interfaces, add the MediumDelayBound entry to the Qossp services subkey. If this entry appears in both the Qossp subkey and an <Interface-name>\Qos subkey, the value in the <Interface-name>\Qos subkey takes precedence over the value in the Qossp subkey when configuring that interface.

Related Entries

MediumDelayBound (Qossp)

LowDelayBound (<Inteface-name>\Qos)

LowDelayBound (Qossp)


RawIPAllowedProtocols

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<interface-name>

Data type | Range | Default value
REG_MULTI_SZ | (Blank value | 0 | IP protocol numbers | 0

Description

Specifies the protocols that are accepted by the raw IP transport on this interface when security filtering is enabled. This entry is used only when the value of EnableSecurityFilters is 1.

Protocols are identified by their protocol numbers. If the value of this entry contains valid protocol numbers, only IP datagrams using the specified protocols are accepted by the raw IP transport which provides raw sockets.

It determines which IP datagrams are accepted by the raw IP transport. It does not affect IP datagrams passed to other transports, such as TCP.

Value | Meaning
(Blank value -- the entry appears in the registry, but there is no data in the value field.) | No datagrams are accepted.
0 (or not in registry) | All datagrams are accepted.
Specific IP protocol numbers | Only datagrams with these IP protocol numbers are accepted.

Change method

To change the value of this entry, use Network and Dial-up Connections. Right-click Local Area Connection, click Properties, click Internet Protocol (TCP/IP), and then click the Properties button. In the bottom, right corner of the Internet Protocol (TCP/IP) Properties page, click the Advanced button, click the Options tab, click TCP/IP filtering, click Properties and then, just above the IP Protocols box, click the Permit Only. This entry is associated with the values added to the IP Protocols list on this page.

Note Image Note

There is no defined or predictable response when the value of this entry includes both a zero and IP protocol numbers. Do not combine these values in this entry.

Related Entries

UdpAllowedPorts

TcpAllowedPorts


SolicitationAddressBcast

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<Interface-name>

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Sends router discovery solicitations on this interface as limited broadcasts (255.255.255.255), instead of multicasts, as described in RFC 1256.

By default, router discovery solicitations are sent to the all-routers multicast group (224.0.0.2). Also, by default, IRDP client listens to both multicast and broadcast router advertisements.

Note Image Note

This entry is used only when router discovery is enabled, that is, when the value of PerformRouterDiscovery is 1.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

PerformRouterDiscovery


SubnetMask

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<interface-name>

Data type | Range | Default value
REG_DWORD | (A space-delimited list of dotted decimal subnet masks.) | 0.0.0.0

Description

Specifies the subnet mask for the IP address specified in the value of IPAddress or DhcpIPAddress. This entry, which can be changed by the user, overrides the DHCP-configured values for the subnet mask.

The subnet mask is determined by two entries, DhcpSubnetMask, which is configured by DHCP, and SubnetMask, which you can configure. If the value of SubnetMask is not 0.0.0.0, then it overrides the value of DhcpSubnetMask.

Related Entries

DhcpIPAddress

DhcpSubnetMask

IPAddress


T1

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<interface-name>

Data type | Range | Default value
REG_DWORD | Time, in seconds, since 12:00 A.M. on January 1, 1970 | There is no default value for this entry.

Description

Determines when the DHCP service attempts to renew the lease on the IP address for this interface. If the attempt is not successful, DHCP tries again at the time specified by value of T2.

By default, this entry is equal to half of the lease term, as stored in the value of Lease. Also, by default, the value of T2 is equal to 7/8 (87.5%) of the value of Lease.

Caution Image Caution

This entry is created and maintained by the DHCP client service when the service is enabled. Do not change this value. If you do, you might not be able to contact the DHCP server.

Related Entries

Lease

LeaseObtainedTime

LeaseTerminatesTime

T2


T2

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<interface-name>

Data type | Range | Default value
REG_DWORD | Time, in seconds, since 12:00 A.M. on January 1, 1970 | There is no default value for this entry.

Description

Determines when the DHCP service reattempts to renew the lease on the IP address for this interface. DHCP first attempts to renew the lease at the time specified by the value of T1. Only if that attempt is unsuccessful, DHCP tries again at the time specified by T2.

By default, the value of T1 is equal to half of the lease term, as stored in the value of Lease. Also, by default, the value of T2 is equal to 7/8 (87.5%) of the value of Lease.

Caution Image Caution

This entry is created and maintained by the DHCP client service when the service is enabled. Do not change this value. If you do, you might not be able to contact the DHCP server.

Related Entries

Lease

LeaseObtainedTime

LeaseTerminatesTime

T1


TCPAllowedPorts

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<interface-name>

Data type | Range | Default value
REG_MULTI_SZ | (Blank value | 0 | IP protocol numbers | 0

Description

Specifies the TCP ports on which incoming connection requests (SYNs) are accepted on this interface when security filtering is enabled. Security filtering is enabled when the value of EnableSecurityFilters is 1.

Value | Meaning
(Blank value -- the entry appears in the registry, but there is no data in the value field.) | No SYNs are accepted.
0 (or not in registry) | All SYNs are accepted.
Specific IP protocol numbers | Only SYNs arriving on these ports are accepted.

Change method

To change the value of this entry, use Network and Dial-up Connections in Control Panel. Right-click Local Area Connection, click Properties, click Internet Protocol (TCP/IP), and then click the Properties button. In the bottom, right corner of the Internet Protocol (TCP/IP) Properties page, click the Advanced button, click the Options tab, click TCP/IP filtering, click Properties and then, just above the TCP Ports box, click Permit Only. This entry is associated with the values added to the TCP Ports list on this page.

Note Image Note

There is no defined or predictable response when the value of this entry includes both a zero and IP protocol numbers. Do not combine these values in this entry.

Related Entries

UdpAllowedPorts

RawIpAllowedProtocols


TcpDelAckTicks

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<interface-name>

Data type | Range | Default value
REG_DWORD | 0 - 6 100-millisecond intervals | 2

Description

Specifies the time interval that defines the end of a segment stream. When an interval equal to this value elapses between the receipt of TCP segments, TCP considers the segment stream to be complete and sends an ACK to acknowledge the segment. Otherwise, TCP acknowledges only alternating segments (every other segment).

This interval is used in TCP's delayed acknowledgement strategy in accordance with RFC 1122.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Caution Image Caution

Do not change this value without careful study of the environment.


TcpInitialRTT

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<interface-name>

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFF | 0x3

Description

Determines how quickly TCP retransmits a connection request if it doesn't receive a response to the original request for a new connection.

This value initializes the retransmission timer. It specifies the time that must elapse between the original transmission and the first retransmission. On each subsequent retransmission, the previous interval is doubled. This strategy assumes that the response is delayed because the connection is slow.

By default, the retransmission timer is initialized to 3 seconds, and the request (SYN) is sent twice, as specified in the value of TcpMaxConnectRetransmissions.

Note Image Note

Windows does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Caution Image Caution

Because the delay between retransmissions grows exponentially, this initial value should be very small. Entering a value greater than 3 (seconds) prevents the server from disposing of unacknowledgeable connection requests expeditiously.


TcpWindowSize

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<interface-name>

Data type | Range | Default value
REG_DWORD | 0x0 - 0x3FFFFFFF bytes | (See description.)

Description

Determines the largest TCP receive window offered by the system. The receive window is the number of bytes a sender can transmit without receiving an acknowledgment. This entry override's TCP's negotiated maximum receive window size and replaces it with the value of this entry.

TCP uses a receive window that is four times the size of the maximum TCP segment size (MSS) negotiated during connection setup up to a maximum size of 64 KB. TCP for Windows 2000 also supports windows scaling, as detailed in RFC 1323. Scaling enables TCP to provide a receive window of up to 1 GB.

For Ethernet networks, the default value of this entry is 0x4470 (17,520 or twelve 1460-byte segments). For other networks, the default value is 0xFFFF (65535) unless 0xFFFF is larger than:

  • Four times the maximum TCP data size on the network;

    • and

  • 0x2000 (8192) rounded up to an even multiple of the network TCP data size.

Note Image Note

This entry determines the maximum receive window size for this interface. When configuring this interface, TcpWindowSize takes precedence over the value of GlobalMaxTcpWindowSize which establishes a maximum window size for all interfaces.

Windows 2000 uses windows scaling automatically if the value of TcpWindowSize is greater than 64 KB. To disable windows scaling, set the value of Tcp1323Opts to 0 or 2.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

GlobalMaxTcpWindowSize

Tcp1323Opts


TypeOfInterface

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<Interface-name>

Data type | Range | Default value
REG_DWORD | 0 | 1 | 2 | 3 | 0

Description

Determines which traffic types can be routed and forwarded on this interface.

Value | Meaning
0 | Permit unicast and multicast traffic.
1 | Prohibit unicast traffic.
2 | Prohibit multicast traffic.
3 | Prohibit unicast and multicast traffic.

Note Image Note

Because this entry affects forwarding and routes, a local application can transmit multicasts over an interface that does not permit them, if there are no other interfaces in the computer that are enabled for multicast, and there is a default route.


UDPAllowedPorts

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<interface-name>

Data type | Range | Default value
REG_DWORD | 0

Description

Specifies the UDP ports on which incoming IP datagrams are accepted on this interface when security filter is enabled. Security filtering is enabled when the value of EnableSecurityFilters is 1.

Value | Meaning
(Blank value -- the entry appears in the registry, but there is no data in the value field.) | No datagrams are accepted.
0 (or not in registry) | All datagrams are accepted.
Specific IP protocol numbers | Only datagrams arriving on these ports are accepted.

Change method

To change the value of this entry, use Network and Dial-up Connections. Right-click Local Area Connection, click Properties, click Internet Protocol (TCP/IP), and then click the Properties button. In the bottom, right corner of the Internet Protocol (TCP/IP) Properties page, click the Advanced button, click the Options tab, click TCP/IP filtering, click Properties and then, just above the UDP Ports box, click Permit Only. This entry is associated with the values added to the UDP Ports list on this page.

Note Image Note

There is no defined or predictable response when the value of this entry includes both a zero and IP protocol numbers. Do not combine these values in this entry.

Related Entries

TcpAllowedPorts

RawIpAllowedProtocols


UseZeroBroadcast

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<interface-name>

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether IP uses zeros broadcasts or ones broadcasts. Most systems use ones broadcasts, but some systems, such as those derived from BSD implementations, use zeros broadcasts. Systems that use different broadcasts will not interoperate well on the same network.

Value | Meaning
0 | Uses ones broadcasts. The ones local broadcast address is 255.255.255.255
1 | Uses zeros broadcasts. The zeros local broadcast address is 0.0.0.0.

Note Image Note

Please note that a value of 1 is associated with the zeros broadcast and a value of 0 is associated with the ones broadcast. A value of 1 overrides the default behavior of the system and requires that it use a zeros broadcast.


IPAutoconfigurationEnabled

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether the IP autoconfiguration feature is enabled for this interface.

Autoconfiguration allows TCP/IP to configure an interface even when it cannot locate a DHCP server. If an attempt to locate a DCHP server fails, TCP/IP configures the interface by using IP addresses from the Microsoft reserved Class B network (169.254.0.0), subnet mask 255.255.0.0. During autoconfiguration, TCP/IP continues its attempts to locate a DHCP server and abandons the autoconfiguration process if one is located.

IPAutoconfigurationEnabled also appears in the Interfaces\<interface-name> subkeys. The value of the entry in the Tcpip\Parameters subkey applies, by default, to all interfaces. However, if this entry appears in any Interfaces\<interface-name> subkey, its value overrides the value in the Tcpip\Parameters subkey when configuring that interface.

Caution Image Caution

Do not change the value of this entry. If you do, the IP address assigned to the interface might not be reliable.


IPAutoconfigurationMask

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | Subnet mask, in dotted decimal format | 255.255.0.0

Description

Stores the subnet mask assigned to the client by the IP autoconfiguration feature.

Autoconfiguration allows TCP/IP to configure an interface even when it cannot locate a DHCP server. If an attempt to locate a DCHP server fails, TCP/IP configures the interface by using an IP address from the Microsoft reserved Class B network (169.254.0.0), subnet mask 255.255.0.0. During autoconfiguration, TCP/IP continues its attempts to locate a DHCP server and abandons the autoconfiguration process if one is located.

IPAutoconfigurationMask also appears in the Interfaces\<interface-name> subkeys. The value of the entry in the Tcpip\Parameters subkey applies, by default, to all interfaces. However, if this entry appears in any Interfaces\<interface-name> subkey, its value overrides the value in the Tcpip\Parameters subkey when configuring that interface.

Note Image Note

This entry is used only when IP autoconfiguration is enabled, that is, the value of IPAutoconfigurationEnabled is 1.

Caution Image Caution

Do not change the value of this entry. If you do, the IP address assigned to the interface might not be reliable.

Related Entries

IPAutoconfigurationMask


IPAutoconfigurationSeed

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFF | 0

Description

The DHCP client manages this entry for its internal use. Do not change the value of this entry.

Caution Image Caution

Do not change the value of this entry under any circumstances. If you do, your computer will not operate properly.


IPAutoconfigurationSubnet

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_SZ | Subnet address, in dotted decimal format | 169.254.0.0

Description

Determines the subnet address used by the IP autoconfiguration feature to assign an IP address to an interface.

Autoconfiguration allows TCP/IP to configure an interface even when it cannot locate a DHCP server. If an attempt to locate a DCHP server fails, TCP/IP configures the interface by using an IP address from the Microsoft reserved Class B network (169.254.0.0), subnet mask 255.255.0.0. During autoconfiguration, TCP/IP continues its attempts to locate a DHCP server and abandons the autoconfiguration process if one is located.

IPAutoconfigurationSubnet also appears in the Interfaces\<interface-name> subkeys. The value of the entry in the Tcpip\Parameters subkey applies, by default, to all interfaces. However, if this entry appears in any Interfaces\<interface-name> subkey, its value overrides the value in the Tcpip\Parameters subkey when configuring that interface.

Note Image Note

This entry is used only when IP autoconfiguration is enabled, that is, the value of IPAutoconfigurationEnabled is 1.

Caution Image Caution

Do not change the value of this entry. If you do, the IP address assigned to the interface might not be reliable.

Related Entries

IPAutoconfigurationSubnet

IPAutoconfigurationEnabled


IPEnableRouter

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether the system routes IP packets to the networks to which it is connected.

Value | Meaning
0 | The system routes IP packets.
1 | IP packets are not routed.


IpEnableRouterBackup

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | (There is no default value for this entry. The system enters a value when you install or upgrade Windows.)

Description

Stores a backup copy of the value that was stored in IPEnableRouter when the system was most recently installed or upgraded.

The system uses this entry to determine whether the value of IpEnableRouter changed, and, if requested, to restore the previous value.

Caution Image Caution

Do not delete this entry or change its contents. If you do, you might disable the IP packet routing mechanism.


KeepAliveInterval

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 0x1- 0xFFFFFFFF milliseconds | 0x3E8 (1 second)

Description

Determines how often TCP repeats keep-alive transmissions when no response is received. TCP sends keep-alive transmissions to verify that idle connections are still active. This prevents TCP from inadvertently disconnecting active lines.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

TcpMaxDataRetransmissions

KeepAliveTime


KeepAliveTime

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 0x1- 0xFFFFFFFF milliseconds | 0x6DDD00 (7,200,000 milliseconds = 2 hours)

Description

Determines how often TCP sends keep-alive transmissions. TCP sends keep-alive transmissions to verify that an idle connection is still active.

This entry is used when the remote system is responding to TCP. Otherwise, the interval between transmissions is determined by the value of KeepAliveInterval.

By default, keep-alive transmissions are not sent. The TCP keep-alive feature must be enabled by a program, such as Telnet, or by an Internet browser, such as Internet Explorer.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

KeepAliveInterval


MaxForwardBufferMemory

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | Network MTU - 0xFFFFFFFF | 0x200000 (2 MB)

Description

Establishes the maximum amount of memory that IP can allocate to store packet data in the router packet queue. The value of this entry must be greater than or equal to the value of ForwardBufferMemory.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

The default value of this entry is changed in Windows 2000. The default value for Windows NT 4.0 prior to Service Pack 4 is 0xFFFFFFFF.

Related Entries

ForwardBufferMemory


MaxFreeTcbs

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF connections | (Varies with the system and amount of physical memory on the computer. See below.)

Description

Determines the number of TCP control blocks (TCBs) the system creates to support active connections. Because each connection requires a TCB, this value determines how many active connections TCP can support simultaneously. If all TCBs are used and more connection requests arrive, TCP can prematurely release connections in the TIME_WAIT state in order to free a TCB for a new connection.

Normally, TCP does not release a connection or reuse its resources until the connection has remained closed for a period specified by the value of TcpTimedWaitDelay. This interval is known as the TIME_WAIT or 2MSL (2 x maximum segment lifetime) state. However, if the system is supporting an unusually large number of connections and is running short of connection resources, TCP releases the connection before their TcpTimedWaitDelay is expired.

The default value for this entry is determined by the amount of physical memory on the computer when TCP/IP starts and the version of the Windows running on the computer, as shown in the following table.

Default value of MaxFreeTcbs
 | Windows 2000 Server | Windows 2000 Professional
Less than 19 MB | 500 | 250
19 - 63 MB | 1000 | 500
64 MB or more | 2000 | 1000

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

TcpTimedWaitDelay


MaxFreeTWTcbs

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 0x1 - 0xFFFF TCB table partitions | 0x4

Description

Determines the number partitions in the Transport Control Block (TCB) table.

Partitioning the TCB table minimizes contention for table access. This is especially useful on multiprocessor systems.

Caution Image Caution

Do not change the value of this entry before carefully studying the effect of different values in a test environment. When testing, do not enter a value greater than two times the number of processors on the computer.


MaxHashTableSize

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 64 - 65536 table entries | 512

Description

Determines the size of the hash table in which TCP control blocks (TCBs) are stored.

TCP stores TCBs in a hash table so it can find them very quickly. If you adjust the number of TCBs the system creates (as specified by the value of MaxFreeTcbs), you should adjust this value proportionally.

Note Image Note

The value of this entry must be a power of 2. If you enter a different value, the system rounds your value up to the next higher power of 2.

Windows does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

MaxFreeTcbs

TcpTimedWaitDelay


MaxNormLookupMemory

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 | 0x1 - 0xFFFFFFFE bytes | 0xFFFFFFFF | (Varies with the system and amount of physical memory on the computer. See below.)

Description

Determines the maximum amount of system memory TCP can allocate for the routing table and its data.

Value | Meaning
0x0 | No TCP routing table.
0x1 - 0xFFFFFFFE | Specifies the maximum amount of system memory that can be allocated to the TCP routing table.
0xFFFFFFFF | There is no limit on the amount of system memory that TCP can allocate to the TCP routing table.

The default value for this entry is determined by the amount of physical memory on the computer when TCP/IP starts and the version of the Windows running on the computer, as shown in the following table.

Default value of MaxNormLookupMemory
Amount of physical memory on the computer | Windows 2000 Server | Windows 2000 Professional
Less than 19 MB | 0x25800 (150 KB = 1,000 routes) | 0x25800 (150 KB = 1,000 routes)
19 - 63 MB | 0x180000 (1.5 MB = 10,000 routes)
64 MB or more | 0x500000 (5 MB = 40,000 routes)


MaxNumForwardPackets

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 0x1 - 0xFFFFFFFE Number of packet headers | 0xFFFFFFFF | 0xFFFFFFFF

Description

Establishes the maximum number of IP packet headers that TCP is permitted to allocate to the router packet queue. The value of this entry must be greater than or equal to the value of NumForwardPackets.

Value | Meaning
0x1 - 0xFFFFFFFE | The maximum number of IP packet headers in the router packet queue.
0xFFFFFFFF | The number of IP packet headers in the router packet queue is not limited.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

NumForwardPackets


MaxUserPort

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 5000 - 65534 port number | 5000

Description

Determines the highest port number TCP is permitted to assign when an application requests an available user port from the system. Typically, ephemeral ports (those used briefly) are allocated to port numbers 1024 through 5000.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


NameServer

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_SZ | IPAddress[ IPAddress...] (A-space delimited list of dotted decimal IP addresses.) | (Blank value.)

Description

This entry appears in the registry, but it is not used by Windows 2000.


NumForwardPackets

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 0x1 - 0xFFFFFFFE packet headers | 0x32 (50)

Description

Determines how many IP packet headers TCP allocates to the router packet queue when the system starts.

When all of the IP packet headers allocated at startup are in use, the router begins to discard packets at random from the queue. The value of this entry is used only when routing is enabled and headers are allocated.

The value of this entry should be at least as large as the value of the ForwardBufferMemory entry divided by the maximum IP data size of the networks connected to the router. However, it should be no larger than the value of ForwardBufferMemory divided by 256, because at least 256 bytes of forward buffer memory are used for each packet. The optimal number of forward packets for a given ForwardBufferMemory size depends on the type of traffic carried on the network and is somewhere between these two values.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

MaxNumForwardPackets

ForwardBufferMemory


NumTcbTablePartitions

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Directs the DHCP client to ignore Media Sense events from the interface.

Media Sense provides a mechanism for network adapters to notify the protocol stack of when network media is connected and disconnected. The protocol stack can then update its network configuration parameters. Media Sense is especially useful on portable computers which are commonly disconnected from one network and connected to a different network.

Media sense events direct the DHCP client to take an action, such as attempting to obtain a lease when a media is connected, or invalidating the interface and routes when media is disconnected.

Value | Meaning
0 | Enables media sense on the DHCP client.
1 | Disables media sense on the DHCP client.

Note Image Note

Because 10b2 or coaxial (RG-58) Ethernet cable is not a connection-based media, media sense does not detect connection and disconnection events on this type of network cable.

NetBEUI and IPX do not recognize media sense events.


NV Domain

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_SZ | DNS suffix | There is no default value for this entry.

Description

Stores the newly assigned primary Domain Name System (DNS) suffix for the computers. The value of this entry will be used as the primary DNS suffix for the computer when you restart Windows 2000.

The primary DNS suffix is used in DNS name registration and DNS name resolution.

This entry stores the value you enter in the Primary DNS suffix of this computer box on the DNS Suffix and NetBIOS Computer Name dialog box in System in Control Panel. When you restart the system, DNS copies the value of the NV Domain entry to the value of Domain and uses the value in that location thereafter.

Change method

To change the value of this entry, click System in Control Panel, click the Network Identification tab, click Properties, click More, and then enter a suffix in the Primary DNS suffix of this computer box.

. The user setting is stored in the value of NV Domain and then it is copied to the value of Domain when you restart Windows 2000.

Note Image Note

The setting in the Primary DNS suffix of this computer box can be superceded by a policy included in Windows 2000. While the Primary DNS Suffix Group Policy is enabled, the system ignores the local setting. The Primary DNS Suffix policy setting is stored in the value of the NV PrimaryDnsSuffix and PrimaryDnsSuffix entries.

The Primary DNS Suffix Group Policy does not disable or change the appearance of the Primary DNS suffix of this computer dialog box. However, while the policy is enabled, the system does not read the value entered in that box and stored in this entry. The system reads this entry when the Primary DNS Suffix Group Policy is disabled or not configured; that is, when the value of the PrimaryDnsSuffix entry does not appear in the registry.

Tip Image Tip

For detailed information about particular Group Policies, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

Related Entries

Domain

NV PrimaryDnsSuffix

PrimaryDnsSuffix


PersistentRoutes

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\

Description

The PersistentRoutes subkey contains entries representing routes that are permanent entries in the IP routing table. Unlike active routes, which are deleted when you shut down or restart Windows 2000, permanent routes are stored in the registry and remain in the IP routing table until you remove them.

Because Windows does not create persistent routes, the PersistentRoutes subkey is empty by default. You must add persistent routes manually by using the -p switch with the Route add command at the command line. The Windows Route program, Route.exe, writes the route to the routing table and to the PersistentRoutes. To remove a persistent route from the routing table (and from the registry), use the Route delete command.

Each entry in the PersistentRoutes subkey represents one route entry in the routing table.


PPTPTcpMaxDataRetransmissions

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 0 - 0xFF retransmissions | 0x5

Description

Determines how many times an unacknowledged PPTP packet is retransmitted before the connection is dropped.

This entry lets you configure a limit on PPTP retransmissions separately from the limit you set for regular TCP retransmissions in TCPMaxDataRetransmissions. You can then adjust the TCP setting to prevent SYN flooding attacks without affecting PPTP traffic.

Note Image Note

The default value of this entry is changed for Windows 2000. For Windows NT 4.0 and earlier, the default value was 0xFFFFFFFF.

Tip Image Tip

To prevent the TCP dead gateway detection feature from inadvertently disconnecting a congested Internet link, set this value higher than the default value of TCPMaxDataRetransmissions.

Related Entries

EnableDeadGWDetect

TCPMaxDataRetransmissions


SackOpts

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Enables and disables the Selective Acknowledgement (SACK) feature of Windows 2000 TCP/IP. SACK is specified in RFC 2018.

Selective Acknowledgement is an optimizing feature that lets you acknowledge receipt of individual blocks of data in a continuous sequence, rather than just the last sequence number. The recipient can tell the sender that one or more data blocks is missing from the middle of a sequence, and the sender can retransmit only the missing data.

Value | Meaning
0 | Disables SACK.
1 | Enables SACK.


SynAttackProtect

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether the SYN flooding attack protection feature of TCP/IP is enabled. SYN flooding attack protection is enabled when the value of this entry is 1 and the value of TcpMaxConnectResponseRetransmissions is at least 2 (see note below).

The SYN flooding attack protection feature of TCP detects symptoms of SYN flooding and responds by reducing the time server spends on connection requests that it cannot acknowledge.

Value | Meaning
0 | SYN flooding attack protection is not enabled.
1 | SYN flooding attack protection is enabled.

Note Image Note

This value is used only when the number of SYN-ACK retransmissions is likely to impair the server, that is, when the value of TcpMaxConnectResponseRetransmissions is at least 2.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

TcpMaxConnectResponseRetransmissions

TCPMaxHalfOpen

TCPMaxHalfOpenRetried

TcpMaxPortsExhausted


Tcp1323Opts

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 2 | 3 | 3

Description

Determines whether TCP uses the timestamping and window scaling features described by RFC 1323.

Window scaling permits TCP to negotiate a scaling factor for the TCP receive window size, allowing for a very large TCP receive window of up to 1 GB. The TCP receive window is the amount of data the sending host can send at one time on a connection.

Timestamps help TCP to measuring round trip time (RTT) accurately in order to adjust retransmission timeouts. The Timestamps option provides two four-byte timestamp fields in the TCP header, one to record the time the initial transmission is sent and one to record the time on the remote host.

This entry is a two-bit bitmask. The lower bit determines whether scaling is enabled; the higher bit determines whether timestamps are enabled. To enable a feature, set the bit representing the feature to 1. To disable the feature, set its bit to 0.

Value | Meaning
0 (00) | Timestamps and window scaling are disabled.
1 (01) | Window scaling is enabled.
2 (10) | Timestamps are enabled.
3 (11) | Timestamps and window scaling are enabled.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Tip Image Tip

For more information on RFC 1323, see the specification at http://www.cis.ohio-state.edu/htbin/rfc/rfc1323.html.


TcpMaxConnectResponseRetransmissions

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 0 - 255 retransmission attempts | 2

Description

Determines how many times TCP retransmits an unanswered SYN-ACK (connection request acknowledgement). TCP retransmits acknowledgements until they are answered, or until this value expires. This entry is designed to minimize the effect of SYN flooding on the server.

This entry also determines, in part, whether the SYN attack protection feature of TCP is enabled. This feature detects symptoms of SYN flooding and responds by reducing the time server spends on connection requests that it cannot acknowledge. SYN attack protection is enabled when the value of SynAttackProtect is 1 and the value of this entry is at least 2.

TCP/IP adjusts the frequency of retransmissions over time. The delay between the first and second retransmissions is 3 seconds. This delay is doubled after each attempt. After the final attempt, TCP/IP waits for an interval equal to double the last delay and then closes the connection request.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

SynAttackProtect

TCPMaxHalfOpen

TCPMaxHalfOpenRetried

TcpMaxPortsExhausted


TcpMaxConnectRetransmissions

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 0 - 255 retransmission attempts | 2

Description

Determines how many times TCP retransmits an unanswered request for a new connection. TCP retransmits new connection requests until they are answered, or until this value expires.

TCP/IP adjusts the frequency of retransmissions over time. The delay between the original transmission and the first retransmissions for each interface is determined by the value of TcpInitialRTT (by default, it is 3 seconds). This delay is doubled after each attempt. After the final attempt, TCP/IP waits for an interval equal to double the last delay and then abandons the connection request.

Note Image Note

TcpMaxConnectRetransmissions determines how many times TCP retransmits requests for new connections. When sending data on existing connections, the maximum number of retransmissions is determined by the value of TcpMaxDataRetransmissions.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

TcpInitialRTT

TcpMaxDataRetransmissions


TcpMaxDataRetransmissions

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF retransmission attempts | 0x5

Description

Determines how many times TCP retransmits an unacknowledged data segment on an existing connection. TCP retransmits data segments until they are acknowledged, or until this value expires.

TCP/IP adjusts the frequency of retransmissions over time. TCP establishes an initial retransmission interval by measuring the round-trip time on the connection. The interval is doubled with each successive retransmission on a connection and is reset to the initial value when responses resume.

TcpMaxDataRetransmissions also is used in the Windows algorithm for defining non-operational ("dead") gateways.

Any given connections defines a gateway as dead (and switches to the next gateway in the list in DefaultGateway or DhcpDefaultGateway) when a packet sent to the gateway must be retransmitted more than half of the number of times specified in the value of TcpMaxDataRetransmissions. The system defines a gateway as dead when more than 25% of its connections have switched to the next default gateway in the list.

Note Image Note

TcpMaxDataRetransmissions determines how many times TCP retransmits data segments. The maximum number of retransmissions of requests for new connections is determined by the value of TcpMaxConnectRetransmissions.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

TcpMaxConnectRetransmissions


TcpMaxDupAcks

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 1 - 3 | 2

Description

Specifies how many duplicate ACKs (ACKs for the same sequence numbers) constitute a signal to retransmit a segment. If you set the value of this entry to 1, the system retransmits a segment when it receives an ACK for a segment with a sequence number less than the number of the segment currently being sent.

When data arrives with a sequence number greater than expected, the receiver assumes that data with the expected number was dropped, and immediately sends an ACK with the ACK number set to the expected sequence number. The receiver sends ACKs set to the same missing number each time it receives a TCP segment that has a sequence number greater than expected. The sender recognizes the duplicate ACKs and sends the missing segment.

Note Image Note

This entry is used only when the receiver supports the fast retransmit feature. Fast retransmit lets TCP retransmit data before the retransmission timer (as set by the value of TcpInitialRtt) expires.


TcpMaxHalfOpen

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 0x64 - 0xFFFF connections | Windows NT Server: 0x64 (100), Windows NT Workstation: 1F4 (500)

Description

Determines how many connections the server can maintain in the half-open (SYN-RCVD) state before TCP/IP initiates SYN flooding attack protection. This entry is used only when SYN flooding attack protection is enabled on this server (that is, the value of SynAttackProtect is 1 and the value of TcpMaxConnectResponseRetransmissions is at least 2).

This entry establishes one of three configurable thresholds which, when exceeded, trigger TCP's SYN attack flooding protection feature. Because SYN flooding often results in many half-open connections, TCP interprets an elevated number of half-open connections to be a symptom of SYN flooding.

The other thresholds are:

  • the number of connections that remain in the half-open (SYN-RCVD) state even after a connection request has been retransmitted exceeds the value of TcpMaxHalfOpenRetried;
  • The number of connection requests the system refuses exceeds the value of TcpMaxPortsExhausted. The system must refuse all connection requests when its reserve of open connection ports runs out.

Note Image Note

The value of this entry should be greater than the value of TCPMaxHalfOpenRetried.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

SynAttackProtect

TcpMaxConnectResponseRetransmissions

TCPMaxHalfOpenRetried

TcpMaxPortsExhausted


TcpMaxHalfOpenRetried

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 0x50 (80) - 0xFFFF | Windows NT Server: 0x50 (80), Windows NT Workstation: 190 (400)

Description

Determines how many connections the server can maintain in the half-open (SYN-RCVD) state even after a connection request has been retransmitted. If the number of exceeds the value of this entry, TCP/IP initiates SYN flooding attack protection. This entry is used only when SYN flooding attack protection is enabled on this server (that is, the value of SynAttackProtect is 1 and the value of TcpMaxConnectResponseRetransmissions is at least 2).

This entry establishes one of three configurable thresholds which, when exceeded, trigger TCP's SYN attack flooding protection feature. Because SYN flooding often results in many half-open connections, TCP interprets an elevated number of half-open connections to be a symptom of SYN flooding.

The other thresholds are:

  • The total number of connections in the half-open (SYN-RCVD) state exceeds the value of TcpMaxHalfOpen;
  • The number of connection requests the system refuses exceeds the value of TcpMaxPortsExhausted. The system must refuse all connection requests when its reserve of open connection ports runs out.

Note Image Note

The value of this entry should be less than the value of TCPMaxHalfOpen.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

SynAttackProtect

TcpMaxConnectResponseRetransmissions

TCPMaxHalfOpen

TcpMaxPortsExhausted


TcpMaxPortsExhausted

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFF | 0x5

Description

Determines how many connection requests the system can refuse before TCP/IP initiates SYN flooding attack protection. The system must refuse all connection requests when its reserve of open connection ports runs out. This entry is used only when SYN flooding attack protection is enabled on this server (that is, the value of SynAttackProtect is 1 and the value of TcpMaxConnectResponseRetransmissions is at least 2).

This entry establishes one of three configurable thresholds which, when exceeded, trigger TCP's SYN attack flooding protection feature. Because SYN flooding often consumes all reserved connection ports, TCP interprets an elevated number connection refusals and a depleted port reserve as a symptom of SYN flooding.

The other thresholds are:

  • The total number of connections in the half-open (SYN-RCVD) state exceeds the value of TcpMaxHalfOpen;
  • The number of connections that remain in the half-open (SYN-RCVD) state even after a connection request has been retransmitted exceeds the value of TcpMaxHalfOpenRetried

Note Image Note

If the value of this entry is 0, SYN flooding protection is triggered as soon as the backlog of connection ports is consumed.

Related Entries

SynAttackProtect

TcpMaxConnectResponseRetransmissions

TCPMaxHalfOpen

TCPMaxHalfOpenRetried


TcpNumConnections

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFE | 0

Description

Determines the maximum number of connections that TCP is permitted have open simultaneously.

If the value of this entry is 0, you cannot establish any connections.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


TcpTimedWaitDelay

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 0x1E- 0x12C (30 - 300) seconds | 0xF0 (240 seconds = 4 minutes)

Description

Determines the time that must elapse before TCP can release a closed connection and reuse its resources. This period between closure and release is known as the TIME_WAIT state or 2MSL state. During this time, the connection can be reopened at much less cost to the client and server than establishing a new connection.

RFC 793 requires that TCP maintain a closed connection for an interval at least equal to twice the maximum segment lifetime (2MSL) of the network. When a connection is released, its socket pair and TCP control block (TCB) can be used to support another connection. By default, the MSL is defined to be 120 seconds, and the value of this entry is equal to two MSLs, or 4 minutes. However, you can use this entry to customize this interval.

Reducing the value of this entry allows TCP to release close connections faster, providing more resources for new connections. However, if the value is too low, TCP might release connection resources before the connection is complete, requiring the server to use additional resources to reestablish the connection.

Note Image Note

Normally, TCP does not release closed connections until the value of this entry expires. However, TCP can release connections before this value expires if it is running out of TCP control blocks (TCBs). The number of TCBs the system creates is specified by the value of MaxFreeTcbs.

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Related Entries

MaxFreeTcbs


TcpUseRFC1122UrgentPointer

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines which mode TCP uses for urgent data. The two mechanisms interpret the urgent pointer in the TCP header and the length of the urgent data differently. The two modes do not interoperate.

Value | Meaning
0 | TCP uses the mode used by BSD-derived systems.
1 | TCP uses the RFC 1122 specification for urgent data.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


TrFunctionalMcastAddress

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether IP multicasts are sent by using the Token Ring Multicast address described in RFC 1469 or by using the subnet broadcast address.

Value | Meaning
0 | IP multicasts are sent by using the Token Ring Multicast address described in RFC 1469
1 | IP multicasts are sent by using the subnet broadcast address.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Tip Image Tip

For more information, see RFC 1469 at http://rfc.fh-koeln.de/rfc/html/rfc1469.html


UpdateSecurityLevel

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 16 | 256) | 0x0

Description

Determines whether the DNS client uses secure dynamic update or standard dynamic update.

Windows 2000 supports both dynamic update and secure dynamic update. With secure dynamic update, the authoritative name server accepts updates only from authorized clients and servers.

Value | Meaning
0 | Send secure dynamic updates only when non-secure dynamic updates are refused.
16 | Send only non-secure dynamic updates.
256 | Send only secure dynamic updates.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Tip Image Tip

To find other registry entries related to DNS dynamic update, type "dynamic update" on the Search tab in this file.

Related Entries

DefaultRegistrationTTL

EnableAdapterDomainNameRegistration

DisableDynamicUpdate

DisableReplaceAddressesInConflicts

DisableReverseAddressRegistrations


UseDomainNameDevolution

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Description

Determines whether the DNS client performs name devolution.

By default, when a query fails for a name to which a primary DNS suffix has been attached, the DNS client drops the left-most label of the primary DNS suffix on each successive attempt, making the query more general. This is known as name devolution. For example, if the primary DNS suffix, ooo.aaa.reskit.com is attached to the name reskituser, and the query for reskituser.ooo.aaa.reskit.com fails, the DNS client devolves (drops the left-most label) the primary DNS suffix, and submits a query for reskituser.aaa.reskit.com. The DNS client devolves the primary DNS suffix on each attempt until the name is successfully resolved or the name to be submitted has fewer than two labels.

You can add this entry to the registry with a value of 0 to disable name devolution.

Value | Meaning
0 | Disable name devolution.
1 | Enable name devolution.

Change method

To disable name devolution, use Network and Dial-up Connections. Right-click the name of a connection, select Internet Protocol (TCP/IP), click Properties, click Advanced, click the DNS tab, and clear the Append parent suffixes of the primary DNS suffix check box.


Performance

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\

Description

The Tcpip\Performance subkey contains entries for the performance counter dynamic-link library (DLL) for the TCP/IP service. These values are used by the performance library to collect data for the performance counters that monitor the service. These entries are maintained by the system and should not be changed.

Activation method

To make changes to entries in this subkey effective, restart the Remote Registry Service or restart Windows 2000.

Tip Image Tip

Most entries that can appear in this subkey are described in the generic Performance subkey. The entries described here are specific to the Tcpip\Parameters subkey and have no effect unless they appear in this subkey.

Related Entries

Performance subkey


FriendlyNetworkInterfaceNames

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Performance

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether network adapters are listed by name or by number in performance monitoring tools, such as System Monitor.

Network adapters are represented by instances of the Network Interface performance object. By default, System Monitor displays the display name provided by the network adapter driver as the name of the instance.

In Windows NT 4.0 and earlier, Performance Monitor 4 numbered the instances of the Network Interface object, beginning with 2 (1 represents the loopback interface). The numbers represent the order in which the network interface drivers load.

To direct System Monitor to display numbers for the network adapters, instead of names, add this entry to the registry and set its value to 0.

Value | Meaning
0 | Numbers. System Monitor displays numbers to represent network adapters.
1 | Names. System Monitor displays the names of network adapters.

Activation method

To make changes to this entry effective, restart the Remote Registry Service or restart Windows 2000.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.


WINS

HKLM\SYSTEM\CurrentControlSet\Services\

Description

The Wins subkey stores configuration data for the Windows Internet Name Service (WINS).

WINS associates IP addresses to more familiar DNS and NetBios computer names. WINS enables users to find computer resources by their familiar names, instead of requiring them to use IP addresses.


Parameters

HKLM\SYSTEM\CurrentControlSet\Services\WINS\

Description

The Wins\Parameters subkey stores general configuration data for WINS, that is, configuration data that is not related to replicating the WINS database.

Windows Internet Name Service (WINS) associates IP addresses to more familiar DNS and NetBios computer names. WINS enables users to find computer resources by their familiar names, instead of requiring them to use IP addresses.


BackupDirPath

HKLM\SYSTEM\CurrentControlSet\Services\WINS\Parameters

Data type | Range | Default value
REG_SZ | Path | There is no default value for this entry.

Description

Specifies the directory where the backup of WINS database is performed.

This entry appears in the registry only when you use the WINS console to establish a database backup path.

Change method

To change the value of this entry, use the WINS console.

Caution Image Caution

If you administer Windows NT 3.51 servers from a computer running Windows 2000 or Windows NT Server 4.0, the data type of this entry might be set incorrectly to REG_EXPAND_SZ. See your Microsoft Product Support Services specialist for assistance.


BurstHandlingF

HKLM\SYSTEM\CurrentControlSet\Services\WINS\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether the WINS server uses burst handling. When using burst handling, the WINS server sends success responses to the clients whose requests are dropped.

The WINS server currently stores a maximum of 25,000 name registration and refresh queries in its queue before dropping queries.

Value | Meaning
0 | Burst handling is not enabled. The WINS server does not send success responses when client requests are dropped.
1 | Enables burst handling. The WINS server sends success responses to clients whose requests are dropped.

Burst handling attains temporary steady state on the WINS server when the WINS server is started with an empty database, or when many WINS clients log on for the first time. These situations cause a large amount of traffic due to name registration and name refresh operations.

Because success responses have fixed time-to-live values (TTLs), they slow the refresh rate of new WINS clients and regulate the burst of WINS client traffic. As a result, a steady state is reached much more quickly.

Change method

To change the value of this entry, use the WINS console. In WINS server properties, click the Advanced tab. This entry corresponds to the Enable burst handling check box.


ConsistencyCheck

HKLM\SYSTEM\CurrentControlSet\Services\WINS\Parameters\

Description

The WINS ConsistencyCheck subkey is an optional subkey that you can add to the registry to direct WINS to perform periodic database consistency checks. Typically, consistency checks are not performed because they consume a substantial amount of resources on both the WINS server and the network.

If you add this subkey, set the values to minimize the load on the network due to consistency checking. Consider the network topology and the number of WINS servers, WINS clients, and WAN/LAN links between WINS servers to determine acceptable values for these entries.

Change method

To enable periodic automated consistency checking, use the WINS console. In WINS server properties, click the Database Verification tab, click the Verify database consistency check box, and use the options to configure consistency checking.

Caution Image Caution

Consistency checking uses a significant amount of network resources and can consume substantial processor time on WINS servers.


MaxRecsAtATime

HKLM\SYSTEM\CurrentControlSet\Services\WINS\Parameters\ConsistencyCheck

Data type | Range | Default value
REG_DWORD | 1000 - total number of records | 30,000

Description

Specifies the maximum number of records replicated in each consistency check cycle.

WINS performs consistency checks on the records of one owner WINS server at a time. (The owner WINS server is the WINS server from which the record was replicated.) After checking an owner WINS server, the local WINS server checks the value of this entry, and if the number of records meets or exceeds this value, the WINS server stops checking records.

Change method

To enable periodic automated consistency checking, use the WINS console. In WINS server properties, click the Database Verification tab, click the Verify database consistency check box, and use the options to configure consistency checking.

Caution Image Caution

Consistency checking uses a significant amount of network resources and can consume substantial processor time on WINS servers.


SpTime

HKLM\SYSTEM\CurrentControlSet\Services\WINS\Parameters\ConsistencyCheck

Data type | Range | Default value
REG_SZ | Time in hh:mm:ss format | Default: 2:00:00 (2:00 a.m.)

Description

Specifies the time of day when the first WINS server database consistency check occurs. Thereafter, the WINS database is checked for consistency as frequently as is specified in the value of TimeInterval.

Change method

To change the value of this entry, use the WINS console. In WINS server properties, click the Database Verification tab. This entry corresponds to the Begin verifying at option.

Related Entries

SpTime

(<IP address of pull partner> subkey)


TimeInterval

HKLM\SYSTEM\CurrentControlSet\Services\WINS\Parameters\ConsistencyCheck

Data type | Range | Default value
REG_DWORD | 0x5460 - 0xFFFFFFFF seconds (6 hours or greater) | 0x15180 (86,400 seconds = 1 day)

Description

Determines how often the WINS server performs database consistency checks.

Change method

To change the value of this entry, use the WINS console. In WINS server properties, click the Database Verification tab. This entry corresponds to the Verify database consistency every [ n ] hours option.


UseRplPnrs

HKLM\SYSTEM\CurrentControlSet\Services\WINS\Parameters\ConsistencyCheck

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether WINS contacts only its replication partners when performing consistency checks. Limiting the scope of a consistency check to replication partners is recommended for networks with a large number of WINS servers.

Value | Meaning
0 | WINS contacts the owner WINS server. (The owner WINS server is the WINS server from which the record was replicated.)
1 | WINS only contacts its replication partners. If the owner of a record is a WINS replication partner, WINS contacts the owner WINS server. If the owner is not a replication partner, WINS contacts a WINS server selected randomly from its list of pull partners.

Change method

To change the value of this entry, use the WINS console. In WINS server properties, click the Database Verification tab. This entry corresponds to the Owner servers or Randomly selected partners options in the Verify against section.


DataFiles

HKLM\SYSTEM\CurrentControlSet\Services\WINS\Parameters\

Description

The Wins\Parameters\Datafiles subkey contains entries representing the files that the WINS server uses to initialize and reinitialize its local database. These files contain static records.

By default, this subkey does appear in the registry. However, you can add it to the registry and add entries to direct WINS to add static records in the specified data files to its database.

The entries in the Datafiles subkey have the following format:

Entry name | [Path\] File name
Data type | REG_SZ | REG_EXPAND_SZ
Value | (Blank)

The path is optional. If you do not enter a path, WINS assumes the files are located in the directory from which the WINS service runs. The file can have any name and file name extension.

Note Image Note

Windows 2000 does not add this subkey to the registry. You can add it by editing the registry or by using a program that edits the registry.


DbFileNm

HKLM\SYSTEM\CurrentControlSet\Services\WINS\Parameters

Data type | Range | Default value
REG_EXPAND_SZ | Path | %SystemRoot%\System32\Wins\wins.mdb

Description

Stores the full path to the WINS database file.

Change method

To change the value of this entry, use the WINS console. In WINS server properties, click the Advanced tab. This entry corresponds to the Database path box.

Note Image Note

This entry can also have the REG_SZ data type.


DoBackupOnTerm

HKLM\SYSTEM\CurrentControlSet\Services\WINS\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether the WINS database is backed up automatically when the WINS service stops.

Value | Meaning
0 | The WINS database is not backed up when the WINS service stops.
1 | The WINS database is backed up automatically when the WINS service stops.

Change method

To change the value of this entry, use the WINS console. In WINS server properties, click the General tab. This entry corresponds to the Back up database during server shutdown option.


DoStaticDataInit

HKLM\SYSTEM\CurrentControlSet\Services\WINS\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether the WINS server initializes its database.

Value | Meaning
0 | The WINS server does not initialize its database.
1 | The WINS server initializes its database.

If the value of this entry is 1, the WINS server initializes its database when the WINS process is started and whenever a value in the WINS\Parameters subkey or the WINS\Parameters\Datafiles subkey changes (unless the change is to set the value of DoStaticDataInit to 0). The database is initialized by using records specified in the WINS\Parameters\Datafiles subkey.


InitTimePause

HKLM\SYSTEM\CurrentControlSet\Services\WINS\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether WINS starts in the paused state and remains in that state until the first replication. In the paused state, WINS does not accept any name registrations, releases, or queries. WINS remains in the paused state until it has replicated with its partners or until its replication attempt has failed.

Value | Meaning
0 | WINS does not start in a paused state.
1 | WINS starts in the paused state.

Note Image Note

If the value of InitTimePause is 1, set the value of InitTimeReplication (Wins\Partners\Pull) to 1 or delete InitTimeReplication from the registry.


LogDetailedEvents

HKLM\SYSTEM\CurrentControlSet\Services\WINS\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Specifies the level of detail of events the WINS server writes to the System Log in Event Viewer.

Value | Meaning
0 | Errors only.
1 | Errors, warnings and informational messages.

Change method

To change the value of this entry, use the WINS console. On the Action menu, click Properties, and then click the Advanced tab. This entry corresponds to the Log detailed events to the Windows event log option.


LogFilePath

HKLM\SYSTEM\CurrentControlSet\Services\WINS\Parameters

Data type | Range | Default value
REG_EXPAND_SZ | Path | %SystemRoot%\System32\Wins

Description

Determines whether WINS automatically backs up its database, and specifies the location where the backups are stored.

If you enter a path in the value of this entry, WINS automatically backs up its database every three hours and stores the backup in the Jet.log file in the specified path. If you delete this entry or its value, WINS does not back up the database.

Change method

To change the value of this entry, use the WINS console. On the Action menu, click Properties, and then click the Advanced tab. This entry corresponds to the Log detailed events to Windows event log box.

Note Image Note

This entry can have a data type of REG_SZ or REG_EXPAND_SZ.


LoggingOn

HKLM\SYSTEM\CurrentControlSet\Services\WINS\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether database changes are recorded in a log file.

Value | Meaning
0 | Changes are not logged.
1 | Database changes are written to Jet.log.


McastIntvl

HKLM\SYSTEM\CurrentControlSet\Services\WINS\Parameters

Data type | Range | Default value
REG_DWORD | 0x960 - 0xFFFFFFFE seconds | 0xFFFFFFFF | 0x960 (2400 seconds = 40 minutes)

Description

Determines how often the WINS server sends a multicast message to announce its presence to other WINS servers. If the value of this entry is 0xFFFFFFFF, multicasting is disabled.

Value | Meaning
0x960 - 0xFFFFFFFE seconds | WINS sends multicasts at this interval.
0xFFFFFFFF | WINS does not send multicasts.

Related Entries

McastTtl

UseSelfFndPnrs


McastTtl

HKLM\SYSTEM\CurrentControlSet\Services\WINS\Parameters

Data type | Range | Default value
REG_DWORD | 1 - 32 hops | 2

Description

Specifies the maximum number of hops (steps between subnets) a WINS multicast announcement is permitted to perform. If the multicast attempts to perform more hops than permitted by the value of this entry, WINS returns an ICMP Time Exceeded error.

Change method

To change the value of this entry, you can use the WINS console. Right-click the Replication Partners node, click Properties, and then click the Advanced tab. This entry corresponds to the Multicast Time to Live (TTL) box.

Related Entries

McastIntv

UseSelfFndPnrs


MigrateOn

HKLM\SYSTEM\CurrentControlSet\Services\WINS\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines how the WINS server regards static database records that conflict with a new registration or replica.

Value | Meaning
0 | Unique and multihomed static records that conflict with a new registration or replica are still regarded as static records.
1 | If unique and multihomed static records conflict with a new registration or replica, they are treated as dynamic records.

Change method

To change the value of this entry, use the WINS console. Right-click the Replication Partners node, click Properties and then, from the General tab, select the Overwrite unique static mappings at this server (migrate on) box.


NoOfWorkThreads

HKLM\SYSTEM\CurrentControlSet\Services\WINS\Parameters

Data type | Range | Default value
REG_DWORD | 1 - 40 threads | (Number of processors on the computer.)

Description

Specifies the number of worker threads in the WINS process.

Activation method

Changes to this value take effect immediately. You do not need to restart WINS or restart the computer running the WINS service.


PriorityClassHigh

HKLM\SYSTEM\CurrentControlSet\Services\WINS\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines the priority class of the WINS server process. Setting the value of this entry to 1 ensures that other processes, such as electronic mail and other applications, do not preempt WINS.

Value | Meaning
0 | The WINS server runs in a normal priority class.
1 | WINS runs in high-priority class.


RefreshInterval

HKLM\SYSTEM\CurrentControlSet\Services\WINS\Parameters

Data type | Range | Default value
REG_DWORD | 0x960 - 0x7FFFFFFF seconds | 0x7E900 (6 days)

Description

Determines how often a client must refresh its name registration and how often the scavenging thread (which deletes extinct records) runs.

The scavenging thread begins running when half of the value of RefreshInterval has elapsed, at which point the client must refresh its name registrations.

For example, if the value of RefreshInterval is six days, the client must refresh its name registration every three days.

The WINS server adjusts the refresh interval to minimize the difference between the renewal interval of this WINS server and the renewal interval of its replication partners.

Change method

To change the value of this entry, use the Intervals tab on the WINS <Server-name> Properties dialog box. This entry corresponds to the Renew interval field.

Related Entries

TombstoneInterval

TombstoneTimeout

VerifyInterval


TombstoneInterval

HKLM\SYSTEM\CurrentControlSet\Services\WINS\Parameters

Data type | Range | Default value
REG_DWORD | 0x960 - 0x7FFFFFFF seconds | 0x54600 (4 days)

Description

Determines how long after WINS database entry is considered to be extinct that it is released.

The WINS server adjusts this value based on the value of RefreshInterval and, if the WINS server has replication partners, on the largest replication interval set for any partner. The value of TombstoneInterval must be at least twice the value of RefreshInterval.

Change method

To change the value of this entry, use the Intervals tab on the WINS <Server-name> Properties dialog box. This entry corresponds to the Extinction interval field.

Related Entries

RefreshInterval

TombstoneTimeout

VerifyInterval


TombstoneTimeout

HKLM\SYSTEM\CurrentControlSet\Services\WINS\Parameters

Data type | Range | Default value
REG_DWORD | 0x960 - 0x7FFFFFFF seconds | 0x7E900 (6 days)

Description

Determines how long after an entry is marked as extinct that it is deleted from the WINS database.

The WINS server adjusts this value based on the value of RefreshInterval and, if the WINS server has replication partners, on the longest replication interval set for any partner.

Change method

To change the value of this entry, use the Intervals tab on the WINS <Server-name> Properties dialog box. This entry corresponds to the Extinction time-out field.

Related Entries

RefreshInterval

TombstoneInterval

VerifyInterval


UseSelfFndPnrs

HKLM\SYSTEM\CurrentControlSet\Services\WINS\Parameters

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether the WINS server detects or ignores multicasts from other WINS servers.

Value | Meaning
0 | The WINS server ignores multicasts from other WINS servers on the network.
1 | The WINS server detects multicasts from other WINS servers.

If network routers support multicasting, the WINS server automatically finds other WINS servers on the network by listening for their multicasts (as defined by RFC1112) to the IP address 224.0.1.24. Any WINS servers found by accepting WINS multicasts are automatically configured as push and pull replication partners, with pull replication set to occur every two hours.

If network routers do not support multicasting, then even if the value of UseSelfFndPnrs is 1, the WINS server finds only WINS servers on its subnet.

By default, WINS maintains partnership data that is discovered through multicasting. A Microsoft WINS server that is discovered through multicasting is automatically removed as a replication partner when the WINS server shuts down successfully. However, if the WINS console has been used to change or view the found WINS server information, the partnership data is not removed.

Tip Image Tip

To disable WINS multicasting, set the value of McastIntvl to 0xFFFFFFFF.

Related Entries

McastTtl

McastIntv


VerifyInterval

HKLM\SYSTEM\CurrentControlSet\Services\WINS\Parameters

Data type | Range | Default value
REG_DWORD | 0x1FA400 - 0x7FFFFFFF seconds | 0x1FA400 (576 hours = 24 days) or 3 times the value of TombstoneInterval, whichever is greater.

Description

Specifies how long the WINS server is permitted to retain a name that it does not own before it must verify that the name is still active.

Change method

To change the value of this entry, use the Intervals tab on the WINS <Server-name> Properties dialog box. This entry corresponds to the Verification interval field.

Related Entries

RefreshInterval

TombstoneInterval

TombstoneTimeout


VersCounterStartVal_HighWord

HKLM\SYSTEM\CurrentControlSet\Services\WINS\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 7FFFFFFF | 0x0

Description

Stores the highest version identifier used in the WINS database. Each record in the WINS database has a version identifier. WINS uses this entry to determine how many records the WINS database contains.

Note Image Note

Version refers to the number of entries in the WINS database, not to the version number of the WINS database program.

Tip Image Tip

For more information on repairing a corrupted WINS database, see the Microsoft Knowledge Base link on the Web Resources page. Search the Knowledge Base for Article Q135405, or use the keywords repairing WINS database.

Related Entries

VersCounterStartVal_LowWord


VersCounterStartVal_LowWord

HKLM\SYSTEM\CurrentControlSet\Services\WINS\Parameters

Description

Stores the lowest version identifier used in the WINS database. Each record in the WINS database has a version identifier. WINS uses this entry to determine the starting record in the WINS database.

Note Image Note

Version refers to the number of entries in the WINS database, not to the version number of the WINS database program.

Tip Image Tip

For more information on repairing a corrupted WINS database, see the Microsoft Knowledge Base link on the Web Resources page. Search the Knowledge Base for Article Q135405, or use the keywords repairing WINS database.

Related Entries

VersCounterStartVal_HighWord


Partners

HKLM\SYSTEM\CurrentControlSet\Services\WINS\

Description

The Wins\Partners subkey contains entries that specify the properties of the WINS server and its replication partners.

The Partners subkey contains two subkeys, Pull and Push, which store entries for pull and push operations of the WINS server.

Change method

To display and change these values, use the WINS console whenever possible. Changes to these values are effective immediately; you do not have to restart WINS or Windows 2000. To see the changes reflected in your registry editor, refresh the display.

Related Entries

Push subkey

Pull subkey


PersonaNonGrata

HKLM\SYSTEM\CurrentControlSet\Services\WINS\Partners

Data type | Range | Default value
REG_MULTI_SZ | IP addresses | (Blank)

Description

Lists the IP addresses of Microsoft WINS servers whose records are excluded from the local database during replication.

You can use this entry to prevent incorrect records in the databases of WINS servers on your network from being replicated to your WINS server.

Change method

To change the value of this entry, use the Advanced tab on the Replication Partners Properties dialog box. This entry corresponds to the Block records for these owners list.

Activation method

Changes to these values are effective immediately; you do not have to restart WINS or Windows 2000. To see the changes reflected in your registry editor, refresh the display.


Pull

HKLM\SYSTEM\CurrentControlSet\Services\WINS\Partners\

Description

The Pull subkey contains entries that specify how and when replicas are pulled from push partners of the WINS server. These entries are stored at the root level of the Pull subkey and apply to all pull operations.

In addition to the entries stored in the Pull subkey, the Pull subkey contains subkeys representing each pull partner from which the WINS server can pull replicas. These subkeys, which are named by the IP address of the pull partner, store data that applies only to that pull partner. See IP address of pull partner subkey.

Change method

To display and change these values, use the WINS console whenever possible. Changes to these values are effective immediately; you do not have to restart WINS or Windows 2000. To see the changes reflected in your registry editor, refresh the display.

Related Entries

Push subkey

IP address of push partner subkey

IP address of pull partner subkey


<IP address of pull partner>

HKLM\SYSTEM\CurrentControlSet\Services\WINS\Partners\Pull\

Description

The Pull subkey contains one subkey for each pull partner from which the WINS server can pull replicas. The subkeys are named for the IP address of the pull partner. These subkeys contain data that is configured separately for each pull partner and applies only to that pull partner.

The <IP address of pull partner> subkey is a variable representing the IP address subkeys in the WINS\Partners\Pull subkey. It doesn't actually appear in the registry. This variable subkey display the entries and subkeys that are common to subkeys in the Pull subkey.

Change method

To display and change these values, use the WINS console whenever possible. Changes to these values are effective immediately; you do not have to restart WINS or Windows 2000. To see the changes reflected in your registry editor, refresh the display.


MemberPrecedence

HKLM\SYSTEM\CurrentControlSet\Services\WINS\Partners\Pull\<IP address of pull partner>

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines whether addresses in an Internet group pulled from a WINS partner are assigned a high or low precedence in the domain group. A high precedence indicates that a WINS partner is physically close.

Addresses in an Internet group are identified by the value 0x1C in the sixteenth byte of their NetBIOS name. Locally registered addresses always have a high precedence. Set the value of this entry to 1 if this WINS partner is serving a geographic location that is nearby.

Value | Meaning
0 | Low: Addresses in an Internet group (0x1C in the 16th byte) are assigned a low precedence.
1 | Addresses in an Internet group (0x1C in the 16th byte) are assigned a high precedence.


SpTime

HKLM\SYSTEM\CurrentControlSet\Services\WINS\Partners\Pull\<IP address of pull partner>

Data type | Range | Default value
REG_SZ | 00:00:00 - 23:59:59 (in hh:mm:ss format) | (Time of initialization + value of TimeInterval)

Description

Specifies the time of day at which the first replication occurs after the WINS server is initialized.

Thereafter, the WINS server replicates as often as is specified in the value of TimeInterval. If the time specified has already passed, the WINS server waits for the period specified by TimeInterval, and replicates when that time expires.

Change method

To change the value of this entry, use the WINS console. Right-click the Replication Partners node, click Properties and then click the Advanced tab. This entry corresponds to the Start time box.

Related Entries

TimeInterval

SpTime

(ConsistencyCheck subkey)


TimeInterval

HKLM\SYSTEM\CurrentControlSet\Services\WINS\Partners\Pull\<IP address of pull partner>

Data type | Range | Default value
REG_DWORD | 0x0 (or not configured) | 0x258 - 0xFFFFFFFF seconds | 0x708 (30 minutes)

Description

Determines how often the WINS server database is replicated. If the value of this entry is 0x0, or if this entry does not appear in the registry, the WINS server database is not replicated.

Value | Meaning
0 | The WINS server database is not replicated.
0x258 (10 minutes) - 0xFFFFFFFF seconds | Specifies the interval between replications.

Change method

To change the value of this entry, use the WINS console. Right-click the Replication Partners node, click Properties and then click the Advanced tab. This entry corresponds to the Replication interval box.


CommRetryCount

HKLM\SYSTEM\CurrentControlSet\Services\WINS\Partners\Pull

Data type | Range | Default value
REG_DWORD | 0 - 999 | 3

Description

Specifies the maximum number of times the WINS server tries to connect with a partner when pulling a replica when each attempt fails. The interval between attempts is specified by the value of InitTimeReplication.

Change method

To change the value of this entry, use the WINS console. Right-click the Replication Partners node, click Properties and then click the Pull Replication tab. This entry corresponds to the Number of retries box.

Related Entries

InitTimeReplication


InitTimeReplication

HKLM\SYSTEM\CurrentControlSet\Services\WINS\Partners\Pull

Description

Determines when the WINS server pulls replicas of new WINS database entries from its partners.

Value | Meaning
0 | Replication occurs only as often as specified in the value of TimeInterval.
1 | The WINS server pulls replicas of new WINS database entries from its partners when the system is initialized or when a replication-related parameter changes.

Change method

To change the value of this entry, use the WINS console. Right-click the Replication Partners node, click Properties and then click the Pull Replication tab. This entry corresponds to the Start pull replication at service startup option.

Related Entries

CommRetryCount

InitTimeReplication (Push subkey)


Push

HKLM\SYSTEM\CurrentControlSet\Services\WINS\Partners\

Description

The Push subkey contains entries that specify how and when the WINS server sends update notification messages to its push partners. These entries are stored at the root level of the Push subkey and apply to all push operations.

In addition to the entries stored in the Push subkey, the Push subkey contains one subkey representing each push partner to which the WINS server sends update notification messages. These subkeys, which are named by the IP address of the push partner, store data that applies only to that push partner. See IP address of push partner subkey.

Change method

To display and change these values, use the WINS console. In the console tree, click Replication Partners, on the Action menu, click Properties, and then click the Push Replication tab.

Activation method

Changes to these value in this subkey are effective immediately; you do not have to restart WINS or Windows 2000. To see the changes reflected in your registry editor, just refresh the display.

Related Entries

Pull subkey

IP address of push partner subkey

IP address of pull partner subkey


<IP address of push partner>

HKLM\SYSTEM\CurrentControlSet\Services\WINS\Partners\Push\

Description

The Push subkey contains one subkey for each push partner to which the WINS server sends update notification messages. The subkeys are named for the IP address of the push partner. These subkeys contain data that is configured separately for each push partner and applies only to that push partner.

The <IP address of push partner> subkey is a variable representing the IP address subkeys in the WINS\Partners\Push subkey. It doesn't actually appear in the registry. This variable subkey display the entries and subkeys that are common to subkeys in the Push subkey.


NetBIOSName

HKLM\SYSTEM\CurrentControlSet\Services\WINS\Partners\Push\<IP address of push partner>

Data type | Range | Default value
REG_SZ | Computer name | There is no default value for this entry.

Description

Specifies the NetBIOS computer name of the push partner.


OnlyDynRecs

HKLM\SYSTEM\CurrentControlSet\Services\WINS\Partners\Push\<IP address of push partner>

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Determines which records are replicated to the WINS database.

Value | Meaning
0 | All records (dynamic and static) are replicated.
1 | Only dynamically registered records are replicated to pull partners.

Note Image Note

In previous versions of this file, this entry was reported to be in another subkey. This is the correct location.


RplOnlyWCnfPnrs

HKLM\SYSTEM\CurrentControlSet\Services\WINS\Partners\Push\<IP address of push partner>

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether the WINS server replicates only with its push and pull partners.

Value | Meaning
0 | The WINS server can replicate with unlisted partners, as well as with its push and pull partners. The WINS server replicates with unlisted partners as a result of administrative action or when it receives an update notification.
1 | The WINS server replicates only with its push and pull partners (servers whose IP address appear either in the Push or Pull subkeys.)


UpdateCount

HKLM\SYSTEM\CurrentControlSet\Services\WINS\Partners\Push\<IP address of push partner>

Data type | Range | Default value
REG_DWORD | 0x14 - 0x8FFFFFF | 0xFFFFFFFF (An invalid value that is replaced when you configure push partners.)

Description

Determines the number of changes to the database before replication is triggered.


InitTimeReplication

HKLM\SYSTEM\CurrentControlSet\Services\WINS\Partners\Push

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether the WINS server notifies its replication partners of the status of its database when the system is initialized.

Value | Meaning
0 | No message is sent.
1 | The WINS server sends a database status message.

Change method

To change the value of this entry, use the WINS console. In the Replication Partners Properties dialog box, click the Push Replication tab, and then click the At service startup check box.

Activation method

Changes to these value in this subkey are effective immediately; you do not have to restart WINS or Windows 2000. To see the changes reflected in your registry editor, just refresh the display.

Related Entries

InitTimeReplication (Pull subkey)


PropNetUpdNtf

HKLM\SYSTEM\CurrentControlSet\Services\WINS\Partners\Push

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether the WINS server propagate push notices it receives from push partners to its pull partners.

Value | Meaning
0 | Push notices are not sent to pull partners.
1 | Push notices are sent to pull partners.

Activation method

Changes to these value in this subkey are effective immediately; you do not have to restart WINS or Windows 2000. To see the changes reflected in your registry editor, just refresh the display.


RplOnAddressChg

HKLM\SYSTEM\CurrentControlSet\Services\WINS\Partners\Push

Data type | Range | Default value
REG_DWORD | 0 | 1 | 1

Description

Determines whether the WINS server notifies its replication partners of the status of its database when an address in a mapping record changes.

Value | Meaning
0 | No message is sent.
1 | The WINS server sends a database status message.

Change method

To change the value of this entry, use the WINS console. In the Replication Partners Properties dialog box, click the Push Replication tab, and then click the When address changes check box.

Activation method

Changes to these value in this subkey are effective immediately; you do not have to restart WINS or Windows 2000. To see the changes reflected in your registry editor, just refresh the display.


Disk

HKLM\SYSTEM\

Description

The Disk subkey still appears in the registry of some computers that were upgraded from Windows NT 4.0 and earlier, but the contents are ignored by Windows 2000.

In Windows NT 4.0 and earlier, the Disk subkey contained information about all physical disk drives, logical partitions of disk drives, CD-ROM drives, and network drive mappings on the computer. In Windows 2000, the Disk subkey is eliminated and similar information is stored in HKLM\SYSTEM\MountedDevices.


MountedDevices

HKLM\SYSTEM\

Description

The NTFS file system stores its database of mounted devices in the MountedDevices subkey. This database associates persistent volume names with unique internal indentifiers for volumes. The internal identifier often includes the disk signature of the volume. This pairing enables NTFS to maintain the identity and persistent name of a volume, even when its variable device name changes.

NTFS uses the MountedDevices subkey to support mounted drives on all types of volumes, including removable drives and CD-ROM drives.

Note Image Note

The MountedDevices subkey replaces the HKLM\System\Disk subkey used in Windows NT 4.0 and earlier. However, its contents and use are changed for Windows 2000.


Select

HKLM\SYSTEM\

Description

The Select subkey contains entries that specify which control set is used to start the system. The entries record which control set was used to start the system this time, which control set will be used to start it next time, and which control sets have failed to start the system in the past.

Caution Image Caution

Do not change the value of this entry. The Select subkey is maintained by Windows 2000, and should not be changed by users.


Current

HKLM\SYSTEM\Select

Data type | Range | Default value
REG_DWORD | 0xN | 0xN

Description

Identifies the control set used to start the system this time. The control set identified by the value of this entry appears in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet. If the system started without error, Current and Default identify the same control set.

For example, if the value of this entry is 0x1, ControlSet001 is the CurrentControlSet.

Related Entries

CurrentControlSet subkey


Default

HKLM\SYSTEM\Select

Data type | Range | Default value
REG_DWORD | Control set number | There is no default value for this entry.

Description

Identifies the control set the system will use for the next startup, unless an error occurs or the user selects the LastKnownGood control set. If the system started without error, the current control set (indicated by Current) is the default.

For example, if the value of this entry is 0x1, then ControlSet001 is the default control set.


Failed

HKLM\SYSTEM\Select

Data type | Range | Default value
REG_DWORD | 0xN | 0xN

Description

Identifies the control set that was replaced by the LastKnownGood control set. The value of this entry is 0x0 unless the LastKnownGood control set was used to start the system.

For example, if the value of this entry is 0x1, ControlSet001 failed and the LastKnownGood control set was used to start the system.


LastKnownGood

HKLM\SYSTEM\Select

Data type | Range | Default value
REG_DWORD | 0xN | 0xN

Description

Identifies a control set, other than the current one, that started the system successfully. The LastKnownGood control set is used as the current control set when a control set fails or the user select the LastKnownGood control set during the boot loader process.

For example, if the value of this entry is 0x1, the LastKnownGood control set is ControlSet001.


HKEY_USERS

HKU

Description

The HKEY_USERS subtree contains all actively loaded user profiles. HKEY_USERS has at least three keys.

  • .DEFAULT, which stores the profile used when no users are logged on to the computer (such as when the CTRL+ALT+DELETE logon prompt is displayed).
  • A subkey named for the Security Identifier (SID) of the current local user. This subkey contains the current user's profile. If the user is logged on remotely, the data for their profile is stored in the registry of their local computer. The data in HKEY_USERS\<SID> also appears in HKEY_CURRENT_USER.
  • A subkey named for the Security Identifier (SID) of the current local user with the _Classes suffix. This subkey contains the current user's Classes. The data in HKEY_USERS\<SID>\_Classes is also contained in HKEY_CLASSES_ROOT.

In Windows 2000 the default user profile is not stored in the registry. It is stored on the system drive in \Documents and Settings\Default User [WINNT]\Ntuser.dat.


IdleAckDelay

HKLM\SOFTWARE\Microsoft\MSMQ\Parameters

Data type | Range | Default value
REG_DWORD | 0x0 - 0xFFFFFFFF milliseconds | (Message Queuing calculates a value for this entry dynamically.)

Description

Determines the length of time Message Queuing waits for internal message acknowledgement of a network session before deciding that the session should be closed.

By default, Message Queuing calculates an optimal acknowledgment timeout based on the quality of the communication line. However, you can add this entry to the registry and set it to a different value to override the result of the calculation.

Note Image Note

Windows 2000 does not add this entry to the registry. You can add it by editing the registry or by using a program that edits the registry.

Caution Image Caution

Adding this entry to the registry prevents the system from using an optimal value calculated for each line. If you set the value of this entry too low, sessions can be disconnected before any messages are delivered.


DisallowCpl

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\

Description

The DisallowCpl subkey contains a list of Control Panel programs and folders that are hidden by a policy. This list is used only when the value of the DisallowCpl entry is 1.

This subkey stores the setting of the Show Contents box in the Hide specified control panel applets Group Policy. Group Policy adds this subkey and its entries to the registry when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes this subkey and its entries from the registry.

When an entry representing a program or folder appears in this subkey, the system removes its icon from the Start menu and from the Control Panel window. The entry removes the icon only. It does not prevent the user from running the program.

Each entry in this subkey represents a Control Panel program, such as Display, or a folder, such as Fonts. Entries are listed in alphabetical order based on the program name. The number that names this entry only represents the order. It does not affect the feature.

The entries have the following format. Programs must end in the .cpl file name extension.

Item-number REG_SZ Control Panel item

For example, the following entry removes the icon representing the Display program from Control Panel.

1 REG_SZ Desk.cpl

The following entry removes the icon representing the Fonts folder from Control Panel.

1 REG_SZ Fonts

Change method

To change the value of entries in this subkey, use Group Policy. This subkey corresponds to the Show Contents box in the Hide specified control panel applets policy (User Configuration\Administrative Templates\Control Panel).

Note Image Note

There is also a DisallowCpl entry which enables the Hide specified control panel applets policy. If the DisallowCpl entry is not in the registry, or if its value is 0, the policy is not enabled, and the system ignores the DisallowCpl subkey and its entries.

The Hide specified control panel applets policy takes precedence over the Show only specified control panel applets policy. If the same Control Panel item appears in both the DisallowCpl subkey and the RestrictCpl subkey, the item is hidden, and the entry in the RestrictCpl subkey is ignored.

Tip Image Tip

To find the file name of a Control Panel item, search for files with the .cpl file name extension in the Systemroot\System32 directory.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

NoDispCPL

DisallowCpl (subkey)

RestrictCpl (entry)

RestrictCpl (subkey)


RestrictCpl

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\

Description

The RestrictCpl subkey stores a list of selected Control Panel items that are displayed while a policy hides all other Control Panel items. This list is used only when the value of the RestrictCpl entry is 1.

This subkey stores the setting of the Show Contents box in the Show only specified control panel applets Group Policy. Group Policy adds this subkey and its entries to the registry when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes this subkey and its entries from the registry.

The Show only specified control panel applets policy hides all Control Panel items and folders except those represented by entries in this subkey. When hidden, the icons representing Control Panel programs and folders do not appear on the Start menu or in the Control Panel window.

Each entry in this subkey represents a Control Panel program, such as Display, or folder, such as Fonts. Entries are listed in alphabetical order of the program name. The number that names this entry only represents the order. It does not affect the feature.

The entries have the following format. Control Panel program names must end in the .cpl file name extension.

Item-number REG_SZ Control Panel item name

For example, the following entry displays the icon representing the Mouse program.

1 REG_SZ Main.cpl

The following entry displays the icon representing the Fonts folder.

1 REG_SZ Fonts

Change method

To change the value of the entries in this subkey, use Group Policy. These entries correspond to the Show Contents box in the Show only specified control panel applets policy (User Configuration\Administrative Templates\Control Panel).

Note Image Note

The Show only specified control panel applets policy only affects the display of icons. It does not prevent any Control Panel programs from running.

There is also a RestrictCpl entry which enables the Show only specified control panel applets policy. If the RestrictCpl entry is not in the registry, or if its value is 0, the policy is not enabled, and the system ignores the RestrictCpl subkey and its entries.

If the value of RestrictCpl is 1, but this subkey does not appear in the registry or contain valid entries, then the Control Panel window is empty.

The Hide specified control panel applets policy takes precedence over the Show only specified control panel applets policy. If the same Control Panel item appears in both the DisallowCpl subkey and the RestrictCpl subkey, the item is hidden, and the entry in the RestrictCpl subkey is ignored.

Tip Image Tip

To find the file name of a Control Panel item, search for files with the .cpl file name extension in the Systemroot\System32 directory.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

RestrictCpl (entry)

DisallowCpl subkey

DisallowCpl (entry)


RestrictRun

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Data type | Range | Default value
REG_DWORD | 0 | 1 | 0

Description

Limits the Windows programs that users can run on the computer. When the value of this entry is 1, users can only run programs represented by entries in the RestrictRun subkey.

This entry stores the setting of the Run only allowed Windows applications Group Policy. Group Policy adds this entry to the registry with a value of 1 when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes the entry from the registry, and the system behaves as though the value is 0.

Value | Meaning
0 (or not in registry) | Users can run all installed Windows programs.
1 | Users can only run programs represented by entries in the RestrictRun subkey.

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Run only allowed Windows applications policy (User Configuration\Administrative Templates\System).

Note Image Note

The RestrictRun subkey stores the names of Windows programs that restricted users can still run. If the subkey does not appear in the registry or does not contain any entries, then users cannot run any programs started by Windows Explorer.

This entry only prevents users from running programs that are started by the Windows Explorer process. It does not prevent users from running programs, such as Task Manager, which are started by the system process or by other processes. Also, if users have access to the command prompt, Cmd.exe, this policy does not prevent them from starting programs in the command window that they are not permitted to start by using Windows Explorer.

The Run only allowed Windows applications policy takes precedence over the Don't run specified Windows applications policy. If both policies are applied to the same user, the Run only allowed Windows applications policy is implemented and the Don't run specified Windows applications policy is ignored.

Tip Image Tip

To determine which processes started a program, use Tlist.exe, a tool included with the Windows 2000 Support Tools.

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Caution Image Caution

If you are the person who applies Group Policy, do not apply this policy to yourself. If applied too broadly, this policy can prevent administrators from running Group Policy or the registry editors. As a result, once applied, you cannot change this policy except by reinstalling Windows 2000.

Related Entries

DisallowRun

RestrictRun subkey


DisallowRun

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\

Description

The DisallowRun subkey contains a list of Windows programs that users cannot run. This list is used only when the value of the DisallowRun entry is 1.

This subkey stores the contents of the Show Contents box in the Don't run specified Windows applications Group Policy. Group Policy adds this subkey and its entries to the registry when you enable the policy. If you disable the policy or set it to Not configured, Group Policy deletes this subkey and its entries from the registry.

Each entry in this subkey represents a Windows program, such as Notepad, and contains the name of the executable file for the program, such as Notepad.exe. The number that names this entry only represents the order in which the programs are entered. It does not affect the feature.

These entries have the following format. All entries must include the file name extension of the file.

Item-number REG_SZ Name of executable file

For example, the following entry permits restricted users to use Microsoft Word (Winword.exe).

1 REG_SZ Winword.exe

Change method

To change the value of this entry, use Group Policy. This entry corresponds to the Don't run specified Windows applications policy (User Configuration\Administrative Templates\System).

Note Image Note

The DisallowRun entry enables the Don't run specified Windows applications policy. If the DisallowRun entry is not in the registry, or if its value is 0, the policy is not enabled, and the system ignores the DisallowRun subkey and its entries.

This entry only prevents users from running programs that are started by the Windows Explorer process. It does not prevent users from running programs such as Task Manager, which are started by the system process or by other processes. Also, if users have access to the command prompt, Cmd.exe, this policy does not prevent them from starting programs in the command window that they are not permitted to start by using Windows Explorer.

The Run only allowed Windows applications policy takes precedence over the Don't run specified Windows applications policy. If both policies are applied to the same user, the Run only allowed Windows applications policy is implemented and the Don't run specified Windows applications policy is ignored.

Tip Image Tip

For detailed information about particular Group Policy settings, see the Group Policy Reference (Gp.chm) on the Windows 2000 Resource Kit companion CD.

For general information about Group Policy, see Group Policy in Windows 2000 Help.

To see a table associating policies with their corresponding registry entries, see the Group Policy Reference Table.

Related Entries

RestrictRun subkey


Repl topology update period (secs)

HKLM\SYSTEM\CurrentControlSet\Services\NTDS\Parameters

Data type | Range | Default value
REG_DWORD | 0x20 - 0xFFFFFFFF seconds | 0x384 (900 seconds = 15 minutes)

Description

Allows the administrator to modify the interval at which the Knowledge Consistency Checker performs a review of the topology.

By default, as long as services are running, the Knowledge Consistency Checker reviews the topology every 15 minutes and makes changes as necessary.


Calendar Table

Windows 2000 Calendar Table

ID | Calendar
1 | Gregorian (localized)
2 | Gregorian (U.S.)
3 | Era: Year of the Emperor (Japan)
4 | Era: Year of Taiwan
5 | Tangun Era (Korea)
6 | Hijri (Arabic Lunar)
7 | Thai
8 | Hebrew (Lunar)
9 | Gregorian (Middle East) French
10 | Gregorian Arabic
11 | Gregorian transliterated English
12 | Gregorian transliterated French


Copyright

Information in this document, including URL and other Internet Web site references, is subject to change without notice. Unless otherwise noted, the example companies, organizations, products, people, and events depicted herein are fictitious and no association with any real company, organization, product, person, or event is intended or should be inferred. Complying with all applicable copyright laws is the responsibility of the user. Without limiting the rights under copyright, no part of this document may be reproduced, stored in or introduced into a retrieval system, or transmitted in any form or by any means (electronic, mechanical, photocopying, recording, or otherwise), or for any purpose, without the express written permission of Microsoft Corporation.

Microsoft may have patents, patent applications, trademarks, copyrights, or other intellectual property rights covering subject matter in this document. Except as expressly provided in any written license agreement from Microsoft, the furnishing of this document does not give you any license to these patents, trademarks, copyrights, or other intellectual property.

© 2000 Microsoft Corporation. All rights reserved.

Microsoft, MS-DOS, Windows, Windows NT, and other names of Microsoft products and/or services referenced herein are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries/regions.

The names of actual companies and products mentioned herein may be the trademarks of their respective owners. NT is a trademark of Northern Telecom Limited.

Any RFC excerpts are subject to the following statement:

Copyright © The Internet Society (1999). All Rights Reserved. This document and translations of it may be copied and furnished to others, and derivative works that comment on or otherwise explain it or assist in its implementation may be prepared, copied, published and distributed, in whole or in part, without restriction of any kind, provided that the above copyright notice and this paragraph are included on all such copies and derivative works. However, this document itself may not be modified in any way, such as by removing the copyright notice or references to the Internet Society or other Internet organizations, except as needed for the purpose of developing Internet standards in which case the procedures for copyrights defined in the Internet Standards process must be followed, or as required to translate it into languages other than English. The limited permissions granted above are perpetual and will not be revoked by the Internet Society or its successors or assigns. This document and the information contained herein is provided on an "AS IS" basis and THE INTERNET SOCIETY AND THE INTERNET ENGINEERING TASK FORCE DISCLAIMS ALL WARRANTIES, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO ANY WARRANTY THAT THE USE OF THE INFORMATION HEREIN WILL NOT INFRINGE ANY RIGHTS OR ANY IMPLIED WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE.


Day, Month, Year and Time Format

sLongDate, sShortDate, and sTimeFormat will all recognize any combination of the following values, all of which are case-sensitive.

Text

All strings should be surrounded by single quotes, and any single quotes should be entered as four single quotes in a row:

Value | Example
it''''s | it's
'Today is 'M/dd/yy' and it''''s 'h:mm | Today is 01/22/99 and it's 8:18

Day

The day can be displayed in one of four formats using a lowercase "d".

Value | Meaning | Example
d | Day of the month as digits without leading zeros for single digit days. | 5
dd | Day of the month as digits with leading zeros for single digit days. | 05
ddd | Day of the week as a three letter abbreviation. | Mon
dddd | Day of the week as its full name. | Monday

Month

The month can be displayed in one of four formats using capital "M". The letter "M" must be uppercase to distinguish months from minutes.

Value | Meaning | Example
M | Month as digits without leading zeros for single digit months. | 1
MM | Month as digits with leading zeros for single digit months. | 01
MMM | Month as a three letter abbreviation. | Jan
MMMM | Month as its full name. | January

Year

The year can be displayed in one of three formats using lowercase "y".

Value | Meaning | Example
y | Year represented only by the last digit, if the year is less than 10. Years greater than 10 will be given the value of yy. | 9
yy | Year represented only by the last two digits. | 09
yyyy | Year represented by the full 4 digits. | 1909

Period/Era

The period/era string can be displayed in a single format using the letter "g". The letter "g" must be lowercase. If you include the gg in a date string that does not have any associated Era string, the gg will be ignored.

Value | Meaning
(Null) | Gregorian dates are used. Does nothing if Gregorian is value of iCalendarType
gg | Period/era string. This is used by Windows to calculate the year when an optional calendar is selected. See iCalendarType for optional Calendars.

Time

The time can be displayed in one of many formats using the letter "h" or "H" to denote hours, the letter "m" to denote minutes, the letter "s" to denote seconds and the letter "t" to denote the time marker. The lowercase "h" denotes the 12 hour clock and uppercase "H" denotes the 24 hour clock. The "m" must be lowercase to denote minutes as opposed to Months. The "s" for seconds and "t" for the time marker string must also be lowercase.

Value | Meaning | Example
h | Hours without leading zeros for single digit hours (12 hour clock). | 1
hh | Hours with leading zeros for single digit hours (12 hour clock). | 01
H | Hours without leading zeros for single digit hours (24 hour clock). | 1
HH | Hours with leading zeros for single digit hours (24 hour clock). | 01
m | Minutes without leading zeros for single digit minutes. | 9
mm | Minutes with leading zeros for single digit minutes. | 09
s | Seconds without leading zeros for single digit seconds. | 5
ss | Seconds with leading zeros for single digit seconds. | 05
t | One character time marker string. This will be the first letter of the values in the AM symbol or PM symbol boxes in Regional Options as determined by the vales of s1159 or s2359. | A
tt | Multi-character time marker string. This will be values in the AM symbol or PM symbol boxes in Regional Options as determined by the vales of s1159 or s2359. | AM


Windows 2000 Registry: Entry

Entry

Entries are the lowest level element in the registry. They appear in the right pane of a registry editor window. Each entry consists of an entry name, its data type, and its value.

Entries store the actual configuration data that affects the operating system and programs that run on the system. As such, they are different from keys and subkeys, which are merely containers.

Entries are referenced by their registry path and name. The amount and type of data that can be stored in an entry is determined by the data type of the entry.


Windows 2000 Registry: Key

Key

Keys are the first division of a subtree. Keys contain subkeys and entries.


Windows 2000 Registry: Subkey

Subkey

Subkeys are children of keys. All registry folder contained in keys are called subkeys. Subkeys can contain entries and other subkeys.


Windows 2000 Registry: Subtree

Subtree

A subtree is a root, or primary division, of the registry.

The Windows 2000 registry is divided into five subtrees. These subtrees appear as windows in Regedt32, and as folders in Regedit. Subtrees do not contain configuration data; they contain the keys and subkeys in which the data is stored.

To see a description, click the name of a subtree.

  • HKEY_CLASSES_ROOT
  • HKEY_CURRENT_USER
  • HKEY_LOCAL_MACHINE
  • HKEY_USERS
  • HKEY_CURRENT_CONFIG


Windows 2000 Resource Kit Registry Disclaimer Page

Disclaimer

Although we make every effort to be timely and accurate, the registry is part of the Windows 2000 internal programming code and is therefore subject to change at any time. Possible discrepancies include changes in the locations of the entries, the default values, the range, the use of the data, and its content. See the Windows 2000 Resource Kits Web site for updates and corrections.

Registry Caution

Do not use a registry editor to edit the registry directly unless you have no alternative. The registry editors bypass the standard safeguards provided by administrative tools. These safeguards prevent you from entering conflicting settings or settings that are likely to degrade performance or damage your system. Editing the registry directly can have serious, unexpected consequences that can prevent the system from starting and require that you reinstall Windows 2000. To configure or customize Windows 2000, use the programs in Microsoft Management Console or Control Panel whenever possible.

© Copyright 1985-2000 Microsoft Corporation. All rights reserved.


Windows 2000 Resource Kit: Core Networking Guide Online Book

Resource Kit Component Not Installed

The Windows 2000 Resource Kit component you attempted to reach is not installed on your computer.

Click the Back button to return to the previous topic.

© Copyright 1985-2000 Microsoft Corporation. All rights reserved.


Technical Reference to the Windows 2000 Registry Search Tips Page

Technical Reference to the Registry

How to Find a Registry Entry

The Technical Reference to the Windows 2000 Registry is designed to look and operate like Regedit, a Windows registry editor included in the operating system. Registry elements appear in this file in their registry path, just as they do in Regedit.

To find the description of a registry subtree, key, subkey, or entry, click the books and pages in the table of contents pane. A description of each element appears in the contents pane. For example, to find a description of the DNS service subkey, click the HKEY_LOCAL_MACHINE, SYSTEM, CurrentControlSet, Services, and DNS folders, just as you do in Regedit.

How to Search

If you do not know where in the registry a certain element appears, use the Search tab.

How to Find Generic Subkeys

This file includes generic subkeys that, although they do not appear in the registry themselves, represent a group of subkeys with common characteristics. You can identify these generic subkeys by the brackets surrounding their names. For example, the entries that are common to most service subkeys appear in the <Service-name> subkey. If you are looking for a common entry and do not find it in the subkey in which it appears in your registry, look for a generic subkey. It usually appears first in the list of subkeys under a key.

Limitations of this Reference

If you cannot find a registry element, it might be because it is not included in this reference. The Technical Reference to the Windows 2000 Registry does not describe the entire registry. Some registry elements are specific to your registry. Others are part of the Windows internal code and are not meaningful to users. Many entries just store values you have set in Windows. This reference primarily documents entries that users might need to change that cannot be changed by using the Windows interface or the administrative tools provided with Windows.

© Copyright 1985-2000 Microsoft Corporation. All rights reserved.


Group Policy Registry Reference

Group Policy Registry Table

Group Policy, a Windows 2000 administrative tool, determines how programs, network resources, and the operating system behave for users and computers in an organization. Group Policy uses Group Policy Objects in Active Directory, and affects computers and users by adding, deleting, and changing the values of entries in the Windows 2000 registry.

The following table displays the Group Policy settings in the Administrative Templates folder and the registry entries that they change. The policies are listed in alphabetical order.

For information about the registry entry, click the entry name in the table. For information about the Group Policy settings, click the name of the policy.

caution-icon Caution

To change the value of entries in this table, use Group Policy. Do not edit the registry.

Group Policy | Registry entry
Action on server disconnect (Computer) (Computer Configuration\Administrative Templates\Network\Offline Files) | GoOfflineAction (HKLM) (HKLM\Software\Policies\Microsoft\Windows\NetCache)
Action on server disconnect (User) (User Configuration\Administrative Templates\Network\Offline Files) | GoOfflineAction (HKCU) (HKCU\Software\Policies\Microsoft\Windows\NetCache)
Active Desktop Wallpaper (User Configuration\AdministrativeTemplates\Desktop\Active Desktop) | Wallpaper, WallpaperStyle (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System)
Active Directory Domains and Trusts (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{EBC53A38-A23F-11D0-B09B-00C04FD8DCA6})
Active Directory Sites and Services (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{D967F824-9968-11D0-B936-00C04FD8D5B0})
Active Directory Users and Computers (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{E355E538-1C2E-11D0-8C37-00C04FD8FE93})
Add "Run in Separate Memory Space" check box to Run dialog box (User Configuration\AdministrativeTemplates\Start Menu & Taskbar) | MemCheckBoxInRunDlg (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Add Logoff to the Start Menu (User Configuration\AdministrativeTemplates\Start Menu & Taskbar) | ForceStartMenuLogOff (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Add/Delete items (User Configuration\AdministrativeTemplates\Desktop\Active Desktop) | Add, Delete (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop)
Administrative Templates (Computer) (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins\Group Policy) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{0F6B957D-509E-11D1-A7CC-0000F87571E3})
Administrative Templates (User) (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins\Group Policy) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{0F6B957E-509E-11D1-A7CC-0000F87571E3})
Administratively assigned offline files (Computer) (Computer Configuration\Administrative Templates\Network\Offline Files) | AssignedOfflineFolders subkey (HKLM) (HKLM\Software\Policies\Microsoft\Windows\NetCache\AssignedOfflineFolders)
Administratively assigned offline files (User) (User Configuration\Administrative Templates\Network\Offline Files) | AssignedOfflineFolders subkey (HKCU) (HKCU\Software\Policies\Microsoft\Windows\NetCache\AssignedOfflineFolders)
Allow access to current user's RAS connection properties (User Configuration\Administrative Templates\Network\Network and Dial-up Connections) | NC_RasMyProperties (HKCU\Software\Policies\Microsoft\Windows\Network Connections)
Allow admin to install from Terminal Services session (Computer Configuration\Administrative Templates\Windows Components\Windows Installer) | EnableAdminTSRemote (HKLM\Software\Policies\Microsoft\Windows\Installer)
Allow configuration of connection sharing (Computer) (Computer Configuration\Administrative Templates\Network\Network and Dial-up Connections) | NC_ShowSharedAccessUI (HKLM) (HKLM\Software\Policies\Microsoft\Windows\Network Connections)
Allow configuration of connection sharing (User) (User Configuration\Administrative Templates\Network\Network and Dial-up Connections) | NC_ShowSharedAccessUI (HKCU) (HKCU\Software\Policies\Microsoft\Windows\Network Connections)
Allow connection components to be enabled or disabled (User Configuration\Administrative Templates\Network\Network and Dial-up Connections) | NC_ChangeBindState (HKCU\Software\Policies\Microsoft\Windows\Network Connections)
Allow only bitmapped wallpaper (User Configuration\AdministrativeTemplates\Desktop\Active Desktop) | NoHTMLWallPaper (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop)
Allow printers to be published (Computer Configuration\Administrative Templates\Printers) | PublishPrinters (HKLM\Software\Policies\Microsoft\Windows NT\Printers)
Allow pruning of published printers (Computer Configuration\Administrative Templates\Printers) | Immortal (HKLM\Software\Policies\Microsoft\Windows NT\Printers)
Allow TCP/IP advanced configuration (User Configuration\Administrative Templates\Network\Network and Dial-up Connections) | NC_AllowAdvancedTCPIPConfig (HKCU\Software\Policies\Microsoft\Windows\Network Connections)
Always install with elevated privileges (Computer) (Computer Configuration\Administrative Templates\Windows Components\Windows Installer) | AlwaysInstallElevated (HKLM) (HKLM\Software\Policies\Microsoft\Windows\Installer)
Always install with elevated privileges (User) (User Configuration\Administrative Templates\Windows Components\Windows Installer) | AlwaysInstallElevated (HKCU) (HKCU\Software\Policies\Microsoft\Windows\Installer)
AppleTalk Routing (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins\Extension snap-ins) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{1AA7F83C-C7F5-11D0-A376-00C04FC9DA04})
Apply Group Policy for computers asynchronously during startup (Computer Configuration\Administrative Templates\System\Group Policy) | SynchronousMachineGroupPolicy (HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System)
Apply Group Policy for users asynchronously during logon (Computer Configuration\Administrative Templates\System\Group Policy) | SynchronousUserGroupPolicy (HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System)
Apply policy to removable media (Computer Configuration\Administrative Templates\System\Disk Quotas) | ApplyToRemovableMedia (HKLM\Software\Policies\Microsoft\Windows NT\DiskQuota)
At logoff, delete local copy of user’s offline files (Computer Configuration\Administrative Templates\Network\Offline Files) | PurgeAtLogoff (HKLM\Software\Policies\Microsoft\Windows\NetCache)
Automatically publish new printers in Active Directory (Computer Configuration\Administrative Templates\Printers) | Auto Publishing (HKLM\Software\Policies\Microsoft\Windows NT\Printers\Wizard)
Browse a common web site to find printers (User Configuration\Administrative Templates\Control Panel\Printers) | Printers Page URL (HKCU\Software\Policies\Microsoft\Windows NT\Printers\Wizard)
Browse the network to find printers (User Configuration\Administrative Templates\Control Panel\Printers) | Downlevel Browse (HKCU\Software\Policies\Microsoft\Windows NT\Printers\Wizard)
Cache transforms in secure location on workstation (Computer Configuration\Administrative Templates\Windows Components\Windows Installer) | TransformsSecure (HKLM\Software\Policies\Microsoft\Windows\Installer)
Century interpretation for Year 2000 (User Configuration\Administrative Templates\System) | <Calendar-ID> (HKCU\Software\Policies\Microsoft\Control Panel\International\Calendars\TwoDigitYearMax)
Certificates (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{53D6AB1D-2488-11D1-A28C-00C04FB94F17})
Certification Authority (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins\Extension snap-ins) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{3F276EB4-70EE-11D1-8A0F-00C04FB93753})
Check published state (Computer Configuration\Administrative Templates\Printers) | VerifyPublishedState (HKLM\Software\Policies\Microsoft\Windows NT\Printers)
Clear history of recently opened documents on exit (User Configuration\AdministrativeTemplates\Start Menu & Taskbar) | ClearRecentDocsOnExit (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Code signing for device drivers (User Configuration\Administrative Templates\System) | BehaviorOnFailedVerify (HKCU\Software\Policies\Microsoft\Windows NT\Driver Signing)
Component Services (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{C9BC92DF-5B9A-11D1-8F00-00C04FC2C17B})
Computer location (Computer Configuration\Administrative Templates\Printers) | PhysicalLocation (HKLM\Software\Policies\Microsoft\Windows NT\Printers)
Computer Management (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{58221C67-EA27-11CF-ADCF-00AA00A80033})
Connect home directory to root of the share (User Configuration\Administrative Templates\System\Logon/Logoff) | ConnectHomeDirToRoot (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System)
Connection Sharing (NAT) (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins\Extension snap-ins) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{C2FE450B-D6C2-11D0-A37B-00C04FC9DA04})
Create new Group Policy Object links disabled by default (User Configuration\Administrative Templates\System\Group Policy) | NewGPOLinksDisabled (HKCU\Software\Policies\Microsoft\Windows\Group Policy Editor)
Custom support URL in the Printers folder's left pane (Computer Configuration\Administrative Templates\Printers) | SupportLink, SupportLinkName (HKLM\Software\Policies\Microsoft\Windows NT\Printers)
Custom user interface (User Configuration\Administrative Templates\System) | Shell (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System)
DCOM Configuration Extension (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins\Extension snap-ins) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{9EC88934-C774-11d1-87F4-00C04FC2C17B})
Default Active Directory path when searching for printers (User Configuration\Administrative Templates\Control Panel\Printers) | Default Search Scope (HKCU\Software\Policies\Microsoft\Windows NT\Printers\Wizard)
Default cache size (Computer Configuration\Administrative Templates\Network\Offline Files) | DefCacheSize (HKLM\Software\Policies\Microsoft\Windows\NetCache)
Default quota limit and warning level (Computer Configuration\Administrative Templates\System\Disk Quotas) | Limit, LimitUnits, Threshold, ThresholdUnits (HKLM\Software\Policies\Microsoft\Windows NT\DiskQuota)
Delete cached copies of roaming profiles (Computer Configuration\Administrative Templates\System\Logon) | DeleteRoamingCache (HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System)
Device Manager (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{90087284-d6d6-11d0-8353-00a0c90640bf})
Device Manager (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins\Extension snap-ins) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{74246bfc-4c96-11d0-abef-0020af6b0b7a})
DHCP Relay Management (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins\Extension snap-ins) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{C2FE4502-D6C2-11D0-A37B-00C04FC9DA04})
Directory pruning interval (Computer Configuration\Administrative Templates\Printers) | PruningInterval (HKLM\Software\Policies\Microsoft\Windows NT\Printers)
Directory pruning priority (Computer Configuration\Administrative Templates\Printers) | PruningPriority (HKLM\Software\Policies\Microsoft\Windows NT\Printers)
Directory pruning retry (Computer Configuration\Administrative Templates\Printers) | PruningRetries (HKLM\Software\Policies\Microsoft\Windows NT\Printers)
Disable "Make Available Offline" (Computer) (Computer Configuration\Administrative Templates\Network\Offline Files) | NoMakeAvailableOffline (HKLM) (HKLM\Software\Policies\Microsoft\Windows\NetCache)
Disable "Make Available Offline" (User) (User Configuration\Administrative Templates\Network\Offline Files) | NoMakeAvailableOffline (HKCU) (HKCU\Software\Policies\Microsoft\Windows\NetCache)
Disable Active Desktop (User Configuration\AdministrativeTemplates\Desktop\Active Desktop) | NoActiveDesktop (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Disable Add/Remove Programs (User Configuration\Administrative Templates\Control Panel\Add/Remove Programs) | NoAddRemovePrograms (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall)
Disable adding, dragging, dropping and closing the Taskbar's toolbars (User Configuration\AdministrativeTemplates\Desktop) | NoCloseDragDropBands (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Disable addition of printers (User Configuration\Administrative Templates\Control Panel\Printers) | NoAddPrinter (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Disable adjusting desktop toolbars (User Configuration\AdministrativeTemplates\Desktop) | NoMovingBands (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Disable Advanced Menu (Computer) (Computer Configuration\Administrative Templates\Windows Components\Task Scheduler) | Disable Advanced (HKLM) (HKLM\Software\Policies\Microsoft\Windows\Task Scheduler5.0)
Disable Advanced Menu (User) (User Configuration\Administrative Templates\Windows Components\Task Scheduler) | Disable Advanced (HKCU) (HKCU\Software\Policies\Microsoft\Windows\Task Scheduler5.0)
Disable all items (User Configuration\AdministrativeTemplates\Desktop\Active Desktop) | NoComponents (Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop)
Disable and remove links to Windows Update (User Configuration\AdministrativeTemplates\Start Menu & Taskbar) | NoWindowsUpdate (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Disable and remove the Shut Down command (User Configuration\AdministrativeTemplates\Start Menu & Taskbar) | NoClose (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Disable automatic update of ADM files (User Configuration\Administrative Templates\System\Group Policy) | DisableAutoADMUpdate (HKCU\Software\Policies\Microsoft\Windows\Group Policy Editor)
Disable Autoplay (User) (User Configuration\Administrative Templates\System) | NoDriveTypeAutoRun (HKCU) (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Disable Autoplay (Computer) (Computer Configuration\Administrative Templates\System) | NoDriveTypeAutoRun (HKLM) (HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Disable background refresh of Group Policy (Computer Configuration\Administrative Templates\System\Group Policy) | DisableBkGndGroupPolicy (HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System)
Disable Boot / Shutdown / Logon / Logoff status messages (Computer Configuration\Administrative Templates\System) | DisableStatusMessages (HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System)
Disable browse dialog box for new source (Computer Configuration\Administrative Templates\Windows Components\Windows Installer) | DisableBrowse (HKLM\Software\Policies\Microsoft\Windows\Installer)
Disable Change Password (User Configuration\Administrative Templates\System\Logon/Logoff) | Disable Change Password (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System)
Disable changes to Taskbar and Start Menu Settings (User Configuration\AdministrativeTemplates\Start Menu & Taskbar) | NoSetTaskbar (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Disable changing wallpaper (User Configuration\Administrative Templates\Control Panel\Display) | NoChangingWallPaper (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop)
Disable context menu for taskbar (User Configuration\AdministrativeTemplates\Start Menu & Taskbar) | NoTrayContextMenu (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Disable Control Panel (User Configuration\AdministrativeTemplates\Start Menu & Taskbar) | NoControlPanel (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Disable deletion of printers (User Configuration\Administrative Templates\Control Panel\Printers) | NoDeletePrinter (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Disable DFS tab (User Configuration\Administrative Templates\Windows Components\Windows Explorer) | NoDFSTab (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Disable Display in control panel (User Configuration\Administrative Templates\Control Panel\Display) | NoDispCPL (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System)
Disable Drag-and-Drop (Computer) (Computer Configuration\Administrative Templates\Windows Components\Task Scheduler) | DragAndDrop (HKLM) (HKLM\Software\Policies\Microsoft\Windows\Task Scheduler5.0)
Disable Drag-and-Drop (User) (User Configuration\Administrative Templates\Windows Components\Task Scheduler) | DragAndDrop (HKCU) (HKCU\Software\Policies\Microsoft\Windows\Task Scheduler5.0)
Disable drag-and-drop context menus on the Start Menu (User Configuration\AdministrativeTemplates\Start Menu & Taskbar) | NoChangeStartMenu (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Disable IE security prompt for Windows Installer scripts (Computer Configuration\Administrative Templates\Windows Components\Windows Installer) | SafeForScripting (HKLM\Software\Policies\Microsoft\Windows\Installer)
Disable legacy run list (Computer) (Computer Configuration\Administrative Templates\System) | DisableLocalMachineRun (HKLM) (HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Disable legacy run list (User) (User Configuration\Administrative Templates\System\Logon/Logoff) | DisableLocalMachineRun (HKCU) (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Disable Lock Computer (User Configuration\Administrative Templates\System\Logon/Logoff) | DisableLockWorkstation (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System)
Disable Logoff (User Configuration\Administrative Templates\System\Logon/Logoff) | NoLogoff (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Disable Logoff on the Start Menu (User Configuration\AdministrativeTemplates\Start Menu & Taskbar) | StartMenuLogOff (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Disable media source for any install (User Configuration\Administrative Templates\Windows Components\Windows Installer) | DisableMedia (HKCU\Software\Policies\Microsoft\Windows\Installer)
Disable New Task Creation (Computer) (Computer Configuration\Administrative Templates\Windows Components\Task Scheduler) | Task Creation (HKLM) (HKLM\Software\Policies\Microsoft\Windows\Task Scheduler5.0)
Disable New Task Creation (User) (User Configuration\Administrative Templates\Windows Components\Task Scheduler) | Task Creation (HKCU) (HKCU\Software\Policies\Microsoft\Windows\Task Scheduler5.0)
Disable patching (Computer Configuration\Administrative Templates\Windows Components\Windows Installer) | DisablePatch (HKLM\Software\Policies\Microsoft\Windows\Installer)
Disable personalized menus (User Configuration\AdministrativeTemplates\Start Menu & Taskbar) | Intellimenus (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Disable programs on Settings menu (User Configuration\AdministrativeTemplates\Start Menu & Taskbar) | NoSetFolders (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Disable registry editing tools (User Configuration\Administrative Templates\System) | DisableRegistryTools (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System)
Disable reminder balloons (Computer) (Computer Configuration\Administrative Templates\Network\Offline Files) | NoReminders (HKLM) (HKLM\Software\Policies\Microsoft\Windows\NetCache)
Disable reminder balloons (User) (User Configuration\Administrative Templates\Network\Offline Files) | NoReminders (HKCU) (HKCU\Software\Policies\Microsoft\Windows\NetCache\AssignedOfflineFolders)
Disable rollback (Computer) (Computer Configuration\Administrative Templates\Windows Components\Windows Installer) | DisableRollback (HKLM) (HKLM\Software\Policies\Microsoft\Windows\Installer)
Disable rollback (User) (User Configuration\Administrative Templates\Windows Components\Windows Installer) | DisableRollback (HKCU) (HKCU\Software\Policies\Microsoft\Windows\Installer)
Disable Support Information (User Configuration\Administrative Templates\Control Panel\Add/Remove Programs) | NoSupportInfo (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall)
Disable Task Deletion (Computer) (Computer Configuration\Administrative Templates\Windows Components\Task Scheduler) | Task Deletion (HKLM) (HKLM\Software\Policies\Microsoft\Windows\Task Scheduler5.0)
Disable Task Deletion (User) (User Configuration\Administrative Templates\Windows Components\Task Scheduler) | Task Deletion (HKCU) (HKCU\Software\Policies\Microsoft\Windows\Task Scheduler5.0)
Disable Task Manager (User Configuration\Administrative Templates\System\Logon/Logoff) | DisableTaskMgr (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System)
Disable the command prompt (User Configuration\Administrative Templates\System) | DisableCMD (HKCU\Software\Policies\Microsoft\Windows\System)
Disable the run once list (Computer) (Computer Configuration\Administrative Templates\System) | DisableLocalMachineRunOnce (HKLM) (HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Disable the run once list (User) (User Configuration\Administrative Templates\System\Logon/Logoff) | DisableLocalMachineRunOnce (HKCU) (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Disable UI to change keyboard navigation indicator setting (User Configuration\Administrative Templates\Windows Components\Windows Explorer) | NoChangeKeyboardNavigationIndicators (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Disable UI to change menu animation setting (User Configuration\Administrative Templates\Windows Components\Windows Explorer) | NoChangeAnimation (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Disable user configuration of Offline Files (Computer) (Computer Configuration\Administrative Templates\Network\Offline Files) | NoConfigCache (HKLM) (HKLM\Software\Policies\Microsoft\Windows\NetCache)
Disable user configuration of Offline Files (User) (User Configuration\Administrative Templates\Network\Offline Files) | NoConfigCache (HKCU) (HKCU\Software\Policies\Microsoft\Windows\NetCache)
Disable user tracking (User Configuration\AdministrativeTemplates\Start Menu & Taskbar) | NoInstrumentation (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Disable Windows Explorer's default context menu (User Configuration\Administrative Templates\Windows Components\Windows Explorer) | NoViewContextMenu (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Disable Windows Installer (Computer Configuration\Administrative Templates\Windows Components\Windows Installer) | DisableMSI (HKLM\Software\Policies\Microsoft\Windows\Installer)
Disk Defragmenter (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{43668E21-2636-11D1-A1CE-0080C88593A5})
Disk Management (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{8EAD3A12-B2C1-11d0-83AA-00A0C92C9D5D})
Disk Quota policy processing (Computer Configuration\Administrative Templates\System\Group Policy) | NoSlowLink, NoBackgroundPolicy, NoGPOListChanges (HKLM\Software\Policies\Microsoft\Windows\Group Policy\{3610eda5-77ef-11d2-8dc5-00c04fa31a66})
Display and enable the Network Connection wizard (User Configuration\Administrative Templates\Network\Network and Dial-up Connections) | NC_NewConnectionWizard (HKCU\Software\Policies\Microsoft\Windows\Network Connections)
Distributed File System (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{677A2D94-28D9-11D1-A95B-008048918FB1})
Do not add shares from recently opened documents to the My Network Places folder (User Configuration\AdministrativeTemplates\Desktop) | NoRecentDocsNetHood (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Do not automatically encrypt files moved to encrypted folders (Computer Configuration\Administrative Templates\System) | NoEncryptOnMove (HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Do not detect slow network connections (Computer Configuration\Administrative Templates\System\Logon) | SlowLinkDetectEnabled (HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System)
Do not keep history of recently opened documents (User Configuration\AdministrativeTemplates\Start Menu & Taskbar) | NoRecentDocsHistory (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Do not request alternate credentials (User Configuration\Administrative Templates\Windows Components\Windows Explorer) | NoRunasInstallPrompt (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Do not track Shell shortcuts during roaming (User Configuration\Administrative Templates\Windows Components\Windows Explorer) | LinkResolveIgnoreLinkInfo (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Do not use the search-based method when resolving shell shortcuts (User Configuration\AdministrativeTemplates\Start Menu & Taskbar) | NoResolveSearch (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Do not use the tracking-based method when resolving shell shortcuts (User Configuration\AdministrativeTemplates\Start Menu & Taskbar) | NoResolveTrack (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Don't display welcome screen at logon (Computer) (Computer Configuration\Administrative Templates\System) | NoWelcomeScreen (HKLM) (HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Don't display welcome screen at logon (User) (User Configuration\Administrative Templates\System) | NoWelcomeScreen (HKCU) (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Don't run specified Windows applications (User Configuration\Administrative Templates\System) | DisallowRun (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Don't save settings at exit (User Configuration\AdministrativeTemplates\Desktop) | NoSaveSettings (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Download missing COM components (Computer) (Computer Configuration\Administrative Templates\System) | COMClassStore (HKLM) (HKLM\Software\Policies\Microsoft\Windows\App Management)
Download missing COM components (User) (User Configuration\Administrative Templates\System\Group Policy) | COMClassStore (HKCU) (HKCU\Software\Policies\Microsoft\Windows\App Management)
EFS recovery policy processing (Computer Configuration\Administrative Templates\System\Group Policy) | NoSlowLink, NoBackgroundPolicy, NoGPOListChanges (HKLM\Software\Policies\Microsoft\Windows\Group Policy\{B1BE8D72-6EAC-11D2-A4EA-00C04F79F83A})
Enable access to properties of a LAN connection (User Configuration\Administrative Templates\Network\Network and Dial-up Connections) | NC_LanProperties (HKCU\Software\Policies\Microsoft\Windows\Network Connections)
Enable access to properties of components of a LAN connection (User Configuration\Administrative Templates\Network\Network and Dial-up Connections) | NC_LanChangeProperties (HKCU\Software\Policies\Microsoft\Windows\Network Connections)
Enable access to properties of components of a RAS connection (User Configuration\Administrative Templates\Network\Network and Dial-up Connections) | NC_RasChangeProperties (HKCU\Software\Policies\Microsoft\Windows\Network Connections)
Enable access to properties of RAS connections available to all users (User Configuration\Administrative Templates\Network\Network and Dial-up Connections) | NC_RasAllUserProperties (HKCU\Software\Policies\Microsoft\Windows\Network Connections)
Enable Active Desktop (User Configuration\AdministrativeTemplates\Desktop\Active Desktop) | ForceActiveDesktopOn (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop)
Enable adding or removing components of a RAS or LAN connection (User Configuration\Administrative Templates\Network\Network and Dial-up Connections) | NC_AddRemoveComponents (HKCU\Software\Policies\Microsoft\Windows\Network Connections)
Enable Classic Shell (User Configuration\Administrative Templates\Windows Components\Windows Explorer) | ClassicShell (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Enable connecting and disconnecting a LAN connection (User Configuration\Administrative Templates\Network\Network and Dial-up Connections) | NC_LanConnect (HKCU\Software\Policies\Microsoft\Windows\Network Connections)
Enable connecting and disconnecting a RAS connection (User Configuration\Administrative Templates\Network\Network and Dial-up Connections) | NC_RasConnect (HKCU\Software\Policies\Microsoft\Windows\Network Connections)
Enable deletion of RAS connections (User Configuration\Administrative Templates\Network\Network and Dial-up Connections) | NC_DeleteConnection (HKCU\Software\Policies\Microsoft\Windows\Network Connections)
Enable deletion of RAS connections available to all users (User Configuration\Administrative Templates\Network\Network and Dial-up Connections) | NC_DeleteAllUserConnection (HKCU\Software\Policies\Microsoft\Windows\Network Connections)
Enable disk quotas (Computer Configuration\Administrative Templates\System\Disk Quotas) | Enable (HKLM\Software\Policies\Microsoft\Windows NT\DiskQuota)
Enable filter in Find dialog box (User Configuration\AdministrativeTemplates\Desktop\Active Directory) | EnableFilter (HKCU\Software\Policies\Microsoft\Windows\Directory UI)
Enable renaming of connections, if supported (User Configuration\Administrative Templates\Network\Network and Dial-up Connections) | NC_RenameConnection (HKCU\Software\Policies\Microsoft\Windows\Network Connections)
Enable renaming of RAS connections belonging to the current user (User Configuration\Administrative Templates\Network\Network and Dial-up Connections) | NC_RenameMyRasConnection (HKCU\Software\Policies\Microsoft\Windows\Network Connections)
Enable status statistics for an active connection (User Configuration\Administrative Templates\Network\Network and Dial-up Connections) | NC_Statistics (HKCU\Software\Policies\Microsoft\Windows\Network Connections)
Enable the Advanced Settings item on the Advanced menu (User Configuration\Administrative Templates\Network\Network and Dial-up Connections) | NC_AdvancedSettings (HKCU\Software\Policies\Microsoft\Windows\Network Connections)
Enable the Dial-up Preferences item on the Advanced menu (User Configuration\Administrative Templates\Network\Network and Dial-up Connections) | NC_DialupPrefs (HKCU\Software\Policies\Microsoft\Windows\Network Connections)
Enable user control over installs (Computer Configuration\Administrative Templates\Windows Components\Windows Installer) | EnableUserControl (HKLM\Software\Policies\Microsoft\Windows\Installer)
Enable user to browse for source while elevated (Computer Configuration\Administrative Templates\Windows Components\Windows Installer) | AllowLockdownBrowse (HKLM\Software\Policies\Microsoft\Windows\Installer)
Enable user to patch elevated products (Computer Configuration\Administrative Templates\Windows Components\Windows Installer) | AllowLockdownPatch (HKLM\Software\Policies\Microsoft\Windows\Installer)
Enable user to use media source while elevated (Computer Configuration\Administrative Templates\Windows Components\Windows Installer) | AllowLockdownMedia (HKLM\Software\Policies\Microsoft\Windows\Installer)
Enabled (Computer Configuration\Administrative Templates\Network\Offline Files) | Enabled (HKLM\Software\Policies\Microsoft\Windows\NetCache)
Enforce disk quota limit (Computer Configuration\Administrative Templates\System\Disk Quotas) | Enforce (HKLM\Software\Policies\Microsoft\Windows NT\DiskQuota)
Enforce Show Policies Only (User Configuration\Administrative Templates\System\Group Policy) | ShowPoliciesOnly (HKCU\Software\Policies\Microsoft\Windows\Group Policy Editor)
Event logging level (Computer) (Computer Configuration\Administrative Templates\Network\Offline Files) | EventLoggingLevel (HKLM) (HKLM\Software\Policies\Microsoft\Windows\NetCache)
Event logging level (User) (User Configuration\Administrative Templates\Network\Offline Files) | EventLoggingLevel (HKCU) (HKCU\Software\Policies\Microsoft\Windows\NetCache)
Event Viewer (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{975797FC-4E2A-11D0-B702-00C04FD8DBF7})
Event Viewer (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins\Extension snap-ins) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{394C052E-B830-11D0-9A86-00C04FD8DBF7})
Exclude directories in roaming profile (Exclude directories in roaming profile) | ExcludeProfileDirs (HKCU\Software\Policies\Microsoft\Windows\System)
FAX Service (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{753EDB4D-2E1B-11D1-9064-00A0C90AB504})
Files not cached (Computer Configuration\Administrative Templates\Network\Offline Files) | ExcludeExtensions (HKLM\Software\Policies\Microsoft\Windows\NetCache)
Folder Redirection (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins\Group Policy) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{88E729D6-BDC1-11D1-BD2A-00C04FB9603F})
Folder Redirection policy processing (Computer Configuration\Administrative Templates\System\Group Policy) | NoSlowLink, NoGPOListChanges (HKLM\Software\Policies\Microsoft\Windows\Group Policy\{25537BA6-77A8-11D2-9B6C-0000F8080861})
Go directly to Components wizard (User Configuration\Administrative Templates\Control Panel\Add/Remove Programs) | NoServices (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall)
Gray unavailable Windows Installer programs Start Menu shortcuts (User Configuration\AdministrativeTemplates\Start Menu & Taskbar) | GreyMSIAds (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Group Policy domain controller selection (User Configuration\Administrative Templates\System\Group Policy) | DCOption (HKCU\Software\Policies\Microsoft\Windows\Group Policy Editor)
Group Policy refresh interval for computers (Computer Configuration\Administrative Templates\System\Group Policy) | GroupPolicyRefreshTime (HKLM), GroupPolicyRefreshTimeOffset (HKLM) (HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System)
Group Policy refresh interval for domain controllers (Computer Configuration\Administrative Templates\System\Group Policy) | GroupPolicyRefreshTimeDC, GroupPolicyRefreshTimeOffsetDC (HKLM\Software\Policies\Microsoft\Windows\System)
Group Policy refresh interval for users (User Configuration\Administrative Templates\System\Group Policy) | GroupPolicyRefreshTime (HKCU), GroupPolicyRefreshTimeOffset (HKCU) (HKCU\Software\Policies\Microsoft\Windows\System)
Group Policy slow link detection (Computer) (Computer Configuration\Administrative Templates\System\Group Policy) | GroupPolicyMinTransferRate (HKLM) (HKLM\Software\Policies\Microsoft\Windows\System)
Group Policy slow link detection (User) (User Configuration\Administrative Templates\System\Group Policy) | GroupPolicyMinTransferRate (HKCU) (HKCU\Software\Policies\Microsoft\Windows\System)
Group Policy snap-in (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins\Group Policy) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{8FC0B734-A0E1-11D1-A7D3-0000F87571E3})
Group Policy Tab for Active Directory Tools (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins\Group Policy) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{D70A2BEA-A63E-11D1-A7D4-0000F87571E3})
Hide Active Directory folder (User Configuration\AdministrativeTemplates\Desktop\Active Directory) | HideDirectoryFolder (HKCU\Software\Policies\Microsoft\Windows\Directory UI)
Hide Add New Programs page (User Configuration\Administrative Templates\Control Panel\Add/Remove Programs) | NoAddPage (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall)
Hide Add/Remove Windows Components page (User Configuration\Administrative Templates\Control Panel\Add/Remove Programs) | NoWindowsSetupPage (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall)
Hide all icons on Desktop (User Configuration\AdministrativeTemplates\Desktop) | NoDesktop (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Hide Appearance tab (User Configuration\Administrative Templates\Control Panel\Display) | NoDispAppearancePage (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System)
Hide Background tab (User Configuration\Administrative Templates\Control Panel\Display) | NoDispBackgroundPage (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System)
Hide Change or Remove Programs page (User Configuration\Administrative Templates\Control Panel\Add/Remove Programs) | NoRemovePage (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall)
Hide Hardware tab (User Configuration\Administrative Templates\Windows Components\Windows Explorer) | NoHardwareTab (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Hide Internet Explorer icon on desktop (User Configuration\AdministrativeTemplates\Desktop) | NoInternetIcon (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Hide My Network Places icon on desktop (User Configuration\AdministrativeTemplates\Desktop) | NoNetHood (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Hide Property Pages (Computer) (Computer Configuration\Administrative Templates\Windows Components\Task Scheduler) | Property Pages (HKLM) (HKLM\Software\Policies\Microsoft\Windows\Task Scheduler5.0)
Hide Property Pages (User) (User Configuration\Administrative Templates\Windows Components\Task Scheduler) | Property Pages (HKCU) (HKCU\Software\Policies\Microsoft\Windows\Task Scheduler5.0)
Hide Screen Saver tab (User Configuration\Administrative Templates\Control Panel\Display) | NoDispScrSavPage (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System)
Hide Settings tab (User Configuration\Administrative Templates\Control Panel\Display) | NoDispSettingsPage (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System)
Hide specified control panel applets (User Configuration\Administrative Templates\Control Panel) | DisallowCpl, DisallowCpl subkey (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Hide the "Add a program from CD-ROM or floppy disk" option (User Configuration\Administrative Templates\Control Panel\Add/Remove Programs) | NoAddFromCDorFloppy (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall)
Hide the "Add programs from Microsoft" option (User Configuration\Administrative Templates\Control Panel\Add/Remove Programs) | NoAddFromInternet (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall)
Hide the "Add programs from your network" option (User Configuration\Administrative Templates\Control Panel\Add/Remove Programs) | NoAddFromNetwork (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall)
Hide the common dialog back button (User Configuration\Administrative Templates\Windows Components\Windows Explorer\Common Open File Dialog) | NoBackButton (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Comdlg32)
Hide the common dialog places bar (User Configuration\Administrative Templates\Windows Components\Windows Explorer\Common Open File Dialog) | NoPlacesBar (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Comdlg32)
Hide the dropdown list of recent files (User Configuration\Administrative Templates\Windows Components\Windows Explorer\Common Open File Dialog) | NoFileMru (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Comdlg32)
Hide the file scan progress window (Computer Configuration\Administrative Templates\System\Windows File Protection) | SfcShowProgress (HKLM\Software\Policies\Microsoft\Windows NT\Windows File Protection)
Hide these specified drives in My Computer (User Configuration\Administrative Templates\Windows Components\Windows Explorer) | NoDrives (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Hides the Manage item on the Windows Explorer context menu (User Configuration\Administrative Templates\Windows Components\Windows Explorer) | NoManageMyComputerVerb (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
IAS Logging (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins\Extension snap-ins) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{2E19B602-48EB-11d2-83CA-00104BCA42CF})
IGMP Routing (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins\Extension snap-ins) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{C2FE4508-D6C2-11D0-A37B-00C04FC9DA04})
Indexing Service (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{95AD72F0-44CE-11D0-AE29-00AA004B9986})
Initial reminder balloon lifetime (Computer) (Computer Configuration\Administrative Templates\Network\Offline Files) | InitialBalloonTimeoutSeconds (HKLM) (HKLM\Software\Policies\Microsoft\Windows\NetCache)
Initial reminder balloon lifetime (User) (User Configuration\Administrative Templates\Network\Offline Files) | InitialBalloonTimeoutSeconds (HKCU) (HKCU\Software\Policies\Microsoft\Windows\NetCache\AssignedOfflineFolders)
Internet Authentication Service (IAS) (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{8F8F8DC0-5713-11D1-9551-0060B0576642})
Internet Explorer Maintenance (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins\Group Policy) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{FC715823-C5FB-11D1-9EEF-00A0C90347FF})
Internet Explorer Maintenance policy processing (Computer Configuration\Administrative Templates\System\Group Policy) | NoSlowLink, NoBackgroundPolicy, NoGPOListChanges (HKLM\Software\Policies\Microsoft\Windows\Group Policy\{A2E30F80-D7DE-11d2-BBDE-00C04F86AE3B})
Internet Information Services (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{A841B6C2-7577-11D0-BB1F-00A0C922E79C})
IP Routing (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins\Extension snap-ins) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{C2FE4500-D6C2-11D0-A37B-00C04FC9DA04})
IP Security (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{DEA8AFA0-CC85-11d0-9CE2-0080C7221EBD})
IP Security policy processing (Computer Configuration\Administrative Templates\System\Group Policy) | NoSlowLink, NoBackgroundPolicy, NoGPOListChanges (HKLM\Software\Policies\Microsoft\Windows\Group Policy\{e437bc1c-aa7d-11d2-a382-00c04f991e27})
IPX RIP Routing (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins\Extension snap-ins) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{90810502-38F1-11D1-9345-00C04FC9DA04})
IPX Routing (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins\Extension snap-ins) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{90810500-38F1-11D1-9345-00C04FC9DA04})
IPX SAP Routing (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins\Extension snap-ins) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{90810504-38F1-11D1-9345-00C04FC9DA04})
Limit profile size (User Configuration\Administrative Templates\System\Logon/Logoff) | EnableProfileQuota, IncludeRegInProQuota, MaxProfileSize, ProfileQuotaMessage, WarnUser, WarnUserTimeout (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System)
Limit Windows File Protection cache size (Computer Configuration\Administrative Templates\System\Windows File Protection) | SfcQuota (HKLM\Software\Policies\Microsoft\Windows NT\Windows File Protection)
Local Users and Groups (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{5D6179C8-17EC-11D1-9AA9-00C04FD8FE93})
Log event when quota limit exceeded (Computer Configuration\Administrative Templates\System\Disk Quotas) | LogEventOverLimit (HKLM\Software\Policies\Microsoft\Windows NT\DiskQuota)
Log event when quota warning level exceeded (Computer Configuration\Administrative Templates\System\Disk Quotas) | LogEventOverThreshold (HKLM\Software\Policies\Microsoft\Windows NT\DiskQuota)
Log users off when roaming profile fails (Computer Configuration\Administrative Templates\System\Logon) | ProfileErrorAction (HKLM\Software\Policies\Microsoft\Windows\System)
Logging (Computer Configuration\Administrative Templates\Windows Components\Windows Installer) | Logging (HKLM\Software\Policies\Microsoft\Windows\Installer)
Logical and Mapped Drives (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins\Extension snap-ins) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{6E8E0081-19CD-11D1-AD91-00AA00B8E05A})
Maximum number of Recent documents (User Configuration\Administrative Templates\Windows Components\Windows Explorer) | MaxRecentDocs (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Maximum retries to unload and update user profile (Computer Configuration\Administrative Templates\System\Logon) | ProfileUnloadTimeout (HKLM\SOFTWARE\Policies\Microsoft\Windows\System)
Maximum size of Active Directory searches (User Configuration\AdministrativeTemplates\Desktop\Active Directory) | QueryLimit (HKCU\Software\Policies\Microsoft\Windows\Directory UI)
Maximum wait time for Group Policy scripts (Computer Configuration\Administrative Templates\System\Logon) | MaxGPOScriptWait (HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System)
No "Computers Near Me" in My Network Places (User Configuration\Administrative Templates\Windows Components\Windows Explorer) | NoComputersNearMe (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
No "Entire Network" in My Network Places (User Configuration\Administrative Templates\Windows Components\Windows Explorer) | NoEntireNetwork (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Network)
No screen saver (User Configuration\Administrative Templates\Control Panel\Display) | ScreenSaveActive (HKCU\Software\Policies\Microsoft\Windows\Control Panel\Desktop)
Non-default server disconnect actions (Computer) (Computer Configuration\Administrative Templates\Network\Offline Files) | CustomGoOfflineActions subkey (HKLM) (HKLM\Software\Policies\Microsoft\Windows\NetCache\CustomGoOfflineActions)
Non-default server disconnect actions (User) (User Configuration\Administrative Templates\Network\Offline Files) | CustomGoOfflineActions subkey (HKCU) (HKCU\Software\Policies\Microsoft\Windows\NetCache\CustomGoOfflineActions)
Only allow approved Shell extensions (User Configuration\Administrative Templates\Windows Components\Windows Explorer) | EnforceShellExtensionSecurity (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
OSPF Routing (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins\Extension snap-ins) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{C2FE4506-D6C2-11D0-A37B-00C04FC9DA04})
Password protect the screen saver (User Configuration\Administrative Templates\Control Panel\Display) | ScreenSaverIsSecure (HKCU\Software\Policies\Microsoft\Windows\Control Panel\Desktop)
Performance Logs and Alerts (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{7478EF61-8C46-11d1-8D99-00A0C913CAD4})
Pre-populate printer search location text (Computer Configuration\Administrative Templates\Printers) | PhysicalLocationSupport (HKLM\Software\Policies\Microsoft\Windows NT\Printers)
Prevent access to drives from My Computer (User Configuration\Administrative Templates\Windows Components\Windows Explorer) | NoViewOnDrive (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Prevent Task Run or End (Computer) (Computer Configuration\Administrative Templates\Windows Components\Task Scheduler) | Execution (HKLM) (HKLM\Software\Policies\Microsoft\Windows\Task Scheduler5.0)
Prevent Task Run or End (User) (User Configuration\Administrative Templates\Windows Components\Task Scheduler) | Execution (HKCU) (HKCU\Software\Policies\Microsoft\Windows\Task Scheduler5.0)
Prevent use of Offline Files folder (Computer) (Computer Configuration\Administrative Templates\Network\Offline Files) | NoCacheViewer (HKLM) (HKLM\Software\Policies\Microsoft\Windows\NetCache)
Prevent use of Offline Files Folder (User) (User Configuration\Administrative Templates\Network\Offline Files) | NoCacheViewer (HKCU) (HKCU\Software\Policies\Microsoft\Windows\NetCache)
Primary DNS Suffix (Computer Configuration\Administrative Templates\System\DNS Client) | NV PrimaryDnsSuffix, PrimaryDnsSuffix (HKLM\Software\Policies\Microsoft\System\DNSclient)
Printer browsing (Computer Configuration\Administrative Templates\Printers) | ServerThread (HKLM\Software\Policies\Microsoft\Windows NT\Printers)
Prohibit adding items (User Configuration\AdministrativeTemplates\Desktop\Active Desktop) | NoAddingComponents (Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop)
Prohibit Browse (Computer) (Computer Configuration\Administrative Templates\Windows Components\Task Scheduler) | Allow Browse (HKLM) (HKLM\Software\Policies\Microsoft\Windows\Task Scheduler5.0)
Prohibit Browse (User) (User Configuration\Administrative Templates\Windows Components\Task Scheduler) | Allow Browse (HKCU) (HKCU\Software\Policies\Microsoft\Windows\Task Scheduler5.0)
Prohibit changes (User Configuration\AdministrativeTemplates\Desktop\Active Desktop) | NoActiveDesktopChanges (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Prohibit closing items (User Configuration\AdministrativeTemplates\Desktop\Active Desktop) | NoClosingComponents (Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop)
Prohibit deleting items (User Configuration\AdministrativeTemplates\Desktop\Active Desktop) | NoDeletingComponents (Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop)
Prohibit editing items (User Configuration\AdministrativeTemplates\Desktop\Active Desktop) | NoEditingComponents (Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop)
Prohibit user from changing My Documents path (User Configuration\AdministrativeTemplates\Desktop) | DisablePersonalDirChange (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Prompt user when slow link is detected (Computer Configuration\Administrative Templates\System\Logon) | SlowLinkUIEnabled (HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System)
Prune printers that are not automatically republished (Computer Configuration\Administrative Templates\Printers) | PruneDownlevel (HKLM\Software\Policies\Microsoft\Windows NT\Printers)
Public Key Policies (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins\Extension snap-ins) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{34AB8E82-C27E-11D1-A6C0-00C04FB94F17})
QoS Admission Control (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{FD57D297-4FD9-11D1-854E-00C04FC31FD3})
RAS Dialin - User Node (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins\Extension snap-ins) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{B52C1E50-1DD2-11D1-BC43-00C04FC31FD3})
Registry policy processing (Computer Configuration\Administrative Templates\System\Group Policy) | NoBackgroundPolicy, NoGPOListChanges (HKLM\Software\Policies\Microsoft\Windows\Group Policy\{35378EAC-683F-11D2-A89A-00C04FBBCFA2})
Reminder balloon frequency (Computer) (Computer Configuration\Administrative Templates\Network\Offline Files) | ReminderFreqMinutes (HKLM) (HKLM\Software\Policies\Microsoft\Windows\NetCache)
Reminder balloon frequency (User) (User Configuration\Administrative Templates\Network\Offline Files) | ReminderFreqMinutes (HKCU) (HKCU\Software\Policies\Microsoft\Windows\NetCache\AssignedOfflineFolders)
Reminder balloon lifetime (Computer) (Computer Configuration\Administrative Templates\Network\Offline Files) | ReminderBalloonTimeoutSeconds (HKLM) (HKLM\Software\Policies\Microsoft\Windows\NetCache)
Reminder balloon lifetime (User) (User Configuration\Administrative Templates\Network\Offline Files) | ReminderBalloonTimeoutSeconds (HKCU) (ReminderBalloonTimeoutSeconds)
Remote Access (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins\Extension snap-ins) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{5880CD5C-8EC0-11d1-9570-0060B0576642})
Remote Installation Services (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins\Group Policy) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{3060E8CE-7020-11D2-842D-00C04FA372D4})
Removable Storage (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins\Extension snap-ins) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{243E20B0-48ED-11D2-97DA-00A024D77700})
Removable Storage Management (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{3CB6973D-3E6F-11D0-95DB-00A024D77700})
Remove "Map Network Drive" and "Disconnect Network Drive" (User Configuration\Administrative Templates\Windows Components\Windows Explorer) | NoNetConnectDisconnect (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Remove common program groups from Start Menu (User Configuration\AdministrativeTemplates\Start Menu & Taskbar) | NoCommonGroups (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Remove Disconnect item from Start menu (Terminal Services only) (Computer Configuration\Administrative Templates\System) | NoDisconnect (HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Remove Documents menu from Start Menu (User Configuration\AdministrativeTemplates\Start Menu & Taskbar) | NoRecentDocsMenu (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Remove Favorites menu from Start Menu (User Configuration\AdministrativeTemplates\Start Menu & Taskbar) | NoFavoritesMenu (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Remove File menu from Windows Explorer (User Configuration\Administrative Templates\Windows Components\Windows Explorer) | NoFileMenu (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Remove Help menu from Start Menu (User Configuration\AdministrativeTemplates\Start Menu & Taskbar) | NoSMHelp (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Remove My Documents icon from desktop (User Configuration\AdministrativeTemplates\Desktop) | {450D8FBA-AD25-11D0-98A8-0800361B1103} (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\NonEnum)
Remove My Documents icon from Start Menu (User Configuration\AdministrativeTemplates\Desktop) | NoSMMyDocs (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Remove Network & Dial-up Connections from Start Menu (User Configuration\AdministrativeTemplates\Start Menu & Taskbar) | NoNetworkConnections (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Remove Run menu from Start Menu (User Configuration\AdministrativeTemplates\Start Menu & Taskbar) | NoRun (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Remove Search button from Windows Explorer (User Configuration\Administrative Templates\Windows Components\Windows Explorer) | NoShellSearchButton (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Remove Search menu from Start Menu (User Configuration\AdministrativeTemplates\Start Menu & Taskbar) | NoFind (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Remove security option from Start menu (Terminal Services only) (Computer Configuration\Administrative Templates\System) | NoNTSecurity (HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Remove the Folder Options menu item from the Tools menu (User Configuration\Administrative Templates\Windows Components\Windows Explorer) | NoFolderOptions (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Remove user's folders from the Start Menu (User Configuration\AdministrativeTemplates\Start Menu & Taskbar) | NoStartMenuSubFolders (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Request credentials for network installations (User Configuration\Administrative Templates\Windows Components\Windows Explorer) | PromptRunasInstallNetPath (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Restrict selection of Windows 2000 menus and dialogs language (User Configuration\Administrative Templates\Control Panel\Regional Options) | MultiUILanguageID (HKCU\Software\Policies\Microsoft\Control Panel\Desktop)
Restrict the user from entering author mode (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console) | RestrictAuthorMode (HKCU\Software\Policies\Microsoft\MMC)
Restrict users to the explicitly permitted list of snap-ins (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console) | RestrictToPermittedSnapins (HKCU\Software\Policies\Microsoft\MMC)
RIP Routing (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins\Extension snap-ins) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{C2FE4504-D6C2-11D0-A37B-00C04FC9DA04})
Routing (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins\Extension snap-ins) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{DAB1A262-4FD7-11D1-842C-00C04FB6C218})
Routing and Remote Access (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{1AA7F839-C7F5-11D0-A376-00C04FC9DA04})
Run legacy logon scripts hidden (Run legacy logon scripts hidden) | HideLegacyLogonScripts (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System)
Run logoff scripts visible (User Configuration\Administrative Templates\System\Logon/Logoff) | HideLogoffScripts (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System)
Run logon scripts synchronously (Computer) (Computer Configuration\Administrative Templates\System\Logon) | RunLogonScriptSync (HKLM) (HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System)
Run logon scripts synchronously (User) (User Configuration\Administrative Templates\System\Logon/Logoff) | RunLogonScriptSync (HKCU) (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Run logon scripts visible (User Configuration\Administrative Templates\System\Logon/Logoff) | HideLogonScripts (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System)
Run only allowed Windows applications (User Configuration\Administrative Templates\System) | RestrictRun (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Run shutdown scripts visible (Computer Configuration\Administrative Templates\System\Logon) | HideShutdownScripts (HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System)
Run startup scripts asynchronously (Computer Configuration\Administrative Templates\System\Logon) | RunStartupScriptSync (HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System)
Run startup scripts visible (Computer Configuration\Administrative Templates\System\Logon) | HideStartupScripts (HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System)
Run these programs at user logon (Computer) (Computer Configuration\Administrative Templates\System) | Run subkey (HKLM) (HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\Run)
Run these programs at user logon (User) (User Configuration\Administrative Templates\System\Logon/Logoff) | Run subkey (HKCU) (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\Run)
Screen saver executable name (User Configuration\Administrative Templates\Control Panel\Display) | SCRNSAVE.EXE (HKCU\Software\Policies\Microsoft\Windows\Control Panel\Desktop)
Scripts (Logon/Logoff) (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins\Group Policy) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{40B66650-4972-11D1-A7CA-0000F87571E3})
Scripts (Startup/Shutdown) (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins\Group Policy) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{40B6664F-4972-11D1-A7CA-0000F87571E3})
Scripts policy processing (Computer Configuration\Administrative Templates\System\Group Policy) | NoSlowLink, NoBackgroundPolicy, NoGPOListChanges (HKLM\Software\Policies\Microsoft\Windows\Group Policy\{42B5FAAE-6536-11d2-AE5A-0000F87571E3})
Search order (User Configuration\Administrative Templates\Windows Components\Windows Installer) | SearchOrder (HKCU\Software\Policies\Microsoft\Windows\Installer)
Security Configuration and Analysis (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{011BE22D-E453-11D1-945A-00C04FB984F9})
Security policy processing (Computer Configuration\Administrative Templates\System\Group Policy) | NoBackgroundPolicy, NoGPOListChanges (HKLM\Software\Policies\Microsoft\Windows\Group Policy\{827D319E-6EAC-11D2-A4EA-00C04F79F83A})
Security Settings (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins\Group Policy) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{803E14A0-B4FB-11D0-A0D0-00A0C90F574B})
Security Templates (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{5ADF5BF6-E452-11D1-945A-00C04FB984F9})
Send Console Message (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins\Extension snap-ins) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{B1AFF7D0-0C49-11D1-BB12-00C04FC9A3A3})
Service Dependencies (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins\Extension snap-ins) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{BD95BA60-2E26-AAD1-AD99-00AA00B8E05A})
Services (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{58221C66-EA27-11CF-ADCF-00AA00A80033})
Set Windows File Protection scanning (Computer Configuration\Administrative Templates\System\Windows File Protection) | SfcScan (HKLM\Software\Policies\Microsoft\Windows NT\Windows File Protection)
Shared Folders (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{58221C65-EA27-11CF-ADCF-00AA00A80033})
Show only specified control panel applets (User Configuration\Administrative Templates\Control Panel) | RestrictCpl, RestrictCpl subkey (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer)
Slow network connection timeout for user profiles (Computer Configuration\Administrative Templates\System\Logon) | SlowLinkTimeOut, UserProfileMinTransferRate (HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System)
SMTP Protocol (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins\Extension snap-ins) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{03f1f940-a0f2-11d0-bb77-00aa00a1eab7})
SNMP (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins\Extension snap-ins) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{7AF60DD3-4979-11D1-8A6C-00C04FC33566})
Software Installation (Computer) (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins\Group Policy) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{942A8E4F-A261-11D1-A760-00C04FB9603F})
Software Installation (User) (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins\Group Policy) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{BACF5C8A-A3C7-11D1-A760-00C04FB9603F})
Software Installation policy processing (Computer Configuration\Administrative Templates\System\Group Policy) | NoGPOListChanges, NoSlowLink (HKLM\Software\Policies\Microsoft\Windows\Group Policy\{c6dc5466-785a-11d2-84d0-00c04fb169f7})
Specify default category for Add New Programs (User Configuration\Administrative Templates\Control Panel\Add/Remove Programs) | DefaultCategory (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall)
Specify Windows File Protection cache location (Computer Configuration\Administrative Templates\System\Windows File Protection) | SFCDllCacheDir (HKLM\Software\Policies\Microsoft\Windows NT\Windows File Protection)
Subfolders always available offline (Computer Configuration\Administrative Templates\Network\Offline Files) | AlwaysPinSubFolders (HKLM\Software\Policies\Microsoft\Windows\NetCache)
Synchronize all offline files before logging off (Computer) (Computer Configuration\Administrative Templates\Network\Offline Files) | SyncAtLogoff (HKLM) (HKLM\Software\Policies\Microsoft\Windows\NetCache)
Synchronize all offline files before logging off (User) (User Configuration\Administrative Templates\Network\Offline Files) | SyncAtLogoff (HKCU) (HKCU\Software\Policies\Microsoft\Windows\NetCache)
System Information (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{45ac8c63-23e2-11d1-a696-00c04fd58bc3})
System Properties (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins\Extension snap-ins) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{0F3621F1-23C6-11D1-AD97-00AA00B88E5A})
Telephony (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{E26D02A0-4C1F-11D1-9AA1-00C04FC3357A})
Terminal Services Configuration (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{B91B6008-32D2-11D2-9888-00A0C925F917})
Timeout for dialog boxes (Computer Configuration\Administrative Templates\System\Logon) | ProfileDlgTimeOut (HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System)
User Group Policy loopback processing mode (Computer Configuration\Administrative Templates\System\Group Policy) | UserPolicyMode (HKLM\Software\Policies\Microsoft\Windows\System)
Verbose vs normal status messages (Computer Configuration\Administrative Templates\System) | VerboseStatus (HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System)
Wait for remote user profile (Computer Configuration\Administrative Templates\System\Logon) | SlowLinkProfileDefault (HKLM\Software\Policies\Microsoft\Windows\System)
Web-based printing (Computer Configuration\Administrative Templates\Printers) | DisableWebPrinting (HKLM\Software\Policies\Microsoft\Windows NT\Printers)
WMI Control (User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins) | Restrict_Run (HKCU\Software\Policies\Microsoft\MMC\{5C659257-E236-11D2-8899-00104B2AFB46})


Connect home directory to root of the share policy: Example

Drive letter Z: is mapped to \\server\share\dir1\dir2\homedir.

  • If the policy is disabled or not configured (Windows 2000 behavior):
    • %HOMEDRIVE% | Z: (mapped to \\server\share\dir1\dir2\homedir)
%HOMESHARE% | \\server\share\dir1\dir2\homedir
%HOMEPATH% | \
  • If the policy is enabled (Windows NT 4.0 behavior):
    • %HOMEDRIVE% | Z: (mapped to \\server\share)
%HOMESHARE% | \\server\share
%HOMEPATH% | \dir1\dir2\homedir


Language ID Table

Language | Language ID
Arabic | 0401
Brazilian | 0416
Chinese (Simplified) | 0804
Chinese (Traditional) | 0404
Czech | 0405
Danish | 0406
Dutch | 0413
English (default) | 0409
Finnish | 040b
French | 040c
German | 0407
Greek | 0408
Hebrew | 040d
Hungarian | 040e
Italian | 0410
Japanese | 0411
Korean | 0412
Norwegian | 0414
Polish | 0415
Portuguese | 0816
Russian | 0419
Spanish | 0c0a
Swedish | 041D
Turkish | 041f


Language ID Table

Language | Abbreviation | Locale ID
Afrikaans | AFK | 00000436
Albanian | SQI | 0000041c
Arabic (Algeria) | ARG | 00001401
Arabic (Bahrain) | ARH | 00003C01
Arabic (Egypt) | ARE | 00000C01
Arabic (Iraq) | ARI | 00000801
Arabic (Jordan) | ARJ | 00002C01
Arabic (Kuwait) | ARK | 00003401
Arabic (Lebanon) | ARB | 00003001
Arabic (Libya) | ARL | 00001001
Arabic (Morocco) | ARM | 00001801
Arabic (Oman) | ARO | 00002001
Arabic (Qatar) | ARQ | 00004001
Arabic (Saudi Arabia) | ARA | 00000401
Arabic (Syria) | ARS | 00002801
Arabic (Tunisia) | ART | 00001C01
Arabic (U.A.E.) | ARU | 00003801
Arabic (Yemen) | ARY | 00002401
Armenian | HYE | 0000042b
Assamese | ASM | 0000044d
Azeri (Cyrillic) | AZC | 0000082c
Azeri (Latin) | AZE | 0000042c
Basque | EUQ | 0000042D
Belarusian | BEL | 00000423
Bengali | BEN | 00000445
Bulgarian | BGR | 00000402
Catalan | CAT | 00000403
Chinese (Hong Kong SAR) | ZHH | 00000C04
Chinese (Macau) | ZHM | 00001404
Chinese (PRC) | CHS | 00000804
Chinese (Singapore) | ZHI | 00001004
Chinese (Taiwan) | CHT | 00000404
Croatian | HRV | 0000041a
Czech | CSY | 00000405
Danish | DAN | 00000406
Dutch (Belgium) | NLB | 00000813
Dutch (Netherlands) | NLD | 00000413
English (Australia) | ENA | 00000c09
English (Belize) | ENL | 00002809
English (Canada) | ENC | 00001009
English (Caribbean) | ENB | 00002409
English (Ireland) | ENI | 00001809
English (Jamaica) | ENJ | 00002009
English (New Zealand) | ENZ | 00001409
English (Philippines) | ENP | 00003409
English (South Africa) | ENS | 00001c09
English (Trinidad) | ENT | 00002c09
English (United Kingdom) | ENG | 00000809
English (United States) | ENU | 00000409
English (Zimbabwe) | ENW | 00003009
Estonian | ETI | 00000425
Faeroese | FOS | 00000438
Farsi | FAR | 00000429
Finnish | FIN | 0000040b
French (Belgium) | FRB | 0000080c
French (Canada) | FRC | 00000c0c
French (France) | FRA | 0000040c
French (Luxembourg) | FRL | 0000140c
French (Monaco) | FRM | 0000180c
French (Switzerland) | FRS | 0000100c
Georgian | KAT | 00000437
German (Austria) | DEA | 00000c07
German (Germany) | DEU | 00000407
German (Liechtenstein) | DEC | 00001407
German (Luxembourg) | DEL | 00001007
German (Switzerland) | DES | 00000807
Greek | ELL | 00000408
Gujarati | GUJ | 00000447
Hebrew | HEB | 0000040D
Hindi | HIN | 00000439
Hungarian | HUN | 0000040e
Icelandic | ISL | 0000040F
Indonesian | IND | 00000421
Italian (Italy) | ITA | 00000410
Italian (Switzerland) | ITS | 00000810
Japanese | JPN | 00000411
Kannada | KAN | 0000044b
Kashmiri (India) | KAI | 00000860
Kazakh | KAZ | 0000043f
Konkani | KOK | 00000457
Korean | KOR | 00000412
Latvian | LVI | 00000426
Lithuanian (Classic) | LTH | 00000827
Lithuanian | LTH | 00000427
Macedonian | MKD | 0000042f
Malay Brunei Darussalam | MSB | 0000083e
Malayalam | MAL | 0000044c
Malaysian | MSL | 0000043e
Manipuri |  | 00000458
Marathi | MAR | 0000044e
Nepali (India) | NEI | 00000861
Norwegian (Bokmal) | NOR | 00000414
Norwegian (Nynorsk) | NON | 00000814
Oriya | ORI | 00000448
Polish | PLK | 00000415
Portuguese (Brazil) | PTB | 00000416
Portuguese (Portugal) | PTG | 00000816
Punjabi | PAN | 00000446
Romanian | ROM | 00000418
Russian | RUS | 00000419
Sanskrit | SAN | 0000044f
Serbian (Cyrillic) | SRB | 00000c1a
Serbian (Latin) | SRL | 0000081a
Sindhi | SND | 00000459
Slovak | SKY | 0000041b
Slovenian | SLV | 00000424
Spanish (Argentina) | ESS | 00002c0a
Spanish (Bolivia) | ESB | 0000400a
Spanish (Chile) | ESL | 0000340a
Spanish (Colombia) | ESO | 0000240a
Spanish (Costa Rica) | ESC | 0000140a
Spanish (Dominican Republic) | ESD | 00001c0a
Spanish (Ecuador) | ESF | 0000300a
Spanish (El Salvador) | ESE | 0000440a
Spanish (Guatemala) | ESG | 0000100a
Spanish (Honduras) | ESH | 0000480a
Spanish (Mexico) | ESM | 0000080a
Spanish (Nicaragua) | ESI | 00004c0a
Spanish (Panama) | ESA | 0000180a
Spanish (Paraguay) | ESZ | 00003c0a
Spanish (Peru) | ESR | 0000280a
Spanish (Puerto Rico) | ESU | 0000500a
Spanish (Spain - Modern Sort) | ESN | 00000c0a
Spanish (Spain - Traditional Sort) | ESP | 0000040a
Spanish (Uruguay) | ESY | 0000380a
Spanish (Venezuela) | ESV | 0000200a
Swahili (Kenya) | SWK | 00000441
Swedish (Finland) | SVF | 0000081d
Swedish | SVE | 0000041D
Tamil | TAM | 00000449
Tatar (Tatarstan) | TAT | 00000444
Telugu | TEL | 0000044a
Thai | THA | 0000041E
Turkish | TRK | 0000041f
Ukrainian | UKR | 00000422
Urdu (Pakistan) | URD | 00000420
Uzbek (Cyrillic) | UZC | 00000843
Uzbek (Latin) | UZB | 00000443
Vietnamese | VIT | 0000042a


Table of Class ID Subkeys for MMC Snap-ins - (Sorted by CLASS ID)

Table of Class ID Subkeys for MMC Snap-ins
(Sorted by CLASS ID)

Sort by snap-in name

Class ID | Snap-in
{011BE22D-E453-11D1-945A-00C04FB984F9} | Security Configuration and Analysis
{03f1f940-a0f2-11d0-bb77-00aa00a1eab7} | SMTP Protocol
{0F3621F1-23C6-11D1-AD97-00AA00B88E5A} | System Properties
{0F6B957D-509E-11D1-A7CC-0000F87571E3} | Administrative Templates (Computers)
{0F6B957E-509E-11D1-A7CC-0000F87571E3} | Administrative Templates (Users)
{1AA7F839-C7F5-11D0-A376-00C04FC9DA04} | Routing and Remote Access
{1AA7F83C-C7F5-11D0-A376-00C04FC9DA04} | AppleTalk Routing
{243E20B0-48ED-11D2-97DA-00A024D77700} | Removable Storage
{2E19B602-48EB-11d2-83CA-00104BCA42CF} | IAS Logging
{3060E8CE-7020-11D2-842D-00C04FA372D4} | Remote Installation Services
{34AB8E82-C27E-11D1-A6C0-00C04FB94F17} | Public Key Policies
{3CB6973D-3E6F-11D0-95DB-00A024D77700} | Removable Storage Management
{3F276EB4-70EE-11D1-8A0F-00C04FB93753} | Certification Authority
{40B6664F-4972-11D1-A7CA-0000F87571E3} | Scripts (Startup/Shutdown)
{40B66650-4972-11D1-A7CA-0000F87571E3} | Scripts (Logon/Logoff)
{43668E21-2636-11D1-A1CE-0080C88593A5} | Disk Defragmenter
{45ac8c63-23e2-11d1-a696-00c04fd58bc3} | System Information
{53D6AB1D-2488-11D1-A28C-00C04FB94F17} | Certificates
{58221C65-EA27-11CF-ADCF-00AA00A80033} | Shared Folders
{58221C66-EA27-11CF-ADCF-00AA00A80033} | Services
{58221C67-EA27-11CF-ADCF-00AA00A80033} | Computer Management
{5880CD5C-8EC0-11d1-9570-0060B0576642} | Remote Access
{5ADF5BF6-E452-11D1-945A-00C04FB984F9} | Security Templates
{5C659257-E236-11D2-8899-00104B2AFB46} | WMI Control
{5D6179C8-17EC-11D1-9AA9-00C04FD8FE93} | Local Users and Groups
{677A2D94-28D9-11D1-A95B-008048918FB1} | Distributed File System
{6E8E0081-19CD-11D1-AD91-00AA00B8E05A} | Logical and Mapped Drives
{7478EF61-8C46-11d1-8D99-00A0C913CAD4} | Performance Logs and Alerts
{753EDB4D-2E1B-11D1-9064-00A0C90AB504} | FAX Service
{7AF60DD3-4979-11D1-8A6C-00C04FC33566} | SNMP
{803E14A0-B4FB-11D0-A0D0-00A0C90F574B} | Security Settings
{88E729D6-BDC1-11D1-BD2A-00C04FB9603F} | Folder Redirection
{8EAD3A12-B2C1-11d0-83AA-00A0C92C9D5D} | Disk Management
{8F8F8DC0-5713-11D1-9551-0060B0576642} | Internet Authentication Service (IAS)
{8FC0B734-A0E1-11D1-A7D3-0000F87571E3} | Group Policy snap-in
{90087284-d6d6-11d0-8353-00a0c90640bf} | Device Manager
{90810500-38F1-11D1-9345-00C04FC9DA04} | IPX Routing
{90810502-38F1-11D1-9345-00C04FC9DA04} | IPX RIP Routing
{90810504-38F1-11D1-9345-00C04FC9DA04} | IPX SAP Routing
{942A8E4F-A261-11D1-A760-00C04FB9603F} | Software Installation (Computers)
{95AD72F0-44CE-11D0-AE29-00AA004B9986} | Indexing Service
{975797FC-4E2A-11D0-B702-00C04FD8DBF7} | Event Viewer
{9EC88934-C774-11d1-87F4-00C04FC2C17B} | DCOM Configuration Extension
{A841B6C2-7577-11D0-BB1F-00A0C922E79C} | Internet Information Services
{B1AFF7D0-0C49-11D1-BB12-00C04FC9A3A3} | Send Console Message
{B52C1E50-1DD2-11D1-BC43-00C04FC31FD3} | RAS Dialin - User Node
{BACF5C8A-A3C7-11D1-A760-00C04FB9603F} | Software Installation (Users)
{B91B6008-32D2-11D2-9888-00A0C925F917} | Terminal Services Configuration
{BD95BA60-2E26-AAD1-AD99-00AA00B8E05A} | Service Dependencies
{C2FE4500-D6C2-11D0-A37B-00C04FC9DA04} | IP Routing
{C2FE4502-D6C2-11D0-A37B-00C04FC9DA04} | DHCP Relay Management
{C2FE4504-D6C2-11D0-A37B-00C04FC9DA04} | RIP Routing
{C2FE4506-D6C2-11D0-A37B-00C04FC9DA04} | OSPF Routing
{C2FE4508-D6C2-11D0-A37B-00C04FC9DA04} | IGMP Routing
{C2FE450B-D6C2-11D0-A37B-00C04FC9DA04} | Connection Sharing (NAT)
{C9BC92DF-5B9A-11D1-8F00-00C04FC2C17B} | Component Services
{D70A2BEA-A63E-11D1-A7D4-0000F87571E3} | Group Policy Tab for Active Directory Tools
{D967F824-9968-11D0-B936-00C04FD8D5B0} | Active Directory Sites and Services
{DAB1A262-4FD7-11D1-842C-00C04FB6C218} | Routing
{DEA8AFA0-CC85-11d0-9CE2-0080C7221EBD} | IP Security
{E26D02A0-4C1F-11D1-9AA1-00C04FC3357A} | Telephony
{E355E538-1C2E-11D0-8C37-00C0-4FD8FE93} | Active Directory Users and Computers
{EBC53A38-A23F-11D0-B09B-00C04FD8DCA6} | Active Directory Domains and Trusts
{FD57D297-4FD9-11D1-854E-00C04FC31FD3} | QoS Admission Control


Table of Class ID Subkeys for MMC Snap-ins - (Sorted by Snap-in name)

Table of Class ID Subkeys for MMC Snap-ins
(Sorted by snap-in name)

Sort by CLASS ID

Snap-in | Class ID
Active Directory Domains and Trusts | {EBC53A38-A23F-11D0-B09B-00C04FD8DCA6}
Active Directory Sites and Services | {D967F824-9968-11D0-B936-00C04FD8D5B0}
Active Directory Users and Computers | {E355E538-1C2E-11D0-8C37-00C0-4FD8FE93}
Administrative Templates (Computers) | {0F6B957D-509E-11D1-A7CC-0000F87571E3}
Administrative Templates (Users) | {0F6B957E-509E-11D1-A7CC-0000F87571E3}
AppleTalk Routing | {1AA7F83C-C7F5-11D0-A376-00C04FC9DA04}
Certificates | {53D6AB1D-2488-11D1-A28C-00C04FB94F17}
Certification Authority | {3F276EB4-70EE-11D1-8A0F-00C04FB93753}
Component Services | {C9BC92DF-5B9A-11D1-8F00-00C04FC2C17B}
Computer Management | {58221C67-EA27-11CF-ADCF-00AA00A80033}
Connection Sharing (NAT) | {C2FE450B-D6C2-11D0-A37B-00C04FC9DA04}
DCOM Configuration Extension | {9EC88934-C774-11d1-87F4-00C04FC2C17B}
Device Manager | {90087284-d6d6-11d0-8353-00a0c90640bf}
DHCP Relay Management | {C2FE4502-D6C2-11D0-A37B-00C04FC9DA04}
Disk Defragmenter | {43668E21-2636-11D1-A1CE-0080C88593A5}
Disk Management | {8EAD3A12-B2C1-11d0-83AA-00A0C92C9D5D}
Distributed File System | {677A2D94-28D9-11D1-A95B-008048918FB1}
Event Viewer | {975797FC-4E2A-11D0-B702-00C04FD8DBF7}
FAX Service | {753EDB4D-2E1B-11D1-9064-00A0C90AB504}
Folder Redirection | {88E729D6-BDC1-11D1-BD2A-00C04FB9603F}
Group Policy snap-in | {8FC0B734-A0E1-11D1-A7D3-0000F87571E3}
Group Policy Tab for Active Directory Tools | {D70A2BEA-A63E-11D1-A7D4-0000F87571E3}
IAS Logging | {2E19B602-48EB-11d2-83CA-00104BCA42CF}
IGMP Routing | {C2FE4508-D6C2-11D0-A37B-00C04FC9DA04}
Indexing Service | {95AD72F0-44CE-11D0-AE29-00AA004B9986}
Internet Authentication Service (IAS) | {8F8F8DC0-5713-11D1-9551-0060B0576642}
Internet Information Services | {A841B6C2-7577-11D0-BB1F-00A0C922E79C}
IP Routing | {C2FE4500-D6C2-11D0-A37B-00C04FC9DA04}
IP Security | {DEA8AFA0-CC85-11d0-9CE2-0080C7221EBD}
IPX RIP Routing | {90810502-38F1-11D1-9345-00C04FC9DA04}
IPX Routing | {90810500-38F1-11D1-9345-00C04FC9DA04}
IPX SAP Routing | {90810504-38F1-11D1-9345-00C04FC9DA04}
Local Users and Groups | {5D6179C8-17EC-11D1-9AA9-00C04FD8FE93}
Logical and Mapped Drives | {6E8E0081-19CD-11D1-AD91-00AA00B8E05A}
OSPF Routing | {C2FE4506-D6C2-11D0-A37B-00C04FC9DA04}
Performance Logs and Alerts | {7478EF61-8C46-11d1-8D99-00A0C913CAD4}
Public Key Policies | {34AB8E82-C27E-11D1-A6C0-00C04FB94F17}
QoS Admission Control | {FD57D297-4FD9-11D1-854E-00C04FC31FD3}
RAS Dialin - User Node | {B52C1E50-1DD2-11D1-BC43-00C04FC31FD3}
Remote Access | {5880CD5C-8EC0-11d1-9570-0060B0576642}
Remote Installation Services | {3060E8CE-7020-11D2-842D-00C04FA372D4}
Removable Storage | {243E20B0-48ED-11D2-97DA-00A024D77700}
Removable Storage Management | {3CB6973D-3E6F-11D0-95DB-00A024D77700}
RIP Routing | {C2FE4504-D6C2-11D0-A37B-00C04FC9DA04}
Routing | {DAB1A262-4FD7-11D1-842C-00C04FB6C218}
Routing and Remote Access | {1AA7F839-C7F5-11D0-A376-00C04FC9DA04}
Scripts (Logon/Logoff) | {40B66650-4972-11D1-A7CA-0000F87571E3}
Scripts (Startup/Shutdown) | {40B6664F-4972-11D1-A7CA-0000F87571E3}
Security Configuration and Analysis | {011BE22D-E453-11D1-945A-00C04FB984F9}
Security Settings | {803E14A0-B4FB-11D0-A0D0-00A0C90F574B}
Security Templates | {5ADF5BF6-E452-11D1-945A-00C04FB984F9}
Send Console Message | {B1AFF7D0-0C49-11D1-BB12-00C04FC9A3A3}
Service Dependencies | {BD95BA60-2E26-AAD1-AD99-00AA00B8E05A}
Services | {58221C66-EA27-11CF-ADCF-00AA00A80033}
Shared Folders | {58221C65-EA27-11CF-ADCF-00AA00A80033}
SMTP Protocol | {03f1f940-a0f2-11d0-bb77-00aa00a1eab7}
SNMP | {7AF60DD3-4979-11D1-8A6C-00C04FC33566}
Software Installation (Computers) | {942A8E4F-A261-11D1-A760-00C04FB9603F}
Software Installation (Users) | {BACF5C8A-A3C7-11D1-A760-00C04FB9603F}
System Information | {45ac8c63-23e2-11d1-a696-00c04fd58bc3}
System Properties | {0F3621F1-23C6-11D1-AD97-00AA00B88E5A}
Telephony | {E26D02A0-4C1F-11D1-9AA1-00C04FC3357A}
Terminal Services Configuration | {B91B6008-32D2-11D2-9888-00A0C925F917}
WMI Control | {5C659257-E236-11D2-8899-00104B2AFB46}


Remote access RADIUS attributes

The following lists the RADIUS attributes that are supported by the remote access server running Windows 2000 for the various RADIUS packet types. For more information about these attributes, see RFC 2138, "Remote Authentication Dial-in User Service (RADIUS)" and RFC 2548, "Microsoft Vendor-specific RADIUS Attributes."

Access-Request

  • User-Name (RADIUS attribute 1)

    • A string value that contains the user principal name or the Windows NT name without the domain.

  • User-Password (RADIUS attribute 2)

    • A string value that contains the user password and is only sent if Password Authentication Protocol (PAP) is negotiated as the authentication protocol.

  • CHAP-Password (RADIUS attribute 3)

    • Contains the response value provided by the Challenge Handshake Authentication Protocol (CHAP) in response to the challenge.

  • NAS_IP_Addresss (RADIUS attribute 4)

    • Contains the IP address of the remote access server.

  • NAS-Port (RADIUS attribute 5)

    • Indicates the number of the port on the remote access server on which the incoming call was received.

  • Service-Type (RADIUS attribute 6)

    • The only value that is sent is "Framed" (2).

  • Framed-Protocol (RADIUS attribute 7)

    • The only value that is sent is "PPP" (1).

  • Framed-MTU (RADIUS attribute 12)

    • Used in conjunction with EAP authentication to notify the RADIUS server of the maximum transmission unit (MTU) negotiated with the client, so that the RADIUS server does not send EAP messages that cannot be delivered over the link.

  • State (RADIUS attribute 24)

    • The remote access server never sends this attribute in the initial Access-Request. If EAP is used as the authentication protocol and a State attribute is received in an Access-Challenge packet, that State attribute is returned unmodified in the next Access-Request packet sent.

  • Called-Station-Id (RADIUS attribute 30)

    • Telephone number on which the call was received. For virtual private network (VPN) connections, the IP address of the VPN server.

  • Calling-Station-Id (RADIUS attribute 31)

    • Telephone number on which the call was made. For virtual private network (VPN) connections, the IP address of the VPN client.

  • NAS-Identifier (RADIUS attribute 32)

    • The fully qualified domain name of the remote access server.

  • CHAP-Challenge (RADIUS attribute 60)

    • The challenge sent by the remote access server during CHAP authentication.

  • NAS-Port-Type (RADIUS attribute 61)

    • The only values sent are Async (0), ISDN Sync (2), ISDN Async V.120 (3) ISDN Async V.110 (4), and Virtual (5). Virtual port is used to indicate VPN connections.

  • Tunnel-Type (RADIUS attribute 64)

    • The only values sent are PPTP (1) and L2TP (3).

  • Tunnel-Medium-Type (RADIUS attribute 65)

    • The only value sent is IP (1).

  • Tunnel-Client-EndPoint (RADIUS attribute 66) (PPTP only)
  • Tunnel-Server-EndPoint (RADIUS attribute 67) (PPTP only)
  • Connect-Info (RADIUS attribute 77)

    • Contains whatever data TAPI returns about the call.

  • EAP-Message (RADIUS attribute 79)
  • Signature (RADIUS attribute 80)

    • Always sent if EAP is used for authentication. Otherwise, it is configurable on the properties of the RADIUS server.

  • MS-CHAP-Response (vendor type 1)
  • MS-CHAP-CPW-2 (vendor type 4)
  • MS-Chap-LM-Enc-Pw (vendor type 5)
  • MS-CHAP-NT-Enc-PW (vendor type 6)
  • MS-Ras-Vendor (vendor type 9)
  • MS-Chap-Challenge (vendor type 11)
  • MS-Ras-Version (vendor type 18)

Access-Accept

  • Service-Type (RADIUS attribute 6)

    • Only Framed (2) and Callback Framed (4) are accepted. If any other Service-Type is received, the call is dropped.

  • Framed-Protocol (RADIUS attribute 7)

    • Only PPP (1) is accepted. If any other Framed-Protocol is received, the call is dropped.

  • Framed-IP-Address (RADIUS attribute 8)

    • The only acceptable values are 0xFFFFFFFF (user selects address) and 0xFFFFFFFE (remote access server selects address). If any other Framed-IP-Address is received, the call is dropped.

  • Framed-MTU (RADIUS attribute 12)

    • Not used.

  • Framed-Compression (RADIUS attribute 13)

    • The only recognized values are None (0) and VJ TCP/IP header compression (1). All other values are ignored.

  • Reply-Message (RADIUS attribute 18)

    • Returned in CHAP, PAP, and MS-CHAP (both v1 and v2) Success packets and in the EAP Notification message.

  • Framed-Route (RADIUS attribute 22)
  • State (RADIUS attribute 24)

    • Returned to the remote access server unchanged.

  • Class (RADIUS attribute 25)

    • Sent unchanged to accounting server in Accounting Start message.

  • Session-Timeout (RADIUS attribute 27)
  • Idle-Timeout (RADIUS attribute 28)
  • Termination-Action (RADIUS attribute 29)

    • Not used.

  • Port-Limit (RADIUS attribute 62)
  • EAP-Message (RADIUS attribute 79)
  • Signature (RADIUS attribute 80)

    • Only accepted if EAP is used for authentication.

  • Acct-Interim-Interval (RADIUS attribute 85)
  • MS-MPPE-Encryption-Policy (vendor type 7)
  • MS-MPPE-Encryption-Types (vendor type 8)
  • MS-CHAP-Domain (vendor type 10)
  • MS-BAP-Usage (vendor type 13)
  • MS-Link-Utilization-Threshold (vendor type 14)
  • MS-Link-Drop-Time-Limit (vendor type 15)
  • MS-Filter (vendor type 22)

Access-Challenge

The Access-Challenge is only used with EAP. Otherwise, the receipt of an Access-Challenge is treated as Access-Reject.

  • State (RADIUS attribute 24)
  • Session-Timeout (RADIUS attribute 27)
  • EAP-Message (RADIUS attribute 79)
  • Signature (RADIUS attribute 80)

Accounting-Request

  • User-Name (RADIUS attribute 1)
  • NAS_IP_Addresss (RADIUS attribute 4)
  • NAS-Port (RADIUS attribute 5)
  • Service-Type (RADIUS attribute 6)
  • Framed-Protocol (RADIUS attribute 7)
  • Framed-IP-Address (RADIUS attribute 8)
  • Framed-MTU (RADIUS attribute 12)
  • Framed-Compression (RADIUS attribute 13)
  • Framed-Route (RADIUS attribute 22)
  • Class (RADIUS attribute 25)
  • Session-Timeout (RADIUS attribute 27)
  • Idle-Timeout (RADIUS attribute 28)
  • Termination-Action (RADIUS attribute 29)
  • Called-Station-Id (RADIUS attribute 30)
  • Calling-Station-Id (RADIUS attribute 31)
  • NAS-Identifier (RADIUS attribute 32)
  • NAS-Port-Type (RADIUS attribute 61)
  • Port-Limit (RADIUS attribute 62)
  • Tunnel-Type (RADIUS attribute 64)
  • Tunnel-Medium-Type (RADIUS attribute 65)
  • Tunnel-Client-EndPoint (RADIUS attribute 66)
  • Tunnel-Server-EndPoint (RADIUS attribute 67)
  • Connect-Info (RADIUS attribute 77)
  • Acct-Status-Type (RADIUS attribute 40)

    • "On" is sent when the Routing and Remote Access service is started. "Off" is sent if the Routing and Remote Access service is gracefully stopped. "Start" and "Stop" are sent at the beginning and end of a user connection. "Interim-Update" is sent at approximately the interval specified in the Acct-Interim-Interval attribute (some random jitter is applied) and only if the Acct-Interim-Interval attribute was returned in the Access-Accept message.

  • Acct-Delay-Time (RADIUS attribute 41)

    • Five seconds are added on every retransmission (regardless of the actual time between retransmissions).

  • Acct-Input-Octets (RADIUS attribute 42)
  • Acct-Output-Octets (RADIUS attribute 43)
  • Acct-Session-Id (RADIUS attribute 44)
  • Acct-Authentic (RADIUS attribute 45)
  • Acct-Session-Time (RADIUS attribute 46)
  • Acct-Input-Packets (RADIUS attribute 47)
  • Acct-Output-Packets (RADIUS attribute 48)
  • Acct-Termination-Cause (RADIUS attribute 49)

    • The only values sent are 1 (User Request), 4 (Idle Timeout), 5 (Session Timeout), 6 (Admin Reset), and 8 (Port Error).

  • Acct-Multi-Session-Id (RADIUS attribute 50)
  • Acct-Link-Count (RADIUS attribute 51)
  • MS-Ras-Vendor (vendor type 9)
  • MS-CHAP-Domain (vendor type 10)
  • MS-Ras-Version (vendor type 18)
  • MS-Filter (vendor type 22)


Alphabetical List of Registry Elements

Subkey or entry icon <{Class-GUID}>

Subkey or entry icon <Accessibility-option>

Subkey or entry icon <Adapter-GUID>

Subkey or entry icon <Adapter-GUID>

Subkey or entry icon <Adapter-name>

Subkey or entry icon <Calendar-ID>

Subkey or entry icon <Class-ID>

Subkey or entry icon <Class-ID>

Subkey or entry icon <code-page>

Subkey or entry icon <Color>

Subkey or entry icon <console-window-name>

Subkey or entry icon <ControlSet00n>

Subkey or entry icon <Device-number (000n)>

Subkey or entry icon <DLL-name>

Subkey or entry icon <domain>:<user-name>

Subkey or entry icon <DosKeybCode>

Subkey or entry icon <DosKeybID>

Subkey or entry icon <Drive letter>

Subkey or entry icon <driver-name>

Subkey or entry icon <driver-name>

Subkey or entry icon <element-name>

Subkey or entry icon <element-name>

Subkey or entry icon <element-name>

Subkey or entry icon <file-name or driver-name>

Subkey or entry icon <file-name or driver-name>

Subkey or entry icon <file-name>

Subkey or entry icon <font-name>

Subkey or entry icon <Font-name>

Subkey or entry icon <group-number>

Subkey or entry icon <interface-name>

Subkey or entry icon <IP address of pull partner>

Subkey or entry icon <IP address of push partner>

Subkey or entry icon <Keyboard layout code>

Subkey or entry icon <Keyboard layout code>

Subkey or entry icon <Language-code>

Subkey or entry icon <language-ID>

Subkey or entry icon <layout-number>

Subkey or entry icon <locale>

Subkey or entry icon <Log-name>

Subkey or entry icon <Monitor>

Subkey or entry icon <Option#>

Subkey or entry icon <Pattern>

Subkey or entry icon <pod-name>

Subkey or entry icon <Pool-number>

Subkey or entry icon <printer-name>

Subkey or entry icon <printer-name>

Subkey or entry icon <printer-name>

Subkey or entry icon <processor-name>

Subkey or entry icon <Profile-number>

Subkey or entry icon <Profile-number>

Subkey or entry icon <Realm-name>

Subkey or entry icon <Scheme-name>

Subkey or entry icon <server-name>

Subkey or entry icon <Server-name>

Subkey or entry icon <Server-name>

Subkey or entry icon <service-name>

Subkey or entry icon <SID>

Subkey or entry icon <SID>

Subkey or entry icon <sort-code>

Subkey or entry icon <Source-name>

Subkey or entry icon <Zone-name>

Subkey or entry icon (Network adapters) {4D36E972-E325-11CE-BFC1-08002BE10318}

Subkey or entry icon \Device\Serial#

Subkey or entry icon \REGISTRY\MACHINE\HARDWARE

Subkey or entry icon \REGISTRY\MACHINE\SAM

Subkey or entry icon \REGISTRY\MACHINE\SECURITY

Subkey or entry icon \REGISTRY\MACHINE\SOFTWARE

Subkey or entry icon \REGISTRY\MACHINE\SYSTEM

Subkey or entry icon \REGISTRY\USER\<Security ID number>

Subkey or entry icon \REGISTRY\USER\.DEFAULT

Subkey or entry icon {1AA7F83F-C7F5-11D0-A376-00C04FC9DA04}

Subkey or entry icon {1AA7F840-C7F5-11D0-A376-00C04FC9DA04}

Subkey or entry icon {1AA7F841-C7F5-11D0-A376-00C04FC9DA04}

Subkey or entry icon {1AA7F846-C7F5-11D0-A376-00C04FC9DA04}

Subkey or entry icon {450D8FBA-AD25-11D0-98A8-0800361B1103}

Subkey or entry icon {BDEADF00-C265-11D0-BCED-00A0C90AB50F}

Subkey or entry icon 1.0

Subkey or entry icon 13

- A -

Subkey or entry icon AcceptVJCompression

Subkey or entry icon Accessibility

Subkey or entry icon Accounting

Subkey or entry icon AccountLockout

Subkey or entry icon AckTimeout

Subkey or entry icon ACP

Subkey or entry icon ActiveDesktop

Subkey or entry icon ActiveProvider

Subkey or entry icon ActiveProvider

Subkey or entry icon ActiveWndTrkTimeout

Subkey or entry icon ActivityLogFlag

Subkey or entry icon Adapters

Subkey or entry icon Adapters

Subkey or entry icon Adapters

Subkey or entry icon AdapterTimeoutCacheTime

Subkey or entry icon Add

Subkey or entry icon AddPrinterDrivers

Subkey or entry icon Address

Subkey or entry icon AddressAnswerLimit

Subkey or entry icon AdminComponent

Subkey or entry icon Advanced

Subkey or entry icon AeDebug

Subkey or entry icon Aging

Subkey or entry icon Alerter

Subkey or entry icon AlertNames

Subkey or entry icon allocatecdroms

Subkey or entry icon allocatedasd

Subkey or entry icon allocatefloppies

Subkey or entry icon Allow Browse

Subkey or entry icon Allow Browse

Subkey or entry icon Allow LM Authentication

Subkey or entry icon Allow SNMP Set

Subkey or entry icon AllowClientIpAddresses

Subkey or entry icon AllowedPaths

Subkey or entry icon AllowLockdownBrowse

Subkey or entry icon AllowLockdownMedia

Subkey or entry icon AllowLockdownPatch

Subkey or entry icon AllowRepInNonMixed

Subkey or entry icon AllowUnqualifiedQuery

Subkey or entry icon AllowUpdate

Subkey or entry icon AllowUserRawAccess

Subkey or entry icon Alternate Sorts

Subkey or entry icon AlternateShell

Subkey or entry icon AlwaysInstallElevated

Subkey or entry icon AlwaysInstallElevated

Subkey or entry icon AlwaysPinSubFolders

Subkey or entry icon AlwaysWithoutDS

Subkey or entry icon APIProtocolSupport

Subkey or entry icon App Management

Subkey or entry icon App Management

Subkey or entry icon AppData

Subkey or entry icon Appearance

Subkey or entry icon AppendToLogFile

Subkey or entry icon AppInit_DLLs

Subkey or entry icon ApplyToRemovableMedia

Subkey or entry icon ArpAlwaysSourceRoute

Subkey or entry icon ArpCacheLife

Subkey or entry icon ArpCacheMinReferencedLife

Subkey or entry icon ArpRetryCount

Subkey or entry icon ArpTRSingleRoute

Subkey or entry icon ArpUseEtherSNAP

Subkey or entry icon AssignedOfflineFolders

Subkey or entry icon AssignedOfflineFolders

Subkey or entry icon AtmUni

Subkey or entry icon Attributes

Subkey or entry icon AuthenticateRetries

Subkey or entry icon AuthenticateTime

Subkey or entry icon Authentication

Subkey or entry icon Authentication Packages

Subkey or entry icon AuthorizationDlls

Subkey or entry icon AuthSrv

Subkey or entry icon Auto

Subkey or entry icon Auto Publishing

Subkey or entry icon AutoAdminLogon

Subkey or entry icon AutoArrange

Subkey or entry icon AutoConfigFileZones

Subkey or entry icon AutoDisconnect

Subkey or entry icon AutoEndTasks

Subkey or entry icon AutoReboot

Subkey or entry icon AutoRestartShell

Subkey or entry icon AutoRun

Subkey or entry icon Autorun

Subkey or entry icon AutoRun

Subkey or entry icon AutoRunAlwaysDisable

Subkey or entry icon AutoSiteCoverage

Subkey or entry icon AUX

Subkey or entry icon AvoidPdcOnWan

- B -

Subkey or entry icon Backup Engine

Subkey or entry icon Backup files inuse

Subkey or entry icon BackupBrowserRecoveryTime

Subkey or entry icon BackupDatabasePath

Subkey or entry icon BackupDirPath

Subkey or entry icon BackupInterval

Subkey or entry icon BackupRestore

Subkey or entry icon BapListenTimeout

Subkey or entry icon BeepEnabled

Subkey or entry icon BeepEnabled

Subkey or entry icon BehaviorOnFailedVerify

Subkey or entry icon Bind

Subkey or entry icon Bind

Subkey or entry icon BindSecondaries

Subkey or entry icon boot

Subkey or entry icon BootExecute

Subkey or entry icon BootMethod

Subkey or entry icon BootVerification

Subkey or entry icon BootVerificationProgram

Subkey or entry icon BorderWidth

Subkey or entry icon Bounds

Subkey or entry icon BrowsePrintWorkstations

Subkey or entry icon BrowserFindMasterTimeout

Subkey or entry icon BrowserMinimumConfiguredBrowsers

Subkey or entry icon BscAckFrequency

Subkey or entry icon BufFilesDenyWrite

Subkey or entry icon BufNamedPipes

Subkey or entry icon BuiltIn

Subkey or entry icon BurstHandlingF

- C -

Subkey or entry icon CachedLogonsCount

Subkey or entry icon CacheFileTimeout

Subkey or entry icon CachePrimaryDomain

Subkey or entry icon Calendars

Subkey or entry icon CallbackRetries

Subkey or entry icon CallbackTime

Subkey or entry icon CapPercentsAt100

Subkey or entry icon CaptionFont

Subkey or entry icon CaptionHeight

Subkey or entry icon CaptionWidth

Subkey or entry icon CaretWidth

Subkey or entry icon CategoryCount

Subkey or entry icon CategoryMessageFile

Subkey or entry icon Cdrom

Subkey or entry icon CertificationAuthorities

Subkey or entry icon CertInfoCacheSize

Subkey or entry icon ChangeLogSize

Subkey or entry icon CheyenneDMG

Subkey or entry icon Class

Subkey or entry icon ClassicShell

Subkey or entry icon CleanupInterval

Subkey or entry icon ClearPageFileAtShutdown

Subkey or entry icon ClearRecentDocsOnExit

Subkey or entry icon CloseSiteTimeout

Subkey or entry icon ClusteredQMs

Subkey or entry icon ClusterName

Subkey or entry icon cmdline

Subkey or entry icon CNs

Subkey or entry icon CodePage

Subkey or entry icon Collect Timeout

Subkey or entry icon CollectionTime

Subkey or entry icon CollectUnicodeProcessNames

Subkey or entry icon Color Schemes

Subkey or entry icon Colors

Subkey or entry icon ColorTable<#>

Subkey or entry icon COMClassStore

Subkey or entry icon COMClassStore

Subkey or entry icon Comdlg32

Subkey or entry icon Command Processor

Subkey or entry icon Command Processor

Subkey or entry icon Common Desktop

Subkey or entry icon Common Documents

Subkey or entry icon Common Favorites

Subkey or entry icon Common Programs

Subkey or entry icon Common Start Menu

Subkey or entry icon Common Startup

Subkey or entry icon CommRetryCount

Subkey or entry icon CompletionChar

Subkey or entry icon CompletionChar

Subkey or entry icon ComSpec

Subkey or entry icon config.sys

Subkey or entry icon Configuration File

Subkey or entry icon Configuration Flags

Subkey or entry icon ConfirmUrl

Subkey or entry icon ConnectHomeDirToRoot

Subkey or entry icon Connections

Subkey or entry icon ConnectionType

Subkey or entry icon ConnectMultiplePorts

Subkey or entry icon ConnectTimeout

Subkey or entry icon ConsistencyCheck

Subkey or entry icon Console

Subkey or entry icon Control

Subkey or entry icon Control Panel

Subkey or entry icon Control Panel

Subkey or entry icon Control Panel

Subkey or entry icon ControlProtocols

Subkey or entry icon ControlReceiveWindow

Subkey or entry icon ConvertedToLinks

Subkey or entry icon CoolSwitch

Subkey or entry icon CoolSwitchColumns

Subkey or entry icon CoolSwitchRows

Subkey or entry icon Counter

Subkey or entry icon Cpu

Subkey or entry icon CrashControl

Subkey or entry icon CrashDumpEnabled

Subkey or entry icon CrashDumpFile

Subkey or entry icon CrashOnAuditFail

Subkey or entry icon CreateCrashDump

Subkey or entry icon CriticalDeviceDatabase

Subkey or entry icon CriticalSectionTimeout

Subkey or entry icon CryptKeyExpirationTime

Subkey or entry icon CryptReceiveKeyCacheSize

Subkey or entry icon CryptSendKeyCacheSize

Subkey or entry icon Current

Subkey or entry icon Current

Subkey or entry icon Current

Subkey or entry icon Current

Subkey or entry icon CurrentConfig

Subkey or entry icon CurrentControlSet

Subkey or entry icon CurrentMQISServer

Subkey or entry icon CurrentUser

Subkey or entry icon CurrentUser

Subkey or entry icon CurrentVersion

Subkey or entry icon CurrentVersion

Subkey or entry icon CurrentVersion

Subkey or entry icon CurrentVersion

Subkey or entry icon CursorBlinkRate

Subkey or entry icon CursorSize

Subkey or entry icon Custom Colors

Subkey or entry icon CustomColors

Subkey or entry icon CustomGoOfflineActions

Subkey or entry icon CustomGoOfflineActions

- D -

Subkey or entry icon Data File

Subkey or entry icon DatabaseCleanupInterval

Subkey or entry icon DatabaseDirectory

Subkey or entry icon DatabaseFile

Subkey or entry icon DatabaseName

Subkey or entry icon DatabasePath

Subkey or entry icon DatabasePath

Subkey or entry icon DataFiles

Subkey or entry icon DataTimeOut

Subkey or entry icon Datatype

Subkey or entry icon DbFileNm

Subkey or entry icon DBFlag

Subkey or entry icon DbType

Subkey or entry icon DCacheMinInterval

Subkey or entry icon DCacheUpdate

Subkey or entry icon DcCacheExpirationTime

Subkey or entry icon DcCacheSize

Subkey or entry icon DCI

Subkey or entry icon DCOption

Subkey or entry icon Debug Disable

Subkey or entry icon Debug Log File

Subkey or entry icon Debug Log Files

Subkey or entry icon Debug Log Severity

Subkey or entry icon Debug Maximum Log Messages

Subkey or entry icon DebugFlag

Subkey or entry icon DebugFlags

Subkey or entry icon Debugger

Subkey or entry icon DebugServerCommand

Subkey or entry icon Default

Subkey or entry icon Default

Subkey or entry icon Default Priority

Subkey or entry icon Default Priority

Subkey or entry icon Default Search Scope

Subkey or entry icon Default User Identity

Subkey or entry icon DefaultAgingState

Subkey or entry icon DefaultCallbackDelay

Subkey or entry icon DefaultCategory

Subkey or entry icon DefaultColor

Subkey or entry icon DefaultColor

Subkey or entry icon DefaultDomain

Subkey or entry icon DefaultDomainName

Subkey or entry icon DefaultGateway

Subkey or entry icon DefaultIdleTimeout

Subkey or entry icon DefaultLocation

Subkey or entry icon DefaultNoRefreshInterval

Subkey or entry icon DefaultNullDataSource

Subkey or entry icon DefaultPortLimit

Subkey or entry icon DefaultRefreshInterval

Subkey or entry icon DefaultRegistrationTTL

Subkey or entry icon DefaultScriptOptions

Subkey or entry icon DefaultSeparateVDM

Subkey or entry icon DefaultSessionTimeout

Subkey or entry icon DefaultSpoolDirectory

Subkey or entry icon DefaultSpoolDirectory

Subkey or entry icon DefaultSpoolDirectory

Subkey or entry icon DefaultTTL

Subkey or entry icon DefaultUserName

Subkey or entry icon DefCacheSize

Subkey or entry icon DeferredInit

Subkey or entry icon DelayedExpansion

Subkey or entry icon DelayedExpansion

Subkey or entry icon Delete

Subkey or entry icon DeleteRoamingCache

Subkey or entry icon DeleteRoamingCache

Subkey or entry icon Denials

Subkey or entry icon Dependent Files

Subkey or entry icon DependentFiles

Subkey or entry icon DependOnGroup

Subkey or entry icon DependOnService

Subkey or entry icon DESCRIPTION

Subkey or entry icon Description

Subkey or entry icon Description

Subkey or entry icon Desktop

Subkey or entry icon Desktop

Subkey or entry icon Desktop

Subkey or entry icon Desktop

Subkey or entry icon DesktopProcess

Subkey or entry icon DetectConflictRetries

Subkey or entry icon Device

Subkey or entry icon DEVICEMAP

Subkey or entry icon DeviceNotSelectedTimeout

Subkey or entry icon Devices

Subkey or entry icon Dfs

Subkey or entry icon DfsDriver

Subkey or entry icon DFSHost

Subkey or entry icon Dhcp

Subkey or entry icon DhcpDefaultGateway

Subkey or entry icon DhcpDomain

Subkey or entry icon DhcpDomain

Subkey or entry icon DhcpIPAddress

Subkey or entry icon DhcpLogDiskSpaceCheckInterval

Subkey or entry icon DhcpLogFilePath

Subkey or entry icon DhcpLogFilesMaxSize

Subkey or entry icon DhcpLogMinSpaceOnDisk

Subkey or entry icon DhcpNameServer

Subkey or entry icon DhcpNameServer

Subkey or entry icon DHCPServer

Subkey or entry icon DhcpServer

Subkey or entry icon DhcpSubnetMask

Subkey or entry icon DhcpSubnetMaskOpt

Subkey or entry icon DiffServByteMappingConforming

Subkey or entry icon DiffServByteMappingConforming

Subkey or entry icon DiffServByteMappingNonConforming

Subkey or entry icon DiffServByteMappingNonConforming

Subkey or entry icon Directory

Subkey or entry icon Directory

Subkey or entry icon Directory

Subkey or entry icon Directory

Subkey or entry icon Directory UI

Subkey or entry icon Disable Advanced

Subkey or entry icon Disable Advanced

Subkey or entry icon Disable Performance Counters

Subkey or entry icon Disable Performance Counters

Subkey or entry icon DisableAll

Subkey or entry icon DisableAll

Subkey or entry icon DisableAutoADMUpdate

Subkey or entry icon DisableAutoReverseZones

Subkey or entry icon DisableBkGndGroupPolicy

Subkey or entry icon DisableBrowse

Subkey or entry icon disablecad

Subkey or entry icon DisableChangePassword

Subkey or entry icon DisableCMD

Subkey or entry icon DisableDHCPMediaSense

Subkey or entry icon DisableDynamicUpdate

Subkey or entry icon DisableDynamicUpdate

Subkey or entry icon DisableFastStart

Subkey or entry icon DisableIPSourceRouting

Subkey or entry icon DisableLocalMachineRun

Subkey or entry icon DisableLocalMachineRun

Subkey or entry icon DisableLocalMachineRunOnce

Subkey or entry icon DisableLocalMachineRunOnce

Subkey or entry icon DisableLockWorkstation

Subkey or entry icon DisableMedia

Subkey or entry icon DisableMediaSenseEventLog

Subkey or entry icon DisableMSI

Subkey or entry icon DisablePagingExecutive

Subkey or entry icon DisablePasswordChange

Subkey or entry icon DisablePatch

Subkey or entry icon DisablePersonalDirChange

Subkey or entry icon DisableRegistryTools

Subkey or entry icon DisableReplaceAddressesInConflicts

Subkey or entry icon DisableReverseAddressRegistrations

Subkey or entry icon DisableRollback

Subkey or entry icon DisableRollback

Subkey or entry icon DisableSavePassword

Subkey or entry icon DisableServerThread

Subkey or entry icon DisableStatusMessages

Subkey or entry icon DisableTaskMgr

Subkey or entry icon DisableTaskOffload

Subkey or entry icon DisableWebPrinting

Subkey or entry icon DisallowCpl

Subkey or entry icon DisallowCpl

Subkey or entry icon DisallowRun

Subkey or entry icon DisallowRun

Subkey or entry icon Disk

Subkey or entry icon DiskQuota

Subkey or entry icon display.drv

Subkey or entry icon DisplayName

Subkey or entry icon DisplayName

Subkey or entry icon DisplayName

Subkey or entry icon DisplayNameFile

Subkey or entry icon DisplayNameID

Subkey or entry icon DNS

Subkey or entry icon DnsCache

Subkey or entry icon DNSclient

Subkey or entry icon DNSNameServers

Subkey or entry icon DnsRefreshInterval

Subkey or entry icon DnsTtl

Subkey or entry icon DoBackupOnTerm

Subkey or entry icon Documents

Subkey or entry icon Domain

Subkey or entry icon Domain

Subkey or entry icon Domains

Subkey or entry icon Domains

Subkey or entry icon DontAddDefaultGateway

Subkey or entry icon DontDisplayLastUserName

Subkey or entry icon DontNegotiateMultilinkOnSingleLinks

Subkey or entry icon DormantFileLimit

Subkey or entry icon DOS Devices

Subkey or entry icon DosKeybCodes

Subkey or entry icon DosKeybIDs

Subkey or entry icon DosPrint

Subkey or entry icon DoStaticDataInit

Subkey or entry icon DoubleClickHeight

Subkey or entry icon DoubleClickSpeed

Subkey or entry icon DoubleClickWidth

Subkey or entry icon Downlevel Browse

Subkey or entry icon DragAndDrop

Subkey or entry icon DragAndDrop

Subkey or entry icon DragFullWindows

Subkey or entry icon DragHeight

Subkey or entry icon DragWidth

Subkey or entry icon Driver

Subkey or entry icon Driver

Subkey or entry icon Driver

Subkey or entry icon Driver

Subkey or entry icon Driver Signing

Subkey or entry icon Driver Signing

Subkey or entry icon Driver Signing

Subkey or entry icon Drivers

Subkey or entry icon DrWatson

Subkey or entry icon DSAdsRefreshIPSitesIntervalSecs

Subkey or entry icon DSAdsRefreshNT4SitesIntervalSecs

Subkey or entry icon DSCliSearchAdsForServersIntervalSecs

Subkey or entry icon DsDriver

Subkey or entry icon DsIntegrated

Subkey or entry icon DSListRefresh

Subkey or entry icon DSSecurityCache

Subkey or entry icon DsSpooler

Subkey or entry icon DumpAllThreads

Subkey or entry icon DumpFile

Subkey or entry icon DumpSymbols

Subkey or entry icon DuplicateEventlogTimeout

Subkey or entry icon DynamicSiteName

- E -

Subkey or entry icon EAP

Subkey or entry icon EditLevel

Subkey or entry icon Enable

Subkey or entry icon EnableAdapterDomainNameRegistration

Subkey or entry icon EnableAddrMaskReply

Subkey or entry icon EnableAdminTSRemote

Subkey or entry icon EnableAuthenticationTraps

Subkey or entry icon EnableBcastArpReply

Subkey or entry icon EnableBroadcastSpoolerStatus

Subkey or entry icon Enabled

Subkey or entry icon EnableDeadGWDetect

Subkey or entry icon EnableDHCP

Subkey or entry icon EnableExtensions

Subkey or entry icon EnableExtensions

Subkey or entry icon EnableFastRouteLookup

Subkey or entry icon EnableFilter

Subkey or entry icon EnableForRas

Subkey or entry icon EnableForRouting

Subkey or entry icon EnableMulticastForwarding

Subkey or entry icon EnablePlainTextPassword

Subkey or entry icon EnablePMTUBHDetect

Subkey or entry icon EnablePMTUDiscovery

Subkey or entry icon EnablePriorityBoost

Subkey or entry icon EnablePriorityBoost

Subkey or entry icon EnableProfileQuota

Subkey or entry icon EnableRegistryBoot

Subkey or entry icon EnableRSVP

Subkey or entry icon EnableRSVP

Subkey or entry icon EnableSecurityFilters

Subkey or entry icon EnableTracing

Subkey or entry icon EnableUserControl

Subkey or entry icon EnableWheelDetection

Subkey or entry icon Enforce

Subkey or entry icon EnforceShellExtensionSecurity

Subkey or entry icon EnterpriseId

Subkey or entry icon Enum

Subkey or entry icon Enum

Subkey or entry icon Enum

Subkey or entry icon Environment

Subkey or entry icon Environment

Subkey or entry icon Environments

Subkey or entry icon EOJTimeout

Subkey or entry icon ErrorControl

Subkey or entry icon ErrorMode

Subkey or entry icon Event Viewer

Subkey or entry icon Event Viewer

Subkey or entry icon EventLog

Subkey or entry icon EventLog

Subkey or entry icon EventLog

Subkey or entry icon EventLoggingLevel

Subkey or entry icon EventLoggingLevel

Subkey or entry icon EventLogLevel

Subkey or entry icon EventLogLevel

Subkey or entry icon EventMessageFile

Subkey or entry icon ExcludedProviders

Subkey or entry icon ExcludeExtensions

Subkey or entry icon ExcludeFromKnownDlls

Subkey or entry icon ExcludeProfileDirs

Subkey or entry icon Exclusive Tunnels

Subkey or entry icon Execution

Subkey or entry icon Execution

Subkey or entry icon ExpectedDialupDelay

Subkey or entry icon Explorer

Subkey or entry icon Explorer

Subkey or entry icon Explorer

Subkey or entry icon Explorer

Subkey or entry icon Export

Subkey or entry icon Export

Subkey or entry icon ExtCounterTestLevel

Subkey or entry icon ExtensionAgents

Subkey or entry icon ExtensionDlls

Subkey or entry icon Extensions

- F -

Subkey or entry icon FaceName

Subkey or entry icon Failed

Subkey or entry icon FailureTimeout

Subkey or entry icon FastPrintSlowDownThreshold

Subkey or entry icon FastPrintThrottleTimeout

Subkey or entry icon FastPrintWaitTimeout

Subkey or entry icon Favorites

Subkey or entry icon FFPControlFlags

Subkey or entry icon FFPFastForwardingCacheSize

Subkey or entry icon File

Subkey or entry icon File Manager

Subkey or entry icon FileRenameOperations

Subkey or entry icon FilesNotToBackup

Subkey or entry icon FileSystem

Subkey or entry icon FirstWanNode

Subkey or entry icon Font Drivers

Subkey or entry icon FontDPI

Subkey or entry icon FontFamily

Subkey or entry icon Fonts

Subkey or entry icon FontSize

Subkey or entry icon FontSmoothing

Subkey or entry icon FontSubstitutes

Subkey or entry icon FontWeight

Subkey or entry icon ForceActiveDesktopOn

Subkey or entry icon ForcedDSServer

Subkey or entry icon ForceFifoEnable

Subkey or entry icon ForceNoTransactionModeSwitch

Subkey or entry icon ForceStartMenuLogOff

Subkey or entry icon ForegroundFlashCount

Subkey or entry icon ForegroundLockTimeout

Subkey or entry icon Forms

Subkey or entry icon ForwardBroadcasts

Subkey or entry icon ForwardBufferMemory

Subkey or entry icon ForwardDelegations

Subkey or entry icon Forwarders

Subkey or entry icon ForwardingTimeout

Subkey or entry icon fPrintError

Subkey or entry icon fPrintFileLine

Subkey or entry icon fPrintVerbose

Subkey or entry icon fPrintWarning

Subkey or entry icon fPromptOnError

Subkey or entry icon fPromptOnVerbose

Subkey or entry icon fPromptOnWarning

Subkey or entry icon FriendlyName

Subkey or entry icon FriendlyNetworkInterfaceNames

Subkey or entry icon From

Subkey or entry icon FullScreen

- G -

Subkey or entry icon GcSiteCoverage

Subkey or entry icon GetBrowserListThreshold

Subkey or entry icon GlobalFlag

Subkey or entry icon GlobalMaxTcpWindowSize

Subkey or entry icon GoOfflineAction

Subkey or entry icon GoOfflineAction

Subkey or entry icon GraphicsDrivers

Subkey or entry icon GRE_Initialize

Subkey or entry icon GreyMSIAds

Subkey or entry icon GridGranularity

Subkey or entry icon Group

Subkey or entry icon Group Policy

Subkey or entry icon Group Policy Editor

Subkey or entry icon GroupOrderList

Subkey or entry icon GroupPolicyMinTransferRate

Subkey or entry icon GroupPolicyMinTransferRate

Subkey or entry icon GroupPolicyRefreshTime

Subkey or entry icon GroupPolicyRefreshTime

Subkey or entry icon GroupPolicyRefreshTimeDC

Subkey or entry icon GroupPolicyRefreshTimeOffset

Subkey or entry icon GroupPolicyRefreshTimeOffset

Subkey or entry icon GroupPolicyRefreshTimeOffsetDC

- H -

Subkey or entry icon HARDWARE

Subkey or entry icon Hardware Profiles

Subkey or entry icon Hardware Profiles

Subkey or entry icon HelloInterval

Subkey or entry icon HelloMs

Subkey or entry icon Help

Subkey or entry icon Help File

Subkey or entry icon HideDirectoryFolder

Subkey or entry icon HideLegacyLogonScripts

Subkey or entry icon HideLogoffScripts

Subkey or entry icon HideLogonScripts

Subkey or entry icon HideShutdownScripts

Subkey or entry icon HideStartupScripts

Subkey or entry icon HistoryBufferSize

Subkey or entry icon hivelist

Subkey or entry icon HKEY_CLASSES_ROOT

Subkey or entry icon HKEY_CURRENT_CONFIG

Subkey or entry icon HKEY_CURRENT_USER

Subkey or entry icon HKEY_LOCAL_MACHINE

Subkey or entry icon HKEY_USERS

Subkey or entry icon HostName

Subkey or entry icon Hostname

Subkey or entry icon Hosts

Subkey or entry icon Hotkey

Subkey or entry icon HungAppTimeout

Subkey or entry icon i8042prt

- I -

Subkey or entry icon IAS

Subkey or entry icon iCalendarType

Subkey or entry icon IconFont

Subkey or entry icon IconSpacing

Subkey or entry icon IconTitleWrap

Subkey or entry icon IconVerticalSpacing

Subkey or entry icon iCountry

Subkey or entry icon iCurrDigits

Subkey or entry icon iCurrency

Subkey or entry icon iDate

Subkey or entry icon IDConfigDB

Subkey or entry icon iDigits

Subkey or entry icon IdleAckDelay

Subkey or entry icon IdleAckDelay

Subkey or entry icon iFirstDayOfWeek

Subkey or entry icon iFirstWeekOfYear

Subkey or entry icon IGMPIdle

Subkey or entry icon IGMPLevel

Subkey or entry icon IgnoreBroadcastFlag

Subkey or entry icon IgnoreFramingMismatch

Subkey or entry icon IgnoreNoRevocationCheck

Subkey or entry icon IgnoreRevocationOffline

Subkey or entry icon IllegalDatagramResetTime

Subkey or entry icon IlmiRegisterAddresses

Subkey or entry icon iLZero

Subkey or entry icon ImagePath

Subkey or entry icon ImagePath

Subkey or entry icon IME File

Subkey or entry icon iMeasure

Subkey or entry icon Immortal

Subkey or entry icon IncludeRegInProQuota

Subkey or entry icon iNegCurr

Subkey or entry icon iNegNumber

Subkey or entry icon InitialAddressPoolSize

Subkey or entry icon InitialBalloonTimeoutSeconds

Subkey or entry icon InitialBalloonTimeoutSeconds

Subkey or entry icon InitialKeyboardIndicators

Subkey or entry icon InitialSendTimeoutMs

Subkey or entry icon InitTimePause

Subkey or entry icon InitTimeReplication

Subkey or entry icon InitTimeReplication

Subkey or entry icon InsertMode

Subkey or entry icon InstalledComponents

Subkey or entry icon Installer

Subkey or entry icon Installer

Subkey or entry icon InstallLanguage

Subkey or entry icon Instructions

Subkey or entry icon IntelliMenus

Subkey or entry icon Intellimenus

Subkey or entry icon Interfaces

Subkey or entry icon Interfaces

Subkey or entry icon International

Subkey or entry icon International

Subkey or entry icon Internet Print Provider

Subkey or entry icon IoPageLockLimit

Subkey or entry icon Ip

Subkey or entry icon IPAddress

Subkey or entry icon IPAutoconfigurationAddress

Subkey or entry icon IPAutoconfigurationEnabled

Subkey or entry icon IPAutoconfigurationEnabled

Subkey or entry icon IPAutoconfigurationMask

Subkey or entry icon IPAutoconfigurationMask

Subkey or entry icon IPAutoconfigurationSeed

Subkey or entry icon IPAutoconfigurationSeed

Subkey or entry icon IPAutoconfigurationSubnet

Subkey or entry icon IPAutoconfigurationSubnet

Subkey or entry icon IPEnableRouter

Subkey or entry icon IpEnableRouterBackup

Subkey or entry icon IpOutHighWatermark

Subkey or entry icon IpOutLowWatermark

Subkey or entry icon Ipx

Subkey or entry icon IsSlave

Subkey or entry icon iTime

Subkey or entry icon iTimePrefix

Subkey or entry icon iTLZero

- J -

Subkey or entry icon JoinStatus

- K -

Subkey or entry icon KdcNames

Subkey or entry icon KdcSrvPort

Subkey or entry icon KeepAliveInterval

Subkey or entry icon KeepAliveTime

Subkey or entry icon KeepConn

Subkey or entry icon KeepRasConnection

Subkey or entry icon Kerberos

Subkey or entry icon KernelDumpOnly

Subkey or entry icon Keyboard

Subkey or entry icon Keyboard Layout

Subkey or entry icon Keyboard Layout

Subkey or entry icon Keyboard Layouts

Subkey or entry icon KeyboardDataQueueSize

Subkey or entry icon KeyboardDelay

Subkey or entry icon KeyboardDeviceBaseName

Subkey or entry icon KeyboardSpeed

Subkey or entry icon KeysNotToRestore

Subkey or entry icon KeyType

Subkey or entry icon KnownDLLs

Subkey or entry icon KnownDLLs

Subkey or entry icon KpasswdNames

- L -

Subkey or entry icon Language

Subkey or entry icon Language Groups

Subkey or entry icon LanMan Print Services

Subkey or entry icon LanMan Print Services

Subkey or entry icon LanMan Print Services Port

Subkey or entry icon LanmanServer

Subkey or entry icon LanmanWorkstation

Subkey or entry icon LanOnlyMode

Subkey or entry icon LargeSystemCache

Subkey or entry icon LastKnownGood

Subkey or entry icon LastPrivateQueueId

Subkey or entry icon Layout File

Subkey or entry icon Layout Id

Subkey or entry icon Layout Text

Subkey or entry icon LdapGcSrvPort

Subkey or entry icon LdapSrvPort

Subkey or entry icon LdapSrvPriority

Subkey or entry icon LdapSrvWeight

Subkey or entry icon Lease

Subkey or entry icon LeaseObtainedTime

Subkey or entry icon LeaseTerminatesTime

Subkey or entry icon LegacyDiscovered

Subkey or entry icon LegalNoticeCaption

Subkey or entry icon LegalNoticeText

Subkey or entry icon Library Validation Code

Subkey or entry icon Limit

Subkey or entry icon LimitUnits

Subkey or entry icon Linkage

Subkey or entry icon Linkage

Subkey or entry icon LinkResolveIgnoreLinkInfo

Subkey or entry icon List

Subkey or entry icon ListenAddresses

Subkey or entry icon LkgMQISServer

Subkey or entry icon lmcompatibilitylevel

Subkey or entry icon load

Subkey or entry icon LoadConIme

Subkey or entry icon LoadTrustedDrivers

Subkey or entry icon Locale

Subkey or entry icon Locale

Subkey or entry icon LocalNetPriority

Subkey or entry icon LocalVolumes

Subkey or entry icon Location

Subkey or entry icon Location

Subkey or entry icon LockIncrement

Subkey or entry icon LockMaximum

Subkey or entry icon LockQuota

Subkey or entry icon LogDataCreated

Subkey or entry icon LogDetailedEvents

Subkey or entry icon LogElectionPackets

Subkey or entry icon LogEvent

Subkey or entry icon LogEventOverLimit

Subkey or entry icon LogEventOverThreshold

Subkey or entry icon LogFifo

Subkey or entry icon LogFileMaxSize

Subkey or entry icon LogFileName

Subkey or entry icon LogFilePath

Subkey or entry icon LogFilePath

Subkey or entry icon LogFilePath

Subkey or entry icon LogFlags

Subkey or entry icon Logging

Subkey or entry icon Logging

Subkey or entry icon Logging

Subkey or entry icon Logging

Subkey or entry icon LoggingFlags

Subkey or entry icon LoggingOn

Subkey or entry icon LoginAccount

Subkey or entry icon LoginPrompt

Subkey or entry icon LogLevel

Subkey or entry icon LogLevel

Subkey or entry icon LogMgrBuffers

Subkey or entry icon LogMgrChkptInterval

Subkey or entry icon LogMgrFileSize

Subkey or entry icon LogMgrFlushInterval

Subkey or entry icon LogMgrProbeInterval

Subkey or entry icon LogMgrTimerInterval

Subkey or entry icon Logon

Subkey or entry icon LogonPrompt

Subkey or entry icon LogonScript

Subkey or entry icon LogPixels

Subkey or entry icon LongLiveTime

Subkey or entry icon LooseWildcarding

Subkey or entry icon LowDelayBound

Subkey or entry icon LowDelayBound

Subkey or entry icon LowerBandwidthThreshold

Subkey or entry icon LowerRange

Subkey or entry icon LowPowerActive

Subkey or entry icon LowPowerTimeOut

Subkey or entry icon LPT_timeout

Subkey or entry icon Lsa

- M -

Subkey or entry icon MACCP

Subkey or entry icon Machine

Subkey or entry icon MachineCache

Subkey or entry icon MachineDN

Subkey or entry icon MachineDomain

Subkey or entry icon MachineJournalQuota

Subkey or entry icon MachineQuota

Subkey or entry icon MAILSLOT

Subkey or entry icon MailslotBuffers

Subkey or entry icon MailslotDatagramThreshold

Subkey or entry icon MailslotDuplicateTimeout

Subkey or entry icon MailslotMessageTimeout

Subkey or entry icon Manufacturer

Subkey or entry icon MapGeneralInfo

Subkey or entry icon MapGeneralInfo

Subkey or entry icon MasterId

Subkey or entry icon MasterServers

Subkey or entry icon Max Retries

Subkey or entry icon Max Retries

Subkey or entry icon MaxAckDelayMs

Subkey or entry icon MaxActiveThreads

Subkey or entry icon MaxCacheEntryTtlLimit

Subkey or entry icon MaxCacheTtl

Subkey or entry icon MaxCmds

Subkey or entry icon MaxCollectionCount

Subkey or entry icon MaxConcurrentApi

Subkey or entry icon MaxConfigure

Subkey or entry icon MaxDenials

Subkey or entry icon MaxFailure

Subkey or entry icon MaxForwardBufferMemory

Subkey or entry icon MaxForwardPending

Subkey or entry icon MaxFreeConnections

Subkey or entry icon MaxFreeTcbs

Subkey or entry icon MaxFreeTWTcbs

Subkey or entry icon MaxGlobalOpenSearch

Subkey or entry icon MaxGPOScriptWait

Subkey or entry icon MaxGPOScriptWait

Subkey or entry icon MaxHashTableSize

Subkey or entry icon MaximumBrowseEntries

Subkey or entry icon MaximumCrashes

Subkey or entry icon MaximumLogFileSize

Subkey or entry icon MaximumMailslotMessages

Subkey or entry icon MaximumPasswordAge

Subkey or entry icon MaximumPortsServiced

Subkey or entry icon MaxKeepSearch

Subkey or entry icon MaxLinkDelay

Subkey or entry icon MaxMessageSize

Subkey or entry icon MaxMpxCt

Subkey or entry icon MaxNonpagedMemoryUsage

Subkey or entry icon MaxNormLookupMemory

Subkey or entry icon MaxNumForwardPackets

Subkey or entry icon MaxOutOfOrder

Subkey or entry icon MaxOutstandingSends

Subkey or entry icon MaxOutstandingSends

Subkey or entry icon MaxPagedMemoryUsage

Subkey or entry icon MaxProcessingThreads

Subkey or entry icon MaxProfileSize

Subkey or entry icon MaxRawWorkItems

Subkey or entry icon MaxRecentDocs

Subkey or entry icon MaxRecsAtATime

Subkey or entry icon MaxReject

Subkey or entry icon MaxRetransmits

Subkey or entry icon MaxRpcSize

Subkey or entry icon MaxRRThreads

Subkey or entry icon MaxSendTimeoutMs

Subkey or entry icon MaxSize

Subkey or entry icon MaxSOACacheEntryTtlLimit

Subkey or entry icon MaxSysQueue

Subkey or entry icon MaxTerminate

Subkey or entry icon MaxThreadsPerQueue

Subkey or entry icon MaxTLSMessageLength

Subkey or entry icon MaxUnackedPacket

Subkey or entry icon MaxUserPort

Subkey or entry icon MaxWanEndpoints

Subkey or entry icon McastIntvl

Subkey or entry icon McastTtl

Subkey or entry icon MediumDelayBound

Subkey or entry icon MediumDelayBound

Subkey or entry icon MemberPrecedence

Subkey or entry icon MemCheckBoxInRunDlg

Subkey or entry icon Memory Management

Subkey or entry icon MenuFont

Subkey or entry icon MenuHeight

Subkey or entry icon MenuShowDelay

Subkey or entry icon MenuWidth

Subkey or entry icon MessageFont

Subkey or entry icon MessageID

Subkey or entry icon Microsoft

Subkey or entry icon Microsoft

Subkey or entry icon Microsoft

Subkey or entry icon Microsoft

Subkey or entry icon MigrateOn

Subkey or entry icon Migration

Subkey or entry icon MinAnimate

Subkey or entry icon MinArrange

Subkey or entry icon MinHorzGap

Subkey or entry icon Minimal

Subkey or entry icon MinOnRun

Subkey or entry icon MinRRThreads

Subkey or entry icon MinVertGap

Subkey or entry icon MinWanEndpoints

Subkey or entry icon MinWidth

Subkey or entry icon MMC

Subkey or entry icon MonitorDuplicateInstances

Subkey or entry icon Monitors

Subkey or entry icon Monitors

Subkey or entry icon Mouclass

Subkey or entry icon MountedDevices

Subkey or entry icon Mouse

Subkey or entry icon MouseDataQueueSize

Subkey or entry icon MouseDataQueueSize

Subkey or entry icon MouseDataQueueSize

Subkey or entry icon MouseResendStallTime

Subkey or entry icon MouseResolution

Subkey or entry icon MouseSpeed

Subkey or entry icon MouseSynchIn100ns

Subkey or entry icon MouseThreshold1

Subkey or entry icon MouseThreshold2

Subkey or entry icon mqisConnectionNumber

Subkey or entry icon mqisdb

Subkey or entry icon MQISServer

Subkey or entry icon MQISServersForJoin

Subkey or entry icon MQS

Subkey or entry icon MRxSmb

Subkey or entry icon MSMQ

Subkey or entry icon MsmqIpPingPort

Subkey or entry icon MsmqIpPort

Subkey or entry icon MsmqIpxPingPort

Subkey or entry icon MsmqIpxPort

Subkey or entry icon MSV1_0

Subkey or entry icon MTU

Subkey or entry icon MultiUILanguageID

- N -

Subkey or entry icon Name

Subkey or entry icon Name

Subkey or entry icon Name

Subkey or entry icon Name

Subkey or entry icon Name

Subkey or entry icon NameCheckFlag

Subkey or entry icon NameServer

Subkey or entry icon NameServer

Subkey or entry icon NASIpAddress

Subkey or entry icon NASIpAddress

Subkey or entry icon NC_AddRemoveComponents

Subkey or entry icon NC_AdvancedSettings

Subkey or entry icon NC_AllowAdvancedTCPIPConfig

Subkey or entry icon NC_ChangeBindState

Subkey or entry icon NC_DeleteAllUserConnection

Subkey or entry icon NC_DeleteConnection

Subkey or entry icon NC_DialupPrefs

Subkey or entry icon NC_LanChangeProperties

Subkey or entry icon NC_LanConnect

Subkey or entry icon NC_LanProperties

Subkey or entry icon NC_NewConnectionWizard

Subkey or entry icon NC_RasAllUserProperties

Subkey or entry icon NC_RasChangeProperties

Subkey or entry icon NC_RasConnect

Subkey or entry icon NC_RasMyProperties

Subkey or entry icon NC_RenameConnection

Subkey or entry icon NC_RenameMyRasConnection

Subkey or entry icon NC_ShowSharedAccessUI

Subkey or entry icon NC_ShowSharedAccessUI

Subkey or entry icon NC_Statistics

Subkey or entry icon Ndi

Subkey or entry icon NDIS

Subkey or entry icon NdisWan

Subkey or entry icon NDSPreferredServer

Subkey or entry icon NegativeCacheTime

Subkey or entry icon NegativeSOACacheTime

Subkey or entry icon NegotiateTime

Subkey or entry icon NetBIOSName

Subkey or entry icon NetCache

Subkey or entry icon NetCache

Subkey or entry icon NetFailureCacheTime

Subkey or entry icon NetHood

Subkey or entry icon Netlogon

Subkey or entry icon NetMessage

Subkey or entry icon NetPopup

Subkey or entry icon NetPopup

Subkey or entry icon NetPopupToComputer

Subkey or entry icon NetPopupToComputer

Subkey or entry icon NetPrinterDecayPeriod

Subkey or entry icon NetWare or Compatible Network

Subkey or entry icon Network

Subkey or entry icon Network

Subkey or entry icon Network

Subkey or entry icon Network

Subkey or entry icon Network

Subkey or entry icon Network

Subkey or entry icon Network Connections

Subkey or entry icon Network Connections

Subkey or entry icon NetworkPath

Subkey or entry icon NetworkProvider

Subkey or entry icon networkprovider

Subkey or entry icon NewGPOLinksDisabled

Subkey or entry icon Nls

Subkey or entry icon NMICrashDump

Subkey or entry icon NoActiveDesktop

Subkey or entry icon NoActiveDesktopChanges

Subkey or entry icon NoAddFromCDorFloppy

Subkey or entry icon NoAddFromInternet

Subkey or entry icon NoAddFromNetwork

Subkey or entry icon NoAddingComponents

Subkey or entry icon NoAddPage

Subkey or entry icon NoAddPrinter

Subkey or entry icon NoAddRemovePrograms

Subkey or entry icon NoBackButton

Subkey or entry icon NoBackgroundPolicy

Subkey or entry icon NoCacheViewer

Subkey or entry icon NoCacheViewer

Subkey or entry icon NoChangeAnimation

Subkey or entry icon NoChangeKeyboardNavigationIndicators

Subkey or entry icon NoChangeStartMenu

Subkey or entry icon NoChangingWallPaper

Subkey or entry icon NoClose

Subkey or entry icon NoClose

Subkey or entry icon NoCloseDragDropBands

Subkey or entry icon NoClosingComponents

Subkey or entry icon NoCommonGroups

Subkey or entry icon NoComponents

Subkey or entry icon NoComputersNearMe

Subkey or entry icon NoConfigCache

Subkey or entry icon NoConfigCache

Subkey or entry icon NoControlPanel

Subkey or entry icon NoDeletePrinter

Subkey or entry icon NoDeletingComponents

Subkey or entry icon NoDesktop

Subkey or entry icon NoDFSTab

Subkey or entry icon NoDisconnect

Subkey or entry icon NoDispAppearancePage

Subkey or entry icon NoDispBackgroundPage

Subkey or entry icon NoDispCpl

Subkey or entry icon NoDispScrSavPage

Subkey or entry icon NoDispSettingsPage

Subkey or entry icon NoDriveAutoRun

Subkey or entry icon NoDriveAutoRun

Subkey or entry icon NoDrives

Subkey or entry icon NoDriveTypeAutoRun

Subkey or entry icon NoDriveTypeAutoRun

Subkey or entry icon NoEditingComponents

Subkey or entry icon NoEncryptOnMove

Subkey or entry icon NoEntireNetwork

Subkey or entry icon NoFavoritesMenu

Subkey or entry icon NoFileAssociate

Subkey or entry icon NoFileAssociate

Subkey or entry icon NoFileMenu

Subkey or entry icon NoFileMenu

Subkey or entry icon NoFileMru

Subkey or entry icon NoFind

Subkey or entry icon NoFolderOptions

Subkey or entry icon NoGPOListChanges

Subkey or entry icon NoHardwareTab

Subkey or entry icon NoHTMLWallPaper

Subkey or entry icon NoInstrumentation

Subkey or entry icon NoInteractiveServices

Subkey or entry icon NoInternetIcon

Subkey or entry icon NoLogoff

Subkey or entry icon NoMakeAvailableOffline

Subkey or entry icon NoMakeAvailableOffline

Subkey or entry icon NoManageMyComputerVerb

Subkey or entry icon NoMovingBands

Subkey or entry icon NonBestEffortLimit

Subkey or entry icon NonBestEffortLimit

Subkey or entry icon NonEnum

Subkey or entry icon NonEnum

Subkey or entry icon NoNetConnectDisconnect

Subkey or entry icon NoNetHood

Subkey or entry icon NoNetworkConnections

Subkey or entry icon NonPagedPoolQuota

Subkey or entry icon NonPagedPoolSize

Subkey or entry icon NonServiceInstalled

Subkey or entry icon NoNTSecurity

Subkey or entry icon NoOfWorkThreads

Subkey or entry icon NoPlacesBar

Subkey or entry icon NoPopUpsOnBoot

Subkey or entry icon NoRecentDocsHistory

Subkey or entry icon NoRecentDocsMenu

Subkey or entry icon NoRecentDocsNetHood

Subkey or entry icon NoRecursion

Subkey or entry icon NoRefreshInterval

Subkey or entry icon NoReminders

Subkey or entry icon NoReminders

Subkey or entry icon NoRemovePage

Subkey or entry icon NoResolveSearch

Subkey or entry icon NoResolveTrack

Subkey or entry icon NoRevocationCheck

Subkey or entry icon NoRootRevocationCheck

Subkey or entry icon NoRun

Subkey or entry icon NoRun

Subkey or entry icon NoRunasInstallPrompt

Subkey or entry icon NoSaveSettings

Subkey or entry icon NoSaveSettings

Subkey or entry icon NoServices

Subkey or entry icon NoSetFolders

Subkey or entry icon NoSetTaskbar

Subkey or entry icon NoShellSearchButton

Subkey or entry icon NoSlowLink

Subkey or entry icon NoSMHelp

Subkey or entry icon NoSMMyDocs

Subkey or entry icon NoStartMenuSubFolders

Subkey or entry icon NoSupportInfo

Subkey or entry icon Notification Packages

Subkey or entry icon NotifyChange

Subkey or entry icon NotifyLevel

Subkey or entry icon NotifyServers

Subkey or entry icon NoTrayContextMenu

Subkey or entry icon NoViewContextMenu

Subkey or entry icon NoViewOnDrive

Subkey or entry icon NoWelcomeScreen

Subkey or entry icon NoWelcomeScreen

Subkey or entry icon NoWindowsSetupPage

Subkey or entry icon NoWindowsUpdate

Subkey or entry icon NT4 Instance Names

Subkey or entry icon Ntbackup

Subkey or entry icon NTDS

Subkey or entry icon NTEContextList

Subkey or entry icon NtFrs

Subkey or entry icon NtfsAllowExtendedCharacterIn8dot3Name

Subkey or entry icon NtfsDisable8dot3NameCreation

Subkey or entry icon NtfsDisableLastAccessUpdate

Subkey or entry icon NtfsEncryptionService

Subkey or entry icon NtlmMinClientSec

Subkey or entry icon NtlmMinServerSec

Subkey or entry icon NUL

Subkey or entry icon NullPort

Subkey or entry icon NUMBER_OF_PROCESSORS

Subkey or entry icon NumberOfButtons

Subkey or entry icon NumberOfButtons

Subkey or entry icon NumberOfCrashes

Subkey or entry icon NumberOfHistoryBuffers

Subkey or entry icon NumForwardPackets

Subkey or entry icon NumIllegalDatagramEvents

Subkey or entry icon NumShape

Subkey or entry icon NumTcbTablePartitions

Subkey or entry icon NV Domain

Subkey or entry icon NV PrimaryDnsSuffix

Subkey or entry icon NWCWorkstation

- O -

Subkey or entry icon ObjectDirectories

Subkey or entry icon ObjectName

Subkey or entry icon OCMsetup

Subkey or entry icon OEM URL

Subkey or entry icon OEMCP

Subkey or entry icon OEMHAL

Subkey or entry icon OnlyDynRecs

Subkey or entry icon Open Timeout

Subkey or entry icon OpenProcedureWaitTime

Subkey or entry icon Option

Subkey or entry icon Options

Subkey or entry icon Order

Subkey or entry icon Order

Subkey or entry icon Order

Subkey or entry icon OS/2 Subsystem for NT

Subkey or entry icon Os2LibPath

Subkey or entry icon OtherDependencies

Subkey or entry icon OtherDependencies

Subkey or entry icon OtherDomains

Subkey or entry icon OutgoingRole

Subkey or entry icon Override User-Name

Subkey or entry icon OverrideKeyboardSubtype

Subkey or entry icon OverrideKeyboardType

Subkey or entry icon Overwrite

- P -

Subkey or entry icon PagedPoolQuota

Subkey or entry icon PagedPoolSize

Subkey or entry icon PagingFiles

Subkey or entry icon PaintDesktopVersion

Subkey or entry icon ParameterMessageFile

Subkey or entry icon Parameters

Subkey or entry icon Parameters

Subkey or entry icon Parameters

Subkey or entry icon Parameters

Subkey or entry icon Parameters

Subkey or entry icon Parameters

Subkey or entry icon Parameters

Subkey or entry icon Parameters

Subkey or entry icon Parameters

Subkey or entry icon Parameters

Subkey or entry icon Parameters

Subkey or entry icon Parameters

Subkey or entry icon Parameters

Subkey or entry icon Parameters

Subkey or entry icon Parameters

Subkey or entry icon Parameters

Subkey or entry icon Parameters

Subkey or entry icon Parameters

Subkey or entry icon Parameters

Subkey or entry icon Parameters

Subkey or entry icon Parameters

Subkey or entry icon Parameters

Subkey or entry icon Parameters

Subkey or entry icon Parameters

Subkey or entry icon Parameters

Subkey or entry icon Parameters

Subkey or entry icon Parameters

Subkey or entry icon Parameters

Subkey or entry icon Parameters

Subkey or entry icon Parameters

Subkey or entry icon Parameters

Subkey or entry icon Parameters

Subkey or entry icon Parameters

Subkey or entry icon Parameters

Subkey or entry icon params

Subkey or entry icon Partners

Subkey or entry icon Password

Subkey or entry icon PasswordCmd

Subkey or entry icon PasswordExpiryWarning

Subkey or entry icon Path

Subkey or entry icon Path

Subkey or entry icon PathCompletionChar

Subkey or entry icon PathCompletionChar

Subkey or entry icon Pattern

Subkey or entry icon Patterns

Subkey or entry icon PayloadReceiveWindow

Subkey or entry icon PayloadSendWindow

Subkey or entry icon PDH

Subkey or entry icon PendingFileRenameOperations

Subkey or entry icon PendingUpgrades

Subkey or entry icon PerfDisk

Subkey or entry icon Perflib

Subkey or entry icon Perfmon

Subkey or entry icon Performance

Subkey or entry icon Performance

Subkey or entry icon Performance

Subkey or entry icon PerformRouterDiscovery

Subkey or entry icon PerformRouterDiscoveryBackup

Subkey or entry icon PermanentSettingChanges

Subkey or entry icon PermitShare

Subkey or entry icon PermittedManagers

Subkey or entry icon Persistent Connections

Subkey or entry icon PersistentRoutes

Subkey or entry icon Personal

Subkey or entry icon Personal

Subkey or entry icon PersonaNonGrata

Subkey or entry icon PerThreadDSServer

Subkey or entry icon pg2MaxObjPerView

Subkey or entry icon PhysicalLocation

Subkey or entry icon PhysicalLocationSupport

Subkey or entry icon Ping User-Name

Subkey or entry icon PIPE

Subkey or entry icon PipeIncrement

Subkey or entry icon PipeMaximum

Subkey or entry icon PnPData

Subkey or entry icon PointerDeviceBaseName

Subkey or entry icon PointerDeviceBaseName

Subkey or entry icon PointerDeviceBaseName

Subkey or entry icon Policies

Subkey or entry icon Policies

Subkey or entry icon Policies

Subkey or entry icon Policies

Subkey or entry icon Policy

Subkey or entry icon Policy

Subkey or entry icon Policy

Subkey or entry icon PollingIterations

Subkey or entry icon PollingIterationsMaximum

Subkey or entry icon PollStatusIterations

Subkey or entry icon PopupColors

Subkey or entry icon Port Number

Subkey or entry icon Ports

Subkey or entry icon PortThreadPriority

Subkey or entry icon PowerCfg

Subkey or entry icon PowerdownAfterShutdown

Subkey or entry icon PPP

Subkey or entry icon PPTPTcpMaxDataRetransmissions

Subkey or entry icon Preferences

Subkey or entry icon PreferredServer

Subkey or entry icon Preload

Subkey or entry icon Previous Names

Subkey or entry icon PreviousLocalHostname

Subkey or entry icon PrimaryDnsSuffix

Subkey or entry icon PrimaryModule

Subkey or entry icon Print

Subkey or entry icon Print

Subkey or entry icon Print Processor

Subkey or entry icon Print Processor

Subkey or entry icon Print Processors

Subkey or entry icon Printer Driver

Subkey or entry icon Printer Driver

Subkey or entry icon PrinterDriverData

Subkey or entry icon PrinterDriverData

Subkey or entry icon PrinterPorts

Subkey or entry icon Printers

Subkey or entry icon Printers

Subkey or entry icon Printers

Subkey or entry icon Printers

Subkey or entry icon Printers

Subkey or entry icon Printers

Subkey or entry icon Printers Page URL

Subkey or entry icon PrintHood

Subkey or entry icon PrintOption

Subkey or entry icon Priority

Subkey or entry icon Priority

Subkey or entry icon PriorityClass

Subkey or entry icon PriorityClassHigh

Subkey or entry icon PriorityControl

Subkey or entry icon PRN

Subkey or entry icon PROCESSOR_ARCHITECTURE

Subkey or entry icon PROCESSOR_LEVEL

Subkey or entry icon ProcessorAffinityMask

Subkey or entry icon ProcessorControl

Subkey or entry icon ProductOptions

Subkey or entry icon ProductSuite

Subkey or entry icon ProductType

Subkey or entry icon ProfileDlgTimeOut

Subkey or entry icon ProfileDlgTimeOut

Subkey or entry icon ProfileErrorAction

Subkey or entry icon ProfileQuotaMessage

Subkey or entry icon ProfileUnloadTimeout

Subkey or entry icon Program Groups

Subkey or entry icon Program Manager

Subkey or entry icon Programs

Subkey or entry icon Programs

Subkey or entry icon ProhibitIpSec

Subkey or entry icon PromptRunasInstallNetPath

Subkey or entry icon Propagate Method

Subkey or entry icon PropAllowGroup

Subkey or entry icon PropDenyGroup

Subkey or entry icon Property Pages

Subkey or entry icon Property Pages

Subkey or entry icon PropNetUpdNtf

Subkey or entry icon ProviderName

Subkey or entry icon ProviderOrder

Subkey or entry icon ProviderOrder

Subkey or entry icon Providers

Subkey or entry icon Providers

Subkey or entry icon Providers

Subkey or entry icon Providers

Subkey or entry icon Providers

Subkey or entry icon ProviderType

Subkey or entry icon PruneDownlevel

Subkey or entry icon PruningInterval

Subkey or entry icon PruningPriority

Subkey or entry icon PruningRetries

Subkey or entry icon PSCAckFrequencySN

Subkey or entry icon Psched

Subkey or entry icon Psched

Subkey or entry icon PswdSync

Subkey or entry icon Public

Subkey or entry icon PublishAddresses

Subkey or entry icon PublishAutonet

Subkey or entry icon PublishPrinters

Subkey or entry icon Pull

Subkey or entry icon Pulse

Subkey or entry icon PulseConcurrency

Subkey or entry icon PulseMaximum

Subkey or entry icon PulseTimeout1

Subkey or entry icon PulseTimeout2

Subkey or entry icon PurgeAtLogoff

Subkey or entry icon PurgeBuffer

Subkey or entry icon Push

- Q -

Subkey or entry icon QMId

Subkey or entry icon QmPbKeyCacheSize

Subkey or entry icon QMThreadNo

Subkey or entry icon Qos

Subkey or entry icon Qossp

Subkey or entry icon QueryLimit

Subkey or entry icon QuickEdit

- R -

Subkey or entry icon Randomize

Subkey or entry icon RasForce

Subkey or entry icon Rasl2tp

Subkey or entry icon RasMan

Subkey or entry icon RawIPAllowedProtocols

Subkey or entry icon RcvOnlyEnhMsgAuthn

Subkey or entry icon Rdr

Subkey or entry icon RealmFlags

Subkey or entry icon Recent

Subkey or entry icon RecursionRetry

Subkey or entry icon RecursionTimeout

Subkey or entry icon RefreshInterval

Subkey or entry icon RefreshInterval

Subkey or entry icon RefreshTimesPerDecayPeriod

Subkey or entry icon RefusePasswordChange

Subkey or entry icon RegisterDnsARecords

Subkey or entry icon RegisteredProcessors

Subkey or entry icon RegisterRoutersWithNameServers

Subkey or entry icon RegistrySizeLimit

Subkey or entry icon RegLocation

Subkey or entry icon ReminderBalloonTimeoutSeconds

Subkey or entry icon ReminderBalloonTimeoutSeconds

Subkey or entry icon ReminderFreqMinutes

Subkey or entry icon ReminderFreqMinutes

Subkey or entry icon RemoteAccess

Subkey or entry icon RemotePath

Subkey or entry icon RemoteQMMachine

Subkey or entry icon RemoveDuplicateCleanup

Subkey or entry icon Repl topology update delay (secs)

Subkey or entry icon Repl topology update period (secs)

Subkey or entry icon Repl topology update period (secs)

Subkey or entry icon ReplMsgTimeout

Subkey or entry icon ReplThreads

Subkey or entry icon ReportBootOk

Subkey or entry icon ReportControllerMissing

Subkey or entry icon ReportDC

Subkey or entry icon ReportEventsToEventLog

Subkey or entry icon RequestNameServerAddresses

Subkey or entry icon RequestVJCompression

Subkey or entry icon requiresignorseal

Subkey or entry icon RequireStrongKey

Subkey or entry icon ResendIterations

Subkey or entry icon ResetTime (mins)

Subkey or entry icon ResourceTimeoutCount

Subkey or entry icon RestartJobOnPoolEnabled

Subkey or entry icon RestartJobOnPoolEnabled

Subkey or entry icon RestartJobOnPoolError

Subkey or entry icon RestartJobOnPoolError

Subkey or entry icon RestartTimer

Subkey or entry icon RestoreFlag

Subkey or entry icon Restrict_Run

Subkey or entry icon RestrictAnonymous

Subkey or entry icon RestrictAuthorMode

Subkey or entry icon RestrictCpl

Subkey or entry icon RestrictCpl

Subkey or entry icon Restrictions

Subkey or entry icon Restrictions

Subkey or entry icon RestrictRun

Subkey or entry icon RestrictRun

Subkey or entry icon RestrictToPermittedSnapins

Subkey or entry icon Retention

Subkey or entry icon Retries

Subkey or entry icon Retries

Subkey or entry icon RetryPopup

Subkey or entry icon RetryPopup

Subkey or entry icon RMFlushInterval

Subkey or entry icon RoundRobin

Subkey or entry icon Route

Subkey or entry icon Route

Subkey or entry icon RouterCacheSize

Subkey or entry icon RouterCacheSize

Subkey or entry icon RouterType

Subkey or entry icon RpcCancelTimeout

Subkey or entry icon RpcProtocol

Subkey or entry icon RplOnAddressChg

Subkey or entry icon RplOnlyWCnfPnrs

Subkey or entry icon RRThreadIdleTTL

Subkey or entry icon RSVP

Subkey or entry icon Run

Subkey or entry icon Run

Subkey or entry icon Run

Subkey or entry icon run

Subkey or entry icon RunLogonScriptSync

Subkey or entry icon RunLogonScriptSync

Subkey or entry icon RunLogonScriptSync

Subkey or entry icon RunLogonScriptSync

Subkey or entry icon RunOnce

Subkey or entry icon RunStartupScriptSync

Subkey or entry icon RxFIFO

Subkey or entry icon s1159

Subkey or entry icon s2359

- S -

Subkey or entry icon SackOpts

Subkey or entry icon SafeBoot

Subkey or entry icon SafeForScripting

Subkey or entry icon SampleRate

Subkey or entry icon SampleRate

Subkey or entry icon SaveConnections

Subkey or entry icon SaveSettings

Subkey or entry icon SaveSettings

Subkey or entry icon ScavengeInterval

Subkey or entry icon ScavengeServers

Subkey or entry icon ScavengingInterval

Subkey or entry icon SchedulerThreadPriority

Subkey or entry icon Schema Update Allowed

Subkey or entry icon Schemes

Subkey or entry icon sCountry

Subkey or entry icon Screen Saver.<Screensaver-name>

Subkey or entry icon ScreenBufferSize

Subkey or entry icon ScreenColors

Subkey or entry icon ScreenSaveActive

Subkey or entry icon ScreenSaveActive

Subkey or entry icon ScreenSaverGracePeriod

Subkey or entry icon ScreenSaverIsSecure

Subkey or entry icon ScreenSaverIsSecure

Subkey or entry icon ScreenSaveTimeOut

Subkey or entry icon Scripts

Subkey or entry icon SCRNSAVE.EXE

Subkey or entry icon SCRNSAVE.EXE

Subkey or entry icon ScrollHeight

Subkey or entry icon ScrollWidth

Subkey or entry icon sCurrency

Subkey or entry icon sDate

Subkey or entry icon sDecimal

Subkey or entry icon sealsecurechannel

Subkey or entry icon SearchOrder

Subkey or entry icon SecondaryServers

Subkey or entry icon SecondLevelDataCache

Subkey or entry icon SecurePipeServers

Subkey or entry icon SecureResponses

Subkey or entry icon SecureSecondaries

Subkey or entry icon Security

Subkey or entry icon Security

Subkey or entry icon Security

Subkey or entry icon Security

Subkey or entry icon SecurityHostTime

Subkey or entry icon Select

Subkey or entry icon SendAlert

Subkey or entry icon SendMsgAuthn

Subkey or entry icon SendPort

Subkey or entry icon SendSignature

Subkey or entry icon SendTo

Subkey or entry icon Separator File

Subkey or entry icon Separator File

Subkey or entry icon SeqIDAtLastRestore

Subkey or entry icon SeqMaxAckDelay

Subkey or entry icon SeqResend10Time

Subkey or entry icon SeqResend13Time

Subkey or entry icon SeqResend46Time

Subkey or entry icon SeqResend79Time

Subkey or entry icon Serial

Subkey or entry icon Serial#

Subkey or entry icon SERIALCOMM

Subkey or entry icon Sermouse

Subkey or entry icon Server Manager

Subkey or entry icon ServerCertDigest

Subkey or entry icon ServerCertStore

Subkey or entry icon ServerFlags

Subkey or entry icon Servers

Subkey or entry icon Servers

Subkey or entry icon Servers

Subkey or entry icon Servers

Subkey or entry icon ServersCache

Subkey or entry icon ServerThread

Subkey or entry icon ServerThreadTimeout

Subkey or entry icon Service

Subkey or entry icon ServiceDll

Subkey or entry icon ServiceGroupOrder

Subkey or entry icon ServiceProvider

Subkey or entry icon Services

Subkey or entry icon Session Manager

Subkey or entry icon SessTimeout

Subkey or entry icon Settings

Subkey or entry icon Setup

Subkey or entry icon SFCDllCacheDir

Subkey or entry icon SFCDllCacheDir

Subkey or entry icon SfcQuota

Subkey or entry icon SfcQuota

Subkey or entry icon SfcScan

Subkey or entry icon SfcScan

Subkey or entry icon SfcShowProgress

Subkey or entry icon SfcShowProgress

Subkey or entry icon sGrouping

Subkey or entry icon Share Name

Subkey or entry icon Share Name

Subkey or entry icon Shared Parameters

Subkey or entry icon Shell

Subkey or entry icon Shell

Subkey or entry icon Shell Folders

Subkey or entry icon Shell Folders

Subkey or entry icon Shell Icon BPP

Subkey or entry icon ShellIconSize

Subkey or entry icon ShortcutCount

Subkey or entry icon ShortcutDirectory

Subkey or entry icon Show

Subkey or entry icon ShowCommonGroups

Subkey or entry icon ShowLanErrors

Subkey or entry icon ShowLogonOptions

Subkey or entry icon ShowPoliciesOnly

Subkey or entry icon Shutdown Setting

Subkey or entry icon ShutdownWithoutLogon

Subkey or entry icon signsecurechannel

Subkey or entry icon SiteCoverage

Subkey or entry icon SiteId

Subkey or entry icon SiteName

Subkey or entry icon SiteName

Subkey or entry icon SiteNameTimeout

Subkey or entry icon SizCharBuf

Subkey or entry icon size

Subkey or entry icon Size

Subkey or entry icon sLanguage

Subkey or entry icon sList

Subkey or entry icon sLongDate

Subkey or entry icon SlowLinkDetectEnabled

Subkey or entry icon SlowLinkDetectEnabled

Subkey or entry icon SlowLinkProfileDefault

Subkey or entry icon SlowLinkProfileDefault

Subkey or entry icon SlowLinkTimeOut

Subkey or entry icon SlowLinkTimeOut

Subkey or entry icon SlowLinkUIEnabled

Subkey or entry icon SMAddOns

Subkey or entry icon SmCaptionFont

Subkey or entry icon SmCaptionHeight

Subkey or entry icon SmCaptionWidth

Subkey or entry icon sMonDecimalSep

Subkey or entry icon sMonGrouping

Subkey or entry icon sMonThousandSep

Subkey or entry icon SnapToDefaultButton

Subkey or entry icon sNativeDigits

Subkey or entry icon sNegativeSign

Subkey or entry icon SNMP

Subkey or entry icon SOFTWARE

Subkey or entry icon Software

Subkey or entry icon SolicitationAddressBcast

Subkey or entry icon SoundNotification

Subkey or entry icon Sources

Subkey or entry icon SpoolDirectory

Subkey or entry icon SpoolDirectory

Subkey or entry icon SpoolerPriority

Subkey or entry icon sPositiveSign

Subkey or entry icon SpTime

Subkey or entry icon SpTime

Subkey or entry icon sShortDate

Subkey or entry icon Staging Space Limit in KB

Subkey or entry icon Stamp

Subkey or entry icon Start

Subkey or entry icon Start Menu

Subkey or entry icon StartMenuLogOff

Subkey or entry icon StartTime

Subkey or entry icon StartTime

Subkey or entry icon Startup

Subkey or entry icon StaticAddressPool

Subkey or entry icon StaticMQISServer

Subkey or entry icon StatMon

Subkey or entry icon StatusFont

Subkey or entry icon StatusUpdateEnabled

Subkey or entry icon StatusUpdateInterval

Subkey or entry icon sThousand

Subkey or entry icon sTime

Subkey or entry icon sTimeFormat

Subkey or entry icon StoreAckTimeout

Subkey or entry icon StoreInSeqLogPath

Subkey or entry icon StoreJournalPath

Subkey or entry icon StoreLogPath

Subkey or entry icon StoreMqLogPath

Subkey or entry icon StorePersistentPath

Subkey or entry icon StoreReliablePath

Subkey or entry icon StoreXactLogPath

Subkey or entry icon StrictFileParsing

Subkey or entry icon SubnetMask

Subkey or entry icon Substitutes

Subkey or entry icon SubSystems

Subkey or entry icon SupportLink

Subkey or entry icon SupportLinkName

Subkey or entry icon swapdisk

Subkey or entry icon SwapMouseButtons

Subkey or entry icon SynAttackProtect

Subkey or entry icon SyncAtLogoff

Subkey or entry icon SyncAtLogoff

Subkey or entry icon SynchronousMachineGroupPolicy

Subkey or entry icon SynchronousUserGroupPolicy

Subkey or entry icon SyncOpenPrinter

Subkey or entry icon SysQueuePriority

Subkey or entry icon System

Subkey or entry icon SYSTEM

Subkey or entry icon System

Subkey or entry icon System

Subkey or entry icon System

Subkey or entry icon System

Subkey or entry icon System

Subkey or entry icon System

Subkey or entry icon SystemDirectory

Subkey or entry icon SystemPages

Subkey or entry icon SystemStartOptions

Subkey or entry icon SysVol

Subkey or entry icon SysVolReady

Subkey or entry icon Sytos Plus ECC Flag

- T -

Subkey or entry icon T1

Subkey or entry icon T2

Subkey or entry icon Tag

Subkey or entry icon Task Creation

Subkey or entry icon Task Creation

Subkey or entry icon Task Deletion

Subkey or entry icon Task Deletion

Subkey or entry icon Task Scheduler5.0

Subkey or entry icon Task Scheduler5.0

Subkey or entry icon TaskMan

Subkey or entry icon TaskManager

Subkey or entry icon TCP/IP Port

Subkey or entry icon Tcp1323Opts

Subkey or entry icon TCPAllowedPorts

Subkey or entry icon TcpDelAckTicks

Subkey or entry icon TcpInitialRTT

Subkey or entry icon Tcpip

Subkey or entry icon TcpMaxConnectResponseRetransmissions

Subkey or entry icon TcpMaxConnectRetransmissions

Subkey or entry icon TcpMaxDataRetransmissions

Subkey or entry icon TcpMaxDupAcks

Subkey or entry icon TcpMaxHalfOpen

Subkey or entry icon TcpMaxHalfOpenRetried

Subkey or entry icon TcpMaxPortsExhausted

Subkey or entry icon TCPNoDelay

Subkey or entry icon TcpNumConnections

Subkey or entry icon TcpTimedWaitDelay

Subkey or entry icon TcpUseRFC1122UrgentPointer

Subkey or entry icon TcpWindowSize

Subkey or entry icon TEMP

Subkey or entry icon TEMP

Subkey or entry icon TemporarySettingChanges

Subkey or entry icon Threshold

Subkey or entry icon ThresholdUnits

Subkey or entry icon TileWallpaper

Subkey or entry icon TimeBelowThreshold

Subkey or entry icon TimeInterval

Subkey or entry icon TimeInterval

Subkey or entry icon Timeout

Subkey or entry icon Timeout

Subkey or entry icon TimerResolution

Subkey or entry icon TimerResolution

Subkey or entry icon TimesHelloForReplicationInterval

Subkey or entry icon Tips

Subkey or entry icon TMP

Subkey or entry icon TMP

Subkey or entry icon To

Subkey or entry icon Toggle

Subkey or entry icon TombstoneInterval

Subkey or entry icon TombstoneTimeout

Subkey or entry icon TotalInstanceName

Subkey or entry icon TransactionMode

Subkey or entry icon TransformsSecure

Subkey or entry icon Translators

Subkey or entry icon TransmissionRetryTimeout

Subkey or entry icon Transparency

Subkey or entry icon TrapConfiguration

Subkey or entry icon TrFunctionalMcastAddress

Subkey or entry icon TrueType

Subkey or entry icon TrustedDomainList

Subkey or entry icon TrustedDriverPath

Subkey or entry icon TTEnable

Subkey or entry icon TTonly

Subkey or entry icon TwoDigitYearMax

Subkey or entry icon TxFIFO

Subkey or entry icon Type

Subkey or entry icon Type

Subkey or entry icon Type 1 Fonts

Subkey or entry icon Type 1 Installer

Subkey or entry icon TypeOfInterface

Subkey or entry icon TypesSupported

- U -

Subkey or entry icon UDPAllowedPorts

Subkey or entry icon UMAddOns

Subkey or entry icon UNC

Subkey or entry icon UNICODE Groups

Subkey or entry icon UNICODE Program Groups

Subkey or entry icon Uninstall

Subkey or entry icon UntilTime

Subkey or entry icon UntilTime

Subkey or entry icon Update

Subkey or entry icon Update

Subkey or entry icon Update Retry Interval

Subkey or entry icon Update Retry Interval

Subkey or entry icon UpdateCount

Subkey or entry icon UpdateMode

Subkey or entry icon UpdateOptions

Subkey or entry icon UpdateSecurityLevel

Subkey or entry icon UpperRange

Subkey or entry icon Use fast file restore

Subkey or entry icon UseDomainNameDevolution

Subkey or entry icon UseDynamicDns

Subkey or entry icon UseLockReadUnlock

Subkey or entry icon UseMHAsyncDns

Subkey or entry icon UseOpportunisticLocking

Subkey or entry icon UsePing

Subkey or entry icon User Identity Attribute

Subkey or entry icon User Interface

Subkey or entry icon User Manager

Subkey or entry icon User Manager for Domains

Subkey or entry icon User Shell Folders

Subkey or entry icon User Shell Folders

Subkey or entry icon UserCacheExpirationTime

Subkey or entry icon UserCacheSize

Subkey or entry icon UserDebuggerHotKey

Subkey or entry icon Userinit

Subkey or entry icon UserList

Subkey or entry icon UserName

Subkey or entry icon UseRplPnrs

Subkey or entry icon UserPolicyMode

Subkey or entry icon UserPreferencesMask

Subkey or entry icon UserPriorityMapping

Subkey or entry icon UserPriorityMapping

Subkey or entry icon UserProfileMinTransferRate

Subkey or entry icon UseSelfFndPnrs

Subkey or entry icon UseUnlockBehind

Subkey or entry icon UseZeroBroadcast

- V -

Subkey or entry icon ValidCommunities

Subkey or entry icon VDD

Subkey or entry icon VerboseStatus

Subkey or entry icon VerifyInterval

Subkey or entry icon VerifyPublishedState

Subkey or entry icon VersCounterStartVal_HighWord

Subkey or entry icon VersCounterStartVal_LowWord

Subkey or entry icon Version

Subkey or entry icon Version-<number>

Subkey or entry icon VirtualDeviceDrivers

Subkey or entry icon VisualNotification

Subkey or entry icon VmApplet

- W -

Subkey or entry icon Wait time

Subkey or entry icon WaitTime

Subkey or entry icon WaitToKillAppTimeout

Subkey or entry icon WaitToKillServiceTimeout

Subkey or entry icon Wallpaper

Subkey or entry icon Wallpaper

Subkey or entry icon WallpaperStyle

Subkey or entry icon WallpaperStyle

Subkey or entry icon WAN Miniport (L2TP) <Device-number (000n)>

Subkey or entry icon WanEndpoints

Subkey or entry icon WarnUser

Subkey or entry icon WarnUserTimeout

Subkey or entry icon WaveFile

Subkey or entry icon Welcome

Subkey or entry icon WheelScrollLines

Subkey or entry icon Win31FileSystem

Subkey or entry icon Win32PrioritySeparation

Subkey or entry icon Win95TruncatedExtensions

Subkey or entry icon windir

Subkey or entry icon WindowMetrics

Subkey or entry icon WindowPosition

Subkey or entry icon Windows

Subkey or entry icon Windows

Subkey or entry icon Windows

Subkey or entry icon Windows

Subkey or entry icon Windows

Subkey or entry icon Windows

Subkey or entry icon Windows

Subkey or entry icon Windows File Protection

Subkey or entry icon Windows Help

Subkey or entry icon Windows NT

Subkey or entry icon Windows NT

Subkey or entry icon Windows NT

Subkey or entry icon Windows NT

Subkey or entry icon Windows <environment-name>

Subkey or entry icon WindowSize

Subkey or entry icon Winlogon

Subkey or entry icon Winlogon

Subkey or entry icon Winprint_TextNoCRTranslation

Subkey or entry icon Winprint_TextNoTranslation

Subkey or entry icon winreg

Subkey or entry icon WINS

Subkey or entry icon WINSNameServer

Subkey or entry icon WINSNameServerBackup

Subkey or entry icon Wizard

Subkey or entry icon Wizard

Subkey or entry icon Workgroup

Subkey or entry icon World Full Access Shared Parameters

Subkey or entry icon WOW

Subkey or entry icon WOW

Subkey or entry icon wowcmdline

Subkey or entry icon wowsize

Subkey or entry icon WriteAuthorityNs

Subkey or entry icon WriteMsgTimeout

- X -

Subkey or entry icon XactDeadLetterAlways

Subkey or entry icon XactDelayReceiveNack

Subkey or entry icon XfrConnectTimeout

- Y -

- Z -

Subkey or entry icon Zones


Technical Reference to the Registry: Alphabetical List

Alphabetical List of Registry Content

A B C D E F G H I J K L M
N O P Q R S T U V W X Y Z
To find the full registry path of any element, move your cursor over the element name. To see a complete description of the element, double-click the element name.


Technical Reference to the Registry: Related Resources

Technical Reference to the Registry

Related Resources

Information about registry content is designed for users who are well aquainted with the Windows 2000 registry and troubleshooting procedures. This information is available from a variety of sources and is being updated continuously.

Windows 2000 Help

The Windows 2000 Registry topic in Windows 2000 Help provides essential background information, including procedures for viewing and editing the registry.

Windows 2000 Server Resource Kit

The Windows 2000 Server Resource Kit Server Operations Guide contains information about the registry, including protecting and repairing the registry, and using the registry for troubleshooting.

If you have an Internet connection and a Web browser, you can click the following links to visit these sites.

Internet Windows 2000 Resource Kits Web Site

Windows Web Sites

Internet Windows 2000 Server

Internet Windows Web Site

Internet Windows NT Server Web Site

Internet Windows NT 4.0 Workstation Web Site

Internet Microsoft Support Web Site

Internet Windows Hardware Compatibility List

Other Microsoft World Wide Web Sites of Interest

Internet Microsoft Knowledge Base Search

Internet Microsoft Internet Explorer Web Site

Internet Microsoft TechNet

Internet MSDN Online: Essential Resources for Developers

Internet Newsgroups

Microsoft Home Page

For any other information about Microsoft products, point your browser to:

Internet Microsoft Home Page

© Copyright 1985-2000 Microsoft Corporation. All rights reserved.


Remote Access Server Flags

Binary | Hexadecimal | Result
10 | 0x00000002 | Software compression. Enables software compression over RAS.
100 | 0x00000004 | NETBEUI transport protocol. Makes NETBEUI transport protocol available to dial-in clients and routers.
1000 | 0x00000008 | IPX transport protocol. Makes the IPX transport protocol available to dial-in clients and routers.
100000 | 0x00000020 | Appletalk transport protocol. Makes the Appletalk transport protocol available to dial-in clients and routers.
1000000 | 0x00000040 | Shiva-PAP authentication protocol. Makes the Shiva-PAP authentication protocol available to dial-in clients and routers.
100000000 | 0x00000100 | CHAP authentication protocol. Makes the Microsoft Challenge Handshake Authentication Protocol (CHAP) authentication protocol available to dial-in clients and routers.
1000000000 | 0x00000200 | LCP extensions. Makes Link Control Protocol (LCP) extensions, such as callback and identification messages, available to dial-in clients and routers.
10000000000 | 0x00000400 | Multilink PPP protocol. Makes the Multilink PPP protocol available to dial-in clients and routers.
10000000000000 | 0x00002000 | BAP protocol. Makes the Bandwidth Allocation protocol (BAP) available to dial-in clients and routers.
100000000000000 | 0x00004000 | No authentication required. Clients connecting through any port may connect without being authenticated.
1000000000000000 | 0x00400000 | No authentication required for null modems. Clients connecting over direct connect ports, such as null modems and infrared ports, may connect without being authenticated.


SYN flooding attack protection

The SYN flooding attack protection feature of TCP detects symptoms of SYN flooding and responds by reducing the time server spends on connection requests that it cannot acknowledge.

Specifically, TCP shortens the required interval between SYN-ACK (connection request acknowledgements) retransmissions. (TCP retransmits SYN-ACKS when they are not answered.) As a result, the allotted number of retransmissions is consumed quicker and the unacknowledgeable connection request is discarded faster.

When enabled, the system monitors the connections maintained by TCP and starts SYN attack flooding protection when the any of the following conditions symptomatic of SYN flooding obtain:

  • The total number of connections in the half-open (SYN-RCVD) state exceeds the value of TcpMaxHalfOpen;
  • The number of connections that remain in the half-open (SYN-RCVD) state even after a connection request has been retransmitted exceeds the value of TcpMaxHalfOpenRetried;
  • The number of connection requests the system refuses exceeds the value of TcpMaxPortsExhausted. The system must refuse all connection requests when its reserve of open connection ports runs out.

SYN flooding protection is enabled when the value of SynAttackProtect is 1 and the value of TcpMaxConnectResponseRetransmissions is at least 2.