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1 Overview

Network Connectivity Manager (NCM) provides End-to-End service management
of a generic Mobile Back Haul network domain IP or Ethernet based.

End-to-end transport between the Access and the Core network can be
implemented by different technologies and service types in different parts of the
network, for example, L2 Ethernet services in the access part and L3 IP VPN
services in the aggregation part over a transport underlay managed by ENM
WAN SDN.

In the following figure a mobile backhaul network is represented which can be
provisioned using ENM together with the NCM application.

Figure 1    Mobile Backhaul Network

Overview
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2 Use the NCM Application

The NCM application consists of a dashboard, header, a navigation bar, and a
view panel.

2.1 Network Objects

The network objects used by NCM are NEs and component domains. These
resources must be either configured or synchronized before services can be
designed and activated with the NCM application. For details about view/
configuration of the following objects:

— NEs, see Network Elements View.

— Ports, port configuration is possible only via Topology Browser or Node CLI.

— Links, see Links View.

— Component Domain, see Prepare the Network for NCM Service, Reference[5]
for the population of a new component domain.

For details about resynchronizing the following objects: NEs, Ports, links and
configuring the objects like component domains, see the corresponding ENM
documentation.

2.2 Dashboard

The dashboard provides panels that show summary breakdowns by type and
state for Services.

Service Summary Panels

Service summary panels display the Service types. The graph bars in these
summary panels are service states.

Service summary panel: Active, Partially Active, and Inactive.

NCM User Guide
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Figure 2    Summary Panel

2.3 Navigation Bar and View Panels

The navigation bar allows to access all the functional areas of the application.
The view panels provide various actions to access resources, create templates
and services. The view panels also offer query functionality for resource
information. Refer to the table below for a list of available menus and actions
that it is possible to perform using the menus.

Table 1     Navigation Bar and View Panels

Menu Submenu View Panel Description More Information

Services Service LCM
(Life Cycle
Management)

Add, view, edit, activate, and
remove services.

Activate, bulk activate,
deactivate, detach, and
unroute Ethernet services.

Import CSV file containing
services. For more details,
see Inventory Import in the
NCM Service Discovery
guide, Reference[8] .

See
Section:Manage
Services.

Service
Discovery

Initiate the service discovery
task for Ethernet services.

See
Section:Discover
and Synchronize
Existing Services.

Templates E-LAN Add, view, edit, remove, and
bulk modify E-LAN service
templates.

Create NCM
Service Template.

Reference [6]

See also NCM
Service Creation
Roadmap,
Reference [4].

E-Line Add, view, edit, remove, and
bulk modify E-Line service
templates.

IP Add, view, edit, and remove
standard service templates
and related configuration
information of Service
Templates, CLI Templates,
and Global Configuration.

UNI
Bandwidth

Add, view, edit, and remove
Bandwidth.

End-Point Add, view, edit, remove, and
bulk modify End-Point
service templates.

End-Point
Profile

View, remove, customize
End-Point profiles.

Use the NCM Application
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Menu Submenu View Panel Description More Information

Resources Network

Elements

Manage NEs available for
Ethernet services:

— Access related views and
launch actions

— Organize NEs into
component domains

— Synch the NE

Links View, filter the list of Links. See
Section:Network
Objects.

Component

Domains

Add, populate, and modify
component domains.

See
Section:Network
Objects.

Reports Manage the different types
of service specific or network
reports. Select a report type,
enter specific date-range
parameters, and generate
reports that can be viewed
online and saved.

See Section:
Generate
Reports .

Diagnostics Collect the NCM server logs
and provide the database
diagnostic information.

For collection of
server logs, refer
to Collecting
System
Diagnostics in the
ENM System
Administrator
Guide.

Options User preferences can be
defined in 'General' tabs, as
follows:

"Do not prompt confirmation
dialog during service
activation" can be enabled or
disabled. Prompt
Confirmation Dialog during
service activation is based on
this preference.

See section:
Manage User
Preferences.

Network Synchronizati
on

Synchronize with the current
state of the Network

See
Section:Network
Objects.
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2.4 Tables

Tables are widely used in the NCM application to present information. They are
accessed from the navigation bar and by browsing from one table to another
using the Browse-to functionality.

By right-clicking a row in a table, it is possible to open a context-sensitive menu
that provides additional actions. These menus show possible actions depending
on the particular context: some menus permit basic actions like viewing,
modifying, and deleting , while some other provide advanced actions (basic
actions plus Browse-to functionality to other tables and launching functions).
The tables in the NCM application allow to delete multiple items at once. To
delete multiple items in a table:

— If the items are non-consecutive, hold the Ctrl button and select the rows to
be deleted.

If the items are consecutive, shift-click the first and last items of the table
that to be deleted.

— Right-click in any row to open a context-sensitive menu.

— Select Remove.

A vertical scroll bar appears when there are more rows that can be displayed in
the window. When there are more items that can be usably displayed on a page,
the table is paginated, and it is possible easily to move from page to page using
controls that appear below the table.

In any table accessed from the navigation bar, the number of items displayed has
an upper limit. Filter the table to make sure all the items to be viewed in the table
are displayed.

Use the NCM Application
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2.4.1 Customize the Appearance of Tables

It is possible to change the appearance of a table to display or organize rows
differently. The changes persist between user sessions. It is possible to make the
following alterations to the appearance of a table:

— Move columns: Click a column heading and drag and drop to the desired
spot.

— Change column width: Click the column border and slide the double-arrow
mouse cursor left and right. The minimum width of a column is 30 pixels.

— Sort within a column: Click the arrow next to the column heading to toggle
the sort order. If the table is grouped, the sorting is done within the current
grouping.

— Hide and show columns: Click the gearwheel icon at the far right of the
heading row to open the pop-up menu. Click the check box beside a column
label to show or hide the column.

— Group by a column: Click the gearwheel icon at the far right of the heading
row. Go to Columns grouping to open a drop-down menu, and click the
column label to group the table rows by. Click on a checked column label to
ungroup the rows.

— Expanding the table width off-screen: Click the gearwheel icon at the far
right of the heading row. Go to Expand content and click the percentage
value that the table width must be expanded by.

2.4.2 Filter Information in Tables

Filtering a table reduces the amount of information displayed, making it easier to
find an item of interest. Filtering is only available for tables accessed from the
navigation bar.

The filtering criteria for tables appear in one or more collapsible field groups
above the table. Click on the label to expand or collapse a field group. Enter the
search parameters in the fields. Wildcard characters are supported in text fields.

2.4.3 Access Tables

The NCM application is designed to access the tables that contain the detailed
needed information.

Two strategies are used: frequently accessed and essential information is
accessed rapidly using the navigation bar, and specialized information is
accessed intuitively using the Browse-to submenu in the context-sensitive
menus.

NCM User Guide
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2.4.4 Export Information in Tables

Each table's content can be exported as CSV file.

To export the information contained in the table:

1. Click Export

2. Save the export.csv file

Figure 3    Export of the Table Content

Once the export is complete it is possible to rename the export file as needed.

2.4.5 Synchronization

Click the Network navigation tab, to access the Synchronization page.

From this page, it is possible to synchronize with the latest state of Network.

Use the NCM Application
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The status messages of synchronization are shown in progress dialog as shown
above.

2.4.6 Network Elements View

The first time the NE view is open, all the NEs available for configuring E-Line/
E_LAN services are listed in order by name. It is possible to use the fields in the
Query filter field list to filter the NE list, to display the NEs of interest.

It is possible to navigate to Network Elements list following different paths:

Steps

1. Resources > Network Elements page.

2. Resources > Links page. Right-click on a link entry and select Browse >
Network Elements page.

NCM User Guide
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3. Resources > Component Domains page. Right-click on a Component Domain
entry and select Browse > Network Elements page.

4. Services > Service LCM page. Right-click on a service entry and select Browse
> Network Elements page.

Use the NCM Application
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2.4.7 Links View

The ENM user interface displays a link as a line connecting two network Element
icons. The ENM user interface also allows to retrieve information about links in
tabular form.

The NCM UI provides graphical representations of links in the logical service
topology view and the link diagram. There is no symbol to represent the
technology types of a link.

1. Path to Link Tables.

It is possible to navigate to Links list following different Paths:

a. Resources > Network Elements page. Right-click on a Network Element
entry and select Browse > Links page.

NCM User Guide
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2. Resources > Links page. Right-click on a link entry and select Browse >
Network Elements page.

3. Resources > Component Domains page. Right-click on a Component Domain
entry and select Browse > Network Elements page.

4. Services > Service LCM page. Right-click on a service entry and select Browse
> Network Elements page.

Use the NCM Application
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2.5 Manage User Preferences

Click Resource-Options navigation, to access the 'Options' page.

Thus, from the General tab, the user can configure the available options,
according to the required preferences, as follows:

1. Do not prompt confirmation dialog during service activation:

It is the user preference to activate any service, with or without confirmation
dialog prompt to the user.

a. If enabled, service activation starts immediately without prompting any
confirmation dialog to the user.

b. If disabled, during service activation 'confirmation dialog' is prompted to
the user. User can enable the preference again by selecting “Do Not
Show this message again” check-box in any 'Service Activation
Confirmation Dialog Prompt' and this preference is persisted for that
user.

The option is applicable to the activation process of all types of services.

NCM User Guide
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3 Manage Services

Using NCM it is possible to Create, Edit, View, Discover, Activate and Deactivate
E-LAN, E-Line and L3VPN Services on NEs managed by ENM.

Table 2     Services by Type

Service Description

E-Line Point-to-point service.

E-LAN Multipoint-to-multipoint service

L3VPN Both full-mesh and unconstrained
(custom) topologies are available.
Includes Virtual Private Network
context and attachment circuit
confguration

Each service instance is built from a service template. For information on service
template design, refer to Create NCM Service Template, Reference [6].

Selecting a service allows to display the logical view of its topology. The services
allow to browse to information about the resources used by the service itself. The
tabs for service history and operator notes are visible only for L3 VPN services.

For information on building specific services, refer to the following sections in
Create NCM Service, Refer [6]:

— Building an E-LAN Service

— Building an E-Line Service

— Building an L3 VPN Service

Note: Before removing a node in ENM verify that the node is not associated to
any service.

Any references to VpWS or CESoIP services reported on the NMC GUI
refer to future implementation and are not active.

3.1 Access the Services Views

The Services views allow to create new services, read the service status, modify
existing services as well as discovering and synchronizing exsiting services. To
access the Services views:

— Service-Service LCM to access the view for Add (Creating), View/Edit and
Synchronize services.

Manage Services
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— Service-Service Discovery to access the view to discovery services.

Figure 6    Service Page

The Services table provides a list of existing service instances and their service
details. It is possible to filter the table by service type and/or service name.

From the service view:

1. Filter the service table - see Section Filter the Service Table.

2. Create new services - see Section Create a Service.

3. Edit an existing service—Select the service, right-click, and select View/Edit.
The multi-tabbed service page refreshes with the Design tab selected. Each
tab provides access to a service-specific design or management tool,
including:

• Routing and activating Ethernet services, see Section Route and Activate
Ethernet Services.

4. View the state of a service, see Section View Service States.

3.2 Filter the Service Table

It is possible to filter all services by service name. For E-Line and E-LAN services,
filters on various service-specific criteria are available.

To filter the service table:

Steps

1. In the Service Type field, select either E-LAN, E-Line, L3VPN or All (the
default).

When filtering:

NCM User Guide
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— E-LAN Services—It is possible to filter on certain columns using the
fields shown:

Figure 7    E-LAN Filter

— E-Line Services—It is possible to filter on certain columns using the
fields shown:

Manage Services
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Figure 8    E-Line Filter

— L3VPN Services—It is possible to filter on certain columns using the
fields shown:

Figure 9    L3VPN Filter

— All services—It is possible to filter on the Service Name columns only.

When filtering E-LAN or E-Line services, additional fields appear if checking
either the Terminating on NE or Mid-Point NE check boxes. A NE must be
selected, and, optionally, a port name.

NCM User Guide
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3.3 Design Service Templates

Before creating services, service-specific templates containing configuration
details that are common to and can be shared among multiple instances of the
services planned to be provided must be designed.

For more information about templates, see the document Create NCM Service
Template, Reference [6].

3.4 Create a Service

To create a service:

Steps

1. Click Service-Service LCM .

2. Click Add

Type a name to identify the service. This name can be up to 32 characters
and must be unique. Special characters are allowed.

3. Click Service Type and select the service type for designing the service.

4. Click Service Template and select the service template for designing the
service. The service template determines the coming input fields.

For information on creating service templates, refer to the Create NCM
Service Template, Reference [6].

5. 3. During E-LAN or E-Line service creation: :

a. Click Next. The view refreshes with the Create Service - Select Service
Endpoints page.

For instructions about specific services, see the following sections in
Create NCM Service, Reference [7]:

b. Click Finish when all service parameters are provided. The page
refreshes with the Design tab selected.

c. 3. Click Close and the new service appears in the Services list in the
Created state.

d. To deploy the service, right click the service and select Route.

For information on activating services and deploying service
components, refer to Route and Activate Ethernet Services.

6. During L3 VPN service creation:

Manage Services
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a. Optional. Click Order # and type the order number for this service.

b. Click Next. The page refreshes with the following tabs selected:

— Design

Service parameters depend on the particular service you are building.
The service design state is In Design. As you configure service details,
you can click Save at any time.

For detailed instructions about a specific service, see the following
section in Create NCM Service,Reference [7]:

• Build an L3 VPN Service

c. Click Complete Design when all service parameters are provided.

d. Click Close and the new service appears in the Services list in the Not
Deployed state.

When the user is ready to deploy the service select it, click the right
button and open the View/Edit menu. Then click Complete Design and
Activate Service. For information on activating services and deploying
service components, see section Activate VPN Services on page 18

3.5 Activate VPN Services

When the user activates a non-Ethernet service, all components belonging to the
service are deployed. When a service component is deployed, the component
configuration is sent to the network device.

Note: It is not possible to use NCM application to create a Layer 3 service on
an NE that requires manual confirmation for context creation. Use the
no system confirmations context command to allow the application to
deploy and create Layer 3 services that include context creation. By
default, confirmation query is disabled.

The service state indicates whether a service has been successfully activated.
Deployment attempts that are not successful after 5 minutes are ended, and an
error message is sent.

To activate a service:

Steps

1. On the Services page, right-click a service that has a service state of Not
Deployed, and select View/Edit.

The service details page appears with the Design tab selected.

2. If the service design is complete, click Activate Service.

NCM User Guide

18 1/1553-CNA 403 3666 Uen B | 2020-11-24



3. In the Activation dialog box, click Confirm.

To deactivate a service, click an activated service, click Deactivate Service,
and confirm the deactivation. The user must have Service Deactivation
permission to deactivate services.

3.6 Route and Activate Ethernet Services

Before an Ethernet service is activated, it must be routed. Before routing an
Ethernet service, create the service and select endpoints; see Building an E-Line
Service or Building an E-LAN Service in Create NCM Service, Reference [7]. See
Prepare the Network for NCM Service, Reference [5] for the population of a new
component domain.

A service must have a service state of Created before it can be routed.

To route and activate an Ethernet service:

Steps

1. On the Design page of a created service, click Route.

The service topology is available on each routing step view, and the selected
or being configured object is highlighted in the logical view.

2. To use existing VLAN tags, select Enable automatic link discrimination. If no
VLAN tag is detected, the next available VLAN tag is assigned.

To manually provide a VLAN tag to identify the traffic stream, do not select
this option.

3. Click Next.

The Route Ethernet service page displays different options depending on the
component domain configured on the NEs.

— Point-Point component domain allows to swap the start and end
boundary points.

— ERP component domain allows to select a discriminator value.

A message confirming the routing information appears.

4. Click Finish to route the service.

The service page is updated with the current service status.

Note: On closing the Design page without routing, the service appears in
the service list page with the Created service state.

5. On the Design page, click Activate Service.

Manage Services
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The Activating Ethernet Service page acquires the routing information and
activates the service. A confirmation message appears, depending on user
preference set for Do not prompt confirmation dialog during service
activation in Options Tab. Then, the service state changes to Active on the
service list page.

3.7 View Service States

In the State column on the Services page, it is possible to view the current state
of the available services. Service state information is read only.

It is also possible to right-click a service and select View or Edit to view its service
state. The service state is shown in the header information along with customer,
order number, service type, service name, and service template.

From the Design tab of a service, click Analyze State to refresh the current state
value. Additional information is provided if the service state has changed. An
error message is shown if a service is only partially deployed due to a problem
during deployment.

For details related to the possible Service State Values for Ethernet Services see
the document Create NCM Service, Reference [7].

3.8 Lock and Unlock Services

Service locking and unlocking is available only for VPN services.

Figure 10    Example of Locked and Unlocked Services

When a service is locked, it cannot be deleted or modified. To lock , or unlock an
existing service, the user must have a security role with read-write access NCM
Locking service type.

To lock or unlock a service:

NCM User Guide
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Steps

1. Navigate to the Services page.

2. Right-click an unlocked service and select Lock Service.

After it is locked, the service cannot be modified or deleted until it is
unlocked.

3. Right-click a locked service and select Unlock Service.

Note: Service locking is available to any NCM user with the appropriate
security role. If a user locks a service, another user with the same
security role can unlock the service.

3.9 Service Topology View

It is possible to view the topology of a service using the Logical view. Right-click
a service from the service menu page and select View or Edit details. The service
topology page appears with the Logical views. The Logical view provides a
graphical representation of a service, including its components and connections.

It is possible to adjust the view to see all connections in a service, or it is possible
to focus on a specific section. It is also possible to select a service object, get
configuration details about the object, move objects within the view. Each service
object is represented by an icon. Icons that are shown depend on the
configuration of the selected service and the view selected.

Relationships between service objects are represented in the Logical view by
straight lines. For E-LAN and E-line services, link type icons appear on the line
representing a link between two NEs. If a link type icon is available, it is possible
to right-click on it to display more information about the link.

Click to pan the topology, select an object, or reposition network objects. It is
possible to use the mouse wheel or zoom tools to zoom in and out, or shift-click
to zoom in on a specific area of the view.

Leaving the view without saving the new layout makes losing any changes.

Figure 11    Topology View Tools

Manage Services
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3.9.1 Logical View of a Service

To view the topology of a service in Logical view:

Steps

1. Navigate to the Services page an open a service:

2. Depending on the service type, click:

— The Topology tab and then click the Logical View subtab

— The Logical View tab

The logical view opens, showing a schematic layout of the service.

3. Click an object to display configuration details and access the actions
available for that object.

The service object configuration details include information about the
corresponding service component. For example, click a component domain
object to open the component domain and view the logical layout of NEs and
links within the component domain.

Configuration details for service components are available on Design tab.

Logical View

Figure 12    Logical View

Component Domain View

NCM User Guide
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Figure 13    Component Domain View

3.9.2 Link View of Ethernet Service

To view the topology of an Ethernet service in Link view:

Steps

1. Navigate to the Services page an open a service.

2. Depending on the service type, click:

— The Topology tab and then click the Link View subtab

— The Link View tab

3. Select one link, and check the Show Link Diagram option, a diagram of the
link is shown under the link table.

Manage Services
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Figure 14    Link View

3.10 Verify a Service Deployment

Audit a deployed service to collect deployment information. For Ethernet services,
clicking Audit Service resynchronizes participating NEs in NCM and generates an
audit report. The audit report includes NE configuration data, such as links, cross-
connections, and ports, from each NE in the service.

To run a service audit:

Steps

1. Navigate to the Services page.

2. Right-click the service to be audited and click View/Edit.

3. From the service details page, click Audit Service.

4. To audit an Ethernet service, click OK to confirm auditing for the selected
service. A window showing the progress of the audit appears.

The result of the service audit report is displayed in the Service Audit dialog
box. If the device configuration differs from the service definition or there is a
configuration error, NCM generates a service issue for each associated object.
Any service issues for deployed service objects are listed first, followed by a
separate table identifying any issues for undeployed service objects.

NCM User Guide
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Use the content in the service audit report to correct any configuration
discrepancies in the service definition. If necessary, correct the configuration
on the NE, or notify the network administrator.

If the service audit report returns no service issues, the configuration defined
in the service is consistent with the configuration on the NEs.

Table 3     Service Audit Report Field Descriptions

Field Description Possible Values

Severity Identifies the severity
level for the service issue.

— CRITICAL—Identifies a
service issue with an
impact to a critical area of
the associated service.
Critical service issues
must be addressed for the
service to function as
expected.

— INFO—Identifies a critical
service issue for an
undeployed service object.
Before a service is
deployed, all outstanding
service issues with this
severity level must be
addressed for the service
to function as expected.

Type Lists the service object
with a configuration
inconsistency or error.

Description Describes the details of
the service issue.

Includes the following
information:

— The NE or device that the
service object is
configured on

— The service object
identification details; for
example, the name of the
service object or the
circuit ID

— The configuration
expected and found on
each corresponding NE or
device

Manage Services
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3.11 Manage an L3VPN Service

Service Design, Service Topology, Service Diagnostics, Service History, Service
Notes, View Tabs are only available for existing L3 VPN Services as shown in
Figure 12.

To run a service audit:

Figure 15     View/Edit Page for L3VPN Service

Service Design, Alarms and Topology View tabs are available for existing
Ethernet Service, as shown in the following Figure:

Figure 16    Edit/View Page for Ethernet (E-Line/E-LAN) Services

3.12 Bulk Operation on Ethernet Services

Users can perform bulk operation for Ethernet services at one time. The bulk
operations include activate, deactivate, detach and unroute Ethernet services.

NCM User Guide
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Users can perform bulk operation for Ethernet services when the services are
under the status listed in the following table.

Table 4     Conditions to Perform Bulk Operation

Routed Partially
Active

Active Service
Degrade

Activate Yes Yes N/A Yes

Deactivate N/A Yes Yes Yes

Detach N/A N/A Yes Yes

Unroute Yes N/A N/A N/A

To bulk operate the Ethernet Services:

Steps

1. Click Services in the navigation bar.

2. Select one or multiple Ethernet Services from the Services list and right-click
Bulk Operation, and then perform Activate, Deactivate, Detach or Unroute as
needed.

The maximum number of selected Ethernet services is 25 by default. Users
can define a service number for bulk operation, refer to Configuring Bulk
Operation Maximum Service Number in ENM System Administrator Guide for
more details.

3. When performing bulk Detach operation, the Remove existing route option is
shown on the Bulk Operation pop up window.

See Attaching and Detaching Route in Building an E-LAN Service or Building
an E-Line Service sections in Create NCM Service Template, Reference [6],
for the detailed information about this option. Click OK to continue the bulk
operation.

4. When performing Activate, Deactivate or Unroute operations, there is no
Remove existing route option on pop up window. Click OK to continue the
bulk operation, or click Cancel to quit.

5. A bulk operation task page pops up.

On the pop-up bulk operation task page, it is possible to perform the
following actions:

— Active/Frozen — By default, the Ethernet services status are
automatically refreshed. Switch Active to Frozen by clicking the button
at the top right corner to stop the auto-refresh.

— Abort—Click Abort to abort the task after the running services have
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completed running.

— Close—Click Close to close the bulk operation task page.

— View Service Detail—Click the icon to view certain Ethernet service
operation detail information.

All the bulk operation tasks are reserved in the Bulk Operation Tasks page.

6. To view bulk operation task right-click a certain task in the Bulk Operation
Tasks list and click View.

7. On the pop-up task page, perform the actions as step [unresolved external
reference].

3.13 Get List of Services

The List of Services in NCM can be obtained from: NCM application, Go to
Services.

The maximum number of records displayed in GUI is 1000. If there are more than
1000 records, the following message is displayed to the User:

Maximum records retrieved. There are more, please narrow your
search.

Then User has to apply filter Criteria based on Service name, Service Type (E-
LAN or E-LINE) and Service State.

User can view the details in .csv file by using Export button.

Figure 17    List of Services

NCM User Guide

28 1/1553-CNA 403 3666 Uen B | 2020-11-24



4 System Level Operations

4.1 Database Analyzer

The database analyzer helps locate Network Connectivity Manager service
related problems. To access the database analyzer, click System > Diagnostics >
DB Analyzer.

On each tab, filter helps to search the dedicated records. — Ethernet Analysis:
The user can query the Ethernet service discrepancy information triggered by
Audit or NE resynchronization operations. These information can be viewed in
the table by mouse over the Discrepancy Information. When the service is
deleted, the discrepancy information is also deleted from the database. Click gear
icon > Export to save the information into a file.

Figure 18    Database Analyzer

4.2 Discover and Synchronize Existing Services

When NCM application manages a network where the services it supports have
been already configured on NEs, those services can be discovered and imported
into the NCM database.

The service discovery task examines only NEs that are installed in ENM and
belong to component domains.

The service discovery task is managed from the NCM application. After the
service discovery task is completed, it is possible to review the services and
accept or reject them for future management. For details on when and how to
use this task, see NCM Services Discovery, Reference [8].
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Figure 19    Service Discovery

4.3 Generate Reports

Click the Reports navigation tab to access the reports. Only a valid NCM user with
permission to generate reports can use the action buttons on this page. Reports
are generated immediately based on current data and are displayed in a new
web browser page.

Note: You must have pop-ups enabled on your browser to view reports.

Generated reports are saved in the database. You can use your web browser to
copy the URL of a generated report and add it to a list of bookmarks if you need
to reference the report in the future.

The following report pages are available:

1. Network Summary (Service Type)

2. Service Report

3. Delete stored report

4. Schedule Report

5. Export Report

1. To view a report, click the following buttons:

— Service Report - lists all service details by service name.

— Delete Stored Reports

— Network Summary (Service Type)

— Export Report

2. To delete all stored reports in the database, click Delete stored reports (you
must be assigned the Report Delete role). There is no response information
from the database to indicate the operation is successful. Delete stored
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reports periodically if the reporting functionality is used frequently;
otherwise, the stored data accumulates in the database.

Note: This action deletes all report data generated by all users. All saved
bookmarks become obsolete and result in browser errors when
used.

3. To schedule a report task, click Schedule Report. The scheduled tasks if
present already are listed with status under the Schedule Report. Delete and
Stop operations are applicable to the tasks in the list.

The output files are stored in the ENM and only the latest 30 files of each
type (.xml and .csv) are kept, the expired files are cleared automatically.

Before starting a schedule task, the options in Schedule Report need to be
set. You can choose to report any one or more of Services, Links, Nodes,
NodePorts, FlowPoints or/and ServiceEndPoints, and select the formats of
the output files.

A number of schedule schemes are provided and the scheduled tasks are
performed at midnight of the day you choose, as follows:

• Once: the task is executed immediately and only run once.

• Before starting a schedule task, the options in Schedule Report need to
be set. Recur Every: sets the frequency. For example, for value 2, the
scheduled task is executed every two days. 1 to 15 days are the scope of
this field.

• Start On and Finish On: set the start date and end date. If Never is
checked, then no end date is set.

While scheduling Service reports, Ethernet services can be filtered based on
the following attributes:

• Service Type (Available options are E-LINE, E-LAN and ALL)

• 1) On Clicking the "Schedule Report" button, the following page shows
up:

• 2) Selecting the "Services" check-box enlists the "Service Type" drop-
down as follows:

• 3) After selecting "E-LINE" or "E-LAN" from the "Service Type" drop-
down, two more components "Network Element" and "VLAN Id" appear
as follows:

• 4) If "Terminating on NE" or/and "Mid-Point NE" is/are selected, a drop-
down "Ne Name" is displayed as follows:

• 5) To export the output files of the scheduled tasks, click Export Report.
You can download or delete these files, by selecting the required file and
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then performing the required step, by either clicking Download or Delete
option.
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