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The information in this document is subject to change without notice and describes
only the product defined in the introduction of this documentation. This document is
intended for the use of Nokia Telecommunications’ customers only for the purposes
of the agreement under which the document is submitted, and no part of it may be
reproduced or transmitted in any form or means without the prior written permission
of Nokia Telecommunications. The document has been prepared to be used by
professional and properly trained personnel, and the customer assumes full
responsibility when using it. Nokia Telecommunications welcomes customer
comments as part of the process of continuous development and improvement of
the documentation.

The information or statements given in this document concerning the suitability,
capacity, or performance of the mentioned hardware or software products cannot be
considered binding but shall be defined in the agreement made between Nokia
Telecommunications and the customer. However, Nokia Telecommunications has
made all reasonable efforts to ensure that the instructions contained in the
document are adequate and free of material errors and omissions. Nokia
Telecommunications will, if necessary, explain issues which may not be covered by
the document.

Nokia Telecommunications’ liability for any errors in the document is limited to the
documentary correction of errors. Nokia Telecommunications WILL NOT BE
RESPONSIBLE IN ANY EVENT FOR ERRORS IN THIS DOCUMENT OR FOR
ANY DAMAGES, INCIDENTAL OR CONSEQUENTIAL (INCLUDING MONETARY
LOSSES), that might arise from the use of this document or the information in it.

This document and the product it describes are considered protected by copyright
according to the applicable laws.

NOKIA logo is a registered trademark of Nokia Corporation.

SYNFONET is a trademark of Nokia Telecommunications Oy.

Other product names mentioned in this document may be trademarks of their
respective companies, and they are mentioned for identification purposes only.

Copyright � Nokia Telecommunications Oy 1999. All rights reserved.
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.

Summary of changes

This document has been re-formatted and edited to comply with Nokia NMS
Release H3.3.
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1 About this manual

Starting with the Nokia NMS is intended for users who are new to the Nokia
NMS Top-level User Interface. It provides information and instructions on the
most common daily operations and operating principles. This operating manual
relates to Nokia NMS Release H3.3.

We try to make the Nokia NMS manuals as useful for you as possible.
Therefore, we would greatly appreciate any comments and suggestions you
may have about how we could improve them. Should you find any errors or
omissions in the manuals, forward comments to your local Nokia NMS support
staff.

1.1 How to use this manual

This guide assumes no previous knowledge of the Nokia NMS, but you should
have experience with a GUI (graphical user interface) such as Microsoft
WindowsTM.

� Chapter 1 introduces the structure of the document and explains the
conventions used there.

� Chapter 2 gives an overall description of the system without going into
detail of how to use it.

� Chapter 3 briefly introduces the graphical user interface that the Nokia
NMS is based on.

� Chapter 4 contains detailed instructions about how to use the Top-level
User Interface of the Nokia NMS.

� Chapter 5 tells where to go after completing the introduction.

If you have already read Feature Descriptions [3], or Product Description [5],
you can skip the first three sections of Chapter 2. If you are already well-versed
in Hewlett Packard’s VUE, you can skip Chapter 3. If you are already familiar
with this or other versions of the Nokia NMS, you may just want to keep this
guide for reference. In this case, Chapter 4 will be most useful to you. Both
Chapter 3 and Chapter 4 are intended to be worked through while you are
sitting at the workstation and using the Nokia NMS.

At the back of this document you will find “References” with suggestions for
further reading, and “Glossary” with the most important technical terms used in
the Nokia NMS. The full version of the glossary is provided as a separate
document Glossary [13].
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1.2 Typographic  conventions

The Nokia NMS manuals use the following typographic conventions:

Initial Upper Case Names of applications, windows and dialogs

Initial Upper Case in
Bold

Menu items, icons and buttons

Initial Upper Case in
Italics

Referenced document titles

SMALL UPPER CASE LETTERS Keys on the keyboard or mouse buttons.
Mouse buttons are defined as SELECT (left),
ADJUST (middle), and MENU (right). Since
mouse buttons can be configured by the user,
these functions do not always correspond to
the same positions.

The Courier font Output from the computer, user names, file
and directory names, database table names
and counters

Courier bold Input the user types

Click File → Exit Choose Exit from the File menu

< > Variable information to be supplied by the
user is identified between angle brackets < >

[  ] Optional information in a command is
indicated within brackets [  ]

% System prompt for a normal user

# System prompt for the root  user

Caution icon. Cautions indicate possible
damage to equipment or system.

Notes indicate additional information such as
recommendations.

Task sequence icon. Indicates the start of a
procedure.

!

Note

1
2
3
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2 General description

This chapter gives a general description of the Nokia NMS. The following
topics are covered in this chapter:

� purpose of the system

� hardware and interfaces

� user applications

� object model

� Top-level User Interface.

2.1 Purpose  of the system

The Nokia NMS is a network management system for telecommunications
networks which are based on modern telecommunications technology. The
Nokia NMS offers functions for fault management, performance management,
and configuration management.

A Nokia NMS system provides services for:

� achieving sufficient utilisation and an appropriate balance of load in all
network elements while keeping up the required quality of service for the
subscriber

� supporting the network operator in planning network evolution and
restructuring of the network (for example by adding additional network
elements)

� supporting efficient maintenance activities.

2.2 Hardware  and interfaces

The Nokia NMS system consists of workstations, servers, X-terminals, and
PCs. The user workstations and the servers are connected through a local or
wide area network based on the TCP/IP protocol. The users work in a GUI
environment running on either workstations or X-terminals and all applications
and data are stored in the servers. Some functions are performed using PCs
which retrieve data from the servers for further processing.



Starting with the Nokia NMS

NTC TAN 0197
Issue 6 en

10 (62) � Nokia Telecommunications Oy

Logically, there are three kinds of servers in a Nokia NMS system. Database
Servers provide the applications with an SQL interface for storing and
retrieving network management data. Communication Servers act as gateways
between the management applications and the managed network elements.
Application Servers run the terminal sessions for the Nokia NMS users.

These functions can be performed by the same machine, so it would be possible
to build a Nokia NMS system with just one physical server. In practice, there
are usually at least two servers so that one can provide redundancy for the other.
The actual hardware configuration varies according to your company’s needs.

If the managed network is large, there may be multiple Communication Servers
and a large number of Application Servers may be running the user interface.
The workstations running the Nokia NMS can be distributed to different
locations and connected via a LAN or WAN. The network elements are
connected to the Nokia NMS via DCN (Data Communication Network) using
X.25 or Ethernet (TCP/IP or ISO/IP) protocols. A typical hardware
configuration of the Nokia NMS for a small network is shown in Figure 1.

HP 700 workstations X–terminals

WAN

HP 800 business servers

X.25 to
network
elements

X.25 to
network
elements

PCs

Figure 1. Example of the Nokia NMS configuration

In this example, there are two servers which are configured to provide
redundancy to each other. Various hardware and software safeguards ensure that
the system keeps running even if one server fails.

2.3 User  applications

The user application software consists of independent parts that store their data
in the common Nokia NMS database and communicate through shared
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communication services. This software architecture facilitates a flexible
distribution of the user applications in a local area network. You can start any
specific Nokia NMS application from the Top-level User Interface. In addition,
each application has its own user interface that includes application-specific
information and options.

Most user interface facilities are GUI-based and conform with the OSF/Motif
Style Guide. Some tasks, however, need to be performed by directly entering
MML (Man-Machine Language) commands to the network elements. The
Nokia NMS provides facilities to establish these connections quickly and
easily.

There are four main groups of graphical network management applications:

The Top-level User Interface provides graphical representations of the
managed network and offers access to all other Nokia NMS applications.

The Performance Management applications collect the performance
measurement reports from all network elements into the Nokia NMS database.
There are facilities for presenting the data in graphical form and for creating
reports. Compressed measurement reports can be obtained from raw
measurements on a daily, weekly, or monthly basis.

The Fault Management applications collect the alarm notifications from all
network elements and allow the user to monitor the alarm situation and view
the Alarm History database.

The Configuration Management applications provide tools for remote
network element management, for network configuration management, and
time management. 

This guide only deals with the Top-level User Interface of the Nokia NMS. To
find information on other applications, refer to Chapter 5.

2.4 Object  model of the Nokia NMS

A managed object (MO) is a resource that forms part of a telecommunications
network and is administered using the Nokia NMS. All elements of a
telecommunications network are viewed as managed objects in the Nokia NMS.
These objects are organised hierarchically in classes. Figure 2 shows the
hierarchy of the managed object classes in the Nokia NMS.

Note
Figure 2 contains all the objects that can be managed with the Nokia NMS. The
shaded objects represent the managed objects of a transmission network. The
objects that you can see in your system depend on your configuration.

An object that is higher in the hierarchy than another is called its parent.  The
lower object is called the child. The child-parent relationship between managed
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objects can mean two things. Either the parent object consists of the child
objects or the parent object controls the child object. For example, a DX 210
consists of Functional Units, I/O Units, Subunits, etc. A Remote Switching
Unit on the other hand is a self-contained piece of hardware that is controlled
by a DX 210 or DX 220 switch.

The physical components of the network are called instances of the abstract
classes of objects that are represented in the hierarchy. A real DX 210 switch
would be an instance of the class of DX 210 switches. This terminology has
been adopted from object oriented programming and is not always used
consistently. Therefore, it is important to keep the distinction between classes
and instances in mind. In everyday usage, both of these are usually referred to
simply as objects.
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Figure 2. Hierarchy of managed object classes

2.5 Top-level  User Interface

The Top-level User Interface has two main functions. It provides a starting
point from which other Nokia NMS applications can be launched and it
organises the managed objects of the telecommunications network into a
hierarchy of views.

A view is a graphical representation of a part of the network with a particular
level of detail. A view may, for instance, present all the DX 220 switches in a
particular area, such as a city. Each of these switches is represented by a
symbol, called a view object.
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The views that the system presents to the user have been designed beforehand
to correspond to the telecommunications network that is managed by the Nokia
NMS installation in question. Therefore ordinary users cannot change the
views. Only system administrators and users with proper authorisation have the
right to edit views (Figure 3).

System
administrator

�����

Users
authorised
to use
Network
Editor

Other

users

Defines:

– authorities

Defines:
– contents
– hierarchy

Uses:
– to manage

the network

Uses:
– to manage

the network

– contents
– hierarchy

Figure 3. Use of views

Some symbols are linked to subviews which present a more concentrated level
of detail, e.g., a symbol for a DX 220 switch may be linked to a subview that
presents all the functional units which constitute the switch.

There are four types of view objects:

� Managed objects are view objects that represent the physical network
elements such as DX 220 or SYNFONET Node. You can give various
commands to managed objects. The parameters of managed objects are
stored in the Nokia NMS database. Managed objects are always used
hierarchically, and they can be used as a link to a subview. Refer to
Section 2.4 for more information on the object model.

� A grouping object represents a group of other objects. All network
elements in a particular location may be represented by a grouping
object. For instance, all the switches in a city may be represented by a
city grouping object in a view that shows the whole network with every
city in the country.
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� A map object is a graphical element that is used to build up a map. Such
a map can be used to illustrate the geographical distribution of network
elements.

� A communication line (CLine) represents a connection between managed
objects.

When a view object has a subview, the symbol of the view object has what
looks like a shadow underneath it. By clicking on it, the user can access another
view that is lower in the hierarchy. Only managed objects represent pieces of
equipment in the real world. All other view objects exist to give clear
organisation and structure to the views. Figure 4 presents a simplified model of
the view hierarchy.

City 1 City 2

City 3

Subview
City 1

Subview

Figure 4. Example of the view hierarchy
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3 Using  Visual User Environment

This chapter is intended for readers who are not familiar with
Hewlett-Packard’s VUE (Visual User Environment) but who have used another
graphical user interface such as Microsoft Windows . If you have never used a
computer with a GUI, you should refer to the detailed introduction to the
system in HP Visual User Environment 3.0 [53]. If you are already familiar
with VUE, you can skip this chapter.

The Nokia NMS GUI is based on Hewlett-Packard’s VUE, a graphical shell
which controls the UNIX environment of your Nokia NMS workstation. This
chapter gives an overview of some important elements of the graphical user
interface used by the Nokia NMS.  VUE features are also standard in the Nokia
NMS unless otherwise specified.

3.1 Logging  in

Before you can operate the Nokia NMS, you need to get a username and
password from your system administrator. The system uses them to identify
you. Without them, you cannot use the Nokia NMS.

When you switch on your workstation, the system prompts you for your
username and password with a dialog. Type the username in the first field and
the (secret) password in the second. If both are correct, you are granted access
to the system. Your session has started.

3.2 Logging  out

The easiest way to log out is to click the Exit  button on the VUE Workspace
Manager. This brings up a dialog asking for confirmation before you are logged
out of the workstation.

3.3 VUE mouse conventions

The mouse provided with the VUE has three buttons.  See Figure 5 below for a
diagram of the mouse and descriptions of its general functions.
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Note
Since mouse buttons can be configured by the user, the functions of the left,
middle, and right button in your mouse can differ from those in Figure 5.

Clicking is a simple action which consists of pressing and releasing the mouse
button when the cursor is on top of a relevant item.

Double-clicking means clicking twice in rapid succession.

Selecting an item means clicking the desired item with the mouse button on the
left.

Dragging means placing the mouse cursor on top of a managed object and
holding the button down while moving the item to the required location.

Use the left button to: Use the right button to:

Use the middle button to:

– select icons
– open and select from most

menus, including the 
Nokia NMS 

– manipulate windows

– open and select from

the Utils 

– open and select from 

the Window Ops

menu

menu

menu

Figure 5. Functions of the mouse buttons in VUE

The button on the left is used for selecting icons, opening and selecting from
most menus, and manipulating windows within the workspace.  When not
inside a window, it also opens the Nokia NMS menu.  This menu allows you to
start some Nokia NMS applications.

The button in the middle is used for opening and selecting from the Window
Ops menu.  This menu includes such actions as Refresh Screen and window
manipulation through commands.

The button on the right is used for opening and selecting from the Utils menu.
This menu contains such items as a clock, calendar, and xhost options.

Please note that the functions of the mouse in VUE and the Nokia NMS are
different. These mouse instructions apply only when the cursor lies in VUE
windows and workspaces. Refer to Section 4.2  for a summary of the functions
of the mouse in the Nokia NMS.  Further details on how to use the mouse are
provided in the relevant sections for each application within VUE and the
Nokia NMS.

3.4 The Workspace Manager
Figure 6 shows the VUE Workspace Manager under the Nokia NMS. This
Workspace Manager always appears on your desktop when you are using the
Nokia NMS.  It is your starting point for accessing the system.
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Xterm VUE Help Manager Workspace buttons

Printer File Manager

Exit button Trashcan

Tearoff menu

Figure 6. VUE Workspace Manager (front panel) in the Nokia NMS

The VUE Workspace Manager (also called front panel) provides a panel of
controls for applications, sessions, workspaces, and subpanels (or tearoff
menus). The most important Nokia NMS applications are configured as icons
in Workspace Manager and can be started by clicking the icons with the mouse.
The icons that appear in the Workspace Manager are configured by your system
administrator. Therefore, it is possible that it looks different on your system.
Ask your system administrator about the meaning of any icons that are not
explained here or in HP Visual User Environment 3.0 [53].

3.5 Workspaces

A screen with its application windows is called a workspace. VUE can maintain
several workspaces which let you organise your work by grouping related
windows in the same workspace. It is like having several monitors in front of
you, each with a different picture. On each screen you can work normally, e.g.,
open windows and run programs. The contents of all the screens you are not
currently looking at are stored in memory.  You can switch between the
workspaces by clicking the workspace buttons in the VUE Workspace Manager.
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3.6 Menus

Three kinds of menus are used in the VUE:

� A pulldown menu is reached through the menu bar at the top edge of a
window or the window menu button in the top left corner of the window.
Its content is displayed when you click on its title with the left mouse
button.

� Popup menus are either general VUE menus or specific to objects in the
Top-level User Interface. The general popup menus appear when you
click a mouse button on the desktop and the mouse pointer is not inside
any window. There is usually a different menu associated with each
mouse button.  For information on popup menus in the Nokia NMS, refer
to Section 4.4.3.

� Tearoff menus (also called subpanels in VUE) are reached by clicking on
the little triangles above some of the icons on the Workspace Manager
with the left mouse button. They can be detached from the Workspace
Manager by clicking on their title bar and moving them while holding
down the mouse button. The menu then stays in place until it is removed.
You can remove a tearoff menu by clicking the small triangle at the
bottom of the menu with the left mouse button.

Toggle marker

Selection marker

Submenu marker

Figure 7. Markers of menu items

Three different markers may appear in menus to convey more information
about the menu item. The markers are shown in Figure 7. A toggle marker is
either visible or not visible. If it is visible, it means that the menu item has been
selected earlier and is now active. If the menu item is chosen again, the marker
will disappear and the option will become inactive. A selection marker applies
to a range of menu options, only one of which can be active at a time. In the
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example, only one update interval can be active.  The one that has been chosen
last will be the active one and carry the marker. The submenu marker indicates
that the menu has a submenu.  If you choose a menu item with three dots,  a
dialog appears for further selections by the user.

3.7 Option  buttons

Analogous to the menu markers, there are several different kinds of option
buttons in the graphical user interface. Figure 8 shows the four types of option
buttons available.

� Radio buttons form a range.  Only one of them can be active at a time.
Thus, clicking on one radio button deselects any other in the range and
the button most recently clicked becomes active.

� A check (or toggle) button indicates that the option it relates to has been
selected.  If several check buttons form a range, more than one of them
can be selected at the same time.

� Stepper buttons permit the user to move up or down numerical options
according to the arrows on the side.  Clicking on the button pointing
upwards causes the value to rise by one.   Clicking on the button pointing
downwards causes the value to drop by one.

� Sliders allow continuous values of different variables where exact
numerical values are not so important.

Radio buttons

Check buttons

Slider

Stepper buttons

Figure 8. Types of buttons within the graphical user interface

3.8 Cut  and paste

‘‘Cut and Paste” is a method of transferring text between windows. In a text
editor, use the menu items Cut, Copy, and Paste from the Edit  menu.  In VUE
(as in most UNIX based windowing systems), select text in a window by
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moving the mouse cursor over it while holding down the left mouse button.
The selected text appears inverted: the background goes light and the text goes
dark. When all the required text is inverted, release the left mouse button. To
paste the selected text into another window, place the text cursor where the text
should appear.  Click the middle mouse button. The originally selected text is
not affected by this operation.

3.9 Drag-and-drop

‘‘Drag-and-Drop” is a quick way of transferring data between and within
applications. In VUE, this is done in three steps:

1. Select the icon of the object to be moved by clicking it with the left
mouse button.

2. Keep the button down and move the object to its target (that is, drag).

3. Release (that is, drop) the object into its target.

A simple example of drag-and-drop is selecting a file from File Manager and
moving and dropping it on the printer object. As a result, the selected file is
printed.

If an icon is dropped to a place that cannot receive it, the cursor will change to
indicate this fact. In that case, the drag-and-drop operation will have no
consequences.

For guidelines on drag-and-drop within the Nokia NMS, refer to Section 4.4.5.

3.10 File Manager

File Manager is a program that lets you view and manipulate the files and
directories in your system. Start File Manager by clicking its icon on the
Workspace Manager. It opens and displays the contents of your home directory.
In your home directory, there are icons representing folders (directories) and
documents. Change to a folder by double-clicking on it. Double-clicking on a
document starts a text editor that displays the contents of the document. To exit
File Manager, click File → Close.

3.11 Trashcan

To remove a file, simply drag-and-drop it onto the Trashcan icon. This
removes the file. It is no longer displayed in File Manager. Note that files are
not really deleted when they are moved to Trashcan. The process does not
actually free any diskspace.

1
2
3
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To recover a file from Trashcan:

1. Click the Trashcan icon to open Trashcan.

2. Select the file.

3. Click File → Restore.

To delete a file:

1. Move the file to Trashcan.

2. Click the Trashcan icon to open Trashcan.

3. Select the file.

4. Click File → Remove.

After this, the file cannot be recovered.

Note
Trashcan is automatically emptied (that is, all files are deleted) when the user
logs out.

To close Trashcan, click File → Close.

3.12 Xterm  windows

Use an xterm window to directly type commands to the system. Open an xterm
window by clicking the blue X icon on the VUE Workspace Manager. There are
various customisation options available to change the appearance of xterm
windows. These can be accessed by clicking the middle and right mouse
buttons inside the xterm while holding down the CTRL key. For example, make
the xterm window scrollable by clicking the middle mouse button while
holding down the CTRL key. This brings up a popup menu from which you
should choose the option Enable Scrollbar. To change the font in the xterm
window, use the right mouse button menu in the same way.

3.13 Resources

Resources determine the appearance of an application. Change the look of the
VUE session and its applications by specifying your own values for the
resources used by these applications. How resources are used and specified is
beyond the scope of this guide. Information on this topic can be found in HP
Visual User Environment 3.0 [53].

1
2
3

1
2
3
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4 Using the Nokia NMS

This chapter introduces you to working with the Nokia NMS. It should be read
by all new users. It is best understood while sitting in front of the workstation
and working with the system. It concentrates on how to use the Top-level User
Interface and on how to navigate the view hierarchy presented by it.
Information on the other Nokia NMS applications can be found in the
appropriate advanced guides. Refer to “References” for a list of these guides.

The layout of the graphical user interfaces described in Nokia NMS customer
documentation may change without notice according to the application
development demands. Therefore, there may be some minor differences
between what you see on your screen and what you read in Nokia NMS
manuals. Major changes are always accompanied by supporting documentation.

Some Nokia NMS manuals may describe features that are not included in your
software package.

4.1 Getting  started

Figure 9 once more shows the VUE Workspace Manager. This time the Nokia
specific elements are labelled.
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Top-level UI

Alarm Viewer

Nokia NMS Manager

Triangle button

Tearoff menu with 
Nokia NMS applications

Figure 9. VUE Workspace Manager of the Nokia NMS

The first thing you will probably want to do when you log in to the Nokia NMS
is start the Top-level User Interface. There are four alternative ways to do this:

a. Click the Top-level UI icon on the VUE Workspace Manager.

b. Click the triangle button above the Nokia NMS Manager icon to open
the Nokia NMS tearoff menu. On the menu, click the Top-level UI icon.

c. Place the pointer in a vacant area of the screen and then click and hold
the SELECT (left) mouse button. This opens up the Nokia NMS popup
menu. Choose Top-level UI to start the Top-level User Interface.

d. Click the Nokia NMS Manager icon on the VUE Workspace Manager.

The first three ways (a, b, c) bring up the Opening a View dialog. It prompts for
the name of the view to be opened. It contains the names of all the views that
are in the system. Only some of those views may be relevant for your particular
purpose. If you are not sure which, ask your system administrator. Select a
name and click the OK  button. The Top-level User Interface (see Figure 10) is
then loaded with the view you have selected.

The fourth alternative (d) automatically opens the default view which has been
preset by the system administrator.
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Selection 1

Selection 2

Selection 3

Selection 4

Title

Selection 2

Selection 3

Name

ID

Pulldown menu

Symbol

Popup menu

Menu bar

View area

Message area

Information bar

Status bar

Message Service Indicator

Name of the NMS and name of the view

Figure 10. Areas of the Top-level User Interface window

4.2 Nokia  NMS mouse conventions

The mouse provided with the Nokia NMS system has three buttons. See
Figure 11 for a diagram of the mouse and lists of its general functions.

Note
Since mouse buttons can be configured by the user, the functions of the left,
middle, and right button in your mouse can differ from those in Figure 11.

The SELECT button (default position on the left) is used for selecting view
objects and choosing menu commands.

The ADJUST button (default position in the middle) is used in the drag-and-drop
operation. The user drags managed objects from the Top-level User Interface to
other applications. Refer to Section 4.4.5 for more detailed information on
dragging and dropping within the Nokia NMS.

The MENU button (default position on the right) is used for calling popup menus
and choosing commands on these menus.
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Use the

Use the

– select view objects

– choose menu commands

– open a subview

with a double-click

– open popup menus

– choose commands on the
popup menus

– drag managed objects

SELECT Use the button to: MENU button to:

ADJUST button to:

Figure 11. Function of the mouse buttons in the Nokia NMS

To select several items simultaneously, there are three possibilities:

� Select each item individually, holding the SHIFT or CTRL key at the same
time.

� For lists, hold down the SELECT (left) mouse button and move it down the
list. Each selected item in the list will be highlighted.

� For icons, hold down the SELECT (left) mouse button. A flexible rectangle
pops up. It will be anchored at the place where it appears. Move the
rectangle to surround the desired icons.

Please note that the functions of the mouse with the Nokia NMS and VUE are
different. These mouse instructions only apply when the cursor lies within
Nokia NMS windows. Refer to Section 3.3 for a summary of the functions of
the mouse in VUE. Further details on the use of the mouse are provided in the
relevant sections for each application within VUE and the Nokia NMS.

4.3 User  interface

4.3.1 Menu bar

The menu bar of the Top-level User Interface lets you access most applications,
allows you to switch between views, and lets you change the appearance of the
view you see on the desktop. This section follows the structure of the menu bar,
illustrated in Figure 12.

Figure 12. Top-level User Interface menu bar

Note
The system administrator can set up the system so that the User menu is not
present.
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File  menu

Figure 13. File menu

 

Open...
Lets you open a new view in the current window. The
command opens the Opening a View dialog. Select a
new view and click OK. The new view opens. The
system reads the view and all its subviews and loads
them into memory. The old views disappear. You can
also use this command to refresh the view.

This command reads the contents of the view and its
subviews from the disk. If it finds objects that are not
already in the memory of the Top-level User Interface it
reads those objects from the database.

Find Object
Lets you find any managed object, even if you do not
know its location in the view hierarchy. The command
opens a submenu that contains all classes of managed
objects known to the system. When you select a class,
a dialog appears that contains all the managed objects
of that class known to your Nokia NMS installation. If
you select one and click the OK button, or simply
double-click one of the items, the Opening a Found
View dialog appears listing all the views that contain
the particular managed object you have selected.
Select the view you want and click OK to open it.

Options... Opens the Options dialog where you can choose
whether you wish to turn on the blinking of
unacknowledged alarms or adjust the blinking rate.

Duplicate...
Lets you look at two or more different views on the
screen at the same time by opening another Top-level
User Interface window. This second window is another
instance of the Top-level User Interface and works
independently.

Continued
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Continued

Refresh Lets you update the view presented in the window. If
the view has been modified, it will be marked by
having its name in the name panel printed between
two stars. Additionally, the information panel at the
bottom of the window will display a notice. This
command reads the contents of the view from the disk
but it also reads objects from the database in order to
update the colours of the objects in the view.

Exit Ends the Top-level User Interface session. It does not
affect any other Top-level User Interface windows that
are open.

 

Mode menu

Figure 14. Mode  menu

In the fault management applications of the Nokia NMS, managed object
symbols have different colours reflecting the fault situation. The symbols are
also blinking if there are unacknowledged alarms. For more information on
colours and blinking, refer to Managing Network Alarms [22]. The Mode
command lets you turn the colours and blinking on or off:
 

Alarms Turns the colours and blinking on (default setting).

Object States Turns the colours and blinking off.

 

Hide menu

Figure 15. Hide menu

Sometimes a view contains many view objects and therefore appears cluttered.
The Hide command lets you select classes of view objects to remove from
view. It contains the following options:
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None Turns all managed objects back into the On state,
making them visible on the screen again.

 All Turns all managed objects into the Off state, making
them invisible on the screen.

Map Takes the map away from the background.

Cline Takes the communication lines away.

Object Types Opens a submenu which displays a list of all classes of
view objects in the current view hierarchy. To hide a
class, simply select it from the menu. Select the class
again to make it visible.

 

Utils menu

This menu (Figure 16) lets you start some of the other applications that make
up the Nokia NMS. For more information on the applications, refer to the
appropriate user’s guides.
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Utils

Managed Object Browser...

Fault Mgmt

Performance Mgmt

System Mgmt

Task Scheduler...

Time Management...

Internal Alarms...

Alarm Viewer...

Alarm Monitor...

Alarm History

Alarm Forwarder...

Alarm Thresholds...

Default...

Search Criteria...

PM Data Post-processing...

DB Contents...

Thresholds for Measurements...

Textual Reports
Observation Report...

Call Tracing Report...

Database Functions...

Network Editor...

User Group Profiles...

Authority Manager...

Task Creator...

Path and Circuit Mgmt Network Navigator...

Resource Manager...

Path and Circuit Manager...

Reporting Utility...

Access Mgmt V5 AN Manager
Line Testing

Directory Number Mapping

Figure 16. Utils  menu of the Top-level User Interface

Note
Which applications appear on the menu depends on your particular installation
and authorisation.

User menu

This menu gives access to some standard Unix applications such as E-mail, a
clock, the Unix command shell, and so on. The contents of this menu are
determined by your system administrator. The system administrator can also set
up the system so that the User menu will not be present.

Window menu

This menu contains all the views that belong to a particular view hierarchy and
that you have visited already. When you start the Top-level User Interface, the
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Window menu contains only one item: the name of the view you are in. If that
view has subviews, and you change to one of those, both the view you are
currently in and the previous one will appear in the menu. You can now change
between them by simply choosing their names from the menu. All the subviews
you visit are added to the menu, thus providing an easy way to navigate
between views. When you click File → Open..., however, the system will
forget all the previous views and only the views you have visited after the last
Open command will appear on the menu.

Help menu

Every application of the Nokia NMS offers a Help item in its menu bar. This
gives direct access to the help topics of the particular application. Another way
to get help is by pressing F1. This starts the Help application and automatically
loads the text that relates to the window or dialog that is currently active. If a
Nokia NMS Help window is already open, it is updated with the new help text
or index.

The following items are on the Help menu.

Figure 17. Help  menu
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About... Displays the name of the application, the version
number, and the copyright notice.

Index... Provides a list of all available Help topics for the
particular application in which help was requested.
Figure 18 illustrates the Help window with the Main
Index for the Top-level User Interface.The buttons on
the button bar have the following functions:

Index  opens the Main Index for the Top-level User
Interface.
Back  returns to the most recently opened Help page.
Brows e << moves backward from the current Help
page to the previous one.
Brows e >> moves forward from the current Help page
to the next one.
Open  gives access to the currently selected Help
page.

Current T opic F1... Displays information on using the context-sensitive
help feature, which is invoked by pressing F1.

How to Use Help... Provides instructions on using Help.

Getting Started... Gives instructions on how to begin using the particular
application.

Help on Colours... Brings up a window that shows which colours are used
for the various alarm classes and object states. For
more information on alarm colours, refer to Managing
Network Alarms [22]. Only available in the Help menu
of the Top-level User Interface and Network Editor. The
Network Editor Help  menu does not show alarm
colours, but does show the colours of object states.

Note:  Object states are not functional in the current
version of the Nokia NMS.

Help on Symbols... Every class of managed object has its own symbol.
This command brings up a dialog that shows which
symbols are used for the various classes. For more
information on these symbols, refer to View
Management [42]. Only available in the Help menu of
the Top-level User Interface, Network Editor, and
Network Navigator. In the last-mentioned application,
this command displays the transmission network
specific symbols.
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Figure 18. Nokia NMS Help with the Main Index Help page

4.3.2 View area

The view area contains the view objects, the popup menu of the whole view, as
well as popup menus of managed objects in the current view.

4.3.3 Message area

The message area has the following components:

� The status bar shows the mode of the view. The status bar also shows the
number of Internal Alarms, in other words, critical alarm situations such
as local message service failures, database connection failures, or failures
in the observation of the database connections.

� The information bar displays any additional information related to the
current view, for example, Changing  mode to Alarms...done .

� The Message Service Indicator denotes the message service. If the
message service is working, the indicator is running. If the message
service is not working, the symbol is crossed out.

Figure 19 illustrates a view in the Top-level User Interface window.
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Figure 19. Example of a view

4.4 Working  with views

4.4.1 View objects

Every view object provides several pieces of information about the managed
object it represents.

� The class of the managed object is shown by its symbol. Click Help →
Help on Symbols... in the Top-level User Interface for more information.

� The alarm class is shown by the colour of the symbol. If the object is
blinking, the managed object has sent an alarm that has not yet been
acknowledged. Click Help → Help on Colours... in the Top-level User
Interface for more information.

� The ID of the object uniquely identifies the network element to the Nokia
NMS database. It appears directly underneath the object symbol.

� The object name is another unique identifier for each network element. It
appears directly above the symbol and its main purpose is to make the
individual network elements easier to remember.

� Some view objects are shaded. This means they are linked to a subview.
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Figure 20 points out each identifying part of a Nokia NMS icon. The full set of
Nokia NMS view objects may be seen in the Top-level User Interface Help
menu. See Section 4.3.1, “Help Menu”.

ID of the object

Object name

Object has a subviewObject class icon

Figure 20. A view object in the Nokia NMS

4.4.2 Navigating the view hierarchy

There are several ways to change views.

a. Open a new view by clicking File → Open..., as described in Section
4.3.1 “File Menu”.

b. If a symbol is shaded, it has a subview. You can simply change to the
symbol’s subview by double-clicking the symbol.

c. Find a managed object, as described in Section 4.3.1, “File Menu”.

d. Use the Window menu to return to a view you have opened earlier, as
described in Section 4.3.1, “Window Menu”.

e. Use the popup menu, as described in Section 4.4.3.

f. You can locate all the views which contain a particular managed object
from your current view by clicking that managed object with the ADJUST

(middle) mouse button. The Opening a Found View dialog opens with a
list of views containing that managed object. You can now open any of
those views by selecting it and clicking OK .

4.4.3 Popup menu

All view objects except map objects have a popup menu associated with them.
There is also a popup menu that applies to the whole view. The menus are
activated by clicking an object with the MENU (right) mouse button, or, for the
whole view, by clicking the MENU (right) mouse button somewhere inside the
view window without pointing at any object. Figure 21 gives an example of a
Whole View popup menu.
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Figure 21. The Top-level User Interface with the Whole V iew  popup menu

The commands which appear in a popup menu depend on the object associated
with the menu. The exact composition of each menu may vary with your
configuration and the context you are working in.

The following items can appear in a popup menu:
 

<name of the  object> The first item in every popup menu. The name is the
same as the one shown above every symbol. As can
be seen in Figure 21, if the popup menu applies to the
whole view, the name will be Whol e View.

Push Next View:
<name of the view>

Applies only to single managed objects. It is in the
menu if the object has a subview attached. Selecting
this option moves the user down to the view which it
names.
The Whol e View  in Figure 21 cannot have subviews
attached. An object is shaded if it has subviews. There
are three managed objects in Figure 21 with subviews
attached.

Pop Previous View:
<name of the view>

Available in the menu if the current view is a subview.
It moves up to the view which it names. The Whole
View in Figure 21 is not a subview of a previous view.

Select All Only available with the Whol e View  option. It selects
all managed objects from the view for further action.

Continued
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Continued

Deselect  All Only available with the Whol e View  option. As its
name suggests, the opposite of Select All .

Information... Available on every popup menu in the Top-level User
Interface.

If chosen from a managed object popup menu, the
Information.. . command opens the Object Details - Int
ID <XXXX> dialog which contains information about
individual managed objects, such as its maintenance
region, its parent object, and so on.

If chosen from the Whol e View popup menu, the
Information.. . command opens an Information on
Objects window listing all the managed objects on the
Top-level User Interface. If you wish to view the details
of any of the managed objects in the list, select the
desired managed object, and click View → Details... ,
or simply double-click the desired object. If you wish to
go down a level in the hierarchy, select the desired
managed object, and click View → Children... . The
Information on Objects window at the current level
opens.

If chosen from the popup menu of several selected
managed objects (Multipl e Object s menu), the
Information.. . command opens an Information on
Objects window listing the selected objects. To view
the details, proceed as above.

Note... Only available on the popup menus for individual
managed objects. Choosing it brings up a dialog
(Figure 22) into which you can type your own notes.
Click into the text area to type or edit notes. When you
have finished editing, click the OK button. If you click
the Cancel button, your changes will not be saved.
You can also print the notes by clicking the Print
button.

When you add a note or make changes to an already
existing note, the note automatically becomes active.
The next time you choose this command for the same
object, you can read or edit your notes. A managed
object with an active note attached to it has its name
shown with a black background. Active notes are
acknowledged as read by clicking the Note Indicator
button in the Notepad dialog.

Continued
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Continued

Alarm  History
Alarm Database
Upload...
Alarm Parameter
Handling

These commands start Fault Management
applications. More information on these applications
can be found in Managing Network Alarms [22].

Performance
Management

Starts the Performance Management Database
Contents application. The details may be obtained from
Managing Network Performance Data [23].

Database
Maintenance

Allows you to delete, acknowledge, or cancel all alarms
of a selected managed object. For more information,
refer to Database Maintenance [35].

MML Session... Starts an MML session if the selected managed object
is a DX 200 switch,TMS4, or 10 MF. The Nokia NMS
automatically logs in to the network element and you
can enter MML commands to it. More information on
using MML can be found in Remote Management of
Network Elements [26].

MML Session to
Parent...

Starts an MML session to the parent network element
if the selected managed object is a subordinate object
of a DX 200 switch, TMS4, or 10 MF. More information
can be found in Remote Management of Network
Elements [26].

Node Manager ... Opens a session to a node manager. More information
can be found in Remote Management of Network
Elements [26].

Service T erminal
Emulator...

Used for starting the TMS4 Service Terminal Emulator.
More information can be found in Remote
Management of Network Elements [26].

Macro STE... Used for starting the Macro Service Terminal Emulator.
More information can be found in Remote
Management of Network Elements [26].

 

Figure 22. Notepad
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4.4.4 Commands to objects

There are several ways of giving commands to objects in a view:

Commands to one object

1. Place the cursor on the desired objects.

2. Click the MENU (right) button to invoke the popup menu associated with
that object.

3. Click the desired command on the popup menu.

Commands to an object and its subview

1. Select an object and its shadow. There are several ways of doing this:

a. Click the shadow with the SELECT (left) mouse button.

b. Click both the object and its shadow with the SELECT (left) mouse
button.

c. Follow the instructions in Section 4.2 on how to select several
items simultaneously.

2. Place the cursor on the object or its shadow.

3. Click the MENU (right) button to invoke the Multiple Objects popup menu
associated with that managed object and its subview.

4. Click the desired command on the popup menu.

Commands to all objects

1. Place the cursor on the background.

2. Click the MENU (right) button to invoke the Whole View popup menu.

3. Click the desired command on the popup menu.

Commands to a set of objects

You can form a non-permanent group of objects and give commands to the
group:

1. Select multiple objects with the mouse, as described in Section 4.2.

2. Move the cursor onto one of the selected objects.

3. Press and hold the CTRL key and click the MENU (right) mouse button to
invoke the Multiple Objects popup menu.

– If all the objects belong to the same class, the popup menu is the
one related to that class.

– If the objects are from various classes, the popup menu does not
contain class specific items.

4. Click the desired command on the popup menu.

5. You can deselect the objects by clicking on the background with the
SELECT (left) mouse button.

1
2
3

1
2
3

1
2
3

1
2
3
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4.4.5 Dragging and dropping within the Nokia NMS

The drag-and-drop feature in the Top-level User Interface allows you to select a
view object in an application and copy it to another application.

1. Select the object(s) to drag, as described in Section 4.2.

2. Place the mouse cursor on top of the desired object(s). Hold down the
ADJUST (middle) mouse button. If you have only one object, the cursor
changes into the shape of the object. If you have more than one object,
the cursor changes into the symbol shown in Figure 23a.

3. Place the cursor over the application to which you want to transfer the
object. If the drop site is valid, it will look like Figure 23b. If the drop
site is not valid, the cursor will look like Figure 23c.

4. Release the mouse button. If the drop site is valid, the cursor will
disappear. If the drop site is not valid, the managed object is taken back
to the Top-level User Interface.

If you drag a symbol that has a subview, all objects and subviews of the
subview are transferred at the same time. You can also drag and drop a
communication line that has a subview. In that case it is the subview that is
dragged and dropped.

Multiple managed objects are being dragged.

Invalid drop site.

Drop site OK.a.

b.

c.

One managed object is being dragged.
Drop site OK.

Figure 23. Drag-and-drop symbols

Note
When you have dragged an object to a valid drop site, you can access the Drop
Help dialog by holding down the ADJUST (middle) mouse button and pressing
the F1 key before dropping. If you click OK in the Drop Help dialog, the
application will complete the operation. If you click Cancel, the whole
operation will be cancelled.
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5 What to do next

After reading this document, you should be familiar with the basic operating
principles of the Nokia NMS and you should be able to use the Top-level User
Interface. The next step should be for you to learn to use the applications that
you will be using for your everyday work in the operations and maintenance
centre.
 

If you are concerned with... Look for more information in...

fault management Managing Network Alarms [22]

performance management Managing Network Performance Data
[23]

operations on transmission network Path and Circuit Management [25]

performing operations on network
elements

Remote Management of Network Ele-
ments [26]

 

You can also use the User’s Quick Reference [17] to find information on a
particular topic and brief instructions on how to use the applications of the
Nokia NMS.

5.1 Nokia  NMS manuals on-line

You can also read, print, and run searches on Nokia NMS manuals on-line.

Opening on-line manuals

1. Place the pointer in a vacant area of the screen. Click and hold the left
mouse button.

2. The Nokia NMS popup menu opens. Choose On-line NMS manuals to
start the WorldView viewer.

3. The home page of the on-line manuals opens listing the Nokia NMS
customer documents according to document categories.

4. To open a document, double–click the hyperlink symbol next to the name
of the document.

5. The document opens to page one. Press the PAGE DOWN key to go to the
document’s table of contents.

1
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6. Continue to page down to move through the whole document in the same
window or double–click the hyperlink in the table of contents to open
more than one page simultaneously.

To move from one page to another, click on the empty area in the scroll bar or
use the PAGE DOWN or PAGE UP key.

It is also possible to open the document collection from the menu bar. File →
Open Collection... displays the chapters of the entire documentation set.
Double-click on a title to open a chapter.

Document titles are displayed in the WorldView windows headers.

Printing on-line manuals

You can print out the documents or only the pages that you need. You can print
within a page or document that is open.

1. Open a chapter and select File→Print from the menu bar.

2. The print dialog opens. Select the printer ($LPDEST is the Nokia NMS
default printer) and the range of pages you want to print.

3. Select Print . The message area tells when the printing is finished.

4. Click Cancel to quit the dialog.

For further instructions how to use the viewer, refer to WorldView
documentation and on-line Help.

5.2 Nokia  NMS Documentation Roadmaps

To further streamline your information search, the following roadmaps are
designed to help you find the instructions you need in the Nokia NMS
documentation.

The Task-oriented User Roadmap is for those who want to use and know about
Nokia NMS user applications.

The Task-oriented System Administrator Roadmap follows on directly from the
previous figure. It helps you when you are performing administrative tasks.

The Roadmap for the Top-level User Interface guides you to the right place in
the documentation while you are using the Top-level User Interface.
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Glossary

This section explains the terms and concepts that are used in this manual. For
additional definitions, refer to Glossary [13].

alarm Message in a telecommunications network that notifies
the management system of an abnormal event in the
network.

alarm class Identifies the severity of an alarm. There are four alarm
classes in the Nokia NMS: critical, major, minor, and
warning.

application Software that performs a particular function directly for
the user. Some examples of applications in the Nokia
NMS are: Alarm History, Network Editor, and ASCII
Terminal.

AXE AXE Exchange

BIDI Bidirectional PCM

communication line (CLine)
View object in a Top-level User Interface view. It
represents communication facilities between network
elements.

D210 DX 210 Exchange

D220 DX 220 Exchange

data communication network (DCN)
Communications network used for data
communications within a telecommunications
management network. For example, a data
communication network exists between network
elements and the Nokia NMS.

DAXN DAXNode

dialog Subsidiary window called from the main window of
the Top-level User Interface or an application. It
contains settings and controls for further action by
applications. A dialog does not have a menu bar.

DOMC DX 200 OMC

DX 200 Family of products by Nokia Telecommunications
covering a wide range of network elements for
switching and network management.
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DX 200 OMC Product by Nokia Telecommunications that implements
an operations and maintenance centre based on DX 200
technology.

DX 210 Compact stand-alone exchange with a capacity of up to
5000 subscriber lines. It runs with the same software
and provides similar services as the DX 220.

DX 220 Exchange that provides all the services and features of
the DX 200 switching system. It has been designed for
the capacity range of medium- to large-size
applications, with a line capacity of 100,000.

EWSD EWSD Exchange

Fault Management Set of telecommunications management network
functions that enables the detection and localisation of
failures, the scheduling of repairs, and the testing out
and return to service of repaired equipment (ITU-T
M.3010).

feature Functionality within a computer program.

FU Functional Unit

graphical user interface (GUI)
Work area for interacting with computer software based
on windows and graphical icons.

I/O Input/Output

IN Intelligent Network

IF Physical Interface

internal alarm Serious alarm that indicates a local message server
failure, a database connection failure, or a failure in the
observation of the database connections. These alarms
are seen in the view of the Top-level User Interface.
Internal alarms are not saved into the database, thus
sending internal alarms is possible also when the
database is down. Because of the serious nature of
these alarms their indication has been made as simple
as possible in order to achieve great reliability. For
more information, refer to Managing Network Alarms
[22] .

International Standards Organization (ISO)
Organization which assists in the monitoring of
standards and consistency in various industries.
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International Telecommunication Union: Telecommunication Standardization
Sector (ITU-T)

Organization that assists in the monitoring of standards
and consistency in the telecommunications industry.

IOU I/O Unit

IP Internet Protocol

local area network (LAN)
Local area network provides a system for
interconnection between computer terminals, PCs, and
related equipment operating within the same general
area. LANs are based on the sharing of information and
resources within a local work group or department.

maintenance region (MR)
Part of a telecommunications network maintained by a
specific service organisation. Each managed object
belongs to a maintenance region defined by the system
administrator. Thus, the views of the Top-level User
Interface are normally organised according to the
division of the network into maintenance regions.
Alarms are also shown by maintenance areas, which
makes it easier to send fault reports to the service
personnel.

Man-Machine Interface (MMI)
Subsystem or function of network elements, which
performs user interface functions.

Man-Machine Language (MML)
Command language for controlling network elements.

managed object (MO)
Management view of a network resource (logical or
physical). An example is the DX 200 OMC or any of
its functional units.

managed object class
Named set of managed objects sharing the same
attributes, notifications, and management operations
(ITU-T M.3100).

managed object instance
Particular managed object of a managed object class.

MR Maintenance Region
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NE Network Element

network element (NE)
Telecommunications equipment (or groups/parts of
telecommunications equipment) and support
equipment, located at the same site, which performs
telecommunications functions. A network element
normally contains many resources, which are managed
as managed objects. In terms of administered objects, a
network element is represented by the highest level
managed object at a site.

NMS Nokia NMS

Nokia NMS Network management system, a product of Nokia
Telecommunications for the operation and maintenance
of telecommunications networks.

NW Network

OPS DX 200 OPS

OSF/Motif Graphical user interface that provides a window
manager, a user interface language, widget tools to
build application interfaces, and a style guide to
provide help in maintaining consistency in
applications.

packet assembly/disassembly facility (PAD)
Protocol used to establish terminal or interactive
sessions asynchronously to remote hosts in X.25
packet networks (ITU-T X.3, X.28, X.29).

PCM Pulse Code Modulation

Performance Management
Set of telecommunications management network
functions for the collection and presentation of
measurement data about the performance of a network.

Remote Subscriber Stage (RSS)
Network element that can manage up to 1000
subscriber lines. It is used to connect small and
remotely located subscriber groups to an exchange.

Remote Switching Unit (RSU)
Access network element with a capacity of up to 5000
subscriber lines connected to the parent exchange. It
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provides all the services that are available to the
subscribers connected directly to the exchanges.

RSS Remote Subscriber Stage

RSU Remote Subscriber Unit

SCP IN Service Control Point

SDH Synchronous Digital Hierarchy

SMP IN Service Management Point

SQL Structured Query Language

STN Station

subordinate managed object, child
Managed object instance further from the root in the
naming tree, contained within a superior managed
object and named within the scope of its superior
managed object (ISO IS 10165-1). In the naming tree a
subordinate managed object can also be the superior
managed object of another subordinate managed
object.

SUBU Subunit

superior managed object, parent
Managed object instance that contains another
managed object instance. In the naming tree a superior
managed object can also be the subordinate managed
object of another superior managed object.

SXC Digital cross-connector, a product of Nokia
Telecommunications.

SYNF SYNFONET Node

SYNFONET Node (SYNF)
Managed object that represents the SDH product
family of Nokia Telecommunications.

system administrator User of the Nokia NMS who is mainly concerned with
maintaining the functioning of the Nokia NMS
installation. A system administrator has the access
rights for carrying out tasks like creating user accounts
and modifying views, which a normal user is not
allowed to do.
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SYSX SystemX Exchange

telecommunications management network (TMN)
Concept which provides the architecture for the actual
realisation of network management (ITU-T M.3010).

TMS Transmission Management System

Top-level User Interface
Application of the Nokia NMS. It allows the user to
start the other applications and it presents graphical
views of the telecommunications network.

Transport Control Protocol (TCP)
Transport service located in the transport layer of the
OSI model.

TREQ Transmission Equipment

user Any person who uses the Nokia NMS. There are two
classes of users: normal users and system
administrators. Normal users have fewer access rights
to the network and to the operating system than system
administrators.

view Graphical representation of a part of the managed
telecommunications network that is seen on the
Top-level User Interface. The view consists of symbols
for managed objects and auxiliary graphical symbols as
well as connecting lines between these symbols. The
views are created by the system administrator.

view object Any graphical symbol in a view of the Top-level User
Interface. There are four classes of view objects:

� managed objects

� grouping objects

� map objects

� communication lines.

All view objects, except for map objects, can have
subviews.

Visual User Environment (VUE)
Hewlett-Packard operating system used on the Nokia
NMS workstations.

wide area network (WAN)
Network extending over distances greater than one
kilometre.
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window Rectangular area of the screen used to control an
application. Applications can use more than one
window, but one window is always the main window.
Windows may be rearranged and adjusted in size
within VUE. Most windows can be minimised to an
icon and have a menu bar.

WS Workstation

X.25 Interface between data terminal equipment for
terminals operating in packet mode that are connected
to public data networks by dedicated hardware. X.25 is
connection oriented, that is, a connection has to be
established before any data is sent (ITU-T X.25).

X-terminal Terminal that allows you to use the X Window System
in a networked environment.

X Window System Network-based graphics window system that allows
workstation users to use applications running on more
than one host.

xterm Program that displays a terminal window that emulates
a DEC VT102 and Tektronix 4014 terminal. Also, an
abbreviation for X-terminal.
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Index

A

alarm classes, 34

Application Server, 10

C

class
of alarm, 34
of managed object, 34

communication lines, 14

Communication Server, 10

configuration management, 11

cut and paste, 19

D

Database Server, 10

documentation roadmaps. See roadmaps

drag–and–drop, 20, 40

F

fault management, 11

File Manager, 20

File menu
Duplicate, 27
Exit, 28
Find Object, 27
in Top–level User Interface, 27
Open, 27
Options, 27
Refresh, 28

files, deleting in VUE, 21

finding, objects, 27

G

grouping objects, 13

H
Help menu

About, 32
Current Topic, 32
Getting Started, 32
Help on Colours, 32
Help on Symbols, 32
How to Use Help, 32
Index, 32
in Top–level User Interface, 31

Hide menu
All, 29
Cline, 29
Map, 29
None, 29
Object Types, 29
in Top–level User Interface, 28

I
ID, of an object, 34

information on objects, 37

M
managed objects, 13

class, 34
ID of, 34
information on, 37
object name, 34

map objects, 14

menu bar, 26

Mode menu, in Top–level User Interface, 28

mouse conventions
in Nokia NMS, 25
in VUE, 15

N
navigating, view hierarchy, 35

Nokia NMS
about, 9
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drag–and–drop, 40
front panel, 16
getting started, 23
hardware, 9
interfaces, 9
logging in, 15
logging out, 15
menu bar, 26
mouse conventions, 25
object model, 11
purpose, 9
starting on–line manuals, 41
Top–level User Interface, 12
user applications, 10
using, 23
views, 34
Workspace Manager, 16

Notepad, 37

O
object model, 11

object name, 34

objects, finding, 27

on–line manuals, starting, 41

online help. See Help Menu

opening
parallel Top–level User Interface windows, 27
views, 27

option buttons, 19

P
performance management, 11

popup menus, 18, 35

pulldown menus, 18

R
recovering, files from trashcan, 21

refreshing, views, 27, 28

resources, 21

roadmaps, 42
task–oriented system administrator, 42

task–oriented user, 42
Top–level User Interface, 42

S
selection markers, 18

submenu markers, 19

subpanels. See tearoff menus

T
tearoff menus, 18

toggle markers, 18

Top–level User Interface, 11, 12
exiting, 28
File menu, 27
Help menu, 31
Hide menu, 28
Mode menu, 28
starting, 23
User menu, 30
Utils menu, 29
Window menu, 30

trashcan, 20
recovering files from, 21

U
updating, views, 28

User menu, in Top–level User Interface, 30

Utils menu, in Top–level User Interface, 29

V
view objects, 34

views, 34
commands to all objects, 39
commands to an object and its subview, 39
commands to one object, 39
commands to sets of objects, 39
finding, 35
navigating, 30, 35
opening, 27
popup menus, 35
refreshing, 27, 28
view objects, 34
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Visual User Environment, 15
cut and paste, 19
drag–and–drop, 20
File Manager, 20
logging in, 15
logging out, 15
menus, 18
mouse conventions, 15
option buttons, 19
popup menus, 18
pulldown menus, 18
resources, 21
selection markers, 18
submenu markers, 19
tearoff menus, 18
toggle markers, 18

trashcan, 20
Workspace Manager, 16
workspaces, 17
xterm windows, 21

VUE. See Visual User Environment

W
Window menu, in Top–level User Interface, 30

Workspace Manager, 16

workspaces, 17

X
xterm windows, 21
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