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Motorola Solutions Technical Notification (MTN) 

  
TITLE:   ESXi loses connection with DAS (Model 3520) attached by HPE H241 and/or Fans are running at high speed on HP 
DL380 Gen9 servers 
 
TECHNOLOGY:  ASTRO 25 
  
SYMPTOMS: 

1. ESXi loses connection with DAS (Model 3520) attached by HPE H241. DAS was reporting generic controller issues to 
UEM. 

2. Fans are running at high speed in servers despite no actual reason for them to do so on HP DL380 Gen9 servers. 
 
MODELS / SYSTEM RELEASES / KITS / DATE/CODES AFFECTED:  
ProLiant DL380 Gen9 with HBA H241 Card / Dot Hill Model 3520  
VMware ESXi 5.5(7.14, 7.15, 7.16), 6.0(7.17) 
 
SEVERITY RECOMMENDATION: 
High / Safety - Perform Immediately  
 
ROOT CAUSE / DEFINITIVE TEST: 

1. Issue is caused by a combination of third party vendor firmware and driver defects. Older storage controller  firmware issue 
can cause VMS storage to become unreachable and VMS to loose connection to both datastores (local and the das) and 
the DAS becoming inoperable. 

2. Due to a defect in HP firmware the HP Active Health System (AHS) or HPE Integrated Lights-Out (iLO) logs may 
indicate that the fans are running at high speeds (for example, above 70% duty) 

  
WORKAROUNDS AND CORRECTIVE ACTIONS:  
 

1. Complete “Disable Application” procedure if it is applicable for a virtual machine. 
2. Shutdown all virtual machines. 
3. Reboot ESXi server. 

 

 
This workaround provides only a temporary recovery as the issue will take place again sometime after the 
reboot. 

RESOLUTIONS AND REPAIR PROCEDURES: 
 

 
This is general recommended update for all Customers. 

 
RESOLUTION: 
Before You Begin: 

● An NM Client with a network connection to the storage controller enclosure (DAS) is required. 

● The Dothill Firmware Media is required and is inserted into the optical drive of the NM Client. 
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● Verify whether it is a single-controller or a dual-controller storage enclosure (DAS). 
Either visually verify that there are two physical storage controllers in the DAS or determine this from the system 
configuration: L1/M1 configurations are non-redundant, all other configurations are redundant. 

 
Proceed to appendices. First perform instructions in Appendix A. and then perform instructions in Appendix B. 
 
PARTS REQUIRED (HARDWARE/SOFTWARE): 
 

Media Name KC Number Release 

Dothill Firmware Media KC877V0B0000071710 A7.14/A7.15/A7.16/A7.17 

HP Firmware Install Media (DL380 G9) KC877L0DJ000071755 A7.14/A7.15/A7.16/A7.17 

VMware vSphere 5.5 Upgrade Media KC877V0CS000071604 A7.14/A7.15/A7.16 

VMware vSphere 6.0 Upgrade Media KC877V0CS000071702 A7.17 

 
 
ADDITIONAL INFORMATION:  
NA 
  
REFERENCE THE FOLLOWING DOCUMENTS/PROCESSES FOR INSTALLATION PROCEDURES: 
NA 
 
WHEN TO APPLY RESOLUTION: 
 After reboot __ 
After (re)installation _X_ 
After upgrade _ 
After power cycle __ 
After database restoration __ 
After failure __ 
On FRU replacement __ 
During maintenance __ 
Immediately _X_ 
As instructed X_ 
Information only __ 
 
  
LABOR ALLOWANCE: 
This is an informational bulletin.  No labor warranty is implied, intended or authorized for U.S. Domestic Partners/Customers.  Other 
regions should follow their own standard procedures. 
 
For assistance with this bulletin please contact your MSI Technical support centre 
https://www.motorolasolutions.com/en_us/support.html  

https://www.motorolasolutions.com/en_us/support.html
https://www.motorolasolutions.com/en_us/support.html
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Appendix A: Updating Storage Controller Modules Firmware 

Conventions 3 
Signing In 3 
Viewing System Status 3 
Shutting Down Virtual Machines 3 
Single-Controller Configuration 4 

Management Controller Restart 4 
Updating Controller-Module Firmware 4 

Final Check 4 
Dual-Controller Configuration 5 

Disabling PFU 5 
Firmware Update 5 

Management Controller Restart 5 
Updating Controller-Module Firmware 5   

Final Check 6 
 

 

If you are about to apply this procedure in the time when symptom #1 is observable, please apply 
instructions in WORKAROUNDS AND CORRECTIVE ACTIONS section of this document before 
continuing. 

 

 
Please contact SSC team for further assistance in case of an abnormal completion of any step or 
unsuccessful execution of any script within the scope of this procedure.  

 

 

Perform all steps  consequently; run next script only after the previous script’s execution is completed. 

Conventions 
● Storage controller module A – installed into upper slot of the controller enclosure. 

● Storage controller module B – installed into bottom slot of the controller enclosure and is available for only dual-
controller configuration. 

● IP addresses of network ports of the above controllers hereinafter referred to as <controller-a-ipaddr> and 
<controller-b-ipaddr> respectively. 

Viewing System Status 
1. On NM Client, run Internet Explorer  and in the web browser address field, type https://<controller-a-

ipaddr>/ and press Enter. Login in to RAIDar management webpage using username manage. 

2. In the Configuration View panel, right-click the system and select View > Overview. Be sure that the system health 
status is OK.  If system health status is not OK, please capture screenshots of the errors/alarms/warnings and DAS logs.  
This information will be requested when contacting the SSC for support.  . 

Shutting Down Virtual Machines 
Shut down all virtual machines, which use this storage controller enclosure as their datastore (be sure you completed it for all ESXi 
hosts connected to this storage controller enclosure). 

 

Proceed to the appropriate chapter depending on the storage controller enclosure configuration: 

For single-controller storage enclosure, continue with chapter Appendix A > Single-Controller 
Configuration. 

For dual-controller storage enclosure, continue with chapter Appendix A > Dual-Controller 
Configuration. 
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Single-Controller Configuration 

Management Controller Restart 
Perform a restart of the Management Controller A: 
 

1. Run Internet Explorer. 

2. Sign in to RADar management webpage  https://<controller-a-ipaddr>/ using username manage. 

3. In the Configuration View panel, right-click the local system and select Tools > Shut Down or Restart Controller. 

4. In the main panel, set the options: 
a. Select the Restart operation. 
b. Select the type of controller processor to restart - Management. 
c. Select to restart the processor in controller A. 

5. Click Restart now. A confirmation dialog appears. 

6. Click Yes to continue, a second confirmation dialog appears. 

7. Click Yes to continue, a message describes restart activity. 
 
The restart should take approximately two minutes. Once the restart is complete, the log-in page 
appears. Continue as soon as you can successfully login back to https://<controller-a-ipaddr>/  

Updating Controller-Module Firmware 
To update controller-module firmware: 

1. In the Configuration View panel, right-click the system and select Tools > Update Firmware. The table titled Current 
Controller Versions shows the currently installed versions. 

2. Click Browse and navigate to the Dothill Firmware Media. Search a file with extension .bin in directory 
\firmware\DH3520\. 

3. Select the found firmware file to install and click Open. 

4. Click Install Controller-Module Firmware File. A dialog box shows firmware-update progress. The process starts by 
validating the firmware file: 

a. If the file is invalid, verify that you specified the correct firmware file. If you did, try downloading it again from 
the source location. 

b. If the file is valid, the process continues. 

5. When firmware upload starts user will see a progress screen, user will be automatically signed out after the upload 
finishes and the Management Controller A will restart. Until the restart is complete, the RAIDar Sign In page will be 
unavailable. Wait around 15 minutes until the user can login to the controller’s RAIDar Sign page.  

6. In the Internet Explorer, click Gear icon and then select Internet Options . In Internet Options window, click Delete in 
Browsing history section. In a new window, check the following checkboxes: Temporary Internet files and website 
files and Cookies and website data, and click Delete. 

7. Then sign in back to RAIDar webpage https://<controller-a-ipaddr>/ . 

Final Check 
1. Right-click the top item of the tree in the Configuration View panel. 

2. Select Tools > Update Firmware.  

3. Result: The table titled Current Controller Versions shows the currently installed versions. 

4. In the Current Controller Versions table, verify that the Bundle Version value for Controller A is equal to the name of 
the file that you selected earlier for the firmware update. 
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Dual-Controller Configuration 

Disabling PFU 
1. Run Internet Explorer. 

2. Sign in to RADar management webpage  https://<controller-a-ipaddr>/ using username manage. 

3. Right-click the top item of the tree in the Configuration View pane tree hierarchy. Click Configuration > Advanced 
Settings > Firmware. 

4. Verify that the check box for Partner Firmware Update is unchecked. If it is checked then clear it and Apply your 
changes. 

Firmware Update 

 
Perform the following instructions below for controller A first. As soon as firmware update for the controller 
A is finished successfully repeat the same instruction for controller B. 

Management Controller Restart 
Restart the Management Controller in the controller to be updated. To perform a restart: 
 

1. In the Configuration View panel, right-click the local system and select Tools > Shut Down or Restart Controller. 

2. In the main panel, set the options: 
a. Select the Restart operation. 
b. Select the type of controller processor to restart - Management. 
c. Select to restart the processor in controller A(B). 

3. Click Restart now. A confirmation dialog appears. 

4. Click Yes to continue, a second confirmation dialog appears. 

5. Click Yes to continue, a message describes restart activity. 
 
The restart should take approximately two minutes. Once the restart is complete, the log-in page 
appears. Continue as soon as you can successfully login back to https://<controller-a-ipaddr>/ 
(https://<controller-b-ipaddr>/). 

Updating Controller-Module Firmware 
To update controller-module firmware: 

1. In the Configuration View panel, right-click the system and select Tools > Update Firmware. The table titled Current 
Controller Versions shows the currently installed versions. 

2. Click Browse and navigate to the Dothill Firmware Media. Search a file with extension .bin in directory 
\firmware\DH3520\. 

3. Select the found firmware file to install and click Open. 

4. Click Install Controller-Module Firmware File. A dialog box shows firmware-update progress. The process starts by 
validating the firmware file: 

a. If the file is invalid, verify that you specified the correct firmware file. If you did, try downloading it again from 
the source location. 

b. If the file is valid, the process continues. 

5. When firmware update on the controller A(B) is complete, user is automatically signed out and the Management 
Controller A(B) will restart. Until the restart is complete, the RAIDar Sign In page will say that the system is currently 
unavailable. Wait until this message is cleared. 

6. In the Internet Explorer, click Gear icon and then select Internet Options . In Internet Options window, click Delete in 
Browsing history section. In a new window, check the following checkboxes: Temporary Internet files and website 
files and Cookies and website data, and click Delete. 
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7. Then sign in back to RAIDar webpage https://<controller-a-ipaddr>/ . 

Final Check 
1. Right-click the top item of the tree in the Configuration View panel. 

2. Select Tools > Update Firmware.  

3. Result: The table titled Current Controller Versions shows the currently installed versions. 

4. In the Current Controller Versions table, verify that the Bundle Version value for Controller A(B) is equal to the name 
of the file that you selected earlier for the firmware update. 
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Appendix B: Updating HP DL380 Gen9 BIOS/iLO Firmware and VMware 
ESXi 
 

Conventions 7 
Preparing for Service Mode 7 
Changing the ESXi Host Boot Order 7 
Uploading Software Depot to the ESXi 8 
Updating the Host Firmware and ESXi Software 8 

 
 

 

If you are about to apply this procedure in the time when symptom #1 is observable, please apply 
instructions in WORKAROUNDS AND CORRECTIVE ACTIONS section of this document before 
continuing. 

 

 
Please contact SSC team for further assistance in case of an abnormal completion of any step or 
unsuccessful execution of any script within the scope of this procedure .  
 

 

 

Perform all steps  consequently; run next script only after the previous script’s execution is completed. 
Always wait until a script completes its execution. 

 

 

Conventions 
● <ilo_ipaddr> - an IP address of iLO network port, where iLO web interface available. 

● <cd_drive> - a drive letter assigned to CD-ROM or DVD-ROM disc drive in your  NM client. 

● <esxi_ipaddr> - an  IP address of network management port of the affected ESXi host (VMS). 

 

Preparing for Service Mode 
1. Insert HP Firmware Install Media disc into the  ESXi host’s (VMS) optical disc drive. 

2. Insert the VMware Vsphere Upgrade Media disc into the optical drive of the  NM Client. 

3. Run VMware vSphere Client on your  NM Client and login in to the affected ESXi host using <esxi_ipaddr> and 
account root. 

4. Disable (if applicable) and then shut down all virtual machines, which are running on the affected ESXi host (VMS). 

5. Browse to the host in the vSphere Web Client navigator, then Right-click the host and select Maintenance Mode > Enter 
Maintenance Mode.  

 

Changing the ESXi Host Boot Order 
Run Internet Explorer and in the web browser address field, type https://<ilo_ipaddr>/ and press Enter. Login in to iLO 
web interface using username Administrator. 
 
Click Expand All on the top-left corner of the page and in the navigation tree view on the left side of the page, click Boot Order. 
Select an CD/DVD Drive option from the Select One-Time Boot Option list and click Apply. 
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Uploading Software Depot to the ESXi 
Open an Administrator Command Prompt window (run as administrator) on an  NM Client and at this command prompt, run 
powershell.exe command. 
 
At the PowerShell prompt, change directory to <cd_drive>:\bin and then run two commands in series; 

Start-Transcript  
.\upload-patches.ps1 

 
At the dialogue’s questions prompt, enter corresponding answers (values): <esxi_ipaddr>, password of this ESXi root 
account, and a path to depot - <cd_drive>:\depot. Confirm your entered values by entering y character. 
 
During execution, upload-patches.ps1 script outputs a path string started with /vmfs and ended with /depot. Save this path 
string since it is required to use it in steps below (hereinafter referred to as <depot_path> ). 

 

Updating the Host Firmware and ESXi Software 
Open a command prompt window as Administrator (run as administrator) on your  NM client and at this command prompt, run 
powershell.exe command. 
 
At the PowerShell prompt, change directory to <cd_drive>:\bin and then run two commands in series; 

Start-Transcript 
.\upgrade-esxi.ps1 -noreboot 

 
At the dialogue’s questions prompt, enter corresponding answers (values): <esxi_ipaddr>, password of this ESXi root 
account, and the path string to depot <depot_path>. Confirm your entered values by entering y character. 
 
Run VMware vSphere Client on your NM Client and login in to the affected ESXi host using <esxi_ipaddr> and account root. 

Browse to the host in the vSphere Web Client navigator, then Right-click the host and select Maintenance Mode > Exit 
Maintenance Mode.  

Browse to the host in the vSphere Web Client navigator, then Right-click the host and select Reboot.  Provide a reason for the 
reboot. 

 
Please be noted that further steps are executed automatically  with the following  process: 

● Rebooting 
● Booting HP Firmware Install Media disc 
● Updating the host firmware 
● Rebooting 
● Updating of ESXi hypervisor 
● Rebooting 
● Starting the ESXi hypervisor  
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Software Order Form 

 Upgrade Operations Software Team 
 

Phone Number: (800) 221-7144 
 

       
 

            
SECTION 1: General Information 

    NOTE: PRICE QUOTES GIVEN BY UOST ARE VALID FOR ONLY 90 DAYS   
  

 
Date   

 
Case Number   

 
 

System ID   
 

Site ID   
 

 
System Name   

 
Site Name   

 

 

Customer 
Name   

    
       

 

Form 
Completed by   

 
Field Contact   

 
 

Organization   
 

Organization   
 

 

Phone 
Number   

 
Phone Number   

 
 

Pager Number   
 

Pager Number   
 

 
Fax Number   

 
Fax Number   

               

SECTION 2: Order Information 
    

       Product Type:   
 

Serial Number   
 

       Reason for Software / Hardware Change:                                                                                        
Downgrade? If so, list current and target releases.         
              
Software / Hardware Description:         
              
Part # or Version #      Quantity   

 
       Date Required     

                 
SECTION 3: Shipping / Billing Information 

          Ship To:     
 

Bill To:     

 
    

  
    

 
    

  
    

Email:     
  

    
Attn:     

 
Attn:     

       Phone:     
 

Phone:     

       
 

Customer Billing 
  

Internal Billing 
 P.O. #:     

 
PROJECT #:     

CUST #:     
 

FSB #:     
TAG #:     

 
DEPT #:     

    
APC #: 
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Software Order Form 

Upgrade Operations Software Team 
 

Phone Number: (800) 221-7144 
 

       °  This form has been sent to you because you have requested an order from  
     the Upgrade Operations Software Team. 

   
       °  Please fill out the order form and email back to the Upgrade Operations Software 
    Team 

      
       °  If desired, please provide your email address on the order form  

    and we will provide a tracking number when your order ships for your convenience. 
 

       °  Orders will normally be processed in 3-5 business days once all information has been  
   received. 

     
       °  If additional space is required for software information, please use the optional addendum on  
   page 3 below in addition to the original order form.  This form is for use with large orders with    
   multiple part numbers. 

    
       NOTE: 

      
       1)  If this in an SSA CUSTOMER please order via Motorola factory order. 

 2)  Limited Liability is Implied to the maximum of order amount. 
  3)  Price quotes provided by UOST are valid for 90 days 
         

       
       
       
       
       
       Thank you and have a good day! 
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Supplemental Order  

    

Information 
Addendum 

       
    

(Optional) 
         

       Software Description           

       Part# or Version #           

       Quantity: 
 

  
    

              
       Software Description           

       Part# or Version #           

       Quantity: 
 

  
           

       
       Software Description           

       Part# or Version #           

       Quantity: 
 

  
    

              
       Software Description           

       Part# or Version #           

       Quantity: 
 

  
    

              
       Software Description           

       Part# or Version #           

       Quantity: 
 

  
    

       
       
       Software Description           

       Part# or Version #           

       Quantity: 
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