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About this document

This guide describes how to install and use Preside MDM Passport Service 
Data Backup and Restore for Passport 6000, 7000, 15000, and 20000 nodes 
and Preside MDM Passport/SNMP Backup and Restore for Passport 4400 
and 4460 nodes.

Note: In this document, Passport refers to Passport Multiservice switches 
(6000, 7000, 15000 and 20000); Passport/SNMP refers to Passport 4400 
and Passport 4460).

The following topics are discussed in this section:

• “Who should read this document and why” (page 13)

• “What you need to know” (page 14)

• “How this document is organized” (page 14)

• “What’s new in this document” (page 14)

• “Text conventions” (page 15)

• “Related documents” (page 16)

Who should read this document and why
You should read this document if you are responsible for backing-up and 
restoring Passport/Passport 4400 switch service data using the Passport and 
SNMP Devices Backup and Restore tools. As well, users responsible for 
population and synchronization of the Administration Database should read 
this document.
Preside MDM Passport/SNMP Devices Backup and Restore User Guide   14.3RSUP
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What you need to know
You should be familiar with the configuration and service data storage on the 
switch types that you are responsible for maintaining. You should also have 
a working knowledge of Preside Multiservice Data Manager (MDM).

How this document is organized
The information in this guide is organized as follows:

• “Introducing Preside MDM Backup and Restore” (page 19) introduces 
the interfaces and their functionality.

• “Installing and configuring backup and restore applications” (page 31) 
provides installation and configuration instructions.

• “Starting Backup and Restore” (page 47) describes how to begin using 
Passport and Passport/SNMP Service Data Backup and Restore.

• “Basic service data backup” (page 69) describes how to back up service 
data.

• “Basic service data restore” (page 89) describes how to restore service 
data.

• “Current Configuration Backup and Database Synchronization” 
(page 109) describes the available backup options, and how the 
Administration Database is backed up and restored.

• “Current Configuration Recovery” (page 125) describes how to recover 
service data when a Passport fails or is destroyed.

What’s new in this document
The following feature was added to this document:

• “Backup, Restore and Database Synchronization Enhancements” 
(page 15)
241-6001-807   14.3RSUP   
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Backup, Restore and Database Synchronization 
Enhancements

This document has been updated for the following enhancements to the 
Backup, Restore and Database Synchronization process:

• Backup and Restore GUI enhancements which include separate user 
interfaces for Passport nodes (6000, 7000, 15000, and 20000) and for 
Passport/SNMP nodes (4400 and 4460).

• Data synchronization. Data Synchronization is performed by the Data 
Synchronization Administration Tool. In order to support backup and 
restore tasks, the Data Synchronization server must be enabled even if 
the database is not being used. This document contains configuration 
information for Data Synchronization as it relates to Backup and Restore 
only. For more information on the Data Synchronization Tool, refer to 
241-6001-400 Preside MDM Administration Database User Guide.

Text conventions
This document uses the following text conventions: 

• nonproportional spaced plain type

Nonproportional spaced plain type represents system generated text or 
text that appears on your screen.

• nonproportional spaced bold type

Nonproportional spaced bold type represents words that you should type 
or that you should select on the screen.

• italics

Statements that appear in italics in a procedure explain the results of a 
particular step and appear immediately following the step.

Words that appear in italics in text are for naming.

• [optional_parameter]

Words in square brackets represent optional parameters. The command 
can be entered with or without the words in the square brackets.
Preside MDM Passport/SNMP Devices Backup and Restore User Guide   14.3RSUP
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• <general_term>

Words in angle brackets represent variables which are to be replaced 
with specific values.

• UPPERCASE,lowercase

In Preside Multiservice Data Manager (MDM), uppercase and lowercase 
letters that appear in UNIX commands and parameters must be matched 
exactly. The system matches upper and lowercase characters differently.

• |

This symbol separates items from which you may select one; for 
example, ON|OFF indicates that you may specify ON or OFF. If you do 
not make a choice, a default ON is assumed.

• ...

Three dots in a command indicate that the parameter may be repeated 
more than once in succession.

The term absolute pathname refers to the full specification of a path starting 
from the root directory. Absolute pathnames always begin with the slash ( / )
symbol. A relative pathname takes the current directory as its starting point, 
and starts with any alphanumeric character (other than /).

Related documents
See the following documents for related information:

General
241-6001-102 Preside MDM Planning Guide
241-6001-303 Preside MDM Administrator Guide
241-6001-400 Preside MDM Administration Database User Guide
241-6001-310 Preside MDM Server Reference Guide

Passport 6000
For a list of documents, see 241-6401-001 Passport 6400 Documentation 
Guide.
241-6001-807   14.3RSUP   
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Passport 7000/15000/20000
For a list of documents, see 241-5701-001 Passport 7400, 15000, 20000 
About Passport Documentation.

Passport 4400
Passport 4400 Hardware Installation Manual
Passport 4400 Operators Manual
Passport 4400 CLI Reference for the Command Line Interface
Preside MDM Passport/SNMP Devices Backup and Restore User Guide   14.3RSUP
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Chapter 1
Introducing Preside MDM Backup and Restore

Preside MDM provides two distinct interfaces for backup and restore 
activities:

• Passport Service Data Backup and Restore, used for the Passport 6000, 
7000, 15000, and 20000 nodes

• Passport/SNMP Service Data Backup and Restore, used for Passport 
4400 and 4460 devices

You can perform basic backup and restore functions using both interfaces. In 
addition, you can use Passport Service Data Backup and Restore to perform 
a current configuration backup.

Navigation
• “Basic backup and Restore for Passport and Passport/SNMP nodes” 

(page 20)

• “Current configuration backup for Passport nodes” (page 20)

• “Backup configuration files” (page 23)

• “Backup and Restore server architecture” (page 24)

• “Passport Service Data Backup and Restore” (page 28)

• “Passport/SNMP Service Data Backup and Restore” (page 30)
Preside MDM Passport/SNMP Devices Backup and Restore User Guide   14.3RSUP
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Basic backup and Restore for Passport and Passport/
SNMP nodes

Passport and Passport/SNMP Service Data Backup and Restore can be used 
to perform a basic service data backup. The basic service data backup enables 
you to back up view files for a single node or for multiple nodes.

The basic backup function enables you to perform the following:

• full backup

• incremental backup

• selected service data backup

The basic restore function enables you to perform the following:

• full restore of service data for a single node or for multiple nodes

• incremental restore of service data for a single node or for multiple nodes

• restore of selected service data for a single node

Current configuration backup for Passport nodes
Passport Service Data Backup and Restore can be used to perform a current 
configuration backup for Passport 6000, 7000, 15000, and 20000 nodes. The 
backup server must be started with the -notification option to enable the 
current configuration backup. 

The Backup Server can be configured to perform a backup in the following 
ways:

• on alarm with journaling supported

For journal-supported Passport devices, a journal log file is created 
during each activation and contains a delta of the configuration changes 
between the current and edit views. For more information on Passport 
journaling, refer to 241-5701-045 Passport 7400, 15000, 20000 
Management System User Interface.
241-6001-807   14.3RSUP   
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• on alarm for complete view (with journaling not supported)

Passports that do not support journaling only send out a confirm prov, to 
trigger the Backup Server to backup recently created view files. This 
mode is only recommended for small networks.

• on demand through a scheduled cron job

Backups can be done on demand through the command line. You can 
specify Backup_On_Demand in the device configuration file and then 
issue the backup command when a backup is required. You can define a 
cron job for scheduled backups.

The figure, “Backup server architecture for current configuration backup 
including Database Synchronization” (page 22) shows the sequence of events 
that occur. The Backup server receives an alarm from GMDR when a 
provisioning change is made. This alarm triggers the Backup server to start a 
backup. The Backup Server communicates to the Backup Provider, which 
sends a request to the Passport to back up the most current view name and 
journal files. The new files are stored on the backup site.

When the current configuration backup has been used, you can perform the 
node recovery functions for Passport 7000, 15000, and 20000 nodes with 
PCR 5.1 or later.

Data synchronization
If synchronization has been specified in the DataSync.cfg file, the Database 
Synchronization server is notified that a backup has occurred. For more 
information on this capability, see “Current Configuration Backup and 
Database Synchronization” (page 109). For more information on the 
Administration Database, see 241-6001-400 Preside MDM Administration 
Database User Guide.
Preside MDM Passport/SNMP Devices Backup and Restore User Guide   14.3RSUP



22   Chapter 1 Introducing Preside MDM Backup and Restore
Figure 1
Backup server architecture for current configuration backup including Database 
Synchronization
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This functionality is available only for Passport 7000, 15000, and 2000 nodes 
with PCR 5.1 or higher. See “Current Configuration Recovery” (page 125).

Backup configuration files
The remote mapping file (Controller.cfg) is used when you need to access a 
Provider that is not running on the same host machine as the Controller. When 
this situation occurs, the remote mapping file needs an entry for the node, or 
nodes, on the remote Provider that the Controller is attempting to access. You 
can also use the remote mapping file to distribute the workload over several 
Providers. 

Passport service data backup configuration files
The data synchronization file (DataSync.cfg) is used to specify backup 
information for current configuration backup, current configuration recovery 
and data synchronization information for Passport nodes. It lists the groups 
(as defined in the Host Group Directory Service) that will be used to 
determine which nodes to backup, and the backup options. It includes 
configuration information for the Backup server and the DB synchronization 
controller. This file is updated using the Configuration Editor to modify all 
the parameters.

Passport/SNMP service data backup configuration files
The device information file (devices.cfg) has an entry for each node that 
Passport/SNMP Backup and Restore services. This file contains information 
about the nodes supported by the Backup and Restore tools. The Backup and 
Restore applications automatically create and update the file /opt/
MagellanNMS/data/nst/devices.cfg using GMDR for Passport 4400/4460.

The interface mapping file (ifmap.cfg), which is only for Passport 4400 
nodes, is used when the Provider’s host machine has multiple network 
interfaces. You can use the interface mapping file to map the IP address of the 
appropriate host interface to the IP addresses of the nodes that need to connect 
to that host interface.

For more information on the use of these configuration files, see “Installing 
and configuring backup and restore applications” (page 31).
Preside MDM Passport/SNMP Devices Backup and Restore User Guide   14.3RSUP
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Backup and Restore server architecture
The servers are referred to as controllers and providers. The Backup 
controller and provider back up the most recent information from the Passport 
and store it on a backup site. The Restore controller and provider are 
responsible for restoring the backed up information to the Passport nodes. 

See “Passport Service Data Backup and Restore Architecture” (page 25) and 
“Passport/SNMP Service Data Backup and Restore” (page 26).
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Figure 2
Passport Service Data Backup and Restore Architecture
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Figure 3
Passport/SNMP Service Data Backup and Restore
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Backup and Restore server redundancy
To ensure Backup server reliability, redundancy can be set up for the Backup 
and Restore servers. Backup server redundancy may be critical if there is a 
requirements to be able to quickly recover a node to its current configuration. 
Two or more independent Backup servers can be running at the same time on 
different MDM workstations. See “Backup server redundancy” (page 27).

Figure 4
Backup server redundancy
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Both Backup servers cover the same Passports and are triggered by the same 
alarms from GMDR, which are generated by the Passports. A command line 
option can specify the host to which the GMDR server connects (see 
“Interface with GMDR” (page 122). 

In the illustration in “Backup server redundancy” (page 27), the Backup 
servers connect to two different GMDR’s, one for each Backup server. In 
another possible scenario, one common GMDR could be running on a 
separate workstation. Both Backup servers would receive alarms from this 
GMDR and trigger the servers to do backups. Regardless of the setup, two 
backups are done in parallel and independently. The two Backup servers do 
not communicate with each other. 

Similarly, two separate Restore controllers could run on workstation 1 and 
workstation 2 respectively and have a remote workstation with two separate 
instances of the recover tool connecting to the distinct Restore controllers.

Backup groups
The system administration uses the Configuration Editor to define attributes 
in a default backup group. When you add a new backup group, you can either 
define specific values for the new group or, if you don’t define any values, the 
system automatically uses the values of the default group.

All backup groups are defined in the HGDS server using the Host Group 
Administration tool. For more information, refer to 241-6001-303 Preside 
MDM Administrator Guide.

Passport Service Data Backup and Restore
Use Passport Service Data Backup and Restore to perform the basic backup 
and restore function for Passport 6000, 7000, 15000, and 20000 nodes. In 
addition, you can use the interface to perform the current configuration 
backup.

See “Accessing Passport Service Data Backup and Restore” (page 29)
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Figure 5
Accessing Passport Service Data Backup and Restore
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Passport/SNMP Service Data Backup and Restore
Use Passport/SNMP Service Data Backup and Restore to perform basic 
backup and restore for Passport 4400 and Passport 4460 nodes using the 
SNMP protocol. 

See “Accessing Passport/SNMP Service Data Backup and Restore” (page 30)

Figure 6
Accessing Passport/SNMP Service Data Backup and Restore
241-6001-807   14.3RSUP   
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Chapter 2
Installing and configuring backup and restore 
applications

This section explains how to install and configure Passport and Passport/
SNMP Service Data Backup and Restore applications. 

This section contains the following information:

• “Packaging” (page 31)

• “Resource usage” (page 32)

• “Migration notes” (page 32)

• “File and Directory structure” (page 33)

• “Prerequisites for installing Backup and Restore applications” (page 34)

• “Configuration required for Passport Service Data Backup and Restore” 
(page 37)

• “Configuration required for Passport/SNMP Service Data Backup and 
Restore” (page 39)

Packaging
Passport and Passport/SNMP Service Data Backup and Restore are packaged 
as part of Preside Multiservice Data Manager (MDM). You need a license key 
to run these applications on an MDM workstation. For more information 
about the application license, see “Prerequisites for installing Backup and 
Restore applications” (page 34).
Preside MDM Passport/SNMP Devices Backup and Restore User Guide   14.3RSUP
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The executable files containing Passport and Passport 4400 devices backup 
and restore information are stored in /opt/MagellanNMS/bin. By default, the 
stored data is stored in /opt/MagellanNMS/data/Backup_Data. For 
information on the configuration files, refer to “File and Directory structure” 
(page 33).

Resource usage
The disk space requirement for the Passport/SNMP Devices Backup and 
Restore software is 15 MB. An additional 1 MB is required for the Passport 
Devices Backup and Restore software. In addition, you require sufficient 
storage for service data backups. See 241-6001-101 Preside MDM 
Engineering Guide.

Migration notes
Version 13.4 and earlier

Note the following information when migrating software from version 13.4 
and earlier to version 14.3:

• All data is migrated automatically except for the node list.

• The Data Synchronization server is added to the Server Administration 
list of servers. The Data Synchronization server maintains 
synchronization between the database and the Passport’s current view. 
For more information, refer to 241-6001-400 Preside MDM 
Administration Database User Guide.

Note: In order to support backup and restore tasks, the Data 
Synchronization server must be enabled even if the database is not being 
used.

Version 14.1
Note the following information when migrating software from version 14.1 
to version 14.3:

• All data is migrated automatically except for the node list.

• The BackupNodes.cfg file is replaced by the DataSync.cfg file which 
may only be edited using the Configuration Editor.
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• The user must now define HDGS groups for nodes and then add the 
groups to the backup system. For more information, refer to 
241-6001-303 Preside MDM Administrator Guide and “Adding a 
backup group” (page 115).

Version 14.2
Note the following information when migrating software from version 14.2 
to version 14.3:

• All data is migrated automatically except for the node list.

• The configurations in the DBSyncController.cfg file are merged into the 
DataSync.cfg file.

• The nodes, previously defined in the BackupNodes.cfg file, are not 
migrated because the nodes cannot be automatically mapped to HGDS 
groups.

• The user must now define HDGS groups for nodes and then add the 
groups to the backup system. For more information, refer to 
241-6001-303 Preside MDM Administrator Guide and “Adding a 
backup group” (page 115).

File and Directory structure
The table “Backup and restore file and directory structure” (page 33) 
summarizes the location of the main backup and restore files and directories.

Table 1
Backup and restore file and directory structure

Directory/Files Location

Backup Directory for each 
Passport device containing 
the Passport views and 
journal log files

/opt/MagellanNMS/data/Backup_Data/
PASSPORT<Passport_name>

For Passport devices only

Remote mapping file /opt/MagellanNMS/cfg/Controller.cfg

 (Sheet 1 of 2)
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Prerequisites for installing Backup and Restore 
applications

The Passport and Passport/SNMP Devices Backup and Restore applications 
are installed with MDM Base. For information about installing MDM Base, 
see 241-6001-100 Preside MDM Installer Guide.

You must be licensed to use the Passport and SNMP Devices Backup and 
Restore applications. For information about installing or updating an MDM 
software license, see 241-6001-100 Preside MDM Installer Guide.

In addition, you need:

• for Passport devices, the Host Group Directory Server (HGDS) to 
identify and locate Passports

• for Passport 4400 devices, the General Management Data Router 
(GMDR) server to identify and locate Passport 4400/4460 devices

Modifying the remote mapping file
Modify the remote mapping file (Controller.cfg) when you need to access a 
Provider that is not running on the same host machine as the Controller. This 
is required for Passport and Passport/SNMP Service Data Backup and 
Restore.

Data synchronization 
configuration file (for current 
configuration backup and 
recovery)

/opt/MagellanNMS/cfg/DataSync.cfg

For Passport 4400 devices only

Device information file /opt/MagellanNMS/data/nst/devices.cfg

Interface mapping file /opt/MagellanNMS/cfg/ifmap.cfg

Table 1
Backup and restore file and directory structure (continued)

Directory/Files Location

 (Sheet 2 of 2)
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The Controller uses the remote mapping file (Controller.cfg) to determine the 
Provider to which a device is connected. Add an entry to the remote mapping 
file for any device that you want accessed by a specific Provider. In this file, 
each service has a separate service mapping block of commands. You need to 
include an entry in the service mapping block for each device that you want 
accessed by a specific Provider.

If you do not create an entry, the Backup and Restore tools assume the device 
is connected to the local Provider. The Backup and Restore tools support only 
one remote mapping file.

The format of a service mapping block in the remote mapping file is

service=<service_type>
dev_type=<devtype> 
[dev_name=<devname> | dev_addr=<IPaddress>] 
host=<provider_host>[<:provider_port>]

...

where: 

service_type is either backup or restore.

devtype is the name of the device type (PASSPORT, PP4400, or PP4460).

devname is the name of the device. You can match a group of devices by 
using the wildcard character (*).

IPaddress is the IP address of the device and has the format n.n.n.n. You 
can match a group of devices by using the wildcard character (*).

provider_host:provider_port is the Provider location; provider_host 
is the hostname or IP address of the Provider and provider_port is the port 
number registered to the Provider. The default values for provider_port are:

5020 Passport Backup Provider
5021 Passport Restore Provider
5030 Passport 4400 Backup Provider
5031 Passport 4400 Restore Provider
5040 Passport 4460 Backup Provider
5041 Passport 4460 Restore Provider
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If you do not use devname or IPaddress, the Provider identified in 
provider_host handles the service for all devices of the specified dev_type.

Note: You must include devtype, devname/IPaddress, and host on the 
same line.

You can include comments in the remote mapping file by inserting an 
octothorpe (#) at the beginning of the line. You can also include blank lines.

Example
The following example shows a remote mapping file with 2 service blocks. 
Each device in the service blocks is connected to a different remote host.

# Remote mapping file

service=backup

dev_type=PASSPORT dev_addr=42.208.*.111 host=23.257.32.12

dev_type=PP4400 dev_name=PP4400_20 host=bcarse80

dev_type=PP4460 dev_name=PP4460_64 host=winnipeg

service=restore

dev_type=PASSPORT dev_addr=42.208.*.111 host=59.620.6.24

dev_type=PP4400 dev_name=PP4400_20 host=bcarse80

dev_type=PP4460 dev_name=PP4460_64 host=winnipeg
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Configuration required for Passport Service Data Backup 
and Restore

After you install the Passport Service Data Backup and Restore application, 
perform the following configuration tasks in the order listed:

• Verify the system requirements. For more information, refer to “System 
requirements for Passport nodes” (page 37).

• Install servers. For more information, refer to 241-6001-310 Preside 
MDM Server Reference Guide.

• Enable the Data Synchronization server using the Server Administration 
tool. For more information, refer to “Configuring the Data 
Synchronization server” (page 37).

System requirements for Passport nodes
You need FTP and FMIP access to backup and restore Passport 6000, 7000, 
15000, and 20000 nodes. This is not a requirement for Passport 4400 and 
4460 backup and restore.

Configuring the Data Synchronization server
Passport Service Data Backup and Restore requires that the Data 
Synchronization server is enabled even if the database is not being used. This 
is required for the basic backup and the current configuration backup 
functions.

Use the Server Administration Tool to add the Data Synchronization Server 
to the server list and enable it to automatically startup at reboot time.

Procedure steps
1 In the Preside MDM window, select System -> Administration -> Server 

Administration to open the Server Administration tool.

2 From the Security menu, select the Authorize command.

3 In the SVM Enter Authorization Password dialog box, type a valid 
password and click OK.

4 From the Edit menu, select New Server.

The SVM New Server Selection window displays.

5 Expand the server categories to locate the Data Sync Server in this list.
Preside MDM Passport/SNMP Devices Backup and Restore User Guide   14.3RSUP



38   Chapter 2 Installing and configuring backup and restore applications
6 Select the server and click Select Server.

The SVM Edit Server dialog displays with the fields pre-filled with default 
information.

7 In the Startup command field, type the following command, as follows:

/opt/MagellanNMS/bin/dataSyncServer
[-help]

8 Enable the Automatic startup at reboot time option.

9 Click OK.

A confirmation dialog displays.

10 Click Yes to accept this information.

11 Click Close.
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Configuration required for Passport/SNMP Service Data 
Backup and Restore

After you install the Passport/SNMP Devices Backup and Restore 
application, perform the following configuration tasks in the order listed:

• Verify system requirements and perform any necessary communication 
configuration. For more information, refer to

— “System requirements for Passport 4400/4460 devices” (page 39)

— “IP connectivity for Passport 4400/4460” (page 40)

— “Multiple network interface configuration for Passport 4400/4460 
devices” (page 41)

• “Modifying the device information file for Passport 4400/4460 devices” 
(page 42)

• “Modifying the interface mapping file for Passport 4400/4460 devices” 
(page 45)

• Install servers. For more information, refer to 241-6001-310 Preside 
MDM Server Reference Guide

• “Modifying the remote mapping file” (page 34)

System requirements for Passport 4400/4460 devices
• The Passport 4400 and Passport 4460 Providers need IP connectivity to 

their respective devices. 

For information on how IP connectivity is established with a Passport 
4400 device, see “IP connectivity for Passport 4400/4460” (page 40). 

To verify the IP connectivity between the Providers and a Passport 4400/
4460 device, type the command ping w.w.w.w on the Passport 4400/
4460, where w.w.w.w is the IP address of the workstation where the 
Providers reside.

• The Passport and Passport 4400/4460 devices must be configured to 
allow them to communicate with the workstations on which their 
associated Providers are running.
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IP connectivity for Passport 4400/4460 
The following procedure describes how to configure the communication 
between a Passport 4400/4460 device and a Provider if the Passport 
4400/4460 contains a default configuration. A default configuration means no 
configuration has been entered.

Procedure steps
1 Establish a communication with the Passport 4400/4460 through the 

serial console port. The default line parameters are 9600N81, which 
means:

baud rate: 9600
parity: none
bits: 8
stop bit: 1

If successful, you are prompted for a login when you press the Return key.

2 Type cli at the login prompt. For the password, press the Return key.

3 Define the Ethernet interface IP address of the Passport 4400/4460 by 
entering the following CLI (command line interface) command:

add ip address entry 3 x.x.x.x y.y.y.y z.z.z.z

where:

x.x.x.x is the IP address of the Passport 4400/4460
y.y.y.y is the network netmask
z.z.z.z is the broadcast address

4 Save the configuration with the CLI command:

save config update

5 Reset the Passport 4400/4460 with the new configuration using the CLI 
command:

reset system current reset
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Multiple network interface configuration for Passport 4400/
4460 devices

File transfers between a Passport 4400/4460 and a Provider are initiated by 
the Provider. The IP address of the Provider is delivered to the Passport 
4400/4460. The Provider instructs the Passport 4400/4460 to start the file 
transfer process. The Passport 4400/4460 establishes the TFTP connection 
and the files are transferred.

If the Provider’s host machine has only one network interface (1 IP address), 
that IP address is used for the TFTP connection between the Passport 
4400/4460 and the Provider. 

The Provider host machine can have multiple network interfaces. For 
example, the system can have one interface to the LAN and other interfaces 
to the WAN where the Passport 4400/4460 devices reside. In this 
configuration, the Passport 4400/4460 devices cannot see the IP address of 
the interface to the LAN. In this situation you need to configure the Provider 
to use the correct interface address for the TFTP connection. You do this by 
creating an interface mapping file. For more information on the interface 
mapping file, see “Modifying the interface mapping file for Passport 4400/
4460 devices” (page 45).
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Modifying the device information file for Passport 4400/4460 
devices

Passport/SNMP Service Data Backup and Restore uses the device 
information file (devices.cfg) to display the devices that you can back up and 
restore.You need to include an entry for every device that Passport/SNMP 
backup and restore can access on the host machine.You do not need to include 
all devices in a single file; you can create as many device information files as 
you want and select one from the main window before performing a backup 
or restore.

The device information file enables you to group devices. This option enables 
you to back up or restore all devices within a particular group.

If you have Passport/SNMP Service Data Backup and Restore software on 
multiple hosts, it is recommended that you duplicate the entries in the device 
information files. However, you can divide the entries into device 
information files on different hosts so that each host backs up and restores 
only those devices managed by that host.

The device information file does not have a naming convention. 

Its format is

device: type = <devtype> name = <devname> 
addr = <IPaddress>[:<port>] [userid = <id>]
[passwd = <password>]

group: name = <groupname>
member: name = <devname>

where:

device: indicates information about a particular device.

devtype is the name of the device type (PP4400, or PP4460).

devname  is the name of the device.

IPaddress is the IP address of the device and has the format n.n.n.n. 

port is the port number of the device.
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id is the userID for a Passport and the READ community string for a 
Passport 4400/4460.

password is the user password for a Passport and the WRITE community 
string for a Passport 4400/4460. 

group: indicates information about a group of devices.

groupname is the name of the group to which the device belongs. 

member: indicates information about a member of the group. You need to 
place all members of a group directly after the group line.

Note: You must include devtype, devname, IP address, id, and password 
on the same line.

You can include comments in the device information file by inserting an 
octothorpe (#) at the beginning of the line. You can also include blank lines.

Example
The following example shows a device information file.

device: type = PASSPORT name = NODER05 addr = 82.152.6.19

device: type = PASSPORT name = NODER06 addr = 82.152.6.32

device: type = PASSPORT name = NODERF addr = 82.232.33.74

device: type = PP4400 name = PP4400_20 addr = 35.195.4.173

device: type = PP4400 name = PP4400_EMU addr = 82.195.1.45

device: type = PP4460 name = PP4460_64 addr = 35.195.4.173

device: type = PP4460 name = PP4460_CAL addr = 82.195.1.45

group: name = group01

member: name = NODER05

member: name = NODER06

member: name = NODERF

# You can put a device in more than one group.

group: name = group02
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member: name = NODERF

member: name = PP4400_20

member: name = PP4400_EMU

group: name = group03

member: name = PP4460_64

member: name = PP4460_CAL

device: type = PP4400 name = TEST addr = 15.190.6.58

device: type = PASSPORT name = NODE_TOR addr = 18.232.1.32

group: name = group03

member: name = TEST

member: name = NODE_TOR
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Modifying the interface mapping file for Passport 4400/4460 
devices

If the Provider’s host machine has only one network interface (one IP 
address), that IP address is used for the TFTP connection between the 
Passport 4400/4460 and the Provider. 

The Provider host machine can have multiple network interfaces. For 
example, the system can have one interface to the LAN and other interfaces 
to the WAN where the Passport 4400/4460 devices reside. In this 
configuration the Passport 4400/4460 devices cannot see the IP address of the 
interface to the LAN. In this situation you need to configure the Provider to 
use the correct interface address for the TFTP connection. You do this by 
creating an interface mapping file.

The Passport 4400 and Passport 4460 Providers can use the interface mapping 
file to determine the IP address used as the TFTP server address. The Passport 
4400/4460 device connects to the TFTP server address for TFTP file 
transfers. Each line in the interface mapping file defines the mapping of the 
host address and the Passport 4400/4460 address or addresses. The host 
address is the TFTP server address.

The interface mapping file is named ifmap.cfg. 

The format of ifmap.cfg is

<interface IP address> <device IP address(es)>

where:

interface IP address is the IP address of the interface to be used and 
has the format n.n.n.n.

device IP address(es) is the IP addresses of the devices and has the 
format n.n.n.n. You can match a group of devices by using the wildcard 
character (*).

You can include comments in the interface mapping file by inserting an 
octothorpe (#) at the beginning of the line. You can also include blank lines.
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Example
The following example shows an interface mapping file for a host machine 
that has 3 network interfaces: one connects to the LAN and the other two are 
connected to separate networks of Passport 4400/4460 devices. 

# Interface mapping file

# The last entry is the interface address to the LAN, 

# which needs to map to any device address.

# This last entry can be omitted.

131.147.0.1 131.147.*

131.148.0.1 131.148.*

32.123.1.1 *
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Starting Backup and Restore

This section describes how to set all the options required for Passport and 
Passport/SNMP Service Data Backup and Restore. 

For information on how to perform Current Configuration Backup and 
Current Configuration Recovery, refer to “Current Configuration Backup and 
Database Synchronization” (page 109) and “Current Configuration 
Recovery” on page 125.

Use the procedures described in:

• “Summary of tasks for Passport devices” (page 47)

• “Summary of tasks for Passport 4400/4460 devices” (page 56)

Note: Two distinct interfaces are provided for backup and restore 
activities depending on which type of Passport device you have. For 
information on each of these interfaces, refer to:

• “Passport Backup and Restore window” (page 52)

• “Passport/SNMP Devices Backup and Restore window” (page 61)

Summary of tasks for Passport devices
• Launch the Controllers and Providers as server processes. For more 

information, refer to “Controller commands” (page 49) and “Provider 
commands for Passports” (page 48).

• Set the default account used to access a device. For more information, 
refer to “Setting the default account used to access a device” (page 51).
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• Specify the location of the Data Synchronization Server for the Backup 
and Restore tool. For more information, refer to “Specifying the location 
of the Data Synchronization Server” (page 51).

• Start the Data Synchronization Server. For more information, refer to 
241-6001-400 Preside MDM Administration Database User Guide.

• Start the Passport Backup and Restore tool. For more information, refer 
to “Starting Passport Backup and Restore” (page 52).

Controller and Provider commands for Passport devices
Note: The commands contained in this section are used only for the basic 
view file backups (not Current Configuration mode). Additional 
commands for Current Configuration backup and database 
synchronization are described in “Current Configuration Backup and 
Database Synchronization” on page 109.

The Passport Devices Backup and Restore tool is not fully functional until 
you launch the Controllers and Providers as server processes.

For Provider commands, see “Provider commands for Passports” (page 48) 
and for Controller commands, see “Controller commands” (page 49).

Provider commands for Passports
To start the Passport Backup Provider, you can use the Server Administration 
tool or type the following UNIX command:

/opt/MagellanNMS/bin/pbckpp [-p <port_no>]

To start the Passport Restore Provider, type the following UNIX command:

/opt/MagellanNMS/bin/prstpp [-p <port_no>]

where:

port_no

 is the port number that the Provider uses. 
The default port for the Passport Backup Provider is 5020. The default port 
for the Passport Restore Provider is 5021.
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Controller commands
To start the Backup Controller, type the following UNIX command:

/opt/MagellanNMS/bin/nsctlbck [-p <port_no>] 
[-c <remote_mapping_file>]

To start the Restore Controller, type the following UNIX command:

/opt/MagellanNMS/bin/nsctlrst [-p <port_no>] 
[-c <remote_mapping_file>]

where:

port_no is the port number that the Controller uses. 
The default port for the Backup Controller is 5000. The default port for the 
Restore Controller is 5001.

remote_mapping_file is the name of the remote mapping file. 
The default remote mapping file is /opt/MagellanNMS/cfg/Controller.cfg.

The -nbofbck <#>, where # is the maximum number of backups, limits the 
number of backups that can be performed in parallel. This option can only be 
used with the -notification option that enables current configuration backup 
on alarm or on demand; this option cannot be used for a basic backup. The 
default # is 5. Backup requests coming after the maximum number are queued 
in a waiting queue and are transferred to the executing queue if the executing 
queue is not full. That is, it has less than the maximum number of parallel 
backups, as specified in the nbofbck <#> option of the Backup Server 
command line. By limiting the number of simultaneous backups, you reduce 
congestion problems that may occur with a large number of backups. It is 
recommended that the default be left at 5, unless engineering information is 
available. See “Current Configuration Backup and Database 
Synchronization” on page 109. 

Starting the Restore Provider
Use this procedure to start the Restore Provider and add it to the server list in 
the Server Administration tool. 

Procedure steps
1 In the Preside MDM window, select System -> Administration -> Server 

Administration to open the Server Administration tool.
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2 From the Security menu, select the Authorize command.

3 In the SVM Enter Authorization Password dialog box, type a valid 
password and click OK.

4 From the Edit menu, select Edit -> New server.

The SVM New Server Selection displays.

5 Find the Restore Provider in the list by expanding the server categories.

6 Select the Restore Provider and click Select Server.

The SVM Edit Server displays.

7 In the Startup command field, type the following command:

/opt/MagellanNMS/bin/prstpp

For more information on these variables, refer to “Variable definitions” 
(page 50).

8 Enable the Automatic startup at reboot time option.

9 Click OK.

A confirmation dialog displays.

10 Click Yes to confirm.

11 Click Cancel to close the SVM Edit Server window

12 Right-click on the Restore Provider entry in the server list.

13 From the pop-up menu, select Start.

The Restore Provider starts.

Variable definitions

Variable Definition

-p <portno> is the option to specify the port to use. The default is 5021.

-rt <timeout> is the number of timeout minutes for reconnecting to the Passport. 
The default is 5 minutes.

-h is the option to display command line usage.
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Setting the default account used to access a device
Use the following procedure to set default userids and passwords to access a 
device.

Procedure steps
1 Open the Passport Backup and Restore window.

a. From the Preside MDM window, select Configuration->Passport 
Devices->Administration->PassportService Data Backup/
Restore.

For more information on this window, refer to “Passport Backup and 
Restore window” (page 52).

2 In the Passport Backup and Restore window, select Set Default 
Authentication from the Options menu.

The Default Authentication dialog displays.

3 Enter the appropriate user id and password.

4 Click OK.

Specifying the location of the Data Synchronization Server
It is necessary to specify the location of the Data Synchronization Server for 
the Backup and Restore tool if it is not on the local host.

Procedure steps
1 Open the file /opt/MagellanNMS/cfg/bkRst.cfg.

2 Locate the command line that contains

jmx.server.host: localhost

Note:  The default value for this attribute is localhost.

3 Change the value of localhost to the location of the Data Synchronization 
Server. For example

jmx.server.host: wcars123

4 Save then close the file.
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Starting Passport Backup and Restore
Prerequisites

• launch the Controllers and Providers as server processes. See “Controller 
and Provider commands for Passport devices” (page 48)

• Ensure proper completion of the installation and configuration processes. 
Confirm the following:

— the Controllers are installed on the same host machine as the backed 
up service data

— the Providers are configured to run on host machines

Note: When the Controllers and Providers are configured to run on 
different host machines, the remote mapping file must be properly 
configured. For more information, see “Modifying the remote mapping 
file” (page 34).

Procedure steps
Use one of the following methods:

1 From the Preside MDM window, select Configuration -> Passport Devices 
-> Administration -> Passport Service Data Backup/Restore

The Backup and Restore window opens.

OR 

2 To launch the Passport Backup and Restore application as a stand-alone 
application, type the following UNIX command:

/opt/MagellanNMS/bin/bkRst

Passport Backup and Restore window
The Passport Backup and Restore tool lets you back up and restore service 
data on Passport devices. You can choose full, incremental, or selected 
backup and restores for single or multiple devices.

The Passport/SNMP Devices Backup and Restore window consists of the 
following components:

• “Menu bar” (page 53)
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• “Views” (page 54)

Menu bar
The menu bar is located at the top of the main window. See the following 
sections for information on the menu bar entries:

• “File menu” (page 53)

• “Options menu” (page 53)

• “Tools menu” (page 54)

• “Help” (page 54)

File menu
The File menu contains the following items:

• Reconnect reconnects you to the administration database.

• Exit exits Backup and Restore.

Options menu
The Options menu contains the following items:

• Set Default Authentication opens a dialog where you enter a default 
userid and password that is used to connected to the selected nodes unless 
you enter a specific userid and password.

• Set Software Distribution Site opens a dialog where you can edit the host, 
userid and password for the software distribution site (SDS). The SDS is 
used to download software to a node when using the node recovery 
mode.

• Edit Server Configuration opens a dialog allowing the user to change the 
following:

— backup server host name: name of backup server

— backup server port number: port number of backup server

— backup directory: path to location of backed up data

— restore server host name: name of restore server

— restore server port number: port number of restore server

— restore directory: path to location of restored data
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Tools menu
The Tools menu contains the following items:

• Backup Current Configuration opens the Backup Current 
Configuration window. You use this window to perform a current view 
backup of a group of devices.

Help
The Tools menu contains the following item:

• Help on Window displays online documentation describing the Passport 
Backup and Restore window.

Views
Three views are available by selecting a tab to display the following:

• “Backup Configuration” (page 54)

• “Restore Configuration” (page 55)

• “Recover Device” (page 55)

Each of these view contains a combination of the following command 
buttons: 

• Add opens the Add Device dialog which allows you to define the backup/
restore or recovery mode, userid and password for the selected node.

• Remove removes the selected node from the list.

• Remove removes the selected node from the list.

• Restore restore the selected node from the list.

• Backup initiates a backup on all the nodes in the list.

• Recover initiates a recover on all the nodes in the list.

Backup Configuration 
The Backup Configuration window displays a list of devices you have 
selected for backup and the backup mode (incremental, full, selective). For 
devices with a Selective backup mode, you can search for available views by 
clicking on the Configuration title to display a drop-down list that displays 
the available views.
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The Device Details section of the Backup window displays userid and 
passwords for the selected device. 

The Messages section of the Backup window displays information about the 
Backup process. The text in the Messages section is recorded in the log file 
located in /opt/MagellanNMS/bkRst.log in the users home directory.

Restore Configuration
The Restore Configuration window displays a list of devices you have 
selected to restore the configuration views back to the device. The restore 
modes are displayed (incremental, full, selective). For devices with a 
Selective restore mode, you can search for available views in the backup 
repository by clicking on the Configuration title to display a drop-down list 
that displays the available views

For nodes with an Incremental restore mode, you can edit the date in order to 
define the restore criteria. All views in the repository, later than or equal to 
the specified date, will be restored to the node.

The Device Details section of the Backup window displays userid and 
passwords for the selected node. 

The Message section of the Restore window displays information about the 
Restore process.

Recover Device

The Recover Device window displays a list of devices you want to recover 
back to their last known configuration. Recover detects the last configuration 
data backed up for the device, restores the configuration information and the 
software as well as resets the switch to bring the configuration into service.

The Device Details section of the Recover window has three tabs that you can 
select: 

• Authentication displays userid and passwords for the selected node

• Configuration displays Journal status information for the selected node

ATTENTION The recover capability is available only if you used current 
configuration backup.
Preside MDM Passport/SNMP Devices Backup and Restore User Guide   14.3RSUP



56   Chapter 3 Starting Backup and Restore
• Application Versions displays the list of software on the Passport at the 
time of the latest backup.

The Messages section of the Recover window displays information about the 
recover process. See “Current Configuration Recovery” (page 125).

Summary of tasks for Passport 4400/4460 devices
• Specify which device information file to use. For more information, refer 

to “Specifying the device information file and the devices for Passport 
4400/4460” (page 56)

• Launch the Controllers and Providers as server processes. For more 
information, refer to “Controller commands” (page 58), “Provider 
commands for Passport 4400” (page 57) and “Provider commands for 
Passport 4460” (page 58).

• Start the Passport device. For more information, refer to “Starting 
Passport 4400/4460 devices” (page 59).

• Change Backup options. For more information, refer to “Changing 
options using the Backup Options dialog for an SNMP-based device” 
(page 60).

• Change Restore options. For more information, refer to “Changing 
options using the Restore Options dialog for an SNMP-based device” 
(page 60).

Specifying the device information file and the devices for 
Passport 4400/4460

You need to use a device information file that has entries for the devices you 
are going to access. See “Open File dialog” (page 64).

Procedure steps
1 Open the Passport/SNMP Devices Backup and Restore window.

a. From the Preside MDM window, select Configuration->Passport 
4400 Devices->Administration->Passport/SNMP Service Data 
Backup/Restore.

For more information on this window, refer to “Passport/SNMP 
Devices Backup and Restore window” (page 61).
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2 In the Passport/SNMP Devices Backup and Restore window, select the 
devices to backup or restore. 

If the devices or device groups are not displayed in the devices area

a. From the File menu, select Open.

The Open File dialog opens.

b. Select a device information file by entering a path and file name in the 
File name: data entry box. You can also select a device information 
file using the Look in: pull-down menu and clicking on the file in the 
display panel.

c. Click Open to load the selected device information file and close the 
dialog.

d. From the Passport/SNMP Devices Backup and Restore main 
window, select Options->Save Options to save the current device 
information file as the default for future sessions. This menu item also 
saves any changes you make in the Change Backup Options and 
Change Restore Options dialogs.

Controller and Provider commands for Passport 4400 
devices

The Passport/SNMP Devices Backup and Restore tool is not fully functional 
until you launch the Controllers and Providers as server processes.

For Provider commands, see “Provider commands for Passports” (page 48) 
and for Controller commands, see “Controller commands” (page 49).

Provider commands for Passport 4400
To start the Passport 4400 Backup Provider, you can use Server 
Administration or type the following UNIX command:

/opt/MagellanNMS/bin/pbckpp4400 
[-m <interface_mapping_file>] [-p <port_no>]

To start the Passport 4400 Restore Provider, type the following UNIX 
command:

/opt/MagellanNMS/bin/prstpp4400 
[-m <interface_mapping_file>] [-p <port_no>]

where:
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interface_mapping_file is the name of the interface mapping file. This 
optional file is required when your system has multiple network interfaces. 
The default interface mapping file is /opt/MagellanNMS/cfg/ifmap.cfg. 

If the file ifmap.cfg exists in directory /opt/MagellanNMS/cfg and is 
populated with valid mapping information, it is not necessary to specify the 
-m option. This file is used by default.

port_no is the port number that the Provider uses. 
The default port for the Passport 4400 Backup Provider is 5030. The default 
port for the Passport 4400 Restore Provider is 5031.

Controller commands
To start the Backup Controller, type the following UNIX command:

/opt/MagellanNMS/bin/nsctlbck [-p <port_no>] 
[-c <remote_mapping_file>]

To start the Restore Controller, type the following UNIX command:

/opt/MagellanNMS/bin/nsctlrst [-p <port_no>] 
[-c <remote_mapping_file>]

where:

port_no is the port number that the Controller uses. 
The default port for the Backup Controller is 5000. The default port for the 
Restore Controller is 5001.

remote_mapping_file is the name of the remote mapping file. 
The default remote mapping file is /opt/MagellanNMS/cfg/Controller.cfg.

Provider commands for Passport 4460
To start the Passport 4460 Backup Provider, type the following UNIX 
command:

/opt/MagellanNMS/bin/pbckpp4460 
[-m <interface_mapping_file>] [-p <port_no>]
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To start the Passport 4460 Restore Provider, type the following UNIX 
command:

/opt/MagellanNMS/bin/prstpp4460 
[-m <interface_mapping_file>] [-p <port_no>]

where:

interface_mapping_file is the name of the interface mapping file. This 
optional file is required when your system has multiple network interfaces. 
The default interface mapping file is /opt/MagellanNMS/cfg/ifmap.cfg. 

If the file ifmap.cfg exists in directory /opt/MagellanNMS/cfg and is 
populated with valid mapping information, it is not necessary to specify the 
-m option. This file is used by default.

port_no is the port number that the Provider uses. 
The default port for the Passport 4460 Backup Provider is 5040. The default 
port for the Passport 4460 Restore Provider is 5041.

Starting Passport 4400/4460 devices
Prerequisites

• launch the Controllers and Providers as server processes. See “Controller 
and Provider commands for Passport devices” (page 48)

• Ensure proper completion of the installation and configuration processes. 
Confirm the following:

— the Controllers are installed on the same host machine as the backed 
up service data

— the Providers are configured to run on host machines

Note: When the Controllers and Providers are configured to run on 
different host machines, the remote mapping file must be properly 
configured. For more information, see “Modifying the remote mapping 
file” (page 34).

Procedure steps
Use the following methods:
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1  From the Preside MDM window, select Configuration -> Passport 4400 
Devices -> Administration -> Passport/SNMP Service Data Backup/
Restore

The Passport/SNMP Devices Backup and Restore window opens.

Changing options using the Backup Options dialog for an 
SNMP-based device

Before you perform a SNMP-based backup, you can change the default 
values of the Controller, Controller port, and target directory. See “Change 
Backup Options dialog” (page 66).

Procedure steps
1 Open the Passport/SNMP Devices Backup and Restore window.

a. From the Preside MDM window, select Configuration->Passport 
4400 Devices->Administration->Passport/SNMP Service Data 
Backup/Restore.

For more information on this window, refer to “Passport/SNMP 
Devices Backup and Restore window” (page 61).

2 In the Passport/SNMP Devices Backup and Restore window, select 
Change Backup Options from the Options menu.

The Change Backup Options dialog opens.

3 Modify the Backup controller host, Backup controller port, or Target 
directory.

4 Click OK to close the dialog.

5 From the Options menu, select Save Options to save your changes for 
future sessions. This command also saves the current device information 
file and any changes you make in the Change Restore Options dialog.

Changing options using the Restore Options dialog for an 
SNMP-based device

Before you perform a restore, you can change the default values of the 
Controller, Controller port, and source directory. See “Change Restore 
Options dialog” (page 67).

Procedure steps
1 Open the Passport Backup and Restore window.
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a. From the Preside MDM window, select Configuration->Passport 
Devices->Administration->PassportService Data Backup/
Restore.

For more information on this window, refer to “Passport Backup and 
Restore window” (page 52).

2 In the Passport Backup and Restore window, select Change Restore 
Options from the Options menu.

The Change Restore Options dialog opens.

3 Modify the Restore controller host, Restore controller port, or Source 
directory.

4 Click OK to close the dialog.

5 From the Options menu, select Save Options to save your changes for 
future sessions. This command also saves the current device information 
file and any changes you make in the Change Backup Options dialog.

Passport/SNMP Devices Backup and Restore window
The Passport/SNMP Devices Backup and Restore tool lets you back up and 
restore service data on Passport 4400 and 4460 SNMP devices. You can 
choose full, incremental, or selected backup and restores for single or 
multiple devices. You can also perform a Node Recover for a replacement 
Passport in the event of a disaster.

The figure “Passport Backup and Restore window” (page 52) shows a sample 
window.
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Figure 7
Passport/SNMP Devices Backup and Restore window

The Passport/SNMP Devices Backup and Restore window consists of the 
following components:

• “Menu bar” (page 53)

• “Configuration file area” (page 63)

• “Devices area” (page 63)

• “Command buttons” (page 64)

Menu bar
The menu bar is located at the top of the main window. See the following 
sections for information on the menu bar entries:

• “File menu” (page 53)

• “Options menu” (page 53)

• “Tools menu” (page 54)

File menu
The File menu contains the following items:

• Open opens the Open File dialog. From this dialog, you can set the 
device information file that Passport/SNMP Devices Backup and 
Restore uses. For more information, see “Open File dialog” (page 64).
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• Exit exits Passport/SNMP Devices Backup and Restore.

Options menu
The Options menu contains the following items:

• Change Backup Options opens the Change Backup Options dialog. From 
this dialog you can set Controller information and the target directory for 
the backup data. For more information, see “Change Backup Options 
dialog” (page 66).

• Change Restore Options opens the Change Restore Options dialog. From 
this dialog you can set Controller information and the source directory 
for the restore data. For more information, see “Change Restore Options 
dialog” (page 67).

• Save Options saves, for future sessions, the current device information 
file and the changes you make in the Change Backup Options and 
Change Restore Options dialogs. This information is saved in the 
preferences file $home/.NS/.nsOptions where $home is your home 
directory.

Help menu
The Help menu contains the following item:

• Help On Window displays online documentation describing the Passport/
SNMP Devices Backup and Restore window.

Configuration file area
This display field shows the name of the device information file in use by 
Passport/SNMP Devices Backup and Restore. You can use the Open option 
of the File menu to select another device information file.

Devices area
The devices listed in the current device information file are displayed in this 
area. Group names are indicated by filled folder icons. You can display the 
device names contained in a group by double-clicking the group name. 
Device names are indicated by blank page icons.

You can select single devices or groups of devices to back up, restore or 
recover by clicking on the device or group names. Selected entries are shaded. 
You can change an entry from selected to unselected by clicking on it.
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Command buttons
The Passport/SNMP Devices Backup window contains the following 
command buttons:

• Backup
The Backup button opens the Passport/SNMP Backup window. For more 
information, see “Basic service data backup” (page 69).

• Restore
The Restore button opens the Passport/SNMP Restore window. For more 
information, see “Basic service data restore” (page 89).

• Node Recover
The Node Recover button opens the Passport Devices Node Recovery 
window. For more information, see “Current Configuration Recovery” 
(page 125).

• Exit
The Exit button exits the Passport/SNMP Devices Backup and Restore 
tool.

Passport/SNMP Devices Backup and Restore startup dialogs
There are three dialogs that allow you to edit default information before 
performing backup and restore operations. These dialogs are

• “Open File dialog” (page 64)

• “Change Backup Options dialog” (page 66)

• “Change Restore Options dialog” (page 67)

Open File dialog
The Open File dialog (from the File menu) enables you to select the device 
information file used by Passport/SNMP Devices Backup and Restore. You 
can enter the absolute path and file name or select the file from the display 
panel.

The Open File dialog opens at the default directory /opt/MagellanNMS/data/
nst.
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To save your changes for future sessions, from the Passport/SNMP Devices 
Backup and Restore menu, select Options->Save Options. For more 
information about the Save Options menu item, see “Passport Backup and 
Restore window” (page 52).

The Open File dialog consists of six areas:

• the Look in pull-down box displays the directory hierarchy for the 
current disk. You can change directories using this pull-down box by 

— clicking on the down arrow to open the box

— proceed up the directory hierarchy by clicking on any directory 
above the current directory

— proceed down the directory on any filled folder icon in the display 
panel

• five buttons that change the display

— the button with an up-arrow through a folder proceeds up the 
directory hierarchy one level

— the button with the house moves the display to your home directory

— the button with a folder, only, creates new sub-directories.

— the four icon button lists files in the current directory

— the two icon button displays file details for the current directory

• Use the central display to select a device information file by clicking on 
the file. The central display panel shows 

— sub-directories of the current directory using filled folder icons

— files in the current directory using blank page icons

• a data entry box where you enter the absolute path and device file name. 
If you select a file using the display panel, the selected file name is 
indicated in this data entry box.

• a pull-down box to specify the type of files to display. The default is all 
files in the current directory are displayed.

• two buttons to open or close (cancel) the Open File dialog
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— Open loads the selected file and returns to the Passport/SNMP 
Devices Backup and Restore main window.

— Cancel closes the Open File dialog without loading a file.

The figure “Open File dialog” (page 66) shows an example of the Open File 
dialog.

Figure 8
Open File dialog

Change Backup Options dialog
The Change Backup Options dialog enables you to select 

• the Controller that Passport/SNMP Devices Backup and Restore 
accesses when backing up service data

• the Controller port that Passport/SNMP Devices Backup and Restore 
uses when backing up service data

• the target directory where the backed up service data is stored

The OK button closes the Change Backup Options dialog. To save your 
changes for future sessions, click OK, and from the Options menu on the 
menu bar, select Save Options. 

The figure “Change Backup Options dialog” (page 67) shows an example of 
the Change Backup Options dialog.
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Figure 9
Change Backup Options dialog

Change Restore Options dialog
The Change Restore Options dialog enables you to select 

• the Controller that Passport/SNMP Devices Backup and Restore 
accesses when restoring service data

• the Controller port that Passport/SNMP Devices Backup and Restore 
uses when restoring service data

• the source directory for the service data to be restored

The OK button closes the Change Restore Options dialog. To save your 
changes for future sessions, click OK, and from the Options menu on the 
menu bar, select Save Options. 

The figure “Change Restore Options dialog” (page 68) shows an example of 
the Change Restore Options dialog.
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Figure 10
Change Restore Options dialog
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Basic service data backup

This section describes using Passport and Passport/SNMP Service Data 
Backup and Restore to perform a basic back up of service data.

Passport Backup copies only the configuration data of the Passport. The 
service data views that make up the configuration data are found on the 
Passport disk in a set of files in individual directories under the directory /
provisioning. Passport Backup also copies the special files that are found 
under the directory /provisioning/netsentry.

 Passport and Passport/SNMP Service Data Backup and Restore provide three 
types of backup.

• A full backup copies all service data on the selected device or devices.

• An incremental backup copies only service data changed or created since 
the last backup. Like the full backup, you can perform an incremental 
backup on either one or multiple devices.

• A selective backup copies specific service data that you select. You can 
perform a selective backup on either one or multiple devices.

ATTENTION Use Passport Service Data Backup and Restore for Passport 
6000, 7000, 15000, and 20000 nodes.
Use Passport/SNMP Service Data Backup and Restore for 
Passport 4400 and 4460 nodes.
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Note: The result of all three backup types is the same for Passport 4400/
4460 devices. This is because Passport 4400/4460 devices have only one 
view. Therefore, if you select a full backup, you backup one view. 
Conversely, if you select a selective or incremental backup, you backup 
the same view. The configuration data for Passport 4400/4460 devices 
are stored in two memory banks (bank3 and bank4). Passport/SNMP 
service data backup does not back up both banks, only the committed 
bank is backed up

For Passport and Passport/SNMP backup see “Backup file naming 
convention” (page 71)

• “Backup file naming convention” (page 71)

The following information applies to using the Passport Service Data 
Backup and Restore tool to backup Passport 6000, 7000, 15000, and 
20000 nodes:

• “Adding Passport devices to the backup list” (page 72)

• “Removing Passport devices from the backup list” (page 73)

• “Viewing the Passport backup repository” (page 73)

• “Defining a specific userid and password for a Passport in the backup 
list” (page 74)

• “Changing the Default User Authentication” (page 74)

• “Performing a full backup for a Passport device” (page 75)

• “Performing an incremental backup for a Passport device” (page 75)

• “Performing a selective backup for a Passport device” (page 76)

The following information applies to using the Passport/SNMP Service 
Data Backup and Restore tool to backup Passport 4400 and 4460 nodes:

• “Changing default information for SNMP-based devices Backup” 
(page 78)

• “Performing a full backup for an SNMP-based device” (page 78)

• “Performing an incremental backup for an SNMP-based device” 
(page 79)
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• “Performing a selective backup for a SNMP-based device” (page 81)

Backup file naming convention
The service data backup files have the following naming convention:

./<devtype>/<devname>/<timestamp>.<dataset>/ \ 
<datafiles...>

Note: The period (.) represents the Passport/SNMP Devices Backup and 
Restore root directory.

where:

devtype is the device type (PASSPORT, PP4400, or PP4460).

devname is the device name.

timestamp has the format yyyymmddhhmmss

datatset is the dataset name. 
For Passport, the dataset name is the Passport view file name. 
For Passport 4400/4460, the dataset name is either COMMIT or ACTIVE.

<datafiles...> are the names of one or more files that are backed up.

Examples
The following example indicates that a backup was done of the Passport 
switch NODE10 on January 4, 1998 at 10:20:30 a.m.

./PASSPORT/NODE10/19980104102030.mydata.full.001

The following example indicates that a backup was done of the Passport 4400 
switch PP01 on December 29, 1998 at 5:25:48 p.m.

./PP4400/PP01/19981229172548.COMMIT

The following example indicates that a backup was done of the Passport 4460 
switch PP4460_CAL on March 18, 2000 at 1:45:16 p.m.

./PP4460/PP4460_CAL/20000318134516.COMMIT
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Passport Backup Procedures
The following information applies to the Passport Service Data Backup and 
Restore tool for Passport 6000, 7000, 15000, and 20000 nodes:

• “Adding Passport devices to the backup list” (page 72)

• “Removing Passport devices from the backup list” (page 73)

• “Viewing the Passport backup repository” (page 73)

• “Defining a specific userid and password for a Passport in the backup 
list” (page 74)

• “Changing the Default User Authentication” (page 74)

• “Performing a full backup for a Passport device” (page 75)

• “Performing an incremental backup for a Passport device” (page 75)

• “Performing a selective backup for a Passport device” (page 76)

Adding Passport devices to the backup list
Use this procedure to add devices to the list of devices that you wish to 
backup.

Procedure steps
1 Open the Passport Backup and Restore window.

a. From the Preside MDM window, select Configuration->Passport 
Devices->Administration->PassportService Data Backup/
Restore.

For more information on this window, refer to “Passport Backup and 
Restore window” (page 52).

2 Select the Backup Configuration tab.

3 Select Add to launch the Add Devices Dialog.

4 From the left pane, select a group of devices or expand the group and use 
the Ctrl key to select a number of devices within a group.

5 From the drop down list, in the right pane, select a backup mode 
(Incremental or Full). 

6 If a specific userid and password is required for the device, enter the 
values in the user ID and Password fields and uncheck the Use default  
checkbox.
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If you wish to use the default userid and password, click the Use default 
checkbox.

7 Click OK.

The devices display in the Device List.

Removing Passport devices from the backup list
Use this procedure to remove devices from the list of devices that you wish 
to backup.

Procedure steps
1 Open the Passport Backup and Restore window.

a. From the Preside MDM window, select Configuration->Passport 
Devices->Administration->PassportService Data Backup/
Restore.

For more information on this window, refer to “Passport Backup and 
Restore window” (page 52).

2 Select the Backup Configuration tab.

3 In the Device List, select the devices you wish to remove.

4 Click Remove.

5 In the confirmation dialog, select Yes to confirm or No to cancel the 
removal.

Viewing the Passport backup repository
If the backup server is running locally, use the following procedure to view 
all the backup files in the backup repository.

Procedure steps
1 Telnet into the remote workstation with the appropriate userid and 

password.

2 Navigate to the repository directory.

3 Use unix directory commands to view the contents of the backup 
repository.
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Defining a specific userid and password for a Passport in 
the backup list

A specific userid and password can be defined when you add the node to the 
node list or you can set it later using the following procedure.

Procedure steps
1 Open the Passport Backup and Restore window.

a. From the Preside MDM window, select Configuration->Passport 
Devices->Administration->Passport Service Data Backup/
Restore.

For more information on this window, refer to “Passport Backup and 
Restore window” (page 52).

2 Select the Backup Configuration tab.

3 Select a node in the Device List section.

4 In the Device Details section, in the Authentication tab, enter a userid 
and password.

5 Clear the Use default checkbox.

Changing the Default User Authentication 
Use the following procedure to define a default userid and password which is 
used for all node access unless overridden by a specific userid and password 
for the node.

Procedure steps
1 Open the Passport Backup and Restore window.

a. From the Preside MDM window, select Configuration->Passport 
Devices->Administration->Passport Service Data Backup/
Restore.

For more information on this window, refer to “Passport Backup and 
Restore window” (page 52).

2 Select Options ->Set default authentication.

3 Enter the userid and password in the appropriate fields.

4 Click OK.

The new userid and password are used on the next node access.
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Performing a full backup for a Passport device 
Prerequisites

The devices that you back up must be properly configured in 
Passport Backup and Restore. See “Installing and configuring backup and 
restore applications” (page 31). 

Procedure steps
1 Verify that the “Prerequisites” (page 75) are satisfied.

2 Open the Passport Backup and Restore window.

a. From the Preside MDM window, select Configuration->Passport 
Devices->Administration->Passport Service Data Backup/
Restore.

For more information on this window, refer to “Passport Backup and 
Restore window” (page 52).

3 Select the Backup Configuration tab.

4 Select Add to launch the Add Devices dialog.

5 From the left pane, select a group of devices or expand the group and use 
the Ctrl key to select a number of devices within a group.

6 Select a device in the Device list:

7 Click in the Mode title and select Full from the drop-down list.

8 Click Backup.

The progress of the backup is displayed in the Messages area. If the 
backup is unsuccessful, an error dialog is displayed that specifies the 
device and the reason for the failure.

Note:  To cancel a backup in progress click Cancel.

Performing an incremental backup for a Passport device 
Use the following procedure to backup only backup files that are not already 
in the repository.

Procedure steps
1 Verify that the “Prerequisites” (page 75) are satisfied.

2 Open the Passport Backup and Restore window.
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a. From the Preside MDM window, select Configuration->Passport 
Devices->Administration->Passport Service Data Backup/
Restore.

For more information on this window, refer to “Passport Backup and 
Restore window” (page 52).

3 Select the Backup Configuration tab.

4 Select Add to launch the Add Devices dialog.

5 From the left pane, select a group of devices or expand the group and use 
the Ctrl key to select a number of devices within a group.

6 Select a node in the nodes list.

7 In the Mode title, select Incremental from the drop-down list.

8 If you wish to specify a backup of views later than a specific date, enter 
the date in the date field. (for example July 3, 2003

9 Click Backup.

The progress of the backup is displayed in the Status area. If the backup 
is unsuccessful, an error dialog is displayed that specifies the device and 
the reason for the failure.

Note:  To cancel a backup in progress click Cancel.

Performing a selective backup for a Passport device 
Use the following procedure to backup only a single specified file to the 
repository.

Procedure steps
1 Verify that the “Prerequisites” (page 75) are satisfied.

2 Open the Passport Backup and Restore window.

a. From the Preside MDM window, select Configuration->Passport 
Devices->Administration->Passport Service Data Backup/
Restore.

For more information on this window, refer to “Passport Backup and 
Restore window” (page 52).

3 Select the Backup Configuration tab.

4 Select Add to launch the Add Devices dialog.
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5 From the left pane, select a group of devices or expand the group and use 
the Ctrl key to select a number of devices within a group.

6 Select a device in the Devices list.

7 In the Mode title, select Selective from the drop-down list.

The Configuration column in the table is enabled.

8 Click in the Configuration cell to display a pull-down list that displays all 
the available views on the Passport.

Note:  This step may take a few seconds to complete because the 
application must access the Passport and list all the views names.

9 Click Backup.

The progress of the backup is displayed in the Status area. If the backup 
is unsuccessful, an error dialog is displayed that specifies the device and 
the reason for the failure.

Note:  To cancel a backup in progress click Cancel.
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SNMP-based devices procedures
The following information applies to the Passport/ SNMP Service Data 
Backup and Restore tool for Passport 4400 and 4460 nodes:

• “Changing default information for SNMP-based devices Backup” 
(page 78)

• “Performing a full backup for an SNMP-based device” (page 78)

• “Performing an incremental backup for an SNMP-based device” 
(page 79)

• “Performing a selective backup for a SNMP-based device” (page 81)

Changing default information for SNMP-based devices 
Backup

You can change the default information for any device type listed in the main 
window.

Procedure steps
1 Open the Passport/SNMP Devices Backup and Restore window.

a. From the Preside MDM window, select Configuration->Passport 
4400 Devices->Administration->Passport/SNMP Service Data 
Backup/Restore.

For more information on this window, refer to “Passport/SNMP 
Devices Backup and Restore window” (page 61).

2 In the Passport/SNMP Devices Backup window, double-click on the entry 
that you need to change in the Default Backup Information area. See 
“Passport/SNMP Devices Backup window” (page 83) for information on 
this window.

The Change Default Information dialog opens.

3 Make the required changes.

4 Click OK to save your changes and close the dialog.

Performing a full backup for an SNMP-based device
A full backup copies all the service data on a selected device or devices.
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Passport/SNMP Devices Backup copies only the configuration data of the 
Passport. The service data views that make up the configuration data are 
found on the Passport disk in a set of files in individual directories under the 
directory /provisioning. Passport/SNMP Devices Backup also copies the 
special files that are found under the directory /provisioning/netsentry.

Prerequisites
For information about configuring Passport/SNMP Devices Backup and 
Restore for Passport 4400/4460 devices, see “Configuration required for 
Passport/SNMP Service Data Backup and Restore” (page 39) and 
“Modifying the remote mapping file” (page 34).

Procedure steps
1 Open the Passport/SNMP Devices Backup and Restore window.

a. From the Preside MDM window, select Configuration->Passport 
4400 Devices->Administration->Passport/SNMP Service Data 
Backup/Restore.

For more information on this window, refer to “Passport/SNMP 
Devices Backup and Restore window” (page 61).

2 In the Passport/SNMP Devices Backup window, select only the device or 
devices whose service data you need to back up from the Backup 
Information area of the window. See “Passport/SNMP Devices Backup 
window” (page 83).

The selected devices have a check mark in the Bck column. All other 
devices have no entry in the Bck column.

3 In the Backup Mode Selection area, click full.

4 Click Backup.

When the backup completes successfully, a message is displayed in the 
Message area. If the backup is unsuccessful, an error dialog is displayed 
that specifies the device and the reason for the failure.

Performing an incremental backup for an SNMP-based 
device 

An incremental backup copies only that service data changed or created since 
the last backup. For Passport 4400/4460 devices, an incremental backup is the 
same as a full backup because this device has only one view.
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Passport/SNMP Devices Backup copies only the configuration data of the 
Passport. The service data views that make up the configuration data are 
found on the Passport disk in a set of files in individual directories under the 
directory /provisioning. Passport/SNMP Devices Backup also copies the 
special files that are found under the directory /provisioning/netsentry.

The configuration data for Passport 4400/4460 devices are stored in two 
memory banks (bank3 and bank4). Passport/SNMP Devices Backup does not 
back up both banks, only the committed bank is backed up.

Prerequisites
For information about configuring Passport/SNMP Devices Backup and 
Restore for Passport 4400/4460 devices, see “Modifying the remote mapping 
file” (page 34) and “Configuration required for Passport/SNMP Service Data 
Backup and Restore” (page 39).

Procedure steps
1 Open the Passport/SNMP Devices Backup and Restore window.

a. From the Preside MDM window, select Configuration->Passport 
4400 Devices->Administration->Passport/SNMP Service Data 
Backup/Restore.

For more information on this window, refer to “Passport/SNMP 
Devices Backup and Restore window” (page 61).

2 In the Passport/SNMP Devices Backup window, select only the device or 
devices whose service data you need to back up from the Backup 
Information area of the window. See “Passport/SNMP Devices Backup 
window” (page 83).

The selected devices have a check mark in the Bck column. All other 
devices have no entry in the Bck column.

3 In the Backup Mode Selection area, click incr.

4 Click Backup.

When the backup completes successfully, a message is displayed in the 
Message area. If the backup is unsuccessful, an error dialog is displayed 
that specifies the device and the reason for the failure.
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Performing a selective backup for a SNMP-based device
A selective backup copies only the service data that you select. For Passport 
4400/4460 devices, a selective backup is the same as a full backup because 
this device has only one view.

Passport/SNMP Devices Backup copies only the configuration data of the 
Passport. The service data views that make up the configuration data are 
found on the Passport disk in a set of files in individual directories under the 
directory /provisioning. Passport/SNMP Devices Backup also copies the 
special files that are found under the directory /provisioning/netsentry.

The configuration data for Passport 4400/4460 devices are stored in two 
memory banks (bank3 and bank4). Passport/SNMP Devices Backup does not 
back up both banks, only the committed bank is backed up.

Prerequisites
The devices that you back up need to be properly configured in 
Passport/SNMP Devices Backup and Restore. See “Modifying the remote 
mapping file” (page 34) and “Configuration required for Passport/SNMP 
Service Data Backup and Restore” (page 39).

Procedure steps
1 Open the Passport/SNMP Devices Backup and Restore window.

a. From the Preside MDM window, select Configuration->Passport 
4400 Devices->Administration->Passport/SNMP Service Data 
Backup/Restore.

For more information on this window, refer to “Passport/SNMP 
Devices Backup and Restore window” (page 61).

2 In the Passport/SNMP Devices Backup window, select only the device or 
devices whose service data you need to back up from the Backup 
Information area of the window. See “Passport/SNMP Devices Backup 
window” (page 83).

The selected devices have a check mark in the Bck column. All other 
devices have no entry in the Bck column.

3 In the Backup Mode Selection area, click sel.

The List Views button is enabled.
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4 Click the List Views button and select the required view file. You can 
display selected view files by using the Filter data entry field and pressing 
<return>.

OR

Enter the name of the required view file in the sel data entry field and 
press <return>.

The view file name is displayed in the sel data entry field and in the View 
column of the Backup Information area.

5 Click Backup.

When the backup completes successfully, a message is displayed in the 
Message area. If the backup is unsuccessful, an error dialog is displayed 
that specifies the device and the reason for the failure.
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Passport/SNMP Devices Backup window
The Passport/SNMP Devices Backup window displays relevant backup 
information and provides fields that let you select the devices to backup and 
level of backup. The window also contains a message area that displays status 
information while the backup process executes.

The figure “Passport/SNMP Devices Backup window” (page 83) shows a 
sample backup window.

Figure 11
Passport/SNMP Devices Backup window
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The Passport/SNMP Devices Backup window consists of the following 
components:

• “Default Backup Information area” (page 84)

• “Controller Information area” (page 84)

• “Backup Information area” (page 85)

• “Backup Mode Selection area” (page 86)

• “Message area” (page 86)

• “Command buttons” (page 86)

Default Backup Information area
The Default Backup Information area contains connection information. There 
is an entry for each different device type in the device information file. Each 
device type that is listed in this area can have the following entries:

• DevType is the device type.

• id (rd community) is the userID for a Passport and the READ community 
string for a Passport 4400/4460.

This field is displayed as a series of asterisks (*). 

• pw (wr community) is the user password for a Passport and the WRITE 
community string for a Passport 4400/4460. 

This field is displayed as a series of asterisks (*).

• Port is the port number of the device.

You can edit any line in this area by double-clicking on it. This action opens 
the Change Default Information dialog. For more information about changing 
the default information, see “Changing default information for SNMP-based 
devices Backup” (page 78).

Controller Information area
The Controller Information area displays the information from the Change 
Backup Options dialog.
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Backup Information area
The Backup Information area contains details about each device available for 
back up. Click on a line in this area to edit it. Make your changes by editing 
other fields on the main window.

Each device has the following entries:

• DevName is the device name.

• id (rd community) is the userID for a Passport and the READ community 
string for a Passport 4400/4460.

This field is displayed as a series of asterisks (*). 

When present, this field overrides the corresponding field in the Default 
Backup Information area. You can edit this field in the id (rd community) 
data entry field immediately below the Backup Information area. A 
backup fails when the device has no id (rd community).

• pw (wr community) is the user password for a Passport and the WRITE 
community string for a Passport 4400/4460. 

This field is displayed as a series of asterisks (*). 

When present, this field overrides the corresponding field in the Default 
Backup Information area. You can edit this field in the pw (wr 
community) data entry field immediately below the Backup Information 
area. A backup fails when the device has no pw (wr community).

• A check mark in the Bck field indicates that this device is to be backed 
up. You can select and deselect any device by double-clicking the line 
containing the device name.

• Mode indicates the type of backup (full, incremental, or selective). You 
can change this field by clicking the appropriate button in the Backup 
Mode Selection area.

• View is the view being backed up by a selective backup. Clicking the sel 
button in the Backup Mode Selection area activates the View and List 
Views fields. You can choose a view file from List Views by double-
clicking on an entry or you can enter a view file name in the View data 
entry field and press Return.
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Backup Mode Selection area
The Backup Mode Selection area contains information about the types of 
backups you can perform. When you edit the fields in this area, you change 
the Mode and View fields of the device that is highlighted in the Backup 
Information area.

This area contains the following fields:

• incr indicates an incremental backup.

• full indicates a full backup.

• sel indicates a selective backup.

• the sel data entry field is where you enter the name of the view file that 
you want to back up. The file entered in this field updates the View field 
in the Backup Information area.

• List Views button lists the view files that are available for selective 
backup. You select a file in this list by double-clicking on an entry. 
Selection of a view from the List Views window updates the contents of 
the View data entry field and the View field in the Backup Information 
area. The List Views button is enabled only when you select the sel 
button.

• the Filter data entry field specifies a search criteria for view files. You 
can match any string of any length by using the wildcard character (*).

Note: The question mark (?) does not function as a wildcard in the Filter 
field. For example, MM?[ab] returns only the view MM?[ab], if it exists.

Message area
The Message area displays messages generated by Passport/SNMP Devices 
Backup during execution.

Command buttons
The Passport/SNMP Devices Backup window contains the following 
command buttons:

• Backup
The Backup button starts the backup process.
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• Cancel
The Cancel button terminates an executing backup. Completed backups 
are kept; backups in progress, or not started, are cancelled.

• Exit
The Exit button closes the Passport/SNMP Devices Backup window.

• Help
The Help button displays online documentation describing the Passport/
SNMP Devices Backup window.
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Basic service data restore

This section describes using Passport and Passport /SNMP Service Data 
Backup and Restore to restore backed up service data from the backup site to 
the device. 

 The Passport and Passport/SNMP Service Data Backup and Restore tools 
provide three types of restore:

• A full restore restores all backed up service data to the selected device or 
devices.

• An incremental restore restores service data based on a specified date. 
Like the full restore, you can perform an incremental restore on either 
one or multiple devices.

• A selective restore restores specific service data that you select. Like the 
full restore, you can perform a selective restore on either one or multiple 
devices.

Note: It is not recommended that an active file (current view) be restored 
on a Passport. When you restore the current view, you may overwrite the 
existing current view with different content. This action will cause an 
outage of the Backup and Restore tool.

ATTENTION Use Passport Service Data Backup and Restore for Passport 
6000, 7000, 15000, and 20000 nodes.
Use Passport/SNMP Service Data Backup and Restore for 
Passport 4400 and 4460 nodes.
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The following information applies to using the Passport Service Data 
Backup and Restore tool to perform a restore for Passport 6000, 7000, 
15000, and 20000 nodes:

• “Adding Passport devices to the restore list” (page 91)

• “Removing Passport devices from the restore list” (page 92)

• “Defining a specific userid and password for a Passport device in the 
restore list” (page 92)

• “Performing a full restore for a Passport device” (page 93)

• “Performing an incremental restore for a Passport device” (page 94)

• “Performing a selective restore for a Passport device” (page 94)

• “Activating the restored Passport data” (page 96)

The following information applies to using the Passport/SNMP Service 
Data Backup and Restore tool to perform a restore for Passport 4400 and 
4460 nodes:

• “Changing default information for Passport/SNMP Devices Restore” 
(page 97)

• “Performing a full restore for an SNMP-based device” (page 98)

• “Performing an incremental restore for an SNMP-based device” 
(page 99)

• “Performing a selective restore for an SNMP-based device” (page 100)

• “Activating the restored Passport 4400/4460 data” (page 101)

• “Passport/SNMP Devices Restore window” (page 102)
241-6001-807   14.3RSUP   



Chapter 5 Basic service data restore   91
Passport Service Data restore procedures
The following procedures apply to using the Passport Service Data Backup 
and Restore tool to perform a restore for Passport 6000, 7000, 15000, and 
20000 nodes:

• “Adding Passport devices to the restore list” (page 91)

• “Removing Passport devices from the restore list” (page 92)

• “Defining a specific userid and password for a Passport device in the 
restore list” (page 92)

• “Performing a full restore for a Passport device” (page 93)

• “Activating the restored Passport data” (page 96)

Adding Passport devices to the restore list
Use the following procedure to add devices to the Devices List.

Procedure steps
1 Open the Passport Backup and Restore window.

a. From the Preside MDM window, select Configuration->Passport 
Devices->Administration->Passport Service Data Backup/
Restore.

For more information on this window, refer to “Passport Backup and 
Restore window” (page 52).

2 Select the Restore Configuration tab.

3 Click Add to open the Add Device dialog.

4 Select a group of devices or expand the group and use the Ctrl key to 
select a number of devices.

5 Select the appropriate restore mode, from the Mode column (full or 
incremental).

6 If a specific userid and password is required for the device, enter the 
values in the User ID and Password fields and uncheck the Use default 
checkbox.

If you wish to use the default userid and password, click the Use default 
checkbox.

7 Click OK.
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The IP addresses for the devices are retrieved from HGDS and the device 
displays in the Devices list. 

For devices that are not in HGDS, you are prompted for their IP address. 
If you are prompted for an IP address, do step 8.

8 If you know the IP address, enter the correct IP address in the form and 
click OK and the device is added to the Devices list.

If the IP address is unknown or the device is not valid, press Cancel and 
the device is not added to the Devices list.

Removing Passport devices from the restore list
Use this procedure to remove nodes from the list of nodes that you wish to 
backup.

Procedure steps
1 Open the Passport Backup and Restore window.

a. From the Preside MDM window, select Configuration->Passport 
Devices->Administration->Passport Service Data Backup/
Restore.

For more information on this window, refer to “Passport Backup and 
Restore window” (page 52).

2 Select the Restore Configuration tab.

3 In the Device List, select the devices you wish to remove.

4 Click Remove.

5 In the confirmation dialog, select Yes to confirm or No to cancel the 
removal.

Defining a specific userid and password for a Passport 
device in the restore list

A specific userid and password can be defined when you add the device to the 
restore list or you can set it later using the following procedure.

Procedure steps
1 Open the Passport Backup and Restore window.
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a. From the Preside MDM window, select Configuration->Passport 
Devices->Administration->Passport Service Data Backup/
Restore.

For more information on this window, refer to “Passport Backup and 
Restore window” (page 52).

2 Select a device.

3 In the Device Details section, enter a userid and password.

4 Clear the Use default checkbox.

Performing a full restore for a Passport device
Use the following procedure to copy all the files from the repository back to 
the Passport.

Prerequisites
The devices that you restore need to be properly configured in 
Passport/SNMP Devices Backup and Restore. See “Installing and 
configuring backup and restore applications” (page 31).

Procedure steps
1 Verify that the “Prerequisites” (page 93) are satisfied.

2 Open the Passport Backup and Restore window.

a. From the Preside MDM window, select Configuration->Passport 
Devices->Administration->Passport Service Data Backup/
Restore.

For more information on this window, refer to “Passport Backup and 
Restore window” (page 52).

3 Select the Restore Configuration tab.

4 Click Add to open the Add Device dialog.

5 Select a group of devices or expand the group and use the Ctrl key to 
select a number of devices.

6 Select a device from the Device List.

7 Click in the Mode title and select Full from the drop-down list.

8 Click Restore.

9 After a successful restore, you need to activate the restored data. See 
“Activating the restored Passport data” (page 96).
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Performing an incremental restore for a Passport device
Use the following procedure to copy files, based on a specific date, from the 
repository back to the Passport.

Procedure steps
1 Verify that the “Prerequisites” (page 93) are satisfied.

2 Open the Passport Backup and Restore window.

a. From the Preside MDM window, select Configuration->Passport 
Devices->Administration->PassportService Data Backup/
Restore.

For more information on this window, refer to “Passport Backup and 
Restore window” (page 52).

3 Select the Restore Configuration tab.

4 Click Add to open the Add Device dialog.

5 Select a group of devices or expand the group and use the Ctrl key to 
select a number of devices.

6 Select a device from the Device List.

7 Click in the Mode title and select Incremental from the drop-down list.

8 Define a date in the date column. (For example, July 4, 2003)

All the files, with the date and time that are not greater than the specified 
date, will be restored.

9 Click Restore.

10 After a successful restore, you need to activate the restored data. See 
“Activating the restored Passport data” (page 96) and “Activating the 
restored Passport 4400/4460 data” (page 101).

Performing a selective restore for a Passport device
Use the following procedure to copy a specific file from the repository back 
to the Passport.

Procedure steps
1 Verify that the “Prerequisites” (page 93) are satisfied.

2 Open the Passport Backup and Restore window.
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a. From the Preside MDM window, select Configuration->Passport 
Devices->Administration->PassportService Data Backup/
Restore.

For more information on this window, refer to “Passport Backup and 
Restore window” (page 52).

3 Select the Restore Configuration tab.

4 Click Add to open the Add Device dialog.

5 Select a group of devices or expand the group and use the Ctrl key to 
select a number of devices.

6 Select a device from the Device List.

7 Click in the Mode title and select Selective from the drop-down list.

8 In the View column, select the desired view from the repository using the 
drop-down list.

Note:  This step may take a few seconds to complete because the 
application must access the Passport and list all the views names. 

9 Click Restore.

10 After a successful restore, you need to activate the restored data. See 
“Activating the restored Passport data” (page 96).
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Activating the restored Passport data
Passport Restore restores the backup configuration data onto the Passport 
disk. After a successful restore, perform the following procedure to activate 
the restored data.

Procedure steps
1 Establish a telnet session to the Passport.

2 Download to the Passport any required application software missing from 
the Passport disk.

3 Enter provisioning mode.

4 Activate the restored view and confirm the activation.

5 If required, commit the activated view.
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Passport/SNMP service data restore procedures
The following procedures apply to using the Passport/SNMP Service Data 
Backup and Restore tool to perform a restore for Passport 4400 and 4460 
nodes:

• “Changing default information for Passport/SNMP Devices Restore” 
(page 97)

• “Performing a full restore for an SNMP-based device” (page 98)

• “Performing an incremental restore for an SNMP-based device” 
(page 99)

• “Performing a selective restore for an SNMP-based device” (page 100)

• “Activating the restored Passport 4400/4460 data” (page 101)

• “Passport/SNMP Devices Restore window” (page 102)

Changing default information for Passport/SNMP Devices 
Restore

You can change the default information for any device type listed in the main 
window.

Procedure steps
1 Open the Passport/SNMP Devices Backup and Restore window.

a. From the Preside MDM window, select Configuration->Passport 
4400 Devices->Administration->Passport/SNMP Service Data 
Backup/Restore.

For more information on this window, refer to “Passport/SNMP 
Devices Backup and Restore window” (page 61).

2 In the Default Restore Information area of the main window, double-
click on the entry that you need to change.

The Change Default Information dialog opens.

3 Make the required changes.

4 Click OK to save your changes and close the dialog.
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Performing a full restore for an SNMP-based device
A full restore restores all backed up service data to a selected device or 
devices. For Passports, Passport/SNMP Devices Restore restores backed up 
configuration data onto the Passport disk

The Passport 4400/4460 has two memory banks, called bank 3 and bank 4, 
for configuration data. Passport/SNMP Devices Restore restores backed up 
configuration data onto the non-committed bank. 

Prerequisites
The devices that you restore need to be properly configured in 
Passport/SNMP Devices Backup and Restore. See “Modifying the remote 
mapping file” (page 34) and “Configuration required for Passport/SNMP 
Service Data Backup and Restore” (page 39).

Procedure steps
1 Open the Passport/SNMP Devices Backup and Restore window.

a. From the Preside MDM window, select Configuration->Passport 
4400 Devices->Administration->Passport/SNMP Service Data 
Backup/Restore.

For more information on this window, refer to “Passport/SNMP 
Devices Backup and Restore window” (page 61).

2 In the Passport/SNMP Devices Restore window, select only the device or 
devices whose service data you need to restore from the Restore 
Information area of the window. See “Passport/SNMP Devices Restore 
window” (page 102).

The selected devices have a check mark in the Rst column. All other 
devices have no entry in the Restore column.

3 In the Restore Mode Selection area, click full.

4 Click Restore.

When the restore completes successfully, a message is displayed in the 
Message area. If the restore is unsuccessful, an error dialog is displayed 
that specifies the device and the reason for the failure.

5 After a successful restore, you need to make the restored data active. See 
“Activating the restored Passport 4400/4460 data” (page 101).
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Performing an incremental restore for an SNMP-based 
device

An incremental restore restores service data, based on a date that you specify. 
If you do not specify the date, an incremental restore is the same as a full 
restore. 

Prerequisites
The devices that you restore need to be properly configured in 
Passport/SNMP Devices Backup and Restore. See “Modifying the remote 
mapping file” (page 34) and “Configuration required for Passport/SNMP 
Service Data Backup and Restore” (page 39).

Procedure steps
1 Open the Passport/SNMP Devices Backup and Restore window.

a. From the Preside MDM window, select Configuration->Passport 
4400 Devices->Administration->Passport/SNMP Service Data 
Backup/Restore.

For more information on this window, refer to “Passport/SNMP 
Devices Backup and Restore window” (page 61).

2 In the Passport/SNMP Devices Restore window, select only the device or 
devices whose service data you need to restore from the Restore 
Information area of the window. See “Passport/SNMP Devices Backup 
and Restore window” (page 61).

The selected devices have a check mark in the Rst column. All other 
devices have no entry in the Restore column.

3 In the Restore Mode Selection area, click incr.

4 In the Restore Mode Selection area, fill in the Date field. The restore 
process restores the service data that was backed up on that date. If no 
backup exists for that date, the restore process restores the service data 
that was backed up closest to, but not exceeding, that date.

5 Click Restore.

When the restore completes successfully, a message is displayed in the 
Message area. If the restore is unsuccessful, an error dialog is displayed 
that specifies the device and the reason for the failure.

6 After a successful restore, you need to make the restored data active. See 
“Activating the restored Passport data” (page 96) and “Activating the 
restored Passport 4400/4460 data” (page 101).
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Performing a selective restore for an SNMP-based device
A selective restore restores only the service data that you select.

Prerequisites
The devices that you restore need to be properly configured in 
Passport/SNMP Devices Backup and Restore. See “Modifying the remote 
mapping file” (page 34) and “Configuration required for Passport/SNMP 
Service Data Backup and Restore” (page 39).

Procedure steps
1 Open the Passport/SNMP Devices Backup and Restore window.

a. From the Preside MDM window, select Configuration->Passport 
4400 Devices->Administration->Passport/SNMP Service Data 
Backup/Restore.

For more information on this window, refer to “Passport/SNMP 
Devices Backup and Restore window” (page 61).

2 In the Passport/SNMP Devices Restore window, select only the device or 
devices whose service data you need to restore from the Restore 
Information area of the window. See “Passport/SNMP Devices Backup 
and Restore window” (page 61).

The selected devices have a check mark in the Rst column. All other 
devices have no entry in the Restore column.

3 In the Restore Mode Selection area, click sel.

The List Views button is enabled.

4 Click the List Views button and select the required view file. You can 
display selected view files by using the Filter data entry field and pressing 
<return>.

OR

Enter the name of the required view file in the sel data entry field and 
press <return>.

The view file name is displayed in the sel data entry field and in the View 
column of the Restore Information area.

5 Click Restore.
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When the restore completes successfully, a message is displayed in the 
Message area. If the restore is unsuccessful, an error dialog is displayed 
that specifies the device and the reason for the failure.

6 After a successful restore, you need to make the restored data active. See 
“Activating the restored Passport data” (page 96) and “Activating the 
restored Passport 4400/4460 data” (page 101).

Activating the restored Passport 4400/4460 data
Passport/SNMP Devices Restore restores the backup configuration data onto 
the non-committed bank of the Passport 4400/4460. After a successful 
restore, perform the following procedure to activate the restored data.

Procedure steps
1 Establish a connection to the Passport 4400/4460 through the serial 

console port. Alternatively, you can start a telnet session if there is IP 
connectivity between the Passport 4400/4460 and the workstation.

2 Verify the status of the restore by entering the following CLI (command 
line interface) command:

show tftp error

The response should be: 

LastOperStatus : <status>
ServerIPAddr : <x.x.x.x>
FileName : <filename>
TransferBank : toBank<3|4>
PortNumber : <xxx>

3 Confirm that the LastOperStatus variable indicates a successful 
download. The value of TransferBank indicates to which bank the 
configuration data was restored.

4 Set the active configuration bank to the bank to where the configuration 
data was restored by entering the CLI command:

set system firmware activeConfigBank bank<x>

where <x> is the bank to which the configuration data was restored.

5 Reset the Passport 4400/4460 by entering the CLI command:

reset system current reset

The configuration takes effect once the Passport 4400/4460 has 
completed boot up.
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Passport/SNMP Devices Restore window
The Passport/SNMP Devices Restore window displays relevant restore 
information and provides fields that let you select the type of information to 
restore. The window also contains a message area that displays status 
information while the restore process executes.

The figure “Passport/SNMP Devices Restore window” (page 102) shows 
sample restore window.

Figure 12
Passport/SNMP Devices Restore window
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The Passport/SNMP Devices Restore window consists of the following 
components:

• “Default Restore Information area” (page 103)

• “Controller Information area” (page 103)

• “Restore Information area” (page 104)

• “Restore Mode Selection area” (page 105)

• “Message area” (page 106)

• “Command buttons” (page 106)

Default Restore Information area
The Default Restore Information area contains connection information. There 
is an entry for each different device type in the device information file. Each 
device type that is listed in this area can have the following entries:

• DevType is the device type.

• id (rd community) is the userID for a Passport and the READ community 
string for a Passport 4400/4460.

This field is displayed as a series of asterisks (*). 

• pw (wr community) is the user password for a Passport and the WRITE 
community string for a Passport 4400/4460. 

This field is displayed as a series of asterisks (*).

• Port is the port number of the device.

You can edit any line in this area by double-clicking on it. This action opens 
the Change Default Information dialog. For more information about changing 
the default information, see “Changing default information for Passport/
SNMP Devices Restore” (page 97).

Controller Information area
The Controller Information area displays the information from the Change 
Restore Options dialog. 
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Restore Information area
The Restore Information area contains details on each device available for 
restore. Click on a line in this area to edit it. Make your changes by editing 
other fields on the main window.

Each device has the following entries:

• DevName is the device name.

• id (rd community) is the userID for a Passport and the READ community 
string for a Passport 4400/4460.

This field is displayed as a series of asterisks (*). 

When present, this field overrides the corresponding field in the Default 
Restore Information area.You can edit this field in the id (rd community) 
data entry field immediately below the Restore Information area. A 
restore fails when the device has no id (rd community).

• pw (wr community) is the user password for a Passport and the WRITE 
community string for a Passport 4400/4460. 

This field is displayed as a series of asterisks (*). 

When present, this field overrides the corresponding field in the Default 
Restore Information area. You can edit this field in the pw (wr 
community) data entry field immediately below the Restore Information 
area. A restore fails when the device has no pw (wr community).

• A check mark in the Rst field indicates that this device is to have service 
data restored. You can select and deselect any device by double-clicking 
the line containing the device name.

• Mode indicates the type of restore (full, incremental, or selective). You 
can change this field by clicking the appropriate button in the Restore 
Mode Selection area.

• View is the view being restored by a selective backup. Clicking the sel 
button in the Restore Mode Selection area activates the View and List 
Views fields. You can choose a view file from List Views by double-
clicking on an entry or you can enter a view file name in the View data 
entry field and press Return.
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Restore Mode Selection area
The Restore Mode Selection area contains information about the types of 
restores you can perform.When you edit the fields in this area, you change the 
Mode and View fields of the device that is highlighted in the Restore 
Information area.

This area contains the following fields:

• incr indicates an incremental restore.

• the Date data entry field is an option for an incremental restore. You 
enter a date with the format yyyymmdd to have Passport/SNMP Devices 
Restore restore the service data backed up on that date. You can specify 
the time with format yyyymmddhhmmss.

When there are no backups for the date specified, Passport/SNMP 
Devices Restore restores the service data backed up on the date closest 
to, but not exceeding, the specified date. If there is more than one backup 
for the specified date and you have not specified the time, 
Passport/SNMP Devices Restore restores the latest backup on the 
specified date. If you do not use this field, the incremental restore is the 
same as a full restore.

• full indicates a full restore.

• sel indicates a selective restore.

• the sel data entry field is where you enter the name of the view file that 
you want to restore. The file entered in this field updates the View field 
in the Restore Information area.

• List Views button lists the view files that are available for selective 
restore. You select a file in this list by double-clicking on an entry. 
Selection of a view from the List Views window updates the contents of 
the View data entry field and the View field in the Restore Information 
area. The List Views button is enabled only when you select the sel 
button.

• the Filter data entry field specifies a search criteria for view files.You 
can match any string of any length by using the wildcard character (*).

Note: The question mark (?) does not function as a wildcard in the Filter 
field. For example, MM?[ab] returns only the view MM?[ab], if it exists. 
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Message area
The Message area displays messages generated by Passport/SNMP Devices 
Restore during execution.

Command buttons
The Passport/SNMP Devices Restore window contains the following 
command buttons:

• Restore
The Restore button starts the restore process.

• Cancel
The Cancel button terminates an executing restore. Completed restores 
are kept; restores in progress, or not started, are cancelled.

• Exit
The Exit button closes the Passport/SNMP Devices Restore window.

• Help
The Help button displays online documentation describing the Passport/
SNMP Devices Restore window.

Change Default Information dialog
The Change Default Information dialog is the only Passport/SNMP Devices 
Restore dialog other than the main window. You can use this dialog to change 
the information contained in the Default Restore Information area of the main 
window. For more information about the Default Restore Information area, 
see “Restore Information area” (page 104).

The figure “Change Default Information dialog” (page 107) shows an 
example of the Change Default Information dialog.
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Figure 13
Change Default Information dialog
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Chapter 6
Current Configuration Backup and Database 
Synchronization

This section describes how to use Passport Service Data Backup and Restore 
to perform a backup of a Passport 6000, 7000, 15000, and 20000 current 
configuration. This functionality is used for Node Recovery as well as to 
enable backup capability for Passport view and journal files. It supports the 
database synchronization mechanisms to ensure that the MDM 
Administration Database is updated with the latest configuration.

Overview
In this Backup mode, the Backup Server retrieves the most current 
configuration of the switch. A current configuration is the combination of the 
committed configuration and activations that have occurred on that switch. It 
is not possible in all cases to retrieve all of the current configuration.

In the case where on-switch journaling is enabled, the Backup Server 
retrieves the journal files and the committed configuration of the switch. In 
other words, the current configuration is completely backed up to the MDM. 
In addition, the complete current configuration can be synchronized with the 
Administration Database.

However, if journaling is not enabled/available, it is not possible to obtain a 
complete current view. If a user has performed provisioning and activations 
on the switch without saving, then only the committed view can be backed up 
on the MDM. The activations will not be backed up to the MDM, until they 
are saved, activated and a "confirm prov" command has been performed.
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Once the Backup Server retrieves the most current view and journal log files 
from the Passports, and completes their storage to a local disk, it notifies the 
Data Synchronization Server and passes it the view and journal information. 
These notifications trigger the synchronization process.

The Data Synchronization Server compares the view and journal information 
that it receives from the Backup Server with the contents of the view and 
journal information contained in the database to determine if the database is 
synchronized. If the database is not synchronized with this information, the 
Data Synchronization Server initiates the translation of the missing views and 
journals into database compatible format. 

The Data Synchronization Administration tool is used to view 
synchronization activities and basic status information, based on information 
provided by the Data Synchronization Server.

The "confirm prov" command is extremely important in cases where 
journaling is not enabled/available.

For detailed configuration options, see “Configuring the Backup Server for 
current configuration backup” (page 112).

Perform the following procedures to implement current configuration 
backups for your system:

• “Modifying the Backup Server command line” (page 111)

• “Configuring the Backup Server for current configuration backup” 
(page 112)

• “Performing a Current Configuration Backup” (page 122)
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Modifying the Backup Server command line
To support the Current Configuration backup and database synchronization, 
and to configure the maximum number of parallel backups, you must add 
options to the command line for the Backup Server.

Procedure Steps
1 Open the Server Administration tool and perform authorization. For more 

information, refer to 241-6001-303 Preside MDM Administrator Guide.

2 Select Backup Controller from the Server list.

3 Right click to select Edit Server.

The SVM Edit Server window displays.

4 In the Startup command field, add the following options to the command 
line.

/opt/MagellanNMS/bin/nsctlbck - notification -nbofbck 
<#>

where:

The -nbofbck <#>, where # is the maximum number of backups, limits the 
number of backups that can be performed in parallel. This option can only 
be used with the -notification option for backup on alarm or on demand; 
this option cannot be used for a basic backup. The default # is 5. Backup 
requests coming after the maximum number are queued in a waiting 
queue and are transferred to the executing queue if the executing queue 
is not full. That is, it has less than the maximum number of parallel 
backups, as specified in the nbofbck <#> option of the Backup Server 
command line. By limiting the number of simultaneous backups, you 
reduce congestion problems that may occur with a large number of 
backups. It is recommended that the default be left at 5, unless 
engineering information is available.

-notification option, when included, allows the system to perform current 
configuration backups. 

Any changes you make to the server startup command take effect when the 
server is restarted. For instructions on how to use the Server Administration 
tool, see the 241-6001-303 Preside MDM Administrator Guide.
Preside MDM Passport/SNMP Devices Backup and Restore User Guide   14.3RSUP



112   Chapter 6 Current Configuration Backup and Database Synchronization
Note: The Backup Controller is known as the Backup Server when the -
notification option is specified. For example:

/opt/MagellanNMS/bin/pbckpp
/opt/MagellanNMS/bin/nsctlbck -notification

Configuring the Backup Server for current configuration 
backup

There are two options for configuring your system. These options are defined 
in the configuration file:

• On Alarm with journaling supported uses alarm notification for 
configuration changes from the device to trigger the backup of Passport 
view and journal files. The database can then be synchronized using this 
information. This mode can be used for near-real-time synchronization 
of both backup and database information.

On Alarm for complete view (with journaling not supported) is used 
for pre-PCR 5.1 releases. In this case, a complete configuration file is 
transferred for each provisioning confirmation done on each Passport. 
This may cause engineering issues in terms of OAM network and 
workstation capacity, and is not recommended.

The On Alarm option requires that the Backup Server be configured to 
listen to a particular GMDR server, which provides the notification based 
on the alarm information from the node. Without the GMDR server, the 
Backup Server cannot receive the real-time notification of the 
provisioning changes. If the GMDR runs on a different host than the 
Backup Server, you can specify this. See “Interface with GMDR” 
(page 122) for more information.

CAUTION
Starting the Backup Controller
The Backup Provider must be started before the Backup 
Controller (Backup Server) when using the -notification 
option. The Backup Controller is known as the Backup 
Server when the -notification option is specified. See 
“Current Configuration Backup and Database 
Synchronization” (page 109).
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• On Demand uses a command line trigger to backup Passport views and 
journals. This command line trigger can also be used in a cron job to 
provide a scheduled backup and database capability. If journaling is not 
supported or enabled, the operator must ensure that a save, activate, and 
“confirm prov” has been done to ensure availability of the current view.

The devices to be backed up must be specified in a user configuration file. 
This configuration file also determines if backups are on_demand, and if 
database synchronization should be done. For more information, see the 
following sections:

• “Modifying the Data Synchronization configuration file for a Current 
Configuration Backup” (page 113)

• “Defining the default backup group for Passport devices” (page 114)

• “Adding a backup group” (page 115)

• “Removing a backup group” (page 117)

• “Backup site directory structure” (page 120)

• “Interface with GMDR” (page 122)

Modifying the Data Synchronization configuration file for a 
Current Configuration Backup

Backups are performed on the list of Passport devices specified in a user 
configuration file on the MDM. The configuration file is stored under

/opt/MagellanNMS/cfg/DataSync.cfg

All backup groups must be defined in the HGDS server using the Host Group 
Administration tool. For more information, refer to 241-6001-303 Preside 
MDM Administrator Guide. 

The Backup Server and the Database Synchronization server share the 
DataSync.cfg file. This file contains the list of devices with their userids and 
passwords, as well as additional fields for each devices.

For security reasons, passwords can be encrypted in a separate file in which 
case the full path of the file containing the encrypted password replaces the 
password field in the DataSync.cfg file. MDM provides a tool to encrypt a 
password, and save it in a separate file, /opt/MagellanNMS/bin passwd_gen. 
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This tool must be run as root. For the procedures to generate a secure 
password for an MDM server, and how to change a secure password, refer to 
NN10600-605 Passport - MDM Network Security: Operations. 

Defining the default backup group for Passport devices
The default group options can be used for any backup group that you add. 
You must verify that the values in the default group options are acceptable for 
your system. Use the following procedure:

Procedure steps
1 Start the Server Administration tool.

For more information, refer to 241-6001-303 Preside MDM Administrator 
Guide.

2 In the Server Administration window, select the Backup Controller.

3 Right click to select Edit Configuration and then Backup Server.

The Configuration Editor displays. For information on the displayed 
parameters, refer to “Supporting information for configuring Passport 
Current Configuration Backup and Recovery” (page 117).

4 Expand the Default group element.

5 Select Authentication and 

a. enter the appropriate username,

b. enter the password 

OR

set the usePassword File to True and enter the location of the 
password file in the passwordFileName field.

6 Verify that the values in the Backup and DBSynch elements are 
appropriate.

7 From the File menu, select Save.
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Adding a backup group
Define a set of Passport devices as part of a group that will be backed up 
together at the same time in the same manner. Specify the manner in which 
this group is backed up.

Note: If you do not define the values of the backup group, the system 
uses the values defined in the default backup group.

Procedure steps
1 Define a group in the HGDS system using the Host Group Administration 

tool. For more information on adding groups, refer to 241-6001-303 
Preside MDM Administrator Guide.

Note 1:  If the Backup Controller is already running, you must run the 
Passport kick script. This script is used to update the HGDS, FDTM and 
FMDR servers with the new information, without having to restart the 
servers.

Note 2:  An existing group can be used. It does not have to be defined as 
a backup group.

2 Start the Server Administration tool.

For more information, refer to 241-6001-303 Preside MDM Administrator 
Guide.

3 In the Server Administration window, select the Backup Controller.

4 Right click to select Edit Configuration and then Backup Server.

The Configuration Editor displays. For information on the displayed 
parameters, refer to “Supporting information for configuring Passport 
Current Configuration Backup and Recovery” (page 117).

5 Select the BackupServer element.

6 Right click and select Add Element.

The Add Element dialog displays.

7 Verify that Group is selected and click OK.

8 Select the New Group element.

9 Enter the Group name.

10 Verify that the enabled field is set to True. 
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Note:  At this point, you can accept the values that you defined for the 
default backup group by selecting Save from the File menu which 
completes this procedure or you can specify new options using step 11 
through step 19.

11 Select your new group from the element tree.

12 Right click to select Add Element.

13 In the Add Element dialog, select Authentication and click OK.

14 Repeat step 12 and step 13, selecting BackupOptions and 
DBSynchOptions.

At this point, your new group has three subelements (Authentication, 
BackupOptions and DBSynchOptions).

15 Click on the group element to expand it.

16 Select Authentication and 

a. enter the appropriate username,

b. enter the password 

OR

set the usePassword File to True and enter the location of the 
password file in the passwordFileName field.

17 Select the BackupOptions element and verify that onAlarm is set to True 
if you wish backups to be performed on alarm.

Note that you do not have to select this option at this time. You can set 
this option later using the Backup and Restore tool. For more information, 
refer to “Modifying the Data Synchronization configuration file for a 
Current Configuration Backup” (page 113).

18 Select DBSyncOptions and

a. Verify that enabled is set to True if you wish to send a notification to 
the Data Sync server and have the database updated whenever a 
backup is performed.

b. Enter the name of the DBSyncController in the server field. Note that 
if you leave the server field blank, the system defaults to localhost.

19 Select Save from the File menu.
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Removing a backup group
If a group no longer requires backing up, you can remove it from the 
DataSync.cfg file.

Procedure steps
1 Start the Server Administration tool.

For more information, refer to 241-6001-303 Preside MDM Administrator 
Guide.

2 In the Server Administration window, select Backup Controller.

3 Right click to select Edit Configuration and then Backup Server.

The Configuration Editor displays. For more information, refer to 
“Configuration Editor window” (page 118).

4 Select the group you wish to remove.

5 Right click to select Remove Element.

6 In the Confirmation dialog, select Yes.

7 If the group was specific to the backup system and is no longer needed, 
remove it using the Host Group Administration tool. For more information 
on removing groups, refer to 241-6001-303 Preside MDM Administrator 
Guide.

Supporting information for configuring Passport Current 
Configuration Backup and Recovery

Passport Backup and Restore uses the data synchronization file to display the 
devices that you can back up and restore.You need to include an entry for 
every device that Passport Backup and Restore can access on the host 
machine.

If you have Passport Backup and Restore software on multiple hosts, it is 
recommended that you duplicate the entries in the data synchronization file. 

Note: The DBSyncController name must be identical to the DBSync 
name value. For more information on configuring the 
DBSyncController, refer to 241-6001-400 Preside MDM Administration 
Database User Guide.
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For more information, refer to:

• “Configuration Editor window” (page 118)

• “Data Synchronization file parameters” (page 118)

• “How the Backup Server works” (page 119)

Configuration Editor window
The Configuration Editor allows you to edit the DataSync.cfg file. You can 
launch the Configuration Editor from Server Administration Tool.

The editor has two panes. The left pane displays the symbol for the server 
which can be expanded to display a tree hierarchy which lists all the devices 
or groups of devices. Each device or group element can be expanded to 
display three parameter categories. The right pane displays the parameters 
contained in the selected category. 

Data Synchronization file parameters
The following table describes each of the backup and restore-related fields 
contained in the DataSync.cfg file.

Table 2
Data Synchronization file parameters for Backup Server

Category Field Description Default

BackupServer port Option to specify the Backup 
server port, to communicate with.

5050

dataDir Option to specify the backup data 
directory where the views and/or 
journals are stored. 

/opt/Magellan/
NMS/data/
Backup_Data

Authentication username Username to access device

 password Password to access device

usePasswordFile Determines if a password file is 
used for access to the account

false

 passwordFile Path to the file that contains an 
encrypted password

 (Sheet 1 of 2)
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How the Backup Server works
When the Backup Server is started with the -notification option, it initiates a 
backup for the devices that have On_Alarm set to True, whenever it receives 
a commit, confirm, reset or node reconnect alarm. The following information 
is obtained from the Passport:

• committed view name

• number of journals

• current view name

• journalDisabledReason attribute

• restorePossible attribute

• activation time = (in this case, activation time is the d prov time of the 
last journal backup)

This information is stored in the recovery.INFO file. The Backup Server 
compares this information with what has already been backed up and then 
transfers the necessary view and journal files.

BackupOptions onAlarm Determines if the devices in the 
group are backed up when the 
sever receives a configuration 
event from a device

true

DBSync Options enabled Determines if a dbsynchcontroller 
is notified when the device is 
backed up true

true

 server Name of the server to notify when 
a device is backed up

Table 2
Data Synchronization file parameters for Backup Server (continued)

Category Field Description Default

 (Sheet 2 of 2)
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When journaling is not enabled, the Passport sends only Confirm and Node 
Reconnect alarms. When the Backup Server receives the Confirm and Node 
Reconnect alarms, it recovers the current view from the Passport. The 
customer must save, activate, and confirm prov to ensure that a current view 
is available.

In this case, the current view has a valid name. The Backup Server checks if 
it already has the backed up file, and if not, it transfers the file to the backup 
site. There are no journals to be transferred.

To trigger a backup of all the Passports simultaneously, you can edit the 
DataSync.cfg file to give all the Passport nodes the same group label and 
execute the command /opt/MagellanNMS/bin/nsbck -demand without 
specifying a group. Note that this is not recommended due to possible 
engineering and performance impacts. The maximum number of Passports in 
a group is 50.

The actual FTP backup session is performed the same as an FTP backup 
triggered by an alarm with On Alarm. 

Backup site directory structure
The journal files are stored by the Backup tool in a subdirectory of the view 
they are associated with. If a new set of journal log files is created for the 
same view, another journal directory is created.

The naming convention for the journal directories is <timestamp>journal. 
The timestamp comes from the Passport file system and is the creation date 
of the file.

/provisioning/journal/current/journalView

This directory is created with the first journal log file.

The following files are also created on the backup site:

• “view.INFO file” (page 121)

• “recovery.INFO file” (page 121)

• “avl.INFO file” (page 121)
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view.INFO file
A view.INFO file is created on the Backup site for each view. This file 
contains the name of the base view as stored on the Backup site, and enables 
the association of the proper base view to a delta view. For each backup or 
restore, the tool checks if the base view is on the Backup site. If not, it will 
backup or restore it. The base view is a portable or complete view.

The format of the file is as follows:

BASE_NAME <timestamp>.<viewname>

For example:
BASE_NAME 200301261812228.view1.full.001

The view.INFO file is located on the backup site with the view. For example, 
a named view1.full.001 on a Passport NODE1 is found at the following 
location:

/opt/MagellanNMS/data/Backup_Data/Passport/NODE1/
200301261812228.view1.full.001/view.INFO

recovery.INFO file
A recovery.INFO file is also generated during each backup. This file contains 
the committed view name, the current view name, the journal directory name, 
the number of journal files, and two values: restorePossible and journalStatus. 
These two values come from the switch at the time when the backup was 
done. When a Node Recovery is performed, it reads this recovery.INFO file 
in order to restore the needed information. 

avl.INFO file
The recovery.INFO file and the avl.INFO file are MDM-specific files and are 
created by the Backup Server during a backup. These files do not exist on the 
Passport and are used by the Node Recovery tool to recover a Passport node 
on a replacement Passport. When a node is recovered, the software that is 
being run must be downloaded to the replacement Passport. Therefore, each 
backup must also contain the current AV list. This information is stored in a 
new file called avl.INFO.
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Interface with GMDR
The GMDR process must be available whenever an On_Alarm backup must 
occur. The GMDR process ensures that the Backup Server is notified of a 
provisioning change on the Passport.

GMDR sends alarms to the Backup Server when a notification alarm is 
received from the Passport. If GMDR runs on a different host than the Backup 
Server, you can specify the GMDR host with the option -gmdrhost as follows:

/opt/MagellanNMS/bin/nsctlbck -notification -gmdrhost 
<hostname>

Performing a Current Configuration Backup
Use this procedure to perform a Current Configuration Backup of a group of 
devices. 

Prerequisites
The devices that you restore need to be properly configured. See “Installing 
and configuring backup and restore applications” (page 31).

Procedure steps
1 Open the Passport Backup and Restore window.

a. From the Preside MDM window, select Configuration->Passport 
Devices->Administration->Passport Service Data Backup/
Restore.

For more information on this window, refer to “Passport Backup and 
Restore window” (page 52).

2 Select Tools -> Backup Current Configuration.

The Backup Current Configuration window displays.

3 Click Add.

The Add Group window displays.

4 Select one group or select a number of groups using the Ctrl key.

5 Click OK.

The Groups you wish to backup are displayed in the Group List.

6 Click Backup.
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If the backup request is successfully scheduled, the Messages pane 
indicates that the process has started. Note, however, that this type of 
backup is scheduled as background activity and does not provide updates 
to the Messages pane. 

7 View the Backup Status of all current configuration backups by selecting 
Tools->Show Server Log from the menu bar.

A window displays a snapshot of the end of the server log. To refresh the 
text in this window, close the window by pressing the Cancel button and 
re-selecting Tools->Show Server Log from the menu bar.
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Chapter 7
Current Configuration Recovery

This section describes using Passport Service Data Backup and Restore to 
perform current configuration recovery for Passport 6000, 7000, 15000, and 
20000 nodes. 

Note: For information on backing up views/journals for Recovery, see 
“Current Configuration Backup and Database Synchronization” 
(page 109).

A Passport Devices Recovery recovers the committed configuration of the 
Passport, its journal log files, and downloads the recent software, and restores 
them to a replacement Passport.

Prerequisites

CAUTION
Files will be overwritten
Before reconnecting a replacement Passport to the 
network, edit the DataSync.cfg file to turn off backup on 
alarm for the device, and then restart the Backup Server. 
See “Modifying the Data Synchronization configuration 
file for a Current Configuration Backup” (page 113). This 
step prevents the Backup Server from being triggered by a 
reconnect alarm, which would back up this device and 
overwrite the recovery.info and avl. info files.
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Before proceeding with this procedure, ensure that the Backup Server has 
been configured properly. See “Configuring the Backup Server for current 
configuration backup” (page 112) and “Modifying the Backup Server 
command line” (page 111).

When you are recovering a mix of devices, you must recover all Passport 
7000s (specifying the Passport 7000 software distribution site) in one 
procedure. Then, you must repeat the procedure for the Passport 15000 
(specifying the Passport 15000 software distribution site) to recover those 
nodes. The software distribution site is different for the Passport 7000s and 
Passport 15000s.

For more information, refer to:

• “Defining the Software Distribution Site for a Passport node recovery” 
(page 126)

• “Performing a Current Configuration Device Recovery” (page 127)

Defining the Software Distribution Site for a Passport node 
recovery

Use this procedure to define the software distribution site to be used in Node 
Recovery.

1 Open the Passport Backup and Restore window.

a. From the Preside MDM window, select Configuration->Passport 
Devices->Administration->Passport Service Data Backup/
Restore.

For more information on this window, refer to “Passport Backup and 
Restore window” (page 52).

2 In the Passport Backup and Restore window, select Set Software 
Distribution Site from the Options menu.

The Software Distribution Site dialog displays.

3 In the appropriate fields, enter the IP host name, userid and password of 
the Software Distribution Site.

4 Click OK.
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Performing a Current Configuration Device Recovery
Procedure steps

1 Verify that the “Prerequisites” (page 125) are satisfied.

2 Open the Passport Backup and Restore window.

a. From the Preside MDM window, select Configuration->Passport 
Devices->Administration->PassportService Data Backup/
Restore.

For more information on this window, refer to “Passport Backup and 
Restore window” (page 52).

3 Select the Recover Device tab.

4 Click Add to open the Add Device dialog.

Note:  The Add Device dialog displays only devices that have a 
recovery.info file. Only those devices that have had a current 
configuration backup have a recovery.info file.

5 Select a group of devices or expand the group and use the Ctrl key to 
select a number of devices.

6 Select the Use default box to use the default password or enter the user 
ID and Password.

7 Click OK.

The devices are displayed in the Device List.

8 Select the devices(s) on which to perform the Node Recovery. 

The date column displays the date of the last current view backup. The 
view column displays the name of the committed view. The software 
column displays the software version active at the time.

You can view the last journal number and the journal status of a device by 
selecting the Configuration Information tab in Device Details. The 
Application Versions tab displays the software application version that 
was used for this configuration.

9 Click Recover.

You can cancel the recovery process by clicking Cancel.
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