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About this document

This guide describes how to setup and use Preside MDM Passport Service 
Data Backup and Restore for Passport 6000, 7400, 15000, and 20000 nodes 
and Preside MDM Passport/SNMP Backup and Restore for Passport 4400 
and 4460 nodes.

Note: In this document, Passport refers to Passport Multiservice switches 
(6000, 7400, 15000 and 20000); Passport/SNMP refers to Passport 4400 
and Passport 4460).

The following topics are discussed in this section:

• “Who should read this document and why” (page 13)

• “What you need to know” (page 14)

• “How this document is organized” (page 14)

• “What’s new in this document” (page 14)

• “What’s new in this document” (page 15)

• “Text conventions” (page 15)

• “Related documents” (page 17)

Who should read this document and why
You should read this document if you are responsible for using Preside MDM 
to backup and restore the service data for Passport Multiservice switches and 
Passport 4400 and 4460 SNMP devices.
Preside MDM Network Backup and Restore User Guide   15.1RSUP



14   About this document
What you need to know
You should be familiar with the configuration and service data storage on the 
switch types that you are responsible for maintaining. You should also have a 
working knowledge of Preside Multiservice Data Manager (MDM).

How this document is organized
The information in this guide is organized as follows:

• “Service Data Backup/Restore setup” (page 19) describes how to set up 
the Backup and Restore Controllers and Providers.

• “Basic service data backup” (page 47) describes how to back up service 
data.

• “Basic service data restore” (page 69) describes how to restore service 
data.

• “Current Configuration Backup” (page 87) describes how to backup the 
current configuration for Passport 6000, 7400, 15000, and 20000 
devices.

• “Current Configuration Recovery” (page 99) describes how to recover 
service data when a Passport fails or is destroyed.

• “Fundamentals of Preside MDM Backup and Restore” (page 103) 
describes how the Preside MDM Backup and Restore application 
functions and provides installation and configuration instructions.

• “Passport Service Data Backup/Restore tool” (page 127) describes the 
tool GUI.

• “Passport/SNMP Service Data Backup/Restore tool” (page 133) 
describes the tool GUI.

What’s new in this document
This document has been restructured based on the Nortel Networks Modular 
Task Based Information (MTBI) format. The conceptual information about 
the MDM backup and restore fundamental and the Backup/Restore GUIs 
have been moved to the end of the NTP and the procedural information moved 
to the start of the NTP. This is to facilitate user access to the task based 
information that supports on-the-job activities.
241-6001-807   15.1RSUP   
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What’s new in this document
The document has been restructured as part of the first phase of the transition 
to Modular Task-Based Information. In addition, the following feature 
updates were added to this document:

• “MDM Database Synchronization Support” (page 15)

• “Passport Service Data Backup/Restore GUI” (page 15)

MDM Database Synchronization Support
This document has been updated to include the following enhancements for 
Database Synchronization, Backup and Restore logging:

• “Backup and Restore logs” (page 125)

Passport Service Data Backup/Restore GUI
The Passport Service Data Backup/Restore GUI has been modified in the 
following ways:

• Passport Service Data Backup/Restore tool distinct from Passport/SNMP 
Service Data Backup/Restore tool. Passport Service Data Backup/
Restore tool compatible only with Passport 6000, 7400, 15000, and 
20000 devices.

•  Passport Service Data Backup/Restore tool provides capability of 
backing up current configuration

Text conventions
This document uses the following text conventions: 

• nonproportional spaced plain type

Nonproportional spaced plain type represents system generated text or 
text that appears on your screen.

• nonproportional spaced bold type

Nonproportional spaced bold type represents words that you should type 
or that you should select on the screen.
Preside MDM Network Backup and Restore User Guide   15.1RSUP
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• italics

Statements that appear in italics in a procedure explain the results of a 
particular step and appear immediately following the step.

Words that appear in italics in text are for naming.

• [optional_parameter]

Words in square brackets represent optional parameters. The command 
can be entered with or without the words in the square brackets.

• <general_term>

Words in angle brackets represent variables which are to be replaced with 
specific values.

• UPPERCASE,lowercase

In Preside Multiservice Data Manager (MDM), uppercase and lowercase 
letters that appear in UNIX commands and parameters must be matched 
exactly. The system matches upper and lowercase characters differently.

• |

This symbol separates items from which you may select one; for 
example, ON|OFF indicates that you may specify ON or OFF. If you do 
not make a choice, a default ON is assumed.

• ...

Three dots in a command indicate that the parameter may be repeated 
more than once in succession.

The term absolute pathname refers to the full specification of a path starting 
from the root directory. Absolute pathnames always begin with the slash ( / )
symbol. A relative pathname takes the current directory as its starting point, 
and starts with any alphanumeric character (other than /).
241-6001-807   15.1RSUP   



About this document   17
Related documents
See the following documents for related information:

General
241-6001-102 Preside MDM Planning Guide
241-6001-303 Preside MDM Administrator Guide
241-6001-400 Preside MDM Administration Database User Guide
241-6001-310 Preside MDM Server Reference Guide

Passport 6000
For a list of documents, see 241-6401-001 Passport 6400 Documentation 
Guide.

Passport 7400/15000/20000
For a list of documents, see NN10600-001 Nortel Networks Multiservice 
Switch 7400/15000/20000 Basics: Customer Documentation.

Passport 4400
Passport 4400 Hardware Installation Manual
Passport 4400 Operators Manual
Passport 4400 CLI Reference for the Command Line Interface
Preside MDM Network Backup and Restore User Guide   15.1RSUP
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Chapter 1
Service Data Backup/Restore setup

This section describes the setup required to enable the use of the Passport and 
Passport/SNMP Service Data Backup/Restore applications. 

Navigation
• “Prerequisites to Service Data Backup/Restore setup” (page 19)

• “Passport Service Data Backup/Restore setup” (page 20)

• “Passport/SNMP Service Data Backup/Restore setup” (page 28)

• “Additional configuration for Passport and Passport/SNMP backup and 
restore” (page 36)

• “Additional configuration for Passport/SNMP backup and restore” 
(page 39)

Prerequisites to Service Data Backup/Restore setup

ATTENTION If the Provider is not running on the same machine as the 
Controller, or if you want to use more than one Provider to 
share the load, the remote mapping file must modified. For 
more information, see “Modifying the remote mapping file 
(optional)” (page 37)
Preside MDM Network Backup and Restore User Guide   15.1RSUP
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Passport Service Data Backup/Restore setup
The task flow shows you the sequence of procedures you perform to setup the 
Passport Service Data Backup/Restore tool. To link to any procedure in this 
document, double-click on the procedure name in the task flow or in the list.

Figure 1
Task flow for setting up Passport Service Data Backup/Restore applications

Starting the Passport 
backup and restore 

servers

Setting the default 
account used to 
access a device

Specifying the location of the Data 
Synchronization server

END

Passport Service Data 
Backup/Restore setup

Configuring the Data 
Synchronization server

Modifying the Data 
Synchronization configuration file 
for a Current Configuration Backup
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Passport Service Data Backup/Restore setup procedure 
navigation

• “Starting the Passport backup and restore servers” (page 22).

• “Setting the default account used to access a device” (page 24).

• “Specifying the location of the Data Synchronization server” (page 25).

• “Configuring the Data Synchronization server” (page 26)

• “Modifying the Data Synchronization configuration file for a Current 
Configuration Backup” (page 27)
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Starting the Passport backup and restore servers
Use this procedure to start the servers or to add options. 

Prerequisites
• Launch the Server Administration tool:  System -> Administration -> 

Server Administration.

• If you are adding options to a server that is already running, you must 
stop the server before you add the option.

Procedure steps
1 From the Security menu, select the Authorize command.

2 In the SVM Enter Authorization Password dialog box, type a valid 
password and click OK.

3 From the Edit menu, select Edit -> New server.

The SVM New Server Selection displays.

4 Expand the Configuration Server category to find the server in the list.

5 Select the server and click Select Server.

The SVM Edit Server opens with the startup command displayed.

6 Optionally, edit the Startup command to add the option(s):

/opt/MagellanNMS/bin/<server_name> [-<option> <option 
value>]

See “Variable definitions” (page 23) for the possible options and their 
values.

7 Optionally, disable the Automatic startup at reboot time option.

8 Click OK.

A confirmation dialog displays.

9 Click Yes to confirm.

10 Click Cancel to close the SVM Edit Server window

ATTENTION The Backup Provider server must be started before the 
Backup Controller server when using the -notification 
option.
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11 Right-click on the server name in the server list.

12 From the pop-up menu, select Start.

The server starts.

Variable definitions

Option/Variable Definitions/Values

-c /opt/MagellanNMS/cfg/
<filename.cfg>

The option to specify a filename for the controller config file if you 
are using a filename other than Controller.cfg. You must show the 
full path to the file.

-d The option to set debugging on. The default is off.

-DB_Synch_port <port> The option to use the specified port for communication with the 
DB_Synch. The default is 5050.

Note:  You can use this option only if you use Preside MDM with the 
Administration Database. See 241-6001-400 Preside MDM 
Administration Database User Guide.

-h The option to display command line usage.

-nbofbck <#> The option to specify the maximum number of parallel backups. The 
default # is 5.

Note:  This option can only be used with the - notification option.

-notification The option to enable current configuration backups.

-p <port_no> The option to specify the port to use. If you use this option, you will 
override the dynamic port selection process.

<server_name> The command line value that represents the server name:

• Passport Backup Provider = pbckpp

• Passport Restore Provider = prstpp

• Backup Controller = nsctlbck

• Restore Controller = nsctlrst
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Setting the default account used to access a device
Use the following procedure to set default userids and passwords to access a 
device.

Procedure steps
1 From the Preside MDM window, select Configuration->Passport-

>Administration->Passport Service Data Backup/Restore.

2 In the Passport Backup and Restore window, select Set Default 
Authentication from the Options menu.

The Default Authentication dialog displays.

3 Enter the appropriate user id and password.

4 Click OK.
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Specifying the location of the Data Synchronization server
Use this procedure if you want the backup and restore process synchronized 
with the MDM Administration Database. It is necessary to specify the 
location of the Data Synchronization server for the Backup and Restore tool 
if the server is not on the local host.

Procedure steps
1 Open the file /opt/MagellanNMS/cfg/bkRst.cfg.

2 Locate the command line that contains

jmx.server.host: localhost

Note:  The default value for this attribute is localhost.

3 Change the value of localhost to the location of the Data Synchronization 
Server. For example

jmx.server.host: wcars123

4 Save then close the file.
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Configuring the Data Synchronization server
Passport Service Data Backup and Restore requires that the Data 
Synchronization server is enabled even if the database is not being used. This 
is required for the basic backup and the current configuration backup 
functions.

Procedure steps
1 In the Preside MDM window, select System -> Administration -> Server 

Administration to open the Server Administration tool.

2 From the Security menu, select the Authorize command.

3 In the SVM Enter Authorization Password dialog box, type a valid 
password and click OK.

4 From the Edit menu, select New Server.

The SVM New Server Selection window displays.

5 Expand the server categories to locate the Data Sync Server in this list.

6 Select the server and click Select Server.

The SVM Edit Server dialog displays with the fields pre-filled with default 
information.

7 In the Startup command field, type the following command, as follows:

/opt/MagellanNMS/bin/dataSyncServer
[-help]

8 Click OK.

A confirmation dialog displays.

9 Click Yes to accept this information.

10 Click Close.
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Modifying the Data Synchronization configuration file for a 
Current Configuration Backup

Passport Backup and Restore uses the data synchronization configuration file 
(DataSync.cfg) to display the devices that you can back up and restore. This 
file contains the list of devices with their userids and passwords, as well as 
additional fields for each devices. 

The configuration file is stored under

/opt/MagellanNMS/cfg/DataSync.cfg

You need to include an entry for every device that Passport Backup and 
Restore can access on the host machine.

If you have Passport Backup and Restore software on multiple hosts, it is 
recommended that you duplicate the entries in the data synchronization file. 

For security reasons, passwords can be encrypted in a separate file in which 
case the full path of the file containing the encrypted password replaces the 
password field in the DataSync.cfg file. MDM provides a tool to encrypt a 
password, and save it in a separate file, /opt/MagellanNMS/bin passwd_gen. 
This tool must be run as root. For the procedures to generate a secure 
password for an MDM server, and how to change a secure password, refer to 
NN10600-605 Passport - MDM Network Security: Operations. 

All backup groups must be defined in the HGDS server using the Host Group 
Administration tool. For more information, refer to 241-6001-303 Preside 
MDM Administrator Guide. 

ATTENTION The DBSyncController name must be identical to the DBSync 
name value. For more information on configuring the 
DBSyncController, refer to 241-6001-400 Preside MDM 
Administration Database User Guide
Preside MDM Network Backup and Restore User Guide   15.1RSUP
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Passport/SNMP Service Data Backup/Restore setup
The task flow shows you the sequence of procedures you perform to setup the 
Passport/SNMP Service Data Backup/Restore tool. To link to any procedure 
in this document, double-click on the procedure name in the task flow or in 
the list.

Figure 2
Task flow for setting up Passport/SNMP Service Data Backup/Restore applications

Specifying the device 
information file and the 

devices for Passport 

Starting the Passport 
backup and restore 

servers

Changing options 
using the Backup 

Options dialog for an 
SNMP-based device

Changing options using 
the Restore Options 
dialog for an SNMP-

based device

END

Passport/SNMP Service 
Data Backup/Restore setup
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Passport/SNMP Service Data Backup/Restore setup 
procedure navigation

• “Specifying the device information file and the devices for Passport 
4400/4460” (page 30).

• “Starting the Passport/SNMP backup and restore servers” (page 31).

• “Changing options using the Backup Options dialog for an SNMP-based 
device” (page 34).

• “Changing options using the Restore Options dialog for an SNMP-based 
device” (page 35).
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Specifying the device information file and the devices for 
Passport 4400/4460

You need to use a device information file that has entries for the devices you 
are going to access.

Prerequisites
• For information about naming the device information file, see “Device 

information file for Passport 4400/4460 devices” (page 43).

Procedure steps
1 From the Preside MDM window, select Configuration->Passport 4400-

>Administration->Passport/SNMP Service Data Backup/Restore.

2 In the Passport/SNMP Devices Backup and Restore window, select the 
devices to backup or restore. 

If the devices or device groups are not displayed in the devices area

a. From the File menu, select Open.

The Open File dialog opens.

b. Select a device information file by entering a path and file name in the 
File name: data entry box. You can also select a device information 
file using the Look in: pull-down menu and clicking on the file in the 
display panel.

c. Click Open to load the selected device information file and close the 
dialog.

d. From the Passport/SNMP Devices Backup and Restore main 
window, select Options->Save Options to save the current device 
information file as the default for future sessions. This menu item also 
saves any changes you make in the Change Backup Options and 
Change Restore Options dialogs.
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Starting the Passport/SNMP backup and restore servers
Use this procedure to start the servers and to specify the ports to use for the 
controller servers, or to add other options.

Prerequisites
• Launch the Server Administration tool:  System -> Administration -> 

Server Administration.

• If you are adding options to a server that is already running, you must 
stop the server before you add the option.

Procedure steps
1 From the Security menu, select the Authorize command.

2 In the SVM Enter Authorization Password dialog box, type a valid 
password and click OK.

3 From the Edit menu, select Edit -> New server.

The SVM New Server Selection displays.

4 Expand the Configuration Server category to find the server in the list.

5 Select the server and click Select Server.

The SVM Edit Server opens with the startup command displayed.

6 Edit the Startup command to specify the required controller port numbers, 
as follows:

To specify the backup controller port:

/opt/MagellanNMS/bin/nsctlbck [-p 5000]

To specify the restore controller port:

/opt/MagellanNMS/bin/nsctlrst [-p 5001]

7 Edit the Startup command to specify the backup and restore provider 
server ports:

ATTENTION If the Provider is not running on the same machine as the 
Controller, or if you want to use more than one Provider to 
share the load, the remote mapping file must modified. For 
more information, see “Modifying the remote mapping file 
(optional)” (page 37).
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/opt/MagellanNMS/bin/<provider_server_name> [-p 
<provider_server_port_no]

8 Optionally, edit the Startup command to add other option(s):

/opt/MagellanNMS/bin/<server name> [-<option> <option 
value>]

See “Variable definitions” (page 32) for possible options and their values.

9 Optionally, disable the Automatic startup at reboot time option.

10 Click OK.

A confirmation dialog displays.

11 Click Yes to confirm.

12 Click Cancel to close the SVM Edit Server window

13 Right-click on the server name in the server list.

14 From the pop-up menu, select Start.

The server starts.

Variable definitions

Option/Variable Values/Definitions

-c /opt/MagellanNMS/cfg/
<filename.cfg>

The option to specify a filename for the controller config file if you 
are using a filename other than Controller.cfg. You must show the 
full path to the file.

-d The option to set debugging on. The default is off.

-h The option to display command line usage.

-m <interface_mapping_file> Use this option to specify the interface mapping file.This optional file 
is required when your system has multiple network interfaces. The 
default interface mapping file is /opt/MagellanNMS/cfg/ifmap.cfg.

If the file ifmap.cfg exists in directory /opt/MagellanNMS/cfg and is 
populated with valid mapping information, it is not necessary to 
specify the -m option. This file is used by default.

For information about when to use this option, see “Modifying the 
interface mapping file for Passport 4400/4460 devices” (page 41).

 (Sheet 1 of 2)
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-p 
<provider_server_port_no>

Use this option to specify the port to use for the Backup and Restore 
Provider servers. The default values are as follows:

• Passport 4400 Backup Provider = 5030

• Passport 4400 Restore Provider = 5031

• Passport 4460 Backup Provider = 5040

• Passport 4460 Restore Provider = 5041

<provider_server_name> The value that represents the provider server name:

• Passport 4400 Backup Provider = pbckpp4400

• Passport 4400 Restore Provider = prstpp4400

• Passport 4460 Backup Provider = pbckpp4460

• Passport 4460 Restore Provider = prstpp4460

Option/Variable Values/Definitions

 (Sheet 2 of 2)
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Changing options using the Backup Options dialog for an 
SNMP-based device

Before you perform a SNMP-based backup, you can change the default 
values of the Controller, Controller port, and target directory.

Procedure steps
1 From the Preside MDM window, select Configuration->Passport 4400-

>Administration->Passport/SNMP Service Data Backup/Restore.

2 In the Passport/SNMP Devices Backup and Restore window, select 
Change Backup Options from the Options menu.

The Change Backup Options dialog opens.

3 Modify the Backup controller host, Backup controller port, or Target 
directory.

4 Click OK to close the dialog.

5 From the Options menu, select Save Options to save your changes for 
future sessions. This command also saves the current device information 
file and any changes you make in the Change Restore Options dialog.
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Changing options using the Restore Options dialog for an 
SNMP-based device

Before you perform an SNMP-based restore, you can change the default 
values of the Controller, Controller port, and source directory. 

Procedure steps
1 From the Preside MDM window, select Configuration->Passport 4400-

>Administration->Passport/SNMP Service Data Backup/Restore.

2 In the Passport Backup and Restore window, select Change Restore 
Options from the Options menu.

The Change Restore Options dialog opens.

3 Modify the Restore controller host, Restore controller port, or Source 
directory.

4 Click OK to close the dialog.

5 From the Options menu, select Save Options to save your changes for 
future sessions. This command also saves the current device information 
file and any changes you make in the Change Backup Options dialog.
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Additional configuration for Passport and Passport/SNMP 
backup and restore

For both Passport and Passport/SNMP Service Data backup and restore, the 
Controller uses the remote mapping file (Controller.cfg) to determine the 
Provider to which a device is connected. You must modify the Controller.cfg 
file if one or both of the following conditions exist:

• the Provider is not running on the same workstation as the Controller

• more than one Provider is used to share the load

See “Modifying the remote mapping file (optional)” (page 37).
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Modifying the remote mapping file (optional)
Add an entry to the remote mapping file for any device that you want accessed 
by a specific Provider. In this file, each service has a separate service mapping 
block of commands. You need to include an entry in the service mapping 
block for each device that you want accessed by a specific Provider.

If you do not create an entry, the Backup and Restore tools assume the device 
is connected to the local Provider. The Backup and Restore tools support only 
one remote mapping file.

The format of a service mapping block in the remote mapping file is

service=<service_type>
dev_type=<devtype> 
[dev_name=<devname> | dev_addr=<IPaddress>] 
host=<provider_host>[<:provider_port>]

...

where: 

service_type is either backup or restore.

devtype is the name of the device type (PASSPORT, PP4400, or PP4460).

devname is the name of the device. You can match a group of devices by 
using the wildcard character (*).

IPaddress is the IP address of the device and has the format n.n.n.n. You 
can match a group of devices by using the wildcard character (*).

provider_host:provider_port is the Provider location; provider_host 
is the hostname or IP address of the Provider and provider_port is the port 
number registered to the Provider. The port number for Passports (not PP4400 
or PP4460) is dynamic by default. The default values for provider_port are:

dynamic Passport Backup Provider
dynamic Passport Restore Provider
5030 Passport 4400 Backup Provider
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5031 Passport 4400 Restore Provider
5040 Passport 4460 Backup Provider
5041 Passport 4460 Restore Provider

If you do not use devname or IPaddress, the Provider identified in 
provider_host handles the service for all devices of the specified dev_type.

Note: You must include devtype, devname/IPaddress, and host on the 
same line.

You can include comments in the remote mapping file by inserting an 
octothorpe (#) at the beginning of the line. You can also include blank lines.

Example
The following example shows a remote mapping file with 2 service blocks. 
Each device in the service blocks is connected to a different remote host.

# Remote mapping file

service=backup

dev_type=PASSPORT dev_addr=42.208.*.111 host=23.257.32.12

dev_type=PP4400 dev_name=PP4400_20 host=bcarse80

dev_type=PP4460 dev_name=PP4460_64 host=winnipeg

service=restore

dev_type=PASSPORT dev_addr=42.208.*.111 host=59.620.6.24

dev_type=PP4400 dev_name=PP4400_20 host=bcarse80

dev_type=PP4460 dev_name=PP4460_64 host=winnipeg
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Additional configuration for Passport/SNMP backup and 
restore

In addition to the basic setup tasks, you may have to perform the following 
configuration tasks, depending on your particular setup.

• “Configuring connectivity between Passport 4400/4460 and a provider 
(optional)” (page 40)

• “Modifying the interface mapping file for Passport 4400/4460 devices” 
(page 41)

• “Device information file for Passport 4400/4460 devices” (page 43)
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Configuring connectivity between Passport 4400/4460 and 
a provider (optional)

The following procedure describes how to configure the communication 
between a Passport 4400/4460 device and a Provider if the Passport 
4400/4460 contains a default configuration. A default configuration means no 
configuration has been entered.

Procedure steps
1 Establish a communication with the Passport 4400/4460 through the 

serial console port. The default line parameters are 9600N81, which 
means:

baud rate: 9600
parity: none
bits: 8
stop bit: 1

If successful, you are prompted for a login when you press the Return key.

2 Type cli at the login prompt. For the password, press the Return key.

3 Define the Ethernet interface IP address of the Passport 4400/4460 by 
entering the following CLI (command line interface) command:

add ip address entry 3 x.x.x.x y.y.y.y z.z.z.z

where:

x.x.x.x is the IP address of the Passport 4400/4460
y.y.y.y is the network netmask
z.z.z.z is the broadcast address

4 Save the configuration with the CLI command:

save config update

5 Reset the Passport 4400/4460 with the new configuration using the CLI 
command:

reset system current reset
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Modifying the interface mapping file for Passport 4400/4460 
devices

File transfers between a Passport 4400/4460 and a Provider are initiated by 
the Provider. The IP address of the Provider is delivered to the Passport 
4400/4460. The Provider instructs the Passport 4400/4460 to start the file 
transfer process. The Passport 4400/4460 establishes the TFTP connection 
and the files are transferred.

If the Provider’s host machine has only one network interface (one IP 
address), that IP address is used for the TFTP connection between the 
Passport 4400/4460 and the Provider. 

The Provider host machine can have multiple network interfaces. For 
example, the system can have one interface to the LAN and other interfaces 
to the WAN where the Passport 4400/4460 devices reside. In this 
configuration the Passport 4400/4460 devices cannot see the IP address of the 
interface to the LAN. In this situation you need to configure the Provider to 
use the correct interface address for the TFTP connection. You do this by 
creating an interface mapping file.

The Passport 4400 and Passport 4460 Providers can use the interface mapping 
file to determine the IP address used as the TFTP server address. The Passport 
4400/4460 device connects to the TFTP server address for TFTP file 
transfers. Each line in the interface mapping file defines the mapping of the 
host address and the Passport 4400/4460 address or addresses. The host 
address is the TFTP server address.

The interface mapping file is named ifmap.cfg. 

The format of ifmap.cfg is

<interface IP address> <device IP address(es)>

where:

interface IP address is the IP address of the interface to be used and 
has the format n.n.n.n.
Preside MDM Network Backup and Restore User Guide   15.1RSUP



42   Chapter 1 Service Data Backup/Restore setup
device IP address(es) is the IP addresses of the devices and has the 
format n.n.n.n. You can match a group of devices by using the wildcard 
character (*).

You can include comments in the interface mapping file by inserting an 
octothorpe (#) at the beginning of the line. You can also include blank lines.

Example
The following example shows an interface mapping file for a host machine 
that has 3 network interfaces: one connects to the LAN and the other two are 
connected to separate networks of Passport 4400/4460 devices. 

# Interface mapping file

# The last entry is the interface address to the LAN, 

# which needs to map to any device address.

# This last entry can be omitted.

131.147.0.1 131.147.*

131.148.0.1 131.148.*

32.123.1.1 *
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Device information file for Passport 4400/4460 devices
Passport/SNMP Service Data Backup and Restore uses the device 
information file (devices.cfg) to display the devices that you can back up and 
restore.You need to include an entry for every device that Passport/SNMP 
backup and restore can access on the host machine.You do not need to include 
all devices in a single file; you can create as many device information files as 
you want and select one from the main window before performing a backup 
or restore.

The device information file enables you to group devices. This option enables 
you to back up or restore all devices within a particular group.

If you have Passport/SNMP Service Data Backup and Restore software on 
multiple hosts, it is recommended that you duplicate the entries in the device 
information files. However, you can divide the entries into device information 
files on different hosts so that each host backs up and restores only those 
devices managed by that host.

The device information file does not have a naming convention. 

Its format is

device: type = <devtype> name = <devname> 
addr = <IPaddress>[:<port>] [userid = <id>]
[passwd = <password>]

group: name = <groupname>
member: name = <devname>

where:

device: indicates information about a particular device.

devtype is the name of the device type (PP4400, or PP4460).

devname  is the name of the device.

IPaddress is the IP address of the device and has the format n.n.n.n. 

port is the port number of the device.
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id is the userID for a Passport and the READ community string for a 
Passport 4400/4460.

password is the user password for a Passport and the WRITE community 
string for a Passport 4400/4460. 

group: indicates information about a group of devices.

groupname is the name of the group to which the device belongs. 

member: indicates information about a member of the group. You need to 
place all members of a group directly after the group line.

Note: You must include devtype, devname, IP address, id, and password 
on the same line.

You can include comments in the device information file by inserting an 
octothorpe (#) at the beginning of the line. You can also include blank lines.

Example
The following example shows a device information file.

device: type = PASSPORT name = NODER05 addr = 82.152.6.19

device: type = PASSPORT name = NODER06 addr = 82.152.6.32

device: type = PASSPORT name = NODERF addr = 82.232.33.74

device: type = PP4400 name = PP4400_20 addr = 35.195.4.173

device: type = PP4400 name = PP4400_EMU addr = 82.195.1.45

device: type = PP4460 name = PP4460_64 addr = 35.195.4.173

device: type = PP4460 name = PP4460_CAL addr = 82.195.1.45

group: name = group01

member: name = NODER05

member: name = NODER06

member: name = NODERF

# You can put a device in more than one group.

group: name = group02
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member: name = NODERF

member: name = PP4400_20

member: name = PP4400_EMU

group: name = group03

member: name = PP4460_64

member: name = PP4460_CAL

device: type = PP4400 name = TEST addr = 15.190.6.58

device: type = PASSPORT name = NODE_TOR addr = 18.232.1.32

group: name = group03

member: name = TEST

member: name = NODE_TOR
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Basic service data backup

Use the Passport Service Data Backup/Restore tool and the Passport/SNMP 
Service Data Backup/Restore tool to backup service data.

Navigation
• “Prerequisites to service data backup” (page 47)

• “Passport service data backup procedures” (page 49)

• “Passport/SNMP service data backup procedures” (page 58)

• “Using the command line interface to perform backups” (page 63)

• “Viewing the Passport backup repository” (page 67)

Prerequisites to service data backup
• Before you perform a backup, you need to start up the Backup Controller 

and Providers. For more information, see “Service Data Backup/Restore 
setup” (page 19)

• For Passport Service Data backup, launch the Passport Backup and 
Restore GUI: Configuration->Passport->Administration->Passport 
Service Data Backup/Restore.

ATTENTION Use Passport Service Data Backup/Restore for Passport 
6000, 7400, 15000, and 20000 nodes.
Use Passport/SNMP Service Data Backup/Restore for 
Passport 4400 and 4460 nodes.
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• For Passport/SNMP Service Data backup, launch the Passport/SNMP 
Backup and Restore GUI: Configuration->Passport 4400 -
>Administration->Passport/SNMP Service Data Backup/Restore.
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Passport service data backup procedures
The task flow shows you the sequence of procedures you perform to backup 
Passport service data. To link to any procedure in this document, double-click 
on the procedure name in the task flow or in the “Passport service data backup 
procedure navigation” (page 50) list.

Figure 3
Passport service data backup procedures
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Passport service data backup procedure navigation
• “Adding Passport devices to the backup list” (page 51)

• “Removing Passport devices from the backup list” (page 52)

• “Defining a specific userid and password for a Passport in the backup 
list” (page 53)

• “Changing the Default User Authentication” (page 54)

• “Performing a full backup for a Passport device” (page 55)

• “Performing an incremental backup for a Passport device” (page 56)

• “Performing a selective backup for a Passport device” (page 57)
241-6001-807   15.1RSUP   



Chapter 2 Basic service data backup   51
Adding Passport devices to the backup list
Use this procedure to add devices to the list of devices that you wish to 
backup.

Procedure steps
1 Select the Backup Configuration tab.

2 Select Add to launch the Add Devices Dialog.

3 From the left pane, select a group of devices or expand the group and use 
the Ctrl key to select a number of devices within a group.

4 From the drop down list, in the right pane, select a backup mode 
(Incremental or Full). 

5 If a specific userid and password is required for the device, enter the 
values in the user ID and Password fields and uncheck the Use default  
checkbox.

If you wish to use the default userid and password, click the Use default 
checkbox.

6 Click OK.

The devices display in the Device List.
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Removing Passport devices from the backup list
Use this procedure to remove devices from the list of devices that you wish to 
backup.

Procedure steps
1 Select the Backup Configuration tab.

2 In the Device List, select the devices you wish to remove.

3 Click Remove.

4 In the confirmation dialog, select Yes to confirm or No to cancel the 
removal.
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Defining a specific userid and password for a Passport in 
the backup list

A specific userid and password can be defined when you add the node to the 
node list or you can set it later using the following procedure.

Procedure steps
1 Select the Backup Configuration tab.

2 Select a node in the Device List section.

3 In the Device Details section, in the Authentication tab, enter a userid 
and password.

4 Clear the Use default checkbox.
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Changing the Default User Authentication 
Use the following procedure to define a default userid and password which is 
used for all node access unless overridden by a specific userid and password 
for the node.

Procedure steps
1 Select Options ->Set default authentication.

2 Enter the userid and password in the appropriate fields.

3 Click OK.

The new userid and password are used on the next node access.
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Performing a full backup for a Passport device
Use this procedure to backup all views on the device to the MDM backup data 
file.

Procedure steps
1 Select the Backup Configuration tab.

2 Select Add to launch the Add Devices dialog.

3 From the left pane, select a group of devices or expand the group and use 
the Ctrl key to select a number of devices within a group.

4 Select a device in the Device list:

5 Click in the Mode title and select Full from the drop-down list.

6 Click Backup.

The progress of the backup is displayed in the Messages area. If the 
backup is unsuccessful, an error dialog is displayed that specifies the 
device and the reason for the failure.

Note:  To cancel a backup in progress click Cancel.
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Performing an incremental backup for a Passport device 
Use the following procedure to backup only backup files that are not already 
in the MDM backup data file.

Procedure steps
1 Select the Backup Configuration tab.

2 Select Add to launch the Add Devices dialog.

3 From the left pane, select a group of devices or expand the group and use 
the Ctrl key to select a number of devices within a group.

4 Select a node in the nodes list.

5 In the Mode title, select Incremental from the drop-down list.

6 If you wish to specify a backup of views later than a specific date, enter 
the date in the date field. (for example July 3, 2003

7 Click Backup.

The progress of the backup is displayed in the Status area. If the backup 
is unsuccessful, an error dialog is displayed that specifies the device and 
the reason for the failure.

Note:  To cancel a backup in progress click Cancel.
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Performing a selective backup for a Passport device 
Use the following procedure to backup only a single specified file to the 
MDM backup data file.

Procedure steps
1 Select the Backup Configuration tab.

2 Select Add to launch the Add Devices dialog.

3 From the left pane, select a group of devices or expand the group and 
select a device. You can use the Ctrl key to select a number of devices 
within a group. 

4 Leave the default mode as is and click OK.

The Passport Backup and Restore window appears with the selected 
devices in the device list.

5 In the Mode column for each device, click on the default mode to open the 
mode list and select Selective.

The Configuration column in the table is enabled.

6 Click in the Configuration cell to display the available views on the 
device.

Note:  This step may take a few seconds to complete because the 
application must access the device and list all the view names.

7 Click Backup.

The progress of the backup is displayed in the Messages area. If the 
backup is unsuccessful, an error dialog is displayed that specifies the 
device and the reason for the failure.

Note:  To cancel a backup in progress click Cancel.
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Passport/SNMP service data backup procedures
The task flow shows you the sequence of procedures you perform to backup 
Passport service data. To link to any procedure in this document, double-click 
on the procedure name in the task flow or in the “Passport/SNMP service data 
backup procedure navigation” (page 58) list.

Figure 4
Passport/SNMP service data backup procedures
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Changing default information for SNMP-based devices 
backup

You can change the default information for any device type listed in the main 
window.

Procedure steps
1 In the Passport/SNMP Devices Backup window, double-click on the entry 

that you need to change in the Default Backup Information area.

The Change Default Information dialog opens.

2 Make the required changes.

3 Click OK to save your changes and close the dialog.
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Performing a full backup for an SNMP-based device
Perform a full backup to copy all the service data on a selected device or 
devices to the MDM backup data file.

Procedure steps
1 In the Passport/SNMP Devices Backup window, select only the device or 

devices whose service data you need to back up from the Backup 
Information area of the window.

The selected devices have a check mark in the Bck column. All other 
devices have no entry in the Bck column.

2 In the Backup Mode Selection area, click full.

3 Click Backup.

When the backup completes successfully, a message is displayed in the 
Message area. If the backup is unsuccessful, an error dialog is displayed 
that specifies the device and the reason for the failure.
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Performing an incremental backup for an SNMP-based 
device 

Perform an incremental backup to copy only that service data changed or 
created since the last backup. For Passport 4400/4460 devices, an incremental 
backup is the same as a full backup because this device has only one view.

Procedure steps
1 In the Passport/SNMP Devices Backup window, select only the device or 

devices whose service data you need to back up from the Backup 
Information area of the window.

The selected devices have a check mark in the Bck column. All other 
devices have no entry in the Bck column.

2 In the Backup Mode Selection area, click incr.

3 Click Backup.

When the backup completes successfully, a message is displayed in the 
Message area. If the backup is unsuccessful, an error dialog is displayed 
that specifies the device and the reason for the failure.
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Performing a selective backup for a SNMP-based device
Perform a selective backup to copy only the service data that you select. For 
Passport 4400/4460 devices, a selective backup is the same as a full backup 
because this device has only one view.

Procedure steps
1 In the Passport/SNMP Devices Backup window, select only the device or 

devices whose service data you need to back up from the Backup 
Information area of the window.

The selected devices have a check mark in the Bck column. All other 
devices have no entry in the Bck column.

2 In the Backup Mode Selection area, click sel.

The List Views button is enabled.

3 Click the List Views button and select the required view file. You can 
display selected view files by using the Filter data entry field and pressing 
<return>.

OR

Enter the name of the required view file in the sel data entry field and 
press <return>.

The view file name is displayed in the sel data entry field and in the View 
column of the Backup Information area.

4 Click Backup.

When the backup completes successfully, a message is displayed in the 
Message area. If the backup is unsuccessful, an error dialog is displayed 
that specifies the device and the reason for the failure.
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Using the command line interface to perform backups
You can use the command line to perform full, incremental, or selective 
backups. You can perform multiple backups on multiple devices in a single 
command. You have the option of obtaining the backup information from a 
file.

To display online help for this command, use the -h option on the command 
line.

Navigation
• “Procedure step” (page 63)

• “Backup file naming convention” (page 65)

Procedure step
Enter the following command as one continuous command:

/opt/MagellanNMS/bin/nsbck 
[-full <devtype> <devname> <devaddr> <id> <pw>]
[-incr <devtype> <devname> <devaddr> <id> <pw>]
[-view <viewname> <devtype> <devname> <devaddr> 
<id> <pw>]
[-cdir <backup_dir_path>
[-demand [<group_label> [<nodename>]]]
[-f <backup_info_file>]
[-chost <controller_address>]
[-nolog] | [-log [<logfile>]]
[-nc <#_concurrent_connections>]

Table 1
Variable definitions for backup using the command line interface

Variable Definition

-full indicates a full backup

-incr indicates an incremental backup

-view indicates a selective backup

devtype is the device type, such as PASSPORT, PP4400, PP4460

devname is the name of the device
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devaddr is the IP address of the device and has the format n.n.n.n

id is the userID for a Passport and the READ community string for a 
Passport 4400/4460

pw is the user password for a Passport and the WRITE community 
string for a Passport 4400/4460

viewname is the name of the view file for a selective backup

-cdir is the backup directory used for this backup operation

-demand is used only for current configuration backups. For information 
about this option and its variables, see “Scheduling current 
configuration backups” (page 97).

backup_dir_path is the path to the backup directory

-f indicates that the backup information is obtained from a file

backup_info_file is the name of the file containing backup information. Each line in 
the file has the same format as the -full, incr, or -view options

-chost indicates the remote Controller to be used in place of the Controller 
running on the local host.

controller_address is the address of the Controller and has the format host[:port]

-nolog indicates that output messages are to be discarded

-log indicates that output messages go to stdout/stderr or to a log file. 
The default is stdout/stderr 

logfile is the name of the file to which output messages go. If not specified, 
the messages go to the file mbrbackup.log in the current directory 
(where the tool runs)

-nc indicates the number of concurrent backups to be performed. By 
default, Passport/SNMP Devices Backup tries to back up 5 different 
devices concurrently. This parameter is useful when you are 
backing up a large number of device

#_concurrent_connections is the number of concurrent backups

Table 1 (Continued)
Variable definitions for backup using the command line interface

Variable Definition
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Examples
The following command is used to perform daily backups of service data.

/opt/MagellanNMS/bin/nsbck \
-incr PASSPORT PP1 123.123.1.1 my_id my_pw \
-incr PASSPORT PP2 123.123.1.2 my_id my_pw \
-full PP4400 PP4400_A 123.2.8.1 private public \
-full PP4400 PP4400_B 123.2.8.2 private public \
-full PP4460 PP4460_CAL 123.4.4.1 private public

You can also create a file, for example backup.info, that contains the 
following lines:

-incr PASSPORT PP1 123.123.1.1 my_id my_pw 
-incr PASSPORT PP2 123.123.1.2 my_id my_pw 
-full PP4400 PP4400_A 123.2.8.1 private public 
-full PP4400 PP4400_B 123.2.8.2 private public
-full PP4460 PP4460_CAL 123.4.4.1 private public

Type the following command to perform the same backup operation using the 
above file backup.info:

/opt/MagellanNMS/bin/nsbck -f backup.info

Backup file naming convention
The service data backup files have the following naming convention:

./<devtype>/<devname>/<timestamp>.<dataset>/ \ 
<datafiles...>

Note: The period (.) represents the Passport/SNMP Devices Backup and 
Restore root directory.

where:

devtype is the device type (PASSPORT, PP4400, or PP4460).

devname is the device name.

timestamp has the format yyyymmddhhmmss

datatset is the dataset name. 
For Passport, the dataset name is the Passport view file name. 
For Passport 4400/4460, the dataset name is either COMMIT or ACTIVE.
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<datafiles...> are the names of one or more files that are backed up.

Examples
The following example indicates that a backup was done of the Passport 
switch NODE10 on January 4, 1998 at 10:20:30 a.m.

./PASSPORT/NODE10/19980104102030.mydata.full.001

The following example indicates that a backup was done of the Passport 4400 
switch PP01 on December 29, 1998 at 5:25:48 p.m.

./PP4400/PP01/19981229172548.COMMIT

The following example indicates that a backup was done of the Passport 4460 
switch PP4460_CAL on March 18, 2000 at 1:45:16 p.m.

./PP4460/PP4460_CAL/20000318134516.COMMIT
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Viewing the Passport backup repository
If the backup server is running locally, use the following procedure to view 
all the backup files in the backup repository.

Procedure steps
1 Telnet into the remote workstation with the appropriate userid and 

password.

2 Navigate to the repository directory.

3 Use unix directory commands to view the contents of the backup 
repository.
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Basic service data restore

Use the Passport Service Data Backup/Restore tool and the Passport/SNMP 
Service Data Backup/Restore tool to restore service data.

Navigation
• “Prerequisites to service data restore” (page 69)

• “Passport service data restore procedures” (page 70)

• “Passport/SNMP service data restore procedures” (page 79)

Prerequisites to service data restore
• Before you perform a restore, you need to start up the Restore Controller 

and Providers. For more information, see “Service Data Backup/Restore 
setup” (page 19)

• For Passport Service Data restore, launch the Passport Backup and 
Restore GUI: Configuration->Passport->Administration->Passport 
Service Data Backup/Restore.

• For Passport/SNMP Service Data restore, launch the Passport/SNMP 
Backup and Restore GUI: Configuration->Passport 4400 -
>Administration->Passport/SNMP Service Data Backup/Restore.

ATTENTION Use Passport Service Data Backup/Restore for Passport 
6000, 7400, 15000, and 20000 nodes.
Use Passport/SNMP Service Data Backup/Restore for 
Passport 4400 and 4460 nodes.
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Passport service data restore procedures
The task flow shows you the sequence of procedures you perform to restore 
Passport service data. To link to any procedure in this document, double-click 
on the procedure name in the task flow or in the “Passport service data restore 
procedure navigation” (page 70) list.

Figure 5
Passport service data restore procedures

Passport service data restore procedure navigation
• “Adding Passport devices to the restore list” (page 72)
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• “Removing Passport devices from the restore list” (page 73)

• “Defining a specific userid and password for a Passport device in the 
restore list” (page 74)

• “Performing a full restore for a Passport device” (page 75)

• “Performing an incremental restore for a Passport device” (page 76)

• “Performing a selective restore for a Passport device” (page 77)
Preside MDM Network Backup and Restore User Guide   15.1RSUP



72   Chapter 3 Basic service data restore
Adding Passport devices to the restore list
Use the following procedure to add devices to the Devices List.

Procedure steps
1 From the Passport Service Data Backup/Restore window, select the 

Restore Configuration tab.

2 Click Add to open the Add Device dialog.

3 Select a group of devices or expand the group and use the Ctrl key to 
select a number of devices.

4 Select the appropriate restore mode, from the Mode column (full or 
incremental).

5 If a specific userid and password is required for the device, enter the 
values in the User ID and Password fields and uncheck the Use default 
checkbox.

If you wish to use the default userid and password, click the Use default 
checkbox.

6 Click OK.

The IP addresses for the devices are retrieved from HGDS and the device 
displays in the Devices list. 

For devices that are not in HGDS, you are prompted for their IP address. 
If you are prompted for an IP address, do step 7.

7 If you know the IP address, enter the correct IP address in the form and 
click OK and the device is added to the Devices list.

If the IP address is unknown or the device is not valid, press Cancel and 
the device is not added to the Devices list.
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Removing Passport devices from the restore list
Use this procedure to remove nodes from the list of nodes that you wish to 
backup.

Procedure steps
1 From the Passport Service Data Backup/Restore window, select the 

Restore Configuration tab.

2 In the Device List, select the devices you wish to remove.

3 Click Remove.

4 In the confirmation dialog, select Yes to confirm or No to cancel the 
removal.
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Defining a specific userid and password for a Passport 
device in the restore list

A specific userid and password can be defined when you add the device to the 
restore list or you can set it later using the following procedure.

Procedure steps
1 From the Passport Service Data Backup/Restore window, select a 

device.

2 In the Device Details section, enter a userid and password.

3 Clear the Use default checkbox.
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Performing a full restore for a Passport device
Use the following procedure to copy all the files from the repository and 
restore the data to the same or to another Passport device.

Procedure steps
1 From the Passport Service Data Backup/Restore window, select the 

Restore Configuration tab.

2 Click Add to open the Add Device dialog.

3 Select a group of devices or expand the group and use the Ctrl key to 
select a number of devices.

4 Select a device from the Device List.

5 Click in the Mode title and select Full from the drop-down list.

6 If you want to restore the service data to a different device, click in the To 
Device title to open the drop-down list and select the device whose data 
you want to restore.

7 Click Restore.

8 After a successful restore, you need to activate the restored data. See 
“Activating the restored Passport data” (page 78).
Preside MDM Network Backup and Restore User Guide   15.1RSUP



76   Chapter 3 Basic service data restore
Performing an incremental restore for a Passport device
Use the following procedure to copy files, based on a specific date, from the 
repository and restore the data to the same or to another Passport device.

Procedure steps
1 From the Passport Service Data Backup/Restore window, select the 

Restore Configuration tab.

2 Click Add to open the Add Device dialog.

3 Select a group of devices or expand the group and use the Ctrl key to 
select a number of devices.

4 Select a device from the Device List.

5 Click in the Mode title and select Incremental from the drop-down list.

6 If you want to restore the service data to a different device, click in the To 
Device title to open the drop-down list and select the device whose data 
you want to restore.

7 Define a date in the date column. (For example, July 4, 2003)

All the files, with the date and time that are not greater than the specified 
date, will be restored.

8 Click Restore.

9 After a successful restore, you need to activate the restored data. See 
“Activating the restored Passport data” (page 78).
241-6001-807   15.1RSUP   



Chapter 3 Basic service data restore   77
Performing a selective restore for a Passport device
Use the following procedure to copy a specific file from the repository and 
restore the data to the same or to another Passport device.

Procedure steps
1 From the Passport Service Data Backup/Restore window, select the 

Restore Configuration tab.

2 Click Add to open the Add Device dialog.

3 From the left pane, select a group of devices or expand the group and 
select a device. You can use the Ctrl key to select a number of devices 
within a group. 

4 Leave the default mode as is and click OK.

The Passport Backup and Restore window appears with the selected 
devices in the device list.

5 Select a device from the Device List.

6 In the Mode column for each device, click on the default mode to open the 
mode list and select Selective.

The Configuration column in the table is enabled.

7 Click in the Configuration cell to display the available views on the 
device.

Note:  This step may take a few seconds to complete because the 
application must access the device and list all the view names.

8 If you want to restore the service data to a different device, click in the To 
Device title to open the drop-down list and select the device whose data 
you want to restore.

9 Click Restore.

10 After a successful restore, you need to activate the restored data. See 
“Activating the restored Passport data” (page 78).
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Activating the restored Passport data
Passport Restore restores the backup configuration data onto the Passport 
disk. After a successful restore, perform the following procedure to activate 
the restored data.

Procedure steps
1 Establish a telnet session to the Passport.

2 Download to the Passport any required application software missing from 
the Passport disk.

3 Enter provisioning mode.

4 Activate the restored view and confirm the activation.

5 If required, commit the activated view.
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Passport/SNMP service data restore procedures
The task flow shows you the sequence of procedures you perform to restore 
Passport/SNMP service data. To link to any procedure in this document, 
double-click on the procedure name in the task flow or in the “Passport/
SNMP service data restore procedure navigation” (page 79) list.

Figure 6
Passport service data restore procedures

Passport/SNMP service data restore procedure navigation
• “Changing default information for Passport/SNMP Devices Restore” 

(page 81)

• “Performing a full restore for an SNMP-based device” (page 82)

• “Performing an incremental restore for an SNMP-based device” 
(page 83)
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• “Performing a selective restore for an SNMP-based device” (page 84)

• “Activating the restored Passport 4400/4460 data” (page 85)
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Changing default information for Passport/SNMP Devices 
Restore

You can change the default information for any device type listed in the main 
window.

Procedure steps
1 In the Default Restore Information area of the Passport/SNMP Service 

Data Backup/Restore window, double-click on the entry that you need to 
change.

The Change Default Information dialog opens.

2 Make the required changes.

3 Click OK to save your changes and close the dialog.
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Performing a full restore for an SNMP-based device
Perform a full restore to restore all backed up service data to a selected device 
or devices.

Procedure steps
1 From the Passport/SNMP Service Data Backup/Restore, click on the 

Restore command button.

The Passport/SNMP Devices Restore window opens.

2 Select only the device or devices whose service data you need to restore 
from the Restore Information area of the window.

The selected devices have a check mark in the Rst column. All other 
devices have no entry in the Restore column.

3 In the Restore Mode Selection area, click full.

4 Click Restore.

When the restore completes successfully, a message is displayed in the 
Message area. If the restore is unsuccessful, an error dialog is displayed 
that specifies the device and the reason for the failure.

5 After a successful restore, you need to make the restored data active. See 
“Activating the restored Passport 4400/4460 data” (page 85).
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Performing an incremental restore for an SNMP-based 
device

Perform an incremental restore restores service data, based on a date that you 
specify. If you do not specify the date, an incremental restore is the same as a 
full restore. 

Procedure steps
1 From the Passport/SNMP Service Data Backup/Restore, click on the 

Restore command button.

The Passport/SNMP Devices Restore window opens.

2 Select only the device or devices whose service data you need to restore 
from the Restore Information area of the window.

The selected devices have a check mark in the Rst column. All other 
devices have no entry in the Restore column.

3 In the Restore Mode Selection area, click incr.

4 In the Restore Mode Selection area, fill in the Date field. The restore 
process restores the service data that was backed up on that date. If no 
backup exists for that date, the restore process restores the service data 
that was backed up closest to, but not exceeding, that date.

5 Click Restore.

When the restore completes successfully, a message is displayed in the 
Message area. If the restore is unsuccessful, an error dialog is displayed 
that specifies the device and the reason for the failure.

6 After a successful restore, you need to make the restored data active. See 
“Activating the restored Passport 4400/4460 data” (page 85).
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Performing a selective restore for an SNMP-based device
Perform a selective restore to restore only the service data that you select.

Procedure steps
1 From the Passport/SNMP Service Data Backup/Restore, click on the 

Restore command button.

The Passport/SNMP Devices Restore window opens.

2 Select only the device or devices whose service data you need to restore 
from the Restore Information area of the window.

The selected devices have a check mark in the Rst column. All other 
devices have no entry in the Restore column.

3 In the Restore Mode Selection area, click sel.

The List Views button is enabled.

4 Click the List Views button and select the required view file. You can 
display selected view files by using the Filter data entry field and pressing 
<return>.

OR

Enter the name of the required view file in the sel data entry field and 
press <return>.

The view file name is displayed in the sel data entry field and in the View 
column of the Restore Information area.

5 Click Restore.

When the restore completes successfully, a message is displayed in the 
Message area. If the restore is unsuccessful, an error dialog is displayed 
that specifies the device and the reason for the failure.

6 After a successful restore, you need to make the restored data active. See 
“Activating the restored Passport 4400/4460 data” (page 85).
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Activating the restored Passport 4400/4460 data
Passport/SNMP Devices Restore restores the backup configuration data onto 
the non-committed bank of the Passport 4400/4460. After a successful 
restore, perform the following procedure to activate the restored data.

Procedure steps
1 Establish a connection to the Passport 4400/4460 through the serial 

console port. Alternatively, you can start a telnet session if there is IP 
connectivity between the Passport 4400/4460 and the workstation.

2 Verify the status of the restore by entering the following CLI (command 
line interface) command:

show tftp error

The response should be: 

LastOperStatus : <status>
ServerIPAddr : <x.x.x.x>
FileName : <filename>
TransferBank : toBank<3|4>
PortNumber : <xxx>

3 Confirm that the LastOperStatus variable indicates a successful 
download. The value of TransferBank indicates to which bank the 
configuration data was restored.

4 Set the active configuration bank to the bank to where the configuration 
data was restored by entering the CLI command:

set system firmware activeConfigBank bank<x>

where <x> is the bank to which the configuration data was restored.

5 Reset the Passport 4400/4460 by entering the CLI command:

reset system current reset

The configuration takes effect once the Passport 4400/4460 has 
completed boot up.
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Current Configuration Backup

Use the Passport Service Data Backup/Restore tool to perform a backup of a 
Passport 6000, 7400, 15000, and 20000 current configuration. This 
functionality is used for Node Recovery as well as to enable backup capability 
for Passport view and journal files. It supports the database synchronization 
mechanisms to ensure that the MDM Administration Database is updated 
with the latest configuration.

Navigation
• “Prerequisites to current configuration backup” (page 87)

• “Backup server configuration for current configuration backup” 
(page 88)

• “Performing a Current Configuration Backup” (page 96)

• “Scheduling current configuration backups” (page 97)

Prerequisites to current configuration backup
• The devices to be backed up must be specified in a user configuration file. 

This configuration file also determines if backups are on_demand, and if 
database synchronization should be done. See “Modifying the Data 
Synchronization configuration file for a Current Configuration Backup” 
(page 27).
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Backup server configuration for current configuration 
backup

The task flow shows you the sequence of procedures you perform to 
configure the backup server for current configuration backup of Passport 
service data. To link to any procedure in this document, double-click on the 
procedure name in the task flow or in “Configuring the backup server for 
current configuration backup procedure navigation” (page 88).

Figure 7
Configuring the backup server for current configuration backup procedures

Configuring the backup server for current configuration 
backup procedure navigation

• “Modifying the Backup Server command line” (page 90)

• “Defining the default backup group for Passport devices” (page 92)
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• “Adding a backup group” (page 93)

• “Removing a backup group” (page 95)
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Modifying the Backup Server command line
To support the Current Configuration backup and database synchronization, 
and to configure the maximum number of parallel backups, you must add 
options to the command line for the Backup Server.

Procedure Steps
1 Open the Server Administration tool and perform authorization. For more 

information, refer to 241-6001-303 Preside MDM Administrator Guide.

2 Select Backup Controller from the Server list.

3 Right click to select Edit Server.

The SVM Edit Server window displays.

4 In the Startup command field, add the following options to the command 
line.

/opt/MagellanNMS/bin/nsctlbck - notification -nbofbck 
<#>

where:

The -nbofbck <#>, where # is the maximum number of backups, limits the 
number of backups that can be performed in parallel. This option can only 
be used with the -notification option for backup on alarm or on demand; 
this option cannot be used for a basic backup. The default # is 5. Backup 
requests coming after the maximum number are queued in a waiting 
queue and are transferred to the executing queue if the executing queue 
is not full. That is, it has less than the maximum number of parallel 
backups, as specified in the nbofbck <#> option of the Backup Server 
command line. By limiting the number of simultaneous backups, you 
reduce congestion problems that may occur with a large number of 
backups. It is recommended that the default be left at 5, unless 
engineering information is available.

-notification option, when included, allows the system to perform current 
configuration backups. 

Any changes you make to the server startup command take effect when the 
server is restarted. For instructions on how to use the Server Administration 
tool, see the 241-6001-303 Preside MDM Administrator Guide.
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Note: The Backup Controller is known as the Backup Server when the -
notification option is specified. For example:

/opt/MagellanNMS/bin/pbckpp
/opt/MagellanNMS/bin/nsctlbck -notification

CAUTION
Starting the Backup Controller
The Backup Provider must be started before the Backup 
Controller (Backup Server) when using the -notification 
option. The Backup Controller is known as the Backup 
Server when the -notification option is specified. See 
“Current Configuration Backup” (page 87).
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Defining the default backup group for Passport devices
The default group options can be used for any backup group that you add. You 
must verify that the values in the default group options are acceptable for your 
system. Use the following procedure:

Procedure steps
1 Start the Server Administration tool.

For more information, refer to 241-6001-303 Preside MDM Administrator 
Guide.

2 In the Server Administration window, select the Backup Controller.

3 Right click to select Edit Configuration and then Backup Server.

The Configuration Editor displays. For information on the displayed 
parameters, refer to “Configuration Editor window” (page 118).

4 Expand the Default group element.

5 Select Authentication and 

a. enter the appropriate username,

b. enter the password 

OR

set the usePassword File to True and enter the location of the 
password file in the passwordFileName field.

6 Verify that the values in the Backup and DBSynch elements are 
appropriate.

7 From the File menu, select Save.
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Adding a backup group
Define a set of Passport devices as part of a group that will be backed up 
together at the same time in the same manner. Specify the manner in which 
this group is backed up.

Note: If you do not define the values of the backup group, the system 
uses the values defined in the default backup group.

Procedure steps
1 Define a group in the HGDS system using the Host Group Administration 

tool. For more information on adding groups, refer to 241-6001-303 
Preside MDM Administrator Guide.

Note 1:  If the Backup Controller is already running, you must run the 
Passport kick script. This script is used to update the HGDS, FDTM and 
FMDR servers with the new information, without having to restart the 
servers.

Note 2:  An existing group can be used. It does not have to be defined as 
a backup group.

2 Start the Server Administration tool.

For more information, refer to 241-6001-303 Preside MDM Administrator 
Guide.

3 In the Server Administration window, select the Backup Controller.

4 Right click to select Edit Configuration and then Backup Server.

The Configuration Editor displays. For information on the displayed 
parameters, refer to “Configuration Editor window” (page 118).

5 Select the BackupServer element.

6 Right click and select Add Element.

The Add Element dialog displays.

7 Verify that Group is selected and click OK.

8 Select the New Group element.

9 Enter the Group name.

10 Verify that the enabled field is set to True. 
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Note:  At this point, you can accept the values that you defined for the 
default backup group by selecting Save from the File menu which 
completes this procedure or you can specify new options using step 11 
through step 19.

11 Select your new group from the element tree.

12 Right click to select Add Element.

13 In the Add Element dialog, select Authentication and click OK.

14 Repeat step 12 and step 13, selecting BackupOptions and 
DBSynchOptions.

At this point, your new group has three sub-elements (Authentication, 
BackupOptions and DBSynchOptions).

15 Click on the group element to expand it.

16 Select Authentication and 

a. enter the appropriate username,

b. enter the password 

OR

set the usePassword File to True and enter the location of the 
password file in the passwordFileName field.

17 Select the BackupOptions element and verify that onAlarm is set to True 
if you wish backups to be performed on alarm.

Note that you do not have to select this option at this time. You can set this 
option later using the Backup and Restore tool. For more information, 
refer to “Modifying the Data Synchronization configuration file for a 
Current Configuration Backup” (page 27).

18 Select DBSyncOptions and

a. Verify that enabled is set to True if you wish to send a notification to 
the Data Sync server and have the database updated whenever a 
backup is performed.

b. Enter the name of the DBSyncController in the server field. Note that 
if you leave the server field blank, the system defaults to localhost.

19 Select Save from the File menu.
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Removing a backup group
If a group no longer requires backing up, you can remove it from the 
DataSync.cfg file.

Procedure steps
1 Start the Server Administration tool.

For more information, refer to 241-6001-303 Preside MDM Administrator 
Guide.

2 In the Server Administration window, select Backup Controller.

3 Right click to select Edit Configuration and then Backup Server.

The Configuration Editor displays.

4 Select the group you wish to remove.

5 Right click to select Remove Element.

6 In the Confirmation dialog, select Yes.

7 If the group was specific to the backup system and is no longer needed, 
remove it using the Host Group Administration tool. For more information 
on removing groups, refer to 241-6001-303 Preside MDM Administrator 
Guide.
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Performing a Current Configuration Backup
Use this procedure to perform a Current Configuration Backup of a group of 
devices. 

Procedure steps
1 From the Preside MDM window, select Configuration->Passport-

>Administration->Passport Service Data Backup/Restore.

2 Select Tools -> Backup Current Configuration.

The Backup Current Configuration window displays.

3 Click Add.

The Add Group window displays.

4 Select a group of devices or expand the group and select a device. You 
can use the Ctrl key to select a number of groups or a number of devices 
within a group. 

5 Select one group or select a number of groups using the Ctrl key.

6 Click OK.

The Groups you wish to backup are displayed in the Group List.

7 Click Backup.

If the backup request is successfully scheduled, the Messages pane 
indicates that the process has started. Note, however, that this type of 
backup is scheduled as background activity and does not provide updates 
to the Messages pane. 

8 View the Backup Status of all current configuration backups by selecting 
Tools->Show Server Log from the menu bar.

A window displays a snapshot of the end of the server log. To refresh the 
text in this window, close the window by pressing the Cancel button and 
re-selecting Tools->Show Server Log from the menu bar.
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Scheduling current configuration backups
Create a cron job to schedule current configuration backups on one or more 
of the Passports listed in the DataSync.cfg file.

Navigation
• “Procedure steps” (page 97)

• “Variable definitions” (page 97)

• “Procedure job aid” (page 98)

Procedure steps
1 From the xterm window, type the following command:.

crontab -e

An empty vi file is displayed on the screen.

2 Type the following command:

<time> * * [<day> [<day_range>]] /opt/MagellanNMS/bin/
nsbck -demand [<group_label> [<nodename>]]

Variable definitions

Variable Definition Values

day The day of the week that the backup 
is to occur.

 Enter 1 for Monday, 2 for 
Tuesday, 3 for Wednesday, 
and so on.
To schedule backups on 
non-consecutive days, type 
the command for each day.

day_range The range of days that the backup is 
to occur.

 Enter a range of consecutive 
days e.g. 2-5

group_label (optional) The group name in the DataSync.cfg 
that contains the list of Passports 
that are to be backed up.

To schedule backups on 
more than one group, type 
the command for each 
group.

 (Sheet 1 of 2)
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Procedure job aid
The following example shows a crontab file that performs backup on all 
devices from Monday to Friday at midnight:

0 0 * * 1-5 /opt/MagellanNMS/bin/nsbck -demand

The following example shows a crontab file that performs backup on three 
different groups on Monday, Tuesday and Wednesday at midnight:

0 0 * * 1 /opt/MagellanNMS/bin/nsbck -demand group1
0 0 * * 2 /opt/MagellanNMS/bin/nsbck -demand group2

0 0 * * 3 /opt/MagellanNMS/bin/nsbck -demand group3

nodename (optional) The name of a Passport in the 
DataSync.cfg.

To schedule backups on 
more than one Passport, 
type the command for each 
Passport.

time The time that the backup is to occur. Enter the time of day in hours 
and minutes e.g. 0 0 for 
midnight.

Variable Definition Values

 (Sheet 2 of 2)
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Chapter 5
Current Configuration Recovery

Use the Passport Service Data Backup/Restore tool to perform current 
configuration recovery for Passport 6000, 7400, 15000, and 20000 nodes. 

Note: For information on backing up views/journals for Recovery, see 
“Current Configuration Backup” (page 87).

A Passport Devices Recovery recovers the committed configuration of the 
Passport, its journal log files, and downloads the recent software, and restores 
them to a replacement Passport.

Navigation
• “Prerequisites to current configuration recovery” (page 100)

• “Defining the Software Distribution Site for a Passport node recovery” 
(page 101)

CAUTION
Files will be overwritten
Before reconnecting a replacement Passport to the 
network, edit the DataSync.cfg file to turn off backup on 
alarm for the device, and then restart the Backup Server. 
See “Modifying the Data Synchronization configuration 
file for a Current Configuration Backup” (page 27). This 
step prevents the Backup Server from being triggered by a 
reconnect alarm, which would back up this device and 
overwrite the recovery.info and avl. info files.
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• “Performing a current configuration device recovery” (page 102)

Prerequisites to current configuration recovery
• Before proceeding with this procedure, ensure that the Backup Server 

has been configured properly. See “Backup server configuration for 
current configuration backup” (page 88) and “Modifying the Backup 
Server command line” (page 90)

• When you are recovering a mix of devices, you must recover all Passport 
7400s (specifying the Passport 7400 software distribution site) in one 
procedure. Then, you must repeat the procedure for the Passport 15000 
(specifying the Passport 15000 software distribution site) to recover 
those nodes. The software distribution site is different for the Passport 
7400s and Passport 15000s.

• Launch the Passport Backup and Restore GUI: Configuration-
>Passport->Administration->Passport Service Data Backup/
Restore.
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Defining the Software Distribution Site for a Passport node 
recovery

Use this procedure to define the software distribution site to be used in Node 
Recovery.

1 From the Passport Service Data Backup/Restore window, select Set 
Software Distribution Site from the Options menu.

The Software Distribution Site dialog displays.

2 In the appropriate fields, enter the IP host name, userid and password of 
the Software Distribution Site.

3 Click OK.
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Performing a current configuration device recovery
Use this procedure to perform a current configuration recovery for a Passport 
device.

Procedure steps
1 From the Passport Service Data Backup/Restore window, select the 

Recover Device tab.

2 Click Add to open the Add Device dialog.

Note:  The Add Device dialog displays only devices that have a 
recovery.info file. Only those devices that have had a current configuration 
backup have a recovery.info file.

3 Select a group of devices or expand the group and use the Ctrl key to 
select a number of devices.

4 Select the Use default box to use the default password or enter the user 
ID and Password.

5 Click OK.

The devices are displayed in the Device List.

6 Select the device(s) on which to perform the Node Recovery. 

The date column displays the date of the last current view backup. The 
view column displays the name of the committed view. The software 
column displays the software version active at the time.

You can view the last journal number and the journal status of a device by 
selecting the Configuration Information tab in Device Details. The 
Application Versions tab displays the software application version that 
was used for this configuration.

7 Click Recover.

You can cancel the recovery process by clicking Cancel.
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Chapter 6
Fundamentals of Preside MDM Backup and 
Restore

Preside MDM provides two distinct interfaces for backup and restore 
activities:

• Passport Service Data Backup/Restore, used for the Passport 6000, 7400, 
15000, and 20000 devices 

• Passport/SNMP Service Data Backup/Restore, used for Passport 4400 
and 4600 devices

You can perform basic backup and restore functions using both interfaces. In 
addition, you can use Passport Service Data Backup/ Restore to perform a 
current configuration backup on Passport 6000, 7400, 15000, and 20000 
devices.

Navigation
• “Backup configuration files” (page 104)

• “Connectivity requirements for Passport nodes” (page 105)

• “Connectivity requirements for Passport 4400/4460 devices” (page 106)

• “Backup and Restore server architecture” (page 106)

• “Basic backup functions” (page 111)

• “Basic restore functions” (page 112)

• “Current configuration backup for Passport nodes” (page 113)

• “Backup and Restore logs” (page 125)
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Backup configuration files
The remote mapping file (Controller.cfg) is used for both Passport and 
Passport/SNMP Service Data backup when you need to access a Provider that 
is not running on the same host machine as the Controller. When this situation 
occurs, the remote mapping file needs an entry for the node, or nodes, on the 
remote Provider that the Controller is attempting to access. You can also use 
the remote mapping file to distribute the workload over several Providers. 

Passport service data backup configuration files
The data synchronization file (DataSync.cfg) is used to specify backup 
information for current configuration backup, current configuration recovery 
and data synchronization information for Passport nodes. It lists the groups 
(as defined in the Host Group Directory Service) that will be used to 
determine which nodes to backup, and the backup options. It includes 
configuration information for the Backup server and the DB synchronization 
controller. This file is updated using the Configuration Editor to modify all 
the parameters.

Passport/SNMP service data backup configuration files
The device information file (devices.cfg) has an entry for each node that 
Passport/SNMP Backup and Restore services. This file contains information 
about the nodes supported by the Backup and Restore tools. The Backup and 
Restore applications automatically create and update the file /opt/
MagellanNMS/data/nst/devices.cfg using GMDR for Passport 4400/4460.

The interface mapping file (ifmap.cfg), which is only for Passport 4400 
nodes, is used when the Provider’s host machine has multiple network 
interfaces. You can use the interface mapping file to map the IP address of the 
appropriate host interface to the IP addresses of the nodes that need to connect 
to that host interface.

For more information on the use of these configuration files, see “Passport 
Service Data Backup/Restore tool” (page 127).

File and Directory structure
The table “Backup and restore file and directory structure” (page 105) 
summarizes the location of the main backup and restore files and directories.
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Connectivity requirements for Passport nodes
You need FTP and FMIP access to backup and restore Passport 6000, 7400, 
15000, and 20000 nodes. This is not a requirement for Passport 4400 and 
4460 backup and restore.

Table 2
Backup and restore file and directory structure

Directory/Files Location

Backup Directory for each 
Passport device containing 
the Passport views and 
journal log files

/opt/MagellanNMS/data/Backup_Data/
PASSPORT<Passport_name>

Backup server log files /opt/MagellanNMS/data/log/bckRst/backup.dlog
/opt/MagellanNMS/data/log/bckRst/restore.dlog

For Passport devices only

Remote mapping file /opt/MagellanNMS/cfg/Controller.cfg

Data synchronization 
configuration file (for current 
configuration backup and 
recovery)

/opt/MagellanNMS/cfg/DataSync.cfg

For Passport 4400 devices only

Device information file /opt/MagellanNMS/data/nst/devices.cfg

Interface mapping file /opt/MagellanNMS/cfg/ifmap.cfg
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Connectivity requirements for Passport 4400/4460 devices
• The Passport 4400 and Passport 4460 Providers need IP connectivity to 

their respective devices. 

For information on how IP connectivity is established with a Passport 
4400 device, see “Configuring connectivity between Passport 4400/4460 
and a provider (optional)” (page 40). 

To verify the IP connectivity between the Providers and a Passport 4400/
4460 device, type the command ping w.w.w.w on the Passport 4400/4460, 
where w.w.w.w is the IP address of the workstation where the Providers 
reside.

• The Passport and Passport 4400/4460 devices must be configured to 
allow them to communicate with the workstations on which their 
associated Providers are running.

Backup and Restore server architecture
The servers are referred to as controllers and providers. The Backup 
controller and provider back up the most recent information from the Passport 
and store it on a backup site. The Restore controller and provider are 
responsible for restoring the backed up information to the Passport nodes. 

See “Passport Current Configuration Backup and Restore architecture” 
(page 107) and “Backup and Restore Architecture” (page 108).
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Figure 8
Passport Current Configuration Backup and Restore architecture
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Figure 9
Backup and Restore Architecture
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Backup and Restore server redundancy
To ensure Backup server reliability, redundancy can be set up for the Backup 
and Restore servers. Backup server redundancy may be critical if there is a 
requirements to be able to quickly recover a node to its current configuration. 
Two or more independent Backup servers can be running at the same time on 
different MDM workstations. See “Backup server redundancy” (page 109).

Figure 10
Backup server redundancy
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Both Backup servers cover the same Passports and are triggered by the same 
alarms from GMDR, which are generated by the Passports. A command line 
option can specify the host to which the GMDR server connects (see 
“Interface with GMDR” (page 122). 

In the illustration in “Backup server redundancy” (page 109), the Backup 
servers connect to two different GMDR’s, one for each Backup server. In 
another possible scenario, one common GMDR could be running on a 
separate workstation. Both Backup servers would receive alarms from this 
GMDR and trigger the servers to do backups. Regardless of the setup, two 
backups are done in parallel and independently. The two Backup servers do 
not communicate with each other. 

Similarly, two separate Restore controllers could run on workstation 1 and 
workstation 2 respectively and have a remote workstation with two separate 
instances of the recover tool connecting to the distinct Restore controllers.
241-6001-807   15.1RSUP   



Chapter 6 Fundamentals of Preside MDM Backup and Restore   111
Basic backup functions
The basic service data backup enables you to back up view files for a single 
device or for multiple devices of the same type.

Passport and Passport/SNMP Service Data Backup/Restore provide three 
types of backup:

• A full backup copies all views of the service data on the selected device 
or devices and stores the data on MDM to a file in /opt/MagellanNMS/
data/<backup data file name>. The full backup overwrites any views 
already stored in the MDM backup data file.

• An incremental backup copies only service data changed or created since 
the last backup. Like the full backup, you can perform an incremental 
backup on either one or multiple devices.

• A selective backup copies specific service data that you select. You can 
perform a selective backup on either one or multiple devices.

The Passport and Passport/SNMP backup function copies only the 
configuration data of the device. The service data views that make up the 
configuration data are found on the device disk in a set of files in individual 
directories under the directory /provisioning. The backup function also copies 
the special files that are found under the directory /provisioning/netsentry.

The configuration data for Passport 4400/4460 devices are stored in two 
memory banks (bank3 and bank4). Passport/SNMP Devices Backup does not 
back up both banks, only the committed bank is backed up.

ATTENTION The result of all three backup types is the same for Passport/
SNMP devices because these devices have only one view. 
Therefore, if you select a full backup, you backup one view. 
Conversely, if you select a selective or incremental backup, 
you backup the same view. The configuration data for 
Passport 4400/4460 devices are stored in two memory banks 
(bank3 and bank4). Passport/SNMP service data backup 
does not back up both banks, only the committed bank is 
backed up.
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Backup groups
The system administration uses the Configuration Editor to define attributes 
in a default backup group. When you add a new backup group, you can either 
define specific values for the new group or, if you don’t define any values, the 
system automatically uses the values of the default group.

All backup groups are defined in the HGDS server using the Host Group 
Administration tool. For more information, refer to 241-6001-303 Preside 
MDM Administrator Guide.

Basic restore functions
 The Passport and Passport/SNMP Service Data Backup and Restore tools 
restore functions can be performed on one or multiple devices. 

For Passports 6000, 74000, 15000, and 20000, MDM restores backed up 
configuration data onto the Passport disk. The data backed up from one 
Passport can also be restored to another Passport of the same type.

The Passport 4400/4460 has two memory banks, called bank 3 and bank 4, 
for configuration data. Passport/SNMP Devices Restore restores backed up 
configuration data onto the non-committed bank.

You can perform three types of restore:

• A full restore restores all backed up service data to the selected device or 
devices. For the Passport Service Data restore, this overwrites any 
previously restored view on the device. For the Passport/SNMP restore, 
this adds the new view and does not overwrite any previously restored 
view on the device. In both cases, the restore function does not overwrite 
protected views on the device. The committed view is always a protected 
view and cannot be restored.

• An incremental restore restores service data based on a specified date. 
For the Passport Service Data restore, if you do not specify the date, an 
incremental restore is the same as a full restore. You are not required to 
specify a date for the Passport/SNMP Service Data restore as the default 
sets the restore function to the current date.

• A selective restore restores specific service data that you select.
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Current configuration backup for Passport nodes
Passport Service Data Backup and Restore can be used to perform a current 
configuration backup for Passport 6000, 7400, 15000, and 20000 nodes. 

The backup server must be started with the -notification option to enable the 
current configuration backup. In addition, the -nbofbck option can be used to 
specific the maximum number of backups that can be performed in parallel. 
Backup requests coming after the maximum number are queued in a waiting 
queue and are transferred to the executing queue if the executing queue is not 
full. That is, it has less than the maximum number of parallel backups, as 
specified in the nbofbck <#> option of the Backup Server command line. By 
limiting the number of simultaneous backups, you reduce congestion 
problems that may occur with a large number of backups. It is recommended 
that the default be left at 5, unless engineering information is available

When the current configuration backup has been used, you can perform the 
node recovery functions for Passport 7400, 15000, and 20000 nodes with 
PCR 5.1 or later.

Overview of current configuration backup
In this Backup mode, the Backup Server retrieves the most current 
configuration of the switch. A current configuration is the combination of the 
committed configuration and activations that have occurred on that switch. It 
is not possible in all cases to retrieve all of the current configuration.

In the case where on-switch journaling is enabled, the Backup Server 
retrieves the journal files and the committed configuration of the switch. In 
other words, the current configuration is completely backed up to the MDM. 
In addition, the complete current configuration can be synchronized with the 
Administration Database.

However, if journaling is not enabled/available, it is not possible to obtain a 
complete current view. If a user has performed provisioning and activations 
on the switch without saving, then only the committed view can be backed up 
on the MDM. The activations will not be backed up to the MDM, until they 
are saved, activated and a "confirm prov" command has been performed.The 
"confirm prov" command is extremely important in cases where journaling is 
not enabled/available.
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Once the Backup Server retrieves the most current view and journal log files 
from the Passports, and completes their storage to a local disk, it notifies the 
Data Synchronization Server and passes it the view and journal information. 
These notifications trigger the synchronization process.

The Data Synchronization Server compares the view and journal information 
that it receives from the Backup Server with the contents of the view and 
journal information contained in the database to determine if the database is 
synchronized. If the database is not synchronized with this information, the 
Data Synchronization Server initiates the translation of the missing views and 
journals into database compatible format. 

The Data Synchronization Administration tool is used to view 
synchronization activities and basic status information, based on information 
provided by the Data Synchronization Server.

There are two options for configuring your system. These options are defined 
in the configuration file:

• On Alarm with journaling supported uses alarm notification for 
configuration changes from the device to trigger the backup of Passport 
view and journal files. The database can then be synchronized using this 
information. This mode can be used for near-real-time synchronization 
of both backup and database information.

The figure, “Backup server architecture for current configuration backup 
including Database Synchronization” (page 123) shows the sequence of 
events that occur. The Backup server receives an alarm from GMDR 
when a provisioning change is made. This alarm triggers the Backup 
server to start a backup. The Backup Server communicates to the Backup 
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Provider, which sends a request to the Passport to back up the most 
current view name and journal files. The new files are stored on the 
backup site.

On Alarm for complete view (with journaling not supported) is used 
for pre-PCR 5.1 releases. In this case, a complete configuration file is 
transferred for each provisioning confirmation done on each Passport. 
This may cause engineering issues in terms of OAM network and 
workstation capacity, and is not recommended.

The On Alarm option requires that the Backup Server be configured to 
listen to a particular GMDR server, which provides the notification based 
on the alarm information from the node. Without the GMDR server, the 
Backup Server cannot receive the real-time notification of the 
provisioning changes. If the GMDR runs on a different host than the 
Backup Server, you can specify this. See “Interface with GMDR” 
(page 122) for more information.

• On Demand uses a command line trigger to backup Passport views and 
journals. This command line trigger can also be used in a cron job to 
provide a scheduled backup and database capability. If journaling is not 
supported or enabled, the operator must ensure that a save, activate, and 
“confirm prov” has been done to ensure availability of the current view.

Backup Server functionality for current configuration backup
When the Backup Server is started with the -notification option, it initiates a 
backup for the devices that have On_Alarm set to True, whenever it receives 
a commit, confirm, reset or node reconnect alarm. The following information 
is obtained from the Passport:

• committed view name

• number of journals

• current view name

• journalDisabledReason attribute

• restorePossible attribute

• activation time = (in this case, activation time is the d prov time of the last 
journal backup)
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This information is stored in the recovery.INFO file. The Backup Server 
compares this information with what has already been backed up and then 
transfers the necessary view and journal files.

When journaling is not enabled, the Passport sends only Confirm and Node 
Reconnect alarms. When the Backup Server receives the Confirm and Node 
Reconnect alarms, it recovers the current view from the Passport. The 
customer must save, activate, and confirm prov to ensure that a current view 
is available.

In this case, the current view has a valid name. The Backup Server checks if 
it already has the backed up file, and if not, it transfers the file to the backup 
site. There are no journals to be transferred.

To trigger a backup of all the Passports simultaneously, you can edit the 
DataSync.cfg file to give all the Passport nodes the same group label and 
execute the command /opt/MagellanNMS/bin/nsbck -demand without 
specifying a group. Note that this is not recommended due to possible 
engineering and performance impacts. The maximum number of Passports in 
a group is 50.

The actual FTP backup session is performed the same as an FTP backup 
triggered by an alarm with On Alarm. 

Backup site directory structure
The journal files are stored by the Backup tool in a subdirectory of the view 
they are associated with. If a new set of journal log files is created for the same 
view, another journal directory is created.

The naming convention for the journal directories is <timestamp>journal. 
The timestamp comes from the Passport file system and is the creation date 
of the file.

/provisioning/journal/current/journalView

This directory is created with the first journal log file.
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The following files are also created on the backup site:

• “view.INFO file” (page 117)

• “recovery.INFO file” (page 117)

• “avl.INFO file” (page 117)

view.INFO file
A view.INFO file is created on the Backup site for each view. This file 
contains the name of the base view as stored on the Backup site, and enables 
the association of the proper base view to a delta view. For each backup or 
restore, the tool checks if the base view is on the Backup site. If not, it will 
backup or restore it. The base view is a portable or complete view.

The format of the file is as follows:

BASE_NAME <timestamp>.<viewname>

For example:
BASE_NAME 200301261812228.view1.full.001

The view.INFO file is located on the backup site with the view. For example, 
a named view1.full.001 on a Passport NODE1 is found at the following 
location:

/opt/MagellanNMS/data/Backup_Data/Passport/NODE1/
200301261812228.view1.full.001/view.INFO

recovery.INFO file
A recovery.INFO file is also generated during each backup. This file contains 
the committed view name, the current view name, the journal directory name, 
the number of journal files, and two values: restorePossible and journalStatus. 
These two values come from the switch at the time when the backup was 
done. When a Node Recovery is performed, it reads this recovery.INFO file 
in order to restore the needed information. 

avl.INFO file
The recovery.INFO file and the avl.INFO file are MDM-specific files and are 
created by the Backup Server during a backup. These files do not exist on the 
Passport and are used by the Node Recovery tool to recover a Passport node 
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on a replacement Passport. When a node is recovered, the software that is 
being run must be downloaded to the replacement Passport. Therefore, each 
backup must also contain the current AV list. This information is stored in a 
new file called avl.INFO.

Configuration Editor window
The Configuration Editor allows you to edit the DataSync.cfg file. You can 
launch the Configuration Editor from Server Administration Tool.

The editor has two panes. The left pane displays the symbol for the server 
which can be expanded to display a tree hierarchy which lists all the devices 
or groups of devices. Each device or group element can be expanded to 
display three parameter categories. The right pane displays the parameters 
contained in the selected category. 

Data Synchronization file parameters
The following table describes each of the backup and restore-related fields 
contained in the DataSync.cfg file.

Table 3
Data Synchronization file parameters for Backup Server

Category Field Description Default

BackupServer port Option to specify the Backup 
server port, to communicate with.

5050

dataDir Option to specify the backup data 
directory where the views and/or 
journals are stored. 

/opt/Magellan/
NMS/data/
Backup_Data

Authentication username Username to access device

 password Password to access device

usePasswordFile Determines if a password file is 
used for access to the account

false

 passwordFile Path to the file that contains an 
encrypted password

 (Sheet 1 of 2)
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BackupOptions onAlarm Determines if the devices in the 
group are backed up when the 
sever receives a configuration 
event from a device

true

DBSync Options enabled Determines if a dbsynchcontroller 
is notified when the device is 
backed up true

true

server Name of the server to notify when 
a device is backed up

Table 4
DBSyncController configuration file parameters

Category Field Description Default

DBSyncController name Option to specify the name of the 
DBSync Controller.

hostname

port Option to specify the port that the 
DBSyncControler listens to.

5757

maxParallelUpdates Option to limit the number of 
simultaneous updates by the 
DBSyncController that can occur

5

mode Option to specify which database 
(“config”, “admin”, or “both”) to be 
updated/synchronized.

Both

connection-Timeout Option to specify the time-out 
value which server attempts to 
connect to the Backup Server

45

 (Sheet 1 of 3)

Table 3
Data Synchronization file parameters for Backup Server (Continued)

Category Field Description Default
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 username and 
epassword

You must enter a user name and 
an encrypted password.

If only the Administration 
Database is used, enter the user 
name and encrypted password 
for the account that owns the 
Administration Database.

If the Configuration Repository is 
used, or if both the Administration 
Database and Configuration 
Repository are used, enter the 
user name and encrypted 
password for the account that 
owns the Configuration 
Repository.

 

 dataDir Option to specify the directory 
where the DBSyncController data 
are stored

AutoDiscovery autoDiscovery Option to specify whether or not 
automatic discovery is enabled. 

false

Logging logErrorToFile Option to specify logging 
DBSyncController errors to file

true

 logFileName Name of the log file /opt/
MagellanNMS/
data/dbsync/
dbsync.log

PPConfigServer host Option to specify the host name 
or ip of the Passport 
Configuration server to 
communicate with.

localhost

port Option to specify the Passport 
Configuration (PCS) server port, 
to communicate with.

6760

Table 4
DBSyncController configuration file parameters (Continued)

Category Field Description Default

 (Sheet 2 of 3)
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dataDir Option to specify where the 
PPConfigServer data are stored.

/opt/
MagellanNMS/
data/fps

Operational Data dataDir Option to specify the directory 
where the operational data are 
stored.

/opt/
MagellanNMS/
data/opcoll

schema Option to specify the operational 
data schema

/opt/
MagellanNMS/lib/
cfg/
opdbcoll.schema

BackupServer host Option to specify the Backup 
server host name or IP address, 
to communicate with

localhost

port Option to specify the Backup 
server port, to communicate with.

5050

dataDir Option to specify the backup data 
directory where the views and/or 
journals are stored. 

Note:  

/opt/Magellan/
NMS/data/
Backup_Data

deviceConfigFile Option to specify the device 
configuration file directory.

/opt/
MagellanNMS/
cfg/
BackupNodes.cfg

Note:  If there is more than one Backup server, you need to specify the above parameters for each 
of them.

Table 4
DBSyncController configuration file parameters (Continued)

Category Field Description Default

 (Sheet 3 of 3)
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Interface with GMDR
The GMDR process must be available whenever an On_Alarm backup must 
occur. The GMDR process ensures that the Backup Server is notified of a 
provisioning change on the Passport.

GMDR sends alarms to the Backup Server when a notification alarm is 
received from the Passport. If GMDR runs on a different host than the Backup 
Server, you can specify the GMDR host with the option -gmdrhost as follows:

/opt/MagellanNMS/bin/nsctlbck -notification -gmdrhost 
<hostname>

Data synchronization
If synchronization has been specified in the DataSync.cfg file, the Database 
Synchronization server is notified that a backup has occurred. For more 
information on this capability, see “Current Configuration Backup” 
(page 87). For more information on the Administration Database, see 
241-6001-400 Preside MDM Administration Database User Guide.
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Figure 11
Backup server architecture for current configuration backup including Database 
Synchronization

Node recovery
If the Current configuration mode of backup is used, the system has the 
additional functionality to recover the most current view from the backup site 
and restore this information, potentially to a replacement Passport. It is also 
used as input for database synchronization.

Data Synchronization
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This functionality is available only for Passport 7400, 15000, and 2000 nodes 
with PCR 5.1 or higher. See “Current Configuration Recovery” (page 99).
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Backup and Restore logs
The OAMC server collects logs from the Backup Controller and the Restore 
Controller. These logs can also be sent directly to a log file. See the diagram 
“Backup and Restore log collection” (page 125). The Backup Controller logs 
are stored in /opt/MagellanNMS/data/log/bckRst/backup.dlog. The Restore 
Controller logs are stored in /opt/MagellanNMS/data/log/bckRst/
restore.dlog. Logging is automatically enabled as a default. The default log 
levels included are error, warning and notice.

Figure 12
Backup and Restore log collection
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Passport Service Data Backup/Restore tool

The Passport Service Data Backup/Restore tool provides a GUI that is used 
to backup the configuration data for the devices in your network, to restore 
configuration data that is lost or corrupted, and to recover the complete 
configuration data in the event of a catastrophic data loss or corruption.

Navigation
• “Passport Service Data Backup/Restore GUI” (page 128)

ATTENTION Use this tool with Passport 6000, 7400, 15000, and 20000 
devices. For Passport 4400 and 4460 SNMP devices, see 
“Passport/SNMP Service Data Backup/Restore tool” 
(page 133).
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Passport Service Data Backup/Restore GUI
The Passport Service Data Backup and Restore is launched from the Preside 
MDM toolset under Configuration->Passport->Administration-
>Passport Service Data Backup/Restore.

The main window of the interface consists of the following sections:

• “Menu bar” (page 128)

• “Function tabs” (page 129)

Menu bar
The menu bar is located at the top of the main window. See the following 
sections for information on the menu bar entries:

• “File menu” (page 128)

• “Options menu” (page 128)

• “Tools menu” (page 129)

• “Help” (page 129)

File menu
The File menu contains the following items:

• Reconnect reconnects you to the administration database.

• Exit exits the Backup/Restore interface.

Options menu
The Options menu contains the following items:

• Set Default Authentication opens a dialog where you enter a default 
userid and password that is used to connected to the selected nodes unless 
you enter a specific userid and password.

• Set Software Distribution Site opens a dialog where you can edit the host, 
userid and password for the software distribution site (SDS). The SDS is 
used to download software to a node when using the node recovery 
mode.

• Edit Server Configuration opens a dialog allowing the user to change the 
following:
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— backup server host name: name of backup server

— backup server port number: port number of backup server

— backup directory: path to location of backed up data

— restore server host name: name of restore server

— restore server port number: port number of restore server

— restore directory: path to location of restored data

Tools menu
The Tools menu contains the following items:

• Backup Current Configuration opens the Backup Current 
Configuration window. You use this window to perform a current view 
backup of a group of devices.

Help
The Tools menu contains the following item:

• Help on Window displays online documentation describing the Passport 
Backup and Restore window.

• What’s this changes your cursor to an arrow with a question mark. 
Pointing the arrow at certain items in the window and clicking the item 
opens help on that item.

Function tabs
Three tabs are available to select the required tool function. Selecting a tab 
displays a panel containing a device list, device details, and messages sections 
appropriate to the function.

• “Backup Configuration panel” (page 129)

• “Restore Configuration panel” (page 130)

• “Recover Device panel” (page 131)

Backup Configuration panel
The Backup Configuration panel consists of three sections: Device List, 
Device Details, and Messages. You can click the arrow beside each section 
label to display or hide the section. 
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Device List
The Device List consists of four columns. The columns are populated when 
you use the Add command button to add the device(s) that you want backed 
up.

Device Details
The Device Details section contains the Authentication panel which displays 
userid and passwords you entered when you added the device using the Add 
command button. 

Messages
The Messages section of the Backup window displays information about the 
Backup process. The text in the Messages section is recorded in the log file 
located in $HOME/MagellanNMS/bkRst.log.

Restore Configuration panel
The Restore Configuration window displays a list of devices you have 
selected to restore the configuration views back to the device. 

The Restore Configuration panel consists of three sections: Device List, 
Device Details, and Messages. You can click the arrow beside each section 
label to display or hide the section. 

Device List
The Device List consists of five columns. The columns are populated when 
you use the Add command button to add the device(s) that you want backed 
up.

Table 5
Backup configuration panel device list

Column Description

Type Device type e.g. Passport

Device Device name

Mode Backup mode (incremental, selective, or full)

Configuration View of the device to be used for selective backup.
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Device Details
The Device Details section contains the Authentication panel which displays 
userid and passwords you entered when you added the device using the Add 
command button. 

Messages
The Message section of the Restore window displays information about the 
Restore process.

Recover Device panel

The Recover Device window displays a list of devices you want to recover 
back to their last known configuration. Recover detects the last configuration 
data backed up for the device, restores the configuration information and the 
software as well as resets the switch to bring the configuration into service.

The Device Details section of the Recover window has three tabs that you can 
select: 

• Authentication displays userid and passwords for the selected node

• Configuration displays Journal status information for the selected node

Table 6
Restore configuration panel device list

Column Description

Type Device type e.g. Passport

Device Device name

Mode Backup mode (incremental, selective, or full)

Configuration View of the device to be used for selective backup.

Date Used in incremental mode. All views before or equal to that date are 
restored if they are not already on the device.

To Device The node where the configuration is to be restored.

ATTENTION The recover capability is available only if you used current 
configuration backup.
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• Application Versions displays the list of software on the Passport at the 
time of the latest backup.

The Messages section of the Recover window displays information about the 
recover process. See “Current Configuration Recovery” (page 99).

Command buttons
All the function tab panels contain the following command buttons: 

• Add opens the Add Device dialog which allows you to select a device and 
enter the default authentication information for the device. The Backup 
Configuration and Restore configuration Add Device dialog allows you 
to select either incremental or full mode.

• Remove removes the selected node from the list.

Each of the Backup Configuration, Restore Configuration, and Restore 
Device panels contains its respective command button to initiate the 
appropriate task, as follows:

• The Backup Configuration panel Backup command button initiates a 
backup on all the nodes selected in the Device List.

• The Restore Configuration panel Restore command button restores the 
data for the nodes selected in the Device List.

• The Recover Device Recover command button initiates a recover on all 
the nodes selected in the Device List.
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Passport/SNMP Service Data Backup/Restore 
tool

Use Passport/SNMP Service Data Backup and Restore to perform basic 
backup and restore for Passport 4400 and Passport 4460 nodes using the 
SNMP protocol. 

The Passport Service Data Backup and Restore is launched from the Preside 
MDM toolset under Configuration->Passport 4400->Administration-
>Passport/SNMP Service Data Backup/Restore.

Passport/SNMP Devices Backup and Restore window
The Passport/SNMP Devices Backup and Restore tool lets you back up and 
restore service data on Passport 4400 and 4460 SNMP devices. You can 
choose full, incremental, or selected backup and restores for single or 
multiple devices. You can also perform a Node Recover for a replacement 
Passport in the event of a disaster.

The figure “Passport/SNMP Devices Backup and Restore window” 
(page 134) shows a sample window.
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Figure 13
Passport/SNMP Devices Backup and Restore window

The Passport/SNMP Devices Backup and Restore window consists of the 
following components:

• “Menu bar” (page 134)

• “Configuration file area” (page 135)

• “Devices area” (page 135)

• “Command buttons” (page 144)

Menu bar
The menu bar is located at the top of the main window. See the following 
sections for information on the menu bar entries:

• “File menu” (page 134)

• “Options menu” (page 135)

• “Help menu” (page 135)

File menu
The File menu contains the following items:

• Open opens the Open File dialog. From this dialog, you can set the device 
information file that Passport/SNMP Devices Backup and Restore uses. 
For more information, see “Open File dialog” (page 136).
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• Exit exits Passport/SNMP Devices Backup and Restore.

Options menu
The Options menu contains the following items:

• Change Backup Options opens the Change Backup Options dialog. From 
this dialog you can set Controller information and the target directory for 
the backup data. For more information, see “Change Backup Options 
dialog” (page 138).

• Change Restore Options opens the Change Restore Options dialog. From 
this dialog you can set Controller information and the source directory 
for the restore data. For more information, see “Change Restore Options 
dialog” (page 139).

• Save Options saves, for future sessions, the current device information 
file and the changes you make in the Change Backup Options and 
Change Restore Options dialogs. This information is saved in the 
preferences file $home/.NS/.nsOptions where $home is your home 
directory.

Help menu
The Help menu contains the following item:

• Help On Window displays online documentation describing the Passport/
SNMP Devices Backup and Restore window.

Configuration file area
This display field shows the name of the device information file in use by 
Passport/SNMP Devices Backup and Restore. You can use the Open option 
of the File menu to select another device information file.

Devices area
The devices listed in the current device information file are displayed in this 
area. Group names are indicated by filled folder icons. You can display the 
device names contained in a group by double-clicking the group name. 
Device names are indicated by blank page icons.

You can select single devices or groups of devices to back up, restore or 
recover by clicking on the device or group names. Selected entries are shaded. 
You can change an entry from selected to unselected by clicking on it.
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Command buttons
The Passport/SNMP Devices Backup window contains the following 
command buttons:

• Backup
The Backup button opens the Passport/SNMP Backup window. For more 
information, see “Basic service data backup” (page 47).

• Restore
The Restore button opens the Passport/SNMP Restore window. For more 
information, see “Basic service data restore” (page 69).

• Node Recover
The Node Recover button opens the Passport Devices Node Recovery 
window. For more information, see “Current Configuration Recovery” 
(page 99).

• Exit
The Exit button exits the Passport/SNMP Devices Backup and Restore 
tool.

Passport/SNMP Devices Backup and Restore startup dialogs
There are three dialogs that allow you to edit default information before 
performing backup and restore operations. These dialogs are

• “Open File dialog” (page 136)

• “Change Backup Options dialog” (page 138)

• “Change Restore Options dialog” (page 139)

Open File dialog
The Open File dialog (from the File menu) enables you to select the device 
information file used by Passport/SNMP Devices Backup and Restore. You 
can enter the absolute path and file name or select the file from the display 
panel.

The Open File dialog opens at the default directory /opt/MagellanNMS/data/
nst.

To save your changes for future sessions, from the Passport/SNMP Devices 
Backup and Restore menu, select Options->Save Options.
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The Open File dialog consists of six areas:

• the Look in pull-down box displays the directory hierarchy for the 
current disk. You can change directories using this pull-down box by 

— clicking on the down arrow to open the box

— proceed up the directory hierarchy by clicking on any directory 
above the current directory

— proceed down the directory on any filled folder icon in the display 
panel

• five buttons that change the display

— the button with an up-arrow through a folder proceeds up the 
directory hierarchy one level

— the button with the house moves the display to your home directory

— the button with a folder, only, creates new sub-directories.

— the four icon button lists files in the current directory

— the two icon button displays file details for the current directory

• Use the central display to select a device information file by clicking on 
the file. The central display panel shows 

— sub-directories of the current directory using filled folder icons

— files in the current directory using blank page icons

• a data entry box where you enter the absolute path and device file name. 
If you select a file using the display panel, the selected file name is 
indicated in this data entry box.

• a pull-down box to specify the type of files to display. The default is all 
files in the current directory are displayed.

• two buttons to open or close (cancel) the Open File dialog

— Open loads the selected file and returns to the Passport/SNMP 
Devices Backup and Restore main window.

— Cancel closes the Open File dialog without loading a file.
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The figure “Open File dialog” (page 138) shows an example of the Open File 
dialog.

Figure 14
Open File dialog

Change Backup Options dialog
The Change Backup Options dialog enables you to select 

• the Controller that Passport/SNMP Devices Backup and Restore 
accesses when backing up service data

• the Controller port that Passport/SNMP Devices Backup and Restore 
uses when backing up service data

• the target directory where the backed up service data is stored

The OK button closes the Change Backup Options dialog. To save your 
changes for future sessions, click OK, and from the Options menu on the 
menu bar, select Save Options. 

The figure “Change Backup Options dialog” (page 139) shows an example of 
the Change Backup Options dialog.
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Figure 15
Change Backup Options dialog

Change Restore Options dialog
The Change Restore Options dialog enables you to select 

• the Controller that Passport/SNMP Devices Backup and Restore 
accesses when restoring service data

• the Controller port that Passport/SNMP Devices Backup and Restore 
uses when restoring service data

• the source directory for the service data to be restored

The OK button closes the Change Restore Options dialog. To save your 
changes for future sessions, click OK, and from the Options menu on the 
menu bar, select Save Options. 

The figure “Change Restore Options dialog” (page 140) shows an example of 
the Change Restore Options dialog.
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Figure 16
Change Restore Options dialog
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Passport/SNMP Devices Backup window
The Passport/SNMP Devices Backup window displays relevant backup 
information and provides fields that let you select the devices to backup and 
level of backup. The window also contains a message area that displays status 
information while the backup process executes.

The figure “Passport/SNMP Devices Backup window” (page 141) shows a 
sample backup window.

Figure 17
Passport/SNMP Devices Backup window
Preside MDM Network Backup and Restore User Guide   15.1RSUP



142   Chapter 8 Passport/SNMP Service Data Backup/Restore tool
The Passport/SNMP Devices Backup window consists of the following 
components:

• “Default Backup Information area” (page 142)

• “Controller Information area” (page 142)

• “Backup Information area” (page 143)

• “Backup Mode Selection area” (page 144)

• “Message area” (page 144)

• “Command buttons” (page 144)

Default Backup Information area
The Default Backup Information area contains connection information. There 
is an entry for each different device type in the device information file. Each 
device type that is listed in this area can have the following entries:

• DevType is the device type.

• id (rd community) is the userID for a Passport and the READ community 
string for a Passport 4400/4460.

This field is displayed as a series of asterisks (*). 

• pw (wr community) is the user password for a Passport and the WRITE 
community string for a Passport 4400/4460. 

This field is displayed as a series of asterisks (*).

• Port is the port number of the device.

You can edit any line in this area by double-clicking on it. This action opens 
the Change Default Information dialog.

Controller Information area
The Controller Information area displays the information from the Change 
Backup Options dialog.
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Backup Information area
The Backup Information area contains details about each device available for 
back up. Click on a line in this area to edit it. Make your changes by editing 
other fields on the main window.

Each device has the following entries:

• DevName is the device name.

• id (rd community) is the userID for a Passport and the READ community 
string for a Passport 4400/4460.

This field is displayed as a series of asterisks (*). 

When present, this field overrides the corresponding field in the Default 
Backup Information area. You can edit this field in the id (rd community) 
data entry field immediately below the Backup Information area. A 
backup fails when the device has no id (rd community).

• pw (wr community) is the user password for a Passport and the WRITE 
community string for a Passport 4400/4460. 

This field is displayed as a series of asterisks (*). 

When present, this field overrides the corresponding field in the Default 
Backup Information area. You can edit this field in the pw (wr 
community) data entry field immediately below the Backup Information 
area. A backup fails when the device has no pw (wr community).

• A check mark in the Bck field indicates that this device is to be backed 
up. You can select and deselect any device by double-clicking the line 
containing the device name.

• Mode indicates the type of backup (full, incremental, or selective). You 
can change this field by clicking the appropriate button in the Backup 
Mode Selection area.

• View is the view being backed up by a selective backup. Clicking the sel 
button in the Backup Mode Selection area activates the View and List 
Views fields. You can choose a view file from List Views by double-
clicking on an entry or you can enter a view file name in the View data 
entry field and press Return.
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Backup Mode Selection area
The Backup Mode Selection area contains information about the types of 
backups you can perform. When you edit the fields in this area, you change 
the Mode and View fields of the device that is highlighted in the Backup 
Information area.

This area contains the following fields:

• incr indicates an incremental backup.

• full indicates a full backup.

• sel indicates a selective backup.

• the sel data entry field is where you enter the name of the view file that 
you want to back up. The file entered in this field updates the View field 
in the Backup Information area.

• List Views button lists the view files that are available for selective 
backup. You select a file in this list by double-clicking on an entry. 
Selection of a view from the List Views window updates the contents of 
the View data entry field and the View field in the Backup Information 
area. The List Views button is enabled only when you select the sel 
button.

• the Filter data entry field specifies a search criteria for view files. You can 
match any string of any length by using the wildcard character (*).

Note: The question mark (?) does not function as a wildcard in the Filter 
field. For example, MM?[ab] returns only the view MM?[ab], if it exists.

Message area
The Message area displays messages generated by Passport/SNMP Devices 
Backup during execution.

Command buttons
The Passport/SNMP Devices Backup window contains the following 
command buttons:

• Backup
The Backup button starts the backup process.
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• Cancel
The Cancel button terminates an executing backup. Completed backups 
are kept; backups in progress, or not started, are cancelled.

• Exit
The Exit button closes the Passport/SNMP Devices Backup window.

• Help
The Help button displays online documentation describing the Passport/
SNMP Devices Backup window.

Passport/SNMP Devices Restore window
The Passport/SNMP Devices Restore window displays relevant restore 
information and provides fields that let you select the type of information to 
restore. The window also contains a message area that displays status 
information while the restore process executes.

The figure “Passport/SNMP Devices Restore window” (page 146) shows 
sample restore window.
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Figure 18
Passport/SNMP Devices Restore window

The Passport/SNMP Devices Restore window consists of the following 
components:

• “Default Restore Information area” (page 147)

• “Controller Information area” (page 142)

• “Backup Information area” (page 143)

• “Backup Mode Selection area” (page 144)

• “Message area” (page 144)

• “Command buttons” (page 144)
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Default Restore Information area
The Default Restore Information area contains connection information. There 
is an entry for each different device type in the device information file. Each 
device type that is listed in this area can have the following entries:

• DevType is the device type.

• id (rd community) is the userID for a Passport and the READ community 
string for a Passport 4400/4460.

This field is displayed as a series of asterisks (*). 

• pw (wr community) is the user password for a Passport and the WRITE 
community string for a Passport 4400/4460. 

This field is displayed as a series of asterisks (*).

• Port is the port number of the device.

You can edit any line in this area by double-clicking on it. This action opens 
the Change Default Information dialog.

Controller Information area
The Controller Information area displays the information from the Change 
Restore Options dialog. 

Restore Information area
The Restore Information area contains details on each device available for 
restore. Click on a line in this area to edit it. Make your changes by editing 
other fields on the main window.

Each device has the following entries:

• DevName is the device name.
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• id (rd community) is the userID for a Passport and the READ community 
string for a Passport 4400/4460.

This field is displayed as a series of asterisks (*). 

When present, this field overrides the corresponding field in the Default 
Restore Information area.You can edit this field in the id (rd community) 
data entry field immediately below the Restore Information area. A 
restore fails when the device has no id (rd community).

• pw (wr community) is the user password for a Passport and the WRITE 
community string for a Passport 4400/4460. 

This field is displayed as a series of asterisks (*). 

When present, this field overrides the corresponding field in the Default 
Restore Information area. You can edit this field in the pw (wr 
community) data entry field immediately below the Restore Information 
area. A restore fails when the device has no pw (wr community).

• A check mark in the Rst field indicates that this device is to have service 
data restored. You can select and deselect any device by double-clicking 
the line containing the device name.

• Mode indicates the type of restore (full, incremental, or selective). You 
can change this field by clicking the appropriate button in the Restore 
Mode Selection area.

• View is the view being restored by a selective backup. Clicking the sel 
button in the Restore Mode Selection area activates the View and List 
Views fields. You can choose a view file from List Views by double-
clicking on an entry or you can enter a view file name in the View data 
entry field and press Return.

Restore Mode Selection area
The Restore Mode Selection area contains information about the types of 
restores you can perform.When you edit the fields in this area, you change the 
Mode and View fields of the device that is highlighted in the Restore 
Information area.
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This area contains the following fields:

• incr indicates an incremental restore.

• the Date data entry field is an option for an incremental restore. You enter 
a date with the format yyyymmdd to have Passport/SNMP Devices 
Restore restore the service data backed up on that date. You can specify 
the time with format yyyymmddhhmmss.

When there are no backups for the date specified, Passport/SNMP 
Devices Restore restores the service data backed up on the date closest 
to, but not exceeding, the specified date. If there is more than one backup 
for the specified date and you have not specified the time, 
Passport/SNMP Devices Restore restores the latest backup on the 
specified date. If you do not use this field, the incremental restore is the 
same as a full restore.

• full indicates a full restore.

• sel indicates a selective restore.

• the sel data entry field is where you enter the name of the view file that 
you want to restore. The file entered in this field updates the View field in 
the Restore Information area.

• List Views button lists the view files that are available for selective 
restore. You select a file in this list by double-clicking on an entry. 
Selection of a view from the List Views window updates the contents of 
the View data entry field and the View field in the Restore Information 
area. The List Views button is enabled only when you select the sel 
button.

• the Filter data entry field specifies a search criteria for view files.You can 
match any string of any length by using the wildcard character (*).

Note: The question mark (?) does not function as a wildcard in the Filter 
field. For example, MM?[ab] returns only the view MM?[ab], if it exists. 

Message area
The Message area displays messages generated by Passport/SNMP Devices 
Restore during execution.
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Command buttons
The Passport/SNMP Devices Restore window contains the following 
command buttons:

• Restore
The Restore button starts the restore process.

• Cancel
The Cancel button terminates an executing restore. Completed restores 
are kept; restores in progress, or not started, are cancelled.

• Exit
The Exit button closes the Passport/SNMP Devices Restore window.

• Help
The Help button displays online documentation describing the Passport/
SNMP Devices Restore window.

Change Default Information dialog
The Change Default Information dialog is the only Passport/SNMP Devices 
Restore dialog other than the main window. You can use this dialog to change 
the information contained in the Default Restore Information area of the main 
window. For more information about the Default Restore Information area, 
see “Backup Information area” (page 143).

The figure “Change Default Information dialog” (page 150) shows an 
example of the Change Default Information dialog.

Figure 19
Change Default Information dialog
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