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C h a p t e r  1

How to get help

This section explains how to get help for Nortel products and services.

Getting help from the Nortel Web site

The best way to get technical support for Nortel products is from the Nortel 
Technical Support Web site:

www.nortel.com/support

This site provides quick access to software, documentation, bulletins, and 
tools to address issues with Nortel products. From this site, you can:

download software and related tools
download technical documents, release ntoes, and product bulletins
sign up for automatic notification of new software and documentation
search the Technical Support Web site and Nortel Knowledge Base for 
answers to technical issues
open and manage technical support cases

Getting help over the phone from a Nortel Solutions Center

If you do not find the information you require on the Nortel Technical 
Support Web site, and you have a Nortel support contract, you can also get 
help over the phone from a Nortel Solutions Center. 

In North America, call 1-800-4NORTEL (1-800-466-7835).

http://www.nortel.com/support
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Outside North America, go to the following Web site to obtain the phone 
number for your region:

www.nortel.com/callus

Getting help from a specialist by using an Express Routing 
Code 

You can use an Express Routing Code (ERC) to quickly route your call to 
the appropriate support specialist. To locate the ERC for your product or 
service, go to:

www.nortel.com/erc

Getting help through a Nortel distributor or reseller 

If you purchased a service contract for your Nortel product from a 
distributor or authorized reseller, contact the technical support staff for that 
distributor or reseller.

http://www.nortel.com/callus
http://www.nortel.com/erc
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Subject

Use this Nortel Technical Publication (NTP) in conjunction with other NTPs 
issued in support of Call Center Management Information System 
(CC MIS).

This guide provides an overview of the CC MIS Supervisor interface. For 
additional detail about CC MIS functions, see the CC MIS online Help.

Note: This guide does not cover the System Administration functions 
accessed from the Admin menu on the main window. Information 
concerning the use of these functions is presented in the CC MIS online 
Help, which is accessed from any window in the CC MIS product.

Applicable systems

This document applies to systems that run the CC MIS client.

Intended audience

This guide is for supervisors who are new to the CC MIS product and 
provides the basic steps and information needed to quickly access all major 
functions available to a supervisor terminal. 

How to use this guide
This NTP provides descriptive information about CC MIS, including the 
following information: 

Chapter 2, “About this document”—Provides an overview of this NTP 
and lists the documentation related to the product.
Chapter 3, “Online Help windows”—Provides information about the 
Help system, which gives you information about using the CC MIS 
product and its windows to perform functions.
Chapter 4, “Accessing CC MIS using the Supervisor interface”—
Provides information to connect and log on to the CC MIS Supervisor 
interface. This chapter also discusses Client Services.
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Chapter 5, “CC MIS main window functions”—Provides information 
about the functions provided in the CC MIS main window.
Chapter 6, “Agent Status display”—Provides information about the 
Agent Status display, which is used to gather information about the status 
of each position in an Automatic Call Distribution (ACD) group.
Chapter 7, “Queue Statistics display”—Provides information about the 
Queue Statistics display, which is used to gather information about the 
efficiency with which an ACD group handles calls.
Chapter 8, “Wallboard messages”—Provides information to create 
wallboard messages and displays.
Chapter 9, “SNMP alarms”—Provides information about the Alarms 
Definition window.
Chapter 10, “Historical reports”—Provides information about generating 
reports based on historical data.
Chapter 11, “Configuration Control”—Provides information about 
configuration control functions.
Chapter 12, “System reports”—Provides information about reports that 
are derived from the system database. 

Related information

This section explains where to find additional information about CC MIS.

NTPs
Where appropriate, references to documents specific to a particular 
component are listed in the description sections.
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For more information about CC MIS, see the following NTPs: 

CC MIS System Description (297-2671-150)
CC MIS Release Notes (297-2671-211)
CC MIS Installation and Maintenance (297-2671-545)

Online

To access Nortel documentation online, click the Technical Documentation 
link under Support on the Nortel home page:

www.nortel.com/documentation

CD-ROM
To obtain Nortel documentation on CD-ROM, contact your Nortel customer 
representative.

http://www.nortel.com/documentation
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Features in Release 6.0

The CC MIS Supervisor interface in Release 6.0 provides the following 
changes and enhancements:

Individual walkaway code thresholds—The Walkaway Code Definition 
window includes an optional code-specific threshold field where you can 
assign various thresholds to each walkaway code. This change affects 
when a position in the walkaway state is highlighted on the Agent Status 
display. In previous releases, positions in walkaway state were 
highlighted based on the single walkaway threshold value associated 
with the ACD group of the position. This functionality remains the 
default in Release 6.0, but you now have some flexibility to determine 
when a position in the walkaway state enters a highlighted state.
System reports to e-mail or file destinations—You can send CC MIS 
system reports (reports that provide a listing of various CC MIS database 
tables) to files on disk or to e-mail in the same way you currently send 
historical reports.
Report delimiters for reports saved as files—In the Client Services Filing 
tab, you can specify a text file to be prepended to each report that is 
saved to disk. The text in this file can be a parsing delimiter if the report 
is sent to an external system for processing.
Use of Windows Installer for the CC MIS Client Setup program—The 
CC MIS Client Setup program uses the Microsoft Windows Installer 
program instead of InstallShield. The operation and use of the setup 
program remains largely the same; however, the user interface presented 
in the installation program is slightly different.
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Sending reports as e-mail from the server— You can generate reports as 
e-mail messages directly from the CC MIS server without requiring the 
report to be sent from an e-mail account that is accessible to one or more 
CC MIS clients. This feature increases security and eliminates the need 
to have a selected CC MIS client running at all times. Only the Linux 
platform supports this functionality.
Note: This feature requires that the Linux Sendmail program is properly 
configured on the server. This capability is provided on a partition-by-
partition basis through a new setting in the Partition Options window of 
the CC MIS Configuration utility.
Security banner—The Customer Options window includes an option to 
enable or disable the display of a security banner dialog upon successful 
connection to the server or upon each successful supervisor logon. 
Default text for the security banner is provided. You can modify the 
default text through the Customer Options window. The default security 
banner text is as follows:

WARNING!  This computer system and network is PRIVATE 
and PROPRIETARY and may only be accessed by authorized 
users.  Unauthorized use of this computer system or 
network is strictly prohibited and may be subject to 
criminal prosecution, employee discipline up to and 
including discharge, or the termination of vendor/
service contracts.  The owner, or its agents, may 
monitor any activity or communication on the computer 
system or network.  The owner, or its agents, may 
retrieve any information stored within the computer 
system or network.  By accessing and using this 
computer system or network, you are consenting to such 
monitoring and information retrieval for law 
enforcement and other purposes.  Users should have no 
expectation of privacy as to any communication on or 
information stored within the computer system or 
network, including information stored locally or 
remotely on a hard drive or other media in use with 
this computer system or network.



May 2007 About this document

CC MIS Getting Started Guide (Supervisor Interface) 19

The Security Banner window has OK and Cancel buttons to close the 
dialog box (see Figure 18 on page 39). If you click the Cancel button, the 
connection or logon action is cancelled.
Note: You can provide a security banner on the Maintenance interface by 
creating a text file named /etc/motd. This file, if it exists, appears 
immediately after the logon of a Linux user but before the shell starts.
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C h a p t e r  3
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Introduction

Help is available from any window within the CC MIS. The Help system 
provides information about using the CC MIS product and its windows to 
perform functions.

Note: On a multilingual system, the Help system uses the current language 
of interaction.

Help options

The following three Help options (see Figure 1) are available from the Help 
menu on most CC MIS windows: 

Help Topics (see page 23)
Window (see page 26)
Using Help (see page 27)

Figure 1: Help menu
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Help Topics

Procedure 1: Displaying Help Topics

1 Select the Help > Help Topics command (see Figure 1 on page 22).

The Help Topics: CC MIS Help window appears (see Figure 2). This 
window shows all Help topics available for CC MIS. Help topics are 
nested.

Figure 2: Help Topics: CC MIS Help window
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2 Double-click any Help topic (see Figure 3).

Relevant subtopics are listed under each selected topic. These subtopics 
relate to the selected main Help topic. 

Figure 3: Expanded Help topic 
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3 Select any subtopic (for example, Communications Setup), and a Help 
window appears with information about that topic (see Figure 4).

Figure 4: Help subtopic window
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Window

Select Help > Window from the Help menu to open a window that contains 
information for the active window on your terminal.

Figure 5 shows an example of a Help window.
Figure 5: Help window
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Using Help

Select Help > Using Help from the Help menu to open a window that 
contains information about using the Windows Help. 

Figure 6 shows an example of the Using Help window.
Figure 6: Using Help window

This window provides access to information about how to use the Windows 
Help function. You can also customize the Help windows. 
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System Administrator symbol

Some pages in the online Help are marked with the System Administrator 
symbol ( ). This symbol indicates that you can use a particular function 
only if you are in System Administration mode (and only if your privilege 
level allows you to access the function). 

To enter System Administrator mode, from the CC MIS main window, 
select Admin > Access. Then enter the System Administrator password. 
Select the Admin > Access command again to return to normal mode, to 
protect the System Administrator functions.
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C h a p t e r  4
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Introduction

A key step in using CC MIS is learning how to connect to the CC MIS 
server, and how to log on and log off of the supervisor terminal. 

This chapter contains the following topics:

connecting to the system (see page 31)
downloading software upgrades (see page 35)
logging on to and off of CC MIS (see page 37)
determining if a connection has gone down (see page 41)
setting up Client Services (see page 42)
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Connecting to the CC MIS server

To begin using the CC MIS Supervisor interface, you must first connect to 
the CC MIS server. To connect, you must set up a communications profile 
using the Communications Setup window.

After you establish a communications profile, it is saved on disk and used 
each time you start the CC MIS Supervisor interface. 

Access the Communications Setup window at any time to perform the 
following tasks:

Make changes to your communications settings.
Create an additional profile if you need to regularly access more than one 
CC MIS server. 
Note: If multiple communications profiles exist, the last profile used is 
reloaded whenever the CC MIS Supervisor interface restarts.

Access the Communications Setup window using the steps in Procedure 2 
on page 32.
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Procedure 2: Accessing communication parameters

1 From your desktop, double-click the Call Center MIS 6.0 icon (see 
Figure 7) to launch the CC MIS Supervisor interface.

Note: You can also launch CC MIS from the Start menu by selecting 
Start > Programs > Call Center MIS.

Figure 7: Call Center MIS program icon

Note: The icon shown in Figure 15 is a sample icon. The name of the 
icon on your desktop or in the Start menu can be different.

The CC MIS main window appears and the application attempts to 
connect to the CC MIS server.

2 Click Session, and select Setup > Communications (see Figure 8).

Figure 8: Session > Setup > Communications

The CC MIS Communications Setup dialog box appears (see Figure 9 
on page 33).
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Figure 9: CC MIS Communications Setup dialog box

The CC MIS Communications Setup dialog box allows you to define one 
or more communication profiles, which store the connection setup 
parameters used to connect to a CC MIS system. 

3 See the CC MIS online Help for the Communications Setup field 
descriptions and enter changes as required.

4 Click OK.

If the communications are properly established, the CC MIS main 
window is similar to Figure 10 on page 34, and the Connection Status 
icon appears. For more information, see “Connection Status icon” on 
page 34.
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Connection Status icon

When you are properly connected, a green border surrounds the Connection 
Status icon in the CC MIS main window (see Figure 10).
Figure 10: CC MIS main window—connected 

The Connection Status icon on the CC MIS main menu appears slightly 
different when the Networking feature is enabled and you log on to a 
Network Access Partition (NAP) (see Figure 11).
Figure 11: Connection Status icon (when Networking is enabled)

If you are not connected to the CC MIS server, a red border surrounds the 
Connection Status icon (see Figure 12).
Figure 12: CC MIS main window—not connected
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Automatic download of software upgrades

Each time the CC MIS client connects to the server, a check determines if 
the version of the client software matches the version of the server software. 
If a mismatch occurs, the Version Mismatch Detected window appears (see 
Figure 13). The Version Mismatch Detected window provides an automatic 
upgrade process for the CC MIS client software.

Procedure 3: Downloading software upgrades

1 In the Version Mismatch Detected window, click Download to start the 
upgrade process, and then reply to the prompts. 

Figure 13 shows the Version Mismatch Detected window and the 
Downloading New Software dialog box. The Downloading New Software 
dialog box shows the status of the software download.

Figure 13: Download Mismatch Detected window 

Note: If desired, you can ignore the version mismatch and continue 
using the current version (the Ignore button), you can select another 
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server to connect to (the Change Host button), or you can exit without 
performing the upgrade (the Exit button). Nortel does not recommend 
that you ignore the version mismatch. In some cases, ignoring the 
version mismatch is not an available option. If the application determines 
that the protocol version is different between the client and server, the 
Ignore button appears dimmed.

After the software is downloaded to your computer, the Welcome to the 
Call Center MIS 6.0 Setup Wizard window appears (see Figure 14). 

Figure 14: CC MIS installation of new software version

2 Select the Repair Call Center MIS 6.0 option.

Note: The Remove Call Center MIS 6.0 option removes the software 
from the computer.

3 Click Finish to begin the software installation.

When the installation is complete, log on using Procedure 4 on page 37.
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Logging on and off of the system

This section describes how you log on to, log off from, and exit the CC MIS 
application.

Logging on

Supervisors with profiles established in CC MIS can log on to any 
supervisor terminal. Only one session can run at a time for each supervisor 
ID. If you log on to one terminal and then try to log on at a different 
terminal, you must either override your original logon, causing the CC MIS 
system to log you off the original session, or you must cancel your logon 
attempt and return to the terminal where you are already logged on. 

The steps in Procedure 4 guide you through the logon process on the 
CC MIS supervisor terminal. 
Procedure 4: Logging on to CC MIS

1 From your desktop, double-click the Call Center MIS 6.0 icon (see 
Figure 15) to launch the CC MIS Supervisor interface.

Note: You can also launch CC MIS from the Start menu by selecting 
Start > Programs > Call Center MIS.

Figure 15: Call Center MIS program icon

Note: The icon shown in Figure 15 is a sample icon. The name of the 
icon on your desktop or in the Start menu can be different.
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The CC MIS main window appears and, using the most recently used 
communications profile, the application attempts to connect to the 
CC MIS server (see “Accessing communication parameters” on page 
32). 

2 From the CC MIS main window, select Session > Login.

Note: It can take a few seconds for the Login command to become 
enabled following connection to the server.

Figure 16 shows the Session menu.

Figure 16: Session > Login

The CC MIS Login dialog box appears (see Figure 17).

Figure 17: CC MIS Login dialog box

3 In the CC MIS Login dialog box, perform the following steps:

a. Enter your supervisor Login ID (and Password, if required).

Note: The last supervisor Login ID entered is stored after you log off 
of CC MIS. Therefore, if you log back on to a terminal you were 
previously logged on to (and you have no password), you can click 
OK to log on. 
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b. Identify your Preferences. Preferences include such things as color 
preferences, window locations, and features that are changeable from 
the Preferences menu of any window.

Note: Normally, supervisors leave the default settings for the 
Preferences. However, if you change the settings, you can revert to 
the default setting by selecting the System defaults option. Changes 
to preferences are saved when you log off normally (that is, using a 
graceful logoff).

Also, if Supervisor A likes Supervisor B’s settings, Supervisor A can 
choose the Other supervisor option and supply Supervisor B’s ID to 
have all of Supervisor B’s preferences loaded at the start of the 
session. To do this, enter Supervisor B’s ID in the box adjacent to the 
Other supervisor option (see Figure 17).

c. Click OK.

4 Click OK to close the Security Notice dialog box (see Figure 18) if it is 
displayed. The Security Notice dialog box appears only if the Display at 
login Security Banner option is set.

Figure 18: Security Notice dialog box
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The CC MIS main window appears upon successful logon (see 
Figure 19).

Figure 19: CC MIS main window

Logging off

To log off your session, use the steps in Procedure 5.
Procedure 5: Logging off of CC MIS

1 Return to the CC MIS main window.

2 Select Session > Logout.

The CC MIS session ends. (Only the Connection Status icon remains in 
the CC MIS main window and the title bar indicates that you are logged 
off.)

Exiting CC MIS 

To exit CC MIS, use the steps in Procedure 6. You need not log off CC MIS 
before you exit a session.
Procedure 6: Exiting CC MIS

1 From the CC MIS main window, select Session > Exit.

The CC MIS main window closes.

Note: Use the steps in Procedure 4 to log back on to CC MIS. 
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When the connection goes down

If the connection to the CC MIS server goes down, or the server is shut 
down for maintenance, your session terminates. 

If the session terminates, the following occur:

The border around the Connection Status icon changes from green 
(operational) to red (nonoperational).
The Host Process Terminated message appears. 

When the connection or the system comes back up, the border surrounding 
the Connection Status icon changes from red to green. However, the Host 
Process Terminated message remains displayed. The message is for 
supervisors (who may have been away from their terminals when the system 
went down), and the message explains the need to log back on to CC MIS.
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Client Services (report destinations and 
wallboards)

You can use the CC MIS Client Services Setup window to define report 
destinations (printer, file, and e-mail) and PC-attached wallboards. 

Note: Depending on your Windows configuration, the CC MIS Client 
Services Setup window can have up to seven tabs. The following sections 
describe these tabs.

Use the steps in Procedure 7 to access the CC MIS Client Services Setup 
window.
Procedure 7: Accessing CC MIS Client Services Setup

1 Return to the CC MIS main window.

2 Click Session, and then select Setup > Client Services.

The CC MIS Client Services Setup window appears (see Figure 20 on 
page 43). 
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Figure 20: CC MIS Client Services Setup window

3 Click Help to access online Help for descriptions of the fields on each 
tab.

4 Select the tab and enter the desired settings.

5 Click OK.
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Services tab
On the Services tab, you can specify the services that are enabled for the PC 
(see Figure 21). 

Figure 21: Services tab

Use the Services tab to perform the following tasks:

Enable or disable any or all of the available report processing or 
wallboard services. 
Note: In a per-machine installation of the CC MIS client, the ability to 
enable or disable any report processing or wallboard service is 
unavailable if the Windows user that runs the Supervisor interface does 
not have administrative access rights. The check boxes are unavailable. 
All other functionality associated with this window is available.
Associate a meaningful name with the computer to identify it in various 
menus in the CC MIS system



May 2007 Accessing CC MIS using the Supervisor interface

CC MIS Getting Started Guide (Supervisor Interface) 45

Filing tab
On the Filing tab, you can specify the default folder, file name, and file type 
for the reports that are saved as files on the PC (see Figure 22).

Figure 22: Filing tab
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Printer tab
On the Printer tab, you can select a printer from the list of configured 
Windows printers that are used to print reports (see Figure 23). 

You can also set up the printer on this tab to capture the reports as files on 
your computer. The Print to a file option creates a printer file. For example, 
if you use a postscript printer, this option creates a postscript file. However, 
if you want to capture reports only as text files, use the Filing tab instead.
Figure 23: Printer tab
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Text tab
On the Text tab, you can specify the format setting for tabular reports (see 
Figure 24). You can choose the font and orientation to use for the reports.

Figure 24: Text tab
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Graphics tab
On the Graphics tab, you can specify the format for graphical reports (see 
Figure 25). 

Figure 25: Graphics tab
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E-mail/Fax tab

On the E-mail/Fax tab, you can configure how reports tagged with an 
electronic distribution list are handled. You can select the profile to use from 
the list and specify in the e-mail settings to send the report as an attachment.

If an e-mail client that supports the Messaging Application Programming 
Interface (MAPI) is installed on your PC, you can use the E-Mail/Fax tab to 
send reports by e-mail or by fax to one or more recipients (see Figure 26).

Note: You cannot send an e-mail or a fax that contain graphical reports.

Figure 26: E-mail/Fax tab
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Wallboard tab
You can configure a wallboard that is attached directly to the supervisor 
terminal (that is, a PC-attached wallboard) on the Wallboards tab (see 
Figure 27). 

You can attach wallboards to a free serial port on your PC. To configure a 
PC-attached wallboard, you must select a free COM port, and then specify 
the address and name for each wallboard (up to five wallboards) that is 
connected to this port.
Figure 27: Wallboard tab
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Color customization

If your PC supports more than 256 colors, you can use the Graphics tab to 
customize the colors that are used in graphical reports (see Procedure 8). 
Procedure 8: Customizing colors used in graphical reports

1 Open the CC MIS main window.

2 Select Session > Setup > Client Services.

The CC MIS Client Services Setup window appears. 

3 Select the Graphics tab (see Figure 28).

Figure 28: Graphics tab

4 In the Chart Options area, click Chart Colors.

The Color Selection dialog box appears (see Figure 29 on page 52). 



Accessing CC MIS using the Supervisor interface Standard 1.0

52 Call Center Management Information System

Figure 29: Color Selection dialog box

5 Under Color Map, click Customize to create custom colors.

The Color dialog box appears (see Figure 30). 

Figure 30: Color dialog box
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6 Select one of the 16 custom colors that you want to change.

7 Click one of the basic colors, or use the color controls on the right side of 
the dialog box to select the new color settings for this custom color.

8 Click Update Custom Color.

After you change the custom colors, click OK to close the Color dialog 
box. The Color Selection dialog box appears (see Figure 31). Use this 
dialog box to update the color palette.

Figure 31: Color Selection dialog box

The new colors appear in the color map on the Color Selection dialog 
box.

Note: You can customize the color maps in the Color Selection dialog 
boxes for printers and displays. This option is available if your system can 
support more than 256 colors.

9 Click OK.
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C h a p t e r  5

CC MIS main window functions
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Introduction

This chapter describes the functions that you can access from the CC MIS 
main window. 

Figure 32 shows the CC MIS main window. The menu commands available 
from the main window are briefly discussed in the following sections. 

Note: The main window is sometimes referred to as the Session Manager.

Figure 32: CC MIS main window

ATTENTION The appearance of the CC MIS main window depends 
on your assigned privilege level. Your main window 
includes only menus and menu commands for 
capabilities for which you are granted access.
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Session menu

The Session menu (see Figure 33) contains commands to log on, logoff of, 
and exit the CC MIS. The menu also contains the commands to set up 
communications and client services and to message between supervisors. 
Figure 33: Session menu

“Accessing CC MIS using the Supervisor interface” on page 29 describes 
the Session menu.
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Displays menu

The Displays menu contains commands for the following tasks:

enter the Agent Status and Queue Statistics displays
customize displays
manage wallboards
define alarms
Note: The Alarms command appears only when the Simple Network 
Management Protocol (SNMP) feature is enabled.

Click Displays to view the Displays menu (see Figure 34).
Figure 34: Displays menu
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Reports menu

The Reports menu (see Figure 35) contains commands for the CC MIS 
Reporting function:

generate and view reports
customize reports
check the status of reports sent directly to a printer or other report 
destination (e-mail or file)

Figure 35: Reports menu
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Config menu

The Config menu (see Figure 36) contains commands for the Configuration 
Control function.
Figure 36: Config menu

Use Configuration Control to adjust parameters inside the Automatic Call 
Distribution (ACD) switch. You can change only those parameters that 
relate to the operation of the ACD function through the Configuration 
Control modes. Use the Config menue to access all Configuration Control 
modes.

Access to each Configuration Control mode is controlled by the privilege 
level assigned to you in your supervisor profile. As a result, not all 
configuration functions may be available to you.

For more information, see “Configuration Control” on page 155.

Note: When the Networking feature is enabled, a slight difference exists 
between the Configuration Control windows for local partitions and 
Network Access Partitions (NAP). For more information about networking, 
see “Networked CC MIS” on page 64.
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Profile menu

The Profile menu (see Figure 37) contains commands to set a supervisor’s 
profile. Use this menu option to view and modify portions of your personal 
login profile. You can change any enabled field on the window. Only a 
supervisor, who is authorized to define supervisor profiles and change 
supervisor privileges, can change the other fields.
Figure 37: Profile menu

Admin menu

The Admin menu (see Figure 38) contains commands that the system 
administrator uses to control the CC MIS environment. 

Note: This NTP does not cover the Admin options. 

Figure 38: Admin menu
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Messaging

With the Messaging feature, supervisors can send messages to and receive 
messages from other supervisors. 

To send messages to other supervisors, you must be logged on and have the 
Messaging option enabled in your privilege level.

To access this feature, follow the steps in Procedure 9.
Procedure 9: Messaging another supervisor

1 In the CC MIS main window, select Session > Messaging.

The Supervisor Messaging dialog box appears (see Figure 39).

Figure 39: Supervisor Messaging dialog box

2 In the To field, select the supervisors you want to send a message to.

3 In the Message Text field, type a message to send to the selected 
supervisor. When you type your message, the Send button becomes 
active.

4 Click Send.

Note: Click the Broadcast button to broadcast the message to all logged-
on supervisors.

Note: For information about other fields in the Supervisor Messaging 
dialog box, see the online Help.
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Replying to a Message 
When you receive a message from another supervisor, the Supervisor 
Messaging window appears and is ready to accept your reply in the Reply 
Text field. Type your reply and click Reply. You can also reply to past 
messages by selecting the message from the Recent Messages list.
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Networked CC MIS

Supervisors who log on to a Network Access Partition (NAP) in a CC MIS 
network can view consolidated network data from the set of individual 
partitions that are configured as the virtual nodes in the NAP.

Networking enables the following:

Node field in all of the Configuration Control windows.
Ability to insert groups into Configuration Control windows based on 
node selection.
Partition code prefix on agent position IDs in real-time displays.
Ability to view information based on a selected node in the view 
windows for the Audio, OFRT, and IBNRTE Tables.

Note: The Connection Status icon appears different on a NAP. The border 
on a NAP connection icon indicates the status of the virtual nodes that are 
associated with the NAP. A red border indicates that one or more virtual 
nodes is down.
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Introduction

The Agent Status display provides information concerning the status of each 
agent position in the supervisor's scope. The supervisor can view the 
following information on this display:

the type of call an agent is currently handling
the agents that are logged on
the agents on walkaway
other related information
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Accessing the Agent Status display

Perform the steps in Procedure 10 to access the Agent Status display.
Procedure 10: Accessing the Agent Status display

1 From the CC MIS main window, select Displays > Agent Status (see 
Figure 40).

Figure 40: Displays > Agent Status

The Agent Status window appears (see Figure 41 on page 68).

2 From the View menu on the Agent Status window, select one of the 
views (Subgroup, Group, or Global).

Figure 41 shows the Agent Status window with the Global view selected.
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Figure 41: Agent Status—Global view

From the Agent Status display, you can control the view of the positions 
for which agent status is displayed, the information for each position, and 
the display layout. 

Note: Some display fields are controlled by the supervisor’s profile. 
Specifically, if the Agent Performance option is disabled in the Privilege 
Level Definition associated with your profile, you cannot access any field 
that displays agent performance (state duration and login time). If the 
Agent Identity option is disabled, you cannot view the agent names.

Navigator
pane
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Agent Status display field descriptions

Table 1 describes the fields that can appear on the Agent Status display.
Table 1: Agent Status display — field descriptions (Part 1 of 2)

Field Description

Navigator pane The navigator pane, when displayed, appears along the 
left side of the window and lists the ACD groups and 
subgroups available in the current view. You can quickly 
navigate to a specific ACD group or subgroup and use 
drag-and-drop to reassign positions among subgroups (if 
enabled by your privilege level).

ACD Group The ACD group that is being viewed.

POSN The position ID of the physical phone set.

Status The state of the position.
If the agent is in the current state for longer than the 
threshold defined for the state, this field is highlighted. 
The appearance of this field is controlled by the 
Preferences > States command. The Preferences > Dual 
DN Status command also affects the appearance of this 
field by enabling or disabling the display of the status for 
a second DN associated with the position.

Durations This field displays real-time timers that indicate the time 
period (in minutes and seconds) that the agent has been in 
the current state.

Note: Separate timers exist for the ACD in-calls key and 
the DN keys.

The appearance of this field is controlled by the 
Preferences > Durations command. Timers exist for one 
or two DN keys, depending on the current state of the 
Preferences > Dual DN Status command.
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Agent Name This field displays the name of the agent logged on to the 
position.
The display of this field is controlled by the Preferences > 
Names command.

Login This field appears when the login option is selected from 
the Preferences menu. The field displays the time of day 
the agent logged on. This field always appears in the 
rightmost column.

Table 1: Agent Status display — field descriptions (Part 2 of 2)

Field Description
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Setting the view

You can select one of three views for the Agent Status display: Subgroup, 
Scope, and Global. The access level that is provided by the system 
administrator when creating your profile determines your available views. 

Your default view

You set the default view in your profile. CC MIS uses this view when you 
first log on and access your Agent Status display. The default can be either 
subgroup/group, scope, or global. 

To change your default view, access your profile using the Profile > Options 
command in the CC MIS main window. Use the steps in Procedure 11 to 
change your default view.
Procedure 11: Changing your default view

1 In the CC MIS main window, select Profile > Options.

The Profile Maintenance window appears (see Figure 42 on page 72).
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Figure 42: Profile Maintenance window

2 Modify the selection in the Default View area of the profile. 

3 Select File > Save.

4 Select File > Exit.

Notes: 

Changes made to the Default View setting in your profile take effect the 
next time you log on to CC MIS.
The Default View setting in your profile affects both the Agent Status 
display and Queue Statistics display.
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During a session, you can change the default view to another view at any 
time. To see the change, log off from your current session and log back on to 
CC MIS.

Switching between views

The View menu provides commands to change the views (see Figure 43). 
You can also switch between views using the toolbar buttons (see 
Figure 44).
Figure 43: Agent Status display—View menu

Figure 44: Agent Status display—Toolbar buttons

When you change your view during a session, your default view that is set at 
the time of log on is not affected. The Default view is configured through 
the supervisor profile.
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Select View > Navigator to show the Navigator pane (see Figure 41 on 
page 68). You can expand the listing of subgroups in the Navigator pane 
using the Expand All command (View > Expand All) or hide the listings 
using the Collapse All command (View > Collapse All). Figure 45 on 
page 74 shows a comparison of the Collapse All and Expand All options.
Figure 45: Collapsed and expanded subgroups in the Navigator pane
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Customizing the display

This section describes how to customize your display.

Selecting fonts and colors for the display

You can set the colors and fonts for the display elements. Use the 
Preferences > Font menu to identify the font, font style, and size used in the 
display. 

Note: Screen elements used to customize colors are shared between the 
Agent Status display and Queue Statistics display. Changes to the colors in 
one display affects the other display.

If your system supports more than 256 colors, the Color Selection dialog 
box displays a Customize button. Click the Customize button to display the 
Color dialog box. The colors you select in the Color dialog box are placed in 
the color map for use in displays (see “Color customization” on page 51). 

Selecting the fields presented in the display

Use the Preferences menu to identify the information that appears for each 
position in the display (see Figure 46 on page 76). 

You can enable or disable any or all of the Status, Duration, Agent Name, or 
Login fields through the commands on the Preferences menu. 

You can use the toolbar buttons on the Agent Status display to switch on or 
off the Status, Duration, and Agent Name fields.
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Figure 46: Agent Status display—Preferences menu

Normally, the color of a state displayed in the Status field for each position 
also represents the state of the position, including whether the agent has 
been in that state longer than a prescribed threshold value. If the Status field 
is disabled in the display, the color used to display the primary ACD state of 
the position is used as the color for the Position ID field.

Understanding the Status field

The Status field in the Agent Status display window always displays the 
primary ACD state of the position, which is the state of the ACD In-Calls 
key (the telephone line on which the agent receives call center calls). In 
addition, this field splits whenever the agent has a call active on the 
secondary DN key. In this case, the primary ACD state is abbreviated, and 
the DN state appears to the right.

CC MIS can track up to two simultaneous DN calls for each agent position. 
If agents are often simultaneously involved with multiple DN calls, you can 
add a second DN state to the field by enabling the Preferences > Dual DN 
Status menu command.
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In addition to indicating the current status of the agent, the Status field can 
also indicate if the agent remained in the current state too long and can 
display not ready or walkaway reason codes when the agent is in these 
states. For more information, see the online Help.

Showing elapsed time for state durations

The CC MIS system tracks the length of time an agent position spends in 
each state. To view this information in the Agent Status display, select the 
Preferences > Duration command. This field always appears in the Agent 
Detail window (right-click the agent position) and on Agent Status display 
printouts (see Figure 47).
Figure 47: Durations

Hold Time
The Preferences > Hold Time command affects the way the time appears in 
the Duration field. When Hold Time is enabled, each time the ACD or DN 
call is placed on hold, the timer resets and begins counting. An underline 
( _ ) is used to differentiate hold time from total ACD or DN call time. 
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After the hold state terminates, the timer reverts to display the total call 
duration.

Hiding spare positions
By default, spare positions (positions with a spare status) appear in the 
Agent Status display window. The Preferences > Spare Positions submenu 
provides options to hide these positions from the display (see Figure 48).

Figure 48: Spare Positions

Note: A position in the forced state, which indicates that the agent was 
logged off automatically by the switch for failure to answer a call, always 
appears on the display, even though the position has no agent logged on. 
Positions in the forced state are always displayed.

For additional information about hiding spare positions, see the online Help.
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Saving preferences

You can use your supervisor ID on the CC MIS server (using the 
Preferences > Save command) to save the changes you make to the format 
of the Agent Status display. You must save your changes or all changes are 
lost when you log off of CC MIS.

ATTENTION The Preferences > Save command does not immediately 
save the preferences on the server. All changes made to 
supervisor preferences are stored in a preferences file on 
the local PC until the supervisor logs off. At logoff time, 
the modified preferences file is transferred to the server 
for retrieval the next time the supervisor logs on. 
Therefore, if you change your preferences, but the 
connection to the server is interrupted before you can 
log off, these changes are lost.
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Detail windows

The following sections describe the CC MIS detail windows.

Agent Detail window

To display an Agent Detail window, position the pointer on an agent 
position ID in the Agent Status window and double-click the left mouse 
button. Figure 49 shows the Agent Detail window.
Figure 49: Agent Detail window

Note: The Agent Detail window cannot be displayed if the Agent 
Performance option is disabled in the Privilege Level Definition associated 
with your profile.

Figure 50 shows an example of the Agent Detail window with the Options 
menu displayed.
Figure 50: Agent Detail—Options menu

Select one of the three commands to change the content and layout of the 
detail window. There are three options:

Call Totals (see Figure 51 on page 81)
Average Durations (see Figure 52 on page 81)
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Time Allocation (see Figure 53 on page 81)
Figure 51: Agent Detail—Call Totals

Figure 52: Agent Detail—Average Durations

Figure 53: Agent Detail—Time Allocation
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ACD Group detail window

To display an ACD Group Detail window (see Figure 54), position the 
pointer on an ACD Group ID in the Agent Status window and right-click. 
Figure 54: ACD Group Detail window

Subgroup detail window

To display a Subgroup Detail window (see Figure 55), expand a group in the 
Navigator pane to show the Subgroup IDs, and then position the pointer on a 
Subgroup ID and right-click. 
Figure 55: Subgroup Detail window
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Monitoring another supervisor

You can observe another supervisor’s displays if you selected the Monitor 
display option in your Privilege Level definition. This feature is useful when 
a peer is absent from their workstation and someone must monitor the 
activity of the agents and queue for which the supervisor is responsible. 

Note: When you monitor another supervisor’s display in scope view, the 
display is limited to the scope restrictions of the supervisor ID you monitor. 
(This is transparent if both you and the supervisor you monitor have a global 
scope restriction.)
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Introduction

The Queue Statistics display provides information about the efficiency with 
which an ACD group handles calls. 

When using the Queue Statistics display, you can control the following:

Groups—Set the view to Single Group, Scope, Global, or New ACD 
Group. Or, if it is enabled in your privilege level definition, monitor 
another supervisor.
Format—Set the current display format to one of the four standard 
formats or to a custom display format (public or personal).
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Accessing the Queue Statistics display

Perform the steps in Procedure 12 to access the Queue Statistics display. 

Note: The Default Display field of your profile determines the initial format 
of the Queue Statistics display following your logon. 

Note: The system administrator determines the default when creating your 
profile. If you can access your profile, you can change the default. 

Procedure 12: Accessing the Queue Statistics display

1 From the CC MIS main window, select Displays > Queue Statistics 
(see Figure 56).

Figure 56: Displays > Queue Statistics

The Queue Statistics window appears with the default view that is set 
with your profile. For more information, see “Your default view” on 
page 89.

2 Use the View menu in the Queue Statistics window (Figure 57 on 
page 88) to select a view (Subgroup, Group, Global).

Figure 57 shows the Queue Statistics window with the Global view 
selected.
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Figure 57: Queue Statistics—Global view
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Setting the view

You can select one of three views for the Queue Statistics window: Single 
Group, Scope, and Global. The access level provided by the system 
administrator when creating your profile determines your available view.

The New ACD Group command provides a way to select which group is 
displayed in the Single Group view. Additional views (such as New ACD 
Group and New Subgroup) can also be available, depending on your access 
privileges. The system administrator provides access privileges.

Your default view

The default view is set in your profile. CC MIS uses this view when you first 
log on and access your Queue Statistics window. The default is selected 
from the menu list. During a session, you can change this default to another 
view. To see the change, log off from your current session and log back on.

Switching between views

The View menu provides commands to change the views (see Figure 58 on 
page 90). You can also use the toolbar buttons to switch between views (see 
Figure 59 on page 90).

Changing the view does not affect the default view that is set at log on. The 
default view is configured through the supervisor profile.
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Figure 58: Queue Statistics window—View menu

Figure 59: Queue Statistics window toolbar
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Setting the display format

The display format of the Queue Statistics window refers to the display 
format definition currently used to determine the statistics that are presented 
in the window and how they are displayed. The CC MIS system provides 
four standard display format definitions. Use other display customization 
windows (see “Creating a custom Queue Statistics window” on page 92) to 
create a library of custom display format definitions for use in the Queue 
Statistics window. Customize a display definition to perform the following 
tasks:

select the statistics presented in the display
add meaningful names to the statistics
choose whether to display the information in a tabular or graphical 
format 

Changing the display format without changing the default

While you are in a session, you can temporarily change the format; that is, 
you can change the format until you log off or change the format again. Use 
the View > New Display Format command to change the format. If you 
change the display format without changing the default and you log off, 
CC MIS reverts to your default Queue Statistics display when you establish 
another session. 
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Creating a custom Queue Statistics 
window

To ensure the CC MIS standard display definitions meet your needs, you 
can develop a set of custom display definitions. 

Two levels of customization can exist:

You can develop new formulas from the raw real-time statistics that 
CC MIS collects if the set of standard formulas does not contain a 
formula that you require. This level of customization is restricted to 
supervisors that have the Formulas privilege enabled in the Display 
Options group in their privilege level. All custom formulas are defined as 
public definitions, which are available to all supervisors in the system.
You can build custom display definitions from the set of standard and 
custom formulas using the Quadrant and Screen definition modes. Both 
public (available to all supervisors) and personal custom display 
definitions can be created, depending on whether the Public Formats or 
Personal Formats privileges are enabled in your privilege level.

Overview of the process

The three basic steps to create a custom Queue Statistics display are as 
follows: 

1. Define formulas (see page 93).

2. Define quadrants (see page 94).

3. Define screens (see page 99).

The following sections describe the basic process to create a custom Queue 
Statistics display. 
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Step 1: Define formulas

First, define formulas you need (to collect the data you want) in your 
display. However, you need not create custom formulas; you can use any of 
the standard formulas provided by CC MIS. 

Access the Display Formulas window, as shown in Figure 60, by selecting 
the Displays > Formulas command from the CC MIS main window.
Figure 60: Display Formulas window
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Step 2: Define quadrants

Define how the information is presented in a quadrant. 

The two quadrant sizes are as follows:

full screen
half screen

The two types of layouts are as follows:

tabular (see “Defining tabular quadrants,” on page 95)
graphic (see “Defining graphic quadrants,” on page 96)

When you create a custom quadrant definition, you can save it as a public 
quadrant or as a personal quadrant. 

All supervisors can use public quadrants, but only system administrators 
can define them (that is, those supervisors who have the Public Formats 
display option enabled in their privilege level and who know the system 
administration password). 
Only the supervisor who creates a personal quadrant can use it. A total of 
five personal quadrants can be defined. 

For more information, see “Saving your quadrant as a public or personal 
quadrant,” on page 98.
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Defining tabular quadrants 
Use the Quadrant Definition window to define tabular quadrants. To display 
the Quadrant Definition window, select the Displays > Quadrants command 
from the CC MIS main window. 

Note: For descriptions of the fields on the Quadrant Definition window, see 
the CC MIS online Help.

Figure 61 shows the Quadrant Definition window in default tabular style.
Figure 61: Quadrant Definition—Tabular style 

The lower portion of the window contains all currently defined standard and 
custom formulas. 
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The process of defining a tabular quadrant consists of the following steps:

1. Select the formulas.
See the Edit Columns tab in Figure 61 on page 95.

2. Provide meaningful display headings.
See the Edit Headings tab in Figure 61 on page 95.

3. Optionally set thresholds on columns.
See the Edit Thresholds tab in Figure 61 on page 95.

When you finish defining the quadrant, save the screen by selecting the File 
> Save command.

Defining graphic quadrants
Use the same window as the tabular quadrant (the Quadrant Definition 
window) to define graphic quadrants. When you select the Graphic button in 
the Style field, the window reappears with the fields shown in Figure 62 on 
page 97. 

Note: For descriptions of the fields on the Quadrant Definition window, see 
the CC MIS online Help.
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Figure 62: Quadrant Definition—Graphic style 

The lower portion of the window contains all currently defined standard and 
custom formulas. 

The process to define a graphic quadrant consists of the following steps:

1. Select up to five statistics to include in the bar graph.
See the Edit Elements tab in Figure 62.

2. Provide meaningful legend text.
See the Edit Legend tab in Figure 62.

When you finish defining the quadrant, save the screen by selecting the File 
> Save command.



Queue Statistics display Standard 1.0

98 Call Center Management Information System

Saving your quadrant as a public or personal quadrant
Public quadrants are available to all supervisors, while personal quadrants 
are available only for your use. 

You determine whether the quadrant is a public or a personal quadrant when 
you save it. Select the File > Save As command. The Save Quadrant 
Definition As dialog box appears (see Figure 63). Click either the New 
Personal button to create a new personal quadrant or the New Public button 
to create a new public quadrant. 
Figure 63: Saving a quadrant

If you read an existing custom quadrant, the File > Save command 
overwrites the opened quadrant with any changes you made.
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Step 3: Defining screens

In this step, you name the display and position the quadrants in the display. 
You can save custom screen definitions as either public or personal screens; 
however, if any personal quadrants are used in the screen, you must save the 
screen as a personal screen. You can define up to five personal screens.

After you define the quadrant, position the quadrants on a screen. Consider 
the size of a quadrant when you place the quadrant on the screen: 

You can place full screen quadrants only in the upper or lower left area of 
the screen. 
You can define lower screen quadrants only if a quadrant is placed above 
it. Lower screen quadrants are optional. 

Note: If only an upper quadrant exists, the system automatically extends the 
display to the bottom of the screen. 

Select the Displays > Screens command on the CC MIS main window. The 
Display Screen Definition window appears (see Figure 64 on page 100).
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Figure 64: Display Screen Definition window

Note: For definitions of the fields on the Display Screen Definition window, 
see the CC MIS online Help. 

When you define a screen, you can use any standard quadrant, public 
quadrant, or personal quadrant (defined by you). Predefined standard 
quadrants are available from the menu in the Screen Definition window. 

You can read an existing screen definition and modify it to meet your needs 
by selecting the File > Open command and then selecting the definition 
from the list. You can also overwrite an existing definition. 
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After you define a screen, perform the steps in Procedure 13 to view the 
screen.
Procedure 13: Viewing a custom display

1 From the Queue Statistics window, select View > New Display format.

2 At the New Display Format? dialog box, select the screen.

3 Click OK.

Perform the steps in Procedure 14 to set your default to display a custom 
screen.
Procedure 14: Setting your default to a custom display

1 From the CC MIS main window, select Profile > Options.

The Profile Maintenance dialog box appears (see Figure 65).

Figure 65: Profile Maintenance dialog box
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2 Under Real Time Display Options, select your format from the Default 
Display list (see Figure 66).

Figure 66: Profile Maintenance dialog box—Default Display

3 Select File > Save to save the default settings.

4 Exit and immediately implement changes.

a. From the Profile Maintenance window, select File > Exit.

A dialog box appears.

b. Read the information in the dialog box, and select one of the 
following:

Yes if you want the changes to apply immediately. You are logged off 
from CC MIS.

No if you do not want to be logged off.
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Introduction

Supervisors can display information on wallboards. Wallboards are light 
emitting diode (LED) message boards that are mounted in the Automatic 
Call Distribution (ACD) group office. Supervisors use wallboards to notify 
agents of ACD statistical information and administrative information. 

Supervisors with the Wallboards display option enabled in their privilege 
level can perform the following tasks:

construct messages to suit their needs
define which messages are displayed

Messages consist of text and variable information, such as Queue Statistics 
display formula results. 

CC MIS supports three types of wallboards: Spectrum, Daktronics, and 
Generic. Spectrum wallboards can display multicolor, multiline messages 
(depending on the wallboard model).

The basic steps to define and display messages on the wallboard are as 
follows:

1. Define the messages using the Wallboard Message Definition window.

2. Define the displays using the Wallboard Display Definition window.

3. Send messages to a wallboard using the Wallboard Run Table window.

Note: You can also send a quick message to the wallboard by completing 
the Quick Message fields and sending the message.
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Creating a wallboard message

Supervisors use the Wallboard Message Definition window to define the 
actual messages that are displayed on the wallboard. 

You can simultaneously display multiple messages on a wallboard. 
Therefore, after defining a wallboard message, you can use the Wallboard 
Display Definition window to combine the new message with other 
messages to form a complete display. 

Alternatively, after defining a wallboard message, you can immediately send 
the single message to a wallboard using the Quick Message section at the 
bottom of the Wallboard Message Definition window (see Figure 67).
Figure 67: Wallboard Message Definition window
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Wallboard Message Definition fields

The Wallboard Message Definition window contains the following fields:

Text field—Messages must not exceed 100 characters (this includes five 
parameters that represent values from formulas). The character 
sequences <1>, <2>, <3>, <4>, <5>, <G> (ACD Group), <T> (Time), 
and <D> (Date) in the message text refer to the variables. Messages can 
consist of multiple lines of text. 
Color, Style, and Display fields—The display formats describe how the 
message appears on the wallboard. Choose a format for each field from 
the list. 
Select the appropriate check box to choose optional settings, such as 
Double-high, Double-wide options, or Left-justified, fixed width. (The 
display formats that you can use depend on the type of wallboard in use.) 
Variable tabs—The window contains a tab for each variable that can be 
defined within a message. Variables represent formulas that are based on 
real-time statistical data collected by the system.

 Choose up to five formulas to display on the wallboard <1> through 
<5>. The formulas available on the wallboard are the same as those 
available in the Queue Statistics display.
The ACD Group variable <G> displays the primary DN or defined 
name for the ACD group specified in the Wallboard Display 
Definition window.
The Date <D> variable displays the date variable fields.
The Time <T> variable displays the time variable fields.

Quick Message Fields—Use the Quick Message fields to quickly send a 
saved message to a wallboard without leaving the Wallboard Message 
Definition window. After you define the message and specify the 
parameters, click the Send Quick Message button to immediately send 
the message.
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Defining a wallboard message 

Use Procedure 15 to define a wallboard message.
Procedure 15: Defining a wallboard message

1 From the CC MIS main window, select Displays > Wallboard 
Messages.

The Wallboard Message Definition window appears (see Figure 67 on 
page 105).

2 Define the message:

a. In the Wallboard Message Definition window, click the Text field.

b. Enter the message to appear on the Wallboard. 

Note: Enter variables as a number from 1 to 5, surrounded by <> (for 
example, Service Level <1>).

c. Specify the display format characteristics: Color, Style, and Display 
format.

d. Click the tabs to define variables entered in message. Complete the 
variable information in the tab area.

e. For each variable, select a display formula from the Formula list and 
a display format from the Format list.

3 Save the definition:

a. Select File > Save.

b. If the definition exists already, click OK in the information box.

Note: You can save multiple wallboard messages with the same name. If 
you modify an existing wallboard message, save the modification by 
using the Save command. Save the modification to prevent the system 
from creating different wallboard message definitions with the same 
name.

4 Exit the window by selecting File > Exit. 

The system returns to the CC MIS main window.
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Creating a wallboard display 

Supervisors use Wallboard Display Definitions to perform the following 
tasks:

Combine several messages to form a complete wallboard display. 
Define the ACD group (for each selected message) to receive the display 
information.

Figure 68 shows the Wallboard Display Definition window. 
Figure 68: Wallboard Display Definition window
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Wallboard Display Definition fields
The following fields are on the Wallboard Display Definition window:

Display Definition Name—Define a name that uniquely identifies the 
display definition. Use up to 40 characters in the name. CC MIS can save 
up to 250 public display definitions.
Update Rate—Enter a value in seconds (2–999). This field determines 
the frequency that the wallboard display contents are updated. (On 
Spectrum boards, this is the rate at which variable information is 
updated.)
Presentation Speed—Specify the length of time the message appears on 
the wallboard before it is rotated. 
Message—Select up to 10 messages to be displayed on the wallboard. 
When you select a message from the Message list, that message replaces 
the currently selected message. To add a new message to the list, use the 
Edit > Insert command to open a new placeholder, and then select the 
new message from the list.
Message List fields (Message, ACD Group, Position, and Presentation 
Mode)—If the corresponding message contains variables, then identify 
the data source that corresponds to the message. If you do not select a 
value from the pop-up menu, then the default value (All Groups) is used. 
Presentation Mode specifies how the message appears on the wallboard.
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Defining a wallboard display 

After you define all messages, perform the steps in Procedure 16 to define 
the wallboard display.
Procedure 16: Defining a wallboard display

1 From the CC MIS main window, select Displays > Wallboard Displays.

The Wallboard Display Definition window appears (see Figure 68 on 
page 108).

2 Enter the information in the Wallboard Display Definition window:

a. Enter a name in the Display Definition Name field.

b. To add a message to the display, click the message before which the 
new message is added (or the --End of List-- item to add the 
message to the end); then use the Edit > Insert command (or Insert 
key) to create a new message placeholder. You can add up to 10 
messages to a wallboard display definition.

c. Select the desired message from the Message List. Specify the ACD 
Group, Position, and Presentation Mode for the message. (Repeat for 
each message.)

d. Select the Presentation Speed.

e. Enter the desired Update Rate in seconds.

3 Save the definition as follows:

a. At the Wallboard Message Definition window, click File > Save.

b. If the definition exists already, click OK on the information box.

If this is a new definition, click NEW at the Save Message Definition 
As box.

4 Select File > Exit from the Wallboard Display Definition window to return 
to the CC MIS main window.
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Sending a display to the wallboard

Perform the steps in Procedure 17 to send a display to one or more 
wallboards.
Procedure 17: Sending a display to the wallboard

1 From the CC MIS main window, select Displays > Wallboard Run 
Table.

The Wallboard Run Table window appears (see Figure 69).

Figure 69: Wallboard Run Table window

2 Select the Wallboards on which to send the display.

3 Select the display from the Display list.

4 Click Update to send the display to the selected wallboards. 

The wallboards begin to display the newly selected wallboard messages.

Note: You can use the Quick Message field on the Wallboard Run Table 
window to send an immediate message to the wallboard. Quick 
Messages override any assigned wallboard display. Use Quick Message 
to send an urgent message to one or more wallboards and to later clear 
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the display (causing the wallboard to return to its normal display). You 
must set the Quick Message field to (None) for a newly selected display 
to run on the wallboard.

5 Select File > Exit to return to the CC MIS main window.
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Clearing a wallboard

To clear a wallboard display, send the Reset/Clear standard display to the 
wallboard. 

Perform the steps in Procedure 18 to clear a wallboard display.
Procedure 18: Clearing a wallboard display

1 From the CC MIS main window, select Displays > Wallboard Run 
Table.

The Wallboard Run Table window appears. 

2 Select the built-in Reset/Clear display (see Figure 70).

Figure 70: Wallboard Run Table—Reset/Clear
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Introduction

The Alarms option appears only if the Simple Network Management 
Protocol (SNMP) feature is enabled and if you have supervisor access 
privileges to this feature.

Note: Due to the technical nature of the SNMP feature, Nortel recommends 
that administrators and users of this feature have a background in network 
management and the SNMP protocol. For additional SNMP information, 
see the CC MIS online Help.
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Alarm definition

The Alarms Definition window (see Figure 71 on page 118) is the starting 
point for all SNMP-related activities at the partition level, including the 
following activities:

alarm definition and maintenance
SNMP community setup and maintenance
SNMP MIB file transfer

From the Alarms Definition window, you can create up to 100 alarm 
definitions, each consisting of the specification of a standard or custom real-
time display formula with associated threshold and alarm information. You 
can set up each alarm definition to apply to all ACD groups or to a list of 
specific ACD groups. The setup of each statistic includes threshold and 
alarm information. The information defined for each Alarm Definition is 
what is provided to a Network Management System (NMS) when it queries 
the CC MIS Partition Management Information Base (MIB) entries. 
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Perform the steps in Procedure 19 to access the Alarm Definition window.
Procedure 19: Accessing the Alarms Definition window

1 From the CC MIS main window, select Displays > Alarms.

The Alarms Definition window appears (see Figure 71).

Figure 71: Alarms Definition window 

The Alarm Definition window consists of four major components: toolbar, 
status bar, form template, and definitions list.

Toolbar
The toolbar comprises the row of buttons across the top of the window that 
provides shortcuts to many of the menu commands. A ToolTip window 
appears for a short time when you position the pointer over a toolbar button. 
This ToolTip contains a brief description of the function performed by the 
button.

Status bar

Definitions
list

Toolbar

template 

area

Form 

Mode button
(Add/Modify)
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Status bar
The status bar appears at the bottom of the window and consists of three 
sections. The first section indicates the number of records defined and the 
maximum number allowed. The second section indicates the number of 
records currently selected in the definitions list. The third section displays 
status and progress messages.

Form template
The form template (see Table 2) consists of the fields (in the top half of the 
window) used to enter and modify the fields that make up an alarm 
definition. The definitions list (in the bottom half of the window) displays a 
scrollable list of currently defined alarm definitions. Any or all fields in the 
definition can be displayed as a column in the definitions list. The only 
restriction is that the ID column must always appear in the first column. As 
you add or remove columns, the columns automatically resize themselves to 
provide the best fit for the current width of the window. 
Table 2: Form template area — field descriptions (Part 1 of 3)

Field Description

Alarm ID A unique alarm ID number with the range of 
1 to 100.

Alarm Name The name assigned to the alarm definition. 
This name can consist of 1 to 30 characters excluding 
the vertical bar (|).

Formula The standard or custom formula used to compute the 
statistic value upon which the alarm condition is 
based.

Threshold Level This field determines whether the computed value for 
the statistic should cause an alarm condition if the 
value rises above or falls below the threshold value 
defined for the alarm. 
The two possible values for this field are Above or 
Below.



SNMP alarms Standard 1.0

120 Call Center Management Information System

Threshold Type The type of threshold to apply to the statistic value. 
This can be any available ACD group threshold (as 
defined using Threshold Definition) or the following 
special threshold type:
(Zero) — The threshold value is defined solely by the 
constant value entered in the Plus field.

Plus This field defines a numeric value to be added to the 
value of the ACD group threshold selected in the 
Threshold Type field to arrive at the threshold value 
used to determine when the statistic value indicates an 
alarm state.
This constant component of the alarm threshold can be 
any signed 32-bit number (–2 147 483 647 through 
2 147 483 647). 

Alarm Type This field determines the type of alarm (SNMP trap) to 
be generated by this alarm definition. The four 
possibilities are Poll, Minor, Major, and Critical. 
The Poll setting does not generate an SNMP trap. In 
this case, the Network Management System must poll 
the value of the variable.

Delay This field sets a delay period (in seconds) from the 
time that an alarm condition is first detected until the 
time that an SNMP trap is sent. 
If the alarm condition clears within this delay period, 
no trap is sent. This delay value also applies to 
clearing an alarm condition. 
The maximum delay value is 999 seconds.

Table 2: Form template area — field descriptions (Part 2 of 3)

Field Description
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The operation of the Alarm Definition window depends on the current 
mode: Add or Modify. The label on the button in the upper right corner of 
the window indicates the mode (see Figure 71 on page 118).

When the window appears, the initial mode is Add (if no alarm definitions 
are currently defined). Otherwise, the mode is set to Modify.

Alarm Groups This field determines which ACD groups can cause 
traps to be generated. 
The field contains the names of all currently defined 
ACD group lists (as defined in List Definition mode) 
and the special All selection. 

If a list is selected, only the groups in the specified 
list definition cause traps to be generated. 
If All is selected, all ACD groups cause traps to be 
generated.

Table 2: Form template area — field descriptions (Part 3 of 3)

Field Description
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Perform the steps in Procedure 20 to add an alarm definition.

Note: For more information about adding or modifying an alarm definition, 
select the Help > Window command.

Procedure 20: Creating an Alarm definition

1 From the Alarm Definition window (see Figure 72), select Options > Add 
or type a new ID number in the Alarm ID field. 

Figure 72: Add mode

2 Enter information into the Alarm Definition window.

3 Click Add to send the definition to the database. 

The definition is now listed in the list of alarm definitions.
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Perform the steps in Procedure 21 to modify an existing alarm definition.
Procedure 21: Modifying an Alarm definition

1 From the Alarm Definition window, select an existing alarm definition 
from the list of Alarm Definitions.

2 Make the changes.

3 Click Modify to send the changes to the database. 

Note: To cancel the changes, click Revert (or select 
Edit > Revert) before you click Modify.
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SNMP Community Setup

Use the SNMP Community Setup window to define the rights for Network 
Management Systems to access the CC MIS Partition MIB for the partition. 
This SNMP Community Setup window is shown in Figure 73.

This window displays the current settings for each of the three communities 
defined by CC MIS. When a CC MIS partition is created, the community 
defaults are public, secure, and traps for the read-only, read-write, and traps 
communities, respectively. The members list for the read-only community is 
set to 0.0.0.0, while the other two members lists are empty.
Procedure 22: Accessing the Community Setup window

1 From the Alarms Definition window, select SNMP > Community 
Setup.

The SNMP Community Setup window appears (see Figure 73).

Figure 73: SNMP Community Setup window
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SNMP MIB Transfer

Use the SNMP MIB Transfer dialog box to download the CC MIS MIB 
definition files to the local PC for use with a Network Management System. 
These MIB definition files are text files that define all SNMP objects that 
the CC MIS system implements. 

The SNMP MIB Transfer dialog box is shown in Figure 74.

Perform the steps in Procedure 23 to access the SNMP MIB Transfer dialog 
box.
Procedure 23: Accessing the SNMP MIB Transfer dialog box

1 From the Alarms Definition window, select SNMP > MIB Transfer. 

The SNMP MIB Transfer dialog box appears (see Figure 74).

Figure 74: SNMP MIB Transfer dialog box

From the SNMP MIB Transfer window, you can select either the CC MIS 
Partition MIB or the CC MIS System MIB to be downloaded. 

2 Select an MIB option, and then click OK.

The Save MIB File As dialog box appears. 

3 Select the location to save the file and click OK.
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C h a p t e r  1 0

Historical reports
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Introduction

Use the reporting feature of CC MIS to generate reports based on historical 
data in the following ways:

in one of three main formats: tabular, graphic, and event log
on a schedule and ad hoc (on demand)
on paper, on your terminal, to a file, to an e-mail, or fax to one or more 
recipients

In addition, you can create reports that can be imported into commercial 
spreadsheet packages.
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Accessing the reporting functions

Except for scheduling a report to generate, reporting capabilities are 
provided through the Reports menu.
Procedure 24: Accessing the Reports menu

1 From the CC MIS main window, select Reports. 

The Reports menu appears (see Figure 75).

Figure 75: Reports menu

2 Select a command from the Reports menu.

The following commands are available on the Reports menu:

View and Monitor View—View a report that was generated for display 
on the supervisor’s terminal.
Report Status Logs—Track the progress of reports (that you requested) 
that are directed to output destinations other than the supervisor terminal 
window.
Parameters—Define the contents of all reports that are based on 
historical data. With this command, you can quickly generate a report on 
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an ad hoc basis or to save a complete report parameter definition for later 
retrieval or for scheduled generation of reports.
Tabular Formats, Graphic Formats, and Formulas—Create and maintain 
a set of custom report format definitions that are tailored to the exact 
needs of your call center. 
Spectrums—Adjust the time ranges associated with the three built-in 
spectrum definitions used in the standard Answering Delay, Abandoning 
Delay, and Call Duration reports. For more information, see “Spectrums” 
on page 149.
System Reports—Generate reports that list various definitions database 
tables maintained by the system (such as agent definitions, ACD group 
definitions, and LOB definitions). In addition, four ACD configuration 
reports provide a snapshot of the ACD configuration information. For 
more information, see “System reports” on page 189
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Generating a report

Perform the following high-level steps to generate a report (with one 
exception):

1. Identify the name for the report.

2. Identify the format information for the report.

3. Identify the options for the report.

4. Identify the output destination (printer, screen, file, e-mail, or fax).

5. Select the desired values for the data selection fields.

6. Request that the report is generated immediately (ad hoc report) or is 
scheduled to print.

The exception is generating a system report. You cannot schedule system 
reports. For more information, see “System reports” on page 189

Report formats

Report formats are either standard, event log, personal, or public. The 
format identifies the data elements in the report:

Standard formats—CC MIS provides a number of standard report 
formats. You can use the standard formats to generate tabular and 
graphic reports. For a list of standard report formats, see “Standard 
tabular report formats” on page 150 and “Standard graphical report 
formats” on page 153.
Event log formats—CC MIS provides event log report formats that 
provide detailed listings of agent activity throughout the day. You cannot 
customize event log report formats. To schedule or generate event log 
reports, you must have the Agent Performance option enabled in the 
Privilege Level Definition associated with your Supervisor Profile.
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Personal formats—Each supervisor can create five personal formats. 
These formats are available only to the supervisor who creates them. 
Personal formats can generate tabular or graphic reports. 
Public formats—Supervisors with access to system administrator 
functions (Admin) can create public formats for all supervisors to use. 
These formats can generate tabular or graphic reports. 

Report options

You can define the following report options:

Time frame used to generate report—Time frame determines the 
granularity of the data reported and refers to how data is stored in the 
historical database. Possible time frames are interval, shift, day, week, 
month, and period.
Manner in which the data is reported:

by logical group
by totaling options (data and totals, totals only, or data only) 
The Data export option is a special form of the data-only totaling 
option, which modifies the output of the report so that the report can 
be read by a spreadsheet package that uses the comma-separated 
value (CSV) format.
by using secondary groupings through the Group by... and by... 
feature

Report data selections

You can use the following data elements to select the data to include in a 
report:

intervals
months
weeks
days
periods
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shifts
agents
subgroups
logical groups
ACD groups
ACD-DNs
LOB codes
walkaway codes

The set of data elements for which you can supply selection criteria depends 
on the report format you select and the report options (most notably, the 
selected time frame). For each applicable data element, you can enter 
selection criteria to limit the data in the report to a single data element, a 
range of data elements or, in some cases, a list of data elements.

Defining report parameters

Use the Report Parameter Definition window to define the format, scope, 
output device, and presentation method in a report (see Figure 76 on 
page 134). 

In the Report Parameter Definition window, you can name the definition and 
use the name as the title of the report. The report name is used in menus so 
that you can request the report by name, rather than recreate the report 
parameter definition each time you request that report.

Note: Ensure that the name assigned to a report is unique. CC MIS allows 
you to save multiple report parameter definitions with the same name. 
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Procedure 25: Accessing the Report Parameter Definition window

1 From the CC MIS main window, select Reports > Parameters. 

The Report Parameter Definition window appears (see Figure 76).

Figure 76: Report Parameter Definition window

Note: The ACD Group by Walkaway Code Report under Format provides 
a representative sample of the fields that can appear in the Data 
Selections area. Depending on the statistics group that the report format 
is based on, the fields displayed under Data Selections can be different 
from those shown here.

2 In the Name field, enter a name for the report.

3 To identify the report name as the title of the report, select Use as title.

4 In the Format section, identify a format for your report.

From the first list, choose Tabular, Graphic, or Event Log.



May 2007 Historical reports

CC MIS Getting Started Guide (Supervisor Interface) 135

From the second list, choose a category for the report (standard, 
public or personal) and select a format in that category from a menu. 
Icons indicate if the format is standard, public, or personal.

From the Contents Style list, select whether the report is generated 
by totals only, data only, data and totals, or as data export.

When selected, the Page Breaks check box inserts page breaks into 
the report. 

From the Language list, select the language to use in the report. This 
list is available only if the Language Support option is enabled on your 
system.

To generate a summary page describing the contents of the report, 
select the Summary Info check box.

5 In the Options section, identify the report options.

The Time Frame list identifies the time frames for which data is 
collected. Time Frame also determines the granularity of data. 
Possible values are intervals, shifts, days, weeks, periods, or months.

The Group by and and by lists indicate secondary groupings, which 
provide subtotals according to the chosen criteria. Possible selections 
(depending on the report) include (but are not limited to) the following: 
None, Shift, Day, Dst ACD Group, Logical Group, and Subgroup.

When selected, the Logical Groups check box indicates that you 
want the information grouped logically; that is, information for several 
various groups (defined as logical groups) are summed together. 

When selected, the Interval Lengths check box appends interval 
lengths to the interval time on interval reports. (For example, 
12:30, 05 where 05, after the comma, indicates the interval length, in 
minutes.)

The Network View field indicates that the Networking feature is 
enabled and that the time frame for the report contents includes 
values from the network. The NAP supervisor can specify how the 
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data is collected from the remote nodes. 

Example: 
A NAP supervisor in Location 1 requests a previous interval report at 
1700 EST. Three nodes exist in the virtual network for this NAP: the 
first in Location 2, the second in Location 3, and the third in 
Location 4. Interval time frame reports allow the Network View option 
to be selected.

Network View enabled: 
The data from the previous interval relative to the local time of each 
node is returned.

Network View disabled: 
The data from the (1630–1700) interval in each time zone is returned. 
In this example, this interval has not yet occurred in Locations 3 or 4. 
Therefore, these nodes return no data.

Node NAP Location 2 Location 3 Location 4

Time zone EST EST CST PST

Local time 1700 1700 1600 1400

Time requested 1630–1700 1630–1700 1530–1600 1330–1400

Interval returned 34 
(1630–1700)

32
(1530–1600)

28
(1330–1400)

Node NAP Location 2 Location 3 Location 4

Time zone EST EST CST* PST*

Local time 1700 1700 1600 1400

Time requested 1630–1700 1630–1700 1630–1700 1630–1700

Interval returned 34 
(1630–1700)

34
(1630–1700)

34
(1630–1700)

Note: The shaded areas indicate time ranges that have not 
occurred as of 1700 EST. These nodes return no data. The data 
from all nodes is available as soon as the earliest time zone (in 
this case, PST) completes the requested interval.
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6 In the Output To section, select a report destination from the list. The 
possible destinations include screen (default), a printer, a file, or an 
e-mail or fax.

If you select a file destination, the File Name field appears. 

If you select an e-mail or fax destination, a Destination field appears. 
(You must enter an e-mail address in this field.)

Note: You cannot e-mail or fax graphical reports.

7 In the Data Selections section, select the ranges for data elements from 
the Interval, Day, Dst ACD Group, Agent, and Walkaway Code lists.

This area defines ranges for data elements of the report format. For 
each list, you can select one of the following: All, Range, or defined 
lists (in applicable key fields). Interval and other time frame fields also 
contain the Current and Previous selections. 

Note: To select the previous time frame (such as day), you can select 
Previous, rather than selecting Range then entering a –1.

The Supervisor Scope list identifies the supervisor scope restriction 
to use for the report.

On a NAP partition, use the Node list to restrict a report to a specific 
node. Select a value for this field from the list (see Figure 77). 

Note: The Node list does not appear on local partitions.

Figure 77: Node list

8 Request that the report be generated immediately (an ad hoc report), or 
save the report to retrieve later or to attach to a schedule.
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Saving the report definition

You can save a report definition after you define the following information:

the report name
the report format and all desired options
the scope of the data to include in the report
the output destination

Depending on the reporting options enabled in your privilege level, you can 
save report definitions as either public or personal report definitions. You 
can generate personal report definitions only on an ad hoc basis. You can 
generate public definitions on an ad hoc basis or you can schedule them to 
automatically generate.

Note: You must have system administrator permissions to schedule reports.

Creating ad hoc reports

An ad hoc report is a report that is requested directly from the Report 
Parameter Definition, rather being scheduled. 
Procedure 26: Generating an ad hoc report

1 Complete the report parameters on the Report Parameter Definition 
window (see Procedure 25 on page 134).

2 Request the report using either the Report > Generate command or by 
clicking the Generate this report button on the toolbar.

Note: Reports that you request on an ad hoc basis do not require that 
you supply a name for them to be generated. The name is required only 
if you subsequently decide to save the report definition.

Each time you request an ad hoc report, it is saved to a special ad hoc 
personal report definition. If you exit the Report Parameter Definition 
window and then reenter it (even after you log off from the supervisor 
interface), you can retrieve the definition of your last ad hoc report using the 
Report > Open Ad hoc command.
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Determining report status
After you request an ad hoc report that is sent to the screen (or other 
location), the system notifies you that a report is gathering information or is 
pending. 

The system notifies you of the status of the report through the Report Status 
icon on the CC MIS main window. The Report Pending status is indicated 
by a report with an hourglass.

For reports sent to other destinations (besides the screen), you can use the 
Report Status Logs window to determine the status of the report. For more 
information, see “Report Status” on page 142.

Regardless of the report destination, you can request only one ad hoc report 
at a time. While the system generates an ad hoc report, the Report > 
Generate command is disabled, preventing you from requesting another 
report. 

Cancelling ad hoc report generation

If you make a mistake and want to cancel the ad hoc report that is currently 
generating, select the Report > Cancel command or click the corresponding 
toolbar button from within the Report Parameter Definition window (see 
Figure 78).
Figure 78: Cancel Report button

Cancel Report Generation 
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Viewing reports at your terminal

When you select Screen as your output device and generate a report, the 
report is sent to a file on the server that you can view on your terminal. After 
the report generates, you can use one of the following methods to view it:

On the main window, double-click the Report Status icon.
On the main window, select the Reports > View command.
On the Report Parameter Definition window, select the Report > View 
command.

The report arrives on your desktop screen where you can view it; you may 
need to resize the report in the window. 

The report remains active on your desktop until one of the following occurs:

You manually delete the report using the File > Delete command in the 
report preview window.
You replace the report with another soft-copy report that you requested 
be sent to the screen.

Note: You cannot view reports sent to printers on your screen. Reports sent 
to printers do not affect reports currently displayed on your screen.

You can view a report on your screen, leave the window that contains the 
report open, and request a different report through the Report Parameter 
Definition window. This action automatically closes the report-viewing 
window.

Viewing the report parameters
When a report appears on your screen, in addition to viewing the report, you 
can view the report parameters used to create it. To view the report 
parameters, view the report, and then select File > View Summary.
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Scheduling a report

After you define a report and save it as a public report definition, you can 
attach the report to a schedule and automatically generate it later. You must 
have the access to system administrator (Admin) privileges to schedule the 
report.

Note: Scheduled reports must have the output device set to something other 
than Screen. If the output device is Screen, the report is sent to the default 
printer specified in the Customer Options window.

Creating a data export report

A data export report can be used by a commercial spreadsheet software 
package. To generate a data export report, select Data Export Report from 
the Contents Style list. The resulting report contains only the title of the 
report and detail data lines in comma-separated value (CSV) format; it 
contains no column headings or column totals.

When you create a data export report, the file option is normally selected as 
the output device for the report. The file is saved on your supervisor 
terminal (or any other supervisor terminal). You can also print the report and 
send it to your terminal for display. You can then view the contents of the 
report before you actually generate a file to import into a spreadsheet.
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Report Status 

After you request any report (except ad hoc reports sent to the screen), you 
can use the Report Status Logs window to view the status of the report (see 
Figure 79). You can access this window using the Reports > Report Status 
Logs command in the CC MIS main window.
Figure 79: Report Status Logs window

The Report Status Logs window shows both ad hoc reports you requested 
and scheduled reports you saved.

Cancelling Pending Reports
If a requested report is pending, you can cancel the report using the File > 
Cancel command in the Report Status Logs window. To cancel a pending 
report, select the pending report in the list and choose the File > Cancel 
command.
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Viewing another supervisor's report
You can view another supervisor's report from your terminal, if that 
supervisor already requested the report, and if the report is in their inbox. 
Perform the steps in Procedure 27 to view another supervisor’s report.

Procedure 27: Viewing another supervisor’s report

1 From the display window, select Reports > Monitor View.

The Supervisor to Monitor? dialog box appears. 

2 Select a supervisor, and then click OK.

If a report is available, it appears on your screen. 

If no report is available for the selected supervisor, the following 
message appears: “There is no report available.” 

Generating an Event Log report

Event Log reports provide information about agent activities. For more 
information about Event Log reports, see the online Help.

Perform the steps in Procedure 28 to print an Event Log report. 

Note: These reports are not available for supervisors who have the Agent 
Performance option disabled in the Privilege Level Definition associated 
with their Supervisor Profile. 

Procedure 28: Printing an Event Log report

1 From the CC MIS main window, select Reports > Parameters. 

The system displays the Report Parameters Definitions window (see 
Figure 76 on page 134).

2 Identify your report parameters:

a. In the Format section, select Event Log.

b. In the Output To section, select a destination for the report from the 
list.

c. In the Data Selections section, provide the range for each data 
element.



Historical reports Standard 1.0

144 Call Center Management Information System

3 Select Report > Generate.

4 Select File > Exit. 

The system returns to the CC MIS main window.

Interval Configuration

Intervals for each hour of the day are configured in the CC MIS 
Maintenance and Administration interface. For more information about 
Interval Configuration, see CC MIS Installation and Maintenance (297-
2671-545). 

You can view the intervals used by your partition while in the Report 
Parameters Definition window by selecting the Report > Intervals 
command. Figure 80 shows the Interval Configuration dialog box.
Figure 80: Interval Configuration dialog box
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Customizing Reports

You can create personal (custom) tabular or graphic report formats. 

Tabular formats

Use the Tabular Format Definition window (see Figure 81) to define 
personal or public tabular formats. To access this window, select Reports > 
Tabular Formats. You can select formats defined on this window in the 
Report Parameter Definition window. 
Figure 81: Tabular Format Definition window
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Field descriptions

Format Title—Specify the format title. This name appears in other 
menus and serves as a default report title unless you specify a report title 
in a report parameter definition. This field accepts up to 55 characters. 
Statistics Group—Specify the statistical group: Destination ACD-GRP, 
Overflow, Agent, LOB Code, ACD-DN, or Walkaway.
Column Selections—Click the Edit Columns tab and choose the columns 
to make up the tabular report format. You can select columns by double-
clicking or by dragging them into the column selections area.
Custom Headings—Click the Edit Headings tab, and then type the 
custom column heading text as desired. You can also click Use standard 
headings as starting point to populate the heading text area with standard 
heading text and edit the text as desired.
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Graphic formats

Use the Graphic Format Definition window (see Figure 82) to define 
personal or public graphic formats. To access this window, select Reports > 
Graphic Formats. You can select formats defined and saved from this 
window in the Report Parameter Definition window. 
Figure 82: Graphic Format Definition window

Field descriptions

Graph Title—Specify the title for the graph.
Statistics Group—Specify the statistical group: Destination ACD-GRP, 
Overflow, Agent, LOB Code, ACD-DN, or Walkaway statistics. Select 
the statistics group from the list.
Chart Type—Specify the chart type for the graphic format. The window 
is redrawn with fields that apply to the type of chart you select. Seven 
chart types are available. Figure 82 on page 147 shows the first chart 
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type and Figure 83 shows the other six types. After you select the chart 
type and the window reappears, the graphic image of the chart is drawn 
in the window. 

Figure 83: Graphical chart types

Axis Labels—Specify the data and key axis labels for the chart.
Keys—Specify the axis and legend keys for the chart.
Data Elements:

Available Data Elements—This is a list of available statistics that you 
can add to the graph.
Selected Data Elements—This is a list of statistics that you added to 
the graph.

Note: To select an available data element and have it appear on the graph 
and in the selected list, you can double-click the desired data element or 
drag the element from the Available Data Elements to the Selected Data 
Elements column.
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Spectrums

Use the Spectrum Definition window (see Figure 84 on page 149) to define 
categories into which incoming calls are placed, based on the delay or the 
duration of the call. Access this window by selecting Reports > Spectrums. 
You can define up to 10 categories for each of the three available spectrums.

Spectrums are used in the following standard reports:

Delay Before Answering
Delay Before Abandoning
Call Duration

The individual categories are also available for custom reports in ACD 
Group Statistics.
Figure 84: Spectrum Definition window
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Listing of standard report formats

This section includes information about the following report formats:

Table 3 lists the standard tabular formats. 
Table 4 on page 153 lists the standard graphical formats.
Table 5 on page 154 list the event log formats.

  
Table 3: Standard tabular report formats (Part 1 of 3)

Standard format Explanation

ACD Call Duration The duration of a call by measuring from when the 
call is answered by the agent until the call is 
released by the agent.

ACD-DN Calls 
Abandoned

The total number of calls abandoned per ACD-DN 
and the total abandon delay.

ACD-DN Calls 
Answered

The total number of calls answered per ACD-DN 
and the total answer delay.

ACD Group by 
Agent Performance

Agent activities for each group. This report can tell 
if a problem exists with a particular agent or if all 
agents are experiencing the same difficulties.

ACD Group by 
Agent Transfer

Agent transfer activities for each group.

ACD Group by 
LOB Code

The number and duration of calls by LOB code for 
each group.

ACD Group by 
Walkaway Code

The walkaway codes associated with a specific 
ACD group.
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ACD Group Overflow For each source and destination ACD group pair, 
indicates the number of calls that either queue-
overflowed (for example, due to exceeding 
maximum wait or queue size) or time-overflowed 
from the source to the destination.

ACD Group 
Transfer-In 

The number of calls that were transferred in to a 
group.

ACD Group 
Transfer-Out

The number of calls that were transferred out of a 
group.

Agent Summary Details about the types of calls received and made 
and the amount of time each agent spent.

Agent by ACD 
Group Performance

The activities of all agents sorted by Agent ID 
trough ACD group.

Agent by LOB Code The activities of all agents sorted by LOB codes.

Agent by Subgroup 
Performance

The performance of each agent under  different 
subgroups.

Delay Before 
Abandoning

The number of calls abandoned and the length of 
time that callers waited before they hung up.

Delay Before 
Answering 

Information about the service callers receive. 

LOB Code by 
ACD Group 

The call processing time for each LOB code. 
Breaks down information to show which ACD 
group received the calls associated with the LOB 
code.

Table 3: Standard tabular report formats (Part 2 of 3)

Standard format Explanation
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LOB Code by Agent The call processing time for each LOB code and 
breaks down information to show the LOB codes 
associated with specific agents.

Summarized ACD-
DN Call Analysis

The ACD-DNs and summarizes the associated call 
activity.

Summarized ACD 
Group Call Analysis

An overall analysis of an ACD group.  Shows how 
calls were handled and maximum and average 
delays and call durations.

Summarized ACD 
Group Performance

Groups in the system and a summary of group load 
performance. It shows the actual number of calls 
each group answered and the average time it took 
to handle each call.

Summarized ACD 
Group Transfer 

The groups and a summary of transfer information 
for the groups.

Subgroup by Agent 
Performance

Provides supervisors with performance information 
for their agents.

Walkaway Code by 
ACD Group

The reason for and the total time spent in  
walkaway state by an agent in a specific ACD 
group. 

Walkaway Code by 
Agent ID

The reason for and the total time spent in walkaway 
state by an agent. 

Table 3: Standard tabular report formats (Part 3 of 3)

Standard format Explanation
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Table 4: Standard graphical report formats

Standard format Explanation

ACD Group Calls 
Abandoned Report

For each ACD Group, how many calls were 
abandoned before and after the callers received 
a recorded announcement.

ACD Group Calls 
Answered Delay Report

For each ACD group, how many calls were 
answered before and after the delay objective. 

ACD-DN Calls 
Abandoned Report

For each ACD-DN, how many calls were 
abandoned before and after the callers received 
a recorded announcement.

ACD-DN Calls Answered 
Delay Report

For each ACD-DN, how many calls were 
answered before and after the delay objective.
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Table 5: Standard event log report formats

Standard format Explanation

Agent All Login/Logout 
Report

The time and length of each agent’s logon and 
logoff activities during the day. You can use this 
reportto verify shift and break times.

Agent Detail Report The time and length of each agent’s logon, 
logoff, and walkaway activities during the day. 
You can use this report to verify shift times, 
break times, and walkaway times.

Agent First Login/Last 
Logout Report

When an agent started and ended on that day 
and how much time was spent in staffed status. 
You can use this report as a summary for payroll 
and administration and to show variations in the 
overall efficiency of individual agents.

Agent Trace Report The time and activity of each agent’s calls 
during the day. You can use this report to verify 
agent activity and call handling.

Agent Walkaway Report The time and length of each agent’s logon, 
logoff, and walkaway activities during the day. 
You can use this report to verify shift times, 
break times, and walkaway times.
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C h a p t e r  1 1

Configuration Control

In this chapter
Introduction . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 156

Networked CC MIS . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 157

Accessing Configuration Control functions . . . . . . . . . . . . . . . . . . . . . . 158

Using Configuration Control efficiently  . . . . . . . . . . . . . . . . . . . . . . . . . 181



Configuration Control Standard 1.0

156 Call Center Management Information System

Introduction

In the Configuration Control window, you can view and adjust parameters 
inside the ACD switch that relate to operating functions such as traffic 
control and staffing. 

CC MIS provides two modes of security to give supervisors control over 
access to Configuration Control screens and system administration. The two 
modes are as follows:

Privilege Level Definition 
Scope Definition
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Networked CC MIS

When the Networking feature is enabled, the Configuration Control 
windows contain a Node field and the Insert dialogs allow for Node 
selection. The Node field identifies the position node, ACD group, or ACD-
DN. With the node selection function, you can select a node, and then insert 
items listed under the selected node.

Note: The Automatic Position Reassignment (APR) feature assigns a 
desired subgroup (or APR) to each agent. The subgroup is stored in the 
agent definition database table on the local partition that contains the 
positions that the agent can log on to. Because Network Access Partitions 
(NAPs) have no direct access to this information, the APR subgroup field is 
not displayed in the Position Reassignment Configuration Control windows 
of NAP partitions.
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Accessing Configuration Control 
functions

Access the CC MIS Configuration Control (load management) functions 
from the Config menu in the CC MIS main window. Perform the steps in 
Procedure 29 to access the Config menu. 
Procedure 29: Accessing the Config menu

1 From the CC MIS main window, select Config. 

The Config menu appears (see Figure 85).

Figure 85: Config menu

2 Select the desired command from the menu.

Note: The Config menu can appear differently than shown in Figure 85 
because some or all Configuration Control features may not be enabled 
in your privilege level.
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Ad hoc Load Management screens

Use Ad hoc Load Management screens to make and execute immediate load 
management changes. All screens for Positions, Groups, ACD-DNs, and 
Networking follow the same format and have the same commands.

Screen functionality
The following terms are used to describe the Configuration Control 
windows: 

Cell—A cell is a row and column location in the data portion of the 
window.
Key field or column—The leftmost column of the data portion of the 
window is referred to as the key field or key column.
Key—The data (or type of data) that is in the leftmost cell of any row. 
Null cell—The bottom cell that serves as a place holder to insert new 
cells. No data can be associated with this cell.

Configuration Control windows are initially displayed with a cursor in the 
upper left corner cell of the data portion of the screen. The types of keys are 
as follows: 

Positions
ACD groups
ACD-DNs
ACD group pairs

Insert dialog box

To display the Insert dialog box, select Edit > Insert or press the Insert key 
on your keyboard. 

You can insert keys and their associated data into the screen by using the 
Insert dialog box. The contents of the Insert dialog box depend on the type 
of window currently displayed. Figure 86 shows the Insert dialog box 
(specifically Insert Position(s) dialog box).
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Figure 86: Insert dialog box—Insert Position(s)

Show Changes
The default setting for the Show Changes option (on the Preferences menu) 
is checked. This setting (indicated by a check mark) allows you to see the 
changes made to any field on the window. When you clear the check box, 
the window displays the original data on the screen. (Changes made remain 
even though they do not appear on the screen.) 
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Changing agent position assignments

You can use the Config > Positions command to view or change the 
subgroup and ACD group assignments of specified agent-positions. The 
changes that you make using this command alter the KSETFEAT table. 

Figure 87 shows the Configuration Control – Positions window.
Figure 87: Configuration Control—Positions window 
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Position Assignments fields

Position—Identifies an existing agent position ID. Use the Edit > Insert 
command to insert positions. (Positions are up to four digits in length.)
Node—Identifies the node on which the position resides in the network. 
This is a display-only field. The field is available only on Network 
Access Partitions (NAP).
Subgroup—Identifies the subgroup and ACD group to which the 
position is assigned.
APR Subgroup—Identifies the Automatic Position Reassignment (APR) 
subgroup of the current agent. This field appears only if the current 
subgroup does not match the APR subgroup and if APR is enabled in 
Customer Options. This field is displayed only if the APR feature is 
enabled and if you are not logged on to a Network Access Partition. 
Current Agent—Displays the ID and name of the agent currently logged 
on to that position. No input is accepted. This field is displayed only if 
the Agent Identity option is enabled in the supervisor’s associated 
Privilege Level Definition.

Moving an active position to a new group

When a position that is currently active on an ACD call is moved to a new 
ACD group, the position appears to be in the new group on the Agent Status 
display. However, the statistics for the agent are counted against the old 
group until the current call completes.
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Changing agent set parameters

Use the Config > Groups > Agent Set Parameters command to change the 
multistage queue threshold settings, the number of display digits, the default 
LOB code, and the ACD group wrap-up time for agent sets. Changes alter 
the ACDGRP table. 

Figure 88 shows the Agent Set Parameters window. 
Figure 88: Configuration Control—Agent Set Parameters window

Note: Asterisks (***) that appear in a field of a Configuration Control 
window indicate that the feature associated with the field is not enabled for 
that ACD group on the switch. You cannot change these fields.
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Agent Set Parameters fields 

ACD Group—Identifies the name or primary DN of an existing ACD 
group. Valid input (using Edit > Insert) is any existing ACD group name, 
ACD group list name, or ACD group by its primary DN. 
Node—Identifies the node on which the group resides on the network. 
This field is display-only and appears only on NAPs.
Multi-Stage Queue Threshold Type—Identifies whether the Multi-Stage 
Queue ranges are associated with call queue size or call wait time. The 
valid values are QSize or WTime.
Multi-Stage Queue Threshold—Identifies three threshold values that 
represent indicators on agent sets. Each threshold depends on the 
threshold type (either wait time or queue size). 
Display Digits—Specifies the number of digits displayed to agents in the 
ACD group. The range is 0 to 10 and is selected from a menu.
Default LOB—LOB is the line-of-business code for the ACD group. A 
valid range is 0 to 999.
Wrap-Up Time—Defines the group wrap-up time (the default amount of 
time an agent is unavailable after handling an ACD call). This is 
considered as agent not-ready time and is pegged as variable wrap-up 
time and shown as VARWRAP on the Agent Status window. A valid 
range is 1 to 600 seconds.
Note: Agent wrap-up time overrides the default wrap-up time if it is 
datafilled in the ACD Table ACDLOGIN or Table ACDENLOG.
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Changing queue size parameters of an ACD group

Use the Config > Groups > Queue Sizes command to view or change the 
queue size parameters of specified ACD groups. Changing fields alters the 
Table ACDGRP. 

Note: If you use the BCS 35 protocol, you must datafill the MAXCQLMT 
and MAXVQLMT options on the switch to change queue sizes. If either 
options is not datafilled, the following two error messages are displayed (in 
order):

“Max Call Queue threshold value exceeds limit”
“Max Virtual Call Queue threshold value exceeds limit”

Figure 89 shows the Queue Sizes window.
Figure 89: Configuration Control—Queue Sizes window 

Note: Asterisks (***) that appear in a field of a Configuration Control 
window indicate that the feature associated with the field is not enabled for 
that ACD group on the switch. You cannot change these fields.
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Queue Size fields 

ACD Group—Identifies the name or primary DN of an existing ACD 
group. Valid input is any existing ACD group name or ACD Group list 
name. You can also enter primary ACD-DNs.
Node—Identifies the node on which the group resides in the network. 
This field is display-only and appears only on NAPs.
Maximum Calls—Identifies the maximum number of calls that can be 
queued in this ACD group incoming call queue at any one time. Valid 
input is any number from 0 to 511. A zero value means that this ACD 
group does not have call queuing but routes to the table specified in 
either the Threshold Route or Overflow Targets fields in the Overflow 
Targets window. 
Maximum Wait Time—Identifies the maximum number of seconds that 
a call can be held in the incoming call queue before an agent answers it. 
Valid input is any number from 0 to 1800 seconds.
Maximum Incoming Overflow—Identifies the maximum number of 
logical calls that can be queued. Valid input is any number from 0 to 511.   
Maximum Transfer—Identifies the maximum number of calls that can be 
transferred to agents in this ACD group. Valid input is any number from 
0 to 42. 
Note: The Call Transfer Queue Size depends on the maximum call queue 
size for your group. Normally, the range is 0 to 42, but if the maximum 
call queue size is less than 42, that lower value cannot be exceeded.
Priority Promotion Timer—Identifies the maximum amount of time an 
unanswered call can remain in a particular priority queue. When the call 
exceeds this Priority Promotion Timer value, it is promoted to the next 
higher priority queue. Valid input is any number from 0 to 255. A zero 
value means that priority promotion time out does not apply.

Changing time overflow parameters of an ACD group

Use the Config > Groups > Time Overflow command to view or change the 
time overflow parameters of specified ACD groups. This option alters the 
Table ACDGRP.
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Figure 90 shows the Time Overflow Parameters window. 
Figure 90: Configuration Control—Time Overflow Parameters window

Note: Asterisks (***) that appear in a field of a Configuration Control 
window indicate that the feature associated with the field is not enabled for 
that ACD group on the switch. You cannot change these fields.
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Time Overflow Parameters fields 
The Time Overflow Parameters window contains the following fields:

ACD Group—Identifies the name or primary DN of an existing ACD 
group. Valid input is any existing ACD group name or ACD group list 
name. You can use primary ACD-DNs.
Node—Identifies the node on which the group resides in the network. 
This field is display-only and appears only on NAPs.
Priority 0 Only—Identifies that only priority 0 calls have time delay 
overflow. Valid input is either yes or no. If the value is no, then all calls 
have time delay overflow.
Immediate Timer—Identifies that timing for time delay overflow starts 
as soon as a call is received. Valid input is either yes or no.
Time Delay Threshold—Identifies the time delay overflow threshold that 
applies to all calls or priority 0 calls only. Valid input is 0 to 1800.
Service Order—Identifies the order in which the call queues are 
serviced. Valid input is as follows: 

0 = Outflow calls, then inflow calls, then calls queued within priority
1 = Outflow calls, then priority 0 calls, then inflow calls, then other 
calls queued within priority 
2 = Oldest call of either the physical or the logical queue 

Time Delay Time—Identifies the amount of time in seconds a time delay 
overflowed call remains in queue before being rerouted to the Time 
Delay Threshold Route. Valid input is 0 to 1800.
Threshold Route—Identifies the route used to reroute time delay 
overflow calls. Valid input is Table OFRT or Table IBNRTE and 0 to 
1023.
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Changing the overflow targets for an ACD group

Use the Config > Groups > Overflow Targets command to view or change 
the overflow targets of specified ACD groups. The changes to this option 
alter Table ACDGRP.

Figure 91 shows the Overflow Targets window.
Figure 91: Configuration Control—Overflow Targets window



Configuration Control Standard 1.0

170 Call Center Management Information System

Overflow Targets fields

ACD Group—Identifies the name or primary DN of an existing ACD 
group. Valid input is any existing ACD group name or ACD group list 
name. You can use primary ACD-DNs.
Node—Identifies the node on which the group resides on the network. 
This field is display-only and appears only on Network Access Partitions 
(NAPs).
Overflow Targets—Identifies up to four targets to enhance overflow. 
Accepts the primary DN of an ACD group or a group name as input.
Threshold Route—Identifies the route used to reroute time delay 
overflow calls. 
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Changing recorded announcements parameters of an 
ACD group

Use the Config > Groups > Recorded Announcements command to view or 
change parameters for the recorded announcements (RAN) of specified 
ACD groups. The changes to this option alter the Tables ACDGRP and 
AUDIO.

Figure 92 shows the Recorded Announcements window.
Figure 92: Configuration Control—Recorded Announcements window
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Recorded Announcements fields 

ACD Group—Identifies the name or primary DN of an existing ACD 
group. Valid input is any existing ACD group name or ACD group list 
name using the Edit > Insert command. You can use primary ACD-DNs.
Node—Identifies the node on which the group resides on the network. 
This field is display-only and appears only on NAPs.
Threshold—Identifies the length of time the incoming call waits in the 
queue before the caller receives a recorded announcement. If this value is 
0, the caller receives an announcement immediately upon entering the 
incoming call queue for this ACD Group and does not receive a ring 
(RINGING field in table ACD Group = No). Valid input is 0 and 6 to 60.
Audio Group—Identifies the audio group which, in turn, identifies the 
choices (MUSIC, SILENCE, ANN, and REPEAT) and the number of 
times these recorded announcement choices play to queued calls in this 
ACD group. If the existing value in the Audio Group field is 0, the DMS-
ACD has no defined audio group for the related ACD group. Valid input 
is 1 to 512.
Forced Incoming—Identifies the audio group to use to give forced 
incoming announcements to new incoming ACD calls. Valid input is 1 to 
512. 
Forced Overflow—Identifies the audio group to use to give forced 
overflow announcements for deflected ACD calls. Valid input is
1 to 512.
Provide Announcements—Specifies if the ACD group provides forced 
incoming announcements and delay announcements for calls that 
overflow into this group. Valid input is Yes or No. (This specifies which 
announcement the caller hears: either the announcement from the 
original group called or the announcement from the group to which the 
caller is overflowed.)
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Changing special routing parameters for an ACD group

Use the Config > Groups > Special Routing command to view or change the 
night service and control interflow parameters of specified ACD groups. 
The changes to this option alter Table ACDGRP. ACD activates the night 
service feature when all agents in an ACD group have log off their 
telephones. 

All calls that reside in the incoming call queue at this time remain in queue 
(unless the call queue clearing ACD feature is active) until the caller 
disconnects, but no new incoming calls are received by this ACD group. 
The supervisor can activate the night service and controlled interflow 
features.

Figure 93 shows the Special Routing window.
Figure 93: Configuration Control—Special Routing window
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Special Routing option fields

ACD Group—Identifies the name or primary DN of an existing ACD 
group. Valid input is any existing ACD group name or ACD group list 
name using the Edit > Insert command. You can use primary ACD-DNs.
Node—Identifies the node on which the group resides on the network. 
This field is display-only and appears only on NAPs.
Night Service Route—Identifies a table name and an index number to 
which this ACD group routes night service calls. Valid input is either 
Tables OFRT or IBNRTE and an existing index number.
Night Service Group—Identifies the Audio Group used to provide a 
night service announcement to callers prior to rerouting the call to the 
night service route. Valid input is 1 to 512.
Controlled Interflow Route—Identifies the route the calls take when the 
supervisor places the group into controlled interflow mode. Values for 
this field are Tables OFRT and IBNRTE and index ranges 0 to 1023. 
Re-Enqueue Time—The maximum amount of time in seconds a 
reenqueued call remains queued before being rerouted to the reenqueue 
route. Valid input is 0 to 1800.
 Re-Enqueue Route—The reenqueue route that consists of table (Values: 
OFRT and IBNRTE) and index (Range: 0 to 1023). 
Re-Enqueue Audio Table—The audio group used to provide reenqueue 
announcement to callers prior to rerouting the call to the reenqueue 
route. Valid input is 1 to 512.
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Changing network parameters for an ACD group

Use the Config > Groups > Network Parameters command to change 
various parameters that are used to network ACD groups (NACD). The 
changes to this option alter Table NACDGRP.

Figure 94 shows the Network Parameters window.
Figure 94: Configuration Control—Network Parameters window

Note: Asterisk (***) that appear in a field of a Configuration Control 
window indicate that the feature associated with the field is not enabled for 
that ACD group on the switch. You cannot change these fields.
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Network Parameters option fields

ACD Group—This field identifies the name or number of the ACD 
Group. This field can display primary ACD-DNs.
Node—This field identifies the node on which the group resides on the 
network. This field is display-only and appears only on NAPs.
Call Threshold—This field can change the queue threshold with a range 
of 0 to 511. 
Wait Threshold—This field can change the maximum wait threshold 
with a range of 0 to 1800.
Preference Weighting Factor—This field shows the group preference 
weight factor with a range of 0 to 32767. 
Most Idle Agent—This is the factor used to calculate the Resource Index 
for the group with a range of 0 to 600. 
Num Idle Agent—This is the factor used to calculate the Resource Index 
for the group with a range of 0 to 255. 
Service Rate—This is the average service rate (call handling time) for 
the group with a range of 0 to 600. 
Consider Source—This field specifies whether to consider the source 
group when determining the best target group for time overflow calls. 
Valid input is Yes or No.
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Changing ACD-DN assignments and priorities 

Use the Config > ACD-DNs command to change the trunk priorities for 
specified ACD-DNs, the line priorities of primary DNs, the group 
assignments of supplementary DNs, and the name of the ACD-DN. The 
changes to this option alter the Tables DNROUTE and DNATTRS.

Figure 95 shows the Change ACD-DNs (Assignments and Priorities) 
window.
Figure 95: Configuration Control—ACD-DNs window
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ACD-DNs fields 

ACD-DN—Identifies the existing ACD-DN. Valid input is any existing 
ACD-DN number or ACD-DN list name using the Edit > Insert 
command.
Node—Identifies the node on which the group resides on the network. 
This field is display-only and appears only on NAPs.
DN Type—Identifies the DN as a primary or supplementary DN. Each 
ACD group receives calls from one primary ACD-DN and zero or more 
supplementary DNs. The maximum number of supplementary DNs 
associated with an ACD group depends on the software release of the 
switch but can be either 16 or 64.
Trunk Priority—Identifies the priority for ACD calls that arrive over 
trunks. Valid input is 0 to 3, where 0 is the highest priority and 3 is the 
lowest priority.
Line Priority—Identifies the priority for ACD calls that arrive over lines 
or for ACD calls originated from within the same switch. Valid input is 0 
to 3, where 0 is the highest priority and 3 is the lowest priority. The field 
remains blank and is not accessible if the DN type is Supplementary.
ACD Group—Identifies the name or Primary DN of an existing ACD 
group that processes calls for this ACD DN. Valid input is any existing 
ACD group name or ACD Primary DN.
Name—Identifies the name of the ACD-DN. Valid input is 15 characters 
or less. CC MIS does not use this name.
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Changing network targets 

Use the Config > Networking command to set the Preference Weighting 
Factor for networked ACD groups. (You can also set the Resource Index for 
networked groups on non-DMS switches.) The changes to this option alter 
Tables NACDGRP and REMNACD.

Figure 96 shows the Network Targets window.
Figure 96: Configuration Control—Network Targets window
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Network Targets option fields

Source/Destination ACD Group Pair—This field identifies the 
destination ACD groups that are network targets of the source ACD 
group. A total of 48 destination groups can exist for each source ACD 
group. 
Node—Identifies the node on which the group resides on the network. 
This field is display-only and appears only on NAPs.
Preference Weighting Factor—Change the Preference Weight Factor for 
the source/destination ACD group pair. The range of this field is 0 to 
32767.
Resource Index Value—This is the current Resource Index for the 
destination ACD group. (This is a display-only field.)
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Using Configuration Control efficiently

Configuration Control has several features that you can use to effectively 
control configuration. These features include the following:

defining change orders rather than on-demand requests
defining lists
viewing the transaction log

Change orders are defined for the following:

schedule the changes
initiate several changes on one schedule
define changes you use frequently

Note: You must have system administrator abilities (access to Admin) to 
schedule a change order. 

When you define a change order, group a set of Configuration Control 
changes and reference them by the change order name. You can either 
execute these change orders immediately or schedule the changes to execute 
at either a later date and time or at recurring intervals. 

Note: CC MIS allows multiple change orders to be saved with the same 
name. When you modify an existing change order, use the Overwrite an 
existing change order command to prevent the system from saving different 
change orders with the same name.

Figure 97 on page 182 shows the Change Orders window.
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Figure 97: Configuration Control—Change Orders window 

Use the View > Transaction Log and View > Execution Queue commands to 
monitor the status of your changes.

Provide a change order name and, in the Configuration Area list, select the 
area in which to make the change (see Figure 98 on page 183).
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Figure 98: Change Order Name field and Configuration Area list  

Use the Edit > Insert command to view the desired values. 

After the insert action is complete, you can select the field to modify and 
enter the new value (see Figure 99 on page 184).
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Figure 99: Enter new value

After you make the modifications, use the File menu commands to Save, 
Schedule, or Execute your change order.
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Viewing Configuration Control database tables

You can view the data tables through the Config/View or View menus. 

Configuration Control database tables 

Route List—Displays the route list for all ACD Groups in the current 
configuration. After the initial screen appears, use the Page Up and Page 
Down keys or the scroll bar to scroll through the table.
Audio List—Displays the audio list for all ACD Groups in the current 
configuration. After the initial screen appears, use the Page Up and Page 
Down keys or the scroll bar to scroll through the table.
OFRT Tables—Selection displays a sub-menu. Menu options are OFRT, 
OFR2, OFR3, and OFR4. Selecting one of these options displays all 
defined entries in that table. After the initial screen opens, use the Page 
Up and Page Down keys to scroll through the table. 
IBNRTE Tables—Selection displays a submenu. Menu options are 
IBNRTE, IBNRT2, IBNRT3, and IBNRT4. Select one of these options to 
display all defined entries in that table. After the initial screen appears, 
use the Page Up and Page Down keys to scroll through the table. 
Audio Table—Displays all defined ACD entries in the Audio table. After 
the initial screen appears, use the Page Up and Page Down keys to scroll 
through the table.
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Supported Route Selectors
The CC MIS application queries the switch for the contents of the OFRT 
and IBNRTE routing tables (including the expanded OFRn and IBNRTn 
tables) upon connection to the switch and during scheduled configuration 
updates. Due to limitations in the ACDMIS protocol used between the 
switch and the CC MIS system, not all types of routing table entries that can 
be defined on the switch can be sent to the CC MIS system:

The route selectors in the OFRT tables that can be sent to the CC MIS are 
CND, DN, MN, N, NOT, RT, S, ST, T, and TS.
The route selectors in the IBNRTE tables that can be sent to the CCMIS 
are AC, CFT, CND, DN, EOW, LINE, N, NOT, OW, RX, S, T, and VFG.

Any unlisted routing table entry using a route selector appears in the 
Configuration Control routing table display windows as ROUTE INFO 
NOT AVAILABLE. 

The supported route selectors for the OFRT and IBNRTE tables map to the 
CC MIS descriptions as listed in Table 6.
Table 6: CC MIS route selectors mapping (Part 1 of 2)

CC MIS description OFRT 
selectors

IBNRTE 
selectors

ROUTES TO TABLE ENTRY <x> T, ST T, OW

CONDITIONALLY ROUTES TO <x> CND, NOT CND, NOT

ROUTES TO <dn> RT LINE

ROUTES TO <dn> DN DN

ROUTES TO CUSTOMER GROUP 
<x>, SUBGROUP <x>

RX

ROUTES TO TRUNK GROUP <x> S, N, MN, TS S, N, CFT, OW
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ROUTES TO VTG <xxx> OW, EOW, VFG

ROUTES TO ATTENDANT CONSOLE 
<xxx>

AC

Table 6: CC MIS route selectors mapping (Part 2 of 2)

CC MIS description OFRT 
selectors

IBNRTE 
selectors
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C h a p t e r  1 2
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Introduction

System reports provide information derived from the system database. That 
is, system reports provide a way to report what is currently defined in the 
various database tables maintained by CC MIS (primarily through the 
Admin menu). As a result, system reports do not require you to define the 
report parameters. 

The following system reports are available:

ACD Group Configuration Report
ACD Group Database Report
ACD Networks Targets Configuration Report
ACD Position Configuration Report
ACD-DN Configuration Report
ACD-DN Database Report
Agent Database Report
Alarm Definitions Database Report
Graphic Format Database Report
Interval Configuration Database Report
List Definition Database Report
LOB Code Database Report
Logical Group Database Report
Period Definition Database Report
Privilege Level Database Report
Schedule Definition Database Report
Scope Database Report
Shift Definition Database Report
Spectrum Definition Database Report
Supervisor Database Report
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Threshold Definition Database Report 
Tabular Format Database Report
Walkaway Code Database Report
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Printing a system report

You can print system reports (see Procedure 30) or view the reports on your 
screen. You can also send system reports by e-mail or send them to a file 
destination. 

You can request system reports through the System Reports window.

Note: You can specify the range of the report for several system reports. 
Examples are the Supervisor Database Report, Agent Database Report, and 
ACD Group Database Report.

Procedure 30: Printing a system report

1 From the display window, select Reports > System Reports.

The System Reports window appears (see Figure 100). 

Figure 100: System Reports window
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2 Identify the report:

a. From the Report Type list, select your report from the options.

b. If you are prompted for additional information, select the appropriate 
option from the Selection list.

c. Select the report Output Device. The Output Device destination 
includes the screen, a printer, a file (stored on the hard disk), or to an 
e-mail address.

3 Select File > Print (or press the Generate this Report button on the 
toolbar) to generate the report.

4 Select File > Exit to return to the CC MIS main window.
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