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Copyright © 2006 Nortel Networks. All rights reserved.

The information in this document is subject to change without notice. The statements, configurations, technical data, and 
recommendations in this document are believed to be accurate and reliable, but are presented without express or implied 
warranty. Users must take full responsibility for their applications of any products specified in this document. The 
information in this document is proprietary to Nortel Networks Inc. 

The software described in this document is furnished under a license agreement and may be used only in accordance 
with the terms of that license. The software license agreement is included in this document.

Trademarks
Nortel Networks, the Nortel Networks logo, the Globemark, Unified Networks, and PASSPORT are trademarks of 
Nortel Networks.

Microsoft, Windows, and Windows NT are trademarks of Microsoft Corporation.

Adobe and Acrobat Reader are trademarks of Adobe Systems Incorporated.

UNIX is a trademark of X/Open Company Limited.

The asterisk after a name denotes a trademarked item.

Restricted rights legend

Use, duplication, or disclosure by the United States Government is subject to restrictions as set forth in subparagraph 
(c)(1)(ii) of the Rights in Technical Data and Computer Software clause at DFARS 252.227-7013.

Notwithstanding any other license agreement that may pertain to, or accompany the delivery of, this computer software, 
the rights of the United States Government regarding its use, reproduction, and disclosure are as set forth in the 
Commercial Computer Software-Restricted Rights clause at FAR 52.227-19.

Statement of conditions

In the interest of improving internal design, operational function, and/or reliability, Nortel Networks Inc. reserves the 
right to make changes to the products described in this document without notice.

Nortel Networks Inc. does not assume any liability that may occur due to the use or application of the product(s) or 
circuit layout(s) described herein.

Portions of the code in this software product may be Copyright © 1988, Regents of the University of California. All 
rights reserved. Redistribution and use in source and binary forms of such portions are permitted, provided that the 
above copyright notice and this paragraph are duplicated in all such forms and that any documentation, advertising 
materials, and other materials related to such distribution and use acknowledge that such portions of the software were 
developed by the University of California, Berkeley. The name of the University may not be used to endorse or promote 
products derived from such portions of the software without specific prior written permission.

SUCH PORTIONS OF THE SOFTWARE ARE PROVIDED “AS IS” AND WITHOUT ANY EXPRESS OR 
IMPLIED WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED WARRANTIES OF 
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE.

In addition, the program and information contained herein are licensed only pursuant to a license agreement that contains 
restrictions on use and disclosure (that may incorporate by reference certain limitations and notices imposed by third 
parties).
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Nortel Networks Inc. software license agreement

This Software License Agreement (“License Agreement”) is between you, the end-user (“Customer”) and Nortel 
Networks Corporation and its subsidiaries and affiliates (“Nortel Networks”). PLEASE READ THE FOLLOWING 
CAREFULLY. YOU MUST ACCEPT THESE LICENSE TERMS IN ORDER TO DOWNLOAD AND/OR USE THE 
SOFTWARE.  USE OF THE SOFTWARE CONSTITUTES YOUR ACCEPTANCE OF THIS LICENSE 
AGREEMENT.  If you do not accept these terms and conditions, return the Software, unused and in the original 
shipping container, within 30 days of purchase to obtain a credit for the full purchase price.

“Software” is owned or licensed by Nortel Networks, its parent or one of its subsidiaries or affiliates, and is copyrighted 
and licensed, not sold. Software consists of machine-readable instructions, its components, data, audio-visual content 
(such as images, text, recordings or pictures) and related licensed materials including all whole or partial copies.  Nortel 
Networks grants you a license to use the Software only in the country where you acquired the Software.  You obtain no 
rights other than those granted to you under this License Agreement.  You are responsible for the selection of the 
Software and for the installation of, use of, and results obtained from the Software.

1. Licensed Use of Software. Nortel Networks grants Customer a nonexclusive license to use a copy of the Software 
on only one machine at any one time or to the extent of the activation or authorized usage level, whichever is applicable.  
To the extent Software is furnished for use with designated hardware or Customer furnished equipment (“CFE”), 
Customer is granted a nonexclusive license to use Software only on such hardware or CFE, as applicable.  Software 
contains trade secrets and Customer agrees to treat Software as confidential information using the same care and 
discretion Customer uses with its own similar information that it does not wish to disclose, publish or disseminate.  
Customer will ensure that anyone who uses the Software does so only in compliance with the terms of this Agreement.  
Customer shall not a) use, copy, modify, transfer or distribute the Software except as expressly authorized; b) reverse 
assemble, reverse compile, reverse engineer or otherwise translate the Software; c) create derivative works or 
modifications unless expressly authorized; or d) sublicense, rent or lease the Software. Licensors of intellectual property 
to Nortel Networks are beneficiaries of this provision. Upon termination or breach of the license by Customer or in the 
event designated hardware or CFE is no longer in use, Customer will promptly return the Software to Nortel Networks 
or certify its destruction.  Nortel Networks may audit by remote polling or other reasonable means to determine 
Customer’s Software activation or usage levels.   If suppliers of third party software included in Software require Nortel 
Networks to include additional or different terms, Customer agrees to abide by such terms provided by Nortel Networks 
with respect to such third party software.

2. Warranty.  Except as may be otherwise expressly agreed to in writing between Nortel Networks and Customer, 
Software is provided “AS IS” without any warranties (conditions) of any kind. NORTEL NETWORKS DISCLAIMS 
ALL WARRANTIES (CONDITIONS) FOR THE SOFTWARE, EITHER EXPRESS OR IMPLIED, INCLUDING, 
BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABLITITY AND FITNESS FOR A 
PARTICULAR PURPOSE AND ANY WARRANTY OF NON-INFRINGEMENT.  Nortel Networks is not obligated 
to provide support of any kind for the Software.  Some jurisdictions do not allow exclusion of implied warranties, and, in 
such event, the above exclusions may not apply.  

3. Limitation of Remedies.  IN NO EVENT SHALL NORTEL NETWORKS OR ITS AGENTS OR SUPPLIERS 
BE LIABLE FOR ANY OF THE FOLLOWING: a) DAMAGES BASED ON ANY THIRD PARTY CLAIM; b) LOSS 
OF, OR DAMAGE TO, CUSTOMER’S RECORDS, FILES OR DATA; OR c) DIRECT, INDIRECT, SPECIAL, 
INCIDENTAL, PUNITIVE, OR CONSEQUENTIAL DAMAGES (INCLUDING LOST PROFITS OR SAVINGS), 
WHETHER IN CONTRACT, TORT OR OTHERWISE (INCLUDING NEGLIGENCE) ARISING OUT OF YOUR 
USE OF THE SOFTWARE, EVEN IF NORTEL NETWORKS, ITS AGENTS OR SUPPLIERS HAVE BEEN 
ADVISED OF THEIR POSSIBILITY.  The forgoing limitations of remedies also apply to any developer and/or supplier 
of the Software.  Such developer and/or supplier is an intended beneficiary of this Section.  Some jurisdictions do not 
allow these limitations or exclusions and, in such event, they may not apply.

4. General

a. If Customer is the United States Government, the following paragraph shall apply: All Nortel Networks 
Software available under this License Agreement is commercial computer software and commercial computer 
software documentation and, in the event Software is licensed for or on behalf of the United States 
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Government, the respective rights to the software and software documentation are governed by Nortel 
Networks standard commercial license in accordance with U.S. Federal Regulations at 48 C.F.R. Sections 
12.212 (for non-DoD entities) and 48 C.F.R. 227.7202 (for DoD entities).

b. Customer may terminate the license at any time. Nortel Networks may terminate the license if Customer fails 
to comply with the terms and conditions of this license. In either event, upon termination, Customer must 
either return the Software to Nortel Networks or certify its destruction.

c. Customer is responsible for payment of any taxes, including personal property taxes, resulting from 
Customer’s use of the Software. Customer agrees to comply with all applicable laws including all applicable 
export and import laws and regulations.

d. Neither party may bring an action, regardless of form, more than two years after the cause of the action arose.

e. The terms and conditions of this License Agreement form the complete and exclusive agreement between 
Customer and Nortel Networks.

f. This License Agreement is governed by the laws of the country in which Customer acquires the Software. If the 
Software is acquired in the United States, then this License Agreement is governed by the laws of the state of 
New York.
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Revision history
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Q01373211: Change in documentation: Added step 7—In the Run dialog box, 
click OK (“Installing JDM on Windows from the CD” on page 25).

Q01377650: Change in documentation: Added procedure to uninstall Device 
Manager (“Uninstalling Device Manager on Windows” on page 21).
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Preface

Device Manager is a graphical user interface (GUI) used to configure and manage 
Passport* 8000 Series switches. You install it on a management station in the 
network.

This guide describes how to install and start the Device Manager software on a 
Windows* or UNIX* platform. It also describes some common startup problems 
and how to troubleshoot them.
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14 Preface
Before you begin

This guide is intended for network administrators with the following background:

• Basic knowledge of networks, Ethernet bridging, and IP and IPX routing

• Familiarity with networking concepts and terminology

• Basic knowledge of network topologies

• Experience with windowing systems or graphical user interfaces (GUIs)
316341-B Rev 01



Preface 15
Text conventions

This guide uses the following text conventions:

angle brackets (< >) Indicate that you choose the text to enter based on the 
description inside the brackets. The description may list 
the exact text choices or may indicate the type of 
information needed. Do not type the brackets when 
entering the command. 
Example: If the command syntax is:
config cli more <true | false>, you enter 
either:
config cli more true or config cli more 
false.

If the command syntax is:
config cli timeout <seconds>, you might enter:
config cli timeout 30

to specify a timeout interval of 30 seconds.

bold Courier 
text

Indicates command names and options and text that you 
need to enter.
Example: Enter show ip {alerts|routes}.

braces ({}) Indicate required elements in syntax descriptions where 
there is more than one option. You must choose only one 
of the options. Do not type the braces when entering the 
command.
Example: If the command syntax is
show ip {alerts|routes}, you must enter either
show ip alerts or show ip routes, but not both.

brackets ([ ]) Indicate optional elements in syntax descriptions. Do not 
type the brackets when entering the command.
Example: If the command syntax is
show ports info config [<ports>], you can 
enter either:
show ports info config <ports> or 
show ports info config.
Installing and Using Device Manager



16 Preface
ellipsis points (. . . ) Indicate that you repeat the last element of the command 
as needed.
Example: If the command syntax is
ethernet/2/1 [<parameter> <value>]... ,
you enter ethernet/2/1 and as many
parameter-value pairs as needed.

italic text Indicates new terms, book titles, and variables in 
command syntax descriptions. Where a variable is two or 
more words, the words are connected by a hyphen.
Example: If the command syntax is
config bootconfig master <cpu-slot>, 
cpu-slot is one variable, and you substitute one 
value for it.

plain Courier 
text

Indicates command syntax and system output, for 
example, prompts and system messages.
Example: 8600# show cli

separator ( > ) Shows menu paths. 
Example: Edit > Chassis identifies the Chassis option on 
the Edit menu. 

vertical line ( | ) Separates choices for command keywords and 
arguments. Enter only one of the choices. Do not type the 
vertical line when entering the command.
Example: If the command syntax is:
show ip {alerts | routes}, you enter either:
show ip alerts or show ip routes, but not both.
316341-B Rev 01



Preface 17
Hard-copy technical manuals

You can print selected technical manuals and release notes free, directly from the 
Internet. Go to the www.nortelnetworks.com/documentation URL. Find the 
product for which you need documentation. Then locate the specific category and 
model or version for your hardware or software product. Use Adobe* Acrobat 
Reader* to open the manuals and release notes, search for the sections you need, 
and print them on most standard printers. Go to Adobe Systems at the 
www.adobe.com URL to download a free copy of the Adobe Acrobat Reader.

You can purchase printed books and documentation sets from Vervante. To order 
printed documentation, go to Vervante at the www.vervante.com/nortel URL.
Installing and Using Device Manager
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18 Preface
How to get help

If you purchased a service contract for your Nortel Networks product from a 
distributor or authorized reseller, contact the technical support staff for that 
distributor or reseller, for assistance.

If you purchased a Nortel Networks service program, contact Nortel Networks 
Technical Support. To obtain contact information online, go to the 
www.nortelnetworks.com/cgi-bin/comments/comments.cgi URL, then click on 
Technical Support.

From the Technical Support page, you can open a Customer Service Request 
online or find the telephone number for the nearest Technical Solutions Center. 
If you are not connected to the Internet, you can call 1-800-4NORTEL 
(1-800-466-7835) to learn the telephone number for the nearest Technical 
Solutions Center.

An Express Routing Code (ERC) is available for many Nortel Networks products 
and services. When you use an ERC, your call is routed to a technical support 
person who specializes in supporting that product or service. To locate an ERC for 
your product or service, go to the http://www.nortelnetworks.com/help/contact/
erc/index.html URL.
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Chapter 1
Installing Device Manager software

Device Manager (JDM) is an SNMP-based graphical user interface (GUI) tool 
designed to manage single devices. To use Device Manager (also referred to in 
this manual as Device Manager), you must have network connectivity to a 
management station running JDM in one of the supported environments.

The Device Manager software is provided on the software CD as a self-extracting 
executable file. Device Manager is also available from the Nortel Networks Web 
site. This chapter provides instructions for installing the Device Manager software 
in a Windows* or UNIX* environment. 

In Passport 8000 Series Switch Software Release 3.7, the Java Runtime 
Environment (JRE) is bundled with the Device Manager software and therefore, 
does not require a separate installation.

This chapter includes the following topics:

Topic Page

JDM installation notes 20

Uninstalling Device Manager on Windows 21

Installing Device Manager on Windows 23

Installing Device Manager on UNIX 32
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JDM installation notes

The following installation notes apply to both Windows and UNIX: 

• If you have other Nortel Networks switches in your network, and are running 
earlier versions of Device Manager software, you must install the newest 
version of Device Manager in order to access the switches running the latest 
software. 

• Prior to upgrading Device Manager, either uninstall your previous version of 
the Device Manager software (see “Uninstalling Device Manager on 
Windows” on page 21), or install the new software to a different directory. 
(You can have multiple versions of Device Manager stored on your PC or 
UNIX machine, provided that each version is stored in a separate directory).

In a windows environment, a dm.ini file is created in the JDM install directory 
to save those IP addresses visited in JDM. In a Unix environment, a ~/.jdm/
dm.ini file is created to save those IP addresses visited in JDM. A JDM 
unistall operation does not remove this file. If you wish, you can move or 
copy these files from a previous version of JDM to a new JDM installation. 
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Uninstalling Device Manager on Windows

To uninstall your previous version of the Device Manager software:

1 Save your work.

2 Exit the Device Manager that you plan to uninstall.

3 Click Start > Programs > Nortel > Java Device Manager > Uninstall DM.

The Uninstall Java Device Manager dialog box appears (Figure 1).

Figure 1   Uninstall Java Device Manager dialog box

4 Click Uninstall.

The Uninstall Device Manager proceeds and the Uninstall Java Device 
Manager dialog box appears with the message, “All items were completely 
uninstalled” (Figure 2 on page 22).
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Figure 2   Uninstall Java Device Manager dialog box (Uninstall complete)i

5 Click Done.
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Installing Device Manager on Windows

This section includes the following topics:

Topic Page

Windows minimum requirements 24

Installing JDM on Windows from the CD 25

Installing JDM in a Windows environment from the Web 31
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Windows minimum requirements

The minimum system requirements for installing Device Manager on Microsoft* 
Windows NT*, Windows 95, Windows 98, Windows 2000, and Windows XP are:

• 350 MHz or higher Pentium processor 

• 256 MB DRAM

• 300 MB space on hard drive

• Download Time: Windows XP - 5 min; Solaris - 10 min 

• Installation Time: Windows XP - 17 min; Solaris - 5 min
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Installing JDM on Windows from the CD

1 Close all programs.

2 Insert the software CD into your CD-ROM drive.

3 From the Windows Start menu, choose Run. 

The Run dialog box opens.

4 Use Browse to navigate to the drive where the CD-ROM is located.

5 Double-click the jdm_xxxx.exe file.

6 In the Run dialog box, click OK.

An install screen opens, followed by a Nortel dialog box. Then, the 
Introduction dialog box appears (Figure 3).

Figure 3   Introduction dialog box

7 Click Next to continue the installation process.

The License Agreement dialog box opens (Figure 4 on page 26).
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Figure 4   License Agreement dialog box

8 Click I accept the terms of the license agreement as shown in Figure 4.

9 Click Next.

The Choose Install Set dialog box opens (Figure 5).

Figure 5   Choose Install Set dialog box
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10 Do one of the following:

— Select Typical installation to install the common set features, as well as 
online help.

— Select Minimal installation to select minimal features to install 
(recommended for those with limited disk space)

— Select Help to install only the online help.

— Select Custom installation to customize the features prior to installation.

11 Click Next.

The Choose Install Folder dialog box opens (Figure 6).

Figure 6   Choose Install Folder dialog box

12 Click Restore Default Folder or click Choose to select the storage path.

13 Click Next.

The Choose Shortcut Folder dialog box opens (Figure 7 on page 28).
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Figure 7   Choose Shortcut Folder dialog box

14 Select a shortcut path, if desired.

15 Click Next.

The Pre-Installation Summary dialog box opens (Figure 7).

Figure 8   Pre-installation Summary dialog box
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16 Verify the folder, shortcut, and disk space required to install the software. Use 
the Previous button to return to the appropriate dialog box to make changes.

17 Click Install.

The installation process begins (Figure 9).

Figure 9   Installing Java Device Manager dialog box

When the installation is complete, the Install Complete dialog box opens 
(Figure 10 on page 30).
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Figure 10   Install Complete dialog box

18 Click Done to exit the installation.

Device Manager is now completely installed on your machine. For 
instructions on starting the Device Manager software, see Chapter 2, “Starting 
Device Manager,” on page 43.
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Installing JDM in a Windows environment from the Web

To obtain the Device Manager software from the Nortel Networks Web site:

1 Go to the following URL:

http://www.nortelnetworks.com/support

2 Click on the product for which you want JDM.

A page opens that displays all versions of that product line.

3 Click Software under the specific product you are working with.

The software page opens.

4 Click the Java Device Manager version you want.

The Software Detail Information page opens.

5 Click JDM for PC (95/98/NT/2000/XP)

A File Download dialog box opens that asks you to either run this program 
from its current location or to download the Device Manager software to your 
system.

6 Choose the directory to which you want to download the software. The 
software download is a self-extracting .exe file.

7 Close all programs.

8 Navigate to the directory on your system where you downloaded the Device 
Manager Software.

9 Double-click the jdm_xxxx.exe file.

An install screen opens, followed by a Nortel dialog box. Then, the 
Introduction dialog box appears. Go to Figure 3 on page 25 and complete 
steps 7 through 18.

Note: In the file name, xxxx represents the current version of the Device 
Manager software.
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Installing Device Manager on UNIX

This section includes the following topics:

Note: Java Device Manager installation procedures are now standardized 
across all platforms. In addition, the required Java Runtime Environment 
(JRE) (version 1.4.1) is now part of the JDM installation package and does not 
require a separate installation. The bundled JRE will be used with this JDM 
only and should not affect other JAVA applications on the same system. 
Please note for Solaris and HP-UX, certain OS patches are required for JDM/
JRE to function properly. Please consult SUN or HP to install the appropriate 
OS patches before launching JDM.

Topic Page

Installing JDM in a Unix environment 33

Installing JDM on Solaris from the CD 34

Installing JDM on UNIX from the Web 36

Executing the JDM installation software on UNIX 37
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Installing JDM in a Unix environment

The minimum system requirements for installing Device Manager in a UNIX 
SPARC* workstation running the Sun* Solaris* 2.7.x (or higher) operating 
system are as follows:

• 4 MB available in a temporary directory

• 300 MB free in the directory where you want to install the Device Manager 
software

• 128 MB DRAM 

The minimum system requirements for installing Device Manager on an HP* 
workstation running the HP-UX* 11.x or above operating system are as follows:

• 4 MB available in a temporary directory

• 300 MB free in the directory where you want to install the Device Manager 
software

• 128 MB DRAM

Installing the Device Manager software in a UNIX environment includes:

1 Uninstalling the previous version of Device Manager

2 Installing the Device Manager software.
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Installing JDM on Solaris from the CD

To install the Device Manager software to a Solaris environment 
from the CD:

1 Navigate to the Solaris/JDM subdirectory on the software CD. 

2 Refer to steps 4 to 14 in “Executing the JDM installation software on UNIX” 
on page 37 for the remaining instructions on how to install the Device 
Manager software in a UNIX (Solaris or HP-UX) environment.
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Installing JDM on HP-UX from the CD

To install the Device Manager software to a HP-UX environment 
from the CD follow these steps with the exact syntax:

1 Navigate to the HP-UX/JDM subdirectory on the software CD.

2 Refer to steps 4 to 14 in “Executing the JDM installation software on UNIX” 
on page 37 for the remaining instructions on how to install the Device 
Manager software in a UNIX (Solaris or HP-UX) environment.

Note: The CD that supports the 5.6.2 version of Java Device Manager is in 
ISO9660 format and does not support Rock Ridge extensions. On a HP-UX 
CD ROM system you may see all of the directories and files in uppercase 
followed by a revision number. For example, you may see the executable as 
“jdm_xxxx_hpux_pa-risc.sh” where xxxx is the release version, and the file 
name is case sensitive.
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Installing JDM on UNIX from the Web

To install the Device Manager software to a UNIX (Solaris or HP-UX) 
environment from the Web:

1 Go to the following URL:

http://www.nortelnetworks.com/support

2 Click on the product for which you want JDM.

A page opens that displays all versions of that product line.

3 Click Software under the specific product you are working with.

The software page opens.

4 Click the Java Device Manager version you want.

The Software Detail Information page opens.

5 Click JDM for Unix-Solaris, HP-UX.

A File Download dialog box opens that asks you to either run this program 
from its current location or to download the Device Manager software to your 
system.

6 Choose a directory to which you want to download the software. 

7 See “Executing the JDM installation software on UNIX” on page 37 for the 
remaining instructions on how to install the Device Manager software in a 
UNIX (Solaris or HP-UX) environment.

Note: After you launch Device Manager on a Solaris workstation, if several 
warning messages are displayed, do the following two things:

• Add the following to your .cshrc file:

setenv XKEYSYMDB $HOME/ .XKeysymDB

• Make sure there is a .XKeysymbDB file in your home directory.
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Executing the JDM installation software on UNIX

To execute the JDM installation software in a UNIX environment:

1 Close all programs.

2 Navigate to the directory on your system where you loaded the Device 
Manager software.

3 For the Solaris environment, make the file executable by entering:

chmod a+x dm_xxxx_solaris_sparc.sh

For the HP-UX environment, make the file executable by entering:

chmod a+x jdm_xxxx_hpux_pa-risc.sh

4 For the Solaris environment, run the dm_xxxx_solaris_sparc.sh file.

For the HP-UX environment, run the jdm_xxxx_hpux_pa-risc.sh file.

An install screen, followed by a Nortel dialog box opens. Then, the 
Introduction dialog box appears (Figure 11).

Figure 11   InstallAnywhere Introduction dialog box

5 Click Next to continue the installation process.

The License Agreement dialog box opens (Figure 12 on page 38).
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Figure 12   License Agreement dialog box

6 Click I accept the terms of the license agreement as shown in Figure 12.

7 Click Next.

The Choose Install Set dialog box opens (Figure 13).

Figure 13   Choose Install Set dialog box
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8 Do one of the following:

— Select Typical installation to install the common set features, as well as 
online help.

— Select Minimal installation to select minimal features to install 
(recommended for those with limited disk space).

— Select Help to install only the online help.

— Select Custom installation to customize the features prior to installation.

9 Click Next.

The Choose Install Folder dialog box opens (Figure 14).

Figure 14   Choose Install Folder dialog box

10 Click Restore Default Folder or click Choose to select the storage path.

11 Click Next.

The Pre-Installation Summary dialog box opens (Figure 15 on page 40).
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Figure 15   Pre-installation Summary dialog box

12 Verify the folder and disk space required to install the software. Use the 
Previous button to return to the appropriate dialog box to make changes.

13 Click Install.

The installation process begins (Figure 16 on page 41).
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Figure 16   Installing Java Device Manager dialog box

When the installation is complete, the Install Complete dialog box opens 
(Figure 17).

Figure 17   Install Complete dialog box
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14 Click Done to exit the installation.

Device Manager is now completely installed on your machine.
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Starting Device Manager

This chapter describes the basic procedures for starting the Device Manager 
software, which includes the following topics:

Topic Page

Starting Device Manager using Windows and UNIX 44

Setting the Device Manager properties 46

Opening a device 48

Note: Before you can manage a switch using Device Manager, you must 
set an IP address for the switch using the CLI (see Getting Started for 
instructions).
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Starting Device Manager using Windows and UNIX

To start Device Manager:

• In the Windows* environment, from the Windows Start menu, choose 
Programs > Java Device Manager > DM.

• In a UNIX* environment, verify that the Device Manager installation 
directory is in your search path; then type:

JDM

An abbreviated Device Manager window opens, as shown in Figure 18.

Figure 18   Abbreviated Device Manager window

Do one of the following:

Note: On startup, Device Manager performs a DNS lookup for the 
machine on which it is running. If the DNS lookup is slow or fails, a 
timeout message appears. 
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Replicating editable fields in Device Manager

You can replicate all editable table cells by doing the following:

1 Single-click the cell.

The cell will highlight. (Note: A double-click makes the cell editor available. 
The cell editor includes directly updating the value, opening an option item 
list or opening a dialog. If required, update the cell prior to highlighting it to 
be copied.) 

2 Click the Copy icon.

3 Highlight the cell(s) in which you want the data copied.

4 Click the Paste icon. 

The content in the first cell is replicated into the highlighted cell(s). 

5 Click Apply to set the change or click the Arrow icon to reset the change.
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Setting the Device Manager properties

Device Manager uses the Simple Network Management Protocol (SNMP) to 
configure and manage 8000 Series switches. You can use the Device Manager 
Properties dialog box to configure important communication parameters such as 
the polling interval, timeout, and retry count. You can set these parameters at any 
time before or after you open a device.

To set the Device Manager properties:

1 From the initial Device Manager window menu bar, choose Device > 
Properties.

The Device Manager Properties dialog box (Figure 19) opens.

2 Select properties you want to change and set their values. 

3 Click OK.

Figure 19   Properties dialog box
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Table 1 describes the Properties dialog box fields.

Table 1   Properties dialog box fields

Field Description

Status Interval Interval at which statistics and status information are 
gathered (default is 20 seconds).

(IfTraps, Status Interval) If the Register for Traps box is checked, interval, in seconds, 
at which statistics and status information are gathered.

Hotswap Detect every Enter a number for the number of intervals at which Device 
Manager will check for module hot swaps.

Enable If checked, Device Manager will poll the switch according to 
the settings listed above the Enable box.

Retry Count If Device Manager cannot transmit polling information at 
startup, the number of times Device Manager retransmits 
polling information.

Timeout Length of each retry of each polling waiting period. When 
accessing the device through a slow link, you may want to 
increase the timeout interval and then change the 
Retransmission Strategy to superlinear.

Trace If checked, you have the ability to perform trace routes.

Register for Traps If checked, Device Manager will register a trap.

Listen for Traps If checked, Device Manager will listen for a trap.

Max Traps in Log The specified number of traps that may exist in the trap log. 
The default is 500.

Trap Port The number of the port that trap messages will be captured 
on. The default is 162.

Listen for Syslogs If checked, Device Manager will listen for syslogs.

Confirm row deletion If checked, Device Manager will send a message when a 
system table row was deleted.

Default Read Community Displays the default Read Community type. You can edit this 
field by highlighting the current value and typing over it.

Default Write Community Displays the default Write Community type. You can edit this 
field by highlighting the current value and typing over it.
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Opening a device

Opening a device displays the device view, a picture of the device. Before you can 
display the device view, you must enter community strings that determine the 
access level granted to the device. 

To open a device:

1 From the abbreviated Device Manager window menu bar, choose Device > 
Open. Or, from the Device Manager toolbar, click the open device button.

The Open Device dialog box opens (Figure 20). 

Figure 20   Open Device dialog box

2 Identify the device by typing the DNS name or IP address of the device in the 
Device Name field.

3 Type the proper community strings in the Read Community and Write 
Community fields.  

Note: To gain read/write/all access to a device in Device Manager, 
you must enter the read/write/all community string for both the Read 
Community and Write Community strings.
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4 Click Ping to check if the switch is reachable, or Telnet to initiate a Telnet 
session.

5 Click Open.

Device Manager automatically determines what version of software the selected 
device is running. The Device Manager window opens, showing a picture of the 
device (Figure 21) that represents the physical features of the device.

Figure 21   Device Manager window showing an 8000 Series switch

Table 2 describes the Open Device dialog box fields.

Note: For information about connecting to the switch using SNMPv3, 
refer to Configuring and Managing Security.

Table 2   Open Device dialog box fields

Field Description

Device Name Identifies the DNS name or IP address of the device.

Read Community Indicates the length of the read community password string.

Write Community Indicates the length of the write community password string.
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v3 Enabled Enables (checked) or disables (not checked) SNMP version 3.

User Name Indicates the user’s security name. If v3 Enabled is checked, 
this name appears in the Edit > SnmpV3 tables.

Authentication Protocol Indicates the selected authentication protocol: NONE, MD5 or 
SHA-96.

Authentication Password Indicates the length of the authentication password string.

Privacy Protocol Indicates the selected privacy protocol: NONE or DES.

Privacy Password Indicates the length of the privacy password string.

Table 2   Open Device dialog box fields (continued)

Field Description
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Opening a device using the Open Last option

You can use Device Manager’s Open Last option to view and/or select from a list 
of available devices. 

To open a previously opened device:

1 From the abbreviated Device Manager window menu bar, choose Device > 
Open Last. 

A pull-down menu appears, listing the devices that were previously opened. 
The open last list displays up to 144 devices at a time. Additional devices may 
be viewed by selecting Device List 2, Device List 3, and so forth. Devices 
opened with SNMP v3 is not recorded in the Open List list.

2 Choose the IP address/system name of the device that you want to open. The 
Open Device dialog box for that device opens. 

To delete devices from the Open Last Device List, choose Device > Open Last > 
Edit. The Devices dialog box opens. Highlight the device that you want to remove 
from the list and click Delete.

If you are not able to open a device in Device Manager, see “Switch fails to open 
in Device Manager” on page 83, for information about how to troubleshoot the 
problem.
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Understanding the Device Manager window

The Device Manager window has the following four parts (Figure 22):

• Menu bar

• Tool bar

• Device view

• Status bar

Figure 22 displays the parts of the Device Manager Window.

Figure 22   Parts of the Device Manager window 
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Using the menu bar

The menu bar on the Device Manager window (Figure 23) provides menus with 
commands that let you monitor a device.

Figure 23   Menu bar

Table 3 describes the menu bar fields.

Table 3   Device Manager menu bar description

Menu Description

Device The Device menu lets you open a device, refresh the device view, and 
set polling and SNMP properties.This menu also allows you to open and 
view the Trap Log, SysLog, and Log. It also allows you to Telnet to 
currently opened device.

Edit The Edit menu lets you view parameters for the chassis or for selected 
objects. The object can be a card, fan, MDA, port, power supply or any 
other object. This menu also lets you set security parameters, run 
diagnostic tests, and select all objects in the device. This menu also 
include FileSystem, NTP, SNMP v3 related configurations. ATM menu is 
useful only if the chassis contains ATM card.

Graph The Graph menu lets you view Device Manager statistics and produce 
graphs of the chassis or port statistics.

VLAN The VLAN menu lets you view information about VLANs, spanning tree 
groups (STGs), MultiLink Trunks/LACP, MAC Learning, SMLT, SVLAN, 
and Global MAC Filtering. 

IP Routing The IP Routing menu lets you set up IP routing functions for the switch, 
including OSPF, RIP, VRRP, Multicast, IGMP, DVMRP, DHCP, BGP, 
RSMLT, PIM, PGM, UDP forwarding, filters, and policies.

IPX Routing The IPX Routing menu lets you set up IPX routing functions, including 
RIP, SAP, RSMLT, and policies.

QOS The QOS menu lets you set up and view QoS filters and profiles.

RMON The RMON menu lets you set up RMON alarms and view the alarm log 
and history log. This menu also allows you to enable or disable RMON 
history or statistics on all ports.
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Actions The Actions menu provides quick access to selected actions without 
going through other menus and submenus. Use this menu to open the 
Web management interface, to save runtime configurations, to save boot 
configurations, or to get PCAP file.

Help The Help menu lets you view online Help topics for Device Manager. 
This menu also provides a legend for the port colors in the device view.

Note: All WSM related menus are activated only when chassis contains 
WSM card, and the WSM card is selected.

Table 3   Device Manager menu bar description

Menu Description
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Using the toolbar

The toolbar buttons provide quick access to commonly used commands and some 
additional actions (Table 4).

Table 4   Toolbar buttons

Button Name Description Menu equivalent

Open Device Opens a device. Device > Open

Refresh 
Device 
Status

Refreshes the device view 
information.

Device > Refresh Status

Telnet Opens a Telnet session. Device > Telnet

Trap Log Opens the trap log. Device > Trap Log

Help Opens online Help in a Web 
browser window.

Help > Device Manager 
Basics>Passport and 
BayStack Families

Edit Selected Displays configuration data 
windows for the selected chassis 
object. 

Edit > Chassis

Edit > Card

Edit > Fan
Edit > MDA

Edit > Mgmt Port

Edit > Port
Edit > Power Supply

Edit > Serial Port

Graph 
Selected

Opens statistics and graphing 
windows.

Graph > Chassis
Graph > Port

Open 
Device’s 
Home Page

Opens the Web management 
interface home page.

Actions > Open Home 
Page
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Save 
Runtime 
Config

Saves the current run-time 
configuration.

Actions > Save Runtime 
Config

Alarm 
Manager

Opens the RMON Alarm Manager 
window.

Rmon > Alarm Manager

Table 4   Toolbar buttons (continued)
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Using the Device view

The device view allows you to determine at a glance the operating status of the 
various modules and ports in your hardware configuration. You can also use the 
device view to perform management tasks on specific objects.
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Selecting objects

In the device view (Figure 24), you can select the following types of objects:

• The entire chassis

• A card (module) or multiple cards

• A port or multiple ports

• A power supply

• A fan

• An MDA

• A management port

• A serial port

Figure 24   Objects in an 8000 Series switch device view
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To select a single object, click the edge of the object. The object is outlined in 
yellow, indicating that it is selected. Subsequent activities in Device Manager 
refer to the selected object.

To select multiple objects of the same type (such as ports or modules), use one of 
the following actions:

• For a block of contiguous ports or modules, drag to select the group of 
objects.

or

• For multiple ports or modules anywhere in the switch chassis, [Ctrl]-click the 
objects anywhere in the device view.

The general rule for selecting multiple physical objects (fans, power supplies, 
MDAs, modules, ports, etc.) is that the selected objects must belong to the same 
category/family or have some kind of parent/child relationship. For example, 
when a 10/100TX port is the base of all ports, and a 10/100TX port is selected 
first, then all other port can also be selected. 

However, if a different type of port is selected first, for example a Gig port on a 
Passport 8632TXE module, and then you attempt to select a port under a different 
category, for example, an 8672ATM port or a 8683POS port, etc., Device Manager 
will not allow you to select that port. To work around this issue in the example 
provided, you would first select the 10/100TX port (the most common basic port), 
and then select other type of ports (for example, a Gig port). 
316341-B Rev 01



61 Chapter 3 Understanding the Device Manager window
Interpreting the status of LEDs and ports

The conventions on the device view are similar to the actual switch appearance. 
Module LEDs are in one of three states: on, off, or blinking. For a full description 
of what each state means, refer to the documentation that came with the module.

The ports on the device view are color coded to provide at-a-glance port status. 
Table 5 shows the status assigned to each color.

In addition, the Help menu provides a legend that identifies the port colors and 
their meanings.

Table 5   Device Manager port color codes

Color Description

Green Port is up and operating.

Red Port has been manually disabled.

Orange Port has no link.

Light Blue Port is in standby mode.

Dark Blue Port is being tested.

Grey Port is not reachable by Device Manager.

Pink Port has a loopback connector connected to it.
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Using shortcut menus

Objects in the device view such as the chassis, ports, and cards have shortcut 
menus. These menus provide a faster path for editing objects and applying 
changes; however, you can access the same options through the menu bar or the 
toolbar.

To display the chassis shortcut menu (Figure 25), select the chassis and right click.

Figure 25   Chassis shortcut menu

Table 6 describes the chassis shortcut menu options.

To display the port shortcut menu (Figure 26), select one or more ports and right 
click.

Table 6   Chassis shortcut menu options

Option Description

Edit Edit chassis parameters.

Graph Graph chassis statistics.

Save Runtime Config Save any changes made as a run-time configuration.

Save Boot Config Save any changes made as a boot configuration.

Reset Counters Reset all the statistics counters for the switch.

Hard Reset Perform a hard reset of the switch.

Soft Reset Perform a soft reset of the switch.

Refresh Port Tooltip Refresh the port tooltip data of the switch. The port tooltip data 
contains: Slot/Port, PortName, and PortOperSpeed.

Disable Port Tooltip Disable the port tooltip function of the switch.
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Figure 26   Port shortcut menus

Table 7 describes the I/O port shortcut menu options.

The card shortcut menu provides a quick way to view the card’s parameters. When 
the selected card is an I/O module, you can click on the Edit option on the shortcut 
menu to open the Edit Card dialog box. 

Table 7   Port shortcut menu options

Option Description

Edit Display edit port menu.

Graph Graph port statistics.

Graph POS Displays on POS ports only.

Enable Administratively bring a port up.

Disable Administratively shut down a port.

Enable Rmon Stats Enable Rmon statistics logging on this port or ports. Does not 
display on ATM or POS ports.

Enable Rmon History Enable Rmon history logging on this port or ports. This field 
does not display on ATM or POS ports.

Enable FastStart Enable FastStart spanning tree operation on this port or ports. 
This field does not display on ATM ports.

Disable FastStart Disable FastStart spanning tree operation on this port or ports. 
This field does not display on ATM ports.
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To display the card shortcut menu (Figure 27), select a card and right click.

Figure 27   Card shortcut menu (I/O module)

Figure 27 is an example, this popup menu is context sensitive base on the what 
kind of card is selected.
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Using the status bar

At the bottom of the Device Manager window is the status bar. This area displays 
error and informational messages from the software application. These messages 
are not related to the device being managed.
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Using Device Manager dialog boxes

Many Device Manager dialog boxes contain editable fields that allow you to enter 
parameter values, and many of the parameters have predetermined possible 
values. For example, a port may be set to be enabled or disabled. Other parameter 
values are ranges of user-determined values. For example, the value for a system 
contact will be a name you enter in the SysContact field.

Editable fields in Device Manager dialog boxes are displayed in white. 

To change the value in a field:

1 Click the field.

The possible choices for that parameter are displayed (Figure 28).

Figure 28   Parameter selection menu

2 Click a new value from the list.

3 Click Apply.

For fields that do not have preset values, click the field and type the value.

When you enter values for IP addresses, MAC addresses, or time, follow these 
guidelines:

• Enter an IP address in decimal format:

<xxx>.<xxx>.<xxx>.<xxx>

• Enter a MAC address in hexadecimal format:

xx:xx:xx:xx:xx:xx

• Time is a value based on the delta from the switch boot-up time.
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Using the buttons in Device Manager dialog boxes

Table 8 describes buttons that appear in Device Manager dialog boxes and tabs. 
Not all buttons appear in all dialog boxes.

Table 8   Device Manager buttons

Button Description

Apply Applies the changes you have entered in fields on a tab or dialog box. 
The button is grayed out until you change a parameter. Changes are 
displayed as bold text or numbers. 

Insert Opens a dialog box to create a new entry for a table; then from the 
dialog box, inserts the new entry in the table.

Delete Deletes a selected entry.

Refresh Refreshes the information in the window. Every time you click on 
Refresh, new information is polled from the switch and displayed.

Close Closes the tab or dialog box and disregards any changes you have 
made to fields.

Help Opens context-sensitive online Help.

Resize 
Columns

Resizes table columns to fit the data in them.

Stop Stops the current action (polling).

Copy Will copy selected items to your computer’s memory clipboard.

Paste Will paste the contents of your computer’s clipboard.

Reset changes Resets any configuration values you have changed back to their original 
value.

Export data Allows you to copy data to external media.

Print Table Prints the contents of any table that is displayed.

Graph Graphs selected data.

Export (on 
Graph dialog 
boxes)

Saves the current table in ASCII format in a file you specify. The table 
contains tabs, that allows you to import this file into a text editor or 
spreadsheet for further analysis. 

Print (on Graph 
dialog boxes)

Prints the current table.
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Editing objects

You can edit objects and values from Device Manager in the following ways:

• Select an object; from the Device Manager toolbar, click Edit Selected. The 
edit dialog box opens for that object.

• From the shortcut menu for a chassis, card, port, or any other object, choose 
Edit. The edit dialog box opens for that object.

• Double-click an object. The edit dialog box opens for that object.

• From the Device Manager menu bar, choose Edit > Selected All. Then choose 
an object type from the list.

When you change values in a field, you can see fields that have been changed but 
not applied. Click Apply to apply the changes to the device. 

Most tabs and dialog boxes contain a Refresh button. After you apply changes to 
fields, click Refresh to display the new information in the tab or dialog box. In 
Windows and UNIX environments, the changed value is displayed in bold.

Note: To make changes in the running configuration, click Apply. 
Changes are not applied to Device Manager until you click Apply. To 
make the changes permanent, from the Device Manager menu bar, click 
Actions > Save Runtime Config.
316341-B Rev 01



69 Chapter 3 Understanding the Device Manager window
Online help

Online help in Device Manager is context-sensitive. You use a Web browser to 
display online help. The Web browser should launch automatically when you 
click help. To display online help correctly, Nortel Networks recommends using 
the following Web browsers: 

• Microsoft Internet Explorer 5.0 or later

• Netscape Navigator 4.7 or later

In a Unix environment, for Device Manager (or Optivity Switch Manager) to 
launch a Netscape browser properly, the shell in which Device Manager was 
launched must have a Netscape browser in its path. 

In a Solaris environment, Device Manager may not open a Netscape window 
when you click a Help button. To work around this issue, first launch Netscape 
manually; then the Help system properly opens in the Netscape browser window. 

The Help menu may behave erratically after you view the “About Device 
Manager” selection. If the edge of the Help menu extends beyond the device view 
window, you may not be able to select Legend using the cursor. The workaround 
for this problem is to use the arrow keys to select from this menu, or to widen the 
device view window, so that the Help menu is displayed in entirety on top of the 
device view. 

If, for some reason, the Web browser does not launch, the location of the Help 
files are the default install directories listed in Table 9. 

Table 9   Help file locations

Help files Default path

Device Manager jdm installed directory/help/pp8k_basics/dmhelp.html

Device specific help jdm installed directory/help/platform/version/help.html, where 
platform/version is the platform/version of current device. For 
example, for passport v370 release, the platform is “accelar2k” 
and version is “v370”.
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Chapter 4
Managing the system

This chapter describes how to manage the switch system using the Device 
Manager software, and includes the following topics:

Topic Page

Working with files 72

Using the trap log 78
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Working with files

The File System tabs allow you to copy files and to verify the files currently stored 
in onboard flash memory and on an installed PCMCIA card. These tabs allow you 
to perform the following tasks:

• Copy a file

• Check the amount of memory used and the number of files stored in onboard 
flash memory and an installed PCMCIA card

• Verify the name, size, and storage date of each file present in onboard flash 
memory and PCMCIA memory
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Copying files

To copy a file:

1 From the menu bar, choose Edit > File System.

The File System dialog box opens with the Copy File tab displayed 
(Figure 29).

Figure 29   Copy File dialog box

2 In the Source text box, specify the file to be copied in one of these forms:

• /flash/filename

• /pcmcia/filename

• ipaddress:/home/user/filename

3 In the Destination text box, specify the location where you intend the file to be 
copied in one of these forms:

• /flash/filename

• /pcmcia/filename

• ipaddress:/home/user/filename

For example, to copy a configuration file to a remote TFTP server, the 
Destination text box might read:

10.10.40.20:/home/joe/config.cfg

and the Source text box might read:

/flash/config.cfg

4 In the Action field, click start.
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5 Click Apply to start copying the files.

The results of the action appears in the Result field.
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Checking flash memory use

To check use of the flash memory in the switch:

1 From the menu bar, choose Edit > File System.

The File System dialog box opens with the Copy File tab displayed.

2 Click the Device Info tab.

The Device Info tab opens (Figure 30).

Figure 30   Device Info tab

The Device Info tab shows the amount of memory used and available for both 
onboard flash memory and an installed PCMCIA card, as well as the number of 
files in each location. The Action field allows you to reset the PCMCIA card.
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Viewing file names on the Flash

To view the names and sizes of switch files:

1 From the menu bar, choose Edit > File System.

The File System dialog box opens with the Copy File tab displayed.

2 Click the Flash Files tab (Figure 31).

Figure 31   Flash Files tab

These tabs list the name, modification date, and size of each switch file in the 
onboard flash memory. The slot number indicates the chassis location of the 
referenced CPU/switch fabric module.
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Viewing file names on the PCMCIA

To view the names and sizes of switch files:

1 From the menu bar, choose Edit > File System.

The File System dialog box opens with the Copy File tab displayed.

2 Click the PCMCIA Files tab (Figure 32).

Figure 32   PCMCIA Files tab

These tabs list the name, modification date, and size of each switch file in the 
PCMCIA card. The slot number indicates the chassis location of the referenced 
CPU/switch fabric module.
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Using the trap log

You can configure an 8000 Series switch to send out SNMP generic traps. When 
Device Manager is running, any traps received are recorded in the trap log. You 
set the maximum number of entries in the trap log using the Properties dialog box. 
(See “Setting the Device Manager properties” on page 46). The default number of 
trap log entries is 500.

To view the trap log:

• On the toolbar, click the Trap Log button.

• From the menu bar, choose Device > Trap Log.

The Trap Log dialog box opens (Figure 33).

Figure 33   Trap Log dialog box

Do one of the following:
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By default, traps are sent in SNMP V2c format. However, if you are using an older 
network management system (NMS), one that supports only SNMP V1 traps 
(HP OpenView), you can select that the traps be sent in V1 format. 

In this release, the register for traps option is not valid. When enabled, It will not 
register the PC in the switch’s trap receiver table. Create entries in the 
Edit->SnmpV3->Target Table and Edit->SnmpV3->Notify Table to get traps from 
the switch.

Note: When you operate Device Manager from a UNIX platform, you 
must be logged in as root in order to receive traps.

On Windows platform, only the first JDM application can open trap log.

On UNIX platform, only the root user can open trap log.
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Appendix A
Troubleshooting Device Manager

This appendix contains information about problems that may occur while you are 
operating the switch, and includes the following topics:

Topic Page

Login prompt fails to appear from the Console port 82

Switch fails to open in Device Manager 83

Exception error displayed while launching Java application 
launcher

85
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Login prompt fails to appear from the Console port

If you have connected a terminal to the Console port and fail to get a login prompt, 
the port may have an incorrect DCE/DTE setting. Try moving the DCE/DTE 
switch from its current setting to the other position (Figure 34). 

Figure 34   DCE/DTE switch

If the console screen still fails to show a prompt, use Device Manager to check the 
port settings. 

To check the Console port settings:

1 In the Device View, select the Console port.

2 From the Device Manager menu bar, choose Edit > Port.

3 Check to see that the port settings are:

• 9600 baud

• 8 data bits

• 1 stop bit

• No parity

If necessary, change the port settings to match those in this list.

9595EA

Link

100

Console

DCE|DTE
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Switch fails to open in Device Manager

If a switch does not open, Device Manager displays a timeout message. Timeouts 
can occur in slower networks and indicate that you need to increase your 
retransmission retries and timeout interval. For information about setting these 
values, refer to “Setting the Device Manager properties” on page 46.

If increasing the retransmission retries and timeout interval does not solve the 
problem, in the Open Device dialog box, make sure that you entered the correct 
read and write community information. For instructions on entering community 
strings, see “Opening a device” on page 48.

If the switch cannot be reached through IP (the management station cannot 
communicate with the switch), verify the following:

• Is the switch connected to the network?

• Is the switch turned on?

• Does the switch have an incorrect IP address?

• Is the incorrect IP address specified in the Open Device field in Device 
Manager?

• Is the network misconfigured?
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If you are using SNMPv3, verify the following: 

• Is the encryption module correctly loaded on the switch? 

• Is the user login and password correct?

• Is the authentication protocol and password correct?

• Is the privacy protocol and password correct?
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Exception error displayed while launching Java 
application launcher

Device Manager uses the default settings of the Java application launcher when it 
is launched. These default fits most operations, but in large configurations you 
may need to increase the default heap size setting in the Java application launcher 
from 64MB to 128MB (-Xmx128m) to avoid display issues or error messages, for 
example,

java.lang.OutOfMemoryError.
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Example in a Windows environment:

a Close Device Manager.

b Change the shortcut as follows:

"C:\Program Files\JavaSoft\JRE\1.3.1\bin\javaw.exe" -Xmx128m 
-cp 
dm_40.jar;1k_40.jar;2k_40.jar;om8k_40.jar;bs_40.jar;falcon_4
0.jar;jcch art450k.jar;sfc.jar 
com.baynetworks.fswitch.dm.DM.
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Example in a Solaris environment:

a Close Device Manager.

b Change the shortcut as follows:

$java_cmd -Xmx128m -cp
1k_40.jar:2k_40.jar:om8k_40.jar:bs_40.jar:falcon_40.jar:jcch
art450K.jar
:sfc.jar:dm_40.jar com.baynetworks.fswitch.dm.DM $*.
Installing and Using Device Manager



88 Appendix A Troubleshooting Device Manager
316341-B Rev 01



89
Index
A
Action field 73, 75

Actions menu 55

Alarm Manager button 57

angle brackets in command syntax 15

Apply button 67

B
braces in command syntax 15

brackets in command syntax 15

Browse Device’s Home Page button 56

buttons
task 67
toolbar 56
using Device Manager 67

C
card, selecting 60

chassis, selecting 60

Close button 67

color-coded ports 61

community strings
default 49

Confirm row deletion 47

Console port, checking settings 82

conventions
text 15

Copy File tab 73

customer support 18

D
DCE/DTE switch 82

Delete button 67

Destination field 73

device
opening 48, 51
viewing 58
window parts 53

Device Info tab 75

Device Manager
help files 69
installing on UNIX 33
installing on Windows 24
menu bar descriptions 54
requirements 19
setting poll interval 47
setting properties 46
starting 44
toolbar buttons 56
uninstalling on Windows 21

Device Manager window 44

dialog boxes, using Device Manger 66

E
Edit Component button 56

Edit menu 54

Export data button 67

F
failure of switch to open in Device Manager 83

failure to get a login prompt 82
Installing and Using Device Manager



90 Index
file names
viewing 76, 77

files, copying 73

flash memory, checking 75

G
Graph button 67

Graph menu 54

Graph Selected button 56

H
Help button 56, 67

Help menu 55

Help, Device Manager 69

Hotswap Detect 47

I
Insert button 67

IP address
incorrect 83

IP Routing menu 54

IPX Routing menu 54

L
LEDs, interpreting 61

login prompt, failure to get 82

M
menus. See individual menu names

module, selecting 60

O
objects

editing 68
selecting 60

online help 69

Open Device button 56

Open Device dialog box 48

P
PCMCIA Files tab 77

polling waiting period 47

ports
color-coded 61
selecting 60

Print Table button 67

product support 18

Properties dialog box 46

publications
hard copy 17

Q
QOS menu 54

R
Read Community, SNMP 48

Read-Write-All access 48

Refresh button 67

Refresh Display button 56

Register for Traps 47

requirements
Device Manager 19
UNIX installation of Device Manager 33
Windows installation of Device Manager 24

Reset changes button 67

Resize Columns button 67

retransmission retries 83

Retry Count 47

RMON, menu 54

run-time configuration, saving 57
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