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What’s new in this guide

Introduction

The Desktop Messaging Software Installation and Maintenance Guide for 
CallPilot 1.07 now includes

� information on how to install, configure, and maintain Novell Groupwise

� a list of new features for CallPilot 1.07 including descriptions

� one guide for all integrated and Internet mail client information 

� expanded troubleshooting information and added information about ne
support tools
10 CallPilot
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About this guide

Introduction

This guide provides system requirements, enhancements, and detailed 
instructions on how to install and configure Desktop Messaging software on
CallPilot server and on the desktop user’s PC. A Web Messaging chapter 
provides installation and configuration procedures. A troubleshooting chapt
gives solutions to various problems that users might encounter while install
or running CallPilot.

This guide is intended for the CallPilot system administrator, but the end-us
can run some of the procedures for configuration and troubleshooting, unde
guidance of the administrator.

Refer to the Desktop Messaging Quick Reference Guide and the online Help for 
information and procedures on how users compose, address, save, and use
fax, and text messages with Desktop Messaging.
Desktop Messaging Software Installation and Maintenance Guide 11
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Related information products

Introduction

The following CallPilot technical documents are stored on the CD-ROM tha
you receive with your system. You can search the entire suite of documenta
online, or you can print part or all of a guide. 

Planning and engineering guides

Use these guides before you install CallPilot to help plan your system, and 
plan a migration of data from Meridian Mail to CallPilot. 

Installation and configuration guides

These guides describe how to install hardware and software for the CallPilo
server, client, and desktop messaging. They also provide instructions for 
configuring the switch.

Document Title

Planning and Engineering Guide

Meridian Mail to CallPilot Migration Utility Guide

Document Title

200i Installation and Configuration Guide

702t Installation and Configuration Guide

1001rp Installation and Configuration Guide

Desktop Messaging Software Installation and Maintenance Guide
12 CallPilot
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Administration guides

These guides provide specialized information to help you configure CallPilo
administer and maintain it, and use its features. 

Networking guides

These guides describe how to plan, install, set up, and troubleshoot networ
services. 

Document Title

Getting Started Quick Reference Card

Administrator's Guide

Reporter Guide

Application Builder Guide

Monitoring and Security for the Administrator

Document Title

Network Planning Guide

AMIS Implementation and Administration Guide

Integrated AMIS Implementation and Administration Guide

NMS Implementation and Administration Guide

Enterprise Implementation and Administration Guide

VPIM Implementation and Administration Guide
Desktop Messaging Software Installation and Maintenance Guide 13
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End-user guides

These guides are intended for end-users of CallPilot, such as phoneset use
desktop messaging users.

Troubleshooting reference

This reference provides step-by-step troubleshooting procedures for CallPil

Using the online Help, guides, and tutorials

CallPilot contains three online sources for information:

� Online Help provides brief answers to the questions “What’s this?” and
“How do I...?”

� Online guides provide detailed conceptual information, as well as 
information on how to perform detailed tasks.

� Online tutorials provide a complete product overview, as well as specifi
information on how to use Application Builder.

You can access all information using either the Help menu or Help buttons.

Contacting technical support

Contact your distributor’s technical support organization to get help with 
troubleshooting your system.

Document Title

Multimedia Messaging User Guide

Speech Activated Messaging User Guide

Desktop Messaging Quick Reference Guide

Document Title

CallPilot Troubleshooting Reference
14 CallPilot
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Contacting Nortel Networks

If you have comments or suggestions for improving CallPilot and its 
documentation, contact Nortel Networks at the following web site address:

http://www.nortelnetworks.com/callpilot_feedback
Desktop Messaging Software Installation and Maintenance Guide 15
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About CallPilot Desktop Messaging

Introduction

CallPilot Desktop Messaging is a multimedia messaging application that wo
with an e-mail client to provide a single graphical interface for the users’ 
CallPilot voice, fax, and text messages, as well as their e-mail messages.

Refer to the Desktop Messaging Quick Reference Guide and the online Help for 
information and procedures on how users compose, address, save, and use
fax, and text messages with Desktop Messaging.

Open a message

A message is opened from the CallPilot inbox and uses the CallPilot custom
form. 

A CallPilot message can consist of text, voice, and fax. The most common 
message received from CallPilot is a voice message. Other common messa
include fax and voice-annotated fax. 

Access to phoneset interface

CallPilot users can access their CallPilot voice, fax, and text messages thro
the phoneset or from their e-mail client. Users must use the phoneset to ch
their greeting, to archive messages, and perform most personal administra

Computer playback/record

CallPilot messages use the Nortel Networks Voice Block (VBK) format. If th
user chooses the Computer Playback/Record button located on the player, 
messages play over the computer’s speakers. Users record messages with
computer microphone. 
16 CallPilot
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At first, when a message plays over PC speakers, it downloads to the local 
The message is stored there and is available for repeated playing without b
downloaded again. In CallPilot 1.07, the message no longer needs to be 
downloaded to the CallPilot client before phoneset playback is possible. Th
reduces LAN traffic and improves phoneset playback response times.

If the user selects the Phoneset Playback/Record button, voice messages p
and are recorded over the phoneset. This control is also located on the 
configuration dialog box. When the user opens a message, the configured 
telephone number rings. When the user answers the telephone, playback o
recording begins. 

View fax messages

CallPilot Fax Messages are encoded using the standard Tagged Image File
Format-F (TIFF-F). Fax Messages appear within the CallPilot Custom Form
The CallPilot server does not accept images that are not stored in TIFF-F. 

Windows Imaging displays fax components using an OCX Control. This con
provides Windows Imaging capability within the custom form. 

Faxes displayed in the custom form can be printed, deleted, saved to disk, 
forwarded, replied, annotated, rotated, shown in thumbnail form, and displa
in multiple zoom settings. 

View text messages

Desktop messaging users can view the text portion of a message. Phonese
must have fax capability enabled to view text since the text must be convert
fax to be printed.

Playing and viewing messages

If a user opens a message composed of a single component, the Nortel Net
custom form opens and begins to play or display the message. If there are 
multiple components, the user chooses which component to play or view fir

� If a message has a text component, it appears by default. 

� If phoneset playback is selected, the message is not downloaded to th
Desktop Messaging Software Installation and Maintenance Guide 17
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� If computer playback is selected and the Download file before playing 
check box is selected, the message is downloaded to the PC. 

� If streaming mode is selected in the configuration dialog box (the 
Download file before playing check box is not selected), the messages
streamed to the PC. 

With streaming turned on, playback occurs as soon as enough of the 
message has been received to begin playback (about two seconds). If 
message has already been played or previously downloaded, playback
begins immediately. 

� The user can cancel from a streaming playback. If the user closes the p
while the message is still being streamed to the PC, the streaming stop
the player closes immediately. 

� For CallPilot systems connected to non-M1 switches, streaming is not 
automatic.

Manual playing/viewing

Users can navigate messages with multiple parts by selecting the compone
they want to view in the icon window. The message components appear in 
custom form display window. 

Only the header of a CallPilot message is transferred to the PC at logon tim
The contents of the message (that is, its body parts) are not transferred unt
message is opened for display or explicitly downloaded via the Download A
Messages command. A message is considered read after the user opens th
message header from the inbox.

Compose message

The CallPilot user can compose a CallPilot message choosing the New Cal
Message option on the Tools menu. When a user composes a message, a 
message is created and displayed using a CallPilot custom form.

When sending a voice message from either Exchange/Outlook or GroupWi
an external e-mail address, the VBK format is converted to the WAV format.
18 CallPilot
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Reply/Reply All 

The user can Reply or Reply All to a CallPilot message by selecting a mess
and choosing the Reply or Reply All toolbar button. If the message is open 
custom form, the user can use the Reply or Reply toolbar buttons on the cu
form. 

Changing the message subject line

In Outlook, the user can change the subject of CallPilot messages by typing
new subject in the subject field of the custom form. This subject is only save
the client PC and is not uploaded to the server. 

Forward message

A user can forward a CallPilot message by selecting a message and choosi
Forward toolbar button. If the message is open in a custom form, the user c
use the Forward toolbar button on the custom form. 

Print message

In the CallPilot custom form, you cannot print an entire message with all its
components in a single operation. You must print each component of the 
message separately. You cannot print voice components. 

Delivery Receipt

The user has the option to select Delivery Receipt from the custom form. In
case, the server generates a receipt message once the receiving server ha
received the original message. 

Read Receipt

The end-user determines when a CallPilot message has been read by sele
the Read Receipt check box on the custom form. When the recipient reads
message, an Acknowledgment message is sent to the sender. If the messa
sent to multiple recipients, a separate acknowledgment is sent for each reci
Desktop Messaging Software Installation and Maintenance Guide 19
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Next/Previous

The Next/Previous buttons, located along the top of the custom form, switch
view in the custom form from message to message. 

Save As (Export)

An entire CallPilot message cannot be saved to disk in a single operation. T
user saves a message component by selecting the component and choosin
File > Save As menu item. For messages with multiple components, the use
the option to right-click the component icon and choose Save As. A user m
save each component of a message individually.

Voice components are saved as VBK or WAV files, fax components are save
TIFF files, and text files are saved as TXT files.

However, for Microsoft Outlook or Exchange, users can drag and drop a 
message from the CallPilot inbox. In this case, a user can save the comple
message to disk.

Address capabilities

All integrated clients have the ability to access the local address book on th
client to address CallPilot messages. Clients also have the ability to addres
CallPilot messages to other e-mail addresses. 

Clients can address messages by selecting the To, Cc or Bcc button from t
custom form. An address book opens and displays a list of valid addresses
user can either select an address from the list or create a new address. The
address is added to the address list of the message. It can be stored in the
personal address book for future use.

Note: Lotus Notes clients cannot send messages to external e-mail address
20 CallPilot
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CallPilot address dialog box

When creating a new CallPilot address, CallPilot presents the user with a d
box that offers the user available address types. After selecting an address
the user only needs to enter the number and a name. For example, to send
fax machine, the user selects Fax and enters the number of the fax machin

For more information on addressing, see “Using the simple addressing feature 
(Exchange/Outlook and GroupWise)” on page 29, and “Combination box for 
simple addressing (Lotus Notes)” on page 30. Also, see the Desktop Messaging 
Quick Reference Guide or the online Help.

Distribution lists

The integrated client offers users the ability to create Personal Distribution L
(PDLs). You can use these distribution lists to send CallPilot messages to a
predefined set of addresses. The client allows users to mix a CallPilot addr
with other e-mail addresses in these lists. You can only access CallPilot per
distribution lists from the desktop.

CallPilot also provides Shared Distribution Lists (SDLs), which users can us
send CallPilot messages to a list of CallPilot mailboxes. These lists are 
maintained on the CallPilot server and can be accessed from the phoneset
interface or the desktop interface. The desktop interface, however, does no
display the SDLs to the user. The user must know the number of the SDLs 
create it as an entry in his or her Personal Address Book.

When you are determining the number of addresses in an address list, an S
counts as a single address, but you must expand PDLs to determine the co

Desktop PDLs are different from CallPilot distribution lists. You cannot acce
either one from the other’s interface.

Notification of new messages

If the client is logged on when the message arrives, the client automatically
updates the user’s message list with new CallPilot messages. If the client is
logged on, the message is retrieved and displayed the next time the user lo
For integrated clients, a message waiting indicator (MWI) displays on the 
Windows system tray on the taskbar.
Desktop Messaging Software Installation and Maintenance Guide 21
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If a user deletes message from the phoneset or a different client, the delete
message is removed automatically from the client. If the client is logged on 
when the message is deleted, the message is deleted immediately. If the cl
not logged on and a message is deleted, the message is removed from the
the next time that the user logs on. For integrated clients, notification can be
indicated by MWI.

Media incompatibility

If a message is sent to the CallPilot server with an attachment that is not 
supported by the server, it is returned as a Non-Delivery Notification (NDN)
Each recipient is listed in the NDN.

If a mixed media message is sent to a user without the capability to receive
media type, the whole message is rejected in the NDN. If it is sent to a telep
or fax, the message is partially rejected. 

However, if one part of the message is not accepted, the rest of the messag
still be sent. As an example, if a message containing voice and text is sent 
phoneset, an NDN message can be generated stating the following: “The v
portion of the mixed media message was delivered. The recipient can only 
receive this portion of the message.”

Message header options

The user has the option to automatically include a text message header wit
message when composing, forwarding, and replying. This message heade
allows the recipient to see when the message is sent and provides a history
where the message has been. Text with the From field, Send (time) field, an
Subject fields appears. 

By default, this option is not enabled. If there is text in a message, the serve
treats it as a fax message and notifies the phoneset user that there is a fax
attached to the message. This can be tedious to the recipient since he or sh
print the message to see that the fax is only the message header. However
message is in the CallPilot inbox on the PC, the message header is readily
available for viewing.
22 CallPilot
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Maximum message length
Desktop messages that exceed the maximum message length are not deliv
Maximum message length is configured in the user’s mailbox class. Howev
the following rules also apply:

� Messages to an Audio Messaging Interchange Specification (AMIS) 
recipient are limited to eight minutes. Each part of a multi-part messag
an Enterprise Networking recipient is limited to 99 minutes.

� For fax messages (up to approximately 400 pages of normal-resolution
fax), each page must be no more than 1728 pixels (8.5 inches or 21.5 
wide.

� For text messages, no specific maximums are imposed, aside from the
maximum message length in the user’s mailbox class.

Default window sizes

The user can define the size of different messaging windows such as a voic
only message, a fax-only message, and a mixed-media message. This lets
user establish default sizes for various message types and can be useful w
switching between fax and voice messages. For example, the user can ma
fax message window size large, while a voice message window size can be
small.

Help

Online Help is provided as a menu selection from the client under the Help 
menu.

Logging off CallPilot

The CallPilot user is automatically logged off the CallPilot server when he o
she exits the client.
Desktop Messaging Software Installation and Maintenance Guide 23
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Hardware requirements

Required hardware

The following list contains both the minimum and recommended hardware t
Desktop Messaging software needs for operation:

Optional hardware
� a sound card and a set of speakers for playing messages from the PC 

� a microphone for recording messages from the PC

Note: Refer to the manufacturer’s instructions for the required settings to us
when you install speakers and microphones on your PC.

Required Hardware Minimum Recommended

IBM PC or compatible Pentium/586 or faster system 
with 16 Mbytes of RAM

Pentium/586 or faster system
with 32 Mbytes of RAM

monitor 16-color VGA 640 x 480 
capability

256-color SVGA 800 x 600 
capability

hard disk drive 15 Mbytes of free disk space 
to install software

15 Mbytes of free disk space 
to install software

CD-ROM drive 

Windows-compatible 
mouse and keyboard

LAN connection to the 
CallPilot server (Ethernet 
or Token Ring). Users can 
access their CallPilot 
messages LAN via ISDN, 
ADSL, or even dial-up 
modem.
24 CallPilot
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Associated software

Integrated clients

Integrated clients run with a corporate e-mail server.

You can use CallPilot Desktop Messaging with one or more of the following
integrated clients:

� Microsoft Exchange/Outlook

� Novell GroupWise

� Lotus Notes

Internet Mail clients

You can also use CallPilot Desktop Messaging with the following IMAP Inter
clients:

� Microsoft Outlook Express

� Microsoft Outlook (Internet mail mode)

� Netscape Messenger

� Qualcomm Eudora Pro

Web server software

If you use the CallPilot Web Messaging feature, the web server requires the
following software:

� Microsoft Windows NT 4 server with Service Pack 3, 4, or 5

� an installed and operational version of Microsoft IIS 4

Web Client PC requirements

CallPilot Web Messaging requires one of the following operating systems on
client PC:

� Windows 95 retail, OSR 2.1
Desktop Messaging Software Installation and Maintenance Guide 25



Desktop Messaging: Requirements and enhancements Standard 1.0

ipt 

 list 
� Windows 98

� Windows 2000

� Windows NT 4 Workstation

The client PC also requires one of the following web browsers with JavaScr
and Cookies enabled:

� Microsoft Internet Explorer 

� Netscape Navigator 

The CallPilot Player
Use the CallPilot Player or the Microsoft Media Player for voice message 
playback. 

Imaging for Windows
You need Imaging for Windows for fax display and printing.

Refer to the CallPilot 1.07 General Release Bulletin for the most up-to-date
of supported clients and their versions.
26 CallPilot
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CallPilot 1.07 feature enhancements

Introduction

CallPilot 1.07 includes the following feature enhancements:

� a modified CallPilot logon sequence

� an improved combination box interface for message addressing with se
options

� phoneset playback without downloading a message over the Local Are
Network (LAN)

� speed control for slower or faster audio playback

� audio streaming for faster message playback

� CallPilot directory access from a Lotus Notes server, so multiple users 
access a shared, centralized directory

� IMAP server-only feature improvement

� a secure socket layer (SSL) for IMAP client/server connection (exce
for the Eudora Pro client)

� a message waiting indicator on the Windows system tray on the taskba

� the ability to cancel a message download

� support for Novell GroupWise 5.5

Modified logon sequence

The modified CallPilot Logon Sequence provides better offline support and 
clearer error messages. The following flowchart illustrates the logon proces

Note: All components in the original CallPilot logon sequence are still prese
in the modified logon sequence.
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Using the simple addressing feature 
(Exchange/Outlook and GroupWise)

A combination box has been added to simplify addressing messages. The 
supported address types include

� unformatted

� local mailbox

� network mailbox

� fax number

� telephone number

� Open VPIM

� Open AMIS

When the user selects an address type, the appropriate fields, and Help tex
display on the screen. Some fields are prefilled with default values. The 
following screen shows an address dialog box. The example given is for the 
mailbox address type. 
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The fields containing text are prefilled with default values. 

For more information on addressing using the CallPilot address type, see th 
online Help.

Combination box for simple addressing (Lotus Notes)

With the new Add CallPilot Address dialog box, the Lotus Notes user can ea
add an address not found in the address book. Addresses added using the
Custom Form interface are automatically entered into the user’s Local Addr
book.

The supported address types include

� unformatted

� local mailbox

� network mailbox

� fax number
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� telephone number

� Open VPIM

� Open AMIS

When the user selects an address type, the appropriate fields and Help tex
display with the screen. Some fields are prefilled with default values. The 
following screen shows an address dialog box. The example given is for the 
mailbox address type. 

The fields containing text are prefilled with default values. As well, Lotus No
users can now add the new address directly to their local address book, usin
Lotus Notes local address book interface. The Lotus Notes Administrator m
occasionally download all addresses to keep the CallPilot database up-to-d

For more information on addressing and the CallPilot address type, refer to
online Help.

Player changes

The player changes produce messages that start to play more quickly. For 
information on the player, refer to the online Help.
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Player speed control
The speed control allows the user to control the speed of the voice messag
playback when playing a message on a PC. Speed settings are temporary a
lost when the player is closed or when you select another message within a
session.

Telephone playback without download

If the player is configured to play messages over the telephone, no downloa
required from the CallPilot server to the desktop user’s PC over the LAN.

Audio streaming

You can play back a voice message on the computer through the speakers
headset without first downloading the entire message to the hard drive. In a
streaming, the audio content of the message downloads to the client and p
once enough of the voice message is received. This allows the user to hear
contents of the message immediately before it is completely downloaded.

Player Speed Control
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Configure this option by opening a CallPilot Custom Form, and then clicking
Tools > Options on the menu bar. On the CallPilot Desktop Messaging dialo
box, select the Audio tab. To enable the audio streaming for voice message
make sure the Download file before playing option is not selected, then clic
OK.

CallPilot Directory on the Lotus Notes server

The CallPilot Directory on the Lotus Notes server allows users to access th
CallPilot address book from the Lotus Notes server.

All users connected to this Lotus Notes server can use the address book to
address messages. The Administrator can also create Groups (distribution 
which can be used by all CallPilot users.

With the CallPilot Address Book installed on a Lotus Notes server, the user
choose to use the local CallPilot Address or the one on the server. The nam
CallPilot address book located on a Lotus Notes server is CallPilot Address
Book. After selecting an address book, the user is presented with a list of na
The Administrator must update the address book by clicking OK to the 
Download all addresses message that appears.

By using the CallPilot address book on the server, users are no longer requi
manage a copy of the CallPilot address book on their PCs. This saves disk 
and also slightly reduces LAN traffic.

Secure socket layer for IMAP clients

Secure socket layer for IMAP clients is a security feature required for all no
integrated desktop clients that send clear text passwords across a network.
Currently, Outlook Express and Netscape Messenger IMAP clients support
Secure socket layer (SSL).

Note: Eudora Pro does not support SSL.

SSL is the security standard used to encrypt data communication between 
end points on a network. The CallPilot server must be configured with a 
minimum of Windows NT service pack 5 for this feature to work. 
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There are four options from which to choose on the IMAP configuration tab 
appears on the Administration Client. These option appear in the following 
screen:

IMAP service is disabled when you deselect the Enable IMAP field. Once IM
service is turned off, no desktop clients can establish a connection or access
messages. Any existing connections end immediately if the service is disab

Security certificates (a requirement of SSL) are automatically generated an
installed on the system when SSL is selected. Certificate regeneration is al
automatically handled. Certificate import is not supported.

Certificates expire at midnight, one year after the day they were created. At
time of expiry, the active desktop clients that are using SSL have their sess
disconnected and then reconnected immediately upon making use of new 
certificates.
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The CallPilot Player and integrated clients support both the Challenge-Resp
and Plain Password forms of authentication, but they always use Challenge
Response if it is enabled as it is more secure. IMAP and Web Messaging cl
only support Plain Password Authentication. 

Message waiting indicator

A message waiting indicator icon (a telephone handset) now appears on th
Windows system tray on the taskbar. When the user has no unread messag
icon is dark; when there are new messages or unread messages, the icon a
bright red. If users place their mouse over the icon, a pop up dialog box app
which provides the mailbox number, the total number of CallPilot messages
number of new messages, if any, and the number of unsent messages, if a

The message waiting indicator is available on the integrated clients only an
does not apply to the Web or IMAP clients.

Canceling message downloads

A new 1.07 client feature gives the user the ability to cancel a message 
download. These dialog boxes appear when the user selects download all 
CallPilot messages from one of the integrated clients.

Exchange/Outlook client
For Exchange/Outlook users, the dialog box to cancel the download appea
only when it takes longer than four seconds to download a message for pla
viewing, or forwarding. 
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This feature is useful for users dialing over a modem. Messages downloade
over a LAN usually take less than four seconds to download, so these user
not normally see these dialog boxes. 

Note: The Exchange/Outlook client downloads all message components be
opening the message. 

Lotus Notes and GroupWise clients
For Lotus Notes and GroupWise users, the custom form appears and the s
bar displays the status of the message download. Only one component at a
is downloaded. The user can cancel the download by closing the custom for
if the message has multiple components, by selecting another message 
component from the list displayed in the custom form.
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Before using Desktop Messaging

Checklist of conditions

Before you can use Desktop Messaging, ensure that you meet the following
conditions:

On the CallPilot server

� Ensure that Internet Message Access Protocol (IMAP) and Lightweight
Directory Access Protocol (LDAP) are running.

From the Administration client

� Specify the Voice Profile for Internet Mail (VPIM) prefix for the Prime 
Location and all Satellite locations (for systems using the Network 
Message System [NMS] feature).

� Configure the CallPilot Server Fully Qualified Domain Name (FQDN) in
Networking on the CallPilot server.

Note: If you do not have a Domain Name System (DNS), use the CallP
Server CLAN IP address or configure on the host file.

� Configure the LDAP search base on the CallPilot server.

� Set up mailbox classes that have Desktop Messaging capability enable

If users need the capability to transmit and receive faxes via the deskto
the mailbox classes must also have Fax Capability enabled.

� Create the individual mailbox users, and ensure that the ones who nee
Desktop Messaging are assigned to mailbox classes that have that 
capability enabled. 

On the user’s desktop
Set up the individual users’ desktops. Either supply each user with the follow
information so that they can set up their own desktops, or preset this informa
in the inisetup file:

� a CallPilot Server FQDN

� a search base (see the description of directory tree root, which is the se
base, under “Configuring IMAP/LDAP settings” on page 43)
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� a mailbox number

� a mailbox password

� a CallPilot mail address

Desktop Restriction/Permission List

CallPilot implements a Desktop Restriction/Permission List (RPL) to define 
mailbox number used to play back and record messages using the phonese
Desktop RPL is configured as part of the mailbox class associated with eac
user.

CallPilot applies the Desktop RPL to all messages from the desktop. If the 
message uses a feature that has an RPL associated with it, then CallPilot a
both RPLs to the call.

The Delivery to fax (DTF) RPL restricts numbers to which you can send you
fax, whether you send them through the phoneset or through Desktop 
Messaging.

The Outcalling and DTF RPLs limit the delivery of messages sent by deskto
clients to addresses that require outcalling (telephone numbers, fax numbe
and Open AMIS addresses).

For more information on RPLs and mailbox classes, see “Configuring outca
services” in the Administrator’s Guide.

Desktop Messaging and data network security

Due to the complexity and diversity of network configurations, this guide can
adequately cover issues of data network security. Discuss security issues w
security specialist or data network administrator. For more information on 
security issues, refer to Monitoring and Security for the Administrator.
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Configuring IMAP/LDAP/SMTP servers for 
Desktop Messaging

Introduction

CallPilot supports the IMAP/LDAP protocols, which allow Desktop Messagin
users to access their CallPilot mailboxes using Microsoft Exchange, Micros
Outlook, Lotus Notes, Novell GroupWise, and selected third-party Internet m
clients (Microsoft Outlook Express, Microsoft Outlook, Netscape Messenge
and Qualcomm Eudora Pro).

Each type of desktop client is configured and used slightly differently. To 
configure a specific desktop client, refer to Chapter 4, “Installing and 
configuring Desktop Messaging on the user’s PC.”

Although the Desktop Clients are configured within their own boundaries, th
CallPilot server is configured in the same way for all the desktop clients it 
supports. Follow the instructions in this chapter to configure the IMAP/LDAP
SMTP servers.

IMAP

Internet Message Access Protocol (IMAP) allows a client to access and 
manipulate electronic mail messages on a server. These messages are alw
stored on the CallPilot server. 

IMAP allows users to check for messages from any location with an Interne
connection. IMAP also allows messages to be accessed from multiple locat
It is a method of accessing electronic mail or bulletin board messages that 
kept on a shared mail server. It permits a client e-mail program to access re
message stores as if they were local. For example, e-mail stored on an IMA
server can be manipulated from a desktop computer at home, a workstation
the office, and a notebook computer while traveling, without the need to tran
messages or files back and forth between these computers.
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LDAP

Lightweight Directory Access Protocol (LDAP) is a set of protocols for 
accessing information directories. LDAP supports TCP/IP, which is necessa
for any type of Internet access. LDAP allows a client to search for and 
manipulate information entries on a directory server, such as the CallPilot se
For example, a typical entry in the CallPilot directory contains attributes of a
user such as name, telephone number, and CallPilot mail address. Internet
clients can use LDAP to query address book information from the CallPilot 
directory, perform address resolution, or search for specific users (if this 
functionality is implemented by the Internet client). For more information, se
“To configure the LDAP settings” on page 46.

SMTP

Simple Mail Transfer Protocol (SMTP) is a protocol for sending e-mail 
messages between servers. Most e-mail systems that send mail over the In
use SMTP to send messages from one server to another; the messages ca
be retrieved with an e-mail client using IMAP. In addition, SMTP is generally
used to send messages from a mail client to a mail server. This is why you 
specify both the IMAP server and the SMTP server when you configure you
mail application. 

Voice Profile for Internet Mail (VPIM) Networking also uses SMTP. For this 
reason, much of the configuration required for IMAP is completed in the sam
boxes that are completed for VPIM Networking.

SMTP/VPIM prefix
You use the SMTP/VPIM prefix in CallPilot to create a unique SMTP addres
for every mailbox on the CallPilot system. This address is required for the 
CallPilot Desktop user to log on to the CallPilot server. Every user on a CallP
system is identified by his or her own mailbox number. For an NMS, there a
many switches but only one CallPilot system. Each mailbox on the CallPilot
system is identified by its NMS location. This allows two different NMS sites
each have a mailbox with the same number. For example, both NMS site To
and NMS site Richardson can have the Mailbox number 5833. Both of thes
mailboxes reside on the CallPilot system; however, CallPilot internally is aw
that one mailbox belongs to the Richardson site and one mailbox belongs t
Toronto site.
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When an NMS user logs on to CallPilot via the telephone, the CallPilot syst
knows the location of the user because it is informed by the telephone switc
However, when a CallPilot Desktop user logs on to CallPilot, the CallPilot 
system does not have a way to know the location of the user. The CallPilot 
Desktop user logs on through IMAP using TCP/IP, so there is no telephone
switch to provide any location information.

As a result, the CallPilot Desktop client must provide the location of the 
CallPilot user. The location is defined by the SMTP/VPIM prefix. For each 
CallPilot NMS location, a different SMTP/VPIM prefix is defined. For exampl
Richardson is assigned prefix 1314442, and Toronto is assigned prefix 1416
When a user logs on via CallPilot Desktop, the user provides his or her ma
number, password, and SMTP/VPIM prefix. The CallPilot server now knows
location of this CallPilot Desktop user, and the CallPilot system now knows 
difference between user 1314442 5833 and user 1416338 5833.

SMTP addresses
SMTP uses the Internet mail addressing format:

SMTP user@<CallPilot Fully Qualified Domain Name>
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Configuring IMAP/LDAP settings

Introduction

Configure the IMAP/LDAP settings on the Internet Mail Clients dialog box o
the Administration client. You must configure IMAP settings to enable users
access and play messages. Configure LDAP settings so that users can acc
CallPilot address book.

Notes: 

� The term Internet Mail Clients refers to all the Desktop Messaging e-m
clients.

� Alteration of the settings can interrupt the service to desktop messagin
users.

Getting there  CallPilot Administration Client > CallPilot System > Messaging 
Administration > Internet Mail Clients
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To configure the IMAP settings

1 Click the IMAP tab.

2 By default, the IMAP Session Security Options are checked.

IMAP provides desktop clients with access to their CallPilot messages. If 
this service is disabled, desktop clients cannot retrieve and play their 
messages, including phoneset playback. 

If you disable this feature when users are connected, all desktop client 
sessions in progress are disconnected and other desktop clients cannot 
access this service.

3 To set encryption options for fully secure communications, ensure the 
Enable IMAP with SSL port check box is checked. SSL is normally used in 
environments that require additional security (for example, some users 
might be remotely accessing their mailbox over a modem using a public 
Internet service provider). 

Note: After you enable this option, inform users requiring this level of 
security to configure their Internet mail client to use SSL, and to use the 
default port number of 993. 
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4 To enable authentication options, ensure that you select one or both of the 
following options.

Enable IMAP with Challenge-Response Authentication:  Integrated mail 
clients use a challenge-response authentication (a standards-based 
encoding scheme) to send mailbox numbers and passwords over the 
network when a desktop session is initiated. If you disable this option, it 
prevents this type of desktop client, including the CallPilot player, from 
establishing additional connections. Any existing connections are left intact.

Enable IMAP with Plain Password Authentication:  Select this option to 
use one of the supported Internet mail or Web messaging clients. It enables 
the “Clear Text” transmission of mailbox number and password over the 
network when a desktop session is initiated. If you disable this option, it 
prevents Internet mail and Web messaging clients from establishing 
additional connections. Any existing connections are left intact.

5 Click Save to save your changes and close the dialog box or go to the next 
procedure “To configure the LDAP settings” on page 46.
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To configure the LDAP settings

1 Click the LDAP tab.

2 By default, the Session Security Options are checked. To enable LDAP, 
ensure the Enable LDAP check box is checked. LDAP provides desktop 
client address book functionality. If you disable this service, it prevents 
desktop clients from downloading the CallPilot address book or searching 
for specific addresses not in their address books.

3 To set encryption options for fully secure communications, ensure the 
Enable LDAP with SSL port check box is checked. SSL is normally used in 
environments that require additional security, such as when some users 
might be remotely accessing their mailbox over a modem using a public 
Internet service provider. 

Note: After enabling this option, you must remember to inform users 
requiring this level of security to configure their Internet mail clients to use 
SSL, and to use the default port number of 636. 
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4 To enable authentication options, ensure that you select one or both of the 
following options:

Enable LDAP with Plain Password Authentication : If this is the only 
option selected, users must enter their mailbox passwords before they 
access the CallPilot address book.

Note: If you enable this option, you must inform all Internet mail client 
desktop users to configure their clients for LDAP logon with password 
access.

Enable LDAP with No authentication : If this option is selected, any LDAP 
clients on the network can access the CallPilot address book.

5 In the Enter the directory tree root hosted by this LDAP server box, type the 
directory tree root (also known as the search base) for the part of your 
company or organization served by this CallPilot server. If you do not know 
the search base, speak to your IS administrator.

Example: A company called Acme has the Internet domain acme.com. 
Within the company there are several organizations including marketing, 
accounting, and newyork. The root of the LDAP directory is acme.com. 
Below the root is marketing.acme.com, accounting.acme.com, and 
newyork.acme.com. The search base is dc=acme,dc=com. Nortel 
Networks strongly recommends that CallPilot Desktop Messaging use this 
format.

Note: Order is critical.The component closest to the root of the namespace 
must be written last. Since com is the first domain component and acme is 
the second domain component, com must be written last. Also, there must 
be no spaces between the two domain components, only a comma 
separating them.

Example: Another way to use the search base is to provide the 
organization name (o) of the tree. If acme.com is the organizational name 
because acme.com represents the entire tree, including any branches, then 
the search base is o=acme.com.

In this example, for acme.com the CallPilot server is located in the 
Accounting branch of the tree. To search the tree starting at the accounting 
branch in the tree, you provide the domain components of the Acme 
Accounting branch. The domain component (dc) must include accounting 
so that you start at the accounting branch. The search base is 
dc=com,dc=acme,dc=accounting. Nortel Networks strongly recommends 
that CallPilot Desktop Messaging use this format.
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You can use the organization name (acme.com) and the organizational unit 
(ou), which is accounting. The search base is o=acme.com,ou=accounting. 

Once the LDAP client has a search base, it can search the CallPilot 
directory. Many LDAP clients, such as Outlook Express, allow the user to 
search for a specific attribute in the directory, such as Lastname = Jones.

Note: Both the Administration Client and the Desktop client must have the 
same LDAP search base configured.

6 Click Save to save your changes and close the dialog box.
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Configuring SMTP settings

Introduction

A desktop client uses SMTP to send messages. SMTP configuration involv
these tasks:

1. enabling the system to exchange CallPilot messages

2. setting the CallPilot server fully qualified domain name (FQDN)

3. specifying an SMTP/VPIM network shortcut

4. for CallPilot servers using NMS, configuring a VPIM prefix for the prime
location and all satellite locations. For more information, see the NMS 
Networking Implementation and Administration Guide.

Getting there  CallPilot Administration Client > CallPilot System > Messaging 
Administration > Networking > Message Delivery Configuration

To enable the exchange of CallPilot messages

The settings in the following procedure might already be configured for you
system, but you must check that they are correct.

1 Click the SMTP/VPIM tab.

2 To receive incoming messages to the CallPilot server (outgoing messages 
from the desktop client), enable the Incoming SMTP/VPIM messages 
check box.

Note: If this check box is not enabled, all incoming SMTP messages, 
whether from a local desktop client or from a remote SMTP/VPIM server, 
are refused. You can use this check box to shut out temporarily all incoming 
SMTP messages in the event of a security problem.

Note: The setting of the Outgoing SMTP/VPIM check box does not affect 
CallPilot messages. This setting controls VPIM Networking messages only.
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Record the CallPilot server FQDN

A fully qualified domain name consists of a host and domain name, includin
top-level domain. For example, www.example.com is a fully qualified domai
name: www is the host, example is the second-level domain, and com is the top 
level domain. 

As part of desktop client configuration, you must enter the name of the CallP
server. When configuring Internet mail clients, you usually enter the same se
name separately in the boxes for each of the incoming mail (IMAP), outgoin
mail (SMTP), and directory (LDAP) servers. 

You can set this server name to the CallPilot server’s Fully Qualified Domai
Name (FQDN), or (when the desktop client machines are located on the sa
LAN as the CallPilot server) abbreviate it to just the hostname part of the 
FQDN, as discussed below. This depends on whether you have a Domain N
System (DNS). If you do not have a DNS, use the CallPilot server customer
LAN (CLAN) IP address. For more information, see “Configuring environments 
without a DNS” on page 54.

If you do not know your server FQDN, speak to your IS administrator, or if y
have access to the CallPilot server, follow these steps on the CallPilot serve

Getting there   CallPilot server > Windows Start Menu > Settings > Control Panel

To determine the server FQDN

1 On the Control Panel, double-click Network.

Result: The Network dialog box appears.

2 Click the Configuration tab.

3 Select the TCP/IP component, and click Properties.

Result: The Microsoft TCP/IP Properties page appears.

4 Click the DNS Configuration tab.

5 Write down the host name and the domain name.

Note: When combined, the host name and the domain name become the 
server FQDN. Insert a dot between the host name and the domain name.
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Example: The hostname compass and the domain name acme.com 
combine to form the FQDN compass.acme.com.

6 Click Close until the Control Panel closes.

Getting there  CallPilot Administration Client > CallPilot System > Messaging 
Administration > Networking > Messaging Network Configuration

To set the SMTP/VPIM server FQDN

1 In the network tree view, select the local messaging server and click File > 
Properties.

2 On the General tab, enter the FQDN in the SMTP/VPIM server FQDN box.

3 Click Save.

Result: The information is validated and saved to the network database.

4 Publish the SMTP/VPIM server FQDN and the LDAP search base to all 
desktop users to enable the configuration of desktop clients, unless you 
have preset the setup.ini file.

Specify the SMTP/VPIM network shortcut

You must specify at least one SMTP/VPIM network shortcut. You use an SM
VPIM network shortcut to create the e-mail address of a CallPilot desktop u
A network shortcut also identifies local addresses for incoming SMTP mess
to the CallPilot server, and messages sent by local CallPilot desktop users.

Note: Make the SMTP/VPIM network shortcut as long as possible to ensure 
the mapping is correct and no conflict occurs. SMTP/VPIM network shortcu
are not true shortcuts since they must be more than a few digits long. A sho
SMTP/VPIM network shortcut can conflict with the left side of another SMT
address.

ATTENTION Do not restart the CallPilot server, even if you are asked to do 
so.
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Example: 
With the following SMTP/VPIM network shortcut defined as 1416777, the 
From: field of a message sent from mailbox xxxx is 

From:1416777xxxx@serverFQDN

The SMTP/VPIM network shortcut can be any number. However, Nortel 
Networks strongly recommends that the SMTP/VPIM be set to the Public 
Switched Telephone Network (PSTN) for that location of the CallPilot users
the following reasons:

� The PSTN is a unique number and guarantees that you will not conflict
with any neighboring voice mail systems when exchanging Open VPIM
messages with other voice mail systems.

� The PSTN is a number that is easy for your voice mail users to remem
because they are already familiar with it.

Example
Your organization owns the telephone numbers 14167776000 to 14167776
and the mailboxes are 6000 to 6999. Do not define 1416777, overlap 0. Ins
define 14167776, overlap 1. Overlap 1 indicates that all valid mailboxes in y
organization begin with 6. This avoids a potential mismatch with another 
address, such as 14167771234@neighbor.com.

If your local site is not an NMS site, Nortel Networks strongly recommends t
you specify only one shortcut. If you use more than one shortcut, define ea
one using an overlap to ensure unique mapping of shortcuts to mailbox num

If your local site is an NMS site, configure one SMTP/VPIM network shortcu
for each switch location. For more information on NMS Networking, refer to 
NMS Implementation and Administration Guide.

Getting there  CallPilot Administration Client > CallPilot System > Messaging 
Administration > Networking > Messaging Network Configuration

To specify the SMTP/VPIM network shortcut

1 In the network tree view, select the local prime switch location and click 
File > Open.

Result: The Local Prime Switch Location Properties dialog box appears.
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2 Click the SMTP/VPIM tab.

3 To add a network shortcut, click Add New... .

Result: The New network prefix dialog box appears.

4 Enter the prefix and the amount of overlap with the local mailbox numbers.

5 Click Save.

Result: The prefix and overlap appear in the SMTP/VPIM Network 
Shortcuts list box.

6 Click Save.

Result: The information is validated and saved to the network database.
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Configuring environments without a DNS

Overview

The Domain Name System (DNS) is an Internet service that translates dom
names into IP addresses. Because domain names are alphabetic, they are
for users to remember. The Internet is based on IP addresses. Every time yo
a domain name, therefore, a DNS must translate the name into the correspo
IP address. For example, the domain name www.example.com might transl
198.105.232.4. 

The DNS is, in fact, its own network. If one DNS server does not know how
translate a particular domain name, it asks another one, and so on, until the
correct IP address is returned.

CallPilot Desktop Messaging uses Domain Name resolution, which is provi
by a DNS. If your environment does not have a DNS, then you must configu
CallPilot Desktop messaging to support name resolution in a different way. 

To do so, perform one of the following:

� Configure CallPilot Desktop Messaging using HOSTS files.

� Configure CallPilot Desktop Messaging with the IP address of the CallP
server if you do not want to use a HOSTS file.

If you use a HOSTS file, you must configure the HOSTS file on each client 
on which Desktop Messaging is installed.
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Configuring CallPilot Desktop using HOSTS 
files

Introduction

A HOSTS file is a text file that maps host names to IP addresses. This file i
typically used to resolve host names for TCP/IP utilities. You can use a HOS
file to resolve host names for CallPilot Desktop Messaging if you do not hav
DNS.

To use the HOSTS file, you must

1. enter a host and domain name on the CallPilot server

2. update the HOSTS file with the name and IP address of the CallPilot s

3. configure the LDAP search base on the CallPilot Administration Client 

4. configure the HOSTS file on all PCs running Desktop Messaging

5. configure the search base on PCs running Desktop Messaging

To enter a Host Name and Domain Name on the server

Perform the following actions on the CallPilot server.

1 On the CallPilot server, to configure the TCP/IP information for the CallPilot 
server, right-click the server icon, highlight TCP/IP Dialup Adapter, and click 
Properties. 

2 On the DNS Configuration tab, type a Host Name in the Host box.

Example: A Host Name can be myServer.

3 Type a Domain Name in the Domain box. 

Note: You must configure a mock domain since you do not have an 
authorized domain. 

Example: A domain can be any name (for example, myCompany). 

4 Make a note of the Host Name and Domain Name that you entered on the 
CallPilot server.
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5 Click Save.

To update the HOSTS file on the server

Perform the following actions on the CallPilot server.

1 From the Windows Start menu, click Find > Files or Folders and type hosts  
in the Named box.

Result: The HOSTS file appears in the list of files found.

2 Double-click the HOSTS file and open it with a text editor such as Notepad.

Note: If the HOSTS file does not exist, copy the HOSTS.SAM file and 
rename it HOSTS.

3 In the HOSTS file, type the IP address of the CallPilot server at the bottom 
of the file. Press Tab and type the Hostname of the CallPilot server (for 
example, myServer).

Example: The bottom of the HOSTS file looks like the following:
127.0.0.5 localhost
58.345.6.12 myserver

4 Click File > Save to save the changes to the HOSTS file.

Getting there  CallPilot Administration Client > CallPilot System > Messaging 
Administration > Internet Mail Clients

To configure the LDAP search base on the Administration Client

1 Click the LDAP tab.

2 In the Search Base box, enter your Search Base. The Search Base is 
composed of the domain name that you entered on the server.

Example: If myCompany is the domain, then the search base is 
dc=mycompany.

3 Click Save to save your changes and exit.

4 Click Networking > Message Configuration.

5 In the FQDN field, type the Host name that you previously entered on the 
server to configure the CallPilot Fully Qualified Domain Name (FQDN).
56 CallPilot



May 2000 Configuring the server for Desktop Messaging
To configure the HOSTS file on the PC running Desktop Messaging

1 From the Start menu, click Find > Files and Folders, and type host  in the 
Named box.

Result: The HOSTS file appears in the list.

Note: If the HOSTS file is not found, copy the HOSTS.SAM file and rename 
the copy HOSTS.

2 Double-click the HOSTS file and open it with a text editor such as Notepad.

3 In the HOSTS file, enter the IP address of the CallPilot server at the bottom 
of the file. Press Tab and type the Hostname of the CallPilot server.

Example: The bottom of the HOSTS file should look like the following:
127.0.0.5 localhost
56.345.6.12 myserver

Note: You must repeat steps 1 to 3 on every PC that will use CallPilot 
Desktop messaging.

4 Click File > Save to save the changes to the HOSTS file.

5 On the CallPilot Desktop clients, configure the Search Base to be the same 
as for the Administrative Client (that is, dc=mycompany). 

Note: Ensure that the Search Base configured on the CallPilot Desktop 
client is exactly as it appears on the CallPilot Administration Client, Internet 
Mail Clients.
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Configuring CallPilot Desktop with IP address 
only

Introduction

If you do not use a HOSTS file to resolve domain names, you can configure
CallPilot server and client PCs to use an IP address only.

To do so you must

1. enter the host and domain name on the CallPilot server

2. configure the LDAP search base on the CallPilot Administration Client

3. configure the IP address as the same search base on the PCs running
Desktop Messaging

To enter a Host Name and Domain Name on the server

1 On the CallPilot server, to configure the TCP/IP information for the CallPilot 
server, right-click the server icon, highlight TCP/IP Dialup Adapter, and click 
Properties. 

2 On the DNS Configuration tab, type a mock host name in the Host field.

Example: A mock host name can be any name (for example, myCompany). 

3 Type a Domain Name in the Domain field. 

Note: You must configure a mock domain, since you do not have an 
authorized domain. 

Example: A domain can be any name (for example, myCompany). 

Note: Make a note of the Host Name and Domain Name that are entered 
on the CallPilot server.

4 Click OK to save your changes.

Getting there  CallPilot Administration Client > CallPilot System > Messaging 
Administration > Internet Mail Clients
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To configure the LDAP search base on the Administration Client

1 Click the LDAP tab.

2 In the Search Base box, enter your Search Base. The Search Base is the 
mock domain name that you entered on the server.

Example: If myCompany is the domain, then the search base is 
dc=mycompany.

3 Click Save to save your changes and exit.

4 Double-click Networking > Message Configuration.

5 In the FQDN field, type the Host name that you previously entered on the 
server.

6 Click Save to save and exit.

To configure access to the server by the Desktop client PCs

1 When you first start the Desktop Messaging client PC, on the Desktop 
Messaging Logon, type the IP address in the Server box.

Note: You will also need to enter your password and mailbox.

Result: The e-mail client opens.

2 From the Tools menu, click Services.

3 Select CallPilot Desktop Messaging, and click Properties.

4 Click the Address Book tab.

5 Ensure that the Search Base box has the same value as the one on the 
Administrative Client (that is, dc=mycompany). 

Note: Ensure that the Search Base configured on the CallPilot Desktop 
client is exactly as it appears on the CallPilot Administrative Client: Internet 
Mail Clients.

6 Click OK to save your changes.

7 Click OK to exit from the window.

8 Repeat this process on each Desktop client PC.
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Installing Desktop Messaging

In this chapter 
 About Desktop Messaging installation 62

 Running the setup initialization procedure 63

 Configuring the setup initialization file 64
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About Desktop Messaging installation

Introduction

Desktop Messaging installation consists of the following procedures. 

1. Run a setup initialization procedure on any PC attached to the network
This creates a set of site-specific default settings that are stored in a fil
(setup.ini), which the end-user uses when installing Desktop Messagin
See “Running the setup initialization procedure” on page 63.

2. Copy the contents of the Desktop Messaging Client CD-ROM to the sa
directory in which the setup.ini file is stored. See “Copy CD contents to the 
same directory” on page 67.

3. Install Desktop Messaging on the user’s PC from the network using the
setup.ini file and the copied CD contents. Either you, as the administra
or the user can install the software. See Chapter 4, “Installing and 
configuring Desktop Messaging on the user’s PC.” 

4. If you are not using a Domain Name System (DNS), configure each us
PC to resolve domain names. See Chapter 2, “Configuring the server for 
Desktop Messaging.”
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Running the setup initialization procedure

Introduction

Run the setup initialization procedure from the appropriate CD-ROM. Perfo
the following procedure on any PC attached to the same network as CallPil

To run the setup initialization procedure from the CD-ROM

1 Insert the CD labeled Desktop Client into the CD-ROM drive. 

Result: The Setup program starts and the Welcome window appears.

2 Click Cancel.

3 From the Windows Start menu, select Run.

4 Browse the CD to find the inisetup.exe file, and click OK.

Result: The Setup initialization program starts and the Welcome window 
appears.

5 Click Next to continue the setup initialization procedure.

ATTENTION The CallPilot Desktop Client must have the Windows 
Messaging system installed for GroupWise and Exchang
Outlook clients.
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Configuring the setup initialization file

To set up the initialization of CallPilot

1 Select the appropriate e-mail client(s). 

2 Click Next.

Result: The Select Destination Folder screen appears.

3 If the default Destination folder is acceptable, click Next to continue the 
setup initialization procedure.

If you want to save the setup.ini file in a different folder, click Browse... to 
view other locations. 

Result: The Select Destination Directory box appears.

4 Select the folder you want the setup.ini file to save to, and then click OK. 

Result: The selected folder appears in the Select Destination Folder 
window. 

Note: If there is an existing setup.ini file in the directory you have chosen, 
you are asked if you want to replace this file.
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5 Click Next to continue the setup initialization procedure.

Result: The CallPilot Server Settings window appears.

You defined these settings in the previous chapter on configuring the server 
for Desktop Messaging.

6 Enter the fully qualified domain name (FQDN) or the CLAN IP address of 
the CallPilot server. 

Note: See the FQDN definition in “Configuring SMTP settings” on page 49.

7 Enter the SMTP/VPIM prefix of the CallPilot server.

Notes: 

� The prefix is the string of digits that is concatenated with the mailbox 
number to form the address. Do not include any overlap digits that are 
configured on the server. 

� See the SMTP/VPIM prefix definition in “Configuring SMTP settings” on 
page 49.

8 Enter the search base used for address searches in the CallPilot directory. 

Note: See the search base definition in “Configuring IMAP/LDAP settings” 
on page 43.
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9 Click Next.

Result: The Additional Options window appears.

10 If you want to install the fax printer driver, check the appropriate box. 

Note: The options that appear dimmed are not supported by Desktop 
Messaging for the type of e-mail client you have chosen.

11 If you want to prevent end users from modifying the default settings created 
by the Setup Initialization program, check the Make default settings read-
only check box. Nortel Networks recommends choosing this option.

12 Click Next to continue the setup initialization procedure. 

Result: The setup.ini file is copied to the directory you specified.

13 Click Finish to complete the setup initialization.
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Copy CD contents to the same directory

Nortel Networks recommends that you copy the entire contents of the Desk
Messaging CD to the same directory in which you saved the setup.ini file. W
you do this, it also copies the setup.exe file from which users install. 

When the setup.exe and setup.ini files are in the same directory, the setup.i
is automatically used when the user runs setup.exe. If these files are in diffe
directories, the setup.ini file with the predefined settings is not used during 
user install procedure. Tell users to run the setup.exe from this directory.

Installing Desktop Messaging on users’ PCs

After you set up the initialization file for Desktop Messaging, begin installati
of Desktop Messaging on any user’s PC. Go to Chapter 4, “Installing and 
configuring Desktop Messaging on the user’s PC.”
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Installing and configuring Desktop 
Messaging on the user’s PC

In this chapter
Section A: Installing Desktop Messaging on the user’s PC 71

Section B: Configuring Microsoft Exchange/Outlook 83

Section C: Configuring Novell GroupWise 87

Section D: Configuring Lotus Notes 97

Section E: Configuring the Internet Mail clients 101
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Section A: Installing Desktop Messaging on 
the user’s PC

In this section
 Preinstallation information 72

 Starting the installation 74
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Preinstallation information

Introduction

Before you install Desktop Messaging software on the desktop user’s PC, r
to 

� Chapter 1, “Desktop Messaging: Requirements and enhancements,” for 
hardware and software information

� the README.RTF file, which is located in the root directory of the 
CallPilot product CD

Based on desktop users’ expertise, you might also ask them to run this proc
on their PC.

Ensure that the microphones, speakers, and sound cards that are connecte
user’s PC are configured. Refer to the manufacturer’s documentation.

Other information you need

Have the following information available before installation:

� the location of the Desktop Messaging setup.exe file

or

� the Desktop Client CD-ROM if you, the system administrator, have not
previously set up Desktop Messaging

or

� the Desktop client self-extracting setup executable file

Also have the following CallPilot server settings information available:

� the fully qualified domain name (FQDN) of the CallPilot server (or the 
CallPilot server CLAN IP address, if you do not have a DNS)

� the SMTP/VPIM prefix of the CallPilot server

� the search base (dc=) to be used for address searches in the CallPilot 
directory

� the mailbox number
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Note: With the exception of the mailbox number, these are set and saved in
setup.ini file. Make default settings read-only.

Fax requirements

Administration privileges for the Nortel Fax printer driver
To install the Nortel Fax printer driver on a PC running Windows NT, you m
have administration privileges. The installation of Desktop Messaging requi
the registration of several components in the Windows registry. If you log on
a user without administration privileges and attempt to install the Nortel Fax
printer driver, the installation will fail.

Requirements to view and manipulate faxes
If users intend to send and receive faxes on their PC, they must install Imag
for Windows.

To verify whether Imaging for Windows is already installed, from the Windo
Start menu click > Programs > Accessories > Graphics Tools > Imaging.

Note: If Imaging for Windows is not installed on the user’s PC, you can insta
from the Desktop Messaging CD.

Estimated installation time 

Installation of Desktop Messaging software takes approximately 10 minutes

ATTENTION Novell GroupWise 5.5 requires that Windows Messaging
4.0 is installed on the user’s PC. This is normally the cas
when Windows is installed on a PC. However, in the case
where Windows Messaging 4.0 is not installed, the 
GroupWise installation provides you with the following 
options: 
1. Install the complete Windows Messaging system. 
2. Leave Windows Messaging as is. 

Choose option 1.; otherwise, the GroupWise CallPilot Deskt
Client is dimmed.
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Starting the installation

Introduction

You install Desktop Messaging from a CD-ROM. This can be the physical C
or from a version that has been copied to the network. See Chapter 3, “Installing 
Desktop Messaging,” for more information.

If you are asking the desktop users to run this procedure, you must provide 
with information on the type of installation to perform and where to find the 
appropriate files. You can customize the README.RTF file, which is located
the root directory of the CallPilot product CD, for your specific desktop 
messaging client (such as GroupWise or Lotus Notes).

Before you begin

Close all Windows applications that are running. If certain applications are n
closed, Desktop Messaging might not install successfully.

Types of installation

Previous setup by administrator with read-only settings
You can configure the setup.ini file associated with Desktop Messaging prio
the user installation procedure. During this configuration, you can set the de
settings to read-only. 

Nortel Networks recommends this type of installation. If this is done, the us
does not see all of the installation screens, and some screens appear dimm
requiring no input. This shortens the user installation procedure. Run the 
setup.exe file from a location on a network drive that you have defined.

Previous setup by administrator
If you (the administrator) did not set the default settings as read-only, the pe
installing sees all the screens and needs to enter information in all the relev
fields. The setup.exe file is run from a location on a network drive that you a
the administrator have defined.
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To install from a network drive

Use this type of installation if you, as administrator, have previously set up 
setup.ini file for Desktop Messaging and copied the contents of the Desktop
Messaging Client CD-ROM to the network. 

There are many ways to run the setup.exe file from your computer.

1 From the Windows Start menu, select Run.

2 Type in or browse to the location of the setup.exe file. If you ask the 
desktop user to do this, you must supply the correct path.

3 Choose Network Neighborhood and go to the appropriate drive and folder 
over the network, where the setup.exe file is located.

4 Click OK.

Result: The setup program starts and the Welcome window appears.

5 Click Next to continue the installation.

Alternatively, you can map the network drive where the setup file is located

1 From your PC desktop, select My Computer and click the right mouse 
button.

Result: The Map Network Drive dialog box appears.

2 Enter the path name to go to the file where the setup.exe file is located.

3 Click OK.

Result: The network drive where the setup.exe file is located appears in 
My Computer.

4 From My Computer, select the mapped Network drive where the setup.exe 
file is located.

5 Select the setup.exe file.

6 Click OK.

Result: The setup program starts and the Welcome window appears.

7 Click Next to continue the installation.
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To install from the CD-ROM

Use this type of installation if you, the administrator, have not previously se
the Desktop Messaging setup.ini file and copied the contents of the Deskto
Messaging Client CD-ROM to the network.

1 Insert the CD labeled Desktop Client into the CD-ROM drive. 

Result: The setup program starts and the Welcome window appears.

2 Click Next to continue the installation.

To uninstall a previous version of CallPilot 

Note: Use this procedure only if CallPilot 1.06 or earlier is installed.

1 Exit from all applications including the installation program. 

Note: If you were running Microsoft Exchange or Microsoft Outlook, it can 
take an additional minute or two for the mail services to shut down.

2 From the Windows Start menu, select Programs > Nortel Networks 
CallPilot Desktop Messaging > Uninstall CallPilot Desktop Messaging for 
(specific e-mail client).

Result: The Uninstall window appears.

3 Click Uninstall NOW!

Notes: 

� If the system prompts you to delete any files beginning with the letters 
nb, nm, or ns, click Yes.

� If you are uninstalling Desktop Messaging for Lotus Notes, the system 
asks you to enter your Lotus Notes password before the uninstall 
process continues.

Result: The system removes CallPilot Desktop Messaging from the PC. 
When the operation is complete, you return to your desktop. 

To install the Desktop Messaging software

Note: If an e-mail client is already selected for you, then proceed to the Sele
Destination Folder screen in step 8.
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1 Close all Windows applications.

2 If you are upgrading CallPilot, uninstall the current CallPilot Desktop 
Messaging on your system. 

For more information, see “To install the Desktop Messaging software” on 
page 76, before continuing.

3 Click Start on the Windows taskbar, and then click Run.

4 Type in the location or click Browse to find the setup.exe file, and then click 
Open.

5 Click OK.

Result: The setup program starts and the Welcome window appears.

6 Click Next to continue the installation.

Note: If other applications are open, the system prompts to close them 
before continuing.

7 When the Select Type of E-Mail Client screen appears, click the 
appropriate check boxes beside the e-mail clients that you are using.

The Internet Mail clients include Microsoft Outlook Express, Microsoft 
Outlook (in Internet mail mode), Netscape Messenger, and Qualcomm 
Eudora Pro.

Note: You can select more than one e-mail client.
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8 Click Next.

Result: The Select Destination Folder screen appears.

a. Accept the default directory by clicking Next.

b. Click Browse... to view other destination folders, and select the folder in 
which you want to install Desktop Messaging.

c. Click OK.

Note: Nortel Networks recommends that you install CallPilot in the default 
folder.

9 Click Next.
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Result: The CallPilot Mailbox Number screen appears.

10 On the CallPilot Mailbox Number screen, enter your mailbox number 
(usually your telephone number).

11 Click Next.

Result: The CallPilot Server Settings screen appears.
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If the screen appears with no information in the fields, enter the following 
information after the field names:

Server Name or IP Address:  The fully qualified domain name (FQDN) of 
the CallPilot server.

SMTP/VPIM prefix:  The SMTP/VPIM prefix of the CallPilot user’s address. 
This is the string of digits that is concatenated with the mailbox to form the 
address. Do not include any overlap digits that are configured on the 
server. For more information, refer to “SMTP” on page 41.

Search Base to be used for address searches:  The search base is the 
directory tree root for the part of your company or organization served by 
the CallPilot server. It should match the directory tree root configured on the 
server. For example, for a CallPilot server used by Nortel Networks in 
Toronto with an FQDN of CallPilot@toronto.nortelnetworks.ca, the search 
base is dc=toronto,dc=nortelnetworks,dc=ca. For more information, refer to 
“LDAP” on page 41.

Note: If you, as the administrator, have not preset Desktop Messaging in 
the setup.ini file, you must provide users with the information for these 
fields.

12 Click Next.

Result: The Ready to Install! screen appears.
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If you want to install the fax printer driver, check the Nortel Fax Printer 
Driver box. This driver enables you to save any document in TIFF-F. You 
can then send the file as a fax to other CallPilot users.

To use the fax driver

1 To use the fax driver, you require one of the following programs installed on 
your system, in addition to your Internet mail client:

� Microsoft Exchange or Outlook

� Lotus Notes and CallPilot Desktop Messaging for Lotus Notes

� Novell GroupWise

If options appear dimmed, they are not supported by Desktop Messaging 
for the type of e-mail client you have chosen, and the appropriate fax 
drivers are pre-selected. If all the selections are dimmed, then the 
administrator has predefined them.

Note: If you are installing Desktop Messaging for Lotus Notes, the system 
asks you to enter your Lotus Notes password before the installation 
process continues.

2 Click Next.

Result: The installation progress bar appears and indicates the files that 
are being copied.

3 Click Finish to complete the installation.

What’s next?

The next few sections provide details on the specific configurations for a 
particular e-mail client. Refer to the appropriate section:

� “Configuring Microsoft Exchange/Outlook” on page 83

� “Configuring Novell GroupWise” on page 87

� “Configuring Lotus Notes” on page 97

� “Configuring the Internet Mail clients” on page 101
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Section B: Configuring Microsoft 
Exchange/Outlook

In this section
 Choosing configuration options 84
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Choosing configuration options

Introduction

The information in this window might have been predefined by you, in whic
case all of the options appear dimmed and you do not have to select anythi
Simply perform step 2.

If the options do not appear dimmed, you must select the options you want 
install.

You must decide whether to install the Fax Printer driver. This driver enable
you to save any document in TIFF-F. You can then send the file as a fax to 
CallPilot users.

If you are installing Desktop Messaging for Microsoft Exchange/Outlook, 
Configure Exchange/Outlook Services is selected by default. 

Starting point: The Ready to Install! window
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1 If you want to install the fax printer driver, check the appropriate box. 

Note: The options that appear dimmed are not supported by Desktop 
Messaging for the type of e-mail client you have chosen.

2 Click Next to continue the installation. 

Result: The Installing progress bar appears and identifies the files that are 
being copied. When all of the files are copied, the configuration is complete 
for your Exchange or Outlook.

What’s next?

Once installation of Desktop Messaging is completed, you can start your e-
client and log on to Desktop Messaging to view your messages. For more 
information, refer to the online Help available from the Help menu within the
client or to the Desktop Messaging Quick Reference Guide.
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Section C: Configuring Novell 
GroupWise

In this section
 Overview 88

 To configure GroupWise for CallPilot Messaging 92
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Overview

Introduction

Novell GroupWise is supported as a new desktop messaging client for Call
1.07. The following section provides a brief overview of how the client is 
integrated with CallPilot. For more information, and for procedures on how 
use GroupWise to address, compose, open, delete, and perform other Call
message operations, refer to the Desktop Messaging Quick Reference Guide or 
the online Help.

CallPilot custom form

GroupWise uses the same custom form as the Lotus Notes and Exchange/
Outlook clients. The CallPilot custom form gives users a convenient interfac
view and compose voice, fax, and text messages.

ATTENTION Novell GroupWise 5.5 needs Windows Messaging 4.0 
installed on the user’s PC. This is normally the case whe
Windows is installed on a PC. 

However, in the case where Windows Messaging 4.0 is not
installed, the GroupWise installation provides you with the 
following options:
1. Install the complete Windows Messaging system. 
2. Leave Windows Messaging as is. 

Choose option 1.; otherwise, the GroupWise CallPilot Deskt
Client is dimmed.
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Fields created on the GroupWise Server

CallPilot uses two custom fields when displaying messages to the user—th
From and the Date/Time field. The From and the Date/Time fields are create
the GroupWise server Post Office during installation of the desktop client an
are used to display the From and Data/Time information to the user in each
CallPilot message. The first user who installs GroupWise at a site causes th
two fields to be created. Subsequent installs by other users do not cause th
fields to be created again since they are already there. 

Note: GroupWise does not provide a way to remove these fields. Once they
created, they remain until the GroupWise server is rebuilt. This should not c
a problem since GroupWise or other GroupWise applications are not affecte
these fields. 

Organizing messages

While you can move GroupWise CallPilot messages to other folders within 
mailbox, this action is not recommended. The CallPilot Desktop Messaging
folder is a special folder. The From column and the Date/Time column, 
mentioned in the previous section, get their data from CallPilot customized 
fields within the message. The From field displays the GroupWise stored na
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for that user, and the Date/Time field displays the date and time the messag
first added to the user’s GroupWise database. This is always a later Date a
Time than the actual Date and Time the message was received on the Call
server.

These Date/Time fields are hidden from the user and created during installa
of the desktop client. If the user moves messages to other folders, these co
display inaccurate information. 

Delivery and non-delivery notification

The GroupWise user receives a delivery notification if he or she selects the
Delivery Receipt check box on the CallPilot custom form. This causes a tex
message to appear in the user’s inbox when the message has been succes
delivered.

A Non-Delivery Notification (NDN) is received when a message fails to reac
its destination. An NDN might contain the original message as an attachme
depending on where the problem is detected. If the problem is detected by 
CallPilot GroupWise client software, the original message is not attached 
because the send operation is canceled, and the original message remains
Outbox.

The original message is returned as an attachment only if the IMAP service
Message Transfer Agent (MTA) component of CallPilot rejects the message

Considerations for traveling users

CallPilot provides a phoneset interface for access to messages. In addition
GroupWise integrated clients provide offline support so users can view, pla
and create messages while not connected to the office LAN. Users must 
download all messages they want to have access to before working offline.
user accesses offline mode by selecting the Work Offline button from logon
dialog boxes, or any of the logon error or warning dialog boxes that display
Work Offline button.

After installing the GroupWise client, you must configure it for CallPilot 
Desktop Messaging. 
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CallPilot Message Store

When the user installs CallPilot Desktop messaging for GroupWise, the 
CallPilot Desktop installation process adds a folder to the user’s GroupWise
mailbox on the GroupWise Server.

If the user does not use the following procedure to remove CallPilot from 
GroupWise, the CallPilot Message Store might remain visible. This can be 
confusing to the user.

To remove CallPilot from GroupWise, you must remove CallPilot explicitly b
using the Add/Remove programs in Control Panel. Refer to “To uninstall a 
previous version of CallPilot” on page 76.
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To configure GroupWise for CallPilot 
Messaging

Getting there  Tools > CallPilot > CallPilot Configuration

1 Select the CallPilot Configuration Menu option.

Result: The following screen appears:

If the screen appears with no information in the fields, enter the following 
information after the field names:

Server:  The server name or IP Address.

SMTP/VPIM prefix: Designates a group of users on the server. For more 
information, refer to “Configuring SMTP settings” on page 49.

Mailbox:  A user’s mailbox number.

Check for new messages:  (Automatically/Manually) ISDN and dialup 
users might want to choose Manually. This option saves on toll charges by 
not continuously checking for new messages on the server.
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Include original message header when forwarding or replying: If 
checked, header information is added to each forward or reply. This allows 
CallPilot messages to be consistent with e-mail messages. Users can 
disable this feature, if required. 

Note: The server treats the attached text header of a voice message as a 
fax when accessed from the phoneset.

Remember password: Users can check this box if they do not want to 
enter their password each time they log on.

Personal folders: This field is not used by the CallPilot GroupWise client.

2 Click the Address Book tab.

Result: The following screen appears:

If the screen appears with no information in the fields, enter the following 
information after the field names:

Path:  The location of the local CallPilot address book.

Search base:  Enter the directory tree root hosted by the LDAP server on 
the CallPilot system.

Order: Use the drop-down arrow to select the order in which you want the 
names to be displayed in the address book.
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Remind me to download address book every 20 day(s ): If users want to 
automatically download addresses from the CallPilot server, they can 
check the check box. They can change the number of days, if required. 
Users can leave the box unchecked if no address download is desired. 

Download now: Users can select this button if they want to download the 
address book from the server on demand.

3 Click the Audio tab.

Result: The following screen appears:

Choose audio device before each audio session:  Users can select this 
check box if they do not use either the telephone or the PC to listen to their 
messages on a regular basis.

Audio device:  The user can choose either Computer or Telephone as a 
playback/record device. If Telephone is selected, the user must enter a 
telephone number and select Add.

Note: All telephone numbers are stored, which is useful if the user listens 
to or records messages from multiple locations.

4 Click the Volume Control tab.
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Result: The following screen appears:

The user can choose the default speaker and microphone volumes from 
this tab. The microphone level can only be changed from this dialog box. 
The user can change the volume level as well as the volume control on the 
player from this dialog box. The selected volume level is used for future 
player sessions.

5 Click OK to save your changes and exit.
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Section D: Configuring Lotus Notes

In this section
 Overview 98

 Updating the Mail database design manually 99
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Overview

Introduction

A user must have Manager or Designer access control of his or her mail data
to install the Lotus Notes CallPilot Desktop Messaging client. This control is
on the server by the Lotus Notes administrator for each user.

Updating the Mail database design

The Mail database design determines which messages appear in your Lotu
Notes message list. When you update the design, it changes your database
that CallPilot messages also appear in your message list. If you have the U
Lotus Notes Databases check box selected during installation, then there is
nothing else to do. However, if you want CallPilot messages and e-mail 
messages in the same folder, uncheck the Update Lotus Notes Databases 
box during installation, then see “Updating the Mail database design manually” 
on page 99.

See also

For more information on the Personal Address Book and CallPilot Address 
Book, refer to the online Help.
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Updating the Mail database design manually

Introduction

If a user wants CallPilot messages to be displayed in the same Inbox as his 
Lotus Notes e-mail messages, then the user can update the Mail database 
manually after first logging on. This is an alternative method. 

When a user updates the Mail database design manually, it allows him or h
see CallPilot messages from the Lotus Notes Inbox.

Nortel Networks’ recommended configuration is to select the Update Lotus 
Notes Databases checkbox during installation, which creates a separate vie
CallPilot messages. No manual update is required for this method.

Note: Replace the Mail database design only if Lotus Notes has not been 
customized. When a user replaces the Mail database design, it removes an
customization.

To update the Mail database design manually

1 Start and log on to Lotus Notes.

2 Make a note of the version of Lotus Notes. From the Help menu, select 
About Notes Desktop.

3 Click the Mail database (the database with your name and the envelope 
icon).

4 On the File menu, click Database, and then click Replace Design.

5 In the Replace Database Design dialog box, select Template Server.

6 In the Template Server window, select Local, then click OK.

7 Make sure that the Show advanced templates check box is checked.

8 Select CallPilot Mail (R4.5), CallPilot Mail (R4.6) or CallPilot Mail (R5.0) 
from the list. Your selection depends on which version of the Lotus Notes 
client you are running.

9 Click Replace.
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10 The system asks you to confirm that you want to change a database’s view. 
Click Yes.

To configure the optional Lotus Notes Server address book

An empty Lotus Notes database (callpilot.nsf) for the CallPilot address boo
must be installed in the Lotus Notes data directory during installation on the
Lotus Notes server. To install the database, follow these steps.

1 Insert the CallPilot Desktop CD in the Lotus Notes server CD-ROM drive.

2 From the Server directory, run setup.exe.

Result: An empty callpilot.nsf file is created.

To add a database to the Lotus Notes workspace

To add this database to the Lotus Notes workspace, the Lotus Notes serve
administrator follows these steps.

1 From the Lotus Notes server, select File > Database > Open.

2 Open a Lotus Notes database from the Server Workspace.

3 Select Browse to locate the callpilot.nsf file in the notes/data directory.

4 Click Select.

5 Press Add Icon to add the icon to the Server Workspace.

Result: The new icon appears on the Lotus Notes server workspace.

6 Double-click the icon and open the address book. 

7 Select CallPilot (People) and select Actions/Download CallPilot Address 
Book to populate the new database. 

Note: To download the address book, you must have the Lotus Notes 
server administrative password. Contact your IS administrator, if you do not 
have the password.
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Section E: Configuring the Internet Mail 
clients

In this section
 Overview 102

 Configuring Outlook Express or Outlook (in Internet Mail mode) 103

 Configuring Netscape Messenger 115

 Configuring Eudora Pro 122
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Overview

Introduction

CallPilot Desktop Messaging supports the following Internet mail clients:

� Outlook Express

� Outlook (in Internet mail mode)

� Netscape Messenger

� Eudora Pro

Note: It is very important to use at least the minimum supported version of t
Internet mail client as indicated above. In particular, Netscape Messenger 
versions earlier than 4.5 are incompatible with CallPilot Desktop Messaging
Your IS administrator can provide you with more information on upgrading y
Internet mail client. For more information on the supported Internet mail clie
and their versions, refer to the CallPilot 1.07 General Release Bulletin.

Before you begin

You need the following information to configure your Internet mail client:

� the fully qualified domain name or CLAN IP address of the CallPilot ser

� your CallPilot mailbox number and password

� the SMTP/VPIM prefix of the CallPilot server

� the search base to use for address searches in the CallPilot directory

Provide this information to desktop users if you want them to configure the 
client. You can customize the README.RTF file, which is located in the roo
directory of the CallPilot product CD, for your specific desktop messaging 
client.
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Configuring Outlook Express or Outlook (in 
Internet Mail mode)

Introduction

If your Internet mail client is Microsoft Outlook Express or Outlook, use the 
following procedures for configuration.

Note: For installation instructions, see Chapter 3, “Installing Desktop 
Messaging.”

To configure an IMAP account on Outlook Express or Outlook 

1 From the menu bar on the main screen, select Tools > Accounts > Mail.

The following screen appears. The contents of your screen might differ:

2 Click Add, and then click the Mail option.

Result: The Internet Connection Wizard starts up.

3 Type your name in the Display name box, and then click Next.
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Result: The Internet Connection Wizard - Internet E-mail Address screen 
appears.

4 Type your CallPilot mail address in the E-mail address box, and then click 
Next.

Your e-mail address should be in the form 
<SMTP/VPIM prefix><mailbox number>@<local CallPilot server>. 

Example: 14165556003@voiceserver.ca.result.com

where 1416555 is the SMTP/VPIM prefix

6003 is your CallPilot mailbox number

voiceserver.ca.result.com is the fully qualified domain name of 
the CallPilot server

Result: The following screen appears:

5 Choose IMAP as the incoming mail server type.
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Result: If you entered the CallPilot server name, voiceserver.ca.result.com, 
your screen appears as follows:

:

6 Click Next.

Result: The Internet Mail Logon screen appears with your IMAP account 
name already entered. 

7 Type your CallPilot mailbox password in the Password box.

Note: Do not check the Log on using Secure Password Authentication 
(SPA) box.
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Example: The following screen is an example of the Internet Mail Logon 
screen after you enter the IMAP account name and password:

8 Click Next.

Result: The Internet Connection Wizard - Friendly Name screen appears.

9 Type an easily recognizable name for your CallPilot IMAP account in the 
Internet mail account name box.

Example: You can type in your first name or full name, or you can type a 
name that identifies the purpose of the account.

10 Click Next.

Result: The Internet Connection Wizard - Choose Connection Type screen 
appears.

11 Choose the connection type between your PC and your CallPilot server.

Example: The connection chosen in the example is for a local area 
network (LAN). Your connection type can differ.

12 Click Next.

Result: The Internet Connection Wizard - Congratulations screen appears.

13 Click Finish.
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Result: The Outlook Express screen appears.

14 Select Yes to download the folder list for the IMAP account that you just 
created. Select No if you do not want to download the folder list at this time.

Result: In either case, the following screen appears.

Tip: To make changes to your new IMAP account, select the account name 
and click Properties to display the Properties page.

15 Click Close.
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To configure an LDAP directory service for Outlook Express or 
Outlook 

1 From the menu bar on the main screen, select Tools > Accounts > Directory 
Service.

Result: The following screen appears. The contents of your screen might 
differ:

2 Select Add and click the Directory Service option.
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Result: The Internet Connection Wizard starts and the following screen 
appears:

3 Type the fully qualified domain name of the CallPilot server into the Internet 
directory (LDAP) server box.

Note: Do not check the My LDAP server requires me to log on box.

4 Click Next.

Result: The Internet Connection Wizard - Check E-mail Addresses screen 
appears.

5 If you want to check for addresses in the CallPilot LDAP directory when 
addressing messages, click Yes; otherwise, click No.

6 Click Next.

Result: The Internet Connection Wizard - Friendly Name screen appears.

7 Type an easily recognizable name for your CallPilot directory service in the 
Internet directory service name box.

Tip: Type in a name that helps you to recognize the type of information in 
the directory.

8 Click Next.

Result: The Internet Connection Wizard - Congratulations screen appears.

9 Click Finish. 
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Result: The Internet Accounts screen appears.

10 Click Properties, and then click the Advanced tab.

Result: The following screen appears:

11 If your CallPilot server has SSL enabled and you want to use this option for 
directory searches, place a check mark in the This server requires a secure 
connection (SSL) box.

12 If your network is slow, move the slide bar under Search timeout toward 
Long to increase the timeout.

13 If you expect to do directory searches that return more matches than the 
number shown, increase the number in the Maximum number of matches 
to return box.

14 Type the search base for the CallPilot directory in the Search base box.

Note: Your system administrator can provide you with the search base.

15 Click OK.
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Result: The Directory Service screen appears again.

16 If you choose to check for addresses in the CallPilot LDAP directory, click 
Set Order. 

Result: The Directory Services Order screen appears.

Tip: If necessary, use Move Up or Move Down to position the CallPilot 
LDAP directory in the search order.

17 Click OK.

Result: The Directory service screen appears.

18 Click Close.

To configure special settings for Outlook Express or Outlook (Internet 
Mail mode)

1 If you are using Outlook Express, check the following settings:

a. From the menu bar on the main screen, select Tools, and then click 
Options from the pull-down menu. 

b. Click the Send tab.

Result: The Options screen appears.

c. Under Mail sending format, select Plain Text.

d. Click Settings beside Plain Text.

Result: The following screen appears:

e. Under Message format, select MIME. 

f. Under Encode text using, select None.
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g. Click OK.

Result: The Options Send tab appears.

h. Click OK.

2 If you are using Outlook 98, check the following settings:

a. From the menu bar on the main screen, select Tools, and then click 
Options from the pull-down menu.

b. Click the Mail Format tab.

Result: The following screen appears:

c. Under Send in this message format, select Plain Text.

d. Click OK.

3 If you add addresses from the CallPilot LDAP directory to your Outlook 
Express or Outlook 98 personal address book, check the following setting:
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a. Select the recipient name in the personal address book, and click with 
the right mouse button. From the pop-up menu, select Properties, and 
then select the Personal tab.

Result: The Properties screen appears.

b. Place a check mark in the box for Send E-Mail using plain text only.

To test the Outlook Express or Outlook (Internet Mail mode) IMAP 
account

1 Use your telephone to log on to your CallPilot mailbox.

2 Compose a test voice message and send it to yourself.

Example 1: If your Internet mail client is Outlook Express, the following 
screen appears when the message is delivered. Your screen can differ:
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Example 2: If your Internet mail client is Outlook 98 or Outlook 2000, the 
following screen appears. Your screen can differ:
114 CallPilot



May 2000 Installing and configuring Desktop Messaging on the user’s PC

ures 

nnot 

cape 
rver 

rsions 
Configuring Netscape Messenger

Introduction

If your Internet mail client is Netscape Messenger, use the following proced
for configuration.

Notes: 

1. If the desktop user is using Netscape with POP for e-mail, Netscape ca
be configured with IMAP at the same time. You must set up a different 
Netscape user profile.

2. If the desktop user is already using Netscape for his or her e-mail, Nets
cannot be configured to send mail to CallPilot, since only one SMTP se
can be configured. You must set up a different Netscape user profile.

3. You need Netscape Messenger 4.5 or above. Netscape Messenger ve
prior to 4.5 are incompatible with CallPilot Desktop Messaging.

For installation instructions, see Chapter 3, “Installing Desktop Messaging.”

To configure an IMAP account on Netscape Messenger

1 From the menu bar on the main screen, select Edit, and then, from the pull-
down menu, click Preferences.

2 In the Mail & Newsgroups category, select Identity.

Result: The Preferences screen appears.

3 Type your name and CallPilot mail address in the first two boxes.

Enter your e-mail address in the form 
<SMTP/VPIM prefix><mailbox number>@<local CallPilot server>. 

Example:  198887002@voiceuser.factor.com

where 19888 is the SMTP/VPIM prefix

7002 is your CallPilot mailbox number

voiceuser.factor.com is the fully qualified domain name of the
CallPilot server
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Result: When you fill in the appropriate boxes, the screen appears as 
follows. Your screen can differ:

4 In the Mail & Newsgroups category, select Mail Servers.

Result: The Preferences screen appears.

5 Click Add so that the Mail servers properties dialog box appears. Select the 
General tab if it is not already selected. Type the fully qualified domain 
name of the CallPilot server in the Server Name box.

6 Type the part of your CallPilot mail address to the left of the @ sign in the 
User Name box.

7 Set the frequency that you want Netscape Messenger to check for new 
messages in the Check for mail every ___ minutes box.
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Example: The Mail Server Properties screen shows an example of a 
configuration. Your screen can differ:

8 Select the IMAP tab.

9 If your CallPilot server has SSL enabled and you want to use this option, 
check the Use secure connection (SSL) box.

10 Under When I delete a message, choose Mark it as deleted.

11 Check the Clean up (“Expunge”) Inbox on exit box. 

12 Click OK.

Result: You return to the Mail Servers screen.

13 Type the fully qualified domain name of the CallPilot server in the Outgoing 
mail (SMTP) server box.

14 Type the part of your CallPilot mail address to the left of the @ sign in the 
Outgoing mail server user name box.
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Example: The following screen shows an example of a configuration. Your 
screen can differ:

15 In the Mail & Newsgroups category, select Addressing.

16 Under Pinpoint Addressing, check both Address Books and Directory 
Server.

17 In the Mail & Newsgroups category, select Messages.

18 Under Forwarding and Replying to Messages, By default, forward 
messages:, select As Attachment.

19 Under Send messages that use 8-bit characters, choose Using the “quoted 
printable” MIME encoding.

20 In the Mail & Newsgroups category, select Copies and Folders.

21 Deselect Create a new folder on my IMAP server.

22 Clear all boxes.

23 In the Mail & Newsgroups category, select Formatting.
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24 Under Message formatting, choose Use the plain text editor to compose 
messages.

25 In the Mail & Newsgroups category, select Return Receipts.

26 Under If I request a receipt when sending a message, I want, choose A 
delivery receipt from the receiving server (DSN).

27 Under When a receipt arrives, choose Leave it in my Inbox.

28 Click OK.

To configure an LDAP directory service for Netscape Messenger

1 From the menu bar on the main screen, select Communicator. Then, from 
the pull-down menu, click Address Book.

Result: The Address Book screen appears.

2 Select File, and then select New Directory from the pull-down menu.

Result: The Directory Server Property screen appears.

3 In the first three boxes, type

� a descriptive name for your CallPilot directory service

� the fully qualified domain name of the CallPilot server

� the search base into the first three boxes.

Note: If you are the desktop user, ask your CallPilot system administrator 
to provide you with the search base.
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Example: The following shows a filled-in screen. Your screen can differ:

4 Click OK.
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To test the Netscape Messenger IMAP account

1 Use your telephone to log on to your CallPilot mailbox.

2 Compose a test voice message and send it to yourself.

Example: When the message is delivered, the following screen appears. 
Your display can differ:
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Configuring Eudora Pro

Introduction

The following procedures and screens describe the configuration of Eudora

To change any part of this configuration after it is complete, select Tools fro
the menu bar on the main screen, and then click Options to display the 
configuration screens.

Note: For installation instructions, see Chapter 3, “Installing Desktop 
Messaging.”

To configure an IMAP account on Eudora Pro

1 Double-click the Eudora Pro icon.

Result: The New Account Wizard - Welcome to Eudora Pro! screen 
appears.

ATTENTION Eudora Pro version 4.2 does not support the CallPilot 1.0
Secure Socket Layer (SSL).
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2 Click Next.

Result: The New Account Wizard - Account Settings screen appears.

Note: If you have another IMAP account for your CallPilot mailbox, you can 
import the settings. This configuration assumes that the Eudora IMAP 
account is a new configuration.

3 Under Would you like to:, select Create a brand new e-mail account, and 
then click Next.

Result: The New Account Wizard - Personal Information screen appears.

4 Type your name in the Your Name box, and then click Next.

Result: The New Account Wizard - E-Mail Address screen appears.

5 Type your CallPilot mail address in the E-Mail Address box, and then click 
Next.

Your e-mail address should be in the form 
<SMTP/VPIM prefix><mailbox number>@<local CallPilot server>. 

Example: 14164067001@voiceuser.factor.com

where   1416406 is the SMTP/VPIM prefix

7001 is your CallPilot mailbox number

voiceuser.factor.com is the fully qualified domain name of the
CallPilot server

Result: The New Account Wizard - Logon Name screen appears.

6 Check that the Logon Name box contains the part of your CallPilot mail 
address to the left of the @ sign, and then click Next.

Result: The New Account Wizard - Incoming E-Mail Server screen 
appears.

7 Check that the Incoming Server box contains the fully qualified domain 
name of the CallPilot server.

8 Under Please choose whether the server for your incoming mail uses POP 
or IMAP, choose IMAP, and then click Next.

Result: The New Account Wizard - IMAP Location Prefix screen appears.

9 Click Next without entering a location prefix.
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Result: The New Account Wizard - Outgoing E-Mail Server screen 
appears.

10 Check that the Outgoing Server box contains the fully qualified domain 
name of the CallPilot server, and then click Next.

Result: The following screen appears:

11 Click Finish.

Result: The following screen might appear, based on the speed of the 
server connection:
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Result: When the connection is made, the following screen appears:

12 On the menu bar, select Tools > Options.

13 Scroll to the Attachments icon under the Category heading.

Result: The Options screen appears.

14 Under Encoding method, select MIME.

15 Scroll to the Styled Text icon under the Category heading.
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Result: The following screen appears:

16 Under When sending mail with styled text (HTML):, select the Send plain 
text only option.

17 Click OK to save the changes for both the Attachments and the Styled Text 
screens.

Result: The system returns you to the main screen.
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To configure an LDAP directory service for Eudora Pro

1 On the menu bar on the main screen, click Tools > Directory Services.

Result: The following screen appears:

2 Select LDAP in the Protocols box, and then click New Database... .

Result: The Modify Database screen appears.

3 On the Network tab, type a descriptive name for the CallPilot directory 
service in the first box, and then type the fully qualified domain name of the 
CallPilot server in the Host Name box.

4 Select the Search Options tab.
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Result: The following screen appears:

5 If your network is slow, move the slide bar under Search timeout toward 
Long to increase the timeout. 

6 Type the search base for the CallPilot directory in the Search Base box.

Note: Your IS administrator can provide you with the search base.

7 Click OK.

Result: The system returns you to the Directory Services screen.

8 Click the X in the upper right corner of the Directory Services screen to 
return to the main screen.

To test the Eudora Pro IMAP account

1 Use your telephone to log on to your CallPilot mailbox.

2 Compose a test voice message and send it to yourself.
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Result: When the message is delivered, the following screen appears. 
Your display can differ:
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Overview

Introduction

CallPilot Web Messaging allows users to access, view, listen to, and delete
CallPilot messages using a web browser. They cannot create or edit messa

Architecture overview
CallPilot Web Messaging requires the installation of the CallPilot Web 
Messaging web site application, which runs within your Microsoft Internet 
Information Server (IIS, version 4).

Note: Nortel Networks recommends that you use this web server exclusively
the CallPilot Web Messaging web site application and no other mission-crit
web applications.

The WinNT server hosting CallPilot Web Messaging must not be the same 
WinNT server that hosts CallPilot. Place the Web Messaging server on the 
customer LAN and not on CallPilot’s ELAN.

Most client-server communications are implemented using HTTP and the 
intermediary web server. In this way, Web Messaging can be deployed acro
your company’s firewall to the Internet, with the option of using third-party 
certificate authorities.

User overview
Users access the CallPilot Web Messaging system and display their CallPil
messages over a direct connection to the CallPilot Web Messaging URL. T
can use any PC that has a supported browser and HTTP access to the Cal
Web Messaging server. Users can access all message content through a d
network. Dial-up users access all messages through the same single teleph
line that is used for the dial-up modem connection. 

The CallPilot Player enables users to play their CallPilot voice messages fr
telephone or from a computer. The Microsoft Media Player (version 6.01 or
later) enables users to play their messages from a computer.
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Users can display faxes on any client PC that has Imaging for Windows 
installed.

Supported languages

CallPilot Web Messaging supports the following languages:

� English

� French

� German

� Chinese

� Japanese
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Hardware and software requirements

Introduction

CallPilot Web Messaging requires the following hardware and software.

Web server hardware

The CallPilot Web Messaging server requires the following hardware:

� a minimum Pentium 166 MHz Pentium processor (450 MHz 
recommended)

� a minimum 64 Mbytes of RAM (128 Mbytes recommended)

� 20 Mbytes of free disk space

Note: If you require voice messages to be played over the Windows Media 
Player, the messages must be transcoded to WAV format. This can be proc
intensive. Nortel Networks recommends a 450 MHz processor on the web s
if you expect a large amount of transcoding. 

Web server software

The CallPilot Web Messaging server requires the following software:

� Microsoft WinNT 4 server with Service Pack 3, 4, or 5

� an installed and operational version of Microsoft IIS 4

PBX hardware

CallPilot Web Messaging is supported with any of the PBX options approved
connection to CallPilot.

CallPilot system hardware

CallPilot Web Messaging does not interact directly with any CallPilot hardwa
as all interfaces use the CallPilot IMAP service.
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CallPilot software

You must install CallPilot with a keycode that enables CallPilot Desktop 
Messaging features.

Client PC requirements

CallPilot Web Messaging requires one of the following operating systems on
client PC:

� Windows 95 retail, OSR 2.1

� Windows 98

� Windows 2000

� WinNT 4 Workstation

CallPilot Web Messaging requires Desktop Messaging capability on the 
CallPilot mailbox.

The client PC also requires one of the following web browsers with JavaScr
and cookies enabled:

� Microsoft Internet Explorer

� Netscape Navigator 4.x

The CallPilot Player
You use the CallPilot Player or the Microsoft Media Player (version 6.01 or 
later) for voice message playback. You must install the player on the client P
before voice messages can download. 

Note: After you install CallPilot Web Messaging, you can install the CallPilo
Player or the Microsoft Media Player, or another supported player, using a 
from the Downloads area of the window.

Imaging for Windows
You need Imaging for Windows for fax display and printing.

Note: After you install CallPilot Web Messaging, you can install Imaging for 
Windows, using a link from the Downloads area of the window. The Downlo
Link is displayed on the browser window at all times, not only on the logon 
window.
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Security

Introduction

CallPilot Web Messaging operates using Internet components and might ha
limitations imposed on it by companies’ network security policies. It does no
attempt to circumvent any firewall or other network security software installe
by companies on top of TCP/IP.

The CallPilot Web Messaging client passes the user password in the clear 
the network between the user’s browser and the web server. The web serve
turn, passes the user password to the CallPilot IMAP server in the clear ove
your network.

Using an authentication certificate

For customers who require medium to high security, Nortel Networks 
recommends the installation of an authentication certificate in the Microsoft
Internet Information Server (IIS) (the web server), which allows the browser
connect to the server using a strongly encrypted network channel. 

Secure Socket Layer (SSL) is a security protocol that provides the following
features:

� encryption of all information passed between the client and the server

� authentication of the server’s identity

� authentication of the client’s (browser’s) identity

When SSL is enabled on the web server, the CallPilot web client automatic
detects this, and it uses the HTTPS protocol to ensure that the user’s mailb
and password are channeled through SSL.
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Enabling SSL

To enable SSL security on your web server, ask your IS administrator to fol
the instructions in the IIS documentation. Here is a high-level overview of th
process:

1. Generate a server certificate request by using the Command menus in
IIS Manager application.

2. Present the certificate request to a certificate authority, and obtain a sit
certificate. 

3. Select the certificate authority that you or the IS administrator feels mo
comfortable with. 

4. Install the site certificate on the IIS web server using the Command me
in IIS Manager.

Note: After this has been done, you can publish the HTTPS URL to access 
CallPilot Web Messaging.

Once SSL is enabled for the CallPilot Web Messaging directory, the access 
is http://<server address>/CallPilot.

Port hiding

If you make CallPilot Web Messaging available over the Internet, you might
want to change the TCP port used to connect to the web server. 

Normally, all HTTP web connections arrive on port 80. However, you can 
configure the Microsoft IIS server to accept HTTP connections on any other
specified port. If this is done, CallPilot Web Messaging automatically detect
this configuration and uses the configured port when connecting to the serv

This can provide an additional level of security because it hides the service 
malicious attempts to scan well-known TCP ports.

Speak to your IS administrator if you want to have this additional level of 
security.
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Recommended configuration for external 
Internet access

Introduction
The following diagram shows the recommended configuration of the various
servers used by CallPilot Web Messaging when installed in a network with 
Internet firewall.

. 

CAUTION

Risk of system corruption or data loss
Nortel Networks strongly recommends that you obtain an 
independent security audit before you provide external access 
your system based on the recommended configuration.
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Notes on the recommended configuration

1. This solution requires an additional web server to act as an external pr
server. Typically, many customers already have a PC outside the firewa
(for DNS and SMTP). This server can double as the web server proxy.

2. Use SSL to secure all web browser to web server communications.

3. Use SSL to secure all traffic from the external web server proxy to the 
internal web server (the CallPilot web server).

4. All traffic to and from the CallPilot server remains behind the firewall. Th
is desired as there is no facility to encrypt it, and passwords are handle
the clear.

5. Configure the firewall to allow HTTP connections between the internal 
CallPilot web server and the external web server proxy.

Discuss the configuration requirements with the IS administrator.
Desktop Messaging Software Installation and Maintenance Guide 139



CallPilot Web Messaging Standard 1.0

 
wing 

 on 

 

)

e 

al 

e 
 

Installing CallPilot Web Messaging 

Introduction

CallPilot Web Messaging uses Microsoft Internet Information Server (IIS) to
host a web site from which users can retrieve CallPilot messages. The follo
instructions show how to set up and configure the CallPilot components.

You execute the installation on the WinNT server. No installation is required
the user’s desktop.

If you are unfamiliar with the operation and administration of Microsoft’s 
Internet Information Server, contact your IS administrator to assist you in 
installing CallPilot Web Messaging.

Before you begin

1. Before you install CallPilot Web Messaging, you must have installed an
operational version of Microsoft Internet Information Server (IIS) 4. 

2. You require the following information for the installation:

� the host name of the CallPilot server (Fully Qualified Domain Name

� the alias name of the virtual directory for the CallPilot web client. Th
default alias is CallPilot. Obtain the alias name from the IS 
administrator.

� the name of the web site to which you want to add the CallPilot virtu
directory (the default is Default web site)

3. On the desktop user’s PC, the user needs the CallPilot Player or the 
Microsoft Media Player (or another supported player) for voice messag
playback. The user also needs Imaging for Windows for fax display and
printing.
140 CallPilot



May 2000 CallPilot Web Messaging

st 

ne 
To uninstall previous versions of CallPilot Web Messaging

If you have installed an earlier version of CallPilot Web Messaging, you mu
uninstall this version before proceeding.

1 Shut down the IIS web server service.

2 From the Windows Start menu, select Control Panel > Add/Remove 
Programs, and then select CallPilot Web Messaging.

3 Click Add/Remove and confirm that you want to remove CallPilot Web 
Messaging.

4 Run the CallPilot Web Messaging uninstall program.

5 You might need to restart your machine, and then manually remove the old 
directory and files that were in use.

Result: In any case, the service starts up automatically and the CallPilot 
virtual directory is deleted automatically.

Note: The uninstall program does not remove the directory structure 
c:\CallPilot\WebMessaging\bin. You must remove this manually.

If the web client fails to stop the World Wide Web service or seems to hang 
while you stop the service, you might need to stop this service manually. 

a. From the Windows Start menu, select Control Panel > Services. Select 
World Wide Web Publishing service, and then click Stop.

b. If this fails to stop the service, open a console window and type
net stop iisadmin /y  

This stops all IIS services, such as FTP and World Wide Web. 

c. You must restart these services after you finish uninstalling CallPilot 
Web Messaging. 

From the Windows Start menu, select Control Panel > Services. Select 
World Wide Web Publishing service, and then click Start.

To install CallPilot Web Messaging 

The setup is slightly different depending on whether you install from a 
CD-ROM or from a file downloaded from the web. This procedure can be do
in conjunction with the IS administrator.
Desktop Messaging Software Installation and Maintenance Guide 141



CallPilot Web Messaging Standard 1.0
1 Log on to your Internet Information Server computer with administrator 
privileges.

2 If you are installing from a downloaded file, you need to unarchive the 
downloaded file into a temporary directory. In Windows Explorer, navigate 
to the downloaded file and double-click the executable file name. When 
prompted, choose a temporary directory in which to store the unarchived 
files.

3 Use Windows Explorer to navigate to the executable Setup file. 

This file is in the root directory of the CD-ROM or in the temporary directory 
on your disk drive where you unarchived the downloaded file.

4 Double-click Setup (setup.exe).

5 In the Welcome window, click Next.

6 In the Choose Destination Location window, choose the location on your 
hard drive where you want to install the CallPilot Web Messaging files, and 
then click Next. 

Note: The default is c:\CallPilot\WebMessaging.

7 In the IIS Virtual Directory window, enter the alias of the virtual directory for 
the CallPilot web application.

Note: The default alias is CallPilot.
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8 In the IMAP Server Information window, type the IP address or the host 
name of the CallPilot server, and then click Next.

9 In the Select Components window, choose both English text strings and 
Program Files as the components to install, and then click Next.

Result: The World Wide Web Service is automatically stopped.

Note: If you are installing on a web server with IIS 4, you might see an error 
dialog box. This does not affect the installation. When you cancel, the 
installation resumes.

10 In the Choose Web Site window, select the web site to which you want to 
add the CallPilot virtual directory, and then click Next.

Note: The default is Default web site. 

You might have to check whether this window appears behind the Setup 
window.

11 You can view the CallPilot Web Messaging site. Use your web browser to 
view the URL

http://<servername>/<virtual_dir_name> 

where <virtual_dir_name> is the name of the virtual directory that you 
entered during the installation.
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To test your installation

1 Go to a client PC that has access over the network to the CallPilot Web 
Messaging web server.

Note: The client PC must run on one of the following supported platforms:

� Windows 95 retail, OSR 2.1

� Windows 98

� Windows 2000 Professional

� WinNT 4 Workstation

2 Start up a supported browser on this client PC. 

Note: The following are the supported browsers. You must enable 
JavaScript/Jscript and Cookies:

� Microsoft Internet Explorer

� Netscape Navigator version

3 Navigate to the CallPilot Web Messaging web site, which is the virtual 
directory you created during installation.

Note: This is normally CallPilot. In a typical installation, you navigate to 
http://<your server address>/CallPilot.

4 In a few seconds, the Logon window appears, and you can log on.

Note: If you see the following error messages when you browse to the CallP
Web Messaging URL, and your web server is running IIS 4 with Service Pac
then ensure that the virtual directory is set up as an application:

Document contains no data

Session (…) object required

The browser times out

To verify that the virtual directory is set up as an application, right-click the 
virtual directory in the Microsoft Management Console, and then select 
Properties. Under Application Setting, ensure that an application has been 
created. (You should see a Remove button, not a Create button.)
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To download supported plug-ins

CallPilot Web Messaging requires the CallPilot Player, the Windows Media 
Player, or another supported player for playback of voice messages, and Im
for Windows for fax display.

For more information, refer to the online Help provided with CallPilot Web 
Messaging.

1 To install a required plug-in, on the web client PC, click Downloads.

2 Click the required plug-in, and then install it.

Note: Some of the links are to external sites.
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Overview

Introduction

This chapter identifies problems that users can experience with Desktop 
Messaging. 

The troubleshooting information is divided into symptoms and solutions. A 
symptom defines the problem that the desktop user is facing. A solution 
describes the steps you follow to fix the problem. Based on the user’s exper
you might prefer to guide the user in running the steps. 

If the suggested action does not correct the problem, contact your Nortel 
Networks representative.

Note: These problems apply to all clients unless otherwise noted. The solutio
executed from the desktop PC. Where the solution requires action on the 
CallPilot server or administration client, the step listed notifies you that this is
administrator action only.
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Troubleshooting during installation

Before you install

Before you begin to install Desktop Messaging for Microsoft Exchange, 
Microsoft Outlook, GroupWise, or Lotus Notes, you require the following 
information:

� your CallPilot mailbox number

� the fully qualified domain name of the CallPilot server

� the SMTP/VPIM prefix of the CallPilot server

� the search base to be used for LDAP address searches in the CallPilot 

Note: Before you install the CallPilot Desktop Client, make sure your Integra
Client (Microsoft Exchange, Microsoft Outlook, GroupWise, or Lotus Notes)
working properly.

To obtain the version number

1 If the user cannot log on, but you require the CallPilot version number, 
navigate to the following file: 

windows\system\nmdcva.exe

2 Highlight the file, right-click, and then select Properties. 

Result: The Properties page appears. 

3 Select the Version tab. 

Result: Version information for CallPilot Desktop Messaging appears.

Symptom - error message about default mail client (Microsoft Outlook 
only)

You receive an error message when you install the CallPilot desktop: “Eithe
Outlook is not the default mail client or there is no default mail client to fulfil
the current request.”
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If Outlook is installed on your PC but you do not want Outlook to be your 
default mail client, you can change to another client after the CallPilot Desk
is installed.

Solution

1 To define Outlook as the default mail client, on the Windows Start menu, 
click Settings > Control Panel. Double-click Internet Options.

2 On the Internet Properties dialog box, click the Programs tab.

3 In the E-mail box, select Microsoft Outlook from the dropdown list.

4 Click OK to close the Internet Properties dialog box.

5 To close the Control Panel, click File > Close, or click X in the top right 
corner.

Symptom - error message about Image Viewer

Error message: “Image Viewer is not installed.”

This means you need Imaging for Windows to view and compose faxes. Du
installation, CallPilot checks for Imaging for Windows. If it is not installed, 
CallPilot still installs successfully. You can install the imaging software later.

Solution

1 To install Imaging for Windows, from the Windows Start menu, select 
Settings > Control Panel > Add/Remove Programs.

2 Click the Windows Setup tab.

3 Highlight and double-click Accessories.

4 Scroll down the list, and ensure that Imaging is checked. 

5 Click OK to return to the Control Panel.

Note: If Imaging for Windows is not installed on your PC, you can install it 
from the CallPilot Desktop Messaging CD.

Symptom - authorization error message (specific to Lotus Notes 
clients)

Error message: “No authorization to perform this operation.”
150 CallPilot



May 2000 Troubleshooting

 to 
or 
. 

yed. 

 

es.
Solution
A user must have Manager or Designer access control of the mail database
install the Lotus Notes CallPilot desktop client. The Lotus Notes administrat
sets this control on the server for each user. The default is Manager access

To determine the level of access control for a user

1 From the user’s Lotus Notes Mail database, select File > Database > 
Access Control... . 

2 Click the user’s name in the displayed list. 

Result: The user’s access control level appears in the Access box. The 
choices are Manager, Designer, Editor, Author, Reader, Depositor, and No 
Access. 

For a user to install the desktop client, Manager or Designer must be displa
If neither Manager nor Designer is selected, then 

� you must temporarily give the user Manager or Designer access

or

� the Lotus Notes administrator must manually update the Mail database
from the server for each user needing CallPilot access

This update creates a new view, CallPilot Desktop Messaging, in Lotus Not

To update each CallPilot user Mail database from the server (when a 
user is unable to update his or her own database)

1 Install CallPilot Desktop Messaging on the Lotus Notes server computer by 
running Server > setup.exe.

2 Start Update database design.

Note: To locate the Update database design program, click Start > 
Programs > Nortel CallPilot Desktop > Update database design.

3 From Update CallPilot Mail databases, select Add CallPilot components or 
Remove CallPilot components.

4 Click OK.

5 From the Select database(s) dialog box, select one or a group of mail files 
to update.

6 Click OK.
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Symptom - error message about invalid credentials

The user gets a message similar to “Invalid credentials. Please retry...” or “T
server could not be located. Please Retry... .”

Solution (from the desktop user’s PC)

1 Check that Desktop Messaging is configured with the proper settings. Verify 
that the following information is correct:

� mailbox number

� fully qualified domain name (FQDN) of the CallPilot server

� the SMTP/VPIM prefix of the CallPilot server

� the search base for address searches in the CallPilot directory

2 Check that you can log on successfully from the telephone using the same 
mailbox number and password.

3 Verify that you have network connectivity to the CallPilot server. 

For example, issue a network command to the CallPilot server exactly as it 
appears in your Desktop Messaging configuration—try to ping using the 
DOS prompt—and ensure that you receive a valid response from the 
CallPilot server. If you do not have network connectivity to the CallPilot 
server, then you are not able to access CallPilot Desktop Messaging.

Solution (from the Client PC)

1 On the Administration Client PC, check that IMAP is enabled on CallPilot, 
mailbox class has been desktop enabled, and there are no alarms referring 
to the IMAP service.

2 The CallPilot server name might not be in the DNS server. 

To check if the name is in the server, on the Client PC, from the DOS 
prompt, issue a ping command to the CallPilot server IP address. Then 
issue a ping command to the fully qualified domain name of the CallPilot 
server. If you receive a ping response from the IP address but not the 
server name, then check the following:
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� Ensure that DNS is configured on this PC. Under TCP/IP properties, 
select the DNS tab. Ensure that a DNS server is listed. Verify that it is 
the correct IP address for the DNS server.

� Check with the DNS administrator whether the server name is in the 
DNS server. Verify that the correct hostname has been configured in the 
DNS server.

� If you do not have a DNS server, then you must add the CallPilot server 
hostname to the Client PC's host file.

The following actions can be taken to resolve this situation:

a. The CallPilot FQDN must be properly configured in the DNS server.

b. If there is no DNS server available, then you must add an entry to the 
Client PC's Host file.

See “Configuring environments without a DNS” on page 54 for instructions 
on configuring CallPilot Desktop messaging in an environment with no DNS 
server.

Note: Nortel Networks recommends that you set up DNS properly instead o
asking the desktop users to update their host file. Optionally, you can ask u
to configure their client with the IP address instead of host names.

To add an entry to the HOSTS file

1 If the user is running Windows 95 or 98, open the host file usually located in 
the Windows directory.

If the user is running Windows NT, open the host file usually located in the 
WinNT\system32\drivers\etc directory.

If the user does not have a host file, open the HOSTS.SAM file located in 
the directory specified above, and rename it host (no extension).

2 Add the following line to the host file:

<IP address>tab<fully qualified domain name of CallPilot server>

Example: 102.54.94.97  rhino.acme.com
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3 Save and close the file.

Note: If the problem continues, try to stop and restart IMAP service on the 
CallPilot server. 

Symptom - error message about no Desktop Capability

When the user attempts to log on, a message states that “You do not have 
Desktop Capability.”

Solution
As the CallPilot administrator, do the following:

1 Verify that Desktop Messaging is configured with the correct Mailbox 
number.

2 Verify that this mailbox is assigned to a mailbox class that is desktop-
enabled. For more information on mailbox class, refer to the Administrator’s 
Guide.

ATTENTION When you restart this service, it can cause the desktop 
user session to end. The system administrator must 
restart the desktop client.
154 CallPilot



May 2000 Troubleshooting

 

iew 

d 

g.
Troubleshooting logon problems (for Lotus 
Notes clients)

If CallPilot has been properly installed, then the user sees CallPilot Desktop
Messaging under Folders and Views. In the Personal Name and Address 
Book on Local database, the user sees two new views:

� Groups (CallPilot)

� People (CallPilot)

Notes: 

1. In Lotus Notes version 5.0, these views are accessible only from the V
menu.

2. Lotus Notes 5.0 users must log on to CallPilot before they can downloa
the address book.

Symptom - cannot see CallPilot Desktop Messaging

 When the user logs on, he or she does not see CallPilot Desktop Messagin

Solution

1 Verify that you are in Folders and Views > CallPilot Desktop Messaging.

2 If you do not see CallPilot Desktop Messaging and you are in Folders and 
Views, uninstall the current version of CallPilot, and then reinstall it. When 
you reinstall, ensure that Update Lotus Notes databases is checked in the 
Ready to Install! window. 

Note: This is the default. Nortel Networks recommends that you leave this 
box checked.

Whether or not you select the check box, you have the option to update the 
Mail database design manually.

Note: Replace the Mail database design only if you have not customized 
Lotus Notes. When you replace the database design, it removes any 
customization.
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You require Manager- or Designer-level access to update the Mail database 
design.

To replace the Mail database design
If you are a Lotus Notes user, to replace the Mail database design, see “Updating 
the Mail database design manually” on page 99.

The Lotus Notes administrator can replace the Mail database design from t
Lotus Notes server. 

To update the Mail database design (Lotus Notes administrator)

1 Copy one of the files—cpmail45.ntf if you have Lotus Notes 4.5, 
cpmail46.ntf for Lotus Notes 4.6, or cpmail50.ntf if you have Lotus Notes 
5.0—into the notes/data directory on the Lotus Notes server.

2 Use File > Database > Open to add the mail database icon that you are 
going to update.

3 Select this icon.

4 Select File > Database > Replace design.

5 In the Replace Database Design window, check the Show advanced 
templates check box.

6 Make sure that 

� the Inherit future design changes check box is checked

and

� Hide formulas and LotusScript is not checked

7 Select CallPilot Mail (R4.5), CallPilot Mail (R4.6), or CallPilot Mail (R5.0).

8 Click Replace.

9 Repeat steps 3 to 8 for each database that you must update.

10 Press F9 to refresh the window and display the names.

Symptom - no entries in CallPilot Personal Name and Address Book

While in the Personal Name and Address Book window, the user selects Pe
(CallPilot). There are no entries in the CallPilot Address Book.
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Solution
You must download the CallPilot Address Book manually and update the 
Personal Address Book template.

To manually download the CallPilot Address Book

1 Make sure that your Address Book—People (CallPilot) window is the active 
window.

2 From the Actions menu, select Download CallPilot Address Book.

Symptom - DLL error message

Error message: “The dynamic link library nNOTES.dll could not be found in 
specified path.”

Solution

1 On your desktop, right-click the Lotus Notes icon, select Properties, and 
then click the Shortcut tab.

2 Examine the properties of your Lotus Notes shortcut.

3 Verify the path in the Start in box.

Note: Usually, when Lotus Notes creates a shortcut, it puts a working 
directory in this box.

4 Add or update the path.

Symptom - no entries in CallPilot address book

The CallPilot address book has been downloaded and a dialog box appear
stating that 0 entries are found.

Solution
As the administrator, do the following:

1 Check the CallPilot Address Book search base.

Note: Search base is configured under Actions > CallPilot Desktop 
Messaging > CallPilot Desktop Messaging. Select the Address Book tab.

2 Verify that the search base is exactly as it is configured on the CallPilot 
Administration Client.
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Troubleshooting after the user has logged on 
successfully

Symptom - the CallPilot address book is empty

Solution (Lotus Notes client)

Note: Lotus Notes 5.0 users must log on to CallPilot before they can downlo
the address book.

1 Make sure that your Address Book—People (CallPilot) window is the active 
window.

2 On the View menu, click Refresh.

3 Make sure the CallPilot Address Book has been downloaded.

Solution (Exchange/Outlook and GroupWise clients)

1 Click Download CP Address Book.

2 If it responds with 0 entries found, verify that the search base is correct.

Symptom - the user has message access problems

The user has modified the settings so that they are now correct, but the use
cannot access his or her messages.

Solution
If you modified the settings while your Desktop client was open, close and 
reopen the Desktop Client application so that the settings take effect.

1 Verify the mailbox class.

2 Check the alarm monitor to ensure that there are no alarms relating to the 
IMAP service.

3 Verify network connectivity to CallPilot.
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Symptom - the user has problems sending messages

When the user sends a message, it arrives in the recipient’s Exchange/Out
mailbox, but it does not arrive in the CallPilot message mailbox.

Solution

1 Ensure that when you address the message, you locate the recipient’s 
address in the CallPilot Address Book. If the recipient is defined in your 
Personal Address Book, then ensure that the Personal Address Book entry 
is a CallPilot address. 

2 To ensure that the recipient is defined as a CallPilot Address type, highlight 
the name, click Properties, and verify that the Address Type=CallPilot. 

3 Before you send the message, in the To field, highlight the Recipient, click 
Properties, and verify that the Address Type=CallPilot.

Symptom - the user cannot send messages

The user cannot send messages to telephone, fax, AMIS users, or network
users.

Solution

1 Make sure that the user is addressing the message correctly. See Address 
Formats in the online Help.

2 Ensure that the user has the capability to send messages to telephone, fax, 
AMIS users, and Networking users. 

Security concerns can restrict users from composing messages to these 
types of users.

3 Verify that the RPL in the CallPilot system is configured to allow DTT and 
DTF network messages.

4 For DTT and DTF, ensure that you can dial the number you are trying from 
a phone connected to the same switch as CallPilot.

5 For Networking, verify that networking is currently configured in CallPilot 
administration. For more information on networking, refer to the appropriate 
Networking Implementation and Administration Guide.
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Symptom - the user cannot send a CallPilot message

The user cannot send a CallPilot message. When the user clicks Send, an 
dialog box appears: “Error. Failed to send message.”

Solution checklist (User)

1 Verify that your mailbox is not full. If your mailbox is full, you cannot send 
messages until some messages are deleted.

2 Check the format of the message address.

Note: If the FQDN on the right side of the @ symbol does not match the 
FQDN of the CallPilot server configured to this mailbox, then the message 
is rejected.

3 Verify that no attachment is empty. An empty attachment causes the entire 
message to be rejected. Delete the empty attachment and try sending the 
message again.

4 Contact your CallPilot system administrator.

Solution checklist (Administrator only)

1 Verify that you can ping the CallPilot server. At the DOS prompt, type 

ping <CallPilot FQDN>

2 If the response is “request timed out,” then type

ping <CallPilot server IP address>

Note: If there is a reply, then the CallPilot server FQDN has not been 
properly configured to your Domain Name System (DNS). Contact your 
DNS administrator for assistance.

3 If you do not have a DNS server, then you might require a host file entry. 

4 If there is No Reply, then verify that the CallPilot server is reachable on your 
LAN. Contact your IS administrator for help.

5 Verify that the CallPilot server is up and running.

6 If there is no response, verify that the Internet Message Agent (IMA), 
Message Transfer Agent (MTA), and IMAP services are running. You might 
need to restore them.
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Symptom - non-delivery notification

The user receives non-delivery notifications for messages that her or she se

Solution

1 Verify that you have a valid attachment type.

2 Make sure that your mailbox is not full.

3 Make sure that you are addressing the message correctly. See Address 
Formats in the online Help.

4 Ensure that you are attaching only TIFF-F, VBK, WAV, or TXT files to your 
messages. Desktop Messaging does not accept any other file types.

5 If you are sending to a remote location, verify that the address is valid and 
that it still exists.

6 For fax machines, ensure that the fax number is valid and that the machine 
is accepting faxes.

7 Ensure that you have the capability to dial the number. You can confirm this 
in the Restriction/Permission list. See the Administrator’s Guide.

Note: This is an administrator action only.

8 Verify that the remote server is responding by issuing a network command 
on the CallPilot server. 

Note: This is an administrator action only.

Note: Internet Mail clients cannot send or receive WAV files.

Symptom - "Unknown" in Sender field

In some messages, the user sees a name or phone number in the Sender 
other messages, the user sees “Unknown.”

Meaning
If the caller’s phone system provides a Calling Line ID, then it appears in th
Sender field for messages that are created when people phone you and yo
not available. However, if this information is not provided, then it appears as
“Unknown.”
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For messages that are sent from people using Networking, if the sender’s n
is not provided to the CallPilot system, then the Sender field appears as 
“Unknown.”

Symptom - the user has problems with faxing

Users cannot preview, view, or send faxes.

Meaning
Imaging for Windows is not installed.

You require Imaging for Window to view and compose faxes. During 
installation, CallPilot checks for Imaging for Windows. If it is not installed, 
CallPilot is still installed successfully. You can install the imaging software la

Solution

1 To install Imaging for Windows, from the Windows Start menu, select 
Settings > Control Panel > Add/Remove Programs.

2 Click the Windows Setup tab.

3 Highlight and double-click Accessories.

4 Scroll down the list, and ensure that Imaging is checked. 

5 Click OK to return to the Control Panel.

Note: If Imaging for Windows is not installed on your PC, you can install it 
from the CallPilot Desktop Messaging CD.

6 If the error message states that the message cannot be sent because part 
of the media cannot be converted, or because the media is not supported 
at the recipient’s system, ensure that in messages sent using CallPilot 
Desktop Messaging, you only send attachments that are TIFF-F, WAV, 
VBK, or text files. 

7 Ensure that you, as the sender, and the recipients have the capability to 
send and receive fax (TIFF-F) messages. Also, ensure that all TIFF files are 
TIFF-F files created using the Nortel Fax Printer. Not all TIFF files are class 
F.

8 Ensure that your mailbox is not full. When you log on to the Desktop 
Messaging session or when you log on using the telephone, if you receive 
the error message that your mailbox is full, then you cannot send any 
messages until you delete messages to create space in your mailbox.
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9 If messages are not returned with an NDN, then check the CallPilot server 
processor usage. If it is at or near 100 percent for a long time, then contact 
your Nortel Networks Customer Technical Support.

Symptom - the user has problems with fax reception

People do not receive faxes sent by the user, or the user does not receive f
that others are sending to him or her.

Solution

� Verify that the mailbox class to which the user is assigned has the capa
to send and receive faxes. 

� Make sure that those to whom you send faxes have the capability to rec
faxes. For more information, refer to the Desktop Messaging Quick 
Reference Guide.

Symptom - the user has problems with receiving replies

Recipients can see the user’s CallPilot messages and people receive the 
messages that the user sends, but the user does not get any of the replies t
her messages.

Solution

1 From the Actions menu, select CallPilot Configuration. 

2 Click Properties. 

3 Ensure that the SMTP/VPIM prefix is specified correctly.

Ensure that if people are sending you faxes (TIFF files) in their replies, you h
the capability to receive TIFF files.

Symptom - the user cannot print text messages

Users can see text messages in their Desktop mailbox, but when they acce
them from their mailbox using the telephone and try to print them to a fax 
machine, they see the message, “Your command cannot be completed at th
time.”
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Solution
The current configuration of the user’s CallPilot mailbox only allows him or h
to access text messages from the desktop and does not allow him or her to
the telephone-based mailbox. If he or she wants to print these faxes to a fa
machine through the mailbox, you must add Fax capability to the user’s mai
class. See the Administrator’s Guide.

Symptom - deleting messages from CallPilot

When a user deletes messages using CallPilot Desktop Messaging, the me
are still in the user’s mailbox when he or she accesses the mailbox using th
telephone.

Solution
If the messages that you delete on the Desktop are still located in a Deleted
Items Folder in your CallPilot Message Store, then they remain in your CallP
mailbox. Therefore, you still have these messages when you access them f
the telephone. To remove the messages from both mailboxes, you must 
permanently delete them from the Deleted Items folder.

Symptom - deleting messages from the Desktop client

The user cannot delete his or her messages. When the user selects to dele
messages permanently, nothing happens.

Solution
If the user is using CallPilot Desktop Messaging to delete these messages a
or she is also logged on to the mailbox with the telephone, then he or she c
delete messages using CallPilot Desktop Messaging. 

End the Telephone Mailbox session, and then attempt to delete the messag
from Desktop again.

Symptom - messages no longer on server

Error message: “This message could not be found on the server. Messages
exist on the server in order to be played via the telephone. Use computer to
this file. Port failed.”
164 CallPilot



May 2000 Troubleshooting

 no 

 

new 

cy as 
Solution
Voice messages that have been saved to the user’s computer hard drive are
longer in the user’s CallPilot Inbox. As a result, the user cannot play these 
messages from the telephone. 

To listen to these messages, the user must use the computer speakers or 
headphones.

Symptom - voice message does not play on telephone

The user plays a voice message from the telephone. The user answers the
telephone when it rings but the message does not play.

Solution

1 When you answer the telephone, say something, such as “Hello,” to initiate 
message playback.

2 Check the CallPilot player status bar. If it states Open Pending, then hang 
up the telephone. Click Computer on the player, and then click telset 
playback. The phone rings again.

3 If the Status bar still says Open Pending, then hang up again and wait three 
to five minutes and attempt to play again. If this problem persists, contact 
your Nortel Networks Customer Technical Support.

Symptom - message waiting indicator active but no new message

The user’s telephone message waiting indicator is activated but there is no 
message in the user’s Desktop Inbox.

Solution
Messages are downloaded from the CallPilot server with the same frequen
e-mail messages (this applies only to Lotus Notes users). 

1 To adjust the frequency, from the File menu, select Tools > User 
Preferences > Mail, and change the Check for mail every __ minutes 
setting.

2 To have an immediate download, from the Actions menu, select Refresh 
CallPilot Message List.
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Troubleshooting installation problems for Web 
Messaging

Introduction

All IMAP errors and CallPilot Web Messaging errors are logged on the web
server’s Event Log and can be viewed using the Event Viewer. If you are 
unfamiliar with the Microsoft IIS server and its operation, contact your IS 
administrator to assist you in troubleshooting CallPilot Web Messaging.

Symptom - installation problems

The desktop user sees a blank screen if CallPilot Web Messaging’s virtual 
directory is not set up as an application virtual directory.

Solution (Administrator action only)

1 Select the Properties section of the virtual directory, and click the Make 
Application button.

2 Ensure that the CallPilot server can be pinged from the web server by using 
either CallPilot’s IP address or its fully qualified domain name (whichever is 
used as the IMAP server registry entry).

3 Ensure that the COM control is registered. Search the registry for 
CPWMCTRL.

During installation, setup attempts to register the file CPWMCTRL.DLL, 
which is found in the CallPilot Web Messaging directory specified during 
installation. 

a. Verify that Nortel.CPWMCtrl.001 has been inserted into the registry 
and is associated with the CPWMCTRL.DLL file in the correct directory. 
Use a registry search tool to verify this. 
166 CallPilot



May 2000 Troubleshooting

 

b. If the file is not properly registered, you can register it manually using 
regsvr32.exe, which is found in the Windows system directory.

The host name of the CallPilot IMAP server is installed at the following 
location in the WinNT registry:

HKEY_LOCAL_MACHINE\SOFTWARE\Nortel\CallPilot\WebClient\ 
IMAPServer

c. Ensure that this attribute is set correctly to the host name of the 
CallPilot IMAP server. The host name must be fully qualified if it is on 
another domain.

Symptom - Web server problems 

The IIS server reports serious problems in the WinNT Error Log. 

Solution (Administrator action only)
From the IIS server, do the following:

1 From the Windows menu, click Start > Administrative Tools > Error & Event 
Log. 

2 Check both the System and Application logs.

Symptom - logon problems

Error message: “Error. Login failed.” Failure to log on can result from either
CallPilot Web Messaging problems or CallPilot problems.

Solution (Administrator action only)

1 Verify that IMAP is enabled on the CallPilot Administration Client.

2 Verify all items under Symptom: Installation problems.

3 Ensure that Desktop capability is enabled on the user’s CallPilot mailbox.

4 Check the Event Log on the web server.

5 Check the registry values to ensure that the web server points to the correct 
CallPilot server.

6 Try logging on using another CallPilot client, such as the Microsoft 
Exchange, Microsoft Outlook, Lotus Notes, Outlook Express, or Netscape 
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Messenger client. If this other client fails, then the problem is with CallPilot. 
If it succeeds, the problem is with CallPilot Web Messaging.

7 You can further analyze the problem as follows: if you can log on from the 
telephone but not through any of the Desktop clients, the problem can be 
related to the CallPilot IMAP server on the CallPilot system. 

In this case, follow CallPilot troubleshooting procedures for IMAP/Desktop 
messaging. For example, you might need to stop and restart the IMAP 
server on the CallPilot system using the Windows NT Service Control 
Panel. 

8 Make sure that CallPilot Desktop Messaging is not in use by any CallPilot 
users. When you stop the IMAP service, it ends all Desktop sessions and 
require users to log on again.

9 If you identify the problem with CallPilot Web Messaging, check that this 
application is installed correctly. In particular, ensure that the IMAP server 
attribute is set correctly.

10 If the CallPilot IMAP service is down and users try to log on, they do not 
receive a message telling them that the server is down. Instead, they 
receive the following message: 

Login failed, please try again.

Symptom - browser problems

The web browser does not work properly. 

The CallPilot Web Messaging client checks to see whether the user’s brows
has JavaScript and Cookies enabled. The user can experience problems if 
unsupported plug-in attempts to play the WAV voice files or view the TIFF-F 
messages. During run time, CallPilot Web Messaging checks for the existen
known unsupported plug-ins. You must disable unsupported plug-ins. 

The Quicktime and LiveAudio plug-ins are supported only on versions of 
Netscape Navigator 4.7 and later.

Netscape Navigator is often installed with its own plug-ins. The CallPilot We
Messaging client might not be able to play voice messages or view fax mess
if some of these plug-ins are installed.
168 CallPilot



May 2000 Troubleshooting

r 
s to 
ta’s 
Solution
If you encounter problems, verify which plug-ins are installed:

� See the Help menu > About Plug-ins.

or

� From the Start menu, click > Settings > Control Panel > Add/Remove 
Programs.

Remove the plug-in that is causing the problem.

Symptom - playing and viewing messages (MIME-type applications)

There are problems with playing or viewing messages.

Applications that are associated with a MIME type are those used to play o
view data of the MIME type. Ensure that the applications that the user want
use to play or view the data is the application that is associated with that da
MIME type.

Note: Internet Explorer uses the Windows file associations. 

Solution

1 To view and edit these associations, select Windows Explorer > View > 
Folder Options... > File Types.

2 Netscape Navigator first checks its own associations. To view these 
associations, open Netscape, and then click Edit > Preferences... > 
Applications.

Note: Users require version 6.01 or later of the Microsoft Media Player if 
they want to play voice messages in WAV format.

Data MIME type

CallPilot VBK audio/x-nortel-vbk

CallPilot TIFF image/tiff

WAV audio/x-wav
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Symptom - playing and viewing messages (Plug-ins)

There are problems with playing or viewing messages. 

Some users can have plug-ins installed that attempt to play or view data of 
MIME type audio/x-wav and imaging/tiff. You might need to disable these pl
ins.

Note: Popular unsupported plug-ins are Quicktime and LiveAudio on versio
of Netscape Navigator earlier than 4.5.

Fax messages read using the web client still appear as new fax messages 
the user changes to the phoneset.

Solution

1 To view and edit these fax message, select Windows Explorer > View > 
Folder Options... > File Types.

2 Netscape Navigator first checks its own associations. To view these 
associations, open Netscape, and then select Edit > Preferences... > 
Applications.

Note: Users require version 6.01 or later of the Microsoft Media Player if 
they want to play voice messages in WAV format.

Symptom - access permissions

All browsers must be able to access the CallPilot Web Messaging files and 
directories on the web server. The web server runs each client connection a
is a local user. The particular local user that the web server uses is configur
IIS admin. 

Solution
You must ensure that all files and directories have the appropriate access 
privileges for this user. 

To determine the IIS user for access control purposes, see the instructions 
your version of IIS.
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1 Start IIS admin.

2 Select the web site that contains the CallPilot Web Messaging virtual 
directory from the IIS tree view. 

Note: The default is Default web site.

3 Right-click the site, and select Properties > Directory security tab. 

4 Under Anonymous Access and Authentication Control, click Edit. 

5 Ensure that the Allow Anonymous Access check box is selected.

6 Select Edit to view the UserID.

In addition to the files in the CallPilot Web Messaging directory, certain syst
files must be accessible from the application. A standard CallPilot Web 
Messaging install on a clean NT Server platform has all the necessary 
permissions set up properly.

If you suspect that there might be additional file permission problems, a 
procedure for checking this is described in the Microsoft Knowledge Base, 
article Q16133. 

Symptom - reply to message is rejected on AMIS network (Eudora Pro 
only)

A reply to a message cannot be sent over an AMIS network. This is caused
autotext placed at the start of the message.

Solution (for the Administrator)

1 Open the Eudora.ini file using a text editor such as Notepad.

2 Under the [Settings] statement, add these lines:

ReplyAllAttribution=

ReplyAttribution=

3 Click File > Save to save the settings.
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Accessing Desktop Messaging online Help

Introduction

Desktop Messaging for Microsoft Exchange/Outlook, Novell GroupWise, an
Lotus Notes provides standard online Help.

Note: Internet Mail client online Help is accessed from the Administration 
online Help by going to Messaging Administration > Internet Mail Client 
Administration. Internet Mail client online Help is limited to help involving the
CallPilot interface. Use the manufacturer’s online Help for queries relating to
Internet Mail product.

To access online Help

Microsoft Exchange/Outlook

From your Inbox, on the Help menu, select CallPilot Desktop Messaging Help.

Novell GroupWise

From your Inbox, on the Help menu, select CallPilot Desktop Messaging Help.

Lotus Notes

From your Inbox, on the Actions menu, select CallPilot Help Topics.
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Using the CallPilot Desktop Support Tools

Reset CallPilot message store (for Microsoft Exchange/Outlook 
clients only)

This feature is only available for users of the Microsoft Exchange and Micro
Outlook client. It is useful to remove invalid or corrupt messages from the in

The Lotus Notes and GroupWise clients can reset their mailboxes by choos
the Refresh CallPilot Message List option.

Outlook 97

1 Press Ctrl + Shift.

2 Select Tools > Check for New Mail.

Microsoft Outlook 98, 2000

1 Press Ctrl + Shift.

2 From the toolbar, select Send and Receive, or from the Tools menu, select 
Send and Receive > CallPilot Transport.

3 Continue to hold down Ctrl + Shift, until the following dialog box appears:

4 Select Reset Mailbox. 

All CallPilot messages are purged from the user's mailbox, and the CallPilot 
message headers currently stored on the CallPilot server for that user are 
downloaded again. The user sees all messages disappear and then 
reappear one by one. All message caching is lost. 

Note: The messages are not deleted from the CallPilot server; they are 
removed from the Client PC cache. Messages are downloaded again from 
the CallPilot server to the Client PC.
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This feature is intended for system administrators and CallPilot product 
support.

CPTrace

The CPTrace utility has been available since CallPilot 1.0. CPTrace is insta
with each desktop client in the \Program Files\Nortel\<client directory> as 
specified below:

CPTrace allows users, developers, and support personnel to collect informa
about a problem occurring with one of the desktop clients. Problems includ

� trouble connecting to the CallPilot server

� player problems

� address book problems 

� message compose, reply, forward, delete, notification

Save the data to disk and analyze it to determine the cause of the problem.

Note: Running CPTrace affects the dynamics of the CallPilot client. You mig
not be able to reproduce problems while CPTrace is running. This is an 
uncommon occurrence.

The CallPilot 1.07 version of CPTrace replaces the previous CPTrace tool, 
well as the logging interface provided in the 1.0 and 1.06 versions of the 
Exchange/Outlook client.

Desktop client Directory

Microsoft Exchange/Outlook nmdc

Lotus Notes nmln

GroupWise nmgw
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All options are stored in the Windows registry; therefore, every time you run
utility, the existing settings are used.
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Options

To close CPTrace, click the close button (X) in the upper right corner of the 

When you close CPTrace with the File check box selected, the client contin
to write debug information to the file selected. This slows down the client 
operation slightly. The file never gets larger than 1Mbyte. When the file size
does grow to 1Mbyte, 10 percent of the file is purged. The oldest data is 
removed. 

If you select Save to File and CPTrace is closed, you receive a dialog box 
warning that File tracing is still enabled and asking if you want to turn off 
tracing. 

Buttons or box Function

IMAP/SMTP Log all IMAP/SMTP traffic.

Desktop client Log internal Exchange/Outlook, Lotus Notes, and 
Groupwise traffic.

Audio player Log Audio player traffic.

File Write logs to a file. 

Note: Trace statements continue to be written to the lo
file even if the CPTrace utility is shut down.

Window Write logs to the display window.

Erase Empty the log file.

Clear Clear the display Window.

Save A Save As dialog appears allowing the user to save t
trace to a file.

Always on top Always keep the CPTrace tool on top of other window
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network shortcut
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