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Installing and Using the lomega Ditto™ External Tape Drive
for OS/2-Based Systems

This note provides information on the requirements for installing and configuring the
lomega Ditto™ external tape drive for the messaging systems running under OS/2 Warp.
The steps in this note help you:

* Install the tape drive hardware
* Install the tape drive software
« Select the files to be backed up

« Configure the messaging system software to automatically backup the selected
files

Backed up files are stored on the tape cassette. Refer to the Ditto Tape Systems User’s
Guide for information on re-installing compressed files.

Notes:

You should not back up messaging systems files while the messaging software is running.
Be sure to properly shut down the messaging system before instituting any type of backup
procedure, including tape formatting.

Make sure you insert a tape cartridge into the Ditto tape drive before attempting to
perform a backup.

Ditto Tape Drive Components
The Ditto tape drive includes the following components:

- Ditto external tape drive

e Ditto Tools backup software

e External power supply

e Parallel port cable (cable with 25-pin connectors)

e Tape cartridge
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INSTALLING THE DITTO™ TAPE DRIVE FOR OS/2 SYSTEMS

Connecting the Ditto Tape Drive Hardware

The following procedure outlines the general steps for connecting the Ditto tape drive in
the computer.

To install the tape backup hardware:

1.
2.

Shut down the messaging system and turn off the computer.
If a printer is currently attached to the sentinel on the PC’s parallel port, unplug it.

Connect the female end of the parallel cable to the Ditto 25-pin connector (has a PC
icon below it).

Connect the male end of the parallel cable to the sentinel on the messaging system
PC'’s parallel port.

If a printer was connected to the messaging system, plug the printer cable into the
Ditto drives parallel port (has a printer icon below it).

Connect the external power supply to the tape drive and plug the other end into an
electrical outlet. When the Ditto drive is first plugged in, the tape drive activity light
(small LED on the far right of the front of the drive) flashes and turns off. The power
light (small LED to the left of the activity light) stays on.

For best results, position the Ditto tape drive at least 10 inches (25 cm) from the
messaging system PC monitor.

Turn on the messaging system PC.

Installing the Tape Backup Software on OS/2 Systems

Follow the steps in the procedure below to install and configure the BackMaster software
on systems using OS/2. For additional information, refer to the BackMaster User
Reference Manual.

To install the tape backup software on OS/2 Systems:

1.

2
3.
4

If the messaging system is running, select Exit from the File menu to shut it down.
Insert the BackMaster installation disk in the disk drive.
Open an OS/2 window.

At the command prompt, type A: and press <ENTER>. The A: prompt displays.
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INSTALLING THE DITTO™ TAPE DRIVE FOR OS/2 SYSTEMS

5. From the A: prompt, type | NSTALL and press <ENTER>. You are prompted to wait
while the system loads the necessary files. Once the files are loaded, the Instructions
dialog box displays.

- 5|
[~

P#elcome to BackMaster 3.0 for 05/2

The following windows will guide you through the installation of
BackMaster 3.0. See the README.TKT on the first diskette for more
information.

Select Continue to start the installation. Select Exit to stop the
installation.

| Continue I | Cancel |

6. Click Continue. The Install dialog box displays.
Boma

BackMaster 3.0
Product number: MSR_BM3_1
Yersion: 00.30.14
Feature: MSR Driver Rey. 2.3

Install this product?

| 0K I |Cancel| | Help |

7. Click OK. The Install-Directories dialog box displays.

Select the components that you want to install:

BackMaster Installation Utility =
BackMaster 3.0 Tape Backup Software =

BackMaster Scheduler 1.2
Optional SCSI Tape Drive Support Deselect all

[]
[ [
Bytes needed: 2,450,000

Enter the directories where you want to install the
components. These directories will be created if they do not
already exist.

Installation directory C:\BACKMAST &

|jnstall... I | Disk space... | | Cancel | | Help |

8. Under Select the components that you want to install, select BackMaster 3.xx Tape
Backup Software. The amount of disk space required for installation is displayed next
to Bytes needed. You can click Disk space to verify that there is sufficient disk space
available on the target drive.

9. Leave the installation directory at the default C\BACKMAST.

10. Click Install.

11. When prompted, remove the installation disk and insert diskette 2 in the disk drive. If

you used a disk drive other than A:, specify the appropriate drive letter in the Drive
field.
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INSTALLING THE DITTO™ TAPE DRIVE FOR OS/2 SYSTEMS

12.

13.

14.

15.
16.
17.
18.
19.

20.

21.

Click Continue. You are prompted to wait while the system unpacks the required files.
The BackMaster Installation dialog box displays.

F4 BackMaster 3.0 - Installation

~Use mouse or keyboard to choose options. Select OK to start.——

Tape drive configuration

[ Internal/ floppy tape driver

[] Parallelfexternal port tape driver

[_1 Trakker tape driver

CUROE Yane defusy

|| Device driver memory enhancement [required for
8mb machines]

| Ok I |Qefault| |§ancel| | Help |

Enable Parallel/external port tape driver and disable all other options.

If the messaging system PC has only 8 MB RAM installed, also enable the Device
driver memory enhancement option.

Click OK. The BackMaster Configuration Complete dialog box displays.

£ BackMaster - Configuration Complete

Configuration is complete. CONFIG.SYS
has been modified, a copy of the original
has been saved to the directory in which
BackMaster was installed.

It will be necessary to close all
applications, shutdown the system and
reboot before using BackMaster.

Click OK. The Installation and Maintenance dialog box displays.

Click OK. The OS/2 window displays.
To close the OS/2 window, type EXI T then press <ENTER>.
Remove the disk from the disk drive.

Close any open applications and windows, then select Shutdown from the LaunchPad
and follow the onscreen prompts to reboot the PC.

Once the PC reboots and the OS/2 desktop displays, shut down the messaging
system if it is configured to launch automatically on bootup.

Insert a blank tape cartridge in the Ditto tape drive.
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22. Open the BackMaster program by opening the BackMaster folder and double-clicking
the BackMaster program icon. The Configuration Options notebook displays the
Device tab the first time you open BackMaster.

BIE]

s BackMaster 3.0 - Configuration Options

Selected device
Parallel Pord H | Test | Backup
Check the settings on the following pages Restore

[Floppy, Parallel, or 5CSI] for the selected
device and use the TEST button to verify
that the device is configured correctly.
Please contact MSR Development Technical
Support for current information about tape
drives supported or if you are having
problems operating a tape drive.

O
|

Device

Floppy

na}tended

Enable time critical

ok | | Undo | | Default| | Help |

- Go

Errors

Custom

:ﬁ
:ﬁ
:ﬁ
:ﬁ
:ﬁ
:ﬁ
:ﬁ
:ﬁ
:ﬁ
:ﬁ
:ﬁ
:ﬁ
:ﬁ
=
:ﬁ

23. Verify that the Selected device field displays Parallel Port and verify that the Enable

time critical box is unchecked.

24. Click Test to verify that the device is configured correctly.
25. When the message displays that the tape drive was successfully detected, click OK.
26. Click the Parallel tab to display the Parallel page.
BackMaster 3.0 - Configuration Options [ [
Backup
Parallel port tape drive configuration Restore
Device
Control delay Data delay Floppy
E s e Parallel

Transfer speed
300k 1M ()2M

Unattended

Errors |

| ok | | Undo | Default| | Hetp |

=[]

Custom |

e o o e e

27. Leave Transfer Speed at the default, Automatic, and click OK.

28. Click the Unattended tab to display the Unattended page.

== BackMaster 3.0 - Configuration Options [ [

:ﬁ

= 96852 AM 11-09-1998 Backup

3 Restore

=3 hour minute Device

®) AM =

% EIE O PM Floppy
month  day year Parallel

:ﬁ

3 (11 | o [# 1998 [ Scsl

= [_1 Enable unattended Unattended

:|_:l Errors

= Undo Default Help Custom

=
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INSTALLING THE DITTO™ TAPE DRIVE FOR OS/2 SYSTEMS

29. Verify that the Enable Unattended box is unchecked, then click the Errors tab to
display the Errors page.

BackMaster 3.0 - Configuration Options

BIE]

Backup

Error retry count E
Locked retry count E
Logfile size [Kbytes] E

[_1Error prompting enabled
[+/1 Error logging enabled
[_] Abbreviated message log

Restore

Device
Floppy
Parallel
5CS1
Unattended

Errors |

0

1 g e e e o

{L

I | Undo | |Qefault| | Help | ustom |

30. Leave the values for Error retry count, Locked retry count, and Logfile size values at
the defaults. Disable the Error Prompting Enabled and Abbreviated Message Log
boxes and verify that the Error Logging Enabled box is checked.

31. To accept your selections and exit the Configuration Options notebook, click OK. The
BackMaster main window displays.

Selecting Files for Tape Backup

The steps for selecting the directories and files that comprise an effective messaging
system backup are detailed below.

To select files for backup:
1. Access the BackMaster main window, if it is not currently displayed.
2. From the Backup menu, choose Selective.

3. Inthe Drives field, select the letter of the drive(s) containing messaging system files.
Click OK. The Selection Window displays.

4. Click the + sign to display the subdirectories on the root drive you selected.

5. Select the subdirectories you want to back up by clicking the directory then pressing
<SPACEBAR> to check it. You can use the up and down arrows to scroll through the
directory tree. Select the following directories:

« CVR

« CVR1

« RECO00 through REC09

*  FAXO00 through FAX09

« BACKUP1 through BACKUP5

If a + appears next to any of the directories listed above, that indicates that there are
subdirectories present. If you do not want the subdirectories backed up, click the +
sign next to the main directory that contains the subdirectories, then for each
subdirectory that you do not want backed up, click the subdirectory and press
<SPACEBAR> to remove the check.
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10.

11.

12.

13.

14.

15.

Highlight the drive icon at the top of the tree, and click the - sign to close the
subdirectories.

Press <ENTER> to open a box containing the files on the root drive you selected.

Select the following files by highlighting them using the arrow keys then pressing the
<SPACEBAR>. Select the messaging system files and the Dialogic files for the voice
board(s) in the system.

Some of the files listed below are not available on all systems.

System Files: Dialogic Files:

AUTOEXEC.BAT D12X.FWL GENBOOT.BIN
BFAX.SYS D42NS.FWL GENBOOT.FWL
BTLIB.CFG D42SL.FWL GENLOAD.SYS
BT_CPARM.CFG D42SX.FWL OCTEL.PRM
CONFIG.SYS D4AX.FWL

FAXINIT.EXE D4XDNLD.EXE

FIRMWARE.EXE D8X.FWL

IBMPCPS.FZ8 DIALOGIC.CFG

STARTUP.CMD DXXXDRV.SYS

TR114.PEX

Press <ESC> to close the file contents box.

From the Backup menu, select Save file selections. The File Selection Set-Save As
dialog box displays.

In the Save as filename field, type TAPE.FSS.
Click OK.

If you want to run a manual backup at this time, select Start backup from the Backup
menu. If you do not want to run a backup now, select Cancel Backup from the Backup
menu, then click Yes.

To close the BackMaster program, double-click the icon in the top-left corner of the
BackMaster main window.

To close the BackMaster folder, double-click the icon in the top left corner of the folder
window.

Setting Up the System for Automatic Backups

The following three procedures contain the steps for configuring the messaging system to
run automatic tape backup during the software’s maintenance routine.

The configuration process consists of three general steps:

Creating a .CMD file to initiate the backup
Modifying RUNVM.CMD to indicate when to run the backup

Adjusting System Setup to allow the backup to run
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To create an TAPE.CMD file to run backup:

1.
2.

Open an OS/2 window.

Change to the BACKMAST directory by typing CD \ BACKMAST and pressing
<ENTER>.

Open the OS/2 editor by typing E and pressing <ENTER>.

Type the following in the editor window:

C.

CD\ BACKMAST

BACKMAST / QE

BACKMAST /BS:"XXX BACKUP” C:\BACKMAST\FSS\TAPE.FSS
CD\CVR

Where C: is the drive on which the system is installed.

From the File pull-down menu, select Save. The Save As dialog box displays. In the
Save as filename field, type TAPE.CMD.

Click the Type... button. The Type dialog box displays. Select 0S/2 Command File
from the scroll list. To close the Type dialog box click Set.

To close the Save as box, click Save.

To close the OS/2 editor and return to the OS/2 window, double-click the icon in the
top-left corner of the editor box.

Test the TAPE.CMD file you just created by shutting down the messaging system,
then running the TAPE.CMD file by typing TAPE.CMD at the \BACKMAST prompt
and pressing <ENTER>. The BackMaster screen displays and the tape backup
system performs a backup. Once the backup is complete, the program automatically
verifies that all of the files were backed up.

To indicate the day(s) to run automatic tape backup:

1.

At the BACKMAST directory prompt, change to the root directory by typing CD..
and pressing <ENTER>. To change to the CVR directory, type CD CVR then press
<ENTER>.

To edit the RUNVM.CMD file, type E RUNVM.CMD and press <ENTER>.

Locate the line ECHO TODAY IS XXXXXXX line, where XXXXXXX is the name of
the day when you want to run the backup.

Press <End> to move the cursor to the end of the line, then press <ENTER> to start a
new line.

With the cursor at the start of the new line, type the following:

CALL X:\BACKMAST\TAPE.CMD

where X is the drive on which the BackMaster software is installed.

To save the file, select Save from the File menu.

To exit the editor and return to the OS/2 window, double-click the icon in the top-left
corner of the editor window.

To close the OS/2 window, type EXIT at the prompt and press <ENTER>.
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To configure the messaging system for automatic backups:

1. Open the messaging system folder on the OS/2 desktop by double-clicking the folder
icon.

2. Double-click the messaging system program icon.
3. Under the File menu, select Password. The Supervisor Password dialog box displays.

4. Enter the level 3 password in the field and press <ENTER>. Click OK to close the
password accepted dialog box.

5. Under the Options menu, select System Setup. The System Setup General
Parameter tab displays.

6. Highlight Daily Maintenance Time. This is the time when the system runs system
maintenance and backs up the system files. Enter a number between 0 and 23
(midnight and 11:00 PM, respectively).

7. Click Shutdown System after Daily Maintenance to enable it.
8. To save the System Setup, select Save from the File menu.

9. To close System Setup and return to the System Manager window, select Exit from
the File menu.

10. Log off the system by selecting Logoff from the File menu.

Be advised that if a tape is not inserted into the tape backup drive, or if the tape that is
inserted is not operational (is a “bad” tape), the automated attendant/voice mail system
will not restart as it should after the system shuts down to perform daily maintenance.
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Notes:
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