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Chapter 1
How to get Help

This section explains how to get help for Nortel products and services.

Getting Help from the Nortel Web site
The best way to get technical support for Nortel products is from the Nortel
Technical Support Web site:

www.nortel.com/support

This site provides quick access to software, documentation, bulletins, and
tools to address issues with Nortel products. More specifically, with the
site, you can:

• download software, documentation, and product bulletins

• search the Technical Support Web site and the Nortel Knowledge Base
for answers to technical issues

• sign up for automatic notification of new software and documentation
for Nortel equipment

• open and manage technical support cases

Getting Help over the phone from a Nortel Solutions Center
If you don’t find the information you require on the Nortel Technical Support
Web site, and have a Nortel support contract, you can also get help over the
phone from a Nortel Solutions Center.

In North America, call 1-800-4NORTEL (1-800-466-7835).

Outside North America, go to the following Web site to obtain the phone
number for your region:

www.nortel.com/callus
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Getting Help from a specialist by using an Express Routing Code
To access some Nortel Technical Solutions Centers, you can use an Express
Routing Code (ERC) to quickly route your call to a specialist in your Nortel
product or service. To locate the ERC for your product or service, go to:

www.nortel.com/erc

Getting Help through a Nortel distributor or reseller
If you purchased a service contract for your Nortel product from a distributor
or authorized reseller, contact the technical support staff for that distributor
or reseller.
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Chapter 2
Introduction to Application Builder

In this chapter
"What is Application Builder?" (page 13)

"How Application Builder works" (page 15)

"A comparison of Application Builder and Meridian Mail Voice Services"
(page 16)

"About this guide" (page 18)

"CallPilot online Help and documentation" (page 19)

What is Application Builder?
Application Builder is a graphical program that you use to create CallPilot*
applications that callers access as dialable services. With Application
Builder, you can

• specify the call functions that you want to include in an application, such
as menus, announcements, and transfers

• design the call flow (the path calls follow) in an application

In Application Builder, applications are represented by a series of blocks
connected by lines. With this graphical display, you can easily follow the
call flow.

What is an application?
An application is a set of functions (such as announcements, menus, and
transfers) that determines the way CallPilot treats a call. When a CallPilot
system receives a call, an application handles the call flow.
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14 Chapter 2 Introduction to Application Builder

Application example
The automated attendant application is a typical application. This application
greets callers to the organization and can transfer them to a department or
to a specific individual. For example, an automated attendant can contain
the following menu:

Thank you for calling SuperValue Grocery. Please choose one of the
following four options, or remain on the line for assistance.
If you know the extension of the person you want to reach, press 1.
To access our company directory, press 2.
To reach our Bakery Department, press 3.
To reach our Deli Department, press 4.

An automated attendant can handle calls differently depending on the day
of the week or the time of day.

The following illustration shows the call flow for the automated attendant
example:

Fax options
If your CallPilot system includes fax messaging, you can include fax
functions in your CallPilot applications.

Example
A caller wants to find out the location of ABC Company. One of the options
in the ABC menu is "To receive a fax showing our location, press 4."
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When the caller presses 4, the following prompt plays: "Map of ABC
Company’s location."

The application prompts the caller for the fax number to which the map
can be sent.

Benefits of Application Builder
Application Builder provides the following benefits:

• With Application Builder, you can plan your CallPilot services online
rather than on paper.

• Application Builder provides a simple graphical interface for adding
functions to the application and connecting functions to create the call
flow.

You drag functions (blocks) from the palette into the application window.
Then, you click the mouse on the source and destination functions to
connect the blocks and create the call flow.

• With Application Builder, you can record voice items while you create
your application.

After you create a new voice item, such as a menu or an announcement,
the application prompts you to record the new voice item.

• Application Builder shows the call flow graphically.

The application window shows you, at a glance, how calls are handled
by the system.

• With Application Builder, you can import an application into other
applications. You can save a group of functions that you want to share
among multiple applications.

For example, you can have several applications that provide the same
handling for calls arriving after hours. If so, you can create an application
named After_Hours, and import it into all applications that use that
handling. If you change the After_Hours application, the changes are
automatically reflected in all parent applications.

How Application Builder works
With Application Builder, you can graphically create your applications.
You select the required call functions (blocks) from palettes. You arrange
blocks in the desired call flow sequence, and then create the connections
between the blocks.

Location of the application
When you work on an application, Application Builder stores a copy of the
application on your local computer. When you save it, Application Builder
transfers a copy of the application to the server.
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Application Builder only permits one administrator at a time to access a
given application. This ensures that changes that one administrator makes
are not accidentally overwritten by another administrator.

When you open an application, Application Builder locks it on the server
to prevent others from accessing it. When you close the application,
Application Builder unlocks the application. For more information about how
Application Builder stores applications, see Chapter 9 "Saving applications"
(page 117).

Connected callers
Callers can be connected to an application while you change it. When
you save your changes, any connected callers continue to interact with
the previous version of the application. New callers interact with the new
version.

A comparison of Application Builder and Meridian Mail Voice
Services

Meridian Mail* Voice Services, like Application Builder, creates services that
callers dial. However, Meridian Mail Voice Services is packaged differently
than Application Builder, and it uses different terminology. In Application
Builder, these services are named applications; in Meridian Mail Voice
Services, they are known as voice services.

Controllers and blocks
In Meridian Mail Voice Services, controllers are added to voice services and
functions. Controllers perform the same role as blocks in Application Builder.

Voice recordings
Meridian Mail Voice Services and Application Builder classify voice
recordings differently.

Meridian Mail
Meridian Mail Voice Services uses two types of voice recordings:

• prompts--You can use a prompt only once.

• announcements--You can use an announcement as many times as
needed.

Application Builder
Application Builder classifies voice recordings as

• system prompts--Any prerecorded voice prompt that comes with the
system. "Transferring to an attendant" is an example of a system prompt.

• voice item--A custom recording that you or someone else creates.
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You can use both system prompts and voice items as many times as you
want. Therefore, you do not need to re-record voice items.

Making applications available to callers
In Meridian Mail Voice Services, callers can dial voice services after you
add the services to the Voice Service Directory Number (VSDN) Table. In
Application Builder, applications become services after you add them to
the SDN Table.

Interfaces
The interfaces of Application Builder and Meridian Mail Voice Services are
very different. Application Builder uses a graphical interface, and Meridian
Mail Voice Services uses a command-line interface.

Meridian Mail Voice Services interface
To create a menu in Meridian Mail Voice Services, you use the three parts
of the Add a Voice Menu Definition screen.

Application Builder interface
To create a menu in Application Builder, you use the application window.
You can drag blocks from the palette into the window, and use the mouse to
create connections between the blocks.
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About this guide
This guide helps you to plan, design, manage, implement, and troubleshoot
your applications. It focuses on explaining how Application Builder works,
and provides examples and lessons that you can use to build your own
applications.

Some chapters are divided into two sections:

• Section A provides overview information about using Application Builder,
including planning considerations, design guidelines, and requirements.

• Section B provides a lesson that guides you through the process of
developing an application. Each lesson builds on the lesson in the
previous chapter.
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CallPilot online Help and documentation
CallPilot online Help and documentation incorporate the following:

• CallPilot Manager online Help is the primary source of procedural
information.

• This Application Builder Guide (NN44200-102) is available only in PDF
format.

This guide assumes that

• the CallPilot server is correctly installed and is operational

• the switch is installed and provisioned to support your CallPilot system

If the CallPilot server is not installed, install it before proceeding. For
installation instructions, refer to the Installation and Configuration Task List
(NN44200-306) and the Server Installation Guide for your server.

CallPilot technical documents are stored on the CallPilot documentation
CD that you receive with your system. The documents are also available
from the following sources:

• CallPilot Manager

• My CallPilot

• the Nortel Partner Information Center (PIC) at
www.nortel.com/pic

You require a user ID and password to access the PIC. If you do not
have a PIC account, click Register to request an account. It can take up
to 72 hours to process your account request.

You can print part or all of a guide, as required.

Troubleshooting
The Troubleshooting Guide (NN44200-700) describes symptoms that can
appear on all CallPilot server platforms, and describes ways to resolve them.
The Troubleshooting Guide (NN44200-700) is available from the Nortel PIC.

Using online sources
CallPilot administration online Help
The CallPilot Manager and CallPilot Reporter software contain online Help
that provide access to

• technical documentation in Acrobat PDF format

• online help topics in HTML format
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To access online information, log on to CallPilot Manager or CallPilot
Reporter, and then use either of the following methods:

• Click the white Help button at the top of any screen to access the
Administration Help area.

• Click the gray Help button on any screen to display a topic that relates to
the contents of the screen.

For more information about using these Help systems, access CallPilot
Manager Help, open the Getting Started book, and click Navigating CallPilot
Manager Help.

The Application Builder software contains a Windows Help system.

CallPilot online Help for mailbox owners
My CallPilot software contains a Useful Information area that provides
access to end-user guides. To access online Help for the currently selected
My CallPilot tab, click the Help button on the upper right corner of the My
CallPilot screen.

Desktop messaging provides product-specific Windows Help for groupware
clients (Microsoft Outlook, Novell GroupWise, and Lotus Notes). The
stand-alone version of CallPilot Player also provides addressing and
troubleshooting information for Internet mail clients.

Contacting Nortel
If you have comments or suggestions for improving CallPilot and its
documentation, contact Nortel at the following Web site address:

www.nortel.com/documentation

Reference documents
For a list of all CallPilot documents, see the following CallPilot Customer
Documentation Map
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Chapter 3
Getting started with Application Builder

In this chapter
"Installing Application Builder" (page 23)

"Starting Application Builder" (page 25)

Installing Application Builder
This section provides requirements and instructions for Application Builder
installation.

Required services
To run, Application Builder requires the following server services:

• CallPilot LDAP Service

• CallPilot AOS Service

• FTP Publishing Service

• Volume Servers

• SQL Anywhere database

Client computer
Application Builder requires the following hardware and software:

• Windows 2000 Professional, Windows XP Professional, or Windows
Vista

• 25 to 30 Mbytes of free disk space for the Application Builder software

• Internet Explorer 5.5 SP2, 6.0, or 7.0, if you plan to access Application
Builder from CallPilot Manager

• CallPilot Player to record voice items (You can download CallPilot Player
from CallPilot Manager)
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• The following ports must be enabled when using a firewall:

— TCP port 20 (FTP)

— TCP port 21 (FTP)

— TCP port 135 (DCOM)

— UDP port 135 (DCOM)

— UDP port 137 (DCOM)

— TCP port 143 (IMAP)

— TCP port 389 (LDAP)

— TCP port 636 (LDAP)

— TCP port 993 (IMAP)

— TCP ports 1024 to 65535 (DCOM)

— UDP ports 1024 to 65535 (DCOM)

CAUTION
Risk of Vulnerability to unauthorized traffic
The broad range of open TCP and UDP ports can pose a
significant security risk. Consult your network administrator before
proceeding.

Upgrading from previous versions
Applications created for previous CallPilot 1.x systems are automatically
upgraded.

Do not install Application Builder on the CallPilot server or on a stand-alone
CallPilot Manager Web server. Install the client software on computers that
you plan to use for CallPilot system administration.

To install Application Builder

Step Action

1 Insert the CallPilot Application CD-ROM in the computer where you
plan to install Application Builder.

2 From either your CD-ROM or DVD-ROM drive, open the
CallPilotInstall folder, and then double-click the appbuilder.exe file.

Result: The installation program starts.

3 Follow the instructions in the installation program.

—End—
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Defining CallPilot systems
With Application, you can maintain applications for multiple CallPilot
systems.

When you access Application Builder from CallPilot Manager, all your
logon information except for your password, is retained from your CallPilot
Manager session. You do not need to log on again but you must input
your password.

If you plan to use Application Builder in stand-alone mode (without logging
on to CallPilot Manager), you must define the server connection details for
CallPilot systems that you want to access with Application Builder. After
the CallPilot systems are defined, you can select the system you want to
access when you log on to Application Builder.

For details about defining CallPilot systems in Application Builder, see the
Application Builder online Help.

ATTENTION
Application Builder cannot connect to the CallPilot server when using Network
Address Translation (NAT). Application Builder must be able to resolve hostnames
in both directions.

Starting Application Builder
You can start Application Builder from CallPilot Manager or (in stand-alone
mode) from the Windows Start menu.

To start Application Builder from CallPilot Manager

Step Action

1 From the CallPilot Manager window, choose Tools →Application
Builder.

Result:The Login To AppBuilder dialog box appears.

2 In the Password box, type the password for the mailbox number
specified in the User ID box.
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Result: The Application Builder window appears as shown on "The
Application Builder window" (page 27).

—End—

Note: When CallPilot Manager is connected to a CallPilot server from
a client, enter the CallPilot server name or IP address in the server
box to log on. If you enter "local host" instead of the actual CallPilot
server name, the administrator cannot connect Application Builder to the
CallPilot server when starting it from the CallPilot Manager Web page.
Also, calls to the telephone cannot be made to play or record greetings.

To start Application Builder from Windows

Step Action

1 From the Windows Start menu, choose Programs →CallPilot
Application Builder →CallPilot Application Builder.

Result: The Application Builder logon dialog box appears.

2 Type your mailbox number and password.

3 From the System list, select the CallPilot server to access.

4 If you use a Network Message Service (NMS) system, type the
name of the NMS location in the Location box.

5 Click OK.
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Result: The Application Builder window appears.

—End—

The Application Builder window

You create your applications in the application window. Optionally, you can
display page breaks, which show where a new page begins on a printout of
the application.

The palette has one tab for each block type: basic, system, and imported
application. (The imported application tab appears only in an application
that imports another application.) Some blocks do not appear in the palette,
but are automatically added to applications when you create or export them.
For example, the Start and End blocks are part of every application and,
therefore, appear automatically when you create an application. Another
block, the Continue block, appears in an application only when you export it.
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Chapter 4
Creating an application

In this chapter
"Section A: About application development" (page 29)

"What is an application?" (page 29)

"Overview of developing applications" (page 30)

"Planning for applications" (page 31)

"Section B: Lesson -- Creating applications" (page 32)

"Automated attendant application" (page 32)

"Saving and closing applications" (page 119)

"Creating a spoken name for an application" (page 36)

"Next steps" (page 37)

Section A: About application development

In this section
"What is an application?" (page 29)

"Overview of developing applications" (page 30)

"Planning for applications" (page 31)

What is an application?
An application is a set of voice and fax functions that callers access by
dialing phone numbers.
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30 Chapter 4 Creating an application

Parts of an application
An application consists of blocks, voice items, and fax items.

Blocks
Each block in an application represents a function. For example,
the Announcement block provides the primary way to play recorded
announcements. To build an application, add and connect blocks.

Voice items
Many blocks, such as announcement and menu blocks, have voice items
associated with them. Voice items are the system and custom voice
recordings that make up prompts, announcements, and menus. Callers
hear these voice recordings as they interact with an application. With
Application Builder, you can

• create the content of voice items using a phoneset

• import existing voice files

Fax items
Some blocks have fax items associated with them. Fax items consist of a
confirmation prompt and a fax file that callers can request for delivery. For
example, a customer can request a fax file showing the location of ABC
Company. The customer hears the following menu:

To obtain a map showing the location of our store, press 1.
To obtain a list of weekly specials by fax, press 2.

The customer presses 1 and hears the confirmation prompt, "You have
requested a map showing our location." The application can send the file
containing the weekly specials directly to the customer’s phoneset.

Call flow
When you look at an application, you see linked blocks. The combined
blocks, like a flowchart, show the paths that callers can take through the
application. A caller’s path is known as the call flow.

Overview of developing applications
The following table shows the application development process:

Task Reference

1 Plan for the application.
Consider who uses the
application and how
it interacts with other
applications.

See "Planning for applications" (page 31).
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Task Reference

2 Create the application
and assign it a name and
application ID.

See "Saving and closing applications"
(page 119).

3 Design the call flow for the
application.

See Chapter 5 "Designing the call flow"
(page 39).

4 Create voice and fax items
required for the application.

See Chapter 6 "Working with voice items"
(page 75) and Chapter 7 "Working with fax
items" (page 91).

5 Include call functions from
other applications, copy the
functions you require, or
import the entire application.

See Chapter 8 "Integrating applications"
(page 111).

6 Save and close the application
to transfer it to the server.

See Chapter 9 "Saving applications" (page
117).

7 Test the application, and then
make it available to callers.

See Chapter 10 "Putting applications into
service" (page 123).

Planning for applications
Who uses the application?

When you design your application, consider the following questions about
your callers:

Do some callers have rotary telephones?
Callers who use rotary dial phonesets can get lost in applications that
require dual-tone multifrequency (DTMF) input. To avoid this problem,
provide callers with a way out of all applications. You can direct rotary dial
callers to a live attendant or, after hours, to a mailbox.

How do callers access fax services?
If callers access a fax application from a phoneset, same-call fax delivery
is not appropriate. However, if they call from a fax machine, same-call fax
delivery is appropriate. Consider the type of phoneset when you configure
the application’s session profile. For information about session profiles, see
Chapter 10 "Putting applications into service" (page 123)

Do some callers speak a different language?
If your callers speak different languages, you can install multiple languages
on your system. Callers can then interact with the application in their
preferred language.
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Can callers dial the application directly?
For callers to dial an application, it must have an Service Directory
Number (SDN.) However, callers do not dial all applications. Callers never
dial imported applications, but access them through other applications.
Therefore, an imported application does not require an SDN, but the parent
application does require one. To identify which applications require SDNs,
identify which applications callers dial. For information about SDNs, see
Chapter 10 "Putting applications into service" (page 123)

How many callers do you expect?
Applications use channels for processing. You may need more channels for
a large number of applications to ensure that calls are not lost.

Can you reuse all or part of the application?
Before you create an application, consider whether

• you can use all or part of an existing application in the new application

• you can use all or part of your new application in another application

Two options are available to reuse call handling functions in an application:

• Save a group of call handling functions that you want to re use as
a separate application. You can import the small application into
other applications that require the same call handling. Changes to an
imported application are automatically reflected in all parent applications
that use it.

• Copy blocks from one application and paste them into another
application.

Section B: Lesson -- Creating applications

In this section
"Automated attendant application" (page 32)

"Saving and closing applications" (page 119)

"Creating a spoken name for an application" (page 36)

"Next steps" (page 37)

Automated attendant application
This lesson shows you how to create a simple automated attendant
application to illustrate the application development process. You can
use this application as the basis of your own automated attendant by
customizing the call handling functions. You can also customize the call flow
by adding additional blocks, either immediately or over time.
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The automated attendant
The manager of the SuperValue Grocery Store wants to implement an
automated attendant application. For calls arriving outside business hours,
the application must play an announcement that tells the store’s hours and
its location. For calls arriving during business hours, the application must
allow callers to

• call the Bakery or Deli department

• dial a specific extension

• access the company directory to specify the name of the person whom
they want to call

No response handling

• If the callers do not enter a response for the Menu block (the first block
requiring user interaction), the application assumes that they use a
rotary phone. It invokes the Rotary block, and the call is transferred
to an attendant.

• If callers do not enter a response for the Thru-Dial block, but they
enter a response for the Menu block, the application knows they use a
touchtone phone and it follows the path for the No Response output.
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Creating an application
When you create a new application, you assign it a unique file name and ID.

File name
The file name can be up to 60 characters long (for example, AutoAttendant).
Give your application a meaningful name, especially if you are one of
several administrators. Do not use names that sound alike. Also, try to
include the same prefix in the names of related applications, but try to keep
your prefix short so that the rest of the name is easily recognized. For
example, you can prefix any accounting department applications with "ac."
Then, "acmenu" represents the menu for that department.

Application ID
The application ID must be a unique number from 1000--49 999 (for
example, 10 001). When you use Voice Item Maintenance or Fax Item
Maintenance to maintain applications from a phoneset, you identify
applications by ID.

Note: When you create an application, Application Builder assigns it a
default application ID. If desired, you can assign another available ID.

Where the application is stored
When you create an application, you can choose the location on the server
where you want to store it. You choose a location with the Volume ID field.
In a system with multiple volumes, you can use the following volume IDs:

Volume ID Location (drive)

1 D:

102 E:

103 F:

Application locking
While an application is open, Application Builder locks it so that other
administrators cannot access it until you close it.

To create an application

Step Action

1 In Application Builder, choose File → New.

Result:The New dialog box appears.

2 Specify the file name, application ID, and storage location.

3 Click New.
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Result: The new application appears in an application window.
The new application contains the default blocks: a Start block, an
End block, a Rotary Dial block, a Call Transfer block, and three
Announcement blocks.

—End—

To view or modify identification details for an application

Step Action

1 Choose File → Properties.
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2 Click the General tab.

—End—

Creating a spoken name for an application
You can include a voice recording to identify an application. This audio
identifier is called a spoken name. Record a spoken name for all
applications that include fax items or voice items. With a spoken name,
administrators can confirm the identity of an application when they use
Voice Item Maintenance or Fax Item Maintenance services to manage voice
and fax items from a phoneset.

For example, to identify the application for the Automated Attendant in the
London office, you can record the spoken name "London office Automated
Attendant."

You can create this voice recording in one of the following ways:

• Create the recording within Application Builder, using a phoneset.

• Import a sound file.

To record a spoken name from a phoneset

Step Action

1 In Application Builder, open the application for which you want to
record a title.

2 Choose File → Properties.

Result:The File properties dialog box appears, with the General
tab displayed.
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3 Click Record through telephone.

4 In the Specify Phoneset box, type the number of the phoneset you
want to use for recording, and then click OK.

Result:Application Builder Player appears.

5 Click Record.

6 Answer the phone when it rings.

7 When you hear a beep, say the title of the application (for example
"Automated Attendant"), and then click Stop.

8 To listen to the recording, click Play.

9 If you do not like the recording, record over it.

10 When you are satisfied with your recording, click Save.

11 Hang up the telephone, and then close Application Builder Player.

—End—

To import a sound file

Step Action

1 In Application Builder, open the application for which you want to
import a title.

2 Choose File →Properties.

Result:The File properties dialog box appears, with the General
tab displayed.

3 Click Import from.WAV file.

4 Select the file that contains a recording of the application’s title, and
then click Open.

5 Click OK.

—End—

Next steps
If you want to save changes to your application before you proceed to the
next lesson, choose File →Save. For details about saving applications, see
"Saving and closing applications" (page 119).
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38 Chapter 4 Creating an application

When you are ready to continue, the next step is to create the call flow for
your application. See Chapter 5 "Designing the call flow" (page 39)
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Chapter 5
Designing the call flow

In this chapter
"Section A: Blocks and connections" (page 40)

"Defining call functions with blocks" (page 40)

"Types of blocks" (page 42)

"Connecting blocks" (page 48)

"Block interactions" (page 49)

"Guidelines for designing the call flow" (page 50)

"Section B: Lesson - Designing the call flow" (page 52)

"Overview" (page 53)

"Adding a Day Control block" (page 53)

"Using the Date Control block" (page 55)

"Adding Time Control blocks" (page 57)

"Adding Announcement blocks" (page 60)

"Adding a Menu block" (page 64)

"Adding the Thru-Dial blocks" (page 67)

"Adding the Call Transfer blocks" (page 71)
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"Documenting and printing your application" (page 72)

"Next steps" (page 74)

Section A: Blocks and connections

In this section
"Defining call functions with blocks" (page 40)

"Types of blocks" (page 42)

"Connecting blocks" (page 48)

"Block interactions" (page 49)

Defining call functions with blocks
What is a block?

A block represents a specific function in an application. In Application
Builder, blocks display as gray squares, with an icon that suggests the
block’s function.

For example, with the Announcement block, you can play a
voice recording for the caller.

For example, suppose that you create a simple application
that has an announcement and a menu. While creating
another application, you realize you need to use the same
announcement and menu. Instead of recreating them, you
simply import that application into the current one.

Blocks in the application window
A block looks different in an application from the way it looks in the palette.
When you add a block to an application, you see both the block and its
outputs.
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The outputs are the different conditions that can occur. For example, in the
Menu block, one of the following conditions can occur:

• The caller presses a number from 1 to 9.

• The caller presses 0.

• The caller presses * or #.

• The caller does not respond.

• The caller presses an invalid key.

• The caller is using a rotary telephone.

You must decide which path calls can take when each of these conditions
occurs.

In Application Builder, when you add a new block, that block has a pink
border, and some of its outputs are pink. The pink outputs are outputs that
must connect to another block. The pink border indicates that one or more
required outputs are not connected, or the block is not configured. (For
the Menu block, for example, you must specify the name of the voice item
containing the menu choices, as well as the voice items that play when there
is no response or an invalid response.)

Naming conventions for blocks
When you add a block, you must assign a name to that block.

The following symbols are allowed in block names:

• A - Z (Latin uppercase letters)

• a - z (Latin lowercase letters)

• 0 - 9 (Digits)
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The following limitations are applicable naming blocks:

• a block name must be unique in the scope of application

• a block name cannot exceed 30 symbols

• a block name cannot start with a digit (0-9)

Note: Some names are reserved by Application Builder for internal use,
and cannot be used as a block name. If you attempt to name a block with
one of the names reserved for internal use, an error message appears.

Connections
Connections between blocks determine the call flow, or the handling given
to calls. Each output for a block must connect to another block. For more
information about connections, see "Connecting blocks" (page 48).

Types of blocks
Block classifications

Application Builder classifies blocks as basic, system, and imported
application blocks.

Basic blocks
Basic blocks provide general functionality. You must configure the basic
blocks. For example, for the Announcement block, you must specify the
name of the voice item containing the recording that plays.

System blocks
System blocks represent predefined system applications (or services). Use
these blocks to link your applications to services.

For example, with the Express Voice Messaging block, you can
transfer callers to the Express Voice Messaging service where
they can leave a voice message in a mailbox.

Imported application blocks
Imported application blocks enable you to place applications within other
applications.

The following tables show the types of blocks that appear in your
applications.
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Automatically created blocks
The following table alphabetically lists blocks that are automatically added to
applications when applications are created or exported:

Block Purpose Setup required

Continue
(exported
applications
only)

Passes callers from an imported
application to the destination
application.

• Connect at least one other
block to the Continue block.

End Terminates an application in one of the
following ways:

• disconnects callers from an
application

• transfers callers to a service

Note: To transfer callers from an
application to a service, the End block
must terminate the application.

• None

Rotary Dial Ensures that callers who use a rotary
dial phoneset reach a live attendant and
do not get trapped in the application.

Note: Application Builder cannot
determine whether callers actually have
DTMF capability. Therefore, if callers do
not enter a DTMF response for certain
blocks, they transfer to the Rotary Dial
block. (You can configure different
handling.) The time-out period is set in
the CallPilot Manager.

• Connect the output.
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Block Purpose Setup required

Start Begins an application. • Connect the output.

Unavailable Indicates that an imported application or
fax function is unavailable in a restored
application. For information about
archiving and restoring applications,
see Chapter 11 "Archiving and restoring
applications" (page 131)

• Restore missing imported
applications from your archives,
if they are available.

• Delete Unavailable blocks,
and then reconnect and
reconfigure blocks to complete
the application.

Blocks in the Basic palette
The following table describes the blocks on the Basic palette, and the setup
they require. For more information about basic blocks, see the online Help.

Block Purpose Setup required

Announcement Plays a voice recording to provide
information. Caller interaction is not
required. Compare with Menu block.

• Connect the outputs.

• Choose the voice item.

• Determine how many times the
announcement plays.

• Define the phoneset keys
that can interrupt the
announcement, and whether
those keys can be saved for
the next block.

Call Transfer Transfers callers to the default
attendant or an extension specified by
the caller.

Note: If you transfer callers to the
default attendant, ensure that the
default attendant is defined in CallPilot
Manager. See the Administrator’s Guide
(NN44200-601).

• Connect the outputs.

• Optionally select a voice item
that is used as a greeting.

• Specify the number to which
callers transfer.
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Block Purpose Setup required

Date Control Routes callers to different blocks in an
application depending on the date.

• Connect the outputs.

• Configure the date period.

Day Control Routes callers to different blocks in an
application based on the day of the
week or whether the day is a holiday.

• Connect the output for each
day.

• Specify whether the day of
the week is checked against a
holiday schedule.

• The number of holidays are
limited to sixty (60). Attempting
to add a sixty-first holiday
results in a system error.

Fax Select Allows callers to select an associated
fax item for same-call or callback
delivery. (See Chapter 7 "Working with
fax items" (page 91))

• Connect the outputs.

• Associate a fax item with the
Fax Select block.

Fax Send Delivers selected faxes through
same-call or callback delivery. (See
Chapter 7 "Working with fax items"
(page 91))

• Connect the outputs.

Language Select Changes the current language for all
system prompts.

• Connect the output.

• Choose the language in which
system prompts play. More
than one language can be
ordered and installed on the
system. You can select any
installed language.
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Block Purpose Setup required

Menu Provides callers with a list of choices
that correspond to the keys on the
phoneset.

• Connect the outputs.

• Identify the voice item
containing the menu choices.

• Identify the voice item that plays
when there is no response.

• Identify the voice item that
plays when an invalid response
is received.

Password Check Verifies passwords entered by callers
and gives callers with correct passwords
access to the protected areas of the
application.

• Connect the outputs.

• Define up to five passwords.

• Optionally, identify a voice item
that is used for a greeting.

Thru-Dial Provides an automated attendant
service that transfers callers to the
extension they choose.

• Connect the outputs.

• Identify a voice recording to
play as the greeting.

• Specify whether callers enter
an extension, enter the name
of the person they want to call,
or both.

• Select a restriction/permission
list to determine the type
of extension numbers (for
example, long distance) that
callers can access.

Time Control Routes callers to different blocks in an
application based on the time of day.

• Connect the outputs.

• Configure the time period.
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System blocks
The following table describes the blocks in the System palette, and the
setup they require. System blocks allow you to access system services
from within the application. For more information about system blocks,
see the online Help.

Block Purpose Setup required

Custom
Commands

Allows callers to create custom
commands for the Speech Activated
Messaging system (for example,
recording a synonym for a command, or
recording a word or phrase in another
language as a synonym for a command).

• None

Express Voic
e Messaging

Transfers callers to the Express Voice
Messaging service where they can leave
a voice message in a mailbox.

• Determine whether callers leave
messages in mailboxes that they
specify or in a mailbox that you
specify.

Express Fax
Messaging

Transfers callers to the Express Fax
Messaging service where they can leave
a fax message in a mailbox.

• Determine whether callers leave
fax messages in mailboxes that
they specify or in a mailbox that
you specify.

Fax Item
Maintenance

Transfers callers to the Fax Item
Maintenance service, where callers can
edit fax items.

• None

Multimedia
Messaging

Transfers callers to the Multimedia
Messaging service, where callers can
use a DTMF phoneset to access their
mailboxes for maintenance, and for
message retrieval and composition.

• None

Speech
Activated
Messaging

Transfers callers to the SA Messaging
service. With this service, callers can
use paced speech recognition to access
their mailboxes for administration, and for
message retrieval and composition.

• Specify whether callers can use
paced speech recognition.

Voice Form Transfers callers to a voice form service
where they can answer a series of
questions, which creates an electronic
form. Because this block offers a service,
it causes the application to end.

• Specify the Voice Form ID or
Title when you select the Voice
Form Parameters tab.

Voice Item
Maintenance

Transfers callers to the Voice Item
Maintenance service, where callers can
edit voice items.

• None
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Imported Application block
The following table describes the blocks on the Imported Application palette,
and the setup they require. For more information about imported application
blocks, see the online Help.

Note: The Imported Application palette is available only if you import
one or more applications into the application that is open. If there are no
imported applications, only the Basic and System palettes are available.

Block Purpose Setup required

Imported
application

The palette contains a block for each
imported application. When you drag
the block for an imported application
into the application window, you
place the imported application in your
application. If the functionality of
the imported application changes, it
updates in all the applications that
imported it.

• Connect the imported
application to at least one
output. Connect the Continue
and End outputs of the imported
application.

Connecting blocks
Types of connections

The ways that you connect the functions in an application determine the
possible paths a call can take, or the call flow.

You can represent connections in two ways:

• line connections - A line joins the output to the connected block.
These connections make the call flow easier to see, but in a complex
application, too many crossing line connections are hard to interpret.

• stubbed connections - The name of the connected block appears to
the right of the output. These connections are neater, but not as easy
to follow at a glance.

The following illustration shows these types of connections:
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Block interactions
This section describes how the different blocks interact, and how you can
use these interactions in your applications.

Announcement block and blocks requiring user interaction
Interruption and buffering
You can configure your Announcement block to accept and buffer menu
keys. If you do, when the caller enters a menu key (1-9), the key interrupts
the announcement and the application passes it to the next block. The
result varies depending on what kind of block is next.

Announcement Key buffering stops and the key is deleted from the buffer.

Menu The menu choices greeting does not play, and the buffered
key is used as a menu selection.

Thru-Dial The thru-dial greeting does not play, and the buffered key
is used as the first digit in the thru-dial number.

Uninterruptible greetings
Both the Menu and Thru-Dial block greetings are interrupted when the caller
presses a key. To prevent the caller from interrupting these greetings, put
the greetings in an Announcement block, and configure the Announcement
block to be uninterruptible.

Rotary Dial block and blocks requiring user interaction
In the first block requiring user interaction, if the caller does not respond,
the application assumes that the caller is using a rotary dial phoneset. The
application follows the path for the Rotary output, which (by default) invokes
the Rotary Dial block.
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The Rotary output is used only for the first block requiring user interaction.
For all subsequent blocks, if the user does not respond, the application
uses the No response output.

Example: No response at the Menu block
In your sample application, a caller with a rotary telephone reaches
SuperValue Grocery store. The caller hears the menu, but is unable to
respond. After the no response period elapses, the application uses the
Rotary output, which invokes the Rotary Dial block. The caller is transferred
to an attendant.

Example: No response at a subsequent block
In your sample application, the caller with a touch tone phoneset hears
the menu and presses 1 to dial an extension. At the Thru-Dial block, the
caller realizes she forgot the extension, and looks in her address book.
Meanwhile, the time-out period elapses, and the application uses the No
response output, which invokes the Attendant block.

End block and system blocks
All system blocks connect to the End block to terminate the application
before transferring callers to the system service.

Guidelines for designing the call flow
Consider the following guidelines when you design an application:

• A pink border around a block indicates that you must configure or
connect it to complete the application. Connect the block’s outputs to
other blocks to define the path for the call.

• Always connect an output from one block to a different block. Avoid
infinite loops that are created by connecting a block’s output back to
the same block. Infinite loops can raise SLEE CPU consumption to
abnormally high levels, resulting in ring-no-answer behavior or system
slowdown.

• Saving and closing an application are different processes. When
you save an application, Application Builder updates the server, but
the application remains locked until you close it. When you close an
application, Application Builder unlocks it so that other administrators
can view or maintain it.

• An application must be complete before you can export it or put it into
service.

Avoiding Infinite Loops
An infinite loop is created when the call path between one or more blocks
loops back to the first block. Infinite loops consume system resources,
which can result in slow system performance and ring-no-answer behavior.
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Check for infinite loops in the Application Window. Non-looping call paths
connect blocks from left to right. Any call paths traveling the other way
probably form an infinite loop.

The blocks in the preceding figure are connected in an infinite loop. Callers
who use the application Monday to Friday inside the configured date ranges
can not continue through the application.

If Program Diagnostics is enabled, refer to "To specify a program diagnostic
level" on "To specify a program diagnostic level" (page 134). Application
Builder checks for infinite loops when you save an application. An error
message listing all the blocks involved in infinite loops appears.
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Application Builder does not generate an error if an infinite loop is created
with a single Menu block. Because the Menu block waits for the caller
to make a menu selection, it does not cause the application to consume
system resources. If a loop consists of two or more blocks, Application
Builder generates a message. Application Builder does not detect the loop
if the loop area is not reachable from the Begin block. In the Application
Builder Program Diagnostics, unreachable blocks are reported.

Section B: Lesson - Designing the call flow

In this section
"Overview" (page 53)

"Adding a Day Control block" (page 53)

"Using the Date Control block" (page 55)

"Adding Time Control blocks" (page 57)

"Adding Announcement blocks" (page 60)

"Adding a Menu block" (page 64)

"Adding the Thru-Dial blocks" (page 67)

"Adding the Call Transfer blocks" (page 71)

"Documenting and printing your application" (page 72)

"Next steps" (page 74)
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Overview
This lesson shows you how to create and document the call flow for the
example automated attendant application that you created in the previous
lesson.

As you build the application, refer to the diagram on page "Creating an
application" (page 34) to view the overall call flow.

Learning more about blocks
For details about each type of block and working with blocks, outputs, and
connections to design the call flow of your application, refer to the Designing
Applications book in the Application Builder online Help.

Adding a Day Control block
In this section, you add the Day Control block to define call handling based
on the day of the week.

Holidays
When you configure the Day Control block, you can choose whether to
check a holiday schedule. You can define the holiday schedule in CallPilot
Manager. If you use the holiday schedule, you associate a Holiday output
with the desired call handling. When the application receives a call on a
defined holiday, the call is routed to the holiday call functions. For example,
if Christmas falls on a Monday, calls arriving on Christmas day are given
holiday treatment rather than Monday treatment.

To add the Day Control block

Step Action

1 Drag the Day Control block from the palette to the application
window. (To drag a block, move the cursor to the block, press the left
mouse button, and hold it while you move the block to the desired
location.)

Tip: If the Palette does not appear, choose View → Palette.

Result: The Add Day Control Block dialog box appears.

2 Enter a name for the block (for example, Days), and then click OK.

Nortel CallPilot
Application Builder Guide

NN44200-102 01.02 Standard
5.0 12 April 2007

Copyright © 2007, Nortel Networks

.



54 Chapter 5 Designing the call flow

Note: The name of the block must adhere to the naming
convention rules for blocks. For more information about naming
convention rules, see "Naming conventions for blocks" (page 41).

Result: The Day Control block is added to the window. Note that the
block border and all of the outputs are pink.

3 To configure the block, double-click it, complete the Parameters tab,
and then click OK.

4 Connect the Start block to the Day Control block. To do so, click the
left mouse button (left-click) on the connector for the Start block
(the black square to the right of the Start block), and then left-click
the Days block.

Result: The pink border around the Start block disappears, and a
connecting line appears between the Start and Day Control blocks.

You must connect the Day Control block outputs, but before you can
do so, you must add the blocks associated with the outputs.

—End—
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Using the Date Control block
The Date Control block routes calls to different blocks based on date.
Each Date Control block can include up to five separate date ranges. If
the current date falls within a specified date range, the application uses
the Inside output. If the date is not within the date range, the application
uses the Outside output.

To define a date period for the Date Control block
Define a date period to specify on which calendar days the application can
route callers to a particular block. A date period can consist of up to five
subperiods. In Application Builder’s Date Control block:

Step Action

1 In a box under From (mm/dd), type the month and the day on which
the date subperiod begins.

2 In the corresponding box under To (mm/dd), type the month and the
day on which the date subperiod ends.

3 Repeat steps 1 and 2 to define another date subperiod.

4 Click OK.

Tip: Include a date in more than one subperiod to overlap
subperiods. Use a Date Control block to define departmental
holidays that differ from organizational holidays.

—End—

Date Control - Parameters
Use the Parameters tab to configure the Date Control block. You can specify
up to five date ranges. Options:

• From (mm/dd)

Nortel CallPilot
Application Builder Guide

NN44200-102 01.02 Standard
5.0 12 April 2007

Copyright © 2007, Nortel Networks

.



56 Chapter 5 Designing the call flow

Specifies, in months (mm) and days (dd), the start date of one date
subperiod. Up to five subperiods can define the date period. Example:
10/08 to represent October 08.

• To (mm/dd)

Specifies, in months (mm) and days (dd), the end date of one date
subperiod. Up to five subperiods can define the date period. Example:
10/04 to represent October 04 of the following year.

Date range examples

• 01/03 to 01/03 - A single date, January 3.

• 07/03 to 07/05

• 07/05 to 07/06 - Overlapping date ranges. If the current date falls within
either range (07/03 - 07/05 or 07/05 - 07/06), or both, it is considered to
be inside the date range.

• 12/22 to 01/03 - A date range that starts in one year and ends in the
following year. If the begin date is later than the end date, the date
range is assumed to span the end of the year. In this example, the date
range covers the period from December 22 of one year to January 3
of the following year.

Tip: If you require additional date ranges, connect Date Control blocks.
You can use this block with the Time Control block to route calls during
specific time periods.

Date Control - Outputs
Use the Date Control - Outputs tab to see where callers go in the application
if they call either inside or outside the date period. Options:

• Name - Displays the names of the block’s outputs.

Nortel CallPilot
Application Builder Guide

NN44200-102 01.02 Standard
5.0 12 April 2007

Copyright © 2007, Nortel Networks

.



Adding Time Control blocks 57

• Connection - Displays the block to which each output is connected.

• Visible - Displays Yes or No. Yes indicates that you can see the block’s
output in the application window. No indicates that you cannot see the
block’s output.

• Notes - Type information about the block or its configuration.Tip: Include
information that you want to see when the application is printed. You can
also include information for anyone else who maintains the application.

Date Control example
Registration at City University occurs September 4 to 7. During this period,
the Registration office is open from 8:00 a.m. to 9:00 p.m. At all other times,
the Registration office is open from 9:00 a.m. to 5:00 p.m.

The application for City University contains a Date Control block. If the
current date falls within the registration period (September 4 to 7), the
application invokes a Time Control block with a time range from 8:00 a.m. to
9:00 p.m. If a call arrives within this time period, the application invokes a
menu. If a call arrives outside this time period, the application invokes an
announcement that gives the office’s open hours.

If the current date is not within the registration period, the application
invokes a different Time Control block. This block has a time range from
9:00 a.m. to 5:00 p.m. If a call arrives within this time period, the application
invokes a menu. If a call arrives outside this time period, the application
invokes an announcement that gives the office’s open hours.

Adding Time Control blocks
In the sample automated attendant application, the SuperValue Grocery
store is open from 8:00 a.m. to 8:00 p.m. on weekdays, and from 9:00 a.m.
to 6:00 p.m. on Saturdays. It is closed on Sundays and holidays.

This section shows you how to add two Time Control blocks:

• The first block, WeekdayHours, handles calls arriving during weekdays.
This block determines whether a call is arriving inside or outside
business hours (that is, 8:00 a.m. to 8:00 p.m.).

• The second block, SaturdayHours, handles calls arriving on Saturdays.
This block determines whether a call is arriving inside or outside
business hours (9:00 a.m. to 6:00 p.m.).

Time Control blocks allow you to handle calls differently, depending on
whether they fall inside or outside the specified period.

Note: For a Time Control block, you can define up to five time periods.
For example, you can include the following periods in your Time Control
block:
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• 9:00 a.m. - 10:30 a.m.

• 10:45 a.m. - 12:00 p.m.

• 1:00 p.m. (13:00) - 3:00 p.m. (15:00)

• 3:15 p.m. (15:15) - 5:00 p.m. (17:00)

With this schedule, you can give outside-hours handling to calls arriving
during coffee and lunch breaks.

To add a Time Control block

Step Action

1 Drag the Time Control block from the palette to the application
window.

Result: The Add Time Control Block dialog box appears.

2 Enter a name for the block (for example, WeekdayHours), and
then click OK.

Note: The name of the block must adhere to the naming
convention rules for blocks. For more information about naming
convention rules, see "Naming conventions for blocks" (page 41).

Result: The Time Control block is added to the window. Note that
the block border and the outputs are pink.

3 To configure the block, double-click it, complete the Parameters tab,
and then click OK.
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4 Connect the Time Control block to each of the weekday outputs
of the Day Control block. To do so, hold down the Shift key and
left-click Monday, Tuesday, Wednesday, Thursday, and Friday. Then
left-click WeekdayHours.

5 Add another Time Control named SaturdayHours, and configure it
with a time period from 9:00 to 18:00 (6:00 p.m.). Connect this Time
Control to the Saturday output.

The Sunday and Holiday outputs are still unconnected. Because the
store is not open on Sundays and holidays, you are connected to
these outputs to an announcement for nonbusiness hours covered
"Adding Announcement blocks" (page 60) on page 84.

—End—
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Adding Announcement blocks
Calls arriving at SuperValue Grocery outside business hours hear an
announcement that tells when the store is open, and provides the store’s
address.

This section shows you how to add the Announcement block that provides
this announcement. An Announcement block is the primary means of
playing voice recordings in an application.

Voice items
You assign voice items to an Announcement block in one of the following
ways:

• Select a system prompt (see "System prompts" (page 77)).

• Select an existing custom voice item.

• Create a new custom voice item, and either

— record the announcement, or

— import an existing recording for the announcement

This section shows you how to create a new custom voice item, but it does
not describe how to import the voice recording. For information about
creating and importing voice recordings, see Chapter 6 "Working with voice
items" (page 75)

Voice item IDs
Each voice item within an application must have a unique identifying number
in the range from 1-3000.

You can use the same ID in two different applications. However, if you
import or copy and paste a voice item into an application, you can have ID
conflicts if two voice items have the same ID. Application Builder recognizes
ID conflicts, and you can manually or automatically assign new IDs to the
items you import or paste. For more information about resolving name and
ID conflicts, see the Troubleshooting book in the Application Builder online
Help.

Interruption
When callers become familiar with your application, they may not need to
hear all of the announcements. For example, a utility company has the
following application:

Announcement: Thank you for calling Metro Utilities, proud winner of the
2000 Metropolis Business of the Year Award. Our office is open from 9:00
a.m. to 5:00 p.m., Monday to Friday, and we are located at 100 Main Street,
Metropolis.
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Menu: Please choose one of the following four options, or remain on the
line for assistance.
To report problems with your service, press 1.
To reach our billing department, press 2.
If you know the extension of the person you want to reach, press 3.
To use our company directory, press 4.

A frequent caller may not want to hear the entire announcement. When you
configure the Announcement block, you can choose whether to allow the
caller to interrupt the announcement by entering the following:

• a menu key (1-9)

• the attendant key (0)

• the help key (*)

• the cancel key (#)

Metro Utilities’ administrator lets callers use the menu and attendant keys
in the Announcement block. Therefore, when Eric Wilson calls, he can
press a number from 0 to 9 as soon as the announcement begins. When he
presses a number, the announcement is interrupted.

You may not want to allow callers to interrupt announcements. For example,
a service outage occurs in a section of Metropolis. To handle all calls
arriving from the affected area, Metro Utilities’ administrator creates a new
announcement:

Announcement: Thank you for calling Metro Utilities. We are currently
experiencing a service interruption in the area bounded by Main Street, First
Avenue, Water Street, and Third Avenue. Repair crews are on the scene,
and service is expected to resume at 8:00 p.m.

The administrator does not allow callers to interrupt this announcement with
a menu or attendant key because she wants all callers to hear the message.

Passing a selected key to the next block
If you allow callers to interrupt an announcement, you can also specify
whether the selected key passes to the next block. This option is called
key buffering. Key buffering is useful when an announcement is followed
by a menu.

For example, Mai Win calls Metro Utilities after service is restored, and
hears the original announcement (Thank you for calling Metro Utilities,
proud winner of the...). She is familiar with the menus, so she presses 2
to reach the billing department. The announcement terminates, and the 2
is passed to the Menu block. The menu prompt does not play, but Mai is
transferred to Accounts Receivable.
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Note: An Announcement block always stops key buffering initiated by a
preceding Announcement block.

Pauses
You can add a pause after the announcement to allow the caller to note
information provided in the announcement. Ensure the pause is not too
long. Excessive pauses can frustrate callers.

Note: If an announcement plays multiple times, the pause occurs only
after the last time the announcement plays.

To add an Announcement block

Step Action

1 Drag the Announcement block from the palette to the application
window.

Result: The Add Announcement Block dialog box appears.

2 Enter a name for the block (for example, Hours_Location), and
then click OK.

Note: The name of the block must adhere to the naming
convention rules for blocks. For more information about naming
convention rules, see "Naming conventions for blocks" (page 41).

Result: The Announcement block is added to the window. The block
border and the outputs are pink.

3 To configure the block, double-click it.

Result: The properties dialog box appears.

4 For this example, create a new custom voice item. In the Custom
Voice Item box, select <new voice item>, and then click New.

5 Complete the Add voice item dialog box, and then click Done.
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Note: Use the ID in Voice Item Maintenance to identify the voice
item. The Description text prints when you print voice/fax items.

Result: The Edit voice item content dialog box appears.

6 You can record or import the voice item. For this example, do not
add the content at this point. Click OK.

For information about recording or importing voice items, see
Chapter 6 "Working with voice items" (page 75)

7 Complete the Parameters tab, and then click OK.

8 Connect the Sunday and Holiday outputs on the Days block to the
new Announcement. To do so, hold down the Shift key and left-click
the Sunday and Holiday outputs, and then left-click Hours_Location.

9 Connect the Outside output for the two Time Control blocks to
the Announcement block. To keep the call flow tidy, and to avoid
criss-crossing lines, stub the lines. Hold down the Shift key and
left-click the Outside output for the WeekdayHours block, and the
Outside output for the SaturdayHours block. Then, right-click the
Hours_Location block.

10 Because the call terminates after the announcement plays, you must
connect the output for the Announcement block to the End block.
Click the Hours_Locationblock.

11 Click the Done block to select it, and then right-click the Done block.

12 Right-click the End block.
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—End—

The previous procedure sets up handling for calls arriving outside of
business hours. Now, you can add the menu presented to calls arriving
during business hours.

Adding a Menu block
Calls arriving at the SuperValue Grocery store inside business hours are
presented with the following menu:

Please choose one of the following four options, or remain on the line for
assistance
If you know the extension of the person you want to reach, press 1.
To access our company directory, press 2.
To reach our Bakery Department, press 3.
To reach our Deli Department, press 4.

This section shows you how to add a Menu block that gives callers these
choices.

Guidelines for creating menus
Follow these guidelines when creating menus:

• Indicate the number of options so that callers know what to expect.
(For example, Welcome to Landon Offices. Please choose one of the
following five options.)

• Limit the number of options to five to avoid overloading callers.
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• Present options sequentially. (For example, For English, press 1; for
French, press 2; for Italian, press 3; for Spanish, press 4.)

Voice items
A menu block can have three voice items associated with it:

• Menu choices greeting

• No response prompt-If you allow retries when no response is received,
this prompt plays if the caller does not respond within the No response
period defined in CallPilot Manager.

• Invalid response prompt-If you allow retries after an invalid response,
this prompt plays when the caller presses an invalid key.

You can assign these voice recordings in the same way as you assign voice
recordings to announcements.

This section shows you how to create a new custom voice item for the Menu
choices greeting, but it does not describe how to create or import the voice
recording. (For information about creating and importing voice recordings,
see Chapter 6 "Working with voice items" (page 75)) You use the default
system prompt for the Invalid response prompt.

To add a Menu block

Step Action

1 Drag the Menu block from the palette to the application window.

Result: The Add Menu Block dialog box appears.

2 Enter a name for the block (for example, MainMenu), and then click
OK.

Note: The name of the block must adhere to the naming
convention rules for blocks. For more information about naming
convention rules, see "Naming conventions for blocks" (page 41).

Result: The Menu block is added to the window. Note that the block
border and the outputs are pink.
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3 To configure the block, double-click it.

Result: The properties dialog box appears.

4 To create a new custom voice item for the Menu choices greeting,
in the Menu choices greeting box, select <new voice item>, and
then click New.

5 Complete the Add voice item dialog box, and then click Done.

Result: The Edit voice item content dialog box appears.

6 You can record or import the voice item. For this example, do not
add the content at this point. Click OK.

For information about recording or importing voice items, see
Chapter 6 "Working with voice items" (page 75)

7 Complete the Parameters tab, and then click OK.
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8 Hide the menu key outputs you are not using. To hide the outputs
for menu key 5, right-click the MainMenu block, and then choose
Hide/Show Outputs → 5. Repeat this step to hide outputs 6 to 9.

9 Connect the No response output to the Rotary block.

Note: This block is the first block that expects a response from
the caller. If the caller does not respond, the caller may be using
a rotary phone.

10 Click the Cancel output to select it, and then right-click the End block.

11 Connect the Attendant output to the Attendant block.

12 Connect the Inside outputs on the two Time Control blocks to the
new MainMenu block.

—End—

Now you must add the Thru-Dial and Call Transfer blocks that you can
invoke from the menu.

Adding the Thru-Dial blocks
Callers to the SuperValue Grocery store can dial a specific individual, either
by entering the extension or by using the company directory. To provide this
ability, the administrator adds two Thru-Dial blocks to the application.
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Name and number dialing
The Thru-Dial block can allow name dialing, number dialing, or both. If you
allow both name and number dialing, callers who want to use the Name
Dialing service must enter the name dialing prefix before entering the name.
(The default prefix for the Name Dialing service is 11. The prefix is defined
in CallPilot Manager.)

Note: If Name Dialing is not enabled in CallPilot Manager, callers
cannot access the Name Dialing service.

Fixed-length extension numbers
Fixed-length extension numbers have a definite number of digits. For
example, a phone number in your dialing area can have seven digits.
Typically, fixed-length extension numbers begin with the same digits, called
left-pad digits. For example, a company’s main phone number is 686-0000.
All company phone numbers begin with 686. These digits are the left-pad
digits.

When you define fixed-length extension numbers and their left-pad digits,
you save callers from having to enter prefix digits for locations that they
dial frequently.

Note: Callers can enter fewer digits only if these digits are followed by
the number sign (#).

Example
The ABC Company’s main phone number is 555-0000. All employees at
the company have their own phone numbers: Jonah Smith’s number is
555-7624; Jessica Freedman’s number is 555-8845. To set up a Thru-Dial
block in a company application, specify that the fixed-length number is
seven. Seven digits make up each phone number. Because each number
begins with 555, you define those three digits as left-pad. As a result, callers
who use the Thru-Dial block to contact Jonah only, enter 7624. Likewise,
they only enter 8845 to reach Jessica.

Callers can enter some or all of the left-pad digits. If they enter all of Jonah’s
number (that is, 555-7624), they still reach him. They also reach him if
they dial 5-7624.

Variable-length extension numbers
Variable-length extension numbers have an indefinite number of digits, up to
30. If you define variable-length extension numbers, callers can enter up to
30 digits for an extension number.

Note: Callers must use the number sign (#) to terminate variable-length
extension numbers.
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Restriction/permission list
A restriction/permission list (RPL) limits the types of numbers that callers
can dial from the Thru-Dial block. For example, an RPL can prevent callers
from placing a long distance call, even if they dial the correct number. If an
unauthorized caller attempts to dial a long distance number, the block plays
a system default error message and asks the caller to try another number.

The administrator sets up RPLs in CallPilot Manager. For more information
about RPLs, see the Administrator’s Guide (NN44200-601).

Voice recordings
You assign voice items to the Thru-Dial block in the same way as you assign
voice items in Announcement blocks. The following table lists the default
system prompts for the Thru-Dial block:

Thru-Dial option Content of prompt

Only name dialing is allowed. Please enter the name of the person you
want to reach, followed by number sign.
To enter a name, spell the last name, and
then spell the first name.

Only number dialing is allowed,
and the numbers are variable
length.

Please enter the number of the extension
you want to dial, followed by number sign.

Only number dialing is allowed,
and the numbers are fixed length.

Please enter the number of the extension
you want to dial.

Both name dialing and number
dialing are allowed, and the
name-dialing prefix is 11.

Please enter the number or the name of
the person you want to reach, followed by
number sign. To enter a name, press 1-1,
spell the last name, and then spell the first
name.

To add a Thru-Dial block

Step Action

1 Drag the Thru-Dial block from the palette to the application window.

Result: The Add Thru-Dial Block dialog box appears.

2 Enter a name for the block (for example, Extension), and then click
OK.

Note: The name of the block must adhere to the naming
convention rules for blocks. For more information about naming
convention rules, see "Naming conventions for blocks" (page 41).

Result: The Thru-Dial block is added to the window. The block
border and the outputs are pink.
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3 To configure the block, double-click it.

Result: The properties dialog box appears.

4 Complete the Parameters tab, and then click OK.

5 Click the Cancel output to select it, and then right-click the Main
Menu block.

6 Connect the Attendant and No response outputs to the Attendant
block.

7 Hide the Rotary output by right-clicking the Extension block and
choosing Hide/Show Outputs → Rotary.

Note: The application does not use this output because the
Thru-Dial block is not the first block requiring user interaction.

8 Connect output 1 on the MainMenu block to the Extension block.

9 Repeat steps "To add a Thru-Dial block" (page 69) to step 7 to add,
connect, and configure a Thru-Dial block with name dialing ability.
Use the default system prompt.

10 Connect output 2 on the MainMenu block to the Thru-Dial block that
you created in the previous step.

—End—
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Adding the Call Transfer blocks
From the main menu for the SuperValue Grocery, callers can transfer to the
Bakery or Deli departments. To allow them to transfer, the administrator
adds Call Transfer blocks to the application.

To add a Call Transfer block

Step Action

1 Drag the Call Transfer block from the palette to the application
window.

Result: The Add Call Transfer Block dialog box appears.

2 Enter a name for the block (for example, Bakery), and then click OK.

Note: The name of the block must adhere to the naming
convention rules for blocks. For more information about naming
convention rules, see "Naming conventions for blocks" (page 41).

Result: The Call Transfer block is added to the window. The block
border and the outputs are pink.

3 To configure the block, double-click it.

4 Complete the Parameters tab, and then click OK.

5 Connect the Failed and Busy outputs to the Attendant block.

6 Connect output 3 on the MainMenu block to the Bakery block.
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7 Repeat steps 1 to step 5 to create the Call Transfer block for the
Deli Department.

8 Connect output 4 on the MainMenu block to the Call Transfer block
created in the previous step.

—End—

To complete your application
To complete the automated attendant application, perform these tasks:

1. Create another Announcement block named Help.

2. Connect the Help and Invalid outputs on the Menu block to the Help
block.

3. Configure the Help block to accept the attendant and cancel keys, and
to use a new voice item, HelpAnnounce.

4. Connect the Attendant output to the Attendant block, and the Cancel
output to the Menu block.

Note: If you use the default attendant, ensure that the default
attendant is defined in CallPilot Manager. For more information
about completing your application, see the Administrator’s Guide
(NN44200-601).

After your application is complete, you can add notes to explain its purpose
and design. For information about documenting your application, see
"Documenting and printing your application" (page 72).

Documenting and printing your application
In the future, you or someone else may need to modify an application.
To help you and other administrators to understand the purpose of an
application and follow the call flow, you can provide some documentation.
With Application Builder, you can document your application in two ways:

• add notes to blocks

• add notes to the application window

You can print the call flow and block details as a visual record of your
application design. Notes that you add appear in your printouts.
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To add a note to a block

Step Action

1 Double-click the block you want to describe. For this lesson,
double-click the Announcement block (Hours_Location).

2 Click the Outputs/Notes tab.

3 In the Notes box, type any additional information about the block.
Because you did not record a voice item for the Announcement
block yet, you can type a note to remind you that the voice item
must be recorded.

4 Click OK.

—End—

To add a text note to the application window
In this procedure, you add a text note to the automated attendant application.
The procedure assumes that the application is open in Application Builder.

Step Action

1 Choose Edit → Create Text Note.

2 Position the pointer (+) where you want the text note to appear.

3 Click and, keeping the mouse button pressed, drag the pointer to
make a rectangle.

4 Release the mouse button.

5 Type the text of the note.

6 Click anywhere outside the note to finish creating it.

—End—
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Working with text notes
The following table describes how you can work with text notes. For detailed
instructions, refer to the Application Builder online Help.

Action Steps

Edit a text note Double-click the text note and edit the text.

Change the appearance of
a text note

1. Select the text note.

2. Choose Edit → Change Text Note Font.

3. Choose the desired font and font size, and then click OK.

Note: To specify a default font, choose Options → Set Default Text
Note Font.

Resize a text note

1. Double-click the text note.

2. Place the pointer on one side of the box. The cursor changes to
a two-sided arrow (↔).

3. Drag the cursor to resize the box.

Move a text note Drag the text note to the desired location.

Delete a text note Click the text note and choose Edit → Delete.

Printing call flow information
You can print the call flow or print a list of blocks and their configuration.

To print the call flow

Choose File → Print Flow.

To print block information

Choose File → Print Block Details.

Next steps
If you want to save changes to your application before you proceed to the
next lesson, choose File →Save. For details about saving applications, see
"Saving and closing applications" (page 119).

When you are ready to continue, the next step is to record the voice items
for your application. See Chapter 6 "Working with voice items" (page 75)
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Chapter 6
Working with voice items

In this chapter
"Section A: About voice items" (page 75)

"Overview of voice recordings" (page 76)

"Types of voice recordings" (page 77)

"Guidelines for voice recordings" (page 79)

"Guidelines for creating recordings" (page 80)

"How to use voice items created for Meridian Mail Voice Services" (page 81)

"Section B: Lesson -- Managing voice items" (page 82)

"Recording a voice item" (page 83)

"Importing a voice item" (page 85)

"Working with voice items" (page 86)

"Next steps" (page 90)

Section A: About voice items

In this section
"Overview of voice recordings" (page 76)

"Types of voice recordings" (page 77)

"Guidelines for voice recordings" (page 79)

Nortel CallPilot
Application Builder Guide

NN44200-102 01.02 Standard
5.0 12 April 2007

Copyright © 2007, Nortel Networks

.



76 Chapter 6 Working with voice items

"Guidelines for creating recordings" (page 80)

"How to use voice items created for Meridian Mail Voice Services" (page 81)

Overview of voice recordings
Voice recordings provide your announcements, greetings, menus, and
prompts. The following table lists the blocks that use voice recordings, and
the function of the recordings in these blocks:

Block Voice recordings used for

Announcement announcement

Call Transfer (optional) prompt

Menu • menu choices greeting

• (optional) no response prompt

• (optional) invalid response prompt

Password Check (optional) password prompt

Thru-Dial (optional) thru-dial greeting

Voice items are stored on the server. They are accessed from any client
computer if you do not use Application Builder in stand-alone mode, or
remotely with Voice Item Maintenance.

Online updating
All changes that you make to an application take effect as soon as you
save the application. However, callers who are currently connected to the
application continue to interact with the previously saved version. Only new
callers interact with the new version.

Example
Currently, you have three announcements customized for:

• morning

• afternoon

• after business hours

You want to reduce the number of announcements to two, using one
announcement for both the morning and the afternoon.

A caller calls the application before you change the announcements.
Because the caller accesses the application in the afternoon, she hears:
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Good afternoon. Thanks for calling Book Bonanza. If you know the number
of the department you want to reach, press 1. If you don’t know the
department’s number, press 2.

While the caller interacts with the application, you use Application Builder to
replace the morning and afternoon announcements with one announcement
that plays during all business hours.

Hello. Thanks for calling Book Bonanza. If you know the number of the
department you want to reach, press 1. If you don’t know the department’s
number, press 2.

The caller who connects to the application is unaware of the changes. After
she hangs up, however, she realizes she must call Book Bonanza again
because she forgot to ask about a book’s availability. During the time it
takes her to complete the call and then redial the number, you change the
announcements and save the application. When the caller redials the
application, she hears the new announcement.

Types of voice recordings
CallPilot supports three types of voice recordings: system prompts, voice
items, and customized prompts. You use all three types of voice recordings
in Application Builder.

System prompts
System prompts are voice recordings that come with the system. You
cannot delete any system prompts. However, you can use System Prompt
Customization to edit some system prompts.

The following table lists the system prompts and their content:

Prompt name as it appears in
Application Builder

Actual content of prompt

For more information, press star For more information, press star.

Transferring to an attendant Transferring to an attendant. One
moment, please.

For help, press star For help, press star.

Please try again Please try again.

<beep> <<Beep>>

Please contact your administrator Please contact your administrator.

<beep> No operator is available <<Beep>> No operator is available.

<beep> That number is busy, try
later

<<Beep>> That number is busy. Please
try again later.
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Prompt name as it appears in
Application Builder

Actual content of prompt

<beep> Number cannot be
reached

<<Beep>> That number cannot be
reached from this service. Please try
again.

<beep> Your call cannot be
completed

<<Beep>> Your call cannot be completed
at this time. Please try again later.

<beep> Selection not recognized <<Beep>> That selection is not
recognized.

<beep> Please make another
choice

<<Beep>> That selection is not
recognized. Please make another choice.

<beep> Invalid password <<Beep>> That password is incorrect.
Please contact your administrator for
assistance.

<beep> Invalid password, try
again

<<Beep>> That password is incorrect.
Please try again.

<beep> Invalid password,
transferring

<<Beep>> That password is incorrect.
Transferring to an attendant; one moment,
please.

Maximum fax selections reached You reached the maximum number of
selections that can be made in one call.
If you would like to make additional
selections, please call again.

Goodbye Goodbye.

Note: You can customize, or edit, the
"Goodbye" system prompt by using System
Prompt Customization.

Voice items
Voice items are custom-made voice recordings. You can use a phoneset to
record your own voice items, or you can import a sound file in WAV format.

Voice items are stored on the server. They are accessed from any client, as
well as with Voice Item Maintenance.

Each voice item within an application has a unique identifying number
in the range from 1 to 3000. (You can use the same ID in two different
applications.)
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Customized prompts
Customized prompts are system prompts that you replace, or customize,
with a phoneset recording or a sound file in WAV format. You can customize
the following system prompts in System Prompt Customization:

• CallPilot from Nortel Networks

• Goodbye

• Express Messaging to mailbox?

• You have dialed the Express Messaging Service. To leave a message,
enter the mailbox number, followed by number sign.

• You have dialed the Express Messaging Service. To leave a message,
enter the mailbox number or the name.

• Hello. You have a message from:

• Hello.

Guidelines for voice recordings
Describe character keys

The character keys on the keypad of a phoneset have various names.
Describe these keys accurately and consistently. Also, use the same
descriptions as other services:

• Call the * key "the star key," not "asterisk."

• Call the 0 key "the zero key," not "oh."

• Call the # key "the pound key" or "number sign" or whatever term is most
common in your country.

Denote keys for responses
Applications often require users to give "yes" or "no" responses. In such
applications, choose responses that are both consistent and conventional.
Use 1 to denote Yes and 2 to denote No.

Give examples
A description sometimes does not give callers enough information about
the information they must enter. When a description is unclear, follow it
with a specific example.

For example, suppose that a Thru-Dial block expects callers to enter both
an area code and a phone number. The voice recording associated with the
block can provide an example of which digits to enter.

Please enter the phone number you want to call, preceded by 1 and the
area code. For example, enter 1 4 1 6 5 5 5 1 0 0 0.
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Organize in goal-action sequence
Identify the result of an action before stating the action. For example, a
recording says:

To speak to a customer representative, press 5 now.

Use everyday language
For example, you can call a telephone a telset, but telset is jargon, and
jargon confuses callers. Use everyday, familiar language when you write
recordings.

Write in the active voice
A voice recording in active voice is clear: "To reach the Accounting
Department, press 1." Passive voice confuses callers because it only
implies what they should do: "To reach the Accounting Department, the
number one key should be pressed."

Make affirmative statements
Tell callers what to do instead of what not to do.

Negative statement: Do not hang up.

Affirmative statement: Please stay on the line.

Use affirmative statements and ensure clarity in your voice recordings.

Give callers useful feedback
Voice recordings can indicate when a selection is incorrect, and then list the
valid options from which callers can choose. If callers press an incorrect key,
they do not want to hear "error," "invalid response," or "unable to process."
None of those recordings indicates what callers can do next.

Guidelines for creating recordings
Record in a quiet area

Ensure that no noise interferes. Turn off any background music. Background
noise can interfere with a caller’s ability to understand the recording.

Be consistent

• Use one professional voice. The voice you record projects your
organization’s identity. Consider whether to use a male or female voice,
and whether the voice sounds formal or casual. For consistency, use
only one voice per application.

• Record all voice items during one session, if possible.
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• Use the same recording device for the voice. For example, use only the
phoneset or the computer microphone.

How to use voice items created for Meridian Mail Voice Services
You can reuse voice items created for Meridian Mail Voice Services so
that you do not waste time recreating existing announcements and voice
prompts.

You can migrate the following items from Voice Services to Application
Builder:

• announcements

• fax items

• menus

This section describes how to use migrated announcements and menus.
For information about using migrated fax items, see "Using faxes created for
Meridian Mail Voice Services" (page 94).

For information about migrating voice items from Meridian Mail Voice
Services, refer to the Meridian Mail to CallPilot Migration Utility Guide.

Contents of a menu
Each menu from Voice Services contains voice prompts for:

• the greeting

• caller choices

• the 1--9 menu keys

How to identify migrated voice items
Announcements and menus migrated from Meridian Mail Voice Services
are identified by the migrated service type and a service ID number.

Menus
A migrated menu name has a prefix of "Menu," followed by its ID from Voice
Services. For example, a Voice Services menu with an ID of 64 appears
as "Menu64" in Application Builder. The description of the application is
"Migrated from Menu Service 64."

Announcements
A migrated announcement has a prefix of “ANN,” followed by its ID from
Voice Services. For example, a Voice Services announcement with an ID of
65 appears as “ANN65”, ID 1010 in Application Builder. The description of
the application is “Migrated from Announcement Service 65.”
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Within that file, you see the announcement (voice item) with a name
(“Voice1”).

Format of migrated voice items
Voice Services distinguishes between announcements and prompts. You
can use announcements in multiple services, but you can only use a voice
prompt in one service. In Application Builder, both announcements and
voice prompts are classified as voice items.

Access
On the server, you access migrated announcements and the voice prompts
of menus in the same way that you access voice items.

Use
Voice items are compatible with all applications. For example, you can
use the same voice item in multiple applications just as you used an
announcement in multiple services. As a result, you now can use all your
existing voice prompts in multiple applications.

Applications that contain migrated voice items
You can use migrated voice items in new applications and in rebuilt
applications that existed in Meridian Mail Voice Services. Consider when
to build both types of applications.

New applications
You can create new applications that use migrated voice items either before
or after the voice items are migrated from Voice Services.

If you create new applications before migration, you save time. However,
you can complete the applications and use them only after migration.

Rebuilt applications
You can rebuild applications that use migrated voice items either before or
after the voice items are migrated from Voice Services.

You save time if you rebuild applications before migration. However, you can
complete the applications and use them only after migration.

You can do everything at once if you rebuild applications after migration.
You can paste the voice items into the applications while you create them.
Also, the migrated voice items can help you remember what to rebuild.

Section B: Lesson -- Managing voice items

In this section
"Recording a voice item" (page 83)
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"Importing a voice item" (page 85)

"Working with voice items" (page 86)

"Next steps" (page 90)

Recording a voice item
In the previous chapter, you created custom voice items for use with your
blocks. However, the voice items have no voice content. In this section, you
use a phoneset to record the voice content for a voice item.

If you need to change the recording later, you can re-record the voice item.
Your new recording replaces the previous recording.

To record a voice item

Step Action

1 In Application Builder, open the application for which you want to
record the voice content.

2 Choose Define → Voice items.

Result: The Define voice items dialog box appears.

3 Select the voice item to record, and then click Edit.

Result: The Edit voice item dialog box appears.
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4 In the Name box, type a name for the voice item.

5 Click Record.

Result: The Specify Phoneset dialog box appears.

6 In the Specify Phoneset box, type the number of the phoneset you
want to use for recording, and then click OK.

Result: Application Builder Player appears.

7 Click Record.

8 Answer the phone when it rings.

9 When you hear a beep, say the content of the voice item, and then
click Stop.

10 To listen to the recording, click Play.

11 If you do not like the recording, re-record the message by clicking
the previous chapter button (|<<), and then record again.

Note: If you re-record without going back to the beginning of
your initial recording, you add to the initial recording.

12 When you are satisfied with your recording, click Save.
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13 Hang up the telephone, and then close Application Builder Player.

14 On the Edit voice item dialog box, click Done.

15 Click OK on the Properties dialog box.

—End—

Importing a voice item
If you have a prerecorded sound file in the correct format, you can import it
into Application Builder. Sound files must be mono 8-bit or 16-bit files in WAV
format, with a sampling frequency rate of 11 kHz, 22.05 kHz, or 44.1 kHz.
You can import sound files from anywhere on your client computer network.

If you want to change the content of the voice item later, you can import a
new file. The new recording replaces the previous recording.

ATTENTION
Risk Voice Quality Degradation
CallPilot converts audio into the following format:

• Audio Format: PCM

• Average data rate: 16 kb/s

• Sample rate: 8 kHz

• Audio sample size: 16 bit

• Channels: 1 (Mono)

There is a risk of degradation in sound quality if the files imported into Application
Builder are in another format.

To import a voice item

Step Action

1 In Application Builder, open the application for which you want to
import the voice content.

2 Choose Define → Voice items.

Result: The Define voice items dialog box appears.

Nortel CallPilot
Application Builder Guide

NN44200-102 01.02 Standard
5.0 12 April 2007

Copyright © 2007, Nortel Networks

.



86 Chapter 6 Working with voice items

3 Select the voice item into which you want to import, and then click
Edit.

Result: The Edit voice item dialog box appears.

4 Click Import.

5 Select the sound file that you want to import.

6 Click Open.

7 Click OK.

8 Click Done and return to the application window.

—End—

Working with voice items
You can work with your voice items using either Application Builder or
Voice Item Maintenance. This section lists the voice item maintenance
procedures you can perform.
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In Application Builder

Action Steps

Edit the name or description of a
voice item 1. Choose Define → Voice items.

2. Select the voice item to edit, and then click Edit.

3. Make the desired changes, and then click Done.

Delete voice items

1. Choose Define → Voice items.

2. Select the voice item to delete.

3. Click Delete.

Note: You cannot delete a voice item that is used by an
application.

Copy a voice item to the clipboard 1. In the application containing the voice item to copy,
choose Define → Voice items.

2. Select the voice item you want to copy.

3. Click Copy.

Note: When you copy a block from one application to
another, any associated voice items are also copied to the
destination application.

Paste a voice item from the clipboard
into the current application window

1. Choose Define → Voice items.

2. Click Paste.

3. If the application contains a voice item with the same
name or ID as the voice item you paste, Application
Builder prompts you to resolve the name or ID
conflicts. You can accept the new name and ID
assigned by Application Builder, or specify your own.

Print a list of all voice and fax items Choose File → Print Voice/Fax Items.
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Using Voice Item Maintenance
With Voice Item Maintenance (VIM), you can maintain voice items from a
remote location, using a telephone.

Before you use Voice Item Maintenance to maintain the voice items in an
application, define a telset maintenance password for the application.

To use Voice Item Maintenance, you must know:

• the service directory number (SDN) for the Voice Item Maintenance
service

• the ID of the application that contains the voice item you want to modify

• the telset maintenance password

• the ID of the voice item

To define a telset maintenance password

Step Action

1 In Application Builder, open the application for which you want to use
Voice Item Maintenance.

2 Choose File → Properties.

3 Click the Security tab.

4 Select the telset maintenance password check box, and type the
password in the Telset maintenance password and Password
confirmation fields.

5 Click OK.

6 Save and close the application.

Note: The minimum length for a password is defined in the
Security section of CallPilot Manager.

—End—
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Tasks in Voice Item Maintenance
You can perform the following tasks with Voice Item Maintenance:

Action Steps

Log on to Voice Item Maintenance

1. Dial Voice Item Maintenance.

2. Enter the ID of the application that you want to edit,
and then press number sign (#).

3. Enter the telset maintenance password for the
application, and then press number sign (#).

4. If the application contains multiple voice items, the
program prompts you to enter the ID of a voice item.
Enter the ID of the appropriate voice item, and then
press number sign (#).

Select another voice item

1. Press 6.

2. Enter the ID of the voice item, and then press number
sign (#).

Select another application

1. Press 81.

2. Enter the ID of the application, and then press number
sign (#).

Record voice items

1. Press 5.

2. Speak clearly to record your message.

3. Press number sign (#).

4. To listen to the recording, press 2.

5. To re-record, follow steps 1 to 3.

6. To delete the recording, press 76.
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Action Steps

Change the telset maintenance
password 1. Press 84.

2. Enter the old password, and then press number sign
(#).

3. Enter the new password, and then press number sign
(#).

4. Enter the new password again, and then press
number sign (#).

Note: The minimum length for a password is defined in the
Security section of CallPilot Manager.

Exit Voice Item Maintenance Press 83.

Next steps
If you want to save changes to your application before you proceed to the
next lesson, choose File →Save. For details about saving applications, see
"Saving and closing applications" (page 119).

When you are ready to continue, the next step is to add fax items to your
application. See Chapter 7 "Working with fax items" (page 91)

If you want to skip the next few lessons for now, you can learn how to set up
a completed application as a service. See Chapter 10 "Putting applications
into service" (page 123).
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Chapter 7
Working with fax items

In this chapter
"Section A: About fax items" (page 91)

"What are fax items?" (page 92)

"Fax block interactions" (page 94)

"Using faxes created for Meridian Mail Voice Services" (page 94)

"Section B: Lesson -- Creating a fax application" (page 95)

"The fax-on-demand application" (page 96)

"Creating the fax files" (page 96)

"Creating the fax-on-demand application" (page 98)

"Adding Fax Select blocks" (page 100)

"Adding a Fax Send block" (page 103)

"Working with fax items" (page 104)

"Next steps" (page 109)

Section A: About fax items

In this section
"What are fax items?" (page 92)

"Fax block interactions" (page 94)
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"Using faxes created for Meridian Mail Voice Services" (page 94)

What are fax items?
If your CallPilot system includes fax messaging, you can make faxes
available from your applications. For example, you can allow callers to
request a map of your location, a price list, or a list of frequently asked
questions.

A fax item consists of two parts:

• fax file

• confirmation prompt-- A voice recording that gives callers information
about a fax.

Example:
"List of weekly specials for SuperValue Grocery."

Note: If the confirmation prompt is not recorded, it does not play.
However, if it is recorded and contains only background noise, it does
play.

Fax items are stored on the server. They are accessed from any client
computer that has a connection to the server, or remotely with Fax Item
Maintenance.

Each fax item within an application has a unique identifying number in
the range from 1 to 3000. (You can use the same ID in two different
applications.)

Adding fax capability to applications
To add fax options to your applications, you use the following blocks:

• Fax Select--Allows a caller to select the associated fax item for same-call
or callback delivery.

• Fax Send--Delivers selected faxes through same-call or callback
delivery.

Note: Selected faxes are automatically delivered when an error occurs
in the application, when the caller hangs up, or when the application
encounters one of the following blocks:

• Call Transfer

• End

• Thru-Dial

• system blocks (Express Voice Messaging, Express Fax Messaging,
Fax Item Maintenance, and so on)
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The session profile
To include fax items in any application, define fax options in the session
profile for the application (see "Setting up the session profile for applications"
(page 124)). The session profile determines how many faxes callers can
request during one call and how the system delivers those faxes.

Maximum number of faxes per call
In the session profile, specify both the maximum number of faxes and
the maximum number of fax pages that a caller can receive during one
call. When a caller reaches the first maximum number in an application, a
warning message plays and the application takes the caller to the next block.

Types of fax delivery
In the session profile, you also configure the type of fax delivery the system
uses:

• same-call delivery

With same-call delivery, the caller--who must be at a fax phone--receives
faxes after selecting them. Same-call delivery avoids billing problems
because the caller pays any long distance charges.

• callback delivery

With callback delivery, the caller provides a fax number to which the
system delivers faxes. This callback number must be validated against
the restriction/permission list, which you also configure in the session
profile. For example, a restriction can prevent the system from calling
back a long-distance fax number.

• delivery choice of caller

With delivery choice of caller, the system prompts callers to indicate
whether they want either same-call or callback delivery.

Online updating
All changes that you make to an application take effect as soon as you
save the application. However, callers who are currently connected to the
application continue to interact with the previously saved version. Only new
callers interact with the new version.

Example
You maintain applications for a company that sells swimming pools and
supplies. One night, your supervisor calls you at home and asks you to
update the fax that lists available chemicals immediately, because the
sales representatives are at a conference and need the information. Your
supervisor faxes you the updated list.

You call Fax Item Maintenance. You identify the application and the fax item
by ID. Then, you scan the updated list into the item.
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While you scan the fax, a sales representative calls the application to get
the list. You save the fax item and the application before he selects the
list. However, he receives the out-of-date list because he accessed the
application while you were editing it, but before it was saved.

The sales representative calls to ask why the list is not updated. You
explain that he did not get an updated list because he called while you were
making the changes. After the new list is available, you can advise all sales
representatives to pick up the new list.

Fax block interactions
Fax Select block and default fax delivery

If faxes are selected with a Fax Select block, but not delivered by a Fax Send
block, automatic fax delivery occurs when one of the following events occurs:

• the caller hangs up

• an error occurs in the application

• the application encounters one of the following blocks:

— Transfer

— End

— Thru-Dial

— system blocks (Express Voice Messaging, Express Fax Messaging,
Fax Item Maintenance, and so on)

Using faxes created for Meridian Mail Voice Services
You can migrate the following items to Application Builder from faxes created
for Meridian Mail Voice Services:

• announcements

• fax items

• menus

Contents of a fax item
Each fax item from Voice Services contains:

• a fax

• a confirmation prompt
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How to identify migrated fax items
All faxes migrated from Meridian Mail Voice Services are identified by
names beginning with the prefix "FAX" followed by a Voice Services ID.
For example, a Voice Services fax with an ID of 66 appears as "FAX66" in
Application Builder. The description of the application is "Migrated from
Fax Service 66."

Within that file, you see the fax item with both a name and an ID (for
example, FaxItem 1000).

Format of migrated faxes
In Application Builder, a migrated fax is in the same format as fax items.

Access
On the server, you access migrated faxes in the same way that you access
fax items.

Use
You can use migrated faxes in any application that has fax functionality.

Applications that contain migrated faxes
You can use migrated faxes in new applications and in rebuilt applications
that existed in Meridian Mail Voice Services. Consider when to build both
types of applications.

New applications
You can create new applications that use migrated faxes either before or
after the fax is migrated from Voice Services.

Rebuilt applications
You can rebuild applications that use migrated faxes either before or after
the fax is migrated from Voice Services.

You can do everything at once if you rebuild applications after migration. You
can paste the fax into the applications during creation. Also, the migrated
fax can help you remember what to rebuild.

Section B: Lesson -- Creating a fax application

In this section
"The fax-on-demand application" (page 96)

"Creating the fax files" (page 96)

"Creating the fax-on-demand application" (page 98)
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"Adding Fax Select blocks" (page 100)

"Adding a Fax Send block" (page 103)

"Working with fax items" (page 104)

"Next steps" (page 109)

The fax-on-demand application
This lesson demonstrates the fax feature by showing you how to create
a fax-on-demand application for SuperValue Grocery store. The store
decides to add a fax-on-demand option to its menu, which allows customers
to request either:

• a map showing the location of the store

• a list of specials for the current week

The following illustration shows the application:

With a menu, callers can choose the fax item that they want. After a caller
selects a fax item, the Fax Send block delivers it.

Creating the fax files
The fax file that callers can request must be in tagged image file format,
class F (TIFF-F). No other TIFF formats are supported. TIFF is an image
format; even fax files containing only text are still considered to be images.
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You can create a fax file in one of the following ways:

• Use the Print command in your application to output the file in TIFF-F
format.

During installation of CallPilot Desktop Messaging, a fax printer driver
installs on the client computer. The name of this printer driver is
Nortel Networks Fax. When you print a document to this printer, your
application creates a TIFF file.

• Use Fax Item Maintenance and a fax phone to scan the document into a
file. (For more information about scanning, see 'Scan a document into
a fax file' on page 158.) The fax item must be created in Application
Builder.

Guidelines for fax items
Include a logo
To help callers recognize and become familiar with your organization,
include your logo on a cover page.

Include a cover page
Use a cover page to communicate essential information and company
identity. You can send a custom cover page with all fax deliveries.

Use the header
The header, or trimtab, of a fax can contain useful information for recipients.
For example, the number of the sending fax machine can appear in the
header. Recipients can refer to this number if a transmission error occurs.

Formatting tips

• Leave large margins, especially at the top and bottom of fax pages. This
ensures that information does not get cut off during transmission.

• Select a typeface that is easy to read. Avoid decorative typefaces. Do
not use a font size smaller than nine points.

• Do a spell check on all faxes to ensure that they do not contain any
errors. Spelling errors make your organization appear unprofessional.

To save a file as a fax

Step Action

1 Open the document in the appropriate application.

Example: Your Map document is in Microsoft Word format, so open
it in Word.

2 Choose File → Print.
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3 From the list of printers, select Nortel Fax.

4 Click Print or OK.

Result: The Compose Fax window appears.

5 To add another document to the fax file, repeat steps 1 to 4.

6 Click Compose Fax to maximize the window.

7 To view the fax in your fax viewer software, select it in the Item list,
and then click View/Edit Image. When you are finished, choose
File → Exit.

8 To delete a file, select it, and then click Remove Item.

9 To scroll up and down the list of files, click Move Forward and
Move Backward.

10 Click Save As.

11 From the Save as type list, select TIFF-F Files (*.tif).

12 In the File name box, type a name for the fax.

13 From the Save list, select the directory in which you want to save
the fax.

14 Click Save.

—End—

Creating the fax-on-demand application
First, create the new application in Application Builder, and then add the
Menu block.

To add the Menu block

Step Action

1 Create a new application, as you did in Chapter 4 "Creating an
application" (page 29).

Result: The new application appears in the Application Builder
application window.

2 Drag the Menu block from the palette to the application window.

Result: The Add Menu Block dialog box appears.
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3 Enter a name for the block (for example, FaxMenu), and then click
OK.

Note: The name of the block must adhere to the naming
convention rules for blocks. For more information about naming
convention rules, see "Naming conventions for blocks" (page 41).

Result: The Menu block is added to the window. The block border
and the outputs are pink.

4 To configure the block, double-click it.

Result: The properties dialog box appears.

5 To create a new custom voice item for the Menu choices greeting,
in the Menu choices greeting box, select <new voice item>, and
then click New.

6 Complete the Add voice item dialog box, and then click Done.

Result: The Edit voice item content dialog box appears.

7 Do not add the content at this time. Click OK.

8 Complete the Parameters tab, and then click OK.
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9 Hide the menu key outputs that you are not using. For outputs 3 to
9, right-click the Menu block, point to Hide/Show Outputs, and then
click the output number.

10 Hide the Rotary output. Right-click the menu block, and then choose
Hide/Show Outputs → Rotary.

Note: Because you import this application into the automated
attendant application, this block is not the first block that requires
user interaction.

11 Connect the Cancel output to the End block, using the right mouse
button.

12 Connect the Attendant, No response, and Invalid outputs to the
Attendant block.

—End—

What to do next
Record or import the content for the menu choices greeting. For more
information about voice items, see Chapter 6 "Working with voice items"
(page 75).

Adding Fax Select blocks
Add a Fax Select block for each fax item that callers can select. For your
sample application, you must add two Fax Select blocks.
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To add a Fax Select block

Step Action

1 Drag the Fax Select block from the palette to the application window.

Result: The Add Fax Select Block dialog box appears.

2 Enter a name for the block (for example, Map), and then click OK.

Note: The name of the block must adhere to the naming
convention rules for blocks. For more information about naming
convention rules, see "Naming conventions for blocks" (page 41).

Result: The Fax Select block is added to the window. The block
border and the outputs are pink.

3 To configure the block, double-click it.

Result: The properties dialog box appears.

4 To create a new fax item, in the Fax Item box, select <new fax
item>, and then click New.

5 Complete the Add fax item dialog box, and then click Done.

Result: The Edit fax item content dialog box appears.
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6 To import a fax file, follow these steps:

a. In the Fax item content section, click Import.

b. Browse to the path in which you saved the fax file, and then
select it.

c. Click Open.

7 To record a confirmation prompt, follow these steps:

a. Click Record.

b. In the Specify Phoneset box, type the phone number of the
phone you want to use for recording, and then click OK.

Result: The Application Builder Player window appears.

c. Click Record.

d. Answer the phone when it rings.

e. Say the content of the confirmation prompt, and then click Stop.

f. Click Play to listen to the recording.

g. If you do not like the recording, record over it.

h. When you are satisfied with your recording, press Save. Hang
up the telephone, and then close Application Builder Player.

8 Complete the Parameters tab, and then click OK.
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9 Connect the Attendant, Max Selections, and No response outputs to
the Attendant block.

10 Repeat steps 1 to 9 to add, configure, and connect a Fax Select
block for the Weekday Specials fax.

—End—

Adding a Fax Send block
The Fax Send block sends all faxes selected in the Fax Select blocks. You
must add a Fax Send to your application.

Note: Selected faxes are automatically delivered when an error occurs
in the application, when the caller hangs up, or when the application
encounters one of the following blocks:

• Call Transfer

• End

• Thru-Dial

• system blocks (Express Voice Messaging, Express Fax Messaging,
Fax Item Maintenance, and so on)

To add a Fax Send block

Step Action

1 Drag the Fax Send block from the palette to the application window.
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Result: The Add Fax Send Block dialog box appears.

2 Enter a name for the block (for example, SendFax), and then click
OK.

Note: The name of the block must adhere to the naming
convention rules for blocks. For more information about naming
convention rules, see "Naming conventions for blocks" (page 41).

Result: The Fax Send block is added to the window. The
block border and the No faxes selected output are pink. The
Sent/Submitted output is automatically connected to the End block.

3 Connect both of the Fax Select blocks to the Fax Send block. To do
so, hold the Shift key and left-click the Done output for the Map and
Specials blocks. Then, left-click the Fax Send block.

4 Connect the No faxes output of the Fax Send block to the Fax Menu
block. (If callers do not select a fax, the application returns them
to the menu.)

—End—

Your fax-back application is now complete. In the next chapter, you export
this application and import it into your automated attendant application.

Working with fax items
You can work with your fax items using either Application Builder or Fax
Item Maintenance. This section lists the fax item maintenance procedures
you can perform.

Using Application Builder

Action Steps

Edit the name or
description of a fax item 1. Choose Define → Fax items.

2. Select the fax item, and then click Edit.

3. Make the desired changes, and then click Done.
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Action Steps

Delete fax items

1. Choose Define → Fax items.

2. Select the fax item.

3. Click Delete.

Note: You cannot delete a fax item that is used by an application.

Delete an existing
confirmation prompt for
a fax

1. Choose Define → Fax items.

2. Select the fax item, and then click Edit.

3. Click Reset.

Copy a fax item to the
clipboard 1. Choose Define → Fax items.

2. Select the fax item you want to copy.

3. Click Copy.

Note: When you copy a block from one application to another, any
associated fax items are also copied to the destination application.

Paste a fax item from the
clipboard into the current
application window

1. Choose Define → Fax items.

2. Click Paste.

3. If the application contains a fax item with the same name or ID
as the fax item you paste, Application Builder prompts you to
resolve the name or ID conflicts. You can accept the new name
and ID assigned by Application Builder, or specify your own.

Print a list of all voice and
fax items

Choose File → Print Voice/Fax Items.
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Using Fax Item Maintenance
With Fax Item Maintenance, you can maintain your fax items from a remote
location, using a phoneset.

Before you use Fax Item Maintenance (FIM) to maintain the fax items in
an application, you must define a telset maintenance password for the
application. You can allow Fax Item Maintenance users to:

• change the fax confirmation prompts

If you want to use the same voice for all prompts, you can disable this
option.

• change the fax verification number

The fax verification number is the phone number of the fax machine
to which Fax Item Maintenance sends a copy of the document just
scanned for a fax item. Make sure Fax Item Maintenance users can
change the fax verification number if they use fax machines other than
the one indicated on the Security tab.

To use Fax Item Maintenance, you must know:

• the service directory number (SDN) for the Fax Item Maintenance
service

• the ID of the application containing the fax item you want to work with

• the telset maintenance password

• the ID of the fax item

To configure Fax Item Maintenance

Step Action

1 In Application Builder, open the application for which you want to
use Fax Item Maintenance.

2 Choose File → Properties.

3 Click the Security tab.
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4 Click OK.

5 Save and close the application.

Note: The minimum length for a password is defined in the
Security Administration program.

—End—

Tasks in Fax Item Maintenance
You can perform the following tasks with Fax Item Maintenance:

Note: To scan a document into a fax file, you must access Fax Item
Maintenance from a fax phone.

Action Steps

Log on to Fax Item
Maintenance 1. Dial Fax Item Maintenance.

2. Enter the ID of the application that you want to edit, and then
press number sign (#).

3. Enter the telset maintenance password for the application, and
then press number sign (#).

4. If the application contains multiple fax items, the program
prompts you to enter the ID of a fax item. Enter the ID of the
appropriate fax item, and then press number sign (#).
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Action Steps

Select another fax item

1. Press 6.

2. Enter the ID of the fax item, and then press number sign (#).

Select another application

1. Press 81.

2. Enter the ID of the application, and then press number sign (#).

Record confirmation
prompts 1. Press 5.

2. Speak clearly to record the prompt.

3. Press number sign (#).

4. To listen to the prompt, press 2.

5. To delete the prompt, press 76.

Scan a document into a fax
file

Note: Fax Item Maintenance ends after the document is scanned.
Therefore, if you want to perform another task, such as change the
item’s confirmation, you can do so before you scan the document.

1. Press 9.

2. To send the fax to the default fax verification number, press
number sign (#), press 1, and then go to step 5.

3. To send the fax to a fax verification number other than the
default, press number sign (#), next press 2, and then go to
step 4.

Note: This option is only available if the Allow modification of fax
verification number from telset box option is enabled. To check the
setting, choose File → Properties, and then select the Securities tab.

4. Enter the new number, and then press number sign (#).

5.

6. Put the document in the fax machine.

7. Press the Send key on the fax machine.

Result: The fax transmits and Fax Item Maintenance ends.
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Action Steps

If a document does not scan properly, then Fax Item
Maintenance sends an error message rather than a verification
fax to the fax verification number.

Change the telset
maintenance password 1. Press 84.

2. Enter the old password, and then press number sign (#).

3. Enter the new password, and then press number sign (#).

4. Enter the new password again, and then press number sign (#).

Note: The minimum length for a password is defined in the Security
Administration program.

Exit Fax Item Maintenance Press 83.

Next steps
If you want to save changes to your application before you proceed to the
next lesson, choose File →Save. For details about saving applications, see
"Saving and closing applications" (page 119).

When your fax-on-demand application is complete, you can integrate it
with the automated attendant application that you worked with in previous
lessons. See Chapter 8 "Integrating applications" (page 111)

If you want to skip the lesson about integrating applications for now, you can
learn how to set up a completed application as a service. See Chapter 10
"Putting applications into service" (page 123).
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Chapter 8
Integrating applications

In this chapter
"Section A: About integrating applications" (page 111)

"Sharing call functions" (page 111)

"Section B: Lesson -- Integrating applications" (page 113)

"Exporting an application" (page 113)

"Importing an application" (page 114)

"Next steps" (page 115)

Section A: About integrating applications

In this section
"Sharing call functions" (page 111)

Sharing call functions
Sometimes you need to reuse part of an application regularly. Two options
are available to reuse parts of an application:

• copy the required functions--You can copy sections of an application
and paste them into another application. Use this method if you need to
reuse a few simple blocks, or if you want to copy a set of functions that
you cannot save as a separate, complete application.

• import an application that performs the required functions--You can
import an entire application into another application. With this option,
you can share a set of call functions between multiple applications, but
maintain the call functions in one place. When you design complex
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applications, save components that you can reuse as imported
applications.

Imported application example
You need to use an automated attendant in various applications. Instead of
recreating this functionality every time you need it, create one automated
attendant application with the following blocks:

• Day Control

• Time Control

• Announcement

• Menu

• Thru-Dial

• Call Transfer

You configure the Day Control block as follows:

• On non-business days, callers hear an announcement that lists business
days and hours.

• On business days, it routes callers to the Time Control block.

You configure the Time Control block as follows:

• Before and after business hours, callers hear an announcement that lists
business days and hours.

• During business hours, callers go to the Menu block.

You configure the Menu block so callers hear a greeting that gives them
two options:

Hello. Thanks for calling Oswald Law Offices. If you know the extension of
the person you want to reach, press 1. If you don’t know the extension,
press 2.

You connect the Thru-Dial block to the number 1 menu key. Then, callers
can dial people only by number. You connect the Call Transfer block to the
number 2 menu key. You also configure this block to pass callers to a live
attendant. As a result, callers reach someone who can direct their calls
to the appropriate people.

After you complete the application, you save it as "Attendant" and export it.
Whenever you need to add an automated attendant to another application,
you import "Attendant."
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Section B: Lesson -- Integrating applications

In this section
"Exporting an application" (page 113)

"Importing an application" (page 114)

"Next steps" (page 115)

Exporting an application
This lesson demonstrates the import/export feature by showing you how
to import your fax-on-demand application into the automated attendant
for SuperValue Grocery. The first step is to export your fax-on-demand
application.

To export the fax-on-demand application

Step Action

1 In Application Builder, open the source application (Fax) that you
created in "Section B: Lesson -- Creating a fax application" (page
95).

2 Choose File → Export.

Result: A Continue block appears in the application. This block
returns callers from the fax-on-demand application to the importing
application (in this case the automated attendant application). At
least one output in your fax-on-demand application must connect to
this block.

3 Connect the Cancel output for the Menu block to the Continue block.
(If callers cancel out of the Fax-on-demand menu, they return to the
automated attendant application.)

4 To verify that the application is exported, choose File → Properties.
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5 Click OK, and then save and close the application.

—End—

Importing an application
After you export the application, you can import it into the destination
application. In this section, you import the fax-on-demand application into
your automated attendant. You also modify the MainMenu block to allow
callers to access the fax-on-demand menu.

To import an application

Step Action

1 Open the destination application (AutoAttendant).

2 Choose File → Import.

3 Select the application to be imported (Fax), and then click Import.

Result: The imported application block (Fax.1001) appears in the
Imported Applications palette.

4 Drag the imported application block into the application window.

5 Connect the Continue output to the MainMenu block. (If callers press
Cancel in the menu for the fax-on-demand application, they return to
the Main Menu in the automated attendant application.)

6 To add the fax-on-demand option to the MainMenu, right-click the
MainMenu block, and then choose Hide/Show Outputs → 5.

Result: output 5 appears.

7 Connect output 5 to the imported application block.

8 Save and close the application.

—End—

What to do next
You must create new content for the Menu voice item. Update the menu to
include the following option:

To request a fax using our fax-on-demand system, press 5.
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For information about editing voice items, see "Recording a voice item"
(page 83).

Next steps
When your applications are complete, you can set them up as a service.
See Chapter 10 "Putting applications into service" (page 123).
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Chapter 9
Saving applications

In this chapter
"Ensuring that an application is complete" (page 117)

"How Application Builder stores files" (page 118)

"Saving and closing applications" (page 119)

Ensuring that an application is complete
An application is complete when you connect and configure all the blocks
in your application. If you still need to connect or configure a block, a pink
border appears around the block.

You must complete an application before you can:

• make it available as a service

• export it so that you can integrate it with other applications

To verify that an application is complete

Step Action

1 Choose File → Properties.

2 Click the General tab. If the Complete box contains "Yes," you can
export or import the application.

3 Click OK.

—End—

Nortel CallPilot
Application Builder Guide

NN44200-102 01.02 Standard
5.0 12 April 2007

Copyright © 2007, Nortel Networks

.



118 Chapter 9 Saving applications

How Application Builder stores files
When you create an application in Application Builder, the application is
stored on the client computer. When you save the application, Application
Builder copies it to the server. However, the application remains locked until
you close it. When an application is locked, other administrators cannot
access it. This ensures that changes you make are not overwritten by
another administrator.

Similarly, when you open an application in Application Builder, the program
locks it, and creates a copy on the client computer. When you save your
changes, Application Builder copies the application from the client computer
to the server, but it remains locked. When you close the application,
Application Builder unlocks it so that it is available to other administrators.
At this point, an administrator on another computer or at another site can
maintain your applications.

Example
Client 25 has Application 2051 open, Client 12 has Application 1020 open,
and Client 3 has Application 2050 open. Therefore, Client 8 cannot access
Application 2051, Application 2050, or Application 1020.
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To view a list of locked applications
Choose File → Locks.

Result: The list of locked applications appears.

Saving and closing applications
After you create or change an application, you must save it. When you save
an application, Application Builder copies it from the client computer to
the server. If you enable Auto Save, Application Builder can automatically
save changes to your application on your local computer at a specified
interval. Changes are not transferred to the server until you manually save
the application.
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ATTENTION
If the user attempts to save the 501st application on volume one, an error dialog
box appears.

Only 500 applications can be saved on the first volume, 1000 applications on the
second volume, and 1000 applications on the third volume.

Complete and incomplete applications
An application is complete when all the blocks are connected and
configured. You can save an application if it is not complete, but you cannot
make it available to callers as a service or export it until it is complete.

To verify whether an application is complete
Choose File → Properties, and check the Complete box on the General
tab. If "Yes" appears in the box, the application is complete.

To enable Auto Save

Step Action

1 Choose Options → Auto Save Options.

Result:The Application Auto Save dialog box appears.

2 In the Save application every...minutes box, specify how often to
save the application, and then click OK.

—End—

To manually save an application
When you complete the automated attendant application, you must save it.
This procedure assumes that your application is open in Application Builder.

Choose File → Save.

To close an application
When you are finished working with the automated attendant application,
you must close it. When you close an application, Application Builder
unlocks it so that others can access it and make changes to it.

Choose File → Close.

If you did not save the application, you are prompted to save it now.
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Where to go from here
If all of the fax items and voice items (prompts and announcements)
required for your application exist, you can put the application into service
(see Chapter 10 "Putting applications into service" (page 123)).
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Chapter 10
Putting applications into service

In this chapter
"How applications become services" (page 123)

"Setting up the session profile for applications" (page 124)

"Using a cover page for fax services" (page 127)

"Testing applications" (page 128)

How applications become services
When you work on a new application in Application Builder, it is unavailable
to callers. To make the application available to callers, you must put it into
service.

After the new application is complete, you add it to the Service Directory
Number (SDN) Table so that you can test it, and then make it available as a
service that callers can dial. An application becomes a service when you
add a service directory number for that application to the SDN Table.

This chapter describes the process of setting up and testing your application
as a service.

Requirements
Before you can make an application available, ensure it is complete--that is,
make sure all of its blocks are connected and configured. If a pink border
appears around a block, you still need to configure or connect it. Save the
application after it is complete.

To verify whether an application is complete
Choose File → Properties, and check the Complete box on the General
tab. If "Yes" appears in the box, the application is complete.
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Main steps
To put an application into service

1. Add the application to the Service Directory Number (SDN) Table to
make it available to callers. For information about working with the SDN
Table, refer to the CallPilot Manager online Help.

2. Configure the application’s session profile. The session profile
determines how the application behaves (for example, the type of fax
delivery it supports). For more information about session profiles, see
"Setting up the session profile for applications" (page 124).

3. Test the application from the caller’s perspective to ensure that the call
flow works as you intended. For more information about testing, see
"Testing applications" (page 128).

4. After you are finished your testing, publish the dialing number for the
service.

How callers are routed to services
When you route callers through your application, keep in mind calls are
routed from the switch to services. Also consider how you configure the
SDN Table and SDNs.

Each CallPilot service that callers access by dialing a number needs
an SDN in the SDN Table. You must know what SDNs are, and how to
configure them, to control the channels that are allocated to services.

Setting up the session profile for applications
Some SDNs require additional configuration. You configure a session profile
for all SDNs associated with Application Builder services.

This section describes the options that are available in the session profile.
For information on configuring the session profile, see the Administrator’s
Guide (NN44200-601).

What is a session profile?
A session profile is a set of operational characteristics associated with
the SDN of certain CallPilot services, including the services created in
Application Builder. The session profile determines how a service behaves
when it is called, and the length of time that callers can use the service.

Multiple session profiles for one service
The session profile determines the behavior of a service on a per-SDN
basis. You can enter the same service into the SDN Table more than once,
with a different SDN for each entry. As well, you can configure the session
profile of each SDN differently. Consequently, the same service can behave
differently based on the SDN that callers dial.
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Example 1
You have a service that contains fax items. In the SDN Table, add two SDNs
for the service. Because you know that some callers can call the service
from fax phones, configure the first SDN’s session profile to use same-call
delivery. Configure the second SDN’s session profile to use callback
delivery, because other callers can access the service only from a phoneset.

Example 2
Your company’s corporate directory appears in two services. The first
service is a main menu from which external callers access the directory.
The second service is the directory that employees access. Each service
has its own SDN and, therefore, its own session profile. For the first service,
configure a lower number of maximum invalid selections. You do so for
security reasons. For the second service, configure a higher number of
maximum invalid selections. Security is less of an issue where internal
callers are concerned. Also, to ensure security, give the external callers’
service a shorter session limit than the employees’ service.

What the session profile controls
The session profile affects all Application Builder services. In particular, it
affects the following blocks: Fax Select, Fax Send, and Menu. You must
configure more session profile options for services with fax capability.

All Application Builder services
For all Application Builder services, the session profile determines the
following aspects:

• the maximum length of a call session

• the maximum number of password failures allowed for services
that contain the Password Check block and, therefore, have
password-protected content

Application Builder services with fax capability
To include fax items in an application, define the application’s fax options
in the session profile of the SDN Table. In the session profile, establish
settings for all fax applications and other settings that are specific to fax
applications that use callback delivery.

For all fax applications
In the session profile, establish the following settings for all fax applications:

• the maximum number of faxes a caller can select during one call

• the maximum number of fax pages that the system delivers to a caller
during one call

• the telephone number of the fax machine that the system uses to send
faxes
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• the fax delivery method (callback, same-call, caller’s choice)

• whether a custom cover page, called a sponsor fax item, transmits with
each fax

• how page transmission errors are handled

For fax applications that use callback delivery
In the session profile, you also establish the following settings for fax
applications that use callback delivery:

• the DN to which fax callback transmissions are billed

• whether the system cover page transmits with each fax

• whether to prompt the caller for the extension number of the recipient of
the fax

• the type (for example, national) of fax phone number for which the
system must prompt callers so it knows where to deliver faxes

• the restriction/permission list against which the fax phone number must
be validated before the system can make a fax callback transmission

Types of fax delivery
For services with fax capability, in the session profile, configure which type
of fax delivery the system uses:

• same-call

• callback

• caller’s choice

Same-call delivery
With same-call delivery, the caller--who must be at a fax phone--receives
faxes after selecting them. Same-call delivery avoids billing problems,
because the caller pays any long-distance charges.

Callback delivery
Configure callback delivery if callers access fax applications from a
phoneset. With callback delivery, the caller provides the number of a fax
phone to which the system delivers faxes.

If you configure callback delivery for services with fax capability, then you
must configure callback handling. This ensures that callers are prompted
to enter callback numbers in the appropriate format based on where they
are calling from. Each callback number must be validated against the RPL,
which you configure in the session profile. For example, a restriction can
prevent the system from calling back an international fax phone number.
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Delivery choice of caller
With delivery choice of caller, the system prompts callers to indicate if they
want either same-call or callback delivery.

Using a cover page for fax services
Two types of cover pages are available to send with each fax: a system
cover page, and a custom cover page (also called a sponsor fax). You
configure both of these options when you configure the SDN.

You configure whether a system cover page sends with those faxes on
the Callback Handling tab.

You configure the information that appears on the custom cover page on the
Session Profile tab. The custom cover page is included with all your faxes.

For more information about fax services, see the Administrator’s Guide
(NN44200-601).

What information appears on the two cover pages
System cover page
The system cover page contains information defined by the system, and
sends only with callback fax transmissions.

On a system cover page, the system automatically generates the following
information:

• (optional) the caller’s extension number

The system puts this number on the page only if you configure the
callback handling to prompt the caller for his or her extension.

• the number of the fax machine entered by the caller

• the sender’s name and address

This information is entered in the session profile.

• the total number of pages sent (including the cover page)

• the date and time the fax was submitted by the system for delivery

• instructions that the recipient can request the information again from the
service if the fax does not transmit properly

Custom cover page
You define all of the information that appears on a custom cover page. This
page transmits with all faxes. Therefore, include all important information
such as your company logo, and the name and number of a contact person.
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A custom cover page is an image file in tagged image file format, class F
(TIFF-F). You can save a file in TIFF-F by using the Nortel Networks Fax
printer driver that installs with CallPilot Desktop Messaging, or by using fax
or graphics software that can create files in TIFF-F format.

For more information about custom cover pages, see the CallPilot Manager
online Help.

Transmission order for cover pages
Both the system and custom cover pages send only if you configure them to
do so. The system cover page always transmits before the custom cover
page. Therefore, if you configure both cover pages and the system sends a
callback fax transmission, the fax transmits in the following order:

1. system cover page

2. custom cover page

3. fax pages

Testing applications
After you build an application and before you publish its SDN to callers, you
must test it. You test an application by interacting with it from a caller’s
perspective.

Why you test
Test an application to access and interact with it from a caller’s perspective
and, by doing so, gain valuable design input. As you test the application,
you can ensure that the application works as you intended.

When to test
You can test an application only after it is complete, and before you publish
its SDN to callers.

What to test
To test an application, put it in the SDN Table, call it, and interact with all of
its flow. For example, if a menu has five options, follow each of those options
through to its end to ensure it works properly. Do the following when you test:

• Give no DTMF response at the beginning of the application to verify
how it handles rotary-dial callers.

• Make no response at various times throughout the application to confirm
that it correctly prompts callers to give input.

• Give incorrect responses at various times throughout the application to
ensure that it correctly directs callers to give input.

• Make enough no responses in the application to check how it handles
time-out periods.
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After you test an application
After you are sure an application has no errors, publish its SDN so that
callers can dial into and use the application.
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Chapter 11
Archiving and restoring applications

In this chapter
"How to archive and restore applications" (page 131)

How to archive and restore applications
Archive applications to preserve their information. You also archive and
restore to move applications from one volume ID or server to another. To
move applications, archive the applications on one volume ID or server, and
then restore them on another volume ID or server.

Archiving applications
You can archive individual applications or archive all applications at once.
To create an Application Builder archive, you can select applications by
name or ID.

You can archive all applications on a regular basis to ensure that you have
a complete backup of your application services. Archiving is particularly
important if you use imported applications. If you restore an application, but
not the imported applications that it contains, Unavailable blocks indicate
the missing components and the restored application becomes unusable.

Restoring applications
You can restore individual applications from an archive or all applications
in an archive. Restore archived applications when you want to transfer
them to another computer, or when you need to recover from data loss.
When you restore the applications, open each one in Application Builder
and save it before you configure it in the SDN Table. When you open an
application, verify that it is complete. If Unavailable blocks appear in the
application, the application is incomplete. For information about fixing
incomplete applications, see the Troubleshooting book in the Application
Builder online Help.
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ATTENTION
Make a backup of your data prior to any upgrade.

See also
For more information about running services on the server and restarting
the server, see the installation guide for your server.

For information about archiving and restoring, see the Administrator’s Guide
(NN44200-601).
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Chapter 12
Troubleshooting

In this chapter
"Diagnosing problems" (page 133)

"Application Builder cannot run" (page 134)

"Client or server crashes" (page 135)

"Calls not answered or system unusually slow" (page 136)

"Troubleshooting application development problems" (page 137)

Diagnosing problems
When you encounter a problem with Application Builder, collect information
to help you identify the source of the problem.

1. Capture any error messages associated with the problem. Capture
screen shots of the error, or record the exact text of error messages
that appear.

2. Save Application Builder log files to a permanent location.

3. Try to reproduce the problem.

Monitoring Application Builder activity
Each time you run Application Builder, two log files trace all Application
Builder errors. These log files are stored on the client computer:

• appbuilderlog.txt

• nmabdlauncherlog.txt

You can specify a monitoring level for these log files.
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To specify monitoring levels
On the Options menu, point to Log Level, and then specify a monitoring level.

Tracking application compilation errors
Application Builder automatically compiles an application when you save
it. If you enable program diagnostics, Application Builder analyzes an
application before compiling it. If Application Builder finds an error in your
application, an error message appears.

Here are a few examples of the errors that Application Builder looks for
when it analyzes an application:

• infinite loops - An infinite loop is created when the call path between
one or more blocks loops back to the first block. This means that calls
that pass through the output cannot leave the block until the call is
disconnected. Infinite loops also consume system resources.

• unreferenced block - An unreferenced block is a block that is not
connected. This means that the functionality of the block is inaccessible
to the caller. To complete an application, all blocks that you want to
include in the application must be properly connected. Remove any
blocks that you do not require.

• incomplete application - You must complete an application before you
can export it or put it into service. An application is complete when all
blocks are properly configured and connected. If a pink border appears
around a block, it is not connected or configured.

You can set the program diagnostic level to Low, Medium, or High. If you
do not want Application Builder to evaluate your applications before saving
them, you can disable program diagnostics.

To specify a program diagnostic level
On the Options menu, point to Program Diagnostics, and then specify a
monitoring level. To disable program diagnostics, choose the None option.

Application Builder cannot run
Application Builder requires services that run on the server. If those services
are not running or if the server crashes, then Application Builder cannot run.

System requirements
Confirm the Application Builder system requirements. For information about
system requirements, see "Installing Application Builder" (page 23).

How to run Application Builder
How you get Application Builder to run depends on whether the server
crashes, a required service crashes, or a required service is not running.
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To run Application Builder after the server crashes

Step Action

1 Restart the server.

2 Run Application Builder.

—End—

To run Application Builder after a required service crashes

Step Action

1 Restart the service.

2 Run Application Builder.

—End—

To run Application Builder after a required service is not running

Step Action

1 On the server, start the service.

2 Run Application Builder.

—End—

Client or server crashes
When you open an application on a client computer, Application Builder
locks it on the server. Any changes you make to that application are stored
in a temporary file on the client until you save the application. When you
save the application, the changes are transferred to the server. If the client
or server crashes while you change an application, the application remains
locked, and any changes you make remain in the temporary file on the client.

When the client and server computers become available again, you can
recover the changes from the temporary file and unlock the application.
If you cannot use the same client computer, you can use another client
computer to unlock the application. However, you lose any changes made
to the application since the last time that the application was saved.
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To recover an application on the client computer that locked the
application

Step Action

1 Run Application Builder.

Result: Application Builder prompts you to confirm that you want to
recover the application.

2 Click Yes.

3 Save the application.

Result: Application Builder transfers the recovered application to
the server.

—End—

To recover an application on another client computer

Step Action

1 Run Application Builder with the mailbox number and password of
the administrator who opened the application.

2 Open the application to recover.

Result: The following prompt appears: Application is
locked. If opened, it can no longer be recovered
from another copy. Do you want to open this
application?

3 Click Yes.

4 Close the application.

Result: Application Builder unlocks the application.

—End—

Calls not answered or system unusually slow
Symptom

Callers encounter ring-no-answer when they access an application, or the
CallPilot system is unusually slow.
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Explanation
The application can contain an infinite loop that uses up system resources.

Solution
Verify that your applications do not contain infinite loops. Infinite loops occur
when you connect a block’s output back to the same block or more blocks
are connected to the first block. Always connect an output from one block to
a different block to ensure that you do not create infinite loops.

If Program Diagnostics are enabled, Application Builder checks for infinite
loops when you save an application. If an application contains infinite
loops, a warning appears that identifies the blocks that you need to properly
connect. Enable Program Diagnostics to detect infinite loop problems.

Infinite loops raise SLEE CPU consumption to abnormally high levels,
resulting in ring-no-answer behavior or system slowdown.

Note: Application Builder does not generate an error if you create an
infinite loop with the Menu block. This situation does not cause the
application to consume system resources because the Menu block must
wait for the caller to make a menu selection.

Troubleshooting application development problems
The Application Builder online Help contains information to help you
troubleshoot problems you can encounter while you design or work with
applications. Topics include:

• restoring blocks that currently appear as Unavailable blocks in an
application

• resolving block, voice item, or fax item name conflicts

To view the troubleshooting information, open the Troubleshooting book in
the Application Builder online Help.

Nortel CallPilot
Application Builder Guide

NN44200-102 01.02 Standard
5.0 12 April 2007

Copyright © 2007, Nortel Networks

.



138 Chapter 12 Troubleshooting

Nortel CallPilot
Application Builder Guide

NN44200-102 01.02 Standard
5.0 12 April 2007

Copyright © 2007, Nortel Networks

.



139

Appendix A
Sample applications

In this appendix
"Section A: Applications for educational institutions" (page 139)

"The University of City main menu" (page 140)

"The University of City English menu" (page 140)

"The Faculty of Arts application" (page 142)

"The Religious Studies department menu" (page 143)

"Section B: Applications for a hospital" (page 144)

"The Mount Sinai Hospital main menu" (page 144)

"The Mount Sinai Hospital menu for nurses" (page 145)

"Section C: Application for a sales company" (page 147)

"The ABC Company main menu" (page 147)

Section A: Applications for educational institutions

In this section
"The University of City main menu" (page 140)

"The University of City English menu" (page 140)

"The Faculty of Arts application" (page 142)

"The Religious Studies department menu" (page 143)
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The University of City main menu
The main menu of the University of City directs calls to the university’s main
telephone number at different times and on different days. Due to the
university’s location, the main menu also supports bilingual callers.

Description of the main menu of university
The main menu directs callers according to the day of the week and the
time of day. After business hours (8:30 a.m. to 5:00 p.m.) and on weekends
and holidays, callers hear an appropriate announcement. During business
hours, they choose to hear the rest of the application in either English or
French.

Two imported applications--an English menu and a French menu--appear
in the main menu. While callers use either imported application, they
can press the Cancel (#) key and return to the main menu to choose a
language. Both imported applications contain the same functions. Their
only difference is language.

The University of City English menu
If callers press 1 or 2 while in the main menu of the University of City, they
go to the English or French menu respectively. The English menu, like the
French menu, directs callers through the various faculties and services
of the university.
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Description of the English menu of the university
With the English menu, callers can:

• dial staff by name or number

• transfer to such services as the bookstore

• select another menu that directs them to one of the six faculties

Callers transfer to the faculty of their choice. If any transfer fails, callers hear
an explanation before the application ends.

The English menu anticipates which keys, other than the menu keys, callers
can press. If callers press the Cancel (#) key, they return to the main menu
and the Menu block named "language." If they press the Help (*) key,
they hear detailed instructions about what they can do. If they press the
Attendant (0) key, they transfer to an attendant. Callers also transfer to an
attendant if they do not respond or if they make too many invalid choices.
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The Faculty of Arts application
If callers press 2 while in the Menu block named "faculties" of the English
menu, they transfer to the Faculty of Arts. The faculty’s application directs
callers to one of nine departments.

Description of the Faculty of Arts application
From the Menu block called "departments," callers can transfer to one
of the following departments: Anthropology, English, Fine Arts, History,
Philosophy, Psychology, Language, Religious Studies, and Women’s
Studies. Each department has its own phone number. If any transfer fails,
callers hear an explanation before the application ends.

Like the English menu, the Arts application anticipates which keys other
than the menu keys that callers can press. If callers press the Help (*) key,
they hear detailed instructions about what they can do. If callers press the
Attendant (0) key, they are transferred to an attendant. They also transfer to
an attendant if they do not respond or if they make too many invalid choices.
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The Religious Studies department menu
From the Faculty of Arts application, you can transfer to the Religious
Studies department. The Religious Studies department observes the
University of City’s holidays, but it also observes holidays for each of the
four religions of study: Christianity, Judaism, Islam, and Hinduism. The
application for the department must direct callers appropriately on either
a university or a religious holiday.

Description of the Religious Studies department menu
Because callers can dial the Religious Studies department directly, the
application routes callers in the same way that the University of City’s main
menu does for business hours, non business hours, and university holidays.

The Religious Studies Department also directs callers on religious holidays.
During business hours and on religious holidays that do not coincide
with university holidays, callers reach the department’s secretary. Before
callers transfer to one of the department’s four professors, the menu
checks whether the day is a holiday. If it is a holiday, callers transfer to the
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department mailbox where they leave a message. All the professors use
the mailbox. If the day is not a holiday, callers transfer to the professor for
the selected religion.

Callers also transfer to the department mailbox if any transfer fails or a
line is busy.

Section B: Applications for a hospital

In this section
"The Mount Sinai Hospital main menu" (page 144)

"The Mount Sinai Hospital menu for nurses" (page 145)

The Mount Sinai Hospital main menu
The main menu of Mount Sinai Hospital directs calls from both external
callers and staff. The application contains two distinct flows. The flow for
staff is password protected.
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Description of the main menu of the hospital
The Mount Sinai Hospital main menu greets callers and directs external
callers to press 1 and staff to press 2. Because staff need access to
different information, they must enter a password to identify themselves
before hearing their options.

After external callers press 1, they can choose to dial a patient by extension
number or a staff member by extension number or name. As well, they can
choose to hear a list of departments in the hospital. All of the departmental
information, which is made up of many menus, is in an imported application.

After staff enter a password that identifies them as a doctor or a nurse, they
are passed to the appropriate imported application. Both the application for
doctors and the application for nurses contain similar functionality.

Throughout the application, callers press the Attendant (0), Help (*), and
Cancel (#) keys. In the application, invalid choices and no responses pass
to an attendant.

The Mount Sinai Hospital menu for nurses
If Mount Sinai staff members enter the password for nurses in the main
menu, they pass to the imported application titled "nurses." This application
contains more Menu blocks. The application also represents the types
of options available in the "doctors" imported application. The "nurses"
application ensures that nursing staff can retrieve and communicate
essential information.
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Description of the menu for nurses
From their menu, nurses can access their mailboxes and leave messages
for other staff members using Express Voice Messaging. They can also
hear an announcement that highlights daily information, such as a staff
shortage in a particular department. Nurses can call from a faxphone and
retrieve the weekly schedule for a department by fax.

Because nurses use the menu daily, no Help is provided. However, if nurses
make too many invalid choices, do not respond, or press the Attendant (0)
key, the system passes the call to the attendant.

If nurses press the Cancel (#) key while in the Menu block titled "choices,"
they go to the Menu block titled "external callers" in the main menu
application. From the main menu, they can dial staff members.
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Section C: Application for a sales company

In this section
"The ABC Company main menu" (page 147)

The ABC Company main menu
Customers call the main menu of ABC Company to receive product
information or speak to staff. Staff often call the menu to place toll-free calls
when they are on the road. Through the main menu customers can access
various types of Thru-Dials, and different information.

Description of main menu of ABC Company
The first Menu block, "mainmenu", greets callers and ensures that they
identify themselves as either customers or staff. Customers are directed
to a list of options. Staff must enter a password to use their area of the
application.
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The application presents customers with two options: to contact staff
members by dialing their extension numbers or names, or to retrieve a list of
ABC Company’s products.

After staff enter their password, they choose between two options. They can
receive one of the various lists of information. Like customers, staff can
obtain a product list. However, their product list contains more sensitive
information, such as wholesale prices and the names of third-party
manufacturers. Staff can also retrieve information about inventory and
customers.

As their second option, staff can dial a number. Before they dial the
number, they enter a password that determines the type of Thru-Dial they
are allowed. For example, salespeople can make only local calls while the
manager can make international calls.

Both the customer and staff menus let callers dial an attendant or reach
an attendant if they make too many invalid choices or do not respond.
Unlike the staff menu, the customer menu gives callers help if they press
the appropriate key.
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B
basic blocks

example
purpose 42

benefits of Application Builder 15
blocks
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imported application 40, 42
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output 40
pink border 40
system blocks 42
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