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Chapter 1
How to get help

This chapter explains how to get help for Nortel products and services.

Getting Help from the Nortel Web site
The best way to get technical support for Nortel products is from the Nortel
Technical Support Web site:

www.nortel.com/support.

This site provides quick access to software, documentation, bulletins, and
tools to address issues with Nortel products. From this site, you can:

• download software, documentation, and product bulletins

• search the Technical Support Web site and the Nortel Knowledge Base
for answers to technical issues

• sign up for automatic notification of new software and documentation
for Nortel equipment

• open and manage technical support cases

Getting Help over the phone from a Nortel Solutions Center
If you do not find the information you require on the Nortel Technical Support
Web site, and you have a Nortel support contract, you can also get help
over the phone from a Nortel Solutions Center.

In North America, call 1-800-4NORTEL (1-800-466-7835).

Outside North America, go to the following Web site to obtain the phone
number for your region:

www.nortel.com/callus.

Getting Help from a specialist by using an Express Routing Code
To access some Nortel Technical Solutions Centers, you can use an Express
Routing Code (ERC) to quickly route your call to a specialist in your Nortel
product or service. To locate the ERC for your product or service, go to:

Nortel CallPilot
1005r Server Maintenance and Diagnostics

NN44200-704 01.05 Standard
5.0 26 April 2007

Copyright © 2007, Nortel Networks

.

http://www130.nortelnetworks.com/go/main.jsp
http://www.nortel.com/help/contact/global/index.html


10 Chapter 1 How to get help

www.nortel.com/erc.

Getting Help through a Nortel distributor or reseller
If you purchased a service contract for your Nortel product from a distributor
or authorized reseller, contact the technical support staff for that distributor
or reseller.
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Chapter 2
Outlining maintenance and diagnostics
activities

In this chapter
"1005r server features" (page 11)

"Maintenance and diagnostics overview" (page 13)

1005r server features
Note: To comply with the EU (European Union) RoHS directive, some
of the part numbers now contain an E5 or E6 suffix. For example, part
number NTRH2014 is now NTRH2014E6. The part numbers in this
guide do not contain a suffix.

Front control panel and features
The following diagram shows the front view of the 1005r server chassis
with the bezel cover removed. When the bezel cover is on, the DVD
connections, controls, alarm LEDs, and status LEDs are visible. With the
bezel cover removed, both hard drives, the peripheral DVD/CD/CDRW drive,
the antistatic connection, and the front serial port are accessible.
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12 Chapter 2 Outlining maintenance and diagnostics activities

Front panel controls

Label Control or feature Label Control or feature

A Power switch L HDD1 activity

B Reset switch M HDD0 activity

C Critical alarm LED N DVD/CD/CDRW LED and
eject button

D Major alarm LED O Front connection to comm 2
serial port

E Minor alarm LED P USB 2

F Power alarm LED Q Electrostatic discharge
(ESD) connection

G NMI switch (not used) R Hard drive 1 pull handle

H ID switch S Hard drive 1 release lever

I ID LED T Hard drive 0 pull handle

J NIC activity LED U Hard drive 0 release lever

K Status LED

Back panel controls and features
The following diagram shows the back panel controls. The features on the
right are the AC power supply banks. The PCI card brackets are in the
middle of the back panel while the connectors and ports are along the
bottom and left side.
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Back panel controls and features

Label Control or feature Label Control or feature

A DB15 Telco alarm connector
(not used)

G Rear connection to comm
2 serial port

B1 PCI low-profile card #1
bracket

H RJ45 NIC 1 connector

B2 PCI card #2 dual NIC
for High Availability (HA)
configuration. For more
information about HA,
see High Availability:
Installation and Configuration
(NN44200-311).

I RJ45 NIC 2 connector

B3 PCI card #3 dual NIC for
HA configuration. For
more information about
HA, see High Availability:
Installation and Configuration
(NN44200-311).

J Video connector

C PCI full-size card brackets.
Numbered (1, 2, 3) from top
to bottom.

K USB 1

D Power supply 1 L USB 0

E Power supply 2 M Server management LAN
port

F PS/2 mouse and keyboard
connectors

N External SCSI tape drive

Maintenance and diagnostics overview
The maintenance and diagnostic activities discussed in this guide are
divided into two groups of activities:

• troubleshooting and diagnostics (identifying the cause of system
problems and resolving them)
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14 Chapter 2 Outlining maintenance and diagnostics activities

• performing hardware maintenance

This guide is for administrators, technicians, and engineers responsible for
maintaining a CallPilot server. This guide assumes that you have basic
computing skills and are familiar with the necessary safety procedures.

If you cannot resolve your system problems with the resources described
in this guide, you can also refer to the Troubleshooting Reference Guide
(NN44200-700).

Note: Nortel continually updates the Troubleshooting Guide.
It is available from the Partner Information Center (PIC) at
www.nortel.com/pic.

For information about restarting, shutting down, and powering up
the CallPilot server, see the Installation and Configuration Task List
(NN44200-306). You can be asked to perform one or more of these tasks
while maintaining your server.

Your CallPilot server comes preinstalled with the Windows operating system
and CallPilot server software. If your CallPilot server no longer functions
because of a software problem, you may need to reinstall the CallPilot
software or rebuild the system.

Note: If you load the firmware on the server, both power supplies and
hard drives must be connected and the hard drives must be online. If
a failure occurs on any of these components it is not reported by the
server LEDs or by ISM.

Replacement parts
Before replacing any parts on your server, refer to the Nortel product
catalog for the part codes.

CAUTION
Risk of system damage
The use of parts that are not supplied by Nortel can cause serious
system problems or void your Nortel warranty.

Preparing for maintenance activities
Before you proceed with hardware maintenance activities, review the
1005r Server Hardware Installation (NN44200-308) guide for the following
information:

• required tools and equipment
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• recommended safety precautions for electrostatic discharge, handling
cards, and handling your server

Reference documents
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Chapter 3
Troubleshooting your CallPilot system

In this chapter
"Startup diagnostics overview" (page 17)

"Basic hardware check" (page 17)

"Power-On Self-Test diagnostics" (page 19)

"Interpreting BIOS error messages" (page 21)

"What to do when the server fails to boot into service" (page 23)

"Interpreting hard drive LEDs" (page 24)

"Performing a hardware shutdown" (page 24)

Startup diagnostics overview
This section contains procedures for interpreting the startup diagnostics
on the 1005r server.

Types of startup diagnostics
The following types of startup diagnostics are available on the server:

• basic hardware check (front panel LEDs)

• Power-On Self-Test (POST) diagnostics

• SCSI hard drive controller diagnostics or RAID controller diagnostics

These diagnostics are available at initial system startup or after any 1005r
server reset.

Basic hardware check
This section describes some basic checks that you can do when you start
up the server.
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18 Chapter 3 Troubleshooting your CallPilot system

To run the startup test

Step Action

1 Ensure the system is powered down and the AC cords are
disconnected. Wait 5 seconds before applying power again.

2 Apply AC power to the server by plugging in the first AC cord then
the second AC cord. Observe the front panel display.

1005r front panel.

Result: All the alarm LEDs on the front panel illuminate for a fraction
of a second.

Note 1: The back panel LEDs on each power supply start
blinking green when AC power is applied and turn solid green
after a few seconds. When AC power is removed from one power
supply, the LED turn amber. If there is a hardware problem with
the supply or it is not functioning properly, the power supply LED
is red.

Note 2: Refer to "Front control panel and features" (page 11) for
details of the front panel.
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Power-On Self-Test diagnostics 19

3 Check that all the alarm LEDs (C to F) are illuminated amber for
a few seconds. If not, refer to the following table for functional
descriptions of fault LEDs.

Alarm fault LEDs

LED Functional description

CRT A critical system fault is an error or event with a fatal system
impact. The system cannot continue to operate.

MJR A major system fault is an error or event with a discernible
impact on system operation. The system can continue to
operate but with reduced performance or features.

MNR A minor system fault is an error or event with little impact on
system operation. The system continues to operate.

PWR A power supply fault indicates that one of the power supplies
is not providing power. The MJR LED is also lit.

4 Boot the server by pressing the power button on the front of the
CallPilot 1005r server.

5 Observe the following server actions:

• The hard drives (R and T) spin up, and the amber hard drive
activity LEDs on the front panel display (HDD0 and HDD1)
extinguish, and then flash with activity.

• The DVD combo LED illuminates temporarily as the system
checks the DVD combo drive (N).

6 Check the monitor for any error messages as the server counts RAM
and completes a POST.

For more information about POST, see "Power-On Self-Test
diagnostics" (page 19).

—End—

Power-On Self-Test diagnostics
The Power-On Self-Test (POST) is a system diagnostic program (stored in
the BIOS (Basic Input/Output)) that runs each time the 1005r server starts.
The function of the POST is to test system components and display status
messages.
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To run the POST

Step Action

1 Power up the CallPilot server and monitor.

Result: After a few seconds, the POST begins to run.

After the memory test, various screen prompts and messages
appear. The screen prompts can be accompanied by a single beep.

2 Observe the screen for any error messages and listen for POST
beep codes. When the POST is complete, the server beeps once.

If the server halts before the POST is finished, the server emits a
beep code indicating that a fatal system error requires immediate
attention. For more information, see "Interpreting POST diagnostics"
(page 20).

If the POST can display a message on the monitor, the server emits
two beeps as the message appears.

Record the message that appears on the monitor and the beep code
that you hear. This information is useful if you need assistance from
your technical support representative.

—End—

Interpreting POST diagnostics
This section provides an explanation of the POST diagnostic codes.

POST beep codes
If an error occurs before video initialization, the POST emits beep codes
that indicate errors in hardware, software, or firmware.

A beep code is a series of separate tones, each equal in length.

ATTENTION
If your system emits POST beep codes, record the beep code sequence and then
call Nortel technical support before attempting to correct the problem. Ensure
you have the required system information. Some POST beep codes are fatal and
can require that you replace the server.

POST beep codes

Beep count Description

1, 2, or 3 Memory error.
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Beep count Description

4 – 7 or 9 – 11 A fatal error indicates a possible serious system problem
occurred.

8 A problem with the onboard video card occurred indicating
a fault on the server board.

Interpreting BIOS error messages
When a recoverable error occurs during the POST, an error message
appears describing the problem.

ATTENTION
If BIOS error messages appear, record the error messages and then call Nortel
technical support before attempting to correct the problem.

BIOS error messages
BIOS error messages appear on the video monitor. Refer to the following
table for a description of the messages.

BIOS error messages

Error message Description

GA20 Error An error occurred with Gate A20 when
switching to protected mode during
the memory test.

Pri Master HDD Error

Pri Slave HDD Error

Sec Master HDD Error

Sec Slave HDD Error

Could not read sector from
corresponding drive.

ATAPI Incompatible Drive

• Pri Master Drive

• Pri Slave Drive

• Sec Master Drive

• Sec Slave Drive

The corresponding drive is not
an ATAPI (Advanced Technology
Attachment Packet Interface) device.
Run Setup to make sure the device is
selected correctly.

A: Drive Error No response from the disk drive.

CMOS Battery Low The battery is losing power. Replace
the battery soon.

Nortel CallPilot
1005r Server Maintenance and Diagnostics

NN44200-704 01.05 Standard
5.0 26 April 2007

Copyright © 2007, Nortel Networks

.



22 Chapter 3 Troubleshooting your CallPilot system

Error message Description

CMOS Display Type Wrong The display type is different from that
stored in CMOS. Check Setup to
make sure the type is correct

CMOS Checksum Bad The CMOS checksum is incorrect.
CMOS memory can be corrupted.
Run Setup to reset the values.

CMOS Settings Wrong The CMOS values are not the same
as the last boot. Either these values
are corrupted or the battery failed.

CMOS Date/Time Not Set The time or date values stored in
CMOS are invalid. Run Setup to set
the correct values.

DMA Error An error occurred during the
read/write test of the DMA (Direct
Memory Access) controller.

FDC Failure An FDC Failure error occurred while
trying to access the diskette drive
controller.

HDC Failure An error occurred trying to access the
hard disk controller.

Checking NVRAM.... The NVRAM (Non-Volatile Random
Access Memory) is being checked to
see if it is valid.

Update OK! The NVRAM is invalid and has been
updated.

Updated Failed The NVRAM is invalid and cannot be
updated.

Keyboard Error An error in the keyboard connection.
Make sure the keyboard is connected
properly.

KB/Interface Error The keyboard interface test failed.

Memory Size Decreased The memory size has decreased since
the last boot. If you have not removed
any memory, then the memory can be
faulty.

Memory Size Increased The memory size has increased since
the last boot. If you have not added
any memory, there is a problem with
the system.
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Error message Description

Memory Size Changed The memory size has changed since
the last boot. If you did not add or
remove any memory, then the memory
can be faulty.

No Boot Device Available. The system did not find a device to
boot from.

Off Board Parity Error A parity error occurred on an offboard
card. This error is followed by the card
address.

On Board Parity Error A parity error occurred in onboard
memory. This error is followed by the
card address.

Parity Error A parity error occurred in onboard
memory at an unknown address.

NVRAM / CMOS / PASSWORD
cleared by Jumper

NVRAM, CMOS, and passwords have
been cleared. Power the system down
and remove the jumper.

<CTRL_N> Pressed The CMOS is ignored and NVRAM is
cleared. You must enter Setup.

What to do when the server fails to boot into service
This section suggests tasks you can perform to determine why the server
fails the bootup cycle.

To determine why the server fails to boot to Windows

Step Action

If CallPilot fails to boot to Windows, follow these steps:

1 Make a note of any diagnostic codes.

2 Press the power switch to restart the server.

3 View the diagnostic codes for failures during the boot sequence.

4 Retrieve the system event log. Refer to "To save system event logs
to a USB media drive" (page 134).

5 Refer to the Troubleshooting Guide (NN44200-700) for other
suggestions. If you still cannot determine the cause of the startup
failure, call your Nortel technical support representative.

—End—
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To determine why CallPilot fails to come into service

Step Action

If CallPilot fails to come into service, follow these steps:

1 Make a note of any diagnostic codes.

2 Press the power switch to restart the server.

3 View the diagnostic codes for failures during the boot sequence.

4 View the event logs. For instructions, see "Viewing event logs" (page
25).

5 Refer to the Troubleshooting Guide (NN44200-700) for other
suggestions. If you still cannot determine the cause of the startup
failure, call your Nortel technical support representative.

—End—

Interpreting hard drive LEDs
Refer to L and M in "1005r front panel." (page 18) for the location of the hard
drive LEDs for drive 0 and drive 1.

LED color Hard drive status

Green/blinking green Normal

Amber Critical but recoverable condition.
Often during a controlled condition
such as a RAID split.

Red Failure. This LED color is a major
event, and the server must be
attended to immediately.

Performing a hardware shutdown
If you cannot shut the server down using Windows, press the power switch
on the front panel and hold it in for more than 1 second. The server saves
all system data and then powers off.
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Chapter 4
Using Windows online diagnostic tools

In this chapter
"Overview" (page 25)

"Viewing event logs" (page 25)

"Using TCP/IP diagnostic tools" (page 29)

"Using the chkdsk utility" (page 36)

Overview
This section describes how to access the run-time online diagnostic tools
provided by the Windows server software. Use the following tools when a
serious problem prevents the use of the CallPilot diagnostic tools that are
available in CallPilot Manager:

• Windows Event Viewer

• TCP/IP diagnostics

• chkdsk utility

CAUTION
Risk of software corruption
Do not run any utilities that are not documented in this guide.

Viewing event logs
If one or more messages appear on the monitor during the server startup
cycle, use the following diagnostic tools to determine what event or fault
occurred.

• Hardware system event log

• Windows Event Viewer on the 1005r server
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26 Chapter 4 Using Windows online diagnostic tools

• CallPilot Event Browser or Alarm Monitor in CallPilot Manager

Note: The Event Browser and Alarm Monitor include online Help for
events to help you resolve the problem. If you cannot log on to the
CallPilot system using a Web browser due to server problems, then
use the Windows Event Viewer.

You can view the Hardware system event log from ISM, or by booting from
the CallPilot image DVD and selecting the system event log from the menu.

If the server does not boot up, use the Nortel CallPilot Image Utilities on
the DVD to view system event logs. Refer to "Using system event logs"
(page 132).

Types of Windows event logs
Three types of event logs are available from the Windows Event Viewer, as
follows:

Log type Description

System Logs events by Windows components,
including RRAS or other Windows services.

Security Logs security events, such as logons, logoffs,
and illegal access. This option is available to
users with Administrative access.

Application Logs events by application, such as database
file errors.

To use the operating system Event Viewer

Step Action

1 Click Start > Programs > Administrative Tools > Event Viewer.

Result: The Event Viewer window appears.
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Event Viewer

2 To view a log, click the name of the log in the left pane of the window.

The following illustration shows an example of the Application log.

Application log

The following illustration shows an example of the System log.
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System log

Note: The Security log, which is available to administrators, is
not shown.

3 Look for error codes flagged with or that have occurred since the
last startup.

Note: Each error is date- and time-stamped. indicates major or
critical errors. indicates minor errors, and indicates information.

4 Double-click an error to determine the cause of the error.

Result: An Event Properties dialog box appears detailing the
description of the error. Use the description to help determine how
to resolve errors.

Note: If the error persists or the error description does not
suggest a solution, contact your Nortel support representative.

Nortel CallPilot
1005r Server Maintenance and Diagnostics

NN44200-704 01.05 Standard
5.0 26 April 2007

Copyright © 2007, Nortel Networks

.



Using TCP/IP diagnostic tools 29

5 Click OK.

Result: The Event Properties dialog box disappears.

6 Click File > Exit.

Result: The Event Viewer closes.

—End—

Using TCP/IP diagnostic tools
This section describes the following TCP/IP diagnostic tools that are
available for the network adapter:

• ipconfig

• ping

• tracert

• arp

• nbtstat

• netstat

These utilities help you to verify network connectivity, test the network
interface, and isolate any configuration problems.

The ipconfig command
The ipconfig command displays IP configuration information.

ipconfig default
If you run the command without flags, it displays the IP address, subnet
mask, and default gateway for each adapter bound to TCP/IP.

ipconfig command syntax
The ipconfig command uses the following syntax:

ipconfig /[ ]

The following flags are available for the ipconfig command.

ipconfig command extensions

Flag Description

/? Displays Help information.

/all Displays full configuration information.

/release Releases the IP address for the specified adapter.

/renew Renews the IP address for the specified adapter.
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To run the ipconfig command from Windows

Step Action

1 Click Start > Programs > Accessories > Command Prompt.

Result: The Command Prompt dialog box appears.

2 Type ipconfig <parameters>.

Example: ipconfig /all

3 Press Enter.

Result: The system runs the ipconfig utility.

4 Type Exit to exit the Command Prompt dialog box and return to
Windows.

—End—

The ping command
The ping command sends an echo request to a specified host. Use this
command to verify network connectivity to the remote device.

Ping command syntax
The ping command uses the following syntax:

ping [-t] [-a] [-n count] [-l size] [-f] [-i TTL]
[-v TOS] [-r count] [-s count]
[[-j host-list] | [-k host-list]]
[-w timeout] destination-list

ping command extensions

Parameter Description

-t Pings the specified host until interrupted.

-a Resolves addresses to host names.

-n count Specifies the number of echo requests to send.

-l size Sends buffer size.

-f Sets Don’t Fragment flag in packet.

-i TTL Specifies the Time To Live.

-v TOS Specifies the Type Of Service.

-r count Specifies the number of Record route for count hops.

-s count Specifies the number of Time stamp for count hops.

-j host-list Specifies the Loose source route along host list.
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Parameter Description

-k host-list Specifies the Strict source route along host list.

-w timeout Specifies the Timeout in milliseconds to wait for each reply.

To run the ping command from Windows

Step Action

1 Click Start > Programs > Accessories > Command Prompt.

Result: The Command Prompt dialog box appears.

2 Type ping <destination IP address> (for example, ping
200.286.32.0) or ping <computer name>.

3 Press Enter.

Result: The system displays the ping results.

4 Type Exit to exit the Command Prompt dialog box and return to
Windows.

—End—

The tracert command
This utility determines the route taken to a destination.

How tracert works
The tracert utility follows several steps to complete its task:

• Tracert sends Internet Control Message Protocol (ICMP) echo packets
with varying Time-To-Live (TTL) values to the destination.

• Each router along the path must decrement the TTL on a packet by at
least 1 before forwarding it, so the TTL is effectively a hop count.

• When the TTL on a packet reaches 0, the router sends back an ICMP
Time Exceeded message to the source system.

• Tracert determines the route by sending the first echo packet with a TTL
of 1, and incrementing the TTL by 1 each subsequent transmission until
the target responds or the maximum TTL is reached.

• Tracert then examines the ICMP Time Exceeded messages sent back
by intermediate routers.

Tracert syntax
The tracert command uses the following syntax:
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tracert [-d] [-h maximum_hops] [-j host_list]
[-w timeout] [target_name]

Tracert parameters
The following table shows the tracert parameters.

Tracert parameters

Parameter Description

-d Specifies not to resolve addresses to host
names.

-h maximum_hops Specifies the maximum number of hops to
search for the target.

-j host-list Specifies a loose source route along the host
list.

-w timeout Waits the number of milliseconds specified by
the timeout for each reply.

target_name Specifies the name of the target host.

To run the tracert command from Windows

Step Action

1 Click Start > Programs > Accessories > Command Prompt.

Result: The Command Prompt dialog box appears.

2 Type the following command:

tracert [-d] [-h maximum_hops] [-j host_list] [-w
timeout] [target_name]

Example: tracert 200.286.0.32

3 Press Enter.

Result: The system runs the tracert utility.

4 Type Exit to exit the Command Prompt dialog box and return to
Windows.

—End—

The arp command
The arp command displays and modifies the IP-to-physical address
translation tables used by Address Resolution Protocol (ARP).

ARP command syntax
The ARP command uses the following syntax:
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arp -s inet_addr eth_addr [if_addr]

arp -d inet_addr [if_addr]

arp -a [inet_addr] [-N if_addr]

ARP command parameters

ARP command parameters

Parameter Description

-a Displays current arp entries by interrogating
the current protocol data. If inet_addr is
specified, the IP and physical addresses for
the specified computer appear. If more than
one network interface uses arp, entries for
each arp table appear.

-g Same as -a.

inet_addr Specifies an Internet address.

if_addr Specifies the Internet address of the interface
where the address translation table can be
modified. If not present, the first applicable
interface is used.

eth_addr Specifies a physical address.

-N if_addr Displays the arp entries for the network
interface specified by if_addr.

-d Deletes the host specified by inet_addr.

-s Adds the host and associates the Internet
address inet_addr with the physical address
eth_addr. The physical address is given as
six hexadecimal bytes separated by hyphens.
The entry is permanent.

To run the arp command from Windows

Step Action

1 Click Start > Programs > Accessories > Command Prompt.

Result: The Command Prompt dialog box appears.

2 Type arp with the required parameters (for example, arp -g
200.286.0.32).

3 Press Enter.

Result: The system runs the arp command.

4 Type Exit to exit the Command Prompt dialog box and return to
Windows.
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—End—

The nbtstat command
The nbtstat command displays protocol statistics and current TCP/IP
connections using NBT.

Nbtstat command syntax
The nbtstat command uses the following syntax:

nbtstat [-a remotename] [-A IP address] [-c] [-n]
[-R] [-r] [-S] [-s] [interval]

nbstat command parameters

nbstat command parameters

Parameter Description

-a remotename Lists the remote computer name table using its name.

-A IP address Lists the remote computer name table using its IP address.

-c Lists the contents of the NetBIOS name cache giving the
IP address of each name.

-n Lists local NetBIOS names. Registered indicates that the
name is registered by broadcast (Bnode) or WINS (other
node types).

-R Reloads the LMHOSTS file after purging all names from
the NetBIOS name cache.

-r Lists name resolution statistics for Windows networking
name resolution Windows computer configured to use
WINS, this option returns the number of names resolved
and registered through broadcast or through WINS.

-S Displays both client and server sessions, and lists the
remote hosts by IP address.

-s Displays both client and server sessions and attempts to
convert the remote host IP address to a name using the
HOSTS file.

interval Displays selected statistics, pausing interval seconds
between each display. Press Ctrl+C to stop displaying
statistics. Without this parameter, nbtstat prints the current
configuration information once.

To run the nbtstat command from Windows
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Step Action

1 Click Start > Programs > Accessories > Command Prompt.

Result: The Command Prompt dialog box appears.

2 Type nbtstat with the required parameters.

3 Press Enter.

Result: The system runs the nbtstat utility.

4 Type Exit to exit the Command Prompt dialog box and return to
Windows.

—End—

The netstat command
The netstat command displays current TCP/IP network connections and
protocol statistics.

Netstat command syntax
The netstat command uses the following syntax:

netstat [-a] [-e] [-n] [-s] [-p proto] [-r] [interval]

netstat command parameters

netstat command parameters

Parameter Description

-a Displays all connections and listening ports.

-e Displays Ethernet statistics. This can be combined with the
-s option.

-n Displays addresses and port numbers in numeric form.

-s Displays statistics for each protocol.

-p proto Shows connections for the protocol specified by proto. Proto
can be tcp or udp. If used with the -s option, proto can be tcp,
udp, or ip.

-r Displays the contents of the routing table.

interval Re-displays selected statistics, pausing between each display.
Press Ctrl+C to stop re-displaying.

To run the netstat command from Windows
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Step Action

1 Click Start > Programs > Accessories > Command Prompt.

Result: The Command Prompt dialog box appears.

2 Type netstat with the required parameters.

3 Press Enter.

Result: The system runs the netstat utility.

4 Type Exit to exit the Command Prompt dialog box and return to
Windows.

—End—

Using the chkdsk utility
The chkdsk utility checks a specified disk on the server and displays a
status report. You can run the utility on drives C, D, E, or F. It is an online
utility, but it reduces system performance while it runs.

The chkdsk utility checks for errors at the Windows file system level. CallPilot
can be affected by errors at both the Windows and CallPilot file system
levels. The chkdsk utility does not detect CallPilot file system level errors.

Note: A version of this utility, called autocheck, automatically runs
during Windows startup. Output from this utility appears on the blue
startup screen.

Chkdsk utility syntax
The chkdsk utility uses the following syntax:

chkdsk [drive:][path]filename] [/F] [/V] [/R]

Chksdsk utility parameters

Chksdsk utility parameters

Parameter Description

drive: Drive letter of the drive that you want to check.

filename Names of files to check for fragmentation.

/F Optional parameter to fix errors on the disk.
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Parameter Description

/V Optional parameter to display the full
pathname of every file on the disk.

/R Optional parameter to locate bad sectors and
to recover readable information.

To run the chkdsk utility from Windows

Step Action

1 Click Start > Programs > Accessories > Command Prompt.

Result: The Command Prompt dialog box appears.

2 Type chkdsk <drive letter:> (for example, chkdsk c:).

3 Press Enter.

Result: The system runs the chkdsk utility.

4 Type Exit to exit the Command Prompt dialog box and return to
Windows.

—End—
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Chapter 5
Monitoring server hardware

In this chapter
"ISM overview" (page 39)

ISM overview
Intel Server Manager (ISM) is a server management tool installed on your
1005r server. Use ISM to monitor hardware health and server performance.
Set up the following types of tasks using ISM:

• Monitor the hardware sensors on the managed server.

• Monitor the performance of the server using data collected from the
operating system.

• Receive alert messages when the sensor values are out of range, or
when a performance threshold is reached.

Refer to the Help files in the ISM screen for more information.
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Chapter 6
Monitoring multimedia hardware

In this chapter
"Understanding fault management" (page 41)

"Alarm Monitor" (page 43)

"Event Browser" (page 44)

"Channel and Multimedia Monitors" (page 46)

"The Maintenance screen" (page 46)

"Viewing component states" (page 49)

"Starting and stopping components" (page 51)

"Running integrated diagnostics" (page 53)

"Viewing the last diagnostics result" (page 55)

"Working with the Multimedia Monitor" (page 56)

"Working with the Channel Monitor" (page 58)

Understanding fault management
Fault management is a subsystem within CallPilot that detects and notifies
you of potential or real hardware problems with the multimedia hardware.
CallPilot monitors events in the multimedia hardware and raises an alarm
when a fault occurs.

Event processing
An event is any change in system configuration or operational state. An
event is also any action taken by the system that requires user notification
such as a faulty MPB96 card switching to disabled status.
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All events are reported to the fault management server. The fault
management server lets the CallPilot server listen and respond to its clients.
The interaction is called event processing and the server detects hardware
faults in the multimedia hardware.

Alarm notification
Alarms are warnings generated by events. Alarms communicate the same
information as events. However, alarms are reported in the Alarm Monitor
instead of the Event Browser and are managed differently than events.

When an alarm appears in the Alarm Monitor, you must investigate the
problem, isolate it, and then fix the cause of the problem. When you fix the
problem, the alarm is cleared from the Alarm Monitor.

Component dependencies
The status of some components is dependent on the operational status
of other components. If a component fails or is stopped, the dependent
components go out of service.

Note: The components in your system are based on your CallPilot
server type and switch type. Disregard dependencies for components
not in your system.

Component Dependent components

Media bus All MPBs, all multimedia channels, and all call channels.

MPB board All multimedia and call channels associated with the MPB
board.

Time switch All multimedia and call channels associated with the same
MPB as the time switch.

MPB96 All multimedia channels on the MPB96 card.

DS30X All DS30X channels associated with the DS30X link.

Detecting hardware problems
Typically, you first become aware of a hardware problem when an alarm is
raised. All hardware faults produce an alarm (or series of alarms, depending
on the problem) in the Alarm Monitor.

Other indications of a hardware problem include the following:

• user complaints

• call processing difficulties, such as busy signals, static, dropped calls,
connection problems, and cross talk (hearing other conversations)

• system administrator logon difficulties

• alert icons on the Maintenance screen
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Alarm Monitor
Use the Alarm Monitor to investigate one or more raised alarms.

About alarms
Alarms are warnings generated by events. Alarms communicate the same
information as events. However, alarms are reported in the Alarm Monitor
instead of the Event Browser and are managed differently than events:

• Alarms appear in the Alarm Monitor for Minor, Major, and Critical events
(not Information events). All events can be reported in the Event Browser
(depending on the filtering criteria defined in the Event Browser).

• The first time an event occurs, it generates an alarm that appears in
the Alarm Monitor. If the same event continues to occur, a new alarm
is not generated. Instead, the time and date assigned to the original
generated alarm is updated.

• Alarms can be cleared from the Alarm Monitor, but the event that
generated the alarm is not cleared from the event log or the Event
Browser.

Each alarm in the Alarm Monitor has Help text that often provides a solution
to the problem. If the solution is not apparent, use the Event Browser or the
Maintenance screen to further investigate the problem.

To investigate using the Alarm Monitor

Step Action

1 Run CallPilot Manager and log on.

2 In CallPilot Manager, click System > Alarm Monitor.

Result: The Alarm Monitor screen appears.
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3 Click the Event Code for the first Critical or Major alarm.

Result: A description of the event appears in a new Web browser
window.

4 Review the description and recovery action.

5 Repeat steps 3 and 4 for more alarms, if necessary.

6 If the solution to the problem is not apparent, make a note of the
event codes and continue the investigation by using the Event
Browser (see "Event Browser" (page 44)).

—End—

Event Browser
Use the Event Browser to investigate a series of events that occurred
around the time an alarm was raised. The event listing can help you
determine the root cause of a problem.

About events
The Event Browser displays events that are recorded in the server log. Each
event identifies the time the event occurred, the object that generated the
event, and the cause of the event.

Events are classified as Information, Minor, Major, or Critical. By default, the
Event Browser displays the latest 100 critical events.
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To investigate using the Event Browser

Step Action

1 Run CallPilot Manager and log on.

2 In CallPilot Manager, click System > Event Browser.

Result: The Event Browser screen appears.

3 Click an event that appears to be related to the problem, or click an
event that occurred near the time the alarm was raised.

Result: A description of the event appears in a new Web browser
window.

4 View the description and recovery action.

5 Repeat steps 3 and 4 for more events, if necessary.

6 If the solution to the problem is not apparent, contact your Nortel
technical support representative.

Note: For information about how to use the Event Browser, see
the CallPilot Manager online Help.

—End—
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Channel and Multimedia Monitors
The Channel Monitor shows the status of call channels. The call channels
are the connections between the server and the switch that carry the call
signals to CallPilot.

The Multimedia Monitor shows the status of multimedia channels. The
multimedia channels are the DSP ports that process the calls. They are the
voice, fax, and speech recognition channels.

Disabling call channels
If you must take the CallPilot system out of service to perform software
or hardware maintenance, Nortel recommends that you disable all call
channels first. There are two ways to disable the call channels:

• Courtesy stop the channels (preferred method).

When you courtesy stop call channels, CallPilot waits until the channels
are no longer active before disabling them, instead of suddenly
terminating active calls.

• Stop the channels.

When you stop channels, you suddenly disable them and terminate
all active calls.

The Maintenance screen
Use the Maintenance screen in CallPilot Manager to do the following:

• Obtain general information about components.

• View component states.

• Start and stop components.

• Run integrated diagnostic tests.

• View the results of the last diagnostic test run against a component.

What the Maintenance screen provides
The Maintenance screen identifies the server platform and switch
connectivity type. It also provides a navigation tree that, when expanded,
lists the physical and logical hardware components down the left side of the
screen. To list the server hardware components, click the plus sign (+) at
the top of the tree. To list the subcomponents for each component, click the
plus sign (+) beside the component.

Note: The components that are listed on the Maintenance screen are
based on the CallPilot server type and the switch that is connected to
CallPilot. The examples in this chapter are for illustration purposes and
may not appear exactly the same as your system.
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Partially expanded tree for 1005r shows a partially expanded tree for the
1005r server.

When you click a component, the screen refreshes to show the details
about that component. Details are divided into the sections described
in the following table.

Component sections

Section Description

General This section shows general technical information about the
selected component. This typically includes the following
details:

• the name, class, type, series, or version of a component

• various capabilities of a component (for example, whether
a component is removable)

Note: This section does not appear for all components.
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Section Description

Maintenance This section shows the state of the selected component. Use
this section to start and stop a component before running a
diagnostic test.

For more information about working with component states,
see the following sections:

• "Viewing component states" (page 49)

• "Starting and stopping components" (page 51)

Diagnostics Use the Diagnostics section to run one or more diagnostic
tests, or to view the results of the last diagnostic tests that were
run on the selected component.

For more information about running diagnostics, see the
following sections:

• "Running integrated diagnostics" (page 53)

• "Viewing the last diagnostics result" (page 55)

Maintenance activities for each component
The following table identifies the maintenance activities you can perform for
each component that is listed in the component tree.

Maintenance activities

Component Start /
stop?

Courtesy
stop?

Diagnostics
available?

Replaceable?

Media Bus Yes No No No

MPB96
board

Yes No Yes Yes

Time Switch No No No No

DSPs (emb
edded MPB
boards)

Yes No Yes No (embedded)

Multimedia
channels

Yes Yes No No

Call channel
s

Yes Yes No No

DS30X link Yes No No No
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Note: The MGate card and DS30X cable are replaceable. If you are
having problems with the DS30X link, determine if either one or both of
these items are causing the problem and need to be replaced.

Viewing component states
View a component state to determine the general condition of the
component, including whether the component is disabled or off duty. The
component state is shown in the Maintenance section of the Maintenance
screen.

Component states
You can determine the state of a component by looking at the State box
in the Maintenance section.

State Description

Active The component is working and currently involved in
processing a call.

Disabled The diagnostic failed.

Idle The component is working but not currently involved in
processing a call.

InTest A diagnostic is running on the resource or device.

Loading The component has started and takes it out of the Off Duty
state.

This state occurs quickly and is immediately followed by
Idle.

Local (Red)
Alarm

A Receive Loss of Synchronization error occurred on
incoming data over a T1 link and lasted more than 2.5
seconds. This condition exists until synchronization is
recovered and remains recovered for 12 seconds.

No resources The hardware required for the component to operate is not
installed or is not operating properly.

Not Configured The device is not configured in CallPilot.

For example, a DSP is not being used because it was not
allocated in the Configuration Wizard.

Off Duty The component has been stopped.

Remote Off Duty The component has been taken out of service at the switch.

Remote (Yellow)
Alarm

A red alarm exists at the receiving device. This alarm is
sent by the receiving T1 device to CallPilot, and it remains
in effect until the red alarm is cleared at the receiving
device.
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State Description

Shutting Down The component is in the process of stopping.

This state occurs quickly and is immediately followed by
Off Duty.

Uninitiated The call processing component has not initialized the
resource.

Alert icons
If one of the following icons appears next to a component in the tree, then
the component or one of its subcomponents is experiencing a problem:

Icon Description

A problem exists with a subcomponent of the selected component.
Expand the tree to locate the subcomponent with the problem.

A problem exists with the selected component.

To view the state of a hardware component

Step Action

1 Run CallPilot Manager and log on.

2 In CallPilot Manager, click Maintenance > Maintenance Admin.

Result: The Maintenance screen appears.

3 Click the plus signs (+) beside the CallPilot server to expand the
component tree.

4 Continue clicking the plus sign (+) until the component you want to
work with is visible.

5 Click the hardware component you want to work with.

Result: The Maintenance screen refreshes to show details about
the component.

6 Scroll down to the Maintenance section.

7 View the state of the selected component in the State box.

—End—
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Starting and stopping components
When you stop a component, you take it out of service and prevent it from
operating. You must stop a component before you can replace it (if the
component is replaceable) or run a diagnostic test on it.

To bring an out-of-service component back into service, you must start it.

Start and stop components from the Maintenance section on the
Maintenance screen.

ATTENTION
Nortel recommends that, if possible, you courtesy stop a component. Courtesy
stop is available at the individual channel level.

To courtesy stop CallPilot, use the following:

• Multimedia Monitor - to courtesy stop a range of multimedia channels

• Channel Monitor - to courtesy stop a range of call (DS30X, also known
as DS0) channels

Stop versus courtesy stop
The following two methods of taking a component out of service allow you to
choose how active calls are affected.

Courtesy stop
A courtesy stop takes the component out of service after the component
finishes processing the active calls.

• If the component is currently processing a call, the call is not dropped;
the component remains active until the call is finished.

• If the component is not currently in use, it is taken out of service
immediately.

Courtesy stop is the preferred method for taking a component out of service.

Stop
A stop takes the component out of service immediately, regardless of
whether the component is currently processing calls. All active calls are
dropped. Typically, you perform a stop only when severe problems that
are affecting a large number of incoming calls occur or if your organization
determines a special need for it.

Components that you can start and stop
Only the following components can start and stop.
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Note: If you want to start or stop more than one or two multimedia
(DSP) or call (DS30X) channels, use the Multimedia Monitor or Channel
Monitor.

Component Effect of stopping

Media Bus Takes all call processing resources
out of service.

MPB board Takes all call processing resources on
the selected board out of service.

Time switch You cannot perform maintenance
administration on the time switch.

Multimedia Channel Takes the selected multimedia
channel out of service.

Channels Takes the selected DS30X channel
out of service.

DS30X link Takes the selected DS30X link out of
service.

To start or stop a component

Step Action

1 Run CallPilot Manager and log on.

2 In CallPilot Manager, click Maintenance > Maintenance Admin.

Result: The Maintenance screen appears.

3 Click the plus sign (+) beside the CallPilot server to expand the
component tree.

4 Continue clicking the plus signs (+) until the component you want to
work with is visible.

5 Click the hardware component that you want to start or stop.

Result: The Maintenance screen refreshes to show details about
the component.

6 Scroll down to the Maintenance section.

7 Click Courtesy Stop or Start as required.

Button Description

Start If the selected component is out of service, click this
button to put it into service.
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Button Description

Courtesy
Stop

Click this button to take the selected component out
of service. CallPilot waits for calls to be completed
before disabling the component.

ATTENTION
If you are courtesy stopping all components (that is,
you are taking the entire system down), ensure that
you inform all administrators, desktop messaging
users, and Web messaging users so that they can
log off their sessions before you proceed.

The system asks you to confirm the courtesy stop.
If you click OK, the component is put out of service
after all calls are finished.

Stop Click this button to take the selected component out
of service immediately. All calls that are in progress
are disconnected immediately.

ATTENTION
If you are stopping all components (that is, you are
taking the entire system down), ensure that you
inform all administrators, desktop messaging users,
and Web messaging users so that they can log off
their sessions before you proceed.

—End—

Running integrated diagnostics
Run diagnostic tests from the Diagnostics section on the Maintenance
screen in the following circumstances:

• You want to ensure that a component is operating properly after
installing or reinstalling it.

• The CallPilot server is having trouble processing incoming calls and you
are hoping that diagnostic results can tell you why.

Problems include static, dropped calls, and cross talk (hearing another
conversation).
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Before you begin

ATTENTION
Take the component out of service before you run the diagnostic test. See
"Starting and stopping components" (page 51).

Components with diagnostic tests available
The following table identifies the components on which you can run
diagnostics.

Component Diagnostics available? Replaceable?

Media Bus No No

MPB96 board Yes Yes

Time switch No No

Multimedia channels No No

Channels No No

DS30X link (cable) No Yes

Diagnostic tests available for each component
The diagnostic tests that are available for each component are listed in the
Diagnostic section of the Maintenance screen. To view the list of diagnostic
tests for a particular component, click the component in the component tree.

If a diagnostic test fails or cannot be run
If a warning message appears, you cannot run the diagnostic test because a
prerequisite condition has not been met. If a diagnostic test fails, a message
appears in a new browser window.

In both cases, check the Alarm Monitor to determine the reason and the
appropriate action to take.

If the Alarm Monitor and Event Browser do not provide a solution to a
hardware problem, you may need to replace or service a component. If
the problem is with a component that is not replaceable because it is not
a physical entity (such as the Time Switch), you must either replace its
parent component or contact your Nortel technical support representative,
depending on the component.

To run a diagnostic test

Step Action

ATTENTION
Nortel recommends that you courtesy stop rather than stop a component if
possible. For instructions, see "Starting and stopping components" (page 51).
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1 Run CallPilot Manager and log on.

2 In CallPilot Manager, click Maintenance > Maintenance Admin.

Result: The Maintenance screen appears.

3 Click the plus sign (+) beside the CallPilot server to expand the
component tree.

4 Continue clicking the plus signs (+) until the component you want to
work with is visible.

5 Click the hardware component for which you want to run diagnostics
with.

Result: The Maintenance screen refreshes to show details about
the component.

6 Scroll down to the Maintenance section, and ensure that the
component is out of service.

7 Scroll down to the Diagnostics section.

8 Select the check box for each diagnostic that you want to run.

Note: If you want to run all of the diagnostics, select the
Diagnostic Description check box at the top of the list.

9 Click Run.

Result: A new Web browser window appears with the progress
and results of the diagnostics.

Note: The Diagnostic Results box in the Diagnostics section
appears when you click Get Last Result.

—End—

Viewing the last diagnostics result
You can review the results of diagnostics by clicking the Get Last Results
button for a component.

To view the last diagnostics result

Step Action

ATTENTION
Nortel recommends that you courtesy stop rather than stop a component if
possible. For instructions, see "Starting and stopping components" (page 51).
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1 Run CallPilot Manager and log on.

2 In CallPilot Manager, click Maintenance > Maintenance Admin.

Result: The Maintenance screen appears.

3 Click the plus sign (+) beside the CallPilot server to expand the
component tree.

4 Continue clicking the plus signs (+) until the component you want to
work with is visible.

5 Click the hardware component for which you want to run diagnostics
with.

Result: The Maintenance screen refreshes to show details about
the component.

6 Scroll down to the Diagnostics section.

7 Select the check box for each diagnostic for which you want to
review results.

8 Click Get Last Result.

Result: The results appear in the Diagnostic Results box with the
following information:

• diagnostic title

• diagnostic result: pass or fail

• the date and time the test was completed

—End—

Working with the Multimedia Monitor
The Multimedia Monitor shows the status of multimedia channels. The
multimedia channels are the DSP ports that process the calls. They are the
voice, fax, and speech recognition channels.

To view or work with multimedia channel states

Step Action

1 Run CallPilot Manager and log on.

2 In CallPilot Manager, click Maintenance > Multimedia Monitor.
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Result: The Multimedia Monitor screen appears, showing the
channels associated with each DSP.

Note: For an explanation of the channel states, see the CallPilot
Manager online Help.

3 Do one of the following:

IF you want to stop or start THEN

all of the channels associated with
a DSP

select the check box to the left of
the DSP that you want to stop or
start.

Repeat this step for each DSP.

only one or several channels that
are associated with a DSP

select the check box for each
channel that you want to stop or
start.

4 Click Courtesy Stop or Start as required.

Result: If you click Courtesy Stop or Start, you are asked to confirm
the Courtesy Stop or Start. Click OK.

The selected channels change to off-duty or idle status, according
to the action you chose.
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Note: If the buttons are not available, wait a few seconds for
the screen to refresh.

—End—

Working with the Channel Monitor
The Channel Monitor shows the status of call channels. The call channels
are the connections between the server and the switch that carry the call
signals to CallPilot.

To view or work with call channel states

Step Action

1 Run CallPilot Manager and log on.

2 In CallPilot Manager, click Maintenance > Channel Monitor.

Result: The Channel Monitor screen appears, showing the DS30X
(also known as DS0) channels associated with each DS30X link.

Note: For an explanation of the channel states, see the CallPilot
Manager online Help.
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3 Do one of the following:

IF you want to stop or start THEN

all of the channels associated with
a DS30X link

select the check box to the left of
the DS30X link that you want to
stop or start.

Repeat this step for each DS30X
link.

only one or several channels that
are associated with a DS30X link

select the check box for each
channel that you want to stop or
start.

4 Click Courtesy Stop or Start as required.

Result: If you click Courtesy Stop or Start, you are asked to confirm
the Courtesy Stop or Start. Click OK.

The selected channels change to off-duty or idle status, according
to the action you chose.

Note: If the buttons are not available, wait a few seconds for
the screen to refresh.

—End—
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Chapter 7
Using CallPilot system utilities

In this chapter
"Overview" (page 61)

"Diagnostics Tool" (page 62)

"PEP Maintenance utility" (page 63)

"Session Trace" (page 64)

"CallPilot System Monitor" (page 66)

Overview
The following table lists the CallPilot system utilities.

Utility Description

Diagnostics Tool Allows CallPilot startup diagnostics to be enabled
or disabled (turned on or off).

PEP Maintenance Displays a list of installed PEPs and enables PEP
removal.

Session Trace Displays detailed information about the activity in
a user’s mailbox and the state of the message
waiting indicator (MWI).

CallPilot System Monitor Displays the following information:

• the status of all CallPilot channels

• the status of all CallPilot services

Note: This status is more accurate than the status
provided in the Services Control Panel.
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• particulars about the CallPilot system, such
as names, keycodes, serial numbers, IP
addresses, and system numbers

Accessing the system utilities
You can access all CallPilot utilities from the CallPilot server in the Start >
Programs > CallPilot > System Utilities menu.

Diagnostics Tool
Use the Diagnostics Tool to enable or disable CallPilot startup diagnostics.
CallPilot startup diagnostics automatically identify hardware problems
that can exist when the system and its services are started. When you
disable startup diagnostics, you can save time during system maintenance
operations where restarts or call processing services restarts are required.
There are three recommended steps:

• Use the Diagnostics Tool to turn off CallPilot startup diagnostics.

• Perform system maintenance.

• Use the Diagnostics Tool to turn on CallPilot startup diagnostics.

To access the Diagnostics Tool

Step Action

1 On the Windows desktop, click Start > Programs > CallPilot >
System Utilities > Diagnostic Tool.

Result: The Diagnostics Tool dialog box appears.

—End—

To enable startup diagnostics

Step Action

1 From the Diagnostics Tool dialog box, select Configuration >
Maintenance Startup Diag > Enable.

—End—
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To disable startup diagnostics

Step Action

ATTENTION
Nortel recommends that you leave the startup diagnostics turned on. When you
disable CallPilot startup diagnostics, you prevent CallPilot from automatically
identifying hardware problems that can exist when the system and its services are
started (for example, DSP, time switch, or Media Bus).

1 On the Diagnostics Tool dialog box, select Configuration >
Maintenance Startup Diag > Disable.

—End—

PEP Maintenance utility
The PEP Maintenance utility displays a list of all installed PEPs on the server
and lets you uninstall PEPs. For information about installing or uninstalling
PEPs, see the Installation and Configuration Task List (NN44200-306).

To access the PEP Maintenance utility

Step Action

1 From the Windows desktop, click Start > Programs > CallPilot>
System Utilities > PEP Maintenance Utility.

Result: The DMI Viewer dialog box appears.

—End—

To view a list of all installed PEPs

Step Action

1 Click the component for which you want to display the PEP list.

2 Click Show PEPs.

Result: A list of all installed PEPs appears in the left pane.

3 If you want to review the readme file associated with a PEP, click the
PEP, and then click Read.

Result: The readme file appears in Notepad.

—End—
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Session Trace
The Session Trace tool displays detailed information about the activity in
a user’s mailbox and the state of the message waiting indicator (MWI).
The session information includes:

• voice messaging

• call answering

• express messaging activity (messages composed and sent or left in
a mailbox)

• the number of messages played or unplayed at the beginning, middle,
and end of a session

• messages and personal distribution lists restored to a mailbox

• the last change to the MWI (turned on or off, or untouched)

With the Session Trace information, an administrator or technician can
study the state of a user’s mailbox and MWI to track user complaints. For
example, a user can complain that the MWI is on, but no voice messages
are in the mailbox when the user logs on. The session information can tell
the administrator why the MWI is turned on.

To access the session trace tool

Step Action

1 From the Windows desktop, click Start > Programs > CallPilot >
System Utilities > Session Trace Tool.

Result: The MCE Session Trace dialog box appears.

—End—

To find a session

Step Action

1 From the Session Type list, choose the type of session. To display a
list of all session types, select All Session Types.

2 Enter as much information in the search criteria boxes to identify
the session you want to view. To display a list of all users for the
selected session type, leave the search criteria boxes blank.

3 Click Search to initiate the search.
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a. If you did not enter any user information, a list of users matching
the session type appears at the bottom of the window. To select
a user from the list, double-click the user name to display session
type information.

b. If you selected All Session Types for a user, the session type
information appears in the right of the window.

4 Double-click the session type to display the session information.

Result: The session type information appears at the bottom of the
window. The following example shows Call Answering session type
information.

Call Answering session

—End—
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CallPilot System Monitor
The System Monitor consists of three tabs, as described in the following
table.

System Monitor tabs

Tab Description

Channel Monitor Shows the status of all CallPilot services, multimedia
channels, and call channels (DS30X channels).

System Info Displays details about the CallPilot system, such as
features purchased, keycode, serial number, and
CallPilot server IP addresses.

Legend/Help Provides a description of icons and terminology
displayed in the System Monitor window.

System Monitor is a nondestructive tool that does not alter the behavior of
any CallPilot components.

To access the CallPilot System Monitor

Step Action

1 On the Windows desktop, click Start → Programs → CallPilot →
System Utilities → System Monitor.

Result: The CallPilot System Monitor window appears. By
default, the Channel Monitor tab appears at the top. Click the
other tabs to view the information on those tabs.

—End—

Channel Monitor tab
The following is an example of the Channel Monitor tab when connected
to a Meridian 1.
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Channel Monitor with M1

CallPilot services
The Service Name pane shows the status of services from a CallPilot
perspective. The Windows Services Control Panel can show that a service
is running, but it may not be fully running or in service from a CallPilot
perspective. Refer to the Channel Monitor tab in the Systems Monitor for
the true status.

The services listed under Service Name can be either running or in full
service when CallPilot is functioning optimally. If any CallPilot services are
stopped, investigate the cause of this. Call Nortel technical support for
assistance.

Note: While you can investigate any stopped services, some services
are not critical. CallPilot can continue to handle call processing even
with some services stopped.
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The critical services that are required for basic CallPilot call answering are
listed in the following table. For your reference, the equivalent names as
they appear in the Windows Control Panel are also listed.

CallPilot
System Monitor

Windows Control Panel
equivalent

CTMS Server CTMS Server

Telephony (TAPI) Telephony Services

MCE SLEE CallPilot SLEE Service

MCE Notification CallPilot MWI Service

MAS Notification CallPilot Notification Service

MAS CCR CallPilot Call Channel Router

MAS BCR CallPilot Blue Call Router

SQL Anywhere Adaptive Server Anywhere -
%ComputerName%_SQLANY

MAS MltmediaCache CallPilot Multimedia Cache

MAS MltmediaVol1 CallPilot Multimedia Volume 1

MAS MltmediaVol2 (TRP only) CallPilot Multimedia Volume 102 (TRP
only)

MAS MltmediaVol3 (TRP only) CallPilot Multimedia Volume 103 (TRP
only)

MAS Rsrc. Pckg. 1 CallPilot Resource Package1

DSPs
In the DSP pane, each DSP is represented in a separate row. Each box in
the row is one DSP channel or multimedia channel. Click the Legend/Help
tab to view descriptions of the multimedia channel icons.

Your 1005r server has either one or three MPB96 boards. Each MPB96
board has 12 DSP sections embedded on the board.

DS30X links
In the DS30X link pane, each DS30 row represents a separate DS30X
link (also referred to as a DS30 link). Each box in the row represents one
DS30X channel.

The DS30X links connect the CallPilot server to the MGate card in the
Meridian 1 switch or Communication Server 1000 system. The DS30X link
to the switch is supported by the connection of the server to the switch
backplane.
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ATTENTION
You must connect the DS30X-1 cable to an MGate card to receive the clock
source for the MPB96 board. Failure to connect the DS30X-1 cable to an MGate
card can result in noise interference on the remaining voice channels.

System Info tab
"System Info tab" (page 69) shows an example of the System Info tab.

System Info tab

The numbered items provide information about the features purchased.
Information about the underlying operating system appears in the top right
corner, including the server IP addresses.

PEP information and configured Service DNs appear in the bottom part of
the window.

Legend/Help tab
"Legend/Help tab" (page 70) shows an example of the Legend/Help tab.
Consult this window for descriptions of the icons found on the Channel
Monitor tab.
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Legend/Help tab
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Chapter 8
Replacing basic chassis components

In this chapter
"Removing and replacing the front bezel" (page 71)

"Removing and replacing the server cover" (page 73)

"Removing and replacing the processor air duct" (page 74)

"Replacing the power supply" (page 76)

"Replacing a hard drive" (page 77)

"Replacing the four-fan assembly" (page 80)

"Replacing the dual NIC card" (page 82)

"Replacing the DVD combo drive" (page 87)

"Replacing memory DIMMs" (page 89)

"Replacing the software feature key" (page 91)

Removing and replacing the front bezel
Remove the front bezel to service the hard drives and DVD combo drive.
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To remove the front bezel

Step Action

1 Front bezel

Loosen the captive screws (A) on both sides of the front bezel. The
screws cannot be removed from the front bezel. Refer to "Front
bezel" (page 72).

CAUTION
Risk of equipment damage
Support the front bezel while loosening the captive screws
as the front bezel is not held onto the front panel with
another mechanism.

2 Hold the front bezel by the captive screws and lift it toward you.
Place it in a secure location while you service the server.

—End—

To replace the front bezel

Step Action

When the CallPilot server maintenance is complete, replace the front bezel.

1 Align the captive screws on the front bezel with the threaded holes
in the front panel.
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2 Tighten the captive screws.

—End—

Removing and replacing the server cover
Remove the server cover if you must service the interior of the server.

Note: If a component has a:

Blue tab Power down the server before replacing it.

Green tab It can be replaced while the server is powered on.

Black tab It is non-replaceable, or not important.

To remove the server cover

Step Action

DANGER
Risk of electric shock
High current inside the chassis can cause severe injury.

CAUTION
Risk of equipment damage
Take precautions to protect internal components. Electrostatic
discharge (ESD) can damage boards and make them unusable.

1 Power down the server, unplug all peripheral devices and Ethernet
cables, and disconnect the AC power.

2 Turn off all peripheral devices connected to the server.

3 Attach the ESD strap to your wrist and attach the other end to a
known grounded connection.

4 While holding the blue button at the top of the chassis in, slide the
top cover back until it stops.
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Server cover

5 Lift the cover straight up to remove it from the platform.

—End—

To replace the server cover

Step Action

1 Place the cover over the chassis so that the side edges of the cover
sit just inside the chassis sidewalls. The front of the cover is about
an eighth of an inch from the sheet metal at the front of the chassis.
Refer to "Server cover" (page 74).

2 Press down slightly on the chassis cover behind the DVD combo
drive area and slide the cover forward until it clicks into place.

—End—

Removing and replacing the processor air duct
You must remove the air duct to access the processor assembly, four-fan
assembly, and the memory modules. Because the processor air duct
channels the airflow within the chassis, be sure to reinstall the air duct
before installing the chassis cover.

Requirements
You need a Phillips (cross head) screwdriver, #1 and #2 bit.
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To remove the processor air duct

Step Action

1 Power down the server, unplug all peripheral devices and Ethernet
cables, and disconnect the AC power.

2 Attach the ESD strap to your wrist and attach the other end to a
known grounded connection.

3 Remove the chassis cover. Refer to "Removing and replacing the
server cover" (page 73).

4 Remove the screws at the top of the air duct.

Processor air duct

5 Lift the air duct from the server platform and store it in a safe location.

—End—

To replace the processor air duct

Step Action

1 Place the processor air duct over the processor socket and four-fan
assembly. Make sure you do not pinch any wires beneath the edges
of the air duct. Refer to "Processor air duct" (page 75).
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2 Tighten the screws at the top of the air duct. The top of the installed
air duct must be flush with the top surface of the PCI adapter
assembly.

3 Replace the chassis cover. Refer to "Removing and replacing the
server cover" (page 73).

4 Take the ESD strap off.

—End—

Replacing the power supply
The power supplies are hot-swappable and you can replace each power
supply without powering down the server.

ATTENTION
Do not remove both power supplies while the system is running. Shut down the
multimedia channels by using the Courtesy Stop in CallPilot Manager. Shut down
the server using the Windows Shut Down option, and unplug the power supplies
before removing both power supplies at the same time.

When to hot-swap the power supply
A green LED on the power supply indicates that the power supply is working
properly. If the green LED on the power supply module is unlit or red, the
module is failing or has failed. If the PWR alarm LED on the front panel is
red, this also indicates a problem with one of the power supplies.

Note: A power supply will not be used by the system if it is not installed
when the firmware is updated.

To hot-swap a power supply

Step Action

DANGER
Risk of electric shock
High current inside the chassis can cause severe injury.

1 Depress and hold the green lever (A) to disengage the power supply.
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Power supplies

2 Grasp the black handle (B) and pull the power supply from the
chassis.

3 Insert the replacement power supply. When inserting the new power
supply, make sure the green handle (A) is pressed downward while
sliding the module into the power supply cage.

4 Plug the new power supply into the AC mains.

Result: The power supply LED illuminates green.

—End—

Replacing a hard drive
Two hot-swappable SCSI drives are installed in your chassis. You do not
need to remove the chassis cover to add or replace a hot-swap hard drive,
but you must remove the front bezel to access the hard drives.

ATTENTION
The replacement hard drive must be the same size or larger than the drive being
replaced.

To replace a SCSI hard drive

Step Action

1 Remove the front bezel. Refer to "Removing and replacing the front
bezel" (page 71) for instructions.
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2 Attach the ESD strap to your wrist and attach the other end to a
known grounded connection.

3 Locate the faulty hard drive. Refer to the following diagram of the
front panel.

Front panel

• Hard drive 0 is on the right (T). The status LED of hard drive 0 is
marked with the hard drive symbol and the number 0 (M).

• Hard drive 1 is on the left (R). The status LED of hard drive 1 is
marked with the hard drive symbol and the number 1 (L).

4 Press the green latch (A) on the front of the hard drive carrier as
shown in the following diagram.

Nortel CallPilot
1005r Server Maintenance and Diagnostics

NN44200-704 01.05 Standard
5.0 26 April 2007

Copyright © 2007, Nortel Networks

.



Replacing a hard drive 79

SCSI hard drive carrier

5 Pivot the latch (A) into the upright position.

6 Pull out on the black lever to slide the carrier from the chassis (B).

7 Remove the new hard drive from its wrapper and place it on an
antistatic surface.

8 With the drive circuit-side down, position the connector end of the
drive so that it is facing the rear of the drive carrier.

9 Align the holes in the drive to the holes in the drive carrier and
attach it to the carrier using four screws that meet the drive vendor’s
recommendation.
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Hard disk drive location in carrier

10 With the black lever in the fully open position, slide the drive
assembly into the chassis.

11 Insert the replacement drive in the bay. The green latch at the front
of the drive carrier must be to the right. Do not push on the black
drive carrier lever until the lever begins to close by itself.

12 When the black drive carrier lever begins to close by itself, push on it
to lock the drive assembly into place.

13 Take the ESD strap off.

14 Replace the front bezel.

15 Resynchronize the new hard disk. Refer to "To synchronize the
RAID after a successful PEP installation" (page 101).

—End—

Replacing the four-fan assembly
The four-fan cooling assembly is not hot-swappable. You must power down
the server and disconnect it from the power supply.

When to replace the cooling fan assembly
When one or more of the four cooling fans is not turning, the remaining fans
rotate faster to maintain the same volume of air flow through the chassis.
The hum of a cooling fan rotating faster is both louder and higher in pitch
than normal and indicates that the assembly must be replaced. You cannot
replace just one fan in the assembly.
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To replace the four-fan assembly

Step Action

1 Power down the server, unplug all peripheral devices and Ethernet
cables, and disconnect the AC power.

2 Attach the ESD strap to your wrist and attach the other end to a
known grounded connection.

3 Remove the chassis cover. Refer to "Removing and replacing the
server cover" (page 73) for instructions.

4 Remove the processor air duct. Refer to "Removing and replacing
the processor air duct" (page 74) for instructions.

5 Disconnect the fan connectors (A) from the front panel I/O board.
Make of note of the order in which the fans are plugged into the
board.

Cooling fan assembly

6 Loosen the captive screw (B) that attaches the four-fan assembly
to the chassis.

7 Lift the fan module straight up and remove it from the chassis.

8 Lower the new fan module into place.

9 Tighten the captive screw (B).
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10 Connect the fan cables to the correct fan connectors on the front
panel I/O board. The fan connectors are labeled on the front panel
I/O board.

11 Replace the processor air duct.

12 Replace the chassis cover.

13 Take the ESD strap off.

14 Connect the AC power cords, peripheral devices, and restart the
server.

—End—

Replacing the dual NIC card
Your server has three low-profile PCI add-in cards. The RAID card is in slot
1 and the two dual NIC cards are in slots 2 and 3 (counting from top to
bottom). The two dual NIC cards are reserved for future use.

CAUTION
Risk of electrical damage

• Wear an antistatic ESD wrist strap when handling cards
or boards, or when working inside the server.

• Do not touch the components or gold-edge connectors
of the cards.

• Place the card on an antistatic surface until you are
ready to install it.

PCI add-in cards are not hot-swappable and you must power down the
system before adding or replacing the cards.

CAUTION
Risk of physical equipment damage
Remove the 1005r from the rack, and place it on a solid surface
when replacing or adding cards. The PCI riser assembly requires
considerable force when inserting it into the connector, and
physical damage can result if the assembly is not properly aligned.

Placing the server on a solid surface such as a workbench gives
you a better view of the card alignment, and lets you exert the
necessary force when inserting the assembly into the connector.
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Requirements

• Phillips (cross head) screwdriver, #1 and #2 bit

• replacement dual NIC card

• electrostatic discharge (ESD) grounding strap

To replace a dual NIC card

Step Action

1 Power down the server, unplug all peripheral devices and Ethernet
cables, and disconnect the AC power. Ensure all cables are labeled.

2 Attach the ESD strap to your wrist and attach the other end to a
known grounded connection.

3 Remove the chassis cover. Refer to "Removing and replacing the
server cover" (page 73) for instructions.

4 Disconnect the red power cable from the PCI riser assembly.

5 Disconnect the DS30X cable from the MPB96 card in the full-size
side of the PCI riser.

DS30X cables for high capacity

Note: If you have the high capacity configuration with three
MPB96 cards, label each cable with the MPB96 slot number
before disconnecting them. Incorrectly connected MPB96 cards
do not answer calls.

6 Disconnect the SCSI cable attached to the RAID card.
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SCSI cable attached to RAID card

7 Lift the blue tabs and pull up on the riser to remove the riser card
assembly from the chassis.

PCI riser card assembly
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8 Turn the riser card upside down and place it on a table.

Low-riser PCI card

9 Release the retention bar (A).

10 Replace the card in either slot 2 or 3 (the two upper slots in the
preceding diagram and not the lower slot as shown).

11 Lock the retention bar in place.

12 Turn the PCI riser card right-side up.

13 Arrange the PCI riser assembly red power cable as shown in the
following illustration to avoid pinching the cable when you put the
riser assembly into the chassis.

PCI riser assembly power cord
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14 Hold the PCI riser assembly by the two blue handles (A) and
push the assembly into the server board. Refer to "PCI riser card
assembly" (page 84).

15 Line up the two grooves on the back lip of the PCI riser assembly
with the pins on the rear panel as shown in the following illustration.

ATTENTION
If the PCI riser assembly is not fully seated, the server can malfunction.

PCI riser assembly rear grooves

16 Reconnect the PCI riser assembly power cord.

17 Reconnect the SCSI cable to the RAID card.

18 Reconnect all cables.

19 Replace the chassis cover.

20 Take the ESD strap off.

21 Power up the server and log onto Windows.

Result: The Windows New Hardware Found Wizard screen appears.

22 Click Next.

23 Select the presented driver (there is only one).
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24 Run the Configuration Wizard to detect the new hardware.

For instructions, see the Installation and Configuration Task List
(NN44200-306).

Result: The board replacement is complete.

25 Test the system to ensure the new board is functioning properly.

For instructions, see "Testing the CallPilot installation" in the
Installation and Configuration Task List (NN44200-306).

—End—

Replacing the DVD combo drive
The DVD combo drive is not hot-swappable. You must power down the
system to replace the DVD combo drive.

Requirements
You need a Phillips (cross head) screwdriver, #1 and #2 bit.

To replace the DVD combo drive

Step Action

1 Power down the server, unplug all peripheral devices and Ethernet
cables, and disconnect the AC power.

2 Remove the front bezel. Refer to "Removing and replacing the front
bezel" (page 71).

3 Attach the ESD strap to your wrist and attach the other end to a
known grounded connection.

4 Remove the chassis cover. Refer to "Removing and replacing the
server cover" (page 73) for instructions.

5 Pull out on the drive carrier handle (A) as shown in the following
diagram.
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DVD combo drive assembly

6 Slide the DVD combo drive assembly from the chassis.

Note: There are no cables to disconnect.

7 Remove the screw on the left side of the drive assembly and save it
for installing the new DVD combo.

8 Remove the DVD combo drive from the carrier.

a. Open the two latches holding the DVD combo drive in the carrier.

b. Disconnect the ribbon cable.

c. Disconnect the power cable from the DVD combo drive.

d. Remove the three screws that fasten the carrier around the DVD
combo drive.

e. Gently pry open the carrier and remove the DVD combo drive.

9 Install the new DVD combo drive in the carrier.

a. Line up the pins on each side of the bracket (two on each side)
with the holes in the drive and set the replacement DVD combo
drive into the drive bracket. Push gently on one side of the
bracket to push the pins into place.

b. Screw the carrier shut with the three screws.

c. Reconnect the power and ribbon cables.

10 Slide the DVD combo drive assembly into the chassis.

11 With the black drive carrier handle in the fully open position, slide the
drive assembly back into the chassis.
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12 Attach the drive power and data cables at the rear of the drive.
When the cables are firmly installed, the cable retention clips lock
into place.

13 Replace the chassis cover.

14 Take the ESD strap off.

15 Replace the front bezel.

16 Reconnect the power cables and peripheral devices.

17 Restart the server.

—End—

Replacing memory DIMMs
Four Dual Inline Memory Modules (DIMMs) are installed on your server. You
must replace all four memory DIMMs with those in the Nortel replacement
pack. Nortel does not support more than four DIMM modules in the 1005r
server.

CAUTION
Risk of equipment damage
Take precautions to protect internal components. Electrostatic
discharge (ESD) can damage cards and make them unusable.

To replace the DIMM cards

Step Action

1 Power down the server, unplug all peripheral devices and Ethernet
cables, and disconnect the AC power.

2 Attach the ESD strap to your wrist and attach the other end to a
known grounded connection.

3 Remove the chassis cover. Refer to "Removing and replacing the
server cover" (page 73) for instructions.

4 Remove the processor air duct. Refer to "To remove the processor
air duct" (page 75) for instruction.

5 Locate memory banks 1A, 1B, 2A, and 2B on the server board.
Refer to the following diagram.
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Memory DIMM locations

6 Push the clips at each end of the DIMM sockets outward to the
open position.

7 Remove all the DIMMs.

8 Holding each DIMM by the edges, remove it from the antistatic
envelope.

9 Position the DIMM above the socket and align the small notch in the
bottom edge of the DIMM with the keys in the socket.

10 Insert the bottom edge of the DIMM into the socket.

11 Push down on the top edge of the DIMM until the retaining clips snap
into place. The retaining clips must be fully closed for the DIMM to
make proper contact with the server board.

12 Install the other three DIMMs.

13 Replace the processor air duct.

14 Replace the chassis cover.

15 Plug in all peripheral devices and AC power.

Nortel CallPilot
1005r Server Maintenance and Diagnostics

NN44200-704 01.05 Standard
5.0 26 April 2007

Copyright © 2007, Nortel Networks

.



Replacing the software feature key 91

16 Restart the server.

—End—

Replacing the software feature key
If you upgrade your system or convert it to high capacity, you must replace
the software feature key with a new key.

To replace the software feature key

Step Action

1 Remove the new software feature key from the plastic bag.

2 Eject the old software feature key by inserting a straightened paper
clip into the side access hole.

3 Push the paper clip in the direction of the software feature key.

4 Insert the new software feature key into the software feature slot on
the dongle with the data contact facing down and away from the
embossed i.

Dongle with open slot

In the following figure, label 1 is the data contact and label 2 is the
ground.
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Inserting the feature key

—End—
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Chapter 9
RAID operations

In this chapter
"Outlining RAID functions" (page 93)

"Verifying the RAID firmware" (page 94)

"Configuring RAID using LSI320-1 controller and Ctrl+M" (page 96)

"Verifying consistency on the drives" (page 99)

"RAID splitting" (page 100)

"Replacing the RAID card" (page 103)

Outlining RAID functions
Redundant Array of Independent Disks (RAID) is a technology that can
combine two or more drives for fault tolerance and continuous service.
The CallPilot RAID controller is a PCI RAID SCSI card that provides
high-performance disk mirroring with RAID Level 1.

With Level 1 mirroring, two equal-capacity disk drives mirror one another.
One disk drive serves as the backup copy of the other disk drive. If one disk
drive fails, the other continues to run.

RAID configuring and splitting
Working with RAID involves the following:

• verifying the RAID firmware version

• upgrading or downgrading the RAID firmware

• configuring RAID using the LSI320-1 controller and the Ctrl+M menu
at server bootup

• ensuring that your system is working and the RAID hardware is properly
configured

Nortel CallPilot
1005r Server Maintenance and Diagnostics

NN44200-704 01.05 Standard
5.0 26 April 2007

Copyright © 2007, Nortel Networks

.
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• performing RAID splitting

• synchronizing RAID after installing CallPilot software upgrades (PEPs)

— Resynchronizing RAID if the installation is successful

— Resynchronizing RAID if the installation is not successful

WARNING
Nortel strongly recommends that you do not perform low level
formatting. Performing low level formatting results in the drives
becoming unusable.

Verifying the RAID firmware
You require the following minimum RAID firmware version:

• 1L37

To verify the RAID firmware version

Step Action

To determine what the current RAID firmware version is on the RAID
LSI320-1 controller, use either of the following procedures:
Press Ctrl+M

1 Turn on the server and press Ctrl+M when prompted during system
bootup.

Note: The Ctrl+M utility can take up to 1 minute to launch with
1L37 firmware. The system can appear frozen. Do not reset.

2 Select Objects menu → Adapter → Other Adapter Information.

3 Review the information on the screen. The LSI320-1 controller
firmware must be 1L37.

—End—

Step Action

Launch MegaRAID Power Console Plus

1 Launch the MegaRAID client by clicking Start > Programs> Power
Console Plus > Launch Client.

2 From the MegaRAID Power Console Plus - Server Selection window,
select Access Mode > Full Access to view or change configuration
information and click OK.
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3 From the MegaRAID console, choose Adapter > Properties.

4 Review the information on the screen. The LSI320-1 controller
firmware must be 1L37.

If the firmware is not correct, perform a firmware update. For
instructions, see "To upgrade or downgrade the RAID firmware"
(page 95).

—End—

ATTENTION
Perform the following procedure only if the firmware version is not the version
identified in this section.

To upgrade or downgrade the RAID firmware

Step Action

The firmware of the RAID card is upgraded through a flash process. The
flash process is initiated by running the RAID card firmware update utility
on the CallPilot DVD.

1 Insert the CallPilot Image DVD for the platform into the DVD combo
drive.

2 Power down the CallPilot server.

3 Restart the CallPilot server.

Result: The server boots from the DVD and the Startup Menu
appears.
1.Install CallPilot 5.0 1005r server image and exit to
DOS (recommended).
2.Install CallPilot 5.0 1005r server image and exit to
DOS (FACTORY ONLY).
3.Utilities (BIOS, Firmware, etc...)

4 Enter 3 and press Enter to run Utilities (BIOS, Firmware, etc...) from
the Startup.

Result: The Nortel CallPilot Image Menu appears.
1.1005r server BIOS update
2.1005r server FRU/SDR firmware update
3.1005r server Board Management Controller (BMC)
firmware update
4.LSI320-1 RAID controller firmware update
5.1005r system Utilities and SEL Viewer
6.Go to DOS
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5 Enter 4 to run the LSI320-1 RAID card firmware update from the
Nortel CallPilot Image Menu.

Result: The system prompts you to confirm the RAID firmware
update.

6 Enter Y to confirm.

Result: The system displays the valid image for the RAID card
firmware update and asks the following:

Do you wish to continue (y/n)?

7 Type Y and press Enter.

Result: The system states that you are flashing the Firmware (it
displays the version), and asks the following:

Do you wish to continue (y/n)?

8 Type Y and press Enter.

Result: The Flash programming is performed. Once complete, the
system prompts for you to reboot the system.

9 Manually reboot the CallPilot 1005r.

Result: The system reboots and the Startup Menu appears.

10 Remove the DVD from the DVD combo Drive.

11 Restart the server.

—End—

Configuring RAID using LSI320-1 controller and Ctrl+M
The configuration of the RAID card is stored on both the card and the hard
drive. Typically you are not required to reconfigure RAID unless you are
making a change to the RAID system (for example, if you replace the hard
drives with higher capacity hard drives).

CAUTION
Risk of data loss
This procedure requires that the logical drive be initialized. When
you initialize the logical drive, all data on the hard drives is erased.

Do not perform this procedure unless you are replacing the
hard drives or you are rebuilding the CallPilot system (that is,
reinstalling the Windows operating system and CallPilot software).
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To configure an LSI320-1 RAID system

Step Action

To configure RAID, do the following:

1 Turn on the server and press Ctrl+M when prompted during system
bootup.

Note: The Ctrl+M utility can take up to 1 minute to launch with
1L37 firmware. The system can appear frozen. Do not reset.

2 From the Management menu, select Objects and press Enter.

3 From the Objects menu, select Adapter and press Enter.

4 From the Adapter menu, select Factory Default and press Enter.

5 Select Yes to confirm the selection and press Enter.

Result: The system displays ForceBoot Option is Enabled Press
Any Key.

6 Press any key.

Result: The system displays BOOT Parameters Changed. Press
Ctrl-Alt-Delete to REBOOT.

7 Press Ctrl+Alt+Delete when prompted to restart system.

8 During bootup, press Ctrl+M to re-enter the RAID setup utility.

9 From the Management menu, select Objects → Adapter, and then
ensure the Adapter 1 values are set as follows:

FlexRAID PowerFail: Enabled
Fast Initialization: On
Disk Spin up Timings: 1 disk every 6 secs
Cache Flush Timings: Every 4 Seconds
Rebuild Rate: 30%
Alarm Control: Enabled (There is no audible alarm)
Other Adapter Options:
Emulation: Mass Storage
— Auto Rebuild: Disabled
— Initiator ID: 7
— Multiple PCI Delayed Trans: Disabled
— Force Boot: On
— Coercion Algorithm: 1GB-way
— CC Restoration: Enabled

Note: The Coercion Algorithm must be set properly. When
changed, it cannot be changed again without clearing the
configuration.
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10 From the Configure menu, select New Configuration. Click Yes
to proceed.

Result: The system displays the SCSI channel with two drives.
SCSI IDs are automatically assigned for each of the two drives. All
disk drives must be in READY state.

Note: Do not use the Load command on the Configure menu.
This command is not for RAID operations.

11 Create the logical drive by selecting Channel-1 A01-0 and pressing
the spacebar.

Result: The display changes to ONLIN A01-01.

12 Select A01-02 and press the Spacebar.

Note: The drives blink when you select them.

13 Press Enter to End the Array.

Result: The blinking stops.

14 Press F10 to configure the logical drive.

15 Press the spacebar to select Configuration Array.

Result: Span-1 appears in the box opened for the A01 logical drive.

16 Press F10 to configure the logical drive.

Result: The system prompts you for the logical drive to consecutively
select:

RAID 1;
Size: accept the size displayed
Accept
SPAN = NO

Change the last value to NOSPAN, if required.

17 Select Accept and press Enter to accept these new values.

Result: The system prompts you to save the configuration.

18 Select YES and press Enter.

Result: The configuration is saved. Press any key to continue.

19 Press ESC to exit the submenus.

20 In the Management menu, choose the Initialize submenu.

21 Press F2 to select the logical drive.

22 Press F10 and consecutively select YES to initialize the drive pack.
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23 When the initialization is complete, press any key to return to the
Management menu.

24 Press ESC to exit the utility. Select Yes and press Enter.

25 Press Ctrl+Alt+Delete as indicated by the menu to reboot.

—End—

Verifying consistency on the drives
This optional consistency check on the logical drive of the RAID system
ensures that the data on the drives is identical. If any errors are found,
they are corrected automatically. Nortel strongly recommends that you do
a consistency check before you split the RAID system pack. If possible,
perform the consistency check the day before the scheduled maintenance.
A good data backup on an offline drive is important if you need to revert to
the CallPilot system from an unsuccessful upgrade or update.

Note: The consistency check can take up to 2 hours to complete and
has no significant impact on system performance.

To perform a consistency check

Step Action

1 In Windows, click Start > Programs > Power Console Plus >
Launch Client.

Result: The MegaRAID Power Console Plus Server Selection
dialog box appears.

2 Ensure that Access Mode > Full Access is selected, and click OK.

Result: The MegaRAID Power Console Plus dialog box appears
displaying the Logical View of the Physical Devices and the Logical
Devices. The status bar at the bottom of the window indicates that
RAID channels are being scanned. When scanning is done, the
screen refreshes and the Physical and Logical Devices screen
appears.

3 In the Logical Devices section, right-click the logical drive, and then
choose Check Consistency from the shortcut menu.

Result: The Check Consistency status dialog box appears. You
are informed when the check is finished. If any errors are found, a
window with an error message appears.

4 Select Configuration > Exit to close the MegaRAID console.

Result: An end of session message appears.
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5 Click OK.

—End—

RAID splitting
Ensure that your system is in full working order and the RAID hardware
configuration is set up properly as described on "Configuring RAID using
LSI320-1 controller and Ctrl+M" (page 96).

Split the RAID before you install software upgrades (PEPs). If you are
performing a platform upgrade or migration, refer to the Upgrade and
Platform Migration Guide (NN44200-400) for complete instructions.

ATTENTION
As an extra precaution, Nortel recommends that you perform a full system backup
prior to performing a RAID-split. For more information about system backups,
see the CallPilot Manager online Help.

To split the RAID

Step Action

1 Load the MegaRAID console. Select Start > Programs > Power
Console Plus > Launch Client.

2 Ensure that Access Mode > Full Access is selected.

3 Click OK.

Result: The MegaRAID Power Console Plus window appears.

4 Ensure all drives are in ONLINE state (marked green).

5 In the Physical Devices section, right-click the first drive. The drives
are displayed as follows:

(0)A1-1-Onln

(1)A1-2-Onln

6 Select Tools → Fail Drive from the shortcut menu.

Result: A message appears advising that marking the online drive
Failed results in changes.

7 Ignore the warning and click OK. The drive status changes to FAILED
and the color of the icon changes to red (for example, A01-2-Failed).

At this point, the RAID is split, and the drive marked FAILED is the
backup drive and is no longer written to. You can install a PEP on
the system and use the backup drive to back out of the installation.
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ATTENTION
Do not make the failed drive online at this point, or data corruption can
occur. If you failed the wrong drive by mistake, you must select rebuild to
bring it back into service.

MegaRAID Power Console Plus drive status

—End—

RAID synchronization after installing a PEP
Resynchronize the RAID after you perform a software upgrade with a PEP.

To synchronize the RAID after a successful PEP installation

Step Action

To restore RAID to full service after a successful PEP installation:

1 Without shutting down the server, from Windows, click Start >
Programs > Power Console Plus > Launch Client.

Note: Ensure that Access Mode > Full Access is selected.

2 Click OK.

Result: The MegaRAID Power Console Plus window appears.

3 In the Physical Devices section, right-click the hard disk drive that
is marked FAILED.
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Example: A01-2-Failed.

ATTENTION
Do not make the failed drive online at this point, or data corruption can
occur. If you failed the wrong drive by mistake, you must select rebuild to
bring it back into service.

4 From the right mouse shortcut menu, select Rebuild.

Result: When the rebuild is complete, the drive status changes to
ONLINE and the color of the icon changes to green.

—End—

The process can take up to 1 hour. If the server reboots during the rebuild
process, the rebuild continues when the server restarts. However, a power
down or reboot is not recommended during the rebuild process.

To synchronize the RAID after an unsuccessful PEP installation

Step Action

If the PEP installation fails, you must return the system to the original
configuration.

ATTENTION
Do not use the Power Console for the following procedure, or data corruption
can occur.

1 Restart the server and enter the Ctrl+M utility when prompted during
system bootup.

2 From the Management menu, select Objects and press Enter.

3 Select Objects > Physical Drive and press Enter.

4 Select FAIL Drive for the drive that is online (A01-1-Onln).

Result: The drive shows as failed.

5 Select the second drive (previously taken offline as the backup
drive and marked failed) and make it ONLINE. Ignore the warning
message.

Result: The second drive is marked ONLINE and the first drive is
marked failed.

6 Exit the utility and press Ctrl+Alt+Delete to reboot the server.
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Result: The system boots up to the original configuration before
the PEP installation.

7 When the system is fully booted, open the Windows MegaRAID
console and rebuild the failed drive using the same process
described in "To synchronize the RAID after a successful PEP
installation" (page 101).

Result: The system is now in the original configuration.

—End—

Replacing the RAID card
The RAID card is in low-profile slot 1 (counting from the top down) of the
PCI riser assembly.

CAUTION
Risk of electrical damage

• Wear an antistatic ESD wrist strap when handling cards
or boards, or when working inside the server.

• Do not touch the components or gold-edge connectors
of cards or boards.

• Place the card on an antistatic surface until you are
ready to install it.

PCI add-in cards are not hot-swappable. You must power down the system
and remove the power cords before replacing the card.

CAUTION
Risk of physical equipment damage
Remove the 1005r from the rack, and place it on a solid surface
when replacing or adding cards. The PCI riser assembly requires
considerable force when inserting it into the connector, and
physical damage can result if the assembly is not properly aligned.

Placing the server on a solid surface such as a workbench gives
you a better view of the card alignment and lets you exert the
necessary force when inserting the assembly into the connector.

Requirements

• Phillips (cross head) screwdriver, #1 and #2 bit

• RAID card replacement kit
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• electrostatic discharge (ESD) grounding strap

To replace the RAID card

Step Action

1 Power down the server, unplug all peripheral devices and ethernet
cables, and disconnect the AC power.

2 Attach the ESD strap to your wrist and attach the other end to a
grounded connection away from the server.

3 Remove the chassis cover. Refer to "Removing and replacing the
server cover" (page 73) for instructions.

4 Disconnect the red power cable from the PCI riser assembly.

5 Disconnect the DS30X cable from the MPB96 card in the full-size
side of the PCI riser.

DS30X cables for high capacity

Note: If you have the high capacity configuration with three
MPB96 cards, label each cable with the MPB96 slot number
before disconnecting them. Incorrectly connected MPB96 cards
do not answer calls.

6 Disconnect the SCSI cable from the RAID card.
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SCSI cable to RAID card

7 Lift the blue tabs and pull up on the riser to remove the riser card
assembly from the chassis.

PCI riser card assembly
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8 Turn the riser card upside down and place it on a table.

Low-riser PCI card

9 Release the retention bar (A).

10 Replace the card (B).

11 Lock the retention bar in place.

12 Turn the PCI riser card right-side up and place it on a table.

13 Arrange the PCI riser assembly red power cable as shown in the
following illustration to avoid pinching the cable when you put the
riser assembly into the chassis.

PCI riser assembly power cord
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14 Reconnect the DS30X cable or cables to the MPB96 card or cards.
You must reconnect each cable to the same MPB96 card it was
previously connected to. Use the labels you applied.

15 Hold the PCI riser assembly by the two blue handles (A) and
push the assembly into the server board. Refer to "PCI riser card
assembly" (page 105).

16 Line up the two grooves on the back lip of the PCI riser assembly
with the pins on the rear panel as shown in the following illustration.

ATTENTION
If the PCI riser assembly is not fully seated, the server can malfunction.

PCI riser assembly rear grooves

17 Reconnect the PCI riser assembly power cord.

18 Reconnect the SCSI cable to the RAID card.

19 Replace the chassis cover.

20 Take the ESD strap off.

21 Power up the server and log on to Windows.

Result: The Windows New Hardware Found Wizard screen appears.

22 Click Next.

23 Select the presented driver.
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24 Check that the RAID firmware is version 1L37. Refer to "To verify the
RAID firmware version" (page 94).

25 Upgrade the RAID firmware, if required. Refer to "To upgrade or
downgrade the RAID firmware" (page 95).

26 Configure the new RAID card. Refer to "To configure an LSI320-1
RAID system" (page 97).

27 Test the system to ensure the new board is functioning properly.

For instructions, see "Testing the CallPilot installation" in the
Installation and Configuration Task List (NN44200-306).

—End—
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Chapter 10
Replacing or adding voice processing
boards

In this chapter

• "M1/CS1000 switch connectivity" (page 109)

• "Locating the voice processing boards" (page 110)

• "DSP numbering and location" (page 110)

• "Replacing an MPB96 board" (page 111)

• "Upgrading to high capacity" (page 119)

M1/CS1000 switch connectivity
There are two valid configurations for MPB96 boards with M1/CS1000
switch connectivity. The following table shows valid configurations.

MPB96 with M1/CS1000 switch

MPB96 boards Slot number Max. channels MPU

1 1 96 96

3 (high capacity) 1, 2, 3 192 288

Determine which configuration applies to your system.

ATTENTION
You must use one of the valid configurations for the system to function properly.

Taking safety precautions
Before you make any changes to the server hardware, follow these safety
precautions:

• Respect appropriate electrostatic discharge (ESD) rules.

• Power down the system.
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• Do not drop and leave screws inside the server.

• Do not drop hard objects (such as screwdrivers) inside the server as
this can damage the server.

Locating the voice processing boards
"1005r server rear panel" (page 110) shows the rear panel of the 1005r
server with the three full-height PCI card slots (C). The MPB96 voice
processing boards occupy one or three full-height slots. In the following
diagram, the card slots are numbered from 1 to 3 starting at the top.

1005r server rear panel

Refer to the 1005r Server Hardware Installation (NN44200-308) guide to
identify the other features on the 1005r rear panel.

DSP numbering and location
DSPs are the built-in voice processing components on MPB boards. DSPs
are numbered to distinguish them in CallPilot maintenance programs, such
as the Maintenance screen in CallPilot Manager. Each DSP supports up to
eight multimedia channels.

DSP numbering MPB96 boards
The MPB96 board has 12 embedded DSPs. MPC-8 cards are not required.
If an embedded DSP is faulty, you must replace the entire MPB96 board.
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MPB96 board

Replacing an MPB96 board
This section describes how to replace an MPB96 board.

You must replace an MPB96 board:

• if the board becomes faulty

• when the PCI firmware needs to be updated, and the board must be
sent back to the factory

CAUTION
Risk of electrical damage

• Wear an antistatic ESD wrist strap when handling cards
or boards, or when working inside the server.

• Do not touch the components or gold-edge connectors
of cards or boards.

• Place the board on an antistatic surface until you are
ready to install it.

MPB96 boards are not hot-swappable and you must power down the system
before replacing the cards.
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CAUTION
Risk of physical equipment damage
Remove the 1005r from the rack, and place it on a solid surface
when replacing or adding cards. The PCI riser assembly requires
considerable force when inserting it into the connector, and
physical damage can result if the assembly is not properly aligned.

Placing the server on a solid surface such as a workbench gives
you a better view of the card alignment and lets you exert the
necessary force when inserting the assembly into the connector.

Requirements

• Phillips (cross head) screwdriver, #1 and #2 bit

• MPB96 replacement board

• electrostatic discharge (ESD) grounding strap

To replace an MPB96 board

Step Action

1 Courtesy stop all CallPilot channels. Refer to "Starting and stopping
components" (page 51).

2 Power down the server, unplug all peripheral devices and ethernet
cables, and disconnect the AC power.

3 Attach the ESD strap to your wrist and attach the other end to a
known grounded connection.

4 Remove the chassis cover. Refer to "Removing and replacing the
server cover" (page 73) for instructions.

5 Disconnect the red power cable from the PCI riser assembly.

6 Disconnect the DS30X cable from the MPB96 card in the full-size
side of the PCI riser.
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DS30X cables for high capacity

Note: If you have the high capacity configuration with three
MPB96 cards, label each cable with the MPB96 slot number
before disconnecting. Incorrectly connected MPB96 cards do
not answer calls.

7 Disconnect the SCSI cable attached to the RAID card.

SCSI cable attached to RAID card

8 Lift the blue tabs and pull up on the riser to remove the riser card
assembly from the chassis.
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PCI riser card assembly

9 Turn the riser card upside down and place it on a table.

10 Disconnect the CT bus cable from the MPB96 cards (high capacity
configuration only).
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CT bus cable attached to MPB96 boards.

11 Release the retention clip by loosening the blue captive screw (A) as
shown in the following diagram.

Full-height PCI card
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12 Remove the rear retention screw (B) as shown in the previous
diagram.

13 Replace the card and tighten the screws. Make sure the red power
cable to the full-size PCI riser card is not pinched.

14 Reconnect the 3-drop CT bus cable (high capacity configuration
only).

15 Turn the PCI riser card right-side up.

16 Arrange the PCI riser assembly short red power cable inside the
riser assembly as shown in the following illustration to avoid pinching
the cable when you put the riser assembly into the chassis.

Full-size PCI riser card red power cable

17 Arrange the PCI riser assembly power cable as shown in the
following illustration.
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PCI riser assembly power cable

18 Line up the two grooves on the back lip of the PCI riser assembly
with the pins on the rear panel as shown in the following illustration.

19 Hold the PCI riser assembly by the two blue handles (A) and
push the assembly into the server board. Refer to "PCI riser card
assembly" (page 114).

ATTENTION
If the PCI riser assembly is not fully seated, the server can malfunction.
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PCI riser assembly rear studs and slots

20 Reconnect the DS30X cable or cables to the MPB96 card or cards.
You must reconnect each cable to the same MPB96 card it was
previously connected to. Use the labels you applied as a guide.

21 Replace the chassis cover.

22 Take the ESD strap off.

23 Power up the server and log on to Windows.

Result: The Windows New Hardware Found Wizard screen appears.

24 Click Next.

25 Select the presented Nortel MPB driver (there is only one).

26 Run the Configuration Wizard to configure the new hardware.

For instructions, see Meridian 1 and CallPilot Server Configuration
(NN44200-302) or CS1000 and CallPilot Server Configuration
(NN44200-312).

Result: The MPB96 board replacement is complete.

27 Test the multimedia channels to ensure the new MPB96 board is
functioning properly.

For instructions, see "Testing the CallPilot installation" in the
Installation and Configuration Task List (NN44200-306).
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—End—

Upgrading to high capacity
This section describes how to upgrade your server hardware to the high
capacity configuration. You need three MPB96 boards to support the high
capacity feature.

CAUTION
Risk of electrical damage

• Wear an antistatic ESD wrist strap when handling cards
or boards, or when working inside the server.

• Do not touch the components or gold-edge connectors
of cards or boards.

• Place the board on an antistatic surface until you are
ready to install it.

MPB96 boards are not hot-swappable and you must power down the system
before adding boards.

Requirements

• Phillips (cross head) screwdriver, #1 and #2 bit

• High capacity upgrade kit (includes two MPB96 boards, a CT bus cable,
and two DS30X cables)

To add two MPB96 boards

Step Action

1 Courtesy stop all CallPilot channels. Refer to "Starting and stopping
components" (page 51).

2 Power down the server, unplug all peripheral devices and ethernet
cables, and disconnect the AC power.

3 Attach the ESD strap to your wrist and attach the other end to a
known grounded connection.

4 Remove the chassis cover. Refer to "Removing and replacing the
server cover" (page 73) for instructions.

5 Disconnect the red power cable from the PCI riser assembly.
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6 Disconnect the DS30X cable from the MPB96 card in the full-size
side of the PCI riser. Mark the cable as number 1.

7 Disconnect the SCSI cable attached to the RAID card.

SCSI cable attached to RAID card

8 Lift the blue tabs and pull up on the riser to remove the riser card
assembly from the chassis.
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PCI riser card assembly

9 Turn the riser card upside down and place it on a table.

10 Release the retention clip by loosening the blue captive screw (A).

11 Remove the rear retention screw (B).

12 Add the new boards to slots 2 and 3. Tighten the retaining screws
(B). Make sure the red power cable is not pinched.
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Full-height PCI card

13 Connect the 3-drop CT bus cable to the MPB96 cards as shown in
the following illustration.

CT bus cable attached to MPB96 boards

14 Turn the PCI riser card right-side up.
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15 Arrange the PCI riser assembly red power cable inside the riser
assembly as shown in the following illustration to avoid pinching the
cable when you put the riser assembly into the chassis.

PCI riser assembly inside power cable

16 Arrange the PCI riser assembly long red power cable that plugs into
the short red cable as shown in the following illustration.

PCI riser assembly power cable

17 Line up the two grooves on the back lip of the PCI riser assembly
with the pins on the rear panel as shown in the following illustration.

18 Hold the PCI riser assembly by the two blue handles (A) and
push the assembly into the server board. Refer to "PCI riser card
assembly" (page 114).
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PCI riser assembly alignment studs and slots

19 Reconnect the PCI riser assembly power cord.

20 Reconnect the CT bus cable.

21 Connect the DS30X cables to the MPB96 cards as shown in the
following illustration. Start with the cable labeled 1 and connect it to
the MPB96 card in slot 1.

DS30X cables for high capacity

22 Replace the chassis cover.
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23 Take the ESD strap off.

24 Power up the server and log on to Windows.

Result: The Windows New Hardware Found Wizard screen appears.

25 Click Next.

26 Select the presented Nortel MPB driver (there is only one).

27 The Windows New Hardware Found Wizard screen appears again.

28 Click Next.

29 Select the presented Nortel MPB driver (there is only one).

If you are upgrading a pair of High Availability servers, do not
complete the next two steps. Return to the Procedure "Performing a
High Capacity upgrade".

30 Run the Configuration Wizard to configure the new hardware.

For instructions, see Meridian 1 and CallPilot Server Configuration
(NN44200-302) or CS1000 and CallPilot Server Configuration
(NN44200-312).

Result: The high capacity expansion is complete.

31 Test the multimedia channels to ensure the new MPB96 boards are
functioning properly.

For instructions, see "Testing the CallPilot installation" in the
Installation and Configuration Task List (NN44200-306).

—End—
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Chapter 11
Maintaining the BIOS and system board
firmware

In this chapter
"Configuring the 1005r BIOS and firmware" (page 127)

"BIOS settings" (page 130)

"Using system event logs" (page 132)

"Maintaining the onboard video and network cards" (page 135)

Configuring the 1005r BIOS and firmware
The Basic Input/Output System (BIOS) of your 1005r server is flash
ROM-based code. Upgrade or reconfigure the BIOS using the utilities on
the CallPilot Image DVD. The utility programs write updated code to the
Flash ROM chips. The following table shows the latest BIOS and firmware
versions.

BIOS and firmware versions

Description Version

System board BIOS 87

FRU/SDR Nortel customized based on Intel
FRU/SDR 6.55

BMC 0.50

Upgrading the BIOS and firmware is a four step process:

1. Boot off the Image DVD and display the Image Menu.

2. Update the BIOS firmware.

3. Update the FRU/SDR firmware.

4. Update the BMC firmware.
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ATTENTION
You must complete all steps in the correct order for your system to function
properly.

When to upgrade the BIOS

CAUTION
Risk of data loss
Perform this procedure only if specifically instructed to do so by
your Nortel representative.

The CallPilot server is shipped to you with the required minimum BIOS and
system board firmware versions. Upgrade the BIOS and system board
firmware only if your Nortel representative deems this necessary to solve a
system problem.

When to reconfigure the BIOS
The initial BIOS configuration is performed at the factory before the CallPilot
server is shipped to you. Reconfigure the BIOS only after you recover from
a BIOS or CMOS failure.

Requirements for upgrading or reconfiguring the BIOS

• CallPilot Image DVD

ATTENTION
You must have all of the hardware components of your system installed and
connected before you upgrade the firmware.

To display the Nortel CallPilot Image Menu

Step Action

1 Insert the CallPilot Image DVD for the platform into the DVD combo
drive.

2 Power down the CallPilot server.

3 Restart the CallPilot server.

Result: The server boots from the DVD and the Startup Menu
appears.
1.Install CallPilot 5.0 1005r server image and exit to
DOS (recommended)
2.Install CallPilot 5.0 1005r server image and exit to
DOS (FACTORY ONLY)
3.Utilities (BIOS, Firmware, etc...)
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4 Enter 3 to select Utilities (BIOS, Firmware, etc...) and
press Enter.

Result: The Nortel CallPilot Image Menu displays.
1.1005r server BIOS update
2.1005r server FRU/SDR firmware update
3.1005r server Board Management Controller (BMC)
firmware update
4.LSI320-1 RAID controller firmware update
5.1005r system Utilities and SEL Viewer
6.Goto DOS

—End—

To upgrade the BIOS and system board firmware

Step Action

1 Enter 1 to run 1005r server BIOS update from the Nortel CallPilot
Image Menu.

Result: The system prompts you to confirm the BIOS update.

2 Enter Y to confirm.

Result: The BIOS update progress appears with the following
message:
System will now reboot.
Press any key to continue...

3 Enter any key.

Result: The system reboots and the Startup Menu appears.

4 Enter 3 to run Utilities (BIOS, Firmware, etc...) from the Startup
Menu and press Enter. If the Startup Menu is not displayed, refer to
"To display the Nortel CallPilot Image Menu" (page 128).

5 Enter 2 to run 1005r server FRU/SDR firmware update from the
Nortel CallPilot Image Menu.

Result: The system prompts you to confirm the FRU/SDR update.

6 Enter Y to confirm.

Result: The FRU/SDR update progress dialog box appears with the
following message:
System will now reboot.
Press any key to continue...

7 Enter any key.
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Result: The system reboots and the Startup Menu appears.

8 Enter 3 to run Utilities (BIOS, Firmware, etc...) from the Startup
Menu and press Enter. If the Startup Menu is not displayed, refer to
"To display the Nortel CallPilot Image Menu" (page 128).

9 Enter 3 to run 1005r server Board Management Controller (BMC)
firmware update from the Nortel CallPilot Image Menu.

Result: The system prompts you to confirm the BMC update.

10 Enter Y to confirm.

Result: The BMC update progress dialog box appears with the
following message:
System will now reboot.
Press any key to continue...

11 Remove the Image DVD from the DVD combo drive and enter any
key.

Result: The system reboots.

12 The BIOS upgrade is complete.

—End—

BIOS settings
"BIOS settings" (page 130) displays the 1005r server BIOS settings. As the
system boots, press F2 to enter the 1005r BIOS. BIOS Settings that are in
bold text are settings that are modified by Nortel.

BIOS settings

Main Set the Date and the language to English

Processor Configuration Processor Re-test: Disabled
Max CPU ID Value Limit: Disabled
Hyper treading Technology: Enabled
HT Technology in MPS: ENABLED
Execute Disable Bit: Enabled
Hardware Prefetcher: Disabled
Adjacent Cache Line Prefetch:
Disabled

IDE Configuration Onboard P-ATA Channels:
PRIMARY
Onboard S-ATA Channels:
DISABLED
Primary IDE master: ATAPI CDROM
Primary IDE slave: Not Detected

Advanced
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Secondary IDE Slave: Not Detected
Third IDE Master: Not Detected
Fourth IDE master: Not Detected
Hard Disk write protection: Disabled
IDE Detect Time Out: 35 sec
ATA(PI) 80 pin Cable Detection:
Host&Device

Floppy Configuration Onboard FDD Disabled

Super I/O Configuration Serial Port Trimode:Mode1 BMC
Snoop
SIM Tri state: Disabled
Serial Port A Address: 3F8/IRQ4
Serial Port B Address: 2F8/IRQ3

USB Configuration USB Function: Enabled
Legacy USB Support: Auto
Post64/100 Emulation: Disabled
USB2.0 Controller: Enabled
USB2.0 Controller Mode: HiSpeed

PCI Configuration Onboard Video: Enabled
Dual Monitor Video: Disabled
Onboard NIC: Enabled
Onboard NIC1 ROM: Enabled
Onboard NIC2 ROM: Enabled
Onboard SCSI: Enabled
Onboard SCSI ROM: Enabled
Onboard SCSI Mode: IM/IME
PCI Priority Arbitration: Disabled
MMI/O Above4GB: Disabled

Memory Configuration DIMM 1A, 1B, 2A, 2B should be
installed
External Memory Test: Disabled
Memory Re-test: Disabled
Memory Re-Map feature: Enabled
Memory Mirroring/Sparring:
MIRRORING

Boot Settings Configuration Quick Boot: Enabled
Quiet Boot: DISABLED
Boot Up Num Lock: Off
PS2 Mouse Support: Auto
Post Error Pause: Enabled
Hit F2 message Display: Enabled
Scan User Flash Area: Disabled

Boot Device Priority CD/DVD
PCI Bus 03 Device 9 RAID Adapter

Boot

Nortel CallPilot
1005r Server Maintenance and Diagnostics

NN44200-704 01.05 Standard
5.0 26 April 2007

Copyright © 2007, Nortel Networks

.



132 Chapter 11 Maintaining the BIOS and system board firmware

Hard Disk Drives PCI Bus 03 Device 09 RAID Adapter

Removable Media There should be no removable media

ATAPI CD-ROM Drive Sony CD-ROM/DVD-ROM

Security All Features Disabled

This is a view only menu

Serial Power Console BIOS Redirection Port: Disabled
Baud Rate 19.2k
Flow Control: CTS/RTS
Terminal Type: VT100+
ACPI Redirection: Disabled
Serial Port Console: Serial B

Event Log Configuration Clear All Event Logs: Disabled
Clear event Log When Full: Disabled
BIOS Event Logging: Enabled
Critical Event Logging: Enabled
ECC Event Logging: Enabled
PCI Error Logging: Enabled
FSB Error Logging: Enabled
Hublink Error Logging: Enabled
Time Stamp clock sync Event:
Enabled

Power Management Features Wake On LAN (S5 Only): Enabled

Assert NMI on SERR: DISABLED

Assert NMI on PERR: Enabled

Resume on AC Power Loss: POWER
ON

FRB -2 Policy: Disable BSP

Late POST Timeout: Disabled

Hard Disk OS Boot Timeout: Disabled

PXE OSBoot Timeout: Disabled

OS Watchdog Timer policy: RESET

Server

Platform Event Filtering: Enabled

Using system event logs
The system event logs record all the hardware events that take place while
the system boots up and functions. You can view these logs even when the
system is not operational through the utilities on the CallPilot Image DVD.
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ATTENTION
This tool is only intended for use by authorized level 2 support personnel under
Nortel supervision.

The system event logs can only hold 2000 events and display a warning
message when full. You must clear the logs to turn off the warning message.
Refer to "To clear system event logs" (page 134).

Even if your system is not operational, you can save the system event logs
to an optional USB media drive. Your support representative can use the
logs to diagnose hardware faults. Refer to "To save system event logs to a
USB media drive" (page 134).

To view system event logs

Step Action

1 Boot from the CallPilot Image DVD and display the Nortel CallPilot
Image Menu that lists the utilities. Refer to "To display the Nortel
CallPilot Image Menu" (page 128).

2 Enter 5 to run the 1005r system utility and SEL viewer from the
Nortel CallPilot Image Menu.

3 Enter Y to confirm that you want to run the utility.

Result: The Intel GUI screen appears.

Note: The Intel GUI is not a Windows-based screen.

4 Click Continue.

5 Choose Server Configuration Utilities and click Continue.

6 Choose Run SEL Viewer Utility and click Continue.

Result: The SEL Viewer screen appears.

7 Use the arrow keys to scroll through the system events. The details
of the currently selected event appear on the bottom of the screen.

8 When you finish viewing events, select File > Exit from the menu bar.

Result: The Intel GUI appears.

9 Click Exit to close the GUI.

—End—
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To save system event logs to a USB media drive

Step Action

1 Connect a USB drive media to the USB port on the front of the
server.

2 Restart the server.

3 Display the SEL Viewer. Refer to "To view system event logs" (page
133).

4 Select File > Save as.

5 Enter the file name and destination (usually a:) to save the system
event logs to the USB media drive.

—End—

To clear system event logs

Step Action

1 Display the SEL Viewer. Refer to "To view system event logs" (page
133).

2 Select SEL > Clear SEL from the menu bar.

Result: The list of events is now empty.

3 After clicking Clear SEL, the system asks the following:

Are you sure you want to clear the SEL?

Select OK.

4 Select File > Exit from the menu bar.

Result: The Intel GUI appears.

5 Click Exit to close the GUI.

—End—

If you do not have the image DVD, you can clear the system event logs from
BIOS with the following procedure:

Step Action

1 Restart the PC, and press F2 when prompted.
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2 When the BIOS window appears, select Server > Event Log
configuration > Clear All Event Logs.

—End—

Maintaining the onboard video and network cards
Network card failure

The network cards are integrated into the server board. If the network cards
fail, you must replace the server.

Video card failure
The video card is integrated into the server board. If the video card fails,
you must replace the server.

Indicators for video card failure
If the monitor appears to be functioning but no display is visible, look for the
following indicators of video card malfunction:

• Brightness and contrast are set at normal level.

• The server is powered on, and one long beep is followed by two short
beeps.

• The DVD combo drive light goes on when the server is powered, but no
display is visible on the monitor.

• The DVD combo drive light comes on when you type dir D: and press
Enter, but no display is visible on the monitor.
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Index

A
alarm board

replacement of 89
Alarm Monitor 43
alarms

about 42, 43
investigating 43

alert icons, component states 50
application event log

definition 26
arp command 32

parameters and descriptions 33
running from Windows 33
syntax 32

B
bezel, front 73

removal of 72
replacement of 72

BIOS
requirements for upgrading 127

boot failure
CallPilot

what to do 24
Windows

what to do 23

C
call channels

disabling 46
working with 58, 59

CallPilot
utilities

Diagnostics Tool 61
PEP Maintenance 61, 63
Session Trace 64
System Monitor 62

CallPilot Manager
alarms

about 42, 43
investigating 43

alert icons, component states 50
Channel Monitor, using 46, 58, 59
Event Browser, using 44, 46
events

about 41, 44
investigating 45

fault management
alarm notification 42
event processing 41

Maintenance screen
Diagnostics section 48
General section 47
Maintenance section 48
purpose 46

Multimedia Monitor, using 46, 56, 58
CallPilot services

Channel Monitor tab 67
Channel Monitor tab 66

CallPilot services 67
critical 68

DS30X links pane in 68
DSP pane in 68

Channel Monitor, using 46, 58, 59
channels

call, working with 58, 59
disabling 46
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multimedia, working with 56, 58
chkdsk utility 36

parameters and descriptions 36
running from Windows 37
syntax 36

commands, TCP/IP
arp 32
ipconfig 29
nbtstat 34
netstat 35
ping 30
tracert 31

components
CallPilot Manager maintenance
activities 48
dependencies 42
diagnostics that can be run 54
diagnostics-eligible 54
list 47
replacing 14
states

Alert icons 50
description 49, 50
viewing 50

Courtesy stop, description 51
critical services, CallPilot 68

D
diagnostics

integrated
running 53, 54, 55
troubleshooting failures 54
when to run 53

last results
viewing 55, 56

TCP/IP 29
arp 32
ipconfig 29
nbtstat 34
netstat 35
ping 30
tracert 31

Diagnostics section, Maintenance screen 48
diagnostics tool

TCP/IP 29
Diagnostics Tool 61

diagram
rear panel

slot locations 12

E
Event Browser, using 44, 46
event log

application 26
security 26
system 26

event logs
types, description 26
viewing 26

events
about 41, 44
investigating 45

F
fan, hot-swap 80
fault management

alarm notification 42
event processing 41

Firmware revision
verifying 94

flashing the 95

G
General section, Maintenance screen 47

H
hardware problems, detecting 42

I
indicators 135
integrated diagnostics

running 54, 55
troubleshooting failures 54
when to run 53

ipconfig command 29
flags and descriptions 29
running from Windows 30
syntax 29

ipconfig default 29
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L
LED, non-illumination of 77
Legend/Help tab 69
location

MPB96 DSP 110
logs

event types
viewing 26

event, viewing 26

M
maintenance

activities by component 48
preparing for 14

Maintenance screen, CallPilot Manager
Diagnostics section 48
General section 47
Maintenance section 48
purpose 46

MPB96 board 110
replacing or adding 112, 119

multimedia channels, working with 56, 58
Multimedia Monitor, using 46, 56, 58

N
nbtstat command 34

parameters and descriptions 34
running from Windows 35
syntax 34

netstat command 35
parameters and descriptions 35
syntax 35

network card
failure 135

P
parts, obtaining replacement 14
PEP Maintenance utility 61, 63
ping command 30

parameters and descriptions 30
running from Windows 31
syntax 30

POST error codes and messages 21
POST message formats 20
power supply, hot-swap 76

Power-On Self-Test
See POST 19

R
RAID 93

upgrading 95
RAID system

configuring 97
Redundant Array of Independent Disks

(RAID) 93
replacement parts, obtaining 14

S
SCSI controller

error messages 21
security event log

definition 26
server cover 73

removal of 73
Session Trace utility 64
startup problems

what to do 23, 24
Stop, description 51
system event log

definition 26
System Info tab 69
System Monitor 62

Channel Monitor tab 66
Legend/Help tab 69
System Info tab 69

System Monitor utility 66
system utilities

System Monitor 66

T
TCP/IP diagnostics 29

arp 32
ipconfig 29
nbtstat 34
netstat 35
ping 30
tracert 31

tracert command 31
parameters and descriptions 32
running from Windows 32
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syntax 31

U
utilities

chkdsk 36
Diagnostics Tool 61
PEP Maintenance 61, 63
Session Trace 64
System Monitor 62, 66

V
video card, failure 135
viewing 26

W
Windows

viewing 26
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